7 Centrifugal loads and angular accelerations

7.1 Introduction

This example will look at essentially planar objects subjected to centrifugal loads. That is, loads due to angular
velocity and/or angular acceleration about an axis. The part under consideration is a spinning grid strainer that
rotates about a center axis perpendicular to its plane. The part has five symmetrical segments, of 72 degrees
each, and each segment has a set of slots that have mirror symmetry about a plane at 36 degrees. The
questions are: 1. Does a cyclic symmetric part, with respect to its spin axis, have a corresponding set of cyclic
displacements and stresses when subject to an angular velocity, w, about that axis? 2. Does it have the same
type of behavior when subjected to an angular acceleration?

To answer these questions you need to recall the acceleration kinematics of a point mass, dm = p dV, following
a circular path of radius r. In the radial direction there are usually two terms, r w” that always acts toward the
center and d’r/dt’ acting in the direction of change of the radial velocity. The latter term is zero when r is
constant, as on a rigid body. In the tangential direction there are also two components in general: r a acting in
the direction of a and a Coriolis term of 2 dr/dt w, in the direction of w if dr/dt is positive. Again the latter
term is zero for a rigid body. The remaining radial acceleration (r w?) always acts through the axis of rotation
(as a purely radial load), thus, it will have full cyclic symmetry. Angular acceleration always acts in the
tangential direction a rotating part, as it spins up or spins down. The worst case is often at a sudden stop
where a large angular velocity exists and a negative large angular acceleration is applied.

A part with angular acceleration is basically subjected to torsional or cantilever like loading about its axis of
rotation. To illustrate these concepts consider a cantilever beam rotating about an axis outside its left end.
The deformed shapes and stress levels for constant angular velocity were seen in Figure 3-24 through Figure
3-26. The angular acceleration results for a similar cantilever will be considered next. For a radial spoke, the
angular acceleration effect is similar to a transverse linearly increasing line load acting on a cantilever beam.
The transverse force would equal the mass per unit length of the spoke times the tangential acceleration,
f = pAra. Simple beam theory would thus predict an end deflection of v = 11malL*/120EI for a spoke
mass of m = pAL. The simple spoke model in Figure 7-2 agrees very closely with that deflection estimate.
The von Mises stress (Figure 7-2) shows a typical bending response about the radial centerline. An extension
of this model will be used to estimate the expected angular acceleration loading on the more geometric
complex part considered in the next section.
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Figure 7-1 Radial spoke under angular acceleration
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Figure 7-2 Von Mises stress in a spoke with angular acceleration about the left end

7.2 Building a segment geometry

The desired rotating spin_grid is shown in Figure 7-3. The part has a inner shaft hole diameter, and outermost
diameter of 1 inch and 4 inches, respectively. It has six curved slots % inch wide, symmetric about the 36
degree line, and end in a semi-circular arc that is 1/8 inch from the 0 degree line. The grid is 0.20 inches thick.

Figure 7-3 Full geometry and its one-fifth symmetry

Prepare a sketch in the top view with several radial and arc construction lines via:

1. Front=>Insert Sketch, build several construction lines for the center of the slots, the symmetry plane,
and an off-set horizontal line for the fillet centers. Add arcs, and line segments to close the shape.
Extrude, about the mid-plane, to the specified thickness.

m\ww dﬂm

2. Define the axis of rotation. In this case it’s the axis of the inner circular hole. Use Insert->Reference
Geometry—>Axis to open the Axis panel. In the Axis panel check Cylindrical/Conical Face and select
the inner-most cylindrical surface segment of the part and Axis 1 will be defined as a reference
geometry entity.
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At this point the smallest geometrical region is complete and you can move on the SW Simulation Feature
Manager to conduct the deflection and stress analysis.

7.3 |Initial SW Simulation angular velocity model

7.3.1 Analysis type and material choice

To open a centrifugal analysis you have to decide if it is classified as static, vibration, or something else.
Instead of applying Newton’s second law, F = m a, for a dynamic formulation (where is F the resultant external
force vector and is a the acceleration vector of mass m), D’Alembert’s principle is invoked to use a static
formulation of F — F, = 0, where the inertia force magnitude is £, = m r w’ in the radial direction and/or m r a in
the tangential direction. That is, we reverse the acceleration terms and treat it as a static problem. Since this
part has symmetry in the radial and circumferential directions, the angular velocity case can be obtained with
the smaller 36 degree segment. In SW Simulation:

1. Right click on the Part_name->Study, Name the part (spin_grid here), pick Static analysis. The study
defaults to solid elements. (A planar model is almost always the cheapest and fastest way to do initial
studies of a constant thickness part.)

2. When the Study Menu appears right click on Solid—> Edit/Define Material.

3. In the Material panel pick Library->Steel>Cast Alloy. Select Units>English. Note that the yield
stress, SIGYLD, is about 35e3 psi. That material property will be compared to the von Mises Stress
failure criterion later. (The mass density, DENS, is actually weight density, y = pg, and is mislabeled.)

Name: ICastAIIDy Steel

Description: I

Source: I

Erﬁfeariualtnf.allure IMED( won Mises Stress LI
FProperty Yalue |Units |Temp Dependency
Elastic modulus 2755717007 psi Constant
Foizson's ratio 0.26 A, Constant
Shear modulus 11312943.54 psi Constant
tass density 02637232765 lhfin™3 Constant
Tensile strength 64988.87212 psi Constant
Compressive strength psi Constant
“ield strength 34994.00918 psi Constant

Draft 10.2 Copyright 2009. All rights reserved. 120



Centrifugal loads and angular accelerations J.E. Akin

7.3.2 Displacement restraints for angular velocity load

For the centrifugal load due to the angular velocity only the spoke center plane and slots center plane always
move in a radial direction. That means that they have no tangential displacement (that is, no displacement
normal to those two flat radial planes). In the Manager menu:

1. Select Fixtures to activate the first Fixture panel. Pick Advanced->Symmetry as the Type and select

the part face in the O degree plane. That sets the normal displacement component to zero. Preview
the restraints, then click OK.

Advanced(Symmeiry) # :
@ symmery [Semmeiry ]|

(®| Circular Symmetry

Use Reference Geometry

Yy

On Flat Faces
On Cylindrical Faces

On Spherical Faces

2. Repeat that process and select all seven of the part flat faces lying in the 36 degree plane (above).

0@V @@

At this point a total of eight surfaces are required to have only radial displacements. Either of the above two
restraint operations eliminates a possible rigid body rotation about the axis of rotation. The inner arc of the
grid is assumed to be force fit bonded to the shaft in the circumferential direction. Use
Fixtures=>Advanced—>On Cylindrical Faces—=> Circumferential.

Advanced(On Cylindrical #
Faces)

Symmetry

Circular Symmetry

On Cylindrical Faces: _|
Circurmferential {rad); [0

Use Reference Geometry

Py

On Flat Faces
On Cylindrical Faces

On Spherical Faces

I

cg@L o=

To prevent a rigid body translation of the part in the direction parallel to the axis you should also at least
restrain the cylindrical shaft contact surface in that direction as well. An alternative, for this loading, is to use
symmetry of the front or back face of the part.

1. Select Fixtures to activate the first Fixture panel. Pick Advanced—->Symmetry, select the inter-most
cylindrical surface.
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2. Select another color for the restraints present to just avoid RBM.

Advanced(Symmetry) “

@ Symmetry

l@] Circular Symmetry <\
)| Use Reference Geometry
@) 3 [Syrmmetry: | |

|E| On Cylindrical Faces (\ Q \
|Q| On Spherical Faces
@ Face<1:= i \ \

Symbol Settings A
[

7.3.3 Angular velocity loading

[Cj| On Flat Faces

Next you set the centrifugal body force loads due to the angular velocity. That will require picking the
rotational axis so select View—>Axes first and then:

1. Right click External Loads—> Centrifugal to activate the Centrifugal panel.
2. There pick Axis 1, set rpm as the Units and type in 1,000 rom for the angular velocity.

Centrifugal e | =% spin_grid
o B

Angular Welocity (rpm:

Selected Reference A Angular Acceleration (rpm®2):
T [ C—
Centrifugal Force A
B [metic (6) ~|
& mrpm ,
[~ Reverse direction ‘fl\;q

The radial acceleration, a, = r w?, varies linearly with distance from the axis, so expect the biggest loads to act
on the outer rim. Also remember that the radial acceleration is also proportional to the square of the angular
velocity. Thus, after this analysis if you want to reduce the stresses by a factor 4 you cut the angular velocity in
half. (You would not have to repeat the analysis; just note the scaling in your written discussion. But you can
re-run the study to make a pretty picture for the boss.)

7.3.4 Mesh generation

For this preliminary study each curved ring segment will act similar to straight fixed-fixed beam of the same
length under a transverse gravity load. (To know about what your answers should be from SW Simulation, do
that simple beam theory hand calculation to estimate the relative deflection at the center as well as the center
and end section stresses.) Thus, bending stresses may concentrate near the ends so make the mesh smaller
there:
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1. Right click Mesh—> Apply Control to activate the Mesh Control panel.
2. There pick the six bottom arc faces as the Selected Entities and specify an element size.
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4. Start the equation solver by right clicking on the study name and selecting Run. When completed
review the results.

7.3.5 Post-processing review

Both the displacements and stresses should always be checked for reasonableness. Sometimes the stresses
depend only on the shape of the material. The deflections always depend on the material properties. Some
tight tolerance mechanical designs (or building codes) place limits on the deflection values. SW Simulation
deflection values can be exported back to SolidWorks, along with the mesh model, so that an interference

study can be done in SolidWorks.

7.3.5.1 Displacements
You should always see if the displacements look reasonable:

1. Double click on Results=>Define Displacement Plot to see their default display, which is a continuous
color contour format. Such a pretty picture is often handy to have in a report to the boss, but the
author believes that more useful information is conveyed with the discrete band contours.

2. Right click on Plot 1> Settings—> Fringe Options—> Discrete. The default deformed shape displacement
contours appear.
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3. Since displacements are vector quantities you convey the most accurate information with vector plots.
Right click Plot1; Edit Definition->Advanced - Show as a vector plot.
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4. When the vector plot appears, dynamically control it with Vector Plot Options and increase Size. Then
dynamically vary the Density (of nodes displayed) to see different various nodes and their vectors
displayed. Retain the one or two plots that are most informative.

As expected, the center of the outer-most rim has the largest displacement while the smallest
displacement occurs along the radial “spoke” centered on the 0 degree plane. You may want to compare
the relative displacement of the outer ring to a handbook approximation in order to validate the computed
displacement results (and your knowledge of SW Simulation). Localized information about selected
displacements at nodes or lines are also available. For problems with angular velocity or angular
accelerations you should also view the displacements in cylindrical coordinate components. For that use:

1. Edit Definition>Advanced and select axis-1 from the part tree. Then the part’s radial displacement
component will be displayed as UX.

Displacemer .

« ¥ 42

Display A
& IUX: X Displacement j
Fl in ~]
Advanced Options 2
& [ [axist
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2. Right click in the graphics area and select Probe. That lets you pick any set of nodes in the mesh and
display their resultant displacement value and location on the plot, as well as listing them (above).

3. The probe operation is usually easier if you display the mesh first with Settings=>Boundary Options
2> Mesh. Using the support and center points in Figure 7-4 as probe points you find a relative
displacement difference of about 1.65e-5 inches. That can be compared to a fixed-fixed uniformly
loaded beam mid-span deflection estimate.
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Figure 7-4 Outer ring radial displacements (UX) at the symmetry planes

7.3.5.2 Stress results

All of the physical stress components are available for display, as well as various stress failure criteria. The
proper choice of a failure criterion is material dependent, and it is the user’s responsibility to know which one
is most valid for a particular material. The so called Effective Stress (actually distortional energy), or von Mises
stress, value is often used for ductile materials.

7.3.5.3 Effective stress

The von Mises failure criterion (a scalar quantity) is superimposed on the deformed -Figure 7-5-
- color contours. Also Chart Options=>Color Options was used to select only eight colors. The
maximum effective stress is only about 290 psi, compared to a yield stress of about 35,000 psi. That is a ratio
of about 134. Since the centrifugal load varies with the square of the angular velocity you would have to
increase the current w by the square root of that ratio (about 11.5). In other words you should expect yielding
to occur at w=11.5 (1000 rpom) = 11,500 rpm.

Since this is a linear analysis problem, it would not be necessary to repeat the run with that new angular
velocity. You could simply scale both the displacements and the stresses by the appropriate constant.
However, if you have a fast computer you may want to do so in order to include your most accurate plots in
your written summary of the analysis.
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Figure 7-5 The von Mises failure criterion and deformed shape due to angular velocity

7.3.5.4 Principal stresses

The magnitude and direction of the maximum principal stress P1 is informative (and critical for brittle
materials). Since they are vector quantities they give a good visual check of the directions of the stress flow,

especially in planar studies (they can be quite messy in 3-D):

1. Right click in the graphics area, select Edit Description then pick P1 Maximum Principal Stress, and
Vector style and view the whole mesh again.

2. |If the arrows are too small (look like dots) zoom in where they seem biggest and further enhance you
plot with a right click in the graphics area, select Vector Plot Options and increase the vector size, and
reduce the percentage of nodes used for the vector plot. A typical P1 plot, with the deformed shape,
is given in Figure 7-6 for the outermost ring junction with the radial spoke.
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Figure 7-6 Principal stress P1 at outer ring, due to angular velocity

7.3.6 Factor of safety

For this material you would use the von Mises effective stress failure criterion. That is, your factor of safety is

defined as the yield stress divided by the maximum effective stress.

greater than ten in this preliminary study.

It was noted above that the ratio is
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7.4 Angular acceleration model

The previous model considered only constant angular velocity, w, so the angular acceleration was zero. During
start and stop transitions both will present and the two effects can be superimposed because this is a linear
analysis. Next consider the initial angular acceleration (where w = 0 for an instant). You can always use the full
model, but that takes a lot of computer resources. The most efficient symmetric analysis would require using
any 72 degree segment and invoking a special restraint know as circular symmetry, or multiple point
constraints or repeated freedoms for nodes on those to edges. That means we know the two edges have the
same displacement components normal and tangential to the edges, but they are still unknowns.

7.4.1 Angular acceleration Loads

You need to identify the axis and angular acceleration value. First, turn on the axes with View—>Axes. Then
select External Loads—> Centrifugal and pick Axis 1 in the Centrifugal panel and type in the value of the angular
acceleration (Figure 7-7).

entrifuga % Spin_grid

& R
Selected Reference A
D [t
Angular Welocity (rpm): 0
Centrifugal Force Py Angular Acceleration (rpm®d): | 1e-+H108
Bl [metric (G) |

& IU 'lrpm

[T Reverse direction

& [1e+006 = rpm~2

Figure 7-7 Angular acceleration (only) about the center axis

7.4.2 Approximate cyclic symmetry restraints

Rather than conducting a larger cyclic symmetry model at this stage, you can get a smaller model first
approximation by assuming that the Poisson ratio effects can be neglected. Then symmetry planes of the
model will have no radial displacement, just tangential displacement due to the tangential acceleration (ra).
Apply that approach with the previous 36 degree segment with two symmetry planes. Remember to prevent
the rigid body motions of rotation about the axis and translation along the axis. First apply zero radial
displacement on the two symmetry planes from the Manager menu via Fixtures. To prevent the two rigid
body rotations select the inner cylindrical surface and impose displacement restraints in the axial and
circumferential direction, as shown in Figure 7-8 .

7.4.3 Mesh generation and solution

Here you can simply use the same meshing process given above.
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Figure 7-8 Invoking zero radial displacements and preventing RBM to approximate cyclic symmetry
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7.5 Post-processing approximate restraint results

7.5.1 Displacements for approximate cyclic restraints

The displacements, of Figure 7-9, are mainly in the tangential direction. To obtain the plots in polar
components, use Edit Definition=> UY->Advanced-> Axis-1->0K. The graph, along the bottom edge, of the
circumferential deflection will be compared to the larger formal cyclic symmetry study presented next.
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Figure 7-9 Circumferential displacements for approximate cyclic restraints
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Figure 7-10 Radial displacements for approximate cyclic restraints
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7.5.2 Stress results for approximate restraints

The effective stresses (Figure 7-11) are quite low, for the current angular acceleration value. Increasing the
angular acceleration by a factor of about 25 would put the stress just below the yield point. The maximum
stresses occur around the innermost slot. Figure 7-12 shows that the maximum tension (principal stress P1)
occurs on the lower right edge of the first grove. Both the maximum compression and shear occur in the lower
left (red) regions of Figure 7-13.
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Figure 7-12 Maximum principal stress vectors and values around slot base for approximate restraint

You should expect the maximum shear stress (Figure 7-13) to occur near there also. The (reaction) torque
necessary to accomplish the specified angular acceleration is transmitted radially by the spokes. The ribs can
be viewed as similar to lumped masses attached to a cantilever spoke. As you move from the outer rib toward
the rotation axis you are picking up more mass, and you get the maximum torque by the inner hole. That
torque is transmitted by shear stresses here. The first open gap has the largest torque going through the
spoke thickness.
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Figure 7-13 Twice the maximum shear stress for approximate cyclic restraints

7.6 Cyclic symmetry model

The above studies show that you can often pick symmetry regions in rotational loadings and drastically reduce
the computer resources required. Here it seems like you could refine the outer spoke mesh further to see
worst angular velocity effects and refine the innermost gap ends to see the worst angular acceleration effects.
Actually, the full model can be replaced by the 72 degree segment using the SW Simulation cyclic (circular)
symmetry boundary condition.

The automation of a cyclic symmetry analysis requires that the software can express the degrees of freedom in
terms of changing coordinate systems established tangential and normal to the repeated surface of cyclic
symmetry. That is illustrated in Figure 7-14 (left) where the top view of a cyclic symmetry impeller solid shows
some of the pairs of tangential and normal displacements that have to be established and coupled by the
analysis software. SW Simulation includes this ability to impose that the normal and tangential displacements
on the two limiting surfaces are the same, even though initially unknown. That figure shows that the limiting
surfaces do not have to be flat (as in the current example). A similar impeller solid body with cyclic symmetry
appears in Figure 7-15. Out of plane body parts there would be more influenced by angular acceleration.

Figure 7-14 An impeller well suited for cyclic symmetry analysis
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Figure 7-15 An impeller solid with 16 segments of cyclic symmetry

7.6.1 Mirroring the part for the circular symmetry geometry

Continuing from the 36 degree segment, use Insert->Pattern/Mirror->Mirror to open the Mirror panel.
Select the previous part as the Features to Mirror and pick one of the free ring faces as the Mirror Plane, OK.

BT

& R

b3

Mirror FacefPlane

Ij] ‘Face<:1:= ‘

b3

Features to Mirror

# Segment_18-degree

You could pick any 72 degree segment of the part as the cyclic symmetry geometry, but the above choice
seemed most logical.

7.6.2 Proper cyclic symmetry restraints

In this case the two limiting surfaces, having the same unknown displacements, are flat radial planes. To
invoke circular symmetry use Fixtures—>Advanced-> Circular Symmetry to open the Circular Symmetry Panel.
There pick Axis-1 as the common axis for the cyclic symmetry innermost inner edges, pick one face, and then
pick that face’s revolved location as the second face, OK. The SW Simulation will automatically establish
matching meshes on those two faces and create normal and tangential coordinates at each node on those two
faces (like in Figure 7-14). While you see two different nodes at corresponding points on those surface meshes,
you should think of them as a single node having normal, and tangential displacement components to be
determined by the specific loading conditions.
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7.6.3 Shaft restraints

The angular acceleration in this example is input by its fixation to the outer surface of the center shaft (not
shown). That would usually be accomplished by a shrink fit, which would also prevent rigid body motion in the
axial direction of the shaft. Apply those restraints with Fixtures=>Advanced->On Cylindrical Faces.

— o [ [on Cylindrical Faces: | |
@ On Cylindrical Faces Gircurnferential {rad): |0
|Q| On Spherical Faces
5 Face<3>
IS - |
=g |

7.6.4 Preventing rigid body motion

Py

The restraints described above would prevent the six possible rigid body motions. In this case, since the part is
flat there will be no axial displacements. Thus, you can reduce the number of unknowns to be solved, and
better stabilize an iterative solver, by alternately preventing the z-axis RBM by treating the top face as a
symmetry plane. Change the symbol colors to remind yourself that it is more an efficiency restraint as well as
restraint against RBM. Use Fixtures—> Advanced-> Symmetry.
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7.6.5 Mesh generation

Here you generate solid elements in the full 72 degree segment.
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7.6.6 Solution method

The fast iterative solver has worked for crude cyclic symmetry meshes; however it failed for practical mesh
sizes. The direct sparse solver is better suited to problems with multipoint constraints, like circular symmetry.
It takes much longer to run and requires more memory and disk space but is most likely to yield an accurate
solution. The results were obtained with it. They will be compared to the approximate validation predictions

from the previous discussions.

7.6.7 Cylindrical component displacements

Once again, it is logical to present the displacements in terms of their radial (UX) and circumferential (UY)
values (the axial UZ values are essentially zero). The amplified deformed cyclic symmetry shape is given in
Figure 7-16. That figure also shows the color levels for the magnitude of the main circumferential
displacement values. To verify that the circular symmetry solve has indeed computer the same displacements
on the two limiting surfaces the circumferential values are graphed along the zero and 72 degree line
segments. The graphs, in Figure 7-17 , are compared with the approximation given above as a validation result.

The agreement is surprisingly good.
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The radial displacements, for angular acceleration only, are about a factor of ten times smaller. Their
amplitudes are shown in Figure 7-18. The radial displacements along the outer arc are graphed on the left in
Figure 7-19 and are compared with the half model approximation on the right of that figure. Here, the radial
displacements are anti-symmetric about the middle 36 degree line.
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Figure 7-16 Amplified deformed shape, with circumferential displacement colors
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Figure 7-17 Cyclic symmetry UY values at 0 and 72 degrees (top) compared with approximate validation
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Figure 7-18 The radial displacements, UX, are about ten times smaller than UY
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Figure 7-19 Outer arc radial deflection, UX, compared to (half) validation estimate on the right

7.6.8 Possible failure criteria

The von Mises stress is always positive so it shows symmetric distributions (Figure 7-20) under this angular
acceleration loads. The levels are quite low and would not govern when compared to the angular velocity
results. The maximum principal normal stress, P1, is also quite small, as seen in Figure 7-21. The maximum
shear stresses are given in Figure 7-22 and they are also small. All of these possible material failure criterions
are directly proportional to the angular acceleration value. They are also within about 20% of the approximate
validation estimates given above. That is unusually good agreement.

von Mises (psi)
1000.0
l 875.0
. 7500
B25.0

l s00.0

. 3780

Max. 1274.0 \

2500

1260 \
nn - _ax. 1274.0

Figure 7-20 Cyclic symmetry von Mises stress from angular acceleration
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Figure 7-22 Twice the maximum shear stress is symmetric for cyclic symmetry restraints

7.7 Full part model

If you failed to recognize the above cyclic symmetry cases then you might be forced to employ a full part
model. To do that you must first build the full part. An efficient approach would be to use a fine mesh in one
repeating segment while having a very coarse mesh elsewhere, as seen in Figure 7-23.
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Figure 7-23 Overlooking cyclic symmetry requires solving much larger problems

Draft 10.2 Copyright 2009. All rights reserved. 138



