
 

STAR*NET V6 

Least Squares Survey Adjustment Package 
Ten-Station Demonstration Program 

 

 

 

A Tour of 

STAR*NET 
 

Illustrating 
Standard, Plus, Pro & Lev Edition Features 

 

 

 

 

 

STARPLUS SOFTWARE, INC. 
460 Boulevard Way, Oakland, CA 94610 

510-653-4836 
 

 



 

 

 

 



 

TOUR OF THE STAR*NET PACKAGE 

Overview 

The STAR*NET suite of programs perform rigorous least squares adjustments of survey 
networks. The Standard Edition handles 2D and 3D networks containing conventional 
terrestrial observations. The LEV edition handles 1D differential level networks only. 
The PLUS edition includes Standard Edition features plus the differential level network 
features of the LEV edition. The high-end PRO edition adds the handling of GPS vectors 
and full support for geoid and vertical deflection modeling. The software is menu driven 
and allows you to edit your input data, run your adjustment and view the processing 
results, both graphically and in a listing report, all from within the program. 

STAR*NET  is ideal for the adjustment of traditional interconnected traverse networks. 
It is equally suited to the analysis of data sets for establishing control for close-range 
photogrammetry and structural deformation monitoring.  

This tutorial includes examples designed to acquaint you with the general capabilities of 
the STAR*NET suite. It contains the following: 

 STAR*NET Demo Program Installation Instructions. 

 Example 1:  Two dimensional traverse network. This example shows you the basic 
features of STAR*NET, and lets you run an adjustment and view the output results 
in both listing and graphical formats. 

 Example 2:  Combined triangulation/trilateration network. 

 Example 3:  Three dimensional traverse network. 

 Example 4:  Same three dimensional network, but processed as a grid job. 

 Example 5:  Resection. 

 Example 6:  Traverse with sideshots. 

 Example 7:  Preanalysis of a network. 

 Example 8:  Simple GPS network (STAR*NET-PRO edition). 

 Example 9:  Combining conventional observations and GPS vectors (PRO edition). 

 Example 10: Differential leveling network (PRO, PLUS & LEV editions). 

 Supplemental information. Some extra details are included if you want to try out 
additional STAR*NET features on your own using the demo program. 
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In this tutorial, we will go through the same sequence of operations that you would 
normally follow when creating and adjusting a survey network – but in these examples, 
we will be just reviewing options and data, not setting options and creating new data. 
The normal sequence of operations one goes through in adjusting a survey project is the 
following: set project options, create input data, run an adjustment, review results 
including viewing both an adjusted network plot and an output listing report. 

The demo program is a fully functional version of STAR*NET. It includes all the 
capabilities of the STAR*NET-PRO edition, except that it is limited to an adjustment of 
10 stations, 100 observations and 15 GPS vectors.  

Note that this tutorial documentation is not designed to be an operating manual. It is 
intended only as a guide to the use of the demo program. A complete, fully detailed  
manual is provided with purchase of STAR*NET. To order the program, or if you have 
questions about its use, please contact: 

STARPLUS SOFTWARE, INC. 
460 Boulevard Way, Oakland, CA 94610 
800-446-7848 sales and product information 
510-653-4836 
510-653-2727 (Fax) 
Email: starplus@earthlink.net      
 

Installing the STAR*NET Demo Program 

If you received a CD, insert the CD in your drive and go to Step 1.  

If you downloaded (or were emailed) a single-file install program, simply double-click 
the file in explorer to start the installation, and go directly to Step 3. 

1. From the Windows taskbar, select Start>Run. The Run windows appears. 
 
2. In the Open field, type “D:\SETUP”, substituting the letter of the CD drive you are 

using if it is other than drive “D”. Select OK. 
 
3. Follow the installer instructions. Note that you can accept the default destination 

folder named “C:\Program Files\Starplus\StarNet-Demo” or choose a different 
destination folder by browsing.  

 
If you choose to a different installation destination, we encourage you to create a 
separate folder just for the demo, not one already containing other programs from 
Starplus Software or other companies, to eliminate the possibility of conflicts. 

 
4. After installing, press the Windows “Start” button, select Programs>Starplus, and 

then click the “StarNet Demo” selection to run the STAR*NET demo program. 
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Example projects provided for this tutorial are located in a subfolder of your install 
directory named “Examples.” Therefore: 

 If you installed the demo in “C:\Program Files\Starplus\StarNet-Demo,”  then, 
 
 The example projects are in “C:\Program Files\Starplus\StarNet-Demo\Examples.” 

 
Each sample project consists of a “Project” file (a file with a “prj” extension) and at least 
one “Data” file (a file with a “dat” extension). An existing project is opened by selecting 
its “prj” file from the Open Existing Project dialog. 

The “Project” file contains all the option settings for a project such as whether it is a 2D 
or 3D job, a local or grid job, all instrument standard error settings, and much more 
information. The project file also includes a list of all data files that are considered part 
of the project. All options are preset for these sample projects, so you can simply review 
them and not be concerned about setting or changing any yourself. 

All “Data” files used in STAR*NET are simple text files that may be prepared within the 
program or external to the program using any text editor. All of the input data files for 
the sample projects are provided, with full comments, to help you get an idea of how to 
use STAR*NET to handle your adjustment problems. It is not required that you edit any 
of these sample data files when running the sample projects. 

In the following examples in this tour, the instructions simply ask you to open a named 
project. Choose File>Open Project, or press the Open tool button, and the following 
dialog will appear allowing you to open one of the existing example projects.  

 

If for some reason the example projects as shown above do not appear, browse to the 
folder you installed the STAR*NET demo, open the sub-folder named “Examples” and 
you will find them there.  

Note! For the sake of simplicity in this tutorial, the dialogs that show the path of the 
example projects will indicate that the “Starplus” directory exists right at the root. 
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Example 1: Two Dimensional Traverse Network 

The first example project demonstrates the functioning of STAR*NET's main menu 
system. You will run an adjustment for a project, then view the results in both graphical 
and listing formats. After running this example, you should have a basic understanding 
of how the program works. Later examples will show more data types and go into more 
detail about program options. (Comments following the # character are ignored.) 

 
 
   # 2D Job with Multi-Loop Traverses 
    
   C    1     5045.572   5495.338  ! !  # fixed coordinates 
   C    6     5000       5190           # approximate coordinates 
    
   TB   6  # traverse backsight to point 6 
   T    1       99-47-25   205.03 
   T    2      115-10-00   134.19 
   T    3       94-51-53   105.44 
   T    4      216-46-09   161.57 'Existing post 
   T    5      106-26-42   160.71 'Iron pipe 
   T    6       86-57-49   308.30 
   TE   1  # end this loop at Point 1 
    
   TB   2  # traverse backsight to point 2 
   T    3      225-47-02   115.41 
   T    7       97-31-36   284.40 
   T    8      115-14-57   191.66 
   T    9      156-15-44   166.90 
   M    9-8-5   83-45-28   161.95  # add a tie-in course to 5 
   T    10     106-12-32   151.34 
   TE   6      164-00-42    1      # end at 6, turn angle into 1  
    
   B    8-7   n79-52-31e  !  # fixed bearing 
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1. Run STAR*NET and open the “Trav2D.prj” example project. 

2. The Main STAR*NET Menu will appear: 

 
 
All program operations can be selected from these dropdown menus, and the most 
common operations can be selected by pressing one of the tool-buttons. Pause your 
mouse pointer over each button to see a short description of its function. 

3. Choose Options>Project, or press the Project Options tool button. 

 
 

The “Adjustment” options page includes settings that describe the project, whether it 
is a 2D, 3D or Lev type, local or grid, linear and angular units used, and information 
about the datum scheme. A realistic “Average Project Elevation” should be entered 
if you are asking the program to reduce observations to some common datum, but 
this is not the case in this sample job so we’ve left the value at zero. Other important 
calculations based on this average project elevation are described in the full manual. 
Only relevant items on this options dialog are active. For example, other sections of 
this dialog and other dialogs will be active or inactive (grayed-out) depending on 
whether the adjustment is a 2D or 3D or a Lev type, or Local or Grid system. 

The “Lev” adjustment type is available in the PRO, PLUS and LEV editions. Most 
example projects shown are 2D or 3D. Example 10 illustrates a “Lev” type. 
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4. Review the “General” options by clicking the “General” tab. This page includes 
settings that are very general in nature that you seldom need to change during the life 
of a job. Some of these settings are actually “preferences” which describe the order 
you normally enter your coordinates (North-East, or visa versa), or the station name 
order you prefer when entering angles (At-From-To or From-At-To). 

 
 

5. Review the “Instrument” options page. Here you see default values used in the 
adjustment, such as standard errors for each of the data type, instrument and target 
centering errors, and distance and elevation difference proportional (PPM) errors. 
These are some of the most important parameters in the program since they are used 
in the weighting of your observation data. Since this is a 2D network, you will notice 
that only 2D standard error items are active. 
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Note that instrument and target centering errors can be included to automatically 
inflate the standard error values for distance and angle observations. Entering 
horizontal centering errors causes angles with “short sights” to be less important in 
an adjustment than those with “long sights.” Likewise, in 3D jobs, a vertical 
centering error can also be included to cause zenith angles with short sights to be less 
important in an adjustment than those with long sights. 

6. Review the “Listing File” options page. These options allows you to control what 
sections will be included in the output listing file when you run an adjustment. Note 
that the Unadjusted Observations and Weighting item is checked. This causes an 
organized review of all of your input observations, sorted by data type, to be 
included in the listing – an important review of your input. 

The Adjusted Observations and Residuals section, is of course, the most important 
section since it shows you what changes STAR*NET made to your observations  
during the adjustment process – these are the residuals. 

  

 
Note that the Traverse Closures section is also checked. This creates a nicely 
formatted summary of your traverses and traverse closures in the listing. You’ll see 
these and the other selected sections later in this tutorial project once you run the 
adjustment and then view the listing. 

The last part of this options page allows you so set options that affect the appearance 
of observations or results in the listing. Note that you can choose to have your 
unadjusted and adjusted observation listing sections shown in the same order the 
observations were found in your data, or sorted by station names. 

You can also choose to have the adjusted observations listing section sorted by the 
size of their residuals – sometimes helpful when debugging a network adjustment. 
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7. Finally, review the “Other Files” options page. This menu allows you to select 
additional output files to be created during an adjustment run. For example, you can 
choose to have a coordinate points file created. Or when adjusting a “grid” job, you 
can choose to have a geodetic positions file created. 

 
 

The optional “Ground Scale” file is particularly useful then running grid jobs. You 
can specify that the adjusted coordinates (grid coordinates in the case of a grid job) 
be scaled to ground surface based on a combined scale factor determined during the 
adjustment, or a factor given by the user. These newly-created ground coordinates 
can also be rotated and translated by the program.  

The optional “Station Information Dump” file contains all information about each 
adjusted point including point names, coordinates, descriptors, geodetic positions 
and ellipse heights (for grid jobs) and ellipse information. The items are comma 
delimited text fields which can be read by external spread sheet and database 
programs – useful for those wishing to create custom coordinate reports. This 
“Dump” file and the “Ground Scale” file are described in detail in the full manual. 

The Coordinate Points and Ground Scaled Points files can both be output in various 
formats using format specifications created by the user. The user-defined formatting 
specifications are discussed in the full manual. 

8. The “Special” option tab includes a positional tolerance checking feature to support 
certain government (such as ACSM/ALTA) requirements, but is not discussed in this 
tutorial. The “GPS” and “Modeling” option tabs are active in the “PRO” edition. See 
Examples 8 and 9 later in this tutorial for a description of the “GPS” options menu.  

9. This concludes a brief overview of the Project Options menus. After you are finished 
reviewing these menus, press “OK” to close the dialog. 
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10. Our next step is to review the input data. Choose Input>Data Files, or press the  
Input Data Files tool button. In this dialog you can add data files to your project, 
remove files, edit and view them, or rearrange their position in the list. The order of 
the list is the order files are read during an adjustment. You can also “uncheck” a file 
to temporarily eliminate it from an adjustment – handy when debugging a large 
project containing many files. This simple project includes only one data file. 

 

 
View the highlighted data file by pressing the “View” button. A view window opens 
so you can scroll through a file of any size. Take a minute to review the data and 
then close the window when finished. To edit the file rather than view it, you would 
press the “Edit” button, or simply double-click its name in the list.  

Note that the Input Data dialog automatically closes when you view or edit a file. 
Otherwise, for the other functions, you would press “OK” to exit the dialog. 

11. Run the adjustment! Choose Run>Adjust Network, or press the Run Adjustment  
tool button. A Processing Summary window opens to show the progress. 

When the adjustment finishes, a short 
statistical listing is shown in the Processing 
Summary window indicating how each 
type of data fit the adjustment. The total 
error factor is shown plus a statement 
indicating whether the Chi Square Test 
passed, a test on the “goodness” of the 
adjustment.  

After adjusting a network, you will want to 
view the network plot, or review the 
adjustment listing. 

We’ll view the network plot next. 



10 

12. To view the plot, choose Output>Plot, or press the Network Plot  tool button.  

 

 
Resize and locate the plot window for viewing convenience. The size and location of 
most windows in STAR*NET are remembered from run to run. 

Experiment with the tool keys to zoom in and zoom out. Also zoom into any selected 
location by “dragging” a box around an area with your mouse. Use the “Pan” tool to 
set a panning mode, and small hand appears as your mouse pointer which you can 
use to drag around the image. Click the “Pan” tool again to turn the mode off. Use 
the “Find” tool to find any point in a large network. Use the “Inverse” tool to inverse 
between any two points on the plot. Type names into the dialog or simply click 
points on the plot to fill them in (see the example above) and press Inverse.  

Pop up a “Quick Change” menu by right-clicking anywhere on the plot. Use this 
menu to quickly turn on or off  items (names, markers, ellipses) on the plot. 

Click the “Properties” tool button to bring up a plot properties dialog to change many 
plotting options at one time including which items to show, and sizing properties of 
names, markers, and error ellipses. 

Double-click any point on the plot to see its adjusted coordinate values and error 
ellipse dimensions. Double-click any line on the plot to see its adjusted azimuth, 
length, elevation difference (for 3D jobs), and relative ellipse dimensions. 

Choose File>Print Preview or File>Print, or the respective tool buttons on the 
program’s mainframe tool bar, to preview or print a plot. More details using the 
various plot tools to view your network and printing the network plot are discussed 
in the full operating manual. 

When you are finished viewing the adjusted network plot, let’s continue on and 
review the output adjustment listing next. 
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13. To view the listing, choose Output>Listing, or press the Listing tool button. 

 

 
The listing file shows the results for the entire adjustment. First, locate and size the 
listing window large enough for your viewing convenience. This location and size 
will be remembered. Take a few minutes to scroll through the listing and review its 
contents. For quick navigation, use the tool buttons on the window frame to jump 
forward or backward in the file one heading at a time, a whole section at a time, or to 
the end or top of the file.  

For quicker navigation to any section in the file, right-click anywhere on the listing, 
or press the Index Tree tool button to pop up a “Listing Index” (as shown above). 
Click any section in this index to jump there. Click [+] and [-] in the index to open 
and close sections as you would in Windows Explorer. Relocate the index window to 
any convenient location and it will stay. Check the “Keep on Top” box on the index 
window if you want it to always be present when the listing is active. 

Using one of the navigation methods described above, go to the section named 
“Summary of Unadjusted Input Observations.” Note that each observation has a 
standard error assigned to it. These are the default values assigned by the program 
using the project options instrument settings reviewed earlier in step 5. 

Still in the listing, further on, look at the “Statistical Summary.” This important 
section indicates the quality of the adjustment and how well each type of data such 
as angles, distances, etc. fit into the overall adjusted network. 

Always review the “Adjusted Observations and Residuals” section! It shows how 
much STAR*NET had to change each observation to produce a best-fit solution. The 
size of these residuals may pinpoint trouble spots in your network data.  
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Take a look at the “Traverse Closures of Unadjusted Observations” section. This 
project had data entered in traverse form, and in the Project Options, this report was 
selected as one of the sections to include in the listing. For each traverse, courses are 
listed with unadjusted bearings (or azimuths) and horizontal distances. When 
possible, angular misclosures are shown along with the amount of error per angle. 
The linear misclosures are shown based on unadjusted angles “corrected” by the per-
angle error. Many governmental agencies want to see this kind of closure analysis. 
But it is important to note, however, that these corrections are only for the benefit of 
this traverse closure listing. Actual corrections to angles are calculated during the 
least squares adjustment, and are shown as residuals. 

At the end of the listing, review the Error Propagation listing section. You will find 
the standard deviation values and the propagated error ellipse information for all 
adjusted stations. Also present are relative error ellipses between all station pairs 
connected by an observation. 

This concludes the quick review of the listing. You’ll note that much information is 
shown in this file – it contains just about everything you might want to know about 
the results of an adjustment. In some cases, you may only wish to see a subset of this 
information, so remember that you can tailor the contents of this file by selecting 
which sections to include in the Project Options/Listing file menu. 

14. In the “Project Options/Other Files” menu reviewed in step 7, an option was set to 
create an adjusted coordinates file. Choose Output>Coordinates to view this file. 
Any additional files created can also be viewed from this menu. 

 
 

15. This completes the review of the “Trav2D” example project. We have toured the 
main option menus, the input data dialog, performed an adjustment, reviewed the 
output listing contents in some detail and viewed network plots. Now that you have a 
good idea how the program works, the remaining tutorial examples can be examined 
with a minimum of explanation. 
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The sample project that you have just stepped through is a realistic example of a small 
two dimensional multi-loop traverse. Note that only a few simple steps are required to 
run an adjustment: 

 Set options for your project 
 Create one or more data files 
 Run the adjustment 
 Review both graphical and listing output 

 
The “listing file” you reviewed by choosing Output>Listing is the final adjustment 
report produced from the STAR*NET run. Once a project is adjusted to your 
satisfaction, you may want to get a printout of this listing for your records. This file is a 
text file having the name of your project, plus a “lst” extension. A  listing file named 
“Trav3D.lst” therefore, was created by running this example. 

The listing file can be printed from within the program by choosing File>Print while the 
listing window is open and active. 

The adjusted coordinates for this project are in a file named “Trav2D.pts” and like the 
listing file, can be simply printed from within the program. Since the points are in text 
format, many COGO programs will be able to read them directly. 

However for your convenience, there is a “Points Reformatter” utility that can be run 
from the “Tools” menu. This utility allows export adjusted coordinates to several 
standard formats, as well as custom formats defined by you 

Another utility available from the “Tools” menu is a “DXF Exporter” which creates a 
network plot in AutoCAD compatible DXF format.  

STAR*NET offers many options and has extensive features not described in this tutorial, 
but in general, most adjustments can be performed in the straight forward fashion 
illustrated by this example. At this point, you may wish to go back and review the actual 
data file used for this example. Note that the “Traverse” mode of data entry is very easy 
and efficient. Multiple traverses can be entered in one file, and additional distance and 
angle observations can be freely mixed with the traverse data, so as to keep observations 
in the same order as your field book. 

The remaining examples illustrate more STAR*NET capabilities and data types. It is 
assumed after following all the steps detailed in this first example project that you are 
now somewhat familiar with the operation of the program. The following examples do 
not always go into detail describing the individual program functions. 
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Example 2: Combined Triangulation/Trilateration 2D Network 

This example illustrates the adjustment of a simple triangulation-trilateration network. In 
the sample data file, many data lines are entered using the “M” code. This is the most 
commonly used data type meaning all “measurements” to another station. All the 
remaining independent observation are entered on a single “A” and “D” data lines. 

 
 
   # Triangulation/Trilateration 2D Network 
    
   C    1    5102.502    5793.197   ! ! 
   C    3    7294.498    6940.221   ! ! 
   C    2    5642        7017 
    
   # Angle and Distance Observations at Perimeter 
   M    2-1-3   111-08-11   1653.87 
   M    2-1-6    77-24-52   1124.25 
   M    3-2-4    87-07-04   1364.40 
   M    3-2-6    40-58-15    951.92   4.0  .03 
   M    4-3-5   120-26-52   1382.49 
   M    4-3-6    44-14-21    983.86 
   M    5-4-1   110-34-04   1130.75 
   M    5-4-6    39-46-29   1493.54 
   M    1-5-2   110-43-40   1337.89 
   M    1-5-6    65-36-54   1548.61 
     
   # Angles at Center Point 
   A    6-5-4    64-01-01 
   A    6-4-3    89-36-55 
   A    6-3-2   105-18-27 
   A    6-2-1    57-28-12 
    
   # Distance Cross-ties 
   D    1-4       2070.76 
   D    2-5       2034.47 
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1. Open the “Net2D.prj” example project.  

2. Choose Input>Data Files, or press the Data Files tool button to open the Data Files 
dialog. Then press “View” to view the “Net2D.dat” example data file. 

Note that the Measure lines contain horizontal angle and distance observations from 
one station to another. The standard errors for observations normally default to 
Instrument setting values defined in the Project Options as discussed in the last 
example. However, for illustration purposes, explicit standard errors have been 
added to one of the data lines in this example. Close the view window. 

3. Run the adjustment, by choosing Run>Adjust Network, or by pressing the Run 
Adjustment tool button. 

4. Choose Output>Plot or press the Network Plot tool button to view the network 
graphically. Experiment by resizing the plot window larger and smaller by dragging 
the corners or edge of the plot window. 

5. Zoom into a section of the plot by dragging your mouse pointer around some part of 
the network. For example, drag a zoom box around just points 1 and 2. Note the 
status information at the bottom of the plot window. The North and East coordinates 
are shown for the location of the mouse pointer as you move it around the plot. The 
Width value shown is the width of the plot window in ground units, FeetUS in this 
example. This width value will give you a good sense of scale when you are zoomed 
way into a very dense plot. Zoom out by pressing the Zoom All button. 

Right-click anywhere on the plot to bring up the “Quick Change” menu. Click the 
“Show Relative Ellipses” item to make relative ellipses display. These ellipses 
represent the relative confidences in azimuth and distance between connections in 
the network. Double click any line and to see its adjusted azimuth and distance 
values plus its relative ellipse dimensions. Likewise, double click any point to see its 
adjusted coordinates and ellipse dimensions. Chapter 8, “Analysis of Adjustment 
Output” in the full manual, includes an extensive discussion of error ellipse and 
relative error ellipse interpretation. 

6. View the Listing File by choosing Output>Listing, or by pressing the Listing tool 
button. Review the various parts of the listing in the same way you did for the last 
example. Be sure to review the “Statistical Summary” section which indicates how 
well each group of observation types fit into the adjusted network. 

Likewise, you should always review the “Adjusted Observations and Residuals” 
section which shows how much STAR*NET had to change your observations. You 
would normally examine this list carefully, especially if the adjustment fails the Chi 
Square test, to look for possible problems with your data. 

7. This completes the review of the “Net2D” example project. 
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Example 3: Three Dimensional Traverse Network  

This example illustrates the adjustment of a three dimensional network. Data includes 
two small traverses with slope distances and zenith angles. An extra cross tie is entered 
between the two traverses. STAR*NET can also accept 3D data in the form of horizontal 
distances and elevation differences.  

 
 

#  3D Traverse Network 
 
C A1   10000.00   10000.00    1000.00  ! ! ! 
C A2    9866.00    7900.00     998.89  ! ! ! 
 
TE  A2  # backsight to A2 
T   A1  163-59-26.0   1153.67   91-35-30.0  5.25/5.30 
T   1   115-35-06.8   1709.78   90-56-41.6  5.31/5.32 
T   2    86-31-37.9   1467.74   90-05-56.2  5.26/5.31 
T   3    82-07-57.7   2161.76   88-20-39.6  5.15/5.22 
TE  A1   75-45-17.6     1   # closing angle to  1 
 
TB  1   # backsight to 1 
T   2   133-21-35.8   2746.28   91-37-53.3  4.98/5.12 
T   4   101-39-39.6   1396.76   88-23-31.8  5.23/5.25 
T   5   124-35-19.6   3643.41   88-28-02.3  5.35/5.30 
TE  A2   80-48-52.2     A1  # closing angle to  A1 
 
M 5-4-3  69-59-28.7   2045.25   89-00-41.0  6.21/5.25 
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1. Open the “Trav3D.prj” example project.  

2. Take a look at the Project Options for this project. Note that on the Adjustment 
options page the “Adjustment Type” is now set to 3D. On the same menu, down in 
the Local Jobs group of options, we have the Default Datum Scheme set to “Reduce 
to a Common Datum” and the elevation value is set to 0.00 feet. What this means is 
that we want the job reduced to sea level. The controlling coordinates given in the 
data must be sea level values, and during the adjustment, observations will be 
internally reduced to this datum to produce sea level coordinates. 

Also while in the Project Options, review the “Instrument” settings page. Note that 
all settings for vertical observations are now active. Centering errors of 0.005 feet 
have been set for both horizontal and vertical centering which will affect standard 
errors for all our measurements. Shorter sightings will receive less weight! 

3. Examine the input data file. Note that each traverse line now contains additional data 
elements, the zenith angle and an “HI/HT” entry giving the instrument and target 
heights. Coordinate lines now contain an elevation value. The sample data file 
contains two small connecting traverses. The “TB” (traverse begin) lines indicate the 
beginning backsights, and the “TE” (traverse end) lines indicate at which station the 
traverses end. In this example, they both contain an optional closing angle. 
STAR*NET will use this information in the traverse closure listing, as well as 
entering them as observations in the adjustment. 

Additional redundancy is provided by an “M” data line containing angle, distance 
and vertical information between points on the two traverses.  

4. Run the network adjustment and then look at the network graphically. Double click 
any of the adjusted points and note the displayed information now includes adjusted 
elevations and vertical confidence statistics. 

5. View the output Listing file. Review the unadjusted observations and note that the 
standard errors for all angles and zenith angles are no longer constant values. 
Because of the “centering error” values entered in the instrument options, the 
standard errors assigned to these observations will be larger (less weight) for angles 
with short sights than for those with long sights. 

Further down in the listing, review the adjustment statistical summary. Since this is a 
3D job, you now see additional items in this list. Review the remaining sections and 
note the differences from the previous 2D adjustment listing in the first two example 
projects. In the Traverse Closures section, for example, vertical traverse closures are 
shown. And in the Error Propagation section, standard deviations are shown for 
elevations, and vertical confidences for ellipses.  

6. This completes the review of the “Trav3D” example project.  
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Example 4: Three Dimensional Grid Job 

This example demonstrates the ability of STAR*NET to reduce ground observations to a 
grid system plane during the processing of a network adjustment.  

The following example is the same 3D multiple traverse network illustrated in the 
previous example. All ground observations are identical; only the coordinates have been 
changed to be consistent with NAD83, California Zone 0403. 

 
 
#  3D Traverse Grid Job 
 
C A1 2186970.930 6417594.370  300.00 ! ! ! 
C A2 2186836.940 6415494.520  298.89 ! ! ! 
 
TB A2  # traverse backsight to A2 
T A1  163-59-26.0   1153.67   91-35-30.0  5.25/5.30 
T 1   115-35-06.8   1709.78   90-56-41.6  5.31/5.32 
T 2    86-31-37.9   1467.74   90-05-56.2  5.26/5.31 
T  3    82-07-57.7   2161.76   88-20-39.6  5.15/5.22 
TE  A1   75-45-17.6     1  # closing angle to Station 1 
 
TB 1 
T 2   133-21-35.8   2746.28    91-37-53.3  4.98/5.12 
T 4   101-39-39.6   1396.76    88-23-31.8  5.23/5.25 
T 5   124-35-19.6   3643.41    88-28-02.3  5.35/5.30 
TE A2   80-48-52.25    A1  # closing angle to Station A1 
 
M 5-4-3  69-59-28.7  2045.25    89-00-41.0  6.21/5.25 
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1. Open the “Grid3D.prj” example project. 

2. Open the Project Options for this job and review the Adjustment options page. You 
will see some differences from the adjustment options in the last example project: 

 
 

First, you will note that the Coordinate System is set to “Grid,” and the actual grid 
system chosen from the dropdown selection list is NAD83. Other selections are 
NAD27, UTM and Custom. (User-defined and international grids come under the 
category of Custom.) The zone currently selected, as indicated on the large selection 
button, is California Zone 0403. How is a zone selected? Simply press the large 
selection button to bring up the zone selection dialog. Give it a try. 

 
 

Here you just select from the list to change zones. Press “Show Parameters” to see 
the zones parameters. Don’t make a new selection now – just press OK to exit.  
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Before you exit the Project Options, note another difference in the options from the 
previous example. At the bottom of the menu is an options group specific to grid 
jobs. Here you enter the average Geoid Height. This value is always entered in 
meters, and it is important to use the correct sign. (It’s negative in the contiguous 
United States.) For GPS jobs, it is important to perform geoid modeling so that a 
geoid height is determined at every point. But for jobs having only conventional 
observations such as this example, an average project geoid height is sufficient since 
only ground to grid scaling in affected. 

3. Examine the data file if you wish. As mentioned before, the observation data for this 
example is identical to the previous example except that the entered control 
coordinates are grid coordinates consistent with NAD83, California zone 0403. The 
same data set was used for this example so that, if you wish, you can compare output 
results from two identical jobs, one run as local, and the other as grid. 

4. Run the network adjustment. Look at the network graphically – it will look the same 
as in the last example. However, if you double click any of the adjusted points, the 
displayed coordinates will now, of course, be grid coordinates. 

5. View the output Listing file and browse through the various sections as you did in 
the last example. But since this job is a “grid” adjustment, you will find some new 
information present. Go down to the “Adjusted Station Information” section. First, 
comes the adjusted grid coordinates. Then directly following are the computed 
geodetic positions and ellipsoid heights as shown in the listing window below.  

 
 

As shown above, next comes a listing of convergence angles and scale factors 
computed at every station in the network. The factors include the grid scale factor, 
the elevation factor, and the resulting combined factor. 
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In the “Adjusted Bearings and Horizontal Distances” section previously seen in other 
examples in this tour, the bearing shown is now a “grid” bearing, and both “grid” and 
“ground” distances are now shown for every network connection.  

 
 

Finally, look at the “Traverse Closures of Unadjusted Observations” section. Since 
this is a “grid” job, the listing  of traverse closures is based on unadjusted bearings 
and distances that are reduced to the grid plane. 

6. See what other files were created by the adjustment by looking at the items that show 
up in the Output pulldown menu. Before we’ve seen the Coordinates file. And now 
we see a Lat/Longs (geodetic positions) file. The creation of both these files were 
requested in the ”Project Options/Other Files” menu. Go ahead and view one or both 
of these files if you want. 

7. This completes the review of the “Grid3D” example project. Since this was the first 
“grid” job in our tutorial examples, we went into extra detail reviewing the option 
settings and output sections relating to grid adjustments. 
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Example 5: Resection 

This example demonstrates the use of STAR*NET in solving a resection problem, 
involving the measurement of angles from 6 known stations to an unknown point. 

 
 
   # Resection 
 
   # Approximate location for the unknown station 
   #    
   C    P48    104500     93600  
 
   # Fixed coordinates for the known stations 
   # 
   C    1     90132.03     88237.92   ! ! 
   C    2     97418.58     82279.10   ! ! 
   C    3     98696.21     81802.35   ! ! 
   C    4    102911.40     80330.69   ! ! 
   C    5    111203.37     95234.19   ! ! 
   C    6    103278.43    106872.91   ! ! 
 
   # Occupy “P48” and turn angles to known stations 
   # 
   A   P48-1-2      37-35-00.0 
   A   P48-2-3       5-56-19.4 
   A   P48-3-4      19-56-18.3 
   A   P48-4-5     115-34-35.0 
   A   P48-5-6      78-09-31.0 
   A   P48-6-1     102-48-30.0 
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1. Open the “Resection.prj” example project. 

2. Review the project options if you wish. This is a standard 2D, local project.  

3. Examine the input data file.  

Note that all station coordinates are fixed with the “!” symbol, except for the 
unknown instrument station “P48” which is free. The angles default to the standard 
error for angles set in the Project Options/Instrument options menu. 

4. Run the adjustment.  

Review the processing summary on the screen. Note that in the short statistical 
summary, the only observation type listed is the angle, and the adjustment passes the 
Chi Square test. 

5. Look at the network graphically.  

You will see only one error ellipse since there is only one unknown point in the 
whole network. 

6. Review the listing file. 

 It’s quite short since our only observations are angles. 

7. This completes the review of the “Resection” example project.  
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Example 6: Traverse with Sideshots 

This example illustrates data consisting of a simple traverse containing many sideshots. 
Sideshots (SS) are single, non-redundant shots that do not affect the adjustment results. 
You cannot occupy or backsight to a sideshot. These shots are diverted during loading of 
the input data file, and are not processed until after the network is adjusted. Their 
computed coordinates are written to both the Listing File and the Points File. Because 
they are processed after the adjustment, no error propagation is performed on Sideshots. 
The special sideshot data type is available so that you can process a network containing 
hundreds or thousands of sideshots without slowing down the adjustment of the actual 
network. In particular, this approach lends itself to the processing of large topo data sets 
downloaded from data collectors. 

 
 
   #  Traverse with Sideshots 
    
   C   1   1000.00   1000.00 1440.28  ! ! ! 
   C   2   1725.18   1274.36 1467.94  ! ! ! 
    
   #  Begin Field Observations 
   # 
   TB  2 
   T   1      51-59-30  242.42   88-44-35   5.25/5.30 
   T   59    198-19-55  587.14   89-39-40   5.30/5.50 'IRON PIN 
   T   572   140-52-34  668.50   80-14-25   5.18/5.22 
   TE  828 
    
   #  Begin Sideshots 
   # 
   SS  1-2-3   104-18-07  146.08   90-56-54   5.25/5.33 'TOE 
   SS  1-2-4    24-33-33  118.64   89-16-07   5.25/5.33 'TOE 
   SS  1-2-5   339-20-11  254.12   88-03-45   5.25/5.33 'FACE OF CURB 
   SS  1-2-14  339-35-31  383.90   88-33-17   5.25/5.33 'TOE 
   etc... 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

828

57259

2
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1. Open the “Sideshots.prj” example project. 

2. View the input data file. Note that the sideshots are entered with the “SS” code. 
Scroll down and view the entire file; the data includes quite a number of sideshots!  
Most of the sideshots also have a text descriptor at the end of the line, which is 
marked with a single or double quote character. 

Remember that the sideshots are processed after the adjustment, and do not slow 
down the network processing. It is also important to remember that since sideshots 
are not actually part of the “adjusted” network, and that you cannot occupy a 
sideshot, or backsight to one. You cannot take a sideshot to the same point and 
expect that point to be adjusted. In all these cases, you should enter your 
observations with an “M” data line which is included in the actual adjustment. 

For simplicity, sideshots in this example were all entered following the traverse. 
However they may be freely intermixed with traverse data or any other types of data, 
to preserve the same order recorded in your field book or data collector. 

3. Run the adjustment. The adjustment of the traverse proceeds very quickly, and the 
sideshots are processed independently after the adjustment is completed.  

Note that in this particular example, the main traverse is simply an open ended 
traverse that doesn't even tie into a known station. So in this case, although all points 
are computed, nothing is really adjusted. This illustrates how STAR*NET can be 
used simply as a data reduction tool. And had we been working in some grid 
coordinate system, for example NAD83 or UTM, all the observations would have 
also been reduced to grid, producing adjusted grid coordinates. 

4. View the resulting network graphically - many sideshots fill the plot screen. Zoom 
into a small group of sideshots. Right-click the plot screen to bring up the Quick 
Change menu, and click the “Show Sideshot Descriptors” item to turn on viewing of 
descriptors. Descriptors often clutter up a plot view, so by default you will usually 
leave them turned off. You can also turn sideshots off and on in the Quick Change 
menu by unchecking and checking the “Show Sidehots” item.  

5. Take a quick look at the adjustment listing file. Looking through the listing you will 
see a review of the input sideshot observation data as well as final sideshot 
coordinates in the “Sideshot Coordinates Computed After Adjustment” section. 
These computed sideshot coordinates, along with the traverse coordinates, also 
appear in the “points” output file created during the processing. This file can be 
viewed by choosing Output>Coordinates as illustrated in earlier examples. 

6. This completes the review of the “Sideshots” example project.  
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Example 7: Preanalysis 

This example demonstrates using STAR*NET in the preanalysis of survey networks. 
Preanalysis means that the network will be solved using approximate coordinates to 
locate the stations, and a list of observation stations to indicate which distances and 
angles are planned to be observed. No actual field data are required. STAR*NET will 
analyze the geometric strength of the network using the approximate layout, and the 
instrument accuracies supplied as observation standard errors. The predicted accuracy of 
each station will be computed, and error ellipses generated. Preanalysis is a powerful 
tool that will help you to test various network configurations before any field work is 
done, or to test the effects of adding measurements to an existing network. 

You can use any of the 2D and 3D data types provided for in STAR*NET to define a 
proposed survey. In this simple 2D example, we traverse around the perimeter, use 
measure lines to define some cross ties, and then fill in some angles. 

 
    
   # Preanalysis 
    
   C    1        51160    52640  ! ! 
   C    2        50935    52530 
   C    3        50630    53660 
   C    1001     51160    52950 
   C    1002     51145    53280 
   C    1003     50645    53265 
   C    1004     50915    53570 
   C    1005     50655    52770 
   C    1006     50945    52820 
   C    1007     50865    53160 
    
   B    1-2       ?   ! 
   #B   1003-3    ?   5.0    # Uncomment this line to add another bearing  
    
   TB   2 
   T    1 
   T    1001 
   T    1002 
   T    1004 
   T    3 
   T    1003 
   T    1007 
   T    1006 
   T    1005 
   T    2 
   TE   1 
     
   M    1-2-1005 
   M    1-2-1006 
   M    1001-1-1006 
   M    1001-1-1007 
   M    1002-1001-1007 
   M    1002-1001-1003 
   M    1004-1002-1003 
   A    1003-1007-1002 
   A    1003-1007-1004 
   A    1007-1006-1001 
   A    1007-1006-1002 
   A    1006-1005-1 
   A    1006-1005-1001 
   A    1005-2-1 
 
 
 

1 1001 1002

1004

31003

1007
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1. Open the “Preanalysis.prj” example project. This is a “2D” project. 

2. View the input data file. Note that all stations have been given approximate 
coordinates. This defines the network geometry. Note also that the list of distance 
and angle data lines contains no field observations. Observation standard errors 
default to the values set for the various data types in the Project Options/Instrument 
menu. If a specific standard error is required, a place holder such as “?” is required 
on the data line in place of the actual observation. 

3. Run the preanalysis by choosing Run>Preanalysis. Note that if you were to make 
any other choice from the Run Menu such as “Adjust Network” or “Data Check 
Only,” errors would result due to the missing observations. 

4. View the network graphically. Note that the resulting station error are larger for the 
stations furthest from the fixed station. Also, their shape and orientation suggest an 
azimuth deficiency in the network. This is the purpose of running a preanalysis, to 
study the strength of your planned survey network using only proposed field 
observations. 

5. If you wish, you can experiment with adding another observation to the network. 
Open the Data Files dialog by choosing Input>Data Files, or by pressing the Input 
Data Files tool button. Press the ”Edit” button, or simply double-click the 
highlighted data file in the list. Locate the line in the data file that has a Bearing from 
Station 1003 to Station 3. Uncomment the line by deleting the “#” symbol at the 
beginning of the line, just before the “B” code. Note that this data line has an 
explicitly entered standard error of 5 seconds. (This new data, for example, might 
represent an observed solar azimuth.) Save the file and exit from the text editor.  

Now rerun the preanalysis by choosing Run>Preanalysis again. Review the new 
results graphically as described in Step 4 above. Notice the increased positional 
confidence provided by the addition of the proposed bearing observation. The 
ellipses we were concerned with are now smaller and more round. If you wish to see 
the actual ellipse dimensions, double-click any point on the plot, or of course you 
can view the error ellipse information in the listing file as suggested below.  

6. Take a quick look through the listing. Even though no actual observations were 
provided as input, observation values (angles and distances) will be shown in the 
listing. These values are inversed from the given coordinates and standard errors are 
assigned to these proposed observations from the Project Options/Instrument menu 
settings. And of course, station ellipses and relative ellipses are also shown, their 
computed values being the main purpose for making a preanalysis run. 

7. This completes the review of the “Preanalysis” example project. 
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Example 8: Simple GPS Network 

This example demonstrates the major steps you would go through to setup and adjust a 
simple network made up of only GPS vectors. You will set a few required project 
options, review the main data file which defines the coordinate constraints, import a few 
vectors from Trimble GPSurvey baseline files, and adjust the network. 

 
# Simple GPS Network 
# Fully-constrained, two fixed stations plus a fixed elevation 

   # Grid Coordinates are used for constraints in this example 
 
C 0012   230946.1786  120618.7749  224.299  ! ! !  'North Rock 
C 0017   218691.2153  131994.0354  209.384  ! ! !  '80-1339 
E 0013    205.450  ! 'BM-9331 
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0016
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1.  Open the “VectorJob.prj” example project. 
 
2. Choose Options>Project, or press the Project Options tool button. 

 
 

Options in the Adjustment tab are settings that describe the project. Note that the 
Adjustment Type is set is “3D” and the Coordinate System is set to “Grid.” When a 
project contains GPS vectors, these two options must always be set this way. This 
example project is set to use NAD83 Arizona Central zone 0202. 

The Average Geoid Height is set to -32.20 meters. For GPS vector adjustments 
however, it is very important to perform geoid modeling as the connection between  
vectors (which are ellipsoid-based) and elevations (which are geoid-based) are 
accurate geoid separations. For simplicity though, we will not be performing geoid 
modeling in this tutorial example, therefore this value will be assigned as the geoid 
height to all stations in the project. 

If you wish, review the next four option tabs: General, Instrument, Listing File, and 
Other Files. They contain typical settings you have seen before while reviewing the 
tutorial in the main manual. The “Instrument” settings only relate to conventional 
observations, so in the case of this project having only GPS vectors, they have no 
relevance in the adjustment. 
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3. Review the “GPS” options by clicking the “GPS” tab. These fields allow you to set 
default values or options relating to GPS vectors present in your network data. 

 
 

We know that all vectors imported for this example have supplied weighting so we 
didn’t set any default standard errors offered by the “Apply Default StdErrs” field. 

A value of 8.00 has been set for the “Factor Vector StdErrors” field which means 
that all the imported vector standard errors will be multiplied by this factor. Standard 
errors reported by many baseline processors are over-optimistic and this option 
allows you to make them more realistic. A “Vector Centering StdError” value of 
0.002 meters has been entered which further inflates the standard errors.  

The “Transformations” box is checked and a choice has been made to solve for scale 
and three rotations, around North, East and Up axes, during the adjustment. Solving 
for these transformations often helps “best-fit” vectors to your station constraints by 
removing systematic errors or biases that may exist in vector data. 

Finally, in the “Listing Appearance” options, certain output preferences are set for 
various listing items including how you like to see vector weighting expressed and 
how both unadjusted and adjusted vectors data should be sorted. Note that in this 
sections, it has been chosen to show a “Residual Summary” section in the listing. 
We’ll review this very useful report later. 

4. Review the “Modeling” tab. It is here that you select to perform both geoid modeling 
and deflection modeling during an adjustment. For simplicity in this demo tutorial, 
we are not going to perform any modeling. The average geoid height specified on the 
Adjustment options page will be applied to all stations in the network. 

5. This concludes the overview of the Project Options for this example. After you are 
finished reviewing the options, press “OK” to close the dialog. 
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6. Next, review the input data. Choose Input>Data Files, or press the Input data tool 
button. Note there are two files in the list. The first file is the main data file shown at 
the beginning of this example. It simply contains two stations with fixed north, east 
and elevation values, and one station with a fixed elevation. 

 
 

The second file contains the imported vectors for this project. For simplicity, we 
have already imported the vectors into a file for this example, and it appears in the 
data file list with the same name as the project, and with a “GPS” extension. In the 
next step, we’ll actually go through the exercise of running the GPS importer to 
show you how this file was created.  

But while we are still in the Data Files dialog, let’s review the vector file. Highlight 
the “VectorJob.Gps” file in the list and press the “View” button. 

 
 

The file contains eight imported vectors. Each vector consists or four lines which 
includes a vector ID number, the Delta-X, Y & Z vector lengths, and covariance 
information for weighting. After reviewing the vector data, close the window. 
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7. Now that the imported vectors have been reviewed, let’s see how they were actually 
imported in the first place. Choose Input>Import GPS Vectors.  

 
 

 
The first step in importing vectors is to choose a GPS Baseline Format from the drop 
down selection list. In this example we are extracting vectors from baseline files 
created using the Trimble GPSurvey package. Next, take a quick look at the 
“Options” tab. Here you can set a few options that will affect vector importing.  

Back in the “Import” tab, press the “Select Baseline Files” button to bring up a file 
selection dialog. (The baselines are in the “StarExamples” sub-folder of your install 
directory, so if the dialog does not open there, go ahead and browse there.)  The 
selection dialog will show eight Trimble “SSF” baseline files. Highlight these files 
as shown, and press the “Select” button. 
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These selected files now appear in the main Import page dialog as shown below and 
the “Import” button is now active. 

 
 

If we press “Import,” the importer will extract vectors from these files and write 
them to the file named “VectorJob.GPS” specified in the “Import Vectors to” field 
above. But to simplify this tutorial example, we had previously imported them.  

However, if you want to import the vectors anyway just to see how it works, press 
the “Import!” button. When importer warns you that the file already exists, it asks if 
you want to Overwrite or Append the file - select to Overwrite the file. 

Complete details on importing vectors, setting import options, and information on 
the current baseline formats available to import from are fully discussed in the 
STAR*NET-PRO documentation. Press “Close” to exit the vector importer. 

8. Project Options have been set and all input data files created, so now we can adjust 
the network. Choose Run>Adjust Network, or press the Run Adjustment button. 

The Processing Summary window opens, and the network adjustment iterations 
finish quickly. Note that the total “Error Factor” was low, less than 1.00, and the 
adjustment passed the “Chi Square” test. 

9. Review the network plot if you wish. Note that the geometry for point 0015 seems 
rather weak, and the error ellipse for that point is larger than those for the other 
points. In the next example, we will run a traverse from 0013 to 0018 and make ties 
from the traverse to points 0015 and 0016.  
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10. View the output Listing file and browse through the various sections, especially the 
output sections relating to GPS vectors. Go to the “Summary of Unadjusted Input 
Observations” section where you will first see the list of controlling coordinates.  

Directly following will be the unadjusted vectors showing the lengths and standard 
errors of the Delta X, Y and Z components of each vector expressed in the earth-
centered Cartesian system. Standard errors shown for these components include the 
affects of any “Factoring” and “Centering Errors” set in the options. 

Next go to the “Adjusted Observations and Residuals” section. The first part of this 
section shows solutions of the transformations requested in the GPS options 
reviewed earlier. Here you see solutions for a scale and three rotations. The scale 
change is very small as are the three rotations. This should be expected when 
performing an adjustment on a GPS-based ellipsoid such as WGS-84 or GRS-80. If 
any of these solved transformation values are unreasonably large, you need to review 
your observations and constraints and find the reason why. 

 
 

As shown above, the next output in the same section are the adjusted GPS vectors 
and their residuals. Always review this important section since it shows you how 
much STAR*NET had to change each vector to produce a best-fit solution. 

Note that all the vector, residual and standard error components have been rotated 
from earth-centered Cartesian to local-horizon North, East and Up components. This 
orientation is simple to understand and very easily related to conventional 
observations. 
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The next section is the “GPS Vector Residual Summary” mentioned earlier in this 
example. Users find this one of the most helpful GPS related sections in the listing. It 
can be sorted in various ways to help you find the “Worst” vectors in your network. 
In our example, the summary is sorted by “3D” residuals, made up of local-horizon 
North, East and Up residual components. 

 
 

Review the remaining sections in the listing file if you wish. These section are not 
unique to GPS vectors, and you have seen them before when running the examples 
earlier in this tutorial. 

11. This completes the “VectorJob” example project. This was a realistic example of a 
small GPS job containing only vectors.  

To keep the tutorial short however, this example skipped a very important step! 
When running your own adjustments, always run a minimally-constrained 
adjustment first, holding only a single station fixed. This will test the integrity of the 
observations without the influence of external constraints. When you are confident 
that all observations are fitting together well, then add any remaining fixed stations 
to the network. 

The next example will add the vectors from this project to some conventional 
observations and you will run a combined network adjustment. If you want to 
continue on to the next example, turn the page for instructions. 
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Example 9: Combining Conventional Observations and GPS 

This example demonstrates combining conventional observations and GPS vectors in a 
single adjustment. We'll be using the same imported vectors and constraints as in the last 
example, only now a traverse and some ties have been added to the network. 

 
# Combining Conventional Observations and GPS Vectors 
# Latitudes and Longitudes are used as constraints in this example 
# The "VectorJob.GPS" file is added in the Data Files Dialog 

 
P 0012  33-04-44.24402 112-54-36.04569 224.299 ! ! ! 'North Rock 
P 0017  32-58-09.73117 112-47-13.55717 209.384 ! ! ! 'AZDOT 80-1339 
E 0013  205.450  ! 'BM-9331 
 
TB 0012 
T  0013   67-58-23.5  4013.95  90-04-44  5.35/5.40 
T  0051  160-18-01.7  2208.27  90-14-33  5.40/5.40 
T  0052  213-47-22.1  2202.07  89-43-20  5.36/5.40  'SW Bridge 
T  0053  198-52-17.3  2714.30  89-58-19  5.35/5.38 
TE 0018 
 
# Ties to GPS points 
M 0051-0013-0015  240-35-47.03  1601.22  90-27-52  5.40/5.40 
M 0052-0051-0015  320-50-46.25  2499.61  90-05-49  5.36/5.41 
M 0052-0051-0016  142-02-01.50  2639.68  90-07-37  5.36/5.40 
M 0053-0052-0016   61-14-43.77  2859.65  90-20-19  5.35/5.42 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

0012

0016

0018

0017

0015

0013

0051

0052
0053
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1. Open the “VectorCombined.prj” example project. 

2. Review the Project Options if you wish. Since this project contains conventional 
observations, the “Instrument” options settings will be relevant in the adjustment. 
Note that the standard error values entered for the turned angle, distance and zenith 
angle observations are quite small indicating that high quality instruments and field 
procedures are being used. The “GPS” option settings are the same as in the first 
example project.  

When combining conventional observations with GPS vectors, it is particularly 
important to carefully set weighting parameters in the Instrument options as well as 
in the GPS options since standard errors determine the relative influence of each  
type of data in the adjustment.  

3. Open the Input Data Files dialog. There are two files in the list. The first file named 
“VectorCombined.Dat” contains the station constraints and conventional 
observations, and the second file named “VectorJob.Gps” contains GPS vectors 
imported to that file in the last example project. This file was simply added to the 
data file list by pressing the “Add” button and selecting the file. View either of these 
files if you wish, otherwise press “OK” to exit the dialog. 

 
 

Note that in the “VectorCombined.dat” file, shown on the first page of this example, 
the same stations have been constrained as were in the last project, except they are 
entered as equivalent geodetic positions rather than grid coordinates simply to 
illustrate use of that data type. Results will be identical either way. 

Conventional observations in the network include a traverse and four ties from 
traverse stations to two of the GPS stations. The traverse lines and the tie 
observations (the “M” lines) include turned angles, slope distances and zenith angles. 
Instrument and target heights are also included. 
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4. Run the network adjustment! The Processing Summary window opens, and the 
adjustment converges in a few iterations. The total “Error Factor” was slightly 
greater than 1, but the adjustment passed the “Chi Square” test. 

 

5. View the network plot. Note that although the standard errors for the conventional 
observations were set quite small (indicating use of high quality instruments and 
field procedures), the error ellipses for points observed only by these observations 
are noticeably larger than those observed by GPS vectors. 

If you wish, open the plot properties 
dialog, and turn on both relative 
ellipses and point descriptors.  

Experiment by double clicking points 
and connection lines to see the adjusted 
information including ellipse and 
relative ellipse sizes. 
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6. View the listing file. Note that listing sections reviewing unadjusted and adjusted 
observations now include both conventional and GPS vector observations. 

 Find the “Statistical Summary” listing section and review how each type of 
observation (angle, distance, zenith angle and vector) fit in to the adjusted network. 

7. This completes the “VectorCombined.Prj” project, the last example in this tour. 

As you can see, combining conventional observations and GPS vector observations is 
very easy. When combining conventional and GPS observations, the most important 
consideration is establishing realistic weighting relationships between your GPS vector 
observations and your conventional observations. As mentioned in the first example, the 
standard errors reported by most manufacturer’s baseline processors are usually over-
optimistic, so you normally need to set a “factor” in the GPS options to make them 
realistic, and more compatible with conventional observations. 

Note that geoid modeling has been mentioned more than once in the two example 
projects containing GPS vectors. But for simplicity, geoid modeling was not performed. 
However, installed along with this demo program is a separate utility program which 
extracts geoid information from a variety of government-supplied files and creates 
neutral geoid files that are used with the STAR*NET-PRO edition. This utility, named 
StarGeoid, is an-easy-to-use single dialog program: 

 

 
The use of this utility is not discussed in the tutorial, but in short, it allows you to extract 
geoid (and vertical deflection) information from government sources and save the data in 
a neutral format for use by STAR*NET-PRO. Then when you want to perform modeling, 
all you do is to check the “Perform Geoid Modeling” box in the Modeling options, and 
modeling will be automatically performed during the adjustment – very easy! 
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Example 10: Differential Leveling Network 

This example demonstrates running a stand-alone differential level network adjustment. 
A stand-alone “Lev” adjustment is available in the STAR*NET-LEV edition plus the 
higher-end STAR*NET-PLUS and STAR*NET-PRO editions. Level observations can 
also be included in any 3D adjustment in the STAR*NET suite. 

 
#  Simple Level Network with 4 Fixed Benchmarks 
 
#  Fixed Elevations 
E   TIDAL1     1.375  !   'NGS Ref 1  
E   TIDAL2     2.165  !   'NGS Ref 2 
E   BM75      23.768  !    
E   BM26      57.129  !   'Brass Cap 1939 
 
# Leveling Observation Data  
L   TIDAL1-129    12.345   20100 
L   BM75-129     -10.023   25300  
L   BM75-125      15.920   31200  
L   129-130       22.130   37400 'Central 
L   130-125        3.833   28100 'At Hyde 
L   129-128       11.810   41700   
L   128-130       10.336   32100   
L   125-BM26      17.458   37500     
L   BM26-126       2.814   39200    
L   130-126       24.065   40900   
L   128-126       34.422   52200  
L   126-127      -15.485   48100 
L   128-127       18.95    45300  
L   TIDAL2-127    42.321   17700 
 
# To produce an optional plot diagram,   
# supply 2D coordinates at any scale. 
 
.2D 
C   TIDAL1  11.0  12.0   
C   TIDAL2   0.2  11.8   
C   BM26     5.4   2.6  
C   BM75    12.2   6.4   
C   125      8.7   3.9   
C   126      3.3   4.3   
C   127      1.2   8.0    
C   128      4.0   9.6   
C   129      9.1   8.5   
C   130      6.1   6.7  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

TIDAL2

128

132

126

130

125

129

TIDAL1

BM26

BM75
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1. Open the “LevNet.prj” example project. 

2. Open the Project Options for this job and review the “Adjustment” options page. 

 

 
Here the “Lev” adjustment type has been selected. This is a 1-D network adjustment 
requiring only elevations used as benchmark restraints and differential leveling 
observations as input. The only other setting you will set on this dialog is the default 
linear units of the input and output. 

3. Review the “General” options page. 

 
 

Again, only a few options settings are needed for a level network adjustment. There 
are no iterations required for this kind of adjustment as the solution is linear. Why is 
there a “Coordinate Order” option for a level network? As illustrated by the data, 
Northing and Easting coordinates may be optionally entered for each station if you 
want a schematic plot generated for your level network. More on this later. 

4. Review the “Instrument” options page. 

 

 
Here the default standard error for the leveling observations is set. Weighting for 
differential leveling can be defined by section length or by the turns. For this 
example network, the elevation difference standard error for each observation will be 
propagated by the program using 0.006 Feet per Mile section. 
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5. Also review the “Listing File” and “Other Files” options pages in the Project Options 
if you wish. A few options can be set relating to output for a level network.  

6. Examine the data file if you wish. You will note this simple network includes four 
fixed elevations and 14 leveling section observation “L” lines. These two types of 
data lines are the only types required to perform an adjustment. Note however that 
2D coordinates have also been provided for all the stations in the network. These are 
optional and need be entered only of you wish the program to create a schematic plot 
of the level network. Since these coordinates will only be used to create this plot, the 
scale of the coordinates makes no difference. Coordinates entered in this example 
were simply scaled off a sketch of the network drawn on grid paper. 

7. Run the network adjustment. 

8. Look at the network graphically. As mentioned above, this is only a schematic plot 
based on the relative 2D coordinates entered. Although straight lines are shown 
between connections, in actual leveling networks these connections may actually 
follow along roads, wander around hills, etc.  

 
 

While viewing the diagram, double-click any point to get a pop-up information box 
showing its adjusted elevation and confidence region values. Double-click on other 
points and the information will refresh. Double-click on any line to show its adjusted 
elevation difference and relative confidence values. The example pop-up box shows 
information generated by double-clicking connection 129-128 on the plot diagram. 
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9. View the output listing and browse through the various sections as you did in 
previous examples. Go to the “Adjusted Elevations and Error Propagation” section. 
Here adjusted elevations, standard deviations and confidence regions are all shown 
for all stations. Horizontal coordinates, even though entered for the benefit of 
creating a plot diagram, are not shown as they play no part in the adjustment. 

 

 
Go to the “Adjusted Observations and Residuals” section. Here the adjusted level 
observations are shown along with their residuals. Note the standard errors used in 
weighting the observations are all different because they are propagated based on the 
length of the sections. 

 
 

10. This completes the “LevNet” example project, the last example in this tutorial. 
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You have now completed all of the sample projects in this Tour. We hope that you now 
have a basic understanding of the operation of STAR*NET and how, as a versatile tool, 
it can be used not only to provide the best analysis and adjustments possible, but as a 
valuable aid to survey planning. 

We now encourage you to experiment with the Demonstration Program by rerunning 
some of the examples, or trying some of your own data. 

The next section, “Supplemental Information” provides extra details concerning editing 
your data and the format of data lines shown in the examples. 
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Supplemental Information 

Editing Your Data 

As illustrated in the tutorial, STAR*NET uses standard text files for all data. You can 
create and edit these data these files external to STAR*NET, or more conveniently, right 
from the Data Files dialog by highlighting a file name and pressing “Edit.” 

When you installed the STAR*NET demo program, the windows “Notepad” editor was 
assigned as the default editor. However, if you have a text editor you would rather have 
STAR*NET to use, choose File>Set Editor to make the change: 

 

 
Browse for the editor of your choice and press OK. Note that you should normally 
refrain from using most word processors since they often insert special formatting 
characters that cannot be correctly interpreted by  the STAR*NET program. 

Input Data Files  

This section is included for users of the STAR*NET Demo Program who want to change 
the sample input data files, or create their own files. More detailed information may be 
found in the STAR*NET User's Manual, which is supplied with the purchase of the full 
STAR*NET  Standard, PLUS, PRO or LEV package. 

STAR*NET input data files are standard text that can be created with a text editor. Data 
files can also be generated as output from some another program, such as a third party 
COGO program or a data collector routine. For example, Starplus Software has 
developed several utility programs which convert from raw field files (TDS, SDR33, 
SMI, etc.) to formats used in STAR*NET. Therefore, you might often create a data file 
external to the program, and use the editing feature in STAR*NET to modify the file as 
needed. However, you can also create the entire file by hand-typing observation data 
from within the program.  

Although STAR*NET is flexible on how you can name your data files, it is suggested 
that you use “DAT” extensions for files consisting of conventional observations and 
control coordinates, and “GPS” for imported vectors. For convenience, the program 
automatically adds these extensions unless you specify otherwise. For example, if you 
create a project named “SouthPark”, the program will offer “SouthPark.dat” as a data file 
name in the Data Files dialog. 
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Several files are created during an adjustment run. Each is given the project name, but a 
different extension. Using the “SouthPark” example project name, some of the output 
files created will be SouthPark.lst, (adjustment results listing), SouthPark.pts (adjusted 
coordinate points), SouthPark.pos (adjusted geographical positions if the job was grid), 
SouthPark.gnd (if you requested a ground-scale coordinates file to be created), etc. 

Data Lines 

STAR*NET input data files are relatively free in format. Spacing on a line is up to you, 
but the order of data elements on a line must conform to STAR*NET's rules. Generally, 
lines begin with a one or two alphabetic character code identifying the type of data, 
followed by the station names and actual observations. You have seen many examples of 
these data lines in the example projects. 

For a least squares adjustment to work, coordinates (fixed or approximate) must be 
known for all stations in the network. Fortunately STAR*NET has the ability to look 
through all your data and figure out the approximate coordinates based on the actual 
angle and distance observation information in the data file. Often, however, you will 
have to enter an approximate coordinate or two to help STAR*NET get started 
calculating other approximate coordinates. For example, in the first sample project on 
page 4, we gave an approximate coordinate value for the first traverse backsight point. 
This is discussed in detail in the full STAR*NET User's Manual. 

All STAR*NET data lines follow the same general format, as shown below. 

Code Stations Observations Standard Errors 
 

The first one or two characters of a line of data form the code that defines the content of 
the line. Next comes the station name(s), followed by the observation(s) and the standard 
error(s). As explained in the STAR*NET User's Manual, the standard errors are used to 
define how much importance (weight) a particular observation will have in the 
adjustment. Normally you would simply set default standard errors for a project and not 
include them on your data lines. 

The line below defines a single distance observation with an explicit standard error: 

D TOWER-822 932.66 0.03 
 

Likewise, the line below defines a full set of 2D measurements, angle and distance, from 
one point to another plus the respective standard errors: 

M P25-12-HUB 163-43-30       1297.65 4   0.03 
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The following table lists most data types available in the STAR*NET program suite. 
These codes may be entered in upper or lower case. 

Code            Meaning 

 
# 

 
Remainder of line is a comment and is ignored 

C or CH Coordinate values for a station 

E or EH Elevation value for a station 

P or PH Geodetic Position for a station (Grid jobs only) 

A Turned Angle 

D Distance 

V Zenith Angle or Elevation Difference (3D data only) 

DV Distance and Vertical (3D Data only) 

B Bearing or Azimuth 

M Measure (Observations to another network point) 

BM Bearing Measure (Observations to another network point) 

SS Sideshot (Observations to a sideshot point) 

TB Traverse Begin  

T Traverse (All observations to next network point) 

TE Traverse End 

DB Begin Direction Set 

DN Direction 

DM Direction with Measure Data 

DE End Direction Set 

L Differential Level Data 

G GPS Vector (Professional Edition)

GH Geoid Height Value (Professional Edition)

GT Vertical Deflection Value (Professional Edition) 

 

Note that to keep this tutorial somewhat short and easy to review in a reasonable amount 
of time, all data type codes have not been illustrated in the example projects. The full 
STAR*NET documentation set that is included with software fully describes and 
illustrates all data types shown here. 
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Following the data type code on a line of data is the name of one, two or three stations 
depending on the type of data line being entered. Multiple names are separated by a dash. 
In the distance line shown on page 40, “TOWER-822” defines the FROM and TO 
stations of the distance observation. Station names may be 1 to 15 characters in length, 
although only 10 characters are shown in most of the reports. 

Next comes the actual observation (or observations) such as a distance, turned angle, 
zenith, azimuth or bearing, a direction, or coordinates for a station. Angular values may 
be entered in “D-M-S” format (123-44-55.66) or “packed” format (123.445566), the 
format commonly used by calculators. Angles may also be entered in GONS. For 
simplicity, all examples in this tutorial are shown entered in “D-M-S” format. 

Directly following the observations, you can optionally enter standard error values for 
the observations. A standard error may be entered as the actual value, as a special 
symbol, or simply left blank so that a default will be assigned. When more than one 
observation is on the line, you must either provide a standard error entry for each one, or 
leave them all out. The following table explains the various entries you can make for 
standard errors. 

 
 Entry    Explanation 

      Numeric Value  An actual Standard Error value (i.e. 0.03) 

      Nothing Entered  Defaults to the value defined in the global options 

      The "&" Symbol  Defaults to the value defined in the global options 

      The "!" Symbol  The observation is FIXED in the adjustment 

      The "*" Symbol  The observation is FREE in the adjustment 
 
 

When performing 3D adjustments, another optional entry is normally added following 
the standard error values, if any. This is the height of instrument and height of target, or 
HI/HT data entry. For example, if an HI is 5.25' and an HT is 5.73', the two values would 
be entered as a 5.25/5.73 entry. This entry is illustrated in all the 3D examples. 

Point Descriptors may be added to most data lines. Point Descriptors begin with a single 
or double quote character. These descriptors are listed with the final adjusted coordinates 
in the resulting points file. You have seen the use of these descriptors in several of the 
example projects. 

There are additional data types and data entry modes not mentioned here, which are fully 
described in the STAR*NET User’s Manual. For example, in 3D data entry, horizontal 
distances and delta elevations can be input as well as slope distances and zenith angles. 
Also, “Traverse Begin” and “Traverse End” data lines have options for backsighting and 
closing to fixed bearings. 
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The following are standard formats for most of the conventional observation data types 
that have been illustrated in this tutorial. Formats for other data types (direction sets, 
elevation differences, differential leveling, etc.) are not shown. Observations in 
parentheses are those entered for 3D data. Items in brackets are optional. 

The "C" Code: Station Coordinates 
C Station Name North   East     (Elevation) [Std Errors] 

The "A" Code: Horizontal Angle 
A At-From-To Angle [Std Error] 

The "D" Code: Distance (Slope Distance if 3D) 
D From-To Distance [Std Error] 

The "V" Code: Zenith Angle (3D Data Only) 
V From-To Zenith (HI/HT) [Std Error] 

The "B" Code: Bearing or Azimuth 
B From-To Bearing or Azimuth [Std Error] 

The "M" Code: Measurement (All Observations to Next Point) 
M At-From-To Angle    Distance    (Zenith) (HI/HT) [Std Errors] 

The "SS" Code: Sideshot (All Observations to a Sideshot Point) 
SS At-From-To Angle    Distance    (Zenith) (HI/HT)  

The "TB" Code: Traverse Begin (Backsight point) 
The "T"  Code: Traverse to Next Point (One or more data lines) 
The "TE" Code: Traverse End (Ending point) 
 
TB Backsight Station Name or Backsight Bearing 

T At Angle   Distance   (Zenith) (HI/HT) [Std Errors] 

TE End Station  [Closing Angle plus Closing Station Name or Bearing] 



 

Additional Features 

STAR*NET has many features not discussed in detail in this short tutorial including: 

 An AutoCAD DXF export tool transfers your network with ellipses, station names, 
and elevations. In addition, a Points Reformatter tool converts adjusted coordinates 
to several standard COGO formats as well as formats defined by you. 

 An “Instrument Library” facility allows you to define unlimited unique weighting 
schemes (standard errors, centering errors, PPM, etc.), and apply them anywhere in 
your network data to handle multi-instrument projects with little effort. 

 Station names may be entered as alpha-numeric and up to 15 characters in length. A 
sorting option causes them to be listed in the coordinate files by name, or in order of 
their first encounter. Another sorting option causes adjusted observations to be 
sorted either by name or by residual size – useful for debugging a network. 

 An inline “UNITS” option converts input observations on the fly. For example, 
change observed values in Meters to US Feet, or visa versa. Many other inline data 
options are available for changing input modes within data files. For example, 
change mode from slope distance/zenith mode to horizontal distance and elevation 
difference. Change refraction index, change scale factor, etc. 

 Internal reduction of 3D field data during an adjustment for those who wish to run a 
horizontal adjustment only, but retain the original data as 3D for future use. 

 A special option causes the program to create a scaled-to-ground coordinate file. 
Converts adjusted grid coordinates back to ground for construction work. 

 A “Positional Tolerance” checking feature to satisfy relative position specification 
requirements set forth by the ACSM/ALTA committee and other agencies. 

 A “Map Mode” data entry option makes it easy to combine “already-reduced” 
traverse information from record maps with field observations in a GIS network. 
Maps with different “basis of bearings” can are combined by automatic conversion 
of adjacent bearings into “neutral” turned angles. 

 Add differential leveled observations to conventional and GPS vector observations in 
a 3D adjustment to add to the confidence of your resulting elevations. 

 In the “Professional” edition, flexible weighting options relating to GPS allow for 
easy integration of vectors with conventional observations. Full geoid and deflection 
modeling can be performed during the network adjustment as well as manual 
definition of geoid heights and vertical deflections at individual stations. 
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