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AC4.1 RentalPoint to MYOB Data Export/Import 

Australian Application  
 

RentalPoint Software is designed to interface with popular accounting systems including MYOB software, 
providing an efficient and reliable data transfer of customer and account information. Once configured, the 

RentalPoint export function is very easy to use and will allow accounting staff to enter payments directly into 
MYOB. 
 

RentalPoint Software Requirements : RentalPoint Version 9.0 or higher 
 

MYOB Software Requirements 
 
: 

 
MYOB Accounting V15+ or MYOB Premier V8+ 

 

How the RentalPoint to MYOB Export /Import works 
 
When you activate the exporting feature in RentalPoint, the system will keep track of any invoice and the 

customer information you create, including any re-invoices of a booking which will automatically generate a credit 
and a new invoice. 

 

You can run the Accounts Export command which is conveniently located in the RentalPoint Others menu at 
any point in time. RentalPoint will export the Customer Card information, followed by the Service Sales Invoice 

information that needs to be imported into MYOB.  
 

When the RentalPoint invoice information is imported into MYOB, the invoices will appear in MYOB as Service Sale 

Invoices. The MYOB summary invoice includes the rental/hire amount, the delivery/pickup amount, the labour 
amount, the sales amount, the sundry amount and the insurance/damage waiver amount. If some of these fields 

are not used in your system, then these amount will not appear in your RentalPoint system. 
 

In addition to importing your invoice files, the MYOB import procedure can also be configured to capture and 

update customer details such as a change of billing address, phone numbers or contact person. RentalPoint sales 
or front counter staff would update the RentalPoint customer files at the point of sale as and when required. This 

information is then imported and saved to the MYOB customer card/s with the information coming from 
RentalPoint.  

 
RentalPoint will only export invoices and customer transactions from the date you setup the exporting information 

and restart RentalPoint on each workstation. Because of this you may want to start this export from the 1st of a 

month or financial period. The system cannot export transactions created prior to the Export activation date.  
 

With easy to follow prompts to guide the operator along the way, you can be sure of a successful export and 
import of your account information each and every time.  

 

 
 Whenever you run a successful RentalPoint Accounts Export command you MUST import this information 
into MYOB immediately. It is imperative for the financial records that when you do an export from 

RentalPoint, that you do an import into MYOB immediately. 
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MYOB Information Required For RentalPoint Export 
 

You will need to obtain the following General Ledger account numbers from your MYOB system in order to set up 

the MYOB Export in RentalPoint. 
 

The GL account numbers have to come from your MYOB accounts system and you may, or may not need all of 
these account numbers, depending on how you use RentalPoint. 
 
 

 Rental Income Account 
 Sales/Disposables Income Account 

 Losses Income Account 
 Delivery Income Account 

 Labour Account 

 Sundry Account 
 Insurance / Damage Waiver Account 

 Sale of Assets Account 
 Discounts Account 

 Production Income Account 

 Credit Card Surcharge Account 
 
 

 
If you require further assistance, we recommend you speak with your Head of Finance or Accountant, as 

our RentalPoint support staff would require a copy of your MYOB data file in order to assist you. 
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RentalPoint Configuration for Exporting Account Information  
 
STEP 1  
 
To setup the MYOB Export information select the Setup>Parameters from the RentalPoint main Menu. 
 

 
 

 
Click on the Accounts button.  
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STEP 2  
 
To open the Setup Account Export Screen, key 21 in the Go to Parameter field or scroll down to item 21 as 
shown below.  Double click on 21. Export Parameters or click Select to open it. 
 

 

 
 
STEP 3  
 
The Setup Account Export screen is where your RentalPoint account information and export file names are 

configured. 
 

 
The Package by Location If you are running a RentalPoint multi-location system you can choose to export 

your data as a whole or by location. In a single location system you will not see 

this prompt, if you are using a Multi-location system and want to export by 
location set to ON. 

 
Accounting Package If you use MYOB V15 then you would select MYOB Australian Ver, Single 

User.  If you use MYOB Premier V8 then you would select MYOB Australian 

Ver, Multi User. 
 

MYOB Australian Version 
Export Path 

Enter the location of where you want the exported files copied to in the field 
provided. You can either type this information in manually or click the browse 

button and use the windows explorer type interface to select the directory you 
want. This directory can be on a local machine or on a network drive.  

 
MYOB Australian Version 
Filenames 

Enter the three file names in the fields provided. In the example below we have 
entered three basic, abbreviated file names you could use, however you can 

choose what you want these to be called.  
The files will be exported in a CSV (Comma Separated Value) format file which 

would normally have a “.CSV” extension. We suggest using a “.TXT” extension as 

shown, due to the fact that MYOB defaults to a TXT extension, rather than a CSV 
extension. There is no reason why it can‟t be a CSV extension it just means less 

keystrokes are required when importing into MYOB if it is a .TXT extension. 
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Tax Codes The Tax Codes setup should be as shown in the example below unless you have a 
non-standard setup in MYOB. 

  
The tax code for GST that is setup in MYOB needs to be entered here. This would 

simply be „GST‟ as shown below in a standard MYOB file. The second field is the 

MYOB Tax Code for a „Tax Free‟ transaction. This could be „FRE‟ or „N-T‟ 
depending on the tax code used in your MYOB data file. The default of „FRE‟ 

would normally be adequate for most systems. 
 

Stamp Duty Hire Tax By clicking on the drop down box you will be presented with taxes that are setup 

in RentalPoint. Select the tax that relates to Stamp Duty. If you do not charge 
Stamp Duty, then select either „none‟ or „exempt‟ as shown in your system. 

 
Discount / Charge The Discount / Charge options are to be filled in if you offer these facilities 

otherwise just leave them at Zero as this will save you getting warnings from 
MYOB when you go to import the transaction information. 

 
MYOB Australian Address 
Export 

Select your preferred address export option. You can choose to export the street 
address or postal address first. 
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Note if you use the incorrect Accounting Package Version, I.E. Use the Single User version on a multi-user 
version of the software or vice versa, then you will get errors on importing. 

 
 

You have now configured the Account Export options. Click the Close button and click YES to confirm and save 

changes to the Account Export Parameters.  
 

 
 

 
The following prompt will appear to confirm the information has been saved. Click OK and return to the Select 

Parameters screen. 
 

 
 

 

STEP 4  
 

To set up the MYOB GL accounts in RentalPoint, key 22 in the Go to Parameter field or scroll down to item 22 

as shown below.  Double click on this item or click Select to open it.  
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If you are using a RentalPoint Multi-location system you have the option to set up different GL Accounts for each 
Location.  Click Yes or No on the pop up window depending on your system and business requirements. Then 

click OK to continue to the G/L accounts numbers screen. 

 

STEP 5  
 

Enter the GL account numbers gathered from your MYOB system as per the example shown below. When this is 

done press the  button to save the information and click Close to exit this screen.  
 

 
 

 

RentalPoint Multi-Location users can use the drop down selection box located at the top of the screen. 
Select locations to edit the GL account numbers for each location. 

 
 

 RentalPoint Multi-Location users can click the All Locations button to copy the GL numbers on the screen 
displayed, to all locations set up in RentalPoint. 
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STEP 6  

Click Close on the Select Parameters screen and then click the  button in the main Parameter 

Set up screen. 
 

 

STEP 7  
 

You need to restart RentalPoint before it will start to use the settings that you have just entered. 
 

Click OK on the information prompt and restart RentalPoint on each workstation. RentalPoint will then start to log 
all the invoice and customer information, as you print invoices from it. 
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RentalPoint Export Process 
 

It is recommended that you do a test export/import. With the RentalPoint to MYOB Export/Import feature 

activated, RentalPoint will now start to collect customer and invoice information as you print invoices.  
 

STEP 1.  
 

Print at least two invoices from within RentalPoint. 

 
 

STEP 2  
 
Open the Account Export screen by selecting Others>Import/Export>Export Accounts from the 

RentalPoint main Menu.  
 

 
 
 
STEP 3  
 

You will be asked to confirm which MYOB system you are running. If you have setup RentalPoint for the Multi-

user version of MYOB, then it will say MYOB Multi User. If you have setup RentalPoint for a Single user version 
it will say MYOB Single User, as shown below.  

 
You can click NO and nothing will be exported, otherwise click YES to proceed and the MYOB invoice file will be 

exported.  
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If the invoice and customer file can be created, the prompt below be will displayed. Click OK to proceed. 
 

 
 

If there is no information to be exported then the prompt below will be displayed. This means that there have not 
been any invoices created since the last export was done. Simply click OK so that you can continue working in 

RentalPoint. 

 
 

Invoices are only exported from RentalPoint once. 
 

 

RentalPoint will create the relevant files in the export directory folders that you created earlier. The date 
and time will be inserted as the date and time that the export files were created and will be added at 

the end of each the file names automatically.  
 

As per the previous example in step 3, the customer file will be called RPCUST-Date-Time.TXT and 
the invoice file will be called RPINV-Date-Time.TXT. These files are found in the C:\RP-

DEMO\Aus-DEV\AUS-DEV-Accounts folder on this system. 
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MYOB Import Process 
 

MYOB Accounting V15+ and MYOB Premier V8+ uses the same process to import RentalPoint Invoice and 

Customer files. The difference is in the make up the exported files, as both versions have slightly different import 

file requirements. 
 
You must import the RentalPoint customer file before you import the RentalPoint invoice file, otherwise you may 
try to import invoices for a customer that doesn’t yet exist in MYOB and you will receive errors from MYOB. 

 
 

STEP 1  
 
To import the RentalPoint Customer File into MYOB, open MYOB and select File>Import Data>Cards> 

Customer Cards from the main menu. This will open the Import File screen. 
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STEP 2  
 

Select the following setting in the Customer Import File screen.  
 

Import File Format This needs to be set to Comma-separated 

 
First Record is Select Header Record, this is the MYOB default selection 

 
Duplicated Records You have the option to choose how you want to manage duplicate records. 

We suggest you set this to Update Existing Record as this will then take 

the information from RentalPoint and update the MYOB record.  
 

Identify Records by If you already have some of your customer records in MYOB this should be 
set to Co./Last Name as you will not have the Card ID field set in your 

MYOB records (which is the Customer Code from RentalPoint).  
 
**If you have the customer name set in RentalPoint as “The ABC Company” 
but have it setup in MYOB as “ABC Company” when you import this 
information MYOB will create a new customer card. Unless you are importing 
by Card ID. 
 

 If you are setting up a new system and have already set the Card ID in 

MYOB to match RentalPoint customer code fields, you may choose to import 
by Card ID. 

 
 

 
 
 

Click the Continue button.  
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STEP 3 
 

MYOB will display an Explorer window that allows you to find the Customer File that RentalPoint created. Browse 
to the required directory and highlight the Customer file and click Open. 

 

 
 
 

The following screen is displayed.  
 

 
 
 

STEP 4 
 

Click Match All then click Import. 
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MYOB will import the records and a screen will be displayed showing you how many records were imported 
without errors, how many records were skipped and how many records were imported with warnings.  

 

 
 

Click OK to continue, you are now ready to import the invoice/transaction information. 
 

If there are any records that are imported with warnings and/or records skipped you will need to send the 
file information to RentalPoint for further assistance. MYOB creates a log file that is located in the MYOB 

directory called MYOBLOG.TXT for Version 15 and MYOBPLOG.TXT for Premier V8. Please send this file as well as 
your original files that you are trying to import to myobhelp@rentalpoint.com . 
 
STEP 5 
 
To import the Invoices file select File>Import Data>Sales>Service Sales from the MYOB main menu. 

 

 

mailto:myobhelp@rentalpoint.com
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STEP 6  
 
Select the following Service Sales settings in the Import File screen.  
 

 

Import File Format This needs to be set to Comma-separated. 
 

First Record is Select Header Record, this is the MYOB default selection. 
 

Duplicated Records You have the option to choose how you want to manage duplicate records. 

We suggest you set this to Add Them.  
 

**The MYOB default is Reject them. In some instances, this may need to 
be set on each import. 
 

Identify Records by If you already have some of your customer records in MYOB this should be 

set to Co./Last Name as you will not have the Card ID field set in your 

MYOB records which is the Customer Code from RentalPoint.  
 
**If you have the customer name set in RentalPoint as “The ABC Company” 
but have it setup in MYOB as “ABC Company” when you import this 
information MYOB will create a new customer card. Unless you are importing 
by Card ID. 
 

 
 

 
 

 
Click the Continue button 
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STEP 7  
 

Similar to importing the Customer File information, MYOB will bring up an Explorer type screen that allows you to 
find the Invoice File that RentalPoint created. Browse to the required directory, highlight the appropriate file and 

click Open. 

 

 
 

 
STEP 8 
 

The following screen is displayed.  Click Match All then click Import . 
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MYOB will import the records and a screen will be displayed showing you how many records were imported 

without errors, how many records were skipped and how many records were imported with warnings.  
 

 
 
 

If there are any records that are imported with warnings and/or records skipped you will need to send the 
file information to MYOB for further assistance. MYOB creates a log file that is located in the MYOB 

directory called MYOBLOG.TXT for Version 13.5/14 and MYOBPLOG.TXT for Premier V8. Please send this file as 
well as your original files that you are trying to import to myobhelp@rentalpoint.com . 
 
Click OK and the import procedure is now complete 

 
 

 

 
 

 
 

 

 
 

 
 

 
 

 

 
 

 
 

 

 
 

 
 

 
 
Any questions or feedback? Please email training@rentalpoint.com putting the module reference number 
and name in the Subject line of your email. EG: AC4.2 RentalPoint to MYOB Data Export/Import. 
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