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4 ANIMATING SYMBOLS 

Lesson Overview 

In this lesson, you’ll learn how to do the following: 

• Animate the position, scale, and rotation 
of objects 

• Adjust the pacing and timing of your animation 

• Animate transparency and special effects 

• Change the path of an object’s motion 

• Create nested animation 

• Split a motion tween 

• Change the easing of an object’s motion 

• Animate in 3D space 

This lesson will take about two hours to complete. Please log in to your 
account on peachpit.com to download the lesson files for this chapter, or 
go to the Getting Started section at the beginning of this book and follow 
the instructions under “Accessing the Lesson Files and Web Edition.” 
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Use Adobe Animate CC to change almost any aspect 
of an object—position, color, transparency, size, rota- 
tion, and more—over time . Motion tweening is the 
basic technique of creating animation with symbol 
instances . 
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● Note If you have not 
already downloaded 
the project files for 
this lesson to your 
computer from your 
Account page, make 
sure to do so now . See 
“Getting Started” at the 
beginning of the book . 

Getting Started 
Start by viewing the finished movie file to see the animated title page that you’ll 
create in this lesson. 

1 Double-click the 04End.mp4 file in the Lesson04/04End folder to play the final 
animation, which was exported as a video file. 

 
 

The project is an animated opener that would be placed on a website for an 
imaginary soon-to-be-released motion picture. In this lesson, you’ll use motion 
tweens to animate several components on the page: the cityscape, the main 
actors, several old-fashioned cars, and the main title. 

2 Close the 04End.mp4 file. 

3 Double-click the 04Start.fla file in the Lesson04/04Start folder to open the initial 
project file in Animate. This file is an ActionScript 3.0 document that is partially 
completed and already contains many of the graphic elements imported into the 
library for you to use. You’ll use all the animation functionality available in an 
ActionScript 3.0 document, but instead of using the Flash Player for playback in 
a browser, you’ll export an MP4 video file. 

4 From the view options above the Stage, choose Fit In Window, or choose View > 
Magnification > Fit In Window, so that you can see the entire Stage on your 
computer screen. 

5 Choose File > Save As. Name the file 04_workingcopy.fla, and save it in the 
04Start folder. 

Saving a working copy ensures that the original start file will be available if you 
want  to  start over. 
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About Animation 
Animation is the movement, or change, of objects through time. Animation can be 
as simple as moving a box across the Stage from one frame to the next. It can also 
be much more complex. As you’ll see in this lesson, you can animate many different 
aspects of a single object. You can change an object’s position on the Stage, change 
its color or transparency, change its size or rotation, or animate the special filters 
that you saw in the previous lesson. You also have control over an object’s path of 
motion and even its easing, which is the way an object accelerates or decelerates. 

In Animate, the basic workflow for animation goes like this: Select an object on the 
Stage, right-click, and choose Create Motion Tween from the context menu. Move 
the red playhead to a different point in time and move the object to a new position 
or change one of its properties. Animate takes care of the rest by smoothly interpo- 
lating the changes between the two points in time. 

Motion tweens create animation for changes in position on the Stage and for 
changes in size, color, or other attributes. Motion tweens require you to use a 
symbol instance. If the object you’ve selected is not a symbol instance, Animate will 
automatically ask to convert the selection to a symbol. 

Animate also automatically separates motion tweens onto their own layers, which 
are called tween layers. There can be only one motion tween per layer, and there 
can be no other element on the layer. Tween layers allow you to change various 
attributes of your instance at different key points over time. For example, a space- 
ship could be on the left side of the Stage at the beginning keyframe and at the far- 
right side of the Stage at an ending keyframe, and the resulting tween would make 
the spaceship fly across the Stage. 

The term “tween” comes from the world of classic animation. Senior animators 
would be responsible for drawing the beginning and ending poses for their char- 
acters. The beginning and ending poses were the keyframes of the animation. 
Junior animators would then come in and draw the “in-between” frames, or do 
the “in-betweening.” Hence, “tweening” refers to the smooth transitions between 
keyframes. 

 
Understanding the Project File 
The 04Start.fla file contains a few of the animated elements already or partially 
completed. Each of the six layers—man, woman, Middle_car, Right_car, footer, and 
ground—contains an animation. The man and woman layers are in a folder called 
actors, and the Middle_car and Right_car layers are in a folder called cars. 
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You’ll be adding more layers to create an animated 
cityscape, refining the animation of one of the actors 
and adding a third car and a 3D title. All the neces- 
sary graphic elements have been imported into the 
library. The Stage is set at 1280 pixels by 787 pixels, 
and the Stage color is black. You might need to choose 
a different view option to see the entire Stage. Choose 
View > Magnification > Fit In Window, or choose 
Fit In Window from the view options at the upper- 
right corner of the Stage, to view the Stage at a magnification percentage that fits 
your screen. 

 
Animating Position 
You’ll start this project by animating the cityscape. It will begin slightly lower than 
the top edge of the Stage and then rise slowly until its top is aligned with the top 
of the Stage. 

1 Lock all the existing layers so you don’t accidentally modify them. Create a new 
layer above the footer layer and rename it city. 
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2 Drag the bitmap image called cityBG.jpg from the bitmaps folder in the Library 
panel to the Stage. 

 

 

3 In the Properties panel, set the value of X to 0 and the value of Y to 90. 
 

 

This positions the cityscape image just slightly below the top edge of the Stage. 

4 Right-click the cityscape image and choose Create Motion Tween, or choose 
Insert > Motion Tween. 
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5 A dialog box appears warning you that your selected object is not a symbol. 
Motion tweens require symbols. Animate asks if you want to convert the 
selection to a symbol so it 
can proceed with the motion 
tween. Click OK. 

Animate automatically 
converts your selection to 
a symbol, with the default name Symbol 1, and stores it in your Library panel. 
Animate also converts the current layer to a tween layer so you can begin to 
animate the instance. Tween layers are distinguished by a special icon in front 
of the layer name, and the frames are tinted blue. The range of frames covered 
by the tween is the tween span. The tween span is represented by all the colored 
frames from the first keyframe to the last keyframe. Tween layers are reserved 
for motion tweens; hence, no drawing is allowed on a tween layer. 

 

 

6 Move the red playhead to the end of the tween span, at frame 191. 

7 Select the instance of the cityscape on the Stage, and while holding down the 
Shift key, move the instance up the Stage. 

Holding down the Shift key constrains the movement to right angles. 

8 For more precision, set the value of Y 
to 0 in the Properties panel. 

A small black diamond appears in 
frame 191 at the end of the tween span. 
This indicates a keyframe at the end of 
the tween. 

Animate smoothly interpolates the 
change in position from frame 1 to frame 191 and represents that motion with a 
motion path on the Stage. 

 

128  LESSON 4    ANIMATING SYMBOLS 



From the Library of Alvaro Alvarez  

9 Drag the red playhead back and forth at the top of the Timeline to see the 
smooth motion. You can also choose Control > Play (or press Enter/Return) to 
make Animate play the animation. 

Animating changes in position is simple because Animate automatically creates 
keyframes at the points where you move your instance to new positions. If you 
want to have an object move to many different points, simply move the red 
playhead to the desired frame and then move the object to its new position. 
Animate takes care of the rest. 

 
Preview the animation 
Integrated into the bottom of the Timeline is a set of playback controls. These 
controls allow you to play, rewind, or go step by step backward or forward through 
your Timeline to review your animation in a controlled manner. You can also use 
the playback commands on the Control menu. 

1 Click any of the playback buttons on the controller below the 
Timeline to go to the first frame, go to the last frame, play, stop, 
or move forward or backward one frame. 

2 Select Loop option (to the right of the controller), and then click the Play 
button. 

The playhead loops, allowing you to see the 
animation over and over for careful analysis. 

3 Move the start or end markers in the Timeline 
header to define the range of frames that you want 
to see looped. 

The playhead loops within the marked frames. 
Click Loop Option again to turn it off. 

 
Changing the Pacing and Timing 
You can change the duration of the entire tween span or change the timing of the 
animation by dragging keyframes on the Timeline. 

Changing the animation duration 
If you want the animation to proceed at a slower pace (and thus take up a much 
longer period of time), you need to lengthen the entire tween span between the 
beginning and end keyframes. If you want to shorten the animation, you need to 
decrease the tween span. Lengthen or shorten a motion tween by dragging its ends 
on the Timeline. 

� Tip Hide all the 
other layers to isolate 
the cityscape and to 
better see the results of 
the motion tween . 

 

� Tip Remove a 
motion tween by 
right-clicking the 
motion tween on the 
Timeline or the Stage 
and choosing Remove 
Tween . 

 
 
 
 
 
 
 
 
 
 
 
 
� Tip  You can also 
use the Time Scrub tool 
(hidden under the Hand 
tool) to move back and 
forth on the Timeline to 
preview your animation . 
Choose the Time Scrub 
tool (or hold down 
Spacebar+T) and drag 
back and forth on the 
Stage . 
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1 Move your mouse pointer close to the end of the tween span in the city layer. 

Your pointer’s cursor changes to a double-headed 
arrow, indicating that you can lengthen or shorten the 
tween span. 

2 Drag the end of the tween span back to frame 60. 

Your motion tween shortens to 60 frames, reducing the 
time it takes the cityscape to move. 

 

3 Move your mouse pointer close to the beginning of the tween span (at frame 1). 
 

 

 
 
 
 
 
● Note If you have 
multiple keyframes in 
a tween, changing the 
length of the tween 
span by dragging 
one end or the other 
will distribute all your 
keyframes uniformly . 
The timing of your 
entire animation 
remains the same; only 
the length changes . 

4 Drag the beginning of the frame span forward to frame 10. 

Your motion tween begins at an earlier time, so it now plays only from frame 10 
to frame 60. 

 

 
 
Adding frames 
You’ll want the last keyframe of your motion tween to hold for the remainder of the 
animation. Add frames by Shift-dragging the end of a tween span. 

1    Move your mouse cursor close to the end of the tween span. 
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2   Hold down the Shift key and drag the end of the tween span forward to frame 191. 
 

 

The last keyframe in the motion tween remains at frame 60, but Animate adds 
frames through frame 191. 

 
 
 

� Tip You can also 
add individual frames 
by choosing Insert > 
Timeline > Frame (F5), 
or remove individual 
frames by choosing 
Edit > Timeline > 
Remove Frames 
(Shift+F5) . 

 
 

Moving keyframes 
If you want to change the pacing of an animation, you can select individual 
keyframes and then drag them to new positions. 

1 Click the keyframe at frame 60. 

The keyframe at frame 60 is selected. A tiny box appears 
next to your mouse pointer, indicating that you can move 
the keyframe. 

2 Drag the keyframe to frame 40. 

The last keyframe in the motion tween moves to frame 40, 
so the motion of the cityscape proceeds more quickly. 
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132  LESSON 4    ANIMATING SYMBOLS 

Span-based vs. frame-based 
selection 
By default, Animate uses frame-based 
selection, which means you can select 
individual keyframes within a motion 
tween . However, if you prefer to click a 
motion tween and have the entire span 
(the beginning and end keyframes, and all 
the frames in between) be selected, you 
can enable Span Based Selection from the 
Options menu on the upper-right corner of 
the Timeline (or you can Shift-click to select 
the entire span) . 

With Span Based Selection enabled, you can click anywhere within the motion 
tween to select it, and move the whole animation backward or forward along the 
Timeline as a single unit . 

If you want to select individual keyframes while Span Based Selection is enabled, 
hold down the Ctrl/Command key and click a keyframe . 

Moving keyframes vs. changing 
time in tween spans 
Managing the timing of your animation by moving keyframes and stretching or 
squashing tween spans can sometimes be frustrating because you will get different 
outcomes depending on what you’ve selected on the Timeline and how you drag 
those selections . 

If you want to simply move the location of a keyframe within a tween span, make 
sure that only a single keyframe is selected, and that the tiny box appears next to 
your mouse cursor before you begin dragging the keyframe to a new location . 

If you want to select individual keyframes while Span Based Selection is enabled, 
hold down the Ctrl/Command key and click a keyframe . 

Consider the following animation, where a ball moves from the left side of the Stage 
to the bottom edge and then to the right side, making a figure “V .” On the Timeline, 
three keyframes mark the three positions of the ball . 
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Moving the middle keyframe changes the timing of when the ball hits the bottom 
of the Stage . 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Keyframe moved Box 
 

When you select a span of frames within a tween, you can compress or expand its 
duration by dragging the selection when the double-headed arrow appears near 
the right edge of the selection . 

 
 
 
 

Group of frames selected 
 
 
 
 
 

Selected frames expanded 
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Selected frames compressed 
 
 
 
 
 

Final result: motion tween split 
 

Finally, a double-headed arrow with a vertical break indicates that you can change 
the position of the separation between two different tweens . 

Understanding frame rate 
The speed of your animation is tied to the frame rate of your document (shown in 
the Properties section of the Properties panel), but do not modify the frame rate in 
order to change the speed or duration of your animation . 

The frame rate determines how many frames 
on the Timeline make up one second of time . 
The default is 24 frames per second (fps) . The 
seconds are marked on the Timeline . Frame 
rate is a measure of how smooth an anima- 
tion appears—the higher the frame rate, the 
more frames there are to show the action . 
Animations at slower frame rates appear 
choppy because there are fewer frames to 
show the action . Slow-motion videography 
depends on very high frame rates in order 
to capture action that happens very quickly, 
such as a speeding bullet or a falling water 
droplet . 

If you want to modify the overall duration or 
speed of your animation, don’t change the 
frame rate . Instead, add or delete frames from your Timeline . 

If you want to change the frame rate but keep the overall duration constant, select the 
Scale Frame Spans option in the Properties panel before you modify the frame rate . 
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Animating Transparency 
In the previous lesson, you learned how to change the color effect of any symbol 
instance to change the transparency, tint, or brightness. You can change the color 
effect of an instance in one keyframe and change the value of the color effect in 
another keyframe, and Animate will automatically display a smooth change, just as 
it does with changes in position. 

You’ll change the cityscape in the beginning keyframe to be totally transparent but 
keep the cityscape in the ending keyframe opaque. Animate will create a smooth 
fade-in effect. 

1 Move the red playhead to the first keyframe of the motion tween (frame 10). 
 

 

2 Select the cityscape instance on the Stage. 

3 In the Color Effect section of the Properties panel, choose Alpha from the 
Style menu. 

 

4 Set the Alpha value to 0%. 
 

 

The cityscape instance on the Stage becomes totally transparent. 
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5 Move the red playhead to the last keyframe of the motion tween (frame 40). 
 

6 Make sure that the cityscape instance on the Stage is still selected. 

7 In the Properties panel, in the Color Effect section, set the Alpha value to 100%. 

The cityscape instance on the Stage becomes totally opaque. 

 

8 Preview the effect by choosing Control > Play (or pressing Enter/Return). 

Animate interpolates the changes in both position and transparency between 
the two keyframes. 
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Animating Filters 
Filters, which give instances special effects such as blurs and drop shadows, can 
also be animated. You’ll next refine the motion tween of the actors by apply- 
ing a blur filter to one of them to make it appear as if the camera changes focus. 
Animating filters is no different from animating changes in position or changes in 
color effect. You simply set the values for a filter at one keyframe and set different 
values for the filter at another keyframe, and Animate creates a smooth transition. 

1 Make sure that the actors layer folder on the Timeline is visible. 

2 Unlock the woman layer. 

3 Move the red playhead to the beginning keyframe of the motion tween in the 
woman layer, at frame 23. 

 
 
 
 
 
 
● Note Filters can 
not be animated in 
an HTML5 Canvas 
document . 

 

 
 

4 Select the instance of the woman on the Stage. You won’t be able to see her 
because she has an alpha value of 0% (totally transparent). Click the upper- 
right side of the Stage to select the transparent instance. Or, click the woman 
layer in the Timeline to highlight it; then click within the outline that appears 
on the Stage. 
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5 In the Properties panel, expand the Filters section. 

6 Click the Add Filter (+) button in the 
Filters section, and choose Blur from the 
menu to add a blur to the instance. 

7 In the Filters section of the Properties 
panel, make sure that the link icons are 
selected in order to apply equal values to 
the x and y directions. Set the Blur X value 
to 20 pixels. 

The Blur Y value also changes to 20 pixels. 

8 Move the red playhead across the entire 
Timeline to preview the animation. 

The woman instance is blurred throughout 
the motion tween. 

 

9 Right-click the woman layer at frame 140, and choose Insert Keyframe > Filter. 
 

 

Animate establishes a keyframe for filters at frame 140. 
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10 Move the red playhead to frame 160, right-click the woman layer, and choose 
Insert Keyframe > Filter to add another filter keyframe. 

 

 

11 Select the instance of the woman on the Stage at frame 160. 

12 In the Properties panel, change the value of the Blur filter to X=0 and Y=0. 

The Blur filter changes from the keyframe at frame 140 to the keyframe at 160. 
Animate creates a smooth transition from a blurry instance to an in-focus instance. 
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Understanding property keyframes 
Changes in properties are independent of one another and do not need to be 
tied to the same keyframes . That is, you can have a keyframe for position, a different 
keyframe for the color effect, and yet another keyframe for a filter . Managing many 
different kinds of keyframes can become overwhelming, especially if you want dif- 
ferent properties to change at different times during the motion tween . Fortunately, 
Animate CC provides a few helpful tools for keyframe management . 
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Animating Transformations 
Now you’ll learn how to animate changes in 
scale or rotation. These kinds of changes are 
made with the Free Transform tool or with 
the Transform panel. You’ll add a third car to 
the project. The car will start small, and then 
become larger as it appears to move forward 
toward the viewer. 

1 Lock all the layers on the Timeline. 

2 Insert a new layer inside the cars folder, 
and rename it Left_car. 

3 Select frame 75 and insert a new 
keyframe (F6). 

4 Drag the movie clip symbol called carLeft 
from the Library panel to the Stage at 
frame 75. 
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When viewing the tween span, you can choose to view the keyframes of only 
certain properties . For example, you can choose to view only the Position keyframes 
so that you can see when your object moves . Or, you can choose to view only the 
Filter keyframes so that you can see when a filter changes . Right-click a motion 
tween in the Timeline, choose View Keyframes, and then select the desired property 
from the list . You can also choose All or None to see all the properties or none of the 
properties . 

 
 
 
 
 
 
 
 
 
 
 

When inserting a keyframe, you can also insert a keyframe specific to the property 
you want to change . Right-click a motion tween in the Timeline, choose Insert 
Keyframes, and then select the desired property . 

You can also view an advanced panel, called the Motion Editor, to see and edit how 
the different properties of your object change over the course of the motion tween . 
You’ll learn more about the Motion Editor in the next lesson . 
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5 Select the Free Transform tool. 

The transformation handles appear around the instance on the Stage. 
 

 

6 While holding down the Shift key, drag a corner handle inward to make the 
car smaller. 

7 In the Properties panel, make sure that the width of the graphic is about 
400 pixels. 

Alternatively, you can use the Transform panel (Window > Transform) and 
change the scale of the car to about 29.4%. 

8 Move the car to its starting position at about X=710 and Y=488. 
 

 

9 In the Properties panel, in the Color Effect section, choose Alpha from the 
Style menu. 
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10 Set the Alpha value to 0%. 
 

 

The car becomes totally transparent. 

11 Right-click the car on the Stage and choose Create Motion Tween. 

The current layer becomes a tween layer. 

12 Move the red playhead on the Timeline to frame 100. 
 

 

13 Select the transparent instance of the car on the Stage, and in the Properties 
panel, change the Alpha value to 100%. 

A new keyframe is automatically inserted at frame 100 to indicate the change in 
transparency. 

14 While holding down the Shift key, drag a corner handle outward to make the 
car larger. For more precision, use the Properties panel and set the dimensions 
of the car to width=1380 pixels and height=445.05 pixels. 

15 Position the car at X=607 and Y=545. 
 

 

You have used Animate to tween the change in position and the change in scale 
as well as the change in transparency from frame 75 to frame 100. 

 
 

142  LESSON 4    ANIMATING SYMBOLS 



From the Library of Alvaro Alvarez  

16 Move the Left_car layer in between the Middle_car and Right_car layers so that 
the car in the center overlaps the cars on the side. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Save your progress so far in this document, 04_workingcopy.fla. In the next 
section, you’ll work with a different file. 

 
Changing the Path of the Motion 
The motion tween of the left car that you just animated shows a colored line with 
dots indicating the path of the motion. You can easily edit the path of the motion 
to make the car travel in a curve, or you can move, scale, or rotate the path just like 
any other object on the Stage. 

To better demonstrate how you can edit the path of the motion, open the sample file 
04MotionPath.fla in the Lesson04/04Start folder. The file contains a single tween layer 
with a rocket ship moving from the top left of the Stage toward the bottom right. 

� Tip Holding down 
the Alt/Option key 
while dragging one 
corner handle of the 
bounding box causes 
the box to resize 
relative to the opposite 
corner rather than 
relative to the object’s 
transformation point 
(usually the center) . 
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Moving the path of the motion 
You will move the path of the motion so that the relative movement of the rocket 
ship remains the same but its starting and ending positions change. 

1 Select the Selection tool. 

2 Click the path of the motion to select it. 

The path of the motion becomes highlighted. 
 

3 Drag the motion path to move it to a different place on the Stage. 

The relative motion and timing of the animation remain the same, but the 
starting and ending positions are relocated. 

 
Changing the scale or rotation of the path 
You can also manipulate the path of the object’s motion using the Free 
Transform tool. 

1 Select the path of the motion. 

2 Select the Free Transform tool. 
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Transformation handles appear around the path of the  motion. 
 

 

3 Scale or rotate the path of the motion as desired. You can make the path smaller 
or larger, or rotate the path so that the rocket ship starts from the bottom left of 
the Stage and ends at the top right. 

 

 
Editing the path of the motion 
Making your objects travel on a curved path is a simple matter. You can edit the 
path with Bezier precision using anchor point handles, or you can edit the path 
in a more intuitive manner with the Selection tool. 

1    Select the Convert Anchor Point tool, which is hidden under the Pen tool. 
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2 Click the starting point or the ending point of the motion path on the Stage, and 
drag the control handle out from the anchor point. 

 

 

 
 
 
 
 
 

� Tip You can also 
directly  manipulate 
the path of the motion 
with the Selection tool . 
Select the Selection tool 
and make sure the path 
is deselected . Move 
your pointer close to 
the path of the motion . 
A curved icon appears 
next to your pointer, 
indicating that you can 
edit the path . Drag the 
path of the motion to 
change its curvature . 
Choose the spots where 
you drag carefully! Each 
drag breaks the path 
into smaller segments, 
making it harder to 
achieve a smooth curve . 
Mastery will come with 
practice . 

The handle on the anchor point controls the curvature of the path. 

3 Select the Subselection tool. 

4 Drag the handle at each end of the path to edit its curve. Make the rocket ship 
travel in a wide curve. 

 

 

 

Orienting objects to the path 
Sometimes the orientation of the object traveling along the path is important. In 
the motion picture promotional project, the orientation of the car is constant as it 
moves forward. However, in the rocket ship example, the rocket ship should follow 
the path with its nose pointed in the direction in which it is heading. Orient To 
Path in the Properties panel gives you this option. 
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1 Select the motion tween on the Timeline (Shift-click to select the whole tween). 

2 In the Properties panel, under Rotation, select the Orient To Path  option. 
 

 

Animate inserts keyframes for rotation along the motion tween to orient the 
nose of the rocket ship to the path of the motion. 

 

 

 
 
 

� Tip To direct the 
nose of the rocket ship, 
or any other object, 
along the path of its 
motion, you must 
orient its position so 
that it is facing in the 
direction that you want 
it to travel . Use the 
Free Transform tool to 
rotate its initial position 
so that it is oriented 
correctly . 

 
 

Swapping Tween Targets 
The motion tween model in Animate CC is object based. This means that an object 
and its motion are independent of each other, and you can easily swap out the tar- 
get of a motion tween. If, for example, you’d rather see an alien moving around the 
Stage instead of a rocket ship, you can replace the target of the motion tween with 
an alien symbol from your Library panel and still preserve the animation. 

1 Drag the movie clip symbol of the alien from the Library panel onto the 
rocket ship. 
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● Note You can also 
use the Properties panel 
to swap instances . 
Select the object that 
you want to swap 
on the Stage . In the 
Properties panel, click 
the Swap button . In the 
dialog box that appears, 
choose a new symbol 
and click OK . Animate 
will swap the target of 
the motion tween . 

Animate asks if you want to replace the existing tween target object with a new 
object. 

 

 

2 Click OK. 

Animate replaces the rocket ship with the alien. The motion remains the same, 
but the target of the motion tween has changed. 

 
 
 
● Note If your symbol 
instance disappears 
from view after the 
symbol swap, choose 
View > Magnification > 
Show All (Ctrl+3/ 
Cmd+3) to change the 
zoom level to show all 
objects on the Stage . 

 

Creating Nested Animations 
Often, an object that is animated on the Stage will have its own animation. For 
example, the wings of a butterfly moving across the Stage may flap as it moves. Or 
the alien that you swapped with the rocket ship could be waving his arms. These 
kinds of animations are called nested animations because they are contained inside 
the movie clip symbols. Movie clip symbols have their own timeline that is inde- 
pendent of the main Timeline. 

In this example, you’ll give the alien his own independent movement so he can 
wave as he flies across the Stage. 

Creating animations inside movie clip symbols 
We’ll animate some of the symbols that make up the alien’s body to allow him 
to wave. 
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1 In the Library panel, double-click the alien movie clip symbol icon. 

You are now in symbol-editing mode for 
the alien movie clip symbol. The alien 
appears in the middle of the Stage. In 
the Timeline, the parts of the alien are 
separated in layers. 

2 Select the Selection tool. 

3 Right-click the alien’s left arm and choose 
Create Motion Tween. 

 

 

Animate converts the current layer into a tween layer and inserts 1 second’s 
worth of frames so that you can begin to animate the instance. 

 

4 Select the Free Transform tool. 

5 Move the mouse pointer near the corner transformation handle until the cursor 
changes to the rotation icon. Drag the corner handle near the hand to rotate the 
arm upward to the alien’s shoulder height. 
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A keyframe is inserted at the end of the motion tween. The left arm rotates 
smoothly from the resting position to the outstretched position. 

6 Move the red playhead back to frame 1. 

7 Now create a motion tween for the alien’s other arm. Right-click his right arm 
and choose Create Motion Tween. 

The current layer is converted into a tween layer, and 1 second’s worth of frames 
are inserted. 

8 Choose the Free Transform tool if it’s not selected already. 

9 As you did for the left arm, drag the 
corner transformation handle near the 
right hand to rotate the arm upward to 
the alien’s shoulder height. 

Animate inserts a keyframe at the end 
of the motion tween. The arm rotates 
smoothly from the resting position to the 
outstretched position. 

10 Select the last frame in all the other layers and insert frames (F5) so that the 
head, body, and feet all remain on the Stage for the same amount of time as the 
moving arms. 

 

 

11 Click the Scene 1 button in the Edit bar at the top of the Stage to exit symbol- 
editing mode. 

Your animation of the alien raising his arms is complete. Wherever you use the 
movie clip symbol, the alien’s nested animation will continue to play. 
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12 Preview the animation by choosing Control > Test. 

Animate opens a window showing the exported 
animation. The alien moves along the motion 
path while the nested animation of his arms 
moving plays and loops. 

13 Save your project and close it. You’ll return to 
your previous animation in the next section. 

 
Easing 
Easing refers to the way in which a motion tween proceeds. You can think of easing 
as acceleration or deceleration. An object that moves from one side of the Stage to 
the other side can start off slowly, then build up speed, and then stop suddenly. Or 
the object can start off quickly and then gradually slow to a halt. Your keyframes 
indicate the beginning and end points of the motion, but the easing determines 
how your object gets from one keyframe to the next. 

A simple way to apply easing to a motion tween is to use the Properties panel. 
Easing values range from −100 to 100. A negative value creates a more gradual 
change from the starting position (known as an ease-in). A positive value creates a 
gradual slowdown (known as an ease-out). 

A more advanced way of applying eases to a motion tween is to use the new 
Motion Editor, which you’ll learn about in the next lesson. 

Splitting a motion tween 
Easing affects the entire span of a motion tween. If you want the easing to affect     
only frames between keyframes of a longer motion tween, you should split the    
motion tween. For example, return to the 04_workingcopy.fla file of the cinematic 
animation. The motion tween of the car in the Left_car layer begins at frame 75 and 
ends at frame 191, at the very end of the Timeline. However, the actual movement     
of the car starts at frame 75 and ends at frame 100. You’ll split the motion tween so  
that you can apply an ease to the tween just from frame 75 to frame 100. 

1 In the Left_car layer, select frame 101, which is the frame just after the second 
keyframe, where the car ends its movement. 

● Note Animations 
inside movie clip 
symbols won’t play 
on the main Timeline . 
Choose Control > Test 
to preview nested 
animations . 

 
● Note Animations 
inside movie clip 
symbols will loop 
automatically . To 
prevent the looping, 
you need to add code 
to tell the movie clip 
timeline to stop on its 
last frame . You’ll learn to 
control those timelines 
with ActionScript or 
JavaScript in later 
lessons . 
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2 Right-click frame 101 and choose Split Motion. 
 

 

The motion tween is cut into two separate tween spans. The end of the first 
tween is identical to the beginning of the second tween. 

Motion tween split 

 
 

3 In the Middle_car layer, select frame 94, right-click, and choose Split Motion to 
cut the motion tween into two separate tween spans. 

4 In the Right_car layer, select frame 107, right-click, and choose Split Motion to 
cut the motion tween into two spans. 

The motion tweens of all three cars have now been split. 
 

 
Applying eases to motion tweens 
You’ll apply an ease-in to the motion tweens of the approaching cars to give them a 
sense of weight and to make them decelerate, as real cars would. 

1 In the Middle_car layer, select any frame between the first and second 
keyframes of the first motion tween (frame 70 to frame 93). 
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2 In the Ease section of the Properties panel, enter 100 for the Ease value. 
 

 

This applies an ease-out to the motion tween. 

3 In the Left_car layer, select any frame between the first and second keyframes of 
the first motion tween (frame 75 to frame 100). 

 

 

4 In the Properties panel, enter 100 for the Ease value to apply an ease-out to the 
motion tween. 

5 In the Right_car layer, select any frame between the first and second keyframes 
of the first motion tween (frame 78 to frame 106). 

 

 

6 In the Properties panel, enter 100 for the Ease value to apply an ease-out to the 
motion tween. 

7 Select Loop at the bottom of the Timeline and move the start and end markers 
in the Timeline header to frames 60 and 115, respectively. 

Start marker End marker 

 
Loop playback 
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8 Click Play (Enter/Return). 

Animate plays the Timeline in a loop between frames 60 and 115 so you can 
examine the ease-out motion of the three cars. 

 
Frame-by-Frame Animation 
Frame-by-frame animation is a technique that creates the illusion of movement by 
making incremental changes between every keyframe. Frame-by-frame animation 
in Animate is similar to traditional hand-drawn cel animation, where each drawing 
is on a separate sheet of paper, and it’s just as tedious. 

Frame-by-frame animations increase your file size rapidly because Animate has to 
store the contents for each keyframe. Use frame-by-frame animation sparingly. 

In the next section, you’ll insert a frame-by-frame animation inside the carLeft 
movie clip symbol to make it move up and down in a jittery fashion. When 
the movie clip loops, the car will rumble slightly to simulate the idle of the motor. 

 
Inserting a new keyframe 
The frame-by-frame animations inside the carMiddle and carRight movie clip sym- 
bols have already been done. You’ll finish the animation for the carLeft symbol. 

1 In the Library panel, double-click the carRight movie clip symbol to examine its 
completed frame-by-frame animation. 

Inside the carRight movie clip, three 
keyframes establish three different 
positions for the car and its headlights. 
The keyframes are spaced unevenly to 
provide the unpredictable up and down motion. 

2 In the Library panel, double-click the carLeft movie clip symbol. 

You enter symbol-editing mode for the carLeft symbol. 
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3 Select frame 2 in both the lights layer and the smallRumble layer. 
 

 

4 Right-click and choose Insert Keyframe (F6). 

Animate inserts a keyframe in frame 2 of the lights layer and the smallRumble 
layer. The contents of the previous keyframes are copied into the new keyframes. 

 

 

 
 
 

� Tip  If the image 
of the car isn’t visible, 
select Fit In Window 
from the Zoom menu in 
the upper-right corner 
of the Stage . 

 

Changing the graphics 
In the new keyframe, change the appearance of the contents to create the animation. 

1 In frame 2, select all three graphics (the car and its two headlights) on the Stage 
(Edit > Select All, or Ctrl+A/Command+A) and move them down the Stage by 
1 pixel. Use the Properties panel to decrease the Y-position value by 1 pixel, or 
press the Down Arrow key to nudge the graphics by 1 pixel. 

The car and its headlights move down slightly. 

2 Next, repeat the process of inserting keyframes and changing the graphics. For a 
random motion like an idling car, using at least three keyframes is ideal. 

Select frame 4 in both the lights layer and the smallRumble layer. 

3 Right-click and choose Insert Keyframe (F6). 

Keyframes are inserted into frame 4 of the lights and smallRumble layers. The 
contents of the previous keyframes are copied into the new keyframes. 

 

4 Select all three graphics on the Stage (Edit > Select All, or Ctrl+A/Command+A) 
and move them up the Stage by 2 pixels. You can use the Properties panel or 
press the Up Arrow key twice to nudge the graphics by 2 pixels. 

The car and its headlights move up slightly. 
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● Note In this section, 
you created the car’s 
idling motion by 
manually moving the 
car’s position frame 
by frame . In the next 
lesson, you’ll learn to 
use the Refine Tween 
panel, which can 
automatically modify 
your motion tween 
to simulate natural 
movements such as 
bounces or random 
jitters (as in the idling 
of a car) . 

 
� Tip You can navigate 
quickly between 
multiple keyframes 
by choosing Control > 
Step Forward To Next 
Keyframe (Ctrl/Cmd+ .) 
or Control > Step 
Backward To Previous 
Keyframe (Ctrl/Cmd+,) . 
You can also click the 
forward-pointing or 
backward-pointing 
arrow in front of your 
layer name on the 
Timeline to move to 
the next or previous 
keyframe, respectively . 

5 Test the idling motion by enabling the Loop Playback option at the bottom of 
the Timeline and clicking Play (Enter/Return). 

 
Animating 3D Motion 
Finally, you’ll add a title and animate it in 3D space. Animating in 3D presents the 
added complication of a third axis (z). When you choose the 3D Rotation or 3D 
Translation tool, you need to be aware of the Global Transform option at the bot- 
tom of the Tools panel. (The tools and the Global Transform option were intro- 
duced in the Lesson 3 section “Positioning Objects in 3D Space.”) Global Transform 
toggles between a global option (button selected) and a local option (button dese- 
lected). Moving an object with the global option selected makes the transformation 
relative to the global coordinate system, whereas moving an object with the local 
option on makes the transformation relative to itself. 

1 Click Scene 1 in the Edit bar to return to the main Timeline. Insert a new layer 
at the top of the layer stack and rename it title. 

 

2 Lock all the other  layers. 

3 Insert a new keyframe at frame 120. 
 

 
 

4 Drag the movie clip symbol called movietitle from the Library panel onto 
the Stage. 
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The movietitle instance appears in your new layer in the keyframe at frame 120. 

5 Position the title in the empty sky at x=180 and y=90. 
 

 

6 Right-click the movie title and choose Create Motion Tween. 

Animate converts the current layer to a tween layer so that you can begin to 
animate the instance. 

7 Move the red playhead to frame 140. 
 

 

8 Select the 3D Rotation tool . 

The 3D rotation control appears on the selected movie clip. 
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9 Deselect the Global Transform option ) at the bottom of the Tools panel to 
put the 3D Rotation tool into local mode. 

10 Drag upward on the left arm of the green Y control to rotate the title around 
the y axis to angle it so that it seems to recede into the distance. Its angle is at 
about −50 degrees. You can check the rotation values in the Transform panel 
(Window > Transform). 

 

 

11 Move the red playhead to the first keyframe, at frame 120. 

12 Drag upward on the Y control to rotate the title around the y axis in the 
opposite direction so that the instance looks like just a sliver. 
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The change in the 3D rotation becomes a motion tween, so the title appears to 
swing in three dimensions. 

 
Exporting Your Final Movie 
You can quickly preview your animation by “scrubbing” the red playhead back and 
forth on the Timeline, by choosing Control > Play, or by using the Time Scrub tool 
from the Tools panel. You can also use the integrated controller at the bottom of 
the Timeline. But to create your final project as a movie, you must export it. 

Create an MP4 movie file by exporting the project and converting it in Media 
Encoder, a freestanding application that comes packaged with Animate (you’ll learn 
more about Media Encoder in Lesson 11). 

1 Choose File > Export > Export Video. 

The Export Video dialog box  opens. 

2 Keep the Render Size at its original dimensions. Select the Convert Video In 
Adobe Media Encoder option. Click Browse to select the destination filename 
and location. Click Export. 

 
 
● Note Animating 
the 3D rotation 
or translation of a 
symbol is not currently 
supported in HTML5 
Canvas documents or in 
WebGL documents . 

 

 
 

Animate generates a SWF file (.swf) and then saves a MOV (.mov) file from it. 
Adobe Media Encoder automatically launches. 
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3 In Adobe Media Encoder, notice that your MOV file is already added to the 
Queue panel. 

 

 

4 In the Queue panel’s Preset menu, choose Match Source – Medium Bitrate. 

The Match Source – Medium Bitrate setting keeps the dimensions of the source 
file and balances file size and quality. 

5 Click the Start Queue button (the green triangle) or press Enter/Return to begin 
the encoding process. 

6 Media Encoder converts the MOV file into an H.264-formatted video with the 
standard .mp4 extension. 

 

 

Congratulations—you’re done! The final file can be uploaded to Facebook, 
YouTube, or other video sharing sites, or put up on a promotional website for 
the fictional cinematic release. 
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