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Legal notices

Legal notices
For legal notices, see http://help.adobe.com/en_US/legalnotices/index.html.

A note to our customers
Adobe provides this searchable PDF of archived technical support documents as a service to our 
customers who own and continue to enjoy older, unsupported versions of our software products. The 
information in these documents is not updated, and will become increasingly less accurate as 
hardware, browsers, and operating systems continue to evolve. Please be aware that these archived 
documents reflect historical issues and solutions for products that are no longer supported. Adobe 
does not warrant that the information in this document is accurate.
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WebDAV error when connecting to a server using Basic 
authentication for PROPFIND command

Issue
 In Adobe Dreamweaver CS3, when you try to make a WebDAV connection to a server using Basic authentication for 
the PROPFIND command, the connection fails and the following message is displayed: 

"Cannot display the remote folder: An HTTP WebDAV error occurred. Dreamweaver cannot get a listing for the folder 
you specified. Make sure you have proper authorization on the server, and the server is properly configured. Make sure 
the remote folder is available or select a different one by clicking Manage Sites. To try again, click the Refresh button in 
the Files panel." 

The WebDAV connection is successful with earlier versions of Dreamweaver. 

This problem only occurs when the WebDAV server doesn't require authentication for the OPTION command, but the 
server does require Basic authentication for the PROPFIND command. Most WebDAV users are not affected by this 
issue. (Ref. 226989) 

Solution
 Adobe has created a fix for this issue. Download the fix for your operating system and install it using the following 
instructions: 

Windows

1 Download the Windows version of the fix: NetIODav.zip.

2 Unzip the file NetIODav.dll to your desktop.

3 Quit Dreamweaver.

4 Locate your installation of Adobe Dreamweaver CS3. The default location is C:\Program Files\Adobe\Adobe 
Dreamweaver CS3.

5 In the Adobe Dreamweaver CS3 folder, there should be a file called NetIODav.dll.

6 Back up the original NetIODav.dll by renaming it to NetIODav_ORIG.dll.

7 Copy the new NetIODav.dll from your desktop into the folder.

8 Launch Dreamweaver.

Mac OS

1 Download the Mac OS version of the fix: NetIODav.bundle.zip.

2 Unzip the file NetIODav.bundle to your desktop.

https://www.adobe.com/support/dreamweaver/ts/documents/kb402079/NetIODav.zip
https://www.adobe.com/support/dreamweaver/ts/documents/kb402079/NetIODav.bundle.zip
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3 Quit Dreamweaver.

4 Locate your installation of Adobe Dreamweaver CS3. The default location is Mac HD/Applications/Adobe 
Dreamweaver CS3/.

5 Select the Dreamweaver executable, and bring up its context menu by right-clicking or Control-clicking it.

6 In the context menu, select Show Package Contents menu.

7 Navigate to the Contents > PlugIns folder. There should be a file called NetIODav.bundle.

8 Back up the original NetIODav.bundle by renaming it NetIODav_ORIG.bundle.

9 Copy the new NetIODav.bundle from your desktop into the folder.

10 Launch Dreamweaver.

Additional Information
 "Configuring WebDAV in IIS for use with Dreamweaver" (TechNote tn_19095 ) 

"Troubleshooting WebDAV connections" (TechNote tn_15167 ) 

Using FileMaker in Dreamweaver via Lasso Studio

Issue
FileMaker is not a database supported by Dreamweaver for creating dynamic database-driven web applications 
(ColdFusion, ASP, ASP.NET, JSP and PHP).

Reason
Because of problems concerning FileMaker's ODBC connectivity feature, FileMaker is not one of the natively 
supported databases when it comes to creating dynamic web applications in Dreamweaver. The following databases are 
natively supported by Dreamweaver:

• Microsoft Access

• Microsoft SQL Server

• MySQL (PHP only)

• Oracle

Databases that are not listed above, such as FileMaker, may work with Dreamweaver, but they have not been tested by 
Macromedia's engineers and Macromedia does not provide support for those databases.

Solution
If you would like to use FileMaker as the database for your web application, there is a third-party product available for 
purchase: the Lasso Studio for Dreamweaver by Blue World. The Lasso Studio installs Lasso objects into Dreamweaver, 
which facilitate the visual creation of Lasso Dynamic Markup Language (LDML) pages that run on a Lasso web 
application server. Because Lasso can communicate with FileMaker in the database's native language, FDML 
(FileMaker Dynamic Markup Language), the ODBC connectivity issue is averted.

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_19095
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15167
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Currently, Lasso Studio 5 is only compatible with Dreamweaver 4 and Dreamweaver UltraDev 4. The next version of 
Lasso Studio (out later in 2002) is slated to support Dreamweaver MX.

Note: Macromedia does not provide technical support for third-party software or extensions, such as Lasso Studio for 
Dreamweaver. Please contact Blue World if you need assistance.

Additional Information
• FileMaker white paper on FileMaker, Dreamweaver UltraDev and JSP

Using Dynamic SQL parameters inside standard 
Recordsets in Dreamweaver 8.0.2 and CS3
What's covered

• Addressing database security vulenability 

• SQL Injections and prevention methods 

• Using prepared statements 

• Allowing for dynamic parameters in standard Recordsets 

Addressing database security vulnerability

 To increase security in Dreamweaver 8.0.2 and CS3 we removed the ability to use dynamic SQL parameters inside 
standard Recordsets. The original code exposed databases to SQL injections . Using prepared statements for ASP_VBS 
and ColdFusion server models addressed the security vulnerability. It was necessary to add a function to the page when 
the first Recordset is applied and then call that function from all Recordsets on the page for PHP_MySQL. This 
technique is similar to the prepared statements of ASP_VBS and ColdFusion. 

In the effort to close the security vulnerability, we have traded some flexibility for security. We want to give developers 
who already have or plan to develop extensions that will need to handle dynamic SQL queries;as well as end users who 
want to customize their recordsets to accept dynamic parameters;the ability to edit these custom Recordsets from 
within Dreamweaver. 

SQL Injections and prevention methods

A SQL Injection is a technique that exploits a security vulnerability occurring in the database layer of an application. 
The vulnerability is present when user input is either incorrectly filtered for string literal escape characters embedded 
in SQL statements or user input is not strongly typed and thereby unexpectedly executed. It is in fact an instance of a 
more general class of vulnerabilities that can occur whenever one programming or scripting language is embedded 
inside another. Please visit Wikipedia for additional information.

Standard SQL Query example:

SELECT * FROM company_com WHERE name_com = '$companyName'

In the example above, the $companyName variable is read from a input form field, so the user have the total control of 
what value will be submitted. In the best case scenario, when the user enters "Adobe" (without the quotes) in the input 
corresponding to the company name, the given SQL query will look like this:

SELECT * FROM company_com WHERE name_com = 'Adobe'

http://www.filemaker.com/downloads/pdf/FMPU55_UltraDev.pdf
http://helpx.adobe.com/dreamweaver/kb/#main_SecurityVulnerability
http://helpx.adobe.com/dreamweaver/kb/#main_SQLInjections
http://helpx.adobe.com/dreamweaver/kb/#main_UsingPreparedStatements
http://helpx.adobe.com/dreamweaver/kb/#main_DynamicParameters
http://helpx.adobe.com/dreamweaver/kb/#main_SQLInjections
http://en.wikipedia.org/wiki/SQL_injection
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But there are cases when users may want to break the web site and steal sensitive information and/or destroy the 
database. Considering the example above, a SQL injection will be easy achievable by entering the following string 
"blabla' OR '1'='1"(without the surrounding quotes). By giving this sequence of characters, the user will have access to 
all companies instead of a single company. The actual SQL that gets executed is:

SELECT * FROM company_com WHERE name_com = 'blabla' OR '1'='1'

Moreover, if the user wants to delete the entire company_com table, he/she may do this by simply passing the following 
string "x'; DROP TABLE company_com; --"(without the surrounding quotes). here is the complete SQL query:

SELECT * FROM company_com WHERE name_com = 'x'; DROP TABLE company_com; --'

Use one of the following measures to protect your website from SQL injections:

• Restrict input to a minimum set of allowed characters by automatically removing all other characters that falls 
outside of the given range.

• Escape all characters that can cause issues when used inside a SQL query (for example, single quotes).

• Use prepared statements.

• Use database access rights.

• Use stored procedures.

We recommend prepared statements which are described in more detail in Using prepared statements . Dreamweaver 
8.0.2 and CS3 use the prepared statements approach for ASP_VBS, ASP_JavaScript, Cold Fusion and JSP server models, 
and the escape the user's input approach for the PHP_MySQL server model. Please refer to SQL Injection Attacks by 
Example for additional information on SQ injection attacks.

Using prepared statements

 Dreamweaver 8.0.2 and CS use prepared statements since this solution guarantees us that the replacement of the actual 
SQL parameters with given values (possibly sent via URL) will be done on the server and not on the page. Prepared 
statements also guarantee that the value passed to the SQL itself has the appropriate data type and uses the appropriate 
escaping (if a parameter is said to be of type int, then the user will not be able to submit a letter, or if a parameter is of 
type text, then the entire passed string will be properly escaped and the user will not have the chance to perform a SQL 
injection). 

Prepared statements for the ASP_VBS and ASP_JS server models

 For ASP_VBS and ASP_JS, we rely on the ADODB database layer. The following example shows a simple ASP_VBS 
Recordset that uses a dynamic SQL parameter to filter results: 

... <% Dim Recordset1__MMColParam Recordset1__MMColParam = "1" If (Request.QueryString("id_com") <> "") 
Then Recordset1__MMColParam = Request.QueryString("id_com") End If %><% Dim Recordset1 Dim 
Recordset1_cmd Dim Recordset1_numRows Set Recordset1_cmd = Server.CreateObject ("ADODB.Command") 
Recordset1_cmd.ActiveConnection = MM_connContacts_STRING Recordset1_cmd.CommandText = "SELECT * 
FROM company_com WHERE id_com = ?" Recordset1_cmd.Prepared = true Recordset1_cmd.Parameters.Append 
Recordset1_cmd.CreateParameter("param1", 5, 1, -1, Recordset1__MMColParam) ' adDouble Set Recordset1 = 
Recordset1_cmd.Execute Recordset1_numRows = 0 %> ...

Prepared statements for the ColdFusion server model

 ColdFusion offers built-in support for prepared statements. The following example shows a simple ColdFusion 
Recordset that uses a dynamic SQL parameter to filter results: 

... <cfparam name="URL.id_com" default="1"><cfquery name="Recordset1" datasource="company_employee"> 
SELECT * FROM company_com WHERE id_com = <cfqueryparam value="#URL.id_com#" 
cfsqltype="cf_sql_numeric"></cfquery> ...

http://helpx.adobe.com/dreamweaver/kb/#main_UsingPreparedStatements
http://www.unixwiz.net/techtips/sql-injection.html
http://www.unixwiz.net/techtips/sql-injection.html
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Simulated prepared statements for the PHP_MySQL server model

 Prepared statements for PHP became available with MySQL 4.1, but because we wanted to support previous versions 
of MySQL as well, we decided to implement a custom function that does virtually the same thing. The following 
example shows a simple PHP Recordset that uses a dynamic SQL parameter to filter results: 

... <?php if (!function_exists("GetSQLValueString")) { function GetSQLValueString($theValue, $theType, 
$theDefinedValue = "", $theNotDefinedValue = "") { $theValue = get_magic_quotes_gpc() ? stripslashes($theValue) : 
$theValue; $theValue = function_exists("mysql_real_escape_string") ? mysql_real_escape_string($theValue) : 
mysql_escape_string($theValue); switch ($theType) { case "text": $theValue = ($theValue != "") ? "'" . $theValue . "'" : 
"NULL"; break; case "long": case "int": $theValue = ($theValue != "") ? intval($theValue) : "NULL"; break; case "double": 
$theValue = ($theValue != "") ? "'" . doubleval($theValue) . "'" : "NULL"; break; case "date": $theValue = ($theValue != "") 
? "'" . $theValue . "'" : "NULL"; break; case "defined": $theValue = ($theValue != "") ? $theDefinedValue : 
$theNotDefinedValue; break; } return $theValue; } } $colname_Recordset1 = "-1"; if (isset($_GET['id_com'])) { 
$colname_Recordset1 = $_GET['id_com']; } mysql_select_db($database_connContacts, $connContacts); 
$query_Recordset1 = sprintf("SELECT * FROM company_com WHERE id_com = %s", 
GetSQLValueString($colname_Recordset1, "int")); $Recordset1 = mysql_query($query_Recordset1, $connContacts) 
or die(mysql_error()); $row_Recordset1 = mysql_fetch_assoc($Recordset1); $totalRows_Recordset1 = 
mysql_num_rows($Recordset1); ?> ...

Allowing for dynamic parameters in standard Recordsets

 So how can we protect against SQL injections while still allowing for dynamic parameters and keeping the resulting 
code editable via the Server Behaviors panel in Dreamweaver? The solution is to insert the dynamic parameters into 
the SQL query itself, rather than passing them as classic SQL parameters (which would either be escaped or appended 
to the SQL via prepared statements). 

Important: Users cannot generate such code using the Objects and Server Behaviors that ship with Dreamweaver 8.0.2 
or CS3 (Example: Inserting a Recordset via the Server Behaviors panel or Insert bar). This solution requires the user to 
edit the code manually, or to install a third-party extension that creates such code. The responsibility of writing secure 
code falls on the user or third party software developer. 

The purpose of this method is to let experienced developers create dynamic SQL queries. Misuse of thise solution gives 
a hacker the possibility to get unwanted privileges and/or break the web pages and database. Please refer to SQL 
Injections and prevention methods to minimize the risk of SQL injections. 

The main cases we identified this solution would be used are: 

• Manually creating/updating a SQL query to accept dynamic parameters. 

• Create/upgrade existing extensions to generate dynamic parameters. 

Both use cases will be detailed in the following paragraphs. 

Manually creating/updating a SQL query to accept dynamic parameters while keeping the Recordset still editable 
from within Dreamweaver

 In the following example the user wants to add sorting functionality to a dynamic table. He decides to reload the page 
while passing the files and the sort direction to be used (ascending or descending) in the URL. A initial URL example is: 

http://www.mydomain.com/index.php?sortCol=name_com&sortDir=asc

 Hand-coding is required to accomplish this task in Dreamweaver using the Server Behaviors. The following code 
samples show the changes that must be made for each server model. 

http://helpx.adobe.com/dreamweaver/kb/#main_SQLInjections
http://helpx.adobe.com/dreamweaver/kb/#main_SQLInjections
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Important: Please note that none of the examples below have validation against SQL injections. Their role is pure 
educational and should be not used in production as they are. The examples are not bullet-proof to keep them as simple 
as possible. You must protect against SQL injections. For additional information please refer to SQL Injections and 
prevention methods . 

ASP_VBS

 Before: 

... <% Dim Recordset1 Dim Recordset1_cmd Dim Recordset1_numRows Set Recordset1_cmd = Server.CreateObject 
("ADODB.Command") Recordset1_cmd.ActiveConnection = MM_connContacts_STRING 
Recordset1_cmd.CommandText = "SELECT * FROM company_com" Recordset1_cmd.Prepared = true Set 
Recordset1 = Recordset1_cmd.Execute Recordset1_numRows = 0 %> ...

 After: 

... <% Dim orderBy: orderBy = "" If (Request.QueryString("sortCol") <> "") Then orderBy = "ORDER BY " & 
Request.QueryString("id_com") If (Request.QueryString("sortDir") <> "") Then orderBy = orderBy & " " & 
Request.QueryString("sortDir") End If End If %><% Dim Recordset1 Dim Recordset1_cmd Dim 
Recordset1_numRows Set Recordset1_cmd = Server.CreateObject ("ADODB.Command") 
Recordset1_cmd.ActiveConnection = MM_connContacts_STRING Recordset1_cmd.CommandText = "SELECT * 
FROM company_com " & orderBy & "" Recordset1_cmd.Prepared = true Set Recordset1 = Recordset1_cmd.Execute 
Recordset1_numRows = 0 %> ...

ColdFusion

 Before: 

... <cfquery name="Recordset1" datasource="company_employee"> SELECT * FROM company_com </cfquery> ...

 After: 

... <cfparam name="URL.sortCol" default=""><cfparam name="URL.sortDir" default="ASC"><cfset orderBy=""><cfif 
(#URL.sortCol# NEQ "")><cfset orderBy="ORDER BY #URL.sortCol# #URL.sortDir#"></cfif><cfquery 
name="Recordset1" datasource="company_employee"> SELECT * FROM company_com #orderBy# </cfquery> ...

PHP_MySQL

 Before: 

... <?php mysql_select_db($database_connContacts, $connContacts); $query_Recordset1 = "SELECT * FROM 
company_com"; $Recordset1 = mysql_query($query_Recordset1, $connContacts) or die(mysql_error()); 
$row_Recordset1 = mysql_fetch_assoc($Recordset1); $totalRows_Recordset1 = mysql_num_rows($Recordset1); ?> ...

 After: 

... <?php $orderBy = ""; if (isset($_GET['sortCol'])) { $orderBy = "ORDER BY " . $_GET['sortCol']; if 
(isset($_GET['sortDir'])) { $orderBy .= " " . $_GET['sortDir']; } } ?><?php mysql_select_db($database_connContacts, 
$connContacts); $query_Recordset1 = "SELECT * FROM company_com " . $orderBy . ""; $Recordset1 = 
mysql_query($query_Recordset1, $connContacts) or die(mysql_error()); $row_Recordset1 = 
mysql_fetch_assoc($Recordset1); $totalRows_Recordset1 = mysql_num_rows($Recordset1); ?> ...

Create/upgrade existing extensions to generate dynamic parameters while keeping the Recordset still editable 
from within Dreamweaver

 Now consider the same scenario as above, except that the user wants to create an extension that will generate the 
appropriate code rather than relying on a combination of built-in functionality and hand-editing. The new extension 
should generate the correct code for the ASP_VBS, ColdFusion, and PHP_MySQL server models. 

http://helpx.adobe.com/dreamweaver/kb/#main_SQLInjections
http://helpx.adobe.com/dreamweaver/kb/#main_SQLInjections
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Important: The following sections we will only focus on generating code that will use the values from the URL 
parameters to create a dynamic SQL query. The main focus is to generate the code so that it will be still recognized by 
Dreamweaver and will be editable from within standard Dreamweaver interfaces. This tutorial will not handle the 
validation of input data (via URL parameters) or protect the final SQL against any attempt of SQL injections because 
the complexity of such code falls outside of the scope of this tutorial. Developer is solely responsible to protect the final 
SQL against SQL injections. 

We provide a demo extension which takes a connection and a table as input and generates a dynamic table displaying 
all records. It also updates the generated SQL to contain the orderBy variable as shown in the examples above. The 
extension was designed for Dreamweaver 8.0.2 and CS3. The generated code is not bullet proof, as the goal is to create 
Recordsets containing dynamic parameters that remain editable using standard Dreamweaver interfaces. The 
extension source code is located in User's Configuration folder . 

In all of the code examples below, the highlighted sections were added to enable the sorting functionality via the URL 
parameters sortCol and sortDir. 

ASP_VBS

 The code that generates the appropriate SQL query for the ASP_VBS server model is located within 
"[USER_CONFIGURATION_FOLDER]/Commands/My Dynamic Table.js" file in the User Configuration Folder . 
The notable change is on line 130: 

... 130: paramObj.encodedSQL = "SELECT * FROM " + paramObj.table + " \" & orderBy & \""; ...

 The participants file for the MyDynamicTable ASP_VBS server behavior includes an extra participant which adds the 
"orderBy" variable definition to the page: 

<group name="MyDynamicTable" version="9.0"><groupParticipants><groupParticipant 
name="connectionref_statement" /><groupParticipant name="MyDynamicTable_orderBy" /><groupParticipant 
name="recordset_main" /><groupParticipant name="repeatedRegion_init2" /><groupParticipant 
name="DynamicTable_main" /><groupParticipant name="recordset_close" /></groupParticipants></group>

ColdFusion

 The same "[USER_CONFIGURATION_FOLDER]/Commands/My Dynamic Table.js" in the User Configuration 
Folder also contains the code for ColdFusion server model; the relevant change in this case is on line 138: 

... 138: paramObj.SQLStatement = "SELECT * FROM " + paramObj.table + " #orderBy#"; ...

 The participants file for the MyDynamicTable ColdFusion server behavior includes an extra participant which adds 
the "orderBy" variable definition to the page: 

<group name="MyDynamicTable" version="9.0"><groupParticipants><groupParticipant 
name="MyDynamicTable_orderBy" /><groupParticipant name="Recordset_main" /><groupParticipant 
name="DynamicTable_main" /><groupParticipant name="RepeatedRegion_pageNum" /><groupParticipant 
name="RepeatedRegion_maxRows" /><groupParticipant name="RepeatedRegion_startRow" /><groupParticipant 
name="RepeatedRegion_endRow" /><groupParticipant name="RepeatedRegion_totalPages" 
/></groupParticipants></group>

PHP_MySQL

 The last server model in the extension is PHP_MySQL. The relevant change in the 
"[USER_CONFIGURATION_FOLDER]/Commands/My Dynamic Table.js" file in the User Configuration Folder is 
on line 122: 

... 122: paramObj.SQLStatement = "SELECT * FROM " + paramObj.table+ " \" . $orderBy . \""; ...

http://www.adobe.com/support/dreamweaver/ts/documents/kb402875/MyDynamicTable1-0-0.mxp
http://helpx.adobe.com/dreamweaver/kb/#main_UserConfigFolder
http://helpx.adobe.com/dreamweaver/kb/#main_UserConfigFolder
http://helpx.adobe.com/dreamweaver/kb/#main_UserConfigFolder
http://helpx.adobe.com/dreamweaver/kb/#main_UserConfigFolder
http://helpx.adobe.com/dreamweaver/kb/#main_UserConfigFolder
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 The participants file for the MyDynamicTable PHP_MySQL server behavior includes an extra participant which adds 
the "orderBy" variable definition to the page: 

<group name="MyDynamicTable" version="9.0"><groupParticipants><groupParticipant 
name="Connection_include" /><groupParticipant name="MyDynamicTable_orderBy" /><groupParticipant 
name="EditOps_SQLValueString" /><groupParticipant name="Recordset_main" /><groupParticipant 
name="DynamicTable_main" /><groupParticipant name="Recordset_close" /></groupParticipants></group>

Pros

 The method described above has several advantages, including: 

• The more advanced developers can take advantage of the SQL injection vulnerability to construct more complex 
SQLs, dynamically. 

• The Recordsets created will still be editable from within Dreamweaver. 

• It's not difficult to integrate into existing Dreamweaver extensions that generate Recordsets with dynamic SQL 
parameters. 

• The default code generated by Dreamweaver remains unchanged; developers who do not require dynamic queries 
(and their clients) can be assured that the code written by Dreamweaver is secure. 

Cons

 Since Dreamweaver was not designed by default to support this method, it also has some drawbacks, including: 

• The code generated using the method described in this document is vulnerable to SQL injections and therefore 
needs to be protected in other ways. The list of such protection methods includes but is not limited to: 

• Ensure that the end user cannot use the SQL injection method to comprise the web page and/or database; 

• Escape the arguments before they reach the actual SQL; 

• Make sure that even if the user manages to break your code, he/she will not steal sensitive information and/or 
will not comprise the database. 

• Two known issues that cannot be fixed until the next version of Dreamweaver is released: 

• ColdFusion: Simple Recordset UI removes the hashes around variable names from the SQL query when edited 
and then re-applied 

• ColdFusion, ASP_VBS, ASP_JS: Test button from Advanced Recordset UI is not working when SQL query 
contains variable names 

Locating the User's Configuration folder

• Windows XPC:\Documents and Settings\[username]\Application Data\Adobe\Dreamweaver 9\Configuration

• Windows VistaC:\Users\[username]\AppData\Roaming\Adobe\Dreamweaver 9\Configuration

• Mac OS 10.4.x/Users/[username]/Library/Application\ Support/Adobe/Dreamweaver\ 9/Configuration

Update record primary key issue (Dreamweaver 
Developer Toolbox)
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Issue
 I've created a page that allows updating records in a database, but when I preview it in the browser and try to submit 
information, I get an error message saying "tNG_update.prepareSQL:No Primary Key Column was set. 
(UPD_NO_PK_SET)".

•  Products: Developer Toolbox. 

• Operating System: All. 

• Server Models: All. 

• Dreamweaver version: CS3. 

Reason
 This happens because the update page was accessed without sending a value for the Primary Key. Usually, update pages 
take the ID of the record to update from an URL parameter. If it is missing, the update operation cannot work properly, 
because there is no definite record. 

Solution
 When accessing an update page, make sure you always pass it a correct value for the primary key column of the table 
that's being updated. This is done easy, if the update page is called from a link that automatically passes the ID of the 
record to edit. 

Uninstall Dreamweaver CS3 | Mac OS
Adobe Dreamweaver CS3 comes with an uninstaller on Mac OS. If you remove Dreamweaver CS3, use the uninstaller 
instead of manually deleting application folders by dragging them to the trash. Manually deleting folders before using 
the uninstaller can cause problems when you try to reinstall Dreamweaver CS3.

Remove Dreamweaver CS3 using the uninstaller
The uninstaller is designed to remove everything installed by Dreamweaver CS3.

Note: When you run the uninstaller, you are reminded to deactivate your software. If you plan to reinstall the 
Dreamweaver CS3 on the same machine, then considering keeping your activation.

Use the uninstaller on Mac OS
Navigate to /Applications/Utilities/Adobe Installers and double-click the Add or Remove Adobe Dreamweaver CS3 
alias. Follow the onscreen instructions to remove Dreamweaver CS3.

Remove Dreamweaver using the Adobe CS5 Cleaner Tool
If you manually removed Dreamweaver CS3 by dragging it to the trash and are having problems reinstalling it, then 
run the Adobe CS5 Cleaner Tool. 

Download the Adobe CS5 Cleaner Tool from http://www.adobe.com/support/contact/cs53clean.html and follow the 
instructions included with the script.
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Unable to select correct local root folder for a Site in 
Dreamweaver CS3 and CS4 on Windows Vista SP2 and 7

Issue
When selecting a local root folder within a Site definition in Dreamweaver CS3 or CS4 on Windows Vista SP2 and 7, 
the parent folder is returned instead.

Solution

Solution 1: Browse to another folder within the folder you want to select. 
The file browser is currently returning the parent of the folder you've selected. Select a folder inside the folder you want 
as the site local or remote root.

1 Click Site > Manage Sites.

2 Select the site you want to modify and click Edit.

3 Select the Local Info category and click the Folder Browse button.

4 Navigate to a child folder of the desired local/network site root and click Select.Example: When selecting 
C:\inetpub\wwwroot\images, C:\inetpub\wwwroot is ultimately what will be selected.

5 Click OK.

Important: If the problem occurs with your remote site folder, repeat these steps in the Remote Info category.

Solution 2: Manually enter the local site root folder. 
1 Click Site > Manage Sites.

2 Select the site you want to modify and click Edit.

3 Select the Local Info category and type the folder path in the Local Root Folder field.

4 Click OK.

Important: If the problem occurs with your remote site folder, repeat these steps for the Remote Folder in the Remote 
Info category.

 

Unable to paste text from Word 2008 into Dreamweaver 
CS3 (Mac OS X)
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Issue
 On Mac OS X, when you attempt to copy and paste text from Microsoft Word 2008 to Adobe Dreamweaver CS3, no 
text appears. 

Reason
 There is a conflict with Microsoft Word 2008 for Macintosh that prevents you from pastingformatted text into 
Dreamweaver CS3. 

Solution
 Do one of the following: 

Solution 1: Upgrade to Dreamweaver CS4.
 We have compensated for this issue in Dreamweaver CS4. Please visit the Adobe Store for upgrade information. 

Solution 2: Paste the text into Dreamweaver without any formatting applied.
1 Click Edit > Paste Special.

2 Choose Text Only and click OK.

3 Reapply formatting.

Unable to assign keywords in pages created from a 
template

Issue
 Users are unable to add keywords or other meta tags to a page created from a template, whether they use the menu 
command Insert> Head > Keywords or the Head category, Keyword button of the Object Palette. 

Note: This is not an issue for newer versions of Macromedia Dreamweaver. If you are using a template created in an 
older version of the application, you may need to use the solution listed below. Otherwise, you should have no problems 
adding meta tags to a page based on a template in newer versions of Dreamweaver. 

Reason
 Both the Keyword button of the Object Palette and the menu command are attempting to insert the code for the 
keywords in a line of the noneditable <head> section of the HTML. 

Note: The <head> section of the HTML in a page created from a template is not editable except for the title information 
section. 

Solution
 The keywords can be added to the page by manually typing the meta tag and the keywords after the <title> tag in the 
source code. 

http://www.adobe.com/products/dreamweaver/
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To add keywords to a page created from a template do the following:

1 Open the HTML source code (Window > HTML).

2 Locate the <title> section that begins with the following comment line:<!--#BeginEditable "doctitle" --> Refer to the 
following example code:

 <html><!--#BeginTemplate "/Templates/myTemplate.dwt" --><head><!--#BeginEditable 
"doctitle" --><title>Untitled Document</title><!-- #EndEditable --><meta http-
equiv="Content-Type" content="text/html; 

 
   charset=iso-8859-1"></head><body > 

3 Type the following code after the <title> line and before the EndEditable comment line typing your keywords 
separated by commas between the empty quotes.<meta name="keywords" content=" "> Refer to the following 
example for correct placement of the line of code.

<html><!--#BeginTemplate "/Templates/myTemplate.dwt" --><head><!--#BeginEditable "doctitle

Troubleshoot JavaScript errors | Dreamweaver CS4, CS5, 
CS5.5, CS6

Identify JavaScript errors
When you perform tasks within Dreamweaver, you sometimes encounter a JavaScript error message. These design-
time JavaScript errors usually prevent you from implementing a portion of Dreamweaver functionality.

Example: The following JavaScript error message can appear when you save a file:

Another example of a possible JavaScript error: "While executing onLoad in tempURL_afterSave.htm, a JavaScript 
error occurred."

Important: These pop-up JavaScript errors in Dreamweaver are different from JavaScript runtime errors you encounter 
when viewing a page in a web browser. JavaScript errors in a web browser indicate a problem with embedded or linked 
JavaScript in the HTML page. These types of runtime JavaScript errors are beyond the scope of this TechNote. See the 
Dreamweaver Help files for errors resulting from JavaScript that Dreamweaver generates. Or, see a third-party 
JavaScript reference for troubleshooting hand-coded JavaScript.

Sometimes, a translator error message accompanies these internal JavaScript errors:

The following translators were not loaded due to errors: ASP.htm: has configuration information that is invalid. 
ASP.NET.htm: has configuration information that is invalid. ColdFusion.htm: has configuration information that is 
invalid. PHP_MySQL.htm: has configuration information that is invalid. JSP.htm: has configuration information that 
is invalid. XSLT.htm: has configuration information that is invalid.
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JavaScript errors in Dreamweaver
Dreamweaver uses JavaScript to perform numerous internal actions. Adobe has implemented much of Dreamweaver 
functionality by using JavaScript files. This heavy use of JavaScript helps to make Dreamweaver easily extensible. 
Developers only have to have a good knowledge of JavaScript and access to the Dreamweaver API to add to or change 
the native functionality of Dreamweaver. However, the errors that Dreamweaver generates if it encounters a problem 
executing some action tend to be JavaScript errors.

JavaScript error troubleshooting tips
JavaScript errors in Dreamweaver usually indicate a conflicting Dreamweaver extension, a conflict with the code on a 
page or a bad installation of Dreamweaver. Here are a few questions that can help you isolate the problem:

• Does the error occur when using a specific feature? For example, do you see the same error message every time 
you attempt to create a web photo album? This error can indicate a conflicting extension or a bad installation of 
Dreamweaver.

• Does the error occur on a specific page or with all pages? If the error doesn't occur with all pages, then you can 
have a conflict with some code on a particular page.

• Does the error occur in all sites or just one? To test this issue properly, make sure that you test a different site that 
does not use the same files. If the error only occurs in a certain site, then the issue can be specific to files and code 
within that site.

• Does the problem persist if you restart Dreamweaver? If the problem does not recur on relaunching 
Dreamweaver, then it's possible that a JavaScript file loaded incorrectly.

• If using a server behavior, does the problem occur with all databases and tables? If not, then it's possible that you 
have an issue with the database connection files or with the tables of the database itself.

Troubleshooting steps
After answering the questions above, follow the steps below to troubleshoot the errors:

1 Check the list of known JavaScript errors. 

2 Install the latest update for your version of Dreamweaver. 

3 Name objects referenced by JavaScript. 

4 Delete the FileCache.dat file. 

5 Try a new page. 

6 Re-create the site cache. 

7 For site-specific errors, try deleting the .dws site cache file. 

8 Mac OS users: Check for special characters in paths. 

9 Verify that extensions are compatible with your version of Dreamweaver. 

10 Disable extensions. 

11 Uninstall extensions. 

12 Re-create the Dreamweaver user configuration folder. 

13 Run Dreamweaver in Selective Startup Mode or Diagnostic Startup Mode. 

14 See additional TechNotes. 

http://helpx.adobe.com/dreamweaver/kb/#main_known_errors
http://helpx.adobe.com/dreamweaver/kb/#main_latest_update
http://helpx.adobe.com/dreamweaver/kb/#main_name_objects
http://helpx.adobe.com/dreamweaver/kb/#main_dat
http://helpx.adobe.com/dreamweaver/kb/#main_new_pg
http://helpx.adobe.com/dreamweaver/kb/#main_site_cache
http://helpx.adobe.com/dreamweaver/kb/#main_dws
http://helpx.adobe.com/dreamweaver/kb/#main_special_char
http://helpx.adobe.com/dreamweaver/kb/#main_ext_compat
http://helpx.adobe.com/dreamweaver/kb/#main_disable_ext
http://helpx.adobe.com/dreamweaver/kb/#main_uninstall_ext
http://helpx.adobe.com/dreamweaver/kb/#main_user_config
http://helpx.adobe.com/dreamweaver/kb/#main_safe_mode
http://helpx.adobe.com/dreamweaver/kb/#main_additional
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1. Check the list of known JavaScript errors.
Adobe has documented a number of known errors within Dreamweaver and have provided information to assist you 
in resolving the problem. For a list of known issues, see the Known JavaScript Errors Chart .

2. Install the latest Dreamweaver updates.
Updates provide fixes for a number of issues identified within Adobe applications. Download updates from the Adobe 
Updates page.

3. Verify that any object the JavaScript references is named in the code.
For example, if you have a behavior applied to an image, then that image must have a name. Likewise, if the behavior 
references another image, then that image must also have a name. All object names must be unique and must meet 
other criteria. Object naming is described in Naming strategies for Dreamweaver and various interpreters (tn_14610).

4. Delete FileCache.dat files from the Dreamweaver user configuration folder.
Delete the WinFileCache-7A9586CB.dat, MacFileCache-BFE7CE2E.dat, or FileCache.dat file from the Dreamweaver 
user configuration folder. Adobe recommends that you delete the FileCache.dat file if you are experiencing a JavaScript 
error related to "dwscripts. " Also delete the file if you receive a "translators were not loaded" error. The string of 
characters after "FileCache-" can differ on your machine. The location of the FileCache.dat file depends your operating 
system and your version of Dreamweaver. On Windows, the Application Data and AppData folders are hidden by 
default, so verify that your Windows Explorer folder options are set to View Hidden Folders.

Note: The [language] folder below is an abbreviation of the language you are currently using. Typically there is only one 
folder in this location.

• Mac OS: Dreamweaver CS6: /Users/Your User Name/Library/Application Support/Adobe/Dreamweaver 
CS6/[language]/Configuration Dreamweaver CS5.5: /Users/Your User Name/Library/Application 
Support/Adobe/Dreamweaver CS5.5/[language]/Configuration Dreamweaver CS5: /Users/Your User 
Name/Library/Application Support/Adobe/Dreamweaver CS5/[language]/Configuration Dreamweaver CS4: 
C/Users/Your User Name/Library/Application Support/Adobe/Dreamweaver CS4/[language]/Configuration 

• Windows 7 or Windows Vista: Dreamweaver CS6: C:\Users\Your User 
Name\AppData\Roaming\Adobe\Dreamweaver CS6\[language]\Configuration Dreamweaver CS5.5: 
C:\Users\Your User Name\AppData\Roaming\Adobe\Dreamweaver CS5.5\[language]\Configuration 
Dreamweaver CS5: C:\Users\Your User Name\AppData\Roaming\Adobe\Dreamweaver 
CS5\[language]\Configuration Dreamweaver CS4: C:\Users\Your User 
Name\AppData\Roaming\Adobe\Dreamweaver CS4\[language]\Configuration 

• Windows XP: Dreamweaver CS6: C:\Documents and Settings\Your User Name\Application 
Data\Adobe\Dreamweaver CS6\[language]\Configuration Dreamweaver CS5.5: C:\Documents and Settings\Your 
User Name\Application Data\Adobe\Dreamweaver CS5.5\[language]\Configuration Dreamweaver CS5: 
C:\Documents and Settings\Your User Name\Application Data\Adobe\Dreamweaver 
CS5\[language]\Configuration Dreamweaver CS4: C:\Documents and Settings\Your User Name\Application 
Data\Adobe\Dreamweaver CS4\[language]\Configuration 

For older versions of Dreamweaver, the configuration paths are as follows:

Dreamweaver CS3 on Windows Vista: C:\Users\[user name]\AppData\Roaming\Adobe\Dreamweaver 
9\Configuration

Dreamweaver CS3 on Windows XP: C:\Documents and Settings\[user name]\Application Data\Adobe\Dreamweaver 
9\Configuration

http://helpx.adobe.com/dreamweaver/kb/#main_KnownJS
http://www.adobe.com/support/dreamweaver/downloads_updaters.html
http://www.adobe.com/support/dreamweaver/downloads_updaters.html
http://kb2.adobe.com/cps/146/tn_14610.html
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Dreamweaver 8 on Windows XP: C:\Documents and Settings\[user name]\Application 
Data\Macromedia\Dreamweaver 8\Configuration

Dreamweaver 8 on Windows Vista: C:\Users\[user name]\AppData\Roaming\Macromedia\Dreamweaver 
8\Configuration

Dreamweaver CS3 on Macintosh: Mac HD/Users/[user]/Library/Application Support/Adobe/Dreamweaver 9/

Dreamweaver 8 on Macintosh: Mac HD/Users/[user]/Library/Application Support/Macromedia/Dreamweaver 8/

5. Try a new page.
There can be conflicting code or Dreamweaver behaviors on the page. Try to build a page from scratch with minimal 
behaviors and other design elements and see if you can reproduce the error. Custom code or modified Dreamweaver 
code can occasionally cause problems.

6. Re-create the site cache and see if the problem persists.
In particular, this step is useful for JavaScript errors related to templates, library items, and uploading files. This step is 
only available if the site is defined to use a site cache:

1 Within Dreamweaver, open the Site panel by choosing Window > Files.

2 From the Files panel group, click the Options menu in the upper-right corner, and choose Site > Recreate Site Cache.

7. For site-specific errors, try deleting the .dws site cache file.
If the JavaScript only occurs in one site definition, then delete the site cache file for that site. To delete the cache, choose 
Site > Advanced > Recreate Site Cache.

8. Mac OS users: Check for special characters in paths.
Check for any special characters in the hard drive name, in the path to the Dreamweaver configuration folder, or in the 
path to your site files. Examples of special characters that can cause conflicts include the following:

~ @ # $ % ^ & * ( ) + | / \ ';

9. Verify that extensions are compatible with your version of Dreamweaver.
There can be a conflicting extension installed in Dreamweaver. For example, an extension could have been designed to 
work with an older version of Dreamweaver. Check the extension developer's website to see if the extension is 
compatible with your version of Dreamweaver.

There are several JavaScript errors associated with third-party extensions. Adobe recommends searching the 
Dreamweaver forum. Search using some of the keywords in your JavaScript error message (for example, search using 
the text of the JS filename).

10. Disable extensions.
To manually test for an extension conflict, open the Extension Manager and disable the extensions that you installed in 
Dreamweaver. If turning off the extensions solves the problems, then turn them back on one-by-one, until you isolate 
the problematic extension. If you identify a problematic extension, then notify the extension developer.

1 Choose Commands > Manage Extensions.

2 In the Extension Manager, select your version of Dreamweaver from the product list

3 Within the list of installed extensions, set the On/Off checkbox to Off for all Dreamweaver extensions.

http://forums.adobe.com/community/dreamweaver
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11. Uninstall extensions.
If the JavaScript error persists after you disable all of the extensions, then uninstall the extensions in the Extension 
Manager. If you identify a problematic extension, then notify the extension's author.

1 Within the Extension Manager, select each extension.

2 Choose File > Remove Extension.

12. Re-create the Dreamweaver user configuration folder.
For Dreamweaver CS4, CS5, CS5.5 or CS6, see Restore preferences | Dreamweaver CS4, CS5, CS5.5, CS6.

For Dreamweaver CS3 on Windows, see "How to re-create the Dreamweaver user configuration folder (CS3 on 
Windows XP, Vista)" (TechNote kb401118).

On Mac OS

1 Quit Dreamweaver

2 In the Mac Finder, browse to the following folder: /Users/[username]/Library/Application 
Support/Adobe/Dreamweaver CS4 [or CS5]/[language]/ConfigurationNote: For older versions of Dreamweaver, 
the paths are as follows:Dreamweaver CS3: Mac HD/Users/[user]/Library/Application 
Support/Adobe/Dreamweaver 9/ConfigurationDreamweaver 8: Mac HD/Users/[user]/Library/Application 
Support/Macromedia/Dreamweaver 8/Configuration

3 Rename the folder to "Configuration Old."

4 Restart Dreamweaver and see if the problem persists.

13. Run Dreamweaver in Selective Startup Mode.
• To start Windows XP in diagnostic mode, see Start Windows in Diagnostic mode (Windows XP) (kb404860) for 

details.

• To start Windows Vista/7 in modified mode, see Restart Windows in a modified mode (Windows Vista/7) 
(kb404913) for details.

14. See additional TechNotes.
If the JavaScript errors persist after you follow the suggestions above, then see the following TechNotes for additional 
troubleshooting suggestions. Uninstalling and reinstalling Dreamweaver, with anti-virus software disabled, is an 
important test to perform:

• Troubleshooting Dreamweaver for Windows (tn_15481)

Known JavaScript errors and solutions

JavaScript Error Solution

http://helpx.adobe.com/dreamweaver/kb/restore-preferences-dreamweaver-cs4-cs5.html
http://kb2.adobe.com/cps/401/kb401118.html
http://kb2.adobe.com/cps/404/kb404860.html
http://kb2.adobe.com/cps/404/kb404913.html
http://kb2.adobe.com/cps/154/tn_15481.html
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Troubleshooting synchronization problems in 
Dreamweaver (Mac OS and Windows)

Issue
 When using Dreamweaver's synchronize feature or uploading files to a server, the following problems may occur: 

• You are putting files and Dreamweaver is warning you that the remote file has changed on the server: "my_file.htm 
has changed on the remote server since your last get or put operation. Putting it may overwrite changes to the file. 
Do you wish to put the file anyway?" However, you are sure that the remote files haven't changed. 

• The Synchronize preview dialog box is not correctly listing the files that should be synchronized. 

• The Synchronize preview dialog box says no synchronization is necessary, but you know some files have changed. 

Note: This TechNote only applies to Dreamweaver 8 and later. The synchronize feature was redesigned in Dreamweaver 
8, so the troubleshooting steps mentioned here do not apply to Dreamweaver MX 2004 and earlier. (Ref. 202195) 

Reason
 In Dreamweaver 8 and later, whenever a user puts or gets a file, Dreamweaver locally stores the remote and local 
date/time stamps in files called dwsync.xml which are located in hidden _notes folders in the same folder as the files 
being transferred. Occasionally, the dwsync.xml files can become corrupted. 

Solution
 There are two recommended solutions, depending on how widespread the synchronize problems are. 

Only a few files have synchronization problems

 If only a few of your files are having synchronize problems, try deleting the specifc dwsync.xml files, instead of 
recreating all of the synchronization information for your site. 

1. Close Dreamweaver. 

"The following JavaScript errors occurred: At line 56 of file "C:\ Program 
Files\Adobe\Dreamweaver CS4\Configuration\Shared\Common\ 
Scripts\dwscriptsExtData.js": ReferenceError: dwscripts is not defined."

Remove the WinFileCache-7A9586CB.dat file from the Dreamweaver 
user configuration folder. If that doesn't solve it, then recreate the 
Dreamweaver user configuration folder . These suggestions also apply 
if you are receiving the error message: "The following translators were 
not loaded due to errors."

While executing DWMenu_File_SaveDocumentToRemoteServer 
command in menus.xml, the following JavaScript errors occurred: 
Exception thrown in native function.

See the following TechNote for more information: JavaScript error and 
hang when performing Save To Remote Server (kb401216)

"While executing applyBehavior in Show Pop-Up Menu.htm, the 
following JavaScript errors occurred: At line 27 of file "D:\Program 
Files\Macromedia\DreamweaverMX\Configuration\ 
Behaviors\Actions\Show Pop-up Menu.js":

The image to which you are applying the behavior is not named, or 
there is a problem with the object name. For more information, see 
"Error 'While executing applyBehavior in Show Pop-Up Menu...'" 
(TechNote tn_16462).

http://helpx.adobe.com/dreamweaver/kb/#main_dat
http://helpx.adobe.com/dreamweaver/kb/#main_user_config
http://helpx.adobe.com/dreamweaver/kb/#main_user_config
http://kb2.adobe.com/cps/401/kb401216.html
http://kb2.adobe.com/cps/401/kb401216.html
http://kb2.adobe.com/cps/164/tn_16462.html
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2. In Windows or Mac Finder, browse to your site's local root folder and browse to the folder that contains the files that 
are having synchronization problems. For each folder(s) having synchronization problems, locate the _notes folder and 
delete the dwsync.xml file inside of it. The dwsync.xml files only reside locally. Dreamweaver will never upload the 
dwsync.xml files to the server, and there is no reason to upload them to the server. 

3. Re-open Dreamweaver and see if the problem is resolved. 

Several or all files have synchronization problems

 If you are experiencing widespread synchronization problems, then it is recommended to temporarily disable the 
"Maintain synchronization information" setting so that Dreamweaver recreates all of the synchronization information 
for your site. 

1. Temporarily disable the "Maintain synchronization information" option from the Remote Info category of the 
advanced view of the Site Definition dialog box. This will delete all of the existing dwsync.xml files. 

2. Close Dreamweaver. 

3. Verify that all of the dwsync.xml files have been deleted from your local root folder and all of its subfolders. The 
dwsync.xml files are located in the _notes folder which are hidden by default in Dreamweaver, so check for the _notes 
folders and dwsync.xml files in the Windows or Macintosh file browsers. The dwsync.xml files only reside locally. 
Dreamweaver will never upload the dwsync.xml files to the server, and there is no reason to upload them to the server. 

4. Re-open Dreamweaver and go into the site definition dialog box. Turn "Maintain synchronization information" back 
on. Dreamweaver will now recreate the dwsync.xml files as you transfer files back-and-forth to and from the server. See 
if the problem is resolved. 

Additional Information
For more information on Dreamweaver's synchronize feature, please refer to this section of the Dreamweaver 
documentation: Synchronizing the files on your local and remote sites.

Also, refer to How synchronization works in Dreamweaver 8 (TechNote kb400972).

Troubleshooting Dreamweaver for Windows
What's covered

This TechNote presents a series of steps that test potential sources of trouble for users running Dreamweaver on 
Microsoft Windows operating systems. If you are experiencing crashes, slow performance or unexpected behavior with 
Dreamweaver, the steps below should help either solve the problem or isolate the source. If you are still experiencing 
problems after completing all of the suggested procedures below, please check the additional information section at the 
end of this TechNote.

There are many potential variables involved when troubleshooting these types of issues, so the list of suggestions and 
tests is quite long. We have tried to make this TechNote as comprehensive as possible, but one drawback is that some 
of the most common solutions may be hard to find. The easiest tests and suggestions are near the top, and the more 
drastic or time-consuming suggestions are near the bottom. However, some of the more drastic suggestions, like 
reinstalling Dreamweaver, are often the suggestions that end up solving the problem. To highlight the tips and tests that 
most often solve Dreamweaver issues on Windows, here is an abbreviated list:

Restart Dreamweaver and/or the computer 

http://livedocs.macromedia.com/dreamweaver/8/using/05_sit45.htm
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb400972
http://helpx.adobe.com/dreamweaver/kb/#main_Additional_information
http://helpx.adobe.com/dreamweaver/kb/#main_restarting
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Are you able to launch other Adobe programs? 

Install the latest Dreamweaver updater if available 

Try a new file, in a new site and re-create the site cache 

Re-create the user configuration folder for Dreamweaver 

Reinstall Dreamweaver in Selective Startup Mode or Safe Mode with virus protection disabled 

Here is the comprehensive list:

Verify system requirements 

Are you unable to launch Dreamweaver? 

Are you able to launch other Adobe/Macromedia programs? 

Do problems also occur in other non-Adobe or non-Macromedia programs? 

Gather important background information 

Restart Dreamweaver and/or the computer 

Try a new file, in a new site and re-create the site cache 

Install the latest Dreamweaver updater if available 

Disable the Dreamweaver Start page 

Re-create the Dreamweaver user configuration folder 

Test with a new Windows Admin user account 

1 Does Dreamweaver crash when adding or modifying site definitions? 

Try to run Dreamweaver in Selective Startup Mode 

Try disabling some of the new Vista features 

Turn down hardware acceleration 

Test the video card 

Scan system for viruses and run Windows Update 

Reinstall Dreamweaver in Selective Startup Mode or Safe Mode with virus protection disabled 

Try the same steps on another system 

Download the Dreamweaver installer again 

Uninstall prior versions of Dreamweaver 

Try general Windows utilities 

1. Verify system requirements

Verify that your computer meets the minimum system requirements to run Dreamweaver, as listed in Dreamweaver 
system requirements (TechNote 19124 ).

2. Are you unable to launch Dreamweaver?

If you are unable to launch Dreamweaver, here a few troubleshooting tips in particular to focus on:

• Dreamweaver 8 users should try the suggestions in "Dreamweaver 8 does not launch" (TechNote fb181c10 )

http://helpx.adobe.com/dreamweaver/kb/#main_activation
http://helpx.adobe.com/dreamweaver/kb/#main_updater
http://helpx.adobe.com/dreamweaver/kb/#main_newFile
http://helpx.adobe.com/dreamweaver/kb/#main_userConfigFolder
http://helpx.adobe.com/dreamweaver/kb/#main_reinstall
http://helpx.adobe.com/dreamweaver/kb/#main_sysReq
http://helpx.adobe.com/dreamweaver/kb/#main_launch_DW
http://helpx.adobe.com/dreamweaver/kb/#main_activation
http://helpx.adobe.com/dreamweaver/kb/#main_otherPrograms
http://helpx.adobe.com/dreamweaver/kb/#main_backgroundInfo
http://helpx.adobe.com/dreamweaver/kb/#main_restarting
http://helpx.adobe.com/dreamweaver/kb/#main_newFile
http://helpx.adobe.com/dreamweaver/kb/#main_updater
http://helpx.adobe.com/dreamweaver/kb/#main_startPage
http://helpx.adobe.com/dreamweaver/kb/#main_userConfigFolder
http://helpx.adobe.com/dreamweaver/kb/#main_new_win_acct
http://helpx.adobe.com/dreamweaver/kb/#main_siteDef
http://helpx.adobe.com/dreamweaver/kb/#main_run_in_safe_mode
http://helpx.adobe.com/dreamweaver/kb/#main_disable_vista_fts
http://helpx.adobe.com/dreamweaver/kb/#main_hw_accel
http://helpx.adobe.com/dreamweaver/kb/#main_videoCard
http://helpx.adobe.com/dreamweaver/kb/#main_virusCheck
http://helpx.adobe.com/dreamweaver/kb/#main_reinstall
http://helpx.adobe.com/dreamweaver/kb/#main_diffSystem
http://helpx.adobe.com/dreamweaver/kb/#main_redownload
http://helpx.adobe.com/dreamweaver/kb/#main_prior
http://helpx.adobe.com/dreamweaver/kb/#main_winUtils
http://www.adobe.com/products/dreamweaver/tech-specs.html
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_19124
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=fb181c10
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• Check if it's an activation problem 

• Try disabling the Dreamweaver Start page 

• Check for a corrupt site definition 

• Dreamweaver MX 2004 users should try the following steps. This step does not apply to version MX, 8 or CS3:

1 Press Ctrl+Alt+Delete and click the Task Manager button. Select the Processes tab. If you are using Windows 98, 
you will be presented with a Close Window dialog box, which does not have any tab options.

2 Click on the Image Name column header to sort the processes by name.

3 Locate any dreamweaver.exe processes.

4 Select each process and click End Task for each one.

5 Repeat Step 4 for any ~e5d141.tmp and Macromedia Licensing.exe process(es) running as well, if present.

6 Try to launch Dreamweaver again.

3. Are you able to launch other Adobe/Macromedia programs?

If you are unable to launch Dreamweaver, see if you are able to launch any other Adobe/Macromedia applications (for 
example: Flash, Fireworks, Contribute, Photoshop, Illustrator). If you are unable to launch other Adobe/Macromedia 
programs, then this usually indicates a product activation problem. Dreamweaver CS3 users should refer to CPS 51428. 
Another resource for product activation issues is the Activation Support Center. If you do not own other Adobe 
products, you can download trial versions to test with.

4. Do problems also occur in other non-Adobe or non-Macromedia programs?

If you are experiencing problems with other non-Adobe or non-Macromedia programs in addition to Dreamweaver, 
then you likely have problems with your operating system or a hardware-related issue. These types of issues are beyond 
the scope of this TechNote, so it's recommended that you contact Microsoft or the vendor who sold you the computer 
and let them know that you are experiencing problems with multiple programs. Some of the general Windows 
diagnostics mentioned in this TechNote may help: hardware acceleration , video card , scan for viruses , run in Safe 
Mode , and general Windows utilities .

5. Gather important background information

If the problem only occurs with Dreamweaver, answering the following questions may help you, Dreamweaver forum 
members, or support staff to isolate the problem:

• Did Dreamweaver ever work or has the problem always been present?

• If the problem just started occurring, did anything change on the computer? For example, did you install any new 
software, hardware, drivers or Windows Updates? Was your computer affected by any of the following: virus, power 
outage, or physical trauma?

• Is there an error message associated with the problem? If so, write down the exact text of the error message and any 
error numbers. Some error messages may help support staff or forum participants identify the problem quicker.

• If you are working in a group environment (for example, an office or a school), do other computers in your work 
group have the same problem?

• Look for any Dreamweaver crash logs in one of the following locations. If you contact technical support, they may 
ask you to send these logs. Crash logs were introduced in Dreamweaver MX 2004, so this step doesn't apply to 
Dreamweaver MX (version 6) and earlier.

• Dreamweaver CS3 on Windows Vista: C:\Users\[user]\AppData\Roaming\Adobe\Dreamweaver 
9\Configuration\CrashLogs

http://helpx.adobe.com/dreamweaver/kb/#main_activation
http://helpx.adobe.com/dreamweaver/kb/#main_startPage
http://helpx.adobe.com/dreamweaver/kb/#main_siteDef
http://helpx.adobe.com/x-productkb/policy-pricing/activation-deactivation-products.html
http://www.adobe.com/cfusion/tdrc/index.cfm?product=dreamweaver
http://helpx.adobe.com/dreamweaver/kb/#main_hw_accel
http://helpx.adobe.com/dreamweaver/kb/#main_videoCard
http://helpx.adobe.com/dreamweaver/kb/#main_virusCheck
http://helpx.adobe.com/dreamweaver/kb/#main_run_in_safe_mode
http://helpx.adobe.com/dreamweaver/kb/#main_run_in_safe_mode
http://helpx.adobe.com/dreamweaver/kb/#main_winUtils
http://helpx.adobe.com/dreamweaver/kb//cfusion/webforums/forum/index.cfm?forumid=12
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• Dreamweaver CS3 on Windows XP: C:\Documents and Settings\[user]\Application 
Data\Adobe\Dreamweaver 9\Configuration\CrashLogs

• Dreamweaver 8 on Windows Vista: C:\Users\[user]\AppData\Roaming\Macromedia\Dreamweaver 
8\Configuration\CrashLogs

• Dreamweaver 8 and MX 2004 on Windows XP & Windows 2000: C:\Documents and 
Settings\[user]\Application Data\Macromedia\Dreamweaver [version]\Configuration\CrashLogs

• Check the Windows Event Viewer for clues.

• Windows XP and Windows 2000: Start button > Settings > Control Panel > Administrative Tools > Event 
Viewer. Check the Application log for any Dreamweaver related errors.

• Windows Vista: Start button > Control Panel > click the Classic View link > Administrative Tools > Event 
Viewer. Expand the Windows Logs node and check the Application log for any Dreamweaver related errors.

• Do you have any firewall software or Internet security software installed on your machine? There is a known issue 
with older versions of the CyberArmor firewall software not allowing Dreamweaver to launch. Upgrading to the 
latest version of CyberArmor resolves the issue.

6. Restart Dreamweaver and/or the computer

When a problem first occurs, exit from Dreamweaver and restart it to see if the problem persists. If it does, reboot 
Windows and launch Dreamweaver to see if the problem still occurs. If you are unable to launch Dreamweaver, try the 
following steps:

1 Press Ctrl+Alt+Delete and click the Task Manager button. Select the Processes tab.

2 Click on the Image Name column header to sort the processes by name.

3 Locate any dreamweaver.exe processes.

4 Select each process and click End Task for each one.

Note: This step only applies to Dreamweaver MX 2004: Repeat Step 4 for any ~e5d141.tmp and Macromedia 
Licensing.exe processes running as well, if present.

5 Try to launch Dreamweaver again.

7. Try a new file, in a new site and re-create the site cache

Create a new file (select File > New) to see if the problem persists.

• If the problem does not happen on the new page, this indicates that your installation of Dreamweaver is working 
properly, but some code on the page is causing problems. Slowly rebuild your old page in the new file that works, 
testing at each step of the way. Either you will reconstruct a functional version of the page, or you will be able to track 
down which element on the page is causing the problem.

• If the problem still occurs with a new file, create a new Dreamweaver site definition, and work with a new file within 
the new site definition. If a new file works in a new site, try recreating the Dreamweaver site cache in the old site: 
select Site > Advanced > Recreate Site Cache.

8. Install the latest Dreamweaver updater if available

If an updater is available for your version of Dreamweaver, install it and see if it resolves the problem. For Dreamweaver 
8, install the 8.0.2 updater. For Dreamweaver MX 2004, install the 7.0.1 updater. For Dreamweaver MX, install the 6.1 
updater.

9. Disable the Dreamweaver Start page

If you are having problems launching Dreamweaver, try the suggestions in "How to disable the Start page in 
Dreamweaver" (TechNote 14ca38fb ).

https://www.adobe.com/support/dreamweaver/downloads_updaters.html
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=14ca38fb
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10. Re-create the Dreamweaver user configuration folder

If Dreamweaver starts behaving unpredictably, this sometimes indicates a corrupt user configuration folder. 
Dreamweaver (MX version 6 and later) allows multiple users to log in to a machine and customize Dreamweaver to 
their liking. For example, each user can have different snippets, menu options, extensions, spelling dictionaries, etc. 
These customizations are saved in each user's configuration folder in Windows. To test for a corrupt user configuration 
folder, see "Re-creating the Dreamweaver user configuration folder on Windows" (TechNote 36bda422 ) and "How to 
re-create the Dreamweaver user configuration folder (CS3 on Windows XP, Vista)" (TechNote kb401118 ).

11. Test with a new Windows Admin user account

If re-creating the Dreamweaver user configuration folder as described above does not help, try creating a new Windows 
account with administrator privileges as a test. Do not delete your existing Windows account ; the new account is only 
for testing purposes, and you can revert back to your original Windows account after you finish testing. Once you have 
the new account setup, login to it and see if you can run Dreamweaver.

• On Windows XP, you can create a new user account by going to Start button > Settings> Control Panel > User 
Accounts.

• For Windows Vista, see the " Create new local administrator account " section of "Common Microsoft Windows 
Vista procedures" (TechNote kb401275 ).

For more details on creating a new Windows user account, consult with your IT administrator or the Windows 
documentation.

12. Does Dreamweaver crash when adding or modifying site definitions?

If you are experiencing crashing problems when working with site definitions, refer to "Dreamweaver crashes when 
performing a task related to site definitions" (TechNote 5989f7f4 ) and "Error when accessing sites: Server busy ... the 
other program is busy ... choose 'Switch To' to activate" (TechNote 16485 ).

13. Try to run Dreamweaver in Selective Startup Mode or Diagnostic Mode

Occasionally, other programs and services running on your machine can conflict with Dreamweaver. This includes 
programs that you launch manually as well as programs that startup automatically and run in the background. To 
disable other programs, boot up your system in Selective Startup Mode or Diagnostic Mode. If the problem does not 
occur in Selective Startup Mode or Diagnostic Mode, then it's likely that another application which runs in Normal 
Mode is causing the conflict.

For instructions, see "Running Dreamweaver in Selective Startup Mode and Diagnostic Mode" (TechNote d2a8c508 ).

14. Try disabling some of the new Vista features

If you are running Dreamweaver 8 on Windows Vista try disabling some of the new features to see if they are related to 
the problem you are seeing:

Disabling Visual Themes

1 In Windows Explorer, browse to the Dreamweaver.exe file: C:\Program Files\Macromedia\Dreamweaver 
8\Dreamweaver.exe

2 Right-click Dreamweaver.exe and select Properties > Compatibility tab.

3 Leave the Run This Program In Compatibility Mode For option deselected, but do select "Disable Visual Themes". 
All other checkboxes should be deselected.

4 Click OK and see if the problem stops.

Disabling Aero and running the Windows Vista Basic color scheme

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=36bda422
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb401118
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb401275#create_local_adminacct
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb401275#create_local_adminacct
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=5989f7f4
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_16485
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=d2a8c508


23

Last updated 11/5/2015

If you have the Vista Aero user interface turned on, the try disabling it as a test. To disable Aero:

1 Choose Start > Control Panel.

2 Choose Classic View in the left pane.

3 Double-click Personalization and select Window Color And Appearance.

4 Click Open Classic Appearance Properties For More Color Options.

5 Select Windows Vista Basic and click OK.

6 Try to reproduce the problem.

To reenable Aero after testing:

1 Choose Start > Control Panel.

2 Choose Classic View in the left pane.

3 Double-click Personalization and select Window Color And Appearance.

4 Choose Windows Aero from the Color Scheme menu and click OK.

Running Dreamweaver in Windows XP Compatibility mode

1 Navigate to the C:\Program Files\Macromedia\Dreamweaver 8 folder.

2 Right-click on the Dreamweaver.exe file and select Properties.

3 Click on the Compatibility tab.

4 Click Run This Program In Compatibility Mode For: and select Windows XP (Service Pack 2).

5 Select Run This Program As An Administrator.

Disabling User Account Control (UAC)

The Vista User Account Control (UAC) feature can help prevent unauthorized changes to your computer. Microsoft 
recommends that you leave UAC turned on to help protect your computer. After running this test, turn UAC back on.

To disable UAC:

1 Choose Start > Control Panel.

2 Choose Classic View in the left pane.

3 Choose User Accounts.

4 Click Turn User Account Control On Or Off.

5 Deselect Use User Account Control (UAC) To Help Protect Your Computer and then click OK.

6 Restart your computer.

15. Turn down hardware acceleration

Hardware acceleration is a setting for the video card driver that allows it to interact with some of your system's resources 
in rendering the screen display. By default, hardware acceleration is set to 'Full'. Turning down this default setting 
sometimes resolves display problems and crashing issues. The steps for changing this setting are:

1 Right-click in a blank area of the Windows Desktop.

2 Do one of the following:

• Windows XP and 2000: choose Properties > Settings tab> Advanced button > Troubleshoot. The location of the 
hardware acceleration control may differ for your video card driver.
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• Windows Vista: choose Personalize > Display Settings > Advanced Settings button > Troubleshoot tab > Change 
Settings button.

3 Slide system hardware acceleration from Full to None.

4 Restart the computer.

5 Launch Dreamweaver.

6 Increase hardware acceleration gradually to find a setting that does not conflict with Dreamweaver.

16. Test the video card

Invalid page faults, general protection faults, freezes, and other problems are sometimes caused by a conflict with a 
Windows device driver, most commonly a video card. These types of conflicts are often resolved with new driver 
releases available from the manufacturer's website (usually a small and free download). In some cases, rolling back to 
a prior version of a driver may be the solution.

Windows Vista: See " Verify that device drivers are compatible with Windows Vista " in "Common Microsoft Windows 
Vista procedures" (TechNote kb401275 ).

Windows XP: To test for a video card driver conflict, disable the device in Device Manager:

1 Right-click My Computer, select Properties, and select the Hardware tab.

2 Click the Device Manager button.

3 Expand the Display Adapters node, right-click the video card, and select Disable.

4 Restart the computer.

5 Launch Dreamweaver and test to see if the problem persists. If the problems stop, then the video card driver is the 
likely culprit. However, even if the problems persist, updating to the most recent or a different driver may still be the 
solution. You can find the name of the video card model and manufacturer in the Settings tab.

Downloading and installing a new driver

Visit the manufacturer's website to download and install the most recent driver according to the manufacturer's 
instructions. You can also find updated drivers by visiting Microsoft's Windows Update website. Restart your computer 
after installing the updated driver before testing to see whether the problem has stopped.

17. Scan system for viruses and run Windows Update

Crashes and lockups can be caused by a virus on the system. Install anti-virus software if you do not have it already, 
update the virus definition files and run a full system scan. Update your virus scanning software frequently and keep 
your operating system up-to-date with the latest service packs and security updates from Microsoft's Windows Update 
website.

18. Reinstall in Selective Startup Mode or Safe Mode with virus protection disabled

Some problems with Dreamweaver are caused by a corrupt or incomplete installation. For most users, Dreamweaver 
installs fine without any special set of actions. However, if you have experienced problems with a prior installation of 
Dreamweaver, you may want to consider reinstalling Dreamweaver using the guidelines below.

One of the most common causes of Dreamweaver crashes and JavaScript errors inside the Dreamweaver authoring 
environment is installing Dreamweaver when virus protection software is running. Reinstalling while booted up in 
Selective Startup Mode or Safe Mode should automatically disable your anti-virus software. These modes will load only 
the minimal required number of components needed to run the operating system, which may eliminate software that 
is conflicting with the Dreamweaver installation.

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb401275#restart_windows_modified_mode
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb401275
http://update.microsoft.com/microsoftupdate/v6/vistadefault.aspx?ln=en-US
http://update.microsoft.com/microsoftupdate/v6/vistadefault.aspx?ln=en-US
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Note: This does not mean running Dreamweaver after installation without virus protection. However, modifying your 
virus protection settings may result in improved system performance when using Dreamweaver. Please refer to "Slow 
system performance using Dreamweaver" (TechNote tn_16104 ) for more information.

To ensure a clean installation when troubleshooting, first completely uninstall Dreamweaver using the TechNote below 
applicable to your version of Dreamweaver:

• "Remove Creative Suite 3 and CS3 components from Windows XP, Windows Vista and Mac OS" (TechNote 
kb401090 )

• "Uninstalling Studio 8 applications on Windows" (TechNote 4e7826b7 )

• "Uninstalling Dreamweaver MX & MX 2004 on Windows" (TechNote 362d7b81 )

Then reinstall Dreamweaver in Selective Startup Mode or Safe Mode using the TechNote below applicable to your 
version of Dreamweaver:

• "Installing Dreamweaver CS3 in Selective Startup Mode on Windows Vista" (TechNote kb401454 )

• "Installing Dreamweaver in Selective Startup Mode on Windows XP" (TechNote d2b5934d )

• "Installing Dreamweaver MX & MX 2004 in Safe Mode on Windows" (TechNote 362eefb2 )

19. Try the same steps on another system

Testing on another system can sometimes help you determine if the problem is specific to a particular system or 
configuration. If the problem is not reproducible on another system, focus attention on any differences between the two 
systems to help determine the cause of the problem. If the problem is reproducible on another machine, this could 
indicate that these two systems both have a common conflict with Dreamweaver or it could be an instance of a bad 
installation CD.

20. Download the Dreamweaver installer again

If you downloaded the Dreamweaver installer from the Adobe website, the file may have been corrupted during the 
download process. Download the installer again and install in Selective Startup Mode or Safe Mode as described above. 
Please refer to "Download help" (ServiceNote 15296 ) for more details.

21. Uninstall prior versions of Dreamweaver

Though unlikely, an existing installation of an older version of Dreamweaver may be causing a conflict with the newer 
version of Dreamweaver. To correct this problem, try uninstalling the older version of Dreamweaver using Add Or 
Remove Programs on Windows XP and Windows 2000 (select Start > Settings > Control Panel), or using Programs And 
Features on Windows Vista (select Start > Control Panel > Classic View). If you uninstall all versions of Dreamweaver, 
only reinstall the newer version. Before uninstalling, back up any site definitions you want to continue using and any 
special customizations you may have made to Dreamweaver (snippets, menu options, extensions, spelling dictionaries, 
etc.) as described in "Backing up and restoring Dreamweaver settings" (TechNote 18736 ).

22. Try general Windows utilities

If the suggestions above do not help, then you may want to try some general Windows system utilities like Disk 
Cleanup, ScanDisk, Defrag (Disk Defragmenter), chkdsk, System Restore, System File Checker, Norton Utilities, other 
tools and lastly, reinstalling the Windows operating system. Please note that running these tools and operations can 
have a wide ranging impact on your system's functionality, so use caution. Some of these utilities should only be run by 
advanced users and only after exhausting all other options. For more details on how to run these utilities, please see the 
Windows documentation or search on the Internet.

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_16104
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb401090
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=4e7826b7
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=362d7b81
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb401454
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=d2b5934d
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=362eefb2
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15296
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_18736
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Additional Information
Below you will find additional Windows TechNotes and articles from Adobe and third parties:

• Adobe product activation center

• Software installation

• "Troubleshooting Ikernel and InstallShield installation issues" (TechNote 18662 )

• "Backing up and restoring Dreamweaver settings" (TechNote 18736 )

• InstallShield consumer site, http://consumer.installshield.com/

• "Network install of Dreamweaver not working properly" (TechNote 15216 )

• Selective Startup Mode and Clean Boot

• How to Perform a Clean Boot in Windows XP (Microsoft)

• Also, see the Windows help files and Microsoft support site

• "Windows installation troubleshooting" (TechNote 15492 )

• "Troubleshooting JavaScript errors in Dreamweaver" (TechNote 19105 )

• "Serial number not accepted" (ServiceNote 15282 )

• Trial version

• "Early expiration" (ServiceNote 12824 )

• Also, see the ServiceNotes listed in Customer Service's Trial Download Information section.

• General Windows troubleshooting

• Troubleshooting Windows XP / Tips and Tricks (Microsoft TechNet)

• "Fonts in Dreamweaver panels display incorrectly" (TechNote 13862 )

• "Troubleshooting FTP issues" (TechNote 14834 )

• "Trouble installing extensions for Dreamweaver" (TechNote 15134 )

You can also search the Dreamweaver Support Center for TechNotes related to problems you may be experiencing. 
Also, consider searching existing posts on the Dreamweaver forum and submitting your own post if your question 
hasn't already been answered. Dreamweaver forum participants include Adobe Product Support specialists, Adobe 
Community Experts, professional web developers and new Dreamweaver users. For more information about posting, 
see "Dreamweaver online forums" (TechNote 12606 ).

If you have purchased a copy of Dreamweaver and need direct one-to-one assistance, please contact Adobe Product 
Support. Note that one-to-one technical support is not available for the trial version. Trial users should use the 
Dreamweaver forum for assistance.

Troubleshoot Dreamweaver on Macintosh OS X
Introduction

 This TechNote suggests some general troubleshooting techniques for issues or unexpected behavior with Macromedia 
Dreamweaver MX, Dreamweaver MX 2004 and Dreamweaver 8 running on Apple Macintosh OS X. Answers to 
common questions and additional information are at the end of the TechNote. 

http://www.adobe.com/products/activation/
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_18662
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_18736
http://consumer.installshield.com/
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15216
http://support.microsoft.com/?id=310353
http://support.microsoft.com
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15492
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_19105
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15282
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15324
https://helpx.adobe.com/contact.html
http://www.microsoft.com/technet/community/events/winxppro/tnt1-93.mspx
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_13862
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_14834
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15134
https://www.adobe.com/support/dreamweaver/
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_12606
http://www.adobe.com/support/contact/
http://www.adobe.com/support/contact/
http://helpx.adobe.com/dreamweaver/kb/#main_common
http://helpx.adobe.com/dreamweaver/kb/#main_additional_info
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Note: This TechNote includes information specific to Dreamweaver. Users should use this TechNote in conjunction 
with General Macintosh troubleshooting (TechNote tn_3500), which describes basic troubleshooting steps appropriate 
for all Macromedia products on Macintosh OS X. 

The information is divided into three main sections: 

• Collecting information 

• Isolating the problem 

• Searching for a workaround 

Collecting Information

 Troubleshooting problems with Dreamweaver is generally easier when complete information and conditions to 
reproduce the issue are available. Information to help narrow down the problem can be found by answering the 
questions below. 

• Does the computer meet the minimum system requirements for Dreamweaver? 

• Are Background Maintenance Tasks run on a regular basis? 

• Which applications are executing when the computer starts? (this is covered in the General TechNote ) 

• Which applications are running before Dreamweaver starts? (this is covered in the General TechNote ) 

• Is there any way to get detailed reports about crashes? (this is covered in the General TechNote ) 

Does the computer meet the minimum system requirements for Dreamweaver?

Verify that your system meets the minimum requirements. Running below or without the advertised minimum 
requirements may cause the software to malfunction.

• Dreamweaver 8: 600 MHz PowerPC G3 and later Macintosh OS X 10.3 and later 256 MB RAM 300 MB available 
disk space You must have at least 1024 x 768, thousands of colors monitor, although millions of colors is 
recommended.Note: This product must be activated over the Internet prior to use. Visit the Product Activation 
Center to learn more about activation.

• Dreamweaver MX 2004: 500 MHz Power PC G3 processor Macintosh OS X 10.2.6 and later, 10.3 128 MB computer 
RAM (256 MB recommended) 275 MB available disk space You must have at least 800 x 600, thousands of colors 
monitor, although 1024 x 768, millions of colors is recommended.Note: This product must be activated over the 
Internet or phone prior to use. Visit the Product Activation Center to learn more about activation.

• Dreamweaver MX: A Power Macintosh G3 or better Macintosh OS 9.1 and higher or Macintosh OS X 10.1 and 
higher 96MB RAM (128 MB recommended) 275 MB of available disk space You must have at least 800 x 600, 
thousands of colors monitor, although 1024 x 768, millions of colors is recommended.

Note: Unix File System (UFS) is not a supported File system format to use with Dreamweaver on Macintosh OS X 10.x. 
Use Macintosh OS Extended (Journaled) HFS formatting in your hard disks.

Are Background Maintenance Tasks run on a regular basis?

 Some developers report that aberrant behavior is corrected, and application performance improved, when Background 
Maintenance Tasks have been run. It is recommended these tasks be run on a regular basis. Please refer to the Apple 
Support Article ID 107388 for more information. 

Isolating the problem

 After confirming system requirements are met, and information is collected about applications running at the same 
time as Dreamweaver, isolation of the problem can begin. 

• Does the problem happen when Classic mode is not running? (this is covered in the General TechNote ) 

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500
http://helpx.adobe.com/dreamweaver/kb/#main_collecting
http://helpx.adobe.com/dreamweaver/kb/#main_isolating
http://helpx.adobe.com/dreamweaver/kb/#main_workaround
http://helpx.adobe.com/dreamweaver/kb/#main_systemrequirements
http://helpx.adobe.com/dreamweaver/kb/#main_bgmaint
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#running
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#running
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#log
http://helpx.adobe.com/x-productkb/policy-pricing/activation-deactivation-products.html
http://helpx.adobe.com/x-productkb/policy-pricing/activation-deactivation-products.html
http://helpx.adobe.com/x-productkb/policy-pricing/activation-deactivation-products.html
http://docs.info.apple.com/article.html?artnum=107388
http://docs.info.apple.com/article.html?artnum=107388
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#no_classic
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• Is there a conflict with another application? 

• Could the problem be the preferences file? 

• Is there a problem with permissions? (this is covered in the General TechNote ) 

• Corrupt fonts or possible problem with Extensis Suitcase or DiamondSoft Font Reserve (this is covered in the 
General TechNote ) 

• New window disappearing on a second monitor? 

• Dreamweaver help is not working (this is covered in the General TechNote ) 

• Where did the sites, or extensions, go when I logged in as a different user? (this is covered in the General TechNote ) 

• Has the hard drive been checked for corruption? 

• Other Macintosh OS X 10.x troubleshooting 

• Can you reproduce the problem in Macintosh OS 9? (For Dreamweaver MX only) 

Is there a conflict with another application?

 Close all other applications and verify that the problem persists when Dreamweaver is the only application running. A 
list of running applications can be viewed in the Force Quit Applications window by pressing Option-Apple-Escape. 
For advanced users the ProcessViewer utility (found in /Applications/Utilities) provides some information about 
currently running applications. 

Additional information can be found by running the Unix top utility in the terminal window, which shows the name 
of the application. For additional information about processes and daemons please see the articles, Mac OS X Server: 
Processes and Mac OS X: What are all those processes?. 

Could the problem be the preferences file?

 Because the preferences file for Dreamweaver is generally updated more frequently than other Dreamweaver files, the 
chances of that file becoming corrupt is greater. To test the Dreamweaver preference file, move or rename the file while 
Dreamweaver is not running, restart Dreamweaver and try reproducing the issue. Dreamweaver will create a new 
preferences file that should eliminate issues associated with a corrupt file. 

Note: Dreamweaver site definitions are stored in the preferences file, so use the export/import functionality built into 
the Sites dialog box before performing this test. The Dreamweaver Preference file is located in the 
HD:Users:[username]:Library:Preferences folder, named as follows: 

• Dreamweaver 8 Prefs 

• Dreamweaver MX 2004 Prefs 

• Dreamweaver MX Prefs 

New window disappearing on a second monitor?

 Several customers have reported issues when opening new files on a second monitor. The new window appears as a 
small rectangle about five to ten pixels down the side of the second display screen. The workaround is to move the title 
bar to the first display screen and resize the window by dragging the bottom right corner. 

Has the hard drive been checked for corruption?

 There are several utilities that examine and repair disk corruption. Knowledge Base document, Mac OS X: About Using 
Disk Utility and fsck for File System Maintenance describes the use of these utilities. In addition, there are third-party 
utilities to fix certain types of disk corruption. 

Can you reproduce the problem in Macintosh OS 9?

http://helpx.adobe.com/dreamweaver/kb/#main_application_conflict
http://helpx.adobe.com/dreamweaver/kb/#main_preferences
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#permissions
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#fonts
http://helpx.adobe.com/dreamweaver/kb/#main_dual_displays
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#help
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#multiuser
http://helpx.adobe.com/dreamweaver/kb/#main_disk
http://helpx.adobe.com/dreamweaver/kb/#main_other
http://helpx.adobe.com/dreamweaver/kb/#main_os9
http://docs.info.apple.com/article.html?artnum=106415
http://docs.info.apple.com/article2.html?artnum=60053
http://docs.info.apple.com/article2.html?artnum=60053
http://www.westwind.com/reference/OS-X/background-processes.html
http://docs.info.apple.com/article.html?artnum=106214
http://docs.info.apple.com/article.html?artnum=106214
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Note: This is a useful step for Dreamweaver MX users, but Dreamweaver 8 and Dreamweaver MX 2004 do not run 
under classic mode. Dreamweaver 8 and MX 2004 require Macintosh OS X. 

Another useful piece of information is whether or not the problem can be reproduced in Macintosh OS 9.x. Please note, 
this is not the same as running in classic mode. To run the applications in Macintosh OS 9.x you will need to restart the 
computer. The Apple Knowledge Base document, How to Switch Between Mac OS 9 and Mac OS X, describes switching 
between Macintosh OS 9.x and Macintosh OS X. 

If the problem cannot be reproduced in Macintosh OS 9.x, further investigation should determine if the problem is with 
the Dreamweaver MX installation by using a new account with admin privileges to see if the problem is reproduced. 

Searching for a workaround

 Most issues with Dreamweaver can be fixed once the problem has been defined, but some issues may require 
reinstalling Dreamweaver or disabling a corrupt font. 

• How do I uninstall Dreamweaver? 

• How do I reinstall Dreamweaver? 

• How to disable a font? 

How do I uninstall Dreamweaver?

 Please refer to Uninstalling Studio 8 applications on Macintosh OS X (TechNote 8f101099) for instructions on 
Dreamweaver uninstallation. Before uninstalling, make sure to back up important sites and customized settings; see 
Backing up and restoring Dreamweaver settings (TechNote tn_18736) for details. 

How do I reinstall Dreamweaver?

1 Copy the Dreamweaver installer from the CD to the Desktop. (Browse the CD and look for FSCOMMAND > 
DW_client_installer.

2 Shut down 10.x ( Apple Menu > Shut Down)

3 Turn on the machine and hold down the Shift key to start in Safe Boot (also called Safe Mode).

4 Run the Dreamweaver installer in Safe Mode.

5 Restart the machine to log out of Safe Mode.

How to disable a font?

Mac OS X error when launching Fireworks (TechNote tn_16404) describes how to disable fonts. To add or remove 
Classic Fonts from the Font folder, please see Apple knowledge base document, How to Add or Remove Classic Fonts. 
Another font resource is the knowledge base document, Font Locations and Their Purposes.

Other Macintosh OS X 10.x Troubleshooting

• Run the Hotfix for Macromedia Installers Please refer to Some applications do not run after upgrading Macintosh 
OS X versions (ServiceNote tn_18933). Note: This step does not apply to Dreamweaver 8.

• Run Macromedia License Cleaner Please refer to Macromedia License Cleaner. Note: This step does not apply to 
Dreamweaver 8.

• Disable Start Page Some users have encountered issues where the start page of Dreamweaver causes the application 
to hog memory or causes launching issues. This issue was first reported on Macintosh OS X 10.3.9. In most cases, 
turning off the start page would resolve the issue.

1 Go to HD:Users:[username]:Library:Preferences:Dreamweaver 8 Prefs.

2 Open the preference file in Text Edit (Control + Select the preference file and choose Open with > Text Edit).

3 In Text Edit, Choose Edit > Find >Find (Apple Command + F) and look for GENERAL PREFERENCES.

http://www.info.apple.com/kbnum/n106667
http://helpx.adobe.com/dreamweaver/kb/#main_uninstall
http://helpx.adobe.com/dreamweaver/kb/#main_reinstall
http://helpx.adobe.com/dreamweaver/kb/#main_disable_font
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=8f101099
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_18736
http://docs.info.apple.com/article.html?artnum=107393
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_16404
http://docs.info.apple.com/article.html?artnum=106737
http://docs.info.apple.com/article.html?artnum=106417
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_18933
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_18933
https://www.adobe.com/support/service/activation/license_cleaner.html
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4 Change the line show start page=True to show start page=False.

5 Save the file (File > Save).

6 Test Dreamweaver 8.Note: Deleting or uninstalling/reinstalling Dreamweaver 8 will revert the preference file to 
its default settings.

• Create a New user account on Macintosh OS X 10.x with Administrator privileges (this is covered in the General 
TechNote ) 1. Go to Apple menu > System Preferences. 2. Launch Accounts dialogue in the System category. 3. Click 
the plus (+) button for New User 4. Supply all the fields in the New user dialogue window and make sure you check 
(select) "Allow user to administer this computer" in the Security tab.Note: If this option is unavailable, you might 
not be the Administrator of your machine and you may need to ask the Administrator to do this step for you. 5. Log 
on as the New User account (Apple Menu > Log out as [username]). 6. Test Dreamweaver. Note: If the problem goes 
away there may be some problem with the original account. You may consider Repairing Disk Permission.

• Repair Mac OS X permissions Permission repair in Mac OS X 10.2 or later means increasing the startup speed, 
performance and stability of the operating system. It is a good practice to repair permissions periodically. 
Permissions are privileges given to files, folders, and directory structures in Mac OS X. When files come from 
another operating system, or are installed without having correct permissions, problems may occur. For additional 
information about the Repair Disk Utility of Macintosh OS X, visit the Apple knowledge base document 
Troubleshooting permissions issues in Mac OS X.Note: You may need to verify if you have the latest update for the 
Operating System. Visit the Apple website to check for the latest update for your Operating System.

Answers to common questions

• If Dreamweaver MX is installed on Macintosh OS 9, will it run on Macintosh OS X?Yes

• If Dreamweaver MX is installed on Macintosh OS X, will it run on Macintosh OS 9?Yes

• How do I enable the root account on Macintosh OS X?Apple describes how to enable root access in the knowledge 
base document, Enabling and using the "root" user in Mac OS X.

• Where are Dreamweaver Extensions installed?Extensions installed by users are stored in 
/Users/USERNAME/Library/Application Support/Macromedia Dreamweaver 8/Configuration.

Additional information

 Below you will find additional troubleshooting TechNotes and links to more resources: 

TechNotes on specific Macintosh issues

• General Macintosh Troubleshooting (TechNote tn_3500) 

• Known Macintosh conflicts (TechNote tn_15014) 

• Memory issues on the Macintosh (TechNote tn_14263) 

• FreeHand troubleshooting for the Macintosh (TechNote tn_15821) 

• Fireworks MX 2004 is not supported in a UFS formatted hard drive in Macintosh OS X 10.x (TechNote tn_19425) 

• Some applications won't run after upgrading to Macintosh OS X version 10.2.8 or to Panther (version 10.3) 
(ServiceNote tn_18933) - only applies to Dreamweaver MX 2004 users. 

• Macromedia License Cleaner - only applies to Dreamweaver MX 2004 users. 

• Macintosh OS 9.1 issues (TechNote tn_15072) - only applies to Dreamweaver 4 and Dreamweaver UltraDev 4 users. 

TechNotes on Font issues

• How to detect a corrupt font on the Macintosh (TechNote tn_15830) 

• Mac OS X error when launching Fireworks MX (TechNote tn_16404) 

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#other_accounts
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500#other_accounts
http://docs.info.apple.com/article.html?artnum=106712
http://www.apple.com
http://docs.info.apple.com/article.html?artnum=106290
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_3500
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15014
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_14263
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15821
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_19425
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_18933
http://helpx.adobe.com/dreamweaver/kb//support/service/activation/license_cleaner.html
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15072
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15830
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_16404
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• Font installation in Macintosh OS X (TechNote tn_15818) 

• Font Locations and Their Purposes (Apple Knowledge Base document 106417) 

• To Add or Remove Classic Fonts (Apple Knowledge Base document 106417) 

Third-party resources

• Mac OS X: Troubleshooting a Startup Issue (Apple Support Article ID 106464) 

• Mac OS X: How to Force Background Maintenance Tasks (Logs and Temporary Items) (Apple Support Article ID 
107388) 

• Common system error messages: what they mean and what might help resolve the problem (Apple Support Article 
ID 55743) 

• Mac OS X 10.2, 10.3: Starting up in Safe Mode (Apple Support Article ID 107393) 

• Choosing UFS or Mac OS Extended (HFS Plus) Formatting (Apple Support Article ID 25316) 

• Enabling and using the "root" user in Mac OS X (Apple Support Article ID 106290) 

• Troubleshooting permissions issues in Mac OS X (Apple Support Article ID 106712) 

• Troubleshooting solutions for the Macintosh can be found at the following web site: http://www.macfixit.com

Third party links

Although links to external web sites are provided as a resource, the web sites are not part of Macromedia. Please see the 
Macromedia policy regarding links to third party web sites in the Legal Notices and Information section. Pages to 
external web sites will open in a new browser window.

Understanding the Template Updating option in 
Dreamweaver 8.0.1-8.0.2
Description

 After updating from Dreamweaver 8.0 to either Dreamweaver 8.0.1 or 8.0.2, you will see a new Templates category 
added to the Site Definition dialog box. This category consists of just one checkbox: "Template Updating: Don't rewrite 
document relative paths" (shown below): 

Why would you want to uncheck the Template Updating checkbox?

By default, the Template Updating checkbox is checked. If your template workflow matches the three-step workflow 
listed below, you might want to consider unchecking the Template Updating checkbox, otherwise, you should leave it 
checked. You should consider unchecking the checkbox if your workflow includes all of the following items:

1 You are using a Dreamweaver template (DWT file).

2 The DWT file contains relative paths pointing to server-side include (SSI) files, CSS files, links or images.

3 The SSI files, CSS files, links, or images being pointed to are also located in the Templates folder along with the DWT 
file. In other words, your Templates folder contains non-template items.

 If you are not using Dreamweaver templates, or you only have DWT files in your Templates folder, you can most likely 
leave this checkbox checked (the default setting). 

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15818
http://docs.info.apple.com/article.html?artnum=106417
http://docs.info.apple.com/article.html?artnum=106737
http://docs.info.apple.com/article.html?artnum=106464
http://docs.info.apple.com/article.html?artnum=107388
http://docs.info.apple.com/article.html?artnum=55743
http://docs.info.apple.com/article.html?artnum=107393
http://docs.info.apple.com/article.html?artnum=25316
http://docs.info.apple.com/article.html?artnum=106290
http://docs.info.apple.com/article.html?artnum=106712
http://www.macfixit.com/
http://helpx.adobe.com/en/dreamweaver/dreamweaver-copyright-trademarks-third-party-notices.html
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What changed in Dreamweaver 8.0?

 Dreamweaver MX 2004 and Dreamweaver MX would not touch any path that pointed into the Templates folder, 
inconsistent from how Dreamweaver would deal with any other types of paths in a template. Due to complaints from 
some Dreamweaver MX 2004 and Dreamweaver MX users regarding this inconsistency, Dreamweaver 8.0 was changed 
so that it treated paths into the Templates folder just like it treated any other path. This change caused problems for 
some Dreamweaver users though, who were used to the Dreamweaver MX 2004 behavior. 

In Dreamweaver 8.0, new pages created from templates with paths that pointed into the Templates folder, always had 
the Templates folder added to the path. For example, in Dreamweaver 8.0, the following code in the parent template 
DWT file in either a non-editable or editable region: 

<!--#include -->

 would be rewritten to something similar to one of the following paths when a new child page was created from the 
template: 

<!--#include --><!--#include -->

 The Dreamweaver 8.0 way of writing paths is problematic if you want the item being linked to, to be relative to the child 
pages and not to the parent template. For example, each of your template child pages may have its own CSS, SSI or image 
file. In the sample site below, each department has its own unique SSI file that consists of department-specific content, 
but the SSI files are all named include.inc. 

Since the include files' names are the same for all departments, you may have manually entered the path <!--#include -
-> in the parent template file. 

Note: When entering paths in Dreamweaver templates, it is recommended to browse to the file through the 
Dreamweaver user interface, so Dreamweaver writes the path for you. Manually entering a path in a Dreamweaver 
template is not a recommended workflow. However, you may find your setup similar to the one above, and there may 
not be a better alternative for your project. 

In the example site above, my_template.dwt has the following path: 

<!--#include -->

 When you create the child page hr_child_pg.htm from my_template.dwt, the include file path turns into this: 

<!--#include -->

 Since there isn't an include.inc file in the Templates folder, the page breaks. You can't workaround this problem by 
placing the include.inc file in the Templates folder, because each include.inc file in the different departments' subfolders 
actually has different content, even though they all share the same file name. A site root relative path also can't be used 
because each department's include file has different content -- a site root relative path would just point to one of the 
include.inc files. 

How Dreamweaver MX 2004 and Dreamweaver MX wrote paths

 In Dreamweaver MX 2004 (version 7) and Dreamweaver MX (version 6), the following code in the parent template 
DWT file in either a non-editable or editable region: 

<!--#include -->

would remain untouched when a new child page was created from the template: 

<!--#include -->
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How to get Dreamweaver 8 to leave these paths alone

With the Dreamweaver 8.0.2 or 8.0.1 Updaters, the Template Updating checkbox is checked by default, which means 
the default behavior is now to leave relative paths alone that point to items located inside the Templates folder, which 
is the same behavior as Dreamweaver MX 2004 and Dreamweaver MX. If you would prefer to have Dreamweaver 8.0.2 
or 8.0.1 treat relative paths that point to items located inside the Templates folder as it would any other path and re-
write them, then go into the Site Definition dialog box and uncheck the Template Updating checkbox. That way, 
Dreamweaver will add the Templates folder to the path, which was the default behavior and only option in 
Dreamweaver 8.0.

How synchronize works in Dreamweaver 8
For the Dreamweaver 8 release, Adobe did a major redesign of Dreamweaver's synchronize feature. While the 
synchronize feature worked great for most users, some users were encountering accuracy problems. The new algorithm 
implemented in Dreamweaver 8 gets used when synchronizing files. But it's also used to determine whether remote files 
have changed on the server when putting. That way, Dreamweaver can warn you that you could be overwriting changes 
on the server.

Note: This TechNote only applies to Dreamweaver 8 and later. The synchronize feature was redesigned in Dreamweaver 
8, so the information mentioned here does not apply to Dreamweaver MX 2004 and earlier.

How Dreamweaver MX 2004 determines whether a file has changed locally, 
remotely or both
Dreamweaver MX 2004 determined whether a local file is newer than the remote file by figuring out the difference 
between the time stamp of the local file and of the remote file. Then, it adjusted for the difference in remote server time 
versus local machine time. This method worked, but there were a few flaws in the system. FTP servers don't return 
seconds, and when files are from a previous year, don't even return an hour and minute. Also, machine times can drift 
over time at different rates. So that Dreamweaver MX 2004 knew for certain that the remote and local files were 
identical, it set the local time stamp to match the remote time stamp after every put or get. This method led to a usability 
issue, since you now don't really know when a file was last updated locally. Dreamweaver 8 no longer alters the 
date/time stamp of the local file to match the remote date/time stamp. So, it reflects the local time when the file was last 
saved.

The dwsync.xml file
Whenever you put or get a file, Dreamweaver 8 now locally stores the remote and local date/time stamps in files called 
dwsync.xml. These files are in the hidden _notes folder in the same folder as the files being transferred. All files in a 
folder store their date/time stamp in that folder's dwsync.xml file. Therefore, there is only one dwsync.xml file per 
folder. If your site has multiple subfolders, then you also have multiple dwsync.xml files and _notes folders one 
dwsync.xml file and one _notes folder for each subfolder. While the _notes folder is primarily used to hold Design 
Notes, the dwsync.xml file is not considered a Design Note. The dwsync.xml files only reside locally. Dreamweaver 
never uploads the dwsync.xml file to the server, and there is no reason to upload it to the server.

New algorithm for determining whether a file has changed locally, remotely, 
or both
When Dreamweaver 8 needs to determine which files to upload to the server or download from the server, it uses the 
following algorithm:

https://www.adobe.com/support/dreamweaver/downloads_updaters.html
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If the dwsync.xml file exists, and there is an entry for the file in the dwsync.xml file:

Dreamweaver 8 checks to see if there is an entry in the dwsync.xml file for the local file. If so, Dreamweaver sees if the 
time stamp in dwsync.xml for the local file is different from the current time stamp of the local file. If so, the local file 
has been altered since the last get or put. Dreamweaver does the same check for the remote file. If the remote file time 
stamps do not match, the remote file has been changed since the last get or put you did.

If the dwsync.xml file does not exist, or if there is no entry for the file in the dwsync.xml file:

If no dwsync.xml file exists and the time stamps are the same, Dreamweaver still assumes that the files are identical. If 
no dwsync.xml file exists or no entry for that file is in the dwsync.xml file, Dreamweaver falls back to figuring out the 
newer file using the time stamps and machine time stamp difference. The exception is when the difference in file time 
stamps is smaller than the difference in machine times. For that scenario, Dreamweaver can't determine with 
confidence whether the local file or the remote file or both files have changed. This issue was the primary source of 
problems where Dreamweaver MX 2004 said that the remote file was newer. Therefore, Dreamweaver 8 now leaves it 
up to you to tell Dreamweaver which file is the correct one or to do a merge of the files.

Dreamweaver 8 synchronize statuses
In Dreamweaver 8, each file evaluated now has a status of "Local Newer," "Remote Newer," "Same," or "Don't know." 
During synchronize, "Local Newer" files are uploaded, "Remote Newer" files are downloaded and "Same" files are not 
uploaded or downloaded. Finally, "Don't know" files are reported to you to allow you to merge the files or figure out 
which file is newer.

Local Newer If the local file has changed and the remote file hasn't changed.

Remote Newer If the remote file has changed and the local file hasn't changed.

Don't Know If both files have changed or if no entry exists for that file.

Same If neither file has changed or no entry exists and the time stamps are the same.

Changes to the Synchronize dialog box
The Synchronize functionality in Dreamweaver 8 uses the new algorithm for comparing files. Therefore, there is a new 
category of files to list those in which Dreamweaver cannot determine whether the local or remote file is the newer file. 
Dreamweaver MX 2004 only listed files it was going to Get, Put, or Delete. Dreamweaver 8 lists all of the files so you 
get a clear picture of what Dreamweaver is doing. The choices in the Action column are: Put, Get, Resolve, Delete, 
Ignore, or Synchronized. If the Action is Ignore, the Status column indicates why either "The local and remote version 
of the file changed since the last synchronization. Please decide whether to put or get this file." or "Not enough 
information to synchronize".

You have the option of seeing files Dreamweaver thinks are already synchronized or that Dreamweaver would ignore 
by clicking the "Show all files" checkbox. By default, this is deselected so that Dreamweaver doesn't clutter the dialog 
box with all of the already synchronized files.

You can make a selection of files and change what Dreamweaver does when you click OK. All of these buttons change 
the action to be performed but don't perform the action until you click OK. Here's what clicking each of the buttons in 
the above dialog does:

Mark selected files to get the testing version If you are doing a two-way synchronize, you can choose whether to 
Get the file by clicking this button. Changes the action to Get.
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Mark selected files to put the local version If you are doing a two-way synchronize, you can choose whether to 
Put the file by clicking this button. Changes the action to Put.

Mark selected files for deletion If you want to delete any file in the list, you can choose to delete files by clicking 
the Delete button. Deletes the file from both the local and remote side, if necessary. Changes the action to Delete.

Ignore selected files during this synchronization Changes the action to Ignore and the status to "User is ignoring."

Mark selected files as already synchronized You can inform Dreamweaver that the selected files are already 
synchronized. Changes the action to Synchronized and status to "Files are synchronized." Creates entries for the 
selected files in the dwsync.xml files for those files upon you clicking OK. If you cancel, no changes are made to the xml 
file. Also note the current local and remote time stamps in the dwsync.xml file.

Compare the testing and local versions of the selected files One new option in Dreamweaver 8 is it allows you to 
compare the local and remote files. To do this, you select those files to compare and click Compare to launch the 
integrated file diff tool and passes in the selected files.

There is also a right-click context menu which has options to match the buttons mentioned above:

 If you select Synchronize and no synchronization is necessary, Dreamweaver puts up a message stating that. 
Dreamweaver 8 also allows you to click the Yes button and see the list of files anyway and override whether the 
synchronization happens: 

Maintain Synchronization Information site definition preference
Dreamweaver 8 has a new preference to determine if Dreamweaver should track file time stamps in the dwsync.xml 
files mentioned above. This preference is enabled by default. But, if you are not interested in using the synchronize 
feature, consider turning it off to speed up performance. Also turn it off if you don't want to be warned about potentially 
overwriting changes on the server. If you are experiencing problems with the synchronize feature, temporarily disabling 
and reenabling this preference clears out Dreamweaver's synchronize information. For more information, see 
"Troubleshooting synchronization problems in Dreamweaver" (TechNote kb400975 ). The preference is a site-specific 
preference and is located in the Remote Info category of the site definition dialog box.

A warning appears if you deselect the preference indicating that synchronization is disabled for that site. You aren't 
warned of potentially overwriting changes on the server.

If the preference is on, Dreamweaver gets the remote file's current time stamp and compare it to the one in the 
dwsync.xml file. If no dwsync.xml file exists or the remote time stamp isn't in the dwsync.xml file, Dreamweaver 
doesn't warn you. Dreamweaver only warns if it knows with certainty the remote file has changed since the last 
synchronization. You are presented with the following dialog and given the choice of comparing the remote file to the 
local file, putting the local file, or canceling the put operation. Clicking "Compare" downloads the remote file to a 
temporary file and launches the file diff tool comparing the downloaded temp file to the local file.

Additional information
For more information on Dreamweaver's synchronize feature, see the following section of the Dreamweaver 
documentation: Synchronizing the files on your local and remote sites.

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb400975
http://livedocs.macromedia.com/dreamweaver/8/using/05_sit45.htm
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Synchronize and Select Newer options are not working 
correctly

Issue
 Dreamweaver takes a long time to connect and/or timestamp related functions do not work correctly. When you check 
the site FTP log, you can see that Dreamweaver is failing to create and remove the temporary XYIZNWSK folder (MKD 
XYIZNWSK and RMD XYIZNWSK). The functions you may be seeing problems with include Select Newer, 
Synchronize, and the warning when Getting and Putting older versions of files. 

Note: This TechNote applies to Dreamweaver MX 2004 and earlier. The Synchronize and Select Newer features were 
redesigned in Dreamweaver 8 and the XYIZNWSK folder is no longer created by Dreamweaver. For more information, 
see "How synchronization works in Dreamweaver 8" (TechNote kb400972 ). 

Reason
 You don't have permission to create a directory in the default login directory of the remote server. Dreamweaver MX 
2004 and earlier create a temporary directory (XYIZNWSK) and read the server's timestamp to establish the time 
difference. This allows Dreamweaver to complete functions that involve comparing files' timestamps. 

Solution
 In order for the timestamp-related functions to work correctly in Dreamweaver MX 2004 and earlier, users must have 
permission (set by the server administrator) to create directories in the default login directory. 

Slow system performance using Dreamweaver

Issue
 Dreamweaver is running slowly even though your computer meets Dreamweaver system requirements. 

Reason
 Dreamweaver may be running slowly due to on-access virus scanning. Dreamweaver consists of many internal 
JavaScript files (.js files), and real-time virus scanners sometimes scan the JavaScript files that Dreamweaver is 
accessing. On-access scanning of these JavaScript files can slow down Dreamweaver. 

Solution
 Modify the preferences for your virus protection software so that the JavaScript files in the Dreamweaver main 
program folder and Dreamweaver user configuration folder are not scanned when opened. The location of these folders 
depends on which operating system and which version of Dreamweaver you are using: 

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb400972
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Windows

• Dreamweaver CS3 on Windows Vista: C:\Program Files\Adobe\Adobe Dreamweaver CS3\ 
C:\Users\[user]\AppData\Roaming\Adobe\Dreamweaver 9\

• Dreamweaver CS3 on Windows XP: C:\Program Files\Adobe\Adobe Dreamweaver CS3\ C:\Documents and 
Settings\[user]\Application Data\Adobe\Dreamweaver 9\ 

• Dreamweaver 8 on Windows Vista: C:\Program Files\Macromedia\Dreamweaver 8\ 
C:\Users\[user]\AppData\Roaming\Macromedia\Dreamweaver 8\

• Dreamweaver 8 and MX 2004 on Windows XP & Windows 2000: C:\Program Files\Macromedia\Dreamweaver 
[version]\ C:\Documents and Settings\[user]\Application Data\Macromedia\Dreamweaver [version]\ 

Macintosh

• Dreamweaver CS3 Mac HD/Applications/Adobe Dreamweaver CS3/ Mac 
HD/Users/[username]/Library/Application Support/Adobe/Dreamweaver 9/ 

• Dreamweaver 8 and earlier Mac HD/Applications/Macromedia Dreamweaver [version]/ Mac 
HD/Users/[username]/Library/Application Support/Macromedia/Dreamweaver [version]/

A script in file EditingUtils.js has been running for a long 
time

Issue
 Adobe Dreamweaver CS3 freezes when opening specific files that contain a Spry TabbedPanels or CollapsiblePanel 
widget. Eventually, you see the following message: 

"A script in file C:\Program Files\Adobe\Adobe Dreamweaver 
CS3\configuration\shared\spry\designTime\EditingUtils.js has been running for a long time. Do you want to 
continue?" 

(Ref. 227251) 

Reason
 This problem happens if you manually modify the widget constructor's options so that they make use of non-constant 
parameters. 

Here is an example of a widget constructor that works as expected: 

<script type="text/javascript"> 
 

   <!-- var TabbedPanels1 = new Spry.Widget.TabbedPanels("TabbedPanels1", {defaultTab: 0}); --> 
 

   </script> 

Here is an example of a widget constructor that was manually modified to make use of a JavaScript variable and will 
cause the problem described in the Issue section: 
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<script type="text/javascript"> 
 

    <!-- var TabbedPanels1 = new Spry.Widget.TabbedPanels("TabbedPanels1", {defaultTab: 
(params.panel ? params.panel : 0)}); --> 

 
    </script> 

Modifying the widget constructor's options to use server-side markup will also cause the problem described in the Issue 
section: 

<script type="text/javascript"> 
 

    <!-- var TabbedPanels1 = new Spry.Widget.TabbedPanels("TabbedPanels1", {defaultTab: 
<%=foo%>}); --> 

 
    </script> 

Solution
 Below are the instructions for manually applying two single-line fixes necessary to solve the problem. Please note that 
before making these fixes, you should back up the files so you can restore them if necessary. 

1 Exit from Dreamweaver.

2 Make a backup of the following files which you will be editing. This TechNote assumes Dreamweaver is installed in 
the default location.

• Windows

• C:\Program Files\Adobe\Adobe Dreamweaver CS3\Configuration\Shared\Spry\Widgets\TabbedPanels\ 
DesignTime\SpryTabbedPanelsDesignTime.js 

• C:\Program Files\Adobe\Adobe Dreamweaver CS3\Configuration\Shared\Spry\Widgets\CollapsiblePanel\ 
DesignTime\SpryCollapsiblePanelDesignTime.js 

• Macintosh

• Mac HD/Applications/Adobe Dreamweaver 
CS3/Configuration/Shared/Spry/Widgets/TabbedPanels/DesignTime/ SpryTabbedPanelsDesignTime.js 

• Mac HD/Applications/Adobe Dreamweaver CS3/Configuration/Shared/Spry/Widgets/CollapsiblePanel/ 
DesignTime/SpryCollapsiblePanelDesignTime.js

•  Give the backup copies different names, like SpryTabbedPanelsDesignTime.js.BACKUP and 
SpryCollapsiblePanelDesignTime.js.BACKUP.

3 Edit SpryTabbedPanelsDesignTime.js and make the following changes:

a Go to line 188. Change:eval("opts = " + args[ 1 ]); to:try { eval("opts = " + args[ 1 ]); } catch(e) { opts = null; }

b Save the file.

4 Edit SpryCollapsiblePanelDesignTime.js and make the following changes:

a Go to line 188. Change:eval("opts = " + args[ 1 ]); to:try { eval("opts = " + args[ 1 ]); } catch(e) { opts = null; }

b Save the file.

5 Launch Dreamweaver and verify that you can now load your file.
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The registration message box continues to appear on 
launch after registration
IssueIn Dreamweaver 3 on Windows 2000 or Windows NT, a message box appears on every launch prompting the user 
to register. This prompt repeatedly appears on launch although Dreamweaver 3 has been registered or the user has 
clicked "Don't Remind Me." 

Note:This situation does not occur in Dreamweaver 4. 

ReasonOn Windows 2000 and Windows NT, only the Administrator or users with certain permissions can install 
applications. If an administrator installs the application and then another non-administrative user launches the 
application, the prompt to register can appear on every launch. 

Solutions One of the following two solutions may solve the problem: 

Installer disables the registration message box Whoever installed 
the application must log in, launch Dreamweaver and click "Don't 
Remind Me" on the registration message box. The user may then be 
able to log in and run the application without the appearance of the 
prompt. 

User reinstalls Dreamweaver3

1

 Uninstall Dreamweaver 3 using Add/Remove programs. 
(Start this process by choosing Start > Settings > Control 
Panel> Add/Remove programs. Select Dreamweaver 3 
and then click Change/Remove.) 

Note: Uninstalling Dreamweaver 3 will clear all your Site 
Definition information. After reinstalling the program, 
you will have to reenter the Site Definition information to 
redefine all your sites. Write down all Site Definition 
information;including all FTP information for each 
site;before uninstalling Dreamweaver 3. 

2

 Reinstall Dreamweaver 3 under an Administrative login 
or as a user with permissions. The login must be the same 
login that will be used to run the application after 
installation. 

3

 Launch Dreamweaver 3 (using the same login that was 
used to reinstall the application). 

4

 Click an option on the registration message box. Clicking 
"Don't Remind Me" will prevent the appearance of the 
registration message box the next time that Dreamweaver 
launches. 
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Re-creating the Dreamweaver user configuration folder 
on Windows
 If Dreamweaver starts behaving unpredictably, this can be an indication that the Dreamweaver user configuration 
folder has become corrupt. Dreamweaver (version MX and later) allows multiple users to log in to a machine and 
customize Dreamweaver to their liking. For example, each user can have different snippets, menu options, extensions, 
spelling dictionaries, etc. These customizations are saved in each user's configuration folder in Windows. To test for a 
corrupt user configuration folder, try the following: 

1 Exit from Dreamweaver if necessary.

2 Open Windows Explorer by right-clicking the main Start button and selecting Explore.

3 In Windows Explorer, browse to the following folder (this example assumes Dreamweaver 8): C:\Documents and 
Settings\[username]\Application Data\Macromedia\Dreamweaver 8Note: To see this folder, you may need to make 
the following change in Windows Explorer: Tools > Folder Options > View > Advanced Settings section> Files and 
Folders section > Hidden Files and Folders > turn on "Show hidden files and folders".

4 Re-name this folder to an arbitrary name, such as "OLD Dreamweaver 8." Once the user configuration folder has 
been renamed, Dreamweaver will no longer be able to find it and Dreamweaver will automatically create a new user 
configuration folder with the default settings.

5 Launch Dreamweaver and see if the problem still occurs.

6 If the problem is resolved after re-creating the user configuration folder, you can delete your old user configuration 
folder, but save any files you may have customized and try to transfer them over to the newly created user 
configuration folder. See Backing up and restoring Dreamweaver settings (TechNote 18736). Note that these 
customized files may be the source of the problem. If the problem is reintroduced after copying old files back in, go 
through steps 1-5 again to get a clean user configuration folder, then transfer customized files one at a time, testing 
for the problem after each file is transferred, to identify the problem file.Note: If you have Dreamweaver extensions 
installed, it is not recommended to move existing user configuration subfolders back into the new user 
configuration folder since extensions can write files to various subfolders in the Dreamweaver user configuration 
folder. Instead, extension users should start from the new user configuration folder and reinstall extensions using 
the Extension Manager installer one at a time. Test each extension individually after installing it, so that you can 
identify any problematic extensions.

Optional step

 If the steps above don't solve the problem, then go back through the steps above again, but insert the following step 
after step4: 

WARNING: If you edit the Windows Registry incorrectly, you can cause serious problems that may require you to 
reinstall your operating system. Adobe does not guarantee that problems that you cause by editing the registry 
incorrectly can be resolved. Edit the registry at your own risk. 

? Backup the Dreamweaver user configuration registry key, delete it, and then restart Dreamweaver to see if it fixes 
the problem. To do this choose Start button > Run > type in "regedit". In the Registry Editor, find the following key 
(this example uses Dreamweaver 8):HKEY_CURRENT_USER\Software\Macromedia\Dreamweaver 8 Select the 
Dreamweaver 8 folder and choose File > Export (so that it is backed up), and then delete it (Edit > Delete).

Additional Information
 If this TechNote doesn't resolve the problem, then here are some additional TechNotes that may help: 

• Troubleshooting Dreamweaver for Windows (TechNote 15481) 

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_18736
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15481
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• Troubleshooting JavaScript errors in Dreamweaver (TechNote 19105) 

• Uninstalling Studio 8 applications on Windows (TechNote 4e7826b7) 

• Uninstalling Dreamweaver MX & MX 2004 on Windows (TechNote 362d7b81) 

• Installing Studio 8 products in Selective Startup mode on Windows XP (TechNote d2b5934d) 

• Installing Dreamweaver MX & MX 2004 in Safe Mode on Windows (TechNote 362eefb2) 

• Dreamweaver crashes when performing a task related to site definitions (TechNote 5989f7f4) 

How to re-create the Dreamweaver user configuration 
folder (CS3 on Windows XP, Vista)
 If Adobe Dreamweaver CS3 starts displaying errors, crashing, or behaving unpredictably, it is possible that the 
Dreamweaver user configuration folder is corrupted. The configuration folder stores individual user's customizations, 
such as snippets, menu options, extensions, spelling dictionaries, etc. To test for a corrupt user configuration folder, try 
the following: 

Note: This procedure requires you to locate hidden files, hidden folders and extensions for known file types. By default, 
Windows Explorer doesn't show hidden files, hidden folders, and file name extensions that it recognizes. 

To show hidden files, hidden folders, and extensions for known file types:

1 In Windows Explorer, do one of the following: 

• In Windows XP, choose Tools > Folder Options. 

• In Windows Vista, choose Organize > Folder and Search Options. 

2 Click the View tab in the Folder Options dialog box.

3 In Advanced Settings, select Show Hidden Files And Folders.

4 Deselect Hide Extensions For Known File Types.

5 Click OK.

Note: Re-creating the Dreamweaver Configuration folder restores Dreamweaver settings to their defaults. 

To re-create the Dreamweaver user's Configuration folder on Windows XP:

1 Quit Dreamweaver.

2 Go to Start > My Computer.

3 Rename Documents and Settings\[username]\Application Data\Adobe\Dreamweaver 9\Configuration to 
Configuration Old.

4 Start Dreamweaver. Dreamweaver creates a new Configuration folder.

To re-create the Dreamweaver user's Configuration folder on Windows Vista:

1 Quit Dreamweaver.

2 Go to Start > Computer.

3 Rename Users\[username]\AppData\Roaming\Adobe\Dreamweaver 9\Configuration to Configuration Old.

4 Start Dreamweaver. Dreamweaver creates a new Configuration folder.

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_19105
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=4e7826b7
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=362d7b81
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=d2b5934d
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=362eefb2
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=5989f7f4
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 If the problem continues, then the Dreamweaver configuration files aren't the cause. To restore custom settings, quit 
Dreamweaver, then delete the new configuration folder and restore the original name of the previous configuration 
folder. 

If the problem is resolved after re-creating the user configuration folder, transfer any configuration files you may have 
customized to the newly created user configuration folder, then delete the old configuration folder. Refer to "Backing 
up and restoring Dreamweaver settings" (TechNote 18736 ) for instructions. If the problem is reintroduced after 
transferring old files to the new folder, follow the steps above to recreate the user configuration folder, then transfer 
customized files one at a time. Test for the problem after each file is transferred to isolate the damaged file(s).Note: 
Dreamweaver extensions may write files to subfolders in the Dreamweaver user configuration folder. If you have 
Dreamweaver extensions installed, we do not recommend transferring existing user configuration subfolders back into 
the new user configuration folder. Instead, extension users should start from the new user configuration folder and 
reinstall extensions using the Extension Manager installer one at a time. Test each extension individually after installing 
it to isolate any problematic extensions. 

Optional step

 If the steps above don't resolve the problem, follow the steps above again, but insert the following step after step 3: 

Disclaimer: This procedure involves editing the Windows registry. Adobe doesn't provide support for editing the 
registry, which contains critical system and application information. Make sure to back up the registry before editing 
it. For more information about the registry, see the Windows documentation or contact Microsoft. 

In Windows XP:

? Go to Start > Run > type in "regedit" and press enter. In the Registry Editor, delete the following 
key:HKEY_CURRENT_USER\Software\Adobe\Dreamweaver 9

In Windows Vista:

? Go to Start, type "regedit" in the search field and press enter. In the Registry Editor, delete the following 
key:HKEY_CURRENT_USER\Software\Adobe\Dreamweaver 9

Additional Information
 If this TechNote doesn't resolve the problem, refer to the following TechNotes for additional troubleshooting: 

• Troubleshooting Dreamweaver for Windows (TechNote 15481 ) 

• Troubleshooting JavaScript errors in Dreamweaver (TechNote 19105 ) 

• Dreamweaver crashes when performing a task related to site definitions (TechNote 5989f7f4 ) 

Protecting PHP server behaviors from SQL injection 
vulnerability

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_18736
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15481
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_19105
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=5989f7f4
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Issue
Some databases let you send multiple SQL statements in a single query. Therefore, there are potential security risks 
when you pass parameters in a query string to a dynamically generated database query. Hackers could try to modify 
URL or form variables in a dynamic query by appending malicious SQL statements to existing parameters. This is often 
referred to as a SQL injection attack. Some of the server behavior code created by Dreamweaver should be modified to 
reduce the risk of SQL injection attacks. For more background information on SQL injection, see this Wikipedia article. 
(Ref. 201713)

Note: The issue described in this TechNote has been fixed in the Dreamweaver 8.0.2 Updater.

This TechNote covers Dreamweaver's PHP server behaviors. There are separate TechNotes for the ColdFusion , ASP 
VBScript , ASP JavaScript , and JSP server behaviors. The ASP.NET server behaviors are not affected.

Solution
When you let a query string pass a parameter, ensure that only the expected information is passed. Adobe has created 
a Dreamweaver 8.0.2 Updater that reduces the risk of SQL injection attacks. These fixes will be incorporated into all 
future releases of Dreamweaver. After updating Dreamweaver 8, you will need to reapply the server behaviors to the 
pages that use them, and redeploy those pages to your server.

The remainder of this TechNote documents how to manually edit Dreamweaver MX 2004 code to prevent SQL 
injection attacks with the PHP server model. Server behaviors that are vulnerable to these attacks are listed below, along 
with fixes:

• Recordset with a filter 

• Insert, Update, and Delete Record server behaviors and Record Insertion Form wizard 

• Log In User 

• Check New User 

• Master Detail Page Set 

• Record Update Form wizard 

Recordset with a filter
 Unfiltered recordsets do not need to be modified, but filtered recordsets do. In the example below, a Dreamweaver MX 
2004 recordset named "rs_byDate" is filtered by a date value passed in from a URL parameter. The highlighted code 
below is what needs to be changed: 

<?php $colname_rs_byDate = "1"; if (isset($_GET['relDate'])) {   $colname_rs_byDate = 
(get_magic_quotes_gpc()) ? $_GET['relDate'] : addslashes($_GET['relDate']); } 
mysql_select_db($database_dreamqa2, $dreamqa2); $query_rs_byDate = sprintf("SELECT * FROM 
albums WHERE relDate = '%s'", $colname_rs_byDate); $rs_byDate = mysql_query($query_rs_byDate, 
$dreamqa2) or die(mysql_error()); $row_rs_byDate = mysql_fetch_assoc($rs_byDate); 
$totalRows_rs_byDate = mysql_num_rows($rs_byDate); ?>

 To protect the recordset from SQL injection attacks, a custom GetSQLValueString() function should be created near 
the top of the page. This function verifies the data type of the query parameter. Once the function has been created, 
then update the recordset code to use the GetSQLValueString() function. 

1 Go to the second line in code view, right after the include file for the connection, and add the GetSQLValueString() 
function to the beginning of the code as follows:

http://en.wikipedia.org/wiki/Sql_injection
https://www.adobe.com/support/dreamweaver/downloads_updaters.html
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=300b670e
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=57ae79b2
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=57ae79b2
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=581a553c
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=585ac720
https://www.adobe.com/support/dreamweaver/downloads_updaters.html
http://helpx.adobe.com/dreamweaver/kb/#main_recordset
http://helpx.adobe.com/dreamweaver/kb/#main_insert
http://helpx.adobe.com/dreamweaver/kb/#main_login
http://helpx.adobe.com/dreamweaver/kb/#main_new_user
http://helpx.adobe.com/dreamweaver/kb/#main_master
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<?php if (!function_exists("GetSQLValueString")) { function GetSQLValueString($theValue, 
$theType, $theDefinedValue = "", $theNotDefinedValue = "")  {   $theValue = 
get_magic_quotes_gpc() ? stripslashes($theValue) : $theValue;   $theValue = 
function_exists("mysql_real_escape_string") ? mysql_real_escape_string($theValue) : 
mysql_escape_string($theValue);   switch ($theType) {     case "text":       $theValue = 
($theValue != "") ? "'" . $theValue . "'" : "NULL";       break;      case "long":     case 
"int":       $theValue = ($theValue != "") ? intval($theValue) : "NULL";       break;     case 
"double":       $theValue = ($theValue != "") ? "'" . doubleval($theValue) . "'" : "NULL";       
break;     case "date":        $theValue = ($theValue != "") ? "'" . $theValue . "'" : "NULL";        
break;     case "defined":       $theValue = ($theValue != "") ? $theDefinedValue : 
$theNotDefinedValue;       break;   }   return $theValue; } } ?>

2  Remove the magic quotes code so that backslashes are not incorrectly added to GET and POST data when magic 
quotes are turned off on the PHP server. Original code:

$colname_rs_byDate = (get_magic_quotes_gpc()) ? $_GET['relDate'] : 
addslashes($_GET['relDate']);

Modified code:

$colname_rs_byDate = $_GET['relDate'];

3 Update the recordset code to create a SQL string using the GetSQLValueString() function created above. Update the 
value of the variable $query_rs_byDate: Original code:

$query_rs_byDate = sprintf("SELECT * FROM albums WHERE relDate = '%s'", $colname_rs_byDate);

 Modified secured code:

$query_rs_byDate = sprintf("SELECT * FROM albums WHERE relDate = %s", 
GetSQLValueString($colname_rs_byDate, "date"));

Insert, Update, and Delete Record server behaviors and Record Insertion Form wizard
 The Insert, Update, and Delete Record server behaviors and Record Insertion Form wizard already use the 
GetSQLValueString() function, so they need to be refined to prevent SQL injections. The only changes needed are in 
the GetSQLValueString() function. 

Here is the original code. The line to change is highlighted in yellow: 

if (!function_exists("GetSQLValueString")) { function GetSQLValueString($theValue, $theType, 
$theDefinedValue = "", $theNotDefinedValue = "")    {$theValue = (!get_magic_quotes_gpc()) ? 
addslashes($theValue) : $theValue;   switch ($theType) {     case "text":       $theValue = 
($theValue != "") ? "'" . $theValue . "'" : "NULL";       break;      case "long":     case 
"int":       $theValue = ($theValue != "") ? intval($theValue) : "NULL";       break;     case 
"double":       $theValue = ($theValue != "") ? "'" . doubleval($theValue) . "'" : "NULL";       
break;     case "date":       $theValue = ($theValue != "") ? "'" . $theValue . "'" : "NULL";       
break;     case "defined":       $theValue = ($theValue != "") ? $theDefinedValue : 
$theNotDefinedValue;       break;   }   return $theValue; } }

Update the definition of the variable $theValue:
 Original code: 

$theValue = (!get_magic_quotes_gpc()) ? addslashes($theValue) : $theValue;

 Modified secured code: 

$theValue = get_magic_quotes_gpc() ? stripslashes($theValue) : $theValue; $theValue = 
function_exists("mysql_real_escape_string") ? mysql_real_escape_string($theValue) : 
mysql_escape_string($theValue);

http://helpx.adobe.com/dreamweaver/kb/
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Log In User server behavior
 Here are the steps to fix the Log In User server behavior: 

1 Create a GetSQLValueString() function as described in Recordset with a filter above.

2 Modify the code that constructs the login SQL query. Original code:

$LoginRS__query=sprintf("SELECT username, password FROM login WHERE username='%s' AND 
password='%s'",    get_magic_quotes_gpc() ? $loginUsername : addslashes($loginUsername), 
get_magic_quotes_gpc() ? $password : addslashes($password));

 Modified secured code:

$LoginRS__query=sprintf("SELECT username, password FROM login WHERE username=%s AND 
password=%s",    GetSQLValueString($loginUsername, "text"), GetSQLValueString($password, 
"text"));

Check New User server behavior
 The Check New User server behavior requires that an Insert Record server behavior be added to the page first. The 
GetSQLValuesString() function is included with the Insert Record server behavior. All that needs to be done is to 
update the GetSQLValuesString() to better handle SQL Injection and update the Check New User server behavior to 
use this function when a parameter is passed in.

1 Change the first line in the function to update the GetSQLValuesString() function as described in Update the 
definition of the variable $theValue .

2 Modify the code to construct the login SQL query to use the GetSQLValuesString() to pass in parameters. Toward 
the top of the page, locate the code in the section starting with // *** Redirect if username exists. Original code:

$LoginRS__query = "SELECT username FROM login WHERE username='" . $loginUsername . "'"

 Modified secured code:

$LoginRS__query = sprintf("SELECT username FROM login WHERE username=%s", 
GetSQLValueString($loginUsername, "text"));

Master Detail Page Set
For the Master Detail Page Set application object, the changes are mainly in the recordset that Dreamweaver creates for 
the Detail Page. If you don't have a filtered recordset in the Master Page, then no changes need to be made to the Master 
Page. If you have a filtered recordset, then see recordset with a filter to update the recordset code.

Dreamweaver creates a filtered recordset in the Detail Page, so that recordset code needs to be updated to use a 
GetSQLValueString() function to pass in parameters and sprintf() to construct the SQL string.

1 Create the GetSQLValueString() function as described in Recordset with a filter above.

2 Update the variable declaration code and construct the SQL query using the GetSQLValuesString() function. 
Original code:

$recordID = $_GET['recordID']; $query_DetailRS1 = "SELECT * FROM albums WHERE ID = 
$recordID";

 Modified secured code:

$colname_DetailRS1 = "-1"; if (isset($_GET['recordID'])) { $colname_DetailRS1 = 
(get_magic_quotes_gpc()) ? $_GET['recordID'] : addslashes($_GET['recordID']); } 
$query_DetailRS1 = sprintf("SELECT * FROM albums WHERE ID = %s", 
GetSQLValueString($colname_DetailRS1, "int"));

http://helpx.adobe.com/dreamweaver/kb/#main_recordset
http://helpx.adobe.com/dreamweaver/kb/#main_theValue
http://helpx.adobe.com/dreamweaver/kb/#main_theValue
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http://helpx.adobe.com/dreamweaver/kb/#main_recordset
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Record Update Form wizard
1 Update the definition of the variable $theValue as described in Insert, Update, and Delete Record server behaviors 

and Record Insertion Form wizard .

2 Update the code for the Recordset which is required for the Record Update Form as described in step 2 of Recordset 
with a filter .

Additional Information
Please refer to the following article for more information about SQL injection: Wikipedia article on SQL injection.

Adobe Security Bulletin: APSB 06-07 Dreamweaver Server Behavior SQL Injection vulnerability.

Protecting ColdFusion server behaviors from SQL 
injection vulnerability

Issue
Some databases let you send multiple SQL statements in a single query. Because of this, there are potential security risks 
when you pass parameters in a query string to a dynamically generated database query. Hackers might try to modify 
URL or form variables in a dynamic query by appending malicious SQL statements to existing parameters. This is often 
referred to as a SQL injection attack. Some of the server behavior code created by Dreamweaver should be modified to 
reduce the risk of SQL injection attacks. For more background information on SQL injection, see this Wikipedia article. 
(Ref. 201713)

Note: The issue described in this TechNote has been fixed in the Dreamweaver 8.0.2 Updater.

This TechNote covers Dreamweaver's ColdFusion server behaviors. There are separate TechNotes for the PHP , ASP 
VBScript , ASP JavaScript , and JSP server behaviors. The ASP.NET server behaviors are not affected.

Solution
When you let a query string pass a parameter, ensure that only the expected information is passed. Adobe has created 
a Dreamweaver 8.0.2 Updater that reduces the risk of SQL injection attacks. These fixes will be incorporated into all 
future releases of Dreamweaver. After updating Dreamweaver 8, you will need to reapply the server behaviors to the 
pages that use them, and redeploy those pages to your server.

The remainder of this TechNote documents how to manually editDreamweaver MX 2004 code to prevent SQL injection 
attacks with the ColdFusion server model. Server behaviors that are vulnerable to these attacks are listed below, along 
with the fixes:

• Recordset with a filter 

• Insert Record server behavior and Record Insertion Form Wizard 

• Update Record and Record Update Form Wizard 

• Delete Record server behavior 

• Log In User server behavior 

• Check New User server behavior 

http://helpx.adobe.com/dreamweaver/kb/#main_insert
http://helpx.adobe.com/dreamweaver/kb/#main_insert
http://helpx.adobe.com/dreamweaver/kb/#main_recordset_step2
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• Master Detail Page Set 

Recordset with a filter
 Unfiltered recordsets do not need to be modified, but filtered recordsets do. In the example below, a Dreamweaver MX 
2004 recordset named "Recordset1" is filtered by an ID value passed in from a URL parameter. The highlighted code 
below is what will need to be changed: 

<cfquery name="Recordset1" datasource="cafetownsend"> SELECT * FROM COMMENTS WHERE COMMENT_ID 
=#URL.COMMENT_ID#</cfquery>

 To protect the recordset from SQL injection attacks, use thecfqueryparam tag within the cfquery tag that contains the 
SQL SELECT statement. Thecfqueryparam tag will verify the data type of the query parameter and help secure your 
databases from unauthorized users. The line in yellow is the modified secure code: 

<cfquery name="Recordset1" datasource="cafetownsend"> SELECT * FROM COMMENTS WHERE COMMENT_ID 
=<cfqueryparam value="#URL.COMMENT_ID#" cfsqltype="cf_sql_numeric"></cfquery>

Insert Record server behaviors and Record Insertion Form Wizard
 To protect the recordset from SQL injection attacks, use thecfqueryparam tag within the cfquery tag that contains the 
SQL INSERT statement. Thecfqueryparam tag will verify the data type of the query parameter and help secure your 
databases from unauthorized users. 

Original code. The highlighted code below is what will need to be changed: 

<cfquery datasource="cafetownsend">   INSERT INTO COMMENTS (FIRST_NAME, LAST_NAME, TELEPHONE)   
VALUES (<cfif IsDefined("FORM.textfield1") AND #FORM.textfield1# NEQ 
"">'#FORM.textfield1#'<cfelse>NULL</cfif>   ,<cfif IsDefined("FORM.textfield2") AND 
#FORM.textfield2# NEQ "">'#FORM.textfield2#'<cfelse>NULL</cfif>   ,<cfif 
IsDefined("FORM.textfield3") AND #FORM.textfield3# NEQ 
"">'#FORM.textfield3#'<cfelse>NULL</cfif>   )</cfquery>

 Modified secured code: 

<cfquery datasource="cafetownsend">   INSERT INTO COMMENTS (FIRST_NAME, LAST_NAME, TELEPHONE)   
VALUES<cfif IsDefined("FORM.textfield1") AND #FORM.textfield1# NEQ ""><cfqueryparam 
value="#FORM.textfield1#" cfsqltype="cf_sql_clob" maxlength="50"><cfelse>''</cfif>   ,<cfif 
IsDefined("FORM.textfield2") AND #FORM.textfield2# NEQ ""><cfqueryparam 
value="#FORM.textfield2#" cfsqltype="cf_sql_clob" maxlength="50"><cfelse>''</cfif>   ,<cfif 
IsDefined("FORM.textfield3") AND #FORM.textfield3# NEQ ""><cfqueryparam 
value="#FORM.textfield3#" cfsqltype="cf_sql_clob" maxlength="20"><cfelse>''</cfif>   
)</cfquery>

Note: Choose the appropriatecfslqtype and maxlength values for your data. 

Update Record and Record Update Form Wizard
 The Update Record server behavior and Record Update Form Wizard require a combination of the fixes above. First, 
look for thecfquery that contains the SQL SELECT statement and modify it as described in Recordset with a filter . 
Then, look for the cfquery that contains the SQL UPDATE statement and modify it as described in Insert Record server 
behaviors and Record Insertion Form Wizard . 

Delete Record server behavior
 The Delete Record server behavior modification is similar to the one for Recordset with a filter . 

Original code: 

http://helpx.adobe.com/dreamweaver/kb/#main_master
http://helpx.adobe.com/dreamweaver/kb/#main_recordset
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<cfquery datasource="cafetownsend">    DELETE FROM COMMENTS    WHERE 
COMMENT_ID=#URL.COMMENT_ID#</cfquery>

 Modified secure code: 

<cfquery datasource="cafetownsend">   DELETE FROM COMMENTS   WHERE COMMENT_ID=<cfqueryparam 
value="#URL.COMMENT_ID#" cfsqltype="cf_sql_numeric"></cfquery>

Note: Choose the appropriatecfslqtype and maxlength values for your data. 

Log In User server behavior
 To fix the Log In User server behavior code, look for thecfquery tags and add cfqueryparam tags. 

Original code: 

<cfquery name="MM_rsUser" datasource="cafetownsend">   SELECT FIRST_NAME,LAST_NAME FROM 
COMMENTS WHERE FIRST_NAME='#FORM.textfield1#'   AND LAST_NAME='#FORM.textfield2#'</cfquery>

 Modified secured code: 

<cfquery name="MM_rsUser" datasource="cafetownsend">   SELECT FIRST_NAME,LAST_NAME FROM 
COMMENTS WHERE FIRST_NAME=<cfqueryparam value="#FORM.textfield1#" cfsqltype="cf_sql_clob" 
maxlength="50">   AND LAST_NAME=<cfqueryparam value="#FORM.textfield2#" 
cfsqltype="cf_sql_clob" maxlength="50"></cfquery>

Note: Choose the appropriatecfslqtype and maxlength values for your data. 

Check New User server behavior
 The Check New User server behavior requires that an Insert Record server behavior be added to the page first. First, 
look for the cfquery that contains the SQL SELECT statement and modify it as described in Recordset with a filter . 
Then, look for the cfquery that contains the SQL INSERT statement and modify it as described in Insert Record server 
behaviors and Record Insertion Form Wizard . 

Master Detail Page Set
 For the Master Detail Page Set application object, the changes are mainly in the recordset that Dreamweaver creates 
for the Detail Page. If you don't have a filtered recordset in the Master Page, then no changes need to be made to the 
Master Page. If you do have a filtered recordset on the Master Page, then see Recordset with a filter to update the 
recordset code. 

For the Detail Page, look for the cfquery that contains the SQL SELECT statement and modify it as described in 
Recordset with a filter . 

Additional Information
Adobe recommends that you use the cfqueryparam tag within every cfquery tag, to help secure your databases from 
unauthorized users. For more information, see Security Bulletin ASB99-04, "Multiple SQL Statements in Dynamic 
Queries" and Accessing and Retrieving Data in ColdFusion MX Developers Guide.

• ColdFusion MX 7 LiveDocs: Enhancing security with cfqueryparam and cfqueryparam tag description.

• Securing Database Access Using the cfqueryparam Tag (ColdFusion Developer Center Article by Dave Watts)

• Adobe Security Bulletin: APSB 06-07 Dreamweaver Server Behavior SQL Injection vulnerability

http://helpx.adobe.com/dreamweaver/kb/#main_recordset
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What can prevent JavaScript control over audio?
SummaryNot all browsers will let JavaScript control audio. You might consider interactive audio to be a nice addition 
for those visitors whose browsers support it, but be sure to provide visual feedback too. If you need interactive audio 
across a range of browsers, then putting the interactivity and audio in Flash or Shockwave is the standard solution. 

(This TechNote adds to previous interactive audio information in documents such as Dreamweaver 2.0's 
Troubleshooting the Control Sound Behavior Functionality . It includes information on the differences in default audio 
behaviors introduced in Dreamweaver 3.0) How do various browsers trigger audio files? The simplest method is to 
just EMBED an audio file. It will start when the page loads, and will use whatever audio player the browser prefers. You 
won't be able to trigger the audio by a mouseover or other JavaScript event, and will need to use an audio format which 
most browsers support, but a simple EMBED is the standard method of including audio when the page loads. 

Some browsers let JavaScript trigger audio, while others do not: 

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_14049
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How do Dreamweaver's various sound behaviors work? The Control Sound Behavior in Dreamweaver 1 and 2 
attempted to play audio in browsers which supported it. If a browser did not support script control over audio, then no 
sound would be heard. 

The Play Sound Behavior in Dreamweaver 3.0 takes a different tack. If the script cannot determine that the browser has 
a controllable audio player, it will open the sound as a new page in the window. This means that you will always get the 
sound, but may lose the content. 

(Note that this behavior was current in the default behavior set of Dreamweaver 3.0, at the time of this writing in 
February 2000. It's quite possible that a newer Play Sound Behavior may replace this original one. The upcoming 
Dreamweaver Behavior Exchange would be the place to find updated behaviors and other extensions for 
Dreamweaver.) 

Netscape browsers The Netscape 3.0 browsers on PowerMac and 
Windows 95 introduced LiveConnect, which uses Java to have 
JavaScript and Netscape Plugins talk together. Not all plugins are 
LiveConnect-aware. 

Netscape's default LiveAudio plugin can be controlled by JavaScript. 
Shockwave and Flash can be controlled by JavaScript. Beatnik and 
RealPlayer can be controlled by JavaScript. QuickTime 4.1 can be 
controlled by JavaScript, while earlier versions cannot. These various 
players may have slightly different JavaScript commands exposed. 

Because of the way EMBED tags work -- you specify the MIME type, and 
the browser chooses an appropriate player -- you cannot predict what 
type of player will render your audio file. This means that JavaScript 
may or may not be able to control an audio file in any particular 
Netscape browser. 

Generally, a stock Netscape 3+ browser on a Java-enabled PowerMac 
or Win32 will let JavaScript control audio through the default 
LiveAudio Player. If someone installed an older QuickTime plugin then 
they may not be able to hear audio under JavaScript control. With 
other customizations they may or may not be able to hear audio under 
JavaScript control. 

Microsoft browsers The Microsoft 3.0 browsers on Win95 introduced 
ActiveX Scripting, where JScript could address certain ActiveX 
Controls, and VBScript could catch events from ActiveX Controls. 

The OBJECT tag for ActiveX Controls lets you specify a particular media 
player. If you're just using an EMBED tag then this does not specify a 
particular media player. In the latter case, it's possible that a particular 
browser may be set up to use an unusual media player which does not 
have script control over audio. 

The Microsoft browsers for Macintosh do not offer any means for 
scripts and plugins to communicate. (At time of writing, February 
2000, IE5/Mac is in beta and does not seem to reverse this trend.) 

Generally, IE/Win32 browsers let JavaScript control audio. IE/Mac 
browsers do not let JavaScript control audio. 

Other browsers or platforms Other browsers (such as iCab or Opera) 
and other computer platforms (such as Windows 3.1), and other 
delivery devices (such as PDAs or web phones) tend not to support 
advanced abilities such as page scripts controlling media players. 

If you're designing for a particular device in the future you might wish 
to investigate its abilities, but generally JavaScript control over audio 
is available to Java-enabled Netscape 3+ browsers on PowerMac or 
Win32, and to ActiveX-enabled Microsoft 3+ browsers on Win95 or 
better. 
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If you'd like to have the DW3 Play Sound Behavior act more like the DW2 Control Sound Behavior, and to just fail 
silently on browsers without a controllable audio player, then you might consider removing the final line in that 
behavior: "else window.location=sndFile;". This is the line that triggers the redirect to a new window with just the 
sound. 

Another approach would be to rewrite the JavaScript to open a new window that plays the sound, rather than to play 
the sound in the current window. 

If making such manual edits to behaviors, then it is good to check that your edits are still there before delivering the 
files, because Dreamweaver can automatically fix damaged behaviors. Alternately, you could make the changes in the 
master "PlaySound.js" file itself in your Configuration / Behaviors / Actions folder. 

Summary The audio control behaviors changed between Dreamweaver 2 and 3, and may change after Dreamweaver 
3.0 as well. If you'd rather not have the page play an audio file full-screen, then a small edit to the behavior could attain 
the goal today, without needing to wait for a new behavior. 

Pop-up blocker conflicts (Dreamweaver Developer 
Toolbox)

Issue
 When trying to work with Query Builder, only a browser window opens with this message: "To help protect your 
security, Internet Explorer has restricted this file from showing active content that could access your computer. Click 
here for options ...", but none of the user interface is displayed.

Reason
 You have a pop-up blocker, either the browser default, or a third-party application (e.g. the Microsoft Internet Explorer 
Pop-up Blocker available in SP2, the Mozilla Firefox one or the pop-up blocker in the Google Toolbar). 

Solution
 Disable the pop-up blocker or simply configure it to allow pop-ups for the page containing Query Builder, on a 
temporary or permanent basis. 

To disable the Internet Explorer default pop-up blocker, simply open the Tools menu>Pop-up Blocker >Turn Off Pop-
up Blocker. 

How to pass a user name from a login page
 When using Dreamweaver's Log In User server behavior, you may want to use the user name on the very next page 
(the "redirect page") or on other pages in your web application. Some reasons you may want to pass the user name onto 
other pages include: 

• You want to greet the user after logging in. For example: "Hello John!" 

• You want to filter a recordset based on the user name in order to personalize the page. 
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• You want to insert the user name into a form field to be used for inserting, updating or deleting a record.

The Log In User server behavior automatically generates a session variable consisting of the user name for the user 
when they log in successfully. The session variable for the user name is labeled "MM_Username". 

Note: A second session variable is also automatically generated containing the user's authorization level, should you 
need to use this information on other pages. This session variable is named "MM_UserAuthorization". 

Defining the MM_Username session variable as a data source for your pages

 To utilize the MM_Username session variable on the pages in your site, open the login page in Dreamweaver. Open 
the Bindings panel. Click the plus (+) button and choose Session Variable from the pop-up menu. In the dialog box that 
pops up, enter "MM_Username" (without the quotes) in the name field. Click OK. Expand the Session icon that appears 
in the Bindings panel. The newly defined data source should appear, with a yellow lightning bolt icon next to it. 

Using the MM_Username session variable in your pages:

• Displaying the user name on successive pages: To display the user name on any of the successive pages, open the
page where you want to display the user name. Open the Bindings panel and drag the MM_Username session
variable on the page in Design view. This will cause the session variable contents to be written to this page.

• Filtering a recordset based on the user name: Open the page where you want to create the filtered recordset. To
filter a recordset based on the session variable, go into the simple view of the Recordset dialog box, and set the filter 
to:"[myUsernameField] = Session Variable MM_Username", where"[myUsernameField]" is the name of the
database field holding the user names. The advanced view of the Recordset dialog box should be used if you are
filtering on multiple variables or if you need to use a more complex SQL statement.

• Setting a form field's value equal to the user name: Open the page that contains the form. To set a form field's value 
equal to the session variable, select the text field form element on the page. Go to the Property inspector > click the
Attributes tab in the upper left corner > click the plus (+) button > choose "value" from the drop-down menu > click 
the yellow lightning bolt icon > choose the MM_Username session
variable.

Additional information

 If you would like to pass form data other than the user name from your login page, please refer to How do I create a 
session variable? (TechNote 14791) for detailed information on creating session variables. 

For an explanation of why session variables should be used to pass form data from a login page to successive pages, 
please refer to: How to pass form data from an insert, update or delete page (TechNote 15239). Though the TechNote 
discusses the insert, update and delete server behaviors, the mechanics are similar for the Log In User server behavior. 

New template features in Dreamweaver MX
 Macromedia Dreamweaver MX introduced many new features for templates. With these new features, you can create 
templates that allow a great deal of control over page editing. With the advent of optional regions, repeat regions and 
nested templates, you can create complex, almost dynamic pages. 

This TechNote will review the template features introduced in Dreamweaver MX. 

Nested Templates

 Nested templates are essentially templates within templates. This feature allows different levels of control on pages 
created from these templates. 

The benefits of nested templates

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_14791
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_14791
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15239
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 Nested templates can help developers in a number of ways, but the common thread among all uses is to provide two 
differing levels of control and editability. A common scenario in which nested templates is useful is for a website that 
has a single overall appearance (the company logo and contact information, for example). But the website also has 
sections that use a distinct appearance. For the separate sections of your web site, you can make nested templates that 
will have common elements and layout features for that section. 

This helps you as a developer because if you need to change your address or logo, you need to merely change it in the 
parent template file and it will automatically update all the pages. If your Products section develops a new look, 
however, you simply have to update the nested template (otherwise known as the child template), and those changes 
will only propagate through the Products pages. 

How to create nested templates

Note: This topic is described in greater detail in Creating a nested template in Dreamweaver MX (TechNote 16282). 
This section just provides an overview of the method used for creating nested templates. 

1 Create a normal template, the same as in previous versions of Dreamweaver. This template will act as the parent 
template. There must be at least one editable region in the template.

2 Make a page from this template. As usual, you will only be able to add new content to the editable area(s). The rest 
of the page will be locked. This template will now act as the nested;or child;template. Add content to the editable 
area(s). You can add images, text or any other web element.

3 In this second template, add a new editable area within the existing editable area. This will convert the page from an 
instance of a template into a nested template.

4 Save this file as a template.

 To see the differences between the two templates, make a page based on this nested template. As expected, you will 
only be able to edit the content defined as editable regions in the nested template. When you make a change to the 
nested template, only pages based on the nested template will update. When you make a change to the original template, 
any pages based on the parent template;including the nested template itself;will update. Since the nested template is 
updated by changes in the parent template, all pages based on the nested template will update, too. 

Note: An example of the template attributes discussed below can be found in the example code provided at the bottom 
of this page. All code examples in this TechNote are taken from this sample file. 

Repeat Regions

 The template repeat regions feature allows developers to create a template without knowing how many instances of a 
certain element will be needed. This allows developers to control the appearance of a specific element, yet the template 
users can freely repeat that specific element, changing the content in the element as appropriate. 

The benefits of repeat regions

 Developers are most likely to use repeating regions in conjunction with tables. If your template contains a table, you 
can set a row or group of rows to be a repeating region. You might then define an editable region within the repeating 
region (so in the example of a table, at least one table cell will contain an editable region). When a user makes a page 
based on that template, the user will be able to add a new row or group of rows, adding distinct content into the editable 
table cells. The template itself will have only one row (or group of rows), yet pages based on the template can have as 
many rows as is needed to display the information. The template user can add and subtract rows and move the rows up 
and down within the repeating rows. This is a good way to give developers flexibility for expanding pages as the site 
grows without disturbing the underlying templates. 

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_16282
http://helpx.adobe.com/dreamweaver/kb/#main_example
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This is such a popular way of using a repeat region that Dreamweaver has a template object called Repeating Table. 
This object allows you to set up the table and repeat region within the same dialog box. 

How to create repeating regions

Note: This topic is described in greater detail in the help documentation. This section just provides an overview of the 
method used for creating repeating regions. 

1 Open or create a new template.

2 Choose the content that you want to repeat. This can be a bunch of text, an image, etc.

3 Choose Insert > Template Objects > Repeating Region.

4 Name the repeat region with a name that does not include spaces or unusual characters, and click OK.

5 Optional: Select content within the newly defined repeat region and make it editable by choosing Insert > Template 
Objects > Editable Objects.

6 Save the template file.

7 Create a new file from this template, and note that the content is available. As shown in the image above, there will 
be a plus and minus icon to allow you to add and remove an instance of the repeat region, and the up and down 
arrow icons allow you to resort the regions.

 Remember that depending on how you define the repeating regions, you may not really need the repeating region. An 
example of a situation in which a repeating region is uniquely suited is if you insert an image, and make it a repeat 
region but not editable. In a document based on this template, the image object can be repeated as necessary simply 
with a click of the plus icon. 

How to create repeating tables

Note: This topic is described in greater detail in the help documentation. This section just provides an overview of the 
method used for creating repeating tables. It is also important to note that the repeating table is merely a specialized 
use of a repeating region. 

1 Open or create a new template.

2 Choose Insert > Template Objects > Repeating Table.

3 Within the Repeating Table dialog box, enter the settings you want for your table, then specify which row should be 
repeated. The Ending Row setting will help determine how many rows will be repeated, and must also be filled. If 
you want only the first row to be repeated, you would enter 1 in both the Starting and Ending Row text boxes.

4 Click OK. Each of the cells in the row will automatically be defined as editable, which means template users will be 
able to add content into each of those cells.

Optional Regions/Template Parameters

 Optional regions are just that: optional. Optional regions define content or editable regions that can be turned on or 
off (be visible or not). 

The benefits of optional regions

 The usage of optional regions can range from simple to complex, and more complex usages will require forethought 
and scripting capabilities. 
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A simple use of an optional region is to allow content to either be visible or not in a page based on the template. The 
content defined as an optional region is added in the template. A template user who makes a template with an optional 
region can then decide whether or not to retain the optional region. If the user turns the optional region off, the content 
defined as the optional region will no longer appear on the page. This may be useful in a situation where the template 
developer wants to control the placement and appearance of a bit of content, yet the developer also wants template users 
to choose whether or not to use that bit of content. 

More complex usages of optional regions allow parameters to determine whether or not the optional region will appear. 
So, instead of the template user choosing to toggle the optional region, the optional region will toggle on or off in 
reaction to a parameter. 

Creating alternate table row colors is an example of a more complex usage of optional regions. If you have a repeating 
table (such as the one discussed and displayed above), the developer is unable to change the appearance of the table 
rows since they are locked down by the template. Dreamweaver can keep track of the number of rows in a table, 
however. You can therefore set up an parameter within the template that tracks the number of rows. The optional region 
can be defined to toggle on or off in response to the row number. 

How to create and implement optional regions

Note: This topic is described in greater detail in the help documentation. This section just provides an overview of the 
method used for creating and implementing optional regions. This section will also give some general information 
about creating and using template parameters, but it is beyond the scope of this TechNote to give precise instructions 
for creating template parameters. 

Create the optional region in the template file: 

1 Open or create a new template file.

2 Add some content (text or a graphic, for example) to the template page and select it.

3 Choose Insert > Template Objects > Optional Region.Note: If you want the template users to be able to add or edit 
the content contained within the optional region, choose Editable Optional Region. Doing so will add a region next 
to the content you have added (not surrounding the content).

4 The New Optional Region dialog box contains two tabs: Basic and Advanced. To create a simple optional region;an 
optional region that template users can toggle themselves;enter a name for the region in the Basic tab and click OK.

5 Save the template.

Toggle the optional region in a file based on the template file: 

1 Create a new file from the template.

2 Choose Modify > Template Properties.

3 The optional region you defined above is listed in the Template Properties dialog box. Select the name of the 
optional region. By default, the optional region will be set to show, so the value for the optional region is True.

4 Turn off the optional region by clicking the Show<OptionalRegionName> option. Choose OK.

 You can create template parameters manually in the code of the template file, but template parameters are also created 
automatically when you create an optional region as described above. In any case, all template parameters must be 
written in the head of the document and must follow the syntax shown below (replace <custom> with customized 
values). 

<!-- TemplateParam name="<custom>" type="<custom>" value="<custom>" -->

 When you create an optional region using the method described above, the template parameter is written specifically 
as follows: 

<!-- TemplateParam name="<custom>" type="boolean" value="true" -->
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 While in the template file, you can create an optional region that uses a template parameter by using the Advanced 
tab of the New Optional Region dialog box: 

• Use Parameter: You can create an optional region that uses a pre-existing template parameter IF the template 
parameter is a boolean type with a value of either true or false. Any parameters that meet that specification will be 
available in this pop-up menu. 

• Enter Expression: Essentially, once you have created a template parameter, the parameter can be used as would any 
other parameter in JavaScript. In fact, template expressions are based on JavaScript coding rules, so the syntax is 
identical to JavaScript coding. You can use mathematical functions to add, subtract, multiply or divide parameters 
to added complexity. 

You can also create an optional region that uses a template parameter directly within the code. How you code these 
regions depends on where in the code you are using them. 

• A region that uses a template parameter can be expressed as a variable. This is the more flexible choice since it can 
be used to replace a value of a tag's attribute, and it can also be used as a placeholder for the content. You use the 
syntax below if expressing the parameter as a variable (replace <parameter> with the name of a defined template 
parameter): 

@@("<parameter>")@@

• A region that uses a template parameter can be expressed as a tag. The Template Expression tag is set off as an HTML 
comment, but it otherwise acts as a tag in that it has a single attribute and a value. This method can not be used to 
replace a value of a tag's attribute, since it is a tag itself. The Template Expression tag is coded as below (replace 
<parameter> with the name of a defined template parameter): 

<!-- TemplateExpr expr="<parameter>" -->

 In both cases, Dreamweaver recognizes the code and will replace the code with the value of the parameter in any page 
based on this template. To get a sense of how they differ, though, the following examples highlight how to use them. 

Example 1: In this example, either method of hand coding an optional region (highlighted in red) will work, because 
the code is not used to replace the value of a tag's attribute. In both cases, Dreamweaver will see this code in any page 
based on this template, and will replace the code with the actual defined value (the value will be editable for template 
users by modifying template properties): 

• Works:<title>@@("title")@@</title>

• Works:<title><!-- TemplateExpr expr="title" --></title>

Example 2: In this example, the method of hand coding that uses a Template Expression tag is incorrect, because the 
code IS used to replace the value of tag's attribute. For the first method, though, Dreamweaver will see this code in any 
page based on this template, and will replace the code with the actual defined value (the value will be editable for 
template users by modifying template properties). For both methods, the code that attempts to describe the parameter 
is highlighted in red: 

• Works:<table border=@@("border")@@ cellpadding=3 cellspacing=0>

• Does not work:<table border=<!-- TemplateExpr expr="border" --> cellpadding=3 cellspacing=0>

Editable Attributes

 Sometimes you want to allow your template users to adjust some specific aspects of the page, but not have access to all 
of the code for the element. Editable attributes can be the answer for this. Editable attributes allow the template users 
to change specific attributes of a tag, without having access to the tag itself. 
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Note: Editable attributes are a specialized use of an optional region. Essentially, adding an editable attribute is the same 
as defining that tag's attribute as an optional region. This feature creates a template parameter, for which the template 
creator can define a default value, and the template users can modify the parameter value as they would modify any 
other optional region's parameter value. 

The benefits of editable attributes

 In HTML, attributes are details assigned to tags. For example, a table tag may have a bgcolor attribute, which defines 
the background color of the table. Typically, if a template developer wanted template users to be able to modify things 
like the background color of a table, the developer would have to allow the entire table to be editable (so in the case of 
a table, the table would actually have to be added into an editable region). By using an editable attribute, however, the 
developer can add the table, set only table cells to be editable regions, and define the background color;the bgcolor 
attribute;to be an editable attribute. In a page based on such a template, the user will not be able to modify the table 
itself, but can change the bgcolor attribute and add or edit any content in editable regions within the cells of the table. 

How to create editable attributes

 Editable attributes are defined by the template developer. 

1 Open or create a new template file.

2 Add content to the page. For example, for the table example, insert a table on the page. Whatever you add to your 
page, it has to be contained in a tag (so text itself wouldn't work, but text contained in a paragraph tag would).

3 Select the tag whose attribute you want to enable. In the case of the table, select the table and define a background 
color for it. You can also skip this step and type the name of the attribute in step 5, but that requires knowing the 
name of the attribute.

4 With the object still selected, choose Modify > Templates> Make Attribute Editable. The Editable Tag Attributes 
dialog box appears:

5 Choose the attribute you wish to make editable from the Attributes pop-up menu. If you did not already set the 
attribute in step 2, click the Add button and type the name of a valid attribute. Important: The attribute must be a 
valid attribute for the tag.

6 Check the Make Attribute Editable option.

7 Type a name for this editable attribute. Dreamweaver will provide one automatically, but it is wise to type a name 
that you know will be unique. Remember, the template users will have to recognize this name from a list when 
choosing to define this attribute.

8 If you choose to make editable an attribute that was already defined, then Dreamweaver should choose the Type 
setting for you. If you added an attribute name in step 5, then you will have to choose the appropriate type from the 
pop-up menu. Verify this setting is correct for the data, since template users will have different methods of choosing 
their value depending on this setting. The choices are:

• Text: This is appropriate for a value that requires text. An example is the align attribute for a table tag. The 
template user will get a text box in which to enter the replacement text. 

• URL: This is appropriate for describing the path to a file. An example is the source (src) attribute for an image 
(img) tag. The template user will get a text box as well as a folder icon to allow them to browse to the file. 

• Color: This is appropriate for setting a color. An example is the background color (bgcolor) for a table tag. The 
template user will get a text box as well as a color picker to choose the color. 
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• True/False: This is appropriate for an attribute that toggles on or off. An example is the nowrap attribute for a 
table cell tag. The template user will get a pop-up menu from which to choose either true or false. 

• Number: This is appropriate for an attribute that requires a number. An example is the width value for a table 
tag. The template user will get a text box in which to enter the replacement number. 

9 Define a default value for the attribute.

10 Click OK.

11 Create a new page from this template, and choose Modify > Template Properties. A list of editable attributes will be 
listed in the dialog box. Optional regions are also in this dialog box. Select the attribute you want to edit and set the 
value in the dialog. Click OK and the new value will be set on the page.

Additional template features

Removing Template Regions

 To remove an editable area or other template region, highlight the region in question and choose Modify > Templates 
> Remove Template Markup. 

Check Template Syntax

 Another feature in Dreamweaver is the ability to verify that your template code is correct. With the added complexity 
and hand coding needed for some template expressions and parameters, there is a bigger opportunity for coding errors. 
Using the Check Template Syntax Command will help you debug your code. 

This feature can only be used in the actual template file. Choose Modify > Templates > Check Template Syntax. 

Example code

 This example code contains editable regions within a repeat region. To use the example code, follow these instructions: 

1 In Dreamweaver, create a new HTML Template (File > New > Template Page > HTML Template).

2 Save this file as a template within a defined site by choosing File > Save as Template, choosing the site from the Site 
list, and naming the file.

3 Within the browser window, select the example code from below and choose Edit > Copy.

4 Switch back to the template file in Dreamweaver.

5 Select all code in the template file (switch to Code View, and choose Edit > Select All) and paste the copied code by 
choosing Edit > Paste.

6 Save the template by choosing File > Save.

7 Make a page based on this template by choosing File > New> Templates, and selecting the template from the 
appropriate site. To use the repeating region feature, choose Modify > Templates > Repeating Entries, and add a new 
entry. These colors can be modified within the instance of the template by choosing Modify > Template Properties.

The template contains:

• an editable attribute.

• expressions

• editable regions

• repeat region

• Template parameters
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<html> <head> <title><!-- TemplateExpr expr="title" --></title> <meta http-equiv="Content-Type" 
content="text/html; charset=iso-8859-1"> <meta name="" content="This example is based an a template created by 
Wanda Huang.">

<!-- TemplateParam name="title" type="text" value="Using Repeat Region Variables in Expressions" --> <!-- 
TemplateParam name="border" type="number" value="1" --> <!-- TemplateParam name="evenColor" type="color" 
value="FFFFFF" --> <!-- TemplateParam name="oddColor" type="color" value="#CCCCCC" --> </head> <body 
text="#000000"> <table border=@@("border")@@ cellpadding=3 cellspacing=0> <tr> <th >Name</th> <th>email 
address</th> <th>phone</th> </tr> <!-- TemplateBeginRepeat name="Parent" --> <tr > <TD><!-- TemplateExpr 
expr="_index+1" --></TD> <TD><!-- TemplateBeginEditable name="email" -->email<!-- TemplateEndEditable --
><br> </TD> <TD><!-- TemplateBeginEditable name="phone" -->phone<!-- TemplateEndEditable --></TD> </tr> 
<!-- TemplateEndRepeat --> </table> </body> </html>

Additional information For more information about the new Dreamweaver MX template features, check the Using 
Templates section of the Dreamweaver Support Center.

For more information about creating nested templates, seeCreating a nested template in Dreamweaver MX (TechNote 
16282).

New features of Cascading Style Sheets in Dreamweaver 
MX
 

The Dreamweaver MX interface incorporates additional CSS editing options. Dreamweaver MX Cascading Style Sheets 
(CSS) are easier to use, and comply to World Wide Web Consortium (W3C) standards. This TechNote introduces some 
of the new CSS editing options in Dreamweaver MX.

Note: The Dreamweaver MX Design view renders CSS according to the standards set by the W3C. The W3C CSS Test 
Suite was used for testing and development.

Update: Dreamweaver MX 2004's implementation of CSS is more advanced than Dreamweaver MX. See the Developer 
Center article Designing with CSS Part 1: Understanding CSS Design Concepts for information specific to that version.

CSS in the Dreamweaver MX interface

CSS styles applied to text are reflected in both the CSS Styles panel and the Property inspector. Additionally, styles can 
be applied from either panel, or from the Text menu (Text > Style submenu).

Styles with block-level elements, and most inline-level elements applied in Dreamweaver MX are rendered correctly in 
the design window. The asterisk, used in earlier versions of the Dreamweaver CSS wizard to indicate styles that 
rendered only in the browser, is no longer needed. CSS constructs will now render in the design environment.

Dreamweaver MX CSS Styles panel

In the default Dreamweaver MX workspace layout, the CSS Styles panel is located on the Design tab, grouped with the 
HTML Styles and Behaviors panels. As with any MX panel, it may be ungrouped and floated in the workspace, or 
regrouped with other panels to accommodate workflow. To access the CSS panel when collapsed or ungrouped, choose 
Window > CSS Styles, or Shift + F11. There are two option modes: Apply and Edit Styles. When in the Edit mode the 
CSS window is split vertically.

To see the different modes move the mouse over the image below.

https://www.adobe.com/support/dreamweaver/templates.html
https://www.adobe.com/support/dreamweaver/templates.html
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_16282
http://www.w3.org/
http://www.w3.org/Style/CSS/Test/CSS1/current/
http://www.w3.org/Style/CSS/Test/CSS1/current/
http://www.adobe.com/devnet/dreamweaver/articles/css_concepts_cs3.html
http://www.w3.org/TR/REC-CSS2/visuren.html#block-level
http://www.w3.org/TR/REC-CSS2/visuren.html#inline-level
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• The Apply Styles mode displays custom styles, linked and embedded, and provides the ability to apply them to your
page.

• The Edit Styles mode displays all styles, linked and embedded, and the properties of each. It also provides easy access
for editing styles.

CSS Styles contextual menu

Each mode has the same contextual right-click menu (Windows), Control-click on 

Macintosh.

Applying a style from the CSS Styles panel. 

1 Select the text to which you wish to apply a style.

2 Click the style displayed in the Apply Styles mode.

Editing a style from the CSS Styles panel.

• To open the style definition panel and make changes, double-click (Windows) or Control-click (Macintosh) on the 
style or CSS file you wish to edit.

• Choose an individual CSS style from the CSS Styles panel. Click the Edit button (shown below) and make changes
as desired.

MX Property inspector

The Property inspector now has the ability of formatting text with CSS. CSS attributes are also displayed in the Property 
inspector. To access the Property inspector choose Window > Properties or Control + F3 (Macintosh). Use the image 
below to toggle the CSS and HTML options by clicking on the letter A (CSS/HTML toggle button) or the Font list drop-
down menu.

• Change the property's context from HTML <font> tags to CSS.

• The Property inspectordisplays the CSS style attributes for the text selected.

• Use the drop-down Style list to assign styles.

Note: Do not edit the style from here. Edits made with the Property inspector will generate HTML <font> tags.

CSS wizard changes

The Box category properties default to auto-complete all values at once. To set the Box attributes differently, 
deselect the Same for All option and set them individually.

Design Time Style Sheets

Last updated 11/5/2015



61

• Choose the drop-down arrow in the top-right corner of the Design tab > Design Time Style Sheets. Or right-click
the style (Windows), Control-click (Macintosh), and choose Design Time Style
Sheets.

• Use the plus (+) and minus (-) buttons to setup the CSS file
visibility.

Note: Each external CSS file is either turned on or off in Design Time Style Sheets. Individual styles within a CSS file 
cannot be hidden or shown at design time only. Internal style sheets cannot utilize the Design Time feature.

W3C Tags

Dreamweaver MX uses the default tags <strong> for bold text and <em> for italic text, instead of the <b> and<i> tags. 
To use the <b> and <i> tags, choose Edit > Preferences > General.

External Editors

Dreamweaver MX will recognize TopStyle an external CSS editor. To specify TopStyle as the default CSS editor, choose 
Edit > Preferences > File Types/Editors.

Additional Information

For additional information about Cascading Styles Sheets, please see the following TechNotes and Designer & 
Developer Center articles:

• Best Practices with CSS in Dreamweaver CS4

• Learn to work with CSS

• World Wide Web Consortium, CSS

coords=6,1,310,214rect152,2,316,114rect4,0,144,113

How to use a MouseOver Event to create an Image Swap 
Action in a different frame
Note: This TechNote only applies to Dreamweaver 1.x. Cross frame communication is a feature built into Dreamweaver 
2. Refer to the Dreamweaver 2 documentation for assistance.

Dreamweaver Events and Actions are easily assigned to objects within one frame. When an Event in an Active Frame 
is used to control an Action in a different frame (independent separate file), the code "parent.frameName" is added 
manually to accomplish the cross frame communication. The following example uses the Swap Image Action with the 
onMouseOver and onMouseOut Events. This technique can be adapted for other Events and Actions. 

Swap Image Example

 The Web page in this example is divided into two frames (left and right). This division is commonly used for 
navigation, where an index on the left frame loads the page selected from the index on the right frame. In the 
following example the logo.gif image will be inserted in the left frame and the greentea.gif image inserted in the 
right frame. When the mouse is moved over the logo image, it only changes the green tea image in the right frame to 
another image with no change to the logo in the left frame. When the mouse moves away from the logo in the left 
frame, it changes the image on the right frame back to its original. 

Last updated 11/5/2015

A new feature created for the developer's convenience is the Design Time Style Sheets option. For example, this handy 
feature can be used to see text in the draft stage or to hide a background image.

http://www.bradsoft.com/topstyle/index.asp
http://www.adobe.com/devnet/dreamweaver/articles/css_best_practices.html
http://www.adobe.com/devnet/dreamweaver/css.html
http://www.w3.org/Style/CSS/
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To use an event to create an action in another frame do the following:

1 Choose File>New and choose View>Frame Borders. Choose Window > Frames. This shows the Frame inspector 
Window.

2 Move the mouse to the left frame border and hold down Alt (Windows) or Option (Macintosh) and drag the border 
to the right to create two frames equal in size. (In this example the width of the frames can be any size.)

3 Click the mouse in the left frame in the Frame Inspector window. Choose Window>Properties and name the 
frame"pNav."

4 Click the mouse in the right frame in the Frame inspector window. In the Frame Properties window name the 
frame"pBody."

5 Choose File>Save Frameset and enter a filename. Use the file name "example.htm". Click Save.

6 Choose File>Save All. This opens the save dialog prompting to save the new documents created by the two 
frames.Note: Dreamweaver always defaults to the right frame first.

7 Name the right frame file "rightbody.htm" and name the left frame file "leftnav.htm".

8 Click the left frame in the main window and insert logo.gif image. This image is located in the 
Dreamweaver>Configuration>Template folder.

9 Choose Window>Properties and name the image"myLogo".

10 Click the right frame in the main window and insert the greentea.gif image. This image is located in the 
Dreamweaver>Configuration>Templates>Frames folder.

11 Choose Window>Properties and name the image"myTea".

12 Choose File>Save All. This saves the frameset file and the separate files for the left and right frames.

13 Select the green tea image. Choose Window>Behaviors to open the Behaviors dialog box. Leave the Browser version 
set to 4.0 Browsers.

14 Access the Events pop-up menu by clicking the plus button. Select onMouseOver from the pop-up menu. Click OK 
on the dialog reminder about the anchor.

15 In the Actions pop-up menu select Swap Image. Select the logo.gif for the source image. Leave Preload images 
checked.Note: The anchor tags for the Preload Image Behavior appear in the window.

16 Select onMouseOut from the Events pop-up menu. Select Swap Image from the Action menu. Select the greentea.gif 
for the source image.

17 Open the HTML source window for the right frame. Cut the code for the anchor tag but DO NOT include the 
reference for the green tea image (img href="../greentea.tif).Note: This leaves an </a> tag in the main window of the 
right frame. Delete the extra </a> in the right frame.Code Example
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<a href="#" onMouseOver="MM_swapImage 

 ('document.myTea','document.myTea',' 

 ../logo.gif','MM_swapImage1')"   onMouseOut="MM_swapImage 

  ('document.myTea','document.myTea',' 

 ../greentea.gif','MM_swapImage2')">

18 Open the HTML source window for the left frame. Paste the code for the anchor tag in front of the <img src> tag 
for the logo.gif. Make sure the </a> tag is at the end of the code for the logo image.Note: An </a> anchor (to close 
the <a href> tag) needs to be added manually for the left frame and the </a> deleted from the right frame code.

19 If the left frame does not contain the JavaScript code between the <head> and </head> tags for preloading and 
swapping images, open the right frame and copy the code. Paste the code between the <head> and </head> tags of 
the left frame.Note: Only the required JavaScript functions need to be copied. In this example with a new created 
document, copy all the JavaScript functions.

Start copying the following section: 

<script > 

<!--function MM_preloadImages()> Including the section:<function MM_swapImage()> 

 end with the section:</script> 

20 When using the Preload Image behavior also cut the JavaScript code between the <body> and </body> tags from 
the right frame and paste between the <body> and </body> tags in the left frame. Code Example

<<!-- #BeginBehavior MM_swapImage2 --> 

<script language='JavaScript'> 

<!--MM_preloadImages('../greentea.gif');//--> 

</script> 

<!-- #EndBehavior MM_swapImage2 --> 

<!-- #BeginBehavior MM_swapImage1 --> 

<script language='JavaScript'> 

<!--MM_preloadImages('../logo.gif');//--> 

</script> 

<!-- #EndBehavior MM_swapImage1 -->> 

21 Open the HTML source window of the left frame and type in"parent.pBody." in front of each"document.myTea" in 
the code of the anchor tag for the image. The reference to "document.myTea" occurs four times. The mouse event 
can then correctly reference the targeted frame window within a frameset.Code Example
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<a href="#" 

 onMouseOver="MM_swapImage 

 ('parent.pBody.document.myTea', 

 'parent.pBody.document.myTea',' 

 ../logo.gif','MM_swapImage1')" 

 onMouseOut="MM_swapImage 

 ('parent.pBody.document.myTea', 

 'parent.pBody.document.myTea',' 

 ../greentea.gif','MM_swapImage2')"> 

<img href="../logo.gif" 

   name="mLogo"></img></a> 

22 Choose File>Save All and Press F12 to view results in browser.

Modified date of local file changes after put

Issue
 After uploading a file to the remote server, the modified date for the local file changes in the Files panel to match the 
modified date of the file uploaded to the server. 

Note: This TechNote applies to Dreamweaver MX 2004 and earlier. The timestamp-related features were redesigned in 
Dreamweaver 8. The local file's timestamp is no longer changed when putting files. For more information, see "How 
synchronization works in Dreamweaver 8" (TechNote kb400972 ). 

Reason
 This change in the modified date for the local file is necessary for the Synchronize command in Dreamweaver MX 2004 
and earlier. Making this change to the local file's modified date is necessary so thatduring the synchronization process, 
Dreamweaver MX 2004 and earlier can determine whether a local file has been updated since it was last transferred to 
the server. 

Additional Information
 For more information about Dreamweaver MX 2004 and earlier synchronization issues, see "Synchronize and Select 
Newer options are not working correctly" (TechNote tn_14413 ). The Site Management and Collaboration chapter in 
the manual, Using Dreamweaver, has additional information about synchronizing local and remote files. 

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb400972
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_14413
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"Low on memory" errors when running Dreamweaver

Issue
 When running Adobe Dreamweaver on Windows, the following error occurs: "Your system is low on memory, Please 
save your documents, then free up memory by closing some document or other applications." One thing that some 
users reporting this problem have in common is that they are running Windows systems with 2GB of RAM. (Ref. 
223385) 

Reason
 There are two reasons that Adobe is aware of that can cause this problem: 

• This problem usually occurs when the currently allocated amount of virtual memory is manually set at a value lower 
than the recommended amount of virtual memory. This can occur when you add real memory to your system and 
you don't manually increase the currently allocated amount of virtual memory. 

• One user has reported that this problem was fixed when there was a file path that exceeded 255 characters and 
shortening the file path fixed the problem. 

Solution
 Make sure that the currently allocated amount of virtual memory on your system is set to a value at least the same as 
the recommended amount of virtual memory. The recommended amount of virtual memory is based on the amount 
of real memory of your system. Virtual memory is a system to extend the amount of real memory, so it will always be 
larger than the real amount of memory you have. 

Setting the amount of virtual memory allocated on Windows XP:

1 Go to the Start Menu > Settings > Control Panel > System.

2 In the System Properties dialog box, select the Advanced Tab. In the Advanced tab, go to the Performance section 
and click the Settings button.

3 In the Performance Options dialog box, click the Advanced tab, go down to the Virtual Memory Section and click 
the Change button.

4 In the Virtual Memory dialog box, if you have the Custom Size option chosen, verify that the Initial Size matches 
the Recommended Size at the bottom. In other words, the Currently Allocated Size should match the 
Recommended Size. You will need to restart your system after changing the Initial Size.

Setting the amount of virtual memory allocated on Windows Vista:

1 Choose Start > Control Panel.
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2 Choose Classic View in the left pane.

3 Double click System.

4 Click the Advanced System Settings link to open the System Properties dialog box.

5 Click the Advanced tab, then click the Settings button in the Performance section.

6 In the Performance Options dialog box, click the Advanced tab, go down to the Virtual Memory Section and click 
the Change button.

7 In the Virtual Memory dialog box, if you have the Custom Size option chosen, verify that the Initial Size matches 
the Recommended Size at the bottom. In other words, the Currently Allocated Size should match the 
Recommended Size. You will need to restart your system after changing the Initial Size. You can also instead try 
using the option: "Automatically manage paging file size for all drives".

Check for file paths longer than 255 characters

 Check your files for any file paths that exceed 255 characters and shorten the file paths if you see any. 

JavaScript error and hang when performing Save To 
Remote Server

Issue
 When selecting File > Save To Remote Server, the following JavaScript error occurs in Dreamweaver: 

While executing DWMenu_File_SaveDocumentToRemoteServer command in menus.xml, the following JavaScript 
error(s) occurred:

Exception thrown in native function.

 After clicking the OK button, Dreamweaver hangs. The only way to exit from Dreamweaver is to force quit. This issue 
only occurs with Windows XP, and does not occur on Windows Vista. (Ref. 225886) 

Reason
 This error occurs when you have Internet Explorer 7 installed on Windows XP. 
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Solution
 There are two recommended solutions: 

• Use an alternative method of saving files to the server. For example, use the Put button or Check-In button in the 
Files panel to upload files to the server. 

• Uninstall Internet Explorer 7 which will rollback your system to Internet Explorer 6. 

Additional Information
 For more information on other JavaScript errors, see Troubleshooting JavaScript errors in Dreamweaver (TechNote 
tn_19105 ) 

Issue when creating a database connection: HTTP Error 
Code 404 File Not Found (Dreamweaver Developer 
Toolbox)

Issue
 When I try to create a new Dreamweaver database connection, I get an error message saying : HTTP Error Code 404 
File Not Found

Reason
 There are several possible causes for which this can happen: 

1 The testing server is not setup right in the Dreamweaver site definition. Dreamweaver attempts to upload some files 
on the testing server into the folder you pointed into the site definition and then it tries to call them with an HTTP 
call using the URL base you provided. If the paths are not configured correctly, you will receive this error.

2 The web server is not up and running on the testing server machine.

3 The proxy server as it is configured in thebrowser,is used even for local addresses like localhost, the testing server 
where you want to connect.

4 Your browser is set to "Work Offline".

Solution
 There are several solutions you can attempt: 

1 Go into your site definition from Dreamweaver and recheck all the choosen paths (both folders and URLs).

2 Check the web server status, you may even restart it to be sure.

3 You should change your proxy server configurations in thebrowser to bypass local addresses like localhost.

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_19105
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Installing Dreamweaver MX / MX 2004 in Safe Mode on 
Windows
 If you are experiencing crashes, errors or other unexpected behavior with Dreamweaver MX 2004 or Dreamweaver 
MX, reinstall it with all other applications and background processes turned off to ensure nothing is conflicting with 
the Dreamweaver installer, like anti-virus software. Before installing Dreamweaver in Safe Mode, perform a complete 
uninstall as described in Uninstalling Dreamweaver MX / MX 2004 on Windows (TechNote 362d7b81). 

Note: Dreamweaver 8 uses Windows Installer packages (MSI). Therefore, you cannot install Dreamweaver 8 in Safe 
Mode, because Safe Mode disables the Windows Installer service. For more details on diagnostic installations of 
Dreamweaver 8, see Installing Studio 8 products in Selective Startup mode on Windows XP (TechNote d2b5934d). 

Installing Dreamweaver MX & MX 2004 in Safe Mode

1 Copy the Dreamweaver installer from the installation CD onto the Windows desktop. This is necessary because the 
CD-ROM drive will be disabled in Safe Mode. If you downloaded the application, make sure the installer is fully 
downloaded and available on your hard drive.

a In Windows, browse the MX or MX 2004 CD and go to the FSCOMMAND folder.

b Copy DW_Client_Installer.exe from the FSCOMMAND folder to the Windows desktop.

2 Reboot the computer system in Safe Mode. Here are the instructions for Windows XP, 2000, 98, ME, 95:

a Restart the computer.

b When the computer begins to boot back up, start tapping the F8 key. For Windows 98 and ME, the Ctrl key also 
works.

c When the Windows startup menu appears, select Safe Mode.

3 Log in using the Windows administrator account or a user account with administrator privileges.

4 Exit from all applications that may be open. Disable any virus protection software if Safe Mode did not already 
disable it.

5 Run the installer you copied to the desktop in step 1.

6 When installation is complete, delete the installation files copied from the installation CD.

7 Restart the computer in normal mode.

8 Launch Dreamweaver.

Additional Information
 Here are some related TechNotes: 

• Uninstalling Dreamweaver MX & MX 2004 on Windows (TechNote 362d7b81) 

• Troubleshooting Dreamweaver for Windows (TechNote 15481) 

• Installing Studio 8 products in Selective Startup mode on Windows XP (TechNote d2b5934d) 

• Dreamweaver crashes when performing a task related to site definitions (TechNote 5989f7f4) 

• Uninstalling Studio 8 applications on Windows (TechNote 4e7826b7) 

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=362d7b81
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=d2b5934d
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=362d7b81
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15481
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=d2b5934d
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=5989f7f4
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=4e7826b7
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Installing Dreamweaver CS3 in Selective Startup Mode 
on Windows Vista
 If you are experiencing crashes, errors or other unexpected behavior with Adobe Dreamweaver CS3, it's a good idea to 
try reinstalling it with all other applications and background processes turned off, to ensure nothing is conflicting with 
the Dreamweaver installer, like anti-virus software. The Windows installer for Dreamweaver uses Windows Installer 
packages (MSI), and because of this, you cannot install Dreamweaver in Safe Mode, because Safe Mode disables the 
Windows Installer service. 

If you have Windows Vista, an alternative to installing in Safe Mode is to start in Selective Startup Mode. This mode 
will disable most nonessential programs and background processes, but it will let you enable the Microsoft services, 
including the Windows Installer service, so you can install Dreamweaver. 

How to start in Selective Startup mode

Note: Make sure your Windows account has administrative privileges before booting up in Selective Startup Mode. If 
you do not have administrative privileges, you may not be able to return to Normal Mode. 

1 In Windows Vista, choose Start, type msconfig in the Search text box, and press Enter.

2 This will bring up the System Configuration dialog box.

3 Click the General tab, and choose Selective Startup.

4 Select Load System Services, deselect Load Startup Items, and leave Use Original Boot Configuration selected.

5 Click the Apply button and then click the Services tab.

6 Select Hide All Microsoft Services so you only see non-Microsoft services.

7 Click the Disable All button so all non-Microsoft services are disabled.

8 Deselect Hide All Microsoft Services and verify that all Microsoft services are enabled but all non-Microsoft services 
are disabled.

9 Click Apply and then click OK and restart your machine when prompted.

10 After restarting into Selective Startup mode, install Dreamweaver.

11 Once Dreamweaver has been installed, run msconfig again and specify Normal Startup mode.

12 Restart the machine back into Normal Startup mode and see if the problem with Dreamweaver has been resolved.

Additional Information
 Please refer to the following Microsoft Knowledge Base articles for more information on Selective Startup Mode in 
Windows Vista: 

• How to perform a clean boot procedure to prevent background programs from interfering with a game or a program 
that you currently use (Article ID 331796) 

• Run Selective Startup using System Configuration

• Using System Configuration

 For Windows XP installation tips, see "Installing Dreamweaver in Selective Startup Mode on Windows XP" (TechNote 
d2b5934d ). 

For general Windows troubleshooting tips, see "Troubleshooting Dreamweaver for Windows" (TechNote tn_15481 ). 

http://support.microsoft.com/kb/331796
http://support.microsoft.com/kb/331796
http://windowshelp.microsoft.com/Windows/en-US/Help/121ff6a6-181e-4e8f-83bb-c7b1f3c6d71a1033.mspx
http://windowshelp.microsoft.com/Windows/en-US/Help/bd9e1cb6-a66a-47a8-a4b6-ef7ea672ae4b1033.mspx
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=d2b5934d
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15481
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How to include the current date in an insert page
 There are different ways to include the current date in a newly inserted record. This TechNote describes two options: 

1 Using hidden fields with ColdFusion, PHP, ASP, ASP.NET or JSP code.

2 Setting the default value for the database field equal to the current date.

Hidden form fields

 One approach to this task is to setup a hidden field (Insert> Form > Hidden Field). Once the hidden field has been 
added, select the yellow icon that represents the hidden field and go to the Property inspector. In the Value field, enter 
the appropriate code for the date function: 

• ASP: <%= Date() %>

• JSP: <%= new java.util.Date() %>

• ColdFusion: #Now()#

 If you want to give the end user the option to change the date to something other than today's date, then use a regular 
text field instead of a hidden field. 

When filling out the Insert Record server behavior dialog box, map the hidden form field to the date field in the 
database and set the data type to either "Date" or "MS Access Date".

Note: The date being inserted will be the date on the application server. Keep this in mind if users are in different time 
zones. 

Setting the default value in the database

 Another approach to this task is to set the default value of the database's date field to the current system date. Most, if 
not all, databases will have a "default value" option for database fields. One advantage to using this approach is that you 
do not have to worry about the date format being sent from the web page. Here is how to set the default value to today's 
date in Microsoft Access 2000: 

1 Open the database in Microsoft Access.

2 Open the database table in Design view, and select the date field.

3 Go to the General tab in the bottom section of the window and type "Date()" (no quotes) in the Default Value field.

4 Save and close the database, and go back to Dreamweaver to finish the insert page.

5 When filling out the Insert Record server behavior dialog box in Dreamweaver, you will not map a form field to the 
date field in the database. The database will automatically fill in the current date when a new record is created.

 Please refer to the Microsoft Access documentation for further detail on setting default values. If you are not using 
Access, please refer to your database documentation for instructions on how to set the default date value. 

Note: The date being inserted will be the date on the database server. Keep this in mind if users are in different time 
zones. 

Additional information

For more information on how to use the Insert Record server behavior, please see Building an insert record page block 
by block.

https://helpx.adobe.com/dreamweaver/using/building-record-insert-page-cs6.html
https://helpx.adobe.com/dreamweaver/using/building-record-insert-page-cs6.html
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HTML colors are different from SWF colors
If you set a SWF file's background color to the same background color as an HTML page, the colors don't always match 
on all machines. In particular, you're more likely to see a slight difference on 16-bit monitors, set to display at 
"thousands of colors." That's because a 16-bit monitor can't display as many colors as other monitors, and different 
renderers can round colors in different ways.

Monitors set to "hundreds of colors" have a wider range than those set to "thousands." Although a 16-bit display can 
show more simultaneous colors, the palletized image can choose from a wider range of colors.

The math shows why: 32-bit monitors and 8-bit palettes both use a full byte of information for the red, green, and blue 
channels. That's 256 possible values for each of three colors. But a 16-bit monitor has only 2 bytes of info per pixel, and 
it gives about 5 bits to each channel. Therefore, it can only display 32 different red values, 32 different green values, and 
32 different blue values. Each channel can display only one-eighth of the colors seen on other displays.

When a color is shown on a 16-bit display, most of the time it is rounded to the nearest permitted color. Different 
renderers in a browser can round colors in different ways. That's why a SWF file's color and HTML color can have the 
same definition, but look different from each other on different machines.

Possible solutions

• Try making designs that don't require absolute color fidelity across all machines.

• Use "herringbone" and other patterns to hide edges.

• Consider putting more of the page's content inside the SWF file.

• On Windows versions of Internet Explorer, you can set thewmode attribute to hide an unused SWF file's 
background.

None of thesesolutions are entirely satisfactory, but it can be difficult to expect all devices to render all colors identically.

Do "Web-safe colors" matter?

Not really, not in this case. Web-safe colors describe how a browser sets the computer's palette at a depth of "hundreds 
of colors." but these color-cube values can still shift on a monitor set to "thousands of colors." The Web-safe color 
discussions are a bit different from these 16-bit rounding discussions.

To summarize, a monitor set to display "thousands of colors" can only show a fraction of the colors seen on other 
monitors. Different renderers inside a browser round colors in different ways.

Flash movies won''t play in the document window
IssueAfter clicking the play button (on the Properties inspector) for a selected Flash movie object, the movie won't play 
in the Dreamweaver 3 document window. 

ReasonDreamweaver 3 cannot find the Macromedia Flash Player (referred to as the Flash plugin in Dreamweaver 3) 
to display the movie (an SWF file) in the document window. You may not have installed the Flash Player in the Netscape 
Communicator Plugins folder. 
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SolutionYour computer system must have the Flash Player for the Netscape browser installed in order to play a Flash 
movie in Dreamweaver 3. You do not have to have the Netscape browser itself on your system; however, you do need 
to install the Flash Player for the Netscape browser. 

Installing the Flash Player for the Netscape browser

Note:These instructions are intended for Dreamweaver 3 users only. Dreamweaver 4 installs the Flash 5 plugin into its 
own Plugins folder by default, thus avoiding this Dreamweaver 3 issue. 

Error message using Put or Check-in files: Cannot create 
directory...it already exists

Issue
 It is not possible to transfer files that reside more than two directories deep from the Root folder. When attempting to 
do so, the following error message appears: "Cannot create directory example/subexample/subsubexample because it 
already exists." 

Reason
 The Web host is using WU-FTPD v2.6. Many users may have been using Dreamweaver without these errors, but may 
start getting these errors due to an incompatibility when Web hosts and ISPs upgrade to WU-FTPD v2.6. There may 
be other FTP server software packages that yield the same or similar error messages. 

Solution
 Open the Site FTP log and read the login information. In Windows, this is done by choosing FTP log from the Site 
menu in the site files window. On Macintosh, choose FTP log from the Site menu to access the login information. On 
many servers, including WU-FTPD, this log will identify which FTP server software is being used by the Web host or 
ISP. If it is WU-FTPD v2.6, Dreamweaver 1 and 2 cannot be used to transfer files more than two directories deep. 

Download the Flash Player from 
http://www.macromedia.com/downloads/.

The Flash Player can also be installed from the Dreamweaver 3 
installation CD, as follows:

1

Navigate to Other Macromedia Software > Flash Player > Netscape > 
flash32.EXE.

2

Double-click on the flash32.EXE file to launch the installer.

3

Follow the instructions to install the Flash Player.

http://www.adobe.com/downloads/
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Workarounds:
• Use a directory structure that doesn't have files more than two directories deep. For example, use: ROOT: 

Images/Subimages/phoo.gif In place of this structure: ROOT: Images/Subimages/Subsubimages/phoo.gif 

• Use an external program to transfer files which are more than two directories deep. 

Note: Upgrading to Dreamweaver 3.0 will alleviate this problem. 

Error calling getTables: an unidentified error has 
occurred

Issue
When expanding the Tables tree in the Database Items section of UltraDev's advanced recordset dialog box, the error 
"Error calling getTables: an unidentified error has occurred." is generated.

Or, an "Unable to retrieve table from this connection, click on the 'Define...' button to test this connection." error is 
generated when using the simple recordset dialog when selecting a connection from the Connections pop up menu.

Reason
These errors occur even when the connection test within UltraDev's Modify Connection dialog box is successful. This 
is an OLEDB provider issue which is specific to OLEDB connections using Microsoft SQL Server version 6.5. This is 
not an issue when using other versions of Microsoft SQL Server, or when using ODBC connections with Microsoft SQL 
Server 6.5.

Solution
The work around is to use ODBC connections instead of OLEDB connections when connecting to a Microsoft SQL 
Server 6.5 database. See Using ADO Connections in UltraDev (TechNote 14577) for more information on connection 
strings within UltraDev.

Dreamweaver CS3 performance problems on Mac OS

Issue
 Some Intel-based Macintosh users are reporting performance problems with Adobe Dreamweaver CS3. Some of the 
symptoms include Dreamweaver freezing for 2-60 seconds when opening files and performing basic actions in the 
Dreamweaver user interface, like typing text, selecting table elements, and scrolling up and down. 

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_14577


74

Last updated 11/5/2015

There are two scenarios where this problem occurs: 

• You are using a remote server as the Local Root Folder in the Site Definition and your files have several images. 

• You are using your local hard drive as the Local Root Folder in the Site Definition and your files have several images 
or have external images referenced with absolute paths. 

(Ref. 227126, 227108, 227272) 

Reason
 Dreamweaver CS3 has a problem processing images with certain files on Intel-based Macs. The more images the file 
contains, the more noticeable the problem is. If you can reproduce this problem with a page that does not contain any 
images, then this TechNote does not address the problem you are seeing. 

Solution
 Adobe is aware of this problem and is researching it. Dreamweaver CS3 has a native binary for Intel-based Macs, so in 
general it is much faster than previous versions of Dreamweaver on Intel-based Macs, but there appears to be an image 
processing problem with some setups. 

Solution 1

 If you are using a remote machine as the Local Root Folder in your Site Definition, use a folder on your local hard drive 
as the Local Root Folder. 

Solution 2

 If your pages contain external images, try deselecting View > Display External Files. External images have absolute 
URLs for the src path, for example: http://www.example.com/images/logo.gif. 

Solution 3

 Run Dreamweaver in Rosetta mode. You will lose performance gains in tasks like startup time, menu response, etc., 
but the problem described in this TechNote should stop. To run Dreamweaver in Rosetta mode, perform these steps: 

1 In the Finder, browse to Applications/Adobe Dreamweaver CS3/Dreamweaver.

2 Select the Dreamweaver application and choose File > Get Info.

3 In the General section, select "Open using Rosetta".

Solution 4

 If none of the scenarios above apply to you, please contact Adobe Tech Support . When contacting Tech Support, please 
provide answers to the following questions: 

• If you open a page with no images, does the problem still occur? 

• For users that have an FTP server connection in their site definition: if you disconnect from the FTP server, does 
the problem still occur? 

• If you collapse all of the folders in the Files panel, does the problem still occur? 

Additional Information
 For more information on Dreamweaver for Macintosh troubleshooting, see the following TechNotes: 

• "Troubleshooting system errors or freezes in Dreamweaver (8, CS3 on Mac OS X)" (TechNote kb401096 ) 

• "Slow system performance using Dreamweaver" (TechNote tn_16104 ) 

http://helpx.adobe.com/dreamweaver/kb//support/contact/
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb401096
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_16104
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Dreamweaver CS3 and CS4 could not connect to FTP site 
after Leopard (Mac OS X v10.5) upgrade

Issue
 After you upgrade a Mac OS X system from Tiger (Mac OS X v10.4) to Leopard (Mac OS X v10.5), or after you perform 
a clean install of Leopard (Mac OS X v10.5), Adobe Dreamweaver fails to connect to some FTP sites. 

Details
 The sites defined in Dreamweaver use domain names for the FTP host attribute.

Reason
 The Dreamweaver Engineering team is currently investigating this issue.

Solution
 Do one or more of the following solutions: 

Solution 1: Update to the latest dot release of Mac OS X v10.5.
 Download the latest dot releases from the Apple website. 

Solution 2: Use the IP address of the FTP host instead of the domain name.

Additional Information
 Currently, this error has only been reported in Adobe Dreamweaver CS3 and CS4 (Ref. 229582). 

Dreamweaver CS3 crashes after Daylight Savings Time 
ends

Issue
 Adobe Dreamweaver CS3 crashes when working with certain PHP or ASP files in Code view or Design view after the 
clock goes back one hour, when Daylight Savings Time ends. The crashes only occur when selecting certain lines in 
Code view, or selecting certain objects in Design view. The crashes only occur in files that have PHP or ASP code, 
intermingled with HTML code. The crashes do not occur in Dreamweaver 8 or earlier (Ref. 229536). 

Reason
 The Dreamweaver CS3 WinFileCache-AD76BB20.dat file has been corrupted by the time change.
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Solution
1 If Dreamweaver is open, quit the application.

2 Delete the WinFileCache-AD76BB20.dat file from the Dreamweaver user configuration folder. Note that on 
Windows, the Application Data and AppData folders are hidden by default, so verify that your Windows Explorer 
folder options are set to View Hidden Folders. The location of this file is as follows:

• Dreamweaver CS3 on Windows Vista: C:\Users\[username]\AppData\Roaming\Adobe\Dreamweaver 
9\Configuration 

• Dreamweaver CS3 on Windows XP: C:\Documents and Settings\[username]\Application 
Data\Adobe\Dreamweaver 9\Configuration 

3 Restart Dreamweaver.

Dreamweaver 8 for Windows loses FTP login settings
Issue

 Some Windows users are reporting that their FTP usernames and passwords in their Dreamweaver site definitions are 
deleted when they close and re-open Dreamweaver 8 or when they reboot their machine. This issue does not occur in 
earlier versions of Dreamweaver. (Ref. 205051, 210466) 

Reason

 There are two known causes for this issue: 

• The most common cause is that Internet Explorer 7 (IE 7) is installed on the same machine as Dreamweaver 8.

• A less likely cause is that the following registry key is missing or is 
empty:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Explorer\User Shell 
Folders\AppData

Solution

If you have Internet Explorer 7 installed

If you have Internet Explorer 7 installed, then installing theDreamweaver 8.0.2 Updater should resolve this issue. Before 
installing the Dreamweaver 8.0.2 Updater, it is recommended to check the Dreamweaver 8 Emerging Issues TechNote 
for changes that may affect your workflow, particularly if you create server-side pages (ASP, PHP, ColdFusion, etc.) or 
insert Flash content.

Note: After you install the Dreamweaver 8.0.2 Updater, verify that the updater successfully installed. Some users think 
they have installed 8.0.2, when in fact the updater installation didn't take. In Dreamweaver, go to Help > About 
Dreamweaver > and click the scrolling text to reveal the version number. It should say Dreamweaver 8.0.2. If it still says 
Dreamweaver 8.0 or 8.0.1, please see Can't install Dreamweaver 8 updaters for Windows after canceling updater 
installer (TechNote 785362aa).

Note: Internet Explorer 7 was released after Dreamweaver 8 and therefore was not tested with Dreamweaver 8 and 
earlier.

If you do not have Internet Explorer 7 installed or if the Dreamweaver 8.0.2 Updater doesn't solve the problem

If you didn't have Internet Explorer 7 at the time this problem occurred, then install the Dreamweaver 8.0.2 Updater as 
described above, and then perform the following steps if you are comfortable editing the Windows Registry.

https://www.adobe.com/support/dreamweaver/downloads_updaters.html
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=a3f38dcf
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=785362aa
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=785362aa
https://www.adobe.com/support/dreamweaver/downloads_updaters.html
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Warning: Editing the Windows Registry incorrectly can cause serious problems that may require reinstalling your 
operating system. Adobe does not guarantee that problems caused by editing the registry incorrectly can be resolved. 
Edit the registry at your own risk.

1 Launch the Registry Editor by clicking the Start button, choose Run, then type "regedit". In the Registry Editor, 
navigate to this folder:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Explorer\User 
Shell Folders\

2 See if there is a key called AppData, as shown in the screen shot below:

3 Backup the Users Shell Folders registry branch as follows:

a Right-click the Users Shell Folders folder and select "Export".

b In the "Export range" section, choose "Selected branch".

c Save the .reg file to the desktop.

d If problems occur after editing the registry, double-clicking the .reg file will re-install that registry branch.

4 If the AppData key is missing, then perform the following steps. If the AppData key exists, then skip to Step 5.

a On the right side of the Registry Editor explorer pane, right-click in a blank area anywhere under the last key in 
the list. You should get a context menu that says "New" with a flyout menu.

b In the flyout menu, select "Expandable String Value" and name the new key AppData.

5 Right-click the new AppData key (or the existing one if it was already there), select Modify, and enter the following 
in the Value Data field: %USERPROFILE%\Application Data. If the values for the other keys in your User Shell 
Folders directory don't start with %USERPROFILE%, then use the value that your other keys use. For example, if 
your Local Settings key has a value of u:\Local Settings, then try usingu:\Application Data.

6 Open Dreamweaver, re-enter the FTP login information for one of your sites, and see if the FTP login is now saved 
when you close and re-open Dreamweaver.

If the solutions above don't solve the problem, then please contact Adobe Technical Support or submit a bug report and 
specify that you are experiencing the issue described in TechNote 3491671c.

Dreamweaver 8 issues on Windows Vista
What's covered

• Vista support for Dreamweaver 8 

• Known support issues on Vista 

Vista support for Dreamweaver 8

Dreamweaver 8 was released more than a year before Windows Vista became publicly available and does not officially 
support this new operating system. However, Dreamweaver 8 runs fine for the majority of users running Windows 
Vista. Dreamweaver CS3 is avaliable and fully supports Windows Vista. Please refer to How Adobe Products Support 
Vista for more information on Adobe product support for Vista,

Known support issues on Vista

https://www.adobe.com/support/contact/
https://www.adobe.com/go/wish
http://helpx.adobe.com/dreamweaver/kb/#main_VistaSupport
http://helpx.adobe.com/dreamweaver/kb/#main_KnownSupportIssues
https://www.adobe.com/support/products/pdfs/adobe_products_and_windows_vista.pdf
https://www.adobe.com/support/products/pdfs/adobe_products_and_windows_vista.pdf
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 While Dreamweaver 8 works well for most users on Vista, some users have reported problems. 

Vista specific issues with Dreamweaver 8: 

• Dreamweaver 8 crashes on some Vista systems while browsing for files (TechNote kb400788 ) 

• Vista help system stops working when Dreamweaver is the default XML editor (TechNote kb400789 ) 

• Control-Alt-Tab keyboard shortcut change in Windows Vista (TechNote 8718ad77 ) 

Common support issues that also affect Vista with Dreamweaver 8: 

• Troubleshooting Dreamweaver for Windows (TechNote tn_15481 ) 

• Dreamweaver 8 does not launch (TechNote fb181c10 ) 

• Can't install Dreamweaver 8 updaters for Windows after canceling updater installer (TechNote 785362aa ) 

Dreamweaver 8 crashes while browsing files (Windows 
Vista)

Issue
Dreamweaver 8 may crash when it performs file browsing actions on Microsoft Windows Vista. Some examples 
include:

• Using File > Open to browse the hard drive to open a file.

• Inserting an image and using the file browser to select the image.

• Creating a hyperlink and using the file browser to select the target file.

• Creating a site definition and using the file browser to select the local root folder or remote folder.

Additional reported behavior includes:

• Crash occurs when a file browsing dialog appears.

• Crash occurs when browsing two or more folders away.

• Crash occurs after inserting four images.

• Crash occurs when you leave the file browsing dialog box open for a period of time.

Reason
The problem appears to be a conflict between Dreamweaver 8 and the Groove component of Microsoft Office 2007 on 
Microsoft Windows Vista. Microsoft Office Groove 2007 is only bundled with MS Office Ultimate 2007 and Microsoft 
Office Enterprise 2007.

Solution
Complete one or more of the following solutions:

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb400788
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=kb400789
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=8718ad77
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_15481
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=fb181c10
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=785362aa
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Solution 1: Upgrade to Dreamweaver CS4.
This issue has been resolved in Dreamweaver CS3. Upgrading to Dreamweave CS3 and above will resolve this issue. 
Please visit the Adobe Store for purchase information. For additional information on Vista support, see our PDF on 
How Adobe Products Support Vista.

Solution 2: Uninstall Microsoft Grove 2007.
Uninstalling Microsoft Grove 2007 will remove the feature from your system. If you require MS Grove 2007 please refer 
to another solution.

1 Choose Start > Control Panel.

2 Double-click Programs And Features and select Microsoft Office Ultimate 2007.Note: Choose Classic View in the 
left pane if Programs And Features is not available. 

3 Click Change.

4 Select Add Or Remove Features from the Office setup wizard.

5 Click the drop-down menu next to Microsoft Office Groove and select Not Available.

6 Follow the on screen prompts to uninstall Groove 2007.

Solution 3: Use the Open button instead of double-clicking folders and files while browsing.
Using the Open button instead of double-clicking the folders and files should prevent the issue from occurring. If your 
issue is not resolved please proceed to the next solution.

Solution 4: Manually enter the path into the dialog.
Type the file path manually into the dialog or copy and paste it from Windows Explorer address bar.

Solution 5: Create a new site definition from a new local root folder after rebooting.
1 Reboot the computer.

2 Create a new local root folder for the site.

3 Create a new site definition directing to the new local root folder.

Solution 6: Delete the _notes folder from the site.
1 Browse to the local root folder for the site using Windows Explorer.

2 Delete the _notes folder.

3 Choose Site > Advanced > recreate Site Cache from Dreamweaver.

Solution 7: Disable visual themes in Microsoft Windows Vista.
1 Browse to the Dreamweaver.exe executable in Windows Explorer. \Program Files\Macromedia\Dreamweaver 8\

2 Right-click Dreamweaver.exe and select Properties.

3 Select the Compatibility tab and check Disable Visual Themes.Note: All other checkboxes should be unchecked 

4 Click OK and see if the crashes stop.

http://www.adobe.com/products/dreamweaver/
https://www.adobe.com/support/products/pdfs/adobe_products_and_windows_vista.pdf
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Solution 8: Create a new local administrator account.
Please contact network administrators for assistance creating administrative accounts within a domain. If possible 
create a new local administrative account using the steps below. Microsoft Windows Vista Home users will need to 
create a new administrative account using the Users application within the Control Panel.

1 Right click My Computer and click Manage.

2 Expand Administrative Tools > Local Users and Groups > Users.

3 Right click Users and select New User.

4 In the New User dialog box, type Administrator in the Description field, complete the remaining fields.

5 Uncheck User Must Change Password At Next Login and check Password Never Expires, and then click Close.

6 Right-click the newly created user and select Properties.

7 Select the Member Of tab and click the Add button.

8 Type Administrators in the "Enter the object names to select" field, and click OK.

9 Click OK to close the User Properties window.

10 Log off of the current user and log into the newly created Administrator account.

Solution 9: Disable Windows Aero and run using the Windows Vista Basic color scheme.
Disable Aero to determine if it is causing the issue.

To disable Aero:

1 Choose Start > Control Panel.

2 Double-click Personalization and select Window Color And Appearance.Note: Choose Classic View in the left pane 
if Personalization is not available. 

3 Click Open Classic Appearance Properties For More Color Options.

4 Select Windows Vista Basic and click OK.

To re-enable Aero after testing:

1 Choose Start > Control Panel.

2 Double-click Personalization and select Window Color And Appearance.Note: Choose Classic View in the left pane 
if Personalization is not available. 

3 Choose Windows Aero from the Color Scheme menu and click OK.

Solution 10: Running Dreamweaver in Windows XP Compatibility mode.

1 Navigate to \Program Files\Macromedia\Dreamweaver 8\ in Windows Explorer

2 Right-click on the Dreamweaver.exe file and select Properties.

3 Click the Compatibility tab.

4 Click Run This Program In Compatibility Mode For: and select Windows XP (Service Pack 2) from the drop-down.

5 Select Run This Program As An Administrator.

Solution 11: Temporarily disable User Account Control (UAC).

The Vista User Account Control (UAC) feature can help prevent unauthorized changes to your computer. Microsoft 
recommends that you leave UAC turned on to help protect your computer. Re-enable UAC after testing.
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To disable UAC:

1 Choose Start > Control Panel.

2 Choose User Accounts.Note: Choose Classic View in the left pane if User Accounts is not available. 

3 Click Turn User Account Control On Or Off.

4 Deselect Use User Account Control (UAC) To Help Protect Your Computer and click OK.

5 Reboot the computer.

Additional Information
For information on other Vista related issues, see "Dreamweaver 8 issues on Windows Vista" (TechNote kb400787).

Please refer to How Adobe Products Support Vista for more information on Adobe product support for Vista,

Different redirect pages for each user level 
(Dreamweaver Developer Toolbox)

Issue
 When trying to access a page that is protected by the Restrict Access To Page server behavior for a particular level, I 
get redirected to the default login successful page, instead of the page I was trying to access. I thought that the page the 
user tried to access will be passed to the login page as an URL parameter. 

Reason
 In Adobe Dreamweaver Developer Toolbox, each user level has its own redirect pages defined in the Developer 
ToolboxControl Panel: a redirect page when the login is successful and one for failure. When a page that has the 
Restrict Access to Page server behavior applied for a certain user level is accessed by a user with a different access level, 
it will be taken to the login page, and if he logs in correctly, he will be redirected to its default login successful page. If 
the user has the correct access level, he will be redirected to the desired page. 

Solution
 Define the desired pages in the Developer Toolbox Control Panel for each user level used in the database. Also, when 
applying the Restrict Access to Page server behavior, specify the exact level that is allowed access. All other users that 
do not have the correct level, will not be able to access it, even if they log in correctly. Also, concerning the matter of 
the page on which access was attempted at first, it is not passed as an URL parameter, but as a session variable. After 
login, the redirect is done automatically to the desired page, if all data match (username, password and access level). 

Different date and time formats (Dreamweaver 
Developer Toolbox)

http://kb2.adobe.com/cps/400/kb400787.html
https://www.adobe.com/support/products/pdfs/adobe_products_and_windows_vista.pdf
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Issue
 The dates and times displayed throughout the Adobe Dreamweaver Developer Toolbox interfaces and applications 
use a different format than the one my database supports.

•  Products: Developer Toolbox 

• Operating System: All. 

• Server Models: All. 

• Dreamweaver version: CS3. 

Reason
 This happens because you use a screen format for date and time that is different from the database format. In Developer 
Toolbox Control Panel, two distinctive formats are used: 

• The screen format - this is the displayed / used format. 

• The database format - the format under which data is stored in the database tables. 

The screen and database formats can be different, because an automatic conversion is made, thus resulting in correctly 
stored information. 

Solution
 To define the screen and the database format, you have to access the Developer Toolobox Control Panel > Date formats. 

The screen format is used in all components of Developer Toolbox, ranging from dynamic drop-down to the date-
picker widget. 

Based on the defined format, when entering a date into a field that uses validation, or a Dynamic List filter field, the 
actual value is auto-completed based on the Control Panel specified format. 

The Date Picker calendar window does not show up 
(Dreamweaver Developer Toolbox)

Issue
 After enhancing a standard text field with the Date Picker widget, when I press the button in the browser the calendar 
window does not show up. On a simple page containing only the enhanced text field it works. 

Reason
 This happens because elements on the page containing the Date Picker enhanced text field use z-index as method of 
establishing element depth. The calendar window which is displayed when the button is pressed does not use z-index 
and therefore is not visible (it is positioned below the other page elements). 

http://www.interaktonline.com/Documentation/MXKollection/052110_Date_formats.htm
http://www.interaktonline.com/Documentation/MXKollection/04532a_Filter_dynamic_data.htm
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Solution
 In order to display the Date Picker interface, you have two options: 

1 Remove the z-index options in the page.

2 Set the z-index value for the layer containing the Date Picker to 0.

Customizing HTML code in Dreamweaver
 The SourceFormat.txt file in Dreamweavers Configuration folder can be used to customize some of the HTML 
formatting created by Dreamweaver. This changes how the HTML appears in the HTML Source window. 

Customizing the HTML code is done by one of two methods: 1) entering new information in the HTML Format dialog 
box in Dreamweaver, which updates the SourceFormat.txt file or 2) editing the SourceFormat.txt file itself. 

Method one: entering new information in the HTML Format dialog box To enter new information in the HTML 
Format dialog box, open Dreamweaver and choose Edit > Preferences > HTML Format. The HTML formatting items 
listed in the HTML Format dialog box are those items that can be changed inDreamweaver. 

The settings in the above HTML Format dialog box apply to the following section of the SourceFormat.txt file:

<!-- options     INDENTION      : indention options 
 

      ENABLE    - allows indention 
 

      INDENT    - columns per indention 
 

      TABS      - columns per tab character 
 

      USE       - TABS or SPACES for indention 
 

      ACTIVE    - active indention groups (IGROUP) 
 

 LINES          : end-of-line options 
 

      AUTOWRAP  - enable automatic line wrapping 
 

      BREAK     - CRLF, CR, LF 
 

      COLUMN    - auto wrap lines after column 
 

 OMIT           : element omission options 
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      OPTIONS   - options 

 
 ELEMENT        : element options 

 
      CASE      - "UPPER" or "lower" case 

 
      ALWAYS    - always use preferred element case (instead of 

 
                  original case) 

 
 ATTRIBUTE      : attribute options 

 
      CASE      - "UPPER" or "lower" case 

 
      ALWAYS    - always use preferred element case (instead of 

 
                  original case) 

 
 --><? options><indention enable indent="2" tabs="4" use="spaces" active="1,2,3"><

The SourceFormat.txt settings define the following HTML :

Method two: editing the SourceFormat.txt fileThe SourceFormat.txt file is found in the Configuration folder inside 
the Dreamweaver 3 program folder.

The following are some important considerations before editing the SourceFormat.txt file:

Understanding the Elements section of theSourceFormat.txt fileWhen editing the SourceFormat.txt file, it is 
important to understand that the Elements section is where the heart of formatting takes place. 

 Indentation defines the setting for indent and tab sizes and whether 
to use spaces or tabs or these parameters. 

Lines defines the autowrap, column length and break style. 

Omit has been reserved for future use. 

Element defines upper or lower case for the Element and "always" 
refers to when to use the custom case setting. 

Attribute defines upper or lower case for the Attribute and "always" 
refers to when to use the custom case setting. 

 Dreamweaver reads this document as it opens and updates it upon 
closing. Therefore, it is vital that you have the program closed before 
you do any editing of the SourceFormat.txt. 

If you do not see the changes reflected in the code, click Commands> 
Apply Source Formatting. 

It is a good idea to save a copy of the file before you edit it. 
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<!-- element information line breaks        : BREAK     = "before, inside start, inside                                  
end, after" 

 
 indent contents    : INDENT 

 
 indent group       : IGROUP    = "indention group number 

 
                                  (1 through 8) 

 
 specific name case : NAMECASE  = "CustomName" 

 
 prevent formatting : NOFORMAT        

Do Not Use--><?elements><address break="1,0,0,1"><applet break="0,1,1,0" indent><base break="1,0,0,

The key to understanding the formatting is in the line breaks line:

 : BREAK = " before, inside start, inside end, after" 

The line breaks defines where a break will be placed in relationship to a tag. 

When the Address line is edited to read <address break="1,0,0,1">, there will be one break before the opening address 
tag, no break inside of the address tag before the value, no break inside of the address tag after the value, and one break 
after the closing address tag. 

In the HTML Source window, it will look like this: 

<P>Previous sentence.</P><ADDRESS>Joe Macromedia</ADDRESS><P>Next sentence.</P>

 In the Document window, it will look like this: 

Previous sentence. 

Joe Macromedia 

Next sentence. 

When the Address line is edited to read <Address break="1,1,1,1">, there will be one break between the opening 
address tag and the value and one break between the the value and the ending address tag. 

In the HTML Source window, it will look like this: 

<P>Previous sentence.</P><ADDRESS>Joe Macromedia</ADDRESS><P>Next sentence.</P>

 Since altering the HTML source formatting only affects the HTML source code, the text in the Document window will 
appear the same as it did in the previous example. 

Note:Remember to select Commands > Apply Source Formatting when you reopen Dreamweaver! 

If we want to put a space between the surrounding tags and indent the value, the line will read:<Address break="2,1,1,2" 
indent> 

In the HTML Source window, it will look like this: 

<P>Previous sentence.<P><ADDRESS> 
 

Joe Macromedia 
 

</ADDRESS> 
 

<P>Next sentence.<P> 

Note:The value of this indent is set in the Option indentation line and can be modified from the Preferences menu. 
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Understanding the IGROUPSsection of theSourceFormat.txt file The IGROUP parameter is for enabling groups of 
tags to be defined by the Options settings.By default, IGROUP 1 groups Table rows and columns and IGROUP 2 groups 
Frames and Frameset tags. 

To enable an IGROUP, you would simply put its number in the "active=" parameter of the Indentation Option. (Notice 
that checking 'Table Rows and Columns' and 'Frames and Framesets' in the Preferences will add '1' and '2' respectively 
to the "active=" parameter.) 

You can easily create your own IGROUP. At the end of any tag definition, enter "indent" (this is necessary to enable the 
IGROUP settings) and then "IGROUP= #" (1-8). Then put that number in the "active=" parameter in the Options 
settings. 

To put the Address tag into its own IGROUP, the line would look like this: 

<Address break="2,1,1,2 indent igroup="3">

 In the Options indentation line, it would read 'active="1,2,3" ' 

Note:In order for the IGROUP to be active, the second break number, the "inside start" number, must be greater than 
'0'. IGROUPs will only indent if the value has its own line. 

Additional informationFor more information, read Editing the HTML source formatting profile in the Dreamweaver 
Help Pages. 

Create client-side dynamic dependent list boxes

Introduction

Client-side dynamic dependent list boxes allow a "child" list box to refresh when a selection is made in a "parent" list 
box, without having to return to the server. Most dynamic dependent list box models return to the server to requery 
the dependent list box's recordset. The model described in this TechNote passes dependent list box data to the browser 
in an array. It uses JavaScript to extract the appropriate values from the array and refresh the "child" list box in the 
client's browser.

The advantage to this approach is immediate page response; the user does not have to wait for the new page to be 
delivered from the remote server. The disadvantage is all the data for the dynamic dependent list box is sent to the client 
as text, thus increasing the size of the requested page. An evaluation must be made whether the increased page size 
warrants saving return trips to the server. If the amount of data required for the dynamic dependent list box is not 
significant, page size remains relatively small.

Multiple dynamic dependent list boxes can be added to a page. The extra steps to do this are documented at the end of 
this TechNote.

The model described here has a "parent" list box created normally in UltraDev. It can be either dynamic or static. The 
model also has a "child" dynamic dependent list box created in UltraDev as a normal List/Menu object. The "child" 
dynamic dependent list box is made dynamic on the client side with the addition of the code presented here.

Building the page

1 Add the "parent" list box to the page. Add either hard coded or dynamic Item Labels and Values to it.

Dreamweaver UltraDev is no longer supported, and the Dreamweaver UltraDev support center will no longer be actively updated. The 
functionality available in Dreamweaver UltraDev is available in Dreamweaver, beginning with Dreamweaver MX. Accordingly, we are moving 
pertinent content to the Dreamweaver support center. Please refer to the Dreamweaver version of this technote: Creating client-side dynamic 
dependent list boxes in ASP (TechNote 19117).

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_19117
http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_19117
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2 Add the "child" list box to the page. Do not add any Item Labels or Values to it.

3 Create a recordset for the child list box, which must include fields for its Item Labels, Values, and the relationship to 
the parent list box as explained in Relating the list boxes .

4 Copy the appropriate VBScript or JavaScript code and paste into the page's HTML code window just above the 
closing head tag.

5 Change the object names in the pasted code as explained in Object names .

6 Add the Call JavaScript behavior(s) as explained in Final changes .

7 Apply the code to view dynamic listboxes in Netscape 4 as explained in Netscape 4 Modification .

8 If errors occur when viewing the page, or the dependent list box does not function correctly, check Troubleshooting .

9 To add more than one dynamic dependent list box to a page, follow the instructions in Multiple dynamic dependent 
list boxes on one page .

Relating the list boxes

When defining the relationship between the parent and child list boxes, two rules apply.

• The Value of the parent list box is used to filter the data used to populate the child list box.

• A field in the child list box's recordset must correspond to the Value in the parent list box (the "relation").

The following example shows a parent list box populated with two Item Labels;Colors and Shapes;with their 
corresponding values. The child list box is populated in the client browser from a recordset with three fields. The 
Relation field identifies the relationship with the Value of the parent list box. The Item Label field will be displayed in 
the child list box. The Value field is returned to the server corresponding to the item label selected by the user.

Parent list box Child list box

Item Label

Relation

Item Label

Value

Value

Colors

ColorCode

Blue

1

ColorCode

 

ColorCode

Red

2

 

ColorCode

Green

3

http://helpx.adobe.com/dreamweaver/kb/#main_relating
http://helpx.adobe.com/dreamweaver/kb/#main_vbsource
http://helpx.adobe.com/dreamweaver/kb/#main_jssource
http://helpx.adobe.com/dreamweaver/kb/#main_objectnames
http://helpx.adobe.com/dreamweaver/kb/#main_finalchanges
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BACK TO Building the Page 

Object names

The code provided in this TechNote uses the following object names which must be renamed to the corresponding 
object names from your page.

Note: By naming your objects with the above names, only "Relation", "Label", and "Value" (and possibly form2) need 
to be changed in the provided code.

BACK TO Building the Page 

Client-side dynamic dependent list box code - VBScript

 

ColorCode

Yellow
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ShapeCode

Square

A

ShapeCode

 

ShapeCode

Circle

B

 

ShapeCode

Triangle

C

Parent list box Child list box

Colors Shapes Blue Red Green Yellow

selList1 Name of the parent list box, defined in UltraDev.

form1 Form name containing the selList1 object.

selList2 Name of the child list box populated by this code on the client side 
after making a selection in selList1.

form2 Form name containing the selList2 object (usually the same form 
selList1 uses).

rsList2 Recordset used to populate the child list box, selList2, from an array on 
the client side.

"Relation" Field name from rsList2 used to define the relationship with selList1.

"Label" Field name from rsList2 used to fill the Item Label column of selList2.

"Value" Field name from rsList2 used to fill the Value column of selList2.

http://helpx.adobe.com/dreamweaver/kb/#main_building
http://helpx.adobe.com/dreamweaver/kb/#main_building
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Client-side dynamic dependent list box code This code creates the array for the client side from the recordset rsList2. 
It also includes the functions called when the first list box is changed. setDynaList() controls the functions. 
clearDynaList() clears existing elements from selList2. populateDynaList() adds elements to selList2 based on the value 
selected in selList1.

The client-side dynamic dependent list box code is available for VBScript (this code) or JavaScript server-side scripting 
languages in ASP pages.

Code insertion location

Insert the code provided in the head section of the page, right above the closing head tag. Make sure the first two lines 
and last two lines are not contained within any other open and closed script tags, or a nesting error will occur.

Replace the eight object names in red with your object names. Make sure to leave the quotation marks in the code.

<!-- Dynamic Dependent List box Code for *** VBScript *** Server Model //--><script ><!-- var 
arrDynaList = new Array(); var arrDL1 = new Array(); arrDL1[1] = "selList1";               // 
Name of parent list box arrDL1[2] = "form1";                  // Name of form containing parent 
list box arrDL1[3] = "selList2";               // Name of child list box arrDL1[4] = "form2";                  
// Name of form containing child list box arrDL1[5] = arrDynaList;<% Dim txtDynaListRelation, 
txtDynaListLabel, txtDynaListValue, oDynaListRS txtDynaListRelation = "Relation"      ' Name 
of recordset field relating to parent txtDynaListLabel = "Label"            ' Name of recordset 
field for child Item Label txtDynaListValue = "Value"            ' Name of recordset field for 
child Value Set oDynaListRS = rsList2             ' Name of child list box recordset Dim 
varDynaList varDynaList = -1 Dim varMaxWidth varMaxWidth = "1" Dim varCheckGroup varCheckGroup 
= oDynaListRS.Fields.Item(txtDynaListRelation).Value Dim varCheckLength varCheckLength = 0 Dim 
varMaxLength varMaxLength = 0 While (NOT oDynaListRS.EOF) If (varCheckGroup <> 
oDynaListRS.Fields.Item(txtDynaListRelation).Value) Then If (varCheckLength > varMaxLength) 
Then varMaxLength = varCheckLength End If varCheckLength = 0 End If %> 
arrDynaList[<%=(varDynaList+1)%>] = 
"<%=(oDynaListRS.Fields.Item(txtDynaListRelation).Value)%>" 
arrDynaList[<%=(varDynaList+2)%>] = "<%=(oDynaListRS.Fields.Item(txtDynaListLabel).Value)%>" 
arrDynaList[<%=(varDynaList+3)%>] = 
"<%=(oDynaListRS.Fields.Item(txtDynaListValue).Value)%>"<% If 
(len(oDynaListRS.Fields.Item(txtDynaListLabel).Value) > len(varMaxWidth)) Then varMaxWidth = 
oDynaListRS.Fields.Item(txtDynaListLabel).Value End If varCheckLength = varCheckLength + 1 
varDynaList = varDynaList + 3 oDynaListRS.MoveNext() Wend If (varCheckLength > varMaxLength) 
Then varMaxLength = varCheckLength End If %> //--></script><!-- End of object/array 
definitions, beginning of generic functions --><script ><!-- function setDynaList(arrDL){ var 
oList1 = document.forms[arrDL[2]].elements[arrDL[1]]; var oList2 = 
document.forms[arrDL[4]].elements[arrDL[3]]; var arrList = arrDL[5]; clearDynaList(oList2); if 
(oList1.selectedIndex == -1){ oList1.selectedIndex = 0; } populateDynaList(oList2, 
oList1[oList1.selectedIndex].value, arrList); return true; } function clearDynaList(oList){ 
for (var i = oList.options.length; i >= 0; i--){ oList.options[i] = null; } oList.selectedIndex 
= -1; } function populateDynaList(oList, nIndex, aArray){ for (var i = 0; i < aArray.length; 
i= i + 3){ if (aArray[i] == nIndex){ oList.options[oList.options.length] = new Option(aArray[i 
+ 1], aArray[i + 2]); } } if (oList.options.length == 0){ oList.options[oList.options.length] 
= new Option("[none available]",0); } oList.selectedIndex = 0; } //--></script>

BACK TO Building the Page 

Client-side dynamic dependent list box code - JavaScript

http://helpx.adobe.com/dreamweaver/kb/#main_jssource
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Client-side dynamic dependent list box code This code creates the array for the client side from the recordset rsList2. 
It also includes the functions called when the first list box is changed. setDynaList() controls the functions. 
clearDynaList() clears existing elements from selList2. populateDynaList() adds elements to selList2 based on the value 
selected in selList1.

The client-side dynamic dependent list box code is available forVBScript or JavaScript (this code) server-side scripting 
languages in ASP pages.

Code insertion location

Insert the code provided in the head section of the page, right above the closing head tag. Make sure the first two lines 
and last two lines are not contained within any other open and closed script tags, or a nesting error will occur.

Replace the eight object names in red with your object names. Make sure to leave the quotation marks in the code.

<!-- Dynamic Dependent List box Code for *** JavaScript *** Server Model //--><script ><!-- 
var arrDynaList = new Array(); var arrDL1 = new Array(); arrDL1[1] = "selList1";               // 
Name of parent list box arrDL1[2] = "form1";                  // Name of form containing parent 
list box arrDL1[3] = "selList2";               // Name of child list box arrDL1[4] = "form2";                  
// Name of form containing child list box arrDL1[5] = arrDynaList;<% var txtDynaListRelation, 
txtDynaListLabel, txtDynaListValue, oDynaListRS; txtDynaListRelation = "Relation"      // Name 
of recordset field relating to parent txtDynaListLabel = "Label"            // Name of recordset 
field for child Item Label txtDynaListValue = "Value"            // Name of recordset field 
for child Value oDynaListRS = rsList2                 // Name of child list box recordset var 
varDynaList = -1; var varMaxWidth = "1"; var varCheckGroup = 
oDynaListRS.Fields.Item(txtDynaListRelation).Value; var varCheckLength = 0; var varMaxLength 
= 0; while (!oDynaListRS.EOF){ if (varCheckGroup != 
oDynaListRS.Fields.Item(txtDynaListRelation).Value) { varMaxLength = Math.max(varCheckLength, 
varMaxLength) varCheckLength = 0; } %> arrDynaList[<%=(varDynaList+1)%>] = 
"<%=(oDynaListRS.Fields.Item(txtDynaListRelation).Value)%>"; 
arrDynaList[<%=(varDynaList+2)%>] = "<%=(oDynaListRS.Fields.Item(txtDynaListLabel).Value)%>"; 
arrDynaList[<%=(varDynaList+3)%>] = 
"<%=(oDynaListRS.Fields.Item(txtDynaListValue).Value)%>";<% if 
(oDynaListRS.Fields.Item(txtDynaListLabel).Value.length > varMaxWidth.length) { varMaxWidth = 
oDynaListRS.Fields.Item(txtDynaListLabel).Value; } varCheckLength = varCheckLength + 1; 
varDynaList = varDynaList + 3; oDynaListRS.MoveNext(); } varMaxLength = 
Math.max(varCheckLength, varMaxLength) %> //--></script><!-- End of object/array definitions, 
beginning of generic functions --><script ><!-- function setDynaList(arrDL){ var oList1 = 
document.forms[arrDL[2]].elements[arrDL[1]] var oList2 = 
document.forms[arrDL[4]].elements[arrDL[3]] var arrList = arrDL[5] clearDynaList(oList2); if 
(oList1.selectedIndex == -1){ oList1.selectedIndex = 0; } populateDynaList(oList2, 
oList1[oList1.selectedIndex].value, arrList); return true; } function clearDynaList(oList){ 
for (var i = oList.options.length; i >= 0; i--){ oList.options[i] = null; } oList.selectedIndex 
= -1; } function populateDynaList(oList, nIndex, aArray){ for (var i = 0; i < aArray.length; 
i= i + 3){ if (aArray[i] == nIndex){ oList.options[oList.options.length] = new Option(aArray[i 
+ 1], aArray[i + 2]); } } if (oList.options.length == 0){ oList.options[oList.options.length] 
= new Option("[none available]",0); } oList.selectedIndex = 0; } //--></script>

BACK TO Building the Page 

Final changes

http://helpx.adobe.com/dreamweaver/kb/#main_vbsource
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After inserting the code into your page and renaming the objects to your object names, only one or two more changes 
are needed.

1 Select the selList1 list box object. From the Behaviors panel, add the Call JavaScript behavior. Enter 
setDynaList(arrDL1) (capitalization counts!) in the Call JavaScript dialog box. Make sure the action is added to the 
onChange event for the list box. This causes the child list box contents to update when a change is made in the parent 
list box.

2 Select the body tag in the lower left border of the page. From the Behavior inspector, add the Call JavaScript 
behavior. EntersetDynaList(arrDL1) (capitalization counts!) in the Call JavaScript dialog box. Make sure the action 
is added to the onLoad event. This step is optional. It will initialize selList2 when the page loads on the basis of the 
default value for selList1.

BACK TO Building the Page 

Netscape 4 Modification

An extra modification is needed for Netscape 4 browsers to properly view the dynamic listbox. If the dynamically 
populated listbox does not have any initial values, Netscape 4 will not resize the listbox to accommodate the 
dynamically populated contents. The listbox is essentially unusable. To remedy the situation, this modification will 
initially populate the listbox with the widest item label and the largest number of item labels from your child listbox 
recordset groups. As long as you call thesetDynaList function from the onLoad event, these initial values will not be 
displayed.

Note: The "largest number of item labels" means the number of items in the largest Relation group. In the above 
color/shape example, this value is 4, because there are four ColorCodes. To insure the correct maximum is calculated, 
the recordset must be sorted by Relation (you can add secondary sorts as well, for example by Label).

In the source code, the HTML for the child listbox will appear as follows (with your name if you used a different name):

<select name="selList2"></select>

Replace the code for the child listbox with the following if you are using the VBScript server model:

<select name="selList2"><% Dim varLoopCounter For varLoopCounter = 1 TO varMaxLength %><option 
value = "<%=varMaxWidth%>"><%=varMaxWidth%></option><% Next %></select>

Replace the code for the child listbox with the following if you are using the JavaScript server model:

<select name="selList2"><% for (varLoopCounter = 1; varLoopCounter <= varMaxLength; 
varLoopCounter++){ %><option value = "<%=varMaxWidth%>"><%=varMaxWidth%></option><% } 
%></select>

BACK TO Building the Page 

Troubleshooting

• Verify the object names have been changed correctly as explained in Object names . This is the most common 
problem encountered.

• Verify the "relation" field in the child list box recordset corresponds to the parent list box's Value as explained in 
Relating the list boxes .

• Verify the correct code has been inserted for your server-side scripting language, VBScript or JavaScript.

• Try rebuilding the page from scratch, or building a simple test page.

BACK TO Building the Page 

Multiple dynamic dependent list boxes on one page

http://helpx.adobe.com/dreamweaver/kb/#main_building
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The provided code can easily be enhanced to accommodate more than one dynamic dependent list box on a page. The 
functions are generic, so no modifications are needed for the functions section of code. Follow these steps to add 
another dynamic dependent list box.

1 Copy the top half of the code down to the following line:<!-- End of object/array definitions, beginning of generic 
functions -->

2 Paste the code segment into a text editor to perform the following modifications.

3 In the same manner as explained above for the first set of list boxes, rename the objects in the code to correspond 
to your object names.

4 Rename the following objects. As long as they do not conflict with other object names in the page, and changes are 
made consistently to all references in the code, the new names are not so important. Use a Find/Replace function to 
ensure all instances are changed correctly.

Note: For a third pair of dynamic dependent list boxes, use names such as "arrDynaList3", and so forth and so on.

5 Add new Call JavaScript behaviors to the new parent list box's onChange event and to the body's onLoad event. This 
time, use the new array name as the parameter in the function call. For example,setDynaList(arrDL2) . 

You may also want to add setDynaList(arrDL2) to the onChange event of another list box, if you now have a 
grandparent/parent/child relationship.

6 Check the source code of any multiple onLoad and onChange JavaScript calls. Starting with the top level list box and 
working down, make sure the functions execute in the proper order.<select 
onChange="setDynaList(arrDL1);setDynaList(arrDL2)" name="selList1">

Configuring WebDAV in IIS for use with Dreamweaver
 Original doc (PDF) 

There are different ways to set up Web-based Distributed Authoring and Versioning (WebDAV) for sharing files over 
the Internet. This TechNote describes one method that allows a website authoring team to modify live files on an IIS-
hosted website using WebDAV in Dreamweaver. To achieve this functionality, this method uses duplicate websites 
running on different ports in Microsoft's Internet Information Services (IIS) server, both pointing to the same set of 
files on the web server.

Prerequisites:

Original Name New Name

arrDynaList arrDynaList2

arrDL1 arrDL2

txtDynaListRelation txtDynaListRelation2

txtDynaListLabel txtDynaListLabel2

txtDynaListValue txtDynaListValue2

oDynaListRS oDynaListRS2

varDynaList varDynaList2

http://helpx.adobe.com/dreamweaver/kb//content/dam/kb/en/190/tn_19095/attachments/Configuring_WebDAV_in_IIS_for_use_with_Dreamweaver.pdf
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In order to get the most out of this TechNote, developers must have an understanding of IIS, and must know how to 
define a folder as a website in IIS. We recommend the IIS help files. This setup applies to IIS version 5 or higher, which 
includes support for WebDAV.Why configure duplicate websites running on different ports?

If you follow the steps in the IIS help documentation for "Creating a Publishing Directory" using WebDAV, you will 
create a physical directory on the server, link that physical directory to an IIS virtual directory, and grant limited access 
permissions (Read, Write, and Browsing) for the virtual directory. The IIS help documents also state that the WebDAV 
directories should have anonymous access turned off. The problem here is that only the authoring team (assuming they 
have the necessary Windows permissions) will be able to view the website. In other words, the Internet public will not 
be able to view the website, since anonymous access is turned off. A server administrator could transfer the files from 
the "locked down" WebDAV directory to an "open" public website directory, but that would introduce an additional 
administrative step into the website publishing process. Creating duplicate IIS websites running on different ports 
makes web publishing a one-step process in Dreamweaver.Defining and configuring two IIS website instances

For the configuration method explained in this TechNote, it is necessary to define two separate websites in IIS pointing 
to the same folder on the server (in this example,c:\inetpub\wwwroot). One website will handle normal Internet traffic 
(read-only), and the other website will be dedicated to handling WebDAV requests (read, write, file management, file 
locking, etc.).

Note: The instructions for configuring the websites in IIS are provided as a courtesy to customers, but Macromedia 
does not accept responsibility for ensuring such configurations function as expected. This is one of many possible 
configurations, and customers are encouraged to use any other configuration that works for them.Website 1: Setting up 
a website for normal browser (HTTP) requests.

1. Define a new website in IIS which uses port 80.

2. Use restricted permissions for the Home Directory. For example, allow "Read" access and set "Execute Permissions" 
to "Scripts Only".

3. Allow Anonymous access. Allowing Integrated Windows authentication is optional. See the IIS help files for more 
information on Integrated Windows authentication.

Website 2: Setting up a second IIS website devoted to handling WebDAV requests.

1. Define a second site in IIS, pointing to the same folder but using a port number other than 80. In this example, port 
81 is used.

2. Allow most or all permissions for the Home Directory and set "Execute Permissions" to "Scripts only".

3. Disable the ASP script server, the ColdFusion script server or other script server you may be using. You do this by 
clicking the "Configuration..." button in the screen shot above and removing the appropriate DLL. This will prevent IIS 
from sending the server-side script to the application server for processing. Someone editing a ColdFusion page would 
want to see the pre-processed ColdFusion code, not the resultant post-processed HTML code.

4. Because the WebDAV site is much more permissive, do not allow Anonymous access. Use Basic authentication.

Note: Basic authentication sends passwords over the network in an unencrypted form, however the Basic 
authentication checkbox must be checked in order for WebDAV to work in Dreamweaver. Microsoft Internet Explorer 
(version 2.0 and later) is the only WebDAV client that supports Integrated Windows authentication (user names and 
passwords are hashed before being sent across the network). WebDAV in Dreamweaver will continue to work if you 
check the "Integrated Windows authentication" checkbox in addition to Basic authentication. This setup would allow 
Dreamweaver connections to use Basic authentication and Internet Explorer connections to use Integrated Windows 
authentication. Microsoft recommends turning on Basic authentication only if you encrypt passwords through Secure 
Sockets Layer (SSL). Dreamweaver 8 now supports WebDAV over SSL.

Define the site in Dreamweaver
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1. In Dreamweaver, open the Site Definition dialog box and select the Remote Info category. Set the Access drop-down 
menu to WebDAV. In the WebDAV Connection dialog box, append port 81 to the server name in the URL. Enter the 
username and password that allows you to log into the WebDAV site using IIS Basic authentication.

2.

If you are using a testing server for this Dreamweaver site, set the Access for the testing server to WebDAV and fill out 
the WebDAV Connection dialog box the same as above.Important: Note that the last field of the Testing Server dialog 
box, URL Prefix, should be set to the regular URL (do not add port 81).

Note: WebDAV is only available as a Testing Server Access choice if the Remote Info category uses WebDAV as the 
access choice.

Note: Configuring an Apache web server site to handle both browser traffic and WebDAV requests also requires a setup 
procedure which is a bit more painstaking. For more information about this Apache-specific process, please review 
mod_dav Installation and Configuration at www.webdav.org.

Watch the demonstration below of the steps to configure WebDAV in IIS for use with Dreamweaver.

Additional Information

For more information on IIS and WebDAV, please refer to:

* IIS help documentation. If IIS is installed on your machine, you can access the help files at: http://localhost/iisHelp. * 
WWW authentication methods with Microsoft Internet Information Server (TechNote 19078) * www.webdav.org * 
Troubleshooting WebDAV Connections (TechNote 15167) * Check In/Check Out may not work properly on WebDAV 
(TechNote 15537)

Third party links

Although links to external websites are provided as a resource, the websites are not part of Macromedia. Please see 
Macromedia's policy regarding links to third party websites in the Legal Notices and Information section. Pages to 
external websites will open in a new browser window.

How to configure Dreamweaver to access a different FTP 
port
Port 21: the default setting Because most Web servers set aside Port 21 to receive connections from FTP clients, 
Dreamweaver is also configured to access Port 21 to upload files. 

Choosing another port for FTP access Sometimes, however, server administrators change the port setting of 21 to 
another port to prevent unauthorized FTP access. In those situations, Dreamweaver can be set to access a different port 
by adding the port number to the end of the FTP host name, as outlined below: 

Configuring Dreamweaver to access an FTP port other than Port 21

1 Dreamweaver 2, 3 or 4: In the Site or Document window, choose Site 
> Define Sites. 

Dreamweaver 1: In the Site window, click the Remote Site pop-up 
menu and select Edit Sites. Then go to step 4. 

2  Click Edit (or New for a new site). 
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Additional informationFor more information about setting up a remote site, see the Site Management and 
Collaboration chapter in the manual, Using Dreamweaver. For Dreamweaver 3, see the Site Management chapter. 

For more information about FTP issues, consult Setting up Dreamweaver's FTP connection (TechNote 14787). 

Compressed Flash MX SWF file properties are not 
recognized by Dreamweaver

Issue
Dreamweaver cannot determine URLs and movie properties such as size in SWF files published from Flash MX with 
"SWF Compression" turned on. As a result, movies default to a size of 32 x 32, and link management for URLs 
referenced in the movie is not available.

Note: This is no longer an issue in Dreamweaver MX. To download the trial of Dreamweaver MX, please see the 
Macromedia Dreamweaver MX product website.

Reason
 A new feature of Flash MX is the ability to compress SWF files. This option is turned on by default. However, when 
compressed SWF files are inserted into Dreamweaver, movie properties are not properly discovered and are 
inaccurately inserted into the HTML and reported in the Property Inspector. 

Solution
 Export SWF files from Flash MX without compression enabled. This option is available on the Flash tab of the Flash 
Publish settings dialog (File > Publish Settings) or in the Export Flash Player dialog box that appears when a movie is 
exported (File > Export Movie). 

Note: In Dreamweaver 4, users can see URLs referenced with a GoToURL action in a Flash movie by viewing the page 
containing the Flash movie in Site Map view. To see the URLs, do the following: 

1 Launch the Site Map view. 

• On Windows, choose Site > Site Map while in the Document Window, or Window > Site Map while in the Site 
Window. 

3  Select the Remote Info (Dreamweaver 4) or Web Server Info 
(Dreamweaver 3) from the Category list. 

4  Add a colon and the port number to the end of the FTP host name in 
the FTP Host text box. The FTP host name will appear similarly to the 
following examples: 

www.myhost.com:80 

123.456.789.012:80 

http://helpx.adobe.com/dreamweaver/kb//cfusion/knowledgebase/index.cfm?id=tn_14787
http://www.adobe.com/products/dreamweaver.html
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• On Macintosh, choose Window > Site Map while in either the Document Window or the Site Window. 

1 The Site Map can only be shown if there is a home page defined for the site. You will only see the file containing the 
Flash movie if it is linked to from the defined home page.

2 Make sure that you can view both dependent and hidden files. 

• On Windows, choose View > Show Files Marked as Hidden and View > Show Dependent Files while in the Site 
Window. A checkmark indicates these options have been set. 

• On Macintosh, choose Site > Site Map View > Show Files Marked as Hidden, and Site > Site Map View > Show 
Dependent Files while in the Site Window. A checkmark indicates these options have been set. 

Column cannot be null (Dreamweaver Developer 
Toolbox)

Issue
 When submitting data into a database table, through a form, I get an error message,saying " General (or SQL) error: 
Column 'name' cannot be null". 

For ASP_VBScript server model, the error is similar: 

Error.SQL error: [Microsoft][ODBC Microsoft Access Driver] The field 'company_com.name_com' cannot contain a 
Null value because the Required property for this field is set to True. Enter a value in this field.

• Operating System: All. 

• Server Models: All. 

• Dreamweaver version: CS3. 

Reason
 This usually happens because a form field is left empty. One of the table columns used in the insert operation does not 
allow NULL values, which causes the insert to fail. The table column does not allow null values based on settings from 
the database software. 

Solution
 There are several solutions to this issue: 

1 If the column specified in the error message is not that important and could contain NULL values, alter the table 
structure and the column properties to allow NULL values. Instructions on how to do it should be provided with 
your database management software.

2 Make sure to always enter a value in the corresponding form field or use Form Validation to check for a value before 
executing the SQL query.

3 Set a default value for the form field, either through the wizard (Insert Record Wizard, Update Record Wizard or the 
Dynamic Form Wizard) or by editing the corresponding server behavior.
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Changes to ASP Command Variables in Dreamweaver 
8.0.2
In the Dreamweaver 8.0.2 Updater, changes were made to the ASP code Dreamweaver generates, in order to prevent 
SQL injection attacks. One specific change that might be confusing are the changes to the ASP Command server 
behaviors. When you fill out the Command dialog box, Dreamweaver 8.0.2 now asks you to provide the Type and Size 
for the variables without any hinting or drop-down menus, so you have to know what to type in these text fields. Screen 
shots below show the difference between the dialog boxes in Dreamweaver 8.0.2 and Dreamweaver MX 2004 7.0.1. 
Notice the extra columns for Type and Size in the 8.0.2 Variables section.

Dreamweaver 8.0.2 ASP VBScript Insert Command

Dreamweaver MX 2004 7.0.1 ASP VBScript Insert Command

Why do you need to specify Type and Size now?

 To prevent SQL injection attacks, Dreamweaver changed from using a simple Insert SQL statement to using prepared 
statements. Prepared statements are more secure but they require more information, like Type and Size parameters. 

What do you enter in the Size field?

 To get the Size value, you can use the Databases panel in Dreamweaver. Find your database in the Databases panel and 
expand it. Then find the table you are working with and expand it. You should see the sizes listed for your fields. For 
example, it might say: ADDRESS (WChar 50). In this example, 50 is the size. You can also find the size in your database 
application. 

Note: Numeric, boolean and date/time data types always use -1 as the size, as shown in the table below. 

What do you enter in the Type field?

The table below shows the different Types that can be used. In the table, Access is Microsoft Access, and MS SQL stands 
for Microsoft SQL Server. 

Commands (Insert, Update, Delete)

 Value Constant Value in Dreamweaver Size Database data type 

5 adDouble Double -1 Numeric (Access, MS SQL, 
MySQL) 

5 adBoolean Double -1 Boolean, Yes/No (Access, 
MS SQL, MySQL) 

135 adDBTimeStamp DBTimeStamp -1 Date/Time (Access, SQL 
Server, MySQL) 
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In the Dreamweaver Command dialog box, you need to enter the word in the "Value in Dreamweaver" column above. 
Alternatively, you can type the numeric value in Code view. If you have a data type that is not covered in the table above, 
you can create a sample page using the Record Insertion Form Wizard or Record Update Form Wizard, and 
Dreamweaver will write the code for the Type and Size values for you, and you can then plug those values into the 
Command. Or, if you are inserting/updating a field that is not covered by the TechNote (e.g. from a different database 
like Oracle) you can look for the corresponding ADO datatype for that field (in the database reference manuals) and 
use that (ADO constant) in the Type column of the Variables grid of the Command.

Example using MS Access and an Insert Command

 The 8.0.2 screen shot above shows how to fill out the Command dialog box for an Insert command using Microsoft 
Access. This example uses the Comments table from the Cafe Townsend sample database that's included with 
Dreamweaver 8. This table has the following MS Access data types: 

• Comment_ID ; Data Type: AutoNumber; field size: Long Integer 

• Last Name ; Data Type: Text; Field Size: 50 

• Submit Date ; Data Type: Date/Time 

• Comments ; Data Type: Memo 

• Answered ; Data Type: Yes/No 

Here is the resulting code: 

201 adLongVarChar LongVarChar check Databases panel all other types of text 
fields, including the 
MySQL text data types 
char, varchar and longtext 

202 adVarWChar VarWChar check Databases panel Text (Access) or nvarchar, 
nchar (MS SQL) 

203 adLongVarWChar LongVarWChar 1073741823 Memo (Access) or ntext 
(MS SQL) or: these fields 
supports large amounts of 
text. 
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<% Set Command1 = Server.CreateObject ("ADODB.Command") Command1.ActiveConnection = 
MM_cafetownsend_STRING Command1.CommandText = "INSERT INTO COMMENTS (COMMENT_ID, LAST_NAME, 
SUBMIT_DATE, COMMENTS, ANSWERED)   

 
VALUES (?, ?, ?, ?, ?) " Command1.Parameters.Append Command1.CreateParameter("varCommentID", 
5, 1, -1, MM_IIF 

 
(Request.QueryString("txtCommentID"), Request.QueryString("txtCommentID"), 
Command1__varCommentID &amp; "")) Command1.Parameters.Append 
Command1.CreateParameter("varLastName", 202, 1, 50, MM_IIF 

 
(Request.QueryString("txtLastName"), Request.QueryString("txtLastName"), 
Command1__varLastName &amp; "")) Command1.Parameters.Append 
Command1.CreateParameter("varSubmitDate", 135, 1, -1, MM_IIF 

 
(Request.QueryString("txtSubmitDate"), Request.QueryString("txtSubmitDate"), 
Command1__varSubmitDate &amp; "")) Command1.Parameters.Append 
Command1.CreateParameter("varComments", 203, 1, 1073741823, MM_IIF 

 
(Request.QueryString("txtComments"), Request.QueryString("txtComments"), 
Command1__varComments &amp; "")) Command1.Parameters.Append 
Command1.CreateParameter("varAnswered", 5, 1, -1, MM_IIF 

 
(Request.QueryString("cbxAnswered"), Request.QueryString("cbxAnswered"), Command1

Example using Microsoft SQL Server and an Insert Command

 The 8.0.2 screen shot below shows how to fill out the Command dialog box for an Insert command using Microsoft 
SQL Server. This example uses the Employees table from the Northwind sample database that's included with SQL 
Server. This table has the following SQL Server data types: 

• LastName ; Data Type: nvarchar; size: 20 

• FirstName ; Data Type: nvarchar; size: 10 

• BirthDate ; Data Type: datetime 

• Notes ; Data Type: ntext; size: 16 

• ReportsTo ; Data Type: int; size: 4 

Here is the resulting code: 
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<% Set Command1 = Server.CreateObject ("ADODB.Command") Command1.ActiveConnection = 
MM_sqlServ_ts2000adv_northwind_STRING Command1.CommandText = "INSERT INTO dbo.Employees 
(LastName, FirstName, BirthDate, Notes, ReportsTo)   

 
VALUES (?, ?, ?, ?, ?) " Command1.Parameters.Append Command1.CreateParameter("varLastName", 
202, 1, 20, MM_IIF 

 
(Request.QueryString("txtLastName"), Request.QueryString("txtLastName"), 
Command1__varLastName &amp; "")) Command1.Parameters.Append 
Command1.CreateParameter("varFirstName", 202, 1, 10, MM_IIF 

 
(Request.QueryString("txtFirstName"), Request.QueryString("txtFirstName"), 
Command1__varFirstName &amp; "")) Command1.Parameters.Append 
Command1.CreateParameter("varBirthDate", 135, 1, -1, MM_IIF 

 
(Request.QueryString("txtBirthDate"), Request.QueryString("txtBirthDate"), 
Command1__varBirthDate &amp; "")) Command1.Parameters.Append 
Command1.CreateParameter("varNotes", 203, 1, 1073741823, MM_IIF 

 
(Request.QueryString("txtNotes"), Request.QueryString("txtNotes"), Command1__varNotes &amp; 
"")) Command1.Parameters.Append Command1.CreateParameter("varReportsTo", 5, 1, -1, MM_IIF 

 
(Request.QueryString("txtReportsTo"), Request.QueryString("txtReportsTo"), Command1

Additional Information

For more informationabout the changes in Dreamweaver 8.0.2, see Protecting ASP VBScript server behaviors from 
SQL injection vulnerability (TechNote 57ae79b2).

For more information on Types, see MSDN ADO 2.8 API Reference ADO Enumerated Constants - DataTypeEnum 
and http://www.carlprothman.net/Default.aspx?tabid=97.

Change, add recognized file extensions | Dreamweaver
Introduction

This TechNote applies to the following related symptoms in Adobe Dreamweaver:

• When opening a file, you see this error message: "Can't find a valid editor for this file extension."

• The color-coding in Code view isn't matching the color-coding for the file type you want.

• The server-model functionality isn't available for your file type.

• You cannot open a page in Design view. It only opens in Code view.

• When you go to File > Save, or File > Open, you don't see the file type you want.

Dreamweaver ships with the ability to edit and display many different file types. This TechNote focuses on customizing 
Dreamweaver to recognize new file types by editing the Extensions.txt and MMDocumentTypes.xml files, and setting 
the Open In Code View settings to see the new file types in Design view.

• The Extensions.txt fileThe Extensions.txt file is a text file listing all file types recognized by Dreamweaver. This file 
can be edited in any external text editor like Notepad or Text Editor to add to the list of recognized file types. Do not 
modify the Dreamweaver configuration files in Dreamweaver itself.

http://www.carlprothman.net/Default.aspx?tabid=97
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• The MMDocumentTypes.xml file The MMDocumentTypes.xml file contains definitions of document types as 
well as a list of file extensions associated with each recognized document type. Adding file extensions to the 
Extensions.txt file allows Dreamweaver merely to recognize a file extension and allow files of this type to be opened 
in Dreamweaver. Adding file extensions to the MMDocumentTypes.xml file tells Dreamweaver how to treat this 
new file extension and to which document type this file extension belongs. 

Note: For the purpose of this TechNote, only basic aspects of editing the MMDocumentTypes.xml file will be 
discussed. For a detailed overview of editing this file, see Extending Dreamweaver (from within Dreamweaver, 
choose Help > Extending Dreamweaver, and search on MMDocumentTypes.xml).

• Open in Code View The Open in Code View preference identifies file extensions that do not allow Design view. 
After following the instructions in this TechNote, be sure to remove the file extension (if it is listed) from the Open 
In Code View preference to allow file editing in Design view. To set this preference, choose Edit > Preferences 
(Windows) or Dreamweaver > Preferences (Mac OS), and locate the File Types / Editors category.

Editing the Extensions.txt file

When opening a file that Dreamweaver doesn't recognize, you see this error message: "Can't find a valid editor for this 
file extension." New extensions can be added to the list of extensions that Dreamweaver recognizes. To add new 
extensions, edit the Extensions.txt file. Entries in the Extensions.txt file also control the order in which files are listed 
in the File > Open and File > Save dialog boxes. For the purpose of demonstration, we will add the .inc file type to 
Dreamweaver.

Note: This procedure requires you to locate hidden files, hidden folders and extensions for known file types. By default, 
Windows Explorer doesn't show hidden files, hidden folders, and file name extensions that it recognizes.

To show hidden files, hidden folders, and extensions for known file types:

1 In Windows Explorer, do one of the following: 

• In Windows XP, choose Tools > Folder Options.

• In Windows Vista, choose Organize > Folder and Search Options.

2 Click the View tab in the Folder Options dialog box.

3 In Advanced Settings, select Show Hidden Files And Folders.

4 Deselect Hide Extensions For Known File Types.

5 Click OK.

To add file types to the Extensions.txt file:

1 Locate the Extensions.txt file within the Dreamweaver user configuration folder. The location of this folder depends 
on the operating system and the version of Dreamweaver:

• Dreamweaver CS3 on Windows Vista: C:\Users\[username]\AppData\Roaming\Adobe\Dreamweaver 
9\Configuration

• Dreamweaver 8 on Windows Vista: C:\Users\[username]\AppData\Roaming\Macromedia\Dreamweaver 
8\Configuration

• Dreamweaver CS3 on Windows XP: C:\Documents and Settings\[username]\Application 
Data\Adobe\Dreamweaver 9\Configuration

• Dreamweaver 8 on Windows XP & 2000: C:\Documents and Settings\[username]\Application 
Data\Macromedia\Dreamweaver 8\Configuration

• Dreamweaver CS3 on Mac OS X: Mac HD:Users:[username]:Library:Application 
Support:Adobe:Dreamweaver 9:Configuration
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• Dreamweaver 8 on Mac OS X: Mac HD:Users:[username]:Library:Application 
Support:Macromedia:Dreamweaver 8:Configuration

Note: Edits to this file will only be available to the current user. Changes made to files within the user profile will 
not be available to other users. For more information about manually editing Dreamweaver configuration files in a 
multi-user environment, please see Customizing Dreamweaver.

2 Open Extensions.txt in any external text editor like Notepad or Text Editor. Do not modify the Dreamweaver 
configuration files in Dreamweaver itself.

3 Add the extension to the All Documents line. Extensions must be in uppercase letters and separated by commas. 
(INC should already be listed by default. If not, add it.) 

Example: HTML,HTM,SHTM,SHTML,INC

4 To add extensions to an existing document group, add the extension to the extension list for the desired group. To 
add a new document group, add a new line that contains the new document type as well as a listing of associated 
extensions. 

Example: INC:Include Files

(This can also be added to the Server Side Include list already within the file.)

5 Save the file and restart Dreamweaver.

6 To see the changes, open Dreamweaver and open a file with the newly added file extension. It should now open in 
Code view only in Dreamweaver. Select File > Save As, and click the Save As Type pop-up menu. You should now 
see an option for Include Files with *.inc as the recognized file extension. It's the same for the Files Of Type pop-up 
menu in File > Open.

Note: The order in which extensions are listed is the order in which they will appear in the File > Open and File > Save 
dialog boxes.

To get Design view, color coding, and server behavior functionality (if applicable) working, you need to edit the 
MMDocumentTypes.xml file, as described below.

The MMDocumentTypes.xml file

Where the Extensions.txt file contains the list of extensions recognized by Dreamweaver, the MMDocumentTypes.xml 
file contains information about the server model, color coding style, descriptions, and so forth for each known 
document type.

In addition to adding extensions to the Extension.txt file, new extensions must also be added to the file extension lists 
for the associated document type. If not, Dreamweaver will not know how to display this file type and will open it in 
Code view by default. If this extension is not associated with any defined document type, a new document type should 
be created. To create a new document type, see Extending Dreamweaver (from within Dreamweaver, choose Help > 
Extending Dreamweaver, and search on MMDocumentTypes.xml).

Note: For the purpose of this TechNote, 'document type definition' refers to files that contain information about 
documents recognized by Dreamweaver and are not to be confused by 'DTDs' mentioned in XML documentation.

Steps to add extensions to a document type definition in the MMDocumentTypes.xml file:

1 Locate the MMDocumentTypes.xml file in the main Dreamweaver configuration folder (not the Dreamweaver user 
configuration folder). The location of this folder depends on the operating system and the version of Dreamweaver: 

• Dreamweaver CS3 on Windows Vista & XP: C:\Program Files\Adobe\Adobe Dreamweaver 
CS3\Configuration\DocumentTypes

• Dreamweaver 8 on Windows Vista, XP & 2000: C:\Program Files\Macromedia\Dreamweaver 
8\Configuration\DocumentTypes

https://www.adobe.com/support/dreamweaver/custom/customizing_dwmx/
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• Dreamweaver CS3 on Mac OS X: Mac HD:Applications:Adobe Dreamweaver CS3:Configuration:Document 
Types

• Dreamweaver 8 on Mac OS X: Mac HD:Applications:Macromedia Dreamweaver 8:Configuration:Document 
Types

2 Open MMDocumentTypes.xml in any external text editor like Notepad or Text Editor. Do not modify the 
Dreamweaver configuration files in Dreamweaver itself.

3 Find the tag set for the desired document type. Below is the default document type definition for HTML documents 
from the MMDocumentTypes.xml file:<documenttype id="HTML" internaltype="HTML" 
winfileextension="html,htm,shtml,shtm,stm,tpl,lasso,xhtml" 
macfileextension="html,htm,shtml,shtm,tpl,lasso,xhtml,ssi" writebyteordermark="false">

4 Add the desired extension to the winfileextension and macfileextension attributes of the documenttype tag. For 
example:winfileextension="html,htm,shtml,shtm,stm,tpl,lasso,xhtml,inc"

The code above adds the INC file extension to the list of files that Dreamweaver treats as HTML files. Adding 
extensions to the Mac OS and Windows lists for this file types allows Dreamweaver to open this file type in Design 
view as other files with defined HTML file extensions.

5 Save MMDocumentTypes.xml and restart Dreamweaver.

6 To see the changes, open Dreamweaver and open a file that has the newly added file extension. You should see that 
Design view, code coloring and server behavior functionality (if applicable) are working now.

Note: The order in which extensions are listed is important. The first extension in the extensions lists will be the default 
extension used for this file type.

Note: If you made a backup of the MMDocumentTypes.xml and left it in the Configuration/DocumentTypes folder, 
you will see multiple warning messages pop up when you launch Dreamweaver that look like this:

'The Document Type "HTML" will not be added because it uses a file extension that is already associated with a prior 
Document Type.'

To stop these warning messages, move your backup copy of the MMDocumentTypes.xml file outside the 
Configuration/DocumentTypes folder. For example, move it to the desktop. You will also get this error message if you 
have the same file type listed more than once in the MMDocumentTypes.xml.

Edit in Code View preference

The final step is to check the File Types / Editors preference settings (Edit > Preferences) and make sure that this file 
extension is not listed in the Open In Code View field. By default, the INC file extension appears on this list. Remove 
".inc" from the Open in Code View list and files with this extension should now be viewable in Design view.

Additional Information
For more information on modifying file types in Dreamweaver, see the following sections of the Extending 
Dreamweaver help system:

• Document extensions and file types

• Changing the default file type

• Document type definition file

http://livedocs.adobe.com/en_US/Dreamweaver/9.0_Extending/help.html?content=dwr_customizing_cu_22.html
http://livedocs.adobe.com/en_US/Dreamweaver/9.0_Extending/help.html?content=dwr_customizing_cu_06.html
http://livedocs.adobe.com/en_US/Dreamweaver/9.0_Extending/help.html?content=dwr_customizing_cu_19.html
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The captcha image is not generated on the page 
(Dreamweaver Developer Toolbox)

Issue
 When previewing a page with the Capthca wizard applied, instead of the image I get an error message: 

Cannot write in captcha folder 

Reason
 This happens because the temporary folder where the captcha images are stored until display does not allow the user 
running the web server to write files to 

Solution
 To solve this problem you mustgrantwritepermissionstothe user as which the web server is running for the 
<site_root>\common\lib\captcha\temp folder. This will allow the creation and storage of the temporary captcha 
images. 

Can''t install Dreamweaver 8.0.2 Updater | InstallShield 
wizard interrupted

Issue
Installing the Dreamweaver 8.0.2 Updater fails on certain Windows systems. The 8.0.2 Updater installer starts, but then 
stops with the following InstallShield wizard error message:

"The wizard was interrupted before Macromedia Dreamweaver 8.0.2 Updater could be completely installed. Your 
system has not been modified. To complete installation at another time, please run setup again."

Then a second error message sometimes appears:

"The exception unknown software exception (0xc0000005) occurred in the application at location 0x009441902. Click 
on OK to terminate the program Click on CANCEL to debug the program."

Note: It's possible that you don't get the error messages above when installing the Dreamweaver 8.0.2 Updater. 
However, if after updating, the Dreamweaver version still says 8.0 or 8.0.1, you could have previously canceled an 
updater installer. To resolve this issue, uninstall and then reinstall Dreamweaver 8 or Studio 8. (Ref. 211853)

Solution
There is an InstallShield .exe wrapper around the actual Dreamweaver 8.0.2 Updater installer which is an MSP file. If 
you have trouble with the standard Dreamweaver 8.0.2 Updater installer and its InstallShield wrapper, download the 
unwrapped MSP file for Dreamweaver 8.0.2 and run that. Once you download the MSP file to your hard drive, double-
click it and see if Dreamweaver 8.0.2 installs successfully.

http://www.adobe.com/support/dreamweaver/ts/documents/kb400150/DW802_unwrapped.zip
http://www.adobe.com/support/dreamweaver/ts/documents/kb400150/DW802_unwrapped.zip
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Note: After you install the Dreamweaver 8.0.2 Updater, verify that the updater successfully installed. Some users think 
they have installed 8.0.2, when in fact the updater installation didn't take. In Dreamweaver, go to Help > About 
Dreamweaver > and click the scrolling text to reveal the version number. It should say Dreamweaver 8.0.2. If it still says 
Dreamweaver 8.0 or 8.0.1, uninstall and then reinstall Dreamweaver 8 or Studio 8 to resolve the issue.

Additional information
Some Windows systems have a conflict with the InstallShield install wizard in Dreamweaver 8.0.2.

 

Cannot create queries using Query Builder 
(Dreamweaver Developer Toolbox)

Issue
 When I try to create my first query with Query Builder I get an error message: There have been some problems 
connection to your database. [...] Please see the manual for possible reasons and solutions.

Reason
 This error occurs because one of the following: 

1 The database connection does not exist, or an error occurred connecting to the database.

2 The user which connects to the database does not have permissions to create new tables.

3 The user which connects to the database does not have permissions to insert data into a table.

4 You have a ColdFusion data source configured to use a MySQL database through a JDBC connector. The connector 
version is 3.0.6 or higher. Starting with the 3.0.6 version the connector no longer allows creating tables or altering 
their contents.

Solution
 To solve this problem, try one of the following: 

• First make sure that the database connection exists and the web server can actually connect to the database. 

• Check that the user name used in the database connection has permissions to create tables and insert data into them. 
If it does not have them, consult your database server documentation to find out how to grant these permissions. 

• If in case four, you must use a different type of connection, or a JDBC prior to version 3.0.6. 

Assigning behaviors to an image map
 In Dreamweaver 3, assigning a behavior to an image map is straightforward: select the appropriate hotspot and assign 
a new behavior with the plus key of the Behaviors inspector. 
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However, in Dreamweaver 2, the procedure requires using a dummy image to generate the JavaScript and editing the 
HTML source to reassign the code. The instructions below outline this procedure step by step. Once again, this only 
applies to Dreamweaver 2. 

To edit the HTML source code in Dreamweaver 2, do the following:

1 Insert an image in the Document window. This image will serve as a dummy in the document and will be deleted 
after completion of the task.

2 Assign a null link to the image by selecting it and entering a pound (#) sign into the Link field of the Property 
inspector.

3 Select the anchor tag of this dummy image and assign the desired behavior to it. (A quick way to select the anchor 
tag of an image is to select the image then click the <a> tag displayed in the bottom left corner of the Document 
window.)

4 With the anchor tag of the dummy image selected, open the HTML inspector (F10).

5 Find the behavorial JavaScript within the highlighted HTML. The code below is an example of the JavaScript section 
in a sample document.

<a href="#" > 
 

<img href="/support/dreamweaver/ts/documents/assets/Creation.JPG"     name="creation

6 Copy the JavaScript that represents the mouse events. In this example, copy the red color code. This Javascript 
activates the Swap Image behavior using the onMouseOver event.

7 Locate the map tag in the HTML source code that is referenced by the "usemap" attribute of the final destination 
image. You can find the "usemap" attribute within the destination image tag.

<img href="/support/dreamweaver/ts/documents/assets/myImage.JPG"   
 

   ></img> 

8 Paste the code inside the area tag for this image map.

<map name="myName"><area shape="rect" coords="5,4,153,43" href="#"        tar ></map> 

9 Delete the dummy image created in step 1.

Active content not displayed in browser after converting 
page in Dreamweaver 8.0.2

Issue
In Dreamweaver 8.0.2, after creating a new page with active content (for example, Flash Player content) or after 
converting an existing page with active content, the active content does not display when the page is uploaded to the 
server and viewed in a web browser. This problem is page-specific (browse to the sample "fixed" page on the Developer 
Center and verify that it works as expected, with no gray border around the Flash movie).

(Ref. 20777)
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Reason
The most likely reason the active content isn't being displayed is because the Scripts folder (and the JavaScript files 
inside) automatically created at the root level of your site by Dreamweaver 8.0.2 hasn't been uploaded to the server. For 
more information on the Scripts folder and the accompanying JavaScript files, see Converting Active Content with the 
Dreamweaver 8.0.2 Updater (TechNote 2f98fbe7).

Solution
Upload the Scripts folder to the server, as described in both the Dreamweaver help system and in Converting Active 
Content with the Dreamweaver 8.0.2 Updater (TechNote 2f98fbe7):

"Dreamweaver creates this external file (AC_RunActiveContent.js), and places it in a new folder (called Scripts, placed 
at the root of your site) when you save the updated file. It is extremely important that you upload the 
AC_RunActiveContent.js file when you upload the updated page, either manually or by clicking Yes in the Dependent 
Files dialog box."

Additional Information
Other causes have similar symptoms. If this TechNote does not resolve your issue, check the following TechNotes:

• Active content JavaScript file not created for existing files that already have active content reference (TechNote 
35ae3721)

• Adobe active content JavaScript fix fails in some installations of Internet Explorer (TechNote 4f91f9b8)
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