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Legal notices

Legal notices
For legal notices, see http://help.adobe.com/en_US/legalnotices/index.html.

A note to our customers
Adobe provides this searchable PDF of archived technical support documents as a service to our 
customers who own and continue to enjoy older, unsupported versions of our software products. The 
information in these documents is not updated, and will become increasingly less accurate as 
hardware, browsers, and operating systems continue to evolve. Please be aware that these archived 
documents reflect historical issues and solutions for products that are no longer supported. Adobe 
does not warrant that the information in this document is accurate.
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Change default font | Illustrator CS2, CS3, CS4
The default font in Adobe Illustrator is Myriad Pro for CS3, CS4 and Myriad for CS2. The default font is selected in the 
Font menu, Character palette, and as the Normal Character Style in the Character Styles palette. The default font is 
selected even if the document you open doesn't contain that font or if you last used another font before quitting 
Illustrator. You can change the default font in Illustrator CS3 and CS4 by editing the default template files, or in CS2 by 
editing the Startup Files.

To change the default font in Illustrator, you must create a custom startup file by editing the Normal Character Style in 
the Illustrator startup files for CS2, or the default template files in CS3 or in CS4.

To change the default font for Illustrator CS3

1 Choose File > Open and go to Documents and Settings/User/Application Data/Adobe/Adobe Illustrator CS3 
Settings/New Document Profiles (Windows) or to Users/User/Library/Application Support/Adobe/Adobe 
Illustrator CS3/New Document Profiles (Mac OS).

2 Open one of the default document profile template files (Basic CMYK, Basic RGB, Mobile and Devices, Print, Video 
and Film, or Web, depending on which type of document you intend to use).

3 Choose Window > Type > Character Styles.

4 Select the Normal Character Style and choose Character Style Options from the palette menu.

5 Select Basic Character Formats and choose the desired font from the Font Family menu.

6 Click OK, and then choose File > Save and close the file.

7 Choose File > New and select the desired default document profile.

To change the default font for Illustrator CS4

1 Choose File > Open and go to Documents and Settings/User/Application Data/Adobe/Adobe Illustrator CS4 
Settings/New Document Profiles (Windows) or to Users/User/Library/Application Support/Adobe/Adobe 
Illustrator CS4/New Document Profiles (Mac OS).

2 Open one of the default document profile template files (Basic CMYK, Basic RGB, Mobile and Devices, Print, Video 
and Film, or Web, depending on which type of document you intend to use).

3 Choose Window > Type > Character Styles.

4 Select the Normal Character Style and choose Character Style Options from the palette menu.

5 Select Basic Character Formats and choose the desired font from the Font Family menu.

6 Click OK, and then choose File > Save and close the file.

7 Choose File > New and select the desired default document profile.

To change the default font for Illustrator CS2

1 Quit Illustrator.
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2 In the Adobe Illustrator CS2 Plug-ins folder, copy the current default startup file--Adobe Illustrator Startup_CMYK 
or Adobe Illustrator Startup_RGB--and save it with a different name. (This creates a copy of the original startup file 
in case you need it again.)

3 Open one of the default startup files (Adobe Illustrator Startup_CMYK or Adobe Illustrator Startup_RGB, 
depending on which type of document you intend to use).

4 Choose Window > Type > Character Styles.

5 Select the Normal Character Style and choose Character Style Options from the palette menu.

6 Select Basic Character Formats and choose the desired font from the Font Family menu.

7 Click OK, and save the new file as Adobe Illustrator Startup _CMYK or Adobe Illustrator Startup_RGB in the Plug-
ins folder.

8 Restart Illustrator.

 

Create a Custom New Document Profile (Illustrator CS3)
To create a custom New Document Profile

 To create a custom document profile in Illustrator CS3: 

1 Open the New Document Profile file you want to customize in the New Document Profiles folder located in the 
below directories. 

• Windows: Documents and Settings\(User)\Application Data\Adobe\Adobe Illustrator CS3 Settings. 

• Mac OS: Users\(User)\Library\Application Support\Adobe\Adobe Illustrator CS3 

2 Delete any existing swatches, graphic styles, brushes, or symbols you dont want to retain.

3 Do any of the following: 

• Create any colors, patterns, and gradients you want, and save them as swatches. You can also import swatches 
using the Swatch Libraries command and then move the swatches you want in the Document Profile file into the 
default Swatches panel. 

• Save any graph designs that you want available in your files using the Graph Design dialog box.

• Create any graphic styles you want and save them to the Graphic Styles panel. 

• Create any brushes you want and save them to the Brushes panel. 

• Create any symbols you want and save them to the Symbols panel. 

• Select the options you want as default settings from the following: View preferences (from the View menu), ruler 
origins, page origins, print settings (in the Print dialog box, File > Print), and actions. 

4 Save the Document Profile file and restart Illustrator.

Create mutli-page PDF | Illustrator
Adobe Illustrator CS2 and CS3 allows you to create multiple-page PDF files directly from the application using the 
Create Multi-Page PDF From Page Tiles option in the PDF Save dialog box when you save the file from Illustrator with 
tiled pages.
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If you save Adobe Illustrator CS artwork with multiple-page tiles as an Adobe PDF file, the resulting PDF file contains 
one page, rather than individual pages for each tile. You can, however, convert Illustrator CS artwork with multiple-
page tiles to a multiple-page PDF file by printing the file to PostScript, and then converting the PostScript file to PDF 
in Adobe Acrobat Distiller. To complete this process, you must have Illustrator CS, the Adobe PostScript Printer Driver, 
and Acrobat Distiller 5.x or later installed on your system. You can download the Adobe PostScript Printer Driver from 
the Adobe website at www.adobe.com/support/downloads/.

To create multiple-page PDF files from an Illustrator file with multiple-page tiles:

In Illustrator CS2, CS3:

1 In Illustrator, create a new document or open an existing Illustrator file with multiple-page tiles. 

• If you create a new document, specify a custom width and height large enough for all the pages in the PDF file 
in the New Document dialog box. For example, to create a four-page 8.5" x 11" document, enter 34 inches for 
Width and 11 inches for Height.

• If you use an existing file with multiple-page tiles, proceed to step 8.

2 Choose View > Show Page Tiling.

3 Choose File > Print.

4 In the Media section of the Print dialog box, select the orientation and the page size of the individual pages. For 
example, click Portrait Up in the Orientation section, and choose US Letter from the Size menu.

5 Click Setup, and then choose Tile Full Pages from the Tiling menu.

6 Click Done to close the Print dialog box. Illustrator numbers the pages from left to right and from top to bottom, 
starting with page 1. These page numbers appear on-screen for reference only.Note: If the tiles aren't properly 
aligned on the artboard, either double-click the Page tool to snap the tiles to the upper left corner of the artboard, 
or use the Page tool to move the pages manually. 

7 Create or import artwork into the document.

8 Choose File > Save.

9 Select Adobe PDF from the Save as type pull down menu.

10 Select the Create Multi-page PDF from Page Tiles option in the General section.

11 Click Save PDF.

In Illustrator CS:

1 In Illustrator, create a new document or open an existing Illustrator file with multiple-page tiles. 

• If you create a new document, specify a custom width and height large enough for all the pages in the PDF file 
in the New Document dialog box. For example, to create a four-page 8.5" x 11" document, enter 34 inches for 
Width and 11 inches for Height.

• If you use an existing file with multiple-page tiles, proceed to step 8.

2 Choose View > Show Page Tiling.

3 Choose File > Print.

4 In the Media section of the Print dialog box, select the orientation and the page size of the individual pages. For 
example, click Portrait Up in the Orientation section, and choose US Letter from the Size menu.

5 Click Setup, and then choose Tile Full Pages from the Tiling menu.

http://www.adobe.com/support/downloads/


4

Last updated 11/12/2015

6 Click Done to close the Print dialog box. Illustrator numbers the pages from left to right and from top to bottom, 
starting with page 1. These page numbers appear on-screen for reference only; they don't print.Note: If the tiles 
aren't properly aligned on the artboard, either double-click the Page tool to snap the tiles to the upper left corner of 
the artboard, or use the Page tool to move the pages manually. 

7 Create or import artwork into the document.

8 Choose File > Print.

9 Choose Adobe PostScript File from the Printer menu.

10 Click Save.

11 Name the file with a .ps (PostScript) extension (for example, multiplepage.ps), and then click Save.

12 In Acrobat Distiller, open the new PostScript file. Acrobat Distiller creates a PDF file in the same location as the 
PostScript file.

DXF or DWG file scales up and fills entire artboard when 
opened in Illustrator (CS2)

Issue
DXF or DWG files scale up and fill the entire artboard when you open the files in Adobe Illustrator CS2.

Details
The Autocad file was saved with unitless dimensions or was saved out of Unigraphics with mm dimensions.

Solution

Solution 1: Upgrade to Illustrator CS4 and input the correct import unit dimensions when 
opening the file.
Upgrade, and then input the correct unit dimensions in the Artwork Scale dialog box when opening the DXF or DWG 
file. For upgrade information, see the Adobe website at www.adobe.com/products/illustrator.

Solution 2: Scale the file when you import it.
To scale the file by 3.93700 percentage when you import it:

1. Open the DXF or DWG file.

2. Select Scale By in the Import Options dialog box and type 3.93700 in Percentage.

Additional Information
Illustrator CS2 imports DXF or DWG files saved with unitless dimensions, or saved out of Unigraphics with mm 
dimensions, in inches which causes the files to increase in size. Illustrator CS3 and CS4 allows you to input the correct 
unit dimensions when importing DXF or DWG files.

http://www.adobe.com/products/illustrator
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DXF or DWG files imports at incorrect size when opened 
in Illustrator (CS3 & CS4)

Issue
When importing DXF or DWG files into Illustrator their size displays incorrectly.

Solution

Install Illustrator CS5
To purchase an upgrade from Adobe, visit the Adobe Store at http://store.adobe.com, click the link for your region, click 
Software, and then click the link for the product you want to purchase. 

To locate an authorized reseller, visit the Adobe website at http://www.adobe.com/buy

Additional Information
The issue has been addressed in Illustrator CS5.

 

Error: "Missing required plugins: BRS Pencil Tool [...]" 
when you start Illustrator CS2 or CS3

Issue
 When you try to start Adobe Illustrator CS2 or CS3, the application returns this error or a similar error: "Missing 
required plugins: BRS Pencil Tool. ExpandS. Pathfinder Suite."

Solution
 Do one or more of the following solutions: 

Solution 1: Re-create the Illustrator preferences files.
 The "Missing required plugins" error may appear because one of the Illustrator preferences files has become damaged. 
Follow the instructions below to re-create the preferences files. 

Warning: When you re-create the preferences files, you will lose any unsaved actions that you created. To save actions 
that you created, choose Save Actions from the Actions palette menu in Illustrator before you follow the instructions 
below. To load your custom actions in Illustrator after you have re-created the preferences folder, choose Load Actions 
from the Actions palette menu. 
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Note: The Windows instructions in this solution require you to locate hidden files and hidden folders. By default, 
Windows Explorer doesn't show hidden files or hidden folders. To make these items visible, see "Show hidden files and 
folders (Windows XP, Vista)" (TechNote kb402324). 

To re-create the Illustrator CS2 preferences files: 

1 Quit Illustrator CS2.

2 Do one of the following:

• Mac OS: Rename the Adobe Illustrator CS2 Settings folder (for example, to Old Adobe Illustrator CS2 Settings) 
in the /Users/[your user name]/Library/Preferences folder. Rename the com.adobe.illustrator.plist file (for 
example, to Old com.adobe.illustrator.plist) in the same folder. 

• Windows XP: Rename the Adobe Illustrator CS2 Settings folder (for example, to Old Adobe Illustrator CS2 
Settings) in the C:\Documents and Settings[your user name]\Application Data\Adobe folder. 

• Windows Vista: Rename the the Adobe Illustrator CS2 Settings folder (for example, to Old Adobe Illustrator CS2 
Settings) in the C:\Users\[your user name]\AppData\Roaming\Adobe folder. 

3 Open Illustrator CS2. Illustrator will create new preferences files.

 To re-create the Illustrator CS3 preferences files: 

1 Quit Illustrator CS3.

2 Do one of the following:

• Mac OS: Rename the Adobe Illustrator CS3 Settings folder (for example, to Old Adobe Illustrator CS3 Settings) 
in the /Users/[your user name]/Library/Preferences folder. Rename the com.adobe.illustrator.plist file (for 
example, to Old com.adobe.illustrator.plist) in the same folder. 

• Windows XP: Rename the Adobe Illustrator CS3 Settings folder (for example, to Old Adobe Illustrator CS3 
Settings) in the C:\Documents and Settings[your user name]\Application Data\Adobe folder. 

• Windows Vista: Rename the the Adobe Illustrator CS3 Settings folder (for example, to Old Adobe Illustrator CS3 
Settings) in the C:\Users\[your user name]\AppData\Roaming\Adobe folder. 

3 Open Illustrator CS3. Illustrator will create new preferences files.

 If the problem continues, then damaged preferences file are not the cause. To restore custom settings, delete the new 
preferences folders and restore the original name of the previous preferences folders. On Mac OS, also delete the new 
com.adobe.illustrator.plist file and restore the original name of the previous file. 

Solution 2 (Illustrator CS3 on Windows only): Verify that the required font is installed and 
active.
 The "Missing required plugins" error may appear because a Windows system font required by Illustrator CS3 has been 
disabled or deleted. 

On Windows XP, Illustrator CS3 requires the Tahoma font. On Windows Vista, Illustrator CS3 requires the Segoe-UI 
font. 

To verify that the required font is installed and active, use the Fonts item in the Control Panel, or use your own font 
management utility if you prefer. 

If Tahoma or Segoe-UI is no longer installed, then contact Microsoft for instructions on reinstalling it as well as any 
other missing system fonts. 

http://www.adobe.com/go/kb402324
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Solution 3: Run Illustrator in a new administrator user account.
 A damaged user account or an account with limited system permissions may be the cause of the "Missing plugins" 
error. Create a new administrator account, log on to it, and then try to start Illustrator in the new account. 

To create a new administrator account, contact your system administrator or do one of the following: 

• Mac OS: See "Install or run an Adobe application from within a new user account (Mac OS X)" (TechNote 
kb404927). 

• Windows XP: Choose Start > Help And Support and see the article "To add a new user to the computer." 

• Windows Vista: See "Create new local administrator account (Windows Vista)" (TechNote kb404912). 

Error: "The update cannot be applied to the product" 
when you install the Illustrator CS3 13.0.1 update

Issue
When you use Adobe Updater to install the Adobe Illustrator CS3 13.0.1 update, Adobe Updater returns the error 
message,"An error occurred during install. The update cannot be applied to the product. Please reinstall the product 
and try again."

Solution
 

? Do one of the following:

• Mac OS: In the Finder, navigate to /Library/Application Support/Adobe/Installers. Make sure that you go to the 
/Library folder in the system /root directory and not the /user directory.

• Windows: In Windows Explorer, navigate to C:\Program Files\Common Files\Adobe\Installers.

1 Delete the file named {C4519961-AC64-4565-B3AF-9050296B5D5A}.patch. 

2 Download the standalone installer for the 13.0.1 update from one of these web pages:

• Mac OS: www.adobe.com/support/downloads/detail.jsp?ftpID=3625

• Windows: www.adobe.com/support/downloads/detail.jsp

? Install the 13.0.1 update manually.

Note: For installation instructions, see the operating system-specific web page in Step 3.

On Mac OS, if you are still unable to install the update, do the following:

1 Uninstall Illustrator using the option to delete preferences.

2 Remove Illustrator CS3 from firewall for allowed net connections if it exists.

3 Remove parental control for Illustrator CS3 if it exists.

4 Delete the Adobe Illustrator CS3 folder manually if left behind from ‘/Applications’ or the install directory.

5 Install Illustrator CS3 again.

http://www.adobe.com/go/kb404927
http://www.adobe.com/go/kb404912
http://www.adobe.com/support/downloads/detail.jsp?ftpID=3625
http://www.adobe.com/support/downloads/detail.jsp?ftpID=3629
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6 Now manually run the update downloaded previously (Mac OS: 
www.adobe.com/support/downloads/detail.jsp?ftpID=3625).

Additional Information
See kb2.adobe.com/cps/332/332745.html for troubleshooting problems with the Adobe Update Manager.

 

Illustrator EPS Previews and On-Screen and Printed 
Appearance of EPS Graphics
What's Covered

 EPS Preview Options 

EPS Previews and Printed Appearance of EPS Graphics 

EPS Previews and On-Screen Appearance of EPS Graphics 

By default, when you save an Encapsulated PostScript (EPS) file from Adobe Illustrator, Illustrator creates an EPS 
preview in the PICT (Mac OS) or TIFF (Windows) format. This low resolution preview appears on-screen when you 
place an EPS graphic in another application or another Illustrator file. This document describes how EPS previews 
affect on-screen and printed appearance of placed Illustrator EPS graphics. 

EPS Preview Options

 When you save an EPS file from Illustrator, the EPS Format dialog box offers the following preview options: 

Illustrator for Mac OS

Illustrator for Windows

Preview Option Preview Format

 None n/a 

1-bit IBM PC TIFF 

8-bit IBM PC TIFF 

1-bit Macintosh PICT 

8-bit Macintosh PICT 

Preview Option Preview Format

 None n/a 

1-bit IBM PC TIFF 

8-bit IBM PC TIFF 

http://kb2.adobe.com/cps/332/332745.html
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EPS Previews and Printed Appearance of EPS Graphics

 EPS previews can affect the printed appearance of placed EPS graphics: 

- PostScript printers ignore the preview and print high resolution PostScript information for placed EPS graphics; 
transparent backgrounds print transparent even if they appear opaque on-screen. 

- Non-PostScript printers (e.g., PCL, QuickDraw) print the low resolution preview for placed EPS graphics from most 
applications; transparent backgrounds print opaque if they appear opaque on-screen. Adobe InDesign for Windows, 
however, prints transparent backgrounds to non-PostScript printers, regardless of the screen preview. 

EPS Previews and On-Screen Appearance of EPS Graphics

 EPS previews affect the on-screen appearance of placed EPS graphics. The information below describes the on-screen 
appearance of each type of EPS preview in Illustrator, InDesign, Adobe PageMaker, Adobe Photoshop, and 
QuarkXPress. 

Note: Unless otherwise noted below, transparent backgrounds appear transparent on-screen. 

EPS previewsin Illustrator

EPS previewsin InDesign

*Using InDesign's Proxy Images setting for EPS previews. 

EPS previewsin PageMaker 6.5.x

Preview Type Placed Appearance in Mac OS Placed Appearance in Windows

 None Transparent box Transparent box 

1-bit IBM PC Black and white (transparent backgrounds 
appear opaque) 

Black and white (transparent backgrounds 
appear opaque) 

8-bit IBM PC 256 colors 256 colors 

1-bit Macintosh Black and white Transparent box 

8-bit Macintosh 256 Colors Transparent box 

Preview Type Placed Appearance in Mac OS* Placed Appearance in Windows* 

None 256 colors 256 colors 

1-bit PC Black and white Black and white 

8-bit PC 256 colors 256 colors 

1-bit Mac Black and white (transparent backgrounds 
appear opaque) 

256 colors 

8-bit Mac 256 colors 256 colors 

Preview Type Placed Appearance in Mac OS Placed Appearance in Windows

 None Gray box Gray box 

1-bit PC Black and white Black and white 
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EPS previews in Photoshop

EPS previewsin QuarkXPress

Additional Information
322594: Saving and Exporting Illustrator 8.0 or Later Artwork for Use in Office 97 or Later for Windows 

323385: Create transparency in Photoshop images for use in Illustrator (CS, 10) 

Missing tools and panels (Illustrator CS5-CS2 on 
Windows)

Issue
In Adobe Illustrator, some tools don't appear in the Tools panel, and some panels aren't listed in the Windows menu.

Solution
Do one or more of the following:

8-bit PC 256 colors 256 colors 

1-bit Mac Black and white Gray box 

8-bit Mac 256 colors Gray box 

Preview Type Placed Appearance in Mac OS and Windows

 None Photoshop ignores the preview and instead rasterizes the graphic's 
PostScript data. As a result, Photoshop displays placed EPS files in full 
color with transparent backgrounds, regardless of the preview type. 

1-bit PC 

8-bit PC 

1-bit Mac 

8-bit Mac 

Preview Type Placed Appearance in Mac OS Placed Appearance in Windows

 None Gray box with file description Gray box with file description 

1-bit PC Black and white Black and white 

8-bit PC 256 colors 256 colors 

1-bit Mac Black and white Gray box with file description 

8-bit Mac 256 colors Gray box with file description 

http://helpx.adobe.com/illustrator/kb//cfusion/knowledgebase/index.cfm?id=322594
http://helpx.adobe.com/illustrator/kb//cfusion/knowledgebase/index.cfm?id=323385


11

Last updated 11/12/2015

Solution 1: Retarget the Illustrator Plug-ins folder. (CS2 Only)
1 Choose Edit > Preferences > Plug-ins and Scratch Disk.

2 Click Choose, and then select the Plug-ins folder in the Illustrator CS2 folder, and click OK. (The Illustrator CS2 
folder is in Program Files\Adobe by default.)

3 Restart Illustrator.

Solution 2: Re-create the Illustrator preferences file.
When you re-create the preferences file, all settings revert to their defaults and unsaved actions are lost. To save actions, 
choose Save Actions from the Actions palette menu before re-creating the preferences file.

To re-create the preferences file:

1 Quit Illustrator.

2 Delete the AIPrefs file from the following location: 

• Windows Vista and Win 7:

• For Illustrator CS5: Users/(user)/AppData/Roaming/Adobe/Adobe Illustrator CS5 Settings

• For Illustrator CS4: Users/(user)/AppData/Roaming/Adobe/Adobe Illustrator CS4 Settings

• For Illustrator CS3: Users/(user)/AppData/Roaming/Adobe/Adobe Illustrator CS3 Settings

• For Illustrator CS2: Users/(user)/AppData/Roaming/Adobe/Adobe Illustrator CS2 Settings

• Windows XP:

• For Illustrator CS5: Documents and Settings\[ user profile ]\Application Data\Adobe\Adobe Illustrator CS5 
Settings

• For Illustrator CS4: Documents and Settings\[ user profile ]\Application Data\Adobe\Adobe Illustrator CS4 
Settings

• For Illustrator CS3: Documents and Settings\[ user profile ]\Application Data\Adobe\Adobe Illustrator CS3 
Settings

• For Illustrator CS2: Documents and Settings\[ user profile ]\Application Data\Adobe\Adobe Illustrator CS2 
Settings

3 Restart Illustrator.

Solution 3: Increase system resources.
Quit applications except Illustrator, including those that run in the background (such as font management utilities), 
and reduce the number of active TrueType fonts. (To prevent applications from starting automatically with Windows, 
remove them from the Startup folder.)

• kb404867: Reduce the number of active fonts (Windows XP)

• kb404915: Reduce the number of active fonts (Windows 7 and Windows Vista)

Solution 4: Uninstall Illustrator, re-create the Illustrator preferences file, and then reinstall 
Illustrator. (CS2 Only)
Uninstall Illustrator, re-create the Illustrator preferences file, and then reinstall Illustrator.

To uninstall Illustrator: Remove any personal files from the Illustrator application folder.

• If you installed Illustrator from the Illustrator CD, then choose Start > Control Panel > Add Or Remove Programs. 
Select Illustrator CS2 and click Remove. Follow the on-screen instructions.

http://kb2.adobe.com/cps/404/kb404867.html
http://kb2.adobe.com/cps/404/kb404915.html
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• If you installed Illustrator from the Adobe Creative Suite 2 CDs, then choose Start > Control Panel > Add Or 
Remove Programs. Select Adobe Creative Suite 2 and click Remove. Follow the on-screen instructions to uninstall 
the Illustrator component.

To re-create the Illustrator preferences file, see solution 2.

To reinstall Illustrator:

1 Insert either the Adobe Creative Suite 2 or Illustrator CS2 installation media

2 Follow the on-screen instructions to complete the installation.

Background information
If two different versions of Illustrator earlier than CS3 to CS5 are installed in the same folder and you remove the earlier 
version after installing the later version, some of the toolbox tools are removed (including, but not limited to, the Direct 
Select Lasso, Rectangle, Paintbrush, and Pencil tools). Similarly, several of the palettes, including PathFinder, 
Transform, Actions, Transparency, and Navigator, are removed from the Window menu.

If insufficient system resources are available, then Illustrator may display tools and palettes incorrectly. A damaged 
preferences file may also cause Illustrator to display tools and palettes incorrectly.

 

Optimize performance | Illustrator |CS2-CS3 |Windows
What's covered

 Optimizing Windows Optimizing your hardware configuration Using Illustrator features effectively Windows 
resources 

The performance of Adobe Illustrator depends on several factors, including the options you select, your workflow, and 
the operating system and hardware configuration. The performance improvements listed below are most noticeable 
when you work with larger files. Optimizing the operating system and hardware configuration improves performance 
in other applications as well. 

Before you perform the steps below, make sure to install the latest version of Illustrator or any Illustrator updates to the 
version you are using. Illustrator updates often include performance-related fixes or enhancements. Current version 
information and updates are available on the Adobe website at www.adobe.com . 

Note:The Windows XP and Vista procedures in this document are based on the default interface. If the interface is 
customized, then some procedures may vary. For example, a commonly encountered difference is the navigation to 
Control Panel from the Start menu: You may navigate Start > Settings > Control Panel instead of Start > Control Panel. 

Optimizing Windows

 By configuring your system to run efficiently, you increase the amount of memory available to applications and ensure 
that they run smoothly. Increase the amount of memory available to Illustrator, quit applications you are not using, or 
disable nonessential startup applications or fonts to improve the performance of Illustrator. 

Virtual memory

 Virtual memory allows the system to use hard disk space to store information normally stored in RAM. Because it takes 
longer to access information on a hard disk than it does to access information in memory, using a portion of the hard 
disk as virtual memory can decrease performance. 

http://www.adobe.com
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Windows XP and Vista manage virtual memory using a paging file; you define the minimum and maximum size of this 
file. Illustrator performs best when the paging file's maximum size is at least three times the amount of installed RAM. 

To create a paging file with a maximum size of three times your amount of installed RAM: 

Note: You need Administrator rights to change the size of your computer's paging file. 

1 Quit all applications.

2 Choose Start > Control Panel and then double-click System.

3 Access the Performance Options dialog box: 

• In WindowsVista, click on Advanced System Settings,, click Settings in the Performance section, and then click 
the Advanced tab. 

• In Windows XP, click the Advanced tab, click Settings in the Performance section, and then click the Advanced 
tab. 

4 In the Virtual Memory section, click Change.

5 Uncheck the box for "automatically manage paging file size for all drives.

6 From the Drive list, select a hard drive that has at least three times the amount of your computer's installed RAM. 
For example, if your computer has 64 MB of RAM, select a hard drive that has at least 128 MB of free space. For best 
performance, choose a hard drive not used for the Illustrator scratch disk.Note:To determine the amount of space 
available on a drive, click the drive letter; the amount of space available appears in the Paging File Size for Selected 
Drive section.

7 In the Initial Size box in the Paging File Size for Selected Drive section, enter a value equal to the amount of your 
computer's installed RAM plus 300 MB.

8 In the Maximum Size box, enter a value equal to three times the amount of your computer's installed RAM.

9 Close the System Properties dialog box:

a Click Set, and then click OK.

b Click OK in the Performance Options dialog box

c Click OK in the System Properties dialog box.

10 Click Yes in the System Settings Change dialog box to restart Windows.

Display drivers

 Some display drivers offer advanced settings for accelerating or modifying graphics display. Sometimes these settings 
can adversely affect screen redraw performance in Illustrator. Try disabling driver-specific features to determine the 
best settings for use with Illustrator. For more information, see the documentation for your display card. 

Fonts

 If you install only the fonts you need, then you will improve system performance and the performance of applications 
that access fonts. Each installed font increases the amount of RAM used by the system, which decreases the amount of 
RAM available to open applications, and increases the amount of time applications take to display font menus. Use a 
font management utility to help you manage many fonts. 

Startup applications

 Applications that start automatically with Windows compete with Illustrator for available RAM. You can prevent 
programs from starting automatically with Windows by doing the following: 
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To remove programs from the StartUp folder in Windows XP: 

1 Quit all applications.

2 Start Windows Explorer.

3 Disable startup applications that are specific to the current user by moving all icons and shortcuts from the 
Documents and Settings\[current user]\Start Menu\Programs\Startup folder to another folder.

4 Disable startup applications that are common to all users by moving all icons and shortcuts from the Documents 
and Settings\All Users\Start Menu\Programs\Startup folder to another folder:

5 Restart Windows.

 To disable programs from the StartUp folder in Windows Vista 

1 Quit all applications.

2 Go to Start>All Programs>Windows Defender.

3 In Windows Defender click the tools button, then click "Software Explorer."

4 In the Category box, selet Startup Programs.

5 Select "Show for all users"

6 Select the program that you want to prevent from running and then click "Disable."

7 Click "Yes" to confirm that you want to stop that program from running.

8 Repeat steps 6 and 7 for every program you want to stop from running.

9 Restart Windows 

• If the performance of Illustrator does not improve, then move the icons and shortcuts back (Windows XP) or re-
enable them in Windows Defender (Windows Vista 

• If the performance of Illustrator improves, then isolate the performance problem to one or more programs by 
moving one back and restarting Windows XP or using Windows Defender to re-enable programs. Repeat this 
process until the performance of Illustrator degrades. When you have isolated the icon or shortcut that is causing 
the performance problem, remove it again and contact the program's manufacturer to see if an update is 
available. 

To close applications that are specified to start automatically in the registry: 

1 Restart Windows.

2 Press Ctrl+Shift+Esc.

3 Click the Applications tab.

4 Select an application name, and then click End Task.

5 Restart Illustrator. If performance for Illustrator improves, then contact the application's manufacturer for help in 
permanently disabling it from starting automatically. Repeat steps 2-5 for each remaining startup application.

Optimizing your hardware configuration

 The hardware you use affects the performance of Illustrator: the faster the processor or hard drive, the faster Illustrator 
can process information. Other hardware enhancements, such as installing additional RAM, using a multiprocessor 
system, or optimizing and defragmenting drives, can also improve performance. 

Processor speed
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 The speed of Illustrator is limited by the speed of your computer's Central Processing Unit (CPU). Since Illustrator 
manipulates large quantities of data and performs many calculations, its speed is greatly dependent on the processor's 
speed. Using a computer with a faster processor will increase Illustrator's speed. 

Installed RAM

 If Illustrator has insufficient RAM, it uses hard disk space (that is, virtual memory, scratch disk, or both) to process 
information. Illustrator is fastest when it can process information in memory, without having to use a hard disk. 

Hard disks

 As you add, delete, and move files on a hard disk, available space is no longer a single, contiguous block. If the system 
does not have enough contiguous space, it saves fragments of a file to different locations on the hard disk. An 
application requires more time to read a fragmented file than one saved to a contiguous location. You can test your hard 
disk by using ChkDsk (Windows XP) or "Check your hard disk for errors." (Windows Vista). You can defragment files 
and optimize available hard disk space by using Disk Defragmenter. For more information on these tools, see your 
Windows documentation. 

Since Illustrator reads and writes information while working on a file, the faster the access speed of the disk containing 
the file or the Illustrator scratch disk, the faster Illustrator can process file information. To improve the performance of 
Illustrator, work on files saved on drives with fast access speeds, such as an internal hard drive, rather than those with 
slow access speeds, such as a network server (a network drive) or removable media (for example, Zip drive, or floppy 
disk). Removable media often have slower access times and are more easily damaged than internal hard drives. 

When you want to save an Illustrator file to a network or removable drive, Adobe recommends you first save the file to 
an internal hard disk, and then close the file and use Windows Explorer to copy the closed file to the external or network 
drive, or save the file to the network using Adobe Version Cue. 

Printer language

 For best results when printing from Illustrator, use a PostScript printer. Most non PostScript printers rely on display 
information, host computer resources, and proprietary printer drivers to relay print information to the printer, so they 
may take much longer to print than a PostScript printer. 

Using Illustrator features effectively

 The way you work in Illustrator, and especially the way you view artwork, can effect the performance of Illustrator. 
Modifying view options, linking images rather than embedding them, and optimizing scratch disk and startup options 
can all affect the speed of Illustrator and its memory usage. 

OutlineView

 Outline view hides paint attributes, displaying the artwork as unfilled paths. Working in Outline view can speed the 
display of complex artwork, such as objects containing gradients or patterns. Outline view can also make it easier to 
edit objects hidden behind other filled objects. In Illustrator, choose View > Outline to display a document in outline 
mode. 

For more information on viewing artwork in Illustrator, see Illustrator Help. 

Custom Views

 You can create custom views of your document, allowing you to quickly change the view mode, magnification, scroll 
position, and layer options by choosing a custom view from the View menu. To create a custom view, set the view 
attributes you want to save, and then choose View > New View and type a name in the New View dialog box. The 
custom view appears in the View menu. 

Display performance
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 You can specify the quality and speed of the display when you use the Hand tool to move the artboard. To specify the 
display quality, choose Edit > Preferences > Units & Display Performance. Drag the Hand Tool slider to the left to 
improve the display quality when you use the Hand tool, or move it to the right to improve speed. 

Raster effect resolution

 You can change the resolution of raster effects to optimize the performance of Illustrator. To change the resolution of 
raster effects, choose Effect > Document Raster Effects Settings, do one of the following, and then click OK: 

• If you are editing files, click Screen. Illustrator uses a resolution of 72 ppi for raster effects, increasing display speed. 

• If you are printing files, click High. Illustrator uses a resolution of 300 ppi for raster effects, decreasing printing 
speed, but increasing print quality. 

Layers panel

 The Layers panel lets you easily organize and modify artwork. When you hide layers that contain complex artwork or 
high resolution bitmap images, Illustrator redraws the screen faster. To hide a layer, click the eye icon to the left of the 
layer name, deselect Show Layer, and then click OK. To hide all but the selected layer, Alt-click the eye icon. 

Note: The Layers panel can display thumbnails for top-level layers, nested layers, groups, and objects. You can reduce 
the number of thumbnails so Illustrator redraws the screen faster: 

1 Choose Panel Options from the Layers palette menu.

2 Reduce the number of thumbnails: 

• To remove all thumbnails from the Layers panel, select Small in the Row Size section, and then click OK. 

• To remove thumbnails for specific elements in the Layers panel, deselect Layers, Groups, or Objects in the 
Thumbnails section, and then click OK. 

Scratch disk

 When you work with an embedded bitmap image and your system does not have enough RAM to perform an 
operation, Illustrator uses hard disk space as a scratch disk. Because it takes longer to access information on a hard disk 
than it does to access information in memory, using a portion of the hard disk as virtual memory can decrease 
performance. If you need more memory to work in Illustrator, Adobe Systems recommends installing more RAM. 

By default, Illustrator uses the system drive as its primary scratch disk. You should change the Illustrator primary 
scratch disk setting to your fastest hard drive. 

To change the scratch disk preference: 

1 Choose Edit > Preferences > Plug-ins & Scratch Disk.

2 Choose a hard disk from the Primary pop-up menu. If you work with large images and have more than one hard 
disk, choose another disk from the Secondary pop-up menu.

3 Click OK and restart Illustrator.

Note: Adobe recommends that you use a disk utility, such as Disk Defragmenter, to optimize and defragment your hard 
disk on a regular basis. For more information, see your Windows documentation. 

Illustrator startup files

 Illustrator startup files (CS2) or Document Profiles (CS3) contain the default patterns, gradients, graph designs, colors, 
and color libraries that appear in new Illustrator documents. These files also determine zoom level, window size, 
viewing preferences, and scroll position for new documents. You can minimize the file size of new documents by 
removing unnecessary swatches and brushes from Illustrator startup files. 



17

Last updated 11/12/2015

For instructions on creating custom startup files in Illustrator CS2, see Illustrator Help. For instructions on creating 
custom document profiles in Illustrator CS3 see, "To create a custom new document profile (Illustrator CS3)" (Technote 
kb400732). 

Templates

 Templates let you create new documents that share common settings and design elements. For example, to design a 
series of business cards with a similar look and feel, create a template with the desired artboard size, view settings (such 
as guides), and print options. You can minimize the file size of new documents by removing unnecessary swatches, 
symbols, graphic styles, and brushes from templates. 

Templates offer a powerful alternative to creating custom startup files. You can create an unlimited number of 
templates. In addition, you can store and access templates anywhere, as opposed to startup files, which must have a 
specific name and location. 

For instructions on creating template files, see Illustrator Help. 

Linked files

 Embedded bitmap images (for example, TIFF, BMP, or Photoshop EPS) can dramatically increase the size of an 
Illustrator document, causing slower performance. To improve performance, select Link in the Place dialog box when 
you place a bitmap image. The Link option references the placed image on the hard disk. (If a service buereu requires 
embedded images, then save a copy f the file and select Include Linked Files in the Illustrator Native Format Options 
or EPS Format Options dialog box.) 

EPS previews

 If a document contains linked EPS images that have high-resolution previews, Illustrator may redraw the screen slowly 
as you edit artwork. To enable Illustrator to redraw the screen more quickly, use low-resolution EPS previews: Choose 
Edit > Preferences > File Handling & Clipboard, select Use Low Resolution Proxy For Linked EPS, and then click OK. 

Show DCS Transparency Interactions option

 The Links Panel Options dialog box includes a Show DCS Transparency Interactions option. If this option is selected, 
the Links palette displays a yellow icon to identify linked DCS EPS graphics that are transparent or overlap transparent 
objects. Because this option forces Illustrator to regularly determine if linked EPS files interact with transparency, it can 
reduce performance. 

To disable the Show Transparency Interactions option: 

1 Choose Palette Options from the Links palette menu.

2 Deselect Show DCS Transparency Interactions, and then click OK.

Navigator panel

 The Navigator panel displays a thumbnail view of your current artwork for easy navigation. Depending on the 
complexity of your artwork, a substantial amount of processing time may be required to update the thumbnail each 
time you make a change. To improve screen redraw speed and performance in a complex Illustrator document, hide 
the Navigator panel by unchecking Navigator under the Window menu. 

You can set up custom views to more efficiently zoom to particular areas of your document. See the Custom 
Viewssection of this document for more information. 

Anti-Alias Artwork option

 The Anti-Alias Artwork option smooths text and graphics by blending the color of an object's edge pixels with that of 
adjacent pixels. However, this process can cause slow screen redraw. To disable this option, choose Edit > Preferences 
> General; then deselect Anti-aliased Artwork and click OK. 

http://www.adobe.com/go/kb400732
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Simplifycommand

 The Simplify command reduces the amount of anchor points in paths and path shapes, reducing file size and increasing 
performance. To apply the Simplify command, select the desired path or object, and then choose Object > Path > 
Simplify. 

For more information on the Simplify command, see Illustrator Help. 

Smart Guides

 Smart Guides allow you to create, align, edit, and transform Illustrator objects relative to other objects. If you have a 
large number of objects in your artwork, Illustrator will require more time to display Smart Guides. To disable Smart 
Guides, uncheck Smart Guides under the View menu. 

For more information on Smart Guides, see Illustrator Help. 

Windows resources

 The following websites provide troubleshooting tips and general information about Windows. 

Adobe Customer Support: www.adobe.com/support/

 Microsoft Knowledgebase: http://support.microsoft.com

Additional Information

Optimize performance | Illustrator |CS2-CS4 | Mac OS X
What's covered

• Optimizing the Mac OS configuration 

• Optimizing the hardware configuration 

• Using Illustrator features effectively 

The performance of Adobe Illustrator depends on several factors, including the options you select, your workflow, and 
the operating system and hardware configuration. The performance improvements listed below are most noticeable 
when you work with larger files. Optimizing the Mac OS and hardware configurations improves performance in other 
applications as well.

Before you perform the steps below, make sure to install the latest version of Illustrator or any Illustrator updates to the 
version you are using. Illustrator updates often include performance-related fixes or enhancements. Current version 
information and updates are available on the Adobe website at www.adobe.com .

Optimizing the Mac OS configuration

If you configure your system to run efficiently, then you increase the amount of memory available to applications and 
ensure that they run smoothly. Quit applications that you aren't using or disable nonessential fonts to improve the 
performance of Illustrator.

Fonts

http://www.adobe.com/support/
http://support.microsoft.com
http://helpx.adobe.com/illustrator/kb/#main_optimiseOSconf
http://helpx.adobe.com/illustrator/kb/#main_OptimizeHWConf
http://helpx.adobe.com/illustrator/kb/#main_IllustratorFeatures
http://www.adobe.com
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If you install only the fonts you need, then you will improve system performance and the performance of applications 
that access fonts. Each installed font increases the amount of RAM used by the system, which decreases the amount of 
RAM available to open applications and increases the amount of time applications take to display font menus. Use a 
font management utility, such as Extensis Suitcase, to help you manage a large number of fonts.

Printer drivers

Because non-PostScript printer drivers can conflict with Illustrator, Adobe recommends that you set a PostScript 
printer driver as the default printer in Mac OS.

Note: To complete this procedure, a PostScript printer must be connected to the computer either directly or via a 
network.

To set a PostScript printer as the default printer:

1 At the Finder, choose Go > Applications, open the Utilities folder, and then double-click Printer Setup Utility (Mac 
OS X 10.3 or later) or Print Center (Mac OS X 10.2.8 or earlier).

2 If a PostScript printer isn't listed, then click Add Printer, navigate to a PostScript printer, and click Add.

3 Select a PostScript printer, and then choose Printers > Make Default.

To configure Illustrator to print to a nondefault printer:

1 In Illustrator, choose File > Print.

2 Choose the printer from the Printer menu.

3 Click Done to close the Print dialog box, or Print to print the file.

Optimizing the hardware configuration

The hardware you use affects the performance of Illustrator: The faster the processor or hard drive, the faster Illustrator 
can process information. Other hardware enhancements, such as installing additional RAM, using a multiprocessor 
system, or optimizing and defragmenting drives, can also improve performance.

Processor speed

Because Illustrator manipulates large quantities of data and performs many calculations, its speed is limited by the 
speed of the computer processor: The faster the processor, the faster Illustrator performs.

Installed RAM

If Illustrator has insufficient RAM, then it uses hard disk space (that is, a scratch disk) to process information. 
Illustrator is fastest when it can process file information in memory, without having to use the hard disk.

Hard disks

As you add, delete, and move files on a hard disk, available space is no longer a single, contiguous block. If the system 
does not have enough contiguous space, then it saves fragments of a file to different locations on the hard disk. An 
application requires more time to read a fragmented file than one saved to a contiguous location. You can defragment 
files and optimize available hard disk space by using a third-party disk utility (for example, Norton Utilities).

Since Illustrator reads and writes information while working on a file, the faster the access speed of the disk containing 
the file or the Illustrator scratch disk, the faster Illustrator can process file information. To improve the performance of 
Illustrator, work on files saved on drives with fast access speeds, such as an internal hard drive, rather than those with 
slow access speeds, such as a network server (a network drive) or removable media (for example, a Zip drive, or a 
diskette). Removable media often have slower access times and are more easily damaged than internal hard drives.
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When you want to save an Illustrator file to a network or removable drive, Adobe recommends you first save the file to 
an internal hard disk, and then close the file and use the Finder to copy the closed file to the external or network drive, 
or save the file to the network using Adobe Version Cue.

Printer language

For best results when printing from Illustrator, use a PostScript printer. Because most non-PostScript printers rely on 
display information, host computer resources, and proprietary printer drivers to relay print information to the printer, 
they may take much longer to print than a PostScript printer.

Using Illustrator features effectively

The way you work in Illustrator, and especially the way you view artwork, can effect the performance of Illustrator. 
Modifying view options, linking images rather than embedding them, and optimizing scratch disk and startup options 
can all affect the speed of Illustrator and its memory usage.

Outlineview

Outline view hides paint attributes, displaying the artwork as unfilled paths. Working in Outline view can speed the 
display of complex artwork, such as objects containing gradients or patterns. Outline view can also make it easier to 
edit objects hidden behind other filled objects. Choose View > Outline to display a document in outline mode.

For more information about viewing artwork in Illustrator, see Illustrator Help.

Custom views

You can create custom views of your document, allowing you to quickly change the view mode, magnification, scroll 
position, and layer options by choosing a custom view from the View menu. To create a custom view, set the view 
attributes you want to save, choose View > New View, and enter a name in the New View dialog box. The custom view 
appears in the View menu.

Display performance

You can specify the quality and speed of the display when you move the artboard using the Hand tool. To specify the 
display quality, choose Illustrator > Preferences > Units & Display Performance. Drag the Hand Tool slider to the left 
to improve the display quality when you use the Hand tool, or move it to the right to improve speed.

Raster effect resolution

You can change the resolution of raster effects to optimize the performance of Illustrator. To change the resolution of 
raster effects, choose Effect > Document Raster Effects Settings, do one of the following, and then click OK:

• If you are editing files, then click Screen. Illustrator uses a resolution of 72 ppi for raster effects, increasing display 
speed.

• If you are printing files, then click High. Illustrator uses a resolution of 300 ppi for raster effects, decreasing printing 
speed but increasing print quality.

Layers palette (CS2) or Layers panel (CS3 or CS4)

The Layers palette (CS2) or Layers panel (CS3 or CS4) lets you easily organize and modify artwork. When you hide 
layers that contain complex artwork or high resolution bitmap images, Illustrator redraws the screen faster. To hide a 
layer, click the eye icon to the left of the layer's name. To hide all but the selected layer, Option-click the eye icon.

The Layers palette (CS2) or Layers panel (CS3 or CS4) can display thumbnails for top-level layers, nested layers, groups, 
and objects. You can reduce the number of thumbnails so Illustrator redraws the screen faster:

1 Choose Palette Options (CS2) from the Layers palette menu or Panel Options (CS3 or CS4) from the Layers panel 
menu.
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2 Reduce the number of thumbnails: 

• To remove all thumbnails from the Layers palette (CS2) or Layers panel (CS3 or CS4), select Small in the Row 
Size section, and then click OK.

• To remove thumbnails for specific elements in the Layers palette (CS2) or Layers panel (CS3 or CS4), deselect 
Layers, Groups, or Objects in the Thumbnails section, and then click OK.

Scratch disk

When you work with an embedded bitmap image, and the system doesn't have enough RAM to perform an operation, 
Illustrator uses hard disk space as a scratch disk. Because it takes longer to access information on a hard disk than it 
does to access information in memory, using a portion of the hard disk as virtual memory can decrease performance. 
If you need more memory to work in Illustrator, Adobe Systems recommends installing more RAM.

By default, Illustrator uses the system drive as its primary scratch disk. You should change the Illustrator primary 
scratch disk setting to your fastest hard drive.

To change the scratch disk preference:

1 Choose Illustrator > Preferences > Plug-ins & Scratch Disk.

2 Choose a hard disk from the Primary pop-up menu. If you intend to work with large images and have more than 
one hard disk, choose another disk from the Secondary pop-up menu.

3 Click OK and restart Illustrator.

Note: Adobe recommends that you use a disk utility, such as Norton Utilities or TechTool Pro, to optimize and 
defragment the hard disk regularly.

Illustrator startup files

Adobe Illustrator startup files (CS2) or Document Profiles (CS3 or CS4) contain the default patterns, gradients, graph 
designs, colors, and color libraries that appear in new Illustrator documents. These files also determine zoom level, 
window size, viewing preferences, and scroll position for new documents. You can minimize the file size of new 
documents by removing unnecessary swatches, gradients, graphic styles, and brushes from Adobe Illustrator startup 
files.

For instructions on creating custom startup files in Illustrator CS2, see Illustrator Help For instructions on creating 
custom document profiles, see " Create a Custom New Document Profile (Illustrator CS3)" (Technote kb400732 ).

Templates

Templates let you create new documents that share common settings and design elements. For example, to design a 
series of business cards with a similar look and feel, create a template with the desired artboard size, view settings (such 
as guides), and print options. You can minimize the file size of new documents by removing unnecessary swatches, 
symbols, graphic styles, and brushes from templates.

Templates offer a powerful alternative to creating custom startup files. While you can create only two custom startup 
files (one for CMYK mode and one for RGB mode) for Illustrator CS2, and a limited amount of document profiles for 
Illustrator CS3, and CS4 you can create an unlimited number of templates. In addition, you can store and access 
templates anywhere, as opposed to startup files, which must have a specific name and location.

For instructions on creating template files, see Illustrator Help.

Linked files

http://helpx.adobe.com/illustrator/kb//cfusion/knowledgebase/index.cfm?id=%20kb400732
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Embedded bitmap images (such as TIFF, BMP, or Photoshop EPS) can dramatically increase the size of an Illustrator 
document, causing slower performance. To improve performance, select Link in the Place dialog box when you place 
a bitmap image. The Link option references the placed image on the hard disk. (If a service bureau requires embedded 
images, save a copy of the file and select Include Linked Files in the Illustrator Native Format Options or EPS Format 
Options dialog box.)

EPS previews

If a document contains linked EPS images with high-resolution previews, Illustrator may redraw the screen slowly as 
you edit artwork. To allow Illustrator to redraw the screen more quickly, use low-resolution EPS previews: Choose 
Illustrator > Preferences > File Handling & Clipboard, select Use Low Resolution Proxy for Linked EPS, and then click 
OK.

Show DCS Transparency Interactions option

The Links Palette (CS2) or Links Panel (CS3 or CS4) Options dialog box includes a Show DCS Transparency 
Interactions option. If this option is selected, the Links palette displays a yellow icon to identify linked DCS EPS 
graphics that are transparent or overlap transparent objects. Because this option forces Illustrator to regularly 
determine if linked EPS files interact with transparency, it can reduce performance.

To disable the Show Transparency Interactions option:

1 Choose Palette (CS2) or Panel (CS3 or CS4) Options from the Links palette (CS2) or Links panel (CS3 or CS4) 
menu.

2 Deselect Show DCS Transparency Interactions, and then click OK.

Navigator palette (CS2) or Navigator panel (CS3 or CS4)

The Navigator palette (CS2) or Navigator panel (CS3 or CS4) displays a thumbnail view of the current artwork for easy 
navigation. Depending on the complexity of the artwork, a substantial amount of processing time may be required to 
update the thumbnail each time you make a change. To improve screen redraw speed and performance in a complex 
Illustrator document, hide the Navigator palette (CS2) or Navigator panel (CS3 or CS4) by choosing Window > Hide 
Navigator.

You can set up custom views to more efficiently zoom to particular areas of your document. See the Custom Views 
section of this document for more information.

Anti-Alias Artwork option

The Anti-Alias Artwork option smoothes text and graphics by blending the color of an object's edge pixels with that of 
adjacent pixels. However, this process can cause slow screen redraw. To disable this option, choose Illustrator > 
Preferences > General, deselect Anti-aliased Artwork, and then click OK.

Simplifycommand

The Simplify command reduces the amount of anchor points in paths and path shapes, reducing file size and increasing 
performance. To apply the Simplify command, select the desired path or object, and then choose Object > Path > 
Simplify.

For more information on the Simplify command, see Illustrator Help.

Smart Guides

Smart Guides allow you to create, align, edit, and transform Illustrator objects relative to other objects. If artwork 
contains a large number of objects, Illustrator requires more time to display Smart Guides. To disable Smart Guides, 
choose View > Smart Guides. A check mark appears next to the command when Smart Guides are enabled.

For more information on Smart Guides, see Illustrator Help.
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Preference file location | Illustrator
Adobe Illustrator stores its preferences file in the following locations:

Note: If you can't find the AIPrefs file in the following locations, enable Windows to show hidden files and folders. For 
instructions, refer to your Windows documentation. For Mac OS, the name of the preferences file is Adobe Illustrator 
Prefs.

Illustrator CC
Mac OS

Local

/Users//Library/Preferences/Adobe Illustrator 17 Settings/en_US*/Adobe Illustrator Prefs

Synced

/Users//Library/Preferences/Adobe Illustrator 17 Settings/en_US*/Adobe Illustrator Cloud Prefs

Windows 8.1 | Windows 8 | Windows 7 | Windows Vista

Local:

Users\<username>\AppData\Roaming\Adobe\Adobe Illustrator 17 Settings\en_US*\x64*\Adobe Illustrator Prefs

Synced:

Users\<username>\AppData\Roaming\Adobe\Adobe Illustrator 17 Settings\en_US*\x64*\Adobe Illustrator Cloud 
Prefs 

Illustrator CS6
Mac OS

/Users//Library/Preferences/Adobe Illustrator CS6 Settings/en_US*/Adobe Illustrator Prefs

Windows 8.1 | Windows 8 | Windows 7 | Windows Vista

Users\<username>\AppData\Roaming\Adobe\Adobe Illustrator CS6 Settings\en_US*\x64*\Adobe Illustrator Prefs

Windows XP | Windows 2000

Documents and Settings\\Application Data\Adobe\Adobe Illustrator CS6 Settings/ Adobe Illustrator Prefs

Illustrator CS5
Mac OS

/Users//Library/Preferences/Adobe Illustrator CS5 Settings/en_US*/

Windows 7 | Windows Vista

Users\\AppData/Roaming\Adobe\Adobe Illustrator CS5 Settings\en_US*\AIPrefs

Windows XP | Windows 2000

Documents and Settings\\Application Data\Adobe\Adobe Illustrator CS5 Settings/AIPrefs
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Illustrator CS4
Mac OS

/Users//Library/Preferences/Adobe Illustrator CS4 Settings/en_US*/

Windows 7 | Windows Vista

Users\<username>\AppData\Roaming\Adobe\Adobe Illustrator CS4 Settings\AIPrefs

Windows XP | Windows 2000

Documents and Settings\<username>\Application Data\Adobe\Adobe Illustrator CS4 Settings\AIPrefs

Illustrator CS3
Mac OS

/Users/username/Library/Preferences/Adobe Illustrator CS3 Settings/

Windows 7 | Windows Vista

Users\\AppData\Roaming\Adobe\Adobe Illustrator CS3 Settings\AIPrefs

Windows XP | Windows 2000

Documents and Settings\\Application Data\Adobe\Adobe Illustrator CS3 Settings\AIPrefs

Spot colors, transparency
When you use spot colors and transparency, Illustrator sometimes manipulates file content to maintain the appearance 
of artwork in PostScript and other transparency flattening processes. When Illustrator manipulates content during the 
flattening process, spot colors involved in specific transparency scenarios sometimes require conversion to process 
colors. While these cases are less and less common with each successive version of Illustrator, the following items 
address the remaining limitations to spot color preservation when interacting with transparency in Illustrator CS3 and 
later and CS2.

Raster effects

In Illustrator CS2 when you apply raster-based effects (for example, Rasterize and Gaussian Blur) at the object, group, 
or layer level to objects that contain multiple spot colors or a combination of spot and process color, Illustrator converts 
the object color to either the document's process color space, grayscale, or bitmap. You can choose one of these options 
in the Raster Effects Settings dialog box. For example, in a simple rectangle with a spot color fill and a process black 
stroke, the spot color fill convert to a process color. However, if all of the attributes of an object, group, or layer are 
colored with a single spot color, then the spot color is maintained regardless of where you apply the effect. Illustrator 
CS3 and later maintain the spot color in any of the above scenarios.

The Preserve Spot Colors When Possible check box (CS2) or the Preserve Spot Colors check box (CS3 and later) in the 
Raster Effects Settings dialog box is not selected by default when you open Illustrator files created in versions earlier 
than CS2. This setting ensures that the printing behavior of these files is consistent with earlier versions of Illustrator. 
The selection in the Preserve Spot Colors When Possible check box in Illustrator CS2 files is maintained when the files 
are reopened.

Gradients and gradient mesh
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Illustrator CS3 and later and CS2 (or Cs2 and later) preserves spot-color-to-spot-color gradients and spot-color-to-
process-color gradients in both opaque and transparent scenarios. To print and export spot colors in gradient scenarios, 
select Preserve Overprints and Spot Colors in the Object > Flatten Transparency dialog box.

In Illustrator CS2, when a gradient mesh contains more than one spot color, or a process color and a spot color, 
Illustrator converts the mesh to the document's process color space. Illustrator CS3 and later retain the spot color in 
both of the preceding gradient mesh scenarios.

Spot-to-spot blends

When you create a blend between two different spot color objects, Illustrator converts all of the intermediate steps to 
the document's process color space.

Rasterization

In Illustrator CS2, the Object > Rasterize command allows you to convert all spot colors to the document's process color 
space, grayscale, or bitmap. Spot colors aren't preserved when rasterized. The Effects > Rasterize command is subject 
to the Effect limitations explained in Raster Effects (above) and will "Preserve Spot Colors When Possible" when you 
select this option in the Raster Effects Settings dialog box.

Illustrator CS3 and later allows you to retain spot colors when using both the Object > Rasterize and Effects >Rasterize 
command by selecting the Preserve Spot Colors option in the Object > Rasterize dialog box and the Effects > 
Document Raster Effects Settings dialog box respectively.

Live Trace tool

Illustrator CS3 and later and CS2 preserves spot colors in grayscale raster objects when the spot color has been applied 
in Illustrator. Spot colors in all other raster format files, whether linked or embedded, are converted to process colors 
or ignored when you use the Live Trace command.

SVG filters

When you apply any SVG Filter in Illustrator CS2, spot colors are converted to the document's process color space.

Imported raster formats

Methods for accommodating spot colors imported from raster formats are much improved in both Illustrator CS3 and 
later and CS2 over earlier versions. Illustrator CS2 retains spot colors in embedded native Photoshop files as a raster 
opacity mask over a rectangle that is filled with the spot color and set to overprint, and in Illustrator CS3 and later it 
converts the image to a deviceN raster object (alll spot and process colors are retained together in an NChannel format). 
Illustrator CS3 and later, CS2 (or CS and later) retains spot colors in embedded PDF files as output-friendly non-
native art. The only significant raster format limitations remaining are listed below and are all fixed by Illustrator CS3 
and later.

• TIFF: Illustrator CS2 does not import spot colors in TIFF files. Only the CMYK, RGB, or Grayscale portion is 
imported. Illustrator CS3 and later import spot colors in TIFF files exported from Photoshop.

• PSD Duotone: You can't link or embed PSD Duotone in Illustrator CS2. These actions cause an error message and 
the Place function fails with no result. You can successfully link and embed PSD Duotone files in Illustrator CS3 and 
the spot colors are retained.

• EPS Duotone: Illustrator CS2 converts spot colors in embedded EPS Duotone files to process colors. Illustrator CS3 
and later retain spot colors in embedded EPS Duotone files.
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• DCS 2.0 EPS: Illustrator CS2 does not support spot colors or high-resolution data contained in DCS EPS files when 
the DCS EPS interacts with transparency. In this case, only composite data is preserved. Illustrator CS2 supports 
DCS EPS only in non-transparent separated workflows. Illustrator CS3 supports DCS 2.0 EPS files and the retention 
of spot colors in both transparent and non-transparent host separated workflows. DCS 1.0 EPS files are still limited 
to non-transparent host separated workflows in both Illustrator CS3 and CS2 (CS2 and later).

Note: For more information on non-native art, see Importing monotone, duotone, and tritone images from Adobe PDF 
files" in Illustrator CS3, CS2 Help.

Alpha channel transparency

Illustrator CS2 and later preserve spot colors that interact with alpha channel transparency (for example, opacity masks, 
live raster effects, and transparent images). Earlier versions of Illustrator convert spot colors to process colors in these 
scenarios.

Legacy formats

When you save files to Illustrator version 8 or earlier, and select Preserve Appearance and Overprints in the Save dialog 
box, all spot color objects are converted to process color objects.

Text is converted when you export artwork to legacy 
format (Illustrator CS2-CS3)

Issue
 When you save or export artwork to a legacy Illustrator format (that is, Illustrator 10.x or earlier format) in Adobe 
Illustrator CS2-CS3, the text is converted to either individual point text or outlines. 

Solution
 Do one of the following solutions: 

Solution 1: Create and complete the file in Illustrator 10.x or earlier.
 If a project requires you to save or export artwork in a legacy Illustrator format earlier than Illustrator CS, then create 
and complete the file in Illustrator 10.x or earlier. 

Solution 2: Make the text a text block.
 If the text in an Illustrator file was changed to point text, open the legacy Illustrator file and make the text a text block. 

Note: This solution allows you to fix the text problem for documents that have been saved or exported; however, if you 
save or export the document to a legacy Illustrator format again, the text will be converted to point text or outlines. 

To make the text a text block: 

1 Select all the point text and choose Edit > Copy.

2 Select the Text tool and click or click-and-drag then choose Edit > Paste.
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Additional Information
 Illustrator CS introduced a redesigned type technology. Because versions of Illustrator earlier than Illustrator CS aren't 
compatible with most of the technology's features, Illustrator CS3 and CS2 convert the text when exporting artwork to 
a legacy Illustrator format (that is, a format earlier than Illustrator CS). Illustrator converts the text depending on the 
selection you make in the Type panel of the Document Setup dialog: select Preserve Text Appearance to convert text to 
outlines; or select Preserve Text Editability to convert text to individual points. 

Text in Illustrator CS3 and CS2 files saved to the Illustrator CS format will not be converted to point text or outlines 
because Illustrator CS, CS2 and CS3 all use the same type technology. 

Troubleshoot damaged Illustrator files
What's covered

• Beginning and intermediate troubleshooting 

• Advanced troubleshooting 

This document can help you resolve errors caused by damaged Adobe Illustrator files. A damaged Illustrator file may 
cause an error, such as "There is not enough memory to open the Illustration" or "Acrobat PDF File Format is having 
difficulties...," or cause other unexpected behavior (for example, crashes, objects failing to preview) when you modify, 
save, or print artwork in Illustrator. 

To determine if a damaged file is the cause, create a new Illustrator file and perform the same tasks that caused the 
problem with the original file. If you cannot re-create the problem with the new file, the original file may be damaged. 

An Illustrator file may become damaged because of low disk space, low system resources, or software conflicts. In 
addition, if the system returns an error, freezes, or crashes while an application is reading from or writing to disk, the 
open file can become damaged. Working with a file on a network or removable drive increases the likelihood of a 
communication error during the read/write process. 

Beginning and intermediate troubleshooting

 To repair a damaged file, create a backup copy of it on the local hard drive, and then complete one or more of the tasks 
in this section, in order. 

1. Install the latest version of Illustrator.

Updates correct problems that are discovered after an application is released. By installing the latest update, you can 
minimize the possibility that the error is caused by a problem in the application itself. (To determine which version of 
Illustrator you're using, in Illustrator choose Help > About Illustrator.) The latest update for Illustrator is available from 
the Adobe website at www.adobe.com/support/downloads.

• To locate an Authorized Reseller, visit the Adobe website at 
http://partners.adobe.com/resellerfinder/na/findreseller.jsp and choose your country or region from the menu at 
the top of the page.

• To purchase an upgrade from Adobe, visit the Adobe Store at http://store.adobe.com/store and choose your country 
or region from the menu at the top of the page.

• To contact Adobe Customer Service in your region for assistance, visit the Adobe website at www.adobe.com, select 
your region from the menu at the top of the page, and then click Contact Us

2. Copy the file to your hard drive.

http://www.adobe.com/support/downloads/
http://store.adobe.com/store
http://www.adobe.com/
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 If the file is on a network volume or removable disk (for example, diskette, Zip or Jaz disk), copy it to your hard drive 
and open it from there. 

If you purchased Illustrator as part of the Adobe Creative Suite and need to store files on a network drive, install and 
configure the accompanying Version Cue software for saving files directly to a network. For more information on 
Version Cue, see the Adobe Creative Suite product page at www.adobe.com/products/creativesuite . 

3. Place the damaged Illustrator file in a new Illustrator file.

Important: This solution doesn't work if you didn't select Create Compatible PDF File in the Illustrator Native Format 
Options dialog box when you saved the original file. On the Macintosh platform, the damaged Illustrator file may 
appear dimmed in the Place dialog box, but you will still be able to select it and place it in the new Illustrator file. 

1 In Illustrator, choose File > New.

2 Select the appropriate size and color mode, and then click OK.

3 Choose File > Place.

4 In the Place dialog box, choose All Formats from the Files of Type pop-up menu (Windows) or choose All 
Documents from the Show pop-up menu (Mac OS), choose the damaged file, and then click Place.

5 Name and save the file.

4. Copyartwork from a damaged fileinto a new file.

1 Open the damaged file, and then choose Object > Path > Cleanup to remove unwanted items (for example, stray 
points, unpainted objects, empty text paths) from the artwork.

2 If the original file contains multiple layers, choose Paste Remembers Layers from the Layers Panel pop-up menu to 
ensure the artwork appears on the same layers when you paste it into the new file.

3 Using the Selection tool, drag a marquee around the artwork.

4 Choose Edit > Copy.

5 Choose File > New to create a new file.

6 In the new file, choose Edit > Paste In Front to paste the artwork in the correct position on the page.

7 Choose File > Save.

 If the new file exhibits the same behavior, it may contain a damaged object. To determine whether an object is damaged, 
delete it from the new file, and then save and reopen the file and try to re-create the problem. Repeat for each object in 
the file. 

When you can no longer re-create the problem, delete and re-create the damaged object in the original file: 

• If an Illustrator-drawn object is damaged, then re-create the object with the drawing tools in Illustrator. 

• If a linked image is damaged, then re-create the original image, and then replace it in your artwork. 

• If a text object is damaged, then convert the text object to outlines or change its font. 

To quickly change all fonts in a document: 

1 Open the document in Illustrator and Choose Object > Unlock All.

2 Choose Edit > Select All.

3 Choose Type > Font, and select a font not currently used in the document.

Note: To prevent text objects from becoming damaged in the future, reinstall the problematic font from the original 
disk. 

5. Delete unused swatches, custom colors, color groups, brushes, symbols, or styles.

http://www.adobe.com/products/creativesuite
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 Eliminate a problem caused by a damaged swatch, brush, symbol, or style by deleting unused swatches, custom colors, 
color groups (CS3 and later), brushes, symbols, or styles: Choose Select All Unused from the Swatches panel menu, 
from the Brushes panel menu, from the Symbols panel menu, and from the Styles panel menu, and then press Delete. 

Advanced troubleshooting

 The following elements can damage files: corrupt fonts, gradients, patterns, links, and objects (for example, text blocks, 
imported graphics, Illustrator-drawn graphics). If the tasks listed in the previous section don't resolve the problem, you 
may need to repair the file by using one of the following tasks. 

Note: If you repair a damaged file using one of the following tasks, then you lose transparency and layer information. 

6. Check for a damaged pattern, gradient, or custom color.

 To determine if the problem is caused by a damaged pattern, gradient, or custom color: 

1 Choose Edit > Select All and change the fill and stroke to process black.

2 Perform task 4 again to determine whether the problem occurs in a new file that does not contain the patterns, 
gradients, or spot colors. If the problem does not recur, re-create the pattern, gradient, or spot color in the original 
file.

7. Convert the file to an Adobe PDF file.

 If the file is in EPS format, convert the file to PDF in Adobe Acrobat Distiller, and then open the PDF file in Illustrator. 

8. Print the file to disk as a PostScript file.

 Print the Illustrator file as a PostScript file, and then open the PostScript file in Illustrator. 

Note: To perform this solution you must have a PostScript printer driver installed. For information on installing 
Postscript printers in Windows Vista and XP, please see the Windows Help Menus. 

1 Choose File > Print.

2 Specify the desired print or output settings.

3 Choose Adobe Postscript File from the Printer pop up menu, and then click Save.

4 Type a filename that includes a .ps extension (for example, Filename.ps), and then click OK (Windows) or Save (Mac 
OS).

5 Open the PostScript file in Illustrator.

9. Re-create the file in Illustrator.

 Re-create the file in Illustrator after resaving or re-creating graphics, templates, and custom colors used in the original 
Illustrator file. Re-create all elements copied from other Illustrator files. 

Additional Information
kb408008: Copy/Paste of artwork is very slow and/or includes large amounts of unused data, such as swatches 
(Illustrator CS4 and earlier)311742 : Creating Efficient Illustrator Files and Improving Print Performance 

312896 : Memory-Related PostScript Error ("VMerror," "limitcheck") Printing from Illustrator -- Troubleshooting 
Guide 

http://www.adobe.com/go/kb408008
http://helpx.adobe.com/illustrator/kb//cfusion/knowledgebase/index.cfm?id=311742
http://helpx.adobe.com/illustrator/kb//cfusion/knowledgebase/index.cfm?id=312896
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Troubleshoot installation problems (Illustrator CS2, CS3 
on Windows)
What's covered

• Beginning troubleshooting

• Intermediate troubleshooting

• Advanced troubleshooting

This document can help you resolve problems that interrupt the installer for Adobe Illustrator. These problems can 
manifest themselves in many different ways, including (but not limited to) a frozen cursor or screen, or an error.

This document doesn't address problems related to serial numbers. For these problems, contact Adobe Customer 
Services. To contact Adobe Customer Services, visit the Adobe website at www.adobe.com, choose your country or 
region from the pop-up menu at the top of the page, and then click Contact Us.

Many different factors can interrupt the installer of an application, including the Autoplay feature of Windows or an 
application, incorrect data in the Windows registry, and hardware problems. To get the most from this document, 
perform the tasks in order. Keep a log of the tasks you perform and the results of each, including errors or problematic 
behavior. (You can download a log from www.adobe.com/support/pdfs/ts_log.pdf , or you can create your own.) Adobe 
Technical Support can use this information to better assist you, should you need to call.

Beginning troubleshooting

The tasks in this section can help you resolve the most common installation problems. Before performing any of these 
tasks, back up all personal files. Always restart the computer after a system error occurs to refresh its memory. 
Continuing to work without restarting the computer may compound the problem.

1.Make sure that the system meets the minimum requirements for Illustrator.

Illustrator may not install correctly on a system that doesn't meet the requirements for it. The requirements vary, 
depending on the version of Illustrator.

Illustrator CS3

• Intel Pentium 4/5, Centrino, Xeon, Core Duo or compatible processor

• Microsoft Windows XP with Service Pack 2, or Windows Vista Home, Premium, Business, Enterprise, Ultimate 
(Certified for 32-bit editions)

• 1GB RAM or more recommended; 512MB Minimum

• 2GB of available hard-disk space

• DVD drive - Internet or phone connection required for activation

• 1024 x 768 monitor resolution with support for 16-bit or greater video card

• For PostScript printing: Adobe PostScript Level 2 or PostScript 3 printer

Illustrator CS2

• Intel Pentium III or 4 processor

• Microsoft Windows XP with Service Pack 1 or 2, or Windows 2000 with Service Pack 3 or 4

• 256 MB of RAM and 384 MB with Adobe Bridge (512 MB recommended)

• 820 MB of available hard-disk space

• CD-ROM drive

http://www.adobe.com
http://www.adobe.com/support/pdfs/ts_log.pdf
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• 1024 x 768 monitor resolution with support for 16-bit or greater video card

• For PostScript printing: Adobe PostScript Level 2 or PostScript 3 printer

To check how much RAM is installed, choose Start > Settings > Control Panel, and double-click System. The amount 
of RAM is listed on the lower half of the General panel in the System Properties window.

2. Check the installation DVD, CD and DVD, CD-ROM drives.

Dust or dirt on a DVD or CD can interfere with an installation and prevent the DVD or CD-ROM drive from 
recognizing the DVD or CD. Examine the Adobe Illustrator DVD or CD for dirt, dust, or fingerprints. Gently wipe the 
bottom of the DVD or CD from the center outward with a soft, lint-free cloth.

Verify that the DVD or CD-ROM drive can read other DVDs or CDs. If it can't, examine the DVD or CD caddy or 
loading tray for dirt, and clean it with a lint-free cloth. If it still can't read other DVDs or CDs, contact the DVD or CD-
ROM drive manufacturer or the computer manufacturer.

3.Log in as administrator.

The installer requires that you be a member of the Power Users or Administrators group. Log in as an administrator of 
the local machine, or as a user with administrator privileges, and then install Illustrator.

4. Install Illustrator in a new user account.

A user account may be corrupt or have security settings that prevent the installer from working properly. To circumvent 
these issues, create a new user account that has the same permissions as the account that you use, and then install 
Illustrator under the new user account. For instructions on creating a new user account, see "Create a new user account" 
in Windows Help.

5. Install Illustrator from the hard disk instead of theDVD or CD.

Device driver conflicts may prevent Illustrator from installing directly from the DVD or CD. Installing Illustrator from 
setup files copied to the hard disk can prevent conflicts.

To install Illustrator from the hard disk (using the Illustrator DVD or CDs):

1 Insert the Adobe Illustrator DVD or CD into the DVD or CD-ROM drive and press the Shift key for 20 seconds to 
disable AutoPlay. If you release the key too soon and AutoPlay starts, click Quit to exit AutoPlay. (You may need to 
click Next and advance to the next screen to access the Quit button.)Note: If a FilterKeys window appears, release 
the Shift key and click Cancel. FilterKeys is a Windows Accessibility option that displays a dialog box when the right 
Shift key is held down for eight seconds. 

2 Double-click the My Computer icon on the desktop.

3 Right-click the DVD or CD-ROM drive, and choose Explore. (Don't double-click the drive, or AutoPlay will start.)

4 Copy the Adobe Illustrator [version] folder from the Adobe Illustrator DVD or CD to the desktop.

5 Double-click the Setup.exe file in the Adobe Illustrator [version] folder on the desktop, and then follow the on-
screen instructions to complete installation.

To install Illustrator CS3 from the hard disk using the Creative Suite CS3 DVD:

1 Insert the Adobe Creative Suite CS3 installation DVD into the DVD drive.

2 Select US English and then click OK..

3 Click Accept to accept the license agreement..

4 Select Browse DVD Contents..

5 Drag the Creative Suite 3 (Version) folder to the desktop.(Version could be Design, Web, and Standard, or 
Premium).
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6 Double click the Setup.exe file in the Creative Suite 3 (version) folder that you created in Step 5 and then follow the 
on-screen instructions to install the Illustrator CS3 component of the Creative Suite....

To install Illustrator CS2 from the hard disk (using the Adobe Creative Suite 2 CDs):

1 Create a folder on the desktop named "Creative Suite 2".

2 Insert the Adobe Creative Suite 2 CD 1 into the CD-ROM drive.

3 Select US English, and then click OK.

4 Click Accept to accept the license agreement.

5 Select Explore CD Contents.

6 Drag the contents of the CD to the Creative Suite 2 folder you created in step 1.

7 Insert the Adobe Creative Suite CD 3 into the CD-ROM drive.

8 Open the Adobe Creative Suite 2.0 folder on the CD.

9 Drag the Adobe Illustrator CS2 folder on the CD to the Adobe Creative Suite 2.0 folder which is located in the 
Creative Suite 2 folder that you created in step 1:

10 Open the Creative Suite 2.0 folder that resides in the Creative Suite 2 folder on the desktop, double-click Setup.exe, 
and then follow the on-screen instructions to install the Illustrator CS2 component of the Creative Suite.

6. Install Illustrator in Low Resolution or VGA mode.

Device drivers and software that load automatically with Windows (for example, screen savers, virus protection 
utilities) can conflict with the Illustrator installer. To prevent conflicts, reinstall Illustrator while Windows is in VGA 
mode, which disables some nonstandard device drivers.

To install Illustrator in Low Resolution mode in Windows Vista:

1 Choose Start > Run.

2 Type msconfig in the Open text box, and then press OK.

3 Click the Startup tab, click Disable All, and then click OK.

4 In the System Configuration dialog box, click Restart.

5 Press the F8 key as soon as Windows begins loading, and then choose Enable low-resolution video (640 x 480) from 
the list of startup options from the Advanced Boot Options screen and press Enter.

6 Insert the installation DVD or CD (Illustrator) or disk 1 of the installation CDs (Adobe Creative Suite 2) and follow 
the on-screen instructions to install Illustrator.

To install Illustrator in VGA mode in Windows XP:

1 Choose Start > Run.

2 Type msconfig in the Open text box, and then press Enter.

3 Click the Startup tab, click Disable All, and then click OK.

4 In the System Configuration dialog box, click Restart.

5 Press the F8 key as soon as Windows begins loading, and then choose Enable VGA Mode from the list of startup 
options.

6 In the Desktop dialog box, click OK to start Windows.

7 Insert the installation DVD or CD (Illustrator) or disk 1 of the installation CDs (Adobe Creative Suite 2) and follow 
the on-screen instructions to install Illustrator.
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Note: When you install Illustrator in VGA mode, the Next and Accept buttons aren't visible on-screen in the install 
dialog boxes due to reduced screen resolution. Press Enter to advance past these screens.

Intermediate troubleshooting

If the tasks in the previous section don't solve the problem, try the following intermediate troubleshooting tasks.

Before you complete each task in this section, complete the following steps:

Note: These steps free up hard disk space and remove any damaged files (permanent and temporary) that the installer 
needs to overwrite but can't. Normally, the installer removes temporary files after it completes an installation. If 
problems occur, causing temporary files to remain, the installer may return an error the next time you try to install 
Illustrator.

1 Quit all applications.

2 Remove Illustrator.

3 Search for and delete any *.tmp files on your computer.

4 Delete the following items, if present, from the Users\[user profile]\AppData\Local\Temp folder (Windows Vista) 
or Documents and Settings\ [user profile] \Local Settings\Temp folder (Windows XP). 

• Folders: 

• _istmp [x] .dir

• Files: 

• _ins [x] ._mp

• _inst32i.ex_

• _inz [x] ._mp

• _isdel.exe

• _istmp [x] .dir

• _setup.dll

• _setup.lib

• _wutl [x] .dll

• ~ins [x] .~mp

In those files and folders, "[x]" can be any number

7. Install Illustrator to a different hard disk.

Hard disk problems can prevent Illustrator from installing correctly. By installing Illustrator to a different hard disk, 
you can verify if the original hard disk is preventing installation.

8. Repair and defragment hard disks, and then install Illustrator in Low Resolution or VGA mode.

Installation problems can occur if hard disks contain damaged sectors or fragmented files. Repair and defragment hard 
disks by using either the error-checking tool and the Disk Defragmenter utility included with Windows or a third-party 
disk utility, such as Symantec Norton Utilities. You should run such utilities on each hard disk or partition. For 
instructions, see the documentation included with Windows or the utility.

You should run such utilities on each hard disk or partition. After you repair and defragment hard disks, install 
Illustrator in Low Resolution or VGA mode. (For instructions, see task 6.)

Note: Make sure that the disk utility repairs any errors that it detects. If you defragment a disk that contains errors, you 
may lose data. If the utility detects errors that it cannot fix, contact the computer manufacturer for assistance.
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9. Scan the system for viruses.

System viruses can cause erratic behavior and prevent Illustrator from installing. Use current antivirus software (for 
example, Symantec Norton AntiVirus or McAfee VirusScan) to check the system for viruses. Make sure that you have 
the latest virus definitions for the antivirus software you use. Although virus infections are rare, they can cause strange 
system behavior, including system errors. Running virus-detection software regularly prevents viruses from damaging 
software on the system. For instructions, see the documentation for the anti-virus software.

Advanced troubleshooting

If the tasks in the previous section don't resolve the problem, hardware may be conflicting with Illustrator.

10. Try to install Illustrator on a different computer.

Try to install Illustrator on a different computer to determine if the problem is unique to your computer. If the problem 
is unique to the computer, contact the computer manufacturer. If the problem occurs on multiple computers, contact 
Adobe Technical Support.

11. Visit the Adobe User to User Forums.

You can see if other Adobe customers have a similar problem by visiting the User to User Forums at 
www.adobeforums.com . If you confirm that the problem happens on other computers, Adobe Technical Support may 
be able duplicate and research the problem.

Troubleshoot installation problems | Illustrator CS2, CS3 
| Mac OS X
This document can help you resolve problems that interrupt the installer for Adobe Illustrator. These problems can 
manifest themselves in many different ways, including (but not limited to) a frozen cursor or screen, or an error.

This document doesn't address problems related to serial numbers. For these problems, contact Adobe Customer 
Services at 800-833-6687 (US and Canada). For Customer Service in other countries, visit the Adobe website at 
www.adobe.com. Choose your country or region from the menu at the top of the page, and then click Contact Us.

Many different factors can interrupt the installer of an application, including hardware problems or third-party 
software running in the background. To get the most from this document, perform the tasks in order. Keep a log of the 
tasks you perform and the results of each, including errors or problematic behavior. (You can download a log from 
www.adobe.com/support/pdfs/ts_log.pdf, or you can create your own.) Adobe Technical Support can use this 
information to better assist you, if you call.

Beginning and intermediate troubleshooting
The tasks in this section can help you resolve the most common installation problems. Before performing any of these 
tasks, back up all personal files. Always restart the computer after a system error occurs to refresh its memory. 
Continuing to work without restarting the computer can compound the problem.

1. Make sure that the system meets the minimum requirements for Illustrator.
Illustrator can't install correctly on a system that doesn't meet the requirements for it. The requirements vary, 
depending on the version of Illustrator.

Illustrator CS3

• PowerPC G4, or G5, multi-core Intel processors

http://www.adobe.com/support/forums/main.html
http://www.adobe.com
http://www.adobe.com/support/pdfs/ts_log.pdf
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• Mac OS X v10.4.8

• 1 GB of RAM or more recommended; 512 MB minimum

• 2.5 GB of available hard-disk space

• DVD drive - Internet or phone connection required for activation

• 1024 x 768 monitor resolution with support for 16-bit or greater graphics adapter

• For PostScript printing: Adobe PostScript Level 2 or PostScript 3 printer

Illustrator CS2

• PowerPC G4, or G5 processor

• Mac OS X v10.2.8-10.3.8 (Mac OS X v10.3.4-10.3.8 recommended)

• 256 MB of RAM or 384 MB with Adobe Bridge (512 MB recommended)

• 1.2 GB of available hard-disk space

• CD-ROM drive

• 1024 x 768 monitor resolution with support for 16-bit or greater graphics adapter

• For PostScript printing: Adobe PostScript Level 2 or PostScript 3 printer

2. Check the DVD, CD, and CD-ROM drive.
Sometimes dust or dirt on a DVD or CD can interfere with an installation and prevent the DVD or CD-ROM drive 
from recognizing the DVD or CD. Examine the Illustrator DVD or CD for dirt, dust, or fingerprints. Gently wipe the 
bottom of the DVD or CD from the center outward with a soft, lint-free cloth.

Verify that the DVD or CD-ROM drive can read other DVDs or CDs. If it can't, examine the DVD or CD caddy or 
loading tray for dirt and clean it with a lint-free cloth. If it still can't read other DVDs or CDs, contact the DVD or CD-
ROM drive manufacturer or Apple Computer.

3. Install from files copied to the hard disk.
Copy the installer files from the DVD or CD to the hard disk, and then install Illustrator:

To install Illustrator from the hard disk using the Illustrator DVD or CD, do the following:

1 Insert the installer DVD or CD into the DVD or CD-ROM drive.

2 Double-click the DVD or CD.

3 Locate the Adobe Illustrator [Version] folder and copy it to the hard disk.

4 Restart the computer while holding down the Shift key to prevent startup items from opening.

5 Open the Adobe Illustrator [Version] folder you copied to the hard disk, and double-click the Setup file (Illustrator 
CS3), or the Adobe Illustrator CS2.pkg file (Illustrator CS2). Follow the onscreen instructions to install Illustrator.

Note: If the installation fails, leave the Illustrator folder on the hard disk and continue troubleshooting. You can delete 
the folder after you install Illustrator. 

To install Illustrator CS3 from the hard disk using any version of the Creative Suite CS3 DVD media: 

1 Create a disk image of the Creative Suite CS3 Installation DVD on the desktop by using a disk utility, (for example, 
hdiutil or the Apple Disk Utility). Disk images must include a .dmg file extension. (For instructions, see the 
documentation on the Apple web site at www.apple.com/support.)

2 Restart the computer while holding down the Shift key to prevent startup items from opening.

http://www.apple.com/support
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3 Double-click the resulting .dmg file to mount the disk.

4 Double-click the resulting Adobe Creative Suite mounted disk.

5 Double-click the Setup file and follow the on-screen instructions to install the Illustrator component.

To install Illustrator CS2 from the hard disk using the Adobe Creative Suite 2 CDs, do the following:

1 Create disk images of the Adobe Creative Suite installation 1 CD and installation 3 CD on the desktop by using a 
disk utility, (for example, hdiutil or the Apple Disk Utility). Disk images must include a .dmg file extension. (For 
instructions, see the documentation on the Apple web site at www.apple.com/support.)

2 Restart the computer while holding down the Shift key to prevent startup items from opening.

3 Double-click the resulting .dmg files to mount the disks.

4 Double-click the resulting Adobe Creative Suite Disk 1 mounted disk.

5 Double-click the Adobe Installer and follow the onscreen instructions to install the Illustrator component.

4. Repair disk permissions by running Disk Utility.
If you log in to an account with administrator privileges but are still unable to install Illustrator, your disk permissions 
could be damaged.

Repair disk permissions using the Disk Utility:

1 Choose Go > Applications, open the Utilities folder, and then double-click Disk Utility.

2 Select the volume on which you want to install Illustrator.

3 Click the First Aid tab, and then click Repair Disk Permissions.

5. Install Illustrator from within a new user account.
Occasionally, a user account can become corrupted and prevent the installer from accessing or creating the necessary 
files and folders. Create an account, log in to the new account, and then try to install Illustrator.

To create a user account in Mac OS 10.3.x or later, do the following:

1 From the Apple menu, choose System Preferences.

2 Click Accounts.

3 Click the plus sign at the lower-left corner.

4 Type a user name and a password that you can remember, such as test.

5 Click the Security tab, and then select Allow User To Administer This Computer (10.3.x), or just select Allow User 
to Administer This Computer (10.4.x). This optoin makes the test user an administrator.

6 Close the Accounts window.

7 Choose Log Out from the Apple menu.

To create a user account in Mac OS 10.2.8, do the following:

1 From the Apple menu, choose System Preferences.

2 From the View menu, choose Users, and then click New User.

3 Type a user name.

4 Click the Password tab, and then type a password that you can remember, such as test .

5 Select Allow User To Administer This Computer to make the test user an administrator.

6 Click OK and close the Accounts window.

http://www.apple.com/support
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7 Choose Log Out from the Apple menu.

6. Troubleshoot fonts.
Disable all font management utilities and move fonts out of the Fonts folder in the Library folder before installing 
Illustrator.

To move the fonts out of the Fonts folder and install Illustrator, do the following:

1 Drag the contents of the Library/Fonts folder to a new folder on the desktop.

2 In the Finder, choose File > Find.

3 Type AdobeFnt.lst , select the system drive, and then press Return.

4 Delete all AdobeFnt.lst files found.

5 Restart the computer.

6 Install Illustrator, and then continue as follows: 

• If Illustrator installs correctly, then move all the fonts back into the Library/Fonts folder. 

• If Illustrator doesn't install correctly, then move the contents of the [user] /Library/Fonts folder to the folder you 
created on the desktop. 

7. Check hard disks for damage.
A damaged hard disk can cause installation errors. Check hard disks using a disk utility, such as Apple Disk Utility, 
Symantec Norton Utilities, or Micromat Drive 10.

Disclaimer: Adobe doesn't support third-party disk utilities but provides the following instructions as a courtesy. For 
support, contact the developer of the disk utility.

To check for damage by using Apple Disk Utility (included on the system CD), do the following:

1 Start the computer from the system CD.

2 Choose Installer > Open Disk Utility.

3 Select the disks to be checked, and then click the First Aid tab.

4 Click Repair to check and, if necessary, repair selected disks.

8. Scan for viruses.
Use current anti-virus software, such as McAfee Virex or Symantec Norton AntiVirus, to check your system for viruses. 
Make sure that you have the latest virus definitions for the anti-virus software you're using. Although virus infections 
are rare, they can cause strange system behavior, including installation errors. Running virus-detection software 
regularly (for example, daily) prevents viruses from damaging software on your system. For instructions on running or 
obtaining the latest updates to your virus-detection software, see its documentation.

Advanced troubleshooting
If the tasks in the previous section don't resolve the problem, then hardware could be conflicting with Illustrator.

10. Install to a different hard disk designated as the startup disk.
Install the system software to a different hard disk (not a different partition on the same disk) and then select it as the 
startup disk. Then, install Illustrator to the new startup disk.
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To change the startup disk, do the following:

1 Choose System Preferences from the Apple menu.

2 Select Startup Disk from the System selections.

3 Select the drive on which you installed the system software.

4 Restart the computer.

Troubleshoot memory-related PostScript error 
("VMerror," "limitcheck") printing from Illustrator (CS3-
CS2)

Issue
 When you print an Adobe Illustrator document to a PostScript printer, a memory-related PostScript error (for 
example, "VMerror," "limitcheck," "Fatal System Error; OffendingCommand: [varies]") occurs. 

Details
 The printer blinks or begins to print the document, then resets itself before it finishes printing the document, or the 
document prints very slowly or not at all. 

Solution
 Do one or more of the following: 

Solution 1
 Reset the printer's memory by turning the printer or the RIP off, waiting approximately 30 seconds, then turning it 
back on. When printing, some applications download preparation files that occupy printer memory. Clearing the 
printer's memory after printing from an application that downloads a printer preparation file ensures the maximum 
amount of memory is available for printing. 

Solution 2
 If the document includes downloadable fonts, manually download the outline (printer) fonts to the printer's RAM or 
hard disk, or decrease the number of downloadable fonts used in the document. Instructions for manually 
downloading fonts can be found in the documentation for the download utility. 

Solution 3
 When printing to a desktop printer, reduce the amount of printer memory required by printing with a smaller paper 
size selected in the Page Setup dialog box (for example,Letter instead of Legal). 

Solution 4
 If the document contains gradients, select Compatible Gradient and Gradient Mesh Printing in the Graphics section 
of the Print dialog box. Compatible Gradient Printing enables gradient fills to print more easily to PostScript Level 1 
devices. 
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Solution 5
 Convert gradient fills into masked blends using the Object > Expand command: 

1 Make a backup copy of the document.

2 Select the gradient object, then choose Object > Expand.

3 In the Expand Gradient dialog box, type "255" in the Specify Objects text box, then click OK.

Solution 6
 Reduce the number of steps used in blended objects to make them less complex. 

Solution 7
 Simplify the patterns used in the document (for example, avoid using blends or fonts in a pattern). 

Solution 8
 Select an object with a pattern fill, then choose Object > Expand as you would do for gradients (for instructions, see 
Solution 5, 6, and 7). 

Solution 9
 Change the stacking order by moving complex elements to the back of the current layer or to a different layer. 
PostScript interpreters image elements from the back layer to the front layer, one layer at a time. When a "VMerror" or 
"limitcheck" error occurs and only a portion of the document prints, the next element or layer that should have printed 
is most likely the element that exceeded the printer's available memory. A printer may have more free memory earlier 
in the print job, so moving complex elements back may help to image such elements. 

Solution 10
 Simplify drawn objects by using the minimum number of points needed to draw the path: Use the Simplify Path tool 
to decrease the number of anchor points in paths, increase the Path Fitting and the Minimum Area in the Tracing 
options of any Live Trace objects, and increase the Fidelity value in the Pencil Tool Preferences dialog box before using 
the Pencil tool. 

Solution 11
 Limit the number of complex elements or simplify complex elements. The offending command included in the 
PostScript error may indicate the type of element causing the PostScript error. To determine which elements are 
complex, see Additional Information. 

Solution 12
 Remove unused styles, brushes, swatches, patterns, custom colors, symbols and gradients: 

Solution 13
 Remove unused graphic styles, brushes, swatches, and symbols . 

To remove unused graphic styles: 

1 Choose Window > Graphic Styles.

2 From the Graphic Styles panel (CS3) or palette (CS2) menu, choose Select All Unused.

3 Click the trash icon at the bottom of the Graphic Styles panel (CS3) or palette (CS2) menu .
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 To remove unused brushes: 

1 Choose Window > Brushes to display the Brushes panel (CS3) or palette (CS2).

2 From the pop-up menu in the Brushes panel (CS3) or palette (CS2), select Select All Unused.

3 Click the trash can icon at the bottom of the Brushes panel (CS3) or palette (CS2).

 To remove unused swatches: 

1 Choose Window > Swatches to display the Swatches panel (CS3) or palette (CS2).

2 From the pop-up menu in the Swatches panel (CS3) or palette (CS2), select Select All Unused.

3 Click the trash can icon at the bottom of the Swatches panel (CS3) or palette (CS2).

 To remove unused symbols: 

1 Choose Window > Symbols to display the Symbols panel (CS3) or palette (CS2).

2 From the pop-up menu in the Symbols panel (CS3) or palette (CS2), select Select All Unused.

3 Click the trash can icon at the bottom of the Symbols panel (CS3) or palette (CS2).

Solution 14
 Delete stray points, unpainted objects, and empty text paths by choosing Object > Path > Cleanup. Make sure all three 
options are selected in the Cleanup dialog box, then click OK. 

Solution 15
 Print at a lower resolution. 

Solution 16
 If you are printing to an imagesetter, then minimize the number of exit server applications (for example, calibration 
software, screening software, error handler software) at the printer. 

Solution 17
 When printing to a Linotronic imagesetter, perform a Disk Restore. When printing to any other imagesetter, delete the 
font cache. Performing a Disk Restore or deleting a font cache frees printer memory. 

Solution 18
 Print to a device that has more printer memory. 

Solution 19
 Simplify your elements in your document by ungrouping elements and nested groups. 

Solution 20
 Avoid using multiple screen rulings, or extremely high or low rulings, in a single document. 

Solution 21
 Make sure you're using the most current printer driver for your printer. Contact your printer manufacturer for 
information about which printer driver you should use or for driver updates. 



41

Last updated 11/12/2015

Solution 22
 If you're printing to a PostScript printer, make sure you're using the correct PostScript Printer Description (PPD) file, 
or use a generic PPD file. 

Solution 23
 Make sure you have plenty of hard disk space available. Print drivers create temporary files when printing, and store 
these files on the computer's hard disk. Adobe recommends that you keep free disk space equivalent to at least three to 
five times the size of the file you're printing. 

Solution 24
 When creating masks and patterns, use a collection of simple shapes, rather than a single complex object. 

Additional Information
 The greater the number or combination of complex effects and elements in a document, the more memory the 
document will require to print. Complex effects and elements include masks, EPS files containing clipping paths, linked 
or embedded raster images, compound paths (e.g., text converted to paths), pattern fills, gradient fills, and mesh 
objects. 

The PostScript errors, "VMerror" or "limitcheck" occur when you print a document whose complexity requires more 
memory than is available at the printer. The type of elements used in an Illustrator document, rather than the 
document's file size, affect how much memory the printer needs to process the document. 

When the printer is unable to return an error because of low memory, printing stops. When the printer has a very small 
amount of memory available, the printer may attempt to print the document using the available memory. Elements are 
then imaged in smaller groups, using the limited memory, resulting in extremely long processing times. The job may 
not print at all, depending on the memory requirements of the remaining elements in the file. 

331742 : Creating Efficient Illustrator Files and Improving Print Performance320318 : Adobe Illustrator Damaged File 
Troubleshooting Guide311742 : Creating Efficient Illustrator Files and Improving Print Performance

Unable to export file to previous Illustrator version | 
Illustrator CS3, CS2

Issue
You can't export an Adobe Illustrator CS3, CS2 file to a previous version of Illustrator.

Solution
Save an Illustrator CS3, CS2 file as a legacy version Illustrator file:

1 Choose File > Save.

2 Choose Adobe Illustrator [*.AI] as the Save As Type (Windows) or Adobe Illustrator Document as the Format (Mac 
OS).

3 Click Save.

http://helpx.adobe.com/illustrator/kb//cfusion/knowledgebase/index.cfm?id=311742
http://helpx.adobe.com/illustrator/kb//cfusion/knowledgebase/index.cfm?id=320318
http://helpx.adobe.com/illustrator/kb//cfusion/knowledgebase/index.cfm?id=311742
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4 Choose a legacy version from the Version menu.

5 Click OK.

Additional information
The text engine in Illustrator CS3 and CS2 requires that you save files in legacy format to work with them in versions 
earlier than CS. You can save Illustrator legacy files compatible with Illustrator 10.x, 9.x, 8.x, 3.x, and Japanese 
Illustrator 3.x from Illustrator CS3 and CS2.

Unknown error |Save, export | Illustrator CS3 | Windows

Issue
When you try to save or export files from Adobe Illustrator CS3 on Windows, the application returns the error "An 
unknown error has occurred."

Solution
Do one or more of the following solutions.

If Microsoft Zune software is installed on your computer, then start with Solution 1 . If Microsoft Zune software is not 
installed on your computer, then skip Solution 1 and start with Solution 2 .

Solution 1: Update or remove Zune software.
If Microsoft Zune software is installed on your computer, then you may have an older version of the Zune software 
which conflicts with Illustrator CS3.

Download the latest version of the Zune software from www.zune.net or choose Check For Updates in the Zune 
software to start the automatic updater.

If the error continues to occur after you have installed the latest version of the Zune software, then remove the Zune 
software and restart your computer.

To remove Zune software, use Add Or Remove Programs (Windows XP) or Programs And Features (Windows Vista) 
in the Control Panel.

Disclaimer: Adobe doesn't support third-party software and provides these procedures as a courtesy only. For further 
assistance with updating or removing Zune software, contact Microsoft.

If the error continues to occur after you have removed Zune software from your computer, then reinstall the Zune 
software and proceed to Solution 2.

Solution 2: Run Illustrator with startup items and non-essential services disabled.
Startup items (which start automatically with Windows) and services (specialized programs that perform functions to 
support other programs) may conflict with Illustrator and cause an "unknown error" message. To determine whether 
a startup item or service is causing the error, disable all startup items and non-essential services before you start 
Illustrator.

http://helpx.adobe.com/illustrator/kb/#main_solution1
http://helpx.adobe.com/illustrator/kb/#main_solution2
http://www.zune.net
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To disable startup items and non-essential services, follow the instructions in one of these TechNotes:

• "Disable startup items and services (Windows XP)" (TechNote kb404984)

• "Restart Windows in a modified mode (Windows Vista)" (TechNote kb404913)

When you have restarted your computer with startup items and non-essential services disabled, open Illustrator and 
try to reproduce the error.

If the error continues to occur, then startup items and services are not the cause, and you can re-enable startup items 
and services.

To re-enable startup items and services:

1 Open the System Configuration utility by doing one of the following:

• Windows XP: Choose Start > Run, type msconfig in the Open text box, and press Enter.

• Windows Vista: Click Start, type msconfig in the Start Search text box, and press Enter.

2 Choose the General tab, and select Normal Startup.

3 Deselect any items that were previously disabled (items that you wrote down in Step 3 of either TechNote kb404984 
or TechNote kb404913).

4 Click OK, and restart your computer for the changes to take effect.

If the error no longer occurs after you have disabled startup items and services, then one of the startup items or services 
is the cause.

To identify the specific startup item or service that is causing the error:

1 Open the System Configuration utility by doing one of the following:

• Windows XP: Choose Start > Run, type msconfig in the Open text box, and press Enter.

• Windows Vista: Click Start, type msconfig in the Start Search text box, and press Enter.

2 Re-enable approximately half of the items that were disabled.

3 Click OK, and then restart your computer for the changes to take effect.

4 Try to reproduce the error in Illustrator. Then do one of the following:

• If the error continues to occur, then open the System Configuration utility and disable half of the most recently 
enabled items.

• If the error no longer occurs, then open the System Configuration utility and re-enable half of the remaining 
items.

5 Go back to Step 3, and continue dividing the items into halves until you have determined which startup item or 
service is causing the error.

6 Once you have isolated the problematic startup item or service, contact its manufacturer for information about 
available updates, or leave it disabled.

Solution 3: Re-create the Illustrator preferences folder.
An "unknown error" message may appear because one of the Illustrator preferences files has become damaged. Follow 
the instructions below to re-create the preferences files.

Warning: When you re-create the preferences files, you will lose any unsaved actions that you created. To save actions 
that you created, choose Save Actions from the Actions palette menu in Illustrator before you follow the instructions 
below. To load your custom actions in Illustrator after you have re-created the preferences folder, choose Load Actions 
from the Actions palette menu.

http://www.adobe.com/go/kb404984
http://www.adobe.com/go/kb404913
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Note: This solution requires you to locate hidden files and hidden folders. By default, Windows Explorer doesn't show 
hidden files or hidden folders. To make these items visible, see "Show hidden files and folders (Windows XP, Vista)" 
(TechNote kb402324).

To re-create the Illustrator preferences files:

1 Close Illustrator.

2 Do one of the following:

• Windows XP: Rename the Adobe Illustrator CS3 Settings folder (for example, to Old Adobe Illustrator CS3 
Settings) in the C:\Documents and Settings\[your user name]\Application Data\Adobe folder.

• Windows Vista: Rename the Adobe Illustrator CS3 Settings folder (for example, to Old Adobe Illustrator CS3 
Settings) in the C:\Users\[your user name]\AppData\Roaming\Adobe folder.

3 Open Illustrator. Illustrator will create new preferences files.

If the error continue to occur, then a damaged preferences file is not the cause. To restore your custom settings, delete 
the new preferences folder and restore the original name of the previous preferences folder.

4. Run Illustrator in a new local administrator account.
Damaged or incorrect permissions in your user account may be causing the "unknown error" message. Create a new 
local administrator account, log on to it, and then run Illustrator while logged on to the new account.

To create a new local administrator account:

• Windows XP: Choose Start > Help And Support and see the article "To add a new user to the computer"; or contact 
your system administrator.

• Windows Vista: See "Create new local administrator account (Windows Vista)" (TechNote kb404912).

Updated DFX/DWG plug-in | Illustrator CS3
This document describes the updated optional DxfDwg.aip plug-in for Illustrator CS3. It also covers installation 
requirements and installation process.

About this DXF/DWG plug-in

This updated plug-in creates layers in Illustrator CS3 that correspond to the layers in the DFX or DWG file and imports 
the objects in the corresponding layer. However, because of differences in the way layers are treated in Illustrator and 
AutoCAD, object stacking order may change after importing a DFX or DWG file with this plug-in.

Install this optional plug-in only if you want to maintain the layer hierarchy while opening a DXFor DWG file in 
Illustrator CS3. This plug-in works for all languages and operating systems that meet the minimum system 
requirements for Adobe Illustrator CS3.

Installation requirements

To use the DWF/DWG plug-in, you must meet these requirements:

• Illustrator CS3 13.0 or greater installed

• Mac OS 1.4.8, Mac OS 10.5, Windows XP with Service Pack 2, or Windows Vista

http://www.adobe.com/go/kb402324
http://www.adobe.com/go/kb404912
http://www.adobe.com/products/illustrator/systemreqs/
http://www.adobe.com/products/illustrator/systemreqs/
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Installation instructions

1 Download the DFX/DWG plugin. 

• For Windows, download DxfDwg.aip.

• For Mac OS, download AiCS3dfx.dmg.

2 Quit Illustrator CS3 if it is running.

3 Mac Only: Mount AiCS3dxf.dmg to access the DxfDwg.aip file.

4 Navigate to the "Illustrator Formats" folder in the Illustrator CS3 installation folder. 

• Default location for Windows: C:\Program Files\Adobe\Adobe Illustrator CS3\Plug-ins\Illustrator Formats

• Default location for Mac OS: /Applications/Adobe Illustrator CS3/Plug-ins/Illustrator Formats

5  Please be aware that the path names might be different on your machine if you have installed a non-English version 
of Illustrator CS3. In this case, please navigate to the appropriate corresponding folder.

6 Remove the existing DxfDwg.aip file from this folder and move it to another folder outside of the Illustrator 
application directory. Renaming the file is not sufficient as Illustrator may attempt to load the file regardless of its 
filename/extension.

7 Copy the new DxfDwg.aip plug-in to the Illustrator Formats folder.

8 Start Illustrator CS3.

ReadMe files

For further details or localized instructions, please see the ReadMe files:

• English: http://www.adobe.com/support/illustrator/ts/documents/kb402977/DxfDwg_AICS3_Plug-in_en.pdf

• French: http://www.adobe.com/support/illustrator/ts/documents/kb402977/DxfDwg_AICS3_Plug-in_fr.pdf

• German: http://www.adobe.com/support/illustrator/ts/documents/kb402977/DxfDwg_AICS3_Plug-in_de.pdf

• Italian: http://www.adobe.com/support/illustrator/ts/documents/kb402977/DxfDwg_AICS3_Plug-in_it.pdf

• Spanish: http://www.adobe.com/support/illustrator/ts/documents/kb402977/DxfDwg_AICS3_Plug-in_es.pdf

• Dutch: http://www.adobe.com/support/illustrator/ts/documents/kb402977/DxfDwg_AICS3_Plug-in_nl.pdf

• Japanese: http://www.adobe.com/support/illustrator/ts/documents/kb402977/DxfDwg_AICS3_Plug-in_ja.pdf

• Danish: http://www.adobe.com/support/illustrator/ts/documents/kb402977/DxfDwg_AICS3_Plug-in_da.pdf

• Swedish: http://www.adobe.com/support/illustrator/ts/documents/kb402977/DxfDwg_AICS3_Plug-in_sv.pdf

• Korean: http://www.adobe.com/support/illustrator/ts/documents/kb402977/DxfDwg_AICS3_Plug-in_kr.pdf

• Chineese: http://www.adobe.com/support/illustrator/ts/documents/kb402977/DxfDwg_AICS3_Plug-in_cn.pdf or 
http://www.adobe.com/support/illustrator/ts/documents/kb402977/DxfDwg_AICS3_Plug-in_tw.pdf

http://www.adobe.com/support/illustrator/ts/documents/kb402977/DxfDwg.aip
http://www.adobe.com/support/illustrator/ts/documents/kb402977/AiCS3dxf.dmg
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