
Allegro PCB Editor: Tips and Tricks 

Product Version: SPB 17.2 
November 2020 



Allegro PCB Editor: Tips and Tricks 

 

Learn more at Cadence Online Support - https://support.cadence.com  

© 2020 Cadence Design Systems, Inc. All rights reserved worldwide Page 2 
 

Copyright Statement 

© 2020 Cadence Design Systems, Inc. All rights reserved worldwide. Cadence and the Cadence logo are registered 
trademarks of Cadence Design Systems, Inc. All others are the property of their respective holders  

https://support.cadence.com/


Allegro PCB Editor: Tips and Tricks 

 

Learn more at Cadence Online Support - https://support.cadence.com  

© 2020 Cadence Design Systems, Inc. All rights reserved worldwide Page 3 
 

Contents 

Purpose ................................................................................................................6 

Audience ..............................................................................................................6 

What SW version was my database saved in? ........................................................6 

Maintaining Custom Menus and Shortcuts ..............................................................6 

Backdrill................................................................................................................6 

Constraint Regions – Shape Voiding.......................................................................7 

Add Shape Header to Visibility Pane.......................................................................8 

Add/Remove Classes to the Visibility Pane .............................................................8 

Add subclasses to the Visibility Pane ......................................................................9 

Display Layer Numerical Sequence in Visibility Pane ............................................. 10 

Customizing Via Labels ....................................................................................... 11 

Copy Shape to Different Layers ............................................................................ 11 

Shape Boundary Editing ...................................................................................... 12 

Voids under SMD Pads........................................................................................ 15 

Component Placement - Dynamic Alignment ......................................................... 15 

Routing - Dynamic Rat Suppression ..................................................................... 16 

Cutting Clines...................................................................................................... 17 

Checking for max stacked via depth ..................................................................... 18 

Assign net to vias ................................................................................................ 19 

Route Cleanup .................................................................................................... 19 

Save and Restore your Canvas settings................................................................ 20 

Reducing mouse clicks and travel......................................................................... 21 

Center display at cursor location........................................................................... 21 

Adding Vias: Use of Space Bar............................................................................. 21 

Adding Vias: “Working Layer” model ..................................................................... 22 

Deleting a via in a stack ....................................................................................... 24 

Add Connect: Single-click execution ..................................................................... 24 

Add Connect: Add a vertex using a Funckey key ................................................... 24 

Add Connect: Prevent null net routing ................................................................... 25 

Add Connect: Toggle Corner ................................................................................ 25 

Add Connect: Add a vertex at cursor location ........................................................ 26 

Changing line width during Add Connect  ............................................................... 26 

Curving the corners ............................................................................................. 26 

Disabling shape fill when shapes become disabled ................................................ 27 

Working in Etch Edit Application Mode .................................................................. 27 

Suppress Rats during Add Connect ...................................................................... 28 

Expand/Contract a shape or void .......................................................................... 28 

Highlight all GND pins on a particular component .................................................. 29 

Slide: Single-click execution ................................................................................. 30 

Moving Components: Single-click execution .......................................................... 30 

Moving Component with Slide Etch option............................................................. 30 

https://support.cadence.com/


Allegro PCB Editor: Tips and Tricks 

 

Learn more at Cadence Online Support - https://support.cadence.com  

© 2020 Cadence Design Systems, Inc. All rights reserved worldwide Page 4 
 

Changing App Modes with Function Key ............................................................... 30 

Changing Active/Alternate Layers using Function Keys in Etch Edit Mode ............... 30 

Deleting Elements using Function Key .................................................................. 31 

Using the Delete by Rectangle command .............................................................. 31 

Rotating a Component using Function key ............................................................ 31 

Mirroring a Component Using Function key ........................................................... 32 

Snapping Using Funckey key ............................................................................... 32 

Creating a “Snap Pick to” Shortcut with Scriptmode +e .......................................... 32 

Mirroring a stationary component (do not move it)  ................................................. 33 

Aligning Components........................................................................................... 33 

Snapping a rat T to a pin/via................................................................................. 33 

Protecting Alias/Function keys.............................................................................. 34 

Extracting single-footprint from PCB Database ...................................................... 34 

Refreshing package symbol instance .................................................................... 34 

Using Mouse Wheel to control interface visibility .................................................... 34 

Aliasing commands to the Middle Mouse Wheel .................................................... 35 

Trimming and Extending Drafting Lines................................................................. 36 

Sliding vias/clines freely into dynamic shape ......................................................... 36 

Variations of a Route Keepout Area ...................................................................... 37 

Replacing padstacks by window selection ............................................................. 37 

Changing Net Names on vias (skill code) .............................................................. 37 

Polygon selection window .................................................................................... 38 

Z-Copy: A powerful utility ..................................................................................... 38 

Enabling offset routing (fabric weave) ................................................................... 40 

Fixing/Unfixing elements in the design .................................................................. 40 

Datatip Display of the Fixed Property .................................................................... 41 

Datatip Options ................................................................................................... 42 

Status Form Traffic Lights .................................................................................... 43 

“Go to” X,Y Location ............................................................................................ 44 

Color Dialog: Open the last used folder ................................................................. 45 

Displaying a layer ................................................................................................ 45 

Invoking Allegro in No OpenGL mode ................................................................... 45 

Displaying properties in the canvas....................................................................... 46 

Suppressing pin-to-pin violations within the same symbol....................................... 47 

Creating a Command Shortcut with Scriptmode +e ................................................ 49 

DFA Dynamics: Controlling spacing bubble resistance ........................................... 50 

“Locked” Property ................................................................................................ 50 

Locating a dynamic shape.................................................................................... 51 

Voiding of GND Clines through GND Plane ........................................................... 51 

How to convert non-Acute angles for shapes to round corners?.............................. 52 

HTML Reports..................................................................................................... 52 

Printing a form using Control+P keys .................................................................... 53 

Adding Text (from a file) ....................................................................................... 54 

Method to renumber all Ref Des from start ............................................................ 55 

Why does the system react slowly when moving a comp? ...................................... 55 

https://support.cadence.com/


Allegro PCB Editor: Tips and Tricks 

 

Learn more at Cadence Online Support - https://support.cadence.com  

© 2020 Cadence Design Systems, Inc. All rights reserved worldwide Page 5 
 

Why does DRC update take hours to run? ............................................................ 55 

Is my database optimized for performance? .......................................................... 55 

Read-only variables ............................................................................................. 56 

BBVIA GAP DRC reporting too many DRCs .......................................................... 58 

Same Net DRCs not being generated ................................................................... 58 

Working with Xnets .............................................................................................. 59 

Gathering Diff Pair ............................................................................................... 60 

Routing a Tandem Diff pair .................................................................................. 61 

Displaying length meter for non-constrained nets................................................... 61 

Constraint Manager ............................................................................................. 62 

Displaying only the failed results........................................................................... 62 

Displaying only the nets that have constraints ....................................................... 63 

Segregating sections of CM with divider lines ........................................................ 63 

Export to Excel .................................................................................................... 64 

Constraint resolution ............................................................................................ 65 

Assigning pins of dummy nets to net classes ......................................................... 66 

Preventing Shorts ................................................................................................ 67 

Suppressing SIGNOISE warnings and error messages .......................................... 67 

Write vs. Save ..................................................................................................... 67 

Autosave the Database........................................................................................ 68 

Reopen command ............................................................................................... 68 

File Management (Artwork, Plots, Log Files, Reports) ............................................ 69 

What is the earliest version of Allegro that can open my database? ........................ 69 

Open File Manager from Allegro ........................................................................... 70 

Looking for a particular pad stack based on holesize?............................................ 70 

Testability → Multiple Probe-Type Support .......................................................... 70 

Drill Legend Support for INCHES and METRIC ..................................................... 71 

Uprev Symbols.................................................................................................... 71 

Troubleshooting: Running Allegro in Safe Mode .................................................... 72 

Tips from Allegro PCB Users................................................................................ 73 

Windows 7: Graphic Issues .................................................................................. 74 

Support............................................................................................................... 74 

Feedback............................................................................................................ 74 

 

  

https://support.cadence.com/


Allegro PCB Editor: Tips and Tricks 

 

Learn more at Cadence Online Support - https://support.cadence.com  

© 2020 Cadence Design Systems, Inc. All rights reserved worldwide Page 6 
 

Purpose  
This document provides tips and tricks for using Allegro PCB Editor. It also covers 

usage and examples to customize the environment to maximize productivity.  

Audience  
This document is intended for Allegro PCB Editor users who wish to maximize the 

performance of Allegro PCB Editor for their environment. It also contains FAQs.  

  

Use the feedback button on Cadence Online Support if you have tips or tricks that you 
would like to contribute.  

What SW version was my database saved in?  

As of release 17.2 S058, the database stores the last program and release the 

database was saved with. Use the command dbstat -l to retrieve this information. For 
the near term, this option is undocumented.  

 

  

Maintaining Custom Menus and Shortcuts  
Questions related to custom menus, especially around the time of new release 

migration comes up often. It is recommended to go through Adding and Appending 
Allegro Menu Items using SKILL.  

Backdrill 
Backdrill can be driven by library data or from the associated parameter form. It’s 

important to know the library driven model will always take priority over the parameter 

entries. How do you know if all via and pin pads in your database have backdrill library 

data? Click the “Details” button as shown below for an assessment. This should be 
done early on to give the library folks time to make the updates.  

 

https://support.cadence.com/
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Constraint Regions – Shape Voiding 
By default, a cline crossing a region boundary will be voided to the larger of the 

inside/outside constraint values. Customers desire what is referred to as vectorized 
behavior where the line to shape spacing follows the explicit rules defined. The user 

preference variable “shape_void_cline_region” can be enabled to change the default 

behavior. 

** Please test out the solution first keeping an eye on potential performance 

degradation.  
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Add Shape Header to Visibility Pane 
Enable the user preference variable “shape_layer_visibility_env” then restart Allegro. 

This will allow you to quickly turn on/off the visibility of shapes by layer or globally.  

 
 

 

Add/Remove Classes to the Visibility Pane 
Add your most frequented classes to the visibility pane by invoking the color dialog – 

Visibility Pane Tab then drag or double click from the “available classes’ section. In the 

example below, Via KO, Route KO and Constraint Region classes were appended to 
the pane header. They are abbreviated to conserve space.  
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If you do not leverage the flowplan/bundle features, you may wish to remove the “Plan” 

column. Following the steps provided above, select “Plan” for the “visible classes” 

section then click the down arrow to remove it. 

 

 

Add subclasses to the Visibility Pane 
Add your most frequented subclasses to the visibility pane by invoking the color dialog – 

Layers tab. Navigate to the subclass then hover over the color swatch followed by a 
“RMB – Add to  Visibility”. In the example below, “Design Outline” is added to the 

Class/Subclass section of the pane. 
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Display Layer Numerical Sequence in Visibility Pane  

If you are having difficulty mapping via labels to actual layer names or simply wish to 

see a numerical order to the stackup, consider enabling the “show layer numbers” 

option in the color dialog. When set, the sequential layer numbers appear in the first 

column of the visibility pane.  
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Customizing Via Labels 
By default, the values associated with BB via labels begin with 1 (layer top) and 

increase sequentially. This may cause confusion as labels may be out of sync with the 

actual layer names. Consider editing the Layer ID field associated with the Cross 

Section Editor. There is a max 3-character limit. 

 

 
Cross Section Editor 

 

 
Custom Via Label 

Copy Shape to Different Layers 
By now I’m sure many of you have used the Z-Copy command to copy shapes across 

layers. Consider a more robust option that involves first selecting a shape (Shape-

Select Shape or Void) then use the RMB button to access the “Copy to Layers” 
command. Select the target class and subclasses then consider the options at the 

bottom of the form; create dynamic shape and retain net. The last step would be to click 

the “Copy” button, sometimes an oversite before clicking “OK” 
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Shape Boundary Editing 
If you’re not already using the Shape Application Mode to edit shape boundaries, this 

section is a must read! The app mode is designed to improve your efficiency in the 
following areas: 

• Slide shape edges with or without corners 

• Corner conversions to round or chamfer 

• Multi-segment sliding 

• Adding of notches 

 

Steps: 

1. Enable the app mode! Setup – Application Modes – Shape Edit 
2. Find filter adjustment – recommend all elements are enabled especially shapes 
3. Choose LMB click and drag behavior 

 

 
4. Add a notch by making 2 clicks on the shape boundary 

 

 
 

https://support.cadence.com/


Allegro PCB Editor: Tips and Tricks 

 

Learn more at Cadence Online Support - https://support.cadence.com  

© 2020 Cadence Design Systems, Inc. All rights reserved worldwide Page 13 
 

5. Slide an edge by holding the LMB button then drag  
 

 
 

6. Convert an orthogonal corner by clicking the vertex location; adjust settings for chamfer 
or round. Note the cursor changes appearance when hovering over corner.  

   
7. Most common question – how do I convert all corners? Hover over shape then use RMB 

to access “Trim Corners” command. 
 

        
 

8. Second most common question – how do I slide an edge with round or chamfered 
corners? Enable the “Extend Selection” option then use LMB drag to slide the edge with 
its associated corners.  
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9. Convert chamfered/rounded corner to orthogonal - adjust the “Click” option to 

“Remove/Extend”. Select a rounded corner to revert to Orthogonal. 
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Voids under SMD Pads   
The padstack supports an Adjacent Layer Keepout field that can be used for this 

application or even drill overshoot. Generally, the librarian controls the adjacent layer 

geometry in the pad definition while the Designer adds the layer depth control via the 

following properties. 

Properties: 

• Adjacent_layer_void_above 

• Adjacent layer_void_below 

• Max adjacent layer count = 8 

 

Benefit: The keepout are associated with the symbol therefore move with it!  

 

Component Placement - Dynamic Alignment   
Consider enabling the Move command option “Dynamic Alignment”. When set, symbols 

can be aligned by its origin or placebound shape edge.  
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Customize the color of the alignment guides by accessing the color dialog – display 

folder.  

Routing - Dynamic Rat Suppression 
When in the Add Connect command, consider enabling the option “auto-blank other 
rats”. The image below shows a cluster of rats, most likely denser conditions exist on 

your board design. 

 
With the auto-blank option enabled, you benefit from the temporary suppression of all 
rat clutter except for the active net you are routing. 

Origin Alignment 

Place_Bound Alignment 
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Cutting Clines   
Two commands located in the Manufacture menu (OK not obvious) that could be 
leveraged to make cuts in your route path.  

1. Manufacture – Drafting – Delete by Rectangle 

• Select the routes you wish to cut 

• Draw the cut rectangle 
 

Hint – follow instructions in the command window if you experience difficultly.  

 
Delete by rectangle 
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2. Manufacture – Drafting – Delete by Line 

• Select the routes you wish to cut 

• Draw a line across the routes 

• Select side of line to make the cut 
 

   
   Draw line                                            Pick side to cut 

Checking for max stacked via depth  
This check requires the “Venture” or “Enterprise” product where advanced DFx checks 

are available. Navigate to the Manufacturing domain then Design for Fabrication 

section. Select the category “holes” then apply the max stacked via count value to the 

Cset. As with other CM domains, apply this section to the Design section 

 

 
 

The image below shows the applying of the Cset 
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Assign net to vias 
Offered previously as a skill app, general and etch edit modes now offer this command 
using the RMB context sensitive menu. Hover over a via(s) then RMB – Assign net to 

via. Refer to options pane for netlist pulldown or select net based element in the 

workspace.  

Route Cleanup  
From non-ideal pad entry, short segments, 90 degree corners or non-arc corners, 

consider the Route Vision Application. First enable the Vision Manager (View – Vision 
Manager) then in the Options Pane, select the “Visions” tab; pick Route Vision from the 

pulldown. Configure your settings then click OK to invoke the command.  
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Save and Restore your Canvas settings 
Allegro offers the flexible to customize the location of the option panes and toolbar 
icons. If for some reason your environment is reset to the Cadence default environment, 

you may want to consider these steps to restore your custom environment. First step 

would be to establish your preferred environment.  

• Save Steps: View – UI Settings – Save Settings then provide name when prompted 

• Restore Steps: View – UI Settings then select name from list 
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Reducing mouse clicks and travel  
Tips to help reduce the number of mouse clicks to travel to the options panel.  

Center display at cursor location 

funckey z  "zoom center; pick -cursor" 

 
Move your cursor to the position that you want to be the center location, and then click 

the z key. 

 

Adding Vias: Use of Space Bar  
Adding a via has traditionally been done with a double-click of the LMB. Using the 

Space Bar can save you several thousand mouse clicks per year. The Space Bar is an 

easy key to click and hence best for adding vias.  
 

funckey " " "pop bbdrill -cursor"  (double quote – space – double quote) 
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Adding Vias: “Working Layer” model   
The Working Layer (WL) model is the recommended method to add conventional or HDI vias.  
 

1. Select your target routing layer from a popup GUI that appears adjacent to the via 
insertion area.    

2. Go into the Add Connect command, and then select “WL” over in the Options Panel. 
3. A pop-up list appears. Enable the layers you want to see each time you pop a via.  
 

 
 

In Add Connect – Select ‘WL” 

 

 
                                                             

Select Target Layer during routing 

What if you wanted to use HDI vias as the priority vias, and use the through-hole as an 
exception? 

 

1. Open Constraint Manager and navigate to the “Physical” domain. 
2. Click on the “Via List” Cell and note the order of the vias. Therefore, via019 is first used 

ahead of the microvias.  
3. Use the down-arrow button to move via019 to the end of the list. 
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4. Add the through-hole via (via019) by selecting the (…) button. This is how we access 
the least preferred vias in the “via list”. 
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Deleting a via in a stack 
 

1. Use Edit → Delete, select the stacked via, and then use the RMB → Split Stack 
command. From the popup list, select the layer pair to delete.  

 

 

        

 

Add Connect: Single-click execution  
In the Etch Edit Application mode, make a single pick on a pin, via or rat to begin using 

Add Connect.  Ensure the “Enable Single Pick Execution” mode is enabled. Access this 

option by RMB → Customize menu.   

  

Add Connect: Add a vertex using a Funckey key  
Instead of using the LMB to add a vertex point during Add Connect, consider using a 
Function Key. You can simply click the X key every time you want to add a vertex during 

routing.   

  

funckey x "pick_to_grid -cursor"  
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Add Connect: Prevent null net routing 
PCB Designers move the mouse a lot faster. It is easy to make a pick in open space 

when the intent is to pick on a pin or a dangling end segment.  

 

1. Set the “acon_disable_nullnet_route variable in the User Preference Editor to prevent 
accidental picks that invoke Add Connect.  

 

 

 

Add Connect: Toggle Corner 
2. During the Add Connect command, use the F2 key to toggle the corners between arc and 

line. 

3. Route one signal and press the F2 key four times to experience dynamic corner behavior.  

 

alias a1 'FORM mini lock_mode Arc;FORM mini lock_direction 45' 

alias a2 'FORM mini lock_mode Arc;FORM mini lock_direction 90' 

alias a3 'FORM mini lock_mode Line;FORM mini lock_direction 45' 

alias a4 'FORM mini lock_mode Line;FORM mini lock_direction 90' 

alias F2 'settoggle CMD a1 a2 a3 a4;$CMD' 
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Add Connect: Add a vertex at cursor location 
Instead of using the LMB to add a vertex point during Add Connect, consider using a 

Function Key. This will save you thousands of mouse picks per year. However, it will 

take some time to get used to.  

 
You can simply click the “X” key every time you want to add a vertex during routing.  

 
funckey x "pick_to_grid -cursor" 

 
Consider other applications such as move components and move text that might also 

leverage this command.  

 

Changing line width during Add Connect  
Not all the line widths are derived from Physical Csets or Regions. Consider creating 

function keys for the typical line widths you use that are not constraint defined. For 

example, the GND net may be defined as 10 mils but you might decide to widen at 

various locations (large pad components). This function key changes the current line 

width to 25 during the ADD Connect command.  

 

funckey 9 form mini acon_line_width 25 

 

Curving the corners  
 

1. Use Slide → Vertex Action → Arc Corner or consider the Auto-Interactive Convert Corner 
command if you wish to convert corners across a larger group of signals.  
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Disabling shape fill when shapes become disabled 
This user preference variable disables the filling of dynamic shapes when these become 

out of date. This may reduce the need to move shapes off the edge of the board outline 

when setting the shape fill mode to “disabled”: 

 

 

Working in Etch Edit Application Mode 
1. When in “Etch Edit” Application Mode, you can: 
 
a) Make a single pick on a pin, via or rat line to begin “Add Connect”  

i) Even move a component by holding down (drag) the LMB and press ESC key to 
release drag 

b) Make a pick on a cline segment to invoke the “slide” command 
c) Easily change the width or fix a cline or segment by hovering over it and then using the 

RMB context menu.  
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Suppress Rats during Add Connect  
Want to de-clutter the screen when routing?  Consider enabling the “Auto-blank other 

rats” option. When enabled, all rats other than the primary ones are suppressed during 

the Add Connect command (Introduced 16.6 QIR6). 

 

Expand/Contract a shape or void 
1. Select “General Edit” Application Mode. 
2. Hover over the boundary of the shape/void or cavity (ensure boundary visibility is enabled 

in the color dialog under the Stack-Up > Conductor folder). 
3. Use the RMB to access the Expand/Contract command. 
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Highlight all GND pins on a particular component 
1. Consider using the “Find by Query” function to locate elements based on qualifiers.  
2. Invoke “Show Element”. 
3. Open the Find Filter and select “Find by Query”. 
4. Select the “Interconnect” tab. 
5. Enable PIN and NET. 
6. In the following example screen, enter U7.* in the PIN field and GND in the net field 

 

Candidate objects are listed, and can be highlighted using the RMB to access 

the “highlight selected objects” command. 
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Slide: Single-click execution  
In Etch Edit Application Mode, make a single pick on a cline segment to slide it.   

 

Moving Components: Single-click execution 
• Select Placement Application Mode. 

• Make a single LMB pick on a component to move it.   
 

Moving Component with Slide Etch option 
Use the ‘Move’ command and enable the option “Slide etch”. Works best with low pin 

count components like resistors.  

Changing App Modes with Function Key  
funckey a "settoggle CMD 'generaledit' 'placementedit' 'etchedit';$CMD" 

 

Changing Active/Alternate Layers using Function Keys in 
Etch Edit Mode  
Increment or decrement the active or alternate layer:  

  

funckey + subclass -+ (use of “+” character to increment active subclass) 

funckey - subclass -- ( use of “-“ character to decrement active subclass) 

funckey a altsubclass -+ (use of “a” character to increment alternate 

subclass)  

 Directly change the active layer:  

  
funckey 1 options subclass TOP funckey 

2 options subclass SIGNAL_2 funckey 3 

options subclass SIGNAL_3 funckey 4 

options subclass SIGNAL_4 funckey 5 

options subclass SIGNAL_5 funckey 6 

options subclass SIGNAL_6 funckey 7 

options subclass SIGNAL_7 funckey 8 

options subclass BOTTOM  
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Another method to change the active subclass is from the RMB:  

  

RMB → Quick Utilities → Change Active Subclass   

  

Note: If you are not in Etch Edit mode, the class must be set to “etch” for the function 

key to operate correctly.  

  

Deleting Elements using Function Key  
This function key is used more than any other one. Pass your cursor over a cline, 

segment, via, text or shape and click “d” to delete it. No click of the mouse. Works on 
multiple selected elements as well. 

  

funckey d "prepopup; pop dyn_option_select @:@Delete"  

  

Using the Delete by Rectangle command 
Use the “Delete by Rectangle” command to make a window cut in a group of clines. 

Access the command from Manufacture → Drafting → Delete By Rectangle. 

 

 

 

Rotating a Component using Function key  

Press the function key R to rotate a component during movement:  

  

funckey r iangle 90  
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Mirroring a Component Using Function key  

Press the function key M to mirror a component during movement:  

  

funckey m "pop mirror"  

  

Snapping Using Funckey key  

• The “snap pick to” RMB menu contains many options. You may want to consider creating 
function keys for the ones you use frequently. A few examples: 

 

funckey f "prepopup;pop dyn_option_select 'Snap pick to@:@Figure'" 

funckey i "prepopup;pop dyn_option_select 'Snap pick to@:@Intersection'"  

funckey c "prepopup;pop dyn_option_select 'Snap pick to@:@Arc/Circle Center'" 

funckey v "prepopup;pop dyn_option_select 'Snap pick to@:@Via'" 

 

 

Creating a “Snap Pick to” Shortcut with Scriptmode +e  

• Type scriptmode +e in the command window.  

• The “e” option is used to echo the Allegro command language to the command window. 

• Perform a snap function and note the command is written to the ‘command window’. 

• Select the command then RMB → Copy. 

• Paste the command after a Funckey key and enclose in double quotes. Example:  
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o Funckey c “pop dyn_option_select 'Snap pick to@:@Arc/Circle Center'” 
 

   
 

Mirroring a stationary component (do not move it) 

While hovering over a symbol, use the RMB and select the Mirror command. 
 

Aligning Components 

1. Window-select a group of components, hover over the “anchor” component, and then use 
the RMB to access the “Align components” command. 

2. The key point with hovering is you must be hovering over an object. Do not hover in 
BLACK SPACE! 

3. Consider the options for equal spacing or compress to DFA spacing.  

 

Snapping a rat T to a pin/via  

While moving a Rat T, try setting rotation point to “Body Center”:  

  

  
 

https://support.cadence.com/


Allegro PCB Editor: Tips and Tricks 

 

Learn more at Cadence Online Support - https://support.cadence.com  

© 2020 Cadence Design Systems, Inc. All rights reserved worldwide Page 34 
 

Protecting Alias/Function keys  

Is there is a way to prevent users from creating aliases that are named the same as 
Cadence aliases, or the ones originated from site admins? 

 

• To protect (for example, read-only) alias/funckey assignments, use the alias_protect 

command. 
 

Usage: 

alias_protect <alias/funckey> 

 

Example: 

• funckey m move 

• alias_protect m 
 
Commands assigned the Alias_Protect option will always win out over similar commands 
sourced from other locations.  

  

Extracting single-footprint from PCB Database 

1. Use the skill command to write out the package symbol data files for a single symbol. 
In the following example, SR0201.dra and SR0201.psm are generated along with the 
respective padstacks. 

2. Enter the following command in the Allegro command window:  
 

skill axlWritePackageFile( car(axlSelectByName("SYMTYPE" "SR0201"))-

>definition) 

 

Refreshing package symbol instance 

1. Select Placement Edit App Mode. 
2. Hover over package symbol, and then use the RMB to access the “Refresh Symbol 

Instance” command. 
 

Using Mouse Wheel to control interface visibility 

Net-Groups are part of the Base Allegro/SIP product line, and provide the user with 

graphical and CM “Objects” that are used to “map” electrical interfaces to physical 
objects the layout designer can easily understand. This mapping provides convenient 

grouping of nets that have similar electric, physical, and spacing route path 

requirements.  
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The following two “button” commands let you use the middle mouse wheel while holding 

the Shift key to ascend or descend the net-group hierarchy: 

 

button Swheel_up interface_vis up 

button Swheel_down interface_vis down 

 

  
Top level View     Byte Lane Level 

Aliasing commands to the Middle Mouse Wheel   

The “button” command can be used to alias the Middle Mouse Wheel to commands. 
Works with SHIFT, CONTROL and SHIFT + CONTROL combinations.   

  

Examples:   

button Swheel_up subclass -+ button 

Swheel_down altsubclass -+ button 

Cwheel_up "roam y -$roamInc" button 
Cwheel_down "roam y $roamInc" button 

SCwheel_up "roam x -$roamInc" button 

SCwheel_down "roam x $roamInc"  
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In Constraint Manager, the experienced designers can use the <Control> Middle Mouse 

Wheel to increase the font size.    

Trimming and Extending Drafting Lines  

Access these commands from Manufacturing → Drafting Menu (This is available from 

one of the QIR’s for SPB 16.6). 

 

Sliding vias/clines freely into dynamic shape 

This variable when set will let you freely slide vias and clines into dynamic shapes. 
Without the variable, you will experience “jumpy” behavior at the boundary. Set the 

“Ignore Dynamic Shapes in Etch Edit” variable.  

 

This has been made a default behavior in 16.6. The variable is now in the User 

Preference editor. 
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Variations of a Route Keepout Area 

• There are a suite of properties that permit exceptions for route keepout areas 
 

o Allow vias - apply the property vias_allowed to KO shape 
o Allow Shapes – apply the property shapes_allowed to KO shape 
o Allow Routes – apply the property routes_allowed to KO shape 

  
 

Replacing padstacks by window selection  

In General Edit Application Mode, window around the set of pins or vias you wish to 
change, and then use the RMB → Symbol Pin or Via → Replace Padstack → Selected 

Instances command.   

 

Changing Net Names on vias (skill code) 

A skill application named “change_net_on_vias.il” is located in your install directory 
share/pcb/examples/skill/cmds. 

1. If not already done, open your allegro.ilinit file (located in your PCBENV dir). 
2. Add this command and then load “change_net_on_vias.il”. 
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3. Enter change_vianet in the command window to launch the application. 
  

Polygon selection window  

If a polygon selection window is desired:  

  

RMB → Selection Set → Select by Polygon   

Z-Copy: A powerful utility   

Creating a Route Keepin area derived from the Board Outline 

  

Create a Route Keepin area derived from the board outline. Most of you might know 

how to do this. There is a handy tip following this short step.  

 
1. Select Edit Z-COPY, and then adjust the options settings as follows: 

 

• Class = ROUTE KEEPIN 

• Subclass = ALL. 

• Enable ‘contract’  

• Enter value of 25 in the Offset field 
 

2. Select the Board Outline to create the Keepin shape. 
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Tip: Z-Copy can be used to target multiple layers in one operation? 

 

If, for example, you wish to create multiple GND planes, the names of the layers may be 
called GND_1, GND_3, GND_5, GND_8, and so on.  

 

3. Select Edit -Z-Copy.  
4. Adjust the options form so that Class = Etch. 
5. Select one of the GND layers.  
6. Edit/backspace the numerical part of the layer, and then enter the wildcard ‘*’ character as 

shown in the following figure.  
7. Set Offset value to 0. 
8. Select the Route Keepin to create the 2 GND planes. 
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Enabling offset routing (fabric weave)  

For routing that requires offset angles (11.3 typical), while in the Add Connect 
command, click the W key to enable the “Route Offset” option.  

 

funckey w "pop flip" 

 

 

 

 

Fixing/Unfixing elements in the design   

Tips to add and remove the Fixed Property.  

  

Quickly unfixing all elements  

 
The quickest method to remove the fixed property from all the elements in the Design is 
to:  

  

1. Click the Unfix Icon.   

  
  

2. RMB → Unfix All.  

  
Figure 5  
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Fixing the location of a symbol 

Mouse over the symbol, and then select the “Fix” command from the context sensitive 

RMB menu.  

  

  
Figure 6  

  

Datatip Display of the Fixed Property  

  

By hovering over it, you can know whether an element is fixed.   

  

  
Figure 7  

  

Configure the datatip setting as shown in the following figure. You might also want to 

enable other symbol-related properties to display in the datatip window. This is done 

from the Setup → Datatip Customization menu. Select Symbol Instance under Object 

Type, and then enable the value “FIXED”.  
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Figure 8  

Datatip Options   

Controls for delay, location and disablement  

 

The User Preference Editor contains hundreds of variables. The “Search” box is a very handy 

mechanism. In this example, when you type in the word “datatip” and click Search, variables to 

delay, locate and disable datatips are available to you.   

  

  
Figure 9  
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The complete set of variables related to Datatips is located in the Display → Datatips 

Category.  

  
Figure 10  

Status Form Traffic Lights   

You can click on the indicators to obtain a report?   

  
Figure 11  
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“Go to” X,Y Location   

Navigate to an X,Y location in the Design  

   

You wish to quickly go to a specific X, Y location in the Design. For example, you want go to the 

location x = 5000, y = 7000.  

  

Adjust your zoom level, and then click on the “P” button located at the base of the 
canvas display. Enter in your coordinates then click “Pick”. 

  

Note: Set application mode as none for this behavior.  

  

  
Figure 12  

 Disabling Custom Color Assignments    

You may inherit a board from another designer or shop and question some of the color 

assignments. One quick method to disable color overrides that might have been applied 
to nets, buses, Diff Pairs is to go into the color form. If you select the “Nets” radio button 

on top, you will see a new button called “Disable Custom Colors”. Select this option to 

revert to “layer-based” coloring.   

  
Figure 13  

https://support.cadence.com/


Allegro PCB Editor: Tips and Tricks 

 

Learn more at Cadence Online Support - https://support.cadence.com  

© 2020 Cadence Design Systems, Inc. All rights reserved worldwide Page 45 
 

Color Dialog: Open the last used folder  

 

Set the “color_lastgroup” variable located in Setup → User Preferences → UI → 

Control_panel.  

  

  
Figure 14  

Displaying a layer   

Click the color swatch box to the left of the subclass to quickly turn layers on/off during a 

command.   

  

 

  

Invoking Allegro in No OpenGL mode   

It might be necessary to run Allegro in No OpenGL mode. For example, hosting a Net 

Meeting. Consider creating a Desktop Shortcut for Allegro.exe with the –noopengl 

option.   

  

  
Figure  15   
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Figure 16  

Displaying properties in the canvas      

Any property attached to an element can be displayed in the canvas. From the Display 
→ Property menu, select the Graphics tab, and then select properties to display from 

the left column. Clicking the Create button writes out the property values and/or the 

respective name to the subclass properties.    
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Figure 17  

  

  

  
Figure 18   

Suppressing pin-to-pin violations within the same symbol      

PCB Designers often use Constraint Regions to suppress pin-to-pin violations within the 

same symbol. The “nodrc_same_sym_pin” property can be applied to the symbol. 

However, did you know it can also be applied to the drawing? Applying it at the drawing 
level has a global impact to all symbols.  

  

1. Go to Edit → Property and then select drawing in the Find by Name field.   

  
Figure 19  

  

2. Select Drawing Select.  I has now moved to the selected objects column.    
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Figure 20  

  

3. Click Apply and then pick nodrc_same_sym_pin from the list.  

  

  
Figure 21  
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Creating a Command Shortcut with Scriptmode +e   

Adding a drawing level property in the previous tip was labor intensive. Now you can create 
a shortcut.  

 

  

1. Enter scriptmode +e in the command window. This echoes the commands you 

enter.  

  
Figure 22  

  

2. Copy all the commands above to a single line.  

3. Separate with semicolons.  

4. Map to a function key. When using multiple commands in a function key or alias, 

put these in double quotes.  

5. funckey e "property edit;setwindow form.find;FORM find name_type 
Drawing;FORM find find_by_name;FORM findname objlist 'Drawing 

Select';FORM findname done"   

6. Click the “e” key, and then press “ENTER” in the command window to launch the 

property editor dialog.  

  

  
Figure 23   
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Scriptmode +i   

 
"scriptmode +i" is a shorthand for "scriptmode +invisible".  

  

Suppose you want to create an alias to toggle end cap display but do not want to see 

the parameter form appear while executing the script, use:   

 

alias ec "scriptmode +i; prmed; FORM prmedit display_enhance toggle; FORM 

prmedit done"  

DFA Dynamics: Controlling spacing bubble resistance   

When placing components to DFA rules, it is difficult to pull back the component when the 

bubble appears.  

  

The resistance can be controlled by the “dfa_pause_level” variable located in User 
Preferences → DFA_DRC. Set it to 0 for no resistance.   

“Locked” Property  

The Locked property was designed for Re-Use modules. However,:  

  

• The property can be applied to a place replicate circuit to prevent accidental 

movement of its members.   
 

• It can also be applied to a package symbol to prevent editing or deletion of the 

assembly outline or other data elements.  

  

Suggestion: Consider applying the locked property to the symbol definition (at the 
library level).  
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Locating a dynamic shape  

A dynamic shape is "out of date" BUT has a "No Etch" status.    

  

You cannot find the shape in question.  It says it is at a particular XY location, on a 
particular layer, but there is nothing there. Turn on the “Boundary” color item for that 

layer to locate the shape outline.  

  
Figure 24  

 

 

Voiding of GND Clines through GND Plane  

Here is the method to auto-void GND sense lines being routed through a GND plane.     

In the following example, a GND net is routed through a GND shape. The 
'void_same_net' property was applied to the cline.    

  

  
Figure 25  
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How to convert non-Acute angles for shapes to round 

corners?  

This feature is available in 16.3. Go to the dynamic shapes parameter and set the Acute angle 

control to "Full Round". Static shapes get the same capability in a future ISR with the 

eap_static_newsmooth env variable.   
 

HTML Reports   

Reports and messages can be displayed in HTLM format when the  

“allegro_html” variable is set. One advantage of using HTML is the ability to search 
through the report.  

  

  
Figure 26  

  

  

  
  

Figure 27  
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Printing a form using Control+P keys 

Did you know Control+P can be used to print a form?  

  

For example, inside the DFA Symbol classification window, press Cntrl+P to open up 

the Print form window, and then click  the "To File" button to save the information to a 

text file.  

 

  
Figure 28 - Control P the click “to file” 
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Figure 29 – Example of file  

 

Adding Text (from a file)  

To add text from a .txt file on disk: 

   

1. Run the add text command:  Add → Text.  

2. Set the desired text options on the Control Panel “Options” tab.  

3. Set the Active class to Board Geometry.   

4. Set the Subclass to Dimension (or any other subclass).  

5. Set Marker Size:    

6. Set Rotation:    

7. Set Text Block:  

8. Set Text Justification:   
9. Position the cursor/LMB at the location that you want the first line of  

     text to start.  

10. RMB and choose: Read from File.  
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Method to renumber all Ref Des from start 

Use the fst_ref_des variable. You must ensure that the refdes digits in the Sequential 
Renaming section of the UI allow for the number of digits in the fst_ref_des variable.  

The variable is located in User Preference → Manufacturing → Silkscreen.  

Why does the system react slowly when moving a comp?  

Most likely because your large pin-count nets are scheduled Min Tree. Add a voltage 

property or RATSNEST_SCHEDULE = POWER_AND_GROUND to large pin-count 

nets like Vcc and GND.     

 

Why does DRC update take hours to run?  

Usually, the slower checking is a result of a large number of constraint areas and/or a 

large number of overlapping constraint areas.  If that is not the case, then it might be the 

larger spacing values that you have to satisfy you high voltage requirements or simply 
fudge values entered as no-ops.  Large-spacing values result in more neighboring items 

being examined for each item being checked.   

 

Note: Review your extra-large spacing values. There could be a value of 999 entered. 

When reduced, DRC update can go from 1 hour to 3 minutes.  

  

Is my database optimized for performance?    

Performance Advisor provides suggestions to increase database performance. The 

command can be run from Tools → Database Check → Performance Advisor.   
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Figure 30  

Read-only variables   

A method for a site administrator to make variables read-only.  

   

Add a “readonly” entry under the respective variable. In the following example, you wish 
to prevent the end user from modifying PSMPATH. The readonly psmpath command is 

added just below the "set psmpath" variable.    

   

  
Figure 31  

   

To verify in Allegro, type readonly at the command line prompt. The window lists 

variables that are read-only.   
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Figure 32  

   

When an attempt is made to change psmpath in the User Preferences Editor, the 

following warning will appear:    

  
Figure 33  
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 BBVIA GAP DRC reporting too many DRCs  

Under normal circumstances, the Buried/Blind vias separated by less than the minimum 
BBVIA gap rule will generate a DRC, no matter how many layers separate them.  A 

drawing level property, BBVIA_SEPARATION, suppresses the DRC if the vias are 

separated by the specified layer span value or more. In the following example, the 

property value of “2” suppresses the DRC on the left side.   

  

  
Figure 34  

Same Net DRCs not being generated  

It is most likely because your “DRC by-layer” setting is set to “False”.  

  

  
Figure 35  
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Working with Xnets  

Create Xnets – Assign Espice models to the discrete devices from the Analyze → SI/EMI Sim  

→ Model Assignment menu.  

 

Prevent Xnets on an Instance basis - Assign the no_xnet_connection property at the 

component level.   

 

Display Xnets – In CM, go to Object → Filter and enable “net” to see the nets of the 

Xnet.  

  

  
Figure 36  

  

Naming Convention – The Xnet name defaults to the net name with the lowest alphanumeric 

character. In the example, L is before S.   

  

Change the Xnet Name 

 

In CM, select the Xnet, and then use RMB → Rename  

  

  
Figure 37  
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Gathering Diff Pair 

Looking for tighter coupling at the gathering location?    

    

Decrease the value of the “padentry_factor” variable located in ETCH category of the 

User Preferences Editor.   

  

  
Figure 38  

  

 

  
Figure 39 – Default  

  

 

      
Figure 40 - Padentry set to 10  
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Routing a Tandem Diff pair  

Pre-route each member as shown in the following figure, and then use Add Connect to 
route as a tandem pair. This assumes a Diff Pair constraint object has been created.   

  

  
Figure 41  

  

  

Displaying length meter for non-constrained nets   

Set the “allegro_etch_length” variable located in User Preference → Route → Connect 

category.  

  

  

  
Figure 42  
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Constraint Manager   

You wish to display propagation delay analysis for unrouted nets in CM. Enable the 
“unrouted” modes in Analyze → Analysis Modes → Options tab.  

 

  
Figure 43  

  

Sorting results from the worst case to best case margin  

 
Double-click Margin Column Header, or RMB → Sort.  

  

  
Figure 44  

  

Displaying only the failed results  

Click Object Header, RMB → Filter, and enable failed only, or simply click on the 

following icon:  
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Displaying only the nets that have constraints 

Click Object Header, RMB → Filter, and enable constrained only, or simply click on the 

following icon: 

  

  
  

Segregating sections of CM with divider lines 

 It, means identifying the transition between buses and matched groups.   
 

1. In CM, go to View → Options → Workbooks → Enable “Object Type Dividers”, or simply 

click on the following icon: 

  

  
  

  
Figure 45  

  

You wish to change a constraint, for example, min line width across a certain layer of all the 

available PCSets.  

Consider working in the “By Layer” worksheet to change the Top layer constraint across 
all the available Csets.  
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Figure 46  

  

   

Export to Excel  

Constraint Manager can export to a native excel spreadsheet (Windows Only & you 

must have Excel installed).  

  

In CM, go to Tools → Excel → Active Worksheet/Workbook.  
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Constraint resolution   

You want to see how the constraint resolves between 2 objects?  

  

Use Display → Constraint, and then window select the 2 elements to obtain spacing 
resolution. Next, select single element for physical resolution.  

  

In the following example, you window selected the two clines of a Diff Pair to obtain 

spacing resolution. The actual measured gap is supplied in the middle section of the 

report.   

   

  
Figure 47  
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Assigning pins of dummy nets to net classes    

In 16.3 (June 2010 ISR), enter the cns_dummy_net command or type helpcmd to get 

the complete Allegro command set.  

  

  
Figure 48  

  
Figure 49  
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 Preventing Shorts  

In Allegro, It is possible to override a DRC with properties.  

1. Make sure that the nets involved do not have the “NO_DRC” property on 
a pin(s).   

2. Make sure there are no invalid “waived DRCs”.  
3. Make sure your DRC modes are enabled. Be especially careful with 

newly-released DRCs (for example, Microvia-based) as those are 
disabled by default.   

4. Run DBDoctor to keep the design in sync and up to date.  
5. Make sure the plane layers in the cross section form agree with the 

artwork control form (negative or positive).  
6. Make sure the padstacks are designed properly; both Antipads and 

thermals.  
7. Include the IPC-D-356 netlist in your Fab Package. Ensure that the 

Fabricator does a netlist to Gerber compare.     

  

Suppressing SIGNOISE warnings and error messages   

To suppress Signoise warning and error messages from appearing in the message 

window, set the ‘set sigsuppress ERROR WARNING’ variable. 

 

Write vs. Save  

You want to save the current board file you are working on as a new name. However, 
you want to keep the current file open using its current name. The “Save As” function 

will make the saved file the active file. 

 

Enter “WRITE” in the command window followed by a design name.  
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Autosave the Database  

Key variables to auto save the database.  

  

 
Figure 51  

Reopen command  

Most people do not know about this convenient command, which does what is says. It 

reopens a design file.   

  

Enter reopen in the command window to reopen the same file.   

  

  
Figure 52  
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File Management (Artwork, Plots, Log Files, Reports)  

Looking to manage your artwork, plots and reports more efficiently? There is a suite of 
variables beginning with ADS, designed to create subdirectories for the common data 

files.   

 

  
Figure 53  

 

 What is the earliest version of Allegro that can open my 

database? 

• The command “Dbstat” will report the Allegro database revision and platform type. 

• Dbstat supports the following file types (extensions): 

• .brd .mdd .cio .sip .mdd .dpf .scf .pad .dra .mcm .psm .ssm .fsm, .bsm 

• Type “Shell” in the Allegro command window to bring up a DOS window 

• Type dbstate <file name> 
 
Example: 
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Open File Manager from Allegro  

Quick method to explore to your working directory: 

  

Tools → Utilities → File Manager   

Looking for a particular pad stack based on holesize?  

There are two methods to obtain a report of library padstacks:    

  

1. Manufacturing → NC → Drill Customization → Library Drill Report  

2. PadDesigner → Reports → Library Drill Report  

 

Sort by column type by placing cursor in one of the cells, and then RMB → Sort by.  

  

  
Figure 54   

Testability → Multiple Probe-Type Support  

The Testprep parameter form supports entries for multiple probe-types. Typically, the names are 

100, 75 and 50 MIL. The names and center-to-center spacing is can be user-defined.   To add a 

row in the form, select a Probe Type cell and RMB → Add. 
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Figure 55  

Drill Legend Support for INCHES and METRIC  

Update your default .dlt file as shown here:    

   
?AlternateUnits "millimeters"  
?ColumnDefinitions '(  
                       ("Figure"      "FIGURE"        7)  
                       ("Holesize"    "SIZE"         15)  

            ("Tolerance"   "Tolerance"    15)  
            ("Holesize2"   "SIZE MM"      15)  

                       ("Tolerance2"   "TOLERANCE MM" 15)  
                       ("PlateStatus" "PLATED"       10)  
                       ("NonStandard" "NONSTANDARD"  15)  
                       ("Quantity"    "QTY"           6)                      

)  

Uprev Symbols   

The uprev_overwrite command can be used to uprev library files to the current 

software revision.  

  

Syntax: uprev_overwrite n where n = *.dra; *.psm; *.ssm 

  

Example: 

In a command window, enter uprev_overwrite *.dra to update all the .dra files to 

the current software level.   

  

For more flexibility in upreving, in a DOS command window, type:  

  
             uprev -help  

  

Note: Be sure to make a backup copy of your library before uprev.  
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Figure 56  

Troubleshooting: Running Allegro in Safe Mode   

Many Allegro programs support the -safe command line option. This starts the 

program without any user customizations or extensions. This can be used as a debug 

mechanism to eliminate user configurations as the cause of the problem with the 
product.   

  

It disables loading at startup:  

  

 local env file (<HOME>/pcbenv/env)  
 cds_site configuration data  
 any user skill code  
 pre-register scripts  
 ini file which stores window size/position information   
 most recent used files (MRU)  
 remembered Windows positions (.geo files)  

  

UNIX: Currently it cannot disable X window resource settings.   

  

In addition, graphic programs support the -noopengl option, which will disable the 

enhanced Graphics based upon OpenGL.  

  

Example: Run an "out of the box" allegro without opengl:   

  

            allegro -safe -noopengl  
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Tips from Allegro PCB Users   

Join the Cadence Community Website and see what other users are saying.  

  

http://www.cadence.com/community/forums/27.aspx?CMP=home  

  

  
Figure 57  
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Windows 7: Graphic Issues  

 

  
  

Try disabling Aero (desktop composition) for Allegro only:  

  

1. Navigate to the executable or shortcut for the program you wish to disable 
desktop composition using Explorer.  

2. Right-click on it, and select Properties.  

3. Select the Compatibility tab and check Disable desktop composition, and then 

click on OK.  

4. As always, ensure your graphic driver is up-to-date.  

 

Support 

Cadence Online Support provides access to support resources, including an extensive 

knowledge base, access to software updates for Cadence products, and the ability to interact 
with Cadence Customer Support. Visit https://support.cadence.com. 

Feedback 

Email comments, questions, and suggestions to content_feedback@cadence.com. 
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