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Agenda

Overview of HFSS

Capabilities and key features

Example measurement comparisons

Cylindrical cavity tutorial

Eigenmode solver

Parametric geometry

Curvilinear elements

Modal frequencies

Q-factors

Field plots

Field calculator
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Overview of HFSS

Full-wave frequency-domain 3-D field solver 

based upon finite element method

Industry-standard accuracy

Adaptive meshing of arbitrary geometry

Fully parametric modeling

Optimization and HPC

Multi-physics via Ansys Workbench

Widely used for RF/microwave design

Antenna design and platform integration

Filters and waveguide structures

Electronic packages and PCBs

Connectors and transitions

EMC/EMI

Radar cross-section

Integrated into Ansys Electronics Desktop

Part of Ansys Electromagnetics Suite
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Recent Capability Additions to HFSS

Base license includes multiple solvers

Frequency-domain 3D finite element solver

Frequency-domain 3D finite element eigenmode solver

Transient finite 3D element solver

Frequency-domain 3D integral equation solver

Frequency-domain FEBI hybrid solver

Frequency-domain 2.5D planar integral equation solver

Linear circuit solver

Base license enables use of 4 processor cores

HPC, Optimetrics, and Distributed Solver licenses increase computing 

capabilities

HFSS offers two different interfaces to same solver to accommodate 

different workflows

3D view (for CAD)

3D Layout view (for ECAD such as Cadence, Mentor Graphics)
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HFSS R19 User Interface within Ansys

Electronics Desktop

Project 
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Properties

Message 
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Progress 

Window
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Editor 
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Frequency-domain FEM Solution Types

Eigenmode solution

Solves for natural resonances of structure 

based on geometry, materials, and boundaries

Provides modal frequencies, unloaded Q-

factors, and fields

Can solve for up to 20 modes at once

Driven solution

Port or incident field used to excite the 

structure

Driven modal method commonly used for 

RF/microwave designs

Driven terminal method commonly used for 

multi-conductor transmission lines (no 

waveguides, symmetry boundaries, or Floquet

ports)

Provides S-parameters and fields
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Adaptive Mesh Algorithm

Tetrahedral mesh automatically generated 

and refined below user-defined electrical 

length

Tetrahedral element shape conforms to 

arbitrary geometries

Iterative algorithm solves fields and refines 

mesh until user-defined convergence 

threshold value is reached

Can be performed for set of user-specified 

frequencies (broadband adaptive meshing)

Driven modal: S-parameter convergence

Eigenmode: Frequency convergence

Produces graded mesh with fine 

discretization only where needed to 

accurately represent field behavior

Efficient use of computational resources

Tunes mesh to capture EM performance
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Mesh Controls

Mesh seeding allows user to directly 

influence initial mesh

Reduce number of adaptive passes

Focus mesh elements in critical areas

Not required for accurate results

Can improve field plots

Seeding radiation boundary can 

improve far-field data

Lambda refinement

Ensures that initial mesh is refined to 

fraction of electrical wavelength

Electrical size depends on solver basis 

order

Zero: /10, First: /3, Second: 2/3, 

Mixed: 2/3
Initial geometric mesh Electrical mesh after 

lambda refinement
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Curvilinear Mesh Elements

Global mesh approximation setting 

for all true surfaces in model

Higher order (curvilinear) elements 

used to represent the geometry

Pulls midpoints of tetrahedra

surfaces to true surface

Pillbox resonator with analytical fR = 

22.950 GHz for TM010 mode

Default setting: 23.269 GHz

Finer segmentation: 23.012 GHz

Curvilinear elements: 22.950 GHz

6024 DOF

1.38% error

6140 DOF

0.03% error

4966 DOF

0.00% error
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Port Excitations for Driven Solutions

Wave ports

2D FEM solver calculates requested number 

of modes (treated as t-line cross-section)

Solves for impedances and propagation 

constants

Supports multiple modes and de-embedding

Simple for closed t-lines

Must allow room for fields of open t-lines

Must touch external boundary or backed by 

conducting object

Lumped ports

User-assigned constant impedance

Uniform electric field on surface

Single TEM mode with no de-embedding

Can be internal to model
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Frequency Sweeps for Driven Solutions

Discrete sweep

Solves adapted mesh at every frequency

Matrix data and fields at every frequency

Fast sweep

Adaptive Lanczos-Padé Sweep (ALPS) solver 

extrapolates rational polynomial function for 

electric field over specified range from center 

frequency field solution

Usually valid over less than 10:1 BW

Matrix data and fields at every frequency

Interpolating sweep

Solves minimum number of frequencies to 

create rational polynomial fit for S-parameters

Useful for very broadband S-parameters

Matrix data at every frequency
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FEM Solvers for Driven Solutions

Direct matrix solver is default technique

Exactly solves matrix equation Ax = b

Multi-frontal sparse matrix solver to find 

inverse of A (LU decomposition)

Solves for all excitations b simultaneously

Iterative matrix solver is optional technique 

for driven solutions

Reduces RAM usage and often runtime

Solves matrix equation Max = Mb where M 

is preconditioner

Begins with initial solution and recursively 

updates solution until tolerance is reached

Iterates for each excitation b

More sensitive to mesh quality, reverts to 

direct solver if it fails to converge
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Boundary Conditions

Can be used to simplify geometry or 

make meshing more efficient

Material properties for surfaces

Finite conductivity (imperfect conductor)

Perfect electric or magnetic conductor

Surface approximations for components

Lumped RLC

Layered impedance

Radiation

Absorbing boundary condition

Perfectly matched layers (PML)

FE-BI boundary

Any object surface that touches the 

background is automatically defined as 

Perfect E (perfect conductor) boundary
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FEM Basis Functions

Basis functions are n-order polynomials that 

describe how E-field varies along mesh elements 

edge, face, or volume

Hierarchical basis functions

Zero or first or second order basis functions

Higher-order elements have increased accuracy but 

more unknowns (6, 20, 45)

Mixed order basis functions

Zero and first and second order basis functions

hp-FEM method refines element order p and element 

size h

Automatically distributes element order based on 

element size to optimize use of resources

Choice of ideal basis function is problem dependent

Mixed order efficiency is comparable to or better than 

best of single order basis functions
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Fields Calculator

Tool for performing math operations 

on saved field data

E, H, J, and Poynting data

Geometric, complex, vector, and 

scalar data

Uses peak phasor representations 

of steady-state fields

Perform operations using model or 

non-model geometry 

Generate numerical, graphical, 

geometrical, or exportable data

Reverse Polish notation

Frequently used expressions can 

be included in user library and 

loaded into any project

Eliminates need to re-create 

expressions used across projects

Data stack

Stack 

operations

Context 

selection

Named 

expressions

Calculator 

functions
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Quality Factor of Eigenmode Solutions

Provided with solution data for each 

requested mode

Obtained from complex frequency

Can also be calculated using fields 

calculator
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Example Comparison with Measurement

Excellent agreement for ADMX cylindrical cavity

HFSS solution includes 12 modes in vicinity of TM010 mode

Blue markers indicate mode with largest form factor at each rod location

Measured and COMSOL results 
(Lyapustin 2015)
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Example Comparison with COMSOL

Model presented by SungWoo Youn at January 2017 Workshop on 

Microwave Cavities and Detectors for Axion Research

Dielectric rod moved from center to wall in 1.5 mm increments

HFSS ResultsYoun 2017
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Other Comparisons with Measurements
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Cylindrical Cavity Example
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Cylindrical Cavity Example

Empty copper cavity

Radius = 21 cm

Height = 100 cm

Expected results for TM010 mode

fR = 546.42 MHz

Q-factor = 61,391 (Li and Jiang, 2006)

Form factor C = 0.69 (Peng et al., 2000)

Form factor C = 0.692 (Stern et al., 2015)
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1: Create HFSS Project

Insert into Electronics Desktop using New
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2: Set Eigenmode Solution Type

Select HFSS > Solution Type > Eigenmode
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3: Set Model Units

Select Modeler > Units > cm
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4: Set Dialog Data Entry Mode

Select Tools > Options > General Options > 3D Modeler > Drawing > Dialog
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5: Set Default Transparency of 0.7

Select Tools > Options > General Options > Display > Rendering
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6: Create Parameterized Cavity

Select Draw > Cylinder
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6: Create Parameterized Cavity

Cavity_rad = 21 cm

Cavity_height = 100 cm
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6: Create Parameterized Cavity

Fit cavity to view using View > Fit All > All Views
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7: Assign Cavity Wall Conductivity

Select cavity in 3D modeler tree and Edit > Extend Selection > All 

Object Faces
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7: Assign Cavity Wall Conductivity

Select HFSS > Boundaries > Assign > Finite Conductivity
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7: Assign Cavity Wall Conductivity

Enter name “cavity_walls” and use default 5.8E7 S/m
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7: Assign Cavity Wall Conductivity

Should have boundary condition as shown here
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8: Apply Curvilinear Mesh Elements

Select cavity in 3D modeler tree and apply curvilinear elements

Select HFSS > Mesh Operations > Assign > Apply Curvilinear Meshing



August 16, 2018 35

8: Apply Curvilinear Mesh Elements

Can also apply curvilinear elements as global setting

Right-click Mesh Operations > Initial Mesh Settings
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9: Add Solution Setup

Select HFSS > Analysis Setup > Add Solution Setup
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9: Add Solution Setup

Enter Minimum frequency = 540 MHz, Number of Modes = 3, Maximum Number 

of Passes = 12, Max Delta Frequency / Pass = 2%, Minimum Passes = 4
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10: Save Project

Select File > Save and save project as “cavity_tutorial.aedt”
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11: Perform Validation Check

Select HFSS > Validation Check

Confirms that required steps to solve model have been performed
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12: Solve Model

Select HFSS > Analyze All
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13: View Solution Data

Select HFSS > Results> Solution Data
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13: View Solution Data

Select Eigenmode Data tab to view modal frequencies and Q-factors

TM010

TM011

TE113
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13: View Solution Data

Select Convergence tab to view adaptive pass information
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13: View Solution Data

Select Profile tab to view run log file (20 sec runtime)
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14: View E-Field Phase Animation

Select XZ and YZ planes in 3D modeler tree and select HFSS > Fields > Plot 

Fields > E > Mag_E
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14: View E-Field Phase Animation

Select Done to create plot of electric field magnitude
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14: View E-Field Phase Animation

Right-click on Mag_E1 plot to animate phasor field
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15: View E-Field Vector Animation

Select XZ and YZ planes in 3D modeler tree and select HFSS > Fields > Plot 

Fields > E > Vector_E
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How to Activate Mode of Interest for Field 

Plots and Calculations

Select HFSS > Fields > Edit Sources
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16: Calculate Form Factor

Open field calculator using HFSS > Fields > Calculator
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16: Calculate Form Factor Assuming 

Uniform Z-directed Magnetic Field

Must use integration by parts

Step 1: Calculate integral of real(Ez)

Quantity > E

Scal? > ScalarZ

Complex > Real

Geometry > Volume > cavity

Integrate, Eval

Step 2: Calculate integral of imag(Ez)

Quantity > E

Scal? > ScalarZ

Complex > Imag

Geometry > Volume > cavity

Integrate, Eval

Step 3: Calculate integral of |E|2

Copy ComplexMag_E to stack

Push

Multiply (*)

Geometry > Volume > cavity

Integrate, Eval

Step 4: Calculate cavity volume

Number -> 1

Geometry > Volume > cavity

Integrate, Eval

Form factor = (1471252+1.82512) / 

(0.13854*225763387957) = 0.692

Can save operations as Named Expression 
which can be evaluated in single step
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Cavity Simulation Results

Good agreement between simulated and analytical results

Quantity Calculation Simulation % Difference

Frequency 546.42 MHz 546.42 MHz 0.00%

Unloaded Q-factor 61,391 61,378 0.02%

Form Factor 0.692 0.692 0.00%

𝑄𝑢 =


2𝑖


