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ANSYS  Workbench  Guide  
  
Introduction  
This  document  serves  as  a  step-by-step  guide  for  conducting  a  Finite  Element  
Analysis  (FEA)  using  ANSYS  Workbench.  It  will  cover  the  use  of  the  simulation  
package  through  the  graphical  user  interface  (GUI).  More  advanced  topics  will  also  
be  briefly  covered.  
  
Aims  and  Objectives  
The  purpose  of  this  document  is  to  provide  step-by-step  instructions  on  how  to  use  
ANSYS  Workbench  through  the  GUI.  Upon  completion,  the  student  should  be  able  
to:  

•   use  symmetry  conditions  to  simplify  a  typical  engineering  problem  
•   perform  a  finite  element  simulation  of  a  typical  engineering  problem  
•   investigate  the  effects  of  certain  variables  that  are  changed  

  
Problem  
In  this  guide,  a  thin  plate  with  a  hole  scenario  will  be  investigated,  as  shown  below.  
  

  
  

Perform  a  stress  analysis  by  determining:  
1.   the  stress  state  at  points  A  and  B  
2.   the  x-component  of  stress  along  line  AC  
3.   the  stress  state  at  points  A  and  B  with  different  variables  applied:  

a.   changing  the  size  of  the  hole  
b.   changing  the  thin  plate  to  a  thick  block  
c.   increasing  the  temperature  of  the  plate  
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Step  1:  Launching  ANSYS  Workbench  
The  ANSYS  installation  has  many  packages  included.  For  this  tutorial,  we  will  be  
using  ANSYS  Workbench.  

•   Start menu > ANSYS 15.0 > Workbench 15.0 
  
The  Workbench  Project  Window  will  open.  
  

  
  
Step  2:  Pre-processing  (Setting  up  the  Model)  
Our  analysis  is  a  Static  Structural  analysis.  It  can  be  found  in  the  Toolbox  on  the  left,  
and  needs  to  be  added  to  the  Project  Schematic  by  either  double  clicking  it,  or  
dragging  it  into  the  pane.  
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The  Static  Structural  component  and  all  of  its  modules  will  be  created.  The  modules  
are  similar  to  those  in  ANSYS  MAPDL.  They  outline  the  steps  that  are  required  to  
complete  a  finite  element  analysis.  

•   Engineering  Data  module  is  used  to  define  the  material  properties.  
•   Geometry  module  opens  the  DesignModeler  application,  which  can  be  used  
to  import  CAD  models  from  other  software  like  SolidWorks  or  to  sketch  a  new  
2D  or  3D  geometry.  

•   Model,  Setup,  Solution,  and  Results  modules  opens  the  Mechanical  
application,  which  can  be  used  to  set  up  and  solve  the  simulation  (includes  
meshing,  load  and  boundary  condition  applications,  solving,  and  results).  

  
Step  2A:  Engineering  Data  
Double-click  Engineering  Data.  What  you  see  in  this  window  may  differ  from  the  
screenshot  below.  In  here,  you  can  add  a  new  material  by  defining  a  new  material  
entry  for  Mild  Steel.  We  want  to  define  the  material  as  an  isotropic  elastic  one.  
  

  
  

•   “Outline” pane > “Click here to add a new material” > 
Type “Mild Steel” 

•   “Toolbox” pane > Linear Elastic > Isotropic Elasticity 
(double-click) 

  
Two  yellow  boxes  will  appear  in  the  Properties  pane.  In  ANSYS  Workbench,  yellow  
boxes  indicate  values  that  must  be  entered  before  continuing.  In  this  case,  enter  in  
the  Young’s  Modulus  (in  Pa)  and  Poisson’s  Ratio  for  Mild  Steel  (find  values  for  these  
yourself  in  textbooks  or  in  articles).  
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Exit  Engineering  Data  by  closing  the  tab  at  the  top  of  the  window  and  return  to  the  
main  Project.  
  
Step  2B:  Geometry  
By  default,  ANSYS  Workbench  will  analyse  the  problem  in  3D.  In  this  problem,  we  
are  modelling  a  plane  stress  scenario,  which  allows  us  to  reduce  the  analysis  down  
to  a  2D  problem.  
  

•   Static Structural system > Geometry (right-click) > 
Properties > “Properties” pane > Advanced Geometry 
Options > Analysis Type > “2D” 

  
Enter  the  DesignModeler  application  by  double-clicking  on  the  Geometry  module.  
  
DesignModeler  is  similar  to  a  CAD  program.  Here  you  can  work  with  the  model  and  
create  sketches  by  clicking  on  the  tabs  on  the  left.  
  

  
  
The  aim  here  is  to  draw  a  square  with  a  circle  cut-out  on  the  XYPlane  that  will  
become  a  model  of  the  plate  with  a  hole.  To  take  advantage  of  the  symmetry  of  the  
model,  we  can  model  just  one-quarter  of  the  square  and  remove  a  quarter  circle  on  
one  of  the  corners.  
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To  model  a  1m  x  1m  square,  with  the  origin  at  the  bottom  left  corner:  
  

•   “Modeling” tab > A: Static Structural > XYPlane (right-
click) > Look At 

•   “Sketching” tab > Draw > Rectangle > Draw a rectangle in 
the graphics window 

•   “Sketching” tab > Dimensions > General > Click on 
horizontal line of rectangle > Click again to set 
dimension 

•   Details > Dimension > H1 > Type “1” 
•   “Sketching” tab > Dimensions > General > Click on 

vertical line of rectangle > Click again to set dimension 
•   Details > Dimension > V2 > Type “1” 
•   “Sketching” tab > Constraints > Coincident > Click on Y 

axis > Click on left edge of rectangle 
•   “Sketching” tab > Constraints > Coincident > Click on X 

axis > Click on bottom edge of rectangle 
•   Back to “Modeling” tab 

  

  
  
Notice  that  a  new  sketch  is  now  visible  under  the  XYPlane  category.  This  sketch  
does  not  constitute  a  body  or  surface.  We  need  to  define  a  surface  from  it.  
  

•   Concept (top menu bar) > Surfaces from Sketches 
•   “Modeling” tab > A: Static Structural > XYPlane > Sketch1 
•   “Details” pane > Base Objects > Apply 
•   Click “Generate” 

  
We  now  need  to  create  a  circle  to  Boolean  subtract  from  the  square.  First  we  need  to  
freeze  the  square  to  tell  ANSYS  not  to  make  any  further  changes  to  the  square  
sketch.  
  

•   Tools (top menu bar) > Freeze 
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Now  go  back  to  the  XYPlane  and  add  a  new  sketch.  
  

  
  
In  this  sketch,  draw  a  circle  centred  at  the  origin  (by  using  the  coincident  constraints)  
and  a  radius  of  0.2m  (by  using  the  general  dimension  tool).  Create  a  surface  from  
this  sketch  and  generate  it.  
  

  
  
You  can  now  subtract  the  circle  from  the  square:  
  

•   Create (top menu bar) > Boolean 
•   “Details” pane > Operation > Subtract 
•   Target bodies > Select the square > Apply 
•   Tool bodies > Select the circle > Apply 
•   Generate 
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DesignModeler  is  linked  with  the  Project  Window,  so  no  saves  are  required  from  this  
window.  However,  it’s  a  good  idea  to  save  your  project  at  this  point  from  the  Project  
Window.  Workbench  will  save  a  .wbpj  file  and  a  separate  folder.  Keep  these  together  
when  moving  the  project  around.  
  
Close  the  DesignModeler  window  to  return  to  the  Project  Window.  
  
Step  2C:  Model  
Enter  the  Mechanical  application  by  double-clicking  on  the  
Model  module.  At  this  point,  Workbench  should  attach  the  
geometry  that  was  made  in  DesignModeler  and  make  it  
available  in  the  Mechanical  application,  where  we  will  
complete  the  configuration  of  this  simulation  and  solve  it.  
  
At  this  point,  notice  that  the  Mechanical  application  has  
two  panes  on  the  left:  “Outline”  and  “Details”.  The  Outline  
pane  contains  a  tree  with  all  the  settings  you  add  to  the  
model.  The  Details  pane  will  provide  options  for  each  of  
these  settings  that  you  can  change.  
  
After  configuring  Workbench  to  run  this  Static  Structural  
simulation  in  2D,  the  Mechanical  application  allows  for  the  
use  of  various  2D  assumptions,  including  the  plane  stress  
and  plane  strain  assumptions.  For  plane  stress,  a  
thickness  will  need  to  be  defined,  as  it  is  needed  to  
calculate  the  strain  in  the  z  direction.  
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•   “Outline” pane > Model > Geometry 
•   “Details” pane > Definition > 2D Behavior > “Plane 

Stress” 
•   “Outline” pane > Model > Geometry > Surface Body 
•   “Details” pane > Definition > Thickness > Type “0.1” 

  
You  may  also  specify  a  material  for  each  geometrical  body  in  your  simulation.  
  

•   “Outline” pane > Model > Geometry > Surface Body 
•   “Details” pane > Material > Assignment > “Mild Steel” 

  
Similar  to  that  of  ANSYS  MAPDL,  meshing  will  discretise  the  model  into  elements  
and  nodes  that  will  resemble  the  geometry.  The  arrangement  of  these  elements  and  
nodes  is  known  as  a  mesh.  As  you  may  have  figured  out  from  Assignment  1,  the  
mesh  can  have  an  effect  on  the  results  of  the  analysis.  A  finer  mesh  typically  gives  
more  accurate  results,  but  at  the  cost  of  higher  computational  requirements.  Other  
mesh  factors,  such  as  shape,  element  order  and  distribution,  may  also  influence  the  
accuracy  of  your  results.  
  
In  this  example,  we  will  set  all  the  elements  to  be  triangles,  as  this  will  conform  to  the  
geometry.  The  sizing  will  be  set  to  0.1m  in  this  tutorial,  however  this  will  not  be  small  
enough  to  make  your  simulation  accurate  enough.  You  should  change  this  number  
yourself  to  evaluate  the  effect  of  element  size  on  your  results.  
  

•   “Outline” pane > Model > Mesh (right-click) > Insert > 
Method > Click on body > “Details” pane > Scope > 
Geometry > Apply 

•   “Details” pane > Definition > Method > “Triangles” 
•   “Outline” pane > Model > Mesh (right-click) > Insert > 

Sizing > Click on body > “Details” pane > Scope > 
Geometry > Apply 

•   “Details” pane > Definition > Element Size > Type “0.1” 
•   “Outline” pane > Model > Mesh (right-click) > Generate 

Mesh 
  
Workbench  provides  different  selection  tools  that  will  allow  you  to  select  vertices,  
edges,  faces,  and  bodies.  To  switch  between  these,  use  the  buttons  at  the  top  of  the  
screen.  You  also  have  the  option  to  interact  directly  with  the  geometry  or  the  mesh  
by  using  the  dropdown  menu  for  Select  Type  (Geometry/Mesh).  
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The  next  step  is  to  apply  the  necessary  boundary  conditions  and  loads  to  the  model.  
The  1MPa  stress  on  the  right  edge  as  well  as  the  symmetry  conditions  will  be  
defined:  
  

•   “Outline” pane > Model > Static Structural (right-click) 
> Insert > Pressure > Click on right edge > “Details” 
pane > Scope > Geometry > Apply 

•   “Details” pane > Definition > Magnitude > Type “-1e6” 
•   “Outline” pane > Model (right-click) > Insert > Symmetry 
•   “Outline” pane > Model > Symmetry (right-click) > Insert 

> Symmetry Region > Click on left edge > “Details” pane > 
Scope > Geometry > Apply 

•   “Details” pane > Definition > Symmetry Normal > “X Axis” 
  
An  alternative  method  for  inserting  the  symmetry  condition  is  by  defining  the  the  x-
component  of  displacement  to  be  equal  to  zero  for  the  left  edge.  Either  method  can  
be  used  and  will  have  the  same  effect.  
  

•   “Outline” pane > Model > Static Structural (right-click) 
> Insert > Displacement > Click on left edge > “Details” 
pane > Scope > Geometry > Apply 

•   “Details” pane > Definition > X Component > Type “0” 
  
You  will  need  to  apply  the  symmetry  condition  for  the  bottom  edge  yourself  in  a  
similar  fashion  with  the  appropriate  adjustments  for  the  direction  of  symmetry.  
  
The  results  of  interest  may  be  configured  before  solving  the  model.  A  variety  of  
stress  results  may  be  visualised  in  the  form  of  contours  on  the  geometry.  It  is  
important  to  note  that  the  scale  of  the  legend  affects  the  visualisation  of  the  contours.  
This  scale  must  be  consistent  when  comparing  plots  of  the  same  parameter.  
  
To  obtain  the  x-component  of  normal  stress  and  the  shear  stress  in  the  x-y  plane  
over  the  entire  geometry:  
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•   “Outline” pane > Model > Static Structural > Solution 
(right-click) > Insert > Stress > Normal 

•   “Details” pane > Definition > Orientation > “X Axis” 
•   “Outline” pane > Model > Static Structural > Solution 

(right-click) > Insert > Stress > Shear 
•   “Details” pane > Definition > Orientation > “XY Plane” 

  
You  will  also  need  to  add  the  y-component  of  stress  in  order  to  fully  determine  the  
stress  state  of  the  model.  Add  this  yourself.  
  
So  far,  the  stress  components  will  provide  values  for  the  entire  geometry.  You  may  
be  interested  in  determining  the  stress  along  a  line,  or  at  a  single  point.  To  do  this,  
add  a  new  stress  component  yourself.  Next,  you  will  have  to  associate  that  stress  
component  with  an  edge  or  a  point  (remember  to  change  the  selection  tool  first):  
  

•   “Details” pane > Scope > Geometry > Click on the edge or 
point > Apply 

  
If  you  defined  a  stress  component  for  an  edge,  you  can  also  Convert  to  a  Path  
Result  to  produce  a  table  and  graph  of  the  stress  values  along  the  edge.  Pay  
attention  to  the  direction  of  the  path,  as  it  has  been  defined  from  1  to  2  in  the  
graphics  window.  
  

•   “Outline” pane > Model > Static Structural > Solution > 
Right-click on the stress component associated with an 
edge > Convert to Path Result 

  
To  solve  the  model,  click  on  Solve  at  the  top  of  the  screen.  After  solving,  you  can  
then  view  the  results  by  clicking  on  the  items  under  Solution  in  the  tree.  
  
Miscellaneous:  Thermal  Loading  
A  thermal  load  can  be  added  to  the  model  from  within  Static  Structural.  
  
The  thermal  properties  must  be  specified  in  the  Engineering  Data  module.  In  addition  
to  the  Young’s  modulus  and  Poisson’s  ratio,  you  will  need  to  add  an  Isotropic  Secant  
Coefficient  of  Thermal  Expansion.  This  requires  both  an  expansion  coefficient  and  a  
reference  temperature.  Enter  this  in  yourself.  After  exiting  the  Engineering  Data  
module,  remember  to  update  your  project.  
  
Back  in  the  Mechanical  application,  we  will  need  to  define  the  environment  
temperature  and  the  thermal  condition.  Set  the  environment  temperature  to  the  
reference  temperature.  The  thermal  condition  will  depend  on  the  reference  
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temperature.  For  example,  if  your  reference  temperature  is  25  degrees,  and  your  
temperature  increases  by  25  degrees,  your  magnitude  should  be  50  degrees.  
  

•   “Outline” pane > Model > Static Structural 
•   “Details” pane > Environment Temperature > Enter 

reference temperature 
•   “Outline” pane > Model > Static Structural (right-click) 

> Insert > Thermal Condition > Click on body > “Details” 
pane > Scope > Geometry > Apply 

•   “Details” pane > Definition > Magnitude > Enter value 
  
Note  that  what  has  been  described  here  will  not  be  enough  for  you  to  complete  the  
question  in  the  assignment.  You  will  need  to  add  the  appropriate  boundary  
conditions.  
  
Miscellaneous:  Parametric  Studies  
The  procedure  is  demonstrated  below  for  a  parametric  temperature  change.  You  can  
create  a  similar  set  up  for  varying  other  inputs,  such  as  the  radius  of  the  hole.  
  
In  order  to  run  multiple  simulations  over  a  design  space  without  manually  setting  up  
separate  simulation  files,  you  can  set  any  input  as  a  parameter  by  changing  the  box  
next  to  it.  A  “P”  will  show  up  in  the  box.  
  

  
  
This  will  tell  Workbench  to  iterate  this  input  parameter  according  to  the  design  space  
now  available  in  the  Project  window.  
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Double  clicking  Parameters  will  create  a  new  view  with  the  Table  of  Design  Points.  
You  can  add  as  many  design  points  to  the  table  as  you  want.  Note  that  you  will  also  
need  to  tell  Workbench  what  output  value  to  export  as  you  vary  the  design.  This  can  
be  done  by  parametising  the  corresponding  result  (checking  the  appropriate  result  
box  to  show  “P”).  
  

  
  
Finally,  click  Update  All  Design  Points  to  obtain  all  solutions  over  your  design  space.  


