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Welcome to Arena Basic Edition

What is Arena Basic Edition?

Arena Basic Edition software lets you bring the power of modeling and simulation to 

business process improvement. It is designed primarily for newcomers to simulation and 

serves as an introductory product and foundation to the rest of the Arena product family. 

Typically, any process that can be described by means of a flowchart can be simulated 

with Arena Basic Edition.

Arena Basic Edition is most effective when analyzing business, service, or simple (non-

material-handling intensive) manufacturing processes or flows. 

Typical scenarios include: 

� Documenting, visualizing, and demonstrating the dynamics of a process with 

animation

� Predicting system performance based on key metrics such as costs, throughput, cycle 

times, and utilizations

� Identifying process bottlenecks such as queue build ups and over-utilization of 

resources

� Planning staff, equipment, or material requirements

In addition to the Arena Basic Edition, Rockwell Automation offers a full suite of prod-

ucts to provide enterprise-wide simulation, optimization, and 3D model animation.

Intended audience

The Arena Basic Edition is designed for business consultants, business analysts, and 

engineers. It can be widely deployed as a desktop tool and can serve as a natural extension 

to those who use various flowcharting packages such as Visio® to document business 

processes. 

We assume that you are familiar with the basic concepts and terms used in these types of 

systems. You are interested in improving business or manufacturing productivity and are 

responsible for evaluating and predicting the impact of proposed strategic and tactical 

changes to help improve performance. A familiarity with computers and the Microsoft® 

Windows® operating system is assumed. A familiarity with the concepts and terms used 

in simulation is also helpful.
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Where can I go for help?

Our commitment to your success starts with the suite of learning aids and assistance we 

provide for Arena. Whether you’re new to simulation or a seasoned veteran putting a new 

tool to use, you’ll quickly feel at home with the Arena Basic Edition.

Reference the user’s guides

The documentation set includes this manual, Arena Basic Edition User’s Guide, which 

covers the product basics in an easy, “click-by-click” tutorial for modeling and analyzing 

a discrete manufacturing process. In addition, the Variables Guide is a separate reference 

booklet providing complete descriptions of Arena variables found in the Arena product 

templates.

DOCUMENT CONVENTIONS 

Throughout the guides, a number of style conventions are used to help identify material. 

New terms and concepts may be emphasized by use of italics or bold; file menu paths are 

in bold with a (>) separating the entries (e.g., go to Help > Arena Help); text you are 

asked to type is shown in Courier Bold (e.g., in this field, type Work Week), and dialog 

box and window button names are shown in bold (e.g., click OK). 

Explore our examples

Arena is accompanied by a number of sample models that illustrate many of the com-

monly used approaches for capturing the essence of manufacturing processes. Examples 

are provided for both job shop and flow shop environments. For a description of and list 

of Arena’s examples, go to Help > Arena Help. On the Contents tab, choose Model 

Building Basics, and then select Viewing Arena Example Models.

Get help

Online help is always at your fingertips! Arena incorporates the latest in help features, 

including What’s This? help that displays a brief description of fields in dialogs, context-

sensitive help on menu and toolbar buttons, and a help button on each of Arena’s modules. 

Just refer to the Arena help table of contents and index for a list of all help topics.

Use the Smarts library

As you craft models of your own manufacturing processes, use our Smarts library to 

explore how to best use Arena. This suite of tutorial models covers topics ranging from 

modeling resources to animation techniques. The library is organized into categories to 

help you find the right model with ease. When you’re wondering how to take the next step 

in your model, browse the Smarts library for a ready-made solution. For a list of 

categories and their related Smarts, go to Help > Arena Help. On the Contents tab, first 

click Model Building Basics, and then Learning Arena with Smart Files.
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Access the Arena Symbol Factory

Arena animations can be enhanced using Arena Symbol Factory’s extensive library of 

symbols. These symbols can be used for entity, resource, transporter, or global pictures or 

as graphic symbols within a model window. You can copy these symbols directly to the 

Arena model window, add them to your own libraries (.plb files), or add them to any of 

the Arena picture library files.

Get phone support

Rockwell Automation provides full support for the entire Arena family of products. 

Questions concerning installation, how modules work, the use of the model editor, and the 

use of the software are handled by technical support.

ARENA TECHNICAL SUPPORT INCLUDES:

� (for users on active maintenance) a technical support hotline and e-mail address 

staffed by full-time, experienced professionals

� help with installation problems or questions related to the software’s requirements

� troubleshooting

� limited support regarding the interaction of Arena with other programs

� support of the Arena Object Model, which is used in Microsoft Visual Basic for 

Applications

If you call the support line (1.440.646.3434), be at your computer and be prepared to give 

the following information:

� the product serial number 

� the product version number

� the operating system you are using

� the exact wording of any messages that appeared on your screen

� a description of what happened and what you were doing when the problem occurred

� a description of how you tried to solve the problem

Get Web support

In addition to phone support, the Rockwell Automation Customer Support Center offers 

extensive online knowledgebases of tech notes and frequently asked questions for support 

of non-urgent issues. These databases are updated daily by our support specialists. Go to 

http://www.rockwellautomation.com/support/ to sign up for online support.

Once you have signed up for online support you can elect to receive regular e-mail 

messages with links to the latest tech notes, software updates, and firmware updates for 

the products that are of interest to you. You can also submit online support requests.
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And be sure to check the Arena User Zone section of our Web site at www.ArenaSimula-

tion.com. The User Zone links to a peer-to-peer forum on Arena topics and has a link to a 

download page where you can check for possible software updates (patches). If you can’t 

find the answer you need, contact your local representative or Arena technical support.

Get training

Do you need training? Rockwell Automation offers a standard training course comprised 

of lecture and hands-on workshops designed to introduce you to the fundamental concepts 

of modeling with Arena. 

We also offer customized training courses designed to meet your specific needs. These 

courses can be held in our offices or yours, and we can accommodate one person or 

twenty. You design the course that’s right for you! Simply contact our consulting services 

group to discuss how we can help you achieve success in your simulation efforts.

Get consulting services

Rockwell Automation provides expert consulting and turnkey implementation of Arena 

Basic Edition and the entire Arena product suite. Please contact our offices for more infor-

mation.

Contact us

We strive to help all of our customers become successful in their manufacturing improve-

ment efforts. Toward this objective, we invite you to contact your local representative or 

Rockwell Automation at any time that we may be of service to you. 

Support E-mail: Arena-Support@ra.rockwell.com

Corporate E-mail: Arena-Info@ra.rockwell.com

Support phone: 1.440.646.3434

URL: www.ArenaSimulation.com

URL: www.RockwellAutomation.com
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Getting Started

Introduction

While you may not realize it quite yet, you now have the power to transform your 

business. Whenever you and others in your organization are wondering “what if…?,” you 

can look into the future to find the answer. 

With Arena, you can: 

� Model your processes to define, document, and communicate.

� Simulate the future performance of your system to understand complex relationships 

and identify opportunities for improvement.

� Visualize your operations with dynamic animation graphics.

� Analyze how your system will perform in its “as-is” configuration and under a myriad 

of possible “to-be” alternatives so that you can confidently choose the best way to run 

your business.

Our task: Analyze a home mortgage application process

In this chapter, we will examine a simple mortgage application process to illustrate how 

you can model, simulate, visualize, and analyze with Arena. To begin, we’ll look at the 

process of receiving and reviewing a home mortgage application. We will build the flow-

chart shown below, introducing you to the process of modeling and simulating with 

Arena.
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The Arena modeling environment

If Arena is not already running, start it from the Windows Start menu and navigate to 

Programs > Rockwell Software > Arena. The Arena modeling environment will open 

with a new model window, as shown below.

To model your process in Arena, you’ll work in three main regions of the application 

window. The Project Bar hosts panels with the primary types of objects that you will work 

with:

� Basic Process panel: Contain the modeling shapes, called modules, that you’ll use to 

define your process. 

� Reports panel: Contains the reports that are available for displaying results of simula-

tion runs.

� Navigate panel: Allows you to display different views of your model, including 

navigating through hierarchical submodels and displaying a model thumbnail.

Model window 
flowchart view

Model window 
spreadsheet view

Project Bar

The Project Bar 
usually is docked at 
the left of the Arena 
application window, 

but can tear off or 
dock at another 
position just like 

any toolbar.

ArenaBE.book  Page 6  Wednesday, April 28, 2010  4:31 PM



2 • GETTING STARTED

7

•  •  •  •  •

2 • G
ettin

g
 S
tarte

d

In the model window, there are two main regions. The flowchart view will contain all of 

your model graphics, including the process flowchart, animation, and other drawing 

elements. The lower, spreadsheet view displays model data, such as times, costs, and other 

parameters.

As we model the mortgage application process, we’ll work in all three of these regions of 

Arena.

Map your process in a flowchart

Let’s start by examining what we’re going to do: Build a flowchart. The word itself—

flowchart—suggests two of the main concepts behind modeling and simulation. We’ll be 

building a chart—also referred to as a process map or a model—that describes a flow. 

This raises a key question in process modeling: What exactly is it that will flow through 

the chart?

We’re modeling the process of reviewing mortgage applications. These mortgage applica-

tions are the items, referred to as entities, that will move through the process steps in our 

model. They are the data, whether on paper or in electronic form, that are associated with 

our client’s request for a mortgage. As we build the flowchart, it’s helpful to think of the 

process from the perspective of the entity (the mortgage application), asking questions like:

� Where do the mortgage applications enter the process?

� What happens to them at each step?

� What resources are needed to complete work?

First, we’ll draw the flowchart representing the mortgage application process. Refer to the 

Mortgage Application Process Flowchart (shown previously) so you’ll know what we’ll 

be creating.

Create the mortgage application entities

We’ll start the flowchart using a Create module, from the Basic Process panel. This is the 

starting point for the flow of entities through the model.

1. Drag the Create module from the Basic Process panel into the model window.

A default name, Create 1, is given to the module when it’s placed. We’ll return later to 

provide a more meaningful description as well as some data to support the simulation.

ArenaBE.book  Page 7  Wednesday, April 28, 2010  4:31 PM



ARENA BASIC EDITION USER’S GUIDE

8

• 
 •

  
• 

 •
  
•

Process the applications

Next in our flowchart is a Process module that represents the Review Application step. 

1. Be sure that the Create module is selected so that Arena will automatically connect the 

Process to the Create module.

2. Drag a Process module from the Basic Process panel into the model window, placing 

it to the right of the Create. Arena will automatically connect the two modules.

As with the Create, the Process module has a default name that we’ll replace later. 

Every process flow 
starts with a 

Create module. 
When you simulate 

the flowchart, 
individual entities 

will be created 
according to timing 

information you 
supply in the 

Create module 
properties. After it’s 
created, each entity 

moves from the 
Create module to 
the next shape in 
the process flow.

If your Create and 
Process were not 
connected auto-

matically when you 
placed the Process, 
check the Object > 

Auto-Connect menu 
to verify that it is 

checked. If it is not, 
select it to turn on 

this option.
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Note: If no connection appears between Create and Process, click the Object > Connect menu 

item or the Connect toolbar button to draw a connection. Your cursor will change to a cross hair. 

Start the connection by clicking the exit point ( ) of the Create module, then click the entry point  
(  ) of the Process module to complete the connection. If you need to make multiple connec-

tions, simply double-click the Connect button or select Object > Connect twice (the Connect 

button will remain depressed to indicate it is in multi-connect mode). Then draw as many connec-

tions as desired. A valid connection target (e.g., entry point, exit point, or operand object) is now 

highlighted during a connection session if the pointer is hovered over it. To end the multi-connec-

tion session, click again on the Connect option, press Esc, or right-click.

How do I use Snap and Grid?

If your flowchart shapes aren’t lining up properly, you can use Arena’s snap and grid 

features to straighten them out. First, check the Snap option on the View menu so that 

newly placed shapes will be positioned at regular snap points. To realign the shapes 

you’ve already placed, select the main module shapes (the yellow boxes) by holding the 

Ctrl key and clicking on each shape. Then, click the Arrange > Snap to Grid menu 

option to adjust their positions to align with grid points.

You can display the grid by checking the Grid option on the View menu. Both snap and 

grid are turned off by clicking on the menu option again, turning off the check box.
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Decide whether applications are complete

After the Process, we have a Decide module which determines whether the mortgage 

application is complete.

1. If you’re using the Auto-Connect feature (i.e., it’s checked on the Object > Auto-

Connect menu), be sure that the Process module is selected so that the Decide module 

will be connected to it.

2. Drag a Decide module to the right of the Process module.

If the mortgage application has a complete set of information, it will leave the Decide 

module from the right side of the diamond shape, representing the True condition. Incom-

plete applications (False result to the Decide test) will leave via the bottom connection.

Dispose the applications to terminate the process

Next we’ll place the Dispose module that represents accepted applications, connecting to 

the True (right) output from the Decide shape. Then, we’ll complete the flowchart with 

another Dispose for returned applications.

1. Select the Decide shape so that our first Dispose will be connected automatically.
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2. Drag a Dispose module to the right of the Decide module. Arena will connect it to the 

primary (True) exit point of the Decide module. (We won’t include a graphic display 

since you’re now familiar with the drag-and-drop sequence.)

3. To add the second Dispose module, once again select the Decide module, so that 

Arena will automatically connect its False exit point to the new Dispose module, and 

drag another Dispose module below and to the right of the Decide module.

4. Drag and drop another Dispose module, placing it below and to the right of the Decide 

shape, completing the process flowchart.

Using modules in Arena Basic Edition

Arena Basic Edition includes all of the modules in the Basic Process panel. If you add a 

module to your model from another template, such as the Advanced Process, Advanced 

Transfer, Blocks, or Elements panels, Arena will go into demonstration mode.

What is a module?

In Arena, modules are the flowchart and data objects that define the process to be 

simulated. All information required to simulate a process is stored in modules.

For now, we’re working with flowchart modules—those that are placed in the model 

window to describe the process. In the Basic Process panel, these are the first eight 

shapes:

� Create: The start of process flow. Entities enter the simulation here.

� Dispose: The end of process flow. Entities are removed from the simulation here.

� Process: An activity, usually performed by one or more resources and requiring some 

time to complete.

� Decide: A branch in process flow. Only one branch is taken.

� Batch: Collect a number of entities before they can continue processing.

� Separate: Duplicate entities for concurrent or parallel processing, or separating a 

previously established batch of entities.

� Assign: Change the value of some parameter (during the simulation), such as the 

entity’s type or a model variable.

� Record: Collect a statistic, such as an entity count or cycle time.

Simulation settings are defined in the Run > Setup > Replication Parameters dialog 

box. There is also a set of data modules for defining the characteristics of various 

process elements, such as resources and queues.

Entity flow always 
begins with a Create 

module and termi-
nates with a Dispose 

module. You may 
have as many of each 

of these modules as 
you need to generate 
entities into the model 

and to remove them 
when their process-

ing is complete.
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Define model data

Now that we’ve drawn the basic flowchart for our mortgage application process, let’s 

define the data associated with the modules, including the name of the module and infor-

mation that will be used when we simulate the process.

Initiate mortgage application (Create module)

First, let’s visit the Create module, which will be named Initiate Mortgage Application. Its 

data will include the type of entity to be created—in our case, a mortgage Application. We 

also need to define how often mortgage applications are initiated. We’ll use an average of 

2 hours between applicants as a starting point for our model, and we’ll make this a 

random activity to represent the natural variation in the timing of mortgage applications 

being submitted.

1. Double-click the Create module to open its property dialog box.

2. In the Name field, type Initiate Mortgage Application. 

3. For the Entity Type, name our entities by typing Application.

4. Type 2 in the Value field of the Time Between Arrivals section.

5. Click OK to close the dialog box.

For now, we’ll leave the default values for the other Create module properties. Feel free to 

explore their purposes through online help or the Arrivals models in the Smarts library.
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Review application (Process module)

Remember that as we create the flowchart, we’re looking at the process from the perspec-

tive of the entity. The Create module is a starting point for an entity’s flow through the 

system being modeled. Next, in our case, the application will be reviewed for complete-

ness by a Mortgage Review Clerk. Because this will take some amount of time, holding 

the entity at this point in the flowchart for a delay and requiring a resource to perform the 

activity, we use a Process module. We’ll call this process Review Application.

For the time delay, we also want to capture the natural variability that exists in most 

processes. Very often, for work done by people or equipment, a triangular distribution 

provides a good approximation. You specify the minimum time in which the work could 

be done, the most likely value for the time delay, and the maximum duration of the process. 

During the simulation run, each time an entity enters the process, Arena will calculate a 

sample from the distribution information you’ve provided—in our case, a triangular 

distribution. Over the course of a long simulation run where thousands of individual 

samples are taken, the times will follow the profile illustrated next.

What are entities?

Entities are the items—customers, documents, parts—that are being served, produced, 

or otherwise acted on by your process. In business processes, they often are documents 

or electronic records (checks, contracts, applications, purchase orders). In service 

systems, entities usually are people (the customers being served in a restaurant, 

hospital, airport, etc.). Manufacturing models typically have some kind of part running 

through the process, whether it’s raw material, a subcomponent, or finished product. 

Other models might have different types of entities, such as data packets in network 

analysis or letters and boxes in package-handling facilities.

You may have different types of entities in the same model. For example, customers 

moving through a check-in counter at an airport might be separated into regular, first-

class, and priority entity types. In some cases, entity types might be of an altogether 

different form rather than classifications of some basic type. For instance, in a pharmacy, 

prescriptions would be modeled as entities, running through the process of being filled. 

At the same time, customers might be competing for the pharmacist’s attention with 

medical inquiries; they would also be modeled as entities. 

Appendix A 
describes the 

distributions 
available in Arena.
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For our Review Application process, we’ll use a minimum time of 1 hour, most likely 

value of 1.75 hours, and a maximum of 3 hours. We will assign a resource, the Mortgage 

Review Clerk, to perform this process.

1. Double-click the Process module to open its property dialog box.

2. In the Name field, type Review    Application. 

3. To define a resource to perform this process, pull down the Action list and select Seize 

Delay Release.

Arriving entities will wait their turn for the resource to be available. When its turn 

comes, the entity will seize the resource, delay for the process time, and then release 

the resource to do other work.

4. A list of resources will appear in the center of the dialog box. To add a resource for 

this process, click Add.

If more than one 
resource is required 
for a process to be 
performed, add as 

many as are 
necessary in the 
Process dialog’s 

Resources list. An 
entity won’t 

commence its 
process delay until 
all listed resources 

are available.
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5. In the Resource Name field of the Resource dialog box, type Mortgage Review 

Clerk.

6. Click OK to close the Resource dialog box.

7. Define the process delay parameters in the Minimum, Value (Most Likely), and 

Maximum fields as 1, 1.75, and 3. (Note that the default delay type is Triangular and 

the default time units are in hours.) 

8. Click OK to close the dialog box.

For now, we’ll leave the default values for the other Process module properties. Feel 

free to explore their purposes through online help or the Basic Concepts and 

Resources models in the Smarts library.

Complete? (Decide module)

After the mortgage application has been reviewed, we determine whether to accept or 

return the application. In Arena, whenever an entity selects among branches in the process 

logic, taking just one of the alternatives, a Decide module is used.

For the mortgage application process, we’ll use a simple probability to determine the 

outcome of the decision, with 88% of applications accepted as complete. 

1. Double-click the Decide module to open its property dialog box.

2. In the Name field, type Complete?. 

When you use a 
2-way Decide 

module, the entity 
that enters the 

module leaves via 
one of the two exit 

points. If you want to 
make copies of an 

entity to model 
parallel processes, 

use a Separate 
module.
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3. For the Percent True field, type 88 to define the percent of entities that will be treated 

with a “True” decision (i.e., will depart through the exit point at the right of the Decide 

module). 

4. Click OK to close the dialog box.

Accepted, Returned (Dispose module)

In our simple process for reviewing mortgage applications, all the work that we’re 

interested in is done. Now, we’ll remove the mortgage applications from the model, 

terminating the process with a Dispose module. Because there are two possible outcomes 

of the mortgage application process—applications can be accepted or returned—we’re 

using two Dispose modules that will count the number of applications under each 

outcome.

1. Double-click the first Dispose module (connected to the True condition branch of the 

Decide module) to open its property dialog box, and in the Name field, type 

Accepted.

2. Click OK to close the dialog box.

3. Double-click the other Dispose module to open its property dialog box. In the Name 

field, type Returned. 
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4. Click OK to close the dialog box.

Mortgage review clerk (Resource module)

Along with our flowchart, we also can define parameters associated with other elements 

of our model, such as resources, entities, queues, etc. For the mortgage process, we’ll 

simply define the cost rate for the Mortgage Review Clerk so that our simulation results 

will report the cost associated with performing this process. The clerk’s costs are fixed at 

$12 per hour.

To provide these parameters to the Arena model, you’ll enter them in the Resources 

spreadsheet. 

1. In the Basic Process panel, click the Resource icon to display the Resources spread-

sheet.

2. Because we defined the Mortgage Review Clerk as the resource in the Review 

Application process, Arena has automatically added a resource with this name in the 

Resources spreadsheet. Click in the Busy/Hour cell and define the cost rate when the 

clerk is busy by typing 12. Click in the Idle/Hour cell and assign the idle cost rate by 

typing 12.

You can edit the 
fields for any 
module using 

Arena’s spread-
sheet, including 

flowchart modules. 
Just click on the 
icon in the Basic 
Process panel to 

display its 
spreadsheet.
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Prepare for the simulation

To make the model ready for simulation, we’ll specify general project information and the 

duration of the simulation run. Since we’re just testing our first-cut model, we’ll perform 

a short, 20-day run. 

1. Open the Project Parameters dialog box by using the Run > Setup menu item and 

clicking the Project Parameters tab. In the Project Title field, type Mortgage 

Review Analysis; we’ll leave the Statistics Collection check boxes as the 

defaults, with Entities, Queues, Resources, and Processes checked and we’ll also 

check the costing box. 

2. Next, click the Replication Parameters tab within the same Run Setup dialog box. In 

the Replication Length field, type 20; and in the Time Units field directly to the right 

of Replication Length, select days from the drop-down list. Click OK to close the 

dialog box.

Save the simulation model

Now that you’ve done some work on your model, it seems like a good time to save it. 

Click Save on the Standard toolbar or select the File > Save menu item. Arena will 

prompt you for a destination folder and file name. Browse to the target folder in which 

you want to save the model (e.g., C:\My Documents) and type a name (e.g., Mortgage 

Review) in the file name field.

Arena’s model files store all of the model definition, including the flowchart, other 

graphics you’ve drawn, and the module data you entered. When you perform a simulation 

run, the results are stored in a database using the same name as the model file.

Simulate the process

With these few, short steps, we are ready to predict the future! The mortgage application 

model contains all of the information needed to run the simulation. 

Start the simulation run by clicking the Go button or clicking the Run > Go menu item. 

Arena first will check to determine whether you’ve defined a valid model, then will 

launch the simulation. 
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As the simulation progresses, you’ll see small entity pictures resembling pages moving 

among the flowchart shapes. Also, a variety of variables change values as entities are 

created and processed, as illustrated below.

If the animation is moving too fast, you can slow it down by adjusting the animation scale 

factor. For this, you have the following choices:

� Open the Run Setup dialog box via the Run > Speed > Animation Speed Factor 

menu item and enter a smaller value (e.g., 0.005) for the scale factor; or

� Use the less-than (<) key during the run to decrease the scale factor by 20%. Be sure 

that the model window is active—not the Navigate panel—or > and < won’t take 

effect. Pressing < repeatedly is an easy way to fine tune the animation speed. The 

greater-than (>) key speeds up animation by 20%.

� Use the slider bar in the main toolbar. Move the slider to the left to slow down the ani-

mation; move the slider to the right to speed up the animation.

To pause the simulation, click the Pause button or press the Esc key. With the automatic 

flowchart animation, you can see how many entities have been created, are currently in 

the Review Application process, have left each branch of our Decide module, and have 

left the model at each of our terminating Dispose modules. These variables can be helpful 

in verifying the model. For example, if the probability in the Decide shape was entered 

incorrectly (e.g., if you typed 12—the rejection probability—instead of 88), the variables 

would show that many more applications were leaving the Returned branch.

If Arena displays an 
error message, you 

can use the Find
button in the error 

window to locate the 
source of the 

problem. You can 
change between the 

error and model 
windows by selecting 

them from the 
Window menu.

Create: Number of Decide: Number of 
entities created entities out each branch

Process: Number of entities 
currently in process

Dispose: Number of 

entities disposed

The animation scale 
factor is the amount 

of simulated time 
between successive 

screen updates. 
Smaller values 

provide smoother, 
slower animation.

If the run finishes 
before you have a 
chance to explore 

these controls, 
answer No when 

you’re asked if you 
want to view the 

results. Then click 
Start Over on the 

Run toolbar to begin 
the run again.
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You also can step through the simulation one event at a time. Pause the simulation, then 

click the Step button or press the F10 key. Each time you step the simulation, an entity is 

moved through the flowchart. Usually, you’ll see animation of the entity’s movement, 

though sometimes no visual change will take place (e.g., when the next event is creating a 

new entity). When this occurs, just step again to move forward to the next event.

View simulation reports

After you’ve watched some of the animated flowchart, you can quickly run to the end of 

the simulation to view reports. Pause the simulation, then click the Fast Forward button 

to run the simulation without updating the animation.

At the end of the run, Arena will ask whether you’d like to view reports. Click Yes, and 

the default report (the Category Overview Report) will be displayed in a report window, 

as shown below. 

On the left side of each report window is a tree listing the types of information available in 

the report. The project name (in our case, Mortgage Review) is listed at the top of the tree, 

followed by an entry for each category of data. This report summarizes the results across 

all replications (although, in this model, we have only one replication). Other reports 

provide detail for each replication.

Each of Arena’s 
reports is 

displayed in its 
own window within 

the Arena 
application. You 

can use the 
standard 

window options 
(maximize, 

minimize, etc.) by 
clicking on the 
window control 

buttons or by 
pulling down the 

window menu.
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By clicking on the entries inside the category sections, you can view various types of 

results from the simulation run. The following table illustrates some of the questions you 

could answer from the Category Overview Report on our simple mortgage application 

process simulation.

After you’ve browsed the Category Overview Report, you can close it by clicking on the 

window icon to the left of the File menu and clicking Close. You can look at other reports 

by clicking on their icons in the Project Bar. Each report will be displayed in its own win-

dow. To return to the model window, close all of the report windows or select the model 

file from the Window menu.

After you have viewed the reports and returned to the model window, end the Arena run 

session by clicking the End button.

Enhance the visualization process

Now that we’ve completed the basic steps for analyzing the mortgage application process, 

we can return to our model and embellish the graphical animation to gain further insight 

into the process dynamics. Animation also can be of great benefit in enticing others in the 

organization to be interested in process improvement.

We’ll add two animation components to the mortgage model. First, we’ll show our 

Mortgage Review Clerk working at a desk, either busy or idle. To gain a better sense of 

how many applications are waiting in the Review Application process over time, we’ll 

also add a dynamic plot of the work-in-process (WIP) simulation variable. Our Arena 

model will appear as shown below after we add these two objects.

Question Report Section Answer

On average, how long did mortgage 

applications spend in the modeled 

process?

Total Time (Entity), Average 

column

16.51 hrs

What was the average cost of reviewing  

a mortgage application?

Total Cost (Entity), Average 

column

$22.99

What was the longest time an application 

spent in review?

Total Time (Process), Maximum 

column

33.45 hrs

What was the maximum number of 

applications waiting for review?

Number Waiting (Queue), 

Maximum column

21 applications

What proportion of time was the 

Mortgage Review Clerk busy?

Utilization (Resource), Average 

column

97%
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Note: You can toggle between the split view (flowchart and spreadsheet) and a full-screen view 

of either area by clicking the Split Screen toolbar button or selecting the View > Split Screen 

menu item. When in full-screen view, clicking the icons on the Basic Process panel displays the 

appropriate view (flowchart for flowchart modules and spreadsheet for data-only modules).
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Animate the mortgage review clerk resource

During the simulation run, our Mortgage Review Clerk resource can be in one of two 

states. If no mortgage application entity is in-process, then the resource is idle. We’ll use a 

picture of a person sitting at a desk to depict idleness. When an entity seizes the resource, 

the Mortgage Review Clerk’s state is changed to busy, in which case our picture will show 

the person reviewing a document.

1. Click the Resource button on the Animate toolbar.

2. The Resource Placement dialog box appears. Select the Mortgage Review Clerk 

from the drop-down list in the Identifier field so that this object animates the 

Mortgage Review Clerk.

3. Open the Workers picture library by clicking the Open button, then browsing to the 

Workers.plb file in the Arena application folder (e.g., C:\Program Files\Rockwell 

Software\Arena) and double-clicking on it.

4. To change the idle picture:

� Click the Idle button in the table on the left.

� Select from the picture library table on the right the picture of the worker sitting 

down.

� Click the Transfer button between the tables to use the worker picture for the Idle 

resource state.

5. To change the busy picture:

� Click the Busy button in the table on the left.

� Select from the picture library table on the right the picture of the worker reading a 

document.

� Click the Transfer button between the tables to use the selected picture when the 

Mortgage Review Clerk is busy.

6. Click OK to close the dialog box. (All other fields can be left with their default values.)

7. The cursor will appear as a cross hair. Move it to the model window and click to place 

the Mortgage Review Clerk resource animation picture. 
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8. If you’d like to have the clerk appear a bit larger, select the picture and use the resize 

handles to enlarge it.

How do I use Rulers and Guides?

Selecting the Rulers command on the View menu toggles horizontal and vertical rulers 

at the top and left edges of each drawing window. The ruler labels display the (+/-) dis-

tance from the origin in Arena world units. The spacing between the ruler labels is based 

on the snap spacing, with the labels rounded to the nearest snap point if Snap to Grid is 

enabled. 

When the Guides command (View menu) is activated, you may add guides into the 

application window to aid in positioning shapes precisely. You may either drag them from 

the horizontal or vertical ruler edges independently or drag them simultaneously from the 

origin corner. If you select a guide, you may drag it to a new position, or you may remove 

it by pressing Delete.

Activating the Glue to Guides command (View menu) allows you to drag a shape (mod-

ule or drawing object) to a guide until the shape selection handle turns red (as shown in 

the circled call-out of the example), which indicates that the shape is “glued” to the guide. 

The guide may then be dragged to a new location and all shapes glued to the guide will 

maintain their alignment and will move with the guide.

Rulers

Guides

Glue to Guides

ArenaBE.book  Page 24  Wednesday, April 28, 2010  4:31 PM



2 • GETTING STARTED

25

•  •  •  •  •

2 • G
ettin

g
 S
tarte

d

Plot the number of applications in-process

Our second animation enhancement is a plot of how many mortgage applications are 

under review as the simulation progresses. This will give us a sense of the dynamics of the 

workload, which can vary quite a bit when the random nature of processes is incorporated 

into a simulated model.

1. Click the Plot button on the Animate toolbar.

2. The Plot dialog box appears. We’ll plot a single expression, the work-in-process 

(WIP) at the Review Application process. To add a data series to a plot, go to the Data 

Series tab page and then click the Add button.

3. In the properties grid for the data series (by default it will be named ‘Series1’), go to 

the Source Data\Expression property. This property defines the simulation expression 

to monitor and plot. Type in the expression ‘Review Application.WIP’. 

4. Now go to the Axes tab page and select the Left (Y) Value axis. Change the scale-

related properties for that axis to be as listed below (leaving the default for any prop-

erty not specifically mentioned). 
 
Specify the value ‘5’ for the Scale\MajorIncrement property, so that major tick marks 

on the y-axis are displayed over 5 units. 

5. Now select the horizontal Time (X) axis. Change the scale-related properties for that 

axis to be as listed below (leaving the default for any property not specifically men-

tioned). 
 
Specify the value ‘480’ for the Scale\Maximum property. This sets the horizontal time 

axis of the plot to be 480 hours of simulated time, matching our run length. 
Specify the value ‘48’ for the Scale\MajorIncrement property, so that the major tick 

marks on the x-axis are displayed every 48 hours (or 2 days).

6. Click OK to close the Plot dialog.

7. The cursor changes to a cross hair. Draw the plot in the model window by clicking to 

locate each of the two opposite corners (e.g., the top-left and bottom-right corners), 

placing the plot below the flowchart and to the right of the resource.

You can plot many 
expressions on the 

same set of axes by 
adding multiple 

expressions in the 
Plot dialog. Each can 

be color-coded so 
that you can readily 
compare data such 

as workloads in 
processes, waiting 

customers, etc.
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With the edits complete, you may want to save them by clicking Save or pressing Ctrl+S.

Rerun the simulation

Now that we’ve made our animation more interesting and valuable, let’s run the simula-

tion again. Because we didn’t change any of the process parameters (i.e., data in the  
modules), the simulation will provide the same results. 

Click Run (or press the F5 key) to start the simulation. As the simulation progresses, 

you’ll notice the Mortgage Review Clerk’s picture change from idle (sitting at the desk) to 

busy (reading a document) and back again, as mortgage application entities move through 

the Review Application process.

The plot shows some significant peaks in the number of applications that are under review, 

caused by the combination of the variation in the time between arrivals of applications 

(defined in the Create module) and the time to process applications (Process module). 

What is a model thumbnail?

The Navigate panel on the Project Bar provides a model navigation tree for maneuvering 

through the different named views and hierarchical levels defined in the model. Included 

as part of the Navigate panel is a model thumbnail that helps users orient and change the 

current view within the active drawing window.

The thumbnail displays the world space of the current drawing window. A colored, 

translucent rectangle represents the current view's boundaries. Dragging the rectangle in 

the thumbnail moves the drawing window's current view left, right, up, or down; however, 

the rectangle may not be dragged outside the boundaries of the world space. 

You may also re-center the rectangle, and thus the world space, or change the level of 

zoom. For details on model thumbnail, see the Navigate Panel topic in online help.
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Next steps

You’ve succeeded in modeling, simulating, visualizing, and analyzing a simple mortgage 

application process. To further explore Arena’s capabilities, try solving a few of these 

extensions to the process.

1. Add a screening process before the application is reviewed. 

Applications can be screened in as little as 15 minutes. Most often, it takes about 25 

minutes for the screening, though sometimes it can require as much as 45 minutes. 

Assign a Receptionist (rate of $6.75/hour) to perform the screening. What proportion 

of the Receptionist’s time will be used in this task?

2. Return some applications to the mortgage applicants after the screening process.

On completion of the screening, 8% of the applications are returned. Also, because 

many of the deficient applications are caught in the new screening, the percentage of 

applications that are accepted in the formal review is raised from 88% to 94%, and the 

Mortgage Review process time is reduced by 10%. By how much did the cost of 

reviewing an application change? How about the total time to review applications?

To view completed Arena models for the main tutorial and these two extensions, browse 

to the Examples folder and open Mortgage Applications.doe, Mortgage Extension 1.doe, 

and Mortgage Extension 2.doe.
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The Basic Process Panel

This chapter describes the flowchart and data modules that you’ll use to model your 

process. Additionally, this chapter includes example uses of each module.

Flowchart modules

Flowchart modules are the set of objects that are placed in the model window to describe 

the simulation process.

Create module

DESCRIPTION

This module is intended as the starting point for entities in a simulation model. Entities are 

created using a schedule or based on a time between arrivals. Entities then leave the 

module to begin processing through the system. The entity type is specified in this module.

TYPICAL USES

� The start of a part’s production in a manufacturing line

� A document’s arrival (e.g., order, check, application) into a business process

� A customer’s arrival at a service process (e.g., retail store, restaurant, information 

desk)

PROMPTS

Prompt Description

Name Unique module identifier displayed on the module shape. 

Entity Type Name of the entity type to be generated.

Type Type of arrival stream to be generated. Types include Random (uses an 

exponential distribution, user specifies mean), Schedule (uses an 

exponential distribution, mean determined from the specified Schedule 

module), Constant (user specifies constant value; e.g., 100), or 

Expression (drop-down list of various distributions).

Value Determines the mean of the exponential distribution (if Random is used) 

or the constant value (if Constant is used) for the time between arrivals. 

Applies only when Type is Random or Constant.

Schedule Name Identifies the name of the schedule to be used. The schedule defines the 

arrival pattern for entities arriving to the system. Applies only when 

Type is Schedule.

Number of entities 
created
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Dispose module

DESCRIPTION

This module is intended as the ending point for entities in a simulation model. Entity 

statistics may be recorded before the entity is disposed.

TYPICAL USES

� Parts leaving the modeled facility

� The termination of a business process

� Customers departing the store

PROMPTS

Expression Any distribution or value specifying the time between arrivals. Applies 

only when Type is Expression.

Units Time units used for interarrival and first creation times. Does not apply 

when Type is Schedule.

Entities per Arrival Number of entities that will enter the system at a given time with each 

arrival.

Max Arrivals Maximum number of arrivals that this module will generate. When this 

value is reached, the creation of new arrivals by this module ceases. 

First Creation Starting time for the first entity to arrive into the system. Does not apply 

when Type is Schedule.

Prompt Description

Name Unique module identifier displayed on the module shape. 

Record Entity Statistics Determines whether or not the incoming entity’s statistics will be 

recorded. Statistics include value-added time, non-value-added time, 

wait time, transfer time, other time, total time, value-added cost, non-

value-added cost, wait cost, transfer cost, other cost, and total cost.

Prompt Description

Number of entities 
that have been 
disposed
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Process module

DESCRIPTION

This module is intended as the main processing method in the simulation. Options for 

seizing and releasing resource constraints are available. Additionally, there is the option to 

use a “submodel” and specify hierarchical user-defined logic. The process time is allo-

cated to the entity and may be considered to be value added, non-value added, transfer, 

wait, or other. The associated cost will be added to the appropriate category.

TYPICAL USES

� Machining a part

� Reviewing a document for completeness

� Fulfilling orders

� Serving a customer

PROMPTS

Prompt Description

Name Unique module identifier displayed on the module shape. 

Type Method of specifying logic within the module. Standard processing 

signifies that all logic will be stored within the Process module and 

defined by a particular Action. Submodel indicates that the logic will be 

hierarchically defined in a “submodel” that can include any number of 

logic modules.

Action Type of processing that will occur within the module. Delay simply 

indicates that a process delay will be incurred with no resource 

constraints. Seize Delay indicates that a resource(s) will be allocated in 

this module and delay will occur, but that resource release will occur at a 

later time. Seize Delay Release indicates that a resource(s) will be 

allocated followed by a process delay and then the allocated resource(s) 

will be released. Delay Release indicates that a resource(s) has 

previously been allocated and that the entity will simply delay and 

release the specified resource(s). Applies only when Type is Standard.

Priority Priority value of the entity waiting at this module for the resource(s) 

specified if one or more entities are waiting for the same resource(s) 

anywhere in the model. Not visible when Action is Delay or Delay 

Release or when Type is Submodel.

Resources Lists the resources or resource sets used for entity processing. Does not 

apply when Action is Delay, or when Type is Submodel.

Indicator of a 
submodel process

Number of entities 
currently in process
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Delay Type Type of distribution or method of specifying the delay parameters. 

Constant and Expression require single values, while Normal, 

Uniform, and Triangular require several parameters.

Units Time units for delay parameters.

Allocation Determines how the processing time and process costs will be allocated 

to the entity. The process may be considered to be Value Added, Non-

Value Added, Transfer, Wait, or Other and the associated cost will be  

added to the appropriate category for the entity and process.

Minimum Parameter field for specifying the minimum value for either a uniform or 

triangular distribution.

Value Parameter field for specifying the mean for a normal distribution, the 

value for a constant time delay, or the mode for a triangular distribution.

Maximum Parameter field for specifying the maximum value for either a uniform 

or triangular distribution.

Std Dev Parameter field for specifying the standard deviation for a normal 

distribution.

Expression Parameter field for specifying an expression whose value is evaluated 

and used for the processing time delay.

Report Statistics Specifies whether or not statistics will be automatically collected and 

stored in the report database for this process.

Prompt Description
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Process module — Resource dialog

PROMPTS

Prompt Description

Type Specification of a particular resource, or selecting from a pool of 

resources (i.e., a resource set).

Resource Name Name of the resource that will be seized and/or released. Applies only 

when Type is Resource.

Set Name Name of the resource set from which a member will be seized and/or 

released. Applies only when Type is Set

Quantity Number of resources of a given name or from a given set that will be 

seized/released. For sets, this value specifies only the number of a 

selected resource that will be seized/released (based on the resource’s 

capacity), not the number of members of a set to be seized/released.

Selection Rule Method of selecting among available resources in a set. Cyclical will 

cycle through available members (e.g., 1st member–2nd member–3rd 

member–1st member–2nd member–3rd member). Random will 

randomly select a member. Preferred Order will always select the first 

available member (1st member, if available; then 2nd member, if 

available; then 3rd member, etc.). Specific Member requires an input 

attribute value to specify which member of the set (previously saved in 

the Save Attribute field). Largest Remaining Capacity and Smallest 

Number Busy are used for resources with multiple capacity. Applies 

only when Type is Set.

Save Attribute Attribute name used to save the index number into the set of the member 

that is selected. This attribute can later be referenced with the Specific 

Member selection rule. Does not apply when Selection Rule is Specific 

Member. If Action is specified as Delay Release, the value specified 

defines which member (the index number) of the set to be released. If no 

attribute is specified, the entity will release the member of the set that 

was last seized.

Set Index The index number into the set of the member requested. Applies only 

when Selection Rule is Specific Member. If Action is specified as Delay 

Release, the value specified defines which member (the index number) 

of the set is to be released.
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Decide module

DESCRIPTION

This module allows for decision-making processes in the system. It includes options to 

make decisions based on one or more conditions (e.g., if entity type is Gold Card) or 

based on one or more probabilities (e.g., 75%, true; 25%, false). Conditions can be based 

on attribute values (e.g., Priority), variable values (e.g., Number Denied), the entity type, 

or an expression (e.g., NQ(ProcessA.Queue)).

There are two exit points out of the Decide module when its specified type is either 2-way 

Chance or 2-way Condition. There is one exit point for “true” entities and one for “false” 

entities. When the N-way Chance or Condition type is specified, multiple exit points are 

shown for each condition or probability and a single “else” exit. The number of entities 

that exit from each type (true/false) is displayed for 2-way Chance or Condition modules 

only.

TYPICAL USES

� Dispatching a faulty part for rework

� Branching accepted vs. rejected checks

� Sending priority customers to a dedicated process

PROMPTS

Prompt Description

Name Unique module identifier displayed on the module shape. 

Type Indicates whether the decision is based on a condition (if X>Y) or by 

chance/percentage (e.g., 60%, yes; 40%, no). The type can be specified 

as either 2-way or N-way. 2-way allows for one condition or probability  

(plus the “false” exit). N-way allows for any number of conditions or 

probabilities to be specified as well as an “else” exit.

Conditions Defines one or more conditions used to direct entities to different 

modules. Applies only when Type is N-way by Condition.

Percentages Defines one or more percentages used to direct entities to different 

modules. Applies only when Type is N-way by Chance.

Percent True Value that will be checked to determine the percentage of entities sent 

out a given True exit.

If Types of conditions that are available for evaluation: Variable, Variable 

Array (1D), Variable Array (2D), Attribute, Entity Type, Expression.

Number of entities 
that have taken the 
True branch

Number of entities 
that have taken the 
False branch
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Batch module

DESCRIPTION

This module is intended as the grouping mechanism within the simulation model. Batches 

can be permanently or temporarily grouped. Temporary batches must later be split using 

the Separate module. 

Batches may be made with any specified number of entering entities or may be matched 

together based on an attribute. Entities arriving at the Batch module are placed in a queue 

until the required number of entities has accumulated. Once accumulated, a new represen-

tative entity is created. 

TYPICAL USES

� Collect a number of parts before starting processing

� Reassemble previously separated copies of a form

� Bring together a patient and his record before commencing an appointment

Named Specifies either the name of the variable, attribute, or entity type that 

will be evaluated when an entity enters the module. Does not apply 

when Type is Expression.

Is Evaluator for the condition. Applies only to Attribute and Variable 

conditions.

Row Specifies the row index for a variable array. Applies only when Type is 

N-way by Condition or 2-way by Condition and Variable is Array 1-D or 

Array 2-D.

Column Specifies the column index for a variable array. Applies only when Type 

is N-way by Condition or 2-way by Condition and Variable is Array 1-D 

or Array 2-D.

Value Expression that will be either compared to an attribute or variable or that 

will be evaluated as a single expression to determine if it is true or false. 

Does not apply to Entity Type condition. If Type is Expression, this 

value must also include the evaluator (e.g., Color<>Red).

Prompt Description

Number of entities 
waiting to be 
batched
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PROMPTS

Separate module

DESCRIPTION

This module can be used to either copy an incoming entity into multiple entities or to split 

a previously batched entity. Rules for allocating costs and times to the duplicate are also 

specified. Rules for attribute assignment to member entities are specified as well.

When splitting existing batches, the temporary representative entity that was formed is 

disposed and the original entities that formed the group are recovered. The entities pro-

ceed sequentially from the module in the same order in which they originally were added 

to the batch.

When duplicating entities, the specified number of copies is made and sent from the 

module. The original incoming entity also leaves the module.

TYPICAL USES

� Send individual entities to represent boxes removed from a container

� Send an order both to fulfillment and billing for parallel processing

� Separate a previously batched set of documents

Prompt Description

Name Unique module identifier displayed on the module shape.

Type Method of batching entities together.

Batch Size Number of entities to be batched.

Save Criterion Method for assigning representative entity’s user-defined attribute  

values. 

Rule Determines how incoming entities will be batched. Any Entity will take 

the first “Batch Size” number of entities and put them together. By 

Attribute signifies that the values of the specified attribute must match 

for entities to be grouped. For example, if Attribute Name is Color, all 

entities must have the same Color value to be grouped; otherwise, they 

will wait at the module for additional incoming entities.

Attribute Name Name of the attribute whose value must match the value of the other 

incoming entities in order for a group to be made. Applies only when 

Rule is By Attribute.

Representative Entity The entity type for the representative entity. 

The original leaves 
on this branch

Duplicates leave on 
this branch
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PROMPTS

Assign module

DESCRIPTION

This module is used for assigning new values to variables, entity attributes, entity types, 

entity pictures, or other system variables. Multiple assignments can be made with a single 

Assign module.

TYPICAL USES

� Accumulate the number of subassemblies added to a part

� Change an entity’s type to represent the customer copy of a multi-page form

� Establish a customer’s priority

Prompt Description

Name Unique module identifier displayed on the module shape. 

Type Method of separating the incoming entity. Duplicate Original will 

simply take the original entity and make some number of identical 

duplicates. Split Existing Batch requires that the incoming entity be a 

temporarily batched entity using the Batch module. The original entities 

from the batch will be split.

Percent Cost to  

Duplicates

Allocation of costs and times of the incoming entity to the outgoing 

duplicates. This value is specified as a percentage of the original entity’s 

costs and times (between 0-100). The percentage specified will be split 

evenly between the duplicates, while the original entity will retain any 

remaining cost/time percentage. Visible only when Type is Duplicate 

Original.

# of Duplicates Number of outgoing entities that will leave the module, in addition to the 

original incoming entity. Applies only when Type is Duplicate Original.

Member Attributes Method of determining how to assign the representative entity attribute 

values to the original entities.These options relate to six of the special-

purpose attributes (Entity.Type, Entity.Picture, Entity.Sequence, 

Entity.Station, Entity.Jobstep, and Entity.HoldCostRate) and all user-

defined attributes. Applies only when Type is Split Existing Batch.

Attribute Name Name of representative entity attribute(s) that are assigned to original 

entities of the group. Applies only when Member Attributes is Take 

Specific Representative Values.
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PROMPTS

Record module

DESCRIPTION

This module is used to collect statistics in the simulation model. Various types of observa-

tional statistics are available, including time between exits through the module, entity  
statistics (time, costing, etc.), general observations, and interval statistics (from some time 

stamp to the current simulation time). A count type of statistic is available as well. Tally 

and Counter sets can also be specified.

TYPICAL USES

� Collect the number of jobs completed each hour

� Count how many orders have been late being fulfilled

� Record the time spent by priority customers in the main check-out line

Prompt Description

Name Unique module identifier displayed on the module shape. 

Assignments Specifies the one or more assignments that will be made when an entity 

executes the module.

Type Type of assignment to be made. Other can include system variables, 

such as resource capacity or simulation end time.

Variable Name Name of the variable that will be assigned a new value when an entity 

enters the module. Applies only when Type is Variable, Variable Array 

(1D), or Variable Array (2D).

Row Specifies the row index for a variable array.

Column Specifies the column index for a variable array.

Attribute Name Name of the entity attribute that will be assigned a new value when the 

entity enters the module. Applies only when Type is Attribute.

Entity Type New entity type that will be assigned to the entity when the entity enters 

the module. Applies only when Type is Entity Type.

Entity Picture New entity picture that will be assigned to the entity when the entity 

enters the module. Applies only when Type is Entity Picture.

Other Identifies the special system variable that will be assigned a new value 

when an entity enters the module. Applies only when Type is Other.

New Value Assignment value of the attribute, variable, or other system variable. 

Does not apply when Type is Entity Type or Entity Picture.
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PROMPTS

Prompt Description

Name Unique module identifier displayed on the module shape.

Type Type of observational (tally) or count statistic to be generated. Count 

will increase or decrease the value of the named statistic by the specified 

value. Entity Statistics will generate general entity statistics, such as 

time and costing/duration information. Time Interval will calculate and 

record the difference between a specified attribute’s value and current 

simulation time. Time Between will track and record the time between 

entities entering the module. Expression will record the value of the 

specified expression.

Attribute Name Name of the attribute whose value will be used for the interval statistics. 

Applies only when Type is Interval.

Value Value that will be recorded to the observational statistic when Type is 

Expression or added to the counter when Type is Count. 

Tally Name This field defines the symbol name of the tally into which the observa-

tion is to be recorded. Applies only when Type is Time Interval, Time 

Between, or Expression.

Counter This field defines the symbol name of the counter to Name increment/ 

decrement. Applies only when Type is Counter.

Record into Set Check box to specify whether or not a tally or counter set will be used.

Tally Set Name Name of the tally set that will be used to record the observational-type 

statistic. Applies only when Type is Time Interval, Time Between, or 

Expression.

Counter Set Name Name of the counter set that will be used to record the count-type 

statistic. Applies only when Type is Count.

Set Index Index into the tally or counter set.
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Data modules

Data modules are the set of objects in the spreadsheet view of the model that define the 

characteristics of various process elements, such as resources and queues.

Attribute module

DESCRIPTION

This data module is used to define an attribute’s dimension, datatype and initial value(s). 

An attribute is a characteristic of all entities, but with a specific value that can differ from 

one entity to another.  Attributes can be referenced in other modules (e.g. the Decide mod-

ule), can be reassigned a new value with the Assign module, and can be used in any 

expression.  Attribute values are unique for each entity, as compared to Variables which 

are global to the simulation module.

There are three methods for manually editing the Initial Values of an Attribute module:

� Via the standard spreadsheet interface. In the module spreadsheet, right-click on 

the Initial Values cell and select the Edit via spreadsheet menu item. The values 

for two-dimensional arrays should be entered one column at a time. Array 

elements not explicitly assigned are assumed to have the last entered value.

� Via the module dialog box. In the module spreadsheet, right-click on any cell and 

select the Edit via dialog menu item. The values for two-dimensional arrays 

should be entered one column at a time. Array elements not explicitly assigned are 

assumed to have the last entered value.

� Via the two-dimensional (2-D) spreadsheet interface. In the module spreadsheet, 

click on the Initial Values cell.

TYPICAL USES

� due date of an order (entity)

� priority of order (entity)

� color of a part (entity)

PROMPTS

Prompt Description

Name The unique name of the attribute being defined. 

Rows Number of rows in a dimensional attribute.

Columns Number of columns in a dimensional attribute. 

ArenaBE.book  Page 40  Wednesday, April 28, 2010  4:31 PM



3 • THE BASIC PROCESS PANEL

41

•  •  •  •  •

3
 • B

asic P
ro
c
ess

 P
a
n
e
l

Entity module

DESCRIPTION

This data module defines the various entity types and their initial picture values in a 

simulation. Initial costing information and holding costs are also defined for the entity.

TYPICAL USES

� Items being produced or assembled (parts, pallets)

� Documents (forms, e-mails, faxes, reports)

� People moving through a process (customers, callers)

PROMPTS

Data Type The data type of the values stored in the attribute. Valid types are Real 

and String. The default type is Real.

Initial Values Lists the initial value(s) of the attribute. This value(s) may be changed 

with the Assign module. 

Initial Value Entity attribute value when entity is created and enters the system

Prompt Description

Entity Type The name of the entity type being defined. This name must be unique. 

Initial Picture Graphical representation of the entity at the start of the simulation. This 

value can be changed during the simulation using the Assign module. 

Holding Cost/Hour Hourly cost of processing the entity through the system. This cost is 

incurred when the entity is anywhere in the system.

Initial VA Cost Initial cost value that will be assigned to the value-added cost attribute 

of the entity. This attribute accrues the costs incurred when an entity is 

spending time in a value-added activity.

Initial NVA Cost Initial cost value that will be assigned to the non-value-added cost attri-

bute of the entity. This attribute accrues the costs incurred when an 

entity is spending time in a non-value-added activity.

Initial Waiting Cost Initial cost value that will be assigned to the waiting-cost attribute of the 

entity. This attribute accrues the costs incurred when an entity is 

spending time in a wait activity; e.g., waiting to be batched or waiting 

for resource(s) at a Process module.

Prompt Description
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Queue module

DESCRIPTION

This data module may be utilized to change the ranking rule for a specified queue. The 

default ranking rule for all queues is First In, First Out unless otherwise specified in this 

module. There is an additional field that allows the queue to be defined as shared. You 

cannot use shared queues in Arena Basic Edition.

TYPICAL USES

� Stack of work waiting for a resource at a Process module

� Holding area for documents waiting to be collated at a Batch module

PROMPTS

Initial Transfer Cost Initial cost value that will be assigned to the transfer cost attribute of the 

entity. This attribute accrues the costs incurred when an entity is 

spending time in a transfer activity.

Initial Other Cost Initial cost value that will be assigned to the other cost attribute of the 

entity. This attribute accrues the costs incurred when an entity is 

spending time in an other activity.

Report Statistics Specifies whether or not statistics will be collected automatically and 

stored in the report database for this entity type.

Prompt Description

Name The name of the queue whose characteristics are being defined. This 

name must be unique. 

Type Ranking rule for the queue, which can be based on an attribute. Types 

include First In, First Out; Last In, First Out; Lowest Attribute 

Value (first); and Highest Attribute Value (first). A low attribute value 

would be 0 or 1, while a high value may be 200 or 300.

Attribute Name Attribute that will be evaluated for the Lowest Attribute Value or High-

est Attribute Value types. Entities with lowest or highest values of the 

attribute will be ranked first in the queue, with ties being broken using 

the First In, First Out rule.

Prompt Description
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Resource module

DESCRIPTION

This data module defines the resources in the simulation system, including costing infor-

mation and resource availability. Resources may have a fixed capacity that does not vary 

over the simulation run or may operate based on a schedule. Resource failures and states 

can also be specified in this module.

TYPICAL USES

� Equipment (machinery, cash register, phone line)

� People (clerical, order processing, sales clerks, operators)

PROMPTS

Shared Check box that determines whether a specific queue is used in multiple 

places within the simulation model. Shared queues can only be used for 

seizing resources (e.g., with the Seize module from the Advanced 

Process panel). You cannot use shared queues in Arena Basic Edition.

Report Statistics Specifies whether or not statistics will be collected automatically and 

stored in the report database for this queue.

Prompt Description

Name The name of the resource whose characteristics are being defined. This 

name must be unique. 

Type Method for determining the capacity for a resource. Fixed Capacity will 

not change during the simulation run. Based on Schedule signifies that 

a Schedule module is used to specify the capacity and duration informa-

tion for the resource.

Capacity Number of resource units of a given name that are available to the 

system for processing. Applies only when Type is Fixed Capacity.

Schedule Name Identifies the name of the schedule to be used by the resource. The 

schedule defines the capacity of a resource for a given period of time. 

Applies only when Type is Schedule.

Schedule Rule Dictates when the actual capacity change is to occur when a decrease in 

capacity is required for a busy resource unit. Applies only when Type is 

Schedule.

Prompt Description
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Variable module

DESCRIPTION

This data module is used to define a variable’s dimension and initial value(s). Variables 

can be referenced in other modules (e.g., the Decide module), can be reassigned a new 

value with the Assign module, and can be used in any expression. 

There are three methods for manually editing the Initial Values of a Variable module:

� Via the standard spreadsheet interface. In the module spreadsheet, right-click on 

the Initial Values cell and select the Edit via spreadsheet menu item. The values 

Busy/Hour Cost per hour of a resource that is processing an entity. The resource 

becomes busy when it is originally allocated to an entity and becomes 

idle when it is released. During the time when it is busy, cost will 

accumulate based on the busy/hour cost. The busy cost per hour is 

automatically converted to the appropriate base time unit specified 

within the Replication Parameters page of the Run > Setup menu item.

Idle/Hour Cost per hour of a resource that is idle. The resource is idle while it is not 

processing an entity. During the time when it is idle, cost will 

accumulate based on the idle/hour cost. The idle cost per hour is 

automatically converted to the appropriate base time unit specified 

within the Replication Parameters page of the Run > Setup menu item.

Per Use Cost of a resource on a usage basis, regardless of the time for which it is 

used. Each time the resource is allocated to an entity, it will incur a per-

use cost.

StateSet Name Name of states that the resource may be assigned during the simulation 

run.

Initial State Initial state of a resource. If specified, the name must be defined within 

the repeat group of state names. This field is shown only when a StateSet 

Name is defined.

Failures Lists all failures that will be associated with the resource. 

� Failure Name–Name of the failure associated with the resource.

� Failure Rule–Behavior that should occur when a failure is to occur for 

a busy resource unit.

Report Statistics Specifies whether or not statistics will be collected automatically and 

stored in the report database for this resource.

Prompt Description
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for two-dimensional arrays should be entered one column at a time. Array 

elements not explicitly assigned are assumed to have the last entered value.

� Via the module dialog box. In the module spreadsheet, right-click on any cell and 

select the Edit via dialog menu item. The values for two-dimensional arrays 

should be entered one column at a time. Array elements not explicitly assigned are 

assumed to have the last entered value.

� Via the two-dimensional (2-D) spreadsheet interface. In the module spreadsheet, 

click on the Initial Values cell.

TYPICAL USES

� Number of documents processed per hour

� Serial number to assign to parts for unique identification

� Space available in a facility

PROMPTS

Prompt Description

Name The unique name of the variable being defined. 

Rows Number of rows in a dimensional variable.

Columns Number of columns in a dimensional variable. 

Data Type The data type of the values stored in the variable. Valid types are Real 

and String. The default type is Real.

Statistics Check box for determining whether or not statistics will be collected. 

This field is visible when the rows and columns are not specified (single 

variables).

Clear Option Defines the time (if at all) when the value(s) of the variable is reset to the 

initial value(s) specified. Specifying Statistics indicates to reset this 

variable to its initial value(s) whenever statistics are cleared. Specifying 

System indicates to reset this variable to its initial value(s) whenever the 

system is cleared. None indicates to never reset this variable to its initial 

value(s), except prior to the first replication.

Initial Values Lists the initial value(s) of the variable. This value(s) may be changed 

with the Assign module. 

Initial Value Variable value at the start of the simulation.

Report Statistics Specifies whether or not statistics will be collected automatically and 

stored in the report database for this variable.
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Schedule module

DESCRIPTION

This data module may be used in conjunction with the Resource module to define an 

operating schedule for a resource or with the Create module to define an arrival schedule. 

Additionally, a schedule may be used and referenced to factor time delays based on the 

simulation time.

TYPICAL USES

� Work schedule for staff, including breaks

� Breakdown patterns for equipment

� Volume of customers arriving at a store

� Learning-curve factors for new workers

PROMPTS

Prompt Description

Name The name of the schedule being defined. This name must be unique.

Type Type of schedule being defined. This may be Capacity related (for 

resource schedules), Arrival related (for the Create module), or Other 

(miscellaneous time delays or factors).

Time Units Time units used for the time-duration information.

Scale Factor Method of scaling the schedule for increases or decreases in 

Arrival/Other values. The specified Value fields will be multiplied by 

the scale factor to determine the new values. Not available for Capacity-

type schedules.

Durations Lists the value and duration pairs for the schedule. Values can be 

capacity, arrival, or other type values, while the duration is specified in 

time units. Schedule pairs will repeat after all durations have been 

completed, unless the last duration is left blank (infinite). Schedule data 

can be entered graphically using the Graphical Schedule editor or 

manually using the Value/Duration fields.

Value Represents either the capacity of a resource (if Type is Capacity), arrival 

rate (if Type is Arrival), or some other value (if Type is Other). 

Examples of Other may be a factor that is used in a delay expression to 

scale a delay time during various parts of the day.

Duration Time duration for which a specified Value will be valid.
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Set module

DESCRIPTION

This data module defines various types of sets, including resource, counter, tally, entity 

type, and entity picture. Resource sets can be used in the Process modules. Counter and 

Tally sets can be used in the Record module. 

TYPICAL USES

� Machines that can perform the same operations in a manufacturing facility

� Supervisors, check-out clerks in a store

� Shipping clerks, receptionists in an office

� Set of pictures corresponding to a set of entity types

PROMPTS

Prompt Description

Name The unique name of the set being defined. 

Type Type of set being defined.

Members Repeat group that specifies the resource members with the set. The order 

of listing the members within the repeat group is important when using 

selection rules such as Preferred Order and Cyclical.

Resource Name Name of the resource to include in the resource set. Applies only when 

Type is Resource.

Tally Name Name of the tally within the tally set. Applies only when Type is Tally.

Counter Name Name of the counter within the counter set. Applies only when Type is 

Counter.

Entity Type Name of the entity type within the entity type set. Applies only when 

Type is Entity.

Picture Name Name of the picture within the picture set. Applies only when Type is 

Entity Picture.
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Using Visio and Arena

Introduction

Since the mid-1980s, Business Process Improvement (BPI) and simulation have become 

leading methodologies to allow corporations to deliver high-quality products and services 

through business process modeling. Businesses are seeking not simply to automate 

existing operations, but to improve and redesign business processes to meet and exceed 

customers’ expectations for the delivery of products and services. 

Many simulation systems are standalone, running only on a desktop and having limited 

capabilities to integrate with other technologies such as company databases, workflow 

engines, and other desktop solutions. At the same time, leading corporations have 

discovered the value of simulation technology. Many companies require simulation to be 

used as standard procedure in support of process improvements. 

A much greater return on investment is possible if process descriptions and simulation 

results can be accessed throughout the enterprise. Microsoft® Visio®, the leading desktop 

drawing product, supplies a common graphics platform for representing business process 

models. Visio’s open architecture via ActiveX® and Visual Basic® for Applications 

enables the overall modeling tool to be customized to fit changing needs. The models also 

can be shared throughout the enterprise by publishing on an intranet directly from Visio.

The Arena Basic Edition includes a built-in interface to Visio, mapping shapes from a 

Visio drawing to the appropriate simulation constructs in Arena. Process hierarchy is 

captured in the Arena simulation model, including activity-based costing and process 

logic, enabling an understanding of the distribution of cost and effort among process 

components. As with Visio, Arena supplies robust ActiveX support, a Microsoft® Office-

compatible interface, and VBA to fulfill enterprise needs for best-of-breed software 

products.

The Visio Process Simulation add-in

If you use Visio, you can immediately put Arena’s process mapping tool to work with the 

Visio Process Simulator. Created as an add-in to Visio, the Process Simulator includes a 

Visio template and stencil for mapping processes with shapes designed to mirror the flow-

chart and data modules in the Basic Process panel of the Arena Basic Edition. When 

you’ve completed your Visio process map using these tools, you’re ready to simulate it in 

Arena!

ArenaBE.book  Page 49  Wednesday, April 28, 2010  4:31 PM



ARENA BASIC EDITION USER’S GUIDE

50

• 
 •

  
• 

 •
  
•

Start a drawing

Before opening the Visio stencil, it is necessary to have an administrator on the machine 

set the Visio macro security options to Low so that macros will be enabled. 

To begin a drawing, browse to the Process Simulation template, which the Process Simu-

lator installs in the Program Files\Rockwell Software\Arena\Visio folder. This dialog box 

typically appears when you first start Visio, or you can bring it up via the File > New > 

Choose Drawing Type > Browse Templates menu.

The Process Simulation template sets up the Visio environment to work with Arena and 

opens a new drawing. Drawings that are started with this template will automatically 

display the Process Simulation stencil, provide custom dialog boxes for editing shape 

properties, and add a Simulate menu to Visio for checking your drawing and transferring 

it to Arena. 

The Process Simulation stencil, which is opened with your new drawing, contains shapes 

that will capture your process flow and data. The shapes mirror those in Arena’s Basic 

Process panel, so you can use Visio to define fully a model of your process, including all 

of the parameters needed to exploit the power of simulation analysis. 

The first 14 shapes in the Process Simulation stencil correspond to the Arena flowchart 

and data modules with the same names. In addition, the Visio stencil contains five connec-

tor shapes for properly defining the process flowchart.

It’s important to start 
your drawing by 
browsing to the 

Process Simulation 
template, rather 
than opening or 

starting a new draw-
ing and directly 

attaching the 
Process Simulation 
stencil. If you don’t 

start your drawing 
with the template, 

custom dialogs and 
other features may 

not be available.
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Place and connect shapes

To define the process flow portion of your model, drag and drop flowchart shapes (e.g., 

Create, Process, Dispose) from the Process Simulation stencil into your drawing, just as 

you would with other standard Visio stencils. Then, use the connectors from the Process 

Simulation stencil to establish flow. 

When connecting shapes, the Dynamic Connector is used for all except Decide and 

Separate, which use special connectors to determine the type of each of the two possible 

outgoing connections. The table below lists the shapes from which the connectors can 

start (e.g., the True Connector can only start at a Decide shape). 

The sample flowchart below illustrates the use of these connectors, including the 

Dynamic Connector, which is unlabeled.

 

Connector Valid Starting Shape

True Connector Decide

False Connector Decide

Original Connector Separate

Duplicate Connector Separate

Dynamic Connector Create, Process, Batch, Assign, Record

You can change the 
Visio page layout or 

size via the File > 
Page Setup menu. 
For many process 
maps, a Standard 

page size and Land-
scape orientation 

work well.

Decide shape 
(True and 

False 
connectors)

Separate shape 
(Original and Duplicate 
connectors)
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Enter custom properties

When you place shapes from the Process Simulation stencil, default names appear (e.g., 

Create 1, Process 1) to identify the steps in the process flow. Typically, you’ll replace 

these names with descriptions of the process steps. To do so, simply select the shape and 

type the new name, as with other standard Visio shapes.

The Process Simulation stencil’s shapes also provide custom dialogs for defining property 

values, including lists of valid options and other features to aid you in quickly characteriz-

ing process data. To open the dialog box, either double-click on the shape or right-click 

and select Edit Shape Properties from the pop-up menu, as shown below.

Either of these actions will display the appropriate dialog box for the shape. The dialogs 

that Arena presents for its corresponding modules are designed to match those in Visio, so 

that you’re working in a familiar interface, whether mapping your process in Visio or 

Arena.
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The property values that you define via the custom dialog boxes are stored with the indi-

vidual shapes. When you transfer the process map to Arena, these parameters are used for 

simulation.

Add data shapes

To define the data modules (e.g., Entity, Resource) for the model of your process, you 

place shapes directly in the drawing for each of the elements you want to define. When the 

individual data shapes are transferred to Arena, they will not appear in the model window, 

but will be added to the appropriate spreadsheets instead.

For example, if processes in your flowchart are performed by resources named Clerk and 

Supervisor, you would place two Resource shapes and specify their characteristics (cost, 

capacity) by opening the property dialog boxes.

Simulate the process map in Arena

By using the Process Simulation stencil in Visio, you can define, document, and commu-

nicate your business processes. When you want to predict how your process will operate, 

examine it for bottlenecks, and compare possible changes to make informed decisions, 

you can transfer your process map from Visio to Arena, where the process will come to 

life with simulation and animation.

Check the drawing

While you’re working with your process map, you can check it for any missing or incorrect 

data or connections. To check your drawing, use the Check Drawing item from the 

Simulate menu. After the drawing has been examined, a list of any warnings/errors is 

displayed, as shown below for a drawing that has a connector that is not glued at both ends.

You only need to 
add the data shapes 

if you want to 
change any of the 

default values. 
Otherwise, they are 

not needed in the 
Visio drawing; they’ll 

automatically be 
added to the 

spreadsheets when 
you transfer the 

drawing to Arena.
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If multiple problems are detected, each will be listed with a description and, in the case of 

invalid or missing properties, the field and value that are improper are listed. To correct 

the errors in your drawing, you can use the buttons at the bottom of the dialog box. For 

errors in shape properties, click the Edit Properties button, which displays the shape’s 

dialog box, to correct the data. In the case of connector problems, click Go to Shape, 

which displays and selects the shape that caused the problem, as shown below. (Note that 

the Error Listing dialog box shrinks to allow more room for viewing the drawing.) 

After you’ve corrected the problem, you can return to the list of errors/warnings by click-

ing the Return to Error List button. Once you finish correcting any additional problems, 

click the Close button. You can check your drawing at any time, correcting any or all 

errors that are detected. 

Transfer the drawing to Arena

When you’re ready to simulate your process, it’s a simple matter of selecting the Simulate 

Drawing item from the Simulate menu. This tool opens the Arena Basic Edition and 
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translates your Visio process map into an Arena simulation model. When the process is 

complete, you have an Arena model containing modules from the Basic Process panel that 

mirror the shapes you used from the Visio Process Simulation stencil, including the prop-

erties and connections you specified in Visio. 

In Arena, you can set the simulation run length on the Run > Setup page. If you do not 

define the run length, you can stop the simulation at any time by clicking the Pause 

button, then the End button. 

To run the simulation, click Arena’s Go button. Your entities will animate the flowchart as 

the simulation proceeds, just as if you had created the model directly in Arena. Because 

the process is being simulated in Arena with the standard Basic Process modules, you 

have all of Arena’s capabilities at your disposal, including reports on all aspects of your 

process via the Reports panel selections. 

After you have simulated your process, you can save the Arena model (.doe) file to con-

tinue work in Arena, or you can close it to return to Visio for continued modifications. 

Because the transfer of the Visio drawing is from Visio to Arena (but not vice versa from 

Arena to Visio), it’s usually best to return to Visio. However, you might want to save the 

Arena model in case you want to review the simulation or results as you’re refining the 

Visio process map.

Simulate other Visio drawings

In addition to simulating process maps using the Process Simulation add-in, you can also 

simulate process maps created using other Visio stencils. Arena provides a shape map 

editor to define the relationship between the shapes in the Visio stencils and the modules 

in Arena’s Basic Process panel. Arena’s online help describes how to use this feature, 

which is accessed by opening the Tools > Options menu and clicking on the Visio 

Options tab.

Use Visio and Arena in your organization

The combination of Visio and Arena can widen and deepen the reach of process improve-

ment in your organization. You can exploit the accessibility of Visio to ease the transition 

from drawing pictures to mapping processes. All types of process constituents—from 

those who govern the business to the staff who execute the process—can directly influ-

ence the definition of how the process works now … and what future “to-be” operations 

will provide the most dramatic improvements.

Distribute the Process Simulation add-in

The Process Simulation add-in is automatically installed with Arena and is available to all 

Visio users, with no additional fees or licenses required. You can distribute the add-in 
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throughout your organization so that everyone who has an interest in the process defini-

tion can access it directly through Visio.

With this approach, process maps can be created and shared throughout the organization 

on any desktop with a Visio license. When simulation and animation are needed to visual-

ize and analyze the behavior of the process, the drawings can be transferred to systems 

with the Arena Basic Edition. By using the Process Simulation template and checking the 

process maps as they’re created, you can be confident that taking the step to move from 

static drawing to dynamic simulation will be seamless.

Publish process maps on a Web page

You can share your process maps—the drawing of your process flowchart—with others 

by using Visio’s HTML export feature to publish on an intranet. To save the drawing in 

HTML format, select the File > Save As menu option in Visio and change the type to 

HTML Files. (Refer to Visio’s online help for more information about the HTML export 

feature.)

The value of modeling and analyzing your processes can be further exploited by saving 

process performance information with the process maps. The results of simulation runs 

can be saved in HTML format, providing a benchmark against which actual operations or 

other improvement concepts can be compared. To save the reports, click the Export 

button when you have an Arena report open and select the HTML option as the file type.
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Statistical Distributions

Arena contains a set of built-in functions for generating random numbers from the com-

monly used probability distributions. These distributions appear on pull-down menus in 

many Arena modules where they’re likely to be used. They also match the distributions in 

the Arena Input Analyzer. This appendix describes all of the Arena distributions.

Each of the distributions in Arena has one or more parameter values associated with it. 

You must specify these parameter values to define the distribution fully. The number, 

meaning, and order of the parameter values depend on the distribution. A summary of the 

distributions (in alphabetical order) and parameter values is given in the table below.

Summary of Arena’s Probability Distributions

Distribution Parameter Values

Beta BETA Beta, Alpha

Continuous CONT CumP1,Val1, . . . CumPn,Valn

Discrete DISC CumP1,Val1, . . . CumPn,Valn

Erlang ERLA ExpoMean, k

Exponential EXPO Mean

Gamma GAMM Beta, Alpha

Johnson JOHN Gamma, Delta, Lambda, Xi

Lognormal LOGN LogMean, LogStd

Normal NORM Mean, StdDev

Poisson POIS Mean

Triangular TRIA Min, Mode, Max

Uniform UNIF Min, Max

Weibull WEIB Beta, Alpha
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To enter a distribution in an Arena field, you type the name of the distribution (or its four-

letter abbreviation) followed by its parameters enclosed in parentheses. You may use 

spaces around punctuation to help read the distribution. A few examples appear below.

UNIF(3.5, 6)

Uniform distribution with a minimum value of 3.5, a maximum value of 6

NORMAL(83, 12.8)

Normal distribution with a mean of 83, a standard deviation of 12.8

DISCRETE(0.3,50,0.75,80, 1.0,100)

Discrete probability distribution that will return a value of 50 with probability 0.3, a 

value of 80 with cumulative probability 0.75, and a value of 100 with cumulative 

probability of 1.0. (See “Discrete probability” for a description of these parameters.)

TRIA(10, 15, 22)

Triangular distribution with a minimum value of 10, mode (most likely value) of 15, 

and maximum value of 22

In the following pages, we provide a summary of each of the distributions supported by 

Arena, listed in alphabetical order for easy reference. Each includes the density or mass 

function, parameters, range, mean, variance, and typical applications for the distribution.

If you have existing data and want to select the appropriate distribution for use in your 

model, use Arena’s Input Analyzer. Click on Tools > Input Analyzer to launch the 

program, or launch it from the Windows Start menu.

ArenaBE.book  Page 58  Wednesday, April 28, 2010  4:31 PM



A • STATISTICAL DISTRIBUTIONS

59

•  •  •  •  •

A
 • S

tatis
tica

l D
istrib

u
tio

n
s

Beta(β, α): BETA(Beta, Alpha)

Shape parameters Beta (β) and Alpha (α) specified as positive real numbers.

[0, 1] (Can also be transformed to [a,b] as described below)

Because of its ability to take on a wide variety of shapes, this distribution is often used as 

a rough model in the absence of data. Also, because the range of the beta distribution is 

from 0 to 1, the sample X can be transformed to the scaled beta sample Y with the range 

from a to b by using the equation Y = a + (b - a)X. The beta is often used to represent 

random proportions, such as the proportion of defective items in a lot.

Probability
Density

Function

x
β 1–

1 x–( )
α 1–

B β α( , )
---------------------------------------

0 otherwise

where β is the complete beta  
function given by

B β α,( ) t
β 1–

1 t–( )
α 1–

td
0

1

∫=

f(x) =

for 0 < x < 1

Parameters

Range

Mean
β

β α+
-------------

Variance
βa

β a+( )
2

β a 1+ +( )
-----------------------------------------------

Applications
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Continuous: CONTINUOUS(CumP1, Val1, . . ., CumPn, Valn)  

(c1, x1,. . ., cn,xn)

The CONTINUOUS function in Arena returns a sample from a user-defined distribution. 

Pairs of cumulative probabilities cj (= CumPj) and associated values xj (= Valj) are speci-

fied. The sample returned will be a real number between x1 and xn, and will be less than or 

equal to each xj with corresponding cumulative probability cj. The xj’s must increase with 

j. The cj’s must all be between 0 and 1, must increase with j, and cn must be 1.

The cumulative distribution function F(x) is piecewise linear with “corners” defined by 

F(xj) = cj for j = 1, 2, . . ., n. Thus, for j > 2, the returned value will be in the interval  

Probability 
Density

Function

Cumulative 
Distribution 

Function

f(x) =

c1 if x = x1 (a mass of probability c1 at x1)

cj – cj-1 if xj-1 ≤ x < xj, for j = 2, 3, . . ., n

0 if x < x1 or x ≥ xn

Parameters
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(xj–1, xj] with probability cj – cj–1; given that it is in this interval, it will be distributed uni-

formly over it.

You must take care to specify c1 and x1 to get the effect you want at the left edge of the 

distribution. The CONTINUOUS function will return (exactly) the value x1 with 

probability c1. Thus, if you specify c1 > 0, this actually results in a mixed discrete-

continuous distribution returning (exactly) x1 with probability c1, and with probability  
1 – c1 a continuous random variate on (x1, xn] as described above. The graph of F(x) above 

depicts a situation where c1 > 0. On the other hand, if you specify c1 = 0, you will get a 

(truly) continuous distribution on [x1, xn] as described above, with no “mass” of probability 

at x1; in this case, the graph of F(x) would be continuous, with no jump at x1.

As an example use of the CONTINUOUS function, suppose you have collected a set of 

data x1, x2, . . ., xn (assumed to be sorted into increasing order) on service times, for exam-

ple. Rather than using a fitted theoretical distribution from the Input Analyzer, you want 

to generate service times in the simulation “directly” from the data, consistent with how 

they’re spread out and bunched up, and between the minimum x1 and the maximum xn you 

observed. Assuming that you don’t want a “mass” of probability sitting directly on x1, 

you’d specify c1 = 0 and then cj = (j – 1)/(n – 1) for j = 2, 3, . . ., n.

[x1, xn]

The continuous empirical distribution is often used to incorporate actual data for continu-

ous random variables directly into the model. This distribution can be used as an alterna-

tive to a theoretical distribution that has been fitted to the data, such as in data that have a 

multimodal profile or where there are significant outliers.

Range

Applications
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Discrete: DISCRETE(CumP1, Val1, . . ., CumPn, Valn)  

(c1, x1, . . ., cn, xn)

The DISCRETE function in Arena returns a sample from a user-defined discrete probabil-

ity distribution. The distribution is defined by the set of n possible discrete values 

(denoted by x1, x2, . . . , xn) that can be returned by the function and the cumulative proba-

bilities (denoted by c1, c2, . . . , cn) associated with these discrete values. The cumulative 

probability (cj) for xj is defined as the probability of obtaining a value that is less than or 

equal to xj. Hence, cj is equal to the sum of p(xk ) for k going from 1 to j. By definition,  

cn = 1.

{x1, x2, . . ., xn}

The discrete empirical distribution is often used to incorporate discrete empirical data 

directly into the model. This distribution is frequently used for discrete assignments such 

as the job type, the visitation sequence, or the batch size for an arriving entity.

Probability 
Mass 

Function

Cumulative 
Distribution 

Function

Parameters

Range

Applications

p(xj) = cj – cj-1 

 
where c0 = 0
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Erlang(β, k): ERLANG(ExpMean, k) or ERLA(ExpMean, k) 

If X1, X2, . . . , Xk are independent, identically distributed exponential random variables, 

then the sum of these k samples has an Erlang-k distribution. The mean (β) of each of the 

component exponential distributions and the number of exponential random variables (k) 

are the parameters of the distribution. The exponential mean is specified as a positive real 

number, and k is specified as a positive integer.

[0, + 

kβ

kβ 2

The Erlang distribution is used in situations in which an activity occurs in successive 

phases and each phase has an exponential distribution. For large k, the Erlang approaches 

the normal distribution. The Erlang distribution is often used to represent the time 

required to complete a task. The Erlang distribution is a special case of the gamma distri-

bution in which the shape parameter, α, is an integer (k).

Probability 
Density 

Function

f(x) =

β
k–
x

k 1–
e

x β⁄–

k 1–( )!
---------------------------------

f(x) =
for x > 0

0 otherwise

Parameters

Range ∞ )

Mean

Variance

Applications
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Exponential(β): EXPONENTIAL(Mean) or EXPO(Mean) 

The mean (β) specified as a positive real number.

[0, + 

β

β 2

This distribution is often used to model inter-event times in random arrival and break-

down processes, but it is generally inappropriate for modeling process delay times. 

In Arena’s Create module, the Schedule option automatically samples from an exponen-

tial distribution with a mean that changes according to the defined schedule. This is partic-

ularly useful in service applications, such as retail business or call centers, where the 

volume of customers changes throughout the day.

Probability 
Density 

Function
1

β
---e

x β⁄–

f(x) =
for x > 0

0 otherwise

Parameters

Range ∞ )

Mean

Variance

Applications
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Gamma(β, α): GAMMA(Beta, Alpha) or GAMM(Beta, Alpha) 

Shape parameter (α) and scale parameter (β) specified as positive real values.

[0, + 

αβ

αβ 2

For integer shape parameters, the gamma is the same as the Erlang distribution. The 

gamma is often used to represent the time required to complete some task (e.g., a 

machining time or machine repair time).

Probability
Density 

Function

f(x) =

0 otherwise

for x > 0

where Γ is the complete 

gamma function given by

Γ α( ) tα 1– e 1– td
0

∞

∫=

β α– xα 1– e x β⁄–

Γ α( )
-----------------------------------

Parameters

Range ∞ )

Mean

Variance

Applications
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Johnson: JOHNSON(Gamma, Delta, Lambda, Xi) or 
JOHN(Gamma, Delta, Lambda, Xi) 

Gamma shape parameter (γ), Delta shape parameter (δ > 0), Lambda scale parameter (λ), 

and Xi location parameter (ξ).

(− ∞, + ∞ ) Unbounded Family

[ξ, ξ + λ] Bounded Family

The flexibility of the Johnson distribution allows it to fit many data sets. Arena can 

sample from both the unbounded and bounded form of the distribution. If Delta (δ) is 

passed as a positive number, the bounded form is used. If Delta is passed as a negative 

value, the unbounded form is used with |δ | as the parameter.

Probability
Density

Function

Parameters

Range

Applications

Unbounded Family Bounded Family
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Lognormal(µ, σ): LOGNORMAL(LogMean, LogStd) or 
LOGN(LogMean, LogStd) 

Mean LogMean (µ l > 0) and standard deviation LogStd (σ l > 0) of the lognormal random 

variable. Both LogMean and LogStd must be specified as strictly positive real numbers.

[0, + 

LogMean = µ1 = 

(LogStd)2 = σ 1
2 = 

The lognormal distribution is used in situations in which the quantity is the product of a 

large number of random quantities. It is also frequently used to represent task times that 

have a distribution skewed to the right. This distribution is related to the normal 

distribution as follows. If X has a lognormal (µl, σl) distribution, then ln(X) has a normal 

(µ, σ) distribution. Note that µ and σ are not the mean and standard deviation of the 

Probability 
Density 

Function

Denote the user-specified input parameters as 

LogMean = µl  and LogStd = σl .

Then let 

the probability density function can then be  

written as 

)/ln( 222
lll µσµµ += and

[ ]2/)22(ln lll µµσσ +=

f(x) =
)2/())(ln( 22

2

1 σµ

πσ

−− xe
x for x > 0

0 otherwise

Parameters

Range ∞ )

Mean eµ σ2 2⁄+

Variance e2µ σ2+
eσ2 1–( )

Applications
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lognormal random variable X, but rather the mean and standard deviation of the normal 

random variable lnX.
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Normal(µ, σ): NORMAL(Mean, StdDev) or NORM(Mean, StdDev) 

The mean (µ) specified as a real number and standard deviation (σ) specified as a positive 

real number.

(− ∞, + ∞ )

µ

σ 2

The normal distribution is used in situations in which the central limit theorem applies; 

i.e., quantities that are sums of other quantities. It is also used empirically for many 

processes that appear to have a symmetric distribution. Because the theoretical range is 

from  - ∞ to + ∞, the distribution should only be used for positive quantities like 

processing times.

Probability 
Density

Function
)2/()( 22

2

1
)( σµ

πσ

−−= x
exf for all real x

Parameters

Range

Mean

Variance

Applications
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Poisson(λ): POISSON(Mean) or POIS(Mean)

The mean (λ) specified as a positive real number.

{0, 1,  . . .}

λ

λ

The Poisson distribution is a discrete distribution that is often used to model the number 

of random events occurring in a fixed interval of time. If the time between successive 

events is exponentially distributed, then the number of events that occur in a fixed-time 

interval has a Poisson distribution. The Poisson distribution is also used to model random 

batch sizes.

Probability
Mass

Function

p(x)=

e
λ–
λ

x

x!
------------- for xε {0, 1, ...}

0 otherwise

Parameters

Range

Mean

Variance

Applications

ArenaBE.book  Page 70  Wednesday, April 28, 2010  4:31 PM



A • STATISTICAL DISTRIBUTIONS

71

•  •  •  •  •

A
 • S

tatis
tica

l D
istrib

u
tio

n
s

Triangular(a, m, b): TRIANGULAR(Min, Mode, Max) or TRIA(Min, 
Mode, Max)

The minimum (a), mode (m), and maximum (b) values for the distribution specified as 

real numbers with a < m < b.

[a, b]

(a + m + b)/3

(a2 + m2 + b2 – ma – ab – mb)/18

The triangular distribution is commonly used in situations in which the exact form of the 

distribution is not known, but estimates (or guesses) for the minimum, maximum, and 

most likely values are available. The triangular distribution is easier to use and explain 

than other distributions that may be used in this situation (e.g., the beta distribution).

Probability
Density

Function

f(x)

0

a m b

x

for a ≤  x ≤ m

 for m ≤  x ≤ bf(x) =

2 x a–( )
m a–( ) b a–( )

-----------------------------------

2 b x–( )
b m–( ) b a–( )

-----------------------------------

0 otherwise

Parameters

Range

Mean

Variance

Applications
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Uniform(a, b): UNIFORM(Min, Max) or UNIF(Min, Max) 

The minimum (a) and maximum (b) values for the distribution specified as real numbers 

with a < b.

[a, b]

(a + b)/2

(b – a)2/12

The uniform distribution is used when all values over a finite range are considered to be 

equally likely. It is sometimes used when no information other than the range is available. 

The uniform distribution has a larger variance than other distributions that are used when 

information is lacking (e.g., the triangular distribution). 

Probability 
Density 

Function

f(x)

0
a

1
b-a

b
x

f(x) =

0 otherwise

 for a ≤  x ≤ b
1

b a–
------------

Parameters

Range

Mean

Variance

Applications
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Weibull(β, α): WEIBULL(Beta, Alpha) or WEIB(Beta, Alpha) 

Shape parameter (α) and scale parameter (β) specified as positive real values.

[0, + )

 , where Γ is the complete gamma function (see gamma distribution).

Probability 
Density 

Function

f(x)

0 x

a=1/2

a=1 a=2

a=3

f(x) =

0 otherwise

 for x > 0aβ a– xa 1–
e

x β⁄( )
a

–

Parameters

Range ∞

Mean
β
a
---Γ

1

a
---
 
 

Variance
β

2

a
----- 2Γ

2

a
---
 
  1

a
--- Γ

1

a
---
 
 

2





–




ArenaBE.book  Page 73  Wednesday, April 28, 2010  4:31 PM



ARENA BASIC EDITION USER’S GUIDE

74

• 
 •

  
• 

 •
  
•

The Weibull distribution is widely used in reliability models to represent the lifetime of a 

device. If a system consists of a large number of parts that fail independently, and if the 

system fails when any single part fails, then the time between successive failures can be 

approximated by the Weibull distribution. This distribution is also used to represent non-

negative task times that are skewed to the left.

Applications

ArenaBE.book  Page 74  Wednesday, April 28, 2010  4:31 PM



75

B B
 • S

h
ap
es an

d
 S
y
m
b
o
ls

Library Shapes and Symbols

Arena .plb picture files

Arena’s picture libraries (*.plb files) contain images that you may use for entity, resource, 

and global pictures. You can use the images in these libraries for any of these three types 

of picture animation. You also can copy these pictures into your own libraries, draw new 

pictures in Arena’s picture editor, or add pictures from the Arena Symbol Factory to any 

.plb file. View the online help topic “Animating Objects” to learn more about adding 

symbols to your picture libraries.

The Basic Process library supplies a set of default entity pictures that are preloaded into 

your Arena models. When you start a model, Arena adds the pictures from BasicPro-

cess.plb to the entity picture list (see the Edit > Entity Pictures menu). Also, the pre-

defined names associated with these pictures are added to the entity picture list (e.g., 

Picture.Report) in the Entity module and Entity picture placement dialog.

Example pictures in Basic Process.plb

Report Bike Airplane Man Woman Blue Ball Red Ball

Green Ball Yellow Ball Boat Box Diskette Letter Red Page

Blue Page Yellow Page Green Page Envelope Truck Van Widgets

Email Telephone Package Fax
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Arena .plb libraries

The list of standard Arena picture libraries includes:

� Buldings.plb

� Equipment.plb

� Faces.plb

� Factory.plb

� General.plb

� Machines.plb

� Medical.plb

� Objects.plb

� Office.plb

� Office Equipment.plb

� People.plb

� Symbols.plb

� Vehicles.plb

� Workers.plb

Common shapes may be placed from any of these categories, or they may be added from 

the Arena Symbol Factory or other image source by pasting from your Clipboard into a 

specific library. If you wish to create your own library of shapes, simply select New from 

the Entity Picture Placement window. The “Current Library” displays “(None Opened)” 

because the new library has not yet been named or saved. Simply select Add for each 

library shape you wish to include in your new (or existing) library file, and draw or paste 

the appropriate images onto the picture editor board. Remember to drag-and-drop the 

Ride Point to the appropriate position on your image. 

Arena Symbol Factory

Arena animations can also be enhanced using Arena Symbol Factory’s extensive library 

of over 4,000 symbols. These symbols can be used for entity, resource, transporter, or 

global pictures, or as graphic symbols within a model window. You can copy these images 

directly to the Arena model window, add them to your own libraries (.plb files), or add 

them to any of the standard Arena picture library files.

The Symbol Factory application

The Symbol Factory is launched from the main Arena toolbar by selecting Tools > Arena 

Symbol Factory. The application screen contains three distinct areas: the Preview pane, 

showing an enlarged image of the currently selected symbol; the Categories pane, 

containing the list of library symbols by groupings; and the Symbol pane, displaying 

images of all shapes contained within a selected category. An example of the application 

is shown below with the Machining category selected.
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The basic operation of Symbol Factory simply requires you to select an object from a 

category list, click Edit > Copy, and then paste the symbol into your picture editor 

window or the Arena application window (for static shapes). Details on the Arena Symbol 

Factory can be found in the extensive online help embedded in the application.

You must have suitable license activation to use the full Symbol Factory capabilities. In 

Arena training/evaluation and run-time versions, Arena Symbol Factory is only available 

in demo mode. Demo mode limits use to only the first symbol in each category. New 

categories cannot be created, and symbols cannot be moved, added, deleted, imported, or 

exported in demo mode. 
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disposing  � 30
duplicating  � 36
what are they?  � 13

Entity module  � 41
entity picture sets  � 47
entity type sets  � 47
Erlang distribution  � 57, 63, 65
Exponential distribution  � 57, 64

F
flowchart modules  � 11, 29
flowchart objects  � 11
flowchart view  � 7

G
Gamma distribution  � 57, 65
Glue to Guides  � 24
grid  � 9
grouping within the model  � 35
guides  � 24

J
Johnson distribution  � 57, 66

L
Lognormal distribution  � 57, 67

M
model thumbnail  � 26
model window  � 6

flowchart view  � 7
spreadsheet view  � 7

modules  � 6, 11
mortgage application example  � 5

N
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O
online help  � 2
operating schedule  � 46

P
pause the simulation  � 20
picture libraries  � 75

BasicProcess.plb  � 75
listing of standard files  � 76
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changing from idle to busy  � 23

plots  � 25
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Probability distribution  � 57
process flowchart  � 7
process mapping  � 49
process maps  � 7

checking the drawing  � 53
publishing on a Web  � 56
simulating other Visio drawings  � 55
transferring the drawing to Arena  � 54

Process module  � 8, 13, 31
Process Simulation

distributing the add-in  � 55
stencil  � 50

Project Bar  � 6
Project Parameters dialog  � 18

Q
Queue module  � 42
queueing  � 35

R
ranking rules  � 42
Record module  � 38
reports  � 20
resource constraints

seizing and releasing  � 31
Resource module  � 17, 43
resource sets  � 47
resource states  � 43
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definition  � 43
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rulers  � 24
running the simulation  � 26
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sample models  � 2
saving your model  � 18
Schedule module  � 46
Separate module  � 36
Set module  � 47
sets definition  � 47
simulating your process  � 18
simulation run length  � 55
Smarts library  � 2, 12, 15
snap  � 9
split view  � 22
splitting batches  � 36
spreadsheet view  � 7
stepping through the simulation  � 20

T
tally sets  � 47
technical support  � 3
thumbnail  � 26
time delay  � 13
training courses  � 4
Triangular distribution  � 57, 71

U
Uniform distribution  � 57, 72

V
Variable module  � 40, 44
variables

assigning new values  � 37
definition  � 40, 44

viewing reports  � 20
Visio  � 49
Visio Process Simulator  � 49

adding data shapes  � 53
entering custom properties  � 52
placing and connecting shapes  � 51
simulating the process map  � 53
starting a drawing  � 49

W
Web support  � 3
Weibull distribution  � 57, 73
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