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Setup 
 
All of the files and images needed to complete the activities in this Quick Start guide are located 
in the accompanying Beaches Resources file. Extract this file to a convenient location where 
student files are typically stored. Files will be extracted to a folder named Beaches Resources. 
The completed site files are also located in the Expression Web Quick Start Tutorial Beaches 
Around the World folder.  

  
The screenshots of Expression Web in this tutorial are shown in the Default Windows color 
scheme of Expression Web and may not be the same colors as the version of Expression Web 
installed on student computers. If desired, set the Expression Web color scheme to your current 
Windows color scheme. Click Application Options on the Tools menu. In the Application 
Options dialog box select the Use your current Windows color scheme option. 

 
You will also need to download and install the Microsoft® .NET Framework version 3.5 (which 
includes the Microsoft AJAX extensions) to complete parts of this lab exercise. It is available 
from the link below. 
 
The .NET Framework 3.5: 
http://www.microsoft.com/downloads/details.aspx?FamilyID=333325FD-AE52-4E35-B531-
508D977D32A6&displaylang=en 
 

 
Scenario 

 
The exercises in this tutorial will introduce you to Microsoft Expression® Web. This is the second 
in the series of Beaches Around the World tutorials. This tutorial is included in Module 5 of the 
semester-long curriculum, Introduction to Web Design Using Microsoft Expression Studio. This 
tutorial can stand as in independent learning tool or as the second in the 3-tutorial series. 
Expression Design Tutorial: Creating Images with Expression Design (Beaches Around the World) 
and Expression Web Tutorial (Advanced): Beaches Around the World are the other two tutorials. 
 
By the end of these exercises, you will have created a simple standards-compliant Web site on 
the topic of an around-the-world trip to famous beaches.  
 
In order to create this site, you will learn to use the tools in Expression Web to edit Web 
documents in Design view and to create a site that is ready for publishing to the Web. In these 
lab exercises you will become familiar with Web-based technologies such as cascading style 
sheets (CSS), HTML, and Dynamic Web Templates. 
 
Below is a sneak peek of the “My Beach Trip” Web site that you will create with this tutorial.  
 

http://www.microsoft.com/downloads/details.aspx?FamilyID=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en


 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



The Microsoft® Expression® Web Workspace 
 

 
 

1. Common Toolbar 
2. Folder List 
3. File Tabs 
4. Toolbox 
5. Style and Layer Task Panes 
6. View Tabs 
7. Tag and CSS Property Task Panes 
8. Bread Crumb Trail 

 

 
 
Exercises 
 
EXERCISE 1 - Creating a New Web site  

  
EXERCISE 2 - Creating Page Layouts with Layers 
  
EXERCISE 3 - Styling Your Web Site Using CSS 
  
EXERCISE 4 – Creating More Pages 
  
EXERCISE 5 - Adding Navigation Controls to Your Site  
 



 
 

Exercise 1: Creating a New Web Site 

Scenario: You will create a new, empty Web site and a blank HTML page, and change its 
properties.  

Task 1: Create a new empty Web site 
 
Create the basic framework for your new Web site structure. 

 
1. Click Start, point to All Programs, point to Microsoft Expression, and then click 

Microsoft Expression Web.  

2. On the File menu, point to New, and then click Web Site. 

 

3. In the New dialog box, on the Web Site tab, click General, and then click Empty Web 

Site. 

 

4. Click Browse to specify the location of the new Web site and click Open. 

5. To specify a name for the Web site, highlight the automatically generated name at the 

end of the path and enter a new name to replace it. 

For this example, call this site MyTrip_LastName. (Replace “LastName” with your last 

name.) 

6.  Click OK to create and save the Web site. 



7. Using Windows Explorer, move the Resources folder from the Expression Web Quick 

Start Tutorial Beaches Around the World folder to the folder that was created for this 

new Web site. 

You will find the Web site folder in the location that was chosen in step 4. 

 

Task 2: Create a new HTML page 
 
Create the HTML page that will be the home page of the Web site and set the page properties. 

 
1. On the File menu, point to New, and then click Page. 

2. In the New dialog box, click General, then click HTML and click OK. 

 

3. On the File menu, click Save As. 



 

4. In the Save As dialog box, in the File name box, type index.html and then click Save. 

The page is named “index.html” because most Web servers will recognize this file name 

as the home page. 

5. Right-click anywhere on the blank page and select Page Properties. 

 

6. Under the General tab, specify the values in the following table. This will help users and 

search engines know the topic of the page. 

Property Value 

Title My Beach Trip 

Page Description  This site is about a trip around the world 
to various beach locations. 

Keywords beach, trip, travel 

 



 

7. Under the Formatting tab, specify the colors in the following table. This will change the 

color of all links on the page. 

Property Value 

Hyperlink Blue 

Visited hyperlink Green 

Active hyperlink Light Blue 

Hovered hyperlink Light Blue 

 

 

8. Under the Advanced tab, set all of the margins to 0. This will get rid of the default space 

that creates a small margin around the edge of the Web page when displayed in a 

browser. 

 

9. Click OK to close the Page Properties dialog. 

Exercise 2: Creating Page Layouts with Layers 

Scenario: You will layout your page using layers and CSS Properties. You will then add 
images and text into those layers. 

Task 1: Create a layer and add an image 
 



Create a layer using the toolbox and then insert the header image into the layer. 

 
1. In the Toolbox, click Layer and drag it onto the page. 

 

2. Click inside the new layer to place the cursor within the layer. 

 

3. On the Insert menu, point to Picture and click From File. 



 

4. In the Picture dialog box, navigate to the Resources folder in your Web site and select 

beachHeader_final.png. 

5. Click Insert to add the picture to your site. 

6. In the Accessibility Properties dialog, specify the values from the following table and 

click OK. This will help users and search engines identify the subject of the picture. 

Property Value 

Alternate text My Beach Trip header 

Long description  My Beach Trip text with a sun on the right 

 

 

7. On the File menu, click Save. 

 

Task 2: Make the layer fit the image 
 
Make the layer fit the image using CSS Properties. 

 
1. On the Task Panes menu, ensure Layers is checked. 



 

2. Select the Layers tab from the bottom right task pane. You may need to click the right 

arrow if the Layers tab is not visible. 

3. Click layer 1 on the Layers task pane. 

The layer should be highlighted in blue on the workspace. 

 

 

4. With the layer highlighted, click the CSS Properties tab and specify the values in the 

following table. This will make your layer fit the header image perfectly. 

Property Value 

height 80px 

width   800px 



Property Value 

left 0px 

top 0px 

 

 

5. On the File menu, click Save. 

 

 

Task 3: Add another layer and hero image 
 
Use the toolbox to add another layer and will insert a hero image into that layer. 

 
1. In the Toolbox, double click Layer. 

2. Click inside the new layer to place the cursor within the layer. 



 

3. On the Insert menu, point to Picture and click From File. 

4. In the Picture dialog box, navigate to the Resources folder in your Web site and select 

beach_hero.jpg. 

5. Click Insert to add the picture to your site. 

6. In the Accessibility Properties dialog, specify the values from the following table and 

click OK.  

Property Value 

Alternate text Relaxing on a remote beach 

Long description  Relaxing under a palm tree on a remote 
beach 

 

 

7. Select the Layers tab from the bottom-right task pane. 

 

8. Click layer 2 on the Layers task pane. 

The layer should be highlighted in blue on the workspace. 



 

9. With the layer highlighted, click the CSS Properties tab and specify the values in the 

following table. This will make your layer fit the header image perfectly. 

Property Value 

height 372px 

width   800px 

left 0px 

top 80px 

 

 

10. On the File menu, click Save. 



 

 

Task 4: Add text to a layer 
 
You will add two more layers to contain the Web site’s navigation links and the home page text 
content. 

 
1. In the Toolbox, click Layer and drag it onto the page. 

2. Position the layer below the left side of the hero image and make it a bit bigger. Use the 

following screenshot as a guide. 

 

3. Minimize Expression Web and navigate to the Resources folder using Windows 

Explorer. 

4.  Open the Word file named Text content for Beach Trip Web Site. 

 



5. Copy the four lines of text under the word Menu from the Word document. 

 

 

6. Maximize Expression Web and click inside layer 3 (the layer you just created) to place 

your cursor inside the layer. 

7. Paste the text into this layer. 

 

8. Add another layer to the page using the Toolbox. 

9. Position the layer next to layer 3 and make it wider. Use the following screenshot as a 

guide. 

 



10. Minimize Expression Web and maximize the Word file named Text content for Beach 

Trip Web Site. 

11. Copy the paragraphs labeled Page 1 text and switch back to Expression Web. 

 

12. Click to place your cursor in layer 4. 

13. On the Edit menu, click Paste Text. 

 

14. In the Paste Text dialog, select Normal paragraphs without line breaks and click OK.  

 

15. Highlight the text that you just pasted and select Arial, Helvetica, sans-serif from the 

font dropdown. 



 

16. Click in the top-left corner of layer 4 and move the cursor to the top left using the 

arrows on your keyboard. 

17. Press the Return/Enter key on your keyboard. 

18. Press the Up Arrow key on your keyboard to place the cursor on the top line of the 

layer. 

 

19. Type About My Trip. 



20. On the File menu, click Save. 

 

 

Exercise 3: Styling Your Web Site Using CSS 

Scenario: Use cascading style sheets (CSS) to format headline styles, position layers, 
and align images. At the end of the exercise you will preview the page in a browser. 

Task 1: Format the headline style 
 
Format the h1 headline style using CSS. 

 
1. Click and drag to select the About My Trip headline text. 

2. Select Heading 1 <h1> from the Style dropdown menu. The text should automatically 

resize and become bold. 



 

 

3. Click New Style in the Apply Styles or Manage Styles task panes (lower-right corner.) 

 

4. In the New Style dialog, select h1 from the Selector dropdown menu. 

 

5. With the Font category open, specify the values from the following table. 

 

Property Value 

font-family Arial, Helvetica, sans-serif 

 font-size 16px 

 

 

6. Click OK to save the style. Your header should automatically change to reflect the new 

header style. 

7. On the File menu, click Save. 



 

 

 

Task 2: Position layers using CSS 
 
Position layers 3 and 4 using the CSS properties task pane so they are aligned on the vertical 
axis. 

 
1. Select layer 3 using the Layers task pane or by clicking it in the workspace. 

2. With the layer highlighted, click the CSS Properties tab and enter 465px in the Top field. 

3. Select layer 4 and repeat step 2. This will align the tops of both layers. 

4. On the File menu, click Save. 



 

 
 

Task 3: Use CSS to align an image 
 
Add an image to layer 4 and align it by creating a CSS style. 

 
1. Click to place your cursor at the beginning of the first paragraph in layer 4, just before 

the words “I have chosen four beach…” You may need to use the arrow keys to 

accurately position the cursor exactly at the beginning of the text. 

 

2. On the Insert menu, point to Picture and click From File. 

3. Select the image called hammock.jpg and click OK. 



4. In the Accessibility Properties dialog, specify the values from the following table and 

click OK. 

Property Value 

Alternate text Hammock on the beach 

Long description  A hammock and palm tree in the Bahamas 

 

 

5. Click New Style in the Apply Styles or Manage Styles task panes (lower-right corner.) 

6. In the New Style dialog, enter .img-right in the Selector field. 

Note: All class styles must begin with a dot or period.  

7. Select the Layout category and set Float to Right. 

8. Select the Box category and specify the values from the following table. 

 

Property Value 

Margin: Same for all Unchecked  

Margin: bottom 10px 

Margin: left 10px 

 

9. Click OK to create the new style. 



 

 

10. Click the small image of the hammock that you just inserted into layer 4. 

11. In the Apply Styles task pane, click to select the .img-right style. 

The image should align to the right and the test should wrap around to the left with 10 

pixels of margin on the left and bottom of the image. 



 

12. On the File menu, click Save. 

 

 

 

Task 4: Preview the Page in a Browser 
 



Use a Web browser to preview the page and to see it as a visitor to the published site will see it. 

 
1. On the File menu, click Save. You cannot preview an unsaved page. 

2. On the File menu, point to Preview in Browser and click Windows Internet Explorer 7.0 

(1024 X 768) (or whatever browser you have installed on your computer.)  

 

3. Take a look at your page and close the browser window. 



 

 

 

Exercise 4: Creating More Pages 

Scenario: Create the internal pages of your Web site using a Dynamic Web Template 
and style the pages using an external CSS file.  

Task 1: Create an external style sheet 
 
Create an external style sheet to easily apply the same styles across many pages. 

 
1. On the File menu, point to New and click CSS. 

A blank page will open. DO NOT add anything to the page. 



 

2. On the File menu, click Save. 

3. In the Save As dialog, enter beachtripstylesheet.css into the File Name field and click 

Save. 

4. Click the index.html tab to go back to your home page. 

5. Click Attach Style Sheet in the Apply Styles or Manage Styles task panes (lower-right 

corner.) 

 

6. In the Attach Style Sheet dialog, click the Browse button. 

7. In the Select Style Sheet dialog, select beachtripstylesheet.css from your Web site 

folder and click Open. 

8. In the Attach Style Sheet dialog, click OK to attach the style sheet. 

 

9. In the Manage Styles task pane, click the first style (a) and then click the last style (.img-

right) while holding Shift on your keyboard.  

This should highlight all the styles in the Current Page category. 



 

10. Drag all of the selected styles to the beachtripstylesheet.css category. 

This will move all of your styles from the home page into the external style sheet. 

 

11. On the File menu, click Save. 

12. In the Save Embedded Files dialog, click OK. 



 

 

 

Task 2: Create a Dynamic Web Template 
 
Create a Dynamic Web Template to apply the same layout across many pages. 

 
1. On the File menu, point to New and click Page. 

2. In the New dialog box, click General and then click Dynamic Web Template. 

 

3. In the Save As dialog, enter contentPageTemplate in the File Name field and click Save. 

A file name extension, .dwt, will be added automatically when you save the file. 

4. Click in the layer that is already on the page and press Delete. 

5. In the Toolbox, click Layer and drag it onto the page. 

6. Click the layer to highlight it. 



 

7. With the layer highlighted, click the CSS Properties tab and specify the values in the 

following table. 

Property Value 

height 80px 

width   800px 

left 0px 

top 0px 

 
8. Click inside the new layer to place the cursor within the layer. 

9. On the Insert menu, point to Picture and click From File. 

10. In the Picture dialog box, navigate to the Resources folder in your Web site and select 

beachHeader_final.png. 

11. Click Insert to add the picture to your site. 

12. In the Accessibility Properties dialog, specify the values from the following table and 

click OK. This will help users and search engines know what the picture is. 

Property Value 

Alternate text My Beach Trip header 

Long description  My Beach Trip text with a sun on the right 

 

13. In the Toolbox, double click Layer. You should now have two layers on the page. 

14. Click layer 2 to highlight it. 



 

15. With the layer highlighted, click the CSS Properties tab and specify the values in the 

following table. 

Property Value 

height 200px 

width   200px 

left 15px 

top 95px 

 

 

16. Navigate to your home page (index.html) using the Folder List or the page tabs. 

17. Select and copy the four lines of text in layer 3. 



 

18. Navigate back to your Dynamic Web Template (contentPageTemplate.dwt) and paste 

the text in layer 2. 

19. Add the word Home on a new line at the top of the layer. 

 

20. Add another layer to the Dynamic Web Template using the Toolbox. 

21. With the layer highlighted, click the CSS Properties tab and specify the values in the 

following table. 

Property Value 

height 250px 

width   550px 

left 240px 

top 95px 

 



 

22. Right-click the new layer (layer 3) and select Manage Editable Regions. 

 

23. In the Editable Regions dialog box, enter content into the Region name field, click Add, 

and then click Close. 

This will allow you to edit this layer on pages that you create using the Dynamic Web 

Template.  

 

24. On the File menu, click Save.   



 

 
 

Task 3: Attach a style sheet to the Dynamic Web Template 
 
Attach an external style sheet to the Dynamic Web Template that was just created. This will 
allow all of your pages to have the same styles. 

 
1. Open the Dynamic Web Template (contentPageTemplate.dwt) from the tabs at the top 

of the work area or from the Folder List. 

2. Click Attach Style Sheet in the Apply Styles or Manage Styles task panes (lower-right 

corner.) 

3. In the Attach Style Sheet dialog box, click the Browse button. 

4. In the Select Style Sheet dialog box, select beachtripstylesheet.css from your Web site 

folder and click Open. 

5. In the Attach Style Sheet dialog box, click OK to attach the style sheet. 

6. On the File menu, click Save. 

 

 

Task 4: Create internal pages using the Dynamic Web Template 
 
Create four internal pages using the Dynamic Web Template that was just created. 

 
1. On the File menu, point to New and click Create from Dynamic Web Template. 



 

2. In the Attach Dynamic Web Template dialog box, select contentPageTemplate.dwt 

from your Web site folder and click Open. 

3. Click Close on the Microsoft Expression Web dialog box. 

 

4. Open the Word file named Text content for Beach Trip Web Site from your resources 

folder. 

5. Copy the text below the section labeled page 2 text. 

 

6. Navigate back to Expression Web and click inside layer 3 on the new page to make the 

cursor appear. 

7. Paste the text. 



 

8. Place your cursor at the end of the first line in layer 3 after the h in beach. 

9. Press Enter on your keyboard. This will identify the top line as a new paragraph. 

10. Highlight Pink Sands Beach on the top line. 

 

11. Select Heading 1 <h1> from the pull-down choices in the Common Toolbar at top. 

 

12. On the File menu, click Save. 

13. In the Save As dialog box, click Change title. 

14. In the Set Page Title dialog box, enter Pink Sands Beach and click OK. 

 

15. In the Save As dialog box, enter pink_sands into the File name field and click Save. 



16. Repeat steps 1 through 15 three more times to create a new page for each of these 

beaches:  Phi Phi Island, Anguilla, and Whitehaven Beach. Use the appropriate text from 

the Text content for Beach Trip Web Site Word document and save the page, using the 

appropriate name: phi_phi, anguilla, or whitehaven. 

 

 
 

 

Exercise 5: Adding Navigation Controls to Your Site 

Scenario: Add navigation to your Web site using links and interactive buttons. 

Task 1: Create internal links 
 
You will make the internal links functional so users can navigate your Web site. 

 
1. Open the Dynamic Web Template (contentPageTemplate.dwt) from the tabs at the top 

of the work area or from the Folder List. 

2. Highlight Home on the top line of layer 2. 

3. On the Insert menu, click Hyperlink. 



 

4. In the Insert Hyperlink dialog box, select index.html and click OK. 

 

5. Repeat steps 2 to 4 for the remaining words in the menu: Pink Sands Beach, Phi Phi 

Island, Anguilla, and Whitehaven Beach. Be sure to select the correct HTML document 

for each link. 

6. On the File menu, click Save. 

7. In the Microsoft Expression Web dialog box, click Yes. 

 

8. In the next dialog box, click Close. 



 

 

Task 2: Create an external link 
 
Create a link to another Web site on your home page. 

 
1. Open the home page (index.html) from the tabs at the top of the work area or from the 

Folder List. 

2. Place your cursor at the end of the last paragraph in layer 4 and press Enter. 

3. Enter the words See a list of other famous beaches. Highlight the words just entered. 

 

4. Right-click the highlighted text and click Hyperlink. 



 

5. Enter http://en.wikipedia.org/wiki/List_of_beaches in the Address field and click OK. 

 

6. On the File menu, click Save. 



 

 
 

Task 3: Create interactive buttons 
 
Create interactive buttons on your home page to make the navigation more attractive. 
 

1. Open the home page (index.html) from the tabs at the top of the work area or from the 

Folder List. 

2. Highlight the four lines of text in layer 3 and press Backspace on your keyboard. 

 Make sure you don’t delete the layer that the links were in. Your cursor should be in 

the top-left corner of this layer. If you delete too much, just press control-Z to undo the 

last change. 



 

3. On the Insert menu, click Interactive Button. 

 

4. In the Interactive Button dialog, box on the Button tab, select Simple Line 2 and enter 

Pink Sands Beach in the Text field. 

5. Click Browse next to the Link field. 

6. In the Edit Hyperlink dialog box, select pink_sands.html and click OK. 



 

7. In the Interactive Button dialog box, open the Font tab and specify the values in the 

following table. 

Property Value 

Font Arial, Helvetica, sans-serif 

Font Style (Default Style) 

Size 14 

 



 

8. In the Interactive Button dialog box, open the Image tab and specify the values in the 

following table and click OK. 

Property Value 

Maintain proportions Unchecked 

Width 200 

Height 30 

 



 

9. Repeat steps 3 through 8 to create interactive buttons for each of the remaining 

selections in the menu: Phi Phi Island, Anguilla, and Whitehaven Beach.  

You can use the same process to create interactive buttons on the Dynamic Web 

Template for the rest of the Web site. 

 

9. On the File menu, click Save. 

10. On the Save Embedded Files dialog box, click OK. 



 

11. On the File menu, point to Preview in Browser and click Windows Internet Explorer 7.0 

(1024 X 768) (or whatever browser you have installed on your computer).  

12. Test your links and interactive buttons and then close the browser window. 



 

 

Congratulations!  

You’ve just completed the “My Beach Trip” Web site using Expression Web.  

 
You learned to use many tools and Web technologies that will be useful as you design more 
Web pages. You can now expand your knowledge of Expression Web with the third tutorial in 
the Beaches Around the World series - Expression Web Tutorial (Advanced): Beaches Around 
the World. 
 
The complete series of tutorials are included in the semester-long curriculum, Introduction to 
Web Design Using Microsoft Expression Studio (modules 4, 5, & 7).  
 
Experiment with Expression Web and explore the Help Menu to learn about more exciting Web 
design features and technologies. There are also many learning resources online at 
http://expression.microsoft.com/en-us/cc197140.aspx.  

http://expression.microsoft.com/en-us/cc197140.aspx

