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Part One 

Introduction 
Since 1997, BigFix

®
 has been providing highly scalable, multi-platform, systems management solutions for 

companies around the world. Today, over six million computers rely on BigFix to deploy critical updates to 
globally distributed workstations, servers and other devices using targeted Fixlet

®
 technology. BigFix deploys on 

any size network in days – regardless of OS or geography – to rapidly realize payback. 

BigFix deploys a multi-purpose, lightweight Agent to all endpoint devices. These Agents report back through a 
chain of Relays and Servers, all under the aegis of a central Console, providing continuous visibility for far-flung 
organizations with hundreds of thousands of endpoints. 

This Guide describes the operation of the BigFix Enterprise Suite (BES) Console. It includes a complete 
description of the interface, as well as step-by-step instructions for using the program. This guide also shows 
you how to optimize the performance of the various suite components, including BES Servers, Relays and 
Clients. This guide does not, however, discuss the installation of the software. For that information, see the 
BES Administrator’s Guide or the BES Evaluation Guide. 

Audience 

This guide is for administrators who are using BigFix to monitor and remediate large networks of computers 
using prepackaged Fixlet messages. BigFix also allows properly authorized administrators to create and target 
their own network Fixlet messages, Tasks and Analyses, either by modifying existing content or by creating 
new content from scratch. 

A master Console operator can manage the rights and scope of other Console operators, allowing subsets of 
your network to be administered by divisional or regional managers. Both master and ordinary BigFix Console 
operators can benefit from this guide. 

System Requirements 

To install the BES Console, you must have a computer that meets the following minimum requirements: 

 Hardware: Intel Pentium III–class processor with 512 MB RAM. Larger deployments will require 
more capable computers. 

 Software: Windows XP, 2003, Vista, 2008, 7, or 2008 R2 with Internet Explorer version 7.0 or 
better. 

 
The BES Console can be installed on a laptop or any moderately powerful computer. However, as the number of 
computers that you are managing with the BES Console grows, you may need a more powerful computer. The 
latest BES Console recommendations can be found at the BigFix support site.  

The BES Console also requires a high bandwidth connection (LAN speeds work best) to the BES Server due to 
the amount of data that needs to be transferred to the BES Console. If you need to remotely connect to the 
BES Server across a slow bandwidth connection, it is recommended that you use a remote control connection 
to a computer (such as a Citrix server or Terminal Services computer) with a high-speed connection to the BES 
Server. Contact your support technician for more information about BES Console scaling requirements.  

Note:  The BES Console is the primary interface to BigFix and manages a great deal of information 
about the BES Clients. If the BES Console computers are underpowered or on a slow 
connection, it can adversely impact performance. 

http://support.bigfix.com/bes/install/consolereq.html
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Part Two 

Using the Program 

Overview of the BigFix Enterprise Suite 

The BigFix Enterprise Suite (also called BES) has the following main components: 

 BigFix Clients are installed on every computer you wish to manage under BigFix. They access a 
collection of Fixlet messages that seek out security holes, vulnerabilities and deviations from the 
desired operating environment. If a vulnerability is found, the BigFix Client can then implement 
corrective actions received from the BigFix Console. In most cases, the BigFix Client operates silently, 
without any direct intervention from the end user. However, should you need to solicit user response, 
BigFix also allows you to provide screen prompts. 

 BigFix Servers are collections of interacting server applications that form the heart of the BigFix 
system. They coordinate the flow of information to and from individual BigFix Clients and store the 
results in the BigFix database(s). Redundancy is enabled by employing multiple servers. 

 BigFix Relays increase the efficiency of the system. Instead of requiring every networked computer to 
directly access the BigFix Server, relays can be used to offload much of the burden. Hundreds of BigFix 
Clients can point to a BigFix Relay for downloads, which in turn makes only a single request of the 
server. BigFix Relays can connect to other relays as well, further increasing efficiency. BigFix can also 
automate the relay setup, dynamically determining the best configuration for the current state of your 
network. 

 The BigFix Console ties all these components together to provide a system-wide view of your 
networked computers, along with their vulnerabilities and suggested remedies. If you are an Operator 
with the proper privileges, the BigFix Console allows you to quickly and simply distribute a fix to exactly 
those computers that need it -- with zero impact on the rest of the network. The BigFix Console is 
subject to certain minimal requirements, among them network access to the BigFix Server. 

 Web Reports let you produce charts and graphs of your data, providing you with hard copy and helping 
you to maintain an audit trail of all the Fixlet activity on your network. It allows you to export this data for 
further manipulation in a spread sheet or database. The Web Reports program also allows you to 
aggregate information from additional BigFix Servers that you may have installed in your organization. 
This important feature allows an organization with hundreds of thousands of computers to be quickly 
and easily monitored.  
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A Typical Installation 

A typical BigFix installation has at least one BigFix Server that gathers Fixlet messages from the Internet. 

These messages can be viewed by the BigFix Console operator and distributed to the BigFix Relays, which 

forward the data on to the BigFix Clients. Each BigFix Client inspects its local computer and reports any 

relevant Fixlet messages back to the BigFix Relays, which compress the data and pass it back up to the 

servers.  

The BigFix Console oversees this activity. It connects to the BigFix Server and periodically updates its display 

to reflect changes or new knowledge about your network. When vulnerabilities are discovered, the BigFix 

Console operator can then target patches or other fixes to the appropriate computers. The progress of the fixes 

can be followed in near real-time as they spread to all the relevant computers and, one by one, eliminate bugs 

and vulnerabilities.  

BigFix is flexible enough to connect to a distant office over a VPN and will even allow home-based workers or 

on-the-road sales staff to connect over the Internet to a firewall-protected BigFix Relay in a DMZ. This simple 

hierarchy can be extended and deepened to accommodate networks of virtually any size. 

 

A typical deployment of the BigFix Enterprise Suite (BES).  
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Getting Started 

The BigFix Console is the visible face of the BigFix Enterprise Suite (BES), used by the operator to monitor 

and repair networked computers running the BigFix Client. To begin using the BigFix Console, you will need to 

be authorized. There are two kinds of BigFix Console user: 

 Operators, who manage the day-to-day operation of BigFix, including Fixlet management and action 
deployment, subject to the management rights assigned by a BigFix Site Administrator or Master 
Operator.  

 Master Operators, who are operators with the added authority to assign management rights to other 
BigFix Console operators. Master Operators can also: 

 Create new computer settings, which allow BigFix Clients to be labeled for various groupings.  

 Create or edit retrieved properties, which are used to filter and sort computers.  

 Change the BigFix Client heartbeat, to optimize BigFix performance.  

 Subscribe or unsubscribe from Sites.  

 Create Custom Actions (if that option was selected for this BigFix deployment).  

Once you have your credentials, you're ready to operate the BigFix Console:  

1. Start the BigFix Console by double-clicking on its desktop icon. Or select it from the Programs menu: 
Start / Programs / BigFix Enterprise / BES Console. 

2. In order to establish an ODBC connection, the BigFix Console prompts for credentials for the default 
BigFix Database. Enter the Username and Password you created when you installed BigFix. If you 
have NT Authenticated access to the database, you won't need to type in a password. 

3. The first time you launch the BigFix Console, it asks you for your action site password and private 
key. Insert the disk (or browse to the file) with your private site key to initialize the site. 

4. After you initialize the action site, the BigFix Console opens and begins to import Fixlet messages. After 
it finishes, it sends the Fixlet messages to the BigFix Clients, which evaluate them and return the 
results. This process can take a few minutes. 
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Introducing the BigFix Console 

The Main Console window for the BigFix
®
 Enterprise Suite has a panel on the left containing buttons and 

navigation trees called the Domain Panel. It is designed to group BigFix content into collections pertaining to 

specific operator domains, such as software patching, malware protection, power management, etc. After a 

domain has been chosen and topics are selected from the navigation tree, a list of related content appears to 

the right. From this list, specific items can be selected for a more detailed view in the Work Area beneath the 

list. Here is a simplified breakdown of some of the features you might encounter in a typical session: 

 Domain Panel: This vertical panel on the left provides a high-level view of the extensive BigFix content, 
allowing you to quickly subdivide the information by major IT functions. Within each domain, this panel 
presents navigation trees that make it easy to zoom in on Fixlet Messages, Reports, Analyses and 
other content. This panel may be subdivided into sections, depending on the style of the domain. Some 
of these sections may include:  

 Content Filters: If it exists, this section is at the top and provides various content filters and 
reports that are a part of the selected domain. Click on the disclosure icon to the left (either a 
triangle or a plus sign) to produce a navigation tree to refine your choices.  

 General Content: This section lets you navigate all the content in the domain. The content 
may include Fixlet Messages, Tasks, Actions, Analyses and Computers, all collected from 
various sites. Click on the disclosure icon to the left (either a triangle or a plus sign) to open up 
the tree.  

 Domain Buttons: At the bottom of the Domain Panel, these buttons represent the current set of BigFix 
Domains that are currently available to you. When you subscribe to a site, it is automatically entered 
into the proper domain. If a new domain is required, a button for it will be added to this group. At the 
bottom of the buttons is a control that allows you to adjust the number of buttons to display.  

 Console Toolbar: This toolbar allows you to navigate back and forth through the items you have 
selected from the Domain navigation tree. In addition there are buttons that allow you to display items 
you may have hidden and items that are not currently relevant to any of your BigFix Clients (this 
enables you to view all the available content for research or cloning purposes). There is also a refresh 
button that will reload content from the database for the Console display.  

 List Panel: This is a listing of the items specified by the content filters and the navigation trees in the 
Domain Panel. You can sort this list by clicking on the column headers and you can rearrange the 
headers by dragging them left or right. In addition, you can right-click the headers to see a pop-up 
menu containing a list of all the possible fields. Check those you wish to use as headers.  

 Context Menu: This is the menu that pops up when you right-click any item in a list. Different lists have 
different context menus.  

 Work Area Toolbar: This bar contains context-sensitive buttons that can execute various actions 
based on the content of the current work area.  

 Work Area: Below the List Panel and the Work Area Toolbar is the Work Area. When you click an item 
from the List Panel, the Console opens a detailed document in this window. The following discusses 
elements of one particular document -- the Fixlet message:  

 Document tabs: Each type of document has a unique set of tabs to go along with it. For a 
Fixlet message, the tabs include items such as Description, Details, Applicable Computers and 
Action History.  

 Fixlet Message: When a Fixlet message is opened from the list, the default Description tab is 
selected and the Fixlet document explains the issue in plain English.  

 Action Button: A Fixlet document typically contains at least one Action, represented by a link 
in the Work Area (also available from the Take Action button in the Work Area Toolbar). Click it 
to deploy the Action across your network.  
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Below is a screen shot from a typical session. A subset of Fixlets and Tasks have been selected from the 

Domain navigation tree, and the user is viewing the description of a Task opened from the list panel: 

Domain Panel Console Toolbar List Panel Context Menu 

 

Domain Buttons Work Area Toolbar Work Area   

In general, your workflow will proceed first from the Domain Panel to the List Panel. After selecting an item from 

that list, you will follow the instructions in the Work Area to complete the task. 

How you proceed depends on the content type. Fixlet messages describe problems that have been discovered 

on one or more BigFix Clients. Analyses present you with information collected from the Clients on your BigFix 

network. The Computer branch of the tree allows you to examine specific BigFix clients under your control.  

For instance, if you select Fixlets from the Domain Panel, a list of the relevant Fixlets will appear in the List 

Panel. Select one from the list and it will appear in the Work Area below. The Fixlet document will present you 

with a short, clear explanation of a problem that is currently affecting your BigFix Clients. If you wish, you can 

inspect the underlying code used in the Relevance Expression and the proposed Actions by clicking the Details 

tab. Once you have decided to deploy the action to the affected computers, click the Action (represented by a 

button in the Work Area Toolbar or a hyperlink in the Work Area) and follow the prompts. After deploying the 

action, the affected BigFix Clients will be remediated and will no longer report the problem. At that point, the 

Fixlet message will disappear from the relevant Fixlet list. 

You can set preferences that govern how responsive and secure you want your BigFix network to be. To adjust 

the default values, select Preferences from the File menu. 
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Operating Basics 

The BigFix Enterprise Suite is a powerful and feature-packed program that may seem overwhelming to a new 

user. Fortunately, once you master the typical workflow, the operation becomes straightforward and intuitive. 

Let's run through a sample session: 

1. Start up the BigFix Console.  
2. From the Domain Panel on the left, click the button labeled All Content, which lets us view all 

subscribed sites. Then click the Fixlets and Tasks item at the top of the Domain panel. This then 
displays a list of the Fixlet messages and Tasks that are currently applicable to your BigFix network in 
the List Panel to the right. 
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3. From the List Panel, click a Fixlet message of interest. The corresponding document will open in the 
Work Area below the list. This is the text of the Fixlet message, which will give you the information you 
need to decide on deployment, along with the specific Action(s) to take.  
 

 
 

4. At the bottom of the message you will find one or more links that will initiate Actions to fix the afflicted 
computers. Click on the Action that seems most appropriate. A Take Action dialog box opens up. 
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5. Use the Target tab to select any subset of affected computers you wish to target with the Action. There 
are several techniques for deploying Actions:  

 Specific computers selected in the list below. The first targeting button lets you select the 
computers you want from the panel below right, which lists all those computers for which the 
Fixlet message is currently relevant. The right-click menu allows you to select all the computers 
in the list. This technique limits the Fixlet action to the specified list.  

 All computers with the property values selected in the tree below. Choose the second 
button to take actions on computers with a set of specified properties. Until the expiration of the 
action period, whenever a computer satisfies the given properties it will be targeted. As with all 
actions, only the affected computers will actually receive the action.  

 The computers specified in the list of names below. Choose the third button to specify a list 
of computers.  

6. Use the rest of the tabs to prepare your action, including execution schedules, client messages, extra 
scripting and more, then click the OK button. For more information, see the article on the Take Action 
dialog.  

7. Once you supply your password, the Fixlet action will be deployed throughout your network, and will be 
applied specifically to each computer that needs it, subject to any filters you put in place.  

This is the process that you will use for typical computer maintenance and remediation. As you explore the 

interface, you will discover that BigFix can also help you remediate security issues, inventory your computers, 

manage your users and maintain a detailed audit trail of every patch and upgrade. As varied as these tasks are, 

they are all accomplished with a similar workflow. You should experiment to learn more about the power of this 

interface. 

Fixlets and Tasks 

Introducing Fixlets and Tasks 

Fixlets and Tasks are central to the functionality of BigFix. Using Relevance statements, they target specific 

computers, remediating just those BigFix Clients afflicted by an issue and never bothering those that aren't. 

They are both packaged with an Action script that can resolve the issue with a simple mouse-click. 

Fixlets and Tasks differ mainly in how they get resolved.  

 A Fixlet is triggered by a Relevance clause that detects a vulnerability. When an Action is invoked to 
remediate the vulnerability, the Fixlet automatically loses relevance and is thus no longer applicable on 
that specific BigFix client. As a Fixlet Action propagates through your network, you can track its 
progress with the BigFix Console, Web Reports and the Visualization Tool. Once every BigFix Client in 
your network has been remediated, the Fixlet is no longer relevant and it disappears from the list. 
Should the issue reappear, the Fixlet will reappear in the list, ready to address the issue again. 

 A Task comes with one or more Action scripts that help you adjust settings or run maintenance 
assignments. It generally stays relevant until all the steps of its Action script have been executed. Tasks 
are designed for continued vigilance and as a consequence, they are often persistent. 

Both Fixlets and Tasks may have a Default Action, allowing you to simply click from the list to deploy it. They 

can both be grouped into Baselines, allowing higher levels of automation. If you create a Baseline of Fixlets or 

Tasks which all contain default Actions, you can turn the tedious chores of maintaining a corporate policy or 

common operating environment into a single-click operation.  
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At any time, you can open a Fixlet or Task to inspect the underlying Relevance expressions that are used to 

target the Clients, as well as the Action script(s) that are designed to address the issue. The language is 

human-readable to give you a high degree of confidence in both the applicability the trigger and efficacy of the 

remedial Action. You can also see exactly which computers on your network are affected by each Fixlet or 

Task. Once propagated, you can then view the progress and ultimate history of each Action taken on a Client-

by-Client basis. 

Viewing Fixlets and Tasks 

To display a Fixlet or Task, 

1. From the navigation tree in the Domain Panel, click the icon labeled Fixlets and Tasks.  

2. From the resulting List Panel on the right, click an item to open it.  

The body of the Fixlet message shows up in the Work Area (click the Description tab if not already selected).  

 

 
 

When selected, each Fixlet or Task gets a window of its own. 
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Each Fixlet or Task comes with four tabs in the Work Area: 

 Description: This is a page providing a descriptive explanation of the problem and one or more Actions 
to fix it. The Actions are represented by links at the bottom of the description page. Click on an Action to 
bring up the Take Action dialog, which allows you to further target or schedule the Action. Don't worry 
about accidentally clicking on an Action hyperlink. Before the actual deployment, you always get a 
chance to modify (or cancel) the Action.  

 Details: This dialog contains the Fixlet/Task properties such as category, security ID, download size, 
source, severity and date. It also lists the code behind the Relevance expressions and the Actions. At 
the bottom of this dialog there is a text box for you to enter a comment that will stay attached to this 
item.  

 Applicable Computers: This is a filter/list of all the computers targeted by the selected Fixlet or Task. 
You can filter the list by selecting items from the folders on the left, and sort the list by clicking on the 
column headers.  

 Action History: This is a filter/list of any Actions that have been deployed from this Fixlet or Task. If the 
item is new, there won't be any Actions in the list. Like the other filter/lists in the BigFix Console, you 
can filter the Actions using the left panel, and sort them by clicking the column headers above the right 
hand list.  

Monitoring Fixlets and Tasks 

When a Fixlet or Task becomes relevant somewhere on your network, BigFix will add it to the list available 

under the Fixlets and Tasks icon in the Domain Panel navigation tree. You can filter this list by opening the 

icon and clicking the subcategories underneath. Each icon represents data groupings that you can use to 

narrow down the items in the List Panel on the right. Then, in the listing area itself, you can sort the items by 

clicking a column heading. 

The list headers include the following information: 

 Name: The name assigned to the Fixlet message by the author.  
 ID: A numerical ID assigned to the Fixlet message by the author.  
 Source Severity: A measure of how serious a Fixlet message is, assigned by the Fixlet author. Typical 

values are Critical, Important, Moderate or Low.  
 Site: The name of the site that is generating the relevant Fixlet message.  
 Applicable Computer Count: The number of BES Clients in the network currently affected by the 

Fixlet message.  
 Open Action Count: Number of distinct actions open for the given Fixlet message.  
 Category: The type of Fixlet message, such as a security patch or update.  
 Unlocked Computer Count: The number of unlocked computers affected by the Fixlet.  
 Download Size: The size of the remedial file or patch that the action will download.  
 Source: The name of the source company that provided the Fixlet information.  
 Source ID: An identification number assigned to the Fixlet to relate it back to its source. 
 Source Release Date: The date this Fixlet message was released.  
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For example, you might filter the Fixlet list by opening the Source Severity folder and selecting Important to 

filter out less pressing Fixlet messages. 

 

Then you could sort the Fixlet messages by Applicable Computer Count (which shows the number of affected 

computers) to find which Fixlet messages are relevant to the greatest number of computers. If you don't see 

one of the columns listed above, right-click in the Fixlet header and select it from the pop-up menu. 
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Commenting on Fixlets and Tasks 

You can attach a comment to a Fixlet or Task that other operators can read. 

1. From the Domain Panel, select Fixlets and Tasks from the navigation tree.  
2. Select a Fixlet or Task from the List Panel on the right by clicking it.  
3. From the document panel below, select the Details tab and scroll to the bottom. 

 

 
 

4. Type your comment into the text box and click the Add Comment Button. 

Your comment will be name- and time-stamped for other operators to view it. In addition to Fixlets and Tasks, 

you can attach comments to Actions, Computers and Analyses.  

Creating or Customizing Fixlets and Tasks 

To create your own custom Fixlet or Task message from scratch, 

 Select Tools > Create New Fixlet or Task. This brings up a Create dialog with blank fields for you to fill 
in. 
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You may also wish to customize a Fixlet or Task. You can do this by cloning and modifying an existing one. To 

do so, first select the desired Fixlet or Task from the List Panel, then: 

 Select Edit > Create Custom Copy (or right-click the item and select Create Custom Copy from the 
context menu). The appropriate creation dialog appears, only this time it is filled with the original 
content. 
 

 

Either way, the Create dialog provides the same options. Enter the name of your customized message in the 

top left text box. This will serve as the title when the Fixlet or Task is displayed. You can use the name for 

sorting and filtering, so it's worth creating a consistent naming convention to make your content more 

manageable. Then choose the Site and Domain to host it from the drop-down menus.  

Next, click through each of the tabs to define your Fixlet or Task: 

 Description: Enter your descriptive text in this box. You can use the text manipulation toolbar at the top 
of the dialog to enhance the formatting. 
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 Actions: Define your action in this dialog. Use the buttons at the right to add, delete or change the 
position of the action. Below that is an area to customize the properties of the action. Choose the Script 
Type from the drop-down menu. Below that is a text box where you can enter a new action script or 
modify the original. There are three check boxes you can use to modify the action:  
 

 

 This action is the default action. Click this box to create a default action. 
 Include action settings locks. Click the Edit box to the right of this check box to customize the 

action setting locks, including start time, end time, day exclusions and more. This screen also 
includes failure and reapplication behaviors. 

 Include custom success criteria, which allows you to specify the conditions that will define 
the success of the action.  

 Relevance: Simply leave the default of applying to All computers, or click a different button and enter 
a condition or a relevance statement in the dialog below. This is how you target your Fixlet or Task to 
relevant computers. For more information on the relevance language, refer to the BigFix Inspector 
Libraries. 
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 Properties: Set the properties of your Fixlet or Task, including the category, download size, date, 
severity and more. You can also include the SANS (SysAdmin, Audit, Network, Security) or CVE 
(Common Vulnerabilities and Exposures) ID numbers. 
 

 

When you are satisfied with your definitions, click OK. Your Fixlet or Task needs to be propagated, so you will 

be prompted for your private key password. Once you enter it and click OK, it will be sent to all the BigFix 

Clients, which will evaluate it for relevance and report back their status. You will then be able to follow the 

deployment of your new content in real-time from the BigFix Console.  
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Hiding Fixlets and Tasks 

You can hide a Fixlet or Task with the following procedure: 

1. From any Fixlet or Task List Panel, select the message(s) you want to hide. 
2. Right-click the desired item and select Globally or Locally Hide from the pop-up menu (or select Edit 

> Hiding > Globally/Locally Hide). 
 

 

The selected Fixlet or Task will no longer be displayed in the list. If you elected to hide the item locally, it will still 

be visible to other BigFix Console users. If you are a master operator, you can hide a Fixlet or Task globally, so 

it will also be hidden to all non-master users. 
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Fixlet or Tasks that are hidden are still available and you can restore or "unhide" them at any time. Here's how: 

1. Click the Show Hidden Content button in the Console Toolbar. All content, including hidden content, will 
listed as long as this button is selected. 
 

 
2. A single Fixlet or Task can be unhidden by clicking it from a list. In the resultant Work Area you will see 

an Unhide button. Click it to return the item to its normal state.  
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3. Multiple Fixlets or Tasks can be unhidden by selecting them, right-clicking the group and choosing 
Unhide from the context menu. Or select multiple items and select Edit > Hiding > Globally/Locally 
Unhide. 
 

 

Generally speaking, it isn't necessary to hide Fixlets or Tasks, as you can simply ignore them. The main reason 

for hiding one is if you think the content will never be relevant to your network and you want to avoid viewing it. 



BigFix Console   

Operator's Guide 23 © 2010 by BigFix, Inc. 

Viewing Relevance Expressions 

When a Fixlet message becomes relevant to some computer on your network, you'll want to know exactly what 

triggered it, and what action is suggested. This is easy to investigate, because these items are written in the 

BigFix Relevance Language, which is a human-readable language for probing and acting on computers. 

To view Relevance Expressions: 

1. Click a Fixlet message from any Fixlet List Panel to bring up a detailed Fixlet document in the Work 
Area below. 

2. Select the Details tab. 

This opens a page listing various Properties and below that, the Relevance clauses and Action scripts: 

 

This window shows you how the computer is interrogated and why it has been triggered as relevant. Typically 

there are multiple Relevance clauses that are all ANDed together to determine if a given BigFix Client is 

affected. 
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Introducing Relevance 

In order to quickly inspect various aspects of a computer, BigFix developed the Relevance Language. This 

human-readable language is at the heart of the program and allows Fixlet authors to target actions to just those 

computers that need the fix -- and no others. Thus you can feel confident that only broken machines are being 

fixed and that the rest are never bothered.  

The Relevance Language can query an exhaustive set of computer properties, and do it quickly. Most BES 

Console operators will rely on third parties to write Fixlet messages, and so their exposure to the Relevance 

Language is not critical to operating the BES Console. However, as a power user, you can customize the 

Console with short lines of code from the Relevance Language (called Relevance Expressions) which grant you 

an unprecedented amount of control over the BES Client computers on the network. 

A typical Relevance Expression might be: 

vendor name of processor 

This expression will return the name of the manufacturer of the CPU (Intel or AMD, for instance), which can 

then be used to determine relevance. 

You can use Relevance Expressions to create retrieved properties which you can then use to organize and filter 

the BES Clients on the network. For example, here are some possible properties that might be useful to know 

about your BES Client computers: 

  

Property 
name 

Relevance Expression Result 

Pentium family name of main processor 
contains "Pentium" 

True if the processor is a Pentium. 

Small drive Total space of drive "c:" < 
2000000000 

True if the drive is smaller than 2GB.  

Bad clock absolute value (now - apparent 
registration server time) > 1 hour 

True if the clock is off by more than one 
hour. 

IE Version file version of application 
"iexplore.exe" of the registry 

Version number of Internet Explorer on a 
Windows computer. 

Mailto App application of key 
"HKEY_CLASSES_ROOT\mailto" of 
the registry 

On a Windows computer, the name of 
the app that handles mailto requests 
from a browser. 
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Running 
Word 

exists running application whose 
(name of it as lowercase is 
"winword.exe")  

True if Word is running on a Windows 
BES Client computer. 

Bios date date of Bios BIOS date on a Windows computer, if it 
exists. 

Processors number of processors The total number of processors in the 
BES Client computer. 

 

 

Use the Manage Properties dialog to see how these custom properties work. Click the Add New button, 

supply the property name, and type in the Relevance Expression in the text box. 

There are literally thousands of useful Retrieved Properties — far too many to list here. For a more extensive 

list of retrieved properties, check the BigFix Website. For an in-depth discussion of Relevance, refer to the 

BigFix Relevance Language Reference. 
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Sites 

Introducing Sites 

Sites are collections of Fixlet messages that are created internally by you, by BigFix, Inc., or by other third 

parties. You subscribe to a Site and agree on a schedule for downloading the latest batch of Fixlet messages. 

You can view and manage your collection of Sites by navigating to them and opening them in the Domain 

Panel. You can add a new Site subscription by acquiring a Masthead file from a vendor or from BigFix. Sites 

are generally devoted to a single topic, such as security or the maintenance of a particular piece of software or 

hardware. However, several sites may share characteristics and will then be grouped into Domains which are 

designed to be in accordance with the typical job duties of your various Console managers. For instance, the 

person in charge of patching and maintaining a common operating environment will find BigFix Support sites 

and Patching sites for various operating systems all bundled in the Patch Management Domain.  

You can set up your own custom Site and populate it with Fixlets that you have developed specifically for your 

own network. You and other operators can then send and receive the latest in-house patches and quickly 

deploy them to the appropriate locations and departments. 

Selecting Sites 

Upon installation, BES is automatically set up to subscribe to the BES Support Site. Depending on the terms of 

your license, you may have subscriptions to other sites as well. This means that content from those Sites will 

automatically flow into your enterprise and will be evaluated for relevance on all computers running the BES 

Client. These sites, in turn will automatically be registered with an appropriate Domain, providing a simple way 

to divide the content into functional sections. 

To subscribe to a site, follow these steps: 

1. First, find an appropriate Site. Finding a Site is equivalent to finding a Site masthead file, which has an 
extension of .efxm. There are several ways to do this: 

 BigFix Sites: BigFix may post links list to new Sites as they become available. 

 Fixlet Subscriptions: Sometimes a Fixlet message might offer a subscription. Just click the 
Fixlet action to initiate the subscription. 

 Download Mastheads: You can also subscribe to a Site by downloading a masthead file from 
a vendor's web site. Once the masthead is saved to your computer, you can activate it in one of 
two ways. 

 Double-click the masthead, or 
 Select Add External Site Masthead from the Tools menu, browse to the folder 

containing the masthead and click Open. 
2. You will be prompted for your private key password. Type it in and click OK. 

The masthead is propagated to all BES Clients, which will immediately begin to evaluate the Fixlet messages 

from the new site.  



BigFix Console   

Operator's Guide 27 © 2010 by BigFix, Inc. 

Viewing Site Properties 

After initiating a subscription, you may want to inspect its properties and signing authorities. This can be useful 

when tracking down the origin of a particular Fixlet message or action. Here's how: 

 Click the site from the Domain Panel on the left. 

The Site Properties will appear in the Work Area, detailing information about the site publisher and the precise 

URLs from which the content has been gathered.  

 

 

Depending on its type, a site may have other properties as well. A custom site will let you assign permissions 

for owning, writing and reading a Site. External sites (except BES Support) can have restrictions placed on both 

computers and operators, letting a Master Operator fine-tune the domain of a Site. To access these extra 

properties, click the appropriate tab. 
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Restricting Computers 

There may be occasions where a BES Client or a group of Clients is storing redundant Fixlet messages, 

typically due to an overlap in site content. In addition, some BES Clients may collect superfluous Fixlet 

messages, as when a Linux machine retrieves Windows Fixlets. This poses no problem to the operation of 

BigFix, which knows to ignore irrelevant or redundant Fixlet messages, but it may consume precious Client disk 

space.The Site Subscription dialog lets you narrow down the number of clients subscribed to the selected 

external Site. Here's how: 

1. Select the desired site from the Domain Panel. 
 

 
 

2. Select the Computer Subscriptions tab. You have three choices for selecting computers. 

 All computers. Click this button to automatically subscribe all BigFix Clients to this site. This is 
the default action. 

 No computers. Click here to unsubscribe all BigFix Clients. 

 Computers which match the condition below. Click here and then create a condition that 
must evaluate to TRUE for the BigFix Client to be subscribed to the site. The default is to parse 
computer names, but the pull-down list contains several properties that you can use as useful 
subscription criteria. Press the plus sign to add more criteria. You can combine conditions by 
ANDing or ORing them. 

3. When you are satisfied with how your computers will subscribe to this site, click Save Changes from 
the Work Area Toolbar. Enter your private password to propagate the subscription request to your 
network.  
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Restricting Readers 

Restrictions can be placed on Sites to limit access. As with operator permissions on Custom Sites, you can 

restrict both the operators and computers of most external Sites. 

Not all operators need to know about all sites, and some sites may be most easily managed by a single 

operator, such as an appointed Anti-Virus Czar or the Finance IT Manager. If you have Master Operator 

privileges, you can limit how many Non-Master Operators are able to view any specified Site. Here's how: 

1. Select the desired site from the Domain Panel. 
 

 
 

2. The site properties open in the Work Area. Click Operator Permissions.  
3. The default is to allow only Master Operators to gain access to the selected site. You can't delete 

Master Operators, but you can Remove All Non-Master Operators and then add back any group of 
operators you desire. Click the Add operator button and use Ctrl and Shift-click to select eligible 
operators from the list. 

4. When you're satisfied with your selection, click OK.  
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Creating Custom Sites 

You can create a Custom Site to host your own Fixlet messages that are pertinent to your network. Here's how: 

1. Select Tools > Create Custom Site.  
2. You will be prompted for a name for your custom site. Enter a name and click OK. 
3. In the work area that appears, you can define your site.  

 

 
 
From the Details tab, enter a description of your site. From the Domain pull-down menu, select a 
Domain to house your site.  
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4. From the Computer Subscriptions tab, indicate which subset of your BigFix Client computers you 
wish to subscribe to this site.  
 

 
 
There are several choices:  

 All Computers. Click this button to automatically subscribe all BigFix Clients to this site.  

 No Computers. Click this button if you are not yet ready to subscribe any computers.  

 Computers subscribed via ad-hoc custom site subscription actions. This choice requires 
you to create an Action that will subscribe relevant computers to the site.  

 Computers which match the condition below. This choice allow you to describe a set of 
criteria that must all evaluate to TRUE before a BigFix Client will be subscribed. From the pull-
down menu, you can select from dozens of properties to test for inclusion.  

5. From the Operator Permissions tab, you can grant specific access permissions to specific operators.  
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6. There are several options:  

 Grant read permission globally. Click this button to provide read permission to all operators.  

 Or click specific Operators from the list and assign them specific rights, such as Owner, Writer, 
Reader or None.  

7. Click the Save Changes button above the work area to complete the description of your site. You must 

enter your password to propagate your new custom site.  

Canceling a Subscription 

You can afford to be adventurous in trying out Site subscriptions for your organization, since no actions are ever 

taken without your approval. Nevertheless, if you find that a subscription isn't useful, you can cancel it by 

removing the site from the domain that it resides in, as follows:  

1. In the Domain Panel, expand the icon containing Sites. From the External or Custom icon, select the 
site you wish to delete. 

2. Open the site and from the Work Area Tool bar, click the Remove button. 
3. Click Yes on the confirmation dialog, and enter your password to complete the site removal. 

 

NOTE: You can't unsubscribe from the BES Support site — it's needed to upgrade and manage licensing 

issues in the BES Console program. 
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Domains 

Introducing Domains 

Domains represent the major organizing principle in the BigFix Console. Domains contain a set of related sites, 

such as Patch Management for various operating systems. Domains are designed to reflect the duties of 

specific Console Operators, such as Patch Management, AntiVirus Management, Power Management, etc.  

Domains are situated on the leftmost panel of the BigFix Console. 

 

Select the desired Domain from the buttons at the bottom of the panel. The contents of the domain are then 

displayed. Some Domains have extra structure, such as in this example that includes two Content Filters. Here 

there is a filter for Application Vendors and another for Operating System Vendors. These allow you to narrow 

down the viewable content by Vendor.  



BigFix Console   

Operator's Guide 34 © 2010 by BigFix, Inc. 

Generally there will be a Domain Overview, to help you understand the extent of the content. 

 

This particular overview shows you at a glance what new Fixlets, Analyses, Tasks, etc. have recently been 

added to the Domain.  

In the General Content section, the information available can be further broken down by opening the various 

topics, content types and folders. For most topics here, a single click will cause the contents to show up in the 

List Panel, top right. On items with a disclosure icon (plus/minus or triangle icon), you can click it to open up 

filtering options. Drill down through any folders to reach a leaf node that represents a subset of the original 

topic. Now, in the List Panel, only the specified subset will be displayed. 
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Here the Fixlets and Tasks have been opened to disclose the Source Severity folder. Within that folder, only 

the Critical Fixlets have been selected, making the ultimate List Panel shorter and easier to deal with. 

In general, there will be a Sites section that you can open to examine the sites individually should you need. 

Different domains will have different structures, so feel free to explore them. 
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Domain Sites 

Domains are composed of related sites, grouped together for convenience and because they share a similar 

structure. You can easily examine the Sites that compose a Domain. 

 

Simply find the Sites topic and click the disclosure icon, opening the navigation tree to External and Custom 

sites. Click the disclosure icon next to External to view the various Sites. Each site is clickable if you wish to 

look at its top-level properties. 
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Click the disclosure icon to the left of the site icon to examine subsets of the data. You can continue to drill 

down until you reach a leaf node, allowing you to examine specific subsets of each site. When you finally reach 

the subset you desire, the content is displayed in the List Panel. 
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Selecting Domains 

You will typically have several Domains available to you, each covering a group of related tasks that fall into the 

purview of a specified Console Operator. As you add sites to your Console, they will naturally find their way into 

the appropriate Domains, and they will create new Domains when needed. The Domain Panel is on the left side 

of the BigFix Console, and buttons corresponding to the Domains appear at the bottom of that panel. 

 

When you click a Domain Button, an Overview is typically displayed in the Work Area. It often presents a list of 

the most recent additions to the content for a quick appraisal. 

At the bottom of the button list is a pull-out menu that lets you adjust the number of buttons you wish to display.  
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Navigating Domains 

Domains are a logical collection of sites that all have similar purposes and structure. As a consequence, each 

Domain will reflect that unique structure and display its contents appropriately. Nevertheless, all sites have 

certain similarities in how they manage content, and a simple domain is sufficient to explore most of their 

options and how to navigate amongst them. The example used here is Patch Management. 

 

Click the Domain button to view it in the Domain Panel. For this example, there is a section at the top labeled 

Content Filters. Not all domains have a section like this, but sections are fairly common when there is a benefit 

to grouping the information into logical partitions. Here, there is a way to group the content based either on the 

vendor (such as Adobe, Microsoft, etc.) or the OS (Mac, Windows, Linux, etc.).  
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You can click the disclosure icon (either a plus-minus icon or a rotating triangle icon, depending on your 

operating system) or double-click the tree node itself to open it up and explore its subheaders. 

 

The second section, General Content, presents the domain content in a more generic fashion.  

 

At the top of the General Content section of the Domain Panel is an icon for the Domain Overview. Click this 

icon to see general information about the domain, typically including some of the latest additions. 
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Below that is an icon corresponding to All Fixlets and Tasks. This icon represents the main content of the 

domain, and is created by a union of Fixlets and Tasks combined from all the sites that make up this domain. 

You can open this category and drill down by sources or severity. Under the Source Severity folder is a 

breakdown of the content that allows you to select only critical, important or other categories of Fixlet severity to 

concentrate on. Click on these icons once to see all the content that fits this criteria show up in the List Panel to 

the right. Click twice to open the icon for further winnowing of the content by source. Finally, at the leaf node, 

you can click the icon to produce a list of the filtered content in the List Panel. 

All of these navigation icons work the same. A single click will highlight the particular category and a double 

click will open it for further refinement. In general, each icon can be a destination or the head of a new tree to 

examine. When you click it, the particular subset of data implied by that icon will open in the List Panel to the 

right. 

Note that Fixlets, Tasks, Analyses, Actions, Baselines, Computers and Computer Groups are almost 

always represented in the main navigation tree of any given Domain. Other content, such as filters, custom 

content and custom sites are often represented as well. As the Operator in charge of a Domain, you will find it 

easy to see the overall structure at a glance. From there, drilling down to filter and narrow your selections will 

quickly become second nature. 

Minimizing the Domain Panel 

Should you find yourself needing more screen real estate, you can minimize the Domain Panel by clicking the 

minimize icon at the upper right of the panel. 
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That will reduce the panel to a small stub at the left of the Console window. To restore the Domain Panel, click 

the stub. 
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Deleting Domains 

A Domain can be deleted once it is created by deleting all of its constituent sites. In the Domain Panel, find the 

icon for the collection of sites. 

 

Open up the site icon, and navigate to External sites. Double click each site in turn and use the Remove button 

at the top of the Work Area to delete all of the sites that exist there. Do the same for any Internal sites. The 

Domain should disappear at that point. 
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Actions 

Introducing Actions 

Actions represent the core functionality of the BigFix system. Fixlet messages, Tasks, and Baselines depend on 

Actions to execute their remediation mission. 

Actions are typically scripts that can customize a specific solution for each BigFix Client, using the power of 

Relevance expressions. Although the Relevance language itself can't alter a Client, it can be used to direct 

Actions in a way that parallels the original trigger. For instance, a Fixlet might use the Relevance language to 

inspect a file in the system folder. Using a similar Relevance clause, the Action can then target that same file 

without knowing explicitly where that folder resides. This allows the Action author (and issuer) to concentrate on 

the issue at hand without worrying about the vagaries of each individual computer system. 

You can inspect an Action script before you execute it by looking at the Details tab of Fixlet messages and 

Tasks.  

 

You can also write your own custom Action scripts. For more information, see the BigFix Action Language 

Reference. 
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Viewing Actions  

To view information about an Action, click the desired Action from any Action List Panel. 

 

At the top is a toolbar with four icons.  

 Stop: Click this button to halt the deployment of the Action. 

 Restart: Once stopped, you can click this button to restart it. 

 Export: Click this button to save a copy of this Action, which you can then hand-edit and import as a 
custom Action. 

 Remove: Delete this Action from the database. This button is available for any stopped Action. 

In the bottom panel, there are three tabbed dialogs. 

 Summary: This tab summarizes the Action, with sections on the status of the Action and the progress 
of the download. There is information on the behavior of the Action, including users, execution options 
and post Actions. You can also view the actual relevance clause and the text of the Action script. At the 
bottom of this dialog is a text box where you can insert a comment that will attach to this Action. 

 Computers: This tab shows you the computers that are reporting in for this Action. If the Action was 
originally targeted to specific computers, then a result will be shown for each targeted computer. 
However, if the Action was originally targeted by properties, only computers that respond are displayed, 
and the tab is labeled Reported Computers. 

 Target: This tab lets you look at the set of computers that were targeted for this Action. 
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Deploying the Action 

At the heart of the BigFix system is the ability to deploy Actions to fix one or many computers. Actions are 

scripts that direct the application of updates, registry changes and other remediation to BigFix Clients. Fixlet 

messages, Tasks and Baselines all have attached Actions that you can target to any of the computers in your 

BigFix network. Here's how: 

1. Open a relevant Fixlet or Task from the List Panel by clicking it. Make sure the Description tab is 
selected.  
 

 
 
Read the description carefully.  

2. Click on the Details tab and research the Action. Examine the Relevance section and the Action script 
itself. 

3. From the Description tab, click the link or button corresponding to the Fixlet Action. The Take Action 
dialog box will appear.  
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It will list the name of the action at the top.  

4. In the Preset pull-down, you can accept the default setting or select Policy to establish an open-ended 
Action with no expiration date.  

5. If you wish, you can fine-tune the list of targeted computers using the Target tab.  
 

 
 
Use the computer tree in the left panel to filter the list in the right panel.  
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6. Create an optional message that will show up on BigFix Client computers using the Messages tab.  
7. Set the various scheduling constraints and behaviors with the Execution tab. Use the other tabs in this 

interface to further modify the Action settings.  
8. Any BigFix Operator with Custom Authoring permissions can modify the Action Script as well. 
9. Click the OK button at the bottom of the Take Action dialog box. You will be asked for password 

authentication.  
10. Enter the authentication password and click OK.  

The action will be propagated to all the computers targeted in the Take Action dialog. Once the action has 

executed and the targeted computers are fixed, those computers should no longer report this Fixlet message as 

relevant. 

Monitoring Actions  

When you decide to take a proposed Action you have several deployment options. For example, you might 

schedule the Action to take place unattended after midnight or to take place explicitly with user involvement 

during the day. 

After Actions have been scheduled, the BigFix Server attempts to signal individual computers that Actions are 

waiting for them. Ideally, the BigFix Client gathers the Action information from the Action site and carries it out 

immediately. More typically however, some computers are powered off and others are mobile and undocked at 

the time of the deployment. As soon as these computers are powered on or docked to the network, the 

remedial Actions will be applied to them as well.  

To monitor a deployed Action:  

 Click the Actions icon in the Domain Panel navigation tree.  
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If you haven't yet deployed an Action or all Actions have completed, this list will be empty. Otherwise, 
click any Action to view its status, whether it is evaluating, waiting, running, fixed or failed. You can, 
among other things, add comments to the Action, either for yourself or other operators. 

The Actions may go through several states as they are collected, evaluated and run by the clients. These states 

include: 

 Running: The Action is currently executing. 

 Evaluating: The Action is still evaluating its relevance. 

 Failed: The Action has failed to execute properly. 

 Cancelled: The user has cancelled the Action. 

 Download Failed: The Action failed to complete the download. 

 Locked: The computer is locked and can't execute the action. 

 Offers Disabled: Offers cannot be presented on the specified client, so the Action will never run. 

 Waiting: The Action is waiting on a user response. 

 Pending Downloads: The Action is waiting on downloads. 

 Pending Restart: The Action is waiting for a restart from the Client computer. 

 Pending Message: The Action is waiting for the user to accept the Action message. 

 Pending Login: The Action is waiting for the user to login for a user-assisted Action.  

 Pending Offer Acceptance: The Action is waiting for the user to accept the offer. 

 Constrained: The Action has been constrained by a Relevance statement set in the Execution tab of 
the Take Action Dialog.  

 Expired: The Action has passed its expiration date. 

 Postponed: The Action has been postponed by the Client. 

 Invalid Signature: The Action can't run due to an invalid signature. 

 Not Relevant: The Action is not relevant on this Client. 

 Not Reported: The Action has not reported its success or failure. 

 Error: The Action has resulted in an error. 

 Fixed: The Action has completed, resolving the issue. 
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Stopping an Action 

Should you ever find it necessary to stop execution of an action that has already been deployed but hasn't 

expired yet, follow these steps: 

1. Click on the Actions icon in the Domain Panel navigation tree. This will bring up a List Panel of all 
current and previous actions. You can filter or sort them by State or Time Issued to help you find the 
action you wish to stop.  

2. Right-click the action and choose Stop Action from the pop-up menu.  
 

 
 
Alternatively, select Stop Action from the Edit menu or click the Action and from the Work Area toolbar 
click the Stop button. 

3. You will need to enter your password to confirm the Action halt. 

This will remove the action from the BigFix Server, which — subject to details of a given computer's network 

connectivity and gather frequency — will quickly terminate the action on each computer in your BigFix network.  

If you want to modify an action that has been deployed but hasn't finished running, you must first stop the action 

as described here and then start a new action with the desired characteristics. There is no way to modify the 

targeting or scheduling of an action once the deployment is initiated. 
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Restarting an Action 

If you have stopped an action before it finished, you can start it up again with this command: 

 Select Restart Action from the Edit menu. Alternatively, you can select the same command from the 
right-click context menu, or select the Restart button from the open Action in the Work Area below. 
 

 

This will place the action back on the server, which will then begin to target the action to the relevant machines. 
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Commenting on Actions 

You can attach a comment to Actions that other operators can read.  

1. Select the Actions icon in the Domain Panel navigation tree and choose one of the categories in the 
drop-down to narrow down your list.  

2. Select an Action from the list on the right by clicking it. 
3. Click on the Summary tab.  

 

 
 
Scroll to the bottom of the dialog to the Comments section. 

4. Type your comment into the text box and click the Add Comment Button. 

Your comment will be name- and time-stamped for other operators to view it. As well as with Actions, you can 

attach comments to Fixlets, Tasks, Computers and Analyses.  

Default Actions 

Many Fixlet messages (but not all) have a default Action. Such a message can have its Action execute 

automatically, simplifying the interface: 

 Right-click a Fixlet, Task or Baseline object and choose Take Default Action from the pop-up menu. 
Or click and select Edit > Take Default Action. (This option is only available when the chosen Fixlet or 

Task has a default action).  

Often, a suite of related Fixlet messages becomes relevant all at once. If they each have default actions, you 

can apply all of them as a Multiple Action Group. This is a powerful technique that allows you to fix multiple 

vulnerabilities across multiple machines with a couple of mouse-clicks. As with all power tools, you should 

exercise caution. Here's how to automate multiple Action deployments: 

1. Select (using shift- or ctrl-click) the set of Fixlet messages you want to group.  
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2. Right-click one of the highlighted Fixlet messages and choose Take Default Action from the pop-up 
menu.  

3. From the dialog that pops up, you can refine the targeting of the actions, set an onscreen message, 
modify the deployment schedule and more.  

4. Typically, if any Action in a group fails, the other Actions are stopped as well. If you want to continue 
with the other Actions anyway, then check the box labeled Run all member actions of action group 
regardless of errors from the Execution tab.  

5. Click OK to execute the default action(s).  

Custom Actions 

You can create custom actions to fix problems or address issues across your network that are not covered by 

the standard content. Although the process is simple to describe, there are a large range of actions and 

targeting techniques at your disposal. To create a custom action: 

1. Log on to the BigFix Console as an Operator with Custom Content permissions.  
2. Select Tools > Take Custom Action.  
3. The Take Action dialog pops up. At the top is a place to provide a Name for your custom action.  

 

 
 
This field can be sorted and filtered, so a good naming convention will let you get the most out of your 
lists and reports.  

4. Under the Name field is a pull-down menu that allows you pick a Preset customized action, saving you 
time and ensuring accuracy. You can also save your current input as a preset for later use. There are 
two built-in presets: Default and Policy.  Normally, you will select Default, but if you wish to create an 
Action that has no expiration date, select Policy. The Preset interface includes the following fields and 
buttons:  

 Preset: Select a preset from the pull-down menu.  
 Show only personal presets: Filter the list of presets to just your personal ones.  
 Save Preset: Save the current set of action options for later use. This button isn't active until 

you make a change to one of the options somewhere in this dialog. When you click this button, 
a dialog pops up prompting you for the name of your preset. A check box below that lets you 
save it as a public or private preset.  

 Delete Preset: Removes this preset from the selectable list. It brings up a confirmation dialog 
allowing you to cancel this command.  



BigFix Console   

Operator's Guide 54 © 2010 by BigFix, Inc. 

5. Under the Presets, there are several tabbed dialogs:  
 Target: Select the targets from the provided list, or use properties or a specific list of computers 

to target the action.  
 Execution: Lets you constrain the execution schedule and allows you to specify the retry 

behavior for execution and failure.  
 Users: Lets you run an Action based on user presence. You can also expose specific users or 

groups of users to a Client User Interface. 
 Messages: Lets you provide a message to precede and accompany the Action.  
 Offer: Allows you to advertise the existence of programs or patches that your networked BigFix 

Clients can opt into. This grants extra control to your users to customize their setup. 
 Post-Action: Describe what actions need to be done to complete the action, including restarts 

or shutdowns.  
 Applicability: This tab allows you to modify the original relevance clause.  
 Success Criteria: This tab allows you to determine what constitutes a successful outcome for 

the action.  
 Action Script: This tab allows you to create an action script.  

6. Click on the Action Script tab and type in an action script. For more information on the Action Script 
dialog, refer to the BigFix Action Guide.  

7. Click on the Applicability tab if you would like to fine-tune the targeting of your action script. For more 
information about the Relevance language, see the BigFix Relevance Language Reference and the 
BigFix Inspector Guides.  

8. Click on the Users, Messages, Execution or Post-Action tabs to further customize your action.  
9. When you are ready to deploy your custom action, click OK.  
10. Your custom action will be distributed to all the computers that have been selected or targeted. The 

actions will be applied using whatever execution constraints and schedules you've specified.  
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Making an Offer 

You can offer your BigFix Clients a set of downloads or other actions that they can select at their own discretion 

(also referred to as self-provisioning). These offerings are delivered as a type of Custom Action, so they include 

all the targeting and scheduling you would expect from a typical Action. To advertise such an offer, follow these 

steps: 

1. Select Tools > Take Custom Action.  
2. The Take Action dialog pops up. Click on the Offer tab. 

 

 
 
At the top of this tabbed dialog is a place to provide a Name for your Action Offering. This field can be 
sorted and filtered, so a good naming convention will let you get the most out of your lists and reports.  

3. Check the box labeled Make this action an offer. This will make the rest of the dialog editable. 
4. Enter a Title for the offering in the text box. This is how your BigFix Clients will first see the offering, so 

the title should be aimed at them.  
5. Enter a Category for this offering in the text box. This is an extra field for Client bookkeeping purposes. 

One company may want offering categories like Installers and Uninstallers; another might want 
Applications and Updates. 

6. Enter a Description in the appropriate HTML area, outlining the nature of your Offer. As with the other 
HTML editors in BigFix, you can change fonts, sizes, styles, numbering, and formatting to customize 
the description.  
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7. Click on the other tabs in the Take Action dialog to further customize the Action that will advertise your 
offering. 

8. When you're ready to deploy your Offering, click OK. 
9. Your Action Offer will be distributed to all the computers that have been specifically targeted. This 

select group of users will then be presented with your Offer and prompted to accept it on their own 
schedule. 

Client Computers 

Introducing Client Computers 

Client Computers represent those computers in your network running the BigFix Client. Once the client software 

is installed, you have a high level of control over these machines, allowing you to maintain common operating 

environments, roll out the latest patches, detect spyware, view and summarize properties, create reports, and 

much more.  

Client computers can have settings applied to handle a multiplicity of features, including the ability to define and 

organize corporate departments. Client computers can be automatically grouped according to these settings or 

other computer properties, allowing you to target specialized remediation to distinct domains. Settings are used 

to define Relays, bandwidth, idle time, buffers and much more. 

The Computers icon in the Domain Panel navigation tree in the main interface lets you quickly stay on top of 

your network, with the ability to filter and sort large numbers of computers by dozens of properties.  

The Visualization Tool allow you to quickly monitor large, globally distributed networks, so you can follow 

remediation deployments and compliance, corporate-wide. Web Reports allow operators with access to a 

browser to view audit trails and generate listings and graphical reports with just a few mouse-clicks. 
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Monitoring Computer Status 

Although BES is primarily a preventive maintenance tool, it can also be used to analyze the computers in your 

network. Using the BigFix Relevance Language, you can query any BigFix Client and get a real-time response. 

This can be invaluable for analyzing trends and potential problem areas on your network. To view the 

computers on your network, sorted and filtered by various properties, follow these steps: 

1. Select the Computers icon in the Domain Panel navigation tree. Your networked BES Client computers 
appear in the List Panel, ready to be sorted and filtered by various properties. 

2. Click on By Retrieved Properties (in the navigation tree under the Computers icon) and open up 
folders to filter the list.  
 

 
 
Click on the desired column headers (in the resulting List Panel) to sort the list. Click again to reverse 
the sort order.  
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The folder names and column headers represent important, continuously updated properties of your networked 

computers, called retrieved properties. To view the Relevance Expressions that define the column headers: 

1. Select Manage Properties from the Tools menu. A dialog pops up, initially listing the default properties 
that come predefined by BigFix, such as OS, CPU, Computer Name and so on. 

2. Click on a retrieved property. In the text box underneath, you can view the Relevance Expressions that 
are used to define this column.  
 

 
 
For example, the column heading CPU is generated by the following Relevance Expression:  
 
(significant digits 2 of (speed of main processor / mhz)) as string & "Mhz" & family name of main 
processor... 
 
That is, CPU is a concatenation of relevance expressions and strings that will produce an output like: 
 
2800 Mhz Pentium 4  

3. Each property has an evaluation period. The shorter the period, the more often the client will evaluate it. 
That makes the Console more up-to-date, but it may impact client performance. Make sure long periods 
are allocated to time-consuming or slowly changing Relevance evaluations. 

You can quickly select which properties to display by right-clicking the column headers of any Computer List 

Panel. A pop-up menu is displayed that allows you to simply check or uncheck the properties you want to 

display. Notice that when you delete a property from the headers, it also disappears from the navigation tree 

under the Computers tab. 
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Grouping Computers 

BES Console allows you to group your computers so that you can target them more efficiently. You might want 

to group your development computers, for instance, to make sure you don't interfere with certain legacy 

software projects. There are several ways to group computers, but the two most common techniques are 

Manual Grouping and Automatic Grouping. Manual groups are static, but automatic groups can change 

dynamically, depending on the current values of the inclusion properties. 

Once grouped, you have provided yourself with a simple way to filter and separate your networked computers. 

Open the Computers icon in the Domain Panel navigation tree and select the folder named By Group. Then 

you can select the group or groups you want to list. Alternatively, you can click the Computer Groups icon and 

select groups under that icon as well. 

Whenever a list of computers is presented, you should find the By Group folder/filter. For instance, when you 

click an Action button in a Fixlet or Task, you will see the Relevant Computers icon, listing just those 

computers that are affected by the selected Fixlet. Open the By Group folder to narrow the list of computers 

down to just the selected group(s).  

NOTE: A computer can belong to more than one group.  

Commenting on Computers 

You can attach a comment to a BigFix Client Computer that other operators can read.  

1. Select the Computers icon in the Domain Panel navigation tree and open it if you wish to choose one 
of the Computer subcategories to narrow down your list.  

2. Select a computer from the List Panel on the right by clicking it.  
3. From the document panel below, select the Summary tab. 
4. Scroll to the bottom of the page, type your comment into the text box and click the Add Comment 

Button. 

Your comment will be name- and time-stamped for other operators to view it. As well as Computers, you can 

attach comments to Fixlets, Tasks, Actions and Analyses.  

Creating Retrieved Properties 

You can collect information from BigFix Clients by defining various retrieved properties. An impressive range 

of computer attributes can be monitored as retrieved properties. There are several reasons why you might want 

to create some custom retrieved properties of your own: 

 Once you create a retrieved property it can be used as a filter in all subsequent computer listings, 
allowing you to tame datasets that might otherwise be difficult to visualize.  

 Your newly-created properties will be added to the column headers of computer listings, allowing you to 
sort on their values.  

 Retrieved properties can be used to fine-tune the targeting of Fixlet actions. 

 Retrieved properties can also be used and charted in BES Web Reports.  
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BigFix ships with a predefined set of retrieved properties which are sufficient to group computers by many 

frequently requested criteria. There are times, however, when you may want even more control over how your 

BigFix Clients are grouped and sorted. 

To create a custom retrieved property, follow these steps: 

1. Choose Tools > Manage Properties. The Manage Properties dialog is displayed. 
 

 
 
You can filter the properties by using the left filter panel to select a subset of the properties to view on 
the right. 

2. If you can't find what you want in this list, create a new property: click Add New, type in the name of 
your new retrieved property and create a Relevance Expression to evaluate. This can access hardware 
characteristics, registry entries and even data in specific files on the client computers. After you define 
the new property, the BigFix Clients will automatically compute the value of the corresponding 
relevance expression and return it to the BigFix Database. 

3. Click the OK button. 

Note: Some of these properties are aimed at specific operating systems and will return a blank string for other 

operating systems. If more than one result is retrieved for a property, the entire list is retrieved.  

Creating Client Dashboards 

You can create custom Client Dashboards, similar to those in the BigFix Console. Dashboards are HTML files 

with embedded Relevance clauses that can analyze the local computer and print out the current results. BigFix 

Clients with a dashboard have an extra tab to display the resulting report.  
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To create a Client Dashboard, you must create a new folder named __UISupport (note the leading underlines) 

in the __BESData folder. This is a subfolder of the BigFix Client folder, so the final pathname looks like:  

Program Files/BigFix Enterprise/BES Client/__BESData/__UISupport  

Place the Dashboard file (named _dashboard.html) and any accompanying graphics files into this folder. The 

next time the Client starts up, it will incorporate these files into its interface, adding a tab labeled Dashboard. 

When the user clicks on this tab, the Dashboard will calculate the latest values of each Relevance clause and 

display them.  

The Relevance statements are embedded in the HTML inside special tags with the form:  

<?relevance statement ?>  

For instance, to find and print the time, use the following:  

<?relevance now ?>  

When the BES Client displays the page containing this statement, the BES Client evaluates the Relevance 

clause ―now‖ and substitutes the value for the tag. The following sample HTML prints out the word ―Date:‖ and 

then the current date and time:  

<html>  

 <body>  

  Date: <?relevance now ?>  

 </body>  

</html>  

To allow the user to refresh the Relevance evaluation, add this line to the file:  

<html>  

 <body>  

  Date: <?relevance now ?> 

  <A 

href="cid:load?page=_dashboard.html">Refresh</A>  

 </body>  

</html>  

This link, labeled Refresh, causes the page to reload. When it does, it reevaluates the relevance clauses. It is 

easy to see how you would add other Relevance expressions to this page. For instance, to print out the OS and 

the computer name, add these two lines:  

<html>  
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 <body>  

  Date: <?relevance now ?> 

  Operating System: <?relevance name of operating system 

?>  

  Computer Name: <?relevance computer name ?>  

  <A href="cid:load?page=_dashboard.html"> Refresh </A>  

 </body>  

</html>  

You can use style sheets to format the output. You can even use the default style-sheet, offer.css for some 

preset formatting. Here is an example of a Dashboard with a title, a header, a refresh link and a section of 

retrieved property values:  

<html> 

 <head> 

  <link type="text/css" rel="stylesheet" ref="offer.css"></link> 

  <title>BigFix Dashboard Example</title> 

 </head> 

 <body>  

  <div class="header"> 

   <div class="headerTitle">  

    <font size="6"><?relevance computer name ?></font></div> 

   <div class="headerCategory"> 

    <font size="1">(Last updated: <?relevance now ?>)</font><BR> 

    <div> 

     <font size="1"><a 

href="cid:load?page=_dashboard.html">Refresh</a></font> 

    </div> 

   </div> 

  </div> 

  <div class="section"> 

   <div class="sectionHeader">Computer Information</div> 

   <div class="subsection"> 

    <table> 

     <tr><td valign="top"> OS: </td> 

     <td><?relevance operating system ?></td></tr> 

     <tr><td valign="top"> RAM: </td> 

     <td><?relevance (size of ram)/1048576 ?> MB</td></tr> 

     <tr><td valign="top"> DNS Name: </td> 

     <td><?relevance dns name ?></td></tr> 

    </table> 

   </div> 

  </div> 

 </body> 

</html>  
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This dashboard file produces an output like the following:  

 

To learn more about Relevance expressions, see the BigFix Relevance Language Reference.  

Locking Computers 

You can change the locked status of any BigFix Client in the network. This lets you exclude specific 

computers or groups of computers from the effects of Fixlet actions. This could be useful, for instance, if you 

want to insulate certain development computers from any changes or updates. It also provides a powerful 

technique for testing new Fixlet actions on a limited set of unlocked computers, while keeping the rest of the 

network locked down. Client computers can be locked forever (until explicitly unlocked) or for a defined period 

of time.  

Changes are made to the locked status of a BigFix Client by sending an action. As a consequence, the BigFix 

Console operator must supply proper authentication in order to lock or unlock any computer. Even though a 

BigFix Client is locked, there is still a subset of actions that can be accepted by the client. These include clock 

changes and unlock actions as well as actions from the BigFix Support site. 

In order to lock or unlock a computer, follow these steps: 

1. Click on the Computers icon in the Domain Panel navigation tree to bring up the List Panel of 
networked BigFix Client computers. 

2. Select the computer(s) that you wish to lock. 
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3. Right-click and select Edit Computer Settings from the pop-up menu. (Or select Edit Computer 
Settings from the Edit menu). The Edit Setting dialog appears. 
 

 
 

4. The Edit Settings dialog pops up. Click the checkbox to either lock or unlock the computer. 

Although the Console doesn't provide an explicit interface for setting an expiration date on the lock, you can 

create a custom Action to do so. For more information, see the BigFix Action Guide. 

Removing Computers 

This feature allows you to remove computers which you believe are no longer reporting to BigFix, such as 

decommissioned computers. When you remove a computer from the database, you do not need to uninstall or 

unsubscribe the client. Should the client get reactivated and report back to the Console, the computer will 

reappear in the database with its old information intact. Until then, the client will simply not be listed in the 

BigFix Console. 

To remove a computer from the BigFix database, follow this procedure: 

1. Click the Computers icon in the Domain Panel navigation tree to bring up a list of BigFix Clients in the 
List Panel.  

2. Right-click a Computer in the list and select Remove from Database from the context menu (or select 
Remove from the Edit menu). 

3. Confirm the removal in the subsequent dialog. 

This computer will no longer be visible in the BigFix Console unless reactivated by the BigFix Client itself. 
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Computer Groups 

Introducing Computer Groups 

Grouping your BigFix Client computers can simplify the maintenance of large networks. There are many ways 

to group computers, from simple manual selection to more flexible automatic grouping.  

A simple grouping technique is to manually select members of a group from the listing in the Computers List 

Panel. For a quick look at a manual selection, click View as Group from the right-click context menu. This will 

bring up an Ad-Hoc Computer Group document in the Work Area where you can quickly analyze various 

properties of the group. Ad-hoc groups are temporary, but you can create persistent groups by choosing Add to 

Manual Group from the same context menu. These techniques are simple, but in a network with many 

thousands of computers, they can be tedious. 

A more powerful technique is to define criteria for Automatic Grouping. From the Tools menu, select Create 

New Automatic Group.  

 

Here you can define membership in a group based on the values of specific computer properties. You could, for 

instance, group computers by IP address ranges, operating systems, applications and thousands of other 

criteria using Relevance expressions. Groups created this way have the benefit of automatic enrollment and 

expulsion, so that a computer that is repurposed to a different task or department will automatically switch 

groups without operator intervention. 
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Creating Manual Computer Groups 

To Manually create a computer group, follow this procedure: 

1. Click the Computers icon in the Domain Panel navigation tree and in the resulting List Panel, shift- and 
ctrl-click to select the computers you want group together.  

2. Right-click the computers you've chosen and select Add to Manual Group from the pop-up menu. 
3. From the Select Manual Computer Group dialog, you can choose to add your selected computers to 

an existing group or create a new group for them.  
 

 
 
Select an existing group or name a new one and click OK. 

4. Enter your password to propagate the new manual group. 

This computer group is added under the Computer Group icon in the Domain Panel navigation tree and will 

help you subdivide your networked computers down into more reasonably sized chunks.  
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Creating Automatic Computer Groups 

To create a group that will automatically enlist computers, follow this procedure: 

1. Click Tools > Create New Automatic Group. 
2. From the Create New Automatic Computer Group dialog, enter the name of your group and select 

the site and domain you want it to reside in. 
 

 
3. Enter a property, a relation and a value into the three boxes at the bottom of the dialog. For instance to 

create a group that will automatically enlist Windows computers, select OS contains Win. Click the + 
button to add new properties that you can AND (include all properties) or OR (include any properties) 
together to identify group membership.  

4. When you are done, click OK and enter your password to propagate the group settings.  

You now have a new Automatic Computer Group that will be listed under the Computer Groups icon in the 

Domain Panel navigation tree and can be used to subdivide your network into more workable chunks. Unlike 

Manual Groups which are statically defined, Automatic Groups will change their population depending on the 

evaluation of the group properties.  
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Commenting on Computer Groups 

You can attach a comment to a Computer Group that other operators can read. 

1. Open the Computer Groups icon in the Domain Panel navigation tree and choose one of the 
categories under the icon to narrow down your list.  

2. Select a computer from the resulting List Panel on the right by clicking it.  
3. From the document panel below, select the Description tab. 
4. Scroll to the bottom of the page, type your comment into the text box and click the Add Comment 

Button. 
 
 

 

Your comment will be name- and time-stamped for other operators to view it. As well as Computer Groups, you 

can attach comments to Fixlets, Tasks, Actions and Analyses.  

Removing Computer Groups 

To remove a computer from BES administration, follow this procedure: 

1. Click the Computer Groups icon in the Domain Panel navigation tree.  
2. Right-click a Computer Group from the resultant List Panel and select Remove from the context menu 

(or select Remove Computer Group from the Edit menu).  

3. Provide your password to confirm the deletion. 

This computer group will be deleted from the list. 
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Operators 

Introducing Operators 

When you install BES, you will also set up specific personnel to act as Operators. There are three classes of 

operator: 

 The BES Site Administrator is responsible for installing and maintaining the BES components, as well 
as managing the certificates and keys. Only the Administrator can create new users. 

 The BES Console Master Operators can assign management rights to other operators. 

 The BES Console Operators are the day-to-day managers of their own domains, but they can't assign 
management rights. 

Often these administrative roles will overlap and one person may be assigned multiple duties. 

Assigning Management Rights 

In a typical BES deployment, there may be thousands of computers sharing a centralized Fixlet database. If 

they are all administered by a single BES Console, there may be an overwhelming amount of information to 

view and the response rate may suffer. In addition, most companies wish to limit the actions of various 

managers to specific domains or departments. Each department head can be assigned management rights to 

his or her own departmental computers. For even larger networks, these departments can be broken down 

again. Because different managers can be assigned to overlapping groups of computers, any kind of 

configuration is possible. Managers only receive information from their assigned computers, dramatically 

improving responsiveness. 

Here's how to grant or revoke management rights: 

1. Log in to the BES Console as a Master Operator (you must have a properly-authorized user name 
created with the BES Administration Tool). If you don't have the proper authorization, you will not be 
allowed to edit management rights. 
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2. Click on the Console Operators icon in the Domain Panel navigation tree to bring up the List Panel of 
all authorized BES Operators. (If you don't have the proper authorization, this icon may not be 
available).  
 

 
3. Right-click an operator and select Assign User Management Rights from the pop-up menu. (Or select 

Assign User Management Rights from the Edit menu).  
4. From the dialog, you can grant specific management rights to the selected operator. Click the Add 

button, which will bring up a computer filter.  
 

 
5. Using retrieved properties as a filter, select the desired subset of computers you wish to have 

administered by this Console operator, and click OK.  
6. You can also revoke management rights using this dialog box. Simply click the Delete button which will 

bring up another computer filter. Select the computers you want to remove from this operator's 
administration and click OK.  

7. Click the OK button to finalize the setting. 

Management rights are distributed as Actions, so you will see a brief Action Progress dialog as the new rights 

are deployed.  
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Monitoring Operators 

If you are a Master Operator (you must have a properly authorized user name created with the BES 

Administration Tool), you can monitor what other operators are doing and what computers they are authorized 

to administer. 

Each operator is represented by a Name, Master Operator status and Last Login Time. To view the list of 

Console Operators, select the All Content Domain and then click the item labeled Console Operators from 

the Domain Panel. In the List Panel on the right, all the current Operators will be listed. 

Click any desired operator from the appropriate List Panel to open the Console Operator work area.  

 

There are three tabs: 

 Administered Computers: This tab presents a list of computers that are currently assigned to the 
selected BigFix Console operator. 

 Issued Actions: This tab presents a list of actions that have been issued by the selected BigFix 
Console operator. 

 Management Rights Assignment: This tab displays the current assignment of rights to this Operator. 
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Analyses 

Introducing Analyses 

Analyses allow the BigFix Operator to view and summarize various properties of BigFix Client computers across 

a network. There are several pre-made Analyses supplied by BigFix that examine important aspects of your 

networked computers, including their hardware, applications and Server/Relay/Client relationships. 

Studying these default Analyses can be instructive when you want to make your own or customize existing 

ones. Custom Analyses can help you monitor aspects of your network that are vital to your company's 

operation.  

The Retrieved Properties that underlie each Analysis are created using Relevance expressions. For instance, to 

make sure you have fully deployed the most recent BigFix Client software, you might use an expression such 

as version of client. This simple expression will be evaluated on every computer where the analysis is 

targeted, allowing you to see explicitly which version of the BigFix Client is running on each computer, or to 

view a summary of how many machines are running each version. 

Analyses are targeted with yet another Relevance statement -- which may be as simple as TRUE, which would 

include all connected Clients. Generally, you'll want to narrow the scope with a Relevance statement such as 

name of operating system as lowercase starts with "win", which would limit the Analysis to Windows 

computers only. 
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Viewing Analyses 

To display an Analysis, 

1. Click the Analyses icon in the Domain Panel navigation tree. 
2. Click an entry in the resulting Analysis List Panel. 

The body of the Analysis shows up in the Work Area below the list (click the Description tab if not already 

selected). 

 

The Analysis display region has several tabs: 

 Description: This is an HTML page providing a description of the analysis.  
 Details: This screen provides a property-by-property listing of the chosen analysis, as well as the 

Relevance statement that is being used to target the chosen computers. At the bottom is a text box for 
entering a comment that will become attached to this analysis. 

 Results: This dialog lists the actual results of the analysis, which can be filtered and sorted by the pre-
assigned properties (this tab is only available if the Analysis is activated). 

 Applicable Computers: This is a filter/list of all the computers where the selected analysis is 
applicable. You can filter the list by selecting items from the folders on the left, and sort the list by 
clicking on the column headers.  
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Monitoring Analyses 

When an analysis is activated, BigFix will add it to the list displayed by the Analyses icon in the Domain Panel 

navigation tree. The Analysis List Panel contains entries that can be sorted by the following column headers:  

 Name: The name assigned to the Analysis by the author.  
 Status: The activation state of the Analysis.  
 Site: The name of the site that is generating the relevant Analysis.  
 Applicable Computer Count: The number of BES Clients in the network currently being analyzed.  
 Activated By: The name of the Console operator who has activated this analysis.  
 Time Activated: The date and time the analysis was activated.  

As with all the icons in the Domain Panel navigation tree, you can filter this list by opening the Analyses icon 

and selecting any of the icons beneath it. Each icon you click will narrow down the list of Analyses on the right. 

Then, in the listing area itself, you can sort the Analyses by clicking a column heading.  

For example, you might filter the list by opening the Activated Analyses sub-icon, then opening the Activated 

By folder and selecting a specific BigFix Operator to see the subset of analyses that have been activated by 

that Operator. 

Commenting on Analyses 

You can attach a comment to an Analysis that other operators can read.  

1. Select the Analyses icon in the Domain Panel navigation tree and choose one of the subcategories 
underneath it to narrow down your list.  

2. Select an Analysis from the resultant List Panel on the right by clicking it.  
3. In the Work Area below, select the Details tab. Scroll to the bottom of this dialog to the comments text 

box.  
4. Type your comment into the text box and click the Add Comment button. 

Your comment will be name- and time-stamped for other operators to view it. As well as Analyses, you can 

attach comments to Fixlets, Tasks, Actions and Computers.  
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Creating Analyses 

Analyses allow you to create and track specified properties of your managed BigFix clients. These properties 

can be extracted from any subset of your network, which simplifies the process of managing inventory, 

licensing, security and policies. Using Web Reports, you can view a history of each analysis. 

Analyses are also the only way for Non Master Operators to create retrieved properties, since they don't have 

access to the Manage Properties Dialog. 

To create your own custom Analysis follow these steps: 

1. Select Tools > Create New Analysis...  
2. This brings up the Create Analysis dialog with a text box for entering the name of your new Analysis.  

 

 
 
You can use the name for sorting and filtering, so it's worth creating a consistent naming convention to 
make your Analyses more accessible. Enter the name and then select the host site and domain for the 
Analysis from the drop-down menus at the right. The dialog contains three tabs. Click through each to 
define your Analysis:  

 Description: In this dialog, you can enter the text that will describe your Analysis. You can 
choose from the text editing tools at the top of the text box to create your custom content. 

 Properties: Add the retrieved properties that form the core of your Analysis by clicking the Add 
Property button, then providing a name and a Relevance expression that will be evaluated to 
create the returned property value. 

 Relevance: Enter another Relevance expression that will determine which computers will be 
selected for this Analysis.  

3. Check the box at the bottom of the dialog if you want to automatically activate the Analysis. When 
you're satisfied with your Analysis definitions, click OK.  

4. Your Analysis needs to be propagated, so you will be prompted for your private key password. Once 
you enter it and click OK, your Analysis will be sent to all the BigFix Clients, which will evaluate it for 
relevance and report back their status. You will now be able to monitor specific properties of your 
networked BigFix Clients from the Console.  
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Editing Analyses 

To edit an Analysis, follow these steps: 

1. Open the Analyses icon in the Domain Panel navigation tree, and select My Analyses as a filter. In the 
resultant List Panel, select the Analysis you want to edit. Note that not all Analyses are editable.  

2. Select Edit > Edit Custom Analysis (or right-click the Analysis and select Edit Custom Analysis from 
the pop-up menu). 

3. This brings up the Edit Analysis dialog.  
 

 
 
Enter the Name of the Analysis and then select the hosting site and domain from the pull-down menus. 
Below this, there are three tabs. Click through each to customize your Analysis:  

 Description: Enter the description of the Analysis, explaining the properties that are being 
analyzed. 

 Properties: This is the crux of the Analysis.  
 



BigFix Console   

Operator's Guide 77 © 2010 by BigFix, Inc. 

 
 
Click Add Property or choose an existing property and the relevance box becomes editable. If 
you are adding an new property, enter its name and relevance to define it. Otherwise, edit the 
existing text. The Relevance clause will be evaluated to provide the retrieved property value. 
You can add more properties, or click the Remove Property button to delete the highlighted 
one. 

 Relevance: Here is where you define a Relevance statement to target specific computers for 
your Analysis. 
 

 
 
Simply select All computers or enter an expression that will target just a subset of your 
networked BigFix Clients. 

4. When you are satisfied with your edits, click OK.  
5. Your Analysis needs to be propagated, so you will be prompted for your private key password. Once 

you enter it and click OK, your edited Analysis will be sent to all the BigFix Clients. 
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Hiding Analyses 

You can hide an Analysis with the following procedure: 

1. From any Analysis List Panel, select the Analysis you want to hide. 
2. Right-click the Analysis and select either Globally Hide Analysis or Locally Hide Analysis from the 

context menu (or select these same choices from the Edit menu). 

The selected Analysis will no longer be displayed in the Analysis list. If you elected to hide the Analysis locally, 

it will still be visible to other Console users. If you are a master operator, you can hide an Analysis globally, so it 

will also be hidden to all non-master users. 

Items that are hidden are still available and you can restore or unhide them at any time. Here's how: 

1. Click on the Show Hidden Content icon in the Console toolbar. 
2. Right-click the Analysis you wish to restore and select the appropriate action from the pop-up menu. 

You can unhide or switch the hiding scope between global and local. 

Relays and Servers 

Understanding BigFix Relays 

BigFix Relays are optional network components that can significantly improve the performance of your BigFix 

installation. Downloads and patches, which are often large files, represent by far the greatest fraction of BigFix-

related bandwidth. Relays are designed to take over the bulk of the download burden from the BigFix Server. 

Rather than downloading patches directly from a BigFix Server, Clients can instead be instructed to download 

from designated BigFix Relays, significantly reducing both server load and client/server network traffic. Relays 

help in the upstream direction as well, compiling and compressing data received from the BigFix Clients before 

passing it on the BigFix Server. Any Windows 200x, Windows 7, Vista or XP-based client can serve as a Relay. 

A BigFix Relay simultaneously mitigates two bottlenecks: 

 Relieves the Load on BigFix Servers. The BigFix Server has many duties, among them the taxing job 
of distributing patches and other files. A BigFix Relay can be set up to ease this burden, so that the 
BigFix Server does not need to distribute the same files to every BigFix Client. Instead, the file is sent 
once to the BigFix Relay, which in turn distributes it to several BigFix Clients. The overhead on the 
BigFix Server is reduced, on average, by the ratio of relays to clients. 

 Reduces Congestion on Low-Bandwidth Connections. If you have a BigFix Server communicating 
with a dozen computers in a remote office over a slow VPN, designate one of those computers as a 
BigFix Relay. Then, instead of sending patches over the VPN to every BigFix Client independently, the 
BigFix Server only sends a single copy to the BigFix Relay. That BigFix Relay, in turn, distributes the 
file to the other computers in the remote office over its own fast LAN. This effectively removes the VPN 
bottleneck for remote groups on your network. 
 
Note: BigFix Relays also work well to reduce total network usage when used on subnets connected 

through switches on your LAN. Please ask your BigFix support technician for more details. 

Assigning BigFix Relays is simple, and BigFix Clients can be made to automatically discover and link to them. 

Automatic discovery is recommended because it ensures optimal performance even while computers and 

relays are being disconnected and reconnected across the network.  
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BigFix Relay requirements 

A BigFix Relay takes over most of the download duties of the BigFix Server. If several BigFix Clients 

simultaneously request files from a BigFix Relay, a significant amount of the computer's resources may be used 

to serve those files. Other than that, the duties of the BigFix Relay are not too demanding. The requirements for 

a BigFix Relay computer vary widely depending on three main factors: 

 The number of connected BigFix Clients that will be downloading files. 

 The size of each download. 

 The period of time allotted for the downloads. 

The BigFix Relay system requirements are similar to those for a workgroup file server. A computer with 1 GHZ 

CPU, 256 MB RAM, and 5 GB of free space on the hard drive should be able to act as a BigFix Relay for as 

many as one thousand computers - provided that the BigFix Console operator distributes the file downloads 

over an appropriate length of time. Here are some further requirements and recommendations: 

 The BigFix Relay can only be installed on computers running under Windows 200x, 7, Vista or XP as 
well as Red Hat Enterprise Linux 4/5/6 and Solaris 10. 

 The BigFix Relay can be installed on an ordinary workstation, but if several BigFix Clients 
simultaneously download files, it may slow the computer down. 

 Workgroup file servers and other server-quality computers that are always turned on are good 
candidates for installing a BigFix Relay. 

Setting Up A BigFix (BES) Relay 

To set up a BigFix Relay, you need to designate a Windows 200x, Windows 7, Vista or XP client computer to 

take over some server duties. Once a BigFix Relay has been set up, computers on the network can 

automatically find them and connect to them (or, if you need, you can manually assign BigFix Clients to point at 

specified relays). This significantly reduces the client/server communication necessary for patch application and 

management. BigFix Clients will start to download from these designated relays, minimizing the load on thin 

connections to the BigFix Server. The BigFix Clients will also upload their status information to the BigFix 

Relay, which will compile and compress it before passing it on up to the server. 

To configure a client computer as a BigFix Relay, follow these steps: 

1. Click on the Tasks tab in the main BigFix Window. 
2. Double-click the task labeled Install BES Relay. A task window will open up below. Make sure the 

Description tab is selected. There are three choices for where to place the BigFix Relay install folder: 
o Install to the default location. This is the recommend action. It will automatically find the 

optimal location for the install folder. 
o Install to a given path This option allows you to specify another path for the BigFix Relay 

install folder. 
o Install on the drive with most free space. This action lets you automatically choose the most 

capacious drive for the installation folder. 

After the relays have been created, BigFix Clients can be made to automatically discover and connect up to 

them, always seeking the Relay that is the fewest hops away. 

If you need to manually configure your BigFix Clients, you must notify each computer that it should use a 

specific relay to point to, as described in Using BigFix Relays. 
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Using BES Relays 

Once you've set up a BES Relay you need to direct BES Clients on your network to gather from that relay, 

instead of from your BES Server. This is actually a perfect job for a computer, and BES can automatically 

assign your relays for you. This is not without risks (see the Administrator's Guide or visit 

http://support.bigfix.com for more information), but it can be a good idea for two reasons: 

 BES Clients can determine which relays are the fewest number of hops away, so your topology is 
optimized. 

 Your network configuration is constantly shifting as laptops dock and undock, as computers start up or 
shut down, or as new hardware is added or removed. BES Clients can dynamically assess your 
configuration to maintain the most efficient connections as your network changes. 

Automatic Relays 

Here's how you can ensure that your BES Client computers are automatically signing up to the nearest relays: 

1. Click on the Computers tab to bring up a filter/list of BES Client computers. 
2. Select the set of computers that you want to automatically connect to the optimal BES Relay. 
3. Right-click the highlighted computers and select Edit Computer Settings from the pop-up menu. 
4. Check the box labeled BES Relay Selection Method. 
5. Select the button labeled Automatically Locate Best BES Relay. 
6. Click the OK button. 

Manually Assigning Multiple Clients 

You can select all the computers (or any given subset) of the local net to gather from a specified relay. The 

procedure is different for setting a single computer or multiple computers. Here's how to set multiple computers 

to point to a relay: 

1. Click on the Computers tab to bring up a filter/list of BES Client computers. 
2. Select the set of computers that you want to connect to the BES Relay. Use the filter panel on the left to 

narrow down the computer list, if desired. 
3. Right-click the highlighted computers and select Edit Computer Settings from the pop-up menu. 
4. Check the box labeled Primary BES Relay. 
5. Select the name of the desired BES Relay from the pull-down menu. 
6. Click the OK button. 

Manually Assigning Single Clients 

Here's how to set a single computer to point to a relay:  

1. Click on the Computers tab to bring up a filter/list of BES Client computers. 
2. Right-click the single computer that you want to connect to the BES Relay. 
3. Select Edit Computer Settings from the pop-up menu. 
4. Check the box labeled Assign BES Relays Manually. 
5. From the Primary BES Relay pull-down menu, select the desired Relay. 
6. Click the OK button. 
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Adjusting the BES Server and Relays 

To get the best performance from BigFix, you may need to adjust the server and the relays. There are two 

important ways of adjusting the flow of data throughout your BigFix network -- throttling and caching: 

Throttling Outgoing Download Traffic: Throttling allows you to set the maximum data rate for the BES 

Server. Here's how to change the data rate: 

1. Click the Fixlets and Tasks icon in the Domain Panel navigation tree. 
2. Find and click the task labeled BES Server Setting: Throttle Outgoing Download Traffic. A task 

window will open up below. Make sure the Description tab is selected. There are three choices: 
o Set the limit on total outgoing download traffic. This choice allows you to directly set the 

maximum number of kilobytes per second you wish to grant the server. 
o Disable the setting. This option lets you open the download traffic on the BigFix Server to full 

throttle. 
o Get more information. This option opens a browser window with more detailed information on 

bandwidth throttling. 
3. If you select a throttle limit, then from the subsequent Take Action dialog you can select the desired set 

of computers to throttle. Click OK to propagate the task. 

Download Cache Size: BigFix Servers and Relays maintain a cache of the downloads most recently requested 

by BigFix Clients, helping to minimize bandwidth requirements.  

1. Click the Fixlets and Tasks icon in the Domain Panel navigation tree. 
2. Find and click the task labeled BES Relay / BES Server Setting: Download Cache Size. A task 

window will open up below. Make sure the Description tab is selected. Select the link to change the 
download cache size on the listed computers. This list may include BES Relays as well as the BES 
Server. 

3. Enter the number of megabytes to cache. The default is 1024 MB, or a gigabyte.  
4. From the subsequent Take Action dialog, select the desired set of computers and click OK.  

Dynamic Bandwidth Throttling 

When a large download becomes available, each link in your BES deployment may have unique bandwidth 

issues. There are server-to-client, server-to-relay and relay-to-client links to consider, and each may require 

individual adjustment. As explained elsewhere, it is possible to simply set a maximum value (throttle) for the 

data rates, and for this there are broad-based policies you can follow. You might, for instance, throttle a BES 

Client to 2Kb/s if it is more than three hops from a BES Relay. However, the optimal data rates can vary 

significantly, depending on the current hierarchy and the network environment.  

A better technique is to use dynamic bandwidth throttling, which monitors and analyzes overall network 

capacity. Whereas normal throttling simply specifies a maximum data rate, dynamic throttling adds a ―busy 

time‖ percentage. This is the fraction of the bandwidth that you wish to allocate when the network is busy. For 

instance, you could specify that BES downloads should not use any more than 10% of the available bandwidth 

whenever BES detects existing network traffic. Dynamic throttling also provides for a minimum data rate, in the 

case the busy percentage is too low to be practical.  

When you enable dynamic throttling for any given link, BES monitors and analyzes the existing data throughput 

to establish an appropriate data rate. If there is no competing traffic, the throughput is set to the maximum rate. 

In the case of existing traffic, BES will throttle the data rate to the specified percentage or the minimum rate, 
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whichever is higher. You must enable dynamic throttling on both the server and the client side in order for it 

work properly.  

You control dynamic bandwidth throttling with computer settings. There are four basic settings for each link:  

 DynamicThrottleEnabled: This setting defaults to zero (disabled). Any other value enables dynamic 
throttling for the given link. 

 DynamicThrottleMax: This setting usually defaults to the maximum unsigned integer value, which 
indicates full throttle. Depending on the link, this value sets the maximum data rate in bits or kilobits per 
second.  

 DynamicThrottleMin: This setting defaults to zero. Depending on the link, this value sets the minimum 
data rate in bits or kilobits per second. This value places a lower limit on the percentage rate given 
below. 

 DynamicThrottlePercentage: This setting defaults to 100%, which has the same effect as normal (non-
dynamic) throttling.. It represents the fraction of the maximum bandwidth you wish to use when the 
network is busy. It typically has a value between five and ten percent, to prevent it from dominating 
existing network traffic. (A zero for this setting is the same as 100%.) 

As with any other setting, you can create or edit the dynamic bandwidth settings by right-clicking on an item (or 

group of items) in any computer list and choosing Edit Computer Settings from the context menu.  

The specific variable names include the BES Server/Relay settings:  

_BESRelay_HTTPServer_DynamicThrottleEnabled 

_BESRelay_HTTPServer_DynamicThrottleMaxKBPS 

_BESRelay_HTTPServer_DynamicThrottleMinKBPS 

_BESRelay_HTTPServer_DynamicThrottlePercentage  

The BES Client settings:  

_BESClient_Download_DynamicThrottleEnabled 

_BESClient_Download_DynamicThrottleMaxBytesPerSecond 

_BESClient_Download_DynamicThrottleMinBytesPerSecond 

_BESClient_Download_DynamicThrottlePercentage 

The BES Gathering settings:  

_BESGather_Download_DynamicThrottleEnabled 

_BESGather_Download_DynamicThrottleMaxBytesPerSecond 

_BESGather_Download_DynamicThrottleMinBytesPerSecond 

_BESGather_Download_DynamicThrottlePercentage 

NOTES: For any of these settings to take effect, you must restart the affected services (BES Server, Relay or 

Client).  

If you set a BES Server and its connected BES Client to differing maximums or minimums, the connection will 

choose the smaller value of the two.  
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Baselines 

Introducing Baselines 

Baselines are collections of Fixlet messages and Tasks. They provide a powerful way to deploy a group of 

Actions across an entire network with a single command. 

Baselines provide a way to maintain a common operating environment, making sure that all users in any given 

domain have the same software, patches and drivers. Baselines are easy to set up, simply by selecting the 

Fixlet messages, Tasks and other Baselines that you wish to be a part of the group. To limit the scope of a 

Baseline, a Relevance expression can be used to target any subset of your network, using IP addresses, 

computer names, operating systems and many other qualifiers. 

For instance, you might make a Baseline named "All critical hotfixes," and populate it with all the current critical 

hotfixes available in the Fixlet list. Or you might create one named "Finance department baseline," designed to 

keep that particular group of computers updated with the latest financial programs, financial tables, updates and 

patches. 

Viewing Baselines 

Baselines allow you to group Fixlet messages and Tasks into a group for simple, one-click deployment. To 

display an existing Baseline, click the Baselines icon in the Domain Panel navigation tree. From the resulting 

List Panel, click an item. The body of the Baseline will show up in the Work Area below.  
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The Baseline display region has several tabs: 

 Description: This is typically an HTML page providing a descriptive explanation of the problem and an 
action to fix it.  

 Details: This tab lists the Baseline Properties, a section detailing the code behind the Relevance 
expressions and the Baseline actions, along with other Baseline properties. Scroll to the bottom to enter 
a comment as a note for yourself or other BigFix Console operators.  

 Components: This tab lists the components, namely the Fixlet messages, Tasks and other Baselines 
that are grouped into this Baseline. Baselines make a copy of the components, so it is possible for one 
of these copies to get out of sync with the underlying Fixlet or Task that spawned it. If this happens a 
message will appear saying that the source differs from the copy and allowing you to synchronize with 
the current source.  

 Applicable Computers: This is a filter/list of all the computers targeted by the selected Baseline. You 
can filter the list by selecting items from the folders on the left, and sort the list by clicking on the column 
headers.  

 Component Applicability: This is a filter/list of the various components of the Baseline. It displays the 
number of computers where the Baseline is currently applicable and, after a slash, the number where it 
it not. Double-click an item in the list to bring it up for inspection. 

 Action History: This is a filter/list of any Actions that have been deployed from this Baseline. If the 
Baseline is new, there won't be any Actions in the list. Like the other filter/lists in the BigFix Console, 
you can filter the actions using the left panel, and sort them by clicking the column headers.  

Monitoring Baselines 

When Baselines become relevant somewhere on your network, the BigFix Console will add them to the list of 

Baselines to be displayed under the Baselines icon in the Domain Panel navigation tree. You can filter this list 

by opening the icon and selecting one of the subsets. In the resulting List Panel on the right, you can sort the 

Baselines by clicking one of the column headings that may include the following fields: 

 Name: The name assigned to the Baseline by the author.  
 ID: A numerical ID assigned to the Baseline by the author.  
 Site: The name of the site that is generating the relevant Baseline.  
 Applicable Computer Count: The number of BES Clients in the network currently targeted by the 

Baseline.  
 Open Action Count: The number of actions open for the given Baseline. 

If you don't see one of the columns listed above, right-click in the Baseline header and select it from the pop-up 

menu. 

Commenting on Baselines 

You can attach a comment to a Baseline that other operators can read. 

1. Select the Baselines icon in the Domain Panel navigation tree and open it if you want to choose one of 
the Baseline subcategories to narrow down your list.  

2. Select a Baseline from the List Panel on the right by clicking it.  
3. From the document panel below, select the Details tab and scroll to the bottom of the page. 
4. Type your comment into the text box and click the Add Comment Button. 

Your comment will be name- and time-stamped for other operators to view it. As well as Baselines, you can 

attach comments to Fixlets, Actions, Computers and Analyses.  
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Creating or Customizing Baselines 

Baselines allow you to gather multiple Fixlets and Tasks into groups that can be applied at once to any set of 

target computers. The name Baseline was chosen to suggest a minimal set of conditions that could be applied 

across your network to ensure compliance with corporate guidelines. To create your own custom Baseline from 

scratch, follow these steps: 

 In a Fixlet or Task list, highlight one or more items and select Add To New Baseline from the context 
menu. You can also select Create New Baseline from the Tools menu. 

To clone off a Baseline and customize it, first select the Baseline in any list, then: 

 Select Edit > Create Custom Baseline Copy (or right-click the Baseline and select Create Custom 
Copy from the pop-up menu). 

Either way, this brings up a dialog with four tabs.  

 

At the top of the dialog, you can specify the name of your custom Baseline as well as the Site and Domain that 

will host the Baseline. Click through each of the tabs below to define your Baseline: 

 Description: This dialog lets you describe your custom Baseline as an HTML page. Edit the text, using 
the text modification bar at the top. 

 Components: You can add or customize the components of a Baseline. To add a new component, 
click the add components to group link. From the resulting dialog, you can select new Fixlet 
messages, Tasks and other Baselines to add to the existing Baseline group.  

 Relevance: Enter your relevance statement here, or modify the existing relevance statement. This 
allows you to further constrain your Baseline to specific computers. By default, this Relevance 
statement is simply TRUE, which leaves the job of targeting to the individual Fixlets and Tasks that 
make up the Baseline. For more information on the relevance language, refer to the BigFix Inspector 
Libraries. 
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 Properties: Customize the properties of your Baseline, or accept the original properties. Since you 
have customized the Baseline, you should update the source fields to reflect the new authorship. There 
are fields here specify the category, download size, source info and the CVE/SANS ID codes.  

When you are satisfied with your Baseline modifications, click OK. Your customized Baseline needs to be 

propagated, so you will be prompted for your private key password. Once you enter it and click OK, your 

Baseline will be sent to all networked BigFix Clients, which will evaluate it for relevance and report back their 

status. You will now be able to follow the deployment of your own custom Baselines from the BigFix Console.  

Hiding Baselines 

You can hide a Baseline with the following procedure: 

1. From any Baseline List Panel, select the Baseline you want to hide. 
2. Right-click the Baseline and select Globally or Locally Hide Baseline from the pop-up menu (or from 

the Edit menu). 

The selected Baseline(s) will no longer be displayed in the Baseline list. If you elected to hide the Baseline 

locally, it will still be visible to other Console users. If you are a Master Operator, you can hide a Baseline 

globally, so it will also be hidden to all non-master users. 

Items that are hidden are still available and you can restore or unhide them at any time. Here's how: 

1. Click the Show Hidden Content button in the Console toolbar. 
2. Click on the Baselines icon in the Domain Panel navigation tree, which will now show all the hidden 

content. 
3. From the List Panel, choose the desired Baseline and choose Edit > Hiding > Locally/Globally 

Unhide or right-click and choose the same option from the context menu. You can also open the 

hidden Baseline and click the Unhide button in the Work Area below. 

Generally speaking, it isn't necessary to hide Baselines, as you can simply ignore them. The main reason for 

hiding a Baseline is if you feel that the message isn't relevant to your network and could never be useful and 

you want to avoid viewing the Baseline every time you launch the Console. 
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Displays and Reports 

Web Reports 

The BigFix Web Reports program can monitor, print or archive the status of the local database. It enables you 

to get an overview of your relevant Fixlet messages and any subsequent remediation efforts. You can create 

charts summarizing the number of administered computers in your network and your overall vulnerability status. 

In addition, you will find comprehensive statistics and a list of the most common issues detected. You can drill 

down into these commonly relevant Fixlet messages at any time to see them in greater detail.  

Web Reports also has the ability to read the databases of other BigFix Servers and aggregate the data. That 

offers you a top-level view of a large or far-flung enterprise with multiple database servers. Aggregation servers 

allow you to view information from multiple networks with hundreds of thousands of computers. 

You can view the data in the BigFix database from several different points of view and save or print the output. 

You may also export the output to Excel for further manipulation. These features are provided by the BES Web 

Reports program, which can be run at any time from the desktop by selecting Tools > Launch Web Reports. 

You will need to supply your credentials to log in. When you do, you are greeted by the intro screen: 

 

There are three main links at the top of the screen. 

 Explore Data: Click this link to look at a group of predefined reports and charts that you can easily filter 
and customize. This section provides you with an instant overview of the most basic data managed by 
BigFix, including Computers, Actions, Operators and more. 

 Report List: Click this link to get a look at basic reports organized around your Fixlet content. Create 
and customize reports with a simple, intuitive interface. Some commonly-requested reports are built-in, 
such as Operating System Distribution and Vulnerability Trends. Select them for display by clicking their 
titles in the list. You can create your own custom reports and save them as either public or private 
(viewable only by you). Your public reports will be added to the reports list; your private reports will only 
be available when you log in with a correct password.  

 Administration: Click this link to gain access to various administrative functions, including scheduling 

activities, managing filters, operators, database settings and users. 
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In addition, there are two report categories to get you started. 

 Starred: This link takes you directly to favorite reports that you have flagged as starred.  

 My Authored: This link takes you to a list of those reports you have personally created. 

Here is a snippet of a typical report, summarizing the computers on your network by their properties. 

 

BES Web Reports can be viewed at any time from the BigFix Console under Tools > Launch Web Reports. 

Any BES Web Report server can be set up to aggregate data from the other BigFix Servers. Talk to your BigFix 

Site Administrator about setting up an aggregation server. Refer them to the BES Administrator's Guide for 

further information. 

The Web Reports interface is very rich and its complete documentation is beyond the scope of this guide. For 

more in-depth information, see the Web Reports Guide. 

  

Viewing Dashboards 

Depending on the sites you are subscribed to, you may have a folder icon labeled Dashboards in your Domain 

Panel navigation tree (click the All Content domain to see them all). This folder contains a list of reports that 

update in real-time, like a dashboard gauge in your car. These reports tap into the BigFix Database to provide 

you with timely and compact high-level views of your network.  

Different sites make these Dashboards available. For instance the BES Inventory and License site contains 

the Application Usage Dashboard, which shows you constantly updated statistics about various executables 
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on your client computers. Other Dashboards may report on the BES Deployment, or the status of your Patch 

rollouts. 

To run a Dashboard, simply select it from the Dashboards icon in the Domain Panel navigation tree. It will 

show up in the Work Area at the right of the screen. 

Visualizing Data 

The Visualization Tool allows you to view and manipulate data across your entire managed network. It lets 

you visualize various hierarchical relationships in your network, using an interactive 3D sphere to map the data. 

The Visualization Tool makes it possible to view a real-time graphical network map showing Fixlet relevance, 

Action status, and Retrieved Properties.  

 

As an example, you could view all computers that are currently unpatched for MS04-011 across an enterprise 

network, displayed as an Active Directory hierarchy. Then you could watch the clients change from red to green 

as they get patched in real-time across your network. As another example, you could view all BES Clients that 

are currently using Microsoft Office, colored according to version.  

Or you can create your own hierarchy. You could assign settings on all your machines named 'city', 'building' 

and 'floor'. You could then create a dynamic setting called 'location' that concatenates these properties: 

set setting location = (value of setting 'city' & ';' & value of setting 'building' & ';' & value of setting 'floor') 
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Specify a semi-colon as the delimiter of this setting to visualize your computers as a location-based hierarchy -- 

from each networked city down to the floor of every building. 

To create your own custom view of the data, follow these steps: 

1. Select Tools > Launch Visualization Tool...  
2. There are three tabs in the Visualization Parameters dialog: 

 General: Specify the desired display hierarchy from among BES Relays, Active Directory, IP 
Address or Retrieved Property. 

 Colorization: Indicate how you want to color-code the client nodes. You can base your color 
scheme on Fixlet Relevance, Baseline Relevance, Retrieved Properties, Action Status or a 
custom Relevance clause. 

 Computers: Limit the computers you want to display, using Active Directory and Retrieved 
Properties as filters. To show all the computers under BES management, click Show all 
computers. 

3. Click OK to generate your customized visualization of your network. 
4. A graph of your network, mapped onto a 3D sphere, is displayed. You can now use the Controls listed 

in the upper right corner to change your view of the data.  
5. Double-click a computer node to bring it to the forefront. Drag the elements in the graph to tweak the 

viewpoint. 
6. You can continuously rotate the model by selecting View > Spin Mode.  
7. Use the Navigation menu to move through the hierarchy, from each selected computer to its sibling, 

parent or child. 
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Part Three 

Interface Elements 

Menus 

 

File Menu 

The File Menu offers the following commands:  

 

 

Import Import .bes files, which can be default Tasks, Actions, Baselines or other content 
that you may have created or customized. 

Export Export a Task, Action, Fixlet, Baseline, etc. that you or another Console user can 
subsequently import. Exporting provides a useful mechanism for creating 
customized content. Simply export the content, edit it with any text editor, and then 
import the customized version. 

Preferences... Set refresh, BES Client heartbeat, colorizing, caching and other persistent Console 
preferences. 

Change Database 
Password... 

Change the sign-in password for the currently connected user. 

Exit Quit the program. 
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Edit Menu 

The Edit Menu offers the following commands:  

 

Cut Cut text and put in clipboard. This command is for use in the various text boxes 
that the BES Console uses for data input. 

Copy Text Copy text and put it in the clipboard. 

Copy Text with 
Headers 

Copy text, including any associated headers, and put it in the clipboard. 

Paste Insert the contents of the clipboard. This option is only activated when there is an 
editable text box on the screen. 

Select All Select all items in the current window. Depending on the window, this can be text 
from the Work Area or items in the List Panel. 

Hiding > Remove the selected objects, either Fixlets, Tasks, Baselines or Analyses, from 
the List Panel. The object itself is not actually deleted, and may be retrieved by 
clicking Show Hidden Content in the Console Toolbar. These options only 
become available when you click objects in the List Panel. Alternatively, you can 
right-click the objects and select hiding options from the context menu. There are 
four options 
 
Globally Hide:This hides the object across all BES Consoles.  
 
Globally Unhide: Relist the selected objects (either Fixlets, Tasks, Baselines or 
Analyses). To find the object, click the Show Hidden Content button.  
 
Locally Hide: Hide the object on the current BES Console only -- other Consoles 
will still display the object. The object itself is not actually deleted, and may be 
retrieved by clicking the Show Hidden Content button and selecting it from the 
navigation tree.  
 
Locally Unhide: After clicking the Show Hidden Content button, you can choose to 
unhide locally hidden content with this command.  
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Create Custom 
Object Copy... 

Create a customized clone of the currently selected object (either Fixlet, Task, 
Baseline, Computer Group or Analysis). For each copy, you can create a header 
name and compose a message to describe the associated actions. You can also 
customize or add relevance expressions to refine the targeting of the Fixlet or 
Task. 

Remove Custom 
Object 

Remove a customized object (either Fixlet, Task, Baseline, Computer Group or 
Analysis) from its list. Confirming this choice will permanently remove the 
customized object from the list. 

Edit Custom 
Object... 

Edit the Message, Action, Relevance and Properties of a customized object (either 
Fixlet, Task, Baseline, Computer Group or Analysis).  

Add Comment... Attach a comment to an object, such as a Fixlet, Task, Baseline or Action. This is a 
shortcut menu selection, equivalent to opening an object, selecting the Details tab 
and entering a comment at the bottom of the page. 

Show Action Info View information about a selected action's execution. 

Take Default 
Action... 

Execute the default action for this particular Fixlet message. 

Activate Analysis Activate an Analysis, so that the targeted clients are being queried on a regular 
basis. You will need to supply your private key password. 

Deactivate 
Analysis 

Stop the continuing Analysis of the clients. 

Edit Computer 
Settings... 

Edit the settings (locking, BES Relays and custom settings) for the selected 
computer(s). Typically, you will edit settings on a computer by computer basis, but 
you can also set multiple computer settings at the same time. 

Modify Custom 
Site 
Subscriptions... 

Change the set of computers that are subscribed to a custom site. Select a group 
of computers and click this menu item to subscribe or unsubscribe them from the 
specified custom site. 

Send Refresh Refresh the displayed list of computers by querying the database. 
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Groups > Manage groups of computers. This item expands to include: 
 
View as Group: Create an ad-hoc group from a selected set of computers. You 
may then view the Fixlets, Tasks, Baselines, Actions and Analyses that pertain to 
this particular group. 
 
Add to Manual Group...: Add the selected computer(s) to a named group. You 
can either attach the computer to an existing group or create a new named group. 
You must supply a password to propagate the new group name to the selected 
clients. 
 
Remove From Manual Group: Remove a computer from the specified group. 
First, select the group from the navigation tree on the left, then select a computer 
from the list. You must supply a password to propagate the change. 

Stop Action Stop the selected action(s). 

Restart Action Restart the selected action(s). 

Assign User 
Management 
Rights... 

Bring up a display that lets you grant and revoke management rights on a 
computer-by-computer basis. 

Find... Bring up a dialog that prompts you for the desired search field and search string. 
You can search for fields that either contain or don't contain the desired search 
string. In addition, for objects that can be hidden, such as Fixlets, Tasks, Baselines 
or Analyses, you can search based on visibility. 
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View Menu 

The View Menu offers the following commands: 

 

 

Show Hidden 
Content  

Allow hidden content, including Fixlet messages, Tasks, Analyses, etc. to be 
viewed. Content can be hidden locally (on this Console only) or globally (on all 
Consoles). In order to view this content, select this item or click the button in the 
Console Toolbar with the same name. From the navigation tree, all content will 
become visible and you can select hidden items to unhide them if you choose. 

Show Non-
Relevant Content 

Allow non-relevant content, such as Fixlet messages and Tasks, to be viewed. 
Typically BigFix operates by displaying only those items that are relevant to your 
network. Thus, out of the thousands of available Fixlets, for instance, only a few are 
brought to your attention for remediation. When an item has been remediated 
across your entire BigFix network, it is no longer relevant and simply disappears. 
This menu item allows you to examine these items, which can be useful if you want 
to clone or repurpose one for your own uses. 

Show Status Bar Display the number of relevant messages and the connected database in the status 
bar at the bottom of the BES Console window. Select this menu item to toggle its 
state.  

Refresh Fetch the latest information from the BES database. Typically, your information is 
updated automatically based on a schedule determined by your administrator (and 
by your choice in the Preferences dialog). Since refreshing causes a database 
access, you should use it with restraint. 
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Go Menu 

The Go Menu allows you to quickly select Domains and to change the focus area of the Console. It offers the 

following commands: 

 

 

All Content Open the top-level Domain that contains a combination of all Domains. 

Other Domain 
Names 

Open the specified Domain. The next few entries in this menu include the various 
Domains you have created, depending on the specific Fixlet sites you have 
subscribed to.  

Current List Move the focus of the Console to the List Panel at the top right of the Console. 

Current 
Document 

Move the focus of the Console to the current document in the Work Area at the 
bottom right of the Console. 
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Tools Menu 

The Tools Menu offers the following commands: 

 

Take Custom 
Action...  

Execute a custom command, targeted to any desired subset of BigFix Client 
computers.  

Create New 
Fixlet... 

Create a custom Fixlet message, complete with targeting and actions. 

Create New 
Task... 

Create a custom Task, similar to a Fixlet message, but used by the Console 
operator to install software, update settings or establish other local policies. 

Create New 
Baseline...  

Create a custom Baseline, allowing you to establish a grouping of Tasks, Fixlet 
messages and other Baselines that can be applied with a single click to any 
grouping of computers.  

Create New 
Analysis... 

Create a custom analysis, based on the specified properties of the BigFix Client 
computers. 

Create New 
Automatic 
Computer 
Group...  

Create an automatically defined grouping of computers, based on various client 
properties, such as name, CPU, IP Address, etc.  

Add External Site 
Masthead... 

Start a new Subscription to a BigFix Fixlet site. This command opens a browser 
window for you to select a masthead file, typically with an extension of .efxm. 

Create Custom 
Site... 

Create a custom site containing your own content. You can create custom Fixlets, 
Tasks, Analyses, etc. 

Create Custom 
Filter... 

Create a named filter that will allow you to include specific custom content, based on 
various properties. The objects available to filter include Fixlet messages, Tasks, 
Analyses, Computers and more. 
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Help Menu 

The Help Menu offers the following commands:  

 

 

Manage 
Properties... 

Create and manage properties to retrieve from your BigFix Clients, using Relevance 
clauses. These properties will get included in the column headers on client listings. 
There is a default set of properties, but you may add or delete them. Properties are 
used to filter or select subsets of BigFix Clients for Fixlet action deployment. 

Manage Signing 
Key...  

Present a dialog box to input and manage the signing key for the Action Site. 

View Recent 
Comments  

View the list of comments made by the BigFix Console operators, sorted from most 
recent to oldest. This list includes all comments, regardless of the underlying object. 

Launch Web 
Reports...  

Provide access to data reports which are collected from various BigFix Servers and 
aggregated into a set of HTML reports summarizing the history and status of Fixlet 
messages and actions across extended networks of computers.  

Launch 
Visualization 
Tool... 

Run a tool to visualize the hierarchy of your BigFix installation, from the servers down 
through the relays to the client computers. 

Contents Provide integrated help. 

Visit 
support.bigfix.com 

Launch a browser to view the BigFix support site. 

Customer 
Feedback Options 

Allow BigFix to learn from your experience. Click the button to participate in an 
anonymous survey to help us learn more about how people use the program. This 
information is used to improve your BigFix experience. 

About BES 
Console...  

Display the version number of the program, along with a URL for support. 
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Dialogs 

About BES Console 

The About dialog displays the version of the BigFix Enterprise Suite (BES) Console. It also includes a URL for 

tech support. 

 

This dialog is available by selecting: 

 Help > About BES Console... 
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Action: Computers 

You can view the status of an action as it is deployed across your network. After selecting Actions from the 

navigation tree, click an Action from the List Panel. The Action will open up in its own document window in the 

Work Area below, displaying details of the deployment.  

 

The Computers tab of the Action document shows the number of computers affected by the specified action 

directly in the tab for easy viewing. The window displays a filter/list of the computers targeted by the action, 

along with the current status of each. By clicking through the filter list, you can narrow down the list of 

computers for easier analysis. The list of computers can be sorted by clicking on the appropriate header. You 

can view more detailed information about the targeted computer by double-clicking a computer in the list.  

This set of computers was targeted when the action was initially specified, either explicitly from a list or 

indirectly by retrieved property. The deployed actions progress through a series of well-defined stages on a 

given computer. This dialog lets you track all the stages of each action across all targeted computers.  

This dialog is available by selecting Actions from the Domain Panel navigation tree and then selecting a 

specific Action from the List Panel. In the Work Area below, click the Computers tab. 

Action List and Document 

A list of Actions is displayed when you click Actions, or any of its child nodes, from the Domain Panel 

navigation tree.  
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An Action document is displayed in the Work Area of the BES Console when you click any item in this list. 

 

At the top of the Action document you'll find a description of the Action. Below that is a toolbar presenting you 

with options to Stop, Restart, Export or Remove the Action.  



BigFix Console   

Operator's Guide 102 © 2010 by BigFix, Inc. 

There are three tabs in an Action document. They are:  

 Summary: An HTML display of various action attributes, including Status, Behavior (Message, Users, 
Execution, Post-Action), Relevance, Success Criteria and Action Script. At the bottom of the page is a 
text box for entering a comment.  

 Computers: A list of the BES Clients that have responded to this action. This is a typical filter/list panel 
for computers; click a filter in the left panel to narrow down the list of computers in the right panel. When 
an action has propagated, this tab changes to Reported Computers. 

 Target: Shows what subset of computers was originally targeted by the action. 

To display an Action list, click the Actions item (or any of its child nodes) in the Domain Panel navigation tree.  

An Action document is opened whenever you click an item in an Action list.  

Action History Tab 

The Action History tab lists the deployment history of the action(s) associated with the selected Fixlet, Task or 

Baseline document.  

 

In order to see something in this dialog, you must have issued an Action. The Action History list can be sorted 

by clicking the headers, which include the ID, Time Issued, State, % Complete (based on the number of BES 

Clients reporting success), Name Site, Issued By and Type. 

This dialog is available by selecting a Fixlet, Task or Baseline icon from the Domain Panel navigation tree, 

clicking an item from the List Panel and clicking the Action History tab in the Work Area below the list. 
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Action Site Signing Key 

This dialog allows you to manage the location of your private key (.pvk), or to change the password for your 

Action signing key. 

 

The BigFix Console operator must obtain a private key (publisher.pvk or license.pvk) from the BigFix Site 

Administrator, who must first create it using the BES Admin Tool. Once these keys have been created, the 

BigFix Site Administrator will hand them out to authorized personnel, who can then propagate Actions. To sign 

an action, the authorized BigFix Console operator must browse to the appropriate private key (typically stored 

on a removable disk or memory stick) and provide a password. 

You can see this dialog by selecting Tools > Manage Signing Key.  

Action Parameter 

This dialog box makes a request for extra information required by the Action or group of Actions before 

execution. Typically there is a prompt and a text box for you to fill in with a parameter. Click OK to continue the 

Action deployment. This will typically bring up the Take Action dialog, where you can further specify deployment 

options. 

Action Progress Report  

This dialog box shows the progress of an action as it is applied across the Fixlet network. First, it shows the 

progress of any downloads (patches, updates, etc.). If there are files to download, it displays the name of the 

downloaded file, the total number of bytes, the current amount downloaded, the transfer rate and the estimated 

time to completion. 

The Actions may go through several states as they are collected, evaluated and run by the clients. These states 

include: 

 Running: The Action is currently executing. 

 Evaluating: The Action is still evaluating its relevance. 

 Failed: The Action has failed to execute properly. 

 Cancelled: The user has cancelled the Action. 

 Download Failed: The Action failed to complete the download. 

 Locked: The computer is locked and can't execute the action. 

 Offers Disabled: Offers cannot be presented on the specified client, so the Action will never run. 

 Waiting: The Action is waiting on a user response. 

 Pending Downloads: The Action is waiting on downloads. 
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 Pending Restart: The Action is waiting for a restart from the Client computer. 

 Pending Message: The Action is waiting for the user to accept the Action message. 

 Pending Login: The Action is waiting for the user to login for a user-assisted Action.  

 Pending Offer Acceptance: The Action is waiting for the user to accept the offer. 

 Constrained: The Action has been constrained by a Relevance statement set in the Execution tab of 
the Take Action Dialog.  

 Expired: The Action has passed its expiration date. 

 Postponed: The Action has been postponed by the Client. 

 Invalid Signature: The Action can't run due to an invalid signature. 

 Not Relevant: The Action is not relevant on this Client. 

 Not Reported: The Action has not reported its success or failure. 

 Error: The Action has resulted in an error. 

 Fixed: The Action has completed, resolving the issue. 

Action Script Tab 

The Action Script tab of the Take Action dialog lets you create your own action scripts. We highly recommend 

that you use the action scripts that come with each Fixlet. But should you want to customize the scripts for any 

reason, you can do it here. There are two buttons in this dialog:  

 Use the action script from the original Fixlet or Task message: This is the default for most Fixlet 
actions, and is the recommended option.  

 Use the following action script: If you opted to create a custom action script when you deployed this 
action, this button will be selected, and the following two items will determine the course of the action:  

 Action Script Type: The type of action script you want to use for this script. Some of the 
options include:  

 BigFix Action Script: This is the standard scripting language for BigFix actions.  
 AppleScript: This is Apple's scripting language for controlling computer resources.  
 sh: indicates that the action is a shell script, intended to be run by a linux / unix / bsd 

shell.  
 Action Script: Type your action script into this text box. The default is the prepackaged action 

script that came with the original Fixlet message. You can modify the existing script, or enter an 
entirely new script. Scripting is powerful and can have huge ramifications. Make sure to test 
your action on a small scale before you deploy it on your entire network!  

This dialog is available by selecting a Fixlet message from any list, then clicking an action button. From the 

Take Action dialog, select the Action Script tab. 
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Action Settings 

The Action Settings dialog lets you apply lockable Action Settings to a new or customized Fixlet message, 

Task or Baseline.  

 

Using the lock icons to the right of the screen, you can lock the individual items in under each of the tabs of this 

dialog to force the action to be run with the selected constraints.  

 At the top of this dialog is the Name of the Action. Depending on the context it may be editable, should 
you wish to rename it or add extra information to it.  

Below the Name box are some buttons that allow you to save or re-use your Action values: 

 Preset: This is a pull-down menu with the names of your existing presets, if any. Click on one to 
automatically fill out your Action settings.  

 Show only personal presets: Check this box to limit the presets to your own personal presets.  
 Save Preset: After creating custom settings for an Action, you can save them for later re-use.  
 Delete Preset: Select a preset and then click this button to delete it.  
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This body of the dialog contains several tabs, including: 

 Execution: This tab allows you to set constraints on the Action, including starting and ending dates and 
run windows. You can also set up retry counts (in case the Action fails or reverts) and allow the 
deployment to be distributed over a period of time to minimize the network load. 

 Users: Allows you to specify whether or not you require a logged-on user (or specified group of users) 
to be present before running the Action. 

 Messages: Specify informative messages to be displayed on the targeted BES Clients, along with 
options for end user interaction.  

 Offer: This tab allows you to convert this Action into an Offer, which will trigger the display of an HTML 
user interface on select BES Clients. The user has the option to select these Offers from a list. 

 Post-Action: Specify a follow-up behavior for the Action, such as a restart or shutdown, including 

appropriate warning messages. 

To lock or unlock any of the items under these tabs, simply click the lock icons to the right.  

When you've finished specifying your Action settings, click OK. Before the BigFix Console can issue the Action, 

you will need to enter your password . When you do, a progress dialog will pop up to keep you posted on the 

deployment.  

This dialog is available when you create or customize a Fixlet message, Task or Baseline. For Tasks and Fixlet 

messages, select the Actions tab, check the box next to Include action settings locks and click the Edit 

button to see this dialog. When creating or customizing a Baseline, click the Components tab, check the box 

next to Use custom action settings and click the set action settings link. 
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Action: Summary 

The Summary tab of the Action document shows various attributes of the selected Action.  

 

These settings were created when the Action was initially specified. (To change these values, see Take 

Action). To view this information for a specific Action, click the Action icon in the navigation tree and select the 

desired Action from the List Panel. Information about the Action will be displayed in the bottom window. Click on 

the Summary tab. You will see the following summary: 

 Status: Shows the basic status, indicating how many computers have Reported, or are Waiting, 
Running or Finished with this Action. 

 Downloads: This section indicates the disposition of the download (if applicable), on the BigFix root 
server. 

 Source: This section displays the Fixlet that gave rise to this Action. It includes a link to the Fixlet 
should you wish to see more information. 

 Behavior: This section displays certain behavioral information about the Action, including:  
o Messages: Describes any messages that should be displayed either before or during the 

execution of the specified Action. 
o Users: Lists the requirements for user intervention in the Action. Allows a user interface to be 

presented to select user groups. 
o Execution: Contains information about the execution of the Action, including ending time, 

reapplication and what should happen if the Action fails. 
o Post-Action: Provides information about what should happen -- including restarting or shutting 

down -- after the application of the Action. 
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 Details: This section displays information about the underlying Relevance expressions and Action 
scripts.  

o ID: The ID of the Action 
o Domain: The name of the Domain hosting this Action. 
o Type: Typically Single Action. 
o State: One of the many states of an Action as it deploys. 
o Issued: The date of issuance and the operator who issued the Action. 
o Relevance: This is a full listing of the relevance statement that will determine the targeting of 

this Action. 
o Action Script: This is a listing of the script that will be executed if this Action is relevant to the 

client computer.  
o Success Criteria: Describes what criteria will be used to determine the successful conclusion 

of the Action. 

 Comments: This is a text box that allows you to view or attach a comment to the Action. 

This dialog is available by picking an Actions from the navigation tree in the Domain Panel and then clicking on 

an Action from the List Panel. Then click the Summary tab in the Work Area below. 

Action: Target 

The Target tab of the Action document presents a read-only display of the computers targeted by the specified 

Action..  

 

The dialog shows which computers are currently targeted by the Action. The original targeting was set by the 

Take Action - Target dialog. Depending on the targeting method, this list of computers can be static or 

dynamic. There are three read-only radio buttons at the top of this dialog which correspond to the targeting 

choices made when the Action was deployed. 

 Specific Computers selected in the list below. The currently displayed computer list (typically just 
the relevant computers) will guide the application of Actions if this choice has been selected. This is the 
default behavior.  
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 All computers with the property values selected in the tree below. This button indicates that the 
Action was targeted by the specified retrieved properties. In essence, an action targeted like this is 
waiting for any BES client computer to change some retrieved property, like its OS or its disk space. 
Short-term or one-time Fixlets will typically need an expiration date (look under the Execution tab). 
Policy Fixlets, on the other hand, are often open-ended.  

 The computers specified in the list of names below. If this option was selected, you will see a list of 

computers that have been targeted for this action.  

This dialog is available by clicking the Actions icon in the Domain Panel navigation tree and then clicking on an 

Action from the List Panel. Then click the Target tab in the Action Work Area below. 

Add Comment 

The Add Comment dialog lets you attach an explanatory comment to Fixlet messages, Tasks, Baselines, 

Actions, Computers, Computer Groups and Analyses.  

 

The comment you enter here will then appear in the Description or Summary tab when you open one of the 

associated items in the workspace. 

This dialog is available by right-clicking an item from the List Panel and selecting Add Comment from the 

context menu. 
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Add Custom Setting  

This dialog box lets you create a custom Name/Value setting that will apply to the selected computer.  

 

Type a name for the variable in the first input box, and type the value of the variable in the second box. This can 

be useful for naming or otherwise attaching text or numeric values to a computer or set of computers. 

This dialog is available from the Edit Computer Settings dialog. Right-click a computer from any listing, select 

Edit Computer Settings from the pop-up menu and then click the Add button. 

Analysis List and Document 

A list of Analyses is displayed when you click Analyses, or any of its child nodes, from the Domain Panel 

navigation tree.  

 

An Analysis document is displayed in the Work Area of the BES Console when you click an item from this list.  
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At the top of the Analysis document is the name of the analysis. There is a toolbar at the top of the window, with 

the following choices:  

 Activate: Start the specified Analysis. This option is only available if the Analysis is currently 
deactivated. 

 Deactivate: Stop the specified Analysis. This option is only available if the Analysis is currently 
activated. 

 Edit: Make changes to this Analysis. This option is only available if this is a custom Analysis. 
 Export: Save a copy of this Analysis in order to import it into a different Console or deployment or to 

edit it in an external editor. 
 Hide Globally: Hide this Analysis from all Consoles. 
 Hide Locally: Hide this Analysis from the local Console only. 
 Remove: Delete the Analysis. This option is only available for custom Analyses. 

There are several tabs in an Analysis document. They include:  

 Description: An HTML page describing the Analysis, along with a link to activate or deactivate the 
Analysis. 

 Details: An HTML page listing the various Analysis attributes, including Properties and Relevance. At 
the bottom of the page is a text box for entering a Comment attached to the Analysis. 

 Results: A dialog displaying the results of the Analysis. This tab is only visible for an activated 
Analysis.  

 Applicable Computers: A list of the BES Clients where this Analysis is applicable. This is a typical 
filter/list panel for computers; click a filter in the left panel to narrow down the list of computers in the 
right panel.  

To display an Analysis list, click the Analyses icon (or any of its child nodes) in the Domain Panel navigation 

tree.  

An Analysis document is opened whenever you open an item in an Analysis list.  
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Applicable Computers Tab 

The Applicable Computers tab displays all the networked computers that are affected by the currently 

selected Fixlet, Task, Analysis or Baseline object.  

 

This is a filter/list view with a filter panel on the left, allowing you to narrow down the displayed list of computers. 

To do so, open a retrieved property or group from the left panel and select a value to filter the list. 

Like other filter/lists in the BigFix Console, you can sort it by clicking on the column headers. You can add or 

remove header properties by right-clicking in the header row. 

This dialog is available by opening a Fixlet, Task, Analysis or Baseline from the List Panel and clicking the 

Applicable Computers tab in the Work Area below. 

Applicability Tab 

The Applicability tab can be found in various Action dialogs. It lets you determine what criteria will be used to 

judge the relevance of a Fixlet Action.  

 

It is strongly recommended that you use the original Relevance expression, but you may want to customize it to 

better suit your needs. For instance, you might want to AND the entire expression with inclusion in a specified 

computer group to narrow its scope. 
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Run this action on computers for whom: 

 The relevance clause from the original Fixlet or Task Message evaluates to true. This is the 
default action, and the one most recommended. 

 The following relevance clause evaluates to true. In certain circumstances, you may wish to define a 

more or less restrictive criteria for applicability. 

If you opt for the second choice, the text box below becomes editable and you can revise the original 

Relevance clause, which is the default value.  

This tab is available from several different dialogs: 

Take Action, Take Multiple Actions, and Edit Computer Settings. 

Assign User Management Rights 

The Assign User Management Rights dialog lets you choose which computers an operator can manage.  

 

This dialog displays the current set of computers that can be managed by the selected Console operator and 

lets you add or delete computers from that set. There are two buttons in this dialog: 

 Add: Add new computers to the set of computers that the operator can manage. This brings up a 
standard filter/list box of the computers on your network. Use the values of the retrieved properties to 
filter down the group of computers for this operator. The use of retrieved properties -- including custom 
properties -- makes it simple to group computers. For instance, you may want to group computers by 
their operating system or cpu type. Or you might create a special computer setting, like department or 
location, and use that to parcel out management rights to the selected operator. Or there may be 
computers using particular applications that you want to assign to specialists in your organization.  

 Delete: This button lets you remove computers from the set of computers that the operator can 
manage. It will bring up a dialog that will let you choose which retrieved property filters you want to 
delete. (If a single filter was defining the rights, when you select Delete, it will do so without bringing up 
this dialog.) 

This dialog is available by selecting Console Operators from the Domain Panel navigation tree, right-clicking 

any operator in the List Panel and choosing Assign User Management Rights from the context menu (or 

choose Assign User Management Rights from the Edit menu). You must have logged in with Administrator 

rights to view this tab. 
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Baseline Component Applicability Tab 

The Baseline Component Applicability tab of the Computer document displays a list of Baseline 

Components that are applicable to the selected computer.  

 

The components are listed by their number as defined in the Baseline, the name of the component, the group it 

is associated with and whether or not it is relevant to the specified computer. Right-click the header to see what 

fields are available to display and sort by. 

This dialog is available by selecting Computers from the Domain Panel navigation tree, clicking a computer 

from the List Panel and clicking the Baseline Component Applicability tab. 

Baseline List and Document 

A list of Baselines is displayed when you click Baselines, or any of its child nodes, from the Domain Panel 

navigation tree.  
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A Baseline document is displayed in the Work Area of the BES Console when you click an item from this list.  

 

At the top of the Baseline document you'll find the Baseline name and a toolbar containing several tools:  

 Take Action: Click this button to execute the default Actions in this Baseline Group. 
 Edit: Bring up the Edit Baseline dialog to make changes to this Baseline. 
 Copy: Bring up the Create Baseline dialog to make and edit a copy of this Baseline. 
 Export: Save this Baseline to import into another Console or deployment or to edit it in an external 

editor. 
 Hide Locally: Hide this Baseline from the Local Console. 
 Hide Globally: Hide this Baseline from all Consoles. It can be retrieved later by clicking the Show 

Hidden Content button on the Console toolbar. 
 Remove: Delete this Baseline from the database. 

There are several tabs in a Baseline document. They include:  

 Description: An HTML page describing the Baseline and a set of Actions (implemented as links) that 
are designed to address the problem described. 

 Details: An HTML page describing the Properties and Relevance clauses behind the Baseline. At the 
bottom of the page is a text box to enter a comment to attach to the Baseline. 

 Components: Lists the Fixlet messages and Tasks that have been grouped into this Baseline.  
 Applicable Computers: Shows what subset of computer components this Baseline targets. This tab 

also indicates the current count of Applicable Computers for instant viewing. 
 Component Applicability: Lists the numbered components of the Baseline. In the Applicable 

Computer column, displays the number of computers where the Baseline component is applicable and 
following the slash, the total number of computers where the Baseline is applicable. 

 Action History: Shows the history of any Actions that have been invoked by this Baseline. This tab 

also indicates the current count of executed Actions for easy viewing. 

To display a Baseline list, click the Baseline icon (or any of its child nodes) in the Domain Panel navigation 

tree.  

A Baseline document opens whenever you click an item in a Baseline list.  
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Change Database Password 

The BES Console allows you to change the database password if you have the proper authorization. Enter the 

current password, then enter and validate the new password. 

Note: This dialog is not available if you are using using NT Authentication and thus aren’t using a password to 

connect to the database. 

This dialog is available when you select File > Change Database Password. 

Change Private Key Password 

The BES Console allows you to change your private key password.  

 

Enter your current password, then enter and validate the new password. 

This dialog is available when you select Tools > Manage Signing Keys > Change Password. 
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Comments 

BES Console Operators can make comments on most of the BES objects, including Fixlets, Tasks, Actions, 

Computers, etc. These comments can be created whenever an object like a Fixlet is selected and displayed in 

the main BES window. Here's how to create a comment for a Fixlet message: 

1. Click on the Fixlets and Tasks icon in the Domain Panel navigation tree.  
2. Right-click the desired Fixlet and select Add Comment. 

 

 
 

3. Type your comment into the dialog box that pops up. 
 

 
 

4. Alternatively, you can double-click a Fixlet message, select the Details tab and enter your comment at 

the bottom of the page.  

Similarly, you can attach comments to Tasks, Actions, Computers and Analyses. These comments can include 

keywords or operating notes. You might want to have special information about certain computers, or usage 

pointers for special Tasks. This is a free-form field, so you can make up your own rules for commenting.  
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To view an aggregated list of all comments, select View Recent Comments from the Tools menu.  

 

This dialog lists all the comments created to date, sorted by time-stamp, with the most recent comments at the 

top. The name of the Console Operator responsible for the comment is listed next to the description. Each 

comment contains a link that will open up the original object in the main window, allowing you to view the 

description and other aspects of the object.  

Component Applicability Tab 

The Component Applicability tab of the Baseline document displays a list of how many computers have been 

targeted by the specific component.  

 

The components are numbered, corresponding to their order under the Components tab.  

Following the number is the name of the component and then the Applicable Computer Count. This column is 

composed of multiple numbers in a form like '35/50 (4 unknown)'. The first number is the count of computers 

where the component is applicable, the second is the total number of computers targeted by the Baseline. 

This dialog is available by choosing the Baseline icon in the Domain Panel navigation tree, opening an item 

from the resulting List Panel and clicking the Component Applicability tab. 
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Components Tab 

The Components tab of the Baseline document displays a list of all the component Fixlet messages and 

Tasks that have been grouped into this particular Baseline.  

 

Click on the links beneath each component to view the source Fixlet or Task, or to see the actual code behind 

the Relevance statements and Action scripts. 

The components of a Baseline are copies of the original Fixlet or Task, not pointers. As such, if the underlying 

Fixlet or Task should change, the Baseline may become out of sync with the original. If this happens, the 

message Source Fixlet differs will show up in the component listing. 

This dialog is available by choosing the Baseline icon in the Domain Panel navigation tree, opening an item 

from the resulting List Panel and clicking the Components tab. 
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Computer: Action History 

The Action History tab provides a listing of all the actions that have been deployed on the specified computer.  

 

Note that unlike the general action list for all computers available from the main Actions Tab, this list contains 

only actions targeted to the selected computer.  

The Action History list has options similar to the any Action List Panel. 

To view more information about a particular action, double-click it. That will bring up the corresponding Action 

document in the Work Area. 

This dialog is available by choosing the Computers icon from the Domain Panel navigation tree and then 

clicking a computer from the list. Then click the Action History tab in the Computer document window.  

Computer: Applicable Tasks 

The Applicable Tasks tab of the Computer document lists all the Tasks that are relevant to the selected 

computer. 

 

This filter list is updated in real-time, refreshing its display as Tasks are reevaluated. You can filter the list by 

clicking on items in the left pane, and sort the tasks by clicking on the appropriate headers. 
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This dialog has the same options as the any Task List Panel. 

This dialog is available by clicking the Computers icon in the Domain Panel navigation tree and then clicking 

on a computer from the resulting List Panel. Then click the Applicable Tasks tab in the Computer document 

window.  

Computer List and Document 

A list of Computers is displayed when you click Computers, or any of its child nodes, from the Domain Panel 

navigation tree.  

 

A Computer document is displayed in the bottom window of the BES Console when you click any item from 

this list.  
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Click on the Summary tab to see essential information about this computer. Here you'll find the name, 

information about the processor and operating system. Scroll down to see more information, including how 

many Fixlet messages are relevant to this computer and how many actions are open.  

There are several tabs in a Computer document. They include:  

 Summary: Displays a list of properties that are being retrieved from this computer, as well as the Client 
Relay Status, Group Memberships, Custom Sites, Settings and Comments.  

 Relevant Fixlet Messages: A list of the Fixlet messages that are currently relevant on this computer. 
These can be winnowed down using the filter tree in the left panel, then sorted by clicking on the 
column headers. The current number of relevant messages is indicated in the tab itself, so you can see 
it at a glance. 

 Applicable Tasks: Lists the Tasks that apply to this computer. The current number of tasks is indicated 
in the tab. 

 Relevant Baselines: Lists the Baseline items (Fixlets and Tasks) that have been assigned to this 
computer. The current number of baselines is indicated in the tab. 

 Baseline Component Applicability: Shows what components of specified Baselines are applicable to 
this computer. 

 Action History: Shows what Actions have been applied to this computer. The current number of 
Actions is indicated in the tab. 

 Management Rights: Displays the names of the authorized operators for this computer. The current 

number of operators is indicated in the tab. 

A computer list is displayed when you click on the Computers icon (or any of its child nodes) in the Domain 

Panel navigation tree. 

A Computer document is opened whenever you click an item in any list of Computers.  

Computer Group: Actions 

The Actions tab of the Computer Group document provides a listing of all actions that target any member 

computer of the specified group. 

 

This dialog has the same options as the any Actions List Panel, but contains only Actions targeted to the 

selected Computer Group. 
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To view more information about a particular Action, double-click it. That will bring up the corresponding Action 

document in the bottom panel. 

This dialog is available by clicking the Computer Groups icon in the Domain Panel navigation tree and clicking 

on a Computer Group from the resulting List Panel. Then click the Actions tab in the Computer Group Work 

Area.  

Computer Group: Analyses 

The Analyses tab of the Computer Group document provides a listing of all the Analyses that have been 

deployed and allows you to filter them for the specified Computer Group.  

 

This dialog has the same options as the any Analyses List Panel. 

To view more information about a particular Analysis, click it. That will bring up the corresponding Analysis 

document in the bottom panel. 

This dialog is available by clicking the Computer Groups icon in the Domain Panel navigation tree and clicking 

a Computer Group from the resulting List Panel. Then click the Analyses tab in the Computer Group document 

window.  
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Computer Group: Baselines 

The Baselines tab of the Computer Group document provides a listing of all the Baselines that have been 

deployed on the specified Computer Group.  

 

This dialog has the same options as any Baseline List Panel, but contains only Baselines targeted to the 

selected Computer Group. 

To view more information about a particular Baseline, double-click it. That will bring up the corresponding 

Baseline document in the Work Area. 

This dialog is available by clicking the Computer Groups icon in the Domain Panel navigation tree and clicking 

a Computer Group from the List Panel. Then click the Baselines tab in the Computer Group Work Area.  

Computer Group: Computers 

The Computers tab of the Computer Group document provides a listing of all the computers that have been 

manually selected to be a part of the specified Computer Group.  
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This dialog is displayed for Manual Computer Groups only. It has options similar to other Computer lists, but 

contains only computers belonging to the selected Manual Computer Group. Note that the number of reporting 

computers is available in the tab itself, for viewing at a glance. 

To view more information about a particular Computer, double-click it. That will bring up the corresponding 

Computer document in the bottom panel. 

This dialog is available by clicking the Computer Groups icon in the Domain Panel navigation tree and clicking 

a Manual Computer Group from the List Panel. Then click the Computers tab in the Computer Group Work 

Area.  

Computer Group: Description 

The Description tab of the Computer Group document provides information about a selected Computer 

Group. This is the dialog for an Automatic Computer Group. 

 

It contains different information depending on whether the group is Automatic or Manual: 

Automatic Computer Groups contain several sections: 

 Group Definition: This is a listing of the properties that specify the inclusion of a computer into the 
group. Each is a clause of the form <property> <relationship> <value>. For instance, OS contains 
"win", would create an Automatic Computer Group consisting of Windows machines. 

 Targeting Relevance: This is the full Relevance expression that implements the property evaluation 
described above. Click on show indented relevance to see a formatted version of the expression.  

 Comments: This is a text box to enter a comment that will be attached to the Computer Group for other 

operators to view. 
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Manual Computer Groups only contain a Comment box. The information you enter here will be attached to this 

Computer Group and become available to other BES Console operators. 

This dialog is available by clicking the Computer Groups icon in the Domain Panel navigation tree and clicking 

a Computer Group from the List Panel. Then click the Description tab in the Computer Group document 

window.  

Computer Group List and Document 

A list of Computer Groups is displayed when you click Computer Groups, or any of its child nodes, from the 

Domain Panel navigation tree.  

 

A Computer Group document is displayed in the Work Area of the BES Console when you click any item from 

this list.  
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At the top of the Computer Group document is the name of the group. Under that is the Computer Group 

toolbar. It includes:  

 Edit: Open up a dialog that allows you to edit the criteria for this group. 
 Copy: Create a copy of this group and edit it. 
 Export: Save this group for editing by an external editor. 
 Remove: Delete this group from the list. 

There are several tabs in a Computer Group document, and they may differ according to the group type. They 

include:  

 Description: For an Automatic group, this tab will display the Group Definition (as a list of property-
associated Relevance expressions), the Targeting Relevance clause that implements the group 
definition, and a comment box. For a Manual group, this tab will display a comment box only.  

 Reporting Computers: Only displayed for Automatic groups, this tab is a list of the computers that are 
currently considered members of the group, based on properties and Relevance. This is a filter/list 
panel, allowing you to narrow down the list by selecting from the filtering folders on the left side. 

 Computers: Only displayed for Manual groups, this tab is a list of the computers that have been 
manually selected to be members of the group. This is a filter/list panel, allowing you to narrow down 
the list by selecting from the filtering folders on the left side. 

 Fixlets: Lists all the Fixlet messages that apply to this Computer Group. 
 Tasks: Lists all the Tasks that apply to this Computer Group. 
 Baselines: Lists all the Baselines that apply to this Computer Group. 
 Actions: Lists all the Actions that target any member of this computer group. 
 Analyses: Lists all the Analyses and allows you to filter them by Computer Group. 

To display a Computer Group list, click the Computer Groups icon (or any of its child nodes) in the Domain 

Panel navigation tree.  

A Computer Group document is opened whenever you click an item in a Computer Group list.  

Computer Group: Fixlet messages 

The Fixlets tab of the Computer Group document provides a listing of all the Fixlet messages that have been 

targeted to the specified Computer Group.  
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This dialog has the same options as any Fixlet List Panel, but contains only those Fixlet messages targeted to 

the selected Computer Group. 

To view more information about a particular Fixlet message, double-click it. That will bring up the corresponding 

Fixlet message document in the Work Area. 

This dialog is available by clicking the Computer Groups icon in the Domain Panel navigation tree and clicking 

a Computer Group from the List Panel. Then click the Fixlets tab in the Computer Group Work Area.  

Computer Group: Reporting Computers 

The Reporting Computers tab of the Computer Group document provides a listing of all the computers that 

have been automatically chosen to be a part of the specified Computer Group by virtue of their property values.  

 

This dialog is displayed for Automatic Computer Groups only. It has the same options as any Computer List 

Panel, but contains only computers reporting to the selected Computer Group. 

To view more information about a particular Reporting Computer, double-click it. That will bring up the 

corresponding Computer document in the Work Area. 

This dialog is available by clicking the Computer Groups icon in the Domain Panel navigation tree and clicking 

an Automatic Computer Group from the List Panel. Then click the Reporting Computers tab in the Computer 

Group Work Area.  
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Computer Group: Tasks 

The Tasks tab of the Computer Group document provides a listing of all the Tasks that are applicable to one 

or more computers in the specified Computer Group.  

 

This dialog has the same options as any Task list. Click any header to sort the list. 

To view more information about a particular Task, double-click it. That will bring up the corresponding Task 

document in the Work Area. 

This dialog is available by clicking the Computer Groups icon in the Domain Panel navigation tree and clicking 

a Computer Group from the List Panel. Then click the Tasks tab in the Computer Group Work Area.  

Computer: Management Rights 

The Management Rights tab of the Computer dialog lists the operators who are currently granted 

management rights to apply actions to the specified computer.  
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You can filter this list by using the filter tree in the left panel. The list has three headers that you can use to sort 

the list: 

 Name: The name of the Console operator who has been granted rights. 

 Master Operator: A Yes or No flag that indicates if the rights manager is also a BES Master Operator. 

 Last Login Time: The last time this operator logged in to the BES System 

.  

This dialog is available by clicking the Computers icon in the Domain Panel navigation tree and then clicking 

on a computer in the resulting List Panel. Then click the Management Rights tab in the Work Area below.  

Computer: Relevant Baselines 

The Relevant Baselines tab of the Computer document lists all the Baselines that are applicable to the 

selected computer.  

 

This filter/list is updated in real-time, refreshing its display as Baselines are reevaluated. The number of 

Baselines that are currently relevant are listed in the tab itself for easy viewing. Since Baselines contain content 

such as Fixlets that are targeted to computers based on relevance, different Baselines may apply to different 

computers, depending on current applicability. 

This dialog has the same options as any Baseline List Panel, and can be sorted by the same headers. You can 

open up and view individual Baselines by double-clicking them from this list. 

This dialog is available by clicking an item in any Computer list. Then click the Relevant Baselines tab in the 

Computer Work Area.  
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Computer: Relevant Fixlet Messages 

The Relevant Fixlet Messages tab of the Computer document lists all the Fixlet messages that are relevant to 

the selected computer.  

 

This filter list is updated in real-time, refreshing its display as Fixlet messages are reevaluated. The number of 

Baselines that are currently relevant are listed in the tab itself for easy viewing.  

This dialog has the same options as any Fixlet List Panel and may be sorted by the same headers. 

This dialog is available by clicking the Computers icon in the Domain Panel navigation tree and clicking a 

computer from the List Panel. Then click the Relevant Fixlet Messages tab in the Computer Work Area.  

Computer Subscriptions Tab 

The Computer Subscriptions tab of the Sites document lets you establish criteria for subscribing BigFix 

Clients to the specified site.  
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There are three buttons available for external sites. 

 All computers. Subscribe all available clients to the specified site. 

 No computers. Don't subscribe any clients to the site. 

 Computers which match... Set criteria for subscription based on client properties. This is a flexible 
technique to subscribe only those computers that satisfy the properties you specify in a property / 
operator / value trio. You can select any or all from the pull down to OR or AND the criteria together. 
Use the plus button to add another criterion and the minus button to delete one. 

For custom sites, there is another button. 

 Computers subscribed via ad-hoc custom site subscription actions. With this option all computers 
start out unsubscribed. To subsequently subscribe a computer, you must bring up the list of computers 
(click Computers from the Domain Panel navigation tree) and then right-click the desired set of 
computers. From the context menu, select Modify Custom Site Subscriptions.  
 

 
 
From the resulting dialog, select sites to subscribe or unsubscribe.  
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Only those sites where the ad-hoc option has been set will be available for subscription in the pull down 
menu. Note that this dialog also allows you to unsubscribe computers from an ad-hoc grouping. 

This dialog is available by clicking the Sites icon in the Domain Panel navigation tree, clicking an item from the 

resulting List Panel and then clicking the Computer Subscriptions tab. 

Computer: Summary 

The Computer Summary tab lists several items of interest, including Properties, Relay status, Grouping, 

Custom Sites, Settings and more. 

 

The Properties section of the Summary lists various properties of the given computer, derived from Relevance 

Expressions. These properties help you define subsets, sorting fields, reports and grouping criteria for the 

various client computers under BES administration. 

The default properties include, but are not limited to: 

Core Properties 

 Active Directory Path: The position of the BES Client within the Active Directory hierarchy.  
 OS: The operating system of the given computer.  
 CPU: The speed and type of CPU.  
 DNS Name: The name of the computer.  
 IP Address: The current IP Address of the computer.  
 Last Report Time: The time that the computer last reported.  
 Locked: The locked status (Yes or No) of each computer.  
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Custom Properties 

 BIOS: The version and date of the Basic Input/Output System.  
 Free Space on System Drive: How much room is available on drive C of the given computer.  
 RAM: The amount of RAM in the given computer.  
 Subnet Address: The subnet IP Address of the given computer.  
 Total Size of System Drive: The total size of the drive containing the OS on the given computer.  
 User Name: The name of the BES Client user.  

You can find out more about these predefined properties in the sections on computer properties and Relevance 

Expressions. 

The next section in the Computer Summary is the BES Client Relay Status, which identifies the status of the 

chosen computer as a Server, Relay or Client. 

 

The next section lists any Groups, automatic or manual, that this computer is a member of.  
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The following section lists any Sites that this computer is subscribed to, including external sites, operator sites 

and custom sites. 

 

The next sections contain a list of Settings for this computer, including Client, Relay, Server, Gather and 

WebReport settings and the versions of the BES software running on this computer. 
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Below that is the BES Relay Status, which contains information about the parent Relays of this computer. 

 

At the bottom of the page is a text box where you can enter comments that will be attached to this computer for 

future reference. 

 

This dialog is available by clicking the Computers icon in the Domain Panel navigation tree and clicking a 

computer from the right-hand List Panel. Then click the Summary tab in the Computer Work Area.  
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Connect to Database 

The Connect to Database dialog pops up when you start the BES Console.  

 

It lets you select which BES Database you wish to manage. 

Database: Select the desired database from the pull-down menu. 

Username: Enter the user name that will allow you to access the database. The set of allowed users is 

maintained by the BES Site Administrator using the BES Administration Tool. 

Password: Enter the password that corresponds to the user name above. In some cases, NT will authenticate 

for the user. If this is the case, the password box will be grayed out. 

This dialog is available when launching the BES Console. 

Console Operator: Administered Computers 

The Administered Computers tab of the Console Operator document displays a filter/list of all the computers 

administered by the selected operator.  
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Note that the number of computers is displayed in the tab itself for viewing at a glance. As with any Computer 

List Panel, you can filter and sort it by retrieved properties and groups. That means you can use your own 

custom-created properties or groupings to parcel out administrative rights. You might use a retrieved property, 

for instance, to match up specific applications to experts in your organization. Or you could connect 

departmental IT managers to their own domains, automatically. 

This list is similar to other computer lists in the BES Console, but it is specific to the selected operator, letting 

you focus on one person at a time. 

This dialog is available by clicking an operator from any Console Operator list and selecting the Administered 

Computers tab. 

Console Operator List and Document 

A list of Operators is displayed when you click Console Operators, or any of its child nodes, from the Domain 

Panel navigation tree.  

 

A Console Operator document is displayed in the Work Area of the BigFix Console when you click any item 

from this list.  
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At the top of the Console Operator document is the name of the operator. Beneath that is the toolbar for 

Operators, containing a button that allows you to assign management rights to the specified operator if you 

are a Master Operator. The tabs underneath display at a glance how many computers are being administered 

by this operator and how many actions this operator has issued.  

The tabs in a Console Operator document include:  

 Administered Computers: A typical filter/list window containing all the computers under this operator's 
administration.  

 Issued Actions: Shows what Fixlet actions have been applied by this Console Operator. 

 Management Rights Assignment: Shows the management rights that have been assigned to this 
Console Operator (This tab is only available if you have logged in to the BES Console with the proper 
credentials). 

To display a Console Operator list, click the Console Operators icon (or any of its child nodes) in the Domain 

Panel navigation tree.  

A Console Operator document is opened whenever you click an item in a Console Operator list.  

Console Operator: Issued Actions 

The Issued Actions tab of the Console Operator document displays a filter/list of all the Actions that have 

been deployed by the selected operator.  

 

At the top of the dialog is the name of the operator. As with any Action list, you can filter and sort it by various 

properties, including State (open, expired) and Site. The current number of issued actions for this operator is 

displayed in the tab itself for easy viewing. 

This list is similar to other Action lists in the BES Console, but it is specific to the selected operator, letting you 

focus on one person at a time. 

This dialog is available by clicking an operator from any Console Operator list and selecting the Issued Actions 

tab. 
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Console Operator: Management Rights Assignment 

The Management Rights Assignment tab of the Console Operator document displays a retrieved property 

tree.  

 

This tab is only available if you have logged in to the BigFix Console as a Master Operator. If there were any 

management rights assigned on the basis of a retrieved property (for instance, based on a computer setting 

named "department") you will see them here. In this example, as people changed from one department to 

another, they would automatically be handed over to a new Console operator. 

This is a read-only display. To alter these settings, click Assign User Management Rights button in the 

toolbar. 

This dialog is available by clicking an operator from any Console Operator list and selecting the Assign User 

Management Rights tab. 
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Create Analysis 

The Create Analysis dialog lets you deploy your own custom Analyses to monitor and audit properties across 

your managed network. You can create an Analysis from scratch or you can edit an existing custom Analysis by 

selecting it from the list and choosing Edit > Edit Custom Analysis. 

To create an original Analysis, choose Tools > Create New Analysis. The Create Analysis dialog pops up. 

 

There are three items at the top to help you identify your Analysis: 

 Name: Enter the name of your custom Analysis. 
 Create in site: From the pull-down menu, select the BigFix site (typically the Master Action Site) you 

want to host it.  
 Create in domain: From the pull-down menu, select the Domain you want to house the Analysis.  

Beneath these data fields, there are three tabs:  

 Description: Create a user-readable title and message to accompany the Analysis you wish to run. 
This is an HTML page, and you can use the text editing tools at the top to adjust the look of your 
Analysis.  

 Properties: Specify retrieved client properties for your Analysis. Click the Add Property button, enter a 
name and a relevance clause. You can also specify an evaluation period for this property.  

 Relevance: Specify the target client computers for your custom Analysis via a Relevance clause. The 

Analysis will be applied to all computers where the Relevance clause evaluates to TRUE.  

At the bottom of this dialog is a check box:  

 Automatically activate this analysis after it is created: Check this box if you want to immediately 
propagate this Analysis upon clicking the OK button. Leaving this blank will let you describe your 
Analysis without actually activating it.  
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You can create a new Analysis by selecting Tools > Create New Analysis, or by right-clicking in the Analysis 

window and selecting Create New Analysis from the context menu. 

You can edit your existing custom Analyses by right-clicking on them and selecting Edit from the pop-up menu. 

Create Analysis Description Tab 

The Description tab of the Create Analysis dialog lets you define the html page for your custom Analysis.  

 

Enter the description of your custom Analysis in the first box. You can customize the second box as well, but 

the existing text is pretty standard. 

You can create a new Analysis by selecting Tools > Create New Analysis, or you can edit a custom Analysis 

by right-clicking it and selecting Edit Custom Analysis from the context menu. To clone and edit an existing 

Analysis, first right-click it, select Export from the context menu to save it, then select File > Import to bring it 

back in for editing. 
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Create Analysis Properties Tab 

The Properties tab of the Create Analysis dialog lets you define the properties you wish to analyze.  

 

This is the customized heart of the Analysis, and is not the same as the Properties tab of the Fixlet, Task or 

Baseline dialogs.  

There are two buttons in the Property tab:  

 Add Property. Click this button to bring add a new property to the Analysis. When you do, the text 
areas below will become editable and you can define the property. 

 Remove Property. Highlight a retrieved property from this list to the left and click Remove Property to 

delete this item from the Analysis. 

After clicking the Add Property button, you must enter a Name for the property and a Relevance statement that 

will retrieve the information. For instance you might want to retrieve the names of the administrators for each 

client. You might name the property "Client Admins" and use a Relevance expression like "names of 

administrators of client". 

You can also set the schedule for the analysis from the Evaluate every pull-down menu. The default is to 

update the property value whenever a report is requested. But you can also set it to any regular period between 

5 minutes and 30 days. 

You can create a new Analysis by selecting Tools > Create New Analysis, or you can edit a custom Analysis 

by right-clicking it and selecting Edit Custom Analysis from the pop up or from the Edit menu. 
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Create Analysis Relevance Tab 

The Relevance tab of the Create Analysis dialog lets you define a relevance clause to determine the 

applicability of your custom Analysis to specific computers.  

 

You can choose from three relevance options: 

 All computers: This is the default choice and will analyze the properties you specify on all of the BigFix 
Clients in your network. 

 Computers which match the condition below: When you select this choice, you can select from 
several pre-defined properties to identify a subset of the BigFix Clients for analysis. 

 Computers with match all of the relevance clauses below: This choice lets you specify a computer 
with a custom relevance statement. This is the most powerful of the available choices, and lets you 
easily narrow down the computers to analyze. 

You can create a new Analysis by selecting Tools > Create New Analysis, or you can edit a custom Analysis 

by right-clicking it and selecting Edit Custom Analysis from the context menu. To clone and edit an existing 

Analysis, first right-click it, select Export from the context menu to save it, then select File > Import to bring it 

back in for editing. 

Create Automatic Computer Group 

This dialog allows you to create rules that will automatically enlist specific computers in a group. It has the 

following parts: 

 Computer Group Name: This is a text box to enter the name of your group. This will be listed in the 
name column of any computer group listing.  

 Create in site: This is a pull-down menu listing the site you wish to host the computer group. 
 Create in domain: This is a pull-down menu listing the domain you wish to host the computer group.  
 Include computers with [any/all of] the following property: This option lets you specify a condition 

that must evaluate to true before the computer will become a member of the group. If there is more than 
one condition, this option will include a pull-down menu allowing you to use any or all of the conditions 
listed. Three fields are used to define a condition:  



BigFix Console   

Operator's Guide 145 © 2010 by BigFix, Inc. 

 The retrieved property: select a property from the pull-down list containing dozens of pre-
defined retrieved properties. Note that there are two other options at the top of this list.  

 Select Relevance Expression from the top of the list, select is true or is false from 
the relationship pulldown and then click the Edit Relevance button to define a custom 
relevance expression to base your group on. 

 Select Group Membership from the property list, select the desired membership 
option and then select a manual group from the pull down list to the right. 

 The relationship: select from the four available comparison operators: contains, equals, does 
not contain and does not equal. Depending on the particular retrieved property, there may be 
other relationships available.  

 The value: Enter a value that will be compared to the value of the retrieved property. If the 
comparison is true, the Baseline will become relevant on the specified computer. For instance, 
to create a group that will automatically enlist Windows computers, enter OS contains Win.  
 
There are two buttons used to edit the list of conditions:  

 Plus (+): Click this button to add a new condition to the list. When there are two or more 
conditions, notice that the radio button above will include a pull-down menu allowing you to 
trigger on any or all of the conditions in the list. 

 Minus (-): Click this button to delete the condition associated with it. 

Click OK and enter your password to propagate the new Automatic Computer Group that will be listed in the 

Computer Groups tab.  

This dialog is available by clicking Create New Automatic Group from right-click context menu in the 

Computer Groups tab or select Tools > Create New Automatic Group. 

Create Custom Site 

This dialog lets you name your own Custom Site. 

 

Enter the name of your site and click OK. This will bring up the Custom Site dialog, where you can finish 

defining your site. 

To create a custom site, select Tools > Create Custom Site. 
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Custom Site Document 

This dialog lets you create or Edit a Custom Site. 

 

At the top is a toolbar with four buttons: 

 Save Changes: After making edits, click this button to record your changes. 

 Discard Changes: This button will clear all the changes you have made. 

 Gather: This button with gather the contents of the site. Because the contents of a custom site are 
typically stored locally, this tool may be grayed-out. 

 Remove: This button allows you to entirely remove the site from the Console. 

Beneath the toolbar are three tabs: 

 Details: This tab allows you to add or edit the description of your custom site and to select the Domain 
you want to host the site. 

 Computer Subscriptions: This tab lets you specify which BigFix Clients will be subscribed to this site. 

 Operator Permissions: This tab lets you attach Operators to the site as owners, writers or readers. 

To create a custom site, select Tools > Create Custom Site. 
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Dashboard Document 

Dashboard documents pop up in the main window of the BES Console when you select them from the 

Dashboards icon in the Domain Panel navigation tree. Dashboards tap into the BES Database to provide you 

with timely and compact high-level views of your network.  

 

This is a dashboard displaying the latest information on network-wide deployment of Microsoft patches. 

Dashboards can provide simple textual information, but often provide a visual overview as well to give you 

aggregated infomation at a glance.  

Different sites make these Dashboards available. For the best coverage, select the All Content Domain, which 

will list all available Dashboards in the navigation tree. 

A Dashboard appears whenever you open an item from the Dashboards icon in the Domain Panel navigation 

tree.  
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Description Tab 

The Description tab of provides an English-language description of the selected Fixlet, Task, Analysis or 

Baseline.  

 

It typically provides one or more actions (in the form of links) that can be executed to install a patch, change a 

registry, update an application, run an analysis, etc.  

Click the link to deploy the action or analysis across your network. For Fixlet messages, when an Action 

completes the initiating Fixlet will usually disappear since the problem no longer pertains. Tasks, Baselines and 

Analyses, on the other hand, will continue to stay activated until you terminate them. 

This dialog is available by clicking a Fixlet, Task, Analysis or Baseline icon in the Domain Panel navigation tree, 

selecting an item from the List Panel and clicking the Description tab. 
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Details Tab 

The Details tab provides a look at the mechanics behind the selected Fixlet, Task, Analysis or Baseline 

object.  

 

It includes several sections describing various aspects of the Fixlet message: 

 Properties: As seen above, this section lists various properties of the Fixlet, Task or Baseline, 
including Category, Download Size, Severity and more. These properties are defined manually when 
the object is created. 

 Relevance: This section displays the Relevance expressions that are used to determine the relevance 
of an individual Fixlet message or Task.  
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This example has multiple statements that must all be true for the item to be considered Relevant to 
any particular BigFix Client. For a Baseline, this is an 'envelope' expression that determines the overall 
relevance of the group. Only if the group is applicable will the relevance of the constituent Tasks and 
Fixlets be analyzed. This is the core information for an Analysis, which evaluates the Relevance 
expression and retrieves that value. 

 Actions: This section displays the code that will be executed if an action is deployed from either a 
Fixlet or a Task.  
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 Comment: This section lets you attach comments to the Fixlet, Task or Baseline. 
 

 

This dialog is available by clicking a Fixlet, Task, Analysis or Baseline icon in the Domain Panel navigation tree, 

selecting an item from the resulting List Panel and clicking the Details tab. 
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Edit Actions Tab 

The Actions tab of the Creation/Edit dialogs lets you craft Actions for your new or customized Fixlet or Task 

object.  

 

The Actions you create here will become the clickable links in the finished Task or Fixlet, and they will be 

deployed on the appropriate computers of your BigFix network. The Actions are listed in their display order at 

the top of the dialog. To the right of the list is a set of buttons: 

 Add: Click this button to create a new Action. It creates a new numbered entry in the top list and opens 
a blank text box for you to write your Action script. 

 Delete: Select an item from the list and click this button to Delete it. 
 Move Up: Moves the selected Action up in the list, meaning that it will be displayed earlier. 
 Move Down: Moves the selected Action down in the list, meaning that it will be displayed later. 

For each Action, you can edit the type, certain settings and the script itself.  
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Select an Action Script Type from the pull down menu. Among the choices are: 

 BigFix Action Script: This is a cross-platform scripting language, and is the default scripting type. 

 AppleScript: This is the scripting language of choice for managing Macintosh computers. 

 sh: This is shell script as used by a Unix system. 

 URL: This is a URL pointing to an appropriate script or informational web page. When an Action is 

created as a URL, it is listed as a numbered Link. 

There are some more properties you can use to modify any Action. 

 

Check one or more of the following boxes to customize each action: 

 This Action is the default Action: Check this box to make the selected Action the default for this 
group of Actions. Default Actions should be designed to be failsafe and simple, making it reasonable to 
launch them unattended or to group them for simultaneous deployment. 

 Include Action Settings Locks: Check this box to use custom settings and locks, including display 
messages, users, execution behavior and post-actions. Click on the Edit button to bring up the Action 
Settings dialog with a lock next to each item. Click on the locks to keep these values from being 
changed. 

 Include Custom Success Criteria: Typically a Fixlet is designed so that completing an Action will 
make it fail the initial Relevance test. Since that test is typically triggered by a vulnerability, its failure 
indicates successful remediation, therefore causing the Fixlet to disappear from the Console. However, 
you can select other criteria to establish success by checking this box. Click on the Edit button to bring 
up the Action Success Criteria dialog and key in your alternative criteria. 

In the bottom text box, enter the actual text of the Action Script. The style will vary depending on the script 

type you chose in the previous section. Because they can be potentially distributed to hundreds of thousands of 

computers, it is always wise to test and test again. 
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This dialog is available by clicking the Fixlet, Task or Baseline icon in the Domain Panel navigation tree. Right-

click an item in the resulting List Panel and select Create Custom Copy from the context menu. 

Or select the desired Create item from the Tools menu. 

Edit Baseline 

The Edit Baseline dialog. Baselines are groups of Fixlet messages, Tasks and other Baselines that you wish to 

execute with a single mouse-click.  

 

For instance, a Baseline might be created to group all your application patches or security issues so that you 

can ensure a common operating environment. You can create a Baseline from scratch, or clone or edit an 

existing Baseline.  

When you select this interface, you are presented with a dialog with three input items at the top: 

 Name: Enter the name of your Baseline. 
 Create in site: From the pull-down menu, select the desired host site. 
 Create in domain: From the pull-down menu, select the desired host domain.  

Beneath these data fields, there are four tabs:  

 Description: Create a user-readable title and description for the Baseline you wish to deploy.  
 Components: Specify the components, namely the Fixlet messages, Tasks and other Baselines, that 

you want to group into this Baseline.  
 Relevance: Create a relevance clause to target this Baseline to just the subset of computers you 

desire. Since each component of your Baseline will have its own Relevance clause, the default 
Relevance is set to TRUE.  

 Properties: Specify certain properties for your Baseline, including category, source, severity and date.  
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To create a new Baseline from scratch, select the following: 

 Tools > Create New Baseline 

You can also customize an existing Baseline by selecting it from any Baseline list and then choosing: 

 Edit > Create Custom Copy 

Or right-click in a Baseline list and select Create Custom Copy or Create New Baseline from the context 

menu. Similarly, you can edit an existing custom Baseline by selecting Edit Custom Baseline from the right-

click context menu. 

Edit Components Tab 

The Components tab of the Edit Baseline dialog lets you specify a group of Fixlet messages and Tasks that 

you wish to add to your Baseline.  

 

Click on the link to add components to group and then select Fixlets, Tasks and other Baselines to place into 

your group. Use the edit name link to name the group. You can place all your components into a single group 

or click the add new component group link to add structure to your Baseline. Click the red X to delete the 

associated component, and use the up (^) and down (v) arrows to change the order of the components in the 

list. 
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Check the box next to Use custom action settings if you want to modify the Baseline Action settings. Click on 

the set action settings link to bring up the Action Settings dialog.  

The components of a Baseline are copies of the original Fixlet or Task, not pointers. As such, if the underlying 

Fixlet or Task should change, the Baseline may become out of sync with the original. If this happens, the 

message Source Fixlet differs will show up in the component listing. 

At the bottom of this dialog, there is a Find command that brings up a dialog for you to enter a search string 

and options such as match whole word, match case and search direction. It will allow you to easily search 

through the components of your Baseline. 

There is also a Sync All Components button. This will force all of your Baseline components to sync up with 

the latest versions of their sources, in case they have changed. 

To create a new Baseline from scratch, select the following: 

 Tools > Create New Baseline 

You can also customize an existing Baseline by selecting it from any Baseline list and then selecting: 

 Edit > Create Custom Copy 

Or right-click in a Baseline list and select Edit, Create Custom Copy or Create New Baseline from the context 

menu. 

Edit Description Tab 

The Description tab of the Creation/Edit dialogs lets you describe your new or customized Fixlet, Task, 

Analysis or Baseline object.  

 Enter a custom Description that will constitute the body of your descriptive message. Simply click the 
description in the HTML page to modify it. 

 Below the Description box is the text describing the Action(s) you can attach to this Fixlet, Task or 
Baseline. The Action will appear as a clickable link in the Description page. Simply click the text to 
modify it, although the default phrase is familiar and usually sufficient. 
 
Note: For an Analysis, this link will activate the retrieval of the specified Properties. Technically, 
activation involves the execution of an Action, but in the case of an Analysis, it's a benign Action that 
merely establishes a property that can be read by the Console. 

This dialog is available by clicking the Fixlet, Task or Baseline icon in the Domain Panel navigation tree. Right-

click an item in the resulting List Panel and select the appropriate Create option from the context menu. 

Or select the desired Create item from the Tools menu. 
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Edit Fixlet Message 

The Edit Fixlet Message dialog allows you to create your own custom Fixlet messages. You can create a 

Fixlet message from scratch or clone an existing one and customize it. To create an original Fixlet, choose 

Tools > Create New Fixlet. You will be presented with a dialog with two text boxes at the top: 

 Name: Enter the name of your custom Fixlet message. 
 Create in site: From the pull-down menu, select the BES site you want to host it.  
 Create in domain: From the pull-down menu, select the BigFix Domain you would like to host this 

Task.  

Beneath these data fields, there are four tabs:  

 Description: Create a user-readable title and description for the Fixlet you wish to deploy. If you are 
cloning an existing Fixlet, the original title and description will be the default. This is an HTML page, and 
you can use the toolbar at the top to alter fonts and formatting.  

 Actions: Specify the action(s) for your custom Fixlet to execute.  
 Relevance: Create a relevance clause to target this Fixlet to just the subset of computers you desire. 

For a cloned Fixlet, the original relevance clause will be the default. You can replace or modify the 
relevance clause to suit your network needs.  

 Properties: Specify certain properties for your Fixlet, including Category, Download Size, Source, 

Severity and Date. 

To create a new Fixlet message from scratch, select the following: 

 Tools > Create New Fixlet  

You can also customize an existing Fixlet message by selecting one from any Fixlet list and then selecting: 

 Edit > Create Custom Copy 

Or right-click in a Fixlet list and select Create Custom Copy or Create New Fixlet Message from the pop-up 

menu. 

Edit Processing Instruction 

The Edit Processing Instruction dialog lets you write a Relevance Expression that can be embedded into the 

text portion of a Fixlet, Task, Analysis or Baseline. 
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You can enter the expression as straight text, HTML or Presentation (XML) style.  

This dialog is available whenever you create a new or custom Fixlet, Task, Baseline or Analysis. In the 

description tag, enter the text you desire, and then from the toolbar at the top, click the magic wand . This 

will bring up the Edit Processing Instruction dialog. 

Edit Properties Tab 

The Properties tab of the Creation/Edit dialogs lets you assign certain important properties to your new or 

customized Fixlet, Task or Baseline object. 

 

There are a series of text fields that you can use to describe the various possible properties: 

 Category: There are many categories you can file your Fixlet, Task or Baseline objects under, 
including the standard ones such as Setting, Update, Support and more. If you wish, you can create 
new settings for your particular installation as well. 

 Download Size: If a download is associated with your Fixlet, Task or Baseline, you can enter the size 
here. This will allow you to sort, filter and keep track of the bandwidth requirements of your various 
custom-designed objects. 

 Source: This is the source of the Fixlet, Task or Baseline. For a custom object, this is typically a name 
chosen by the BES Administrator, usually Internal. 

 Source ID: This is an ID associated with the source described above. For an Internal source, the ID is 
typically blank. 

 Source Release Date: Enter the release date of this Fixlet, Task or Baseline so you can manage these 
objects by age. 

 Source Severity: Enter the severity of the Fixlet, Task or Baseline, typically from a list including Low, 
Moderate, Important and Critical. 

 CVE ID: Enter the ID for the Common Vulnerabilities and Exposures standard, if any. 

 SANS ID: Enter the ID for the System Administration, Networking, and Security standard, if any. 
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This dialog is available by clicking the Fixlet, Task or Baseline icon in the Domain Panel navigation tree. Right-

click an item in the resulting List Panel and select Create Custom Copy from the context menu. 

Or select the desired Create item from the Tools menu. 

Edit Relevance Tab 

The Relevance tab of the Creation/Edit dialogs lets you create a relevance expression that will fine-tune the 

deployment of your custom Fixlet, Task, Analysis or Baseline object.  

 

There are several ways to specify the desired set of computers:  

 All computers: The default is simply to include all the networked BigFix Clients for this particular Fixlet, 
Task, Analysis or Baseline -- regardless of relevance.  

 Computers which match [any/all of] the condition[s] below: This option lets you specify a condition 
that must evaluate to true before the computer will trigger the Fixlet, Task, Analysis or Baseline.  
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If there is more than one condition, this option will include a pull-down menu allowing you to select any 
(ORing the conditions) or all (ANDing the conditions). Three fields are used to define each condition:  

 The retrieved property: select a property from the pull-down list containing dozens of pre-
defined retrieved properties. Note that there are two other options at the top of this list.  

 Select Relevance Expression from the top of the list, select is true or is false from 
the relationship pulldown and then click the Edit Relevance button to define a custom 
relevance expression to base your group on.  

 Select Group Membership from the property list, select the desired membership 
option and then select a manual group from the pull down list to the right.  

 The relationship: select from the four available comparison operators: contains, equals, does 
not contain and does not equal. Depending on the particular retrieved property, there may be 
other relationships available.  

 The value: Enter a value that will be compared to the value of the retrieved property. If the 
comparison is true, the Baseline will become relevant on the specified computer. For instance, 
to create a group that will automatically enlist Windows computers, enter OS contains Win.  
 
There are two buttons used to edit the list of conditions:  

 Plus (+): Click this button to add a new condition to the list. When there are two or more 
conditions, notice that the radio button above will include a pull-down menu allowing you to 
trigger on any or all of the conditions in the list.  

 Minus (-): Click this button to delete the condition associated with it.  
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 Computers on which the relevance clause below is true: Click this button to enter a custom 
Relevance expression that will be evaluated on each BES Client.  
 

 
 
If the relevance expression evaluates to true, the Fixlet, Task or Baseline becomes relevant to that 
particular client and the BES Console will reflect that status. In the case of multiple relevance 
statements, they must all be TRUE (they are ANDed together) in order for the Task or Fixlet to become 
relevant. 
 
A complete discussion of relevance expressions is beyond the scope of this documentation. For more 
information, refer to the BigFix Relevance Language Reference and the various BigFix Inspector 
Guides. For some instructive examples, make custom copies of BES Support Fixlets and examine their 

relevance statements. 

This dialog is available by clicking the Fixlet, Task, Analysis or Baseline icon in the Domain Panel navigation 

tree. Right-click the item in the resulting List Panel and select Create Custom Copy from the context menu. 

Or select the desired Create item from the Tools menu. 
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Edit Script Element 

The Edit Script Element dialog lets you create a small script to accompany a new or custom Fixlet, Task, 

Baseline or Analysis. 

 

Enter the text of your action, and click OK. For more information on Action scripts see the BigFix Action 

Language Reference.  

This dialog is available whenever you create a new or custom Fixlet, Task, Baseline or Analysis. In the 

description tag, enter the text you desire, and then from the toolbar at the top, insert the Script icon . This 

will bring up the Edit Script Element dialog. 

Edit Settings for Computer  

The Edit Settings for Computer dialog allows the BES Console operator to alter the settings for a selected 

computer. (For more settings, or to apply settings to multiple computers, see Edit Computer Settings). 
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There are several way you can customize the settings of a computer: 

 Locked. Check this box to lock the computer.  
 Assign BES Relays Manually. Relays can be automatically assigned. Uncheck this box to select 

automatic discovery (the recommended setting). If you want to manually specify a particular relay for 
this BES Client, check this box and select the desired relays from the pull-down menus below.  

 Primary Relay Server: Select the name of the primary BES Relay from the pull-down menu. 
The selected computer will now point to this relay for Fixlet downloads instead of connecting 
directly to the BES Server.  

 Secondary Relay Server: Select the name of the secondary BES Relay from the pull-down 
menu. If the primary relay is unavailable, then this secondary relay will take over the job of 
providing Fixlet downloads.  

Custom Settings: This list box contains custom named variables that can be assigned to each computer. This 

is a valuable technique for organizing a network of computers, and can help to identify individual computers as 

well as groups. The list of settings in this box can be sorted by clicking the appropriate header: 

 Name: This column contains the assigned custom variable names, e.g., "depts." 

 Value: This column lists the values of the named variables, e.g., "human resources." 

 Site: As applied by the BES Console Operator, these named variables are a part of the "local" site. 

These variables may also be set by other Fixlet sites, in which case their site name will show up here.  
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There are three buttons to the right of the list: 

 Add: Click this button to add a new custom variable to the list. 
 Delete: Click this button to delete the selected variable from the list. 
 Edit: Click this button to edit the selected named variable. This places the cursor in the value field of 

the chosen setting for editing. 

Finally, there is a More Options button at the bottom of the dialog, that expands on these functions and opens 

up the Edit Computer Settings dialog. 

This dialog is available by selecting the Computers icon in the Domain Panel navigation tree, right-clicking a 

single computer from the resulting List Panel and selecting Edit Computer Settings from the pop-up menu. 

Edit Computer Settings  

The Edit Computer Settings dialog allows BES Console operators to change certain computer attributes on a 

single or specified set of computers, including locking, making the client a BES Relay, pointing to BES Relays 

and creating custom settings.  

 

There are five tabbed dialogs on this screen to target and customize the settings for a selected group of BES 

Clients: 

 Settings: Displays a group of controls to edit computer settings, such as the locked status, relays, and 
custom variables. 

 Target: Displays a filter/list of computers that can be edited, filtered, sorted and grouped for specifically 
targeted settings. 
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 Execution: As with other Actions, you can limit the activation of the settings to any desired schedule, 
keeping in mind that the Action may take some time to deploy. Once applied, the settings will remain 
until removed. You can also specify certain user interactions and add extra targeting based on the 
contents of retrieved properties. 

 Users: Allows you specify whether or not you want a user to be logged on before activating the 
settings. 

 Messages: Allows you to issue a message to the BES Client before activating the settings. 

When multiple computers are selected, this dialog is available by right-clicking and selecting Edit Computer 

Settings from the context menu (or select Edit Computer Settings from the Edit menu). 

Edit Task Message 

The Edit Task Message dialog allows you to create a Task from scratch or clone an existing Task and 

customize it.  
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To create an original Task, choose Tools > Create New Task Message. You will be presented with a dialog 

with two text boxes at the top: 

 Name: Enter the name of your custom Task. 
 Create in site: From the pull-down menu, select the BigFix site you would like to host this Task.  
 Create in domain: From the pull-down menu, select the BigFix Domain you would like to host this 

Task.  

Beneath these data fields, there are four tabs:  

 Description: Create a user-readable title and description for the Task you wish to deploy. If you are 
cloning an existing Task, the original title and description will be the default. This is an HTML page, and 
you can use the toolbar at the top to alter fonts and formatting.  

 Actions: Specify the action(s) for your custom Task to execute.  
 Relevance: Create a relevance clause to target this Task to just the subset of computers you desire. 

For a cloned Task, the original relevance clause will be the default. You can replace or modify the 
relevance clause to suit your network needs.  

 Properties: Specify certain properties for your Task, including Category, Download Size, Source, 

Severity and Date. 

To create a new Task from scratch, select the following: 

 Tools > Create New Task  

You can also customize an existing Task by selecting it from any Task list and then choosing: 

 Edit > Create Custom Copy 

Or right-click in a Task list and select Create Custom Copy or Create New Task from the pop-up menu. 

Enter Private Key 

The Enter Private Key dialog requests a password.  

 

Type in the publisher password that you were given by your BES Site Administrator. This dialog is displayed 

whenever an action is deployed, in order to assure that only authorized personnel are allowed to update 

computers on the network. 
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Execution Tab 

The Execution tab can be found in various Action dialogs. It lets you constrain the schedule and deal 

effectively with failed or reverted Actions. This dialog also allows you to distribute the Action over a period of 

time, helping you to balance your network load. 

 

The Constraints section of this dialog lets you schedule actions and restrict the target computers: 

 Starts on [date] [time]: Check this box to define a date and time when the Action can first be 
executed. You can choose from Local Client time or Universal time from the pull-down menu. The 
choice you make here affects all of the scheduling constraints. Note that UTC is only available for 
BigFix Clients version 8.0 or better.  

 Ends on [date] [time]: Check this box to define a date and time when the Action should expire. 
 Run between [time] [time]: Check this box to define a block of time when the Action can be run. 
 Run only on [Sun,Mon,Tue,Wed,Thu,Fri,Sat]: Select specific days of the week to run the Action. 
 Run only when [Property] [Operator] [Value]: Check this box when you want to filter the BigFix 

Clients by their retrieved properties. Select a Property and an Operator from the pull-down menus, then 
select a value for comparison. The value entered must form a valid relevance expression. 

The Behavior section of this dialog lets you deal with failed Actions and recurrent relevance. The BigFix Client 

can retry any Action that is unsuccessful. It can also reapply any Action that succeeds and then subsequently 

fails. Among other things, this allows you to implement continuing policies while distributing the execution of the 

Actions over time to minimize the network load: 
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 On failure, retry XX times: Check this box to retry the action in case of a failure. If an action fails, it 
may be that the user dismissed it or that the computer crashed or was otherwise unable to execute the 
action. Select a number of retry attempts (the default is 3). and then select a condition for trying again 
from the choices below: 

 Wait XX between attempts: This button lets you select a period of time to wait before retrying 
the action (the default is one hour).  

 Wait until computer has rebooted: Select this button to wait until the BigFix Client reboots 

before trying to execute the action again.  

 Reapply this action. Check this box to keep reapplying this action as a policy.  

 Whenever it becomes relevant again: Reapply the action whenever the relevance expression 
evaluates to true.  

 While relevant, waiting XX between reapplications: Instead of immediately reapplying the 
action upon relevance, specify a period to wait between attempted reapplications.  

 Limit to XX reapplications: Continue to apply the action the given number of times, as long as 
it is still relevant. This limits a BigFix Client to a certain number of attempts (the default is 3) 
before quitting. Note that this counts as the number of attempts after the original, so a limit of 3 
will actually involve 4 attempts. Note: If an action becomes repeatedly relevant, it might be a 
sign that a client computer needs special handling.  

 Start client downloads before constraints are satisfied: If this box is checked, software downloads 
will be started before the Client has satisfied the execution constraints. This allows you to ensure that 
the download is available for execution as soon as the desired time frame begins. 

 Stagger action start times over MM minutes to reduce network load: By checking this box, you can 
force the BigFix program to space out the execution of actions. This can be useful to reduce the load on 
the network in the case of bandwidth-intensive actions (such as large downloads). It is especially useful 
for allowing BigFix Relays to effectively service hundreds of attached BigFix Clients. 

This tab is available from several different dialogs: 

Take Action, Take Multiple Actions, Action Settings and Edit Computer Settings. 
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Find 

You can find information in any of the lists (Fixlets, Tasks, Actions, etc.) whenever the focus is on that list. To 

do so, you create a Find Filter. For instance, to find a particular word in the Fixlet list, click anywhere in the 

Fixlet List Panel and press Ctrl-F (or select Find from the Edit menu).  

 

There are several section in the Filter dialog:  

Name: First, provide a name for your Find Filter in the Name box.  

Visibility: This box lets you keep the Filter to yourself or share it with other users.  

Include: This section lets you define the scope of the Find. Choose from Fixlets, Actions, Tasks or any of the 

other main categories of BigFix content. You can choose to include all (AND the properties) or any (OR the 

properties) of the following items.  

Two properties have been pre-arranged for you, but you can add or delete from these default choices. As with 

other property choices in the BigFix environment, there is a {field} {operator} {search string} triad to define. 

Here the defaults allow you to select a Name containing a value and a Visibility. Because Fixlets, Tasks and 

Analyses can be hidden, the visibility field allows you to search through these items depending whether they 

are Visible, Locally Hidden or Globally Hidden.  

When you have finished defining your Find Filter, click the Create button. Your custom filter will be placed in the 

All Content Domain, under the Custom Filters folder. To make changes, right-click it and select Edit from the 

context menu.  

This dialog is available by selecting one of the main BigFix content categories (Fixlet Messages, Tasks, 

Actions, etc.) the icon in the Domain Panel navigation tree to establish the focus, then pressing Ctrl-F or 

selecting Find from the Edit menu..  
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Fixlet and Task: List and Document 

A list is created whenever you click Fixlets and Tasks from the Domain Panel navigation tree.  

 

This list incorporates both Fixlets and Tasks, which you can filter by opening the icon and clicking any of the 

child nodes beneath it. The List Panel on the right now contains all the currently relevant Fixlets and Tasks, 

winnowed down by the filters. A Fixlet or Task document is displayed in the Work Area of the BES Console 

when you click any item in the list.  
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Fixlet and Tasks have the same basic tools and tabs available because they are similar objects. The main 

difference between the two is that a Fixlet is triggered by a vulnerability, whereas a Task is designed for 

ongoing maintenance. Both of them use Relevance clauses to target client computers and both use Action 

scripts to accomplish their goals. You can get a separate listing of each by clicking the All Tasks or All Fixlets 

node in the navigation tree.  

At the top of each document you'll find the name of the Fixlet or Task. Beneath that is a toolbar containing the 

following tools:  

 Take Action: This tool provides a pull-down menu of Actions. Select one from the menu to deploy it to 
your BigFix network. 

 Edit: Lets you edit the Fixlet or Task. This tool is only available for custom Fixlets or Tasks. 

 Copy: Lets you copy or clone the Fixlet or Task to customize its functionality. 

 Export: Allows you to export the Fixlet or Task for editing in an external editor, or for copying to another 
Console or deployment. 

 Hide Locally: Hides the Fixlet or Task on this version of the Console. 

 Hide Globally: Hides the Fixlet or Task on all networked BigFix Consoles. 

 Remove: Deletes this Fixlet or Task (only available for Custom Fixlets or Tasks). 

There are several tabs for this document. They include:  

 Description: An HTML page describing the Fixlet or Task and a set of Actions (implemented as links) 
that are designed to address the problem described. You can search any of the HTML interfaces in 
BES by pressing Ctrl-F and then entering your search string. 

 Details: An HTML page describing the Properties, Relevance clauses and Action scripts behind the 
Fixlet or Task. At the bottom of the page is a text box to enter a comment that will be attached to the 
message. 

 Applicable Computers: Shows what subset of computers is targeted by the Action. 
 Action History: Shows the history of any Actions that have been invoked by this Fixlet or Task. 

To display a Fixlet or Task list, click the Fixlets and Tasks icon in the Domain Panel navigation tree.  

A Fixlet or Task document is opened whenever you open an item in the resulting list.  
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Fixlet List and Document 

A list is created whenever you click Fixlets and Tasks from the Domain Panel navigation tree. This list 

incorporates both Fixlets and Tasks, which you can filter by opening the Fixlet and Tasks icon and clicking All 

Fixlet Messages beneath it.  

 

The List Panel on the right now contains all the currently relevant Fixlets. A Fixlet document is displayed in the 

Work Area of the BES Console when you click any message in the list.  
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At the top of the Fixlet document you'll find the Fixlet name. Beneath that is a toolbar containing the following 

tools:  

 Take Action: This tool executes the default action of Fixlet. 

 Edit: This option lets you edit the Fixlet. This tool is only available for custom Fixlets that you have 
created yourself. 

 Copy: This option lets you copy or clone the Fixlet to customize its functionality. 

 Export: This tool allows you to export the Fixlet for editing in an external editor. 

 Hide Locally: Hides the Fixlet on this version of the Console. 

 Hide Globally: Hides the Fixlet on all Consoles. 

 Remove: Deletes this Fixlet (only available for Custom Fixlets). 

There are several tabs in a Fixlet document. They include:  

 Description: An HTML page describing the Fixlet and a set of Actions (implemented as links) that are 
designed to address the problem described. You can search any of the HTML interfaces in BES by 
pressing Ctrl-F and then entering your search string. 

 Details: An HTML page describing the Properties, Relevance clauses and Action scripts behind the 
Fixlet. At the bottom of the page is a text box to enter a comment that will be attached to the Fixlet 
message. 

 Applicable Computers: Shows what subset of computers is targeted by the action. 
 Action History: Shows the history of any actions that have been invoked by this Fixlet message. 

To display a Fixlet list, click the Fixlets icon under the Fixlets and Tasks icon in the Domain Panel navigation 

tree.  

A Fixlet document is opened whenever you open an item in a Fixlet list.  

Help for the BES Console 

Show the help files for the BES Console. These online files provide a tutorial, a description of the program and 

a full-text search capacity. To get started, click here. 

This dialog is available by selecting: 

 Help > Contents 

Import Content 

The Import dialog allows you to import .bes files that you have exported or that have been sent to you by 

another operator.  

BigFix files may contain groups of Fixlet messages, Tasks, Actions or Baselines. When you open them, a 

Create dialog is displayed, along with the expected features for each content type. For more information, see 

the associated creation dialogs for the selected content.  

This dialog is available by selecting Import from the File menu.  
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Launch Web Reports 

The Web Reports dialog provides access to network information which is collected from various BES Servers 

and aggregated into a set of HTML reports. These include summaries of the history and status of Fixlet 

messages and Actions across extended networks of computers. These reports can be used to track software 

deployments and compliance across a global network of independent LANs. To start, select Tools > Launch 

Web Reports. The following dialog will appear in your browser. 

 

Web Reports is a stand-alone program that is not covered in this documentation. For more information, see the 

Web Reports Guide. 

  

This dialog is available by selecting: 

 Tools > Launch Web Reports. 

Main Console Window 

The Main Console Window has a panel on the left containing buttons and navigation trees called the Domain 

Panel. Choose an item from the Domain Panel open up the related List Panel on the right. From this list, 

specific items can be opened in the Work Area below. Here are the main parts: 

 Domain Panel: This panel provides a high-level view of the extensive BigFix content, allowing you to 
quickly subdivide the information by major IT functions. Within each domain, this panel presents 
navigation trees that make it easy to zoom in on Fixlet Messages, Reports, Analyses and other content.  

 Domain Buttons: At the bottom of the Domain Panel, these buttons represent the current set of BigFix 
Domains that are currently available to you. When you subscribe to a site, it is automatically entered 
into the proper domain. If a new domain is required, a button for it will be added to this group. At the 
bottom of the buttons is a control that allows you to adjust the number of buttons to display.  

 Console Toolbar: This toolbar allows you to navigate back and forth through the items you have 
selected from the Domain navigation tree. In addition there are buttons that allow you to display items 
you may have hidden and items that are not currently relevant to any of your BigFix Clients (this 
enables you to view all the available content for research or cloning purposes). There is also a refresh 
button that will re-evaluate content for the Console display.  
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 List Panel: This is a listing of the items specified by the content filters and the navigation trees in the 
Domain Panel. You can sort this list by clicking on the column headers and you can rearrange the 
headers by dragging them left or right. In addition, you can right-click the headers to see a pop-up 
menu containing a list of all the possible fields. Check those you wish to use as headers.  

 Context Menu: This is the menu that pops up when you right-click any item in a list. Different lists have 
different context menus.  

 Work Area Toolbar: This bar contains context-sensitive buttons that can execute various actions 
based on the content of the current work area.  

 Work Area: Below the List Panel and the Work Area Toolbar is the Work Area. When you double-click 
an item from the List Panel, the Console opens a detailed document in this window. 

Domain Panel Console Toolbar List Panel Context Menu 

 

Domain Buttons Work Area Toolbar Work Area   
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Manage Properties 

The Manage Properties dialog contains a list of computer properties that are retrieved on a regular schedule 

from each BES Client.  

 

This allows the Console operator to monitor specific aspects of all managed clients. These properties can also 

form the basis of the client filters (and column headers) in the BES Console whenever client computers are 

listed. In addition, these properties can be used to target computers for Fixlet messages or actions. 

There are several properties listed as defaults in the top panel, but if you are a Master Operator, you can add to 

these (and delete others) by using the buttons on the right:  

 Add New: To add a property, click this button, and the bottom part of the dialog becomes editable. 
Supply a name (that will be used for filtering and sorting) and then fill in a Relevance Expression in the 
text box below.  

 Delete: To delete a property, highlight it in the list and then click this button. 
 Make Custom Copy: You can clone and customize any property by selecting it in the list and then 

clicking this button. 
 Export: To export a property as an XML (.bes) file for sharing with other users, click the button and 

then specify a filename for export. 

Below this panel are two text fields. They display the existing property name and relevance expression. For 

reserved properties, these fields are display-only. Many of the properties, however, are available for editing.  

 Name: Displays the existing name of a property, or allows you to enter a name for a new Property. If 
you make this name available, it will be integrated into the interface for filtering, sorting and targeting. 
This field also allows you to rename a property. 
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 Relevance: This text box displays the relevance expression that is evaluated to produce the retrieved 

property. 

For each of these properties, there is an optional evaluation period:  

 Evaluate Every: Choose a time period, from 5 minutes to a month, which controls how often the 
Property is evaluated. You may wish to set a long period for time-consuming property evaluations or a 
short period for more urgent properties. The default is Every Report, which revaluates the properties 

with each report.  

NOTE: Some of the properties (such as the IP Address and the relay status) are essential to the proper 

functioning of the BES Console. They are marked as Reserved, and may not be renamed or deleted. 

This dialog is available by selecting Tools > Manage Properties...  

Manual Computer Groups 

This dialog allows you to manually group your computers so that you can target them simultaneously.  

 

To choose the computers you wish to group, select them from the Computers List Panel. Right click and select 

Add to Manual Group from the context menu. In the dialog that pops up, you can add these computers to a 

pre-existing group, or define a new one. There are two buttons for these choices: 

 Add the selected computers to the manual group selected below: Click on the desired group and 
click OK.  

 Add the selected computers to a new manual group named: Type in a new group name and click 

OK.  

NOTE: A computer can belong to more than one group. You may also define groups automatically, by using 

properties or Relevance statements to indicate their group status.  

 This dialog is available by clicking the Computers icon in the Domain Panel navigation tree, selecting 

computers from the Computer List Panel, and then right-clicking and selecting Add to Manual Group from the 

context menu.  
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Messages Tab 

The Messages tab can be found in various Action dialogs. Ordinarily, the BigFix system applies actions in the 

background, without bothering any end user who may be present. There are, however, occasions in which the 

BigFix Console operator might prefer that the action be taken only with end-user involvement. The Message tab 

in the Take Action dialog box allows the operator to alert the user with a specific message, and to offer certain 

interactive features on the message display, including the ability to see more information about the proposed 

action and to cancel the proposed action. 

 Display message before running action: Check this box if you want to deliver a message to the 
BigFix Clients before running an action. When this box is checked, other boxes are opened for 
modification:  

 Title: Type a title line for your message. 
 Description: To prepare the user, enter a description of the forthcoming Action in this text box. 
 Ask user to save work: Check this box to include a prompt asking users to save their work 

before the Action is invoked. 
 Allow user to view action script: Check this box to allow the user to look over the script 

before accepting the Action. Note: This option is disabled in the Take Multiple Action dialog.  
 Allow user to cancel action: Check this box if you want to grant the user the right to cancel 

the action. 

Set Deadline: The following two radio buttons allow you to extend the user a grace period after the 

Action becomes relevant. This can give them time to prepare for an upgrade. The deadline can be 

relative or absolute:  

 [time period] from time action is relevant: Click this button to grant the user a specified 
grace period starting at the moment the Action becomes relevant. 

 [date] at [time] client local time: Click this button to specify a specific date and time to serve 
as the Action deadline. The choice of local client time or universal time is set by the Execution 
tab.  

At deadline: When the deadline arrives, these options are available:  

 Run action automatically: Click the button to cause the Action to run automatically when the 
deadline arrives. 

 Keep message topmost until user accepts action: Click this button to keep the message on 

top until the user clicks to accept the Action.  

Confirmation message: When the user accepts an action, you can issue a message:  

 Show confirmation message before running action: Check this box if you want to display a 
final confirmation message to the user before executing the Action. 

 Display message while running action: You can add a separate message to be displayed while the 
action is running. Check this box and then enter the title and your message in the text box below. 

This tab is available from several different dialogs: 

Take Action, Take Multiple Actions, Action Settings and Edit Computer Settings. 
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Modify Custom Site Subscriptions 

The Modify Custom Site Subscriptions dialog lets you subscribe or unsubscribe any specified group of 

computers to any of your ad-hoc enabled custom sites.  

 

To ready a custom site for this type of ad-hoc subscription, you must first open the desired custom site, select 

the Computer Subscriptions tab and click the button labeled Computers subscribed via ad-hoc custom 

site subscription actions. Don't forget to Save Changes using the toolbar. 

Now, when you open Computers in the List Panel, right-click to bring up the context menu and choose Modify 

Custom Site Subscriptions. This dialog will pop up and those custom sites that have been enabled for ad-hoc 

subscriptions will be available for subscription from the pull-down menu. If the site is already subscribed to a 

custom site, this dialog also lets you unsubscribe it. 

This dialog is available by right-clicking on an item from any Computer list and selecting Modify Custom Site 

Subscriptions from the context menu. 
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Offer Tab 

The Offer tab can be found in various Action dialogs. It lets you advertise a list of Actions (typically optional 

patches or updates) to the BES Client user.  

 

The operator of the targeted BigFix Clients can then choose the Actions they desire from the offering list. Offers 

are limited to BigFix version 7.0 Clients or better. 

 Make this action an offer: Check this box to advertise the given Action to users. When you check the 

box, the interface opens up to enter more details about the offer: 

 Title: Enter a descriptive title for your Action here. Remember that this advertisement is being 
presented to end-users who will need a clear and simple description in order to take advantage of the 
offer. 

 Category: Enter a category for this offering. This is a user-defined field, and you can use any scheme 
that makes sense to your particular BES deployment.  

 HTML box: Use this box to customize the HTML that will be presented to the end user. Enter a 

description of the action in the box provided. You can customize this HTML with fonts and styles.  

This tab is available from several different dialogs: 

Take Action, Take Multiple Actions and Action Settings. 
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Operator Permissions Tab 

The Operator Permissions tab of the Site document lets BES Master Operators specify site permissions for 

other operators. 

 

This dialog is available to BES Master Operators and Non-Master Operators who have Site Ownership 

permissions. 

Not all operators need to know about all sites, and some sites may be most easily managed by a single 

operator, such as the Anti-Spyware Czar. This interface lets you attach a Fixlet site to a single operator or 

group of operators. You can also remove operators from this list at any time. 

This interface only affects the reader status of Non-Master Operators. For an external site, there is a check box 

and two buttons: 

 Grant read permission globally: Check this box to allow read access to all operators. 

 Reader: Select an operator from the list and then click this button to grant read permission to that 
operator. 

 None: Select an operator from the list and click this button to deny read permission to the specified 
operator. 

For a custom site, which can be owned and edited, there are two extra permission buttons. 
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As before, you select an operator from the list and then click buttons to grant permissions. The two extra 

buttons are: 

 Owner: This grants the greatest permission to the operator who can then assign reader and writer 
permissions. 

 Writer: This button allows an operator to edit the site. 

This dialog is available by clicking the Sites icon in the Domain Panel navigation tree, selecting a Site from the 

resulting List Panel and then clicking the Operator Permissions tab. 
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Post-Action Tab 

The Post-Action tab can be found in various Action dialogs.  

 

It gives the BES Console operator the choice of restarting or shutting down the client computer after the Action 

has completed. 

There are three radio buttons at the top of this dialog: 

 Do Nothing after action completes: This is the default -- after execution, simply resume normal 
operation. 

 Restart computer after action completes: Many actions require a restart to complete the 
remediation. The Options here include user cancellation and postponement. You can also specify a title 
and a message to be displayed to the user. 

 Shutdown computer after action completes: You may need to shut down the computer after the 
application of the action. As above, you can also specify a title and a message to be displayed to the 
user. 
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If you select either of the last two options above, the bottom panel becomes available for editing:  

Message:  

 Message Title and Text: Use these text boxes to create a message that will be delivered to the end 
user, explaining what's about to happen (restart or shutdown) and what their options are. 

 Allow user to cancel restart/shutdown: This gives the user a dialog box so that they can cancel out 
of the proposed restart or shutdown. 

 Set deadline: This gives the user the option to delay the restart/shutdown for the specified period of 
time (from fifteen minutes to thirty days) after the completion of the Action. Typically, restarts are 
needed to complete an installation, so they should not be put off for long.  

 At deadline: Click one of these buttons to specify what the deadline action will be. You can choose to 
automatically restart (or shutdown), or to keep a dialog box on the screen until the user is ready 
(presumably after saving their work).  

This tab is available from several different dialogs: 

Take Action, Take Multiple Actions and Action Settings. 
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Post-Execution Action Script Tab 

The Post-Execution Action Script tab of the Take Multiple Actions dialog lets you create an action script that 

will execute after the chosen set of Actions is run.  

 

Among other possibilities, this allows you to track the Action deployments using your existing control systems. 

There are two buttons in this dialog:  

 Do not run a custom action script after executing this multiple action group : This is the default 
for most multiple Fixlet actions.  

 Run the following action script after executing this multiple action group: If you want to create a 
custom action script when you deploy this action, select this button, and the following two items will 
determine the course of the action.  

 Action Script Type: The type of action script you want to use for this script. Some of the 
options include:  

 BigFix Action Script: This is the standard scripting language for BigFix actions.  
 AppleScript: This is Apple's scripting language for controlling computer resources.  
 sh: indicates that the action is a shell script, intended to be run by a linux / unix / bsd 

shell.  
 URL: specify a URL pointing to a post-execution script.  

 Action Script: Type your post-action script into this text box. Scripting is powerful and can 
have huge ramifications. Make sure to test your action on a small scale before you deploy it on 
your entire network!  

This dialog is available by selecting multiple Fixlet messages (as long as they have default actions) from any 

Fixlet list, then selecting Take Default Action from the right-click menu.  

You can also arrive at this dialog by selecting Baseline Actions. 

From the Take Multiple Actions dialog, select the post-Execution Action Script tab. 
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Pre-Execution Action Script Tab 

The Pre-Execution Action Script tab of the Take Multiple Actions dialog lets you create an action script that 

will execute before the chosen set of Actions is run.  

 

Among other possibilities, this allows you to track the Action deployments using your existing control systems. 

There are two buttons in this dialog:  

 Do not run a custom action script before executing this multiple action group : This is the default 
for most multiple Fixlet actions.  

 Run the following action script before executing this multiple action group: If you want to create a 
custom action script when you deploy this action, select this button, and the following two items will 
determine the course of the action.  

 Action Script Type: The type of action script you want to use for this script. Some of the 
options include:  

 BigFix Action Script: This is the standard scripting language for BigFix actions.  
 AppleScript: This is Apple's scripting language for controlling computer resources.  
 sh: indicates that the action is a shell script, intended to be run by a linux / unix / bsd 

shell.  
 URL: specify a URL pointing to a pre-execution script.  

 Action Script: Type your action script into this text box. Scripting is powerful and can have 
huge ramifications. Make sure to test your action on a small scale before you deploy it on your 
entire network!  

This dialog is available by selecting multiple Fixlet messages from any Fixlet list (as long as they have default 

actions), then selecting Take Default Action from the right-click menu. You can also arrive at this dialog by 

selecting Baseline Actions. 

From the Take Multiple Actions dialog, select the Pre-Execution Action Script tab. 
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Preferences  

The Preferences dialog lets you adjust certain system-wide parameters. 

 

There are several sections in the Preferences dialog: 

Fixlet List 

 Refresh list every XX seconds: Controls how often the Fixlet display is updated. The default setting 
causes the BES Database to be queried every 15 seconds. More frequent updates cause more network 
traffic, but less frequent updates increase the response time. As the BES Database increases in size, a 
longer refresh rate may be desirable. In practice, 15 seconds provides a good balance between latency 
and bandwidth concerns.  

Client Computers 

 Send heartbeat every XX minutes: Controls how often the BES Client computers check in with the 
BES Server to update their status. Each time a BES Client sends a heartbeat, it includes any retrieved 
property values which have changed. 15 minutes is the default value. 

 Mark as offline after XX minutes: Controls how long to wait after the last heartbeat before a computer 

is declared to be offline. The default is 50 minutes. 
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Relevance Colorization 

 Modify the colors used to display relevance: Whenever Relevance expressions are viewed, the text 
can be colored for easier reading. Click the Set Colors button to open an interface allowing you to 

customize your personal color scheme.  

Console Close 

 Prompt for confirmation before closing the console: This preference provides a yes/no prompt 

every time you exit the BES Console. 

Cache options 

 Always load data from database: If you do not wish to leave information cached on your BES 
Console computer, click this option. This will cause all data to be loaded freshly from the database each 
time you open the Console.  

 Keep partial cache on disk: This option caches everything but retrieved property results. The Console 
still caches Fixlet and Action results which are then written out upon exiting.  

 Keep full cache on disk: With this option, retrieved properties can be stored locally along with Fixlet 
and Action results. The more properties you keep in the cache, the more expensive it is to maintain, so 
the caching policy determines how long the Console runs before it clears items out of its cache.  

Expiration policy. If you have selected the full caching option above, you must also set an expiration 

policy to periodically purge the cache:  

 Aggressive: This policy purges unused data rapidly, purging any items that were not accessed 
in the previous Console session.  

 Moderate: This policy is intermediate between aggressive and conservative.  

 Conservative: This policy allows data to remain for a long time between purges, whether or 

not is has been recently accessed.  

 Clear Cache: Click this button to clear the current cache when the BES Console is next run.  

This dialog is available by selecting: 

 File > Preferences 
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Recent Comments 

This dialog presents a list of comments that have been attached to Fixlet messages, Tasks, Baselines, Actions 

and Computers.  

 

It compiles all the Comments from each of these interfaces for viewing in one spot. 

You can view the current comments by selecting Tools > View Recent Comments.  

Results Tab 

The Results tab of the Analysis document displays a list of targeted computers and the results of the analysis 

for each one.  

 

The format of this display depends on the selected View, either list or summary. The list view is shown above. 

When viewed as a list, each specified retrieved property has a corresponding header and the value of each 

property is displayed beneath it. If there is more than one value for a property, then <multiple results> is 

displayed. You can sort this list by the headers or use the folders in the left-hand panel to filter the results. This 

allows you to manage large sets of computers by their retrieved properties. 
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When viewed as a summary, each property has its own section, with response counts and percentages for 

each value of the property. 

 

This dialog is available whenever you select an activated Analysis from an appropriate list. 



BigFix Console   

Operator's Guide 191 © 2010 by BigFix, Inc. 

Security Warning 

The Security Warning dialog alerts you about scripting or relevance statements embedded in text. 

 

Whenever the Console detects that an embedded Relevance clause or a script is about to be displayed, this 

warning pops up. Unlike Action scripts which require a password before they can be executed, embedded 

scripts will be executed automatically and thus require scrutiny. In general, if these scripts are your own 

creation from a custom site, you can click the checkbox to allow dynamic scripting to always be enabled. 

If you are uncertain as to the source of the embedded script, click Disable. 

This dialog appears whenever content containing a Relevance statement or a script is about to be displayed. 
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Settings Tab 

The Settings tab of the Edit Computer Settings dialog allows the administrator to apply certain settings to 

multiple targeted computers, including locking, relays and custom variables.  

 

It includes the following controls: 

 Locking Status. Check this box to either lock or unlock the targeted computers. You might wish to lock 
a computer because it is currently being used in program development, it is in the middle of a lengthy 
process or because it is running specialized software. As long as a computer is locked, no actions will 
be executed on it.  

 Locked. Click this button to lock the computer.  

 Unlocked. Unlock the targeted computers. 

 BES Relay Selection Method. Choose an automatic or manual Relay method.  

 Automatically Locate Best BES Relay. Select this button to automate the process of 
selecting a BES Relay. This is the recommended setting. 

 Set BES Relays Manually. Force a manual selection of the BES Relays. 

 Primary BES Relay. Select a primary BES Relay. Check the box and select a computer from the pull-
down menu. Any attached BES Clients will then gather Fixlet downloads from this relay rather than 
directly from the BES Server. 

 Secondary BES Relay. Select a secondary BES Relay. Check the box and select a computer from the 
pull-down menu. Any attached BES Clients will then gather Fixlet downloads from this relay if the 
primary relay is unavailable. 
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 Custom Setting. This feature allows the BES Master Operator to create named variables that can be 
associated with the targeted computers.  

 Name. Type the name of a variable to be associated with all targeted computers, e.g., 
"department." 

 Value. Enter the value of the above-named variable, e.g., "payroll." 

When multiple computers are selected, this dialog is available by right-clicking and selecting Edit Computer 

Settings from the context menu.  

Site Details Tab 

The Details tab of the Site document provides you with information about the site and the subscription criteria. 

 

The Details group provides information about the version, publisher and URL of the site. 

The Subscription group provides information about how the criteria used to select clients for subscription to 

the site. 

This dialog is available by clicking the Site icon in the Domain Panel navigation tree, selecting a Site from the 

resulting List Panel and clicking the Details tab from the document in the Work Area below. 
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Site List and Document 

A list of Sites is displayed when you click Sites, or any of its child nodes, from the Domain Panel navigation 

tree.  

 

A Site document is displayed in the Work Area of the BigFix Console when you click any item from this list. If 

you open the Sites icon, you can filter the sites to either Custom or External types. Click an external site from 

the list to open it in the Work Area below. 

 

At the top is a toolbar with four buttons: 

 Save Changes: This button is grayed out for an external site. 

 Discard Changes:This button is grayed out for an external site. 

 Gather: This button with gather the contents of the site. 

 Remove: This button allows you to remove the site from the Console. 
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Beneath the toolbar are three tabs: 

 Details: This read-only tab displays the version, URL and publisher of the site. 

 Computer Subscriptions: This tab lets you specify which BigFix Clients will be subscribed to this site. 

 Operator Permissions: This tab lets you attach Operators to the site as owners, writers or readers. 

You can also create and edit your own Custom sites as well. If you have any custom sites, click one from the 

list to view or edit it.  

 

The document for a Custom Site is similar to that for an External site, with added abilities to edit the site. The 

toolbar has the same four buttons: 

 Save Changes: After making edits to your Custom Site, click this button to record your changes. 

 Discard Changes: This button will clear all the changes you have made. 

 Gather: Because the contents of a custom site are typically stored locally, this tool may be grayed-out. 

 Remove: This button allows you to entirely remove the site from the Console. 
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Beneath the toolbar are the same three tabs: 

 Details: This tab allows you to view or edit the description of your custom site and to select the Domain 
you want to host the site. 

 Computer Subscriptions: This tab lets you specify which BigFix Clients will be subscribed to this site. 

 Operator Permissions: This tab lets you attach Operators to the site as owners, writers or readers. 

To view the Site list, click the Sites Icon (or any of its child nodes) in the Domain Panel navigation tree. Open 

the icon to narrow the list down to either Custom or External sites. 

To view a Site Document, click any item in a site list. 

To create a custom site, select Tools > Create Custom Site. 

Site Properties 

The Site Properties dialog displays information about the selected Fixlet site, including the name of the Site 

publisher and the URL from which the content is gathered.  

 

The tabs in this dialog include: 

 Details: This tab displays the Site type (internal, external), the version and information about the 
publisher and subscriptions.  

 Computer Subscriptions: This dialog allows you to winnow the list of computers that subscribe to the 
chosen site. By eliminating superfluous or irrelevant Fixlet subscriptions, you can reduce the disk-
storage requirements of your client computers.  
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 Operator Permissions: This is a list of the operators and their permission levels. For an external site, 
you can typically only grant read access, but for a custom site you can grant ownership, write or read 
permission.  

This dialog is available by clicking the Sites icon in the Domain Panel navigation tree and then clicking an item 

from the resulting List Panel. The Site information opens in the Work Area below. 

Success Criteria Tab 

The Success Criteria tab of the Take Action dialog lets you define the conditions under which the action will 

be considered to be successful.  

 

There are three buttons in this dialog: 

Consider this Action successful when: 

 The applicability relevance evaluates to false: This is the default success criteria, requiring that the 
Relevance statement that made the Action applicable is no longer TRUE. Since the Relevance 
statement is designed to notice a problem and the Action is designed to fix it, this is generally sufficient 
to establish success. 

 All lines of the action script have completed successfully: You can make success dependent on 
completing the action script.  

 The following relevance clause evaluates to false: You may use a special Relevance clause to 

ensure that the desired action has accomplished it goals. 

If you choose the third option, the text box below becomes editable and you can create or revise an existing 

Relevance clause. 

This dialog is available by selecting a Fixlet message or Task from any list, then clicking an action button. From 

the Take Action dialog, select the Success Criteria tab. 
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Take Action 

The Take Action dialog is similar to the Take Multiple Actions dialog, but it is designed to issue a single 

Action.  

 

When you click an Action button, this dialog pops up, letting you specify exactly how the selected Action is to be 

deployed to the computers on your network. 

 At the top of this dialog is the Name of the Action. It is editable, should you wish to rename it or add 
extra information to it. 

 Next to the name is the domain. The Action may be created and placed into any domain you choose 
from the pull-down menu. The default is All Content, the top-level domain which includes objects from 
all domains.  

Below the Name box are some buttons that allow you to save or re-use your Action values: 

 Preset: This is a pull-down menu with the names of your existing presets. One of these presets is 
Policy, which will create an open-ended Action with no expiration date. Click on a named preset to 
automatically fill out your Action settings.  

 Show only personal presets: Check this box to limit the presets to your own personal presets.  
 Save Preset: After creating custom settings for an Action, you can save them for later re-use.  
 Delete Preset: Select a preset and then click this button to delete it.  
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The body of the dialog contains several tabs, including: 

 Target: Lets you specify subgroups of BES Clients to target with the selected Action. You can select 
computers based on retrieved properties -- including your own custom properties -- or you can supply a 
list of specific computers.  

 Execution: Lets you constrain the execution schedule and allows you to specify the retry and reapply 
behavior for execution and failure.  

 Users: Lets you run an Action based on user presence. You can also expose specific users or groups 
of users to a Client User Interface. 

 Messages: Here you can specify some interactions that may take place with the end user before and 
during the execution of the Action.  

 Offer: Allows you to advertise the existence of programs or patches that your networked BES Clients 
can opt into. This grants extra control to your users to customize their setup. 

 Post-Action: Lets you specify a follow-up behavior for the Action, such as a restart or shutdown.  
 Applicability: Lets you choose the original Action relevance or substitute your own custom relevance 

expression. 
 Success Criteria: Typically, an issue is considered fixed when the Fixlet message is no longer 

relevant, meaning the problem can no longer be detected. This tab lets you use different criteria to 
determine when a problem has been fixed. 

 Action Script: Lets you choose the original Action script or substitute your own custom script.  

When you decide to execute the Action, click OK. You will need to enter your password before the BES 

Console will issue the Action. When you do, a progress dialog will pop up to keep you posted on the 

deployment.  

This dialog is available by opening a Fixlet message from any list and then clicking on an Action button. 
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Take Multiple Actions 

The Take Multiple Actions dialog is similar to the Take Action dialog, but is designed to issue multiple default 

Actions in a single group.  

 

Right-click a selected group of Tasks or Fixlets containing default Actions, and select Take Default Action. 

This dialog pops up, letting you specify exactly how the selected Actions are to be deployed to the computers 

on your network.  

 At the top of this dialog is the Name of the Action. It is editable, should you wish to rename it or add 
extra information to it. 

 After the Name field is a pull-down allowing you to specifiy the Domain where you wish to create the 

Multiple Action. Choose from the set of existing Domains.  

Below these fields are buttons that allow you to save or re-use your Action values: 

 Preset: This is a pull-down menu with the names of your existing presets. One of these presets is 
Policy, which will create an open-ended Action with no expiration date. Click on a named preset to 
automatically fill out your Action settings.  

 Show only personal presets: Check this box to limit the presets to your own personal presets.  
 Save Preset: After creating custom settings for an Action, you can save them for later re-use.  
 Delete Preset: Select a preset and then click this button to delete it.  

The body of the dialog contains several tabs, including: 

 Target: Lets you specify subgroups of BES Clients to target with the selected Actions. You can select 
computers based on retrieved properties -- including your own custom properties -- or you can supply a 
list of specific computers.  

 Execution: Lets you constrain the execution schedule and allows you to specify the retry behavior for 
execution and failure.  
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 Users: Lets you run Actions based on user presence. You can also expose specific users or groups of 
users to a Client User Interface. 

 Messages: Here you can specify some interactions that may take place with the end user before and 
during the execution of the Actions.  

 Offer: Allows you to advertise the existence of programs or patches that your networked BES Clients 
can opt into. This grants extra control to your users to customize their setup. 

 Post-Action: Lets you specify a follow-up behavior for the Action group, such as a restart or shutdown.  
 Pre-Execution Action Script: Lets you specify an Action Script to execute before the group of Actions 

is deployed. 
 Post-Execution Action Script: Lets you specify an Action Script to execute after the group of Actions 

is deployed. 
 Applicability: Lets you choose the relevance provided by the original Actions or substitute your own 

custom relevance expression. 

When you decide to deploy the set of Actions, click OK. You will need to enter your password before the BES 

Console will issue the Actions. When you do, a progress dialog will pop up to keep you posted on the 

deployment.  

Right-click a selected group of Tasks or Fixlets containing default Actions, and select Take Default Action.  

Target Tab 

The Target tab can be found in various Action dialogs.  

 

When an Action becomes relevant, the BES Console operator can target a subset of users to receive the 

action. 

There are three radio buttons at the top of this dialog: 

 Specific Computers selected in the list below. When you select this button, only those BES Clients 
highlighted in the computer list will receive the actions. This is the default behavior. Note that you can 
filter this computer list by selecting items from the tree view in the left panel. Once you click OK, the 
selection of computers in this list will be frozen -- the retrieved values will not be reevaluated before the 
action is deployed. Thus, if a computer is affected by this problem in the future, it will not be covered by 
this option. It will trigger the same Fixlet, but will require you to target it again.  
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 All Computers with the Retrieved Properties values selected in the tree below. This button will 
cause continued evaluation of BES Client computers for relevance if they match the selected 
properties. Unlike the scenario described above, if a new computer is affected by this problem in the 
future, it will be automatically updated. You may also filter this set of relevant computers using the 
retrieved property panel on the left. Because of the open-ended nature of this function, you may want 
use the Execution tab to define an expiration date. 

 The computers specified in the list of names below. This button allows you to enter (or paste) a list 
of specific computers. Format the list with computer names (as displayed in the Console), separated by 
newlines. 

These options grant you great power over the deployment of Fixlet actions. Think carefully about your choices 

here. The first button is the safest, since it describes a static set of computers that you wish to target. The 

second choice is more powerful, because it will continue to evaluate and automatically deploy relevant actions, 

but it could also have long-term consequences that you should consider. The third choice allows you to deploy 

to a specific list of computers, for fine-grain control over your deployment.  

This tab is available from several different dialogs: 

Take Action, Take Multiple Actions and Edit Computer Settings. 

Task List and Document 

A list is created whenever you click Fixlets and Tasks from the Domain Panel navigation tree. This list 

incorporates both Fixlets and Tasks, which you can filter by opening the Fixlet and Tasks icon and clicking All 

Tasks beneath it.  

 

The List Panel on the right now contains all the currently relevant Tasks. The Task document is displayed in 

the Work Area of the BES Console when you click any item in the list.  
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At the top of the Task document is the name. Beneath that is a toolbar with the following tools:  

 Take Action: This tool executes the default action of Fixlet. 

 Edit: This option lets you edit the Fixlet. This tool is only available for custom Fixlets that you have 
created yourself. 

 Copy: This option lets you copy or clone the Fixlet to customize its functionality. 

 Export: This tool allows you to export the Fixlet for editing in an external editor. 

 Hide Locally: Hides the Fixlet on this version of the Console. 

 Hide Globally: Hides the Fixlet on all Consoles. 

 Remove: Deletes this Fixlet (only available for Custom Fixlets). 

There are several tabs in a Task document. They include:  

 Description: A text version of the Task, describing the problem and offering one or more Action 
buttons or links to redress the issue. You can search any of the HTML interfaces in BES by pressing 
Ctrl-F and then entering your search string. 

 Details: A list of the properties, Relevance statements and Actions that constitute the Task. 
 Applicable Computers: Lists the subset of computers are targeted by the Task.  
 Action History: Shows the history of the Action deployment. This list is empty unless the Action 

associated with the Task has already been triggered. 

To display a Task list, click the Tasks icon under the Fixlets and Tasks icon in the Domain Panel navigation 

tree.  

A Task document is opened whenever you open an item in a Task list.  
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Users Tab 

The Users tab can be found in various Action dialogs.  

 

It allows you to fine tune the delivery of Actions based on the presence of users. For instance, you can target 

long installs to just those computers where the users have logged off, ensuring that no downtime is incurred by 

the install.  

For installations that require user feedback, you can also expose specific sets of users to an interface. There 

are three main user modes: 

 Run only when there is no user logged on: Execute the action only in the absence of a user. This 
might be desired for long installs that might happen overnight, but only on logged-off clients. 

 Run independently of user presence, and display the user interface to the specified users: 
Execute the action whether a user is present or not. This can be useful for critical patches or small, 
silent updates. You can specify a set of users (below) that will be allowed to view the BES Client 
interface. 

 Run when at least one of the specified users is logged on, and only display the user interface to 
those users: Execute an Action and display a dialog only when one of the users specified below is 
logged on. This might be desired when the action requires feedback or intervention from specific groups 
of users. 
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The lower section of this dialog lets you select user groups for notification and interaction: 

 All users: Click this button to select all users for interaction with the user interface. 

 Local users: Select only local NT-Vista users to interact with the user interface. 

 Users in the following groups: Select users from the group below to interact with the user interface. 
Typical groups include the Local user group, WinNT and Win9x users. There are also some buttons to 
help you select user groups: 

 Add Domain Group: Add an NT Domain group of users. 
 Add Local Group: Add a local NT-Vista group to the set of users. 
 Add All Win9x Users Group: Add users who are logged in to Win 9x Clients. 
 Add All WinNT Users Group: Add users who are logged in as WinNT users. 
 Remove: Remove the selected user group from the list. 

This tab is available from several different dialogs: 

Take Action, Take Multiple Actions, Action Settings and Edit Computer Settings. 

View Action Info 

The View Action Info dialog displays information on a specific action for a given computer.  

 

Title: Shows the title of the Fixlet or Task that initiated the Action. 

Summary: A summation of the Action deployment for this computer. It includes the current Status, the Start 

and End Time for the Execution of the Action and any Exit Code that may be returned by the Action. 

Action: A listing of the Action script, usually a human-readable BigFix Script. 
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This dialog is available from any Action document in the lower Work Area. Select the Computers tab, right-

click a computer and select Show Action Info from the context menu (or select Show Action Info from the 

Edit menu).  

Visualization Parameters: Colorization 

The Colorization tab of the Visualization Parameters dialog lets you customize the colors for a graphical 

representation of your network.  

 

This tab offers four different ways to color the data, available from the main pull-down menu: 

 No colorization: Select this option to have every computer displayed as white. 

 Fixlet Message Relevance: Color each computer based on the Relevance (applicable or non-
applicable) of specific Fixlet messages. Specify the desired Fixlet message in the filter/list box below. 

 Baseline Relevance: Color each computer based on the Relevance (applicable or non-applicable) of 
specific Baseline groups. Specify the desired Baselines in the filter/list box below. 

 Retrieved Property: Select the colors of the BES Client computers based on the specified retrieved 
property. 

 Action Status: Base the colors of the computers on the current status (completed, open, expired) of a 
specified action. Specify the desired Action in the filter/list box below. 

 Relevance Clause: Color each computer based on a Relevance Clause, as specified in the text box 
below. 

This dialog is available by selecting Tools > Launch Visualization Tool > Colorization. 
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Visualization Parameters: Computers 

The Computers tab of the Visualization Parameters dialog lets you limit the number of computers to be 

graphed. 

 

This tab has two buttons to make your selection easy. 

 Show all computers in visualization: This is the default option, allowing all BES Clients to be 
displayed  

 Show only selected computers in visualization: This option brings up a computer filter/list allowing 

you to specify any subset of computers in your network by retrieved properties or groupings. 

This dialog is available by selecting Tools > Launch Visualization Tool > Computers. 
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Visualization Parameters: General 

The General tab of the Visualization Parameters dialog helps you to customize a graphical representation of 

your network. 

 

There are several ways to represent the data: 

 Use BES Relay structure: Display the network tree from the BES Relay point of view. This is the 
default view. 

 Use Active Directory Structure: Use the Active Directory to map out the network tree for visualization. 

 Use IP Address Structure: Use the IP architecture to map out the network tree. 

 Use Retrieved Property Path Structure: Use standard or custom properties of the client computers to 
map out a custom network tree. If you select this option, you must specify the desired path-style 
property from the section below:  

 Path Retrieved Property: This pulldown menu lists the available BES Client properties. Select 
one of these to define the network graph. A path-style property has a separator string to delimit 
the parts of the path. For instance, if you use an IP address as a path, you would select a 
period as a separator. Another example is an actual directory path, where the delimiter is a 
backslash. You can also create your own custom paths by concatenating fields with your own 
chosen separator. 

 Path Separator String: Enter the delimiter you want to use to parse the path specified above. 
For instance, to create a hierarchy from a directory path, use '\' as a separator string.. 

 Reverse Path Hierarchy: Check this box if your chosen path-style property has the most 
significant part on the right instead of the left. 

 Use first result if the computer has more than one result for this retrieved property: Many 
properties return a list, rather than a single item. These values can be ignored, or you can 
check this box to have the first element in the list used for the network map. 

 Group computers with the same retrieved property value: This option will create easy-to-

visualize groups from computers sharing the same property. 

 Show labels on leaf nodes: Check this box if you want to display labels next to the computers at the 

leaf nodes of the network tree. 
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This dialog is available by selecting Tools > Launch Visualization Tool... 

Visualization Tool 

The BES Visualization tool allows administrators to view and manipulate data from their network. To start up 

this tool, Select Launch Visualization Tool from the Tools menu. A dialog pops up allowing you to set certain 

parameters: 

 

This dialog allows you to load and save your preset preferences, so you can customize individual views of your 

network. The presets are managed with a simple interface: 

 Preset: Select a named set of options from this pull-down menu of previously-defined preferences.  
 Show only personal presets: Check this box to filter down the list of presets to just those you have 

personally created.  
 Save Preset: Click this button to save the current set of preferences as a named preset.  
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You can choose to make your presets private, or you can share them with other BES Operators. Later, 
if you wish to change the parameters of this preset, simply open it up, make the changes and save it 
with the same name. You will be asked to confirm the update.  

 Delete Preset: Deletes the currently selected preset.  

Below the Preset interface, there are three tabbed areas: 

 General: Describe the network hierarchy according to the specified structure.  
 Colorization: Set up a coloring scheme for the display.  
 Computers: Select all computers or a specified subset.  

Before running the tool, your options will be checked for completeness. If it passes, the Visualization tool will 

run with these values. 

 

With this screen, you can display network locations, relay hierarchies, Active Directory domains and other 

administrator-defined hierarchies. The tool is 3D and you can rotate the graph to better visualize the network. 

The tool makes it possible to view a real-time graphical network map showing Fixlet message status, Action 

status, Retrieved Property information and much more. For instance, you could view all computers that are 

currently unpatched for a specific Fixlet across your enterprise, and watch the clients change from red to green 

as the patch is propagated. 

This dialog is available by selecting Tools > Launch Visualization Tool. You will need to enable hardware 

acceleration and OWC, if you haven't already. 
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Part Four 

Resources 

Glossary 

action password—See BES signing password.  

Analysis—A set of retrieved properties that can be used to organize and report on your network. 

BES—See BigFix Enterprise Suite. 

BES Client—Software installed on each networked computer to be managed under BES. The Client accesses 
a pool of Fixlet messages, checks the computer it’s installed on for vulnerabilities, and sends the BES Server a 
message when such a condition occurs. 

BES Console—A management program that provides an overview of the status of all the computers with the 
BES Client installed in the network, identifying which might be vulnerable and offering corrective actions. 

BES database—A component of the BES system that stores data about individual computers and Fixlet 
messages. The BES Server’s interactions primarily affect this database, which is a standard Microsoft product 
(SQL Server 2000 or 2005). 

BES Generator Install folder—The directory on the installation computer where the Generator places the 
installation files for the BES system. 

BES Installation Generator—An application that creates installers for the core BES system components. 

BES Relay—This is a BES Client (Win 2k, 2k3 or XP) that is running special server software. Relays spare your 
server and the network by minimizing direct server-client downloads and by compressing upstream data. 
Relays are automatically discovered by BES Clients, which dynamically choose the best Relay to connect to. 

BES Server—A collection of interacting applications (web server, database server, etc.) that coordinates the 
relay of information to and from individual computers in the BES system. The server processes may be hosted 
by a single server computer or segmented to run on separate server computers. 

BES signing password—The password (specified when the BES system was installed) used by a BES 
Console operator to sign an action for deployment. It is called the action password in the Console interface. 

BES Site Administrator—The person in charge of installing BES and authorizing BES Console operators. 

BES system install folder—The directory on the BES Server where the BES Server and related files 
(including Console and Client installers) will be installed. 

BigFix technology—A process that enables knowledgeable computer technicians to disseminate information 
about the causes of computer problems to BES Clients across a network and provide automatic solutions for 
them.  

BigFix Action Scripting Language—The language used for crafting action scripts. Action can be crafted in 
different scripting languages, including AppleScript and Unix shells.  

BigFix Enterprise Suite (BES)—A preventive maintenance tool for enterprises that monitors computers across 
networks to find and correct vulnerabilities with a few simple mouse-clicks. 

BigFix Relevance Language—The language in which relevance clauses are written. 
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DSA—Distributed Server Architecture. Multiple BES Servers are linked to provide full redundancy in case of 
failure. 

Fixlet message—A mechanism for targeting and describing a problematic situation on a computer and 
providing an automatic fix for it. 

Fixlet servers—Web servers offering Fixlet site subscriptions. They can be either internal to the enterprise 
network or external to the network (if direct external web access is allowed). 

Fixlet site—A trusted source from which the BigFix Client obtains Fixlet messages.  

installation computer—A secure computer (separate from the BES Server computer) that hosts and runs the 
BES Installation Generator. 

Management Rights—Ordinary BES Console Operators can be limited to a specified group of computers. 
These limits represent the management rights for that user. Only a BES Site Administrator or a Master Operator 
can assign management rights. 

Master Operator—A BES Console Operator with administrative rights. A Master Operator can do almost 
everything a BES Site Administrator can do, with the exception of creating new operators. 

masthead—Files containing the parameters of the BES process, including URLs that point to where trusted 
Fixlet content is available. The BES Client brings content into the enterprise based on subscribed mastheads. 

Mirror server—A server required in the BES system if the enterprise doesn’t allow direct web access but 
instead uses a proxy server that requires password-level authentication. 

Operator—A person who operates the BES Console. Ordinary operators can deploy Fixlet actions and edit 
certain computer settings. Master Operators have extra privileges, among them the ability to assign 
management rights to other operators. 

signing password—See BES signing password. 

SQL server—A full-scale database engine from Microsoft that can be acquired and installed into the BES 
system to satisfy more than the basic reporting and data storage needs. A step up from MSDE. 

standard deployment—A deployment of BES that applies to workgroups and to enterprises with a single 
administrative domain. It’s intended for a setting in which all BES Client computers have direct access to a sin-
gle internal server. 

Task—A special type of Fixlet message that can be used to establish corporate policy or maintain a common 
operating environment. You can create your own custom Tasks. 

Throttling—A technique to limit bandwidth to accommodate shared users or thin connections. Throttling can be 
static or dynamic. 

Unmanaged Assets—A list of routers, printers and non-client computers that allows the BES Console to 
extend coverage to these otherwise unmanaged devices. 

Visualization—A tool for graphically analyzing your BES network data. 

VPN—Virtual Private Network. An encrypted channel (or tunnel) that allows companies to extend their local-
area networks across the world by using an inexpensive Internet connection.  

Web Reports—These reports can be collected from various BES Servers, providing a way to centrally 
administer a set of separate networks. 



BigFix Console   

Operator's Guide 213 © 2010 by BigFix, Inc. 

Index 

A 

About BES Console · 98, 99 
Access · ii 
Action 

History · 8, 14, 84, 102, 115, 120, 122, 171, 
173, 203 

Status · 90, 206 
Action Button · 8 
Action Progress Report · 103 
Action Script · 48, 54, 102, 104, 108, 153, 185, 

186, 199, 201 
Action Script Type · 104, 153, 185, 186 
Action Settings · 105, 153, 156, 168, 178, 180, 

184, 205 
action site password · 7 
Action Success Criteria · 153 
Action tab · 54, 183 
actions · 5, 8, 12, 14, 24, 31, 32, 50, 52, 53, 

54, 55, 59, 63, 69, 71, 84, 93, 97, 98, 100, 
104, 120, 122, 129, 132, 139, 148, 153, 167, 
168, 173, 175, 176, 178, 179, 183, 185, 186, 
192, 201, 202, 211, 212 

Actions Tab · 120, 152 
activate · 26, 75, 111, 141, 156 
Activate Analysis · 93 
Activated By · 74 
Active Directory Path · 133 
Active Directory Structure · 208 
Add Custom Setting · 110 
Add External Site Masthead · 26, 97 
Add New · 25, 60, 176 
Add Property · 75, 77, 141, 143 
Add to Manual Group · 65, 66, 94, 177 
Administered Computers · 71, 137, 138, 139 
Administration · 69, 71, 87, 137, 158 
administrator · 95, 192, 210 
aggregate · 5, 87, 88 
Aggregation · 87 
alert · 178 
All Fixlets · 41, 171 
AMD · 24 
Apple · 104, 185, 186 
AppleScript · 104, 153, 185, 186, 211 
Applicable Computers · 8, 14, 73, 84, 111, 

112, 115, 171, 173, 203 
Count · 14, 15, 74, 84, 118 

Applicable Tasks · 120, 121, 122 

architecture · 208 
archive · 87 
Assign BES Relays Manually · 80, 163 
Assign User Management Rights · 70, 94, 113, 

140 
audit · 5, 12, 56, 141 
authenticate · 212 
authentication · 48, 63, 137, 212 
authorize · 27, 69, 70, 116 

B 

bandwidth · 4, 56, 78, 81, 82, 158, 168, 187, 
212 

Baseline · 12, 52, 83, 84, 85, 86, 90, 91, 93, 
97, 102, 105, 106, 112, 114, 115, 118, 119, 
122, 124, 130, 143, 145, 148, 149, 150, 151, 
154, 155, 156, 157, 158, 159, 160, 161, 162, 
185, 186, 206 
Component Applicability · 114, 122 
Relevance · 90, 206 

BES 
Client · 4, 14, 24, 26, 28, 57, 61, 74, 80, 81, 

82, 84, 89, 91, 102, 106, 111, 133, 134, 
161, 163, 164, 165, 176, 180, 187, 192, 
199, 200, 201, 202, 204, 206, 207, 208, 
211, 212 

Console · 4, 7, 24, 32, 59, 69, 92, 95, 101, 
110, 115, 116, 117, 121, 126, 137, 138, 
139, 147, 161, 162, 163, 164, 170, 172, 
173, 176, 177, 183, 188, 199, 201, 202, 
211, 212 

database · 211 
Generator Install folder · 211 
Installation Generator · 211, 212 
Relay · 80, 81, 90, 93, 136, 163, 164, 192, 

208, 211 
Server · 4, 80, 81, 82, 163, 174, 187, 192, 

211, 212 
signing password · 211, 212 
Site Administrator · 212 
system install folder · 211 

BES Administrator's Guide · 88 
BES Client · 4 
BES Console · 4 
BES Relay structure · 208 
BES Server · 4, 212 



BigFix Console   

Operator's Guide 214 © 2010 by BigFix, Inc. 

BigFix · i, ii, 4, 5, 6, 7, 8, 9, 10, 12, 14, 18, 19, 
20, 23, 24, 25, 26, 28, 31, 33, 38, 44, 46, 48, 
50, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63, 
64, 65, 71, 72, 74, 75, 77, 78, 79, 81, 84, 85, 
86, 87, 88, 95, 97, 98, 99, 103, 104, 106, 
107, 112, 131, 138, 140, 141, 144, 146, 150, 
152, 153, 157, 159, 161, 162, 166, 167, 168, 
169, 171, 173, 174, 178, 180, 185, 186, 194, 
195, 196, 205, 211, 212 
Action Script · 104, 153, 185, 186, 211 
Action Scripting Language · 211 
Clients · 5, 6, 7, 8, 9, 12, 19, 28, 31, 46, 54, 

55, 59, 60, 64, 75, 77, 78, 79, 81, 86, 98, 
131, 144, 146, 159, 167, 168, 174, 178, 
180, 195, 196 

Enterprise Suite (BES) · 211 
Relays · 5, 6, 78, 79, 168 
Relevance Language · 211 
Sites · 26 

BigFix Action Script · 211 
BigFix Enterprise Suite (BES) · 211 
BIN · 211 
Bios · 24 
bottleneck · 78 
bsd · 104, 185, 186 
By Retrieved Properties · 57 

C 

cache · 81, 188 
Cache options · 188 
caching · 81, 91, 188 
cancellation · 183 
categories · 41, 52, 55, 68, 88, 158, 169 
Category · 14, 55, 149, 157, 158, 166, 180 
Change Password · 116 
change the locked status · 63 
charted · 59 
charts · 5, 87 
checkbox · 64, 191 
child · 90, 100, 102, 110, 111, 114, 115, 121, 

122, 126, 127, 138, 139, 170, 194, 196 
chunks · 66, 67 
Client · 4, 5, 6, 7, 12, 13, 23, 24, 28, 31, 44, 

48, 49, 54, 55, 56, 57, 59, 60, 61, 63, 64, 65, 
72, 78, 82, 97, 104, 122, 134, 135, 143, 150, 
167, 168, 187, 199, 201, 211, 212 

Client Computers · 56, 187 
Client Dashboard · 60, 61 
clipboard · 92 

clock · 24, 63 
clone · 8, 17, 85, 93, 95, 142, 144, 154, 157, 

165, 166, 171, 173, 174, 176, 203 
collect · 28, 59 
color · 90, 188, 206 
Colorization · 90, 206, 210 
colors · 188, 206 
column · 8, 14, 57, 58, 59, 73, 74, 84, 98, 112, 

115, 118, 122, 144, 163, 175, 176 
Comments · 52, 98, 108, 117, 118, 122, 125, 

189 
compiles · 189 
compiling · 78 
compliance · 56, 85, 174 
Component Applicability · 84, 115, 118 
compress · 6, 79 
Computer 

Name · 58, 61 
Settings · 64, 110, 165 
Subscriptions · 28, 31, 131, 133, 146, 179, 

195, 196 
computer group · 66, 68, 112, 127, 144 
Computers · 8, 16, 28, 31, 41, 45, 52, 56, 57, 

58, 59, 63, 64, 65, 66, 74, 80, 84, 87, 90, 97, 
100, 102, 108, 109, 114, 115, 117, 120, 121, 
122, 124, 125, 127, 130, 131, 132, 136, 144, 
159, 161, 164, 177, 179, 189, 201, 202, 206, 
207, 210 

concatenation · 58, 89, 208 
configuration · 5, 69, 80 
configure · 79 
confirmation · 32, 53, 178, 188 
Connect to Database · 137 
Connections · 78 
connectivity · 50 
Console · i, 4, 5, 6, 7, 8, 9, 10, 12, 14, 19, 20, 

21, 24, 26, 33, 38, 42, 53, 58, 60, 63, 64, 70, 
71, 74, 75, 78, 79, 84, 86, 88, 91, 92, 95, 96, 
97, 98, 99, 103, 106, 111, 112, 113, 115, 
118, 130, 137, 138, 139, 140, 146, 153, 156, 

171, 173, 174, 175, 176, 178,묜188, 191, 

194, 195, 202, 203, 211, 212 
Close · 188 
Toolbar · 8, 9, 21, 92, 95, 174, 175 

Console Operators · 33, 70, 71, 113, 138, 139, 
212 

Context Menu · 8, 9, 175 
CPU · 24, 58, 79, 97, 133 
Create 

Analysis · 75, 97, 141, 142, 143, 144 
Baseline · 85, 97, 155, 156 



BigFix Console   

Operator's Guide 215 © 2010 by BigFix, Inc. 

Custom Site · 30, 97, 145, 146, 196 
Fixlet Message · 157 
Task · 97, 166 

Create Analysis · 75, 141, 142, 143, 144 
Create Automatic Computer Group · 144 
Create Baseline · 115 
Create Custom Copy · 17, 85, 154, 155, 156, 

157, 159, 161, 166 
Create Custom Object Copy · 93 
credentials · 7, 87, 139 
Current Document · 96 
Current List · 96 
Custom Settings · 163, 193 
customize · 17, 18, 24, 44, 54, 55, 56, 72, 76, 

85, 87, 93, 104, 106, 112, 142, 153, 155, 
156, 157, 163, 164, 165, 166, 171, 173, 176, 
180, 188, 199, 201, 203, 206, 208, 209 

CVE · 19, 86, 158 

D 

Dashboards · 60, 88, 89, 147 
database · 5, 7, 8, 45, 64, 69, 87, 93, 95, 115, 

116, 137, 188, 211, 212 
datasets · 59 
Deactivate · 93, 111 
Deactivate Analysis · 93 
Delete Preset · 53, 105, 198, 200, 210 
delimit · 208 
delimiter · 90, 208 
department · 26, 56, 65, 69, 83, 113, 138, 140, 

193 
deploy · 4, 8, 9, 12, 26, 46, 54, 56, 83, 104, 

141, 148, 154, 157, 165, 166, 171, 185, 186, 
201, 202, 212 

deployment · 6, 7, 11, 14, 19, 45, 48, 50, 53, 
69, 81, 83, 86, 98, 100, 102, 103, 106, 111, 
115, 147, 153, 159, 171, 180, 199, 201, 202, 
203, 205, 211, 212 

Description tab · 8, 13, 46, 68, 73, 79, 81, 125, 
126, 142, 148, 156 

designate · 78, 79 
desktop · 7, 87 
developers · ii 
Directory · 89, 90, 133, 208, 210 
disconnected · 78 
discovery · 78, 163 
disposition · 107 
Distributed Server Architecture · 212 
DNS · 62, 133 

Name · 62, 133 
Document tabs · 8 
Domain · 8, 9, 10, 13, 14, 16, 17, 26, 27, 28, 

29, 30, 32, 33, 34, 36, 38, 39, 40, 41, 42, 43, 
48, 50, 52, 56, 57, 59, 63, 64, 66, 67, 68, 70, 
71, 73, 74, 76, 81, 83, 84, 85, 86, 88, 89, 96, 
100, 102, 108, 109, 110, 111, 113, 114, 115, 
117, 118, 119, 120, 121, 122, 123, 124, 125, 
126, 127, 128, 129, 130, 131, 132, 133, 136, 
138, 139, 141, 146, 147, 148, 151, 154, 156, 
157, 159, 161, 164, 166, 169, 170, 171, 172, 
173, 174, 175, 177, 182, 193, 194, 196, 197, 
200, 202, 203, 205 
Panel · 8, 9, 10, 13, 14, 16, 26, 27, 28, 29, 

32, 38, 39, 40, 41, 42, 43, 48, 50, 52, 56, 
57, 59, 63, 64, 66, 67, 68, 70, 71, 73, 74, 
76, 81, 83, 84, 86, 88, 89, 100, 102, 108, 
109, 110, 111, 113, 114, 115, 117, 118, 
119, 120, 121, 122, 123, 124, 125, 126, 

127,묜128, 129, 130, 131, 132, 133, 136, 

138, 139, 147, 148, 151, 154, 156, 159, 
161, 164, 169, 170, 171, 172, 173, 174, 
175, 177, 182, 193, 194, 196, 197, 202, 
203 

Download Mastheads · 26 
Download Size · 14, 149, 157, 158, 166 
DSA · 212 
dynamic bandwidth throttling · 81, 82 

E 

Edit 
Computer Settings · 64, 80, 82, 93, 110, 

113, 162, 164, 165, 168, 178, 192, 193, 
202, 205 

Custom Analysis · 76, 141, 142, 143, 144 
Custom Object · 93 

Edit Menu · 92 
Edit Script Element · 162 
efxm · 26, 97 
eligible · 29 
Enter Private Key · 166 
environment · 5, 12, 26, 81, 83, 154, 169, 212 
Evaluate every · 143 
Excel · 87 
Execution tab · 48, 49, 53, 104, 109, 167, 178, 

202 
expiration · 12, 47, 49, 53, 64, 104, 109, 167, 

188, 198, 200, 202 
Expiration policy · 188 



BigFix Console   

Operator's Guide 216 © 2010 by BigFix, Inc. 

export · 5, 87, 91, 171, 173, 176, 203 
extension · 26, 97 
extensive · 8, 25, 174 

F 

feedback · 204 
File Menu · 91 
Filter · 53, 97, 169 
finalize · 70 
find · 211 
Find · 81, 94, 156, 169 
fix · 5, 11, 14, 24, 46, 52, 53, 84, 197, 212 
Fixlet 

List · 23, 128, 131, 169, 172, 187 
message · 211, 212 
Message · 8, 157, 169, 172, 174, 206 
Relevance · 206 
servers · 212 
site · 212 
Subscriptions · 26 

G 

gauge · 88 
GHZ · 79 
gigabyte · 81 
global · 78, 174 
Globally Hide 

Analysis · 78 
Go Menu · 96 
graph · 5, 56, 89, 90, 206, 208, 210 

H 

hardware · 26, 60, 72, 80, 210 
headers · 8, 14, 57, 58, 59, 73, 74, 84, 92, 98, 

102, 112, 120, 122, 130, 131, 175, 176, 189 
headings · 84 
heartbeat · 7, 91, 187 
Help for the BES Console · 173 
Help Menu · 98 
hidden · 8, 20, 21, 78, 86, 92, 94, 95, 169, 174 
hierarchy · 6, 81, 89, 90, 98, 133, 208, 210 
Highlight · 143 
HKEY · 24 
hops · 79, 80, 81 

HTML · 55, 60, 61, 73, 84, 85, 98, 102, 106, 
111, 115, 141, 156, 157, 158, 166, 171, 173, 
174, 180, 203 

hyperlink · 9, 14 

I 

icon · 7, 8, 13, 14, 32, 34, 36, 37, 40, 41, 43, 
48, 50, 52, 56, 57, 59, 63, 64, 66, 67, 68, 70, 
73, 74, 76, 78, 81, 83, 84, 86, 88, 89, 102, 
107, 109, 111, 115, 117, 118, 119, 120, 121, 
122, 123, 124, 125, 126, 127, 128, 129, 130, 
131, 133, 136, 139, 147, 148, 151, 154, 156, 
159, 161, 162, 164, 169, 170, 171, 172, 173, 
177, 182, 193, 194, 196, 197, 202, 203 

ID · 14, 19, 84, 86, 102, 108, 158 
IE · 24 
iexplore · 24 
Include Action Settings Locks · 153 
Include Custom Success Criteria · 153 
input · 53, 92, 98, 110, 154 
inspect · 9, 13, 24, 27, 44 
Inspector · 18, 54, 85, 161 
Inspector Guide · 54, 161 
inspects · 6 
Install · 4, 5, 6, 7, 56, 69, 79, 204, 211, 212 
Install BES Relay · 79 
installation · 211, 212 
Installation · 4 
instructed · 78 
instructions · 4, 9 
Intel · 4, 24 
interactive · 89, 178 
interface · 4, 12, 48, 52, 53, 56, 61, 64, 87, 88, 

106, 107, 154, 176, 180, 181, 188, 204, 205, 
209, 210, 211 

Internet · 4, 6, 24, 212 
inventory · 12, 75 
IP Address · 90, 97, 133, 134, 177 
IP Address Structure · 208 
Issued Actions · 71, 139 
Issued By · 102 

K 

key · 7, 19, 24, 26, 75, 77, 86, 93, 98, 103, 
116, 153 

keywords · 117 
kilobytes · 81 



BigFix Console   

Operator's Guide 217 © 2010 by BigFix, Inc. 

L 

LAN · 4, 78 
laptop · 4 
laptops · 80 
Last 

Login Time · 71, 130 
Report Time · 133 

latency · 187 
launch · 7, 86, 153 
Launch Web Report · 87, 88, 98, 174 
Launch Web Reports · 87, 88, 98, 174 
leaf · 34, 37, 41, 208 
Libraries · 18, 85 
license · ii, 26, 103 
licensing · 32, 75 
Limit to XX reapplications · 168 
linux · 104, 185, 186 
List Panel · 8, 9, 10, 11, 13, 14, 16, 17, 20, 34, 

35, 37, 41, 45, 46, 50, 57, 58, 59, 63, 64, 65, 
66, 68, 70, 71, 73, 74, 76, 78, 83, 84, 86, 92, 
96, 100, 102, 107, 108, 109, 112, 113, 114, 
118, 119, 120, 121, 122, 123, 124, 125, 126, 
128, 129, 130, 131, 133, 136, 138, 148, 151, 
154, 156, 159, 161, 164, 170, 172, 174, 175, 
177, 179, 182, 193, 197, 202 

listings · 56, 59, 98 
load · 61, 62, 78, 79, 106, 167, 168, 188, 209 
Locally Hide 

Analysis · 78 
lock · 63, 64, 105, 106, 153, 163, 192 
Login · 49, 104 
lowercase · 24, 72 

M 

Macintosh · 153 
Main Console Window · 174 
maintenance · 211 
Make Custom Copy · 176 
Manage Properties · 25, 58, 60, 75, 98, 176, 

177 
Management · 26, 33, 39, 69, 70, 71, 113, 

122, 129, 130, 139, 140, 212 
management rights · 212 
Management Rights · 69, 70, 71, 113, 122, 

129, 130, 139, 140, 212 
Assignment · 71, 139, 140 

managers · 4, 26, 69, 138 
Manual Computer Groups · 66, 125, 126, 177 

master · 4, 10, 20, 78, 86 
Master Operator · 7, 27, 29, 69, 71, 75, 86, 

130, 139, 140, 176, 181, 193, 212 
masthead · 212 
Masthead · 26 
maximum · 81, 82 
megabytes · 81 
menu · 7, 8, 9, 12, 15, 17, 18, 20, 22, 26, 30, 

31, 38, 50, 51, 52, 53, 58, 64, 65, 66, 68, 70, 
76, 78, 80, 82, 84, 85, 86, 90, 92, 93, 95, 96, 
105, 109, 110, 113, 118, 132, 137, 141, 142, 
143, 144, 145, 153, 154, 155, 156, 157, 159, 
160, 161, 163, 164, 165, 166, 167, 169, 171, 
173, 175, 177, 179, 185, 186, 192, 193, 198, 
200, 206, 208, 209 

Message 
tab · 178 
Title · 184 

mhz · 58 
minutes · 7, 143, 168, 177, 184, 187 
Mirror server · 212 
modifications · ii, 86 
monitor · 4, 7, 48, 56, 71, 72, 75, 87, 141, 176 
More Options · 164 
mouse · 12, 52, 56, 154, 211 
MSDE · 212 

N 

numeric · 14, 84, 110 

O 

offers · 87, 91, 92, 95, 96, 97, 98, 206 
Office · 89 
offline · 187 
offload · 5 
oldest · 98 
online · 173 
Open Action Count · 14, 84 
operator · 4, 6, 7, 8, 20, 29, 63, 65, 69, 70, 71, 

74, 78, 79, 97, 103, 108, 113, 130, 132, 135, 
137, 138, 139, 140, 162, 169, 173, 176, 178, 
180, 181, 182, 183, 201, 211 

Operator Permissions · 29, 31, 146, 181, 182, 
195, 196, 197 

organization · 5, 32, 113, 138 
OS · 4, 39, 58, 61, 62, 67, 109, 125, 133, 134, 

145, 160 
Outgoing · 81 



BigFix Console   

Operator's Guide 218 © 2010 by BigFix, Inc. 

output · 58, 62, 63, 87 
overnight · 204 

P 

packed · 10 
pane · 120 
parse · 28, 208 
password · 7, 12, 19, 26, 28, 32, 48, 50, 66, 

67, 68, 75, 77, 86, 87, 91, 93, 94, 103, 106, 
116, 137, 145, 166, 191, 199, 201, 211, 212 

Paste · 92 
patch · 12, 14, 79, 148, 210 
Path 

Retrieved Property · 208 
Separator String · 208 

paths · 208 
payroll · 193 
Pentium · 4, 24, 58 
performance · 4, 7, 58, 78, 81 
periodically · 6, 188 
persistent · 12, 65, 91 
personnel · 69, 103, 166 
pointers · 117, 119, 156 
policy · 12, 75, 81, 97, 167, 168, 188, 212 
preferences · 9, 91, 209 
prevention · 211 
preventive · 211 
Primary BES Relay · 80, 192 
Primary Relay Server · 163 
printing · 60, 61, 87, 212 
Private Key · 116 
privileges · 5, 29, 212 
processor · 4, 24, 58, 122 
prompt · 103, 178, 188 
propagate · 28, 32, 66, 67, 81, 94, 103, 141, 

145 
properties · 12, 14, 18, 19, 24, 25, 27, 28, 29, 

31, 36, 45, 54, 56, 57, 58, 59, 60, 65, 67, 72, 
73, 75, 76, 77, 84, 86, 88, 89, 97, 98, 112, 
113, 122, 125, 127, 132, 133, 134, 138, 139, 
141, 143, 144, 149, 153, 154, 157, 158, 166, 

167, 169, 176, 177, 188, 199, 200,묜202, 

203, 208 
Properties tab · 143, 158 
Property name · 24 
proxy · 212 
pvk · 103 

R 

RAM · 4, 62, 79, 134 
reapply · 18, 107, 167, 199 
rearrange · 8, 175 
reconnected · 78 
redundant · 212 
reevaluated · 120, 130, 131, 201 
refine · 8, 53, 93 
refresh · 8, 61, 62, 91, 174, 187 
registration · 24 
registry · 24, 46, 60, 148 
relationships · 72, 89, 145, 160 
Relay · 5, 6, 72, 78, 79, 80, 82, 122, 133, 134, 

135, 192, 211 
Relevance · ii, 9, 12, 13, 14, 18, 23, 24, 25, 44, 

46, 49, 54, 57, 58, 60, 61, 63, 65, 72, 73, 75, 
77, 83, 84, 85, 90, 93, 98, 102, 104, 108, 
111, 112, 113, 115, 119, 125, 127, 133, 134, 
141, 143, 144, 145, 149, 153, 154, 157, 159, 
160, 161, 166, 171, 173, 176, 177, 188, 191, 
197, 203, 206, 211 
Clause, Expression · 9, 23, 24, 25, 58, 60, 

133, 134, 145, 157, 160, 176, 206 
Relevance Colorization · 188 
Relevance tab · 144, 159 
Relevant 

Baselines · 122, 130 
Fixlet Messages · 122, 131 

Remove 
Computer · 68 
Custom Object · 93 
from Database · 64 

Remove Property · 77, 143 
rename · 105, 176, 198, 200 
Reporting Computers · 45, 102, 127, 128 
representation · 206, 208 
requirements · 4, 5, 79, 81, 107, 158, 196 
responsiveness · 9, 69 
Restart Action · 51, 94 
retrieved properties · 211 
Retrieved Properties · 7, 24, 25, 58, 59, 60, 

70, 75, 90, 109, 113, 138, 145, 160, 165, 
167, 188, 189, 199, 200, 206, 207, 208, 210, 
211 

retry · 54, 106, 167, 168, 199, 200 
Reverse Path Hierarchy · 208 
revoke · 69, 70, 94 
routers · 212 
Run between · 167 



BigFix Console   

Operator's Guide 219 © 2010 by BigFix, Inc. 

S 

safest · 202 
SANS · 19, 86, 158 
Save Preset · 53, 105, 198, 200, 209 
scope · 4, 72, 78, 83, 88, 112, 161, 169 
Secondary BES Relay · 192 
Secondary Relay Server · 163 
secure · 212 
security · 5, 9, 12, 14, 26, 75, 154, 212 
Security Warning · 191 
Select All · 92 
Send Refresh · 93 
separator · 208 
Server · 212 
Servers · 4, 5, 78, 81, 87, 88, 98, 212 
service · 168 
session · 8, 9, 10, 188 
Settings · 56, 64, 105, 122, 133, 135, 162, 

164, 192 
setup · 5, 54, 199, 201 
Severity · 149, 157, 166 
sh · 104, 153, 185, 186 
sheet · 5, 62 
shell · 104, 153, 185, 186 
shortcut · 93 
Show Action Info · 93, 206 
Show all computers · 90, 207 
Show only personal presets · 53, 105, 198, 

200, 209 
Show Status Bar · 95 
shutdown · 106, 184, 199, 201 
signing password · 211, 212 
Site 

Document · 181, 193, 194 
Properties · 27, 196 
Subscription · 28, 93, 132, 179 

Source 
ID · 14, 158 
Release Date · 14, 158 
Severity · 14, 15, 35, 41, 158 

SQL · 211, 212 
server · 212 

standard deployment · 212 
statistics · 87, 88 
Stop Action · 50, 94 
subgroups · 199, 200 
Subnet · 134 

Address · 134 
subscription · 26, 27, 28, 31, 32, 132, 179, 193 
Success Criteria · 54, 102, 108, 197, 199 

Suite · i, 211 
system · 211, 212 

T 

Take Action · 8, 11, 12, 14, 46, 48, 49, 53, 55, 
56, 81, 103, 104, 107, 108, 113, 115, 168, 
171, 173, 178, 180, 184, 197, 198, 200, 202, 
203, 205 

Take Default Action · 52, 53, 93, 185, 186, 
200, 201 

Take Multiple Actions · 113, 168, 178, 180, 
184, 185, 186, 198, 200, 202, 205 

Target tab · 12, 47, 108, 109, 201 
technician · 4, 78 
The BES Client · 212 
The BES Server · 211 
Throttle · 212 
throttling · 81, 212 
Time 

Activated · 74 
Issued · 50, 102 

Tools Menu · 97 
trusted · 212 
tunnel · 212 

U 

unhide · 21, 78, 86, 92, 95 
Unix · 104, 185, 186 
unlock · 63, 64, 106, 192 
Unlocked Computer Count · 14 
Unmanaged · 212 
Unmanaged Assets · 212 
unpatched · 89, 210 
unsubscribe · 7, 28, 32, 64, 93, 132, 179 
upgrade · 12, 32, 178 
upload · 79 
upstream · 78, 211 
User name · 7, 137 
User Name · 134 
users · 212 

V 

vendor name of processor · 24 
vertical · 8 
View Action Info · 205 
View as Group · 65, 94 



BigFix Console   

Operator's Guide 220 © 2010 by BigFix, Inc. 

viewpoint · 90 
visibility · 4, 94, 169 
Visit · 98 
Visualization · 212 
Visualization Parameters · 90, 206, 207, 208 
Visualization Tool · 12, 56, 89, 90, 98, 206, 

207, 209, 210 
VPN · 6, 78, 212 
vulnerability · 5, 6, 12, 52, 87, 153, 171, 211 
vulnerable · 211 

W 

Wait XX between attempts · 168 
Web Reports · 5, 12, 56, 59, 75, 87, 88, 174, 

212 

Website · 25 
winword · 24 
Work Area · 8, 9, 11, 13, 14, 21, 23, 27, 28, 

29, 32, 38, 43, 50, 51, 65, 73, 74, 83, 86, 89, 
92, 96, 100, 101, 102, 108, 109, 110, 112, 
115, 120, 123, 124, 125, 126, 128, 129, 130, 
131, 136, 138, 170, 172, 174, 175, 193, 194, 
197, 202, 206 

workflow · 9, 10, 12 
workgroup · 79 
workstation · 79 

X 

XP · 211 

 


	Audience
	System Requirements
	Overview of the BigFix Enterprise Suite
	A Typical Installation
	Getting Started
	Introducing the BigFix Console
	Operating Basics

	Fixlets and Tasks
	Introducing Fixlets and Tasks
	Viewing Fixlets and Tasks
	Monitoring Fixlets and Tasks
	Commenting on Fixlets and Tasks
	Creating or Customizing Fixlets and Tasks
	Hiding Fixlets and Tasks
	Viewing Relevance Expressions
	Introducing Relevance

	Sites
	Introducing Sites
	Selecting Sites
	Viewing Site Properties
	Restricting Computers
	Restricting Readers
	Creating Custom Sites
	Canceling a Subscription

	Domains
	Introducing Domains
	Domain Sites
	Selecting Domains
	Navigating Domains
	Minimizing the Domain Panel
	Deleting Domains

	Actions
	Introducing Actions
	Viewing Actions
	Deploying the Action
	Monitoring Actions
	Stopping an Action
	Restarting an Action
	Commenting on Actions
	Default Actions
	Custom Actions
	Making an Offer

	Client Computers
	Introducing Client Computers
	Monitoring Computer Status
	Grouping Computers
	Commenting on Computers
	Creating Retrieved Properties
	Creating Client Dashboards
	Locking Computers
	Removing Computers

	Computer Groups
	Introducing Computer Groups
	Creating Manual Computer Groups
	Creating Automatic Computer Groups
	Commenting on Computer Groups
	Removing Computer Groups

	Operators
	Introducing Operators
	Assigning Management Rights
	Monitoring Operators

	Analyses
	Introducing Analyses
	Viewing Analyses
	Monitoring Analyses
	Commenting on Analyses
	Creating Analyses
	Editing Analyses
	Hiding Analyses

	Relays and Servers
	Understanding BigFix Relays
	BigFix Relay requirements
	Setting Up A BigFix (BES) Relay
	Using BES Relays
	Automatic Relays
	Manually Assigning Multiple Clients
	Manually Assigning Single Clients
	Adjusting the BES Server and Relays
	Dynamic Bandwidth Throttling

	Baselines
	Introducing Baselines
	Viewing Baselines
	Monitoring Baselines
	Commenting on Baselines
	Creating or Customizing Baselines
	Hiding Baselines

	Displays and Reports
	Web Reports
	Viewing Dashboards
	Visualizing Data

	Menus
	File Menu
	Edit Menu
	View Menu
	Go Menu
	Tools Menu
	Help Menu

	Dialogs
	About BES Console
	Action: Computers
	Action List and Document
	Action History Tab
	Action Site Signing Key
	Action Parameter
	Action Progress Report
	Action Script Tab
	Action Settings
	Action: Summary
	Action: Target
	Add Comment
	Add Custom Setting
	Analysis List and Document
	Applicable Computers Tab
	Applicability Tab
	Assign User Management Rights
	Baseline Component Applicability Tab
	Baseline List and Document
	Change Database Password
	Change Private Key Password
	Comments
	Component Applicability Tab
	Components Tab
	Computer: Action History
	Computer: Applicable Tasks
	Computer List and Document
	Computer Group: Actions
	Computer Group: Analyses
	Computer Group: Baselines
	Computer Group: Computers
	Computer Group: Description
	Computer Group List and Document
	Computer Group: Fixlet messages
	Computer Group: Reporting Computers
	Computer Group: Tasks
	Computer: Management Rights
	Computer: Relevant Baselines
	Computer: Relevant Fixlet Messages
	Computer Subscriptions Tab
	Computer: Summary
	Connect to Database
	Console Operator: Administered Computers
	Console Operator List and Document
	Console Operator: Issued Actions
	Console Operator: Management Rights Assignment
	Create Analysis
	Create Analysis Description Tab
	Create Analysis Properties Tab
	Create Analysis Relevance Tab
	Create Automatic Computer Group
	Create Custom Site
	Custom Site Document
	Dashboard Document
	Description Tab
	Details Tab
	Edit Actions Tab
	Edit Baseline
	Edit Components Tab
	Edit Description Tab
	Edit Fixlet Message
	Edit Processing Instruction
	Edit Properties Tab
	Edit Relevance Tab
	Edit Script Element
	Edit Settings for Computer
	Edit Computer Settings
	Edit Task Message
	Enter Private Key
	Execution Tab
	Find
	Fixlet and Task: List and Document
	Fixlet List and Document
	Help for the BES Console
	Import Content
	Launch Web Reports
	Main Console Window
	Manage Properties
	Manual Computer Groups
	Messages Tab
	Modify Custom Site Subscriptions
	Offer Tab
	Operator Permissions Tab
	Post-Action Tab
	Post-Execution Action Script Tab
	Pre-Execution Action Script Tab
	Preferences
	Recent Comments
	Results Tab
	Security Warning
	Settings Tab
	Site Details Tab
	Site List and Document
	Site Properties
	Success Criteria Tab
	Take Action
	Take Multiple Actions
	Target Tab
	Task List and Document
	Users Tab
	View Action Info
	Visualization Parameters: Colorization
	Visualization Parameters: Computers
	Visualization Parameters: General
	Visualization Tool

	Glossary
	Index

