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 Introduction
SolidWorks Tutorials

The CAD Student Guide is a companion resource and 
supplement for the SolidWorks Tutorials. Many of the 
exercises in the CAD Student Guide use material from 
the SolidWorks Tutorials.

Accessing the SolidWorks Tutorials

To start the SolidWorks Tutorials, click Help, 
SolidWorks Tutorials. The SolidWorks window is 
resized and a second window appears next to it with a 
list of the available tutorials. There are over 40 lessons 
in the SolidWorks Tutorials. As you move the pointer 
over the links, an illustration of the tutorial will appear at 
the bottom of the window. Click the desired link to start 
that tutorial.

TIP: When you use SolidWorks Simulation 
to perform static engineering analysis, 
click Help, SolidWorks Simulation, 
Tutorials to access over 50 lessons 
and over 80 verification problems. 
Click Tools, Add-ins to activate 
SolidWorks Simulation.
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Introduction
Conventions

Set your screen resolution to at least 1280x1024 for optimal viewing of the tutorials.

The following icons appear in the tutorials:

Click the link below “Next Topic:” to move to the next screen in the tutorial.

Represents a note or tip. It is not a link; the information is next to the icon. Notes 
and tips provide time-saving steps and helpful hints.

You can click most buttons that appear in the lessons to flash the corresponding 
SolidWorks button.

Open File automatically opens the file.

A closer look at... links to more information about a topic. Although not required 
to complete the tutorial, it offers more detail on the subject.

Why did I... links to more information about a procedure, and the reasons for the 
method given. This information is not required to complete the tutorial.

Video: ... demonstrates with a video.

Printing the SolidWorks Tutorials

If you like, you can print the SolidWorks Tutorials by following this procedure:

1 On the tutorial navigation toolbar, click Show.

This displays the table of contents for the SolidWorks Tutorials.

2 Right-click the book representing the lesson you wish to print and select Print... from 
the shortcut menu.

The Print Topics dialog box appears.

3 Select Print the selected heading and all subtopics, and click OK.

4 Repeat this process for each lesson that you want to print.

Focused Product Development Applications

There are additional SolidWorks Education packages that can be purchased that offer 
students more focused product development applications. These include:

 SolidWorks Electrical - Schematic

• Develop system-level electrical schematics 
needed to power and control your robot or 
student project. Use this powerful schematic 
tool to plan power, control, safety, PLC, and 
other systems for your design. (Note: Not for 
PCB assembly design.)
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 SolidWorks Electrical - Professional

• Combines both electrical systems schematic design with 3D cable/wire/harness 
modeling capability in a single product to enable users to complete their overall 
product design. Educators and students can now designprojects, including robots and 
Formula SAE cars, and include the necessary electrical aspects in their designs.

 SolidWorks Composer

• Use SolidWorks Composer to develop 
technical documentation that is linked to your 
original SolidWorks CAD files, streamlining 
development and management of product 
instructions, user manuals, and training 
materials for your product - just as professionals do in industry. Great for team 
projects including robot design, Formula SAE, and other educational projects.

 SolidWorks Enterprise PDM

• SolidWorks Enterprise PDM (EPDM) is a 
professional-grade data management tool 
available to schools for managing student 
design data and to introduce students to the 
world of product data management. Users can 
manage revisions, plan workflows and 
signoffs, and ensure documents are controlled. Manage your next team design project 
using SolidWorks Enterprise PDM.
CAD Student Guide vii
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 Lesson 1: Using the Interface
Goals of This Lesson

 Become familiar with the Microsoft Windows® interface.

 Become familiar with the SolidWorks user interface.

Before Beginning This Lesson

 Verify that Microsoft Windows is loaded and running on your classroom/lab computers.

 Verify that the SolidWorks software is loaded and running on your classroom/lab 
computers in accordance with your SolidWorks license.

 Load the lesson files from the Educator Resources link.

Competencies for Lesson 1 

You develop the following competencies in this lesson:

 Engineering: Knowledge of an engineering design industry software application.

 Technology: Understand file management, copy, save, starting and exiting programs.

SolidWorks education suite contains more than 80 eLearning tutorials in engineering design, 
simulation, sustainability, and analysis.
CAD Student Guide 1



Lesson 1: Using the Interface
Active Learning Exercise — Using the Interface

Start the SolidWorks application, open a file, save the file, save the file with a new name, 
and review the basic user interface.

Starting a Program

1 Click the Start button  in the lower left corner of the window. The Start menu 
appears. The Start menu allows you to select the basic functions of the Microsoft 
Windows environment.

2 From the Start menu, click All Programs, SolidWorks, SolidWorks.

The SolidWorks application program is now running.

Exit the Program

To exit the application program, click File, Exit or click  on the main SolidWorks 
window. 

Opening an Existing File

3 Double-click on the SolidWorks part file Dumbell in the Lesson01 folder.

This opens the Dumbell file in SolidWorks. If the SolidWorks application program is 
not running when you double-click on the part file name, the system runs the 
SolidWorks application program and then opens the part file that you selected. 

You could have also opened the file by selecting File, Open, and typing or browsing to 
a file name or by selecting a file name from the File menu in SolidWorks. SolidWorks 
lists the last several files that you had open.

Saving a File

4 Click Save  on the Menu Bar to save changes to a file. 

It is a good idea to save the file that you are working whenever you make changes to it. 

Note: Click means to press and release the left mouse button.

TIP: A desktop shortcut is an icon that you can 
double-click to go directly to the file or folder 
represented. The illustration shows the 
SolidWorks shortcut.

TIP: Use the left mouse button to double-click. Double-
clicking with the left mouse button is often a quick way of 
opening files from a folder.
2 CAD Student Guide



Lesson 1: Using the Interface
Copying a File

Notice that Dumbell is not spelled 
correctly. It is supposed to have two 
“b’s”.

1 Click File, Save As to save a copy 
of the file with a new name. 

The Save As window appears. This 
window shows you in which folder 
the file is currently located, the file 
name, and the file type.

2 In the File Name field change the 
name to Dumbbell and click 
Save.

A new file is created with the new 
name. The original file still exists. 
The new file is an exact copy of the 
file as it exists at the moment that it 
is copied.

Resizing Windows

SolidWorks, like many applications, uses windows to show your work. You can change 
the size of each window.

1 Move the cursor along the edge of a window until the shape of the 
cursor appears to be a two-headed arrow.

2 While the cursor still appears to be a two-headed arrow, hold down 
the left mouse button and drag the window to a different size.

3 When the window appears to be the size that you wish, release the mouse button.

Windows can have multiple panels. You can resize these panels relative to each other.

4 Move the cursor along the border between two panels until the cursor 
appears to be two parallel lines with perpendicular arrows.

5 While the cursor still appears to be two parallel lines with perpendicular 
arrows, hold down the left mouse button and drag the panel to a different size.

6 When the panel appears to be the size that you wish, release the mouse button.

SolidWorks Windows

SolidWorks windows have two panels. One panel provides non-graphic data. The other 
panel provides graphic representation of the part, assembly, or drawing. 

The leftmost panel of the window contains the FeatureManager® design tree, 
PropertyManager and ConfigurationManager.

1 Click each of the tabs at the top of the left panel and see how the contents of the 
window changes. 
CAD Student Guide 3
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The rightmost panel is the 
graphics area, where you 
create and manipulate the 
part, assembly, or drawing.

2 Look at the graphics area. 
See how the dumbbell is 
represented. It appears 
shaded, in color and in an 
isometric view. These are 
some of the ways in which 
the model can be 
represented very 
realistically.

CommandManager

The CommandManager is a context-sensitive toolbar that dynamically updates based on 
the functions you want to access. By default, it displays tabs that are based on the 
document type. Use the CommandManager to access functions in a central location and to 
save space for the graphics area.

When you click a tab in the control area, the CommandManager updates to show those 
tools. For example, if you click Sketch in the control area, the sketch tools appear in the 
CommandManager. The convention for using the CommandManager is to write, “Click 
Sketch > Smart Dimension .” In this convention, Sketch is the CommandManager 
tab and Smart Dimension is the tooltip.

Mouse Buttons

Mouse buttons operate in the following ways:

 Left – Selects menu items, entities in the graphics area, and objects in the 
FeatureManager design tree.

 Right – Displays the context-sensitive shortcut menus.

 Middle – Rotates, pans, and zooms the view of a part or an assembly, and pans in a 
drawing.

Model

Graphics area

Left panel displaying the FeatureManager design tree

control area
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Shortcut Menus

Shortcut menus give you access to a wide variety of tools and commands while you work 
in SolidWorks. When you move the pointer over geometry in the model, over items in the 
FeatureManager design tree, or over the SolidWorks window borders, right-clicking pops 
up a shortcut menu of commands that are appropriate for wherever you clicked.

You can access the "more commands menu" by selecting the double-down arrows  in 
the menu. When you select the double-down arrows or pause the pointer over the double-
down arrows, the shortcut menu expands to offer more menu items.

The shortcut menu provides an efficient way to work without continually moving the 
pointer to the main pull-down menus or the CommandManager.

Getting Online Help

If you have questions while you are using the SolidWorks software, you can find 
answers in several ways:

 Click the flyout menu of Help options  in the menu bar.

 Click Help, SolidWorks Help.

 While in a command, click Help  in the dialog.
CAD Student Guide 5



Lesson 1: Using the Interface
Lesson 1 — 5 Minute Assessment

Name: _______________________________Class: _________ Date:_______________

Directions: Answer each question by writing the correct answer or answers in the space 
provided or circle the answer as directed.

1 How do you open the file from Windows Explorer?

_____________________________________________________________________

2 How do you start the SolidWorks program?

_____________________________________________________________________

3 What is the quickest way to start the SolidWorks program?

_____________________________________________________________________

4 How do you copy a part within the SolidWorks program?

_____________________________________________________________________
6 CAD Student Guide
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Lesson 1 Vocabulary Worksheet

Name: _______________________________Class: _________ Date:_______________

Fill in the blanks with the words that are defined by the clues.

1 Shortcuts for collections of frequently used commands: ________________________ 

2 Command to create a copy of a file with a new name: __________________________

3 One of the areas that a window is divided into: _______________________________

4 The graphic representation of a part, assembly, or drawing: ______________________

5 Area of the screen that displays the work of a program: _________________________

6 Icon that you can double-click to start a program: _____________________________

7 Action that quickly displays shortcut menus of frequently used or detailed commands: 

_____________________________________________________________________

8 Command that updates your file with changes that you have made to it: ____________

_____________________________________________________________________

9 Action that quickly opens a part or program: _________________________________

10 The program that helps you create parts, assemblies, and drawings: _______________

11 Panel of the SolidWorks window that displays a visual representation of your parts, 
assemblies, and drawings: ________________________________________________
CAD Student Guide 7



Lesson 1: Using the Interface
Lesson Summary

 The Start menu is where you go to start programs or find files.

 There are shortcuts such as right-click and double-click that can save you work.

 File, Save allows you to save updates to a file and File, Save As allows you to make a 
copy of a file.

 You can change the size and location of windows as well as panels within windows.

 The SolidWorks window has a graphics area that shows 3D representations of your 
models.
8 CAD Student Guide
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 Lesson 2: Basic Functionality
Goals of This Lesson

 Understand the basic functionality of the SolidWorks software.

 Create the following part:

Before Beginning This Lesson

Complete Lesson 1: Using the Interface.

SolidWorks supports student teams in Formula Student, FSAE, and other regional and 
national competitions. For software sponsorship, go to www.solidworks.com/students
CAD Student Guide 9
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Lesson 2: Basic Functionality
Competencies for Lesson 2 

You develop the following competencies in this lesson:

 Engineering: Develop a 3D part based on a selected plane, dimensions, and features. 
Apply the design process to develop the box or switch plate out of cardboard or other 
material. Develop manual sketching techniques by drawing the switch plate.

 Technology: Apply a windows based graphical user interface.

 Math: Understand units of measurement, adding and subtracting material, 
perpendicularity, and the x-y-z coordinate system.
10 CAD Student Guide



Lesson 2: Basic Functionality
Active Learning Exercises — Creating a Basic Part

Use SolidWorks to create the box shown at the right. 

The step-by-step instructions are given below.

Create a New Part Document

1 Create a new part. Click 

New  on the Menu 
Bar.

The New SolidWorks 
Document dialog box 
appears.

2 Click the Tutorial tab.

3 Select the Part icon. 

4 Click OK. 

A new part document 
window appears.

Setting Units

The units for a document can be set by clicking Tools, 
Options and then under the Document Properties tab, 
selecting units from the menu on the left. In the status bar, 
units can also be changed by clicking Unit System and then 
selecting the new unit system.

Base Feature

The Base feature requires:

 Sketch plane – Front

 Sketch profile – 2D Rectangle

 Feature type – Extruded boss feature

Open a Sketch

1 Click to select the Front plane in the FeatureManager design tree.

2 Open a 2D sketch. Click Sketch > Sketch .

Confirmation Corner

When many SolidWorks commands are active, a symbol or a set of symbols appears in the 
upper right corner of the graphics area. This area is called the Confirmation Corner.
CAD Student Guide 11



Lesson 2: Basic Functionality
Sketch Indicator

When a sketch is active, or open, a symbol appears in the confirmation corner 
that looks like the Sketch tool. It provides a visual reminder that you are active in 
a sketch. Clicking this symbol exits the sketch saving your changes. Clicking the 
red X exits the sketch discarding your changes.

When other commands are active, the confirmation corner displays two 
symbols: a check mark and an X. The check mark executes the current 
command. The X cancels the command.

Overview of the SolidWorks Window

 A sketch origin appears in the center of the graphics area.

 Editing Sketch1 appears in the status bar at the bottom of the screen.

 Sketch1 appears in the FeatureManager design tree.

 The status bar shows the position of the pointer, or sketch tool, in relation to the sketch 
origin.

Sketch a Rectangle

1 Click Sketch > Corner Rectangle . 

2 Click the sketch origin to start the rectangle. 

3 Move the pointer up and to the right, to create a 
rectangle.

4 Click the mouse button again to complete the 
rectangle.

Status bar

Graphics area
Sketch origin

Menu bar

FeatureManager design tree

Confirmation Corner with sketch indicator

Reference Triad

CommandManager

Heads-up View Toolbar
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Lesson 2: Basic Functionality
Add Dimensions

1 Click Sketch > Smart Dimension . 

The pointer shape changes to .

2 Click the top line of the rectangle.

3 Click the dimension text location above the top line.

The Modify dialog box is displayed.

4 Enter 100. Click  or press Enter.

5 Click the right edge of the rectangle.

6 Click the dimension text location. Enter 65. Click .

The top segment and the remaining vertices are 
displayed in black. The status bar in the lower-right 
corner of the window indicates that the sketch is fully 
defined.

Changing the Dimension Values

The new dimensions for the box are 100mm x 60mm. Change the dimensions.

1 Double-click 65. 

The Modify dialog box appears.

2 Enter 60 in the Modify dialog box. 

3 Click .

Extrude the Base Feature.

The first feature in any part is called the Base Feature. In this exercise, the base feature is 
created by extruding the sketched rectangle.

1 Click Features > Extruded Boss/Base 

The Boss-Extrude PropertyManager appears. The view of the 
sketch changes to trimetric.
CAD Student Guide 13
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2 Preview graphics.

A preview of the feature is shown at the default 
depth.

Handles  appear that can be used to drag the 
preview to the desired depth. The handles are 
colored magenta for the active direction and gray 
for inactive direction. A callout shows the current 
depth value.

The cursor changes to . If you want to create the 
feature now, click the right mouse button. Otherwise, you can make additional changes 
to the settings. For example, the depth of extrusion can be changed by dragging the 
dynamic handle with the mouse or by setting a value in the PropertyManager.

3 Extrude feature settings.

Change the settings as shown.

• End Condition = Blind

•  (Depth) = 50

4 Create the extrusion. Click OK .

The new feature, Boss-Extrude1, is displayed in the 
FeatureManager design tree.

TIP:

The OK button  on the PropertyManager is just one 
way to complete the command.

A second method is the set of OK/Cancel 
buttons in the confirmation corner of the 
graphics area.

A third method is the right-mouse shortcut 
menu that includes OK, among other 
options.

Sketch

Preview

Handle

On-screen Scale
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Lesson 2: Basic Functionality
5 Click the plus sign  beside Boss-Extrude1 in 
the FeatureManager design tree. Notice that 
Sketch1 — which you used to extrude the feature 
— is now listed under the feature.

View Display

Change the display mode. Click Display Style > 
Hidden Lines Visible  on the Heads-up View 
toolbar.

Hidden Lines Visible enables you to select hidden back 
edges of the box.

Save the Part

1 Click Save  on the Menu Bar, or click File, Save.

The Save As dialog box appears.

2 Type box for the filename. Click Save.

The .sldprt extension is added to the filename.

The file is saved to the current directory. You can use the Windows browse button to 
change to a different directory.

Round the Corners of the Part

Round the four corner edges of the box. All rounds have the same 
radius (10 mm). Create them as a single feature. 

1 Click Features > Fillet .

The Fillet PropertyManager appears.

2 Enter 10 for the Radius.

3 Select Full preview.

Leave the remaining settings at their default values.

Click Here
CAD Student Guide 15
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4 Click the first corner edge.

The faces, edges, and vertices are highlighted as you 
move the pointer over them.

When you select the edge, a callout  
appears.

5 Identify selectable objects. Notice how the pointer 
changes shapes:

Edge:  Face:  Vertex: 

6 Click the second, third and fourth corner edges.

7 Click OK .

Fillet1 appears in the FeatureManager design tree.

8 Click Display Style > Shaded  on the Heads-up View 
toolbar.

Hollow Out the Part

Remove the top face using the Shell feature.

1 Click Features > Shell .

The Shell PropertyManager appears.

2 Enter 5 for Thickness.

Note: Normally, a callout only appears on 
the first edge you select. This 
illustration has been modified to 
show callouts on each of the four 
selected edges. This was done 
simply to better illustrate which 
edges you are supposed to select.
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Lesson 2: Basic Functionality
3 Click the top face.

4 Click .

Extruded Cut Feature

The Extruded Cut feature removes material. To make an extruded cut requires a:

 Sketch plane – In this exercise, the face on the right-hand side of the part.

 Sketch profile – 2D circle

Open a Sketch

1 To select the sketch plane, click the right-
hand face of the box. 

2 Click View Orientation > Right  on the 
Heads-up View toolbar.

The view of the box turns. The selected 
model face is facing you.

3 Open a 2D sketch. Click Sketch > Sketch 
.

Top Face

Pick this face
CAD Student Guide 17
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Sketch the Circle

1 Click Sketch > Circle .

2 Position the pointer where you want the center of the 
circle. Click the left mouse button.

3 Drag the pointer to sketch a circle.

4 Click the left mouse button again to complete the circle.

Dimension the Circle

Dimension the circle to determine its size and location.

1 Click Sketch > Smart Dimension . 

2 Dimension the diameter. Click on the circumference 
of the circle. Click a location for the dimension text 
in the upper right corner. Enter 10.

3 Create a horizontal dimension. Click the 
circumference of the circle. Click the left most 
vertical edge. Click a location for the dimension text 
below the bottom horizontal line. Enter 25.

4 Create a vertical dimension. Click the circumference 
of the circle. Click the bottom most horizontal edge. 
Click a location for the dimension text to the right of 
the sketch. Enter 40.

Extrude the Sketch

1 Click Features > Extruded Cut .

The Extrude PropertyManager appears.

2 Select Through All for the end condition.

3 Click .
18 CAD Student Guide
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4 Results.

The cut feature is displayed.

Rotate the View

Rotate the view in the graphics area to display the model from different angles.

1 Rotate the part in the graphics area. Press and hold the middle mouse button. Drag the 
pointer up/down or left/right. The view rotates dynamically.

2 Click View Orientation > Isometric  on the Heads-up View toolbar. 

Save the Part

1 Click Save  on the Menu Bar.

2 Click File, Exit.
CAD Student Guide 19
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Lesson 2 — 5 Minute Assessment

Name: _______________________________Class: _________ Date:_______________

Directions: Answer each question by writing the correct answer or answers in the space 
provided or circle the answer as directed.

1 How do you start a SolidWorks session?

_____________________________________________________________________

_____________________________________________________________________

2 Why do you create and use Document Templates?

_____________________________________________________________________

_____________________________________________________________________

3 How do you start a new Part Document? 

_____________________________________________________________________

4 What features did you use to create the box? 

_____________________________________________________________________

5 True or False. SolidWorks is used by designers and engineers. 

_____________________________________________________________________

6 A SolidWorks 3D model consists of _________ _________ ________.

_____________________________________________________________________

7 How do you open a sketch? 

_____________________________________________________________________

8 What does the Fillet feature do?

_____________________________________________________________________

9 What does the Shell feature do?

_____________________________________________________________________

10 What does the Cut-Extrude feature do? 

_____________________________________________________________________

11 How do you change a dimension value? 

_____________________________________________________________________
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Exercises and Projects — Designing a Switch Plate

Switch plates are required for safety. They cover live electrical wires and protect people 
from electric shock. Switch plates are found in every home and school.

Caution: Do not use metal rulers near switch plates attached to a live wall outlet.

Tasks

1 Measure a single light plate switch cover.
______________________________________
______________________________________
______________________________________

2 Using paper and pencil, manually sketch the 
light plate switch cover.

3 Label the dimensions.

4 What is the base feature for the light plate 
switch cover?
______________________________________
______________________________________
______________________________________
______________________________________

5 Create a simple single light switch cover 
using SolidWorks. The filename for the part 
is switchplate.

6 What features are used to develop the 
switchplate?
___________________________________
___________________________________
___________________________________
___________________________________
___________________________________
___________________________________
___________________________________
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7 Create a simplified duplex outlet cover 
plate. The filename for the part is 
outletplate.

8 Save the parts. They will be used in later 
lessons.
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Lesson 2: Basic Functionality
Lesson 2 Vocabulary Worksheet

Name: _______________________________Class: _________ Date:_______________

Fill in the blanks with the words that are defined by the clues.

1 The corner or point where edges meet: ______________________________________

2 The intersection of the three default reference planes:___________________________

3 A feature used to round off sharp corners: ____________________________________

4 The three types of documents that make up a SolidWorks model: _________________

5 A feature used to hollow out a part: _________________________________________

6 Controls the units, grid, text, and other settings of the document:__________________

7 Forms the basis of all extruded features: _____________________________________

8 Two lines that are at right angles (90°) to each other are: ________________________

9 The first feature in a part is called the ____________ feature.

10 The outside surface or skin of a part: ________________________________________

11 A mechanical design automation software application:__________________________

12 The boundary of a face: __________________________________________________

13 Two straight lines that are always the same distance apart are: ____________________

14 Two circles or arcs that share the same center are:______________________________

15 The shapes and operations that are the building blocks of a part: __________________

16 A feature that adds material to a part: _______________________________________

17 A feature that removes material from a part: __________________________________

18 An implied centerline that runs through the center of every cylindrical feature:_______
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