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Who is this book for?

This book is for beginner to advanced users of Calc, the spreadsheet component of LibreOffice.
You may be new to spreadsheet software, or you may be familiar with another program. If you
have never used LibreOffice before, or you want an introduction to all of its components, you might
like to read Getting Started with LibreOffice first. If you have never used spreadsheets before, you
might also like to read a book or find some tutorials about the use of spreadsheets.

What's in this book?

This book introduces the features and functions of LibreOffice Calc. It is not a tutorial on using
spreadsheets. Some chapters assume familiarity with basic spreadsheet usage when describing
how to use Calc.

You can enter data (usually numerical) in a spreadsheet and then manipulate this data to produce
certain results. Alternatively, you can enter data and then use Calc in a ‘What if...” manner by
changing some of the data and observing the results without having to retype all of the data.
Functions can be used to create formulas to perform complex calculations on data.

Some of the other features provided by Calc include:
» Database functions, to arrange, store, and filter data.
* Dynamic charts: a wide range of 2D and 3D charts.

* Macros, for recording and executing repetitive tasks; scripting languages supported include
LibreOffice Basic, Python, BeanShell, and JavaScript.

* Ability to open, edit, and save Microsoft® Excel® and other spreadsheets.
* Import of spreadsheets from multiple formats, including HTML, CSV, and PostScript.
* Export of spreadsheets into multiple formats, including HTML, CSV, and PDF.

Where to get more help

This book, the other LibreOffice user guides, the built-in Help system, and user support systems
assume that you are familiar with your computer and basic functions such as starting a program,
opening and saving files.

Help system

LibreOffice comes with an extensive Help system. This is the first line of support for using
LibreOffice. Windows and Linux users can choose to download and install the offline Help for use
when not connected to the Internet; the offline Help is installed with the program on macOS.

To display the Help system, press F1 or select LibreOffice Help from the Help menu (Figure 1). If
you do not have the offline help installed on your computer and you are connected to the Internet,
your default browser will open the online Help pages on the LibreOffice website.

The Help menu includes links to other LibreOffice information and support facilities.

g Note

The following options indicated by a * sign are only accessible if your computer is
connected to the Internet.

* What's This? — For quick tips when a toolbar is visible, place the mouse pointer over any
of the icons to see a small box (“tooltip”) with a brief explanation of the icon’s function. For a
more detailed explanation, select Help > What's This? and hold the pointer over the icon.
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In addition, you can choose whether to activate Extended Tips using Tools > Options >
LibreOffice > General.

User Guides* — Opens your default browser at the Documentation page of the LibreOffice
website https://documentation.libreoffice.org/en/english-documentation/. There you will find
copies of User Guides and other useful information.

Get Help Online* — Opens your default browser at the Ask LibreOffice forum of questions
and answers from the LibreOffice community https://ask.libreoffice.org/en/questions/.

Send Feedback* — Opens your default browser at the Feedback page of the LibreOffice
website https://www.libreoffice.org/get-help/feedback/. From there you can report bugs,
suggest new features and communicate with others in the LibreOffice community.

Restart in Safe Mode — Opens a dialog window where you will have the option to restart
LibreOffice and reset the software to its default settings.

Donate to LibreOffice* — Opens your default browser at the Donation page of the
LibreOffice website https://donate.libreoffice.org/. There you can choose to make a
donation to support LibreOffice.

License Information — outlining the licenses under which LibreOffice is made available.

Check for Updates* — Opens a dialog window and checks the LibreOffice website for
updates to your version of the software.

About LibreOffice — Opens a dialog window and displays information about the version of
LibreOffice and the operating system you are using. This information will often be
requested if you ask the community for help or assistance with the software.

Help
&0 LibreOfficeHelp  FL |
PR What's This?

User Guides.,..

Get Help Online...
Send Feedback...

Restart in Safe Made..,
Donate to LibreQOffice

License Information...
Check for Updates...

About LibreOffice

Figure 1: The Help Menu

Other free online support

The LibreOffice community not only develops software, but provides free, volunteer-based support.
In addition to the Help menu links above, there are other online community support options
available, see the table below.

Free LibreOffice support

FAQs Answers to frequently asked questions
https://wiki.documentfoundation.org/Faq

Mailing lists Free community support is provided by a network of experienced users

https://lwww.libreoffice.org/get-help/mailing-lists/
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Free LibreOffice support

Free community assistance is provided in a Question & Answer formatted
Questions & Answers web service. Search similar topics or open a new one in
and https://ask.libreoffice.org/en/questions
Knowledge Base The service is available in several other languages; just replace /en/ with
de, es, fr, ja, ko, nl, pt, tr, and many others in the web address above.

The LibreOffice website in various languages
https://lwww.libreoffice.org/community/nlc/

Native language Mailing lists for native languages

support https://wiki.documentfoundation.org/Local_Mailing_Lists
Information about social networking
https://wiki.documentfoundation.org/Website/Web_Sites_services

Information about available accessibility options

Accessibility options https://lwww.libreoffice.org/get-help/accessibility/

Another forum that provides support for LibreOffice, among other open

OpenOffice Forum source office suites https://forum.openoffice.org/en/forum/

Paid support and training

You can also pay for support through service contracts from a vendor or consulting firm
specializing in LibreOffice. For information about certified professional support, see The Document
Foundation’s website: https://www.documentfoundation.org/gethelp/support/

What you see may be different

lllustrations

LibreOffice runs on Windows, Linux, and macOS operating systems, each of which has several
versions and can be customized by users (fonts, colors, themes, window managers). The
illustrations in this guide were taken from a variety of computers and operating systems. Therefore,
some illustrations will not look exactly like what you see on your computer display.

Also, some of the dialogs may be different because of the settings selected in LibreOffice. You can
either use dialogs from your computer’s operating system or from LibreOffice. The differences
affect mainly Open, Save, and Print dialogs. To change which dialogs are used, go to Tools >
Options > LibreOffice > General and select or deselect the option Use LibreOffice dialogs.

Icons

The LibreOffice community has created icons for several icon sets: Colibre (default set), Breeze,
Breeze Dark, Elementary, Karasa Jaga, Sifr, Sifr Dark and Tango. Each user can select a preferred
set. The icons in this guide have been taken from a variety of LibreOffice installations that use
different sets of icons. The icons for some of the many tools available in LibreOffice may then differ
from the ones used in this guide.

To change the icon set used, go to Tools > Options > LibreOffice > View. Choose from the drop-
down lists under Icon style and Icon size.
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g Note

The Galaxy and Oxygen icon sets are no longer included as part of the standard
installation package. They can be added back by downloading and installing the
following extensions:
https://extensions.libreoffice.org/extensions/galaxy-icon-theme
https://extensions.libreoffice.org/extensions/oxygen-icon-theme

Some of the previously included gallery backgrounds are now only available as an
extension from:
https://extensions.libreoffice.org/extensions/legacy-gallery-backgrounds

Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this book. For a more
detailed list, see the application Help and Appendix A (Keyboard Shortcuts) to this guide.

Windows or Linux macOS equivalent Effect
Tools > Opt.lons LibreOffice > Preferences Access setup options
menu selection
Right-click Control+click and/or right-click o
. pen a context menu
depending on computer setup
Ctrl (Control) & (Command) Used with other keys
Ctrl+Q H+0 Exit / quit LibreOffice
F11 B+T Open the Sidebar’s Styles deck

What are all these things called?

The terms used in LibreOffice for most parts of the user interface (the parts of the program you see
and use, in contrast to the behind-the-scenes code that actually makes it work) are the same as for
most other programs.

A dialog is a special type of window. Its purpose is to inform you of something, or request input
from you, or both. It provides controls to use to specify how to carry out an action. The technical
names for common controls are shown in Figure 2. In most cases the technical terms are not used
in this book, but it is useful to know them because the Help and other sources of information often
use them.

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog
remains open. When you close the dialog after use (usually, clicking OK or another button saves
your changes and closes the dialog), then you can again work with your document.

Some dialogs can be left open as you work, so you can switch back and forth between the dialog
and your document. An example of this type is the Find & Replace dialog.
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https://extensions.libreoffice.org/extensions/legacy-gallery-backgrounds
https://extensions.libreoffice.org/extensions/oxygen-icon-theme
https://extensions.libreoffice.org/extensions/galaxy-icon-theme

Page Style: Default
| Organizer | Page Borders | Background Header | Footer [Sheet| 1

Page order-

® Top to bottom, then right
2 O Left to right, then down 4 5

First page number C%

Print
[] Column and row headers Charts
O Grid Drawing objects
O Comments [0 Formulas
Objects/graphics Zero values

Scale
Scaling mode 6
[Reduce.’enlarge printout 2 J Scaling factor @

7 [ OK ][ Cancel ] Help l [ Reset ]

Figure 2: Dialog showing common controls
1) Tabbed page (not strictly speaking a control).
2) Radio buttons (only one can be selected at a time).
3) Checkbox (more than one can be selected at a time).

4) Spin box (click the up and down arrows to change the number shown in the text box next to
it, or type in the text box).

5) Thumbnail or preview.
6) Drop-down list from which to select an item.
7) Push buttons.

Frequently asked questions

How is LibreOffice Licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Mozilla Public
License (MPL). See https://www.libreoffice.org/about-us/licenses/

It is based on code from Apache OpenOffice made available under the Apache License 2.0
but also includes software that differs from version to version under a variety of other Open
Source licenses. New code is available under LGPL 3.0 and MPL 2.0.

May I distribute LibreOffice to anyone? May | sell it? May | use it in my business?
Yes.

How many computers may | install it on?
As many as you like.

Is LibreOffice available in my language?
LibreOffice has been translated (localized) into over 40 languages, so your language
probably is supported. Additionally, there are over 70 spelling, hyphenation, and thesaurus
dictionaries available for languages, and dialects that do not have a localized program
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interface. The dictionaries are available from the LibreOffice Extension Center:
https://extensions.libreoffice.org/extensions?getCategories=Dictionary.

How can you make it for free?
LibreOffice is developed and maintained by volunteers and has the backing of several
organizations.

I am writing a software application. May | use programming code from LibreOffice in my
program?
You may, within the parameters set out in the licenses: https://www.mozilla.org/MPL/2.0/
https://www.libreoffice.org/about-us/licenses/.

Why do | need Java to run LibreOffice? Is it written in Java?
LibreOffice is not written in Java; it is mostly written in the C++ language. Java is one of
several languages that can be used to extend the software. The Java JRE (Java Runtime
Environment) is only required for some features. The most notable one is the HSQLDB
relational database engine.

Java is available at no cost. More information and download links to the appropriate edition
for your operating system can be found at: https://java.com/en/download/manual.jsp

£7] Note

If you want to use LibreOffice features that require Java it is important that the correct
32 bit or 64 bit edition matches the installed version of LibreOffice.

How can I contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you
do not need to be a programmer. To start, check out this webpage:
https://www.libreoffice.org/community/get-involved/

May I distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement
at the beginning of this book. You do not have to request special permission. We request that
you share with the project some of the profits you make from sales of books, in consideration
of all the work we have put into producing them.

Donate to LibreOffice: https://www.libreoffice.org/donate/

What’s new in LibreOffice Calc 6.4?

The LibreOffice 6.4 Release Notes are here:

https://wiki.documentfoundation.org/ReleaseNotes/6.4
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What is Calc?

Calc is the spreadsheet component of LibreOffice. You can enter data (usually numerical) in a
spreadsheet and then manipulate this data to produce certain results.

Alternatively, you can enter data and then use Calc in a ‘What if...” manner by changing some of
the data and observing the results without having to retype the entire spreadsheet or sheet.

Other features provided by Calc include:

* Functions, which can be used to create formulas to perform complex calculations on data.
» Database functions to arrange, store, and filter data.
* Dynamic charts, including a wide range of 2D and 3D charts.

* Macros for recording and executing repetitive tasks; scripting languages supported include
LibreOffice Basic, Python, BeanShell, and JavaScript.

» Ability to open, edit, and save Microsoft Excel spreadsheets.

* Import and export of spreadsheets in multiple formats, including HTML, CSV, PDF, and
PostScript.

Z Note

If you want to use macros written in Microsoft Excel using the VBA macro code in
LibreOffice, you must first edit the code in the LibreOffice Basic IDE editor. For more
information, see Chapter 12, Macros, in this guide or Chapter 13, Getting Started with
Macros, in the Getting Started Guide.

Spreadsheets, sheets, and cells

Calc works with documents called spreadsheets. Spreadsheets consist of a number of individual
sheets, each sheet containing cells arranged in rows and columns. A particular cell is identified by
its row number and column letter.

Cells hold the individual elements — text, numbers, formulas, and so on — that make up the data to
display and manipulate.

Each spreadsheet can have up to 10,000 sheets and each sheet can have a maximum of
1,048,576 rows and 1,024 columns. The maximum number of characters in one cell is 32,767.

Calc main window

When Calc is started, the main window opens (Figure 3). The various parts of this display are
explained below.

i:.z Note

If any part of the Calc window in Figure 3 is not shown, you can display it using the
View menu. For example, View > Status Bar on the Menu bar will toggle (show or
hide) the Status Bar. It is not always necessary to display all of the parts shown; you
can show or hide any of them as desired.

Title bar

The Title bar, located at the top, shows the name of the current spreadsheet. When the
spreadsheet is newly created, its name is Untitled X, where X is a number. When you save a
spreadsheet for the first time, you are prompted to enter a hame of your choice.
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Figure 3: Calc main window

Menu bar

Under the Title bar is the Menu bar. When you choose one of the menus, a list of options appears.
You can also modify the Menu bar, as explained in Chapter 14, Setting Up and Customizing.

* File — contains commands that apply to the entire document, such as Open, Save,
Wizards, Export as PDF, Print, Digital Signhatures, Templates.

* Edit — contains commands for editing the document, such as Undo, Copy, Find &
Replace, Track Changes.

* View — contains commands for modifying how the Calc user interface looks, such as
Toolbars, View Headers, Full Screen, Zoom.

* Insert — contains commands for inserting elements into a spreadsheet, such as Image,
Text Box, Headers and Footers.

* Format — contains commands for modifying the layout of a spreadsheet, such as Cells,
Page, AutoFormat Styles, Align.

» Styles — contains options for applying and managing styles, such as Heading 1, Footnote,
Manage Styles.

* Sheet — contains commands for inserting and deleting elements and modifying the entire
sheet, such as Delete Rows, Insert Sheet, Rename Sheet, Navigate.

+ Data — contains commands for manipulating data in your spreadsheet, such as Define
Range, Sort, AutoFilter, Consolidate.

* Tools — contains functions to help check and customize a spreadsheet, for example
Spelling, Share Spreadsheet, Macros, Options.

* Window — contains two commands; New Window and Close Window. Also shows all
open windows in other LibreOffice applications.
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* Help — contains links to LibreOffice Help (included with the software), User Guides, and
other miscellaneous functions; for example Restart in Safe Mode, License Information,
Check for Updates.

Toolbars

The default setting when Calc opens is for the Standard and Formatting toolbars to be docked at
the top of the workspace (Figure 3).

Calc toolbars can be either docked (fixed in place), or floating, allowing you to move a toolbar to a
more convenient location on your workspace. Docked toolbars can be undocked and moved to a
different docked location or become floating toolbars. Likewise, floating toolbars can be docked.

You can choose the single-toolbar alternative to the default double toolbar arrangement. It contains
the most-used commands. To activate it, enable View > Toolbars > Standard (Single Mode) and
disable View > Toolbars > Standard and View > Toolbars > Formatting.

For additional information on toolbars, see Chapter 1, Introducing LibreOffice, of the Getting
Started Guide.

The default set of icons (sometimes called buttons) on toolbars provides a wide range of common
commands and functions. You can also remove or add icons to toolbars. See Chapter 14, Setting
Up and Customizing, for more information.

Placing the mouse cursor over an icon, text box, or menu command displays a small box called a
tooltip that shows the name of the item’s function. To close a tooltip, click once away from the icon
or press the Esc key.

To see a more detailed explanation of an icon, textbox, or menu command, do one of the following
to open extended tips:

» To activate extended tips just once: press Shift+F1.

* To activate extended tips from the Menu bar: go to Help > What’s This? and hover the
mouse pointer over an icon.

» To turn extended tips on or off: go to from Tools > Options > LibreOffice > General on the
Menu bar.

Formula Bar

The Formula Bar is located at the top of the Calc workspace. It is permanently docked in this
position and cannot be used as a floating toolbar. However, it can be hidden or made visible by
going to View > Formula Bar on the Menu bar.

L37 v B BT = -
Figure 4: Formula Bar
From left to right in Figure 4, the Formula Bar consists of the following:

* Name Box — gives the current active cell reference using a combination of a letter and
number, for example Al. The letter indicates the column and the number indicates the row
of the selected cell. If you have selected a range of cells that is also a named range, the
name of the range is shown in this box. You can also type a cell reference in the Name Box
to jump to the referenced cell. If you type the name of a named range and press the Enter
key, the named range is selected and displayed.

«  Function Wizard * — opens a dialog from which you can search through lists of available
functions and formulas. This can be very useful because it also shows how the functions
are formatted.

« Select Function 2 — performs a calculation on the numbers in the cells above the
selected cell and then places the result in the selected cell. If there are no numbers above
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the selected cell, then the calculation operates on the cells to the left. The calculation to be
performed is selected from a drop-down menu containing options for Sum, Average, Min,
Max, and Count.

* Formula = -inserts an equals (=) sign in the selected cell and the Input line, allowing a
formula to be entered.

* Input line — displays the contents of the selected cell (data, formula, or function) and allows
you to edit the cell contents. To turn the Input line into a multiline input area for very long
formulas, click the drop down button on the right. To edit inside the Input line area, click in
the area, then type your changes.

You can also directly edit inside the cell by double-clicking on the cell. When you enter new data
into a cell, the Select Function and Formula icons change to Cancel and Accept icons

£7] Note

In a spreadsheet, the term “function” covers much more than just mathematical
functions. See Chapter 7, Using Formulas and Functions, for more information.

Status Bar

The Calc Status Bar at the bottom of the workspace (Figure 5) provides information about the
spreadsheet and convenient ways to quickly change some of its features. Most of the fields are
similar to those in other components of LibreOffice. See Chapter 1, Introducing LibreOffice, in the
Getting Started Guide for more information.

Sheet number Page style Insert [ overwrite mode Unsaved changes  Cell or object information

.,

| Sheet 1 of 1 Selected: 7 rows, 2 columns Default English (USA) Average: ; Sune [ Selection count: 14 100% ‘

ST //

Cell selection information Language Selection mode Digital signature Zoom slider & percentage

Figure 5: Calc Status Bar

The fields on the Status Bar, from left to right, are as follows.

Sheet number
Shows the sequence number of the current sheet and the total number of sheets in the
spreadsheet. The sequence humber may not be the same as the name on the sheet tab if
sheets have been moved. Double-click on this zone to open the Navigator.

Number of selected rows and columns
Shows how many rows and how many columns are selected.

Page style
Shows the page style of the current sheet. To edit the page style, double-click on this field
and the Page Style dialog opens.

Language
Shows current default language as selected at Tools > Options > Language Settings >
Languages.

Insert | overwrite mode
This field is blank if the program is in insert mode. Press the Ins key to change modes.
Overwrite shows when in overwrite mode.

Selection mode
Right-click to open a context menu and select Standard selection, Extending selection, or
Adding selection. The icon does not change when different selection modes are selected,
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but the tooltip shows the current status. See Chapter 1, Introducing LibreOffice, in the
Getting Started Guide for more information.

Unsaved changes

This icon indicates the spreadsheet contains unsaved changes. Click this icon or use File >

Save to save the spreadsheet.

Digital signature

If the document has been digitally signed, an icon shows here. You can double-click the icon
to view the certificate. See Chapter 6, Printing, Exporting, E-mailing, and Signing for more

information about digital signatures.

Cell or object information
Displays information related to the position of the cursor or the selected element of the
spreadsheet. When a group of cells is selected, the sum of the contents is displayed by

default. Right-click in this field to select other functions, such as the average value, maximum

value, minimum value, or count (number of items selected).

Zoom slider
Drag the zoom slider, or click the + and — signs to change the view magnification.

Zoom percentage

Indicates the magnification level of the document. Right-click on the percentage to open a list

of magnification values from which to choose. Double-click on the percentage to open the
Zoom & View Layout dialog.

Sidebar

The Calc Sidebar (Figure 6) is a mixture of toolbar and dialog. When opened (View > Sidebar or
Ctrl+F5), it appears on the right side of the window and consists of five decks: Properties, Styles,

Gallery, Navigator, and Functions. Each deck has a corresponding icon on the Tab panel to the
right of the sidebar, allowing you to switch between them. The decks are described below.

Properties

This deck includes five content panels. These panels, with the exception of the Style panel,
have More Options buttons that open dialogs with additional options. These dialogs lock the
document for editing until they are closed.

Style: Options for applying, updating, or creating cell and page styles.

Character: Options for formatting the text, such as font family, size, and color. Some
controls, such as superscript, only become active when the text cursor is active in the Input
line of the Formula bar or the cell.

Number Format: Options for formatting numbers, including decimals, currency, dates, or
numeric text.

Alignment: Options for arranging the text in various ways, including horizontal and vertical
alignment, wrapping, indenting, merging, text orientation, and vertical stacking.

Cell Appearance: Options include background color, border formats including line color and
style, and grid lines.

Styles

This deck is the same as the dialog opened by selecting Styles > Manage Styles from the
Menu bar or F11.

Gallery

This deck is the same as the dialog opened by selecting View > Gallery from the Menu bar.

Navigator

This deck is the same as the Navigator window opened by selecting View > Navigator from
the Menu bar or F5. See “Using the Navigator” on page 36.
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Figure 6: Sidebar

Functions
This deck contains a list of functions organized by category. It is a simpler version of the
Function Wizard, which is opened by selecting Insert > Function on the Menu bar or

Ctrl+F2.

To the right side of the title bar of each open deck is a Close button (X), which closes the deck to
leave only the Tab bar open. Clicking on any Tab button reopens the deck.

To hide the Sidebar, or reveal it if already hidden, click on the left edge Hide/Show button. To
adjust the deck width, drag on the left edge of the Sidebar.

Spreadsheet layout

Individual cells
The main section of the screen displays the cells in the form of a grid, with each cell located at the
intersection of a column and a row.

At the tops of the columns and the left ends of the rows are a series of header boxes containing
letters and numbers. The column headers use alpha characters that start with A and increase to
the right. The row headers use numerical characters that start at 1 and increase down.

These column and row headers form the cell references that appear in the Name Box on the
Formula Bar (Figure 4). If the headers are not visible on the spreadsheet, go to View > Headers
on the Menu bar.
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Sheet tabs

A spreadsheet file can contain many individual sheets. At the bottom of the grid of cells in a
spreadsheet are sheet tabs (Figure 3). Each tab represents a sheet in a spreadsheet. Create a
new sheet by clicking on the plus sign to the left of the sheet tabs.

Clicking on a tab enables access to an individual sheet. When a sheet is active, the tab is
highlighted. Select multiple sheets by holding down the Ctrl key while clicking on the sheet tabs.

To change the default name for a sheet (Sheetl, Sheet2, and so on):

1) Right-click on the sheet tab and select Rename Sheet from the context menu. A dialog
opens allowing you to type in a new name for the sheet.

2) Click OK when finished to close the dialog.
To change the color of a sheet tab:

1) Right-click on the sheet tab and select Tab Color from the context menu to open the Tab
Color dialog (Figure 7).

2) Select a color and click OK when finished to close the dialog.

Tab Color *

IDefault i
EEEEEN
EEEEEEEN

Default

EEHCE|

Figure 7: Tab Color dialog

To add new colors to this color palette, see “Adding Custom colors” in Chapter 14, Setting up and
Customizing.

Creating, opening, and saving spreadsheets

Creating and opening

Creating and opening spreadsheets is identical to creating and opening documents in the other
LibreOffice modules. For more information on creating and opening spreadsheets, see Chapter 1,
Introducing LibreOffice, in the Getting Started Guide.

Using templates

Calc documents can also be created from templates. For information on how to create and use
templates, see Chapter 4, Using Styles and Templates, in this guide.

Opening a CSV file

Comma-separated values (CSV) files are spreadsheet files in a text format where cell contents are
separated by a character such as a comma or semi-colon. Each line in a CSV text file represents a
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row in a spreadsheet. Text is entered between quotation marks; numbers are entered without
guotation marks.

To open a CSV file in Calc:

1)
2)

3)

4)

Choose File > Open on the Menu bar and locate the CSV file that you want to open.

Select the file and click Open. By default, a CSV file has the extension .csv. However,
some CSV files may have a .txt extension.

The Text Import dialog (Figure 8) opens. Here you can select options for importing a CSV
file into a Calc spreadsheet.

Click OK to open and import the file.

Text Import - [Test%20data.csv] K

Import

Character zet:

Language: Default - English (USA) ~ |

From row: 1 =

Separator Options
O Fixed width ®) Separated by
Tab LComma Semicolon O Space O Other

[ Merge delimiters [ Trim spaces String delimiter: | ™
9 p ]
Other Options
O Format quoted field as text [ Detect special numbers
q B
Fields
Standard |Star1dard |Star1dard Etandard ”
1 LD First Name Last Wame Number
2 [LoBZ Mary Alexander 739-495-8304
3 [LO65 Steve Bacon 379-663-8918
4 1083 patrice Budreau  298-635-0135
| 5 (L8108 Jose Gonzalez 278-270-8386
g [LBa1 Krishna Gupta 943-583-8274
7 L@as vicky Li 198-544-9208
g [LO04 Rose Mokoro 603-883-8313
n HARD Trinh Nrven E73-ART-AOAS ~
< >

Figure 8: Text import dialog

The options for importing CSV files into a Calc spreadsheet are as follows:

Import

Character set — specifies the character set to be used in the imported file.

Language — determines how the number strings are imported. If Language is set to Default,
Calc will use the language selected at Tools > Options > Language Settings >
Languages > Default Languages for Document. If another language is selected, that
language will determine how numbers are treated.

From row — specifies which row the import starts with. The initial rows are visible in the
preview window at the bottom of the dialog.

Separator Options

Fixed width — separates data into columns by a set number of characters. Click on the ruler
that appears in the preview window to set the width.

Separated by — separates data into columns based on the separator defined here. Select
Other to specify another character used to separate data into columns. This custom
separator must also be contained in the data.

Merge delimiters — combines consecutive delimiters and removes blank data fields.
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Trim spaces — removes starting and trailing spaces from within fields.
String delimiter — select a character to delimit text data.

Other options

Fields

Format quoted field as text — when this option is enabled, fields or cells whose values are
entirely within quotes are imported as text.

Detect special numbers — when this option is enabled, Calc will automatically detect all
number formats, including special number formats such as dates, time, and scientific
notation. The selected language influences how such special numbers are detected, since
different languages and regions many have different conventions for such special numbers.

When this option is disabled, Calc will detect and convert only decimal numbers. The rest,
including numbers formatted in scientific notation, will be imported as text. A decimal
number string can have digits 0-9, thousands separators, and a decimal separator.
Thousands separators and decimal separators may vary with the selected language and
region.

— shows how your data will look when it is separated into columns.

Column type — select a column in the preview window and select the data type to be applied
to the imported data.

— Standard — Calc determines the type of data.
— Text - imported data are treated as text.
— Date — imported data are treated as dates.

— US English — numbers formatted in US English are searched for and included
regardless of the system language. A number format is not applied. If there are no US
English entries, the Standard format is applied.

— Hide - the data in the column are not imported.

Saving spreadsheets

For information on how to save files manually or automatically, see Chapter 1, Introducing
LibreOffice, in the Getting Started Guide. Calc can save spreadsheets in a range of formats and
also export spreadsheets to PDF, HTML and XHTML file formats; see Chapter 6 Printing,
Exporting, Emailing, and Signing, for more information.

Saving in other formats

If you need to send files to users who are unable to receive spreadsheet files in Open Document
Format (ODF) (*.ods), which Calc uses as default format, you can save a spreadsheet in another

format.
1)

2)

3)

4)

Select File > Save As on the Menu bar or Ctr/+Shift+S to open the Save As dialog (Figure
9).

In File name, if you wish, enter a new file name for the spreadsheet and select the folder
where you want to save the file.

In the Save as type field, select from the drop-down menu the type of spreadsheet format
you want to use. If Automatic file name extension is selected, the correct file extension
for the spreadsheet format you have selected will be added to the file name.

Click Save.
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Figure 9: The Save As dialog

Each time a file is saved in a format other than ODF format, the Confirm File Format dialog opens
(Figure 10). Click Use [xxx] Format to continue saving in the selected spreadsheet format or click
Use ODF Format to save the spreadsheet in Calc ODS format. If you disable Warn when not
saving in ODF or default format on Tools > Options > Load/Save > General on the Menu bar,
the Confirm File Format dialog will no longer appear. You can also clear the checkbox Ask when
not saving in ODF or default format on the dialog to stop the dialog appearing.

Confirm File Format *

This document may contain formatting or content that cannot be
saved in the currently selected file format “Excel 2007-2019".

Use the default ODF file format to be sure that the document is saved correctly.

Ask when not saving in ODF or default format

Use Excel 2007-2019 Format

Figure 10: Confirm File Format dialog

If you select Text CSV format (*.csv), the Export Text File dialog (Figure 11) opens. Here you can
select the character set, field delimiter, text delimiter and so on to be used for the CSV file.

g Note

Once you have saved a spreadsheet in another format, all changes you make to the
spreadsheet will now occur only in the format you are using because you have
changed the name and file type of your document. If you want to go back to working
with an *.ods version, you must save the file as an *.ods file.

':Q:‘ Tip

To have Calc save documents by default in a file format other than the default ODF
format, go to Tools > Options > Load/Save > General. In the section named Default
File Format and ODF Settings, next to Document type, select Spreadsheet, then next
to Always save as, select your preferred file format, for example Microsoft Excel.
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Figure 11: Export Text File dialog

Password protection

To protect a spreadsheet and restrict who can open, read, and make changes to it, you have to use
password protection. Password protection is common to all LibreOffice modules; for more
information, see Chapter 1, Introducing LibreOffice, in the Getting Started Guide.

Navigating within spreadsheets

Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet to sheet. You
can generally use the method you prefer.

Cell navigation

When a cell is selected or in focus, the cell borders are emphasized. When a group of cells is
selected, the cell area is colored. The color of the cell border emphasis and the color of a group of
selected cells depends on the operating system being used and how you have set up LibreOffice.

Using the mouse — place the mouse pointer over the cell and click the left mouse button. To
move the focus to another cell using the mouse, move the mouse pointer to the cell and
click the left mouse button.

Using a cell reference — select or delete the existing cell reference in the Name Box on the
Formula Bar (Figure 4 on page 17). Type the new cell reference of the cell you want to
move to and press the Enter key. Cell references are case insensitive. Thus, typing a3 or
A3 will move the focus to cell A3.

Using the Navigator — go to View > Navigator or press the F5 key to open the Navigator
dialog (Figure 12). Type the cell references into the Column and Row fields and press the
Enter key.

Using the Enter key — pressing Enter moves the cell focus down one cell (by default). You
can change the direction of this focus movement as described in the “Customizing the
Enter key” section on page 28.

Pressing Shift+Enter moves the focus up one cell.

Using the Tab key — pressing Tab moves the cell focus one cell to the right. Pressing
Shift+Tab moves the focus one cell to the left.

Using the arrow keys — pressing the arrow keys on the keyboard moves the cell focus in the
direction of the arrow pressed.
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Figure 12: Navigator dialog

* Using Home, End, Page Up, and Page Down

— Home moves the cell focus to the start of a row. Ctrl+Home moves the cell focus to the
first cell in the sheet, Al.

— End moves the cell focus to the last cell in the same row that contains data. Ctrl+End
moves the cell focus to the last cell in the sheet that contains data.

— Page Down moves the cell focus down one complete screen display.
— Page Up moves the cell focus up one complete screen display.

Sheet navigation

Each sheet in a spreadsheet is independent of the other sheets, though references can be linked
from one sheet to another. There are three ways to navigate between different sheets in a
spreadsheet.

* Using the Navigator — when the Navigator is open (Figure 12), double-clicking on any of the
listed sheets selects the sheet.

* Using the keyboard — using key combinations Ctrl+Page Down moves one sheet to the
right and Ctrl+Page Up moves one sheet to the left.

* Using the mouse - clicking on one of the sheet tabs at the bottom of the spreadsheet
selects that sheet.

If there are many sheets in the spreadsheet, some of the sheet tabs may be hidden. If this is the
case, use the four buttons to the left of the sheet tabs to move the tabs into view (Figure 13).

Z Note

The sheet tab arrows that appear on the left in Figure 13 are only active if there are
more sheet tabs than can be displayed.
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Move to the first sheet
Move to the next sheet on the left
Move to the next sheet on the right

’/ Move to the last sheet
(2w
Sheet2 /6

Default

Sheet tabs
Figure 13. Navigating sheet tabs

i:.z Note

When you insert a new sheet into a spreadsheet, Calc automatically uses the next
number in the numeric sequence as a name. Depending on which sheet is open when
you insert a new sheet, your new sheet may not be in numerical order. It is
recommended to rename sheets in a spreadsheet to make them more recognizable.

Keyboard navigation

You can navigate a spreadsheet using the keyboard, by pressing a key or a combination of keys at
the same time. For example, Ctrl+Home moves the focus to cell Al. Table 1 lists the keys and key
combinations you can use for spreadsheet navigation in Calc.

Table 1. Keyboard cell navigation

Keyboard L
shortcut Cell navigation
-/ Moves cell focus right/left one cell.
1/l Moves cell focus up/down one cell.
Ctrl+- / If focus is on a blank cell, moves focus to the first cell on the right/left that
Ctrl+ — contains data.
If focus is on a cell containing data, moves focus to the last/first cell on the
right/left containing data.
If there are no more cells containing data, moves focus to the last/first cell on
the right/left in the spreadsheet.
Ctrl+r / If focus is on a blank cell, moves focus to the first cell above/below that
Ctri+| contains data.
If focus is on a cell containing data, moves focus to the cell in Row 1/last cell
containing data in the same column.
If there are no more cells below containing data in that column, moves focus
to the cell in the same column in the last row of the spreadsheet.
Ctrl+Home / Moves focus from anywhere on the spreadsheet to Cell Al/the last cell in the
Ctrl+End lower right-hand corner of the rectangular area of cells containing data on

Alt+Page Down /
Alt+Page Up

Ctrl+Page Down /
Ctrl+Page Up

the same sheet.

Moves focus one screen to the right/left (if possible).

Moves focus to the same cell on the next sheet to the right/left in sheet tabs
if there are more sheets in that direction.
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R Cell navigation

shortcut

Tab / Moves focus to the next cell on the right/left.

Shift+Tab

Enter/ Moves focus down/up one cell (unless changed by user).
Shift+Enter

Customizing the Enter key

You can choose the direction in which the Enter key moves the cell focus by going to Tools >
Options > LibreOffice Calc > General. Use the first two options under Input settings (Figure 14)
to change the Enter key settings. Select the direction cell focus moves from the drop-down list.
Depending on the file being used or the type of data being entered, setting a different direction can
be useful. The Enter key can also be used to switch into and out of editing mode.

Input Settings
Press Enter to move selection

[ Press Enter to switch to edit mode

Right
[ Expand formatting UF?
O Expand references when new columns/rows are (Left

[ Update references when sorting range of cells

Highlight selection in column/row headers
[ Use printer metrics for text formatting
Show overwrite warning when pasting data

[ Position cell reference with zelection

Figure 14: Customizing the Enter key

Selecting items in a spreadsheet

Selecting cells

Single cell

Left-click in the cell. You can verify the selection by looking in the Name Box on the Formula Bar
(Figure 4).

Range of contiguous cells
A range of cells can be selected using the keyboard or the mouse.

To select a range of cells by dragging the mouse cursor:

1) Clickin a cell.

2) Press and hold down the left mouse button.

3) Move the mouse around the screen.

4) Once the desired block of cells is highlighted, release the left mouse button.
To select a range of cells without dragging the mouse:

1) Click in the cell which is to be one corner of the range of cells.

2) Move the mouse to the opposite corner of the range of cells.

3) Hold down the Shift key and click.
To select a range of cells using Extending selection mode:

1) Click in the cell which is to be one corner of the range of cells.
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2) Right-click in the Selection mode field on the Status Bar (Figure 5 on page 18) and select
Extending selection.

3) Click in the cell in the opposite corner of the range of cells.
00 Tip

Make sure to change back to Standard selection or you may find yourself extending a
cell selection unintentionally.

To select a range of cells without using the mouse:

1) Select the cell that will be one of the corners in the range of cells.

2) While holding down the Shift key, use the cursor arrows to select the rest of the range.
To select a range of cells using the Name Box:

1) Click in the Name Box on the Formula Bar (Figure 4 on page 17).

2) Enter the cell reference for the upper left-hand cell, followed by a colon (:), and then the
lower right-hand cell reference, then press the Enter key. For example, to select the range
that would go from A3 to C6, enter A3:C6.

Range of non-contiguous cells

To select a range of non-contiguous cells using the mouse:
1) Select the first cell or range of cells using one of the methods above.
2) Move the mouse pointer to the start of the next range or single cell.

3) Hold down the Ctrl key and click or click-and-drag to select another range of cells to add to
the first range.

4) Repeat as necessatry.
To select a range of cells using Adding selection mode:

1) Click in the cell which is to be one corner of the range of cells.

2) Right-click in the Selection mode field on the Status Bar (Figure 5 on page 18) and select
Extending selection before clicking in the opposite corner of the range of cells.

Selecting columns and rows

Single column or row

To select a single column, click on the column header (Figure 3 on page 16). To select a single
row, click on the row header.

Multiple columns or rows
To select multiple columns or rows that are contiguous:
1) Click on the first column or row in the group.
2) Hold down the Shift key.
3) Click the last column or row in the group.
To select multiple columns or rows that are not contiguous:

1) Click on the first column or row in the group.
2) Hold down the Ctrl key.
3) Click on all of the subsequent columns or rows while holding down the Citrl key.
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Entire sheet

To select the entire sheet, click on the small box between the column headers and the row headers
(Figure 15), or use the key combination Ctr/+A to select the entire sheet, or go to Edit on the Menu
bar and select Select All.

B
Surname

2 \ Weber
Select all box

Figure 15. Select All box

Selecting sheets

You can select either one or multiple sheets in Calc. It can be advantageous to select multiple
sheets, especially when you want to make changes to many sheets at once.

Single sheet

Click on the sheet tab for the sheet you want to select. The tab for the selected sheet becomes
white (default Calc setup) or is otherwise highlighted.

Multiple contiguous sheets
To select multiple contiguous sheets:
1) Click on the sheet tab for the first desired sheet.
2) While holding down the Shift key, click on the sheet tab for the last desired sheet.
3) All tabs between these two selections will turn white (default Calc setup). Any actions that
you perform will now affect all highlighted sheets.
Multiple non-contiguous sheets
To select multiple non-contiguous sheets:
1) Click on the sheet tab for the first desired sheet.
2) While holding down the Ctrl key, click on the sheet tabs for other desired sheets.
3) The selected tabs will turn white (default Calc setup). Any actions that you perform will now
affect all highlighted sheets.
All sheets
Right-click a sheet tab and choose Select All Sheets from the context menu.

Working with columns and rows

Inserting columns and rows

When you insert columns or rows, the cells take the formatting of the corresponding cells in the
column to the left or the row above.

Single column or row
Using the Sheet menu:
1) Select a cell, column, or row where you want the new column or row inserted.

2) Go to Sheet on the Menu bar. For columns, select Sheet > Insert Columns and then
select Columns Before or Columns After. For rows, select Sheet > Insert Rows and
then select Rows Above or Rows Below.
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Using the context menu:

1) Select a column or row where you want the new column or row inserted.
2) Right-click the column or row header.

3) Select Insert Columns Before | After or Insert Rows Above |/ Below from the context
menu.

Multiple columns or rows
Multiple columns or rows can be inserted at once rather than inserting them one at a time.

1) Highlight the required number of columns or rows by holding down the left mouse button on
the first one and then dragging across the required number of identifiers.

2) Proceed as for inserting a single column or row above. The number of columns or rows
highlighted will be inserted.

Deleting columns and rows

Single column or row
To delete a single column or row, do one of the following:

» Select a cell in the column or row you want to delete, right-click and select Delete in the
context menu to open the Delete Cells dialog (Figure 16). Select Delete entire column(s)
or Delete entire row(s) and press the OK button.

» Select a cell in the column or row you want to delete and select Sheet > Delete Columns
or Sheet > Delete Rows.

* Right-click the header of the column or row that you want to delete and select Delete
Columns or Delete Rows from the context menu.

Multiple columns or rows
To delete multiple columns or rows, do one of the following:

» Select arange of cells across the columns or rows you want to delete, right-click and select
Delete in the context menu to open the Delete Cells dialog. Select Delete entire
column(s) or Delete entire row(s) and press the OK button.

* Select arange of cells across the columns or rows you want to delete and select Sheet >
Delete Columns or Sheet > Delete Rows.

» Highlight the required columns or rows by holding down the left mouse button on the
header of the first one and then dragging across the required number of headers. Then
right-click on one of the selected column or row headers and select Delete Columns or
Delete Rows from the context menu.

Deleting cells

1) Select the cell or cells you want to delete.

2) Select Sheet > Delete Cells, or right-click on one of the selected cells and select Delete
from the context menu.

3) Select the option you require from the Delete Cells dialog and press the OK button.
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Delete Cells

() shift cells Jeft
i) Delete entire row(s)
() Delete entire column(s)

Help

Cancel

Figure 16: Delete Cells dialog

Working with sheets

Inserting new sheets

Click on the Add Sheet icon 5 next to the sheet tabs to insert a new sheet after the last sheet in
the spreadsheet without opening the Insert Sheet dialog. The following methods open the Insert
Sheet dialog (Figure 17) where you can position the new sheet, create more than one sheet, name

the new sheet, or select a sheet from a file.

the Menu bar or click Alt+S+S.

from the context menu.

context menu.

Select the sheet where you want to insert a new sheet, then go to Sheet > Insert Sheet on
Right-click on the sheet tab where you want to insert a new sheet and select Insert Sheet

Click in the empty space at the end of the sheet tabs.
Right-click in the empty space at the end of the sheet tabs and select Insert Sheet from the

Position
® Before current sheet
O After current sheet
Sheet
®) New sheet
Mo, of sheets: |1

Mame: Sheet3

OEromfiIe

-
-

Help

Cancel

Figure 17: Insert Sheet dialog

Moving and copying sheets

You can move or copy sheets within the same spreadsheet by dragging and dropping or using the
Move/Copy Sheet dialog (Figure 18). To move or copy a sheet into a different spreadsheet, use the

Move/Copy Sheet dialog.

32 | Working with sheets



Dragging and dropping
To move a sheet to a different position within the same spreadsheet, click on the sheet tab and
drag it to its new position before releasing the mouse button.

To copy a sheet within the same spreadsheet, hold down the Cirl key (Option key on Mac) then
click on the sheet tab and drag it to its new position before releasing the mouse button. The mouse
pointer may change to include a plus sign depending on the setup of your operating system.

Using Move/Copy Sheet dialog

The Move/Copy Sheet dialog allows you to specify exactly whether you want the sheet in the same
or a different spreadsheet, its position within the spreadsheet, and the sheet name when it is
moved or copied.

1)

2)
3)

4)
5)

A

Move/Copy Sheet >
Action

® Move: O Copy
Location

To document

|Quarter|}r staterments (current document) w

Insert before

- move to end position -

New name

P&IL by job

Figure 18: Move/Copy Sheet dialog

In the current document, right-click on the sheet tab you wish to move or copy and select
Move or Copy Sheet from the context menu or go to Sheet > Move or Copy Sheet on the
Menu bar.

Select Move to move the sheet or Copy to copy the sheet.

Select the spreadsheet where you want the sheet to be placed from the drop-down list in
To document. This can be the same spreadsheet, another spreadsheet already open, or
you can create a new spreadsheet.

Select the position in Insert before where you want to place the sheet.

Type a hame in the New name text box if you want to rename the sheet when it is moved or
copied. If you do not enter a name, Calc creates a default name (Sheet 2, Sheet 3, and so
on).

Click OK to confirm the move or copy and close the dialog.
Warning

When you move or copy to another spreadsheet or to a new one, a conflict may occur
if formulas are linked to sheets in the previous location.
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Deleting sheets

To delete a single sheet, right-click on the sheet tab you want to delete and select Delete Sheet
from the context menu, or go to Sheet > Delete Sheet on the Menu bar. Click Yes to confirm the
deletion.

To delete multiple sheets, select the sheets (see “Selecting sheets” on page 30), then right-click
one of the sheet tabs and select Delete Sheet from the context menu, or go to Sheet > Delete
Sheet on the Menu bar. Click Yes to confirm the deletion.

Renaming sheets

By default, the name for each new sheet added is SheetX, where X is the number of the next sheet
to be added. While this works for a spreadsheet with only a few sheets, it can become difficult to
identify sheets when a spreadsheet contains many sheets.

You can rename a sheet using one of the following methods:

« Enter the name in the Name text box when you create the sheet using the Insert Sheet
dialog (Figure 17 on page 32).

* Right-click on a sheet tab and select Rename Sheet from the context menu to replace the
existing name with a different one.

Double-click on a sheet tab to open the Rename Sheet dialog.

£7] Note

Sheet names must start with either a letter or a number. Other characters, including
spaces, are not allowed. Apart from the first character of the sheet name, permitted
characters are letters, numbers, spaces, and the underscore character. Attempting to
rename a sheet with an invalid name will produce an error message.

Viewing Calc

Changing document view

Use the zoom function to show more or fewer cells in the window when you are working on a
spreadsheet. For more about zoom, see Chapter 1, Introducing LibreOffice, in the Getting Started
Guide.

Freezing rows and columns

Freezing is used to lock rows across the top of a spreadsheet or to lock columns on the left of a
spreadsheet. Then, when moving around within a sheet, the cells in frozen rows and columns
always remain in view.

Figure 19 shows some frozen rows and columns. The heavier horizontal line between rows 3 and
23 and the heavier vertical line between columns F and Q indicate that rows 1 to 3 and columns A
to F are frozen. The rows between 3 and 23 and the columns between F and Q have been scrolled
off the page. To freeze rows or columns:

1) Click on the row header below the rows you want the freeze or click on the column header
to the right of the columns where you want the freeze. To freeze both rows and columns,
select the cell (not a row or column) that is below the row and to the right of the column that
you want to freeze

2) Go to View on the Menu bar and select Freeze Rows and Columns. Shortcut: Alt V+R. A
heavier line appears between the rows or columns indicating where the freeze has been
place.
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A B C D E F Q | R
1 Sumame |First Name |Address City Country
2 Weber Jean PO Box 640  |Airlie Beach |Australia
3 Schofield Peter Jankowskiego |Opole Poland
23
_24 |

Figure 19. Frozen rows and columns

Unfreezing

To unfreeze rows or columns, go to View on the Menu bar and click Freeze Rows and Columns
to toggle it off. The heavier lines indicating freezing will disappear.

Splitting the screen

Another way to change the view is by splitting the screen displayed (also known as splitting the
window). The screen can be split horizontally, vertically, or both, displaying up to four portions of
the spreadsheet at the same time. An example of splitting the screen is shown in Figure 20 where
a split is indicated by a gray line.

This could be useful for example, when a large spreadsheet has one cell with a number that is
used by three formulas in other cells. Using the split-screen technique, the cell containing the
number can be positioned in one section of the view and the cells with formulas can be seen in the
other sections. This makes it easy to see how changing the number in one cell affects each of the
formulas.

A | B | c |
1 Beta= 3.2000
2 Al= 0.1000
_5 |
_6 |
7 Al=| Beta*A0"(1-AD) 0.2880
8 A2=| Beta"Al*{1-Al) 0.6562
) A3= Beta*A3"(1-A2) 0.7219
10 Ad=| Beta"Ad7(1-A3) 0.6424
11 A5=| Beta"A5+(1-Ad) 0.7351

Fig_ure 20. Split screen example

Splitting horizontally or vertically
There are two ways to split a screen horizontally or vertically:

Method One:

1) Click on the row header below the rows where you want to split the screen horizontally or
click on the column header to the right of the columns where you want to split the screen
vertically.

2) Go to View on the Menu bar and select Split Window. A thick line appears between the
rows or columns indicating where the split has been placed. An example of a split line is
shown below Row 2 in Figure 20.

Method Two:

For a horizontal split, click on the thick black line at the top of the vertical scroll bar (Figure 21) and
drag the split line below the row where you want the horizontal split positioned.

Similarly, for a vertical split, click on the thick black line at the right of the horizontal scroll bar
(Figure 21) and drag the split line to the right of the column where you want the vertical split
positioned.
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Horizontal screen Vertical screen
split bar split bar

Figure 21. Split screen bars

Splitting both horizontally and vertically

Method One:

Position both the black horizontal and the black vertical lines as described above and as shown in
Figure 21.

Method Two:

1) Click the cell that is immediately below the rows where you want to split the screen
horizontally and immediately to the right of the columns where you want to split the screen
vertically.

2) Go to View on the Menu bar and select Split Window. Thick lines appear between the
rows and columns indicating where the splits have been placed.
Removing split views
To remove a split view, do any of the following:
* Double-click on each split line.

* Click on and drag the split lines back to their places at the ends of the scroll bars.
* Go to View on the Menu bar and click Split Window to toggle it off.

Using the Navigator

The Navigator (Figure 22) is available in all LibreOffice modules. It provides tools and methods to
move quickly through a spreadsheet and find specific items.

@& Navigator

Column A =

Row |1 =

¥ EH Sheets
heet1
EE Range names
&l Database ranges
PP Linked areas
B Graphics
| OLE objects
2] Comments
& Drawing objects

| |Untitled1 (active) o)
i:'igure 22: Navig_ait6r dialog in Calc
The Navigator categorizes and groups spreadsheet objects which you can click on to move quickly

to that object. If an indicator (plus sign or triangle, dependent on computer setup) appears next to a
category, at least one object in this category exists. To open a category and see the list of items,
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click on the indicator. When a category is showing the list of objects in it, double-click on an object
to jump directly to that object’s location in the spreadsheet.

To open the Navigator, do one of the following:

Press the F5 key.
Go to View > Navigator on the Menu bar.
Click the Navigator icon in the Sidebar.

By default, the Navigator opens in the Sidebar.

The controls and tools available in the Navigator are as follows:

:@’_
- =
=

Column — type a column letter and press the Enter key to reposition the cell cursor to the
specified column in the same row.

Row — type a row number and press the Enter key to reposition the cell cursor to the
specified row in the same column.

Data Range ! - specifies the current data range denoted by the position of the cell
cursor.

Start — moves the cursor to the cell at the beginning of the current data range, which
you can highlight using the Data Range icon.

End — moves the cursor to the cell at the end of the current data range, which you can
highlight using the Data Range icon.

Toggle — toggles the contents view. Only the selected category and its objects are
displayed. Click the icon again to restore all elements for viewing.

i
Scenarios 22 _ displays all available scenarios. See Chapter 9, Data Analysis, for more
information about scenarios. Double-click a name to apply that scenario and the result is
shown in the sheet. If the Navigator displays scenarios, you can access the following
commands when you right-click a scenario entry:

— Delete — deletes the selected scenario.
— Properties — opens the Edit scenario dialog, where you can edit the scenario properties.

Drag Mode Be ™ _ opens a submenu for selecting which action is performed when
dragging and dropping an object from the Navigator into a document. Depending on the
mode you select, the icon indicates whether a hyperlink, a link, or a copy is created.

— Insert as Hyperlink — hyperlinks the entire item.

— Insert as Link — links the copied item to the original item so that when the original item is
changed, that change will be reflected in the current document.

— Insert as Copy — inserts a copy of the selected item.
Tip

Ranges, scenarios, pictures, and other objects are much easier to find if you have
given them informative names when creating them, instead of keeping the default Calc
names, for example Scenario 1, Image 1, Image 2, Object 1, and so on. These default
names may not correspond to the position of the object in the document.

Using the Navigator | 37



Using document properties

To open the Properties dialog for a document, go to File > Properties on the Menu bar. The
Properties dialog provides information about the spreadsheet and allows you to set some of its
properties. The dialog is shown in Figure 23 and its tabs are described below.

Properties of "Sales-List" ey

General Description Custorn Properties Security Font Statistics

Sales-List.ods Change Password

Type: OpenDocument Spreadsheet
Location: D:
Size: 34 KB (34,785 Bytes)
Created:  06/16/2020, 11:28:20, Steve Fanning
Maodified:
Termplate:
Digitally signed: Digital Signatures...
Last printed:

Total editing tirne:  00:00:00
Revision number: 1

Applyuserdata 00000 [

Save preview image with this document

Help Beset oK Cancel

Figure 23: Properties dialog, General tab

General

Contains basic information about the current file.

The text box at the top of the dialog displays the file name.

Change Password — opens a dialog to change the password. It is only active if a password
has been set for the file.

Type — displays the file type of the current document.

Location — displays the path and the name of the directory where the file is stored.
Size — displays the size of the current document in bytes.

Created — displays the date, time, and author when the file was first saved.

Modified — displays the date, time, and author when the file was last saved in a LibreOffice
file format.

Template — displays the template that was used to create the file.

Digitally signed — displays the date and time when the file was last signed as well as the
name of the author who signed the document.
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» Digital Signatures — opens the Digital Signatures dialog where you can manage digital
signatures for the current document.

» Last printed — displays the date, time, and user name when the file was last printed.

* Total editing time — displays the amount of time that the file has been open for editing
since the file was created. The editing time is updated when you save the file.

* Revision number — displays the number of times that the file has been saved.

* Apply user data — saves the full name of the user with the file. You can edit the name by
going to Tools > Options > LibreOffice > User Data on the Menu bar.

» Save preview image with this document — saves a thumbnail.png inside the document.
These images may be used by a file manager under certain conditions.

* Reset Properties — resets the editing time to zero, the creation date to the current date and
time, and the version number to 1. The modification and printing dates are also deleted.

Description
Contains optional editable descriptive information about the spreadsheet.

* Title — enter a title for the spreadsheet.

* Subject — enter a subject for the spreadsheet. You can use a subject to group documents
with similar contents.

+ Keywords — enter the words that you want to use to index the content of the spreadsheet.
Keywords must be separated by commas. A keyword can contain white space characters or
semicolons.

« Comments — enter comments to help identify the spreadsheet.

Custom Properties

Use this page to assign custom information fields to the spreadsheet. In a new spreadsheet, this
page may be blank. If the new spreadsheet is based on a template, this page may contain fields.
You can change the name, type, and contents of each row. The information in the fields will be
exported as metadata to other file formats.

Click Add Property to add a new custom property. Click Reset to delete all custom properties.

CMIS Properties

Used for spreadsheets stored on remote servers. See the Help or the Getting Started Guide for
more information.

Security
Enables two password-protected security options.

* Open file read-only — select to allow this document to be opened only in read-only mode.
This file sharing option protects the document against accidental changes. It is still possible
to edit a copy of the document and save that copy with the same name as the original.

* Record changes — select to require that all changes be recorded. To protect the recording
state with a password, click Protect and enter a password. This is similar to Edit > Track
Changes > Record on the Menu bar. However, while other users of this document can
apply their changes, they cannot disable change recording without knowing the password.

* Protect or Unprotect — protects the change recording state with a password. If change
recording is protected for the current document, the button is named Unprotect. Click
Unprotect and type the correct password to disable the protection.
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Font

When Embed fonts in the document is selected, any fonts used in the spreadsheet will be
embedded into the document when it is saved. This may be useful if you are creating a PDF of the
spreadsheet and want to control how it will look on other computer systems.

Only embed fonts that are used in documents — If fonts have been defined for the spreadsheet
(for example, in the template), but have not been used, select this option to not embed them.

Font scripts to embed — You can choose which types of fonts are embedded: Latin, Asian,
Complex. See the Getting Started Guide for more information.

Statistics

Displays statistics for the current file: the number of sheets, cells, pages, and formula groups.
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Introduction

You can enter data into Calc in several ways: using the keyboard, dragging and dropping, the Fill
tool, and selection lists. Calc also provides the ability to enter data into multiple sheets of the same
spreadsheet at the same time. After entering data, you can format and display it in various ways.

Entering data

Most data entry in Calc can be done using the keyboard.

Numbers

Click in the cell and type the number using the number keys on either the main keyboard or the
numeric keypad.

Negative numbers

To enter a negative number, either type a minus (-) sign in front of the number or enclose the
number in parentheses (), for example (1234). The result for both methods of entry is the same; for
example, —1234.

Leading zeroes

If a number is entered with leading zeroes, for example 01481, by default Calc will automatically
drop the leading zero. To retain a minimum number of characters in a cell when entering numbers
and retain the number format, for example 1234 and 0012, use this method to add leading zeroes:

1) With the cell selected, right-click on the cell and select Format Cells from the context
menu, or go to Format > Cells on the Menu bar, or use the keyboard shortcut Ctr/+1 to
open the Format Cells dialog (Figure 24).

2) Make sure the Numbers tab is selected, then select Number in the Category list.

3) In Options > Leading zeroes, enter the minimum number of characters required. For
example, for four characters, enter 4. Any number less than four characters will then have
leading zeroes added, for example 12 becomes 0012.

4) Click OK. The number entered retains its number format and any formula used in the
spreadsheet will treat the entry as a number in formula functions.

To format numbers with only decimal places, but without a leading zero, follow steps 1
and 2 above, then in the Format code box type a . (period or full stop) followed by ?
(question marks) to represent the number of decimal places required. For example, for
3 decimal places, type .??? and click OK. Any number with only decimal places will
then have no leading zero, for example 0.01856 becomes .019.
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Format Cells iy

Mumbers Font Font Effects Alignment Borders Background Cell Protection

Category Format L
User-defined -1235
Percent -1,235
Currency -1,234.57
Date -1,234.57
Time (1,233)
Scientific (1,234.57)
Fraction
Boolean Value
Text -1234.56789012346
Options
Decimal places: = [ Negative numbers red
Leading zeroes: |1 = [ Thousands separator
Format code
General
User-defined

Figure 24: Format Cells dialog — Numbers tab

Numbers as text
Numbers can also be converted into text as follows:
1) With the cell selected, open the Format Cells dialog (Figure 24).
2) Make sure the Numbers tab is selected, then select Text from the Category list.

3) Click OK. The number is converted to text and, by default, is left-aligned. You can change
the formatting and alignment of any text numbers just as you would with normal text.

Text

Click in a cell and type the text. The text is left-aligned by default. Cells can contain several lines of
text. If you want to use paragraphs, press Ctrl+Enter to create another paragraph.

On the Formula Bar, you can extend the Input line if you are entering several lines of text. Click on

the Expand Formula Bar icon d located on the right of the Formula Bar and the Input line
becomes multi-line, as shown in Figure 25. Click the Expand Formula Bar icon again to return to
a single input line.
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Figure 25: Extended Input line on Formula Bar

Date and time

Select the cell and type the date or time. You can separate the date elements with a slash (/) or a
hyphen (-) or use text, for example 10 Oct 2012. The date format automatically changes to the
selected format used by Calc.

£7] Note

Tools > Options > Language Settings > Languages > Language Of > Date
acceptance patterns defines the date patterns that will be recognized by Calc. In
addition, every locale accepts input in an ISO 8601 Y-M-D pattern.

When you enter a time, separate time elements with colons, for example 10:43:45. The time format
automatically changes to the selected format used by Calc.

To change the date or time format used by Calc:

1) With the cell selected, open the Format Cells dialog (Figure 24).

2) Make sure the Numbers tab is selected, then select Date or Time from the Category list.
3) Select the date or time format you want to use from the Format list.

4) Click OK to save the changes and close the dialog.

£7] Note

The date format will be influenced by the system or worksheet language settings.

Special characters

A special character is a character not normally found on a standard keyboard; for example, © % a&
¢ A 6 g C. To insert a special character:

1) Place the cursor where you want the character to appear.

2) Go to Insert > Special Character on the Menu bar to open the Special Characters dialog
(Figure 26).

3) From the grid of characters, select the required character. The last character selected is
shown on the right of the Special Characters dialog along with its numerical code.

4) Any recently inserted characters are shown below the grid of characters and can be
selected in the same way as any other character in the dialog.

5) At the bottom of the dialog there is provision for building a small collection of Favorite
Characters. To add a new character to the collection, select the required character and click
the Add to Favorites button. To remove an existing character from the collection, select
the character and click the Remove from Favorites button.

6) Click Insert to close the dialog and the special character is inserted into the selected cell.
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Recent Characters:

Favorite Characters:

aoaEEaaaaann

Figure 26: Special Characters dialog

‘::‘ Tip

You can quickly insert one of your recent or favorite special characters by clicking the

Insert Special Characters icon Q ¥ on the Standard toolbar and selecting the
required character from the drop-down. Click More Characters on this drop-down to
open the Special Characters dialog (Figure 26).

£7] Note

Different fonts include different special characters. If you do not find a particular
special character you want, try changing the Font and Subset selections.

AutoCorrect options

Calc automatically applies many changes during data input using AutoCorrect, unless you have
deactivated any AutoCorrect changes. You can also undo any AutoCorrect changes by using the
keyboard shortcut Ctrl+Z or manually by going back to the change and replacing the autocorrection
with what you want to actually see.

To change the AutoCorrect options, go to Tools > AutoCorrect Options on the Menu bar to open
the AutoCorrect dialog (Figure 27).
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Figure 27: AutoCorrect dialog
Replace
Edit the replacement table for automatically correcting or replacing words or abbreviations.

Exceptions
Specify the abbreviations or letter combinations that you do not want corrected automatically.

Options
Select the options for automatically correcting errors as you type.

Localized Options
Specify the AutoCorrect options for quotation marks and for options that are specific to the
language of the text.

Reset
Reset modified values back to their previous values.

Inserting dashes

Calc provides text shortcuts so that you can quickly insert dashes into a cell and these shortcuts
are shown in Table 2.

Table 2: Inserting dashes

Text that you type Result

A- B (A, space, hyphen, space, B) A - B (A, space, en-dash, space, B)
A -- B (A, space, hyphen, hyphen, space, B) A—B (A, space, en-dash, space, B)
A--B (A, hyphen, hyphen, B) A—B (A, em-dash, B)

A-B (A, hyphen, B) A-B (unchanged)

A-B (A, space, hyphen, B) A -B (unchanged)

A --B (A, space, hyphen, hyphen, B) A-B (A, space, en-dash, B)
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Speeding up data entry

Entering data into a spreadsheet can be very labor-intensive, but Calc provides tools for removing
some of the drudgery from input. These tools include drag and drop to move or copy contents of
one cell to another using a mouse, an Autolnput tool, the Fill tool, and selection lists.

The Fill tool and selection lists automate input of repetitive material into cells. Calc also has the
ability to input information into multiple sheets of the same spreadsheet at the same time.

Autolnput tool

The Autolnput function in Calc automatically completes entries, based on other entries in the same
column. The column is scanned up to a maximum of 2000 cells or 200 different strings.

When text is highlighted in a cell, Autolnput can be used as follows:

1) To accept the completion, press Enter or F2 or click the mouse button.

2) To view more completions that start with the same letters, use the key combinations
Ctrl+Tab to scroll forward, or Ctrl+Shift+Tab to scroll backward.

3) To see a list of all available Autolnput text items for the current column, use the keyboard
combination Alt+Down Arrow.

When typing formulas using characters that match function names, a Help tip will appear listing the
functions used in the Function Wizard that start with matching characters.

Autolnput ignores the case sensitivity of any data you enter. If, for example, you have written
"Total" in a cell, you cannot then enter "total" in another cell of the same column without first
deactivating Autolnput.

By default, Autolnput is activated in Calc. To turn it off, go to Tools on the Menu bar and deselect
Autolnput.

Fill tool

You can use the Fill tool in Calc to duplicate existing content or create a series in a range of cells in
the spreadsheet as shown by the examples in Figure 28.

A:AD e A2AD w
Duplicate Fill Series Fill
Qriginal 1234
Criginal 1235
Criginal 1236
Criginal 1237
Criginal 1238
Criginal 1239
Criginal : 1240

Figure 28: Examples of using the Fill tool

1) Select the cell containing the contents you want to copy or start the series from.

2) Drag the cursor in any direction or hold down the Shift key and click in the last cell you want
to fill.

3) Go to Sheet > Fill Cells on the Menu bar and select the direction in which you want to copy
or create data (Down, Right, Up, Left, Sheets, Series, or Random Number). A menu
option will be grayed out if it is not available.
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Alternatively, you can use a shortcut to fill cells:

1) Select the cell containing the contents you want to copy or start the series from.
2) Move the cursor over the small selection handle in the bottom right corner of the selected

cell. The cursor will change shape.

3) Click and drag in the direction you want the cells to be filled, vertical or horizontal. If the
original cell contained text, then the text will automatically be copied. If the original cell
contained a number, a series will be created.

A Caution

When you are selecting cells so you can use the Fill tool, make sure that none of the
cells contain data, except for the cell data you want to use. When you use the Fill tool,
any data contained in selected cells is overwritten.

Using a fill series

When you select a series fill from Sheet > Fill Cells > Fill Series on the Menu bar, the Fill Series
dialog (Figure 29) opens. Here you can select the type of series you want or create your own list.

Direction

Determines the direction of series creation.

— Down — creates a downward series in the selected cell range for the column using the
defined increment to the end value.

— Right — creates a series running from left to right within the selected cell range using the
defined increment to the end value.

— Up — creates an upward series in the selected cell range of the column using the
defined increment to the end value.

— Left — creates a series running from right to left within the selected cell range using the
defined increment to the end value.

Fill Series

Direction

Start values
End value:

Increment:

Help

Series Type Time Unit
(®) Linear Day
O Growth Weekda
O Date Month
l:::'ﬂutchiII Year
(0] 4 Cancel

X

Figure 29: Fill Series dialog

Series Type

Defines the series type. These are:

— Linear — creates a linear number series using the defined increment and end value.

— Growth — creates a growth series using the defined increment and end value.
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— Date — creates a date series using the defined increment and end date.

— AutoFill - forms a series directly in the sheet. The AutoFill function takes account of
customized lists. For example, by entering January in the first cell, the series is
completed using the list defined in Tools > Options > LibreOffice Calc > Sort Lists.
AutoFill tries to complete a value series by using a defined pattern. For example, a
numerical series using 1,3,5 is automatically completed with 7,9,11,13; a date and time
series using 01.01.99 and 15.01.99, an interval of fourteen days is used.

Time Unit

In this area you specify the desired unit of time. This area is only active if the Date option has
been selected in Series Type. These are:

— Day — use the Date series type and this option to create a series using seven days.
— Weekday — use the Date series type and this option to create a series of five day sets.

— Month — use the Date series type and this option to form a series from the names or
abbreviations of the months.

— Year — use the Date series type and this option to create a series of years.

Start value

Determines the start value for the series. Use numbers, dates or times.

End value

Determines the end value for the series. Use numbers, dates or times.

Increment

Determines the value by which the series of the selected type increases by each step.
Entries can only be made if the linear, growth or date series types have been selected.

Defining a fill series
To define your own fill series:

1)

2)
3)
4)
5)

Go to Tools > Options > LibreOffice Calc > Sort Lists to open the Sort Lists dialog
(Figure 30). This dialog shows any previously defined series in the Lists box on the left and
the contents of the highlighted list in the Entries box.

Click New and the Entries box is cleared.

Type the series for the new list in the Entries box (one entry per line) (Figure 31).
Click Add and the new list will now appear in the Lists box.

Click OK to save the new list and close the dialog.
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Load/Save
Language Settings
= LibreOffice Calc
General
Defaults
View
Calculate
Formula
Sort Lists

Changes
Compatibility
Grid
Print
LibreOffice Base
Charts
Internet

Options - LibreQffice Calc - Sort Lists

Lists

Sun,Maon, Tue Wed, Thu, Fri,5at
Sunday,Monday, Tuesday, Wednesc
Jan,Feb,Mar, Apr,May,Jun, Jul Aug,?
January,February, March, April,May,
Sunday,Monday, Tuesday, Wednesg

Missan,lyar,Sivan, Tarmrmuz, Av, Elul, T

Help

Copy list from:  |55heet],5C54:5C56

Entries New
Sun
Mon i
Tue Add
Wed
Thu Delete
Fri
Sat
Copy
Apply oK Cancel

Figure 30: Sort Lists dialog

Lists

Entries

Sun,Mon, Tug, Wed, Thu,Fri, 5at
Sunday,Meonday, Tuesday, Wednesday, Th
Jan,Feb, Mar, Apr,May,Jun,Jul Aug,5ep, Oc MNT
January, February,March, April, May, June, )
ACT,NSW,NT,QLD, 54, TAS, VIC WA '

ACT
MSW

aLp
54
TAS
WIC
Wa

Figure 31: Creating a new sort list

Selection lists

Add

Delete

Selection lists are available only for text and are limited to using only text that has already been

entered in the same column.

1) Select a blank cell in a column that contains cells with text entries.

2) Right-click and select Selection List from the context menu, or use the keyboard shortcut

Alt+1. A drop-down list appears listing any cell in the same column that either has at least
one text character or whose format is defined as text.

3) Click on the text entry you require and it is entered into the selected cell.
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Merging and splitting cells

Merging

You can select contiguous cells and merge them into one as follows:

1)
2)

3)

4)

Select the range of contiguous cells you want merge.

Right-click on the selected cells and select Merge Cells from the context menu, or go to
Format > Merge Cells > Merge Cells or Merge and Center Cells on the Menu bar, or
click on the Merge and Center Cells icon = on the Formatting toolbar. Using Merge and
Center Cells will center align any contents in the cells.

If the cells contain any data, a small dialog (Figure 32) opens, showing choices for moving
or hiding data in the hidden cells.

Make your selection and click OK.

Merge Cells *

Some cells are not empty.

@] Move the contents of the hidden cells into the first cell

112]|—[1 2]

(®) Keep the contents of the hidden cellsi

(112 ]—[1 2]

O Empty the contents of the hidden cells

(12 ]—[1 2]
Help oK iCancel

Figure 32: Merge choices for non-empty cells

A Caution

Merging cells can lead to calculation errors in formulas used in the spreadsheet.

Splitting

You can reverse or split only a cell that was created from several cells by merging.

1)
2)

3)

Select a merged cell.

Go to Format > Merge Cells > Split Cells on the Menu bar, or right-click ap_g select Split
Cells from the context menu, or click on the Merge and Center Cells icon = on the
Formatting toolbar.

Any data in the cell will remain in the first cell. If the hidden cells did have any contents
before the cells were merged, then you may have to manually move the contents in to the
correct cell.

Sharing content between sheets

You might want to enter the same information in the same cell on multiple sheets, for example to
set up standard listings for a group of individuals or organizations. Instead of entering the list on
each sheet individually, you can enter the information in several sheets at the same time.
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Selected sheets

Help QK Cancel

Figure 33: Select Sheets dialog

1) Go to Edit > Select > Select Sheets on the Menu bar to open the Select Sheets dialog
(Figure 33).

2) Select the individual sheets where you want the information to be repeated.
3) Click OK to select the sheets and the sheet tabs will change color.

4) Enter the information in the cells on the sheet where you want the information to first
appear and the information will be repeated in the selected sheets.

5) Deselect the sheets when you have finished entering the information that you want
repeated in the sheets.

A Caution

This technique automatically overwrites, without any warning, any information that is
already in the cells on the selected sheets. Make sure you deselect the additional
sheets when you have finished entering the information to be repeated before
continuing to enter data into the spreadsheet.

Validating cell contents

When creating spreadsheets for other people to use, you may want to make sure they enter data
that is valid or appropriate for the cell. You can also use validation in your own work as a guide to
entering data that is either complex or rarely used.

Fill series and selection lists can handle some types of data, but are limited to predefined
information. For example, a cell may require a date or a whole number with no alphabetic
characters or decimal points, or a cell may not be left empty.

Depending on how validation is set up, it can also define the range of contents that can be entered,
provide help messages explaining the content rules set up for the cell and what users should do
when they enter invalid content. You can also set the cell to refuse invalid content, accept it with a
warning, or start a macro when an error is entered.
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Defining validation

To validate any new data entered into a cell:

1) Select a cell and go to Data > Validity on the Menu bar to open the Validity dialog.

2) Define the type of contents that can be entered in that cell using the options given on the
tabbed pages for Criteria, Input Help, and Error Alert. The options are explained below
Figure 34.

Validity X

Criteria Input Help Error Alert

Allow:
Allow empty cells
Show selection [ist
[ Sort entries ascending
Source =

Figure 34: Validity dialog — Criteria page

Criteria options

Specify the validation rules for the selected cells using the Criteria tab in the Validity dialog as
shown in Figure 34. For example, you can define criteria such as numbers between 1 and 10, or
texts that are no more than 20 characters.

The options available on the Criteria tab will depend on what has been selected in the Allow drop-

down list.

* Allow - select a validation option for the selected cells from the drop-down list.

All values — no limitation.
Whole Numbers — only whole numbers allowed.
Decimal — all numbers correspond to decimal format.

Date — all numbers correspond to date format. The entered values are formatted the
next time the dialog is called up.

Time — all numbers correspond to time format. The entered values are formatted the
next time the dialog is called up.

Cell range — allow only values that are given in a cell range. The cell range can be
specified explicitly, or as a named database range, or as a named range. The range
may consist of one column or one row of cells. If you specify a range of columns and
rows, only the first column is used.

List — allow only values or strings specified in a list. Strings and values can be mixed.
Numbers evaluate to their value, so if you enter the number 1 in the list, the entry 100%
is also valid.

Text length — allow entries whose length corresponds to the number of characters that
have been set.

Custom — allow entries that correspond to a formula entered in the Formula box.
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* Allow empty cells — in conjunction with Tools > Detective > Mark Invalid Data, this
defines that blank cells are shown as invalid data (disabled) or not shown (enabled).

* Show selection list — shows a list of all valid strings or values to select from. The list can
also be opened by selecting the cell and pressing Ctr/+D.

* Sort entries ascending — sorts the selection list in ascending order and filters duplicates
from the list. If not checked, the order from the data source is taken.

* Source — enter the cell range that contains the valid values or text.
* Entries — enter the entries that will be valid values or text strings.

» Data — select the comparative operator that you want to use from the drop-down list. The
available operators depend on what you have selected in the Data drop-down list. For
example, if you select valid range, the Minimum and Maximum input boxes replace the
Value box.

* Value — enter the value for the data validation option that you selected in the Data drop-
down list.

* Minimum — enter the minimum value for the data validation option that you selected in the
Data drop-down list.

* Maximum — enter the maximum value for the data validation option that you selected in the
Data drop-down list.

Input Help options
Enter the message to be displayed when the cell or cell range is selected in the spreadsheet
(Figure 35).

* Show input help when cell is selected — displays the message that you enter in the Title
and Input help boxes when the cell or cell range is selected in the sheet. If you enter text in
the Title and Input help boxes and then deselect this option, the text will be lost.

» Title — enter the title to be displayed when the cell or cell range is selected.
* Input help — enter the message to be displayed when the cell or cell range is selected.

Validity X

Criteria Input Help Error Alert

Shaw input help when cell is selected:

Contents
Title:

Input help:

Figure 35: Validity dialog — Input Help tab

Error Alert options

Define the error message that is displayed when invalid data is entered in a cell (Figure 36).
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Criteria Input Help Error Alert

Lhow error message when invalid values are entered!

Contents

Action: Stop o EBrowse..,

Title:

Error message:

Figure 36: Validity dialog — Error Alert tab

Show error message when invalid values are entered — when selected, displays the
error message that you enter in the Contents area when invalid data is entered in a cell.

Action — select the action that you want to occur when invalid data is entered in a cell.

— Stop — rejects the invalid entry and displays a dialog that you have to close by clicking
OK.

— Warning and Information — displays a dialog that can be closed by clicking OK or
Cancel. The invalid entry is only rejected when you click Cancel.

— Macro — activates the Browse button to open the Macro Selector dialog where you can
select a macro that is executed when invalid data is entered in a cell. The macro is
executed after the error message is displayed.

Title — enter the title of the macro or the error message that you want to display when
invalid data is entered in a cell.

Error message — enter the message that you want to display when invalid data is entered
in a cell.

Calc Detective

The Detective is a tool within Calc that you can use to locate any cells in a spreadsheet that
contain invalid data if the cells are set to accept invalid data with a warning.

1)

2)
3)

Go to Tools > Detective > Mark Invalid Data on the Menu bar to locate any cells
containing invalid data. The Detective function marks any cells containing invalid data.

Correct the data so that it becomes valid.

Go to Tools > Detective > Remove All Traces on the Menu bar again and any cells that
were previously marked as containing invalid data have the invalid data mark removed.

£7] Note

A validity rule is considered part of the format for a cell. If you select Delete all from
the Delete Contents dialog (Figure 38), then it is removed. If you want to copy a
validity rule with the rest of the cell, use Edit > Paste Special > Paste Special to open
the Paste Special dialog (Figure 39), then select Paste All or Formats and click OK.
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Editing data

Deleting data

Deleting cell data only

Data can be deleted from a cell without deleting any of the cell formatting. Select a cell or a range
of cells and then press the Delete key.

Delete Cells

This option completely deletes selected cells, columns, or rows. The cells below or to the right of
the deleted cells will fill the space.

1) Select a cell or a range of cells.

2) Press the Ctrl+— keys, or select Sheet > Delete Cells on the Menu bar, or right-click inside
the selected cells and choose Delete from the context menu.

Delete Cells >

() Shift cells left
() Delete entire row(s)
(O) Delete entire column(s)

Help QK Cancel

Figure 37: Delete Cells dialog

3) The Delete Cells dialog (Figure 37) provides four options to specify how sheets are
displayed after deleting cells:

Shift cells up
Fills the space produced by the deleted cells with the cells underneath it.

Shift cells left
Fills the resulting space by the cells to the right of the deleted cells.

Delete entire row(s)
After selecting at least one cell, deletes the entire row from the sheet.

Delete entire column(s)
After selecting at least one cell, deletes the entire column from the sheet.

4) To confirm the selection, click OK.

g Note

The selected delete option is stored and reloaded when the dialog is next called.

Deleting data and formatting
Data and cell formatting can be deleted from a cell at the same time. To do this:
1) Select a cell or a range of cells.

2) Press the Backspace key, or right-click inside the selected cells and choose Clear
Contents from the context menu, or select Sheet > Clear Cells on the Menu bar.
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3) Inthe Delete Contents dialog (Figure 38), choose any of the options or choose Delete All.
Click OK.

Delete Contents X

.........................

Text MNumbers
Eate&time Enrmulas
Comments [ ] Formats
[] Objects

Figure 38: Delete Contents dialog

Replacing data

To completely replace data in a cell and insert new data, select the cell and type in the new data.
The new data will replace the data already contained in the cell and will retain the original
formatting used in the cell.

Alternatively, click in the Input line on the Formula Bar, then double-click on the data to highlight it
completely and type the new data.

Editing data

Sometimes it is necessary to edit the contents of cell without removing all of the data from the cell.
For example, changing the phrase “Sales in Qtr. 2" to “Sales rose in Qtr” can be done as follows.

Using the keyboard
1) Click in the cell to select it.
2) Press the F2 key and the cursor is placed at the end of the cell.

3) Press the Backspace key to delete any data up to the point where you want to enter new
data.

4) Alternatively, use the keyboard arrow keys to reposition the cursor where you want to start
entering the new data in the cell, then press the Delete key or Backspace key to delete any
unwanted data before typing the new data.

5) When you have finished editing, press the Enter key to save the changes.
rf Note

Each time you select a cell, the contents are displayed in the Input line on the Formula
Bar. Using the Input line may be easier when editing data.

Using the mouse
1) Double-click on the cell to select it and place the cursor in the cell for editing.
2) Reposition the cursor to where you want to start editing the data in the cell.

3) Alternatively, single-click to select the cell, then move the cursor to the Input line on the
Formula Bar and click at the position where you want to start editing the data in the cell.
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4)  When you have finished, click away from the cell to deselect it and the editing changes are
saved.

Paste Special function

You can use the Paste Special function to paste into another cell selected parts of the data in the
original cell or cell range, for example its format or the result of its formula.

Paste Special dialog
1) Select a cell or a cell range.

2) Go to Edit > Copy on the Menu bar, or right-click and select Copy from the context menu,
or press Ctrl+C, or click the Copy icon on the Standard toolbar.

3) Select the target cell or cell range.

4) Go to Edit > Paste Special > Paste Special from the Menu bar, or use the keyboard
shortcut Ctrl+Shift+V, or right-click and select Paste Special > Paste Special from the
context menu to open the Paste Special dialog (Figure 39).

5) Select the options for Selection, Operations, Options and Shift Cells. The Paste Special
options are explained below.

6) Click OK to paste the data into to the target cell or range of cells and close the dialog.

Paste Special x
$0 X %5
Selection Operations
[ Paste all @® None
Text O Add
Mumbers O Subtract
[ Date & time O Multiply
DEDrmuIas @] Divide
] Comments
] Formats
L] Objects
Options Shift Cells
[] Skip empty cells (®) Don't shift
] Transpose )] Down
] Link O Right
Help (] 4 Cancel

Figure 39: Paste Special dialog

Paste Special options
» Selection — select a format for the clipboard contents that you want to paste.

— Paste all — pastes all cell contents, comments, formats, and objects into the current
document.

— Text — pastes cells containing text.
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Numbers — pastes cells containing numbers.
Date & time — pastes cells containing date and time values.
Formulas — pastes cells containing formulas.

Comments — pastes comments that are attached to cells. If you want to add the
comments to the existing cell content, select the Add operation.

Formats — pastes cell format attributes.

Objects — pastes objects contained within the selected cell range. These can be OLE
objects, chart objects, or drawing objects.

* Operations — select the operation to apply when you paste cells into the sheet.

None — does not apply an operation when you insert the cell range from the clipboard.
The contents of the clipboard will replace existing cell contents.

Add — adds the values in the clipboard cells to the values in the target cells. Also, if the
clipboard only contains comments, adds the comments to the target cells.

Subtract — subtracts the values in the clipboard cells from the values in the target cells.
Multiply — multiplies the values in the clipboard cells with the values in the target cells.
Divide — divides the values in the target cells by the values in the clipboard cells.

* Options — sets the paste options for the clipboard contents.

Skip empty cells — empty cells from the clipboard do not replace target cells. If you use
this option in conjunction with the Multiply or the Divide operation, the operation is not
applied to the target cell of an empty cell in the clipboard. If you select a mathematical
operation and deselect the Skip empty cells, empty cells in the clipboard are treated as
zeroes. For example, if you apply the Multiply operation, the target cells are filled with
zeroes.

Transpose — the rows of the range in the clipboard are pasted to become columns of
the output range. The columns of the range in the clipboard are pasted to become rows.

Link — inserts the cell range as a link, so that changes made to the cells in the source
file are updated in the target file. To ensure that changes made to empty cells in the
source file are updated in the target file, ensure that Paste All is also selected. You can
also link sheets within the same spreadsheet. When you link to other files, a DDE link is
automatically created. A DDE link is inserted as a matrix formula and can only be
modified as a whole.

* Shift cells — sets the shift options for the target cells when the clipboard content is inserted.

Don't shift — inserted cells replace the target cells.
Down — target cells are shifted downward when you insert cells from the clipboard.
Right — target cells are shifted to the right when you insert cells from the clipboard.

Paste Only options
If you only want to copy text, numbers, or formulas to the target cell or cell range:

1) Select the source cell or cell range and copy the data.
2) Select the target cell or cell range.

3) Right-click on the target cell or cell range and select Paste Special from the context menu,
then select Text, Number, or Formula.

Insert cell fields

You can insert a field linked to the date, sheet name, or document name in a cell.
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1) Select a cell and double-click to activate edit mode.

2) Right-click and select Insert Field > Date or Sheet Name or Document Title from the
context menu.

Z Note

The Insert Field > Document Title command inserts the name of the spreadsheet
and not the title defined in the Description tab in the Properties dialog for the file.

':@:‘ Tip

The fields are refreshed when the spreadsheet is saved or recalculated when using
the Ctrl+Shift+F9 shortcut.

Formatting data

Z Note

All the settings discussed in this section can also be set as a part of the cell style. See
Chapter 4, Using Styles and Templates, for more information.

You can format the data in Calc in several ways, either defined as part of a cell style so that it is
automatically applied, or applied manually to the cell. For more control and extra options, select a
cell or cell range and use the Format Cells dialog. All of the format options are discussed below.

Multiple lines of text

Multiple lines of text can be entered into a single cell using automatic wrapping or manual line
breaks. Each method is useful for different situations.

Automatic wrapping
To automatically wrap multiple lines of text in a cell:

1) Select a cell or cell range.

2) Right-click and select Format Cells from the context menu, or go to Format > Cells on the
Menu bar, or press Ctrl+1 to open the Format Cells dialog.

3) Click on the Alignment tab (Figure 40).
4) Under Properties, select Wrap text automatically and click OK.

Manual line breaks

To insert a manual line break while typing in a cell, press Ctrl+Enter. When editing text, double-
click the cell, then reposition the cursor to where you want the line break.

When a manual line break is entered, the cell width does not change and the text may still overlap
the end of the cell. You have to change the cell width manually or reposition the line break so that
the text does not overlap the end of the cell.
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Figure 40: Format Cells dialog — Alignment tab

Shrinking text to fit a cell
The font size of the data in a cell can automatically adjust to fit inside cell borders.

1) Select a cell or cell range.

2) Right-click on the selection and select Format Cells from the context menu, or go to
Format > Cells on the Menu bar, or press Ctrl+1 to open the Format Cells dialog.

3) Click on the Alignment tab (Figure 40).
4) Under Properties, select Shrink to fit cell size and click OK.

Formatting nhumbers

Several different number formats can be applied to cells by using icons on the Formatting toolbar
(highlighted in Figure 41). Select the cell, then click the relevant icon to change the number format.

For more control or to select other number formats, use the Numbers tab of the Format Cells
dialog (Figure 24 on page 43):

* Apply any of the data types in the Category list to the data.
* Control the number of decimal places and leading zeroes in Options.
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* Enter a custom format code. This is a very powerful facility that is detailed in the Number
Format Codes page of the Help.

» The Language setting controls the local settings for the different formats such as the date
format and currency symbol.

Formatting

liberstionSens v [0 v B ] U A <~ ; = + J [5-%00 _UQ._C'(.‘]' € \H-=-L-18B-
Figure 41: Number icons on Formatting toolbar

Formatting fonts
To select a font and format it for use in a cell:

1) Select a cell or cell range.

2) Click the small triangle on the right of the Font Name box on the Formatting toolbar
(highlighted in Figure 42) and select a font from the drop-down list. The font can also be
changed using the Font tab on the Format Cells dialog.

3) Click on the small triangle on the right of the Font Size box on the Formatting toolbar and
select a font size from the drop-down list. The font size can also be changed using the Font
tab on the Format Cells dialog.

4) To change the character format, click on the Bold, /talic, or Underline icons.

5) To change the paragraph alignment of the font, click on one of the alignment icons (Align
Left, Align Center, and Align Right). The Format > Aligh menu also provides these
options, along with a Justified option.

Farmatting
LiberstionSans |~ 10 ~ | B J' U ﬂ"' -

Figure 42: Font Name and Size on Formatting toolbar

Z Note

To specify the language used in the cell, open the Font tab on the Format Cells dialog.
Changing language in a cell allows different languages to exist within the same
document. For more changes to font characteristics, see “Font effects” below.

‘:@:‘ Tip

To choose whether to show the font names in their font or in plain text, go to Tools >
Options > LibreOffice > View and select or deselect the Show preview of fonts
option in the Font Lists section. For more information, see Chapter 14, Setting Up and
Customizing.

Font effects

1) Select a cell or cell range.

2) Right-click and select Format Cells from the context menu, or go to Format > Cells on the
Menu bar, or press Ctrl+1 to open the Format Cells dialog.

3) Click on the Font Effects tab (Figure 43).

4) Select the font effect you want to use from the options available. The options available are
described in Chapter 4, Using Styles and Templates.

5) Click OK to apply the font effects and close the dialog.
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Figure 43: Format Cells dialog — Font Effects tab

Any font effect changes are applied to the current selection, or to the entire word that contains the
cursor, or to any new text that you type.

Text direction

To change the text direction within a cell, use the Alignment tab on the Format Cells dialog (Figure
40 on page 61).

1) On the Alignment page of the Format Cells dialog, select the Reference edge from which to
rotate the text as follows:

— Text Extension From Lower Cell Border — writes the rotated text from the bottom cell
edge outwards.

— Text Extension From Upper Cell Border — writes the rotated text from the top cell edge
outwards.

— Text Extension Inside Cell — writes the rotated text only within the cell.

2) Click on the small indicator at the edge of the Text orientation dial and rotate it until you
reach the required degrees.

3) Alternatively, enter the number of degrees to rotate the text in the Degrees box.
4) Select Vertically stacked to make the text appear vertically in the cell.

Using the icons on the Formatting toolbar
The icons on the Formatting toolbar can be used as follows after the cell has been selected:
» To change the text direction from horizontal (default direction) to vertical, click on the Text

direction from top to bottom icon & .
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* To change text direction from vertical to horizontal (default), click on the Text direction

from left to right icon —.

* To change text direction from left to right, which is the default direction for Western fonts, to
a right to left direction used in some fonts, for example Arabic, then click on the Right-To-

Left icon T . This only works if a font has been used that requires a right to left direction.
* To change text direction back to the default left to right direction used for Western fonts,
click on the Left-To-Right icon | .

£7] Note

The text direction icons can only be made available if the Asian and Complex text
layout options are checked under Tools > Options > Language Settings >
Languages > Default Language for Documents. If it is necessary to make the
buttons visible, right-click on the toolbar and select Visible Buttons from the context
menu, then click on the icon you require and it will be placed on the Formatting toolbar.

Formatting cell borders

To format the borders of a cell or a group of selected cells, you can use the border icons on the
Formatting toolbar to apply the default styles to borders, or the Format Cells dialog for greater
control. See Chapter 4, Using Styles and Templates, for more information on the options.

:{Z Note

Cell border properties apply only to the selected cells and can only be changed if you
are editing those cells. For example, if cell C3 has a top border, that border can only
be removed by selecting C3. It cannot be removed in C2, even though it appears to be
the bottom border for cell C2.

1) Select a cell or a range of cells.

2) Right-click and select Format Cells from the context menu, or go to Format > Cells on the
Menu bar, or press Ctrl+1 to open the Format Cells dialog.

3) On the Borders tab (Figure 44), select the options required.
4) Click OK to close the dialog and save the changes.
Alternatively, use the icons on the Formatting toolbar to apply default styles to borders:
1) Click the Borders icon and select one of the options displayed in the Borders palette.
2) Click the Border Style icon == and select one of the line styles from the Border Style

palette.
3) Click the Border Color icon & and select a color from Border Color palette.
£7 Note

When entering borders with the border icons on the Formatting toolbar, you have two
choices: click the required icon to add a border to the present borders or Shift-click to
add a border and remove the present borders.
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Figure 44: Format Cells dialog — Borders tab

Formatting cell backgrounds

To format the background color for a cell or a group of cells (see Chapter 4, Using Styles and
Templates, for more information):

1)
2)

3)
4)

Select a cell or a range of cells.

Right-click and select Format Cells from the context menu, or go to Format > Cells on the
Menu bar, or press Ctrl+1 to open the Format Cells dialog.

On the Background tab, click the Color button and select a color from the color palette.
Click OK to save the changes and close the dialog.

Alternatively, click on the Background Color icon on the Formatting toolbar and select a color
from the Background Color palette.

AutoFormat of cells and sheets

Using AutoFormat

You can use AutoFormat to format a group of cells.

1)
2)

3)
4)

Select the cells in at least three columns and rows, including column and row headers, that
you want to format.

Go to Format > AutoFormat Styles on the Menu bar to open the AutoFormat dialog
(Figure 45).

Select the type of format and format color from the list.
Select the formatting properties to be included in the AutoFormat function.
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5)

Click OK to apply the changes and close the dialog.

AutoFormat X

Format

EDeFault
Academic Jan Feb Mar Total
Box List Blue
Box List Green
Box List Red
Box List Yellow
Elegant

Add

Delete

Rename

Financial b

Formatting
Mumber format Font Alignment
Borders Pattern AutoFit width and height

Help OK Cancel

Figure 45: AutoFormat dialog

Defining a new AutoFormat

You can define a new AutoFormat so that it becomes available for use in all spreadsheets.

1)

2)
3)

4)
5)

6)

Format the data type, font, font size, cell borders, cell background, and so on for a group of
cells.

Go to Edit > Select All on the Menu bar to select the whole spreadsheet.

Go to Format > AutoFormat Styles to open the AutoFormat dialog. The Add button is now
active.

Click Add.

In the Name box of the Add AutoFormat dialog that opens, type a meaningful name for the
new format and click OK.

The new AutoFormat is now available in the Format list in the AutoFormat dialog. Click OK
to close the AutoFormat dialog.

Using themes

Calc comes with a predefined set of formatting themes that you can apply to spreadsheets. It is not
possible to add new themes to Calc and the predefined styles cannot be modified. You can modify
styles after you apply them to a spreadsheet, but the modified styles are only available for use for
that spreadsheet.

To apply a theme to a spreadsheet:

1)

2)

3)

Go to Format > Spreadsheet Theme on the Menu bar or click the Spreadsheet Theme
icon in the Tools toolbar to open the Theme Selection dialog (Figure 46), which lists the
available themes for the whole spreadsheet.

Select the theme that you want to apply. As soon as you select a theme, the theme styles
are applied to the spreadsheet and are immediately visible.

Click OK.
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Figure 46: Theme Selection dialog

If you wish, you can now use the Styles deck on the Sidebar to modify specific styles. These
modifications do not modify the theme; they only change the appearance of the style in the
spreadsheet you are creating. For more about modifying styles, see Chapter 4, Using Styles and
Templates.

Value highlighting

Value highlighting displays cell contents in different colors depending on the type of content. An
example of value highlighting is shown in Figure 47.

e Text is shown in black.
* Formulas are shown in green.
*  Numbers are shown in blue.

15 01/03/2008 Kurt 7:30) 1745 9.50
16 01/03r2008 Ute 8:30] 18:30 9.25
17 01/06/2008 Brigitte 9:30 17:30] 7.25
18 01/06/2008 Fritz 11:00f 14:30] 3.50

Figure 47: Example of value highlighting

The value highlighting colors override any colors used in formatting. This color change applies only
to the colors seen on a display. When a spreadsheet is printed, the original colors used for
formatting are printed.

Go to View > Value Highlighting on the Menu bar, or use the keyboard shortcut Ctr/+F8 to turn
the function on or off. When value highlighting is switched off, the original formatting colors are
used for display.

You can make value highlighting the default when opening a spreadsheet in Calc, by selecting
Tools > Options > LibreOffice Calc > View > Value highlighting. This default mode for value
highlighting may not be what you want if you are going to format the cells for printing.
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Using conditional formatting

You can set up cell formats to change depending on conditions that you specify. Conditional
formatting is used to highlight data that is outside the specifications that you have set. It is
recommended not to overuse conditional formatting as this could reduce the impact of data that
falls outside those specifications.

See page 71 for an example of how to use conditional formatting.

Note

Conditional formatting depends upon the use of styles and the AutoCalculate feature
must be enabled. If you are not familiar with styles, see Chapter 4, Using Styles and
Templates, for more information.

Setting up conditional formatting

1)
2)

3)

4)
5)

6)

Ensure that AutoCalculate is enabled: Data > Calculate > AutoCalculate.
Select the cells where you want to apply conditional formatting.

Conditicnal Formatting for AT:F2 >

Conditions

Condition 1

|E|:|ual to w |

Apply Styles Accent w Lorem ipsum

Enter a value:

Add Delete Up Down

Cell Range

= |

Bange: |Al:F8

Help oK Cancel

Figure 48: Conditional Formatting dialog — Condition

Go to Format > Conditional > Condition (Figure 48), Color Scale (Figure 49), Data Bar
(Figure 50), Icon Set, or Date on the Menu bar to open the Conditional Formatting dialog.
Any conditions already defined are displayed.

Click Add to create and define a new condition. Repeat this step as necessary.

Select a style from the styles already defined in the Apply Style drop-down list. Repeat this
step as necessary.

Alternatively, select New Style to open the Cell Style dialog (Figure 51) and create a hew
cell style. Repeat this step as necessary.

Click OK to save the conditions and close the dialog. The selected cells are now set to
apply a result using conditional formatting.
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Figure 49: Conditional Formatting dialog — Color Scale
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Figure 50: Conditional Formatting dialog — Data Bar
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Figure 51: Cell Style dialog

Types of conditional formatting

Condition

Condition is the starting point when using conditional formatting. Here you can define what formats
to use to highlight any data in the spreadsheet that falls outside the specifications that you have
defined.

Color Scale

Use color scale to set the background color of cells depending on the values of the data in those
cells. Color scale can only be used when All Cells has been selected for the condition. You can
use either two or three colors for the color scale.

Data Bars

Data bars provide a graphical representation of data in the spreadsheet. The graphical
representation is based on the values of data in a selected range. Click on More Options in the
Conditional Formatting dialog to define how the data bars will look. Data bars can only be used
when All Cells has been selected for the condition.

Icon Sets

Icon sets display an icon next to the data in each selected cell to give a visual representation of
where the cell data falls within the defined range that you set. The icon sets available include
colored arrows, gray arrows, colored flags, colored signs, symbols, bar ratings and quarters. Icon
sets can only be accessed when the Conditional Formatting dialog has been opened and All Cells
has been selected for the condition.

Conditional formatting management
To see all the conditional formatting defined in the spreadsheet and any styles used:

1) Go to Format > Conditional > Manage on the Menu bar to open the Manage Conditional
Formatting dialog (Figure 52).

2) Select a range from the Range list and click Edit to redefine the conditional formatting.

3) Select a range from the Range list and click Remove to delete the conditional formatting.
The deletion is immediate with no confirmation.

4) Select Add to create a new definition of conditional formatting.
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5) Click OK to save the changes and close the dialog.

Manage Conditional Formatting >

Conditional Formats

First Condition

Color5cale

Cell valueis = 5

Add Edit... Bemove

Help QK Cancel

Figure 52: Manage Conditional Formatting dialog

Copying cell styles
To apply the style used for conditional formatting to other cells later:
1) Click one of the cells that has been assigned conditional formatting and copy the cell to the
clipboard.
2) Select the cells that are to receive the same formatting as the copied cell.

3) Go to Edit > Paste Special > Paste Special on the Menu bar to open the Paste Special
dialog (Figure 39 on page 58).

4) Make sure that only Formats is selected and click OK to paste the conditional formatting
into the cell.

Conditional formatting example

With conditional formatting, you can, for example, highlight the totals that exceed the average
value of all totals. If the totals change, the formatting changes correspondingly, without having to
apply other styles manually. It is recommended that the Styles deck on the Sidebar is open and
visible before proceeding.

Defining conditions
1) Select the cells where you want to apply a conditional style.

2) Go to Format > Conditional > Condition, Color Scale, or Data Bar from the Menu bar to
open the Conditional Formatting dialog.

3) Enter the conditions you want to use for conditional formatting.

Generating number values

You may want to give certain values in your tables particular emphasis. For example, in a table of
turnovers, you can show all the values above the average in green and all those below the average
in red. This is possible with conditional formatting.

1) Create atable in which a few different values occur. For your test you can create tables
with any random numbers. In one of the cells enter the formula =RAND(), and you will
obtain a random number between 0 and 1. If you want integers of between 0 and 50, enter
the formula =INT(RAND()*50).

2) Copy the formula to create a row of random numbers.
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3) Click the bottom right corner of the selected cell, and drag to the right and downward until
the desired cell range is selected.

Defining cell styles

The next step is to apply a cell style to all values that represent above-average turnover and one to
cells that are below the average.

1) Right-click in a blank cell and select Format Cells in the context menu to open the Format
Cells dialog.

2) Click the Background tab and select a background color, then click OK.

3) Inthe Conditional Formatting dialog, select New Style from the Apply Style drop-down list
to open the Cell Style dialog.

4) Enter a name of the new style. For this example, name the style Above.

5) Define a second style, click again in a blank cell and proceed as described above. Assign a
different background color to the cell and assign a name. For this example, name the style
Below.

Calculating average

In our particular example, we are calculating the average of the random values. The result is
placed in a cell:

1) Click in a blank cell, for example, J14, and go to Insert > Function on the Menu bar, or
click the Function Wizard icon on the Formula bar to open the Function Wizard dialog.

2) Select AVERAGE from the Function list.
3) Use the cursor to select all your random numbers.
4) Click OK to close the Function Wizard.

Applying cell styles
Now you can apply the conditional formatting to the sheet:
1) Select all cells containing the random numbers.

2) Go to the Format > Conditional > Condition on the Menu bar to open the Conditional
Formatting dialog.

3) Define the condition for each cell as follows: if cell value is less than J14, format with cell
style Below OR if cell value is greater than or equal to J14, format with cell style Above.

Hiding and showing data

In Calc you can hide elements so that they are neither visible on a computer display nor printed
when a spreadsheet is printed. However, hidden elements can still be selected for copying if you
select the elements around them; for example, if column B is hidden, it is copied when you select
columns A and C. When you require a hidden element again, you can reverse the process and
show the element.

Hiding data

Sheets

Right-click on the sheet tab for the sheet to be hidden and select Hide Sheet from the context
menu.

Rows and columns
1) Select a cell in the row or column you want to hide.
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2)
3)

Cells

Go to Format on the Menu bar and select Rows or Columns.

Select Hide from the menu and the row or column can no longer viewed or printed.
Alternatively, right-click on the row or column header and select Hide Rows or Hide
Columns from the context menu.

Hiding individual cells is more complicated. First you need to define the cells as Protected and
Hidden; then you need to protect the sheet.

1) Select the cells you want to hide.
2) Go to Format > Cells on the Menu bar, or right-click and select Format Cells from the
context menu, or press Ctrl+1, to open the Format Cells dialog (Figure 53).
3) Click the Cell Protection tab and select an option for hiding and printing the cells.
4) Click OK to save the changes and close the dialog.
5) Go to Tools > Protect Sheet on the Menu bar to open the Protect Sheet dialog (Figure 54).
6) Select Protect this sheet and the contents of protected cells.
7) Create a password and then confirm the password.
8) Select or deselect the options for Allow all users of this sheet to: so users can select
protected or unprotected cells.
9) Click OK to save the changes and close the dialog.
Format Cells >
Mumbers Font Font Effects Alignment Borders Background ':E”PFDtECtIDr'I
Protection
L1 Hide all Cell protection is only effective after the current sheet has
Protected been protected.
[ ] Hide formula Select 'Protect Sheet' from the Tools' menu.
Print
[] Hide when printing The cells selected will be omitted when printing.
Help Reset oK Cancel
Figure 53: Format Cells dialog — Cell Protection tab
'i- i Note

When data in cells are hidden, it is only the data contained in the cells that are hidden
and the protected cells cannot be modified. The blank cells remain visible in the
spreadsheet.
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Figure 54: Protect Sheet dialog

Showing data

Sheets

Right-click on any sheet tab and select Show Sheet from the context menu. Choose which sheet
from the list in the Show Sheet dialog. If there are no hidden sheets, the Show Sheet option will
not appear in the context menu.

Rows and columns
1) Select the rows or columns on each side of the hidden row or column.
2) Go to Format on the Menu bar and select Rows or Columns.

3) Select Show from the context menu and the row or column will be displayed and can be
printed.

Alternatively, right-click on a row or column header and select Show Rows or Show Columns
from the context menu.

Cells
1) Go to Tools > Protect Sheet on the Menu bar to open the Protect Sheet dialog (Figure 54).
2) Enter the password to unprotect the sheet and click OK.

3) Go to Format > Cells on the Menu bar, or right-click and select Format Cells from the
context menu, to open the Format Cells dialog (Figure 53).

4) Click the Cell Protection tab and deselect the hide options for the cells. Click OK.

Group and outline

If you are continually hiding and showing the same cells, you can create an outline of your data
and group rows or columns together so that you can collapse a group to hide it or expand a group
to show it using a single click.
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The basic controls for grouping and outlining show plus (+) or minus (-) signs on the group
indicator to show or hide rows or columns. However, if there are groups nested within each other,
the basic controls have numbered buttons so you can hide the different levels of nested groups.

Grouping
To group rows or columns:
1) Select the cells you want to group in the spreadsheet.
2) Go to Data > Group and Outline > Group on the Menu bar, or press the F12 key.

3) Inthe Group dialog that opens, select either Rows or Columns and click OK. A group
indicator appears to the left of any rows grouped or above any columns grouped. Figure 55
shows a group indicator on the left of the first two rows of the spreadsheet have been

grouped.
AZ:E3 “| Fx 2 = ||01/01/1018
Alz] :
Date Name Arrives Leaves Hours
= 01/01/1018{Briggite 10:15 16:15 6.00
01/01/1018 Fanz 11:00 18:45 7.00
01/01/1018 Hans 08:15 19:00 10.00

Figure 55: Group indicator

Hiding details
To hide the details of any group of rows or columns:
1) Click on the minus (=) sign on the group indicator.

2) Alternatively, select a cell within the group and go to Data > Group and Outline > Hide
Details on the Menu bar.

3) The rows or columns are hidden and the minus (-) sign becomes a plus (+) sign on the
group indicator.

Showing details
To show the details of any hidden groups or rows or columns:
1) Click on the plus (+) sign on the group indicator.

2) Alternatively, select a cell on each side of the hidden group and go to Data > Group and
Outline > Show Details on the Menu bar.

3) The hidden rows or columns are displayed and the plus (+) sign becomes a minus (-) sign
on the group indicator.

Ungrouping
To ungroup any groups of rows or columns:
1) Make sure the grouped rows or columns are displayed.

2) Go to Data > Group and Outline > Ungroup on the Menu bar, or use the keyboard
combination Ctrl+F12.

3) If only rows or only columns are grouped, they are ungrouped. If both rows and columns
are grouped, select either Rows or Columns to ungroup and click OK.

A Caution

Any hidden groups of rows or columns must be displayed. If they are hidden, then the
grouped rows or columns are deleted from the spreadsheet.
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g Note

If there are nested groups, only the last group of rows or columns created is
ungrouped.

AutoOutline

If a selected cell range contains formulas or references, Calc automatically outlines the selection.
For example, in Figure 56 the cells for the 1st and 2nd quarters each contain a sum formula for the
three cells to their left. If you apply the AutoOutline command, the columns are grouped into two
quarters.

To apply the AutoOutline function, go to Data > Group and Outline > AutoOutline on the Menu
bar. Calc will then check for cells that contain formulas or references and automatically group the
cells as necessatry.

LeSaL sans el [ . = = =1 —= rooA = ¥ WA L
A2 v fx 2 =
ElS ' - ]
z
_ B | c | D | E_ | F | 6 [ H ]
1 [Jan Feb Mar 1% Quarter  Apr May Jun 2™ Quarter
2 100 120 130 350 100 100 200 400

Figure 56: Example of AutoOutline

Removing

To remove any cell groups of rows or columns, go to Data > Group and Outline > Remove
Outline on the Menu bar and any groups are removed.

Any cell group of rows or columns that are hidden, the grouping is removed from the cells and the
cells are displayed in the spreadsheet.

Filtering

Afilter is a list of conditions that each entry has to meet to be displayed. Calc provides three types
of filter:

Standard — Specifies the logical conditions to filter the data.

AutoFilter — Filters data according to a specific value or string. Automatically filters the selected
cell range and creates one-row list boxes where you can choose the items that you want to display.

Advanced — Uses filter criteria from specified cells.

Applying a standard filter
A standard filter is more complex than AutoFilter. You can set as many as eight conditions as a
filter, combining them with the operators AND or OR. Standard filters are mostly useful for
numbers, although a few of the conditional operators can also be used for text.

1) Select a cell range in the spreadsheet.

2) Go to Data > More Filters > Standard Filter on the Menu bar to open the Standard Filter
dialog (Figure 57).

3) Specify the filter criteria and filtering options that you want to use.

4) Click OK to carry out standard filtering and close the dialog. Any records that match the
filter criteria and options that you specified are shown.
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Standard Filter et
Filter Criteria
Operator Field name Condition Value A
= W ot
- none =
- none =
- none = w
=I Options
(] Case sensitive ] Regular expressions
L] Range contains column labels [ ] Mo duplications
(] Copy results to: Keep filter criteria
- undefined -
Help QK Cancel

Figure 57: Standard Filter dialog

The filter criteria used in standard filtering defines a filter by indicating the type of operator, the
name of the field, a logical condition and a value or a combination of arguments.

Operator — for the following arguments, you can choose between the logical operators
AND / OR.

Field name — specifies the field names from the current table to set them in the argument.
You will see the column identifiers if no text is available for the field names.

Condition — specifies the comparative operators through which the entries in the Field
name and Value fields can be linked.

Value — specifies a value to filter the field. The Value list box contains all possible values for
the specified Field name. Select a value to be used in the filter, including Empty and Not
Empty entries.

Case sensitive — distinguishes between uppercase and lowercase letters when filtering the
data.

Range contains column labels — includes the column labels in the first row of a cell
range.

Copy results to — select the check box and then select the cell range where you want to
display the filter results. You can also select a named range from the list.

Regular expressions — select to use wildcards in the filter definition. See LibreOffice Help
for a list of the regular expressions that LibreOffice supports. If selected, you can use
regular expressions in the Value field if the Condition list box is set to '=' EQUAL or '<>'
UNEQUAL. This also applies to the respective cells that you reference for an advanced
filter.

No duplications — excludes duplicate rows from the list of filtered data.

Keep filter criteria — select Copy results to and then specify the destination range where
you want to display the filtered data. If this box is checked, the destination range remains
linked to the source range. You must have defined the source range under Data > Define
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Range as a database range. You can also reapply the defined filter at any time by clicking
into the source range and then go to Data > Refresh Range.

Applying an AutoFilter

An AutoFilter adds a drop-down list to the top row of one or more data columns which lets you
select the rows to be displayed. The list includes every unique entry in the selected cells sorted
into lexical order (see https://www.dictionary.com/browse/lexical-order for an explanation of lexical
order). AutoFilter can be used on multiple sheets without first defining a database range.

1) Click in a cell range on the spreadsheet. If you want to apply multiple AutoFilters to the
same sheet, you must first define database ranges, then apply the AutoFilters to the
database ranges.

2) Go to Data > AutoFilter on the Menu bar, or click the AutoFilter icon R on the Standard
toolbar. An arrow button is added to the head of each column in the database range.

3) Click the arrow or small triangle in the column that contains the value or string that you
want to set as the filter criteria (shown in Figure 58).

4) Select the value or string that you want to use as the filter criteria. The records that match
the filter criteria that you selected are then shown.

File Edit View |nset Format  Styles Sheet Data Tools Wi

iB-"-H-lled XER-1&§89-
| Arial v o BT U|A-~F -~
Q vl fx 2 = || 101500
p—— - A ; \
1 Mame |+| Start [+] Finish
01/01/2008 . 15 6.00
:i!mmwznma el 45 7.00
— 4 | 01/01/2008 | SortDescending 00 10.00
5_|01/0172008 [ . 00 275
6 | 01/01/2008 45 275
~ 7 | 02/01/2008 | Emety 45 6.00
_ & | 02/01/2008 | Mot Empty 45 6.00
9 | 02/01/2008 130 8.25
10 | 02/01/2008 Standard Filter... 30 7.00
“11_| 02/01/2008 00 6.00
12 | 03/01/2008 | | Search iten 130 8.75
13 | 03/01/2008 30 5.50
14| 03/01/2006 | £ EHFERE 100 9.75
15 | 03/01/2008 | B Fritz t45 9.50
16 | 03/01/2008 || EdHans 30 9.25
17 | 06/01/2008 b4 Kurt £30 T1.25
T1a | 06/01/2008 | EAUte 30 3.50
19| 06/01/2008 15 6.00
20 | 06/01/2008 45 5.00
21 | 06/01/2008 00 4.50
~22 | 07/01/2008 ————— 115 4.75
“23 | 07/01/2008 | B AN IS =T 9.00
_ 24 | 072008 45 &.00
25 | 07/01/2008 45 575
26 | 07/01/2008 Encelil b 575
27 | 08/01/2008  -©mgme wuw 100 7.25

Figure 58: AutoFilter example
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Applying an advanced filter
An advanced filter has a structure similar to a standard filter. The difference is that the advanced
filter arguments are not entered in a dialog. Instead, filters can be entered in a blank area of a
spreadsheet, then referenced by the filter dialog to apply the filters.

1) Select a cell range in the spreadsheet.

2) Go to Data > More Filters > Advanced Filter on the Menu bar to open the Advanced Filter
dialog (Figure 59).

3) In Read Filter Criteria From, select the named range, or enter the cell range that contains
the filter criteria that you want to use.

4) Click OK to carry out advanced filtering and close the dialog. Any records that match the
filter criteria and options that you specified are shown.

£7] Note

The options for advanced filtering are the same as those used for standard filtering,
see “Applying a standard filter” on page 76 for more information.

Range contains column labels

[ Copy results to:

Advanced Filter X
Read Filter Criteria From
- undefined - '~ &
[] Case sensitive [ ] Reqular expressions

[1No duplications

Keep filter criteria

- undefined -

Figure 59: Advanced Filter dialog
For an example of an advanced filter, see the Help page entitled “Filter: Applying Advanced Filters”.

Sorting records

Sorting within Calc arranges the cells in a sheet using the sort criteria that you specify. Several
criteria can be used and a sort applies each criteria consecutively. Sorts are useful when you are
searching for a particular item and become even more useful after you have filtered data.

Also, sorting is useful when you add new information to a spreadsheet. When a spreadsheet is
long, it is usually easier to add new information at the bottom of the sheet, rather than adding rows
in their correct place. After you have added information, you can then sort the records to update
the spreadsheet.

Sort dialog

To sort cells in a spreadsheet using the Sort dialog:

1) Select the cells, rows, or columns to be sorted.
2) Go to Data > Sort on the Menu bar to open the Sort dialog.
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3) On the Options tab (Figure 61), choose options including whether to sort on rows or

columns. See “Sort options” on page 81 for details.

Sort

Sort Criteria Options

Sort Key 1

Sort Key 2

|- undefined -

M ‘

Sort Key 3

|- undefined -

@Escending
Ogescending

@Escending
Ogescending

Ascending

Descending

Figure 60: Sort dialog — Sort Criteria tab

4) On the Sort Criteria tab (Figure 60), select the criteria from the drop-down lists. The

selection lists are populated from the selected cells.

5) Select either Ascending order (A-Z, 0-9) or Descending order (Z-A, 9-0).

6) Click OK and the sort is carried out on the spreadsheet.

Sort

Sort Criteria Options

Sort Options
Range contains column labels
lncludefnrmats
[l Enable natural sort

include boundary colurmn(s) containing only comments
Include boundary column(s) containing anly images

[ Copy sort results to:

|— undefined -

[l Custom sort order

|Sun_. Maon, Tue, Wed Thu,Fri Sat

Language Options

Default - English (USA) e

Direction
® Top to bottom (sort rows)
O Left to right (sort columns)

Help

Cancel

Figure 61: Sort dialog — Options tab
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Z Note

If any of the cells that you select for sorting are protected and the sheet is protected,
then Calc cannot modify those cells and the sort will not be executed. An error
message will be displayed to indicate that protected cells cannot be modified.
However, it is possible to sort a range containing a row of column labels that are
protected, since these are not modified by the sort.

Sort options
On the Options page of the Sort dialog (Figure 61), you can set these options:

» Case sensitive — sorts first by uppercase letters and then by lowercase letters. For Asian
languages, special handling applies.

£7] Note

For Asian languages, select Case sensitive to apply multi-level collation. With multi-
level collation, entries are first compared in their primitive forms with their cases and
diacritics ignored. If they evaluate as the same, their diacritics are taken into account
for the second-level comparison. If they still evaluate as the same, their cases,
character widths, and Japanese Kana difference are considered for the third-level
comparison.

* Range contains column/row labels — omits the first column/row in the selection from the
sort. The Direction setting at the bottom of the dialog defines the name and function of this
check box: if top to bottom, then column labels; if left to right, then row labels.

* Include formats — preserves the current cell formatting.

* Enable natural sort — natural sorting is a sort algorithm that sorts string-prefixed numbers
based on the value of the numerical element in each sorted number, instead of the
traditional way of sorting them as ordinary strings. For instance, assume you have a series
of values such as, Al, A2, A3, A4, A5, A6, ..., A19, A20, A21. When you put these values
into a range of cells and run the sort, it will become Al, All, A12, A13, ..., A19, A2, A20,
A21, A3, A4, A5, ..., A9. With natural sorting selected, values such as these are sorted
correctly.

* Include boundary column(s) containing only comments — keeps these cells associated
with the cells being sorted.

* Include boundary column(s) containing only images — keeps these cells associated
with the cells being sorted.

* Copy sort results to — copies the sorted list to the cell range that you specify. Select a
named cell range where you want to display the sorted list, or enter a cell range in the input
box.

* Custom sort order — select this option and then select the custom sort order that you want
to apply. The available selections are defined as “fill series” in Tools > Options >
LibreOffice Calc > Sort Lists. See “Defining a fill series” on page 49.

* Language — select the language for the sorting rules.

* Options — select a sorting option for the language. For example, select the Phone book
option for German to include the umlaut special character in the sorting.

* Top to bottom (sort rows) — sorts rows by the values in the active columns of the selected
range.

* Left to right (sort columns) — sorts columns by the values in the active rows of the
selected range.

Sort options | 81



Quick sort
If the columns in the spreadsheet have a header with a text format, you can use a quick sort.

1) Select a cell or a cell range to be sorted.
2) Click the Sort Ascending or Sort Descending icon on the Standard toolbar.

Find and replace

Calc has two ways to find text within a document: the Find toolbar and the Find & Replace dialog.
The toolbar is quick and easy to use, but its functions are more limited than using the dialog.

Find toolbar
Find * X
Find V Find Al [ Formatted Display [ Match Case /'{!_i

Figure 62: Find toolbar

1) Goto View > Toolbars > Find or Edit > Find on the Menu bar, or use the keyboard
shortcut Ctrl+F to open the Find toolbar (Figure 62). By default this toolbar is docked in the
lower left of the Calc window. You can undock the toolbar and move it.

2) Type a search term in the Find text box.

3) To refine the search, you can select the Match Case option. For example, if Owner is the
search term, selecting Match Case will find Owner but not owner. You can also select the
Find All or Formatted Display options.

4) Click the Find Next or Find Previous icon. To find other occurrences of the same term,
continue clicking the icon.

Find & Replace dialog

To open the Find & Replace dialog (Figure 63), go to Edit > Find & Replace on the Menu bar, or

use the keyboard shortcut Ctrl+H, or click the Find & Replace icon 4 on the Standard toolbar, or
click the Find & Replace icon on the Find toolbar.

Finding
1) Inthe Find & Replace dialog (Figure 63), enter the search criteria in the Find box.
2) If necessary, click on Other options to increase the number of search filters.
3) Click Find Next to locate the first instance of the search criteria.
4) Click Find Next again to locate the next instance of the search criteria. Repeat as needed.

5) Or, click Find All to locate all cells containing the search criteria. These cells will be
highlighted in the spreadsheet. A small dialog will pop up, listing the cell locations.

Replacing
1) Inthe Find & Replace dialog (Figure 63), enter the search criteria in the Find box.
2) Enter the replacement contents in the Replace box.
3) If necessary, click on Other options to increase the number of search filters.
4) To step through the cells and choose whether to replace the contents:
5) Click Find Next to locate the first instance of the search criteria.

6) If necessary, click Replace to replace the search criteria with the contents of the Replace
box.
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7) Repeat as required.

8) Or, to locate and replace all instances of the search criteria without stopping at each one,
click Replace All.

Find & Replace >

Find: w
O] Match case O] Formatted display O] Entire cells C A sheets

Replace: w

Firnd All Find Previous Fird Mext Beplace Replace All

=I Other options

Current selection only ] Replace backwards
L] Regular expressions (] el Styles
(] Similarity search Sirmilarities...

L1 wildcards

Diacritic-sensitive

Direction: ®RDES OCDIumﬂs Search in:

Help Close

Figure 63: Find & Replace dialog
)% Tip

To replace the first instance of the search criteria you can simply press Replace
without pressing Find Next first.

A Caution

Use Replace All with caution; otherwise, you may end up with some highly
embarrassing mistakes. A mistake with Replace All might require a manual, word-by-
word search to fix, if it is not discovered in time to undo it.

Find & Replace options

The options available to refine your find and replace are as follows:
* Find — enter the text that you want to search for, or select a previous search from the list.
* Match case — distinguishes between uppercase and lowercase characters.

* Formatted display — searches for cell contents in a particular format. For example, if a cell
has a currrency value, say $123.45 and another has the same contents but default
formatting (123.45), then searching for “$123.45” will find the currency cell but not the
default-formatted cell.

* Entire cells — searches for cells with contents that are identical to the search text.
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* All sheets — Searches through all of the sheets in the current spreadsheet file.

* Replace — enter the replacement text, or select a recent replacement text or style from the
list.

* Current selection only — searches only the selected text or cells.

* Replace backwards — search starts at the current cursor position and goes backwards to
the beginning of the file.

* Regular expressions — select to use wildcards in the search. See LibreOffice Help for
more information on the use of regular expressions.

* Cell Styles — searches for cell content formatted with the style that you specify. Select this
option and then select a style from the Find list. To specify a replacement style, select a
style from the Replace list.

« Similarity search — find terms that are similar to the Find text. Select this option, and then
click the ... button to define the similarity options.

* Wildcards — search for a wildcard expression given in the Find text.
» Diacritic-sensitive — include diacritics and accents in the search.
» Direction — determines the Rows or Columns order for searching the cells.

» Search in — select either Formulas, Values, or Notes to search for the characters that you
specify in values, in the results of formulas, or in notes.

Search Results dialog

Search Results X
S5heet | Cell | Content
Sales List  SESGT Hans ~

Sales List SES62 Hans
Sales List  SESE9 Hans
Sales List  SESTO Hans
Sales List  SEST1 Hans
Sales List  SEST2 Hans
Sales List SES73 Hans
Sales List SEST4 Hans
Sales List  SESTS Hans
Sales List SESVR Hans
Sales List  SESTV Hans
Sales List SEST8 Hans
Sales List  SESTY Hans
Sales List  SESE0 Hans
Sales List SES81 Hans hd

24 results found

Show this dialog Close

Figure 64: Search Results dialog

After you select Find All on the Find toolbar, or Find All or Replace All on the Find & Replace
dialog, Calc’s initial default behavior is to display the Search Results dialog (Figure 64) after it has
completed the operation. This dialog summarizes the results. In addition affected cells are
highlighted in the spreadsheet.

84 | Find and replace



The Search Results dialog lists the affected cells and their current content (after any replacement).
It also states the number of affected cells. If you deselect the Show this dialog checkbox on the
Search Results dialog before pressing the Close button, then the dialog will not be displayed after
future Find All or Replace All presses. The display of the Search Results dialog can also be
controlled by enabling or disabling the Tools > Options > LibreOffice Calc > View > Window >
Summary on search option.
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Chapter 3
Creating Charts and Graphs

Presenting information visually



Introduction

Charts and graphs can be powerful ways to convey information and Calc offers a variety of ways to
present data. They can be customized to a considerable extent, enabling information to be shown
in the clearest manner.

For readers interested in effective ways to present information graphically, two excellent
introductions to the topic are William S. Cleveland’s The Elements of Graphing Data, 2nd edition,
Hobart Press (1994) and Edward R. Tufte’s The Visual Display of Quantitative Information, 2nd
edition, Graphics Press (2001).

Chart Wizard

Use Chart Wizard to create an initial chart using data in a spreadsheet. Then use the Chart Wizard
options to change the type of chart, adjust data ranges, and edit some chart elements. Each
change is immediately seen in the chart.

Overview of Chart Wizard

A | B | c | D |
| 1] Equipment Rentals
| 2 | Canoes Boats Motors
| 3 |Jan 12 23 47
| ¢ |[Feb 9 31 54
| 5 Mar 14 27 56
s |Apr 17 28 48
7 [May 13 19 39
s |Jun 8 27 52

I?’gure 65: Example data for creating a chart

To demonstrate the process of using Chart Wizard to create charts, the data shown in Figure 65 is
used in the following sections. Here is an overview of the basic steps:

1) Select the cells containing all of the data — including names, categories, and labels — to
be included in the chart. The selection can be a single block, individual cells, or groups of
cells (columns or rows). In this example, it may be best to select the cell range A2:D8,
which will intentionally omit the overall title “Equipment Rentals” from the chart.

‘:Q:‘ Tip

When the data is in one place, the Chart Wizard can guess the range and create an
initial chart even if all of the data is not selected. Before opening the Chart Wizard, just
place the cursor or select a cell anywhere in the area of the data.

2) Do one of the following. This will cause a chart to be placed on the spreadsheet as an
object (Figure 66) and open the Chart Wizard dialog (Figure 67).

— Go to Insert > Chart on the Menu bar.

— Click the Insert Chart icon l A on the Standard toolbar.

3) Choose the chart type and make any other selections desired. The options are explained
below.

4) Click Finish to save the selections and close the Chart Wizard.
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Figure 66: Example chart automatically created using Chart Wizard

The following sections provide further details about using the Chart Wizard.

Selecting chart type

Calc offers a choice of ten basic chart types. Further options vary according to the type of chart
selected. For more information about the different chart types see “Gallery of chart types” on page
142.

Chart Wizard >
Choosea Chart Type

Steps

' " E Bar

J Pie I I . B I !
2. Data Range Area -

. Line

3. Data Series - XY (Scatter) Mormal
4, Chart Elerments -~ Bubble

Column and Line Shape

Cylinder
Cone

Pyramid

Figure 67: Chart Wizard dialog — selecting chart type

The initial chart created using the Chart Wizard is a 2D column chart. A small preview of the
selected variant is highlighted with a surrounding border, as shown in Figure 67. The name of the
variant (Normal in Figure 67) is shown below the preview.

To change chart types and options:

1) Select the type of chart from the list under Choose a Chart Type.

2) If needed, select a chart variant in the preview box by clicking on it. The options available
depend on the type of chart selected. The chart changes instantly to reflect the selection.

3) To use a 3D chart, select the checkbox 3D Look and select the type of 3D view (Realistic
or Simple). This option is available only for column, bar, pie, or area chart types.

4) Click Next to make changes to data range, data series, and chart elements, explained in
greater detail below.

5) When satisfied with the chart, click Finish to close the Chart Wizard.
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Z Note

To recreate many of the charts shown in the following sections, select the Column
chart type, Normal variant, with the 3D Look option unchecked.

Selecting data range

The data range contains all of the cells with data (including labels and categories) that should be
included in the chart. In the Data Range step of the Chart Wizard (Figure 68), manually correct any
mistakes in data selection for the chart.

Steps Choose a Data Range
Data range: [Sheet1.5BS2:SES8 =
1. Chart Type () Data series in rows
m (®) Data series in columns
3. Data Series [ First row as label
4, Chart Elements First column as label

Figure 68: Chart Wizard dialog — selecting data range
To use the Data Range page:

1) If necessary, change the rows and columns used as data for the chart by editing the cell
references in the Data range text box. Edit the cell references in one of these two ways:

— Directly modify the text in the Data range text box.

— Click the Select data range button to the right of the Data range box. Then use the
cursor to select the data range(s) on the spreadsheet.

2) Specify whether the data series are arranged in rows or in columns. In the example data,
shown in Figure 65, the data series are in columns.

3) Select whether to use the first row, or first column, or both, as labels.
4) Click Next > to move to making changes to the data series (Figure 69).
When satisfied with the chart, click Finish to close the Chart Wizard.

5)
E Note

If the syntax for a data range is not correct, Calc shows the text in red.

Selecting non-adjacent data

To create a complete data range from multiple cells that are not next to each other, use a delimiter
between individual ranges. For example, the English (USA) locale uses a comma as a delimiter
and "$Sheet1.A1:A5,$Sheet1.D1:D5" is a valid data range. A semi-colon is another commonly
used delimiter.

The appropriate delimiter depends on the locale selected at Tools > Options > Language
Settings > Languages > Locale setting. See or change the default delimiter for a locale at Tools
> Options > LibreOffice Calc > Formula. In the Separators section, Array column shows the
default delimiter.
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Z Note

The options under Tools > Options may not be available when the chart is in edit
mode. If desired, click outside the chart to leave edit mode and see the options. Click
the chart twice to enter edit mode again.

To select non-adjacent data, do one of the following in step 1 above:
* Manually enter the data ranges in the text box with delimiter(s) between them.

* Select the data with the cursor by first clicking the Select data range button to the right of
the Data range box. Place the cursor at the end of the first data range in the text box
(otherwise the first range is selected and then deleted) and enter the delimiter. Then drag
the cursor in the spreadsheet to select the next data range.

"{Z Note

When the data is in the same document as the chart, changes to the data are instantly
reflected in the chart.

Linking to external data

Calc offers several options for linking data to external sources. This enables data (and the chart
using the data) to automatically update when the external data changes. The following types of
files can be linked: HTML, Calc, Base, CSV, Excel, and registered data sources. For further
information, refer to Chapter 10, Linking Data, in this guide.

Selecting data series

The Data Series page of the Chart Wizard (Figure 69) enables fine tuning of the data. Each data
series contains a set of data that have something in common, such as the types of rental
equipment listed in Figure 65. Use the Data Series page to change the source range of each data
series and to organize how the data is presented in the chart. This includes removing unnecessary
data and specifying how data is plotted along the axes.

Organizing data series
002 Tip

The Chart Wizard makes initial assumptions about how the data should be displayed,
but the assumptions could be incorrect. If a chart does not look as expected, the first
thing to check is if all data series are defined correctly.

Also, check the settings on the Data Range page that define whether the data are in
rows or columns and whether the first row or first column should be considered labels.

The names of each data series appear in the Data series list box (the middle box in Figure 69). To
organize the data series, select an entry in the Data series list and do one or more of the following:

* To change the name of the data series, select Name in the Data ranges list on the right.
Edit the cell references in the Range for Name text box that appears.

* To change the cell references for data series categories, edit the cell references in the
Categories text box below the Data ranges box.

* Click Add to add another data series below the selected entry. The data ranges for the new
data series will then need to be defined.

* Click Remove to remove the selected entry from the Data series list.
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e Click the Up or Down button to move the selected entry up or down in the list. This does
not change the order in the data source table, but changes only the arrangement in the
chart.

g Note

Different data series must be in separate columns or rows. Otherwise Calc will assume
that they are the same data series.

Setting data series ranges

To understand how Calc treats data in charts, it is important to understand the distinction between
values and categories. Values are numeric data that vary continuously. By contrast, categories
have no mathematical relationship with each other. For example, the categories for the chart data
referred to in Figure 69 and the chart shown in Figure 66 are months of the year.

Most Calc charts require both value and category data, with values plotted along the Y axis and
categories plotted along the X axis. The exceptions are XY (scatter) charts and bubble charts,
which use only value data along both axes.

Chart Wizard >
Customize Data Ranges for Individual Data Series
Steps
Data zeries; Data ranges:
1. Chart Type Border Color
Boats
2.Data Range Motors Marne §'Equipment Rentals'.SE
: -Values S'Equipment Rentals'.5E
4, Chart Elerments
Range for Border Color
=
Categories
Add A Equipment Rentals'.SAS3:SASS =
Remove
Help < Back Mext = Finish Cancel

Figure 69: Chart Wizard dialog - selecting data series

Data ranges that may be defined for a specific chart type appear in the Data ranges box on the
right side of the Data Series page, shown in Figure 69. Not all data ranges may need to be filled in.
The data ranges may include:

Border Color and Fill Color
Border and fill colors for each data point in the data series can be specified here using
numeric values for the RGBA color system. If not specified here, Calc will use default colors.
Conditional formatting can also be used. This enables data point colors to vary, depending on
whether they meet certain conditions or values. For further information, refer to “Assigning
colors” on page 109.

Name
When Data series in columns and First row as label are selected on the Data Range
page, Calc assumes that the column labels of the selected data are the data series hames.
Thus, Calc assumes that the data series hames of the data in Figure 65 are “Canoes”,
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“Boats”, and “Motors”. Similarly, when Data series in rows and First column as label are
selected, Calc assumes that the row labels of the selected data are the data series names.

The only way to change a data series name is by selecting Name in the Data ranges box in
the upper right of Figure 69. Then enter a different cell range in the Range for Name box that
appears below the Data ranges box. (Note that the data series name is often contained in a
single cell, rather than a range of cells.)

Y-Values
These are numeric values that are often plotted along the vertical axis. However, this is not
always the case. For example, while Y-values are plotted on the vertical axis in column
charts, they are plotted along the horizontal axis in bar charts.

Categories
The range for category data is defined in a separate Categories box below the Data ranges
box. Note the difference between categories and data series names. For the data in Figure
65, the categories are the row labels while the data series names are the column labels.

Z Note

Category data usually appears along the X axis (except for XY (scatter) and bubble
charts, which require value data for the X axis).

Depending on the type of chart, other data ranges may need to be defined in addition to those
shown in Figure 69.

Selecting chart elements

Chart Wizard >
Choose Titles, Legend, and Grid Settings
Steps
Title [ Display legend
1. Chart Type Subtitle O Left
2. Data Range . (®) Right
X axis O
3. Data Series -op
i ¥ axis ) Bottom
4. Chart Elements
Display Grids

L] % axis ‘r’axis £ axis

Figure 70: Chart Wizard dialog — selecting and changing chart elements

On the Chart Elements page of the Chart Wizard dialog (Figure 70), add or change the title,
subtitle, axes names, and grids. Use titles that draw the attention of viewers to the purpose of the
chart and describe what they should focus on.

The chart elements for 2D and 3D charts are illustrated in Figure 71.
* The chart wall contains the graphic displaying the data.
* The chart area is the background of the entire chart.

* The chart title and subtitle, chart legend, axes labels, and axes names are in the chart
area.

* The chart floor is only available for 3D charts.
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Figure 71: Chart elements

To add elements to a chart, do one or more of the following on the Chart Elements page (Figure
70):

» Enter a title and subtitle (if desired) in the Title and Subtitle text boxes.

* Enter names to be used in the X axis and Y axis text boxes. The Z axis text box is only
active if creating a 3D chart.

* Select the Display legend checkbox (turned on by default) and choose where to display
the legend — Left, Right, Top, or Bottom. The names in the legend are the data series
names. Specify the names in the Range for Name field in the Data Series page.

* Under Display Grids, select the Y axis or X axis check boxes to display horizontal or
vertical grid lines. For some charts, the axis grids are displayed by default. Grids are not
available for pie charts. The Z axis checkbox is only active when creating a 3D chart. For
further information about grids, refer to Grids on page 122.

Z Note

While clicking Finish closes the Chart Wizard, the chart is still in edit mode, indicated
by gray borders, and can still be modified. Click outside the chart in any cell to exit the
edit mode.

Using the Sidebar to change chart settings

The Properties deck of the Sidebar (Figure 72) makes some basic options readily available for
specifying the appearance of charts. To open the Sidebar, first click outside the chart to deselect it,
then go to View > Sidebar on the Menu bar or press Ctrl+F5. By default, the Sidebar opens on the
right side of the screen.

00 Tip
If you follow the directions above and the Properties deck of the Sidebar does not

appeatr, click the Properties icon on the upper right of the Sidebar. If the Properties
deck still does not appeatr, click the chart again.
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Figure 72: Properties deck of the Sidebar when chart is selected (left) and when chart is in
edit mode (right)

The contents of the Sidebar depend on whether the chart is selected or is in edit mode. The
Sidebar on the left in Figure 72 shows the Properties deck when a chart is selected (by clicking on
it once). When a chart is in edit mode (by clicking on it twice), the Properties deck on the right in
Figure 72 appears.

The options available on the Properties deck of the Sidebar are also available elsewhere. They
may be found in the Menu bar, the Formatting toolbar, or context menus (made available by right-
clicking a chart element).

i:.z Note

The Sidebar can be quite useful. However, because the options are easy to see and
are available elsewhere, further references to it are not included in this chapter.
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Modifying charts

The Chart Wizard establishes basic features of a chart. After using it, you may want to change data
ranges or modify the look of the chart. Calc provides many options for formatting and fine-tuning
the appearance of charts. This includes tools for editing the chart type, chart elements, data
ranges, fonts, colors, and many other options.

Modify charts in one of two ways, depending on what you want to change.

Edit object properties
Click a chart once to edit its object properties. These include size, position on the page,
alignment, outer borders, copying, exporting, and more. See the sections starting with
“Resizing, moving, and positioning charts” on page 135 for more information.

Use edit mode
Use edit mode to change data selection and chart type as well as elements such as axes,
titles, backgrounds, grids, data series, data labels, trend lines, and more.

Overview of using edit mode

Here are some general ways to modify charts in edit mode. These are discussed in greater detail
in the following sections.

* To add an element not already in the chart, use the Insert menu on the Menu bar. Insert
titles, legends, axis labels, grids, data labels, trend lines, mean value lines, and error bars.

* To move or change the size of titles, axis names, chart walls, and legends, click on them
once. The cursor changes to a move icon (appearance depends on the system). Drag the
element to the new location. To change the size, drag the selection handles.

* Modify elements in a few basic ways. The following methods may open the appropriate
dialog or menu. Not all of these methods will work for every element:

— Double-click the element (see an exception below).

— Select the element from the Insert menu (Figure 73) or Format menu (Figure 74) on
the Menu bar.

— Click the element once, then click on the Format Selection icon on the Formatting
toolbar (Figure 75).

— Select the element from the Select Chart Element drop-down list, then click the Format
Selection icon next to it on the Formatting toolbar.
— Right-click the element to open the context menu.

* Double-click titles and axis names to change their spelling. To modify the spelling of other
text, such as categories, data labels, and legend entries, change the text in the data on the
spreadsheet.

« Click once on a data point (such as a column or bar) to select and edit the associated data
series.

— With a data series selected, double-click a single data point to edit its properties (for
example, a single column in a column chart).

Entering edit mode

To edit or format charts, double-click on the chart to place it in edit mode. The chart is now
surrounded by a gray border. In edit mode, the Menu bar changes and the Formatting toolbar
contains a number of formatting options and icons, as discussed in the following sections.
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Z Note

The next several sections (until “Resizing, moving, and positioning charts” on page
135) require a chart to be in edit mode.

Insert menu

In edit mode, the Insert menu on the Menu bar displays the options shown in Figure 73 and
discussed below:

Insert  Format  Jools W

l[l]_ Titles...

Legend...
Hxes,..
arids...

Data Labels...

Mean Yalue Lines
X Error Bars...

% Error Bars...
Figure 73: Insert menu
when chart is in edit mode

Titles

Provides spaces for entering chart title and subtitle as well as titles for X-, Y-, and Z- axes,
including secondary axes. For more information, see “Titles, subtitles, and axis names” on
page 100.

Legend
Specifies if a legend should be included and if so, where. For more information, see
“Legends” on page 102.

Axes

Provides options for showing or not showing axis labels. The Chart Wizard automatically
shows the labels. For more information, see “Axes” on page 111.

Grids

Provides options for showing or not showing major and minor grids for X-, Y-, and Z- axes. To
format grids, see “Grids” on page 122.

Data Labels

Provides options for text attributes, whether to show categories, and the position and rotation
of the labels. These labels appear on each data point. For more information, see “Data
labels” on page 118.

Trend Line
Specifies the type of regression line to be used, options for extrapolation, where the axes
should intersect, the name of the trend line, and whether and how the equation should be

displayed. The option is grayed out until a data series is selected. For more information, see
“Trend and mean value lines” on page 126.

Mean Value Lines

Displays mean value lines for selected or all data series. For more information, see “Mean
value lines” on page 130.
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X Error Bars and Y Error Bars
Specifies the error category to be used, parameters, and display options for positive and
negative indicators. For more information, see “Error bars” on page 131.

Format menu

In edit mode, these settings appear on the Format menu (Figure 74) of the Menu bar. Descriptions
of the options follow:

Format  Tools Window H

Format Selection...

Arrangernent 3
Title 3
51 Legend..
Axis 3
Grid 3
HH Chart Wall...
FH Chart Area...

I Chart Type.
[[' Data Ranges...

Figure 74: Format menu
when chart is in edit mode

Format Selection
Opens a dialog with settings for whatever element is selected. Options may include area fill,
borders, positioning, transparency, fonts, labels, scale, and other attributes.

Position and Size
Enables precise specification of the position and size of a selected element. The position is
defined in relationship to the chart. See “Position and Size dialog” on page 136 for more
information.

Arrangement
Provides two options: Bring Forward and Send Backward. Only one option may be active
for some items. Use these options to arrange overlapping data series.

Title
Formats the title and subtitle for the chart as well as axis names. The text must first be
entered on the Chart Elements page of the Chart Wizard or by going to Insert > Titles.

Legend
Formats legend appearance and position. The legend must first be turned on by using the
Chart Elements page of the Chart Wizard or by going to Insert > Legend.

AXxis
Formats properties such as where the axes cross each other, the scale of units, and
formatting of the axis labels.
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Grid
Formats the grid lines. Use the Chart Elements page of the Chart Wizard to turn on grids or
go to Insert > Grids to turn grids on or off.

Chart Wall, Chart Floor, or Chart Area
Formats borders, area, and transparency of these elements. Note that the chart floor is

available only for 3D charts. See “Formatting chart backgrounds” on page 103 for more
information.

Chart Type
Changes the type of chart and whether it is a 2D or 3D chart. The various chart types are
explained in “Gallery of chart types” starting on page 142.

Data Ranges
Sets ranges for all data in the chart and for individual data series, as explained in “Selecting
data range” on page 89 and “Selecting data series” on page 90.

3D View

Formats 3D charts and is only available for 3D charts. Note that only column, bar, pie, and
area charts can be displayed as 3D charts. See “3D charts” on page 123 for information.

Formatting toolbar

1) (@2 (@(4)B)e) (T (8@ 101 A2 A3 141516 A7)
™ I 1 —IL ":I r'.. Ir'; II'I; L illll Il': Ir— II':- ':I L Il': t:l E': ||'.I
Data Senes 'Motors' = | ) A i i ih || sl il 4 | d &4 All Axes
Chart Area
Chart
Legend p | € F | 6 | w | p—
X Axis |
Y Aocis
Data Series "Canoes’

Data Series ‘Cances’ Data Labels

Data Series ‘Cances’ Mean Value Line

Data Series 'Boats'

Data Series ‘Boats' Data Labels

Data Series ‘Boats' Mean Value Line

Data Series ‘Motors' Data Labels

Data Series ‘Motors' Mean Value Line

Data Series ‘Motors' Trend Line (Linear)
1. Select Chart Element 7. Data Ranges 13. Vertical Grids
2. Format Selection 8. Data Table 14. X Axis
3. Chart Type 9. Titles 15. Y Axis
4. Chart Area 10. Legend On/Off 16. Z Axis
5. Chart Wall 11. Legend 17. All Axes
6. 3D View 12. Horizontal Grids

Figure 75: Formatting toolbar when chart is in edit mode

In edit mode, the Formatting bar appears as in Figure 75. Click one of the icons to open a dialog or
turn an option on or off. The Insert and Format menus on the Menu bar, described above, contain
the same options, with one exception.
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The option Select Chart Element drop-down list does not appear elsewhere. Use it to easily select
individual chart elements. It can be especially helpful when the chart is crowded or it is otherwise
difficult to select elements using the cursor. Note that options such as Data Labels or Trend Line
do not appear on this list unless they have already been inserted using the Insert menu.

Z Note

The next several sections (until “Resizing, moving, and positioning charts” on page
135) require a chart to be in edit mode.

Selecting and moving chart elements

Selecting chart elements

After double-clicking on the chart to enter edit mode, select chart elements using one of the
following methods:

* Click once on the element in the chart (to select individual data points, click twice — but not
too quickly — after clicking once on the data series).

* Select the element from the Select Chart Element drop-down list that appears on the left of
the Formatting toolbar, as shown in Figure 75.

When selected, the chart element will be highlighted with square selection handles.
0)- Tip

When you hover the cursor over an element, Calc will display the element name,
making it easier to select the correct element. The name of the selected element also
appears in the Status Bar.

Moving chart elements

You may wish to move individual elements of a chart, independent of other chart elements. For
example, you may wish to reposition the title or axis names. To do so:

1) Select the element as described above.

2) Keep holding down the mouse button. The cursor changes to the move icon (appearance
depends on computer setup).

3) Drag the cursor to move the element.
4) Release the mouse button when the element is in the desired location.
Alternatively, use the Position and Size dialog for some elements, as described on page 136.

Individual points or data series cannot be moved, with the exception of pie charts. Individual
wedges of a pie can be moved or the entire pie can be exploded. See “Pie charts” on page 144 for
information.

To move axis labels, see “Positioning axis, labels, and interval marks” on page 114. To move data
labels, see “Adding and formatting data labels for a data series” on page 118.

‘::‘ Tip

For some chart elements (such as title, subtitle, axis name, and legend), press the
arrow keys to move the object in small steps.
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g Note

When a 3D chart element is selected, round selection handles may appear. These
control the 3D angle of the element. You cannot resize or reposition the element while
they are showing. Click again to obtain the square selection handles that allow you to
resize and reposition the 3D chart graphic.

Changing chart type

To change the type of chart (bar, column, pie, line, and so on):

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

2) Open the Chart Type dialog using one of these methods:
— Go to Format > Chart Type on the Menu bar.

— Click the Chart Type icon l A on the Formatting toolbar.
— Right-click on the chart and select Chart Type from the context menu.

The dialog is the same as the first page of the Chart Wizard dialog shown in Figure 68 on
page 89.

3) Select the chart type and variant desired.
4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

For further information about the types of charts, please refer to the “Gallery of chart types” on
page 142.

Titles, subtitles, and axis names

Creating or changing text
To create or change the text of a chart title, subtitle, or axis name:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

2) Use one of these methods to open the Titles dialog (Figure 76):
— Goto Insert > Titles on the Menu bar.

— Click on the Titles icon lEll on the Formatting toolbar.
— Right-click in the chart area and select Insert Titles from the context menu.

3) Enter or edit the text in the appropriate text box(es).
4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

‘:@:‘ Tip

The text of a title (but not formatting) can be modified directly. Click on it once in the
chart (with the chart in edit mode). Click again inside the selection handles to directly
change the text (it may take a few clicks to do this). Use Shift+Enter at the end of the
line to create an additional line that splits the text.
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Figure 76: Basic Titles dialog

Formatting text
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Figure 77: Titles formatting dialog (after selecting All Titles option)

Use a more extensive Titles dialog to format the appearance of a chart title, subtitle, or axis name.
To access this dialog:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

2) Do one of the following to open the Titles dialog for formatting (Figure 77):
— Click Format > Title and select the desired type of title or the All Titles option.

— Click on the element in the chart, right-click, and select Format Title (or appropriate
element) from the context menu.

— Click on the element in the chart or select it in the Select Chart Element drop-down list
on the Formatting toolbar. Then select Format > Format Selection on the Menu bar or

click on the Format Selection icon on the Formatting toolbar.

3) Format titles or names as needed. The options are self-explanatory or easily researched.
4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.
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Legends

When a legend is displayed, it shows data series names along with their graphical representations,
such as bars, lines, or points. It will also show trend lines when those are turned on, as shown in

Figure 78.

== Canoes Logarnthmic (Canoes) === Boats Mean (Boats)
Motors == Bikes —p— Tricycles
Figure 78: Example of a chart legend at the bottom of a chart.

Positioning, inserting or deleting legends

Inserting or deleting only
To only insert or delete a legend:

1) Enter edit mode by double-clicking the chart. The chart should now be surrounded by a

gray border.
2) Do one of the following:
[lﬁl.:ﬁl

Click on the Legend On/Off icon on the Formatting toolbar. The default position for
inserting a legend is on the right side of the chart.

— Right-click in the chart area and select Insert Legend or Delete Legend from the
context menu.

If desired, click outside the chart to leave edit mode.

3)
g Note

The names in the legend are the data series hames. They are taken from the Name
data range, discussed in “Selecting data series” on page 90. Change a legend name
by changing the text in the spreadsheet.

Positioning, inserting, and deleting
To position a legend using the basic Legend dialog (Figure 79) as well as insert or delete it, follow
the same steps as above but do the following instead of step 2:

1) Goto Insert > Legend on the Menu bar to open the basic Legend dialog.

O Top

)] Bottom
Figure 79: Basic Legend dialog
2) Select or deselect the Display legend checkbox to either display or not display the legend.
3) Select the desired location for the legend — Left, Right, Top, or Bottom.
4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.
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‘:@:‘ Tip

For finer positioning of the Legend, use one of the methods described in “Moving chart
elements” on page 99.

Formatting legends

For advanced editing of a legend’s appearance, a more extensive Legend dialog (Figure 80) has
several options for formatting borders, fill, fonts, transparency, and position.

1) Enter edit mode by double-clicking the chart. The chart should now be surrounded by a
gray border.

2) Do one of the following to open the Legend dialog (Figure 80):

— Click on the Legend icon Mall on the Formatting toolbar.

— Select Format > Format Legend on the Menu bar.

— Right-click on the legend and select Format Legend from the context menu.

— Click on Legend in the Select Chart Element drop-down list on the Formatting toolbar

——
or click the legend in the chart to select it. Then click on the Format Selection icon
on the Formatting toolbar or select Format > Format Selection.
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Figure 80: Legend dialog with more extensive options
3) Make any desired changes. The options are self-explanatory or easily researched.
4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

Formatting chart backgrounds

The background of a chart is divided into chart area, chart wall, and chart floor, as shown in
Figure 71 on page 93. Border, area, and transparency options for these areas are set in the
following way:
1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.
2) Do one of the following to open the appropriate dialog (such as Figure 81):
— Go to Format on the Menu bar and select Chart Area, Chart Wall, or Chart Floor.
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— Right-click the chart wall, chart floor, or chart area in the chart and select Format Wall,
Format Floor, or Format Chart Area from the context menu. (For help with selecting
these areas, see “Selecting chart elements” on page 99.)

— On the Formatting toolbar, click on the icon for Chart Area FFI or Chart Wall lELl[l (there
is no icon for chart floor).

— Click on Chart Area, Chart Wall, or Chart Floor in the Select Chart Element drop-
down list on the Formatting toolbar. Then click the adjacent Format Selection icon or
select Format > Format Selection.

Borders Area Transparency

Area Transparency Mode
(0 Mo transparency

Angle: |07
Border: 0%
Startvalue:  |0%

-
-
-
-

Endwvalue: | 100%

Figure 81: Chart Area dialog — Transparency tab
3) Select the desired settings from the Borders, Area, and Transparency tabs.

4) Click OK to save the changes and close the dialog. If desired, click outside the chart to
leave edit mode.

Data range and series

The goal of making a chart is to clearly present one or more data series and Calc provides a
number of ways to define and present those data. The following sections discuss topics such as
defining and changing data ranges, aligning data to a secondary Y axis, and formatting the
appearance of the data series.

Changing data ranges

When data ranges change in the spreadsheet, modify the chart settings to reflect those changes.
Use one of the following methods.

£7] Note

The chart automatically reflects changes in the spreadsheet data. Thus, changing a
number from 5 to 50 in the data will instantly show the new number in the chart.

Replacing data by dragging
It is easy to manually replace one set of data with another set of data. Do this in the following way:
1) Use the mouse to select all of the new data.

2) Drag the data over the chart, then release the mouse. This opens the Change Source Data
Range dialog shown in Figure 82.
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3) Specify whether or not the first column or row contains labels, then click OK. If desired,
click outside the chart to leave edit mode.

Labels
[ First column as label:
First row as label

Help 0K Cancel

Figure 82: Change Source Data Range dialog

Modifying the data range and data series
To change the data range or data series, do the following:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

2) Open the Data Ranges dialog using one of these methods:
— Go to Format > Data Ranges on the Menu bar.

— Click on the Data Ranges icon i onthe Formatting toolbar.
— Right-click on the chart and select Data Ranges from the context menu.

3) Edit the data range on the Data Range tab, which is the same as shown in Figure 68 on
page 89.

4) Edit data series on the Data Series tab, which is the same as shown in Figure 69 on page
91.

5) Click OK to save changes and close the dialog. If desired, click outside the chart to leave
edit mode.

If Calc is taking a significant amount of time to process a large amount of data for a
chart, try this: Select only limited data for each data series to initially organize the
chart. Adjust the settings until the chart looks as desired, then select all of the data.

For further information, see “Selecting data range” on page 89 and “Selecting data series” on page
90.

Opening the Data Series dialog

The Data Series dialog offers several options for presenting data in the chart. Note that only one
data series can be selected at a time.

To open the Data Series dialog (Figure 83):

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

2) Do one of the following to select the data series:
— Click on the data series in the chart.

— Click the data series name in the Select Chart Element drop-down list on the Formatting
toolbar.
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3) Do one of the following to open the Data Series dialog:
— Go to Format > Format Selection on the Menu bar.

— Click on the Format Selection icon on the Formatting toolbar.
— Right-click on the data series and select Format Data Series.

4) Click the tab of the appropriate page to make the changes needed. The options for each
page are explained below.

5) Click OK to save changes and close the dialog. If desired, click outside the chart to leave
edit mode.

Data Series >

Options Area Transparency Borders

Settings

Spacing | 100% =
Overlap 0% =
Show bars side by side
Plot Options
Plat missing values (® Leave gap
] Aszume zero
Continue line
[l Include values fram hidden cells
Legend Entry
[ Hide legend entry

Figure 83: Data Series dialog — Options tab

g Note

The tabs that appear on the Data Series dialog depend on the type of chart selected.
Similarly the controls that appear on each tab may differ depending on the type of
chart.

Alignment, spacing, and plot options

Aligning data to secondary Y axis

A secondary axis may be helpful when data differ in units or scale, as in Figure 84. In this case,
there are significantly more numbers of one data series (kayaks). To plot all three data series on
the same chart, the kayak data series is aligned to a secondary Y axis, which has a wider scale.
The color of the secondary Y axis and the axis titles help to show this relationship.

£7] Note

A data series can be associated with a secondary Y axis only after Chart Wizard has
finished creating the chart.
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Figure 84: Data series aligned to a secondary Y axis
To align a data series to a secondary Y axis:

1) Select the data series and open the Data Series dialog as described in the previous
section.

2) On the Options tab, under Align Data Series to, select Secondary Y axis.
3) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

Data can only be aligned to a secondary Y axis, not a secondary X axis. However, it is possible to
create secondary X and Y axes that duplicate the primary axes on the opposite sides of a chart.
This is described in “Add or remove axis labels” on page 111. It is also possible to show different
units or scales on the secondary axis (with or without aligning data to it), as described under
“Defining Scales” on page 113.

Spacing and plot options
The Options tab of the Data Series dialog (Figure 83) contains additional settings that depend on
the type of chart. These include:

Spacing
Sets the spacing interval of columns or bars between category settings, such as time. Values
above 100% increase the spacing while values below 100% decrease the spacing. Maximum
spacing is 600%.

Overlap
Sets overlap of columns or bars within the same category setting, such as a specific time.
The higher the percentage, the greater the overlap (maximum of 100%). Negative
percentages increase the separation (minimum of -100%).

Show bars side by side
When checked, shows no gap in columns or bars in the interval between categories. When
this option is not checked, data aligned to a secondary Y axis may hide other data. Enable
the option to prevent this.

Plot missing values
Specifies handling of missing values, with options depending on the type of chart.

Include values from hidden cells
Enables data from hidden cells to be included or not included.

Hide legend entry
Enables the name of the selected data series to be included or removed from the legend.
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Two additional options (not shown in Figure 83) appear for pie or donut charts:

Orientation

Specifies the order of the pie sections (data points) — clockwise or counter-clockwise. The
default direction is counterclockwise.

Starting Angle
Specifies the starting angle of the first pie section (data point), in the range 0 to 359 degrees.
Drag the small dot around the circle or enter a number for the degrees. Use 0 degrees to
start the first section at the 3 o’clock position and 90 degrees to start the first section at 12
o’clock.

Area, transparency, and borders

Options Area Transparency Borders

Mone LColor Gradient Bitrmap Pattern Hatch

Gradient Options Preview
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Figure 85: Data Series dialog — Area tab, Gradient page

For chart types other than line and scatter, the Data Series dialog (Figure 85) contains pages for
formatting the fill and borders of graphical representations such as columns and bars. The Area tab
offers options for selecting color by clicking directly on a color in a palette, adding a custom palette,
or by specifying the RGB or Hex color codes. Other pages contain options for gradient, bitmap,
pattern, hatch, transparency, and borders. The options are self-explanatory or can be readily
researched.

X Tip
If applying a gradient does not work as expected, do this: After selecting the desired

options on the Gradient page, click Add, provide a name for the gradient (or accept
the default), and click OK.
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Lines, areas, and data point icons

For some chart types (such as line charts and xy (scatter) charts), the Data Series dialog contains
only an Options tab and a Line tab (Figure 86).

Specify line style, color, width, and transparency of the line on the left side of the Line tab. In the
Icon section, select an option for the symbol from the drop-down list: No Symbol, Automatic,
From file, Gallery, or Symbols.

* From file opens a browser for selecting the file that contains the desired symbol.
* Gallery opens a list of available graphics that can be selected.
* Symbols opens a list showing available symbols that can be selected.
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Line Properties lcon

Ie: Select... b

Color:
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Transparency:

S
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Figure 86: Data Series dialog for line and scatter
charts — Line tab

A preview of the selection is shown in the preview box at the bottom of the dialog. Enter the
desired width and height of the symbol. Select Keep ratio if the ratio of width to height of the
symbol should be maintained.

Assigning colors

Colors for the display of data series can be specified in three ways: changing the default color
scheme, using the Data Series dialog, or using data ranges to set colors for border and fill.

Changing default color scheme

To modify the default color scheme for data series, go to Tools > Options > Charts > Default
Colors to specify colors for each data series. Changes made here affect the default colors for any
future chart.

Using Data Series dialog

As discussed in the previous section, the Data Series dialog has options for assigning colors for
lines, areas, and borders. Available options depend on the type of chart.

Using data ranges to assign colors

Use the COLOR function in the Function Wizard (described in Chapter 7, Using Formulas and
Functions) to specify colors with numbers based on combined RGB values. Then assign the
numbers to data ranges for border and fill colors in the Data Series page of the Chart Wizard (see
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“Selecting data series” on page 90) or in the Data Series tab of the Data Ranges dialog (see
“Changing data ranges” on page 104).

For example, using the COLOR function in the Function Wizard, enter 255 for R (red), 0 for G
(green), and 255 for B (blue). The COLOR function calculates a combined RGB value of
16711935. Then, when defining data ranges, enter the RGB value(s) in the cell range for border or
fill color. Optionally, include a value for the alpha channel (A) in the COLOR function. The value of
A can range from 0 (fully transparent) to 255 (fully opaque).

Z Note

Data ranges for border color and fill can only be specified for column, bar, pie, bubble,
and column and line charts.

In addition to directly assigning colors, use conditional formatting to define criteria for when specific
colors will be used. (Conditional formatting is described in Chapter 2, Entering, Editing, and
Formatting Data.)

Figure 87 shows an example of using conditional formatting to specify colors. The COLOR function
in the Formula Wizard was used to create the conditional formula
=IF(B2>100,COLOR(240,240, ,20),COLOR(150,0,150,20))

This formula says that when the value in column B is over 100, the first RGB setting is used to
color that data point in the chart. When the value in column B is 100 or less, the default color (150,
0, 150) is used. This formula is in all cells of column C. The numbers appearing in column C are
the RGB values calculated using the conditional formula (with cell references changed
accordingly).

Temperature | Number Color
Number vs Temperature
20 67 345374870
120
25 78 345374870 100
30 90 345374870 . 80
35 101 35133400 £ 60
s 40
40 111 351334400 = 20
45 106 351334400 0
50 08 345374870 20 25 30 35 40 45 50 55
Temperature
. 55 87 345374870 _ N _
Figure 87: Using the COLOR function and a conditional formula to specify
colors.

The chart on the right in Figure 87 shows how the colors change to reflect the conditional
formatting.

Formatting Data Points

Modify the appearance of an individual data point such as a column or bar using the Data Point
dialog. For most chart types, the dialog contains the same Area, Transparency, and Borders pages
as the Data Series dialog shown in Figure 85 on page 108. For line, scatter, net, and stock charts,
the dialog contains the same options as the Line tab of the Data Series dialog shown in Figure 86
on page 109.

To format data points:

1) Enter edit mode by double-clicking the chart. The chart should now be surrounded by a
gray border.
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2) Click two times (but not too quickly) on the data point to be formatted. The data point will
show square selection handles.

3) To open the Data Point dialog, do one of the following:
— Go to Format > Format Selection.
— Right-click on the data point and select Format Data Point from the context menu.

— Click the Format Selection icon ==/ on the Formatting toolbar.

4) Apply formatting options as desired.
5) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

60
50
40
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20 Data Point &
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0
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Figure 88: Tooltip showing information about a
data point

‘:Q:‘ Tip

As shown in Figure 88, hover the cursor over a data point to show the number of the
data point, the number of the series, and the X and Y values of the data point.

AXxes

Add or remove axis labels

Use the basic Axes dialog shown in Figure 89 to add or remove axis labels, such as numbers or
categories. (To change the name of an axis, see “Titles, subtitles, and axis names” on page 100).

Axes it
Axes Secondary Axes
M axis [ X axis
¥ axis Oy axis
£ axis
Help QK Cancel

Figure 89: Axes dialog — basic version

To use the basic Axes dialog:

1) Enter edit mode by double-clicking the chart. The chart should now be surrounded by a
gray border.

2) Open the basic Axes dialog by doing one of the following:
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— Goto Insert > Axes on the Menu bar.
— Right-click on the chart and select Insert/Delete Axes from the context menu.

3) Select or deselect the check boxes for axis labels. The Z-axis checkbox is only active when
a 3D chart has been created.

4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.
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Figure 90: Both secondary axes enabled.
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Selecting a secondary X axis or a secondary Y axis in this dialog creates duplicate labels on the
opposite side of the chart, as shown in Figure 90. To specify different units or intervals for the
secondary axis, use the Scale tab of the more extensive Axes dialog described in the following
section.

It is also possible to align one or more data series to the secondary Y axis. Do this using the Data
Series dialog, described in “Aligning data to secondary Y axis” on page 106.

Edit and format axes

In addition to the simple dialog above, a more extensive Axis dialog contains options for grid
intervals, positioning the axis, formatting the axis line and axis labels, and defining the scale,
among other settings. Use a dialog for a specific axis, or use a dialog that applies to all axes. The
options in the dialog depend on which axis was selected, type of chart, and whether the chart is 2D
or 3D.

To open the more extensive Axis dialog:

1) Enter edit mode by double-clicking the chart. The chart should now be surrounded by a
gray border.

2) Open a specific axis dialog (Figure 91) by doing one of the following (some options do not
allow choosing all axes):

— Go to Format > Axis on the Menu bar and select the desired axis (X Axis, Y AXis,
Z Axis, Secondary X Axis, Secondary Y Axis, or All Axes).

— Right-click on the desired axis in the chart to open the context menu. Then select
Format Axis.

— Click the axis on the chart or select the axis in the Select Chart Element drop-down list
on the Formatting toolbar and click the adjacent Format Selection icon.

— Click on the icon for X Axis |ﬂ|ﬂ, Y Axis Jllﬂ or Z Axis b'l} on the Formatting toolbar.
Or click on the All Axes option to the right of the other icons.

3) Click the tab of the appropriate page to make the changes needed. The options for each
page are explained below.
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4) Click OK to save changes and close the dialog. If desired, click outside the chart to leave
edit mode.

Y Axis >

Ie Positioning Line Label Mumbers Font Font Effects Asian Typography

Scale
[l Reverse direction

[ Logarithmic scale

Minimum 0 = Automatic
Maximum il = Automatic
Major interval 10 = Autornatic
Minor interval count |2 : Autgmatic

Figure 91: Axis dialog — Scale tab

Defining Scales

Use the Scale tab to modify the automatically generated scale for a primary axis. In addition, use
the Scale tabs for secondary axes to specify scales that are different from the scales for primary
axes. This can be quite useful for showing Celsius and Fahrenheit scales on the same chart, for
example, or for when data are aligned to a secondary Y axis (see “Aligning data to secondary Y
axis” on page 106).

The contents of the Scale tab (Figure 91) vary but may contain the following options:

Reverse direction
Defines the order of lower and higher values along the axis. When not selected, the X axis
shows the lower values on the left and the Y axis shows the lower values at the bottom.
When selected, the orientation of the data display is reversed, as in Figure 92.
Equipment Rentals

Month

Jan Feb Mar Apr May Jun
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20 W Canoes
m Boats

30 Maotors

Number

40
50
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Figure 92: Result when direction is reversed on the Y axis

Logarithmic scale
Specifies that the axis is to be subdivided logarithmically. Logarithmic scaling makes the grid
lines of the axis equidistant from each other, but the values between the lines are not equal.
Use this option when working with values that differ sharply from each other.

Minimum/Maximum
Sets the first/last value for the axis. Automatic must be deselected to set this option
manually.
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Major interval
Defines the intervals between major divisions of the axis. These intervals will be used for
interval marks (specified on the Positioning tab of the Axis dialog) and gridlines. Automatic
must be deselected to set this option manually.

Minor interval count

Defines the number of intervals (not the values between intervals) that subdivide the major
intervals. The same as for major intervals, the interval count defined here will be used for
interval marks (specified on the Positioning tab of the Axis dialog) and gridlines. Automatic
must be deselected to set this option manually.

For some types of charts, additional options may be available:

Type
Specifies whether the labels are text, date, or should be detected automatically.

Resolution
For dates, specifies that the interval steps should be days, months, or years.

‘:Q:‘ Tip

If the X axis is not displaying time as expected, manually entering the minimum and
maximum times on the Scale tab may solve the problem.

Positioning axis, labels, and interval marks
The Positioning tab (Figure 93) controls the position of axis labels and interval marks.

¥ Axis X

ng Line Label Murmbers Font Font Effects Asian Typography

Axis Line

Cross other axis at |Categor}r V| Jan |+~
Labels

Place labels |Nearaxi5 V|

Interval Marks
Major: [ Inner QOuter
Minor; | Inner J Quter

Figure 93: Axis dialog — Positioning tab

Axis Line
Sets where the axis crosses the other axis, as shown in Figure 94. The options on the drop-
down list are Start, End, or a specific value or category.
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Figure 94: Y axis set to cross X axis at specified value
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Labels

Sets where axis labels are placed, using the Place labels drop-down list, The Outside end
and Outside start options are useful for positioning labels on axes with negative numbers,
as shown in Figure 95.
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Figure 95: Axis label positions
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— Major/Minor — specifies whether interval marks are displayed for major/minor intervals.
These intervals are defined on the Scale tab, described above.

— Inner/Outer — specifies whether interval marks are placed on the inner or outer side of
the axis. The interval marks in Figure 95 are on both sides.

— Place marks — specifies where to place the marks: At labels, At axis, or At axis and
labels. (The top two charts in Figure 95 show the labels along the axes. The marks are
thus both at axis and labels. The marks in the bottom two charts are located at the

labels.)

Line tab

The Line tab has options for formatting the axis line style, color, width, and transparency. It has the
same contents as the Line tab of the Data Series dialog shown in Figure 86 on page 109 but
excluding the controls in the Icon area.

Label tab

On the Label tab (Figure 96), choose whether to show or hide the labels and specify how to handle
them when they do not fit neatly in the chart. The options are described below.
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Figure 96: Axis dialog — Label tab

Show labels
Sets whether to show or hide the axis labels.

Order

Defines the horizontal or vertical alignment of the labels on the X or Y axis. These options
are available only for 2D charts.

— Tile — arranges labels on the axis side by side.

— Stagger odd — staggers labels on the axis, with even numbers lower than odd numbers
(even numbers to the left on vertical axis).

— Stagger even — staggers labels, with odd numbers lower than even numbers (odd
numbers to the left on vertical axis).

Automatic — automatically arranges labels on the axis.

Z Note

Problems may arise in displaying labels if the chart is too small. Avoid this by either
enlarging the chart or decreasing the font size.

Text flow
Determines how text flows in axis labels.

— Overlap — allows axis labels to overlap.

— Break — allows text breaks, enabling text to wrap into new lines in the available space.

Text Orientation
Defines the direction and orientation of label text.

Vertically stacked
Stacks characters vertically so that text is read from top to bottom.

ABCD wheel
Defines text orientation by clicking and dragging the indicator on the wheel. Orientation of the
characters "ABCD" on the wheel corresponds to the new setting.

Degrees

Shows the orientation angle of the text as determined by the ABCD wheel or by manually
entering the degrees in the spin box.
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Text direction
Specifies the direction for any text that uses complex text layout (CTL). CTL is only available
if enhanced language support is enabled in Tools > Options > Language Settings >
Languages. Under Enhanced Language Support, check Ignore system input language.

Numbers

Use the Numbers tab (Figure 97) to set the attributes for any numbers used on the axis. When
Source format is selected (as it is by default), numbers are formatted exactly as as they are
formatted on the spreadsheet. Deselect this option to change number formatting. For information
about formatting numbers, see Chapter 2, Entering, Editing, and Formatting Data, in this guide as
well as the online Help.

Scale Positioning Line Label Mumbers Font Font Effects Asian Typography
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-1234.57 [ Source format
Percent -1,235
Currency -1,234.57
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-1234.56739012346

Options
O Megative numbers red

4k

Decimal places:

4 F

Leading zeroes: |1 [] Thousands separator

Format code
General

User-defined
Figure 97: Numbers tab of Axis dialog

Font and font effects

Use the Font and Font Effects tabs to set the font and font effects for the axis labels. These pages
are the same as the tabs for specifying fonts and font effects in cells. See Chapter 2, Entering,
Editing, and Formatting Data for more information.

Asian typography

Sets the Asian typographic options for axis labels. It is only available if enhanced language support
is enabled in Tools > Options > Language Settings > Languages. Under Enhanced Language
Support, check Ignore system input language. Options on this page include:

Apply list of forbidden characters to the beginning and end of lines
Prevents the characters in the list from starting or ending a line. The characters are relocated
to either the previous or the next line. To edit the list of restricted characters, go to Tools >
Options > Language Settings > Asian Layout.
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Allow hanging punctuation
Prevents commas and periods from breaking a line. Instead, these characters are added to
the end of the line, even in the page margin.

Apply spacing between Asian and non-Asian text
Inserts a space between Asian and non-Asian text.

Hierarchical axis labels

Multiple levels of categories can be displayed in a hierarchical manner along the axis of a chart.
Hierarchical axes labels are created automatically if the first column or row defined as data is text
(as opposed to the first column or row defined as labels). An example of hierarchical labels is
shown in Figure 98. In this case, Calc automatically defines the data range for categories as the
first two columns in the spreadsheet. This is reflected in the chart, which shows the hierarchical
relationship between quarters and months.

Equipment Rentals
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17 Quarter  Jan 12 23 47
Feb 9 31 54
Mar 14 27 56
2 Quarter  Apr 17 28 48
May 13 19 39
Jun 8 27 52
60
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40
30 B Canoes
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10
0
Jan Feb Mar Apr May Jun
1st Quarter 2nd Quarter

Figure 98: Example of hierarchical axes labels

Data labels

Data labels display information next to data points on the chart. They can be quite useful for
highlighting specific data when presenting detailed information, but be careful not to create a chart
that is too cluttered to read easily.

Adding and formatting data labels for a data series
To add or format data labels for a data series:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

2) Do one of the following to select a specific data series:
— Click once somewhere in the data series.

— Inthe Select Chart Element drop-down list of the Formatting toolbar, select the data
series name.

i:.z Note

If no data series is selected, then all data series on the chart will be labeled.

3) To open the Data Labels dialog (Figure 99), do one of the following:
— Goto Insert > Data Labels on the Formatting toolbar.
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— First right-click on the selected data series in the chart and select Insert Data Labels
from the context menu. Calc displays data labels with default settings. Then right-click
again and select Format Data Labels from the context menu.

4) Select the options as desired. The options are explained below.
5) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

‘:Q:‘ Tip

Select a data series by clicking once on a column, bar, or other graphic representation
of the data series. Select a single data point by pausing, then clicking again.

Most of the pages in the Data Labels dialog are used in other dialogs and can be readily
understood or easily researched. The exception is the Data Labels tab (Figure 99), which contains
the following options:

Data Labels for Data Series 'Motors' *
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Figure 99: Data Labels tab of the Data Labels dialog

Show value as humber
Displays the numeric value of a data point. When selected, this option activates the Number
format button.

Number format
Opens the Format Number dialog, which is the same as the Numbers tab of the Format Cells
dialog discussed in Chapter 2, Entering, Editing, and Formatting Data. Deselect Source
format to activate options on this page.

Show value as percentage
Displays the percentage value of the data points in each data series. When selected, this
option activates the Percentage format button. Note that the percentage referred to is a
data point’s Y value as a percent of total Y values for a specific X category or value. Thus, in
Figure 100, the February canoe value 9 is 10% of the total February value of 94 (the sum of
9, 31, and 54).
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Percentage format
Opens the Number Format for Percentage Value dialog. Deselect Source format to activate
options on this page.
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Figure 100: Examples of data label options

Show category
Displays the category next to each data point. This option is activated for all data labels in
Figure 100. Thus, all data labels show the month. The text for data labels comes from the
category data series and cannot be changed in the chart. It can only be changed in the
spreadsheet data.

Show legend key
Displays the legend icon for the data series next to each data point. Figure 100 shows the
legend keys for motors and boats, but not for canoes.

Auto text wrap
Wraps data label text if needed.

Separator
Selects what will be used to separate multiple text strings when at least two options above
are selected. In Figure 100, the separator is Semicolon for the canoes data labels, New line
for the motors data labels, and Comma for the boats data labels (with the exception of the
June label, which was modified for better fit). A further option is Space.

Placement
Specifies the placement of data labels relative to the data point representation. In Figure 100,
the placement of data labels is Below for canoes, Above for boats, and Right for motors.
Other available options are Left and Center.

Rotate Text
Sets the text orientation of data labels by using the dial or entering the rotation angle.

Text Direction
Specifies the text direction when Complex Text Layout (CTL) is enabled. (CTL is needed
when the shape or position of characters depends on the context, such as in Arabic script).

Data labels for individual data points

Sometimes it is appropriate to apply data labels to one or a few data points rather than all data
points. This reduces clutter and highlights the most important data.
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Adding a single data label
Insert a data label for a single data point in the following way:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

2) Click the data point once, pause, then click again to select it. (Clicking too quickly opens the
Data Series dialog.)

3) Right-click on the selected data point and select Insert Single Data Label from the context
menu. The data label will have the default settings.

4) Click OK to close the dialog.
5) If desired, click outside the chart to leave edit mode.

Formatting the label for a single data point

To format an existing label for a single data point, follow the directions above but instead of step 3,
do the following to open the Data Label dialog (Figure 99): right-click on the data point and select
Format Single Data Label from the context menu.

The options in the Data Label dialog are described above.

You can also access the Data Label dialog by clicking on the data label, pausing, and then clicking
on it again. Then right-click and select Format Single Data Label from the context menu.

Removing data labels

Remove labels from a single data point, a single data series, or all data points using one of the
methods below.

Before doing any of the following, first select the chart by double-clicking on it to enter edit mode.
The chart should now be surrounded by a gray border. When finished, click OK to close the dialog
and remove the data labels. Then if desired, click outside the chart to leave edit mode.

Removing all data labels from a single data series

Method One
Right-click somewhere in the data series and select Delete Data Labels from the context
menu.

Method Two
1) Do one of the following to open the Data Labels dialog (Figure 99):

— Click somewhere in the data series to select it. Go to Insert > Data Labels on the Menu
bar.

— Inthe Select Chart Element drop-down list of the Formatting toolbar, select the data
labels entry for the required series name and then click the adjacent Format Selection

icon .
— Right-click in the data series and select Format Data Labels from the context menu.
2) Onthe Data Labels tab, deselect all of the options.

Removing a data label from a single data point
1) Click once on the data point, pause, then click again to select it.
2) Right-click to open the context menu and select Delete Single Data Label.

Removing all data labels
1) Make sure that no data label or data series is selected.
2) Goto Insert > Data Labels on the Menu bar.
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3) Onthe Data Labels dialog, deselect all of the options for the data labels to be removed,
then click OK.

Grids

Grid lines or grids divide the intervals along axes to help estimate data point values. Major and
minor grid lines are shown in Figure 101. The darker lines with numbers are major grid lines while
the lighter lines between them are minor grid lines. Note that the Y-axis major grid line is activated

by default.
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Figure 101: Major and minor gridlines for the X and Y axes

Grids are available for all chart types with the exception of pie charts.

Adding/removing grid lines

1) First select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.
2) Do one of the following:

— Goto Insert > Grids on the Menu bar to open the basic Grids dialog (Figure 102).
Select/deselect the check boxes as needed. The Z axis checkbox is only active for a

3D chart.
Major Grids Minor Grids
18 axisi L] axis
¥ axis Ly axis
£ axis £ axis

Figure 102: Basic Grids dialog

— Click the Horizontal Grids icon Jl'-” or Vertical Grids icon |I'I|ﬂ, both located on the
Formatting toolbar. Clicking once turns on the major grid lines. Clicking twice turns on
the minor grid lines as well. Clicking again turns off the grids.

3) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

£7] Note

In the Formatting toolbar, the Horizontal Grids icon -|l|-|] and the Vertical Grids icon

|I'I|ﬂ set grid lines for the Y axis and X axis, respectively. This can be misleading
because both the Y axis and the X axis can be horizontal or vertical, depending on the
type of chart. Thus, for a bar chart, click the Horizontal Grids icon to control the
vertical grids.

Formatting grids

In addition to the basic Grids dialog shown in Figure 102, there is another dialog for formatting
grids. To open the grid formatting dialog:
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1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

2) Go to Format > Grid on the Menu bar and click on the appropriate type of grid to open the
Grid formatting dialog (Figure 103).
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Figure 103: Grid formatting dialog
3) Set formatting options for line style, color, width, and transparency.
4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

Z Note

Use the Scale tab of the Axis dialog to specify the intervals between grid lines. This is
described in “Defining Scales” on page 113.

3D charts

Setting 3D look

Column, bar, pie, and area charts can be displayed as 3D charts. The setting to make a chart 3D is

on the first page of the Chart Wizard. If the chart has already been created, do the following to give
it a 3D look:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

2) Do one of the following:
— Go to Format > Chart Type.

— Click on the Chart Type I Ziconin the Formatting toolbar.

— Right-click in the chart and select the Chart Type option in the context menu.
3) Select 3D Look in the Chart Type dialog.
4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

Setting 3D look | 123



Formatting 3D view
To make changes to a 3D chart, use the 3D View dialog (Figure 104).

Use the 3D View dialog to change the 3D appearance, including perspective, formatting scheme,
and illumination. Note that the chart must already be set to show a 3D look, as described above. To
open the 3D View dialog:

1)

2)

3)

Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

Do one of the following:
— Right-click on the chart and select 3D View from the context menu.

— Go to Format > 3D View.

— Click on the 3D View icon ' in the Formatting toolbar.
Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

This dialog has three tabs, which are explained below.

Perspective Appearance lllumination

X rotation 11 =
¥ rotation 25° =
Z rotation =

Perspective  |20% |5

Figure 104: 3D View dialog — Perspective tab

Rotation and perspective

Some hints for using the Perspective tab (Figure 104) to rotate a 3D chart or change its
perspective view:

Set all angles to 0 for a front view of the chart. Pie charts and donut charts are shown as
circles.

With Right-angled axes enabled, the chart can be rotated only in the X and Y direction;
that is, parallel to the chart borders.

An X value of 90, with Y and Z set to 0, provides a view from the top of the chart. With X set
to —90, the view is from the bottom of the chart.

Rotation is applied in the following order: X axis first, then Y axis, and Z axis last.

When shading is enabled and the chart is rotated, the lights are rotated as if they are fixed
to the chart.

The rotation axes always relate to the page, not to the axes of the chart. This is different
from some other chart programs.

Select the Perspective option to view the chart in central perspective as through a camera
lens (as opposed to using a parallel projection). Set the focal length with the spin box or
type a number in the box. With a 100% setting, a far edge in the chart looks approximately
half as big as a near edge.
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Rotating 3D charts interactively

In addition to using the Perspective tab of the 3D View dialog to rotate 3D charts, rotate 3D charts
interactively in the following way:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

2) Click once on the chart wall to select it, causing round selection handles to appear. The
cursor changes to a rotation icon.

3) Press and hold the left mouse button while dragging in the direction desired. A dashed
outline of the chart is visible to help see how the result will look.

4) Release the mouse button when satisfied.
5) Click outside the chart to exit edit mode.

Appearance

Use the Appearance tab of the 3D View dialog (Figure 105) to modify some aspects of the
appearance of the data in a 3D chart.

Perspective Appearance |llumination

Scheme

Shading
[] Object borders
Rounded edges

Figure 105: 3D View dialog — Appearance tab

First select a scheme from the Scheme drop-down list — Realistic (default) or Simple. The scheme
selected sets the options and light sources. Depending on the scheme selected, not all options
may be available. To create a custom scheme, select or deselect a combination of Shading,
Object borders, and Rounded edges.

Some hints:

* Select Shading to use the Gouraud method for rendering the surface. Otherwise, a flat
method is used. The flat method sets a single color and brightness for each polygon. The
edges are visible but soft gradients and spotlights are not possible. The Gouraud method
applies gradients for a smoother, more realistic look. See the Draw Guide for more
information on the use of shading.

* Select Object borders to draw lines along the edges.
* Select Rounded edges to smooth the edges of boxy shapes.

lllumination
Use the lllumination tab (Figure 106) of the 3D View dialog to control light sources for the 3D view.

Here are the options with some hints:
* Click any of the eight buttons to switch a directed light source on or off.
* The first light source projects a specular light with highlights.

» By default, the second light source is switched on. It is the first of seven normal, uniform
light sources.
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* For the selected light source, select a color from the first drop-down list below the eight light
source buttons. Note that the brightness values of all lights are added together, so use dark
colors when enabling multiple lights.

* The small preview in the dialog shows the effect of repositioning the light source.

» Each selected light source appears as a small colored sphere in the specified color. The
sphere is larger when the light source is actively selected.

» Each light source always points at the middle of the object initially. Move the vertical slider
to adjust the lighting angle. The horizontal slider rotates the light around the object. In
addition, click the light source and drag it to the desired location.

* Click the button in the bottom right corner of the preview to switch the internal illumination
model between a sphere and a cuboid.

* Use the Ambient light drop-down list to define the ambient light, which shines with a uniform
intensity from all directions.

See the Draw Guide for more information on setting the illumination.

Perspective Appearance |llumination

Light source E
r
- Indigo it [
Ambient light
- Dark Gray 1 b [ "

< >

Figure 106: 3D View dialog — Illlumination tab

Trend and mean value lines

Trend lines help show the relationships among scattered data points of a data series. Calc has a
good selection of regression types for creating trend lines: linear, logarithmic, exponential, power,
polynomial, and moving average. Choose the type that comes closest to passing through all of the
points in a data series.

Trend lines can be added to all 2D chart types except for pie, net, and stock charts. When inserted
in the chart, representations of the trend lines are automatically shown in the chart legend.

Z Note

For chart types that use categories for the X axis, such as column, bar, or line charts,
the numbers 1, 2, 3... are used as values for calculating trend lines. By contrast, XY
(scatter) chart types (which include bubble charts) show data rather than categories
along the X axis. Thus, only XY chart types can show meaningful regression equations.

Adding and modifying trend lines

Trend lines can only be added to one data series at a time. To add a trend line to a data series:
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1) Double-click on the chart to enter edit mode. The chart should now be surrounded by a
gray border.

2) Select the data series by doing one of the following:
— Click once on a data series representation such as a bar, column, line, or point.
— Select the data series from the Select Chart Element drop-down list on the Formatting
toolbar.
3) Do one of the following to open the Trend Lines dialog (Figure 107):
— Goto Insert > Trend Lines on the Menu bar.
— Right-click on the data series and select Insert Trend Line from the context menu.

4) Select the type of regression and choose desired options. These are explained below.

5) Click OK to close the dialog and place the trend line in the chart. If desired, click outside the
chart to leave edit mode.

Regression types

By default, x is used for the abscissa variable and f(x) for the ordinate variable. Change the names
under X Variable Name and Y Variable Name on the Trend Line dialog.

Linear trend line
Regression through equation y = a - x+b. Intercept b can be forced and only positive x values
are considered.

Polynomial trend line _
Regression through equation y = Z; (ai - X)). Intercept a can be forced. Degree of polynomial
must be given (at least 2).

Logarithmic trend line
Regression through equation y = a - In(x) + b. Only positive x values are used.

Exponential trend line
Regression through equation y = b - exp(a - x).This equation is equivalent to y = b - m*, with
m = exp(a). Intercept b can be forced. Only positive y values are considered, except if all y
values are negative. In that case, the equation used is y = -b-exp(a - x).

Power trend line
Regression through equation y = b - x2. Only positive y values are considered, except if all y
values are negative. In that case, the equation used isy =-b - x.

Moving Average trend line
Simple moving average for n previous y-values, with n being the period. No equation is
available for this trend line.

Trend line options

Trendline Name
Specifies the name to be used for labeling the equation in the legend; see Figure 108.

Extrapolate Forward/Backward
Specifies the number of units the trend line should be extended forward or back. This only
works for charts that have numeric values along the X axis rather than categories.

Force Intercept
Forces the line to cross the Y axis at the specified value.

Show Equation
Displays the equation in the chart, as shown in Figure 108.
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Show Coefficient of Determination (R?)
Displays the coefficient of determination in the chart. Shown with the polynomial equation in
Figure 108.

X and Y Variable Names
Enables changing the names of X or Y variables for displaying the equation in the chart. The
Show Equation option must be checked for these options to be active.

Type Line
OEDI}ranial
10 Legarithmic Degree |2 v
i Exponentia .- ") Moving Average
T O Exp P O g Awverag
- O Power Period |2 -
Options
Trendline Mame
Extrapolate Forward |0 =
Extrapolate Backward |0 =
[] Force Intercept 0 <

L] show Eguation
[] Show Coefficient of Determination (R
X Variable Mame X

¥ Variable Mame fx)

Figure 107: Trend Line dialog — Type page
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Figure 108: Trend lines showing various equations
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Select a trend line to display information about it in the Status bar, as shown in Figure 109. The
Status bar is normally located at the bottom of the spreadsheet.
&+ Sheet1

Trend line f(x) = - 0.8 x + 52.13 with accuracy R* = 0.05979 selected
Figure 109: Equation information displayed in the Status bar

Formatting trend lines

When inserted, a trend line has the same color as the corresponding data series. To change the
style, color, width, or transparency of a trend line, use the Line tab of the Trend Line dialog (Figure
110). The options are easily understood or researched.

Trend Line for Data Series 'Motors' 4
Type Line
Line Properties
Style:
Colon
[ |#rFD320 -
Width:
oot
Transparency:
0% -

Figure 110: Trend Line dialog — Line tab

Formatting trend line equations

Display the equation in the chart by selecting Show Equation in the Trend Line dialog (Figure
107). Options for the trend line equation include formatting the border around the equation, area
fill, transparency, font, and alignment. The number style can also be specified — this may be quite
useful, especially for specifying the number of decimal places.

To format trend line equations:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

2) Do one of the following to open the Equation dialog:
— Select the equation on the Select Chart Element drop-down list and then click the
Format Selection icon next to it on the Formatting toolbar.

— Click once on the equation to select it then click the Format Selection icon on the
Formatting toolbar.

— Right-click on the equation and select Format Trend Line Equation from the context
menu.

3) Select the desired options on the dialog. The options are self-explanatory or easily
researched. The Numbers tab has the same options as the Numbers tab of the Axis dialog,
Figure 97 on page 117.

4) Click OK to close the dialog.
5) If desired, click outside the chart to leave edit mode.
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Deleting trend lines

1)

2)

3)

Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

Do one of the following:
— Select the trend line and press the Delete key.
— Right-click on the trend line and select Delete Trend Line from the context menu.

If desired, click outside the chart to leave edit mode.

Mean value lines

Mean value lines are a special type of trend line. To create one, Calc calculates the average of a
data series and places a colored line at that value in the chart, as shown in Figure 111. They can
only be created for 2D charts and cannot be created for pie, net, or stock charts.
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40 mm Canoes
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10 t (Motors)
0
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Figure 111: Mean value lines

Inserting mean value lines
For all data series (if no data series is selected, mean value lines are inserted for all data series):

1)

2)
3)

Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

Go to Insert > Mean Value Lines on the Menu bar.
If desired, click outside the chart to leave edit mode.

For a single data series:

1)

2)

3)

4)

Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

Select a data series by doing one of the following:
— Click once somewhere in the data series.

— Select the data series from the Select Chart Element drop-down list on the Formatting
toolbar.

Add the mean value line by doing one of the following:
— Goto Insert > Mean Value Lines on the Menu bar.

— Right-click on the data series and select Insert Mean Value Line from the context
menu.

If desired, click outside the chart to leave edit mode.
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Modifying mean value lines
When inserted, a mean value line has the same color as the corresponding data series. To modify
the style, color, width, and transparency of a mean value line:

1)

2)

3)
4)

Double-click on the chart to enter edit mode. The chart should now be surrounded by a
gray border.

Do one of the following to open the Mean Value Line dialog (the dialog has the same
options as the Line tab of the Trend Line dialog in Figure 110):

— Right-click on the mean value line and select Format Mean Value Line from the
context menu.

— Select the appropriate mean value line from the Select Chart Element drop-down list on

the Formatting bar, then click the Format Selection icon in the Formatting toolbar,
or select Format > Format Selection.

Make desired changes.
Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

Deleting mean value lines

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

2) Do one of the following:
— Select the mean value line and press the Delete key.
— Right-click on the data series and select Delete Mean Value Line from the context

menu.
3) If desired, click outside the chart to leave edit mode.
Error bars

Error bars, shown in Figure 112, can be useful for presenting data that has a known possibility of
error, such as social surveys using a particular sampling method, or for showing the measuring
accuracy of the tool used. They can be created for 2D charts only and cannot be created for pie,
net, or stock charts.
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Figure 112: Error bars showing variance (Canoes), standard
deviation (Boats), and standard error (Motors)
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Inserting error bars

If no data series is selected, X or Y error bars are inserted for all data series. To add error bars for
all data series:

1)

2)

3)
4)

Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

Go to Insert > X Error Bars or Insert > Y Error Bars on the Menu bar to open the Error
Bars dialog (Figure 113).

¥ Error Bars Line

Error Category Error Indicator
O Constant Value + (®) Positive and Megative
O Percentage
@ |Star1dard Deviation |~ . () Positive
(O Cell Range

" (O Megative
Parameters
Positive (+) |0.0 =

Megative (-) |00 =

Same value for both

Figure 113: Error Bars dialog — Error Bars tab

Select the desired options. See below for more information about the options.

Click OK to close the dialog and add the error bars to the chart. If desired, click outside the
chart to leave edit mode.

To insert error bars for a single data series:

1)

2)

3)

4)
5)

Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

Do one of the following to select the data series:
— Click once on a bar, column, line, or other graphical representation in the data series.

— Select the data series from the Select Chart Element drop-down list on the Formatting
Toolbar.

Do one of the following to open the Error Bars dialog (Figure 113):
— GotoInsert > X Error Bars or Insert > Y Error Bars on the Menu bar.

— Right-click on the data series and select Insert X Error Bars or Insert Y Error Bars
from the context menu.

Select the desired options. See below for more information about these options.

Click OK to close the dialog and add the error bars to the chart. If desired, click outside the
chart to leave edit mode.

Error bar dialog options

Under Error Category, only one of the following options can be selected at a time.

Constant Value — shows the error as constant positive and/or negative value(s). Specify
these values in the Parameters section.
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Percentage — shows the error as a percentage of the data points. Specify this in the
Parameters section.
The drop-down list has four measures of the error value:

— Standard Error

— Variance

— Standard Deviation

— Error Margin — uses the value for the error margin that is specified in the Parameters
section.

Cell Range — uses error values defined in a range of cells. Specify the range in the
Parameters section.

Under Parameters, specify positive and negative values or ranges for the error bars. Constant
Value, Percentage, Error Margin, or Cell Range must be checked for these options to be active.

Under Error Indicator, select whether the error graphic shows both positive and negative errors, or
only positive errors, or only negative errors.

Modifying error bars

Error bars can only be changed one data series at a time, using the Error Bars dialog (Figure 113).
Do one of the following to open the Error Bars dialog:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

2) Do one of the following to open the Error Bars dialog:

— Click once on the data series to select it, then go to Insert > X Error Bars or Insert > Y
Error Bars on the Menu bar.

— Select the error bars for the specific data series from the Select Chart Element drop-
down list on the Formatting toolbar. Then go to Format > Format Selection or click the

Format Selection icon on the Formatting toolbar.

— Right-click on the data series and select Format X Error Bars or Format Y Error Bars
from the context menu.

3) Select the desired options. See below for more information about these options.

4) Click OK to close the dialog and update the error bars for the selected series. If desired,
click outside the chart to leave edit mode.

If needed, modify the appearance of the error bars on the Line tab of the Error Bars dialog.

Deleting error bars
To delete error bars for all data series:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

2) Goto Insert > X Error Bars or Insert > Y Error Bars on the Menu bar to open the Error
Bars dialog (Figure 113). When no data series has been selected, the dialog also includes
the option None under Error Category.

3) Select None.

4) Click OK to close the dialog and delete the error bars. If desired, click outside the chart to
leave edit mode.

To delete error bars for a single data series, follow the same steps as above but instead of steps 2
and 3, right-click on the data series and select Delete X Error Bars or Delete Y Error Bars from
the context menu.
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Adding drawing objects to charts

Use the Drawing toolbar to add shapes such as lines, rectangles, circles, text objects, or more
complex shapes such as symbols or block arrows. Use additional shapes to add explanatory
notes, highlight places on a chart, or even hide certain data or text.

Open the Drawing toolbar by going to View > Toolbars > Drawing. Note that it can be moved
around the workspace as needed. For more information on using the Drawing toolbar and drawing
shapes, see Chapter 5, Using Graphics, as well as the Draw Guide.

The Drawing toolbar appears as follows when the chart is in edit mode (by clicking on it twice).
00 Tip

To place arrows, text, or other drawing objects in a chart, be sure that the chart is in
edit mode. Otherwise, an object will not be connected to the chart and will not be
moved with it.

1) (2) (3)(4){5)(6) {(7;:8)9; 10 11 12) 13 14

S IN OO SRARAOO-O-=-B-0-%-

1. Select 6. Freeform Line 11. Block Arrows

2. Insert Line 7. Insert Text Box 12. Flowchart

3. Line Ends with Arrow 8. Callouts 13. Callouts

4. Insert Rectangle 9. Basic Shapes 14. Stars and
Banners

5. Insert Ellipse 10. Symbol Shapes

Figure 114: Drawing toolbar when chart is placed in edit mode (by clicking twice on the chart).

Most of these options are self-evident or can be readily researched, especially by referring to the
Draw Guide. Clicking on the icon for an option changes the cursor’s appearance, depending on the
option. Click and drag the cursor to create the desired drawing object in the chart. Information that
may be helpful for charts follows.

Insert Line
Draws a straight line where dragged.

£7] Note

If you draw a line in the spreadsheet (outside any chart), you can hold down Shift while
dragging to constrain angles of the line to multiples of 45 degrees. This facility is not
applicable when inserting a line on a chart.

Write on the line by double-clicking the line and typing or pasting text. If the text is too low,
press Enter to raise it above the line.

Insert Text Box
Draws a text box with horizontal text direction. To place the text at an angle, click once on the
text box to select it, right-click, and select Position and Size from the context menu. Specify

the angle on the Rotation tab.
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Callouts

Draws a line that ends in a graphic in which text can be placed. Use a callout to describe or
draw attention to a specific point or area. Double-click the callout to write text in it. In Figure
114, Callouts option 8 creates a default callout while option 13 opens a tool palette of callout

styles.

Clicking the down arrows next to the six options on the right in Figure 114 opens the tool palettes
shown in Figure 115.
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Figure 115: Tool palettes that can be opened from the Drawing toolbar.

Resizing, moving, and positioning charts

To resize or move a chart, click it once to put it in selection mode. Resize or move a chart in two
ways: interactively, or by using the Position and Size dialog. Combining both methods may be
useful. Position a chart interactively for quick and easy changes, then use the Position and Size
dialog for precise sizing and positioning.

Changing interactively

Resizing
To resize a chart interactively:
1) Click once on the chart to select it. Square selection handles appear around the border of
the chart.

2) Click and drag one of the selection handles. The cursor indicates the direction to increase
or decrease the chart size. Clicking and dragging a corner preserves the horizontal to
vertical size ratio.
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3) When finished, click outside the chart to leave selection mode.

Moving
Move a chart interactively using one of two methods:

For small moves
1) Click once on the chart to select it. Square selection handles appear around the border of
the chart.

2) Press Alt + an arrow key to move the chart one pixel at a time.
3) When finished, click outside the chart to leave selection mode.

For larger moves
1) Click once on the chart to select it. Square selection handles appear around the border of
the chart.

2) Hover the cursor anywhere over the chart until it changes to a move cursor (shape depends
on computer setup).

3) Click and drag the chart to its new location.
4) Release the mouse button when the chart is in the required position.
5) When finished, click outside the chart to leave selection mode.

Position and Size dialog

Position and Size Rotation Slant & Corner Radius
Position
Position X: | 11.15" = Easze point:
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Size

Width: 741 = Base point:

. = & ~ -
Height: 404" = | |
Keep ratio T - f|'-
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Protect Adapt
[ Position Fit width to text
[] Size Fit height to text

Figure 116: Position and Size dialog — Position and Size tab

The Position and Size dialog contains options for defining the position of the chart on the page,
specifying its size, and rotating, slanting, or rounding the corners of a chart.

Z Note

In addition to charts, the Position and Size dialog can also be used to modify and
position other graphic elements, such as those available on the Drawing toolbar.
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To resize or move a chart using the Position and Size dialog:

1) Click once on the chart to select it. Square selection handles appear around the border of
the chart.

2) Right-click and select Position and Size from the context menu to open the Position and
Size dialog (Figure 116).

3) Select the desired options on the Position and Size, Rotation, and Slant & Corner Radius
tabs on this dialog. See below for further information about the options on these tabs.

4) Click OK to close the dialog and save changes.
5) When finished, click outside the chart to leave selection mode.

Click one of the points in the Base point graphic corresponding to the location to use for anchoring
either the position of the chart or its size.

Note that either the position or the size can be protected from unwanted changes by clicking the
appropriate box in the Protect section. Either or both option(s) selected will remain active after the
dialog is closed. By contrast, Calc resets the base point to the default position after the dialog is
closed.

Position and Size
The options available on the Position and Size tab (Figure 116) are as follows:

Position
Determines the location of the chart on the page. The position of a chart is coordinated
relative to a fixed point (the base point). By default, this base point is located at the upper left
of a chart. To make positioning of a chart simpler, the base point can be temporarily
changed.

— Position X — specifies the horizontal location of the chart relative to the base point.
— Position Y — specifies the vertical location of the chart relative to the base point.
— Base point — specifies a temporary base point for the chart.

Size
Specifies the amount by which to resize the selected chart with respect to the selected base
point.
— Width — sets a width for the selected object.
— Height — sets a height for the selected object.
— Keep ratio — maintains proportions between width and height when resizing the chart.
— Base point — determines the directions in which the chart size will be increased or
decreased.
Protect

Prevents unintended changes to the position or the size of the chart.
— Position — prevents unintentionally moving the chart.
— Size — prevents unintentionally resizing the chart.

Adapt
Specifies if the size should be adjusted to fit the size of entered text. Availability of these
options depends on the context.

— Fit width to text — expands the width of the object to the width of the text, if the object
is smaller than the text.

— Fit height to text — expands the height of the object to the height of the text, if the
object is smaller than the text.
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Rotation
The options for the Rotation tab (Figure 117) are as follows:

Pasition and Size *
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Figure 117: Position and size dialog — Rotation tab

Pivot Point
The chart can be rotated around a pivot point. The default pivot point is at the center of the
chart. Note that if there is not enough room to rotate the chart, it could be rotated off of the
page.

— Position X — specifies the horizontal distance from the left edge of the page to the pivot
point.

— Position Y — specifies the vertical distance from the top edge of the page to the pivot
point.

— Default settings — sets the location of the pivot point. The pivot point can be temporarily
changed. But when the dialog is opened again, the pivot point will be the default
location at the center of the chart and the X and Y positions will reflect the default
location.

Rotation Angle
Specifies the number of degrees that the chart is rotated.

— Angle — shows the number of degrees of rotation (in the range 0 to 359 degrees). The
number can be entered directly or it can be set using the indicator labeled Default
settings.

— Default settings — graphically shows the rotation angle. The angle can be set by clicking
and dragging the indicator. The humber of degrees rotated is shown in the Angle box.

Slant & Corner Radius
The options for the Slant & Corner Radius tab (Figure 118) are as follows:

Corner Radius
This option is not available for charts.

Slant
Slants the chart along an axis. Specify the angle of the axis (in the range -89° to +89°).
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Control Points
These options are not available for charts.

Position and Size Rotation Slant & Corner Radius

Corner Radius Slant
Badius - Angle:  |0.00° -
Control Point 1 Control Point 2

Figure 118: Position and Size dialog — Slant and Corner Radius tab

Selecting multiple charts

Select multiple charts by clicking once on the first chart then pressing Shift while clicking on
additional charts. An invisible selection rectangle covers all of the selected charts and selection
handles appear at the corners and midway between corners. The multiple charts are now treated
as a single object and actions such as the following can be conducted.

e Cut and paste or drag them to new locations.
* Use the Position and Size dialog described in the previous section.

* Use the Drawing Object Properties toolbar to align all of the charts, format the outer
borders, or anchor the charts to the same cell or page.

Changing overall appearance of charts

When a chart is selected (by clicking on it once) it can be formatted as an object. The Drawing
Object Properties toolbar (Figure 119) usually appears below the Standard toolbar (but the location
depends on setup) and shows tools available for all objects, including charts.

Most of the options are self-evident or can be easily researched. Please refer to Chapter 5, Using
Graphics, in this guide and the Draw Guide for further information. Following are a few tips for
using these tools with charts.

Anchor
Connects a chart to either remain in the same position on a page or to move with a cell
(when rows and columns are inserted or deleted). When To cell (resize with cell) is chosen,
the chart or object increases or decreases in size when the cell is made larger or smaller.

Align
Click the icon to open options for aligning multiple charts horizontally (left, centered, right) or
vertically (top, center, or bottom). This option is only active when two or more charts (or other
objects) are selected.

Bring to Front/Forward One/Back Onel/Send to Back
Stacks charts or other objects in front of or behind other objects.
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Figure 119: Drawing Object Properties toolbar that appears when chart is selected

To Foreground/To Background
Places charts or stacks of objects in either the foreground or the background. In Calc, objects
in the background are behind the cell grid and may be difficult to select. Use the Select tool
(arrow icon) on the Drawing toolbar (Figure 114) to select them.

Line Style/Line Width/Line Color
Formats the outer borders of charts.

Area Style/Filling and Fill Color
Colors objects such as arrows, shapes, and callouts. For charts, use the fill options available
in edit mode.

Arrow Style
Specifies the appearance of line arrows and lines. Does not apply to the block arrows shown
in Figures 114 and 115.

Rotate
Rotates the chart around a base point. When selected, places round rotation handles at each
corner. Move these to rotate the chart. Move the small circle in the center of the chart to
change the base point. Move the handles midway between the corners to slant the chart or
other object.

Points
Changes the shape of curved objects. Move the points to shape curves created with the
Curve tool on the Drawing toolbar.

Group
Groups or ungroups two or more objects. When grouped, the objects can be moved together
and global changes can be applied to them. From left to right, the four icons are Group,
Enter Group, Exit Group, and Ungroup.

Copying, exporting, and deleting charts

Copying charts in the same spreadsheet document

When a chart is copied, it retains a connection to the source data it is built on as long as it is in the
same document. This means that changes made to the source data will be reflected in the chart.

Copying and pasting the chart is easy. Just click the chart once to select it, then either press
Ctrl+C, or right-click on the chart and select Copy from the context menu, or click the Copy icon
on the Standard toolbar, or select Edit > Copy. To paste the chart in the desired location, press
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Ctrl+V, or right-click and select Paste from the context menu, or click the Paste icon in the
Standard toolbar, or select Edit > Paste.

Copying to another LibreOffice document

When a chart is copied and pasted into another LibreOffice document, any connection to the data it
is based on is lost. The data is kept with the chart and is now called a data table rather than a data
range. Figure 120 shows an example of this internal data table.

Z Note

A copied chart links to or retains its data only when pasted into a LibreOffice
document. To retain data or links outside LibreOffice, use embedding or linking, as
explained in Chapter 10, Linking Data.

Keeping original data

If the goal is to use the original data for the chart, follow the same procedure as above to copy and
paste the chart to another document. Nothing more needs to be done.

Modifying original data

If the original data for the chart needs to be modified, do the following:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be
surrounded by a gray border.

2) Right-click on the chart and select Data Table to open the data table shown in Figure 120.

B 58 B8 5% F

[._ Canoes ll_ Boats ll_ Motors
Categories | Y¥-WValues | Y¥-Values | Y¥-Values

1 |Jan 12 23 47

2 |Feb ) E) 54

3 [Mar 14 27 56

4 |Apr 17 28 43

5 [May 13 19 39

& [Jun 8 27 52

Figure 120: Data table when a chart is copied into another document

3) Modify the data as desired. In addition to changing numbers in the data, use options to
insert, move, or delete columns and rows.

4) Click OK to close the dialog.
5) If desired, click outside the chart to leave edit mode.

Dragging replacement data

If the chart is still in Calc and replacement data is in the same spreadsheet, select and drag the
new data onto the chart. This is described in “Replacing data by dragging” on page 104.
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Z Note

Calc does not provide a direct way to save chart settings for creating another chart in
LibreOffice. Here are three options for using the same chart settings: 1) copy and
paste the chart into another file; 2) save the file containing the chart as a new file; and
3) save the chart in a template. Depending on the method used, create a new chart by
modifying either the data range or the data table.

Exporting chart images

Charts can be exported in a variety of image formats for use in other documents. File types include
BMP, EMF, EPS, GIF, JPEG, PDF, PNG, SVG, SVM, TIFF, and WMF.

To export a chart in an image format:

1) Click once on the chart to select it. Square selection handles appear around the border of
the chart.

2) Right-click on the selected chart and select Export as Image from the context menu to
open the Save as Image dialog.

3) Inthe dialog, type a name for the graphic file, select the location for saving the file, and
select the desired graphic format.

4) Click Save and an image of the chart will be exported to the location specified.

Deleting charts

To delete a chart, simply click it once to select it. Square selection handles appear on the borders
of the chart. Then press Delete.

Gallery of chart types

While data can be presented using a variety of charts, focus on the message of the chart to
determine which type of chart to use. The following sections present examples of the chart types
that Calc provides, with some notes on the uses of each one.

Column charts

A column chart shows vertical bars, with the height of each bar proportional to its value. The X axis
shows categories and the Y axis shows the value for each category.

Column charts are commonly used for data that show trends over time. They are best for a
relatively small number of data points. It is the default chart type provided by Calc, as it is one of
the most useful and easy to understand. For a larger time series, a line chart would be more
appropriate.

The column chart type has three variants, with a preview pane for each variant as shown in Figure
121. When a preview is clicked, its borders are highlighted and the name appears below. The 2D
variants are:

Normal
Shows all data values belonging to a category next to each other. The main focus is on the
individual absolute values, compared to every other value.

Stacked
Shows the data values of each category on top of each other. The main focus is the overall
category value and the individual contribution of each value within the category.
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Percent stacked
Shows the relative percentage of each data value with regard to the total of its category. The
main focus is the relative contribution of each value to the category total. (Contrary to the
preview picture in Figure 121, the values are stacked, not next to each other.)

Chart Type >

L Bar
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Shape

Figure 121: Chart Type dialog — Column

Additional options for creating column charts are:

3D Look
When this box is checked, two options become available in the drop-down list:

— Realistic — tries to give the best 3D look.
— Simple - tries to mimic the chart view of other products.

When you check the 3D Look box, a fourth chart variant becomes available called Deep.
This shows the data values of each category lined up, one behind the other.

Shape
Gives options for the shape of the columns in 3D charts. The choices are: Bar, Cylinder,
Cone, and Pyramid.

Bar charts

A bar chart is like a column chart that has been shifted 90 degrees. It shows horizontal bars rather
than vertical columns. In contrast to some other chart types, the Y axis is horizontal and the X axis
is vertical. The Chart Type dialog for a bar chart is essentially the same as for a column chart,
described above.

Bar charts can have an immediate visual impact when time is not an important factor — for
example, when comparing the popularity of a few products in a marketplace. They may be
preferred to column charts when the category names are long or there are a significant number of
categories.

In the examples in Figure 122 below:

* To make the first chart after using the Chart Wizard, go to Insert > Grids, deselect Y axis,
and choose Insert > Mean Value Lines. Right-click each mean value line and select
Format Mean Value Line to increase the width of the lines. Create rectangles from the
Drawing toolbar to cover the mean value line entries in the legend. Make them white by
right-clicking and selecting Line and then Area.

e The second chart is a 3D chart created with a simple border and cylinder shape. The chart
area is rotated (described under “Rotation and perspective” on page 124).
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* The third chart eliminates the legend by using labels with the names of the companies on
the Y axis. Whereas the first two charts treat the data as separate data series, this chart
treats the data as one data series in order to have category labels for the X axis. Rather
than colors, a colored horizontal hatch pattern is used for the bars.
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Figure 122: Bar chart examples

Pie charts

A pie chart shows values as circular sections of a circle. The area of each section is proportional to
its value.

Pie charts are excellent for comparing proportions — comparisons of departmental spending, for
example. They work best with smaller numbers of values, up to about half a dozen; more than this
and the visual impact begins to fade.

Chart Type pd
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Figure 123: Chart Type dialog - Pie
Pie variant options, shown in Figure 123, are:

Normal
Shows values as sections of a complete pie, with the option of separating out individual
pieces. Click the outer edge of a section to separate it from the remaining pie or to join it

back.

Exploded Pie
Shows all of the sections separated from each other. Click and drag any section to move it

along radial lines from the pie center.

Donut
Shows multiple data series. Each data series is shown as one donut shape with a hole
inside, where the next data series can be shown. Click and drag an outer section to move it
along radial lines from the donut center.
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Exploded Donut
Shows the outer sections already separated from the remaining donut. Click and drag an
outer section to move it along radial lines from the center.

The Chart Wizard initially guesses how the data should be presented in the chart. Adjust this on
the Data Range and Data Series pages of the wizard or by using the Data Ranges dialog.

You can do some interesting things with a pie chart, especially if you make it into a 3D chart. It can
be tilted, given shadows, and generally turned into a work of art. Just do not clutter it so much that
the message is lost, and be careful that tilting does not distort the relative sizes of the segments.

You can choose in the Chart Wizard to use the exploded pie variant, but this option explodes all of
the pieces (contrary to the preview graphic in Figure 123). If the aim is to accentuate just one piece
of the pie, separate out a piece by carefully highlighting it and dragging it out of the group. After
this, the chart area may need to be enlarged to regain the original size of the pieces.

Budget Estimates Budget Estimates
12%

Traw el $40.000
Utlbes $15.000

o Travel

M Salariee $150,000  14% i
Supplies £50,000 I Supplies

Eruipment
® Sdaries

Equipment £90,000

Figure 124: Pie chart examples

The effects achieved in Figure 124 are explained below.

2D pie chart with one section of the pie exploded
Select Insert > Legend and deselect the Display legend box. Select Insert > Data Labels.
Select Show value as humber and also Show category. Click the edge of the section (the
section will have highlight squares to mark it), and drag it out from the rest of the sections.
The sections will decrease in size. If needed, highlight the chart wall and drag it at a corner to
increase the size.

3D pie chart, exploded variant, with realistic schema and various fill effects
Go to Format > Chart Type and select 3D Look. Go to Insert > Data Labels and select
Show value as percentage. Then carefully select each section so that it has a wire frame
highlight. Right-click and select Format Data Point to get the Data Point dialog. Choose the
Area tab. The illustration in Figure 124 shows one section formatted with bitmap, one with a
radial gradient, one with 50% transparency, and one with a pattern.

Donut and exploded donut variants, shown in Figure 125, are used to display two set of related
information, such as two years of financial data. This variant can be misleading for comparing
numeric data, since inner circles are necessarily smaller. For more variety, use a 3D look.
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Figure 125: Donut chart examples

Area charts

Like a line or column chart, an area chart shows values as points on the Y axis and categories on
the X axis. The Y values of each data series are connected by lines and the areas below the lines
are colored.

Area charts emphasize volumes of change from one category to the next. They have greater visual
impact than line charts, but the data used will make a difference.

NEL- R

Mormal Deep

Figure 126: Chart Type dialog - 2D and 3D Area

Area chart variants, shown in Figure 126, are:

Normal
Plots all data as absolute Y values. It first plots the area of the last data series in the data
range, then the next to last, and so on. Finally the first data series is drawn over the other
data. Thus, higher values in the first data series will hide lower values of later data series.

Deep
When 3D Look is selected, this variant shows the first data series in front, with subsequent
data series behind.

Stacked
Stacks cumulative values on top of each other. This ensures that all values are visible, and
no data set is hidden by others. However, the Y values no longer represent absolute values,
except for the first data series, which is shown at the bottom of the stacked areas.

Percent Stacked
Stacks cumulative values on each other and also scales the values as percentages of the
category total.
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Figure 127: Area chart examples
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Normal area charts

Area charts are sometimes tricky to create. Using transparency values may be helpful. To create
the charts in Figure 127, first set up the basic chart using the Chart Wizard. The chart on the left
shows the result. Because of the data overlap, some of it is missing behind the first data series.
This is probably not desirable. The other examples are better solutions.

To create the chart in the center:

After deselecting the Y axis grid, right-click on each data series in turn and select Format
Data Series. On the Transparency tab, set Transparency to 50%. The transparency makes it
easy to see the data hidden behind the first data series.

To create the chart on the right:

After doing the steps above, right-click and select Chart Type. Select the 3D Look option
and select Realistic from the drop-down list. Rotate the chart area using the 3D View dialog.
Instead of a legend, use labels on the Z axis.

Stacked area charts

Other ways of visualizing the same data series are the stacked area chart and the percentage
stacked area chart (Figure 128). In the first example, each point in a data series is added to the
other data series to show the total area. The second example shows a percentage stacked chart,
showing each value in the series as a percentage of the whole.
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Figure 128: Stacked and percentage stacked area charts
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Line charts

Aline chart is useful for showing trends or changes over time when you want to emphasize
continuity. Values are shown as points on the Y axis and the X axis shows categories — often time
series data. The Y values of each data series may be connected by a line.
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g Note

The difference between line charts, described in this section, and XY (scatter) charts,
described in the next section, is this: line charts show categories along the X axis while
XY (scatter) charts show values along the X axis.

As shown in Figure 129, four variants are available:

Points Only
Plots only points.

Points and Lines
Plots points and connects points of the same data series by a line.

Lines Only
Plots only lines.

3D Lines
Connects points of the same data series by a 3D line.
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Figure 129: Chart Type dialog — Line

When Stack series is selected, it shows cumulative Y values above each other. The options are:

* Ontop — places the value of each data series above the others. The Y values no longer
represent absolute values, except for the first data series, which appears at the bottom of
the chart. This is the default setting.

* Percent — scales the Y values as percentages of the category total.
The Line type drop-down list has three options that determine how the data points are connected:

Straight
Draws straight lines between the points.

Smooth
Connects the points with curves instead of lines. When this option is selected, click

Properties to open the Smooth Lines dialog (Figure 130) and further specify the curves.

For smooth lines, there are two line type options: Cubic spline or B-spline. These are
mathematical models that join together segments of polynomials to display the curves. For B-
spline lines, there is an option to set the degree of the polynomials. Select a higher resolution
for smoother curves.
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Figure 130: Smooth Lines dialog

Stepped
Connects points with horizontal and vertical lines only. Click Properties to further specify the
formatting of the lines (Figure 131). The options are self-explanatory.
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Figure 131: Stepped Lines dialog

Things to do with lines: thicken them, smooth the contours, just use points, or make them 3D.
However, 3D lines can confuse the viewer, so just using a thicker line often works better. Figure
132 shows some examples of line charts.
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Figure 132: Line chart examples

Scatter or XY charts

In contrast to line, column, and bar charts, which contain numeric values on the Y axis and
categories on the X axis, scatter or XY charts contain values along both axes. They are quite
useful, especially for understanding relationships among data that are precise and complex. An XY
chart may contain more than one data series and can perform many tasks, such as generating a
parameter curve or drawing the graph of a function.
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‘:@:‘ Tip

When plotting time on the X axis, make sure that it is not text and is written in the
correct format for your locale. For example, instead of January, use a format such as
1/1/2022. Check locale formats at Tools > Options> Language Settings >
Languages > Date acceptance patterns.

XY charts are most frequently used to explore the statistical associations among quantitative
variables. There is often a constant value against which to compare the data — for example,
weather data, reactions under different acidity levels, or conditions at various altitudes.

‘::‘ Tip

By custom, if one of the variables is either controlled by an experimenter or it changes
consistently (such as time) it is considered an independent variable and plotted on the
X axis.

XY chart variants
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Figure 133: Chart Type dialog — XY (Scatter)

As shown in Figure 133, when the XY (Scatter) chart type is selected, the following variants are
available:

Points Only
Shows an icon for each data point. Calc uses default icons with different forms and colors for
each data series. The default colors are set in Tools > Options > Charts > Default Colors.
Changing the colors and icons is discussed in “Lines, areas, and data point icons” on page
109.

Lines Only
Draws straight lines from one data point to the next. The data points are not indicated by
icons. By default, the drawing order is the same as the order in the data series, but note the
option to sort by X values.

Points and Lines
Shows both points and lines.

3D Lines
Makes the lines look like tapes. The data points are not shown by icons. In the finished chart,
use the 3D View dialog to set properties like illumination and angle of view.

150 | Gallery of chart types



The following options may appear:

Sort by X values
Draws the lines in order of the X values. This can be helpful if the data series on the
spreadsheet is not in numeric order.

Line type - Straight
Draws straight line segments.

Line type — Smooth
Draws curves instead of straight line segments. Click Properties to set details for the curves.

— Cubic spline interpolates the data points with polynomials of degree 3. The transitions
between the polynomial pieces are smooth, having the same slope and curvature.

— Resolution determines how many line segments are calculated to draw a piece of
polynomial between two data points. A value in the range 1 to 100. Click any data point
to see the intermediate points.

— B-spline uses parametric, interpolating B-spline curves. The curves are built from
polynomials. Degree of polynomials sets the degree of these polynomials. A value in
the range 1 to 15.

Line type - Stepped
Uses only horizontal and vertical lines. Click Properties to set details for the stepped lines.

After a scatter chart is created, its default settings can be changed in ways such as the following.
Be sure to first double-click the chart to enter edit mode. Depending on the option, a data point or
data series may also need to be double-clicked.

* Line styles and icons — double-click or right-click on a data series in the chart to open the
Data Series dialog. See “Lines, areas, and data point icons” on page 109 for further
information.

» Error bars — For 2D charts, select Insert > Y Error Bars or X Error Bars to enable the
display of error bars. See “Error bars” on page 131 for further information.

* Mean Value Lines and Trend Line — Enable the display of mean value lines and trend
lines with commands on the Insert menu. See “Trend and mean value lines” on page 126
for further information.

Examples of XY or scatter charts

By default, the first column or row of data (depending on whether the data is arranged in columns
or rows) is represented on the X axis. The rest of the rows of data are then compared against the
first row of data.

Scatter charts may surprise those unfamiliar with how they work. This can be seen in examples
using the following data (Figure 134), which is organized with data series in rows.

The data range for the chart on the left in Figure 134 includes the cells containing the months.
However, the months do not appear on the chart because only values can be used in XY charts
and Calc substitutes cardinal numbers for them.

The data range for the chart on the right does not include the cells containing the months. Calc
assumes that the first row (or column) of data contains values for the X axis. The Y values of the
other data series are paired with each of those X values. This means that there are no data points
for the Japanese yen but each of the other currencies are shown in comparison to the yen, since it
supplies the X values.
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Figure 134: XY (Scatter) chart examples

Bubble charts

A bubble chart is a variation of a scatter chart that can show three variables in two dimensions. The
data points are shown with bubbles. Two variables are plotted along the X and Y axes, while the
third variable is represented by the relative size of the bubbles. These charts are often used to
present financial data or social/demographic data.

One or more data series can be included in a single chart. The data series dialog for a bubble chart
has an entry to define the data range that determines the size of the bubbles.

It may be necessary to build a bubble chart manually in the data series page of the Chart Wizard.
Figure 135 shows how the data ranges can be set for a bubble chart.
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Figure 135: Data series entries for bubble chart

The chart in Figure 136 is based on the data in Figure 135. To format the chart, the data series are
50% transparent with a radial gradient. The data labels are formatted to be numbers in the center
of the data points (bubbles).

g Note

Remember that bubble charts require numeric data. If the data series for the X axis
contains text (or dates not formatted as numbers) cardinal numbers will be used for
axis labels.
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Figure 136: Bubble chart example

Net charts

@ John
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Net charts are also known as spider, polar, or radar charts. They display data values as points on
radial spokes, with each spoke representing a variable. They compare data that are not time
series, but show different circumstances, such as variables in a scientific experiment. They are

especially useful for displaying clusters and outliers.

Figure 137 shows an example of a simple net chart. The radial spokes of the net chart are
equivalent to the Y-axes of other charts. All data values are shown with the same scale, so all data

values should have about the same magnitude.
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Figure 137: Simple net chart example

Generally, between three and eight axes are best; any more and this type of chart becomes
confusing. Before and after values can be plotted on the same chart, or perhaps expected and real

results, so that differences can be compared.
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Figure 138: Chart Type dialog - Net
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Figure 138 shows the options for creating a net chart. These are similar to those for area and line
charts, described above. However, keep in mind that area increases as the square of the distance
along the linear spokes. Therefore, net charts can distort the areas representing the data. Be
especially careful about choosing to stack data series. In this case, successive data series show
increasingly large areas that are not proportional to their values.

Figure 139 shows examples of two types of net charts.

* The example on the left is a filled net chart. The color of one of the data series is 50%
transparent. Partial transparency is often best for showing all of the series.

* The example on the right is a net chart with lines and points. The data point icons are taken
from the Gallery and have a 3D look.

Figure 139: Filled net chart and net chart with 3D data point icons.

Stock charts

A stock chart illustrates the market trends for stock and shares by giving opening price, bottom
price, top price, and closing price. The transaction volume can also be shown and the X axis
usually represents a time series.

When setting up a stock chart in the Chart Wizard, the data should be arranged as shown in Figure
140. It specifies which columns should be the opening, low, high, and closing prices of the stock as
well as the transaction volume. However, manual adjustments may still be needed when defining
the data series.

Acme Ajax
Volume Open Low | High | Close Volume Open Low | High | Close

Monday 2500 | 20 15 25 17 1700 15 10 20 17
Tuesday 3500 32 22 37 30 2700 25 5 25 16
Wednesday 1000 25b 15 17 17 4100 14 7 17 10
Thursday 2200 40 30 47 35 3300 20 12 26 19
Friday 4600 27 20 32 3l 3500 28 16 32 21
Figure 140: Example data arrangement for stock charts

A stock chart organizes data series in two basic ways. The first way is not used in other chart
types. In this case, the open, low, high, and closing values of a row create one data unit in the
chart and one data series consists of several rows containing such data units. The columns
containing transaction volumes are the second way used to organize data series. This is the
familiar way used in other chart types.

Thus, Figure 140 shows the data for four data series: 1) the price data for Acme, which contains
columns for open, low, high, and closing prices, 2) the price data for Ajax, which contains columns
for open, low, high, and closing prices, 3) the Acme transaction volume, which is one column, and
4) the Ajax transaction volume, which is one column.
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Stock chart variants

The Chart Wizard offers four stock chart variants, as shown in Figure 141. Note that some of them
do not use all of the data columns.

ll_ Column

L Bar F oy vy
e Area |

Ii Line

|+ ¥ (Scatter) Stock Chart 2
|~ Bubble

K Net

[._ Column and Line

Figure 141: Chart Type dialog - Stock
The data table in Figure 140 is used to illustrate the variants, which are as follows:

Stock Chart 1
When based only on data in the low and high columns, this variant shows the distance
between bottom price (low) and top price (high) with a vertical line. When the closing column
is also included (Figure 142), it shows an additional horizontal mark for the closing price.

5 Stock Chart Variant 1
45
40
35

30
25 — TR

"
20 I_ o
15 -

10
5
0

Price

Monday Tuesday  WWednesday  Thursday Frday

Figure 142: Stock chart variant 1 showing low, high, and closing prices

Stock Chart 2
Based on the open, low, high, and close columns, this variant generates the traditional
candlestick chart (Figure 143). It shows a vertical line between the bottom and top prices and
adds a rectangle in front that shows the range between the opening and closing prices. For
rising values (the opening price is lower than the closing price), the fill color is white. For
falling values, the fill color is black.
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£ Stock Chart Variant 2
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Figure 143: Stock chart variant 2 showing low and high prices as well as the
range between opening and closing prices

Stock Chart 3
Using the low, high, and close columns, draws a chart similar to Stock Chart 1 but with
additional columns for transaction volume. As shown in Figure 144, a secondary Y axis
enables both transaction volume and price to be shown on vertical axes.

Stock Chart Variant 3

5000 50
4500
4000
3500

3000 l 30
2500 25
200 I L 20
150 I- 15
100K L 0
500 l 5
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Monday Tuesday  Wednesday Thursday Frday
m Acme Volume Ajax Volume Acme Price s Ajax Price

Figure 144: Stock chart variant 3 showing low, high, and closing prices as well
as transaction volumes

i:.z Note

Variants 3 and 4 automatically align data to the secondary Y axis. For more
information about a secondary Y axis, see “Aligning data to secondary Y axis” on page
106.

Price
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=

Stock Chart 4
Based on all five data columns (volume, open, low, high, and close), this variant combines
Stock Chart 2 with a column chart for the transaction volume (Figure 145).
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Stock Chart Variant 4
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Figure 145: Stock chart variant 4 showing opening, low, high, and closing prices as
well as transaction volumes.

Column and line charts

A column and line chart is useful for displaying two or more distinct but related data series, such as
sales over time (columns) and profit margin trends (lines). It could also show constant minimum
and maximum lines, such as used in medical testing or quality control.

Specify in the Chart Type dialog whether there will be 1 or 2 lines. By default, the first column or
row of data is categories and the last columns or rows of data are lines.

Choose between two variants:

Columns and Lines
As seen in Figure 146, the columns are drawn side by side to easily compare their values.

Two Quarters of Profit Growth
400 35

350 -8 &30

L 25 . Acme Sales
250 4 1 20 s United Sales

& 2008 % — Acme Profits
@ 1590 15 & e United Profits
_— 10
50 -8 £ 5
0 0

Jan Feb Mar Apr May Jun
Figure 146: Column and line chart with secondary Y axis

Stacked Columns and Lines
The columns are stacked above each other, so that the height of a column shows the sum of
the data values.

The charts in Figures 146 and 147 show sales and profit data for two firms over a period of time.
Note that when first created, the lines were different colors than the columns for the same
company. To reflect the company relationships, change the line colors individually by clicking on a
line, right-clicking, selecting Format Data Series, and formatting the line color and size on the Line

page.
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For the background, right-click the chart wall, select Format Wall, and select desired options on
the Gradient page of the Area tab. To align the two data series to the secondary Y axis, see
“Aligning data to secondary Y axis” on page 106.

Two Quarters of Profit Growth

400 =

= N i
Sl 25 e United Sales
250 ! ! 20 . mmm Acme Sales
o 20085 = — Acme Profits
L e L 15 & s Uit Profits

100 10

50 5

0 0

Jan " Feb Mar Apr May . Jun
Figure 147: Column and line chart with stacked columns

Pivot charts

Pivot tables are special types of data tables that simplify the manipulation and analysis of data.
They are widely used, especially for processing large amounts of data. Pivot charts are based on
pivot tables and are created by selecting Insert > Chart, or clicking the Insert Chart icon in the
Standard toolbar, after left-clicking a cell inside a pivot table. Pivot charts inherit many properties of
the other chart types described in this chapter but also have other characteristics that are
described in Chapter 8, Using Pivot Tables.
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What are styles? Why use them?

A style is a set of formats that you can apply to selected elements in a document to quickly change
their appearance. Applying a style often means applying a group of formats at the same time.

Many people manually format spreadsheet cells and pages without paying any attention to styles
and are accustomed to formatting documents according to physical attributes. For example, for the
contents of a cell you might specify the font family, font size, and any character formatting such as
bold or italic.

Styles are logical attributes. Using styles means that you stop applying attributes and
characteristics individually (for example, font size 14pt, Times New Roman, bold, centered) and
start using a style, for example Title. Applying attributes and characteristics is time-consuming and
prone to errors. In contrast, using a style, which has been defined to include the attributes and
characteristics you want, will save you time and give greater consistency in formatting.

Styles also make major formatting changes easy. For example, you may decide to change the
appearance of all subtotals in a spreadsheet to be 10 pt Arial instead of 8 pt Times New Roman
after you have created a 15-page spreadsheet. You can change all of the subtotals in the
document by simply changing the properties for the subtotal style.

Calc also provides page styles, as described below.

You can modify the attributes of the supplied styles and define as many new styles as you require.
Creating, modifying, and accessing styles is explained in the following sections.

Direct formatting and Style formatting

Direct formatting (also called manual formatting) overrides styles, and you cannot remove the
direct formatting by applying a style to it.

To remove manual formatting, select the text, right-click, and choose Format > Clear Direct
Formatting from the context menu, or select the text and press Ctrl+M, or select the text and click

the Clear Direct Formatting icon & in the Standard toolbar.

Calc style types

While some components of LibreOffice offer many style types, Calc offers only two: cell styles and
page styles. These style types are explained in the following sections.

Cell styles

Cell styles are similar to paragraph styles used in LibreOffice Writer. They are the most basic type
of style in Calc. Cell styles are used for applying fonts, alignment, borders, background, number
formats (for example, currency, date, number), and cell protection to format the data in the cells.

A basic range of cell styles is supplied with Calc. These styles are shown on the Styles menu on
the Menu bar and in the Styles deck of the Sidebar. When you create a new cell style, it is shown
in the Sidebar. You can also add it to the Styles menu; see Chapter 14, Setting up and
Customizing, for instructions.

Initially, the basic styles are configured so that if you change the font family of the Default style,
then all of the other styles, inheriting from it, will change to match.
Page styles

Page styles in Calc are applied to sheets. Although one sheet may print on several pages, only one
page style can be applied to a sheet. If a spreadsheet file contains more than one sheet, then a
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different page style can be applied to each sheet. For example, a spreadsheet might contain some
sheets to be printed in landscape orientation and other sheets to be printed in portrait orientation.

Two page styles are supplied with Calc: Default and Report. Page styles allow you to set page size
and orientation, page margins, headers and footers, borders and backgrounds, and the sequence
for printing sheets.

Applying cell styles

To apply cell styles in Calc, you can use the Styles menu on the Menu bar, the Styles deck in the
Sidebar, Fill Format mode, the Apply Style list on the Formatting toolbar, and keyboard shortcuts.

Styles menu

The Styles menu (Figure 148) lists the cell styles supplied with Calc. To apply a cell style, select
the cell or group of cells to be formatted, and then choose Styles and click on the required style.

Styles | Sheet  Data
~  Default

Accent 1
Accent 2
Accent 3

Heading 1
Heading 2
Bad

Error
Good
Meutral
Warning

Eootnote

Mote

.. Update Style
—+  New Style...

M Manage Styles F11

Figure 148: The Styles menu

Styles deck in Sidebar

The Styles deck in the Sidebar lists and shows previews of the styles available. If the Sidebar is
not open, choose View > Styles, or Styles > Manage Styles, or tap the F11 function key to open
it.

1) Go to the Styles deck in the Sidebar.

2) Click the Cell Styles icon on top of the Styles deck to open the list of cell styles. Figure 149
shows the panel with cell styles visible.

3) Inthe spreadsheet, highlight the cell or group of cells where you want to apply a cell style.

4) Double-click on the cell style name in the Styles deck and the formatting attributes for that
style are applied to the data contained in the highlighted cells.
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Figure 149: Styles deck in Sidebar, showing cell styles

Fill Format mode
Fill Format mode is useful when you want to apply the same style to many scattered cells.
1) Go to the Styles deck in the Sidebar (Figure 149).
2) Select the style you want to apply.
3) Click the Fill Format Mode & icon in the top right of the Styles deck. The cursor changes
shape.
4) Click in each cell where you want to apply the selected style.
When you have finished formatting cells, click the Fill Format Mode icon to disable it.

5)
g Note

When Fill Format mode is active, a right-click anywhere in the document cancels the
last Fill Format action. Be careful not to accidentally right-click and thus cancel any
formatting actions you want to keep.

Apply Style list
The Apply Style drop-down list is not included by default on the Formatting toolbar in Calc, but you
can add it as follows:
1) Right-click on any icon in the Formatting toolbar and select Visible Buttons from the
context menu (Figure 150).

2) Click Apply Style. The context menu closes and the Apply Style list appears at the left end
of the Formatting toolbar.

Visible Buttons b M Styles

Customize Toolbar... @ Apply Style

Lock Toolbar Position

Font M
Close Toolbar A Eont Mame

Figure 150: Adding the Apply Style list to the Formatting toolbar
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To apply a style using the Apply Styles list:

1) Select a cell or a group of cells in the spreadsheet.

2) Click the down arrow at the right of the Apply Styles list to open the drop-down menu
(Figure 151).

3) Select the required style. The formatting attributes of that style are applied to the selected
cells.

Default

Clear formatting

Heading 1

Dadaulk

Maore Styles...

Figure 151: Applying a style
from the list

Only the styles that are in use are shown on the list. Click More Styles to go to the Styles deck
where all cell styles are available.
Keyboard shortcuts

You can create keyboard shortcuts to apply commonly-used cell or page styles, including any
custom styles that you have created. See Chapter 14, Setting up and Customizing, for more
information.

Applying page styles

The page style applied to a sheet within a spreadsheet is indicated on the Status Bar, as shown in
Figure 152.

32

+ | Sheetl | Sheet2 | Sheet3 |

Sheet 3 of 3 Default English (Australia)
Figure 152: Page style (Default) indicated on Status Bar

To apply a different page style:
1) Select the sheet to be styled by clicking its sheet tab at the bottom of the window.
2) Go to the Styles deck in the Sidebar (Figure 149).
3) In the top of the Styles deck, click the Page Styles icon.
4) Double-click on the required page style.

Creating new (custom) styles

To create a new (custom) style, follow the procedure described in this section.
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7

1)
2)

3)

4)

5)
7

Note

Any new (custom) styles, and any changes to existing styles, apply only to the
spreadsheet in use. To save new styles in a template, see “Creating a template” on

page 176 for more information.

Go to the Styles deck in the Sidebar (Figure 149).

To create a new cell style, click the Cell Styles icon, or to create a new page style, click the
Page Styles icon.

Right-click in the Styles deck and select New from the context menu to open either the Cell
Style dialog or the Page Style dialog.

Use the various tabbed pages in the dialogs to set the attributes for the new style. See “Cell
style attributes” on page 164 and “Page style attributes” on page 171 for more information.

Click OK to close the dialog and save the new style.

Note

Style names are case sensitive. You can define, for example, a style called red and
another style called Red. Make sure all style names are sufficiently different to prevent
any confusion.

Cell style attributes
The following attributes are available on the tabbed pages of the Cell Style dialog (Figure 153).

Organizer tab

Cell Style: testcellstyle

Organizer Mumbers Font Font Effects Alignment Borders Background Cell Protection
Style
Marne: testcellst_',rlel
Inherit from: | Default v| | EditStyle
Category: |Cu5tu:-rr1 Styles v|
Contains
Help Reset Standard (8] 4 Cancel

Figure 153: Cell Style dialog — Organizer tab

Name — displays the name of the selected style. If you are creating or modifying a custom
style, enter a name for the style. You cannot change the name of a predefined style.

Inherit from — you can choose to link the new style to an existing style and then modify
some of the attributes. If you do this, any change to the parent style’s attributes will affect
the new style. For example, you could make the styles identical except for the font color; if
you later change the font family of the parent style, the new style’s family will also change.

Category — displays the category for the current style. If you are creating or modifying a
new style, select Custom Styles from the list. You cannot change the category for a
predefined style.
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+ Contains — describes the formatting used in the style.

Numbers tab

Cell Style: testcellstyle

Organizer Mumbers Font Font Effects Alignment Borders Background Cell Protection

Category Format Language
All General [English (Australia)
User-defined -1235
-1234.57
Percent
Currency -1,234.57
Date -1,234.57
Tirne {1,235)
Scientific (1,234.57)
Fraction
Boolean Value
Text
-1,235

Options

Deciral places: |0 = [ Negative numbers red

Leading zeroes: |1 = [ Thousands separator:
Format code

# #80

User-defined

Figure 154: Cell Style dialog — Numbers tab

Category — select a category from the list. Examples: Currency, Date, Number, Text, ....
Format — select how you want the contents of the selected cell(s) to be displayed.

When you select Currency as a category, you need to select a currency from the drop-
down list and then select the format to use from the options available for that currency.

The currency format is not dependent on the language that you select in the Language
box. The default currency format for a cell is determined by the regional settings of your
operating system.

Language — specifies the language settings for the selected cells. With the language set to
the default, Calc automatically applies the number formats associated with the system
default language. The language setting ensures that date and currency formats are
preserved even when the document is opened in an operating system that uses a different
default language setting.

Options — specify the options for the selected format.
— Decimal places — enter the number of decimal places that you want to display.

— Leading zeroes — enter the maximum number of zeroes to display in front of the decimal
point.

— Negative numbers red — select to change the font color of negative numbers to red.
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— Thousands separator — select to insert a separator between thousands. The type of
separator (for example, a comma or a space) depends on your language settings.

* Format code — displays the number format code for the selected format. You can also
enter a custom format.

* Preview field — displays a preview of the current selection.
Font tab

Cell Style: testcellstyle

Font Effects Alignment Berders Background Cell Protection

Font: Style: Size:
Liberation Sans Regular 10 pt
Liberation Sans ] Bpt =~
Liberation Sans Marrow Bold Tpt
Liberation Serif [talic 8pt
Linux Bialinum G Bold Italic 9 pt
Linux Libertine Display G ﬁ
Linux Libertine G 105 p
Lucida Conscle 11 pt
Lucida 5ans Unicode 12 pt
Malgun Gothic 13 pt
Malgun Gothic Semilight 14pt ¥
Marlett hd €2
Language: |English (Australia) - Eeatures...

The same font will be used on both your printer and your screen.

Liberation Sans.

Help Beset Standard QK Cancel

Figure 155: Cell Style dialog — Font tab
* Font — select a font family from the list.
* Style — select the formatting you want to apply, for example Bold or /talic.

* Size — select or enter the font size that you want to apply. For scalable fonts, you can also
enter decimal values. If you are creating a style that is based on another style, you can
enter a percentage value or a point value (for example, 2pt or 5pt).

* Language — sets the language that the spelling checker is to use. The spelling checker
works only when you have installed the corresponding language module. A language entry
has a check mark in front of it if the spelling checker is activated for that language.

* Features — some fonts offer special features such as Discretionary Ligatures and

Horizontal Kerning. Click this button to access the Font Features dialog (not shown) to
select those features.

* Preview — displays a preview of the current selection.
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Font Effects tab

Cell Style: testcellstyle >

Organizer Murmbers Font Font Effects Alignment Borders Background Cell Protection

Font color: Overlining: Crverline color:
|:| Automatlc - Without) e |:| Automatic
Strikethrough:
(Without) v|
Relief: Underlining: Underline color:
Withowt) w Without) - |:| Automatic
] Qutline Indrvidual words
] Shadow

Liberation Sans

Help Reset Standard oK Cancel

Figure 156: Cell Style dialog — Font Effects tab

Font color — sets the color for the text. If you select Automatic, the text color is set to
black for light backgrounds and to white for dark backgrounds.

Relief — select a relief effect to apply to the text. The Embossed relief makes the
characters appear as if they are raised above the page. The Engraved relief makes the
characters appear as if they are pressed into the page.

Outline — displays the outline of the characters. This effect does not work with every font.
Shadow — adds a shadow that casts below and to the right of the characters.

Overlining — select the overlining style that you want to apply. To apply the overlining to
words only (not the spaces between them), select Individual words.

Overline color — select the color for the overlining. Automatic matches the font color.
Strikethrough — select a strikethrough style for the selected text.

Underlining — select the underlining style that you want to apply. To apply the underlining
to words only (not the spaces between them), select Individual words.

If you apply underlining to a superscript text, the underlining is raised to the level of the
superscript. If the superscript is contained in a word with normal text, the underlining is not
raised.

Underline color — select the color for the underlining. Automatic matches the font color.
Individual words — applies the selected effect only to words and ignores spaces.
Preview — displays a preview of the current selection.
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Alignment tab

Text Alignment

Horizontal ndent Vertical

Default v 2| |Defautt v

=]

Text Orientation

Degrees: [] Vertically stacked

i lay

& < 0 :

— ABCD @

L \: Reference edge:

e
Lp =
Properties

O Wrap text automatically

=

[} ::.-ue.-\._'.-_.—..c.-\. art

[ Shrink to fit cell size

Text direction:  |Use superordinate object settings |~

Figure 157: Cell Style dialog — Alignment tab

* Text Alignment — sets the alignment options for the contents of the current cell, or the

selected cells.

— Horizontal — select the horizontal alignment option that you want to apply to the cell

contents.

— Default — aligns numbers to the right and text to the left.
— Left — aligns the contents of the cell to the left.

— Center — horizontally centers the contents of the cell.

— Right — aligns the contents of the cell to the right.

— Justified — aligns the contents of the cell to the left and to the right cell borders.

— Filled — repeats the cell contents (number and text) until the visible area of the cell is
filled. This feature does not work on text that contains line breaks.

— Distributed — aligns contents evenly across the whole cell. Unlike Justified, it also

justifies the very last line of text.

— Indent — indents from the left edge of the cell by the amount that you enter.

— Vertical — select the vertical alignment option that you want to apply to the cell contents.

— Default — aligns the cell contents to the bottom of the cell.

— Top — aligns the contents of the cell to the upper edge of the cell.

— Bottom — aligns the contents of the cell to the lower edge of the cell.

— Middle — vertically centers the contents of the cell.

— Justified — aligns the contents of the cell to the top and to the bottom cell borders.

— Distributed — aligns contents evenly across the whole cell. Unlike Justified, it also

justifies the very last line of text.
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* Text Orientation — defines the text direction of cell contents.

— ABCD wheel - click anywhere in the wheel to define the text orientation. The characters
"ABCD" on the wheel correspond to the new setting.

— Vertically stacked — assigns vertical text orientation for cell contents.

— Degrees — allows you to manually enter the orientation angle.

— Reference edge — specify the cell edge from which to write the rotated text.

* Properties — determine the text flow in a cell.

Text Extension From Lower Cell Border — writes the rotated text from the bottom cell
edge outwards.

Text Extension From Upper Cell Border — writes the rotated text from the top cell
edge outwards.

Text Extension Inside Cell — writes the rotated text only within the cell.

— Wrap text automatically — wraps text onto another line at the cell border. The number of
lines depends on the width of the cell. To enter a manual line break, press Ctrl+Enter in

the cell.

— Hyphenation active — enables word hyphenation for text wrapping to the next line.

— Shrink to fit cell size — reduces the apparent size of the font so that the contents of the
cell fit into the current cell width. You cannot apply this command to a cell that contains

line breaks.

— Text direction — choices are Left-to-right, Right-to-left, and Use superordinate object
settings (the settings applied to the preceding cell).

Borders tab

Presets:

m

Position:

Line Arrangement

EI=E X

Uszer-defined;

Adjacent Cells:

Shadow Style

olojojojo

Line

Style:

Width:
0.05 pt

Color

I clack

Figure 158: Cell Style dialog — Borders tab

Padding
Left: (.33 mm =
Right  |0.35 mm -
Top: 0,35 mm :
Bottore 0,35 mm =
Synchrenize
I 203080
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Sets the border attributes for the selected cells.

» Line Arrangement — select a preset border style or define your own combination by
clicking in the diagram.

* Line — select the line style, width, and color that you want to apply. The style is applied to
the borders selected in the preview.

* Padding — specify the amount of space that you want to leave between the border and the
contents of the cell. You can set each distance (left, right, top, bottom) individually or select
Synchronize to apply the same padding to all four borders when you enter a new distance.

* Shadow Style — applies a shadow effect to borders. You can specify the position of the
shadow (top, bottom, right, or left side), the distance it extends, and its color.

Background tab

Click Color to select a color to use as a background for the formatted cells. You can choose from
several palettes. To change the color, select another one. To remove the background color, select
None.

Organizer Mumbers Font Font Effects Alignment Borders Background Cell Protection
Colors Mew
Palette: |Ii|::|rE|:|1"ﬁce w |
H EEE 1]
EEN EEN [
EEE R 4 B 114 =
G |15 G [159 =
B |207 B (207 =
Hex |720fcf Hex | 729fcf
Pick #;
Recent Colors
| Il
Custom Palette
Add Delete

Figure 159: Cell Style dialog — Background tab

Cell Protection tab
Protection
¢ Hide all — hides formulas and contents of the selected cells.

* Protected — prevents the selected cells from being modified. This cell protection only takes
effect if you also protect the sheet.

* Hide formula — hides formulas in the selected cells.
Print
* Hide when printing — prevents the selected cells from being printed.
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Print

Organizer Mumbers Font Font Effects Alignment Borders Background Cell Protection

Protection

[lHide all Cell protection is only effective after the current sheet has

Protected
[1 Hide formula Select 'Protect Sheet' from the 'Tools' menu,

[ Hide when printing The cells selected will be omitted when printing.

been protected,

Figure 160: Cell Style dialog — Cell Protection tab

Resetting cell style attributes

The buttons at the bottom of the Cell Style dialog have the following functions:

* Reset —returns to last saved settings for all tabs of this dialog.
« Standard — returns to the settings in the template for the current dialog tab only.

* Cancel — cancels any changes made (to all tabs in the dialog) since the last save of this
dialog (by clicking OK).
* OK - saves all changes made (to all tabs in the dialog).

Page style attributes
The following attributes are available on the tabs of the Page Style dialog (Figure 161).

Organizer tab
This tab is similar to the Organizer tab for the Cell Style dialog.

* Name — displays the name of the selected style. If you are creating or modifying a custom
style, you can enter or change a name of the style. You cannot change the name of a
predefined style.

« Category — displays the category of the current style. If you are creating a new style, select
Custom Styles from the list. You cannot change the category for a predefined style.

* Contains — describes the formatting used in the current style.

Page tab

You can define page layouts for single and multiple-page spreadsheets, as well as page
numbering and paper formats.

* Paper Format — select from a list of predefined paper sizes, or define a custom paper
format.

Format — select a predefined paper size, or create a custom format by entering the
dimensions for the paper in the Height and Width boxes.

Width — displays the width of the selected paper format. To define a custom (user)
format, enter a width here.

Height — displays the height of the selected paper format. To define a custom (user)
format, enter a height here.

Orientation:
— Portrait — displays and prints the spreadsheet with the paper oriented vertically.
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— Landscape — displays and prints the spreadsheet with the paper oriented
horizontally.

Page Style: Test Page Style

Eormat:
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Margins
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Page numbers:
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Figure 161: Page Style dialog

— Paper tray — select the paper source for your printer. You can assign different paper
trays to different page styles. For example, you can assign a different tray for the first
page style in the spreadsheet and load the tray with your company letterhead paper.

* Margins — specify the amount of space to leave between the edges of the paper and the

spreadsheet contents.

— Left/Inner — the space between the left edge of the page and the spreadsheet. If you
are using Mirrored page layout, the space between the inner edge of the paper and the
spreadsheet. You may want to have a wider space as the Left/Inner margin if you will be
punching or binding the pages.

— Right/Outer — the space between the right edge of the paper and the spreadsheet. If
you are using Mirrored page layout, the space between the outer edge of the paper and

the spreadsheet.

— Top — the space between the upper edge of the paper and the spreadsheet.

— Bottom — the space between the lower edge of the paper and the spreadsheet.

* Layout settings — select the page layout style to use for the spreadsheet.
— Page layout:

— Right and left — both odd (right) and even (left) pages have the same margins on all

four sides.

— Mirrored — odd and even pages with inner and outer margins as specified. Use this
layout if you want to bind the printed pages like a book. Enter the binding space as

the Inner margin.
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— Only right — To specify different (but not mirrored) layouts for odd and even pages,
define separate page styles. This one is for right (odd) pages.

— Only left — To specify the layout for left (even) pages, choose this setting.

— Page numbers — select the page numbering format to use for the page style. Typically
this will be 1,2,3 or a,b,c or i,ii,iii.

— Table alignment:
— Horizontal — centers the cells horizontally on the printed page.
— Vertical — centers the cells vertically on the printed page.

Borders and Background tabs

See “Borders tab” and “Background tab” in “Cell style attributes” above for information on how to
set the borders and background for page styles. Page styles can have a bitmap background or a
color.

Header and Footer tabs

Adds a header or footer to the page style. A header is an area in the top page margin where you
can add text or graphics. A footer is a similar area in the bottom page margin. See Chapter 6,
Printing, Exporting, and Emailing, for details.

Sheet tab

Specifies the elements to be included in the printout of all sheets with the page style. Additionally,
you can set the print order, the first page number, and the page scale. See Chapter 6, Printing,
Exporting, and Emailing, for details.

Managing styles

Modifying styles
1) Go to the Styles deck in the Sidebar and click the icon for the type of style you want to
modify.

2) Right-click on the name of the style and select Modify from the context menu to open
either the Cell Style dialog (Figure 153) or the Page Style dialog (Figure 161).

3) Make the necessary changes to the style attributes. For more information on style
attributes, see “Cell style attributes” on page 164 and “Page style attributes” on page 171.

4) Click OK to save the changes and close the dialog.

£7] Note

The Modify command is unavailable if one or more sheets are protected, even if the
style to be modified is being used in an unprotected sheet.

Renaming styles
You can rename custom styles, but not the styles supplied with Calc.

1) Go to the Styles panel in the Sidebar (Figure 149) and click the icon for the type of style
you want to rename.

2) Right-click on the style you want to rename and select Modify from the context menu. The
Cell Styles or Page Styles dialog opens.

3) On the Organizer tab, rename the style and click OK.
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Deleting styles
You can delete custom styles, but not the styles supplied with Calc.

1) Go to the Styles deck in the Sidebar (Figure 149) and click the icon for the type of style you
want to delete.

2) Right-click on the style you want to delete and select Delete from the context menu.

3) Select Yes on the warning message, if displayed. Any data in a cell or a sheet in the
spreadsheet that used the deleted style will revert to the Default style.

Hiding and showing cell styles

You can shorten the list of cell styles by hiding some of them. Only styles that are not being used in
the spreadsheet can be hidden.

1) Go to the Styles deck in the Sidebar and click on the Cell Styles icon.

2) Right-click on an unused cell style and select Hide from the context menu. The style is then
moved to the Hidden Styles category in the Styles deck.

To show hidden cell styles:

1) Go to the Styles deck in the Sidebar.

2) Click on the drop-down list at the bottom of the panel and select Hidden Styles from the
list.

3) Right-click on the hidden style you want to show and select Show from the context menu.

Filtering the list of styles
You can filter the list of styles as follows:
1) Go to the Styles deck in the Sidebar.
2) Click on the drop-down list at the bottom of the panel.
3) Select the category of styles to display in the Styles deck:

— Hierarchical - lists the styles in their hierarchical relationship, for example Heading 1
and Heading 2 under Heading, or Accent 1, Accent 2, Accent 3 under Accent.

— All Styles — lists all the styles that are available in Calc and in the spreadsheet, except
for hidden styles.

— Hidden Styles — lists all the styles that have been hidden in the spreadsheet.
— Applied Styles — lists only the styles that have been applied to the spreadsheet.
— Custom Styles — lists only the user-defined styles defined for the spreadsheet.

What is a template? Why use one?

A template is a model that you use to create other documents in a standard format. For example,
you can create a template for invoices that has your company logo and address at the top of the
page. This means that any new spreadsheets (invoices) created from this template will then have
the company logo and address on the first page of the spreadsheet.

Templates can contain anything that regular documents can contain, such as text, graphics, styles,
and user-specific setup information such as measurement units, language, default printer, and
toolbar and menu customization.

All documents in LibreOffice are based on templates. You can create, or download and install, as
many templates as you wish. If you do not specify a template when you start a new spreadsheet,
that new spreadsheet is then based on the default template for spreadsheets that is included with
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Calc. This default template consists of a blank spreadsheet which you can customize to your
needs and then, if you wish, use as a basis to create a custom default template.

Using a template to create a spreadsheet

A new installation of LibreOffice may not include any spreadsheet templates, but you can create
your own (see “Creating a template” on page 176) or install templates obtained from other sources
(see “Adding templates obtained from other sources” on page 178).

When you do have a spreadsheet template available, you can create a new spreadsheet from it
using either the Templates dialog or the LibreOffice Start Center.

Creating a spreadsheet from the Templates dialog
To use a template to create a spreadsheet:

1) From the Menu bar, choose File > New > Templates, or click the small arrow next to the
New icon and select Templates, or press Ctrl+Shift+N. The Templates dialog (Figure 162)
opens.

2) From the Filter lists at the top of the Templates dialog, select Spreadsheets and the
category of template you want to use. All the templates in that category are then listed on
the page, as shown in Figure 162.

3) Select the required template and click Open, or double-click the selected template. A new
spreadsheet based on the template opens in Calc.

In the spreadsheet, the template it is based upon is listed in File > Properties > General. The
connection between the template and the spreadsheet remains until the template is modified and,
the next time that the spreadsheet is opened, you choose not to update it to match the template.

Templates X

I.Teer-_'h... Filter |Spread5heet5 ~ | |AII Categories ~ |

Title: Book Sales

Book Sales Category: My Ternplates

Expert 3¢ |mport

iy
g’g
=

Help Open Cancel

Figure 162: Templates dialog, showing a selected template

Creating a spreadsheet from a template in the Start Center

You can create a spreadsheet from the Template view of the LibreOffice Start Center, which is
visible when no other document is open. (See Chapter 1, Introduction.)

Click the Templates button in the left pane and icons are displayed in the Start Center for all
available LibreOffice templates. The button also offers a drop-down list to select the templates of a
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given type of document. If you select the Calc Templates option on the list, the available
spreadsheet templates are displayed in the Start Center. Click on the required template to create a
new document based on that template.

Creating a template

You can easily create a template from any spreadsheet:

1) Open a new or existing spreadsheet that you want to use as a base for the template.

2) Add any necessary pre-defined content that you want to appear in a spreadsheet each time
you use the new template, for example company logo and name, company information,
page numbers, and so on. Delete any information that you do not want in the template.

3) Create or modify the cell and page styles that you want to use in the template.

4) From the Menu bar, choose File > Templates > Save as Template, or press Shift+F11.
The Save As Template dialog (Figure 164) opens, displaying the existing template
categories and a hame box.

5) Type a name for the new template and select the required template category. You can also
choose to make this the default template (see “Setting the default template” on page 179
for more information).

6) Click Save to save the new template.

Save Az Template x

Termplate Marme

Termplate Category

Mone ~
Business Correspondence

MediaWiki

Other Business Documents

Personal Correspondence and Documents
Presentations

Styles =

[ Set as default template

Help Save cancel

Figure 163: Save As Template dialog

{:Z Note

Although the Save as Template dialog shows no document type when saving a new
template of any type, the template will appear on the correct tab (Spreadsheets, in this
case) when you return to the Templates dialog.

It is unnecessary to save or do anything further with the spreadsheet file you have
been using to create the new template. It can be safely closed without saving.
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Editing a template

You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s
styles to spreadsheets that were created from that template. You cannot reapply content.

Templates

Search... Filter |Spread5heet5 V| |AII Categories ~

Open
Edit
Set As Default
Rename
Delete
@ - [d (G Move [ Export 7.7 Import
Help Open Cancel

Figure 164: Templates dialog — Editing templates
To edit a template:

1) From the Menu bar, choose File > Templates > Manage Templates, or press Ctrl+Shift+N,
to open the Templates dialog.

2) Navigate to the template that you want to edit. Right-click to open the context menu and
choose Edit (see Figure 164). The template opens in Calc.

3) Edit the template as you would edit any other spreadsheet. To save the changes, choose
File > Save from the Menu bar, or choose File > Save As Template to save the edited
template as a new template.

Updating styles from a changed template

If you make any changes to a template and its styles, the next time you open a spreadsheet that
was created before you changed the template, a confirmation message is displayed.

1) Click Update Styles to apply the changed styles in the template to the spreadsheet.

2) Click Keep Old Styles if you do not want to apply the changed styles in the template to the
spreadsheet.

A Caution

If you select Keep Old Styles, the confirmation message will not appear again the
next time you open the spreadsheet using the same changed template. Although the
template is still listed under File > Properties > General, the spreadsheet is no longer
connected to the template, so it will not update. You can still import styles manually
from the template, but to reconnect the spreadsheet to the template, you will have to
copy it into an empty document based on the template.
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Adding templates obtained from other sources

You can get to the official LibreOffice template repository by using the Browse online templates
button in the lower left of the Templates dialog, as shown in Figure 165, or by typing
https://extensions.libreoffice.org/templates in your browser’s address bar.

On other websites you may find collections of templates that have been packaged into extension
(.OXT) files. These are installed a little differently, as described below.

':' v I_T'E, E?S [ &) Move E"_:' Export "T7 Import
—_|Ernwse Dnlinetemplatesi

Help Open Cancel

Figure 165: Getting more templates for LibreOffice

Installing individual templates
You can import and add templates to your collection as follows:

1) Find and download the template you want to use, as described in the previous section.
2) Open the Templates dialog and click the Import icon near the bottom right.

3) Inthe pop-up dialog, select the category where you want to store the template. (You can
change this later, as described in “Moving a template” on page 181.)

4) Afile browser opens. Navigate to the location of the downloaded template on your
computer.

5) Select the template and click Open. After import, the template becomes available in the
Templates dialog.

You can manually copy new templates into the template folders. The location varies
with your computer’s operating system. To learn where the template folders are stored
on your computer, go to Tools > Options > LibreOffice > Paths.

Installing collections of templates

The Extension Manager provides an easy way to install collections of templates that have been
packaged as extensions. Follow these steps:

1) Download the extension package (.OXT file) and save it anywhere on your computer.

2) In LibreOffice, select Tools > Extension Manager from the Menu bar, or press Ctrl+Alt+E.
In the Extension Manager dialog, click Add to open a file browser window.

3) Find and select the package of templates you want to install and click Open. The package
begins installing. You may be asked to accept a license agreement.

4) When the package installation is complete, restart LibreOffice. The templates are available
for use through File > Templates > Manage Templates and File > New > Templates and
the extension is listed in the Extension Manager.

See Chapter 14, Setting up and Customizing, for more about the Extension Manager.
002 Tip

Some extensions are packaged as .ZIP files.
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Setting the default template

If you create a new spreadsheet using File > New > Spreadsheet on the Menu bar, Calc creates
the document from the default template for spreadsheets. You can set any template as the default
template. You can also reset the default template to the Calc default template.

Setting a template as the default

Most default settings, such as page size and page margins, can be changed but those changes
normally apply only to the spreadsheet you are working on. To make those changes the default
settings for spreadsheets, you need to replace the default Calc template with a new one.

You can set any template displayed in the Templates dialog to be the default for that document
type:
1) From the Menu bar, choose File > Templates > Manage Templates or press Ctrl+Shift+N.

2) Inthe Templates dialog, open the category containing the template that you want to set as
the default.

3) Right-click on the template and click the Set As Default option (see Figure 164). The
template is now indicated by a green check mark in the upper left.

The next time you create a spreadsheet by choosing File > New, by clicking the New icon in the
Standard toolbar, or by pressing Ctri+N, it will be created from this template.

Resetting the default template
To set the default spreadsheet template back to the default template supplied with Calc:

1) Inthe Templates dialog, click the Settings icon on the bottom left (Figure ).

2) Point to Reset Default Template on the drop-down menu, and click Spreadsheet. The
green check mark is removed from the template.

This choice does not appear unless a custom template has been set as the default, as described in
the previous section.

() New Category
Delete Category
' I Refresh
Reset Default Template » Spreadsheet ﬁ
'_' i l__,ﬁl, ['{_'j- Move Ej, Export "?7 Import
Help Open Cancel

Figure 166: Resetting the default template for spreadsheets
You can also reset the default template as follows:

1) Go to the Templates dialog and open the category containing the template you set as
default. It is indicated by a green check mark.

2) Right-click on this template and select Reset Default from the context menu. The next time
that you create a new spreadsheet, it will be created using the Calc default template.
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g Note

Resetting the default template back to the Calc default template is only available if the
default has been changed previously.

Organizing templates

LibreOffice can manage only templates that are in its template folders (categories), although you
can create a spreadsheet from a template that is not in one of these folders. You can create new
template folders and use them to organize your templates and import templates into these folders.
For example, you might have one template folder for sales templates and another for invoice
templates. You can also export templates.

‘:Q:‘ Tip

The location of template folders in LibreOffice depends on the operating system of
your computer. If you want to know where the template folders are located, go to
Tools > Options > LibreOffice > Paths.

To begin, choose File > Templates > Manage Templates, or press Ctrl+Shift+N, to open the
Templates dialog.

Creating a template category
1) Click the Settings button in the lower left of the Templates dialog.
2) Click New Category on the context menu (see Figure 167).

3) In the pop-up dialog (not shown), type a name for the new category and click OK. The new
category now appears in the list of categories.
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Figure 167: Creating a new category

£7] Note

You cannot create a sub-category inside a template category.

Deleting a template category

You cannot delete template categories supplied with LibreOffice. Nor can you delete any
categories added by the Extension Manager unless you first remove the extension that installed
them.

However, you can delete a category that you created:
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1)

2)
3)
4)

Click the Settings button on the Templates dialog and select Delete Category from the
context menu (see Figure 167).

Select the category to be deleted in the Delete Category dialog (not shown) and click OK.
Select Yes in the confirmation dialog to confirm the deletion.
Calc displays a warning dialog if it is unable to delete the category.

Moving a template

To move a template from one template category to another:

1)
2)

Open the Templates dialog and select the template you want to move.

Click the Move icon near the bottom of the dialog, select the destination category from the
popup dialog (Figure 168), and click OK. The selected template is moved to the folder. You
can also create a new category into which to move the template.
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Other Business Documents
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Figure 168: Moving a template to another category

Deleting a template

You cannot delete templates supplied with LibreOffice. Nor can you delete any templates installed
by the Extension Manager except by removing the extension that installed them. You can only
delete templates that you have created or imported.

1)
2)

3)

From the Filter drop-down lists at the top of the Templates dialog, select the category that
contains the template you want to delete.

Right-click on the template that you want to delete to open the context menu and click
Delete (Figure 164).

A message box appears and asks you to confirm the deletion. Click Yes.

Exporting a template

The easiest way to send a template to someone else, or to store it on a network, is to export it:

1)
2)
3)

Open the Templates dialog and find the template that you want to export.
Select the template and click the Export icon.

The Select Folder dialog opens. Navigate to the location where you want to export the
template and click Select Folder. You can also rename the template.
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Z Note

Exporting a template does not remove it from the Templates dialog. The action places
a copy of the template in the location you specify.

182 | Organizing templates



) LibreOffice

Calc Guide

Chapter 5
Using Graphics



Introduction

Calc is used to present and analyze data and to make forecasts and predictions. Graphics can turn
an average spreadsheet into a more memorable document. Calc can import various vector (line
drawing) and raster (bitmap or photo) file formats. The most commonly used graphic formats are
GIF, JPG, and PNG. See LibreOffice Help for a full list of the formats that Calc can import.

Graphics in Calc are of three basic types:
* Image files, such as photographs, drawings, and scanned images

» Diagrams created using LibreOffice's drawing tools

« Charts and graphs created using LibreOffice’s Chart facility; see Chapter 3, Creating Charts
and Graphs, for more information

Using graphics in Calc is similar to using graphics in other components of LibreOffice. For more
detailed descriptions, please refer to the Getting Started Guide or the Draw Guide.

g Note

In LibreOffice, the terms graphics and images refer to both pictures and drawing
objects. Often the word images is used when referring to pictures and other graphics
that are not drawing objects.

Adding graphics (images) to a spreadsheet

Graphics or images (sometimes called pictures in LibreOffice), such as corporate logos and
photographs, are probably the most common types of graphics added to a spreadsheet. They may
be downloaded from the Internet, scanned, created with a graphics program, photographs taken
with a digital camera, or clip art in the Gallery.

Inserting an image file

When the image is in a file stored on the computer, you can insert it into a spreadsheet using one
of the following methods.

Drag and drop
1) Open a file browser window and locate the image you want to insert.
2) Drag the image into the spreadsheet and drop it where you want it to appear.

This method embeds (saves a copy of) the image file in the document. To link the file instead of
embedding it, hold down the Ctrl+Shift keys while dragging the image. See “Linking or embedding
an image file” on page 185 for more information.

Insert Image dialog
1) Click in the spreadsheet where you want the image to appear.
2) Choose Insert > Image from the Menu bar.
3) On the Insert Image dialog (Figure 169), navigate to the file to be inserted, and select it.
4) At the bottom of the dialog is an Insert as Link option. Select it if you want to link the file.

5) Click Open. The file is inserted into the spreadsheet and is anchored to the cell in which the
cursor was placed.
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Z Note

If you have selected to link the image, Calc may present a confirmation dialog with
options to continue with the link or to embed the image instead. An option is provided
on this dialog to prevent it being displayed in future.
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Figure 169: Insert Image dialog

Linking or embedding an image file

Embedding an image into a spreadsheet makes the image a permanent part of the spreadsheet
file. Any changes you make to an embedded image will appear only in that spreadsheet; the
original image will not be affected.

If you select the Insert as Link option in the Insert Image dialog, or use Ctrl+Shift during the drag
and drop method, Calc creates a link to the file containing the image instead of embedding it. The
image is displayed in the document, but when the document is saved, it contains only a reference
to the image file, not the image itself. The document and the image remain as two separate files,
and they are merged together only when you open the document again.

Linking an image has two advantages and one disadvantage:

* Advantage — You can modify the image file separately. The modified image will appear
when you next open the spreadsheet. This can be a big advantage if you (or someone else,
perhaps a graphic artist) is updating images.

* Advantage — Linking can reduce the file size of the spreadsheet when it is saved, because
the image file itself is not included. However, file size is usually not a problem on modern
computers, and Calc can easily handle large files.

+ Disadvantage — If you send the document to someone else, or move it to a different
computer, you must also send the image files and keep the same file structure. For
example, you might keep image files in a subfolder named Images inside the same folder
containing the Calc document. Any recipient of the spreadsheet needs to put the image files
in a subfolder with the same name in the same named folder as the spreadsheet.
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g Note

When inserting the same image several times in a document, it might appear
beneficial to create links. However, this is not necessary, as LibreOffice embeds only
one copy of the image file in the document. Deleting one or more of the copies does
not affect the other copies of the same file.

Embedding linked images
If you originally linked the images, you can easily embed one or more of them later.

1) Open the spreadsheet in Calc.

2) Choose Edit > Links to External Files on the Menu bar to open the Edit Links dialog
(Figure 170), which shows all the linked files.

®® Edit Links
Source file Element: Type Status —_———
f../IMG 20140211 1658( __image __ Manual i —ose.
Help
Update
Modify...
Break Link

. Source file file:/l/Users/jean/Pictures/2014-01-03/IMG_20140211 165808.jpg

Element:
| Type: Image
| Update: ' . .
Figure 170: Edit Links dialog
3) Select the files you want to change from linked to embedded.

4) Click Break Link and confirm you want to remove the selected link. The file then becomes
embedded into the spreadsheet.

Z Note

Going from embedded to linked images is not so easy. You must replace them one at
a time, selecting the Insert as Link option when you reinsert each file.

Inserting an image from the clipboard

Using the clipboard, you can copy images into a Calc spreadsheet from another LibreOffice
document and from other programs. To do this:

1) Open both the source document and the target document.

2) Inthe source document, copy the image to the clipboard — the exact interactions will vary
from program to program.

3) Switch to the target document. Click to place the cursor in the cell where the image is to be
anchored. Right-click and select Paste to insert the image, or select Edit > Paste, or click
the Paste icon in the Standard toolbar, or press Ctrl+V.
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A Caution

If the application from which the image was copied is closed before the image is
pasted into the target, the image stored on the clipboard could be lost.

Inserting an image using a scanner

If a scanner is connected to your computer, LibreOffice can call the scanning application and insert
the scanned item into the LibreOffice document as an image. To start this procedure, choose
Insert > Media > Scan > Select Source. After selecting the scanner, place the cursor where you
want the image to be inserted, and choose Insert > Media > Scan > Request.

Although this practice is quick and easy, it is unlikely to result in a high-quality image of the correct
size. You may get better results by passing scanned material into a graphics program and cleaning
it up there before inserting the resulting image into LibreOffice.

Inserting an image from the Gallery

The Gallery (Figure 171) provides a convenient way to group reusable objects such as images and
sounds that you can insert into your documents. The Gallery is available in all components of
LibreOffice. You can add your own images as well as using the ones supplied with LibreOffice. For
more information, see the Getting Started Guide Chapter 11, Images and Graphics.
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Figure 171: The Gallery in the Sidebar

To insert an image from the Gallery:
1) Click the Gallery icon in the Sidebar, or select View > Gallery.
2) Select atheme.
3) Select an object with a single click.
4) Drag and drop the image into the document.

You can also right-click on the object and choose Insert, in which case the image will be
positioned according to the cells selected in the spreadsheet.
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Z Note

To insert an image as a link, hold down the Shift and Ctrl keys while dragging the
object into the document.

Modifying images

When you insert a new image, you may need to modify it to suit the document. Any changes made
in Calc do not affect the original image, whether it is an embedded or linked image file.

Calc provides several tools for working with images. These tools are sufficient for most
requirements. However, for professional results it is generally better to use Draw or other software
designed to modify image files, and then insert the result into Calc.

Using the Image toolbar

When you insert an image or select one already present in the spreadsheet, the Image toolbar
replaces the Formatting toolbar. If it does not appear, go to View > Toolbars > Image on the Menu
bar. The tools available on the Image toolbar are described below.

E Note

Changes to image properties affect only the display and printing of the image. The
original image file remains unchanged.

* Anchor — choose between anchoring the image to a cell (with or without resize) or to a
page. See “Anchoring images” on page 191.

* Align - if two or more images are selected, you can adjust the horizontal and vertical
alignment of the images in relation to each other. See “Aligning images” on page 192.

» Six buttons for arrangement (the position of images in the stacking order): Bring to Front,
Forward One, Back One, Send to Back, To Foreground, To Background. See
“Arranging images” on page 191.

* Line Style, Line Width, Line Color — set the attributes of the border around the image.

* Area Style | Filling — sets the color or other characteristics of the background area that
contains the image, not the image itself. To see the background, you must set the
transparency of the image to a suitably high value. See the Draw Guide for more
information on how to modify areas.

* Shadow - sets the default shadow effect around the image. To adjust the shadow effect,
open the Area dialog (Format > Object > Area) and choose the Shadow tab.

* Filter — opens the Image Filter toolbar. See the Draw Guide for details on image filters.

* Image Mode — changes the display of the image from color (Default) to grayscale, black
and white, or a watermark. This setting affects only the display and printing of the image;
the original image file remains unchanged.

* Crop Image — places cropping handles around the image. Drag a handle to crop (hide) the
edges of the image.

* Flip Horizontally and Flip Vertically — changes the orientation of the image.
* Rotate — places rotation handles around the image.

* Transparency — adjusts the degree of transparency of the image between 0% (opaque)
and 100% (fully transparent).

* Color - opens the Color toolbar (Figure 172) to adjust the values of the red, green, blue
colors, brightness, contrast and gamma.
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Using the Properties deck in the Sidebar

Some of the settings in the Image toolbar are also available in the Properties deck in the Sidebar
when an image is selected. These include the Color, Line, and Transparency settings.

Adding text

You can add text to an image or drawing object. That text will move with the image when the image
is repositioned. For more information on adding text to images, see the Draw Guide.

1) Double-click on the image. The text cursor flashes in the center of the image. The Text
Formatting toolbar automatically opens at the top of the spreadsheet.
lheationsert V[ [2 V@' @’ @& @ d & @ a, & @ -y~ E=S=E 7 - iEEE
Figure 173: Text Formatting toolbar for images

2) Type your text and use the tools on the Text Formatting toolbar to format it. Most of the
tools are the same as those for formatting text in cells.

3) To adjust the position of the text or how it appears in the image, right-click on the image
(when the text cursor is flashing) and select Text from the context menu to open the Text
dialog (Figure 174).

@ Text

[LText| Text Animation
| custom Shape Text
Word wrap text in shape

Resize shape to fit text

| Spacing to Borders Text Anchor

Left: 0.00 cm Ié_l

Right: 0.00 cm Iil | * |
Top: 0.00 cm § | |
Bottom: 0.00cm | [2] Full width |

Figure 174: Text dialog

4) Make any necessary changes and click OK to close the dialog.
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Positioning, resizing, and arranging images

Using the mouse

To move an image to a new position in your spreadsheet, click on the image and drag it to a new
position. The image will still be anchored as it was originally (that is, To Cell, To Cell (resize with
cell), or To Page).

To resize an image:

1) Click on the image to display the selection handles.

2) Position the cursor over one of the selection handles. The cursor changes shape, giving a
graphical representation of the direction of the resizing. The corner handles resize both the
width and the height of the image simultaneously. The top, bottom, left and right handles
only resize one dimension at a time.

3) Click and drag to resize the image.
X Tip

To retain the original proportions of the image, click and drag one of the corner
handles. If you want to change the original proportions, Shift+click one of the corner
handles, then drag.

Using the Position and Size dialog

To accurately position and size an image in your spreadsheet, click on the image and then go to
Format > Object > Position and Size on the Menu batr, or right-click on the image and select
Position and Size from the context menu.

On the Position and Size tab (Figure 175) of the Position and Size dialog, you can set these
values:
* Position — the location of the selected image on the spreadsheet.
— Position X — the horizontal distance from the base point selected in the grid.
— Position Y — the vertical distance from the base point selected in the grid.

* Size — the width and height of the image with respect to the selected base point.

* Protect — to prevent accidental movement or resizing of the image, select the relevant
option.
The units of measurement used for X / Y coordinates and the width and height of the image are set
by going to Tools > Options > LibreOffice Calc > General > Measurement unit.

The default location of the base points for position and size is the upper left corner of the
spreadsheet. You can temporarily change this base point to make positioning or dimensioning
simpler by clicking on a position corresponding to the location of the base point you want to use.
This change in base point is only valid for single use and the base point is reset to the standard
position of top left corner when you close the Position and Size dialog.

You can also rotate or slant an image (using the Rotation or Slant & Corner Radius tabs of the
Position and Size dialog). See the Draw Guide for details.
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Figure 175: Position and Size dialog

Arranging images
Each image that you place in a spreadsheet is successively stacked on the preceding image,
whether or not they overlap. Use the arrange commands to change the stacking order of images.
You cannot change the stacking order of text.

1) Select the image you want to change.

2) Go to Format > Arrange on the Menu bar, or right-click on the image, select Arrange from
the context menu, and select one of the arrangement options described below.

3) Alternatively, click on one of the six arrangement icons on the Image toolbar to quickly
move the image up or down the stacking order.

The arrangement options are as follows:
* Bring to Front — moves the selected image to the top of the stacking order, so that it is in
front of other images.

* Forward One — moves the selected image up one level, so that it is closer to top of the
stacking order.

* Back One — moves the selected image down one level, so that it is closer to the bottom of
the stacking order.

* Send to Back — moves the selected image to the bottom of the stacking order, so that it is
behind the other images.

* To Foreground — moves the selected image in front of text.

+ To Background — moves the selected image behind text. To select a background image so
that you can modify or replace it, you have to use the Navigator. Other methods of
selection, such as clicking or double-clicking, do not work.

Anchoring images
Anchor images so they stay in their position in relation to other items.

+ To Page — anchor an image to the page to position it in a specific place. The image does
not move when cells are added or deleted; it will always stay in the same position on the
page where it is placed.

Anchoring images | 191



* To Cell — anchor an image to a cell to ensure that the image always stays with the content
it is originally anchored to. If an image is anchored to cell B10, and a new row is inserted
above row 10, the image will then be anchored to cell B11.

* To Cell (resize with cell) — similar to To Cell but with the additional property that the image
resizes as you resize the cell to which it is anchored.

To anchor an image or change the type of anchor used:

* Go to Format > Anchor > To Page or To Cell or To Cell (resize with cell) on the Menu
bar, or right-click on the image and select Anchor > To Page or To Cell or To Cell (resize
with cell) from the context menu.

» Alternatively, click on the Anchor icon on the Image toolbar and select To Page or To Cell
or To Cell (resize with cell).

Aligning images

When you have more than one image in your spreadsheet, you can align these images to give
your spreadsheet a more professional look. The options include three for aligning the images
horizontally (left, centered, right) and three for aligning the images vertically (top, center, bottom).

1) Select all of the images to be aligned (select one and hold down the Shift key while
selecting others).

2) Go to Format > Align on the Menu bar, or right-click on one of the images and select Align
from the context menu, or click on the Align icon on the Image toolbar.

3) Select one of the options available for alignment.

Grouping and ungrouping images
To group several images so that they become a single object in the spreadsheet:

1) Select the images you want to group (select one and hold down the Shift key while
selecting others).

2) Go to Format > Group > Group on the Menu bar, or right-click on one of the selected
images and select Group from the context menu.

To ungroup images:
1) Select the image group you want to ungroup.

2) Go to Format > Group > Ungroup on the Menu bar, or right-click on one of the selected
images and select Ungroup from the context menu.

To edit an image in a group:
1) Select the image group where you want to edit an image within the group.

2) Go to Format > Group > Enter Group on the Menu bar, or right-click on one of the
selected images and select Enter Group from the context menu.

3) Select the image you want to make changes to and make the changes.

4) Go to Format > Group > Exit Group on the Menu bar, or right-click on one of the selected
images and select Exit Group from the context menu.

Using LibreOffice’s drawing tools

Calc, like all other components of LibreOffice, has a range of tools to create drawings such as
simple diagrams, using rectangles, circles, lines, text, and other shapes. You can group several
drawing objects to make sure they maintain their relative position and proportion if you move or
resize them.
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You can also use the drawing tools to annotate photographs, screen captures, or other illustrations
produced by other programs, but this is not recommended. If you need to create complex
drawings, it is recommended to use LibreOffice Draw and then insert the drawing into your
spreadsheet. For a more detailed explanation, see the Draw Guide.

Drawing toolbar

To begin using the drawing tools, go to View > Toolbars > Drawing to open the Drawing toolbar,
which appears in its default position at the bottom of the spreadsheet. You can make this toolbar a
floating toolbar and move it to a convenient position.

When the Drawing toolbar opens, it opens with a default set of tools as shown in Figure 176. Hover
the mouse pointer over a tool to see a tooltip describing its function. lcons with small arrows to the
right side open with palettes of tools. To add tools to the Drawing toolbar, right-click in an empty
area on the toolbar and select Visible Buttons from the context menu.

P\~ male@Ak ¢ @« x 8 OTn
Figure 176: Drawing toolbar
To use a drawing tool:

1) Click on the tool in the Drawing toolbar (Figure 176). The mouse pointer changes to a
drawing-functions pointer -I- and the normal Formatting toolbar changes to the Drawing
I

Object Properties toolbar, becoming a floating toolbar (Figure 177).

2) Move the cross-hair pointer to the place in the document where you want the drawing
object to appear and then click and drag to create the object. Release the mouse button.
The selected drawing function remains active, so that you can draw another object of the
same type.

3) To cancel the selected drawing function, click on the tool’s icon again, press the Esc key or
click on the Select icon (the arrow) on the Drawing toolbar.

4) You can now change the properties (fill color, line type and weight, anchoring, and others)
of the drawing object using the Drawing Object Properties toolbar (Figure 177), the
Properties deck on the Sidebar, or the choices reached by right-clicking on the drawing
object.

Setting the properties of drawing objects
For more information on the properties of drawing objects, see the Draw Guide.

You can set some default properties for a drawing object before you draw an object. These default
properties are applied only to the current spreadsheet and are not retained when you close the
spreadsheet. The properties apply only to drawing objects.

1) Click Select on the Drawing toolbar (Figure 176).

2) On the Drawing Object Properties toolbar (Figure 177), set the values you want to use for
each property. When you select area or line properties, dialogs open where you can set the
values used for area or line.

—_— E 0.00cm | [ = ~ Color &t N - Q
Figure 177: Drawing Object Properties toolbar

3) After you draw an object or group it with another object, more properties become active.
These appear on the toolbar (Figure 178) and some are shown in the Properties deck of
the Sidebar (Figure 179).
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Figure 178: Drawing Object Properties toolbar after inserting an object
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You can change the properties of an existing drawing object (fill color, line type and weight,
anchoring, and so on) using the Drawing Object Properties toolbar (Figure 177), the Properties
deck on the Sidebar, or the context menu when you right-click on the drawing object.
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Figure 179: Properties deck in Sidebar
for drawing object

Resizing drawing objects

Select the object and click on one of the selection handles then drag the object to its new size. For
a scaled resizing, select one of the corner handles and keep the Shift key pressed while dragging
the handle. For more information, see “Positioning, resizing, and arranging images” on page 190.

Grouping and ungrouping drawing objects

For grouping, ungrouping, and editing grouped drawing objects, see “Grouping and ungrouping
images” on page 192.

Additional tools

Some additional tools are available when you right-click on an image or drawing object and open
the context menu.

Description
You can add metadata in the form of a title and description to an image. This information is
used by accessibility tools (such as screen reader software) and as ALT (alternative text)
attributes if you export the document to HTML.
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Name
You can add a custom name to be assigned to an image; this will make the image easier to
find in the Navigator. Also, assigning names to images helps identify them when teams of
people are working on the same multi-page spreadsheet.

Rotate or Flip
You can rotate the image or flip it horizontally or vertically.

Assign Macro
Opens the Assign Macro dialog so you can add programmable functionality to the graphic.
Calc has a very good macro functionality. For more information, see Chapter 12, Macros.

Edit Hyperlink
You can define a hyperlink from an image to another location in your spreadsheet, another
document, or a web page. Select Edit Hyperlink from the context menu to open the
Hyperlink dialog. See Chapter 10, Linking Data, for more information on hyperlinks.

Compress
You can compress images to reduce the file size of the spreadsheet. Select Compress from
the context menu to open a Compress Image dialog where you can set the compression
options. (Option not available for drawing objects.)

Edit with External Tool
You can edit an image with an external tool. The dialog that opens will depend on your
computer setup. (Option not available for drawing objects.)

Using Fontwork

With Fontwork, you can create graphical text art objects to make your work more attractive. There
are many different settings for text art objects (line, area, position, size, and more), so you have a
large choice.

Fontwork is available with each component of LibreOffice, but you will notice small differences in
the way that each component displays it.

Creating a Fontwork object

1) On the Fontwork toolbar (View > Toolbars > Fontwork) or the Drawing toolbar (View >
Toolbars > Drawing), click the Fontwork icon.

2) Inthe Fontwork Gallery (Figure 180), select a Fontwork style, then click OK. The Fontwork
object will appear in the document.

3) Double-click the object to edit the Fontwork text (see Figure 181). Select the text and type
your own text in place of the black Fontwork text that appears over the object.

4) Click anywhere in a free space or press Esc to apply your changes.
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Figure 180: The Fontwork Gallery
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Figure 181: Editing Fontwork text

Editing a Fontwork object

Now that the Fontwork object is created, you can edit some of its attributes. To do this, you can use
the Fontwork toolbar, the Formatting toolbar, or menu options. For more information, see Chapter
11, Images and Graphics, in the Getting Started Guide.
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Printing

Quick printing
To quickly print a spreadsheet, click on the Print Directly icon on the Standard toolbar to send the
entire spreadsheet to the default printer that is defined for your computer.

B Note

You can change the action of the Print Directly icon to send a document to the printer
defined for the document instead of the default printer for the computer. Go to Tools >
Options > Load/Save > General and select the Load printer settings with the
document option.

‘::‘ Tip

The initial default when you first install LibreOffice is for the Print Directly icon not to
appear on Calc’s Standard toolbar. However, you can enable its display by following
the instructions given in Chapter 14, Setting Up and Customizing.

Controlling printing

For more control over printing, select File > Print, press Ctr/+P, or click the Print icon on the
Standard toolbar, to open the Print dialog (Figure 182).

Print >
General LibreOffice Calc
Printer
HP1CE2B4 (HP Desklet 2600 series) -
8.27in (Ad)
Status: Default printer
Range and Copies
® All Pages
O Pages: 1-3
g
(O Even pages
O Odd pages
=
& Preview is disabled Fromwhich: |Print Selected Sheets ~ |
Paper sides: |Print on one side (simplex) w |
Mumber of copies: |1 = Collate .11 1}
- - 1 1
Order: [ print in reverse order
Page Layout
Paper size: A4 8.27in x 11.69in v|
Orientation: |F‘ortrait w |
Pages per sheet: |'I w |
Order: |LEFt to right, then down w | 1
[ Preview L (] Draw a barder around each page
Help Maore Qptions... oK Cancel

Figure 182: Print dialog — General tab
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Z Note

The options selected on the Print dialog apply to this printing of this document only.

To specify default printing settings for LibreOffice, go to Tools > Options > LibreOffice
> Print and Tools > Options > LibreOffice Calc > Print. For details, see Chapter 14,
Setting up and Customizing Calc.

The Print dialog has multiple tabs where you can choose a range of options, as described in the
following sections. Depending on your computer’s operating system, the number of tabs, and the
layout of each tab, may be different from the illustrations shown in this chapter. On some, but not
all, installations a More Options button is provided on the Print dialog.

The Print dialog includes a Preview checkbox which enables you to turn on / off a preview of how
you data will appear on the printed page. The preview appears in the area above the checkbox, on
the left hand side of the dialog. Adjacent controls allow you to navigate through the pages of a long
spreadsheet.

General tab
On the General tab of the Print dialog (Figure 182), you can choose from the following options:
Printer options

* Select the printer to use from the list of those available.

* Press the Properties button to change any required settings of the selected printer. The
options available through this interaction will depend on your printer and system.

Range and Copies options
» Select which sheets and pages to print, single or double sided printing, the number of
copies to print, whether to collate multiple copies, and the page order for printing. (See
“Selecting what to print” on page 200.)

Page Layout options
* Select page layout properties such as paper size, portrait or landscape orientation, how
many pages are printed per sheet of paper, the order in which the pages are printed on a
sheet of paper, and whether a border is drawn around each page.

LibreOffice Calc tab

On the LibreOffice Calc tab of the Print dialog (Figure 183), you can select whether to suppress the
output of empty pages when you print the spreadsheet.

General LibreOffice Calc

Fages:
Suppress output of empty pages

Figure 183: Print dialog — LibreOffice Calc tab

More Options dialog

Press the More Options button to access the More Printing Options dialog (Figure 184). On this
dialog you can choose whether to create separate print jobs for collated output.
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Figure 184: More Printing Options dialog

Printing multiple pages on a single piece of paper

To print multiple pages of a spreadsheet on one piece of paper:

1)

2)

3)

4)
5)

Use File > Print on the Menu bar, or Ctrl+P, or the Print icon on the Standard toolbar, to
open the Print dialog and then select the Page Layout tab (Figure 185).

In the Layout section, select from the Pages per sheet drop-down list the number of
spreadsheet pages to print per sheet of paper. The preview panel on the right shows how
the pages will look in the printed document.

When printing more than two pages per sheet, select the order in which the pages are
printed on a sheet from the Order drop-down list.

To distinguish each page on a sheet, select Draw a border around each page.
Click OK.

Print *

General LibreOffice Calc Page Layout Options

Layout
Pages per sheet |2

5,82 in (A5)

512

Crder

| Draw a bord

top to bottom, then right
top to bottom, then left
right to left, then down

8.27in

Figure 185: Printing more than one spreadsheet page per sheet of paper

Selecting what to print

In addition to printing a full spreadsheet document, you can choose single sheets, multiple sheets,
and selections of cells for printing.

To print an individual sheet:

1)
2)

3)
4)

In the spreadsheet, click on the sheet tab to select the sheet you want to print.

Choose File > Print on the Menu bar, or press Ctr/+P, or click the Print icon on the
Standard toolbar.

In the Range and Copies section of the Print dialog, choose Selected sheets.
Click OK.

To print a range of sheets:

1)
2)

3)

In the spreadsheet, select the sheets to print.

Choose File > Print on the Menu bar, or press Ctr/+P, or click the Print icon on the
Standard toolbar.

In the Range and Copies section of the Print dialog, choose Selected sheets.

200 | Printing



4)

Click OK.

To print a selection of cells:

1)
2)

3)
4)
5)

In the spreadsheet, select the cells to print.

Choose File > Print on the Menu bar, or press Ctrl+P, or click the Print icon on the
Standard toolbar.

In the Ranges and Copies section of the Print dialog, choose Selected cells.
In the sub-section From which print, choose Pages and type 1 in the box.
Click OK.

Printing in grayscale on a color printer

You may wish to print a spreadsheet in grayscale on a color printer. You can do this in two ways.

Z Note

Some color printers may print in color regardless of the settings you choose.

For an individual file, you can change the printer settings to print in black and white or grayscale:

1)
2)
3)

4)
5)

Choose File > Print on the Menu bar, or press Ctr/+P, or click the Print icon on the
Standard toolbar, to open the Print dialog.

Click Properties to open the Properties dialog for the printer. The available choices vary
from one printer to another, but you should find options for the color settings. See your
printer’s help or user manual for more information.

The choices for color might include black and white or grayscale. Choose grayscale.
Click OK to confirm your choice and return to the Print dialog,
Click OK to print the document.

You can change the LibreOffice settings to print all color text and graphics as grayscale:

1)
2)

Choose Tools > Options > LibreOffice > Print.
Select Convert colors to grayscale. Click OK to save the change.

A Caution

This changes the print settings for all components of LibreOffice, not just Calc

Previewing pages/sheets before printing
To preview the sheets in Calc before printing:

1)

2)

3)
4)

Choose File > Print Preview or click the Toggle Print Preview icon on the Standard
toolbar.

The Calc window now displays the Print Preview toolbar instead of the Formatting toolbar.
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Figure 186: Print Preview toolbar (Calc)

To print the document from this view, select File > Print on the Menu bar, or press Cirl+P,
or click the Print icon (on the Standard toolbar), to open the Print dialog.

Choose the print options and click the OK button.

Click the Toggle Print Preview icon again, or click the Close Preview icon on the right-
hand side of the Print Preview toolbar, to return to the normal spreadsheet view.
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Using print ranges

You can define which range of cells on a spreadsheet are to be printed or exported to a PDF. The
cells on the sheet that are not part of the defined print range are not printed or exported. Also, any
sheets without a defined print range are not printed or exported.

Defining and printing a print range
To set a user-defined print range, which will replace any existing defined print range:

1) Select the range of cells that are to be used in the print range.

2) Go to Format > Print Ranges > Define on the Menu bar. Automatic page break lines are
then displayed on the screen, defining the cells that are included in the print range.

3) Click on the Print Directly icon on the Standard toolbar to print the defined print range, or
open the Print dialog and click OK to print the defined print range.

You can check the print range by using Toggle Print Preview or the Preview pane in
the Print dialog. Calc will display only the cells in the print range. See “Viewing print
ranges” on page 203.

Editing a print range
At any time, you can edit the print range, for example to add or remove cells, or define rows and
columns to repeat (such as column or row headings).
[ -  Edit Print Ranges
. Print Range
- user defined - B $AS1L:3HS210

| Rows to Repeat

- user defined - _ﬁ $1
| Columns to Repeat
- none - _ﬂ
Help ORI | cancel

Figure 187: Edit Print Ranges dialog
1) Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges dialog
(Figure 187).

2) If only a single range is defined, then clicking anywhere in the Print Range text box displays
the defined print range bounded in blue, as shown in Figure 188.

A | B

Figure 188: Single print range marked by a bounding box
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3) To add new cells to the defined print ranges, type a comma at the end of the displayed data
in the Print Range text box as the separator for the print range to be added. Select the cell
range using the cursor, or type in the cell references using the same format as the print
ranges already defined in the Print Range text box. Remember to separate the cell
references with a colon.

4) To remove a print range, select the print range in the Print Range text box and delete it.
Make sure the remaining print ranges only have a single comma as a separator and that
there is not a comma at the end of the sequence.

5) Click OK to save your changes and close the dialog.

Viewing print ranges

After print ranges have been defined, they are formatted with automatic page breaks. To view the
page breaks, go to View > Page Break on the Menu bar to open the preview (Figure 189).

Figure 189: Page break preview

The print ranges are outlined by default with a blue border and contain a pale gray page number in
the center of each page. The nonprinting area of the spreadsheet normally has a gray background.

To exit the page break preview, go to View > Normal on the Menu bar.

Named print ranges

& @ Define Name

| Define the name and range or formula expression.
| Name:

. Range or formula expression:

| $'Lulu-sales_all' $A$167:$D$178 =
| Scope:
Document (Global) E

| ¥ Range Options

Print range Repeat column
Filter Repeat row
Help Add Cancel

Figure 190: Define Name dialog
In addition to defining a print range for each print job, you can also define a range of cells to be
used repeatedly, without having to select a range of cells every time. This is useful if different areas
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of a large spreadsheet have to be printed for different reports; several named print ranges can be
defined to meet this need.

Defining and naming

1)

2)
3)

4)
5)
6)

Select the cells you want to define and name as a print range, then go to Sheet > Named
Ranges and Expressions > Define on the Menu bar to open the Define Name dialog
(Figure 190). The selected cells are displayed in the Range or formula expression box.

Alternatively, open the Define Name dialog, then select the cells you want to define and
name. The selected cells are then displayed in the Range or formula expression box.

Type a name for the range in the Name box. Use only letters, numbers, and underscores in
the name; no spaces, hyphens, or other characters are allowed.

If necessary, you can edit or set the range of selected cells for the print range in the Range
or formula expression box. See “Editing a print range” on page 202 for more information.

Make sure Document (Global) is selected from the Scope drop-down list.
Select Print range from Range Options to define the settings as a print range.
Click Add to accept the data and close the dialog.

Printing a named range
To select a named range for printing:

1)

2)
3)
4)

Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges dialog
(Figure 191).

Select the defined and named print range from the Print Range drop-down list.
Click OK to close the dialog.
Open the Print dialog, which will show only the named range in the preview area. Click OK.

@ Edit Print Ranges

Print Range

- user defined - k5 SAB167:5D$178
- none -
RC - entire sheet -
- user defined - - |
- selection - | '
Test_Named_Print_Range |
wnepeac

- none - ﬁ

Help “ Cancel

Figure 191: Choosing a named range for printing

Deleting a named print range
To delete a named print range if it is no longer required:

1)
2)

3)

Go to Sheet > Named Ranges and Expressions > Manage on the Menu bar to open the
Manage Names dialog (Figure 192).

Select the named print range you want to delete and confirm it is a print range by checking
the options in Range Options.

Click Delete and then click OK to close the dialog.

Removing print ranges

It may become necessary to remove a defined print range, for example if the whole sheet needs to
be printed later, or you no longer want to print some of the added ranges.

204 | Using print ranges



Go to Format > Print Ranges > Clear on the Menu bar to remove all of the defined print ranges in
the spreadsheet, except for named print ranges. After the print range is removed, the default page
break lines for the selected paper size will appear on the screen.

To remove named print ranges, see “Deleting a named print range” above.

@ @ Manage Names

' |Name |Range or form... |S{:ope |
+ |Test_Named_Pri $'Lulu-sales_all'. Document (Global)

+ Name:
Test_Mamed_Print_Range
+ Range or formula expression:

| $'Lulu-sales_all.$A$36:5D$45

A

| Scope:
Document (Global) ﬁ

| v Range Options

Print range Repeat column
Filter Repeat row
Add Delete
Help Cancel

Figure 192: Manage Names dialog

Repeat printing of rows or columns

If a spreadsheet is printed on multiple pages, you can define specific rows or columns (for
example, headings) to repeat print on each printed page.

Using print ranges

@ Edit Print Ranges
s Ok |
|-none- = ’ HEJ
Cancel
Rows to repeat
|-user defined - S ’51:53 ] lEJ Help

Columns to repeat

|-user defined - :)fsa HEJ

Figure 193: Repeat printing of rows and columns
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1) Go to Format > Print Ranges > Edit to open the Edit Print Ranges dialog (Figure 193).

2) Inthe Rows to repeat box, type the references for the rows to be repeat printed. For
example, to repeat rows 1, 2 and 3, type $1:$3. This automatically changes the Rows to
repeat drop-down from - none - to - user defined -.

You can also place the cursor in the Rows to repeat box and then, using the mouse, select
a cell in each row you want to be repeat printed. It is not necessary to select the whole row.

3) Inthe Columns to repeat box, type the references for the columns to be repeat printed. For
example, to repeat column A, type $A. This automatically changes the Columns to repeat
drop-down from - none - to - user defined -.

You can also place the cursor in the Columns to repeat box and then, using the mouse,
select a cell in each column you want to be repeat printed.

4) Click OK to save your changes and close the dialog.

Using named print ranges
You can also define named print ranges to use for repeat printing of rows or columns as follows:

1) Define and hame the rows and/or columns you want to repeat print. See “Named print
ranges” on page 203 for more information.

2) Select Repeat column and / or Repeat row from Range Options to define the columns
and / or rows for repeat printing in the Define Name dialog (Figure 190 on page 203).

3) Click Add to accept the data and close the dialog.
4) Go to Format > Print Ranges > Edit to open the Edit Print Ranges dialog (Figure 193).

5) Select the defined and named print ranges from the Rows to repeat and/or Columns to
repeat drop-down lists.

6) Click OK to save your changes and close the dialog.

Page breaks

While defining a print range can be a powerful tool, you may sometimes need to manually adjust
the page breaks to make sure the spreadsheet prints the way you want it to look. You can insert
two types of page breaks into a spreadsheet:

* Row break — is a horizontal page break inserted above a selected cell in a row. For
example, if the selected cell is H15, then a row break is created between rows 14 and 15.

e Column break — is a vertical page break inserted to the left of the selected cell in a
column. For example, if the selected cell is H15, then a column break is created between
columns G and H.

When a manual break is inserted, it appears as a blue line or as a bold line between the rows or
columns on the display. The actual appearance depends on your computer setup. To see manual
break lines more easily on your display, you can change their appearance. Go to Tools > Options
> LibreOffice > Application Colors and scroll down to the Spreadsheet section where you can
change how page breaks appear.

Inserting page breaks
1) Select the cell where you want to insert a manual break in the spreadsheet.
2) Go to Sheet > Insert Page Break on the Menu bar.

3) Select Row Break to insert a row break above the cell or Column Break to insert a column
break to the left of the cell.
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Alternatively, go to View > Page Break on the Menu bar, right-click in the spreadsheet and select
Row Break or Column Break from the context menu. Remember to go to View > Normal on the
Menu bar and return to the standard spreadsheet view.

Deleting page breaks
1) Select the cell where you want to delete a manual break from the spreadsheet.
2) Go to Sheet > Delete Page Break on the Menu bar.

3) Select Row Break to delete a row break from above the cell or Column Break to delete a
column break from the left of the cell.

Deleting multiple page breaks

Multiple manual row and column breaks can exist in the same spreadsheet. If you want to remove
all breaks from the spreadsheet:

1) Go to View > Page Break on the Menu bar.

2) Right-click in the spreadsheet and select Delete Page Breaks from the context menu to
remove all manual breaks from your spreadsheet.

3) Go to View > Normal on the Menu bar to return to the standard spreadsheet view.

Printing options for page styles

When using page styles for your spreadsheets, you can include printing options within the page
style; for example, page order, details, scale to be printed, and so on. Using page styles allows you
to quickly set up and change the printing options of different sheets within your spreadsheet. See
Chapter 4, Using Styles and Templates, for more information about page styles.

@ Page Style: Default

:Organizer' Page  Borders Background | Header anl:erE%

Page order
@ Top to bottom, then right

(0 Left to right, then down

§ First page number: 1 =
Print
[ column and row headers B charts
[ Grid B Drawing objects
[[] Comments [] Formulas
B oObjects/graphics & Zerovalues
Scale

Scaling mode: |Reducefenlarge printout =

Scaling Factor: 100% |~

il Cancel || Help H Reset

Figure 194. Page Style dialog — Sheet tab
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Make sure you have selected the correct sheet within the spreadsheet before setting the print
options. Go to Format > Page on the Menu bar to open the Page Style dialog, then click on the
Sheet tab (Figure 194) to set the printing options for a page style. The dialog indicates which page
style you are about to change.

* Page order — defines the order in which data in a sheet is numbered and printed when it
does not fit on one printed page. A preview of the page order is shown in the graphic on the
top right of the dialog in Figure 194.

— Top to bottom, then right — prints vertically from the left column to the bottom of the
sheet.

— Left to right, then down — prints horizontally from the top row of the sheet to the right
column.

— First page number — select this option if you want the first page to start with a number
other than 1. Enter the number of the first page in the box.

* Print — defines which elements of the spreadsheet are to be printed.
— Column and row headers — prints the column and row headers.

— Grid — prints the borders of the individual cells as a grid. For the view on screen, make
your selection under LibreOffice > Options > LibreOffice Calc > View > Grid lines.

— Comments — prints the comments defined in the spreadsheet. Comments will be
printed on a separate page, along with the corresponding cell reference.

— Objects/limages — includes all inserted objects (if printable) and graphics with the
printed spreadsheet.

— Charts — prints the charts that have been inserted into your spreadsheet.
— Drawing objects — includes all drawing objects in the printed spreadsheet.

— Formulas - prints the formulas contained in the cells, instead of the results of any
formulas used in the spreadsheet.

— Zero values — specifies that cells with a zero value are printed with a zero (0) in the
cell.

» Scale — defines a page scale for the printed spreadsheet.

— Scaling mode - select a scaling mode from the drop-down list. Appropriate controls for
the scaling mode selected will be shown below the drop-down list box.

i) Reducelenlarge printout — specifies a scaling factor to scale all printed pages.
Enter the scaling factor as a percentage in the box.

i) Fit print range(s) to width/height — specifies the maximum number of pages
horizontally (width) and vertically (height) on which every sheet with the current
page style is to be printed.

The print ranges are always scaled proportionally, so the resulting number of pages
may be less than specified. You may clear one of the boxes; then the unspecified
dimension will use as many pages as necessary. If you clear both boxes, the scaling
factor will be 100%.

iif) Fit print range(s) on nhumber of pages — specifies the maximum number of pages
to be printed for each sheet that uses the same page style. The scale will be
reduced as necessary to fit the defined number of pages.
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Headers and footers

Headers and footers are predefined pieces of text that are printed at the top or bottom of a sheet
outside of the sheet area. Headers and footers are set the same way and you can have different
content on left and right pages that use the same page style.

Setting headers and footers

To turn the headers or footers on in your spreadsheet:

1)
2)

3)
4)

5)

Select the sheet where you want to turn on the header or footer.

Go to Format > Page on the Menu bar to open the Page Style dialog and select the
Header (or Footer) tab (Figure 195). The Header and Footer tabs in the Page Style dialog
are identical.

Select the Header on or Footer on option.

Enter the values for the other options according to your requirements. These options are
described below.

Click OK to save your changes and close the dialog.
] Page Style: Report

Organizer Page  Borders  Background u Footer  Sheet

Header
Header on

Same content on left and right pages

Left margin: 0.00 cm Iél
Right margin: 0.00 cm Iél
Spacing: 0.25 cm Iél
Height: 050cm | |2

AutoFit height

More... Edit...

Figure 195: Page Style dialog — Header tab

Header on or Footer on — adds a header or footer to the current page style.

Same content on left and right pages — causes left and right pages to share the same
header or footer content. To assign a different header or footer to left and right pages,
deselect this option and then click Edit. See “Header or footer contents” on page 210 for
more information.

Left margin — enter the amount of space to leave between the left page margin and the left
edge of the header or footer.

Right margin — enter the amount of space to leave between the right page margin and the
right edge of the header or footer.

Spacing — enter the amount of space to maintain between the bottom edge of the header
and the top edge of the spreadsheet, or the top edge of the footer and the bottom edge of
the spreadsheet.

Height — enter the height for the header or footer.
AutoFit height — automatically adjusts the height of the header or footer to fit the content.
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Preview box — shown on the right side of Figure 195, this area displays a preview of the
current selection.

More — opens the Border/Background dialog, where you can define the appearance of
borders and background colors or images for headers or footers. See Chapter 4, Using
Styles and Templates, for more information.

Edit — opens the Header or Footer dialog where you can add, edit, or format text that is
placed in the header or footer. See “Header or footer contents” below for more information.

@ o Header (Page Style: Default)
Left area Center area Rightarea
i =

Cancel
Help

Header |Sheet1 s

customheader A | (28] (8] (&) 8] @) O]

Note

Use the buttons to change the font or insert field commands such as date, time, etc.

Figure 196: Header dialog

Header or footer contents

The headers and footers in a Calc spreadsheet have three columns for text. Each column can
either be empty or have different contents from the other columns.

1)
2)

3)

4)

5)

6)

7
8)

9)

Select the sheet where you want to turn on the header or footer.

Open the Page Style dialog (Figure 195), then select Header on or Footer on and the
options for the header or footer. See “Setting headers and footers” above.

Click Edit to open the Header or Footer dialog (Figure 196). If Same content on left and
right pages is deselected in the Page Style dialog, the Header or Footer dialog will have
tabbed pages where you can set the header or footer contents for right and left pages.

To enter standard contents into the header or footer, select an option from the Header or
Footer drop-down list.

To enter customized contents into the header or footer, click in one the area boxes and type
your text, or click in one of the area boxes and click one of the Custom header or Custom
footer icons. These icons are explained below.

To change the appearance of the text in the header or footer, click the Text Attributes icon
to open the Text Attributes dialog, where you can set the font, font effects and font position.

Click OK to save the changes to text attributes and close the Text Attributes dialog.

Click OK to save the changes to the contents of the header or footer and close the Header
or Footer dialog.

Click OK to save the changes to your header or footer and close the Page Style dialog.

The options available for a Custom header or Custom footer are as follows:
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* Text Attributes — opens a Text Attributes dialog where you can assign formats to new or
selected text. The Text Attributes dialog contains tabbed pages for Font, Font Effects, and
Position.

» Title — inserts a file name placeholder in the selected area. Click and select either Title,
File Name, or Path/File Name from the drop-down menu that opens. If a title has not be
assigned to the spreadsheet, the file name for the spreadsheet will be inserted instead.

» Sheet Name - inserts a placeholder in the selected area for the sheet name of the selected
sheet in the spreadsheet.

* Page - inserts a placeholder in the selected area for the page number. This allows
continuous page numbering in a spreadsheet.

* Pages — inserts a placeholder in the selected area for the total number of pages in the
spreadsheet.

+ Date — inserts a placeholder in the selected area for the current date which will be repeated
in the header/footer on each page of the spreadsheet.

* Time — inserts a placeholder in the selected area for the current time which will be repeated
in the header/footer on each page of the spreadsheet.

Exporting to PDF

Calc can export documents to PDF (Portable Document Format). This industry-standard file format
is ideal for sending a file for someone else to view using Adobe Reader or other PDF viewers.

A Warning

A document in PDF format is not protected against contents tampering or editing by
default. The PDF document contents can be edited by specialized software tools,
including LibreOffice Draw.

‘:Q:‘ Tip

Unlike Save As, the Export command writes a copy of the current document in a new
file with the chosen format, but keeps the current document and format open in your
session.

Quick export to PDF

Click the Export Directly as PDF icon on the Standard toolbar to export the entire spreadsheet
using the PDF settings most recently selected on the PDF Options dialog (see below). You are
asked to enter the file name and location for the PDF, but you do not get a chance to choose a
page range, image compression, or other options.

Controlling PDF content and quality

For more control over the content and quality of the resulting PDF, use File > Export as PDF. The
PDF Options dialog opens. This dialog has six tabs (General, Initial View, User Interface, Links,
Security, and Digital Signatures). Select the appropriate settings, and then click Export. Then
enter the location and file name of the PDF to be created, and click Save to export the file.

General tab of PDF Options dialog

On the General tab (Figure 193), you can choose which pages to include in the PDF, the type of
compression to use for images (which affects the quality of images in the PDF), and other options.
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For more information, see the Getting Started guide or the Help. In most cases, the defaults will be
what you need.

PDF Options >

General Initial View User Interface Links Security Digital Signatures

Range General
O Al O Hybrid PDF (embed ODF file)
) Pages: ] Archive (PDF/A, 150 13005)
(® Selection/Selected sheet(s); POF/A-2Zb PDF/A-1b
| View PDF after export [l Tagged PDF (add docurment structure)
Create POF form
Images Submit format: FDF W

(_) Lossless compression

® JPEG compression L] Allow duplicate field names

-

Quality: 90% - Structure
Beduce image resolution |300 DPI s Export bookmarks
] Comments as PDF annotations
Watermark L] Whole sheet export
[ Sign with watermark Export autormatically inserted blank pages

[] Use reference XObjects

Help Export Cancel

Figure 197: PDF Options dialog — General tab

Range section

All: Exports the entire document to PDF.

Pages: To export a range of pages within a selected sheet, use the format 3-6 (pages 3 to
6). To export single pages, use the format 7;9;11 (pages 7, 9, and 11), or a combination of
the two formats.

Selection/Selected sheet(s): Exports the selected material (a sheet or part of a sheet).

View PDF after export: If selected, your default PDF viewer will open and display the
newly exported PDF.

Images section

Lossless compression: Images are stored without any loss of quality. Tends to make
large files when used with photographs. Recommended for other kinds of images or
graphics.

JPEG compression: Allows for varying degrees of quality, in the range 1 to 100%. A
setting of 90% works well with photographs (small file size, little perceptible loss of quality).

Reduce image resolution: Select the required value from the options in the drop-down
menu. Lower DPI (dots per inch) images have lower quality. Higher DPI settings can greatly
increase the size of the exported file.

Watermark section

Sign with watermark: When this option is selected, a transparent overlay of the text you
enter into the text box will appear on each page of the PDF.

General section

Hybrid PDF (embed ODF file): Use this setting to export the document as a PDF file
containing two file formats: PDF and ODF. In PDF viewers it behaves like a normal PDF
file, and it remains fully editable in LibreOffice.
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* Archive (PDF/A, ISO 19005): PDF/Ais an ISO standard for long-term preservation of
documents, by embedding all the information necessary for faithful reproduction (such as
fonts) while forbidding other elements (including forms, security, and encryption). PDF tags
are written. Also select which version of the standard to use, PDF/A-1b or PDF/A-2b.

* Tagged PDF: Tagged PDF contains information about the structure of the document’s
contents. This can help to display the document on devices with different screens, and
when using screen reader software. Some tags that are exported are table of contents,
hyperlinks, and controls. This option can increase file sizes significantly.

* Create PDF form — Submit format: Use the drop-down menu to choose the format of
submitting forms from within the PDF file.

* Allow duplicate field names — If enabled, the same field name can be used for multiple
fields in the generated PDF file. If disabled, field names will be exported using generated
unigue names.

* Export bookmarks: Generally not used in Calc.
« Comments as PDF annotations: Exports comments as PDF notes. You may not want this!

* Whole Sheet Export: The setting allows you to export your Calc spreadsheet to PDF, with
the content of a sheet exported as one page in the PDF. This facility is not intended for
printing but allows you to easily see and review the full content of a spreadsheet document
in a PDF form, without the usual slicing of the sheets into printable pages. Preview pages
will have different sizes, as do the source sheets.

Z Note:

Selecting the Whole Sheet Export option causes Calc to disregard many of the other
settings on the PDF Options dialog.

* Export automatically inserted blank pages: Not available in Calc.

* Use reference XObjects: Reference XObjects enable one PDF file to import content from
another. More information can be found in section 8.10.4 of the PDF specification, ISO
32000-2:2017 (https://www.iso.org/standard/63534.html). If you are not familiar with
reference XObjects, leave this box unchecked.

Initial View tab of PDF Options dialog

On the Initial View tab (Figure 198), you can select how the PDF file opens by default in a PDF
viewer. The options should be self-explanatory.

& PDF Options

General||nitialview|Userlnterfal:e Links | Security

Panes Page layout

® y @® Default

() Bookmarks and page (O single page

O Thumbnails and page Pt

Open on page e () Continuous facing
Magnification | First pageis left

® Default

() Fitin window

) Fitwidth

() Fitvisible

() Zoom Factor 100% -

Figure 198: PDF Options dialog — Initial View tab
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User Interface tab of PDF Options dialog

On the User Interface tab (Figure 199), you can select options to control how a PDF viewer
displays the file. Some of these options are useful when you are creating a PDF to be used as a
presentation or a kiosk-type display.

& PDF Options

General InitialView|Userlnterfal:e|Links Security

window options User interface options
[[] Resize window to initial page: [] Hide menubar
[] Center window on screen [ Hide toolbar
[] Open in full screen mode [] Hide window controls

[ Display document title

Transitions Bookmarks
&/ Use transition effects ® All bookmark levels
(O Visible bookmark levels 1 =

Figure 199: PDF Options dialog — User Interface tab

Window Options
* Resize window to initial page: the PDF reader window displays the whole first page.

* Center window on screen: the PDF is shown in a reader window centered on screen.

* Open in full screen mode: the PDF reader window is in front of all other windows.

* Display document title:— the PDF is shown with the document title in the reader title bar.
Transitions — not used in Calc.

User Interface Options
* Hide menu bar: hides the reader menu bar when the document is active.

« Hide toolbar: hides the reader toolbar when the document is active.
 Hide window controls: hides the reader controls when the document is active.

Bookmarks
* All bookmark levels: shows all bookmark levels when the reader opens the PDF.

* Visible bookmark levels: shows bookmark levels down to the selected level (in the range
1 to 10) when the reader opens the PDF.

Links tab of PDF Options dialog
On the Links tab (Figure 200) you can select how bookmarks and hyperlinks are exported to PDF.

& PDF Options

General | Initial View Userlnterface|Links | Security

7] EExport bookmarks as named destinations:

[) Convert document references to PDF targets
] Export URLs relative to file system
Cross-document links

@® Default mode

() Open with PDF reader application

(O Open with Internet browser

Figure 200: PDF Options dialog — Links tab

Export bookmarks as named destinations
If you have defined Calc sheet hames, this option exports them as “named destinations” to
which Web pages and PDF documents can link.
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Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (such
as .odt, .ods, and .odp), this option converts the files’ extensions to .pdf in the exported PDF
document.

Export URLSs relative to file system
If you have defined relative links in a document, this option exports those links to the PDF.
See Relative hyperlinks in the Calc Help for more information.

Cross-document links
Defines the behavior of links clicked in PDF files. Select one among the following
alternatives:

— Default mode: The PDF links will be handled as specified in your operating system.

— Open with PDF reader application: Use the same application used to display the PDF
document to open linked PDF documents.

— Open with Internet browser: Use the default Internet browser to display linked PDF
documents.

Security tab of PDF Options dialog

Use the Security tab (Figure 201) to encrypt and set passwords when you export your spreadsheet
and create the PDF file. Setting encryption and passwords also allows you to apply restrictions on
printing and if changes or copying can be carried out on the PDF file.

@ PDF Options

General | Initial View | User Interface | Links | Security | Digital Signatures

File Encryption and Permission Printing

Not permitted

Low resolution (150 dpi
No open password set : P)
PDF document will not be encrypted High resolution

No permission password set

PDF document will be unrestricted Changes

Mot permitted
Inserting, deleting, and rotating pages
Filling in Form Fields
Commenting, filling in form fields
Any except extracting pages
Content
Enable copying of content

Enable text access for accessibility tools
Figure 201: PDF Options dialog — Security tab

Click the Set Passwords button to open the Set Passwords dialog (Figure 202) where you enter
the passwords. You can enter a password (Set open password) to open the file and an optional
password (Set permission password) to restrict what readers can do with the PDF file.

* With an open password set, the PDF can only be opened with the password. Once opened,
there are no restrictions on what the user can do with the document (for example, print,
copy, or change it).
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* With a permission password set, the PDF can be opened by anyone, but its permissions
can be restricted. See Figure 201. After you set a password for permissions, the other
choices on the Security tab become available.

* With both the open password and permission password set, the PDF can only be opened
with the correct password, and its permissions can be restricted.

The options on the Security tab become available only when passwords have been set.

Z Note

Permissions settings are effective only if the user’'s PDF viewer respects the settings.

@ o Sset passwords

Set open password

Password: [ ]

Confirm: [ l

Set permission password

Password: [ ]
Confirm: [ l
Help _ ; Cancel

Figure 202: Set passwords dialog

Digital Signatures tab of PDF Options dialog
This tab contains the options related to exporting a digitally signed PDF.

Digital signatures are used to ensure that the PDF was really created by the original author (that is,
you), and that the document has not been modified since it was signed.

The signed PDF export uses the keys and X.509 certificates already stored in your default key
store location or on a smartcard. The key store to be used can be selected under Tools > Options
> LibreOffice > Security > Certificate Path. (Not available on Microsoft Windows systems, where
LibreOffice will access the system certificate storage.) When using a smartcard, it must already be
configured for use by your key store. This is usually done during installation of the smartcard
software. Details about using these features is outside the scope of this chapter.

% PDF Options

General | Initial View User Interface Links Security | Digital Signatures

Certificate
Use this certificate to digitally sign PDF documents:

| Select... Clear
Certificate password:
Location:
Contact information:
Reason:

Time Stamp Authority: MNone

Figure 203: PDF Options dialog — Digital Signatures tab

» Use this certificate to digitally sign PDF documents: Click Select to open the Select
Certificate dialog, where all certificates found in your selected key store are displayed. If the
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key store is protected by a password, you are prompted for it. When using a smartcard that
is protected by a PIN, you are also prompted for that.

Select the certificate to use for digitally signing the exported PDF, then click OK.

All other fields on the Digital Signatures tab are accessible only after a certificate has been
selected.

* Certificate password: Enter the password used for protecting the private key associated
with the selected certificate. Usually this is the key store password. If the key store
password has already been entered in the Select Certificate dialog, the key store may
already be unlocked and not require the password again.

When using a smartcard, enter the PIN here. Some smartcard software will prompt you for
the PIN again before signing.

* Location, Contact information, Reason: Optionally enter additional information about the
digital signature that will be applied to the PDF. This information will be embedded in the
appropriate PDF fields and will be visible to anyone viewing the PDF. Each or all of the
three fields may be left blank.

* Time Stamp Authority: Optionally select a Time Stamping Authority (TSA) URL. During
the PDF signing process, the TSA will be used to obtain a digitally signed timestamp that is
then embedded in the signature. Anyone viewing the PDF can use this timestamp to verify
when the document was signed.

The list of TSA URLSs that can be selected is maintained under Tools > Options >
LibreOffice > Security > TSAs. If no TSA URL is selected (the default), the signature will
not be timestamped, but will use the current time from your local computer.

Exporting to other formats

LibreOffice uses the term “export” for some file operations involving a change of file type. If you
want to use another spreadsheet file format (for example, Microsoft Excel), use File > Save As. If
you want to create web pages from your spreadsheet, use File > Export.

E-mailing spreadsheets

LibreOffice provides several ways to send documents quickly and easily as an e-mail attachment in
OpenDocument format (LibreOffice default format), other spreadsheet formats, or as a PDF file.
You can also email a document to several recipients. For more information, see the Getting Started
Guide.

To send the spreadsheet as an email:

1) Goto File > Send on the Menu bar and select from the following options. LibreOffice opens
your default e-mail program (if set) with the spreadsheet attached in the selected format.

— Email Document: the spreadsheet is sent in its current format.
— E-mail as OpenDocument Spreadsheet: the spreadsheet is sent in the ODF format.
— E-mail as Microsoft Excel: the spreadsheet is sent in the Excel format (.xlsx).

— E-mail as PDF: The PDF Options dialog opens. Select the parameters to be used for
the PDF file. See “Controlling PDF content and quality” on page 211.

2) Inyour e-mail program, enter the recipient, subject, and any text you want to add, then
send the e-mail.
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Digital sighing of documents

To sign a document digitally, you need a personal key, also known as a certificate. A personal key
is stored on your computer as a combination of a private key, which must be kept secret, and a
public key, which you add to your documents when you sign them. You can get a certificate from a
certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a checksum is computed from the document’s
content plus your personal key. The checksum and your public key are stored together with the
document.

When someone later opens the document on any computer with a recent version of LibreOffice,
the program will compute the checksum again and compare it with the stored checksum. If both
are the same, the program will signal that you see the original, unchanged document. In addition,
the program can show you the public key information from the certificate. You can compare the
public key with the public key that is published on the web site of the certificate authority.

Whenever someone changes something in the document, the change breaks the digital signature.

On Windows operating systems, the Windows features for validating a signature are used. On
Linux systems, files that are supplied by Mozilla Thunderbird or Firefox are used to validate the
signature. For a more detailed description of how to get and manage a certificate, and signature
validation, see About Digital Signatures in the LibreOffice Help.

Applying digital signatures

The following procedure is only an example of how to digitally sign a document. The actual
procedure depends on how your computer is set up and the computer operating system.

1) Open the file that you want to digitally sign.
2) Go to File > Digital Signatures > Digital Signatures on the Menu bar.

— If you have set LibreOffice to warn you when the document contains comments (see
“Removing personal data” on page 220), you may see a message box asking whether
you want to continue signing the document.

— If the document contains comments, a warning dialog opens asking if you wish to
continue. Click Yes to continue, or click No to exit and take appropriate action to
remove the comments and restart this procedure.

— If you have not saved the document since the last change, a message box appears.
Click Yes to save the file. When you have saved the file, the Digital Signatures dialog
opens (Figure 204).
3) Click Sign Document to open the Select Certificate dialog (Figure 205).
Select the certificate you want to use and click OK to close the Select Certificate dialog.

The certificate used is displayed in the Digital Certificates dialog with an icon next to its
name. This icon indicates the status of the digital signature.

— Anicon with a red seal (5) indicates that the document was signed and the certificate
was validated.
— Anicon with a yellow caution triangle overlaying the red seal (&8 ) indicates that the
document is signed but that the certificate could not be validated.
— Anicon with a yellow caution triangle by itself (:!") indicates an invalid digital signature.
4) Click Close to close the Digital Signatures dialog and digitally sign your file.

A signed document shows an icon in the status bar. You can double-click the icon to view the
certificate. More than one signature can be added to a document.
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Z Note

If you make any changes to the document after digitally signing, the digital signature is
removed automatically and you have to repeat the above procedure to digitally sign it
again.

@ o Digital Signatures
The following have signed the document content:

Signed by Digital ID issued by Date

pstyke@gmail.com 'COMODO client Authentication and Se 12/18/2013 09:34:47

& Thesignatures in this document are valid

l View Certificate... ‘

Help Close

Figure 204: Digital Signatures dialog

Remove ‘

[ @ o Select Certificate

Select the certificate you want to use for signing

Issued to Issued by Expiration date

pstyke@gmail.com CcOMODO Client Authenticatio 12

oK H cancel H Help ‘

Figure 205: Select Certificate dialog

Sighing multiple times with same signhature

In the past, LibreOffice prohibited creating multiple signatures by the same author on a document,
because there was no semantic meaning of signing the same document multiple times. LibreOffice
now provides a signature description, so multiple signatures from the same author are now
allowed, because each signature can have a different meaning.

When you select File > Digital Signatures > Digital Signatures, the dialog (Figure 204) lists
existing signatures together with their description (if they have any).

When you click the Sign Document button, the dialog (Figure 205) for certificate selection now
also asks for an optional description.
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Changing the value of an existing description invalidates the signature.

Digitally signing macros

Normally, macros are part of a document. If you sign a document, the macros inside the document
are signed automatically. If you want to sign only the macros, but not the document, go to Tools >
Macros > Digital Signature on the Menu bar and apply the signature as described above.

Removing personal data

You may wish to ensure that personal data, versions, notes, hidden information, or recorded
changes are removed from files before you send them to other people or create PDFs from them.

* In Tools > Options > LibreOffice > Security > Options, you can set Calc to remind you
when files contain certain information and to remove personal information automatically on
saving.

» To remove personal and some other data from a file, go to File > Properties. On the
General tab, deselect Apply user data and then click Reset Properties. This removes any
names in the created and modified fields, deletes the modification and printing dates, and
resets the Total editing time to zero, the creation date to the current date and time, and the
Revision number to 1.

To remove version information, either go to File > Versions on the Menu bar, select the
versions from the list and click Delete, or go to File > Save As and save the file with a
different name.

220 | Removing personal data



) LibreOffice

Calc Guide

Chapter 7
Using Formulas and
Functions



Introduction

In previous chapters, we have been entering one of two basic types of data into each cell: numbers
and text. However, we will not always know what the contents should be. Often the contents of one
cell depends on the contents of other cells. To handle this situation, we use a third type of data: the
formula. Formulas are equations using numbers and variables to get a result. In a spreadsheet, the
variables are cell locations that hold the data needed for the equation to be completed.

A function is a predefined calculation entered in a cell to help you analyze or manipulate data. All
you have to do is add the arguments, and the calculation is made automatically. Functions help
you create the formulas needed to get the results that you are looking for.

Setting up a spreadsheet

If you are setting up more than a simple one-sheet system in Calc, it is worth planning ahead a
little. Make sure to:

* Avoid typing fixed values into formulas

* Include documentation (notes and comments) describing what the system does, including
what input is required and where the formulas come from (if not created from scratch)

* Incorporate a system of error-checking of formulas to verify that the formulas do what is
intended

The trap of fixed values
Many users set up long and complex formulas with fixed values typed directly into the formula.

For example, conversion from one currency to another requires knowledge of the current
conversion rate. If you input a formula in cell C1 of =0.75*B1 (for example to calculate the value in
Euros of the USD dollar amount in cell B1), you will have to edit the formula when the exchange
rate changes from 0.75 to some other value. It is much easier to set up an input cell with the
exchange rate and reference that cell in any formula needing the exchange rate. What-if type
calculations are also simplified: what if the exchange rate varies from 0.75 to 0.70 or 0.80? No
formula editing is needed and it is clear what rate is used in the calculations. Breaking complex
formulas down into more manageable parts, described below, also helps to minimize errors and aid
troubleshooting.

Lack of documentation

Lack of documentation is a very common point of failure. Many users prepare a simple sheet which
then develops into something much more complicated over time. Without documentation, the
original purpose and methodology is often unclear and difficult to decipher. In this case it is usually
easier to start again from the beginning, wasting the work done previously. If you insert comments
in cells, and use labels and headings, a spreadsheet can later be modified by you or others and
much time and effort will be saved.

Error-checking formulas

Adding up columns of data or selections of cells from a sheet often results in errors due to omitting
cells, wrongly specifying a range, or double-counting cells. It is useful to institute checks in your
spreadsheets. For example, set up a spreadsheet to calculate columns of figures, and use SUM to
calculate the individual column totals. You can check the result by including (in a non-printing
column) a set of row totals and adding these together. The two figures—row total and column total
—must agree. If they do not, you have an error somewhere.

You can even set up a formula to calculate the difference between the two totals and report an
error in case a non-zero result is returned (see Figure 206).
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Eror Checking Demonstration
Sum columns A, B and C
A B c Row Sums
0 0.64 0.02 0.66
0.43 0.23 0.753 1.41
0.91 0.57 0.39 2.07
0.07] 0.07 0.45 0.59
0.37] 0.33 0.04 0.74
0.34 0.06 0.98 1.38
0.95 0.34 0.6 1.94
0.93 0.08 0.63 1.64
0.6 0.82 0.17 1.6
Ceolumn Sums =SUM[E.22:E.29)| 4.26
ERROR!!!

Figure 206: Error checking of formulas

Creating formulas

You can enter formulas in two ways, either by using the Function Wizard, or by typing directly into
the cell or into the input line. A formula must begin with an = symbol, so when typing in directly, you
need to start a formula with one of the following symbols: =, + or —. Calc automatically adds the =
symbol for the formula, when starting with the + or — character. Starting with anything else causes
the formula to be treated as if it were text.

Operators in formulas

Each cell in the sheet can be used as a data holder or a place for data calculations. To enter data,
simply type in the cell and move to the next cell or press Enter. With formulas, the equals sign
indicates that the cell will be used for a calculation. An example of a mathematical calculation like
15 + 46 is shown in Figure 207.

While the calculation on the left used only one cell, the real power is shown on the right where the
data is placed in cells and the calculation is performed using references to the cells. In this case,
cells B3 and B4 were the data holders, with B5 the cell where the calculation was performed.
Notice that the formula was shown as =B3+B4. The plus sign indicates that the contents of cells B3
and B4 are to be added together and then have the result in the cell holding the formula. All
formulas build upon this concept. Other ways of using formulas are shown in Table 3.

These cell references allow formulas to use data from anywhere in the sheet being worked on, or
from any other sheet in the document that is opened. If the data needed was in different sheets,
they would be referenced by referring to the name of the sheet, for example
=SUM($Sheet2.B12+$Sheet3.A11).

Z Note

To enter the = symbol for a purpose other than creating a formula as described in this
chapter, type an apostrophe or single quotation mark before the =. For example, in the
entry '= means different things to different people, Calc treats everything after the
single quotation mark—including the = sign—as text.
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Simple Calculation in 1 Cell

Calculation by Reference

Figure 207: A simple calculation

A | B C 4 | B | C
1 1
2 2
3 =15+4f] 3 15
4 4 46
5 5
& 3 [
A B C A B | C
1 1
2 2
3 3 15
5 5 =h3+h4d
& 6
A B | C
1
2
3 15
4 46
g G1
6

Table 3: Common ways to use formulas

Formula

=A1+10

=A1*16%

=A1*A2
=ROUND(A1,1)
=EFFECT(5%,12)

=B8-SUM(B10:B14)
=SUM(B8,SUM(B10:B14))
=SUM(B1:B1048576)
=AVERAGE(BloodSugar)

=IF(C31>140, "HIGH",
"OK")

Description

Displays the contents of cell Al plus 10.

Displays 16% of the contents of Al.

Displays the result of multiplying the contents of A1 and A2.
Displays the contents of cell A1 rounded to one decimal place.

Calculates the effective interest for 5% annual nominal interest with
12 payments a year.

Calculates B8 minus the sum of the cells B10 to B14.
Calculates the sum of cells B10 to B14 and adds the value to BS8.
Sums all numbers in column B.

Displays the average of a named range defined under the name
BloodSugar.

Displays the results of a conditional analysis of data from two
sources. If the contents of C31 is greater than 140, then HIGH is
displayed, otherwise OK is displayed.
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Functions in Table 3 are identified by a word, for example ROUND, followed by parentheses, which
normally enclose references or numbers.

£7 Note
Users of some other spreadsheet software may be familiar with formulas that begin
with +, -, =, (, @, ., $, or #. A mathematical formula would look like +D2+C2 or +2*3.

Functions begin with the @ symbol such as @SUM(D2..D7),
@COS(@DEGTORAD(30)) and @IRR(GUESS,CASHFLOWS). Ranges are identified
such as A1..D3.

It is also possible to establish ranges for inclusion by naming them using Sheet > Named Ranges
and Expressions > Define, for example BloodSugar representing a range such as B3:B10.
Logical functions can also be performed as represented by the IF statement which results in a
conditional response based upon the data in the identified cell, for example

=IF(A2>=0, "Positive", "Negative")

A value of 3 in cell A2 would return the result Positive, a value of —9 the result Negative.

Operator types
You can use the following operator types in Calc: arithmetic, comparative, text, and reference.

Arithmetic operators

The addition, subtraction, multiplication, and division operators return numerical results. The
negation and percent operators identify a characteristic of the number found in the cell, for
example -37. The example for exponentiation illustrates how to enter a number that is being
multiplied by itself a certain number of times, for example 2/3 = 2*2*2.

Table 4: Arithmetical operators

Operator Name Example
+ (Plus) Addition =1+1

— (Minus) Subtraction =2-1

— (Minus) Negation -5

* (Asterisk) Multiplication =2*2

/ (Slash) Division =10/5

% (Percent) Percent 15%

A (Caret) Exponentiation 2"3

Comparative operators

Comparative operators are found in formulas that use the IF function and return either a true or
false answer; for example, =IF(B6>G12, 127, 0) which, loosely translated, means if the
contents of cell B6 are greater than the contents of cell G12, then return the number 127,
otherwise return the number O.

A direct answer of TRUE or FALSE can be obtained by entering a formula such as =B6>B12. If the
numbers found in the referenced cells are accurately represented, the answer TRUE is returned,
otherwise FALSE is returned.
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Table 5: Comparative operators

Operator Name Example
= Equal Al=B1

> Greater than Al1>B1

< Less than Al<B1
>= Greater than or equal to Al1>=B1
<= Less than or equal to Al<=B1
<> Inequality Al<>B1

If cell A1 contains the numerical value 4 and cell B1 contains the numerical value 5, the above
examples would yield results of FALSE, FALSE, TRUE, FALSE, TRUE, and TRUE.

Text operators

It is common for users to place text in spreadsheets. To provide for variability in what and how this
type of data is displayed, text can be joined together in pieces coming from different places on the
spreadsheet. Figure 208 shows an example.

[suM B A ® v [=B2&""&C2&","&D2
A [ B | ¢ | D | E F G
1
2 June 23 2010 =B2&""&C28&","&D2
3
ﬁ
[F2 f.z:\zaza""&cza","&oz
A | B | ¢ | b | E F G
1
2 June 23 2010 June 23, 2010
3
j

Figure 208: Text concatenation

In this example, specific pieces of the text were found in three different cells. To join these
segments together, the formula also adds required spaces and punctuation enclosed within
guotation marks, resulting in a formulaof=B2 & "" & C2 & ", " & D2. The result is the
concatenation into a date formatted in a particular sequence.

Calc has a CONCATENATE function which performs the same operation.

Reference operators

An individual cell is identified by the column identifier (letter) located along the top of the columns
and a row identifier (number) found along the left-hand side of the spreadsheet. On spreadsheets
read from left to right, the reference for the upper left cell is Al.

Thus in its simplest form a reference refers to a single cell, but references can also refer to a
rectangle or cuboid range or a reference in a list of references. To build such references you need
reference operators.

Reference range operator

The range operator is written as a colon. An expression using the range operator has the following
syntax:

reference upper left : reference lower right
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The range operator builds a reference to the smallest range including both the cells referenced
with the left reference and the cells referenced with the right reference.

[A1:D12 HE =
B

A C D E

@WHO’!M&NNHL

12 —1]

Figure 209: Reference operator for a range

In the upper left corner of Figure 209 the reference A1:D12 is shown, corresponding to the cells
included in the drag operation with the mouse to highlight the range.

Examples

A2:B4 Reference to a rectangle range with 6 cells, 2 column width x 3 row
height. When you click on the reference in the formula in the input
line, a border indicates the rectangle.

(A2:B4):C9 Reference to a rectangle range with cell A2 top left and cell C9

bottom right. So the range contains 24 cells, 3 column width x 8
row height. This method of addressing extends the initial range
from A2:B4 to A2:C9.

Sheetl.A3:Sheet3.D4 Reference to a cuboid range with 24 cells, 4 column width x 2 row
height x 3 sheets depth. (Assumes that sheets Sheetl, Sheet2, and
Sheet3 appear in that order on the Sheet tabs area.)

B:B Reference to all cells of column B.

A:D Reference to all cells of columns Ato D.
20:20 Reference to all cells of row 20.

1:20 Reference to all cell of rows 1 to 20.

When you enter B4:A2, B2:A4, or A4:B2 directly, then Calc will turn it to A2:B4. So the left top cell
of the range is left of the colon and the bottom right cell is right of the colon. But if you name the
cell B4 for example with _start and A2 with _end, you can use _start;_end without any error.

Reference concatenation operator
The concatenation operator is written as a tilde. An expression using the concatenation operator
has the following syntax:

reference left ~ reference right

The result of such an expression is a reference list, which is an ordered list of references. Some
functions can take a reference list as an argument, SUM, MAX, or INDEX for example.

The reference concatenation is sometimes called 'union’. But it is not the union of the two sets
'reference left' and 'reference right' as normally understood in set theory. COUNT(A1:C3~B2:D2)
returns 12 (=9+3), but it has only 10 cells when considered as the union of the two sets of cells.
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Notice that SUM(A1:C3,B2:D2) is different from SUM(A1:C3~B2:D2) although they give the
same result. The first is a function call with 2 parameters, each of them is reference to a range.
The second is a function call with 1 parameter, which is a reference list.

The reference concatenation also applies to whole rows and whole columns. For example
SUM(A:B~D:D) is the sum of all cells in columns A and B and the column D.

Reference intersection operator

The intersection operator is written as an exclamation mark. An expression using the intersection
operator has the following syntax:

reference left ! reference right

If the references refer to single ranges, the result is a reference to a single range, containing all
cells, which are both in the left reference and in the right reference.

If the references are reference lists, then each list item from the left is intersected with each one
from the right and these results are concatenated to a reference list. The order is to first intersect
the first item from the left with all items from the right, then intersect the second item from the left
with all items from the right, and so on.

Examples
A2:B4 ! B3:D6

This results in a reference to the range B3:B4, because these cells are inside A2:B4 and inside
B3:D6. This is illustrated in Figure 210, in which the cells in the range A2:B4 have orange
backgrounds and the cells in the range B3:D6 have thick black borders. The cells that have both
an orange background and a thick black border (B3:B4) form the intersection of the two ranges.

A | 8 | ¢ | o |

Figure 210: Simple example of reference intersection
operator

(A2:B4~B1:C2) ! (B2:C6~C1:D3)
First the intersections A2:B4!B2:C6, A2:B4!C1:D3,B1:C2!B2:C6, and B1:C2!C1:D3 are

calculated. This results in B2:B4, empty, B2:C2, and C1:C2. Then these results are concatenated,
dropping empty parts. So the final result is the reference list B2:B4 ~ B2:C2 ~ C1:C2.

A:B ! 10:10
Calculates the intersection of columns A and B with line 10, thus selecting A10 and B10.

You can use the intersection operator to refer a cell in a cross tabulation in an understandable way.
If you have columns labeled "Temperature' and 'Precipitation’ and the rows labeled 'January’,
'February', 'March’, and so on, then the following expression

'February' ! 'Temperature'
will reference the cell containing the temperature in February.

The intersection operator (!) has a higher precedence than the concatenation operator (~), but do
not rely on precedence.
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‘:@:‘ Tip

Always put in parentheses the part that is to be calculated first.

Relative and absolute references

References are the way that we refer to the location of a particular cell in Calc and can be either
relative (to the current cell) or absolute (a fixed amount).

Relative referencing

An example of a relative reference will illustrate the difference between a relative reference and
absolute reference using the spreadsheet from Figure 211.

1) Type the numbers 4 and 11 into cells C3 and C4 respectively of that spreadsheet.

2) Copy the formula in cell BS (=B3+B4) to cell C5. You can do this by using a simple copy
and paste or click and drag B5 to C5 as shown below. The formula in B5 calculates the sum
of values in the two cells B3 and B4.

3) Click in cell C5. The formula bar shows =C3+C4 rather than =B3+B4 and the value in C5 is
15, the sum of 4 and 11 which are the values in C3 and C4.

In cell B5 the references to cells B3 and B4 are relative references. This means that Calc interprets
the formula in B5, applies it to the cells in the B column, and puts the result in the cell holding the
formula. When you copied the formula to another cell, the same procedure was used to calculate
the value to put in that cell. This time the formula in cell C5 referred to cells C3 and C4.

A B C | D |
1
2
3 15 4
4 46 11
5 | E1l |
[ 6 |
A B C D
_1
_2
3 | 15 4
4 46 11
5 15,
3

Figure 211: Relative references

You can think of a relative address as a pair of offsets to the current cell. Cell B1 is 1 column to the
left of cell C5 and 4 rows above. The address could be written as R[-1]C[-4]. In fact earlier
spreadsheets allowed this notation method to be used in formulas.

Whenever you copy this formula from cell B5 to another cell, the result will always be the sum of
the two numbers taken from the two cells one and two rows above the cell containing the formula.

Relative addressing is the default method of referring to addresses in Calc.
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Absolute referencing

You may want to multiply a column of numbers by a fixed amount. A column of figures might show
amounts in US Dollars. To convert these amounts to Euros it is necessary to multiply each dollar
amount by the exchange rate. $US10.00 would be multiplied by 0.75 to convert to Euros, in this
case Eur7.50. The following example shows how to input an exchange rate and use that rate to
convert amounts in a column from USD to Euros.

1) Input the exchange rate Eur:USD (0.75) in cell D1. Enter amounts (in USD) into cells D2,
D3 and D4, for example 10, 20, and 30.

2) In cell E2 type the formula =D2*D1. The result is 7.5, correctly shown.

3) Copy the formula in cell E2 to cell E3. The result is 200, clearly wrong! Calc has copied the
formula using relative addressing: the formula in E3 is =D3*D2 and not what we want,
which is =D3*D1.

4) In cell E2 edit the formula to be =D2*$D$1. Copy it to cells E3 and E4. The results are now
15 and 22.5 which are correct.

The $ signs before the D and the 1 convert the reference to cell D1 from relative to absolute or
fixed. If the formula is copied to another cell the second part will always show $D$1. The
interpretation of this formula is “take the value in the cell one column to the left in the same row
and multiply it by the value in cell D1".

E2 v fx = [-02D1 E2 ~ fx B = |-DDd1

D E F L E F |
1 €0 75 1 £€0.75
2 100 750 2 s10 750
3 $20 3 200 ]
4 330 4 $30

Enter the conversion formula into E2, correct result, then copy it to E3.

E3 v x E = |-03m2 SUM | fx %8 <@ |-D2=sosh
E

D E F | D F
1 €0.75 1 £0.75
2 $10 7.50 2 $10 =D2°5D$1
3 2020000 3 $20 200.00
4| $30 4 530

E3 result is clearly wrong; change the formula in E2 to read absolute reference.

E2 ~| x B = |-Dres1 E3 ~| fx E = |-D3=0s1

D E F D E =
1 €0.75 1 €0.75
2 100 7.50) 2 510 7.50
3 320 200.00 3 520 16.00
4 530 4 330

Apply the correct formula from E2 to E3 to get the correct answer.

Figure 212: Absolute references

Cell references can be shown in four ways.
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Reference Explanation

D1 Relative, from cell E3 it is the cell one column to the left and two rows above
$D%$1 Absolute, from cell E3 it is the cell D1
$D1 Partially absolute, from cell E3 it is the cell in column D and two rows above
D$1 Partially absolute, from cell E3 it is the cell one column to the left and in row 1
iy
A~ TIp

To change references in formulas, highlight the cell and press F4 to cycle through the
four types of references. To cycle only part of the formula select the cells in the formula
bar and cycle with F4. Selecting the menu option Sheet > Cycle Cell Reference
Types is equivalent to pressing the F4 shortcut.

Knowledge of the use of relative and absolute references is essential if you want to copy and paste
formulas and to link spreadsheets.

Named ranges

Cells and cell ranges can have a name assigned to them. Naming cells and ranges enhances
formula readability and document maintenance. A simple example would be naming a range of
cells B1:B10 as “Weight” and sum all weights. The formula is =SUM(B1:B10).

When the range B1:B10 is named as Weight, you can transform the formula to =SUM(Weight). The
advantage is clear in terms of readability of the formulas.

Another advantage is that all formulas that have the named range as argument are updated when
the named range changes location or size. For example, if the range Weight is now in cells
P10:P30, you do not need to review all the formulas that have Weight as an argument; you only
need to update the named range Weight with the new size and location.

To define a named cell or range select the cell or range and use menu Sheet > Named Ranges
and Expressions > Define. The dialog in Figure 213 appears with the selected range and you
define the name and scope of the named range.

Define Name @

Define the name and range or formula expression.

MName:

Weight]

Range or formula expression:

§Sheet.SBSL$BS10 (2]
Scope:

Document (Global) El

— Range Options
Print range Repeat column

Filter Repeat row

Help l Add H Cancel ‘

Figure 213: Define Name dialog

You can also define a named range directly in the sheet by selecting the range and typing its name
in the Name Box at the left of the Formula Bar (Figure 214).
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Edit  View Insert Format Styles !
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Liberation Sans E 10 E B I Q

Weight =]l fix T =120
A B

2
2 21
: 22
23
24
: 25
7 26
: 27

: 28
0 29

1
Figure 214: Inserting name in the
range box to define a named range

To quickly access a named range, select the named range in the Name Box drop-down above. The
named range is shown on the screen and selected.

hManage Mames *

Marne |Range or formula expression Scope

Weight . ] 0 Document [Global)

MName:
Weight

Range or forrmula expression:

$5heet1.5B51:5B510 =]
Scope:
Document (Global) e
Range Options

Add Delete

Help oK Cancel

Figure 215: Manage Names dialog
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To modify a named range, use the Manage Names dialog (Figure 215). This dialog is accessed by
selecting Sheet > Named Ranges and Expressions > Manage from the Menu bar or pressing
Ctrl+F3.

Named expressions

You also can give a long or complex formula a name. To name a formula, open the Define Name
dialog (Figure 213) and enter the formula expression in the Range or formula expression box.
Name the expression and click Add.

As an example, suppose you need to compute in cells C1 to C10 the circumference of a set of
circles and you are given their radius in B1 to B10. Define a named expression
CIRCUMFERENCE, with expression =2*PI()*B1 and click Add to close the dialog. In cell C1, type
=CIRCUMFERENCE and press Enter. The formula is applied to cell C1. Copy cell C1 and paste in
the remaining cells from C2 to C10 and you have the circumferences of all the circles. All cells in
the range C1:C10 have the expression =CIRCUMFERENCE.

Note that the named expression uses the same rules for cell addressing, that is, absolute and
relative references.

Order of calculation

Order of calculation refers to the sequence in which numerical operations are performed and the
Wikipedia article at https://en.wikipedia.org/wiki/Order_of_operations provides useful general
background information. Division and multiplication are performed before addition or subtraction.
There is a common tendency to expect calculations to be made from left to right as the equation
would be read in English. Calc evaluates the entire formula, then based upon programming
precedence, breaks the formula down executing multiplication and division operations before other
operations. Therefore, when creating formulas you should test your formula to make sure that the
expected and correct result is being obtained. Following is an example of the order of calculation in
operation.

Table 6: Order of calculation

Left To Right Calculation Ordered Calculation

1+3*2+3 =11 =1+3*2+3 result 10

1+3=4,then 4 x 2 = 8, then 8+3 =11 3*2 = 6, then 1+6+3 = 10

Another possible intention could be: The program resolves the multiplication of 3 x 2
1+3*2+3 =20 before dealing with the numbers being added.

1+3 =4, then 2+3 =5, then 4 x 5=20

If you intend for the result to be either of the two possible solutions on the left, order the formula as:
((1+3)*2)+3 =11 (1+3) * (2+3) = 20

£7] Note

Use parentheses to group operations in the order you intend; for example,
=B4+G12*C4/M12 might become =( (B4+G12)*C4)/M12.

Calculations linking sheets

Another powerful feature of Calc is the ability to link data through several sheets. The naming of
sheets can be helpful to identify where specific data may be found. A name such as Payroll or
Boise Sales is much more meaningful than Sheetl. The function named SHEET() returns the
sheet number (position) in the collection of sheets. There may be several sheets in each document
and they may be numbered from the left: Sheetl, Sheet2, and so forth. If you drag the sheets
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around to different locations among the tabs, the function returns the number referring to the
current position of this sheet. In a new instance of Calc, the default is a single sheet.

For example, if the formula =SHEET() is put into A1 on Sheet 1 it returns the value 1. If you drag
Sheet 1 to be positioned between sheets 2 and 3 then the value changes to 2; it is now the second
sheet in the order.

An example of calculations obtaining data from other work can be seen in a business setting where
a business combines revenues and costs of each of its branch operations into a single combined
sheet. See the four parts of Figure 216 below.

r

— K | L | M | N |
. Flowing Abundantly,
Ltd.
| & |Combined Sales ¥TD
L4 |
5
6 Oct Mo Dec ¥TD
7 |Revenue:
[} Greenery Sales 36,286 52874 81,335 1,283,107
9 Fertilizer Sales 16,522 3,825 3 ,pO0 697,634
10 | Earth Sales 2018 459 432 84,479
11 |Sub-Total 55,129 57,158 85,367 2,065,220
12
13 |Cost of Sales:
14 | Wholesaler Purchases 18,744 19,434 29 025 702,175
15 | Sales Tax 5,054 5287 9300 227,174
16 |Sub-Total 24,808 25,721 38,415 929,349
17
18 [Tatal Revenue: 30,321 31,437 16,952 1,135,871
19
20 |Fynenses
LT[> 1P Seanch / Eranchz 7 rancha 7 cambined /71« ]
& K | L | M N
, Flowing Abundantly,
Ltd.
3 |Cornbined Sales YTD
_t
_s |
6| Oct Mo Dec ¥TD
_ 7 |Revenue:
5 Greenery Sales 38,2481 14 899 49 538 1,027,538
9 | Fenilizer Sales 5,120 2,384 7534 164,406
10 | Earth Sales 734 286 952 19,729
11 |Sub-Total 45,106 17,569 58471 1,211,673
1z
13 |Cost of Sales:
14 | “Whaolesaler Purchases 16,336 5973 19 881 411,969
15 | Sales Tax 4 962 15933 5432 133,284
16 |Sub-Total 20,298 7,906 26,313 545,253
17
158 [Total Revenue: 24,808 9,663 32,161 666,420
19
7n |Fynenzes
o 0 1 I Branch2 £ Branch3 4 ]
A k| L [ ™M ] ow
3 |Combined Sales ¥TD
4
5 Oct Dec ¥TD
& |Revenue:
7 | Greenery Sales 5801 88257 102179 1,498,444
8 | Fertilizer Sales 54 533 17 520 8,782 843,175
9 | Earth Sales 59025 16,824 7 B2 397,342
10 |Sub-Tatal 179,659 92,701 118,583 2,738,961
11
12 [Cost of Sales:
13 | Wholesaler Purchases G1084.06 3151834 4031822 931246.74
14 | Sales Tax 19762.43 119711 1304413 301285.7M1
15 |Sub-Tatal 80846.55 4171545 5336235 1232532.45
16
17 [Total Revenue: 98812 50086 65.221] 1,506,429
15

10 |Fynoncoc:
]« P\iPII; Branchl / Eranchz ', Branch3 / Combined / |||

Sheet containing data
for Branch 1.

Sheet containing data
for Branch 2.

Sheet containing data
for Branch 3.
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K7 v[ fg E = I=Branch1.K?+Branch2.K?+Branch3.K? Sheet Containing

b S combined data for all
Flowering Abundantly,
2 |Ltd. branches.
| 3 |Combined Sales ¥TD
P
| 5 | Cct Mo Dec ¥TD
| & |Revenue:
| 7 | Greenery Sales 167 890! 169,385 2856593 4,279,995
| 8 | Fertilizer Sales 126,488 39,085 21,164, 2,383,984
| 9 | Earth Sales 120,062 34,107 15 676 879,163
| 10 |=ub-Tatal 414,447 242,560 322,533 7,543,142
11
| 12 [Cost of Sales:
| 13 | Whalesaler Purchases 140,912 52,470 109661 2,564,668
| 14 | Sales Tax 45 589 26 B2 35479 829,746
| 15 |=ub-Total 186,501 109,152 145,140 3,394,414
16
| 17 [Total Revenue 227,946 133,408 177,393 4,148,728
18
10 |Fwn -
Ll | 4 b\ibll\ Branchl £ Eranch2 # Branch3 ' Combined / |4 ]

Figure 216: Combining data from several sheets into a single sheet

The sheets have been set up with identical structures. The easiest way to do this is to open a new
spreadsheet, set up the first branch sheet, input data, format cells, and prepare the formulas for
the various sums of rows and columns.

1) On the sheet tab, right-click and select Rename Sheet. Type Branchl. Right-click on the
tab again and select Move or Copy Sheet.

2) Inthe Move/Copy Sheet dialog (Figure 217), select the Copy option (automatically selected
if there is only one sheet in the spreadsheet) and select -move to end position- in the
Insert before area. Change the entry in New name to Branch2. Click OK. Repeat to
produce the Branch3 and Combined sheets.

Move/Copy Sheet

Action

Location
To document

Untitled1 {current document) hdl

Insert before

Branch1
- move to end position -

Mame
Mew name
Branchf

[ Help ] [ Ok l [ Cancel

Figure 217: Copying a sheet

3) Enter the data for Branch 2 and Branch 3 into the respective sheets. Each sheet stands
alone and reports the results for the individual branches.

4) In the Combined sheet, click on cell K7. Type =, click on the tab Branch1, click on cell K7,
press +, repeat for sheets Branch2 and Branch3, and press Enter. You now have a formula
in cell K7 which adds the revenue from greenery sales for the three branches.
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K7 vl fx B = |=Branchl.K?+Brand12.K?-IBrand13.K?
A | L M N

1
2 -

Flowing Abundantly Ltd
3 |Combined YTD
4
5 Oct Nov Dec
6 |Revenue:
7 |Greenery Sales m 126,030 233,102 4,279,995
g |Fertilizer Sales \ 23,829 20,316 2,383,984
g |Earth Sales 81,778 17,569 9,006 879,163
10 |Sub-Total 279,893 167,428 262,424 7,543,142
11
12 |Costof Sales:
13 |Wholesaler Purchases 98 572.06 T0,386.34 93358.22 2,564,668.00
14 |Sales Tax 3189049 2277111 3182413 829,746.00
15 |Sub-Total 130,462.55 93,157.45 130,192.35 3,394, 414.00
16
17 |[Total Revenue: 227,946 133408 177,393 4,148,728
18
19 |Expenses:
20

Figure 218: Combined sheet showing linking between branch sheets

5) Copy the formula, highlight the range K7:N17, click Edit > Paste Special > Paste Special,
uncheck the Paste all and Formats options in the Selection area of the dialog, check all
other options in that area, and click OK. You will see the following message:

' ‘fou are pasting data into cells that already contain data.
Do you really want to overwrite the existing data?

/ |

Warn me about this in the future.

e J[ w

Figure 219: Linking sheets: pasting a formula to a cell range

Help

6) Click Yes. You have now copied the formulas into each cell while maintaining the format set
up in the original sheet. Of course, in this example you would have to tidy up the sheet by
removing the zeros in the non-formatted rows.

Figure 220: Linking sheets: Copy / Paste Special from K7:N17

g Note

Ni7 vl fx B = | =Branch1.M17+Branch2.M17+Branch3.N17
A | k | L M [

i

? |Flowing Abundantly Ltd

3 |Combined YTD

4

5 Qct Now Dec YTD

& |Revenue:

7 |Greenery Sales 140,340 126,030 233,102 3,809,089

8 |Fertiizer Sales 77775 23,829 20,316 1,705,215

g |Earth Sales 81778 17,589 5,006 501,550

10 |Sub-Total 279,893 167,428 262424 6,015,354

11 0 0 0 0

12 |Cost of Sales: 0 0 0 0

13 |Wholezaler Purchases 98,572.06 70,386.34 9336832 2,045,300.74

14 |Sales Tax 3139049 2277111 3182413 661,743.71

15 |Sub-Total 130,462,565 93,157.45 130,192.35 2,707,134.45

16 0 0 0 0

17 Total Revenus: 153,941 92086 1433 aaonso0
] '

19 |Expenses:

LibreOffice default is to paste all the attributes of the original cells: formats, notes,
objects, text strings, and numbers.
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The Function Wizard can also be used to accomplish the linking. Use of this wizard is described in
detail in “Using the Function Wizard” on page 239.

Understanding functions

Calc includes over 500 functions to help you analyze and reference data. Many of these functions
are for use with numbers, but others are used with dates and times or even text. A function may be
as simple as adding two numbers together or finding the average of a list of numbers, or it may be
as complex as calculating the standard deviation of a sample or a hyperbolic tangent of a number.

Typically, the name of a function is an abbreviated description of what the function does. For
instance, the FV function gives the future value of an investment, while BIN2HEX converts a binary
number to a hexadecimal number. By tradition, functions are entered entirely in upper case letters,
although Calc will read them correctly if they are in lower or mixed case, too.

A few basic functions are somewhat similar to operators. Examples:

+  This operator adds two numbers together for a result. SUM() on the other hand adds groups of
contiguous ranges of numbers together.

*  This operator multiplies two numbers together for a result. PRODUCT() does the same for
multiplying that SUM() does for adding.

Each function has a number of arguments used in the calculations. These arguments may or may
not have their own name. Your task is to enter the arguments needed to run the function. In some
cases, the arguments have predefined choices, and you may need to refer to the text on the
Function Wizard and the Function List deck, or the Help, to understand them. More often, however,
an argument is a value that you enter manually, or one already entered in a cell or range of cells in
the spreadsheet. In Calc, you can enter values from other cells by typing in their name or range, or
—unlike the case in some spreadsheets—by selecting cells with the mouse. If the values in the
cells change, then the result of the function is automatically updated.

Compatibility with other spreadsheet applications

For many functions, Calc follows the OpenfFormula standard defined in Part 2 (Recalculated
Formula (OpenFormula) Format) of the Open Document Format for Office Applications
(OpenDocument) Version 1.2. This standard can be accessed at the OASIS website
(https://www.oasis-open.org/) or the ISO website (https://www.iso.org/standard/66375.html). Calc’s
general support for OpenFormula leads to a level of inherent compatibility with the function set of
any other spreadsheet application that follows the same standard. (There are some functions
within Calc that are not in accordance with OpenFormula but many of these are included
specifically to improve the exchange of files between Calc and Microsoft Excel.)

In order to improve interoperability, Calc is able to open spreadsheets created by many different
applications and able to save spreadsheets in many different formats. In the case of Microsoft
Office, it is extremely straightforward to exchange spreadsheet files between the two applications.
When Calc opens a Microsoft Excel spreadsheet, it automatically takes steps to avoid
incompatibilities that might otherwise be encountered with certain functions. For example, when
Calc opens an Excel file that contains calls to Excel's CEILING function, these are automatically
converted to reference Calc’s CEILING.XCL function. Similarly when Calc saves a spreadsheet to
Microsoft Excel format, it automatically takes steps to avoid potential incompatibilities. An example
of this occurs when Calc saves a spreadsheet containing calls to its FLOOR function, as these are
automatically converted to reference Excel’'s FLOOR.MATH function.

The Document Foundation’s wiki provides a comparison of the features of LibreOffice and
Microsoft Office, see https://wiki.documentfoundation.org/Feature_Comparison:_LibreOffice_-
_Microsoft_Office. This comparison shows that Calc currently provides 506 discrete functions, with
only 27 of those being unique to Calc, and the remainder having counterparts in Microsoft Excel. It
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is clear that there is a high level of commonality between the function sets of Calc and Excel, and
many functions can be used in both applications with no change, thus increasing interoperability.

There are cases where a Calc function produces a result in accordance with international
standards but the result differs from that produced by the equivalent Excel function. In such cases
Calc often has a similarly named function but with a suitable modifier added to its name (such as
“ ADD” or *_EXCEL2003") which provides the same result as the Excel function.

Understanding the structure of functions

All functions have a similar structure. If you use the right tool for entering a function, you can
escape learning this structure, but it is still worth knowing for troubleshooting.

As a typical example, the structure of a function to find cells that match entered search criteria is:
= DCOUNT(Database, Database field, Search criteria)

A function cannot exist on its own; it must always be part of a formula. Consequently, even if the
function represents the entire formula, there must be an = sign at the start of the formula.
Regardless of where in the formula a function is, the function will start with its name, such as
DCOUNT in the example above. After the name of the function comes its arguments. All arguments
are required, unless specifically listed as optional.

Arguments are added within the parentheses and are separated by commas. A Calc function can
take up to 255 arguments. An argument can be not only a number or a single cell, but also an array
or range of cells that contain several or even hundreds of cells.

Depending on the nature of the function, arguments may be entered as follows:

"text data" The quotes indicate text or string data is being entered.
9 The number nine is being entered as a number.

"g" The number nine is being entered as text.

Al The address for whatever is in Cell Al is being entered.
B2:D9 The range of cells is being entered.

Nested functions

Functions can also be used as arguments within other functions. These are called nested
functions.

=SUM(2, PRODUCT(5,7))

To get an idea of what nested functions can do, imagine that you are designing a self-directed
learning module. During the module, students do three quizzes, and enter the results in cells A1,
A2, and A3. In A4, you can create a nested formula that begins by averaging the results of the
quizzes with the formula =AVERAGE (A1 :A3). The formula then uses the IF function to give the
student feedback that depends upon the average grade on the quizzes. The entire formula would
read:

=IF(AVERAGE(A1:A3) >85, "Congratulations! You are ready to advance to the
next module", "Failed. Please review the material again. If necessary,
contact your instructor for help")

Depending on the average, the student would receive the message for either congratulations or
failure.

Notice that the nested formula for the average does not require its own equal sign. The one at the
start of the equation is enough for both formulas.
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If you are new to spreadsheets, the best way to think of functions is as a scripting language. We
have used simple examples to explain the concept more clearly, but, through nesting of functions,
a Calc formula can quickly become complex.

£7] Note

Calc keeps the syntax of a formula displayed in a tool tip next to the cell as a handy
memory aid as you type.

Using the Functions List deck

A more reliable method is to use the Functions List deck on the Sidebar (Figure 221), accessed by
selecting View > Function List.

The Functions List deck includes a brief description of each function and its arguments. Highlight
the function and look at the bottom of the pane to see the description. If necessary, hover the
cursor over the division between the list and the description; when the cursor becomes a two-
headed arrow, drag it upwards to increase the space for the description. Double-click on a
function’s name to add it to the current cell, together with placeholders for each of the function’s
arguments.

Using the Functions List deck is almost as fast as manual entry, and has the advantage of not
requiring that you memorize a formula that you want to use. In theory, it should also be less error-
prone. In practice, though, some users may fumble when replacing the placeholders with values.
Another feature is the ability to display the last formulas used.

i S
E-BH M8 £FTE & S QVEHE Sty B0 -
|
| | Default Liberation Sans [§ |10 a a a ﬁ' B-=== =2 a EB -
| cos £ X & =cos(Number) =] [l Functions o
| A B | &; | D | E B -
1 =Cos (I 3 C -
2 COMCAT
T COMCATENATE @
— CONFIDENCE A

4 CONFIDENCE.NORM

5 CONFIDENCE.T —
W CONVERT N
L | CONVERT_OOOQ

7 CORREL #x

8 cos
T COSH
[ | COoT
| 108 COTH

n cos:

12
13 | Number

Returns the cosine of a number.
+ | Sheetl
¥ |Find Find All || Formatted Display [ | Match Case C’{
h N7 molHe@AL € @« H %X 8- 0Tch
Sheet 1 of 1 Default English (Australia) m | [ Average: ; Sum:0 - ——C + | 120%

Figure 221: Functions List deck in Sidebar

Using the Function Wizard

The most commonly used input method is the Function Wizard (Figure 222). To open it, choose

Insert > Function, or click the Function Wizard icon fx on the Formula Bar, or press Ctrl+F2. The
Function Wizard provides the same help features as the Functions List deck, but adds fields in
which you can see the result of a completed function, as well as the result of any larger formula of
which it is part.

Using the Function Wizard | 239



Select a category of functions to shorten the list, then scroll down through the named functions and
select the required one by double-clicking on it. When you select a function its description appears
on the right-hand side of the dialog. Optionally you can type the function name in the search box
and the search narrows on each character inserted (Figure 222).

The wizard now displays an area to the right where you can enter data manually in text boxes or

click the Shrink button El.to shrink the wizard so you can select cells from the sheet.

Function Wizard @
Functions - SUM Function result |0
Search Returns the sum of all arguments.
Category
Number 1 (required
Mathematical IZ| req )
. Number 1, number 2, ... are arguments whose total is to be calculated.
Function
ROUNDDOWN -
ROUNDSIG
ROUNDUP
SEC P
Number 1 -fx -'—?
SECH ‘ =
SERIESSUM Number 2
SIGN
SIN Number 3
SINH Number 4 -
SQRT
SQRTPI
SUBTOTAL
SUMIF Formula Result |0
SUMIFS
SUMSQ | =sum ™
TAN 3 L
TANH T
TRUNC -
0 aray Nex
Figure 222: Functions tab of Function Wizard
| =sUM (S8}
Function Wizard - SUM({ number 1; ... ) —
o &

Figure 223: Function Wizard after shrinking

To select cells, either click directly on the cell or hold down the left mouse button and drag to select
the required area.

When the area has been selected, click the Expand button to return to the wizard again.

If multiple arguments are needed click in the next text box and repeat the selection process for the
next cell or range of cells. Repeat this process as often as required. The wizard will accept up to
255 ranges or arguments in the SUM function.

Click OK to accept the function, add it to the cell, and get the result.
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A Caution

If you select a function by double-clicking it in the list, and then change your mind and
select a different one by double-clicking again, then the second choice formula is
added into the first choice formula in the Formula text box. You must clear the Formula
text box and then double-click the function to add it to the box.

This additive facility allows you to create complex formulas by building them up in the
Formula box.

You can also select the Structure tab to see a tree view of the parts of the formula. The main
advantage over the Functions List deck is that each argument is entered in its own field, making it
easier to manage. The price of this reliability is slower input, but precision is generally more
important than speed when creating a spreadsheet.

The structure view of the wizard is important for debuging and fixing very long, nested, and
complex formulas. In this view, the formula is parsed, and each formula component is calculated by
a simpler function call or arithmetic operation and then combined following the rules of calculation.
It is possible to visualize each parsed element of the formula and check if the intermediate results
are correct, until the mistake is found.

Functions can be entered into the Input line. After you enter a function on the Input line, press the
Enter key or click the Accept button on the Formula Bar to add the function to the cell and get its

result.
SUM

® ¥ |=SUM(A1:A10)
| |
3 4

l—'l_
N

5

1 Name Box showing list of common functions

2 Function Wizard 4  Accept

3 Cancel 5 Inputline
Figure 224: The Formula Bar

If you see the formula in the cell instead of the result, then Formulas are selected for display in
Tools > Options > LibreOffice Calc > View > Display. Deselect Formulas, and the result will
display. However, you can still see the formula in the Input line.

‘:@:‘ Tip

The menu option View > Show Formula and the shortcut Ctr/+ (grave accent) also
toggle formulas on / off.

Array formulas

What is an array formula?

A formula in which the individual values in a cell range are evaluated is referred to as an array
formula. The difference between an array formula and other formulas is that the array formula
deals with several values simultaneously instead of just one.

Not only can an array formula process several values, but it can also return several values. The
results of an array formula is also an array.

When Calc updates the formulas, each affected cell is read and its formula is recalculated. If you
have a thousand cells in a column with the same formula (the formula expression only changes the
data to compute), you end with one thousand identical formulas to interpret and execute.
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Array formulas will evaluate the formula once and execute calculations as many time as the size of
the array, thus saving the time used to interpret each cell formula. And because Calc stores only
one formula for the entire array of data cells, it also save space in the spreadsheet file.

El [*] &% & = |(-10A1C5)
A | B | C \ D F | G |
1 2 3 20 30
_2 | 2 3 4 20 30 40
"3 | 3 4 5 30 40 50
4| 4 5 6 40 50 60
5 | 5 6 7 50 60 70

6

F/?gure 225: Source array in yellow and resulting array in green. The array
formula is shown in the formula bar.

To multiply the values in the individual cells by 10 in the above array (Figure 225), you do not need
to apply a formula to each individual cell or value. Instead you just need to use a single array
formula. Select a range of 3 x 5 cells on another part of the spreadsheet, enter the formula
=10*A1:C5 and confirm this entry using the key combination Ctr/+Shift+Enter. The resultis a 3 x 5
array in which the individual values in the cell range (A1:C5) are multiplied by a factor of 10.

In addition to multiplication, you can also use other operators on the reference range (an array).
With Calc, you can add (+), subtract (-), multiply (*), divide (/), use exponents ("), concatenation (&)
and comparisons (=, <>, <, >, <=, >=). The operators can be used on each individual value in the
cell range and return the result as an array if the array formula was entered.

Comparison operators in an array formula treat empty cells in the same way as in a normal
formula, that is, either as zero or as an empty string. For example, if cells A1 and A2 are empty the
array formulas {=A1:A2=""} and {=A1:A2=0} will both return a 1 column 2 row array of cells
containing TRUE.

When do you use array formulas?

Use array formulas if you have to repeat calculations using different values. If you decide to
change the calculation method later, you only have to update the array formula. To add an array
formula, select the entire array range and then make the required change to the array formula.

Arrays are an essential tool for carrying out complex calculations, because you can have several
cell ranges included in your calculations. Calc has different math functions for arrays, such as the
MMULT function for multiplying two arrays.

Creating array formulas

If you create an array formula using the Function Wizard, you must mark the Array check box each
time so that the results are returned in an array (Figure 222). Otherwise, only the value in the
upper-left cell of the array being calculated is returned.

If you enter the array formula directly into the cell, you must use the key combination
Shift+Ctrl+Enter instead of the Enter key. Only then does the formula become an array formula.

£7] Note

Array formulas appear in braces (curly brackets) in Calc. You cannot create array
formulas by manually entering the braces.

A Warning

The cells in a results array are automatically protected against changes. However, you
can edit or copy the array formula by selecting the entire array cell range.
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Strategies for creating formulas and functions

Formulas that do more than a simple calculation or summation of rows or columns of values
usually take a number of arguments. For example, consider the following equation:

1
x=xi+vit+—at2
2

This equation models the position of an object undergoing linear, translational motion, with
constant acceleration. The position (x) depends on time (t), and the equation also contains
constant values for initial position (xi), initial velocity (vi), and acceleration (a).

For ease of presentation, it is good practice to set up a spreadsheet in a manner similar to that
shown in Figure 226. In this example, the individual variables are input into cells on the sheet and
no editing of the formula (in cell B9) is required.

F& v fx 3w = || =508+ 5CSE EG+D.5"SCSTER"2
A | B | C | D | E F
_ 1 |Pasition as a function of time (), for linear, translational, constantly accelerated motion.
_2 | x=(U2pFart2 +v_ 't +x i
3
4 |[EXAMPLE: enter values in green t X
5 Jt time indep variable| [units of time) [(units of position)
nx position at time t |dep variable 0 50
7 |a acceleration 16 2 a2
2 |v.i initial velocity 5 4 193
9 % initial position 50 ) 368
10 | B 602
11| 10 900

Figure 226: Setting up a formula with arguments

You can take several broad approaches when creating a formula. In deciding which approach to
take, consider how many other people will need to use the sheets, the life of the sheets, and the
variations that could be encountered in use of the formula.

If people other than yourself will use the spreadsheet, make sure that it is easy to see what input is
required and where. Explanation of the purpose of the spreadsheet, basis of calculation, input
required and output generated are often placed on the first sheet.

A spreadsheet that you build today, with many complicated formulas, may not be quite so obvious
in its function and operation in 6 or 12 months. Use comments and notes liberally to document your
work.

You might be aware that you cannot use negative values or zero values for a particular argument,
but if someone else inputs such a value, will your formula be robust or simply return a standard
(and often not too helpful) Err: message? Itis a good idea to trap errors using some form of
logic statements or with conditional formatting.

Place a unique formula in each cell

The most basic strategy is to view whatever formulas are needed as simple and with a limited
useful life. The strategy is then to place a unique formula in each appropriate cell. This can be
recommended only for very simple or “throw away” (single use) spreadsheets.

Break formulas into parts and combine the parts

The second strategy is similar to the first, but instead you break down longer formulas into smaller
parts and then combine the parts into the whole. Many examples of this type exist in complex
scientific and engineering calculations where interim results are used in a number of places in the
sheet. The result of calculating the flow velocity of water in a pipe may be used in estimating losses
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due to friction, whether the pipe is flowing full or partially empty, and in optimizing the diameter for
the given flow regime.

In all cases you should adopt the basic principles of formula creation described previously.

Speeding up calculations

Spreadsheets are often used to process raw data and produce meaningful summaries,
consolidation and display of information for the decision maker or to be used as the source for
reports. The raw data can be produced by physical measurements, business transactions, or
various other means. Sheets with thousands or even hundreds of thousands of rows and several
columns are frequently found in finance departments or laboratories. Computations carried out on
these raw data sets can be time consuming and last for minutes, hours and perhaps, days.

A common mistake is to insert formulas for each cell and perform thousands of formulas
interpretation and calculations. Here are some recommendation for speeding up calculations.

Use array formulas on massive data

Array f