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This document guides you through translating AutoCAD files into MicroStation using a .CSV 
remapping file.  Steps 1-4 listed below should be followed when saving an AutoCAD file to 
MicroStation manually, without the use of a remapping file. The manual method should only be 
used on small files where a limited number of levels will need to be changed. In this case, use the 
change symbology tools in MicroStation as outlined in the Roadway Drafting Using MicroStation 
training manual. Once the levels have been changed manually, follow the steps listed under 
“Other Drawing Elements”, beginning on page 9, for updating text, cells, patterning, 
dimensioning, and models. For plotting AutoCAD files only, see the workflow, CDOT Printing 
AutoCAD Files in MicroStation.  
 
For this workflow not only will you be bringing the files into MicroStation, you will be updating 
the files to the CDOT configuration. This means all levels in the MicroStation drawing file will 
be standard CDOT levels having bylevel symbology and all drawing files you are translating will 
be set up using the standard CDOT workflows.  For any questions about the CDOT standard 
procedures and workflows please contact the CDOT Help Desk at 303-757-9317 for additional 
support on translating your files.     

 
Opening an AutoCAD file in MicroStation 

 
1. From the MicroStation Manager, open an AutoCAD (*.dwg) drawing file.  Change 

List Files of Type to CAD Files (*.dwg, *.dgn, *.dxf) to view AutoCAD files.  
Highlight the desired file and select OK.  

 

 
 
2. The MicroStation DWG/DXF Units dialog box will appear.  Verify the Units are 

set to Survey Feet and select OK.   
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3. Select File > Save As.   
 

 
 
4. Change the Select Format to Save to MicroStation V8 DGN Files (*.dgn).  and 

browse to the appropriate folder under the Projects directory.  The file will be 
automatically saved with the same name as the AutoCAD file with a different 
extension.  You can rename the file at this time if you choose to do so. Select 
Options.  

 

 
 
Note:  Model files are saved to the specialty group’s Reference_Files folder.  Sheet 
files are saved under the specialty group’s Drawings folder.  
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Editing the CSV file 
 

5. In the Save As V8 Option dialog box, open the template CSV file that is created 
when you run the CDOT – Create Project Directory application.  The CSV file 
maps all of the previous AutoCAD layers to the standard CDOT MicroStation levels.  
Select the Browse for CSV remapping file icon to edit the CSV file.   

 

 
 
6. Browse to C:/Projects/12345/Miscellaneous.  Select the file 12345.csv and select 

OK.  
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7. The CSV File field will be populated.  In the Save As V8 Options dialog box, select 
the Edit CSV remapping file icon.   

  

 
 
8. Microsoft Excel will activate.  If the Security Warning dialog box appears, select 

Enable Macros.   
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9. In Excel, the Level tab will be active.  Select the  icon that is embedded in the 
Level cell. 
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10. The fields under Level will be populated with the layers that are defined in the 
AutoCAD file. 
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11. In order to remap to the standard CDOT levels, you will need to manually populate 

the V8OutputLevel fields.  Use the standard CDOT levels that are located under the 
AutoCAD layers in the Level column to copy/paste to the V8OutputLevel column.  
When this is complete, Save the CSV file in Excel and Exit the Excel application 
window.     

 

 
 
 Note: Not all levels need to be populated.  Blank entries in V8OutputLevel column 

will be ignored when processed and the AutoCAD level (if occupied) will be brought 
into the MicroStation file.  Be aware that some of the MicroStation levels are not in 
alphabetical order. And take care to search the entire list for the desired level. 

  
 Layers generated in AutoCAD that will be recreated as cells in MicroStation such as 

the Border, North Arrow, and Bar Scales do not need to be remapped because they 
will automatically come in on the correct levels when the standard CDOT workflows 
are followed.   Also, the levels used for creating AutoCAD viewports do not need to 
be remapped.  Items on the Defpoints layer should be remapped to the level 
DRAFT_INFO_No-Plot.  
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 The line styles, color, and weight of each level has already been taken into account 
through the CSV file.  The translation variables in the CSV file have been set to 
remap all levels to bylevel symbology.   

 
12. In the Save As V8 Options dialog, select the Filter tab.  Select Models.   

 

 
 

13. From the Select Models dialog, you can isolate the Sheet Layouts from the Model 
file.  Sheet Layouts are carried over from the AutoCAD Paper Space functionality.  
Sheet Layouts are not used in the standard CDOT workflow.  However, they may 
contain information that will need to be copied to the model file or to the sheet file.  
If this is the case, the information will also need to be translated to CDOT’s standards 
using the same procedure outlined in this workflow.  The CSV file will only run for 
the file selected.  Highlight the Model file and select OK.   
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14. Check on the fields for Apply Level Mapping, Apply Line Style Mapping, Apply 
Color Mapping, and Apply Weight Mapping.  Select OK.   

 

 
 
15. Select OK in the Save As dialog box.  The CSV file will execute and the AutoCAD 

drawing file will be converted to a MicroStation file.   
 

 
 

The file that is now open in MicroStation is the converted file.  Running the CSV file 
changed the levels in the Model file to the CDOT Standard levels with bylevel 
symbology.   

 
16. From the MicroStation menu, selected Settings > Color Table after the MicroStation 

drawing file has been created.  
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17. Select File > Default. 
 

 
 

 
18. In the Color Table dialog, select Attach.   
 

 
 

19. Verify that the conversion was successful.  Select the Level Display icon from the 
MicroStation Primary toolbar. 

 
 
20. In the Level Display window, Data on the Used tab to sort the levels by those that 

have elements.  (Note: levels with elements will have a dot in this column.  If no used 
elements are visible, Data on the tab again.  If the triangle on the tab is pointing 
down, the used levels are at the top of the window.) 
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Other Drawing Elements 
 
21. Other updates will need to be made to the files so all drawing elements and sheet 

setups conform to the CDOT standards.   
 
22. All of the Sheet Layouts will need to be recreated using CDOT standard workflows.  

This means there can only be one Model for each MicroStation file. All of the sheet 
borders will need to be placed in their own separate file, called a Sheet File.  Then, 
the Model file will be referenced to the Sheet File.   Please refer to the documents 
CDOT Sheet File Creation, CDOT Sheet File Creation Multiple Scales, and CDOT 
Creating Multiple Plan Sheets for additional information about this procedure.  They 
are all accessed from the Windows Start menu under > All Programs > 
_CDOT_CADD_Information > Workflows. 

 
23. Recreate all Dimensions and leader lines (placed by AutoCAD) using the standard 

CDOT dimension styles. 
 

 
 
24. Erase all hatch patterns generated in AutoCAD recreate using the MicroStation 

Patterns tools, shown below, or using the CDOT Menus.   
 

 
 

25. All blocks generated in AutoCAD will need to be replaced with the standard CDOT 
MicroStation Cells. Cells may be placed using the MicroStation tools or the CDOT 
menus. 
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Updating Text 
 
26. Text created in AutoCAD with multiple text strings can be converted to a text node in 

MicroStation.  Some multiple text strings created in AutoCAD will be translated into 
a text node when the file is converted.   

To verify this, select the Element Information icon .  Text Nodes will display 
under the General Tab.   

 

 
 

27. If not, select all text that will be combined into a text node using the Element 
Selection tool.  While in the Element Selection command, hold down the Ctrl key to 
select individual text strings.  Highlight them in the order they are to be placed into 
the text node.  Do not Window around the multiple lines of text because the text 
strings may not merge in the desired order. 
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28. Select the TXT to Node utility from the CDOT Menus under Add On’s.   
 

 
 

29. Select the TXT to Node icon  
 
30. The following dialog box will appear. The selected text will be anchored to the 

cursor.  
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31. Check on Delete Original, set the Justification, and leave the Line Spacing set to 
1.00.  Place the text in the desired location. 

 

 
 

Note:  If the Justification is set to anything other than Left Bottom, double click on 
the text after it is placed.  The text will be brought into the Text Editor dialog.  Click 
again on the screen to place the text to its proper location and close the dialog. 
  

32. Select all text and key-in annotationscale add.  The text will now recognize the 
MicroStation Annotation Scale Factor.   

 

 
 

 
33. Update the text style by selecting Change Text Attributes.  Select the desired 

CDOT Text Style and select the text placed previously in AutoCAD.  

  
34. All fractions placed in AutoCAD will need to be re-typed in MicroStation so the 

format conforms to CDOT standards.     
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Compressing the Model File 
 
35. After all changes and updates have been made to update the drawing into 

MicroStation using CDOT standards and standard workflows, select File > 
Compress Design.  This will remove all AutoCAD information stored in the drawing 
buffer.  This will ensure that AutoCAD data does not get repopulated into the 
drawing.   

 
     

 
 
 
 
 
 
 
 
 
 
 
 
36. Under Compress > Options, verify that all options are checked ON.   
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Batch Conversion Of AutoCAD Files 
Entire directories can be processed at one time using the Batch Converter.  Using this 
option, a large number of files can be processed quickly.  However, because only one of 
the files can be used to create the csv file (the open file), many AutoCAD levels may be 
transferred to the MicroStation files.  As the user finds MicroStation files with AutoCAD 
levels, those files can be used to create a new csv file and the Batch Converter can be re-
run on all the files.  By repeating this process all of the AutoCAD levels will be gradually 
eliminated. 
 
The steps below describe how to set up and run the Batch Converter. 
 
37. Open one of the AutoCAD drawings to be converted with MicroStation as described 

in steps 1 and 2 above. 
38. Select Utilities > Batch Converter from the MicroStation menu.  The Batch 

Converter dialog box is displayed. 
 

 
 

39. Select Edit > Add Files from the menu. 
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40. From the Select Files and Directories to Convert dialog box, highlight the directory 
containing the files to be converted on the right side of the dialog box. Select the Add 
icon to add the directory to the Selected Files list at the bottom of the dialog box. 
Individual files can be selected from the list on the left side of the dialog box.  Be 
sure to select the Add button after each Directory or group of files from a directory is 
highlighted.  

 

 
 

41. After all of the desired files and directories have been added, select the Done icon.  
The Select Files and Directories to Convert is dismissed. 
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42. Back on the Batch Converter dialog box, select Edit > V8 Save Options from the 
menu. 

 

 
 

43. Follow steps 5 through 18 described above to edit the csv file that will be used to 
remap the levels of the selected files. 

 

 
 

44. From the Batch Converter dialog box, select the Process Batch Convert Job icon. 
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45. The Files To Convert dialog box is displayed.  From this dialog, select the Convert 
icon. 

 

 
 

46. When the processing is complete, select the Done icon to dismiss the dialog box. 
 

 
 

This will convert all of the levels in the active file (as specified in the csv file) and 
convert the same levels in the other specified files.   
 
It is possible that the other files processed will have other AutoCAD levels.  When these 
are discovered, repeat this conversion process on the previously converted MicroStation 
files.  This will clean up the file that is currently being used and update the levels in other 
specified files.   


