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                                                                     CHAPTER 1 
FINITE ELEMENT METHOD IN DESIGN ANALYSIS 
 

1.1 INTRODUCTION 
 

The finite element method has been a powerful tool for the numerical solution of a wide 

range of engineering problems. Application range from deformation and stress analysis of 

automotive, aircraft, building, defense, missile, and bridge structures to the field analysis of 

dynamics, stability, fracture mechanics, heat flux, fluid flow, magnetic flux, seepage and 

other flow problems. With the advances in computer technology and CAD systems Complex 

problems can be modeled with relative ease. Several alternate configurations can be tried out 

on a computer before the first prototype is built. The basics in engineering field is must to 

idealize the given structure for the required behavior. The proven knowledge in the typical 

problem area, modeling techniques, data transfer and integration, computational aspects of 

the finite element method is essential.  

 

Most often it is not possible to ascertain the behavior of complex continuous system without 

some sort of approximation. For simple members like uniform beams, plates etc,. Classical 

solutions can be sought by forming differential and/or integral equations through structures 

like machine tool frames. Pressure vessels, automobile bodies, ships, aircraft structures, 

domes etc, need some approximate treatment to arrive at their behavior, be it static 

deformation, dynamic properties or heat conducting property. Indeed these are continuous 

systems with their mass and elasticity being continuously distributed. The classical 

differential equation solution approach leads to intractability. To overcome this engineers and 

mathematicians have form time to time proposed complex structure is defined using a finite 

number of well-defined components. Such systems are then regarded as discrete systems. The 

discretization method could be finite difference approximation, various residual procedures 

etc. 

 

Finite element method comes under this category of discretization methods. R.W. Clough 

appears to be the first to use this term of finite element since 1960s there has been much 

progress in the method. The method requires a large number of computations requiring a fast 

computer. In fact digital computer advances have been responsible for the expanding usage of 

the finite element method. The finite element method was initially developed to solve 

structural problems. Its use of late, has been rapidly extended to various fields. The delivery 

of applications of the method can be  

 

 

seen from the following table 2.1, which still by no means can be claimed as complete since 

fields of usage are being continuously diversified. 
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1.2 METHODS OF ENGINEERING ANALYSIS 
 

The general methods for solving the practical problems can be classified as shown in figure: 

 

 
 

 

 

 

 

 

 

 

 

 

 

Fig.1.1. Block diagram of engineering analysis 

 

 Exact method Provides exact solution to the problems, but the limitation of this 

method is that all practical problems cannot be solved and even if they can be solved, 

they may have very complex solution. 

 Approximate analytical methods are alternative to the exact methods, in which 

certain functions are assumed to satisfy the geometric boundary conditions, but not 

necessary the governing equilibrium equations. These assumed functions, which are 

simpler, are then solved by any conventional method available. The solutions 

obtained from these methods have limited range of values of variables for which the 

approximate solution is nearer to the exact solution. 

 Numerical method has been developed to solve almost all types of practical 

problems. The two common numerical methods used to solve the governing equations 

of practical problems are numerical integration and finite element technique. 

 Methods of analysis 

 Approximate Methods (E.g. 

Rayleigh Ritz methods and 
Galerkin’s methods) 

  Numerical Methods  Analytical Methods 

 Exact Methods (E.g. 

separation of variables and 

Laplace transformation 

methods, Integration of 

differential equations) 

Numerical solution of 

governing differential 
equation 

 Finite Element Method  Boundary Element         
           Method 

 Numerical 

Integration 

  Finite Differences 
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 Numerical integration methods such as Runge-Kutta, Miline’s method etc. adopt 
averaging of slopes of given function at the given initial values. These methods yield 

better solutions over the entire field width but sometimes laborious. 

 Finite difference method the differential equations are approximated by finite 

difference equation. Thus the given governing equation is converted to a set of 

algebraic equations. These simultaneous equations can be solved by any simple 

method such as Gauss Elimination, gauss-Seidal iteration method, Crout’s method 
etc. the method of finite difference yield fairly good results and are relatively easy to 

program. Hence, they are popular in solving heat transfer and fluid flow problems. 

However, it is not suitable for problems with irregular geometry and not suitable for 

problems of rapidly changing variables such as stress concentration problems. 

 Finite Element Method (F.E.M) has emerged out to be powerful method for all 

kinds of practical problems. In this method the solution region is considered to be 

built up of many small-interconnected sub regions, called finite elements. These 

elements are applied with an interpolation model, which is simplified version of 

substitute to the governing equation of the material continuum property. The stiffness 

matrices obtained for these elements are assembled together and the boundary 

conditions of the actual problems are satisfied to obtain the solution all over the body 

or region FEM is well suited for computer programming. 

 Boundary element method (B.E.M) like finite method is being used in all 

engineering fields. In this approach, the governing differential equations are 

transformed into integral identities applicable over the surface or boundary. These 

integral identities are integrated over the boundary, which is divided into small 

boundary segments. As in finite element method provided that the boundary 

conditions are satisfied, set of linear algebraic equations emerges, for which a unique 

solution is obtained. 

 

1.3 INTRODUCTION TO FEM 

 
In the field of engineering, it is necessary to obtain the unknown field parameters like 

displacement or forces, which can describe the behavior of structures. These unknowns can 

be obtained by using exact analytical solutions or energy methods, which are formulated with 

governing equilibrium equations of analytical solutions on the basis of solid mechanics. 

However in practice the real structure viz., aircraft/automobiles, civil, naval architecture, 

offshore and nuclear engineering are large in size with irregular shapes, intermediate in 

nature, possessing geometrical material non-linearity and having complicated loading or 

boundary conditions. 

          In these cases, to reduce the continuous system to a discrete one by conventional 

method, a lot of effort and assumption must be made, which are  

 

cumbersome and error prone. The advent of high-speed electronic computer has given 

tremendous opportunity to the numerical method approach. The most commonly used 

numerical technique in solving engineering problems is FEM, because 

1. Algebraic work corresponding to the solid mechanics is programmed in systematic 

matrix calculations and formulated into mathematical model. User need not work with 

complicated algebra but only to deal with the discredited geometry of the physical 

structural. 

2. Ability to consider alternate loading and bending condition for the same geometry. 
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3. Accuracy of data mainly depends on the number of approximations. Since in FEM we 

can make lesser number of assumptions, degree of accuracy will be high with a 

minimum percentage or error from the exact value. 

4. Faster and automatic calculations, which are repetitive in nature, simultaneous display 

of modification and part processing results. 

5. Accurate prediction with adequate details for identifying critical areas of interest like 

highly stressed regions. 

 

1.4 FINITE ELEMENT METHOD 

 
          The given system or structure is divided into small elements of units interconnected at 

grid points. Each element is solved variable, inherently making use of classical procedures 

and analytical. This process of breaking down of continuum of finite discrete elements and 

solving for the variable (velocity, displacement, stress and loads etc) is called finite element 

analysis. 

The two methods used for the analysis of a problem in FEM are: 

 

(a) Force method:  Here the forces are unknown (minimum complimentary energy 

method) 

 

(b) Displacement Method:  Here the displacements are unknown (minimum potential 

energy method) 

 

The analysis by FEM involves the following steps. 

 

1. Pre-processing:  It is the act of preparation of data such as nodal locations, element 

connectivity co-ordinates imposing boundary conditions applications of load and providing 

material information to element etc. one can decide in this stage regarding the number of 

nodes, elements, types with their order and the pattern of FE mesh. 

2. Processing:  This stage involves stiffness generation, stain energy calculation and 

solutions of equations resulting in the evolution of nodal variables, induced elemental forces, 

strains and stresses. 

3. Post-Processing:  The geometric deformation and distribution of forces, stresses 

and strains in the structure, here the aspect of plotting a displaced plotting nodal date in the 

form of contour plots, such as isotherms and isobars, and conversion of element oriented data 

into best fitting nodal values is discussed. 

 Preprocessing and post processing are integral parts of finite element analysis. The 

general purpose mesh generation scheme can model a variety of complex regions.  

 The node numbering gives spars matrices and in many cases should given minimum 

bandwidth proper block representation.   

Mesh plotting shows the element layout. 

 

1.5 WHAT IS FEA? 
 

Finite Element Analysis is a way to simulate loading conditions on a design and 

determine the design’s response to those conditions. 
 The design is modeled using discrete building blocks called elements. 

• Each element has exact equations that describe how it responds to a certain 

load. 
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• The “sum” of the response of all elements in the model gives the total 

response of the design. 

• The elements have a finite number of unknowns, hence the name finite 

elements. 

 The finite element model, which has a finite number of unknowns, can only 

approximate the response of the physical system, which has infinite unknowns. 

                  So the question arises:  How good is the approximation? 

Unfortunately, there is no easy answer to this question.  It depends entirely on 

what you are simulating and the tools you use for the simulation.  We will, 

however, attempt to give you guidelines throughout this training course. 

 

     

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

    

 

                Physical System                                                F.E. Model 

 

 

1.6 DEGREES OF FREEDOM 
 

       Degrees of freedom (DOFs) characterize the response of a field.  
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1.7 BASIC CONCEPTS OF FINITE ELEMENT METHOD 
 

 Full field is divided into finite number of elements. 

 Knowing the behavior of one/many elements one can predict the assemblage. 

 It is to predict the behavior of individual elements under load. 

 Minimum potential energy principle is used to evaluate element stiffness.  

 Independent of the problem to be solved, stiffness of the element can be obtained. 

 

1.8 TERMINOLOGY IN THE FINITE ELEMENT METHOD 
 

The commonly used terminologies in FE analysis are as follows. 

 

1. Discritization 

         The physical structure has to be represented by a mathematical model in such way that 

it simplify the construction and easy to analyze.  In modeling the given global domain is 

divided into sub-domains called elements.  This process of modeling is termed as 

discrimination, which includes proper selection of type and density of the elements, the 

location of the nodal points for applying loads/boundary conditions, to extract the results 

from the areas of interest. 

 

 

2. Grids 

         The point in space used for defining the geometry and connecting the elements.  These 

points are useful to specify the displacement, force and boundary conditions of the structure. 

 

3. Displacement 

         Displacement defines the deformation or the movement caused by an external force.  

There are six displacements for an element in space.  These are three translations vectors u; v 

and w and are three rotational vectors with respect to x, y and z. co-ordinate system.  These 

nodal variables are referred to as degrees of freedom. 

 

4. Co-ordinate System 

         A co-ordinate system is the reference, which can specify the position of a point or an 

element in a space.  The co-ordinate systems used are. 

 Global co-ordinate system (Cartesian i.e. x. y. z.) 

 Local co-ordinate system. 

 Polar co-ordinate system(r. 0) 

 Cylindrical co-ordinate system(r. 0. z) 
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 Spherical co-ordinate system(r. 0) 

 Can be Cartesian also (x. y. z) 

5. Boundary Conditions/Constraints 

 Resistance (reaction) offered at grid points due to the motion of the structure being 

constrained by the applied forces.  

             These reactions can be obtained with respect to the specified co-ordinate  

              System.              

 To prevent the rigid body motion there by reducing the continuous structure to 

discrete system(avoiding the phenomena of mechanism) 

 These constraints can be zero (u. v. w. x. y. z = 0) or non-Zero and specified 

enforced displacement at grid points. 

 

1.9 STEPS INVOLVED IN FEM 

 
The basic steps involved in finite element method are as follows. 

1. Modeling 
         The basic idea of finite element modeling is to discretize the region and expresses the 

displacement in terms of values at discrete points. 

2. Discritization 

         Discritization means division of a given structure into finite number elements of better 

approximations.  This forms the first step in the analysis of complicated structural system. 

 

3. Formulation of elemental equation and convergence test 

 

         The properties of the elements are formulated and combined to obtain the solution for 

the entire body or structure.  For e.g. in the displacement formulation widely adopted in FE 

analysis, simple functions known as shape functions are chosen to approximate the variation 

of the displacement at the nodes of the element.   

 

 

Convergence test is done to know that how much the approximate solution converges to the 

exact value and the errors are calculated. 

4. Determination of 

 

         a. Elemental stiffness matrix [Ke] 

         b. Elemental nodal displacement vector [Qe] 

         c. Elemental load vector [Fe] 

5. Equilibrium equations are imposed so that each of the elements is in a state of    

    Equilibrium 

                            [Ke] [Qe] = [Fe] 

 

6. Assembly of 

 

a. Stiffness matrix of all the elements [K] 

b.  Nodal displacements of all the elements [Q] 

c. Nodal forces of all elements [f] 

d. Overall stiffness matrix is formed by global addition of element stiffness matrices. 

 

 

7. Assembled Equilibrium Equation 
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         The equation of equilibrium for the entire structure of body is then obtained by 

combining the equilibrium equation of each element such that the continuity of displacement 

is ensured at each node where the elements are connected. 

                   [K] [Q] = [F] 

8. Application of boundary conditions to the overall equilibrium equation. 

 

         The necessary conditions are imposed and the equations of equilibrium are solved for 

the nodal displacements. There are two approaches of applying the boundary conditions. 

a. Elimination technique 

         In this technique after imposing the boundary conditions, whichever displacement is 

Zero, the corresponding row and column of the overall equilibrium is eliminated. 

b. Penalty approach 

         A second approach for handling boundary condition is the penalty approach.  This 

approach easily implemented in a computer program and retains its simplicity even when 

considering general boundary conditions where a large value of C is added to the highest 

diagonal elements.  On applying the boundary conditions, the overall equilibrium equation 

gets modified. 

c. Solution of the modified overall equilibrium equation by gauss elimination method 

         The value of nodal displacements will be obtained in this step.  Thus knowing of all the 

nodal displacements, stain of each element will be computed.  From these values elemental 

stresses are obtained. 

Computation of Stains: 

         For each element stain calculated is given by the overall equation 

   [] = {b} {q} 

 Where   []   =   Strain Matrix 

                         {b}    = Strain Displacement Matrix where be is unique for each element 

              {q} =   Elemental Nodal Displacement Vector. 

Computation of Stress: 
         Knowing the strain, the stress is calculated as follows 

          i.e., [] = {D} {}   Where   [] = Stress Matrix 

                                                                         {D} = Constitutive Matrix for plane stress 

                                                                         {} = Strain Matrix 

         These are the main steps carried out in structural problems where the analysis is simple.  

It becomes complicated thereafter for each and every problem, which includes dynamic 

analysis where the forces and all the conditions vary with time.  In thermal, it is transient 

analysis and in fluid flow situations, it is turbulent flow analysis.  The finite element method 

was initially developed on a physical basis for the analysis of problems in structural 

mechanics; however, it was soon recognized that the method can be applied equally well to 

the solution of many other classes or problems. 

 

1.10 MERITS OF FEM 

 
The merits of finite element method are: 

 The systematic generality of finite procedure makes it a powerful and versatile tool 

for a wide range of problems.  Thus flexible, general-purpose computer programs can 

be developed and can be applied to various problems with little or no modification. 

 FEM can be easily interpreted in physical terms and it has a strong mathematical base.  

Hence, finite element method can be easily applied to any problem with a proper 
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knowledge of the physical system under consideration and can be solved to a greater 

accuracy by the application of proper mathematical tool. 

 Non-homogeneous continuum can also be dealt with by merely assigning different 

properties to different elements.  It is even possible to vary the properties within an 

element according to the polynomial applied. 

 Finite element method accommodates complex geometry with ease and is capable of 

handling non-linear and time dependent system also. 

 In finite element method, since boundary conditions are introduced in the assembled 

equations, it requires only to specify the geometric boundary conditions without 

regarding its effects on interior elements.  Since the boundary conditions do not enter 

into the individual finite element equations, the field variable models need not be 

changed, when the boundary conditions change. 

 Finite element method considers the multidimensional continuity of the body.  Hence 

it does not require separate interpolation process to extend the approximate solution to 

every point with in the continuum.  Also it does not require the trial solutions that 

must all apply to the entire multidimensional continuum. 

 

1.11 LIMITATIONS OF FEM 
 

 FEM has been developed as a very high solution technique.  However, the solution 

obtained from FEM can be realistic if and only if the material properties are known   

precisely. 

 The major draw back of FEM is sensitivity of the solution on the geometry of the 

element such as type, shape and orientation of elements used. 

 The compute programs yield a large amount of data as results it is very difficult to 

separate out the required results from the pile of numbers. 

 

 

1.12 ERRORS INHERENT IN FEM FORMULATION 
 

1. Geometry is simplified. 

 

 
 

 

2. Field quantity is assumed to be a polynomial over an element. (Which is not true) 

 

 
 

3. The computer carries only a finite number of digits. 
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4. The computer carries only a finite number of digits. 

14159265.341421356.12:g.e   

 

Mistakes by Users 

 

1. Elements are of the wrong type: e.g.) Shell elements are used where solid elements are 

needed 

 

2. Distorted elements 

 

3. Supports are insufficient to prevent all rigid-body motions 

 

4. Inconsistant units (e.g. E=200 GPa, Force = 100 lbs) 

 

Element Properties: The discretization of the structure or body into Finite Elements forms 

the basic first step in the analysis of a complicated structural system.  

 

Rules For Discretization Of The Structure Into Elements: Sub-division of a body or 

structure into Finite Elements should satisfy the following requirements:  

1. Two distinct elements can have common points only on their common boundaries if such 

boundaries exist. No overlapping is allowed. Common boundaries can be points, lines or 

surfaces.  

 

2. The assembled element should leave no holes within the two elements and approximate 

the geometry of the real body or structure as closely as possible to do. 

 

When the boundary of a structure or body cannot be exactly represented by the elements 

selected, an error cannot be avoided. Such error is called Geometric Discretization Error and 

it can be decreased by reducing the size of the elements or by using elements allowing 

boundaries to become curved. 

 

Mesh Generators: The finite element models for practical analysis can contain tens of 

thousands or even hundreds of thousands degrees of freedom. It is not possible to create such 

meshes manually. Mesh generator is a software tool, which divides the solution domain into 

many Sub domains – finite elements. Mesh generators can be of different types.  

 

For two-dimensional problems, we want to mention two types: block mesh generators and 

triangulates. 

 

Block Mesh Generators require some initial form of gross partitioning. The solution domain 

is partitioned in some relatively small number of blocks. Each block should have some 

standard form The mesh inside block is usually generated by mapping technique. 
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Triangulators typically generate irregular mesh inside arbitrary domains. Voronoi polygons 

and Delaunay triangulation are widely used to generate mesh. Later triangular mesh can be 

transformed to the mesh consisting of quadrilateral elements. Delaney triangulation can be 

generalized for three dimensional domains. 

 
Finite Element Model of Gear tooth 
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Three-dimensional stress on an element. 

 

 

PICTORIAL SUMMARY OF ELEMENTS TYPES 

 

Refer ANSYS Help 

 

COMMERICAL FEM SOFTWARE PACKAGES AVAILABLE 

 

 ANSYS – (General Purpose, PC and workstations). 

 SDRC/I-DEAS-- (Complete CAD/CAM/CAE Package). 

 Nastran – (General purpose FEA on main frames) 

 ABAQUS—(Non linear and dynamic analyses) 

 ALGOR – (PC & Workstations). 

 DYNA-3D – (Crash/Impact analysis). 
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                                                                                                              Chapter 2  
INTRODUCTION TO ANSYS 
 

 ANSYS is a complete FEA software package used by engineers worldwide in 

virtually all fields of engineering: 

o Structural 

o Thermal 

o Fluid, including CFD (Computational Fluid Dynamics) 

o Electrical / Electrostatics 

o Electromagnetics 

 A partial list of industries in which ANSYS is used: 

o Aerospace 

o Automotive 

o Biomedical 

o Bridges & Buildings 

 ANSYS/Multiphysics is the flagship ANSYS product which includes all 

capabilities in all engineering disciplines. 

 

 

 

 There are three main component products derived from ANSYS/Multiphysics: 

o ANSYS/Mechanical - structural & thermal capabilities 

o ANSYS/Emag - electromagnetics 

o ANSYS/FLOTRAN - CFD capabilities 

 Other product lines: 

o ANSYS/LS-DYNA - for highly nonlinear structural problems 

o DesignSpace - an easy-to-use design and analysis tool meant for quick 

analysis within the CAD environment 

o ANSYS/ProFEA - for ANSYS analysis & design optimization within 

Pro/ENGINEER 
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 Structural analysis:  is used to determine deformations, strains, stresses, and reaction 

forces. 

 

o Static analysis 

 Used for static loading conditions. 

 Nonlinear behavior such as large deflections, large strain, contact, plasticity, 

hyper elasticity, and creep can be simulated 

o Dynamic analysis 

 Includes mass and damping effects. 

 Modal analysis calculates natural frequencies and mode shapes. 

 Harmonic analysis determines a structure’s response to sinusoidal loads of 
known amplitude and frequency. 

 Transient Dynamic analysis determines a structure’s response to time-varying 

loads and can include nonlinear behavior. 

o Other structural capabilities 

 Spectrum analysis 

 Random vibrations 

 Eigenvalue buckling 

 Substructuring, submodeling 

o Explicit Dynamics with ANSYS/LS-DYNA 

 Intended for very large deformation simulations where inertia forces are 

dominant. 

 Used to simulate impact, crushing, rapid forming, etc. 

 

 

 Thermal analysis: is used to determine the temperature distribution in an object.  

Other quantities of interest include amount of heat lost or gained, thermal gradients, 

and thermal flux. All three primary heat transfer modes can be simulated:  conduction, 

convection, radiation. 

o Steady-State 

 Time-dependent effects are ignored. 

o Transient 

 To determine temperatures, etc. as a function of time. 

 Allows phase change (melting or freezing) to be simulated. 

 

 

o Electromagnetic analysis is used to calculate magnetic fields in electromagnetic 

devices. 

 

o Static and low-frequency electromagnetics 

 To simulate devices operating with DC power sources, low-frequency AC, or 

low-frequency transient signals. 

 

o Computational Fluid Dynamics (CFD) 

 To determine the flow distributions and temperatures in a fluid. 

 ANSYS/FLOTRAN can simulate laminar and turbulent flow, compressible 

and incompressible flow, and multiple species. 

 Applications:  aerospace, electronic packaging, automotive design 
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 Typical quantities of interest are velocities, pressures, temperatures, and film 

coefficients. 

2.2 THE GUI LAYOUT 

 
Utility Menu 

Contains functions which are available throughout the ANSYS session, such as file controls, selecting, 

graphics controls, parameters, and exiting. 

 

Toolbar Menu 

Contains push buttons for executing commonly used ANSYS commands and functions.  Customized 

buttons can be created. 

 

Graphics Area 

Displays graphics created in ANSYS or imported into ANSYS. 

 

Input Line 

Displays program prompt messages and a text field for typing commands.  All previously typed 

commands appear for easy reference and access. 

 

Main Menu 

Contains the primary ANSYS functions, organized by processors (preprocessor, solution, general 

postprocessor, etc.) 

 

Output 

Displays text output from the program.  It is usually positioned behind the other windows and can be 

raised to the front when necessary. 

Resume:  
This is opening a previously saved database. It is important to know that if you simply 

resume a database, it doesn’t change the job name. For example: You start ANSYS with a job 
name of “file”. Then you resume my model.db, do some work, then save. That save is done to 
file.db! Avoid this issue by always resuming using the icon on the toolbar. If you open 

Output  
Window 

Icon Toolbar Menu 

Abbreviation Toolbar Menu 

Utility Menu 

Graphics Area 

Main Menu 

Input Line Raise/Hidden Icon 

Current Settings 
User Prompt Info 
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mymodel.db using this method, it resumes the model and automatically changes the job name 

to my model.  

 

Plotting:   
Contrary to the name, this has nothing to do with sending an image to a plotter or 

printer. Plotting in ANSYS refers to drawing something in the graphics window. Generally 

you plot one type of entity (lines, elements, etc.) to the screen at a time. If you want to plot 

more than one kind of entity use, “Plot → Multiplot”, which by default will plot everything in 

your model at once.  

 

Plot Controls:  

This refers to how you want your “plot” to look on the screen (shaded, wire frame, 
entity numbers on or off, etc). Other plot control functions include sending an image to a 

graphics file or printer. 

 

Creating Geometry: 

 

Geometry in ANSYS is created from 

 “Main Menu → Preprocessor → Modeling → Create” and has the following terminology,  
 

KEYPOINTS: These are points, locations in 3D space.  

LINES: This includes straight lines, curves, circles, spline curves, etc. Lines are typically 

defined using existing keypoints.  

AREAS: This is a surface. When you create an area, it’s associated lines and keypoints are 
automatically created to border it.  

VOLUMES: This is a solid. When you create a volume, it’s associated areas, lines and 
keypoints are automatically created.  

SOLID MODEL: In most packages this would refer to the volumes only, but in ANSYS this 

refers to your geometry. Any geometry. A line is considered a “solid model”.  
You can’t delete a child entity without deleting its parent, in other words you can’t delete a 

line if it’s part of an area, can’t delete a key point if it’s the end point of a line, etc. 
 

Boolean Operations:  

 

Top Down style modeling can be a very convenient way to work. Instead of first 

creating keypoints, then lines from those keypoints, then areas from the lines  

 

and so on (bottom up modeling), start with volumes of basic shapes and use Boolean 

operations to add them, subtract them, divide them etc. Even if you are creating a shell 

model, for example a box, you could create the box as a volume (a single command) and then 

delete the volume keeping the existing areas, lines and keypoints.  

These kinds of operations are found under “Main Menu → Preprocessor → Modeling → 
Operate → Booleans” with some common ones being:  
Add: Take two entities that overlap (or are at least touching) and make them one.  

Subtract: Subtract one entity from another. To make a hole in a plate, create the plate (area 
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of volume) then create a circular area or cylinder and subtract it from the plate.  

Glue: Take two entities that are touching and make them contiguous or congruent so that 

when meshed they will share common nodes. For example, using default mesh parameters, 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Meshing without gluing areas.                                         Meshing after gluing areas.  
 

Note: In case of Meshing after gluing areas.  The coincident nodes on the common line between the 

two areas will be automatically merged. You don’t have to manually equivalence them like in some 
other codes. 

 

The Working Plane:  

 

All geometry is created with respect to the working plane, which by default 

is aligned with the global Cartesian coordinate system. The “Working 
Plane” is actually the XY plane of the working coordinate system. The 
working coordinate system ID is coordinate system 4 in ANSYS. Global 

Cartesian is ID 0, Global Cylindrical is ID 1, and Global Spherical is ID 2. 

Working Plane Hints: 

 

Turn on the working plane so you can see it with, “Utility Menu → 
Work Plane → Display Working Plane”.  
Change the way the working plane looks or adjust the snap settings under 

“Utility Menu → Work Plane → WP Settings…”.  
Move the working plane around using  
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“Utility Menu → Work Plane → Offset WP to…”.  
Align the working plane with various parts of the model using  

“Utility Menu → Work Plane → Align WP with…”.  
If you select more than one node or keypoint to offset the working plane to, it will go to the 

average location of the selected entities. VERY handy!  

Use the working plane to slice and dice your model. For example to cut an area in pieces use  

“Main Menu → Modeling → Operate → Booleans → Divide → Area by WrkPlane”. Do this 
for lines and volumes as well. 

Select Logic: 

  

Selecting is an important and fundamental concept in ANSYS. Selected entities are 

your active entities. All operations (including Solving) are performed on the selected set. In 

many operations you select items “on the fly”; ANSYS prompts for what volumes to mesh 
for example, you pick them with the mouse, and ANSYS does the meshing.  

However there are many times when you need to select things in more sophisticated 

ways. Also, in an ANSYS input file or batch file you can’t select things 
with the mouse!  

 

Examples where this would be useful:  

 

• You have many different areas at Z = 0 you want to constrain. You could 

select them all one by one when applying the constraint, or select “By 
Location” beforehand, then say “Pick All” in the picking dialog.  

 

• You have a structure with many fastener holes that you want to constrain. 
Again, you could select them all one by one when applying the 

constraint, or select lines “By Length/Radius”, type in the radius of the 
holes to select all of them in one shot, then “Pick All” in the picking 
dialog when applying the constraint.  

 

After working with the selected set,  

“Utility Menu → Select → Everything” to make the whole model active 
again. 

Select Entities Dialog Box Terminology:  

 

From Full: Select from the entire set of entities in the model.  

Reselect: Select a subset from the currently selected entities.  

Also Select: Select in addition to (from the whole model) the set you have currently selected.  

Unselect: Remove items from the selection set.  

Select All: This is not the same as “Utility Menu → Select → Everything”. This selects all of 
whatever entity you have specified at the top of the dialog.  

Invert: Reverses the selected and unselected entities (just the entities specified at the top of 

the dialog).  

OK: This does the select operation (or brings up a picker dialog so that you can pick with the 

mouse) and then dismisses the dialog.  

Apply: This does the operation but keeps the dialog box. Typically use this so the dialog 

stays active.  

Replot: Replots whatever is active in the graphics window.  
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Plot: Plots only the entity specified at the top of the dialog.  

 

Organizing Your Model Using Components:  

 

If you select a group of entities and think that you might want to use that selection set again, 

create a component out of it. Components are groups of entities but hold only one kind of 

entity at a time. Components can themselves be grouped into Assemblies, so this is how you 

group different types of entities together. Use “Utility Menu → Select → Comp/Assembly → 
Create Component…” to create a component. The new Component Manager in Release 8.0 
makes it very easy to manage and manipulate groups and select/plot what you want to see to 

the screen. This is found under “Utility Menu → Select → Component Manager” 

 

Creating a Material:  

 

Create the material properties for your model in  

“Main Menu → Preprocessor → Material Props → Material Models”. This gives you this 
dialog box where all materials can be created,  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Double click on items in the right hand pane of this window to get to the type of material 

model you want to create. All properties can be temperature dependant. Click OK to create 

the material and it will appear in the left hand pane. Create as many different materials as you 

need for your analysis.  
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Selecting an Element Type:  
 

ANSYS has a large library of element types. Why so many? Elements are organized into 

groups of similar characteristics. These group names make up the first part of the element 

name (BEAM, SOLID, SHELL, etc). The second part of the element name is a number that is 

more or less (but not exactly) chronological. As elements have been created over the past 30 

years the element numbers have simply been incremented. The earliest and simplest elements 

have the lowest numbers (LINK1, BEAM3, etc), the more recently developed ones have 

higher numbers. The “18x” series of elements (SHELL181, SOLID187, etc) are the newest 

and most modern in the ANSYS element library.  

Tell ANSYS what elements you are going to use in your model using “Main Menu → 
Element Type → Add/Edit/Delete” 

 

 

  

 

 

 

 

 

Later, when meshing or creating elements manually you will need to tell ANSYS what type 

of elements you want to create.  

 

Creating Properties  
 

A solid element (brick or tet) knows its thickness, length, volume, etc by virtue of its 

geometry, since it is defined in 3D space. Shell, beam and link (truss) elements do not know 

this information since they are a geometric idealization or engineering abstraction. Properties 

in ANSYS are called Real Constants. Define real constants using “Main Menu → Real 
Constants → Add/Edit/Delete”. 
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Creating the Finite Elements Model - Meshing: 

  If you are just starting out in FEA, it is important to realize that your geometry (called 

the solid model in ANSYS) is not your finite element model. In the finite element method we 

take an arbitrarily complex domain, impossible to describe fully with a classical equation, 

and break it down into small pieces that we can describe with an equation. These small pieces 

are called finite elements. We essentially sum up the response of all these little pieces into the 

response of our entire structure The solver works with the elements. The geometry we create 

is simply a vehicle used to tell ANSYS where we want our nodes and elements to go. While 

you can create nodes and elements one by one in a manual fashion (called direct generation in 

ANSYS) most people mesh geometry because it is much another very good reason we mesh 

geometry is that we assign materials and properties to that geometry.  

Then any element created on or in that geometric entity gets those attributes. If we don’t like 
the mesh we can clear it and re-mesh, without having to re-assign the attributes. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



CAMA-LAB (06MEL67) VI SEMESTER 22 

 

Steps for Creating the Finite Elements: 

 Assign Attributes to Geometry (materials, real constants, etc). 

 Specify Mesh Controls on the Geometry (element sizes you wa 

 Mesh.  

 

Most of the meshing operations can be done within the MeshTool, so that will be examined 

in some detail now. Start it from “Main Menu → Preprocessor → Meshing → MeshTool”. 
 

Smart Size is used to automatically  

pick the element edge length depending  

on the sizes of features in the geometry.  

It makes a finer mesh around smaller  

Features in order to capture them  

adequately.  

For example in the mesh below  

no sizes were specified at all  

except a Smart Size level of 4. 

 
A mapped mesh generates a very regular  

grid of elements. This can only be used on  

rectangular shaped areas or volumes.  

A free mesh will mesh any entity  

regardless of shape. 

 

 

Applying Loads and Boundary Conditions:  

 

Loads and boundary conditions can be applied in both the Preprocessor  

(“Main Menu → Preprocessor → Loads → Define Loads → Apply”), and the Solution 
processor  

(“Main Menu → Solution → Define Loads → Apply”).  
1. Select the kind of constraint you want to apply.  

2. Select the geometric entity where you want it applied.  

3. Enter the value and direction for it.  

 



CAMA-LAB (06MEL67) VI SEMESTER 23 

 

There is no “modify” command for loads and B.C.’s. If you make a mistake simply apply it 
again with a new value (the old one will be replaced if it’s on the same entity), or delete it 
and reapply it.  

Loads: Forces, pressures, moments, heat flows, heat fluxes, etc.  

Constraints: Fixities, enforced displacements, symmetry and anti-symmetry conditions, 

temperatures, convections, etc.  

Although you can apply loads and boundary conditions to nodes or elements, it’s generally 
better to apply all B.C.’s to your geometry. When the solve command is issued, they will be 
automatically transferred to the underlying nodes and elements. If B.C.’s are put on the 
geometry, you can re-mesh that geometry without having to reapply them 

 

Solving:  
 

Solution is the term given to the actual simultaneous equation solving of the 

mathematical model. The details of how this is done internally is beyond the scope of this 

guideline but is addressed in a separate “ANSYS Tips” white paper. For the moment, it is 
sufficient to say that the basic equation of the finite element method that we are solving is, 

[K]{u}={F}  

where [K] is the assembled stiffness matrix of the structure,  

          {u} is the vector of displacements at each node, and  

          {F} is the applied load vector. This is analogous to a simple spring and is the 

essence of small deflection theory.  

To submit your model to ANSYS for solving, go to “Main Menu → Solution → Solve → 
Current LS”. LS stands for load step. A load step is a loading “condition”.  
This is a single set of defined loads and boundary conditions (And their associated solution 

results. More on this in the next section). Within an interactive session the first solve you do 

is load step 1, the next solution is load step 2, etc.  

If you leave the solution processor after solving to do post-processing for example, the load 

step counter gets set back to one. You can also define and solve multiple load steps all at 

once.  

There are several solvers in ANSYS that differ in the way that the system of equations is 

solved for the unknown displacements. The two main solvers are the sparse solver and the 

PCG solver. If the choice of solvers is left to “program chosen” then generally ANSYS will 
use the sparse solver. The PCG (preconditioned conjugate gradient) solver works well for 

models using all solid elements. From a practical perspective one thing to consider is that the 

sparse solver doesn’t require a lot of RAM but swaps out to the disk a lot. Disk I/O is very 
slow. If you have a solid model and lots of RAM the PCG solver could be significantly faster 

since the solution runs mostly in core memory 

 

Postprocessing:  

 

The General Postprocessor is used to look at the results over the whole model at one 

point in time. This is the final objective of everything we have discussed so far; finding the 

stresses, deflections, temperature distributions, pressures, etc. These results can then be 

compared to some criteria to make an objective evaluation of the performance of your design.  

The solution results will be stored in the results file as result “sets”. For a linear static 
analysis like we are talking about, the correlation between Load Step numbers and Results 

Set numbers will be one to one as shown below. Only one set of results can be stored in the 
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database at a time, so when you want to look at a particular set, you have to read it in from 

the results file. Reading it in clears the previous results set from active memory. 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

To read in a results set from the results file (not needed if you have run only a single load 

step) use “Main Menu → General Postproc → Read Results → First Set, or By Pick”. Most 
results are displayed as a contour plot as shown below. To generate a plot of stresses use 

“Main Menu → General Postproc → Plot Results → Contour Plot → Nodal Solution”, then 
pick the stresses you want to see 

.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

There are many, many other ways to look at your results data including:  

• Listing them to a file.  
• Querying with the mouse to find a result at a particular node.  
• Graphing results along a path.  
• Combining different load cases.  

• Summing forces at a point.  
• Extracting data and storing it an APDL array that you can do further operations with.  
 

Animate any result on the deformed shape with “Utility Menu → Plot Ctrls → Animate”. 
This is very helpful for understanding if your model is behaving in a reasonable way.
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            Chapter 3 

 

ANSYS EXERCISE (PART – A) 
 

PART A.1:STRESS ANALYSIS OF BARS OF CONSTANT CROSS 

SECTION AREA  
 

Problem 1 
 A steel rod subjected to compression is modeled by two bar elements, as shown in 

Figure. Determine the nodal displacements and the axial stress in each Element.  

E=207 GPa, A = 500 mm
2
 

 

Procedure: 
1. Utility Menu > File > Change Jobname > Enter ‘Bar Analysis’ 
2. Utility Menu > File > Change Title > Enter Bar Analysis. 

3. Preprocessor> Element type>Add/Edit/Delete>Add> Link1 

4. Preprocessor> Real constant> Add/Edit/Delete>Add>Ok> Area>500 

5. Preprocessor>Material Property> Young’s Modulus > Enter Ex = 2e5. 

6. Preprocessor > Modeling > Create>node > In active CS > Create three nodes     

    at Location (0, 0, 0) (500, 0, 0) and (1000, 0, 0). 

7. Preprocessor > Modeling > Create > Element > Auto numbered > 

    Thru node > (Pick nodes (1, 2), (2, 3) and create element). 

8. Preprocessor > Load > Define load > Apply > Structural > Displacement>    

   Select Node number 1 and apply ‘ALL DOF’. 
9. Preprocessor > Load > Define load > Apply> Structural > Force / moment on  

     nodes > Select node number 3 and Enter value Fx = -12000 N. 

10. Solution > Solve > Current LS 

11. General postprocessor > Plot Results > Deform shape 

12. Postprocessor> Contour plot> Nodal solution> Displacement vector sum. 

13. Postprocessor>Element Table>Define Table>Add>By sequence num>LS 1 

14. Postprocessor>Element Table>List Elem table>LS 1>ok 
 

Comparison between theoretical and Ansys values 

 
 Ansys Theoretical 

Deformation   

Stress   

Reaction   
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Problem 2: 

 
For the simple bar shown in the figure determine the displacements, stress and the 

reaction. The cross section of the bar is 500 mm
2, length is 1000mm and the Young’s 

modulus is E= 2x10
5
 N/mm

2
. Take load = 1000N 

         

 

 

 

 

 

 

 

 

 

 
Comparison between Ansys and Theoretical Results 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ansys 

 

Theoretical 

 

Deformation 

 

  

Stress 

 

  

Reaction 
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PART A. 2: STRESS ANALYSIS OF BARS OF TAPERED CROSS SECTION AREA 

  

 Problem 3 
Obtain nodal displacements for the tapered bar. Use the following numerical 

values: E = 10 × 106 lb/in2, A0= 4 in2, L = 20 in, P = 4000 lb. 

 
 

Procedure: 

1. Utility Menu > File > Change Jobname 

2. Utility Menu > File > Change Title 

3. Preprocessor> Element type>Add/Edit/Delete>Add> Link1. 

4. Preprocessor> Real constant> Add/Edit/Delete>Add>Ok> Area>  

   (create 2 set of Real  Constant) > A1= 3.5 in2 and A2 = 2.5 in2. 

5. Preprocessor>Material Property> Young’s Modulus > Enter Ex= 10e6. 

6. Preprocessor > modeling > Create > Node > In active CS> Create 3 Nodes > 

(0, 0, 0), 

    (0,-10, 0) and (0,-20, 0). 

7. Preprocessor>Modeling >Create>Element> Element Attributes  

    (you can set Real Constant number set to 1). 

8. Preprocessor>Modeling >Create>Element >Auto numbered >Thru Node>  

     ( Pick nodes and create element between nodes 1 and 2) 

9. Repeat the procedures given in 7 and 8 set Real constant number to 2 and create 

element between nodes 2 and 3. 

10. Preprocessor>Load>Define load> Apply> Structural> Displacement> on 

nodes and 

     select node 1 and Apply ‘ALL DOF’ in the wizard. 

11. Preprocessor>Load>Define load> Apply> Structural>Force / moments > on 

Nodes > 

     Select node number ‘3’ and Apply a force Fy = - 4000. 

12. Solution> Solve> Current LS. 

13. General postprocessor > Plot Result > Deform shape 

14. Postprocessor > Contour plot > Nodal solution > Displacement vector sum. 

 
Comparison between theoretical and Ansys values 
 
 Ansys Theoretical 

Deformation   

Stress   

Reaction   
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Problem 4 
For the tapered bar shown in the figure determine the displacement, stress and reaction 

in the bar. 

Given A1 = 1000 mm
2
 and A2 = 500 mm

2
, E = 2x10

5
 N/mm

2
 

 

 

 

 

 

 

 

 

 

 
The Tapered bar is modified into 2 elements as shown below with modified area of cross 

section 

 

(1000+500)/2 = 750 mm
2
 

A1 = (1000+750)/2 = 875 mm
2
 

A2 = (750+500)/2 = 625 mm
2
 

 

  

 

 

 

 

 

 

 
Comparison between Ansys and Theoretical Results 

 
 

 

  

 

 

 

 

 

 

 

 

 

 

Ansys 

 

Theoretical 

 

Deformation 

 

  

Stress 

 

  

Reaction 
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PART A.3: STRESS ANALYSIS OF A STEPPED BAR 

Problem 5 

 
Determine the nodal displacements and Reaction forces for the Stepped bar shown 

below. 

 
Procedure: 

1. Utility Menu > File > Change Job name 

2. Utility Menu > File > Change Title 

3. Preprocessor> Element type>Add/Edit/Delete>Add> Link1. 

4. Preprocessor > Real constant> Add/Edit/Delete > Add > Ok> Area > 

   (create 2 set of real constants). 

5. Preprocessor>Material Property>Material Models> Young’s Modulus >Enter  
    Ex= 15e6 Under Material Models>Material>New Model (define the second      

   property) Enter Ex = 10e6. 

6. Preprocessor > Modeling > Create > Node > In active CS> Create 3 Nodes  

    (0, 0, 0),(20, 0, 0) and (40, 0, 0). 

7. Preprocessor>Modeling > Create>Element> Element Attributes  

   (you can see 2 real Constant sets and 2 material properties select the real constant      

    number 1 and create element). 

8. Preprocessor>Modeling >Create>Element >Auto numbered >Thru Node>  

    (pick nodes 1 and 2 and create element). 

9. Repeat the procedure given in 7 and 8 by choosing material number 2 and real  

    Constant number 2 and create element between nodes 2 and 3. 

10.Preprocessor>Load>Define load> Apply> Structural> Displacement > on  

    Nodes > Pick node number 1 and apply ‘All Dof’. 
11. Preprocessor>Load>Define load> Apply> Structural >Force > on Nodes > 

Apply 

     Fx = 2000. 

12. Solution > Solve > Current LS 

13. General postprocessor > Plot Result > Deform shape. 

14. Postprocessor> Contour plot> Nodal solution> Displacement vector sum. 

15. General Post processor >List Result > Reaction solu >All structural force ‘F’. 
 
Comparison between theoretical and Ansys values 

 Ansys Theoretical 

Deformation   

Stress   

Reaction   
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Problem 6: 

 
A Stepped bar is subjected to axial load as shown in the figure find the Stress Reactions 

for the following following problem using Link 1 Element. 

Given Data: A1 = 40 mm
2
, A2 = 20 mm

2
 

   

 

 

 

 

 

 
Comparison between Ansys and Theoretical Results 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

Ansys 

 

Theoretical 

 

Deformation 

 

  

Stress 

 

  

Reaction 

 

  

20 mm 40 mm

1000 N
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Problem 7: 
 

Consider the bar in figure. Determine the nodal displacements, element stresses & 

support reactions. The Temperature is then raised to 60C E = 200  10
9
 N/m

2 

 

Solution: 

 

Node 

No 

Element 

No 

Deflection 
Load/ Reaction 

(KN) 

Stress 

N/mm
2
 

Theory Ansys Theory Ansys Theory Ansys 

1 

 

       

2 

 

       

3 

 

       

4 

 

 

 

      

 

When temperature raised to 60
0
C. 

 

Node 

No 

Element 

No 

Deflection 
Load/ Reaction 

(KN) 

Stress 

N/mm
2
 

Theory Ansys Theory Ansys Theory Ansys 

1 

 

       

2 

 

       

3 

 

       

4 
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Problem 8: 
a. Determine the displacements, stresses& Support reactions 

b. In the structure is subjected to an increase in Temperature of 80C.  

    Determine the Displacements, Support Reactions & Stresses 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Solution: 

 

Node 

No 

Element 

No 

Deflection 
Load/ Reaction 

(KN) 

Stress 

N/mm
2
 

Theory Ansys Theory Ansys Theory Ansys 

1 

 

       

2 

 

       

3 

 

       

4 

 

 

 

      

 

When temperature raised to 80
0
C. 

 

Node 

No 

Element 

No 

Deflection 
Load/ Reaction 

(KN) 

Stress 

N/mm
2
 

Theory Ansys Theory Ansys Theory Ansys 

1 

 

       

2 

 

       

3 

 

       

4 
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Problem 9: 
An Axial load P = 300  10

3
 N is applied at 20C to the rod as shown in figure. 

Determine the nodal Displacements, Reaction & Stresses. 

 

 

 

 

 

 

 

 

Solution: 

 

Node 

No 

Element 

No 

Deflection 
Load/ Reaction 

(KN) 

Stress 

N/mm
2
 

Theory Ansys Theory Ansys Theory Ansys 

1 

 

       

2 

 

       

3 

 

       

4 
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Problem 10: 
a. An axial load of P = 300  10

3
 N is applied at 20C to the rod as shown in  

    Figure. Determine the nodal Displacements, reactions & Stresses 

b. In the temperature is raised to 60C. Determine the Displacements,   

   Support Reactions & Stresses 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Solution: 

 

Node 

No 

Element 

No 

Deflection 
Load/ Reaction 

(KN) 

Stress 

N/mm
2
 

Theory Ansys Theory Ansys Theory Ansys 

1 

 

       

2 

 

       

3 

 

       

4 

 

 

 

      

 

In the temperature is raised to 60C. 

 

Node 

No 

Element 

No 

Deflection 
Load/ Reaction 

(KN) 

Stress 

N/mm
2
 

Theory Ansys Theory Ansys Theory Ansys 

1 

 

       

2 

 

       

3 

 

       

4 
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Problem 11: 
Consider the bar shown in figure. An axial load p = 200  10

9
 N is applied as shown.                        

Determine the nodal displacements and the reaction forces 

 

 

 

 

 

Solution: 

 

Node 

No 

Element 

No 

Deflection 
Load/ Reaction 

(KN) 

Stress 

N/mm
2
 

Theory Ansys Theory Ansys Theory Ansys 

1 

 

       

2 

 

       

3 

 

       

4 

 

 

 

      



CAMA-LAB (06MEL67) VI SEMESTER 36 

Problem 12: 
Determine the displacement field, support reactions and stress in the body shown as 

loaded. Use 1D bar element E= 20Gpa, A= 250mm
2
, P = 60KN 

 

 

 

CASE A  

Node 

No 

Element 

No 

Deflection 
Load/ Reaction 

(KN) 

Stress 

N/mm
2
 

Theory Ansys Theory Ansys Theory Ansys 

1 

 

       

2 

 

       

3 

 

       

4 

 

 

 

      

 

CASE B:  When the displacement g =1.2mm is given  

 

Node 

No 

Element 

No 

Deflection 
Load/ Reaction 

(KN) 

Stress 

N/mm
2
 

Theory Ansys Theory Ansys Theory Ansys 

1 

 

       

2 

 

       

3 

 

       

4 
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Problem 13: 
An axial load P= 500 x 10

3
 N is applied at 40

0
c to the rod as shown in figure. Determine 

the nodal displacements, reaction and stresses. 

 

 

 

 
 

Solution: 

 

 

Node 

No 

Element 

No 

Deflection 
Load/ Reaction 

(KN) 

Stress 

N/mm
2
 

Theory Ansys Theory Ansys Theory Ansys 

1 

 

       

2 

 

       

3 

 

       

4 
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Problem 14: 

 

 

 

 

 

 

 

 

 

 

 

Solution: 

 

 

Node 

No 

Element 

No 

Deflection 
Load/ Reaction 

(KN) 

Stress 

N/mm
2
 

Theory Ansys Theory Ansys Theory Ansys 

1 

 

       

2 

 

       

3 

 

       

4 
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PART A. 4: ANALYSIS OF TRUSSES 

Problem 15 
The two-element truss in Figure is subjected to external loading as shown. Using the 

same node and element numbering as in Figure, determine the displacement 

components of node 3, the reaction force components at nodes 1 and 2, and the 

element displacements, stresses and forces. The elements have modulus of elasticity 

E1 = E2 = 10 × 106 lb/in2 and cross-sectional areas A1 = A2 = 1.5 in2. 

 
 

Procedure: 

1. Utility Menu > File > Change Job name 

2. Utility Menu > File > Change Title 

3. Preprocessor> Element type>Add/Edit/Delete>Add> Link1. 

4. Preprocessor> Real constant> Add/Edit/Delete>Add>Ok> Area>1.5. 

5. Preprocessor>Material Property> Young’s Modulus > Enter 10e6. 

6. Preprocessor > Modeling > Create > Node >In Active CS > Create 3 nodes 

    Node 1 = (0, 0, 0), Node 2 (0, 40, 0) and Node 3 (40, 40, 0). 

7. Preprocessor>modeling >create>element >auto numbered >thru node>  

    (pick nodes and create element between nodes (1, 3) and (2, 3)). 

8. Preprocessor>Load>Define load> Apply> Structural> Displacement> on 

nodes > 

    Select nodes 1 and 2. 

9. Preprocessor > Load > Define load > Apply > Structural > Force/ moment on 

nodes > 

    Select node number 3 and Apply a force ‘Fy’ = 300 

10. Solution > Solve > Current LS 

11. General postprocessor > plot Result > Deform shape 

12. Postprocessor> Contour plot> Nodal solution> Displacement vector sum. 

13. General Postprocessor > List Result > Reaction Solu > All ‘struc forcF’. 
 

Results  
1. Nodal solution and Displacements 

 

 

 

 

 

 

 

  

Node No Ux ( Theory ) Ux ( ANSYS ) Uy (Theory) Uy ( ANSYS) 

1     

2     

3     

4     
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           2. Elemental Solution and Displacement 

 

 

 

 

 

 

 

 

           3. Reaction Solution  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Element No Stress (Theory) Stress (ANSYS) 

1   

2   

3   

4   

Node No Fx (Theory) Fx (ANSYS) Fy (Theory) Fy (ANSYS) 

1     

2     

3     

4     
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Problem 16: 
For the two bar truss shown in figure, determine the reaction forces, nodal 

displacement and element Stress. 

 

 
 

Results  
1. Nodal solution and Displacements 

 

 

 

 

 

 

 

 2. Elemental Solution and Displacement 

 

 

 

 

 

 

 

 

           3. Reaction Solution  

 

 

 

 

 

 

 
 

 

 

 

 

 

 

 

Node No Ux ( Theory ) Ux ( ANSYS ) Uy (Theory) Uy ( ANSYS) 

1     

2     

3     

4     

Element No Stress (Theory) Stress (ANSYS) 

1   

2   

3   

4   

Node No Fx (Theory) Fx (ANSYS) Fy (Theory) Fy (ANSYS) 

1     

2     

3     

4     
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Problem 17: 
 

For the two bar truss shown in figure, determine the reaction forces, nodal 

displacement and element Stress. 

 

 
 

Results  
1. Nodal solution and Displacements 

 

 

 

 

 

 

 

 2. Elemental Solution and Displacement 

 

 

 

 

 

 

 

 

           3. Reaction Solution  

 

 

 

 

 

 

 
 

 

 

 

Node No Ux ( Theory ) Ux ( ANSYS ) Uy (Theory) Uy ( ANSYS) 

1     

2     

3     

4     

Element No Stress (Theory) Stress (ANSYS) 

1   

2   

3   

4   

Node No Fx (Theory) Fx (ANSYS) Fy (Theory) Fy (ANSYS) 

1     

2     

3     

4     
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Problem 18: 
For the Pin jointed configuration shown in figure 

a. Calculate the reaction forces 

b. Nodal Displacements 

c. Element Stresses. 

 

 
 

Results  
1. Nodal solution and Displacements 

 

 

 

 

 

 

 

 2. Elemental Solution and Displacement 

 

 

 

 

 

 

 

 

           3. Reaction Solution  

 

 

 

 

 

 

 
 

 

Node No Ux ( Theory ) Ux ( ANSYS ) Uy (Theory) Uy ( ANSYS) 

1     

2     

3     

4     

Element No Stress (Theory) Stress (ANSYS) 

1   

2   

3   

4   

Node No Fx (Theory) Fx (ANSYS) Fy (Theory) Fy (ANSYS) 

1     

2     

3     

4     
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Problem 19: 
Consider the four bar truss shown in figure. It is given that E= 200 Gpa and Area= 625 

mm
2
 for all elements. Calculate the reaction forces, Nodal displacement and element 

stresses. 

 

 

Results  
1. Nodal solution and Displacements 

 

 

 

 

 

 

 

 2. Elemental Solution and Displacement 

 

 

 

 

 

 

 

 

           3. Reaction Solution  

 

 

 

 

 

 

 
 

 

 

 

 

Node No Ux ( Theory ) Ux ( ANSYS ) Uy (Theory) Uy ( ANSYS) 

1     

2     

3     

4     

Element No Stress (Theory) Stress (ANSYS) 

1   

2   

3   

4   

Node No Fx (Theory) Fx (ANSYS) Fy (Theory) Fy (ANSYS) 

1     

2     

3     

4     
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Problem 20: 
For truss shown in figure an horizontal load of P= 18KN is applied in the direction at 

Node 2. Calculate the reaction forces, Nodal displacement and element stresses. 

 
 

Results  
1. Nodal solution and Displacements 

 

 

 

 

 

 

 

 2. Elemental Solution and Displacement 

 

 

 

 

 

 

 

 

           3. Reaction Solution  

 

 

 

 

 

 

 
 

 

 

 

 

 

Node No Ux ( Theory ) Ux ( ANSYS ) Uy (Theory) Uy ( ANSYS) 

1     

2     

3     

4     

Element No Stress (Theory) Stress (ANSYS) 

1   

2   

3   

4   

Node No Fx (Theory) Fx (ANSYS) Fy (Theory) Fy (ANSYS) 

1     

2     

3     

4     
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Problem 21: 

 

 

 

 

 

 

 

 

 

Results  
1. Nodal solution and Displacements 

 

 

 

 

 

 

 

 2. Elemental Solution and Displacement 

 

 

 

 

 

 

 

 

           3. Reaction Solution  

 

 

 

 

 

 

 

 

 

Node No Ux ( Theory ) Ux ( ANSYS ) Uy (Theory) Uy ( ANSYS) 

1     

2     

3     

4     

Element No Stress (Theory) Stress (ANSYS) 

1   

2   

3   

4   

Node No Fx (Theory) Fx (ANSYS) Fy (Theory) Fy (ANSYS) 

1     

2     

3     

4     
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Problem 22: 
Consider a 4 Bar Truss as shown in the below figure. And solve the problem for 

displacement stress and Reaction Forces 

 Data: A=100 mm
2
, E=2x10

5
 N/mm

2
, Poisson ratio is 0.3. 

 

 

 

 

 

 

 

 

 

Results  
1. Nodal solution and Displacements 

 

 

 

 

 

 

 

 2. Elemental Solution and Displacement 

 

 

 

 

 

 

 

 

           3. Reaction Solution  

 

 

 

 

 

 

 

 

 

 

Node No Ux ( Theory ) Ux ( ANSYS ) Uy (Theory) Uy ( ANSYS) 

1     

2     

3     

4     

Element No Stress (Theory) Stress (ANSYS) 

1   

2   

3   

4   

Node No Fx (Theory) Fx (ANSYS) Fy (Theory) Fy (ANSYS) 

1     

2     

3     

4     

75 mm

2.5 kN

10 KN

100 mm
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Problem 23: 
Consider a 3 Bar Truss as shown in the below figure. And solve the problem for 

displacement stress and Reaction Forces The cross-sectional area of each member is 

0.01 m, the Young's modulus is 200x10
9
 N/m

2
 and Poisson ratio is 0.3. 

 

 

 

 

 

 

 

 

 

 

 

  

Results  
1. Nodal solution and Displacements 

 

 

 

 

 

 

 

 2. Elemental Solution and Displacement 

 

 

 

 

 

 

 

 

           3. Reaction Solution  

 

 

 

 

 

 

 

 

 

Node No Ux ( Theory ) Ux ( ANSYS ) Uy (Theory) Uy ( ANSYS) 

1     

2     

3     

4     

Element No Stress (Theory) Stress (ANSYS) 

1   

2   

3   

4   

Node No Fx (Theory) Fx (ANSYS) Fy (Theory) Fy (ANSYS) 

1     

2     

3     

4     
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Problem 24: (For Practice) 
The below figure shows a truss with a roller support at node 4. The area of cross section 

of the elements of the truss is 120 Sq.mm. The force acting on the nodes are shown in 

the figure. It is supported at node 1 by a hinged joint, Node 4 is supported on a roller 

arrangement and the support allows a freedom of movement at an angle of 30
0
. 

Determine the nodal displacement, reactions and stresses in the truss member shown in 

figure. 

 

 

 
Problem 25: (For Practice) 
The figure shows a truss element loaded with 500N at node 2. All horizontal members 

have an area of 100 Sq.mm and inclined members an area of 80 sq.mm. Young’s 
modulus (E) of element 3= 80Gpa and other element is 210 Gpa. Determine the nodal 

displacement, reactions and stresses in the truss member shown in figure. 

 

 
 

Problem 26: (For Practice) 
 

Consider a Truss as shown in the below figure. And solve the problem for displacement 

stress and Reaction Forces Cross-sectional area of truss members = 3.0E-4 m
2
; Modulus 

of Elasticity = 2.07E11 N/m
2
. Circled numbers shown are node numbers

F= 125 N F= 100 N

3 m 3 m 3 m 3 m

3 m

1 2 3 4 5

6 7 8
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PART A. 5: STRESS ANALYSIS OF BEAMS 

Problem 27 
Consider a cantilever beam of length 1000mm, subjected to uniformly varying load 0 

to 500N/mm. Young’s modulus 2e5 N/mm2. The cross section is rectangular with 

Breadth and Height of 10mm. Obtain the shear force and bending moment diagrams. 

Obtain the values of deflection, bending moment, maximum bending stress. 

 
Procedure: 

1. Utility Menu > File > Change Job name 

2. Utility Menu > File > Change Title > Cantilever Beam 

3. Preprocessor> Element type > Add/Edit/Delete > Add > Beam3 

4. Preprocessor > Real constant >Add/Edit/Delete > Add > OK > Area = 100 > 

Area 

   moment of inertia = 833.33> Height = 10. 

5. Preprocessor >Material Property > Material models > Young’s Modulus > 

    Enter Ex = 2e5. 

6. Preprocessor > Modeling > Create > Nodes >In Active CS > Create three 

nodes 

    Node number 1 = (0, 0, 0) 

    Node number 2 = (1000, 0, 0) 

7. Preprocessor >modeling > create>element >auto numbered >thru node> 

    (Pick nodes (1, 2) and create one element). 

8. Preprocessor>Load>Define load> Apply> Structural> Displacement> On 

Nodes > 

    Select node 1 > Apply ‘ALL DOF’. 
9. Preprocessor > Load > Define load > Apply > Structural>pressure>on 

beam> Select 

    the First element > OK >give the pressure value ‘0’ in VALI and ‘500’ in VALJ. 
10. Solution > Solve> Current LS. 

12. General postprocessor > plot Result > Deform shape 

13. Postprocessor> Contour plot> Nodal solution> Displacement vector sum. 

14. To find Bending moment 

Postprocessor>element table>Define table> add>by sequence number>SMISC 

6>ok 

Postprocessor>element table>Define table> add>by sequence number>SMISC 

12>ok 

14. To plot the Bending moment results 

General Postprocessor > Contour plot > Line elem Res 

15. Similarly for shear force, max and min stress 

Postprocessor>element table>create table> add>by sequence number>SMISC 

2>ok 

Postprocessor>element table>create table> add>by sequence number>SMISC 

8>ok 

Postprocessor>element table>create table> add>by sequence number>NMISC 

1>ok 
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Postprocessor>element table>create table> add>by sequence number>NMISC 

3>ok 

Postprocessor>element table>create table> add>by sequence number>NMISC 

2>ok 

Postprocessor>element table>create table> add>by sequence 

number>NMISC4>ok 

 

Result: 

Loading 

Deflection (mm) 

 

Bending Moment 

(N/mm) 

Max.Bending Stress 

(N/mm
2
) 

ANSYS Theory ANSYS Theory ANSYS Theory 

1       

2       

3       
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Problem 28: 
The figure shows a loaded beam subjected to various types of loading. E = 200Gpa & I = 

4 x 10
6 

mm
4
. 

 

 
 

 

Results: 
 

Result Node No Deflection 

(mm) 

 

Node No Beding 

Moment 

(N-mm) 

Element 

No 

Max. 

Bending 

Stress 

(N/mm
2
) 

ANSYS 

1  1  1- 2  

2  2  2-3  

3  3  3-4  

4  4  4-5  

5  5  5-6  

6  6  6-7  

7  7  7-8  

8  8  8-9  

9  9    

Theory 

1  1  1- 2  

2  2  2-3  

3  3  3-4  

4  4  4-5  

5  5  5-6  

6  6  6-7  

7  7  7-8  

8  8  8- 9  

9  9    
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Problem 29: 
Determine the end forces of a clamped beam due to a 25mm settlement at the right end. 

A = 50 x 50 Sq.           E = 200 Gpa           I = 2mm
4
 

 

 
 

 

Results: 
 

 

 

Result Node No Deflection 

(mm) 

 

Node No Beding 

Moment 

(N-mm) 

Element 

No 

Max. 

Bending 

Stress 

(N/mm
2
) 

ANSYS 

1  1  1- 2  

2  2  2-3  

3  3  3-4  

4  4  4-5  

5  5    

Theory 

 

 

 

1  1  1- 2  

2  2  2-3  

3  3  3-4  

4  4  4-5  

5  5    
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Problem 30:  

 
A 2m Long Cantilever with rectangular section (60mmx90mm) is subjected to 

concentrated load of 4KN at the free end of the beam. Determine the Deflection, 

maximum stress due to bending, Bending moment and Shear Force. Take E = 200Gpa. 

P = 4 x 10
3 

N, Length L = 2m = 2000 mm 

 

 

 

 

 

Results: 
 

Loading 

Deflection (mm) 

 

Bending Moment 

(N/mm) 

Max.Bending Stress 

(N/mm
2
) 

ANSYS Theory ANSYS Theory ANSYS Theory 

1       

 

 
Problem 31: 

 
A 2m Long Cantilever with rectangular section (60mmx90mm) is subjected to 

Uniformly Distributed load of 4 KN/m through out its Length. Determine the 

Deflection, maximum stress due to bending, Bending moment and Shear Force.  

Take E = 200Gpa. Length L = 2m = 2000 mm 

 

 

 

 

 
 

Results: 
 

Loading 

Deflection (mm) 

 

Bending Moment 

(N/mm) 

Max.Bending Stress 

(N/mm
2
) 

ANSYS Theory ANSYS Theory ANSYS Theory 

1       

 

 

 

 

 

 

 

 



CAMA-LAB (06MEL67) VI SEMESTER 55 

Problem 32: 
A distributed load of 1000 N/m (1 N/mm) will be applied to a solid steel beam with a 

rectangular cross section as shown in the figure below. The cross-section of the beam is 

(10mm x 10mm) while the modulus of elasticity of the steel is 200GPa. Determine the 

Deflection, maximum stress due to bending, 
 

 

 

 

 

 

 

 

 

 

Results: 
 

 

 

 

 

 

 

Problem 33:  
A simply supported Beam of 3m Span as shown in the figure is subjected to a load of 5 

kN/m. determine the max deflection and Stress E=200 Gpa, I= 10
8
 mm

4
 

 

 

 

 

 

 

 

 

Results: 

 

 

 

 

 

 

 

 

 

 

 

Loading 

Deflection (mm) 

 

Max.Bending Stress 

(N/mm
2
) 

ANSYS Theory ANSYS Theory 

1     

Loading 

Deflection (mm) 

 

Max.Bending Stress 

(N/mm
2
) 

ANSYS Theory ANSYS Theory 

1     

5 kN / m

      3 m
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Problem 34: 
 Loads will not be applied to the beam shown below the beam is to be made of steel with 

a modulus of elasticity of 200 GPa. Find the max deflection and Stress due to the Self 

Weight of the Beam. 

 

 

 

 

 

 

 

 

 

Results: 
 
 

Loading 

Deflection (mm) 

 

Max.Bending Stress 

(N/mm
2
) 

ANSYS Theory ANSYS Theory 

1     
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            Chapter 4 

 

ANSYS EXERCISE (PART – B) 
 

PART B.1: STRESS ANALYSIS OF RECTANGULAR PLATE WITH A CIRCULAR 

HOLE 

Problem 35 
Stress analysis of a rectangular Plate with Hole. Let 2w = 100mm, 2h =50mm,a= 10mm,  

 = 100 Mpa. 

 
Procedure - 

1. Utility Menu > File > Change Job name 

2. Utility Menu > File > Change Title > Stress analysis of a Plate 

3. Preprocessor > Element type > Add/Edit/Delete > Add > Solid > Quad 4     

   node 42 

4. Preprocessor>Material Property> Young’s Modulus > Enter Ex = 2e5 and  
    Poisson’s ratio = 0.3. 

5. The model is symmetric we are going to create ¼ of the model. 

   Preprocessor>modeling >create> Area > Rectangle> By Dimensions> 0, 100     

   (X1, X2) (0, 50) for (Y1, Y2). 

6. Preprocessor>Modeling > Create> Area >Circle > Solid circle > (define    

   dimensions). Enter WP X = 50, WP Y = 25, Radius = 10. 

6. Preprocessor>modeling>operate>Booleans>subtract>areas> (select the  

     bigger Area first click apply and select the smaller one and click OK). 

8. Preprocessor >Meshing>Mesh tool>Smart size ON>Free> Quad >Mesh >    

    Pick all. 

9. Preprocessor>Load>apply>Structural>Displacement>symmetry B.C>on line 

    (Select the line on X coordinates Zero and Y coordinates Zero and apply     

    Symmetric BCs). 

10. Preprocessor>Load>apply>Structural> pressure> on line > Enter VALI =   

    100. 

11. Solution > Solve > Current LS 
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12. General postprocessor > Plot Result > Deform shape 

13. General postprocessor> Plot Result> Contour Plot> Nodal  

      Solution>Displacement Vector Sum. 

14. General postprocessor > Plot Result > Contour Plot > Nodal Solution    

      >Stress >von Misses stress 

15. To Expand the Model. 

Plot control > Style > Symmetry Expansion > Periodic /Cyclic Symmetry>1/4 

Expansion > OK. 

 

Results: 
 

 ANSYS Theory 

 

Deformation  

  

 

Stress 
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Problem 36 
 

Determine the location and magnitude of the maximum stress in the plate as shown in 

figure.  

 

 

 

 

 

 

 

 

 

 

 

 

Results: 
 

 ANSYS Theory 

 

Deformation  

  

 

Stress 
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Problem 37 
 

Determine the location and magnitude of the maximum stress in the plate as shown in 

figure.  

 

 
 

 

 

 

Results: 
 

  

ANSYS 

 

Theory 

 

Deformation  

  

 

Stress 
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Problem 38: 
Determine the maximum stress for a rectangular plate of 50mm x 80 mm with hole of 10 

mm diameter in the center is loaded in axial tension. Thickness of the Plate is 10mm. 

Take E = 200 GPa 

 

 
 

 

 

 

 

 

 

 

 

 

 

Analytical Solution 

 

Results: 
 

  

ANSYS 

 

Theory 

 

Deformation  

  

 

Stress 
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Problem 39: ( For Practice)  

 
We will model the bracket as a solid 8 node plane stress element. By a plane stress 

element we are assuming that there are no stresses in the thickness direction of the 

bracket.  

Geometry: The thickness of the bracket is 3.125 mm 

Material: Assume the structure is made of steel with modulus of elasticity E=200 GPa. 

Boundary conditions: The bracket is fixed at its left edge. 

Loading: The bracket is loaded uniformly along its top surface. The load is 2625 

N/meter. 
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PART B.2: THERMAL ANALYSIS 

Problem 40 
For the rectangular slab shown in the above figure find out the temperature 

distributions for the boundary conditions indicated. Assume material to be made of 

Copper. 

1. Utility Menu > File >        

1. Change Job name 

2. Utility Menu > File > Change Title > Thermal Analysis. 

3. Preprocessor> Element type>Add/Edit/Delete>Add>Thermal>solid>plane55 

4. Preprocessor>Material Property>Thermal> Conductivity>Isotropic> 

(Give conductivity value in KXX) > Enter Kxx = 386 W/mK 

5. Preprocessor>Modeling>create>Area>Rectangle>By Dimension >(give 

dimension) X2=10 and Y2=20. 

6. Preprocessor>Meshing>Mesh tool>smart size ON>Free>Quad>Mesh>pick all 

7. Preprocessor>Load>Apply>Thermal>Temperature>on line>Give 100 for 3 

lines and for the top line give 200. 

8. Solution>Solve>Current LS. 

9. General Postprocessor > Plot Result>contour Plot>Nodal Solution>DOF 

Solution > Nodal Temperature 

ii) In this example you will learn to model a 2D block subjected to varying 

boundary conditions. Using ANSYS will allow you to output the temperature 

distribution in an extremely simple and accurate way. By using any combination 

of these boundary conditions one can model almost any 2D heat transfer 

situation. We assume that our block is a rectangle (1m x 2m) made entirely of 

steel. 

Boundary Conditions: 

1) The top is insulated. 

2) The right side has a constant temperature of 100K. 

3) The left side has constant heat flux into the block of 50 W/m^2. 

4) The bottom side is exposed to a convective boundary layer. 
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Material Properties: (Steel) 

Convection film coeff h = 50 W/ (m^2*K) 

Thermal conductivity k = 20 W/m K. 

Objective: To determine the nodal temperature distribution and create contour plot. 

1. Utility Menu > File > Change Job name. 

2. Utility Menu > File > Change Title. 

3. Preprocessor> Element type>Add/Edit/Delete>Add>Thermal>Solid> 

Plane55 

4. Preprocessor>Material Property>Thermal> Conductivity>Isotropic> 

(Give conductivity value in KXX = 20 W/M K) 

5. Preprocessor>Modeling>create>Area>Rectangle>By Dimension> (give 

dimension) X2=1m and Y2=2m 

6. Preprocessor>Meshing>Mesh tool>smart size ON>Free>Quad>Mesh>pick all 

7. Preprocessor>Load>Apply>Thermal>Temperature>on line> Give 100 to 

right side Line. 

8. Preprocessor>Load>Apply>Thermal>Convection>on line> Select the bottom 

line and Enter values for film coefficient = 50 and bulk temperature = 200K. 

9. Preprocessor>Load>Apply>Thermal>Heat Flux>On line> Enter the value = 

50. 

10. Solution>Solve>Current LS. 

11. General Postprocessor>Plot Result>contour Plot>Nodal Solution>DOF 

Solution >Nodal Temperature. 

 

Results: 

 

Quantity 

 

ANSYS Theory 

T2 

 

  

T3 

 

  

T4 

 

  

T5 
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Problem 41: 
A furnace wall is made of inside Silica brick (K = 1.5 W/mk) and outside magnesia brick 

(K= 4.9 W/mK), each 10 cm thick. The inner and outer surfaces are exposed to fluids at 

temperature of 820 
0
C and 110 

0
C respectively. The contact resistance for inner and 

outside surfaces is equal to 35 w/m
2
k. Find the heat flow through the wall per unit area 

per unit time and temperature distribution across the wall 
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Results: 

 

 

Quantity 

 

ANSYS Theory 

T2 

 

  

T3 

 

  

T4 

 

  

T5 

 

  

Heat flow 
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Problem 42: 
A plane wall ‘X’ (K = 75 W/mk) is 60mm thick and has volumetric heat generation of 
1.5x10

6
 w/m3. It is insulated on one side while the other side is in contact with surface of 

another wall ‘Y’ (k = 150 W/mk) which is 30 mm thick and has no heat generation. The 

free surface of wall ‘Y’ is exposed to a cooling fluid at 20 0
C with a convection 

coefficient of 950W/m
2
k. find steady state temperatures at salient points across the 

composite wall 
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Results: 

 

 

Quantity 

 

ANSYS Theory 

T1 

 

  

T2 

 

  

T3 
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PART B.3: FLUID FLOW ANALYSIS 

Problem 43: 

Fluid flow analysis in 2D bodies  

 
Air travels between two infinite plates. For the sake of modeling, these plates will be 

assumed to be 1.5 m long and 5 cm apart. All units are S.I. 

Boundary Conditions: 

Air enters between the plates at a uniform velocity of 0.1 m/s. 

Material Properties: 

Air: Density = 1.23 Kg/m3 

Viscosity = 1.79 e -5 

Dimensions 

Length = 1.5 m 

Width = 0.05 m 

Objective: Find the nodal velocity distribution within the air gap between the two 

plates. 

 
Preprocessing: 

1. Start ANSYS 

Go to Start > All Programs > ANSYS 11.0 > ANSYS Product launcher 

Specify the working directory and job name and click ‘Run’. 
2. Create areas. 

After opening ANSYS, 

Click Preprocessor>-Modeling-> and create the block as shown below. 

Hint: Use key points and then create the outer area and the plate within it….OR… 

Create the large area using the Create>Areas>Rectangle (1.5m x 0.05m) command, 

then create the small plate and subtract the small plate from the large area. 

3. Define the material properties. 

Go to Preprocessor>Flotran Set Up>Fluid Properties. 

On the box, shown below, change the first two input fields to AIR-SI, and then click on 

OK. Another box will appear. Accept all defaults on that box by clicking on OK. 

Go to the ANSYS Main Menu. 

Click Preprocessor > Material Props > Material Models. The following window will 

appear as shown below, in this menu 

Choose CFD>Density and enter the value 1.23 and choose CFD>Viscosity and enter 

1.79e-5. 

4. Define fluid element type. 

(2D Flotran 141 element, which is a 2-D element for fluid analysis) 

Click Preprocessor>Element Type>Add/Edit/Delete... In the 'Element Types' 

window that opens click on Add... The following window opens. 

Type 1 in the Element type reference number. 

Click on Flotran CFD and select 2D Flotran 141. Click OK. Close the Element types 

window. So now we have selected Element type 1 to be solved using Flotran, the 
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computational fluid dynamics portion of ANSYS. This finishes the selection of element 

type. 

5. Specify meshing controls / Mesh the areas to create nodes and elements. 

Under Ansys Main menu Choose > Meshing > Mesh tool > Set the smart size value to 

‘1’. 
Solution: 

6. Specify boundary conditions. 

Go to Preprocessor>Loads>Define Loads>Apply>Fluid CFD>Velocity>on lines. 

Pick 

the left edge of the outer block and Click OK. The following window comes up. Enter 

0.1 in the VX value field and click OK. The 0.1 corresponds to the velocity of 0.1 meter 

per second of air flowing from the left side. Repeat the above and set the Velocity to 

ZERO for the air along all of the edges of the flat plate. (VX=VY=0 for all sides). 

Now Atmospheric Pressure must be set for the top, bottom, and right side of the outer 

area. T o d o t h i s , s e l e c t Preprocessor>Loads>Define Loads>Apply>Fluid 

CFD>Pressure DOF>on lines. Click the right most line. 

Enter 0 for the constant pressure value for these faces and click OK. This sets the 

pressure to Atmospheric. 
Once all the Boundary Conditions have been applied, the boundary conditions on the plates 

should look like this: 

7. Specify number of solution iterations. 
Go to ANSYS Main Menu>Solution>Flotran Set Up>Execution Ctrl. The following 

window appears. Change the first input field value to 20, as shown. No other changes 

are needed. Click OK. (The reason behind setting the iterations so high is that when you 

run the Flotran Analysis, it stops only when the solution converges, or the solution 

reaches the number of iterations). 

8. Solve. 
Go to Solution>Run FLOTRAN. 

9. Postprocessing: 
Plot the contour plot of the velocity distribution. 

Go to General Postproc >Read Results>Last Set. 

T h e n g o t o General Postproc>Plot Results>Contour Plot>Nodal Solution. 

The following window appears – 

10. Exit: 

Toolbar > QUIT 

Utility Menu > File > Exit 

Use the /EXIT command in the Input Window 
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Problem 44: 
 

The fluid is air, with density, ρ=1.23 kg/m3, and dynamic viscosity, μ =1.79E-5 N-

s/m2.The plate is 1 m long, as shown, and is very thin. It will be modeled with a 

thickness of 0.001m.The plate is modeled in a square field, with edge lengths of 2 m. The 

2 m edge length dimensions are arbitrary. These lengths are chosen large enough such 

that the effects of the flatplate on the flow are captured completely within the square 

field. Also, the flow velocity in alldirections is zero along the sides of the flat plate. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Problem 45: 

 
Compute and plot the Velocity and Temperature distribution of a flow of air over a flat 

plate. Dimensions:  

o The plate is 1 m long. 

o The flow area is  1 m by .25 m.  This arbitrary size serves to set up the boundary 

conditions of air traveling over the plate.  

o The velocity of the air at infinite distance from the plate is 0.5 m/s.  

o Atmospheric pressure is assumed on all faces except the face where velocity is input 

into the system.  
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Problem 46: 
  Air at 100 degrees Celsius travels between two infinite plates.  For the sake of 

modeling, these plates will be assumed to be 1.5 m long and 5 cm apart. All units are S.I. 

 Boundary Conditions: 

 1) Air enters between the plates at a uniform velocity of 0.1 m/s and 20 degrees Celsius. 

 2) The wall temperature is 100 degrees Celsius 

      Material Properties: AIR-SI 

      Dimensions 

      Length = 1.5 m 

      Width = 0.05 m 

 

 

 

 

 

 

 

 

 

 

Problem 47: 

            Compute and plot the velocity distribution of a flow 
  
Dimensions:  

o The duct has an entrance region of 1m by 0.5m and an exit region of 1m by 1m. 

These two regions are separated by a horizontal distance of 1m. 

o The velocity of the air at infinite distance from the plate is 3 mm/s (0.003m/s). This 

velocity best demonstrates the recirculation zone while keeping the flow inside the 

duct laminar. 

 

 

 

 1 m 

3mm/s 

         0.5 m 

 

 

 1m 1m 1m 
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Problem 48: 

 
Compute and plot the velocity distribution of a flow of air over an infinite cylinder. 

 

Dimensions:  

o The cylinder is 0.25 m in diameter 

o Because of symmetry, the problem is simplified so that only half of the cylinder is 

computed. The results are assumed to be the same on the other side of the x axis (axis 

of symmetry) 

o The flow area is  2 m by 0.5 m.  This arbitrary size serves to set up the boundary 

conditions of flow over a cylinder. 

o The velocity of the air at infinite distance from the plate is 5 mm/s (0.005m/s).  

 

 

 

 D=0.25m 

 0.5m 

 0.005m/s 

 

  

 2m 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



CAMA-LAB (06MEL67) VI SEMESTER 74 

PART B.4: DYNAMIC ANALYSIS 

Problem 49: 
Obtain the first five natural frequencies for the beam show below. Take material 

Properties young’s modulus 2e5N/mm2, Density 7800e-12 Tonns/mm3.length of the 

Beam 1000mm cross section 10X10mm. 

 
1. Utility Menu > File > Change Job name > Give Job name ‘Simply supp’ 
2. Utility Menu > File > Change Title 

3. Preprocessor > Element type >Add/Edit/Delete > Add>Beam3 

4. Preprocessor> Real constant > Add/edit/delete > Add >Ok > Area (100) >Area 

    Moment of Inertia (833.33)> Height (10) 

5. Preprocessor>Material Property>structural>Linear>Elastic>Isotropic>give value for 

   Young’s Modules, Poisson ratio and density 

6. Preprocessor > Modeling > Create > Key points > In Active CS> Enter the co-ordinates 

Here. 

7. Preprocessor > Modeling > Create > Lines > Lines > Straight Line > Create a line 

between Key point 1 and Key point 2 and so on. 

8. Preprocessor>Meshing>Mesh tool>Line set>No of division 10> Preprocessor>Meshing 

>Mesh tool>Mesh>pick all 

9. Preprocessor>Load>Define load> Apply> Structural> Displacement> select key points 

on either side and constrain ‘ALL DOF’. 
10. Solution>Analysis Type>New Analysis>Set to Modal 

11. Solution> Analysis Type> Analysis Option> No. of .modes to extract (10)> No of 

modes to expand 10>ok>ok 

12. Solution>Solve>Current LS. 

13. General Postprocessor > Read Results>By Pick> (you can see the frequency values) 

14. Postprocessor> Contour plot> Nodal solution> Displacement vector sum. 

 

Results:  

Sl No Frequency 

1  

2  

3  

4  

5  
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Problem 50: 
 

Simple Harmonic Analysis of a Cantilever beam as shown below 

 E = 206800e
6
 N/m

2
 

 I = 8.33e
-10 

mm
4
 

            = 7830 Kg/m
3
 

 

 
 

 
 

 

 

 

Results : Value (VS) Frequency Graph 

 
Problem 51:  

 
A Rectangular plate of dimensions 100x40x3is fixed at one its ends. It is subjected to 2 

point loads at its free end. It is required to determine the natural frequencies and the 

frequency response of the plate. Also transient analysis is carried out. 

 

 

 

 

 

 

 

 

 

 
Material Properties  

E = 10000 kg/mm
2
 

 = 0.27  

Density = 7.920e-10 kg/mm
3
  

Loading(in Z-direction)  

F1 = 0.5 kg  

F2 = 0.5 Kg 

Analysis Type(s): Mode-frequency Analysis  

                              Mode Superposition Harmonic Response Analysis  

        Mode Superposition Transient analysis 
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Problem 52:  

 
The problem considered here is the vibration analysis of the right-angle frame. 

 

 

 

 

 

 

 

 

 

 

 

 

Problem 53:  
In this example we will find the first five natural modes and frequencies of a square 

plate with simply supported edges and a circular hole at its center, shown in Figure 6.1.  

 
 

E = 70e9 (70 GPa) and  

  = 0.3.  

  = 2.7e3 (2700 kg/cubic meter).  

Dimension = 1m x1m 

Circle = 0.2 m 

 

 

 

 

Results:  

MODE Frequency 

1  

2  

3  

4  

5  
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Problem 54:  
Simple Modal Analysis of a Cantilever Beam as shown below , Objective is to get the 

Frequency and Different modes of Vibration 

 

E = 2e11 N/m
2
 

I = 8.33e-06 m
4
 

Area A = 0.01 m
2
 

Density = 7830 Kg/m
3
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Theoretical Results: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Results:  

 

Mode 

 

ANSYS ( Frequency) 

 

Theory(Frequency) 

 

1 

 

  

2 

 

  

3 
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Problem 55: 
Determine the Modal Deflections for the Truss System below  

E = 200GPa , A = 3250 mm
2
 

 

 

 

 

Results: 

 

Mode Frequency 

1  

2  

3  

4  

 

 

 

 

 

 

 

 
 
 

Chapter 4 
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COMPUTER AIDED MODELING AND ANALYSIS LAB  

VIVA QUESTIONS 
 

 

1. What is the total degree of freedom of Ansys commercial package. 

2. What are the different menus in ANSYS. 

3. What is Work space and Swap space. 

4. What is default value of worksp1ace and Swapspace? 

5. What file format ANSYS can support 

6. What is the current ANSYS version 

7. What is optimization in ANSYS. 

8. What is sub structuring and adaptive meshing. 

9. Which package is better – ANSYS or NASTRAN. 

10.What is Resume in ANSYS. 

11.What is P-method and H-method 

12.What is scalar parameters in ANSYS. 

13.What are primary nodes and Secondary nodes. 

14.What is Mirror ( Reflection). 

15.What is subroutines. 

VIVA QUESTIONS ON FEM 

 

Q.1) What are the different approximate solution methods. 

Different approximate solution methods are 

1.Functional approximation 

2.Finite Difference method 

3. Finite Element method 

 

Q.2) What do you mean by continuum. 

Structure which is considered for analysis is called continuum. 

 

Q.3)  Define term node 

The element which is connected with another element at junction is called node. 

 

Q.4) Define term element 

Descritised  structure is called an element . 

 

Q.5) What is convergence 

Process of achieving value to actual solution. 

 

Q.6) What are the types convergence 

p-convergence 

h-convergence 

 

Q.7) What is p- convergence 

Convergence by increasing the elements 
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Q.8) What is h convergence 

Convergence by increasing nodes 

 

Q.9) What is higher order elements 

The element which contain more no. of  nodes are called higher order element . 

 

Q.10) Give example for higher order elements 

Higher order elements are CST, Quadrilateral element. 

 

Q.11) What do you mean by compatible elements. 

Elements, which are compatible with adjacent element, like no discontinuity, overlap or 

sudden slope. 

 

Q.12) What is geometric invariance. 

The property in which the shape of the element will not change with change in local 

coordinates is called geometric invariance. 

 

Q.13) Why do we use Pascal’s triangle in FEA 

If the displacement equation doesn’t contain all the required terms then balancing is done by 

the Pascal’s triangle. 
 

Q.14) What are the steps involved in FEA 

Steps involved in FEA: 

1.Modelling 

2.Descritization of structure 

3.Derivation of elemental stiffness matrix. 

4.Assembly of elemental equation 

5.Applying boundary conditions 

6.Computation of stress and strain 

7.Interpretaion of results 

 

Q.15) what is stiffness matrix 

The matrix when contain parameters like E, A, displacement and applied force is stiffness 

matrix 

 

.Q16)  How to obtain stiffness matrix 

Stiffness matrix can be obtained by applying condition of minimum potential energy to 

potential energy equation. 

 

Q.17) What is displacement function 

: Displacement function is the assumed polynomial equation, which satisfies boundary 

conditions. 

 

Q.18) How to identify order of elements 

Order of elements depends on the no. of  nodes. 

 

Q.19) Mention different types of elements 

Different types of elements are bar elements, beam element, truss element, shell element, axis 

symmetric. 
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Q.20) Mention some application of FEA 

Mechanical, Aerospace, Civil, structure analysis, biomedical, geo -mechanic, 

electromagnetic. 

 

Q.21) What is connectivity. 

Relation between the connected elements is connectivity. 

 

Q.22) What are the methods to improve problem solution 

Problem solution can be improved by increasing no. of elements or no. of nodes . 

 

Q.23) Define symmetry in matrix 

It is the square matrix in which the element of the row are same as that of element of column. 

 

Q.24) What is plane stress 

Stress acting on 2-D element. 

 

Q.25) What is plane strain 

Strain occurring in 2-D element. 

 

Q.26)  Compare FEA with solid mechanics 

complicated irregular structures are difficult in solid mechanics but FEA it’s easier with 
greater accuracy. 

 

Q.27) What are the packages available for FEA 

packages available for FEA: ANSYS, I-DEAS,NASTRAN,ABAQUS, 

COSMOS,ALGOL,PATRAN. 

 

Q.28)  Define potential energy 

Energy possessed by the body due to it’s position 

 

Q.29) Define minimum potential energy 

for consertive system of all kinematically admissible displacement field those corresponding 

to equilibrium extremise the total potential energy if extreme condition is a minimum the 

equilibrium state is stable 

 

Q.30)  Write potential energy equation for cantilever beam 

= EI/2  (d2y/dx2) dx – pie 

 

Q.31) Mention 2 different methods to approach the model of physical system . 

Discrete system , continuum 

 

Q.32) Difference between global co ordinate and local co ordinate 

Global co-ordinate 

1.Contain 2 degrees of freedom 

2. Represented without prime 

3.  Systematic schemes are  used 

Local co ordinate 

Contain 1 degrees of freedom 

Represented with prime 

No schemes are used 

 

 

 

Q.33) What is local coordinate 
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local coordinate contains 1-D.O.F. at each node. 

 

Q.34) What is global co ordinate 

Global coordinate contains 2-D.O.F. at each node. 

 

Q.35) General assumption made in stress 

Assumptions: 

1.Truss elements are connected by fracture less pin. 

2.Load is applied on the load. 

3.Only two forces compressive and tensile are considered. 

 

Q.36)What  is shape function 

It is mathematical polynomial, which gives displacement within the element. 

 

Q.37)What are two general natural coordinate 

Two general co-ordinates are (eeta) and zeeta. 

 

Q.38) Mention the range of natural co-ordinate 

Range of natural coordinates is  – 0 to 1  and –1 to 1. 

 

Q.39) Number of shape function in CST 

Number of shape function in CST  are three. 

 

Q.40) Number of shape function in quadrilateral 

Number of shape function in quadrilateral are 4. 

 

Q.41) Why we are using natural integration 

we are using natural integration  to simplify the problem. 

 

Q.42) Explain one point formula 

1-point shape function contains one term f(x)dx=w.f(x) 

 

Q.43) Explain two point formula 

2-point shape function contains two term f(x).dx=w1f(x1) w2f(x2) 

 

Q.44)  Why we are using polynomial equation in FEA 

Polynomial equation gives continuous solution & it is simple to solve problem. 

 

Q.45) What are the two important characteristics in stiffness matrix 

Characteristics of stiffness matrix is symmetric and bonded 

 

Q.46) Mention two schemes to represent band width 

2-Schemes are 

Horizontal numbering 

Vertical numbering 

 

Q.47)What are forces involved in work potential 

Forces involved are Body force, Traction force and Point force 

 

Q.48)What are the different methods to apply boundary condition 
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Elimination, multiconstraint, penalty method 

 

Q.49)  What is isoparametric elements 

These are those the S.F. used to define variables of displacement equal to S.F. used to 

represent geometry. 

 

Q.50) What is  orthotropic elements 

Material which has three orthogonal planes of symmetry said to be orthotropic elements. 

Only nine constants are required to describe constituent equation 

 

Q.51) What is anisotropic elements 

The material which doesn’t contain any plane of symmetry 

 

Q.52) What is isotropic elements 

isotropic material is one in which every plane is plane of symmetry only two constants are 

enough to describe constituent equation 

 

Q.53) What is super parametric elements 

GSF > DSF  (geometric shape function, displacement shape function 

Q.54) What is sub parametric elements 

GSF < DSF 

 

Q.55) Different coordinates involved in chain rule. 

Different coordinates involved in chain rule are normal , local and displacement coordinates . 

 

Q.56) What are the 2 different approaches to study elasticity ? 

Strength of material , Theory of elasticity 

 

Q.57) Mention any two methods to solve continuum problems. 

1. Raleighritz method 

2. Galerkin  method 

 

Q.58) List the properties of shape functions. 

SF for 1D bar element N1=0, N2= 0 at node 1 

N1=0 N2= 1 at node 2 . Diff. Of S.F. S.F are constant 

 

Q.59) Define truss. 

Structural member which is subjected to either tensile or compression 

 

Q.60)What is weighted residual methods. 

It’s a method in FEA for accurate solution avoiding error 
(residue = error) 

 

Q.61)Different methods to solve weighed residual problem. 

Point allocation, Sub domain , Galerkein,least square. 

 

Q.62)Explain the principle of virtual work. 

If the force and displacement are unrelated by cause effect relation then the work is said to be 

virtual work. 
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Q.63) Explain the principle of virtual displacement. 

Actual displacement is considered without bothering amount of force is  called virtual 

displacement . 

 

Q.64)What are different types of shape functions. 

Diff types are Lagarangian  and Hermite Shape function 

 

Q.65) Differentiate two types of shape functions. 

Lagarangian shape function only for variable 

Hermite shape function is for both variable and its derivative 

 

Q.66) Mention some advantages of FEA over solid mechanics. 

1.Applied for complicated structure 

2. Analysis is simple 

3. More accurate solution 

 

Q.67) Define Young’s Modulus and Poisson’s Ratio. 
E - it is the ratio of stress and strain 

-   It is the ratio of lateral strain and longitudinal strain 

 

Q.68) Mention different types of elastic constants. 

Young’s modulus, shear modulus, bulk modulus 

 

Q.69)Specify the terms required to solve FEA problem. 

Meshing , properties of material,boundry condition and initial condition. 

 

Q.70) What are the assumptions made in linear static problems. 

all displacement is small, material is isotrpic,linear,elastic solid with    E and  

 

Q.71) Which is the most accepted form of numerical integration in FEM? 

Gaussian Quadrature 

 

Q.72)List the different approaches to derive integral equation 

Direct method , variation method, weighed residual method, energy method 

 

Q.73)What are the advantages of symmetrical matrix. 

symmetrical matrix simplifies the calculation 

 

Q.74) What are the different types of errors in FEA? 

Modeling error , Descritized and Numerical error 

 

Q.75) What are the advantages of isoparametric elements 

Useful in modeling  structure with curved edges 

They are versatile & they are used in 2-D and 3-D elasticity problems 

 

Q.76). Define frontal method for finite element matrices. 

In 3- dimensional problems, the size of the stiffness matrix increases rapidly even with the 

banded method of modeling. An alternative direct method that results in considerable saving 

in the use of computer memory is called frontal method. 
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Q.77) What is the another name of the 3-dimensional frames 

Space frames. 

 

Q.78). Define beam elements. 

Beam elements are slender members that are used for supporting transverses loading. 

 

Q.79) Explain preprocessor steps. 

Determining the Nodal coordinates, connectivity, boundary condition, material information 

 

Q.80) Explain processing steps. 

Stiffness generation, modification, solutions to the equation resulting in evolution. 

 

Q.81) Explain post processing steps. 

Deformation confirmation, mode shapes, temperature and stress distribution, interpretation 

 

Q.82) What are the difference b/w beams and plane frames. 

It is similar to beams expect that axial loads &axial deformations are present. The elements 

also have different orientation. 

 

Q.83) Mention some common material properties. 

Isotropic, orthrotropic, ductility, brittleness 

 

Q.84) What are the different types of analysis. 

Thermal, structural (load), fluid, electromagnetic analysis 

 

Q.85) Define steady state analysis. 

The analysis carried out at constant temperature. 

 

Q.86) What is the advantage of subjecting solids to axisymmetric loading. 

Axisymmetric loading reduces the 3-D problem into 2-D problems because of total symmetry 

about the z-axis. 

 

Q.87) Define CST elements. 

The constant strain triangle is that where the displacement inside an element is represented by 

3-nodal displacement (3-shape functions). 

 

Q.88) How to generate the data files for larger problems in FEA. 

Using MESHGEN program generates data files. 

 

Q.89) Define mesh plotting 

It is the convenient way of reviewing the coordinate and connectivity data is by plotting it 

using computer. 

 

Q.90) Explain lumped mass matrices. 

It is the total element mass in each direction is distributed equally to the nodes of the element, 

and the masses are associated with translational degrees of freedom. 

 

 

 

Q.91) Briefly explain steps involved in Lagrangian method 
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 Formulation of potential energy function.                                                                                                                     

assuming displacement function 

 Checking displacement function considering boundary condition 

 Substitute differential function in potential energy equation 

 Potential energy function is minimized 

 Unknown parameters are determined and substituted in assumed               equation 

 

Q.92) Explain steps involved in Gallerkins method. 

Formulate differential equation of the equilibrium 

Assume trial function, which satisfies boundary conditions 

Substitute displacement function in differential equation then assume the difference due to 

approx. function be ‘R’ (residue) 
Use gallerkin formula 

Determine unknown terms and then substitute in differential function 

 

Q.93) Define jacobian matrix. 

The matrix which is defined explicitly in terms of the local coordinate is known as 

jacobian(J). 

 

Q.94) Mention six components of stress. 

3 linear stress along x, y, z direction 

3 lateral stress along x, y, z direction 

 

Q.95) Mention six components of strain. 

3 linear strain along x, y, z direction 

3 lateral strain along x, y, z direction 

 

Q.96) Define Winkler foundations. 

Large beams are supported on soil form a class of applications known as winkler foundations. 

 

Q.97) Define variational principle 

The problem which specifies a scalar quantity potential energy is defined in an integral form. 

 

Q.98) How to solve the prismatic problems. 

The coefficient of the ordinary differential equation are independent of one of the coordinate 

and the solution of the system can frequently carried out efficiently by standard analytical 

methods. 

 

Q.99) Define stress & strain. 

Stress is the ratio of applied load to its area. 

Strain is the ratio of change in length to its original length. 

 

Q.100) Mention the two distinct procedures available for obtaining the approximation in the 

integral forms. 

Method weighed residuals. 

Method of variation functional. 


	COMMERICAL FEM SOFTWARE PACKAGES AVAILABLE
	CASE B:  When the displacement g =1.2mm is given

