
Chapter 1: Introduction to Using ANSYS Fluent in ANSYS Workbench:
Fluid Flow and Heat Transfer in a Mixing Elbow

This tutorial is divided into the following sections:
1.1. Introduction
1.2. Prerequisites
1.3. Problem Description
1.4. Setup and Solution
1.5. Summary

1.1. Introduction

This tutorial illustrates using ANSYS Fluent fluid flow systems in ANSYS Workbench to set up and solve
a three-dimensional turbulent fluid-flow and heat-transfer problem in a mixing elbow. It is designed to
introduce you to the ANSYS Workbench tool set using a simple geometry. Guided by the steps that
follow, you will create the elbow geometry and the corresponding computational mesh using the
geometry and meshing tools within ANSYS Workbench. You will use ANSYS Fluent to set up and solve
the CFD problem, then visualize the results in both ANSYS Fluent and in the CFD-Post postprocessing
tool. Some capabilities of ANSYS Workbench (for example, duplicating fluid flow systems, connecting
systems, and comparing multiple data sets) are also examined in this tutorial.

This tutorial demonstrates how to do the following:

• Launch ANSYS Workbench.

• Create a Fluent  fluid flow analysis system in ANSYS Workbench.

• Create the elbow geometry using ANSYS DesignModeler.

• Create the computational mesh for the geometry using ANSYS Meshing.

• Set up the CFD simulation in ANSYS Fluent, which includes:

– Setting material properties and boundary conditions for a turbulent forced-convection problem.

– Initiating the calculation with residual plotting.

– Calculating a solution using the pressure-based solver.

– Examining the flow and temperature fields using ANSYS Fluent and CFD-Post.

• Create a copy of the original Fluent fluid flow analysis system in ANSYS Workbench.

• Change the geometry in ANSYS DesignModeler, using the duplicated system.

• Regenerate the computational mesh.

• Recalculate a solution in ANSYS Fluent.
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• Compare the results of the two calculations in CFD-Post.

1.2. Prerequisites

This tutorial assumes that you have little to no experience with ANSYS Workbench, ANSYS DesignModeler,
ANSYS Meshing, ANSYS Fluent, or CFD-Post, and so each step will be explicitly described.

1.3. Problem Description

The problem to be considered is shown schematically in Figure 1.1: Problem Specification (p. 3). A
cold fluid at 293.15 K flows into the pipe through a large inlet and mixes with a warmer fluid at 313.15 K
that enters through a smaller inlet located at the elbow. The mixing elbow configuration is encountered
in piping systems in power plants and process industries. It is often important to predict the flow field
and temperature field in the area of the mixing region in order to properly design the junction.

Note

Because the geometry of the mixing elbow is symmetric, only half of the elbow must be
modeled.
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Figure 1.1:  Problem Specification

Note

The functionality to create named selections exists in both ANSYS DesignModeler and ANSYS
Meshing. For the purposes of this tutorial, named selections are created in ANSYS Meshing
since the meshing application provides more comprehensive and extensive named selection
functionality.

1.4. Setup and Solution

The following sections describe the setup and solution steps for this tutorial:
1.4.1. Preparation
1.4.2. Creating a Fluent Fluid Flow Analysis System in ANSYS Workbench
1.4.3. Creating the Geometry in ANSYS DesignModeler
1.4.4. Meshing the Geometry in the ANSYS Meshing Application
1.4.5. Setting Up the CFD Simulation in ANSYS Fluent
1.4.6. Displaying Results in ANSYS Fluent and CFD-Post
1.4.7. Duplicating the Fluent-Based Fluid Flow Analysis System
1.4.8. Changing the Geometry in ANSYS DesignModeler
1.4.9. Updating the Mesh in the ANSYS Meshing Application
1.4.10. Calculating a New Solution in ANSYS Fluent
1.4.11. Comparing the Results of Both Systems in CFD-Post
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1.4.1. Preparation

1. Set up a working folder on the computer you will be using.

2. Go to the ANSYS Customer Portal, https://support.ansys.com/training.

Note

If you do not have a login, you can request one by clicking Customer Registration on
the log in page.

3. Enter the name of this tutorial into the search bar.

4. Narrow the results by using the filter on the left side of the page.

a. Click ANSYS Fluent under Product.

b. Click 16.0 under Version.

5. Select this tutorial from the list.

6. Click the elbow-workbench_R160.zip link to download the input and solution files.

7. Unzip elbow-workbench_R160.zip to your working folder. This file contains a folder,elbow-
workbench, that holds the following items:

• two geometry files,elbow_geometry.agdb and elbow_geometry.stp

• an ANSYS Workbench project archive,elbow-workbench.wbpz

Tip

The Workbench project archive contains the project as it will be once you have
completed all of the steps of the tutorial and is included for reference. If you want to
extract the project archive, start Workbench and select the File → Restore Archive...
menu item. You will be prompted with a dialog box to specify a location in which to
extract the project and its supporting files. You may choose any convenient location.

Note

ANSYS Fluent tutorials are prepared using ANSYS Fluent on a Windows system. The screen
shots and graphic images in the tutorials may be slightly different than the appearance on
your system, depending on the operating system or graphics card.

1.4.2. Creating a Fluent Fluid Flow Analysis System in ANSYS Workbench

In this step, you will start ANSYS Workbench, create a new Fluent fluid flow analysis system, then review
the list of files generated by ANSYS Workbench.
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1. From the Windows Start menu, select Start > All Programs > ANSYS 16.0 > Workbench 16.0 to start a
new ANSYS Workbench session.

This displays the ANSYS Workbench application window, which has the Toolbox on the left and the
Project Schematic to its right. Various supported applications are listed in the Toolbox and the
components of the analysis system will be displayed in the Project Schematic.

Note

Depending on which other products you have installed, the analysis systems that appear
may differ from those in the figures that follow in this tutorial.

Note

When you first start ANSYS Workbench, the Getting Started pop-up window is displayed,
offering assistance through the online help for using the application. You can keep the
window open, or close it by clicking the ‘X’ icon in the upper right-hand corner. If you
need to access the online help at any time, use the Help menu, or press the F1 key.

2. Create a new Fluent fluid flow analysis system by double-clicking the Fluid Flow (Fluent) option under
Analysis Systems in the Toolbox.

Tip

You can also drag-and-drop the analysis system into the Project Schematic. A green
dotted outline indicating a potential location for the new system initially appears in the
Project Schematic. When you drag the system to one of the outlines, it turns into a red
box to indicate the chosen location of the new system.

5
Release 16.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Setup and Solution



Figure 1.2:  Selecting the Fluid Flow (Fluent) Analysis System in ANSYS Workbench
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Figure 1.3:  ANSYS Workbench with a New Fluent-Based Fluid Flow Analysis System

3. Name the analysis.

a. Double-click the Fluid Flow (Fluent) label underneath the analysis system (if it is not already highlighted).

b. Enter elbow for the name of the analysis system.

4. Save the project.

a. Select the Save option under the File menu in ANSYS Workbench.

File → Save

This displays the Save As dialog box, where you can browse to your working folder and enter
a specific name for the ANSYS Workbench project.

b. In your working directory, enter elbow-workbench as the project File name and click the Save
button to save the project. ANSYS Workbench saves the project with a .wbpj extension and also saves
supporting files for the project.

Note that the fluid flow analysis system is composed of various cells (Geometry, Mesh, etc.) that
represent the workflow for performing the analysis. ANSYS Workbench is composed of multiple
data-integrated and native applications in a single, seamless project flow, where individual cells
can obtain data from other cells and provide data to other cells. As a result of this constant flow
of data, a cell’s state can quickly change. ANSYS Workbench provides a visual indication of a
cell’s state at any given time via icons on the right side of each cell. Brief descriptions of the
various states are provided below:

• Unfulfilled ( ) indicates that required upstream data does not exist. For example, when you first
create a new Fluid Flow (Fluent) analysis system, all cells downstream of the Geometry cell appear
as Unfulfilled because you have not yet specified a geometry for the system.
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• Refresh Required ( ) indicates that upstream data has changed since the last refresh or update.
For example, after you assign a geometry to the geometry cell in your new Fluid Flow (Fluent)
analysis system, the Mesh cell appears as Refresh Required since the geometry data has not yet
been passed from the Geometry cell to the Mesh cell.

• Attention Required ( ) indicates that the current upstream data has been passed to the cell, however,
you must take some action to proceed. For example, after you launch ANSYS Fluent from the Setup
cell in a Fluid Flow (Fluent) analysis system that has a valid mesh, the Setup cell appears as Attention
Required because additional data must be entered in ANSYS Fluent before you can calculate a
solution.

• Update Required ( ) indicates that local data has changed and the output of the cell must be re-
generated. For example, after you launch ANSYS Meshing from the Mesh cell in a Fluid Flow (Fluent)
analysis system that has a valid geometry, the Mesh cell appears as Update Required because the
Mesh cell has all the data it must generate an ANSYS Fluent mesh file, but the ANSYS Fluent mesh
file has not yet been generated.

• Up To Date ( ) indicates that an update has been performed on the cell and no failures have occurred
or that an interactive calculation has been completed successfully. For example, after ANSYS Flu-
ent finishes performing the number of iterations that you request, the Solution cell appears as Up-
to-Date.

• Interrupted, Update Required ( ) indicates that you have interrupted an update (or canceled an
interactive calculation that is in progress). For example, if you select the Cancel button in ANSYS
Fluent while it is iterating, ANSYS Fluent completes the current iteration and then the Solution cell
appears as Interrupted, Update Required.

• Input Changes Pending ( ) indicates that the cell is locally up-to-date, but may change when
next updated as a result of changes made to upstream cells. For example, if you change the Mesh
in an Up-to-Date Fluid Flow (Fluent) analysis system, the Setup cell appears as Refresh Required,
and the Solution and Results cells appear as Input Changes Pending.

• Pending ( ) indicates that a batch or asynchronous solution is in progress. When a cell enters the
Pending state, you can interact with the project to exit Workbench or work with other parts of the
project. If you make changes to the project that are upstream of the updating cell, then the cell will
not be in an up-to-date state when the solution completes.

For more information about cell states, see Understanding Cell States.

5. View the list of files generated by ANSYS Workbench.

ANSYS Workbench allows you to easily view the files associated with your project using the Files
view. To open the Files view, select the Files option under the View menu at the top of the ANSYS
Workbench window.

View → Files
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Figure 1.4:  ANSYS Workbench Files View for the Project After Adding a Fluent-Based Fluid
Flow Analysis System

In the Files view, you will be able to see the name and type of file, the ID of the cell that the file is
associated with, the size of the file, the location of the file, and other information. For more inform-
ation about the Files view, see Files View.

Note

The sizes of the files listed may differ slightly from those portrayed in Figure 1.4: ANSYS
Workbench Files View for the Project After Adding a Fluent-Based Fluid Flow Analysis
System (p. 9).

From here, you will create the geometry described in Figure 1.1: Problem Specification (p. 3), and
later create a mesh and set up a fluid flow analysis for the geometry.

1.4.3. Creating the Geometry in ANSYS DesignModeler

For the geometry of your fluid flow analysis, you can create a geometry in ANSYS DesignModeler, or
import the appropriate geometry file. In this step, you will create the geometry in ANSYS DesignModeler,
then review the list of files generated by ANSYS Workbench.

Important

Note the Attention Required icon ( ) within the Geometry cell for the system. This
indicates that the cell requires data (for example, a geometry). Once the geometry is
defined, the state of the cell will change accordingly. Likewise, the state of some of the
remaining cells in the system will change.

Note

If you would rather not create the geometry in ANSYS DesignModeler, you can import a pre-
existing geometry by right-clicking the Geometry cell and selecting the Import Geometry
option from the context menu. From there, you can browse your file system to locate the
elbow_geometry.agdb geometry file that is provided for this tutorial. If you do not have
access to ANSYS DesignModeler, you can use the elbow_geometry.stp file instead.

To learn how to create a mesh from the geometry you imported, go to Meshing the Geometry
in the ANSYS Meshing Application (p. 20).

1. Start ANSYS DesignModeler.
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In the ANSYS Workbench Project Schematic, double-click the Geometry cell in the elbow fluid
flow analysis system. This displays the ANSYS DesignModeler application.

Tip

You can also right-click the Geometry cell to display the context menu, then select New
Geometry...

2. Set the units in ANSYS DesignModeler.

When ANSYS DesignModeler first appears, you should select desired system of length units to work
from. For the purposes of this tutorial (where you will create the geometry in millimeters and perform
the CFD analysis using SI units) set the units to Millimeter.

Units → Millimeter

3. Create the geometry.

The geometry for this tutorial (Figure 1.1: Problem Specification (p. 3)) consists of a large curved
pipe accompanied by a smaller side pipe. ANSYS DesignModeler provides various geometry primitives
that can be combined to rapidly create geometries such as this one. You will perform the following
tasks to create the geometry:

• Create the bend in the main pipe by defining a segment of a torus.

• Extrude the faces of the torus segment to form the straight inlet and outlet lengths.

• Create the side pipe by adding a cylinder primitive.

• Use the symmetry tool to reduce the model to half of the pipe assembly, thus reducing computa-
tional cost.

a. Create the main pipe:

i. Create a new torus for the pipe bend by choosing the Create → Primitives → Torus menu item
from the menubar.

A preview of the torus geometry will appear in the graphics window. Note that this is a preview
and the geometry has not been created yet. First you must specify the parameters of the torus
primitive in the next step.

ii. In the Details View for the new torus (Torus1), set Base Y Component to -1 by clicking the 1 to
the right of FD10, Base Y Component, entering -1, and pressing Enter. This specifies the direction
vector from the origin to the center of the circular cross-section at the start of the torus. In the same
manner, specify Angle; Inner Radius; and Outer Radius as shown below.

Note

Enter only the value without the units of mm. They will be appended automatically
because you specified the units previously.
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iii. To create the torus segment, click the Generate button  that is located in the ANSYS
DesignModeler toolbar.
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iv. Ensure that the selection filter is set to Faces. This is indicated by the Faces button  appearing

depressed in the toolbar and the appearance of the Face selection cursor,  when you mouse
over the geometry.

v. Select the top face (in the positive Y direction) of the elbow and click the Extrude button 
from the 3D Features toolbar.

vi. In the Details View for the new extrusion (Extrude1), click Apply to the right of Geometry. This
accepts the face you selected as the base geometry of the extrusion.

vii. Click None (Normal) to the right of Direction Vector. Again, ensure that the selection filter is set
to Faces, select the same face on the elbow to specify that the extrusion will be normal to the face
and click Apply.
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viii.Enter 200 for FD1, Depth (>0) and click Generate.
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ix. In a similar manner, create an extrusion of the other face of the torus segment to create the 200
mm inlet extension. You will probably find it helpful to rotate the view so that you can easily select
the other face of the bend.

You can use the mouse buttons to change your view of the 3D image. The following table
describes mouse actions that are available:

Table 1.1:  DesignModeler View Manipulation Instructions

Using Graphics Toolbar Buttons and the MouseAction

After clicking the Rotate icon, , press and hold the left mouse button and
drag the mouse. Dragging side to side rotates the view about the vertical axis,
and dragging up and down rotates the view about the horizontal axis.

Rotate view
(vertical,
horizontal)

After clicking the Pan icon, , press and hold the left mouse button and
drag the object with the mouse until the view is satisfactory.

Translate or
pan view

After clicking the Zoom icon, , press and hold the left mouse button and
drag the mouse up and down to zoom in and out of the view.

Zoom in and
out of view
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Using Graphics Toolbar Buttons and the MouseAction

After clicking the Box Zoom icon, , press and hold the left mouse button
and drag the mouse diagonally across the screen. This action will cause a

Box zoom

rectangle to appear in the display. When you release the mouse button, a new
view will be displayed that consists entirely of the contents of the rectangle.

Clicking the Zoom to Fit icon, , will cause the object to fit exactly and be centered in the
window.

After entering the extrusion parameters and clicking Generate, the geometry should appear
as in Figure 1.5: Elbow Main Pipe Geometry (p. 15).

Figure 1.5:  Elbow Main Pipe Geometry

b. Next you will use a cylinder primitive to create the side pipe.
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i. Choose Create → Primitives → Cylinder from the menubar.

ii. In the Details View, set the parameters for the cylinder as follows and click Generate:

ValueSettingTab

XYPlaneBasePlaneDetails of
Cylinder1 137.5FD3, Origin X Coordinate

-225FD4, Origin Y Coordinate

0FD5, Origin Z Coordinate

0FD6, Axis X Component

125FD7, Axis Y Component

0FD8, Axis Z Component

12.5FD10, Radius (>0)

The Origin Coordinates determine the starting point for the cylinder and the Axis Components determine
the length and orientation of the cylinder body.
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c. The final step in creating the geometry is to split the body on its symmetry plane which will halve the
computational domain.

i. Choose Tools → Symmetry from the menu bar.

ii. Select the XYPlane in the Tree Outline.

iii. Click Apply next to Symmetry Plane 1 in the Details view.

iv. Click Generate.
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The new surface created with this operation will be assigned a symmetry boundary condition
in Fluent so that the model will accurately reflect the physics of the complete elbow geometry
even though only half of it is meshed.

d. Specify the geometry as a fluid body.

i. In the Tree Outline, open the 1 Part, 1 Body branch and select Solid.

ii. In the Details View of the body, change the name of the Body from Solid to Fluid.

iii. In the Fluid/Solid section, select Fluid.
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iv. Click Generate.

Tip

In addition to the primitives you used in this tutorial, ANSYS DesignModeler offers a full
suite of 2D sketching and 3D solid modeling tools for creating arbitrary geometry. Refer
to ANSYS DesignModeler User's Guide for more information.

4. Close ANSYS DesignModeler by selecting File → Close DesignModeler or by clicking the ‘X’ icon in the
upper right-hand corner. ANSYS Workbench automatically saves the geometry and updates the Project
Schematic accordingly. The question mark in the Geometry cell is replaced by a check mark, indicating
that there is a geometry now associated with the fluid flow analysis system.

5. View the list of files generated by ANSYS Workbench by selecting View → Files.

Figure 1.6:  ANSYS Workbench Files View for the Project After Creating the Geometry

Note the addition of the geometry file (FFF.agdb, where FFF indicates a Fluent-based fluid flow
system) to the list of files. If you had imported the geometry file provided for this tutorial rather
than creating the geometry yourself, the elbow_geometry.agdb (or the elbow_geometry.stp)
file would be listed instead.
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1.4.4. Meshing the Geometry in the ANSYS Meshing Application

Now that you have created the mixing elbow geometry, you must generate a computational mesh
throughout the flow volume. For this section of the tutorial, you will use the ANSYS Meshing application
to create a mesh for your CFD analysis, then review the list of files generated by ANSYS Workbench.

Important

Note the Refresh Required icon ( ) within the Mesh cell for the system. This indicates
that the state of the cell requires a refresh and that upstream data has changed since
the last refresh or update (such as an update to the geometry). Once the mesh is defined,
the state of the Mesh cell will change accordingly, as will the state of the next cell in
the system, in this case the Setup cell.

1. Open the ANSYS Meshing application.

In the ANSYS Workbench  Project Schematic, double-click the Mesh cell in the elbow fluid flow
analysis system (cell A3). This displays the ANSYS Meshing application with the elbow geometry
already loaded. You can also right-click the Mesh cell to display the context menu where you can
select the Edit... option.

Release 16.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.20

Introduction to Using ANSYS Fluent in ANSYS Workbench: Fluid Flow and Heat
Transfer in a Mixing Elbow



Figure 1.7: The ANSYS Meshing Application with the Elbow Geometry Loaded

2. Create named selections for the geometry boundaries.

In order to simplify your work later on in ANSYS Fluent, you should label each boundary in the
geometry by creating named selections for the pipe inlets, the outlet, and the symmetry surface
(the outer wall boundaries are automatically detected by ANSYS Fluent).

a. Select the large inlet in the geometry that is displayed in the ANSYS Meshing application.

Tip

• Use the Graphics Toolbar buttons and the mouse to manipulate the image until you can
easily see the pipe openings and surfaces.

• To select the inlet, the Single select ( ) mode must be active.

b. Right-click and select the Create Named Selection option.
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Figure 1.8:  Selecting a Face to Name

This displays the Selection Name dialog box.
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Figure 1.9:  Applying a Name to a Selected Face

c. In the Selection Name dialog box, enter velocity-inlet-large for the name and click OK.

d. Perform the same operations for:

• The small inlet (velocity-inlet-small)

• The large outlet (pressure-outlet)

• The symmetry plane (symmetry).

Important

It is important to note that by using the strings “velocity inlet” and “pressure outlet”
in the named selections (with or without hyphens or underscore characters), ANSYS
Fluent automatically detects and assigns the corresponding boundary types accordingly.

3. Create a named selection for the fluid body.

a. Change the selection filter to Body in the Graphics Toolbar ( )

b. Click the elbow in the graphics display to select it.

c. Right-click, select the Create Named Selection option and name the body Fluid.

By creating a named selection called Fluid for the fluid body you will ensure that ANSYS Fluent
automatically detects that the volume is a fluid zone and treats it accordingly.

4. Set basic meshing parameters for the ANSYS Meshing application.

For this analysis, you will adjust several meshing parameters to obtain a finer mesh.
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a. In the Outline view, select Mesh under Project/Model to display the Details of “Mesh” view below
the Outline view.

Important

Note that because the ANSYS Meshing application automatically detects that you
are going to perform a CFD fluid flow analysis using ANSYS Fluent, the Physics
Preference is already set to CFD and the Solver Preference is already set to
Fluent.

b. Expand the Sizing node by clicking the “+” sign to the left of the word Sizing to reveal additional sizing
parameters.

i. Change Relevance Center to Fine by clicking on the default value, Coarse, and selecting Fine from
the drop-down list.

ii. Change Smoothing to High

c. Add a Body Sizing control.

i. With Mesh still selected in the Outline tree, click the elbow in the graphics display to select it.

ii. Right click in the graphics area and select Insert → Sizing from the context menu.
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A new Body Sizing entry appears under Mesh in the project Outline tree

iii. Click the new Body Sizing control in the Outline tree.

iv. Enter 6e-3 for Element Size and press Enter.

d. Click again on Mesh in the Outline view and expand the Inflation node in the Details of “Mesh” view
to reveal additional inflation parameters. Change Use Automatic Inflation to Program Controlled.

5. Generate the mesh.

Right-click Mesh in the project Outline tree, and select Update in the context menu.
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Figure 1.10: The Computational Mesh for the Elbow Geometry in the ANSYS Meshing Application

Important

Using the Generate Mesh option creates the mesh, but does not actually create the
relevant mesh files for the project and is optional if you already know that the mesh
is acceptable. Using the Update option automatically generates the mesh, creates
the relevant mesh files for your project, and updates the ANSYS Workbench cell that
references this mesh.

Note

Once the mesh is generated, you can view the mesh statistics by opening the Statistics
node in the Details of “Mesh” view. This will display information such as the number of
nodes and the number of elements.

Release 16.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.26

Introduction to Using ANSYS Fluent in ANSYS Workbench: Fluid Flow and Heat
Transfer in a Mixing Elbow



6. Close the ANSYS Meshing application.

You can close the ANSYS Meshing application without saving it because ANSYS Workbench automat-
ically saves the mesh and updates the Project Schematic accordingly. The Refresh Required icon
in the Mesh cell has been replaced by a check mark, indicating that there is a mesh now associated
with the fluid flow analysis system.

7. View the list of files generated by ANSYS Workbench.

View → Files

Figure 1.11:  ANSYS Workbench Files View for the Project After Mesh Creation

Note the addition of the mesh files (FFF.msh and FFF.mshdb) to the list of files. The FFF.msh
file is created when you update the mesh, and the FFF.mshdb file is generated when you close
the ANSYS Meshing application.

1.4.5. Setting Up the CFD Simulation in ANSYS Fluent

Now that you have created a computational mesh for the elbow geometry, in this step you will set up
a CFD analysis using ANSYS Fluent, then review the list of files generated by ANSYS Workbench.

1. Start ANSYS Fluent.

In the ANSYS Workbench Project Schematic, double-click the Setup cell in the elbow fluid flow
analysis system. You can also right-click the Setup cell to display the context menu where you can
select the Edit... option.

When ANSYS Fluent is first started, the Fluent Launcher is displayed, enabling you to view and/or
set certain ANSYS Fluent start-up options.

Note

The Fluent Launcher allows you to decide which version of ANSYS Fluent you will use,
based on your geometry and on your processing capabilities.
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Figure 1.12:  Fluent Launcher

a. Ensure that the proper options are enabled.

Important

Note that the Dimension setting is already filled in and cannot be changed, since
ANSYS Fluent automatically sets it based on the mesh or geometry for the current
system.

i. Ensure that Serial from the Processing Options list is enabled.

ii. Select Double Precision under Options.

iii. Ensure that the Display Mesh After Reading, Embed Graphics Windows, and Workbench Color
Scheme options are enabled.

Note

An option is enabled when there is a check mark in the check box, and disabled
when the check box is empty. To change an option from disabled to enabled (or
vice versa), click the check box or the text.

Note

Fluent will retain your preferences for future sessions.
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b. Click OK to launch ANSYS Fluent.

Note

The ANSYS Fluent settings file (FFF.set) is written as soon as ANSYS Fluent opens.

Figure 1.13: The ANSYS Fluent Application

2. Set general settings for the CFD analysis.

Click General in the tree to open the General task page where you can perform the mesh-related
activities and to choose a solver.

Setup → General
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Note

Many of the common setup, solution and results commands are also accessible through
the submenus that open by right-clicking the tree items under the relevant tree branches.

a. Change the units for length.

Because you want to specify and view values based on a unit of length in millimeters from
within ANSYS Fluent, change the units of length within ANSYS Fluent from meters (the default)
to millimeters.

Important

Note that the ANSYS Meshing application automatically converts and exports
meshes for ANSYS Fluent using meters (m) as the unit of length regardless of
what units were used to create them. This is so you do not have to scale the
mesh in ANSYS Fluent under ANSYS Workbench.

Setup → General → Units...

This displays the Set Units dialog box.
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i. Select length in the Quantities list.

ii. Select mm in the Units list.

iii. Close the dialog box.

Note

Now, all subsequent inputs that require a value based on a unit of length can be
specified in millimeters rather than meters.

b. Check the mesh.

Setup → General → Check

Note

ANSYS Fluent will report the results of the mesh check in the console.

 Domain Extents:
   x-coordinate: min (m) = -2.000000e-01, max (m) = 2.000000e-01
   y-coordinate: min (m) = -2.250000e-01, max (m) = 2.000000e-01
   z-coordinate: min (m) = 0.000000e+00, max (m) = 5.000000e-02
 Volume statistics:
   minimum volume (m3): 1.144763e-10
   maximum volume (m3): 5.871098e-08
     total volume (m3): 2.511309e-03
 Face area statistics:
   minimum face area (m2): 2.051494e-07
   maximum face area (m2): 3.429518e-05
 Checking mesh..........................
Done.

Note

The minimum and maximum values may vary slightly when running on different
platforms. The mesh check will list the minimum and maximum x and y values from
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the mesh in the default SI unit of meters. It will also report a number of other mesh
features that are checked. Any errors in the mesh will be reported at this time. Ensure
that the minimum volume is not negative as ANSYS Fluent cannot begin a calculation
when this is the case.

c. Review the mesh quality.

Setup → General → Report Quality

Note

ANSYS Fluent will report the results of the mesh quality below the results of the mesh
check in the console.

Mesh Quality: 
Minimum Orthogonal Quality = 1.77384e-01 
(Orthogonal Quality ranges from 0 to 1, where values close to 0 correspond to low quality.) 
Maximum Ortho Skew = 7.60448e-01 
(Ortho Skew ranges from 0 to 1, where values close to 1 correspond to low quality.) 
Maximum Aspect Ratio = 1.92111e+01

Note

The quality of the mesh plays a significant role in the accuracy and stability of the
numerical computation.  Checking the quality of your mesh is, therefore, an important
step in performing a robust simulation.  Minimum cell orthogonality is an important
indicator of mesh quality. Values for orthogonality can vary between 0 and 1 with
lower values indicating poorer quality cells.  In general, the minimum orthogonality
should not be below 0.01 with the average value significantly larger. The high aspect
ratio cells in this mesh are near the walls and are a result of the boundary layer inflation
applied in the meshing step. For more information about the importance of mesh
quality refer to Mesh Quality in the User’s Guide.

3. Set up your models for the CFD simulation.

Setup → Models
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a. Enable heat transfer by activating the energy equation.

In the tree, right-click Energy under Models and from the submenu that opens, click On.

Setup → Models → Energy On

Note

You can also double-click a tree item and enable the energy equation in the Energy
dialog box.

b. Enable the -  turbulence model.

Setup → Models → Viscous Edit...
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i. Select k-epsilon from the Model list.

Note

The Viscous Model dialog box will expand.

ii. Use the default Standard from the k-epsilon Model list.

iii. Select Enhanced Wall Treatment for the Near-Wall Treatment.

Note

The default Standard Wall Functions are generally applicable if the first cell center
adjacent to the wall has a y+ larger than 30. In contrast, the Enhanced Wall
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Treatment option provides consistent solutions for all y+ values. Enhanced Wall
Treatment is recommended when using the k-epsilon model for general single-
phase fluid flow problems. For more information about Near Wall Treatments in
the k-epsilon model refer to Setting Up the k-ε Model in the User’s Guide.

iv. Click OK to accept the model and close the Viscous Model dialog box.

4. Set up your materials for the CFD simulation.

Setup → Materials

a. Create a new material called water using the Create/Edit Materials dialog box (Figure 1.14: The Cre-
ate/Edit Materials Dialog Box (p. 36)).

Setup → Materials → Fluid → Create/Edit...

i. Type water for Name.

ii. Enter the following values in the Properties group box:

ValueProperty

1000Density
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ValueProperty

4216 (Specific Heat)

0.677Thermal Conductivity

8e-04Viscosity

Figure 1.14: The Create/Edit Materials Dialog Box

iii. Click Change/Create.

Note

A Question dialog box will open, asking if you want to overwrite air. Click No so
that the new material water is added to the Fluent Fluid Materials list of mater-
ials that originally contained only air.
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Extra

You could have copied the material water-liquid (h2o < l >) from the materials
database (accessed by clicking the ANSYS Fluent Database... button). If the
properties in the database are different from those you want to use, you can edit
the values in the Properties group box in the Create/Edit Materials dialog box
and click Change/Create to update your local copy. The original copy will not be
affected.

iv. Ensure that there are now two materials (water and air) defined locally by examining the Fluent
Fluid Materials drop-down list.

Note

Both the materials will also be listed under Fluid in the Materials task page.

v. Close the Create/Edit Materials dialog box.

5. Set up the cell zone conditions for the CFD simulation.

Setup → Cell Zone Conditions
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a. Set the cell zone conditions for the fluid zone.

i. In the Cell Zone Conditions task page, in the Zone list, select fluid and click Edit... to open the
Fluid dialog box.

Note

You can also double-click a list or tree item in order to open the corresponding
dialog box.
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ii. In the Fluid dialog box, select water from the Material Name drop-down list.

iii. Click OK to close the Fluid dialog box.

6. Set up the boundary conditions for the CFD analysis.

Setup → Boundary Conditions
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a. Set the boundary conditions at the cold inlet (velocity-inlet-large).

Setup → Boundary Conditions → velocity-inlet-large → Edit...

This opens the Velocity Inlet dialog box.

Tip

If you are unsure of which inlet zone corresponds to the cold inlet, you can use the
mouse to probe for mesh information in the graphics window. If you click the right
mouse button with the pointer on any node in the mesh, information about the asso-
ciated zone will be displayed in the ANSYS Fluent console, including the name of the
zone. The zone you probed will be automatically selected from the Zone selection
list in the Boundary Conditions task page.

Alternatively, you can click the probe button ( ) in the graphics toolbar and click
the left mouse button on any node. This feature is especially useful when you have
several zones of the same type and you want to distinguish between them quickly.
The information will be displayed in the console.
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i. Select Components from the Velocity Specification Method drop-down list.

Note

The Velocity Inlet dialog box will expand.

ii. Enter 0.4  for X-Velocity.

iii. Retain the default value of 0  for both Y-Velocity and Z-Velocity.

iv. In the Turbulence group box, from the Specification Method drop-down list, select Intensity and
Hydraulic Diameter.

v. Retain the default of 5  for Turbulent Intensity.

vi. Enter 100 mm for Hydraulic Diameter.

Note

The hydraulic diameter  is defined as:
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where  is the cross-sectional area and  is the wetted perimeter.

vii. Click the Thermal tab.

viii.Enter 293.15  for Temperature.

ix. Click OK to close the Velocity Inlet dialog box.

b. In a similar manner, set the boundary conditions at the hot inlet (velocity-inlet-small), using the values
in the following table:

Setup → Boundary Conditions → velocity-inlet-small → Edit...

ComponentsVelocity Specification Method

0X-Velocity

1.2Y-Velocity

0Z-Velocity
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ComponentsVelocity Specification Method

Intensity & Hydraulic DiameterSpecification Method

5Turbulent Intensity

25 mmHydraulic Diameter

313.15Temperature

c. Set the boundary conditions at the outlet (pressure-outlet), as shown in the Pressure Outlet dialog
box.

Setup → Boundary Conditions → pressure-outlet → Edit...

Note

ANSYS Fluent will use the backflow conditions only if the fluid is flowing into the
computational domain through the outlet. Since backflow might occur at some point
during the solution procedure, you should set reasonable backflow conditions to
prevent convergence from being adversely affected.

7. Set up solution parameters for the CFD simulation.

Note

In the steps that follow, you will set up and run the calculation using the task pages listed
under the Solution branch in the tree.
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a. Change the Gradient method.

Solution → Solution Methods

In the Spatial Discretization section of the Solution Methods pane, change the Gradient to
Green-Gauss Node Based. This gradient method is suggested for tetrahedral meshes.

b. Examine the convergence criteria for the equation residuals.

Solution → Monitors → Residuals Edit...
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i. Ensure that Plot is enabled in the Options group box.

ii. Keep the default values for the Absolute Criteria of the Residuals, as shown in the Residual
Monitors dialog box.

iii. Click OK to close the Residual Monitors dialog box.

Note

By default, all variables will be monitored and checked by ANSYS Fluent as a means
to determine the convergence of the solution.

c. Create a surface monitor at the outlet (pressure-outlet)

It is good practice to monitor physical solution quantities in addition to equation residuals when as-
sessing convergence.

Solution → Monitors → Surface New...
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i. Retain the default entry of surf-mon-1 for the Name of the surface monitor.

ii. Enable the Plot option for surf-mon-1.

iii. Set Get Data Every to 3 by clicking the up-arrow button.

This setting instructs ANSYS Fluent to update the plot of the surface monitor and write data to a
file after every 3 iterations during the solution.

iv. Select Facet Maximum from the Report Type drop-down list.

v. Select Temperature... and Static Temperature from the Field Variable drop-down lists.

vi. Select pressure-outlet from the Surfaces selection list.

vii. Click OK to save the surface monitor settings and close the Surface Monitor dialog box.

The name and report type of the surface monitor you created will be displayed under the Surface
tree item.

d. Initialize the flow field.
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Solution → Solution Initialization

i. Keep the default of Hybrid Initialization from the Initialization Methods group box.

ii. Click Initialize.

e. Check to see if the case conforms to best practices.

Solution → Run Calculation → Check Case

i. Click the Models and Solver tabs and examine the Recommendation in each. These recommend-
ations can be ignored for this tutorial. The issues they raise will be addressed in later tutorials.

ii. Close the Case Check dialog box.

8. Calculate a solution.

a. Start the calculation by requesting 300 iterations.

Solution → Run Calculation

47
Release 16.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Setup and Solution



i. Enter 300 for Number of Iterations.

ii. Click Calculate.

Important

Note that the ANSYS Fluent settings file (FFF.set) is updated in the Files view
of the ANSYS Workbench before the calculation begins.

Important

Note that while the program is calculating the solution, the states of the Setup
and Solution cells in the fluid flow ANSYS Fluent analysis system in ANSYS
Workbench are changing. For example:

• The state of the Setup cell becomes Up-to-Date and the state of the Solution cell
becomes Refresh Required after the Run Calculation task page is visited and the
number of iterations is specified.

• The state of the Solution cell is Update Required while iterations are taking place.
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• The state of the Solution cell is Up-to-Date when the specified number of iterations
are complete (or if convergence is reached).

Note

As the calculation progresses, the surface monitor history will be plotted in the
graphics window (Figure 1.15: Convergence History of the Maximum Temperature at
Pressure Outlet (p. 49)).

Note

The solution will be stopped by ANSYS Fluent when the residuals reach their specified
values or after 300 iterations. The exact number of iterations will vary depending on
the platform being used. An Information dialog box will open to alert you that the
calculation is complete. Click OK in the Information dialog box to proceed.

Because the residual values vary slightly by platform, the plot that appears on your
screen may not be exactly the same as the one shown here.

Figure 1.15:  Convergence History of the Maximum Temperature at Pressure Outlet

You can display the residuals history (Figure 1.16: Residuals for the Converged Solution (p. 50)), by
selecting it from the graphics window drop-down list.
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Figure 1.16:  Residuals for the Converged Solution

b. Examine the plots for convergence (Figure 1.16: Residuals for the Converged Solution (p. 50) and Fig-
ure 1.15: Convergence History of the Maximum Temperature at Pressure Outlet (p. 49)).

Note

There are no universal metrics for judging convergence. Residual definitions that are
useful for one class of problem are sometimes misleading for other classes of problems.
Therefore it is a good idea to judge convergence not only by examining residual
levels, but also by monitoring relevant integrated quantities and checking for mass
and energy balances.

There are three indicators that convergence has been reached:

• The residuals have decreased to a sufficient degree.

The solution has converged when the Convergence Criterion for each variable
has been reached. The default criterion is that each residual will be reduced to a

value of less than , except the energy residual, for which the default criterion

is .

• The solution no longer changes with more iterations.

Sometimes the residuals may not fall below the convergence criterion set in the
case setup. However, monitoring the representative flow variables through iterations
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may show that the residuals have stagnated and do not change with further itera-
tions. This could also be considered as convergence.

• The overall mass, momentum, energy, and scalar balances are obtained.

You can examine the overall mass, momentum, energy and scalar balances in the
Flux Reports dialog box. The net imbalance should be less than 0.2  of the net
flux through the domain when the solution has converged. In the next step you
will check to see if the mass balance indicates convergence.

9. View the list of files generated by ANSYS Workbench.

View → Files

Note that the status of the Solution cell is now up-to-date.

1.4.6. Displaying Results in ANSYS Fluent and CFD-Post

In this step, you will display the results of the simulation in ANSYS Fluent, display the results in CFD-
Post, then review the list of files generated by ANSYS Workbench.

1. Display results in ANSYS Fluent.

With ANSYS Fluent still running, you can perform a simple evaluation of the velocity and temperature
contours on the symmetry plane. Later, you will use CFD-Post (from within ANSYS Workbench) to
perform the same evaluation.

a. Display filled contours of velocity magnitude on the symmetry plane (Figure 1.17: Velocity Distribution
Along Symmetry Plane (p. 53)).

Results → Graphics → Contours Edit...

Note

You can also double-click a tree item in order to open the corresponding dialog box.
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i. In the Contours dialog box, enable Filled in the Options group box.

ii. Ensure that Node Values is enabled in the Options group box.

iii. Select Velocity... and Velocity Magnitude from the Contours of drop-down lists.

iv. Select symmetry from the Surfaces selection list.

v. Click Display to display the contours in the active graphics window.
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Figure 1.17: Velocity Distribution Along Symmetry Plane

b. Display filled contours of temperature on the symmetry plane (Figure 1.18: Temperature Distribution
Along Symmetry Plane (p. 55)).

Results → Graphics → Contours Edit...
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i. Select Temperature... and Static Temperature from the Contours of drop-down lists.

ii. Click Display and close the Contours dialog box.
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Figure 1.18: Temperature Distribution Along Symmetry Plane

c. Close the ANSYS Fluent application.

File → Close Fluent

Important

Note that the ANSYS Fluent case and data files are automatically saved when you exit
ANSYS Fluent and return to ANSYS Workbench.

d. View the list of files generated by ANSYS Workbench.

View → Files
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Note the addition of the compressed ANSYS Fluent case and data files to the list of files. These
will have names like FFF-1.cas.gz and FFF-1-00222.dat.gz. Note that the digit(s) fol-
lowing FFF may be different if you have had to restart the meshing or calculation steps for any
reason and that the name of the data file is based on the number of iterations. Thus your file
names may be slightly different than those shown here.

2. Display results in CFD-Post.

a. Start CFD-Post.

In the ANSYS Workbench  Project Schematic, double-click the Results cell in the elbow fluid
flow analysis system (cell A6). This displays the CFD-Post application. You can also right-click the
Results cell to display the context menu where you can select the Edit... option.

Note

The elbow geometry is already loaded and is displayed in outline mode. ANSYS Fluent
case and data files are also automatically loaded into CFD-Post.

Figure 1.19: The Elbow Geometry Loaded into CFD-Post

b. Reorient the display.

Click the blue Z axis on the axis triad in the bottom right hand corner of the graphics display to
orient the display so that the view is of the front of the elbow geometry.
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c. Ensure that Highlighting ( ) is disabled.

d. Display filled contours of velocity magnitude on the symmetry plane (Figure 1.20: Velocity Distribution
Along Symmetry Plane (p. 58)).

i. Insert a contour object using the Insert menu item at the top of the CFD-Post window.

Insert → Contour

This displays the Insert Contour dialog box.

ii. Keep the default name of the contour (Contour 1) and click OK to close the dialog box. This dis-
plays the Details of Contour 1 view below the Outline view in CFD-Post. This view contains all of
the settings for a contour object.

iii. In the Geometry tab, from the Domains drop-down list, select fluid.

iv. Select symmetry in the Locations list.

v. Select Velocity in the Variable list.

vi. Click Apply.
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Figure 1.20: Velocity Distribution Along Symmetry Plane

e. Display filled contours of temperature on the symmetry plane (Figure 1.21: Temperature Distribution
Along Symmetry Plane (p. 59)).

i. Under User Locations and Plots, clear the check box beside the Contour 1 object to disable the
Contour 1 object and hide the first contour display.

ii. Insert a contour object.

Insert → Contour

This displays the Insert Contour dialog box.

iii. Keep the default name of the contour (Contour 2) and click OK to close the dialog box. This dis-
plays the Details of Contour 2 view below the Outline view.

iv. In the Geometry tab, from the Domains drop-down list, select fluid.
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v. Select symmetry in the Locations list.

vi. Select Temperature in the Variable list.

vii. Click Apply.

Figure 1.21: Temperature Distribution Along Symmetry Plane

3. Close the CFD-Post application by selecting File → Close ANSYS CFD-Post or by clicking the ‘X’ in the top
right corner of the window.

Important

Note that the CFD-Post state files are automatically saved when you exit CFD-Post
and return to ANSYS Workbench.
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4. Save the elbow-workbench project in ANSYS Workbench.

5. View the list of files generated by ANSYS Workbench.

View → Files

Note the addition of the CFD-Post state file (elbow.cst) to the list of files. For more information
about CFD-Post (and the files associated with it), see the CFD-Post documentation.

1.4.7. Duplicating the Fluent-Based Fluid Flow Analysis System

At this point, you have a completely defined fluid flow system that is comprised of a geometry, a
computational mesh, a CFD setup and solution, and corresponding results. In order to study the effects
upon the flow field that may occur if you were to alter the geometry, another fluid flow analysis is re-
quired. One approach would be to use the current system and change the geometry, however you
would overwrite the data from your previous simulation. A more suitable and effective approach would
be to create a copy, or duplicate, of the current system, and then make the appropriate changes to the
duplicate system.

In this step, you will create a duplicate of the original Fluent-based fluid flow system, then review the
list of files generated by ANSYS Workbench.

1. In the Project Schematic, right-click the title cell of the Fluid Flow (Fluent) system and select Duplicate
from the context menu.

Figure 1.22:  Duplicating the Fluid Flow System

Release 16.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.60

Introduction to Using ANSYS Fluent in ANSYS Workbench: Fluid Flow and Heat
Transfer in a Mixing Elbow



Figure 1.23: The Original Fluid Flow System and Its Duplicate

Note

Notice that in the duplicated system, the state of the Solution cell indicates that the cell
requires an update while the state of the Results cell indicates that the cell requires at-
tention. This is because when a system is duplicated, the case and data files are not
copied to the new system, therefore, the new system does not yet have solution data
associated with it.

2. Rename the duplicated system to new-elbow.

3. Save the elbow-workbench project in ANSYS Workbench.

1.4.8. Changing the Geometry in ANSYS DesignModeler

Now that you have two separate, but equivalent, Fluent-based fluid flow systems to work from, you
can make changes to the second system without impacting the original system. In this step, you will
make a slight alteration to the elbow geometry in ANSYS DesignModeler by changing the diameter of
the smaller inlet, then review the list of files generated by ANSYS Workbench.

1. Open ANSYS DesignModeler.

Double-click the Geometry cell of the new-elbow system (cell B2) to display the geometry in
ANSYS DesignModeler.

2. Change the diameter of the small inlet (velocity-inlet-small).

a. Select Cylinder1 to open the Details View of the small inlet pipe.

b. In the Details View, change the FD10, Radius (>0) value from 12.5 millimeters to 19 millimeters.
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c. Click the Generate button to generate the geometry with your new values.
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Figure 1.24:  Changing the Diameter of the Small Inlet in ANSYS DesignModeler

3. Close ANSYS DesignModeler.

4. View the list of files generated by ANSYS Workbench.

View → Files

Note the addition of the geometry, mesh, and ANSYS Fluent settings files now associated with the
new, duplicated system.

1.4.9. Updating the Mesh in the ANSYS Meshing Application

The modified geometry now requires a new computational mesh. The mesh settings for the duplicated
system are retained in the duplicated system. In this step, you will update the mesh based on the mesh
settings from the original system, then review the list of files generated by ANSYS Workbench.
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In the Project Schematic, right-click the Mesh cell of the new-elbow system (cell B3) and select Update
from the context menu. This will update the mesh for the new geometry based on the mesh settings
you specified earlier in the ANSYS Meshing application without having to open the ANSYS Meshing
editor to regenerate the mesh.

Figure 1.25:  Updating the Mesh for the Changed Geometry

It will take a few moments to update the mesh. Once the update is complete, the state of the Mesh
cell is changed to up-to-date, symbolized by a green check mark.

For illustrative purposes of the tutorial, the new geometry and the new mesh are displayed below.

Release 16.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.64

Introduction to Using ANSYS Fluent in ANSYS Workbench: Fluid Flow and Heat
Transfer in a Mixing Elbow



Figure 1.26: The Updated Geometry and Mesh in the ANSYS Meshing Application

Inspecting the files generated by ANSYS Workbench reveals the updated mesh file for the duplicated
system.

View → Files

1.4.10. Calculating a New Solution in ANSYS Fluent

Now that there is an updated computational mesh for the modified geometry in the duplicated system,
a new solution must be generated using ANSYS Fluent. In this step, you will revisit the settings within
ANSYS Fluent, calculate another solution, view the new results, then review the list of files generated
by ANSYS Workbench.

1. Open ANSYS Fluent.

In the Project Schematic, right-click the Setup cell of the new-elbow system (cell B4) and select
Edit... from the context menu. Since the mesh has been changed, you are prompted as to whether

65
Release 16.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Setup and Solution



you want to load the new mesh into ANSYS Fluent or not. Click Yes to continue, and click OK when
Fluent Launcher is displayed in order to open ANSYS Fluent.

Figure 1.27:  ANSYS Workbench Prompt When the Upstream Mesh Has Changed

2. Ensure that the unit of length is set to millimeters.

Setup → General → Units...

3. Check the mesh (optional).

Setup → General → Check

4. Revisit the boundary conditions for the small inlet.

Setup → Boundary Conditions → velocity-inlet-small → Edit...

Here, you must set the hydraulic diameter to 38 mm based on the new dimensions of the small
inlet.

5. Re-initialize the solution.

Solution → Solution Initialization

Keep the default Hybrid Initialization and click Initialize.

6. Recalculate the solution.

Solution → Run Calculation

Keep the Number of Iterations set to 300 and click Calculate.

7. Close ANSYS Fluent.

8. Revisit the results of the calculations in CFD-Post.

Double-click the Results cell of the new-elbow fluid flow system to re-open CFD-Post where you
can review the results of the new solution.

9. Close CFD-Post.

10. Save the elbow-workbench project in ANSYS Workbench.
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11. View the list of files generated by ANSYS Workbench.

View → Files

Note the addition of the solution and state files now associated with new duplicated system.

1.4.11. Comparing the Results of Both Systems in CFD-Post

In this step, you will create a new Results system in ANSYS Workbench, use that system to compare
the solutions from each of the two Fluent-based fluid flow analysis systems in CFD-Post at the same
time, then review the list of files generated by ANSYS Workbench.

1. Create a Results system.

In ANSYS Workbench, drag a Results system from the Component Systems section of the Toolbox
and drop it into the Project Schematic, next to the fluid flow systems.

Figure 1.28: The New Results System in the Project Schematic

2. Add the solutions of each of the systems to the Results system.

a. Select the Solution cell in the first Fluid Flow analysis system (cell A5) and drag it over the Results cell
in the Results system (cell C2). This creates a transfer data connection between the two systems.

Figure 1.29:  Connecting the First Fluid Flow System to the New Results System

b. Select the Solution cell in the second Fluid Flow analysis system (cell B5) and drag it over the Results
cell in the Results system (cell C2). This creates a transfer data connection between the two systems.
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Figure 1.30:  Connecting the Second Fluid Flow System to the New Results System

3. Open CFD-Post to compare the results of the two fluid flow systems.

Now that the two fluid flow systems are connected to the Results system, double-click the Results
cell in the Results system (cell C2) to open CFD-Post. Within CFD-Post, both geometries are displayed
side by side.

Figure 1.31:  CFD-Post with Both Fluid Flow Systems Displayed

a. Re-orient the display.
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In each view, click the blue Z axis on the axis triad in the bottom right hand corner of the
graphics display to orient the display so that the view is of the front of the elbow geometry.

Important

Alternatively, you can select the synchronization tool ( ) in the 3D Viewer
Toolbar to synchronize the views, so that when you re-orient one view, the
other view is automatically updated.

b. Display filled contours of velocity magnitude on the symmetry plane.

i. Insert a contour object.

Insert → Contour

This displays the Insert Contour dialog box.

ii. Keep the default name of the contour (Contour 1) and click OK to close the dialog box. This dis-
plays the Details of Contour 1 view below the Outline view in CFD-Post. This view contains all of
the settings for a contour object.

iii. In the Geometry tab, select fluid in the Domains list.

iv. Select symmetry in the Locations list.

v. Select Velocity in the Variable list.

vi. Click Apply. The velocity contours are displayed in each view.

Note

To better visualize the velocity display, you can clear the Wireframe view option under
User Locations and Plots in the Outline tree view.
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Figure 1.32:  CFD-Post Displaying Velocity Contours for Both Geometries

c. Display filled contours of temperature on the symmetry plane.

i. Deselect the Contour 1 object under User Locations and Plots in CFD-Post to hide the first contour
display.

ii. Insert another contour object.

Insert → Contour

This displays the Insert Contour dialog box.

iii. Keep the default name of the contour (Contour 2) and click OK to close the dialog box. This dis-
plays the Details of Contour 2 view below the Outline view in CFD-Post.
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iv. In the Geometry tab, select fluid in the Domains list.

v. Select symmetry in the Locations list.

vi. Select Temperature in the Variable list.

vii. Click Apply. The temperature contours are displayed in each view.

Figure 1.33:  CFD-Post Displaying Temperature Contours for Both Geometries

4. Close the CFD-Post application.

5. Save the elbow-workbench project in ANSYS Workbench.

6. View the list of files associated with your project using the Files view.

View → Files
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Note the addition of the Results system and its corresponding files.

1.5. Summary

In this tutorial, portions of ANSYS Workbench were used to compare the fluid flow through two slightly
different geometries. ANSYS DesignModeler was used to create a mixing elbow geometry, ANSYS
Meshing was used to create a computational mesh, ANSYS Fluent was used to calculate the fluid flow
throughout the geometry using the computational mesh, and CFD-Post was used to analyze the results.
In addition, the geometry was altered, a new mesh was generated, and a new solution was calculated.
Finally, ANSYS Workbench was set up so that CFD-Post could directly compare the results of both cal-
culations at the same time.
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