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CHAPTER 6 BUILDING BLOCKS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

As you work with documents in Word, it’s likely that you’re using the 
same elements repeatedly, such as tables, images, logos and 
boilerplate text, for example. Instead of having to retype or insert 
the same information over and over, you can save these elements 
as building blocks. You can then easily insert the building block 
into your document as required. Building blocks streamline the 
process of building documents and save time. 

In this session you will: 

 gain an understanding of building blocks 

 learn how to insert a building block 

 learn how to create Quick Parts 

 learn how to save building blocks 

 learn how to insert Quick Parts 

 learn how to edit Quick Parts 

 learn how to delete building blocks 

 learn how to save building blocks in a template 

 gain an understanding of the difference between 

AutoText and Quick Parts. 

INFOCUS 

WPL_W858 
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UNDERSTANDING BUILDING BLOCKS 
 

 

 

 

 

Building blocks are saved objects or elements 
that you insert into a document, such as text, 
logos, tables or images, for example. The 
Building Blocks Organiser, which acts like is 

like a library of these stored building blocks that 
you can select and then paste into your document 
as needed. 

The Building Blocks Organiser 

The Building Blocks Organiser 
is a repository of saved 
document elements, such as 
text, paragraphs, tables, images 
and so on, that you can easily 
insert into any document. The 
Building Blocks Organiser 
includes a default range of 
building blocks, and you can add 
as many of your own as you 
need. The example shown to the 
right is a cover page that you can 
add to a document. This 
automatically creates the page at 
the beginning of the document 
and adds the formatting and 
graphics as shown in the 
preview. 

Building Block Properties 

Unlike the Office Clipboard which just keeps a 
temporary copy of text and/or graphics, the 
Building Blocks Organiser keeps additional 
information about each building block, such as 
its unique name, the gallery in which it 
appears, its category, a description, the 
template in which it is saved and options that 
control the way it is inserted into a document 
(see picture to the right). In this case, the cover 
page is inserted on a page by itself. 

Where Are Building Blocks Stored? 

Items in the Building Blocks Organiser are stored in a special template called Building 
Blocks.dotx. Because this template is separate from the templates that you use to create 
documents, it means that building blocks are available to use in any document that you create. 
You can also save them in other templates so that they can be restricted to particular documents or 
distributed to other users. 
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INSERTING A BUILDING BLOCK 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise 

you must ensure that a blank 
document is open... 

 Click on the Insert tab, then 

click on Quick Parts  in 

the Text group and select 
Building Blocks Organiser 

The Building Blocks Organiser 
dialog box will be displayed... 

 Click on Transcend in the 
gallery Cover Pages to see 
the preview 

 Scroll down through the list  
and click on various building 
blocks to preview them 

 Click on Mod Quote in the 
Text Boxes gallery to see a 
preview 

 Click on [Insert] to insert it into 
your document 

This is just an example of how 
quick and easy it is to insert 
building blocks… 

 Close the document without 
saving 

 

For Your Reference… 

To insert a building block: 

1. Click on Quick Parts  

2. Select Building Blocks Organiser 

3. Click on a building block to preview it 

4. Click on [Insert] 

Handy to Know… 

 You can click on the column headers, Name, 
Gallery, Category or Template, to sort the 
building blocks into alphabetical order by that 
column. This makes it a bit easier to find 
building blocks in specific galleries or 
categories. 

1 

2 

You can view all available building blocks in the 
Building Blocks Organiser. This is accessed 
via Quick Parts in the Text group on the Insert 
tab. You can use the Building Blocks 

Organiser to preview any of the existing building 
blocks, as well as inserting or deleting a building 
block or editing the properties of a building block. 
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CREATING QUICK PARTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise you 

MUST open the file W858 
Building Blocks_1.docx... 

 Select the heading Incident and 
Hazard Reporting and the 
paragraph below it 

 Click on the Insert tab, then 

click on Quick Parts  and 

select Save Selection to Quick 
Part Gallery to display the 
Create New Building Block 
dialog box 

 Type Incident and Hazard 
Reporting in Name 

 Click in Description, type 
Procedure and click on [OK] 

 Click on Quick Parts  to 

display the Quick Parts gallery 

Your new quick part will appear 
at the top of the list, complete 
with a preview... 

 Click on Quick Parts  again 

to close the menu 

 Repeat steps 1 to 6 for the other 
three paragraphs using the 
headings for the Names 

They will be added progressively 
to the Quick Parts gallery… 

 Save the document 

 

For Your Reference… 

To create a quick part from a selection: 

1. Click on Quick Parts  and select Save 

Selection to Quick Part Gallery 

2. Type a Name and Description if required 

3. Click on [OK] 

Handy to Know… 

 To assign a keyboard shortcut to a building 
block, click on the File tab, then Options. Click 
on Customise Ribbon, then [Customise]. 
Select Building Blocks under Categories, 
then select the building block. Type the 
shortcut keys in Assign new shortcut key. 

Click on [Assign] then click on [Close].  

1 

2 

A quick part is a type of building block. Quick 
parts are often blocks of text that you use 
repeatedly across your documents, such as a 
standard opening paragraph in a letter or closing 

signature. You can create as many quick parts as 
you need. The main advantage of creating quick 
parts is that they can be inserted in any document 
quickly and easily. 

5 
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SAVING BUILDING BLOCKS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise 

you MUST open the file W858 
Building Blocks_1.docx... 

 Click on the File tab and then 
click on Exit 

If any documents have been 
modified and not saved, you 
will be prompted to save 
them…  

 Click on [Save] if required to 
save any open documents 

You will now be prompted to 
save changes to the Building 
Blocks.dotx template... 

 Click on [Save] to save the 
template and exit Word 

 Open Microsoft Word 

 

For Your Reference… 

To save Building Blocks: 

1. Click on the File tab and then click on Exit 

2. Click on [Save] if required to save changes 
to any open documents 

3. Click on [Save] to save the changes to 

Building Blocks.dotx 

Handy to Know… 

 You can undo changes that you’ve made in 
the Building Blocks Organiser simply by 
closing Word and clicking on [No] so that the 
changes are not saved. When you reopen 
Word, the entries in the Building Blocks 
Organiser will be as they were before you 
made the changes. 

2 

Quick Parts and other building blocks are saved 
in a template called Building Blocks.dotx. You 
may have noticed it in the Create New Building 
Blocks dialog box when you created the quick 

parts. This template is not automatically updated 
when you make changes. You must remember to 
save the changes when you exit Microsoft Word. 
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INSERTING QUICK PARTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise you 

MUST open the file W858 Building 
Blocks_2.docx... 

 Click at the end of the document 
and press  

This is where we’ll insert the quick 
part... 

 Click on the Insert tab, then click 

on Quick Parts  to display the 

Quick Parts gallery 

 Click on Incident and Hazard 
Reporting to insert the paragraph 

 Click on Quick Parts  then 

click on Reporting Telephone 
Faults to insert this paragraph 

You can also insert quick parts 
from the Building Blocks 
Organiser... 

 Click on Quick Parts  and 

select Building Blocks 
Organiser 

 Click on the Gallery column 
header to sort entries by gallery  

 Scroll down until you can see the 
Quick Parts in Gallery 

 Click on Workstatio... then click 
on [Insert] to insert the paragraph 
and close the dialog box 

 Save the document 

 

For Your Reference… 

To insert a quick part: 

1. Click on Quick Parts  

2. Click on the required quick part  

Handy to Know… 

 You can also insert a quick part by typing its 
name and pressing . If you think you’ll be 

inserting particular paragraphs regularly, you 
might like to give them shorter names so that 
they are easy to remember. 

3 

4 

Once saved, quick parts and other building 
blocks can easily be inserted into any document. 
This is done by retrieving the quick part from the 
Building Blocks Organiser. The quick part will 

be inserted wherever your insertion point is placed 
in the document, so make sure that you are 

prepared before you access the Organiser. 

7 
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EDITING BUILDING BLOCKS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous file 
with this exercise, or open the 
file W858 Building 
Blocks_3.docx... 

 Click at the end of the third 
bulleted point in the paragraph 
about Reporting Telephone 
Faults 

 Press  and type Inability to 

access voice mail 

 Select the entire section on 
Reporting Telephone Faults 

 Click on the Insert tab, then 

click on Quick Parts  and 

select Save Selection to Quick 
Part Gallery to display the 
Create New Building Block 
dialog box 

 Type Reporting Telephone 
Faults for Name, then click in 
Description and type 
Procedure 

 Click on [OK]  

Because an entry with the same 
name already exists, you will be 
asked if you want to redefine it... 

 Click on [Yes] 

Remember to save the Building 
Blocks.dotx template when you 
exit Word… 

 Save the document 

 

 

For Your Reference… 

To edit a quick part: 

1. Select the text or object 

2. Click on Quick Parts  and select Save 

Selection to Quick Part Gallery 

3. Type the Name, then click on [OK] and then 

click on [Yes] 

Handy to Know… 

 If you want to edit a quick part that is not 
displayed in a document anywhere, insert it 
into a blank document, make the changes, 
and then save it in the Building Blocks 

Organiser, replacing the original entry. 

2 

6 

Once you’ve created a quick part (or any other 
building block) you can edit the quick part as 
required.  Note that to edit a quick part, you need 
to insert the quick part into a document and then 

resave it to the Building Blocks Organiser. Here 
you will edit and update a quick part, and then 
resave the quick part. 

4 
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DELETING BUILDING BLOCKS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or open 
the file W858 Building 
Blocks_4.docx... 

 Click on Quick Parts  and 

select Building Blocks 
Organiser 

 Scroll down until you can see 
the Quick Parts entries then 
click on Reporting T... 

 Click on [Delete] 

You will be asked to confirm 
the deletion... 

 Click on [Yes] 

The entry will disappear from 
the list... 

 Repeat steps 2 to 4 to delete 
the other two Quick Parts 

 Click on [Close] then click on 
the File tab and click on Exit 

You will be prompted to save 
any unsaved documents as 
well as the changes to Building 
Blocks.dotx... 

 Click on [Save] to save both 
files if prompted 

 

For Your Reference… 

To delete a quick part: 

1. Click on Quick Parts  and select 

Building Blocks Organiser 

2. Click on the entry and click on [Delete] 

3. Click on [Yes] to confirm then click on 

[Close] 

Handy to Know… 

 You can delete a quick part by right-clicking 
on it in the Quick Parts gallery and selecting 
Organise and Delete. This takes you 
directly into the Building Blocks Organiser 
with the entry already located and selected 
for you. Click on [Delete] to delete the quick 
part. 

2 

3 

When you find you no longer require specific 
quick parts or other building blocks, it makes 
sense to remove them from the Building Blocks 
Organiser. This makes it easier to find the 

entries that you still use and prevents people from 
using old or incorrect entries by mistake. You must 
also remember to save the changes to Building 
Blocks.dotx as you exit Word. 
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SAVING BUILDING BLOCKS TO A TEMPLATE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Before starting this exercise 
you MUST open the file W858 
Building Blocks 
Template.dotx... 

 Select the paragraph on 
Incident and Hazard 
Reporting 

 Click on the Insert tab then 

click on Quick Parts  and 

select Save Selection to 
Quick Part Gallery to display 
the Create New Building 
Block dialog box 

 Type Incident and Hazard 
Reporting for Name then click 
in Description and type 
Procedure 

 Click on the drop arrow  for 
Save in and select W758 
Building Blocks 
Template.dotx 

 Click on [OK] then click on the 
close button  to close the 
document 

You will be prompted to save 
the changes to W758 Building 
Blocks Template.dotx. This 
includes the addition of the 
building blocks to the 
template... 

 Click on [Save] 

 

For Your Reference… 

To save building blocks to a template: 

1. Click on Quick Parts  and select Save 

Selection to Quick Part Gallery 

2. Type a Name  

3. Change Save in to the required template 

then click on [OK] 

Handy to Know… 

 To save building blocks to a template, the 
template or a document based on that 
template must be open. 

1 

4 

Building blocks are saved to Building 
Blocks.dotx and are available to every 
document you open in Word. However, you may 
prefer that some building blocks are restricted to 

specific documents or templates. You can create 
building blocks in a template and then make the 
building blocks only available to documents based 
on that template. 

5 
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AUTOTEXT VERSUS QUICK PARTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

AutoText and quick parts are two types of 
building blocks galleries in Microsoft Word. 
Autotext and quick parts are very similar in that 
they both allow you to store any snippet of text, 

graphics or other objects, however, AutoText is 
useful for small snippets of text while quick parts is 
useful for big blocks of text. This page discusses 
the differences between them. 

Common Features Of AutoText And Quick Parts 

AutoText and quick parts are stored document elements, such as blocks of text, graphics or other 
objects that you can insert into your documents as required. Both AutoText and quick parts can be 

inserted from the Building Blocks Organiser or by typing their name and pressing .  

The Difference Is The Gallery 

The main difference between Autotext and quick 
parts is that Autotext entries are stored in the 
AutoText gallery, while quick parts are stored in the 
Quick Parts gallery. When creating a new building 
block, you can assign the gallery in which the 
elements will be stored. So, click on the drop arrow  
for Gallery and click on AutoText or leave it as the 
default Quick Parts. 

The gallery you select determines where they will 
appear. quick parts, for example, are listed in the 
Quick Parts gallery when you click on Quick Parts 

 in the Text group on the Insert tab. Autotext is 

displayed in the AutoText gallery, which can be 
accessed by clicking on Quick Parts and then 
selecting AutoText to display the AutoText entries. 

 

When To Use Quick Parts 

Save large blocks of text, formatted tables and 
images, for example, as quick parts.  

 

 

 

 

When To Use AutoText 

Autotext is best used for small amounts of text, such 
as company names or personal names which you can 
name with an abbreviation. To use the Autotext, you 
can type the abbreviation, press  to insert the text, 

and keep typing.  

Ultimately, the choice between saving something as a 
quick part or as Autotext is yours! 

 


