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Lab-Volt License Agreement 
By using the software in this package, you are agreeing to 
become bound by the terms of this License Agreement, 
Limited Warranty, and Disclaimer. 
 
This License Agreement constitutes the complete 
agreement between you and Lab-Volt. If you do not 
agree to the terms of this agreement, do not use the 
software. Promptly return the multimedia (CD-ROM) 
compact discs and all other materials that are part of 
Lab-Volt's multimedia Tech-Design product within ten 
days to Lab-Volt for a full refund or credit.  
1. License Grant. In consideration of payment of the 
license fee, which is part of the price you paid for this Lab-
Volt product, Lab-Volt, as Licensor, grants to you, the 
Licensee, a nonexclusive, nontransferable license to use 
this copy of the CD-ROM software with the corresponding 
curriculum resources. Lab-Volt reserves all rights not 
expressly granted to the Licensee. 

2. Ownership. As the Licensee, you own the physical 
media on which the CD-ROM is originally or subsequently 
recorded or fixed, but Lab-Volt retains title to and 
ownership of the software programs recorded on the 
original compact disc and any subsequent copies of the 
CD-ROM, regardless of the form or media in or on which 
the original and other copies may exist. This license is not 
a sale of the original software program of Lab-Volt's CD-
ROM or any portion or copy of it.  

3. Copy Restrictions. The CD-ROM software and the 
accompanying materials are copyrighted and contain 
proprietary information and trade secrets of Lab-Volt. 
Unauthorized copying of the CD-ROM even if modified, 
merged, or included with other software or with written 
materials is expressly forbidden. You may be held legally 
responsible for any infringement of Lab-Volt's intellectual 
property rights that is caused or encouraged by your failure 
to abide by the terms of this agreement. You may make 
copies of the CD-ROM solely for backup purposes 
provided the copyright notice is reproduced in its entirety 
on the backup copy.  

4. Permitted Uses. This CD-ROM and all accompanying 
documentation is licensed to you, the Licensee, and may 
not be transferred to any third party for any length of time 
without the prior written consent of Lab-Volt. You may not 
modify, adapt, translate, reverse engineer, decompile, 
disassemble, or create derivative works based on the Lab-
Volt product without the prior written permission of Lab-
Volt. Written materials provided to you may not be 
modified, adapted, translated, or used to create derivative 
works without the prior written consent of Lab-Volt.  

5. Termination. This agreement is effective until 
terminated. It will terminate automatically without notice 
from Lab-Volt if you fail to comply with any provisions 
contained herein. Upon termination you shall destroy the 
written materials, Lab-Volt's CD-ROM software, and all 
copies of them, in part or in whole, including modified 
copies, if any.  

6. Registration. Lab-Volt may from time to time update 
the CD-ROM. Updates can be made available to you only 

if a properly signed registration card is filed with Lab-Volt 
or an authorized registration card recipient. 
7. Miscellaneous. This agreement is governed by the laws 
of the State of New Jersey. 
 
Limited Warranty and Disclaimer 
This CD-ROM software has been designed to assure 
correct operation when used in the manner and within the 
limits described in the Tech-Lab® Multimedia Installation 
& User’s Guide. As a highly advanced software product, it 
is quite complex; thus, it is possible that if it is used in 
hardware configurations with characteristics other than 
those specified in Tech-Lab® Multimedia Installation & 
User’s Guide or in environments with non-specified, 
unusual, or extensive other software products, problems 
may be encountered by a user. In such cases, Lab-Volt will 
make reasonable efforts to assist the user to properly 
operate the CD-ROM but without guaranteeing its proper 
performance in any hardware or software environment 
other than as described in the Tech-Lab® Multimedia 
Installation & User’s Guide.  
This CD-ROM software is warranted to conform to the 
descriptions of its functions and performance as outlined in 
the courseware documentation. Upon proper notification 
and within a period of one year from the date of installation 
and/or customer acceptance, Lab-Volt, at its sole and 
exclusive option, will remedy any nonconformity or 
replace any defective compact disc free of charge. Any 
substantial revisions of this product, made for purposes of 
correcting software deficiencies within the warranty period, 
will be made available, also on a licensed basis, to 
registered owners free of charge. Warranty support for this 
product is limited, in all cases, to software errors. Errors 
caused by hardware malfunctions or the use of non-
specified hardware or other software are not covered.  
LICENSOR MAKES NO OTHER WARRANTIES OF ANY 
KIND CONCERNING THIS PRODUCT, INCLUDING 
WARRANTIES OR MERCHANTABILITY OR OF FITNESS 
FOR A PARTICULAR PURPOSE. LICENSOR DISCLAIMS 
ALL OBLIGATIONS AND LIABILITIES ON THE PART OF 
LICENSOR FOR DAMAGES, INCLUDING BUT NOT 
LIMITED TO SPECIAL OR CONSEQUENTIAL DAMAGES 
ARISING OUT OF OR IN CONNECTION WITH THE USE OF 
THE SOFTWARE PRODUCT LICENSED UNDER THIS 
AGREEMENT.  
Questions concerning this agreement and warranty and all 
requests for product repairs should be directed to Lab-Volt 
field representative in your area.  

LAB-VOLT SYSTEMS, INC. 
P.O. Box 686 
Farmingdale, NJ 07727 
Attention: Program Development 
Phone: (732) 938-2000 or (800) LAB-VOLT 
Fax: (732) 774-8573 
Technical Support: (800) 522-4436 
Technical Support E-Mail: techsupport@labvolt.com 
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BEGINNING LEVEL  
 
Mill Level 4 Software Programming Sheet #1 
 
Program Information 
Program Name  

Author  

Material  

Drawing No.  

Width (X)  

Depth (Y)  

Height (Z)  

 
Tools Used 

Tool # Description Diameter Radius 
9    

 
PART Program 

Line # Instruction Comment 
00001   

00002   

00003   

00004   

00005   

00006   

00007   

00008   

00009   

00010   

00011   

00012   

00013   
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Activity 1 – You Are the Programmer 
 
For this section, refer to your completed Mill Level 4 Software Programming Sheet #1 
as you work on the computer. 
 
1.  From the File pull-down menu, select New. The Program Setup screen appears. 
 
2. Delete <UNTITLED> from the Program Name field and leave it blank. 
 
3. Delete Teacher from the Author field and enter your name. 
 
4. In the Drawing ID field, the default, Project #1, should appear in the project field. If 

this is incorrect, highlight the text and center a project number. 
 
5.  In the Material section of the screen, select Plastic. If you are using wax, select Wax. 
 
6.  In the Editor portion of the screen, make sure Line Mode is selected. 
 
7.  In the Units portion of the screen, make sure Inch is selected. 
 
8.  In the Coordinates section, make sure Absolute is selected. 
 
9.  Enter the appropriate values in the X, Y, and Z fields. (X=2) (Y=2) (Z=0.5). 
 
10.  Click on the OK button. The Line Editor appears. 
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Entering the Part Program 
 
Notice that the Line Editor is numbered, starting with 00001; this is your first line of 
code. You will use the line numbers on your Mill Level 4 Software Programming 
Sheet #1 as a reference. 
 
1.   For the first line of instruction, begin by typing a backslash, “\”, followed by your 

name and class. The backslash tells the computer to ignore any information 
following it. You use this for information purposes only. If you did not type the 
backslash, the computer would not recognize or accept the information. Line 00001 
should look like this: 

 
\YOUR NAME CLASS 

 
2.   Press Enter. The cursor will move to line 00002. 
 
3.   Look at line 00002 on your Mill Level 4 Software Programming Sheet #1. You 

should have G70 written in the instruction. This tells the computer to use inches for 
measurement. Type “G70”, then press Enter for line 00002. 

 
4.  On line 00003, you will turn on the spindle motor with the M04 code and set the 

spindle speed to 2800 RPM. Type “M04 2800”, then press Enter. 
 
5.  On line 00004, you will set the feed rate at 4 inches per minute. Type “M07 4”, then 

press Enter. 
 
6.   Now enter your first tool movement code on line 00005. If you are moving in a 

straight line from one point to another, you use the Linear Interpolation command, 
which is G01. Type “G01”, then press Enter. 

 
7.  Using your Mill Level 4 Software Programming Sheet #1, continue entering the 

remaining lines of your program. 
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Saving the Program 
 
8.   From the File menu, select Save as. The File, Save As... dialog box opens. 
 
9.   In the File name field, enter your name and PART program (project) number. You 

can abbreviate if necessary. Your name will automatically be entered in the 
Program Name field on the Program Setup screen. 

 
10. Notice that the Save in field shows you that the program will be saved in the M4 

directory in the Mill Level 4 program. 
 
 

NOTE: Whenever you save a program, it is very important 
that you pay attention to the location of the program so that 
you can access it at any time. 

 
 
11. Click on the Save button. The name you assigned to your program now appears on 

the Line Editor title bar. 
 
Your program, which can be identified by your name and PART program (project) 
number, is now saved in the M4 directory with the other PART programs. 
 

Compiling the Program 
 
1.   From the Mill pull-down menu, select Compile. 
 
When the CNC Compiler opens, the program immediately performs a line-by-line check 
of your PART program. 
 
The Status field should say “Success! No Errors Detected.” 
 
2.   If an error is found, the Line Editor will highlight the line of code that is incorrect. You 

should then check your error against the information on your Software 
Programming Sheet and make the necessary changes. You must close the 
Compiler and re-open it each time an error is corrected. A mistake as simple as a 
missing space can cause an error. 

 
3.   When you are done, click on OK. 
 
4.   If any corrections were made, save the changes by selecting Save from the File 

menu. 
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Emulating the Program 
 
The word emulate means to copy, or to simulate. With the Mill Level 4 program, you can 
have the computer emulate the milling process that you programmed. 
 
 

NOTE: Emulation helps programmers and manufacturing 
engineers to see if the program they entered is correct. This 
saves time because they don’t have to make a test part, and 
it saves money because no materials will be wasted. 

 
 
1.   From the Mill pull-down menu, select Emulator. The Mill 3D Emulator opens. 
 
2.   Choose the top view (top-right button) from the View section and then click on the 

green start button in the Control section to see how your part will be machined on 
the mill. 

 
3.   Next, click on the front view (top-left button) in the view screen to see the depth of 

cut. Click on the green start button in the control section to see another view of how 
your part will be machined on the mill. 

 
4.   Click on the Close button (X) in the upper right corner of the Emulator screen to 

close the Emulator. 
 
5.   Click on the Close button (X) in the upper right corner of the Line Editor screen to 

close the Line Editor. 
 

Mill Tool Setup 
 
1.   From the Options pull-down menu, select Tool Setup. The Mill Tool Setup screen 

appears. 
 
2.   Select Tool Number 9 by clicking on the up and down arrows next to the Tool 

Number field. ¼” End Mill appears below the Tool Number. 
 
The Bit Diameter field shows you that the bit diameter is 0.25 inch. 
 
3.   When you are done, click on the OK button. 
 
4.   Go to the next section in the multimedia presentation. 
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Activity 2 – Loading the Program 
 
Do the following to open the PART program that you created in Activity 1. 
 
1.   From the File pull-down menu, select Open. The File, Open… dialog box appears. 
 
2.   Scroll until you find your program file. 
 
3.   Double-click on your program file. 
 
The Line Editor appears with the PART program you previously created. 
 
You are now ready to download your PART program to the CNC mill. Before you 
download your PART program, read the following sections: 
 

LOADING THE WORKPIECE and SETTING THE TOOL POSITION. 
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Loading the Workpiece 
The first step in executing the program is to load the workpiece. 
 
1.   Turn on the power switch located on the side of the mill. 
 
2.   Open the safety door. 
 
3.   Clamp a piece of 2" x 2" x .5" (5.08 cm x 5.08 cm x 1.27 cm) Plexiglas (or wax) in 

the vise. Make sure it is secure and level, with one half of the Plexiglas above the 
top of the vise. Make sure the workpiece is flush with the jaws of the vise (use the 
machinist rule, or ruler, to position the workpiece correctly). 

 
It should look like this: 
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Setting the Tool Position 
Before running your PART program, you must position the milling tool. Your point of 
reference is known as the Program Reference Zero, or PRZ. 
 
The PRZ is a reference point that enables the computer and the milling machine to 
locate the X, Y, and Z coordinates that you entered into your PART program. 
 
Quadrant I of the Cartesian Rectangular Ordinate System is used in programming to 
define the PRZ. The PRZ is the point at which the X axis and Y axis intersect. 
 
The PRZ on the workpiece is the point at which the X, Y, and Z axes intersect in the first 
quadrant. 
 
This means that you want to touch the front left corner of the workpiece with the tool. 
 
1.   Load a ¼" end mill into the spindle. (If necessary, loosen the small screw in the side 

of the spindle with an Allen wrench. After inserting the cutter, secure it by tightening 
the screw.) 

 
 
2.   Close the safety doors. 
 
3.   If locked, unlock the EMERGENCY STOP button and remove the key. 
 

 



CNC Mill  Directions 
 

10  Student Guide 

4.   When you are ready to position the end mill on the front left edge of the workpiece 
press MAIN MENU on the CNC Mill control panel. Your choices are Manual, 
Remote, and Setup. 

 
5.   Use the +Z and -Z keys of the control panel keypad to position the cursor next to 

MANUAL, then press ENTER. 
 
6.   Using the +X, -X, +Z, -Z, +Y, and -Y keys of the control panel keypad, position the 

center of the ¼" end mill on the left front corner edge of the workpiece. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
7.   Open the safety door and cover the workpiece with a 2-inch (5.08 cm) square piece 

of notebook paper. Close the safety door. Using the +Z and -Z keys, position the 
end of the cutter onto the top of the paper-covered workpiece, adjusting it so that 
the cutter is touching the paper, but the paper can be pulled free without ripping. 
Remove the paper. 

 
8.   Press Zero twice. This sets the PRZ for the X, Y, and Z axes to the current cutter 

position. 
 
9.   Press +Z to raise the headstock above the block. 
 
10. Press the ESC key on the control panel to return to the MAIN MENU. 
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Downloading Your Part Program 
1.   From the control panel on the CNC Mill MAIN MENU, use the -Z key to move the 

cursor next to REMOTE and press ENTER. 
 
The mill’s display now reads: 
 

Ready to Download 
 

<Esc> Abort 
 
2.   From the Mill pull-down menu, select Download. The Serial Download screen 

appears. 
 
The Remote Machine field tells you that you are downloading to a 5400 Mill. 
 
The Status field tells you that you are ready to transmit and the Last Error field tells you 
that there are no errors. If an error occurs, this field displays the error message code for 
the problem. If this happens, ask your instructor for help. 
 
3.   Click on the OK button. 
 
Look at the display on the CNC mill’s control panel and you will see “Downloading” and 
a rotating cursor indicating that your PART program is being downloaded to the mill. 
 
When the Download Complete screen is displayed on the mill, your PART program has 
been downloaded. 
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Executing Your Program 
You are now ready to execute your PART program. Remember to always wear safety 
glasses when operating the mill. 
 
Once your PART program has been downloaded to the 5400 CNC Mill, the control 
panel’s display will read: 
 

Download Complete 
 

<Enter> Machine Part 
 

<Esc> Abort 
 
1.   Press ENTER to begin machining your PART program. As the program executes, 
the display will change to show the current X, Y and Z positions; spindle speed, feed 
rate, and G code. 
 
2.   Watch the mill closely and make sure that enough of the workpiece is protruding 
from the vise and that you will not have a tool crash. After the program has finished, the 
mill will return to its home position and then stop. 
 
3.   At your computer, close the Line Editor by clicking on the (X) in the upper right 
corner. 
 

Cleanup 
1.   Open the safety doors and carefully remove the workpiece. 
 
2.   Press Esc to return to the Mill menu. 
 
3.   Press the EMERGENCY STOP button. 
 
4.   Turn off the power switch located on the side of the mill. 
 
5.   Clean up your area and return everything to its proper place. You may want to use a 

shop vacuum to carefully clean out the inside of the mill. 
 
When you are finished, go to the next section in the multimedia presentation. 
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Mill Level 4 Software Programming Sheet #2 
 
Program Information 
Program Name  

Author  

Material  

Drawing No.  

Width (X)  

Depth (Y)  

Height (Z)  
 
 
Tools Used 

Tool # Description Diameter Radius 
9    

 
 
PART Program 

Line # Instruction Comment 
00001   

00002   

00003   

00004   

00005   

00006   

00007   

00008   

00009   

00010   

00011   
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PART Program (continued) 
Line # Instruction Comment 
00012   

00013   

00014   

00015   

00016   

00017   

00018   

00019   
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Activity 3 
 
1.   Enter the program. Use your completed Mill Level 4 Software Programming 

Sheet #2. If necessary, refer to ENTERING THE PROGRAM in the ACTIVITY 1 
section. 

 
2.   Save the program. If necessary, refer to SAVING THE PROGRAM in the ACTIVITY 

1 section. 
 
3.   Compile the program. If necessary, refer to COMPILING THE PROGRAM in the 

ACTIVITY 1 section. 
 
4.   Emulate the program. If necessary, refer to EMULATING THE PROGRAM in the 

ACTIVITY 1 section. 
 
5.   Select the proper end mill. If necessary, refer to MILL TOOL SETUP in the 

ACTIVITY 1 section. 
 
When you are finished, go to the next section in the multimedia presentation. 
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Activity 4 
 
1.   Load the program. You are loading an existing program so, if necessary, refer to 

LOADING THE PROGRAM in the ACTIVITY 2 section. 
 
2.   Load the workpiece. If necessary, refer to LOADING THE WORKPIECE in the 

ACTIVITY 2 section. 
 
3.   Set the tool position. If necessary, refer to SETTING THE TOOL POSITION in the 

ACTIVITY 2 section. 
 
4.   Download the program. If necessary, refer to DOWNLOADING YOUR PROGRAM 

in the ACTIVITY 2 section. 
 
5.   Execute your program. If necessary, refer to EXECUTING YOUR PROGRAM in the 

ACTIVITY 2 section. 
 
6.   Clean up your workstation. If necessary, refer to CLEANUP in the ACTIVITY 2 

section. 
 
When you are finished, go to the next section in the multimedia presentation. 
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Mill Level 4 Software Programming Sheet #3 
 
Program Information 
Program Name  

Author  

Material  

Drawing No.  

Width (X)  

Depth (Y)  

Height (Z)  
 
 
Tools Used 

Tool # Description Diameter Radius 
9    

 
 
PART Program 

Line # Instruction Comment 
00001   

00002   

00003   

00004   

00005   

00006   

00007   

00008   

00009   

00010   

00011   
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PART Program (continued) 
Line # Instruction Comment 
00012   

00013   

00014   

00015   

00016   

00017   

00018   

00019   

00020   

00021   

00022   

00023   

00024   

00025   

00026   

00027   

00028   

00029   
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Activity 5 
 
1.   Enter your program. Use your completed Mill Level 4 Software Programming 

Sheet #3. If necessary, refer to ENTERING THE PART PROGRAM in the 
ACTIVITY 1 section. 

 
2.   Save the program. If necessary, refer to SAVING THE PROGRAM in the ACTIVITY 

1 section. 
 
3.   Compile the program. If necessary, refer to COMPILING THE PROGRAM in the 

ACTIVITY 1 section. 
 
4.   Emulate the program. If necessary, refer to EMULATING THE PROGRAM in the 

ACTIVITY 1 section. 
 
5.   Select the proper end mill. If necessary, refer to MILL TOOL SETUP in the 

ACTIVITY 1 section. 
 
6.   Load the workpiece. If necessary, refer to LOADING THE WORKPIECE in the 

ACTIVITY 2 section. 
 
7.   Set the tool position. If necessary, refer to SETTING THE TOOL POSITION in the 

ACTIVITY 2 section. 
 
8.   Download your program. If necessary, refer to DOWNLOADING YOUR PROGRAM 

in the ACTIVITY 2 section. 
 
9.   Execute your program. If necessary, refer to EXECUTING YOUR PROGRAM in the 

ACTIVITY 2 section. 
 
10. Clean up your workstation. If necessary, refer to CLEANUP in the ACTIVITY 2 

section. 
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Saving to a Floppy Disk 
When all lesson activities have been completed, your PART programs should be saved 
to a floppy disk and then removed from the .M4 directory. Your PART programs can be 
downloaded to Mill Level 4 at any time in the future if necessary. Follow the steps 
below. 
 
1.   Get a blank floppy disk from your instructor and label it with the names you assigned 
to the programs when they were initially created. Be sure to include your name. 
 
2.   Place the floppy disk in your computer floppy disk drive. 
 
3.   From the File pull-down menu, select Open. The File, Open window appears and 
shows all the PART programs stored in the M4 directory. 
 
4.   Right-click on one of your program files. A pop-up menu appears.  Select Send To 
and then click 3½ Floppy (A). Your computer will now download a copy of the program 
file to your floppy disk. 

 
 
 
 
 
 
 
 
 

5.   After the PART program has successfully copied to your floppy disk, right-click 
again on the program file. From the pop-up menu, click Delete. A Confirm File Delete 
dialog box appears. Click Yes. Your PART program is now permanently deleted from 
the directory. 
 
6.   Repeat these steps for each program file you have stored in the M4 directory. 
 
7.   When you are done, remove the floppy disk. 
 
Go to the next section in the multimedia presentation. 
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ADVANCED LEVEL 
 
Mill Level 4 Software Programming Sheet #1 
 
Program Information 
Program Name  

Author  

Material  

Drawing No.  

Width (X)  

Depth (Y)  

Height (Z)  
 
 
Tools Used 

Tool # Description Diameter Radius 
9    

 
 
PART Program 

Line # Instruction Comment 
00001   

00002   

00003   

00004   

00005   

00006   

00007   

00008   

00009   

00010   

00011   
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PART Program (continued) 
Line # Instruction Comment 
00012   

00013   

00014   

00015   

00016   

00017   

00018   

00019   

00020   

00021   

00022   

00023   

00024   

00025   

00026   

00027   

00028   

00029   
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Activity 1 – You Are the Programmer 
 
For this section, refer to your completed Mill Level 4 Software Programming Sheet #1 
as you work on the computer. 
 
1.   From the File pull-down menu, select New. The Program Setup screen appears. 
 
2.   Delete <UNTITLED> from the Program Name field and leave it blank. 
 
3.   Delete Teacher from the Author field and enter your name. 
 
4.   In the Drawing ID field, the default, Project #1 should appear in the project field. If 

this is incorrect, highlight the text and enter a project number. 
 
5.   In the Material section of the screen, select Plastic. If you are using wax, select 

Wax. 
 
6. In the Editor portion of the screen, make sure Line Mode is selected. 
 
7. In the Units portion of the screen, make sure Inch is selected. 
 
8.   In the Coordinates section, make sure Absolute is selected. 
 
9.   Enter the appropriate values in the X, Y, and Z fields. (X=2) (Y=2) (Z=0.5). 
 
10. Click on the OK button. The Line Editor appears. 
 
Complete the next section, ENTERING THE PROGRAM. 
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Entering the Program 
 
Notice that the Line Editor is numbered, starting with 00001; this is your first line of 
code. You will use the line numbers on your Mill Level 4 Software Programming 
Sheet #1 as a reference. 
 
1.   For the first line of instruction, begin by typing a backslash, “\”, followed by your 

name and class. The backslash tells the computer to ignore any information 
following it. You use this for information purposes only. If you did not type the 
backslash, the computer would not recognize or accept the information. Line 00001 
should look like this: 

 
\YOUR NAME CLASS 

 
2.   Press Enter. The cursor will move to line 00002. 
 
3.   Look at line 00002 on your Mill Level 4 Software Programming Sheet #1. You 

should have G70 written in the instruction. This tells the computer to use inches for 
measurement. Type “G70”, then press Enter for line 00002. 

 
4.   Using your Mill Level 4 Software Programming Sheet #1, continue entering the 

remaining lines of your program. 
 

Saving the Program 
1.   From the File menu, select Save as. The File, Save As… dialog box opens. 
 
2.   In the File name field, enter your name and PART program (project) number. You 

can abbreviate if necessary. Your name will automatically be entered in the 
Program Name field on the Program Setup screen. 

 
Notice that the Save in field shows you that the program will be saved in the M4 
directory in the Mill Level 4 program. 
 

NOTE: Whenever you save a program, it is very important 
that you pay attention to the location of the program so that 
you can access it at any time. 

 
3.   Click on the Save button. The name you assigned to your program now appears on 

the Line Editor title bar. 
 
Your program, which can be identified by your name and PART program (project) 
number, is now saved in the M4 directory with the other PART programs. 
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Compiling the Program 
1.   From the Mill pull-down menu, select Compile. 
 
When the CNC Compiler opens, the program immediately performs a line-by-line check 
of your PART program. 
 
The Status field should say “Success! No Errors Detected.” 
 
If an error is found, the Line Editor will highlight the line of code that is incorrect. You 
should then check your error against the information on your Software Programming 
Sheet and make the necessary changes. You must close the Compiler and re-open it 
each time an error is corrected. A mistake as simple as a missing space can cause an 
error. 
 
2.   If any corrections were made, select Save from the File pull-down menu. 
 
3.   When you are done, click on OK. 
 

Emulating the Program 
The word emulate means to copy, or to simulate. With the Mill Level 4 program, you can 
have the computer emulate the milling process that you programmed. 
 

NOTE: Emulation helps programmers and manufacturing 
engineers to see if the program they entered is correct. This 
saves time because they don’t have to make a test part, and 
it saves money because no materials will be wasted. 

 
1.   From the Mill pull-down menu, select Emulator. The Mill 3D Emulator opens. 
 
2.   Choose the top view (top-right button) from the View section and then click on the 
green start button in the Control section to see how your part will be machined on the 
mill. 
 
3.   Next, click on the front view (top-left button) in the view screen to see the depth of 
cut. Click on the green start button in the control section to see another view of how 
your part will be machined on the mill. 
 
4.   Click on the Close button (X) in the upper right corner of the Emulator screen to 
close the Emulator. 
 
5.   Click on the Close button (X) in the upper right corner of the Line Editor screen to 
close the Line Editor. 
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Mill Tool Setup 
1.   From the Options pull-down menu, select Tool Setup. The Mill Tool Setup screen 
appears. 
 
2.   Select Tool Number 9 by clicking on the up and down arrows next to the Tool 
Number field. ¼" End Mill appears below the Tool Number. 
 
The Bit Diameter field shows you that the bit diameter is 0.25 inch. 
 
3.   When you are done, click on the OK button. 
 
Go to the next section in the multimedia presentation. 
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Activity 2 – Loading the Program 
 
Do the following to load the PART program that you entered in ACTIVITY 1. 
 
1.   From the File pull-down menu, select Open. 
 
2.   The File, Open… dialog box appears. 
 
3.   Scroll until you find your program file. 
 
4.   Double-click on your program file. 
 
5.   The Line Editor appears with the PART program you previously entered. 
 
You are now ready to download your PART program to the CNC mill. 
 
Before you download your PART program, read the following sections, LOADING THE 
WORKPIECE and SETTING THE TOOL POSITION. 
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Loading the Workpiece 
The first step in executing the program is to load the workpiece. 
 
1.   Turn on the power switch located on the side of the mill. 
 
2.   Open the safety door. 
 
3.   Clamp a piece of 2" x 2" x .5" (5.08 cm x 5.08 cm x 1.27 cm) Plexiglas in the vise. 

Make sure it is secure and level, with one half of the Plexiglas above the top of the 
vise. Make sure the workpiece is flush with the jaws of the vise (use the machinist 
rule, or ruler, to position the workpiece correctly). 

 
It should look like this: 
 

 
 



CNC Mill  Directions 

Student Guide 29

Setting the Tool Position 
Before running your PART program, you must position the milling tool. Your point of 
reference is known as the Program Reference Zero, or PRZ. 
 
The PRZ is a reference point that enables the computer and the milling machine to 
locate the X, Y, and Z coordinates that you entered into your PART program. 
 
Quadrant I of the Cartesian Rectangular Ordinate System is used in programming to 
define the PRZ. The PRZ is the point at which the X axis and Y axis intersect. 
 
The PRZ on the workpiece is the point at which the X, Y, and Z axes intersect in the first 
quadrant. 
 
This means that you want to touch the front left corner of the workpiece with the tool. 
 
1.   Load a ¼" end mill into the spindle. (If necessary, loosen the small screw in the side 

of the spindle with an Allen wrench. After inserting the cutter, secure it by tightening 
the screw.) 

 
 

 
 
2.   Close the safety doors. 
 
3.   If locked, unlock the EMERGENCY STOP button and remove the key. 
 
4.   When you are ready to position the end mill on the front left edge of the workpiece, 

press MAIN MENU on the CNC Mill control panel. Your choices are Manual, 
Remote, and Setup. 

 
5.   Use the +Z and -Z keys of the control panel keypad to position the cursor next to 

MANUAL, then press ENTER. 
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6.   Using the +X, -X, +Z, -Z, +Y, and -Y keys of the control panel keypad, position the 
center of the ¼" end mill on the left front corner edge of the workpiece. 

 

 
 
7.   Open the safety door and cover the workpiece with a 2-inch square piece of 

notebook paper. Close the safety door. Using the +Z and -Z keys, position the end 
of the cutter onto the top of the paper-covered workpiece, adjusting it so that the 
cutter is touching the paper, but the paper can be pulled free without ripping. 
Remove the paper. 

 
8.   Press ZERO twice. This sets the PRZ for the X, Y, and Z axes to the current cutter 

position. 
 
9.   Press +Z to raise the headstock above the block. 
 
10. Press the ESC key on the control panel to return to the MAIN MENU. 
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Downloading Your Part Program 
1.   From the control panel on the CNC MILL MAIN MENU, use the -Z key to move the 

cursor next to REMOTE and press ENTER. 
 
2.   The mill’s display now reads: 
 

Ready to Download 
 

<Esc> Abort 
 
3.   From the Mill pull-down menu, select Download. The Serial Download screen 

appears. 
 
The Remote Machine field tells you that you are downloading to a 5400 Mill. 
 
The Status field tells you that you are ready to transmit and the Last Error field tells you 
that there are no errors. If an error occurs, this field displays the error message code for 
the problem. If this happens, ask your instructor for help. 
 
4.   Click on the OK button. 
 
Look at the display on the mill’s control panel and you will see “Downloading” and a 
rotating cursor indicating that your PART program is being downloaded to the mill. 
 
When the Download Complete screen is displayed on the mill, your PART program has 
been downloaded. 
 
5.   Close the Line Editor by clicking on the (X) in the upper right corner. 
 

Executing Your Program 
You should have your program loaded, the workpiece loaded, and the PRZ set. You are 
now ready to execute your PART program. Remember to always wear safety glasses 
when operating the mill. 
 
1.   Press ENTER on the mill control panel keypad. As the program executes, the 

display line will change as it moves from line to line. 
 
2.   Watch the mill closely and make sure enough of the workpiece is protruding from 

the vise and that you will not have a tool crash. After the program has finished, the 
mill will return to its home position and then stop. 

 
Go to the next section, CLEANUP. 
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Cleanup 
1.   Open the safety doors and carefully remove the workpiece. 
 
2.   Press Esc to return to the Mill menu. 
 
3.   Press the EMERGENCY STOP button. 
 
4.   Turn off the power switch located on the side of the mill. 
 
5.   Clean up your area and return everything to its proper place. You may want to use a 
shop vacuum to carefully clean out the inside of the mill. 
 
When you are finished, go to the next section in the multimedia presentation. 
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Mill Level 4 Software Programming Sheet #2 
 
Program Information 
Program Name  

Author  

Material  

Drawing No.  

Width (X)  

Depth (Y)  

Height (Z)  

 
 
Tools Used 

Tool # Description Diameter Radius 
9    
5    

 
 
PART Program 

Line # Instruction Comment 
00001   

00002   

00003   

00004   

00005   

00006   

00007   

00008   

00009   

00010   
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PART Program (continued) 
Line # Instruction Comment 
00011   

00013   

00014   

00015   

00016   

00017   

00018   

00019   

00020   

00021   

00022   

00023   

00024   

00025   

00026   

00027   

00028   

00029   

00030   

00031   

00032   

00033   

00034   

00035   

00036   

00037   

00038   
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PART Program (continued) 
Line # Instruction Comment 
00039   

00040   

00041   

00042   

00043   

00044   

00045   

00046   

00047   

00048   

00049   

00050   

00051   

00052   

00053   

00054   

00055   

00056   

00057   

00058   

00059   

00060   

00061   

00062   

00063   

00064   
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Activity 3 – You Are the Programmer 
 
For this section, refer to your completed Mill Level 4 Software Programming Sheet #2 
as you work on the computer. 
 
1.   From the File pull-down menu, select New. The Program Setup screen appears. 
 
2.   Delete <UNTITLED> from the Program Name field and leave it blank. 
 
3.   Delete Teacher from the Author field and enter your name. 
 
4.   In the Drawing ID field, the default, Project #1, should appear in the project field. If 

this is incorrect, highlight the text and enter a project number. 
 
5.   In the Material section of the screen, select Plastic. If you are using wax, select 

Wax. 
 
6.   In the Editor portion of the screen, make sure Line Mode is selected. 
 
7.   In the Units portion of the screen, make sure Inch is selected. 
 
8.   In the Coordinates section, make sure Absolute is selected. 
 
9.   Enter the appropriate values in the X, Y, and Z fields. (X=2) (Y=2) (Z=0.5). 
 
10. Click on the OK button. The Line Editor appears. 
 
Complete the next section, ENTERING THE PART PROGRAM. 
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Entering the Program 
Notice that the Line Editor is numbered, starting with 00001; this is your first line of 
code. You will use the line numbers on your Mill Level 4 Software Programming 
Sheet #2 as a reference. 
 
You will be inserting your program in front of the alphabet subroutines. The subroutines 
must be listed after the final M30 code of the base program. Instructions for doing this 
are provided in the section titled ALPHA PROGRAM. 
 
1.   For the first line of instruction, begin by typing a backslash, “\”, followed by your 

name and class. The backslash tells the computer to ignore any information 
following it. You use this for information purposes only. If you did not type the 
backslash, the computer would not recognize or accept the information. Line 00001 
should look like this: 

 
\YOUR NAME CLASS 

 
2.   Press Enter. The cursor will move to line 00002. 

 
3.   Using your Mill Level 4 Software Programming Sheet #2, continue entering the 

remaining lines of your program. 
 

Saving the Program 
1.   From the File menu, select Save as. The File, Save As… dialog box opens. 
 
2.   In the File name field, enter your name and PART program (project) number. You 

can abbreviate if necessary. Your name will automatically be entered in the 
Program Name field on the Program Setup screen. 

 
Notice that the Save in field shows you that the program will be saved in the M4 
directory in the Mill Level 4 program. 
 

NOTE: Whenever you save a program, it is very important 
that you pay attention to the location of the program so that 
you can access it at any time. 

 
3.   Click on the Save button. The name you assigned to your program now appears on 

the Line Editor title bar. 
 
Your program, which can be identified by your name and PART program (project) 
number, is now saved in the M4 directory with the other PART programs. 
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Alpha Program 
The Alpha program contains the text creation subroutines, which will be called upon by 
the M97 commands you entered in your PART program. Follow the steps below to copy 
the Alpha program to the Line Editor. 
 
1.   Close the Line Editor. 
 
2.   From the File pull-down menu, select Open. The File, Open… screen appears. 
 
3.   Double-click on the Alpha program. 
 
4.   From the Edit pull-down menu, select Select All. From the Edit pull-down menu, 

select Copy. 
 
5.   Close the Line Editor (Alpha program). 
 
6.   From the File pull-down menu, select Open. 
 
7.   The File, Open… dialog box appears. 
 
8.   Scroll until you find your program file that you have just entered. 
 
9.   Double-click on your program file. The Line Editor appears with the PART program 

you previously entered. 
 
10. Scroll down to the end of the program. Click on the next available line. 
 
11. From the Edit pull-down menu, select Paste. 
 
12. From the File pull-down menu, select Save. 
 
The Alpha program can now be called upon when text is needed. 
 
13. Compile the program. If necessary, refer to COMPILING THE PROGRAM in the 

ACTIVITY 1 section. 
 
14. Emulate the program. If necessary, refer to EMULATING THE PROGRAM in the 

ACTIVITY 1 section. 
 
15. Select the proper end mill. If necessary, refer to MILL TOOL SETUP in the 

ACTIVITY 1 section. 
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16. Load the workpiece. If necessary, refer to LOADING THE WORKPIECE in the 
ACTIVITY 2 section. 

 
17. Set the tool position. If necessary, refer to SETTING THE TOOL POSITION in the 

ACTIVITY 2 section. 
 
18. Download the program. If necessary, refer to DOWNLOADING YOUR PROGRAM 

in the ACTIVITY 2 section. 
 
19. Execute your program. If necessary, refer to EXECUTING YOUR PROGRAM in the 

ACTIVITY 2 section. 
 

How to Make a Tool Change 
At line 00044, you will have to make a tool change. When the mill has completed 
machining with the current tool, the mill will move the tool to the programmed tool 
change position. The mill control panel will say Tool Change. Fit Tool 5 then press 
<Enter>. 
 
1.   Open the safety doors. 
 
2.   Remove the holder with the ¼" end mill using the holder bars to loosen the holder 

from the spindle, and install the holder with the 1/16" end mill. 
 
3.   Insert one holder bar into the hole in the holder and the other collet bar into the hole 

in the spindle above the holder. 
 
4.   Holding the spindle and still using the top holder bar, twist the bar in the collet 

clockwise until the holder is loose. 
 
5.   Remove the holder with the 1/4" end mill. 
 
6.   Install the holder with the 1/16" end mill. 
 
7.   When the holder is completely on, use the holder bars to snug the holder onto the 

spindle. DO NOT OVERTIGHTEN! 
 
8.   Close the safety doors. 
 
9.   Press the ENTER key on the mill control panel to tell the mill that the tool has been 

changed. 
 
10. On line 00057, you will have to make another tool change. Following the above 

steps, remove the holder with the 1/16" end mill and install the holder with the ¼" 
end mill. 
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Completing the Program 
1.   After the program has finished, open the safety door and carefully remove the 

workpiece. 
 
2.   Press Esc to return to the Mill menu. 
 
3.   Press the EMERGENCY STOP button. 
 
4.   Turn off the power switch located on the left side of the mill. 
 
5.   Clean up your area and return everything to its proper place. 
 
When you are finished, go to the next section in the multimedia presentation. 
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Activity 4 
 
Before completing this activity, check with your instructor to see if you should download 
this PART program from a master floppy disk or enter it manually. 
 
Complete the next section, YOU ARE THE PROGRAMMER. 
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You Are the Programmer 
1.   Click on the File menu and select New. The Program Setup screen appears. 
 
2.   Delete <UNTITLED> from the Program Name field and leave it blank. 
 
3.   Delete Teacher from the Author field and enter your name. 
 
4.   In the Drawing No. field, the default, Project #1, should appear. If this is incorrect, 

highlight the text and enter a project number. 
 
5.   In the Material section of the screen, select Wax. If you are using plastic, select 

Plastic. 
 
6.   In the Editor portion of the screen, make sure Line Mode is selected. 
 
7.   In the Units portion of the screen, make sure Inch is selected. 
 
8.   In the Coordinates section, make sure Absolute is selected. 
 
9.   Enter the appropriate values in the X, Y, and Z fields. (X=6) (Y=3) (Z=0.5). 
 
10. Click on the OK button. The Line Editor appears. 
 
Complete the next section, ENTERING THE PROGRAM. 
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Entering the Part Program 
1.   Click anywhere in the Line Editor. A cursor appears next to Line 00001. On this 

line, enter a backslash (\), then your name. 
 
2.   Use the Enter key to go to the next line. 
 
3.   Enter the following program, starting on Line 00002. Make sure that you and your 

partner use spaces where indicated. 
 
 

NOTE: It is a good idea to save the program periodically 
since it is so large. To initially save your program, refer to 
SAVING THE PROGRAM in the ACTIVITY 3 section. Once 
you have done this, at random intervals, select Save from 
the File pull-down menu. Save again when the entire 
program has been entered. 

 
 

Double-check your work when you are done. 
 

00001 \your name 
00002 \class 
00003 G70 
00004 M06 9 
00005 M04 2800 
00006 G94 6 
00007 G00 
00008 X2.35 Y1.125 G00 
00009 G01 
00010 Z.1 
00011 Z-.1 
00012 X.35 
00013 G00 
00014 Z-.2 
00015 X2.35 
00016 Z-.25 
00017 X.5 
00018 Z.1 G00 
00019 X2.35 Y1.875 G00 
00020 G01 
00021 Z-.1 
00022 X.35 
00023 Z-.2 
00024 X2.35 
00025 Z-.25 
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00026 X.35 
00027 G00 
00028 Z.1 G00 
00029 X1.725 Y.5 G00 
00030 G01 
00031 Z-.1 
00032 Y2.5 
00033 Z-.2 
00034 Y.5 
00035 Z-.25 
00036 G00 
00037 Z.1 G00 
00038 X0.975 Y.5 G00 
00039 G01 
00040 Z-.1 
00041 Y2.5 
00042 Z-.2 
00043 Y.5 
00044 Z-.25 
00045 Y2.5 
00046 G00 
00047 Z.1 G00 
00048 X3.25 Y.75 G00 
00049 G01 
00050 Z-.1 
00051 X2.75 
00052 G01 
00053 Y2.25 
00054 X4 
00055 X3.25 Y.75 
00056 Z-.2 
00057 X2.75 
00058 Y2.25 
00059 X4 
00060 X3.25 Y.75 
00061 Z-.25 
00062 X2.75 
00063 Y2.25 
00064 X4 
00065 X3.25 Y.75 
00066 G00 
00067 Z.1 G00 
00068 X2.977 Y.909 G00 
00069 G01 
00070 Z.15 
00071 X2.813 Y.813 Z-.1 
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00072 X3.211 
00073 X3.261 Y.911 
00074 X2.813 
00075 Y1.009 
00076 X3.31 
00077 X3.359 Y1.107 
00078 X2.813 
00079 Y1.205 
00080 X3.408 
00081 X3.457 Y1.304 
00082 X2.813 
00083 Y1.402 
00084 X3.506 
00085 X3.555 Y1.5 
00086 X2.813 
00087 Y1.598 
00088 X3.604 
00089 X3.653 Y1.696 
00090 X2.813 
00091 Y1.795 
00092 X3.702 
00093 X3.752 Y1.893 
00094 X2.813 
00095 Y1.991 
00096 X3.801 
00097 X3.85 Y2.089 
00098 X2.813 
00099 Y2.187 
00100 X3.899 
00101 G00 
00102 Z.1 G00 
00103 X2.977 Y.909 G00 
00104 G01 
00105 Z.05 
00106 X2.813 Y.813 Z-.2 
00107 X3.211 
00108 X3.261 Y.911 
00109 X2.813 
00110 Y1.009 
00111 X3.31 
00112 X3.359 Y1.107 
00113 X2.813 
00114 Y1.205 
00115 X3.408 
00116 X3.457 Y1.304 
00117 X2.813 
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00118 Y1.402 
00119 X3.506 
00120 X3.555 Y1.5 
00121 X2.813 
00122 Y1.598 
00123 X3.604 
00124 X3.653 Y1.696 
00125 X2.814 
00126 Y1.795 
00127 X3.702 
00128 X3.752 Y1.893 
00129 X2.813 
00130 Y1.991 
00131 X3.801 
00132 X3.85 Y2.089 
00133 X2.813 
00134 Y2.187 
00135 X3.899 
00136 G00 
00137 Z.1 G00 
00138 X2.977 Y.909 G00 
00139 G01 
00140 Z0 
00141 X2.813 Y.813 Z-.25 
00142 X3.211 
00143 X3.261 Y.911 
00144 X2.813 
00145 Y1.009 
00146 X3.31 
00147 X3.359 Y1.107 
00148 X2.813 
00149 Y1.205 
00150 X3.408 
00151 X3.457 Y1.304 
00152 X2.813 
00153 Y1.402 
00154 X3.506 
00155 X3.555 Y1.5 
00156 X2.813 
00157 Y1.598 
00158 X3.604 
00159 X3.543 Y1.696 
00160 X2.813 
00161 Y1.795 
00162 X3.702 
00163 X3.752 Y1.893 
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00164 X2.813 
00165 Y1.991 
00166 X3.801 
00167 X3.85 Y2.089 
00168 X2.813 
00169 Y2.187 
00170 X3.899 
00171 G00 
00172 Z.1 G00 
00173 X.833 Y.833 Z.1 G00 
00174 G81 
00175 X.6 Y.75 Z-.25 G00 
00176 X1.35 Z-.25 G00 
00177 X2.1 Z-.25 G00 
00178 Y1.5 Z-.25 G00 
00179 X1.35 Z-.25 G00 
00180 X.6 Z-.25 G00 
00181 Y2.25 Z-.25 G00 
00182 X1.35 Z-.25 G00 
00183 X2.1 Z-.25 G00 
00184 X4.5 Y2.5 Z-.25 G00 
00185 X4.25 Y2 Z-.25 
00186 X4.75 Z-.25 G00 
00187 X4 Y1.5 Z-.25 G00 
00188 X4.5 Z-.25 G00 
00189 X5 Z-.25 G00 
00190 X3.75 Y1 Z-.25 G00 
00191 X4.25 Z-.25 G00 
00192 X4.75 Z-.25 G00 
00193 X5.25 Z-.25 G00 
00194 X3.5 Y.5 Z-.25 G00 
00195 X4 Z-.25 G00 
00196 X4.5 Z-.25 G00 
00197 X5 Z-.25 G00 
00198 X5.5 Z-.25 G00 
00199 G80 
00200 G01 
00201 Z1 G00 
00202 X0 Y0 G00 
00203 M04 0 
00204 M30 

 
Congratulations! You made it! If you didn’t save when you finished, do it now. 
 
4.   Compile the program. If necessary, refer to COMPILING THE PROGRAM in the 

ACTIVITY 1 section. 
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5.   Emulate the program. If necessary, refer to EMULATING THE PROGRAM in the 

ACTIVITY 1 section. 
 
6.   Close the Line Editor. 
 
7.   Return the floppy disk to your instructor if one was provided. 
 
Go to the next section in the multimedia presentation. 
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Activity 5 
 
1.   Load the program. If necessary, refer to LOADING THE PROGRAM in ACTIVITY 2. 
 
2.   In order to load the 6" x 3" x 0.5" (15.24 cm x 7.62 cm x 1.27 cm) workpiece onto the 

bed of the 5400 CNC Mill, you must first remove the 2" x 2" (5.08 cm x 5.08 cm) 
vise. To do this, use your Allen key to loosen the L-shaped hold-down brackets. 
Once loose, remove the vise from the mill. 

 
3.   Next, place the 6" x 3" x 0.5" workpiece on the bed, carefully aligning the front edge 

so that it is parallel with the front edge of the bed surface. 
 
4.   Place one L-shaped bracket on the left side of the workpiece in the rear T-slot on 

the bed, and place the second bracket on the right side in the front T-slot. Tighten 
the brackets with the Allen key so that the workpiece is firmly held in place on the 
bed. 

 
5.   Set the tool position. If necessary, refer to SETTING THE TOOL POSITION in 

ACTIVITY 2. 
 
6.   Download the program. If necessary, refer to DOWNLOADING YOUR PROGRAM 

in ACTIVITY 2. 
 
7.   Execute the program. If necessary, refer to EXECUTING YOUR PROGRAM in 

ACTIVITY 2. 
 
8.   Clean up. If necessary, refer to CLEANUP in ACTIVITY 2. 
 
When you are finished, go to the next section in the multimedia presentation. 
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Saving to a Floppy Disk 
When all lesson activities have been completed, your PART programs should be saved 
to a floppy disk and then removed from the M4 directory. Your PART programs can be 
downloaded to Mill Level 4 at any time in the future if necessary. Follow the steps 
below. 
 
1.   Get a blank floppy disk from your instructor and label it with the names you assigned 

to the programs when they were initially created. Be sure to include your name. 
 
2.   Place the floppy disk in your computer floppy disk drive. 
 
3.   From the File pull-down menu, select Open. The File, Open window appears and 

shows all the PART programs stored in the M4 directory. 
 
4.   Right-click on one of your program files. A pop-up menu appears. Select Send To 

and then click 3½ Floppy (A). Your computer will now download a copy of the 
program file to your floppy disk. 

 
 
 
 
 
 
 
 
 
5.   After the PART program has successfully copied to your floppy disk, right-click 

again on the program file. From the pop-up menu, click Delete. A Confirm File 
Delete dialog box appears. Click Yes. Your PART program is now permanently 
deleted from the directory. 

 
6.   Repeat these steps for each program file you have stored in the M4 directory. 
 
7.   When you are done, remove the floppy disk. 
 
Go to the next section in the multimedia presentation. 
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COMPREHENSIVE LEVEL  
 
Mill Level 4 Software Programming Sheet #1 
 
Program Information 
Program Name  

Author  

Material  

Drawing No.  

Width (X)  

Depth (Y)  

Height (Z)  

 
 
PART Program 

Line # Instruction Comment 
00001   

00002   

00003   

00004   

00005   

00006   

00007   

00008   

00009   

00010   

00011   

00012   

00013   
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Activity 1 – You Are the Programmer 
 
For this section, refer to your completed Mill Level 4 Software Programming Sheet #1 
as you work on the computer. 
 
1.   From the File pull-down menu, select New. The Program Setup screen appears. 
 
2.   Delete <UNTITLED> from the Program Name field and leave it blank. 
 
3.   Delete Teacher from the Author field and enter your name. 
 
4.   In the Drawing ID field, the default, Project #1, should appear in the project field. If 
this is incorrect, highlight the text and enter a project number. 
 
5.   In the Material section of the screen, select Plastic. If you are using wax, select 
Wax. 
 
6.   In the Editor portion of the screen, make sure Line Mode is selected. 
 
7.   In the Units portion of the screen, make sure Inch is selected. 
 
8.   In the Coordinates section, make sure Absolute is selected. 
 
9.   Enter the appropriate values in the X, Y, and Z fields. (X=2) (Y=2) (Z=0.5). 
 
10. Click on the OK button. The Line Editor appears. 
 
Complete the next section, ENTERING THE PART PROGRAM. 
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Entering the Program 
Notice that the Line Editor is numbered, starting with 00001; this is your first line of 
code. You will use the line numbers on your Mill Level 4 Software Programming 
Sheet #1 as a reference. 
 
1.   For the first line of instruction, begin by typing a backslash, “\”, followed by your 

name and class. The backslash tells the computer to ignore any information 
following it. You use this for information purposes only. If you did not type the 
backslash, the computer would not recognize or accept the information. Line 00001 
should look like this: 

 
\YOUR NAME CLASS 

 
2.   Press Enter. The cursor will move to line 00002. 
 
3.   Look at line 00002 on your Mill Level 4 Software Programming Sheet #1. You 

should have G70 written in the instruction. This tells the computer to use inches for 
measurement. Type “G70”, then press Enter for line 00002. 

 
4.   Using your Mill Level 4 Software Programming Sheet #1, continue entering the 

remaining lines of your program. 
 
5.   On line 00003, you will turn on the spindle motor with the M04 code and set the 

spindle speed to 2800 RPM. Type “M04 2800”, then press Enter. 
 
6.   On line 00004, you will set the feed rate at 4 inches per minute. Type “M07 4”, then 

press Enter. 
 
7.   Now enter your first tool movement code on line 00005. If you are moving in a 

straight line from one point to another, you use the Linear Interpolation command, 
which is G01. Type “G01”, then press Enter. 

 
8.   Using your Mill Level 4 Software Programming Sheet #1, continue entering the 

remaining lines of your program. 
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Saving the Program 
1.   From the File menu, select Save as. The File, Save As… dialog box opens. 
 
2.   In the File name field, enter your name and PART program (project) number. You 

can abbreviate if necessary. Your name will automatically be entered in the 
Program Name field on the Program Setup screen. 

 
Notice that the Save in field shows you that the program will be saved in the M4 
directory in the Mill Level 4 program. 
 
 

NOTE: Whenever you save a program, it is very important 
that you pay attention to the location of the program so that 
you can access it at any time. 

 
 
3.   Click on the Save button. The name you assigned to your program now appears on 

the Line Editor title bar. 
 
Your program, which can be identified by your name and PART program (project) 
number, is now saved in the M4 directory with the other PART programs. 
 

Compiling the Program 
1.   From the Mill pull-down menu, select Compile. 
 
When the CNC Compiler opens, the program immediately performs a line-by-line check 
of your PART program. 
 
The Status field should say “Success! No Errors Detected.” 
 
If an error is found, the Line Editor will highlight the line of code that is incorrect. You 
should then check your error against the information on your Software Programming 
Sheet and make the necessary changes. You must close the Compiler and re-open it 
each time an error is corrected. A mistake as simple as a missing space can cause an 
error. 
 
2.   If any corrections were made, select Save from the File pull-down menu. 
 
3.   When you are done, click on OK. 
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Emulating the Program 
The word emulate means to copy, or to simulate. With the Mill Level 4 program, you can 
have the computer emulate the milling process that you programmed. 
 
 

NOTE: Emulation helps programmers and manufacturing 
engineers to see if the program they entered is correct. This 
saves time because they don’t have to make a test part, and 
it saves money because no materials will be wasted. 

 
 
1.   From the Mill pull-down menu, select Emulator. The Mill 3D Emulator opens. 
 
2.   Choose the top view (top-right button) from the View section and then click on the 

green start button in the Control section to see how your part will be machined on 
the mill. 

 
3.   Next click on the front view (top-left button) in the view screen to see the depth of 

cut. Click on the green start button in the control section to see another view of how 
your part will be machined on the mill. 

 
4.   Click on the Close button (X) in the upper right corner of the Emulator screen to 

close the Emulator. 
 
5.   Click on the Close button (X) in the upper right corner of the Line Editor screen to 

close the Line Editor. 
 

Mill Tool Setup 
1.   From the Options pull-down menu, select Tool Setup. The Mill Tool Setup screen 

appears. 
 
2.   Select Tool Number 9 by clicking on the up and down arrows next to the Tool 

Number field. ¼" End Mill appears below the Tool Number. The Bit Diameter field 
shows you that the bit diameter is 0.25 inch. 

 
3.   When you are done, click on the OK button. 

 
Go to the next section in the multimedia presentation. 
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Mill Level 4 Software Programming Sheet #2 
 
Program Information 
Program Name  

Author  

Material  

Drawing No.  

Width (X)  

Depth (Y)  

Height (Z)  
 
 
Tools Used 

Tool # Description Diameter Radius 
9    

 
 
PART Program 

Line # Instruction Comment 
00001   

00002   

00003   

00004   

00005   

00006   

00007   

00008   

00009   

00010   

00011   
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PART Program (continued) 
Line # Instruction Comment 
00012   

00013   

00014   

00015   

00016   

00017   

00018   

00019   

00020   

00021   

00022   

00023   

00024   

00025   

00026   

00027   

00028   

00029   
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Activity 2 – You Are the Programmer 
 
For this section, refer to your completed Mill Level 4 Software Programming Sheet #2 
as you work on the computer. 
 
1.   From the File pull-down menu, select New. The Program Setup screen appears. 
 
2.   Delete <UNTITLED> from the Program Name field and leave it blank. 
 
3.   Delete Teacher from the Author field and enter your name. 
 
4.   In the Drawing ID field, the default, Project #1, should appear in the project field. If 

this is incorrect, highlight the text and enter a project number. 
 
5.   In the Material section of the screen, select Plastic. If you are using wax, select 

Wax. 
 
6.   In the Editor portion of the screen, make sure Line Mode is selected. 
 
7.   In the Units portion of the screen, make sure Inch is selected. 
 
8.   In the Coordinates section, make sure Absolute is selected. 
 
9.   Enter the appropriate values in the X, Y, and Z fields. (X=2) (Y=2) (Z=0.5). 
 
10. Click on the OK button. The Line Editor appears. 
 
Complete the next section, ENTERING THE PART PROGRAM. 
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Entering the Part Program 
Notice that the Line Editor is numbered, starting with 00001; this is your first line of 
code. You will use the line numbers on your Mill Level 4 Software Programming 
Sheet #1 as a reference. 
 
1.   For the first line of instruction, begin by typing a backslash, “\”, followed by your 

name and class. The backslash tells the computer to ignore any information 
following it. You use this for information purposes only. If you did not type the 
backslash, the computer would not recognize or accept the information. Line 00001 
should look like this: 

 
\YOUR NAME CLASS 

 
2.   Press Enter. The cursor will move to line 00002. 
 
3.   Look at line 00002 on your Mill Level 4 Software Programming Sheet #2. You 

should have G70 written in the instruction. This tells the computer to use inches for 
measurement. Type “G70”, then press Enter for line 00002. 

 
4.   On line 00003, you will turn on the spindle motor with the M04 code and set the 

spindle speed to 2800 RPM. Type “M04 2800” then press Enter. 
 
Using your Mill Level 4 Software Programming Sheet #2, continue entering the 
remaining lines of your program. 
 

Saving the Program 
1.   From the File menu, select Save as. The File, Save As… dialog box opens. 
 
2.   In the File name field, enter your name and PART program (project) number. You 

can abbreviate if necessary. Your name will automatically be entered in the 
Program Name field on the Program Setup screen. 

 
Notice that the Save in field shows you that the program will be saved in the M4 
directory in the Mill Level 4 program. 
 

NOTE: Whenever you save a program, it is very important 
that you pay attention to the location of the program so that 
you can access it at any time. 

 
3.   Click on the Save button. The name you assigned to your program now appears on 

the Line Editor title bar. 
 
Your program, which can be identified by your name and PART program (project) 
number, is now saved in the M4 directory with the other PART programs. 
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Compiling the Program 
1.   From the Mill pull-down menu, select Compile. 
 
When the CNC Compiler opens, the program immediately performs a line-by-line check 
of your PART program. The Status field should say “Success! No Errors Detected.” 
 
2.   If an error is found, the Line Editor will highlight the line of code that is incorrect. You 

should then check your error against the information on your Software 
Programming Sheet and make the necessary changes. You must close the 
Compiler and re-open it each time an error is corrected. A mistake as simple as a 
missing space can cause an error. 

 
3.   If any corrections were made, select Save from the File pull-down menu. 
 
4.   When you are done, click on OK. 
 

Emulating the Program 
The word emulate means to copy, or to simulate. With the Mill Level 4 program, you can 
have the computer emulate the milling process that you programmed. 
 

NOTE: Emulation helps programmers and manufacturing 
engineers to see if the program they entered is correct. This 
saves time because they don’t have to make a test part, and 
it saves money because no materials will be wasted. 

 
1.   From the Mill pull-down menu, select Emulator. The Mill 3D Emulator opens. 
 
2.   Choose the top view (top-right button) from the View section and then click on the 

green start button in the Control section to see how your part will be machined on 
the mill. 

 
3.   Next, click on the front view (top-left button) in the view screen to see the depth of 

cut. Click on the green start button in the control section to see another view of how 
your part will be machined on the mill. 

 
4.   Click on the Close button (X) in the upper right corner of the Emulator screen to 

close the Emulator. 
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Mill Tool Setup 
1.   From the Options pull-down menu, select Tool Setup. The Mill Tool Setup screen 

appears. 
 
2.   Select Tool Number 9 by clicking on the up and down arrows next to the Tool 

Number field. ¼" End Mill appears below the Tool Number. 
 
The Bit Diameter field shows you that the bit diameter is 0.25 inch. 
 
3.   When you are done, click on the OK button. 
 
4.   From the File pull-down menu, select Save. 
 
Go to the next section in the multimedia presentation. 
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Activity 3 – Loading the Program 
 
Do the following to load the PART program that you entered in ACTIVITY 2. 
 
1.   From the File pull-down menu, select Open. 
 
2.   The File, Open… dialog box appears. 
 
3.   Scroll until you find your program file. 
 
4.   Double-click on your program file. The Line Editor appears with the PART program 

you previously entered. 
 
You are now ready to download your PART program to the CNC mill. 
 
Before you download your PART program, read the following sections, LOADING THE 
WORKPIECE and SETTING THE TOOL POSITION. 
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Loading the Workpiece 
The first step in executing the program is to load the workpiece. 
 
1.   Turn on the power switch located on the side of the mill. 
 
2.   Open the safety door. 
 
3.   Clamp a piece of 2" x 2" x .5" Plexiglas in the vise. Make sure it is secure and level, 

with one half of the Plexiglas above the top of the vise. Make sure the workpiece is 
flush with the jaws of the vise (use the machinist rule, or ruler, to position the 
workpiece correctly). 

 
It should look like this: 
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Setting the Tool Position 
Before running your PART program, you must position the milling tool. Your point of 
reference is known as the Program Reference Zero, or PRZ. 
 
The PRZ is a reference point that enables the computer and the milling machine to 
locate the X, Y, and Z coordinates that you entered into your PART program. 
 
Quadrant I of the Cartesian Rectangular Ordinate System is used in programming to 
define the PRZ. The PRZ is the point at which the X axis and Y axis intersect. 
 
The PRZ on the workpiece is the point at which the X, Y, and Z axes intersect in the first 
quadrant. 
 
This means that you want to touch the front left corner of the workpiece with the tool. 
 
1.   Load a ¼" end mill into the spindle. (If necessary, loosen the small screw in the side 

of the spindle with an Allen wrench. After inserting the cutter, secure it by tightening 
the screw.) 

 

 
 
2.   Close the safety doors. 
 
3.   If locked, unlock the EMERGENCY STOP button and remove the key. 
 
4.   When you are ready to position the end mill on the left front edge of the workpiece, 

press MAIN MENU on the CNC Mill control panel. Your choices are Manual, 
Remote, and Setup. 

 
5.   Use the +Z and -Z keys of the control panel keypad to position the cursor next to 

MANUAL, then press ENTER. 
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6.   Using the +X, -X, +Z, -Z, +Y, and -Y keys of the control panel keypad, position the 
center of the ¼" end mill on the left front edge of the workpiece. 

 

 
 
7.   Open the safety door and cover the workpiece with a 2-inch square piece of 

notebook paper. Close the safety door. Using the +Z and -Z keys, position the end 
of the cutter onto the top of the paper-covered workpiece, adjusting it so that the 
cutter is touching the paper, but the paper can be pulled free without ripping. 
Remove the paper. 

 
8.   Press Zero twice. This sets the PRZ for the X, Y, and Z-axes to the current cutter 

position. 
 
9.   Press +Z to raise the headstock above the block. 
 
10. Press the ESC key on the control panel to return to the MAIN MENU. 
 



CNC Mill  Directions 
 

68  Student Guide 

Saving the Program 
1.   From the File menu, select Save as. The File, Save As… dialog box opens. 
 
2.   In the File name field, enter your name and PART program (project) number. You 

can abbreviate if necessary. Your name will automatically be entered in the 
Program Name field on the Program Setup screen. 

 
Notice that the Save in field shows you that the program will be saved in the M4 
directory in the Mill Level 4 program. 
 
 

NOTE: Whenever you save a program, it is very important 
that you pay attention to the location of the program so that 
you can access it at any time. 

 
 
3.   Click on the Save button. The name you assigned to your program now appears on 

the Line Editor title bar. 
 
Your program, which can be identified by your name and PART program (project) 
number, is now saved in the M4 directory with the other PART programs. 
 
After you have completed downloading your PART program to the mill and you have 
machined the part, you will learn how to save your program to a floppy disk and then 
remove it from the CONTROL program. 
 



CNC Mill  Directions 

Student Guide 69

Downloading Your Program 
1.   From the control panel on the CNC Mill MAIN MENU, use the -Z key to move the 

cursor next to REMOTE and press ENTER. 
 
2.   The mill’s display now reads: 
 

Ready to Download 
 

<Esc> Abort 
 
3.   From the Mill pull-down menu, select Download. The Serial Download screen 

appears. The Remote Machine field tells you that you are downloading to a 5400 
Mill. The Status field tells you that you are ready to transmit and the Last Error field 
tells you that there are no errors. If an error occurs, this field displays the error 
message code for the problem. If this happens, ask your instructor for help. 

 
4.   Click on the OK button. 
 
Look at the display on the mill’s control panel and you will see “Downloading” and a 
rotating cursor indicating that your PART program is being downloaded to the mill. 
 
When the Download Complete screen is displayed on the mill, your PART program has 
been downloaded. 
 

Executing Your Program 
You should have your program loaded, the workpiece loaded, and the PRZ set. You are 
now ready to execute your PART program. Remember to always wear safety glasses 
when operating the mill. 
 
1.   Press ENTER on the mill control panel keypad. As the program executes, the 

display line will change as it moves from line to line. 
 
2.   Watch the mill closely and make sure that enough of the workpiece is protruding 

from the vise and that you will not have a tool crash. After the program has finished, 
the mill will return to its home position and then stop. 

 
3.   At your computer, close the Line Editor by clicking on the (X) in the upper right 

corner. 
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Cleanup 
1.   Open the safety door and carefully remove the workpiece. 
 
2.   Press Esc to return to the Mill menu. 
 
3.   Press the EMERGENCY STOP button. 
 
4.   Turn off the power switch located on the side of the mill. 
 
5.   Clean up your area and return everything to its proper place. You may want to use a 

shop vacuum to carefully clean out the inside of the mill. 
 
When you are finished, go to the next section in the multimedia presentation. 
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Mill Level 4 Software Programming Sheet #3 
 
Program Information 
Program Name  

Author  

Material  

Drawing No.  

Width (X)  

Depth (Y)  

Height (Z)  

 
 
Tools Used 

Tool # Description Diameter Radius 
9    
5    

 
 
PART Program 

Line # Instruction Comment 
00001   

00002   

00003   

00004   

00005   

00006   

00007   

00008   

00009   

00010   
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PART Program (continued) 
Line # Instruction Comment 
00011   

00012   

00013   

00014   

00015   

00016   

00017   

00018   

00019   

00020   

00021   

00022   

00023   

00024   

00025   

00026   

00027   

00028   

00029   

00030   

00031   

00032   

00033   

00034   

00035   

00036   

00037   
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PART Program (continued) 
Line # Instruction Comment 
00038   

00039   

00040   

00041   

00042   

00043   

00044   

00045   

00046   

00047   

00048   

00049   

00050   

00051   

00052   

00053   

00054   

00055   

00056   

00057   

00058   

00059   

00060   

00061   

00062   

00063   

00064   
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Activity 4 – Entering the Part Program 
 
For this section, refer to your completed Mill Level 4 Software Programming Sheet #3 
as you work on the computer. 
 
1.   From the File pull-down menu, select New. The Program Setup screen appears. 
 
2.   Delete <UNTITLED> from the Program Name field and leave it blank. 
 
3.   Delete Teacher from the Author field and enter your name. 
 
4.   In the Drawing ID field, the default, Project #1, should appear in the project field. If 

this is incorrect, highlight the text and enter a project number. 
 
5.   In the Material section of the screen, select Plastic. If you are using wax, select 

Wax. 
 
6.   In the Editor portion of the screen, make sure Line Mode is selected. 
 
7.   In the Units portion of the screen, make sure Inch is selected. 
 
8.   In the Coordinates section, make sure Absolute is selected. 
 
9.   Enter the appropriate values in the X, Y, and Z fields. (X=2) (Y=2) (Z=0.5). 
 
10. Click on the OK button. The Line Editor appears. 
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Entering the Program 
Notice that the Line Editor is numbered, starting with 00001; this is your first line of 
code. You will use the line numbers on your Mill Level 4 Software Programming 
Sheet #3 as a reference. 
 
You will be inserting your program in front of the alphabet subroutines. The subroutines 
must be listed after the final M30 code of the base program. Instructions for doing this 
are provided in the section titled ALPHA PROGRAM. 
 
1.   For the first line of instruction, begin by typing a backslash, “\”, followed by your 
name and class. The backslash tells the computer to ignore any information following it. 
You use this for information purposes only. If you did not type the backslash, the 
computer would not recognize or accept the information. Line 00001 should look like 
this: 
 

\YOUR NAME CLASS 
 

2.   Press Enter. The cursor will move to line 00002. 
 

3.   Using your Mill Level 4 Software Programming Sheet #3, continue entering the 
remaining lines of your program. 

 
4.   Save the program. If necessary, refer to SAVING THE PROGRAM in ACTIVITY 2. 
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Alpha Program 
The Alpha program contains the text creation subroutines, which will be called upon by 
the M97 commands you entered in your PART program. Follow the steps below to copy 
the Alpha program to the Line Editor. 
 
1.   Close the Line Editor. 

 
2.   From the File pull-down menu, select Open. The File, Open… screen appears. 

 
3.   Double-click on the Alpha program. 

 
4.   From the Edit pull-down menu, choose Select All. From the Edit pull-down menu, 

select Copy. 
 

5.   Close the Line Editor (Alpha program). 
 

6.   From the File pull-down menu, select Open. The File, Open… dialog box appears. 
 

7.   Scroll until you find your program file that you entered in Lesson 7. 
 

8.   Double-click on your program file. The Line Editor appears with the PART program 
you previously entered. 

 
9.   Scroll down to the end of the program. Click on the next available line. 
 
10. From the Edit pull-down menu, select Paste. 
 
11. From the File pull-down menu, select Save. 
 
12. The Alpha program can now be called upon when text is needed. 
 
13. Compile the program. If necessary, refer to COMPILING THE PROGRAM in 

ACTIVITY 1. 
 
14. Emulate the program. If necessary, refer to EMULATING THE PROGRAM in 

ACTIVITY 1. 
 
15. Select the proper end mill. If necessary, refer to MILL TOOL SETUP in the 

ACTIVITY 1. 
 
16. Load the workpiece. If necessary, refer to LOADING THE WORKPIECE in the 

ACTIVITY 3 section. 
 
17. Set the tool position. If necessary, refer to SETTING THE TOOL POSITION in the 

ACTIVITY 3 section. 
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18. Download the program. If necessary, refer to DOWNLOADING YOUR PROGRAM 

in the ACTIVITY 3 section. 
 
19. Execute the program. If necessary, refer to EXECUTING YOUR PROGRAM in 

ACTIVITY 3 section. 
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How to Make a Tool Change 
At line 0044, you will have to make a tool change. When the mill has completed 
machining with the current tool, the mill will move the tool to the programmed tool 
change position. The mill control panel will say Tool Change. Fit Tool 2 then press 
<Enter>. 
 
1.   Open the safety doors. 
 
2.   Remove the holder with the ¼" end mill using the holder bars to loosen the holder 

from the spindle, and install the holder with the 1/16" end mill. 
 
3.   Insert one holder bar into the hole in the holder and the other collet bar into the hole 

in the spindle above the holder. 
 
4.   Holding the spindle and still using the top holder bar, twist the bar in the collet 

clockwise until the holder is loose. 
 
5.   Remove the holder with the ¼" end mill. 
 
6.   Install the holder with the 1/16" end mill. 
 
7.   When the holder is completely on, use the holder bars to snug the holder onto the 

spindle. DO NOT OVERTIGHTEN! 
 
8.   Close the safety doors. 
 
9.   Press the ENTER key on the mill control panel to tell the mill that the tool has been 

changed. 
 
10. On line 0057, you will have to make another tool change. Following the above steps, 

remove the holder with the 1/16" end mill and install the holder with the ¼" end mill. 
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Completing the Program 
1.   After the program has finished, open the safety door and carefully remove the 

workpiece. 
 
2.   Press Esc to return to the Mill menu. 
 
3.   Press the EMERGENCY STOP button. 
 
4.   Turn off the power switch located on the side of the mill. 
 
5.   Clean up your area and return everything to its proper place. 
 
When you are finished, go to the next section in the multimedia presentation. 
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Activity 5 
 
Before completing this activity, check with your instructor to see if you should download 
this PART program from a master floppy disk or enter it manually.  
 
• Complete the next section, YOU ARE THE PROGRAMMER 
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You Are the Programmer 
1.   Click on the File menu and select New. The Program Setup screen appears. 
 
2.   Delete <UNTITLED> from the Program Name field and leave it blank. 
 
3.   Delete Teacher from the Author field and enter your name. 
 
4.   In the Drawing No. field, the default, Project #1, should appear. If this is incorrect, 

highlight the text and enter a project number. 
 
5.   In the Material section of the screen, select Wax. If you are using plastic, select 

Plastic. 
 
6.   In the Editor portion of the screen, make sure Line Mode is selected. 
 
7.   In the Units portion of the screen, make sure Inch is selected. 
 
8.   In the Coordinates section, make sure Absolute is selected. 
 
9.   Enter the appropriate values in the X, Y, and Z fields. (X=6) (Y=3) (Z=0.5). 
 
10. Click on the OK button. The Line Editor appears. 
 
Complete the next section, ENTERING THE PART PROGRAM. 
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Entering the PART Program 
1.   Click anywhere in the Line Editor. A cursor appears next to Line 00001. On this line, 
enter a backslash (\), then your name. 
 
2.   Use the Enter key to go to the next line. 
 
3.   Enter the following program, starting on Line 00002. Make sure that you and your 
partner use spaces where indicated. 
 

NOTE: It is a good idea to save the program periodically 
since it is so large. To initially save your program, refer to 
SAVING THE PROGRAM in the ACTIVITY 1 section. Once 
you have done this, at random intervals, select Save from 
the File pull-down menu. Save again when the entire 
program has been entered. 

 
4.   Double-check your work when you are done. 
 

00001 \your name 
00002 \class 
00003 G70 
00004 M06 9 
00005 M04 2800 
00006 G94 6 
00007 G00 
00008 X2.35 Y1.125 G00 
00009 G01 
00010 Z.1 
00011 Z-.1 
00012 X.35 
00013 G00 
00014 Z-.2 
00015 X2.35 
00016 Z-.25 
00017 X.5 
00018 Z.1 G00 
00019 X2.35 Y1.875 G00 
00020 G01 
00021 Z-.1 
00022 X.35 
00023 Z-.2 
00024 X2.35 
00025 Z-.25 
00026 X.35 
00027 G00 
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00028 Z.1 G00 
00029 X1.725 Y.5 G00 
00030 G01 
00031 Z-.1 
00032 Y2.5 
00033 Z-.2 
00034 Y.5 
00035 Z-.25 
00036 G00 
00037 Z.1 G00 
00038 X0.975 Y.5 G00 
00039 G01 
00040 Z-.1 
00041 Y2.5 
00042 Z-.2 
00043 Y.5 
00044 Z-.25 
00045 Y2.5 
00046 G00 
00047 Z.1 G00 
00048 X3.25 Y.75 G00 
00049 G01 
00050 Z-.1 
00051 X2.75 
00052 G01 
00053 Y2.25 
00054 X4 
00055 X3.25 Y.75 
00056 Z-.2 
00057 X2.75 
00058 Y2.25 
00059 X4 
00060 X3.25 Y.75 
00061 Z-.25 
00062 X2.75 
00063 Y2.25 
00064 X4 
00065 X3.25 Y.75 
00066 G00 
00067 Z.1 G00 
00068 X2.977 Y.909 G00 
00069 G01 
00070 Z.15 
00071 X2.813 Y.813 Z-.1 
00072 X3.211 
00073 X3.261 Y.911 
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00074 X2.813 
00075 Y1.009 
00076 X3.31 
00077 X3.359 Y1.107 
00078 X2.813 
00079 Y1.205 
00080 X3.408 
00081 X3.457 Y1.304 
00082 X2.813 
00083 Y1.402 
00084 X3.506 
00085 X3.555 Y1.5 
00086 X2.813 
00087 Y1.598 
00088 X3.604 
00089 X3.653 Y1.696 
00090 X2.813 
00091 Y1.795 
00092 X3.702 
00093 X3.752 Y1.893 
00094 X2.813 
00095 Y1.991 
00096 X3.801 
00097 X3.85 Y2.089 
00098 X2.813 
00099 Y2.187 
00100 X3.899 
00101 G00 
00102 Z.1 G00 
00103 X2.977 Y.909 G00 
00104 G01 
00105 Z.05 
00106 X2.813 Y.813 Z-.2 
00107 X3.211 
00108 X3.261 Y.911 
00109 X2.813 
00110 Y1.009 
00111 X3.31 
00112 X3.359 Y1.107 
00113 X2.813 
00114 Y1.205 
00115 X3.408 
00116 X3.457 Y1.304 
00117 X2.813 
00118 Y1.402 
00119 X3.506 
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00120 X3.555 Y1.5 
00121 X2.813 
00122 Y1.598 
00123 X3.604 
00124 X3.653 Y1.696 
00125 X2.814 
00126 Y1.795 
00127 X3.702 
00128 X3.752 Y1.893 
00129 X2.813 
00130 Y1.991 
00131 X3.801 
00132 X3.85 Y2.089 
00133 X2.813 
00134 Y2.187 
00135 X3.899 
00136 G00 
00137 Z.1 G00 
00138 X2.977 Y.909 G00 
00139 G01 
00140 Z0 
00141 X2.813 Y.813 Z-.25 
00142 X3.211 
00143 X3.261 Y.911 
00144 X2.813 
00145 Y1.009 
00146 X3.31 
00147 X3.359 Y1.107 
00148 X2.813 
00149 Y1.205 
00150 X3.408 
00151 X3.457 Y1.304 
00152 X2.813 
00153 Y1.402 
00154 X3.506 
00155 X3.555 Y1.5 
00156 X2.813 
00157 Y1.598 
00158 X3.604 
00159 X3.543 Y1.696 
00160 X2.813 
00161 Y1.795 
00162 X3.702 
00163 X3.752 Y1.893 
00164 X2.813 
00165 Y1.991 
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00166 X3.801 
00167 X3.85 Y2.089 
00168 X2.813 
00169 Y2.187 
00170 X3.899 
00171 G00 
00172 Z.1 G00 
00173 X.833 Y.833 Z.1 G00 
00174 G81 
00175 X.6 Y.75 Z-.25 G00 
00176 X1.35 Z-.25 G00 
00177 X2.1 Z-.25 G00 
00178 Y1.5 Z-.25 G00 
00179 X1.35 Z-.25 G00 
00180 X.6 Z-.25 G00 
00181 Y2.25 Z-.25 G00 
00182 X1.35 Z-.25 G00 
00183 X2.1 Z-.25 G00 
00184 X4.5 Y2.5 Z-.25 G00 
00185 X4.25 Y2 Z-.25 
00186 X4.75 Z-.25 G00 
00187 X4 Y1.5 Z-.25 G00 
00188 X4.5 Z-.25 G00 
00189 X5 Z-.25 G00 
00190 X3.75 Y1 Z-.25 G00 
00191 X4.25 Z-.25 G00 
00192 X4.75 Z-.25 G00 
00193 X5.25 Z-.25 G00 
00194 X3.5 Y.5 Z-.25 G00 
00195 X4 Z-.25 G00 
00196 X4.5 Z-.25 G00 
00197 X5 Z-.25 G00 
00198 X5.5 Z-.25 G00 
00199 G80 
00200 G01 
00201 Z1 G00 
00202 X0 Y0 G00 
00203 M04 0 
00204 M30 

 
Congratulations! You made it! If you didn’t save when you finished, do it now. 
 
5.   Compile the program. If necessary, refer to COMPILING THE PROGRAM in the 

ACTIVITY 1 section. 
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6.   Emulate the program. If necessary, refer to EMULATING THE PROGRAM in the 
ACTIVITY 1 section. 

 
7.   Close the Line Editor. 
 
8.   Return the floppy disk to your instructor if one was provided. 
 
Go to the next section in the multimedia presentation. 
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Activity 6 
 
1.   Load the program. If necessary, refer to LOADING THE PROGRAM in ACTIVITY 3.  
 
2.   In order to load the 6" x 3" x 0.5" workpiece onto the bed of the 5400 CNC Mill, you 

must first remove the 2" x 2" vise. To do this, use your Allen key to loosen the L-
shaped hold-down brackets. Once loose, remove the vise from the mill. 

 
3.   Next, place the 6" x 3" x 0.5" workpiece on the bed, carefully aligning the front edge 

so that it is parallel with the front edge of the bed surface. 
 
4.   Place one L-shaped bracket on the left side of the workpiece in the rear T-slot on 

the bed, and place the second bracket on the right side in the front T-slot. Tighten 
the brackets with the Allen key so that the workpiece is firmly held in place on the 
bed. 

 
5.   Set the tool position. If necessary, refer to SETTING THE TOOL POSITION in 

ACTIVITY 3. 
 
6.   Download the program. If necessary, refer to DOWNLOADING YOUR PROGRAM 

in ACTIVITY 3. 
 
7.   Execute the program. If necessary, refer to EXECUTING YOUR PROGRAM in 

ACTIVITY 3. 
 
8.   Clean up. If necessary, refer to CLEANUP in ACTIVITY 3. 
 
When you are finished, go to the next section in the multimedia presentation. 
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Saving to a Floppy Disk 
When all lesson activities have been completed, your PART programs should be saved 
to a floppy disk and then removed from the M4 directory. Your PART programs can be 
downloaded to Mill Level 4 at any time in the future if necessary. Follow the steps 
below. 
 
1.   Get a blank floppy disk from your instructor and label it with the names you assigned 

to the programs when they were initially created. Be sure to include your name. 
 
2.   Place the floppy disk in your computer floppy disk drive. 
 
3.   From the File pull-down menu, select Open. The File, Open window appears and 

shows all the PART programs stored in the M4 directory. 
 
4.   Right-click on one of your program files. A pop-up menu appears. Select Send To 

and then click 3½ Floppy (A). Your computer will now download a copy of the 
program file to your floppy disk. 

 
 
 
 
 
 
 
 

5.   After the PART program has successfully copied to your floppy disk, right-click 
again on the program file. From the pop-up menu, click Delete. A Confirm File 
Delete dialog box appears. Click Yes. Your PART program is now permanently 
deleted from the directory. 

 
6.   Repeat these steps for each program file you have stored in the M4 directory. 
 
7.   When you are done, remove the floppy disk. 
 
Go to the next section in the multimedia presentation. 
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INDEPENDENT STUDY ACTIVITY 
 
This will be a simple set of commands to set up the mill for spindle speed and feed rate, 
then to move the tool to three planned locations and return the tool to the home 
position. 
 
Home position on the mill is located at the coordinates X=0, Y=0, Z=1. The tool will start 
and end at this location. 
 
To program this part, use a spindle speed of 900 RPM, feed rate of 3" per minute, and 
operate in inches. 
 
1.   Launch the Mill Level 4 software program by double-clicking on the Mill Level 4 icon, 

located on your desktop. If you can’t find the icon, ask your instructor for help  
 
2.   From the File pull-down menu, select New. The Program Setup screen opens. 
 
3.   Delete <UNTITLED> from the Program Name field and leave it blank. 
 
4.   Delete Teacher from the Author field and enter your name. 
 
5.   In the Drawing ID field, the default, Project #1, should appear in the project field. If 

this is incorrect, highlight the text and enter a project number. 
 
6.   In the Material section of the screen, select Plastic. If you are using wax, select 

Wax. 
 
7.   In the Editor portion of the screen, make sure Line Mode is selected. 
 
8.   In the Units portion of the screen, make sure Inch is selected. 
 
9.   In the Coordinates section, make sure Absolute is selected. 
 
10. Enter the appropriate values in the X, Y, and Z fields. (X=2) (Y=2) (Z=0.5). 
 
11. Click on the OK button. The Line Editor appears. 
 
12. In the Line Editor, make line 1 a comment line by using the backslash, then typing 
the information you want. 
 

00001\Project # - Date 
 

13. Line 2 will set the program to operate in inches. 
 

00002 G70 
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14. Line 3 will set the feed rate. 
 
00003 M07 3 
 

15. Line 4 will set the spindle speed. The M04 signals the computer that you want the 
spindle to start turning and the 900 sets the speed to 900 RPM. 

 
00004 M04 900 
 

You are now set to start programming tool movement. The position of the tool at the 
start of the program will be 1" above the face of the raw stock. 
 
This position is defined by the control program loaded in the mill’s computer. 
 
16. To start the program, move the tool up to the corner of the workpiece just back from 

the surface. The command for move is G01. 
 

00005 G01 
 

17. Line 6 will give the computer the coordinates of where you want the center of the 
tool to move. 

 
00006 X0 Y0 Z.05 R 
 

18. Load the mill with a 1/8" (.125") end mill to do the drilling. All holes will be 1/8" in 
diameter. 

 
The surface height of Z = .05 is the height that the tool will return to as it moves from 
one hole to the other. This will give the clearance needed above the surface of the part 
to prevent a tool crash. 
 
19. To drill holes without a lot of code programming, enter the drilling cycle command, 
G81, on line 7. 
 

00007 G81 
 

20. Lines 8, 9, and 10 will give the location and depth of each hole. 
 

00008 X1 Y.5 Z-.3 
00009 X1.5 Y1.5 Z-.3 
00010 X.5 Y1.5 Z-.3 

 
21. On line 11, use the G80 code to finish the canned cycle. You do not want the 
computer to interpret the next coordinate for drill holes. 
 

00011 G80 
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To finish the program, you need to move the tool a safe distance from the workpiece. 
Do this by using the G01 command and defining positions for X, Y, and Z that are clear 
of the work area. 
 
22. Line 12 sets up the move code G01. 
 

00012 G01 
 
23. Line 13 positions the tool at home. 
 

00013 X0 Y0 Z1 R 
 
24. Terminate your program with the standard code for Stop and Home, M30. 
 

00014 M30 
 
25. Compile the program by selecting Compile from the Mill pull-down menu. 
 
26. Emulate the program by selecting Emulator from the Mill pull-down menu. 
 
27. Experiment with the various emulation features to become familiar with them. 
 
28. If you’d like to save your program, place a floppy disk in your computer floppy disk 

drive. Select Save as from the File pull-down menu. When the File Save As window 
appears, select 3½ Floppy (A) from the Save in drop-down menu. From the File 
pull-down menu, select Exit. If asked if you want to save your program, click No. 
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G AND M OPERATIONS 
 
G Operations 
G00    Rapid Positioning     RAPID 
G01    Linear Interpolation     MOVE 
G02    Arc Clockwise     ARC.CW 
G03    Arc Counterclockwise    ARC.CCW 
G04    Dwell       DWELL 
G05    Arc Command Start     ARC 
G50    Scale Coordinates Off    SCALE.ON 
G51    Scale Coordinates On    SCALE.OFF 
G70    Inch Programming     IN. 
G71    Metric Programming    MM. 
G80    Finish Canned Cycle    FINISH 
G81    Drilling Cycle      DRILL 
G82    Peck Drilling Cycle     PECK 
G83    Pocket Milling Cycle     POCKET 
G84    Cup Milling Cycle     CUP 
G92    Axis Preset      SET.ZERO 
G93    Axis Reset      ABS.ZERO 
 
M Operations 
M04    Spindle Speed Set     SPEED 
M06    Tool Change      TOOL 
M07    Set Feed Rate     FEED 
M08    Coolant On      COOL.ON 
M09    Coolant Off      COOL.OFF 
M11    Set External Output High    OUTPUT.H 
M12    Set External Output Low    OUTPUT.L 
M13    Wait For Input High     INPUT.H 
M14    Wait For Input Low     INPUT.L 
M28    Repeat Loop (start)     DO 
M29    Repeat Loop (end)     END.DO 
M30    Stop and Home     END 
M31    Stop and Repeat     RESTART 
M68    Open Vise      VISE.O 
M69    Close Vise      VISE.C 
M97    Subroutine Call     CALL 
M98    Subroutine Label     SUB 
M99    Subroutine End     END.SUB 
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