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Welcome
What Is in This Book

Mastering PowerPlay describes the advanced features you need to know to become a PowerPlay 
expert.

This book contains

• information you need to know to create advanced reports using nested categories, ranking and 
sorting, and standard reporting

• the process you must follow to distribute reports

• a guide to working offline and integrating PowerPlay with other applications

• general tips to help you get a cube that suits your reporting needs

• reference information on command-line options, specifications, and customizing your 
application

If you are new to PowerPlay, we recommend that you take the online PowerPlay Quick Tour, and 
read Discovering PowerPlay to learn how to create and use reports.

Other Documentation

An annotated list of other documentation, the Documentation Roadmap, is available from the 
Windows Start menu or the PowerPlay Help menu.

How to Order Extra Books

You can order extra copies of the printed documentation that is shipped with PowerPlay. Please 
contact your local Cognos office or Cognos Direct to order any of the installation guides, 
Discovering PowerPlay, Discovering Transformer, Administrator’s Guide, Transformer for UNIX, 
and Enterprise Server Guide. You can also print your own copies of the online versions of these 
books in Acrobat Reader.

Customer Support

For information about customer support locations and programs, see the customer support 
section of the online help or visit the Cognos Support Web site (http://support.cognos.com).

Your Comments Are Welcome

We are interested in your comments or questions about the documentation. Please send email to: 
bipubs@cognos.com.

.
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Chapter 1: Build Advanced Crosstab 
Reports

In this chapter you learn how to

� Use Nested Crosstabs

� Format Crosstab Reports

Use Nested Crosstabs
Your cube contains dimensions that are made up of one or more levels of categories. For 
example, the Years dimension in the Outdoors cube contains four levels.

Using a nested crosstab, you can view multiple levels at the same time. In Explorer or Reporter, 
nested levels can be 

• multiple levels from one dimension

• levels from different dimensions

• levels from a dimension nested with multiple measures

In Reporter reports, nested levels can also be created from alternate paths of the same dimension.

In Explorer reports, levels that are intersected from the same dimension must be nested so that 
child categories appear directly below parent categories. 
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Chapter 1: Build Advanced Crosstab Reports
Add Nested Categories
You can add nested categories to Explorer or Reporter reports.

There are two drop zones which govern how categories are nested—short bar and long bar. 

Long bar drop zones are available for both Explorer and Reporter reports. You can use these drop 
zones to add categories to all rows or columns as a higher or lower level. 

For example, you have an Explorer report with Locations in the columns and Years in the rows. 
Using the long bar drop zone, you add the children of Years as nested categories in all the rows 
of the report.

In the resulting report, the children of the Years dimension are nested in all of the rows.

Short bar drop zones are available for only Reporter reports. You can use these drop zones to add 
categories to individual rows or columns as lower levels. 

For example, you have a Reporter report with Locations in the columns and Years in the rows. 
Using the short bar drop zone, you add the children of 1996 as nested categories in the 1996 row 
of the report.

In the resulting report, the children of the 1996 are nested only next to this row.
8  Mastering PowerPlay
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Step
� Select the categories you want to add and drag them on to the report. 

Categories can be dragged from 

• the dimension viewer

• the dimension line

• the rows, columns, or layers of the report

• another report

Tips
• To preserve the parent /child relationship of a dimension’s levels before adding them to a 

Reporter report, select the levels and then click the Create Nested Levels button.

• To copy a category that is already in your Reporter report, press the CTRL key before you drop 
the category in the new location.

• To delete an entire level from a nested report, right-click a category from the level, click Delete, 
and then click Level.

Select Nested Categories
If you add a nested category to all rows or columns in a level (using long bar drop zones) all 
changes to the category apply to all occurrences of that category. 

For example, if you add the children of Locations as nested categories in all Products, selecting 
one of the Locations categories highlights all occurrences of that Location.

Because all occurrences of the category are selected, any action you perform on one occurrence 
such as moving, removing, formatting applies to all occurrences of that category.

If you add a nested category to only one row or column in a level (using short bar drop zones) all 
changes to the category apply to only that occurrence, even if the category is added again later.

For example, if you add Far East, Europe and Americas as nested categories in Outdoor Products 
and then add these same categories to GO Sports Line, selecting one of the Locations categories 
(Far East) will highlight only that occurrence.
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Drill Down and Up
The same rules that govern drilling down and up apply to regular and nested crosstabs. Drilling 
down on a category in a nested Explorer report replaces the drill category level with the child 
categories. Drilling down on a category in a nested Reporter report adds the children of that 
category as new categories at the same level. 

In Explorer mode, you can drill down on a rank or calculation. You cannot drill down on an 
"Other" category (80/20 suppression).

For example, you have a report with the Years dimension nested in the Locations dimension.

If you drill down on 1996 in an Explorer version of this report, the categories 1996 Q1, 1996 Q2, 
1996 Q3, and 1996 Q4 replace 1996, 1997, and Years.
10  Mastering PowerPlay
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If you drill down on 1996 in a Reporter version of this report, the categories 1996 Q1, 1996 Q2, 
1996 Q3, and 1996 Q4 are added below the 1996 category. 

Swap Nested Categories
There are two types of swapping you can perform on nested crosstabs—full category and partial 
category.

You can swap all rows and columns of a nested crosstab using full category swap. This can be 
done using the Swap command (Explore menu).

You can use partial category swap to swap levels nested from different dimensions of an Explorer 
crosstab by dragging a category from one level to another level.

Perform Calculations
When you perform a calculation on nested categories, the new calculation is added at the same 
level as the last selected category.

For example, you have a report with the Products categories nested below 1996.

If you add Outdoors Products and Environmental Line by selecting only these columns, the new 
calculation appears at the same level.
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If you select 1996 after selecting Outdoor Products and Environmental Line, the new calculation 
appears at the top level.

If you want to perform a calculation on a nested category that was added using short bar drop 
zones, you must select the parent category before performing the calculation.

Note
• If you move a calculation to a different level in a report, it is recalculated.

Tip
• To see how a calculation was created, right-click the calculation and then click Explain.

For more information on calculations, see the PowerPlay online Help.

Format Crosstab Reports

Choose a Layout
You can choose from the following layouts for nested crosstab reports

• Standard Layout. Nested levels appear beside one another for rows and below one another for 
columns.

• Indented 1 Layout. Nested rows are distinguished by indentation. If there are summary 
categories, they appear at the top with their labels in bold type.
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Chapter 1: Build Advanced Crosstab Reports
• Indented 2 Layout. Nested rows are distinguished by indentation. Summary labels are in bold 
type and the lowest level is underlined.

Example

You have prepared a report to show the long-term return of your company’s mutual funds. Before 
you put this report on your web site, you want to change the layout.

Step
� From the Format menu, click Crosstab Layout and then click a layout.

Note: The Indented 2 Layout is available for only Explorer reports.

Tip
• The Crosstab Layout command is also available from the right-click menu. To view this menu, 

right-click anywhere in the report window.

Show Summary Categories
In Explorer reports, you can hide or show the summary categories of a nested crosstab report. 

Example

You have prepared a PowerPlay report that compares the one-year performance of your 
company’s mutual funds by type. You do not use the summaries to compare performance, so you 
have hidden the summary categories. However, your analysis has changed and you now need to 
show the summary categories.

Steps

1. Open your Explorer report, and click the crosstab you want to change.

2. From the Format menu, click Display Options, and then click the General tab.

3. In the Summary Options box, do the following:

• To include the summary rows in the crosstab, select Show Summary Row(s).

• To include the summary columns in the crosstab, select Show Summary Column(s).

• To include the breakdown of outer summary rows, select Show Summary Break-down.

4. Click OK.

Tip
• To suppress summaries at a specific level of data, right-click a row or column category in a 

crosstab, and click Hide Summaries at this Level.
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Indent Summary Labels
When using Indented 2 Layout in Explorer reports, you can align the summary labels of a nested 
crosstab with the

• current level

• previous level

• right edge of the label area

Example

You have prepared a PowerPlay report that outlines the earnings for one of your company’s 
mutual funds. You indent the year’s summary so it stands out.

Steps

1. Open your Explorer report, and click the crosstab you want to change.

You must be using Indented 2 Layout.

2. From the Format menu, click Display Options, and then click the Totals tab.

3. In the Indent Totals box, do one of the following:

• To align the summary label with the lowest-level of nested categories, select With Current 
Level.

• To align the summary label with the second lowest level of nested categories, select With 
Previous Level.

• To align the summary label with the right edge of the label area, select Right Aligned.

4. Click OK.

Tip
• To automatically indent the lowest-level row labels in a non-nested Reporter crosstab, in the 

General tab (Display Options dialog box) click Automatically Indent.

Change Summary Labels
You can change the text and font of the labels for the summary rows or columns in a nested 
crosstab report.

Example

You have prepared PowerPlay reports that contain year-to-date earnings for each of your 
company’s mutual funds. You want to add the fund name to the summary label.

Steps

1. Open your Explorer report, and click the crosstab you want to change.

2. From the Format menu, click Display Options, and then click the Totals tab.

3. If you want to change the label of the row or column summaries, do the following:

• To type a new label, click Use Summary Label.

• To change the font, font style, size, and effects, click Font.

4. Click OK.

Tip
• You can change summary labels by right-clicking the category label and choosing Rename 

Label.
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Hide Report Gridlines
You can hide or show some or all of the gridlines in a crosstab report.

Steps

1. If you have more than one crosstab in your report, click the crosstab you want to change.

2. From the Format menu, click Display Options, and then click the General tab.

3. In the Gridline Options box, select one of the following:

• Show Label Gridlines to show label borders.

• Show Data Gridlines to show cell and label borders.

• Show Row Detail Gridlines to show borders around labels and values for lowest level of 
row detail.

• Show Column Detail Gridlines to show borders around labels and values for lowest level 
of column detail.

The report must include nested categories to use Show Row Detail Gridlines and Show 
Column Detail Gridlines.

4. Click OK.

Insert Blank Rows and Columns
You can add blank rows or columns to a Reporter crosstab. You can also format and resize blank 
rows and columns after you add them.

Example

You have prepared a PowerPlay report that outlines the types of mutual funds that your company 
sells. You want to distinguish the individual funds from the funds summary, so you add a blank 
row and column before the summaries.

Steps

1. In a Reporter report, click the row above or column to the left of where you want the blank 
to appear.

2. From the Insert menu, click Blank(s).
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Notes
• Blank rows and columns appear in only crosstab reports.

• You cannot have blank layers. If you swap rows or columns with layers, the blanks do not 
appear.

• You cannot have a blank row or column at the beginning of a level.

Tip
• To add a background pattern to a blank row or column, select the blank and from the Format 

menu, click Categories, and then click Labels and Values. 

Show Values as Blank Cells
You can format the measures in your report to show blank cells instead of zeros. You can choose 
to show any of the following as blanks

• zero values

• divisions by zero

• missing values

Example

You have prepared a PowerPlay report that outlines the five-year return for all your mutual funds. 
Because some funds are only three years old, there is no data for the first two years. This missing 
data appears as zeros which incorrectly implies a zero return for these funds. You change these 
values to blanks.

Steps

1. In the dimension viewer, click the measures you want to format.

2. From the toolbox, click the Format Measures button, and then click the Blank tab (Number 
Format dialog box).

3. In the Show As Blank box, do one of the following:

• To show all zero values as blank, select Zero Values.

• To show all division by zero calculations as blank, select Division By Zero.

• To show all missing values as blank, select Missing Values.

4. Click OK.

Note
• Zero and missing values appear as blanks in only crosstab displays. In all other displays, zero 

values appear as n/a unless specified otherwise by your administrator.
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Chapter 2: Rank and Sort Data

This chapter covers

� Why Rank and Sort Data

� Rank Data

� Sort Data

Why Rank and Sort Data?
Ranking adds ordinals to a report so you can compare your categories to one another. For 
example, you have a report that outlines revenue for all your products. You can rank this report 
to see which products had the highest revenue.

You can use sorting to arrange your categories in alphabetical or numerical order. For example, 
you have a report that contains all of your salespeople. You can sort this report so the salespeople 
are listed in alphabetical order.

Note

Categories that are hidden are not ranked or sorted.

Automatic vs. Manual
By default, rank categories and sort orders are automatically regenerated whenever there is a 
change to the report data. If you do not want your rank categories and sort orders re-generated, 
turn off automatic ranking or sorting.

If you have turned off automatic re-rank, you manually re-rank by

• right-clicking the rank category and then clicking Re-Rank

• clicking the rank category label and then clicking Rank (Explore menu)

You manually re-sort using the Re-Sort command (Explore menu).
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Why Use Manual Ranking and Sorting?

Use manual ranking when you want to retain the original rank ordinals after changing the 
categories in a report. 

For example, in your Reporter report, you rank the children of All Products (Outdoor Products, 
Environmental Line, and GO Sport Line) but then drill down to add the individual product 
categories to the report. By using manual ranking, you can retain the top level rank ordinals.

Use manual sorting when you want to retain the original order of the categories after you have 
made changes to the categories in the report. For example, in your Reporter report, you sort the 
children of Locations (Europe, Far East, and Americas) by label in ascending order.
18  Mastering PowerPlay



Chapter 2: Rank and Sort Data
You then add the individual Location categories to the report by drilling down. Because you have 
used manual sorting, the sort order is retained for the parent categories.

Rank Data
You can rank the categories in the rows and/or columns of a report. When you rank the rows or 
columns of a report, each row or column value is assigned an ordinal that shows how it 
performed in relation to the other rows or columns. The rank ordinals appear in a new row or 
column which you can sort. In Explorer reports, the label and values of the rank category are 
italicized. The italic formatting is removed when you switch to a Reporter report.

You choose whether the highest or lowest value in a category receives a rank ordinal of 1, and 
how many of the top or bottom results to view. For example, you can show the top five sales 
representatives, giving the one with the highest sales an ordinal of one.

Example

You are the Vice President of Sales for a company that manufactures cars. You created a report 
that shows the revenue generated by all salespeople in each of your company’s regions. You 
want to rank this report to show the top ten salespeople in Europe.

Steps

1. From the Explore menu, click Rank.

2. In the Rank box, click whether you want to rank rows or columns.

The contents of the Rank box depend on the type of display.

3. Click the ellipsis, and click the row or column you want to rank by.

4. In the Show Ordinals box, click the number of ranked categories to show.

You can show all ranked categories, or type how many of the top or bottom ordinals to 
show.

5. Click the Lowest or Highest option button to assign either of these values as ordinal 1.
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6. In the Sort Ordinals box, do one of the following:

• To rank the ordinals without rearranging their order, click None.

• To sort the ordinals in ascending order (for example, 1 to 10), click Ascending.

•  To sort the ordinals in descending order (for example, 10 to 1), click Descending.

7. Select Automatically Re-Rank to use automatic ranking mode.

8. Click OK.

Tips
• To remove ranking from a report, select the rank category label and delete it. You need to 

show the rank category first if it is hidden.

• To hide the rank category for the current display, select the Hide Rank Categories check box 
in the Display tab in the Display Options dialog box (Format menu). This option is not 
available for crosstab displays, or if you select Nested Charts (Explore menu). By default, rank 
categories are hidden in scatter displays.

• To rank the data in a report using the default rank settings, select the row or column you want 
to rank by and click the Rank button on the toolbar. If you have selected more than one row 
or column or no rows or columns when you click the Rank button, the Rank dialog box 
appears.

Note: To change the default settings for the Rank button, click Preferences (File menu), and 
then click the Rank tab.

Rank Identical Values
When you rank the data in a report, data of the same value receive the same rank ordinal. For 
example, in the following report, small tents and large tents have the same revenue value and 
therefore both receive a rank ordinal of 2.

Because tied values receive the same rank ordinal, specifying the top or bottom number of ordinals 
to show in a report shows all tied ordinals that fall into the specified number. For example, if you 
changed the rank settings for the above report to show only the top two ordinals, you actually see 
three categories in the rows since there are two categories with the ordinal two.
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Rank Nested Data
You can rank the lowest level categories of nested reports. If you add a lower level of nested 
categories to the rows or columns where a rank category appears, the rank category is removed.

For example, in the following report, you could rank the columns by Outdoor Products, 
Environmental Line, or Go Sport Line:

If you selected Outdoor Products, the resulting crosstab contains a rank category between Outdoor 
Products and Environmental Line.

For more information about nested categories, see "Use Nested Crosstabs" on page 7.

Sort Data
When you sort, the rows or columns are arranged in ascending or descending order. You can sort

• rows, columns, or layers in alphabetical order

• rows or columns in numerical order

Example

You have prepared a report that includes all salespeople in your company’s European locations. 
You would like to sort the report so the salespeople’s names appear in alphabetical order.

Steps

1. From the Explore menu, click Sort.

2. In the Rows, Columns, and Layers boxes, do one of the following:

• To leave categories unsorted, click None.

• To sort categories in alphabetical order, click By Label.

• To sort categories in numerical order, click By Value.

3. In the Sort Order box, click Ascending or Descending.

4. If you want to re-sort categories when your report changes, select Automatically Re-Sort.

5. Click OK.

Tip
• To sort the values in a report using the default sort settings, select the row or column you want 

to sort by and click the Sort button on the toolbar. If you have selected more than one row or 
column or no rows or columns when you click the Sort button, the Sort dialog box appears.

Note: To change the default settings for the Sort button, click Preferences (File menu) and 
then click the Sort tab.
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Sort Nested Data
You can sort nested rows or columns by label, but not by value. For example, you want to sort the 
rows of the following report so labels appear in alphabetical order.

In the resulting crosstab, the categories within each level are sorted alphabetically.

.
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Chapter 3: Maintain Standard Reports

In this chapter you learn how to

� Share the Dimension Line

� Use Report Templates

� Update Reports

� Create Standard Reports

Share the Dimension Line
Reports can share a dimension line if they use the same cube. A shared dimension line is useful 
for simultaneously showing information about different categories. When reports share a 
dimension line, all changes to dimensions (other than measures) in one report automatically 
appear in the other report. 

By default, all reports created from the same cube share the dimension line. If you want to drill 
down and filter in one report without affecting other open reports, in the Dimensions tab 
(Preferences dialog box) clear the Share The Dimension Line check box.

Example

You are the regional sales manager for a company that sells camping equipment. You have 
created two reports to help you analyze the sales performance of your product line. These reports 
share a dimension line: one report shows trends in products over the past two years and the other 
shows revenue for each customer type in each location.

You want to examine the performance of the product GO tents over the past two years to see 
what customers and locations drive revenue performance. However, you don’t want this filter to 
appear in the second report, so you turn off the shared dimension line.

Step to Turn Off Shared Dimensions
� From the File menu, click Shared Dimensions.

Tip
• To see changes to reports that share a dimension line as you work, tile the reports. When you 

drill down in one report, you immediately see the effects in the other reports.

Use Report Templates
By setting up report templates, you can save time and help new PowerPlay users. 

You can set up a report to use as a template with a similar cube, that is, a cube that has the same 
top-level dimensions. If you are not sure whether two cubes are similar see your administrator. 

Example

You are the Human Resources manager for a nationwide company that sells camping equipment. 
You have three core product groups that each operate as strategic business units—Environmental 
Line, GO Sports Line, and Outdoor Products. Each unit has its own cube for analysis. You create 
a report template so that the manager of each unit presents the data in the same way.
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Steps to Create a Report Template

1. Set up the information to appear in the report. For example, add categories, drill down, or 
filter.

2. Format the report. For example, add a title, resize rows and columns, and change the font 
and style of labels and values.

3. Save the report.

You should make your template report read-only so users don’t overwrite it when saving their 
new reports.

Steps to Use a Report Template for a Local Cube

1. From the File menu, click Open.

2. Select the Prompt for Cube check box.

3. In the Files of Type box, select PowerPlay Reports (*.ppr).

4. Locate and select the report.

5. Click OK. 

6. In the Access box, select Local.

You must install PowerPlay User Edition or PowerPlay Transformation Server (Windows or 
UNIX edition) to access a local cube.

7. Locate and select the cube.

8. Click OK.

Steps to Use a Report Template for a Remote Cube

1. From the File menu, click Open.

2. Select the Prompt for Cube check box.

3. In the Files of Type box, select PowerPlay Reports (*.ppr).

If you have not installed PowerPlay User Edition or PowerPlay Transformation Server 
(Windows or UNIX edition), PowerPlay Reports (*.ppr) is the only choice.

4. Locate and select the report.

5. Click OK.

6. In the Access box, select Remote.

If you have not installed PowerPlay User Edition or PowerPlay Transformation Server 
(Windows or UNIX edition), Remote is the only choice and is automatically selected.

7. Do one of the following:

• To access an existing connection, select a connection in the Connection box.

• To create a new connection, click the Connections button.

For more information about creating remote connections, see the PowerPlay online Help.

8. Select the cube.

9. Click OK.
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Update Reports
By default, PowerPlay updates reports automatically so that you see the most current values for 
the categories in your report.

If you want to show the most current information only when you need it, you can use manual 
updates. This can be especially useful if you want to update your reports only when you have 
time.

Example

You are in charge of the information system for a company that sells camping equipment. 
Because you are working with very large cubes, it takes a long time to update all of your reports. 
You choose to update your reports manually at the end of each day, so they are ready for you in 
the morning.

Step to Turn Off Automatic Updating
� From the Explore menu, click Get Data, and then click Automatically.

Step to Update Reports Manually
� From the Explore menu, click Get Data, and then click Now.

Notes
• You will see a question mark (?) in the report's cells until you update the data.

• If the administrator removes a dimension, you are unable to open the report.

• If the administrator removes a category or categories, your report shows error in place of the 
deleted category.

Tip
• To turn on automatic updating for all new reports, select the Get Data Automatically check box 

in the Options tab (Preferences dialog box).

Create Standard Reports
A standard report is a Reporter report that contains one or more subsets. Subsets are dynamic—
they are updated whenever a change in the cube data affects the categories in the subset. For 
example, you can create a subset that includes all sales representatives of a certain region. Every 
time you open the report containing the subset, the data is updated so the most current sales 
representatives are shown, rather than just those from when the report was created.

Standard reports are especially useful when the categories in your cube constantly change. 
Although you can rely on manual or automatic updates to show new report values, standard 
reporting is the only way to show categories that have been added, deleted, or changed.

Create a Subset Definition
A subset definition is a query that defines a new set of categories based on specified criteria.

A subset definition can be created using the

• Parentage Subset dialog box

• Find in Cube dialog box

• Advanced Subset dialog box

Once you create a subset definition, it is displayed in the subset viewer of the report until you 
delete it.
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Create a Parentage Subset Definition

You create parentage subsets using the Parentage Subset dialog box, in which you create a subset 
definition based on a level or levels in a dimension.

Example

You are one of the regional managers for a company that sells camping equipment around the 
world. Every year, you need to present a report that includes the last two years revenue for all the 
sales people in the Americas. You create a parentage subset definition that includes the lowest 
level children of the Americas.

Steps

1. Open a new or existing Reporter report. 

2. Using the dimension viewer, click the dimension folder you want to use to create the 
definition.

3. Click the Create Parentage Subset Definition button in the toolbox.

4. In the Qualifier box (Parentage Subset dialog box), do one of the following:

• To use the children of the selected level, click Next Level Children.

• To use the children of the selected level as well as the children of those categories, click 
Next Two Levels’ Children.

• To use the lowest level children in the dimension, click Lowest Level Children.

5. Click Save Subset to create the subset definition in the subset viewer.

6. Click Close to close the Parentage Subset dialog box.

Note
• If you click Next Two Levels’ Children, the lower level is nested in the higher level in the report
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Create a Find-in-Cube Subset Definition

You create a subset definition using the Find in Cube dialog box. You use this tool to find all 
categories in the cube that meet specified criteria in the category label.

Example

You are in marketing for a company that sells many different camping products. You need to 
present a report each month that contains all of the products that start with the word GO. You 
create a find-in-cube subset definition that returns all of the categories in the cube that contain 
this word.

Steps

1. Open a new or existing report. 

2. In the dimension viewer toolbox, click the Create Find-in-Cube Subset Definition button.

3. In the Find What box (Find In Cube dialog box), type the string you want to match.

4. To conduct a simple search, in the Simple Patterns box, do one of the following:

• To match the string anywhere within the category label, click Contains.

• To match the string with the beginning of the category label, click Begins With.

• To match the string with the end of a category label, click Ends With.

5. To conduct an advanced search, click Options and do one of the following:

• To conduct a search that matches the lowercase and uppercase characters of the string you 
typed in the Find What box, click Match The Case.

• To match the entire string that you typed in the Find What box, click Match The Whole 
Category.

• To use wild cards in the Find What box, click Use Wildcards. For a list of wildcards, see 
the Wildcards table in this chapter.

6. In the Cube tab, do one of the following:

• In the Dimension(s) box, click which dimension to search.

• In the Name box, click whether you want to search the short name, long name, or 
description of the categories.

7. Click the Find All button.

8. Click Save Subset, and click Close.
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Wildcards

Create an Advanced Subset Definition

You create an advanced subset definition by using the Advanced Subset dialog box. You can use 
this tool to define a subset that matches specified criteria. For example, you may want to define a 
subset that includes only sporting good products sold in Canada and the U.S. These subsets (as 
with all subsets) are saved with the report so that you can reuse them even if the cube changes.

You create an advanced subset definition by first determining the dimension that you want to use. 
For example, if you want your subset to focus on the top sales branches by revenue, you select 
the Locations dimension because sales branches (which are the object of your criteria) are 
contained within the Locations dimension. If you want to also include the country level in your 
definition, you can select more than one level to appear. (You may need to choose an alternate 
drill-down path if the levels that you want are not in the primary drill-down path.) 

Character Finds Example

 ^ The beginning of a string. "^inter" finds 
"interesting" and 
"interfere", but not 
"splinters".

 $ The end of a string. "$in" finds "in" and 
"within", but not 
“interfere".

 ? Any single character (except 
newline).

"to?" finds "top" and 
"ton", but not "to".

 ~ Zero or one occurrence of the 
preceding character (or sub-
expression).

"files~" finds "file" and 
"files", but not "filed".

 * Zero or more occurrences of 
any characters (except 
newline).

"can*" finds "can" and 
"Canada".

 # Zero or more occurrences of 
the preceding character (or sub-
expression)

"filex#" finds "file" and 
"filexxx".

 @ One or more occurrences of the 
preceding character (or sub-
expression).

"filex@" finds "filex" and 
"filexxx", but not "file".

 | Either the preceding character 
(or sub-expression) or the 
following one.

"localis|ze" finds either 
"localise" or "localize".

 [ ] Any character within the 
brackets. Ranges of characters 
can be specified using a 
hyphen (a hyphen at the start 
matches itself). An exclamation 
point at the beginning causes 
the set of characters to be 
inverted; e.g. [!a-m] matches 
everything except a through m.

p[iu]ck" finds "pick" and 
"puck".

 ( ) Sub-expressions, so that 
repetition and alternative 
wildcard characters can be 
applied more generally.

"ab(cd)#e" finds "ab" 
followed by zero or 
more "cd" combinations 
followed by "e".

 \ The next character literally. 
Allows wildcard characters to 
treated as normal characters.

"what\?" finds "what?".
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Advanced subset definitions are always dimension specific because you focus on one type of 
object at a time. This means that you cannot create an advanced subset definition that includes 
more than one dimension (such as the Locations and Products dimensions). 

You can further restrict the definition by including or excluding restrictions by parent category, by 
name or description using find in cube, or by value. A subset definition can include one or all of 
these restrictions. 

Note: When you sort categories in an advanced subset, categories with missing values are sorted 
at the end of the list regardless of the sort order.

Example

You are in charge of Finance for a company that sells camping equipment. Every month, you 
need to present a report that shows revenue for one of your company’s channels. You need to 
see only those products that are sold in Canada and the U.S. and that are part of the Sports Line, 
so you create an advanced subset definition that includes only these categories.

Steps

1. Open a new or existing Reporter report.

2. In the dimension viewer toolbox, click the Create Advanced Subset Definition button.

3. In the Name box (Advanced Subset dialog box), enter a name for the subset definition.

4. In the Dimension box, select the dimension you want to use.

You can use Measures as the dimension only if the selected measure contains more than one 
level.

5. In the Drill-Down Path box, click the drill-down path that includes the categories you want. 

If there are no alternate drill-down paths, the only choice is Primary.

6. In the Level(s) box, select the level or levels to include.

If you select more than one level, your subset appears as nested levels.

7. If you do not want to restrict the categories in the level(s) you have selected, click Save 
Subset.

If you want to restrict these categories, see the following:

• "Create an Advanced Subset Definition with Restriction by Parent" on page 30

• "Create an Advanced Subset Definition with Restriction by Name or Description (Find)" on 
page 31 

• "Create an Advanced Subset Definition with Restriction by Value" on page 31

A subset definition can include one or all of the above restrictions.
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Notes
• If a dimension has alternate drill-down paths below an alternate drill-down path, any level 

below the second level alternate drill-down path will not appear in the Levels box, even if they 
are along the rollup path to the second level alternate drill-down path.

• Changing the dimension, dimension drill-down path, or level(s) clears all restrictions from the 
Advanced Subset dialog box. 

• If you create an advanced subset using Measures as the dimension, you cannot create an 
advanced subset definition with restriction by value.

• If you include a level in your subset definition that is subsequently removed from the cube, 
your results may be incorrect.

Tips
• To remove a restriction from the Selected Restrictions box, click the restriction and then click 

Remove.

• To see a list of some of the categories that are included in a level in the Level(s) box, right-
click the level label and then click Sample Categories.

Create an Advanced Subset Definition with Restriction by Parent

Restricting an advanced subset definition by parent enables you to include or exclude specific 
levels in the subset.

Example

You are one of the regional managers for a company that sells camping equipment around the 
world. Every year, you need to present a report that includes the last two years revenue for all 
sales people in Canada and the US, but Canada, the US, and Mexico are all included in the 
Americas category. You create a parentage subset definition that includes only these lowest level 
children for Canada and the US and excludes the lowest level children for Mexico.

Steps

1. Create an advanced subset definition.

For more information, see "Create an Advanced Subset Definition" on page 28.

2. Click the Parent tab.

3. In the Drill-Down Path box, click the drill-down path that contains the restrictions you want 
to use.

You can qualify a subset definition using restrictions from both primary and alternate drill-
down paths. If there are no alternate drill-down paths, the only choice is Primary.

4. In the Restrict by Parent box, specify the categories you want in the subset.

• To include a category, select it and then click Include.

• To exclude a category, select it and then click Exclude.

5. Click Save Subset and then click Close.

Note
• Although a category must meet all restrictions to be returned in the results of an advanced 

subset definition, if you include two restrictions from the same parent, the results only need 
to meet one of these restrictions. For example, if you include both Canada and the US from 
the Americas dimension, then the resulting categories may come from either Canada or the US.

Tip
• If you want to include the majority of your categories in the subset, you can just exclude the 

few categories you do not want.
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Create an Advanced Subset Definition with Restriction by Name or Description (Find)

Restricting an advanced subset definition by name or description enables you to include levels in 
the subset that contain a specific text string.

Example

You are in marketing for a company that sells many different camping products. You need to 
present a report each month that contains all of the product lines using the word GO. You create 
a subset definition that returns all of the product line categories that contain this word.

Steps

1. Create an advanced subset definition.

For more information, see "Create an Advanced Subset Definition" on page 28.

2. Click the Find tab.

The Restrict by Find Definition box contains only definitions that are already defined for the 
dimension selected in the Dimension box.

3. Click New.

4. In the Find What box (Find in Cube dialog box), enter the string you want to match.

5. To conduct a simple search, do one of the following in the Simple Patterns box:

• To match the string anywhere within the category label, select Contains.

• To match the string with the beginning of the category label, select Begins With.

• To match the string with the end of a category label, select Ends With.

6. To conduct an advanced search, click Options and do one or more of the following:

• To conduct a search that matches the lowercase and uppercase characters of the string you 
typed in the Find What box, click Match the Case.

• To match the entire string that you typed in the Find What box, click Match the Whole 
Category.

• To use wild cards in the Find What box, click Use Wildcards.

7. In the Name box, select whether you want to search the short name, long name, or 
description of the categories.

The dimension that appears in the Search in Dimension box was already set in the Advanced 
Subset dialog box.

8. In the Find in Cube dialog box, click Save Subset and then click Close.

9. In the Advanced Subset dialog box, click Save Subset and then click Close.

Create an Advanced Subset Definition with Restriction by Value

Restricting an advanced subset definition by value enables you to include categories in the subset 
that represent the largest or smallest values or values that are greater than, less than, or between 
specific values in a level.

Note: If you select Measures as the dimension, you cannot create an advanced subset definition 
with restriction by value.

Example

You are in charge of Finance for a company that sells camping equipment. Every month, you 
need to present a report that shows the ten best selling products for one of your company’s 
channels. You need to see only those products that are sold through the camping chain channel, 
so you create an advanced subset definition that includes only these categories.
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Steps

1. Create an advanced subset definition.

For more information, see "Create an Advanced Subset Definition" on page 28.

2. Click the Value tab.

You can also choose an existing value restriction subset definition from the Restrict by Value 
box.

3. Click New.

4. In the Using Values from the Measure box, select the measure you want to use in the restrict 
by value subset.

The dimension in the Select Categories from the Dimension box has already been selected in 
the Advanced Subset dialog box.

5. In the Restrictions box, select one of the following:

• a number of values. Enter the number of values and then select Largest or Smallest. The 
default is The 10 Largest Values.

• values by size. Select a size restriction and then enter the value in the box. The default is 
Values Greater than 1000.

If you select Between as the size restriction, enter values for both the lower and upper limits. 
If you are using values from a measure based on a percentage, you must use the decimal 
format when entering a value. For example, if you are restricting an advanced subset to profit 
margin values greater than 20 percent, enter .20.

6. To specify a category for a dimension other than the default dimensions of the report, select a 
dimension from the Based on the Dimension Setting box and click the Edit button. Then 
select a category in the Modify Dimension Setting dialog box and click OK.

Changing a category for a dimension applies only to the subset and does not affect the 
dimension line settings for the report. You can only change the categories for dimensions that 
have not yet been set. For example, the dimensions selected in previous steps are not 
available in the Based on the Dimension Setting box.

7. In the Restrict by Value box, click OK.

8. In the Advanced Subset dialog box, click Save Subset and then click Close.

Open a Subset Definition

A subset definition can be created from a parentage, find-in-cube, or advanced subset definition. 
You see the results of a subset definition by opening it in the subset viewer.

Step
� In the subset viewer, click the Expand button beside the subset definition. 

Notes
• If the subset definition is taking too long to open, click the Cancel button to stop it. You will 

not see any results.

• If the subset definition does not retrieve any resulting categories, the expand button 
disappears.
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Change a Subset Definition

You can edit any subset definition that appears in the subset viewer. When you edit a subset 
definition that is already added to a report, the categories in the subset are updated to meet the 
new results of the definition.

Steps

1. From the subset viewer, right-click the subset definition you want to modify, and then click 
Edit.

2. In the dialog box used to create the subset definition, change the definition and then save it.

Tips
• To see the details of a subset definition, right-click it, and then click Explain.

• To rename a subset definition, right-click it, and then click Rename.

Delete a Subset Definition

When you no longer need a subset definition, you can delete it by right-clicking the subset 
definition in the subset viewer and clicking Delete. If the subset definition is used in your report, 
you can

• break the subset, which leaves the categories in the report but does not update them

• delete the subset, which removes the categories from the report

Work With Subsets

Create a Subset

A subset is created whenever you add a subset definition to a report. You can create a subset 
from

• a parentage subset definition

• a find-in-cube subset definition

• an advanced subset definition

Example

You created an advanced subset definition that includes all of the camping products sold by one 
sales representative. You want to add this subset definition to your report so the most current 
products show whenever you open the report.

Step
� From the subset viewer, click the subset definition, and then click the Add as Rows, Add as 

Columns, or Add as Layers button in the toolbox.

Notes
• If you change to an Explorer report, you lose the subsets in your report, although they remain 

in the subset viewer.

• If a subset contains categories that you do not have access to, you cannot see them in the 
report. For more information about cube security, see the Authenticator online Help.

• To add the subset to your report, right-click the subset and then click Add as Rows, Add as 
Columns, or Add as Layers.

• You can add individual categories from a subset definition to your report; however, they do 
not become subsets.

Tips
• You can also drag a subset definition onto the rows, columns, or layers of a report.
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Highlight Subsets

If you want to see the categories that belong to a subset in a report, you can add a background 
pattern using the Highlight Subsets command. You must be in Crosstab view to highlight subsets.

Steps to Highlight Subsets in a Report

1. From the Explore menu, click Change Display, and then click Crosstab.

2. From the Format menu, click Display Options.

3. In the General tab, select Highlight Subsets.

4. To change the background pattern, click Subset Patterns and then in the Pattern box (Subset 
Patterns dialog box), select a different pattern. Click OK.

5. Click OK.

Tip
• You can also highlight subsets by clicking Highlight Subsets (View menu). This command uses 

the default background pattern which you can change using the Display tab (Preferences 
dialog box).

Subset Calculations

In order to perform a subset calculation, you must have only one entire subset selected. You can 
perform the following non-group calculations on a subset

• add

• multiply

• maximum

• minimum

• average

• rollup

A subset calculation always appears directly after the subset. Although a subset calculation is not 
highlighted with the rest of the subset, it is recalculated if the subset changes.

You can also perform calculations on individual categories in a subset, however the new 
calculation does not become a member of the subset and is not updated if the subset changes.

For more information about calculations, see the PowerPlay online Help.
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Break a Subset

You can break a subset if you no longer want the subset categories to be updated. For example, 
if you are preparing a report to present at the end of the Quarter, you do not want it updated 
once the Quarter is over. 

You can break a subset by right-clicking the subset and clicking Break Subset.

Other events that also break a subset include:

• if an individual category in the subset is deleted

• if one or more categories are added between two categories in the subset

• if you add a nested category to only one category in a subset (using short bar drop zones)

• if you drill down on a category in a subset

• if you rank or sort a report that results in categories being removed from or inserted in between 
categories in a subset

When you break a subset in one of these ways, you receive a warning to confirm that you want 
the subset broken. You can choose to show this message every time a subset is broken, or you 
can turn it off.

When you save a report in which a subset is broken, a list of the broken subsets appears. If you 
save a report with broken subsets, the categories from the broken subset are not updated, 
however the subset definition remains in the subset viewer.

Note
• You do not receive a warning before you break a subset in a read only report.

Delete a Subset

When you no longer want a subset in your report, you can delete it by right-clicking a category in 
the subset, clicking Delete, and then clicking Subset.
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Chapter 4: Distribute Reports

In this chapter you learn how to

� Save Portable Reports

� Customize the Content of a Report and Publish it to Upfront

� Publish and Distribute HTML Reports 

� Publish a Report as a Page in a Briefing Book

� Print Reports with Large Amounts of Data 

� Attach a Report to Email

Save Portable Reports

Save as a PowerPlay Portable Report
In addition to the existing PowerPlay report format (.ppr), in PowerPlay for Windows 6.6 you can 
save and open a report as a PowerPlay portable report file (.ppx). You can send the .ppx file to 
your colleagues to change the report in PowerPlay for Excel, and then publish it to the Web. With 
this new report type, you are not limited to the authored report for your client alone, and can 
distribute reports to the other PowerPlay clients. 

Steps

1. Open the report.

2. From the File menu, click Save As.

3. In the File Name box, enter the name of the file.

4. In the Save As Type box, select PowerPlay Portable Report (*.ppx).

5. In the Save In box, select the folder where you want to save the .ppx file.

6. Click Save.
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Save as a PDF
In PowerPlay for Windows, you can also save reports as PDFs. A PDF file is useful for distributing 
standard reports using Adobe Acrobat and provides quality multipage output. PDF files are 
compact, portable, and platform-independent so you can capture the original look and feel of a 
document (including all fonts, images, graphics, and formatting of the application file), regardless 
of which client the report was created in. 

Steps

1. Open the report.

2. From the File menu, click Save As.

3. In the File Name box, enter the name of the file.

4. In the Save As Type box, select PDF File (*.pdf).

5. In the Save In box, select the folder where you want to save the .pdf file.

6. Click Options. 

The Save as PDF Options dialog box appears.

7. In the Save box (Save tab), specify the part of the report that you want to save.

8. In the Selected Display Saving Options box, specify the report properties that you want to 
save.

Depending on the option you selected in the Save box, some items are not available.

9. If you clicked Page Layout View or Selected Displays(s) in the Save box, click the Rows and 
Layers tab, and specify the rows and layers that you want to save with the report. 

Rows and layers that are suppressed or hidden do not appear in the Rows and Layers boxes 
and can’t be selected for saving with the PDF.

10. Click OK, and then click Save.

Customize the Content of Reports
In PowerPlay, you can customize the content of a report using the prompts feature in the 
Deployment Options dialog box (File menu). You can select the items that you want the report 
consumer to be prompted for when they open the report in PDF format in PowerPlay Web 
Viewer.

By default, reports are deployed with no prompting. You can change the default prompting 
properties in the Publish to Upfront wizard prior to publishing or republishing a report to 
Upfront. 

For more information, see "Publish to Upfront" on page 39.

Note: The deployment options are saved with the report in both .ppr and .ppx formats. 

Steps

1. Open the report that you want to publish to Upfront.

You can only publish to Upfront reports that are built on remote cubes.

2. From the File menu, click Deployment Options.

3. In the Prompt Report Consumer For box (Prompts tab), specify the prompting options 
available to the consumer when opening the published report.

4. Click the PDF Options tab.

5. In the Save box, specify the part of the report that you want the consumer to see when 
opening the published report.

6. In the Selected Display Saving Options box, specify the report properties that you want to 
save with the published report.

Depending on the option you selected in the Save box, some items are not available.

7. Click OK.
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Publish to Upfront
Upfront is the Web front end to Cognos enterprise applications and other Web data. You can save 
your PowerPlay for Windows reports to Upfront NewsBoxes to give subscribers access to 
multidimensional data. 

You can publish reports built on remote cubes one at a time using the Publish to Upfront wizard. 
Publishing is the process of saving a reports as a NewsItem to an Upfront NewsBox. The wizard 
guides you through the process of publishing to Upfront. Subscribers to a particular NewsBox can 
click a NewsItem to access or run PowerPlay reports. The report is accessible as a PDF to the 
Upfront user, or can be opened directly in PowerPlay for Windows.

Steps

1. Open a remote cube.

2. From the File menu, click Publish to Upfront. 

The Publish to Upfront wizard appears.

You may be prompted for authentication.

3. On the Welcome page, specify the NewsItem Name and Description.

You can click Finish in the Welcome page to update an existing NewsItem that was 
previously published to Upfront.

4. On the NewsBoxes page, select the NewsBox where you want to save the NewsItem.

5. On the Report Prompts page, specify the prompt properties for the report consumer. 

For more information about setting prompts, see "Customize the Content of Reports" on 
page 38. 

6. On the PDF Options page, specify the content of the PDF report.

For more information about setting PDF options, see "Customize the Content of Reports" on 
page 38. 

7. Click Finish to publish or update a NewsItem in Upfront.

Publish and Distribute HTML Reports

Publish a Report as HTML
You can make an HTML report available to users through internet and intranet web pages, a 
network, or email, so that users can view these reports without PowerPlay installed. 

The Publish As HTML command captures what is visible on your screen in normal view. If you 
have a large amount of data and want to ensure that it is all visible, click the Report as HTML 
Table option button (Publish As HTML dialog box). Although the report layout is not preserved 
by the HTML crosstab, all rows and columns are represented.

Example

You are the Chief Financial Officer of a bakery chain. You have formatted your annual report in 
PowerPlay and now want to publish the report on your corporate web site.

Steps

1. Open the report.

2. From the File menu, click Publish As HTML.

3. In the Save In box, select the folder where you want to save the HTML files.

4. In the Prefix box, type the name to use as the prefix for all the HTML files created for this 
report.

The only valid characters are letters, numbers and the underscore (_).
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5. If you have layers in your report, do one of the following in the Layer Range box:

• To publish all layers of your report and include a navigation frame for these layers, click 
All.

• To publish only the current layer of your report, click Current.

6. In the Report Format box, do one of the following:

• To publish the report as a graphical display, click Graphic Image.

• To publish the report as a crosstab display, click HTML Table.

7. Click OK.

The HTML files are created in the location and folder you specified.

8. To view the HTML report, double-click the file with the prefix you specified and the 
extension .htm in Windows Explorer.

The Web browser is started and you can view the report. Verify that it appears as you 
expected and contains the correct navigation options.

Tips
• To minimize the size of the HTML files created, in the Background tab (Display Options dialog 

box) click No Background. This reduces the size of the .jpg file for the graphic image.

• Do not use text colors that may be used as Web browser backgrounds, such as gray or white, 
or your text may be invisible to users.

Distribute HTML Reports
Once you publish an HTML report, you can make it available for users to view. You can distribute 
an HTML report by

• linking the files to an internet or intranet web page

• making the files available on a network

• sending the files to specific users via email

Unlike a PowerPlay Report (*.ppr) which is one file, an HTML report consists of many files. All 
these files are needed to distribute the report, depending on the formatting and graphics included 
in your report. 

File Description

Header (.htm)

Example: Salesdh001.htm

The report title. It has the prefix you 
provide, the letters "dh," and a sequential 
number.

Image (.jpg)

Example: Sales0.jpg

The graphical display. It has the prefix you 
provide and a sequential number.

Layer (.htm)

Example: Salesdi001.htm

A frame-based page that defines both the 
header and body pages for one layer. It has 
the prefix you provide, the letters "di," and 
a sequential number.

Main (.htm)

Example: Sales.htm

The main file that is used to launch the 
HTML report. It has the prefix that you 
provide.

Report body (.htm)

Example: Salesdb1.htm

All pages of the report body. Each page has 
the prefix that you provide, the letters "db," 
and a sequential number.

Scroll Arrows (.gif)

Example: Left.gif

An image file used to create right or left 
scroll arrows that are used to scroll through 
the layers of a display.

Table of Contents (.htm)

Example: Salestoc.htm

A list of all the report body pages. It has the 
prefix you provide and the letters "toc."
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Publish a Report as a Page in a Briefing Book
You can publish a PowerPlay report as a page in a Portfolio briefing book. A briefing book is a 
document created in Portfolio that combines OLE objects, such as PowerPlay reports, into a 
format that is easy to use and distribute.

Example

The market demand for bakeries has escalated and you want to add 1000 outlets to double your 
coverage over the next five years. You need to prepare a presentation for your bank to borrow 
the necessary funds to meet your growth strategy. You have a number of PowerPlay reports that 
summarize your company’s performance, so you combine the reports in a Portfolio briefing book.

Steps

1. Open the report you want to publish as a briefing book page.

2. From the File menu, click Publish as Briefing Book.

The Publish as Briefing Book command is available only if you have Portfolio installed on 
your computer.

3. In the File Name box, type the name of the briefing book you want the page inserted into.

If the briefing book does not exist, it will be created.

4. In the Folders box, locate and select the folder where you want to save the file.

5. Do one of the following:

• To insert the current report content into the new briefing book page, click Embedded. 

• To insert an OLE link into the new briefing book page, click Linked. This link refers to the 
current report location, so you must save your report in order to choose this type. 

• To insert a picture of the current report display into the new briefing book page, click 
Image. No report content is inserted in this case.

6. Click OK.

Note
• If a briefing book is secured, you must have author mode privileges to insert a page into it.

For more information about briefing books, see the Portfolio online Help.
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Print Reports with Large Amounts of Data
When a report contains large amounts of data, you can print only selected portions.

Example

You are the owner of a large chain of bakeries with over 500 locations. You have a cube that 
records customer complaint information, such as type, date, time, and location. Using these 
dimensions, you are able to analyze the frequency of customer complaints at each location. 
Rather than send this entire report to each of your 500 managers, you print only those complaints 
that pertain to each shop.

Steps

1. From the File menu, click Print.

2. In the Print dialog box, do the following:

• To show colors in displays as patterns when printing in black and white, select Colors as 
Patterns.

• To show the report on one page, select Fit to Page.

• To specify the maximum number of pages to print, enter a number in the Threshold box.

3. Click Options.

4. In the Print box (Print tab), specify the part of the report that you want to print.

5. In the Selected Display Printing Options box, specify the report properties that you want to 
print.

Depending on the option you selected in the Print box, some items are not available.

6. If you clicked Page Layout View or Selected Displays(s) in the Print box, click the Rows and 
Layers tab, and specify the rows and layers that you want to print.

Rows and layers that are suppressed or hidden do not appear in the Rows and Layers boxes 
and can’t be selected for printing.

7. Click OK twice.

Tips
• To set the maximum number of pages to print, enter a number in the Threshold box (Print 

dialog box).

• To move your legend so it does not cover your data, switch to Page Layout view and position 
the legend before you print.

• To fit your report on one printed page, click Fit to Page in the Print dialog box. You must have 
clicked Print Selected Display(s) (Print Options dialog box) to use this feature.

Attach a Report to Email
If you use Microsoft Mail, Microsoft Exchange, or Microsoft Outlook, you can send a report as an 
attachment to an email message to users who have access to the cube on which the report is 
based.

Step
� From the File menu, click Send.

The report appears as an attachment to a new Microsoft Mail, Microsoft Exchange, or 
Microsoft Outlook message.
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Chapter 5: Work Offline

This chapter covers

� Why Work Offline

� Turn Off Sub-Cube Refresh

� Save a Sub-Cube

� Set a Report to Use a Sub-Cube

� Automatically Refresh a Sub-Cube

Why Work Offline?
You can continue to work with PowerPlay even when you are not connected to the original cube 
or the network on which the cube is stored. This feature is useful when you want to take work 
home or when you are on a business trip.

You can prepare a report containing a subset of the cube data and save the data for this report as 
a sub-cube (.mdc). When you save only the information used to create the report, you are limited 
to using the dimensions that were saved.

When you are finished working offline, you can automatically update the sub-cube with data 
from the original cube.

Note
• You can only work offline if you have installed PowerPlay User Edition or PowerPlay   

Transformation Server (Windows or UNIX edition).

Turn Off Sub-Cube Refresh
Sub-cubes that you create automatically refresh by default. To work offline, you must turn off the 
automatic refresh option. This turns it off for all reports and cubes that you open.

Steps

1. From the File menu, click Preferences.

2. Click the Options tab.

3. Clear the Refresh Sub-Cubes check box.

4. Click OK.
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Save a Sub-Cube
You can work offline with a PowerPlay report by saving it as a sub-cube. Sub-cubes can only be 
created if the original cube is a:

• PowerCube (Standard or In-database), not a third party cube such as Essbase or Express 

• remote cube and the PowerPlay Enterprise Server administrator has enabled sub-cubes to be 
created from the cube

Example

You are the marketing director for a large advertising agency. You have recently built a report that 
demonstrates your company’s ability to increase revenue and profit for your clients. On short 
notice, a potential client has asked you to visit his company and give a brief presentation 
outlining your agency’s strengths. Before you leave, you are able to save your report and create a 
sub-cube on your laptop so that you can continue to work on your presentation while you are 
traveling.

Steps

1. Prepare the report by drilling down or drilling up to the level of information you need.

2. From the File menu, click Save As to save the sub-cube.

You must install PowerPlay User Edition or PowerPlay Transformation Server (Windows or 
UNIX edition) to save a sub-cube.

3. Locate the folder where you want to save the sub-cube.

4. In the File Name box, type a name for the sub-cube.

5. In the Save As Type box, select one of the following:

• PowerPlay Cube (*.mdc)

• Microsoft Local Cube (*.cub)

A .cub file is available only if you are accessing data in an MS SSOS database. You cannot 
save to a .cub file if your report contains a calculated measure.

6. Click Save.

Note
• If you are saving the sub-cube based on a local cube, do not use the same name as the original 

cube.
44  Mastering PowerPlay



Chapter 5: Work Offline
Set a Report to Use a Sub-Cube
Once you save the report and the sub-cube, you must open the report using the sub-cube, and 
then resave the report. This sets the report to always access the sub-cube rather than the original 
cube.

Steps

1. From the File menu, click Open.

2. Select the Prompt for Cube check box.

3. In the Files of Type box, select PowerPlay Reports (*.ppr, *.ppx).

4. Locate and select the report.

5. Click Open.

If you opened a remote cube in your previous PowerPlay session, the Choose a Remote Cube 
dialog box appears. 

6. In the Access box, click Local.

You must install PowerPlay User Edition or PowerPlay Transformation Server (Windows or 
UNIX edition) to access a local cube.

7. Locate and select the sub-cube.

8. Click Open.

9. From the File menu, click Save to set the report to use the sub-cube.

When you open the report in another PowerPlay session, the report automatically connects to 
the sub-cube.

Notes
• You only have to set a report to use a sub-cube once.

• If you want the report to access the original cube or another cube, follow the above procedures 
and select the original cube or another cube. If the cube is located on a server, select Remote 
in step 6.
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Automatically Refresh a Sub-Cube
When you reconnect to the network on which the original cube is stored, you can set PowerPlay 
to automatically refresh the sub-cube against the parent cube the next time you open the report. 
When you want to work offline, you can turn off this option.

Example

You have returned from a business trip where you presented a report to a client. You now want 
to refresh the sub-cube to update your report.

Steps

1. Close the report or sub-cube that you want to refresh.

2. From the File menu, click Preferences.

3. Click the Options tab.

4. Select the Refresh Sub-Cubes check box.

5. Open the sub-cube or a report based on the sub-cube.

The sub-cube is updated with new information from the original cube.

Notes
• If you see an error message when you try to connect to the cube you may be trying to connect 

to the wrong cube or some dimensions may have been removed since your cube was last 
connected.

• If you open your report and see the word error in a category, either this category has been 
removed from the cube or you have connected to the wrong cube and the categories don't 
match.

• If the original cube is a secure cube, you may be prompted for authentication information 
depending on the type of security specified for the cube.
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Chapter 6: Integrate PowerPlay

This chapter covers

� Why Integrate PowerPlay with Other Applications

� Link Objects

� Embed Objects

� Export a Report

Why Integrate PowerPlay with Other Applications?
By linking and embedding objects, you can take advantage of features from several applications 
or add PowerPlay reporting power to other applications. 

You may want to link or embed new or existing objects into PowerPlay reports to

• show relationships between a PowerPlay report and a spreadsheet report

• add graphics for visual effect. For example, you may want to embed the corporate logo into 
your reports.

• add multimedia or macros

• leverage PowerPlay capabilities with other applications. For example, you may want to include 
your PowerPlay report in a presentation.

If you do not need the whole object you can also link or embed a portion of it.

Linking vs. Embedding
The primary differences between linking and embedding are where the object is stored and 
whether or not changes are reflected. 

An embedded OLE object is a copy of the information that is stored in PowerPlay. A linked OLE 
object is a pointer from PowerPlay to information in another application. Because embedded 
objects are a copy of the information stored within a PowerPlay report, changes made to the 
original object are not reflected. If you want your report to reflect the changes made to OLE 
objects, you should create linked objects. However, you must have the source application 
installed on your computer to edit linked objects.

Tips
• When you link or embed a report, the report appears in the size you saved it. If you maximize 

the PowerPlay report, link it, and later resize the application window, the size of the PowerPlay 
report changes to match the new size of the application window. If you want the report to 
remain a certain size, do not maximize it. Instead, size it manually and then link or embed it.

• You can copy information from PowerPlay to the Clipboard and then paste it into other 
applications. If you regularly copy report objects to another application, you can set up a 
Launch button on the toolbar. When you click the Launch button, PowerPlay automatically 
copies information from the active report to the Clipboard before running the application.
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Link Objects
You can link an object or a portion of an object to a report so that changes to the object are 
reflected in the report. When you link an object, the data is stored in the source file. You can 
open, edit, and change the source file. When the source file changes, the linked object reflects the 
changes. If you don’t want changes reflected, you can embed the object instead.

Example

You are the design manager for a team of software developers that has achieved a breakthrough 
in telephone switching technology. You are working on a PowerPlay report that evaluates the 
potential advantages of this new system. Another team member is developing the graphics that 
appear in your report. You want to link the graphics so updates are reflected in the report.

Steps to Link an Existing File

1. From the View menu, click Page Width.

2. From the Insert menu, click Object.

3. Click Create from File.

4. Select Link.

5. Browse for the file or type the file name in the File box.

6. Click OK.

Steps to Link a Portion of an Object 

1. In the source application, select the desired information and from the Edit menu, click Copy.

2. Open the PowerPlay report and click the location where you want the information to appear.

3. From the Edit menu, click Paste Special.

4. Click Paste Link.

5. In the As box, select the format for the pasted information and then click OK.

Tip
• To show the linked file as an icon, in the Paste Special dialog box select Display As Icon. If 

you want to change the icon or icon name, click Change Icon.

Edit a Linked Object
You can edit a linked object if the source application is available. For linked objects, you can fix 
errors or change the content of the source in the source application that PowerPlay opens. You 
do not have to locate the source.

Example

You recently presented a PowerPlay report on telephone switching systems to a number of your 
corporation’s executives. Your report features a number of linked objects. The company 
executives would like you to present your findings at the annual shareholder’s meeting. However, 
before you do so, you must edit some of the sensitive material found in the linked objects.

Steps

1. From the View menu, click Page Width.

2. Click the linked object in your report.

3. From the Edit menu, click Links.

If you are working in Normal view, you are prompted to change to Page Width view.
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4. In the Links dialog box, click the linked object and click Open Source.

5. In the source application, make the necessary changes, save the source, and close the source 
application.

If Update in the Links dialog box is set to Automatic, the linked object is automatically 
updated.

Notes
• You cannot edit an object whose link is broken.

• You can use the Linked <object description> Document submenu to open or edit the source 
for a linked object. The <object description> in the command depends on the linked object 
selected.

Tip
• You can also edit a linked object by double-clicking it in the report.

Update a Link
By default, PowerPlay creates links that are automatically updated when the source changes. In 
certain cases, you do not want changes in the source reflected in your PowerPlay reports. You 
can turn off the automatic updating feature so that changes to the source file do not appear in 
PowerPlay.

Example

Your corporate logo is being revised. The logo graphic is automatically linked to your PowerPlay 
report. Since you do not want the changes to the logo reflected until they been approved, you 
turn off automatic updating. Once the logo is ready, you manually update the object.

Steps

1. From the View menu, click Page Width.

2. From the Edit menu, click Links.

3. Click the file whose link that you want to update, and click Update Now.

4. Click Close.

Tip
• To change a manual link to an automatic link, in the Links dialog box, click Automatic.

Change a Linked Source
You can change the source to which an object is linked if the current source is no longer valid.

Example

Your manager wants you to incorporate the logo for a new product into all existing PowerPlay 
reports. The former logo is linked to the PowerPlay reports. You can adopt the new logo by 
selecting the source file that contains the new logo as your data source.

Steps

1. From the View menu, click Page Width.

2. From the Edit menu, click Links.

3. In the Links box, click the file you want to change, and then click Change Source.

4. In the Change Source dialog box, locate and click the new source file, and then click OK.

5. Click Close.

Tip
• To add an item name, in the Name box (Change Source dialog box), type the new name.
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Break a Link
You can break the link between an object and its source when you no longer need to change the 
object or when you don't have access to the source. When you break a linked source, the object 
remains in the report. However, you can no longer edit the source or re-establish the link. Be sure 
that you make all the changes to the source before you break the link.

Example

While you are working on a report, the included objects must be linked to their sources on the 
LAN. However, when the report is complete, you need to present it at an off-site meeting and 
your laptop can't access the source files. You can break the links and take only the report.

Steps

1. From the View menu, click Page Width.

2. From the Edit menu, click Links.

3. Click the file for the link you want to break, and click Break Link.

4. Click Yes.

5. Click Close.

Embed Objects
When you embed an object, the data is stored in the report file and becomes part of the report. 
When the source file changes, the embedded object does not reflect the changes. You can edit the 
object in the report, but no changes occur in the source file because the data is stored in 
PowerPlay.

Example

Every month, you present a PowerPlay report that contains an Excel spreadsheet that is sent to 
you from your regional office. Because this spreadsheet is constantly changing, you want to 
embed it in your report before each presentation.

Steps to Embed an Existing File

1. From the View menu, click Page Width.

2. From the Insert menu, click Object.

3. Click Create from File.

4. Browse for the file or in the File box, type the file name.

5. Click OK.

Steps to Embed a New Object

1. From the View menu, click Page Width.

2. From the Insert menu, click Object.

3. Click Create New.

4. In the Object Type box, click the type of object to embed, and then click OK.

The menus and toolbars of the source application replace the PowerPlay menus and toolbars.

5. Create the new object.

6. Click outside the object area when you are done.
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Steps to Embed a Portion of an Object

1. In the source application, select the desired information, and from the Edit menu, click Copy.

2. Open the PowerPlay report, and click the location where you want the information to appear.

3. From the Edit menu, click Paste Special.

4. Click Paste.

5. In the As box, select the format for the pasted information, and then click OK.

Tip
• To display the embedded file as an icon, in the Insert Object or Paste Special dialog box select 

Display As Icon. If you want to change the icon or icon name, click Change Icon.

Edit an Embedded Object
You can edit an embedded object from within PowerPlay if your system has the application that 
created the object. For example, you embed an Excel spreadsheet object. Then, to conserve disk 
space, you remove Excel from your computer. To edit the spreadsheet, you must reinstall Excel.

For embedded objects, you perform in-place editing. When you use in place editing, the menus 
and toolbars of the source application replace the PowerPlay menus and toolbars. When you edit 
an embedded object, the changes are not reflected in the source file.

Example

You recently presented a PowerPlay report that featured an embedded Excel spreadsheet. You 
need to update the contents of the spreadsheet before presenting to your overseas office. You can 
edit the spreadsheet directly from the PowerPlay report.

Steps to Edit an Embedded Object

1. From the View menu, click Page Width.

2. Double-click the embedded object to perform in-place editing.

The menus and toolbars of the source application replace the PowerPlay menus and toolbars.

3. Edit the object.

4. Click outside the object area when you are done.
Mastering PowerPlay  51



Chapter 6: Integrate PowerPlay
Export a Report
Another way to integrate PowerPlay with other application environments is to export your 
PowerPlay reports to other formats. You can export a PowerPlay report to

• PowerPlay Portable Report (*.ppx)

• Delimited ASCII Text File (.asc)

• Microsoft Excel Workbook (.xls) version 4.0 and higher

• PDF file (*.pdf)

When you export a report in delimited ASCII or Excel format, you can export only the level of 
data you see in the report.

Example

You are the regional sales manager for a company that develops and produces telephone 
switching systems. You have a PowerPlay report that includes the various systems and their retail 
prices. A member of your sales team needs to see this information, but does not have access to 
PowerPlay. Since this salesperson has Microsoft Excel, you can export the report in Excel format.

Steps

1. From the File menu, click Save As.

2. Find the folder where you want to save the file.

3. In the File Name box, type a name for the file.

4. In the Save As Type box, click the desired file format, and then click OK.

Notes
• When you export a report in delimited ASCII or Excel format, the top of the text file or the first 

few rows of the Excel worksheet show the date and time of export, the report file name, the 
name of the associated cube, and the report type (Explorer or Reporter). The folder names in 
the dimension line and the data appear below this information.

• You must have Excel installed to save as .xls.
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Chapter 7: Get the Cubes You Need

In this chapter you learn that you can use Transformer to build precisely the cubes you need. You can

� Change the Measures in a Cube

� Change Categories in a Cube

� Add extra detail

For more information about creating and modifying cubes, see Discovering Transformer.

Change Measures in a Cube
You may need to change or add new measures to meet your reporting requirements. For example:

• If a measure appears for categories, levels, or dimensions inappropriately, you can change the 
allocation settings of the measure.

• If you often use calculations that don’t appear in your cube and must be calculated every time 
you create a report, you can set up your calculations as measures, so you can easily show the 
results in every report.

• If you want a measure that counts the records in a category, you can create one. 

Allocate Measures
When you review a report, you may notice that some measures exist only at a summary level. For 
example, the budgeted expenses exist at the annual level, but appear as zeros for individual 
months. Depending on how your business derives certain measures, you may want to change the 
allocation of measures.

Example

You are in charge of the accounting department for a soft drink company. The company owns 10 
bottling plants. The administration costs associated with head office are currently allocated to 
your central plant, however, you would like each plant to absorb 10% of the administration costs.

Using Transformer

The allocation feature distributes data specified at a summary level of a dimension to lower levels. 
For example, actual sales revenue may be tracked daily, while sales revenue is forecast quarterly. 
You may find allocation useful for distributing quarterly forecasts to the month and day levels.

Three types of allocation are available:

• N/A (do not allocate)

• Constant (allocate a measure as a constant value to all descendants)

• By Measure (allocate to descendants proportionally according to another measure)

You can allocate measures over different objects:

• entire dimensions, when the measure appears in a data source that does not reference the 
dimension.

• levels within an individual dimension, when the measure is specified at a level in the particular 
dimension.

• categories within levels, when the measure is specified to the particular level.
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Set Up Calculations as Measures
There are certain calculations that are crucial to understanding your business, but setting them up 
in every report is time consuming. You can make these calculations available as measures in your 
cube.

Example

You are the product manager for a soft drink company. Your current cube includes measures for 
sales revenue and product cost for your entire product line. However, you also want to be able to 
quickly determine the profitability of various combinations of flavors and bottle sizes. The profit 
margin for each product type can be calculated as follows:

(Revenue-Product Cost)/Revenue

You want your cube to include this calculated measure, so you can ascertain the profit margin for 
each product type in your soft drink line without calculating this category each time you create 
the report.

Using Transformer

You can perform a variety of calculations to create new measures. Calculated measures derive 
new data from other measures, functions and constants.

Get Measures that Count Records
You want a measure that counts the number of records.

Example

You are the product manager for a company that currently markets two flavors of 1-liter soft 
drinks. To evaluate a specific market, you have decided to give away your cola for free for 30 
days. Because there is no sales price associated with this product, you want your sales price 
measure to ignore the promotional product when it counts records to determine total sales for the 
month.

Using Transformer

You can add a measure that counts either all records or only those records with non-null values. 

For example, if you specify Count All as the rollup for sales price (which is the method used to 
summarize measure data up the category tree for sale price) the result is 3, because the missing 
value is counted. If you specify Count as the rollup, the result is 2 because the missing value is 
not counted.

Date Line Item Cost Sale Price

19980930 1 Liter Drinks Orange 100 125

19980930 1 Liter Drinks Cola 120 150

19980930 1 Liter Drinks Promo Cola 120 n/a
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Change Categories in a Cube
You may need to change current categories or create new ones to meet your reporting needs. For 
example:

• If you want to use a time period other than the standard calendar year, you can create a model 
that uses your company's fiscal year, a lunar year, industry-specific periods such as 13-week 
manufacturing cycles, and relative time periods such as year-to-date.

• If you want to change the structure of the data to make exploring and reporting easier, you 
can sort, remove, suppress, and summarize categories.

• If you want to see one category shown as part of the whole, for example, revenue for a single 
product as a share of the revenue of the whole company, you can set any category to be a 
share of another category in the dimension.

• If you want to group categories from different levels in the same dimension for analytical 
purposes, (for example, identifying your government customers), you can set up special 
categories that don't follow the normal hierarchical structure. 

• If you want to use a different drill-down path to see a different view of the business, you can 
set up additional drill-down paths to suit your business view.

Use Different Time Periods
A time dimension is a type of dimension that contains categories representing time periods 
(usually dates). Using time dimensions, you can report on data using different periods of time. 
Sometimes, you want to analyze your data using a time period that is not available in your cube.

Example

You want to determine how your diet cola product line has performed this year compared to the 
same period last year. You prepare a PowerPlay report which compares year-to-date last year with 
year-to-date this year, so you want year-to-date to appear as a category in your time dimension.

Using Transformer

You can set up new time periods to appear as measures in your cube. For example, you can set up

• conventional date periods, such as years, quarters, months, weeks, and days

• industry-specific periods, such as 13-week manufacturing periods or seasons (Fall, Winter, 
Spring, Summer)

• custom periods, such as fiscal years, hours, or minutes

• lunar time periods, such as lunar years

• relative time periods, such as year-to-date or previous quarter

Change the Structure of Data
You regularly work with cubes that contain large amounts of data and often need to create reports 
in a short period of time. You sometimes find it difficult to find and isolate the data you need for 
these reports, so you would like to change the organization and structure of your cube.

Example

You have built a cube that contains three levels of detail for the dimension Products, each of 
which contains more than 100 items. Every time you drill down, you see too many categories to 
assess at once. To improve your analytical capability, you can create extra levels which logically 
sort the categories contained therein and make drilling down more manageable.

Using Transformer

You can sort, summarize, remove, and suppress categories, and make any category the top 
category in the hierarchy. As well, if you have too many categories in a particular level, you can 
create extra levels. By changing the structure of the cube, you will find it faster and easier to 
create the PowerPlay reports you need.
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Set Up a Category as a Share of Another Category
You want to see a category as a share of a higher-level category so that you can determine how 
well this category is doing in comparison with a higher-level category.

Example

You are the production line manager for a soft drink bottling plant that produces 750-milliliter, 1-
liter, and 2-liter bottles of soft drinks. You notice that the rejection rate for 1-liter bottles seems 
unusually high this month. Using the Rejection Rate measure, you can compare the rejection rates 
of each bottle to that of all bottles to determine if the 1-liter bottle is abnormal.

Using Transformer

You can set up any category as a share of any higher-level category in the same dimension. When 
you drill down in your PowerPlay Reporter report, you see the category as a share of a higher 
level.

Set Up Special Categories
You want to group categories from different levels into a special group for specific analysis.

Example

You are the sales manager for a company that markets soft drinks. For the most part, your sales 
representatives work exclusively in a single territory; however, you have two sales representatives 
who each have a few small territories. To effectively compare the total revenue that your sales 
representatives are generating, you can create a category that groups the total revenue for these 
two sales representatives.

Using Transformer

You can set up special categories for any data that you want to group together. A special category 
groups regular categories from any level into the same dimension without regard to their normal 
hierarchical organization.

A special category has the same appearance and behavior as other categories in the dimension 
viewer. When you drill down, you go directly to the categories that you have selected for this 
special category.

Drill Down Alternate Paths
You want to set up alternate drill-down paths so you can drill straight to the information you use 
most often.

Example

You are the Human Resources director for a company that manufactures soft drinks. You want to 
analyze the sick day patterns of your employees. Your cube features a Sick Day dimension that 
has six levels: 0, 1-5, 6-10, 11-20, 21-30, and 30+. You are most interested in looking at the data 
for employees that have over 30 sick days, and would like to bypass the other levels and go 
directly to this one.

Using Transformer

You can set up any number of alternate drill-down paths to more effectively analyze your data. 
Alternate drill-down paths improve report navigation and create paths that provide increased 
insight. However, you should limit the number of alternate drill-down paths to avoid confusion.
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Add Extra Detail
Using Transformer, you can add detail that enhances your analytical power in PowerPlay. For 
example:

• If you want to see details at the transaction level, you can link one or more Impromptu reports 
to the measures in a cube (if Impromptu is available to you). When you drill through to the 
transaction level, Impromptu starts, and you can see the details for the PowerPlay report.

• If you want descriptions of the data so that you can distinguish between similar cubes, or you 
want to know the formula used in a calculated measure, you can tie descriptions to the data 
in a cube.

• If you want to convert to a currency that is not available in PowerPlay, you can add the 
currency to the cube.

Drill Through to Transaction-Level Details
In order to accurately interpret the trends in a report, it can be helpful to see the transaction-level 
details behind your numbers.

Example

You are the regional sales manager for a soft drink company. Upon reviewing your PowerPlay 
report, you notice that one of your sales representatives had a large increase in sales in the last 
quarter. You want to determine what is behind this sudden success—a particular customer, a 
group of customers, a special promotional price, or some other factor? You need to see the 
transaction-level details to gain greater insight into the reasons behind the improved sales.

Using Transformer

You can set up default drill-through to Impromptu for the measures defined in a cube. If the cube 
uses an Impromptu query definition as a data source, you can drill through to Impromptu by 
default. You can also set up drill-through access to Impromptu even if you do not use an 
Impromptu query definition. You can drill through to Impromptu from a cell in a PowerPlay 
report to show the details behind the cell.

Note: Drill-through access to Impromptu is available only if Impromptu version 4 or higher is 
installed on your computer and the cube is linked to your Impromptu reports.

Get Descriptions of Data
When you open a report, you see many different types of categories and measures. You may have 
added this data to your cube a long time ago or it may have been given to you by your 
administrator. Either way, it can be helpful to know more about the data before using it to 
interpret the results of a report.

Example

You are the account manager for the central region of a soft drink company. You oversee both 
retail and wholesale accounts. Every day you get two new cubes from your administrator. One 
contains data for retail accounts and the other contains data for wholesale accounts. The cubes 
have several similar calculated measures. You want to see the formula your administrator used to 
create these measures before you use them to analyze your report.

Using Transformer

You can add a description for any dimension, level, category, or measure to help you identify the 
data you are viewing. You retrieve this description in PowerPlay using the Explain command.
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Add Another Currency
You want to convert the measures in your report into a currency that is not available. 

Example

You are the sales manager in your company’s head office. Each month, you need to send a report 
to the sales offices in several countries. Before sending this report, you need to convert the data 
to different currencies.

Using Transformer

You can make a new currency available in the cube. You can also change the conversion rate of 
any currency that is already available.
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Appendix A: Command-Line Options

This appendix covers

� Why Use Command-Line Options

� No Title Screen

� Explorer Report

� Reporter Report 

� Cube Name

� Remote Cube Name

� Report Name

Why Use Command-Line Options?
You can use command-line options to

• start PowerPlay without showing the title screen

• create a new Explorer report using a specific cube

• create a new Reporter report using a specific cube

• create a new report using a specific cube

• open a specific report

The syntax is:

PWRPLAY.EXE
[/nologo]

[/e=name.mdc]

[/r=name.mdc]

[mdc_file_name]

ppdsremote;<server>;<cube>[;<timeout>]

[report_name]

You can combine command-line options. For example, the following command starts PowerPlay, 
opens a new Explorer report based on the Inventory cube (inventry.mdc), opens a new Reporter 
report based on the Accounts cube (accts.mdc), opens a report called Year-End, and bypasses the 
title screen:
C:\COGNOS\PWRPLAY.EXE /e=inventry.mdc /r=accts.mdc year-end.ppr /nologo

Note
• The command-line syntax is not case-sensitive.
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No Title Screen
The /nologo option starts PowerPlay without showing the title screen or Welcome dialog box.

Example

The following command starts PowerPlay, but bypasses the title screen:
C:\COGNOS\PWRPLAY.EXE /nologo

Explorer Report
The /e=name.mdc option opens a new Explorer report.

Examples

The following command starts PowerPlay and opens a new Explorer report based on the Inventory 
cube (inventry.mdc):
C:\COGNOS\PWRPLAY.EXE /e=inventry.mdc

The following command starts PowerPlay and opens a new Explorer report using the Inventory 
cube (inventry.mdc) that exists in the c:\reports folder:
C:\COGNOS\PWRPLAY.EXE C:\reports /e=inventry.mdc

Reporter Report
The /r=name.mdc command opens a new Reporter report.

Examples

The following command starts PowerPlay and opens a new Reporter report based on the Inventory 
cube (inventry.mdc):
C:\COGNOS\PWRPLAY.EXE /r=inventry.mdc

The following command starts PowerPlay and opens a new Reporter report using the Inventory 
cube (inventry.mdc) that exists in the c:\reports folder:
C:\COGNOS\PWRPLAY.EXE C:\reports /r=inventry.mdc

Cube Name
The mdc_file_name option opens a new report based on a specified cube.

Examples

The following command starts PowerPlay and the Inventory cube (inventry.mdc):
C:\COGNOS\PWRPLAY.EXE inventry.mdc

The following command starts PowerPlay and the Inventory cube (inventry.mdc) that exists in the 
c:\reports folder:
C:\COGNOS\PWRPLAY.EXE C:\reports\inventry.mdc
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Remote Cube Name
The ppdsremote;<server>;<cube>[;<timeout>] command opens a remote cube on a PowerPlay 
server, where

• ppdsremote indicates that you want to open a remote cube

This entry must always be "ppdsremote."

• server identifies the PowerPlay server on which the cube has been added

• cube identifies the specific cube on the server

The name must be the label by which the cube is identified on the server.

• timeout specifies the server timeout

This entry is optional.

Example

The following command starts PowerPlay and opens the Inventory cube on the Accounts server 
with a timeout of 60 seconds:

C:\COGNOS\PWRPLAY.EXE ppdsremote;accounts;inventory;60

Report Name
The report_name option opens the specified report.

Examples

The following command starts PowerPlay and opens a report named Year-End:
C:\COGNOS\PWRPLAY.EXE year-end.ppr

The following command starts PowerPlay and opens the Year-End report that exists in the 
c:\reports folder:
C:\COGNOS\PWRPLAY.EXE C:\reports\year-end.ppr
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Appendix B: Customize PowerPlay

This appendix covers

� Why Customize PowerPlay

� Set Your Preferences

� Create a Menu

� Change Buttons on the Toolbar 

� Set Up a Launch Button

� Customize the Dimension Viewer Toolbox

� Distribute Custom Menus and Toolbars

Why Customize PowerPlay?
By customizing your PowerPlay application so that it suits your everyday reporting needs, you 
can save valuable time for yourself and other users in your organization.

Set Your Preferences

There are many options you can set using the Preferences dialog box. For example, you can 
choose which type of report, Reporter or Explorer, to open by default every time you create a 
new report.

Create a Menu

You can add or remove menus and submenus. You can also add or remove commands, separator 
lines, and macros.

Change Buttons on the Toolbar

You can add or remove buttons and spaces from a toolbar. You can hide or show toolbars, delete 
custom toolbars, or return all toolbars to their original settings. For example, you can create a 
toolbar that contains only the buttons you like to use. Then, you can drag it to any position on 
the screen.

Set Up a Launch Button

You can add Launch buttons to a toolbar to start another application or run a macro from within 
PowerPlay. For example, you can set up a button that automatically starts Microsoft Excel. You 
can set up a maximum of ten Launch buttons. Once they are set up, you can edit them.

Customize the Dimension Viewer Toolbox

You can choose which buttons to show in the dimension viewer toolbox. For example, you can 
show the three buttons you use most often.

You can also choose where to position the toolbox. For example, you can position the toolbox on 
the right side of the dimension viewer at all times.

Distribute Custom Menus and Toolbars

You can distribute custom menus and toolbars to other PowerPlay users. For example, you can 
distribute menus that contain only the commands that your department uses.
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Set Your Preferences
You can customize your PowerPlay environment in many ways. The Preferences dialog box 
contains tabs to customize the settings for all new reports.

Use the To

Alignment tab Set the row label, column label, and number 
alignment.

Dimensions tab Show or hide the dimension line, share the 
dimension line, show or hide the first or last 
buttons, set the number of dimensions, and set 
the location of the dimension line.

Directories tab Set the locations for cubes, reports, macros, and 
menus.

Display tab Set the display type, the display options, the 
default font for the legend, whether to show or 
hide the legend, and whether to show or hide 
the preview window in the Display Options 
dialog box.

Font tab Set the default font, style, size, overline or 
underline, color, and effects.

Format tab Select from the preset formats and set the 
number of decimal places to use (0-9).

Options tab Turn data retrieval on or off, intersect 
categories, show the View Modes toolbar, set 
how many entries to show in the most recently 
used list, set a limit on the number of times the 
Undo command can be used, and set default 
sensitivity for automatic exceptions.

Page Defaults tab Set the font, size, color, and content for a 
default title, header, or footer.

Palette tab Set the display colors and patterns, customize 
colors, show colors as patterns, and reset to 
default colors and patterns.

Patterns tab Select a pattern and a foreground and 
background color.

Query tab Set the location of the Impromptu report or 
another application for drill through from 
PowerPlay.

Rank tab Determine the settings for the Rank button on 
the toolbar. You can set the number of 
categories to rank and choose whether to rank 
the top or bottom number, select the rank 
sequence, sort the rank in ascending or 
descending order, and automatically re-rank.

Sort tab Determine the settings for the Sort button on 
the toolbar. You can set the row, column, and 
layer sort order as well as the automatically re-
sort option.
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Create a Menu
You can create your own menus and add the commands you need. When you change the default 
menus or create new ones, the changes are stored in an .mnu file, which is updated each time 
you make a change.

Example

You are in charge of setting up the PowerPlay application for others in your government 
department. As your users distribute reports often, you would like to create a new menu called 
Distribute that contains the Send, Publish As HTML, and Publish As Briefing Book commands.

Steps

1. From the Tools menu, click Customize Menus.

2. Click the Add SubMenu button.

3. In the Submenu Name box, enter a name for the new menu.

4. Do one of the following:

• To add a menu, select the Add at Top Level check box.

• To add a submenu, clear the Add at Top Level check box.

5. Click OK.

The menu or submenu is added.

6. In the Categories box, click a category.

The selection of commands changes depending on the currently selected category. For 
example, click File to choose from the commands found in the File menu.

7. With the menu highlighted, click a command, and then click Add Menu Item.

8. Repeat steps 6 and 7 until you have added all the commands you want and click OK.

Note
• The Screen Help button does not appear on the toolbar by default. If you use screen help, you 

must customize your toolbar to add it.

Tips
• To organize a menu, add a separator line between groups of related commands.

• To remove a menu, remove the .mnu file from your directory. The next time you open 
PowerPlay, the default menus are restored.

• To eliminate changes that you made, click the Default button to restore the default menus.

• To add a macro to a menu, click the Macro button, and then click a macro from the list.

Startup tab Set the default report type for creating reports, 
maximize the report and the application when 
PowerPlay starts, and determine whether or not 
the Welcome dialog box will show.

Suppress tab Suppress zero values, values resulting from 
division by zero, missing values, and overflow 
values.

Use the To
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Change Buttons on the Toolbar
You can change the buttons on an existing toolbar or add buttons to a custom toolbar. You can 
also remove buttons from any toolbar. 

Example

You are in charge of imports for a governmental department. You regularly distribute reports to 
offices in Britain, which requires that you convert your reports to British pounds. You want to 
customize your PowerPlay toolbar to include the Currency button.

Steps

1. From the Tools menu, click Customize Toolbars.

2. If you want to create a new custom toolbar, click New, choose a name and an initial location 
for the toolbar, and then click OK.

3. Drag the buttons you want to appear from the Available Buttons box to the toolbar.

Use the Categories box to change the selection of buttons. For example, click File to show 
only those buttons found in PowerPlay' File menu.

4. If you want to remove a button from an existing toolbar, drag and drop it off of the toolbar 
while the Customize Toolbars dialog box is open.

5. Click Save.

The changes you make are stored in the Ppcustom.ini file and remain in effect for your 
current PowerPlay session.

Tips
• To add a space between buttons, add a Separator button.

• To return to the original settings, click Reset. New buttons are not removed.

• To share custom toolbars with another user, give a copy of your Ppcustom.ini file to the other 
user. 

For more information about distributing custom menus and toolbars, see "Distribute Custom 
Menus and Toolbars" on page 69.

Set Up a Launch Button
You can add up to ten Launch buttons to your custom toolbar. Each button can be configured to 
run a different application or macro from within PowerPlay.

Example

You are the manager of a government department. You keep the data source files for your 
PowerPlay reports in Microsoft Excel spreadsheets. While reviewing your PowerPlay reports, you 
want to look at your data source files. You customize your toolbar to launch Excel directly from 
PowerPlay.

Steps

1. From the Tools menu, click Customize Toolbars.

2. Drag the Launch button to a toolbar.

3. Click Close.

4. Click the Launch button on the toolbar.

5. In the Description box, type a name for the Launch button.

The name appears when you pause the pointer over the button.
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6. Do one of the following:

• To run an application, click the Run Application option button and type the name of the 
.exe file.

• To run a macro, click the Run Macro option button and type the name of the .mac file.

7. If you want to minimize PowerPlay when you launch the application or macro, select the 
Minimize PowerPlay check box.

8. If you want to specify what to copy to a new application, from the Copy to Clipboard box, do 
one of the following:

• To copy everything that is selected in the report to the Clipboard, click Selections.

• To copy the entire report to the Clipboard, click Report.

You can use the Clipboard only when running another Windows application. You can't copy 
information from the Clipboard to a DOS application.

9. In the Button Icon box, do one of the following:

• To keep the default Launch button icon, click the Use Toolbar Icon option button.

• To use the icon that comes with the application, click the Use Application Icon option 
button.

• To locate and select a different icon, click Browse.

10. Click OK.

Tip
• To change the settings of an existing Launch button, hold down the Ctrl key and click the 

Launch button. Then make the changes and click OK.

Customize the Dimension Viewer Toolbox
You can customize the buttons that appear in the dimension viewer toolbox. You can also choose 
to position the toolbox on the left, right, top, or bottom of the pane.

The following toolbox buttons are only available for only Explorer reports:

Click the To

Replace the rows with the selected categories.

Replace the columns with the selected categories.

Replace the layers with the selected categories.
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The following toolbox buttons are available for only Reporter reports:

The following toolbox buttons are available for both Explorer and Reporter reports:

Click the To

Add the selected categories as rows.

Add the selected categories as columns.

Add the selected categories as layers.

Show the average of the selected categories in a new 
category.

Show the values of the selected categories as a 
percentage of their higher-level category.

Show the sum of the selected categories in a new 
category.

Add categories at the next level down from the 
selected category.

Add all categories at the lowest level from the selected 
category.

Show the selected categories as new individual 
categories in the report.

Show the intersection between two categories.

Preserve parent/child relationship when nesting levels 
from a dimension.

Open the Advanced Subset dialog box where you can 
create an advanced subset definition.

Open the Parentage dialog box where you can create 
a level subset definition.

Click the To

Filter data using the selected category.

Switch between short and long versions of the 
category names.

Open the Number Format dialog box, where you can 
format the measures in your report.

Open the Find In Cube dialog box where you can 
create a find-in-cube subset definition.
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Example

You only use the long names for the categories in your reports, so you want to remove the Short/
Long Names button from the toolbox.

Steps to Customize the Toolbox

1. Right-click the toolbox and click Customize.

2. Do one the following:

• To add a new button, click it in the Available Buttons box, and then click Add.

• To remove a button, click it in the Toolbox Buttons box, and then click Remove.

• To reset the toolbox to the default settings, click Reset.

3. If you want to change the order of the buttons, click an enabled button, and then click the 
Move Up or Move Down button until the button is positioned where you want.

4. If you want to add a space before a button in the toolbox, click an enabled button, and then 
add a Separator button. 

5. Click OK.

Steps to Change the Position of the Toolbox

1. Right-click the toolbox and click Location.

2. Click one of the four docking positions.

Distribute Custom Menus and Toolbars
You can distribute frequently used menu commands that you have stored in a custom menu. You 
can also distribute a custom toolbar. Menus are stored in the Menuset.mnu file and toolbars are 
stored in the Ppcustom.ini file.

Example

You are the director of a government department that oversees transportation policy. You have 
worked closely with your systems analyst to build customized menus and toolbars that suit your 
departmental needs. You can distribute these menus and toolbars to others in your department.

Steps

1. To distribute custom menus, give a copy of your Menuset.mnu file to the other user.

2. To distribute custom toolbars, give a copy of your Ppcustom.ini file to the other user.

The Menuset.mnu and Ppcustom.ini files must be stored in the Windows folder.

Notes
• You must restart PowerPlay to see the new menus and toolbars.

• If other users have a custom toolbar with the same name as a custom toolbar you've 
distributed, their custom toolbar is replaced by your toolbar.

• If you have customized your menus and renamed your Menuset.mnu file, you will not see the 
new menus if you are given a new Menuset.mnu file. Delete your .mnu file and then in the 
Customize Menus dialog box, click Load to load the new menu file.

Tip
• To disable the custom menus, delete the Menuset.mnu file or move it to another folder.
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This appendix covers 

� Specifications

Specifications

Attribute Limit

Bitmap size Limited only by available memory

Color Settings (blue, green, red) Minimum: 0

Maximum: 255

Hue (setting for colors) Minimum: 0

Maximum: 239

Largest allowed negative number Defined in the cube

Largest allowed positive number Defined in the cube

Luminosity (setting for colors) Minimum: 0

Maximum: 240

Margins for the page Determined by current printer 
settings

Maximum limit of bars in a display 
(without scrolling)

500

Number of categories in a report 
(rows, columns, or layers)

The limit for the number of 
categories is 6,442,450,940. While 
this is possible, depending on 
your computer's memory, you 
may find that 100,000 is a more 
reasonable limit.

Number of characters for the 
location and filename of the 
picture added to the background 
of a display

Maximum: 126

Number of characters in a category 
label

255

Number of colors available Limited by the number of colors 
supported by your monitor or 
printer

Number of digits in an operand 
(add, subtract, multiply, divide, 
percent, maximum, minimum, 
average, exponentiate)

11

Number of dimensions in the 
dimension line

255
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Number of displays in a report Limited only by available memory

Number of files in the Recent File 
list (File menu)

9

Number of fonts per report Limited by available memory and 
by the number of fonts supported 
on your system

Number of open reports Limited only by available memory

Number of nested category levels Unlimited

Number of toolbars 20

Number of Undo Actions Limited to between 5 and 5,000 as 
specified in the Options tab 
(Preferences dialog box)

Saturation (setting for colors) Minimum: 0

Maximum: 240

Smallest allowed negative number Defined in the cube

Smallest allowed positive number Defined in the cube

Attribute Limit
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Symbols
.cub files

saving, 44
.ppx files

saving, 37

-A-
adding

advanced subset definitions to a report, 33
extra detail in a cube, 57
find-in-cube subset definitions to a report, 33
launch button to toolbar, 66
nested categories, 8
parentage subset definitions to a report, 33

advanced subset definitions
creating, 25, 28, 30, 31
deleting, 33
editing, 33
running, 32

allocating
measures, 53

alternate drill-down paths, 56
automatic

ranking, 17
report updating, 25
sorting, 17

-B-
blanks

inserting rows or columns, 15
showing zeros as, 16

breaking
linked objects, 50
subsets, 35

briefing book pages
publishing reports as, 41

-C-
calculations

on nested categories, 11
on subsets, 34
setting up as measures in a cube, 54

categories
changing cube, 55
drill-down paths, 28, 30, 31
shared, 56
special, 56

changing
available currencies, 58
buttons in the dimension viewer toolbox, 67
buttons on the toolbar, 66
categories in a cube, 55, 56
descriptions in cube, 57
drill-down paths, 56
drill-through paths, 57
linked objects, 49
measures, 53, 54
structure of a cube, 55
summary labels, 14

command-line options, 59
cube, 60, 61
Explorer report, 60
no title screen, 60
report name, 61
Reporter report, 60

contacting
Cognos, v

copyright, ii
creating

advanced subset definitions, 28
briefing book pages, 41
find-in-cube subset definitions, 27
HTML reports, 39
menus, 65
nested reports, 8
parentage subset definitions, 26
standard reports, 25
subset definitions, 25
subsets, 33

crosstab gridlines
hiding, 15
showing, 15

crosstabs
indented 1 layout, 12
indented 2 layout, 13
ranking, 21
standard layout, 12

cubes
adding extra detail, 57
changing categories, 55, 56
changing currencies, 58
changing descriptions of data, 57
changing drill-down paths, 56
changing drill-through paths, 57
changing measures, 53, 54
changing the structure, 55
command-line options, 60, 61
local, 24
refreshing sub-cubes, 43, 46
remote, 24
saving a portion of, 44
saving sub-cubes, 44
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currency
changing, 58

-D-
deleting

subset definitions, 33
subsets, 35

deployment options
setting in reports, 38

dimension line
sharing, 23

dimension viewer
customizing the toolbox, 67

distributing
custom menus and toolbars, 69

distributing reports
as briefing book pages, 41
as HTML, 39, 40
in printed format, 42
in Upfront, 39
saving as .ppx files, 37
saving as PDFs, 38
saving portable reports, 37
setting prompts, 38
via email, 42

divisions by zero
showing as blank cells, 16

Documentation Roadmap, v
drilling down and up

alternate paths, 56
nested categories, 10

drilling through
to Impromptu, 57
to other cubes, 57
to transaction-level details, 57

drop zones
adding nested categories, 8
long bar, 8
short bar, 8

-E-
editing

embedded objects, 51
linked objects, 48
subset definitions, 33

email address
documentation comments or questions, v

emailing
reports, 42

embedding
objects, 47, 50

Explorer reports
command-line options, 60

exporting
reports, 52

-F-
find-in-cube subset definitions

creating, 27
deleting, 33
editing, 33
running, 32
using wildcards, 28

finding
data in cubes, 31

fitting
reports on one printed page, 42

full category swapping
nested categories, 11

-G-
gridlines

hiding, 15
showing, 15

-H-
hiding

crosstab gridlines, 15
summaries, 13

highlighting
subsets, 34

HTML
files, 40
publishing reports as, 39

-I-
Impromptu

drilling through to, 57
indenting

summary labels, 14
inserting

blank rows or columns, 15
intended 1 layout, 12
intended 2 layout, 13

-L-
launch button

setting up, 66
layouts

indented 1, 12
indented 2, 13
standard, 12

levels
definition, 7

limits
product, 71

linking
objects, 47, 48

local cubes
using report templates, 24

-M-
manual

ranking, 17
sorting, 17

measures
allocating, 53
changing, 53
setting up calculations, 54
that count records, 54

menus
creating, 65
distributing custom, 69

missing values
showing as blank cells, 16

moving
nested categories, 9
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-N-
nested categories

adding, 8
drilling down and up, 10
full category swapping, 11
moving, 9
partial category swapping, 11
performing calculations, 11
ranking, 21
removing, 9
selecting, 9
sorting, 22

nested crosstabs
changing summary labels, 14
creating, 8
definition, 7
hiding gridlines, 15
hiding summaries, 13
indenting summary labels, 14
layout, 12, 13
ranking, 21
showing gridlines, 15
showing summaries, 13
sorting, 22

NewsBoxes
in Upfront, 39

NewsItems
in Upfront, 39

no title screen
command-line options, 60

-O-
objects

breaking links, 50
changing links, 49
editing embedded, 51
editing links, 48
embedding, 47, 50
linking, 47, 48
updating links, 49

offline
working, 43

-P-
parent categories

creating subsets, 30
parentage subset definitions

creating, 26
deleting, 33
editing, 33
running, 32

partial category swapping
nested categories, 11

PDFs
saving, 38
setting options, 38

periods of time
using in reports, 55

Portfolio
briefing book pages, 41

PowerPlay
product specifications, 71

preferences
setting, 64

printing
reports, 42
reports on one page, 42

prompts
setting in reports, 38

publishing
as briefing book pages, 41
as HTML, 39
to Upfront, 38, 39

-Q-
questions about this book, v
Quick Tour

introduction to PowerPlay, v

-R-
ranking

automatically, 17
identical values, 20
manually, 17
nested categories, 21
nested crosstabs, 21
reports, 19
ties in a report, 20

ranking vs. sorting, 17
refreshing

sub-cubes, 43, 46
remote cubes

saving as sub-cubes, 44
using report templates, 24

removing
nested categories, 9
subsets, 35

report name
command-line options, 61

Reporter report
command-line options, 60

reports
distributing HTML, 40
exporting, 52
printing, 42
templates, 23
updating automatically, 25
using as templates, 24
using sub-cubes, 45

running
subset definitions, 32

-S-
saving

.cub files, 44

.ppx files, 37
a portion of a cube, 44
in other formats, 52
PDF files, 38
portable reports, 37

selecting
nested categories, 9

sending
reports via email, 42

setting up
launch button, 66
preferences, 64
report templates, 23

shared categories, 56
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sharing
dimension line, 23

showing
crosstab gridlines, 15
summaries, 13
zero values as blanks, 16

sorting
automatically, 17
manually, 17
nested categories, 22
nested crosstabs, 22
reports, 21

special categories, 56
specifications

product, 71
standard layout, 12
standard reports

creating, 25
definition, 25

structure
changing cube, 55

sub-cubes
refreshing, 43, 46
saving, 43, 44
setting a report to use, 45

subset calculations
creating, 34

subset definitions
adding, 33
creating, 25
definition, 25
deleting, 33
editing, 33
find-in-cube, 27
parentage, 26
running, 32

subset viewer, 32
subsets

breaking, 35
creating, 33
creating advanced subsets with name restrictions, 31
creating advanced subsets with parent restrictions, 30
creating advanced subsets with value restrictions, 31
creating an advanced subset definition, 28, 30, 31
deleting, 35
highlighting, 34
removing, 35
viewing, 34

summary labels
changing, 14
indenting, 14

swapping
full category, 11
nested categories, 11
partial category, 11

-T-
templates

opening local cubes, 24
opening remote cubes, 24
setting up, 23
using reports as, 24

time dimensions
using in reports, 55

toolbars
changing buttons, 66
distributing custom, 69

toolbox
changing buttons, 67
customizing, 67

-U-
updating

automatically, 25
object links, 49
reports, 25

Upfront
publishing to, 39
setting prompts in reports, 38

using
different time periods, 55
wildcards, 28

-V-
values

restricting in a subset, 31
viewing

subsets, 34

-W-
wildcards, 28
working offline

overview, 43

-Z-
zero values

showing as blank cells, 16
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