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Chapter 1: About the Agent 
ABOUT THE AGENT
Iron Mo
The following topics describe the functions of the Agent:

Agent overview

Retrieve and restore features

Account recovery

Account Management Website

Terminology
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Agent overview
6 Co
The Agent is the application on your computer that manages the backup and retrieval of your files. To back up 
your files, the Agent uses the Internet or a local intranet to connect to the Data Center. The Data Center stores 
your backups until you must retrieve one or more of them. At that time, the Agent can connect with the Data 
Center and download the appropriate files.

Under most circumstances, you do not need to monitor the Agent after you or an administrator install and 
register it. If you have an open network connection and your computer is powered on, the Agent can perform 
backups automatically, even at times when you are not working on your computer (for example, during the 
middle of the night).

Note

Remember that the Agent provides data protection and not long-term archival storage. Files 
that you delete from your computer are marked for deletion from the Data Center server 
where your backed-up files are stored. The backed-up copies of your locally deleted files are 
kept on the server for a limited time period, and are unavailable for retrieval after that time 
period. Your system administrator sets the retention period for these deleted files.
Agent configuration

An Agent configuration consists of the following components:

The version and language information for the Agent

Settings that determine how the Agent behaves on your computer and which Agent permissions you have.

Settings that determine whether a link to the Account Management Website appears in your Agent 
application window and which permissions you will have in that Website.

A rule set that determines how the Agent selects files for backup. 

Your system administrator creates the Agent configuration and modifies it as needed. If you have permission, 
you can edit some Agent configuration information—such as the backup schedule—from the Agent window. 
File security

When the Agent and Data Center transmit files to each other, encryption keys keep the data secure. The Agent 
encrypts your files before it backs them up. The files remain encrypted while they are stored at the Data Center. 
When you retrieve backed–up files, the Agent receives the files in their encrypted format. The Agent then 
decrypts the files after they are on your computer.
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Retrieve and restore features
Iron Mo
The Agent provides the following retrieve and restore features:

Basic file retrieval. 

If you lose one or more files on your computer, but the rest of your computer functions, you can retrieve the 
missing files from backed up copies at the Data Center.

File retrieval using MyRoam.® 

If you need to retrieve files that you previously backed up, and the computer you are using does not have an 
Agent installed, you can log on to Account Management Website and use the MyRoam application to retrieve 
files. For instructions, see the MyRoam Help.

Agent account recovery.

If your computer crashes or becomes corrupt, you have to reinstall your Agent and retrieve lost files. If you 
have to reinstall your Agent, do not create a new account. Instead, log on to the Account Management 
Website and use the Reinstall Agent feature.

Note

Remember that the Agent provides data protection and not long-term archival storage. Files 
that you delete from your computer are marked for deletion from the Data Center server 
where your backed-up files are stored. The backed-up copies of your files remain on the 
server for a limited time period, and are unavailable for retrieval after that time period. Your 
system administrator sets the retention period for deleted files.
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Account recovery
8 Co
If you experience a system crash or replace your computer hard drive, you might have to reinstall the Agent 
software and direct it to use your existing Agent account. Otherwise, you cannot access the files that you 
previously backed up. Use the Account Management Website to reinstall an Agent.

After you reinstall the Agent and recover your account, you can retrieve missing files.

Note

Before you use the reinstalled Agent to back up files, make sure that you retrieve all 
necessary files. The reinstalled Agent can back up only the files that are on your computer. 
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Account Management Website
Iron Mo
The Account Management Website is a Web-based application that lets you manage your account. 

You can gain access to the Account Management Website in the following ways:

In the Agent window, choose Tools > Manage Account Online.

From the Agent Status icon on the Dock, choose Manage Account Online.

In a Web browser, enter the Account Management Website URL.

The Account Management Website can include all or some of the following features: 

Account registration and installation

Account recovery

Account summary and history

MyRoam® access

Account profile editing

Access to your other accounts

Support information

The Account Management Website includes the following changes:

The Order Media option is not available.

The View menu includes simple and advanced views.

For more information, see the Account Management Website Help.
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Terminology
10 Co
Agent

The Agent is the software application installed on your computer that manages the backup and retrieval of your 
files. The Agent uses the Internet or local intranet to connect to a facility called the Data Center to back up your 
files. The Data Center stores your backups until you need to retrieve one, many, or all of them. At that time, the 
Agent connects with the Data Center and downloads the files that you need.

backup set

The backup set consists of the files on your computer that the Agent backs up. Your system administrator 
determines which files are included in the backup set and whether you are permitted to change your backup set. 
The Backup Set shows your backup set.

Data Center

The Data Center is the set of servers that store your backed-up files. The Agent connects to the Data Center to 
back up or retrieve files.

exclusions

A rule category that the Agent uses to identify files and folders to omit from the backup set.

file selection icons

The following icons indicate whether a folder or file is selected for backup. These icons appear in the Backup Set 
and Retrieve s. If a checkbox is unavailable, the checkbox is locked and you cannot change its selection status.

locked rules

A locked rule determines which files the Agent selects for backup. You cannot edit or override locked rules. 

rule set

A rule set is a collection of rules that the Agent uses to select files for backup. Each Agent has a single rule set. A 
rule set consists of volume exclusions, locked rules, and unlocked rules. If you have permission to edit your 
backup set, you can add user-created rules to the rule set. Your system administrator creates the rule set, changes 
it, and determines whether you can add user-created rules. 

Icon Description

All files and subfolders in a folder are selected, or a file is 
selected.

Some of the subfolders and files in a folder are selected. 
Expand the folder and its subfolders to view which files are 
selected.

All files and subfolders in a folder are not selected, or a file 
is not selected.

Files are selected for backup because of a locked rule. You 
cannot edit or override locked rules.
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Iron Mo
unlocked rules

An unlocked rule determines which files the Agent selects for backup. You cannot edit an unlocked rule. 
However, you can override an unlocked rule if you have permission to edit your backup set. 

user-created files

A rule category for user-created data files, such as spreadsheets and documents. The Agent uses these rules to 
identify data files to select for backup.

user-created rules

A user-created rule determines which files the Agent selects for backup. You can add user-created rules when 
you select files in the Backup Set, or you can add a user-created rule from the Advanced Rules window. 

User-created rules are preserved if a system administrator makes changes to the rule set for your Agent. 
However, because the Agent applies user-created rules after volume exclusions and locked rules, your backup 
set might change if a system administrator changes the rule set for your Agent.

volume exclusions

A volume exclusion is a volume that the Agent excludes from backup. If you exclude a volume from backup, the 
volume and its files do not appear in the Backup Set, and you cannot select these files for backup. Automatic 
volume exclusions include removable drives, network volumes, and case-sensitive volumes. Also, you can create 
volume exclusions by deselecting the checkbox next to a volume that is listed in the Advanced Rules window.

wildcard characters

Characters you can use to find files for retrieval and to create rule definitions. 

* Use this character to match any number of characters. For example, entering *.doc finds any file that 
has a file extension of .doc. Entering *2006* finds any file whose name includes the text 2006. 

? Use this character to match a single character. For example, entering ab?.doc finds abc.doc and 
aby.doc.
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GETTING STARTED
Iron Mo
The following topics provide useful information for new users:

Using the Agent for the first time

Navigating in the Agent

Using the Agent Dock icon

Selecting and deselecting folders and files

Summary pane information

Important account information

Performing your first backup
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Using the Agent for the first time
14 Co
The Agent includes an application window that you can use to perform the following tasks: 

Start a backup.

Retrieve files.

View information about the last backup.

View and change the backup set.

View and change the backup schedule.

View messages sent to the Agent.

View a history of Agent events.
About your first backup

Perform your first backup as soon as possible. During the first backup, the Agent backs up all files in your backup 
set to a Data Center. The first backup can take several hours to complete, depending on the number of files in your 
backup set and the connection speed on the network. Subsequent backups are smaller and faster because the 
Agent backs up only new files and changes to previously backed–up files.
Backup methods

Your Agent can back up files automatically according to a pre-set schedule, or it can require you to initiate 
backups manually. For your first backup, you might want to start the backup manually, rather than wait for a 
scheduled automatic backup.
Performing your first backup

To start the first backup, click Back Up Now from either the Summary pane or Backup Set pane. For more 
information about how to perform your first backup, see Performing your first backup. For information about how 
to verify the status of your first backup, see Monitoring backup progress.

If your Agent is configured to display pop-up messages, after the backup completes, the backup outcome appears 
in a pop-up window. To see more detailed information about the backup, click View Details. To close the pop-
up window, click Close.

If the backup outcome does not appear in a pop-up window, you can view the backup outcome in the Last 
Backup section of the Summary pane and the History pane.
File security

The Agent encrypts files so that they are protected during transmission between the Agent and the Data Center. 
The files remain encrypted while they are stored at the Data Center. When the Agent retrieves backed–up files, 
it receives the files in their encrypted format. The Agent then decrypts the files after they are it retrieves them to 
your computer.
Performing your first backup

Changing your backup schedule

Backing up files manually
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Navigating in the Agent
Iron Mo
The following table tells you how to navigate the Agent to perform common tasks:

Task Navigation

View a summary of the last backup, the 
backup schedule, and the most recent 
message sent to the Agent.

Click the Summary tab.

View detailed statistics for the most 
recent backup.

In the Last Backup section of the 
Summary pane, click View Details.

Change your backup schedule.

Your administrator determines whether 
you can perform this task.

Perform one of the following tasks:

In the Backup Schedule section of the 
Summary pane, click the Backup 
Schedule link.

Choose Tools > Backup Schedule.

View the most recent messages sent to the 
Agent.

 In the Messages section of the Summary 
pane, click Show all messages.

View files that the Agent backs up, and 
edit the backup set.

Your administrator determines whether 
you can perform this task.

Click the Backup Set tab.

Retrieve files that the Agent previously 
backed up.

Click the Retrieve tab.

View a history of Agent events. Click the History tab.

Edit your Agent profile Click Tools > Edit Profile.

Start a backup manually. Perform one of the following tasks:

Choose File > Back Up Now.

In the Summary pane, click Back Up 
Now.

In the Backup Set pane, click Back Up 
Now.

From the Dock menu, choose Backup 
Now.

Cancel a backup that is in progress. Perform one of the following tasks:

In the Agent window, click Cancel.

From the Dock menu, choose Cancel 
Backup.

Toggle between Simple and Advanced 
view in the Backup Set and Retrieve tabs.

Perform one of the following tasks:

Choose View > Advanced.

Choose View > Simple.
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16 Co
Edit the Agent rules.

Your administrator determines whether 
you can perform this task.

Choose Tools > Advanced Rules.

Change the backup mode and FileVault 
settings.

Choose Preferences > Backup.

Choose Preferences > FileVault.

Use the Account Management Website to 
view and manage the Agent account.

Your administrator determines whether 
the Account Management Website is 
enabled.

Choose Tools > Manage Account Online.

View the Agent Help. Complete one of the following tasks:

To view the entire help system, 
choose Help > Agent Help.

To view the help topic for the open or 
window, click the Help icon.

View the software version and your 
account number.

Complete one of the following tasks:

In the Agent application menu, 
choose About.

From the Dock menu, choose About.

Close the Agent window. Complete one of the following tasks:

From the Agent application menu, 
choose Quit.

From the Dock menu, choose Quit.

Task Navigation
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Using the Agent Dock icon
Iron Mo
The Agent icon always appears on the Dock unless you remove it.

Use the Agent icon to open the Agent window and view the status of the Agent during backup and retrieval, and 
to open the Agent Dock menu.
Opening the Agent window

To open the Agent window, click the Agent Dock icon.
Viewing the Agent Dock icon

The appearance of the Agent Dock icon indicates whether a backup or retrieval is in progress, or the outcome of 
the last backup. The following tables describes each variation of the Agent Dock icon:

Agent Status Icon Appearance Indicates

No backup has been performed since this 
Agent was installed, and no backup or file 
retrieval is in progress.

A backup is in progress.

A file retrieval is in progress.
Using the Agent Dock menu

When the Agent is open, you can gain access to the Dock menu options from the Agent Dock icon. To open the 
Dock menu, right-click the Agent Dock icon.

The following table describes the Dock menu options: 

Menu item Task

Back Up Now Start a manual backup.

Cancel Backup Cancel a backup.

About View Agent version information.

Manage Account Online Manage your account using the Account 
Management Website, if it is enabled for 
your account.
Monitoring backup progress

Backing up files manually
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Selecting and deselecting folders and files
18 Co
If you have permission to edit your backup set, you can click the checkboxes that contain file selection icons to 
select and deselect folders and files.

To select folders and files in either the Backup Set or Retrieve panes, click the checkbox next to the item.

To deselect folders and files in either the Backup Set or Retrieve panes, deselect the checkbox next to the item.

Note

In the Backup Set pane, you cannot select or deselect locked folders or files. Your system 
administrator has determined the status of the locked folders or files, and you cannot use the 
Agent window to change that designation.
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Toggling Simple and Advanced view
Iron Mo
The Backup Set and Retrieve tabs show files in either Simple view or Advanced view. 

Simple view shows files and folders as they appear in Finder. 

Advanced view shows files and folders that appear in Finder, and hidden files and folders.
To toggle between Simple and Advanced view, complete the following steps:

1. Open the Backup Set or Retrieve pane.

2. Perform one of the following tasks:

Choose View > Advanced.

Choose View > Simple.

The view selection is a global setting that applies when you switch from to, after you close and reopen the Agent, 
and after you restart your computer. 
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Summary pane information
20 Co
When you open the Agent application, the Summary pane opens. The following table describes the elements in 
the Summary pane: 

Element Description

Last Backup The outcome of the last backup, the end 
time and date of the backup, and a link to 
view the details history for the backup.

Backup Schedule The automatic backup schedule for your 
Agent. 

If your Agent is not configured for 
automatic backups, you see None 
scheduled.

If you have permission to change your 
backup schedule, your backup schedule 
information includes a link to the Backup 
Schedule window. 

Messages A message generated automatically as the 
result of system activity or sent from a 
system administrator. Your Agent 
receives new messages when it connects 
to the Data Center. 

The Summary pane displays only one 
message. This message is the most 
important or most recently generated 
message. The message also appears as the 
first message in the messages window. 
The message window contains all other 
messages sent to your Agent. To open the 
message window, click the View all 
Messages link. The messages are listed 
chronologically and in order of 
importance. 

Action buttons Back Up Now. Click Back Up Now to 
start a manual backup.
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Important account information
Iron Mo
Record your account number and store it in a secure place away from your computer. You need this information 
to reinstall the Agent and retrieve files. 

You can view your account information at the bottom of the About window.
Password protection

Your system administrator can configure your Agent so that you must enter an account password before you can 
retrieve files. 

If you are a technician, when the Enter Password pop-up window opens before a retrieval, click Advanced, and 
then enter your technician ID and password.
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Performing your first backup
22 Co
After the Agent is installed on your computer, perform your first backup as soon as possible. During the first 
backup, the Agent backs up all files in your backup set to a Data Center. The first backup can take several hours 
to complete. The number of files in your backup set and the connection speed on the network determine how 
long the first backup takes to complete. Subsequent backups are smaller because the Agent backs up only new 
files and changes to previously backed–up files.

Your Agent can back up files according to a pre-set schedule, or it can require that you initiate backups manually. 
For your first backup, you might want to start the backup manually rather than wait for a scheduled automatic 
backup.
To manually start the first backup, complete the following steps:

1. To view the files selected for backup, click the Backup Set tab.

If your Agent lets you edit your backup set, you can change the files that are selected for backup. For more 
information, see Viewing and changing your backup set.

2. To start the backup, perform one of the following tasks:

Click Back Up Now in the Backup Set pane. 

Click Back Up Now in the Summary pane.

Choose File > Back Up Now.

The Backing Up dialog box opens and describes the status of the backup.
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BACKING UP FILES
Iron Mo
The primary task of the Agent is to back up the files that are on your computer. During a backup, the Agent scans 
the hard disk of your computer to locate files that it needs to back up. It then encrypts, compresses, and transfers 
these files to the Data Center. You can retrieve these files from the Data Center if the files become corrupted or 
lost on your computer.

An Agent can back up files of any size. However, if an Agent has a maximum backup set size specified, the 
backup is limited to that size. The Agent’s rule set defines the types of files to back up. The Agent might not back 
up all of the folders and files on your computer. Usually, files excluded from a backup are files that you do not 
need to retrieve or save.
Automatic and manual backups

The Agent can back up files according to a pre-set backup schedule. You can also back up files at any time without 
waiting for the Agent to perform the scheduled backup.

Note

An automatically scheduled backup cannot occur if the computer is in standby or 
hibernation mode.
Backup topics

For more information about backing up files, see the following topics:

The backup set

Changing your backup schedule

Changing your backup options

Managing FileVault passwords

Backing up files manually

Monitoring backup progress

Delaying an automatic backup

Cancelling an automatic backup
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THE BACKUP SET
24 Co
The backup set consists of the files that the Agent backs up. The Agent backs up files based on your schedule or 
when you manually initiate a backup. During the first backup, the Agent backs up all files in the backup set and 
transmits them to the Data Center. During subsequent backups, the Agent backs up only new or changed files in 
the backup set. 

Your system administrator determines which files to include in the backup set and whether you have permission 
to change your backup set. 

To view or change the backup set, open the Backup Set. For more information, see Viewing and changing your 
backup set. To undo changes you made in the Backup Set, see Undoing changes to the backup set.

Another way to change your backup set is to use the Advanced Rules window to add user-created rules. For 
more information, see Managing user-created rules. 
Backup set considerations

When you work with a backup set, keep the following information in mind:

If a drive has a name that contains a comma (,) you cannot exclude the drive from the backup set.  Although 
you can use the Agent interface to deselect the drive from the backup set list, the Agent scans the drive for 
backup regardless of the selection and regardless of whether the files on the drive match rules.

If you remove a file from a backup set, the Data Center deletes the backed-up versions of that file from the 
Data Center server. The Data Center uses its file expiration rules to determine how long to keep backups of 
files that you exclude from the backup set. To ensure that the Data Center always has a recent backup of your 
files, keep the files selected in the backup set.

If you delete a file in the backup set from your computer, the Agent removes the file from the backup set. The 
Data Center eventually deletes the file from the Data Center server. Your system administrator sets the 
retention period for deleted files.

If you add a new file to your computer, your Agent rule set determines whether that file is automatically 
added to your backup set.

The first time the Agent backs up files, it backs up all files that are selected for the backup set. Subsequent 
backups are incremental. The Agent backs up only new files and changes to previously backed-up files.

If your Agent has a maximum backup set size, your Agent receives a warning message when your backup 
set approaches or exceeds its maximum size. For more information, see Backup set maximum size.
CAUTION

Do not include the Time Machine folder in your backup set. If you do, the backup process 
uses all available memory.
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Viewing and changing your backup set
Iron Mo
Use the Backup Set to view which files are in your backup set, and to change your backup set if you have 
permission to do so. The default backup set selections are based on the rule set created by your system 
administrator. 

The Backup Set shows all folders and files on your computer except for removable thumb drives, network 
volumes, and case-sensitive volumes. A checkbox next to a folder or file indicates whether the folder or file is 
selected for the backup set.

Note

You cannot change the selection status of a checkbox if either your Agent does not let you 
edit your backup set, or if the folder or file is locked. A folder or file is locked if a locked 
administrative rule specifies that the folder or file must or must not be backed up. 
To view or change your backup set, complete the following steps:

1. Click the Backup Set tab. 

If this is the first time that you have opened this tab since you started the Agent, the Agent scans the 
computer to compile your backup set. While the Agent scans, you receive a Scanning... message.

When the scan is complete, the Agent displays folders in the left side of the Backup Set pane. 

2. To view the contents of a folder, perform one of the following tasks: 

In the left pane, click the folder name. The contents of the folder appear in the right pane.

In the right pane, double-click the folder. The contents of the folder appear in the right pane.

In the left pane, expand the folder. The subfolders appear beneath the folder.

3. To select all of the files and subfolders for backup, select the empty checkbox next to the folder name. 

A locked subfolder or file might prevent you from selecting all subfolders or files in a folder. If the folder 
contains some locked files, a message window opens to inform you that your change applies only to the 
unlocked files in the folder. To close the message, click Close.

4. To select a specific file for backup, use the left pane to select the folder that contains the file. When the file 
appears in the right pane, select the empty checkbox next to the file. 

5. To remove all the files and subfolders in a folder from the backup set, deselect the checkbox next to the folder. 

A locked subfolder or file might prevent you from deselecting all subfolders or files in a folder. If the folder 
contains some locked files, a message window opens to inform you that your change applies only to the 
unlocked files in the folder. To close the message, click Close.

6. To remove a specific file from the backup set, use the left pane to select the folder that contains the file. When 
the file appears in the right pane, deselect the checkbox next to the file.

Note

If you deselect a file that the Agent previously backed up, you remove it from the backup 
set. Over time, the Data Center deletes excluded files based on file expiration rules. After the 
Data Center deletes a file, you cannot retrieve it at a later time.
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Effects of changing your backup set
26 Co
If you change the files selected in the Backup Set pane, when the Agent performs the next backup, it backs up 
only the selected files. Each file selection you change in the Backup Set pane results in the creation of a new user-
created rule with a source of Backup Set selection. (You can view the user-created rules in the Advanced Rules 
window.) These rules ensure that your changes are saved for the next backup. For information about how the 
Agent uses rules to select its backup set, see How the Agent uses rules during a backup.

If a system administrator changes the rule set for your Agent, your user-created rules are preserved, but new 
volume exclusions or locked rules might override them.
Toggling Simple and Advanced view
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Undoing changes to the backup set
Iron Mo
To undo all of your changes to the backup set since you opened the Agent window, in the Backup Set pane, click 
Undo All Changes. 

The Undo feature removes user-created rules that were added since the Agent window was opened, and restores 
the backup set to its previous state.
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Backup set maximum size
28 Co
If your Agent has a maximum backup set size, that value appears in the status bar of the Backup Set pane. If a 
backup reaches its maximum size, the backup process stops and a message appears in a pop-up window to 
inform you that all of the files were not backed up. Your Agent might also be configured to receive a message in 
a pop-up window if the backup set approaches its maximum size. Messages about the limit for backup set size 
also appear in the Messages section of the Summary pane and in the View History Details pane.

For more information about these error messages, see Backup set size limit messages and Viewing messages in pop-up 
windows.
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Changing your backup schedule
Iron Mo
The backup schedule determines whether your Agent is configured for automatic backup, and if so, the days and 
time period when the automatic backup occurs. You can view your backup schedule in the Backup Schedule 
section of the Summary pane.

You can use the Backup Schedule window to change your backup schedule if your Agent configuration lets you 
do so.
To change your backup schedule, complete the following steps:

1. Complete one of the following tasks:

Choose Tools > Backup Schedule.

In the Backup Schedule section of the Summary pane, click the schedule link.

The Backup Schedule dialog box opens.

2. Select your backup schedule. 

3. Click OK.
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The backup options determine how the Agent behaves when an automatic backup does not start.

You can change your backup options only if your Agent configuration lets you do so.
To change your backup preferences, complete the following steps:

1. From the application menu, choose Preferences.

The Preferences dialog box opens.

2. Click the Backup Set tab.

3. Select your backup options. 

For more information, see Backup Options pane. 

4. Click OK.
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The Agent can back up your FileVault-protected files only under the following circumstances:

You are logged on to the Agent computer.

You are not logged on to the Agent computer, but previously you entered your Mac OS® X account user 
name and password in the FileVault tab. 

The Agent encrypts and securely stores your account password.

If you are not logged on to the Agent computer, and you did not enter your Mac OS® X user name and password 
in the FileVault tab, the Agent does not back up your FileVault-protected files.

If you change your Mac system password, you invalidate the FileVault password in the Agent Preferences. If a 
backup runs while you are logged out, and your FileVault password is not valid, the Agent cannot back up your 
FileVault-protected files. To avoid this situation, update your FileVault password immediately after you change 
your Mac system password.
To enable the FileVault option, complete the following steps:

1. From the application menu, choose Preferences.

The Preferences dialog box opens.

2. Click the FileVault tab.

3. To enable the Agent to back up the contents of your FileVault-protected home folder when you are logged 
out, select Enable the Agent to back up the contents of your FileVault-protected home folder when you 
are logged out.

4. From the Account User Name pop-up menu, choose the user name that is associated with the account that 
you want to protect.

The Agent populates the Account User Name pop-up menu with user names only for accounts that have 
FileVault-protected home folders on the computer.

5. In the Password field, type your Mac OS X user account password.

6. Click OK.
To edit a stored account username and password, complete the following steps:

1. From the application menu, choose Preferences.

The Preferences dialog box opens.

2. Click the FileVault tab.

3. Modify the selected user account name or password. 

4. Click OK.
To disable the FileVault option, complete the following step:

Deselect Enable the Agent to back up the contents of your FileVault-protected home folder when you are 
logged out, and click OK.
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You can start a backup manually at any time, even if your Agent backs up files automatically. A manual backup 
is useful if you must be sure that important information is backed up as soon as possible. For example, if you 
intend to upgrade your system, you might want to manually back up the latest files before you start the upgrade 
so that you can retrieve those files if a problem occurs during the upgrade.
To back up files manually, complete one of the following steps:

On either the Summary or Backup Set pane, click Back Up Now.

Choose File > Back Up Now.

Right-click the Agent Dock icon, and then choose Back Up Now or Back Up and Exit.

The Backing Up dialog box opens and describes the status of the backup.
Monitoring backup progress

Viewing and changing your backup set
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If the Agent window is open and a backup is in progress, or if you open the Agent window while an automatic 
backup is in progress, the Agent shows a backup progress bar and status information on top of the Agent 
window. Some features in the Agent window remain disabled until the backup completes. Other features remain 
enabled while the Agent scans files in the backup set for changed information. Phase 2 in the Phase Description 
table in this topic lists the features that remain enabled.

To monitor the progress of a backup, watch the backup progress bar and messages. 

The progress bar indicates the percentage of completion. The messages tell you which phase of the backup is in 
progress. The following table describes the phases of the backup process:

Notes

During a backup, the Agent Status icon has this appearance: .

Phase Description

1 Synchronizing account information

In this phase, the Agent downloads changes to the Agent Version, Agent Rule Set, 
Agent Settings, and Website Settings. The Agent also receives messages and 
uploads logs. The Agent applies all changes to this backup with the following 
exceptions:

The Agent applies backup schedule changes to the next backup. 

The Agent applies Website Settings changes the next time it either 
synchronizes with the Data Center or restarts.

2 Looking for changes

During this phase, the Agent scans the files in the backup set for changes that 
occurred since the last backup. The progress bar remains at 0% and the number of 
files scanned appears beneath the progress bar.

During this phase, the following features remain enabled:

In the Agent window, Cancel

In the Dock menu, Cancel backup

Help

On the Dock menu and on the Tools menu, Manage account online

About the Agent
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If the Agent loses its connection to the Data Center, it tries to reestablish its connection and displays the following 
message, below the progress bar:

Trying to reestablish connection 

The completed percentage does not change until the Agent reestablishes the connection and the backup 
continues.

3 Backing up files

In this phase, the Agent starts to send the files to the Data Center.

The progress bar indicates the percentage of bytes processed. The messages below 
the progress bar indicate the status of the backup process and the name of the file 
that the Agent is backing up.

The status message indicates the number of files that the Agent has backed up, and 
the number of files that the Agent has yet to back up. 

The file name message includes all or part of the path for the file that the Agent is 
backing up.

4 Synchronizing file structure 

In this phase, the Agent sends information about deleted files to the Data Center. 

5 Synchronizing account information

In this phase, the Agent performs the following tasks:

Downloads additional changes to the Agent Version, Agent Rule Set, Agent 
Settings, and Website Settings.

Installs an upgrade, if one is available.

Finishes the synchronization of local file information with the Data Center, 
receives messages, and uploads logs.

Phase Description
Backup outcome

When a backup completes, your Agent receives a backup outcome message from the Data Center. Backup 
outcome messages appear in the Last Backup section of the Summary pane. However, your system administrator 
also can select to show backup outcomes in a pop-up window.

The Last Backup section includes the following information:

The backup outcome

The end time and date of the last backup 

A View Details link that opens the View History Details window. 

The Backup Outcome pop-up window includes the following buttons: 

View Details — Opens the View History Details window. For more information, see View History Details 
window - Backup window.

Close — Closes the pop-up window.

If applicable, after backup, a message opens in a pop-up window to inform you that have reached or are near 
your backup limit. For information about these message types, see Backup set maximum size. 

You also can view backup outcomes on the History pane.
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Delaying an automatic backup
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When the Agent window is open, an Automatic Backup pop-up window opens five minutes before an automatic 
backup starts. If the Agent window is closed, your system administrator determines whether that window 
appears. 

You can use the Automatic Backup window to delay a backup instead of letting it start at the scheduled time. For 
example, if you use the Agent to change a backup set, retrieve files, or view Agent history, you might not want 
to run a backup at the same time.
To delay the start of an automatic backup, complete the following steps:

1. When the Automatic Backup window opens, click Delay Backup.

The Delay Backup dialog box opens.

2. Specify a one of the following postponement time periods:

5 minutes

10 minutes (default)

15 minutes

30 minutes

1 hour

3. Click OK.

The Agent shows the next backup time based on the time period that you select. If you delay the backup for 
more than five minutes, the Automatic Backup window opens again five minutes before the backup starts.

Note

If you do not select an Automatic Backup option within five minutes, the backup starts.
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You can cancel a backup while it is in progress or shortly before it starts. Depending on when you cancel the 
backup, the Agent might be able to back up some of the files in the backup set.

When the Agent window is open, the Agent shows an Automatic Backup pop-up window for five minutes before 
an automatic backup starts. Your system administrator determines whether the pop-up window opens when the 
Agent window is closed.
To cancel a backup that is in progress, complete the following steps:

1. Perform one of the following tasks:

In the Agent window, click Cancel.

From the Dock menu, choose Cancel Backup.

The Agent shows a cancel message while it stops the backup.

2. Check the Agent history for this event to determine whether the Agent backed up some files before you 
canceled the backup.
To cancel an automatic backup before it starts, complete the following steps:

1. In the Automatic Backup window, select Cancel backup.

The Agent shows a cancel message while it stops the backup.

2. Click OK.
Agent History overview

Viewing History
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RETRIEVING FILES
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If you lose files or if specific files become corrupt, you can retrieve backed-up copies of the files from the Data 
Center. The Retrieve option lets you retrieve one or more specific files. 

Notes

During a retrieval, the Agent Status icon has this appearance: .
Retrieve overview
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When the Agent retrieves files, it downloads selected files from the Data Center in encrypted format and then 
decrypts them after they are on your computer. The Agent can retrieve files to their original locations on your 
computer or to other destination folders that you specify. By default, the Agent shows the most recent versions 
of files on the Data Center. You can retrieve older versions, if necessary.

Retrieve restores files that do not currently exist or are different from the files currently in the destination folder. 
If an existing file is identical to a file that you select for retrieval, Retrieve does not restore the file. Identical files 
have the same file name, file size, and modification date.

Note

Remember that the Agent provides data protection and not long-term archival storage. Files 
that you delete from your computer are marked for deletion from the Data Center server 
where your backed-up files are stored. The backed-up copies of your locally deleted remain 
on the server for a limited time period, and are unavailable for retrieval after that time 
period. Your system administrator sets the retention period for these deleted files.
Password-protected retrieval

If the Retrieve option is password protected, the Agent behaves in the following ways:

When you click the Retrieve tab, the Agent prompts you to enter your account password. Enter your 
password and click OK.

When a system Administrator clicks the Retrieve tab of your Agent, the Agent prompts the Administrator 
to enter the account password or click Advanced. The system Administrator must enter a technician ID and 
password, and then click OK. The technician ID must have the Access User’s Data permission turned on.

If you enter three consecutive incorrect passwords, your account password becomes locked and you cannot gain 
access to the Retrieve tab or the Account Management Website for 20 minutes. A system administrator can reset 
a locked account password. 
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By default, the Retrieve tab shows the most recent versions of each file or folder that are backed up on the Data 
Center. To see other versions of backed-up files, select a different value in the Show Versions list.
To retrieve files, complete the following steps:

1. Click the Retrieve tab.

2. Select each file and folder that you want to retrieve.

3. Click Retrieve.

The Retrieve dialog box opens.

4. Specify Retrieve options.

When the retrieval completes, the Retrieve outcome opens in a pop-up window.

The Retrieve outcome can include the following buttons:

Open Folder — If you retrieved all of the files to a single folder, this button opens the folder to which 
the files were retrieved.

View Details — Lets you view details for the retrieval.

Close — Closes the retrieval outcome window.

You also can view the retrieval outcomes on the History pane.

Note

If the retrieve option is password protected, the Agent prompts you to enter your password 
before the Retrieve pane opens. Alternatively, a system administrator who retrieves files on 
your behalf can click Advanced in the Enter Password window, and then enter a technician 
ID and password. The technician ID must have the Access User’s Data permission turned on. 
If it does not, the system administrator cannot use Retrieve.
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Use the Retrieve pane to select the files that you want to retrieve. 

By default, the Retrieve pane shows the most recent version of files that are backed up to the Data Center. To 
select a file for retrieval, check the box next to the name of the file.

You also can select other versions of files for retrieval.

File retrieval involves the following steps:

1. Select which version of backed-up files you want to view.

2. Locate the files that you want to retrieve.

3. Select the files that you want to retrieve.
To select a version of backed-up files, complete the following step:

In the Show Versions drop-down list, select one of the following items:

Most Recent — This is the default value. When you select this option, the Retrieve pane shows only the most 
recent version of each file and folder that is backed up to the Data Center for this Agent account. 

As of Backup Date — When you select this option, the Version as of Backup Date window opens. Select a 
backup date, and then click OK. The Retrieve pane shows only the versions of the files that were backed up 
on the selected date. 

All — When you select this option, the Retrieve pane shows all versions of files backed up on the Data Center 
for this Agent account. The system administrator determines the number of versions that the Data Center 
saves.
To locate the file that you want to retrieve, complete the following step:

Perform one of the following tasks:

In the Backed-up Files section in the left pane, use the tree to expand folders and subfolders. Click a folder 
name to view its subfolders and files in the right pane. 

In the right side of the Retrieve pane, double-click a folder name to view its subfolders and files.

Use Find to locate a specific file.
To select the files that you want to retrieve, complete the following steps:

1. To select the files that you want to retrieve, perform one of the following tasks:

To select all files in a folder, in the Backed-up Files section in the left pane, or in the Name column in the 
right pane, select the checkbox next to the folder. 

To select specific files, in the Backed-up Files section in the left pane, expand a folder, and then, in the 
right pane, select the checkbox next to each file that you want to retrieve. 

To deselect a file or folder, deselect the checkbox next to the file or folder name. 

2. After you select all of the files and folders that you want to retrieve, click Retrieve. 

The Agent prompts you to specify additional Retrieve options. The Retrieve options identify a destination 
for the retrieved files and how the Agent resolves file name conflicts.
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Specifying Retrieve options

Finding files for retrieval

Toggling Simple and Advanced view
Iron Mountain Incorporated Connected® Backup Agent Help  41



Chapter 4: Retrieving Files
Specifying Retrieve options
42 Co
After you select the files that you want to retrieve, the Retrieve window opens. Use the Retrieve window to 
specify where to put the retrieved files, and the how to resolve file name conflicts.
To specify retrieval options, complete the following steps:

1. Select one of the following destinations:

New Location— Select this option to choose a location for the retrieved files. If you select a location that 
is different from the original location, you avoid file name conflicts. The default location is your 
documents folder. To choose a different folder that already exists, or to create a new folder in which to 
store the files, click Choose.

Original Location — Select this option if you want to retrieve the files to their original locations and 
maintain the original folder structure. The original location is the location of the file at the time that the 
Agent backed it up. During the retrieval, the Agent creates missing folders, if necessary, to recreate the 
original path.

2. To specify how the Agent handles name conflicts during the retrieval, select one of the following options:

Rename the files being retrieved — When you select this option, the Agent renames the files that it 
retrieves from the Data Center if a file with the same exists in the retrieval destination, and the existing 
file contains data that is different from the retrieved file. The Agent adds the word “Restored” and a 
sequential number to the end of the file name in the destination folder (for example, Reports Restored 
1.doc). 

Overwrite the files currently on my computer — When you select this option, the Agent replaces files 
in the retrieval destination that have the same names as the files retrieved from the Data Center, and 
contain data that is different from the retrieved files.

3. Click Retrieve.

The Retrieve dialog box opens and describes the status of the retrieval.
nnected® Backup Agent Help            Iron Mountain Incorporated



Chapter 4: Retrieving Files 
Finding files for retrieval
Iron Mo
The Find feature lets you search for specific files for retrieval. The Find feature is helpful if you do not know the 
full name or path for a file. 

You can use the Find feature at any time when you select files for retrieval. Using Find does not affect folder and 
file selections that you have already made in the Retrieve pane. 
To use Find to retrieve files, complete the following steps:

1. On the left side of the Retrieve pane, in the Backed-up Files list, select the volume or folder in which you 

want to search for the file.

The folder name appears in the Find in field to the right of the Find buttons.

2. In the Find field, enter a full or partial filename. You can use wildcard characters in the Find field.

3. Click the Find Next button .

In the right side of the Retrieve pane, the Agent highlights the first matching file. 

The tree in the right side of the Retrieve pane shows where the match is located.

4. To select a file or folder, click the checkbox next to the file name or folder name. 

5. To search for additional files or folders that match the Find criteria, click the Find Next button again. 

In the right side of the Retrieve pane, the Agent shows the next matching file.

6. To return to a previous match, click the Find Previous button .

A pop-up message indicates when the Agent has found all of the matches.

7. To start a new search, repeat this procedure.
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The Agent records event messages for the operations that it performs. You can view this information in the 
History pane.

See the following topics:

Agent History overview

Viewing History
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The History pane lists events that occurred during backup, retrieval, Agent installation, and account recovery or 
file list synchronization. 

You can select one or more events listed in the History pane and view additional information about those events. 
You can also export event details to a TXT or XML file that you can send to a technical support representative if 
you need help with solving problems.

Note

After an account recovery, the Agent does not restore the History. 
Types of events

The History pane lists events for the following operations:

Backup

Retrieve

Agent install/Account recovery

Agent software upgrade
Storage of Agent history

The Agent stores history information on the Agent computer for 90 days.
Viewing History

Exporting History

Agent error messages

Agent warning messages
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The following table lists the event messages that appear in the History pane:

Agent operation Event message Description

Agent install/Account 
recovery

Agent install / Account 
recovery

The Agent tried to recover an 
existing account. 

Agent software upgrade Agent software upgrade The Agent upgraded to a 
newer version. 

Backup Back up <#> files The Agent backed up the 
specified number of files.

Back up The Agent did not back up 
any files. Possible causes 
include the following reasons: 

You canceled the backup 
before the Agent 
transmitted files to the 
Data Center.

An error prevented the 
Agent from transmitting 
files to the Data Center. 

None of the files in the 
backup set changed since 
the last backup.

The backup is postponed 
because the bandwidth 
allocated for backups is 
currently used by other 
Agents. 

Retrieve Retrieve <#> files The Agent retrieved the 
specified number of files.

Retrieve The Agent did not retrieve 
any files. Possible causes 
include the following reasons: 

You canceled the Retrieve 
before the Agent 
retrieved any files. 

An error prevented the 
Agent from retrieving 
files.
Agent error messages

Agent warning messages
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Use the History pane in the Agent window to view events. By default, the History pane displays the most recent 
events first. To sort the list of events, click the column headings. The time stamp for events uses the local time 
and format of the computer.
To view Agent events, complete the following steps:

1. Select the History tab. 

The History pane displays a list of events that occurred during the past 90 days. 

2. Select one or more events in the list and then, to show additional details about the events, click View.

The Agent opens a View History Details window for each selected event.
Sorting the display

To sort the events in the History pane, click a column heading. The column heading shows an up arrow when it 
sorts the events in ascending order. The column heading shows a down arrow when it sorts the events in 
descending order.
Exporting History
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You can export information for history events to a TXT or XML file. These files can help technical support 
representatives solve problems. 
To export history details to a TXT or XML file, complete the following steps:

1. Click the History tab.

2. Select one or more events in the list and click Export.

The Export dialog box opens.

3. Enter a name and location for the export file. The default filename has the following syntax:

Agent Log_Account #.xml 

where Account # is the account number that is associated with your Agent.

If you select multiple events in the History pane, the Agent exports all of the event details to a single file.

4. Click Save.

When you view details for a single event in the View History Details window, click Export from the History 
Details window to export information for the event.
Viewing History
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To view details about errors that occur during an Agent operation, select the event in the History pane, and then 
click View.

For descriptions of common error messages, see the following topics: 

Installation and account recovery error messages

Backup error messages

Retrieve error messages
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The following table lists the most common errors that can occur during account installation or recovery.

Error message Possible cause

The Agent could not connect to the 
Data Center.

The Agent cannot connect to the Data Center. 
Possible causes for this error include the 
following:

Because all licenses in the Data Center 
license file have expired, the Data Center 
is unavailable to Agents.

There is a network problem or a power 
outage. 

The computer is physically disconnected 
from the network.

Because of incorrect proxy settings, the 
Agent cannot communicate with the Data 
Center. 

The Data Center PC or Mac licenses 
have expired.

The Data Center is licensed for both PC and 
Server, and the PC and Mac licenses in the 
license file have expired, but the server 
licenses have not expired.

The Data Center's Server licenses 
have expired.

The PC with Server Option licenses have 
expired, but PC or Mac licenses are still 
available. You must have an available PC with 
Server Option license for registration to 
happen.

No licenses for PC or Mac backup 
accounts are available.

The Data Center Community does not have 
enough PC or Mac licenses.

<parameter> is undefined. A required parameter is missing.

<parameter> is invalid. The value of a required parameter is invalid.

The USERID and PASSWORD are 
invalid.

The USERID and PASSWORD values 
provided for a hands-free account recovery 
are invalid.

ACCOUNTNUMBER is invalid. The ACCOUNTNUMBER value provided for 
a hands-free account recovery is invalid.

Insufficient disk space available. The computer that is associated with the 
account does not have sufficient disk space to 
complete the account recovery.

Hardware error. A hardware error occurred while the Agent 
was trying to recover an account.
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The Agent lost its connection to 
the Data Center.

The Agent cannot re-establish a lost 
connection to the Data Center. The Agent can 
lose connection if any of the following 
situations occur during an account recovery:·

Network problems or a power outage 
make the Data Center unreachable.·

The computer becomes physically 
disconnected from the network.

The Agent cannot communicate with 
its background service. Restart 
your computer or for more 
information, see the Help.

There is a problem with the AgentService 
process, or an antivirus software setting, 
firewall setting, or network setting is blocking 
port 16386. 

Restart your computer to reset the 
AgentService process. 

Ensure that port 16386 is not blocked. 

Cannot register account because 
its Data Center Community has no 
licenses available.

The community in which the Agent attempted 
to register does not have available licenses. 
Change the license allocation to let Agents 
register.

Invalid password. The account password is invalid.

The technician ID does not have 
appropriate permissions to 
register this account in the 
associated Data Center Community.

The technician ID does not have the Modify 
Communities permission. A system 
administrator can use Support Center to 
adjust the permissions or use a different 
technician ID.

Out of disk space. The computer for which you are attempting to 
register an account does not have sufficient 
disk space for the Agent.

Disk error. A disk error occurred and the Agent could not 
complete the registration.

Error message Possible cause
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The following table lists the most common errors that can occur during a backup:

Error message Possible cause

The Agent cannot back up <file 
name> in <path> because its size, 
<value>, is greater than the 
maximum of <maximum file size>.

The file is too large.

To address the problem, complete one of the 
following tasks, and then run the backup 
again:

Exclude the file from backup.

Reduce the size of the file attributes.

Break the file into two separate files.

If the file is a database, compress the 
database.

The Agent cannot back up <file 
name> in <path> because the size of 
the metadata, <value> bytes, 
stored in the file attributes is 
greater than the maximum size of 
<value> bytes.

The amount of metadata stored in the 
attributes of the file exceeds the maximum 
number of bytes allowed. 

To address the problem, complete one of the 
following tasks, and then run the backup 
again:

Exclude the file from backup.

Reduce the size of the file attributes.

Break the file into two separate files.

If the file is a database, compress the 
database.

The Agent could not back up your 
files for the following reason:

The Agent could not communicate 
with the Data Center. Restart your 
computer or for more information, 
see the Help.

There is a problem with the AgentService 
process, or an antivirus software setting, 
firewall setting, or network setting is blocking 
port 16386. 

Restart your computer to reset the 
AgentService process.

Ensure that port 16386 is open. 

The Agent could not back up the 
home folder for <Mac OS X username> 
because it is protected by 
FileVault. To back up files in your 
FileVault-protected home folder 
when you are logged out, select the 
checkbox on the FileVault tab and 
enter your Mac OS X username and 
password. Enable the FileVault 
option in Agent Preferences. To do 
so, select open Preferences from 
the Connected Backup menu, and then 
click the FileVault tab.

You are logged off during backup and your 
Mac OS® X account user name and password 
are not stored in the Agent Preferences.

For more information, see Managing FileVault 
passwords.
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The Agent could not back up the 
contents in the home folder for 
<Mac OS X user name> because the 
Mac OS X account password is 
invalid. To ensure the Agent can 
back up the files in this home 
folder when you are logged out, 
reenter your Mac OS X account 
password. To do so, open 
Preferences and click the 
FileVault tab.

You are logged off during backup and the 
Agent does not have the correct Mac OS X 
account password. The contents of the 
FileVault-protected home folder is part of the 
backup set because it was added to the backup 
set during a previous backup.

The Agent could not connect to the 
Data Center. 

Possible causes for this error include the 
following reasons:

Network problems or a power outage 
have made the Data Center unreachable.·

The computer is physically disconnected 
from the network.·

Incorrect proxy settings prevent 
communication between the Agent and 
the Data Center.

All licenses in the Data Center license file 
have expired. If there are no licenses, the 
Data Center does not work, and the Agent 
is unable to find the Data Center.

Backup failed because your account 
was canceled.

The Agent cannot complete a backup because 
the Agent account was canceled. For more 
information, contact your system 
administrator or service provider.

The Agent is unable to perform the 
backup because this account is in 
use by the computer <name>. Contact 
Support for further assistance.

Possible causes for this error include the 
following reasons:

You performed the most recent backup 
for your account from a different 
computer, you have never backed up 
your account from your current 
computer, and you clicked No when the 
Move Backup Account? pop-up 
message opened.

You performed the most recent backup 
for your account from a different 
computer, and although you have 
previously backed up your account from 
your current computer, you did not 
perform an Account Recovery before this 
backup attempt.

Error message Possible cause
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Backup failed because your account 
was put on hold. 

The Agent cannot complete a backup because 
the Agent account was put on hold. For more 
information contact your system 
administrator or service provider.

The Data Center Server licenses 
have expired.

The PC with Server Option licenses in the 
license file on the Data Center have expired, 
but the PC or Mac licenses have not expired.

The Data Center PC or Mac licenses 
have expired.

The PC or Mac licenses in the license file on 
the Data Center have expired, but the PC with 
Server Option licenses have not expired. 

Insufficient disk space available 
for processing backup.

The Agent could not complete the backup 
because the computer does not have enough 
disk space to process the backup.

Hardware error. A hardware error occurred on the client 
system during a backup. The Agent could not 
complete the backup.

The Agent lost its connection to 
the Data Center. 

The Agent cannot re-establish a lost 
connection to the Data Center. The Agent can 
lose connection if the following situations 
occur:·

Network problems or a power outage 
make the Data Center unreachable.·

The computer becomes physically 
disconnected from the network.

<filename> in folder <path> could 
not be backed up. Reason: <reason>.

The Agent cannot back up the specified file 
because an error occurred when the Agent 
tried to read it the file, or because the Agent 
cannot access the file. 

The Agent could not back up <file> 
in <folder> because it was open or 
in use. Close all applications 
before running backups.

A file was open during the backup and the 
Agent could not back up the file. Close all 
applications and try to run the backup again.

An Index server request needs to be 
completed for this account and so 
the Data Center ended the backup 
session. Try backing up again. If 
this problem continues, contact 
Support.

The Agent could not connect to the Data 
Center because of a pending Index server 
request.

The Agent sent an invalid message 
to the Data Center and so the Data 
Center ended the backup session. 
Try backing up again. If this 
problem continues, contact 
Support.

The Agent could not connect to the Data 
Center because the message sent by the Agent 
to the Data Center contained invalid data.

Error message Possible cause
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Backup stopped because the Agent 
failed to log on to the Data 
Center. Try backing up again. If 
the problem continues, contact 
Support.

The Agent could not connect to the Data 
Center because the logon information sent 
from the Agent to the Data Center was invalid. 

The Data Center terminated the 
transmission session (ReasonCode 
<code>). Try backing up again. If 
the problem continues, contact 
Support.

The Agent could not connect to the Data 
Center because of an unhandled protocol.

(No error message, but the backup 
fails)

The backup failed because of an unexpected 
system shut down, or application failure. No 
error message appears in the View History 
Details window for the backup event. 

Note

Your Agent configuration determines whether backup outcome messages appear in a pop-
up window on the Agent. For more information, see Viewing messages in pop-up windows.

Error message Possible cause
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The following table lists the most common errors that can occur during retrieval:

Error message Possible cause

The Agent could not retrieve 
<filename> because there was not 
enough disk space on the selected 
location. Try freeing up more disk 
space or selecting a different 
location.

The target computer does not have sufficient 
disk space for all of the files selected for 
retrieval. 

Insufficient disk space available. The target computer does not have sufficient 
disk space for any of the files selected for 
retrieval. 

Hardware error. A hardware error occurred on the client 
system during the retrieval. The Agent could 
not complete the retrieval.

Retrieve failed because your 
account was canceled.

The Agent cannot perform the retrieval 
because the Agent account was canceled.

Retrieve failed because your 
account was put on hold. 

The Agent cannot perform the retrieval 
because the Agent account was put on hold.

<filename> in folder <path> could 
not be retrieved. Reason: <reason>

The Agent cannot retrieve the specified file 
because of one of the following situations 
occurred: 

The client system did not have sufficient 
disk space to store the retrieved files. 

An error occurred while the Agent wrote 
the file to the client system. 

An error occurred while the Agent 
decompressed the file. 

The Agent cannot retrieve the file from 
the Data Center.
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To view warning message that might occur during an Agent operation, select the event in the History pane, and 
then click View.

For descriptions of common warning messages, see the following topics:

Backup set size limit messages

Backup warning messages
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The following table lists the backup set size limit messages that the Agent can receive during a backup. In 
addition to backup error or backup warning outcome messages, the Agent also receives the following messages:

Backup set size limit message Possible cause

Your Backup Set is over its size 
limit of  
<size limit>. Some of your files 
are not backed up. Remove 
unnecessary files from your Backup 
Set or contact your administrator 
or service provider to change your 
account to a backup plan with a 
larger Backup Set limit.

The backup set size exceeds the maximum 
size allowed for the Agent.

Your Backup Set is approaching its 
size limit of <size limit>. When 
you reach your limit you will no 
longer be able to back up all of 
your files. Remove unnecessary 
files from your Backup Set or 
contact your administrator or 
service provider to change your 
account to a backup plan with a 
larger Backup Set Limit.

The backup set size is near the maximum size 
allowed for the Agent.
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The following table lists the most common warning messages that can occur during a backup:

Warning message Possible cause

No completely successful backups 
occurred for more than <##> days.

The Agent has not successfully backed up all 
files in the backup set for 4 or more 
consecutive calendar days.

The Data Center postponed this 
backup because insufficient 
bandwidth was available. The Agent 
will attempt another backup in 10 
minutes.

The scheduled backup is postponed because 
other Agents are using most of the bandwidth 
allocated for backups. As a result, the 
minimum bandwidth required to perform a 
backup is not available for this Agent.

The Agent retries a postponed scheduled 
backup every 10 minutes until the backup 
succeeds or fails. 

The Data Center postponed this 
backup because insufficient 
bandwidth was available. 

The manual backup is postponed because 
other Agents are using most of the bandwidth 
allocated for backups. As a result, the 
minimum bandwidth required to perform a 
backup is not available for this Agent.

Retry your backup at a later time.

<filename> in folder <path> could 
not be backed up because it was 
open.

The Agent could not back up the file because 
it was in use. 

Note

Your Agent configuration determines whether backup outcome messages appear in a pop-
up window on the Agent. Viewing messages in pop-up windows.
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If you have permission to edit your backup set, you can use the Advanced Rules window to view rules, manage 
user-created rules, and add volume exclusions. To open the Advanced Rules window, choose Tools > Advanced 
Rules.

If you do not have permission to edit your backup set, the Tools menu does not include Advanced Rules.
Agent rules and rule sets

Using the Advanced Rules window
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Your Agent rule set determines which of the files on your computer the Agent selects for backup. Your system 
administrator creates your Agent rule set. 

A rule set can include the following types of rules:

Locked rules — Rules that users with permission to edit their backup set cannot override. 

In the Backup Set pane, files and folders that are included or excluded because of locked rules have a locked 
checkbox (  or ). 

If the entire contents of a folder are governed by locked rules, and some of the contents are selected for 
backup while the rest are deselected, the folder has a mixed locked checkbox .

You cannot select or deselect a locked checkbox. 

Unlocked rules — Rules that users with permission to edit their backup set can override. 

In the Backup Set pane, files and folders that are included or excluded because of unlocked rules have an 
unlocked checkbox (  or ). 

If the entire contents of a folder are governed by unlocked rules, and some of the contents are selected for 
backup while the rest are deselected, the folder has a mixed unlocked checkbox .

You can select or deselect an unlocked checkbox. 

You cannot change the volume exclusions or rules from the rule set. However, if your Agent lets you to edit your 
backup set, then you can create additional rules called user-created rules, and you can select volumes to exclude.

For instructions, see Managing user-created rules and Excluding volumes from backups.
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Each rule is assigned to a category. The category determines how the Agent uses the rule during a backup. The 
following table describes the rule categories:

Rule category Description

User-Created Files This category includes user-created files, 
such as spreadsheets and documents, in 
backups.

Exclusions This category is for files, such as 
temporary files, that users do not need to 
back up or retrieve. 

The Agent uses this category to determine 
which files to exclude from backups.
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To determine which of your computer files to select for the backup set, the Agent verifies your files against rules 
according to the following sequence:

1. Check files against locked rules.

2. Check files against user-created rules.

3. Check files against unlocked rules.

The Agent does not consider files on excluded volumes. 

If there are multiple rules of one type (for example, multiple locked rules), the Agent checks your files against all 
rules of that type in top-down order before it checks your files against the next rule type. After a file matches a 
rule, the Agent determines whether to select that file for backup and stops the comparison process for that file. 
The Agent continues to compare your other files to rules until either the files match a rule or there are no more 
rules. If a file does not match a rule, the Agent does not select the file for backup.
Rules example

Your computer has two volumes: Macintosh HD and Volume 2. Your Agent includes the following rules:

The Agent uses the following process:

1. The Agent considers the volume exclusion. The Agent excludes volume 2 from the backup set. Therefore, the 
Backup Set pane does not show files on volume 2.

2. The Agent verifies files on the hard drive against the locked rule. All files in */Documents match the locked 
rule. The Agent selects those files for backup and shows them in the Backup Set pane as selected. You cannot 
change the selections because the rule is locked.

3. The Agent verifies the remaining files on the hard drive against the user-created rule. The Agent does not 
check files in */Documents because those files already match a rule. All other DOC files on Macintosh HD 
match the user-created rule. Because the rule is an Exclusions rule, the Agent does not select those files for 
backup, and does not show them in the Backup Set pane as selected. However, you can select the files for 
backup because the rule that governs the files is not a locked rule.

4. The Agent verifies the remaining files on Macintosh HD against the unlocked rule. The Agent does not check 
files in */Documents or DOC files on Macintosh HD because those files already match a rule. No files 
match the unlocked rule, because all DOC files previously matched a different rule. 

The Agent does not select any other files on Macintosh HD for backup. 

Rule type Rule category Rule

Volume exclusion Exclude volume 2

Locked rule User-Created Files Include all files and subfolders in 
*/Documents

User-created rule Exclusions Exclude all DOC files

Unlocked rule User-Created Files Include all DOC files
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Use the Advanced Rules window to view the volume exclusions and rules included in the rule set for your Agent, 
manage user-created rules, and add volume exclusions. To open the Advanced Rules window, choose Tools > 
Advanced Rules.

The following table describes the Advanced Rules panes:

Description

Volume Rules Shows the volumes on your computer, except for removable thumb drives, network 
volumes and case-sensitive volumes, and indicates which volumes are excluded from 
backups. You can use this pane to exclude additional volumes or to include volumes 
that you previously excluded. For instructions, see Excluding volumes from backups.

Locked Rules Shows the locked rules in the Agent rule set. You cannot edit these rules, but you can 
copy a locked rule to create a new user-created rule. For instructions, see Managing 
user-created rules.

User-Created Rules Shows the user-created rules that you add to the rule set. You can use this pane to add, 
edit, and remove user-created rules, and to change the sequence of user-created rules. 
When you change the sequence of user-created rules, you change the priority of the 
rules. For instructions, see Managing user-created rules.

Unlocked Rules  Shows the unlocked rules in the Agent rule set. You cannot edit these rules, but you 
can copy an unlocked rule to create a new user-created rule. For instructions, see 
Managing user-created rules.
Volume Rules pane

Locked Rules pane

User-Created Rules pane

Unlocked Rules pane
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If you do not need to back up files on a specific volume, you can exclude the volume from backup. When you 
exclude volumes, the Agent scans files for backup more quickly because the Agent does not need to consider files 
on every volume.

Only users with permission to edit their backup set can select volumes for exclusion.

By default, all volumes are included in the backup. You can choose volumes that you want to exclude from the 
backups, or you can include a volume that you previously excluded. 

Your volume exclusions are preserved if a system administrator makes changes to the rule set for your Agent. 

Note

The Agent automatically excludes removable or thumb drives, network volumes, and case-
sensitive volumes from backups. These volumes do not appear in the Volume Rules pane.
To select volumes to exclude from backups, complete the following steps: 

1. Choose Tools > Advanced Rules.

The Advanced Rules dialog box opens.

2. In the Volume Rules pane, deselect the checkbox next to each volume that you want to exclude from backup. 

3. To include a volume that you previously excluded, select the checkbox next to the volume.

4. To save your changes, click OK.
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This topic describes how to manage user-created rules. Management includes the following tasks:

Adding a user-created rule

Copying an existing rule to create a new rule

Editing a user-created rule

Changing the sequence of user-created rules

Deleting a user-created rule

To perform these tasks, you must have permission to edit your backup set. 
To add a user-created rule, complete the following steps:

1. Choose Tools > Advanced Rules.

The Advanced Rules dialog box opens.

2. Click the User-Created Rules tab.

3. Perform one of the following tasks:

If other user-created rules exist, to specify a location in the user-created rules list, select the rule above 
where you want to insert the new rule. 

If there are no other user-created rules, continue to step 4.

4. Click the Add Rule button , and from the menu, click New Rule. 

The New Rule dialog box opens.

5. In the New Rule dialog box, enter the parameters. 

For more information, see the online help for the User-Created Rules pane. 

6. Click Save. 

The new rule appears above the rule that you selected when you clicked New. If you did not specify a 
location in the user-created rules list, the new rule appears at the bottom of the list. For information about 
how to change the sequence of user-created rules, see Changing the sequence of user-created rules.

7. To save your changes, click OK.

Another way to add a user-created rule is to change file selections in the Backup Set pane. For more information, 
see Viewing and changing your backup set.
To copy an existing rule to create a new rule, complete the following steps:

1. Choose Tools > Advanced Rules.

The Advanced Rules dialog box opens.

2. Click the tab that contains the rules that you want to copy.

3. Select one or more rules to copy. 

For information about how to select rules, see Selecting rules.

4. Perform one of the following tasks:

To copy a rule and leave it in its original location, click the Action menu , and then choose Copy 
Rule.

To delete the rule from its original location, click Action menu , and then choose Cut Rule. 
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You can click Cut Rule only when you copy a rule from the User-Created Rules pane.

5. Click the User-Created Rules tab.

6. Select the rule above which you want to paste the copied rule.

7. To paste the rule into the new location, click the Action menu, and choose Duplicate Rule. 

The copied rules appear above the rule that you selected in the user-created rules list. For information about 
how to change the rule sequence, see Changing the sequence of user-created rules.

8. If necessary, edit the rule that you copied.

For information about how to edit rules, see Editing a user-created rule.

9. After you edit the rule, click Save.

The Advanced Rules dialog box adds the new rule in the rules list.

10. To close the Advanced Rules dialog box, click OK.
To edit a user-created rule, complete the following steps:

1. Choose Tools > Advanced Rules.

The Advanced Rules dialog box opens.

2. Click the User-Created Rules tab.

3. Select the rule that you want to edit.

4. Click the Action menu , and then choose Edit Rule. 

The Edit Rule dialog box opens.

5. In the Edit Rule dialog box, edit the rule parameters. 

For more information, see the online help for the User-Created Rules pane.

6. Click Save. 

The Edit Rule dialog box closes. The Advanced Rules dialog box adds the new rule in the rules list.

7. To close the Advanced Rules dialog box, click OK.
To change the sequence of user-created rules, complete the following steps:

1. Choose Tools > Advanced Rules.

The Advanced Rules dialog box opens.

2. Click the User-Created Rules tab.

3. Select one or more rules that you want to move. 

For information about how to select rules, see Selecting rules.

4. Perform any of the following steps:

To move the rules up one position at a time, click the up arrow ( ).

To move the rules down one position at a time, click the down arrow ( ).

To cut the rules from the pane so that you can paste them elsewhere in the rules list, click the Action 
menu , and then choose Cut Rule. Then, select the rule above which you want to paste the rules, 
click the Action menu, and then choose Paste Rule. This inserts the rule above the one that you selected.

5. To save your changes, click OK.
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Because the Agent applies rules in top-down order, the sequence of rules in the User-Created Rules pane is 
important. For detailed information about how the Agent applies rules, see How the Agent uses rules during a 
backup.
To delete a user-created rule, complete the following steps:

1. Choose Tools > Advanced Rules.

The Advanced Rules dialog box opens.

2. Click the User-Created Rules tab.

3. Select one or more rules to delete. 

For information about how to select rules, see Selecting rules.

4. Click the Action menu , and then choose Remove Rule. 

The rule is removed from the rules list.

5. To save your changes and close the Advanced Rules dialog box, click OK.
Tips for creating rules

Best practices for rules

Using wildcard characters in rule definitions
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When you work with rules, you can select one rule at a time, a group of consecutive rules, a group of 
nonconsecutive rules, or all rules. The following table describes how to select rules:

Selection Steps

A single rule Point to a rule and click.

A group of consecutive rules Press and hold Shift, click the first rule in the group, 
and then click the last rule in the group. Support 
Center selects all of the rules between the two selected 
rules.

A group of nonconsecutive rules Press and hold Command, and click each rule that you 
want to select.

All rules Click the Action menu  and choose Select all 
Rules.
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When you add user-created rules, consider the following best practices:

In the rule sequence, exclusion rules must precede other rules that match the same files. For example, you 
have a User-Created Files rule that includes all files in a folder, and an Exclusions rule that excludes MP3 
files in the same folder. The Exclusion rule must appear first. Otherwise, the files match the user-created files 
rule first, and the Agent includes MP3 files in the backup.

Create User-Created Files rules to ensure that the Agent selects the appropriate files for backup. Create 
Exclusions rules for files that you do not want the Agent to select for backup. Remember that the Agent does 
not back up files that do not match a rule.
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When you create rules, consider the following tips:

When you create rules, remember that the rule type determines the order in which the Agent compares the 
files on your computer to the rules. The Agent uses rules in the following order:

1.Locked rules

2.User-created rules

3.Unlocked rules

Within each rule type, the Agent compares files to rules in top-down order. For example, if you have three 
locked rules, the Agent compares files to the first locked rule, then to the second locked rule, and so on. After 
a file matches a rule, the Agent does not compare that file to other rules. 

To keep a rule set manageable, use as few rules as possible to get the desired file selection. For example, 
create a single rule to include or exclude entire categories of files, such as graphics, and enter multiple 
comma-separated values when you select the file extensions or types.

Do not rely on the absence of a rule to exclude a file from backup. To exclude files from backup, create an 
exclusion rule to specify the exclusion. For example, assume you want to exclude MP3 files from backups. 
Because the Agent does not consider files for backup unless the file matches a rule, you decide that you can 
exclude MP3 files from backup if you do not create a rule for them. However, a user creates a rule that 
specifies MP3 files for backup. As a result, the Agent backs up the MP3 files. To ensure that the Agent does 
not back up MP3 files, create a locked exclusions rule to exclude MP3 files from backup. Your locked 
exclusion rule overrides the user-created rule.

When you enter names and descriptions for rule sets and rules, be as descriptive as possible. Descriptive 
names helps you to identify what the rule does without having to view each rule’s definitions. For example, 
you could name rules as follows: 

Exclude all API files 

Back up all Word document files in Documents folder

When you enter file names in the File name field, do not enter a file extension. For example, do not enter 
myreports.doc. Enter myreports. 

When you enter file extensions in the Extensions field, do not enter a leading dot (.) before the extension. For 
example, enter doc or xls. Do not enter .doc or .xls. 

Use commas to separate multiple values. For example: xls,doc. 

The default value is the * wildcard character. If you use the default value, the rule matches files of any type 
or extension, including files without extensions. If you leave either field empty, the rule matches only files 
that do not have extensions.
Using the Advanced Rules window

Excluding volumes from backups

Managing user-created rules

Selecting rules

Best practices for rules

Using wildcard characters in rule definitions
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To specify folders, file names, or file types in rule definitions, you can use the following wildcard characters:

Character Description

* (asterisk) Matches any number of characters.

? (question mark) Matches any one character.
Using wildcard characters to specify file names and file extensions

The following examples demonstrate how to use wildcard characters to specify file names and extensions in rule 
definitions:

File name Matches

reports_? File names that start with the word reports_ and are followed by 
one character. For example:

reports_1 or reports_a

*reports File names that end with the word reports and are preceded by 
zero or more characters. For example:

1_reports, my_reports, a_reports, reports

reports* Files that start with the word reports and are followed by zero or 
more characters. For example:

reports_1, or reports_abc, or reports

* All file names.

.do? File extensions that start with do and are followed by one character. 
For example:

doc or dot

.in? All file extensions that begin with the letters in and are followed by 
a single character. For example:

ini or inx

.*t All files extensions that end with the letter t and are preceded by 
zero or more characters. For example:

dat, txt, or bat

.* All file extensions, including files with no extension.
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The following table demonstrates how to use wildcard characters to specify file type and creator codes in rule 
definitions:

This file type... Matches...

*/MSWD Files that have any file type code and also have the creator code 
MSWD.

TEXT/* Files that have the file type code TEXT and also have any creator 
code.

DOC? Files with a file type code that start with DOC and ends with any 
other letter (for example, DOCX or DOCM).
nnected® Backup Agent Help            Iron Mountain Incorporated



Chapter 7: User Profile 
USER PROFILE
Iron Mo
Your user profile contains information that is associated with your Agent account in the Data Center. 

The following topics provide information about how to edit your user profile:
 

User Profile overview

Edit Profile Window

Editing your user profile
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You can edit your user profile only if your Agent account includes permission to do so and your Agent 
community does not store profiles in an LDAP database. 

To edit your user profile, use the Edit Profile window. When you select Tools > Edit Profile, the Agent gets your 
profile information from the Data Center, and then opens the Edit Profile window. If your Agent cannot contact 
the Data Center, it cannot open the Edit Profile window, and you cannot edit your profile. If this situation occurs, 
you receive a message. 

After you edit your profile, the Agent synchronizes with the Data Center again to update your account.
When to edit your user profile

You might want to edit your profile under the following circumstances:

You want to change the password for your Agent account.

You want to change or add information, such as your email address. 

Your email address and account password are important if your Agent account grants you access to the 
Account Management Website. 
 

Edit Profile Window

Editing your user profile
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To edit your user profile, complete the following steps:

1. Click Tools > Edit Profile.

The Synchronizing window opens, and then the Edit Profile window opens.

2. Complete any or all of the following procedures:

Click the User tab, and then enter your user information.

Click the Password tab, click Change password, and then enter your password information.

Click the Address tab, and then enter your address information.

Click the Other tab, and then enter your other contact information.

3. To save your changes and exit the User Profile window, click OK.
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The Agent receives new messages when it connects to the Data Center for automatic or manual backups and 
retrievals.

The system generates messages automatically as the result of system activity, and system administrators send 
messages.
Viewing Agent messages

Message type descriptions
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You can view Agent messages in the following ways:

In a pop-up window on your computer. For more information, see Viewing messages in pop-up windows.

In the Messages section of the Summary pane. For more information, see Viewing messages in the Messages 
section.

In the View History Details window for the event related to the message. For more information, see Viewing 
History.

The message type determines how you can view the message. 
nnected® Backup Agent Help            Iron Mountain Incorporated



Chapter 8: Messages 
Viewing messages in pop-up windows
Iron Mo
The following table lists the messages that appear in a pop-up window on the Agent computer. The table also 
describes the actions that you can take in response to each message. For more information about each message 
type, see Message type descriptions.

If the system generates more than one message, when you close a message, the next message opens. 

Pop-up message Action

Account Canceled or On Hold To see detailed information for the most 
recent backup, click View Details. To 
close the message, click Close.

Backup set near or over size 
limit

To see detailed information for the most 
recent backup, click View Details. To 
close the message, click Close.

Backup outcome To see detailed information for the most 
recent backup, click View Details. To 
close the message, click Close. You 
receive this type of message in a pop-up 
window only if your Agent is configured 
accordingly.

Missed backup To see detailed information for the most 
recent backup, click View Details. To 
close the message, click Close.

Move Backup Account To move the account to your computer, 
click Yes. To keep the account associated 
with the other computer, click No.

New Messages notification To view messages, click OK. To close the 
notification, click Cancel. If you click OK, 
the Summary pane opens so that you can 
view the Messages section.

Retrieve outcome To open the folder to which files were 
retrieved, click Open Folder. To see 
detailed information for the most recent 
Retrieve event, click View Details. To 
close the message, click Close. Open 
Folder is available only if all of the 
retrieved files are in a single folder. View 
Details is available only if the retrieval 
completed with errors or warnings.
Message type descriptions
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The Messages section of the Summary pane shows the following types of messages:

Account Canceled or On Hold

Missed backup

Backup set near or over size limit

Messages sent from a system administrator

The Agent receives new messages when it connects to the Data Center. The Messages section shows up to 50 of 
the most recent messages received by the Agent. Messages appear by type in the sequence shown in the previous 
list. Messages sent from system administrators appear in reverse chronological order. If a message includes a 
link, click the link to get more information about the message. 

The Agent removes the following types of messages from the Messages section when the messages no longer 
apply: 

Account On Hold

Missed backup

Backup set near or over limit
Message type descriptions
nnected® Backup Agent Help            Iron Mountain Incorporated



Chapter 8: Messages 
Message type descriptions
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This section describes the types of messages that the Agent receives when it connects to the Data Center. 
Connected Backup displays some messages in a pop-up window on your computer, some messages in the 
Messages section of the Summary, and some messages in the View History Details window. Connected Backup 
displays backup outcome messages appear in the Last Backup section of the Summary pane. The following table 
describes how to view each message type:

Message type Description

Account Canceled or On Hold You receive these messages when a 
system administrator changes the status 
of an account to Canceled or On Hold. 

You receive these messages in the 
following locations:

Pop-up window *

Messages section**

View History Details window 

Important: If an account is on hold or 
canceled, backups fail. Your system 
administrator can help ensure that you 
are aware of failed backups by 
configuring your Agent to show backup 
outcome messages in a pop-up window 
when the Agent window is closed. 

*You receive these messages in the pop-
up window for a backup outcome 
message. You do not receive them in a 
pop-up window. 

**If this message no longer applies, the 
Agent removes it from the Messages 
section when the Agent next connects to 
the Data Center.
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Backup set near or over size 
limit

These messages appear if your Agent has 
a maximum backup set size and has 
reached or is near the backup set size 
limit. For more information, see Backup set 
maximum size. 

These messages appear in the following 
locations:

Pop-up window

Messages section*

View History Details window 

*The next time the Agent performs a 
backup, if this message no longer applies, 
the Agent removes it from the Messages 
section.

Backup outcome This message appears after a backup and 
indicates whether the backup succeeded, 
succeeded with warnings, succeeded 
with errors, or failed.

These messages appear in the following 
locations:

Pop-up window*

View History Details window 

Last Backup section

*Your system administrator determines 
whether this type of message appears in a 
pop-up window.

Missed backup These messages appear if a successful 
backup has not occurred on your Agent 
for four or more consecutive calendar 
days. Your Agent configuration 
determines whether the Agent generates 
this type of message.

This message appears in the following 
locations:

Pop-up window

Messages section*

*The next time the Agent connects to the 
Data Center, if this message no longer 
applies, the Agent removes it from the 
Messages section.

Message type Description
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Move Backup Account Connected Backup displays this message 
before a backup if the Data Center 
determines the following conditions: 

You used a different computer to 
perform the most recent backup for 
your account.

You have never backed up your 
account from your current computer.

This message opens in a pop-up window.

New Messages notification This message opens if the Agent receives 
one or more new messages from a system 
administrator. You can view the content 
of this type of message in the Messages 
section of the Summary pane.

This message opens in a pop-up window. 
Although New Messages notifications do 
not appear in the Messages section of the 
Summary pane, the messages themselves 
open in that section. 

Retrieve outcome This message opens under the following 
circumstances:

Retrieval completes successfully.

Retrieval completes with errors.

Retrieval completes with warnings.

Retrieval fails. 

These messages open in the following 
locations:

Pop-up window

View History Details window

Administrative messages These messages are ones that system 
administrators send. They open in the 
Messages section of the Summary page.

Although Administrative messages do 
not open in a pop-up window, 
notifications of a administrative messages 
open in a pop-up window. See New 
Messages notification earlier in this topic.

Message type Description
Other message types

For information about other types of Agent messages, see the following sections:

Agent error messages

Agent warning messages
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ABOUT UPGRADES
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Your Agent receives upgrades when it connects to the Data Center. For more information about upgrades, see 
the following topics:

Upgrade overview

Performing a first backup after an upgrade
untain Incorporated Connected® Backup Agent Help  89



Chapter 9: About Upgrades
Upgrade overview
90 Co
Upgrades occur when your Agent connects to the Data Center. For more information about upgrades, see the 
following topic:
 

Performing a first backup after an upgrade
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After an Agent upgrade, you must perform a backup immediately. 

To perform a first backup after an upgrade, complete the following steps:

1. In the Upgrade Welcome window, click Start Agent.

The Summary pane opens.

2. Click the Backup Set tab.

For information about how to change the files selected for backup, see Viewing and changing your backup set.

3. Click Backup Now.

When the first backup completes, the Agent receives a backup outcome message from the Data Center. Your 
Agent configuration determines whether the Agent displays this message to you. The backup completes 
whether your Agent is open or closed.

4. For information about the outcome of your first backup, click the Summary tab, and then see the Last Backup 
section.
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AGENT WINDOWS
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The topics in this section describe the windows in the Agent interface.
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The topics in this section describe the Advanced Rules windows.
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Use the Volume Rules pane to select the volumes that you want to exclude from backups.

The Agent rule set does not include default volume exclusions.

If the Backup Set pane is open when you open the Advanced Rules window, and you save rule changes, the 
Agent scans the files on the computer again to update the backup set.

The following table describes the elements in the Volume Rules pane:

Note

The Volume Rules pane does not show removable or network volumes.

Element Description

Volume If the checkbox next to a volume name is 
selected, the Agent includes files on the volume 
in backups. 

If the checkbox next to a volume name is empty, 
the Agent excludes files on the volume from 
backups. 

If a volume is excluded from backup, the 
volume and its content do not appear in the 
Backup Set pane, and you cannot select these 
files for backup. 

Deselecting the volumes you do not want to 
back up decreases the time that the Agent needs 
to scan the computer to compile the backup set.

To change volume exclusions, select or deselect 
the checkboxes next to the volume names. If a 
checkbox is unavailable, you cannot change the 
selection. For more information about volume 
exclusions, see Excluding volumes from backups.

OK Saves changes and closes the Advanced Rules 
window. 

Cancel Closes the Advanced Rules window without 
saving changes.
Using the Advanced Rules window
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Use the Locked Rules pane to view details about locked rules, and to copy one or more locked rules to create new 
user-created rules. You cannot edit locked rules.

If the Backup Set pane is open when you open the Advanced Rules window, and you save any rule changes, the 
Agent scans the files on the computer again to update the backup set.

The following tables describe the elements in the Locked Rules pane:
Rules List section
Element Description

Category The rule category assigned to the rule:

User-Created Files 

Exclusions 

Rule Name Unique description of the rule.

Source For locked rules, the source is always 
Administrator, indicating that the rule 
comes from the rule set.
Details of Selected Rule section
Element Description

Category The rule category assigned to the rule:

User-Created Files 

Exclusions 

Folder Path and folder to which the rule applies.

Scope Whether the rule applies to files in subfolders:

Include subfolders — The rule applies to 
files in the folder as well as to files in 
subfolders.

Exclude subfolders — The rule applies 
only to files in the folder; it does not apply 
to files in subfolders. 

File name The full or partial names of files that this rule 
matches.
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Extensions  The extensions for the types of files that match 
this rule. For example, DOC,TXT,PDF.

To match this rule, a file must match either the 
Extensions value or the Type /Creator codes 
value, not both. 

Type/Creator The file types or file types and creator codes of 
files that match this rule. For example, */MSWD, 
TEXT/ttxt,“PDF “.

To match this rule, a file must match either the 
Extensions value or the Type /Creator codes 
value, not both.

Element Description
Action Buttons
Element Description

OK Saves changes and closes the Advanced Rules 
window. If the Advanced Rules window was 
opened from the Backup Set window, and 
changes were made, the Agent scans the client 
again to update the backup set.

Cancel Closes the Advanced Rules window without 
saving changes. If the Advanced Rules window 
was opened from the Backup Set window, and 
changes were made and applied before you 
clicked Cancel, the Agent scans the client again 
to update the backup set.

Opens the Action menu.
Using the Advanced Rules window
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Use this window to add and edit user-created rules. This window shows a red asterisk (*) next to required 
parameters.

If the Backup Set pane is open when you open the Advanced Rules window, and you save any rule changes, the 
Agent scans the files on the computer again to update the backup set.

The following tables describe the elements in the New/Edit Rule window:
Rule properties section
Elements Description

Category From the Category list, select one of the 
following rule types: 

User-Created Files — A rule 
category for user-created data files, 
such as spreadsheets and documents. 

The Agent uses these rules to identify 
data files to select for backup. 

Exclusions — A rule category for any 
file type. The Agent uses these rules 
to identify files to exclude from 
backups. 

Rule name Enter a name for the rule. You can use up 
to 64 alphanumeric characters. 
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Elements Description

Folder Enter the path and folder to which the rule 
applies. Use the following format: 
/Volumes/(volume name)/(path and folder 
name). 

You can include wildcard characters.

Examples:

/Volumes/Macintosh HD/Applications — 
matches files in the Applications folder 
on the Macintosh HD volume.

/Volumes/*/Applications — matches files 
in the Applications folder on all 
volumes.

* — matches all files on all volumes. 

For more information about how to use 
wildcard characters, see Using wildcard 
characters in rule definitions.

Scope To specify how the Agent applies this rule to the 
selected folder, select one of the following 
options:

Include subfolders — The rule applies to 
files in the folder as well as to files in 
subfolders.

Exclude subfolders — The rule applies 
only to files in the folder. It does not apply 
to files in subfolders. 

File name Enter full or partial names of files that you want 
this rule to match. Use a comma (,) to separate 
multiple names. You can also use wildcard 
characters in the name. For example, if you 
entered a file name of ModemLog*, the rule 
matches all files that start with ModemLog. 

The Agent uses File name with the Kind criteria 
to determine which files to select for backups.
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Elements Description

Extensions To define a rule that matches specific file 
extensions, select this checkbox and enter the 
file extensions to which this rule applies. 
Separate each extension with a comma. For 
example, DOC,TXT,PDF. Enter * to select all 
extensions. Leave this field blank to match files 
with no extension.

To create a rule that encompasses bundles, 
specify the extension associated with the 
application that created the bundles.

If you do not select this checkbox, the Agent 
ignores file extensions when it applies this rule.

If you select both the Extensions and Type 
/Creator checkboxes, the Agent considers files 
that match either the Extensions value or the 
Type/creator value. The file does not have to 
match both attributes.
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Type/Creator To define a rule that matches a specific file type, 
or a specific file type and creator code, select this 
checkbox and enter the value. Use the format 
TYPE/CREA, where TYPE represents the type 
code and CREA represents the optional creator 
code. Separate each code or code combination 
with a comma.

The file type code and creator code must each be 
exactly four characters long. If a file type code or 
creator code is fewer than four characters, 
enclose the value in double quotation marks 
(““) and add enough space characters after the 
value to make it four characters long. Enter * in 
place of either code to specify all values of that 
file type. 

For example, */MSWD,TEXT/ttxt,“PDF “

To create a rule that encompasses bundles, 
specify the type or creator code that is 
associated with the application that created the 
bundles.

If you do not select this checkbox, the Agent 
ignores file types and creator codes when using 
this rule.

If you select both Extensions and Type 
/Creator, the Agent considers a file that matches 
all other criteria for this rule a match if it 
matches either the Extensions value or the 
Type/Creator value. The file does not have to 
match both attributes.

Elements Description
Managing user-created rules

Best practices for rules

Tips for creating rules

Using wildcard characters in rule definitions
untain Incorporated Connected® Backup Agent Help  101



Chapter 10: Agent Windows
Unlocked Rules pane
102 Co
Use the Unlocked Rules pane to view details for unlocked rules, and to copy one or more unlocked rules to create 
user-created rules. You cannot edit unlocked rules.

If the Backup Set pane is open when you open the Advanced Rules window, and you save any rule changes, the 
Agent scans the files on the computer again to update the backup set.

The following tables describe the elements in the Unlocked Rules pane:
Rules list
Element Description

Category The rule category assigned to the rule:

User-Created Files 

Exclusions 

Rule Name A unique description of the rule.

Source For unlocked rules, the source is always 
Administrator, which indicates that the rule 
comes from the rule set.

Type/Creator The file types, or file types and creator codes, of 
files that match this rule. For example, 
*/MSWD,TEXT/ttxt,“PDF “

To match this rule, a file must match either the 
Extensions value or the Type/Creator value. It 
does not have to match both values.
Details of Selected Rule section
Element Description

Category The rule category that is assigned to the rule. 
The Agent uses the following rule categories:

User-Created Files 

Exclusions 

Folder Path and folder to which the rule applies.
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Scope Whether the rule applies to files in subfolders. 
The scope is one of the following values:

Include subfolders — The rule applies to 
files in the folder as well as to files in 
subfolders.

Exclude subfolders — The rule applies 
only to files in the folder; it does not apply 
to files in subfolders. 

File name The full or partial names of files that this rule 
matches.

Extensions The extensions for the types of files that match 
this rule. For example, DOC,TXT,PDF.

To match this rule, a file must match either the 
Extensions value or the Type /creator codes 
value, not both. 

Type/Creator The file types or file types and creator codes of 
files that match this rule. For example, 
*/MSWD,TEXT/ttxt,“PDF “.

To match this rule, a file must match either the 
Extensions value or the File type /creator codes 
value, not both.

Element Description
Action buttons
Element Description

OK Saves changes and closes the Advanced Rules 
window. 

Cancel Closes the Advanced Rules window without 
saving changes. 

Opens the Action menu.
Using the Advanced Rules window
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Use the User-Created Rules pane to view, add, edit, or delete user-created rules, change the sequence of user-
created rules, and copy user-created rules to create new rules.

If the Backup Set pane is open when you open the Advanced Rules window, and you save any rule changes, the 
Agent scans the files on the computer again to update the backup set.

The following tables describe the elements in the User-Created Rules pane.
Rules list
Element Description

Category The rule category that is assigned to the rule. 
The Agent uses the following rule categories:

User-Created Files 

Exclusions 

Rule name Unique description of the rule.

Source The source of the rule:

Advanced rules — The rule was added 
from the Advanced Rules pane.

Backup Set selection — The rule was 
added automatically as the result of file 
selection changes made in the Backup Set 
pane.
Details of Selected Rule

To view details for a rule, click the rule. Rule details appear in the Details of Selected Rule field.

Element Description

Category The rule category assigned to the rule:

User-Created Files 

System or Application Files. If your Agent 
is configured for Data Only backups, this 
selection is unavailable.

Exclusions 

Folder Path and folder to which the rule applies.
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Scope Whether the rule applies to files in subfolders:

Include subfolders — The rule applies to 
files in the folder as well as to files in 
subfolders.

Exclude subfolders — The rule applies 
only to files in the folder; it does not apply 
to files in subfolders. 

File name The full or partial names of files that this rule 
matches.

Extensions The extensions for the types of files that match 
this rule. For example, DOC,TXT,PDF.

To match this rule, a file must match either the 
Extensions value or the File type /creator codes 
value, not both. 

Type/creator codes The types or types and creator codes of files that 
match this rule. For example, 
*/MSWD,TEXT/ttxt,“PDF “.

To match this rule, a file must match either the 
Extensions value or the Type /creator codes 
value, not both.

Element Description
Action buttons
Element Description

Opens the New Rule window.

For more information, see New / Edit Rule 
window

Deletes the selected rule.

Lets you edit a rule.

Opens the Action menu.

Moves one or more selected, contiguous rules 
up one position in the Rules list.

Moves one or more selected, contiguous rules 
down one position in the Rules list.

OK Saves changes and closes the Advanced Rules 
window. 
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Cancel Closes the Advanced Rules window, but does 
not save changes. 

Element Description
New / Edit Rule window

Using the Advanced Rules window

Managing user-created rules
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The topics in this section describe the Backup windows.
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The Backing Up progress bar appears while a backup is in progress. 

The following tables describes the elements in the Backing Up progress bar:

Element Description

Progress bar Shows what percentage of the current 
backup is complete.

Backup status message Indicates which phase of the backup is in 
progress. For more information, see 
Monitoring backup progress.
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If your Agent account has backup scheduling permissions, you can use this window to modify the automatic 
backup schedule for your Agent, or disable automatic backups. Your system administrator sets your default 
backup schedule. 

The following table describes the elements in the Backup Schedule window:
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Element Description

Backup automatically according to the 
following schedule

Runs backups automatically during a 
specified time range on selected days. For 
an automatic backup to occur, the 
computer must be powered on so that the 
Agent service is running. The Agent 
window does not have to be open. Select 
a backup time range during which the 
computer will be powered on, and when 
the resources the Agent needs to perform 
the backup will not interfere with your 
work.

To select a time schedule, use the 
following elements:

Days of the week checkboxes. Select 
the checkbox for each day when you 
want a backup to run. Deselect the 
checkbox for any day when you do 
not want a backup to run. You must 
select at least one day.

Earliest time list. Select a time from 
the list to specify the start of the 
backup time period. This time is the 
earliest that the Agent begins a 
scheduled backup. It applies only to 
days when scheduled backups run. 
You select a time period rather than a 
specific time so that the Agent can 
perform the backup at the most 
appropriate time within the specific 
time period.

Latest time list. Select an option from 
the list to specify the end of the 
backup time period. This time is the 
latest that the Agent begins a 
scheduled backup. It applies only to 
days when scheduled backups run.

For example, to run backups five days a 
week between 5:00 and 6:00 at night, 
select the checkboxes for Monday 
through Friday, and deselect the 
checkboxes for Saturday and Sunday. 
Then select 5:00 PM from the Earliest 
time list and 6:00 PM from the Latest time 
list.

Do not back up automatically Backups occur only when the user 
initiates them. There are no automatic 
backups.
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Summary pane information
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The Backup Set pane indicates which files and folders on your computer that the backup set includes.

To use the Backup Set pane, you must have permission to edit your backup set.

The first time you open the Backup Set pane during a session, the Agent scans the files on your computer. During 
the scan, the Backup Set pane shows a question mark (?) next to each folder. The question mark indicates that the 
Agent is determining whether to select the contents of the folder for backup. When the scan is complete, the 
checkbox next to each file or folder indicates whether the file or folder is selected for the backup set.

The following table describes the elements in the Backup Set pane:

Note

The Backup Set pane does not show removable drives, network volumes, or case-sensitive 
volumes.

Element Description

Folders list In the left pane, an expandable list of the folders on your computer. 

To navigate in this pane, perform one of the following tasks:

Click the name of a folder to view the contents of the folder in the right pane.

Expand or collapse a folder to show or hide its subfolders in the left pane.

The checkbox to the left of a folder name indicates whether the subfolders and files in 
that folder are selected for backup.

Content list In the right pane, a list of the subfolders and files in the folder that you selected in the 
left pane. 

Double-click a folder name in the right pane to show its contents.

The Contents list includes the following information:

A checkbox that indicates whether an individual folder or file is selected for the 
backup. For more information, see file selection icons.

Name — The name of a folder or file. 

Date Modified—The date the file last changed.

Size — The size of a file.

Kind — The type of file, based on your the file type associations for your system.

To sort the list, click a column heading. An up or down arrow (for ascending or 
descending sort order) appears in the column heading.

Status bar Shows the total number of files selected in the backup set, the total size of the selected 
files in the backup set, and, if applicable, the maximum backup set size for your 
Agent.

Back Up Now Lets you manually start a backup.

Undo All Changes Lets you restore the backup set selections that were in effect when you started this 
session. 
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Viewing and changing your backup set

Undoing changes to the backup set

Backing up files manually

Toggling Simple and Advanced view
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The Unlocked Files Added to Backup Set window opens if you attempt to add an entire folder to the backup set, 
but the folder contains locked subfolders or files as well as unlocked ones. You cannot select the locked subfolders 
and files for backup because the Agent rule set includes locked rules that prevents those files from being backed 
up. However, all unlocked subfolders and files in the selected folder are selected for the backup set.

The following tables describes the element in the Unlocked Files Added to Backup Set window:

Element Description

Close Closes this window. 

In the Backup Set pane, the checkbox next 
to the name of the folder that you 
attempted to select appears partially 
selected. This appearance indicates that 
some subfolders and files in the folder 
will be backed up, while others will not.
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The Unlocked Files Removed from Backup Set window opens if you attempt to remove an entire folder from the 
backup set, but the folder contains locked subfolders or files as well as unlocked ones. You cannot remove the 
locked subfolders and files from the backup set because the Agent rule set includes locked rules that specify those 
files for backup. However, you can remove all unlocked subfolders and files in the folder.

The following tables describes the element in the Unlocked Files Removed from Backup Set window:

Element Description

Close Closes this window. 

In the Backup Set pane, the checkbox next 
to the name of the folder that you 
attempted to select appears partially 
selected. This appearance indicates that 
some subfolders and files in the folder 
will be backed up, while others will not.
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The topics in this section describe the History windows.
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Use the History pane to view events that the Agent records during backup, retrieval, account registration, 
account recovery, and account software upgrade or file list synchronization.

You can use the History pane to determine whether backups and retrievals were successful, and where errors 
occurred. For example, for a backup event, you can see which files the Agent successfully backed up, and which 
files it could not back up because of system problems.

The History pane lists events in chronological order with the most recent event at the top of the list. To sort events, 
click a column heading. An up arrow appears in the column heading to indicate ascending sort order, and a down 
arrow appears in the column heading to indicate descending sort order.

The following tables describes the elements in the History pane:

Element Description

Status icons Indicates the status of the event. The History 
pane uses the following icons:

 

 — Completed successfully

 — Completed with warnings, or 
postponed

 — Failed, canceled by user, or completed 
with errors

Event Identifies the type of event that occurred. For a 
list of events, see Agent events.

Outcome Describes the outcome of the event. The History 
pane uses the following outcomes:

Canceled by user —You stopped the 
operation while it was in progress.

Completed successfully — The event 
completed successfully.

Completed with errors — The event 
completed, but problems occurred during 
the event that affected the final outcome. 
For more information, see Agent error 
messages.

Completed with warnings — The event 
completed, but problems occurred during 
the event that affected the final outcome. 
For more information, see Agent warning 
messages. 

Failed—A critical error occurred and the 
Agent could not complete the operation.

Start time Date and time that the event began.
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End time Shows the date and time that the event stopped.

Export Exports event details to a TXT or XML file that 
you can mail to your technical support 
representative.

View Shows event details.

Element Description
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The View History Details window shows detailed information about events that occur during an account 
recovery.

The following table describes the elements in the View History Details window:

Element Description

Agent install/Account recovery outcome Shows the result of the account recovery. 
Account recovery can have the following 
outcomes:

Completed successfully

Completed with errors

Failed

Canceled by user

For more information about each outcome type, 
see History pane.

Errors Lists errors that occurred during the account 
recovery. 

For descriptions of the errors that might occur, 
see Installation and account recovery error 
messages.

Export Saves the event details to a TXT or XML file that 
you can mail to your technical support 
representative.

Close Closes the window and returns to the History 
pane.
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The View History Details window shows detailed information about events that occur during an Agent upgrade.

The following table describes the elements in the View History Details window:

Element Description

Agent software upgrade Shows the result of the upgrade. Agent software 
upgrades can have the following outcomes:

Completed successfully

Completed with errors

Failed

Canceled by user

For more information about each outcome type, 
see History pane.

Errors Lists errors that occurred during the Agent 
upgrade. 

Export Saves the event details to a TXT or XML file that 
you can mail to your technical support 
representative.

Close Closes the window and returns to the History 
pane.
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The View History Details window shows detailed information about the events that occur during backup.

The following tables describe the elements in the View History Details window:
Summary section
Element Description

Backup outcome Result of the backup. Backups can have 
the following outcomes: 

Canceled by user

Completed successfully

Completed with errors

Completed with warnings, Failed, 
and Postponed

For more information about each 
outcome type, see History pane.

Note: If a backup fails, but no error 
message appears, the system might 
have shut down unexpectedly, or an 
application might have failed.

Total Time Duration of the event in hours, minutes, 
and seconds.

Total size of backup set Total number and size of the files in your 
backup set.

Files that needed backup Number of files in your backup set that 
were not previously backed up, or that 
had changes that required backup.

Files backed up Of the files that the Agent selected for 
backup, the number of files that the Agent 
actually backed up.

Files not backed up Of the files that the Agent selected for 
backup, the number of files that the Agent 
did not back up.

Size of files backed up Total size of all files that the Agent 
successfully backed up during the 
session.

Size after optimization Total size of backed up data after 
SendOnce® and Delta Block® 
optimization completes.
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Size of data sent Total size of backed up data that is 
transmitted to the Data Center after 
compression occurs.

Errors list Errors that occurred during the backup. 
For more information, see Backup error 
messages.

Warnings list Warnings that occurred during the 
backup. For more information, see Backup 
warning messages.

Element Description
Files Backed Up section
Files Backed Up list Shows the file names and the path to the file 
folder for each file that the Agent successfully 
backed up. This section appears only if the 
Agent backed up one or more files.

Export Saves the event details to a TXT or XML file that 
you can mail to your technical support 
representative.

Close Closes the window and returns to the History 
pane.
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The View History Details window lets you export diagnostic event information. Typically, you need to export 
diagnostic event information only when you work with Support to solve an Agent problem.

The following table describes the elements in the View History Details window:

Element Description

Internal diagnostic outcome Shows the result of the internal diagnostic. The 
internal diagnostic can have the following 
outcomes: 

Completed successfully

Failed

If the outcome is Failed, a message appears with 
more information about the event.

Export Saves the event details to a TXT or XML file that 
you can mail to your technical support 
representative.

Close Closes the window and returns to the History 
pane.
nnected® Backup Agent Help            Iron Mountain Incorporated



Chapter 9: Agent Windows
View History Details window - Retrieve 
Iron Mo
The View History Details window shows detailed information about the events that occurred during a retrieval.

The following sections describe the elements in the View History Details window.
Summary section
Element Description

Retrieve outcome Result of the retrieval. Retrievals can have the 
following outcomes: 

Completed successfully

Completed with warnings

Completed with errors

Failed

Canceled by user

For more information about each outcome type, 
see History pane.

Files retrieved Number of files retrieved and the numbers of 
files selected for Retrieve.

Size of files retrieved Size, in megabytes, of the files that the Agent 
retrieved. This value includes the size of the 
files after the Agent decompresses them.
Errors list 

This section shows errors that occurred during a retrieval or when you cancel a retrieval. For a list of error 
messages, see Retrieve error messages.
Files Retrieved list
Element Description

Files Retrieved list Shows the file name and path to the folder for 
each file that the Agent successfully retrieved. 
This section appears only if the Agent retrieved 
one or more files.

Export Saves the event details to a TXT or XML file that 
you can mail to your technical support 
representative.

Close Closes the window and returns to the History 
pane.
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The topics in this section describe the Preferences window.
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The Backup Options pane lets you view and modify backup options set by your system administrator. 

The following table describes the elements in the Backup Options pane:

Element Description

Backup Mode Specifies the behavior of the Agent if it cannot to 
start a scheduled backup. You can select the 
following options:

Aggressive mode — if a scheduled backup 
cannot start, periodically retry. Select this 
option if you want the Agent to try to start 
the scheduled backup until the backup 
starts. 

Passive mode — if a scheduled backup 
cannot start, sleep until the next 
scheduled or manual attempt. Select this 
option if you want the Agent to wait for the 
next scheduled or manual backup before it 
attempts another backup. 
Changing your backup options
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The File Vault pane lets you manage the Mac OS® X account and password combinations that the Agent needs 
to back up FileVault-protected files if you are not logged on to your computer during a backup. Without this 
information, the Agent does not back up FileVault-protected files unless you are logged on to your computer 
during a backup.

The following table describes the elements in the File Vault pane:

Element Description

Enable the Agent to back up the contents 
of your FileVault-protected home folder 
when you are logged out.

Enables the Account User Name field pop-up 
menu and the Password field.

Account User Name Determines which FileVault-protected home 
folder to access when the user is logged out 
during a backup.

This option is available only after you select 
Enable the Agent to back up the contents of 
your FileVault-protected home folder when 
you are logged out. 

The menu includes user names for accounts that 
have a FileVault-protected home folder. The 
default selection is the name of the user 
currently logged on to the computer, or the user 
name that was last selected.

Password Enables you to specify the password needed to 
gain access to the home folder that is associated 
with the account user name.

Cancel Closes the window without saving your 
changes.

OK Saves your changes and closes the window. If 
you selected Enable the Agent to back up the 
contents of your FileVault-protected home 
folder when you are logged out, the Agent 
validates the password for the selected user 
account name.
Managing FileVault passwords
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The topics in this section describe the Retrieve windows.
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The Retrieve window opens after you select files to retrieve in the Retrieve pane and click Retrieve.

The following tables describe the elements in the Retrieve window:

Element Description

Retrieve Location Select one of the following options:

New Location— Retrieves the selected files 
to a new location. Specify a new location for 
the retrieved files. 

Original Location — Retrieves the selected 
files to their original locations. During the 
retrieval, the Agent adds missing folders as 
needed to recreate the original locations. 
When you select this option, the following 
options become available:

- Rename the files being retrieved — If 
you retrieve a file that has the same 
name as a file in the destination folder, 
but contains data that is different than 
the file in the destination folder, the 
Agent adds the word “Restored” and 
a sequential number to the end of the 
name of the file in the destination 
folder. For example, if, under these 
circumstances, you retrieve a file 
named Report.doc, the Agent 
renames the file in the destination 
folder to Report Restored 1.doc. 
This option is available only if you 
select Original Location.

- Overwrite the files on my computer — 
If you retrieve a file that has the same 
name as a file in the destination folder, 
but contains data that is different than 
the file in the destination folder, the 
Agent overwrites the file in the 
destination folder with the retrieved 
file. This option is available only if you 
select Original Location.

Retrieve Information Number of files selected for retrieval on the 
Retrieve pane and the total size of the selected 
files.

Retrieve Starts the Retrieve operation.

Cancel Cancels the Retrieve operation.
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Use the Retrieve pane to retrieve previously backed-up files from the Data Center. You can use Retrieve to 
recover files that were lost, deleted, or damaged.

This pane contains the following elements:

Element Description

Show Versions Select which version of your backed-up files to 
show on the Retrieve pane. You can select the 
following options:

Most Recent — Show only the most recent 
file versions.

As of Backup Date — Show files backed up 
on a specific date. Opens the Retrieve - 
Version as of Backup Date window.

All — Show all versions of your backed-up 
files. Expired versions that have been 
purged from the Data Center do not 
appear. 

Find Enter the full or partial name of a file (including 
the extension) or folder that you want to find. 
You can include wildcard characters in the Find 
field.

The Find feature includes the following buttons:

 — Start a search or proceed to the next 
matching file.

 — Go back to a previous match.

Backed-up Files list (left pane) Shows an expandable list of previously backed-
up folders on your computer. The list is based 
on the option selected in the Show Versions list.

Navigate this pane in one of the following ways:

Click a folder name to view backed up 
subfolders or files in the right pane.

Expand or collapse a folder to show or hide 
its backed-up subfolders in the left pane.

The checkbox to the left of a folder name 
indicates whether the backed-up subfolders and 
files in that folder are selected for Retrieve.
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Contents list (right pane) Shows the backed-up content for the folder 
selected in the left pane. A backed-up file can 
appear more than once in this pane, depending 
on which Show Versions option you selected. 
Use the file size and date information to select 
the appropriate version of the file.

Double-click a folder name in the right pane to 
show its backed-up contents in the right pane. 

The Contents list shows the following 
information for backed-up files:

A checkbox that indicates whether a folder 
or file is selected for Retrieve.

Name — The file name.

Date Modified— The date and time the file 
was modified.

Size — File size in kilobytes (KB).

Kind— The file or folder type.

To sort the list, click a column heading. An up or 
down arrow (for ascending or descending sort 
order) appears in the column heading.

Status bar The Agent shows status information below the 
Backed-up Files list. The status bar shows the 
total number and total size of the files selected 
for retrieval.

Retrieve Opens the Retrieve window.

Element Description
Finding files for retrieval

Retrieve error messages

Retrieve - Version as of Backup Date

Retrieve overview

Toggling Simple and Advanced view
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Use the Retrieve - Version as of Backup Date window to select a specific backup set that contains files that you 
want to retrieve.

The following tables describes the elements in the Retrieve - Version as of Backup Date window:

Element Description

Backup date and time A list of dates and times when the Agent backed 
up files to the Data Center. 

This list shows one of the following in 
descending order:

Backup dates and times for the last 60 days.

If fewer than 20 backups occurred during 
the last 60 days, the last 20 backups.

The default selection is the most recent backup.
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The Retrieving Files progress bar appears when a file retrieval is in progress.

This progress bar includes the following elements:

Element Description

Progress bar Shows the percentage of the current 
retrieval that is complete.

Retrieval status message Indicates the phase of the retrieval that is 
in progress.
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Use the Edit Profile window to change or add to the information in your profile. Your profile is information in 
the Data Center that is associated with your Agent account. 

Your Agent configuration determines the tabs and fields that the Edit Profile window displays. For example, 
your Agent configuration might exclude the Address tab and the Other tab. Also, your configuration might 
exclude fields from the Edit Profile window or make some fields inaccessible or required.
 

Edit Profile window - User pane

Edit Profile window - Password pane

Edit Profile window - Address pane

Edit Profile window - Other pane

Editing your user profile
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Use this pane to change the information that is associated with your account. Your Agent configuration 
determines which elements that the pane displays.

Element Description

Name

First name Your first name

Middle name Your middle name

Last name Your last name

Email Address

Email address Your email address

Phone Number

Phone number Your phone number

Extension Your phone extension number

Action Buttons

OK Saves changes and closes the Edit Profile 
window

Cancel Closes the Edit Profile window, but does not 
save changes
 

Edit Profile Window

Edit Profile window - Password pane

Edit Profile window - Address pane

Edit Profile window - Other pane

Editing your user profile
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Use this pane to change the password for your Agent account. Your Agent configuration determines which 
elements that the pane displays. 

Element Description

Password

Change password Enables a field that lets you enter a new 
password

Current password The password for your Agent account

New password The new password for your Agent account

Confirm new password The password that you entered in the New 
password field

Action Buttons

OK Saves changes and closes the Edit Profile 
window

Cancel Closes the Edit Profile, but does not save 
changes
 

Edit Profile Window

Edit Profile window - Address pane

Edit Profile window - Other pane

Editing your user profile
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Use this pane to change the address information that is associated with your Agent account. Your locale 
determines the fields that the pane displays.

Element Description

Address

Country The country of your address

Address line 1 The first line of your address

Address line 2 The second line of your address

Address line 3 The third line of your address

City The city of your address

State The state of your address

Zip code The Zip Code for your address

Action Buttons

OK Saves changes and closes the Edit Profile 
window

Cancel Closes the Edit Profile window, but does not 
save changes
 

Edit Profile Window

Edit Profile window - Password pane

Edit Profile window - Other pane

Editing your user profile
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Use this pane to add or change additional contact information that is associated with your Agent account. Your 
Agent configuration determines the elements that the pane displays.

Element Description

Other Contact Information

Company Your company

Department Your department

Location Your location

Mail stop Your mail stop

Cost center Your cost center

Employee ID Your employee ID number

Action Buttons

OK Saves changes and closes the Edit Profile 
window

Cancel Closes the Edit Profile, but does not save 
changes
 

Edit Profile Window

Edit Profile window - Password pane

Edit Profile window - Address pane

Editing your user profile
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This section describes the Welcome windows.
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Your Agent configuration determines whether a Welcome window opens when you open the Agent for the first 
time.

To review your backup set, close the Welcome to the Agent window. After you close the Welcome to the Agent 
window, the Agent scans the files on your computer to compile your backup set.
About your first backup

Perform your first backup as soon after Agent installation as possible. During the first backup, the Agent backs 
up the files in your backup set to the Data Center. The first backup can take several hours to complete. The 
number of files in your backup set and the connection speed of the network determine how long the first backup 
takes. Subsequent backups are smaller and faster because the Agent backs up only new files and changes to 
previously backed–up files.
Backup methods

Your Agent can back up files according to a pre-set schedule, or it can require you to initiate backups manually. 
For your first backup, you might want to start the backup manually, rather than wait for a scheduled automatic 
backup.
Performing your first backup

To perform your first backup, complete the following steps:

1. Close the Welcome to the Agent window. 

The Backup Set pane opens. The Backup Set pane lists the files that are in your backup set. Your Agent 
configuration determines whether you can change your backup set. For more information about how to 
change your backup set, see Viewing and changing your backup set.

2. To start the backup, click Back Up Now. 

The Agent displays the Backing Up window. This window describes the progress of the backup process.

During a backup, the following tabs are unavailable:

Summary

Backup Set

Retrieve

History

For more information about how to check the status of your first backup, see Monitoring backup progress.

When the first backup completes, the Agent receives a backup outcome message from the Data Center. To view 
information about the outcome of your first backup, open the Summary pane, and then view the Last Backup 
section.
File security

When the Agent or Data Center transmit files to each other, encryption keeps your files secure. The Agent 
encrypts your files before it backs them up. The files remain encrypted while the Data Center stores them. When 
the Agent retrieves backed–up files, it receives the files in encrypted format. The Agent decrypts the files after 
they are on your computer.
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Changing your backup schedule

Changing your backup options

Backing up files manually
Iron Mo
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The topics in this section describe the Summary windows.
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The Messages window shows up to 50 of the most recent messages received by the Agent. Agents receive 
messages in the following ways:

A system administrator sends the message.

The Agent generates the message automatically as the result of system activity. 

The Agent receives new messages when it connects to the Data Center.

The following table describes the elements in the Messages window:

Element Description

Message icon, date, and content Messages that describe the outcome of the 
backup. Messages appear by type and 
date received in the following sequence:

 

   Account Canceled or On Hold, or 
Backup Set is over size limit

   Missed backup

   Backup set over size limit

   Messages sent from a system 
administrator or service provider

The most recent messages appear first. 
The Agent removes the following 
message types from the Messages 
window when they are no longer 
applicable: 

Account On Hold

Missed backup

Backup set near or over limit.

For information about each message type, 
see Message type descriptions.

Message links A link to more information about the 
message. If a message includes a link, 
click the link.

Scroll bar A scroll bar that lets you view all 
messages.

Close Closes the window.
Viewing messages in the Messages section
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The following tables describe the elements in the Summary pane:
Last Backup section
Element Description

Outcome icon and description The outcome of the last backup. Backups 
result in one of the following outcomes:

 — Canceled by user

You canceled the backup after it 
started.

 — Completed successfully

Backup completed without warnings 
or errors.

 — Completed with errors

Backup completed, but the Agent 
encountered error conditions. For 
more information, see Backup error 
messages.

 — Completed with warnings

Backup completed, but the Agent 
encountered warning conditions. For 
more information, see Backup warning 
messages.

 — Failed

A fatal error occurred. The Agent 
could not run or complete the 
backup.

End time The date and time when the last backup 
completed.

View Details link A link that lets you view history details 
for the last backup.
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Element Description

Backup Schedule Backup schedule that the Agent uses. 

If automatic backup is enabled, this 
sections shows the day and time settings 
for the automatic backup. For example:

Monday-Wednesday, Saturday 
8:00 PM - 1:00 AM

If automatic backup is disabled, this 
section shows None. 

If your Agent lets you edit your backup 
schedule, the schedule appears as a link. 
Click the link to open the Backup Schedule 
window.

Next automatic backup The date and time of the next scheduled 
backup. 
Messages section
Element Description

Messages The date received and up to four lines of 
text from the most important or most 
recent message that the Agent received.

For more information about the messages 
shown in this section, see Viewing 
messages in the Messages section.

Show all messages link Click to open the Messages window to view 
up to 50 of the Agent’s most recent 
messages.
Action buttons
Element Description

Back Up Now Starts a backup.

For more information, see Backing up files 
manually.
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