
 6
Creating Drawings in 

Pro/ENGINEER
This chapter shows you how to bring the cell phone models and the 
assembly you’ve created into the Pro/ENGINEER Drawing mode to 
create a drawing. A mechanical drawing consists of specifically oriented 
representations of the object being drawn. Each of these representations is 
called a view. There are several types of views, each drawn and 
dimensioned to show a certain kind or amount of detail. 

In this exercise you’ll learn how to add an assembly drawing to a bill of 
materials using the table function. On subsequent sheets you’ll add a few 
of the more widely used view types to detail some of the parts. The object 
of these exercises is not to create a full drawing of all eight parts. Instead 
you are introduced to the basic workflow of the process of creating 
drawings. 

First, review the information on dimensions and views in the next 
section, then follow the exercises to create the drawing files. 
6-1 



Understanding Dimensions and Associativity
Applying dimensions to drawing views in Pro/ENGINEER uses a 
different process from that of other programs. The difference is the 
Pro/ENGINEER associativity factor— instead of using the drafting 
program to add a dimension to a view where you need it, you choose to 
selectively show a dimension that has already been passed, along with 
the view, from the 3D model. This dimension is actively linked to the 3D 
model. As a result, you can directly edit the 3D model through the 
dimension in the drawing. When shown in the drawing, these 
dimensions are called driving dimensions, because they can be used to 
drive the shape of the model through the drawing.

Of course, there will be instances where you need additional dimensions 
to show the same value for the same object, for example, a view repeated 
on another drawing sheet. To add these, use the Dimensions commands 
from the Insert menu. These inserted dimensions are called added or 
driven dimensions, because their association is only one-way, from the 
model to the drawing. If dimensions are changed in the model, all edited 
dimension values and the drawing are updated. 

Displaying passed dimensions rather than adding them means your 
drawing will not be overdimensioned and there won’t be any conflicting 
values on different drawing sheets for the same objects. Once driving 
dimensions are shown, they can be hidden. They are never permanently 
deleted.

The nature of driving dimensions has consequences that a drafter must 
bear in mind when making drawings in Pro/ENGINEER:

• Only one driving dimension for each model dimension may exist in a 
drawing. A drawing may have several views of the same object, but 
only one driving dimension for each feature of the model can be 
displayed. This is to avoid overdimensioning the drawing and to 
avoid editing a driving dimension on one sheet but not another. You 
can move a driving dimension from one view to another, for example, 
from a general view to a detailed view where it is more appropriate. 
To provide dimensioning for views when driving dimensions are 
"used up" in other views, you use added driven dimensions. 

• It is possible to unintentionally edit the model. If a driving dimension 
is edited, it turns white as a warning that there is a discrepancy 
between the drawing and the model. When you regenerate the 
model, the drawing accepts the new dimension. The link between 
model and drawing can be broken when configuration options have 
been set to do this, but this is not recommended.
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Drawing view of 3D model with no dimensions showing

Detail Items
Dimensions are the most important detail items passed from the 3D 
model, but they are not the only items available or necessary to detail a 
drawing. In the same way you show or hide dimensions, you can show 
notes, surface symbols, geometric tolerances, datum planes, and axes. 

Adding Models vs. Adding Views
Before you can add a view of a model file to a drawing, the model file 
must be associated with the drawing file. This is called “adding the 
model,” not to be confused with adding a view. You can associate any 
number of models with the drawing, but only one model can be actively 
worked on at a time. The active model is the one ready to have views 
created for it. The active model name appears in the lower-left corner of 
the work area.

You add the first model when you create the new file, during the new file 
setup. Click File > Properties and then Drawing Models > Dwg Models 
> Add Model on the Menu Manager to add.

If you are working with an assembly, you can use the shortcut menu to 
add and activate any of the parts from the Model Tree.
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Placing General Views and Projection Views
The first view you place will be a type called a general view. You can 
regard a general view as a parent view because its orientation and scale 
can be adjusted, and these properties determine the look of any projected 
views derived from it. 

Projections (projected views) are views derived from the general view, 
which show alternate faces of the general view. Using projections you can 
quickly dimension every surface of a 3D object without repeating a 
dimension. Each projection view exists in either a horizontal or vertical 
projection channel to the right, left,  above, or below the general view. 
Projection views are automatically aligned with the general view within 
their projection channels. By default, they can only be moved within the 
channels they occupy.

General view (center) and four projections

Note
Although alignment with the general view is the usual way to show 
projection views, you are not limited to this method. Double-click a 
projection view. The Drawing Views dialog box opens. Select 
Alignment and uncheck the Align this view to other view checkbox 
to unalign the selected projection view and place it anywhere on the 
drawing sheet.

Creating Detailed Views
A detailed view shows a small area of another view at a larger scale. The 
process puts a boundary and note around the detailed area on the parent 
view and creates the new detailed view to a new scale. You can add 
driven dimensions, or use the shortcut command Switch View to move a 
driving dimension from the parent view to the detail view.
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Detailed view

Scaling Drawings and Views
Pro/ENGINEER automatically determines a scale for a new view based 
on the sheet size and the size of the model being placed. This scale value 
appears in the lower-left corner of the screen. To reset the scale, click  
Edit > Value, then click the scale readout and edit the value in the prompt 
line. (A value of 1 means the scale is one-to-one with the actual 
dimensions, a value of .25 means the drawing is scaled to one-quarter the 
actual dimensions.)  

Note
If necessary, use the default_draw_scale configuration option to 
force a global default scale. 

Only two view types may be scaled independently of the default scale 
setting: the general view and the detailed view. When you rescale a 
general view, its projections also rescale. Because a detailed view is an 
enlargement of a small area, you can scale a detailed view independently 
of its parent view as well as independently of the default scale. 

When you place a general view, you choose Scale or No Scale as part of 
the view properties setup in the Menu Manager. If the view is placed as 
No Scale (the default) and you later want to change the scale, you must 
first modify the view type. If your drawing references several parts, you 
can set the scale independently for each part added to the drawing.

In other words, a default scale is set for each model added to the drawing. 
The scale readout in the lower-left corner refers to the active model. Any 
modifications values for scale, relations, and so forth, are applied to the 
active model.
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Using Formats and Templates
Format files contain the collections of lines and text that border a drawing 
sheet. These serve to divide the sheet into sections and state the company 
name, design name,  and so forth. When you associate a format file with a 
new drawing file, the format graphics appear on all sheets created in the 
drawing file. You can also change the format attached to a drawing file 
after the file has been created and saved. 

There is a default format for each standard sheet size, installed in a 
default format directory. To customize a format, save a default format as a 
new format file, and then add text in the form of notes or graphics, such 
as a company logo. 

Templates are a more advanced concept in Pro/ENGINEER. Templates 
contain all the format information and instructions on how to lay out 
views and projections automatically, as well as how to create tables and 
bills of materials. Templates are a powerful functionality that can save 
hours of interactive work on drawings that follow a standard flow. You 
may use templates in the course of creating drawings eventually, but this 
exercise will explain the more basic drawing functions. 

Creating a New Drawing File
The finished drawing will have an exploded view of the assembly on the 
first page, with a bill of materials and BOM balloons calling out the parts. 
However, because these are the more complex elements of the drawing, 
you’ll add them last. First you’ll add a view of the antenna part to the 
drawing. Later in the tutorial you’ll add the assembly view and the BOM. 
Start the new drawing file:

1. Click File > New and select Drawing from the New dialog box. Name yo
drawing antenna_DR_INL_PE_1 and clear the Use default template ch
box. Click OK. The New Drawing dialog box opens.

2. In the Default Model field, Browse to find your antenna part file. 

3. In Specify Template, click Empty. Click "Landscape" under orientation
       In the Size panel, choose Standard Size, then "A" from the drop down
 
 Watch Video
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            Create a Table Now, you will add a table to the bottom right corner of your              

drawing.  

1.        Go to Table > Insert Table.  Choose Descending > 

Rightward >  By Length > Pick Point. 

 

2.   Click in the area of the bottom right of the Drawing. 

 

3.        You will be prompted to “Enter the width of the first 

column in   drawing units ( MM ) [Quit]” in the dialogue 

just above the drawing area.  Enter 60, then click the 

check mark or hit enter. Since you only need one column, 

click the check mark or hit enter again. This will prompt 

ProE to stop adding columns.  

 

4.    You will be prompted to “Enter the height of the first 

row in drawing units( MM ) [Quit]” in the dialogue just 

above the drawing area. Enter 6, then click the check 

mark. Since you want five total rows, repeat the procedure 

four more times, then click the check mark or hit enter 

again. This will prompt ProE to stop adding rows. 

 

5. You can move the table to the bottom right by clicking on 

the table and using the arrows to drag  it. 

 

6. Double Click in the top cell of the table.  The Note 

Properties box will pop up.  Type in Brockton High 

School, then click OK. 
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7. Fill in the rest of the table as it is below, with your name and 

information. 

 

8. You can change the size of the text by clicking on the Text 

Style tab in the note properties box.  Right Click on the 

table or cell to bring up the Note Properties box.

 

     Watch Video 
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Video
Now you will add a general view and a projection to the sheet, orient the 
view, change the view’s properties and show dimensions.

1. Click Insert > Drawing View > General. You are prompted to select a 
center point for the drawing view. Click the center-right area of the 
sheet. 

2. The view is placed and the Drawing View dialog box opens, showing 
all the saved 3D orientations. In the dialog box, under Model View 
Names, select Front from the list. Click Apply.

3. Under Orientation Method, select Angles. Enter 270 for the angle 
value and click Apply. The view reorients to the horizontal, with the 
tip pointing to the right. Click OK in the dialog box to close it. 

 
4.    Under View Display, choose No Hidden in the Display Style box.
  
   Watch Video 
 

Modify the view
When you placed the view, you accepted the default attributes for the 
view type. Now modify the view for a custom scale. 

1. Right-click the view and click Properties from the shortcut menu.

2. Click Scale from the Categories list, and then choose Custom Scale. 
Enter 2, and then click Apply and Close. The view is drawn to the 
new scale. 

3. Select the view again, right-click and uncheck Lock View Movement 
in the shortcut menu. Use the mouse to move the view to a new 
position. When the view is placed, check Lock View Movement. This 
setting applies to all of the views on the sheet, not only the selected 
view.

Now you’ll add the projection view to show the shaft and tip outer 
diameters. 

1. Click Insert > Drawing View > Projection. Click in the space directly 
to the left of the general view. The projection view is added as shown 
in the next figure.

2. Make sure that your display is set to No Hidden  to show only the 
outer diameter and shaft diameter of the tip. When you change 
display properties, click the Repaint icon to refresh the display. Watch 

General view and one projection
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Add the Detailed View 
Now you’ll add the detailed view. This involves a series of prompts that 
define the elements shown in the following figure. 

Elements of a detailed view

1. Click Insert > Drawing View > Detailed. Click along the outline of 
the tip in the general view. At the spline prompt, use the mouse to 
click-draw a circle to enclose the detail to be enlarged. Middle-click 
when the circle is almost complete. A circle is added around the tip. 

Sketching the outline for the detailed view

2. Define the note and leader location by clicking anywhere near the 
circle. The note is added at the selected point (it can be dragged to 
another position at any time).

3. Click in the upper middle of the sheet, and the detailed view is 
added. Drag it in any direction to redefine its position.

4. Right-click the detailed view, and then choose Properties from the 
shortcut menu. Choose Scale from the Categories list and enter a 
value of 9 for the custom scale, and then click OK.

Detailed view

Boundary circle

Detail note
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Show Dimensions
There are several ways to show or hide dimensions passed from the 3D 
model. You can access the commands from the main Show/Erase dialog 
box or from the shortcut menu when you select either a feature or a 
model in the Model Tree. In this step you’ll use the Show/Erase dialog 
box. In subsequent steps you’ll use other methods.

1. To start, click View > Show and Erase. The Show/Erase dialog box 
opens. 

Show / Erase dialog box

The Show/Erase dialog box controls the display of all information 
objects that can be passed from the 3D model. The Show By area lets 
you selectively show dimensions feature by feature or view by view, 
an ability you’ll find useful when drawings get complex. The 
Options tab is used to filter showing between Erased and Never 
Shown. You may have erased some dimensions on one view with the 
intention of showing them in another. The Erased command lets you 
show only those you erased.

2. To start showing dimensions, click the Dimensions icon in the Type 
area in the upper-left corner. 

3. Click View in the Show By area. 

4. Click the detailed view on the sheet. The passed dimensions are now 
shown on that view. 
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In the Show/Erase dialog box, the Preview tab activates. You can 
select certain dimensions to keep or to remove before you close the 
dialog box. (Remember, these dimensions are never really removed. 
They are only hidden.) By default the Sel to Remove button is active. 

Note
The actual position of the dimensions in your file may vary from 
the illustration, but the same dimensions should be showing.

At this point, if the dimensions don’t look as organized on the 
page as you’d like, don’t worry. First you’ll work on uncluttering 
the detail view by moving some of the dimensions to more 
appropriate views. Then, you’ll select and drag the dimensions to 
their final plotted positions. 

Tip detailed view after showing dimensions 

Note
5. The two diameter dimensions could be better shown on the end 

projection view of the shaft. Hold down the Ctrl key and click them 
both to select them for removal. When they are selected, middle-click 
to complete the selection. They are both erased. Now, you’ll show 
them on the end projection view.

6. Click the Options tab in the Show/Erase dialog box. Leave the Show 
By setting on View, and select the Erased checkbox. Zoom out so you 
can see the whole sheet. Click the end projection view. The two 
dimensions are added to the view. Middle-click to complete. Make 
sure the Never Shown and the Switch to Ordinate boxes are cleared. 
Close the Show/Erase dialog box.
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Return to the detailed view of the tip. As you can see, the length 
dimension of the shaft would also be better on the general view. Transfer 
it as follows:

1. Select the dimension, then right-click and choose Move Item to View 
from the shortcut menu.

2. Now click the general view. The dimension is transferred. This is a 
quick way to move shown dimensions from one view to another. 

Insert Added Dimensions
Finally, before you clean up the layout of the dimensions, you will add a 
reference dimension. This dimension will call out a length that is not 
passed with the 3D antenna: its overall length, the shaft plus the tip. The 
reference dimension will have the suffix REF to show that it is not a 
driving dimension. 

1. From the main menu click Insert > Reference Dimension > New 
References. The cursor changes to a pencil shape. 

2. Click the line representing the end of the tip, and then click the end of 
the shaft. (You can zoom and pan without losing your selection.) 
Middle-click to finish. The dimension is added with the .REF suffix.

Clean Up the Dimensions
Now you’re ready to arrange the dimensions as you want to print them. 
Review the techniques below, and then try to place each dimension on the 
tip detail view so it matches the finished illustration. This is not an 
exhaustive review of all the edits you can make to dimensions, but it does 
cover the basic concepts.

A selected dimension is highlighted and surrounded by drag handles that 
you use to drag it from one spot to another. You must move the cursor 
over each handle to see the direction of movement possible:

•  A four-sided cross cursor means you can drag the dimension in any 
direction. 

• A two-way arrow shows that you can drag on one plane. 

When you select a dimension and drag it into position, the leader and 
witness lines follow with it. You will probably have to zoom in to 
properly pick a drag direction.
Creating Drawings in Pro/ENGINEER 6-11 



Dimension drag handles

Edit Witness Lines and Arrows
You can edit witness lines the same way you edit dimensions: by selecting 
them and using drag handles located at either end. You can lengthen or 
shorten dimension lines or skew them away from their default angles. 
You can also use the shortcut menu to create breaks in them where they 
must cross other lines or leaders, and to create jogs in the witness lines to 
widen the dimension area.  

To edit arrows, select the dimension and use the shortcut menu 
commands. You can change the style of the arrowheads or reverse their 
position on the witness line. 

The next figure shows a solution for the tip dimension. Use the right 
mouse button shortcut commands to make the changes indicated. 

One solution for detailing the tip view

Use drag handles to 
move a selected 
dimension

Break

Mod Attach
Flip Arrows

Make Jog
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Create a Second Sheet

Now you’ll create a second sheet, and see how to place an exploded 
view of the cell phone assembly. Follow the guidelines below to create an 
exploded assembly view on a new sheet, create a bill of materials, and 
show the BOM balloons.

Create an Exploded Assembly View

Click Insert > Sheet. A new sheet is added, and listed in the lower right 
corner as 2 of 2. Click Edit > Move Sheet. In the dialog box, select Insert 
at Beginning and click OK. The new sheet is now Sheet One. Now 
you’ll add the assembly file to the drawing models.

1. Right-click the new sheet and choose Properties from the shortcut 
menu. The Menu Manager opens. Click Drawing Models > Add 
Model. Use the browser to choose the assembly file.

2. Right-click and select Insert > General View.

3. Choose DEFAULT ALL in the Select Presentation dialog box. Click 
the sheet, and then OK to place the view.

 
4,    Set up a table like you did for the first sheet. 
   
Creating Drawings in Pro/ENGINEER 6-13 



 

Creating Drawings in Pro/ENGINEER                          6-13a 

 

 

 

Sheet with the Left View inserted 
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Create a Bill of Materials
In this sequence you’ll see how to add a very basic bill of materials to the 
drawing. A bill of materials is the most common use of a report table in 
Pro/ENGINEER. The report table “reads” parameters you enter as text 
into the cells and automatically adds cells in additional rows to 
accommodate information returned from the design database. 

Setting up a report table can be a complex process, but once defined you 
can save and reuse report tables on other drawings. This exercise 
demonstrates as simply as possible how report tables work in 
Pro/ENGINEER. 

Create the Table
A table is a series of cells of a given height and width. You can enter 
"dumb" text into the cells, for example as a column heading. The first step 
in creating the BOM is to define the table.

1. Click Table > Insert > Table. In the Menu Manager, select Descending >
Rightward > By Num Chars > Pick Point. Click at a point where the upp
corner would be on the sheet. A scale of numbers appears 
horizontally from the clicked point. 
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2. Click around the number 5 or 6. The width of the first column is 
defined, and the scale moves to the right. 

3. Click the scale again to define another column width about twice as 
long. When you have defined this column, click the middle mouse 
button. The horizontal scale is replaced with a descending horizontal 
scale. Now you’ll define the number of rows.  

4. You’ll need two rows to start, one for the column headings and one 
for the parameters. Click twice down the scale to create the two rows 
and middle-click to complete the cells. The table should look like this. 

Note
You can always resize cells after you create them but in this case, 
as you practice, it may be easier to delete the table and start 
again.

Enter Text Headings
Now you’ll enter the headings for each column. 

1. Double click the upper-left cell. The Note Properties dialog box 
opens. Use it to type Index in the text area and click OK.
Creating Drawings in Pro/ENGINEER 6-15 



2. In the same way, insert the heading Part Name in the next column. 
The table should look like this: 

You created some table cells, and entered simple text into two of them. To 
adjust the cell size, right-click the cell and choose Height and Width from 
the shortcut menu. 

Now you will set up the remaining cells to expand with information. To 
do this, you first designate the empty cells as repeat regions, or cells that 
will expand automatically to create the finished table. You then "build" 
the parameters you want to enter by selecting text strings from a 
hierarchical menu. 

Define a Repeat Region
1. Click Table > Repeat Region. The Menu Manager opens. 

2. Click Add. You are prompted to select the corners of the region. 

3. Click the lower-left cell, then the lower-right cell. Both cells are 
highlighted. Click OK, then Done on the Menu Manager. 

Now you are ready to enter the parameters for the assembly index 
number and matching part name.

Add BOM Parameters
1. Double-click the left side cell of the repeat region. Because it is now a 

repeat region, the Report Symbol menu opens by default. These are 
the top-level prefixes, denoting the modules for which reports may 
be generated. This menu lets you assemble a report parameter string 
by “punching down” through eligible parameters. 

2. Click rpt..., then index. The cell now contains the heading 
rpt.index. Now double-click the lower-right cell and then asm. > 
mbr. > name on the Report Symbol menu. The assembly member 
name parameter you have just created is entered into the cell.

3. Click Table > Repeat Region > Update Tables > Done. The table is 
expanded to show the information as defined by the parameters.
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Show BOM Balloons
BOM balloons are the finishing touch to the first sheet. First you’ll assign 
an existing repeat region as a BOM balloon region. Then all you need to 
do is choose to show the balloons, and arrange them as you want them.

1. Click Table > BOM Balloons. In the Menu Manager, choose Set 
Region. You are prompted to select a region in the table. Because the 
table has only one region, click anywhere in the table to select the 
region. Once the region has been selected, the rest of the Menu 
Manager items are available.

2. Now click Create Balloon on the Menu Manager under BOM 
BALLOONS. You are prompted to select the view in which to show 
them. Click the Left view, and then Done on the Menu Manager. 
The BOM balloons are added to the view.

3. You can right-click the view and choose Cleanup BOM Balloons 
from the shortcut menu to modify the positions of all balloons. To 
fine-tune the layout, select and drag each balloon separately to a new 
location, or right-click a specific balloon and choose Edit Attachment 
to select a new attachment edge on the object.

Exploded view with BOM balloons on next page
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Finished Sheet with BOM Balloons. 
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Printing your Drawings 
1. Go to File > Print > Configure > Model.   

2. In the Plot box, choose Full Plot.  In the Scale box, type in  .93. 

 

 

  3.   In the sheets range, choose All.  Click OK.   

 

 

 

 

 

 

 

 

 

 

 

 4. Choose the HP 4200 LaserJet Printer.  Click OK and Print.  Staple 

your drawings and hand them in. 
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