
1 

Creating Posters for Professional Meetings 
 
Goal: Create a poster to be displayed at professional meetings.  
 
Tasks to be covered: 
 

1. Getting Started  
2. Content  
3. Poster Design Tips 

a. Color 
b. Text 
c. Illustrations 
d. Layout 

4. Adobe Illustrator Basics 
5. Using Adobe Illustrator tools 
6. Inserting and Editing Files from Other Applications (Excel charts, Word 

documents, JPEGs/image files) 
7. Saving and Exporting your file as a PDF 
8. Printing a Preview of Your Poster 
9. Preparing Your Poster for Professional Printing  
10. Online Guidelines, Tips and Instructions for Preparing Posters 
11. A few recent books added to the Demography Library collection on generating 

graphics with statistical data 
 
Templates with the Penn Logo for large professional posters (created in Adobe 
Illustrator) are available in the shared network drive (psc$ on 'pscworld 
(pscworld.ssc.upenn.edu)') in a folder called “Templates”. To access these poster 
templates, go to My Computer. Open the Network Drive (psc$ on 'pscworld 
(pscworld.ssc.upenn.edu)') and then open the folder “Templates” and then open the 
folder “PAA poster templates” [J:\Templates\PAA poster templates]. 
 
These poster templates are available in 96" x 48", 96" X 40", 60" x 40", and 80" x 40". 
There are a few different color schemes and designs to choose from but you can 
modify them in any way you would like including poster size. 
 
Download the Penn Logo of your choice with your PennKey here: 
http://www.upenn.edu/webguide/style_guide/logo.html  
 
 
 
1. Getting Started 
 
The goal of a poster presented at a professional meeting is to: 
 

(1) attract attention to your research with a well designed poster 
(2) efficiently communicate information about your research 

http://www.upenn.edu/webguide/style_guide/logo.html
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(3) give you an opportunity to network with other researchers interested in the 
field.  

 
Your poster should be visually appealing, easy to understand, accurate and should 
provide a snapshot of your research.  
 
In many cases, you should be present at the poster session to explain your poster and 
to answer questions. Part of your goal is to engage your audience and to share your 
research. It's a good idea to have business cards or a few handouts on hand to give to 
people who are interested in following up with you about your research later, but read 
your conference poster session guidelines to find out what is or is not allowed. 
 
 
2. Content 
 
Each conference will have its own poster session guidelines. Be sure to follow those 
instructions regarding specific poster elements.  
 
*For advice or opinions about the content of your poster, please consult a GGD Faculty 
member, PSC Research Associate, or your advisor for assistance. 
 
*No additional mounting is necessary if you print your poster on one of the media 
described in section 9. 
 
 
3. Poster Design Tips 
 
Color 
 
Color in a poster presentation is a very useful tool. An effective color scheme is more 
than just making the poster look pretty. Color can be used to draw attention to your 
poster and make it stand out from the many other posters in the room. Small bits of 
color strategically placed around the poster can highlight areas that are important. 
 

1. In the very beginning, choose a few colors that you will be working with 
throughout the entire poster design process.  

2. Use these colors when creating your graphs, charts, illustrations, etc.  
3. Avoid harsh, contrasting, primary, or neon colors. While your poster should 

standout, it should also be pleasing (and easy) to look at. 
4. Text should be placed on a contrasting light/dark color. (Light-colored text on a 

dark background or dark-colored text on a light background.)  
5. Avoid large amounts of light text on dark backgrounds. This can be useful in 

small amounts—titles, headings, etc. In large paragraphs, it can be tiring on the 
eyes. 
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6. Kuler at: http://kuler.adobe.com/ is a great resource for finding color themes that 
you might want to use in your poster. Once you find a theme you like click on this 
icon, which allows you to view the color values and make changes to the theme. 

 
 
Text 
 

1. Title should be at least one inch high (approx. 120pt type size.)  
2. Main text should be a 24pt or 36pt type size.  
3. Avoid text in all UPPER CASE. IT CAN BE DIFFICULT TO READ IN LARGE 

AMOUNTS OF TEXT. MAKE TEXT AS EASY TO READ AS POSSIBLE. 
4. Use bold or italics for emphasis.  
5. Choose fonts that are appropriate for a professional publication.  

Fonts often used in main text (serif fonts): Times New Roman, Palatino 
Fonts often used in titles and headings (sans serif fonts): Arial, Tahoma, Myriad 
(These are merely suggestions--any of these fonts would be fine choices.)  

6. Avoid fonts that are distracting or difficult to read. Avoid all fonts that are 
designed to look like hand-writing. (Comic Sans, Monotype Corsiva, Curlz.) 

7. The “Title” banners often contain author(s) and affiliations as well 
 
Illustrations 
 

1. Use illustrations as much as possible (graphs, charts, tables, figures, maps, 
images, etc.). 

2. Text should be used to support the illustrations (see the poster guidelines for 
your conference). 

3. Include a legend describing the content of the figure and your conclusions. 
4. Label illustrations and figures with a title or heading. 
5. They should be able to viewed and read from a distance. 
 

Layout 
 

1. Do not overcrowd the poster.  
2. Allow margins of at least 3-4 inches between all major poster components. 
3. Organize components into columns. Columns of text should be no more than 

approx. 14 inches wide avoiding long textual passages. 
4. Columns are easier to read at a large scale than rows. 
5. Use bulleted lists wherever possible (instead of long paragraphs). 
6. Graphs and charts should be labeled using either numbers or letters at least one 

inch high (see the poster guidelines for your conference). 
7. Other graphic elements (such as arrows or lines) can be used to lead the 

reader’s eye from one point to another.  
 
* Non-traditional and non-linear posters have also won awards. Sometimes 
experimenting with layout can be an effective way of conveying the content of your 
poster. If you have any ideas or other layouts in mind but are not quite sure how to do it, 

http://kuler.adobe.com/
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please contact Demography Library staff for assistance. We are more than happy to 
meet with students individually. 
 
 
4. Adobe Illustrator Basics (Instructions may vary slightly between versions) 
 
Illustrator is a desktop publishing program that is most useful when creating large 
posters of this size. Demography Library staff have created several templates to choose 
from with most major design elements already incorporated into the poster. These 
templates are available in the shared network drive in a folder called “Templates,” see: 
J:\Templates\PAA poster templates. You may also create your own files without the use 
of any templates. 
 
Instructions for working with Adobe Illustrator in the PSC Lab (the PC to the left and the 
PC to the right of the scanner have Illustrator installed on them: 
 
Opening a template. 

1. Launch Adobe Illustrator.  
2. File > Open > Choose template from the “Templates” folder on the shared 

network drive “psc$ on ‘seadog”. 
3. Save file. 

 
 
OR Create a new file. 

1. Launch Adobe Illustrator. (Shortcut is located in the Multimedia folder on the 
desktop.) 

2. File > New 
 

 
 
3. Name the file. 
4. Type in the dimensions of the poster. 
5. Select CMYK in the Color Mode. 
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6. Press OK. 
 
 
5. Using Adobe Illustrator Tools 
 
 

  
 

 
 
About the toolbar: 
 
Shown above are some of the more common tools that you are most likely to use when 
working in Illustrator. For more detailed information about any of the tools, go to the 
Help menu > Tutorials > Using Tools and Commands. 
 
(Some tools in the toolbar have a small triangle in the lower right corner. This indicates 
that more similar tools are hidden underneath. To reveal these hidden tools, click on the 
icon and hold until another option bar appears.) 
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Selection tool selects the entire object. You will probably use this tool more than any 
other tool. Before any other command, you will most likely have to select the object first. 
Selection tool is also used to move an object around within the document 

 
 

 
Type tool.   
 
Draw a text box. Type directly into the textbox, or copy/paste text from another 
document (such as a Word document.) Use the selection tool to adjust the size of the 
textbox at any time. It will not affect the text inside. However, if the text cannot fit inside 
the text box, the text will be cut off. 

 
 

Rectangle Tool (and other shape tools hidden underneath.) These tools are used to 
draw shapes. These shapes can be modified using the direct selection tool. 
Surrounding each shape is a border called the stroke.  

 
Adjust the thickness of the stroke (border) by changing the weight in the stroke palette.  
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Color Picker: Changes the color of any object or text that is selected. A red line 
through the box indicates that no color is selected. The box in the top left is the main 
color (used for the object, text, etc.) The color in the bottom right is for the stroke (or 
border) of an object.  
 

 
 
To change the color (in either the main object or in the stroke) double click the box and 
choose a new color from the color picker. Press OK. 
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6. Inserting and Editing Files from Other Applications 
 
Inserting an Excel Chart  

1. Open spreadsheet containing the chart you wish to import into your poster. 
2. Select the chart. 
3. Edit > Copy. 
4. Open poster in Illustrator. 
5. File > Paste. 

 
 
Inserting a Word Document 

1. Open poster in Illustrator 
2. File > Place > choose Word Document you wish to insert. (Another additional 

dialog box will appear. Keep all boxes checked and select OK.) 
 
(Text can also be brought into Illustrator by copying and pasting from a  
Word document or by typing directly into a text box. See Using Adobe Illustrator 
Tools for information about the type tool.) 
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Inserting a JPEG or other image file 
 

1. Open poster in Illustrator 
2. File > Place > choose image files you wish to insert. 

 
Be sure that any image file you insert has a resolution of at least 300 dots per inch 
(dpi). This is the minimum resolution for printing. Images meant for screen viewing 
typically have a resolution of 72 dpi because this is the maximum resolution of a 
computer screen. Images pulled off the web will not print well because the resolution is 
too low. 
 
It is very important to understand that just because an image looks good on the screen, 
it may not look that way when printed.  
 
 
Editing objects inserted from other applications 
 
Editing an Excel chart  
 
When an Excel chart is imported into Illustrator, it is appears as one single object. 
However, it is actually a collection of very small objects grouped together. For the most 
part, you want to keep everything in the chart grouped together as one object. It is 
easier to move it around the poster if you do not have to select each individual 
component separately.  
 
If you need to edit any part of the chart after it has been inserted, it will need to be 
ungrouped. The chart has several layers of groupings based on what areas you might 
want to be separated at one time. You may have to ungroup several times before every 
component is completely separated from each other. 
 

1. Select the chart. 
2. Choose Object (in the top main menu) and scroll down to Ungroup. 
 
If the component is still grouped with something else, it will need to be separated 
again.  
 
3. Select the parts of the chart that needs to be separated. 
4. Right click and scroll down to Release Clipping Mask. 

 
Everything should be separated. Now you can make the desired changes (change 
the colors, edit the text, etc.) 
 
 At this point, it is safest to re-group all of the pieces back together again so that 
nothing is accidentally moved out of place. It will also make it easier if you choose to 
move the chart around the poster. 
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1. Using the Selection Tool, draw a selection box around the entire chart (including 

each individual component).  
2. Choose Object (in the top main menu) and scroll down to Group. Each of the 

smaller components are now grouped back as one single object again. 
 
 

Editing a Word Document  
 

Once a Word Document is inserted into Illustrator, it becomes an Illustrator text box. 
The text can be edited and formatted as you could with any other text box created in 
Illustrator. Use the “Type Window” to change the font, the size, and paragraph options. 
(See “Using Adobe Illustrator Tools—Text”.) 
 

 
 
 
Scaling an object (making it bigger or smaller) 
 

1. Select the object using the Selection Tool. There will be small white boxes on 
each of the corners of the selection box. 

2. Roll your cursor over one of the boxes until your cursor turns into a double-sided 
arrow. 

3. Press down with the mouse + hold the Shift key down.  
4. While holding both the mouse and the shift key down, drag the corner to the 

desired size. (Holding the shift key down while dragging the corner will constrain 
the proportions.) 

 
Rotating an object  
 

1. Select the object using the Selection Tool. 
2. Right click and scroll down to Transform > Rotate 
3. A new dialog box will appear. Insert how many degrees you would like to rotate 

the object, and press OK. 
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Arranging the order of objects  
 
As objects are brought into an Illustrator file, they are layered in the same order as they 
were brought in. The object imported most recently will appear as though layered on top 
of something brought in before it. You change this by arranging the order of the object. 
 
1. Select the object. 
2. Right click and scroll down to Arrange > choose from Bring to Front,  
 Bring Forward, Send Backward, or Send to Back. 
 
 
7. Saving and Exporting your file as a PDF. 
 

1. File > Save As 
2. Select Adobe PDF as the File Type in the drop-down menu. 
3. Press Save. 
 

 
 
4. Another dialog box will appear. Keep the Illustrator Default settings. 
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5. Press Save PDF. 
 

 
 
 

 
8. Printing a Preview of your Poster  

 
On one sheet of paper 
Print out your poster on a single sheet of paper to get a good sense of how the 
elements in your poster are spaced out and sized.  
1. Open your PDF file 
2. Go to File > Print 
3. Select the Printer \\seadog\PSCLAB_Color 
4. Make sure the paper Scaling is set to “Fit to paper” 
5. Click OK 
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On multiple sheets of paper  
To get a good sense of what your final product will more or less look like print out 
a full size color copy on multiple sheets. This will give you an opportunity to make 
changes and corrections, etc. to problematic areas of your posters that you may 
not have noticed on screen. 
 
1. Open your PDF file 
2. Go to File > Print 
3. Select the Printer \\seadog\PSCLAB_Color 
4. Make sure the paper Scaling is set to “Tile large pages”  
5. Click OK 
 
(The printer will automatically print your poster out at the appropriate size and will 
determine the number of sheets it will need to be printed on. Since the printer 
does not allow printing to the edge of the paper there will be a whit border around 
your poster. The poster was designed to be 96 x 48 inches wide – it will print out 
on 65 sheets of paper. The 65 sheets measure 110.5 x 55 inches although the 
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actual printed image of your poster should measure 96 x 48 on those printed 
sheets.) 
 

 
 
 
9. Preparing your Poster for Professional Printing 
 
Cost of Printing Posters 

 
Funding 
GGD students should ask Tanya Yang for funds to print posters, in 2014 the 
GGD has set aside funding for supporting poster printing. If you are in Sociology 
or Economics please consult your Graduate Chair or Faculty member you are 
working with for information on whether there are funds available for printing 
posters for professional meetings. 
 
Poster printing prices usually vary depending on the size of the poster, paper 
stock selected, and where you get your poster printed.  
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PSC Folks have printed posters at all of these location with success, so pick 
whichever is most convenient to you.  
 
Poster Printing at the Weigle Information Commons at Van Pelt (40” is the 
max. height) http://wic.library.upenn.edu/wicfacilities/posterprinter.html 
You must reserve a time to print your poster at the website above. No more than 
7 posters will be printed in a day. They charge $0.025 per square inch. So if your 
poster is 24 inches by 36 inches, the charge would be $0.025 x 24x 36 = $21.60.  
Some standard sizes and costs:  

Poster Size Cost 
40" x 60" $60.00 
30" x 40" $30.00 
24" x 36" $21.60 
18" x 24" $10.80 
40" x 80" $80.00 

 
SlideMakers http://www.slidemakers.com/ 
(Local Business; Free on campus delivery; Will ship elsewhere as needed; Offers 
a foldable fabric poster option; Will match or beat competitor pricing; If using 
university or grant funds, they are an approved vendor in BEN; They will also 
hand deliver if necessary) 
 
PosterSession http://postersession.com/ (Has poster templates for download) 
 
Campus Copy Center http://www.campuscopycenter.com/  
(Local Business: Will deliver on campus as needed) 
 
Illustrator TEMPLATES:  
J:\Templates\PAA poster templates 
http://clark-it.stanford.edu/poster.htm#templates  
 
PowerPoint TEMPLATES: 
http://www.postersession.com/templates.php  
http://www.makesigns.com/SciPosters_Templates.aspx  
http://www.genigraphics.com/templates/default.asp  
http://www.posterpresentations.com/html/free_poster_templates.html  

 
10. Online Guidelines, Tips and Instructions for Preparing Posters 
 

Population Association of America Poster Session Winners: 
http://www.populationassociation.org/sidebar/annual-meeting/poster-winners/  

 
UNC has instructions online on how to prepare Posters and PDFs of posters at:  
http://gradschool.unc.edu/student/postertips.html#software  

 

http://wic.library.upenn.edu/wicfacilities/posterprinter.html
http://www.slidemakers.com/
http://postersession.com/
http://www.campuscopycenter.com/
http://clark-it.stanford.edu/poster.htm#templates
http://www.postersession.com/templates.php
http://www.makesigns.com/SciPosters_Templates.aspx
http://www.genigraphics.com/templates/default.asp
http://www.posterpresentations.com/html/free_poster_templates.html
http://www.populationassociation.org/sidebar/annual-meeting/poster-winners/
http://gradschool.unc.edu/student/postertips.html#software
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PAA Posters by PSC folks: http://www.pop.upenn.edu/publications/posters  
 
11. A few recent books added to the Demography Library collection on generating 
graphics with statistical data 
 

Data analysis and graphics using R: an example-based approach. By John 
Maindonald and John Braun. Cambridge; New York: Cambridge University 
Press, 2003.  
BK QA276.4 .M245 2003 
 
R graphics. By Paul Murrell. Boca Raton, FL: Chapman & Hall/CRC, 2006.  
BK T385 .M9 2006 
 
Statistical analysis and data display: an intermediate course with examples in S-
plus, R, and SAS : with 200 figures. By Richard M. Heiberger and Burt Holland. 
New York: Springer, 2004. SR QA276.4 .H45 2004 
 
Using SPSS for Windows: data analysis and graphics, 2nd edition. By Susan B. 
Gerber and Kristin Voelkl Finn. New York: Springer, 2005. 
 
The visual display of quantitative information, 2nd edition. By Edward R. Tufte. 
Cheshire, CT: Graphics Press, 2001. BK QA276.3 .T83 2001 
 
A visual guide to Stata graphics. By Michael N. Mitchell. College Station, TX: 
StataCorp LP, 2005. SR QA276.4 .M58 2004 
 
Visual statistics: seeing data with dynamic interactive graphics. By Forrest W. 
Young, Pedro M. Valero-Mora, and Michael Friendly. Hoboken, NJ: John Wiley & 
Sons, Inc., 2006. BK QA276.3 .Y68 2006 

 
Please feel free to ask Demography Library staff for assistance. We are more than 
happy to meet individually. psc_library@mailman.ssc.upenn.edu 

 
Get started early! 

Plan ahead! 
Good Luck! 

 
(This guide was originally created by Laura J. McNamara on February 6, 2006 and was last revised on April 11, 2014 

by Nykia M. Perez Kibler.) 

http://www.pop.upenn.edu/publications/posters

