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Chapter 1

Introduction to ES Cross Stitch

Cross stitching is a popular technique for filling large areas with low stitch 
counts. It can also be used for outlines and borders. It is suitable for 
homeware, tablecloths, children’s clothes and folk designs. Cross stitch 
is also sometimes combined with appliqué.
Unlike machine embroidery where designs are enhanced with different 
stitch types, angles, and effects, in cross stitch you can only add 
dimension to the design with shades of colors. For this reason, most cross 
stitch designs use many more colors than machine embroidery. 

Note  ES Cross Stitch is an add-on cost option for most levels of Wilcom 
ES. You must have the cross stitch option activated in your software to 
use cross stitch. If you do not see the command under the correct menu, 
contact your dealer to upgrade and add the cross stitch features.
This section provides an overview of the various cross stitch types.

Types of cross stitch
Cross stitches are created on a matrix of squares or ‘pixels’. Any part of 
the square can be stitched, from the edges to the diagonals. The full 
range of cross stitches is listed below.

Full Cross Upright Cross
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Cross stitch fills
When using cross stitch as a fill you can select from any of the cross stitch 
fill types.

Full cross stitch

Full cross stitch 
pattern

Full cross stitches are made up of 
two equal-length stitches that 
cross at the center to form an X. 
The overall effect depends on 
which stitch within the X lies 
beneath or on top. You can also 
mix and match for special effects.

Three-quarter cross stitch
A three-quarter stitch is most 
often created by stitching a 
quarter stitch followed by a half stitch. A different effect is achieved by 
stitching the half stitch first and anchoring it with the quarter stitch.

Note  The long arm of the three-quarter stitch can go either / or \ 
directions.

Three-quarte
r cross stitch 
pattern

Three-Quarter Cross Double Cross

Half Cross Elongated Vertical Cross

Quarter Cross Elongated Horizontal Cross

Mini Cross Single Line

French knot
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Frequently a quarter stitch and a three-quarter stitch of different colors 
share a single square. Mix and match their positions to give different 
effects.

mixtures of quarter 
and a three-quarter 
stitches

Half cross stitch
A half stitch is simply a diagonal stitch that looks like / or like \. Half 
stitches are usually used for shadows and background shading. The stitch 
can start from any corner. Sometimes two half stitches of different colors 
are used to make one full cross stitch.

Half cross stitch 
pattern

Half stitches can go in either direction depending on the effect you want 
to achieve. For example, half stitches used to represent feathers would 
slant in the direction of the feathers themselves.

Quarter cross stitch
Quarter stitches are used to stitch more intricate patterns.

Quarter cross stitch 
pattern
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Mini cross stitch
Mini cross stitches are two equal-length stitches that cross at the center 
to form an X but they only fill quarter of the square. Use mini cross stitch 
for details such as eyes or for a denser look in parts of your design.

Mini cross stitch 
pattern

Upright cross stitch
Upright cross stitches are comprised of a vertical and horizontal stitch. 

Upright cross stitch 
pattern

The stitches can be worked diagonally across the canvas, or in a 
horizontal or vertical line.

Double cross stitch

Double cross stitch 
pattern

Double cross stitch is comprised of two full 
cross stitches stitched at 45º to each other. 
A double cross stitch resembles a star. It is 
generally used in a scattered fashion or 
worked into a row to form a decorative 
border.
Typically the top thread of the bottom cross 
is the stitch which lies at 135º to the 
horizontal, while the top thread of the 
overlapping cross is the horizontal stitch.

Elongated cross stitch
Elongated cross stitch consists of two equal-length stitches that cross to 
form an X. There are two types:
 elongated horizontal cross stitch
 elongated vertical cross stitch.
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Elongated horizontal cross stitches are only half the height of normal 
cross stitch and elongated vertical cross stitches are only half the width 
of normal cross stitch.

Elongated vertical cross 
stitch pattern

Elongated horizontal 
cross stitch pattern

French knots
French knots were originally a hand-stitch used for a raised look for 
embellishment in Europe. It was traditionally used in ‘whitework’ with 
very exclusive cotton, and fine silk threads. French knots can be used in 
combination with other cross-stitch types.
Use french knots for eyes, door knobs, dots for flower pistils or in the 
place of beads used in hand-work designs, e.g. ornaments on a 
Christmas tree, to dot the letter i. Use it as an outline border. Try it with 
colorful metallic or variegated threads. French knots are better sewn in 
larger grids.

Petals stitched as 
french knots

Cross stitch borders
Cross stitch can be used as an embroidery outline. You can also combine 
cross stitching with other stitch types to achieve special effects.
You can make outlines with Single Line or Full Cross stitches or a 
combination of both for a denser border. A Single Line outline is treated 
by the software as a border while a Full Cross outline is treated as a fill. 
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This is important if you need to delete a border because a single line can 
be deleted as a single object while a full cross stitch border cannot.

Single line border

Single line black 
border

Single line stitches are only used to 
create borders or add details. The single 
line can be placed on any side of the 
square. Click on the side you want to 
place the line. You can place a single 
line border on one side or all four sides 
of the square. The single line border can 
be placed in a square which already has 
a cross stitch in it.

Full cross border

Full cross black 
border

Full crosses can also be used as a 
decorative outline stitch. If you use full 
cross as a border it will be the same 
cross stitch type as selected in the fill 
stitch type list. You can change this by 
changing the fill stitch type.

Cross stitch variations
The orientation of fractional cross stitches can be varied to create 
different patterning effects. You do this directly pixel-by-pixel, or by 
setting a fill stitch orientation. You can also combine fractional cross 
stitches in a variety of ways. See also Types of cross stitch.

Three-quarter cross stitches
Quarter and three-quarter cross stitches can be used to create rounded 
edges. See also Cross stitch fills.
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Half cross stitches
Half cross stitches can be used to give objects an ‘airy’ look. You can also 
use half cross stitches to make a full cross stitch with two colors. See also 
Combination stitches.

Combined to make 
two-color full cross

Two half 
crosses

Quarter cross stitches
Quarter and three-quarter cross stitch can be used to smooth rounded 
edges. You can also use quarter cross stitch to make a full cross stitch 
with up to four colors. See also Combination stitches.

Combined to make 
four-color full cross

Four quarter 
crosses

Mini cross stitches
Use mini cross stitch for details such as eyes or for a denser look in parts 
of your design.

Four mini 
crosses

Combined to 
make four-mini 
full cross

Elongated cross stitches
Vertical and horizontal elongated cross stitches are made up of two 
equal-length stitches that cross to form an X. They fill either the left, 
right, top or bottom of the square.

Elongated 
cross stitch 

patterns
Combined elongated 

cross stitches



Chapter 1   Introduction to ES Cross Stitch 8

Combination stitches
Quarter, half and three-quarter cross stitches can be combined to make 
crosses comprised of multiple colors. You can also combine mini 
crosses, elongated vertical or horizontal crosses and outline stitches.

Combination of 1/4, 1/2 and 3/4 crosses

Combination of elongated vertical or horizontal crosses

Combination of fractional and mini crosses

Combination of colored outlines

Combination of outlines and crosses
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Chapter 2

Cross Stitch Essentials

In ES Cross Stitch you can add cross stitches either to an entire design 
or selected areas. Or you can place them individually. There are two 
stitch types, outline and fill. An outline stitch can be a single run, or a 
line of cross stitches. A fill can be any of the cross stitch types. You can 
pre-set stitch type, length and the number of times each stitch is sewn.

This section describes the use of the cross stitch design window, 
techniques for manual cross stitch digitizing, and cross stitch design file 
handling.

Opening ES Cross Stitch
Cross stitch design involves a different digitizing technique to ordinary 
embroidery design. For this reason, the cross stitch application has its 
own design window which you open from within EmbroideryStudio.

To open ES Cross Stitch
1 Run EmbroideryStudio.
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2 Select Special > ES Cross Stitch. The ES Cross Stitch design 
window opens.

Title bar
Menu bar

Status line

Edit toolbar

Design window 

Cross stitch toolbar

Pointer toolbar

Color palette

Stitch toolbar

Input toolbar

General toolbar 

Note  Cross stitch toolbars include the Standard and Stitch toolbars 
across the top of the design window. The Pointer, Input, Edit and 
Cross Stitch toolbars are located at the left of the design window. You 
can click and drag toolbars into the design window. Double-click the 
title area of the toolbar to return it to its original position.

Changing grid settings

Click General > Grid to show or hide the grid. Select Options (Special 
menu) to change grid settings.

Use the Options > Grid dialog to change grid settings:
 show or hide the grid
 show major lines (when grid is on)
 set the grid spacing
 change the color of major and minor lines.

To change grid settings
1 Select Special > Options.
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2 Select the Grid tab.

Select to show grid 

Enter number of 
crosses to fit 

between major lines

Select to show major 
lines

Edit line colors 

3 Select the Show Grid checkbox to show grid lines.
4 Select Show Major Lines to show major grid lines.
5 Enter the number of crosses to fit between the major grid lines.
6 Click Edit to change the color of the major and minor lines.

Select line color

7 Select from the available colors or define your own. Click Define 
Custom Colors to mix your own colors from the color wheel.

8 Click OK.

Changing background colors and fabrics
In ES Cross Stitch you can change the background color of the design 
window to match the color of your fabric. Or you can select a background 
fabric for more realistic previews and presentations.

To change background color or fabric
1 Select Special > Options.
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2 Select the Background tab.

Select background 
color or fabric

Edit color

Select fabric 
pattern

Center or tile fabric pattern 
in design window

3 Select the design window background type.
 Color: uses the selected color.
 Fabric: uses an image of a fabric.

4 Select a color or fabric to use.
 To select a background color, click Edit. Select a color from the 

Color dialog and click OK.

Select background 
color

 To select a fabric, click Browse. Select a fabric type from the Open 
dialog and click OK. 
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You can center or tile the fabric bitmap in the design window. If the 
bitmap is large enough to fill the entire window, select Center. 
Otherwise, select Tile.

Select 
background 

fabric

5 Click OK.

Viewing stitches as crosses or tiles

Click General > Crosses to show stitches as colored tiles or cross stitches.

There are two display modes for ES Cross Stitch – crosses or colored 
tiles. When you change to tile mode, you see the design in colored blocks 
without stitch details as appear in stitch mode. See also Generating 
stitches.

To view stitches as crosses or tiles
1 Click the Crosses icon. Any digitized areas are shown as crosses (or 

lines for line borders).
2 Click again to show stitches as colored tiles. 

Stitches shown as 
crosses 

Stitches shown as 
colored tiles

 Stitches shown as 
colored tiles

Stitches shown as 
crosses 
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Viewing design information
The ES Cross Stitch Status Bar provides design information such as 
individual stitch information, approximate stitch count and thread usage 
as well as the zoom factor of the design.

Stitch count Zoom factorPointer coordinates

Setting design size and density
In ES Cross Stitch, design size is controlled by the ‘fabric count’. The 
more stitches per inch, for example, the smaller and more compact the 
resulting design. You can also adjust the density of individual cross 
stitches by stitching them once, twice or three times.

Setting the design size
You set cross stitch design size by adjusting the ‘fabric count’. This 
actually changes the scale of your finished design. The more stitches per 
inch, for example, the smaller and more compact the resulting design.

Caution  A common problem with cross stitch designs is that they ‘pull’, 
especially with smaller, closely packed stitches. Cross stitch designs tend 
to pull in a uniform way with gaps usually forming in straight lines. 
Sometimes holes appear giving the impression of missing stitches. See 
also Setting the stitch density.

To set the design size
1 Select Special > Fabric Count. The Fabric Count dialog opens.

Enter stitches 
per inch

Enter stitches 
per mm

2 Select a fabric count option, inches or millimeters:
 Number of stitches per inch: the fewer stitches per inch, the 

bigger the resulting design.
 Number of millimeters per number of stitches: because a 

cross stitch is bigger than a millimeter, you can adjust the mm and 
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stitch settings in relation to each other. The higher the mm value, 
or smaller the stitch value, the bigger the design.

Tip  By clicking Update, you get an immediate conversion of any 
values you have entered. For example, change the stitches per inch 
value, click Update, and the corresponding stitches per mm value 
will be updated.

3 Click OK.

6 stitches per 
inch

12 stitches 
per inch

6 stitches per 
25.4mm

12 stitches 
per 25.4mm

Setting the stitch density

Use the Stitch > Threads list to set stitch density. 

You can adjust the density of a cross stitch by stitching it once, twice or 
three times. The number of ‘crossovers’ correspond to the values 2, 4 
and 6 in the Threads list. You can change these values at any time.

Note  If you make a design smaller to fit inside the hoop, stitches may 
be stacked on top of each other and pull the fabric. You can avoid this 
problem by reducing the number of crossovers to single (2 threads) for 
both fills and outlines. You can also use a thinner weight thread.

Tip  If you create a design where every square has a stitch, remember 
to baste and stabilize the fabric. 

To set the stitch density
 Select a value from the dropdown Threads list.
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The value 2 corresponds to a single stitch, 4 is double, while 6 is triple. 
This is represented on screen by line thickness.

Thread 
count 2

Thread 
count 6

Tip  When you move your mouse over the stitch, a tool tip will tell you 
the type and color of stitch used.

Selecting cross stitch types
ES Cross Stitch provides the full range of cross stitch types which you can 
use to create outlines and fills of any color. You can also control the 
orientation of fractional cross stitches to create different patterning 
effects.

Selecting a stitch color
You can select stitch colors from the Color Palette before digitizing, or 
apply a new color to selected areas.

To select a stitch color
 Select a color from the color palette to apply to newly digitized areas. 

Stitches will be digitized in that color.
 Select a stitch block by dragging a marquee around it. Then select a 

new color.

Selecting a line stitch type

Select Stitch > Single Line for a single line. 

Select Stitch > Full Cross for lines of crosses. 

There are two types of line stitch, Single Line and Full Cross, available 
from the Stitch toolbar. Select a cross stitch type before clicking the Full 
Cross icon.
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To select a line stitch
 Select Single Line or Full Cross from the Stitch toolbar.

New stitches will be digitized as single lines or crosses. If you are using 
Full Cross, the currently selected cross stitch type applies. See 
Selecting a fill stitch type for details.

Single line 
outline

Crosses 
outline

Note  Depending on the stitch type you select, you can set the 
direction of the stitch. See Setting cross stitch orientation for details.

Selecting a fill stitch type

Select Stitch > Full for full crosses. 

Select Stitch > 3/4 for three quarter crosses. 

Select Stitch > 1/2 for half crosses. 

Select Stitch > 1/4 for quarter crosses. 

Select Stitch > Mini Cross for mini crosses. 

Select Stitch > Upright Cross for upright crosses. 

Select Stitch > Double Cross for double crosses. 

Select Stitch > French Knot for French knots. 

Select Stitch > Elongated Vertical Cross for vertical crosses.

Select Stitch > Elongated Horizontal Cross for horizontal crosses. 

Fill stitches are all cross stitches. Choose from among the following types 
– Full Cross, Three-quarter Cross, Half Cross, Quarter Cross, Mini Cross, 
Upright Cross, Double Cross, Elongated Vertical Cross, and Elongated 
Horizontal Cross. See also Cross stitch fills.
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To select a fill stitch
 Select a cross stitch type from the Stitch toolbar.

Selected and new stitches will be digitized as that stitch type.

Variety of cross stitch 
fill effects

Note  Depending on the stitch type you select, you can set the 
direction of the stitch. See Setting cross stitch orientation for details.

Setting cross stitch orientation
You can control the orientation of fractional cross stitches to create 
different patterning effects. When digitizing individual stitches, you do 
this directly pixel-by-pixel. When digitizing a fill, you do so via the 
Select Fill Style dialog. The method is the same. See also Types of 
cross stitch.

Click the quadrant to 
be filled

To set cross stitch orientation
 To create three-quarter cross stitches, click the corner where you want 

the quarter stitch to be.
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 To create half cross stitches, click the corner where you want your 
stitch to start.

Click here to start 
in this corner

Click here to start 
in this corner

 To create quarter cross stitches, click the corner where you want your 
stitch to start. 

Click here to start 
in this corner

 To create mini cross stitches, click the corner where you want to place 
the stitch.

Click here to 
place a stitch in 
this corner

 To create vertical elongated cross stitches, click the side where you 
want to place the stitch.

Click here to 
place a stitch on 

this side

Digitizing with cross stitches
ES Cross Stitch provides techniques for digitizing single stitches or lines 
of stitches, filled and unfilled rectangles or circles, or filled and unfilled 
‘closed’ free-form shapes. You can also create free-form outlines or 
borders. The Flood Fill feature lets you fill closed shapes or ‘color blocks’ 
with stitches.

Digitizing single stitches or lines

Use Cross Stitch > Pencil to draw a single stitch or line of stitches.
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You can digitize a single stitch or line of stitches. Depending on the stitch 
type you select, you must also set the stitch direction. See also Creating 
combination stitches.

To digitize a single stitch or line
1 Click the Single Line or Full Cross icon.

If you are using Full Cross, the currently selected cross stitch type 
applies. See also Selecting a fill stitch type.

2 Select a color from the color palette. See Selecting a stitch color for 
details.

3 Click the Pencil icon.
4 Click a square to make a single stitch, or click and drag the pencil to 

make a line.

Note  Press Ctrl and drag to draw straight vertical lines.

Single stitches 
and lines

Tip  You can also use the Pencil tool to create combinations of partial 
crosses comprised of multiple colors. See Creating combination 
stitches for details.

Digitizing circles

Use Input > Circle to draw and digitize ovals or circles.

The Circle tool provides a quick way to digitize filled or unfilled circles.

To digitize a circle
1 Click the Circle icon.
2 Select a color from the color palette. See Selecting a stitch color for 

details.
3 Select an Outline or Fill stitch type. See Selecting cross stitch types 

for details.
4 Mark the center point then mark a point on the circumference.
 If you want a perfect circle, press Enter.
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 If you want an ellipse, mark a third reference point.
The circle or oval is filled or outlined depending on the stitch type 
selected. 

Three-quarter cross fillFull cross border  Half cross fillFull cross fill

Digitizing open and closed shapes

Use Input > Cross Stitch Run to draw and digitize open shapes.

Use Input > Cross Stitch Fill to draw and digitize closed shapes.

You can create free-form outlines or borders using the Cross Stitch Run 
icon. You can create freeform filled shapes using the Cross Stitch Fill 
icon. Select an outline stitch for unfilled shapes and a fill stitch for filled 
shapes.

To digitize an open or closed shape
1 Click the Cross Stitch Fill or Cross Stitch Run icon.
2 Select a color from the color palette. See Selecting a stitch color for 

details.
3 Select an Outline or Fill stitch type. See Selecting cross stitch types 

for details.
4 Mark reference points on your design. Left-click for sharp corners and 

right-click for round corners. 
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5 Press Enter. The shape is filled or outlined depending on the stitch 
type selected.

Single-line 
outline 

stitch with 
Cross Stitch 

Run

Full cross 
outline 

stitch with 
Cross Stitch 

Run 

Single-line 
outline stitch 
with Cross 
Stitch Fill

Full cross fill 
stitch with 

Cross Stitch 
Fill

Marked 
reference points

Flood-filling color blocks

Use Cross Stitch > Flood Fill to fill a closed shape or color block with 
stitches.

Fill closed areas with stitches using Flood Fill. You can also use the tool 
to change the color and stitch type of Full Cross outlines.

Note  The Flood Fill tool only works with cross stitches. Flood Fill will 
not work with bitmap images used as backdrops. See also Digitizing 
backdrops automatically.

To flood-fill color blocks
1 Select a color from the color palette. See Selecting a stitch color for 

details.
2 Select a Fill stitch type. See Selecting a fill stitch type for details.
3 Click the Flood Fill icon.
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4 Click within a closed area. The shape is flood-filled in the selected 
stitch type and color.

Digitized using Auto Stitch Image Colors changed using Flood Fill

Caution  Flood Fill will not work within single line outlines. Some 
shapes with angled sides may not fill correctly.

Handling cross stitch design files
Cross stitch designs have their own EMX file format. This can be read by 
EmbroideryStudio. You can also combine EMX with designs in other 
formats.

Generating stitches

Select Stitch > Generate to generate stitches from crosses. 

What appears on-screen when you digitize is actually a ‘painting’ of the 
design. You are not digitizing so much as coloring the boxes with crosses. 
Thus you need to ‘generate’ your design in order to translate the crosses 
on screen into actual stitches. See also Viewing stitches as crosses or 
tiles.
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To generate stitches
 Click the Generate icon. Stitches are generated and the design saved 

as an EMX file. If this is the first time you have saved the design, you 
will be asked to name the file.

Note  You can only save as EMX.

Saving cross stitch designs

Click General > Save to save cross stitch files.

Save your design early and often. Use the EMX extension for saving cross 
stitch files.

To save cross stitch designs
1 Select File > Save. If this is the first time you have saved the design, 

the Save As dialog opens. The file is saved as an EMX file.

2 Type a new name for the design and click Save.
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Using cross stitch with EmbroideryStudio
To include cross stitch in your EMB designs, you need to save and close 
any cross stitch designs as EMX then open them in EmbroideryStudio.

Tip  You cannot view your cross stitch design in TrueView in the cross 
stitch program. However you can do so by saving the design and opening 
it in EmbroideryStudio. 

To use cross stitch with EmbroideryStudio
1 Save your design as EMX.
2 Open EmbroideryStudio.
3 Select File > Open. The Open dialog opens.

Select EMX

4 Select EMX files from the Files of Type list.
5 Select your file.
6 Click Open.
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Chapter 3

Cross Stitch Editing

ES Cross Stitch provides techniques for editing cross stitch designs, 
including moving, rotating, and mirroring stitch blocks. You can erase 
stitches as well as change colors and stitch types of selected areas. You 
can clone a selection for re-use as a ‘rubber stamp’ and fill large areas 
with motifs or special composite stitches. You can also edit stitches to 
create combinations of partial crosses comprised of multiple colors.

This section provides details of cross stitch editing features.

Selecting and locking stitches
In order to edit an area of a design, you must first select it. ES Cross 
Stitch provides a number of ways to select cross stitches. It also lets you 
lock cross stitches and/or outlines so that they are not moved or edited 
by accident.

Selecting stitches with Select or Polygon Select

Use Pointer > Select to select a single stitch or block of stitches.

Use Pointer > Polygon Select to select irregular areas or shapes.
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The Select and Polygon Select tools work in a similar way to 
EmbroideryStudio. The difference is that in ES Cross Stitch you work with 
stitch blocks or areas rather than design objects.

To select cross stitches with Select or Polygon Select
 With the Select tool selected, simply drag a bounding box around the 

area to be selected.
 With the Polygon Select tool selected, mark reference points around 

the area you want to select and press Enter.

Selected parts editedPolygon Select tool used Select tool used

Tip  Hold down Ctrl to select multiple areas.

Selecting stitches with Auto Select

Use Cross Stitch > Auto Select to select a single color block or an 
undigitized area.

Auto Select is specific to ES Cross Stitch. It allows you to select a single 
color block or a closed undigitized area. Only adjoining stitches of the 
same color are selected. 

To select cross stitches with Auto Select
1 Click the Auto Select icon.
2 Click a block of stitches. Only adjoining stitches of that color are 

selected. 
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Tip  Hold down Ctrl to select multiple blocks.

Color block 
selected

Hold down Ctrl 
to select yellow 
color blocks

Tip  You can change the color of the selection completely, by selecting 
a color from the palette.

Locking stitches
You can lock cross stitches and/or outlines so that they are not moved or 
edited by accident.

To lock stitches
1 Select Edit > Crosses or Edit > Outlines. When Crosses is ticked 

in the menu, cross stitches can be moved. Likewise, when Outlines is 
ticked, outlines can be moved.

2 Select an area and click and drag to move stitches.

Design contains outline and fill 
cross stitches – crosses locked

Area dragged, only 
outlines move

3 Select Crosses or Outlines again to uncheck it and lock all crosses or 
outlines.

Simple stitch editing
ES Cross Stitch lets you change the color or stitch type of selected stitch 
blocks at any time. You can also remove stitches at any time.
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Copying, cutting and pasting stitch blocks

Use General > Copy to copy selected stitch blocks to the clipboard.

Use General > Cut) to cut selected stitch blocks to the clipboard.

Use General > Paste to paste copied stitch blocks from the clipboard.

In ES Cross Stitch you work with stitch blocks or areas rather than design 
objects. You can copy, cut and paste selected stitch blocks at any time. 
See also Rubber stamping fills.

To copy, cut and paste stitch blocks
1 Select the stitch block to copy or cut. See Selecting and locking 

stitches for details.
2 Click the Copy or Cut icon. The selected area or areas are copied to 

the clipboard.
3 Click the Paste icon. The duplicate area is pasted over top of the 

selected area.
4 Click and drag to move the pasted stitch block.

Tip  Duplicate and rotate blocks of stitches to make patterns. See 
Transforming stitch blocks for details.

Changing stitch block settings

Use Edit > Auto Select to change the color and/or stitch type of selected 
stitch blocks.

You can change the color and/or stitch type of selected stitch blocks at 
any time.



Chapter 3   Cross Stitch Editing 30

To change stitch block settings
1 Use Auto Select to select the stitch block/s. See Selecting stitches 

with Auto Select for details.

Tip  Hold down Ctrl to select multiple blocks.
2 Change color and/or stitch type as required:
 Select a new color from the palette. The color fills the selected 

area/s. The area remains selected.

Stitch block selected Color changed

 Select a new stitch type from the Stitch toolbar. The stitch type fills 
the selected area/s.

Stitch type changedStitch block selected

3 Press Esc to deselect the selected area/s.

Erasing fills and single lines

Use Cross Stitch > Eraser to erase fills and single lines.

Use the Eraser tool to remove stitches. The eraser will remove either fill 
stitches or single line borders depending on the stitch type selected. 
Cross-stitched borders are treated as fill stitches.

To erase fills and single lines
1 Click the Eraser icon.
2 Click Full Cross on the Stitch toolbar.
3 Click and drag the cursor across the stitches you want to remove.
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Only fill stitches are removed. Single line borders remain.

Drag cursor over 
stitches to erase

Only fill stitches 
erased, single line 
borders remain

Tip  You can also erase cross stitches by selecting them and pressing 
the Delete key.

4 Click Single Line on the Stitch toolbar.
5 Click anywhere on a single line. The line is removed. Cross stitches 

remain.

Click line to 
erase

Line 
erased

Note  A single line border is removed in one click.

Transforming stitch blocks
ES Cross Stitch lets you perform various transformations on selected 
blocks of cross stitches. You can move them, rotate them in a clockwise 
or counter-clockwise direction. You can also mirror blocks of cross 
stitches either horizontally or vertically.

Moving blocks of cross stitches
You can move blocks of cross stitches at any time.

To move blocks of cross stitches
1 Select the stitch block to move. See Selecting and locking stitches for 

details.
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2 Click and drag it to a new location.

Selected area Area moved

Rotating blocks of cross stitches

Use Edit > Rotate Selection to rotate selected stitches. 
Click to rotate clockwise. Right-click to rotate counter-clockwise.

You can rotate blocks of cross stitches in a clockwise or counter-clockwise 
direction. Duplicate and rotate blocks of stitches to make patterns.

To rotate blocks of cross stitches
1 Select the stitch block to rotate. See Selecting and locking stitches for 

details.
2 Click the Rotate Selection icon.

Mirroring blocks of cross stitches

Click Edit > Mirror Selection Horizontal to mirror selected stitches 
horizontally.

Click Edit > Mirror Selection Vertical to mirror selected stitches vertically.

You can mirror blocks of cross stitches either horizontally or vertically.
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To mirror blocks of cross stitches
1 Select the stitch block to mirror. See Selecting and locking stitches for 

details.
2 Click the Mirror Selection Horizontal icon.

Mirrored 
vertically

Mirrored 
horizontally

Special editing techniques
ES Cross Stitch provides a number of editing techniques which are 
especially helpful for cross stitch digitizing. You can clone a selection for 
re-use as a ‘rubber stamp’ and fill large areas with motifs or special 
composite stitches. You can combine fractional cross stitches in a 
variety of ways. You can also add a cross stitch border or a single line 
border, or both, to areas of a design.

Rubber stamping fills

Use Cross Stitch > Rubber Stamp to clone a selection for re-use as a 
‘rubber stamp’.

Clone a selection for re-use as a ‘rubber stamp’ and fill large areas with 
motifs or special composite stitches.

To rubber stamp fills
1 Click the Select icon and select the area to be cloned.
2 Click the Rubber Stamp icon. The selected area is copied and 

attached to the pointer.
3 Click to place the stamp as many times as you want. 

Rubber Stamp used to create borderMotif created

4 Press Esc or select another icon to turn off Rubber Stamp.
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Creating combination stitches

Use Cross Stitch > Pencil to add combination stitches.

Fractional cross stitches – ¼, ½, or ¾ – can be combined to make crosses 
comprised of multiple colors. You can also combine mini crosses, 
elongated vertical or horizontal crosses and outline stitches. See also 
Cross stitch variations.

To create combination stitches
1 Select a stitch type. See Selecting a fill stitch type for details.

Select 3/4 (Stitch toolbar) for three quarter crosses. 

Select 1/2 (Stitch toolbar) for half crosses. 

Select 1/4 (Stitch toolbar) for quarter crosses. 

Select Mini Cross (Stitch toolbar) for mini crosses. 

Select Elongated Vertical Cross (Stitch toolbar) for vertical 
crosses.

Select Elongated Horizontal Cross (Stitch toolbar) for 
horizontal crosses. 

2 Select a color from the color palette. See Selecting a stitch color for 
details.

3 Click the Pencil icon.
4 Click where you want the stitch to be inserted.

Click top left corner to insert a mini cross

Click top right corner to insert a 1/2 cross

Click bottom right corner to insert a 1/4 cross

Note  If you do not have Insert selected, the whole stitch will be 
replaced.
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5 Repeat as many times as needed.

Full crosses 
replaced with 
mini and half 

crosses

Adding borders to selected areas
Add a cross stitch border or a single line border, or both, to selected areas 
of a design.

To add borders to selected areas
1 Select either the Single Line or Full Cross icon.
2 Click the Flood Fill icon and click inside an area. A line of outline 

stitches is added around the edges of the selection.

Tip  Click again in the selection to add another line of stitches inside 
the first line.

Mini cross stitch border Single line border No border

Tip  To combine a cross stitch with a line border, select Full Cross 
stitch type and Flood Fill, then select Single Line and Flood Fill 
again.

Adjusting thread colors
ES Cross Stitch lets you change the thread colors of an existing design. 
You can also mix your own colors to more closely match the required 
design colors.
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Caution  The representations of commercial thread charts are 
approximate, and the computer simulations are not intended to exactly 
match the identified thread color.

Changing thread colors
ES Cross Stitch lets you reassign design colors using the design’s thread 
chart. You can choose colors from pre-defined thread charts or mix your 
own.

To change thread colors
1 Select Edit > Colorways. The Thread Colors dialog opens.

Enter number of 
thread colors

Select a thread 
chart

Select new 
color

Click to assign 
new color

Select color to 
change

2 Enter the total number of colors you want to use in the Threads in 
Design field.

Tip  Color palettes are limited to 128 colors. 36 will fit comfortably at 
800 x 600 resolution.

3 Select a thread chart from the Thread Chart list.
4 In the upper panel, select the thread color to change.

Tip  To mix your own color, use the Edit button. See Editing thread 
colors for details.

5 In the lower panel, select the new thread color and click Assign.
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Tip  To find a required color, search using the Search field. See 
Searching for threads for details.

Searching for threads
You can search for threads by code or description in the Thread Colors 
dialog.

To search for a thread
1 Select Edit > Colorways. The Thread Colors dialog opens.

Type search 
string

Select a thread 
chart

Select search 
criteria (code or 
description)

2 Select a thread chart from the Thread Chart list.
3 Select either Code or Description to search on.

Note  Code is the identification number of a thread color in a brand.
4 In the Search field, key in the first few characters of the required code 

or description. As you type, the cursor will highlight the closest match 
in the thread chart.

5 Scroll through the list to find the exact shade you want. Check your 
threads and select the color according to whatever shade most closely 
matches the color in the chart.

Editing thread colors
You can edit the existing colors in a design without selecting a new color 
from a thread chart.

To edit a thread color
1 Select Edit > Colorways. The Thread Colors dialog opens.
2 In the upper panel, select the thread color to edit.
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3 Click Edit. The Edit Thread dialog opens.

Click to select or 
mix color

Enter code, brand, 
and description 

details

4 Enter code, brand, and description details for the thread color. Code is 
the identification number of a thread color in a brand.

5 Click Mix. The Color dialog opens.

6 From the Basic colors table, select a color that closely matches the 
color you require.

7 Click and drag the cross hairs on the color spectrum to get the exact 
color.

8 Drag the slider on the right of the color spectrum to adjust color 
brightness. The HLS and RGB values appear in the bottom right-hand 
corner of the Color dialog. Enter these values directly to define exact 
colors.

9 When you have mixed the required color, click Add to Custom 
Colors.

10 Click OK. The new color appears in the Color preview box.
11 Click OK. The new color appears in the Threads list.
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Chapter 4

Advanced Cross Stitching

The ES Cross Stitch design window also lets you import pictures to use 
as backdrops or for automatic digitizing. You can also create special cross 
stitch lettering.

This section provides details of advanced cross stitch features including 
automatic digitizing and lettering.

Digitizing with backdrops
Bitmap images can be inserted, pasted or scanned into ES Cross Stitch 
for use as digitizing backdrops. You can digitize backdrop images 
automatically using Auto Stitch Image. Use solid color bitmaps to make 
suitable color blocks for cross stitches.

Inserting bitmap images
You can insert bitmap images of various formats for use as digitizing 
backdrops. See the User Manual for a list of supported file types.
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To insert bitmap images
1 Select Insert > Drawing File. The Open dialog opens.

2 Select a folder from the Look In list.
3 Select a file type from the Files of Type list (e.g. BMP).
4 Select the file you want to insert.

Tip  Select the Preview checkbox to preview the selected file.
5 Click Open.

Tip  You can also use Edit > Paste Drawing > As Vector/As 
Bitmap if the drawing is on the clipboard.

Viewing or hiding backdrops

Click General > Picture to show or hide the picture.

You can show or hide a bitmap backdrop temporarily while you digitize.

To view or hide backdrops
 Click the Picture icon to show the image.
 Click it again to hide the image.

Scaling and reshaping bitmap images
You can scale and reshape images once they are loaded into ES Cross 
Stitch. However, if an image needs to be resized or rotated, it is best to 
do so during scanning. Scaling afterwards may distort the image. See the 
User Manual for details.



Wilcom EmbroideryStudio e4 Cross Stitch Supplement 41

To scale and transform bitmap images
1 Insert the image in the normal way. See Inserting bitmap images for 

details.
2 Click the Select icon.
3 Holding down the Alt key, click the image.

Eight resize selection handles appear around the image. Click and drag 
these to scale the image as you would any other object. See Scaling 
Objects in the EmbroideryStudio User Manual for details.

Resize handles Transform handles

4 Still holding down the Alt key, click the image again.
Eight transform selection handles appear around the image. Click and 
drag these to reshape the image. An additional center point lets you 
move the whole design. See Arranging and Transforming Objects 
in the EmbroideryStudio User Manual for details.

Resize image Transform image

Digitizing backdrops automatically

Use Cross Stitch > Auto Stitch Picture to automatically create cross stitch 
designs from pictures.
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Digitize the entire backdrop image automatically using Auto Stitch 
Image. You can change the stitch type manually later as required.

To digitize backdrops automatically
1 Prepare your image as necessary. Use a third party paint program to 

clean up the image.
2 Insert the image using Insert > Drawing File. See Inserting bitmap 

images for details.

3 Click the Auto Stitch Image icon and click the image. The Auto 
Stitch Image dialog opens.

Select image 
‘mapping’ method

Select to omit 
background color

Select thread 
chart

Specify maximum 
colors

4 Select to map the picture colors to:
 Current Palette: only colors in the current palette are used.
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 Specific Thread Chart: only colors in a selected thread chart are 
used.

Current palette: default Selected thread chart: Sakura Selected thread chart: 
Madeira40-shades

5 Specify the maximum number of colors to be used:
 Unlimited: thread colors will be allocated according to the number 

of colors in the palette selected in the first dialog.
 Restricted: enter the number of colors you want to use.
 Omit Background: select to omit the background color.
The results display in the preview pane.

Unlimited maximum 
colors selected

Restricted 
maximum colors 

selected

6 Click OK.
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The image is digitized. You may need to touch up some areas 
manually.

Unlimited 
maximum colors 
selected

Three colors 
selected

Note  Auto Stitch Image is disabled if no picture is loaded.

Digitizing cross stitch letters

Use Input > Lettering to add letters to your design.
Right-click Lettering to open the Font dialog.

As with EmbroideryStudio, ES Cross Stitch lets you add lettering to a 
design by typing it directly in the design window. Use the Font dialog to 
select font, size and style. Select either outline or fill to digitize letters. 
Once typed, you cannot edit letters. Each letter is treated as a stitch 
block.

Tip  Lettering in ES Cross Stitch may appear thicker than the original 
TrueType font. This is generally due to ‘ClearType’ font smoothing which 
is turned on by default in Windows Vista or later. Temporarily turning off 
ClearType produces better lettering in ES Cross Stitch although this may 
affect its appearance in other applications.
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To digitize cross stitch letters
1 Right-click Lettering. The Font dialog opens.

Select font, style, 
size from lists

2 Select a font type, style and size and click OK.

Regular font Italic fontBold font

3 Select a fill or outline stitch type from the Stitch toolbar.
4 Click a start point in the design window, type the letters and press 

Enter.

 Fill stitches

Outline stitches

Tip  To edit letters, use the Select tool with the Ctrl key to select, then 
change the stitch type or color as required.
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