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Customizing Oracle Identity Manager 

Distribution 

Product Administrator or System Administrator for Oracle Identity Manager 11g R2 PS1 

Overview 

The Identity Self Service user interface (UI) in Oracle Identity Manager is based on Application 
Development Framework (ADF), which ensures consistent customization. ADF allows UI 
customization that is safe from patches and upgrades. This means that after you apply patches 
to Oracle Identity Manager or upgrade Oracle Identity Manager, the UI customizations are 
preserved. 

UI customizations and personalizations are performed using the Web Composer, which runs in 
the browser, eliminating the need for additional development environments. Customizations, 
after they are published, take effect for all users, and can be performed only by administrators 
with the requisite authorization. Personalization can be performed by any user and changes 
made by a user do not affect any other user. 

In this tutorial, you will: 

 Rebrand the Identity Self Service Console 

 Use the Web Composer to modify a button label 

 Use the Web Composer to hide UI components, such as fields on a page 

 Add a custom user attribute, modify pages to include the attribute, and define a policy 
to display the attribute only to users assigned to specific roles 

 Personalize the Home Page of the Identity Self Service Console 

 Personalize search results by creating and saving custom search filters 

 Rename panel text for the Identity Self Service Console 

 Organize, rename, and hide menus for the Identity Self Service Console  

 Add a user defined field (UDFs) to a page on the Identity Self Service Console 

 Add the UDF to a search page 
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Assumptions 

 You installed, configured, and launched Oracle Identity Manager 11gR2 PS1. 

 You downloaded the example-corp-logo.png file to your machine. This file contains 

the logo for Example Corp, the company associated with this tutorial. 

 You created records for the Finance organization and HR Manager role in Oracle 
Identity Manager. 

 You created user records for Clarence Saladna, Dorelia Bratten, Kenny Vesterdal, 
Nancey Jepson, Portia Bradshaw, Rosalia Teerdhala, Trudy Auerbach, and Teena 
Semmens, and assigned these users to the Finance organization. 

 You assigned Teena Semmens to be the manager of Charles Saladna. 

 You assigned the HR Manager role to Teena Semmens. 

 You created two directories on your machine: /sandboxes/first and 

/sandboxes/second. For this tutorial, both directories are nested within the 

/home/oracle directory. 

 

http://www.oracle.com/webfolder/technetwork/tutorials/obe/fmw/oim/oim_11g/simple_customization_OIM/example-corp-logo.png
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Rebranding the Identity Self Service Console 

Overview 

In this topic, you rebrand the Identity Self Service Console by changing the logo and text on the 
header. This involves: 

 Copying a new image file to the deployment directory 

 Using the Web Composer to modify the Identity Self Service Console 

Tasks 

1. Copy the example-corp-logo.png file to the 
/u01/app/Oracle/Middleware/Oracle_IDM1/server/apps/oim.ear/ 

xlWebApp.war/images folder. 

Note: For this tutorial, /u01/app/Oracle/Middleware/Oracle_IDM1 is the home 

directory for Oracle Identity Manager. 

2. Sign in to the Identity Self Service Console as the xelsysadm user. 

3. Click the Sandboxes link (located in the upper-right-hand corner of the console). 

 

Note: You click the Sandboxes link because all Oracle Identity Manager customizations 
must be created in a sandbox. 
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4. On the Manage Sandboxes tab, click Create Sandbox. 

 

5. In the Create Sandbox window, enter Example_Corp in the Sandbox Name field. Make 

sure that the Activate Sandbox check box is selected. Click Save and Close. 

 

Note: You provide Example_Corp for the name of the sandbox because Oracle Identity 
Manager does not allow you to use spaces for sandbox names. 

6. On the Confirmation dialog box, click OK. 

 

Note: The name of the Sandboxes link changes to Sandboxes (Example_Corp). This 
signifies that you created and activated a sandbox. 
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7. Click the Customize link (located in the upper-right-hand corner of the console). 

 

The Oracle Web Composer opens. The top of the page shows “Editing Page: Identity Self 
Service.” 

8. Select Source from the View drop-down menu. 

 

The component layout is displayed. 
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9. Click on the region that you wish to change. This selects the component for editing in the 
Web Composer. You want to change the header text “Identity Self Service,” so click on the 
header text. 

 

The corresponding component is selected for editing in the Web Composer. 

 

10. Click Edit. 

 

The Component Properties window is displayed. 
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11. Click the down arrow next to the Value text area and select Expression Builder. 

 

12. Change the value in the text area from 

#{uiBundle['IDENTITY_SELF_SERVICE_TITLE']} 

to 

Self Service Application 

and click OK. 

 

The Value text area in the Component Properties window is updated with the text Self 
Service Application. 
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13. Click OK. 

 

The Component Properties window closes and the header text is updated. 

 

You have modified the header text. Next, you modify the logo on the header. 



 Copyright © 2013, Oracle and/or its affiliates. All rights reserved.  

  Customizing Oracle Identity Manager 

Effective mm/dd/yy Page 10 of  105 Rev 1 

14. Click the Oracle logo to select it for editing. 

 

15. Click Edit. 

 

16. Change the text in the Short Desc field from Oracle to Example Corp. 

 

Note: This changes the tool tip text that is displayed when the cursor is moved over the 
image. 



 Copyright © 2013, Oracle and/or its affiliates. All rights reserved.  

  Customizing Oracle Identity Manager 

Effective mm/dd/yy Page 11 of  105 Rev 1 

17. Click the Style tab of the Component Properties window. 

 

18. Enter the text url(/xlWebApp/images/example-corp-logo.png) in the Background 

Image field and click OK. 

 

The logo is updated. 
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19. Click Close to close the Web Composer. 

 

20. Move the cursor over the Example Corp logo. Note that the tool tip is now Example Corp. 

 

21. Publish the sandbox to make it active for all users. Highlight the sandbox you created in this 
procedure (Example_Corp). Click Publish Sandbox. 

 

22. On the Confirmation dialog box, click OK. 

 

Note: The name of the Sandboxes link reverts back to its original name (Sandboxes). This 
signifies that you published the sandbox. 



 Copyright © 2013, Oracle and/or its affiliates. All rights reserved.  

  Customizing Oracle Identity Manager 

Effective mm/dd/yy Page 13 of  105 Rev 1 

23. Repeat step 20 of this procedure to verify that the change you made to the mouseover text 
is merged into the main line. 

 

24. Sign out of the Identity Self Service Console. 

You have updated the logo and the header text, and changed the tool tip text for the logo. 

Note: These steps only re-brand the Identity Self Service Console. To re-brand the System 
Administration Console, the same steps must be followed while you are signed in to the 
System Administration Console. 
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Modifying a Button Label 

Overview 

In this topic, you use the Web Composer to change the label on the Submit button on the Modify 
User page to Apply. 

Tasks 

1. Sign in to the Identity Self Service Console as the xelsysadm user. 

2. Create and activate a sandbox called Example_Corp_2. 

3. Click Users under Administration. 

4. Search for and click the link for a user in Oracle Identity Manager. For this example, search 

for the user named Clarence Saladna (CSALADNA). 

 

5. Click Modify User. 

 

A new tab “Modify User : CSALADNA” is displayed. 
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6. Click the Customize link to open the Web Composer. 

 

7. Select Source from the View drop-down menu. 

 

8. Click the Submit button to select it for editing in the Web Composer. 

 

9. Click Edit to confirm editing of the task flow. 
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10. Click Edit. 

 

11. In the Component Properties: Submit dialog box, scroll down to the Text field. Click the 
drop-down arrow next to the field and select Expression Builder. 
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12. Enter Apply in the text area and click OK. 

 

13. Click OK. 
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The button label is updated. 

 

14. Click Close to close the Web Composer. 

 

15. Close the Users, User Details, and Modify User tabs in the Identity Self Service Console. 

Note: Before publishing a sandbox, all tabs in the Console must be closed. 

16. Publish the Example_Corp_2 sandbox. 

You have modified the button label for a form. 
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Hiding User Interface Components 

Overview 

In this topic, you use the Web Composer to hide the Home Phone, Pager, Home Postal 
Address, and PO Box attributes on the User Attributes tab of Identity Self Service Console. 

Tasks 

1. Sign in to the Identity Self Service console as the xelsysadm user. 

2. Create and activate a sandbox called Example_Corp_3. 

3. Click Users under Administration. 

4. Search for and click the link for the user CSALADNA. 

 

5. Click the Attributes subtab, if it is not already active. 
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6. Collapse all the sections of the page so that only the Contact Information section is 
expanded. 

 

Note: Collapsing the sections simplifies navigating in the Web Composer, because fewer 
components are visible. 

7. Click Customize to open the Web Composer. 

 

8. Select Source from the View drop-down menu of the Web Composer. 
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9. Click the area next to the Contact Information header to select it for editing in the Web 
Composer. 

 

10. Click Edit to confirm editing of the task flow. 

 

11. Select the panelFormLayout component under “showDetailedHeader: Contact Information” 
in the Web Composer. 

 

The selection in the Web Composer changes to the container for all the Contact Information 
attributes. 
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12. Click Edit. 

 

In the “Component Properties: panelFormLayout” dialog box, click the Child Components 
tab. 
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13. Deselect Home Phone, Pager, Home Postal Address, and PO Box, and click OK. 

 

14. Click Close to close the Web Composer. 

 

The deselected attributes are no longer displayed in the Identity Self Service Console. 
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15. Expand the Basic Information, Account Effective Dates, and Provisioning Dates sections. 

 

Note: This returns the expansion state of these sections to their default settings. 

16. Close the “User Details : Clarence Saladna” and Users tabs. 

Note: If you receive an error message, log out of the Identity Self Service Console and log 
back in. 

17. Publish the sandbox called Example_Corp_3. 

You have hidden User Interface artifacts using the Web Composer. 
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Adding and Managing Custom User Attributes 

Overview 

The set of user attributes defined in a default installation of Oracle Identity Manager, although 
comprehensive, may not meet the requirements of an organization. In this topic, you perform 
the following tasks: 

 Define a custom user attribute, Salary 

 Add a field for the attribute to the View User Details and Modify User pages in the 
Identity Self Service Console 

 Use Expression Language to hide the attribute for all users, except users assigned to 
the HR Manager and System Administrator roles 

Tasks 

1. Define a custom user attribute. To do this, perform the following: 

a. Sign in to the Identity System Administration Console as the xelsysadm user. 

b. Create and activate a sandbox called Example_Corp_4. 

c. Click Form Designer under Configuration. 

 

d. Select User from the Type drop-down menu and click Search. 

 

e. Click User in the Search Results list to open the form. 
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f. Click the Create icon ( ) to create a new field. 

 

g. Select Number and click OK. 

 

h. In the Display Label field, enter Salary. Click Save and Close. 

 

Note: The Name field is populated automatically. 
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i. Close the Manage User and Form Designer tabs. 

 

 

j. Export the Example_Corp_4 sandbox to your machine. Then, publish the sandbox. 

For this topic, the sandbox is exported to the /home/oracle/sandboxes/first 

directory. 

You have added a custom user attribute. Next, you add the attribute to the View User 
Details and Modify User Details pages. 

Note: You must publish the sandbox where a custom user attribute is defined before 
adding the attribute to other user interface forms, because the attribute is not available 
for selection as a display component until the sandbox is published. 

2. Customize the View User Details page to display the custom user attribute. To do this, 
perform the following: 

a. Sign in to the Identity Self Service Console as the xelsysadm user. 

b. Create and activate a sandbox called Example_Corp_4a. 

c. Click Users under Administration. 

 

d. Search for user CSALADNA and click the user link. 

 



 Copyright © 2013, Oracle and/or its affiliates. All rights reserved.  

  Customizing Oracle Identity Manager 

Effective mm/dd/yy Page 28 of  105 Rev 1 

Note: It is not important that you open any particular user. Editing the View User 
Details page in the Web Composer requires the page to be open. To do this, you can 
search for and open the user details for any user. 

e. Make sure that the Attributes tab is active. If it is not, click the tab. 

 

f. Click Customize to open the Web Composer. 

g. Select View > Source from the Web Composer menu. 
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h. Click the Basic Information region to select it for editing in the Web Composer. 

 

i. Click Edit to confirm that you wish to edit the task flow. 
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j. In the Web Composer pane, select panelFormLayout. 

 

The selection on the View User Details page changes to all fields for the Basic User 
Information section. 

 

Note: The panelFormLayout component is the ADF container component that contains 
the fields in the Basic Information section of the View User Details page. 
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k. Click Add Content. 

 

Note: This adds content to the selected component. Because the container for the 
Basic Information section is selected, the new field will be added to this section. 
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l. In the Add Content dialog box, scroll down to find the Data Component – Manage 
Users entry. Click Open. 

 

Note: These Data Components are Java beans, which implement the data access 
layer within Oracle Identity Manager. By selecting the correct bean and attribute, the 
field on a page is mapped to a particular attribute of an entity. In this topic, you map the 

field on the page to the Salary attribute of the User entity. 
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m. Scroll down to find the UserVO1 entry. Click Open. 
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n. If the list of attributes is empty, click Refresh ( ). 

 

All available attributes are displayed. 
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o. Scroll down until you see the Salary attribute. Click Add and from the pop-up menu, 

select “ADF Output Text w/ Label.” 

 

The component for displaying the Salary attribute is added to the panelFormLayout 

component. 

 

Note: The selection of the component from the pop-up menu determines how the 
attribute is displayed on the page. On the View User Details page, the attributes should 
be displayed as non-editable text, so you select “ADF Output Text w/ Label.” 
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p. Click Close to close the Add Content dialog box. 

 

q. Ensure that the panelFormLayout component is still selected and click Edit. 
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r. In the Component Properties dialog box, click the Child Components tab. 

 

s. Use the down arrow icons to move the Salary component to the bottom of the list. 

 

Note: Each click of the down arrow icon moves the component down by one row. 
Continue to click the down arrow icon for the Salary component until it is at the bottom 
of the list. 
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t. Click OK. 

 

Note: This moves the Salary field to the bottom of the Basic Information section of the 
View User Details page. 

u. Click Close to close the Web Composer. 

v. Verify that the Salary field appears in the Basic Information section of the View User 
Details page. 

 

You have added the field to the View User Details page. 
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3. Customize the Modify User page to add the custom attribute. To do this, perform the 
following: 

a. Click Modify User. 

 

The Modify User page is displayed. 

b. Click Customize to open the Web Composer. 

 

c. Select View > Source from the Web Composer menu. 
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d. Click the Basic Information region to select it for editing in the Web Composer. 

 

e. Click Edit to confirm that you wish to edit the task flow. 

 

f. In the Web Composer pane, select panelFormLayout. 
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The selection on the View User Details page changes to all fields for the Basic User 
Information section. 

 

g. Click Add Content. 
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h. In the Add Content dialog box, find the Data Component – Catalog entry and click 
Open. 

 

Note: The Data Component – Catalog entry is selected, because this is the bean that 
is used when modifying users. 
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i. Scroll down to find the UserVO entry and click Open. 

 

j. If the list of attributes is empty, click Refresh ( ) to reload the list. 
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k. Scroll down to find the Salary entry, click Add, and select “ADF Input Text w/label” from 
the pop-up menu. 

 

The component for displaying the Salary attribute is added to the panelFormLayout 

component. 

 



 Copyright © 2013, Oracle and/or its affiliates. All rights reserved.  

  Customizing Oracle Identity Manager 

Effective mm/dd/yy Page 45 of  105 Rev 1 

l. Click Close to close the Add Content dialog box. 

 

m. In the Web Composer pane, select the “inputText: Salary” component and click Edit. 
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n. Select the check box for Auto Submit and Click OK. 

 

Note: The Auto Submit property is used by ADF to asynchronously send changes to 

the underlying data component, using AJAX technology. 

o. Select the panelFormLayout component and click Edit. 
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p. In the Component Properties dialog box, click the Child Components tab. 

 

q. Use the down arrow to move the Salary component to bottom of the list. 

 

Note: Each click of the down arrow icon moves the component down by one row. 
Continue to click the down arrow icon for the Salary component until it is at the bottom 
of the list. 
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r. Click OK. 

 

s. Click Close to close the Web Composer. 

 

t. Close all the tabs, except for the Manage Sandboxes tab. 
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u. Select the current sandbox to highlight it. 

Note: Do not click the name of the sandbox, because this will open the Details page for 
the sandbox. Instead, click in the row for the sandbox entry. 

v. Click Export Sandbox. 

 

w. In the Download files dialog box, make sure that Save File is selected and click OK. 

 

x. Click the triangle next to “Browse for other folders.” 
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y. Browse to the /home/oracle/sandboxes/second directory, and click Save. 

 

A Downloads dialog box appears, confirming that the file has been saved. 

z. Close the Downloads dialog box. 

aa. Make the Terminal window active and navigate to the 

/home/oracle/sandboxes/second folder. 

bb. Unpack the exported sandbox, by entering the following command: 

unzip sandbox_Example_Corp_4a.zip 
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cc. Open the XML file that contains the modifications to the Modify User page, by entering 
the following command: 

gedit 

oracle/iam/ui/runtime/form/view/pages/mdssys/cust/site/site/user

ModifyForm.jsff.xml 

 

dd. Edit the af:inputText tag, adding the following attribute: 

valueChangeListener="#{pageFlowScope.cartDetailStateBean.attribu

teValueChangedListener}" 

 

Note: This attribute is the callback function to notify the server that the value in the 
Salary field has been updated, thereby enabling the Submit button on the form. This 
attribute is normally set in the Component Properties dialog box in the Web Composer, 
but due to a soon-to-be fixed defect in the version of ADF used by Oracle Identity 
Manager, the attribute has to be manually set in the XML in the sandbox. 

ee. Save the file by selecting File > Save on the editor menu bar. Exit the editor by 
selecting File > Quit. 

ff. Remove the backup file created by the editor by entering the following command: 

rm 

oracle/iam/ui/runtime/form/view/pages/mdssys/cust/site/site/user

ModifyForm.jsff.xml~ 

Important: The backup file has a ~ (tilde) appended to the name. Be sure to remove 

the correct file. 

Note: If the file is not removed, the import of the sandbox file will fail. 
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gg. Repackage the sandbox file by entering the following command: 

zip –r sandbox_Example_Corp_4a.zip oracle mdssys pageDefs 

 

hh. Make the Firefox web browser active. 

ii. On the Manage Sandboxes tab, click Import Sandbox. 

jj. Click Browse. 

 

kk. Select the sandbox_Example_Corp_4a.zip file located in the 

/home/oracle/sandboxes/second directory, and click Open. 
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ll. Click Import. 

 

mm.  Search for and click the link for the user CSALADNA and click Modify User. 

 

nn. Click Customize to open the Web Composer and select View > Source from the Web 
Composer menu. 

oo. Select the “Salary inputText” component and click Edit. 
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pp. Verify that the valueChangeListener attribute is correctly updated. 

 

qq. Click Cancel to close the Component Properties dialog box. 

rr. Close the Web Composer. 

ss. Close all tabs, except the Manage Sandboxes tab. 

tt. Publish the sandbox called Example_Corp_4a. 

You have added the Salary field to the Modify User page and updated the 

valueChangeListener attribute. 
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4. Set the value of the attribute for the user CSALADNA. To do this, perform the following: 

a. Search for and click the link for the user CSALADNA. 

b. Click Modify User. 

c. Enter the value 1200 in the Salary field and click Apply. 

 

d. Close the Modify User: CSALADNA tab. 

e. On the User Details: Clarence Saladna tab, click Refresh. 

 

The page refreshes and the updated value is displayed in the Salary field. 

 

You have updated the Salary field for the user CSALADNA. 
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5. Make the field visible only to users assigned the HR Manager or System Administrator 
roles. To do this, perform the following: 

a. Create and activate a sandbox called Example_Corp_4b. 

b. Search for the user CSALADNA and click the user link. 

c. Click Customize to open the Web Composer. 

d. Select View > Source from the Web Composer menu. 

e. Select the “panelLabelAndMessage: Salary” component in the Web Composer and 
click Edit. 

 

f. Click the down arrow next to Visible and select Expression Builder. 
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g. In the text field, replace the value true with the following expression and click OK. 

#{(oimcontext.currentUser.roles['HR Manager'] != 

null)||(oimcontext.currentUser.roles['SYSTEM ADMINISTRATORS'] != 

null)} 

 

Note: This expression evaluates to true if the current user has the role HR Manager 

or the role System Administrators. Because the value of the Visible attribute is 

based on the result of the expression, the field will be visible only if the current user 
has one of these roles. 
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h. Click OK to close the Component Properties dialog box. 

 

i. Close the Web Composer. 

j. Click Modify User to open the Modify User page. 

k. Repeat steps (e) to (i), but this time modify the “inputText: Salary” component. 

l. Close all tabs, except the Manage Sandboxes tab. 

m. Publish the sandbox called Example_Corp_4b. 

n. Sign out of the Identity Self Service Console. 

6. Confirm that only users with the HR Manager role are able to see the attribute. To do this, 
perform the following: 

a. Sign in to the Identity Self Service Console as the user Teena Semmens (TSEMMENS). 

b. Search for the user CSALADNA and click the user link. 
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c. Verify that the Salary attribute is visible on the View User Details page. 

 

Note: Teena Semmens can see the Salary attribute because this user is assigned to 
the HR Manager role. 

d. Sign out of the Identity Self Service Console. 

e. Sign in to the Identity Self Service Console as the user Nancey Jepson (NJEPSON). 

f. Search for the user CSALADNA and click the user link. 

g. Verify that the attribute Salary is not visible on the View User Details page. 

 

Note: The user NJEPSON is not assigned the HR Manager role, and so is not able to 

view the Salary attribute. 

h. Sign out of the Identity Self Service Console. 

You have confirmed that the Salary field is visible only to users assigned the HR 
Manager role. 
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Personalizing the Home Page 

Overview 

The Home page provides you a snapshot of the various functions in Oracle Identity Self Service. 
Each function is displayed as a component of the page. You can personalize the Home page by 
adding and removing components, and rearranging components. In this topic, you: 

 Remove the Direct Reports and Pending Approvals components from the Home page 

 Move the Getting Started Help Topics component 

Tasks 

1. Sign in to the Identity Self Service Console as the xelsysadm user. 

2. Click the Home link. 

 

The Home page is displayed. 

 

3. Click the Personalize link. 
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4. Remove the Direct Reports component. To do this, perform the following: 

a. Click the Close icon ( ) on the top-right corner of the Direct Reports component. 

 

b. Click Delete to confirm deletion of the container. 

 

5. Follow the instructions in step 4 of this topic to remove the Pending Approvals component. 

6. Move the Getting Started Help Topics component to the column on the right. To do this, 
perform the following: 

a. Position the cursor over the top border of the Help Topics component. The cursor 
changes to a four-way arrow. 

 

b. Drag the component to a location below the Change Password component. 
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7. Click Close. 

 

The personalized Home page is displayed. 

 

You have personalized the Home page. 

8. Sign out of the Identity Self Service Console. 
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Personalizing Search Results 

Overview 

In this topic, you perform the following: 

 Change the sort order of a result table 

 Manage the displayed columns in a result table 

 Save search filters and result layouts for later use 

Tasks 

1. Change the sort order of a result table. To do this, perform the following: 

a. Sign in to the Identity Self Service Console as the xelsysadm user. 

b. Click Users under Administration. 

c. On the Search Users tab, enter Finance in the Organization field. Click Search. 

 

The search results now list only the users in the Finance organization. 

 

You have used search criteria to search for users in the Finance organization. 
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d. Move your cursor over the User Login header in the result table and click Sort 
Descending. 

 

The results are now sorted by the User Login field, in descending order. 

 

e. To sort in ascending order for any displayed column, move your cursor over the header 
in the result table and click Sort Ascending. 

You have sorted the results in the result table. 
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2. Remove the Display Name, Telephone Number, and Organization columns from the result 
table. To do this, perform the following: 

a. Select View > Columns > Manage Columns from the Search Results menu bar. 

 

b. Select Display Name in the Visible Columns list and click  to move the selection to 
the Hidden Columns list. 
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c. Do the same for Telephone Number and Organization, and click OK. 

 

The result table is updated. 

 

You have removed the Display Name, Telephone Number, and Organization columns 
from the result table.  
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3. Save the search for future use. To do this, perform the following: 

a. Click Save. 

 

b. The Create Saved Search dialog box appears. Enter Finance Users in the Name 

field. Deselect the “Set as Default” and Run Automatically options. Select the Save 
Results Layout option. Click OK. 

 

Note: You deselect the “Set as Default” check box to ensure that the search you are 
saving is not the default search for this type of Oracle Identity Manager entity. For this 
example, you do not want Finance Users to be the default search for users. 

You deselect the Run Automatically check box to ensure that an administrator must run 
the saved search manually (by clicking the Search button). 

You select the Save Results Layout check box to ensure that the results table of the 
saved search does not have the Display Name, Telephone Number, or Organization 
columns. 

c. Select Search User from the Saved Search drop-down list and click Search. All users 
are listed in the result table. 

Note: All columns are displayed in the result table. 
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d. Select Finance Users from the Saved Search drop-down list and click Search. 

 

The search results contain only the users in the Finance organization, and the results 
table does not have the Display Name, Telephone Number, or Organization columns. 

You have saved the query and the result layout into a Saved Search called “Finance 
Users.” 

4. Use Query By Example to search for user records. To do this, perform the following: 

a. Select Search User from the Saved Search drop-down list. 

 

b. Make sure that Query By Example is selected in the View menu. 
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c. In the text entry field above the Last Name column, enter s and press Enter. 

 

The list of results is refreshed to display only those records with a Last Name that 
begins with “s.” 

 

You have used Query By Example to search for user records. 
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Renaming Panel Text 

Overview 

In this topic, you change the name of a panel in the Search Users form (from Search to Find).  

Tasks 

1. Sign in to the Identity Self Service Console as the xelsysadm user. 

2. Create and activate a sandbox called Example_Corp_7. 

3. Click Users under Administration. The Search Users form appears. 

 

Note: The top-most panel in the Search Users form is Search. For this topic, you are to 
change the name of the Search panel to Find. 

4. Click Customize to open the Web Composer. 

 

5. Select View > Source from the Web Composer menu. 
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6. Select the Search panel of the Search Users form (a blue border should appear around the 
panel). 

 

7. On the Confirm Task Flow Edit window, click Edit. 

 

8. On the Editing Page page, click Edit. 
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9. On the Component Properties window, click the Down Arrow button to the right of the 
Header Text field. Select Expression Builder from the popup menu that appears. 

 

10. In the Edit window, select the Type a value or expression option. In the text area below the 
option, enter Find. Click OK. 

 

Note: You enter Find in the text area because, in this topic, you are changing the name of 

a panel in the Search Users form (from Search to Find). 
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11. Click OK. 

 

 You changed the name of a panel in the Search Users form (from Search to Find). 

12. Click Close (to close the Web Composer). 

 

13.  Close the Users tab. 

14.  Publish the Example_Corp_7 sandbox. 
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15.  Verify that the change you made to the Search panel in the Search Users form took effect. 
To do so, click Users under Administration. The Search Users form appears. 

 

You changed the name of a panel in the Search Users form (from Search to Find). 
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Customizing Console Menus 

Overview 

In this topic, you organize, rename, and hide menus for the Identity Self Service Console. 
Specifically, you: 

• Organize the My Profile menu of the console so that the My Access item and My 
Information item swap places. As a result, the My Access menu item is to appear first 
and the My Information menu item is to appear second. 

• Change the name of the Requests menu (to My Requests) 

• Hide the Administration menu 

Tasks 

1. Sign in to the Identity Self Service Console as the xelsysadm user. 

2. Create and activate a sandbox called Example_Corp_8. 

3. Click Customize to open the Web Composer. 

 

4. Select View > Source from the Web Composer menu. 
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5. Select the My Profile menu of the console (a blue border should appear around the menu). 

 

Note: You select the My Profile menu because, for this procedure, you are restructuring the 
menu so that the My Access menu item and My Information menu item swap places. 

6.  On the Confirm Task Flow Edit window, click Edit. 

 

7. In the Web Composer pane, select panelGroupLayout: vertical. 

 

 Note: You select panelGroupLayout: vertical because you are changing the layout of the 
group of items in the My Profile menu (which appears vertically on the Identity Self Service 
Console). 
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8.  On the Editing Page page, click Edit. 

 

9. On the Component Properties window, click the Child Components tab. 
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10. Click the blue arrow button to the right of the My Access item. 

 

Note: You click the blue arrow button because you want the My Access item and My 
Information item to swap places. 
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The My Access menu item appears first and the My Information menu item appears 
second. 

 

11.  On the Component Properties window, click Apply. Click OK. 

You organized the My Profile menu of the Oracle Identity Manager Identity Self Service 
Console. You are ready to change the name of the Requests menu of this console to My 
Requests. 

12. Select the Requests menu of the console (a blue border should appear around the menu). 
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13. On the Editing Page page, click Edit. 

 

14. On the Component Properties window, click the Down Arrow button to the right of the Text 
field. Select Expression Builder from the popup menu that appears. 

15. In the Edit window, select the Type a value or expression option. In the text area below the 
option, enter My Requests. Click OK. 

 Note: You enter My Requests in the text area because, in this topic, you are changing the 

name of a menu (from Requests to My Requests). 

16. On the Component Properties window, click Apply. Click OK. 

 You change the name of a menu of the Oracle Identity Manager Identity Self Service 
Console (from Requests to My Requests).  

 

You are ready to hide the Administration menu of this console. 

17. Select the Administration menu of the console (a blue border should appear around the 
menu). 

18. On the Editing Page page, click Edit. 
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19. On the Component Properties window, deselect the Show Component check box. 

 

Note: You deselect the check box because, in this topic, you are hiding the Administration 
menu of the Oracle Identity Manager Identity Self Service Console. 

20. On the Component Properties window, click Apply. Click OK. 

21. On the Editing Page page, click Close. 

22. Publish the Example_Corp_8 sandbox. 
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23. Verify that the changes you made to the My Profile, Requests, and Administration menus of 
the Identity Self Service Console took effect. 

 

In the My Profile menu, the My Access item appears first and the My Information item 
appears second. You restructured the My Profile menu of the console so that the two menu 
items swapped places.  

Also, notice that the Requests menu appears as My Requests, and that the Administration 
menu no longer appears on the console.  

You organized, renamed, and hid menus on the Identity Self Service Console. 
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Adding a User-Defined Field (UDF) to a Console Page 

Overview 

For Oracle Identity Manager 11gR2 PS1, you create, modify, and customize user defined fields 
(UDFs) through the ADF Business Editor. This tool is available through the Identity System 
Administration Console of Oracle Identity Manager. 

In this topic, you add the SS Number UDF as a text field to the Basic User Information page. 

Tasks 

1. Make the Identity System Administration Console active. 

2. Sign in to the Identity System Administration Console as the xelsysadm user. 

3. Create and activate a sandbox called Example_Corp_9. 

4. On the Home page of the Identity System Administration Console, click the Form Designer 
link (located in the left-hand pane). 

 

5. On the Form Designer page, select User from the Type drop-down menu. Click Search. 
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6. From the search results that appear, click the User link. 

 

7. On the User page, click Create a custom field. 
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8. On the Select Field Type window, select the Text option. Click OK. 

 

9. Populate the fields of the Create Text Field page, as indicated in the following screenshot 
(and click Save and Close): 

 

10. Publish the Example_Corp_9 sandbox. 

11. Make the Identity Self Service Console active. 

12. If prompted, sign in to the Identity Self Service Console as the xelsysadm user. 

13. Create and activate a sandbox called Example_Corp_9a. 
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14. On the Home page of the Identity Self Service Console, click the My Information link 
(located in the left-hand pane). 

 

Note: If an error message appears, complete the following steps: 

a. Close the tab that contains the Identity Self Service Console.  

b. Make the console active. 

c. Sign in to the console as the xelsysadm user. 

d. Activate the Example_Corp_9a sandbox. 

e. Click the My Information link. 

15. Click Customize to open the Web Composer. 
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16. Select the View menu. Then, select Source from the drop-down menu that appears. 

 

17. Select the Basic User Information page (a blue border should appear around the content of 
this page). On the Confirm Task Flow Edit window, click Edit. 

 

 Note: The Confirm Task Flow Edit window appears automatically. 
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18. On the Editing Page page, click Add Content. 

 

19. On the Add Content window, click the Open link to the right of Data Component – Catalog. 
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20. On the Add Content window, click the Open link to the right of userVO. 
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21. On the Add Content window, click the Add link to the right of the UDF you created in this 
procedure (SS Number). 
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22. Select ADF Input Text w/Label from the popup window that appears. 
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23. On the Add Content window, click Close. 

 

 The SS Number UDF you created appears at the top of the Basic User Information page. 
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24. On the Editing Page page, click Close. 

 

25. Publish the Example_Corp_9a sandbox. 

26. On the Home page of the Identity Self Service Console, click the My Information link. 

 The SS Number UDF you created appears on the Basic User Information page. 

 

 You added a UDF as a text field to a page in Oracle Identity Manager. 
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Adding the User-Defined Field (UDF) to a Search Page 

Overview 

In the previous topic, you added the SS Number UDF as a text field to the Basic User 
Information page of the Identity Self Service Console.  

You are ready to add this UDF as an attribute to the Search Results table of the Users form. 

Tasks 

1. Make the Identity Self Service Console active. 

2. Sign in to the console as the xelsysadm user. 

3. Create and activate a sandbox called Example_Corp_10. 

4. Click Customize to open the Web Composer. 

 

5. Select the View menu. Then, select Source from the drop-down menu that appears. 

 

6. Select the My Requests menu (a blue border should appear around the content of this 
page). On the Confirm Task Flow Edit window, click Edit. 
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7. Right-click the showDetailHeader: Administration and select Show Component 

from the popup menu that appears. 

 

Note: In this topic, you are adding the SS Number UDF as an attribute to the Search 
Results table of the Users page. Presently, this page is hidden, along with all other pages 
of the Administration menu. Therefore, by selecting Show Component, you are enabling all 
pages that compose the Administration menu (including the Users page) to appear. 

8. On the Editing Page page, click Close. 
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The Administration menu now appears on the Identity Self Service Console. 

 

Now that the Users page is accessible, you are ready to add the SS Number UDF as an 
attribute to the Search Results table of the Users form. 
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9. On the Home page of the Identity Self Service Console, click the Users link (located in the 
Administration menu). 

 

10. Click Customize to open the Web Composer. 

11. Select the View menu. Then, select Source from the drop-down menu that appears. 

12. Click the Search Results table. The table:t1 item should be highlighted in the Editing 

Page page. 

 

 Note: t1 represents the first (and only) table on the Users page: the Search Results table. 
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14. On the Editing Page page, click Add Content. 
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15. On the Add Content window, click the Open link to the right of Data Component – Manage 
Users. 
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16. On the Add Content window, click the Open link to the right of UserVO1. 
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17. On the Add Content window, click the Add link to the right of the UDF you created in the 
previous topic (SS Number). 
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18. Select ADF Table Column from the popup window that appears. 

 

 Note: You select ADF Table Column because you want to add the SS Number UDF to the 
Search Results table of the Users page. 

20. On the Add Content window, click Close. 

21. Verify that you see the SS Number UDF as a column on the Search Results table. 
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22. Click on the SS Number column. A blue border should appear around this column. In 
addition, the column: SS Number should be highlighted on the Editing Page page. 

 

23. On the Editing Page page, click Edit. 
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24. On the Component Properties window, click the Down Arrow button to the right of the 
Header Text field. Select Expression Builder from the popup menu that appears. 

 

25. In the Edit window, select the Type a value or expression option. In the text area below the 
option, enter User Classification. Click OK. 
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26. On the Component Properties window, enter SSNumber__c in the Sort Property field. 

Select the Filterable and Sortable check boxes. Click OK. 

 

Important: Make sure that two underscores (__) appear between SSNumber and c. 

 The Column Header of the Search Results table changes from SS Number to User 
Classification. Also, there is a white text box that appears above this column, signifying that 
this column is both searchable and filterable. 

 

27. On the Editing Page page, click Close. 

28. Publish the Example_Corp_10 sandbox. 

29.  On the Home page of the Identity Self Service Console, click the Users link (contained 
within the Administration menu). 

The User Classification column, which represents the SS Number UDF, appears on the 
Search Results table. 

 


