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Overview

Welcome to the DMU Kinematics User's Guide. This guide is intended for users who need to become 
quickly familiar with the DMU Kinematics Version 5 product. 

This overview provides the following information:

●     DMU Kinematics Simulator in a Nutshell

●     Before Reading this Guide

●     Getting the Most out of This Guide

●     Accessing Sample Documents

●     Conventions Used in this Guide

DMU Kinematics Simulator in a 
Nutshell

DMU Kinematics Simulator is an independent CAD product dedicated to simulating assembly motions. 
It addresses the design review environment of digital mock-ups (DMU) and can handle a wide range 
of products from consumer goods to very large automotive or aerospace projects as well as plants, 
ships and heavy machinery.

DMU Kinematics Simulator is a dedicated DMU Navigator workbench and is available on both UNIX 
and Windows environments. 

Before Reading this Guide
Before reading this guide, you should be familiar with basic Version 5 concepts such as document 
windows, standard and view toolbars. Therefore, we recommend that you read the Infrastructure 
User's Guide that describes generic capabilities common to all Version 5 products. It also describes 
the general layout of V5 and the interoperability between workbenches. You may also read DMU 
Navigator User's Guide

You may also like to read the following complementary product guides, for which the appropriate 
license is required:

●     Knowledge Advisor User's Guide

●     DMU Fitting Simulator User's Guide

●     DMU Space Analysis User's Guide
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Getting the Most out of this Guide

To get the most out of this guide, we suggest you start reading and performing the step-by-step 
tutorial Getting Started. This tutorial will show you how to create mechanisms and joints from 
scratch.

Once you have finished, you should move on to the next section: Basic Tasks dealing with the main 
capabilities of DMU Kinematics product (mechanism and joints design, Kinematics simulations...) The 
next section Advanced Tasks focuses on analysis and review. You might be interested in reading the 
Interoperability section which can be accessed directly from the table of contents using the following 

icon . It may also be a good idea to take a look at the section describing the menus and 
toolbars: Workbench Description

Accessing Sample Documents

To perform the scenarios, you will be using sample documents contained in the 
online\kinug_*X2\samples folder

When samples belong to capabilities common to different products, those samples will be found in 
the online\cfysa_X2\samples folder. 

*Where X can be C for CATIA or E for ENOVIA.

For more information about this, refer to Accessing Sample Documents in the Infrastructure User's 
Guide.

Conventions Used in this Guide

To learn more about the conventions used in this guide, refer to the Conventions section. 
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Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you recognize and understand important concepts and 
specifications. 

Graphic Conventions

The three categories of graphic conventions used are as follows:

●     Graphic conventions structuring the tasks

●     Graphic conventions indicating the configuration required

●     Graphic conventions used in the table of contents

Graphic Conventions Structuring the Tasks

Graphic conventions structuring the tasks are denoted as follows:

This icon... Identifies...

estimated time to accomplish a task

a target of a task

the prerequisites

the start of the scenario

a tip

a warning

information

basic concepts

methodology

reference information

information regarding settings, customization, etc.

the end of a task

functionalities that are new or enhanced with this Release.

allows you to switch back the full-window viewing mode.

Graphic Conventions Indicating the Configuration Required 

Graphic conventions indicating the configuration required are denoted as follows:

This icon... Indicates functions that are... 
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specific to the P1 configuration

specific to the P2 configuration

specific to the P3 configuration

Graphic Conventions Used in the Table of Contents

Graphic conventions used in the table of contents are denoted as follows:

This icon... Gives access to...

Site Map

Split View mode

What's New?

Overview

Getting Started

Basic Tasks

User Tasks or the Advanced Tasks

Workbench Description

Customizing

Reference

Methodology

Glossary

Index

Text Conventions

The following text conventions are used:

  The titles of CATIA, ENOVIA and DELMIA documents appear in this manner throughout the text.
  File -> New identifies the commands to be used.
  Enhancements are identified by a blue-colored background on the text. 

How to Use the Mouse

The use of the mouse differs according to the type of action you need to perform.

Use this
mouse button... Whenever you read...
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●     Select (menus, commands, geometry in graphics area, ...)

●     Click (icons, dialog box buttons, tabs, selection of a location in the document window, ...)

●     Double-click

●     Shift-click

●     Ctrl-click

●     Check (check boxes)

●     Drag

●     Drag and drop (icons onto objects, objects onto objects)

●     Drag

●     Move

●     Right-click (to select contextual menu)
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What's New?
This section identifies what new or improved capabilities have been documented in the Version 5 
Release 13 of DMU Kinematics Simulator User's Guide.

Enhanced Functionalities

All Commands

Working with ENOVIA LCA
Optimal PLM Usability for DMU Kinematics Simulator to ensure that data created in CATIA can 
be correctly saved in ENOVIA V5

Sensors

Using sensors
In the Sensors dialog box, selecting a clash sensor activates automatically the clash detection 
(is set to on)

Mechanism Analysis

Analyzing a mechanism
It is now possible to save the information of the Mechanism Analysis dialog box (in .xls, txt 
and lotus 123 formats)

Managing Kinematics Data in Sub-products

Importing a mechanism and its dressup from a skeleton structure
It is now possible to import the dressup associated to a mechanism from a skeleton structure, 
please also read More about importing mechanisms dressups and Importing a mechanism and 
its dressup
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Getting Started

Before getting into the detailed instructions for using DMU Kinematics Simulator Version 5, the 
following tutorials aim at giving you a feel of what you can do with the product. It provides two step-
by-step scenarios showing you how to use key functionalities.
The main tasks described in this section are:

Designing a V5 Mechanism
Using V4 Kinematic Data
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Designing a V5 Mechanism
 

Entering the Workbench
Creating a Mechanism and Revolute Joints

Creating Cylindrical Joints
Defining a Command
Defining a Fixed Part

Simulating 

 

 

These tasks should take about 20 minutes to complete.
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Entering the Workbench

Before starting this scenario, you should be familiar with the basic commands common to all workbenches. These are 
described in the DMU Navigator User's Guide.

This first task will show you how to enter the DMU Kinematics Simulator workbench and select your models.

1.  Select Digital Mockup -> DMU Kinematics from the Start menu.

The DMU Kinematics workbench is loaded and an empty document opens:

2.  Select File -> Open from the menu bar.

3.  Select the rods.CATProduct  document from the samples folder.
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4.  Click Open to open the selected file.

The specification tree is displayed showing all the selected products. 

5.  Select the products in the tree, then select Edit->Representations->Design Mode.  Then expand the tree to 

show all the design components of the products. 

 

Use the Fit All In icon  to position the model geometry on the screen. 
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Creating a Mechanism and Revolute Joints
This task will show you how to create a mechanism and revolute joints.

Open the rods.CATProduct document.

1.  Select the product in the specification tree, then select Edit->Representations->Design Mode. 

You can now expand the tree to show all the design components of the products. 

2.  Click the Revolute Joint icon  from the Kinematic Joints  toolbar. 

The Joint creation : Revolute dialog box is displayed:

3.  Click New Mechanism. The Mechanism Creation dialog box is displayed:

you can now enter a name of your choice. Click Ok when done.

In our example, keep the default name Mechanism.1
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The Mechanism is identified in the specification tree.

Now you need to select two lines and two planes

 

4.  Select Line 1 in the geometry area. In our example select a cylinder as shown below.

The dialog box is automatically updated with your selection.

Zoom in if necessary using the View->Zoom In Out command and drag (left mouse button) to zoom in 
progressively.
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5.  Select Line 2 in the geometry area. Select a second cylinder.

The dialog box current selection field is automatically updated.

6.  Select the planes as shown below.

The Current selection field is automatically updated.
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7.  Click Ok to end the Revolute Joint creation.The Revolute Joint is created.

The specification tree is updated.

 

Proceed in the same manner to create Revolute. 2, Revolute. 3

This is what you obtain:

You can also create a new mechanism selecting Insert-> New Mechanism... from the Menu bar.
The new mechanism is created and identified in the specification tree.
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Creating Cylindrical Joints
This task will show you how to create cylindrical joints.

You created a mechanism and 3 revolute joints as shown in the previous task.

1.  Click the Cylindrical Joint icon  . 

The Joint Creation: Cylindrical dialog box appears:

2.  Select Line 1 in the geometry area. In our example select a cylinder as shown below:
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The dialog box is automatically updated with your selection.

3.  Select Line 2 in the geometry area. In our example select a cylinder as shown below:
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The Cylindrical joint is created as well as the constraints.
The specification tree is updated.

You can define commands while creating cylindrical joints: 
❍     Angle driven

❍     Length driven

all you need to do is to check the required option.

Remember that you can at any time modify the command. For this, double-click the joint in the 
specification tree and edit the settings in the displayed dialog box. For more details, please 
refer to Editing joints.

 

The dialog box is automatically updated with your selection.

4.  Click OK to end the cylindrical joint creation.
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Defining a Command

You can either define a command after joint creation or during joint creation.

In our example, you will define a command after joint creation.

1.  Double-click Revolute. 3 in the specification tree.

The Joint Edition dialog box is displayed.

2.  Select the Angle Driven checkbox. The Angle driven option lets you assign the revolute 

joint an angle type command.
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3.  Click Ok to confirm your operation.

The command is identified in the specification tree.
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Defining a Fixed Part
This task will show you how to define a Fixed part.

1.  Click the Fixed Part icon  from the DMU Kinematics toolbar or select Insert-

>Fixed Part... from the menu bar. The New Fixed Part dialog box is displayed.

2.  Select the Fixed Part either in the geometry area or in the specification tree.
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At any time you can use the undo command  to modify your selection.

 

3.  The fixed Part is automatically defined.

The fixed part is identified in the specification tree.
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Simulating a V5 Mechanism

This task will show you how to simulate the V5 mechanism you created.

You designed a V5 mechanism as described in the previous steps.

1.  Click the Simulation With Commands icon .

The Kinematic Simulation dialog box is displayed:

The command of the kinematics mechanism is available

2.  Manipulate the slider of the command.

The  kinematics mechanism moves accordingly.

3.  or Use the manipulator in the geometry area. For this:

Move the mouse over a joint. The driven joint highlights and the manipulator appears.

Drag the model with the left mouse button.
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For more information please refer to Running Simulations and About Joints.

You can also enter a value for the command  to achieve the same result.  

Note that if you click the  button, the Kinematics Simulation dialog box expands. The immediate option is set by default. For more 
information about the On request option, please refer to  Simulating on Request
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Using V4 Kinematics Data
 

Entering the Workbench
Browsing the Mechanism

Simulating With Commands
Simulating With Laws

 

 

These tasks should take about 20 minutes to complete.
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Entering The Workbench

Before starting this scenario, you should be familiar with the basic commands common to all workbenches. These 
are described in the DMU Navigator User's Guide.

This first task will show you how to enter the DMU Kinematics Simulator workbench and select your models.

1.  Select Digital Mockup->DMU Kinematics from the Start menu.

The DMU Kinematics workbench is loaded and an empty document opens:

2.  Select Insert -> Existing Component... from the menu bar.

3.  Select the desired Kinematics model files by clicking the first one then shift-clicking the last one you want.

4.  Click Open to open the selected files.

The specification tree is displayed showing all the selected products. 
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5.  Select the products in the tree containing kinematics objects, then select Edit ->Representations-

>Design Mode. You can now expand the tree to show all the design components of the products.

Remember that DMU Kinematics Simulator exploits CATIA Version 4 multi-model sessions that have been 
prepared with one or more kinematic mechanisms.

Use the Fit All In icon  to position the model geometry on the screen.
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Browsing the Properties of the Kinematics 
Mechanism

This task will show you how to browse the properties of the selected kinematics mechanism.

Insert  the KIN_EX17* .model files from the samples folder.

If you work with the Cache System, please make sure you are in Design mode (select Edit->Representations-
>Design Mode.). for more detailed information, please refer to the DMU Navigator user's Guide - Task: 
Viewing the Cache Content.

1.  Select KIN_EX17_00_F1_ACTIVE and expand the tree.

2.  Right-click the kinematics mechanism in the specification tree or select the Edit->Properties... from 

the menu bar.

3.  In the first case, select Properties from the contextual menu displayed.

The Properties dialog box is displayed: 
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4.  Click OK.

5.  Click the Mechanism Analysis icon  . The General Properties of the kinematics mechanism are 

displayed as shown.

6.  You can select another mechanism using the Mechanism name combo.

7.  If you check the Show joints, this is what you obtain:
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8.  If you click the  button, you access to a graphic representation of the laws associated to each 

command. It is represented by a colored curve. When you pass the cursor along the curve, information 

about the law is displayed in the status bar.

For more detailed information please refer to Analyzing A Mechanism.

For more detailed information about laws, please refer to Simulating With Laws.
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Simulating With Commands

This task will show you how to run a kinematics simulation with commands.

Insert the KIN_EX17* .model files from the samples folder.

If you work with the Cache System, please make sure you are in Design mode (select Edit->Representations->Design Mode.). for 
more detailed information, please refer to the DMU Navigator user's Guide - Task: Viewing the Cache Content.

In our sample document, there is only one mechanism. If you work with a product containing more than one mechanism, it is strongly 
recommended to select the mechanism you need before starting the simulation with commands.

1.  Click the Simulation With Commands icon . 

The Kinematic Simulation dialog box is displayed:

The commands of the kinematics mechanism are available as shown

2.  Manipulate the slider of a command. For instance select the LEFT.

The corresponding part of the kinematics mechanism moves accordingly
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You can use the slider, enter a value or manipulate the geometry directly to achieve the same result.

3.  Manipulate the other commands in the same way.

  

 

 

Note that if you click the  button, the Kinematic Simulation dialog box expands. The immediate option is set by 
default. For more information about the On request option, please refer to  Simulating on Request.
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Running a Simulation With Laws

This task will show you how to run a kinematics simulation with laws that are already defined 
on the mechanism.

Insert the KIN_EX17* .model files from the samples folder.
The Kinematics Simulation dialog box is displayed as described in the previous task.

1.  Click the Simulation With Laws icon .

The Kinematic Simulation dialog box appears 

2.  Set the Number of steps to 10, then click the Play button.

You can use the other buttons to run the simulation again in different modes 
(backward, step by step, and so on).

Notice that you cannot record simulations within the Simulation With Laws functionality. If you 
need to record such a simulation or several simulations, please refer to Recording Positions.
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Basic Tasks

The table below lists the tasks you will find in this section.

Setting Up Your Session
Designing a V5 mechanism

Designing Joints
Fixed Parts and Commands

Converting Constraints into Joints
Using the Update Command

Moving Constrained Components Using the Compass
Running Simulations
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Setting Up Your DMU Kinematics Simulator 
Session

DMU Kinematics Simulator provides easy methods to simulate mechanisms previously defined using 
the CATIA Version 4 KINEMAT and KINEMUSE functions. 

You may find it useful to refer to your CATIA Version 4 Kinematics User's Reference Manual.

 

Prepare CATIA Version 4: transfer the solid and surface geometry that represents the moving parts 
into separate models (1 part per model). The model containing the kinematics mechanism should 
only be a stick model (that is, wireframe plus the definition of the mechanism). Use KINEMUSE 
function's DRESSUP item to define set/model relationships. Save all models and, if needed, the 
session.
Convert V4 Kinematic Data into DMU Kinematic V5: open the model containing the kinematics 
mechanism. In the specification tree where the Version 4 kinematics model is displayed, select the 
mechanism you wish to copy into the Kinematics Simulator Version 5. Put the data you have selected 
in the clipboard, then select Application in the specification tree and paste.
Open Version 5: enter the DMU Kinematics workbench, then select Insert->Existing Component in 
order to select the desired models.
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Preparing a Multi-Model Session in CATIA 
Version 4

 

This task shows how to prepare a CATIA Version 4 kinematics mechanism for use in DMU 
Kinematics Simulator Version 5.

 
1.  Transfer the solid and surface geometry that represents the moving parts into separate 

models (1 part per model). 

The model containing the kinematics mechanism should only be a stick model 
(that is, wireframe plus the definition of the mechanism).

  

2.  Use KINEMUSE function's DRESSUP item to define set/model relationships.

3.  Save all models and, if needed, the session.
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Converting Version 4 Kinematics Data into 
Kinematics Version 5 Data

This task shows how to convert  CATIA Version 4 kinematics data into  DMU Kinematics 
Simulator Version 5.Data

Insert  the KIN_EX17* .model files from samples folder.

If you work with the Cache System, please make sure you are in Design mode (select Edit-
>Representations->Design Mode.). for more detailed information, please refer to the DMU 
Navigator user's Guide - Task: Viewing the Cache Content.

The following task shows how kinematics data is pasted from an existing Version 4 model to an 
existing Version 5 document alongside V5  data. You can of course also insert the V4 data into a 
new Version 5 document.

1.  Open the model containing the kinematics mechanism. 

 

Open the Kinematics Simulator workbench if necessary.

The model containing the kinematics mechanism should only be a stick model 
(that is, wireframe plus the definition of the mechanism).

2.  In the specification tree or in the geometry area where the Version 4 kinematics model 

is displayed, select the mechanism you wish to copy into the Kinematics Simulator 

Version 5. In our example, select KIN_EX_00_F1_ACTIVE and LANDING GEAR.
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3.  You can also use the drag &drop capability.

4.  Put the data you have selected in the clipboard. To do this, either click the Copy icon, 

select the Edit->Copy command or select the Copy command in the contextual menu.
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5.  Select Application in the specification tree.

6.  Now either click the Paste icon, select the Edit->Paste command or select the Paste 

command in the contextual menu.

This operation recovers the data previously put in the clipboard

You may want to click the Fit All In icon   to fit all data in the window. 

The dressup is maintained when you perform a copy/paste within the same document.

Notice that the toolbars change depending on whether a Version 4 model or a DMU Kinematic 
Version 5 document is selected.
The result should look something like this:
V4 laws are converted in a V5 mechanism.
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Kinematics Simulator fully supports V4 mechanisms ( 2D/3D) conversion into 3D mechanisms 
version 5.
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V4 dressup  V5 dressup 

 
Outputs   

numerical (angles/distances)  equivalent functionality (no conversion)
speed, acceleration  are not converted

traces  equivalent functionality (no conversion)
clashes  equivalent functionality (no conversion)

distances  equivalent functionality (no conversion)
Laws   

numeric laws  Knowledgeware rules

  

geometric laws  are not converted

 

 

 

What About the Elements You Convert?
To make sure the elements you need to handle in your session are those you expected, here is a list 
presenting the CATIA  V4 Kinematics data supported when converted  into a Kinematics Version 5 
document:

 

V4 Data Type  V5 Data Type
   

Mechanism Structure  Result  
2D  /  3D  3D
mechanism  V5 mechanism

joint  V5 joint
(revolute,cylindrical,spherical,planar,
prismatic,rigid,pt/crv,roll/crv,slid/crv,

gear,rack,cable,screw)
  

command  V5 command
fix  V5 fixed part

model   CATProduct 

set  

sub-product + associated part

Geometry contained in the set 
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Opening Your DMU Kinematics Simulator Document 
in Version 5

 

This task recalls how to open a DMU Kinematics Simulator Version 5 document.

 
1.  Enter the DMU Kinematics workbench, then select Insert->Existing Component in order to select the 

desired models. 

 

Please refer to Entering the DMU Kinematics Workbench and Selecting Models 

2.  Activate the desired kinematics products in the specification tree.
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Designing a V5 Mechanism
About Joints

Creating a Mechanism and Revolute Joints
Creating Joints
Editing Joints

Deleting Joints
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About Joints

DMU Kinematics Simulator lets you define and edit 16 different joint types.

The tables below describe the joint types and their characteristics:

DMU Kinematics Simulator lets you define the following joints using axis systems:
●     u joint

●     prismatic

●     revolute

●     cylindrical

●     spherical

  

V4 NAME JOINT TYPE DEGREES OF FREEDOM COMMAND TYPE DIRECT MANIPULATION

revolute Revolute 1 Rotation Angle YES / Left-mouse button

prismatic Prismatic 1 Translation Length YES / Left-mouse button

actuator Cylindrical 

  

1 Rotation 
1 Translation

  

 

Length + Angle Length: Left-mouse button Angle:
Left-Mouse 

button + Middle-
Mouse button

AND/OR

Angle or Length YES / 
Left-mouse 

button

 

pt/pt Spherical 3 Rotations _ NO

planar Planar 2 Translations 
1 Rotation _ NO

rigid Rigid _ _ NO

roll/crv Roll Curve 1 Rotation
1Translation Length NO

slid/crv Slide Curve 2 Rotations
1 Translation _ NO

pt/crv Point Curve 3 Rotations
1 Translation Length NO

pt/surf Point Surface  2 Translations
3 Rotations _ NO

u jnt U Joint 1 Rotation _ NO

gear Gear joint 1 Rotation Angle1 or Angle2
(exclusive) YES / Left-mouse button

rack Rack Joint 1 Rotation or
1 Translation

Length1 or Angle2
(exclusive) YES / Left-mouse button

cable Cable Joint 1 Translation Length1 or Length2 YES / Left-mouse button

screw Screw Joint 1 Rotation or
1 Translation

Angle or Length
(exclusive) YES / Left-mouse button

cv joint CV Joint _ _ NO
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Prismatic  

 

Line Line Plane Plane _ _ _ (1)(2)(4)

Cylindrical  

 

Line Line _ _ _ _ _ (1)

Spherical  

 

Point Point _ _ _ _ _ (1)

Planar  

 

Plane Plane _ _ _ _ _ (1)

Rigid  

 

Product Product _ _ _ _ _ (1)

Roll Curve  

 

Curve Curve _ _ _ _ _ (1)

Slide Curve  

 

Curve Curve _ _ _ _ _ (1)

Point Curve  

 

Curve Point _ _ _ _ _ (1)

Point Surface   

 

Surface Point _ _ _ _ _ (1)

Universal Joint  

 

Line Line Line _ _ _ _ (1)(5)

Gear Joint Revolute Revolute _ _ _ _ Ratio (7)

Screw Joint Line Line _ _ _ _ Ratio (1)

Cable Joint Prismatic Prismatic     Ratio (7)

Rack Joints Prismatic Revolute     Ratio  

CV Joints U joint U joint      (7)(8)

 

*Conditions between selections:
(1) selection 1 in another product than selection 2
(2) selection 3 in either first selections' product, selection 4 in the other
(3) line orthogonal to plane of same part
(4) line lying in plane of same part
(5) line 'selection 3' must be in either first selections' product and cross selection

(6) selection 5 and 6 are optional ('centered case'); selection 5 in either first selections' product, selection 6 in the other
(7) compound joints are based on basic joints selection or on-the-fly creation: a part is shared by the two joints
(8) requires equal input and output angles

 

JOINT TYPE SELECTIONS RATIO

 

*CONDITIONS

 
  sel.1 sel.2 sel.3 sel.4 sel.5 sel.6   
Revolute  

 
Line  Line Plane Plane Plane Plane _ (1)(2)(3)(6)
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Creating a Mechanism 
and Revolute Joints

This task shows how to create a kinematics mechanism to use in DMU Kinematics Simulator Version 5.

Open the rods.CATProduct document.

 
1.  Make sure you are in Design mode. If not, select the product in the tree, then select Edit->Representations-

>Design Mode. 

If the menu item cannot be selected, right-click product1 in the specification tree.

2.  Click the Revolute Joint icon  from the DMU Simulation Toolbar.The Joint Creation: Revolute dialog box is 

displayed:

3.  Click New Mechanism.

The Mechanism Creation dialog box is displayed:
This dialog box lets you enter a meaningful name for the mechanism. Click Ok when done.

You can also create a new mechanism selecting Insert-> New Mechanism... from the Menu bar.

In our example, keep the default name Mechanism.1.

The Mechanism is identified in the specification tree.
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Now you need to select two lines and two planes

4.  Select Line 1 in the geometry area. In our example select a cylinder as shown opposite:

The dialog box is automatically updated with your selection.

5.  Select Line 2 in the geometry area. Select a second cylinder.

The dialog box current selection field is automatically updated.

6.  Select the planes as shown below.

49Page DMU Kinematics Simulator Version 5 Release 13



The Current selection field is automatically updated.
The specification tree is updated.

7.  Click Ok to end the Revolute Joint creation

8.  Proceed in the same manner to create other joints

Do not forget to define a command and at least one fixed part within your mechanism.
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Creating Joints

 

This task shows how to create joints in a V5 mechanism.
You can now create 16 joint types from the following list:

 

●     Revolute  

●     Prismatic

●     Cylindrical 

●     Spherical 

●     Universal 

These joint can now be created using axis systems. See Creating Joints Using Axis Systems

●     Planar 

●     Rigid 

●     Gear 

●     Cable 

●     Rack 

●     Roll Curve 

●     Slide Curve 

●     Point Curve 

●     Point Surface 

●     CV  

●     Screw 

Open the rods+3joints.CATProduct document.
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When you create joints, you can define the mechanism within the same dialog box. Remember though, 
that you create a mechanism independently from the joints by selecting Insert->New Mechanism... 
from the menu bar.

 
1.  Click the Revolute Joint icon from the DMU Kinematics toolbar (Revolute joint is the default joint 

type)

2.  Click the arrow within the icon and undock the  Kinematics Joints toolbar. 

The DMU Kinematics toolbar is displayed:
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3.  Select the joint type of your choice.

4.  For instance click the rigid joint icon .The Joint Creation: Rigid dialog box is displayed.

The term Rigid corresponds to "Fully restricted" in the standard Kinematics 
terminology.

5.  Select the parts either in the geometry area or in the specification tree.
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For more information, please refer to About Joints and Creating Mechanisms and Joints.

 

6.  Click Ok to confirm your operation.

The Rigid Joint is identified in the specification tree.
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Editing Joints

DMU Kinematics Simulator lets you easily edit joints. Editing joints means you can modify: 
●     its name

●     deactivate the command

●     modify its specifications (curve joints specifications: point curve, slide curve, roll curve joints)

either editing the existing geometry joint or replacing the existing geometry with a new one. The V5 joint mechanism is updated accordingly. 

Please refer two the following scenarios:
Replacing Curve Joint Specifications
Editing Curve Joint Specifications  

 

This task shows you how to do so.

Open the  rods+4joints.CATProduct  document. 

 
1.  Double-click the joint to be edited in the specification tree. For instance Revolute.1.The Joint Edition dialog box appears:

2.  In the name field enter a meaningful name: Revolute. 1-3 for instance.

  

3.  Click the Angle driven checkbox to apply an angle driven command

You can check the command positive orientation and invert it if necessary (either during joint or command edition). Note though, for 
Roll curve and Point curve joints you can only check the command orientation but not change it.
 
The command orientation is defined by a green arrow in the geometry area 

❍     The parts which are not involved in the joint creation are displayed in low light (to easily locate the joint you are working on):

❍     Pass the cursor over the green arrow to launch a short animation 

❍     Click the arrow to reverse the command orientation if necessary
 

The positive orientation of a command does not indicate an absolute movement of the parts involved (in the joint which is 
assigned the command) but the intrinsic movement of the second part with respect to the first part involved in the joint.

4.  Set Joints limits if needed. Please refer to Setting Joint Limits and Checking Joint Limits for more detailed information.

5.  Click OK to confirm your operation.

55Page DMU Kinematics Simulator Version 5 Release 13



The Joint is updated and identified in the specification under its new name. The angle command assigned to Revolute.1-3 is also 

identified.

Note: you can edit the mechanism name. All you need to do is right-click the mechanism in the specification tree and select Properties from 
the contextual menu displayed.

 

  

3.  Click the Angle driven checkbox to apply an angle driven command

You can check the command positive orientation and invert it if necessary (either during joint or command edition). Note though, for 
Roll curve and Point curve joints you can only check the command orientation but not change it.
 
The command orientation is defined by a green arrow in the geometry area 

❍     The parts which are not involved in the joint creation are displayed in low light (to easily locate the joint you are working on):

❍     Pass the cursor over the green arrow to launch a short animation 

❍     Click the arrow to reverse the command orientation if necessary
 

The positive orientation of a command does not indicate an absolute movement of the parts involved (in the joint which is 
assigned the command) but the intrinsic movement of the second part with respect to the first part involved in the joint.

4.  Set Joints limits if needed. Please refer to Setting Joint Limits and Checking Joint Limits for more detailed information.

5.  Click OK to confirm your operation.
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Deleting Joints 
Whenever you have to delete joints, you not necessarily have to delete the associated constraints. The Deletion capability lets you 
define what you really want to delete.

This task shows how to delete a joint and what this operation involves.

Open the Jack.CATProduct document.

 
1.  Right-click Prismatic.6 in the specification tree and select the delete item from the contextual menu displayed.

The Delete dialog box appears:

Note: The Delete all children option is set by default

2.  Click  

Additional options and the elements affected by the deletion are displayed. You can delete the constraints associated with the 

joint.

3.  Click the Delete/Undelete All button.
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Keep in mind you can apply the Undo command if you inadvertently deleted a joint

 

4.  Click Ok

5.  Click Yes in the Confirm Deletion dialog box displayed:
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Designing Joints 
 

More about Joints and Constraints
Designing Lower Pair Joints

Creating Joints Using Axis Systems
More About Resulting Constraints

Designing Higher Pair Joints 
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More About Joints and Constraints

DMU Kinematics Simulator lets you define and edit 17 different joint types. 

We can classify these joints under 4 different categories depending on the way they are defined. Of course one specific joint can belong to several 
categories:

●     Joints using assembly constraints (i.e. a revolute joint is defined by two constraints (coincidence between two lines) and an offset between two 
planes

●     Joints using topological or geometrical elements (i.e. a point curve joint is defined by a point and a curve)

●     Compound joints using other joints (i.e. a gear joint is defined with two revolute joints)

●     Joints defined with axis systems (i.e. universal joint)

DMU Kinematics Simulator lets you define the following joints using axis systems ( ):
●     u joint

●     prismatic

●     revolute

●     cylindrical

●     spherical

The table below describes the joint types with respect to the categories  they belong to (the way they are defined)

JOINT TYPE WITH WITHOUT ASSEMBLY CONSTRAINTS

 General case sub-compound 
joints axis systems With Geometry

Revolute X  X  

Prismatic X  X  

Cylindrical X    

Spherical X  X  

Planar X    

Roll Curve    X
Slide Curve    X
Point Curve    X

Point Surface     X

XU Joint   X

Gear joint X X   

Rack Joint X X   

 Cable Joint X X  

Screw Joint X    

CV Joint    X
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Designing Lower Pair Joints 
Creating Revolute Joints
Creating Prismatic Joints
Creating Cylindrical Joints

Creating Planar Joints
Creating Gear Joints
Creating Rack Joints
Creating Cable Joints
Creating Screw Joints

Creating Spherical Joints
Creating Rigid Joints

Creating Universal Joints
Creating CV Joints
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Creating Revolute Joints
(Beginner's Mode)

This task shows how to create revolute joints in a V5 mechanism.

Open the Create_Revolute.CATProduct document.

Automatic switch to Design mode: 

If you work with the cache system in visualization mode, you no longer need to use Edit->Representations->Design Mode 
beforehand as the switch to design mode is automatic (an eye appears as you point the product in the geometry or specification 
tree). All you need to do is click on the object.

You can now use axis systems to create revolute joints. Select the joint from axis icon  from the Kinematic toolbar. Please refer 
to Creating Joints Using Axis

 1.  Click the Revolute Joint icon  from the Kinematic Joints Toolbar. The Joint Creation: Revolute dialog box is displayed

2.  Click New Mechanism.

The Mechanism Creation dialog box is displayed:
Note: this new dialog box lets you enter a meaningful 
name for the mechanism. Click Ok when done

In our example, keep the default name Mechanism.1.
The Mechanism is identified in the specification tree.

 

3.  The Null Offset option is set by default (radio button). Keep it as it is.

Now you need to select two lines and two planes

62Page DMU Kinematics Simulator Version 5 Release 13



Remember you can use the preselection navigator, it can be helpful to select the geometry.Refer to 
Selecting Using the Preselection Navigator in the Infrastructure User's Guide

4.  Select Line 1 in the geometry area. In our example select the hinge axis as shown below:

5.  Select Line 2 in the geometry area. Select the wheel axis:

The dialog box current selection field is automatically updated.

  

6.  Select the planes as shown below:

❍     Plane 1: select the left inner hinge plane

❍     Plane 2: select the left wheel surface

 

 

7.  Assign the Angle driven command if needed.

63Page DMU Kinematics Simulator Version 5 Release 13



8.  Click Ok to end the Revolute Joint creation.The specification tree is updated 

9.  Open the Create_Coincidence_Revolute.CATProduct to check your result.

Please refer to Creating Revolute Joints with Offset (Advanced mode) 
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Creating Prismatic Joints

This task shows how to create prismatic joints in a V5 mechanism.

Open the Prismatic.CATProduct document.

Automatic switch to Design mode: 

If you work with the cache system in visualization mode, you no longer need to use Edit-
>Representations->Design Mode beforehand as the switch to design mode is automatic (an eye 
appears as you point the product in the geometry or specification tree). All you need to do is click on the 
object.

You can now use axis systems to create prismatic joints. Select the joint from axis icon  from the 
Kinematic toolbar. Please refer to Creating Joints Using Axis

 1.  Click the Prismatic Joint icon  from the DMU Kinematics Joints Toolbar or select Insert -> 

New Joint ->Prismatic from the Menu bar.The Joint Creation: Prismatic dialog box appears.

2.  Click New Mechanism.The Mechanism Creation dialog box is displayed: 

Note: this new dialog box lets you enter a meaningful name for the mechanism. Click Ok when 
done.

In our example, keep the default name Mechanism.1.
The Mechanism is identified in the specification tree.
Now you need to select two lines and two planes

3.  Select Line 1 in the geometry area. In our example select an edge (fix.1)

4.  Select Line 2 in the geometry area. Select a second edge (slot.1)
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5.  Select Plane 1 and Plane 2 as shown below:

6.  Click Ok to end the prismatic joint creation.

The prismatic joint is created and identified in the specification tree
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Creating Cylindrical Joints
This task shows how to create cylindrical joints in V5 mechanism.

Open the Create_Cylindrical.CATProduct document.

Automatic switch to Design mode: 

If you work with the cache system in visualization mode, you no longer need to use Edit->Representations->Design Mode beforehand as the 
switch to design mode is automatic (an eye appears as you point the product in the geometry or specification tree). All you need to do is click on 
the object.

You can now use axis systems to create cylindrical joints. Select the joint from axis icon  from the Kinematic toolbar. Please refer to Creating 
Joints Using Axis

 1.  Click the Cylindrical Joint icon  from the Kinematic joints toolbar or select Insert -> New Joint ->Cylindrical from the Menu bar. The 

Joint Creation: Cylindrical dialog box appears

2.  Click New Mechanism.The Mechanism Creation dialog box is displayed: 

In our example, keep the default name Mechanism.1.
The Mechanism is identified in the specification tree.

Now you need to select two lines 

3.  Select Line 1 in the geometry area. In our example select the Cylinder 1 axis 

4.  Select Line 2 in the geometry area. Select the Cylinder 2 axis

5.  Select the Angle Driven and Length Driven check boxes

6.  Click Ok to end the cylindrical joint creation.
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The joint is created and identified in the specification tree

7.  Define a Fixed part, for this click the Fixed Part icon  and select the object (Cylinder 2).The mechanism can be simulated

8.  Open the Create_Cylindrical_Result.CATProduct document to check your result.
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Creating Planar Joints
This task shows how to create planar joints in a V5 mechanism.

Open the Create_Planar.CATProduct document.

Automatic switch to Design mode: 

If you work with the cache system in visualization mode, you no longer need to use Edit->Representations-
>Design Mode beforehand as the switch to design mode is automatic (an eye appears as you point the product in 
the geometry or specification tree). All you need to do is click on the object.

 1.  Click the Planar Joint icon  from the DMU Simulation Toolbar or select Insert -> New Joint ->Planar 

from the Menu bar.The Joint Creation: Planar dialog box appears.

2.  Click New Mechanism.The Mechanism Creation dialog box is displayed: 

In our example, keep the default name Mechanism.1

The Mechanism is identified in the specification tree.
Now you need to select two planes.

3.  Select Plane 1 in the geometry area (plate inner face)

4.  Select Plane 2 in the specification tree (Puck xy plane)
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5.  Click Ok to end the planar joint creation.

The planar joint is created and identified in the specification tree
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Creating Gear Joints
This task shows how to create gear joints in a V5 mechanism.

Open the Create_Gear.CATProduct document.

Automatic switch to Design mode: 

If you work with the cache system in visualization mode, you no longer need to use Edit->Representations->Design 
Mode beforehand as the switch to design mode is automatic (an eye appears as you point the product in the geometry 
or specification tree). All you need to do is click on the object.

1.  Click the Gear Joint icon  from the Kinematic Joints Toolbar or select Insert -> New Joint ->Gear... from 

the Menu bar. The Joint Creation: Gear dialog box appears.

The Mechanism is identified in the specification tree.

Now you need to select two Revolute joints.

2.  Select Revolute.1 either in the specification tree or in the geometry area. 

3.  Create Revolute.2 within the Gear command. For this: click .The Joint Creation: Revolute dialog box 

appears automatically:
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Select line .1 (green cylinder axis) and line.2 (orange cylinder axis) as shown below in  the geometry area:

Select plane.1 (green cylinder face) and plane.2 (orange cylinder face) either in the specification tree or in the 
geometry area:

4.  Check the Offset option and keep the default value. When done, click Ok
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5.  Assign a command, check for instance Angle driven for Revolute1 option. 

About Ratio definition

Two methods are available to define the ratio parameter:

❍     modifying the formula (in this case the ratio is a knowledge parameter)
for this, right-click in the ratio field and use the Edit Formula contextual menu displayed

❍     using the Define option in the joint creation dialog box  to calculate the ratio automatically

6.  Click  to define the ratio parameter automatically. The Gear Ratio Definition dialog box is automatically 

displayed

7.  Select the two circles in the geometry area
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8.  Click Ok when done

The calculated ratio appears in the Joint Creation: Gear dialog box

9.  Change the rotation direction option if needed.

The default is Same (positive)

Opposite is negative

Note: simulate your mechanism with commands to check the direction is the one you want

  

10.  Click Ok when done

Now, if you use the formula editor, (a formula is already defined in our sample), from step 6

Right-click in the ratio field and use the Edit Formula contextual menu displayed

The Formula Editor: Ratio is automatically displayed.
Click Gear1 product in the specification tree and select the radius as shown below:

74Page DMU Kinematics Simulator Version 5 Release 13



The formula is automatically entered in the ratio field, enter a / (division symbol)

Click Gear 2 and select radius.2 as shown below:
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11.  Click Ok when done. The ratio is updated

The gear  joint is created and identified in the specification tree.
Now expand the gear joint you just created, the embedded leaf joints are displayed. 
Note: the joints involved in a compound joint can be neither edited nor deleted directly. 
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12.  Open the GearV5_Result.CATProduct to check your result

Note: To create a gear joint, the two revolute joints involved in the gear joint must rely on a same support 
part.

See picture below: (P stands for Part, R for Revolute) 
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Creating Rack Joints
This task shows how to create rack joints in a V5 mechanism.

Open Create_Rack.CATProduct document.

Automatic switch to Design mode: 

If you work with the cache system in visualization mode, you no longer need to use Edit->Representations->Design 
Mode beforehand as the switch to design mode is automatic (an eye appears as you point the product in the geometry 
or specification tree). All you need to do is click on the object.

1.  Click the Rack Joint icon   from the Kinematic Joints toolbar or select Insert -> New Joint ->Rack... from 

the Menu bar.

The Joint Creation: Rack dialog box appears.
 
The default ratio is 1 turn per mm 

2.  Select Prismatic joint.2 in the specification tree.

If the prismatic and the revolute are not created yet, use the create button. The corresponding joint 
creation dialog box automatically appears. For more detailed information, see Creating Gear joints, 
Creating Prismatic Joints and Creating Revolute Joints

3.  Select Revolute.1  the specification tree 

4.  Assign a command, for instance select Angle driven for Revolute check box
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5.  Click Ok to end the rack joint creation.The rack joint is created and identified in the specification tree.Your 

mechanism can be simulated: a warning message is displayed. 

 Now expand the rack joint you just created, the embedded leaf joints are displayed

Note: the joints involved in a compound joint can be neither edited nor deleted directly.

 

6.  Double-click Mechanism.1 to launch the simulation with commands functionality.

7.  Open the Rack_Result.CATProduct document to check your result

Now let's modify the ratio

8.  Double-click Rack.3 in the specification tree

The Joint Edition dialog box is displayed
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9.  Click the Define button

The Rack Ratio Definition dialog box appears:

10.  Select a circle in the geometry area

The ratio is automatically calculated

11.  Click Ok
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 2.  It is possible to set a negative value for the ratio. For example, if the translation direction is not 
consistent with the rotation direction, change the sign of the ratio .

Notes: 
1.  To create a rack joint,the prismatic and revolute joints involved in the rack joint must rely on a 

same support part.

See picture below: (P stands for Part, R for Revolute, Pris. for Prismatic) 
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Creating Cable Joints
This task shows how to create cable joints in a V5 mechanism.

Open the Create_Cable.CATProduct document.

Automatic switch to design mode: 

If you work with the cache system in visualization mode, you no longer need to use Edit->Representations->Design Mode beforehand 
as the switch to design mode is automatic (an eye appears as you point the product in the geometry or specification tree). All you need to 
do is click.

1.  Click the Cable Joint icon  from the Kinematic Joints Toolbar or 

select Insert -> New Joint ->Cable from the Menu bar.

The Joint Creation: Cable dialog box appears.

Now you need to select two prismatic joints

2.  Select Prismatic Joint 1 and Prismatic Joint 2 in the specification tree

If the prismatic joints are not created yet, use the create button. The Joint creation: Prismatic dialog box automatically 
appears. For more detailed information, see Creating Gear joints and Creating Prismatic Joints

3.  Assign a command, for example select the Length driven for Prismatic 2 check box

4.  Click Ok to end the cable joint creation.

The mechanism can be simulated

The cable joint is created and identified in the specification tree.
Now expand the cable joint you just created, the embedded leaf joints are displayed.
Note: the joints involved in a compound joint can be neither edited nor deleted directly.
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5.  Double-click Mechanism.1 in the specification tree to launch the Simulation with Commands or click the Simulation with Commands 

icon .

6.  Open the Cable_Result.CATProduct document to check your result.

Note: To create a cable joint, the two prismatic joints involved in the cable joint must rely on a same support part.

See picture below: (P stands for Part, Pris. for Prismatic) 
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Creating Screw Joints

 

This task shows how to create Screw joints in a V5 mechanism.

Open the Create_Screw.CATProduct document.

When you create joints, you can define the mechanism within the same dialog box. Remember though, 
that you create a mechanism independently from the joints by selecting Insert->New Mechanism... 
from the menu bar.
Automatic switch to Design mode:

If you work with the cache system in visualization mode, you no longer need to use Edit-
>Representations->Design Mode beforehand as the switch to design mode is automatic (an eye 
appears as you point the product in the geometry or specification tree). All you need to do is click on the 
object.

1.  Click the arrow within the Revolute Joint icon from the DMU Kinematics toolbar (Revolute joint is 

the default joint type)

2.  Undock the  Kinematics Joints  toolbar:

3.  Select the Screw Joint icon . The Joint Creation: Screw Joint dialog box is displayed.

4.  Click on New Mechanism.The Mechanism Creation dialog box is displayed: 

In our example, keep the default name Mechanism.1.
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5.  Select Line 1 either in the geometry area or in the specification tree. In our example, select the 

screw cylinder axis as shown below:

The current selection field is automatically updated.

6.  Select Line 2, the Part2 cylinder axis:

7.  Enter 10 in the pitch field and select the Length Driven check box.

Note: for all joints: the name of parts involved in the joint creation appears in the joint creation 
dialog box 

8.  Click Ok to end the Universal joint creation.

The specification  tree is updated
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9.  Open the Screw_Result.CATProduct to check your result. (In this sample document, we added a 

fixed part which means the mechanism can be simulated) 

 

10.  Double-click Mechanism1 or click the Simulation With Commands icon .

For more information, please refer to About Joints and Creating Mechanisms and Joints.
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Creating Spherical Joints
This task shows how to create spherical joints in a V5 mechanism.

Open the Create_Spherical.CATProduct document.

You can also use axis systems to create spherical joints. Select the joint from axis icon  from the Kinematic toolbar. Please refer to 
Creating Joints Using Axis 

 1.  Click the Spherical Joint icon  from the Kinematic Joints Toolbar or select Insert -> New Joint ->Spherical from the Menu 

bar.The Joint Creation: Spherical dialog box appears.

2.  Click New Mechanism.The Mechanism Creation dialog box is displayed: 

In our example, keep the default name Mechanism.1.

Automatic switch to Design mode: 

If you work with the cache system in visualization mode, you no longer need to use Edit->Representations->Design Mode 
beforehand as the switch to design mode is automatic (an eye appears as you point the product in the geometry or specification 
tree). All you need to do is click on the object.
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5.  Click Ok to end the spherical joint creation.

The spherical joint is created and identified in the specification tree

 

The Mechanism is identified in the specification tree.
Now you need to select two points.

3.  Select Point 1 in the geometry area. In our example select the ball extremity 

4.  Select Point 2 in the geometry area. Select a second point (socket extremity)
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Creating Rigid Joints
This task shows how to create rigid joints in a V5 mechanism.

Open the Create_Rigid.CATProduct document.

Automatic switch to Design mode: 

If you work with the cache system in visualization mode, you no longer need to use Edit->Representations-
>Design Mode beforehand as the switch to design mode is automatic (an eye appears as you point the product 
in the geometry or specification tree). All you need to do is click on the object.

1.  Click the Rigid Joint icon  from the Kinematic Joints Toolbar or select Insert -> New Joint -

>Rigid from the Menu bar. The Joint Creation: Rigid dialog box appears.

2.  Click New Mechanism.The Mechanism Creation dialog box is displayed: 

In our example, keep the default name Mechanism.1

The Mechanism is identified in the specification tree.
Now you need to select two parts.

3.  Select Part 1 either in the specification tree or in the geometry area. In our example, select Plate1.

4.  Select Part 2 either in the specification tree or in the geometry area. Select Plate2.
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The rigid joint is created and identified in the specification tree.

  

5.  Click Ok to end the rigid joint creation.
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Creating Universal Joints

 

This task shows how to create Universal joints in a V5 mechanism.

Open the UJoint_without_joint.CATProduct document.

When you create joints, you can define the mechanism within the same dialog box. Remember though, that you create a mechanism 
independently from the joints by selecting Insert->New Mechanism... from the menu bar.

You can now use axis system to create universal joints. Select the joint from axis icon  from the Kinematic toolbar. Please refer to Creating 
Joints Using Axis

1.  Click the arrow within the Revolute Joint icon from the DMU Kinematics toolbar (Revolute joint is the default joint type)

2.  Undock the Kinematic Joints toolbar:

3.  Select the Universal Joint icon . The Joint Creation: Universal Joint dialog box is displayed.

The cross-pin axis selection has been simplified:
❍     The default direction is Normal to Spin 2 

❍     You can select any direction checking the Any option (step 7) or 

❍     Select Normal to Spin 1

 

4.  Click on New Mechanism.The Mechanism Creation dialog box is displayed: 

In our example, keep the default name Mechanism.1.

5.  Select Spin 1 either in the geometry area or in the specification tree. In our example, select the green cylinder axis as shown below:

The current selection field is automatically updated.

6.  Select Spin 2, for example the blue cylinder axis:
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7.  Select the cross-pin axis direction. Select the Any option. In this case, you need to select the direction of the cross-pin axis (which has 

to be perpendicular with one of the two axis previously selected). In our example, select an edge of the green cylinder.

8.  Click Ok to end the Universal joint creation.

The specification tree is updated

9.  Open the Ujoint_with_joint.CATProduct to check your result.

 

For more information, please refer to About Joints and Creating Mechanisms and Joints.
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Creating CV Joints

 

This task shows how to create Point Surface joints in a V5 mechanism.

Open the Create_CVjoint.CATProduct document.

When you create joints, you can define the mechanism within the same dialog box. Remember though, 
that you create a mechanism independently from the joints by selecting Insert->New Mechanism... 
from the menu bar.

1.  Click the arrow within the Revolute Joint icon from the DMU Kinematics toolbar (Revolute joint is 

the default joint type)

2.  Undock the Kinematic Joints toolbar:

  

3.  Select the CV Joint icon . The Joint Creation: CV Joint dialog box is displayed.

4.  Click on New Mechanism. The Mechanism Creation dialog box is displayed:

In our example, keep the default name Mechanism.1.

 

5.  Select Spin 1 either in the geometry area or in the specification tree. In our example, select the 

blue cylinder axis as shown below:

93Page DMU Kinematics Simulator Version 5 Release 13



 

The current selection field is automatically updated.

6.  Select Spin 2, for example the green cylinder axis:

  

7.  Select Spin 3, the yellow cylinder axis.

  

8.  Click Ok to end the CV joint creation.
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The tree is updated

Note, you need to add a fixed part and to create revolute joints (with at least one command) to 
simulate this mechanism.

9.  Open the CVjoint_Result.CATProduct document to check your result and simulate the mechanism

(double-click mechanism.1 to display the Simulation with command dialog box).

For more information, please refer to About Joints and Creating Mechanisms and Joints.
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Creating Joints Using Axis Systems

This task shows how to create joints using the axis systems

Open the Ujoint_axis_without_kin.CATProduct document.

Automatic switch to Design mode: 

If you work with the cache system in visualization mode, you no longer need to use Edit-
>Representations->Design Mode beforehand as the switch to design mode is automatic 
(an eye appears as you point the product in the geometry or specification tree). All you need 
to do is click on the object.

1.  Click the Joint from axis icon  from the Kinematic Joints toolbar.

The Joint Creation using axis dialog box appears:

2.  Define the joint type you want from the Joint Type drop-down list:

❍     u joint

❍     prismatic

❍     revolute

❍     cylindrical

❍     spherical

In our example we keep the default type: u joint

3.  Click the axis1 selection field and select Ujoint_Cylinder1 Axis System.1 either in the 

geometry or in the specification tree:
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4.  Click the axis2 selection field and select Ujoint_Cylinder2 Axis System.1 either in the 

geometry or in the specification tree

5.  Click Ok to end the u joint creation.
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Constraints are created:
❍     coincidence constraint between the axis systems origins 

❍     angle (perpendicular constraint = 90deg) between:  x axis from first axis system 
and z axis from the second axis system

The interest of this creation mode lies in the ability to keep associativity even if you 
move one part involved in the joint. Before, you could not update the joint.

i.e. If you move a part involved in the u joint, use the update command to make sure 
the u joint remains associative with the parts involved.

6.  Open the Ujoint_axis_with_kin.CATProduct document to check your result

For more detailed information about constraints created using the axis system mode, see More 
About Resulting Constraints

Note that it is impossible to create joints using axis from V4 models.

The u joint is created and identified in the specification tree:
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More about Resulting Constraints

DMU Kinematics Simulator lets you define and edit 17 different joint types.

The table below describes the constraint types created when using the axis mode to create the following joints:

V4 NAME JOINT TYPE  RESULTING CONSTRAINT TYPES

u jnt U Joint 

●     coincidence (between axis systems origins) 

●     angle 90deg 
(x axis1/z axis2)

Notice you can define 
u joints without constraints
(See Creating Universal Joints)

revolute Revolute 

●     coincidence 
(z axis1/z axis2)

●     coincidence
(xy plane1/ xy plane2)

prismatic Prismatic 

●     coincidence
(z axis1/z axis2)

●     coincidence
(yz plane1/yzplane2)

actuator Cylindrical ●     coincidence
(z axis1/z axis2)

pt/pt Spherical ●     coincidence 
(between axis systems origins)

screw Screw Joint
●     coincidence

(z axis1/z axis2)
(+ pitch)
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Designing Higher Pair Joints 
The following list shows these 7 particular joint types which do not associate assembly constraints during creation:

●     Point Curve 

●     Slide Curve 

●     Roll Curve 

●     Point Surface 

●     Universal 

●     CV 

●     Screw 

The conditions under which you can create these joints are the following:

Point Curve and Point surface: the point has to be on the curve.
Slide and Roll curves: the two curves are in contact and tangent in this point.

Note: to create these four kinematics joints, the parts involved in the joint creation must be well positioned.
Please refer to Tips for Curve or Surface Joints Creation 

 Create Point Curve joints: select Insert->New Mechanism... from the menu bar or click the Point Curve Joint icon, then click New 
Mechanism in the dialog box displayed. Select one curve and one point and click Ok.

Create Point Surface joints: select Insert->New Mechanism... from the menu bar or click the Point Surface Joint icon, then click New 
Mechanism in the dialog box displayed. Select one surface and one point, when done click Ok.

Create Roll Curve joints: select Insert->New Mechanism... from the menu bar or click the Roll curve Joint icon, then click New 
Mechanism in the dialog box displayed. Select two curves and click Ok.

Create Slide Curve joints: select Insert->New Mechanism... from the menu bar or click the Slide Curve Joint icon, then click New 
Mechanism in the dialog box displayed. Select two curves and click Ok. 
 

 You can easily modify Curve Joint specifications either editing the existing geometry (positioning or definition) or replacing the 
existing geometry with a new one. The V5 joint mechanism is updated accordingly. 

Please refer the following Chapter:

Editing Joints -Introduction and read the three corresponding step-by-step scenarios
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Creating Point Curve Joints

 

This task shows how to create point curve joints in a V5 mechanism.

Open the Create_PointCurve.CATProduct document.

When you create joints, you can define the mechanism within the same dialog box. Remember though, that you create a mechanism 
independently from the joints by selecting Insert->New Mechanism... from the menu bar.

 
1.  Click the arrow within the Revolute Joint icon from the DMU Kinematics toolbar (Revolute joint is the default joint type

2.  Undock the Kinematic Joints toolbar:

3.  Select the Point Curve Joint icon .The Joint Creation: Point Curve dialog box is displayed.

4.  Click on New Mechanism. The Mechanism Creation dialog box is displayed: 

Note: this dialog box lets you specify a meaningful name for the mechanism. 

 Click Ok when done.

 

 In our example, keep the default name Mechanism.1.

 

5.  Select Curve 1 in the geometry area.The current selection field is automatically updated with your selection

6.  Select Point 1 in the geometry area. In our example, select Point.1 either in the geometry or in the specification tree
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You can check the command orientation defined by a green arrow in the geometry area and in this example (command 
assigned to a revolute) but you cannot change its orientation

❍     The parts which are not involved in the joint creation are displayed in low light (to easily locate the joint you are 
working on)

❍     Pass the cursor over the green arrow to launch a short animation

Let's say you forgot to assign a command, double-click the Point Curve joint in the specification tree: 

The following dialog box appears: check the 'Length Driven' option 

Note: in edition mode you can see the command orientation identified by a green arrow:
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It is impossible to create point curve joints if the parts involving in the joint are not well positioned.
For more detailed information, please refer to Tips for Curve or Surface Joints Creation

If you try inadvertently to change the command orientation on a point curve joint, the following warning message is 
displayed

 

7.  Click Ok to end the point curve joint creation

The specification tree is updated:
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Creating Point Surface Joints

 

This task shows how to create point surface joints in a V5 mechanism.

Open the PointSurface_without_Joint.CATProduct document.

Automatic switch to Design mode:

If you work with the cache system in visualization mode, you no longer need to use Edit-
>Representations->Design Mode beforehand as the switch to design mode is automatic (an eye 
appears as you point the product in the geometry or specification tree). All you need to do is click.
When you create joints, you can define the mechanism within the same dialog box. Remember though, 
that you create a mechanism independently from the joints by selecting Insert->New Mechanism... 
from the menu bar.

 
1.  Click the arrow within the Revolute Joint icon from the DMU Kinematics toolbar (Revolute joint is 

the default joint type).

2.  Undock the  Kinematic Joints toolbar:

3.  Select the Point Surface Joint icon .The Joint Creation: Point Surface dialog box is 

displayed.

4.  Click on New Mechanism. The Mechanism Creation dialog box is displayed: 

In our example, keep the default name Mechanism.1.

5.  Select Surface 1 either in the geometry area or in the specification tree.
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The current selection field box is automatically updated with your selection.

6.  Select Point 1 either in the geometry area or in the specification tree.

7.  Click Ok to end the point surface joint creation.

The specification tree is updated.

8.  Open the PointSurface_with_Joint.CATProduct document to check your result.

It is impossible to create point surface joints if the parts involving the joint are not well positioned.
For more detailed information, please refer to Tips for Curve or Surface Joints Creation

For more information, please refer to About Joints and Creating Mechanisms and Joints.
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Creating Roll Curve Joints

 

This task shows how to create Roll Curve joints in a V5 mechanism.

Open the RollCurve_without_kin.CATProduct document.

When you create joints, you can define the mechanism within the same dialog box. Remember though, that you create a mechanism 
independently from the joints by selecting Insert->New Mechanism... from the menu bar.

 
1.  Click the arrow within the Revolute Joint icon from the DMU Kinematics toolbar (Revolute joint is the default joint type).

2.  Undock the  Kinematic Joints  toolbar:

3.  Select the Roll Curve Joint icon . The Joint Creation: Roll Curve dialog box is displayed.

4.  Click on New mechanism. The Mechanism Creation dialog box is displayed: 

In our example, keep the default name Mechanism.1.

5.  Select Curve 1, in our example, select the inner ring in the geometry area. The current selection field is automatically updated with 

your selection.
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7.  Click Ok to end the roll curve joint creation.

The specification tree is updated.

8.  Now, create Roll Curve. 2. For this select the  Roll Curve Joint icon  again.

The Joint Creation: Roll Curve dialog box is displayed.

9.  Select the outer ring as curve 1 and the roller as curve 2 in the geometry area

  

10.  Click Ok to end the Roll Curve. 2 (roll curve joint) creation.

6.  Select Curve 2, for instance select the roller as shown below:
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The specification tree is updated

11.  Now, create Revolute. 3. For this select the Revolute Joint icon .

The Joint Creation: Revolute dialog box is displayed.

12.  Select the lines and the planes:

 

❍     Inner ring axis for line 1

❍     outer ring axis for line 2

❍     zx plane (inner ring)

❍     zx plane (outer ring)

 

Remember you can use  the preselection navigator, it can be helpful to select the planes.
Refer to Selecting Using the Preselection Navigator in the Infrastructure User's Guide

 

13.  Assign the command, for this select the Angle driven check box
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In Edition mode only: 

you can check the command orientation defined by a green arrow in the geometry area and in this example (command assigned to 
a revolute), you can change its orientation:

❍     The parts which are not involved in the joint creation are displayed in low light (to easily locate the joint you are working on): 
Picture. 1

❍     Pass the cursor over the green arrow to launch a short animation

❍     Click the arrow to change the command orientation if necessary: Picture. 2

 
Picture .1 Picture .2

Now, if you delete the command and assign it to Joint.1 for instance, all you can do is check the orientation, you cannot 
change the command orientation.
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 Pass your cursor over to launch the animation:

 If you try inadvertently to change the command orientation on a roll curve joint, the following warning message is displayed

 

14.  Click Ok to end the revolute joint creation.

The specification tree is updated.

15.  Click the Fixed Part icon  from the Simulation toolbar or select Insert->Fixed Part... from the menu bar. The New Fixed Part 

dialog box is displayed.
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Open the RollCurve_with_kin.CATProduct document to check your result.
It is impossible to create roll curve joints if the parts involving the joint are not well positioned.
For more detailed information, please refer to Tips for Curve or Surface Joints Creation

For more information, please refer to About Joints and Creating Mechanisms and Joints.

 

16.  Select the inner ring as Fixed Part either in the geometry area or in the specification tree.

The specification tree is updated and the mechanism can be simulated.
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Editing Curve Joints- Introduction

About Joint Modification:

It may prove useful to change a mechanism behavior or to improve its design. To do so, you 
need to modify joints specifications. Once you performed your modifications, the parts 
involved in the mechanism need to be reassembled. 

For kinematics joints based on assembly constraints  (i.e. Revolute Joint, Spherical Joint, 

Cylindrical Joint,  Gear Joint, Rack Joint, Cable Joint, Screw Joint, Axis Joint), this capability is 

already available as you can modify the underlying constraints. You can now modify the curve 

joints specifications

Dealing with mechanisms which can be simulated: 

you can edit point curve, roll curve, point surface  or slide curve joints definition, modifying 
their underlying geometric elements (point or curve). There are three procedures to perform 
such a modification:
 

●      you keep the geometric element itself but you change its position. The mechanism can no 
longer be simulated:

❍     click the Update Positions icon . The  parts involved in the joint are reassembled

❍     simulate your mechanism using either the Simulation With laws or Simulation With 
Commands. 
The mechanism is updated

●     you keep the geometric element itself but you change its definition. The mechanism can no 
longer be simulated. 

❍     click the Update Positions icon . The parts are reassembled, the mechanism can 
be simulated

❍     simulate your mechanism using either the Simulation With laws or Simulation With 
Commands. 
The mechanism is updated
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❍     when done click OK.

 

Editing Point Curve Joints (modifying geometry position)
Editing Point Surface Joints (modifying joints definition)

Replacing Slide Curve Joint Specifications

Please refer to Using the Update Command

●     You do not keep the geometric element, you change it by another one, using the joint 
definition command:

❍     double-click the curve joint to be modified. 

❍     in the Edit dialog box displayed, select the curve/point to be replaced. 

❍     then, select a new curve/point in the geometry area and click Apply. 

113Page DMU Kinematics Simulator Version 5 Release 13



Editing Point Curve Joints

(modifying geometry position)

 

This task shows how to edit point curve joints in a V5 mechanism modifying the elements 
involved in the joint position

Open the Edit_PointCurve.CATProduct document.

 

Automatic switch to Design mode:

If you work with the cache system in visualization mode, you no longer need to use Edit-
>Representations->Design Mode beforehand as the switch to design mode is automatic (an 
eye appears as you point the product in the geometry or specification tree). All you need to do 
is click on the object.

 
1.  Check the mechanism can be simulated, for this: click the Simulation With Commands 

icon  from the Simulation toolbar

The Kinematics Simulation dialog box appears:

Note: the state of the dialog box depends on your settings (expanded or collapsed) 
The command of the kinematic mechanism is available as shown below.

2.  Run your simulation using the slider of the command.

3.  Click the  button and when done, click Close.

4.  Modify the geometry position: in our example, you are going to move the curve.Right-

click the 3D compass and select Snap Automatically to Selected Object item from 

the contextual menu displayed:
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5.  Select the curve either in the specification tree or in the geometry area. The 3D 

compass is automatically snapped onto the curve object

6.  Drag the compass as shown below:
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7.  Detach the 3D compass:
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8.  Click the Simulation With Commands again  from the Simulation toolbar. The 

mechanism can no longer be simulated. A warning message can be displayed (it is not 

always the case as sometimes, DMU Kinematics Simulator performs an automatic 

update).

9.  Click Yes. The Mechanism is updated automatically:

❍     the parts involved in the mechanism are reassembled

❍     the mechanism can be simulated

The Kinematic Simulation dialog box appears:

For more information, please refer to About Joints and Creating Mechanisms and Joints.
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Editing Point Surface Joints

(modifying joints definition)

 

This task shows how to edit point surface joints in a V5 mechanism modifying the elements involved in the joint position

Open the PointSurface.CATProduct document.

 

Automatic switch to Design mode:

 
If you work with the cache system in visualization mode, you no longer need to use Edit->Representations->Design 
Mode beforehand as the switch to design mode is automatic (an eye appears as you point the product in the geometry or 
specification tree). All you need to do is click.

 1.  Check the mechanism can be simulated, for this: click the Simulation With Commands icon  from the 

Simulation toolbar. The Kinematics Simulation dialog box appears:

Note: the state of the dialog box depends on your settings (expanded or collapsed) 

 The commands of the kinematics mechanism is available

 

2.  Run your simulation either using the sliders or the manipulators in the geometry area:

3.  Click the  button and when done, click Close.

4.  Modify the geometry: in our example, you are going to modify one line pertaining to the 
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Surface_PointSurface.CATPart 

5.  Click the Swap visible space icon  to display hidden objects

6.  Double-click one curve as shown below:

The Sketcher workbench is automatically displayed

7.  Click the Hide/Show icon  first and then the Swap visible space icon  to display the curve in the show 

space:

  

8.  Modify the curve as shown below in the Sketcher workbench. 
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❍     Click the Exit Workbench icon 

❍     Click the Update icon  if necessary

❍     The surface and pointer are disassembled: the mechanism can no longer be simulated. 
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10.  (Optional) Click the Update positions icon .

Keep in mind that DMU Kinematics Simulator performs an automatic update.

The Mechanism is updated automatically: the parts involved in the mechanism are reassembled

11.  Simulate your mechanism again with the design changes. For this, all you need to do is click the Simulation 

With Commands  from the Simulation toolbar.

12.  Click Close when satisfied.

 

9.  Double-click Product.2 in the specification tree

Your are back in Kinematics Simulator workbench
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Replacing Slide Curve Joints Specifications

Open the Edit_SlideCurve.CATProduct document.

When you create joints, you can define the mechanism within the same dialog box. Remember 
though, that you create a mechanism independently from the joints by selecting Insert->New 
Mechanism... from the menu bar.
Automatic switch to Design mode:

If you work with the cache system in visualization mode, you no longer need to use Edit-
>Representations->Design Mode beforehand as the switch to design mode is automatic (an 
eye appears as you point the product in the geometry or specification tree). All you need to do 
is click.

 
1.  Check the mechanism can be simulated, for this: click the Simulation With Commands 

icon  from the Simulation toolbar

 The Kinematic Simulation dialog box appears:
 

Note: the state of the dialog box depends on your settings (expanded or not)

 The command of the kinematics mechanism is available as shown below. 

 

2.  Run your simulation using the slider of the command.

3.  Click the  button and when done, click Close.

4.  In the specification tree, double-click  the joint to be modified.

In our example, double-click Joint.1

The joint Edition dialog box is displayed:
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5.  In the joint Edition dialog box, select the curve you want to be replaced

The geometry involved in the slide curve joint is low-lighted
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7.  Click Apply to check the new joint.The mechanism parts are automatically reassembled

6.  Select a new curve for your slide curve joint in the geometry area
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For more information, please refer to About Joints and Creating Mechanisms and Joints.

 

  

8.  Click OK to confirm you operation. The mechanism can be simulated, an information 

message is displayed:
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Creating Slide Curve Joints

 

This task shows how to create slide curve joints in a V5 mechanism.

Open the SlideCurve_without_kin.CATProduct document.

When you create joints, you can define the mechanism within the same dialog box. Remember though, that you 
create a mechanism independently from the joints by selecting Insert->New Mechanism... from the menu bar.

 
1.  Click the arrow within the Revolute Joint icon from the DMU Kinematics toolbar (Revolute joint is the 

default joint type).

2.  Undock the Kinematic Joints toolbar.

3.  Select the Slide Curve Joint icon .The Joint Creation: Slide Curve dialog box is displayed

4.  Click on New Mechanism.The Mechanism Creation dialog box is displayed: 

In our example, keep the default name Mechanism.1.

5.  Select Curve 1 either in the geometry area or in the specification tree. In our example, select the yellow 

sphere arc as shown below:

6.  Select Curve 2 either in the geometry area or in the specification tree. In our example, select the line on 

the green part  as shown below:
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7.  Click Ok to end the slide curve joint creation

 Now create a second joint (revolute joint) and a third joint (prismatic joint) 

For more information, please refer to About Joints, Creating Revolute Joints and Creating Prismatic 
Joints.

 

Revolute.2:
❍     select line .1  (right white lines)

❍     select line.2 (left white lines)

 

 

 

❍     select xy plane ( green) (plane 1)

❍     select xy plane  (white lines)  (plane2)

❍     when done click OK

 

 

Prismatic.3
❍     select line.1 

❍     select line.2 as shown below:

 

 

❍     select xy plane (white lines) (plane 1)

❍     select xy plane  (yellow sphere)  (plane2)

❍     when done click OK
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8.  You forgot to assign the Command:

❍     Double-click Revolute. 2 (revolute joint) in the specification tree  

❍     check the Driven Angle option in the Joint Edition : Joint. 2 dialog box displayed

❍     When done, click Ok

This is what you obtain:

9.  Click the Fixed Part icon  from the Simulation toolbar or select Insert->Fixed Part... from the menu 

bar. The New Fixed Part dialog box is displayed.

128Page DMU Kinematics Simulator Version 5 Release 13



The mechanism can be simulated

11.  Double-click Mechanism.1 in the specification tree

The Kinematic Simulation - Mechanism 1 dialog box is automatically displayed.

Note: if there are laws defined in the mechanism, the simulation with laws functionality will be 
launched automatically.

 

  

10.  Select the Fixed Part either in the geometry area or in the specification tree. Here, select the Green 

sphere.The specification tree is updated.
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Open the SlideCurve_ with_kin.CATProduct  to check your result.

It is impossible to create slide curve joints if the parts involving the joint are not well positioned.
For more detailed information, please refer to Tips for Curve or Surface Joints Creation

 

 Manipulate the slider of the command
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Tips for Curve or Surface Joints Creation
It is impossible to create the four new kinematics joints (Point curve , Roll curves, Slide curves, 
Point surface) if the parts involving the joint are not well positioned.

No sample document is provided.

Tips: to position 2 parts involving a Roll Curve joint: create a point and a line tangent to curve 
on this point for each part. In the Assembly Design Workbench, snap the two points and the 
two lines.
in ENOVIA context: If the parts involved in the joint are not well positioned, 
create the mechanism on positioned assemblies.

Remember: to create Roll Curve and Slide curve joints, the two curves must be coincident 
and tangent in one point. 

 

Scenario 1: Create a Roll curve joint

1.  Select the Roll Curve joint icon from the Kinematics Joints toolbar

The Joint creation: Roll curve dialog box is displayed

2.  You cannot select the Curve 2 in the geometry area. It is impossible to create the roll 

curve joint because the parts are not well positioned:
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3.  Click Cancel to exit the Joint creation functionality.

4.  Select Digital Mockup->DMU Navigator from the Start menu.

5.  Reposition the parts using the Snap command. This is what you obtain:

6.  Select the Roll Curve joint icon from the Kinematics Joints toolbar.

The Joint creation: Roll curve dialog box is displayed.This time you can create the roll 
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curve joint: the parts are correctly positioned.

7.  Click Ok to end the joint creation 
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1.  Select the Point Surface joint icon from the Kinematics Joints toolbar

The Joint creation: Point Surface dialog box is displayed:

2.  You cannot select  Point 1 in the geometry area. It is impossible to create the point 

surface joint because the parts are not well positioned:

 
Remember: to create Point surface and Point curve joints, the point must be on the 
curve. 

 

Scenario 2: Create a Point surface joint 
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3.  Click Cancel to exit the Joint creation command

4.  Select Digital Mockup->DMU Navigator from the Start menu

5.  Reposition the parts using the Snap command. This is what you obtain:
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6.  Select the Point surface joint icon from the Kinematics Joints toolbar.

The Joint creation: Point surface dialog box is displayed.This time you can create the 

point surface joint because the parts are correctly positioned.

7.  Click OK to end the joint creation.
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Fixed Parts and Commands

 
Defining a Fixed Part
Defining Commands 
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Defining a Fixed Part

This task will show you how to define a Fixed part.

Open the rods+4joints+cmd.CATProduct document.

1.  Click the Fixed Part icon  from the Simulation toolbar or select Insert->Fixed Part... 

from the menu bar. The New Fixed Part dialog box is displayed.

2.  Select the Fixed Part either in the geometry area or in the specification tree.
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Keep in mind you can apply the Undo command  to modify your selection.

 

3.  The fixed Part is automatically defined. The Fixed part is identified in the specification tree.
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Defining Commands

You can define a command either during joint creation or after joint creation.

This task shows how to define a command on a cylindrical joint during its creation. 

Open the rods+4joints.CATProduct document. You created a mechanism.

 
1.  Double-click Cylindrical. 4 in the specification tree

The joint Edition dialog box is displayed

For more information about commands, see About Joints

2.  Select the Angle driven checkbox.

You can now check the command positive orientation and change it if necessary  (either at joint or command edition) 

Note though, for Roll curve and Point curve joints you can only check the command orientation but not change it.

The command orientation is defined by a green arrow in the geometry area and in this example (command assigned to a cylindrical), you 
can change its orientation:

❍     The parts which are not involved in the joint creation are displayed in low light (to easily locate the joint you are working on): Picture.1

❍     Pass the cursor over the green arrow to launch a short animation Picture.2

❍     Click the arrow to reverse the command orientation if necessary: Picture.3
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Picture.1

 

Picture.2

 

 Picture.3 ->

The positive orientation of a command does not indicate an absolute movement of the parts involved (in the joint on which is assigned 
the command) but the intrinsic movement of the second part with respect to the first part involved in the joint.

3.  Click Ok to confirm your operation.

The command is identified in the specification tree.

You can also create the command while creating a joint.  
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Converting Constraints into Joints 
(Beginner's Mode)

This task shows you how to convert Assembly constraints into V5 joints.

Open the jigsaw_with_constraints.CATProduct document. The constraints are visible both in the geometry area and in the specification tree

If you work with the Cache System, please make sure you are in Design mode (select Edit->Representations->Design Mode.). for more detailed 
information, please refer to the DMU Navigator user's Guide - Task: Viewing the Cache Content

 
1.  Make sure you are in Design Mode (Edit->Representations->Design Mode).

2.  Click the Assembly Constraints conversion icon  from the DMU Kinematics toolbar.The Assembly Constraints Conversion dialog box 

appears:

  

3.  Click on the New mechanism button. When done click OK.

4.  Click on the Auto Create button to launch the operation.

You can see that there are 5 unresolved pairs of products

 

 The constraints are converted into V5 joints. The 5 joints are identified in the specification tree and highlighted in the geometry area
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You need to create the command manually or click the  button and refer to Converting Constraints into Joints (Advanced 
Mode)

5.  Click Ok to confirm your operation.Now, let's create the command

6.  Double-click Revolute. 4  in the specification tree. The Edit Joint Edition dialog box is displayed

7.  Select the 'Angle driven' checkbox and then OK to create the command. The command is created and identified in the specification tree

An information message is displayed, your mechanism can now be simulated

 

8.  Click OK.
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Using the Update Command

This task shows you how to use the Update Positions command  a very powerful tool which lets you keep the Assembly 
workbench and the Kinematics Simulator workbench synchronized. It means the modifications done are taken into account and 
the joints or constraints are respectively updated.
Note the synchronization between Assembly and Kinematics workbenches is relevant and complete only for joints with 
constraints.

Please also  read Replacing Curve Joint Specifications and Editing Curve Joint Specifications 
in the "Designing Higher Pair Joints " section.
A new capability for the Update command is provided: 

It replaces the previous Sub-Mechanism import dialog box. When you need to re-import a mechanism, just click on the "Update 
Positions" icon, then select the imported mechanism you want to re-import as shown below

Note: the behavior of this Update Positions command (described in the step-by-step scenario below) remains the same with 
non-imported mechanisms.  

For more detailed information on how to use the Import and Update commands, read  Visualizing and Simulating in Sub-
products

What is taken into account ?

●     moving parts in the geometry area 

●     deleting or modifying assembly constraints

●     editing curve joints specifications 

Open the rods_with_joints.CATProduct  document.

1.  Move the Rod.2. and Rod.1 for this: 

❍      Point to the compass manipulation handle

❍     Drag and drop the compass onto the rod.4 in the geometry area

❍     Move the rod.2.

  

2.  Reposition the 3D compass as it was.
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3.  Click the Update Positions icon .

The Update Mechanism dialog box is displayed:

The 'Take current positions for rigid joints' option lets you take into account the new position. 

4.  Click Ok to confirm your operation. The mechanism is updated and the part is back to its initial position.

Now, move Rod.2 and Rod.1 in the same way .
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5.  Click the Update positions icon .

6.  Select the Take current positions for rigid joints checkbox.

This is what you obtain:

 
Now simulate the mechanism. Please refer to Simulating With Commands.
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The current position has been kept for Rigid.2 (Rod.4, Rod.1)
Now delete an assembly constraint.  

7.  If you need information about this particular constraint: double-click Coincidence.2 (Rod.3, Rod.4) in the specification 

tree to display the Constraint Definition dialog box.

8.  Right-click Coincidence.2 (Rod.3, Rod.4) in the specification tree. 

9.  Select Delete from the contextual menu displayed.

10.  Click the Update positions icon .

The Update Mechanism dialog box appears. 

  

11.  Click OK.The joints within the mechanism are updated.

Revolute.1 (Rod.3, Rod.4) is converted into a Cylindrical joint (Cylindrical.1) as shown below:
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Moving Constrained Components 
Using the Compass 

This task consists in manipulating the components in a V5 mechanism  to check if the 
components react the way we want.

Open the Jack.CATProduct document.

 
1.  Select the compass manipulation handle and drag it onto CRIC_BRANCH_1. For 

details about how to use the compass, please refer to Infrastructure User's Guide 

Version 5. As the compass is snapped to the component, you can manipulate the 

component.

2.  Now, if you press and hold down the Shift key, select v/z axis on the compass, then 

drag and drop the component up and down, you can see that three components are 

moving. This is an example of what you can get:
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4.  Release the left mouse button before releasing the Shift key.

5.  Drag the compass away from the selected object and drop it.

 

3.  Repeat the operation as many times as you wish. The product reacts correctly. 

CRIC_FRAME does not move because it is fixed. The other three components can 

move.
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Running Simulations 

DMU Kinematics Simulator provides easy methods to run kinematics simulations and detect 
collisions during simulations.
See: Mechanism Analysis in the Advanced Tasks section

Simulating With Laws
Simulating With Commands

Simulating On Request
Leaving Simulation in Modified Position

Simulating After Having Moved Constrained Components

 

By default the new position is kept when exiting the simulation commands.
To restore the initial product position and before leaving the simulation commands 

you need to click:

●       (Simulation With Commands) 

●      (Simulation With Laws)

 

To restore the initial product position when you already quit the simulation commands:

you need to click the Reset Positions icon . 

Please read Resetting a V5 Mechanism

 

 

Manipulator symbols are displayed for either translating or rotating the mechanism whenever 
its joints have associated commands. 

●     For a joint with a linear command, a linear manipulator symbol is displayed. To translate 
the mechanism just drag it using the left mouse button. 

●     For a joint with an angular command, a circular manipulator symbol is displayed. To rotate 
the mechanism just drag it using the left mouse button. 

●     For a joint with linear and angular commands, a linear manipulator symbol is displayed. To 
translate the mechanism just drag it using the left mouse button. 

●     To access the circular manipulator for rotating the mechanism you must use the left and 
middle mouse buttons together and drag as before. 
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Simulating With Laws

This task will show you how to run a kinematics simulation with laws that are already defined on the mechanism.

Open the Jack.CATProduct document

1.  Click the Simulation With Laws icon  in the DMU Kinematics toolbar

2.  Change the range of Kinematics time parameter directly in this dialog box using the Edit Time range button . The Simulation Duration 

dialog box is displayed

Enter a new value, 20 s for instance and click Ok 

this value must be set in seconds and must be higher 
than 10-6 s

The maximum time bound value is automatically updated in 
the dialog box:

3.  Set the desired Number of steps, then run the simulation using the Simulation buttons:
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❍     Start 

❍     Play Back 

❍     Step Back 

❍     Pause 

❍     Step Forward 

❍     Play Forward 

❍     End.

 
The kinematics mechanism moves according to the pre-defined laws. 

You can switch between any of the simulation modes at any time. 
You can also enter a time value to visualize the position of the mechanism at that time.

4.  Click Analysis if you need to detect interferences or distances while simulating (you need to create interference or distance objects first )

The Edit Analysis dialog is displayed.

5.  Select the interference if you defined one and set the combo to on.

For more details, please refer to Detecting Interferences and Detecting Distances.

6.  Run the simulation.

7.  If you check the Activate Sensors option, the Sensors dialog box is automatically displayed.

This functionality lets you retrieve detailed information during simulation operations (With laws and With commands) about:

❍     joint values (with commands or not) 

❍     measure values (see Measure distances and angles between geometrical entities and 
points)

❍     joint limits if previously defined

❍     speed and accelerations

V5 Mechanisms

Note: the Check Limits option is available only in the Sensors dialog box accessed with the 
Activate Sensors check button. Set the required mode (on, stop) using the radio buttons.
For detailed information, read Using Sensors 

V4 Mechanisms

Note: The Check Limits option is still available through the Kinematics simulation commands 
(with laws, with commands). Please read Checking Joint Limits 
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8.  Click Close to confirm your operation

By default the new position is kept when exiting the simulation commands.
Before leaving the simulation command to go back to the initial position: 
you need to click:

❍      (Simulation With Commands) 

❍      (Simulation With Laws)

For more detailed information, see Leaving Simulation in Modified Position and Simulating After Having Moved  Constrained Components 

 

Notice that you cannot record simulations within the Simulation With Laws functionality. If you need to record such a simulation or several 
simulations, please refer to Recording Positions.
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Simulating With Commands

This task will show you how to run a kinematics simulation with commands.

Open the Jack.CATProduct document

In our sample document, there is only one mechanism. If you are working with a product containing more than one mechanism, it is 
strongly recommended to select the mechanism you need before starting the simulation with commands.

1.  Click the Simulation With Commands icon . The KinematicS Simulation dialog box appears:

Note: the state of the dialog box depends on your settings (expanded or not) 

 The command of the kinematics mechanism is available.

2.  Manipulate the slider of the command.

 

 The corresponding part of the kinematics mechanism moves accordingly. 

Note that if you click the  button, the Kinematics Simulation dialog box expands. The immediate option is 
set by default. For more information about the On request option, please refer to  Simulating on Request

 

You can use the slider, enter a value or manipulate the geometry directly to achieve the same result.

3.  If you set joint limits, use the Activate Sensors check button. In the Sensors dialog box, activate the Check limits option and run 
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your simulation again. Notice the information about limits will appear in the comments field from the History tab.

For more information, please refer to Using Sensors

Note: if you are working with a V4 mechanism, the Check Joint Limits button is available in the Kinematics Simulation 
dialog box, read Checking V4 Mechanism Joint Limits and Simulating With Commands

 
You can set a command value directly in the spin box. You can also set lowest and highest values for the range of a 
command by clicking on the button opposite the command and entering values in the displayed pop-up. Click Ok when 
done

 

4.  Click Close to confirm your operation.

By default the new position is kept when exiting the simulation commands (Simulation With Commands and Simulating With 
Laws) 

You need to click :

❍      (Simulation With Commands context)

❍       (Simulation With Laws)

For more detailed information, see Leaving Simulation in Modified Position and Simulating After Having Moved  Constrained 
Components

You cannot record your simulation within the Simulation With Commands command. You can record simulations within the 
Simulation command (please refer to Recording Positions).
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Simulating On Request

 

This task shows how to perform a simulation on request.

Open the Jack.CATProduct document

In our sample document, there is only one mechanism. If you work with a product containing 
more than one mechanism, it is strongly recommended to select the mechanism you need 
before starting the simulation with commands.

 1.  Click the Simulation With Commands icon .The Kinematics Simulation dialog box is 

displayed.

2.  Click .The command of the kinematics mechanism is available as shown 

below.

By default, the Immediate option is set

3.  Activate the On Request option.

4.  Enter a precise value for the command. For instance 20.

5.  Enter the number of steps you need, 20 for example.
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6.  Click Play Forward The corresponding parts of the kinematics mechanism move 

accordingly at each step.

7.  Click Close to confirm your operation

You need to click  before leaving the simulation with commands to go back to 
the initial position. 

By default the new position is kept when exiting the simulation commands 
(Simulation With Commands and Simulating With Laws) 
(keep in mind, in Simulation With Laws you need to click the Start button to jump to 
the initial position)
 
For more detailed information, see Leaving Simulation in Modified Position and 
Simulating After Having Moved  Constrained Components

 

If there are commands, change at least one command value. You can modify the values of one 
or more commands for each motion.
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Leaving Simulation in Modified Position

 

This task shows the impact of leaving simulations in modified position

Open the Jack.CATProduct document

In our sample document, there is only one mechanism. If you work with a product containing more than one mechanism, it is strongly recommended 
to select the mechanism you need before starting the simulation with commands.

 1.  Click the Simulation With Laws icon .The Kinematics Simulation dialog box is displayed.

Run your simulation and stop at 4.75  

2.  Click .Note: the new position is kept. 

3.  Click the Simulation With Commands icon . As you changed the time parameter (used to define the command value) while simulating 

with laws, the command value (47.5000) changed with respect to the law.

4.  Move the slider up to the end.

5.  Exit the Simulation With commands. Click Close.The position is kept as shown below:
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6.  Click the Simulation With Laws icon .There is a  jump to the command value corresponding to the last time parameter which is 4.750

The command value is automatically recalculated with respect to the law and the time parameter

 

  

7.  Run your simulation again

8.  Click Close when satisfied

 

159Page DMU Kinematics Simulator Version 5 Release 13



Moving Constrained Components in Simulation With Commands 
Context

 

This task shows the impact of moving constrained components in simulation with commands context

Open the Jack.CATProduct document

In our sample document, there is only one mechanism. If you work with a product containing more than one mechanism, it is strongly 
recommended to select the mechanism you need before starting the simulation with commands.

 1.  Click the Simulation With Commands icon .The Kinematics Simulation dialog box is displayed.

2.  Run your simulation moving the command slider (i.e. until value 30.0000)

Initial position Position after simulating

3.  Exit the Simulation With Commands command clicking the Close button.

You need to click  before leaving the simulation command to go back to the initial position
By default the new position is kept when exiting the simulation commands (Simulation With Commands and Simulating With Laws)

  

4.  Now, use the compass and the Shift key to move CRIC_BRANCH_1.1. For more detailed information, please refer to Moving Constrained 

Components Using the Compass

5.  Select the compass manipulation handle and drag it onto  CRIC_BRANCH_1.1

Now, if you press and hold down the Shift key, select v/z axis on the compass, then drag and drop the component up and down, you can see 

that three components are moving.This is an example of what you can get:

  

6.  Now, click the Simulation With Commands icon  again. 

 Note: the last command value was: 30.000

 The command value is automatically calculated with respect to this new position.
The command value becomes in our example: -47.8689
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7.  Run your simulation again.

8.  Click Close.
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Advanced Tasks

DMU Kinematics Simulator provides easy methods to detect and analyze collisions and 
distances between products. It also provides the capacity of generating a swept volume.

 

The DMU Space Analysis Version 5 product must be installed before using these functionalities. 

 

Mechanism Design
Mechanism Analysis

Digital Mockup Review
Working with ENOVIA LCA 
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Mechanism Design
Creating Revolute Joints with Offset (Advanced Mode)

Creating Revolute Joints (Centered Option)
Defining Laws in a V5 Mechanism

Converting Constraints into Joints (Advanced Mode)
Trace

Setting Joint Limits 
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Creating Revolute Joints With Offset 
(Advanced Mode)

This task shows how to create offset revolute joints or centered revolute joints

Open the Create_Revolute.CATProduct document.

Automatic switch to Design mode:

If you work with the cache system in visualization mode, you no longer need to use Edit->Representations->Design Mode beforehand as the 
switch to design mode is automatic (an eye appears as you point the product in the geometry or specification tree). All you need to do is click on the 
object.

1.  Click the Revolute Joint icon  from the Kinematic joints toolbar or select Insert -> New Joint ->Revolute from the Menu bar.The 

Joint Creation: Revolute dialog box appears.

2.  Click New Mechanism. The Mechanism Creation dialog box is displayed:

❍     Enter the name of your choice for the mechanism.

❍     Click Ok when done

 

In our example, keep the default name Mechanism.1.

The Mechanism is identified in the specification tree

3.  Select the lines in the geometry area:

❍     Line 1 = hinge axis

❍     Line 2 = wheel axis

4.  Select the planes in the geometry area:
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❍     Plane 1 = left inner hinge plane

❍     Plane 2 = left wheel axis surface

 

5.  Activate the Offset option. 

Select the offset value for this, three methods are available: 

❍     enter the required value in the offset field 

❍     use the scrollbar

❍     right-click the field and select the measure item from the contextual menu displayed

In our example keep the default value.
If you perform a right-click in the offset value field, a contextual menu lets you select between two items: measure or change step

Select the measure item: the Measure Between dialog box and measure Tools toolbar appear
 

Select two entities. Keep this measure as offset value. A warning message lets you copy the measure you defined.

You can also change the step using Change step->new one 

For more information, see Specifying a Parameter Value as a Measure in the Knowledge Advisor User's Guide and Measuring 
Minimum Distances & Angles between Geometrical Entities and Points in the Space Analysis User's Guide 

6.  Assign the Angle driven command if needed.

7.  Click Ok to end the Revolute Joint creation.
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The specification tree is updated.

Open the Create_Revolute_Offset.CATProduct to check your result.
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Creating Revolute Joints 
(Centered Option)

This task shows how to create offset revolute joints or centered revolute joints

Open the Create_Revolute.CATProduct document.

Automatic switch to Design mode:

If you work with the cache system in visualization mode, you no longer need to use Edit->Representations->Design Mode beforehand as the 
switch to design mode is automatic (an eye appears as you point the product in the geometry or specification tree). All you need to do is click on 
the object.

1.  Click the Revolute Joint icon  from the Kinematic joints toolbar or select Insert -> New Joint ->Revolute from the Menu bar. The 

Joint Creation: Revolute dialog box appears:

Note: this dialog box lets you enter the name of your choice for the mechanism and click OK.

2.  Click New Mechanism. The Mechanism Creation dialog box is displayed: 

In our example, keep the default name Mechanism.1.

The Mechanism is identified in the specification tree.

3.  Activate the Centered option. 

4.  Select the lines in the geometry area: 

❍     Line 1 = hinge axis

❍     Line 2 = wheel axis

 

5.  Select the planes in the geometry area:
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❍     Plane 1 = left inner hinge plane

❍     Plane 2 = left wheel axis plane

❍     Plane 3 = right inner hinge plane

❍     Plane 4 = outer wheel plane

 

6.  Assign the Angle driven command if needed.

7.  Click Ok to end the Revolute Joint creation.

The specification tree is updated.

8.  Open the Create_Revolute_Centered.CATProduct to check your result.
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Defining Laws in a V5 Mechanism

This task will show you how to define laws based on Knowledgeware features allowing time-based simulations
Note that in CATIA two formula edition procedures are available: 

●     through  

●     using the Command edition dialog box (see step3-8)

You need a V5 mechanism you can simulate. Please refer to Designing a V5 Mechanism 

Open the DEFNE_LAWS.CATProduct document.

Use the Fit All In icon  to position the model geometry on the screen.

(Optional)
You can display the relations node in the specification tree. 

For this, activate the relations option display:

●     Select Tools->Options from the menu bar.
The Options dialog box is displayed

●     Expand the Infrastructure category from the  tree

●     Select Product Structure item in the tree 

●     Click the Tree Customization tab

●     Activate the Relations option.

1.  Click the Simulation With Laws icon  in the DMU Kinematics toolbar.

The Kinematic Simulation dialog box appears:

You need to define at least one relation between a command and the Time parameter, let's create this relation referred to as law throughout this 
scenario.

2.  Click the Close button to exit the dialog box.

You are going to create a law using the existing command.1 (joint.1,Angle)
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3.  IN CATIA ONLY Click the Formula icon  from the Knowledge Toolbar. The "Formulas" dialog box is displayed.The 'Incremental' box must be 

unchecked.

Select Mechanism.1 in the specification tree to obtain quickly the parameters specific to your Mechanism document.

 

Select Mechanism .1 in the specification tree to obtain quickly the parameters specific to your Mechanism document.

4.  IN ENOVIA DMU  Double-click Command.1 in the specification tree. Right-click Command value field and select the Edit Formula item from the 

contextual menu displayed. The 'Formulas' dialog box is displayed.

The Formula Editor dialog box appears:

5.  Select Time in the Members of Parameters list.
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6.  Double-click Mechanism.1\KINTime in the Members of time list.

7.  Enter /1s*36deg after Mechanism.1\KINTime to complete the formula. 

When done click OK to exit the Formula Editor dialog box. In Enovia

The Formulas dialog box is updated,

8.  Click Ok to end the formula creation.

  

9.  IN ENOVIA DMU: the Command Edition: Command.1 (Angle) is updated:
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The relation is created and identified in the specification tree under: 
❍     Relations item

❍     Laws item

 

The Mechanism can be simulated with laws.

10.  Click the Mechanism Analysis icon  from the DMU Kinematics toolbar.

Click  in the Mechanism Analysis dialog box displayed.

The laws display dialog box appears:

 Open USE_LAWS.CATProduct to see another example in which various laws have been defined.

For more information, see the Knowledge Advisor User's Guide.
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Converting Constraints Into Joints 
(Advanced Mode)

This task shows how to convert constraints into joints in advanced mode

Open the jigsaw_with_constraints.CATProduct document.
The constraints are visible both in the geometry area and in the specification tree.

1.  Click the Assembly Constraints Conversion icon  from the DMU Kinematics toolbar.

The Assembly Constraints Conversion dialog box appears:

2.  Click on the New mechanism button.

3.  Click the   button.

The Assembly Constraints Conversion dialog box expands:
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Let's look at this dialog box more carefully:

: specifies the status of the product pairs

Shows the pair comprising of two products (Bearing.1 and Case.1). You are dealing with 
the first pair (1/5).
The Constraints list displays: 

❍     the name and type of the constraints,

❍     the elements type and detailed information about the first and second element.

The joints and Fix constraints lists display the same kind of information.
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Run the Assembly constraints conversion using one of the VCR buttons: 

❍       : lets you step forward.

❍       : lets you go to next unresolved pair.

❍        : lets you go to the last pair.

 

4.  Click Create Fix to create the fixed part.The fixed part is visible in the Current Fixed Part 

field.

The Fixed part is identified in the specification tree and highlighted in the geometry area.

You are now ready to convert assembly constraints into joints for the first pair of products 
namely  Bearing.1 and Case.1

 

5.  Multi-select Offset.23, Coincidence.21 and Coincidence.22 in the Constraints List (use CRTL 

Key + left mouse button) The Create Joint button is no longer grayed out.

Click  ( the resulting type is specified in the resulting type field).
The Joint list is updated. If you are not satisfied, click the Delete Joint button.
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The Rigid joint is identified in the specification tree and highlighted in the geometry area

6.  Proceed in the same manner to convert the remaining assembly constraints into joints. Use 

Go to Next Unresolved button : 

You converted the constraints but forgot to create a command.  You need to assign the 
command to Revolute.4
Use Step Backward button

7.  All you need to do is double-click Revolute.4 in the Joint list and check the Angle driven 

option in the Edit joint dialog box displayed.

8.  Click Ok in the Joint Edition dialog box.  When done click OK. The following information 

message is displayed:
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9.  Click OK to confirm your operation.

The mechanism can now be simulated.

10.  Click the Simulation with commands icon  from the DMU Kinematics toolbar.

Please refer to Simulating With Commands.

Note that when you have several fix constraints in your assembly, you can create a rigid joint 
between each of them. When this is the case, the following warning is displayed:
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Trace
Using the Trace Command

Generating a Trace from a V5 Mechanism
Generating a Trace from Lines 
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Using the Trace Command
The Trace and Swept volume functionalities are very useful to design respectively the trajectory of a moving point 
or the volume swept by a set of moving products during simulation. The main default of these commands is that 
they accept only a replay object to create the trace or the swept volume. Now these two commands accept also 
mechanisms. The only condition about these mechanisms is that they can be simulated with laws.

Part Design and Generative Shape Design Licenses:

You can use this capability only if you have a Part Design and/or a Generative Shape Design  license

This task explain how to use the trace of a point for design purposes. This is very useful in the design process as 
you can use the resulting trace to design cams.

Open the Create_Trace.CATProduct document.
A simulation is recorded and compiled into a Replay object.

Automatic switch to Design mode: 

If you work with the cache system in visualization mode, you no longer need to use Edit->Representations-
>Design Mode beforehand as the switch to design mode is automatic (an eye appears as you point the product in 
the geometry or specification tree). All you need to do is click on the object.
(for more detailed information, please refer to DMU Navigator User's Guide- Viewing the Cache Content)

1.  Click the Trace icon   from the DMU Generic Animations toolbar.

The Trace dialog box appears:

2.  Select a point to trace either in the geometry area or in the specification tree.
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3.  Click Ok to end the trace creation.

If the Reference product is a not a Part, the trace destination is a New Part document as you 
cannot only write into a part document.

The trace is created in a New Part and looks like this:
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4.  Copy your resulting trace into your initial document, for this use the Copy/Paste capability.

 

5.  The trace is identified both in the specification tree and in the geometry area
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6.  Now, Run the replay step by step. For this: select Replay in the specification tree and double click replay1.

7.  Click the Trace icon   again.

8.  Expand the Slide node and select point 2 in the specification tree as point to trace.

9.  Select Cog-Wheel.1 as Reference product

10.  Select the trace destination (Reference Product) when done, click Ok.

The trace appears in the geometry area in the part select ( Cog-Wheel.1)
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11.  Now, Run the replay step by step. For this: select Replay in the specification tree and double click replay1.
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Generating a Trace from a V5 Mechanism
(which can be simulated with laws)

This task explains how to generate the trace of a point  from a V5 mechanism which can be simulated with laws. 

This is very useful in the design process as you can use the resulting trace to design cams.
Open the Use_Sensors.CATProduct document.

Automatic switch to Design mode:

If you work with the cache system in visualization mode, you no longer need to use Edit->Representations->Design Mode beforehand as the switch 
to design mode is automatic (an eye appears as you point the product in the geometry or specification tree). All you need to do is click on the object.
(for more detailed information, please refer to DMU Navigator User's Guide- Viewing the Cache Content)

1.  Click the Simulation With Laws icon  in the DMU Kinematics toolbar

2.  Run the simulation using the simulation buttons

3.  Click Close when satisfied.

4.  Click the Trace icon   from the DMU Generic Animations toolbar.

The Trace dialog box appears:

About The number of steps:

It is not possible to edit the number of points value directly in the Trace dialog box.
By-pass: click the Simulation With Laws icon and change the number of steps value.

If the number of steps value is 100 for example, the number of points traced will be 101 
because of the original position. Then the Trace dialog box will appear like this : 

 

5.  Select a point to trace either in the geometry area or in the specification tree.
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6.  Select a reference product, click within the field and select Rear_Moving-Arm.1 in the specification tree

7.  Click Ok to end the trace creation.

If the Reference product is a not a Part, the trace destination is a New Part document as 
you cannot only write into a part document.

The trace is created and looks like this:
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Generating a Trace from Lines
The trace command is very useful to build the trajectory of a moving point of a mechanism or a replay. You can now select 
lines and several elements (point and /or lines) at a time to generate a line.

This task explains how to generate the trace of a point  

Open the Use_Laws.CATProduct document.

Note you can only generate a trace from a replay or a mechanism which can be simulated with laws. Remember, a 
mechanism with no laws associated does not appear in the "Object to trace out" field of the Trace dialog box

Automatic switch to Design mode:

If you work with the cache system in visualization mode, you no longer need to use Edit->Representations->Design 
Mode beforehand as the switch to design mode is automatic (an eye appears as you point the product in the geometry or 
specification tree). All you need to do is click.
(for more detailed information, please refer to DMU Navigator User's Guide- Viewing the Cache Content)

1.  Click the Simulation With Laws icon  in the DMU Kinematics toolbar

2.  Change the number of steps value to 120 

3.  Run your simulation if necessary

About The number of steps:

It is not possible to edit the number of points value directly in the Trace dialog box.
By-pass: click the Simulation With Laws icon and change the number of steps value.

If the number of steps value is 100 for example, the number of points traced will be 101 because of the 
original position. Then the Trace dialog box  will take into account the modification: step 4 

4.  Click the Trace icon   in the DMU Generic Animations toolbar.

The Trace dialog box appears: The number of steps is 121 (120 + original position)
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5.  Zoom in, and select a line to trace out as shown below:

Note: You can multi-select elements (lines and/or points). In this case, the number of elements you selected 
appear in the "Elements to trace out" field 

For instance, if you selected three elements  (two lines + a point, see picture below), three traces will be 
created. The traces of the three geometrical elements will be created in separate bodies 

 

 

6.  Click Ok to end the trace creation

If the Reference product is a not a Part, the trace destination is a New Part document as you cannot only write 
into a part document.

The trace is created in a New Part and looks like this:

188Page DMU Kinematics Simulator Version 5 Release 13



7.  Copy your resulting trace into your initial document, for this use the copy/ paste capability.

 

The trace is identified both in the specification tree and in the geometry area
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8.  Click the Simulation With Laws icon  in the DMU Kinematics toolbar

9.  Launch your simulation with laws using the Play forward button .
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Setting Joint Limits

This task consists in setting joint limits. 

Limits for joints which can be assigned commands are always set. Those limits are used in 
kinematics simulation context (please refer to Simulating With Commands)

Open the SETTING_LIMITS.CATProduct document.

1.  Double-click Revolute.3 in the specification tree.

The Joint Edition: Revolute.3 appears:
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Because a command is assigned to Revolute.3, the limits are necessarily set. The 
default values for angle limits are:

❍     Lower limit -360deg

❍     Upper limit  360deg

For length command types limits  the default values are the following (for Prismatic 
joints,..)

❍     Lower limit -100mm

❍     Upper limit 100mm 

Remember you can at any time change the unit using Tools->Options-> 
Parameters and Measures-> Units...

2.  Click Cancel to exit the Joint Edition dialog box.

You are going to set limits on the prismatic joint which has not been assigned any 
command
  

3.  Double-click Prismatic.2 in the specification tree.

The Joint Edition: Prismatic.2 is displayed.

4.  Check the Lower and Upper limit buttons and enter the required values:

❍     -10mm

❍     10mm
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5.  Click Ok to confirm your operation.

You are ready to run a simulation with the limits set.
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Mechanism Analysis

DMU Kinematics Simulator provides easy methods to detect and analyze collisions and 
distances between products. It also provides the capacity of generating a swept volume.

 

The DMU Space Analysis Version 5 product must be installed before using certain 
functionalities such as swept volume.

 

Analyzing a Mechanism
Sensors

Other Analyses
Measures 
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Analyzing a Mechanism
This task shows how to analyze a mechanism using the Mechanism Analysis dialog box

Open the Mechanism_Analysis_01.CATProduct document

1.  Click the Mechanism Analysis icon .

 

The Mechanism Analysis dialog box is displayed. 
It lets you access information about each joint in the kinematics mechanism, you can see which joint is assigned a command for instance. You 
can now save the information displayed in the Mechanism Analysis dialog box using the Save button.

The mechanism components are detailed under the following characteristics:
❍     Command

❍     Type: revolute, prismatic, spherical...

❍     Part1: first part upon which the joint is based.

❍     Geometry: geometry associated to the part

❍     Additional information: if the joint is valid or not

❍     dressup information

 

If you defined a new mechanism, when you delete a part including in the mechanism the corresponding joint is no longer valid. The message 
invalid joint! appears in the Mechanism Analysis dialog box.

 

The degree of freedom is displayed by default. 

But you can still choose to hide the degree of freedom of the mechanism:

❍     Right-click mechanism.1 in the specification tree  and select hide degree of freedom item form the contextual menu displayed:
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2.  Check the Show joints radio button. All joints are visualized in the geometry. (if you select one particular joint, the corresponding joint is visualized)

 

Note, a low-light visualization mode is available. You can better visualize the different components involved in joints. For instance, select Joint.1 
in the list.

 

 The components involved in the Roll Curve joint are highlighted in the specification tree and in the geometry 

3.  Select Joint.3 in the list.

The mechanism dressup information is displayed
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4.  Now click Close

5.  Open the Mechanism_Analysis_02.CATProduct document

6.  Repeat step 1

The Mechanism Analysis dialog box appears:

you can benefit from a feedback about the validity of your joints in Additional information field

In our example, two joints are considered as broken. You will need to redesign them. 

You can now save the information in various formats: .xls, .txt and Lotus 123 (provided that you have it installed on your machine). To do so:

7.  Click Save. The Save As dialog box appears:

 

❍     set the appropriate Save as type using the drop-down list 
(.xls in our example)

❍     identify the folder in which you want to save the file 

❍     enter a file name 

❍     click Save 
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8.  Click Close.

9.  Open the Mechanism_Analysis.xls file you have just created. You should obtain something like this:

 

 

198Page DMU Kinematics Simulator Version 5 Release 13



Sensors
Using Sensors

Creating Y=f(X) combined sensors curves
Measuring Speeds and Accelerations 
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Using Sensors

About sensors:

This functionality enables to visualize all joint values (with commands or not), measures and joint limits if defined throughout the simulation process.
These different values used as sensors provide useful information to check your mechanism design through both kinematics simulation operations 
(i.e. simulation with laws and simulation with commands)
Existing distances and interferences specifications are available in the sensors list. 

Please follow the step-by-step scenario described below:
This task consists in using sensors to check  joint values and measure values during simulation.

Open the Use_Sensors.CATProduct document.

Note: the degree of freedom of the mechanism displayed by default, if you want to hide it all you need to is right-click the mechanism and select 
Hide degree of freedom item from the contextual menu displayed

1.  Click the Simulation With Laws icon  in the DMU Kinematics toolbar.The Kinematic Simulation - Mechanism.1 dialog box is displayed:

2.  Check the Activate Sensors option.The Sensors dialog box is automatically displayed 

This scenario aims at checking your mechanism complies with the bill of material.
The required specifications to be checked in our example are the following:

❍     Table height = 815 mm  (see measure already defined) 

❍     Table path = 200 mm approximately ( 815mm to 1015mm)

❍     Limits are set on prismatic. 13 (lower limit=0, upper limit = 200mm)

❍     There is a law defined corresponding to the jack path 

❍     Minimum distance between the Arm_Joint products and the table + fixation table

In this first try, you are going to check if your Kinematics mechanism is correctly designed using the corresponding sensors during simulation

Besides, we added an interference specification.

 

3.  Select the sensors to be observed:

❍     Prismatic.13\Length (corresponding to the table path)

❍     MeasureBetween. 369\Length (table height)

❍     Prismatic.14\Length (corresponding to the jack path)

❍     Distance Results.1\Minimal Distance

4.  Set the Check Limits option to Stop.
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5.  Select the History tab to visualize the sensors behavior while running your simulation: 

use the Play Forward button 

before after

6.  Check the last values for:

❍     MeasureBetween.369

❍     Prismatic.13

❍     Prismatic.14

❍     Distance Results.1

Notice the sensors values are valid and correspond (approximately) to the specifications
You can re-dimension the jack path to 260mm
The measure is now 1020.136mm.
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 You haven't finished yet as we added an interference specification 

7.  Clear the History using the Clear button

8.  Modify if necessary the Display Options, the default mode is all

9.  Click the Selection tab and select the Interference Results.1\Nbclash sensor 

The interference is selected by default and set to on
Now, click stop 

 

 

What happens when you select a interference sensor?

The following table summarizes the various cases and gives the corresponding clash status:
Detect Clashes

status
Automatic Interferences

OFF

Mode is set to interferences and 
clash detection switches to ON (see 
image below)

Mode remains set to interferences and clash detection 
switches to ON
(see image below)

ON
Mode is set to interferences and 
clash detection remains set to ON 
(see image below)

Mode remains set to interferences and clash detection 
remains set to ON
(see image below)

STOP

Mode is set to Interferences and 
clash detection remains set to STOP 
(see image below)

Mode remains set to interferences and clash detection 
remains set to STOP 
(see imae below)
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Two actions clear the interference sensors selection (i.e. ALL interference sensors selected)

❍     When the Interferences mode is selected with the clash detection set to OFF

❍     When you switch from Interferences to Automatic mode

10.  Click the Analysis button:

❍     select Interference.1 

❍     click Browse to check the interference specification already defined. See Detecting  Clashes if necessary

 

11.  Run your simulation again (click the Start button ). Repeat from step 5

This time, the measure is not valid with respect to the specifications (969.786mm instead of approximately 1015mm)
In the previous try it equals 1020.136mm which is correct

The parts in collision are highlighted in the geometry and in the specification tree
You will need to redesign the Rear_moving_Arm .CATPart.

 

12.  Once satisfied, click the Graphics button in the outputs area to obtain a graphical representation

Note: You can now plot a sensor according to another sensor using the option button.Please read Creating Y=f(X) combined sensors 
curves 

  

13.  Click File to save as a .xls, .txt or Lotus 123 (provided that you have it installed on your machine).

Give a name and a path

14.  Read your document
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Under UNIX, It is impossible to save your results in . xls format.

About interferences

When an interference is defined in your product, and activated as a sensor
The sensor "value" : 

 

represents either:
●     the penetration depth (if there are clashes in the specification results) or

●     the clearance value (if there are only clearances in the specification results)

This sensor "value" is valuated only if you checked the Compute penetration depth option in the During Initial Computation clash command 
setting via Tools->Options->DMU Space Analysis-> DMU Clash tab at interference creation
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About Interferences, Distances and Measures  

●     If you create interferences or distances without exiting the Kinematics simulation commands (either with laws or with commands), these new 
interferences /distances will not be displayed in the sensors list  (this list is frozen when entering the simulation commands).

●     Note that the distances and measures will not be visible in the geometry area until you activate at least one sensor belonging to  these analyses.

  

 

205Page DMU Kinematics Simulator Version 5 Release 13



Creating Y=f(X) combined sensors curves

About sensors:

This functionality enables to visualize all joint values (with commands or not), measures and joint limits if defined throughout the 
simulation process.
These different values used as sensors provide useful information to check your mechanism design through both kinematics 
simulation operations (i.e. simulation with laws and simulation with commands)

Within a simulation with laws, you could only plot sensors with respect a time parameter, now you can plot a sensor with  respect 
to another sensor

This task consists in using sensors to check  joint values and measure values during simulation.

Open the Engine_V4.CATProduct document.

1.  Click the Simulation With Laws icon  in the DMU Kinematics toolbar. The Kinematic Simulation -Mechanism.1 dialog 

box is displayed.

2.  Change the simulation duration, click the Edit Time range button . The Simulation duration is automatically displayed. 

The default duration is 10 s

3.  Enter 20 s in the maximum time bound field

4.  Change the step number to 200

5.  Select the Activate Sensors check box

This scenario aims at checking the motion of the valve with respect to  the crankshaft  

You are going to check if your Kinematics mechanism is correctly designed using the corresponding sensors during 
simulation

6.  Select the sensors to be observed in the Sensors dialog box 
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❍     Prismatic.25 

❍     Revolute.18 

❍     Revolute.5

Launch the Simulation With laws 

7.  Click the History tab to visualize the sensors behavior while running your simulation: 

use the Play Forward button 

8.  Click the Options button .

The Graphical Representation Options dialog box is displayed:

9.  Select the Customized  option button: the Add, Edit and Remove buttons become accessible

10.  Click Add, the Curve Creation dialog box is displayed

11.  In the Abscissa and Ordinate lists, select the required sensors
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12.  Create two customized curves:

❍     curve1: prismatic 25 with respect to Revolute18

❍     curve2: prismatic 25 with respect to Revolute 5

 
(Optional)
Give a meaningful name to your new customized curve.

13.  Click Ok when done.The two curves are created:

  

14.  Click Close.

15.  Click the Graphics button from the outputs to obtain a graphical representation. The curve 1 is displayed
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16.  Click Curve.2 tab:

17.  Click File to save as a .xls or .txt file.

Give a name and a path

Note you can Swap to the default mode (curves plotted with respect to time) at any time
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18.  Click the Options button and select the versus time option button

19.   Click Close

20.  Click again the Graphics button from the outputs to obtain a graphical representation
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Measuring Speeds and Accelerations 

About measuring speed and acceleration:

To qualify a mechanism behavior, or to improve its design, it is required to measure speed and 
accelerations during mechanism operation. Linear Speed and Acceleration calculations are based a point 
with respect to a reference product, whereas Angular Speed and Acceleration are those of the product to 
which the point belongs. 

You can choose the Cartesian System Axis for the result projection using the Other axis option in the 
Speed and Acceleration dialog box

 
This task consists in measuring speeds and accelerations. We want to calculate the reduction ratio of the 
planetary reducer. We need to measure speeds and accelerations on a point belonging to the output axis.

In our example we will define speeds and accelerations: 
●     on a point belonging to the output shaft (Eccentric_Shaft) with respect to the main frame

 

●     on a point belonging to the exit shaft ( Exit_Shaft ) with respect to the main frame
To simplify the results, we assume the shaft has a translation movement, therefore the results will be 
projected onto an axis system belonging to the main frame (z axis is co-linear with respect to the exit 
shaft axis)

Note: this operation can only  be performed on mechanisms which can be simulated with laws.
Open the MeasureSpeedAcceleration.CATProduct document.

1.  Select  the mechanism on which you want to define speeds and acceleration specification

i.e. select Mechanism.1 in the specification tree

 

Note: the degree of freedom of the mechanism displayed by default, if you want to hide it 
all you need to is right-click the mechanism and select Hide degree of freedom item from the 
contextual menu displayed

2.  Click the Speed and Acceleration icon  in the DMU Kinematics toolbars. The Speed and 
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Acceleration dialog box appears

3.  (Optional)

Enter a meaningful name. In our example keep the default name which is: Speed-Acceleration1

4.  Click once in the Point selection field and select a point belonging to the parts involved in the 

mechanisms.

i.e. select  Point.1 under Eccentric_Shaft either in the specification tree or in the geometry area

Note: The speeds and accelerations of this point (sensor) will be calculated with respect to a 
reference product

5.  Click once in the Reference product field and select the reference product of your choice

i.e. select Main_Frame.1 either in the specification or in the geometry area.
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6.  Select an axis system for the projection of the result. In our example, keep the default one which 

is the root product axis system.

7.  Click Ok in the Speed and Acceleration dialog box

The Speed-Acceleration.1 item is identified in the specification tree.

8.  Repeat Step 2.

9.  Click once in the point selection field and select Point.2 under Exit_Shaft either in the specification 

tree or in the geometry area

10.  Click once in the Reference product field and select Main_Frame.1 either in the specification or in 

the geometry area.
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11.  Select a Cartesian axis system for the projection results.

Select the Other axis option, click once in the field and select Axis System.1 under Main_Frame.1. 

12.  Click Ok to create the Speed-Acceleration.2 item

The Speeds and accelerations are identified in the specification tree
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13.  Click the Simulation With Laws icon  in the DMU Kinematics toolbar

14.  Select the Activate Sensors option to display all measures during simulation. 

15.  Select the sensors to be observed:

❍     Speed-Acceleration.1\\X_AngularSpeed

❍     Speed-Acceleration.2\\Z_Point.2 

❍     Speed-Acceleration.2\\Z_LinearSpeed

❍     Speed-Acceleration.2\\LinearSpeed

❍     Speed-Acceleration.2\\Z_Angular Speed

16.  Run your simulation with laws

17.  The Speed and Acceleration result parameters are logged (22 Measures are available, including 

linear and angular speed and acceleration (their projections on the reference axis chosen + their 
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magnitude. Besides, the coordinates of the computation point are available too. 

18.  Click the Graphics button from the outputs area to obtain a graphical representation

  

19.  Click Close.

20.  Open MeasureSpeedAcceleration_Result.CATProduct document to check your results.
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Other Analyses

  

Sensors->Check Limits

Calculating Distances
Detecting Clashes in V4
Detecting Clashes in V5

Detecting Clashes Automatically in V4
Detecting Clashes Automatically in V5

Checking Joint Limits   
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Calculating Distances
This task shows how to calculate distances between two products.

Insert the KIN_EX17* .model files from the samples folder.
The kinematics document must be already opened.
You already defined a simulation. For more information, please refer to Recording Positions.

1.  In the specification tree, click KIN_EX17_06_CENTRAL_DOOR then control-click 

KIN_EX17_09_LEFT_DOOR.

The two items are selected and highlighted in the specification tree.

2.  Click the Distance and Band Analysis icon  in the DMU Space Analysis toolbar, or select 

Insert -> Distance from the menu bar to calculate distances.The Edit Distance And Band 

Analysis dialog box is displayed. 

3.  Ensure that the first Type drop-down list box is set to Minimum and Inside one selection
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The default distance analysis is measuring the minimum distance inside one selection.

4.  Click Apply

5.  Click OK.

The specification tree is updated. 

6.  Double-click  the Simulation.1 in the specification tree. The Edit Simulation dialog box is 

displayed.

7.  Click the Edit Analysis button.
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The Edit Analysis In Simulation dialog box is displayed: 

8.  Click Add then select Distance1 from the displayed pop-up.

The Edit Simulation dialog box is updated.

9.  Set the Distance combo to On in the Edit Simulation dialog box.
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 The specification tree is updated. 

10.  In the Kinematics Simulation dialog box, run a step by step simulation using the Use Laws 

tab.The minimum distance between the two products is displayed at each step.

  

 

Please refer to the DMU Space Analysis User's Guide for more information about detecting and analyzing 
distances between products or between groups.
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Detecting Clashes In V4
This task shows how to detect clashes between two kinematics products.

 Open CLASH_DETECTION.CATProduct document.

1.  In the specification tree, select GARDENAVALVE then control-click GARDENATRIGGER

The two items are highlighted in the specification tree and in the geometry area.

2.  Click the Clash icon  .

The Check Clash dialog box is displayed. Make sure the interference type is set to Contact + Clash and Inside one selection.

3.  Click Apply, when done Ok.

The specification tree is updated. 

4.  Double-click Simulation.1 in the specification tree.

The Edit Simulation and Kinematic Simulation dialog boxes are displayed.

5.  Click Edit Analysis in the Edit Simulation dialog box.

The Edit Analysis in Simulation dialog box is displayed.

6.  Click Add then select interference 1 from the displayed Select dialog box
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 The Edit Analysis in Simulation dialog box is updated:

 

7.  Click OK to confirm your operation.

You defined an interference.

8.  Set the Interference combo to On.

The specification tree is updated. 

9.  To locate the clash position more precisely, set the Interference combo to Stop  in the Edit Simulation dialog box

The simulation stops at the position where a collision is detected between GARDENAVALVE and GARDENATRIGGER products.

The products in collision are highlighted. 
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10.  Click Edit Analysis in the Edit Simulation dialog box. The Edit Analysis in Simulation appears.

11.  Click Browse. 

12.  The Check Clash dialog box is displayed. The specification tree is updated

Please refer to the DMU Space Analysis User's Guide for more information about detecting and analyzing interferences between products or between 
groups.
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Detecting Clashes In V5
This task shows how to detect clashes between two kinematics products.

 Open the DETECT_CLASH_V5.CATProduct document.

1.  Click the Clash icon  .The Check Clash dialog box is displayed. An entry for the interference appears in 

the specification tree.

2.  Keep the default computation type (Contact + Clash) and activate the second Type drop-down list box to 

select between two selections type 

3.  Select the products to check for interference either in the specification tree or in the geometry area: 

❍     Selection1: Front_Moving_Arm.1

❍     Selection2: Arm_Joint.1 and Arm_Joint.2

4.  Click Apply, when done Ok.

The specification tree is updated. 

5.  Click the Simulation With Laws icon  in the DMU Kinematics toolbar.The Kinematic Simulation -

Mechanism.1dialog box is displayed:

6.  Check the Activate Sensors option.The Sensors dialog box is automatically displayed 

7.  Click the Selection tab and select the sensor Interference.1\Nbclash for this:

❍     Select the Interferences option button

❍      Click the Stop button
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8.  (optional) Click the Analysis button in the Kinematic Simulation -Mechanism.1 dialog box

❍     select Interference1

❍     click Browse to check the interference specification
The Edit Analysis appears:

 

The Check Clash dialog box is displayed

9.  Click Ok, when done, click Close in the Edit Analysis dialog box. Back in the Sensors dialog box, click the 

History tab to visualize the sensors behavior while running your simulation:

10.  Launch your simulation with laws using the Play forward button 
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The parts in collision are highlighted in the geometry area and in the specification tree

Please refer to the DMU Space Analysis User's Guide for more information about detecting and analyzing 
interferences between products or between groups.
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Detecting Clashes Automatically in V4

 

This task shows you how to use the Clash Detection functionality while performing a Kinematics simulation.

 

Open AUTO_CLASH_DETECTION.CATProduct document.

 

 

1.  Click the Simulation With Commands icon  from the DMU Kinematics toolbar.

 

The Kinematic Simulation dialog box is displayed. Select GARDENA as mechanism.

2.  Click  to expand the dialog box. 

3.  Activate the On request mode.
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4.  Click the arrow within the Clash Detection icon   from the DMU Generic Animation toolbar.

Undock the toolbar if necessary.

 

5.  Set the Clash detection to on 

6.  Move slider to 116 for command 3 (C3)

7.  Run your simulation

The clash is highlighted in the geometry area

 

  
  

8.  Now set the clash detection on Stop mode .

9.  Run your simulation. This time, the simulation stops at the first clash detected.

 

 

If you need to obtain a finer clash analysis, you need to define a interference, please refer to Detecting Interferences
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Detecting Clashes Automatically in V5

 

This task shows you how to use the Clash Detection functionality while performing a Kinematics 
simulation.

 

Open the DETECT_CLASH_V5.CATProduct document.

 1.  Click the Simulation With Commands icon  in the DMU Kinematics toolbar.

The Kinematics Simulation dialog box is displayed. 

 

2.  Click  to expand the dialog box. 

3.  Activate the On request mode. 

4.  Change the number of steps to 20

5.  Move the slider to the end
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6.  Check the Activate Sensors option 

 

The Sensors dialog box is automatically displayed 

7.  In the Detect Clashes section, Automatic option is set by default.

Set the Clash detection to Stop.

 

8.  Launch your simulation with commands using the Play forward button 

 

The simulation is stopped once a clash is detected
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If you need to obtain a finer clash analysis, you need to define a interference, please refer to Detecting 
Interferences
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Checking Mechanism Joint Limits 
This task consists in checking joint limits during simulation

Open the CHECKING_LIMITS.CATProduct document. Remember you set joint limits in the previous task 

1.  Click the Simulation With commands icon   from the DMU Kinematics toolbar. The Kinematic Simulation -

Mechanism.1 dialog box is displayed:

If you work with V4 kinematics data, the check Joint Limits option is available through the Kinematics 

simulation commands. ( , )
  

2.  Click the Sensors check button.

3.  In the Sensors dialog box displayed set the check limits mode (click the appropriate option button )For instance 

set the stop mode

4.  Select the joints to be observed: Prismatic.2 and Revolute.3 (use the Selection tab and select the joints in the 

sensor list)

 

Remember, you set limits on Prismatic.2 in the previous task: 
❍     Lower limit -10mm

❍     Upper limit  10mm

 
Note: because a command is assigned to Revolute.3, the limits are necessarily set. The default values for 
angle limits are:

❍     Lower limit -360deg

❍     Upper limit  360deg

 The clash detection is available within the Sensors dialog box. 
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5.  Click the History tab

6.  Manipulate the slider of the command or use the manipulator in the geometry area.

 Note: in direct manipulation context (using the manipulators) the simulation is stopped each time a limit is 
reached.

 In both cases (slider manipulation or direct manipulation) the comments column is updated each time a limit is 
reached.

 

235Page DMU Kinematics Simulator Version 5 Release 13



7.  Click Clear if needed

8.  Click Close to exit the command
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Measures

Additional tools: 

Measuring Properties
Measuring Distances between Geometrical Entities 

  

237Page DMU Kinematics Simulator Version 5 Release 13



Measuring Properties 
The Measure Item command lets you measure the properties associated to a selected item (points, edges, surfaces and 
entire products). 

 This section deals with the following topics:

Measuring properties
Measuring in a local axis system

Customizing the display
Editing measures

Create Geometry from measure results
Exact measures on CGRs and in visualization mode

Associative measures
Using measures in knowledgeware

Measure cursors
Insert the following sample model files: ATOMIZER.model, BODY1.model, BODY2.model, LOCK.model, NOZZLE1.model, 
NOZZLE2.model, REGULATION_COMMAND.model, REGULATOR.model, TRIGGER.model and VALVE.model. 

They are to be found in the online documentation filetree in the common functionalities sample folder cfysa/samples.

 

Restriction: Neither Visualization Mode nor cgr files permit selection of individual vertices.

Note: In the No Show space, this command is not accessible.

Measuring Properties

 

This task explains how to measure the properties associated to a selected item.

 

1.Switch to Design Mode (Edit ->Representations ->Design Mode).

2.Set View -> Render Style to Shading with Edges.

Note: You cannot use this command, if Shading only is selected.
3.Click the Measure Item  icon. 

In DMU, you can also select Analyze -> Measure Item from the menu bar.

The Measure Item dialog box appears.
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By default, properties of active products are measured with respect to the product axis system. Properties of active 
parts are measured with respect to the part axis system. 
Note: This distinction is not valid for measures made prior to Version 5 Release 8 Service Pack 1 where all measures 
are made with respect to the absolute axis system. 

Dialog box options

●     You can also measure properties with respect to a local V5 axis system. 

●     The Keep Measure option lets you keep current and subsequent measures as features. This is useful if you want to 
keep measures as annotations for example.

Some measures kept as features are associativeand can be used to valuate parameters or in formulas. 
In the Drafting workbench, measures are done on-the-fly. They are not persistent. This means that they are 
not associative and cannot be used as parameters.

 
 

●     A Create Geometry option in the dialog box lets you create the center of gravity from measure results. 

●     A Customize... option lets you customize the display of measure results.

Accessing other measure commands

●     The Measure Between command is accessible from the Measure Item 
dialog box. Simply click one of the Measure Between icons in the 
Definition box to switch commands. 

●     In DMU, the Measure Thickness command is also accessible from the 
Measure Item dialog box. For more information, see the appropriate 
task in the DMU Space Analysis User's Guide.

P1-Only Functionality

In P1, the Measure Tools toolbar appears. 
This toolbar has two icons:

 

●     Measure Dialogs : lets you show or hide the associated dialog box.

●     Exit Measure : lets you exit the measure. This is useful when the dialog box is hidden.

4.Set the desired measure mode in the Selection 1 mode drop-down list box.
Defining the Selection 1 Mode

●     Any geometry (default mode): measures the properties of the selected item (point, edge, surface or entire 
product).

●     Point only: measures the properties of points. Dynamic highlighting is  limited to points.

●     Edge only: measures the properties of edges. All types of edge are supported.

●     Surface only: measures the properties of surfaces.

In the last three modes, dynamic highlighting is limited to points, edges or surfaces depending on the mode 
selected, and is thus simplified compared to the Any geometry mode.

 
●     Product only: measures distances between products. 

Products can be specified by selecting product geometry, for example an edge or surface, in the geometry area or 
the specification tree.

  
●     Angle by 3 points: measures the angle between two lines themselves defined by three points.
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  To define lines, select three existing points in the geometry area 
or in the specification tree.
Note: You cannot select picking points.
Smart selection is offered. This means that a sphere or circle, for 
example, are seen as points.

The resulting angle is always positive. It is measured in a 
counterclockwise direction and depends on the order in which 
points were selected as well as your viewpoint (the normal to 
the plane is oriented towards you).

  

  
●     Thickness (DMU only): measures the thickness of an item. For more information, see the appropriate task in the 

DMU Space Analysis User's Guide.

●     The Measure Item command lets you access the radius of an exact cylinder or sphere.

●     The Measure Item command also recognizes ellipse-type conic sections. 

●     Using the Other Selection... command in the contextual menu, you can access the axis of a cylinder as well as the 
center of a sphere to, for example, measure between two cylinder axes.

5.Set the desired calculation mode in the Calculation mode drop-down list box.
Defining the Calculation Mode

●     Exact else approximate (default mode): measures access exact data and wherever possible true values are given. 
If exact values cannot be measured, approximate values are given (identified by a ~ sign).

●     Exact: measures access exact data and true values are given. Note that you can only select exact items in the 
geometry area or specification tree.
In certain cases, in particular if products are selected, a warning dialog box informs you that the exact measure 
could not be made. 

●     Approximate: measures are made on tessellated objects and approximate values are given (identified by a ~ 
sign).

Note: You can hide the ~ sign using the Tools -> Options command (General ->Parameters and 
Measure ->Measure Tools).

6.Click to select the desired item.

Note: The appearance of the cursor has changed to assist you. 
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The dialog box gives information about the selected item, in our case a surface and indicates whether the result is an 
exact or approximate value. The surface area is also displayed in the geometry area.
The number of decimal places, the display of trailing zeros and limits for exponential notation is controlled by the Units 
tab in the Options dialog box (Tools-> Options, General-> Parameters and Measure). For more information, see 
the Infrastructure User's Guide.

7.Try selecting other items to measure associated properties.
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8.If necessary, adjust the presentation of the measure:
You can move the lines and text of the measure.

 
The Properties command (Graphics tab) lets you change the fill color and transparency as well as the color, linetype 
and thickness of measure lines. 

Note: You cannot vary transparency properties, the current object is either the selected color or transparent.
9.Click OK when done. 

If you checked the Keep Measure option in the Measure Item dialog box,  
your measures are kept as features and your specification tree will look 
something like this if properties of the active product were measured.

Or like this, if properties were those of the active part. 

Note: If the product is active, any measures made on the active part are 
placed in No Show.

Some measures kept as features are associative. In Design Mode, if you 
modify a part or move a part in a product structure context and the 
measure is impacted, it will be identified as not up-to-date in the 
specification tree. You can then update it locally have it updated 
automatically. 

When measures are used to valuate parameters, an associative link 
between the measure and parameter is created. Measures can also be 
used in formulas.

 
  

Customizing the Display
 Customizing lets you choose the properties you want to see displayed in both the geometry area and the dialog box.

1.Click Customize... in the Measure Item dialog box to see the properties the system can detect for the various types of 
item you can select. By default, you obtain:
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Edges

The system detects whether the edge is a line, curve or arc, taking model accuracy into account and displays the 
properties as set in the Measure Item Customization dialog box.

Note: If the angle of an arc is less than 0.125 degrees, only the arc length is displayed in the geometry 
area. The angle and radius are not displayed.

Surfaces
●     Center of gravity: The center of gravity of surfaces is visualized by a point. In the case of non planar surfaces, 

the center of gravity is attached to the surface over the minimum distance.

●     Plane: gives the equation of a planar face. The equation of a plane is: Ax + By + Cz + D=0.

●     Perimeter: Visualization mode does not permit the measure of surface perimeter.
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2.Set the properties you want the system to detect, then click Apply or Close.
The Measure Item dialog box is updated if you request more properties of the item you have just selected.

3.Select other items to measure associated properties.

 
  

Measuring Properties in a Local Axis System
 An Other Axis option in the dialog box lets you measure properties in a local axis system.

This type of measure is associative: if you move the axis system, the measure is impacted and can be updated.
 You will need a V5 axis system. 

1.Select the Other Axis checkbox in the Measure Item dialog box.

2.Select a V5 axis system in the specification tree or geometry area.
3.Make your measure.

Measure made with respect to local axis system: Same measure made with respect to 
absolute axis system:

Note: All subsequent measures are made with respect to the selected axis system. 
 4.To change the axis system, click the Other Axis field and select another axis system.
 5.To return to the main axis system, click to clear the Other Axis checkbox.
 6.Click OK when done. 

 
  

Editing Measures
 In addition to editing the presentation of the measure, you can also edit the measure itself and change the selection 

on which it was based. This is particularly useful in design mode where you no longer have to redo your measure. 
You can also change selections that no longer exist because they were deleted.

1.Double-click the measure in the specification tree or geometry area.

 2.Make a new selection.

Note:
You cannot change the selection 1 mode. If you selected a curve, you must make a selection of the same 
type, i.e. another curve.

 3.Click OK when done. 
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Measuring Distances between Geometrical Entities 
The Measure Between command lets you measure distance between geometrical entities. You can measure:

●     Minimum distance and, if applicable angles, between points, surfaces, edges, vertices and entire products
Or,

●     Maximum distance between two surfaces, two volumes or a surface and a volume.

 This section deals with the following topics:

Measuring minimum distance and angles
Measuring maximum distance

Measuring distances in a local axis system
Customizing measure between

Editing measures
Creating geometry from measure results

Exact measures on CGRs and in visualization mode
Measuring exact angles
Associative measures

Using measures in knowledgeware
Measure cursors

Insert the following sample model files: ATOMIZER.model, BODY1.model, BODY2.model, LOCK.model, NOZZLE1.model, 
NOZZLE2.model, REGULATION_COMMAND.model, REGULATOR.model, TRIGGER.model and VALVE.model. 

They are to be found in the online documentation filetree in the common functionalities sample folder cfysa/samples.

Restriction: Neither Visualization Mode nor cgr files permit selection of individual vertices.

Note: In the No Show space, the Measure Between command is not accessible.

Measuring Minimum Distance and Angles
 This task explains how to measure minimum and, if applicable, angles between geometrical entities (points, surfaces, 

edges, vertices and entire products).

 

1. Click the Measure Between  icon. 

In DMU, you can also select Analyze-> Measure Between from the menu bar.

The Measure Between dialog box appears.
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By default, minimum distances and if applicable, angles are measured.

By default, measures made on active products are done with respect to the product axis system. Measures made on 
active parts are done with respect to the part axis system. 
Note: This distinction is not valid for measures made prior to Version 5 Release 8 Service Pack 1 where all measures are 
made with respect to the absolute axis system.  

Dialog box options

●     You can also measure distances and angles with respect to a local V5 axis system. 

●     A Keep Measure option in the dialog box lets you keep the current and subsequent measures as features. This is 
useful if you want to keep the measures as annotations for example. 

Some measures kept as features are associativeand can be used to valuate parameters or in formulas.
In the Drafting workbench, measures are done on-the-fly. They are not persistent. This means that they are 
not associative and cannot be used as parameters.

  
●     A Create Geometry option in the dialog box lets you create the points and line corresponding to the minimum distance 

result. 

●     A Customize... option opens the Measure Between Customization dialog box and lets you set the display of measure 
results.

Accessing other measure commands

●     The Measure Item command  is accessible from the Measure Between dialog box. 

●     In DMU, the Measure Thickness command is also accessible from the Measure Between dialog box. For more 
information, see the DMU Space Analysis User's Guide.

 
P1-Only Functionality

In P1, the Measure Tools toolbar appears. 
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This toolbar has two icons:

 

●     Measure Dialogs : lets you show or hide the associated dialog box.

●     Exit Measure : lets you exit the measure. This is useful when the dialog box is hidden.

2. Select the desired measure type.  

Notice that the image in the dialog box changes 
depending on the measure type selected.

 

 

Defining Measure Types

●     Between (default type): measures distance and, if applicable, angle between selected items.

●     Chain: lets you chain measures with the last selected item becoming the first selection in the next measure.

●     Fan: fixes the first selection as the reference so that you always measure from this item.

3. Set the desired mode in the Selection 1 and Selection 2 mode drop-down list boxes.

Defining Selection 1 & Selection 2 Modes

●     Any geometry (default mode): measures distances and, if applicable, angles between defined geometrical entities 
(points, edges, surfaces, etc.). 
Note: The Arc center mode is activated in this selection mode.

This mode recognizes the axis of cylinders and 
lets you measure the distance between two 
cylinder axes for example. 
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●     Any geometry, infinite: measures distances and, if applicable, angles between the infinite geometry (plane, line or 
curve) on which the selected geometrical entities lie. Curves are extended by tangency at curve ends. 

Line Plane Curve

The Arc center mode is activated and this mode also recognizes cylinder axes. For all other selections, the 
measure mode is the same as any geometry.

Any geometry, infinite Any geometry

●     Picking point: measures distances between points selected on defined geometrical entities. Always gives an 
approximate measure.

 In the DMU section viewer, selecting two picking points on a curve gives the distance along the curve between 
points (curve length or CL) as well as the minimum distance between points.

Notes: 

●     Both points must be located on the same curve element.

●     The minimum distance option must be set in the Measure Between Customization dialog box.
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●     Point only: measures distances between points. Dynamic highlighting is limited to points.

●     Edge only, Surface only: measures distances and, if applicable, angles between edges and surfaces respectively. 
Dynamic highlighting is limited to edges or surfaces and is thus simplified compared to the Any geometry mode. All 
types of edge are supported.

 
●     Product only: measures distances between products. 

Products can be specified by selecting product geometry, for example an edge or surface, in the geometry area or the 
specification tree.

●     Picking axis: measures distances and, if applicable, angles between an entity and an infinite line perpendicular to the 
screen.

Simply click to create infinite line perpendicular 
to the screen. 

●     Intersection: measures distances between points of intersection between two lines/curves/edges or a line/curve/edge 
and a surface. In this case, two selections are necessary to define selection 1 and selection 2 items.

 Geometrical entities (planar surfaces, lines and curves) are extended to infinity to determine the point of 
intersection. Curves are extended by tangency at curve ends.

 

Line-plane Curve-plane Curve-curve

 

  Note: Only intersections which result in points of intersection are managed. 
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●     Edge limits: measures distances between endpoints or midpoints of edges. Endpoints only are proposed on curved 
surfaces.

●     Arc center: measures distances between the centers of arcs.

●     Center of 3 points arc: measures distances between the centers of arcs defined by 3 points.

To define arc center, click three points on the 
geometry. 

Note: The resulting measure will always be 
approximate.

●     Coordinate: measures distances between coordinates entered for selection 1 and/or selection 2 items.

4. Set the desired calculation mode in the Calculation mode drop-down list box.

Defining the Calculation Mode

●     Exact else approximate (default mode): measures access exact data and wherever possible true values are given. If 
exact values cannot be measured, approximate values are given (identified by a ~ sign).

●     Exact: measures access exact data and true values are given. Note that you can only select exact items in the 
geometry area or specification tree.
In certain cases, in particular if products are selected, a warning dialog box informs you that the exact measure could 
not be made. 

●     Approximate: measures are made on tessellated objects and approximate values are given (identified by a ~ sign).

Note: You can hide the display of the ~ sign using the Tools -> Options command (General ->  
Parameters and Measure -> Measure Tools).

5. Click to select a surface, edge or vertex, or an entire product (selection 1).

Notes: 
●     The appearance of the cursor has changed to assist you.

●     Dynamic highlighting of geometrical entities helps you locate items to click on.

6. Click to select another surface, edge or vertex, or an entire product (selection 2).

A line representing the minimum distance vector is drawn between the selected items in the geometry area. Appropriate 
distance values are displayed in the dialog box. 
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By default, the overall minimum distance and angle, if any, between the selected items are given in the Measure Between 
dialog box.

The number of decimal places, the display of trailing zeros and limits for exponential notation is controlled by the Units 
tab in the Options dialog box (Tools ->Options, General ->Parameters and Measure). For more information, see the 
Infrastructure User's Guide.

7. Select another selection and, if desired, selection mode.

8. Set the Measure type to Fan to fix the first selection so that you can always measure from this item.

9. Select the second item.

10.Select another item.

Using the Other Selection... command in the contextual menu, you can access the center of spheres.

11.If necessary, adjust the presentation of the measure:

You can move the lines and text of the measure.
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The Properties command (Graphics tab) lets you change the fill color and transparency as well as the color, linetype and 
thickness of measure lines. 

Note: You cannot vary transparency properties, the current object is either the selected color or transparent.

12.Click OK when done. 

If you checked the Keep Measure option in the Measure 
Between dialog box, your measures are kept as features 
and your specification tree will look something like this if 
measures were made on the active product.

Or like this, if measures were made on the active part. 

Note: If the product is active, any measures on parts are 
placed in No Show.

Some measures kept as features are associative. In 
Design Mode, if you modify a part or move a part in a 
product structure context and the measure is impacted, it 
will be identified as not up-to-date in the specification 
tree. You can then update it locally have it updated 
automatically. 

When measures are used to valuate parameters, an 
associative link between the measure and parameter is 
created. Measures can also be used in formulas.

Sectioning measure results

Having made and kept your measure, select it then click the Sectioning  icon to section measure results. The plane is 

created parallel to the direction defined by the measure and sections entities selected for the measure only. All section 
plane manipulations are available.

Note: You may need an appropriate license to access the Sectioning command.

 

 
 

Customizing Measure Between
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Customizing lets you choose what distance you want to 
measure:

●     Minimum distance (and angle if applicable)

●     Maximum distance

●     Maximum distance from 1 to 2.

Note: These options are mutually exclusive. Each time 
you change option, you must make your measure again.

By default, minimum distances and if applicable, angles 
are measured.

You can also choose to display components and the 
coordinates of the two points (point 1 and point 2) 
between which the distance is measured.

What you set in the dialog box determines the display of 
the results in both the geometry area and the dialog box.

 
 

Measuring Maximum Distance
  You can measure the maximum distance between two surfaces, two volumes or a surface and a volume.

Distance is measured normal to the selection and is always approximate.  Two choices are available:

 
●     Maximum distance from 1 to 2: gives the maximum distance of all distances measured from selection 1.

Note: This distance is, in general, not symmetrical.

  

  
●     Maximum distance: gives the highest maximum distance between the maximum distance measured from selection 1 

and the maximum distance measured from selection 2.

  Note: All selection 1 (or 2) normals intersecting selection 1 (or 2) are ignored.
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1. Click Customize... and check the appropriate maximum distance option in the Measure Between Customization dialog box, 
then click OK.

 2. Make your measure:
●     Select the desired measure type

●     Set the desired selection modes

●     Set the desired calculation mode

●     Click to select two surfaces, two volumes or a surface and a volume.

  

 
3. Click OK when done.

 

 
 

Measuring Distances in a Local Axis System
 An Other Axis option in the dialog box lets you measure distance in a local axis system.

This type of measure is associative: if you move the axis system, the measure is impacted and can be updated.

You will need a V5 axis system.

1. Select the Other Axis checkbox in the dialog box.

2. Select a V5 axis system in the specification tree or geometry area.
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3. Make your measure.

In the examples below, the measure is a minimum distance measure and the coordinates of the two points between 
which the distance is measured are shown.

Same measure made with respect to absolute axis system:

Note: All subsequent measures are made with respect to the selected axis system. 

4. To change the axis system, click the Other Axis field and select another axis system.

5. To return to the absolute axis system, click to clear the Other Axis checkbox.

 
6. Click OK when done.

 

 
 

Editing Measures
 In addition to editing the presentation of the measure, you can also edit the measure itself and change one of the 

selections on which it was based. This is particularly useful in design mode where you no longer have to redo your 
measure. 
You can also change selections that no longer exist because they were deleted.

1. Double-click the measure in the specification tree or geometry area.

 2. Make new selections.

Notes:
You can change selection modes when making new selections.
For invalid measures where one selection has been deleted, you only have to replace the deleted selection.
For all other measures, repeat all selections.

256Page DMU Kinematics Simulator Version 5 Release 13



 3. Click OK when done.
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Digital Mockup Review
 

Reviewing Simulations
Managing Kinematics Data in Sub-products

Managing the Mechanism Dressup
Defining a Swept Volume 
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Reviewing Simulations

DMU Kinematics Simulator provides easy methods to record and replay simulations.

 

Recording Positions
Replaying Simulations

Resetting a V5 Mechanism
Sequencing Mechanisms with Laws
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Recording Positions

This task shows how to record positions of a kinematics mechanism.

Insert the KIN_EX17* .model files from the samples folder.
At least one kinematics mechanism must be active in the specification tree.

 1.  Click the Simulation icon .

The Select dialog box is displayed.

 

2.  Select LANDING GEAR and click OK

 

Kinematic Simulation and Edit Simulation dialog boxes appear. A Simulation object is created in the 
specification tree..

Insert means that you record and insert positions inside the scenario.

Note: the starting shot (initial position) is automatically recorded.

3.  Click the Insert button in the Edit Simulation dialog box
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4.  Move the mechanism (using the manipulators or sliders, for example), then Click the Insert switch again.

5.  Record as many positions as necessary.

6.  Use the VCR buttons to replay the recorded positions.

This type of record can be used to simulate several mechanisms simultaneously.
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Replaying Simulations

 

This task shows you how to create a simulation on a geometry of a part.

 

Insert the KIN_EX17* .model files from the samples folder. See Recording Positions.
You then compiled the Simulation created as described in the previous task. Please refer to 
Compiling a Simulation in the DMU Fitting Simulator User's Guide

 

 

1.  Activate the Simulation object in the specification tree.

2.  Click the Replay icon  .

 

The Replay dialog box is displayed.

3.  Specify the desired speed for instance x 5.

4.  Click: 

❍     the Play button to run a continuous replay of the recorded motion

❍     or the Step button to run a step-by-step sequence of the recorded motion.

Each motion is replayed one after the other in the order they were recorded.

You can choose one of the loop modes to re-run the simulation in a continuous 
way (either in the one direction only or in one direction then the other).
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Resetting a V5 Mechanism
This task shows how to use the reset command .When exiting the simulation with laws or with commands in DMU Kinematics, the modified 

position is kept. You can need to swap to the initial product position, all you need to is click on the Reset Positions icon  and select the 
appropriate option.

In addition, when importing a sub-mechanism, a 'local copy' of the sub-mechanism is created, and if you simulate  it, it becomes de-
synchronized with its reference. The reset command allows to re-synchronize an imported mechanism with its reference. You can also apply 
a particular state of an imported mechanism to its reference
Open the Use_Laws.CATProduct document.

1.  Click the simulation with laws  icon.

Note: you can also choose to run a simulation with commands

❍     Initial position when entering the simulation:

 

2.  Run your simulation using the Play Forward button 

3.  Click the pause button.

4.  Select File -> Save... from the File menu

5.  Click Close to exit the Simulation With Laws command. The modified position is kept.
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6.  Click the Simulation With Laws  icon. Run your simulation again using the Play Forward button 

7.  Exit the Simulation With Laws command without clicking the Start button . The modified position is kept by default

8.  Click the Reset Positions icon . The Reset Mechanism dialog box appears:

 

 

New options buttons appear in the Reset Mechanism dialog box:
❍     Reset the selected mechanism to the original state (at product load)

9.  Apply the state of the selected mechanism to its reference mechanism (not available here, this option button is available if 
dealing with imported mechanisms)

The 'Reset the selected mechanism to the state before last simulation' option button is selected by default, keep it as it is.
 

10.  Click Ok. The mechanism goes back to the position it had before its last simulation:
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11.  Repeat step 8. and this time, clear the default option button and select 'Reset the selected mechanism to the original state (at 

product load)' option button. 

 

  

12.  Click Ok. This is what you obtain:

Note: the mechanism position taken into account is the one  it had after the last 
'File-> Open' operation (even if saving operations (File->Save...) have been 
performed in the meantime) ->You saved your file (see step 4) 

 Now you are going to import the mechanism into another document

13.  Using the File->New command, click the New icon   from the Standard toolbar or select the File->New... command. In the 

New dialog box, double-click Product
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An empty document appears.

14.  Arrange your document windows using Window->Tile Vertically command.

15.  Use the Copy/Paste capability to create a new product:

❍     Right-click PRODUCT1 in the left window. Select Copy from the contextual menu displayed.

❍     In the right window, right-click Product2 and select Paste from the contextual menu.

16.  You have two possibilities to import the sub-mechanisms: 

❍     either click the Simulation with laws icon  or

❍     the Import Sub-Mechanisms icon .
In The import is automatically performed
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17.  Click the Use_Laws.CATProduct window (left in our example) and click the Simulation with laws icon  in the DMU Kinematics 

toolbar 

18.  Run your simulation using the Play Forward button 

19.  Click the Pause button at a position of your choice:

20.  Click the Product2 windows and Click the Reset Positions icon .

21.  Select the imported mechanism (Product1.1\Mechanism.1 the only one in our example)

22.  Select the 'Reset the selected mechanism to the state of the reference mechanism' option button
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The imported mechanism is synchronized with its reference mechanism (they share the same position)

23.  Click Ok to exit the Reset Mechanism dialog box

24.  Still in the Product2 windows, click Simulation with laws icon 

❍     simulate the imported mechanism

❍     stop at a given position, for example: 
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25.  Click Close to exit the Simulation With Laws command

26.  Click the Reset Positions icon  again, this time select 'Apply the state of the selected mechanism to its reference mechanism' 

option button and click Ok to confirm your operation

The imported mechanism position (instance) is applied to its reference
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Sequencing Mechanisms with Laws

 

The sequence integration allows to follow on or to play simultaneously several mechanisms (if the mechanisms can be 
simulated with laws). 

Some tools will also be added to help the user. First, the Gant Chart command will allows to see the sequence as a Gant 
Chart. It will be also possible to convert a Simulation object to a Sequence, to convert a Sequence to a Replay or to export 

a Sequence as an AVI File. 

 

This task shows you how to simulate a mechanism with laws within a sequence

 

Open the MECHANISM_SEQUENCE.CATProduct document 

 
1.  Select Use_Sensors.1\Mechanism.1)

2.  Click the Player  icon  from the DMU Player toolbar, undock it if necessary using the arrow in the Player icon

The player is displayed 

3.  Use the Play forward button to simulate your mechanism

4.  Click the Skip to Begin button from the Player

5.  Click the Play Forward button again

6.  Repeat from Step 2 selecting this time, Use_Sensors.2\Mechanism.1

7.  Now you want to sequence the two mechanisms
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Sequencing aims at defining a time frame within which the actions are scheduled. 
Two sequencing modes are available:

❍     actions start together (simultaneous mode)

❍     actions start right one after the other (consecutive mode)

8.  Click the Sequence icon 

The Edit Sequence dialog box is displayed

9.  Select  Use_Sensors.1\Mechanism.1Use_Sensors.2\Mechanism.1 in the action in session list and click . The 

two actions are scheduled in simultaneous mode.

In fact, you want to play the  two mechanisms in consecutive mode (one action starting after the other)

10.  Select Use_Sensors.2\Mechanism.1 in the action in Sequence list and click the Move Down button
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11.  Now run your sequence using the Player still displayed.You are not satisfied with the Time Step: 

Let's customize the Player parameters 

12.  Click the Parameters icon .The Player Parameters dialog box is displayed:

13.  Enter 0.2 s in the Sampling Step field

 

Each motion is replayed one after the other in the order they were scheduled.

You can choose one of the loop modes to re-run the simulation in a continuous way (either in the one direction only or in 
one direction then the other).
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Managing Kinematics Data in Sub-products
Visualizing and Simulating Mechanisms in Sub-products

More about Importing  Mechanisms Dressup
Importing a Mechanism and its Dressup

Importing a Mechanism and its Dressup from a Skeleton Structure
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Visualizing and Simulating Mechanisms in Sub-Products
This task consists in visualizing and simulating mechanism in sub-products through the Import mechanism capability 

Open the SUB_PRODUCT_MECHANISM_LAWS.CATProduct document.

1.  Make sure you are in Design Mode if you work with the Cache System (please refer to DMU Navigator User's Guide- Viewing the 

Cache Content)

If not, select Edit->Representations->Design Mode from the menu bar...

2.  Using the File->New command, click the New icon   from the Standard toolbar or select the File->New... command. In the 

New dialog box, double-click Product.

An empty document appears.

3.  Arrange your document windows using Window->Tile Vertically command.

4.  Use the Copy/Paste capability to create a new product:

❍     right-click SUB_PRODUCT_MECHANISM in the right window. Select Copy from the contextual menu displayed.

❍     in the left window, right-click Product2 and select Paste from the contextual menu.

  

5.  Repeat Step 4.This is what you obtain:

6.  In the left window, use the 3D compass manipulation handle as shown below to obtain two different  products in the geometry 
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area:

For more information, see Moving Objects using the 3D Compass in the Infrastructure User's Guide

 Drag and drop the compass onto the object:

The compass is snapped to the object selected. The compass changes color. Move the compass to separate the two products 
as shown below:

The import command has been improved: the mechanism import is automatically performed at the first simulation 

(with laws or with commands). The Import sub-mechanisms command  is useful only for the first import. It has 
no effect when every mechanism has been imported.

 

7.  You have two possibilities to import the sub-mechanisms: 

❍     either click the Simulation with laws icon 

❍      or the Import Sub-Mechanisms icon .

The import is automatically done.

8.  Click Ok in the warning message displayed
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The sub-mechanisms are imported and identified in the specification tree:

The laws are imported. However, knowledgeware rules are not imported.
You can modify the laws belonging to a sub-mechanism. 

For instance, if you expand the Laws node in SUB_PRODUCT_MECHANISM.1 and  double-click the formula:

❍     In CATIA 

The Formula Editor automatically appears, letting you perform your modifications

❍     In ENOVIA DMU  

Double-click Command.1.1 under Commands item in the specification tree. Click the Formula button  in the Command Edition 
dialog box to display the Formula Editor dialog box
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9.  Select SUB_PRODUCT_MECHANISM (SUB_PRODUCT_MECHANISM.1).

Click the Simulation with laws icon  from the DMU Kinematics toolbar.

Please refer to Simulating With Laws.

You can simulate the sub-mechanism with laws.

10.  Click the Simulation with commands icon  from the DMU Kinematics toolbar.

Please refer to Simulating With Commands.

You can simulate the sub-mechanism.

 

Note that you can only modify sub-mechanism command and laws. For instance, if you double-click Prismatic 2.1 an 
information message automatically appears

 

 

Now, let's modify SUB_PRODUCT_MECHANISM.CATProduct and use the sub-mechanism import  
❍     delete the existing command (Command.1 (Revolute.3, Angle)

❍     assign a length command to Prismatic.2

11.  In the right window (SUB_PRODUCT_MECHANISM.CATProduct), expand the Command item and delete the existing command 

(Command.1 (Revolute.3, Angle)
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12.  Click Ok in the information message

13.  Double-click Prismatic.2 and assign a Length command

  

14.  Click Ok, when done click Ok in the information message displayed

Note this modification results in deleting the existing law in SUB_PRODUCT_MECHANISM.CATProduct  

  

15.  Click in the left window and then click the Update Positions icon .

16.  The Update Mechanism dialog box is displayed:

  

17.  Select the mechanism to be imported using the drop-down list box

18.  Click Ok

The first sub-mechanism is re-imported and updated accordingly (the command is now assigned on the prismatic 2.1 and 
length driven. The second mechanism remains in its initial state (command assigned to Revolute 3.1)
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Note: the update command imports sub-mechanisms one after the other (i.e. only the one selected has been 
imported taking into account the modification), you will need to repeat the operation for the second mechanism
The mechanism is re-imported thus displayed in the specification tree in last position.

19.  Repeat the step 15 if the Update command is no longer active and select the second mechanism to be imported (the first 

mechanism in the drop-down list because of the inversion valid not only in  the specification tree but also in the Update Positions 

dialog box

20.  Click Ok to validate the operation

Both sub-mechanisms are imported
The modification is taken into account (command change) is taken into account in both sub-mechanisms
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More about Importing Mechanisms Dressup
This section provides information about the dressup import.

The Import capability lets you import sub-mechanisms as well as their associated dressups.

 You have two possibilities to import sub-mechanisms: 

1.  either click the Simulation with laws icon .

2.  or the Import Sub-Mechanisms icon .

Please refer to the following scenarios Importing a Mechanism and its Dressup and Importing a 
Mechanism and its Dressup from a Skeleton Structure

 How does it work?

The Import Sub-Mechanisms command scans all the mechanisms existing in the sub-products. if a 

mechanism is detected (i.e. candidate to the import operation), several cases are to be studied:

 

●     There is not any dressup associated to the mechanism. Only the mechanism is imported at the 

root level

 

●     There is a dressup associated to the mechanism at its level and there is not any other dressup 

pointing this mechansim elsewhere. The mechanism and its associated dressup are imported at 

the root level.
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●     There is a dressup associated to the mechanism (not at the same level). Two cases:

1.  The dressup is already positioned at the root level (i.e integrator level). Only the mechanism 
is imported

 
2.  The dressup is not positioned at the root level, nor at the mechanism level. The dressup is 

imported at the root level as well as its associated mechanism.

283Page DMU Kinematics Simulator Version 5 Release 13



 

●     Particular case: the mechanism is assigned two dressups: one dressup at the same level and 
another dressup at another level. During the import operation, this is the highest-level dressup 
which has the priority:
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Importing a Mechanism and its Dressup
This task consists in importing a and simulating mechanism with its associated dressup using the Import capability

Open the IMPORT_MECHANISM_DRESSUP.CATProduct document.

1.  Make sure you are in Design Mode if you work with the Cache System (please refer to DMU Navigator User's Guide- Viewing the Cache 

Content)

If not, select Edit->Representations->Design Mode from the menu bar...

2.  Using the File->New command, click the New icon   from the Standard toolbar or select the File->New... command. In the New dialog 

box, double-click Product.

An empty document appears.

3.  Arrange your document windows using Window->Tile Vertically command.

4.  Use the Copy/Paste capability to create a new product:

❍     right-click  IMPORT_MECHANISM_DRESSUP in the right window. Select Copy from the contextual menu displayed.

❍     in the left window, right-click Product2 and select Paste from the contextual menu.

 

5.  In the Product2 window, import the mechansim and its associated dressup, for this:

You have two possibilities : 

❍     either click the Simulation with laws icon 

❍     or the Import Sub-Mechanisms icon .

6.  Click Ok in the warning message displayed (if you clicked the  Import Sub-Mechanisms icon ).

The import operation is performed: 
The dressup is imported:
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7.  Select IMPORT_MECHANISM_DRESSUP.1\LANDING GEAR_V5(imported),DOF=0

8.  Click the Simulation with commands icon  from the DMU Kinematics toolbar.

Please refer to Simulating With Commands.

You can simulate the imported mechanism.

286Page DMU Kinematics Simulator Version 5 Release 13



Importing a Mechanism and its Dressup from a Skeleton 
Structure 

This task shows you how to import a mechansim and its associated dressup from a skeleton structure 

Skeleton structure:

Consists in defining mechanisms using the skeleton methodology with three product levels:
 

●     an architect level containing a CATProduct document including the master skeleton and its mechanism

●     several designer levels (i.e. CATproducts documents containing the 3D solid geometry)

●     an integrator level (i.e a CATproduct document which federates the architect level the designer levels and the dressup)

Open the Integrator.CATProduct document.

1.  Make sure you are in Design Mode if you work with the Cache System (please refer to DMU Navigator User's Guide- Viewing the 

Cache Content)

If not, select Edit->Representations->Design Mode from the menu bar...

2.  Using the File->New command, click the New icon   from the Standard toolbar or select the File->New... command. In the 

New dialog box, double-click Product.

An empty document appears.

3.  Arrange your document windows using Window->Tile Vertically command.

4.  Use the Copy/Paste capability to create a new product:

❍     right-click Integrator in the right window. Select Copy from the contextual menu displayed.

❍     in the left window, right-click Productn (Product3 in our example) and select Paste from the contextual menu. This is what you 
should obtain:
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5.  Make sure, the Productn (in our example Product3) window is active and click the Import Sub-Mechanisms icon : 

Note you can also click the Simulation with laws icon  to import the mechanism 

6.  Click Ok in the warning message displayed

 

 
The sub-mechanism and its associated dressup are imported and identified in the specification tree:
Please also read More about importing mechanisms dressup

 

 Product3 window Integrator.CATProduct window (Root product)

The icons change for integrator and architect in the specification tree which become flexible products.
For more information, please read Flexible Sub-Assemblies in Assembly User's Guide

7.  Select Dressup1 in the specification tree

Click the Simulation with Commands icon  from the DMU Kinematics toolbar.

Please refer to Simulating With Commands.
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You can simulate the imported dressup
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Managing the Mechanism Dressup
In the perspective of Kinematics integration in ENOVIA VPM  (based on a skeleton methodology) (a document will be available in a forthcoming 
release)  the dressup is directly accessible from the specification tree, you can simulate it and it can be saved in ENOVIA VPM

This task shows how to dress-up mechanisms. 

Open the MANAGING_DRESSUP.CATProduct document.
At least one kinematics mechanism must be active in the specification tree.

If you work with V4 data, you no longer need to select Edit->Representations->Design Mode as it is automatically activated. DMU Kinematics 
Simulator finds the product containing kinematics objects automatically. This capacity is available for all Kinematics commands (simulation...)

1.  Click the Mechanism Analysis icon .

The Mechanism Analysis dialog box appears:

290Page DMU Kinematics Simulator Version 5 Release 13



2.  Click on the Simulation With Commands icon .

The Kinematic Simulation dialog box is displayed.
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3.  Manipulate the slider of the LEFT command.

The corresponding part of the kinematics mechanism namely the Opening moves accordingly.

4.  Click  and then 

Let's attach the left door to the LANDING GEAR mechanism:

5.  Click the Mechanism Dress-up icon  in the DMU Simulation Toolbar.

The Mechanism Dress-up dialog box is displayed.

6.  Select  LEFT DOOR as link

Note you can select the link directly in the geometry area or in the specification tree, using the the graphic selection option. Though, only 
one selection is allowed.

 

 Note that you can select or deselect attachments directly from the specification tree or geometry area.
 You can select either the available products or all products. By default the Available products option is set.

 ❍     Available products: if set, this option lets you visualize the products that are not referenced in any attachment  within the 
mechanism.

❍     All Products: if set, this option lets you visualize the products that are not attached to the current link (here, LEFT DOOR)

7.  By default the Available products option is set:

The two products in the left column have not been attached yet.
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8.  If you set the All products option this is what you obtain

Now, select  The KIN_EX17_09_DOOR from the available products list to attach it to the link:

The  selected product is highlighted in the specification tree and in the geometry area as shown below:

9.  Click OK to confirm your operation.

Let's simulate the mechanism with the new dressup
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10.  Click on the Simulation With Commands icon  again.

11.  In the Kinematic Simulation dialog box, manipulate the slider of the LEFT command. 

This time, the corresponding part of the kinematics mechanism moves accordingly. 

The Simulation With Commands capability is only used to simulate. If you need to record positions use the (Fitting) Simulation functionality.

 

294Page DMU Kinematics Simulator Version 5 Release 13



Defining Swept Volume

Defining a Swept Volume
Defining a Swept Volume from a Mechanism

Defining a Swept Volume from a Moving Reference
Filtering Swept volume Positions

More About Swept Volume 
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Defining A Swept Volume
This task shows how to generate a Swept volume. 

You recorded a simulation in a Simulation object and compiled the Simulation. You obtained a Replay object.
Open the KIN_SWEPT_VOL.CATProduct document.

Remember, you can generate a swept volume directly from a V5 mechanism which can be simulated with laws.

1.  Click the Swept Volume icon .

The Swept Volume dialog box is displayed.

 

 Wrapping, simplification, silhouette and spatial split options are available within the swept volume dialog box if you 
have a DMU Optimizer license:

 

Note:the Filter Positions option is checked by default

2.  Click in the Product to sweep spin box, the selection list dialog box lets you select or deselect the bodies you want to sweep.

3.  Select KIN_EX17_03_ENS3.1

4.  Click OK.
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5.  Click Preview.The progress bar is displayed letting you monitor and, if necessary, interrupt  (Cancel option) the calculation.

  

6.  If you check the Use level of details option, this what you obtain:

7.  Click Save. 

The Save As dialog box appears

you can save your result in various formats, for example in CATIA model file
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About Save button in swept volume dialog box:

Clicking Save keeps the command active and lets you therefore launch the calculation again if 
needed. When satisfied, click Save in the Save As dialog box

8.  Select cgr file and click Save.

9.  Click Close

10.  Insert the SWEPTVOLUME_absoluteresult.cgr into Product1, for this right-click Product1 and select Components-> Existing 

component from the contextual menu displayed. 

The Swept volume is identified in the specification tree and in the geometry area
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Defining a Swept Volume From a Mechanism

(which can be simulated with laws)

 

The Swept volume functionality is very useful to design the volume swept by a set of moving products 
during simulation. Now, this functionality takes into accounts mechanisms. 

The only condition about these mechanisms is that they can be simulated with laws.
This task shows how to generate a Swept volume from a mechanism 

Open the Use_Sensors.CATProduct document.

1.  Click the Swept Volume icon .

The Swept Volume dialog box is displayed.

Note:the Filter Positions option is checked by default

 

 Please also read About the number of steps in Generating a Trace from a V5 Mechanism...

2.  Click in the Product to sweep spin box, the selection list dialog box lets you select or deselect the 

bodies you want to sweep.

3.  Select Jack_Rod.1
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4.  Click Ok

5.  Click Preview to generate the swept volume 

 The progress bar is displayed letting you monitor and, if necessary, interrupt  (Cancel option) the 
calculation.

 

 This is what you obtain:

 

6.  Click Save.

The Save As dialog box appears:  
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7.  Select cgr file and click Save

8.  Click Close

9.  Insert the SWEPTVOLUME_result.cgr into Use_Sensors, for this right-click Use_Sensors and select 

Components-> Existing component from the contextual menu displayed. The Swept volume is 

identified in the specification tree and in the geometry area
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Defining a Swept Volume from a Moving Reference
This task shows how to define a swept volume using a moving reference. See the previous task. In our example 
you need to obtain a finer result to analyze clashes, if any.

Open the KIN_SWEPT_VOL.CATProduct document.

1.  Click the Swept Volume icon .

The Swept Volume dialog box is displayed.

  

2.  Uncheck the Filter Positions option as shown below: (the Filter Positions option is checked by default)

3.  Click in the Products to sweep spin box, the Product Multiselection dialog box lets you select or deselect 

the bodies you want to sweep.

4.  Select KIN_EX17_03_ENS3.1 from the list.

5.  Click Ok.

6.  Click in the Reference Product spin box.

7.  Select KIN_EX17_01_ENS1.1
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8.  Click Preview to generate the swept volume.

The Computation is in progress.The progress bar is displayed letting you monitor and, if necessary, 

interrupt  (Cancel option) the calculation.

The Preview window is displayed
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9.  Click Save.The Save As dialog box appears automatically

10.  Select cgr file from the Save as type drop-down list and click Save.hj,jn
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11.  Insert the SWEPTVOLUME_relativeresult.cgr into KIN_EX17_01_ENS1, for this right-click  and select 

Components->Existing Component from the contextual menu displayed.The Swept volume is identified 

in the specification tree and in the geometry area.
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Filtering Swept Volume Positions 
This task shows how to filter swept volume positions. It can be very useful in terms of calculation 
performances to retrieve positions in a swept volume.  Please refer to Defining a Swept Volume

You recorded a simulation in a Simulation object and compiled the Simulation. You obtained a Replay object. 
You need this Replay object to define a swept volume.
Open the Open the KIN_SWEPT_VOL.CATProduct document.

1.  Click the Swept Volume icon .

The Swept Volume dialog box is displayed.

  

2.  Click in the Products to sweep spin box, the selection list dialog box lets you select or deselect the 

bodies you want to sweep.

3.  Select KIN_EX17_03_ENS3.1

  

4.  Click OK.

5.  Enter 20mm as filtering precision value
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6.  Click Preview to generate the swept volume.The progress bar is displayed letting you monitor and, if 

necessary, interrupt (Cancel option) the calculation.

This what you obtain:
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7.  Click Save if you are satisfied or launch the calculation again with new values. The Save As dialog box 

appears automatically:
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8.  Select cgr format and click Save

9.  Click Close

10.  Insert the SWEPTVOLUME_filterresult.cgr into Product1, for this right-click Product1 and select 

Components->Existing Component from the contextual menu displayed.

The Swept volume is identified in the specification tree and in the geometry area

Please refer to the DMU Optimizer User's Guide for more information
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More About Swept Volume

About Filter positions option:

This option can be used to simplify the swept volume computation when the replay object contains many positions or when you know what 
precision level you need to obtain.
The "filter precision" defines the maximum distance allowed between the simplified trajectory and the initial one (= discretization precision)

 1- Filtering swept volume positions

The following example aims at illustrating the impact of the filter positions option on the final result

Case 1: the Filter positions option is not checked:

Case 2: the Filter positions option is checked 
Filtering precision = 5mm
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Case 3: the Filter positions option is checked 
Filtering precision = 10mm

 

 

 

2- Relative swept volume 
About Relative swept volume:

You can compute the swept volume of a moving part in the system axis of another moving part.
You can use this option when you need to analyze the swept volume of a product versus another product (moving or not)

Example: two moving parts: circle and square
With the basic computation of the swept volumes, the clash analysis is not relevant: 

the swept volumes clash but two objects may not be in the same clash area at the same time.
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If you use the relative swept volume option and select the circle as the reference product, you can compute the square swept volume in the 
circle system axis.

The result can now be relevant for clash analysis.
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Working with ENOVIA LCA: Optimal PLM Usability for 
DMU Kinematics Simulator

When working with ENOVIA LCA, the Optimal PLM Usability for DMU Kinematics Simulator ensures that you only create and 
modify data in CATIA that can be correctly saved in ENOVIA LCA.

ENOVIA LCA offers two different storage modes Workpackage (Document kept - Publications Exposed) and Explode 
(Document not kept- Structure Exposed). 
 

 In Kinematics Simulator workbench, it is impossible to create and save Kinematics data in explode mode (structure exposed) 
in ENOVIA LCA. The Optimal PLM Usability for DMU Kinematics Simulator means that when working in explode mode 
(structure exposed) all the Kinematics commands are unavailable (i.e grayed). 

On the contrary, when working in publication exposed mode (i.e the document you are working on is defined as a 
workpackage), all the Kinematics commands become available, you can therefore:

●     Create,

●     Modify and,

●     Save your data in ENOVIA LCA provided that your workpackage is based on the root product (i.e. without context, please 
refer to Scenario 3).

The three following scenarios aim at explaining the various cases, when working in workpackage mode-publication exposed:
 

Scenario 1

Scenario 2

Scenario 3
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(1) In context: the tree of the selected object is displayed within the appropriate context i.e. with all its parents as far as the 
PRC.

(2) Without context: the tree of the selected object appears out of context.
For example, if you select a CATProduct instantiated on a PRC, the CATProduct opens without the PRC and the associated 
instances. For more detailed information, please refer to VPM Navigator User Guide and ENOVIA LCA User guides

Recommended Methodology

The recommended methodology for working with ENOVIA LCA is:
 

●     Send your ENOVIA document to CATIA

●     work on your design in CATIA, whether from scratch or modifying an existing design.

●     Save your CATIA data in ENOVIA.
 

To ensure seamless integration, you must have both a CATIA and ENOVIA session running

1.  In the Product Structure workbench of CATIA V5, click the Init Enovia V5 Connection icon  to establish the 

connection between CATIA V5 and ENOVIA LCA

2.  In ENOVIA LCA, send your ENOVIA document to CATIA.

❍     If your document is structure exposed (explode mode), all the Kinematics commands are grayed.

❍     If your document is in publication exposed (defined as a workpackage), all the Kinematics commands are 
available, go to the next step 

3.  Work on your design in your CATIA V5 application (Kinematics Simulator)

4.  In the Product Structure workbench of CATIA V5, click the Save Data in ENOVIA V5 Server... icon  to save 

your data in ENOVIA LCA database.

The save in ENOVIA dialog box appears showing objects to be saved and set to the correct save mode and save 
options. 

The dialog box below shows Kinematics Simulator objects.

5.  Simply click OK in the dialog box.
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Workbench Description
This section contains the description of the icons and menus which are specific to the DMU Kinematics Simulator Version 
5 workbench.

The DMU Kinematic Simulator  window looks like this (click the sensitive areas to see the related documentation):

 

Menu Bar
DMU Kinematics Toolbar

Simulation Toolbar
DMU Joint Toolbar

DMU Generic Animation Toolbar
DMU Kinematic Update

Automatic Clash Detection Toolbar
DMU Space Analysis Toolbar

Specification Tree 
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DMU Kinematics Simulator Menu Bar
Here we will present the various menus and menu commands that are specific to DMU Kinematics Simulator Version 5. 

Start File Edit View Insert Tools Analyze Windows Help

 

 Tasks corresponding to General menu commands are described in the DMU Version 5 Infrastructure User's Guide.

Edit 

For... Description... 

Undo Cancels the last action.

Redo Recovers the last action that was undone.

Cut
Copy
Paste
Paste Special

Performs cut
copy
paste and
special paste operations.

Delete Deletes selected geometry.

Search Allows searching and selecting objects.

Links Manages links to other documents.

Properties Allows displaying and editing object properties.

Insert 
 

For... See... 

New Mechanism Creating a Mechanism and 
Revolute Joints
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New Joint

Creating a Mechanism and 
Revolute Joints

About Joints

Designing Joints With Assembly 
Constraints 

Designing Joints Without 
Assembly Constraints

Fixed Part Defining a Fixed Part

Simulation Recording Positions

Clash Detecting Interferences 

Distance Detecting Distances

Existing Component Entering the DMU Navigator 
Workbench and Selecting Models 

Tools
 

For... See... 

Generate Video DMU Fitting documentation

Generate Replay
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For... See... 

new Gantt Chart 
Window

Displaying Gantt Chart in DMU Fitting User's Guide

Camera Window 

 

 

See Using Camera Capabilities in DMU Navigator User's Guide

 

Window
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DMU Kinematics Toolbar

The DMU Kinematics toolbar contains a number of tools that are useful for DMU Kinematics 
Simulator.

 

 

See Simulating with Commands

See Managing the Mechanism Dressup

See Creating a Fixed Part 

See Creating a Mechanism and Revolute Joints
See Creating Revolute Joints 
See Creating Revolute With Offset
See Creating Revolute Joints With Centered Option

See DMU  Kinematic Joints toolbar

 

See Converting Constraints into Joints
See Converting Constraints into Joints ( Advanced Mode)

See: Measuring Speed and Acceleration

See Analyzing a Mechanism
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Simulation Toolbar
 

 

See Simulating with Commands
See Detecting Clashes Automatically

See Setting Joint Limits 
See Checking Joint Limits

See: Using Sensors

See Simulating With Laws
See Defining Laws in a V5 Mechanism
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Kinematic Joints Toolbar

The Kinematic Joint toolbar contains the various types of joints you can create in Kinematic 
Simulation version 5.

 

 See About Joints 

See Creating Revolute Joints 
See Creating Revolute With Offset
See Creating Revolute Joints With Centered Option

See Creating Prismatic Joints

See Creating Cylindrical Joints

See Creating Spherical Joints

See Creating Planar Joints

See Creating Rigid Joints

See Creating Point Curve Joints

See Creating Slide Curve Joints

See Creating Roll Curve Joints

See Creating Point Surface Joints

See Creating Universal Joints

See Creating Gear Joints

See Creating Screw Joints

See Creating Cable Joints

See Creating Rack Joints

See Creating CV Joints

 
See Creating Joints Using Axis Systems

See More About Resulting Constraints
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DMU Generic Animation Toolbar

 
 

 

 

 
See Recording Simulations 

See Replaying Simulations 

See Detecting Clashes Automatically

See Defining a Swept Volume
See Defining a Swept Volume from a Moving Reference
See Filtering Swept Volume Positions

See Using the Trace Command
See Generating a Trace from a V5 Mechansim

322Page DMU Kinematics Simulator Version 5 Release 13



DMU Kinematic Update
 

 

 
See Using the Update Command

See Visualizing and Simulating Mechanisms in Sub-products

See Resetting a V5 Mechanism
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Automatic Clash Detection Toolbar

 

    

 
  

See Detecting Clashes Automatically
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DMU Space Analysis Toolbar

 

 

See Detecting Distances .

See Detecting Interferences .
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Specification Tree

 Within DMU Kinematics Simulator workbench, you can generate a certain number of features (specific to DMU Kinematics 
Simulator application or not specific). They are  identified in the specification tree as icons under the Application node. The 
following image is not exhaustive but gives you an idea of what you can obtain:
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Icons displayed in the specification tree and specific to the DMU Kinematics workbench identify:
 

mechanisms

Fixed part

command

speeds and accelerations

dressup

revolute joint

prismatic joint

cylindrical joint

screw joint

spherical joint

planar joint

rigid joint

point curve

slide curve

roll curve joint

point surface joint

U joint

CV joint

gear joint

rack joint

cable joint

joint using axis system

  

 

Other icons (which are not specific to DMU Kinematics):
 

Distance and band analysis entries

Measures made using the Measure Between command 

Clash entries

For more information about icons specific to DMU Space Analysis workbench please refer to Specification Tree 
section in the DMU Space Analysis User's Guide

simulation entries ('Fitting' simulation)

Replay entries

sequence entries

 Laws
  
  

 

For standard specification tree symbols, see Specification Tree Symbols in the Product Structure User's Guide.
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 Other icons (which are not specific to DMU Kinematics):

Distance and band analysis entries

Measures made using the Measure Between command 

Clash entries

For more information about icons specific to DMU Space Analysis workbench please refer to Specification Tree 
section in the DMU Space Analysis User's Guide

simulation entries ('Fitting' simulation)

Replay entries

sequence entries

 Laws
  

 
For standard specification tree symbols, see Specification Tree Symbols in the Product Structure User's Guide.
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Glossary

               

 

C 

cable joint A cable type joint between three products (two products are mobile, the 
other is a reference). Number of degrees of freedom is 1 (translation).

cylindrical joint A translation type joint between two products along an axis with a rotation 
about that axis. Number of degrees of freedom is 2 (1 translation and 1 
rotation). This joint was called Actuator in Version 4.

command An angular or linear command that drives the kinematics mechanism. 
CV joint A constant velocity joint between two products. Number of degrees of 

freedom is 4 (comprises two U joints).

D 

degrees of freedom The number of possible independent rotation or translation movements of 
a joint. 

dress up A list of models attached to a set of the kinematics model. These models 
have the same motion as the set. 

F 
fixed product The product that remains stationary when the kinematics mechanism is in 

motion.

G 
gear joint A gear type joint between three products (two products are pinions, the 

other is a reference). Number of degrees of freedom is 1 (rotation).

J 

joint A constraint between geometric entities of two or three products. There are 
several types of joint.

joint stop An imposed limit applied to a joint. 

K 
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kinematics mechanism A mechanism comprising several products that are connected by joints. 

It can be simulated when the number of commands is equal to degrees of 
freedom (in this case the mechanism is said to be complete).

kinematics product A rigid product defined in a single geometric set that contains all the 
elements required to describe the kinematics mechanism and its motion. 

kinematics simulation A simulation of the mechanism's motion using commands. Simulation can 
be immediate (commands are used one by one) or on request (one or 
more commands are used with a given number of steps). 

L 
law A numeric or graphic representation of the commands applied to a 

kinematics mechanism as a function of time.

P 
planar joint A planar joint between two products. Number of degrees of freedom is 3 (1 

rotation and 2 translations).
prismatic joint A translation joint between tow products along an axis with no rotation 

about that axis. Number of degrees of freedom is 1 (translation).

PT/CRV joint A point/curve joint between two products. Number of degrees of freedom 
is 4 (3 rotation and 1 translation) for a 3D mechanism and 2 (1 rotation 
and 1 translation) for a 2D mechanism.

PT/SUR joint A point/surface joint between two products. Number of degrees of freedom 
is 5 (3 rotations and 2 translations).

R 

rack joint A gear/rack type joint between three products (one product is the rack, 
another is the rack, the other is a reference). Number of degrees of 
freedom is 1 (combined translation and rotation).

revolute joint A revolute joint about an axis between two products with no translation 
along that axis. Number of degrees of freedom is 1 (rotation).

rigid joint A rigid (fully restricted) joint between two products. There are no degrees 
of freedom associated to this joint.

roll/CRV joint A rolling type joint between two products that include curves. There is no 
sliding motion with this type of joint. Number of degrees of freedom is 2 (1 
rotation and 1 translation) for a 3D mechanism and 1 (translation) for a 2D 
mechanism.

S 
screw joint A screw/nut type joint between two products relative to an axis. Number of 

degrees of freedom is 1 (combined translation and rotation).
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slid/CRV joint A rolling type joint with a sliding motion between two products that include 
curves. Number of degrees of freedom is 3 (2 rotations and 1 translation) 
for a 3D mechanism and 2 (1 rotation and 1 translation) for a 2D 
mechanism.

spherical joint A spherical joint between two products. Number of degrees of freedom is 3 
(3 rotations) for a 3D mechanism and 1 (rotation) for a 2D mechanism. 
This joint was called PT/PT in Version 4.

storyboard A recorded kinematic motion.

U 

U joint A universal joint between two products. Number of degrees of freedom is 2 
(2 rotations).
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Index 

                  

A
analyzing 

mechanism  

B
browsing 

mechanism  

C
cable joints, creating  
calculating 

distances  
checking 

joint Limits  

clashes, detecting (automatically) in V4  

clashes, detecting automatically in V5  
command 

3D Compass  

Assembly Constraints Conversion  

Cable Joint  

Command  

Cylindrical Joint  

Distance and Band Analysis  

Dressup  

Fixed Part  

Gear Joint  
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Import Sub-mechanisms  

Joints From Axis  

Measure Between  

Measure Item  

Planar Joint  

Point Curve Joint  

Point Surface Joint  

Prismatic Joint  

Rack Joint  

Reset  

Revolute Joint  

Rigid Joint  

Roll Curve Joint  

Screw Joint  

Sensors (see kinematic simulations with laws and with commands)  

Sequence  

Simulation (Fitting)  

Simulation With Commands  

Simulation With Laws  

Slide Curve Joint  

Speeds and Accelerations  

Spherical Joint  

Swept Volume  

Trace  

Universal Joint  

Update (Kinematics)  

command, defining  

constrained components, manipulating  

constraints, converting  
converting 

constraints into joints (advanced Mode)  

constraints into joints (beginner's mode)  
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V4 kinematic data into DMU kinematic V5  
creating 

cable joints  

cylindrical joints  

gear joints  

joints  

joints using axis systems  

mechanism and revolute Joints  

planar joints  

point curve joints  

point surface joints  

prismatic joints  

rack joints  

revolute joints  

revolute joints (centered option)  

revolute joints (with offset)  

rigid joints  

roll curve joints  

screw joints  

slide curve joints  

spherical joints  

universal joints  

Y=f(X) combined sensors curves  

curve joints, editing   

cylindrical joints, creating  

D
defining 

command  

fixed Part  
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laws in a V5 Mechanism  

swept volume   

swept volume (from a mechanism)  

swept volume from a moving reference  

degree of freedom  
designing 

higher pair joints  

lower pair joints  

V5 mechanism  
detecting 

clashes (automatically) in V4  

clashes (automatically) in V5  

clashes in V4  

clashes in V5  

distance (maximum) between surfaces and volumes  

distance (minimum) and angle between geometrical entities and points  

distances  

measuring  

distances, calculating  

dressup, importing  

dressup, managing  

E
editing 

curve joints  

curve joints (modifying geometry position)  

joints  

point surface joints (modifying joints definition)  

exiting simulation in modified position  
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F
fixed part, defining  

G
gear joints, creating  
generating 

trace from a V5 mechanism  

trace from lines  

I
importing 

a mechanism and its associated dressup from a skeleton structure  

mechanisms  

mechanisms and dressups  

J
joint Limits 

checking  

setting  
joints 

cable  

creating  

cylindrical  

deleting  

editing  

gear  

higher pair  

lower pair  
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planar  

point curve  

point surface  

prismatic  

rack  

revolute  

revolute (centered option)  

revolute (with offset)  

rigid  

roll curve  

screw  

slide curve  

spherical  

universal  

using axis systems  

joints limits  

joints, creating  

joints, deleting  

joints, editing  

K
kinematics data, importing  

L
laws, defining  

M
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managing 

mechanism dressup  

maximum distance  

Measure Between command  

Measure Item command  
measuring 

distances  

maximum distance  

minimum distance and angle  

speeds and accelerations  

mechanism, analyzing  

mechanism, browsing  

mechanism, creating  

mechanisms with laws, sequencing  

menu Bar  
minimum distance and angle 

measuring  
more about 

importing mechanisms dressup  

joints  

joints and constraints  

resulting constraints  

swept volume  

moved constrained components, simulating  
moving 

constrained components using compass  

P
planar joints, creating  

point curve joints, creating  

point surface joints, creating  
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positions, recording  
preparing 

CATIA Version 4  

prismatic joints, creating  

R
rack joints, creating  
recording 

positions  
replacing 

slide curve joints  
resetting 

V5 mechanism  

revolute joints (centered option), creating  

revolute joints (with offset), creating  

revolute joints, creating  

rigid joints, creating  

roll curve joints, creating  

S
screw joints, creating  
sensors 

customized curves  

graphical representation  

sequencing mechanisms with laws  
setting 

joint Limits  
setting up 

your session  
simulating 

on request  
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with commands  

with Laws  

Simulating after having moved constrained components  
simulation 

exiting  

replaying  

reviewing  

running  

simulation with laws  

simulation, exiting  

simulation, replaying  

slide curve joints, creating  

spherical joints, creating  
swept volume 

defining  

filtering  

swept volume positions, filtering  

swept volume, defining  

T
tips for curve or surface joints creation  
toolbars 

Automatic Clash Detection  

DMU Generic Animation  

DMU Joints  

DMU Kinematic Update  

DMU Kinematics  

DMU Space Analysis Toolbar   

Simulation  
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U
universal joints, creating  

update, using  
using 

sensors  

trace  

update  

V4 Kinematic Data  

V
V4 kinematic data, converting  
V5 mechanism 

resetting  

V5 mechanism, designing  
visualizing and simulating 

mechanisms in sub-products  
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