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Dynamic Blocks in AutoCAD 
 
Part 1 of 3: Dynamic Block Overview 
and Quick-Start Tutorial. 
 

In AutoCAD® 2006 software, you can now create 
blocks that are intelligent and flexible. This exciting 
new feature, called Dynamic Blocks, enables you 
to modify blocks within specific constraints. A block 
library might have dozens of windows (if 
architectural) or bolts (if mechanical). With 
Dynamic Blocks, you can create one block that 
takes the place of all these related blocks and be 
confident that modifications match the dimensions 
of their real-world objects. As a result, the process 
of finding the right block is much more efficient. 
Inserting and editing the block is practically error-
free. 
Furthermore, you can individually modify components of blocks. For example, within a 
desk set, you could move the chair, change the type of telephone, change the desk size, 
and specify the size of the computer’s monitor. Thereby, you can work with one block that 
contains multiple editable components in place of several blocks. Facilities management 
was never so easy! 

This first of three articles explains the basic concepts of Dynamic Blocks and ends with a 
quick-start tutorial. Part two provides detailed documentation of the feature. Part three 
introduces some of the advanced uses for Dynamic Blocks. 
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How you can use Dynamic Blocks 
 

Once you create a Dynamic Block and specify its features and constraints, you modify the 
block after you insert it, using special grips. As you click or drag the grips, the block 
adjusts according to its allowable flexibility. In other cases, you can choose options from a 
drop-down list to specify how to modify the block. 

Here are some possible scenarios for using Dynamic Blocks: 

 A door that can be stretched to increase its width without increasing its thickness 
 A bolt that can be lengthened without increasing its thickness 
 A bed that can be changed from twin to queen to king, adjusting the number of 

pillows appropriately 
 A picket fence that allows for specific various post heights and then automatically 

arrays those posts as the fence is stretched 
 A rectangular metal plate with a centered hole that stays centered as the plate is 

stretched 
 A piece of equipment (such as a phone or a computer monitor) that can take one 

of several forms that is chosen from a drop-down list 
 
You can make any existing block dynamic by adding dynamic features to it. The office set 
in the figure includes a desk, three chairs, a computer, and a phone. This block is 
constructed so you can stretch the 6-foot desk to 7 feet or 8 feet. As you drag, the chair 
behind the desk and the computer both move, always remaining centered between the 
two sides of the desk. The right chair in front of the desk moves to remain aligned with the 
right side of the desk. Without Dynamic Blocks, you would have to manually adjust all the 
separate components when you stretched the desk. 

 

 

A multi-component block, such as the one above, can feature as much complexity as you 
want. For example, the type of phone, the type of monitor (CRT or LCD), the size of the 
monitor, or the type of computer (desktop or laptop) are all easily changed 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 1: Editing a 
Dynamic Block

This chair moves along with  
the right side of the desk. 

The desk stretches. 
Constraints limit the 
desk length to 6’, 7’, or 
8’. 

The computer and chair move as the desk 
stretches, but only half the distance, so 
they stay centered in relation to the desk. 
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How to Create a Dynamic Block 
 

A Dynamic Block is created (authored) in the new Block Editor by starting from an existing 
block or individual objects. When a block is opened in the Block Editor, you can select and 
edit the individual objects that make up the block; you don’t have to explode it first. After 
saving your changes in the Block Editor, you can insert your new Dynamic Block and test 
it out! 

To start authoring a Dynamic Block based on existing blocks, open the drawing that 
contains the block. Then open the Block Editor using one of the following methods: 

 Click Block Editor on the Standard toolbar 
 Enter bedit on the command line or in the dynamic input tooltip 
 Choose Tools > Block Editor from the drop-down menu 

 
After the Edit Block Definition dialog box appears, you can choose any block in the 
drawing.  If you want to turn all of the objects into a Dynamic Block, choose <current 
drawing> to work with the entire drawing. You’ll then be able to insert the entire drawing 

 

 

 

 

 

 

 

 

 
 
 
 

 
 

 

Note: If you want to use the Design Center to insert the Dynamic Block (which 
you would do for a block library drawing with more than one Dynamic Block), 
choose the block you want to edit. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2: The Edit Block 
Definition dialog box

If the block is dynamic, it shows 
the dynamic symbol. 
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Click OK, and you’re in the Block Editor. The Block Editor is a special 
window for editing Dynamic Blocks. The Block Editor has its own 
toolbar that provides commands for working with Dynamic Blocks. At 
the same time, the Block Authoring Palettes window opens. The 
palette has three tabs that are used for turning ordinary blocks or 
objects into Dynamic Blocks.  

 

 

 

 

 

 

 

 

 

Figure 3: A Dynamic 
Block in the Block 
Editor

Adding Parameters and Actions 
Compared to a regular block, a Dynamic Block generally has two additional items—a 
parameter and an action. Of course, you can add more than one of each. A parameter 
defines the features of the geometry of the objects you want to change. An action defines 
the modification that acts on the parameter. Each action is attached to a parameter. 

One exception is the alignment parameter, which doesn’t require an action. An alignment 
parameter in a Dynamic Block enables you to quickly align the block with other objects in 
the drawing—either tangentially or perpendicularly. Many blocks can benefit from an 
alignment parameter in addition to the other dynamic features they contain. 

The simplest example is a Dynamic Block that allows you to independently move an 
object in a block, based on a specified point on the object. You use the point parameter to 
specify the point and then attach a move action to that parameter. When you insert and 
select this Dynamic Block, you will find a grip on the point you specified. You can then 
move the object from that point. 

You choose a parameter based on the geometry you want to control and the position, 
distance, and/or angle you want to specify. Then you choose an action that modifies that 
parameter. Actions are similar to editing commands—they move, stretch, rotate, scale, 
array, and mirror (flip) objects. 
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To choose a parameter, click one of the parameters on the Parameters tab of the Block 
Authoring palette and then respond to the prompts for that parameter. The prompts vary 
with the parameter, but you generally specify the following: 

 Start point: The first point of the distance (a point parameter has only one point) 
 Endpoint: The end point of the distance, which may also define an angle 
 Label location: A place for the parameter’s label (the label location is for your 

convenience) 
 

For instance, you may want only one parameter point and grip, perhaps at the right side of 
the distance parameter. You can right-click the parameter, and then choose the number of 
grips you want from the Grip Display item on the shortcut menu. The example shows one 
grip only.  If you wanted to add two stretch actions—one to stretch from the left point and 
another to stretch from the right point—you would use two grips. 

When you finish your parameter, an exclamation point appears to remind you that an 
action still needs to be added. 

 
 
 

 

 
 

 

 
 

 

 

 
To assign an action, click the Actions tab and choose one of the actions. Some restrictions 
apply—for example, you can only assign a rotate action to a rotation parameter. The first 
prompt always asks you to select a parameter. The next prompt usually asks you to 
specify which parameter point you want to associate with the action. For example, if you 
want to stretch an object with a linear parameter, do you want to stretch from the left point 
or the right point?  

The next prompts depend on the action, but you generally need to select the objects you 
want to include in the selection set for the action. If you want the parameter to move as 
the object moves, you include the parameter in the selection set. Finally, you place the 
action’s label. The label has no effect on the Dynamic Block and is simply for your 
convenience when you edit the block. When you’re done, the exclamation point should 
disappear, which signals that you’ve successfully assigned the action to the parameter. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4: A linear 
parameter without an 
associated action 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 5: A block with 
a stretch action 
attached to its linear 
parameter 
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Constraining Values for Block Components 
If you’re creating a block for a desk, you probably need to restrict the desk size to the 
sizes available from your supplier. A great feature of Dynamic Blocks is the ability to 
specify either a list of values or possible increments with minimum and maximum values. 
This feature is called value sets and it helps avoid time-consuming mistakes! Value sets 
offer the perfect balance of flexibility and control. 

Let’s say that you only buy desks that are 4 feet, 5 feet, 
or 6 feet 6 inches long. In this case, you can use a list 
value set and simply supply these three values. Then 
you can only stretch the desk to one of those three 
values. On the other hand, you may have a part whose 
length is in increments of 1 inch, but never less than 3 
inches or more than 20 inches. In that case, you can 
use an increment value set to specify those values and 
constrain the length of the part accordingly.  

You specify a value set when you create a parameter. 
You can choose the Value set option when you choose 
a parameter and provide the details on the command 
line or in the dynamic input tool tip. You can also select 
an existing parameter and create the value set in the 
Properties palette. 

 
 
 
 
 
 

 
 
Using Parameter Sets 
AutoCAD 2006 software comes with a number of pairs of parameters and actions you can 
use, almost straight out of the box. These sets are a great way to get started with Dynamic 
Blocks. Click the Parameter Sets tab on the Block Authoring Palettes. 

The parameter sets combine the most commonly used pairs of parameters and actions, 
such as a point parameter with a move action and a linear parameter with a stretch action. 
You still have to choose the geometrical points for the parameter and place its label. 

The only missing information is the selection set for the action. For this reason, when you 
place a parameter set, you see one or more exclamation points to alert you that you need 
to select objects. Double-click the action and then select the objects. That’s all there is  
to it. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 6: The 
Parameter Sets tab of 
the Block Authoring 
Palettes window 
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Inserting and Editing Dynamic Blocks 
When you finish creating your Dynamic Block, save it by choosing Save Block Definition  

 on the Block Editor toolbar. Close it by clicking the Close Button Editor button.  

 

Open a new drawing or any drawing in which you want to insert the Dynamic Block. If you 
saved your block as one of a number of blocks in a drawing that functions as a block 
library, insert the block from the DesignCenter™ function. If you edited the entire drawing 
(choosing <current drawing> when you opened the block editor), choose Insert > Block 
from the menu and insert the drawing.  

Select the block, and then you will see one or more Dynamic Block grips, which are 
usually clicked or dragged. For example, if you added a stretch or move action, the block 
stretches or moves as you drag a grip. If you added a flip action, you just click the grip to 
flip the block. 

 
 

 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 
 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 
Figure 7: Click or drag 
a Dynamic Block grip 
to edit the block 
 

 

 
 

 

Click to flip 
(mirror)  
door up/down 

Click to flip (mirror)  
door left/right 

Drag to stretch width  
of opening 

Drag to move door  
in any direction 

Click to choose 
open angle of door 
(30, 45, 60, 90, or 
closed)

Drag to stretch 
wall thickness 
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Quick-start Tutorial 
Although this white paper is not meant to be a complete tutorial, we’ve included a short, 
simple lesson to help you get started with Dynamic Blocks. After you have created your 
first Dynamic Block, you’ll see that the process is not as difficult as it first might seem.  

This tutorial adds a linear parameter and a stretch action to a desk. 

1. Open office set.dwg. If you would like to keep the original drawing without 
changing it (for example, if you want to do the tutorial again), choose File > Save 
As and save it under a different name. Remember where you saved it. 

 

2. Choose Block Editor from the Standard toolbar. 
 

3. In the Block Edit Definition dialog box, choose the deskset block. Click OK. The 
Block Editor opens and the Block Authoring Palettes window appears. 

 
4. Click the Parameters tab of the palette and choose Linear Parameter. 

 
5. At the Specify start point or [Name/Label/Chain/Description/Base/Palette/Value 

set]: prompt, pick the upper-left corner of the desk. 
 

6. At the Specify endpoint: prompt, pick the upper-right corner of the desk. 
 

7. At the Specify label location: prompt, pick a location above the desk for the label. 
 

8. Select the parameter. Right-click and choose Grip Display > 1 from the shortcut 
menu. The left grip disappears. 

 
9. Click the Actions tab of the palette and choose Stretch Action. 

 
10. At the Specify parameter: prompt, pick the Linear parameter you just inserted. 

 
11. At the Specify parameter point to associate with action or enter [sTart 

point/Second point] <Start>: prompt, move the cursor over the right grip. Click 
when you see the red marker. 

 
12. If OSNAP is on, turn it off. 

 
13. At the Specify first corner of stretch frame or [CPolygon]: prompt, click at Point 1 

in the figure. 
 

14. At the Specify opposite corner: prompt, click at Point 2 in the figure. 
 

15. At the Specify objects to stretch Select objects: prompt, click near (but not 
exactly on) Point 2. 

 
16. At the Specify opposite corner: prompt, click near (but not exactly on) Point 1. 

 
17. At the Select objects: prompt, press Enter to end selection. 

 
18. At the Specify action location or [Multiplier/Offset]: prompt, pick a point to the 

right of the desk for the label. 
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19. Open a new drawing using any template. 

 
20. Press Ctrl+2 to open the DesignCenter. 

 
21. In the Folder List, navigate to the drawing where you saved the Dynamic Block. 

Double-click the drawing and choose the Blocks item. 
 

22. In the content pane of the DesignCenter, double-click the deskset block. In the 
Insert dialog box that opens, click OK. Close the DesignCenter. 

 
23. Click anywhere in your drawing to insert the deskset block. Choose Zoom 

Extents from the Zoom flyout of the Standard toolbar to display the entire block. 
 

24. Select the block. The stretch action grip is a right-facing arrow. Drag the arrow to 
stretch the desk. Click when the desk is the desired length. 

 
Conclusion 
Adding dynamic features to a block greatly increases the flexibility and usefulness of the 
block. Take some time to think about how you could use this feature for your blocks and 
then start creating some Dynamic Blocks! 

 

 

 

 

 

 
 

 

 

 

 
 

 

 
 

 
 
Figure 8: Creating a 
stretch action for a 
desk 
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