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Session - 1 
 

Brief Introduction and concepts of analysis and design 
 

E T A B S: - Extended three dimensional analysis of Building System. 
 

Founded by a company called CSI 
 

CSI: Computers and Structures INC 

 

Initially the ETABS software was just a program and was developed by a group of people 
(Masters Students) in the year of 1975. 

 

Later an official copy of integrated analysis and design software was released in the year 
of 1985. 

 

Case Study: - 1st Project worked out using ETABS was Burj Khalifa, ETABS was used to 
make the mathematical model of Burj Khalifa. (Total height 828m) 
 

The following are the products of CSI 
 

 SAP 2000
 CSI BRIDGE
 ETABS
 SAFE
 PERFORM - 3D
 CSICOL

 

Structural analysis and design concepts 
 

More than to say structural analysis and design it could be called as an art, An art that has 
got a history as good as the origin of human beings on this earth. In due course of 
civilization for the progressive well being of mankind. 

 

One of the best examples for this art is the construction of pyramids of Egypt in the late 
2000 years B.C. which is still a testimony for the modern day architects and designers. 
 

Structural analysis and design in today's world 
 

1. Load acting on the structures is ultimately transferred to ground. 
 
2. In the process of load transferring, various components of the structures are subjected to 
internal stress and strain. 
 
                            Stress=LOAD (P)/AREA (A)          &    strain=CHANDE IN LENGTH (ΔL)/ORIGINAL LENGTH (L)           
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3. For example load acting on a building will be transferred to ground in t he following 
path-way. 
 

Slabs > Beams > Column > Footing > Ground 
 

Definitions 
 

Structural Analysis: - Applying the loads on a structure and assessing the internal stress in 
the components of a structure is known as structural analysis 
 

e.g:- SFD & BMD 

 

Structural Design: - Based on the analysis results finding the suitable size or cross section of 
a particular type of structural component is known as design of structures . 
 

e.g:- Depth and amount of steel 
 

Type of Structures 
 

1. Masonry 
 
2. R.C.C 
 
3. Steel 
 

Or combination of all the above and is often called as Composite Structures. 
 

Types of structural analysis wise 
 

1. Deterministic Structures: - Structures that could be analysed by using static equilibrium 
equations are known as deterministic structures. 
 

The following are the static equilibrium equation:- 
 

 ∑m = 0
 ∑H = 0
 ∑V = 0

 

e.g:- Consider Simply supported beam with UDL 
 
 

 

No., of unknowns is two VA and VB 
 

No., of SEE is 3 
 

Therefore we can solve it manually and 
Hence it is a deterministic structure. 
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2. Indeterminate Structures:- Structures that cannot be analysed with the help of Static 
equilibrium equation alone is known as indeterminate structure s. (This type of 
indeterminate structures are often analysed by matrix method or FEM modulation) 
 

e.g:- 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

No., of unknowns is 4 (VA, VB, VC & VD) 
 

No., of SEE is 3 (∑m = 0, ∑H = 0, ∑V = 0) 

 

So it cannot be solved with the simple manual calculation, it needs complex method of 
analysis like Matrix method of structural analysis or we can also solve this in Staad-Pro or 
ETABS, and hence structure like this are called as Indeterminate structures. 
 

Types of Supports:- 
 

1. Simple Support 
 
 

 

2. Roller Support 
 
 

 

3. Hinged or pinned Support 
 
 

 

4. Fixed Support 
 
 

 

Types of Beams:- 
 

1. Cantilever beam 
 
 

 

2. Simply supported beam 
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3. Overhang beam 
 

 

4. Propped cantilever 
 
 

 

5. Continuous Beam 
 
 

 

Types of Loading:- 
 

1. Concentrated load or point load 
 
 

 

2. Uniformly distributed load (UDL) 
 
 

 

3. Uniformly varying load 
 
 

 

4. General Loading 
 
 

 

5. External moments 
 
 
 
 
 
 

Basic Analysis Terms & Examples 
 

Shear Force: The summation of all the vertical forces either to the right or left side of a 
beam is called shear force. And the representation of this shear force is k nown as a 
shear force diagram (SFD). 

 

Bending moment: The summation of all the moments either to the left or right side of the 
beam is known as a bending moments. And the diagram which represents these moments 
is known as bending moment diagram (BMD). 
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Types of Co-ordinate systems:- 
 

1. Global Co-ordinate system: - The Co-ordinate system for entire structure is known 
as Global co-ordinate system. 
 

e.g:- 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Local Co-ordinate System:- The co-ordinate system for individual members are known 
as local co-ordinate system. 
 

e.g:- 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

How to start a software ETA BS 2015 
 

1. Double click on the software icon on the desktop 
 
2. Waite 
 
3. File > New Model or Short cut is (Ctrl + N). 
 
4. Use built-in settings with, a s shown in the figure below : - 
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5. Now click ok again in the Grid customizing (or we can customize the grid patterns and 
numbers and number of stories) window as shown in the figure below : - 
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6. Now a first start up window should show like this, refer figure below:- 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

7. Units setting up method 
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Click on the units tab from right bottom corner > then click on the consistent units, and as 
the following window appears setup the suitable units and click ok, as shown below. 
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Session - 2 
 

Modeling Generation, Material Properties and basics 
 

Yield Stress of steel: Stress (that is, load per unit cross-sectional area) at which elongation first 
occurs in the test specimen (Steel Rod) without increasing the load during the tensile test. 

 

Material Property: Material property of any structural member refers to the engineering 

properties, such as cube compressive strength of concrete which decides the grade of concrete 

and tensile strength or yield stress of the steel, based on which the steel rebar grade is identified. 
 

 

Eg: (i) For concrete M-20, M-30, M-40 etc., 
 

(ii) For Steel Fe 415, Fe 500 etc., 
 

How to start a new Model in ETABS 
 

Before starting any new model in ETABS it is important to define material type based on which 

the structural behavior, analysis, design and results output depends on, the following are the 
systematic procedure and methodology to define material property in ETABS 2015. 
 

1. Open ETABS software set up the initial settings like units and code books. 
 

2. Create the required pattern of grid (from the new model quick template) based on the 
given architectural plan or import the centre line plan from the AutoCAD in DXF format. 

 
3. Once the grids are ready now we have to define materials, separately for concrete (M-20) 

and steel (Fe-415). 

 

(a). For Concrete: -  Define  --->  Material Properties (Refer figure below) 
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(b). A new dialog box (Define Materials) will open as shown in the figure below 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

And click on “Add New Material” 

 

(c). When the new dialog box (Add New Material Property) appears set the required 
standards as shown in the figure below and click ok. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

(d). Next we will get a dialog box as shown in the figure below, in this dialog box check and 
set the required material parameters of concrete. 
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(e). similarly click on add new material and set the parameters for steel as shown in the figure 
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Once the grid is ready and all the material parameters are defined, next proceed on to make a 
model by creating a frame sections as depicted below:- 
 

Define:- 
 

Section Properties ---> Frame sections 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Next Frame properties window will appear as shown below Choose Type: concrete rectangular 
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Next we will get two different beam creating templates, we have to delete the pre programmed 

one or we can also edit the same by selecting a particular template (Bea m / Column) and we can 

change the properties and parameters. It’s better to create a new on e by clicking on “Add new 

property” 
 

As Shown in the figure below:- 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Once we click on the add new property tab, we will see a window as show n below (From that 
window we can choose our de sired structural shape) 
 
 
 
 

Choose the required shape (Rectangular) and hit ok. Then it will guide you to the next window 

where we set the cross sectional dimensions and rebar diameter, clear c over etc., as shown in 

the figure below: 
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By clicking on to Modify/Show Rebar.... we can change the beam reinforcement and cross 
sectional configuration, refer figure below. 
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The same way we have to se t the parameters and rebar configuration for column as well and 

click ok and now our two new customized beams and columns are ready and are ready to be 

draw a model (Portal frame). 

 

Make a note that we can create any number of cross sectional property f or beams and columns 

of varying dimensions and will listed in the Find this property column which lets you choose the 

particular type of property while generating the model. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

(f). Now we have create the sectional property for slabs and wall, the sa me way like how we 
created it for beams and columns. 
 

Define-----> Section Properties -------> Slab Sections 
 

 

15 



23/Feb/2016 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

(Next it will display the window as shown below) 
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Now the slab definitions and parameters are ready to be used as listed in the table shown 
below 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

(G). Tow Define the parameters for wall section, First create the property for wall section by 
going to 
 

Define ----> material property----> Masonry 
 

As shown below 
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Next go to Define ----> section properties ------> Wall Sections 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Now the Grid is ready as per the centre line of the architectural given plan and all the parameters 

and definitions are ready for creating portal frames and slabs , now we are ready to draw or 

generate the portal frame by following the procedure as mentioned below. 
 

Draw -----> Draw Beams/ Columns/ Brace Objects or click on this icon from the left side 

Tool bar. The procedure is as depicted in the below figure (Next Page)  
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After selecting Draw Beam/Column/Brace Objects: 

 

Choose the type of PROPER TY with which you want to generate the portal frame, from the 
properties table in the left bottom corner as shown in the figure below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

After choosing the particular frame sectional property like beam or column then start drawing 

the beam section from nod e to node for beams and on the nodes for columns, use the following 

icons 
 

Or   : - To draw beams or quick beams in case of multiple beams in a single shot. 
 

 : - To draw Columns. (Either single or multiple) 
 
 
 

 

(H). after choosing a particular type of property, try to draw a basic frame as shown in the figure 
below. 
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(I). How to Generate Slabs 
 

(i). Slabs: For slabs also we have to define property similar to beams and columns 
 
 

 

Define----> section property -----> slab section----> Add New Property--> t he following window 
 

appears 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Set all the parameter and properties as shown in the figure above, and the slab is all ready for 
generating portal frame module. 

 

If the space frame is ready with beams and columns it is very simple to draw slab s, basically there are 
three methods by which you can draw slabs: 
 

 

1. : - To draw irregular slabs or curved slabs.  

2. : - To draw rectangular slabs, though the slab has got 4 corner points only 2 diagonal   s 

 Points are enough to draw a clean rectangular slab.  

3. : - To quickly draw a slab just by window dragging method, (But make sure you have a g 

 closed beam envelope to create a clean slab boundary) This method is fast and j 

 Suggested one for experienced ETABS user.  
 

20 



23/Feb/2016 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

(j). How to Generate Walls 
 

To draw walls also first we need to define and create properties for wall, t he following are the 
two methods by which we ca n create walls. 
 

(i).  : - To draw walls between two points. 
 

(ii).  : - To quickly draw w alls by window dragging method. (Very well suited for walls w 
 

w With common cross section and for common walls. 
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(K). How to Draw a circular slab 
 

Select the particular beam in front of which we need to create circular be am, and use the 
replicate ( ctrl + R ) tool as shown in the figure below:- 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Next click ok and click on the object snap icon (  ) to highlight the mid-points and end points, 
after replicating the beam should be seen like the figure shown below:- 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Now using the irregular shape slab drawing tool (   ) and choose the s lab drawing type as 3- 
Points as shown in the figure below:- 
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Next start drawing the semicircular slab (in two steps, drawing quarter slab span each) as shown 
in the figure below, kindly follow the same order:- 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

(L). How to Draw Circular Wall:- 
 

Drawing circular wall is also similar to that of drawing a circular slab, we have to replicate the 

beam in front of which we need to create the circular wall and follow the order as shown in the 

figure below:- 
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Before drawing this circular w all make sure to set the property and the type of wall as 3-point 
type one as shown below:- 
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Session - 3 
 

Model Modifying Tools ( EDIT - Tab ) 

 

(a) Merge Joints: In case of any complex modeling in the final step while checking your 

model by mistake if any of the nodes or joints is not joined properly @ one point, by using 

merge joints we can join that particular joints or nodes. 
 

The procedure for using the merge joints option is as shown in the figure below:-
First select the particular joint as shown below 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Then click the EDIT tab and click on Merge joints as shown below:- 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Finally click ok. 
 
 
 

 

25 



23/Feb/2016 
 

 

(b) Align Joints/Frames/ Edges (Short cut: - shift + Ctrl + M) :- A lign tool helps you to make a 

smart and aesthetically pleasing models, like inclined strut or a column member etc., 

 
The procedure to us e Align tool and the completed model is as shown in the figure 
below:-  
1.  Select the line of joints which you want to move, using window selection 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

2. Next activate the align command using the shortcut (Shift + Ctrl + M) or from the edit 

tab. And enter the distance dimension in the direction you want to move as shown in 

the figure below: 
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3. After editing all the stories joints one by one the final edited model would be seen 
like the model as shown in the figure below:- 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

(C). Move Joints/Frames/Edges (Shortcut:- Ctrl + M) 

 

Move joints are al so works the same way as the align tool and the working of which 
is as shown below:- 

 

Step 1:- select the particular joint which you want to move 
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Step 2:- Activate move joint command using the short cut (Ctrl + M) or by clicking on to the edit 
tab from the top menu bar an d enter the distance by which you want to move your joints. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Step 3:- After clicking ok the final model should be seen something like this:- 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

(D). EDIT FRAMES:- Edit Frames option helps us to make a divisional change or reciprocative 

changes in the particular frame member (either beam or Column). Using Edit frame option we 

can do following modification s in the model. 

 

(i). Divide Frames:- Divide frames allow you to divide the single frame section into number 

of segments, using this options we can divide a particular beam/ frame sections into any number 

of divisions. 
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Select the member > Edit > Edit Frames > Divide Frames 
 
 
 
 
 

 

 
 
 
 
 
 
Next select the member and click on the edit > edit frames > Divide frames and now you should 
see the following dialog box 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Finally after division the divided frames will look like the figure as shown below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

(ii). Joint Frames:- After dividing the frames into several number of p arts or after finishing 

drawing any beam member of any framed sections then by using Joint Frames we can easily join 

those two members again to make it look like a monolithic structure, refer the figure below. 
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Select the member: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Go to edit > edit frames > Join frames 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Now the member will be a single joined member again, as shown in the figure below 
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(iii). Reverse Frame Connectivity:- This particular editing tool is used specially to rotate the beam 

between two different type of supports or to reverse the local coordinate axes as shown in the 

figure below. 
 

Before:- After:- 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

(E). EDIT Shells:- Edit shells helps us to deform the shape of the shells/ membrane or slab 

element, to the desired shape or dimension, the following are the options we get in the Edit Shell 

option:- 

 

(i). Divide Shells: Divide shells allows us to divide the slab or a shell member in to various number 

of divided objects as shown in the figure below. In order to use t his divide shells option first we 

have to select the slab member and then divide the slab into required number of divisions. 
 

 

------> Step 1: select the slab member 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

31 



23/Feb/2016 
 

 

------> Step 2: go to EDIT---> Edit Shells ----> Divide Shells 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

------> Step 3: When the window appears, Enter the number of divisions t o make in both X and Y 
direction & click ok. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

--------> Step 4: Finally after division the slab would be seen like this 
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(ii). Merge Shells: If we want to rejoin the divided slab/shell member or if we need to join the 

semicircular slab to square edge, then with the help of merge shells we ca n merge these shell 

slab sections to make it a sing le member. 
 

(Process:- Select any two slabs and go to EDIT---> Edit Shells-----> Merge shells) 
 

Step 1:- Select two divided shell member 
 
 
 
 
 
 
 
 
 
 
 
 

 

Step 2:- Edit > Edit Shells > Merge shells 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
 
 
 
Step 3:- Finally after merging process the slab would be seen like this 
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(iii). Expand or Shrink Shells: This option will help us to increase the size of the slab member all-
round its edges, by the specified offset distances. 
 

Step 1:- Select the particular Slab 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Step 2:- Edit > Edit Shells > Expand or Shrink shells 
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Step 3:- A window will appear in that entre the amount of offset distance, to expand (+) value 
and to Shrink use ( - ) value. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Step 4:- After clicking ok the s lab would expand like the figure shown below 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

(iV). Chamfer Slab Corner: U sing this tool we can give the chamfer edge or a fillet edge to a 
particular corner node of a slab. 
 

Process: Select the slab and t he corner and click the Edit > Edit Shells > Chamfer slab corner 
 

Step 1:- select the slab and the particular corner joint 
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Step 2:- Click the edit > Edit Shells > Chamfer the slab corner 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Step 3: Mention the amount of chamfer distance in the dialog box that appears now. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Step 4: Finally the chamfer/filleted edged slab would be seen as shown in the figure below. 
 

Chamfer Fillet 
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(V). Reverse Wall Local Axes 3: Using this tool we can reverse the local coordinates of the wall 
(Shell Element) as shown in t he figure below. 
 

Step 1:- Select the wall by activating local axes coordinates from set display options (Ctrl +W) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Step 2: Go to Edit > Edit Shell s > Reverse Wall Local axes 3 
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Step 3: After Clicking on the “Reverse Wall Local Axes” it will change the local axes 3 of the wall 
element as shown in the figure below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig: Local Axes Reversed 
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Session - 4 
 

How to make typical Stories 

 

(i) If we want to work out the same cross section throughout the entire floor in a single 

step, just activate the command “All Stories” From the right bottom corner tab as 

shown in the figure below and start modeling in any one story. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

(ii) Typical Stories & Similar Stories: Most of the time in case o f either apartments or 

commercial buildings, there are certain number of stories which will have a uniform 

frame sections and load patterns, In ETABS 2015 we have an option to customize 

those stories and t o make it a typical one. 
 

Step 1: Go to Edit ----> Edit Stories and grid system ----> in the story data ----> Click on 
modify/show storey data. 

 
For example if we want to make storey 2 and storey 3 as a typical stories in the dialog 

box that appears when you click the “modify/Show Storey data”, change the 

parameters. But make sure that you activate it to similar stories as shown in the 

figure below. 
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After clicking it to all stories, in this example we have made storey 2 and storey 3 as a typical 
storey, 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

So if we assign any type of loading or frame sections to a Master Storey, T he same effect will be 

replicated to the adjacent stories due to the activation of similar stories . A typical example of the 

working of the similar stories is as shown in the figure below. 
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Concept of releasing the moments 

 

In the situations like where it demands a secondary beam or a tertiary beam in any project it 

becomes imperative and economical to release moments so that it acts as a simply supported 

member instead of including extra torsional moments. 
 

The procedure to release moments is as given below, 

 

Select the secondary or a tertiary beam, go to assign -----> Frame -----> Re leases/ Partial fixity, a 

dialog box appears in that click to release m33 moments since m33 moment being the worst 

case. The schematic representation is shown below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

After the releasing moments the beam should be seen like the figure shown in the figure below 
with the two dots at either ends. 
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How to Activate and Check out the Local Axis for a particular frame sections 

 

In order to see the local axis o f a particular member, in the 3D view window click somewhere go 
to set display option ( ) (Ctrl W) and click on object assignments ----> Frame assignments-- 
 

----> Local Axes. After this local axis will be seen for all the structural frame sections as shown in 
the figure below 
 

. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Smart Selection Process 

 

In any complex structures there are various number of the structural members which are called 

as the frame section in the language of ETABS, when we have a complex model and if we want to 

select a particular frame section in a single click, SELECT tab from menu bar comes in handy. The 

procedure is as given below. 
 

Let us consider we have 3 types of beams of varying dimensions say 
 

1. Beam 200 X 500  
2. Beam 200 X 600  
3. Beam 200 X 750 
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With the help of Select tab we can select a particular frame section of a particular dimension as 
depicted below:- 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

How to create a spring support 

 

In case of designing a Steel Structures especially truss members and sp ace frame trusses we 

might require a type of spring support where in we just need to customize it using joint supports 

and restraints option and finally we can assign it to any nodes, Basically spring supports allows 

displacements only in vertical direction. The procedure to create a spring support is as given 

below:- 
 

First select a joint (point) where you want to assign a spring support, and go to assign---> Joints 
 

-------> Restraints ------> a window appears in which we need to customize the type of supports 
with the help of null support option. 
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Loading and Analysis 

 

1. Loadings and loading pattern: By default ETABS will create two types of load cases i.e. 

Live Load and Dead load. For any other type of load cases like for either wind load case or 

seismic load case w e can add it here, the procedure for adding load patterns and load 

cases are as given below. 
 

Go to Define----> Load Pattern ----> A Window will appear as shown below 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Using this window we can add or delete any type of load cases based on the requirement and type of 
analysis to be performed. 

 

2. Load assigning patter n: Once we are done with the modeling of the whole structure, 

next step is to assign loads like as a dead load we have to assign wall loads on all the 

beams and as a Live Load we have to assign a shell uniform load sets (Uniform loads on 

slabs). 

 

3. Uniform loading on s hell: In order to assign loads (Live loads) on slabs, select the slabs -- 
 

---> Assign -----> shell Loads ------> Uniform. A load assigning window will appear as shown 
in the figure be low 
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Care should be taken because sometimes we might have to assign uniform loads on slabs to 

serve the purpose of floor finish at that time the Load pattern name should be set to “Dead”. 

After assigning the slab loads, ETABS will analyse the loads and it will distribute the loads to the 

adjoining beams automatically which we can make out while checking the post processing results 

like SFD and BMD for beams. 

 

For example, in a network of beam carrying a square shaped slab the SFD for the adjacent beam 

will have a second degree parabola; this is due to the distribution of tri angular (1 part of load 

from square slab) load from slabs. 
 
 
 

4. Load Combinations: to take care of the partial safety factor it is important to consider 

load combinations, t o avoid this problem though ETABS will consider its own load 

combination “UDCON2” it’s always preferred to customize your own Load combination so 

that you have a full hold on your designs.  
The procedure to create load combinations is as given below 

 
Define----> Load Combinations-----> In that window that appears click on add new combo 
as shown in the figure below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

After clicking on Add new combo another window appears as shown below/next page, here we 

can enter the safety factor (1 for DL and 1.5 for LL). After all the load assignments and load 

combinations are define d next the model is ready to be analysed to see the post processing 

results. 
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Session - 6 
 

ETABS will help us design almost any concrete structures, Using Limit State method according to 
the specified codes of practice. 
 

The following are the basic methodology to carry out any concrete frame designs: 
 

1. Open a new file 
 

2. Set the units (m KN) 
 

3. Set up grid lines 
 

4. Define storey levels 
 

5. Define member Properties 
 

6. Draw structural Objects (Beam, Columns & slabs) 
 

7. Assign Properties 
 

8. Define Load Cases 
 

9. Assign loads 
 

10. Do the load combination 
 

11. View the model (Extruded View) 
 

12. Check your model for any unwanted eccentricities 
 

13. Analyze the model (Post processing results) 
 

14. Display results for checking 
 

15. Design the model 
 

16. Generate output 
 

17. Save the model 

 

View/Revise Preferences 

 

In the view/Revise Preferences tab we have a option to set or check the code of standards 

according to which the sections will be designed. In order to access this option, follow the path as 

shown in the figure below. 
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When the View/Revise Preferences option is activated the following window appears where we 

can check the code of standards (IS 456 2000) and the same miniature is as shown in the figure 

below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

View/Revise Overwrites 

 

Using this option we can set the priority or type of design to be carried out i.e., by default 
3 types of designs are available as mentioned below:- 
 

1. Ductile: For the consideration of tall structure and seismic designs 
 
 

2. Ordinary: For norm al residential and low range commercial building design 
projects 

 
 
 

3. Non Sway: For rigid frame designs (includes both steel and concrete) 
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The window that helps you choose these options is as displayed below, In order to 

activate view/revise overwrites go to, Design--> Concrete Frame Design--> View/Revise 

overwrites, now the following widow appears. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

How to Choose and customize Load Combinations 

 

After assigning the Dead Loa d and Live load for any frame sections designs we have to factor it 

with a minimum factor of safety (1.5) and this could be done by a process called Load 

Combination. 

 

By Default ETABS 2015 will consider a Load Combination with the factor of 1.5 and the default 

name for this load combination is “UDCon2” but we need to activate it by clicking on “Add 

Default Design Combos” 
 

In order to access this load combination window in ETABS go to; 
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Define---> Load Combination s---> the following load combinations window appears as shown in 
the next page 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

It is always advised to click “Add Default Design Combos” so that ETA BS will Never make a 

mistake by not considering it, It’s a default program path way. Furthermore we can even 

customize these options by clicking on “Modify of show Combos”. 
 

Meshing of Slabs 

 

After the modeling is complete and all the loads and load combinations are defined just prior to 

the analysis (F5) Select all the slabs and click on, Analyze---> Automatic rectangular mesh settings 

for floor---> this will display the mesh customizing window as shown below. 
 
 
 
 

By default the size of the meshing will be 1.25, But for better results it’s always advised to set it 
to 0.6. 
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Concrete Design 

 

After all the modeling, assigning loads and load combinations are properly assigned next we have 

to analyse the structure to check the post processing results (SFD & BMD) later the model can be 

set to Concrete designing by clicking on 

 

Design---> Concrete Frame Design---> Start Design/ Check (Shortcut sft + F6) as shown in the 
figure below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Finally after analyzing and design of the whole structures the completed design model looks like 
the sample model as shown in the figure below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

SFD & BMD Area of Steel (Ast in mm2) 
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Design of Shear Wall 
 

Shear Wall are specially designed walls incorporated in the buildings to resist lateral forces that 

are produced in the plane o f the wall due to wind, earthquake and other forces. They are mainly 

flexural members and usually provided in tall buildings to avoid the total collapse of the tall 

buildings under seismic forces. 
 

The following are the steps t o design shear wall in ETABS 
 

1.  Complete the model of building with the locations of shear wall and lift cores. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

2.  Now select only shear wall and click on show selected object only 
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3. Define Pier Labels Like P1, P2, P3, P4, P5 and P6, define the pier labels equal to the number 

of shear walls and select one by one shear wall and assign that pier label to all shear wall as 

shown in the figure below . 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

4. Again select the previous selection tab and then go to assign---> Shells ---> wall Auto mesh 
options, the wall auto mesh window is as shown in the figure below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Carefully ensure that t he meshing should be done 1 X 1 (number should be more than 1) 
And click on Add Restraints on edge if corners have restraints. 
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5. Next step is to design the Shear wall But Before that “Do the LOPD” check. 
L:- Live load reduction 

 
O:- Overwrites 
P:- Preferences  
D:- Diaphragms (If we have in our model) 

 

6. Now go to Design----> Shear wall----> Start design/check (Shft+F10) 
 

Now after the ETAB program runs the analysis and design it displays the longitudinal Ast 
as shown in the figure below. 
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In order to check the shear Reinforcement in the shear wall go to Design---> Shear wall Design-- -
> Display design info (Sft+Ctrl+F10). 
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Wind Load Analysis 
 

According IS codes a structures exceeding its height more than 10 meters is considered as tall 

structures and often if the n umber of stories is more than six stories it’s better to analyze the 

building for Lateral wind load, due to which the moments in the structural members increases 

and there by designs the suit able area of steel for that moment. 

 

Once the structure is safe design wise next step is to break the model and add two new load 
cases in the “Define load patterns tab” as shown in the figure below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Next click on one of the wind load cases and click on “Modify Lateral Loa d” the following 
window will be displayed 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

The entries for this box will be done with the help of IS 875 Part 3 
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Page numbers 8, 11 and 14 for the details of terrain category and structure class and co-efficient 

of wind pressure Cpe. The wind speed is also given for different cities in m/sec in Appendix – A. IS 
875 Part-3 page – 53. 
 

For example average wind speed for Bangalore is 33 m/sec and for Mumbai is 44 m/sec. 

 

After feeding these details for both the load cases that is wind-x and wind-y next step is to 

analyze the building and check the maximum joint displacement (Predominantly check for 

maximum beam column joint junction) maximum joint displacement in the whole structure 

should be less than (H/500), where H= total height of the building in m. 

 

This (H/500) limitation is as per the Lateral Sway Clause mentioned in IS 456 – 2000 page 33 
Clause 20.5. 
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Seismic analysis in ETAB S-2015 
 

1. Equivalent static Analysis 
 

First create the model and d o the analysis and design as usual (RCC design) and then once the 
complete model is checked. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Next break the model and s tart defining the load patterns for seismic loads as shown in the 
figure below 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Next click on one of the load cases, say EQ-X and click on Modify Later al Load to specify the 
Seismic load details as per IS 1893 – 2002. 
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The modify lateral load window should look like this 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

In a similar way define seismic loads for both the direction EQ-X and EQ-Y and later, create the 

load combination and Envelope and finally run the model. After the structure is analyzed, go to 

show tables and make a note of following values: 

 

1. Maximum value of Storey Drift: - should be less than 0.004 or 0 .004 times the storey 
height. 

 
2. Maximum Base reaction FZ (Later this value should be compared with Response spectrum 

Base reaction) 
 

Now the Equivalent Static method of seismic analysis is over, next perform the Response 
spectrum analysis. 
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2. Response Spectrum Analysis 
 

In response spectrum analysis, first break the model delete the two load patterns and 
load combinations. And follow the following steps:- 
 

Step-1:- Delete the load patterns defined for linear static analysis 

 

Step-2:- Go to Define ---> Function ---> Response spectrum -> Choose Indian Seismic code IS 1893 
– 2002, the window should look like the figure shown below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Step-3:- Once the function is defined,    
cases for Spectrum-X and Spectrum-Y 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

    next go to Define---> Load Cases ---> Define two new 
load as shown below. 
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Step 4:- Go to Define---> Mass Source---> and add all those lateral load which it has to consider 
for seismic analysis Usually the following 3 loads are considered. 
 

1. SIDL  
2. EQ-X / Spec X  
3. EQ-Y/ Spec Y 

 

The mass source window will look like the figure shown below 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Step 5:- Go to Define---> Modal Mass---> and define the Seismic wave t pes and accelerations the 
modal mass editing window should look like as shown in the figure below. 
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Step 6:- Create load combinations and Envelope ---> Save the model ---> Run analysis 
 

Step 7:- Check the following results 
 

1. Maximum storey Drift should be either 0.004 or 0.004 times the storey height. 
 

2. Maximum Base reaction FZ should be greater than or equal to the Equivalent static/ linear 
static method.  

3. Modal mass participation factor 
 

Sum x and Sum y 
 

0.9 0.9 
 

i.e., at least 90 percent of the lateral loads should be considered. 

 

4. Check the deformed shapes or mode shapes, First 3 modes should be transition that is either 
in x direction or in Y direction. 

 

The Response spectrum analysis is satisfying all the above criteria’s then the model is said to be 
safe and no corrections to be done 
 

Additional Points and Notes :- 

 

1. Storey drift details and limitations given in 
IS 1893-2002 (Part-1) Clause: - 7.11.1 

 
2. For defining the load pattern in equivalent static analysis time period should be calculated 

manually the formula for calculating the time period for different type of building is as 

given in.  
IS 1893-2002 (Part-1), Clause: - 7.6.1 and 7.6.2 in page number – 24. 

 
3. Base reaction comparison details in IS 1893-2002 (Part -1) page – 25 Clause 7.8.2 and 

7.8.2.1. 
 

4. For soft storey consideration refer IS 1893 – 2002 
Page – 27, Clause – 7.10.1. 
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Session 7 
 

Steel Frame Design 
 

The design/ check of steel frames is seamlessly integrated within the program. Automated 

designs are the Object level is available for any one of a number of users-selected design codes, 

as long as the structures have first been modeled and by the program. Model and analysis data 

such as material properties and member forces, are recovered directly from the model database, 

and no additional u ser input is required, if the design defaults are acceptable. 

 

The design is based on a set of user-specified loading combinations. However, the program 

provides default load combinations for each support design code. If the default load 

combinations are acceptable, no definition of additional load combination s is Steel required. 

 

Steel frame design or check consists of calculating the flexural, axial , and shear forces or stresses 

at several locations along the length of a member, and then comparing those calculated values 

with acceptable limits, that comparison produces a demand/Capacity ratio, which typically 

should not exceed a value of one, As per IS 800-2007 clause 9.3.2.2, Page no, 71. 
 

Procedure for steel Design 
 

1. Example 1 
 

Step 1:- Open ETABS as usual, define properties for material and start modeling a steel frame to 
the required architectural de signs (make sure all the dimensions) are in m m and N. 
 

Use the following section property to model a basic frame building 
 

For Columns (I section) 
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For Beams (I section) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

For Intermediate beams 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Using all the properties above try to make a framed structure as shown in the figure below (Try 
with 5m X 5m Grids) 
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Step 2:- Once the model is complete the frames are have to be assigned with loads to all those 

members based on requirement and type of building to be designed. After assigning loads the 

model should be seen as shown in the figure below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Step 3:- Perform LOPD (pre analysis settings and check) 
 

L- Live Load reduction 
 

O- Design Overwrites 
 
P- Design Preferences (ensure that the code is set to IS 800-2007) 
 

D- Assigning Diaphragms (If w e have any slabs in our model) 

 

Step 4:- Run Analysis and Design 
 

Short cuts:- 
 

Run Analysis: - F5 
 

Start Design/Check: - Sft + F5 

 

Once the model is analyzed w e can check the forces (SFD and BMD) if w e want to and later we 
can proceed to design. Design ---> Steel Frame Design---> Start Design/Check. 

 

Step 5:- Finally check the result in all the steel sections that the PMM ratio or Design Capacity 
ratio should be less the 1. As per IS 800-2007 Clause 9.3.2.2, Page No 71. 
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2.  Example 2 
 

Design of Factory roof truss; Refer the following section trial sizes 

 

Roof Truss section “Circular hollow sections”, the property for the circular hollow section is as 
shown in the figure below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

And start modeling the truss framework for the following dimensions 
 

1.  Storey Heights:- 
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2.  In Plan view:- 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

3.  Once the model is complete the model should look like the figure shown below. 
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4. Now assign the Maintenance Live loads/ any type of loadings based on the design 
requirements. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

5.  Run analysis and Design the steel frame and check for its safety and design outputs 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

The entire PMM ratio for all the steel sections should be less than 1, and thus the steel frame 
design is done. 
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Session 8 
 

Design of Steel Connection 
 

If any structure to be intact it is important that it should have sufficient fixity at the junctions i.e., 

at the beam column junctions, the following are some of the connection design etiquettes as per 

IS-800 : 2007 to be followed while designing any type of fasteners or connection. 
 

1. Ease of fabrication and erection should be considered in the design of connections. 
 
2. In general, use of different forms of fasteners to transfer the same force shall be avoided. 

 
3. Minimum spacing between any two bolts:- The distance between centre to centre of 
fasteners shall not be less than 2.5 times the nominal diameter of the fastener. 

 
4. Maximum spacing between any two bolts:- The distance between the centres of any two 
adjacent fasteners shall not exceed 32t or 300 mm whichever is least. 
 

Where, t is the thinner plate thickness. 
 

5. Bolt dia., and minimum clearance 
 

 d0 = d + Clearance


 Consider 1mm for 12mm to 14mm dia bolts.
 Consider 2mm for 16mm to 24mm dia bolts.
 Consider 3mm for bolt dia of 24mm and above.

 

The following are the steps to design the bolt type connection in ETABS 2015 
 

Step 1:- First finish off the steel frame modeling, analysis and Design and the structure should be 

finalized no more architectural alteration should be there in the geometry of steel structures. 
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Step 2:- Now without unlocking the model go to Design----> Steel Connection Design----> Select 
design load combination. 

 

Step 3:- Check for Preferences where we get an option to choose the type of connections to be 

done and interactive editing options, such as choosing a particular type or dia of bolts, 

connecting plate thickness, weld thickness and size of weld etc., 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

A typical Steel connection preferences is as shown in the figure below. 
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In this Preferences tab we also get an option to choose the type of connection to be designed, 
the type of connections available in ETABS connections are as listed below:- 
 

1. Beam to Beam connection  
 Vertical Plate (full)

 
 
 
 
 
 
 
 
 

 

 Vertical Plate (Partial)
 
 
 
 
 
 
 
 

 

 Horizontal Plate
 
 
 
 
 
 
 

 

2. Beam to Column connection  
 Beam Column Shear major axis
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 Beam Column Shear Minor axis
 
 
 
 
 
 
 
 
 
 
 
 

 

 Beam Column moment major axis
 
 
 
 
 
 
 
 
 
 
 
 

 

 Beam Column moment minor axis
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

3. Column to footing connection (Anchor bolts and pedestal type) as shown in the figure 
below. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 

71 



23/Feb/2016 
 

 

Step 4:- After setting all the criteria's and type of connections in design connection preferences 

go to Design---> Steel Connection design ----> Start design or check after connection our model 

will look like the figure shown in the figure below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

The small Dots near all the supports are indicated means this particular connection is done if the 
DC ratio is less than 1. Then the design is SAFE / OK. 
 

Step 5:- How to Check connections and overwrites 

 

For Beam to beam Connections:- Right click on the dot of a beam to beam junction the 
ETABS will display the connection as shown in the figure below 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

If the connection is failing click on overwrites and we can alter either bolt dia or the connecting 
angle plate thickness and run for analysis and design and check the results. 
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For Beam to Column connection:- click on the dot on the beam which is connecting column 
then the design of beam column design is show in the figure below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Column to pedestal connection:- Right click on the dot of the column at the base and we 
can see the complete anchor bolts connection at the base of the column. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Also make a note that by clicking on the Details in this table we can see or check out the 
complete connection design and number of bolts and bolt dia report completely. 
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Session 9 
 

Detailing and BOQ’s 
 

Procedure:- 

 

Step 1:- Complete analysis and design of the project should be done with no further alterations in 

the model or the structural geometry. After the complete analysis and design of the project the 

final designed model should look like the figure shown below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Step 2:- Go to Detailing -----> Start detailing, the typical process is as shown in the figure below. 
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Step 3:- Once the detailing process is done, in the left side Model Explorer bar find a tab called 

Detailing in that, ETABS will create a fully functional detailed drawings as shown in the figure 

below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Step 4:- We also have a provision to convert these drawings to AutoCAD and thus it helps in 

reducing the drafting time as well. The process for converting ETABS generated drawings to 

AutoCAD is as given below. 
 

 Right click on the drawing and click on Export View
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 After we click on Export View we will see a window as shown in the figure below
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 Choose the format in which we want to save our model,

 

DXF ---> Target Directory ---> Start Export ---> waite for the process to be done until it shows 

Ready in the left most box a s shown in the figure above ---> Once the Ready is displayed click on 
done. 
 
 

 

 After this find a DXF fin e saved on the desktop and open it in AutoCad, the detailed drawings 

produced by the ETABS will not be up to standards to execution quality, but with the minimal 

editing of it will complete the drawing and thus reduces the drafting time. The Detailed 

drawings of ETABS after generating and exporting it in to AutoCad it should look like the 

figure shown in the figure.
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Introduction to BOQ 
 

ETABS also generates the tentative Bill of Quantities, and there are several methods in which we 

can generate the Bill of Quantities, out of all those methods one of the fastest method is as 

discussed below. 

 

Let us consider an example o the simple Beam to understand the process of working out BOQ’s in 
ETABS. 
 

Details about example Beam 
 

Beam size = 200 X 500 mm 
 

Length = 5m (5000 mm) 
 

M-25 Concrete 
 

Fe 500 Rebar steel 
 

UDL applied on the beam in the form of Live load = 40 KN/m 
 

After combination, analysis and design the Ast of the beam is shown as 
 
 

 

Longitudinal Ast of Beam:- 
 
 
 
 
 

 

Shear Reinforcement:- 
 
 
 
 
 

 

Rebar Percentage:- 
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 In order to check the tot al weight of the RCC required to this beam, without unlocking the 
model got to Display---> Show tables---> click on,,.

 

 

---> Model----> structure data ---> Material List > Material List by element type > 
Material list by section 

 
> Material list by Storey. 

 

A typical representation of this is as shown in the figure below 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 Now ETABS will display Material quantity tables as shown in the figure below
 
 
 
 
 
 
 
 
 

 

 Using Rebar percentages and total RCC weight from above table we can easily workout the
 

materials required as shown in the calculations below: (same process we have to work out in 
SAFE for footings and Slab BOQ’s) 
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Session 10 
 

Composite Structures 
 

A Composite material is basically a combination of two or more materials, each of which retains 

its own distinctive properties. Multiphase metals are composite materials on a micro scale, but 

generally the term composite is applied to materials that are created by mechanically bonding 

two or more different materials together. The resulting material has characteristics that are not 

characteristic of the components in isolation. The concept of composite material is ancient. An 

example is adding straw or bamboo sticks to mud for building storage mud walls. 

 

In the current world engineers made an attempt to use the same conventional method called 

composite structures in a much more simplified manner. The following are some of the examples 

of composite structures of a modern day world. 
 

Ex 1. Reinforced Cement Concrete 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Ex 2. Steel Sections embedded into Concrete 
 
 
 
 
 
 
 
 
 
 

 

Ex 3. Concrete in filled Steel sections either circular or rectangular. 
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The Following are the steps to Model and design any composite structures in ETABS. 

 

Ex-1: Model and Design a combined steel and composite column PEB structure as shown n 
the figure below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Sectional Details:- 
 

Columns:- 
 

Type: Composite column 
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Tapered Beams 
 
 
 
 
 

 

Following are the varying sizes of tapered beams:- 
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Purlin Beams (ISA 200) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Finally When the tapered Beams are Over designed, try changing the t apered beams sizes 
(Reduce the depths). The changes are as shown below 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Revised tapered beam size is as given below:- 
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Final run and design check: Make a note that since we have two different types of materials 

like steel tapered beams and steel angles and concrete composite columns we have to run 

the design two times in order to check the final design, separately for steel design and one 

more run for composite column design. The final sectional details and results are as shown in 

the figure below. 

 

First run to check the tapered steel beams and purlins 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Second Design run to check the composite column capacity 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

And thus the design is complete 
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Ex 2. Assignment design, Assume suitable sections and dimension and try model and designing a 
composite staircase as shown in the figure below (Type of Building is commercial type, BBMP 

office in yelahanka 4th phase) 
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Modelling and design in ETABS. 
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