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Module 1: Import Data into Excel, and 

Create a Data Model 

Abstract:    This is the first module in a series designed to get you acquainted and comfortable 

using Excel and its built-in data mash-up and analysis features.  We have to review PivotTables 

and models before we got o PowerPivot.  These modules build and refine an Excel workbook 

from scratch, build a data model, then create amazing interactive reports using Power View. The 

modules are designed to demonstrate Microsoft Business Intelligence features and capabilities in 

Excel, PivotTables, Power Pivot, and Power View.  

Note: This module describes data models in Excel 2013. However, the same data modeling and 

Power Pivot features introduced in Excel 2013 also apply to Excel 2016.  

In these modules you learn how to import and explore data in Excel, build and refine a data 

model using Power Pivot, and create interactive reports with Power View that you can publish, 

protect, and share.  

The modules in this series are the following: 

1. Import Data into Excel 2013, and Create a Data Model  
2. Extend Data Model relationships using Excel, Power Pivot, and DAX  

3. Create Map-based Power View Reports  

4. Incorporate Internet Data, and Set Power View Report Defaults  

5. Create Amazing Power View Reports - Part 1  

6. Create Amazing Power View Reports - Part 2  

In this module, you start with a blank Excel workbook.  

The sections in this module are the following: 

Import data from a database  

Import data from a spreadsheet  

Import data using copy and paste  

Create a relationship between imported data  

At the end of this module is a quiz you can take to test your learning.  

This module series uses data describing Olympic Medals, hosting countries, and various 

Olympic sporting events. We suggest you go through each module in order. Also, modules use 

Excel 2013 with Power Pivot enabled. 
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Import data from a database 

We start this module with a blank workbook. The goal in this section is to connect to an external 

data source, and import that data into Excel for further analysis.  

Let’s start by downloading some data from the Internet. The data describes Olympic Medals, and 

is a Microsoft Access database. 

1. Locate these files within your C:\StudentWork folder: 

> OlympicMedals.accdb Access database 

> OlympicSports.xlsx Excel workbook 

> Population.xlsx Excel workbook 

> DiscImage_table.xlsx Excel workbook 

2. In Excel 2013, open a blank workbook. 

3. Click DATA > Get External Data > From Access. The ribbon adjusts dynamically 

based on the width of your workbook, so the commands on your ribbon may look slightly 

different from the following screens. The first screen shows the ribbon when a workbook 

is wide, the second image shows a workbook that has been resized to take up only a 

portion of the screen. 
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4. Select the OlympicMedals.accdb file you downloaded and click Open. The following 

Select Table window appears, displaying the tables found in the database. Tables in a 

database are similar to worksheets or tables in Excel. Check the Enable selection of 

multiple tables box, and select all the tables. Then click OK. 

 

 
5. The Import Data window appears.  

Note: Notice the checkbox at the bottom of the window that allows you to Add this data 

to the Data Model, shown in the following screen. A Data Model is created 
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automatically when you import or work with two or more tables simultaneously. A Data 

Model integrates the tables, enabling extensive analysis using PivotTables, Power Pivot, 

and Power View. When you import tables from a database, the existing database 

relationships between those tables is used to create the Data Model in Excel. The Data 

Model is transparent in Excel, but you can view and modify it directly using the Power 

Pivot add-in. The Data Model is discussed in more detail later in this module. 

 

Select the PivotTable Report option, which imports the tables into Excel and prepares a 

PivotTable for analyzing the imported tables, and click OK.  
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6. Once the data is imported, a PivotTable is created using the imported tables.  

 

 

With the data imported into Excel, and the Data Model automatically created, you’re ready to 

explore the data.  

Explore data using a PivotTable  

Exploring imported data is easy using a PivotTable. In a PivotTable, you drag fields (similar to 

columns in Excel) from tables (like the tables you just imported from the Access database) into 

different areas of the PivotTable to adjust how it presents your data. A PivotTable has four 

areas: FILTERS, COLUMNS, ROWS, and VALUES.  
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It might take some experimenting to determine which area a field should be dragged to. You can 

drag as many or few fields from your tables as you like, until the PivotTable presents your data 

how you want to see it. Feel free to explore by dragging fields into different areas of the 

PivotTable; the underlying data is not affected when you arrange fields in a PivotTable. 

Let’s explore the Olympic Medals data in the PivotTable, starting with Olympic medalists 

organized by discipline, medal type, and the athlete’s country or region. 

1. In PivotTable Fields, expand the Medals table by clicking the arrow beside it. Find the 

NOC_CountryRegion field in the expanded Medals table, and drag it to the COLUMNS 

area. NOC stands for National Olympic Committees, which is the organizational unit for 

a country or region.  

2. Next, from the Disciplines table, drag Discipline to the ROWS area.  

3. Let’s filter Disciplines to display only five sports: Archery, Diving, Fencing, Figure 

Skating, and Speed Skating. You can do this from within the PivotTable Fields area, or 

from the Row Labels filter in the PivotTable itself. 

a. Click anywhere in the PivotTable to ensure the Excel PivotTable is selected. In 

the PivotTable Fields list, where the Disciplines table is expanded, hover over its 

Discipline field and a dropdown arrow appears to the right of the field. Click the 
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dropdown, click (Select All)to remove all selections, then scroll down and select 

Archery, Diving, Fencing, Figure Skating, and Speed Skating. Click OK. 

b. Or, in the Row Labels section of the PivotTable, click the dropdown next to Row 

Labels in the PivotTable, click (Select All) to remove all selections, then scroll 

down and select Archery, Diving, Fencing, Figure Skating, and Speed Skating. 

Click OK. 

4. In PivotTable Fields, from the Medals table, drag Medal to the VALUES area. Since 

Values must be numeric, Excel automatically changes Medal to Count of Medal.  

5. From the Medals table, select Medal again and drag it into the FILTERS area. 

6. Let’s filter the PivotTable to display only those countries or regions with more than 90 

total medals. Here’s how. 

a. In the PivotTable, click the dropdown to the right of Column Labels. 

b. Select Value Filters and select Greater Than…. 

c. Type 90 in the last field (on the right). Click OK. 

 

Your PivotTable looks like the following screen. 

 

With little effort, you now have a basic PivotTable that includes fields from three different 

tables. What made this task so simple were the pre-existing relationships among the tables. 
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Because table relationships existed in the source database, and because you imported all the 

tables in a single operation, Excel could recreate those table relationships in its Data Model. 

But what if your data originates from different sources, or is imported at a later time? Typically, 

you can create relationships with new data based on matching columns. In the next step, you 

import additional tables, and learn how to create new relationships. 

Import data from a spreadsheet 

Now let’s import data from another source, this time from an existing workbook, then specify the 

relationships between our existing data and the new data. Relationships let you analyze 

collections of data in Excel, and create interesting and immersive visualizations from the data 

you import.  

Let’s start by creating a blank worksheet, then import data from an Excel workbook. 

1. Insert a new Excel worksheet, and name it Sports. 

2. Browse to the folder that contains the downloaded sample data files, and open 

OlympicSports.xlsx.  

3. Select and copy the data in Sheet1. If you select a cell with data, such as cell A1, you can 

press Ctrl + A to select all adjacent data. Close the OlympicSports.xlsx workbook. 

4. On the Sports worksheet, place your cursor in cell A1 and paste the data.  

5. With the data still highlighted, press Ctrl + T to format the data as a table. You can also 

format the data as a table from the ribbon by selecting HOME > Format as Table. Since 

the data has headers, select My table has headers in the Create Table window that 

appears, as shown here. 

 

 
 

Formatting the data as a table has many advantages. You can assign a name to a table, 

which makes it easy to identify. You can also establish relationships between tables, 

enabling exploration and analysis in PivotTables, Power Pivot, and Power View.  
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6. Name the table. In TABLE TOOLS > DESIGN > Properties, locate the Table Name 

field and type Sports. The workbook looks like the following screen. 

 
7. Save the workbook. 

Import data using copy and paste 

Now that we’ve imported data from an Excel workbook, let’s import data from a table we find 

on a web page, or any other source from which we can copy and paste into Excel. In the 

following steps, you add the Olympic host cities from a table.  

1. Insert a new Excel worksheet, and name it Hosts. 

2. Select and copy the following table, including the table headers.  

City  NOC_CountryRegion  Alpha-2 Code  Edition  Season  

Melbourne / Stockholm AUS AS 1956 Summer 

Sydney AUS AS 2000 Summer 

Innsbruck AUT AT 1964 Winter 

Innsbruck AUT AT 1976 Winter 

Antwerp BEL BE 1920 Summer 

Antwerp BEL BE 1920 Winter 

Montreal CAN CA 1976 Summer 
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City  NOC_CountryRegion  Alpha-2 Code  Edition  Season  

Lake Placid CAN CA 1980 Winter 

Calgary CAN CA 1988 Winter 

St. Moritz SUI SZ 1928 Winter 

St. Moritz SUI SZ 1948 Winter 

Beijing CHN CH 2008 Summer 

Berlin GER GM 1936 Summer 

Garmisch-Partenkirchen GER GM 1936 Winter 

Barcelona ESP SP 1992 Summer 

Helsinki FIN FI 1952 Summer 

Paris FRA FR 1900 Summer 

Paris FRA FR 1924 Summer 

Chamonix FRA FR 1924 Winter 

Grenoble FRA FR 1968 Winter 

Albertville FRA FR 1992 Winter 

London GBR UK 1908 Summer 

London GBR UK 1908 Winter 

London GBR UK 1948 Summer 

Munich GER DE 1972 Summer 

Athens GRC GR 2004 Summer 

Cortina d'Ampezzo ITA IT 1956 Winter 

Rome ITA IT 1960 Summer 

Turin ITA IT 2006 Winter 

Tokyo JPN JA 1964 Summer 

Sapporo JPN JA 1972 Winter 

Nagano JPN JA 1998 Winter 

Seoul KOR KS 1988 Summer 

Mexico MEX MX 1968 Summer 

Amsterdam NED NL 1928 Summer 

Oslo NOR NO 1952 Winter 

Lillehammer NOR NO 1994 Winter 

Stockholm SWE SW 1912 Summer 

St Louis USA US 1904 Summer 

Los Angeles USA US 1932 Summer 

Lake Placid USA US 1932 Winter 

Squaw Valley USA US 1960 Winter 

Moscow URS RU 1980 Summer 

Los Angeles USA US 1984 Summer 
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City  NOC_CountryRegion  Alpha-2 Code  Edition  Season  

Atlanta USA US 1996 Summer 

Salt Lake City USA US 2002 Winter 

Sarajevo YUG YU 1984 Winter 

1. In Excel, place your cursor in cell A1 of the Hosts worksheet and paste the data.  

2. Format the data as a table. As described earlier in this module, you press Ctrl + T to 

format the data as a table, or from HOME > Format as Table. Since the data has 

headers, select My table has headers in the Create Table window that appears. 

3. Name the table. In TABLE TOOLS > DESIGN > Properties locate the Table Name 

field, and type Hosts. 

4. Select the Edition column, and from the HOME tab, format it as Number with 0 decimal 

places. 

5. Save the workbook. Your workbook looks like the following screen. 

 

Now that you have an Excel workbook with tables, you can create relationships between them. 

Creating relationships between tables lets you mash up the data from the two tables. 
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Create a relationship between imported data 

You can immediately begin using fields in your PivotTable from the imported tables. If Excel 

can’t determine how to incorporate a field into the PivotTable, a relationship must be established 

with the existing Data Model. In the following steps, you learn how to create a relationship 

between data you imported from different sources. 

1. On Sheet1, at the top ofPivotTable Fields, clickAll to view the complete list of available 

tables, as shown in the following screen.  

 
2. Scroll through the list to see the new tables you just added. 
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3. Expand Sports and select Sport to add it to the PivotTable. Notice that Excel prompts 

you to create a relationship, as seen in the following screen.  

 

This notification occurs because you used fields from a table that’s not part of the 

underlying Data Model. One way to add a table to the Data Model is to create a 

relationship to a table that’s already in the Data Model. To create the relationship, one of 

the tables must have a column of unique, non-repeated, values. In the sample data, the 

Disciplines table imported from the database contains a field with sports codes, called 

SportID. Those same sports codes are present as a field in the Excel data we imported. 

Let’s create the relationship. 

4. Click CREATE... in the highlighted PivotTable Fields area to open the Create 

Relationship dialog, as shown in the following screen. 

 

 
5. In Table, choose Disciplines from the drop down list.  

6. In Column (Foreign), choose SportID. 

7. In Related Table, choose Sports.  

8. In Related Column (Primary), choose SportID.  

9. Click OK. 
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The PivotTable changes to reflect the new relationship. But the PivotTable doesn’t look right 

quite yet, because of the ordering of fields in the ROWS area. Discipline is a subcategory of a 

given sport, but since we arranged Discipline above Sport in the ROWS area, it’s not organized 

properly. The following screen shows this unwanted ordering. 

 

1. In the ROWS area, move Sport above Discipline. That’s much better, and the PivotTable 

displays the data how you want to see it, as shown in the following screen. 
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Behind the scenes, Excel is building a Data Model that can be used throughout the workbook, in 

any PivotTable, PivotChart, in Power Pivot, or any Power View report. Table relationships are 

the basis of a Data Model, and what determine navigation and calculation paths.  

In the next module, Extend Data Model relationships using Excel 2013, Power Pivot, and 

DAX, you build on what you learned here, and step through extending the Data Model using a 

powerful and visual Excel add-in called Power Pivot. You also learn how to calculate columns in 

a table, and use that calculated column so that an otherwise unrelated table can be added to your 

Data Model. 
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Checkpoint and Quiz 

Review What You’ve Learned  

You now have an Excel workbook that includes a PivotTable accessing data in multiple tables, 

several of which you imported separately. You learned to import from a database, from another 

Excel workbook, and from copying data and pasting it into Excel.  

To make the data work together, you had to create a table relationship that Excel used to 

correlate the rows. You also learned that having columns in one table that correlate to data in 

another table is essential for creating relationships, and for looking up related rows.  
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Module 2: Extend Data Model relationships 

using Excel, Power Pivot, and DAX 

Applies To: Excel 2013  

Abstract:    This is the second module in a series. In the first module, Import Data into and 

Create a Data Model, an Excel workbook was created using data imported from multiple sources.  

In this module, you use Power Pivot to extend the Data Model, create hierarchies, and build 

calculated fields from existing data to create new relationships between tables. 

The sections in this module are the following: 

Add a relationship using Diagram View in Power Pivot  

Extend the Data Model using calculated columns  

Create a hierarchy  

Use hierarchies in PivotTables  

Checkpoint and Quiz  

At the end of this module is a quiz you can take to test your learning.  

This series uses data describing Olympic Medals, hosting countries, and various Olympic 

sporting events. The modules in this series are the following: 

1. Import Data into Excel , and Create a Data Model  

2. Extend Data Model relationships using Excel, Power Pivot, and DAX 

3. Create Map-based Power View Reports  

4. Incorporate Internet Data, and Set Power View Report Defaults  

5. Create Amazing Power View Reports - Part 1  

6. Create Amazing Power View Reports - Part 2  

We suggest you go through them in order.  

These modules use Excel 2013 with Power Pivot enabled 
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Add a relationship using Diagram View in Power Pivot 

In this section, you use the Microsoft Office Power Pivot in Excel 2013 add-in to extend the 

model. Using Diagram View in Microsoft SQL Server Power Pivot for Excel makes creating 

relationships easy. First, you need to make sure you have the Power Pivot add-in enabled. 

Add Power Pivot to the Excel ribbon by enabling the Power Pivot add-in  

When Power Pivot is enabled, you see a ribbon tab in Excel 2013 called POWER PIVOT. To 

enable Power Pivot, follow these steps. 

1. Go to FILE > Options > Add-Ins.  

2. In the Manage box near the bottom, click COM Add-ins> Go.  

3. Check the Microsoft Office Power Pivot in Microsoft Excel 2013 box, and then click 

OK. 

The Excel ribbon now has a POWER PIVOT tab. 

 

Add a relationship using Diagram View in Power Pivot  

The Excel workbook includes a table called Hosts. We imported Hosts by copying it and pasting 

it into Excel, then formatted the data as a table. To add the Hosts table to the Data Model, we 

need to establish a relationship. Let’s use Power Pivot to visually represent the relationships in 

the Data Model, and then create the relationship. 

1. In Excel, click the Hosts tab to make it the active sheet. 

2. On the ribbon, select POWER PIVOT > Tables > Add to Data Model. This step adds 

the Hosts table to the Data Model. It also opens the Power Pivot add-in, which you use to 

perform the remaining steps in this task. 

3. Notice that the Power Pivot window shows all the tables in the model, including Hosts. 

Click through a couple of tables. In Power Pivot you can view all of the data that your 

model contains, even if they aren’t displayed in any worksheets in Excel, such as the 

Disciplines, Events, and Medals data below, as well as S_Teams,W_Teams, and 

Sports.  
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4. In the Power Pivot window, in the View section, click Diagram View. 

5. Use the slide bar to resize the diagram so that you can see all objects in the diagram. 

Rearrange the tables by dragging their title bar, so they’re visible and positioned next to 

one another. Notice that four tables are unrelated to the rest of the tables: Hosts, Events, 

W_Teams, and S_Teams. 
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6. You notice that both the Medals table and the Events table have a field called 

DisciplineEvent. Upon further inspection, you determine that the DisciplineEvent field in 

the Events table consists of unique, non-repeated values.  

Note:  The DisciplineEvent field represents a unique combination of each Discipline and Event. 

In the Medals table, however, the DisciplineEvent field repeats many times. That makes sense, 

because each Discipline+Event combination results in three awarded medals (gold, silver, 

bronze), which are awarded for each Olympics Edition the Event is held. So the relationship 

between those tables is one (one unique Discipline+Event entry in the Disciplines table) to many 

(multiple entries for each Discipline+Event value). 
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1. Create a relationship between the Medals table and the Events table. While in Diagram 

View, drag the DisciplineEvent field from the Events table to the DisciplineEvent field in 

Medals. A line appears between them, indicating a relationship has been established. 

2. Click the line that connects Events and Medals. The highlighted fields define the 

relationship, as shown in the following screen. 

 

 

3. To connect Hosts to the Data Model, we need a field with values that uniquely identify 

each row in the Hosts table. Then we can search our Data Model to see if that same data 

exists in another table. Looking in Diagram View doesn’t allow us to do this. With Hosts 

selected, switch back to Data View. 

4. After examining the columns, we realize that Hosts doesn’t have a column of unique 

values. We’ll have to create it using a calculated column, and Data Analysis Expressions 

(DAX). 

It’s nice when the data in your Data Model has all the fields necessary to create relationships, 

and mash up data to visualize in Power View or PivotTables. But tables aren’t always so 

cooperative, so the next section describes how to create a new column, using DAX, that can be 

used to create a relationship between tables. 
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Extend the Data Model using calculated columns 

To establish a relationship between the Hosts table and the Data Model, and thereby extend our 

Data Model to include the Hosts table, Hosts must have a field that uniquely identifies each row. 

In addition, that field must correspond to a field in the Data Model. Those corresponding fields, 

one in each table, are what enables the tables’ data to be associated.  

Since the Hosts table doesn’t have such a field, you need to create it. To preserve the integrity of 

the Data Model, you can’t use Power Pivot to edit or delete existing data. You can, however, 

create new columns by using calculated fields based on the existing data. 

By looking through the Hosts table, then looking at other Data Model tables, we find a good 

candidate for a unique field we could create in Hosts, and then associate with a table in the Data 

Model. Both tables will require a new, calculated column in order to meet the requirements 

necessary to establish a relationship. 

In Hosts, we can create a unique calculated column by combining the Edition field (the year of 

the Olympics event) and the Season field (Summer or Winter). In the Medals table there is also 

an Edition field and a Season field, so if we create a calculated column in each of those tables 

that combines the Edition and Season fields, we can establish a relationship between Hosts and 

Medals. The following screen shows the Hosts table, with its Edition and Season fields selected 
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Create calculated columns using DAX  

Let’s start with the Hosts table. The goal is to create a calculated column in the Hosts table, and 

then in the Medals table, which can be used to establish a relationship between them.  

In Power Pivot, you can use Data Analysis Expressions (DAX) to create calculations. DAX is a 

formula language for Power Pivot and PivotTables, designed for the relational data and 

contextual analysis available in Power Pivot. You can create DAX formulas in a new Power 

Pivot column, and in the Calculation Area in Power Pivot.  

1. In Power Pivot, select HOME > View > Data View to make sure Data View is selected, 

rather than being in Diagram View. 

2. Select the Hosts table in Power Pivot. Adjacent to the existing columns is an empty 

column titled Add Column. Power Pivot provides that column as a placeholder. There are 

many ways to add a new column to a table in Power Pivot, one of which is to simply 

select the empty column that has the title Add Column. 

 

 

 
3. In the formula bar, type the following DAX formula. The CONCATENATE function 

combines two or more fields into one. As you type, AutoComplete helps you type the 

fully qualified names of columns and tables, and lists the functions that are available. Use 

tab to select AutoComplete suggestions. You can also just click the column while typing 
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your formula, and Power Pivot inserts the column name into your formula.  

 

=CONCATENATE([Edition],[Season]) 

4. When you finish building the formula, press Enter to accept it. 

5. Values are populated for all the rows in the calculated column. If you scroll down 

through the table, you see that each row is unique – so we’ve successfully created a field 

that uniquely identifies each row in the Hosts table. Such fields are called a primary key.  

6. Let’s rename the calculated column to EditionID. You can rename any column by 

double-clicking it, or by right-clicking the column and choosing Rename Column. When 

completed, the Hosts table in Power Pivot looks like the following screen. 

 

 

The Hosts table is ready. Next let’s create a calculated column in Medals that matches the 

format of the EditionID column we created in Hosts, so we can create a relationship between 

them. 
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1. Start by creating a new column in the Medals table, like we did for Hosts. In Power 

Pivot select the Medals table, and click Design > Columns > Add. Notice that Add 

Column is selected. This has the same effect as simply selecting Add Column. 

2. The Edition column in Medals has a different format than the Edition column in Hosts. 

Before we combine, or concatenate, the Edition column with the Season column to create 

the EditionID column, we need to create an intermediary field that gets Edition into the 

right format. In the formula bar above the table, type the following DAX formula.  

= YEAR([Edition]) 

3. When you finish building the formula, press Enter. Values are populated for all the rows 

in the calculated column, based on the formula you entered. If you compare this column 

to the Edition column in Hosts, you’ll see that these columns have the same format. 

4. Rename the column by right-clicking CalculatedColumn1 and selecting Rename 

Column. Type Year, and then press Enter. 

5. When you created a new column, Power Pivot added another placeholder column called 

Add Column. Next we want to create the EditionID calculated column, so select Add 

Column. In the formula bar, type the following DAX formula and press Enter. 

 

=CONCATENATE([Year],[Season]) 

6. Rename the column by double-clicking CalculatedColumn1 and typing EditionID. 

7. Sort the column in ascending order. The Medals table in Power Pivot now looks like the 

following screen. 
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Notice many values are repeated in the Medals table EditionID field. That’s okay and expected, 

since during each edition of the Olympics (now represented by the EditionID value) many 

medals were awarded. What is unique in the Medals table is each awarded medal. The unique 

identifier for each record in the Medals table, and its designated primary key, is the MedalKey 

field. 

The next step is to create a relationship between Hosts and Medals.  

Create a relationship using calculated columns  

Next let’s use the calculated columns we created to establish a relationship between Hosts and 

Medals. 

1. In the Power Pivot window, select Home > View > Diagram View from the ribbon. You 

can also switch between Grid view and Diagram view using the buttons at the bottom of 

the PowerView window, as shown in the following screen. 

 

 
2. Expand Hosts so you can view all of its fields. We created the EditionID column to act as 

the Hosts table primary key (unique, non-repeated field), and created an EditionID 

column in the Medals table to enable establishment of a relationship between them. We 

need to find them both, and create a relationship. Power Pivot provides a Find feature on 

the ribbon, so you can search your Data Model for corresponding fields. The following 

screen shows the Find Metadata window, with EditionID entered in the Find What 
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field.  

 
3. Position the Hosts table so that it is next to Medals. 

4. Drag the EditionID column in Medals to the EditionID column in Hosts. Power Pivot 

creates a relationship between the tables based on the EditionID column, and draws a line 

between the two columns, indicating the relationship. 
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In this section, you learned a new technique for adding new columns, created a calculated 

column using DAX, and used that column to establish a new relationship between tables. The 

Hosts table is now integrated into the Data Model, and its data is available to the PivotTable in 

Sheet1. You can also use the associated data to create additional PivotTables, PivotCharts, 

Power View reports, and much more.  

Create a hierarchy 

Most Data Models include data that is inherently hierarchical. Common examples include 

calendar data, geographical data, and product categories. Creating hierarchies within Power Pivot 

is useful because you can drag one item to a report – the hierarchy – instead of having to 

assemble and order the same fields over and over.  

The Olympics data is also hierarchical. It’s helpful to understand the Olympics hierarchy, in 

terms of sports, disciplines, and events. For each sport, there is one or more associated 

disciplines (sometimes there are many). And for each discipline, there is one or more events 

(again, sometimes there are many events in each discipline). The following image illustrates the 

hierarchy. 
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In this section you create two hierarchies within the Olympic data you’ve been using in this 

module. You then use these hierarchies to see how hierarchies make organizing data easy in 

PivotTables and, in a subsequent module, in Power View.  

Create a Sport hierarchy  

1. In Power Pivot, switch to Diagram View. Expand the Events table so that you can more 

easily see all of its fields. 

2. Press and hold Ctrl, and click the Sport, Discipline, and Event fields. With those three 

fields selected, right-click and select Create Hierarchy. A parent hierarchy node, 

Hierarchy 1, is created at the bottom of the table, and the selected columns are copied 

under the hierarchy as child nodes. Verify that Sport appears first in the hierarchy, then 

Discipline, then Event. 

3. Double-click the title, Hierarchy1, and type SDE to rename your new hierarchy. You 

now have a hierarchy that includes Sport, Discipline and Event. Your Events table now 

looks like the following screen. 
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Create a Location hierarchy  

1. Still in Diagram View in Power Pivot, select the Hosts table and click the Create 

Hierarchy button in the table header, as shown in the following screen.  

 
 

An empty hierarchy parent node appears at the bottom of the table. 

2. Type Locations as the name for your new hierarchy. 

3. There are many ways to add columns to a hierarchy. Drag the Season, City and 

NOC_CountryRegion fields onto the hierarchy name (in this case, Locations) until the 

hierarchy name is highlighted, then release to add them.  

4. Right-click EditionID and select Add to Hierarchy. Choose Locations. 

5. Ensure that your hierarchy child nodes are in order. From top to bottom, the order should 

be: Season, NOC, City, EditionID. If your child nodes are out of order, simply drag them 

into the appropriate ordering in the hierarchy. Your table should look like the following 

screen. 

 

Your Data Model now has hierarchies that can be put to good use in reports. In the next section, 

you learn how these hierarchies can make your report creation faster, and more consistent. 
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Use hierarchies in PivotTables 

Now that we have a Sports hierarchy and Locations hierarchy, we can add them to PivotTables 

or Power View, and quickly get results that include useful groupings of data. Prior to creating 

hierarchies, you had to add individual fields to the PivotTable, and arrange those fields how you 

wanted them to be viewed.  

In this section you use the hierarchies created in the previous section to quickly refine your 

PivotTable. Then, you create the same PivotTable view using the individual fields in the 

hierarchy, just so you can compare using hierarchies to using individual fields. 

1. Go back to Excel. 

2. In Sheet1, remove the fields from the ROWS area of PivotTable Fields, then remove all 

the fields from the COLUMNS area. Make sure the PivotTable is selected (which is now 

quite small, so you can choose cell A1 to make sure your PivotTable is selected). The 

only remaining fields in the PivotTable fields are Medal in the FILTERS area, and Count 

of Medal in the VALUES area. Your nearly empty PivotTable should look like the 

following screen. 
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3. From the PivotTable Fields area, drag SDE from the Events table to the ROWS area. 

Then drag Locations from the Hosts table into the COLUMNS area. Just by dragging 

those two hierarchies, your PivotTable is populated with a lot of data, all of which is 

arranged in the hierarchy you defined in the previous steps. Your screen should look like 

the following screen. 

 
4. Let’s filter that data a bit, and just see the first ten rows of events. In the PivotTable, click 

the arrow in Row Labels, click (Select All) to remove all selections, then click the boxes 
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beside the first ten Sports. Your PivotTable now looks like the following screen. 

 
5. You can expand any of those Sports in the PivotTable, which is the top level of the SDE 

hierarchy, and see information in the next level down in the hierarchy (discipline). If a 

lower level in the hierarchy exists for that discipline, you can expand the discipline to see 

its events. You can do the same for the Location hierarchy, the top level of which is 

Season, which shows up as Summer and Winter in the PivotTable. When we expand the 

Aquatics sport, we see all of its child discipline elements and their data. When we expand 

the Diving discipline under Aquatics, we see its child events too, as shown in the 
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following screen. We can do the same for Water Polo, and see that it has only one event. 

 

By dragging those two hierarchies, you quickly created a PivotTable with interesting and 

structured data that you can drill into, filter, and arrange.  

Now let’s create the same PivotTable, without the benefit of hierarchies. 

1. In the PivotTable Fields area, remove Locations from the COLUMNS area. Then remove 

SDE from the ROWS area. You’re back to a basic PivotTable. 

2. From the Hosts table, drag Season, City, NOC_CountryRegion, and EditionID into the 

COLUMNS area, and arrange them in that order, from top to bottom. 

3. From the Events table, drag Sport, Discipline, and Event into the ROWS area, and 

arrange them in that order, from top to bottom.  

4. In the PivotTable, filter Row Labels to the top ten Sports.  
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5. Collapse all the rows and columns, then expand Aquatics, then Diving and Water Polo . 

Your workbook looks like the following screen. 

 

The screen looks similar, except that you dragged seven individual fields into the PivotTable 

Fields areas, instead of simply dragging two hierarchies. If you’re the only person creating 

PivotTables or Power View reports based on this data, creating hierarchies might only seem 

convenient. But when many people are creating reports, and must figure out the proper ordering 

of fields to get the views correct, hierarchies quickly become a productivity enhancement, and 

enable consistency.  

In another module, you learn how to use hierarchies and other fields in visually engaging reports 

created using Power View.  
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Checkpoint and Quiz 

Review what you learned  

Your Excel workbook now has a Data Model that includes data from multiple sources, related 

using existing fields and calculated columns. You also have hierarchies that reflect the structure 

of data within your tables, which make creating compelling reports quick, consistent, and easy.  

You learned that creating hierarchies lets you specify the inherent structure within your data, and 

quickly use hierarchical data in your reports. 
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QUIZ  

Want to see how well you remember what you learned? Here’s your chance. The following quiz 

highlights features, capabilities, or requirements you learned about in this module. At the bottom 

of the page, you’ll find the answers. Good luck!  

Question 1: Which of the following views let you create relationships between two tables? 

A: You create relationships between tables in Power View. 

B: You create relationships between tables using Design View in Power Pivot. 

C: You create relationships between tables using Grid View in Power Pivot 

D: All of the above 

Question 2: TRUE or FALSE: You can establish relationships between tables based on a unique 

identifier that is created by using DAX formulas. 

A: TRUE 

B: FALSE 

Question 3: In which of the following can you create a DAX formula? 

A: In the Calculation Area of Power Pivot. 

B: In a new column in Power Pivotf. 

C: In any cell in Excel 2013. 

D: Both A and B. 

Question 4: Which of the following is true about hierarchies? 

A: When you create a hierarchy, the included fields are no longer available individually. 

B: When you create a hierarchy, the included fields including their hierarchy can be used in 

client tools by simply dragging the hierarchy to a Power View or PivotTable area. 

C: When you create a hierarchy, the underlying data in the Data Model is combined into one 

field. 

D: You cannot create hierarchies in Power Pivot. 
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Quiz answers  

1. Correct answer: D 

2. Correct answer: A 

3. Correct answer: D 

4. Correct answer: B 
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Module 3: Create Map-based Power View 

Reports 

Applies To: Excel 2013  

Abstract:    This is the third module in a series. In the first module, Import Data into Excel 2013, 

and Create a Data Model, you created an Excel workbook from scratch using data imported from 

multiple sources, and its Data Model was created automatically by Excel. The second 

module,Extend Data Model relationships using Excel 2013, Power Pivot, and DAX, you learned 

how to extend the Data Model and created hierarchies within the data.  

In this module, you use that extended Data Model to build compelling reports that include 

multiple visualizations using Power View. 

The sections in this module are the following: 

Create a Power View report  

Create calculated fields for Power View and PivotTables  

Set field defaults, table behaviors, and data categories  

Checkpoint and Quiz  

At the end of this module is a quiz you can take to test your learning.  

This series uses data describing Olympic Medals, hosting countries, and various Olympic 

sporting events. The modules in this series are the following: 

1. Import Data into Excel 2013, and Create a Data Model  

2. Extend Data Model relationships using Excel 2013, Power Pivot, and DAX  

3. Create Map-based Power View Reports  
4. Incorporate Internet Data, and Set Power View Report Defaults  

5. Create Amazing Power View Reports - Part 1  

6. Create Amazing Power View Reports - Part 2  

We suggest you go through them in order.  
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Create a Power View report 

In the previous modules, you created an Excel workbook with a PivotTable containing data 

about Olympic medals and events. If you didn’t complete the previous module, you can 

download the workbook from the end of the previous module from here.  

In this section, you create a Power View report to visually represent the Olympics data.  

1. In Excel, click INSERT > Reports > Power View Reports.  

 

 
2. A blank Power View report appears as a sheet in the workbook. 

 

 

3. In the Power View Fields area, click the arrow beside Hosts to expand it, and click City.  

https://download.microsoft.com/download/4/c/0/4c08af92-6a46-4736-88eb-5e422d2eb5a8/book1_end-of-tutorial2.xlsx
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4. Expand the Medals table, and click Sport. With this, Power View lists the Sport beside 

the city, as shown in the following screen. 

 
5. In the FIELDS area of Power View Fields, click the arrow next to Sport and select 

Count (Not Blank). Now Power View is counting the sports, rather than listing them, as 

shown in the following screen. 

 

 
6. On the ribbon, select DESIGN > Switch Visualization > Map. The DESIGN tab is only 

available if the Power View table is selected. You may get a warning about enabling 

external content when you switch to the Map visualization. 

7. A map replaces the table as the visualization. On the map, blue circles of varying size 

indicate the number of different sport events held at each Olympic Host location. But it 

might be more interesting to see which were summer events, and which were winter. 
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8. To make the most use of the report area, let’s collapse the Filters area. Click the arrow in 

the upper right corner of the Filters area. 

9. In Power View Fields, expand Medals. Drag the Season field down to the COLOR area. 

That’s better: the map now displays blue bubbles for summer sports, and red bubbles for 

winter sports, as shown in the following screen. You can resize the visualization by 

dragging any of its corners. 

 

 

Now you have a Power View report that visualizes the number of sporting events in various 

locations, using a map, color-coded based on season. And it just took a few clicks.  

Create calculated fields for Power View and PivotTables 

Power View uses the underlying Data Model to create visualizations. With Power Pivot and 

DAX, you can extend the Data Model by creating custom formulas, then create reports based on 

those formulas and calculations in PivotTables and in Power View.  
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Create a calculated field in Power Pivot 

1. In Excel, click Power Pivot > Data Model > Manage to display the Power Pivot window.  

2. Select the Medals table. Make sure the Calculation Area is displayed. The Calculation 

Area is found below the table data, and is used for creating, editing, and managing 

calculated fields. To view the Calculation Area, select Home > View > Calculation Area, 

as shown in the following screen. 

 

 
3. Let’s calculate the number of Olympic editions. In the Calculation Area, select the cell 

directly below the Edition column. From the ribbon, select AutoSum > Distinct Count, as 

shown in the following screen.  

 

 
4. Power Pivot creates a DAX expression for the active cell in the Calculation Area. In this 

case, Power Pivot automatically created the following DAX formula: 

 

Distinct Count of Edition:=DISTINCTCOUNT([Edition]) 

 

Additional calculations in AutoSum are just as easy, such as Sum, Average, Min, Max, 

and others.  

5. Save the Excel workbook. The Data Model is updated with the new calculated field. 

When you return to the Power View tab in Excel, a warning lets you know the Data 

Model has been updated, as shown in the following screen. 
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We’ll use this Distinct Count of Edition calculated field later on in the modules.  

Create a calculated field using DAX in Power Pivot 

The AutoSum calculation is useful, but there are times when more customized calculations are 

required. You can create DAX formulas in the Calculation Area, just like you create formulas in 

Excel. Let’s create a DAX formula and then see how it appears in our Data Model, and as a 

result, is available in our PivotTable and in Power View.  

1. Open the Power Pivot window. In the Calculation Area, select the cell directly below the 

AutoSum calculation you completed in the previous section, as shown in the following 

screen. 

 

 
2. Let’s calculate the percentage of all medals. In the formula bar, type the following DAX 

formula. IntelliSense provides available commands based on what you type, and you can 

press Tab to select the highlighted IntelliSense option. 

 

Percentage of All Medals:=[Count of Medal]/CALCULATE([Count of 

Medal],ALL(Medals)) 

3. When you switch back to the Excel window, Excel lets you know the Data Model has 

been updated. In Excel, select the PivotTable in Sheet1. In PivotTable Fields, expand the 

Medals table. At the bottom of the fields list are the two calculated fields we just created, 

as shown in the following screen. Select Percentage of All Medals. 
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4. In the PivotTable, the Percentage of All Medals field appears after Count of Medal. It’s 

not formatted as a percentage, so select those fields (you can select them all at once, by 

hovering over the top of one of the Percentage of All Medals field, until the cursor 

becomes a down arrow, and then clicking). Once they’re selected, click HOME > 

Number > Percentage. In the same section of the ribbon, adjust the number of decimal 

places to two. Your pivot table looks like the following screen. 
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In a previous module, we filtered the Sports field to only the first ten, alphabetically, which is 

why we only see Aquatics through Boxing, and why the percentage in the Grand Total is 

29.16%, rather than 100%. What this does tell us, of course, is that these first ten sports account 

for 29.16% of all medals awarded in the Summer games. We also can see that Aquatics 

accounted for 10.88% of all medals. 

Since the Percentage of All Medals field is in the Data Model, it’s also available in Power View. 

You can also create calculated fields from the Power Pivot tab while in Power View. Whether 

you create a calculated field in Power Pivot or while in Power View, the result is the same: the 

Data Model is updated to include the calculated field, and makes it available to all client tools. 

Set field defaults, table behaviors, and data categories 

Another way to streamline report creation in Power View is by setting a default field set. When 

you set a default field set for a table, you can simply click that table in Power View, and the 

default set of fields is automatically added to a new report.  

In this section, you set defaults for your workbook that will save you time when creating reports. 
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Create the Default Field Set for a table  

1. The Power Pivot window should still be available. If not, click Power Pivot > Data 

Model> Manage. In Power Pivot, select Home > View > Data View to make sure Data 

View is selected. Select the Medals table. 

2. On the Advanced tab, click Reporting Properties > Default Field Set. A window appears 

that lets you specify default fields for tables created using client tools such as Power 

View.  

3. Select Sport, Event, EditionID, Athlete, and Medal in the left pane, and click Add -> to 

make them the default fields. Make sure they appear in the right pane, Default fields, in 

the order they were listed. The Default Field Set window looks like the following screen. 

 

 
4. Click OK to save the default field set for the Medals table. 

5. To see how this works, switch to the Power View sheet in Excel.  

6. Click anywhere on the blank report canvas, to make sure you don’t have an existing 

visualization selected. Your Power View sheet currently only has one visualization, 

which is the map you created earlier.  

7. In the Power View Fields list, click the Medals table name. Power View creates a table 

and automatically adds the five default fields from the Medals table, in the order you 

specified, as shown in the following screen. If you accidentally click on the triangle 

beside Medals, the table simply expands, rather than adding a new table with default 

fields. 
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Set Table Behavior  

You can also set the default table behavior, which Power View uses to automatically create 

report labels for the table. This becomes useful when you create visualizations from the same 

table, perhaps for many different reports. We use default table behavior in the next few steps, so 

let’s set it now. 

1. Back in Power Pivot, with the Medals table selected, select Advanced > Reporting 

Properties > Table Behavior. A window appears where you can specify table behavior.  

2. In the Table Behavior window, the Row Identifier is the column that contains only 

unique keys and no blank values. This is often the table’s primary key, but doesn’t have 

to be. You have to select a Row Identifier before making other selections in the window. 

Select MedalKey as the Row Identifier. 

3. In the Keep Unique Rows section, select AthleteID. Fields you select here have row 

values that should be unique, and should not be aggregated when creating Pivot Tables or 

Power View reports.  

 

Note: If you have trouble with reports that don’t aggregate how you want them to, ensure 

the field you want to aggregate is not selected in the Keep Unique Rows fields.  

4. For Default Label, select a key that should be used as a default report label. Select Sport.  

5. For Default Image, leave the selection as [No Column Selected], since you haven’t added 

images yet. The Table Behavior window looks like the following screen. 
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6. Click OK. On the Power View sheet in Excel, select the table you created in the previous 

steps. From the ribbon, select DESIGN > Table > Card. The table you created changes 

into a collection of Cards; the data is the same, but the visualization of the data has 

changed. The table now looks like the following screen. 

 

Notice that the Sport field is larger than the rest, and appears as a heading for each card. That’s 

because you set Sport as the Default Label in the Table Behavior window when you were in 

Power Pivot. 
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Set Data Categories for fields  

In order for Power View to dynamically create reports based on underlying data, such as 

location, fields that contain such data must be properly categorized. For the Olympics data, let’s 

specify the categories for a few fields.  

1. In Power Pivot, select Hosts. Select the NOC_CountryRegion field. From Advanced > 

Reporting Properties > Data Category: click the arrow and select Country/Region from 

the list of available data categories, as shown in the following screen. 

 

 
2. In Medals, select the NOC_CountryRegion column. Again, change the Data Category to 

Country/Region. 

3. Return to Excel, and select the Power View sheet. Expand the Medals table in Power 

View Fields, and notice that the NOC_CountryRegion field now has a small globe icon 

beside it. The globe indicates that NOC_CountryRegion contains a geographic location, 

as shown in the following screen.  

 

 

We’ll use that geographic location in an upcoming module. It’s time to save your work, review 

what you’ve learned, and then get ready to dive into the next module. 
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Checkpoint and Quiz 

Review what you learned  

In this module you learned how to create a map-based Power View visualization, then created 

calculated fields to extend your Data Model, and analyze the data in a different way. You also 

learned how to create default field sets for a table, which streamlined creating a new Power View 

table pre-populated with the default set of fields. You also learned how to define default table 

behavior, so the ordering and labeling of new tables was fast and consistent. 

In the next module in this series, you build on what you learned here. There’s a lot of data out 

there, and in the next module, you add Internet data into your Data Model, and bring in images 

so that your Power View reports can really shine.  

  

QUIZ  

Want to see how well you remember what you learned? Here’s your chance. The following quiz 

highlights features, capabilities, or requirements you learned about in this module. At the bottom 

of the page, you’ll find the answers. Good luck!  

Question 1: Where does Power View get its data to create Power View reports? 

A: Only from worksheets included in Excel. 

B: Only from the Data Model.  

C: Only from data imported from external sources. 

D: From the Data Model, and from any data that exists in the worksheets in Excel. 

Question 2: Which of the following is true about a default field set? 

A: You can only create one default field set for the entire Data Model. 

B: In Power View, clicking the table name in Power View Fields creates a table visualization 

that is automatically populated with the its default field set. 

C: If you create a default field set for a table, all other fields in that table are disabled. 

D: All of the above 

Question 3: Which of the following is true about Calculated Fields? 
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A: When you create them in Power Pivot, they appear in Power View as fields available in the 

table in which they were created. 

B: If you create them in the Calculation Area of Power Pivot, they are hidden from all client 

tools. 

C: When you create them in Power Pivot, they each appear as individual tables in all client tools. 

D: Both A and B. 

Question 4: In the Default Behavior Table window, if you select a field in Keep Unique Rows, 

which of the following is correct?  

A: You must explicitly select “Sum this field” from Power View Fields in order to aggregate the 

field. 

B: The field is always aggregated in Power View or PivotTables. 

C: The field is never aggregated in Power View or PivotTables. 

D: Selecting Keep Unique Rows has no effect on the behavior of the field in Power View or 

PivotTables. 

Quiz answers  

1. Correct answer: B 

2. Correct answer: B 

3. Correct answer: A 

4. Correct answer: C 
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Module 4: Incorporate Internet Data, and Set 

Power View Report Defaults 

Applies To: Excel 2016 Excel 2013  

Abstract:    At the end of the previous module, Create Map-based Power View Reports, your 

Excel workbook included data from various sources, a Data Model based on relationships 

established using Power Pivot, and a map-based Power View report with some basic Olympics 

information. In this module, we extend and optimize the workbook with more data, interesting 

graphics, and prepare the workbook to easily create amazing Power View reports. 

The sections in this module are the following: 

Import Internet-based image links into the Data Model  

Use Internet data to complete the Data Model  

Hide tables and fields for easier report creation  

Checkpoint and Quiz  

At the end of this module is a quiz you can take to test your learning.  

This series uses data describing Olympic Medals, hosting countries, and various Olympic 

sporting events. The modules in this series are the following: 

1. Import Data into Excel 2013, and Create a Data Model  

2. Extend Data Model relationships using Excel 2013, Power Pivot, and DAX  

3. Create Map-based Power View Reports  

4. Incorporate Internet Data, and Set Power View Report Defaults  
5. Create Amazing Power View Reports - Part 1  

6. Create Amazing Power View Reports - Part 2  
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Import Internet-based image links into the Data Model 

The amount of data is constantly growing, and so is the expectation to be able to visualize it. 

With additional data comes different perspectives, and opportunities to review and consider how 

data interacts in many different ways. Power Pivot and Power View bring your data together – as 

well as external data – and visualize it in fun, interesting ways.  

In this section, you extend the Data Model to include images of flags for the regions or countries 

that participate in the Olympics, and then add images to represent the contested disciplines in the 

Olympic Games. 

Add flag images to the Data Model  

Images enrich the visual impact of the Power View reports. In the following steps you add two 

image categories – an image for each discipline, and an image of the flag that represents each 

region or country.  

You have two tables which are good candidates for incorporating this information: the 

Discipline table for the discipline images, and the Hosts table for flags. To make this interesting, 

you use images found on the Internet, and use a link to each image so it can render for anyone 

viewing a report, regardless of where they are. 

1. After searching around the Internet, you find a good source for flag images for each 

country or region: the CIA.gov World Factbook site. For example, when you click on the 

following link, you get an image of the flag for France. 

 

https://www.cia.gov/library/publications/the-world-factbook/graphics/flags/large/fr-

lgflag.gif 

 

When you investigate further and find other flag image URLs on the site, you realize the 

URLs have a consistent format, and that the only variable is the two-letter country or 

region code. So if you knew each two-letter country or region code, you could just insert 

that two-letter code into each URL, and get a link to each flag. That’s a plus, and when 

you look closely at your data, you realize that the Hosts table contains two-letter country 

or region codes. Great.  

2. You need to create a new field in the Hosts table to store the flag URLs. In an earlier 

module you used DAX to concatenate two fields, and we’ll do the same for the flag 

URLs. In Power Pivot, select the empty column that has the title Add Column in the 

Hosts table. In the formula bar, type the following DAX formula (or you can copy and 

paste it into the formula column). It looks long, but most of it is the URL we want to use 

from the CIA Factbook. 

 

=REPLACE("https://www.cia.gov/library/publications/the-world-

factbook/graphics/flags/large/fr-lgflag.gif",82,2,LOWER([Alpha-2 code])) 

 

In that DAX function you did a few things, all in one line. First, the DAX function 
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REPLACE replaces text in a given text string, so by using that function you replaced the 

part of the URL that referenced France’s flag (fr) with the appropriate two-letter code for 

each country or region. The number 82 tells the REPLACE function to begin the 

replacement 82 characters into the string. The 2 that follows tells REPLACE how many 

characters to replace. Next, you may have noticed that the URL is case-sensitive (you 

tested that first, of course) and our two-letter codes are uppercase, so we had to convert 

them to lowercase as we inserted them into the URL using the DAX function LOWER.  

3. Rename the column with the flag URLs to FlagURL. Your Power Pivot screen now looks 

like the following screen. 
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4. Return to Excel and select the PivotTable in Sheet1. In PivotTable Fields, select ALL. 

You see the FlagURL field you added is available, as shown in the following screen. 

 

Notes: In some instances, the Alpha-2 code used by the CIA.gov World Factbook site 

doesn’t match the official ISO 3166-1 Alpha-2 code provided in the Hosts table, which 

means some flags don’t display properly. You can fix that, and get the right Flag URLs, 

by making the following substitutions directly in your Hosts table in Excel, for each 

affected entry. The good news is that Power Pivot automatically detects the changes you 

make in Excel, and recalculates the DAX formula: 

o change AT to AU 

Add sport pictograms to the Data Model  

Power View reports are more interesting when images are associated with Olympic events. In 

this section, you add images to the Disciplines table.  

1. After searching the Internet, you find that Wikimedia Commons has great pictograms for 

each Olympic discipline, submitted by Parutakupiu. The following link shows you the 

many images from Parutakupiu. 

 

http://commons.wikimedia.org/wiki/user:parutakupiu 

2. But when you look at each of the individual images, you find the common URL structure 

doesn’t lend itself to using DAX to automatically create links to the images. You want to 

know how many disciplines exist in your Data Model, to gauge whether you should input 

the links manually. In Power Pivot select the Disciplines table, and look at the bottom of 

the Power Pivot window. There, you see the number of records is 69, as shown in the 

following screen.  
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You decide that 69 records is not too many to copy and paste manually, especially since 

they’ll be so compelling when you create reports.  

3. To add the pictogram URLs, you need a new column in the Disciplines table. That 

presents an interesting challenge: the Disciplines table was added to the Data Model by 

importing an Access database, so the Disciplines table appears only in Power Pivot, not 

in Excel. But in Power Pivot, you can’t directly input data into individual records, also 

called rows. To address this, we can create a new table based on information in the 

Disciplines table, add it to the Data Model, and create a relationship. 

4. In Power Pivot, copy the three columns in the Disciplines table. You can select them by 

hovering over the Discipline column then dragging across to the SportID column, as 

shown in the following screen, then click Home > Clipboard > Copy.  
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5. In Excel, create a new worksheet and paste the copied data. Format the pasted data as a 

table like you did in previous modules in this series, specifying the top row as labels, then 

name the table DiscImage. Name the worksheet DiscImage as well.  

Note:  A workbook with all the manual input completed, called DiscImage_table.xlsx, is one of 

the files you downloaded in the first module in this series. To make it easy, you can download it 

by clicking here. Read the next steps, which you can apply to similar situations with your own 

data. 

1. In the column beside SportID, type DiscImage in the first row. Excel automatically 

extends the table to include the row. Your DiscImage worksheet looks like the following 

screen.  

 

 

https://support.office.com/en-us/article/first-tutorial-4b4e5ab4-60ee-465e-8195-09ebba060bf0
http://download.microsoft.com/download/c/1/9/c19a4e9a-9703-4097-8691-c95e740aa48a/discimage_table.xlsx
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2. Enter the URLs for each discipline, based on the pictograms from Wikimedia Commons. 

If you’ve downloaded the workbook where they’re already entered, you can copy and 

paste them into that column.  

3. Still in Excel, choose Power Pivot > Tables > Add to Data Model to add the table you 

created to the Data Model. 

4. In Power Pivot, in Diagram View, create a relationship by dragging the DisciplineID 

field from the Disciplines table to the DisciplineID field in the DiscImage table.  

Set the Data Category to correctly display images  

In order for reports in Power View to correctly display the images, you must correctly set the 

Data Category to Image URL. Power Pivot attempts to determine the type of data you have in 

your Data Model, in which case it adds the term (Suggested) after the auto-selected Category, 

but it’s good to be sure. Let’s confirm. 

1. In Power Pivot, select the DiscImage table, and then choose the DiscImage column.  

2. On the ribbon, select Advanced > Reporting Properties > Data Category and select 

Image URL, as shown in the following screen. Excel attempts to detect the Data 

Category, and when it does, marks the selected Data category as (suggested). 

 

 

Your Data Model now includes URLs for pictograms that can be associated with each discipline, 

and the Data Category is correctly set to Image URL. 
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Use Internet data to complete the Data Model 

Many sites on the Internet offer data that can be used in reports, if you find the data reliable and 

useful. In this section, you add population data to your Data Model. 

Add population information to the Data Model  

In order to create reports that include population information, you need to find and then include 

population data in the Data Model. A great source of such information is the Worldbank.org data 

bank. After visiting the site, you find the following page that enables you to select and download 

all sorts of country or region data. 

http://databank.worldbank.org/data/views/variableSelection/selectvariables.aspx?source=world-

development-indicators  

There are many options for downloading data from Worldbank.org, and all sorts of interesting 

reports you could create as a result. For now, you’re interested in population for countries or 

regions in your data model. In the following steps you download a table of population data, and 

add it to your Data Model. 

1. Navigate to the worldbank.org website from the link provided above. 

2. In the center section of the page, under COUNTRY, click select all. 

3. Under SERIES, search for and select population, total. The following screen shows an 

image of that search, with an arrow pointing to the search box. 

 

 
4. Under TIME, select 2008 (that’s a few years old, but it matches the Olympics data used 

in these modules) 

5. Once those selections are made, click the DOWNLOAD button, and then choose Excel 

as the file type. The workbook name, as downloaded, isn’t very readable. Rename the 

workbook to Population.xls, then save it in a location where you can access it in the next 

series of steps. 

http://databank.worldbank.org/data/views/variableselection/selectvariables.aspx?source=world-development-indicators
http://databank.worldbank.org/data/views/variableselection/selectvariables.aspx?source=world-development-indicators
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Now you’re ready to import that data into your Data Model. 

1. In the Excel workbook that contains your Olympics data, insert a new worksheet and 

name it Population. 

2. Browse to the downloaded Population.xls workbook, open it, and copy the data. 

Remember, with any cell in the dataset selected, you can press Ctrl + A to select all 

adjacent data. Paste the data into cell A1 in the Population worksheet in your Olympics 

workbook. 

3. In your Olympics workbook, you want to format the data you just pasted as a table, and 

name the table Population. With any cell in the dataset selected, such as cell A1, press 

Ctrl + A to select all adjacent data, and then Ctrl + T to format the data as a table. Since 

the data has headers, select My table has headers in the Create Table window that 

appears, as shown here. 

 

 
 

Formatting the data as a table has many advantages. You can assign a name to a table, 

which makes it easy to identify. You can also establish relationships between tables, 

enabling exploration and analysis in PivotTables, Power Pivot, and Power View.  

4. In the TABLE TOOLS > DESIGN tab, locate the Table Name field, and type 

Population to name the table. The population data is in a column titled 2008. To keep 

things straight, rename the 2008 column in the Population table to Population. Your 

workbook now looks like the following screen. 
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Notes: In some instances, the Country Code used by the Worldbank.org site doesn’t 

match the official ISO 3166-1 Alpha-3 code provided in the Medals table, which means 

some countryregions won’t display population data. You can fix that by making the 

following substitutions directly in your Population table in Excel, for each affected 

entry. The good news is that Power Pivot automatically detects the changes you make in 

Excel: 

o change NLD to NED 

o change CHE to SUI 

5. In Excel, add the table to the Data Model by selecting Power Pivot > Tables > Add to 

Data Model, as shown in the following screen. 

 

 
6. Next, let’s create a relationship. We noticed that the Country or Region Code in 

Population is the same three-digit code found in the NOC_CountryRegion field of 

Medals. Great, we can easily create a relationship between those tables. In Power Pivot, 

in Diagram View, drag the Population table so it’s situated beside the Medals table. 
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Drag the NOC_CountryRegion field of the Medals table onto the Country or Region 

Code field in the Population table. A relationship is established, as shown in the 

following screen. 

 

 

That wasn’t too hard. Your Data Model now includes links to flags, links to discipline images 

(we called them pictograms earlier), and new tables that provide population information. We 

have all sorts of data available, and we’re almost ready to create some compelling visualizations 

to include in reports. 

But first, let’s make report creation a little easier, by hiding some tables and fields our reports 

won’t use. 

Hide tables and fields for easier report creation 

You may have noticed how many fields are in the Medals table. A whole lot of them, including 

many you won’t use to create a report. In this section, you learn how to hide some of those fields, 

so you can streamline the report creation process in Power View. 

To see this yourself, select the Power View sheet in Excel. The following screen shows the list of 

tables in Power View Fields. That is a long list of tables to choose from, and in many tables, 

there are fields your reports will never use.  
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The underlying data is still important, but the list of tables and fields is too long, and maybe a 

little bit daunting. You can hide tables and fields from client tools, such as Pivot Tables and 

Power View, without removing the underlying data from the Data Model.  

In the following steps, you hide a few of the tables and fields using Power Pivot. If you need 

tables or fields you’ve hidden to generate reports, you can always go back to Power Pivot and 

unhide them.  

Note:  When you hide a column or field, you won’t be able to create reports or filters based on 

those hidden tables or fields.  

Hide Tables using Power Pivot 

1. In Power Pivot, select Home > View > Data View to make sure Data View is selected, 

rather than being in Diagram View.  

2. Let’s hide the following tables, which you don’t believe you need to create reports: 

S_Teams and W_Teams. You notice a few tables where only one field is useful; later in 

this module, you find a solution to them as well.  

3. Right-click on the W_Teams tab, found along the bottom of the window, and select Hide 

from Client Tools. The following screen shows the menu that appears when you right-

click a hidden table tab in Power Pivot. 
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4. Hide the other table, S_Teams, as well. Notice that tabs for hidden tables are grayed out, 

as shown in the following screen. 

 

 

Hide Fields using Power Pivot 

There are also some fields that aren’t useful for creating reports. The underlying data may be 

important, but by hiding fields from client tools, such as PivotTables and Power View, the 

navigation and selection of fields to include in reports becomes clearer. 

The following steps hide a collection of fields, from various tables, that you won’t need in your 

reports.  

1. In Power Pivot, click on the Medals tab. Right-click the Edition column, then click Hide 

from Client Tools, as shown in the following screen.  
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Notice the column turns gray, similar to how the tabs of hidden tables are gray. 

2. On the Medals tab, hide the following fields from client tools: Event_gender, MedalKey.  

3. On the Events tab, hide the following fields from client tools: EventID, SportID. 

4. On the Sports tab, hide SportID.  

Now when we look at the Power View sheet and Power View Fields, we see the following 

screen. This is more manageable.  
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Hiding tables and columns from client tools helps the report creation process go more smoothly. 

You can hide as few or as many tables or columns as necessary, and you can always unhide them 

later, if necessary. 

With the Data Model complete, you can experiment with the data. In the next module, you create 

all sorts of interesting and compelling visualizations using the Olympics data and the Data Model 

you’ve created.  

Checkpoint and Quiz 

Review what you learned  

In this module you learned how to import Internet-based data to your Data Model. There’s a lot 

of data available on the Internet, and knowing how to find it and include it in your reports is a 

great tool to have in your reporting knowledge set. 

You also learned how to include images in your Data Model, and how to create DAX formulas to 

smooth the process of getting URLs into your data mash-up, so you can use them in reports. You 

learned how to hide tables and fields, which comes in handy when you need to create reports and 
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have less clutter from tables and fields that aren’t likely to be used. Hiding tables and fields is 

especially handy when other people are creating reports from the data you provide.  

In the next module in this series, you start creating amazing Power View reports. They’re fun, 

interactive, and bounded only by your creativity and imagination. Even within the Olympics data 

set, the number and varied types of reports you can create is nearly boundless.  

  

QUIZ  

Want to see how well you remember what you learned? Here’s your chance. The following quiz 

highlights features, capabilities, or requirements you learned about in this module. At the bottom 

of the page, you’ll find the answers. Good luck!  

Question 1: Which of the following methods is a valid way of including Internet data in your 

Data Model? 

A: Copy and paste the information as raw text into Excel, and it is automatically included. 

B: Copy and paste the information into Excel, format it as a table, then select Power Pivot > 

Tables > Add to Data Model. 

C: Create a DAX formula in Power Pivot that populates a new column with URLs that point to 

Internet data resources. 

D: Both B and C. 

Question 2: Which of the following is true of formatting data as a table in Excel? 

A: You can assign a name to a table, which makes it easy to identify. 

B: You can add a table to the Data Model.  

C: You can establish relationships between tables, and thereby explore and analyze the data in in 

PivotTables, Power Pivot, and Power View. 

D: All of the above. 

Question 3: Which of the following is true of hidden tables in Power Pivot? 

A: Hiding a table in Power Pivot erases the data from the Data Model. 

B: Hiding a table in Power Pivot prevents the table from being seen in client tools, and thus 

prevents you from creating reports that use that table’s fields for filtering. 
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C: Hiding a table in Power Pivot has no effect on client tools. 

D: You cannot hide tables in Power Pivot, you can only hide fields. 

Question 4: True or False: Once you hide a field in Power Pivot, you cannot see it or access it 

any longer, even from Power Pivot itself. 

A: TRUE 

B: FALSE 

Quiz answers  

1. Correct answer: D 

2. Correct answer: D 

3. Correct answer: B 

4. Correct answer: B 
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Module 5: Create Amazing Power View 

Reports - Part 1 

Abstract:    At the end of the previous module, Incorporate Internet Data, and Set Power View 

Report Defaults, your Excel workbook had a complete Data Model, and was ready to create 

reports. In this module, you create three different Power View reports, learn some tips along the 

way, and learn steps you can use to create many, many more. 

The sections in this module are the following: 

Create Interactive Map Charts  

Create Interactive Pie Charts  

Create Interactive Bar and Column Charts  

Checkpoint and Quiz  

At the end of this module is a quiz you can take to test your learning.  

This series uses data describing Olympic Medals, hosting countries, and various Olympic 

sporting events. The modules in this series are the following: 

1. Import Data into Excel 2013, and Create a Data Model  

2. Extend Data Model relationships using Excel 2013, Power Pivot, and DAX  

3. Create Map-based Power View Reports  

4. Incorporate Internet Data, and Set Power View Report Defaults  

5. Create Amazing Power View Reports - Part 1  
6. Create Amazing Power View Reports - Part 2  

Create Interactive Map Charts 

Building reports in Power View is fun and easy. And the reports you create are interactive, 

allowing viewers of the report to click on data elements, and gain new insights into your data. 

In this section, you build a new map chart and extend it, then you create bar charts and pie charts 

that present the data in interesting ways. Along the way, you add some new calculations to the 

Data Model so the reports look the way you want them. Let’s get started. 

Create an Interactive Map Chart  

In a previous module, you created a basic map report to display the host cities for various 

editions of the Olympic Games. You decide there’s more interesting information available in this 
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Data Model, and you want to see it in different ways. To begin, you want to create a new Power 

View map report, to display the count of medals won by each country or region, the medal type, 

and then, results by season.  

1. In Excel, select the Power View1 worksheet. Your sheet looks like the following screen, 

based on work completed in previous modules, and depending on where you click on the 

canvas. 

 

 
 

Create a new Power View report by selecting POWER VIEW > Insert > Power View 

from the ribbon. A blank Power View report sheet is created. Rename the report to Map, 

by right-clicking the tab along the bottom, and selecting Rename from the menu that 

appears. 

2. Expand the Medals table in the Power View Fields, and select NOC_CountryRegion. To 

get information on medals, select the Medal field. The table Power View creates looks 

like the following screen. 
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Uh-oh. That’s not what you want. This report displays the type of medal won by each 

country or region, and you want the count of medals. In a previous module, you used a 

DAX formula to determine the percentage of medals awarded, so you decide to use DAX 

to calculate the count of medals.  

3. In Power Pivot, on the Medals tab, select the cell below the Medal column. If there are 

no cells available below the columns, the Calculation Area might not be displayed. To 

display the Calculation Area, select Home > View > Calculation Area. Type the 

following DAX formula into the cell. 

 

Medal Count:=COUNTA([Medal]) 

 

Note:You can create DAX formulas in any cell in the Calculation Area, and have the 

calculated field available from that table in client tools, such as Power View or 

PivotTables. Selecting the cell below the Medal field is just a good way to keep track of 

which column it calculates. 

4. Back in Excel, your Data Model is updated. In the Map worksheet, your Power View 

Fields now shows the Medal Count field. Since Medal Count is a calculated field, a small 
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calculator icon is displayed next to the field. With the table you created in the previous 

step selected, unselect Medal, and select Medal Count. That’s better. Your screen now 

shows how many medals were won by each country or region, as shown in the following 

screen. 

 

 
5. Select DESIGN > Switch Visualization > Map to display the table as a map. Resize the 

map to make it larger. When you hover over any of the bubbles on the map, additional 
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information appears, as shown in the following screen. Try it for yourself.  

 

Create an Interactive Pie Chart in a Map  

Now that you have the Map visualization, it’s time to make it more interesting. In the following 

steps, you change the bubbles into interactive pie charts, with just a few clicks. 

1. In Power View, from Power View Fields, drag Medal to the COLOR field. Now each 

bubble on the map becomes a pie chart, with each section sized based on the type of 

medal awarded. When you select the map, navigation tools appear that let you zoom in, 

or pan, as shown in the following picture. 

 
2. Hover over any of the pie charts. Information is displayed based on which slice you hover 

over. In the following screen, I hover over the red slice for Spain (ESP), and the 

visualization displays information about that portion of the bubble. Notice, too, that the 
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bubble expands, to allow easier navigation to other slices. 

 

You now have an interactive Map that allows you to zoom in, zoom out, and hover over data 

elements and get more information.  

Notice the medals are ordered alphabetically, which is the default. You want the order to be the 

following: gold, silver, bronze. To do so, we need to sort Medal by another value.  

Change the Sort Order of a Field  

To change the sort order from the default, you need to associate the Medal field with another 

field, then sort by the associated field. There is no associated field at this point, but you can 

create one. There are a few steps involved in doing this, but once you complete them, you see 

how convenient and easy it is to make the Data Model behave the way you want. 

1. In Excel, insert a new worksheet after Population. Rename the sheet MedalValue. Type 

the following data into the MedalValue worksheet. You can also copy and paste it in. 

Medal MedalValue 

Gold  1 

Silver  2 

Bronze  3 

1. Format the data as a table (while in one of the cells, you can press Ctrl + A, then Ctrl + T 

to format the data as a table). Make sure you select My Table has headers in the Create 

Table window. Under DESIGN > Properties > Table Name, name the table 

MedalValue. 

2. Still in Excel, select Power Pivot > Tables > Add to Data Model to add the table to the 

Data Model. 

3. In Power Pivot, select Diagram View. Move the MedalValue table beside the Medals 

table. It’s okay to move other tables out of the way to make room. In the Medals table, 



78 
 

drag the Medal field to the Medal field in the MedalValue table, and create a 

relationship. Select the line between those tables to highlight the relationship you created. 

Your Diagram View looks like the following screen. 

 
4. In Data View in Power Pivot, Select the Medals table. Scroll right and select the column 

titled Add Column. In the formula bar, type the following DAX formula. 

 

=RELATED(MedalValue[MedalValue]) 

 

The RELATED function returns a value from another table in the Data Model. You can 

only sort with columns found in the same table, so we need the MedalValue values to 

exist in the Medals table. The RELATED function lets us pull a MedalValue field into 

the Medals table. Rename the column Medal Value. 

5. Now we need to specify how Power View (and other client tools) should sort the Medal 

field. Select the Medal column, then select Home > Sort and Filter > Sort by Column. 

In the window that appears, select Medal Value as the column by which to sort Medal, as 

show in the following screen. 
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6. Back in Excel, the new sort order is automatically reflected in the Map visualization you 

created earlier, as shown in the following screen. 

 

 

Filter Visualizations using a Slicer  

Now that you have a Map visualization of Olympic events, you want to filter the results based on 

season. You can do that easily with Slicers. 

1. In Power View, drag Season from the Medals table in Power View Fields onto the report 

canvas. A table is created with the Season fields. The table will likely overlap your map, 

so resize the map and move the Season table beside the map.  

2. With the Season table selected, select DESIGN > Slicer > Slicer from the ribbon. The 

Map can now be filtered by the Season slicer. Try it out. On the slicer, click Summer, 

then Winter. Notice how the Map immediately updates the map to reflect the selection 

you make.  

3. To clear the slicer and see all results, click the Clear filter icon that appears above the 

slicer table. It only appears when you hover over the visualization. The Clear filter icon 
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looks like small eraser, as shown in the following screen.  

 

Filter other Visualizations using the Map  

Not only can you use slicers to filter the map, you can use the map to interactively filter other 

tables you include in the report.  

1. In Power View, from the Events table, drag Sport to the report canvas. A table called 

Sports is created. Drag Medal Count, from the Medals table, onto the Sports table as 

well. Your report looks like the following screen. 

 

 
 

Note: If blanks appear in your data, and you want them removed, use the Filters pane. 

For example, you may want to remove blanks from Sports. If the Filters pane is 
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collapsed, expand Filters, then select the Sports table and click the arrow beside Sports, 

select (All) to select all, then (Blank) to exclude blanks from the visualization. 

2. When you click on the pie charts in the map, the Sports table visualization is filtered 

based on your selection, and by any slicers that have been selected. Pie charts that are not 

selected are dimmed, as are slices of the same pie that are not selected. For example, 

click Winter in the Season slicer, then zoom in and click on the orange portion of 

Finland’s pie chart, the Sports table adjust automatically, and immediately. Finland has 

won 95 silver medals, with 11 of them in the Biathalon, 18 in Ice Hockey, and so on. The 

following screen shows the results. 

 

 

Create an Interactive Bar Chart  

But wait, there’s more. It might be interesting to see the distribution of medals, in the map 

visualization, based on the Sport table visualization. And rather than numbers, you want to see it 

as a bar chart. 

1. Select the Sport table visualization. From the ribbon, select DESIGN > Switch 

Visualization > Bar Chart > Clustered Bar. The Sport visualization becomes a bar 

chart. 

2. From the Season slicer, select Summer. Notice how the Sport bar chart changes to reflect 

the sports that are part of the Summer Olympic events.  

3. On the Sport bar chart, click the bar next to Fencing. Notice that the other bars in the 

chart dim, but remain visible. Also notice that on the Map visualization, the Pie Charts 

change to reflect only medals awarded for the selection in the Sport bar chart. Countries 

or regions that have not won medals in fencing are dimmed. The following screen shows 

how your Power View report looks. 
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4. Click some of the other bars in Sports, and see how Power View immediately updates the 

Map and the Bar charts based on your selection.  

To see these visualization as a video, view the following video: 

Create Interactive Pie Charts 

You saw how the map visualization can include pie charts, but you can also create interactive pie 

charts in Power View outside of maps. In this section, you learn how to create interactive pie 

charts, how to drill down into the data within each pie, and how to create slices. Let’s get started. 

Create an Interactive Pie Chart  

1. Select the Map tab in Excel, then click POWER VIEW > Insert > Power View. A new 

tab is created. Rename the tab Pie. 

2. From Power View Fields, select Year from the Medals table. Power View sums the data, 

because they are numbers. To prevent this, click on the arrow beside Year in the FIELDS 

area, and select Count (Distinct), as shown in the following screen. 
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3. Next, from Events, select Sport. A table is created on the report canvas. To change the 

visualization to a Pie Chart, select DESIGN > Switch Visualization > Other Chart > 

Pie. The following screen shows your pie chart.  

 

 
4. That pie chart is too busy. You decide you want to filter the results to only winter sports. 

First, click the arrow icon in the collapsed Filters pane. The Filters pane expands. Click 

VIEW on the Filters pane, so that any filters you drag there will apply to all reports in 

the view. Drag Season from the Medals table into the Filters pane. Select Winter from 

the Season filter, as shown in the following screen.  
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5. As with the Map visualization, the pie chart is interactive. Hover over any slice of the 

pie, and information is displayed. Clicking on any slice, or on any color in the legend, 

highlights that sport. In the following screen you click Skating, and its legend 

information and pie chart slice are highlighted, while all other slices and legend items are 

dimmed. 
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To clear the highlight, click again on the selected slice, or click the blank area in the 

visualization.  

That’s an interesting pie chart, and it was easy to create. But Power View can create more 

interesting pie charts by visualizing multiple levels of depth inherent in hierarchies.  

Create a Drill-Down Pie Chart using Hierarchies  

Let’s create another pie chart, and use a hierarchy that you created in a previous module. 

1. In Power View Fields, in the Events table, click Sport to deselect it, and then click SDE. 

SDE is the Sport/Discipline/Event hierarchy you created in a previous module.  

2. The pie chart appears unchanged, but double-click on the Skiing slice of the Pie chart, 

and Power View drills down into the next level of the hierarchy. Now, the pie chart is 

based on the disciplines within the Skiing sport. Notice that the legend now lists the 

disciplines under the sport of skiing, as show in the following screen. 

 

 
 

Also notice the up arrow that appears to the left of the filter icon, in the upper-right 

corner of the visualization. Click on the up arrow to drill up in the hierarchy, which in 

this case displays a pie chart of Sports. 

3. Double-click on the Ski Jumping slice, and the pie chart drills down another level into the 

hierarchy, which is Events. The events for Ski Jumping are displayed, and the legend 
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shows the chart is displaying Events, which is the lowest level in the hierarchy. 

 
4. To return to higher levels in the hierarchy, also called drilling up, click the up arrow as 

shown in the following screen. When the highest level in the hierarchy is displayed, the 

up arrow is no longer displayed. 

 

Use Slices to Display More Detail  

You can display more detail in pie charts.  

1. From the Medals table in Power View Fields, drag Gender to the SLICES area. Each 

slice in the pie chart is now sliced to reflect how the data is divided by Gender. Hover 

over any slice in the pie chart, and the information provided is displayed based on 

Gender. 
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2. Drill down into Skiing, then into Alpine Skiing. Hover over the lower slice of the 

downhill event, and you see that women’s teams have participated in the downhill event 

on 16 occasions, as shown in the following screen.  

 

 

Cross-Filter Bar Charts with other Visualizations  

You can apply many different filters to pie charts. You can even use other visualizations to filter 

pie charts, with interaction possible on all charts in the view.  

1. Click on the Power View report canvas outside the pie chart. From Power View Fields, 

select Population from the Population table, and then select Country Name from the 

Population table, to display the country or region name 

2. Let’s filter the view to just a handful of countries or regions. To display the Filters area, 

you can either select Filters Area from the POWER VIEW ribbon, or you can click the 

Filters icon that appears when you hover over a visualization, near the upper left corner. 

The Filters Area selection in the ribbon, and the Filters icon, are shown in the following 



88 
 

screen. 

 

3. In Filters, select only the following Country or Regions: Austria, Canada, Chile, Czech 

Republic, France, and Germany. 

4. Let’s turn this into a Clustered Bar Chart. On the ribbon, click DESIGN > Switch 

Visualization > Bar Chart > Clustered Bar Chart.  

5. Click on one of the bars in the Bar Chart. Notice how data in the pie chart updates based 

on your selection, highlighting the corresponding information. Click on Canada in the 

Bar Chart. Your report looks like the following screen. 
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Try clicking other selections, and see how the pie chart changes immediately with your 

selection. 

6. You can also drill down into the data, just as you did before. Double-click on either 

Skiing slice in the pie chart, then double-click on the Alpine Skiing discipline, and the pie 

chart responds by displaying all Events in the Alpine Skiing discipline. Filtering results 

by clicking on the bar chart works the same at this level of the hierarchy. Click on 

France, and the pie chart filters Event results for France, as shown in the following 

screen. 
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You can use many different types of visualizations to filter pie charts, and in Power View, 

they’re all interactive. And when you post reports on a Business Intelligence [term] site on 

SharePoint, your Power View reports remain interactive to anyone with permission to view 

them. 

Create Interactive Bar and Column Charts 

You saw how bar charts can be used to filter other visualizations, such as a pie chart. In this 

section, you learn how to create compelling bar and column charts that are interactive.  

1. Select POWER VIEW > Insert > Power View to create a new Power View Report. 

Rename the report Bar and Column.  

2. From the Medals table, choose Medal Count, then NOC_CountryRegion from the 

Medals table as well. From the ribbon, select DESIGN > Switch Visualization > 

Column Chart > Clustered Column. The visualization has too many entries, so let’s 

filter the view to show only countries or regions that won 200 or more medals. To do 

that, click the Filter icon, and then change the mode of the filter to Advanced, by clicking 

the right-arrow icon beside the eraser, as shown in the following screen.  
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3. To make the chart more interesting, drag Medal from the Medals table onto the 

visualization. 

4. Next, include a slicer. Click on the report canvas outside the chart, select Medal from the 

Medals table, and then select DESIGN > Slicer from the ribbon. Your report looks like 

the following screen. 
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5. That’s interesting. But you decide it would be better as a stacked column. Select 

DESIGN > Switch Visualization > Column Chart > Stacked Column. That looks 

better, and your report now looks like the following screen. 
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6. Now let’s add another slicer, based on Season. Click a blank area on the report canvas, 

then select Season from the Medals table. Then select Slicer from the ribbon. When you 

click on Winter, you notice there are no entries – looks like no country or region won 

more than 200 medals in the Winter. In the Filters pane, click CHART, change the 

Medal Count filter to at least 30 medals, and you see the following results. 

 

 
7. This chart is interactive, too. In the Medal legend, click on Silver. The Silver medal 

results are highlighted, and the rest of the results in the table are dimmed, as shown in the 
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following screen. 

 

 
8. Although this is a Column Chart, it’s easy to change it to a bar chart. Select DESIGN > 

Switch Visualization > Bar Chart > Stacked Bar from the ribbon. You get the same 

chart, turned on its side into a bar chart, as shown in the following screen. The bar chart 

is just as interactive as the other charts. 
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There are all sorts of ways to interact with these Bar and Column charts. Explore it yourself, and 

see. 

Checkpoint and Quiz 

Review what you learned  

In this module you learned how to create interactive map, pie, bar, and column charts, with just a 

few clicks to create each. You also learned how hierarchies can make your reports more 

interactive, and enable viewers of your reports to become engaged with the report and its depth. 

You also learned to put multiple visualizations into one report, and how those visualizations can 

filter, interact, and build on one another.  

In the next module in this series, you create more amazing Power View reports… including 

reports that animate, and show how the Olympics data changed over time. It’s pretty cool and 

easy to build, and even more fun to watch the reactions of people who see the reports you build.  
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QUIZ  

Want to see how well you remember what you learned? Here’s your chance. The following quiz 

highlights features, capabilities, or requirements you learned about in this module. At the bottom 

of the page, you’ll find the answers. Good luck!  

Question 1: Which of the following is true about the sort ordering of values in a field? 

A: To change the sort order of a field, you must associate the field with another field, then delete 

the original field. 

B: You cannot change the sort order of a field, no matter what. 

C: If you want to sort by an associated field, the associated field must be in the Data Model. 

D: None of the above. 

Question 2: What functionality does a slicer provide? 

A: Slicers duplicate data from one field to another. 

B: Slicers cut data in half, and keep half the data for themselves. 

C: Slicers filter visualizations based on data in the slicer field or fields. 

D: None of the above. 

Question 3: When you use a hierarchy in a report visualization, which of the following becomes 

possible? 

A: Nothing – you cannot use hierarchies in visualizations. 

B: You can drill down through levels of the hierarchy, and the visualization automatically 

changes to reflect the current level of the hierarchy. 

C: You can drill down through levels of a hierarchy, but you cannot drill up. 

D: Both B and C. 

Question 4: In the Filters pane, which of the following is correct? 

A: Dragging a field into the CHART area of the Filters pane filters all reports on the Power 

View sheet. 

B: Dragging a field into the VIEW area of the Filters pane filters all reports on the Power View 

sheet. 
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C: You must drag the same field into both the CHART and VIEW areas of the Filters pane to 

filter all visualizations in the Power View sheet. 

D: You cannot drag fields onto the Filters pane. 

Quiz answers  

1. Correct answer: C 

2. Correct answer: C 

3. Correct answer: B 

4. Correct answer: B 
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Module 6: Create Amazing Power View 

Reports - Part 2 

Applies To: Excel 2013  

Abstract:    At the end of the previous module, Create Amazing Power View Reports - Part 1, 

your Excel workbook had three Power View reports and many visualizations, including 

interactive Map, Pie, Bar, and Column Charts. In this module, you learn how to create additional 

interactive Power View reports.  

Note, too, that when you publish these reports and make them available on SharePoint, these 

visualizations are just as interactive as they are in this module, for anyone viewing them.  

The sections in this module are the following: 

Create Multiples Charts  

Build Interactive Reports using Cards and Tiles  

Create Scatter Charts and Bubble Charts with Time-based Play Visualizations  

Checkpoint and Quiz  

At the end of this module is a quiz you can take to test your learning. You can also see a list of 

videos that show many of the concepts and capabilities of Power View in action.  

This series uses data describing Olympic Medals, hosting countries, and various Olympic 

sporting events. The modules in this series are the following: 

1. Import Data into Excel 2013, and Create a Data Model  

2. Extend Data Model relationships using Excel 2013, Power Pivot, and DAX  

3. Create Map-based Power View Reports  

4. Incorporate Internet Data, and Set Power View Report Defaults  

5. Create Amazing Power View Reports - Part 1  

6. Create Amazing Power View Reports - Part 2  
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Create Multiples Charts 

In this section, you continue creating interactive visualizations with Power View. This section 

describes creating a few different types of Multiples charts. Multiples are sometimes also called 

Trellis Charts. 

Create Interactive Vertical Multiples Charts  

To create multiples charts, you begin with another chart, such as a pie chart or a line chart. 

1. In Excel, select the Bar and Column worksheet. Create a new Power View report by 

selecting POWER VIEW > Insert > Power View from the ribbon. A blank Power View 

report sheet is created. Rename the report Multiples, by right-clicking the tab along the 

bottom and selecting Rename from the menu that appears. You can also double-click the 

tab to rename it. 

2. Expand the Medals table in Power View Fields and select the Gender and then the Event 

fields. From the FIELDS area, select the arrow button beside Event, and select Count 

(Not Blank). The table Power View creates looks like the following screen. 

 

 
3. From the ribbon, select DESIGN > Switch Visualization > Other Chart > Pie Chart. 

Now your report looks like the following screen. 
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4. You decide it would be interesting to view the number of events by gender over time. 

One way to view that information is to use multiples. From the Medal table, drag Year to 

the VERTICAL MULTIPLES field. In order to view more multiples, remove the legend 

from the report by selecting LAYOUT > Legend > None from the ribbon. 

5. Change the layout so the multiples grid shows six charts wide by six charts tall. With the 

chart selected, select LAYOUT > Grid Height > 6 and then LAYOUT > Grid Width > 

6. Your screen now looks like the following screen. 

 

 
6. The multiples chart type is interactive too. Hover over any pie chart, and information 

about that slice is displayed. Click any pie slice in the grid, and that selection is 

highlighted for each chart in the multiple. In the screen below the yellow slice (women) 
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for 1952 was selected, and all other yellow slices are highlighted. When more charts are 

available than Power View can display in one screen, a vertical scroll bar is displayed 

along the right edge of the visualization. 

 

 

Create Interactive Horizontal Multiples Charts  

Horizontal charts behave similar to Vertical Multiple Charts.  

1. You want to change your Vertical Multiples Charts to Horizontal Verticals. To do so, 

drag the Year field from the VERTICAL MULTIPLES area into the HORIZONTAL 

MULTIPLES area, as shown in the following screen. 
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2. The Power View report visualization changes to a Horizontal Multiples Chart. Notice the 

scroll bar along the bottom of the visualization, shown in the following screen. 

 

 

Create Multiples Line Charts  

Creating line charts as multiples is easy, too. The following steps show you how to create 

multiple line charts based on the count of medals for each year. 

1. Create a new Power View sheet, and rename it Line Multiples. From Power View 

Fields, select Medal Count and Year from the Medals table. Change the visualization to 

a line chart by selecting DESIGN > Other Chart > Line. Now drag Year to the AXIS 

area. Your chart looks like the following screen. 
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2. Let’s focus on Winter medals. In the Filters pane, select CHART, then drag Season from 

the Medals table into the Filters pane. Select Winter, as shown in the following screen.  

 

 
3. To create the multiples line charts, drag NOC_CountryRegion from the Medals table into 

the VERTICAL MULTIPLES area. Your report now looks like the following screen. 

 
4. You can choose to arrange the multiple charts based on different fields, and in ascending 

or descending order, by clicking on the selections in the upper left corner of the 

visualization. 

Build Interactive Reports using Cards and Tiles 

Tiles and cards convert tables to a series of snapshots that visualize the data, laid out in card 

format, much like index cards. In the following steps, you use cards to visualize the number of 

medals awarded in various sports, and then, refine that visualization by tiling the results based on 

Edition. 

Create Card Visualizations  
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1. Create a new Power View Report, and rename it Cards. From Power View Fields, from 

the Disciplines table, select Discipline. From the Medals table, select Distinct Count of 

Edition, Medal Count, and NOC_CountryRegion. In the FIELDS area of Power View 

Fields, click the arrow next to NOC_CountryRegion, and select Count (Distinct).  

2. In the ribbon, select DESIGN > Switch Visualization > Table > Card. Your table looks 

like the following screen. 

 
3. With the card visualization selected, select DiscImage from the DiscImage table. You 

may get a security warning that prompts you to click a button to Enable Content in order 

to get the images to display, as shown in the following screen.  

 

 
4. In the FIELDS area, arrange the fields in the following order: DiscImage, Discipline, 

Medal Count, Count of NOC_CountryRegion, and last, Distinct Count of Edition. Your 
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Cards now look similar to the following screen.  

 

Use Tiles with Card Visualizations  

1. Reviewing these cards based on the year in which the medals were awarded is easy. In 

Power View Fields, from the Medals table, drag the Year field into the TILE BY area. 

Your visualization now looks like the following screen.  

 
2. Now the cards are tiled by Year, but something else happened as well. The TILE BY 

field became a container, which at this point only contains the cards you created in the 
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previous steps. We can add to that container, however, and see how using TILE BY can 

create interactive reports that coordinate the view of your data. 

3. Click in the area beside the cards visualization, but still inside the TILE BY container. 

The Power View Fields pane changes to reflect that you are still in the TILE BY 

container, but you are not in the cards visualization. The following screen shows how this 

appears in the Power View Fields pane. 

 
4. In Power View Fields, select ALL to show all available tables. From the Hosts table, 

select City, Season, NOC_CountryRegion, and FlagURL. Then from the ribbon, select 

DESIGN > Switch Visualization > Table > Card. You want the table you just created 

to fill up more of the available report space, so you decide to change the type of Card 

visualization. Select DESIGN > Options > Card Style > Callout. That’s better. Your 
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report now looks like the following screen.  

 
5. Notice how, when you select a different Year from the Tiles along the top of the TILE 

BY container, the callout card you just created is also synchronized with your selection. 

That’s because both card visualizations reside within the TILE BY container you created. 

When you scroll the TILE BY selection and select 2002, for example, your report looks 

like the following screen. 

 

 
6. You can also change the way Power View tiles information. From the ribbon, select 

DESIGN > Tiles > Tile Type > Tile Flow. The tile visualizations changes, and Power 
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View moves the tiles to the bottom of the tile container, as shown in the following screen. 

 

As mentioned previously, when you publish these reports and make them available on 

SharePoint, these visualizations are just as interactive for anyone viewing them.  

Create Scatter Charts and Bubble Charts with Time-based 

Play Visualizations 

You can also create interactive charts that show changes over time. In this section you create 

Scatter Charts and Bubble Charts, and visualize the Olympics data in ways that will allow 

anyone viewing your Power View reports to interact with them in interesting and amazing ways. 

Create a Scatter Chart and Bubble Chart  

1. Create a new Power View report by selecting POWER VIEW > Insert > Power View 

from the ribbon. Rename the report Bubbles. From the Medals table, select Medal Count 

and NOC CountryRegion. In the FIELDS area, click the arrow beside 

NOC_CountryRegion and select Count (Distinct) to have it provide a count of country or 

region codes, rather than the codes themselves. Then from the Events table, select Sport.  

2. Select DESIGN > Switch Visualization > Other Chart > Scatter to change the 

visualization to a scatter chart. Your report looks like the following screen. 
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3. Next drag Event from the Events table into the SIZE area of Power View Fields. Your 

report becomes much more interesting, and now looks like the following screen. 

 

 
4. Your scatter chart is now a bubble chart, and the size of the bubble is based on the 

number of medals awarded in each sport.  

5. Your bubble chart is interactive too. When you hover over the Rowing bubble, Power 

View presents you with additional data about that sport, as shown in the following image. 
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Create Time-Based Play Visualizations  

Many of the visualizations you create are based on events that happen over time. In the Olympics 

data set, it’s interesting to see how medals have been awarded throughout the years. The 

following steps show you how to create visualizations that play, or animate, based on time-based 

data. 

1. In the Scatter Chart you created in the previous steps, notice the PLAY AXIS area in 

Power View Fields, as shown in the following screen. 

 

 
2. From the Medals table, drag Year to the PLAY AXIS area. Here comes the fun part. An 

axis is created along the bottom of the scatter chart visualization, and a PLAY icon 

appears beside it, as shown in the following screen. Press play. 
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3. Watch as the bubbles move, grow, and contract as the years move along the Play axis. 

You can also highlight a particular bubble, which in this case is a particular Sport, and 

clearly see how it changes as the Play axis progresses. A line follows its course, visually 

highlighting and tracking its data points as the axis moves forward.  

4. Select Aquatics, then click Play. Aquatics is highlighted, and a watermark in the upper 

right corner of the report displays the Year (the PLAY axis) as the PLAY axis moves 

ahead. At the end, the path Aquatics has taken is highlighted in the visualization, while 

other sports are dimmed. The following screen shows the report when the Play axis 

completes. 

 

 
5. You can select more than one sport by holding the CTRL key and making multiple 

selections. Try it for yourself. In the following screen, three sports are selected: 

Wrestling, Athletics, and Aquatics. 
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6. Lastly, you can filter Scatter charts just like any other visualization. There are a lot of 

colors, because there are a lot of sports in the data set. From the Medals table, drag 

Season into the COLOR area of Power View Fields. Now only two colors are used, one 

for each Season (Summer or Winter). The following screen shows this, but to see how 

cool this looks, watch the video at the end of this module.  
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There are all sorts of amazing, compelling reports you can create with Power View. Each 

visualization brings a certain and distinct view onto your data. To provide even more compelling 

reports, you can combine different visualizations on a single report page, and make your data 

come alive. 


