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STANDARDS

PowerPoint Presentations  
Microsoft’s PowerPoint application is a powerful tool for creating multimedia 
presentations. All university units should use the standard PowerPoint tem-
plates  defined here, and are encouraged to follow brand standards, whenever 
 presenting on behalf of the university and its programs. 

Users should take notice of the “Layout” menu tab, which offers a variety of 
slide layout  options, including: 

• Cover slides

• Content without photos

• Content with static  photo backgrounds

• Content with customizable inset photos

• Blank slides

• Section breaks

• Quotes or impact statements

• Charts and data

These options cover a variety of possible solutions for presenting data 
 consistently and  effectively.

The PowerPoint template can be downloaded via the following link: 
stevens.edu/brandguide

http://www.stevens.edu/brandguide
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Getting Started

Users are encouraged to review the template file downloaded from  
stevens.edu/brandguide. 

Using the Template

Begin building out your presentation by selecting “New Slide” sub menu, located 
in the “Home” menu tab (Fig. 1). This sub menu will display all available slide 
options in the deck. Slides have been broken into categories and captioned 
accordingly for easy identification. Choose the slide which best meets your needs 
based on the content you are presenting.

If while preparing a slide you have accidentally reconfigured slide elements 
around, you can easily reset the slide to the intended format by simply selecting 
the “Layout” menu item and re-selecting the same slide you started with. You can 
also change to another layout. Please note, changing layout can re-arrange your 
content, if the new layout is dramatically different from what was previously used. 
You may be required to cut/paste or re-enter content to fit a desired template.

Fig.1

Fig.2

http://www.stevens.edu/brandguide
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Fonts

How PowerPoint presentations render is dependent on the library of fonts 
 installed on the computer used to open it. Century Gothic* is commonly available 
with Microsoft products (whether running on Windows or Mac OSX). Therefore 
if the computer you are presenting this font on runs MS Office products then it 
should be installed and available, and the PowerPoint design will consistently 
display exactly as  intended. 

Why Century Gothic?

• Clean, simple, circular geometry contrasts well with the angular boilerplate 
shapes/pairs well with the use of our more  condensed, branded sans-serif 
font Trade Gothic (p.19, Visual Identity Guide)

• Size and shape letterforms are legible well when projected at both large 
and  small sizes

• Reproduces well when printed

In the event that Century Gothic is not installed or has been removed from a 
 computer you can download it at the following link:
http://www.microsoft.com/typography/fonts/font.aspx?FMID=643

To install fonts on your system:

Mac

• In Finder navigate to folder Macintosh HD > Library > Fonts
• Drag and drop font files into Fonts folder
• Restart PowerPoint to load new font

Windows 
http://windows.microsoft.com/en-us/windows-vista/install-or-uninstall-fonts

Century Gothic
ABCDEFGHIJKLMNOPQRSTUVWXYZ
abcdefghijklmnopqrstuvwxyz
&1234567890

Century Gothic Bold
ABCDEFGHIJKLMNOPQRSTUVWXYZ
abcdefghijklmnopqrstuvwxyz
&1234567890

Century Gothic Italic
ABCDEFGHIJKLMNOPQRSTUVWXYZ
abcdefghijklmnopqrstuvwxyz
&1234567890

Century Gothic Bold Italic
ABCDEFGHIJKLMNOPQRSTUVWXYZ
abcdefghijklmnopqrstuvwxyz
&1234567890

PLEASE NOTE: Use of Century Gothic is approved for PowerPoint  presentations, but should 
not be considered a brand font. When inserting a new text box, PowerPoint may default to an 
alternate font. Century Gothic can be selected from the list of fonts under the Home tab.
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Slide Options

COVER SLIDES 
Six options of cover slide will be available, several with color 
images around campus as the background and an alternative 
option featuring an abstract pattern. You can switch the 
cover slide you are using by selecting it from the “Layout” 
sub menu in the “Home” tab.

Cover Slide with Photo Background

a. Stevens Logo- Part of the slide master/should NOT be 
 obscured by text whatsoever

b. Presentation Title- Century Gothic Bold; 32-34 pt

c. Sub Title - Century Gothic Italic; 26-30 pt

d. Speaker Information- Century Gothic; 20-22 pt

e. Presentation Date- Century Gothic; All Caps; 12-14 pt

In the event the photo background slide does not serve your 
intended message you can use the cover slide with abstract 
background (Fig. 2). Please maintain the same font sizes 
in this version as were used in the photo background cover 
slide.

a

b

c

d

e
Fig. 2

Fig. 1
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Slide Options

PHOTO BACKGROUND SLIDES
For convenience, photo background slides that utilize 
approved Stevens photography are readily available. These 
slides can give context to your subject matter or serve to 
enhance your presentation content.

Fig. 3 - Content Slide with Static Background Photos

a. Presentation Title- Century Gothic Bold; 32-34 pt

b. Sub Title- Century Gothic; 24 pt

c. Bullets or Text- Century Gothic; 18 pt;

d. Boilerplate & Slide Number- Must NEVER be obscured 
by content.

e. Stevens Logo- On content slides the logo shield is 
echoed in the top right corner to allow content to align 
left and be the focus.

To view the variety of available photo background slides 
simply use the “Layout” drop down menu under the “Home” 
tab and select the background slide that corresponds to your 
content (Fig 4).

It is not advisable to use photo background slides if you have 
an ample amount of content or intent to use other photos 
or diagrams. Photo bakgrounds are appropriate for text-only 
slides. Otherwise, please use blank content slides, which are 
available via the “Layout” drop-down menu. 

Fig. 3

Fig. 4

a

b
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d

e



Page 8 Stevens Institute of Technology  •  POWERPOINT

STANDARDS   ->   POWERPOINT

Slide Options

CUSTOMIZABLE PHOTO SLIDES 
Customizable photo slides are available for use when your 
message is better supported by topic specific imagery. The 
template contains a range of options including 1, 2, 4 and 6 
inset photos. 

To place an image, either click icon in frame or drag and 
drop desired images onto an the image placeholder (Fig. 4). 
Please note the structure of each customizable photo slide 
and maintain that structure when inserting your own photos. 
It is recommended that photos not overlap or intersect one 
another. 

Cropping Best Practices
When cropping an image always be careful to position the 
image so it’s focal point(s) are toward the center of the 
image. 

To adjust position use the crop tool, located in the “Format 
Picture” tab. Examples of both a proper and improper crop 
are demonstrated in the example (Fig. 5).

Fig. 4

Fig. 5
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Slide Options

DATA SLIDES

Customizable data slides are available for use when your 
message is better supported by tables, charts or Smart Art 
which may give particular insight and enhance your overall 
message. 

Options include a single graph with title/caption and a 
data comparison slide (Fig. 6 & 7). A blank content slide 
is included in the deck, for users who intend to use a 
  preexisting graphics in their presentation.

Preexisting Graph Assets 

If concerned with the quality of a graphic you plan to use, 
feel free to consult the Division of Communications & 
Marketing and we are happy to offer recommendations on 
how to proceed. 

If the original data for an existing graphic exists we 
encourage users to input this into one of PowerPoint’s many 
chart graphing options.

What type of data?
Picking the right options to best represent your data can be 
challenging. The following table (Fig. 8) is intended to help 
guide that process.

Fig. 6 Fig. 7

When to Use? Practical Example

Tables Providing a list of values that 
are precise or involve multiple 
units of measure.

In finance: depicting  not only 
an increase in sales, but also 
providing the percentage of 
increase over time.

Charts 
(or Graphs)

When two (or more) sets of 
data can be plotted to reveal 
some pattern or reveal a 
visual relationship between 
sets of data.

Using a pie chart to show the 
percentage of a department’s 
expenditures over the course 
of a given fiscal year.

SmartArt Encouraged when depicting 
relationships between 
information (or non numerical 
based data) and/or when 
pairing data with photography 

Showing the cycle of 
community impact that 
Stevens enacted during the 
Sandy Relief effort.

Fig. 8
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Slide Options

CHARTS 
Charts (or graphs) are advised when providing a list of values 
that are precise or involve multiple units of measure.

Type of Chart
 Typically 3D graphs do not enhance  communication or 
 understanding of data and can obscure the readability. 
2D graphics are the  recommended option for presenting 
graphical data. 

Fonts
Fonts used in tables created in PowerPoint should use 
Century Gothic, refer to page 3 for information on font 
selection in Stevens PowerPoints.

Fig. 8

Fig. 9

a

a

b

b

Fig. 10



Page 11 Stevens Institute of Technology  •  POWERPOINT

STANDARDS   ->   POWERPOINT

Slide Options

TABLES 
Tables are advised when providing a list of values that 
are precise or involve multiple units of measure. It is 
not advisable to use tables with large amounts of data. 
Whenever possible highlight only a portion of the table data 
that best reinforces your message.

Colors 
Tables using a solid color header and white or 
monochromatic table cells (Fig. 13) is an example of a 
minimal style balances well with the style of the existing 
template. Users can use a variety of colors based on what 
PowerPoint offers, but are advised to always maintain this 
simplified look.

It is also advised that users are consistent. If you’ve used a 
certain style/color for one table, use that same style on all 
tables within the presentation.

Fonts 
Fonts used in tables created in PowerPoint should use 
Century Gothic. The exception of course being if you are 
using an image of a table from an existing source. In such 
cases other fonts are acceptable.

Fig. 13

a b

Fig. 12
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Slide Options

SMART ART 
SmartArt is a convenient and powerful feature in PowerPoint 
and provides users with the ability to create engaging visual 
representations by combining shapes, photos and (typically) 
non numerical data. 

As with tables and charts these elements are encouraged for 
use when they support your overall message and enhance 
your presentation to communicate more effectively.

Style
Accessing the SmartArt tab in provides a range of potential 
structural adjustments along with menus to alter color, shape 
and position (Fig. 13).

The use of “3D” smart art options (Fig. 14b) is not advised. 
3D effects will give a degree of dimension and style to 
your graphics, however communicating is of the utmost 
important. In most cases use of such styles simply distracts 
from the data presented. 

Use of flat color smart art (Fig 14a) is encouraged to keep 
the data simple and to the point while supporting your 
message without distraction.

Fig. 13

Fig. 14

a b
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Effective Presentations

The following is a checklist for an effective presentation. Refer to this guideline 
upon completion of slides to track your progress.

CONSISTENCY

 � Review your presentation. Is the look of it consistent? 

 � Have template structures been disrupted?

 � Are text styles consistent throughout?

 � Is color use consistent and within one of the approved palettes?

 � Is everything legible?

 � Is the Stevens logo obscured in any way?

TEXT & BULLETS

 � Have you split up text heavy slides over multiple slides to help your audience digest 
the information? (Fig. 1)

 � Does each slide speak to a specific message, concept or idea? 

 � Is the text presented in your slides succinct and effective? Do the words used have 

significant meaning to your message?

GRAPHICS

 � Do your tables, charts or PowerPoint “SmartArt” support your message or enhance 
learning?

 � Review the graphics one-by-one. Does any element seem overly complicated or 
confusing somehow? If so, how can you simplify it?

 � Are you using the styles recommended in the guide?

FINAL REVIEW

 � Have you filled in adequate reference notes below the active slide window? (Fig. 2)

 � Are there elements in the text/bullets on your slides than can be moved into the notes 
section to allow for a more nimble presentation?

 � Have you made your point? Is there a takeaway message for your audience?

Fig. 1

Fig. 2




