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The FactSet Troubleshooting Guide is intended for IT professionals supporting 
FactSet to utilize when encountering problems with FactSet. This document 
will cover various issues including but not limited to connectivity, Office 
integration, installation, and performance. 

 

FactSet Troubleshooting Utility (FTU) 
The FactSet Troubleshooting Utility is a tool which provides a means to easily troubleshoot problems and 
implement fixes. The FactSet Troubleshooting Utility will be used for many of the problems illustrated throughout 
this document. 
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How do I access the FactSet Troubleshooting Utility?  

+ Click on the following link:  https://support.factset.com/ 

+ Click the Run button to download the executable or Save buttons to download the compressed zip under the 

FactSet Troubleshooting Utility 3 section. 

+ Once downloaded, run the FactSetTroubleshootingUtility.exe process. 

+ Select from the available options and click Run Selected Items. 

+ Click the Advanced button to view the list of advanced options. Click Run next to the desired advanced option. 

 

CITRIX XENAPP WITH NO PUBLISHED INTERNET BROWSER  

+ Within FactSet, click the question mark "?" in the top right of the window. 

+ Click Technical Support. 

+ Click the Run button to download the executable or Save buttons to download the compressed zip under the 

FactSet Troubleshooting Utility 3 section. 

+ Once downloaded, run the FactSetTroubleshootingUtility.exe process. 

+ Close all FactSet, Office, and Adobe applications running in Citrix. 

+ Select from the available options and click Run Selected Items. 

+ Click the Advanced button to view the list of advanced options. Click Run next to the desired advanced option. 

https://support.factset.com/
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FactSet Connectivity Issues  

FTU CONNECTIVITY TESTS  

The user is having difficulty connecting to FactSet. The first step in troubleshooting is to verify basic connectivity to 
FactSet. The FactSet Troubleshooting Utility provides a means to easily perform FactSet connectivity tests as 
follows:   

1. Click on the following link: https://support.factset.com/ 
2. Click the Run button to download the executable or Save buttons to download the compressed zip under 

the FactSet Troubleshooting Utility 3 section.   
3. Once downloaded, run the FactSetTroubleshootingUtility.exe process. 
4. Select all available options under the Connectivity section. 
5. Click the Run Selected Items button in the lower right corner. 
6. The results will display as Success or Failed for each test. 

MANUAL CONNECTIVITY TESTS  

If it is not possible to use the FactSet Troubleshooting Utility, the manual connectivity tests below may be used. 

Test Connectivity for FactSet AC communications: 

1. Go to Start > Run > type “cmd” > click OK. 
2. In the command window type: “telnet gatewaya.factset.com 6670” > press Enter 
3. If successful, the result will be a blank screen with a blinking cursor in the upper‐left corner. 
4. Press Enter until the C:\> prompt returns. 
5. In the command window type: “telnet gatewayb.factset.com 6670” > press Enter 
6. If successful, the result will be a blank screen with a blinking cursor in the upper‐left corner. 
7. Press Enter until the C:\> prompt returns. 
8. Open Internet Explorer and navigate to the following URLs: 

+ https://dispatcher.factset.com/RequestFactsetRouting.aspx 
+ https://dispatcher.factset.com/RequestDefaultConfiguration.aspx 

Test Connectivity for FactSet RT communications: 

1. In the command window type “telnet 208.184.40.10 6672” > press Enter 
2. If successful, the result will be a smiley face. 
3. Close the command prompt window. 
4. Open an Internet Browser and navigate to the following URLs: 

+ https://dispatcher.factset.com/RT/ConnTest.htm 

If successful, you will see the message: “You can connect to this dispatcher!” 

 
Note: Windows Telnet Client is disabled by default in Windows 10/8/7/Vista. To enable the Telnet Client follow 
these steps: 

1. Open the Control Panel. 
2. Select Programs. 
3. Select Programs and Features. 
4. Select Turn Windows features on or off. 
5. Select the Telnet Client option. 
6. Click OK. 

https://support.factset.com/
https://dispatcher.factset.com/RequestFactsetRouting.aspx
https://dispatcher.factset.com/RequestDefaultConfiguration.aspx
https://dispatcher.factset.com/RT/ConnTest.htm
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FactSet Office Add-in Issues  

The user is experiencing an issue with FactSet Office integration. The following are a few examples of errors/issues 

the user may be experiencing: 

 

+ The FactSet Office Add‐in, Ribbon, Toolbar and/or, drop down menu is missing or has disappeared.   

+ “Unhandled exception has occurred in your application. If you click Continue, the application will 

ignore this error…”   

+ “An Exception Occurred in fdsxl32.xll. Unable to register FactSet functions.”   

 

The FactSet Troubleshooting Utility provides tools to remedy many common FactSet add‐in issues, including the 

issues aforementioned.  Follow the steps below to clean‐up the FactSet add‐ins for the Office application in which 

the user is experiencing the issue: 

 

1. Close all FactSet, Microsoft Office, and Adobe applications.   

2. Click on the following link: https://support.factset.com/ 

3. Click the Run button to download the executable or Save buttons to download the compressed zip 

under the FactSet Troubleshooting Utility 3 section.   

4. Once downloaded, run the FactSetTroubleshootingUtility.exe process.   

5. Select from the available Fix options under the Office section. 

6. Click the Run Selected Items button in the lower right corner. 

7. When the selected options have all completed running, launch the Office application(s).   

8. Verify the FactSet Ribbon appears and functions properly.   

 

Problem: User is getting the following error when attempting to download data from FactSet to Excel: 

 

“Server Error – The following error occurred on the FactSet server: Cannot communicate with Excel.” 

 

Solution: Select the Fix Excel Add-Ins option under the Office section within the FactSet Troubleshooting Utility. If 

the error persists, run a repair or reinstall of the default version of Microsoft Office. 

 

Problem: Identifier Lookup or FQL doesn’t work properly when recalculating but the FactSet menu appears in 

Excel. 

 

Solution: FactSet may have been installed under an Administrator or SYSTEM Windows account and the users 

Windows account needs to have FactSet XLL add-in loaded under their Windows profile. Click Start > All Programs 

> FactSet > FactSet Excel Add-In to load the FactSet XLL add-in under the logged in Windows account and launch 

Excel. 

 

https://support.factset.com/
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FactSet Office Add-in Issues continued  
 
Problem: User is receiving error: “An Exception Occurred in fdsxl32.xll. Unable to register FactSet functions” when 
opening Excel. 
 
Solution: This error is usually caused by a loaded add‐in that is no longer installed on the machine. To fix this, 
ensure that all uninstalled add‐ins are completely removed from Excel’s add‐ins manager. 

Excel 2007 

+ Click on the Office button > Click on Excel Options > Select Add‐ins > select Excel Add‐ins from 
the Manage drop‐down menu > click Go… 

+ In the Add‐ins screen uncheck the add‐ins one‐by‐one.  You may receive the error, “Cannot find 
add‐in ‘random.add‐in’. Delete from list?”   

+ Click Yes to remove the problem add‐in. 
+ Close and reopen Excel to test. 

Excel 2010/2013/2016 

+ Click on File > Click on Options > Select Add‐ins > select Excel Add‐ins from the Manage drop‐
down menu > click Go… 

+ In the Add‐ins screen uncheck the add‐ins one‐by‐one.  You may receive the error, “Cannot find 
add‐in ‘random.add‐in’. Delete from list?”   

+ Click Yes to remove the problem add‐in. 
+ Close and reopen Excel to test. 

 

Problem: The user is receiving the following Excel error when trying to refresh =FDS codes:  “An exception occurred 
in fdsxl32.xll. Unable to find =FDS cells. Cannot Recalculate.” 
 
Solution: The tabs in the file(s) may be protected. Change them to unprotected (right‐click on the tab > select 
Unprotect sheet). The file(s) should now refresh as expected. 
 

OFFICE 2007, OFFICE 2010, 2013 AND 2016 SECURITY SETTINGS 

When loading FactSet add-ins, make sure that the Trust Center is configured to allow Add-ins. This security option 

can be located by navigating to the Office Button > … Options > Trust Center > Trust Center Settings… > Add-Ins > 

verify all boxes are unchecked. 
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TROUBLESHOOTING OFFICE ADD-IN ISSUES MANUALLY 

If it is not possible to use the FactSet Troubleshooting Utility, some manual recommended steps are: 

Excel 2007 
+ Launch Excel > click on the Office Button > click on Options > select Add-Ins > change "Manage" to 

Disabled Items > click Go > Enable disabled Add-ins. 
+ Close Excel > go to Start > Run > type "%APPDATA%\Microsoft\Excel\" > click OK > remove all FILES (do 

not remove subfolders) from that folder. 
+ Click the FactSet-Excel Link 

Word 2007 
+ Launch Word > click on the Office Button > click on Options > select Add-Ins > change "Manage" to 

Disabled Items > click Go > Enable disabled Add-ins. 
+ Close Word > go to Start > Run > type "%APPDATA%\Microsoft\Templates\" > click OK > remove all FILES 

(do not remove subfolders) from that folder. 

PowerPoint 2007 
+ Launch PowerPoint > click on the Office Button > click on Options > select Add-Ins > change "Manage" to 

Disabled Items > click Go > Enable disabled Add-ins. 
+ Close PowerPoint > go to Start > Run > type "%APPDATA%\Microsoft\PowerPoint\" > click OK > remove 

all FILES (do not remove subfolders) from that folder. 

Outlook 2007 
+ Launch Outlook > click on File > click on Options > select Add-Ins > change "Manage" to Disabled Items > 

click Go > Enable disabled Add-ins. 
+ Close Outlook > go to Start > Run > type "%APPDATA%\Microsoft\Outlook\" > click OK > remove all FILES 

(do not remove subfolders) from that folder. 

Excel 2010/2013/2016 
+ Launch Excel > click File > click on Options > select Add-Ins > change "Manage" to Disabled Items > click 

Go > Enable disabled Add-ins. 
+ Close Excel > go to Start > Run > type "%APPDATA%\Microsoft\Excel\" > click OK > remove all FILES (do 

not remove subfolders) from that folder. 
+ Click the FactSet-Excel Link 

Word 2010/2013/2016 
+ Launch Word > click on File > click on Options > select Add-Ins > change "Manage" to Disabled Items > 

click Go > Enable disabled Add-ins. 
+ Close Word > go to Start > Run > type "%APPDATA%\Microsoft\Templates\" > click OK > remove all FILES 

(do not remove subfolders) from that folder. 

PowerPoint 2010/2013/2016 
+ Launch PowerPoint > click on File > click on Options > select Add-Ins > change "Manage" to Disabled 

Items > click Go > Enable disabled Add-ins. 
+ Close PowerPoint > go to Start > Run > type "%APPDATA%\Microsoft\PowerPoint\" > click OK > remove 

all FILES (do not remove subfolders) from that folder. 

Outlook 2010/2013/2016 

+ Launch Outlook > click on File > click on Options > select Add-Ins > change "Manage" to Disabled Items > 
click Go > Enable disabled Add-ins. 

+ Close Outlook > go to Start > Run > type "%APPDATA%\Microsoft\Outlook\" > click OK > remove all FILES 
(do not remove subfolders) from that folder. 
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FactSet Integration with Adobe® Products 

PROTECTED MODE 

Problem: The user is having difficulty opening PDF’s from within various portions of FactSet. These include: 
 

+ Source Document Manager (SDM) 
+ Filings Viewer 
+ Investment Research Documents 

 
The user may receive the following error: 
 

"There is a problem with Adobe Acrobat Reader. If it is running please exit and try again. (nnnn:nnnn)" 
 
Solution: Disable Protected Mode in Adobe® Acrobat or Adobe® Reader. See steps below: 
 
Acrobat® Reader X 
 

1. Close FactSet  
2. Launch Adobe® Reader > click Edit > select Preferences > select General > remove the check next to 

Enable Protected Mode at Startup 
3. Close Acrobat or Adobe Reader, Launch FactSet, Perform your chosen action within SDM, Self Service 

Portal, etc. 
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Protected Mode Continued 

 
Acrobat® Reader XI and DC 
 

1. Close FactSet  
2. Launch Adobe® Reader > click Edit > select Preferences > select Security (Enhanced) > remove the check 

next to Enable Protected Mode at Startup 
3. Close Acrobat or Adobe Reader, Launch FactSet, Perform your chosen action within SDM, Self Service 

Portal, etc.   
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Common Setup, Application, and Installation Fixes 

USER ADMINISTRATIVE RIGHTS 

 Administrative rights are required for initial 
installation since FactSet will create new 
directories, update system DLLs, write and update 
registry keys in the HKCR and HKLM, load Excel add‐ 
ins, and self‐register specific files. Users do not 
need administrative rights to run FactSet software. 
However, they will need rights to be able to modify 
the [HKEY_CURRENT_USER\Software\FactSet\] 
registry key and modify the User Data folder and its 
contents. 

FILE PERMISSIONS ISSUES 

The below error messages will indicate a user permissions issue with the installation. 

 

 

 

 
 

 
After the installation of FactSet, the permissions sometimes need to be manually set on the User Data Folder. 
Symptoms of this problem include not being able to modify the FactSet username, serial number, or password, 
and receiving repeated FactSet “User Validation Failure” error messages.  
 
Problem: A user receives the error “signon.dsn access denied” or “signon.fcr access denied.” 
 
Solution: The “Access is denied” error message usually indicates the user cannot write to the SIGNON.DSN 
and/or SIGNON.FCR file. A user must have Modify permission to their User Data directory and all 
subdirectories. Contact your IT helpdesk for assistance in acquiring the proper permissions to that directory. 

HOW TO GRANT PROPER PERMISSIONS FOR FACTSET  

Windows Vista, Windows 7, Windows 8, Windows 10 
 

1. Go to Start > Run > type “%PROGRAMDATA%” and/or “%LOCALAPPADTA%” > click ENTER. 
2. Right‐click on the FactSet folder and click on Properties. 
3. Click on the Security tab > click the Edit… button. 
4. Select the “Users” group in the Group or user names section. 
5. Check the “Modify” check box. 
6. Click OK. 
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FACTSET SLOWNESS 

A user is experiencing slowness with the FactSet application. “Slowness” can be caused by many different factors.  
Network latency, ISP latency issues, a corrupt workspace, or worksheet/tab are a few examples that could 
potentially cause a user to experience latency within FactSet. Storing the FactSet CACHE directory on a network 
share may also cause latency (setting the CACHE directory to the local disk will be discussed later in this section). 
Below are a few examples of where a user is seeing slowness as well as several possible solutions: 

+ "Experiencing slowness when clicking on different tabs in the FactSet workspace." 
+ "FactSet takes a long time to load." 
+ "FactSet is much slower after upgrading to the latest version." 

 
Possible Solutions: 

+ At times it may become necessary to remove dispensable files within the FactSet Cache folder. Follow these 
steps to perform that action:    
 
1. Close all FactSet, Microsoft Office, and Adobe applications. 
2. Click on the following link: https://support.factset.com/ 
3. Click the Run button to download the executable or Save buttons to download the compressed zip under 

the FactSet Troubleshooting Utility 3 section. 
4. Once downloaded, run the FactSetTroubleshootingUtility.exe process. 
5. Select the Clear FactSet Cache options under the FactSet section. 
6. Click the Run Selected Items button in the lower right corner. 
7. Launch the application that was experiencing slowness and verify if the performance improves. 

      Note: The initial launch after running the Clear FactSet Cache option is expected to take longer while 
the FactSet Cache folder is rebuilt. 

 
+ If the FactSet cache is on a network drive, configure the FactSet cache within the local profile by performing 

the following steps. 
 
1. Close all FactSet, Microsoft Office, and Adobe applications. 
2. Click on the following link: https://support.factset.com/ 
3. Click the Run button to download the executable or Save buttons to download the compressed zip under 

the FactSet Troubleshooting Utility 3 section.   
4. Once downloaded, run the FactSetTroubleshootingUtility.exe process. 
5. Click the Advanced button.  
6. Click the Run buttons next to the Set Cache to Fixed Disk option. 
7. Launch FactSet and verify if the performance improves. 

     Note: Contact FactSet support if using FactSet in a Citrix or Terminal Server environment. 

https://support.factset.com/
https://support.factset.com/
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APPLICATION ISSUES  

Problem: A user is getting "The Central Dispatcher is unavailable” upon launching FactSet 
 
Solution: Verify connectivity to the FactSet Central Dispatcher by following the steps above for testing connectivity 
for FactSet RT communications.  Once connectivity to the Central Dispatcher is verified, follow the steps below to 
fix the issue: 
 
+ Open Internet Explorer. 
+ Verify: Tools > Internet Options > Security > Internet Zone > Set Default Level = Medium 
+ Verify: File > Work Offline is UNchecked 
+ Check if the user has checked but maybe should not have checked: Tools > Internet Options > Connections 

Tab > LAN Settings > "Use a proxy server for your LAN". 
+ Check Tools > Internet Options > Connections Tab > LAN Settings. Remove the check next to 'automatically 

detect settings' (if possible). 
+ Within the FactSet Troubleshooting Utility select the Clear Cached Config option under the FactSet section 

and click the Run Selected Items button in the lower right corner. 
 
Problem: A user is getting "Startup Failed, please contact your FactSet Rep” upon launching FactSet 
 
Solution: The user may have a local firewall enabled which is possibly causing problems with FactSet connecting 
(i.e., Norton or Windows firewall), or the communications settings need to be changed. Contact your internal IT 
helpdesk to see if they can assist, or call FactSet Support for assistance. 
 
Problem: The user gets the error, “An invalid argument was encountered” upon launching FactSet Marquee. 
 
Solution: This can be fixed by clearing the FactSet OnlineConfig via the FactSet Troubleshooting Utility: 
 

1. Close all FactSet applications. 
2. Click on the following link: https://support.factset.com/ 
3. Click the Run button to download the executable or Save buttons to download the compressed zip under 

the FactSet Troubleshooting Utility 3 section 
4. Once downloaded, run the FactSetTroubleshootingUtility.exe process. 
5. Select the Clear Cached Config under the FactSet section. 
6. Click the Run Selected Items button in the lower right corner 

https://support.factset.com/
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Application Issues Continued 
 
Problem: The user is receiving a “COM registration Failed” error upon launching FactSet. 
 
Solution: This can be fixed by re‐registering fdsw32.exe via the FactSet Troubleshooting Utility: 
 

1. Close all FactSet applications. 
2. Click on the following link: https://support.factset.com/ 
3. Click the Run button to download the executable or Save buttons to download the compressed zip under 

the FactSet Troubleshooting Utility 3 section. 
4. Once downloaded, run the FactSetTroubleshootingUtility.exe process. 
5. If available, click the Restart As Admin button in the lower left hand concern. 
6. Select the Register FDSW32.EXE options under the FactSet section. 
7. Click the Run Selected Items button in the lower right corner.      
Note: If the user does not have administrator privileges, they will need to contact their internal help desk or IT 
personnel to run the FactSetTroubleshootingUtility.exe process as an administrator. 

 
Problem: When launching FactSet, the user sees “The page cannot be displayed” message. 
 
Solution: If the user has admin rights, go to Start > Run and type: regsvr32 "C:\Program Files\Factset\fdstp.dll" 
(Your path may be different). Click OK.   
 
Note: If the user does not have admin rights, they will need to contact their internal help desk or IT personnel to 
complete the previous instructions. 
 
Problem: The user gets the error, “Failed to launch Adobe Acrobat Reader. Then install/repair Acrobat Reader 
installation” when attempting to open a FactSet research report. 
 
Solution: Launch Adobe Reader > go to Edit > Preferences > select Internet > verify "Display PDF in browser" is 
checked. 
 

  

https://support.factset.com/
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INSTALLATION ISSUES  

 
Problem: Client is getting Error 2753 when attempting to install or upgrade FactSet: 

"The installer has encountered an unexpected error installing this package. This may indicate a problem 
with this package. The error code is 2753." 

 
Solution: The FactSet Installers use a technology called Windows Installer, provided by Microsoft. This error is 
related to a Windows Installer failure. An administrator of the machine will need to re‐register vbscript.dll. 
 
Problem: User is getting Error 2755 when trying to install FactSet: 

"The installer has encountered an unexpected error installing this package. This may indicate a problem 
with this package. The error code is 2755." 

 
Solution: The installation file may be encrypted.  To decrypt the encrypted installation file, right‐click on the file, 
select Properties, click Advanced..., remove the check mark next to Encrypt contents to secure data and click OK  
 
Problem: User is getting Error 2908 when trying to install FactSet: 
 

"The installer has encountered an unexpected error installing this package. This may indicate a problem 
with this package. The error code is 2908." 
 

Solution: This problem usually occurs if the Microsoft .net framework is not installed or is corrupt.  To fix the issue, 
install, repair, or reinstall the Microsoft .NET framework version 4.0 or greater. 
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Log Files and Screen Shots 
Send Diagnostic Report 
Click on the FactSet white and blue F icon in the system tray and click Help > Send Diagnostic Report. This will 
automatically gather and upload the necessary information to FactSet. 
 
MSI Log File 
Go to Start > Run > type “%TEMP%” and click OK. Within that directory sort by Date Modified, you will find files 
named similar to “MSIxxxxxx.LOG.” Open a few of these files to see if there are references to FactSet. Choose the 
files that have been modified most recently. 
 
Event Viewer 
Take a screen shot of the Event Viewer. You can do this by going to Start > Settings > Control Panel > 
Administrative Tools > Event Viewer. Select Application from the left side and arrange the events on the right by 
date so the latest event is at the top. At the top you should also see "MsiInstaller" under the source column. 
Double click on MsiInstaller and take a screenshot of the error details. 
 
Error Message 
Take a screen shot of the error message and save it as a .jpeg file or paste it within a Word document. 
 
What should I do with the Log file and screen shots? 
Send Log files and screen shots to the Technical Deployment Team (techdeploy@factset.com) or contact your 
FactSet Consultant. 

 

Support  
If you have any questions on how to set up or deploy FactSet, contact Technology Solutions Engineering: 
Email: techsolutions@factset.com 
If you have any questions on how to use FactSet or need further assistance, contact the FactSet Helpdesk: 
Email: support@factset.com  

 

file:///C:/Users/kesmith/Documents/techdeploy@factset.com
mailto:techsolutions@factset.com
file:///C:/Users/kesmith/Documents/support@factset.com

