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Introduction The PanaView™ graphical user interface offers interactive 
communications between Windows-based PCs and GE Infrastructure 
Sensing instruments compatible with the company’s IDM protocol.   
(Compatible 32-bit Windows operating systems include Windows 
98SE, NT 4.0 (with Service Pack 6), 2000, XP and ME). With 
PanaView™, you can:

• load and save site file data

• create and save graph and log files

• display text output and graphs of live measurement data

• create custom templates for displaying text, graph and log data

• interface with multiple GE Infrastructure Sensing instruments.

This document focuses on particular applications suitable for meters 
that use the GE Infrastructure Sensing IDM protocol. For general 
PanaView™ applications such as creating graph and log files, 
displaying live measurement data, and creating custom templates, 
please refer to the general PanaView™ User’s Manual (910-211).
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IDM-Compatible Meters To determine if your meter uses the IDM protocol, please check the 
list of compatible meters below. If your meter is not on this list, 
please consult GE Infrastructure Sensing for appropriate instrument 
interface software:

IMPORTANT: PanaView™ does not support any IDM protocol-
based meters with multidrop RS485.

Wiring the RS232 
Interface

All IDM-protocol instruments utilize an RS232 interface to 
communicate with a PC. For details on wiring your RS232 interface, 
please refer to the Installation chapter of your instrument’s User’s 
Manual, and to the document EIA-RS Serial Communications 
(916-054).

Starting Up When the above connections have been made, power up the meter 
and the PC, then start up PanaView™. If a message appears as in 
Figure 1 below, PanaView™ is not able to communicate with the 
meter. Select Don’t Load Meter (this session only), click OK and then 
proceed to Setting Up the Communications Port on page 3.

Figure 1:  Communication Error Window

• AT868 • GN868 • XGM868

• DF868 • GS868 • XGS868

• GC868 • PT868 • XMO2/IDM

• GF868 • UPT868-C • XMT868 

• GM868 • UPT868-P • XMTC
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Setting Up the 
Communications Port

Use the steps below to establish communications with an IDM-
compatible meter.

1. Open the “New Meter Browser” window and expand the network 
tree. Then, highlight the My Computer(Name) branch by clicking 
on it.

2. Pull down the “Edit” menu by clicking on it in the menu bar.

3. Click on the “New” menu option to select it, and a submenu opens 
with two choices on it (see Figure 2 below).

Figure 2:  The Edit Menu
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Setting Up the 
Communications Port 
(cont.)

4. Click on the “Communications Port” option to select it. The Setup 
Communications screen appears similar to Figure 3 below.

Figure 3:  Setup Communications Screen 

5. Open the Protocol menu (the first of the drop-down menus) and 
click on IDM. 

6. Select any suitable available baud rate. A baud rate of 19,200 is 
appropriate for almost all applications. However, if you 
experience periodic communication reliability problems, you may 
wish to consider lowering the baud rate on your instrument and in 
PanaView™.

IMPORTANT: Be sure all the communications port settings match 
those made in setting up the meter’s serial port. 

7. Click on [OK] to complete data entry.
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Adding an IDM-
Compatible Meter

To add a meter on the IDM-configured communications port, 
complete the following steps: 

1. Highlight the communication port to which the meter will be 
added by clicking on it, and then open the “Edit” menu on the 
menu bar (if the communication port is not highlighted first, the 
“New Meter” option is not active in the “Edit” menu).

2. Click on the “New” option in the “Edit” menu (see Figure 4 
below).

Figure 4:  "New" Option in the "Edit" Menu

3. After clicking on the “New” option, the “Meter” menu option 
appears. Click on this option to select it.

4. The "New IDM Meter" screen (shown in Figure 5 below) opens. 
Enter the Network ID number for the meter, and click [OK].

Figure 5:  New IDM Meter Screen
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Adding an IDM-
Compatible Meter (cont.)

IMPORTANT: The Network ID number must match the Network ID 
programmed in the meter’s Communications menu.

If the initialization is successful, the Meter Browser shows a listing 
similar to Figure 6 below.

Figure 6:  The Updated Network Tree

However, if the settings do not match, or there is some other 
difficulty, a screen appears similar to Figure 7 below.

Figure 7:  Communication Error Screen

The screen offers the options of trying again or of canceling the 
operation. Click on the desired choice, and then on [OK] to confirm 
the choice or on [Exit Application] to close PanaView™. 
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Editing Meter Properties Through PanaView™, you can edit the properties of your IDM-
compatible meter. You can:

• Set the meter clock, or synchronize it with the PC clock

• Read, plot and save transducer signals

• Clear totalizers

• Save site files to the meter or PC

• Clear sites from the meter

• Print site files to the PC

To edit the properties of your IDM-compatible meter:

1. Highlight the meter (as shown in Figure 6 on page 6). 

2. Open the "Edit" menu and select the "Properties" option, as 
shown in Figure 8 below.

Figure 8:  The Properties Option in the Edit Menu
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Editing Meter Properties 
(cont.)

The window appears similar to Figure 9 below. To perform a specific 
task, refer to the appropriate section on the following pages.

• Setting the Meter Clock (page 9)

• Reading Transducer Signals (page 10)

• Plotting Transducer Signals (page 10)

• Saving Transducer Signals (page 11)

• Clearing Totalizers (page 11)

• Handling Site Files (page 12)

Figure 9:  Properties Window for IDM-Based Meter

Note: For illustration purposes, the meter shown here is a one-
channel GN868 flowmeter. Specific parameters will vary with 
your particular meter.
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Setting the Meter Clock The meter’s Time may be reset in three different ways:

• manually enter the time and date in the text box, or

• click on the [Sync to PC] option button to have PanaView™ set 
the time and date to the current PC setting, or

• click on the [Set] option button to open the dialog box shown in 
Figure 10 below. Set the desired date and time as indicated, and 
click on the [OK] option button.

Figure 10:  Time and Date Selection Window
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Reading Transducer 
Signals

To read a Signal from the meter:

1. Click on the Read Signals button. (If the meter is a multi-channel 
instrument, open the Channel drop-down menu and click on the 
desired channel.) After a moment, the Properties window appears 
similar to Figure 11 below.

Figure 11:  Active Signal Options in Properties Window

2. To select a different signal type, open the signal menu at the right 
(shown here with Raw Upstream highlighted) and click on the 
desired signal.
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Plotting Transducer 
Signals

To plot the selected signal, click on Plot.  A graphical window opens, 
as shown in Figure 12 below. 

Figure 12:  Signal Graph Window

Saving Transducer Signals To save the raw signal, click Save. A window opens similar to 
Figure 13 below. Enter the desired name, and click Save to save the 
signal as a text file.

Figure 13:  Save As Window

Clearing Totalizers To clear the meter totalizers, click on the Clear Totalizers button in 
the Properties window. The meter totalizers are reset to 0.
916-086B 11
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Handling Site Files To access site files, click on the Site Files button in the Properties 
window. The Site File Operations window (shown in Figure 14 
below) opens.

Figure 14:  The Site File Operations Window

Saving an Existing Site to 
the Meter

To save an existing site to the meter:

1. Select the radio button for Selected and highlight an existing site 
in the left pane.

2. Then click on the Save Site to Meter button.  A screen opens 
similar to Figure 15 below. 

Figure 15:  Site File Selection

3. Highlight the desired site and click Open. PanaView™ sends the 
site to the meter.
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Saving a New Site to the 
Meter 

To save a new site to the meter:

1. Select the radio button for New and click on the Save Site to Meter 
button.

2. A window opens similar to Figure 16 below. Enter the desired 
name, and click [OK].

Figure 16:  Site Name Entry Window

3. The Site File Selection window (Figure 15 on page 12) opens. 
Highlight a site with the desired settings, and click [Open]. 
PanaView™ saves the site in the meter with the new name and the 
desired settings.

Saving a Site to the PC To save a site to the PC:

1. Highlight the desired site in the left pane (see Figure 14 on 
page 12)

2. Click Save Site to PC. A window opens similar to Figure 13 on 
page 11.

3. Enter the desired site name and click [Save]. PanaView™ saves the 
site in the PanaView™ folder unless otherwise specified.

Note: If you have created a site on the meter after opening the Site 
File Operations window, you must close and reopen the 
window to click on the new site.
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Clearing a Site from the 
Meter

To clear a site from the meter:

1. Highlight the site in the left pane (see Figure 14 on page 12).

2. Click Clear Site From Meter. 

3. The program asks for confirmation. Click [OK]. The meter deletes 
the designated file.

Saving a Site in Text Form To store the data from a site file as a text file for display or printout:

1. Highlight the site in the left pane (see Figure 14 on page 12).

2. Click Save Site Print to PC.  

3. The Site File Selection window (Figure 15 on page 12) opens. 
Enter the desired site name (now with a .prt suffix) and click 
[Save]. PanaView™ displays a text version of the site, as shown in 
Figure 17 below.

Figure 17:  Printout of Site File

4. Click [Close] once to close the Site File Operations window, and a 
second time to close the Properties window and return to the 
Meter Browser.
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Changing Meter Settings Through PanaView™, users of IDM-compatible meters can handle 
remote programming of the meter. They can:

• Program and change a meter’s operating parameters; 

• Set up, start, and stop logs; 

• Calibrate and test inputs and outputs; 

• Clear various files. 

To access meter programming:

1. Enter the New Meter Browser option from the "File" menu. 

2. Expand the network tree until you reach the desired meter.

3. Then expand the meter tree as shown in Figure 18 below.

Figure 18:  New Meter Browser with Meter Branch
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Changing Meter Settings 
(cont.)

4. From the meter tree, expand the Edit Functions option. The 
window now appears similar to Figure 19 below, with a list of 
available menus. The menus listed are those available on the 
meter. (For illustration purposes, the specific menus shown are 
those for a one-channel GN868 flowmeter.) 

Figure 19:  Meter Tree with Edit Functions Option

5. To open a particular menu, double-click on that menu on the tree. 
For example, if you double-click on the Site Edit Menu, a window 
opens similar to Figure 20 below.

Figure 20:  The Site Edit Menu Window

Note: The options listed in the left pane correspond to the options 
available in the GN868 PROGRAM menu. For more 
information about the options in your instrument program and 
about appropriate parameters, consult the user’s manual for 
your particular instrument. 
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Changing Meter Settings 
(cont.)

6. To enter a particular option:

a. Highlight and double-click on the desired option in the left 
pane. Figure 21 below shows the first entry (Transducer 
Number) in the Pipe parameters option. The title above the 
center pane lists the current entry, while the center pane 
displays the available selections for that entry. 

b. Click on the desired choice; if the entry requires a numeric 
value, change the value displayed in the right pane. 

Figure 21:  The Pipe Parameters Option in the Site Edit Menu

c. Do one of the following:

Click on [Next Item] to proceed to the next menu item, 

                                      or 

Click on [Previous Item] to return back through the menu to a 
previous item.

Note: If you click on either [Next Item] or [Previous Item] without 
changing the settings, the current settings remain unchanged. 

As you step through the menu, the bottom panel lists the current 
settings you have modified or left unchanged, as shown in Figure 22 
on page 18. If you modify or step through more than five items, a 
scroll bar at the right of the panel lets you review the earlier settings.
916-086B 17



October 2004
Changing Meter Settings 
(cont.)

Figure 22:  Site Edit Menu with Current Settings

7. When you have completed entering parameters in a given option, 
click [Exit Page] to close the option. You can then double-click on 
another option, or click [Close] to close the window.  

You can double-click on another menu to modify its settings, or return 
to the New Meter Browser. For additional PanaView™ functions, 
refer to the PanaView™ User’s Manual.
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