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What is Calc?
Calc is the spreadsheet component of OpenOffice.org (OOo). A 
spreadsheet simulates a worksheet on your computer: you can fill the 
worksheet with data—usually numerical data—and then manipulate the 
data to produce certain results, organize the data, or display the data 
in diagrams.

Alternatively you can enter data and then use Calc in a ‘What If...’ 
manner by changing some of the data and observing the results 
without having to retype the entire spreadsheet or sheet.

Spreadsheets, sheets and cells
Calc works with elements called spreadsheets. Spreadsheets consist of 
a number of individual sheets, each containing a block of cells 
arranged in rows and columns.

These cells hold the individual elements—text, numbers, formulas etc.
—which make up the data to be displayed and manipulated.

Each spreadsheet can have many sheets and each sheet can have many 
individual cells. In version 3.0 of OOo, each sheet can have a maximum 
of 65,536 rows and a maximum of 1024 columns.

Parts of the main Calc window
When Calc is started, the main window looks similar to Figure 1.

Title bar and Menu bar
The Title bar, at the top, shows the name of the current spreadsheet. If 
the spreadsheet is new, then its name is Untitled X, with X being a 
number. When you save a new spreadsheet for the first time, you will 
be prompted to enter a name.

Under the Title bar is the Menu bar. When you choose one of the 
menus, a submenu appears with other options. The Menu bar can be 
modified, as discussed in Chapter 14 (Customizing OpenOffice.org).

Toolbars
Under the Menu bar by default are three toolbars: the Standard 
toolbar, the Formatting toolbar, and the Formula bar.
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Figure 1. Parts of the Calc window

The icons on these toolbars provide a wide range of common 
commands and functions. The toolbars can be modified, as discussed in 
Chapter 14 (Customizing OpenOffice.org).

Placing the mouse pointer over any of the icons displays a small box, 
called a tooltip. It gives a brief explanation of the icon’s function. For a 
more detailed explanation, select Help > What's This? and hover the 
mouse pointer over the icon. Tips and extended tips can now be turned 
on or off from Tools > Options > OpenOffice.org > General.

In the Formatting toolbar, the two rectangular areas on the left are the 
Font Name and Font Size menus (see Figure 2). If there is something 
in these boxes, they show the current setting for the selected area.

Figure 2. Font name and font size

Click the little button with an inverted triangle to the right of the box 
to open a menu. From the Font Name and Font Size menus, you can 
change the font and its size in selected cells.
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Formula bar
On the left of the Formula bar (see Figure 3) is a small text box, called 
the Name box, with a letter and number combination in it, such as D7. 
This is the column letter and row number, called the cell reference, of 
the current cell.

Figure 3. Formula Bar

To the right of the Name box are the the Function Wizard, Sum, and 
Function buttons.

Clicking the Function Wizard button opens a dialog from which you 
can search through a list of available functions, what variables each 
function takes and the result of the function with the given input .

The Sum button inserts a formula into the current cell that totals the 
numbers in the cells above, or to the left if there are no numbers 
above, the current cell.

The Function button inserts an equals sign into the selected cell and 
the Input Line, thereby setting the cell ready to accept a formula.

When you enter new data into a cell, the Sum and Equals buttons 
change to Cancel and Accept buttons  .

The contents of the current cell (data, formula, or function) are 
displayed in the Input Line, the remainder of the Formula bar. You can 
edit the cell contents of the current cell here, or you can do that in the 
current cell. To edit inside the Input Line area, click the appropriate 
part of the Input Line area, then type your changes. To edit within the 
current cell, just double-click the cell.

Individual cells
The main section of the screen displays the individual cells in the form 
of a grid, with each cell being at the intersection of a particular column 
and row.
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At the top of the columns and at the left-hand end of the rows are a 
series of gray boxes containing letters and numbers. These are the 
column and row headers. The columns start at A and go on to the right 
and the rows start at 1 and go on down.

These column and row headers form the cell references that appear in 
the Sheet Area box on the Formula Bar (Figure 3). These headers can 
also be turned off by selecting View > Column & Row Headers.

Sheet tabs
At the bottom of the grid of cells are the sheet tabs (see Figure 4). 
These tabs enable access to each individual sheet, with the visible, or 
active, sheet having a white tab.

Clicking on another sheet tab displays that sheet and its tab turns 
white. You can also select multiple sheet tabs at once by holding down 
the Control key while you click the names.

Figure 4. Sheet tabs

Status bar
At the very bottom of the Calc window you will find the status bar 
(shown in Figure 5) where you can quickly obtain some information on 
the current spreadsheet.

Figure 5: Status bar information

From left to right the status bar displays:
• The current sheet and the total number of sheets in the 

spreadsheet.
• The page style in use for the current sheet. Double-click to open 

the dialog and modify the page style.
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• The zoom level. Double-click to modify the zoom level.
• Selection mode. Click to toggle between default mode (STD), 

extended mode (EXT) and incremental mode (ADD).
• Modified flag. When the document has been modified, a star is 

displayed in this area of the status bar.
• Digital signature flag. If you have added a digital signature to the 

spreadsheet, a small padlock icon is displayed in this area. 
Double-click to digitally sign the spreadsheet.

• Selected cells functions. By default, this area shows the sum of 
the values contained in the selected cells. You can, however, 
change the function used by right-clicking on the area. The 
available functions are:
– Average (averages the values of the selection)
– CountA (counts the cells in the selection which are not empty)
– Count (counts the cells in the selection with a numeric value)
– Maximum (displays the maximum value in the selection)
– Minimum (displays the minimum value in the selection)
– Sum (the sum of the values in the selection)
– None.

Starting new spreadsheets
A new spreadsheet can be opened from any component of OOo, for 
example from Writer or Draw.

From the menu bar
Click File and then select New > Spreadsheet.

From the toolbar
Use the New Document  button on the Standard toolbar. (This 
button is always a page of text from the current component with a 
black arrow to the right.) Click the drop-down arrow for a choice of 
what type of document to open (text document, spreadsheet, and so 
on). Click the button itself to create a new document of the type that 
is currently open (if a spreadsheet is open, a new spreadsheet 
document will be created).

From the keyboard
If you already have a spreadsheet open, you can press Control+N to 
open a new spreadsheet.
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From a template
Calc documents can also be created from templates, if you have any 
spreadsheet templates available. Follow the above procedures, but 
instead of selecting Spreadsheet from the File menu, select 
Templates and Documents. On the Templates and Documents 
window, navigate to the appropriate folder and double-click on the 
required template. A new spreadsheet, based on the selected 
template, opens.

Opening existing spreadsheets
An existing spreadsheet can also be opened from any component of 
OOo.

From the menu bar
Click File and then select Open.

From the toolbar
Click the Open button  on the Standard toolbar.

From the keyboard
Use the key combination Control+O.

Each of these options displays the Open dialog, where you can locate 
the spreadsheet that you want to open.

Tip

You can also open a spreadsheet that has been recently worked 
on using the Recent Documents list. This list can be accessed 
from the File menu, directly below Open. The list displays the 
last 10 files that were opened in any of the OOo components.

Saving spreadsheets
Spreadsheets can be saved in three ways.

From the menu bar
Click File and then select Save.

From the toolbar
Click on the Save button  on the Function bar. If the file has been 
saved and no subsequent changes have been made, this button is 
grayed-out and unselectable.

From the keyboard
Use the key combination Control+S.
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If the spreadsheet has not been saved previously, then each of these 
actions will open the Save As dialog. Here you can specify the 
spreadsheet name and the location in which to save it.

Note

If the spreadsheet has been previously saved, then saving will 
overwrite the existing copy without opening the Save As 
dialog. If you want to save the spreadsheet in a different 
location or with a different name, then select File > Save As.

Navigating within spreadsheets

Going to a particular cell

Using the mouse
Place the mouse pointer over the cell and click.

Using a cell reference
Click on the little inverted black triangle just to the right of the Name 
box (Figure 3). The existing cell reference will be highlighted. Type the 
cell reference of the cell you want to go to and press Enter. Or just 
click into the Name box, backspace over the existing cell reference and 
type in the cell reference you want.

Using the Navigator
Click on the Navigator button  in the 
Standard toolbar (or press F5) to 
display the Navigator. Type the cell 
reference into the top two fields, 
labeled Column and Row, and press 
Enter. In Figure 6 the Navigator would 
select cell G28.
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Moving from cell to cell
In the spreadsheet, one cell, or a group of cells, normally has a darker 
black border. This black border indicates where the focus is (see 
Figure 7).

 
Figure 7. (Left) One selected cell and (right) a group of 
selected cells

Using the mouse
To move the focus using the mouse, simply move the mouse pointer to 
the cell where the focus should be and click the left mouse button. This 
changes the focus to the new cell. This method is most useful when the 
two cells are a large distance apart.

Using the Tab and Enter keys
• Pressing Enter or Shift+Enter moves the focus down or up, 

respectively.
• Pressing Tab or Shift+Tab moves the focus right or left, 

respectively.

Customizing the Enter key
You can customize the direction in which the Enter key moves the 
focus, by selecting Tools > Options > OpenOffice.org Calc > 
General.
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Figure 8: Customizing the effect of the Enter key

The four choices for the direction of the Enter key are shown on the 
right side of Figure 8. Depending on the file being used or on the type 
of data being entered, different directions can be useful.

The Enter key can also be used to switch into and out of editing mode. 
Use the options under Input settings in Figure 8 to change the Enter 
key settings.

Using the arrow keys
Pressing the arrow keys on the keyboard moves the focus in the 
direction of the arrows.

Using Home, End, Page Up and Page Down
• Home moves the focus to the start of a row.
• End moves the focus to the column furthest to the right that 

contains data.
• Page Down moves the display down one complete screen and 

Page Up moves the display up one complete screen.
• Combinations of Control and Alt with Home, End, Page Down, 

Page Up, and the cursor keys move the focus of the current cell in 
other ways. 

Tip Holding down Alt+Cursor key resizes a cell.

Moving from sheet to sheet
Each sheet in a spreadsheet is independent of the others though they 
can be linked with references from one sheet to another. There are 
three ways to navigate between different sheets in a spreadsheet.
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Using the keyboard
Pressing Control+PgDn moves one sheet to the right and pressing 
Control+PgUp moves one sheet to the left.

Using the mouse
Clicking one of the Sheet Tabs at the bottom of the spreadsheet selects 
that sheet.

If you have a lot of sheets, then some of the sheet tabs may be hidden 
behind the horizontal scroll bar at the bottom of the screen. If this is 
the case, then the four buttons at the left of the sheet tabs can move 
the tabs into view. Figure 9 shows how to do this.

Figure 9. Sheet tab arrows

Notice that the sheets here are not numbered in order. Sheet 
numbering is arbitrary—you can name a sheet as you wish.

Note
The sheet tab arrows that appear in Figure 9 only appear if 
you have some sheet tabs that can not be seen. Otherwise they 
will appear faded as in Figure 4.

Selecting items in a sheet or spreadsheet

Selecting cells
Cells can be selected in a variety of combinations and quantities.

Single cell
Left-click in the cell. The result will look like the left side of Figure 7. 
You can verify your selection by looking in the Name box.
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Range of contiguous cells
A range of cells can be selected using the keyboard or the mouse.

To select a range of cells by dragging the mouse:
1) Click in a cell.
2) Press and hold down the left mouse button.
3) Move the mouse around the screen.
4) Once the desired block of cells is highlighted, release the left 

mouse button.

To select a range of cells without dragging the mouse:
1) Click in the cell which is to be one corner of the range of cells.
2) Move the mouse to the opposite corner of the range of cells.
3) Hold down the Shift key and click.

To select a range of cells without using the mouse:
1) Select the cell that will be one of the corners in the range of cells.
2) While holding down the Shift key, use the cursor arrows to select 

the rest of the range.

The result of any of these methods looks like the right side of Figure 7.

Tip

You can also directly select a range of cells using the Name 
box. Click into the Name box as described in “Using a cell
reference” on page 12. To select a range of cells, enter the cell 
reference for the upper left hand cell, followed by a colon (:), 
and then the lower right hand cell reference. For example, to 
select the range that would go from A3 to C6, you would enter 
A3:C6.

Range of non-contiguous cells
1) Select the cell or range of cells using one of the methods above.
2) Move the mouse pointer to the start of the next range or single 

cell.
3) Hold down the Control key and click or click-and-drag to select a 

range. 
4) Repeat as necessary.
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Selecting columns and rows
Entire columns and rows can be selected very quickly in OOo.

Single column or row
To select a single column, click on the column identifier letter (see 
Figure 1).

To select a single row, click on the row identifier number.

Multiple columns or rows
To select multiple columns or rows that are contiguous:

1) Click on the first column or row in the group.
2) Hold down the Shift key.
3) Click the last column or row in the group.

To select multiple columns or rows that are not contiguous:
1) Click on the first column or row in the group.
2) Hold down the Control key.
3) Click on all of the subsequent columns or rows while holding 

down the Control key.

Entire sheet
To select the entire sheet, click on the small box between the A column 
header and the 1 row header (see Figure 10).

Figure 10. Select All box

You can also use the keyboard to select the entire sheet by pressing 
Control+A.

Selecting sheets
You can select either one or multiple sheets. It can be advantageous to 
select multiple sheets at times when you want to make changes to 
many sheets at once.

Selecting items in a sheet or spreadsheet 17
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Single sheet
Click on the sheet tab for the sheet you want to select. The active sheet 
becomes white (see Figure 4).

Multiple contiguous sheets
To select multiple contiguous sheets:

1) Click on the sheet tab for the first sheet.
2) Move the mouse pointer over the last sheet tab.
3) Hold down the Shift key and click on the sheet tab.

All the tabs between these two sheets will turn white. Any actions that 
you perform will now affect all highlighted sheets.

Multiple non contiguous sheets
To select multiple non contiguous sheets:

1) Click on the sheet tab for the first sheet.
2) Move the mouse pointer over the second sheet tab.
3) Hold down the Control key and click on the sheet tab.
4) Repeat as necessary.

The selected tabs will turn white. Any actions that you perform will 
now affect all highlighted sheets.

All sheets
Right-click over any one of the sheet tabs and select Select All Sheets 
from the pop-up menu.

Working with columns and rows

Inserting columns and rows
Columns and rows can be inserted in several different way and 
quantities.

Single column or row
A single column or row can be added using the Insert menu:

1) Select the column or rows where you want the new column or row 
inserted.

2) Select either Insert > Columns or Insert > Rows.

18 Getting Started with Calc



Note
When you insert a single new column, it is inserted to the left 
of the highlighted column. When you insert a single new row, it 
is inserted above the highlighted row.

A single column or row can also be added using the mouse:
1) Select the column or rows where you want the new column or row 

inserted. Right-click the header.
2) Select Insert Rows or Insert Columns.

Multiple columns or rows
Multiple columns or rows can be inserted at once rather than inserting 
them one at a time.

1) Highlight the required number of columns or rows by holding 
down the left mouse button on the first one and then dragging 
across the required number of identifiers.

2) Proceed as for inserting a single column or row above.

Deleting columns and rows
Columns and rows can be deleted individually or in groups.

Single column or row
A single column or row can only be deleted by using the mouse:

1) Select the column or row to be deleted.
2) Right-click on the column or row header.
3) Select Delete Columns or Delete Rows from the pop-up menu.

Multiple columns or rows
Multiple columns or rows can be deleted at once rather than deleting 
them one at a time.

1) Highlight the required number of columns or rows by holding 
down the left mouse button on the first one and then dragging 
across the required number of identifiers.

2) Proceed as for deleting a single column or row above.
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Working with sheets
Like any other Calc element, sheets can be inserted, deleted and 
renamed.

Inserting new sheets
There are many ways to insert a new sheet. The first step for all of the 
methods is to select the sheets that the new sheet will be inserted next 
to. Then any of the following options can be used.

• Click on the Insert menu and select Sheet, or
• Right-click on its tab and select Insert Sheet, or
• Click into an empty space at the end of the line of sheet tabs (see 

Figure 11).

Figure 11. Creating a new sheet

Each method will open the Insert Sheet dialog (Figure 12). Here you 
can select whether the new sheet is to go before or after the selected 
sheet and how many sheets you want to insert. If you are inserting only 
one sheet, there is the opportunity to give the sheet a name.

Figure 12. Insert Sheet dialog
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Deleting sheets
Sheets can be deleted individually or in groups.

Single sheet
Right-click on the tab of the sheet you want to delete and select 
Delete Sheet from the pop-up menu, or click Edit > Sheet > 
Delete.

Multiple sheets
To delete multiple sheets, select them as described earlier, then 
either right-click over one of the tabs and select Delete Sheet from 
the popup menu, or click Edit > Sheet > Delete from the menu 
bar.

Renaming sheets
The default name for the a new sheet is “SheetX”, where X is a 
number. While this works for a small spreadsheet with only a few 
sheets, it becomes awkward when there are many sheets. 

To give a sheet a more meaningful name, you can:
• Enter the name in the name box when you create the sheet, or
• Right-click on a sheet tab and select Rename Sheet from the 

pop-up menu and replace the existing name with a better one.

Note

Sheet names can contain almost any characters with the 
exception of those characters not allowed in MS Excel. This 
restriction has been artificially created for compatibility 
reasons. Attempting to rename a sheet with an invalid name 
will produce an error message.

Viewing Calc

Using zoom
Use the zoom function to change the view to show more or fewer cells 
in the window. For more about zoom, see Chapter 1 (Introducing OOo).

Freezing rows and columns
Freezing locks a number of rows at the top of a spreadsheet or a 
number of columns on the left of a spreadsheet or both. Then when 
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scrolling around within the sheet, any frozen columns and rows remain 
in view.

Figure 13 shows some frozen rows and columns. The heavier horizontal 
line between rows 3 and 14 and the heavier vertical line between 
columns C and H denote the frozen areas.. Rows 4 through 13 and 
columns D through G have been scrolled off the page. Because the first 
three rows and columns are frozen into place, they remained.

Figure 13. Frozen rows and columns

You can set the freeze point at one row, one column, or both a row and 
a column as in Figure 13.

Freezing single rows or columns
1) Click on the header for the row below where you want the freeze 

or for the column to the right of where you want the freeze.
2) Select Window > Freeze.

A dark line appears, indicating where the freeze is put.

Freezing a row and a column
1) Click into the cell that is immediately below the row you want 

frozen and immediately to the right of the column you want 
frozen.

2) Select Window > Freeze.

Two lines appear on the screen, a horizontal line above this cell and a 
vertical line to the left of this cell. Now as you scroll around the screen, 
everything above and to the left of these lines will remain in view.
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Unfreezing
To unfreeze rows or columns, select Window > Freeze. The check 
mark by Freeze will vanish.

Splitting the window
Another way to change the view is by splitting the window—also known 
as splitting the screen. The screen can be split either horizontally or 
vertically or both. This allows you to have up to four portions of the 
spreadsheet in view at any one time.

Why would you want to do this? Imagine you have a large spreadsheet 
and one of the cells has a number in it which is used by three formulas 
in other cells. Using the split screen technique, you can position the 
cell containing the number in one section and each of the cells with 
formulas in the other sections. Then you can change the number in the 
cell and watch how it affects each of the formulas.

Figure 14. Split screen example

Splitting the screen horizontally
To split the screen horizontally:

1) Move the mouse pointer into the vertical scroll bar, on the right-
hand side of the screen, and place it over the small button at the 
top with the black triangle.

Figure 15. Split screen bar on vertical scroll bar
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2) Immediately above this button you will see a thick black line 
(Figure 15). Move the mouse pointer over this line and it turns 
into a line with two arrows (Figure 16).

Figure 16. Split screen bar on 
vertical scroll bar with cursor

3) Hold down the left mouse button and a gray line appears, running 
across the page. Drag the mouse downwards and this line follows.

4) Release the mouse button and the screen splits into two views, 
each with its own vertical scroll bar.

Notice in Figure 14, the ‘Beta’ and the ‘A0’ values are in the upper part 
of the window and other calculations are in the lower part. You may 
scroll the upper and lower parts independently. Thus you can make 
changes to the Beta and A0 values and watch their affects on the 
calculations in the lower half of the window.

You can also split the window vertically as described below—with the 
same results, being able to scroll both parts of the window 
independently. With both horizontal and vertical splits, you have four 
independent windows to scroll.

Splitting the screen vertically
To split the screen vertically:

1) Move the mouse pointer into the horizontal scroll bar at the 
bottom of the screen and place it over the small button on the 
right with the black triangle.

Figure 17: Split bar on horizontal scroll bar

2) Immediately to the right of this button is a thick black line (Figure
17). Move the mouse pointer over this line and it turns into a line 
with two arrows.
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3) Hold down the left mouse button and a gray line appears, running 
up the page. Drag the mouse to the left and this line follows.

4) Release the mouse button and the screen is split into two views, 
each with its own horizontal scroll bar.

Note
Splitting the screen horizontally and vertically at the same 
time gives four views, each with its own vertical and 
horizontal scroll bars.

Removing split views
To remove a split view, do any of the following:

• Double-click on each split line.
• Click on and drag the split lines back to their places at the ends of 

the scroll bars.
• Select Window > Split to remove all split lines at the same time.

Tip

You can also split the screen using a menu command. Click in a 
cell that is immediately below and immediately to the right of 
where you wish the screen to be split, and choose Window > 
Split.

Entering data using the keyboard
Most data entry in Calc can be accomplished using the keyboard.

Entering numbers
Click in the cell and type in the number using the number keys on 
either the main keyboard or the numeric keypad.

To enter a negative number, either type a minus (–) sign in front of it or 
enclose it in parentheses (brackets), like this: (1234).

By default, numbers are right-aligned and negative numbers have a 
leading minus symbol.

Entering text
Click in the cell and type the text. Text is left-aligned by default.
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Entering numbers as text
If a number is entered in the format 01481, Calc will drop the leading 
0. (Exception: see Tip below.) To preserve the leading zero, for example 
for telephone area codes, type an apostrophe before the number, like 
this: '01481.

The data is now regarded as text by Calc. Formulas and functions will 
treat the entry like any other text entry, which typically results in it 
being a zero in a formula, and being ignored in a function.

Tip

Numbers can have leading zeros and be regarded as numbers 
(as opposed to text) if the cell is formated appropriately. Right-
click on the cell and chose Format Cells > Numbers. Adjust 
the leading zeros setting to add leading zeros to numbers.

Note

When using an apostrophe to allow a leading 0 to be displayed, 
the apostrophe is not visible in the cell after the Enter key is 
pressed—if the apostrophe is a plain apostrophe (not a “smart 
quote” apostrophe). If “smart quotes” are selected for 
apostrophes, the apostrophe remains visible in the cell.
To choose the type of apostrophe, use Tools > AutoCorrect > 
Custom Quotes. The selection of the apostrophe type affects 
both Calc and Writer.

Caution When a number is formatted as text care must be taken that 
the cell containing the number is not used in a formula since 
Calc will ignore the value.

Entering dates and times
Select the cell and type the date or time. You can separate the date 
elements with a slant (/) or a hyphen (–) or use text such as 10 Oct 03. 
Calc recognizes a variety of date formats. You can separate time 
elements with colons such as 10:43:45.

Speeding up data entry
Entering data into a spreadsheet can be very labor-intensive, but Calc 
provides several tools for removing some of the drudgery from input.

The most basic ability is to drop and drag the contents of one cell to 
another with a mouse. However, Calc also includes several other tools 
for automating input, especially of repetitive material. They include the 
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Fill tool, selection lists, and the ability to input information into 
multiple sheets of the same document.

Using the Fill tool on cells
At its simplest, the Fill tool is a way to duplicate existing content. Start 
by selecting the cell to copy, then drag the mouse in any direction (or 
hold down the Shift key and click in the last cell you want to fill), and 
then choose Edit > Fill and the direction in which you want to copy: 
Up, Down, Left or Right.

Caution
Choices that are not available are grayed out, but you can still 
choose the opposite direction from what you intend, which 
could cause you to overwrite cells accidentally unless you are 
careful.

Tip
A shortcut way to fill cells is to grab the “handle” in the lower 
right-hand corner of the cell and drag it in the direction you 
want to fill.

Figure 18: Using the Fill tool

You can also use the fill tool selecting some existing series of data that 
you want to extend. If the interval between the values in the selected 
cells is constant, Calc will try to guess and fill the selection with values 
that continue the sequence. For example, if you select three cells 
containing the values 1, 2 and 3 and fill the subsequent cell Calc will 
insert the value 4.

Using a fill series
A more complex use of the Fill tool is to use a fill series. The default 
lists are for the full and abbreviated days of the week and the months 
of the year, but you can create your own lists as well.
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To add a fill series to a spreadsheet, select the cells to fill, choose Edit 
> Fill > Series. In the Fill Series dialog, select AutoFill as the Series 
type, and enter as the Start value an item from any defined series. The 
selected cells then fill in the other items on the list sequentially, 
repeating from the top of the list when they reach the end of the list.

Figure 19: Specifying the start of a fill series (result is in Figure 18)

You can also use Edit > Fill > Series 
to create a one-time fill series for 
numbers by entering the start and end 
values and the increment. For example, 
if you entered start and end values of 1 
and 7 with an increment of 2, you 
would get the sequence of 1, 3, 5, 7.

In all these cases, the Fill tool creates 
only a momentary connection between 
the cells. Once they are filled, the cells 
have no further connection with one 
another.

Defining a fill series
To define a fill series, go to Tools > Options > OpenOffice.org Calc 
> Sort Lists. This dialog shows the previously-defined series in the 
Lists box on the left, and the contents of the highlighted list in the 
Entries box.
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Figure 21: Predefined fill series

Click New. The Entries box is cleared. Type the series for the new list 
in the Entries box (one entry per line), and then click Add.

Figure 22: Defining a new fill series

Using selection lists
Selection lists are available only for text, and are 
limited to using only text that has already been entered 
in the same column.

To use a selection list, select a blank cell and press 
Ctrl+D. A drop-down list appears of any cell in the same 
column that either has at least one text character or 
whose format is defined as Text. Click on the entry you 
require.

Sharing content between sheets
You might want to enter the same information in the same cell on 
multiple sheets, for example to set up standard listings for a group of 
individuals or organizations. Instead of entering the list on each sheet 
individually, you can enter it in all the sheets at once. To do this, select 
all the sheets, then enter the information in the current one.
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Caution
This technique overwrites any information that is already in 
the cells on the other sheets—without any warning. For this 
reason, when you are finished, be sure to deselect all the tabs, 
so that each sheet can be edited without affecting any others.

Editing data
Editing data is done is in much the same way as it is entered. The first 
step is selecting the cell containing the data to be edited.

Removing data from a cell
Data can be removed (deleted) from a cell in several ways.

Removing data only
The data alone can be removed from a cell without removing any of the 
formatting of the cell. Click in the cell to select it, and then press the 
Backspace key.

Removing data and formatting
The data and the formatting can be removed from a cell at the same 
time. Press the Delete key (or right-click and choose Delete Contents, 
or use Edit > Delete Contents) to open the Delete Contents dialog 
(Figure 23). From this dialog, the different aspects of the cell can be 
deleted. To delete everything in a cell (contents and format), check 
Delete all.

Figure 23: Delete Contents dialog
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Replacing all the data in a cell
To remove data and insert new data, simply type over the old data. The 
new data will retain the original formatting.

Changing part of the data in a cell
Sometimes it is necessary to change the contents of cell without 
removing all of the contents, for example if the phrase “See Dick run” 
is in a cell and it needs to be changed to “See Dick run fast.” It is often 
useful to do this without deleting the old cell contents first.

The process is the similar to the one described above, but you need to 
place the cursor inside the cell. You can do this in two ways.

Using the keyboard
After selecting the appropriate cell, press the F2 key and the cursor is 
placed at the end of the cell. Then use the keyboard arrow keys to 
move the cursor through the text in the cell.

Using the mouse
Using the mouse, either double-click on the appropriate cell (to select 
it and place the cursor in it for editing), or single-click to select the cell 
and then move the mouse pointer up to the input line and click into it 
to place the cursor for editing.

Formatting data
The data in Calc can be formatting in several ways. It can either be 
edited as part of a cell style so that it is automatically applied, or it can 
be applied manually to the cell. Some manual formatting can be 
applied using toolbar icons. For more control and extra options, select 
the appropriate cell or cells, right-click on it, and select Format Cells. 
All of the format options are discussed below.

Note

All the settings discussed in this section can also be set as a 
part of the style using the Styles and Formatting window. See 
Chapter 10 (Using Styles in Calc) in the Calc Guide for more 
information.
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Formatting multiple lines of text
Multiple lines of text can be entered into a single cell using automatic 
wrapping or manual line breaks. Each method is useful for different 
situations.

Using automatic wrapping
To set text to wrap at the end of the cell, right-click on the cell and 
select Format Cells (or choose Format > Cells from the menu bar, or 
press Ctrl+1). On the Alignment tab (Figure 24), under Properties, 
select Wrap text automatically. The results are shown in Figure 25.

Figure 24: Format Cells > Alignment dialog

Figure 25: Automatic text wrap
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Using manual line breaks
To insert a manual line break while typing in a cell, press Ctrl+Enter. 
This method does not work with the cursor in the input line. When 
editing text, first double-click the cell, then single-click at the position 
where you want the line break.

When a manual line break is entered, the cell width does not change. 
Figure 26 shows the results of using two manual line breaks after the 
first line of text. 

Figure 26: Cell with manual line breaks

Shrinking text to fit the cell
The font size of the data in a cell can automatically adjust to fit in a 
cell. To do this, select the Shrink to fit cell size option in the Format 
Cells dialog (Figure 24). Figure Figure 27 shows the results.

Figure 27: Shrinking font size to fit cells

Formatting numbers
Several number formats can be applied to cells by using icons on the 
Formatting toolbar. Select the cell, then click the relevant icon.

Figure 28: Number format icons. Left to right: currency, percentage, 
date, exponential, standard, add decimal place, delete decimal place.

For more control or to select other number formats, use the Numbers 
tab (Figure 29).
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Figure 29: Format Cells > Numbers

• Apply any of the data types in the Category list to the data.
• Control the number of decimal places and leading zeros.
• Enter a custom format code.

The Language setting controls the local settings for the different formats such as the date 
order and the currency marker.

Formatting the font
To quickly choose the font used in a cell, select the cell, then click the 
arrow next to the Font Name box on the Formatting toolbar and choose 
a font from the list.

Tip

To choose whether to show the font names in their font or in 
plain text, go to Tools > Options > OpenOffice.org > View 
and select or deselect the Show preview of fonts option in the 
Font Lists section. For more information, see Appendix D 
(Setting Up and Customizing Calc) of the Calc Guide.
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To choose the size of the font, click the arrow next to the Font Size box 
on the Formatting toolbar. For other formatting, you can use the Bold, 
Italic, or Underline icons.

To choose a font color, click the arrow next to 
the Font Color icon to display a color palette. 
Click on the required color.

(To define custom colors, use Tools > Options 
> OpenOffice.org > Colors. Ssee Appendix D 
of the Calc Guide.)

To specify the language of the cell (useful 
because it allows different languages to exist in 
the same document and be spell checked 
correctly), use the Font tab of the Format Cells 
dialog. Use the Font Effects tab to set other font 
characteristics. See Chapter 10 of the Calc 
Guide for more information.

Formatting the cell borders
To quickly choose a line style and color for the borders of a cell, click 
the small arrows next to the Line Style and Line Color icons on the 
Formatting toolbar. In each case, a palette of choices is displayed.

For more control, including the spacing between the cell borders and 
the text, use the Borders tab of the Format Cells dialog. There you can 
also define a shadow. See Chapter 10 of the Calc Guide for details.

Note

The cell border properties apply to a cell, and can only be 
changed if you are editing that cell. For example, if cell C3 has 
a top border (which would be equivalent visually to a bottom 
border on C2), that border can only be removed by selecting 
C3. It cannot be removed in C2.

Formatting the cell background
To quickly choose a background color for a cell, click the small arrow 
next to the Background Color icon on the Formatting toolbar. A palette 
of color choices, similar to the Font Color palette, is displayed.

(To define custom colors, use Tools > Options > OpenOffice.org > 
Colors. See Appendix D for more information.)

You can also use the Background tab of the Format Cells dialog. See 
Chapter 10 of the Calc Guide for details.
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Autoformatting cells and sheets
You can use the AutoFormat feature to quickly apply a set of cell 
formats to a sheet or a selected cell range.

1) Select the cells, including the column and row headers, that you 
want to format.

2) Choose Format > AutoFormat.

Figure 30: Choosing an AutoFormat

3) To select which properties (number format, font, alignment, 
borders, pattern, autofit width and height) to include in an 
AutoFormat, click More. Select or deselect the required options.

4) Click OK.

If you do not see any change in color of the cell contents, choose View 
> Value Highlighting from the menu bar.

Defining a new AutoFormat
You can define a new AutoFormat that is available to all spreadsheets.

1) Format a sheet.
2) Choose Edit > Select All.
3) Choose Format > AutoFormat. The Add button is now active.
4) Click Add.
5) In the Name box of the Add AutoFormat dialog, type a meaningful 

name for the new format.
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6) Click OK to save. The new format is now available in the Format 
list in the AutoFormat dialog.

Formatting spreadsheets using themes
Calc comes with a predefined set of formatting themes that you can 
apply to your spreadsheets.

It is not possible to add themes to Calc, and they cannot be modified. 
However, you can modify their styles after you apply them to a 
spreadsheet.

To apply a theme to a spreadsheet:

1) Click the Choose Themes icon in the Tools toolbar. If this toolbar 
is not visible, you can show it using View > Toolbars > Tools.
The Theme Selection dialog appears. This dialog lists the 
available themes for the whole spreadsheet, and the Styles and 
Formatting window lists the custom styles for specific cells.

2) In the Theme Selection dialog, select the theme that you want to 
apply to the spreadsheet.
As soon as you select a theme, some of the properties of the 
custom styles are applied to the open spreadsheet and are 
immediately visible.

3) Click OK.

Hiding and showing data
When elements are hidden, they are neither visible nor printed, but 
can still be selected for copying if you select the elements around 
them. For example, if column B is hidden, it is copied when you select 
columns A and C. When you need a hidden element again, you can 
reverse the process, and show the element.

To hide or show sheets, rows, and columns, use the options on the 
Format menu or the right-click (context) menu. For example, to hide a 
row, first select the row, and then choose Format > Row > Hide (or 
right-click and choose Hide).
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To hide or show selected cells, choose Format > Cells from the menu 
bar (or right-click and choose Format Cells). On the Format Cells 
dialog, go to the Cell Protection tab.

Figure 31: Hiding or showing cells

Outline group controls
If you are continually hiding and showing the same cells, you can 
simplify the process by creating outline groups, which add a set of 
controls for hiding and showing the cells in the group that are quick to 
use and always available.

If the contents of cells falls into a regular pattern, such as four cells 
followed by a total, then you can use Data > Group and Outline > 
AutoOutline to have Calc add outline controls based on the pattern. 
Otherwise, you can set outline groups manually by selecting the cells 
for grouping, then choosing Data > Group and Outline > Group. On 
the Group dialog, you can choose whether to group the selected cells 
by rows or columns.

When you close the dialog, the outline group controls are visible 
between either the row or column headers and the edges of the editing 
window. The controls resemble the tree-structure of a file-manager in 
appearance, and can be hidden by selecting Data > Outline > Hide 
Details. They are strictly for on screen use, and do not print.

The basic outline controls have plus or minus signs at the start of the 
group to show or hide hidden cells. However, if one or more outline 
group is nested in another, the controls have numbered buttons for 
hiding different levels of group.
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If you no longer need a group, place the mouse cursor in any cell in it 
and select Data > Group and Outline > Ungroup. To remove all 
groups on a sheet, select Data > Group and Outline > Remove.

Figure 32: Outline group controls

Filtering which cells are visible
A filter is a list of conditions that each entry has to meet in order to be 
displayed. You can set three types of filters from the Data > Filter 
sub-menu.

Automatic filters add a drop-down list to the top row of a column that 
contains commonly used filters. They are quick and convenient, and, 
because the condition includes every unique entry in the selected cells, 
are almost as useful with text as with numbers.

In addition to each unique entry, automatic filters include the option to 
display all entries, the ten highest numerical values, and all cells that 
are empty or not-empty, as well as a standard filter. Their drawback is 
that they are somewhat limited. In particular, they do not allow regular 
expressions, so you cannot display contents that are similar, but not 
identical, by using automatic filters.

Standard filters are more complex than automatic filters. You can set 
as many as three conditions as a filter, combining them with the 
operators AND and OR. Standard filters are mostly useful for numbers, 
although a few of the conditional operators, such as = and < > can 
also be useful for text.

Other conditional operators for standard filters include options to 
display the largest or smallest values, or a percentage of them. Useful 
in themselves, standard filters take on added value when used to 
further refine automatic filters.
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Advanced filters are structured similarly to standard filters. The 
differences are that advanced filters are not limited to three 
conditions, and their criteria are not entered in a dialog. Instead, 
advanced filters are entered in a blank area of a sheet, then referenced 
by the advanced filter tool to apply them.

Sorting records
Sorting arranges the visible cells on the sheet. In Calc, you can sort by 
up to three criteria, with each criterion applied one after the other. 
Sorts are handy when you are searching for a particular item, and 
become even more powerful after you have filtered data.

In addition, sorting is often useful when you add new information. 
When a list is long, it is usually easier to add new information at the 
bottom of the sheet, rather than adding rows in the proper places. 
After you have added information, you can then sort it to update the 
sheet.

You can sort by highlighting the cells to be sorted, then selecting Data 
> Sort. The selected cells can be sorted by the order of information in 
up to three columns or rows, in either ascending (A-Z, 1-9) or 
descending (Z-A, 9-1) order.

On the Options tab of the Sort dialog, you can choose the following 
options:

Case sensitive
If two entries are otherwise identical, one with an upper case letter 
is placed before one with a lower case letter in the same position.

Range contains column labels
Does not include the column heading in the sort.

Include formats
A cell's formatting is moved with its contents. If formatting is used 
to distinguish different types of cells, then use this option.

Copy sort results to
Sets a spreadsheet address to which to copy the sort results. If a 
range is specified that does not have the necessary number of cells, 
then cells are added. If a range contains cells that already have 
content, then the sort fails.

Custom sort order
Select the box, then choose one of the sort orders defined in Tools > 
Options > Spreadsheet > Sort Lists from the drop-down list.
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Direction
Sets whether rows or columns are sorted. The default is to sort by 
columns unless the selected cells are in a single column.

Printing
Printing from Calc is the same as printing from other OOo components 
(see Chapter 10), but some details are different, especially regarding 
preparation for printing.

The Print dialog (Figure 33), reached from File > Print, has some 
Calc-specific options: which sheets to print.

Figure 33. Part of the Print dialog

The Printer Options dialog (reached by clicking the Options button on 
the bottom left of the Print dialog) has only two choices, as shown in 
Figure 34: Suppress output of empty pages and Print only 
selected sheets.

Figure 34. Top of the Printer Options dialog
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Selecting sheets to print
You can select one or more sheets for printing. This can be useful if 
you have a large spreadsheet with multiple sheets and only want to 
print certain sheets. For example, an accountant might record costs 
over time with one sheet for each month. To print the November and 
December sheets, follow this procedure:

1) Go to the November sheet. Hold down the Control key and click 
on the tab of the December sheet.

2) To print all of the sheets, go to File > Print and select Options.

Note
The Options button is different from the Properties button. 
Properties deals with the settings of the printer, whereas 
Options deals with OOo’s settings.

3) Select Print only selected sheets. This choice affects the print 
preview, export, and printing of your spreadsheet. Click OK.

Caution If you keep the selected sheets selected, when you enter data 
on one sheet, you enter data on all sheets at the same time. 
This might not be what you want.

Selecting the page order, details, and scale
To select the page order, details, and scale to be printed:

1) Select Format > Page from the main menu.
2) Select the Sheet tab (Figure 35).
3) Make your selections, and then click OK.

Page Order
You can set the order in which pages print. This is especially useful in a 
large document; for example, controlling the print order can save time 
if you have to collate the document a certain way.Where a sheet prints 
on more than one page of paper, it can be printed either by column, 
where the first column of pages prints, and then the second column 
and so on, or by row as shown in the graphic on the top right of the 
page order dialog in Figure 35.
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Figure 35. The Sheet tab of the Page Style dialog

Print
You can specify which details to print. Those details include:

• Row and column headers
• Sheet grid—prints the borders of the cells as a grid
• Notes—prints the notes defined in your spreadsheet on a separate 

page, along with the corresponding cell reference
• Objects and graphics
• Charts
• Drawing objects
• Formulas—prints the formulas contained in the cells, instead of 

the results
• Zero Values—prints cells with a zero value

Note

Remember that since the print detail options are a part of the 
page’s properties, they are also a part of the page style’s 
properties. Therefore, different page styles can be set up to 
quickly change the print properties of the sheets in the 
spreadsheet.
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Scale
Use the scale features to control the number of pages the data will 
print on. This can be useful if a large amount of data needs to be 
printed more compactly or, if the reader has poor eyesight, text can be 
enlarged when it prints.

• Reduce/Enlarge printout—scales the data in the printout either 
larger or smaller. For example if a sheet would normally print out 
as four pages (two high and two wide), a scaling of 50% would 
print as one page (both width and height are halved).

• Fit print range(s) on number of pages—defines exactly how many 
pages the printout will take up. This option will only reduce a 
printout, it will not enlarge it. To enlarge a printout, the 
reduce/enlarge option must be used.

• Fit print range(s) to width/height—defines how high and wide the 
printout will be, in pages.

Using print ranges
Print ranges have several uses, including printing only a specific part 
of the data or printing selected rows or columns on every page. For 
more about using print ranges, see Chapter 5 (Printing, Exporting, and 
E-mailing) in the Calc Guide.

Defining a print range
To define a new print range or modify an existing print range:

1) Highlight the range of cells that comprise the print range.
2) Choose Format > Print Ranges > Define.

The page break lines display on the screen.

Tip
You can check the print range by using File > Page Preview. 
OOo will only display the cells in the print range.

Removing a print range
It may become necessary to remove a defined print range, for example 
if the whole sheet needs to be printed later.

Choose Format > Print Ranges > Remove. This removes all defined 
print ranges on the sheet. After the print range is removed, the default 
page break lines will appear on the screen.
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Printing rows or columns on every page
If a sheet is printed on multiple pages, you can set up certain rows or 
columns to repeat on each printed page.

For example, if the top two rows of the sheet as well as column A need 
to be printed on all pages, do the following:

1) Choose Format > Print Ranges > Edit. On the Edit Print 
Ranges dialog, type the rows in the text entry box under Rows to 
repeat. For example, to repeat rows 1 and 2, type $1:$2. In the 
Rows to repeat list, - none - changes to - user defined -.

Figure 36: Specifying repeating rows

2) Columns can also repeat; type the columns in the text entry box 
under Columns to repeat. For example, to repeat column A, type 
$A. In the Columns to repeat list, - none - changes to 
- user defined -.

3) Click OK.

Note
You do not need to select the entire range of the rows to be 
repeated; selecting one cell in each row works.

Page breaks
While defining a print range can be a powerful tool, it may sometimes 
be necessary to manually tweak Calc’s printout. To do this, you can use 
a manual break. A manual break helps to ensure that your data prints 
properly. You can insert a horizontal page break above, or a vertical 
page break to the left of, the active cell.

Inserting a page break
To insert a page break:

1) Navigate to the cell where the page break will begin.
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2) Select Insert > Manual Break.
3) Select Row Break or Column Break depending on your need.

The break is now set.

Row break
Selecting Row Break creates a page break above the selected cell. 
For example, if the active cell is H15, then the break is created 
between rows 14 and 15.

Column break
Selecting Column Break creates a page break to the left of the 
selected cell. For example, if the active cell is H15, then the break is 
created between columns G and H.

Tip
To see page break lines more easily on screen, you can change 
their color. Choose Tools > Options > OpenOffice.org > 
Appearance and scroll down to the Spreadsheet section.

Deleting a page break
To remove a page break:

1) Navigate to a cell that is next to the break you want to remove.
2) Select Edit > Delete Manual Break.
3) Select Row Break or Column Break depending on your need.

The break is now removed.

Note

Multiple manual row and column breaks can exist on the same 
page. When you want to remove them, you have to remove 
each one individually. This may be confusing at times, because 
although there may be a column break set on the page, when 
you go to Edit > Manual Break, Column break may be 
grayed out.
In order to remove the break, you have to be in the cell next to 
the break. So, for example, if you set the column break while 
you are in H15, you can not remove it if you are in cell D15. 
However, you can remove it from any cell in column H.

Headers and footers
Headers and footers are predefined pieces of text that are printed at 
the top or bottom of a sheet outside of the sheet area. They are set the 
same way.
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Headers and footers are assigned to a page style. You can define more 
than one page style for a spreadsheet and assign different page styles 
to different sheets. For more about page styles, see Chapter 10 of the 
Calc Guide.

To set a header or footer:
1) Navigate to the sheet that you want to set the header or footer 

for. Select Format > Page.
2) Select the Header (or Footer) tab. See Figure 37.
3) Select the Header on option.

From here you can also set the margins, the spacing, and height for 
the header or footer. You can check the AutoFit height box to have 
the height of the header or footer automatically adjust.

Figure 37: Header dialog

Margin
Changing the size of the left or right margin adjusts how far the 
header or footer is from the side of the page.

Spacing
Spacing affects how far above or below the sheet the header or 
footer will print. So, if spacing is set to 1.00", then there will be 1 
inch between the header or footer and the sheet.

Height
Height affects how big the header or footer will be.
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Header or footer appearance
To change the appearance of the header or footer, click More.

From this dialog (Figure 38) you can set the background and border of 
the header or footer. See Chapter 10 (Using Styles in Calc) in the Calc 
Guide for more information.

Figure 38: Header/Footer Border/Background

Contents of the header or footer
The header or footer of a Calc spreadsheet has three columns for text. 
Each column can have different contents.

To set the contents of the header or footer, click the Edit button in the 
header or footer dialog shown in Figure 36 to display the dialog shown 
in Figure 34.
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Figure 39: Edit contents of header or footer

Areas
Each area is independent and can have different information in it.

Header
You can select from several preset choices in the Header drop-down 
list, or specify a custom header using the buttons below. (If you are 
formatting a footer, the choices are the same.)

Custom header
Click in the area (Left, Center, Right) that you want to customize, 
then use the buttons to add elements or change text attributes.

 Opens the Text Attributes dialog.

 Inserts the total number of pages.

 Inserts the File Name field.

 Inserts the Date field.

 Inserts the Sheet Name field.

 Inserts the Time field.

 Inserts the current page number.
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