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ã  ã  ãIntroduction
If you’ve installed Rational Robot, you’re on your way to ensuring that your 
business-critical client/server and Web applications perform exactly as you want.

With Rational Robot, you can plan, develop, and execute functional tests for your 
Windows N T 4.0, Windows 2000, Windows 98, and Windows 95 applications. 
Thanks to Robot’s cross-Windows technology, tests created for applications on one 
Windows platform can be used to test applications on the others. 

H ere are some of the things that Rational Robot’s functional testing lets you do:

ã Test the appearance and state of GU I objects and the interactions between client 
applications and server databases. 

ã Test Web and e-commerce applications developed using Java and Dynamic 
H TML (DH TML).

ã Test client/server applications developed using Microsoft Visual Basic, Visual 
C+ + , Oracle Developer/2000, and Sybase PowerBuilder.

ã Test ERP applications developed by PeopleSoft, Oracle, and SAP.
1



In troduction
Take This Path to Successful Functional Testing

1 . Install Rational Robot as part of 
one of these packagesRational 
Suite TestStudio, Rational 
TeamTest, or Rational Robot.

2 . Create a Rational repository with 
the Rational Administrator to 
store your test assets. 

3 . Record and play back scripts in 
Rational Robot. 
2



Take Th is Path  to Successfu l Functiona l Testing
4 . Review the results of playback in 
the Rational LogViewer and 
Comparators.

5 . Create defects about any failures 
in your scripts with Rational 
ClearQ uest. 

6 . Analyze the results of your tests 
by creating reports in 
TestManager, LogViewer, and 
ClearQ uest.
3



In troduction
How Does Rational Robot Work?

Rational Robot lets all members of your development and testing teams implement 
a complete and effective testing methodology. 

Robot replaces the repetitive, often error-prone process of manual testing with the 
software tools to automate your testing effort. With Robot’s automated functional 
testing, you save time and ensure that your testing process produces predictable and 
accurate results. 

With Robot, you can start recording tests in as few as two mouse clicks. After 
recording, Robot plays back the tests in a fraction of the time it would take to repeat 
the steps manually.

Robot’s O bject-O riented Recording technology lets you generate scripts 
quicklysimply by running and using the application-under-test. Object-O riented 
Recording identifies objects by their internal object names, not by screen 
coordinates. And, if objects in successive builds change locations or their text 
changes, Robot still finds and tests them during playback.

Robot’s O bject Testing technology lets you test standard Windows objects and 
development environment (IDE) objects, whether they are visible or hidden in the 
interface. With O bject Testing, you can test hundreds, even thousands of properties 
for an object as well as an object’s data. 

Click here to start 
record ing.

These are the 
assets of the 
scrip t.

The scrip t com piler 
shows that no errors 
occurred .

Robot creates 
a scrip t as you 
work.
4



U sing Rational Tools for Successfu l Software Testing
Using Rational Tools for Successful Software Testing

Rational Robot is part of a suite of integrated tools that deliver a comprehensive 
solution for the entire functional testing processfrom writing and maintaining 
requirements to creating effective test scripts to tracking defects and analyzing 
results. 

This suite of Rational Test tools includes: 

Rational Adm inistrator – U se to administer Rational Test products and 
components. 

Rational TestM anager – U se to plan tests and manage test assets.

Rational LogViewer and Com parators – U se to review and analyze test results.

Rational TestFactory – U se to automatically generate scripts that provide extensive 
application coverage. 

Rational SiteCheck – U se to manage Internet and intranet Web sites. 

Rational ClearQ uest  – U se to track and manage change requests throughout the 
development and testing process. 

Rational Purify, Visual Q uantify, Visual Pure Coverage – U se to perform run-
time error-checking, determine application performance, and analyze code coverage 
during playback.

Managing Repositories with the Rational Administrator
The Rational Administrator lets you create and manage Rational repositories used 
for storing application testing information. Each repository consists of one or more 
databases and several directories of files. 

Projects in  the 
repository help you 
organize your test ing 
in form ation and 
resources for easy 
tracking. 

Each  repository consists 
of a  Ra tional Test 
database for storing test 
in form ation .

A  repository can a lso 
con ta in a Clea rQ uest 
database for storing 
defect in form ation.
5



In troduction
Planning and Managing Tests with Rational TestManager
Rational TestManager helps you plan testing strategies and manage your software 
testing effort. You can use TestManager to track information through all phases of 
the software development, test, and revision cycles. 

If you want, you can skip using TestManager and simply start recording with Robot. 
But the preferred usage model for any testing activity is to plan first. This lets you 
know the size of the testing effort at the beginning of a project. You’ll also be able to 
assign the development of each part of the testing project to the appropriate person. 
U sing TestManager to plan ahead ensures that your testing effort will run as 
smoothly as possible.

With Rational TestManager, you can do the following:

D isplay the 
results of a  
query.

Plan a new 
scrip t or ed it  
the properties 
of an exist ing  
scrip t.

Create, m anage, and  
d isp lay queries, reports, 
and bu ilds.

Create a test 
requirem ents 
h ierarchy to  
represen t the 
features and 
functionality that 
need to be tested in  
the applicat ion.
6



U sing Rational Tools for Successfu l Software Testing
Analyzing Results in the LogViewer and Comparators
The Rational LogViewer lets you view logs that are created when you play back 
scripts in Robot or run Pilots in TestFactory. (For information about TestFactory, 
see page 9.) 

Reviewing the playback results in the LogViewer reveals whether each script and its 
components passed or failed. 

To analyze each failure and then remedy it, you can use one of the LogViewer’s four 
ComparatorsGrid, O bject Properties, Text, and Image. Each Comparator 
graphically displays the ‘before and after’ results of playback. 

If there is no failure on playback, only a baseline file displaying the recorded data or 
image is displayed. If a failure occurs on playback, an actual file is displayed next to 
the baseline file. 

Since one of 
the verif icat ion
poin ts in  the 
scrip t fa iled, 
the en tire 
scrip t fa ils.

Each scrip t produces 
a log file that 
d isp lays the results 
of each  test with in  
the scrip t.

By com paring the 
baseline and 
actua l f iles, you 
can  determ ine if a  
fa ilu re is an  
in tentional change 
or a defect.
7



In troduction
Testing Applications with Rational TestFactory
TestFactory provides a new level of automated testing as an integrated component of 
Rational Robot. You can use TestFactory to:

ã Automatically create and maintain a detailed map of the application-under-test. 

ã Automatically generate scripts that provide extensive product coverage and 
scripts that encounter defects, without recording. 

ã Track executed and unexecuted source code, and report detailed findings. 

ã Shorten the product testing cycle by minimizing the time invested in writing 
navigation code. 

ã Automate distributed functional testing with TestAccelerator—an application 
that drives and manages the execution of scripts on remote machines. 

ã Play back Robot scripts in TestFactory to see code coverage and to create 
regression suites, and play back TestFactory scripts in Robot to debug them. 

TestFactory can test 
the objects in  the 
classes and  
subclasses known to 
occur in  GU Is.

In  th is pane, view 
a b itm ap of the 
selected  object.

In  th is pane, view 
in form ation about 
whatever is 
selected  in  the left 
paneusually 
properties for a  
selected  U I 
ob ject.Scrip ts recorded in  

Robot can be used 
a long with  scrip ts 
created  in  
TestFactory.

The applicat ion 
m ap lists each 
window and  con tro l 
in  the applicat ion -
under-test. 
8



U sing Rational Tools for Successfu l Software Testing
Managing Intranet and Web Sites with Rational SiteCheck
Rational SiteCheck lets you test the structural integrity of your intranet or World 
Wide Web site. It’s designed to help you view, track, and maintain your rapidly 
changing site. You can test the content of your Web site after every revision to ensure 
that changes have not resulted in defects. And you can capture a baseline of your Web 
site and compare it to the Web site at another point in time.

With SiteCheck you can: 

ã Visualize the structure of your Web site and display the relationship between 
each page and the rest of the site. 

ã Identify and analyze Web pages with active content, such as forms, Java, 
JavaScript, ActiveX, and Visual Basic Script (VBScript). 

ã Filter information so that you can inspect specific file types and defects, 
including broken links. 

ã Examine and edit the source code for any Web page, with color-coded text. 

ã U pdate and repair files using the integrated editor, or configure your favorite 
H TML editor to perform modifications to H TML files. 

ã Perform comprehensive testing of secure Web sites with Secure Socket Layer 
(SSL) support, proxy server configuration, and support for multiple password 
realms. 

In  th is pane, view 
the Web site’ s 
structu re.

Incom ing links to  
the W eb page

O utgoing 
links from  the 
W eb page

Web page 
being tested
9



In troduction
Managing Defects with Rational ClearQuest
Rational ClearQuest is a change-request management tool that tracks and manages 
defects and change requests throughout the development process. With ClearQuest, 
you can manage every type of change activity associated with software development, 
including enhancement requests, defect reports, and documentation modifications. 

With Robot and ClearQ uest, you can:

ã Submit defects directly from the LogViewer or SiteCheck. 

ã Generate defects directly from ClearQuest.

ã Modify and track defects and change requests. 

ã Analyze project progress by running queries, charts, and reports. 

ã Automatically send email about a defect to its owner or to the project leader.

Collecting Diagnostic Information During Playback
As an application is developed and tested, you can use the diagnostic capabilities of 
Rational Purify, Rational Visual Q uantify, and Rational Visual PureCoverage.

Rational Purify is a comprehensive C/C+ +  run-time error checking tool that 
automatically pinpoints run-time errors and memory leaks in all components of an 
application, including third-party libraries, ensuring that code is reliable. 

Rational Visual Quantify is an advanced performance profiler that provides 
application performance analysis, enabling developers to quickly find, prioritize, and 
eliminate performance bottlenecks within an application. 

Each tab 
provides 
im portan t 
in form ation 
about the 
defect.

In form ation autom atica lly 
transferred to  ClearQ uest 
from  the LogViewer.
10



What’ s N ext
Rational Visual PureCoverage is a customizable code coverage analysis tool that 
provides detailed application analysis and ensures that all code has been exercised, 
preventing untested code from reaching the end-user. 

What’s Next

N ow that you’ve been introduced to Rational Robot and its companion products and 
components, there’s still lots more to discover. 

H ere’s where you can find the information you need to get started with 
Rational Robot:

To find out about how to Take a look at

U pgrade from SQA Suite 6.x to 
Rational Suite TestStudio, 
Rational TeamTest, or Rational Robot

The information in the next chapter, 
Upgrade Information. 

U se each of the Rational Robot components The tutorial beginning in the chapter 
Learning Rational Robot – a Tutorial on page 
21.
1 1
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ã  ã  ãUpgrade Information
This chapter explains how to upgrade from SQA Suite 6.x to the current Rational 
Test products. It includes the following topics:

ã Summary of tasks

ã N ew terminology

ã U sing defect reports

ã U sing SQA 6.x repository data in a Rational repository

If you’re not upgrading, you should skip this chapter and take a look at the tutorial 
that begins on page 21.

Summary of Tasks

The following table lists tasks that you use to test an application, the component you 
used in SQ A Suite 6.x for each task, and the component that you now use in Rational 
Test products to do the same task: 

Task SQA Suite 6.x 
Component

Rational Test 
Component

Create a repository. SQA Administrator Rational Administrator

Create test requirements. SQA Manager Rational TestManager

Create test scripts or procedures. SQA Robot Rational Robot

Check for pass/fail of test scripts or 
procedures.

SQA Test LogViewer Rational LogViewer

Track defects. SQA Manager Rational ClearQ uest

Run a report on a defect. SQA Manager Rational ClearQ uest

Run a report on test coverage. SQA Manager Rational TestManager

Customize a report format. SQA Manager Rational ClearQ uest 
1 3



U pgrade In form ation
New Terminology

The following table lists the terminology found in SQA Suite 6.x and the new 
terminology in Rational Test products:

SQA Suite 6.x Term Rational Test Term

distributed GU I test distributed functional test

distributed regression test distributed functional test

Insert toolbar GU I Insert toolbar

log file log

SQA Administrator Rational Administrator

SQA Grid Comparator Grid Comparator

SQA Image Comparator Image Comparator

SQA Manager Rational TestManager

SQA O bject Properties Comparator Object Properties Comparator

SQA O CX Rational ActiveX Test Control

SQA Repository Rational repository

SQA Robot Rational Robot

SQA SiteCheck Rational SiteCheck

SQA Test Log Viewer Rational LogViewer

SQA Text Comparator Text Comparator

test case verification point

test log log

test procedure script

test schedule schedule

test script script
14



U sing D efect Reports
Scripting Languages
You no longer need to select a scripting language at installation. SQABasic is the 
scripting language used for recording GU I scripts, and it is installed automatically. 

Using Defect Reports 

Your Rational Suite TestStudio or Rational TeamTest software comes with special 
defect reports to help you manage your testing efforts. U se Rational ClearQuest to 
run these special reports to track your defects when testing applications. When you 
create a Rational repository that contains an associated ClearQuest database, you 
automatically get these defect reports and report formats to use with ClearQ uest. For 
more information about creating a repository with a ClearQuest database, see the 
section about creating a repository in the chapter Managing a Rational Repository in the 
Using the Rational Administrator manual.

You can customize a defect report or create new reports by customizing a report 
format or by creating a new report format using Rational ClearQuest. To customize 
a report format, you must install Crystal Reports 6.0 Professional Edition, which 
comes with your Rational Suite TestStudio or Rational TeamTest software. 

To install Crystal Reports:

ã U se the Crystal Reports installation directions that come with the Crystal 
Reports CD-RO M. 

Using SQA 6.x Repository Data in a Rational Repository

After installation, you can use data from an existing SQA Suite 6.x repository in a 
Rational repository. When you create a new Rational repository, the Create 
Repository wizard gives you the option of initializing a repository with data from an 
existing SQA Suite 6.x repository.

For information about creating a Rational repository with SQA Suite 6.x data, see the 
section about creating a repository in the chapter Managing a Rational Repository in the 
Using the Rational Administrator manual. 

When to Convert SQA Suite 6.x Repository Data
We recommend that you convert SQA Suite 6.x repository data to Rational 
repository data after you finish a project. 

For information about creating a Rational repository with SQA Suite 6.x data, see the 
section about creating a repository in the chapter Managing a Rational Repository in the 
Using the Rational Administrator manual. 
1 5



U pgrade In form ation
The following table lists the type of data in an SQ A Suite 6.x repository and which 
data converts to a Rational repository:

Type of Data

Converts from 

SQA Suite 6.x data to 

Rational repository 

data

Custom reports and graphs

Defects (For more information about defects, see Details About 
Converting Defects on the next page.)

√

E-mail rules

Filters for defects or test procedures

Groups (Privileges are not converted.) √

List reports

LoadTest schedules

Projects √

Requirements √

Test cases (called verification points in a Rational repository) √

Test logs

Test plans √

Test procedures (called scripts in a Rational repository) √

U sers (Privileges are not converted.) √

Virtual user test procedures (called virtual user scripts in a 
Rational repository)
16



U sing SQ A 6 .x Repository D ata in  a Rationa l Repository
Conversion Details
When you create a Rational repository with SQA Suite 6.x data, the following 
conversion takes place:

ã A script file name or verification point ID with a period (.) in the name is 
prefixed with _REN AMED_.

ã A period (.) in a script file name or verification point ID converts to an 
underscore (_).

For example, a script named wn95.tst converts to _REN AMED_wn95_tst. A 
verification point ID named alpha.b2 converts to _REN AMED_alpha_b2. 

Details About Converting Defects 
The Rational TeamTest and Rational Suite TestStudio products include a special 
version of ClearQ uest to track your defects. For your convenience, these products 
also include a specially designed defect form, the TeamTest defect form, similar to 
the SQA 6.x Manager defect form. For more information about using the TeamTest 
defect form, see the U sing the Rational Robot manual.

The following table lists each field of an SQA 6.x defect and the comparable Rational 
TeamTest defect field. The table also describes how certain fields are converted. 

The word “List” in the Description column of this table indicates that if you 
customize a list in SQA 6.x, it converts to a list in the TeamTest defect form.

SQA 6.x 
Defect Field

TeamTest 
Defect Field

Conversion Description

ID N ew ID
generated

The SQA 6.x ID does not appear on the defect 
form, but you can use the query feature of 
ClearQuest to find it. For more information, see 
the Rational ClearQuest H elp.

Description H eadline/ 
Description

Converts the first 125 characters or up to the 
first carriage return and places this text in the 
H eadline field. The entire SQA 6.x Description 
field also appears in the Description field of the 
TeamTest defect form.

Priority Priority List

Severity Severity List

Occurrences (not converted)

Keywords Keywords List

Symptoms Symptoms List
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U pgrade In form ation
Build Found N otes In SQA 6.x, a Build Found field is a text 

field. The text data from the Build Found 

field is stored in N otes. In Rational 7.x, 

Builds are objects that contain log folders 

and logs. A Build object is not created for 

each SQA 6.x Build Found field.

Build Fixed N otes In SQA 6.x, a Build Fixed field is a text field. 
The text data in the Build Fixed field is stored in 
N otes. In Rational 7.x, Builds are objects that 
contain log folders and logs. A Build object is 
not created for each SQA 6.x Build Fixed field. 

Proc Script

Case Verification 
Point

Cycle (not converted)

Reported By Reported By 
Contact

Reported By 
Company

Reported By 
Company

H ardware H ardware List

Operating 
System

Operating 
System

List

Other Other 
Environment

Test Station (not converted) In SQA 6.x, a Test Station field is a text field. In 
Rational 7.x, the Computers field replaces the 
Test Station field and is an object. A Computer 
object is not created for each SQA 6.x Test 
Station field. 

Log (not converted)

Custom 1 Custom 1 List

If you customized the label for this field in SQA 
6.x, the label is not converted. U se the 
ClearQuest Designer to customize this label.
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U sing SQ A 6 .x Repository D ata in  a Rationa l Repository
Troubleshooting
The convert.txt file in the converted project directory contains the conversion status 
of each verification point and script. U se this file as a diagnostic tool if you have any 
problems with your data after conversion. 

Custom 2 Custom 2 List

If you customized the label for this field in SQA 
6.x, the label is not converted. U se the 
ClearQuest Designer to customize this label.

Custom 3 Custom 3 If you customized the label for this field in SQA 
6.x, the label is not converted. U se the 
ClearQuest Designer to customize this label.

Attachment Attachments You can attach more than one file after you 
convert to a 7.x Rational repository.

Requirement Requirement

Status H istory H istory

Resolution Resolution List

Resolution 
Description

Resolution N ote

Modified 
Software

(not converted)
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ã  ã  ãLearning Rational Robot - a Tutorial
This tutorial takes you through a typical software testing cycle in which you’ll use the 
functional testing capabilities of Rational Robot to test a sample client/server 
application. 

As you follow the examples in this tutorial, you’ll quickly realize how easy it is to use 
Rational Robot to identify changes or unintentional errors in an application. You’ll 
understand how Robot lets you cover all phases of functional testing and how to best 
use Robot for your own testing projects.

What Is Automated Functional Testing?

Automated testing uses software tools to replace repetitive and often error-prone 
manual testing. Automated testing saves time and enables a reliable, predictable, and 
accurate testing process.

With automated functional testing, you validate the behavior of an application. 
Functional testing lets you exercise the application’s GU I to verify that the 
application responds appropriately to user and system input, and that it conforms to 
project requirements. 

Functional testing focuses on: 

ã The ability of the application to address requirements—for example, verifying 
that the application logic functions as designed.

ã The appearance and state of GU I objects for example, verifying that changes to 
the GU I are correct from one build to another. 

ã The operation of the application—for example, verifying that an application 
accurately processes server requests and responses.
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Learn ing Rational Robot - a  Tu toria l
About the Sample Application

The sample application that you’ll use with this tutorial is called Classics Online, 
developed using Microsoft Visual Basic. 

The intent of the Classics O nline application is to allow customers to browse 
through an online catalog and place orders. When the Classics Online application is 
completed, tested, and successfully deployed, it will provide automated order- entry 
and fulfillment capabilities for customers.

About the Tutorial Examples

This tutorial contains seven examples. Each is based on a scenario in which you’re 
an employee of Classics, Inc., working in the Quality Assurance (QA) department. 
Your department is responsible for testing the new application—making sure defects 
are discovered and fixed before the application is deployed.

As you go through the examples in this tutorial, you’ll become familiar with the six 
general phases that occur in most testing projects and the Rational Test products 
used in each phase:

For this testing phase Use this Rational Test product

Test PlanningDefine requirements, and 
plan and manage your test assets.

Rational TestManager 

See Example 1.

Test D evelopmentRecord, verify, and 
enhance your scripts.

Rational Robot

See Examples 2, 3, and 7.

Test ExecutionPlay back the scripts against 
different builds of your application.

Rational Robot 

See Example 4.

Test ResultsReview and analyze the results 
of the tests.

Rational LogViewer and Comparator

See Examples 3 and 4.

D efect TrackingSpecify defects and assign 
them to the appropriate person for resolution.

Rational ClearQuest

See Example 5.

Summary Reporting and Analysis Run 
reports to determine test coverage and the state 
of defects.

Rational TestManager and ClearQuest

See Example 6.
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W here to Find  O ther U sefu l Testing T ips
Where to Find Other Useful Testing Tips

In addition to this tutorial, you can learn about Rational Robot by using the testing 
tips in the Rational Robot Try it! cards. Each card shows you—in a minimal amount of 
steps—how to use Robot to test the controls specific to one of the following 
development environments: Visual Basic, Oracle, PowerBuilder, Java, and H TML. 

When you use the testing tips in a Try it! card on the corresponding sample applet, 
you’ll discover, in just minutes, how to record tests that verify the controls specific 
to the environment you select.
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ã  ã  ãPreparing to Start the Tutorial

Before You Begin

Before you can test the Classics Online sample application, you need to complete 
these tasks: 

ã Install Rational Robot. 

ã Install the Classics Online sample application. 

ã Connect to a sample Rational repository. 

Each task is described in the sections that follow. 

Installing Rational Robot

Rational Robot is available in three different Rational product packages. To install 
your version of Rational Robot, see one of the following manuals:

To install Rational Robot as part of Take a look at

Rational Robot package Installing Rational TeamTest and 

Rational Robot

Rational TeamTest package Installing Rational TeamTest and 

Rational Robot

Rational Suite TestStudio package Installing Rational Suite
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Installing the Sample Application
After you’ve installed Rational Robot, you need to install the Classics O nline sample 
application.

1 . Click Start → Program s → Rat iona l program  group  → Rational Test → 
Setup Rational Test Sam ples.

2 . Select Classics O nline.

3 . Click N ext, and then click Finish.

The sample application appears on the Windows Start menu under Program s → 
Rational Test Sam ples.

Connecting to the Sample Repository
When you use a Rational Test application, you need to connect to a Rational 
repository. The Rational repository stores information about your software testing 
and development efforts. When you test an application, you can create as many 
repositories as needed. And you can use the repository as a single user, or you can 
share it as a member of a team. 

For this tutorial, we’ve provided you with a sample Rational repository, installed 
when you installed the sample application. 

To connect to the sample repository: 

1 . Click Start → Program s → Rational program  group → Rational Test → 
Rational Adm inistrator. 

2 . Click File → Connect.

3 . Select the ClassicsRepository path and click O K .

N O TE: If you want to use the testing tips in the Rational Robot Try it! cards, 
select some or all of the other samples.
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What ’s N ext
4 . Accept adm in as the user ID, with no password, and click O K . 

5 . Minimize the Rational Administrator window. 

What’s Next

You’re ready to begin the tutorial by following the examples in this guide. 

A pro ject 
helps you 
organ ize your 
test ing 
in form ation  
and 
resources for 
easy 
tracking .

The 
database 
stores your 
test assets.
2 7
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ã  ã  ãTest Planning

Objectives

ã Define two test requirements that identify the functionality to test. 

ã Add the test requirements to the requirements hierarchy. 

ã Define a script to verify the requirements. 

ã Associate the script with the test requirements. 

Scenario

To help you with your test planning activities, you’ll use Rational TestManager. Like 
other Rational Test products, TestManager accesses a Rational repository. The 
repository maintains test assets—all of the information about your testing project.

For this tutorial, we assume that you’ve already created a test plan. The test plan 
describes the features and functionality that you’re going to test and how you’re 
going to test them. Often, the test plan describes resource requirements and defines 
schedules. 

As part of the test planning phase for this tutorial, you’ll define test requirem ents—
the features and functionality that you plan to test in the application. 

You’ll use TestManager to build a test requirem ents hierarchy. Each level in the 
hierarchy will represent a specific functional characteristic or feature that’s found in 
the application or expected to be in the application. By defining these test 
requirements before you begin to test, you’ll have a good idea about what you have 
to test.

After you’ve defined the test requirements, you’ll plan a script that you can use to 
verify each requirement that you’ve created.
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Defining Test Requirements

As part of the test planning phase, you need to define the requirements for your 
testing project. The requirements will help you ensure that you provide full test 
coverage for your application.

Since testing is usually an iterative process that tests one level of the application, then 
the next, and then goes back to repeat the process, TestManager lets you create a test 
requirements hierarchy to easily define and display your requirements. 

A test requirements hierarchy is a graphical tree structure. The root is the name of 
the testing project—for example, Classics. The branches define the test 
requirements for each phase of the project.

Requirements in TestManager are stored in a Rational RequisitePro database. 
RequisitePro is a requirements management tool that helps project teams control the 
development process by organizing, managing, and tracking the changing 
requirements of their testing project.

The nam e of the 
test ing  pro ject

Requ irem ents defined 
for test ing
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D efin ing Test Requ irem ents
Defining and Inserting a Requirement in the Hierarchy
As you define and insert requirements, you can view the evolving hierarchy in 
TestManager. This ensures that the requirements that appear in the hierarchy reflect 
the functionality you want to test. You can add requirements to the hierarchy at any 
time in the testing cycle, and you can delete them at any time.

To define and insert a test requirement: 

1 . Click Start → Program s → Rational product nam e → Rational 
TestM anager.

2 . Click File → O pen Requirem ents. 

Because you’re connected to the sample repository, ClassicsRepository and to 
the project Classics, the requirements hierarchy for that project appears. 

3 . To insert a child requirement at the same level as U ser Activities, select U ser 
Activities.

M ake su re that ClassicsRepositor
selected .

Type adm in as your ID . 

M ake sure the pro ject is Classics

Click O K.

The tit le bar d isp lays t
nam e of the pro ject y
selected during log in

Click here to  d isp lay 
the four m ain 
requirem ents from  
the test p lan .

Click here to  d isp lay 
the Functional 
Requirem ents.
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4 . Click Edit → Insert Requirem ent.

5 . To insert a child requirement under D evelopment Activities, select it.

6 . Click Edit → Insert Child Requirem ent.

7 . Type Check O rder Entry Logic and click O K . 

You’ve just inserted a requirement. Later on, a member of the development team will 
check the order-entry logic as part of the testing process for the Classics Online 
application.

Type 
D evelopm ent 
Activities

Click O K.

Inserted paren t 
requirem ent.

Inserted ch ild  
requirem ent.
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D efin ing a  Script
Defining a Script

The next step in the planning process is to define scripts that you’ll use to validate 
your test requirements. A script is a specific sequence of actions and tests recorded 
against the application-under-test. When you define a script, it becomes a place-
holder for the script that you’ll actually record later using Rational Robot. 

If you want, you can skip this test planning phase and simply start recording with 
Robot. But the preferred usage model for any testing activity is to plan first. This lets 
you know at the beginning of a project the size of the testing effort. You’ll also be able 
to assign the development of each script to the appropriate person. And, you’ll be 
able to develop logical and consistent naming conventions for all of your scripts.

Defining a Script and Attaching It to a Requirement
To define a script and attach it to a requirements:

1 . Make sure that the test requirements hierarchy for the Classics project is open 
and the U ser Activities branch expanded.

2 . Click Place an O rder and expand it to view the requirements under it.

3 . Right-click the requirement Single Item  - Place an order for a  single a lbum . 

4 . Click Plan Script .

5 . Fill in the fields of the General tab. 

Select your W indows environm ent.

Click O K.

Select Functional as the test type.

Select BRABKIN .

N am e the scrip t SIN GLE O RD ER.

Select Functional as the test type.

Type M ake su re a lbum  in form ation  is 
retrieved correctly from  database.
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The script SIN GLE O RD ER appears under the requirement Single Item  in the 
hierarchy. SIN GLE O RD ER is the placeholder for the script that you’ll record later 
to test the Single Item  requirement.

6 . To confirm that the script is attached to the requirement, select SIN GLE O RD ER 
and right-click. Since one of the options is D etach, you can assume that the 
script is attached to the requirement.

Summary

You’ve just had a quick introduction to some of the test planning functionality in 
TestManager. And, you’ve started to plan your test suite by using TestManager to:

ã Define test requirements and insert them in the Requirements hierarchy. 

ã Define a script for recording later in Rational Robot. 

ã Attach the script to a specific test requirement to track the progress of your 
testing efforts.

What’s Next

You’re now ready to begin recording with Rational Robot.
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ã  ã  ãRecording a Script

Objectives

ã Record a script that validates specific test requirements. 

ã Test the album data displayed in the tree control. 

ã Test the text property of a pushbutton. 

ã Test the data retrieved from the order-entry database. 

ã Test the properties of a hidden data control.

Scenario

In the last example, you used Rational TestManager to develop a test strategy. By 
planning ahead, you’ve already defined a script called SIN GLE O RDER that you can use 
in this example.

When you record scripts for an early build of an application, you’re investing in 
future testing efforts. As soon as the next build becomes available, you can play back 
the scripts you recorded and test the new build in a fraction of the time it would take 
to perform the tests manually. 
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Record ing a  Script
Recording a Script

The script that you’ll record is the SIN GLE O RDER script that you defined in 
TestManager.

When you record a script, Robot uses its O bject-O riented Recording technology to 
record both the actions as you navigate through the application-under-test and the 
tests that you insert to verify controls and data in the application. 

Navigating Through the Application
To start recording the script SIN GLE O RDER:

1 . Before you begin to record, minimize all open windows except TestManager.

2 . Start Robot by clicking the Rational Robot button on the TestManager toolbar.

N otice how easy it is to switch from one Rational Test product to another. Since 
you’ve already logged in to the Rational repository from TestManager, you can 
access Robot and other Rational Test products without logging in again.

3 . Minimize TestManager.

4 . From Robot, choose File → Record GU I.

N O TE: If you were testing your own Visual Basic, Oracle Forms, Java, or any 
other application containing ActiveX controls, you would install one of the 
Rational Test Enablers before you began to test. Each enabler is non-intrusive and 
allows Rational Robot to thoroughly test the controls specific to your application’s 
development environment. For more information about the Rational Test 
Enablers, see the Using Rational Robot manual.

Type an S for the 
Sing le O rder  scrip t.

N otice that the scrip t 
Single O rder is a lready 
defined and ready to  be 
recorded.

Click O K .
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Recording a  Script
The GU I Record toolbar appears in the upper-left corner after Robot is minimized. 
You’re about to begin recording by inserting different testing capabilities into the 
script. To begin:

5 . Click the Start Application button.

6 . Click Browse and select the following default path for Build A of the Classics 
Online sample application:

C:\Program Files\Rational\Rational Test 7\Sample Applications\ClassicsOnline\ClassicsA.exe

7 . Click O pen, and then click O K.

8 . Click O K to log in as Trent Culpito and to open the Classics Online application.

Click the D isp lay GU I Insert  Toolbar bu tton to d isp lay the GU I Insert 
toolba r.

Point to (don’ t  click) 
each bu tton to  view 
its ToolT ip.

N O TE: Starting the application-under-test while you’re recording lets you 
start an application without using the Start menu or the Windows desktop. 
This gives you more precise control over your test environment and ensures 
that during playback, testing begins with the application in the same state that 
it was in during recording. It also lets you run tests unattended.
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Record ing a  Script
9 . Scroll down until you see M ozart . 

ouble-click M ozart  to  
isp lay the a lbum s you 
an order.

Select 
Sym phony N o. 3 4 .

N O TE: It’s important to know that as you follow this tutorial, you can make 
mistakes—add or repeat steps—without interfering with the script you’re 
recording. As long as you don’t close the Classics application before the script 
is complete or open different application windows, you should be all set.
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Viewing the Beginn ings of the Script
Viewing the Beginnings of the Script

You’ve just navigated through the sample application and clicked a few objects. 
Robot captured each of your user actions in the SIN GLE O RDER script. You’ll 
continue to do some more recording, but now’s a good time to take a look at the 
developing script.

To view the script: 

1 . On the GU I Record toolbar, click the O pen Robot W indow button. N one of 
these actions are recorded in the script.

2 . Maximize the script to view the actions that you’ve taken so far. 

3 . After you’ve looked at the recorded actions in the script, minimize the Robot 
window.

You’re now ready to begin to insert verification points in the script to test specific 
parts of the Classics Online application. 

Adding Verification Points

During recording, you can insert one or more verification points in a script to 
capture and store information about the objects that you’re testing. The information 
becomes the baseline for your testing. You can then play back the script against 
future builds to check the progress of your application. If there are any changes, 
you’ll be able to compare the baseline to the actual and decide which changes are 
enhancements and which are defects.

Start ing the 
applicat ion
Logging in

Record ing the 
in terna l VB nam e 
of the tree con trol,  
t reM a in, not just 
the screen  
coord inates.

Scro lling
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Record ing a  Script
Robot provides various types of verification points. Two of the most powerful—
O bject Properties and O bject D ata—support Robot’s in-depth Object Testing 
technology. 

O bject Testing inspects and verifies all the properties and data in the visible and 
non-visible objects in an application. Object Testing records objects by their internal 
object names, not just by the text that appears externally on the object nor by the 
object’s location in a window or dialog box. 

Capturing Data in a Tree Control – Verification Point 1
The first verification point that you’ll insert into the single order script is an O bject 
Data verification point. This type of test captures and verifies data inside standard 
Windows objects. It also provides specialized support for environment-specific 
objects such as Visual Basic data controls, ActiveX controls, O racle Forms base-table 
blocks, and PowerBuilder DataWindows.

To create the first verification point:

1 . If necessary, click the D isplay GU I Insert Toolbar button.

2 . If necessary, minimize the TestManager window.

3 . Click the O bject D ata  button on the right side of the GU I Insert  toolbar. ICON

Robot automatically names the verification point with its autonaming feature. 
Autonam ing automatically inserts a verification point name for you. You could 
use your own naming conventions, but for this tutorial you’ll use the 
autonaming feature.

4 . Click O K  to accept O bject D ata  as the name of the first verification point.

N O TE:

D rag the O b ject  Finder  tool 
around the contro ls in  the Classics 
O n line window. N otice that it  
iden tif ies each  contro l. 

Press the SH IFT key as you  drag 
the too l to  see the nam e Robot 
uses to  recogn ize each  contro l 
(N am e= ).
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Adding  Verifica tion Poin ts
5 . Drag the O bject Finder tool to the list of composers and albums at the top of 
the application and release the mouse button.

6 . Scroll through the captured data in the Object Data Verification Point dialog box 
to see what Robot captured.

7 . Click O K  to complete the verification point.

In the next sections, you’ll continue recording the single order script by adding two 
Object Properties verification points and another Object Data verification point.

The selected object should be 
TreeView (O CX ) Visua l Basic. If 
it  isn ’ t , repeat step 5 .

Click O K .

Robot captured a ll o f the data 
in  the tree contro leven in  
branches that are not 
expanded. 

You can select and deselect 
the cells. Robot tests only the 
cells that are selected before 
you  continue.

M ake sure a ll the cells are 
selected.
4 1



Record ing a  Script
Capturing the Properties of a Pushbutton – Verification Point 2
The next verification point that you’ll insert into the single order script is an Object 
Properties verification point. Capturing and testing an object’s properties is an 
extremely important capability in real-world testing situations. 

An object’s properties describe its appearance (width, height, color, etc.), state 
(enabled, disabled, etc.), behavior, and non-visible properties (SQL statements, 
computed fields, etc.). 

In the sample application, you’ll record a verification point to verify the text on the 
pushbutton press here to order. In the next build of Classics (Build B), the text on 
this button will change, and Robot will catch this change. At that point, you’ll decide 
whether it’s a defect or an intentional change.

To create the second verification point:

1 . Click the D isplay GU I Insert Toolbar button on the GU I Record toolbar. 

2 . Click the O bject Properties button. 

3 . Accept the autonamed verification point and click O K .

4 . Drag the O bject Finder tool and release over the press here to order button.

5 . Make sure that the selected object is PushButton Visual Basic and click O K.

Robot captures all of the button’s properties, but you’ll edit the captured 
properties so that Robot tests only the text on the button.

Robot captures a ll 
o f the bu tton’s 
propert ies.
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Adding  Verifica tion Poin ts
6 . Click Edit List.

7 . Click O K  again to complete the verification point.

Capturing Data in a Databound Control - Verification Point 3
N ow you’re ready to make sure that Classics Online is adding new orders correctly 
to the order-entry database and retrieving the correct information from the database.

The object that you’re going to test is a databound control. 

A databound ActiveX  consists of two objects:

ã The visible ActiveX control that displays the retrieved data on screen. 

ã A non-visible data  control bound to the ActiveX. The data control retrieves the 
data from the database when an SQ L (software query language) call is made 
from the application. 

To capture the visible data displayed on screen in the ActiveX:

1 . Log in as a new customer by selecting File → Login As N ew U ser.

2 . Select Susan Flontly and click O K.

3 . To view Susan’s existing orders, select O rder → View Existing O rder Status. 
N otice that Susan has placed one order.

4 . Click Close.

First, click < <  to  
m ove a ll the 
Selected  propert ies 
to the A vailab le list.

Scro ll down until 
you  see Text .

Select Text . 

With  Text  
selected, click
>  to  m ove it  
to  the 
Selected list 
by itself.

Click O K .

N O TE: Throughout this tutorial, ActiveX and OCX are used interchangeably.
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Record ing a  Script
5 . With M ozart’s Sym phony N o. 3 4  selected, click press here to order.

6 . Select O rder → View Existing O rder Status and notice that a new order has 
been entered for Susan.

7 . Keep the dialog box open and begin an Object Data verification point.

8 . Accept the autonamed verification point (O bjectD ata2 ) and click O K . 

9 . Drag the O bject Finder to the grid and release the mouse button. 

1 0 . Make sure that the selected object is Generic (O CX ) Visual Basic and 
click O K . 

1 1 . Click O K  again to complete the verification point.

 Type 2 /0 0

Type 1 2 3 4 5

Click Place O rder and 
then  click O K  to 
confirm  the order.

Robot will captu re a ll o f the 
data d isp layed in  the grid .

Click O K to d isp lay the captured  
data.
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Adding  Verifica tion Poin ts
Capturing Properties of a Non-Visible Data Control - Verification 
Point 4
With this verification point, you’ll test the application even more deeply than you did 
when you verified the visible data retrieved from the database. You’ll capture the 
properties of the non-visible data control that makes SQL calls to the database to 
retrieve and update information.

To capture the properties of a non-visible object: 

Move the pointing-hand over the objects in the window. N otice how SQA Robot 
displays the object type in the TestTip that appears under the pointing hand.

1 . Make sure that the View Existing O rders window is open.

2 . Begin an Object Properties verification point.

3 . Accept the autonamed verification point and click O K. Instead of dragging the 
Object Finder to the grid, click the Browse button. This tells Robot to find and 
list all of the visible and non-visible objects on the Windows desktop. 

4 . Click O K again to capture the properties of the control. 

N O TE: If necessary, you can resize the O bject List dialog box to make it 
larger.

f necessary, double-
lick Window 
am e= frm Exist ing  to 

xpand it . Each  
ranch represents an  
b ject in  the View 
xist ing O rders d ia log 
ox.

Clear, and then select
th is to  see a ll o f the 
h idden con tro ls that 
Robot captu red.

With Show h idden 
checked , select 
Generic N am e=  
da taExist inga 
non-visib le data 
con trol tha t 
in teracts with  the 
order-en try 
da tabase. 

Click O K to capture 
a ll of the propert ies 
of the non-visib le 
data con trol.
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Record ing a  Script
5 . In the Object Properties Verification Point dialog box, scroll to the Visible 
property and notice that its value is False, indicating that the data control is non-
visible but has been captured by Robot’s Object Testing technology.

6 . Click O K  to complete the test.

7 . Click Close.

8 . Close Classics Online.

9 . Press the Stop Recording button.

Reviewing the Verification Points You Recorded

After you stop recording, the Robot window appears. 

About the Script You Recorded

The GU I script you recorded consists of commands written in is written in a high-
level language. SQ ABasic, Robot’s scripting language. SQ ABasic provides most of 
the syntax rules and core commands that are contained in the Microsoft Basic 
Language. 

D ouble-click each  
verif icat ion point to  
view what you just 
recorded  in  one of 
the Com parators.

The scrip t

N O TE: To print the script, from Robot click File → Print.
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What the Script Commands Mean
Every action begins as a W indow SetContext command followed by the action. 
Comments begin with a single quote (’).

Each verification point appears as a single line in the recorded script that begins with 
Result =  

The following commands appear in the script:

ã Sub Main - Indicates the beginning of the script. 

ã Dim Result as Integer - Declares the variable Result for verification 
point return values. The Result variable is local to the Main sub procedure. 

ã ‘Initially Recorded: - A comment that automatically shows the date 
and time when the script was recorded. 

ã ‘Script Name: - A comment that identifies the script. 

ã Window SetContext - Specifies the window where user actions occurred. 

ã Window SetTestContext - Specifies the window where a verification point 
was inserted. 

ã Result = Specifies that a verification point was recorded as part of the script. 
The verification point identifies the control by its internal object name and the 
script command recognition method. 

ã Name = Identifies all of the objects that were tested by their internal object 
names. 

ã Pushbutton Click - Indicates a user action command. 

Summary

You’ve just recorded a script and inserted four verification points that check:

ã The album data displayed in the tree control

ã The text property of a pushbutton 

ã The data retrieved from the order-entry database

ã The properties of a hidden data control 

By developing scripts for an early build of an application, you’ll be able to verify that 
future builds of the application perform as intended.
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What’s Next

N ow that you’ve recorded a script, you’re ready to play it back against the same build 
to verify that the script contains no errors and to establish a baseline for future 
testing.
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ã  ã  ãPlaying Back a Script

Objectives

ã Play back the script on the same build to verify that all verification points pass. 

ã View the playback results in the LogViewer. 

Scenario

In the previous example, you recorded a script using Build A of the Classics Online 
application. In this example, you’ll play back the script using the same build of the 
application to ensure that the script works as intended. 

During playback, Robot compares the recorded data to the application-under-test. 
Since no changes have been made to the build, all verification points should pass. A 
verification point fails only if there are differences between the recorded baseline data 
and the current build of the application.
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Playing Back a Script

To play back the SIN GLE O RDER script against Build A:

1 . Make sure that Robot is open. 

2 . From Robot, click File → Playback. 

3 . Select SIN GLE O RDER and click O K .

The rest is automatic. Sit back and relax!

Robot plays back the sequence of recorded actions and verification points. The 
windows of the sample application are displayed on the screen as Robot plays back 
what you’ve recorded. 

At the completion of playback, Robot updates the Rational repository and starts the 
LogViewer, another integrated Rational Test component. 

The LogViewer shows the test results. 

Click here. Type Bu ild  A  and 
click O K .

Click O K .

Click here. Type Bu ild  A  and 
click O K .

D ouble-click to  view 
the verifica tion poin t.

N am e of scrip t and 
each  item  inserted 
in to the scrip t

D a te and tim e of 
record ing
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Sum m ary
4 . Click File → Exit to close the LogViewer and return to Robot.

Summary

You’ve just played back your recorded script against the same build of the application 
to verify that the script works as intended. 

During playback, Robot compared the recorded data to the application-under-test. 
All verification points passed. 

What’s Next

Since the script passed, you’ll use it as the baseline for future builds. When the script 
is played back and differences are found, you’ll be able to use the LogViewer and its 
Comparators to decide whether the differences are intentional changes or defects in 
the build. And you’ll be able to use Rational ClearQuest to track the defects until 
they are resolved.
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ã  ã  ãTesting a New Build and Evaluating 

Results

Objectives

ã Play back the SIN GLE O RDER script to test a new build of the application.

ã U se the LogViewer to review the playback results.

ã U se the Comparators to analyze enhancements or defects in the application.

Scenario

In the previous example, you played back a script using Build A of the Classics 
Online application. In this example, there’s a new build of the application that needs 
testing. You’ll play back the recorded SIN GLE O RDER script on the new build. 
Playback will take a fraction of the time that it would take to repeat the procedure 
manually.
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Testing  a N ew Bu ild and Evalua ting  Resu lts
Viewing the New Build

Before you play back the script against the new build, take a look at how much the 
Classics main window has changed from Build A to Build B. 

Build A

Build B

The text and location  of the 
pushbutton change.

The layou t changes a lo t 
from  Build  A  to  Build  B.

The look of the tree contro l 
changes in  Bu ild  B. The data
rem ains the sam e.
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Playing  Back a  Script Aga inst a  N ew Bu ild
Even though objects in the new build are moved, rearranged, and renamed, you will 
be able to reuse the recorded script to test the objects. Robot’s O bject-O riented 
Recording insulates scripts from changes and guarantees that you can play back 
scripts across builds. 

With Object-Oriented Recording, Robot identifies objects by their internal object 
names. This ensures that even if the layout of the GU I changes and the objects in the 
GU I change locations, Robot will find the objects and test them against the baseline. 
If there are changes, Robot will flag them, and you’ll decide whether they are 
enhancements or defects in the application.

Playing Back a Script Against a New Build

Before you can play back the SIN GLE O RDER script against a new build, you need to 
edit the Start Application path in the script so that Build B of the Classics application 
begins on playback. 

To play back a script against a new build:

1 . In Robot, click File → O pen Script  if the script is not open.

2 . Select SIN GLE O RDER and click O K.

3 . You’ll edit the script at the end of the Start Application line to change the build 
letter.

4 . Click File → Save.

5 . To begin playback, select the Playback button. 

hange ClassicsA .exe 
o ClassicsB.exe.
5 5



Testing  a N ew Bu ild and Evalua ting  Resu lts
6 . Select SIN GLE O RD ER and click O K. 

Robot compiles the script and plays back the sequence of recorded actions and 
verification points. The windows of the sample application are displayed on the 
screen as Robot plays back what you’ve recorded. 

Viewing the Test Results in the LogViewer

When playback is completed, Robot automatically opens the LogViewer so you can 
see the results of playing back the script against the new build. And, for some reason, 
two of the SIN GLE SCRIPT verification points failed when played back against the new 
build. Read on to find out why. 

Click here. Type Bu ild  B and  

click O K .

Click O K .

Click here. Type Bu ild  B and 
click O K .

If any verif icat ion  point in  a
scrip t fa ils, the status for 
the en tire scrip t is Fa il.

The test o f the p ress 
here to  order  
pushbutton fa iled, as 
d id the test o f the 
retrieval o f data from  
the order-entry 
database.
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Analyzing the Resu lts in  the Com para tors
Analyzing the Results in the Comparators

To let you analyze each failure and then remedy it, the LogViewer provides four 
Comparators:

ã Grid - Displays data files for text and numeric verification points that Robot 
displays in a grid.

ã O bject Properties - Displays the properties of objects captured using the Object 
Properties verification point.

ã Text - Displays data files for text and numeric verification points in any format 
except grids.

ã Im age - Displays image files for the Region Image and Window Image 
verification points.

Each Comparator graphically displays the ‘before and after’ results of playback. 

If there is no failure on playback, only a baseline file displaying the recorded data or 
image is displayed. If a failure occurs on playback, an actual file is displayed next to 
the baseline file. By comparing the files, you can determine whether a failure 
occurred because of an intentional change in the build or because of a defect.

Actual file shows that 
d ifferen t data  was 
retrieved  from  the 
database. Th is 
ind icates an  error in  
the order-entry log ic.

Baseline f ile shows 
the a lbum  that was 
ordered. 

Red ind icates an 
error.
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Testing  a N ew Bu ild and Evalua ting  Resu lts
Viewing the Test of the Tree Control
The first Object Data verification point passed even though the outward appearance 
of the tree control changed. The verification point checked the data in each branch 
of the tree control and found that the correct data for each branch was retrieved from 
the database. 

If you had recorded an O bject Properties verification point on the tree control, it 
would have failed because of the changes to some of the control’s properties —lines, 
buttons, height, and width—in Build B.

To view the results of the first Object Data verification point:

1 . Double-click Verification Point (O bject D ata) – O bject D ata  in the Log Event  
column.

Because the verification point passed, the only file displayed in the Grid Comparator 
is the baseline file that contains the data tested.

2 . Choose File → Exit to close the Comparator.

Baseline f ile show
the results of the 
verif icat ion  poin t.
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Analyzing the Resu lts in  the Com para tors
Viewing Two Verification Points That Failed
Two verification points failed. After you review and analyze the failures in the 
Comparators, you’ll discover that one of the failures is an intentional code change in 
Build B. The other failure is a defect.

Viewing the Test of the Pushbutton
The first Object Properties verification point failed. It checked the text on the 
pushbutton and found that it had changed in Build B. Since the development team 
planned this change, it is an enhancement, not a defect. To ensure that the 
verification point passes the next time the script is played back, you need to 
incorporate the enhancement into the baseline script. 

To view the results of the first Object Properties verification point:

1 . Double-click Verif ication Point (O bject Properties)  - O bject Properties in 
the Log Event column. 

2 . Click File → Replace Baseline with Actual.

3 . Click Yes.

The next time you play back SIN GLE O RDER, the verification point will pass.

4 . Choose File → Exit to return to the LogViewer.

The fa ilu re appears 

in  red typeface.

The change is an  
in ten tional, m inor 
enhancem ent.
5 9



Testing  a N ew Bu ild and Evalua ting  Resu lts
Viewing the Test of the Data from the Order-Entry Database
The second O bject Data verification point failed. It checked the data retrieved from 
the order-entry database and found that the incorrect data was retrieved. 

To view the results of the second Object Data verification point: 

1 . Double-click Verification Point (O bject D ata2 ) – O bject D ata  in the Log 
Event  column. 

Choose File → Exit to return to the LogViewer so you can report this error as a defect 
in the application.

Summary

You’ve just found how to use the LogViewer and Comparators to analyze changes in 
your application from build to build. And, you discovered how easy it is to update 
your test when an intentional change is made in the application. 

In the example, you used the LogViewer and the Comparators to: 

ã View the results of the SIN GLE O RDER script. 

ã Analyze each failure to determine if it was a defect or an intentional change.

ã U pdate the baseline file with the actual file when the change was intentional.

What’s Next

You’re now ready to report the defect.

The application  

retrieved the wrong

record from  the 

database.

An order was 
p laced for a  M ozart
a lbum , but a  Bach  
a lbum  was ordered
instead.

To quickly view the 
fa ilu re, click each 
of these, or click 
View  → N ext  
D if ference.
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ã  ã  ãSpecifying and Managing Defects

Objectives 

ã U se Rational ClearQuest to generate defect information. 

ã U se Rational ClearQ uest to create an email rule to send email about the defect 
discovered in the sample application. 

Scenario

When you played back the SIN GLE ORDER script on Build B of the Classics 
application, two of the verification points failed. One of the failures was an 
intentional change to Build A—the name change on the order button. The other 
failure was a defect in the order-entry logic of the application. Even though an order 
was placed for a Mozart album, a Bach album was ordered instead. 

In this example, you’ll use Rational ClearQuest to enter the defect in the repository. 
ClearQ uest lets you track defects through each phase of the development and testing 
process.

N O TE: You can follow the steps in this example if you have Rational ClearQuest 
installed. See the next page for instructions about verifying that ClearQ uest is 
installed.
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Specifying and M anaging  D efects
Making Sure That Rational ClearQuest Is Available 

To see if Rational ClearQ uest is available for defect tracking: 

1 . Click Start → Program s → Rat iona l product  nam e.

2 . Check to see if ClearQuest is listed as a program on the submenu. 

3 . Do not start ClearQ uest yet.

Creating a ClearQuest Master Database 

Before you can start using ClearQuest to generate defects, you need to create a 
sample ClearQ uest master database. The m aster database stores the schema used 
in the defect tracking form. 

To create a ClearQuest master database:

1 . Start the Rational Administrator. 

2 . If necessary, click File → Connect → ClassicsRepository and log in as adm in. 

3 . Click Tools → Rational ClearQ uest M aintenance Tool. 

4 . Click Create a  new schema repository and click N ext .

5 . Keep MS Access as the database type. 

6 . Type C:\M aster.mdb as the path for the database where the schema is stored. 

7 . Click N ext. 

8 . Click Yes because other users will not use this sample master database. 

9 . Select Create sam ple database and click N ext. This creates a sample user 
database that you can connect to the sample master database so you can store 
your defects for this tutorial. 

1 0 . Type C:\U ser.m db as the path for the database where you’ll store you defect 
data. 

1 1 . Click N ext.

1 2 . Click Finish. 

1 3 . Click D one.
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Attaching  a ClearQ uest D atabase to a Repository
Attaching a ClearQuest Database to a Repository 

In this tutorial, after you create the ClearQuest master database, you have to attach a 
ClearQ uest user database called SAM PL to the sample repository. This user 
database contains all the defect data that you’ll enter and the data that the 
LogViewer automatically generates. 

By attaching the user database to the sample repository, you can be sure that you have 
access to the correct schema. The schema determines how the defect tracking form 
looks. 

To attach the ClearQ uest user database: 

1 . From the Rational Administrator, click File → Attach ClearQ uest D atabase.

2 . Accept adm in as your temporary user ID and click N ext. 

3 . Click SAM PL to select it as the database and click N ext . 

4 . Click Finish. 

N otice that ClearQuest database SAMPL is now in the tree under 
ClassicsRepository.

The new 
defect 
database
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Generating a Defect from the LogViewer 

When Robot discovers a change in your application, it logs the change in the 
LogViewer. From the LogViewer, you can then generate a defect so that the 
information is automatically transferred to the ClearQ uest defect database. 

When the defect is generated, the information from the LogViewer appears in a 
defect form. To enter a defect, you add information to the defect form and assign an 
owner and status to it. 

To generate a defect: 

1 . Make sure that the LogViewer is open. 

2 . In the LogViewer, select Verification Point (O bject D ata2 ).

3 . Click D efect → Generate to open the defect form. 

N O TE: If you closed the LogViewer, open the Log Viewer and then do the 
following to open the correct log: Click File → O pen. Double-click Build B. 
Double-click the Build B folder. Double-click Single O rder. 

Click the other tabs 
to  see m ore au to-
generated  
in form ation .

Click O K to subm it 
the defect to  the 
ClearQ uest 
database.

You  m ust type 
in form ation in  every 
tab that has a red  X  
and  in  every f ield  
that has a red label.

Type First Failure as 
the headline for the 
defect.

Select Average for 
the Severity.
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Accessing the D efect from  the ClearQ uest D atabase
Accessing the Defect from the ClearQuest Database 

After you generate a defect from the LogViewer, you can access the defect directly 
from ClearQ uest. 

To access the defect from ClearQuest:

1 . From the LogViewer, click the ClearQuest icon. 

2 . In the left pane, double-click All D efects to view the defects in the SAM PL 
database. 

3 . To view the defect you just entered, double-click Keyword Search in the left 
pane.

4 . Type First Fa ilure and click O K .

5 . Click File → Close to close the defect. 
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Sending Email About a Defect 

After a defect is generated, either you can run ClearQuest to search for the defects 
assigned to you, or your project leader can configure ClearQ uest to automatically 
send email about the defect to the person responsible for it. 

Setting Up an Email Rule 
Before ClearQ uest can automatically generate email about a defect, you must create 
one or more email rules that define when and to whom the defect will be emailed. 
You can create an email rule if you have Super U ser or Schema Designer privileges. 
And, for this tutorial, you do! 

To set up an email rule: 

1 . From ClearQ uest, click Actions → N ew.

2 . Select Em ail_rule and click O K . 

Type Send to O wner 
as the nam e of the 
ru le.

Select D efect.

Click to  d isp lay 
the list  of 
availab le f ields

Select O wner

Click Add To and
click O K.

If  the owner of th
defect changes, t
em ail ru le is 
triggered and the
defect is em ailed
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Send ing Em ail About a  D efect
3 . Select the D isplay Fields tab. 

4 . Select the To Addressing Info tab.

Type your em ail 
address.

Click here, and the
add H eadline. 
Click O K . 
The In form ation  w
appear as the 
subject of the em a

Click here, and the
add  O wner, Priority
and Requ irem ent.
Click O K . 
The Inform ation 
and the defect ID  
will appear in  the 
em ail.

Click here to  add
your em ail 
address so the 
em ail can  be 
sent to you .
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5 . To add your email address, do this:

6 .  Click O K to close the Submit Email Rule dialog box.

Enabling Email Notification 
After you’ve created the email rule, you enable email notification so you can receive 
email about defects. 

To enable email notification: 

ã From ClearQ uest, click View → Em ail O ptions. 

Sending a Trial Email 
N ow that you’ve set up email notification, you can have a defect mailed to you. You’ll 
trigger email by changing the owner of the defect. 

To send a trial email: 

1 . Make sure that your email software is running. 

2 . From ClearQ uest, double-click All D efects to display the defect list.

3 . U nder All D efects, double-click Keyword Search.

ype your em ail 
ddress. Click Add To.

Click O K to 
com plete the ru le.

Click to enable 
your em a il.

Type your em ail 
address.

Type the em ail 
host address.

If necessary, 
check with  your 
adm in istrator.

Click O K.
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4 . Type First Fa ilure and click O K. 

5 . Click Actions and select M odify. 

6 . In the M ain tab, select Q E as the new owner.

7 . Click Apply and see what happens! 

You’ll receive an automatic defect notification. 

Summary 

You’ve just found out how easy it is to generate a defect about a failed verification 
point displayed in the LogViewer. You were also able to send an email message about 
the defect so it could be fixed. 

What’s Next 

You’ve successfully used the SIN GLE ORDER script to test a portion of the Classics 
Online application. N ow it’s time to run a few reports about the testing effort to 
inform management and the rest of your team about where things stand.
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ã  ã  ãUsing Reports to Manage Test Progress

Objectives

ã Run a Script Summary report from TestManager. The report lets you view all 
of the scripts that are planned for the Classics O nline application. 

ã Run a Defect Summary report from ClearQuest. The report lets you view the 
open defects for the Classics O nline application. 

Scenario

As your testing progressed from defining test requirements to creating scripts, and 
from playing back the scripts to tracking defects, all of the test results were stored in 
the Rational repository. You were able to review and analyze the test results in the 
LogViewer. And now you’re ready to create reports about the testing effort.

TestManager and ClearQuest provide integrated report writers. You can use them to 
create and customize dozens of graphs and reports that help you manage the progress 
of your testing effort.

In this example, you’ll generate two reports. The first summarizes all of the scripts 
in the Classics project. The second lists all of the defects that are “open.”
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U sing Reports to M anage Test Progress
Running a Script Summary Report 

The Script Sum mary report provides you with overview information for all of the 
scripts in the Classics project.

To run the Script Summary report:

1 . From TestManager, choose Reports → Run.

2 . Select Script Listing → All Scripts → Sum m ary and click O K .

The report is generated automatically.

3 . Scroll down to view the SIN GLE O RDER script, and then close the report window.

D isplays the 
pro ject nam e as 
well as the date 
and tim e the report
was run .

Lists the nam e of 
each  scrip t, its 
type, and  the 
descrip t ion entered
when the scrip t 
was defined in  
TestM anager.
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Running a Defect Summary Report

ClearQ uest provides two default Defect Summary reports. The first lists all of the 
defects in the database. The second filters the defects according to their states—
Submitted, Open, Resolved, Closed, or Duplicate. 

In this example, you’ll generate a report that lists all of the Open defects for the 
Classics project.

To run a defect report:

1 . From ClearQ uest, double-click Public Q ueries in the left pane to expand its 
branches.

2 . Double-click Reports.

3 . Select D efect Sum m ary (State).

4 . Right-click, and then click Run.

5 . Select O pen and click O K .

6 . To view the report, click 1 00 % and maximize the window.

7 . To print the report, click the printer icon. 

Lists each  
defect 
and its state, 
severity, and 
priority.
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Summary

TestManager and ClearQuest provide integrated report writers that you can use 
to create and customize dozens of graphs and reports to help you manage the 
progress of your testing effort.

In this example, you ran two reports. The first listed all of the scripts that are planned 
for the sample application. The second listed all of the “open” defects in the 
application. 

What’s Next

The first six examples have shown you how the integration between Rational Test 
products ensures a successful testing effort. 

You did the following:

ã U sed Rational TestManager to define test requirements and a script. 

ã U sed Rational Robot to record a script and play back the script against two 
different builds of the sample application. 

ã U sed the Rational LogViewer and comparators to analyze test results. 

ã U sed Rational ClearQuest to generate a defect. 

ã U sed Rational TestManager and Rational ClearQ uest to run reports about your 
testing effort. 

This tight integration between products as well as their ease-of-use lets your 
development and testing teams work together to ensure that the software testing 
effort goes forward as planned.

If you still have time, take a look at the last section in this tutorial. It explains 
advanced scripting techniques that you’ll find useful as you learn more about Robot 
and automated functional testing.
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ã  ã  ãEnhancing Your Scripts

Objective

ã Customize the SIN GLE ORDER script by adding a header file and a library file 
that checks to make sure the order-entry database is reset before each playback 
of the script. 

Scenario

When you recorded the SIN GLE ORDER script, you inserted four verification 
points. One of them placed a new order in the order-entry database. 

If the database is not reset to its initial state with the new order deleted before each 
playback of the script, the same order will be re-entered in the database, and the script 
will fail on playback. To make sure that the database is reset, you have to test to make 
sure that the newly entered orders are actually deleted and the database reset to its 
initial state. 

To accomplish this, you must do the following : 

ã Delete the new record from the database.

ã Enhance the SIN GLE O RDER script by creating a procedure that checks the 
state of the order-entry database. You’ll put the procedure in a library file that 
the SIN GLE ORDER script calls on playback. 
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Deleting the New Record from the Database

To reset the database to its initial state, you have to delete the new order from the 
database.

To delete the new order from the database:

1 . Make sure that the sample application is open.

2 . Log in as Susan Flontly and click O K.

3 . To view Susan’s orders, O rder → View Existing O rder Status.

4 . Select Sym phony N o. 3 4  and click Cancel Selected O rder. 

5 . Make sure that the only order in the database is H aydn’s Sym phonies N os. 9 8  
&  1 0 1 .

6 . Click Close.

Recording and Manually Customizing a Script 

To make sure that the new order has been deleted, you’ll manually customize the 
script instead of using Robot to automatically create an entire script. You’ll customize 
the script by adding two SQABasic commands. And, you’ll only use Robot to record 
navigational actions. 

Finally, you’ll copy the contents of the new script into a library file that will be called 
by the SIN GLE ORDER script. Adding the library file to the SIN GLE ORDER 
script tests to make sure that the order is deleted and the database reset before each 
playback of SIN GLE ORDER. 

Using Robot to Record Navigational Actions 
You’ll follow these steps to record navigational actions: 

ã Start the Classics Online sample application. 

ã Log in as Susan Flontly.

ã Open the View Existing Order dialog box. (After all the navigation is recorded, 
it’s here in the script that you’ll manually add a command to test the order-entry 
grid in the dialog box.)

ã Close the dialog box.

ã Close the sample application. (After all the navigation is recorded, it’s here in the 
script that you’ll manually add the command to send a message to the 
LogViewer.)
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Record ing and M anually Custom izing a  Script
By using Robot to record the actions, you’ll save yourself the time and energy of 
manually writing the actions in the script. 

To record the necessary navigational actions: 

1 . From Robot, click File → Record GU I . 

2 . Type Temporary Script and click O K.

3 . Click the D isplay GU I Insert Toolbar button.

4 . Click the Start Application button.

5 . Type or browse to the default location for Build A of the sample application:

C:\Program Files\Rational\Rational Test 7\Sample 
Applications\Classics Online\ClassicsA.exe

6 . Click O pen and click O K .

7 . Log in as Susan Flontly and click O K . 

8 . Click O rder → View Existing O rder Status. 

9 . Close the dialog box and the sample application.

1 0 . Press the Stop Recording button. 

Before the new 
order is p laced 
for Susan 
Flontly, there are
two rows in  
Susan ’s record 
—one is the 
header row and
the other is an 
existing order.

O rder-entry grid
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Enhancing Your Scripts
Manually Customizing the Script 
N ow that you’ve recorded the actions, you’ll customize the temporary script by 
adding two SQABasic commands—SQ AGetProperty and SQ ALogM essage. 

The first command will capture the row property of the existing order grid to make 
sure that the new order no longer appears. 

The second command will write a message to the LogViewer. The message will 
indicate whether the database has been returned to its initial state. 

To customize the script:

1 . Make sure the Tem porary Script  is open.

2 . At the top of the script after the first D im  statement, add:

Dim RowCount As Variant

N O TE: To become familiar with the syntax of the commands and to view 
comments about them, see the SQABasic Language Reference or the SQABasic 
online H elp. 

You ’ ll declare a 
variab le here that will 
con ta in the num ber of 
rows in  the g rid .

You ’ ll add a com m and here 
to  check for the num ber of 
rows in  Susan Flontly’s 
record .

You ’ ll ad an If-Then 
statem ent here that sends a 
m essage to the LogViewer 
about the database reset
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Record ing and M anually Custom izing a  Script
3 . After the MenuSelect command, add an SQABasic command. The 
command retrieves the Rows property from the FlexigridOrders control. The 
property contains the number of rows in the grid—the number includes the 
header row and the record row—and puts the number into the RowCount 
variable: 

Result = SQAGetProperty (“\;Name=frmExisting;\; 
Name=FlexigridOrders”, “Rows”, RowCount) 

4 . At the end of the script before End Sub, add the following “If-Then-Else” 
statement. If the cleanup is successful, this will send a message to the LogViewer 
stating that the database is reset correctly: 

If RowCount=2 Then
‘Display message in LogViewer 
SQALogMessage sqaPass, “Database is reset, ready for playback”, ““ 
Else 
SQALogMessage sqaFail, “Database is not reset”, ““ 
End If 

5 . Click File → Save to save the additions to Temporary Script . 

N O TE: Make sure that the command appears as one line in the script. 
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Enhancing Your Scripts
Creating a Library File 

After you record the temporary script and add the SQ ABasic commands, you need 
to create a library file to copy contents of the script into. 

To create a library file: 

1 . Make sure that Temporary Script is open.

2 . Select a portion of the script beginning with Dim Result As Integer and 
ending with End Sub.

3 . Click Edit  → Copy.

4 . Begin to create the library file by clicking File → N ew → SQ ABasic File.

5 . Click Library Source File and click O K .

6 . Click Edit  → Paste to copy the script into the library file.

Select th is port ion o
the scrip t.
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Creating  a  H eader File
7 . At the top of the library file, type this line to name the procedure that you pasted 
into the file: 

Sub RunTestDatabase ()

8 . Click File → Save.

9 . Type CheckD BLib and click Save. 

1 0 . Click File → Com pile to compile the library file. 

Creating a Header File 

After you create the library file, you’ll create a header file that declares the custom 
procedure you just created. And you’ll reference the header file from the SIN GLE 
ORDER script. 

To create the header file: 

1 . From Robot, click File → N ew → SQ ABasic File. 

2 . Click H eader File and click O K. 

Type the nam e of 
the procedure 
here.
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Enhancing Your Scripts
3 . Type the following line in the header file to declare the library file that contains 
the subprocedure RunTestDatabase: 

Declare Sub RunTestDatabase BasicLib “CheckDBLib” () 

4 . Click File → Save. 

5 . Type CheckD BH eader as the .sbh header file.

6 . Click Save. 

7 . Click File → Close. 

Adding the Header and Library Files to the Script 

Finally, you’ll reference the header file in the SIN GLE ORDER script. And, you’ll 
call the procedure (RunTestDatabase) from the script. Calling the procedure will 
check whether the database is reset and will send a message to the LogViewer. 

To reference the header file and call the procedure:

1 . Click File → O pen Script . 

2 . Select Single O rder and click O K . 

3 . At the top of the script above Sub Main, type: 

‘$Include “CheckDBHeader.sbh”. 

4 . At the end of the script above the line End Sub, type: 

Call RunTestDatabase() 

5 . Play back the script and see what happens! 

The script will play back, check to make sure that the database is reset, and then write 
a Log Message to the LogViewer.

Summary 

You’ve just discovered how easy it is to edit and customize a Robot script to make it 
do exactly what you want it to do. 

You found out how to: 

ã Add SQABasic commands to a script. 

ã Create a header file. 

ã Create a library file. 
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What ’s N ext
What’s Next 

Congratulations on completing the tutorial! 

You’re now ready to use Rational Robot to test your own application. But before you 
begin, you need to create a new Rational repository to store your testing data. 

H ere’s a quick procedure for creating a repository. For more detailed instructions 
and information about repositories, see the Using the Rational Administrator manual. 

To create a Rational repository: 

1 . Close all Rational Test products.

2 . Click Start → Program s → Rat iona l program  nam e → Rational 
Adm inistrator. 

3 . Click File → Create Repository. 

4 . Type the drive, directory, and name for the new repository—for example, 
C:\repo1 .

5 . Click N ext. 

6 . Accept M S Access as the database type and click N ext .

7 . Accept D o not initia lize the new repository with data from  an existing 
repository and click N ext.

8 . If you created a ClearQuest master database as part of this tutorial, accept Create 
or Attach ClearQ uest D atabase and click N ext. O therwise, clear it, click N ext, 
and skip to step 10.

9 . Enter a database name—a limit of five alphanumeric characters beginning with 
a letter. Click N ext . 

1 0 . Accept the defaults and click Finish. 

Remember, if you want to find out more about Rational Robot, you can follow the 
testing tips in the Rational Robot Try it! cards. Also, for more complete information 
and instructions about using Rational Robot and its companion products, take a look 
at the user’s guide and online H elp for each product.
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