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Chapter 1  
Introduction to the GX-9100 
Software Configuration Tool 

Introduction 
The GX-9100 Graphic Configuration Software Tool (GX Tool) is used 
to configure the DX series of extended digital plant controllers, the 
XT-9100 and XTM-905 extension modules, and the DX Liquid 
Crystal Display (LCD) Display unit. The GX Tool is part of the 
M-Tool suite of programming tools. 
This user’s guide describes the procedures necessary to configure a 
DX controller (Chapters 3-11) and a DX LCD Display 
(Chapters 12-16). 
This chapter describes: 

• GX Tool 

• DX controller 

• extension modules 

• DX LCD Display 

• related information 
For system requirements and software installation details, refer to the 
Metasys® Installation and Platform Requirements Technical Bulletin 
(LIT-12012). 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-120182 Software Release 7.10 
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Key Concepts 
GX Tool 

The GX Tool allows you to define job information, global data, 
input/output and programmable modules, trend logs, and PLC 
diagrams to configure the DX controller and its XT/XTM extension 
modules. The GX Tool allows you to define a Point Database for the 
DX LCD Display. 
The GX Tool is used to download configurations to the DX controller 
and to download data to the DX LCD Display unit (DT-9100). 

DX Controller 
The DX-9100 is a digital control solution for multiple chiller or boiler 
plant control applications, for the Heating, Ventilating, and Air 
Conditioning (HVAC) process of Air Handling Units (AHUs) or for 
distributed lighting and related electrical equipment control 
applications. It provides precise direct digital control as well as 
programmed logic control. 
In a standalone configuration, the DX-9100 controller has both the 
hardware and software flexibility to adapt to the variety of control 
processes found in its targeted applications. The controller’s input and 
output can communicate with Input/Output (I/O) extension modules on 
an extension bus and can monitor and control all connected points via 
its built-in Light-Emitting Diode (LED) display. 
The DX controller is available in three versions, Versions 1.x and 2.x 
for the N2 Bus and Version 3.x for the LONWORKS® network and has 
eight analog inputs, eight digital inputs and six digital outputs. 
Version 1 controller has two analog outputs (not available in North 
America) and Versions 2 and 3 have eight analog outputs. For details, 
see the DX-9100 Extended Digital Controller Technical Bulletin 
(LIT-6364020). 

Extension Modules 
The DX controller input/output can be extended by up to 64 remote 
input/outputs, analog or digital, depending on the type of connected 
XT-9100 or XTM-905 extension module configuration. 
The XTM-905 extension module with an XP expansion module 
provides either eight analog points or eight digital points. An XT/XTM 
can be expanded to provide eight additional points in one physical 
configuration by connecting two to four XP modules to the XT/XTM 
module. 
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DX LCD Display 
The DX LCD Display unit is a person/controller interface used with 
the DX-9100 series of controllers. The display can act as a simple 
adjust and indication unit or be used for more complex tasks often 
associated with a workstation. The display is designed for the 
maintenance person who needs a straightforward way to monitor and 
adjust points in a controller without being limited in capability. 
The display can be used as either a portable, hand-held unit for use 
with more than one controller, or it can be permanently mounted on 
the wall, on a Universal Packaging Module (UPM) or in a panel as an 
integral part of the controller application. 

Related Information 
See the documents in Table 1-1 for more information. 

Table 1-1: Related Information 
Document Code Number 
DX LCD Display User’s Guide  
DX LCD Display Technical Bulletin LIT-16284120 
DX-9100 Extended Digital Controller 
Technical Bulletin 

LIT-6364020 

DX-9100 Configuration Guide LIT-6364030 
DX-9200 LONWORKS Compatible Digital 
Controller Technical Bulletin 

LIT-1162250 

DX Commissioning Using the Point 
Template Program User’s Guide 

LIT-6364080 
LIT-1628480 

XT-9100 Technical Bulletin LIT-6364040 
LIT-1628440 

XT-9100 Configuration Guide LIT-6364050 
LIT-1628450 

LONWORKS Network Layout Technical 
Bulletin 

LIT-1162150 

LONWORKS N2E Bus Technical Bulletin LIT-6364100 
M-Tool Overview and Installation 
Technical Bulletin 

LIT-693100 

Metasys Installation and Platform 
Requirements Technical Bulletin 

LIT-12012 
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Chapter 2  
Software Details and Hardware 
Connections 

Introduction 
This chapter describes the tasks you perform before using the 
GX Tool. 
This chapter describes: 

• software details 

• connection to the DX controller 

• connection to the DX LCD Display 
This chapter describes how to: 

• switch languages and program defaults 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-120183 Software Release 7.10 
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Key Concepts 
Software Details 

Refer to the M-Tool Overview and Installation Technical Bulletin 
(LIT-693100) for software installation details. 
The installation procedure automatically creates or modifies an 
initialization file named GX9100.INI. It also sets up the program 
group, called Configuration Tools, and the icons needed for running 
the GX Tool. 

Default Language 
The language file set installed determines the default temperature 
units, frequency, and language. You can switch the language file set 
without reinstalling the GX Tool. 
See Switching Languages and Program Defaults in this chapter. 

GX9100.INI File Features 
Table 2-1 lists the features you can change or enable by adding lines 
the GX9100.INI file using a standard text editor. For example,  
Figure 2-2 shows update firmware disabled. 

 

Figure 2-1: Update Firmware Disabled 
Figure 2-2 shows update firmware enabled. The GX-9100.INI file is 
located in the Windows® directory. 
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Figure 2-2: Update Firmware Enabled 

Table 2-1: GX-9100 Initialization File Features 
Feature Section Add the Lines Notes 
Password 
Protection 

[Settings]* PasswordEnable=Yes The Y must be uppercase. 

   !  Caution: Once the password 
feature is enabled, you cannot access 
the controller if the password is lost. 

    
Default 
Controller 

[Settings]* DefaultControllerVersion= 
<version number> 

Valid entries for the <version number> are: 1.1, 
1.2, 1.3, 1.4, 2.0, 2.2, 2.4, 3.0, 3.1, 3.2, 3.3, and 
3.4. 
The version controller will default to 2.4 if the 
version number is missing or incorrect. 

Firmware 
Update 

[Firmware 
Download] 

AllowDTFirmwareUpdate=Yes  

Download 
and 
Upload via 
N30 

[Settings]* N30Download=Yes 
N30Executable=<path of the 
LoaderUI.exe program> 

The full path in M-Tool is: C:\Program 
Files\Johnson Controls\System 
ToolsLoaderui.exe. 

Default 
Directory 

[Settings]* AppLibrary=<path of 
Application Library directory> 
PLCLibrary=<path of PLC 
Library directory> 

The path to the first save action is written to the 
[Settings] section of GX9100.INI. 

* If the [Settings] section is not present, add it using square brackets 



 GX-9100 Software Configuration Tool User’s Guide 2-4 

Connection to the DX Controller 
Refer to the Controller Access Technical Bulletin (LIT-6364013) or 
the DX-9200 LONWORKS Compatible Digital Controller Technical 
Bulletin (LIT-1162250) for detailed information about connecting the 
GX Tool Personal Computer (PC) to a DX controller. 
Use the IU-9100 or CVTPRO to connect a PC to the DX-9100’s 
N2 Bus (Bus 91) (Figure 2-3) while the controller is disconnected 
from the supervisory network. 
With this configuration, you can download DX-9100 modules (with 
connected extension modules) one after the other by entering the 
appropriate controller address at the GX Tool PC. The appropriate 
cables are supplied with the IU-9100 converter and CVTPRO units. 

Notes: MM-CVT101 is not compatible with Windows NT® 
software. If you are using Windows NT software, download 
directly via the RS-232 port (Figure 2-4), or upgrade to 
CVTPRO. 
For connection details when using CVTPRO, refer to 
Auxiliary Gear Technical Bulletin (LIT-6363080). 

RT +
RT -
COM

IU-9100

N2 Download

RT +
RT -
COM

CVT
N2 +
N2 -
REF

PCDX

DX PC

Download via N2 bus

Connection n2

IU-9100
to PC
Cable

 

Figure 2-3: Connecting an N2 Bus to a DX Controller 
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Figure 2-4: PC to IU-9100 Cabling Details 



 GX-9100 Software Configuration Tool User’s Guide 2-5

Download the DX-9100 Version 2 or the DX-912x/DX-9200 
Version 3 controller, with its connected XT-9100 and XTM-905 
modules directly via its RS-232 port (Figure 2-5). With this 
configuration, only one DX controller and its XT/XTMs can be 
downloaded. 
Note: If you have a LONWORKS DX-912x/DX-9200 (Version 3.x), 

you cannot download via the LONWORKS trunk from the 
GX Tool. The only way to download the DX-9200 is via the 
RS-232 port on the controller. The DX-912x may also be 
downloaded through a Metasys Operator Workstation 
(OWS). 

DX-9100
Version 2 and 3

RS-232-C 
9-pin Male

Plug
9-pin 

Female

Communication
(RS-232-C) Port

9-pin Male 9-pin Male

Plug
9-pin 
Female

1
2
3
4
5
6
7
8
9

1  DCD
2  RxD
3  TxD
4  DTR
5  GND
6  DSR
7  RTS
8  CTS
9  RI

PC

1
2
3
4
5
6
7
8
9

1
2
3
4
5
6
7
8
9

RxD
TxD

GND
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(RS-232-C) Port

25-pin Male 

2
3
4
5
6
7
8

20

2    
3 
4  
5 
6  
7  
8  
20  

1
2
3
4
5
6
7
8
9

1
2
3
4
5
6
7
8
9

TxD
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RS-232-C 
Plug
9-pin 
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RxD
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Version 2 and 3 PC

Plug
25-pin 
Female
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Figure 2-5: Directly Connecting a PC to a DX Controller (Version 2 or 3) 
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Connection to the DX LCD Display 
Configurations download from the personal computer to the DX LCD 
Display unit via the serial cable provided with the DX LCD Display. 
The 9-pin female plug labeled DX/PC connects to the COM1 or 
COM2 serial port of the PC. The other end of the cable is a phone 
connector and plugs into the phone jack (labeled RS232 INPUT) on 
the DX LCD Display (Figure 2-6). 
Note: Before connecting the serial cable to the PC, power up the 

DX LCD Display and wait for the Download/Upload screen 
to appear. 

Personal Computer
(Rear View)

COM1 or COM2
Serial Port

DX LCD
Display

Serial Cable
(Supplied with

DX LCD Display)

9/12 VDC Power Supply
(AC Adapter)

 

Figure 2-6: Connecting the DX LCD Display to the 
Serial Port 
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Detailed Procedures 
Switching Languages and Program Defaults 

To switch languages and program defaults: 
1. Copy the file GXRES.* to GXRES70.DLL 
2. Copy the file DXMISC.* to DXMISC.LNG 
3. Copy the file DXTEXT.* to DXTEXT.LNG 
Note: The * indicates the file extension by the first three letters of 

the language/defaults.  
For example: GXRES.FRE for French. 
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Chapter 3  
Getting Started with the GX Tool 
and the DX Controller 

Introduction 
This chapter describes tasks you perform when beginning to use the 
GX Tool. It describes the GX Tool user interface and outlines the steps 
necessary to configure a DX controller. 
This chapter describes how to: 

• start the GX Tool 

• define job information 

• define the global data 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-120184 Software Release 7.10 
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Key Concepts 
DX Controller Configuration Process 

The first use of the GX Tool is to create a configuration for a DX 
controller. Figure 3-1 shows the process for configuring a DX 
controller. 

Start the GX Tool. 
↓ 

Choose which version DX to configure. 
↓ 

Define job information. 
↓ 

Define Global Data. 
↓ 

Define Analog Inputs and Digital Outputs. 
↓ 

Define Analog Outputs and Digital Inputs. 
↓ 

Define XT, XTM, and XP modules. 
↓ 

Define network inputs and outputs (Version 3 only). 
↓ 

Define programmable modules. 
↓ 

Define PLC modules. 
↓ 

Make connections. 
↓ 

Define trend log module. 
↓ 

Save the configuration. 
↓ 

Download the configuration. 

Figure 3-1: DX Configuration Process 
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Main Screen 
Figure 3-2 shows the GX Tool’s main screen. Table 3-1 describes the 
callouts. 

 

Figure 3-2: Main Screen for a DX Version 2.x or 3.x 

Table 3-1: GX Tool Main Screen Callouts 
Callout Name Description 

1 System Menu Box Provides access to the system menu. 
2 Title Bar Displays the name of the currently open 

configuration. 
3 Menu Bar Provides access to the eight main menu 

items. 
4 Tool Bar Provides one button access to commonly 

used tools. 
5 Analog Inputs Provides eight analog inputs. 
6 Digital Inputs Provides eight digital inputs. 
7 Analog Outputs Provides eight analog outputs. 
8 Digital Outputs Provides eight digital outputs. 
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Menus 

System Menu 
Table 3-2 lists System menu options. 

Table 3-2: System Menu Options 
Menu Option Description 
Restore Sizes active configuration window to the last size before it 

was minimized or maximized. 
Move Moves active configuration window. 
Size Resizes active configuration window. Adjust height by clicking 

and dragging title bar. Adjust width by clicking and dragging 
scroll bar. 

Minimize Minimizes active configuration window. 
Maximize Maximizes active configuration window. 
Close Closes active configuration window. 
Next Toggles between configuration windows. 
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File Menu 
Table 3-3 lists File menu options. 

Table 3-3: File Menu Options 
Menu Option Description 
New Opens a new configuration file. 
Open Opens an existing configuration file. 
Import Imports files generated by the DOS GX Tool, Version 2, into 

the GX Tool. 
Save Saves the current configuration as a .DXS file. 
Save As Saves a copy of the current configuration under a different 

name. 
Print Prints the current configuration. 

Print Preview Displays the current configuration as it will print on the page. 
Print Setup Sets print parameters, including default printer, portrait or 

landscape, paper size and source, and page range. 
Header/Footer Sets up user defined headers. 
Read User 
Names 

Reads the contents of an existing Tag name ASCII file into a 
GX Tool configuration and modifies the configuration Tag 
names. 

Write User 
Names 

Creates a Tag name ASCII file from an existing GX Tool 
configuration and saves it to disk. 

Open from 
Library 

Transfers a file from the application library or PLC library to 
the clipboard. 

Save to Library Saves the selected set of modules in a configuration to the 
application library, or saves the selected logic blocks in a 
PLC page to the PLC library. 

DDL File Options Defines the items written to the DDL files when the 
configuration is saved. 

Exit Terminates the GX Tool. 
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Edit Menu 
Table 3-4 lists Edit menu options. 

Table 3-4: Edit Menu Options 
Menu Option Description 
Undo Cancels the last action of cut or paste. 
Cut Removes selected modules or logic blocks and copies them 

to the clipboard. 
Copy Copies selected modules or logic blocks to the clipboard. 
Paste Pastes the set of modules or logic blocks from the clipboard. 
Add PM Opens a submenu to add one of several types of 

programmable modules to the configuration. 
Configure Opens a submenu to configure the highlighted module. 
Delete Deletes the selected module. For hardware I/O modules, only 

the configuration is deleted and the module remains on the 
screen. 

Data Opens a data screen with information about the selected 
module. 

Change Module 
Number 

Changes the module number of the highlighted module. 

Global Data Edits information that affects the whole configuration, 
including temperature units, frequency, initialization on power 
up, counter type, daylight saving start and end date, 
password, and the user configuration code. 

Add Alarm 
Disable 

Adds an alarm disable function block to the configuration. 

Connect Connects source and destination points. 
Disconnect Disconnects previously made connections. 
Calibration Calibrates analog input and outputs, and trims the accuracy 

of the realtime clock. 
Job Information Defines information pertaining to the configuration, such as 

job name, controller name, engineer, and branch. 
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View Menu 
Table 3-5 lists View menu options. 

Table 3-5: View Menu Options 
Menu Option Description 
Show Selected Changes the view to show only the modules currently 

selected and the connections between these modules. To 
select multiple modules, hold down CTRL while clicking. 

Show All Returns the view to show every module in the configuration. 
Show User 
Names 

Displays user defined modules names. Undefined modules 
display Tag names. 

Show Tag Names Displays the predefined Tag names for all modules. 
Show 
Connections 

Shows all connections to the currently selected module. 

Trace Creates a graphical trace of all modules connected to a 
selected module for easy tracing of a path, without showing 
lines to and from other modules. 

Snap to Grid Allows snapping boxes to a grid, for easier alignment. 

 

Action Menu 
Table 3-6 lists Action menu items. 

Table 3-6: Action Menu Options 
Menu Option Description 
Upload Uploads a configuration from a DX controller. 
Download Downloads a configuration to a DX controller. 
Upload via N30 Uploads a configuration from a DX controller to the PC via an 

N30 Supervisory Controller. Only appears if enabled in the 
GX9100.INI file. 

Download via 
N30 

Downloads a configuration to a DX controller from the PC via 
an N30. Only appears if enabled in the GX9100.INI file. 
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Controller Menu 
Table 3-7 lists Controller menu options. 

Table 3-7: Controller Menu Options 
Menu Option Description 
DX Version 1.1, 
1.2, 1.3 

Enables Versions 1.1, 1.2, and 1.3 of the DX-9100 controller 

DX Version 1.4 Enables Version 1.4 of the DX-9100 controller (supports 
Trend) 

DX Version 2.0, 
2.1, 2.2 

Enables Versions 2.0, 2.1, and 2.2 of the DX-9100 controller 

DX Version 2.3, 
2.4 

Enables Version 2.4 of the DX-9100 controller (supports 
Trend) 

DX Version 3.0, 
3.1, 3.2 

Enables Versions 3.0, 3.1, and 3.2 of the DX-912x 
LONWORKS compatible controller 

DX Version 3.3, 
3.4 

Enables Version 3.4 of the DX-912x and DX-9200 
LONWORKS compatible controllers (supports Trend) 

 

Window Menu 
Table 3-8 lists Window menu options. 

Table 3-8: Window Menu Options 
Menu Option Description 
Cascade Arranges multiple configurations on the screen in overlapping 

stair-stepped windows. 
Tile Arranges multiple configurations into equally sized windows 

that fill the screen but do not overlap. 
Arrange Arranges icons and windows on the screen. 

 



 GX-9100 Software Configuration Tool User’s Guide 3-9

DX LCD Display Menu 
Table 3-9 lists the DX LCD Display menu options. 

Table 3-9: DX LCD Display Menu Options 
Menu Option Description 
Firmware Version Selects firmware Version 2.01 or Version 3.00 or higher. 
Global Data Edits global data that affects the operation of the display, such 

as the time-out period of the LCD backlight. 
Configuration 
Name 

Edits the configuration name. 

Define Default 
Configuration 

Defines the default DX LCD Display configuration used by the 
DX LCD Display in the event that the stored configuration 
does not match the DX controller configuration. 

Point Database Opens a new window to define the points shown on the 
DX LCD Display. 

TSn/OSn 
Description Text 

Opens a new window to edit the descriptions for Time 
Schedule modules and Optimal Start/Stop modules. 

Define Trend Data Opens a new window to define the trend data shown on the 
DX LCD Display. 

Download Display Downloads the current configuration to the display unit. 
Read User 
Configuration 
Codes 

Reads the configuration codes, names, Home Page data, and 
trend definitions of all of the configurations currently stored in 
the DX LCD Display. 

Upload Display Uploads a configuration from the display unit to the GX Tool 
on the PC. 

Update Firmware Updates Version 3.00 and higher firmware. Only appears if 
enabled in the GX9100.INI file. 

 

Help Menu 
Table 3-10 lists Help menu options. 

Table 3-10: Help Menu Options 
Menu Option Description 
GX9100 Help 
Topics 

Launches Help window with an index of GX Tool topics. 

Help Using Launches a window containing help topics for Microsoft® 
Windows Help. 

About Displays copyright and version information for the GX Tool. 

 



 GX-9100 Software Configuration Tool User’s Guide 3-10 

Toolbar 
Table 3-11 describes Toolbar buttons and functions. 

Table 3-11: Toolbar Buttons 
Toolbar 
Button 

Menu Bar 
Equivalent 

Description 

 
File > New Opens a new configuration file. 

 
File > Open Opens an existing configuration file. 

 
File > Save Saves the current configuration. 

 
Edit > Add PM Opens a submenu to add one of several 

types of programmable modules to the 
configuration. 

 
File > Print Prints the current configuration. 

 
Edit > Cut Removes selected modules or logic blocks 

and copies them to the clipboard. 

 
Edit > Copy Copies selected modules or logic blocks to 

the clipboard. 

 
Edit > Paste Pastes the set of modules or logic blocks 

from the clipboard. 

 
Edit > Undo Cancels the last action of cut or paste. 

 
File > Open from 
Library 

Transfers a file from the application library or 
PLC library to the clipboard. 

 
File > Save to 
Library 

Saves the selected set of modules in a 
configuration to the application library, or 
saves the selected logic blocks in a PLC 
page to the PLC library. 

 



 GX-9100 Software Configuration Tool User’s Guide 3-11

Detailed Procedures 
Starting the GX Tool 

To start the GX Tool: 
1. On the Windows Start menu, click Programs > Johnson Controls > 

M-Tool > Configuration Tools > GX-9100. The GX Tool main 
screen appears (Figure 3-3). 

2. On the Controller menu, click the controller version you want to 
configure. 

 

Figure 3-3: GX Tool Main Screen 
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Defining Job Information 
To define job information: 
1. On the Edit menu, click Job Information. The Job Information 

dialog box appears (Figure 3-4). 

 

Figure 3-4: Job Information Dialog Box 
2. Complete the data fields. 
3. Click OK to save and close the dialog box. 
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Defining the Global Data 
To define the global data: 
1. On the Edit menu, click Global Data. The Edit Global Data dialog 

box appears (Figure 3-5). 

 

Figure 3-5: Edit Global Data Dialog Box 
2. Fill in data fields Table 3-12. 

! CAUTION: Once the Password feature is enabled, you cannot 
access the controller if the password is lost. 

3. Click OK. 
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Table 3-12: Edit Global Data Fields 
Field Description 
Temperature Units Select Celsius or Fahrenheit. 
Frequency Select current frequency as 50 or 60 Hz. 
Init On Power Up Select Initialize on Power Up. 
Counter Type Select Counter Type as 15 bit or 4 byte. 
DL Saving Start 
Date (MM/DD) 

Enter month and day daylight saving time begins. 

DL Saving End Date 
(MM/DD) 

Enter month and day daylight saving time ends. 

Password* Enter 4-digit password. Enter 0000 to disable the 
password. 

User Config Code Enter User Configuration Code between 0 and 9999. This 
number identifies the configuration being edited and 
downloaded. 

* If the Password field is unavailable, password protection is disabled. 
 
Notes: The User Configuration Code identifies the configuration 

being edited and is downloaded to the controller and 
displayed on the front panel of the DX controller at startup 
(Version 1.1 or later). (The GX Tool accepts numbers up to 
65535, but only numbers up to 9999 display correctly on the 
DX front panel.) The User Configuration Code is also used 
by the DX LCD Display unit to identify the configuration, so 
it displays the correct screens. 
The password protects a configuration loaded into a 
controller. Once the password is downloaded into the 
controller along with the configuration, the controller only 
allows another download or upload when the same password 
is entered. Enter a 0000 as the password to disable the 
password function. 
The Password field is unavailable and cannot be edited if the 
Password feature has not been enabled in the GX9100.INI 
file (see the Software Details and Hardware Connections 
chapter of this guide). 
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Chapter 4  
Defining Inputs, Outputs, and 
Programmable Modules 

Introduction 
The GX Tool configures the DX controller using 12 multi-purpose 
programmable modules, the Programmable Logic Controller (PLC), 
Time Schedule modules, and Optimal Start/Stop modules. 
This chapter describes how to: 

• configure inputs and outputs 

• delete modules 

• add programmable and extension modules 

• define a user name 

• define input, output, and programmable module data 

• name a connection point 

• calibrate analog inputs and outputs 

© February 3, 2006 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-120185 Software Release 7.04 
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Key Concepts 
User Names 

Each I/O point, connection source point, destination point, and 
programmable module has a predetermined Tag name (e.g., TS1). 
You can define an 8-character User Name to identify the function of 
each point and programmable module in the configured application. 
You can also enter a 24-character description for the data window. 

I/O Modules 
Configure an Analog Input (AI) as active or passive and configure a 
Digital Output (DO) as P.A.T., D.A.T. On/Off, Sta/Sto, or Pulse 
before defining a user name.  
Note: 

IMPORTANT:

Configure all digital outputs as On/Off or Pulse even if they 
are not used. The exceptions are the 4-output relay modules 
(XP-9107 and XPE-4x4, x=4, 5, 6,or 7). When only 
one 4-output module is installed, select 8DO, but only 
configure DO1-DO4. When two 4-output modules are 
installed, configure both as one 8DO module, and configure 
DO1-DO8. 

 Configure XPM-4x1, XPL-4x1, and XPE-4x1 modules 
as On/Off. The action of the output is determined by 
the hardware, not the configuration. 

Ranges 
The GX Tool accepts any real number between -32750 and 32750. 
Numbers with a modulus greater than 2048 may be rounded up or 
down by as much as 0.1 percent as shown in Table 4-1. 

Table 4-1: Rounding Factors 
Range Rounding (+/-) 
2049-4096 2 
4097-8192 4 
8193-16384 8 
16385-32750 16 
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Module Type Limits 
A limited number of modules are available in a configuration. 
Modules at the limit and unsupported modules do not appear in the 
Add PM menu. Table 4-2 shows the maximum number of modules by 
type you can use in a configuration. 

Table 4-2: Module Type Limits 
Type of Module Maximum Number Allowed 
Control 
Numeric 
Totalization 
Sequencer 
Binary Sequencer 

12 total 

XT or XTM 8 total 
Time Schedule 8 
PLC 8 
Optimum Start/Stop 2 
Analog Constants 1 
Digital Constants 1 
Exception Days 1 
LRS1-32 1 
LRS33-64 1 
Trend Log 1 
NDO Network Module 8 
NDI Network Module 8 
NAO Network Module 16 
NAI Network Module 16 
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Network Modules (DX Version 3.x Only) 
Network modules hold numeric (analog) or logical (digital) values 
from its associated LONMARK™ network variable. 
The network variables transmit data between DX-912x controllers on 
the same LONWORKS N2E network. The LONWORKS N2E network 
supports DX-9120 or DX-9121 controllers, but not both on 
one network. The GX Tool provides all data to the controllers for the 
LONWORKS network configuration. No third-party tool is required. 
The network variables transmit data between DX-9200 controllers on 
an open LONWORKS network. They also transmit data from any other 
LONMARK compliant devices on the network to the DX. Refer to the 
DX-9200 LONWORKS Compatible Digital Controller Technical Bulletin 
(LIT-1162250) for details on the use of each network variable before 
defining network modules. When configuring a DX-9200 controller, 
the GX Tool does not define network module destinations. Network 
connections between network variables in different controllers (source 
and destination) must be defined by a third-party LONWORKS network 
configuration tool. 

PLC Modules 
The DX-9100 operating system provides a software-implemented 
PLC. Every second, the PLC module executes a user-defined program 
that operates on a 2,048-bit memory area containing an image of the 
hardware digital inputs/outputs, logic variable from each module, and 
digital constants. In the memory area, each input, output, and logic 
variable has its own pre-allocated address. Variables in the memory 
area are frozen before the execution of the program in the PLC 
module, and the resulting changes in the logic variables are transferred 
out of the memory area to the appropriate hardware or function 
modules at the end of the module execution. 
The GX Tool’s software-implemented PLC supports most of the 
functions available in dedicated PLCs. Define PLC functions using 
ladder diagrams. In the GX Tool, the PLC ladder diagram is 
subdivided into eight pages: PLC1 to PLC8. A separate ladder diagram 
and a separate module block on the screen represent each PLC. Refer 
to the Creating PLC Ladder Diagrams chapter for more information. 



 GX-9100 Software Configuration Tool User’s Guide 4-5

XT, XTM, and XP Modules 
The DX controller can be extended by up to 64 remote inputs/outputs, 
analog or digital, depending on the connected XT-9100 or XTM-905 
extension module configuration. Figure 4-1 shows the DX controller 
with inputs added by an XT module. Table 4-3 describes the figure 
labels. 
XP inputs/outputs are connected to the first XT or XTM module. An 
expanded digital XT or XTM (EXP) represents the inputs/outputs of 
the second XP on the preceding XT or XTM. The first XT/XTM 
software module represents two hardware modules. 
Table 4-3 lists XT and XTM modules available with the GX Tool. 
Notes: Some XT, XTM, and XP modules described in this 

document are unique to local markets and may not be 
available on a global basis. 
Analog inputs and digital outputs added by an extension 
module need to be configured. 
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Figure 4-1: Inputs and Outputs Added by XT Module 

Table 4-3: XT Module Callouts 
Callout Name Description 

1 Analog Inputs Inputs added for XT module 
2 Analog Outputs Outputs added for XT module 
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Table 4-4: XT and XTM Modules 
Module Description 
XT 
6AI 2AO Six analog inputs and two analog outputs 
4DI 4DO Four digital inputs and four digital outputs 
8DI Eight digital inputs 
8DO Eight digital outputs 
EXP 4DI 4DO Four digital inputs and four digital outputs 
EXP 8DI Eight digital inputs 
EXP 8DO Eight digital outputs 
XTM 
4AI Four analog inputs 
4AO Four analog outputs 
4AI 4AO* Four analog inputs and four analog outputs 

(two XP modules) 
8AI* Four analog outputs (two XP modules) 
8AO* Four analog outputs (two XP modules) 
6AI 2AO Six analog inputs and two analog outputs 
4DI 4DO Four digital inputs and four digital outputs 
8DI Eight digital inputs 
8DO Eight digital outputs 
XPM Momentary output relay 
XPL Magnetically latched output relays 
XPE Electrically latched output relays 

Notes: XP Expanded digital options (preceded with EXP) only appear if the 
preceding module is an XT or XTM and not defined as EXP. 
XPE-4x4 (x=0,1,2, or 3) must be configured as 4DI 4DO and XPE-4x4 
(x=4,5,6, or 7) as 8DO. 

* Not available in North America. 
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Detailed Procedures 
Configuring Inputs and Outputs 

Note: See also Defining Input, Output, and Programmable Module 
Data section. 

To configure AIs and DOs: 
1. Right-click on the AI or DO you want to configure. A pop-up 

menu appears. 
2. Choose an option from Table 4-5. 

Table 4-5: Configuration Options for AI and DO 
Analog Inputs 
Active Accepts voltage or current. 
Passive Accepts Resistance Temperature Device 

(RTD). 
Digital Output 
P.A.T. (Position Adjust Type) Uses a pair of triacs and a numeric source. 
D.A.T. (Duration Adjust Type) Provides a time-based duty cycle proportional 

to the value of the numeric source. 
On/Off Provides a single maintained On/Off triac input. 
Sta/Sto (Start/Stop) Uses a pair of triac outputs and requires a logic 

source. 
Pulse Provides a single momentary triac output from a 

logic source. 

 
3. Follow the procedure in Defining a User Name. 
Note: 

IMPORTANT:

Configure all DOs as On/Off or Pulse regardless of whether 
or not they are used. The only exceptions are the 4-output 
relay modules (XP-9107 and XPE-4x4, x=4, 5, 6, or 7). 
When only one 4-output module is installed, select 8DO, but 
only configure DO1-DO4. When two 4-output modules are 
installed, configure both as one 8DO module, and configure 
DO1-DO8. 

 Configure XPM-4x1, XPL-4x1, and XPE-4x1 modules 
as On/Off. The action of the outputs is determined by 
the hardware, not by the configuration. 



 GX-9100 Software Configuration Tool User’s Guide 4-9

Deleting Modules 
To delete modules: 
1. Right-click on a module. The pop-up menu appears. 
2. Click Delete. An Untitled dialog box appears to confirm the 

deletion. 

 

Figure 4-2: Untitled Delete Confirmation Dialog Box 
3. Click Yes. 
Note: 

Note: 

A deleted AI or Do remains on the screen, but is no longer 
configured. 

Adding Programmable and Extension Modules 
To add programmable and extension modules: 
1. Click the Add PM button on the toolbar. The Add PM menu 

appears. 
2. Select the type of module from the menu. If opting for a XT, 

XTM, control, or numeric module, a submenu appears. 
3. Once you select the type, a highlighted box containing the type 

name and module number appears next to the pointer. 
4. Move the module to the desired location and click. You can move 

the module at any time by clicking and dragging it to a new 
position on the screen. 

Defining a User Name 
This process is the same for programmable modules, AIs, 
DOs, AOs, and DIs. 

To define a user name: 
1. On the GX Tool main screen, right-click on a configured module 

or input/output. A pop-up menu appears. 
2. Select Data. A Data dialog box appears (Figure 4-3). 
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Figure 4-3: Data Dialog Box Example 
3. Enter an 8-character name in User Name field. 
4. Enter a 24-character description in Description field. 

Other data fields are described in Defining Input, Output, 
and Programmable Module Data in this chapter. 

Note: 

5. Click OK. 

Defining Input, Output, and Programmable Module Data 
To define input, output, and programmable module data: 
1. Right-click on the programmable module and select Data from the 

module pop-up menu that appears. The module Data dialog box 
appears (Figure 4-4). 
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Figure 4-4: Module Data Dialog Box Example 
2. Enter values into the data fields. Refer to the DX-9100 

Configuration Guide (LIT-6364030) for data field details. 
Notes: Fields proceeded by an arrow (->) are used for connecting 

modules. Refer to Connecting and Disconnecting Modules 
chapter for details. 

3. Click the Input-Tag button to assign user names to the destination 
points (if applicable). 

4. Click the Output-Tag button to assign user names to the source 
point (if applicable). 

5. Click the Data-2 button to access the second page if the module 
has two pages and a second Data dialog box appears (Figure 4-5). 
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Figure 4-5: Module Data Second Dialog Box Example 
6. Enter the desired values in the empty data fields of the second 

data dialog box. Refer to the DX-9100 Configuration Guide 
(LIT-6364030) for data field details. 

7. Click OK to save the new values and return to the first Data dialog 
box. 

8. Click OK to save all values and exit the Data dialog box. 

Naming a Connection Point 
Note: This procedure is the same for AIs, AOs, DIs, DOs, and 

programmable modules. Not all modules have input and 
output connection points. 

To name a connection point: 
1. On the GX Tool main screen, right-click on the module with 

connection points you want to name. Module pop-up menu 
appears. 

2. Select Data. Module Data dialog box appears (Figure 4-3). 
3. Click Output Tag (or Input Tag) from Module Data box.  

Output-Tag dialog box appears (Figure 4-6). 
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Figure 4-6: Output-Tag Dialog Box Example 
4. Enter a name (up to eight characters) into the User Name box for 

each connection point. 
5. Click OK. Module Data dialog box appears. 
6. Click Input Tag (if applicable) or click OK. 

Calibrating Analog Inputs and Outputs 
To calibrate analog inputs and outputs: 
1. Upload a configuration from the controller with Calibration as the 

selected item in the Upload dialog box. 
See Downloading to the DX Controller chapter for details. Note: 

Note: 

2. On the Edit menu, click Calibration. The Calibration dialog box 
appears (Figure 4-7). 

To save calibration data, create a file for each DX controller. 
The calibration data for each controller is different. 
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Figure 4-7: Calibration Dialog Box 
3. Enter Values according to Table 4-6. 

Table 4-6: Calibration Values 
Field/Group Values 
Input 0–32767 
Output 0–32767 
Clock Daily Adjust -32767–32767 

Note: Reversing High and Low output values reverses the action of the controller. 
 
4. Download the configuration to the controller with Calibration as 

the selected item in the Download dialog box. 
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Troubleshooting 
Download/Upload Errors 

Table 4-7: Downloading/Uploading Configurations Error 
Error Cause 
Data window values delete 
upon exiting window. 

You may have exited the window by clicking 
CANCEL or by pressing Esc before saving 
changes. Be sure to save changes before 
exiting data windows. 

 
During N30 downloads and uploads, unexpected errors are logged in a 
file called errorlog.txt. Errolog.txt is generated in the directory in 
which the GX9100 software is installed. Table 4-8 describes the error 
codes. 

Table 4-8: Error Codes 
Error Code Error Description 
0 System is out of memory, executable file is corrupt, or 

relocations are invalid. 
5 Application tried to dynamically link to a task, or there is a 

sharing or network-protection error. 
6 Library requires separate data segments for each task. 
8 There is insufficient memory to start the application.  
10 Windows® Operating System (OS) version is incorrect.  
11 Executable file is invalid. Either it is not a Windows OS 

application or there is an error in the .EXE image. 
12 Application is designed for a different operating system. 
14 Type of executable file is unknown. 
15 Application tried to load a real-mode application (developed for 

an earlier version of Windows OS). 
16 Application tried to load a second instance of an executable file 

containing multiple data segments that are not marked read-only. 
19 Application tried to load a compressed executable file. The file 

must be decompressed before it can be loaded. 
20 Dynamic-Link Library (DLL) file is invalid. One of the DLLs 

required to run this application is corrupt. 
21 Application requires Microsoft® Windows OS 32-bit extensions. 
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Chapter 5  
Creating PLC Ladder Diagrams 

Introduction 
The GX Tool software-implemented PLC supports most of the 
functions available in dedicated PLCs. PLC functions are defined in 
ladder diagrams. In the GX Tool, the PLC is subdivided into 
eight pages: PLC1 to PLC8. 
This chapter describes how to: 

• access the ladder diagram 

• add instructions to the ladder diagram 

• create logic blocks within a line 

• create an OR loop within a logic block 

• add associated logic variables to instructions 

• delete a PLC instruction 

• cut, copy, and paste logic blocks 

• insert a line into the PLC diagram 

• save to PLC library 

• open from PLC library 

• save the PLC ladder diagram 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-120186 Software Release 7.10 
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Key Concepts 
Ladder Diagrams 

The top of the ladder diagram screen is numbered PLC1 to PLC8 
(Figure 5-1). The User Name and Description fields can only be 
changed from the PLC block’s data window. 
The diagram has eight rows. Each row has eight dots called hot points. 
Instructions start on the hot spots at the left and end at the right.  
Table 5-1 lists PLC instructions. 
Double-click on the control box at the left side of the menu bar to exit 
the diagram. A separate ladder diagram and a separate module block 
on the screen represent each PLC. 

 

Figure 5-1: Ladder Diagram 
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Table 5-1: PLC Instructions 
Module Instructions 
NOP No operation 
LOAD Loads the value of the addressed logic variable into 

the result status. 
LOAD NOT Loads the inverted value of the addressed logic 

variable into the result status. 
AND Logical AND between the value of the addressed 

logic variable and the result status 
AND NOT Logical AND between the inverted value of the 

addressed logic variable and the result status 
OR Logical OR between the value of the addressed logic 

variable and the result status 
OR NOT Logical OR between the inverted value of the 

addressed logic variable and the result status 
ANDB Logical AND operation between two blocks 
ORB Logical OR operation between two blocks 
OUT Transfers the result status to the addressed logic 

variable. 
OUT NOT Transfers the inverted result status to the addressed 

logic variable. 
COS Change-of-state of the result status set the result 

status to 1 for one program cycle. 
SET Sets the addressed logic variable to the logical 1 if 

the result status is 1. 
RST (RESET) Resets the addressed logic variable to the logical 0 if 

the result status is 1. 
RSR (RESTART) Allows you to create a power up routine starting in 

Row 1 of Page 1 and ending the row before the RSR 
instruction. 
The RSR symbol marks the beginning of a PLC 
program instruction. Rows and pages before the RSR 
instruction execute only when the DX controller is 
powered up after a power failure. 
You can define only one RSR instruction. If no RSR 
exists, the PLC begins at Row 1 on Page 1. 
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PLC Menus and Toolbar 
The PLC screen (Figure 5-1) contains five menus and a toolbar. The 
View menu, Window Menu, Help Menu, and the toolbar are identical 
to the main Windows screen. Refer to the Getting Started with the GX 
Tool and the DX Controller chapter for menu details. 
The File menu (Table 5-2) and the Edit menu (Table 5-3) contain PLC 
specific options. 

Table 5-2: File Menu Options- PLC 
Menu Option Description 
Save Saves the current PLC ladder diagram. 
Close Closes the current PLC page. 
Print Prints the current PLC page. 
Print Preview Displays the current PLC ladder diagram as it will 

appear printed. 
Print Setup Sets PLC print parameters, including default printer, 

portrait or landscape, paper size and source, and 
page range. 

Header/Footer Defines headers and footers. 
Open from Library Reads the selected file from the PLC library onto the 

clipboard. The insert action is completed by selecting 
the destination location and executing the paste 
command. 

Save to Library Saves the selected logic blocks in a PLC page to the 
PLC library. 

 

Table 5-3: Edit Menu Options- PLC 
Menu Option Description 
Undo Cancels the last action of cut or paste. 
Cut Removes logic blocks and places them on the 

clipboard. 
Copy Copies logic blocks to the clipboard. 
Paste Pastes logic blocks from the clipboard. 
Select All Selects all logic blocks on the page. 
Insert Line Inserts a blank line in the ladder diagram at the first 

hot spot of an existing logic block. 
Page Reformat Moves all blank lines to the bottom of the page. 
Delete Deletes the selected logic blocks. 
Clear Page Deletes the whole page. (To restore, close without 

saving and reopen PLC module.) 
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Detailed Procedures 
All procedures except Accessing the Ladder Diagram are 
performed within the PLC screen. 

Note: 

Accessing the Ladder Diagram 
To access the ladder diagram: 
Double-click on the PLC module. A ladder diagram appears 
(Figure 5-1). 

Adding Instructions to the Ladder Diagram 
To add instructions to the ladder diagram: 
1. Click on the top left hot point and the PLC List Box  

appears (Figure 5-2). 

 

Figure 5-2: PLC List Box 
2. Select  LOAD as the first instruction and click OK. The LOAD 

symbol appears within the ladder diagram (Figure 5-3). 
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Figure 5-3: Adding the LOAD Symbol 
3. Continue to click on unused hot points and add instructions to the 

ladder diagram until the PLC program is complete (Figure 5-4). 
Note: It is impossible to select a hot point preceded by a blank 

column or if the row above the point is empty. 
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Figure 5-4: PLC Ladder Diagram Example 

Creating Logic Blocks within a Line 
To create a logic block within a line: 
1. Click a hot spot in a line. The PLC instruction list box appears 

(Figure 5-2). 
2. Select LOAD to begin the block. 
3. Add instructions to the logic block. 
4. Select ANDB to end the block. The letter B marks the end of the 

block. 

Creating an OR Loop within a Logic Block 
To create an OR loop within a logic block: 
1. Click a hot spot within the logic block. The PLC instruction list 

box appears (Figure 5-2). 
2. Select ORB. 
3. Select LOAD or LOAD NOT. 
4. Add instructions after the LOAD or LOAD NOT instruction 

(Figure 5-5). 
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Figure 5-5: Example of a Logic Block within a Line 
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Adding Associated Logic Variables to Instructions 
To add associated logic variables to instructions: 
Note: This is also the procedure to modify associated logic 

variables. 

1. Click on the center of the first PLC instruction. The intermediate 
PLC List Box showing all configured modules appears  
(Figure 5-6). 

 

Figure 5-6: PLC List Box for Configured Modules 
2. Select a module from the intermediate menu and click OK. For 

example, if you select DX/XT I/O from the PLC List Box  
(Figure 5-6), the PLC List dialog box for DX/XT I/O appears 
(Figure 5-7). 
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Figure 5-7: PLC List Box Showing All Logic Variables 
Under DX/XT I/O 

3. Select one of the logic variables and click OK. If you select DI1, 
the ladder diagram contains the DI1 variable (Figure 5-8). 

 

Figure 5-8: LOAD Symbol with Associated Variable DI1 
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4. Continue to add associated variables to all remaining logic 
instructions (Figure 5-9). 

 

Figure 5-9: Ladder Diagram with PLC Instructions and 
Associated Values 

Deleting a PLC Instruction 
To delete a PLC instruction: 
Notes: Only Load, Load Not, And, and And Not instruction can be 

deleted. 
All instruction after the deleted Load and Load Not 
instructions are also deleted. 

1. Click on a PLC instruction. PLC List Box appears. 
2. Click Delete. The Modify dialog box appears to confirm deletion. 

 

Figure 5-10: Modify Dialog Box 
3. Click Yes. 
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Cutting, Copying, and Pasting Logic Blocks 
To cut, copy, and paste logic blocks: 
1. Click on a hot spot within a logic block while holding Ctrl. 

The logic block turns red. 
Note: 

Notes: 

Note: 

Note: 

You can select multiple logic blocks at once. 

2. Right-click on a hot spot within the selected logic block and the 
Edit menu appears. 

3. Click Cut or Copy. The logic block is copied to the clipboard. 
4. Move the cursor to a hot spot on the left side of the page and 

right-click. The Edit menu appears. 
5. Select Paste. 

If you insert a block within a page, blocks below will move 
down for the inserted line. 
An error message appears if there are not enough free lines 
in the PLC page. 

Inserting a Line into the PLC Diagram 
To insert a line into the PLC diagram: 
1. Right-click on a hot spot to open the PLC Edit menu. 
2. Select Insert Line. 
3. Repeat to insert multiple lines. 

Blank lines move to the bottom of the page when you exit 
the PLC diagram. 

Saving to PLC Library 
The PLC library is used to save a selected module or selected 
modules. 

To save to PLC library: 
1. On the File menu, click Save to Library. The Save to PLC Library 

dialog box appears (Figure 5-11). 
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Figure 5-11: Save to PLC Library Dialog Box 
2. Change the library directory path if desired. 
3. Enter name into File Name field. 
4. Click OK. 

Opening from PLC Library 
To open from PLC library: 
1. On the File menu, click Open. The Open from PLC Library dialog 

box appears (Figure 5-12). 

 

Figure 5-12: Open from PLC Library Dialog Box 
2.  Select a file with the extension .PXS. 
3. Click OK. The logic block is copied to the clipboard. 
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4. Move the cursor to a hot spot on the left side of the page and 
right-click. The Edit menu appears. 

5. Select Paste. 
Notes: If you insert a block within a page, blocks below will move 

down for the inserted line. 
An error message appears if there are not enough free lines 
in the PLC page. 

Saving the PLC Ladder Diagram 
To save the PLC ladder diagram, on the File menu, click Save. 
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Chapter 6  
Connecting and Disconnecting 
Modules 

Introduction 
A configuration comprises a set of parameters for each module. 
The controller stores modules in a series of memory locations. The 
GX Tool assigns each module a type and connects module outputs 
(source points) to module inputs (destination points). See Appendix A 
for lists of source and destination points. 
This chapter describes how to: 

• connect modules 

• disconnect modules 

• show module connections 

• view selected points and modules in a configuration 

• trace modules in a configuration 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-120187 Software Release 7.10 
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Key Concepts 
Connected Modules 

An input with a logical connection to an output is a connected module. 
The GX Tool screen (Figure 6-1) shows a line between connected 
modules. 

 

Figure 6-1: Example of Connected Modules 
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Procedure Overview 
Table 6-1: Connecting and Disconnecting Modules 
To Do This Follow These Steps: 
Connect Modules Using the 
Click-Drag Method  

Double-click both modules to maximize and show points. Place bent 
arrow cursor on source point. Click and drag cursor to destination point. 
Release Button. Inverted connection dialog box appears (digital inputs 
only). Click Yes or No. Line appears connecting modules. 

Connect Modules Using the 
Connect Option 

Right-click source point module. Select Connect from the module menu. 
Module Connect dialog box appears. Select source point and click OK. 
Right-click destination module. Select Connect from the module menu. 
Module Connect dialog box appears. Choose destination point and click 
OK. Inverted connection dialog box appears (digital inputs only). Click Yes 
or No. Line appears connecting modules. 

Connect Modules within the 
Data Dialog Box 

Right-click on destination point module. Select Data from the module 
menu. The module data window appears. Select the data field 
corresponding to the desired connection. Type an asterisk (*) in the field. 
A menu listing the valid configuration modules appears. Highlight the 
desired configuration module and click OK. A window listing all valid 
module outputs appears. Highlight the desired output and click OK. A line 
appears showing the connection between the two modules. 

Disconnect Modules Using the 
Scissors Cursor 

Double-click both modules to maximize and show points. Place the cursor 
on the connected point. The cursor turns into the Scissors cursor. Click on 
the connection. An Untitled delete confirmation box appears. Click Yes to 
confirm. The connection is removed. 

Disconnect Modules Using the 
Disconnect Option 

Right-click on the destination module. Select Disconnect from the module 
menu. The Disconnect dialog box appears showing all connected module 
destination points. Choose the destination point you wish to disconnect 
and click OK. A dialog box appears to confirm connection deletion. Click 
Yes. The connection line is removed from the screen. 

Disconnect Modules within the 
Data Dialog Box 

Right-click on the module that contains the connection. Select Data from 
the module menu. The module data window appears. Highlight a name in 
the data field and press the Delete key. You are returned to the data 
window. Click OK. The connection line is removed from the screen. 

Show Module Connections • Double-click module to maximize and show source and destination 
points. Double-click to minimize. 

• Select module. Select Edit > Data. Module Data window appears. 
Click OK to close. 

• Select module. Select View > Show Connections. Connections dialog 
box appears and shows all source point connections. Click OK. 

View Selected Points and 
Modules in a Configuration 

Select the points and modules by clicking on them. Hold down Ctrl and 
click to select multiple points. On the View menu, click Show Selected. On 
the View menu, click Show All to see all points on modules on the screen. 

Tracing Modules in a 
Configuration 

Click the module to trace. On the View menu, click Trace. Click another 
module to trace connections to that module. Hold down Ctrl and click to 
trace multiple modules. On the View menu, click Trace to turn off the 
Trace function. 
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Detailed Procedures 
Connecting Modules 

Using the Click-Drag Method 
To connect modules using the click-drag method: 
1. Double-click both modules to maximize and show points. 
2. Place bent arrow cursor on source point. 
3. Click and hold source point. 
4. Drag cursor to destination point. 
5. Release button. Inverted Connection dialog box appears 

(digital inputs only) (Figure 6-2). 

 

Figure 6-2: Inverted Connection Dialog Box 
6. Click Yes or No. A line appears (Figure 6-1) between modules to 

show connection. 

Using the Connect Option 
To connect modules using the Connect option: 
1. Click the module that contains the source point. 
2. Right-click outside of the highlighted module. The pop-up module 

menu appears. 
3. Select Connect from the module menu. The module connect 

dialog box appears (Figure 6-3) containing source points for the 
selected module. 
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Figure 6-3: Module Connection Dialog Box Example 
4. Choose a source point and click OK. 
5. Click the destination module. 
6. Right-click outside the module. The pop-up module menu 

appears. 
7. Select Connect from the module menu. The module connect 

dialog box appears (Figure 6-4) containing destination points for 
the selected module. 

 

Figure 6-4: Destination Point Dialog Box Example 
8. Choose a destination point and click OK. Untitled inverted 

connection dialog box appears (digital inputs only) (Figure 6-2). 
Note: Only unused destination points appear in the Connect 

destination points box. To reuse a destination point, first 
delete the old connection. 

9. Click Yes or No. A line appears showing the connection between 
the two modules. 
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Making Connections within the Data Dialog Box 
To make connections within the Data dialog box: 
1. Right-click on the module that contains the destination point. The 

module pop-up menu appears. 
2. Select Data from the module menu. The module data window 

appears (Figure 6-5). 

 

Figure 6-5: Module Data Window Example 
3. Select the data field corresponding to the desired connection. The 

blinking cursor appears in the box. 
Note: Only descriptions followed by an arrow (->) accept 

connections. 

4. Type an asterisk (*) in the field. A menu listing the valid 
configuration modules for the selected field appears (Figure 6-6). 
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Figure 6-6: List of Valid Configuration Modules Example 
5. Highlight the desired configuration module and click OK. A 

window listing all valid module outputs appears (Figure 6-7). 

 

Figure 6-7: Valid Outputs Window Example 
6. Highlight the desired output and click OK. A line appears  

(Figure 6-1) showing the connection between the two modules. 
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Disconnecting Modules 

Using the Scissors Cursor 
To disconnect modules using the scissors cursor: 
1. Double-click both modules to maximize and show points. 
2. Place the cursor on the connected point. The cursor turns into the 

Scissors cursor. 
3. Click on the connection. An Untitled delete confirmation box 

appears (Figure 6-8). 

 

Figure 6-8: Delete Confirmation Dialog Box 
4. Click Yes to confirm. The connection is removed. 

Using the Disconnect Option 
To disconnect modules using the Disconnect option: 
1. Click on the destination module. 
2. Right-click outside the module. The module pop-up menu 

appears. 
3. Select Disconnect from the module menu. The Disconnect dialog 

box appears (Figure 6-9) showing all destination points of the 
selected module that are currently connected. 

 

Figure 6-9: Destination Point Dialog Box Example 
4. Choose the destination point you wish to disconnect and click OK. 

A dialog box appears (Figure 6-8) to confirm connection deletion. 
5. Click Yes to delete. The connection line is removed from the 

screen. 
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Disconnecting within the Data Dialog Box 
To disconnect the modules using the Data dialog box: 
1. Click on the module that contains the connection. 
2. Right-click outside of the highlighted module. The module pop-up 

menu appears. 
3. Select Data from the module menu. The module data window 

appears (Figure 6-5). 
4. Highlight the entire name in the data field you want to delete and 

press the Delete key. 
5. Data window appears. Click OK. The connection line is removed 

from the screen. 

Showing Module Connections 
There are three ways to show module connections: 

Double-click Module 
To show module connections by double-clicking: 
1. Double click connected module to maximize and show source and 

destination point connections. 
2. Double-click to minimize. 

Module Menu 
To show connections using the Module menu: 
1. Select module. 
2. On the Edit menu, click Data. Module Data window appears. 
3. Click OK to close. 

View Menu 
To show connections using the View menu: 
1. Select module. 
2. On the View menu, click Show Connections. Connections dialog 

box appears (Figure 6-10) and shows all source point connections. 
3. Click OK. 
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Figure 6-10: Connections Dialog Box Example 

Viewing Selected Points and Modules in a Configuration 
To view selected points and modules in a configuration: 
1. Select the points and modules to view by clicking on them. To 

select multiple points, hold down Ctrl and click points. 
2. On the View menu, click Show Selected. 
3. On the View menu, click Show All to see all points and modules 

on the screen. 

Tracing Modules in a Configuration 
To trace modules in a configuration: 
1. Click the module to trace. 
Note: To select multiple modules, press hold Ctrl while clicking. 

2. On the View menu, click Trace. The selected module connections 
remain visible for easy tracing. All other connections become 
invisible. 

3. Click on another module to trace the connections path for that 
module. To trace multiple modules at the same time, Ctrl+click on 
each subsequent module. 

4. On the View menu, click Trace to turn off the Trace function. 
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Troubleshooting 
Table 6-2: Connecting Modules Error Message 
Message Cause 
The source and 
destination points 
do not match! 

The source and destination points are not of 
the same type (analog or digital). Choose a 
new source and/or destination point for this 
connection. 
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Chapter 7  
Defining Trend Log Modules 

Introduction 
The Trend Log module provides Metasys Point History data for 
remotely connected DX controllers or for a local DX LCD Display. 
The module provides 12 trend log channels, each records data from 
either 1 analog item or from a set of 8 logical variables (logic variable 
byte).  
This chapter describes how to: 

• define the Trend Log module channels 

• configure the Dial function for Metasys Point History 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-120188 Software Release 7.10 
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Key Concepts 
Trend Data 

The DX controller collects and stores trend data for up to 12 analog 
and logic variables. An analog variable corresponds to an analog item 
in the DX controller, such as an analog output. A logic variable in the 
DX controller is a byte value representing eight digital bits, such as the 
eight digital inputs DI1 to DI8. Trend data is collected for all eight bits 
of the logic variable experiences a Change-of-State (COS). 
You must satisfy three prerequisites before you can define trend data: 

• The configured DX controller must support trend data. Table 7-1 
lists DX controllers and trend data support. 

• The Trend Log module must exist in the controller configuration. 

• You must define points in the Trend Log module. These points are 
automatically inserted into the same positions of the DX LCD 
Display Trend Data window. 

Table 7-1: Controller/Trend Data Support 
DX Controller Version Supports Trend Data 
1.1, 1.2, 1.3 No 
1.4 Yes 
2.0, 2.1, 2.2 No 
2.3, 2.4 Yes 
3.0, 3.1, 3.2 No 
3.3, 3.4 Yes 
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Metasys Point History 
When an NDM dialer connects the DX controller to a Metasys system, 
the trend data is read whenever the Metasys system makes a 
connection. The data is stored in the point history file of Analog Input 
(AI), Analog Output Setpoint (AOS), and Binary Input (BI) objects 
when they are mapped to the items being recorded. When you select 
the Metasys Point History option for a trend log channel, only those 
items mapped to Metasys objects are allowed, and the trend 
parameters are set by the GX Tool to default values for the Point 
History feature in the Metasys system. 
You must link the Historical Trend Read Request (HTRR) logic 
variable to the DIAL request logic variable in a PLC module to initiate 
a dial-up connection when the trend record buffer is full. 
DX Version 3.x controllers cannot be connected to a Metasys system 
by the NDM dialer and telephone lines. Trend logs cannot be 
configured for Metasys Point History in these versions. 
For more information about Metasys Point History, refer to the Point 
History Technical Bulletin (LIT-636112). 

DX LCD Display without Metasys Point History 
Trend channels excluded from the Metasys Point History are freely 
configurable. For analog items, enter the sampling rate and the stored 
values as average, maximum, or minimum values during the period or 
the instantaneous value at the time of reading. Logic variables receive 
a time and date stamp when the values change. All channels display on 
the DX LCD Display. 

Trend Log Items 
Table 7-2 lists the analog items and logic variables available in a 
Trend Log module for Metasys Point History. On the Metasys system, 
the analog inputs are mapped to AI objects, the analog outputs to AOS 
objects, and the logic variables to BI objects. 
Table 7-3 lists the analog items and logic variables available in a 
Trend Log module for the DX LCD Display. 
A logic variable set is recorded when any one of its variables change 
state. We recommend assigning Logical Result Status (LRS) logic 
variable bytes to the trend log and then connecting the source variables 
you want to trend to the LRS variables in a PLC module (Figure 7-1). 
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Figure 7-1: Example of Assigning LRS Logic Variable Bytes 

Table 7-2: Trend Log Items for Metasys Point History 
DX Version Analog Items Logic Variables 
1.4, 2.4, and Later AI1 to AI8 

OUT1 to OUT8 
ACO1 to ACO8 
XTnAI1 to XTnAI8* 
XTnAO1 to XTnAO8* 

DI1..8 
LRS1..8 
LRS9..16 
LRS17..24 
LRS25..32 
XTnDI1..XTnDI8* 

2.4 and Later OUT9 to OUT14 – 
* Requires Metasys Person-Machine Interface (PMI) Release 11.00 or later. 
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Table 7-3: Trend Log Items for DX LCD Display 
DX Version Analog Items Logic Variables 
2.4, 3.4, and Later AI1 to AI8 

OUT1 to OUT14 
ACO1 to ACO8 
XTnAI1 to XTnAI8 
XTnAO1 to XTnAO8 
PMnK1 to PMnK34 
PMnOU1 to PMnOU8 
PMnAX1, PMnAX2 

DI1..8 
LRS1..8 
LRS9..16 
LRS17..24 
LRS25..32 
LRS33..40 
LRS41..48 
LRS49..56 
LRS57..64 
DO3..8 
DCO1..8 
DCO9..16 
DCO17..24 
DCO25..32 
XTnDI1..8 
XTnDO1..8 
AIH1..4 
AIH5..8 
AIL1..4 
AIL5..8 
XTnAIH1..4 
XTnAIH5..8 
XTnAIL1..4 
XTnAIL5..8 
PMnDO1..8 

3.4 and Later NAI1 to NAI16 NDI1-1..8 
NDI1-9..16 
NDI2-1..8 
NDI2-9..16 
NDI3-1..8 
NDI3-9..16 
NDI4-1..8 
NDI4-9..16 
NDI5-1..8 
NDI5-9..16 
NDI6-1..8 
NDI6-9..16 
NDI7-1..8 
NDI7-9..16 
NDI8-1..8 
NDI8-9..16 
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Detailed Procedures 
Defining the Trend Log Module Channels 

To define the Trend Log module channels: 
1. From the GX Tool main screen, double-click on the Trend Log 

module block. The Trend Log data window appears (Figure 7-2). 

 

Figure 7-2: Trend Log Data Window Example 
2. Right-click the channel to configure, and select Data from the 

pop-up menu that appears. The Data dialog box for the Trend Log 
channel appears (Figure 7-3). 
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Figure 7-3: Data Dialog Box for Trend Log Channel 
3. Type a Tag Name or an asterisk (*) to select a Tag Name from a 

list. Check the Metasys Point History box if required. 
4. Click OK and a Select item category dialog box appears  

(Figure 7-4). 
Note: If you enter a specific Tag Name, the next dialog box is the 

appropriate Trend Data dialog box. Proceed to Step 8. 

 

Figure 7-4: Select Item Category Dialog Box 
5. Highlight a category and click OK. A Select subcategory dialog 

box appears (Figure 7-5). 
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Figure 7-5: Select Subcategory Dialog Box 
6. Highlight a subcategory and click OK. A Select item dialog box 

appears (Figure 7-6). 
Note: Several subcategory dialog boxes may appear before you 

reach the Select item dialog box. 

 

Figure 7-6: Select Item Dialog Box 
7. Highlight the item you want to add to the table and click OK. An 

analog item or a logic variable set Trend Data dialog box appears 
(Figure 7-7 or Figure 7-8). 
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Figure 7-7: Analog Item Trend Data Dialog Box 

 

Figure 7-8: Logic Variable Set Trend Data Dialog Box 
8. Fill-in data fields or select from the drop-down lists according to 

Table 7-4. 
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Table 7-4: Trend Data Entries and Options 
Dialog Field Possible Values Default (Metasys 

Point History Setting) 
Sampling Rate* (period of 
time between records) 

5, 10, 15, 20, 60 
Seconds** 
1 to 1440 Min 

Analog Input: 30 
Analog Output: 30 

Units for Sampling Rate Seconds 
Minutes 

Minutes 

Read Request*** (number 
of new samples to set 
HTRR) 

Analog: 0 to 61**** 
Logic Variables: 
0 to 30 

Analog Input: 48 
Analog Output: 48 
Logic Variables: 10 

Sampling Mode (analog 
value to record at end of 
each period) 

Actual 
Average 
Maximum 
Minimum 

Actual 

Synchronization (exact time 
of the start of trend 
recording) 

None 
Day (midnight 
00:00:00) 
Hour (xx:00:00) 
Minute (xx:xx:00) 

Hour 

* Logic Variable bytes are read each second but only recorded when there has 
been a change-of-state in at least one bit. 

**  When seconds are selected, the GX Tool automatically increases the entered 
value to one of the specified values and gives an error if the value is over 60. 

***  A Read Request value of 0 disables the Read Request feature for the Item or 
Logic Variable. 

**** The GX Tool sends the first 48 read requests in one transmission. The rest are 
sent in a second transmission. To prevent a second transmission, enter 48 as the 
maximum Read Request. 

 
9. Click OK to save the channel data and return to the Trend Log 

definition table. 
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Configuring the Dial Function for Metasys Point History 
To configure the DIAL function for Metasys Point History: 
1. Add a LOAD element to any free line of a PLC module. 
2. Assign the LOAD element with the logic variable Historical 

Trend Read Request (HTRR), listed under Diagnostic. 
3. Add a SET element to the line. 
4. Assign the SET element the logic variable DIAL, listed under 

SUPERV. 
Notes: If other logic variables have already been configured to set 

the DIAL variable, add the HTRR variable as an OR element 
to the ladder diagram (Figure 7-9). 
For more information on this application, refer to the 
DX-9100 Configuration Guide (LIT-6364030) or the NDM 
Configurator Application Note (LIT-6364090). 

 

Figure 7-9: Ladder Logic to Set DIAL from Trend Log 
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Chapter 8  
Reusing Configurations 

Introduction 
The GX Tool allows you to reuse and manipulate the modules and data 
that define configurations. The first step in working with a 
configuration is to upload a configuration from the DX controller or to 
open a previously saved configuration file. 
This chapter describes how to: 

• upload a configuration from the DX controller 

• open a previously saved configuration file 

• save a configuration file 

• save modules to the Application Library 

• open modules from the Application Library 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-120189 Software Release 7.10 
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Key Concepts 
Download and Upload Files 

The file extension indicates if the file is being downloaded or 
uploaded. It also indicates the data it contains. Refer to Table 8-1 for 
download and upload file extensions and the data they contain. 

Table 8-1: Download and Upload File Extensions 
File Extension Configuration Data 
Download Files 
DXF DX and XT 
XTF XT/XTM only 
CLF Calibration only 
Upload Files 
DXU DX and XT 
XTU XT/XTM only 
CLU Calibration only 
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Paste Process 
You can reuse a set of modules in a configuration or transfer them to a 
new configuration. The GX Tool uses a series of dialog boxes to 
modify connections and modules during the pasting process  
(Figure 8-3 and Figure 8-1). 
Connections between selected modules transfer to the target 
configuration. The data content of I/O modules replaces the data 
content of I/O modules in the target configuration. The paste process 
deletes connections to items that do not exist in the target 
configuration. 
Notes: If the module is an Analog Input (AI) that is already 

referenced by a connection in another module, the type of the 
AI module (Active or Passive) cannot be overwritten and the 
paste action must be cancelled. 
If the module is an output module with an existing 
connection, the module cannot be overwritten unless you 
delete the connection first. 
Select Analog Constants (ACO), Digital Constants (DCO), 
and Logic Result Status modules only if they do not exist in 
the target configuration. Redefining connections to these 
modules is part of the transfer process. Enter values for ACO 
and DCO items once the transfer process is complete. 

Each programmable and time schedule module number changes to the 
number of the next available unused module in the target configuration 
during the transfer process, and can be changed by the user. The 
references to connections between modules in the selected set are 
changed automatically and cannot be modified during the transfer 
process. 
The PLC module cannot be pasted. 
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I/O Module Modification 
When I/O modules (e.g., AI1, DO3) are part of the set of modules you 
are reusing or transferring, sufficient modules of the same type must 
be available in the target configuration. If XT or XTM I/O modules are 
included, create the appropriate number of XT or XTM modules in the 
target configuration before reusing or transferring modules. 
Use the Modify I/O Modules dialog box (Figure 8-1) to modify I/O 
modules pasted into the configuration. This box lists the Original and 
New connection points of the I/O modules about to be pasted. 
All connections between the selected modules are transferred to the 
target configuration. 
Connections to modules not included in the selected set must be 
deleted or changed during the paste process to fit the target 
configuration to complete the transfer. See Programmable Module 
Modification. 
The data content of I/O modules included in the selected set replaces 
the data content of I/O modules in the target configuration. If the 
module is an output module with an existing connection, the module 
cannot be overwritten until the connection is first deleted. 
To reuse I/O modules that exist in the target configuration and 
preserve the existing data in the modules, do not select them. 
Double-click the New point for a list of available points. 
Refer to Table 8-2 for options when modifying I/O module 
connections. 
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Figure 8-1: Modify I/O Modules Dialog Box Example 

Table 8-2: Modifying I/O Modules 
Option Description 
Inputs Original Displays originally connected Input modules. 
Inputs New Displays newly connected modules. Double-click to select 

new connections from a pop-up list. 
Outputs Original Displays originally connected modules. 
Outputs New Displays newly connected modules. Double-click to select 

new connections from a pop-up list. 
Previous Displays previous dialog box. 
Next Displays next dialog box. 
Paste All Pastes the selected modules. The paste action cannot 

change a connection to an output module that already exists 
in the target configuration. A warning box appears  
(Figure 8-2) showing all connections that cannot be 
overwritten. 
If the warning appears, you must change the output module 
number to an unused output module, cancel the paste 
action and delete the existing connection in the target 
configuration, or remove the output module from the 
selected set of modules. 

Cancel Aborts the paste process. The selected set of modules 
remains available on the clipboard. 
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Figure 8-2: Destinations Occupied Warning Box 

Programmable Module Modification 
Use the Modify Programmable Modules dialog box (Figure 8-3) to 
modify programmable modules pasted into the configuration. This box 
lists the connection and source points of the programmable modules 
about to be pasted. 
Double-click the source point for a list of available points. 
Refer to Table 8-3 for programmable module data fields. 

 

Figure 8-3: Modify Programmable Modules 
Dialog Box Example 
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Table 8-3: Programmable Module Data Fields 
Option Description 
Module Type Displays the type of module being modified. 
Module Number Displays the module number. Change using drop-down 

menu. 
Connection Displays the connected module points. 
Source Shows the destination points. Double-click to select new 

points from a list of Source points. 
Previous Displays Modify Programmable Modules dialog box. 
Next Displays next dialog box. A warning box appears if any of 

the new references do not exist in the target configuration. 
Paste All Pastes the selected modules without displaying individual 

dialog boxes. A warning box appears if any of the selected 
modules cannot be pasted. 

Cancel Aborts the paste process. The selected set of modules 
remains available on the clipboard. 

Note: Source points marked with an * cannot be changed. 
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Detailed Procedures 
Uploading a Configuration from the DX Controller 

To upload a configuration from the DX controller: 
Note: We recommend saving the current configuration before 

uploading. The configuration you upload from the controller 
replaces the current configuration on the screen. 

1. Close all PLC, Trend, and DX LCD Display definition windows. 
2. On the Action menu, click Upload. The Upload dialog box 

appears (Figure 8-4). 

 

Figure 8-4: Upload Dialog Box 
3. Click the option buttons to select the item to upload and the port 

to which the DX controller is connected. 
Note: The File option under Port is only available if the GX Tool is 

running on a PC with M-Tool software where .dxu, .xtu, or 
.clu files are stored. These files are created when uploading a 
configuration via an N30 using the Loader UI program. To 
upload from a file, select File and click OK. The Choose File 
for Upload dialog box appears (Figure 8-5). Select a file and 
proceed to Step 6. 
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Figure 8-5: Choose File for Upload Dialog Box 
4. Enter the address of the controller from which you are uploading 

into the Address field. If you are uploading an XT/XTM that is 
directly connected to the N2 Bus (not connected to the XT Bus of 
a DX controller), enter the address of the XT/XTM module. 

5. Enter the password number of the configuration you are uploading 
in the DX Password field (only for DX Versions 1.4, 2.4, 3.4, or 
later). The upload fails if the password number is incorrect. 

Note: The Password field only appears if password protection is 
enabled. 

6. Click OK. Upload checks if the configuration in the tool matches 
the configuration in the controller. If the check fails, the GX9100 
modules do not match dialog box appears (Figure 8-6). 

 

Figure 8-6: Modules Do Not Match Dialog Box 
7. Select OK to continue uploading the configuration. The 

configuration displays on the screen when the upload is 
completed. 
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Open a Previously Saved Configuration File 
To open a previously saved file: 
1. On the File menu, click Open. The File Open dialog box appears 

(Figure 8-7). 

 

Figure 8-7: File Open Dialog Box 
2. Select the configuration from the File Name list. 
Note: If the configuration does not appear in the list, browse to the 

proper folder using the dialog box. 

3. Click OK. 
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Save a Configuration File 
To save a configuration file, on the File menu, click Save. 
Notes: The configuration saves under the current file name. If you 

are saving for the first time, the File Save As dialog box 
appears. 
If you save a configuration while in Show Selected mode, 
the entire configuration saves in this mode. When opening 
the file, on the View menu, click Show All to see the entire 
configuration. 

Save Modules to the Application Library 
To save modules to the Application Library: 
1. Click while holding Ctrl and select the modules you want to save. 
2. On the File menu, click Save to Library. The Save to Application 

Library dialog box appears (Figure 8-8). 

 

Figure 8-8: Save to Application Dialog Box 
3. Type a name in the File Name box. 
Note: Library files save as an .lxs file. 

4. Click OK. 
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Open Modules from the Application Library 
To open modules from the Application Library: 
1. On the file menu, click Open from Library. The Open from 

Application Library dialog box appears (Figure 8-9). 

 

Figure 8-9: Open from Application Dialog Box 
2. Select a file from the File Name list. Modules from the file are 

copied to the clipboard. 
3. On the Edit menu, click Paste. 
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Troubleshooting 
Table 8-4: Troubleshooting Errors 
Error/Condition Cause 
Error message: The file 
could not be opened! 

• The software could not find this file. Check that the disk is properly 
inserted in drive. 

• The software could not open the file; the file could possibly be 
corrupted. Use the backup file instead. 

Data window values delete 
upon exiting window. 

You may have exited the window by clicking Cancel or by pressing Esc 
before saving changes. Be sure to save changes before exiting data 
windows. 

When opening a *.dxs file, 
message: Error: Language 
File DXTEXT is missing, 
cannot load GX-9100 
appears on the screen. 

You are opening a *.dxs file not located on the C: drive with Windows 
Explorer or Program File Manager in Advanced Installation Management 
(AIM) Tools. Open the file within the GX Tool using File > Open. 
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Chapter 9  
Downloading the DX Controller 

Introduction 
The GX Tool downloads a configuration to the DX controller. The 
GX Tool also uploads from the DX controller to reuse, print, and 
manipulate the modules and data that define configurations. 
This chapter describes how to: 

• download a configuration to the DX controller 
For information on the Loader UI, refer to the M-Tool Overview and 
Installation Technical Bulletin (LIT-693100). For information on the 
N30 Supervisory Controller, refer to the N30 Supervisory Controller 
Technical Manual. 

© November 11, 2003 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-120190 Software Release 7.10 
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Key Concepts 
Operator Workstation (OWS) 

If downloading a configuration from the OWS, it must be DX or 
XT/XTM and the port must be File. This creates a file with a .DFX 
extension. Move the file from the GX9100 directory to the Metasys® 
System 91 subdirectory so it can be downloaded from a DX Device 
Object Focus window in the OWS. 
You cannot download a DX-9200 controller from the OWS. 

Download and Upload Files 
The file extension indicates if the file is being downloaded or 
uploaded. It also indicates the data it contains. Refer to Table 9-1 for 
download and upload file extensions and the data they contain. 

Table 9-1: Download and Upload File Extensions 
File Extension Configuration Data 
Download Files 
DXF DX and XT 
XTF XT/XTM only 
CLF Calibration only 
Upload Files 
DXU DX and XT 
XTU XT/XTM only 
CLU Calibration only 
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Detailed Procedures 
Downloading a Configuration to the DX Controller 

To download a configuration to the DX controller: 
1. On the Action menu, click Download. The Download dialog box 

appears (Figure 9-1). 

 

Figure 9-1: Download Dialog Box 
2. Select the item to download and the proper port. 
Note: When you are downloading Time from the GX Tool with 
Windows® 2000 Operating System, the Time value downloaded to the 
DX is taken from the time maintained by the GX application, and not 
directly from the current Personal Computer (PC) time. The GX 
application time is synchronized with the PC time when the GX Tool 
is started. If you change the PC time while the GX Tool is running, 
you need to close and restart the GX Tool application to enable the 
GX Tool to synchronize itself with the new time on the PC. The Time 
download feature in the GX Tool is intended for synchronizing the 
time of day in multiple DX controllers that are not connected to a 
Metasys supervisory system. When you want to repeatedly change the 
time in the DX for testing time functions, such as scheduling, when 
running on Windows 2000 operating system, you need to restart the 
GX Tool for each time change before downloading. 
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3. Enter the address of the controller in the Address data field to 
download the configuration. The address must be a number 
between 1 and 255. 

Notes: If you are downloading XT/XTM modules, the address is 
stored in the configuration and the Download dialog box 
address field is unavailable. 
Address 255 is reserved for the DX LCD Display on the 
N2 Bus. If 255 is entered, the GX9100 dialog box appears 
(Figure 9-2) to confirm the address. Click Yes or No. 

 

Figure 9-2: Address Warning Dialog Box 
4. Enter password. 
Notes: If the global data password in the configuration being 

downloaded is different from the controller password, the 
password is changed in the controller. 

 Download fails if the password is incorrect. 
5. Click OK. The hourglass appears on the screen until the 

configuration has downloaded. 
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Chapter 10  
Creating ASCII Tag Name Files 
and DDL Files 

Introduction 
The GX Tool allows you to reuse, print, and manipulate the modules 
and data that define configurations. The first step in working with a 
configuration is to upload a configuration from the DX controller or to 
open a previously saved file.  
This chapter describes how to: 

• write user names to the ASCII Tag file 

• read user names from the ASCII Tag file 

• create DDL files 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
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Key Concepts 
Tag Name ASCII Files 

The Tag name file is an ASCII text file of the current GX Tool 
configuration file information. The GX Tool creates this file and saves 
it on the local drive for offline editing. The GX Tool reads the single 
file back into multiple configurations. 
Edit the Tag name file using a standard text editor. Define names 
following the equal signs (Figure 10-1). The names you enter become 
user names when you read the file into the next configuration. User 
names change for matching modules only. 
Refer to Table 10-1 for information and character limits of the ASCII 
Tag name file. 

Table 10-1: ASCII Tag Name File Character Limits 
Information Number of Characters 
Project Description 50 characters per line 
Tag Name 8 characters 
Tag Description 24 characters per line 
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[File]
File=A:\AHU601.TAG

[Job Information]
Job Name=507 E. MICHIGAN
Controller Name=AHU-601
Engineer=WARREN JOHNSON
Branch=MILWAUKEE
Project Description1=
.
.
.
Project Description5=

[AI1]
User Name=DA-T
Description=
* Output Tag
AI=da-t
AI%=
AIH=
AIL=
OVR=
UNR=

[AIn]
User Name=RM-T
Description=

[TS1]
User Name=
Description=
* Input Tag
TSOV@=
TSON@=
TSOF@=
* Output Tag
EXS=
OUT=

[TSn]
User Name=
.
.
.
[LRSnn-mm]
User Name=
Description=
* Output Tag
LRSnn=
etc.
.
.
.

typ_tag  

Figure 10-1: Partial Example of a Typical Tag Name File 

DDL Files 
Data Definition Language (DDL) is a text-based program used to 
identify the components on a Metasys Network, organize how these 
components connect to each other, and attach the various hardware 
and software objects to the appropriate system. 
When you save the configuration, the GX Tool creates two DDL files. 
Refer to Table 10-2 for DDL file details. 

Table 10-2: DDL Files 
DDL File Extension Description 
Model File .DMO Maps CS objects and commissions 

templates in HVAC PRO™ software. 
NC File .DNC Maps hardware items AIn, DIn, AOn, 

and DOn to Metasys objects. 
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Detailed Procedures 
Writing User Names to the ASCII Tag File 

To write user names to the ASCII Tag file: 
1. On the Select File menu, click Write User Names. A Tag Name 

Dialog box appears (Figure 10-2). 

 

Figure 10-2: Tag Name Dialog Box (Write User Names) 
2. Enter a file name. 
3. Select a location. 
4. Select OK. 

Reading User Names from the ASCII Tag File 
To read user names from the ASCII Tag file: 
1. On the File menu, click Read User Names. A Tag Name Dialog 

box appears (Figure 10-2). 
2. Select the drive and directory containing the file. 
3. Select the desired Tag file from the list in the left side box. Click 

OK. The Tag and user-defined names are imported into the open 
configuration. 
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Creating DDL Files 
To create DDL files: 
1. On the File menu, click DDL File Options. The DDL File Options 

dialog box appears (Figure 10-3). 

 

Figure 10-3: DDL File Options Dialog Box 
2. Select All Items, Items Listed Below, or Show only items with 

user name. 
3. If you selected Items Listed Below, check those items you want to 

include in the DDL file. 
4. Enter the desired 8-character Metasys System Name. 
5. Clear Generate DDL On File Save check box to disable the 

automatic generation of DDL files. 
6. Click OK. 
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Chapter 11  
Downloading and Uploading a DX 
Controller via an N30 Supervisory 
Controller 

Introduction 
The GX Tool can be used to download a configuration to and to 
upload a configuration from the DX controller via an N30 Supervisory 
Controller. 
This chapter describes how to: 

• download to a DX controller via an N30 

• upload from a DX controller via an N30 
For information on the Loader UI, refer to the M-Tool Overview and 
Installation Technical Bulletin (LIT-693100). For information on the 
N30 Supervisory Controller, refer to the N30 Supervisory Controller 
Installation Technical Bulletin (LIT-6891100). 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
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Key Concepts 
XT/XTM Module Download via N30 

GX Tool Release 7 or later supports the download of XT/XTM 
module configurations as part of a DX controller configuration via the 
N30 using DX and XT/XTM. Download via N30 does not support the 
download of the XT/XTM configuration alone in any version. 
You cannot download the XT/XTM configuration individually in any 
system. 

Download and Upload Files 
The file extension indicates if the file is being downloaded or 
uploaded. It also indicates the data it contains. Refer to Table 11-1 for 
download and upload file extensions and the data they contain. 

Table 11-1: Download and Upload File Extensions 
File Extension Configuration Data 
Download Files 
DXF DX and XT 
XTF XT/XTM only 
CLF Calibration only 
Upload Files 
DXU DX and XT 
XTU XT/XTM only 
CLU Calibration only 
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Detailed Procedures 
Downloading to a DX Controller via an N30 

To download to a DX controller via an N30: 
1. On the Action menu, click Download via N30. The Download Via 

N30 dialog box appears (Figure 11-1). 

 

Figure 11-1: Download Via N30 Dialog Box 
2. Select the item to download. 
3. Enter the controller address to download to in the Address data 

field. The address must be a number between 1 and 255. 
4. Click OK. The Loader UI program appears (Figure 11-2). 
Note: The File Name field is the path of the open configuration in 

the GX Tool with an extension .dxf, .xtf, or .clf. The file 
name cannot be changed. 
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Figure 11-2: Loader UI Dialog Box for Download 
5. Click the down arrow in the Site Name field to select site. 
6. Click Connect Site. The Site Manager appears minimized on the 

Windows taskbar and establishes a connection with the Site 
shown in the Site Name field of the Loader UI dialog box. 

7. Select the N30 controller connected to the DX controller in the 
Supervisory Controller field. A list of the DX controllers 
connected to the Supervisory Controller appears in the window. 

8. Select a DX controller from the list. 
9. Click Download to initiate the download process. The DX 

Download dialog box appears (Figure 11-3). 
Note: When the Log File option is selected (default), the program 

writes a series of messages to errorlog.txt in the C: \root 
directory. 
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Figure 11-3: Download Dialog Box 
10. Click OK to continue. The Password dialog box appears  

(Figure 11-4) asking for the password. 

 

Figure 11-4: Password Dialog Box 
11. Enter the password and click OK. If the DX is not password 

protected, click OK. 
Notes: If the Password feature is disabled, but the DX controller is 

password protected, the download fails. 
If the password is incorrect, the GX Download Password 
dialog box reappears. After three incorrect entries, the 
download process is cancelled automatically. 
The progress bar in the Loader UI dialog box indicates the 
download progress. 

12. Click Close when the download is complete. If the download fails, 
refer to the errorlog.txt file for probable causes. 
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Uploading from a DX Controller via an N30 
Note: We recommend saving the current DX and XT/XTM 

configuration before uploading. The configuration you 
upload from the controller replaces the current configuration 
on the screen. 

To upload from a DX controller via an N30: 
1. On the Action menu, click Upload Via N30. The Upload Via N30 

dialog box appears (Figure 11-5). 

 

Figure 11-5: Upload Via N30 Dialog Box 
2. Select the item to upload. 
3. Enter the controller address from which the configuration is to be 

uploaded in the Address field. The address must be a number 
between 1 and 255. 

4. Click OK. When the Loader UI dialog box appears (Figure 11-6). 
Note: The File Name field is the path of the open configuration in 

the GX Tool with the extension .dxu, .xtu, or .clu. The file 
name cannot be changed. The default name of an unopened 
configuration file is n2up.xxx. 
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Figure 11-6: Loader UI Dialog Box for Upload 
5. Click Connect Site. 
6. Click the down arrow in the Site Name field to select another site. 
7. Select the N30 controller connected to the DX controller. A list of 

the DX controllers connected to the selected Supervisory 
Controller appears in the field. Select the DX controller from the 
list. 

8. Click Upload to initiate the upload process. The DX9100 Upload 
dialog box appears (Figure 11-7). 

Note: When the Log File option is selected (default), the program 
writes a series of messages to errorlog.txt in the C: \root 
directory. 

 

Figure 11-7: GX Upload Dialog Box 
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9. Click OK to continue. If the password feature is enabled, the 
Password dialog box appears (Figure 11-4) asking for the 
password. 

Note: 

Notes: 

If the Password feature is disabled, but the DX controller is 
password protected, the download fails. 

10. Enter the password and click OK. If the DX is not password 
protected, click OK. 

If the password is incorrect, the GX Download Password 
dialog box reappears. After three incorrect entries, the 
download process is cancelled automatically. 
The progress bar in the Loader UI dialog box indicates the 
upload progress. 

11. Click Close to close the Loader UI programs and terminate the 
Site Manager and Loader UI programs when the upload is 
complete. If the upload fails, refer to the errorlog.txt file for 
probable causes. 

12. Click OK if the upload is successful. Upload checks whether the 
configuration open in the GX Tool matches the configuration 
uploaded from the controller (unless you are uploading a 
calibration). Upload checks only for DX elements, and Upload 
XT/XTM checks against XT/XTM and their associated EXPs; 
Upload DX and XT/XTM checks both. If the check fails, the 
MYCONFIG dialog box appears (Figure 11-8). 

MYCONFIG

Modules do not match.
Upload will overwrite the current configuration.
OK to continue?

OK Cancel

Match  

Figure 11-8: MYCONFIG Dialog Box 
13. Select OK. The configuration appears on the screen when the 

upload is complete. 
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Troubleshooting 
Table 11-2: Downloading/Uploading Configurations Error 
Error Cause 
A download or upload fails. If the DX controller is password protected, 

while the Password feature is disabled in the 
GX Tool, the download or upload will not 
succeed. 
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Chapter 12  
Getting Started with the GX Tool 
and the DX LCD Display 

Introduction 
The DX LCD Display unit displays up to 96 data points from the 
DX controller configuration. It displays alarm data, time schedules, 
trend logs, and user defined graphics screens. The GX Tool selects 
data points and defines user text for all DX LCD Display screens. 
This chapter describes how to: 

• start the GX Tool 

• define the global data for the DX LCD Display 

• define the DX LCD Display configuration name 

• define the default configuration 

• customize the DX LCD Display main menu 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
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Key Concepts 
DX LCD Display Configuration Process 

The second use of the GX Tool is to create a configuration for a DX 
LCD Display. Figure 12-1 shows the process for configuring the DX 
LCD Display. 

Start the GX Tool. 
↓ 

Load configuration. 
↓ 

Define a User Config Code. 
↓ 

Define the Global Data for the display. 
↓ 

Define the configuration name for the display 
configuration. 

↓ 
Define the Point Database for the display. 

↓ 
Define TSn/OSn module descriptions. 

↓ 
Define Trend Data. 

↓ 
Set the default configuration. 

↓ 
Download configuration and/or Home Page to the 

display. 

Figure 12-1: DX LCD Display Configuration Process 
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DX LCD Display Menu 
The DX LCD Display menu contains all options required to define a 
configuration for the DX LCD Display. Table 12-1 describes the DX 
LCD Display menu options. 

Table 12-1: DX LCD Display Menu Options 
Menu Option Description 
Firmware Version Lists firmware Version 2.01 or Version 3.00.00 or higher. 
Global Data Edits global data that affects the operation of the display 

as a whole, such as the time-out period of the LCD 
backlight. 

Configuration Name Edits the configuration name. 
Define Default 
Configuration 

Defines a default configuration used by the DX LCD 
Display if the configurations stored in the unit do not 
match the DX controller configuration. 

Point Database Defines the points shown on the DX LCD Display. 
TSn/OSn Description 
Text 

Edits the descriptions for Time Schedule modules and 
Optimal Start/Stop modules. 

Define Trend Data Defines the Trend Data points shown on the DX LCD 
Display. 

Download Display Downloads the current configuration to the display unit. 
Read User 
Configuration Codes 

Reads the configuration codes, names, Home Page 
data, and Trend definitions of the configurations 
currently stored in the DX LCD Display unit. 

Upload Display Uploads a configuration from the display unit to the 
GX Tool. 

Update Firmware Updates Version 3.00 and higher firmware. Only 
appears if enabled in the GX9100.INI file. 
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DX LCD Display Data Entry Menu Bar 
The active DX LCD Display window changes the menu bar options. 
Table 12-2 through Table 12-5 describe the options of each menu. 

File Menu 
Table 12-2 describes the File menu options. 

Table 12-2: File Menu Options 
Menu Option Description 
New Unavailable 
Open Unavailable 
Save Saves the data in the data entry window within the 

current controller configuration in memory. 
Note: This does not save the current configuration. 

Print Prints the data in the data entry window in tabular form. 
Print Preview Displays the data in the data entry window as it will print 

on the page. 
Exit Unavailable 

 

Edit Menu 
Table 12-3 describes the Edit menu options. 
Note: You can access the Edit menu by right-clicking on a line in 

the point database table. 

Table 12-3: Edit Menu Options 
Menu Option Description 
Data Enters and/or edits the data of the currently selected 

(highlighted) line in the data entry window. 
Cut Removes the currently selected data and places it on the 

clipboard. 
Copy Copies the currently selected data to the clipboard. 
Paste Pastes the data from the clipboard into the currently 

selected line. 
Delete Deletes the currently selected data without placing it on 

the clipboard. 
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Window Menu 
Table 12-4 describes the Window menu options. 

Table 12-4: Window Menu Options 
Menu Option Description 
Cascade Arranges multiple windows on the screen in an 

overlapping stair-stepped fashion. 
Tile Arranges multiple windows on the screen in a non-

overlapping fashion. 
Arrange Arranges aligned icons (minimized windows) at the 

bottom of the screen. 

 

Help Menu 
Table 12-5 describes the Help menu options. 

Table 12-5: Help Menu Option 
Menu Option Description 
Using GX9100 Help 
Topic 

Launches a Help window with an index of GX Tool 
topics. 

Help Using Launches window containing help topics for Microsoft 
Windows Help. 

About Displays copyright and version information for the 
GX Tool. 

 

Default Display Configuration 
The DX LCD Display stores up to eight separate display 
configurations. Each configuration has a Configuration Name and a 
Configuration Code. 
When you attach the DX LCD Display to a DX controller, the display 
attempts to match one of its stored configuration codes with the 
Configuration Code defined in the DX controller’s configuration. If it 
finds a match, the DX LCD Display uses the corresponding display 
configuration. 
If the display does not find a match or the default configuration is 
disabled, a Configuration not found message appears. You 
can define a default configuration using one of the eight stored 
configurations. 
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Detailed Procedures 
Starting the GX Tool 

To start the GX Tool: 
On the Windows Start menu, click Programs > Johnson Controls > 
M-Tool > Configuration Tools > GX-9100. The GX Tool main screen 
appears. 

Defining the Global Data for the DX LCD Display 
To define the global data for the DX LCD Display: 
1. On the DX LCD Display menu, click Global Data. The DX LCD 

Display - Global Data dialog box appears (Figure 12-2). 

 

Figure 12-2: DX LCD Display - Global Data Dialog Box 
2. Complete the fields using Table 12-6. 
3. Click OK. 
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Table 12-6: Global Data Fields 
Field Description 
Passwords Enter a Level 1 password (allows the user to perform all 

functions) and a Level 2 password (only allows the user 
to perform adjust commands). Both passwords are 
4-digit numbers from 0000 to 9999. 

Password Time-out Enter the time of user inactivity after which the password 
must be re-entered. The range is from 1 to 1440 minutes 
(24 hours). Enter 0 to disable the password time out. 

LCD Backlight 
Time-out 

Enter the time of user inactivity after which the display 
panel’s backlight is automatically switched off. The range 
is from 1 to 30 minutes. 

PC Port Select the serial port that connects the display panel to 
the PC running the GX Tool. COM1 is Serial Port 1 and 
COM2 is Serial Port 2. 
Select File to save the configuration data to a file instead 
of downloading it directly to the display panel. Click 
Choose Dir. to specify folder to store downloaded files.* 

Clock Format Select the display panel to show the time in 12 or 
24 hour format. 

Device Poll Enter addresses and/or ranges to be polled, separated 
by commas. Choose to enable N2 Bus operation. 

Home Page** Choose whether all custom home pages can be 
accessed from an active configuration. 

* File name is the Configuration Code and the extension .dse (e.g., 99.dse) The 
GX Tool also creates three additional files to provide information for the emulator: 
h99.dse, common.dse, and fonts.dse. 

** The Enable Multiple Home Page Display option is intended primarily for 
monitoring a single DX that controls multiple equipment. It allows an individual 
graphic representation of up to eight items of equipment. 
If the DX LCD can connect to more than one DX controller, you must make sure 
that the source items for dynamic data in all Home Pages are configured in the 
same way in each controller. For example, if a Home Page shows "Outdoor 
Temperature" and is mapped to Item AI1, then you must configure each DX 
controller such that AI1 measures the outdoor temperature. 
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Defining the DX LCD Display Configuration Name 
To define the DX LCD Display configuration name: 
1. On the DX LCD Display menu, click Configuration Name. The 

DX LCD Display - Change/Edit Configuration Name dialog box 
appears (Figure 12-3). 

 

Figure 12-3: Configuration Name Dialog Box 
2. Enter a configuration name, using up to 16 characters. 
Note: If you have defined a Job Name, the first 16 characters 

appear as the default Configuration Name. In this case, you 
may edit or accept the name. The Job Name is unaffected by 
any changes to the Configuration Name. 

3. Click OK. 
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Defining the Default Configuration 
To define the default configuration: 
1. On the DX LCD Display menu. click Define Default 

Configuration. The Define Default Configuration dialog box 
appears (Figure 12-4). 

 

Figure 12-4: Define Default Configuration Dialog Box 
2. Select Enable Default Configuration. 
3. Select a Position Number to indicate the number configuration 

you want to set as the default. 
4. Click OK. 

Customizing the DX LCD Display Main Menu 
Note: 

Note: 

This will remove features from the main menu (for example, 
to remove functions for Original Equipment Manufacturer 
[OEM] customers). 

To customize the DX LCD Display main menu: 
1. Open the GX language file (dxmisc.lng) with an ASCII text 

editor. 
2. Copy the line you want to remove and place it below the original. 

Only lines 16068 to 16078 represent menu text. 

3. Type an asterisk in front of the original line to disable it. 
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4. Delete the menu text appearing between the quotation marks in 
the copied line (e.g., Figure 12-5 shows Optimal Start/Stop 
removed from the DX LCD Display Main Menu). 

5. Save and close the file. 

4. . 
. 
. 
* Max Allowed length 28 
16068 0 0 0 0 “Home Page” 
16069 0 0 0 0 “Point Data” 
16070 0 0 0 0 “Alarm Summary” 
16071 0 0 0 0 “Alarm Log” 
16072 0 0 0 0 “Trend Data” 
16073 0 0 0 0 “Time Schedules” 
16074 0 0 0 0 “Holidays” 
* 16075 0 0 0 0 “Optimal Start/Stop” 
16075 0 0 0 0 “” 
16076 0 0 0 0 “Time/Date” 
16077 0 0 0 0 “Password” 
16078 0 0 0 0 “Choose Controller 

Figure 12-5: Editing the DX LCD Display Main Menu 



GX-9100 Software Configuration Tool User’s Guide    13-1 

Chapter 13  
Defining the Point Database of 
the DX LCD Display 

Introduction 
The Point Database determines which points appear on the DX LCD 
Display. The Point Database contains 8 tables with 12 rows per table. 
Each table represents one Point Data screen of the display. 
This chapter describes how to: 

• add a new point to the DX LCD Display 

• edit a point in the DX LCD Display Point Database 

• delete a point from the DX LCD Display Point Database 

• copy a point in the DX LCD Display Point Database 

• move a point in the DX LCD Display Point Database 

• save the Point Database 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-120194 Software Release 7.10 
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Key Concepts 
Point Types 

You can add the following types of points to the DX LCD Display Point 
Database: 

• analog input 

• analog output 

• digital input 

• digital output 

DX LCD Display Data Points 
Table 13-1 through Table 13-5 list the DX controller items you can 
include in the DX LCD Display Point Database. You can adjust or 
override a commandable point at the DX LCD Display. 

Table 13-1: DX-9100/DX-912x/DX-9200 Hardware Points 
Tag Name Command Description 
AI1-8 No Analog Input 1-8 
DI1-8 No Digital Input 1-8 
OUT1-2 Yes Analog Output 1-2 
DO3-8 Yes Digital Output 3-8 
OUT3-8 Yes Value of Analog Source DO 3-8 
OUT9-14 Yes Analog Outputs 9-14 

 

Table 13-2: XT-9100 Hardware Points 
Tag Name Command Description 
XTnAI1-8 No XTn Analog Input 1-8 
XTnDI1-8 No XTn Digital Input 1-8 
XTnAO1-8 Yes XTn Analog Output 1-8 
XTnDO1-8 Yes XTn Digital Output 1-8 

Note: n = 1-8 
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Table 13-3: DX-912x/DX-9200 Network Inputs/Outputs 
Tag Name Command Description 
NAI1-16 Yes* Network Analog Input 1-16 
NDIm-n Yes* Network Digital Inputs 
NAO1-16 No Network Analog Output 1-16 
NDOm-n No Network Digital Outputs 

Notes: m = 1-8 (module) 
n = 1-16 (input/output) 

*  Use the Command option for testing and commissioning purposes only. During 
normal operation, the input is set by a network output of another controller on the 
network. 

 

Table 13-4: DX-9100/DX-912x/DX-9200 Internal Points 
Tag Name Command Description 
SOFF Yes Shut Off 
STUP Yes Start Up 
DIAL Yes Dial-up Flag 
CNT1-8 Yes Counter Value 1-8 
XTnCNT1-8 Yes Counter Value XTn Digital Input 1-8 
HIA1-8 Yes Value of High Limit Analog Input 1-8 
LOA1-8 Yes Value of Low Limit Analog Input 1-8 
XTnHIA1-8 Yes Value of High Limit  

XTn Analog Input 1-8 
XTnLOA1-8 Yes Value of Low Limit  

XTn Analog Input 1-8 
ADF1-8 Yes Value of Alarm Differential  

Analog Input 1-8 
AIH1-8 No High Alarm Flag Analog Input 1-8 
AIL1-8 No Low Alarm Flag Analog Input 1-8 
XTnAIH1-8 No High Alarm Flag XTn Analog Input 1-8 
XTnAIL1-8 No Low Alarm Flag XTn Analog Input 1-8 
DCO1-32 Yes Digital Constant 1-32 
ACO1-8 Yes Analog Constant 1-8 
LRS1-64 No Logic Result Status 1-64 

Note: n = 1-8 
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Table 13-5: Programmable Module Items 
Tag Name Command Description 
PMmK1-34 Yes Module Constant 1-34 
PMmOU1-8 Yes Module Output 1-8 
PMmAX1-2 Yes Auxiliary Output 1-2 
PMmCT1-8 Yes Hold Control 1-8 
PMmDO1-8 Yes Module Logic Output 1-8 
PMmS1-16 No Module Status 1-16 
PMmAC1-8 Yes Accumulator 1-8 

Note: m = 1-12 
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Detailed Procedures 
Adding a New Point to the DX LCD Display 

To add a new point to the DX LCD Display: 
1. On the DX LCD Display menu, click Point Database. The DX 

LCD Display Point Database appears (Figure 13-1). 

 

Figure 13-1: DX LCD Display Point Database Window 
2. Right-click on a row and select Data from the pop-up menu that 

appears. The Data dialog box appears (Figure 13-2). 

 

Figure 13-2: Data Dialog Box 
3. Type a Tag Name or an asterisk (*) to select a Tag Name from a 

list. Click OK and a Select point category dialog box appears 
(Figure 13-3). 

Note: If you entered a specific Tag name, the next dialog box is the 
appropriate Data dialog box. Proceed to Step 8. 
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Figure 13-3: Select Point Category Dialog Box 
4. Highlight a category and click OK. A Select subcategory dialog 

box appears (Figure 13-4). 

 

Figure 13-4: Select Subcategory Dialog Box Example 
5. Highlight a subcategory and click OK. A Select point dialog box 

appears (Figure 13-5). 
Note: Several subcategory dialog boxes may appear before you 

reach the Select point dialog box. 
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Figure 13-5: Select Point Dialog Box Example 
6. Highlight the individual point and click OK. A Data dialog box 

appears (Figure 13-6). 

 

Figure 13-6: Data Dialog Box Example 
7. Complete the Data fields using Table 13-6. 
8. Click OK. 
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Table 13-6: Fields in Point Data Dialog Boxes 
Field Description 
Tag Shows the Tag (Item) name of the point you selected. 
Description Enter a freely definable plain text description for the 

point, using up to 16 characters. The default text in the 
Description field is taken from the main configuration 
database, using the following criteria: 
1. The first 16 characters of the point description is the 

default description field text. 
2. If no description is defined for the point, but a user 

name is defined, then the user name is the default 
text. 

3. If neither a description nor user name is defined for 
the point, then the Tag name is the default text. 

You can accept or edit the default description. This does 
not effect the text defined in the main database from 
which the default was taken. 

Display Units Enter the engineering units (up to six characters) that 
are to be displayed for the point on the DX LCD Display. 
Digital points have two unit fields: one for the State 0 
units and one for the State 1 units. 
A point may have a default value in the Display Units 
field if you have already defined the point’s 
Measurement Units in the main database. You can 
accept or edit the units. This does not effect the 
Measurement Units defined in the main database. 

Alarm Select this box to define that the alarm limits of the point 
be monitored by the DX LCD Display and that an alarm 
is generated on the unit when the point value goes 
outside the limits. This option is only available for 
physical input points that have alarm limits. 
For digital points, select None, State 0, or State 1 to 
define which state generates the alarm. 

Command* Select this box to define the point commandable from 
the DX LCD Display. If this box is not selected, Minimum 
Commandable Value and Maximum Commandable 
Value are unavailable. If this box is unavailable, the point 
cannot be commanded from the DX LCD Display. 

Minimum 
Commandable Value 

Enter the minimum value the user can command from 
the DX LCD Display. The allowable range is shown in 
parentheses. 

Maximum 
Commandable Value 

Enter the maximum value the user can command from 
the DX LCD Display. The allowable range is shown in 
parentheses. 

Notes: Not all points contain all fields. If the field is not shown or is unavailable, it is 
unavailable for that point type. 
Only points defined as On/Off, Stop/Start, or Pulse should be added as a 
digital output type (i.e., included in the database via the DO3-DO8 items). 
Include the value of the analog source in the database for D.A.T. and P.A.T. 
outputs. 

*  Network Input points should be configured for Command for testing and 
commissioning purposes only. During normal operation, the input is set by a 
network output of another controller on the network. 
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Editing a Point in the DX LCD Display Point Database 
To edit a point in the DX LCD Display Point Database: 
1. On the DX LCD Display menu, click Point database. A window 

named DX LCD Display Point Database appears (Figure 13-1). 
2. Click on a point. 
3. Right-click on the selected row and select Data from the pop-up 

menu that appears. The Data dialog box appears (Figure 13-7). 

 

Figure 13-7: Data Dialog Box 
Note: 

Note: 

The originally defined Tag Name appears as the default in 
the Tag Name field. 

4. To display a different point at the selected position, enter a new 
Tag name, or type an asterisk (*) to select the new item from a 
list. If you do not want to change the point, click OK without 
editing the Tag Name field. 

5. Highlight a subcategory and click OK. A Select point dialog box 
appears (Figure 13-5). 

Several subcategory dialog boxes may appear before you 
reach the Select point dialog box. 

6. Highlight the individual point and click OK. A Data dialog box 
appears (Figure 13-6). 

7. Complete the Data fields using Table 13-6. 
8. Click OK. 

Deleting a Point from the DX LCD Display Point Database 
To delete a point from the DX LCD Display Point Database: 
1. Right-click on a point. To select multiple points, hold down Ctrl 

and click. 
2. Select Delete from the pop-up menu that appears. A GX9100 

dialog box appears (Figure 13-8) to confirm deletion. 
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Figure 13-8: GX9100 Confirm Deletion Dialog Box 
3. Click Yes. 

Copying a Point in the DX LCD Display Point Database 
To copy a point in the DX LCD Display Point database: 
1. Right-click point. To select multiple points, hold down Ctrl and 

click points. 
2. Select Copy from the pop-up menu that appears. 
3. Click to highlight the destination row. If you are copying multiple 

points, the row you select marks the starting position to insert all 
rows. 

4. Right-click on the highlighted row, and select Paste from the 
pop-up menu that appears. 

Notes: A deletion confirmation warning message appears before 
overwriting an existing point. 
A confirmation warning message also appears if there are too 
few rows available in the database. Points extending beyond 
Screen 8 are not pasted, but remain on the clipboard. 

5. Edit the pasted point data, as required. 

Moving a Point in the DX LCD Display Point Database 
To move a point in the DX LCD Display Point Database: 
1. Click to highlight the point you want to move. 
2. Right-click on the point and select cut from the pop-up menu. 

The point is removed from the table. 
3. Click to highlight the destination row. If you are copying multiple 

points, the row you select marks the starting position to insert all 
rows. 
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4. Right-click on the highlighted row, and select Paste from the 
pop-up menu that appears. 

Notes: 

Note: 

A deletion confirmation warning message appears before 
overwriting an existing point. 
A confirmation warning message also appears if there are too 
few rows available in the database. Points extending beyond 
Screen 8 are not pasted, but remain on the clipboard. 

5. Edit the pasted point data, as required. 

Saving the Point Database 
To save the Point Database, on the File menu, click Save. 

Saving the Point Database only saves within the current 
configuration; it does not save the configuration to the disk. 
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Chapter 14  
Defining Time Schedule and 
Optimal Start/Stop Module 
Descriptions in the DX LCD 
Display 

Introduction 
Time Schedule (TSn, where n=1-8) and Optimal Start/Stop 
(OSn, where n=1-2) module descriptions are displayed on the 
DX LCD Display. 
This chapter describes how to: 

• edit a TSn/OSn module description 

• delete a TSn/OSn module description 

• save the TSn/OSn module descriptions 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-120195 Software Release 7.10 
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Key Concepts 
TSn/OSn Description Text Window 

The TSn/OSn Description Text window (Figure 14-1) contains 
one table for the Time Schedule modules and another for the Optimal 
Start/Stop modules. Default descriptions appear in the Description 
field for each module, taken from the main configuration database 
using the following criteria: 

• If a description is defined for the module in the main database, the 
first 16 characters are shown as the default. 

• If no description is defined for the module, but a user name is 
defined, the user name is shown as the default. 

• If neither a description nor a user name is defined for the module, 
then the Tag Name is shown as the default. 

Changes to the TSn/OSn description text do not affect the main 
database. 

 

Figure 14-1: TSn/OSn Description Text Window 
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Detailed Procedures 
Editing a TSn/OSn Module Description 

To edit a TSn/OSn module description: 
1. On the DX LCD Display menu, click TSn/OSn Descriptive Text. 

The DX LCD Display TSn/OSn Description Text window appears 
(Figure 14-1). 

2. Click to highlight the module row you want to edit. 
3. Right-click the selected row and select Data from the pop-up 

menu that appears. A Time Schedule Module Description TS1 
dialog box appears (Figure 14-2). 

 

Figure 14-2: Time Schedule Description Dialog Box 
4. Type the module description, using up to 16 characters, in the 

Description field, or accept the default description. 
5. Click OK. 

Deleting a TSn/OSn Module Description 
To delete a TSn/OSn module description: 
1. On the DX LCD Display menu, click TSn/OSn Descriptive Text. 

The DX LCD Display TSn/OSn Description text window appears 
(Figure 14-1). 

2. Right-click selected modules, to select multiple points, hold down 
Ctrl and click points. Select Delete from the pop-up menu that 
appears. A GX9100 dialog box appears to confirm deletion 
(Figure 14-3). 
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Figure 14-3: Confirm Deletion Dialog Box 
3. Click Yes. 

Saving the TSn/OSn Module Descriptions 
To save the TSn/OSn module descriptions, on the File menu, click 
Save. 
Note: Saving the TSn/OSn Module descriptions only saves within 

the current configuration; it does not save the configuration 
to the disk. 
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Chapter 15  
Defining Trend Data Descriptions 
in the DX LCD Display 

Introduction 
The Trend Log module provides Metasys Point History data for 
remotely connected DX controllers or for a local DX LCD Display. 
The module provides 12 trend log channels, each records data from 
either 1 analog item or from a set of 8 logical variables (logic variable 
byte). 
This chapter describes how to: 

• edit a group description in the Trend Data window 

• save the Trend Data definitions 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-120196 Software Release 7.10 
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Key Concepts 
Trend Data Window 

The DX LCD Display Trend Data window contains a table showing 
the points from the Trend Log module in the controller configuration 
(Figure 15-1). The item (Tag) names shown are the Items for which 
the DX is configured to store trend data. 
Note: Saving the Trend Data definitions only saves within the 

current configuration; it does not save the configuration to 
the hard disk. 

 

Figure 15-1: DX LCD Display Trend Data Window Example 
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Digital Trend Data 
Digital items (i.e., a logic variable byte) appear as a group reference 
(e.g., DI1..8). 
The DX LCD Display Digital Trend Data dialog box shows the DX 
trend number, Tag names, description, and the eight individual digital 
items of the group (Figure 15-2). For each item, the description and 
units (State 0 and State 1 names) are taken from the DX LCD Display 
Point Database. The bit number is description of an undefined point 
and 1 and 0 for the units. You can define a 16-character description in 
the Description field. 
For groups of digital items, the default description is the group 
reference (e.g., DI1..8) and units do not apply. You can edit the 
description of the group in the Trend Data window. 

 

Figure 15-2: Digital Trend Data Dialog Box 
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Analog Trend Data 
Analog descriptions and units are taken from the DX LCD Display 
Point Database. If the point is undefined, the Tag name is used for the 
description and there are no units. If you add the point to the Point 
Database later and then reopen the Trend Data window, the point’s 
description and units synchronize to the Point Database. 
The DX LCD Display Analog Trend Data dialog box shows the DX 
Trend number, Tag name, Description, and Units as static text  
(Figure 15-3). You cannot change these values using the dialog box. 
The Data Range is –32768 to +32768. 

 

Figure 15-3: Analog Trend Data Dialog Box 
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Detailed Procedures 
Editing a Group Description in the Trend Data Window 

To edit a group description in the Trend Data window: 
1. On the DX LCD Display menu, click Trend Data. The DX LCD 

Display – Trend Data window appears (Figure 15-1). 
2. Right-click on the row that contains the point that you want to edit 

and select Data from the pop-up menu that appears. A DX LCD 
Display Digital Trend Data dialog box or an Analog Trend Data 
dialog box appears depending on the point you selected  
(Figure 15-2 or Figure 15-3). 

3. For an analog point, enter a Display Range between –32768 to 
+32768. 
For a digital point, type the group description into the Description 
field, using up to 16 characters, or accept the default description. 

4. Click OK to save the description. 

Saving the Trend Data Definitions 
To save the Trend Data definitions, on the File menu, click Save. 
Note: Saving the Trend Data definitions only saves within the 

current configuration, it does not save the configuration to 
the hard disk. 
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Chapter 16  
Downloading and Uploading the 
DX LCD Display 

Introduction 
The DX LCD Display stores up to eight configurations and Home 
Pages. The PC running GX Tool downloads and uploads 
configurations and Home Pages through the serial port to the DX LCD 
Display. 
This chapter describes how to: 

• download a configuration/Home Page to the DX LCD Display 

• display the configuration codes in the display unit 

• upload a configuration/Home Page from the DX LCD Display 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-120197 Software Release 7.10 
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Key Concepts 
Display Configurations and Home Pages 

Up to eight separate display configurations can be stored in the DX 
LCD Display. Storing a configuration is accomplished by 
downloading the configuration from the GX Tool to the display 
through the serial port to which it is connected. 
You can also download up to eight different Home Pages to the 
display. The Home Pages are customizable (see Appendix B: Custom 
Home Page) and can display live point data from the DX controller. 
Home Page definitions are stored in separate files that have a file name 
extension of .hpg. When you open a configuration file in the GX Tool, 
it automatically looks for a Home Page file with the same name as the 
configuration file but with the .hpg extension. For example, if you 
open a configuration file named config1.dxs, the tool automatically 
opens the Home Page file named config1.hpg. 
Note: The GX Tool downloads a default Home Page (named 

default.hpg) to the DX LCD Display if it cannot find a 
custom Home Page with the same name as the open 
configuration file. 
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Detailed Procedures 
Downloading a Configuration/Home Page to the DX LCD Display 

To download a configuration/Home Page to the DX LCD Display: 
1. On the File menu, click Open. The File Open dialog box appears 

(Figure 16-1). 

 

Figure 16-1: File Open Dialog Box 
2. Select the configuration file to open and click OK. 
3. On the DX LCD Display menu, click Download Display. The DX 

LCD Display-Download dialog box appears (Figure 16-2). 
Notes: An error message appears if you have not specified the PC 

port to which the display unit is connected in the DX LCD 
Display Global Data dialog box. 
An error message appears if you have specified the PC port, 
but the configuration tool cannot detect a display panel 
connected to the port. Check that the panel is properly 
connected to the correct port as described in the Software 
Details and Hardware Connections chapter. 
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DX LCD Display-Download

Point Database Home Page

Download in Position

1      2      3      4  5      6      7      8

OK Cancel

gx91t_34 

Figure 16-2: DX LCD Display Download Dialog Box 
4. Select the download options using Table 16-1. 

Table 16-1: Download Options 
Option Description 
Point Database Downloads the configuration data to the DX LCD 

Display. 
Home Page Downloads the Home Page data to the DX LCD 

Display. 
Download in Position Selects the DX LCD Display storage location to 

download the configuration and/or Home Page. 
Note: The default selection is the next available, free position in the display unit. 
 
5. Click OK to begin the download operation. 
Note: If you are downloading a Home Page file, the GX Tool 

performs a Home Page Definition File syntax check. If the 
check fails, the Home Page Definition File Syntax Check 
dialog box appears (Figure 16-3). Click OK to ignore the 
errors or click View Error Listing button to open a window 
listing errors and warnings. 

Home Page Definition File Syntax Check

2 Error(s),  1 Warning(s)

OK

View Error Listing

gx91t_35  

Figure 16-3: Syntax Check Results Dialog Box 
When the download operation is complete, a GX9100 dialog box 
appears indicating successful download (Figure 16-4). 
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GX9100

Download Complete

OK

gx91t_36  

Figure 16-4: Download Complete Dialog Box 

Displaying the Configuration Codes in the Display Unit 
To display the configuration codes in the display unit: 
1. On the DX LCD Display menu, click Read Configuration Codes. 

The DX LCD Display - User Configuration Codes dialog box 
appears (Figure 16-5). 

Note: An error message appears if you have not specified the PC 
port as part of the Global Data or if the GX Tool cannot 
detect a display panel attached to the port. 

DX LCD Display - User Configuration Codes

POSITION

1 1 Chiller Plant Custom Defined

CODE CONFIGURATION NAME HOME PAGE TREND

2 2 Boiler Plant Default

3

4

5

6

7

8 65535 System (Default) Default Not Defined

OK

gx91t_38 

Figure 16-5: User Configuration Codes Dialog Box 
2. Click OK. 
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Uploading a Configuration/Home Page from the DX LCD Display 
To upload a configuration/Home Page from the DX LCD Display: 
1. On the File menu, click New to create a new DX controller 

configuration file. 
2. On the DX LCD Display menu, click Upload Display. The 

DX LCD Display Upload dialog box appears (Figure 16-6). 
Notes: An error message appears if you have not specified the PC 

port to which the display unit is connected in the DX LCD 
Display Global Data dialog box. 
An error message appears if you have specified the PC Port, 
but the configuration tool cannot detect a display panel 
connected to the port. Check that the panel is properly 
connected to the correct port as described in the Software 
Details and Hardware Connections chapter. 

DX LCD Display - Upload

CancelOK

Upload from Position

5 6 7 81 2 3 4

Point Database Home Page

ctgxmen5 

Figure 16-6: DX LCD Display Upload Dialog Box 
3. Select the upload options using Table 16-2. 

Table 16-2: Upload Options 
Option Description 
Point Database Uploads the configuration data to the DX LCD 

Display. 
Home Page Uploads the Home Page data to the DX LCD Display. 
Download in Position Selects the DX LCD Display storage location from 

which to upload the configuration and/or Home Page. 

 
4. Click OK. A GX9100 dialog box appears warning of 

configuration overwrite. 
5. Click OK. When the upload operation is complete, a GX9100 

dialog box appears (Figure 16-7). 
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GX9100

Upload Complete

OK

ctgxmen6  

Figure 16-7: Upload Complete Dialog Box 
6. On the File menu, click Save. 
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Appendix A  
Source and Destination Points 

Introduction 
Module inputs and outputs are shown in the GX Tool as abbreviations 
(for example: ALD@ is disable alarm). This appendix lists 
abbreviations and descriptions for: 

• source points 

• destination points 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-120198 Software Release 7.10 
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Key Concepts 
Note: The variable n is the module number and m is the Item 

number in a module. 

Source Points 
ACOn The current value of an analog constant set by a BAS, 

the GX Tool, SX Tool, or on the DX front panel. 
AFB A 1 when the DO P.A.T. associated feedback value is 

not responding to changes in the DO P.A.T. command 
value. 

AIn The current value of the analog input. 
AI%n The current value of the analog input in percent (%) of 

range. 
AIHn A 1 if the analog input is above its high limit and not 

below the high limit - limit differential. 
AILn A 1 if the analog input is below the low limit and not 

above the low limit + limit differential. 
AOFn A 1 when an analog output is being externally forced. 
AOHn A 1 when the analog output is equal to or above its high 

range. 
AOLn A 1 when the analog output is equal to or below its low 

range. 
BATLOW A 1 when the DX lithium battery needs to be replaced. 
DCOn The current value of a digital constant set by a BAS, 

the GX Tool, SX Tool, or on the DX front panel. 
DIn The current status of the digital input. 
DIAL When set to 1 by a set statement in the PLC, this causes 

the N2 Dialer to connect the N2 Bus to a BAS via 
telephone lines. The DIAL bit will be reset to 0 by the 
BAS when the telephone line connection is successful. 

DICn Toggles from 0 to 1 or 1 to 0 when the number of 
digital input transitions (counts) equals the prescaler. 

DOn The status of the digital output. 
DOnC A 1 when the BAS has commanded the digital output to 

be On. 
DOnE A 1 when the BAS has taken control of the digital 

output. 
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DOFn A 1 when the digital output P.A.T. or D.A.T. is being 
externally forced. 

DOHn A 1 when the digital output P.A.T. or D.A.T. is at its 
defined high limit. 

DOLn A 1 when the digital output P.A.T. or D.A.T. is at its 
defined low limit. 

HTRR Historical Trend Read Request. A 1 when any trend log 
buffer has reached its Read Request limit. 

LRSn The logic result status of an OUT, OUTNOT, SET, or 
RST statement in a PLC. (Refer to the PLC code to 
determine which number to use.) 

NAIn The analog numeric value that is received over the 
LONWORKS N2 Network. 

NDIn-m The digital value that is received over the LONWORKS 
N2 Network. 

NAIUn A 1 when the network analog shared value is no longer 
receiving data from the LONWORKS N2 Network. 

NDIUn A 1 when the network digital shared value is no longer 
receiving data from the LONWORKS N2 Network. 

OSnHEAT A 1 when Optimal Start module is in the Heating mode. 
OSnOUT A 1 when the Optimal Start module requires equipment 

to be On. It is the controlling output of an Optimal Start 
module to START/STOP heating or cooling equipment. 

OSnPRE A 1 while the Optimal Start module is in the 
Pre-conditioning mode (will turn Off at occupancy). 

OSnSTO A 1 when the Optimal Start module is in the Optimal 
Stop mode (will turn Off at vacancy - unoccupancy). 

OUHn A 1 when an analog or digital output is in Hold mode 
from either the DX front panel or BAS. 

OULn A 1 when the INC and DEC connections are both On in 
an analog output module (including P.A.T. or D.A.T.) 
and the output is locked. 

OUTn The value of the analog output (including P.A.T. or 
D.A.T.). 

OVRn A 1 when the value of the analog input is more than 5% 
above its normal range (overrange condition). 
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PMnCMH A 1 when a control module’s output is equal to its 
output high limit. 

PMnCML A 1 when a control module’s output is equal to its 
output low limit. 

PMnCMP A 1 when the control module’s Working Setpoint 
(WSP) is being overridden by a BAS (Computer mode). 

PMnDISm A 1 when the output stage is disabled in a sequencer 
module. 

PMnEF A 1 when this control module is being externally 
forced. 

PMnFSSm A 1 when the totalized value of a totalization module is 
equal to the full scale limit of the channel. 

PMnHDA A 1 when the difference Process Variable (PV) - WSP 
is larger than the high deviation alarm value. 

PMnHEAT A 1 when, in a symmetric control module, the PV is 
below the center of the symmetry band and a 0 when 
above center; or a 1 when, in a dual control module, 
Loop 1 is active. 

PMnHHDA A 1 when the difference PV - WSP is larger than the 
high high deviation alarm value. 

PMnHLD A 1 when the program module is in the Hold mode, 
being overridden by the SX Tool or a BAS. 

PMnHLDm A 1 when the channel of the program module has been 
overridden (in hold) from an SX service module or a 
BAS. 

PMnLDA A 1 when the difference WSP - PV is larger than the 
low deviation alarm value. 

PMnLLDA A 1 when the difference WSP - PV is larger than the 
low low deviation alarm value. 

PMnLSm A 1 when the comparator module channel is at its 
comparison true logic state. 

PMnLSP The value of the local setpoint. (This value is changed 
when adjusting the WSP from the DX front panel.) 

PMnLSP1 The value of the local setpoint of Loop 1 of a dual 
control module. (This value is directly changed when 
adjusting the WSP1 from the DX front panel.) 

PMnLSP2 The value of the local setpoint of Loop 2 of a dual 
control module. (This value is changed when adjusting 
the WSP2 from the DX front panel.) 
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PMnMCSm A 1 as long as the maximum cycles status timer for an 
output stage is active. 

PMnMNWS The value of the minimum working setpoint allowed for 
a control module. 

PMnMXWS The value of the maximum working setpoint allowed for 
a control module. 

PMnNCM The calculation result of a numeric module. 
PMnNCMm The calculation result of a channel of a numeric 

module. 
PMnNMH A 1 when the calculated output is equal to or greater 

than the numeric module high limit. 
PMnNMHm A 1 when the psychrometric numeric module output is 

equal to or greater than the high limit of the channel. 
PMnNML A 1 when the calculated output is less than or equal to 

the numeric module low limit. 
PMnNMLm A 1 when the psychrometric numeric module output is 

less than or equal to the low limit of the channel. 
PMnOCM The value of the PID control module output in percent; 

either a 1 or 0 for an On/Off control module. 
PMnOUT The analog value of the requested output load % 

(percent) of a sequencer. 
PMnOUTD The output difference between the required load minus 

the sum of the loads of stages that are On in a 
Sequencer mode. This can be used for Vernier control. 

PMnOUTS The analog value of the output sum of the loads of 
stages that are On in an sequencer module. 

PMnSOF A 1 when this control module is in the Shutoff mode, 
which occurs when enable shutoff = 1 and the BAS has 
commanded it On. 

PMnSTA A 1 when this control module is in the Startup mode, 
which occurs when enable startup = 1 and the BAS has 
commanded it On. 

PMnSTOm A 1 when the staged output of a sequencer module is 
requested to be On. 

PMnTDOm A 1 when the numeric timer channel output is On. 
PMnTIMm The numeric timer module timer value of each channel. 

It is 0 when the channel is not triggered or the timer has 
expired; or it is the number of seconds (or minutes, or 
hours) left as the timer decrements. 
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PMnTOTm The totalized value of a totalization module channel; 
the number of events, runtime, or integration value. 

PMnWSP The value of a control module working setpoint. 
PMnWSP1 The value of the working setpoint of Loop 1 of a dual 

control module. 
PMnWSP2 The value of the working setpoint of Loop 2 of a dual 

control module. 
SLF A 0 when BAS is active and returns to a 1 sixty seconds 

after receiving the last command from the BAS. 
SOFF A 1 when the BAS has commanded the Shutoff mode. 
SSA A 1 when the BAS is active and returns to 0 two hours 

after the last command from the BAS. 
STUP A 1 when the BAS has commanded the Startup mode. 
TSnEXS A 1 when a time schedule module has its extension 

enabled by a BAS or a DX front panel command. 
TSnOUT A 1 when the real time is currently between the start 

and stop times of an event of the time schedule module 
and the current day is specified for that event. 

UNRn A 1 when the value of the analog input is more than 5% 
below its normal range (underrange condition). 

XTnAIm The current value of the analog input from the XT. 
XTnAIHm A 1 if the analog input is above its high limit and not 

below the high limit - limit differential. 
XTnAILm A 1 if the analog input is below the low limit and not 

above the low limit + limit differential. 
XTnAOm The value of the analog output to the XT. 
XTnCOM A 1 when the extension module is not communicating 

(wrong address, bus line broken, or bus line overload). 
XTnDIm The current status of the digital input from the XT. 
XTnDOn The status of the digital output to the XT. 
XTnERR  A 1 when the XT database in the DX does not match 

the XT database in the expansion module, when 
XTnCOM is a 1, or when XTnHARD is a 1 (Versions 
1.4, 2.3, 3.3 or later). (Combination of errors for 
XT/XTM module, i.e., configuring an XP-9102 and 
connecting an XP-9103 yields an error). 

XTnHARD A 1 when the expansion module is not connected or not 
responding (hardware fault). 
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XTnOUHm A 1 when an analog or digital output is in Hold mode 
from either the DX front panel or BAS. 

XTnPWR  A 1 when the extension module detects a loss of power 
or loss of communication. The DX will reset this after a 
few seconds. 

Destination Points 
ALD@ The connection to disable alarm processing on analog 

inputs AI1-AI8. 
AO@ The numeric connection to control an analog output. 
AOF@ The connection to force an analog output to a specified 

value. 
DEC@ The connection to decrement an analog type output or 

sequencer module. While connection is a logic 1, the 
output will decrease at a rate dependent on the type of 
module. 

DISn@ A connection in a sequencer to disable the 
corresponding stage or set number. 

DO@ The connection to control a digital output. 
DOF@ The connection for forcing a digital output to a 

specified value. 
EF@ The connection to the external forcing point of control 

modules. 
ENL@ The connection to enable output limits of an analog 

type output (P.A.T. and D.A.T. included). 
FB@ The connection to the feedback of a P.A.T.. Usually a 

signal from a potentiometer on the controlled device. 
FST@ The connection to set the sequencer module into fast 

step down mode. 
In@ Analog input connections to a programmable module. 
INC@ The connection to increment an analog type output or 

sequencer module. While connection is a logic 1, the 
output will increase at a rate dependent on the type of 
module. 

MNWS@ The connection to the minimum working setpoint of a 
control module. The WSP cannot be adjusted below 
this value. 

MXWS@ The connection to the maximum working setpoint of a 
control module. The WSP cannot be adjusted above this 
value. 
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NAOn@ The numeric source of a Network Analog Output that is 
shared over the LONWORKS N2 Network. 

NDOn-m@ The digital source of a Network Digital Output that is 
shared over the LONWORKS N2 Network. 

OB@ The connection of an output bias value of a PID 
module. 

OB1@ The connection for Loop 1 of a dual PID output bias. 
OB2@ The connection for the Loop 2 of a dual PID output 

bias. 
OF@ The connection to the Off mode source point of a 

control module. 
OSnDA@ The connection to disable the adaptive action of an 

Optimal Start/Stop module. 
OSnDI@ The connection to disable the Optimal Start/Stop 

module. 
OSnOB@ The connection to the Off Setpoint Bias, which replaces 

the entered value when connected in an Optimal 
Start/Stop module. 

OSnOT@ The connection for the Outdoor Air Temperature sensor 
of an Optimal Start/Stop module. 

OSnSP@ The connection for the Optimal Start Zone Temperature 
setpoint. If connected, it replaces the entered setpoint. 

OSnTS@ The connection in an Optimal Start/Stop module for the 
time schedule that determines when the building is 
occupied. 

OSnZT@ The connection for the Zone Temperature sensor in an 
Optimal Start/Stop module. 

PB@ The connection to proportional band, which replaces 
the value PB if there is a connection. 

PV@ The connection to the process variable of a PID or an 
On/Off. 

RA@ The connection to the reverse action point of a control 
module. 

RHn@  The relative humidity sensor connections for 
psychrometric calculations. 

RS@ The connection to a remote setpoint, which is used in 
the calculation for the working setpoint. 
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RSn@ The connection to the reset function of a totalization 
module channel (to reset to 0 and re-start) or timer 
module channel (to reset the output). 

RS1@ The connection for Loop 1 of a dual PID or On/Off 
remote setpoint. 

RS2@ The connection for Loop 2 of a dual PID or On/Off 
remote setpoint. 

RV@ The connection to reference variable, which is a 
multiplier in the calculation for the working setpoint. 

RV1@ The connection for Loop 1 of a dual PID or On/Off 
reference variable. 

RV2@ The connection for Loop 2 of a dual PID or On/Off 
reference variable. 

SB@ The connection to the stand by source point of a control 
module. 

SPn@ A setpoint connection for a comparator channel if a 
remote setpoint is desired; otherwise the entered value 
for the setpoint will be used. 

TMn@ The temperature sensor connections for psychrometric 
calculations. 

TSnOF@ A connection to externally force the output of a time 
schedule to Off. 

TSnON@ A connection to externally force the output of a time 
schedule to On. 

TSnEX@ A connection to the external extension override of a 
time schedule. 
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Appendix B  
Custom Home Page 

Introduction 
The Home Page is a graphic display of important parameters. The 
GX Tool reads the Home Page definition file (*.hpg) and downloads 
the required bitmaps (*.bmp). 
This chapter describes: 

• default Home Page 

• Home Page definition file 

• Home Page content 

• tokens 

• statements 

• example Home Page 

• Home Page errors 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-120199 Software Release 7.10 
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Key Concepts 
Default Home Page 

When you open a configuration file in the GX Tool, it automatically 
looks for a Home Page file with the same name as the configuration 
file. For example, if you open a configuration file named config1.dxs, 
the tool automatically opens the Home Page file named config1.hpg. 
The GX Tool downloads a default Home Page (Figure B-1), named 
default.hpg, to the DX LCD Display if it cannot find a custom Home 
Page with the same name as the configuration file. 

hh:mm

 

Figure B-1: Default Home Page 

Home Page Definition File 
The Home Page is defined as an ASCII file format with references to 
bitmap files. The DX LCD Display can store up to eight different 
Home Pages. 
Use any standard ASCII text editor to create the Home Page definition 
file. Give the file the same name as the associated DX configuration 
file but use a .hpg file name extension. Use any standard paint program 
to create monochromic Windows bitmap files. 
When you load the Home Page file, the GX Tool performs a syntax 
check and lists any errors or warnings found in the file. Refer to  
Figure B-2 for an example of a Home Page definition file. Refer to 
Table B-4 for a list of syntax errors. 
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Home Page Content 
You have complete control over the contents of the Home Page. Apart 
from referencing user-created bitmaps, the Home Page can also 
reference standard bar graph symbols available in the DX LCD 
Display. You can associate analog and digital items with the graphs. 

Text 
Home Pages can contain dynamic text for numeric items. For example, 
use dynamic text with analog items such as AI1, clock time, etc.  
Table B-1 lists Home Page text sizes. 

Table B-1: Home Page Text Sizes 
Size Width (pixels) Height (pixels) 
Small 6 8 
Medium 12 16 
Large 24 32 

Note: When you load a Home Page file, the GX Tool verifies the text does not 
exceed the limits of the LCD (240 pixels wide by 128 pixels high). 

 

Static Bitmaps 
Static bitmaps are typically used as the background of the Home Page. 
Labels, units, and any other static text can be a part of the static 
bitmap. The file is referenced in the Home Page definition file. Refer 
to the Statements section for information on referencing bitmaps. 

Dynamic Bitmaps 
Dynamic bitmaps are associated with digital items. Different bitmaps 
are associated with State 0 and State 1. Use this feature to display 
changing images that represent the states of the digital item. You 
create the State 0 and State 1 bitmaps, so you have complete control 
over their appearance. 

Bar Graph 
A bar graph can be linked to an analog item. Specify the values of the 
analog source for 0% and 100%. The bar size changes, as the input 
changes from 0% to 100%. 

Alarm Line 
The alarm line displays the most recent alarm and the total number of 
alarms in the small font size on any line of the Home Page. 
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Clock 
The clock displays the current time in 12-hour (hh:mm a/p) or 
24-hour (hh:mm) format in the small, medium, or large font size on 
the Home Page. 

Tokens 
Tokens, shown in angle brackets (<>), are placeholders in the 
statement rules. Replace tokens with values. Table B-2 lists tokens. 
Table B-3 lists the special characters that can be used in the definition 
file. 

Table B-2: Tokens 
Token Values Description 
<row> 1 to 128 Pixel row of display 
<col> 1 to 240 Pixel column of display 
<bmp top l row/col> 1 to 65535 Top left row/column offset of 

image in bitmap file 
<bmp bot r row/col> 1 to 65535 Bottom right row/column offset of 

image in bitmap file 
<height> 1 to 128 Height in pixels 
<width> 1 to 240 Width in pixels 
<font_size> small 

medium 
large 

6 x 8 pixel font 
12 x 16 pixel font 
24 x 32 pixel font 

<orientation> horizontal 
vertical 

Bar graph orientation 

<show status> status 
no_status 

Specifies whether to display the 
analog item status. 

<12_24_format> 12 to 24 12- to 24-hour time format 
<name>  String enclosed in double quotes 

Example: “MASP” 

 

Table B-3: Special Characters 
Character Description 
carriage return Delimiter for each line 
\ Used for continuation of any line. 
* Placed at beginning of line for single line comment 

(multiple line comments are not allowed). 
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Statements 
Statements place elements on the Home Page. For static backgrounds 
and digital items, where you specify a bitmap file name, you must also 
specify the offset of the image within the bitmap file. Use this to store 
all of the Home Page images in one bitmap file and refer to different 
images in the file by specifying their coordinates. 
The following examples show Home Page syntax. 

Begin Home Page Definition 
BEGIN_HOMEPAGE  <name> 

The <name> serves only as an identifier for the Home Page definition 
and is not downloaded to the DX LCD Display. 

End Home Page Definition 
END_HOMEPAGE 

Static Bitmap 
<row> <col> STATIC \ 
<bmp top l row> <bmp top l col> \ 
<bmp bot r row> <bmp bot r col> <bitmap file> 

The bitmap must be monochromic. 

Analog Item 

<row><col>ANALOG<font size> \ 
<no of digits after decimal point>\  
<show status><item tag> 

Digital Item 
<row> <col> DIGITAL \ 
<bmp top l row> <bmp top l col> \ 
<bmp bot r row> <bmp bot r col> <bitmap file for off> \ 
<bmp top l row> <bmp top l col> \ 
<bmp bot r row> <bmp bot r col> <bitmap file for on> \ 
<bmp top l row> <bmp top l col> \ 
<bmp bot r row> <bmp bot r col> \ 
<bitmap file for override off> \ 
<bmp top l row> <bmp top l col> \ 
<bmp bot r row> <bmp bot r col> \ 
<bitmap file for override on> <item tag>\ 

The OFF (State 0) and ON (State 1) bitmaps must be the same size. 
Similarly, the override OFF and override ON bitmaps must be the 
same size. If an override OFF bitmap is specified, an override ON 
bitmap is also required. 
For digital input type items, you do not have to specify bitmap files for 
override OFF and override ON (i.e., you can omit them from the 
DIGITAL statement). 
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For digital output type items, you must specify override OFF and 
override ON bitmap files. They can, however, be the same bitmaps as 
the normal OFF and ON bitmaps. The override bitmaps display at the 
same position as the OFF and ON bitmaps (i.e., they replace them on 
the display). 

Alarm Line 
<row> ALARM_LINE 

The ALARM_LINE begins at the first column and is eight pixels high. 
Only one alarm line is allowed on a Home Page. The row for the alarm 
line must be a multiple of eight. 

Bar Graph 
<row> <col> BARGRAPH <width> <height> \ <orientation> 
<src val for 0%> \  
<src val for 100%> <item tag> 

A rectangle is drawn around the bar graph by leaving a one pixel gap 
on each side to indicate the bar graph’s boundary. 

Clock 
<row> <col> CLOCK <font_size> <12_24_format> 

For 12-hour format, the clock occupies six characters (hh:mm a/p) and 
for 24-hour format, it occupies five characters (hh:mm) of the size 
defined by <font_size>. 
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Example Home Page 
The Home Page definition file (Figure B-2) defines the custom Home 
Page (Figure B-3). 

** put all rectangles, units, and fixed text in the static bitmap 
* 
BEGIN_HOMEPAGE “plant1” 
0 0 STATIC 2 2 129 241 “plant1.bmp” 
10 10 ANALOG LARGE 0 NO_STATUS AI1 
10 130 ANALOG LARGE 0 NO_STATUS AI2 
72 170 DIGITAL 140 2 147 13 “plant1.bmp” 150 2 157 13 “plant1.bmp” DI1 
80 170 DIGITAL 140 2 147 13 “plant1.bmp” 150 2 157 13 “plant1.bmp” DI2 
88 170 DIGITAL 140 2 147 13 “plant1.bmp” 150 2 157 13 “plant1.bmp” DI3 
96 170 DIGITAL 140 2 147 13 “plant1.bmp” 150 2 157 13 “plant1.bmp” DI4 
104 170 DIGITAL 140 2 147 13 “plant1.bmp” 150 2 157 13 “plant1.bmp” DI5 
END_HOMEPAGE 

Figure B-2: Home Page Definition File 

22 c 50%RH
FAN = ON
COOLING = ON
HEATING = OFF
HUMIDIFIER = OFF
DEHUM. = OFF

 

Figure B-3: Home Page Example 
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Home Page Errors 

Table B-4: Home Page Definition Errors 
Error Message Syntax Check Message Solution 
Bitmap File Type Error Line :6 Bitmap Error, 

only monochromic bitmaps 
are supported. 

Reopen the bitmap file in Paint. Change Save As 
type to monochromic bitmap and resave. 

Bitmap file not 
found 

Error Line :6 Bitmap file not 
found. 

The Home Page file (*.hpg) references a bitmap file 
(*.bmp) that is not located in the same directory. 
Locate bitmap file in the same directory as the 
Home Page file. 

Bitmap dimension 
mismatch, Bitmap 
is smaller than 
that specified 

Error Line :6 Bitmap is 
smaller than that specified. 

Increase the bitmap file size to match the Home 
Page definition. The bitmap file can be larger than 
what is defined without producing an error. The 
DX LCD Display unit displays only what appears in 
the area up to 240 pixels wide by 128 pixels high. 

Multiple alarm 
lines 

Error Line :42 Multiple 
alarm lines not allowed. 

Delete all but one alarm line. 

Overlapping area Error Line :42 Overlap 
error, at least two areas 
overlap, dynamic data 
items, Digital, Analog 

The overlapping items could be analog or digital. To 
determine overlapping areas, open the static bitmap 
file, and locate the dynamic item referenced in the 
error line. Locate other dynamic items near the 
referenced item. Check the coordinates from the 
definition of the items in the Home Page file 
(coordinate refers to location of the upper left corner 
of the dynamic item and its font size). Relocate the 
referenced item, so it does not contact another item. 

Statement type not 
recognized 

Error Line :33 Statement 
type not recognized. DO, 
DI, Digital 

Digital items typically use backslash ( \ ) as part of 
the definition. Verify backslash used for line 
continuation includes space before special 
character. 
Example: 90 160 DIGITAL \  
 141 22 151 63 “DX-22.BMP” \ 
 129 22 139 63 “DX-22.BMP” \ 
 DO3 

Not enough space 
to show ANALOG 
item 

Warning Line :11 Not 
enough space to show 
ANALOG item 

Dynamic Analog item is overlapping an area of the 
static bitmap that contains an image. Relocate the 
Analog item. To determine the overlapping area, 
open the static bitmap file, and locate the analog 
item referenced in the Error line. Locate the static 
image (i.e., labels units, text, etc.) near the analog 
item. Check the coordinates from the definition of 
the analog item in the Home Page file (coordinate 
refers to location of the upper left corner of the 
dynamic item and its font size). 

Number of 
Parameters not 
correct for type 
DIGITAL 

Error Line :30 Number of 
Parameters not correct for 
type DIGITAL 

Digital items typically use backslash ( \ ) as part of 
the definition. Verify backslash used for line 
continuation includes space before special 
character. 
Example: 90 160 DIGITAL \  
 141 22 151 63 “DX-22.BMP” \ 
 129 22 139 63 “DX-22.BMP” \ 
 DO3 
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Appendix C  
Updating the DX LCD Display 
Firmware 

Introduction 
You can update a DT-9100 with firmware Version 3.00.00 via the 
DX LCD Display Update Firmware menu. This feature needs to be 
enabled in the GX Tool initialization file. 
This chapter describes how to update DX LCD Display firmware. 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
 Code No. LIT-1201100 Software Release 7.10 
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Detailed Procedures 
Updating DX LCD Display Firmware 

!  CAUTION: Possible Data Loss. Updating the firmware 
overwrites all configuration data in the DX LCD 
Display. To avoid data loss, upload and save all 
configurations and Home Pages from the display 
before updating the firmware. 

To update DX LCD Display firmware: 
1. On the DX LCD Display menu, click Update Firmware. The 

DX LCD Display Update Firmware dialog box appears  
(Figure C-1). 

*.prm

DX LCD Display - Update Firmware

File ame:n

List files of ype:t Dri es:v

Folders:

c:\progra~1\gx_beta\prm
OK

Cancel
30007~1.prm
30008~1.prm

c:\
progra~1
gx_beta

Firmware files (*.PRM)

prm

?

c: hard disk

 

Figure C-1: Update Firmware Dialog Box 
2. Choose the file name and click OK to continue. The dxd_dldr 

DOS window appears (Figure C-2). 
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dxd_dldr

Auto

MS

A

Preparing Download file, Please wait.
Preparing Download file, Please wait.
Waiting to start boot load to DX Display.
Press the zero <0> key to exit this program.
Press the return <cr> key to start sending the initial download.

 

Figure C-2: DOS Window 
3. Press Zero key to abort the download procedure and return to the 

GX Tool, or press the Enter key to start the download procedure. 
If you press Enter, the DT-9100 is reset with a blank screen and 
the download begins (Figure C-3). 
When the download is complete, the Finished - dxd_dldr window 
appears and the DT-9100 is reset (Figure C-4). 

4. Close the download window to return to the GX Tool. 
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dxd_dldr

Auto

MS

A
Parsing Download file, Please wait.
Parsing Download file, Please wait.
Waiting to start boot load to DX Display.
Press the zero <0> key to exit this program.
Press the return <cr> key to start sending the initial download.
Received boot load request from user.
Sending boot load request from user.
Sending boot load to DX Display.
*DS* first load size = 69
DS oRxByte is ff

Completed first boot load to DX Display.

Sending second boot load @ 9600 bps
Press the zero <0> key to exit this program.
*DS* second load size = 530
Waiting for acknowledge...

Second boot load to DX Display Completed.

Sending third boot load @ 9600 bps
Press the zero <0> key to exit this program.
148608 bytes sent out of 262144 bytes total.

 

Figure C-3: Download Starting 

Parsing Download file, Please wait.
Parsing Download file, Please wait.
Waiting to start boot load to DX Display.
Press the zero <0> key to exit this program.
Press the return <cr> key to start sending the initial download.
Received boot load request from user.
Sending boot load request from user.
Sending boot load to DX Display.
*DS* first load size = 69
DS oRxByte is ff

Completed first boot load to DX Display.

Sending second boot load @ 9600 bps
Press the zero <0> key to exit this program.
*DS* second load size = 530
Waiting for acknowledge...

Second boot load to DX Display Completed.

Sending third boot load @ 9600 bps
Press the zero <0> key to exit this program.
148608 bytes sent out of 262144 bytes total.
Third boot load to DX Display completed.

 

Figure C-4: Download Complete 
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Appendix D  
Printing Configurations 

Introduction 
The GX Tool allows you to print DX controller and DX LCD Display 
configurations. 
This chapter describes how to: 

• define the header and footer 

• preview the printed configuration 

• print a configuration 

© November 1, 2001 Johnson Controls, Inc. www.johnsoncontrols.com 
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Detailed Procedures 
Defining the Header and Footer 

To define the header and footer: 
1. On the File menu, click Header/Footer. The Header/Footer Dialog 

box appears (Figure D-1). 

 

Figure D-1: Header/Footer Dialog Box 
2. Enter company name up to 78 characters. 
3. Choose header position and select Field Information from 

drop-down list. Refer to Table D-1 for Field Information options. 
4. Select Page Options to display the header and footer on every 

page or only the first page. 
5. Choose footer position and select Field Information from 

drop-down list. Refer to Table D-1 for Field Information options. 
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The footer does not include descriptors (e.g., JOB NAME:) 
when printed. 

Note: 

Table D-1: Header/Footer Field Information 
Option Description 
None Leaves blank space. 
Job Name* Prints job name. 
Controller* Prints the controller version. 
Engineer* Prints name of engineer. 
Branch* Prints branch name. 
Created On* Prints creation date. 
Page Prints page number. 
Filename Prints the name of the file. 
Printed On Prints the current date. 

* Job Name, Controller Name, Engineer, Branch, and Created On information is 
entered in Job Information. 

 
6. Select OK to save settings or Cancel to revert to the default 

settings. Figure D-2 is an example of a header and footer. 

Johnson Controls

JOB NAME: Test Job
Branch:  JC Toronto

Controller Name:   DX123987
Engineer:  H.W.Schillack Creation Date:  00/03/21

Page: 1

Tuesday, March 21, 2000 DX123987.DXS JC Toronto

Header Example:

Footer Example:

HD&FT_EX  

Figure D-2: Header and Footer Example 
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Previewing the Printed Configuration 
To preview the printed configuration: 
1. On the File menu, click Print Preview. The Print Preview dialog 

box appears (Figure D-3). 

 

Figure D-3: Print Preview Dialog Box 
2. Select options according to Table D-2. 

Table D-2: Print Options 
Option Description 
Selection 
All Items Prints items listed in the Items box, including module data, 

job information, calibration information, and global data. 
Graphic Selection Prints all items selected in the configuration layout. 
Items (listed below) Prints all items with checked boxes in the Items box. 
Print Format 
Draft Prints the configuration as it would be printed in Draft 

mode (without page headers and footers). 
Final Prints the configuration as it would be printed in Final 

mode (with page headers and footers). 
Data Selection 
Data Includes data for every module with the configuration 

printout. 
Input Tags Includes a list of defined input-tags for every module with 

the configuration printout. 
Output Tags Includes a list of defined output-tags for every module with 

the configuration printout. 
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3. Click OK. A print preview screen appears (Figure D-4). 

 

Figure D-4: Print Preview Example 
4. Click Print to print or Close to exit. 
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Printing a Configuration 
To print a configuration: 
1. On the File menu, click Print. The Print Items dialog box appears 

(Figure D-5). 

 

Figure D-5: Print Items Dialog Box 
2. Select options according to Table D-2. 
3. Click OK. The Print dialog box appears (Figure D-6). 

 

Figure D-6: Print Dialog Box 
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4. Click Setup… to change the selected printer and printer options. 
5. Select the print range. 
6. Select the print quality from the drop-down list. 
7. Enter the number of copies to print. 
Note: If you are printing multiple copies, select Collate Copies to 

print each set in order. 

8. Click OK. 
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