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This chapter provides an overview of Oracle's Hyperion® Smart View for Office.

Smart View
Smart View provides a common Microsoft Office interface for Oracle's Hyperion® Essbase® –
System 9, Oracle's Hyperion® Financial Management – System 9, Oracle's Hyperion® Planning
– System 9, Oracle's Hyperion® Workspace, and Oracle's Hyperion® Enterprise® data. Using
Smart View, you can view, import, manipulate, distribute and share data in Microsoft Excel,
Word, and PowerPoint interfaces.

Smart View Benefits
Smart View benefits:

● A common Microsoft Office interface for Essbase, Financial Management, Planning,
Oracle's Hyperion® Financial Reporting – System 9, Oracle's Hyperion® Interactive
Reporting – System 9, Oracle's Hyperion® SQR® Production Reporting – System 9, Oracle's
Hyperion® Web Analysis – System 9, and Hyperion Enterprise

● Ability to import documents from Financial Reporting, Interactive Reporting, SQR
Production Reporting, and Web Analysis

● Ability to use smart tags to import Oracle's Hyperion® Reporting and Analysis – System 9
content and functions

● Auto deployment to notify users when a newer version of Smart View is available
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Smart View Toolbar
The Smart View toolbar in Excel displays buttons (described in Table 1, “Smart View Toolbar
Buttons   ,” on page 12) for accessing most Smart View commands. You can customize the
toolbar by adding and removing buttons.

➤ To add or remove buttons from the Smart View toolbar:

1 Click  (Add or Remove Buttons) on the Smart View toolbar to display a menu of toolbar buttons.

2 Click a button to add it to or remove it from the Smart View toolbar. Your selection is displayed on the toolbar
immediately.

3 Repeat for each button you want to add or remove.

Toolbar Buttons
Table 1 lists the buttons on the toolbar.

Table 1 Smart View Toolbar Buttons  

Button Purpose Description

Connection Manager Opens the Connection Manager where you add, delete, and edit data source
connections

Zoom In Zooms into data from the connected data source

Zoom Out Collapses the cell view

Pivot Changes the dimension orientation

Keep Only Deletes all members except the ones that are selected

Remove Only Removes only the selected members

Refresh Refreshes data in the active Excel worksheet

Submit Data In Hyperion Enterprise, Financial Management, and Essbase, saves ad hoc data
updates to the database

Refresh All Refreshes data in all worksheets of the Excel workbook

Undo Restores the previous database view

Redo Reverses an Undo
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Button Purpose Description

Copy Data Points Copies data points from Excel that you can paste into Word or PowerPoint

Paste Data Points Pastes data points that were copied from Excel into Word or PowerPoint

BI Edit Enables you to edit Reporting and Analysis documents imported into Excel (not
selectable for Hyperion Enterprise)

POV Manager Opens the POV Manager where you can perform operations on a Point of View

Member Selection Opens the Member Selection dialog box where you can select members and filter
member lists

Function Builder Opens the Function Builder, where you create and validate functions

Adjust Provides options for adjusting the values of selected cells

Cell Text For Hyperion Enterprise and Planning data sources, opens the Cell Text dialog
box where you edit supporting text for a range of cells

Supporting Details For Planning data sources, opens the Supporting Details dialog box where you
can provide supplemental calculations for a one-dimensional range of cells

Select Form Opens the Select Forms dialog box where you can select Financial Management,
Hyperion Enterprise, or Planning data forms

Instructions For Planning data sources, displays instructions for data forms

Take Offline Opens the Offline Manager (not selectable for Hyperion Enterprise)

Sync Back Synchronizes data from an offline Planning data form to an online data form (not
selectable for Hyperion Enterprise)

Lock Temporarily locks cell values while Planning enters values in other cells (not
selectable for Hyperion Enterprise)

Expand Displays all levels of detail for the selected cells (not selectable for Hyperion
Enterprise)

Collapse Collapses all levels of detail for the selected cells (not selectable for Hyperion
Enterprise)

Business Rules Opens the Business Rules dialog box where you select Business Rules for
Planning data forms (not selectable for Hyperion Enterprise)

Rules on Form Opens the Rules on Form dialog box, where you execute Calculate Form and
Calculate Currencies business rules (not selectable for Hyperion Enterprise)

Query Designer Opens the Query Designer, where you design reports

Run Reports Runs reports designed in the Query Designer
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Button Purpose Description

Visualize in Excel Enables you to view the detail of a selected Excel data point in a linked report
without losing the formatting of the source report

Visualize in HVE Opens Oracle's Hyperion® Essbase® Visual Explorer (not selectable for Hyperion
Enterprise)

Options Opens the Options dialog box where you set ad hoc, display, and cell style
preferences

Add or Remove Buttons Click — opens a menu of Smart View toolbar buttons to add or remove

Right-click— opens a menu of toolbars to add or remove

Shortcut Menus
In Smart View, you can use right mouse clicks to access shortcut menus. If you select a range of
cells, use Ctrl+right click to maintain the selection of cells.

Login Requirements
Depending on how Smart View was configured by the adminstrator, you may or may not be
required to enter your username and password as you change data providers and Office
applications or enter HVE.

Using Google Search with Smart View
With Essbase, you can use the Google search capabilities of Oracle's Hyperion® Smart Search to
search your data source for information and display the results on an Excel spreadsheet in Smart
View.

Before starting, you must obtain the URL and trigger keyword, which can be provided by the
system administrator.

➤ To use Google with Smart View:

1 Open a browser.

2 Enter the URL to open. Oracle's Hyperion® Smart Search.

3 Enter the trigger keyword.

4 In the search box, enter one or more member names separated by spaces.

5 Click the link under Search to display the results in Smart View in Excel.
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Note:

Excel may display a Security Warning message. If you see this message, you must modify Excel
macro security settings to see the search results. To do this, select Tools > Options from the
Excel toolbar. On the Security tab of the Options dialog box, click Macro Security and set Security
Level to medium or low. See the system administrator for more information.

For Microsoft Office 2007 Users
Smart View supports Microsoft Office 2007, whose products feature ribbons in place of the
previous menu system. In Office 2007 products, the Smart View Hyperion menu is replaced by
the Hyperion ribbon, which contains buttons that access Smart View features. Smart View
functionality is the same as it is in previous Office versions; only the method of access has
changed.

You can still access the Hyperion menu, the online help system, and the Help About screen on
the Add-Ins ribbon.

Table 2 describes Smart View buttons on the Hyperion ribbon, grouped according to ribbon
sections.

Table 2 Smart View Buttons on the Hyperion Ribbon for Office 2007

Button Purpose Description

Connections

Connect Opens the Connection Manager where you add, delete, and edit data source
connections

(no button) Activate Enables you to select the data source that you want to activate for the worksheet

(no button) Reset Disconnects the worksheet from its current data source

Ad Hoc Analysis

Zoom In Zooms into data from the connected data source

Zoom Out Collapses the cell view

Pivot Changes the dimension orientation

Keep Only Deletes all members except the ones that are selected

Remove Only Removes only the selected members

Forms

Select Form Opens the Select Forms dialog box where you can select Financial Management
or Planning data forms
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Button Purpose Description

Instructions For Planning data sources, displays instructions for data forms

Take Offline Opens the Offline Manager (not selectable for Hyperion Enterprise)

Refresh Offline Enables you to update data on offline data forms with current values from online
data forms

Sync Back to Server Synchronizes data from an offline Planning data form to an online data form

Lock Temporarily locks cell values while Planning enters values in other cells (not
selectable for Hyperion Enterprise)

Expand Displays all levels of detail for the selected cells (not selectable for Hyperion
Enterprise)

Collapse Collapses all levels of detail for the selected cells (not selectable for Hyperion
Enterprise)

Review

Refresh Refreshes data in the active Excel worksheet

Refresh All Refreshes data in all worksheets of the Excel workbook

Submit In Reporting and Analysis and Essbase, saves ad hoc data updates to the
database

Task

Undo Restores the previous database view

Redo Reverses an Undo

Copy Data Copies data points from Excel that you can paste into Word or PowerPoint

Paste Data Pastes data points that were copied from Excel into Word or PowerPoint

BI: Import Opens the ImportWorkspace Document dialog box where you can import
Reporting and Analysis documents (not selectable for Hyperion Enterprise)

BI: Edit Enables you to edit Reporting and Analysis documents imported into Excel (not
selectable for Hyperion Enterprise)

POV Manager Opens the POV Manager, where you can perform operations on a Point of View

Member Selection Opens the Member Selection dialog box, where you can select members and
filter member lists

Function Builder Opens the Function Builder, where you create and validate functions
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Button Purpose Description

Adjust Provides options for adjusting the values of selected cells

Cell Text For Planning data sources, opens the Cell Text dialog box, where you edit
supporting test for a range of cells

Supporting Details For Planning data sources, opens the Supporting Details dialog box, where you
can provide supplemental calculations for a one-dimensional range of cells

Query

Query Designer Opens the Query designer, where you design reports

Run Report Runs a report designed in the Query Designer

Visualize

Visualize in Excel Enables you to view the detail of a selected Excel data point in a linked report
without losing the formatting of the source report

Visualize in HVE Opens Visual Explorer (not selectable for Hyperion Enterprise)

Options

Options Opens the Options dialog box where you set ad hoc, display, and cell style
preferences
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Features and Data Source

Providers
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Not all Smart View features pertain to all data source providers. The tables in this chapter list
the supported data source providers for each feature.

Ad Hoc Features and Supported Data Source Providers
Ad Hoc functionality is described in Chapter 7, “Working with Ad Hoc Analysis.”

Note:

To use ad hoc features with Planning data forms, you must be connected to an Essbase data
source.

Ad Hoc Feature

Data Source Providers

Essbase Financial Management Hyperion Enterprise Planning Workspace

Double-click to invoke the
Ad Hoc analysis grid

X X X   

Display POV member
selector

X X X   

Drag and drop members
from POV to grid

X X X   

Set default POV by the
user

X X X   
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Ad Hoc Feature

Data Source Providers

Essbase Financial Management Hyperion Enterprise Planning Workspace

Duplicate member name
support

X X X   

Zoom in and out on
dimensions and members

X X X   

Zoom in and out on Hybrid
Analysis members

X     

Drill-through reports X     

Pivot dimensions to
columns or rows

X X X   

Display cell text  X    

Submit data X X X   

Keep only or remove only
certain data cells

X X X   

Select attribute
dimensions

X     

Filter members by UDA X     

Filter members by
attribute dimensions

X     

Adjust data values in cells X X X   

Calculate data X X X   

Translate and consolidate
data

 X    

Asymmetric grids and free
form mode

X X    

Save formatting X X X   

Preserve formulas X X    

Undo and redo last
actions

X X X   

Select members X X X   

Select Dynamic Time
Series members

X     

Suppress rows X X X   

Indent columns X X X   
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Ad Hoc Feature

Data Source Providers

Essbase Financial Management Hyperion Enterprise Planning Workspace

Navigate without data X X X   

Specify zoom-in levels X X X   

Specify member retention X X X   

Enable or disable double-
clicking

X X X   

Enable or disable undo
feature

X X X   

Specify labels for missing
and no access data cells

X X X   

Specify member display
options

X X X   

Display data status  X X   

Display calculation status
and process management
level

 X    

Specify number of
decimal places

 X X X  

Specify thousands
separator

 X X X  

Specify ancestor position  X X   

Display messages X X X   

Apply cell styles X X X   

VBA function support X X    

Query Designer Features and Supported Data Source Providers
Query Designer functionality is described in Chapter 6, “Query Designer.”

Query Designer Feature

Data Source Providers

Essbase Financial Management Hyperion Enterprise Planning Workspace

Select members by using
Member Selection

X X X   

Drag and drop dimensions
from POV toolbar

X X X   
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Query Designer Feature

Data Source Providers

Essbase Financial Management Hyperion Enterprise Planning Workspace

Enter members into the
grid

X X X   

Pivot dimensions X X X   

Filter data X     

Filter members X  X   

Execute MDX queries X     

Modify queries from
existing reports

X X X   

Run queries X X X   

Dynamic Data Access Features and Supported Data Source
Providers

Dynamic data access functionality is described in Chapter 9, “Accessing Dynamic Data Across
Microsoft Office.”

Dynamic Data Access
Feature

Data Source Providers

Essbase Financial Management Hyperion Enterprise Planning Workspace

Copy and paste data
points between Excel,
Word, and PowerPoint

X X X   

Retrieve original Excel grid
from data points in Word
or PowerPoint

X X X   

View data points in Visual
Explorer

X     

Change POV in Word or
PowerPoint by using POV
Manager

X X X   

Change URL connection
by using POV Manager

X X X   
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Hyperion Visual Explorer Features and Supported Data Source
Providers

Visual Explorer functionality is described in Chapter 10, “Hyperion Visual Explorer.”

Visual Explorer Feature

Data Source Providers

Essbase Financial Management Hyperion Enterprise Planning Workspace

View data in graphical
format

X     

Retrieve Excel grid from
graphical data

X     

Change graph style X     

Data Form Features and Supported Data Source Providers
Data form functionality is described in Chapter 5, “Working with Data Forms” and Chapter 13,
“Working with Offline Planning.”

Data Form Feature

Data Source Providers

Essbase Financial Management Hyperion Enterprise Planning Workspace

View instructions  X X X  

Adjust data values in cells  X X X  

Submit data  X X X  

Specify decimal places  X X X  

Specify thousands separator  X X X  

Manipulate data by
performing unary operations

 X  X  

Lock and spread values to
base periods

   X  

Enter supporting detail    X  

Enter cell text  X  X  

Work offline    X  

Synchronize with Planning
applications

   X  

Execute Business Rules    X  
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View Business Rules with
runtime prompts

   X  

Preserve formulas  X  X  

Apply cell styles  X X X  

Support Offline Planning    X  

Search page dimensions    X  

Hide header rows    X  

Function Features and Supported Data Source Providers
Functions are described in Chapter 12, “Functions.”

Function Feature

Data Source Providers

Essbase Financial Management Hyperion Enterprise Planning Workspace

Use HsGetValue X X X   

Use HsSetValue X X X   

Use HsDescription  X X   

Use HsGetText  X    

Use HsSetText  X    

Use HsCurrency  X X   

Use HsLabel  X X   

Refresh active worksheets
or workbooks

X X X   

Migrate Financial
Management spreadsheet
add-in functions to new
syntax

 X X   

Display functions by using
smart tags

X X X   

Reporting and Analysis Document Import Features and
Supported Data Source Providers

Reporting and Analysis document import functionality is described in Chapter 11, “Importing
Reporting and Analysis Documents into Microsoft Office.”
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Reporting and Analysis
Feature

Data Source Providers

Essbase Financial Management Hyperion Enterprise Planning Workspace

Import Reporting and
Analysis documents into
Microsoft Excel, Word,
PowerPoint, and Outlook
(if Word is the e-mail
editor)

    X

Edit and refresh Reporting
and Analysis documents

    X

Import multiple-page
documents

    X

Use prompts     X

Import Reporting and
Analysis documents by
using smart tags

    X
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Installing Smart View
Because Smart View is an add-in to Microsoft Office products, you can install only on Windows
platforms.

To view imported data within Microsoft Office, each user in an organization must install Smart
View.

You do not need to uninstall earlier versions of Smart View before installing the latest version.

➤ To install Smart View:

1 Navigate to the location of the Smart View installation file specified by your administrator.

2 Double-click smartview.exe to start the installation wizard.

If you are licensed to use Visual Explorer, run SmartViewHVE.exe instead.

3 Click Install.

4 Click Finish. The next time you open Microsoft Excel, Word, or PowerPoint, the Hyperion menu or ribbon is
displayed.

Enabling and Disabling Smart View

➤ To enable or disable Smart View:

1 Select Hyperion > About.

2 Select or clear Enable Add-in to enable or disable Smart View.

Your selection takes effect the next time you start a Microsoft Office application.
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Smart View and Essbase Spreadsheet Add-in
Smart View and Essbase Spreadsheet Add-in (release 7.1.2 or later only) can be installed on the
same computer, but you must enable compatibility between them.

➤ To enable compatibility between Essbase Spreadsheet Add-in and Smart View:

1 Open Excel.

2 Select Essbase > Options > Global.

3 Select Limit to Connected Sheets.

4 Click OK.

Note:

You can connect to data sources from Smart View and Essbase in the same workbook but not
on the same worksheet.

Information for Administrators
The following information in this section is for system administrators.

● “Smart View Files Installed” on page 28

● “Running Silent Installations” on page 29

● “Checking for New Smart View Versions” on page 29

● “Backward Compatibility” on page 30

● “Uninstalling Smart View” on page 30

Smart View Files Installed

Table 3 Directories Created and Files Installed with Smart View

Directory Contents

bin ● Smart View DLLs:

❍ HsAddin.dll

❍ HsSpread.dll

❍ HyperionSmartTag.dll

❍ SVPConn.dll

❍ tabui.dll

❍ tabvizql.dll

● HSTbar.xla, the Smart View toolbar

● smartview.bas, containing VBA function declarations

● hve.exe, theVisual Explorer executable
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Directory Contents

Note: hve.exe installs only if you are licensed for Visual Explorer and used
SmartViewHVE.exe to install Smart View

docs\help Smart View documentation in HTML format; the launch file is launch.htm

docs\pdf Smart View documentation in PDF format, sv_user.pdf

docs\hve Visual Explorer documentation in Windows help format, HVEHelp.chm

Note: The hve folder and documentation installs only if you are licensed for Visual Explorer and used
SmartViewHVE.exe to install Smart View

Running Silent Installations
Administrators can enable silent installations — installations that do not require settings to be
specified each time — for Smart View. The silent installation command can be included in scripts
to automate installation.

➤ To run silent installations:

1 Open a command line prompt.

2 Navigate to the directory of the Smart View installer.

3 Run one of the following commands:

● To install in the default directory, run SmartView.exe /s /v"/qn"

● To install in another directory, run SmartView.exe /s /v"/qn
INSTALLDIR=<target path>", for example, SmartView.exe /s /v"/qn
INSTALLDIR=D:\SmartView"

For Visual Explorer users, replace SmartView.exe with SmartViewHVE.exe in the command
line.

➤ To run silent installation and log the installation sequence:

1 Open a command line prompt.

2 Navigate to the directory of the Smart View installer.

3 Run SmartView.exe /s /v”/qn INSTALLDIR=D:\SmartView /L*v c:
\install.log”.

For Visual Explorer users, replace SmartView.exe with SmartViewHVE.exe in the command
line.

Checking for New Smart View Versions
Smart View supports automatic deployment, which detects when a newer version of Smart View
is available to install. Automatic deployment upgrades only Smart View releases 9.0 and later.
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Backward Compatibility
See the compatibility matrix in the Smart View Readme for information on compatibility with
data source providers.

Uninstalling Smart View
Close all Microsoft Office applications, then use Add or Remove Programs on the Windows
Control Panel to uninstall Smart View, which is listed as Hyperion System 9 Smart View for
Office.

When Smart View is installed, the .MSI file is extracted from SmartView.exe or
SmartViewHVE.exe and placed at C:\WINNT\Downloaded Installations\{<a
dynamic GUID>}\. The .MSI is cached in this location through InstallShield Integrated
Development Environment for maintenance mode activities, such as repairing and removing
files.

The uninstallation details are stored at:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

\<Product GUID>

Under this key, the sub key ”InstallSource” holds the value C:\WINNT\Downloaded
Installations\{<a dynamic GUID>}\.

The uninstallation process refers to this sub key and locates the extracted .MSI file. Because
the .MSI file present in this location only initiates the uninstallation process, you cannot delete
the .MSI file during uninstallation. Only after the product is fully uninstalled can you manually
delete the .MSI file.

Registry Information
To preserve login and user preference information, the following registry items remain after
uninstalling Smart View:

HKEY_CURRENT_USER\Software\Hyperion Solutions\

HyperionSmartViewConnections

HKEY_CURRENT_USER\Software\Hyperion Solutions\HyperionSmartViewLogin

HKEY_CURRENT_USER\Software\Hyperion Solutions\

HyperionSmartViewPreferences

Visual Explorer File Association
If Smart View and Essbase Spreadsheet Add-in are installed on the same computer, when you
open a Visual Explorer .TWB file directly from Windows Explorer, the file is opened by Smart
View, regardless of whether the file was created in Smart View or Spreadsheet Add-in.

If you uninstall Smart View, and keep Spreadsheet Add-in on the computer, the file association
for .TWB files is lost, even with Spreadsheet Add-in.
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Use Windows Explorer to establish .TWB file association manually with Spreadsheet Add-in.

Information for Administrators 31



32 Installing and Enabling Smart View and Visual Explorer



4
Using Connection Manager

In This Chapter

Using Connection Manager .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .33

About Data Sources ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .34

About Connection Manager .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .34

Adding a Data Source Connection ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .34

Connecting to a Data Source ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .37

Associating a Data Source Connection to a Worksheet .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .38

Editing a Data Source Connection ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .38

Setting a Default Connection ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .39

Deleting a Data Source Connection... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .40

Disconnecting from a Data Source ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .40

Changing Passwords for Essbase... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .41

Checking for Active Connections ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .41

Resetting Connections... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .41

Using the Shortcut Menu ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .41

This chapter explains using Connection Manager to manage data source connections. Topics
include how to use Connection Manager for tasks such as adding, editing, deleting, connecting
to and disconnecting from data sources, specifying the default connection, checking for active
connections, and resetting connections.

Using Connection Manager
Use the Connection Manager to perform the following tasks:

● “Adding a Data Source Through Direct Connection” on page 35

● “Adding a Data Source Through Shared Services” on page 36

● “Connecting to a Data Source” on page 37

● “Associating a Data Source Connection to a Worksheet” on page 38

● “Editing a Data Source Connection” on page 38

● “Setting a Default Connection” on page 39

● “Deleting a Data Source Connection” on page 40
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● “Disconnecting from a Data Source” on page 40

● “Changing Passwords for Essbase” on page 41

● “Checking for Active Connections” on page 41

● “Resetting Connections” on page 41

● “Using the Shortcut Menu” on page 41

About Data Sources
A data source contains the database for the application or Reporting and Analysis content
repository for which you want to access data using Smart View. Smart View supports the
following data source providers—Essbase, Financial Management, Hyperion Enterprise,
Planning, Financial Reporting, Interactive Reporting, SQR Production Reporting, and Web
Analysis. For connection information, contact your system administrator.

About Connection Manager
With the Connection Manager you can add, delete, and modify data source connections. These
connections are not specific to worksheets and you can establish multiple connections per Excel
instance. A connection is a communication line between the user and data source regardless of
whether the data source is connected to or disconnected from the provider server. You can tell
whether a data source is connected or disconnected by viewing the icon next to the data source

name in Connection Manager. The  icon indicates that the data source is connected. A grayed

out  icon indicates the data source is disconnected. When you try to connect to a data source
that is disconnected, you are prompted to log in unless you are already authenticated by external
authentication.

For more information on using the Connection Manager, see these topics:

● “Adding a Data Source Connection” on page 34

● “Connecting to a Data Source” on page 37

Adding a Data Source Connection
The data sources to which you can connect are displayed in the Connection Manager. You add
data sources for Essbase, Financial Management, Hyperion Enterprise, Planning, Financial
Reporting, Interactive Reporting, SQR Production Reporting, and Web Analysis. You can either
connect to a data source directly, if you know the URL, or using Oracle's Hyperion® Shared
Services, display a list of providers that you can access.

Note:

Hyperion Enterprise does not support Shared Services.
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You need to know the following information to add a data source connection:

● If you are working with a database or repository, the location of the URL where the data
source is hosted

● If you are working offline, the path of the local storage directory where your metadata resides

● The user name and password that provides you access to the data source, whether it is a URL
or directory location

If you do not know this information, contact your system administrator.

For more information on adding a data source, see:

● “Adding a Data Source Through Direct Connection” on page 35

● “Adding a Data Source Through Shared Services” on page 36

Adding a Data Source Through Direct Connection
When you add a data source connection directly in Connection Manager, you need to know the
URL for the data source provider to which to connect. A provider can be Essbase, Financial
Management, Hyperion Enterprise, Planning, Financial Reporting, Interactive Reporting, SQR
Production Reporting, and Web Analysis data sources. You can get this information from your
system administrator.

➤ To add a data source connection through direct connection:

1 Select Hyperion > Connection Manager. For Office 2007, click Connect in the Connections section of the
Hyperion ribbon.

2 In the Connection Manager dialog box, click the Add button.

3 Select URL Provider.

The Add Connection - Provider Type/URL dialog box is displayed.

4 In the Provider drop-down list box, select the type of data source to which you want to connect:

● Hyperion Provider (for Essbase, Financial Management, Hyperion Enterprise, and
Planning)

● Hyperion Reporting and Analysis — System 9 Provider (for Financial Reporting, Interactive
Reporting, SQR Production Reporting, and Web Analysis)

5 In the Location drop-down list box, type the URL or the local storage directory for the data source to which
you want to connect, and then click Next.

The URL syntax for the various data sources is as follows. Contact your system administrator
for the URL to use:

Essbase: http(s)://<servername>:13080/aps/SmartView

Financial Management: http(s)://<servername>/hfmofficeprovider/
hfmofficeprovider.aspx

Hyperion Enterprise: http://<servername>/heofficeprovider/
heofficeprovider.aspx
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Planning: http(s)://<servername>:8300/HyperionPlanning/SmartView

Reporting and Analysis: http(s)://<servername>:19000/workspace/browse/listxml

If you are accessing a local storage directory, you can click Browse to open the Browse for Folder
dialog box. Navigate to the location where your metadata resides, and click OK.

Note:

You can click the Back button at any time to return to the previous dialog box and edit the entries
you already made.

6 Optional: Select the Set as default connection check box to make the data source your default connection.

7 In the Add Connection - Application/Cube dialog box, expand the Servers node.

A list of servers that are accessible from the URL you selected in step 5 is displayed.

8 Expand the nodes until the object to which you want to connect is displayed, then select that object.

For example, you may want to connect directly to the Essbase, Financial Management, Hyperion
Enterprise, or Planning application.

Note:

You may be prompted to enter your login information if you try to expand an application for
which you do not have access.

9 In the Connect to Data Source dialog box, type the user name and password, and then click Connect.

10 Select the application and click Next. In the Add Connection - Name/Description dialog box, type a name
for this data source connection in the Name text box.

The data source connection name is also referred to as the friendly name.

Note:

Do not use semicolons (;) in connection names planned for using functions. An error occurs
when using Function Builder to create functions and when pasting data points containing
functions.

11 In the Description text box, type any information that is helpful to you in identifying this data source, and
then click Finish.

The data source connection you just added is now listed in the Connection Manager. To connect
to the data source, follow the steps in “Connecting to a Data Source” on page 37. To associate
the data source to the current worksheet, follow the steps in “Associating a Data Source
Connection to a Worksheet” on page 38.

Adding a Data Source Through Shared Services

Note:

This release of Hyperion Enterprise does not support Shared Services.
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You can connect to any provider that has been registered with Shared Services as a provider for
Smart View content. Adding data sources through Shared Services conveniently provides users
with a single location to choose a list of available Smart View content providers.

➤ To add a data source through Shared Services:

1 Select Hyperion > Connection Manager. For Office 2007, click Connect in the Connections section of the
Hyperion ribbon.

2 In the Connection Manager dialog box, click Add.

3 Select Shared Services Provider.

The Add Connection From Shared Services dialog box is displayed.

4 In the Hyperion Shared Services URL text box, type the URL to the Shared Services server. The URL syntax
for Shared Services is as follows:

http://<sharedservices_server>:58080

Contact your system administrator for the Shared Services server name.

5 Click Update.

A list of available data sources that are registered with Oracle's Hyperion® Shared Services is
displayed in the Select a Connection from a Provider list box.

6 From the Select a Connection from a Provider list box, select the data source to which you want to connect.

7 Click Next.

8 In the Connection credentials dialog box, type the user name and password that you will use to access this
data source, and then click Connect.

9 In the Add a Connection Name dialog box, type a name for this data source connection in the Name text
box.

The data source connection name is also referred to as the friendly name.

10 In the Description text box, type any information that is helpful to you in identifying this data source, and
then click Finish.

The data source connection you just added is now listed in the Connection Manager. To connect
to the data source, follow the steps in “Connecting to a Data Source” on page 37. To associate
the data source to the current worksheet, follow the steps in “Associating a Data Source
Connection to a Worksheet” on page 38.

Connecting to a Data Source
You can connect to any data source listed in Connection Manager. Connecting to a data source
enables you to retrieve data into Excel.

➤ To connect to a data source:

1 Select Hyperion > Connection Manager. For Office 2007, click Connect in the Connections section of the
Hyperion ribbon.
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2 In Connection Manager, select the data source to which you want to connect and click Connect.

3 In the Connect to Data Source dialog box, enter the user name and password for the data source.

4 Click Connect.

5 Click Close to close Connection Manager.

To associate the data source to the current worksheet, follow the steps in “Associating a Data
Source Connection to a Worksheet” on page 38.

Associating a Data Source Connection to a Worksheet
After adding data sources to Connection Manager, you need to associate a worksheet with a data
source before you can access the data. You can connect to one data source per worksheet.

➤ To associate a data source to a worksheet:

1 In Connection Manager, select a data source and double-click.

2 In the Connect to data source dialog box, enter the password and click Connect.

The worksheet is now connected to the selected data source.

You can also associate a data source after connecting to it by selecting Hyperion > Active
Connections and selecting the data source you want to activate for the worksheet. See “Checking
for Active Connections” on page 41 for more information.

Editing a Data Source Connection
You can edit existing data sources in Connection Manager. When you edit a data source, you
can change the provider, change to a different server with the same data source provider, or
change the application or repository associated with the data source. You must disconnect from
a data source before you can edit it.

➤ To edit a data source:

1 Select Hyperion > Connection Manager. For Office 2007, click Connect in the Connections section of the
Hyperion ribbon.

2 In the Connection Manager dialog box, select the data source that you want to modify and click Edit.

The Edit Connection - Provider Type/URL dialog box is displayed.

3 In the Provider drop-down list box, select the type of data source to which you want to connect:

● Hyperion Provider (for Essbase, Financial Management, Hyperion Enterprise, and
Planning)

● Hyperion Reporting and Analysis – System 9 Provider (for Financial Reporting, Interactive
Reporting, SQR Production Reporting, and Web Analysis)

4 In the Location field, edit the URL of your data source or select from the list of available data sources.
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The URL syntax for the various data sources is as follows. Contact the system administrator for
the URL to use:

Essbase: http(s)://<servername>:13080/aps/SmartView

Financial Management: http(s)://<servername>/hfmofficeprovider/
hfmofficeprovider.aspx

Hyperion Enterprise: http://<servername>/heofficeprovider/
heofficeprovider.aspx

Planning: http(s)://<servername>:8300/HyperionPlanning/SmartView

Reporting and Analysis: http(s)://<servername>:19000/workspace/browse/listxml

5 Optional: Select the Set as default connection check box to make the data source your default connection.

6 Click Next.

7 In the Connect to Data Source dialog box, enter the user name and password for the data source, and click
Connect.

8 In the Edit Connection - Application/Cube dialog box, expand the Servers node, select an application,
and click Next.

If you do not see any applications, contact your system administrator. You may be prompted to
enter your login information if you try to expand an application for which you do not have
access.

9 In the Edit Connection - Name/Description dialog box, edit the name and description for your connection
user name.

10 Click Finish.

In the Connection Manager dialog box, the newly edited data source should be displayed.

11 Click Close to close Connection Manager.

Setting a Default Connection
The default data source is the data source that is automatically used to retrieve data into the
Excel worksheet. The default data source will always be the data source used when navigating
from worksheet to worksheet. Using Connection Manager, you can choose the default
connection. In Connection Manager, the data source name listed in bold text is the default
connection.

➤ To set the default data source:

1 In Connection Manager, select an existing data source connection.

2 Right-click and select Set As Default.
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Note:

Alternatively, follow the directions in step 6 of “Adding a Data Source Through Direct
Connection” on page 35 or step 5 in “Editing a Data Source Connection” on page 38 to make a
data source connection the default.

Deleting a Data Source Connection
Delete a data source from the list in Connection Manager when the connection is obsolete or
when you no longer need to connect to a particular data source. You must disconnect from a
data source before deleting it.

➤ To delete a data source:

1 Select Hyperion > Connection Manager. For Office 2007, click Connect in the Connections section of the
Hyperion ribbon.

2 In the Connection Manager dialog box, select the data source that you want to remove and click Delete.

Note:

You can delete multiple data sources at once.

3 When prompted to confirm deletion of the data source, click Yes.

4 Click Close to close Connection Manager.

Disconnecting from a Data Source
Disconnecting from a data source means disconnecting from a live connection to the server.
The data source connection is still displayed in Connection Manager until you delete it.
Disconnect from a data source when you do not need to retrieve data from it.

➤ To disconnect from a data source:

1 Select Hyperion > Connection Manager. For Office 2007, click Connect in the Connections section of the
Hyperion ribbon.

2 In the Connection Manager dialog box, select the data source you want to disconnect from and click
Disconnect.

Note:

The Disconnect and Connect buttons toggle, depending on the status of the selected data source.

3 Click Close to close Connection Manager.
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Changing Passwords for Essbase
If you are connected to Essbase, you can update your password whenever it expires or when you
want to change it for security purposes.

Note:

Changing passwords using Smart View is not supported for clusters, only for standalone Essbase
computers. However, an administrator can change passwords for clusters using Administration
Services Console.

➤ To change your password:

1 Select Hyperion > Connection Manager. For Office 2007, click Connect in the Connections section of the
Hyperion ribbon.

2 Connect to Oracle's Hyperion® Provider Services.

3 Click Change Password.

4 In the Change Password dialog box, enter the existing password in the Current Password text box.

5 Enter the new password in the New Password text box.

6 Enter the new password again in the Confirm Password text box.

7 Click Change Password.

Checking for Active Connections
You can check for all active connections in your Excel session. You can have multiple connections
at a time. This feature is useful, especially if you have added many data source connections in
Connection Manager and need to quickly find out what connections are being used.

To check for active connections, from the Hyperion menu, select Active Connections. The data
sources to which you are connected are listed.

Resetting Connections
To disconnect a worksheet from its current connection to a data source, select Hyperion > Reset
connection.

Using the Shortcut Menu
Features in Connection Manager are also available using shortcut menus. When you right-click
your mouse inside Connection Manager, these commands are available:

● Add

● Edit
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● Delete

● Connect

● Set As Default

Shortcut menus provide an alternate way of accessing Smart View commands.
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This chapter explains basic Smart View concepts for working with data forms. Smart View
enables you to export Planning, Financial Management, and Hyperion Enterprise data forms to
Microsoft Excel. Using Smart View, you can work with data forms either online connected to
the Planning or Financial Management or Hyperion Enterprise server, or offline disconnected
from the server.

Working with Data Forms in Excel Worksheets
You can use the functionality of Excel with Planning, Financial Management, and Hyperion
Enterprise data forms. You can view data form data and instructions, create formulas, and format
the color and text in a grid. You cannot create formulas in Hyperion Enterprise data
forms.Financial Management supports data forms, but the Financial Management Add Member
functionality is not supported in data forms opened in Smart View.

When you import a data form into Excel, Smart View retains the customization for the data
form. Although you cannot modify the data form structure, you can modify data values in the
data form. You can create numeric analyses and calculations for the data, which are preserved
in the worksheet when the data form is brought back to the server. This feature provides faster
analytic capability, especially when you work with data forms offline.

Note:

Applying a different data source to a sheet containing a data form than the data source originally
used to create the data form is not supported.
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Note:

Excel worksheets are always protected to avoid entering data for read-only cells. Therefore, some
Excel functions, such as AutoSum and F9, are disabled.

When you work with data forms rendered in Excel with Smart View:

● Member names are indented based on their level in the hierarchy. They are also indented if
you print the data form to a PDF file.

Note:

Financial Management and Hyperion Enterprise data forms are custom-formatted and do
not have indentation.

● For members with aliases, if the administrator selected the Display Alias option, aliases are
displayed on the rows, columns, page, and POV.

● Values submitted back to the database from Excel must be non-formatted data.

● If a data form is currently loaded in Excel and the administrator changes the data form
definition on the server side, Hyperion recommends that you close the data form and reload
it. This action ensures that the newest data form definitions are displayed.

● Multiple levels in an outline are displayed differently in Smart View than pages on the
Planning Web application. Smart View displays up to four levels, while the Web application
displays up to two levels.

● If a Planning administrator hides a dimension in the row axis of a Planning data form, this
dimension does not display in the row header of the data form in Smart View.

For information about working with data forms in an Excel worksheet, see the following topics:

● “Opening Data Forms in Excel” on page 45

● “Navigating in Data Forms” on page 45

● “Viewing Data Form Instructions” on page 45

● “Viewing Multiple Data Forms in Excel” on page 46

● “Selecting Members for Financial Management and Hyperion Enterprise Data Forms” on
page 46

● “Selecting a Range of Cells” on page 48

● “Saving Custom Formats” on page 48

● “Copying and Pasting Cells” on page 49

● “Entering Percentage Values in Planning” on page 49

● “Entering Date Values in Planning” on page 49

● “Writing #Missing Values” on page 50

● “Adding Cell Text” on page 50

● “Subtotaling Values in Planning” on page 51
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Opening Data Forms in Excel
When you open a data form in Excel, the data form displays existing values for the selected
members. You can enter new values or change the existing values.

If you open a group of data forms simultaneously, each is opened in a separate worksheet in the
current workbook. Enough worksheets are created to accommodate them all.

➤ To open a data form:

1 Open Excel and connect to a data source. See “About Connection Manager” on page 34.

2 Select Hyperion  > Forms > Select Form.

The Select Form dialog box displays the Hyperion Enterprise, Essbase, Financial Management,
Planning, and Workforce Planning data forms to which you have access.

3 From Folders, select the folder that contains the data form you want to open.

4 From Forms, select the data form or forms you want to open.

5 Optional: To view any instructions associated with the data form, click View Instructions.

6 Click OK.

For Hyperion Enterprise, the Member Selection dialog box displays after you open a data form
in Excel. To select members for the data form, perform step 3 to step 10 in “Selecting Members
for Financial Management and Hyperion Enterprise Data Forms” on page 46. Alternatively,
you can click the OK tab in the Member selection dialog box to update the POV drop down lists
with the default POV dimension members of the Hyperion Enterprise data source.

Navigating in Data Forms
You can use the following methods to navigate a data form:

● Press the arrow keys to move forward, backward, up, or down in a data form.

● Press Tab to move to the next cell in the row. Press Shift+Tab to move to the previous cell.

● Press Enter to move to the next cell in the column. Press Shift+Enter to move to the previous
cell.

● To navigate among open data forms, click the worksheet tabs at the bottom of the grid.

Viewing Data Form Instructions
Your administrator may have included information to guide you in preparing data, or to explain
the information shown on the data form. For Hyperion Enterprise data forms , the administrator
can include the name and descriptions of data forms. You can view the instructions or
descriptions associated with a data form.

➤ To view the instructions for a data form in Excel:

1 On the Select Form page, select a data form and click View Instructions.
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If the data form is already displayed in Excel, select Forms > Instructions.

2 When you finish reading the text, click OK to close the Instructions window.

Viewing Multiple Data Forms in Excel
You can view multiple data forms in Excel at the same time.

➤ To view multiple data forms in an Excel workbook:

1 Select the workbook that contains the data forms that you want to view.

2 From the Window menu, select New Window.

3 Select the data form that you want to view.

4 From the Window menu, select Arrange to select how you want the worksheets to be displayed.

Tip:

To view only sheets in the active workbook, select Windows of Active Workbook.

Selecting Members for Financial Management and Hyperion
Enterprise Data Forms
You can select the POV dimension members for the data form. After you select members, the
POV drop-down lists are updated with your selections.

You use the Member Selection dialog box to select POV dimension members. You can view
labels or descriptions for dimension members. For example, when you select to view
descriptions, the P_Series member is displayed as “P_Series - Phones and PDAs”.

You can also search for POV dimension members. For more information, see step 8 on page
47.

➤ To select dimension members:

1 From any POV drop-down list, click the Ellipsis button (...) to open the Member Selection dialog box.

2 Select a member to open the Member Selection dialog box.

3 From the Dimension drop-down list, select a dimension.

4 To expand or collapse the list of members, use one of the following methods:

● Click the Expand (+) button to expand all members under the highlighted parent, or click
the Collapse (-) button to collapse all members.

● Click the expand (+) and collapse (-) signs next to dimension members to expand or collapse
them.

5 Optional: To display active entities only, select Active Members.
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Note:

The Active Member option is available only if the application has been set up for Organization
by Period. For information on Organization by Period, see the Hyperion Financial Management
– System 9 Administrator’s Guide. The Active Member option is not supported for Hyperion
Enterprise data source.

6 Highlight a member, then use one of the following methods to select members:

● To select individual members, select the check box next to each member that you want to
use.

● To select all members for the highlighted member, click the Select button, .

● To select all immediate children for the highlighted member, click  and from the drop-
down list, select Children.

● To select all base members for the highlighted member, click  and from the drop-down
list, select Base Members.

Tip:

To deselect members, click Select None, .

7 Click Add, , to move the selected members to the Selection list.

Tip:

To remove members from the Selection list, select the members, then click Remove, . To

remove all members from the Selection list, click Remove All, .

8 Optional: To search for members in the selected dimension, complete the following steps:

a. Click  and enter the member name or pattern for which you want to search in the text
box.

You can enter the start of a text pattern for the search, or you can use a trailing asterisk as
a wildcard symbol. For example, to find EastSales, you can enter “east” or “ea*.'

b. Click  to find the first member within the dimension that matches the search criteria.

Select the check box next to the member if you want to use it and then click .

c. Click  again to search for the next occurrence and, if you want to use the member,

select the check box next to the member and click .
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Tip:

If you are at the bottom of the member list, click  to find the next member that matches
the search criteria.

9 Optional: To reorder members in the Selection list, click the Up or Down arrows or the Make Lowermost
and Make Topmost buttons above the list to move members.

10 When you finish selecting members, click OK.

Selecting a Range of Cells
You can select any group of cells in a data form as long as the selection is rectangular and
contiguous.

After you select a group of cells, you can copy and paste them, or adjust and spread data values
in them. For more information, see “Copying and Pasting Cells” on page 49 and “Adjusting
and Spreading Data Values” on page 57.

Saving Custom Formats
Customization of a data form in Excel is preserved only if the customization was done outside
of the main grid. Customization to the grid is not preserved except for the thousands and
decimals separators.

Note:

In Excel 2002 (XP) and Excel 2003, you change the thousands and decimal separators by selecting
Tools > Options > International. To specify a new separator, enter a new separator in the Decimal
separator or Thousands separator boxes. Additionally, the thousands separator must be enabled
and selected from Hyperion > Options > Display tab > Use Thousands Separator.

Searching for a Page in Planning
If the Planning administrator sets up multiple page dimensions for a form, you select the page
with the data you require from the page drop-down.

➤ To search for a page in Planning:

1 Click in the page dimension you want to search to highlight it.

2 Optional: The page drop-down can contain hundreds of pages. To find a page in a long list, type one or more
characters of the page name you want. For example, to search for USD in the currency page, type U.

If the characters you type match the name of a page, the full name of the page is displayed in the
page drop-down.

3 Select the page name containing the data with which you want to work.
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Copying and Pasting Cells
In Excel, you can copy data values within a data form, and from one data form to another. In a
single copy and paste operation, you can copy values from one cell to another cell, from one cell
to many cells, or from many cells to many cells.

Note:

If you copy and paste a value with supporting detail in the main grid, only the value is copied
and pasted, and not the supporting detail.

➤ To copy and paste data:

1 Select the worksheet in which you are copying and pasting cells.

Tip:

If the worksheet is protected, select Tools > Protection > Unprotect Sheet.

2 Select the cell or group of cells that contain the data that you want to copy.

For information on selecting multiple cells, see “Selecting a Range of Cells” on page 48.

3 Right-click and select Copy to copy the values in the selected cells to the clipboard.

To copy data in other applications, use that application’s Copy command.

4 Select the cell or group of cells to which you want to paste the data.

5 Click Paste.

Note:

If you try to copy and paste using Ctrl+C and Ctrl+V twice, the value is not copied the second
time.

Entering Percentage Values in Planning
If a Planning administrator has set the data type for a member to Percentage, the member is
displayed with a percent sign (%) in its cell. When you change a percentage value, Smart View
accepts the new value and displays a percent sign.

Entering Date Values in Planning
If a Planning administrator sets Date as a member's data type, the member is displayed as a date.
The default date format is DD/MM/YY. When you change a date, Smart View accepts the new
value and displays it. If a member's data type is not Date, you cannot successfully enter a date
in the cell.
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Writing #Missing Values
A cell that displays #Missing has no data value in the data form. You can enter a data value by
selecting the cell and entering the value. You can also eliminate irrelevant data in a cell by selecting
the cell with the irrelevant data and replacing the data with #Missing.

You can submit a data form to write #Missing values to the database. If you replace #missing
with a character (for example, a dash (-)), you can place a dash in the cell and submit that to the
database, too. After you select the cells that you want to contain #Missing, press the Delete key
or enter #Missing. The cells are set to #Missing when you save the data form.

Note:

#Missing is different from zero. Zero is a data value, and #Missing indicates lack of a data value
for the cell. #Missing decreases the size of the database and positively impacts system
performance. On data forms that are designed to suppress missing data, rows that contain cells
with #Missing values are not displayed after the data form is reloaded.

Note:

You can choose to have Smart View display numeric zeroes instead of #Missing or other text.
See “Replacement Labels for Data” on page 206.

Adding Cell Text
You can add annotations called cell text to the cell at any level. You can add cell text at the
summary time period level and across multiple dimensions at any level. You can also add cell
text for non-level zero members (bottom-up versions), calculated cells (Dynamic Calc), and
read-only cells, such as explanations for data analysis of variances and rolling forecasts.

When you work with cell text, keep in mind that you can also use supporting or line item detail
to add comments to data. You can use supporting detail to build and communicate bottom-up
values, such as travel, for which you need to calculate aggregate values. Cells that contain text
are indicated by a dark blue border around the cell.

➤ To add cell text:

1 Open a data form, using the procedure described in “Opening Data Forms in Excel” on page 45.

2 In the data form, select a cell or a range of contiguous cells.

3 Select Hyperion > Cell Text. For Office 2007, click Cell Text in the Task section of the Hyperion ribbon.

4 In the Cell Text window, enter the text that you want to add.

You can add up to 2000 characters of cell text for each cell. If you selected a range of cells, you
can enter cell text in a separate text box for each cell.

5 Click OK.
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Viewing and Editing Cell Text
You can use the Cell Text window to view cell text for a single cell or for a range of contiguous
cells. You cannot view cell text directly in a data form.

➤ To view or edit cell text:

1 Open a data form, using the procedure described in “Opening Data Forms in Excel” on page 45.

2 In the data form, select a cell or a range of cells that contain cell text.

When a cell contains cell text, an indicator is displayed in the cell.

3 Select Hyperion > Cell Text. For Office 2007, click Cell Text in the Task section of the Hyperion ribbon.

4 In the Cell Text window, view or edit the text.

If you selected a range of cells that contain cell text, a separate text box is displayed for each cell.

5 When you finish viewing or editing cell text, click OK.

Submitting Cell Text in Planning
After you enter or edit cell text in a Planning form, you can submit it to the Planning database.

➤ To submit cell text to the Planning database:

1 Open the data form, if necessary, using the procedure described in “Opening Data Forms in Excel” on page
45.

2 Edit the cell text.

3 Select Hyperion > Submit Data to save the text to the database. For Office 2007, click Submit in the
Review section of the Hyperion ribbon.

A blue triangle in a cell's upper right corner indicates that it contains cell text.

Subtotaling Values in Planning
The following points explain how values are subtotaled and totaled in data forms:

● Dimension member subtotals are calculated based on factors such as the hierarchies and
logic of the Essbase outline and the member properties an administrator sets.

● If the Calculate Data Form calc script is selected to launch during a save operation, all
subtotals in the data form are recalculated based on their members’ aggregation properties
and the design and layout of the data form.

● When data is saved, Essbase automatically calculates members that are set to dynamically
calculate, so the data form does not require a calc script to calculate these members. This
Essbase calculation excludes level 0 members.

● Calculations are based on stored values, which are not necessarily the same as displayed
values. For example, the values that you see in the data form may be based on scaling or on
precision settings.
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● Only members displayed on the data form are calculated.

● If you have read but not write access to a member, subtotals correctly include its value even
though it is read-only.

● If a Calculate Data Form business rule is associated with the data form, subtotals are
calculated automatically when the script is launched. See “Executing the Calculate Data
Form and Calculate Currencies Business Rules” on page 56 for more information.

Changing a Data Cell's Currency in Planning
If a Planning administrator enabled the functionality, you can enter data in a currency other
than a cell's base currency. Currencies in the drop-down list can be designated as the local
currency.

Note:

To override the base currency for an entity, the cell must be displayed in the local currency, and
its version must be bottom-up. The application must be a multi-currency application and the
data form should support multi-currency.

➤ To enter cell data in a local currency other than the base currency for the cell:

1 In a data form, select a local currency member for the cell.

2 Optional: To look up the currency's code, select View > Currency.

Available Currencies shows the application's currencies. Note the Currency Code for the
currency you want to work with, and close the window. If you cannot select View > Currency,
multiple currencies are not enabled for this application or data form.

3 In the right column, HSP_InputCurrency, type the new Currency Code in the data cell.

Typing the currency code in the data cell overrides the base currency for the entity.

4 Click Submit to submit the new currency code to the Planning server.

5 Enter the currency value in the left column, HSP_InputValue, of the data cell.

6 Click Rules on Form  and select the Calculate Currencies rule to calculate and save the new currency value.

If the Calculate Currencies calc script is set to run when the data form is saved, and the data
form is enabled for multiple currencies, the data value is displayed in the currency you selected.

Submitting Data
You can submit data to the data source in either connected or disconnected mode. Submitting
data in offline mode is not supported for Hyperion Enterprise.

In valid ad hoc and data form grids in Excel, you can modify and save data (any type) when
Smart View is disconnected from the data source and then submit your modified data to the
data source when you reconnect.
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If you modify member names, however, you trigger free-form mode and must refresh the data
before submitting it. Because refreshing replaces data in the worksheet with data from the data
source, your modifications are lost before you submit them.

Note:

Smart View must be installed on the client computer; otherwise, you lose your changes when
you submit the data. In addition, there must not have been changes to the form, user privileges,
or other settings on the server.

The following rules apply when data is submitted:

● All dimensions must appear in the same axis as they did before the data was synchronized.
For example, if accounts were on the row when you loaded the data form into Smart View,
then they must be on the row on the server when the you submit the data form. If not, you
receive an error message. This is true for all axes (rows, columns, pages and POVs).

● All pages must appear in the same order as when the data form was loaded. If not, you receive
an error message.

● You can change the order of the dimensions in the row or column. For example, if the data
form had Entities and Accounts on the row, and you reverse this order and submit the data
form, when you save the data form, all the data is written to the correct members.

● When using Financial Management or Hyperion Enterprise forms, you can lock any cell or
range of cells to apply cell protection until the data is refreshed or submitted. Note that
locking the cell does not lock the actual data cube in Financial Management, but only the
cell in the form. When the data is refreshed or submitted, the cell is no longer locked.

If all of these rules are followed, the grid is saved. In some cases, some of the cells submitted may
no longer exist on the data form. This can occur when the data form definition changes, when
rows/columns are suppressed, or when access privileges change. In these cases, only the cells that
are writable and exist on the new data form definition are saved. However, you will see a message
that some of the cells were not saved.

This applies to both cells and supporting detail changes, and also applies to both online and
offline modes.

➤ To submit data to the data source, select Hyperion >   Submit Data. For Office 2007, click
Submit in the Review section of the Hyperion ribbon.

Working with Business Rules for Planning
You can launch business rules and calculation scripts that recalculate data in Essbase. The
relevant data form in Excel is updated with the new data. The calculation scripts you can access
are shown by plan type.

When you launch a business rule, the rule can display a runtime prompt, asking you to enter
information.
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If a calculation is successful, the values in the Essbase database reflect the results.

For more information about business rules, see:

● “Launching Business Rules in Excel” on page 54

● “Launching Business Rules From a Data Form” on page 54

● “Entering Runtime Prompts for Business Rules” on page 55

● “Executing the Calculate Data Form and Calculate Currencies Business Rules” on page
56

Launching Business Rules in Excel
You can launch business rules that recalculate data in Essbase.

➤ To launch a business rule in Excel:

1 Open a data form, using the procedure described in “Opening Data Forms in Excel” on page 45.

2 Save any unsaved data in the spreadsheet.

Any data not saved on the spreadsheet is lost when you launch a business rule.

3 Select Hyperion > Calculation Options > Business Rules.

The Business Rules dialog box is displayed.

4 In the Plan Type frame, select the plan type associated with the rule you want to use.

5 Select a rule from the rules listed for that plan type, then click Launch.

If the business rule contains runtime prompts, complete step 2 of “Entering Runtime Prompts
for Business Rules” on page 55.

If the calculation is successful, the values in the Essbase database reflect the results of the
calculation.

6 Click Close.

7 To view the new values in the data form, select Hyperion > Refresh. For Office 2007, click Refresh  in the
Review section of the Hyperion ribbon.

Launching Business Rules From a Data Form
Sometimes one or more business rules are associated with a data form.

➤ To launch a business rule associated with a data form:

1 Open a data form, using the procedure described in “Opening Data Forms in Excel” on page 45.

2 Save any unsaved data in the spreadsheet.

Any unsaved data on the spreadsheet is lost when you launch a business rule.

3 Select Hyperion > Calculation Options > Rules on Form.
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4 Select a rule from the rules listed, then click Launch.

If the business rule contains runtime prompts, complete step 2 of “Entering Runtime Prompts
for Business Rules” on page 55.

If the calculation is successful, the values in the Essbase database reflect the results of the
calculation.

5 To view the new values in the data form, select Hyperion > Refresh. For Office 2007, click Refresh  in the
Review section of the Hyperion ribbon.

Entering Runtime Prompts for Business Rules
When you launch a business rule or save a data form that launches a business rule as a property
of the data form, the rule can issue a runtime prompt, which prompts you to enter information.
When you work with runtime prompts, keep the following points in mind:

● If a business rule has a runtime prompt and Use Members on Data Form is selected by an
administrator in Planning, the default member on the runtime prompt window matches
the current member in the page and/or the POV selection of the open data form.

● Members on the Member Selection page are filtered by the current user’s security definitions
and by any limitations set for the runtime prompt (for example, only Descendants of Q1).
You cannot select a shared member in a runtime prompt.

● You can launch Essbase calculation scripts from Smart View, but you cannot launch
graphical business rules and enhanced calculation scripts.

➤ To enter a runtime prompt for a business rule:

1 Launch a business rule that has a runtime prompt, using the procedure in “Launching Business Rules in
Excel” on page 54.

If you select Submit Data on a data form that has been designed to launch a business rule when
saved, the Runtime Prompts dialog box is displayed automatically, if necessary.

2 In the Runtime Prompts dialog box, enter the necessary information.

The icon in front of the prompt indicates the type of expected input, as shown in the following
table:

Icon Expected Type of Input

Single member selection

Multiple member selections

Numeric value
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Icon Expected Type of Input

Text value

Note: Text value is for use only with enhanced calc scripts. String type cannot be used with Graphical
Scripts.

Dimension from the database

Note: Dimension is for use only with enhanced calc scripts. Dimension type cannot be used with Graphical
Scripts.

3 Click Launch.

If the calculation is successful, the values in the Essbase database reflect the results of the
calculation.

4 To view the new values in the data form, select Hyperion > Refresh. For Office 2007, click Refresh  in the
Review section of the Hyperion ribbon.

Executing the Calculate Data Form and Calculate Currencies
Business Rules
Use the Rules on Form command to select and execute the Calculate Data Form and Calculate
Currencies business rules.

The Calculate Data Form business rule is created for each data form to calculate subtotals. The
Calculate Currencies business rule is created for data forms that include multiple currencies in
a row, column, or page to enable the conversion of values among available currencies.

The order in which business rules are launched is very important and may affect the data. If you
plan to launch both Calculate Data Form and the Calculate Currencies business rules, it is
important that you run the conversions first, before subtotaling the data form.

➤ To launch the Calculate Data Form and Calculate Currencies business rules in Excel:

1 Open a data form, using the procedure described in “Opening Data Forms in Excel” on page 45.

Any data that is not saved on the spreadsheet is lost when you launch the business rule.

2 Select Hyperion > Calculation Options > Rules on Form.

The business rules associated with the data form are displayed in the Business Rules dialog box.

3 Complete one or both of the following actions:

● To convert currencies, select Calculate Currencies.

● To calculate subtotals, select Calculate Forms.

4 Click Launch.

If the calculation is successful, the values in the Essbase database reflect the results of the
calculation.
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Adjusting and Spreading Data Values
You can make adjustments to data values in a data form using the following methods:

● Adjust values by increasing or decreasing by a numeric value or percentage

● Spread values over a range of cells

Note:

Financial Management and Hyperion Enterprise does not support spreading data, but
Planning, Hyperion Enterprise, and Financial Management support adjusting data.

You cannot adjust a data value if the member dimension is read-only or if the value is null (that
is, if the value is #Missing).

For instructions on adjusting data values and spreading, see the following topics:

● “Adjusting Values” on page 57

● “Spreading Data for Time Periods” on page 58

● “How Spreading Data Works” on page 58

● “Spreading Data with Cell Locking in Planning” on page 62

● “Examples of Spreading Data with Cell Locking” on page 62

Note:

In the Options dialog box, Display tab, if you specified a non-numeric symbol for missing
values (for example, a hyphen) in the #NoData/Missing Label text box, you cannot use the
Adjust Data feature.

Adjusting Values
You can adjust the value of cells in a data form by a specified number or percentage if the cells
contain numerical data and are not read-only. You can adjust data for multiple cells if the cells
are all at the same level (for example, you can adjust data for February and March in the same
operation, but not for March and Q1).

➤ To adjust data values:

1 Open a data form, using the procedure described in “Opening Data Forms in Excel” on page 45.

2 In the data form, click the data cell that contains the value that you want to adjust.

3 Select Hyperion > Adjust. For Office 2007, click Adjust  in the Task section of the Hyperion ribbon.

The Adjust Data dialog box is displayed.

4 Select an option:

● Increase Selected Cells by fixed Percentage

● Decrease Selected Cells by fixed Percentage
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● Add Fixed Value to Selected Cells

● Subtract Fixed Value from Selected Cells

● Multiply Selected Cells by a Fixed Value

● Divide Selected Cells by a Fixed Value

5 In the text box, enter the percentage or number by which you want to adjust the value of the cell.

6 Click Adjust Data.

Tip:

For information on how adjusting data can affect other cells, see “How Spreading Data Works”
on page 58.

Spreading Data for Time Periods
While working with a Planning data form page in Excel, you can spread, or distribute, values in
several ways (Financial Management does not support spreading data):

● Spread the value of a summary time period to its base time periods or to the first parent or
first child of the parent time period

● Spread values among children and parents proportionally, based on existing distribution

● Spread values based on the weekly distribution of a quarter, which could be 4-4-5, 5-4-4,
4-5-4, or None (as set up by the budget administrator)

● Temporarily lock the values of certain cells while spreading data over time periods

Note:

You cannot spread data in a summary time period that includes members with mixed
currency types.

➤ To spread data for time periods:

1 Open a data form, using the procedure described in “Opening Data Forms in Excel” on page 45.

2 Enter the new value in the selected cell.

The value is distributed according to the rules in the table on “How Spreading Data Works” on
page 58.

3 Click Save.

How Spreading Data Works
Factors like account type, existing distribution, member hierarchies, and data type affect how
values are distributed. Whether or not a cell is locked also affects data distribution. For
information on spreading data with locked cells, see “Spreading Data with Cell Locking in
Planning” on page 62.
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The following examples show the results if you enter or change a currency or non-currency
value.

Time Balance Property of the Account New Value Distribution Examples

FLOW Revenue, Expense, Saved
Assumption (where the Time Balance
property is set to Flow)

To all children and parents proportionally,
based on the existing distribution. The new
value affects the entire summary period roll
ups hierarchy so that the parent time period
is always the sum of its children.

If there is no existing distribution (that is, if
the values for all children are zeros or
#Missing) and the changed value is a
quarter, the new value spreads down
proportionally, based on the weekly
distribution, which can be 4-4-5, 4-5-4,
5-4-4, or evenly if the account's spreading is
set to None).

If the changed parent is a year Total or some
other kind of summary time period, the value
is spread evenly.

Example 1

You change Qtr 1 from 250 to 500. Before
the change, the months of Qtr 1 have the
following values:

Jan = 100

Feb = 50

Mar = 100

Result: The 500 is distributed to the children
of Qtr 1 proportionally, replacing previous
values as follows:

Jan = 200

Feb = 100

Mar = 200

The 500 is aggregated to the parents of Qtr
1. If Year Total was formerly 1000, its new
value is 1250.

Example 2

You change March from 100 to 200.

Result: March, Qtr 1, and Year Total all
increment by 100. Jan and Feb remain
unchanged.

FIRST All types of Accounts Upward to its first parent and downward to its
child only if the changed cell is the first child
of its parent time period.

The summary time period is always equal to
the first of its child time periods.

If there is no existing distribution (that is,
values for all the children are zeros or are
missing), the new value is copied to each of
the children.

Example 1

You change Qtr 1 from 20 to 40. Before the
change, the months of Qtr 1 have the
following values:

Jan = 20

Feb =15

Mar = 05

Q1 = 20

Result: The 40 is distributed to the children
of Qtr 1 proportionally, replacing their
previous values as follows:

Jan = 40

Feb = 15

Mar = 05

Q1 = 40

BALANCE Asset, Liability, Equity, Saved
Assumption (where the Time Balance
property is set to Balance)

Downward to the last child and upward to the
parent only if the changed cell is the last child
of its parent time period.

Example 1

You change Qtr 1 from 30 to 50.
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The summary time period is always equal to
the last of its child time periods.

If there is no existing distribution (that is, if
the values for all children are zero or missing),
the new value is spread across the children.

Result: March also changes to 50. Jan and
Feb do not change. Year Total does not
change because Qtr 1 is not the last child of
Year Total.

Example 2

You change Qtr 4 from 100 to 50.

Result: Dec changes to 50 because it is the
last child of Qtr 4. Oct and Nov remain
unchanged, as do quarters 1, 2, and 3. Year
Total changes to 50 because Qtr 4 is the last
child of Year Total.

Example 3

You change Qtr 2 to 100. Before the change,
the months of Qtr 2 have the following
values:

Apr = 0

May = 0

June = 0

Result:

Apr = 100

May = 100

June = 100

Year Total is unchanged.

AVERAGE Revenue, Expense, Saved
Assumption, (where the Time Balance
property is set to Average)

To all the children and the parents
proportionally, based on the existing
distribution. The new value affects the entire
summary time period roll ups hierarchy so
that the parent is always the average of its
children.

Assumes an equal number of days in each
period, such as 30 days for each month.

Example 1

You change Qtr 1 from 5 to 10. Before the
change, the months of Qtr 1 have the
following values:

Jan = 05

Feb = 10

Mar = 00

Q1 = 05

Result:

Jan = 10

Feb = 20

Mar = 00

Q1 = 10

AVG_365  Revenue, Expense, Saved
Assumption, (where the Time Balance
property is set to Average)

Weighted daily average based on 365 days
in a year, assuming that February always has
28 days. This does not account for leap years.

As you work with AVG_365, keep these
points in mind:

Example 1

You enter values for Jan, Feb, and Mar. For
any year, including leap years, February is
assumed to have 28 days, and Qtr 1 is
assumed to have 90 days.

Value Entered Number of Days
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● You cannot customize month labels,
although you can use aliases.

● Years must have twelve months, and
quarters must be the sum of three base
months.

● You cannot change the fiscal start month
after the application is set up.

● All months are included in the
calculation. #Missing is treated as 0 in
the numerator, and all of the days are
included in missing months in the
denominator. Thus, for example, QTR
means three months, not QTD, and Total
Year means all twelve months, not YTD.

Jan = 9,000 31

Feb = 8,000 28

Mar = 8,000 31

Q1 90 (the total days for Jan, Feb, and
Mar)

Result:

Q1 = 8,344

The average for Qtr 1 is calculated as follows:
(1) Multiply the value for each month in Qtr1
by the number of days in that month, (2) sum
the values, and (3) divide the total by the
number of days in Q1. Using 28 for the
number of days in Feb and 90 for the number
of days in Q1, the result is as follows: (9,000
* 31 + 8,000 * 28 + 8,000 * 31) / 90 =
8,344

AVG_ACTUAL Revenue, Expense, Saved
Assumption, (where the Time Balance
property is set to Average)

Weighted daily average based on the actual
number of days in a year. This accounts for
leap years, in which February has 29 days.

As you work with AVG_ACTUAL, keep these
points in mind:

● You cannot customize month labels,
although you can use aliases.

● Years must have twelve months, and
quarters must be the sum of three base
months.

● You cannot change the fiscal start month
after the application is set up.

● All months are included in the
calculation. #Missing is treated as 0 in
the numerator, and all days are included
in missing months in the denominator.
Thus, for example, QTR means three
months, not QTD, and Total Year means
all twelve months, not YTD.

Example 1

For a leap year, you enter values for Jan, Feb,
and Mar. February is assumed to have 29
days, and Qtr 1 is assumed to have 91 days.

Value Entered Number of Days

Jan = 9,000 31

Feb = 8,000 29

Mar = 8,000 31

Q1 91 (the total days for Jan, Feb, and
Mar)

Result:

Q1 = 8,341

The average for Qtr is calculated as follows:
(1) Multiply the value for each month in Qtr
1 by the number of days in that month, (2)
sum these values, and (3) divide the total by
the number of days in Q1. Using 29 for the
number of days in Feb and 91 for the number
of days in Q1, the result is as follows: (9,000
* 31 + 8,000 * 29 + 8,000 * 31) / 91 =
8,341

Example 2

For a non-leap year, you enter values for Jan,
Feb, and Mar. February is assumed to have
28 days, and Qtr1 is assumed to have 90
days.

Value Entered Number of Days

Jan = 9,000 31

Feb = 8,000 28
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Mar = 8,300 31

Q1 90 (the total days for Jan, Feb, and
Mar)

Result:

Q1 = 8,344

Using 28 for the number of days in Feb, and
90 for the number of days in Q1, the result
is as follows: (9,000 * 31 + 8,000 * 28 +
8,000 * 31) / 90 = 8,344

Spreading Data with Cell Locking in Planning
When spreading data over time periods, you can temporarily lock the values of one or more cells
to preserve their values when other values are recalculated. You can spread data across time
periods based on various calculations and visually review the changes before committing them
to the database. This breakback capability is useful when you have seeded your data, and you
want to manipulate and analyze values in specific accounts to produce desired results. To see
examples of how cell locking works with spreading, see “Examples of Spreading Data with Cell
Locking” on page 62.

➤ To temporarily lock values:

1 Open a data form, using the procedure described in “Opening Data Forms in Excel” on page 45.

2 In the data form, select the cell or group of cells that you want to lock.

3 Select Hyperion > Forms > Lock. For Office 2007, click Lock  in the Forms section of the Hyperion ribbon.

A color change indicates that a cell is locked. You can now spread or manipulate data in the
other cells however you want, without affecting the locked cells. (For information on how
Planning spreads data, see “Spreading Data for Time Periods” on page 58 and “How Spreading
Data Works” on page 58.).

4 To unlock a cell, select Hyperion > Refresh. For Office 2007, click Refresh  in the Review section of the
Hyperion ribbon.

Examples of Spreading Data with Cell Locking
Example 1

Account A has the following values before locking and spreading:

 Jan Feb Mar Q1

Account A 100 100 100 300
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In this example, you lock the Feb and Mar values at 100. You then change the value in Q1 from
300 to 600. Because Jan, Feb, and Mar must now total 600 and Feb and Mar are locked at 100
each, Planning calculates Jan to be 400 and fills in that value.

This is how the data is displayed after locking and spreading:

 Jan Feb Mar Q1

Account A 400 100 100 600

Example 2

Account B has the following values before locking and spreading:

 Q1 Q2 Q3 Q4 Year Total

Account B 100 100 100 100 400

In this example, you lock Q1 and Q2 values at 100 each. You then change Year Total from 400
to 800. Because the yearly total must equal 800 and Q1 and Q2 are locked at 100 each, Planning
calculates Q3 and Q4 to be 300 each and fills in those values.

This is how the data is displayed after locking and spreading:

 Q1 Q2 Q3 Q4 YearTotal

Account B 100 100 300 300 800

Working With Supporting Detail
Planning’s Supporting detail feature helps you build and communicate bottom-up values when
planning corporate expenses, such as travel, salary, and projects, for which you need to calculate
aggregate values. Supporting detail serves as a built-in calculator for developing data that is not
in the member outline. (Financial Management supports line item detail, but not supporting
detail.) Supporting detail can include text, values, and operators that define how data aggregates.

Supporting detail also provides a way to drill down into data to better understand its basis. For
example, if the bottom-level member in your outline is pens, you can add line items in supporting
detail for ballpoint, fountain, marker, and so on. Then you can aggregate the detail values to the
pen member in the outline.

When working with supporting detail, keep the following points in mind:

● Supporting detail does not change members in the Essbase outline structure.

● To enter, create, change, or delete supporting detail, you must have write access to cells. To
view supporting detail, you must have read access.

● You cannot enter, adjust, spread, or save data into aggregate values that have supporting
detail. Aggregate values with supporting detail are read-only.

● You can add supporting detail to both target and bottom-up versions.
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● You cannot add supporting detail to summary time periods, such as quarters. You can add
supporting detail only to base time periods (level zero members).

● Number and precision formatting is not reflected in the Supporting Detail window.

● The sequence of operators in supporting detail follows the logic that Essbase uses to process
multiple operators in a complex calculation.

● If numeric values are not defined for one or more cells, you can delete the undefined values
from Essbase. If you select to delete the undefined values, #Missing shows in the cells. If
you select not to delete undefined values, the values are left as is.

● If you copy and paste a value with supporting detail in the main grid, only the value is copied
and pasted, not the supporting detail.

● You can select multiple cells when adding supporting detail in online mode only. In offline
mode, you must add supporting detail cell by cell.

For more information about supporting detail, see:

● “Adding Supporting Detail” on page 64

● “Totaling When Supporting Detail Cells Are Blank” on page 65

● “Working with Supporting Detail Hierarchy” on page 66

● “Viewing or Changing Supporting Detail” on page 67

● “Synchronizing Supporting Detail with Essbase” on page 67

Adding Supporting Detail
Use the Supporting Detail window to set and change how detail items aggregate to cell values in
a data form. For information about using supporting detail, see “Working With Supporting
Detail” on page 63.

➤ To add supporting detail that calculates values in a data form:

1 Open a data form in Excel, using the procedure described in “Opening Data Forms in Excel” on page 45.

2 In the data form, select the data cells for which you want to add detail.

You can select a range of contiguous cells in a row or column in online mode only. You cannot
select a section of cells that include a combination of rows and columns. To add detail in offline
mode, you can select cells only on a cell by cell basis.

3 Select Hyperion > Supporting Detail. For Office 2007, click Supporting Detail  in the Task section of the
Hyperion ribbon.

The Supporting Detail window is displayed. This window reflects your cell selection in the data
form.

4 Replace the untitled text with an explanation or description.

You can include up to 1,500 characters of supporting detail. The text and its associated operator
must be unique among children of the same parent.
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5 Use the buttons to create or change the indented hierarchy to reflect the structure and calculations that you
want.

For example, you can click Add Child to add a line item directly below the selected item.

For more information about the structure that you can create, see “Working with Supporting
Detail Hierarchy” on page 66.

6 Set the mathematical relationships among the line items by selecting an operator for each line item.

You can select from these operators: + (add), - (subtract), * (multiply), / (divide), and ~ (ignore).
Selecting Ignore saves the item text without requiring a numeric value.

7 Enter data for the items for which you want to set or calculate values.

When you enter numbers into the Supporting Detail window, use the scaling that was set up for
the data values in the data form.

8 Click OK.

Values are dynamically calculated and aggregated before the data is saved.

Totaling When Supporting Detail Cells Are Blank
If a data cell in supporting detail is blank, the cell is not aggregated. Do not assume that a blank
cell means zero.

For example, you might define the following supporting detail to calculate the daily rate of hiring
an instructor ($250) times the number of days per month for which you plan to retain an
instructor (4 in January, but none in February). As shown in the following example, the
Instructor total for Feb is 250, even though you do not intend to hire an instructor in February:

 Jan Feb

Instructor 1000 250

Rate * 250 250

Days 4  

To correctly total values in this situation, do not leave the cell blank. Instead, leave the Rate cell
blank, or enter a zero in the relevant Days data cell, as shown below:

 Jan Feb

Instructor 1000 0

Rate * 250 250

Days 4 0

In the solution above, the rate (250) is multiplied by 0 (zero), resulting in a value of zero.
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Working with Supporting Detail Hierarchy
The supporting detail hierarchy should reflect the information that supports the cell values and
the mathematical operators that create the appropriate relationships.

➤ To create or change the supporting detail hierarchy:

1 Open a data form in Excel, using the procedure described in “Opening Data Forms in Excel” on page 45.

2 In the data form, select the cells with supporting detail with which you want to work.

3 Select Hyperion > Supporting Detail. For Office 2007, click Supporting Detail in the Task section of the
Hyperion ribbon.

The Supporting Detail window is displayed. This window shows your cell selection in the data
form.

4 Create or change the rows in the hierarchy that provide the detail for the data values by clicking an item and
selecting an option:

Option Result

Expand All Shows all levels of supporting detail

Collapse All Collapses all levels of supporting detail

Add Child Adds a new line item one level below the selected line item. You can add an unlimited number of
children, but keep in mind its potential impact on performance

Add Sibling Adds a line item at the same level as the selected cell. You can add an unlimited number of siblings,
but keep in mind the potential impact on performance

Delete Removes the selected line item

Delete All Removes all supporting detail at once

Promote Moves the selected line item to the next-higher level in the hierarchy

Demote Moves the selected line item to the next-lower level in the hierarchy

Move Up Places the selected line item before its preceding sibling

Move Down Places the selected line item after its sibling successor

Duplicate Row Adds a row below the selected item, duplicating the structure of the selected row (text, operator,
and values)

Fill For rows, copies the data from the current cell to the cells to the right of the current cell

Copy Copies data from the current cell

Paste Pastes data to a cell

5 Click Close.

The save operation stores the detail text and values and stores the aggregate values in the Essbase
database.

66 Working with Data Forms



Viewing or Changing Supporting Detail
Cells that have supporting detail are indicated in the Excel grid by a light green background.

You can select one cell or a range of contiguous cells in a row or column. You cannot select a
section of cells that includes a combination of rows and columns. Select cells that are in the local
currency if you need to write to them.

➤ To view or change supporting detail:

1 Open a data form in Excel, using the procedure described in “Opening Data Forms in Excel” on page 45.

2 In the data form, select the data cells for which you want to view or change detail.

You can select one cell or a range of contiguous cells in a row or column. You cannot select a
section of cells that includes a combination of rows and columns. Select cells that are in the local
currency if you need to write to them.

3 Select Hyperion > Supporting Detail. For Office 2007, click Supporting Detail in the Task section of the
Hyperion ribbon.

4 View or change the line items or the calculations that aggregate the data in the selected cells.

For instructions about adding and maintaining supporting detail, see “Adding Supporting
Detail” on page 64 and “Working with Supporting Detail Hierarchy” on page 66.

Synchronizing Supporting Detail with Essbase
In Planning applications, when you delete supporting detail for a cell, you affect the associated
value in the relational database. You specify how to handle the stored Essbase value. You can set
it to #Missing or leave it as it was before the supporting detail was deleted. This feature is useful
if you want to use supporting detail as a scratch pad or calculator.

➤ To synchronize supporting detail with Essbase:

1 Open a data form in Excel, using the procedure described in “Opening Data Forms in Excel” on page 45.

2 In the data form, click the cell that has the supporting detail you want to remove.

3 Select Hyperion > Supporting Detail. For Office 2007, click Supporting Detail in the Task section of the
Hyperion ribbon.

4 In the Supporting Detail window, delete the information, then click OK.

5 Select an option from the displayed message to specify how to handle the aggregate value of the deleted
supporting detail stored in Essbase:

● To delete the value from Essbase, click Yes, set the value(s) to #Missing.

● To leave the data value in Essbase as is, click No, leave the value(s) as is.
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Working with Formulas in Data Forms
When working with data forms, you can create Excel formulas to manipulate or analyze the data.
You can create formulas inside or outside the data form’s grid. If you want to, you can save the
formulas with the Excel workbook so that when you use the workbook again, the formulas are
preserved.

Note:

Formulas that reference data within the same grid are not supported.

You can create formulas:

● Inside or outside the data form’s grid

● On cells that have cell text

You cannot create formulas:

● On read-only cells or cells that are locked

● On cells that have supporting detail (in Planning) or line item detail (in Financial
Management)

Formulas are preserved even when you:

● Refresh the data form without saving the data

● Later open the saved .XLS worksheet

● Expand or collapse rows or columns

Formulas interact with other functionality in the following ways:

● For Planning only: You can spread data values using a formula in a summary parent cell.
Spreading logic ignores formulas in child cells. For example, you could enter a formula in
Qtr1 whose calculated value is spread over Jan, Feb, and March. However, if you enter a
formula in Feb, that cell is ignored when the value for Qtr1 is spread. For more information
about how data is spread, see “Adjusting and Spreading Data Values” on page 57

● If you move a referential formula, its cell references are updated to reflect its new location

● If you use the Suppress #Missing Rows feature on a cell that has a referential formula, the
cell references are not updated; the cell relationship is absolute, not relative

● If you use the Adjust feature to change the value of a data cell on which you have created a
formula, the adjusted values overwrite the formula

If you create formulas in the data form, you are prompted to save the workbook as an .XLS file
with the new formulas under the following conditions:

● You change the current page.

● You take a data form offline (this applies only to Planning).

● You select a different data form.

● You connect to a different data source.
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Even if you save the formulas with the workbook, you lose temporary access to the formulas if:

● You change the current page, data form, or data source.

● You take the data form offline.

Working with Smart Lists in Planning Data Forms
A Smart List is displayed in a Planning data form cell as an alphanumeric text description, but
stored in the database as a number. For example, an integer Smart List for a reporting cycle may
have values 1-5, for Yearly (1), Quarterly (2), Monthly (3), Daily (4), and Hourly (5). The values
that are displayed on the data form are Yearly, Quarterly, Monthly, Daily, and Hourly. When
you select one of these values on the form, and save the form, the number associated with it is
stored in the database. This saves you from memorizing the numeric values associated with each
time period in the reporting cycle.

You access Smart Lists from custom drop-down lists in Planning data form cells. When you click
into cells whose members are associated with a Smart List (as a member property), you select a
drop-down list option instead of entering data. In fact, you cannot type in a cell that contains a
Smart List. Smart Lists display in cells as down arrows that expand into lists when clicked.

For example, suppose a data form contains a Smart List named Justification that provides
selections for Research, Customer Feedback, and Expansion. When you click into Account cells
named Reason (whose members are associated with the Justification Smart List), a down arrow
is displayed. When you click the down arrow, it expands into a drop-down list containing:

● Research

● Customer Feedback

● Expansion

Select one of the Smart List options as the value for the cell.

Note:

Smart Lists must be set up and enabled by a Planning administrator before you can use them in
Smart View. For more information about enabling Smart Lists for data forms, see “Menus,
Enumerations, UDAs, and Formulas” in the Hyperion System 9 Planning Administrator’s Guide.

➤ To select a Smart List option in a data form cell:

1 Open a data form in Excel, using the procedure described in “Opening Data Forms in Excel” on page 45.

2 In the data form, click into a data cell containing a Smart List.

Note:

Only cells whose members are associated with Smart Lists (as a member property) contain Smart
List drop-down lists.

Working with Smart Lists in Planning Data Forms 69



A down arrow is displayed in the cell.

3 Click the down arrow in the cell.

The down arrow expands into a drop-down list.

4 Select an option.

The option you select is entered into the data cell.
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Query Designer Features
Query Designer is used to design report layouts and select members for queries in Essbase,
Financial Management, and Hyperion Enterprise data sources.

With Query Designer, you can:

● Design queries from default reports

● Extract queries from existing reports

● Enter and run MDX queries for advanced users

● Share queries with other users

Query Designer Worksheets
In Query Designer worksheets, some ad hoc operations are disabled when you design queries
but are enabled in the reports.

Operations enabled only after running queries:

● Formulas

● Asymmetric reports

● Comments
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● Blank rows or columns

● Changes to alias tables

● Ad Hoc actions such as zoom in and out, keep and remove only, and double-click

Operations allowed neither during query design nor after running the query:

● Filtering of column members

● Changing data sources in query mode

Note:

When using grids that contain duplicate (non-unique) members, the Member Name option
must be selected in the Options dialog box to display the qualified name in the worksheet (for
Essbase only). Ensure that duplicate members use fully-qualified member names.

You can create queries from a blank sheet. After retrieving a default report from an Essbase or
Financial Management or Hyperion Enterprise data source, run Query Designer and modify the
layout. See“Creating Queries from Default Reports” on page 72. Another use of Query
Designer is taking an existing report, such as one containing the budget for West Coast markets,
and extracting a basic query from the report. The query can then be modified. See “Extracting
Queries from Reports” on page 73.

Options such as suppress missing rows, repeat member names, and indentation are defined as
in ad hoc queries and can be set while working in the query sheet, but are not applied until after
you run the query.

You cannot change data sources in the same query worksheet. However, you can have multiple
Query Designer worksheets in the same workbook. For example, you can have one query sheet
connected to an Essbase data source and another connected to a Financial Management data
source.

Query Designer worksheets are designated by Sheetname - Query; for example, Sheet1 - Query.
If you have more than one query sheet, the sheet is given a different name, such as Sheet2 -
Query. After running a query, a report sheet is created with the name Sheetname - Report; for
example, Sheet1 - Report, and the query sheet, Sheetname - Query, becomes hidden. Selecting
Hyperion > Query > Query Designer enables you to view and modify the query sheet.

Queries can be saved as .xls files. You can use queries as templates and share them with other
users, who may want to run the same query or customize the query to their own needs.

Creating Queries from Default Reports
Starting with default reports, you can create queries.

➤ To create queries from default reports:

1 In Excel, connect to an Essbase or Financial Management or Hyperion Enterprise data source.

72 Query Designer



2 Select Hyperion > Query > Query Designer For Office 2007, click Query Designer in the Query section of
the Hyperion ribbon.

A worksheet called “Sheetname - Query” is created. It contains a default query (for example,
Sheet1 - Query) and a POV toolbar that contains dimensions and a dropdown menu of
dimension attributes.

3 From the POV toolbar, drag and drop dimensions and attributes either to columns or rows in the worksheet
or within the POV itself. You can also enter members directly into the grid.

If you want to select members or filters for the dimensions, click the dimension name on the
POV toolbar to invoke the Member Selection dialog box. See “Filtering Members in Queries”
on page 74.

4 Select Hyperion > Query > Run Report or click  on the POV toolbar.For Office 2007, click Run
Report in the Query section of the Hyperion ribbon.

The resulting report is displayed in a new sheet called “Sheetname -Report ;” for example, Sheet1
- Report. The report and query can be saved. The query is saved as part of the .xls file.

Note:

The .xls file that results from running the query can be saved for possible use as an Hyperion
Enterprise or Essbase data load data source.

Extracting Queries from Reports
Use Query Designer to extract queries from existing reports, which you can modify and share
with others.

➤ To extract queries from existing reports:

1 Open a report in Excel.

2 Connect to an Essbase or Financial Management or Hyperion Enterprise data source.

3 Select Hyperion > Query > Query Designer. For Office 2007, click Query Designer in the Query section of
the Hyperion ribbon.

A new sheet called “Sheetname - Query” is created. The sheet contains a query extracted from
the existing report; for example, Sheet1 - Query.

4 Modify the query.

For example, you can delete members, add members, or pivot to create different queries and
layouts.

Note:

Modifying the query does not preserve the format of the original report after running the query.

5 Select Hyperion > Query > Run Report or click  on the POV toolbar. For Office 2007, click Run
Report in the Query section of the Hyperion ribbon.
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The resulting report is displayed in a new sheet called “Sheetname -Report”; for example, Sheet1
- Report.

Editing Queries
You can modify queries. After you run a query, the Query Designer sheet, Sheetname - Query,
becomes hidden. You must run Query Designer again to view the Query Designer sheet.

➤ To edit queries:

1 Select the Query Designer sheet Sheetname - Query; for example, Sheet 1- Query.

If the Query Designer sheet is hidden, select Hyperion > Query > Query Designer. The Query
Designer sheet is displayed.

2 Edit the query, such as adding new members, pivoting, removing members, and specifying data filters.

3 Select Hyperion > Query > Run Report.For Office 2007, click Run Report in the Query section of the
Hyperion ribbon.

The report in Sheetname-Report is updated.

Note:

Rerunning queries regenerates the report, therefore any changes to the report, such as zooming
in on members and entering comments or formulas are lost.

Filtering Members in Queries
You can filter members during member selection for queries for Essbase and Hyperion
Enterprise. You can filter members for Essbase by:

● Children

● Descendants

● Levels

● Generation

● UDA (user-defined attributes; defined by the administrator)

● Attribute

● Subset of attribute dimensions to create conditional expressions

● Period

● Date range

You can filter members for Hyperion Enterprise. You can filter,

● Account dimension members by:

❍ Input
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❍ Calculated

❍ Dynamic

● Entity dimension members by:

❍ None

❍ Parent

❍ Base

❍ Parent + Base + Subentity

❍ Parent + Subentity

❍ Base + Subentity

❍ Parent + Base

● Period dimension members by:

❍ None

❍ <Scenario_Frequency>

❍ Daily

❍ Weekly

❍ Monthly

❍ Quarterly

❍ Trimester

❍ Half-Yearly

❍ Yearly

Using the Member Selection dialog box, specifying member filters inserts MDX syntax into the
grid. For example, to filter by descendents for the East market, the MDX syntax is
DESCENDANTS ([East]). You can modify the MDX statement by editing the cell. For example,
you can change the statement to DESCENDANTS ([West]) to filter members by descendents
of West. Other examples of MDX syntax include ([100].CHILDREN), ([Product].LEVELS
(1).MEMBERS), and ATTRIBUTE([True]). You can change the values to ([200].CHILDREN),
([Product].LEVELS(2).MEMBERS), and ATTRIBUTE([False]). If you type an invalid MDX
statement, an error message is displayed when you run the query. See “Filtering Members” on
page 83.

Note:

MDX queries are not supported for Hyperion Enterprise data sources.

Filtering Data
You can filter data in queries for Essbase data sources only. Filtering data limits the amount of
data returned to a specified top or bottom criterion. Top or bottom ranking enables you to view,
for example, the top 10 products in sales for a given region. 
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➤ To filter data:

1 In the report, select a dimension.

2 Select Hyperion > Query > Data Filter.

3 From Data Filter, under Count, select Top or Bottom and specify a number.

4 Under Set, click , and in Member Selection, select a row member for ranking, and click OK to return
to Data Filter.

5 Under Value, click , and in Member Selection, select a column member to run the ranking against,
and click OK to return to the Data Filter dialog box.

6 Click OK.

An MDX query, for example TopCount( { [Qtr3] }, 10, [Measures].[Profit]), that represents
your data filtering settings is inserted into the grid. The example returns the top 10 most
profitable products in quarter 3.

7 Select Hyperion > Query > Run Report. For Office 2007, click Run Report in the Query section of the
Hyperion ribbon.

The query results are displayed in the sheet.

Analyzing Time-Related Data in Query Designer
(Essbase only) Using Smart View, you can analyze flash metrics such as sales of cost of goods
sold against time-based metrics. This enables you to look for trends, find averages for different
time periods, and so forth. To do this, you use linked attributes which enable periodicity of
members. Periodicity is a shared pattern among time dimension members that make them
meaningful for time-based analysis (January and April share periodicity as first months of
quarters, for example). Day by month, day by week, and week by year are examples of linked
attributes. You can also set ranges for linked attributes and apply filters.

➤ To analyze time-related data in Query Designer:

1 Create a query as described in “Creating Queries from Default Reports” on page 72.

2 From the Query Designer toolbar, select Date-Time dimension and drag it to the grid or within the toolbar.

3 Click Date-Time in the Query Designer toolbar to open Member Selection, where you can select members
and apply Period, Range, and other filters as described in “Filtering Members in Queries” on page 74.

4 Under Attributes on the Query Designer toolbar, select an attribute or linked attribute in the dropdown menu,
then drag it to the grid or within the toolbar. Repeat as necessary for other attributes.

5 To select members and apply filters to an attribute, click the attribute name on the Query Designer toolbar
to open Member Selection.

6 Select Hyperion > Query > Run Report. For Office 2007, click Run Report in the Query section of the
Hyperion ribbon.
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Rerunning Queries
You can use Hyperion > Refresh or Refresh All to update data on query reports, but refreshing
does not rerun queries. For example, if data filtering is set to return the top 10 cars sold in
California, the sales data for the 10 cars is refreshed, but the set of 10 cars does not change. To
update the top 10 list of cars, you must rerun the query. Rerunning queries regenerates reports,
therefore changes to reports, such as zooming in and entering comments, are lost.

MDX Queries
Advanced users can bypass the Query Designer interface and enter MDX commands in the query
sheet or in the Execute MDX dialog box.

➤ To execute MDX queries:

1 In Excel, connect to an Essbase data source.

2 Select Hyperion > Query > Execute MDX.

3 In Execute Free Form MDX Query, enter the MDX query.

For example:

SELECT {[Sales], [Cogs]} on columns, Filter ([Product].Levels( 2 ).Members, 
AVG([Year].CHILDREN, 9001.0) > 9000.00) on rows

4 Click Execute.
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Ad hoc grids are used to analyze data from a data source. An ad hoc query is a request to the
database server to search its data for specific information or results. Ad hoc queries enable you
to view data for specific dimensions from the data source without writing spreadsheet functions.

Ad hoc analysis is supported for Essbase, Hyperion Enterprise, and Financial Management data
source providers.
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The Ad Hoc Grid
After you connect to a data source and open a worksheet, you can open the default Ad Hoc grid
by double-clicking a cell in the worksheet or by selecting Refresh to create a default grid. To
open a grid by double-clicking, you must have enabled this feature from the Options dialog box.
For more information on ad hoc options, see “ Ad Hoc Options” on page 201.

The default grid layout is specific to the data source. You can begin working with data using the
default grid, or you can update the columns and rows with additional or different dimension
members. For more information, see “Selecting Members for Ad Hoc Analysis” on page 81.

If you connect to a different data source while you are working in a grid, the system displays a
message that you have applied a new connection to a grid that was connected with a different
connection. You can continue to work with the new connection or either disconnect and then
reconnect to the proper data source or select the data source from the Active Connections menu
option. If you are working in a new grid, to reapply the original data source, you must reconnect
and then refresh the grid. If you are working in a grid from a saved workbook, to reapply the
original data source, you can reconnect to the saved data source without refreshing the grid.

Note:

If you are working in a new grid and you change the data source connection, you must refresh
the grid in order to view the POV. If you open a spreadsheet with a previously saved POV, change
the data source, and refresh the sheet, the POV is not updated with the new data source members.
You must change the POV when you change the data source.

You can change the POV settings at any time for a grid. If you want to save the POV settings in
a worksheet, after you make any changes to the POV, you must refresh the settings before you
save the worksheet. For more information, see “Refreshing the Grid” on page 88.

Note:

If you make changes to the POV of a saved workbook after changing the data source connection,
the changed POV will not be saved when the workbook is saved.

You can also change the starting dimensions in the default grid by selecting a different dimension
or member in the POV Manager before performing a Refresh, as described in “Editing the Point
of View” on page 213.

You can dynamically change the members defined on the rows or columns of the grid. You can
select a member on a row or column and use the Member Selection option to replace the selected
member. For more information see “Selecting Members for Ad Hoc Analysis” on page 81.

Note:

When using ad hoc grids with Financial Management, invalid cells that contain a value display
the value as zero. This is different from other Financial Management modules where invalid cells
that contain a value display that value.

80 Working with Ad Hoc Analysis



Setting Ad Hoc Options
You can set options to control how data is retrieved into the ad hoc spreadsheet and which data
is retrieved as described in“ Ad Hoc Options” on page 201.

Selecting Members for Ad Hoc Analysis
You can select the dimensions and members for the rows and columns of the ad hoc grid. After
you select members, the grid is updated with the new dimension members.

You use the Member Selection dialog box to select dimension members. You can filter the list
of members and you can view labels or descriptions for dimension members. For example, when
you select to view descriptions, the P_Series member is displayed as “P_Series - Phones and
PDAs”.

You can select a maximum of 1,000 members for the ad hoc POV.

You can also search for dimension members. For more information, see step 11 on page 82.

➤ To select dimension members:

1 Select Hyperion > Member Selection.

The Dimension Name Resolution dialog box is displayed.

2 From the Dimensions drop-down list, select a dimension and click OK..

The Member Selection dialog box is displayed.

3 Optional: To filter the list of members, select a member list from the Filter drop-down list. See “Filtering
Members” on page 83.

4 Optional: For advanced filtering, highlight a member without selecting its check box, then select a member
list.

This uses the highlighted member as the filter parameter. For example, if you highlight United
States and change the filter list to Children, the system displays the children of United States.

5 Optional: To display dimension descriptions instead of labels, select Use Descriptions.

6 Optional: To display Dynamic Time Series members for a time dimension, select Dynamic Time Series
Members.

Note:

The Dynamic Time Series option is available only when working with Essbase data sources. For
more information on selecting and working with Dynamic Time Series members, see “Working
with Dynamic Time Series Members” on page 86.

7 Optional: To display active entities only, select Active Members.
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Note:

The Active Members option is available only if the application has been set up for Organization
by Period. For information on Org by Period, see the Hyperion Financial Management – System
9 Administrator’s Guide.

8 In the Members list, highlight a member, then use one of the following methods to select members:

● To select individual members, select the check box next to each member that you want to
use.

● To select all members for the highlighted member, click Select, .

● To select all immediate children for the highlighted member, click  and from the drop-
down list, select Children.

● To select all base members for the highlighted member, click  and from the drop-down
list, select Base Members.

Tip:

To deselect members, click Select None.

9 Click Add, , to move the selected members to the Selection list.

Tip:

To remove members from the Selection list, select the members, then click Remove, . To

remove all members from the Selection list, click Remove All, .

10 Optional: To reorder members in the Selection list, click the Up or Down arrows or the Make Lowermost
and Make Topmost buttons above the list to move members.

11 Optional: To search for members in the selected dimension, complete the following steps:

a. Click  and enter the member name or pattern for which you want to search in the text
box.

You can enter the start of a text pattern for the search, or you can use a trailing asterisk as
a wildcard symbol. For example, to find EastSales, you can enter “east” or “ea*.”

b. Click  to find the first member within the dimension that matches the search criteria.

Select the check box next to the member if you want to use it and then click .

c. Click  again to search for the next occurrence and, if you want to use the member,

select the check box next to the member and click .
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Tip:

If you are at the bottom of the member list, click  to find the next member that matches
the search criteria.

Tip:

F3 enables the Find text box. Selecting F3 again searches down and Shift F3 searches up.

12 When you finish selecting members, click OK.

Filtering Members
When selecting members from a large outline, use filters to limit the members returned in a
report. For Essbase, you can select attributes and set conditions for them using the Subset dialog
box.

➤ To filter members:

1 After selecting a member in the spreadsheet, access the Member Selection dialog box using several
methods:

● Select Hyperion > Member Selection. For Office 2007, click Member Selection in the
Task section of the Hyperion ribbon.

● From POV toolbar, select the down arrow button next to a dimension and select the ellipses
(...).

● From the POV toolbar in Query Designer, double-click the dimension name or select the
down arrow button next to a dimension and select the ellipses (...).

2 From Dimension, select a dimension.

3 From Filter, select an option:

Note:

Filter options vary depending on whether you are connected to Essbase, Financial Management,
or Hyperion Enterprise data sources. Filter options for Essbase are static and are described in
this procedure. Filter options for Financial Management are dynamic.

● None—Applies no filters

● Children—Selects only children of a specific member

● Descendants—Selects only descendants of a specific member

● Level—Selects members by level number

● Generation—Selects members by generation number

● UDA—Selects members by user defined attributes (Essbase only)

● Attribute—Selects members associated with a specified attribute dimension (Essbase only)
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● Subset—Opens the Subset dialog box for specifying attribute dimension criteria (Essbase
only)

● Input—Selects input accounts (Hyperion Enterprise only)

● Calculated—Selects calculated accounts (Hyperion Enterprise only)

● Dynamic View—Selects dynamic view accounts (Hyperion Enterprise only)

● Parent—Selects parent entities (Hyperion Enterprise only)

● Base—Selects base entities (Hyperion Enterprise only)

● Subentity—Selects subentities (Hyperion Enterprise only)

● Daily—Selects daily entries (Hyperion Enterprise only)

● Weekly— Selects weekly entries (Hyperion Enterprise only)

● Monthly—Selects monthly entries (Hyperion Enterprise only)

● Quarterly—Selects quarterly entries (Hyperion Enterprise only)

● Trimester—Selects trimester entries (Hyperion Enterprise only)

● Half-Yearly—Selects half-yearly entries (Hyperion Enterprise only)

● Yearly—Selects yearly entries (Hyperion Enterprise only)

4 If you selected:

● None, Children, Descendants, Input, Calculated, Dynamic View, Parent, Base, Subentity,
Daily, Weekly, Monthly, Quarterly, Trimester, Half-Yearly, or Yearly, go to step 9.

● Level or Generation, the Filter Arguments dialog box is displayed. Go to step 5.

● UDA, the Filter Arguments dialog box is displayed. Go to step 6.

● Attribute, the Filter Arguments dialog box is displayed. Go to step 7.

● Subset, the Subset dialog box is displayed. Go to step 8.

5 In Filter Arguments:

a. Specify the level or generation number in Level or Generation.

b. Click OK.

c. Go to step 9.

6 In Filter Arguments:

a. Type the user defined attribute in UDA.

b. Click OK.

c. Go to step 9.

7 In Filter Arguments, in Attribute Members select .

The Subset dialog box is displayed, enabling you to specify an attribute so that members are
returned containing the specified attribute.

a. In Dimension, select an attribute dimension.

b. In Member, select an attribute member.
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c. Click Add.

d. Optional: You can change the selected attribute dimension and member. Click Set after
making the changes. Click Delete to remove the attribute.

e. Go to step 9.

8 In Subset, define attribute conditions to return members meeting the condition.

a. In Dimension, select an attribute dimension; for example, Caffeinated.

b. In Member, select an attribute member; for example, True.

c. Click Add.

d. In Dimension, select another attribute dimension; for example, Pkg Type.

e. In Member, select another attribute member; for example, Bottle.

f. Click Add.

An AND condition statement is created; for example, [True] AND [Bottle].

g. Optional: Select the condition statement to change it.

h. Select Operator and a condition:

● AND—The selection must meet both conditions; for example, the members must be
caffeinated and packaged in bottles.

● OR—The selection must meet either conditions; for example, the members can be
caffeinated or packaged in bottles.

● NOT—The selection includes only the members that do not have the selected
condition; for example, the members that are not caffeinated.

i. Optional: You can nest conditions by selecting more attributes and selecting Add, then to
Root.

j. Click OK after setting the conditions to return to Member Selection.

9 In Member Selection, click  to add the members to the selection.

10 Click OK.

Member Selection Differences
The Member Selection dialog box can be accessed in several ways. However, depending on where
you accessed the Member Selection dialog box, the functionality can be different.

Table 4 Member Selection Functionality Differences

Member Selection Type Purpose

Ad Hoc Accessed from Hyperion > Member Selection. You can select a dimension on the grid and
change which members are selected for the report. You cannot apply member filters.

POV toolbar Accessed from POV toolbar. You can change the dimension or member to make it available
on the POV toolbar, so that you can add it to the grid.
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Query Designer Accessed from Query Designer. You can change the members for the query. Member
filtering is available.

Dragging and Dropping Dimension Members
You can drag and drop dimensions between rows and columns and move them in and out of
the grid. You can drag and drop the dimensions to any row or column on the grid.

Note:

If you drag a dimension over an existing dimension in the grid, the new dimension is placed on
the outer side of the existing dimension.

➤ To drag and drop a dimension member, use one of the following methods:

● To drag a dimension member from the Point of View toolbar to the grid, select the member,
and drag it to the desired location on the grid.

● To drag a dimension member from the grid to the Point of View toolbar, select the member
in the grid, right-click and drag it to the toolbar.

Note:

Smart View drag and drop is disabled after you perform Excel editing actions such as typing
over member values, inserting or deleting columns or rows, dragging and dropping an Excel
region. etc. To re-enable Smart View drag and drop, refresh the grid.

Working with Dynamic Time Series Members

Note:

This option is available only when working with Essbase data sources.

Dynamic Time Series members are predefined members used in to-date calculations. Dynamic
Time Series members do not appear as members in your database outline; instead, they represent
a generation in a Time dimension. For example, in the Essbase Sample Basic database, the
Application Designer can create a generation name called Quarter for generation 2 of the Year
dimension that contains the data for Qtr1, Qtr2, Qtr3, and Qtr4. When you create the generation
name Quarter, Essbase creates and enables a Dynamic Time Series member called Q-T-D.

To use Dynamic Time Series in calculations, you first define the latest time period for which you
want data. The latest time period is the level 0 member in a Time dimension. For example, in
the Sample Basic database, the level 0 members are the months of the year: Jan, Feb, Mar, and
so on. If the current month is August, and you want to know the sales data for the quarter up
to the current month, Dynamic Time Series calculation gives you the sales data for the months
of July and August.
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Note:

If you are manually entering dynamic time series members into a free-form grid, formats such
as Q-T-D(Jan), QTD(Jan), YTD(Mar), Y-T-D(Mar), MTD(Jun), and M-T-D(Jun) are
supported. Formats such as QTDate(Jan) are not supported.

➤ To specify the latest time period to use:

1 Access the Member Selection dialog box using one of the following methods:

● Select Hyperion > Member Selection. For Office 2007, click Member Selection in the
Task section of the Hyperion ribbon.

● From the Options drop-down menu on the POV toolbar, choose Select Members, select the
time dimension (if available), and then choose a member.

The Member Selection dialog box is displayed, and the Time dimension and member names
are displayed in the Members list box.

2 Select the Dynamic Time Series Member check box.

The dimension and member names are displayed as Dynamic Time Series members.

The following are valid Dynamic Time Series members:

Dynamic Time Series Generation Name

H-T-D History

Y-T-D Year

S-T-D Season

P-T-D Period

Q-T-D Quarter

M-T-D Month

W-T-D Week

D-T-D Day

3 Select the Dynamic Time Series members that you require from the Members list box and click Add,

.

4 In the Selection list box, select a Dynamic Time Series member to highlight it, and then click the dts button.

5 From the drop-down list in the Select DTS Member dialog box, select the latest period on which the to-date
calculation will be based.

6 Click OK.

7 Repeat step 4 through step 6 for all Dynamic Time Series you have added to the Selection list box.

8 Click OK to close the Member Selection dialog box.
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Formatting Data Cells in the Grid
In both free form grids and structured grids, you can use the Capture Formatting command to
capture and apply formatting styles, such as font color or number styles, to selected data cells.

If you are working in a free form grid, you must refresh the grid after you type member names
in the grid in order to use Capture Formatting.

Note:

The procedure in this topic assumes you are displaying the Formatting toolbar in Excel. To
display the formatting toolbar, right-click in the toolbar area of Excel and select Formatting.

➤ To apply formatting to one or more data cells in a grid:

1 Select the cell or cells to which you want to apply formatting.

2 Choose one or more of following formatting options:

● To apply a background color to the selected cells, click the arrow next to the Fill Color button,

, and click on a color from the palette to select it.

● To apply a font color to the selected cells, click the arrow next to the Font Color button,

, and click on a color from the palette to select it.

● To apply formats to numbers, such as add decimal places or a currency symbol, select Format
> Cells and make the appropriate selections in the Number tab.

3 Select Hyperion > Capture Formatting to retain the formatting options for the selected cells.

Tip:

You can also right-click and select Hyperion > Capture Formatting to apply the formatting
options you have chosen to the selected cells.

Refreshing the Grid
You can refresh the grid at any time to retrieve data from the connected data source into the
active worksheet. For example, after you change the Point of View, you can refresh the grid to
see the changes. If you want to save the Point of View settings in a worksheet, you must refresh
the settings before you save the worksheet.

Note:

To refresh a grid, 250 bytes per cell of memory is needed. For example, to refresh a 100x30 cell
grid requires 750,000 bytes of JVM memory.
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➤ To refresh the grid, take one of the following actions:

● Select Hyperion > Refresh. For Office 2007, click Refresh in the Review section of the
Hyperion ribbon.

● Click the Refresh toolbar button.

● From the Point of View dialog box, click the Refresh arrow.

● Right-click, then select Hyperion > Refresh.

To refresh all grids, functions, and forms in the workbook, select Hyperion > Refresh All. For
Office 2007, click Refresh All in the Review section of the Hyperion ribbon.

Zooming In on Dimension Members
You can drill down to various levels of data in the grid by expanding the members. For example,
if you want to view data for a specific quarter or month rather than for the whole year, you can
zoom in on the [Year] member to see more detailed data.

When you zoom in on a member, it is expanded according to the options specified in the Options
dialog box. If you select the option to zoom in on all levels, the grid displays all descendants of
the selected member.

The default zoom option is to zoom in to the next level to retrieve data for the children of the
selected member or members. For example, if you double-click the [Year] member, the system
displays Quarter1, Quarter2, Quarter3, and Quarter4.

You can zoom in on the bottom level to retrieve data for the lowest level of members in a
dimension. You can select to retrieve data at the sibling level, the same level, or the same
generation as the selected member.

Hybrid Analysis gives the spreadsheet user the ability to drill down from multidimensional
members to relationally-stored members. In Smart View, when you connect an Essbase data
source, you can drill down to relationally-stored members if they are present in the Essbase
database. Drilling down on Hybrid Analysis members is enabled by default. For more
information on Hybrid Analysis, see “Accessing Data from a Hybrid Analysis Relational Source”
on page 92.

➤ To zoom in on dimension members, take one of the following actions:

● Double-click on a cell.

● Select a worksheet cell for which you want to zoom in, then select Hyperion > Ad Hoc
Analysis > Zoom In. For Office 2007, click Zoom In in the Ad Hoc Analysis section of the
Hyperion ribbon.

Zooming Out on Dimension Members
You can drill up to higher levels of data in the grid by collapsing, or zooming out to, dimensions.
For example, if you previously drilled down on a dimension such as Period to view data for
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October, November, and December in Quarter 2, you might need to drill up to view aggregate
data for the period. When you zoom out from December, the Period dimension is collapsed for
October, November, and December and replaced with Quarter2.

➤ To zoom out on dimension members:

1 Select a worksheet cell for which you want to zoom out.

2 Select Hyperion > Ad Hoc Analysis > Zoom Out. For Office 2007, click Zoom Out in the Ad Hoc
Analysis section of the Hyperion ribbon.

Retrieving Attribute Dimensions and Members
You retrieve attribute dimensions or members by first performing an ad hoc query, then typing
their names directly on the worksheet. The base dimension must already exist on the worksheet
before you type the attribute name in the sheet.

For information on retrieving attributes in free-form grids, see:

● “Working with Attribute Dimensions” on page 104

● “Valid Grid with POV Region and Attribute” on page 117

● “Retrieving Attribute Dimensions in Free-Form Mode” on page 120

➤ To retrieve an attribute member by typing it name:

1 Perform an ad hoc query to place the base member on the worksheet.

2 Type the attribute name over the base dimension name in the worksheet.

The attribute member name replaces the base dimension name.

3 Refresh the worksheet.

4 Zoom in on the attribute member name.

5 Optional: Perform other ad hoc query operations, such as pivoting or adding other dimensions to the sheet.

For example, to retrieve the Pkg Type attribute from the Essbase Sample Basic application and
database, perform the following steps:

a. Connect to Sample Basic in a blank worksheet and refresh the sheet.

b. Drag the Product dimension from the POV and drop it on the Year dimension. Or, in the
POV, select Options > Pivot to Row > Product.

c. In the worksheet, in the cell that contains the Product dimension type Pkg Type over the
word Product.

d. Double-click Pkg Type to view measures by can or bottle package type.

Viewing the Qualified Name of a Member
As you perform ad hoc queries in the grid, you can view the qualified name for a member.
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When you view the qualified name of the member, you are able to view the member name and
the names of its parents up to the level in the dimension that uniquely defines the member. This
can be helpful when querying on a grid that contains aliases or duplicate member names.

The qualified member name is displayed in a pop-up dialog box in the following format:

[Dimension].[Member]

The number of members displayed in the qualified name depends on the number of member
levels necessary to provide the qualified name of the member.

➤ To view the qualified name of a member in the grid:

1 Select a member in the grid.

2 Select Hyperion > Ad Hoc Analysis > View Qualified Member Name.

A dialog box containing the qualified member name is displayed.

3 Click OK.

4 Optional: To view the qualified name of another member, repeat the procedure.

Note:

If you want to view qualified member names in the worksheet, select the “Description Only”
option in the Display tab of the Options dialog box. See “Specifying Data Display Options” on
page 207 for instructions on setting this option.

Displaying Aliases for Member Names

Note:

This option is not available when working with Hyperion Enterprise data sources.

Aliases are alternate names for database members. You can perform ad hoc retrievals using the
database member name, which is often a stock number or a product code, or an alias, which can
be more descriptive. Each database to which you connect can contain up to 10 alias tables.

For example, members of the Product dimension in the Essbase Sample Basic database are
defined as codes, such as 100 and 200. A descriptive value for each member of Product, such as
Colas and Root Beer, is defined in an alias table. In some cases, alias names may vary depending
on the combination of other database members. For example, a Product member may have an
alias in multiple languages for worldwide users.

Note:

Using the Change Alias Table command may result in the loss of cell comments and formulas
that you added to the worksheet, and formatting that you preserved using the Capture
Formatting command.
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➤ To display aliases for member names:

1 In the Options dialog box, Display tab, verify that in the Member Name Display Options group, either
Member Name and Description or Description Only has been selected.

The “Member Name and Description” option or the “Description Only” option must be selected
in order for alias names to display in the ad hoc grid. See “Display Options” on page 206 for
information on setting the Member Name Display Options.

2 Perform one of the following options:

● Select Hyperion > Connection Manager. For Office 2007, click Connect in the
Connections section of the Hyperion ribbon.

If you are using Essbase, you can select or change an alias table for a data provider connection
in the Connection Manager. New data sources and new worksheets associated with this
connection use the specified alias table. New worksheets that contain a previously existing
grid, however, continue to use the previous alias table. Copy/ pasted data points are not
affected by changes to the alIas table.When an alias tables is modified in the Connection
Manager, the background POV is updated with the new aliases.

Changing the alias table in the Connection Manager causes functions that are dependent on
the connection to fail.

● Select Hyperion > Ad Hoc Analysis > Change Alias Tables. Use this option to change alias
tables for existing grids.

3 In the Connection Manager, right-click the active provider and select Change Alias Table.

4 In the Select Alias Table dialog box, select the alias table that contains the member names that you want
to use, and click OK.

5 Refresh the grid to display the alias names from the table you have chosen.

Use any of the methods described in “Refreshing the Grid” on page 88.

Accessing Data from a Hybrid Analysis Relational Source
Because relational databases can store several terabytes of data, they offer nearly unlimited
scalability. Essbase multidimensional databases are generally smaller than relational databases
but offer sophisticated analytical capabilities. With Hybrid Analysis, you can integrate a
relational database with an Essbase database and thereby leverage the scalability of the relational
database with the conceptual power of the multidimensional database.

Hybrid Analysis eliminates the need to load and store lower-level members and their data within
the Essbase database. This feature gives Essbase the ability to operate with almost no limitation
on outline sizes and provides for rapid transfer of data between Essbase databases and relational
databases.

In Smart View, you do not need to set a specific option order to retrieve data that is stored in
the Hybrid Analysis relational source. This functionality is enabled automatically. Perform zoom
in operations as described in “Zooming In on Dimension Members” on page 89.

92 Working with Ad Hoc Analysis



Pivoting Dimensions
Pivoting changes the orientation of the data on the worksheet. You can move dimensions
between rows and columns and move dimensions in and out of the grid. When you move
between rows and columns, the system moves the selected dimension to the outermost row or
column on the opposite axis. For example, when you select Pivot to Row, the system moves the
dimension to the far left side of the grid, and when you select Pivot to Column, the system moves
the dimension to the top of the grid. You can also select to pivot a dimension out of the ad hoc
grid to the Point of View.

Before you remove a dimension from a grid, you must first pivot the replacement dimension
into the grid.

Note:

When the “Use Excel Formatting” option is selected (as described in “Using Excel Formatting”
on page 209), member and numeric formats may unexpectedly change after pivot operations.
For example, member names may be centered and numeric values may be left justified. You can
reset the grid to the proper format using the formatting options of Excel.

➤ To pivot data, do one of the following tasks:

● To move a dimension to the outermost row or column, click on a dimension, then select
Hyperion > Ad Hoc Analysis > Pivot. For Office 2007, click Pivot in the Ad Hoc Analysis
section of the Hyperion ribbon.

● To pivot a dimension to the Point of View, select the dimension, then from the Point of
View toolbar, select Options > Pivot to POV.

● To pivot a dimension to a row, from the Point of View toolbar, select Options > Pivot to
Row, then select a dimension.

● To pivot a dimension to a column, from the Point of View toolbar, select Options > Pivot
to Column, then select a dimension.

Note:

In Financial Management, you can pivot only from rows or columns with multiple
dimensions. If you need to pivot a grid with one row dimension and one column dimension,
first move a POV dimension to a row or column, pivot, then move POV dimension back.

Note:

In Hyperion Enterprise, the Pivot to POV, Pivot to Row, and Pivot to Column options are
not available.
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Keeping Data
You can modify the ad hoc grid by selecting only the dimension members that you want to keep
in the grid. When you select the Keep Only option, the system keeps only the selected member
(the active cell) or member range within the grid. All unselected members are removed from
the worksheet for that dimension.

The options that you select for member retention also affect the behavior of the Keep Only
option. For more information, see “Member Retention Options” on page 205.

➤ To keep data in the grid:

1 Select the member or members that you want to keep.

2 Select Hyperion > Ad Hoc Analysis > Keep Only. For Office 2007, click Keep Only in the Ad Hoc
Analysis section of the Hyperion ribbon.

Removing Data
You can modify the ad hoc grid by removing dimension members from the grid. When you
select Remove Only, the system removes the selected member (the active cell) and data or
member range and data from the worksheet for that dimension. All unselected members are
retained in the worksheet.

The options that you select for member retention also affect the behavior of the Keep Only
option. For more information, see “Member Retention Options” on page 205.

Note:

If you delete members from a grid using the Delete key (not using the Remove Only command),
you must also delete the corresponding data points; otherwise, when you refresh the grid, the
remaining cells are treated as comments.

➤ To remove data from the grid:

1 Select the member or members that you want to remove.

2 Select Hyperion > Ad Hoc Analysis > Remove Only. For Office 2007, click Remove Only in the Ad Hoc
Analysis section of the Hyperion ribbon.

Adding Cell Text

Note:

This option is not available when working with Hyperion Enterprise data sources.
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You can add a text description for any cell. For example, you might want to add an explanation
of the cell’s data. After you have added cell text, you can also make any necessary changes to the
text.

➤ To add cell text:

1 Select the cell or cells for which you want to add text.

2 Select Hyperion > Cell Text. For Office 2007, click Cell Text in the Task section of the Hyperion ribbon.

The Point of View is displayed for the cell that you selected.

3 In the Cell Text window, enter the text that you want to add.

You can add up to 2,000 characters of cell text for each cell. If you selected a range of cells, you
can enter cell text in a separate text box for each cell.

4 Click OK.

Cells that contain text are indicated by dark blue borders.

Viewing Cell Text

Note:

This option is not available when working with Hyperion Enterprise data sources.

If a worksheet cell contains cell text, you can view it from an ad hoc grid. Cells that contain text
are indicated by dark blue borders.

➤ To view cell text:

1 Select the cell for which you want to view cell text.

2 Select Hyperion > Ad Hoc Analysis > Cell Text. For Office 2007, click Cell Text in the Task section of the
Hyperion ribbon.

The Point of View is displayed for the cell that you selected.

3 View the cell text, then click OK to close the dialog box.

Calculating Data
When you are using an ad hoc grid, you can select several options to calculate data. You can
calculate data, force a calculation to run for selected cells, calculate contribution values, or force
calculation to run for selected contribution values.

To calculate data, you must have security access rights to the data. If the calculation option is
not available for the cell, the system ignores that cell.
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All options described in this topic are available to Financial Management users. For more
information on calculating data from a Financial Management data source, see the Hyperion
Financial Management – System 9 User’s Guide.

Note:

If you are connected to an Essbase data source, only the Calculate option is available. Choosing
this option invokes the Calculation Scripts dialog box, where you may select the calculation
script that you want to run. See “Selecting a Calculation Script” on page 96 for more
information.

Note:

If you are connected to Hyperion Enterprise data source, only the Calculate option is available.
For Hyperion Enterprise data sources, refresh the data forms after calculating data to update the
calculated accounts.

➤ To calculate data:

1 Select a cell or range of cells for which you want to calculate data.

2 Select Hyperion > Calculation Options, then select one of the following options:

● To calculate the selected cells, select Calculate.

Note:

If you are connected to an Essbase data source, you are prompted to select a calculation
script to run, as described in “Selecting a Calculation Script” on page 96.

● To force calculation to run for all selected cells, select Force Calculate.

● To calculate contribution values, select Calculate Contribution.

● To force calculation to run for all selected contribution values, select Force Calculate
Contribution.

Selecting a Calculation Script
If you are connected to an Essbase data source, you can choose a calculation script with which
to calculate an Essbase database.

➤ To calculate the database with a calculation script:

1 Select Hyperion > Calculation Options > Calculate to display the Calculation Scripts dialog box.

The Cube area displays the databases that belong to this application. The calculation scripts
associated with each cube are listed in the lower portion of the dialog box.
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Tip:

To view a subset of scripts, clear all check boxes in the Cube area of the dialog box and then
select the cube with which you are working to list only the scripts available for that cube in the
lower portion of the dialog box.

2 Click on a calculation script name and click Launch.

A status message is displayed telling you whether the calculation was successful or not. If the
calculation was not successful, contact your Essbase administrator.

Inserting Calculating and Non-Calculating Rows and Columns
When you work with an ad hoc grid, columns and rows you add are retained when you perform
a Refresh or a zoom-in operation.

Keep the following guidelines in mind when inserting calculating and non-calculating columns
and rows:

● Rows or columns may be inserted within the grid or outside of the grid.

● An inserted row or column may contain a formula.

● An inserted row or column may contain text or an Excel comment.

Translating Data

Note:

This option is not available when working with Hyperion Enterprise data sources.

When you are using an ad hoc grid, you can translate data for cells. You can translate selected
data, or force translation to run for selected cells.

To translate data, you must have security access rights to the data. If the translation option is
not available for the cell, the system ignores that cell.

For more information on translating data, see the Hyperion Financial Management – System 9
User’s Guide.

➤ To translate data:

1 Select a cell or range of cells for which you want to translate data.

2 Select Hyperion > Calculation Options, then select one of the following options:

● To translate the selected cells, select Translate.

● To force translation to run for all selected cells, select Force Translate.
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Consolidating Data
When you are using an ad hoc grid, you can consolidate data for cells. You can consolidate
selected data, consolidate all data, or consolidate all cells that contain data.

To consolidate data, you must have security access rights to the data and you must be assigned
the Consolidate security role. To Consolidate All data, you must be assigned the Consolidate All
security role.

If the consolidation option is not available for the cell, the system ignores that cell.

For more information on consolidating Financial Management data, see the Hyperion Financial
Management – System 9 User’s Guide.

➤ To consolidate data:

1 Select a cell or range of cells for which you want to run consolidation.

2 Select Hyperion > Calculation Options, then select one of the following options:

● To consolidate data for the selected cells, select Consolidate.

● To consolidate data for all cells, regardless of whether they contain data, select Consolidate
All.

● To consolidate data for all cells that contain data, select Consolidate All With Data.

Submitting Data
After you calculate, translate, or consolidate data on an ad hoc grid, you can submit data from
the grid to the data source to ensure that the data source uses the latest information from the
worksheet. See “Submitting Data” on page 52.

To submit data to the data source, select Hyperion > Submit Data. For Office 2007, click
Submit in the Review section of the Hyperion ribbon.

Note:

When the grid layout is changed (such as by inserting a column or row) or when the area outside
of the data region is changed, the Submit Data option will be disabled. Select Hyperion > Refresh
to refresh the grid so that the data region can be established by Smart View, then the Submit
Data option will be enabled and data can be changed and submitted.

Working with Formulas in Ad Hoc Grids
When working with ad hoc grids, you can create Excel formulas to manipulate or analyze the
data.

You can create formulas:

● Inside or outside the ad hoc grid
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● On cells that have cell text or are locked

You cannot create formulas:

● On read-only cells

● On cells that have supporting detail (applies only when working with Planning data forms)

Formulas are preserved even when you:

● Refresh the ad hoc grid

● Zoom in or zoom out (referential formulas are updated with their new relative positions)

Note:

After performing a Zoom In or Zoom Out operation, the location of the formula is calculated
based on the first occurrence of a member on any row or column. If member names are
repeated, then zooming in or zooming out on the grid may cause the formula location to
be wrongly calculated. Hyperion recommends that you avoid use of Zoom In and Zoom
Out operations when working with grids containing repeated members and formulas
referring to them.

● Use the Keep Only or Remove Only functions

● Add comments

Formulas are not preserved if you change the grid by:

● Pivoting data (for example, by selecting Pivot to POV or Pivot to Column)

● Clearing the grid

● Retrieving data without saving the formulas

● Using the Change Alias Table command

Working with Drill-Through Reports

Note:

This option is not available when working with Hyperion Enterprise data sources.

Drill-through is a tool that enables you to drill from the summarized and calculated data stored
in Essbase into detail data stored in a relational database. For example, if you are analyzing retail
sales for the first quarter in the Eastern region, you can request a drill-through report to see a
list of customers who purchase a particular product in a particular size. From Smart View, you
can access a predefined, detail-level drill-through report that is based on the member
intersections of Essbase data cells in the sheet. Oracle's Essbase® Integration Services then
retrieves the detail data from the relational source and returns the report in the context of the
data already displayed in the sheet.
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➤ To access a drill-through report:

1 In the Connection Manager, connect to the data source from which you will be accessing drill-through
reports.

If you do not know which data source to access, contact your system administrator. See
“Connecting to a Data Source” on page 37 for information on connecting.

2 Optional: To aid in recognizing the cells to which a drill-through report is attached, set a style for drill-through
cells using the procedure described in “Setting Cell Styles” on page 211.

3 Navigate in the sheet and locate one or more drill-through cells.

4 Select a single cell or a continuous range of cells from the same parent in the sheet to display all drill-
through reports associated with the cell you select.

Note that in order for Integration Server to return a valid drill-through report when multiple
cells are selected, all members selected for multi-cell drill-through must come from:

● The same physical table and column in the relational source database

● The same member level in the underlying OLAP metaoutline

● The same hierarchy

A multi-cell drill-through operation is valid only if all three criteria noted above are met. A
message is displayed if the combination of cells you select is not valid for performing a multi-
cell drill-through operation.

5 Select Hyperion > Ad Hoc Analysis > Drill-Through Reports.

The Drill-Through Reports dialog box is displayed.

6 Choose a report from the list and click Launch.

Essbase launches drill-through, generates the report, and displays the results in a new worksheet
within the current workbook. The new sheet is after the existing sheets in the workbook.

7 View the drill-through report.

8 Optional: If more than one drill-through report was associated with the selected cell or cells, repeat
step 4 through step 7 to select and view another drill-through report.
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8
Using Free-Form Reporting to

Retrieve Data
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About Free-Form Reporting
In addition to Ad Hoc retrieval and Member Selection operations,Smart View supports free-
form reporting.

Free-form reporting enables you to tell the connected data source specifically what you want to
retrieve by typing member names into the worksheet. This free-form mode of reporting is
especially useful when you are familiar with the dimensions and members in the database outline.

When you construct a report by entering names directly into a worksheet, Smart View queries
the connected data source, interprets the member names entered, and creates a default view that
is based on the location of the labels.

Free-form mode also provides most of the retrieval capabilities types of retrieval capabilities,
enabling you to incorporate into the sheet many of the Ad Hoc retrieval techniques described
in this chapter, such as zoom in and zoom out, pivot, and member selection.

With free-form, you can:

● Type dimension or member names directly into the grid

● Expand what you type using the POV and Member Selection

● Format member and data cells

● Create a template that can be shared with other users
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● Use VBA functions to customize and automate worksheets

Smart View Grid Components
The graphic in this section shows the Smart View grid components. In the example Smart View
grid, the Row dimensions are to the left and to the bottom of the Column dimensions. The Page
dimensions can occur anywhere in the rows above the Column dimensions (applies to Essbase
only).

The components of the Smart View grid are described in Table 5.

Table 5 Smart View Grid Components

Grid Component Color in Example Grid Description

Row Dimension Yellow A dimension or dimension members that are placed down one column
across one or more rows on a worksheet

Column Dimension Yellow A dimension or dimension members that are placed on a row across
one or multiple columns in a worksheet

Page Dimension Orange A dimension or dimension member that is placed in the area above
the column dimensions in a worksheet (Essbase only)

Comments Light Blue Descriptive text added by the user into the worksheet

Data Region Gray After a grid operation such as a Refresh, Zoom In, or Zoom Out—the
area where the row, column, and page data is placed
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Grid Component Color in Example Grid Description

Blank Region Purple Areas of the worksheet that are not yet affected by any grid operations

See “Free-Form Guidelines” on page 103 for some general rules for free-form and descriptions
of valid and invalid free-form grid layouts.

See “Answering Business Questions Using Free-Form” on page 122 for an example scenario
that incorporates many aspects of free-form reporting.

Free-Form Guidelines
Keep in mind the following guidelines when you are working in free-form mode:

● When typing member names that consist of numbers into a blank worksheet, preceded the
member name with a single quotation mark. For example, when accessing the Essbase
Sample Basic database, type '100 in the worksheet for Product dimension member 100.

● Hyperion recommends using Member Selection, as described in “Selecting Members for Ad
Hoc Analysis” on page 81, to input member names into a free-form worksheet. Manually
typing member names is permitted, but can be error prone.

● Member strings that are admissible in free-form mode are member names and their aliases
from the current alias table. Aliases from a noncurrent alias table that are input into a free-
form sheet are identified and processed as comment strings.

● When connected to an Essbase or Hyperion Enterprise data source, if you cut and paste
from certain sources, such as Microsoft Word, into an Excel worksheet, some of the strings
you paste into the grid may be prefixed by hidden characters (control characters). The
hidden characters may result in ad hoc or free-form behavior that is misleading or error
messages that are not obvious. In such cases, contact your Smart View administrator, who
can identify the issue through logs.

● When connected to a duplicate member Essbase data source, be sure to select the Description
Only option in the Display tab of the Options dialog box, as described in “Specifying Data
Display Options” on page 207. Smart View then displays qualified member names in the
worksheet.

● When creating or editing a sheet that is connected to a duplicate member Essbase data source,
you must use qualified member names for the duplicate members in the sheet.

The following topics contain particular information on working with free-form grids:

● “Working with Attribute Dimensions” on page 104

● “Entering Dynamic Time Series Members” on page 104

● “Submitting Dirty Cells” on page 105

● “Comment Handling” on page 105

● “Preserving Comments, Formulas, and Format” on page 106

● “Handling the #Missing and the #No Access Label” on page 106
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For more information about the kinds of grids you can and cannot create with free-form
reporting, and on Smart View handling of free-form, see “Valid and Invalid Grids” on page
107.

Working with Attribute Dimensions
In structured grid processing operations, attribute dimensions are not shown. In free-form, you
can type an attribute dimension member in the grid and it will be processed and validated. Only
the attribute dimension member that you added will be displayed and used during processing
and validation; the remaining attribute dimension members will not be included. Structured
grid operations that follow this free-form request will retain the attribute dimension member.

Note:

Attribute dimension members are not supported for Hyperion Enterprise.

Entering Dynamic Time Series Members
Smart View supports Dynamic Time Series members typed directly into free-form grids. This
section contains some (not all) examples of supported and unsupported formats.

For a complete list of Dynamic Time Series members, see “Working with Dynamic Time Series
Members” on page 86.

Note:

Dynamic time series members are not supported for Hyperion Enterprise.

Supported Format Examples
When entering dynamic time series members into a free-form grid, some examples of supported
formats are:

● Q-T-D(Jan)

● QTD(Jan)

● Y-T-D(Mar)

● YTD(Mar)

● M-T-D(Jun)

● MTD(Jun)

Unsupported Format Examples
When entering dynamic time series members into a free-form grid, some examples of
unsupported formats are:

● Q-T-Date(Jan)
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● QTDate(Jan)

● Y-T-Date(Mar)

● YTDate(Mar)

● M-T-Date(Jun)

● MTDate(Jun)

Submitting Dirty Cells
If you modify a data cell in a Smart View grid, Smart View marks the cell “dirty.” During a
Submit Data operation, dirty cells are updated in the data source.

For Hyperion Enterprise, the default color of dirty cells is yellow.

The Submit Data command is enabled only when you perform either of the following tasks:

● Type over a data cell.

● Select a range of cells and use one of the options in the Adjust Data dialog box to change a
data value, as described in “Adjusting and Spreading Data Values” on page 57.

The Submit Data command is disabled in free-form mode when you type over non-data.

In free-form mode, if you want to change and submit new data, refresh the worksheet as
described in “Refreshing the Grid” on page 88; make your changes to the data cell; and then use
the Hyperion > Submit command to update the changed, or dirty, cells in the data source.

Note:

When the grid layout is changed (such as by inserting a column or row) or when the area outside
of the data region is changed, the Submit Data option will be disabled (except Hyperion
Enterprise). Select Hyperion > Refresh to refresh the grid so that the data region can be
established by Smart View, then the Submit Data option will be enabled and data can be changed
and submitted.

Note:

In Hyperion Enterprise, when you try to submit data after changing the grid layout, you will be
prompted to refresh the grid.

See “Submitting Data” on page 98 for information on the Submit command.

Comment Handling
Comments can be placed in various places in the grid. In the example in “Smart View Grid
Components” on page 102, you can see comments marked in light blue color.

Comments can be placed as follows:
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● Between Row dimensions

● Between Column dimensions

● Between Page dimensions

● Between dimensions and data

● To the left, right, top, bottom of the grid

● Inside the grid range

● Interleaved with members of Page dimensions

● Comment rows and Comment columns can be interleaved with row and columns dimension
member

● Interleaved with members of Row, Column and Page dimensions

Comments can be placed anywhere in the grid with the exceptions described in the section,
“Valid and Invalid Grids” on page 107.

Preserving Comments, Formulas, and Format
Smart View tries to preserve all comments, formulas, and customized report layouts. Some
exceptions that may result in unexpected behavior are when the following actions are performed:

● Zoom in on a Page dimension

● Pivot a dimension from the POV to a row or column

● Drag and drop a dimension from the POV to the worksheet

● Pivot a Row dimension to a Column dimension

● Switch the location of a Row dimension to another row

● Switch the location of a Column dimension to another column

● Change member aliases using the Change Alias Table command

Handling the #Missing and the #No Access Label
Smart View correctly identifies the #Missing label and the #No Access label as data and not as
comments. You can set this label in the Display tab of the Options dialog box, using any string
you choose, including a blank. In the free- form request,Smart View sends the label string to the
data source. If the label is found in member intersection cells in the data region, the cell is
correctly identified as data and not as a comment. If this string in a member intersection cell in
the data region is anything but the label, Smart View determines the grid to be invalid.

Note:

You can choose to have Smart View display numeric zeroes instead of #Missing or other text.
See “Replacement Labels for Data” on page 206.
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Valid and Invalid Grids
The following sections contain samples of valid and invalid grid layouts. Use these samples as
guidelines when building your own free-form grids. The sample free-form grids pertaining to
page dimensions and dynamic time series members are not applicable for Hyperion Enterprise.

For Hyperion Enterprise data sources, you cannot type dimension names in the free-form grids.
You can type only member names.

Valid Simple Grid
Figure 1 is a valid simple grid, where Year is the Row dimension, Measures is the Column
dimension and Product is the Page dimension. Figure 2 on page 107 is a valid simple grid specific
for Hyperion Enterprise.

Figure 1

Figure 2

Valid Grid that Starts in Cell Other Than Cell A1
In Smart View, a valid simple free-form grid does not necessarily have to start in cell A1 on the
sheet. Figure 3 is also a valid free-form grid. Dimension or member names are simply typed on
the grid prior to retrieval.

Figure 3 Valid Grid with Different Start Location
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Invalid Grid with Dimension in Both Row and Column Dimensions
Members of a dimension can only be typed in one of the following regions:

● In the same row

● In the same column

● Anywhere in the Page dimension region

Figure 4 is invalid because, with Qtr1 typed in cell F2, the Year dimension occurs in both a Row
and a Column dimension.

Figure 4

Invalid Grid with Dimension in Both Row and Page Dimensions
Figure 5 is invalid because the Year dimension occurs in both a Row and a Page dimension.

Figure 5

Valid Grid with Different Dimensions in Page Dimension Region
The Page dimension region can contain members of different dimensions. In Figure 6, the
Product, Market (member East), Scenario are all Page dimensions.

Figure 6
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Invalid Grid with Two Members from Same Dimension in Page Dimension
Region
No two members in the Page dimension region can belong to the same dimension. In
Figure 7, dimension Market (Market and member East) occurs twice as a Page dimension and
the grid is invalid.

Figure 7

Invalid Grid Where Column Dimension Contains Its Members and a Different
Dimension
Every Row and Column dimension can only have members from the same dimension in their
rows and columns respectively. Figure 8 is an invalid grid because the Column dimension,
Measures, also contains it members in addition to a different dimension, Market. Figure 9 is
specific for Hyperion Enterprise. Figure 9 is an invalid grid because the Column dimension
(Account), also contains its members in addition to a member from a different dimension
(Entity). Smart View interprets the additional Entity dimension (US) as a comment.

Figure 8

Figure 9

Valid Grid Where Smart View Interprets Column Dimensions as Page
Dimensions
A valid free-form grid must have at least one row and at least one column dimension. However,
Figure 10 is an example of a special case. At first glance, it may seem like Figure 10 does not have
any Column dimensions and that Measures, Product and Market are all Page dimensions based

Free-Form Guidelines 109



on the rules stated in the preceding grids. Yet, Smart View validates this grid and interprets it as
Row dimension Year, Column dimension Measures, and Page dimension Product and Market.

Where there are no obvious Column dimensions, only one member in only one Row dimension,
and multiple members all of different dimensions on the same row and to the top and to the
right of the single Row dimension, Smart View interprets the first dimension to be a Column
dimension and the dimensions to the right of it as Page dimensions.

Figure 10

Invalid Grid with Multiple Members on Same Row With Another Dimension
The grid shown in Figure 11 is invalid because it has both Market and East, both belonging to
the same dimension, on the first row along with another dimension, Measures.

Figure 11

Invalid Grid Where Smart View Interprets Stacked Dimensions
The first row that has multiple members, all of the same dimension, is identified as a Column
dimension. All the dimensions that are placed above this row are candidates for Page dimension,
if they comply with the rules for Page dimension. There is an exception to this rule, as shown in
Figure 12. According to the rules described to this point, you might expect Product and Market
to be interpreted as Page dimensions. However, Smart View interprets Product and Market as
Column dimensions, making this grid invalid.

Figure 12

The Smart View logic is that if you identify the first Column dimension on row R, and let C be
the first column on this row R that contains a member, for each subsequent row above row R,
if there is a member on the same column C and that row does not contain any other members,
then that row is identified as a Column dimension. Each such row that contains a member that
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is “stacked” on top of column C is a Column dimension. A row that does not obey this condition
is a candidate for a Page dimension as long as it complies with the rules for Page dimensions.

Valid Grid Where Stacked Dimensions Are Interpreted as Page Dimensions
Rows above a page dimension can only be candidates for a Page dimension and cannot be a
Column dimension even if they obey the condition for “stackable” members. In Figure 13,
Product is a Column dimension since it stacked on top of Profit; Market is a Page dimension
since it is not stacked on top of Profit. However, Scenario is a Page dimension, even though it
is stacked on top of Profit, because it is a row that is above a Page dimension; hence, it cannot
be a Column dimension.

Figure 13

Zooming In On a Page Dimension
If you zoom in on a Page dimension, the result is that the Page dimension is moved to a Row
dimension through a POV to Grid operation.

Figure 14

Results of Zoom In
For example, if you zoom in on Market in Figure 14, it will result in Figure 15.

Figure 15
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Valid Grid Where Member Overrides Dimension in the Page Dimension
Region
If you type a dimension or member name into the Page dimension region, this Page dimension
overrides any default or existing POV. For example, in Figure 16, where the user types East into
an existing grid which has Product, Market, and Scenario as the POV, then East overrides Market
in the POV.

Figure 16

Invalid Grid Where Data Region Cells Cannot Be Comments
Member intersection cells in the Data region must be data cells and cannot contain comments.
Figure 17 is invalid.

Figure 17

Invalid Grid Where Blank Region Cells Cannot Be Comments
Member intersection cells in the Blank region must be blank and cannot contain comments.
Figure 18 is invalid.

Figure 18

Invalid Row and Column Dimensions and First Members
The first members of every column dimension must occur on the same column, and the first
members of every row dimension must occur on the same row. Figure 19 is invalid because cell
B2 is on the first column of the column dimensions and it has to be a member of the Measures
dimension, whereas it is a comment.
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Figure 19

Invalid Grid that Contains Comment Row and Comment Column in
Dimension Region
Row and column dimension regions can be interleaved with comment rows and comment
columns. Figure 20 below is invalid because the comment in cell C2 does not belong to either a
comment row or a comment column. (Both row 2 and column C have dimension members.)

Figure 20

Valid Grid Containing Dynamic Time Series Member
Dynamic Time Series (DTS) members can be placed on the free-form grid using Member
Selection. Additionally, you can also manually type a DTS member name into a grid.
Figure 21 is a valid free-form grid and the member name Q-T-D(Jan) can be manually typed
into the grid.

Figure 21

Note:

DTS member formats such as Q-T-D(Jan), QTD (Jan), YTD(Mar), Y-T-D(Mar), MTD
(Jun), and M-T-D(Jun) are supported. Formats such as QTDate(Jan) are not supported.

Valid Grid with Duplicate Member Names
In free-form mode, when editing a sheet that is connected to a duplicate member Essbase data
source, you must use the qualified member names for the duplicate members in the sheet.
Figure 22 shows the syntax to use when typing in duplicate member names.
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Figure 22

Valid Grid That Contains Numeric Member Names
Member and dimension names cannot be comments.

If you want to type a numeric member name using free-form, tag the numeric name as a member
by typing a single quote ( ‘ ) in front of the member name when you enter it in the Excel cell.
For example, ‘100.

By typing the single quote, you differentiate between a numeric member name and a numeric
comment or numeric data. In Figure 23, 100 is interpreted as a member.

Figure 23

Valid Grid With Numeric Comment and Numeric Data
Both numeric comment and numeric data are typed the same by the user. Smart View identifies
if it is a numeric comment or numeric data depending on the region in which the number is
placed. If it is in the data region, then Smart View identifies it as a data cell; otherwise, it is marked
as a comment. In Figure 24, 2005 is identified as data.

Figure 24

Valid Grid Where Numeric Data is Identified as a Comment
In Figure 25, 2005 is identified as a comment since it is not in the data region, and the grid is
identified to be valid.
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Figure 25

Valid Grid Consisting of Two Columns by Two Rows
Figure 26 is a basic two columns by two rows layout showing the Product and Market dimensions
in the first row and column, and members of Sales and Year in the second row and column.
Figure 26 is specific for Hyperion Enterprise. Figure 26 is a basic two columns by two rows layout
showing the Scenario and Entity dimensions in the first row and column, and members of
Account and Period dimensions in the second row and column.

Figure 26

Figure 27

Valid Grid with Blank Row and Column Inserted
Figure 28 builds on Figure 26 by inserting a blank row and column to the top and left of the grid.
These cells could be used for formatting purposes, such as adding a title to the worksheet. The
title text would be considered a comment.
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Figure 28

Valid Grid with Comments Inserted in Blank Row and Column
Figure 29 provides an example of comment usage in Smart View. It is a valid grid with comments
bordering the data/metadata region. In this case comments are listed in columns A and H, and
in rows 1, 2, and 10. These comments are retained for retrieval and zoom operations. For a list
of rules when using comments on a grid, see “Comment Handling” on page 105.

Figure 29

Valid Grid with Formulas Inserted in Blank Row and Column
Figure 30 provides a valid example of Excel-based formula usage in the Smart View environment.
Formulas are added to the edges of the grid. These are standard Excel formulas and resolve based
on your personal Excel settings. Formulas can be added in any area in which a comment can
exist. For a list of formula usage guidelines, see “Working with Formulas in Ad Hoc Grids” on
page 98 and “Preserving Comments, Formulas, and Format” on page 106.
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Figure 30

Valid Grid with POV Region and Attribute
Figure 31 provides a valid example of both the page region and attribute usage. In this example,
Pkg Type and Budget are understood (by Smart View) to be page dimensions. Additionally, Pkg
Type is an attribute dimension attached to the base member product. By drilling down on Pkg
Type you can do attribute based analysis on measures as it relates to specific Product attributes.
This can be further used to create a cross-tab analysis of product SKUs by attribute. For a
description of zoom behavior when working with the page area see the description on grid
“Zooming In on Dimension Members” on page 89 and “Zooming Out on Dimension Members”
on page 89.

Figure 31

Valid Grid with Complex Comments
Figure 32 provides a valid, combined sample of using the Page region, attributes, and comments
on a single grid.
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Figure 32

Retrieving in Free-Form Mode

➤ To construct a free-form report:

1 Open a worksheet and connect to a data source as described in “Connecting to a Data Source” on page
37.

2 In the worksheet, type in the member names for the report in the layout that you want to create.

For example, in a blank worksheet connected to the Sample Basic application and database in
Essbase, to see the total product sales in New York, you may type New York in cell B1 and
Sales in cell A2.

If a member name you entered is a duplicate, the Member Name Resolution dialog box is
displayed. See “Resolving Member Names in Free-Form Grids” on page 121 for information
on using this dialog box.

Note:

If a member name consists of a number, such as 100, you must precede the member name with
a single quotation mark (for example, '100). This rule also applies to member names with spaces
between words.

3 Refresh the grid using any of the methods described in “Refreshing the Grid” on page 88.

Smart View retrieves data from the connected data source for the members you entered into the
free-form report.

4 Optional: Perform further Ad Hoc operations on the worksheet.

For example, you may proceed by performing one or more of the following operations:

● Zoom in on dimensions and members, as described in “Zooming In on Dimension
Members” on page 89.
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● Insert rows and add formulas to cells, as described in “Working with Formulas in Ad Hoc
Grids” on page 98.

● Pivot dimensions from the POV to the worksheet, as described in “Pivoting Dimensions”
on page 93.

See “Answering Business Questions Using Free-Form” on page 122 for an example free-form
scenario.

Resolving Dimension Names
When you select Hyperion > Member Selection in a blank grid, the Dimension Name Resolution
dialog box is displayed, where you choose a dimension or members to place on the grid. This
process is referred to as resolving dimensions because when you choose the Member Selection
option on a blank sheet, the data source has no way of predicting which dimension or members,
including attribute members, you want to see and choose from in the Member Selection dialog
box.

When you choose dimensions and members using this method, be sure that the first cell you
select on the sheet is the cell in which you want to begin your free-form layout.

Note:

For Hyperion Enterprise data source, you cannot place dimensions on the grid.

➤ To resolve dimensions names in a grid:

1 In a blank worksheet, select a cell.

For example, to build a grid that starts from the left column, select cell A2. To build a grid that
starts on the first row, select cell B1.

2 Select Hyperion > Member Selection. For Office 2007, click Member Selection in the Task section of the
Hyperion ribbon.

3 In the Dimension Name Resolution dialog box, select the dimension to place on the sheet.

For example, if you are connected to an Essbase data source, select the Product dimension.

4 To orient members vertically in the worksheet starting from the cell you selected in step 1, select the Vertical
Orientation check box.

This check box is cleared by default; meaning that members will be oriented horizontally across
the sheet from the cell you selected in step 1.

5 Click OK to launch the Member Selection dialog box.

6 Select the members to place on the worksheet, as described in “Selecting Members for Ad Hoc Analysis”
on page 81, and click OK.

7 View the layout of the dimension or members you just placed on the sheet.

8 Perform one of the following actions:

● If you placed members vertically on the grid:

Resolving Dimension Names 119



❍ Repeat step 1 through step 7 to place a new set of members horizontally on the grid

❍ Use the POV to pivot a dimension to a row

❍ Type a dimension or member name (including attribute dimension or member names)
directly on the grid

● If you placed members horizontally on the grid:

❍ Repeat step 1 through step 7 to place a new set of members vertically on the grid

❍ Use the POV to pivot a dimension to a column

❍ Type a dimension or member name (including attribute dimension or member names)
directly on the grid

9 Refresh the grid using any of the methods described in “Refreshing the Grid” on page 88.

Retrieving Attribute Dimensions in Free-Form Mode
You retrieve attribute dimensions using a method similar to that described in “Resolving
Dimension Names” on page 119.

You can also retrieve an attribute member by typing the name directly in the worksheet, as
described in “Retrieving Attribute Dimensions and Members” on page 90. This method can be
used when the base dimension already exists on the worksheet.

The method for retrieving attributes described in this section assumes you are starting with a
blank worksheet.

Note:

Hyperion Enterprise does not support Attribute dimensions.

➤ To retrieve an attribute dimension in free-form using Member Selection:

1 In a blank worksheet, select a cell.

For example, to build a grid from the left column, select cell A2. To build a grid that starts on
the first row, select cell B1.

2 Select Hyperion > Member Selection. For Office 2007, click Member Selection in the Task section of the
Hyperion ribbon.

3 In the Dimension Name Resolution dialog box, select the attribute dimension.

For example, if you are connected to an Essbase data source, to query by package type, select the
Pkg Type attribute dimension.

4 To orient members vertically in the worksheet starting from the cell you selected in step 1, select the Vertical
Orientation check box.

This check box is cleared by default; meaning that members will be oriented horizontally across
the sheet from the cell you selected in step 1.

5 Click OK to launch the Member Selection dialog box.
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6 Select the members to place on the worksheet, as described in “Selecting Members for Ad Hoc Analysis”
on page 81.

Note:

You can also add attribute dimensions and members to the sheet using the procedure in
“Retrieving Attribute Dimensions and Members” on page 90.

Resolving Member Names in Free-Form Grids
When working in a free-form grid, Smart View may not be able to identify the dimension to
which a member that you have typed belongs. For example, if you type the member name
“Albany” on an empty worksheet, Smart View cannot know whether this signifies the member
Albany whose parent is New York or California, or whether the member Albany comes from a
market or a customer dimension. In this case, Smart View asks you to resolve the member by
providing the dimension to which the member belongs.

When you type a member name that Smart View cannot resolve, the Member Name Resolution
dialog box is displayed.

Note:

The Member Name Resolution dialog box only appears when you are connected to a Financial
Management or Hyperion Enterprise data source. If you are connected to an Essbase data source,
an error message is displayed. In this case, use Member Selection to choose member names, as
described in “Selecting Members for Ad Hoc Analysis” on page 81.

➤ To resolve a member name:

1 In the Member Name Resolution dialog box, select the dimension to which the member belongs from the
drop-down list.

If a second unresolved member exists, a second drop-down list is displayed.

2 Optional: If a second unresolved member exists, select the dimension to which the member belongs from
the second drop-down list.

3 Click OK.

4 Refresh the grid using any of the methods described in “Refreshing the Grid” on page 88.

Smart View retrieves data from the connected data source and displays the resolved members
in the following format: [Dimension].[Member]. This format is not supported for Hyperion
Enterprise data sources. For Hyperion Enterprise, Smart View displays the resolved member
names in the following format: Member. The number of members displayed in the name depends
on the number of members necessary to uniquely identify the member.
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Answering Business Questions Using Free-Form
Free-Form reporting gives you the ability to answer business questions beyond those represented
on a standard report. By providing the ability to quickly create an ad hoc grid, through typing
or using member selection, Free-Form reporting moves you from question to answer. For
example, what if you wanted to know: What are my actual sales in New York?

The following steps lead you through a series of questions based on the Essbase Sample Basic
database. The process starts with a single business and culminates with a reusable report
template.

Note:

The scenario in this topic assumes that you are connected to the Essbase Sample Basic database.

➤ To construct an example free-form report:

1 Type the member names Sales in cell A2 and New York in cell B1, and then select Hyperion >
Refresh. For Office 2007, click Refresh in the Review section of the Hyperion ribbon.

You should see a grid similar to this:

The total Sales figure for New York is $32,229. But how does this figure break down? This leads
to new questions, such as what are the sales by product? What are the sales by quarter?

2 View sales by product using the Select Member option in the POV to select all the products from Product
dimension.

a. In the POV, click Options > Select Members > Product.

b. In the Select Member dialog box, select Product and members 100, 200, 300, and 400 and

then click .

c. Click OK.

The POV should look similar to this:
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3 Click the arrow in the Product dimension, select 100, and refresh the grid to view only the sales total for
product 100.

Refresh the grid by selecting Hyperion > Refresh; clicking , or clicking the green arrow in
the POV. For Office 2007, click Refresh in the Review section of the Hyperion ribbon.

4 In the POV, click the arrow next to 100 and select 200, then refresh the grid to view the sales total for product
200; repeat to view sales totals for products 300 and 400.

5 Click the arrow next to 400 and select Product; and then drag Product from the POV to the grid and drop it
on the Sales cell.

The grid and POV should look similar to this:

6 Select Hyperion > Options (or Office 2007, click Options in the Options section of the Hyperion ribbon)
and in the Options dialog box, set the following options:

● In the Ad Hoc tab, select Suppress Repeated Members options.

● In the Display tab, clear the #No Data/Missing Label text box.

Refresh the grid to view the effect of these options changes.

Note:

The Suppress Repeated Members option only affects member names in the outermost row or
columns.

7 Change the nesting order by moving Sales; right-click Sales and drag it on top of the Product cell.

The grid should look similar to this:

Note:

When Sales was moved to the outer column in the grid, the repeated members in the column
were suppressed.
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8 Pivot the dimensions on the grid by selecting either the Sales or Product dimension and clicking  or
selecting Hyperion > Ad Hoc Analysis > Pivot; try this several times to see different layouts of the grid.

When there are two row dimensions, pivot one of the row dimensions. When there are two
column dimensions, pivot one of the column dimensions.

9 Click the Undo button, , until the grid appears as it was in step 7.

Next, we will take a look at how New York breaks down across product lines and scenarios.

10 Pivot the Scenario dimension to a column.

In the POV, click Options > Pivot to Column > Scenario to place the Scenario dimension on
the worksheet. The Scenario dimension should appear above New York in the grid.

11 In the worksheet, zoom in on Scenario.

Select Scenario and zoom in by performing one of the following actions:

● Select Hyperion > Ad Hoc Analysis > Zoom In. For Office 2007, click Zoom In in the As
Hoc Analysis section of the Hyperion ribbon.

● Click .

● Double-click Scenario.

12 Change the replacement text to display for missing or no label cells to a hyphen (-).

a. Select Hyperion > Options (or Office 2007, click Options in the Options section of the
Hyperion ribbon), and then click Display.

b. In the #NoData/Missing Label text box, type a hyphen, -, then click OK.

c. Refresh the grid to view the changes in the Diet row.

13 Remove the Scenario column.

After the zoom in operation, we decide that the Scenario column is not really needed. To remove
the Scenario column:

a. Select the cell that contains “Scenario.” This should be cell G1, but may be different in
your worksheet.

b. Select Hyperion > Ad Hoc Analysis > Remove Only (For Office 2007, click Remove.

Only in the Ad Hoc Analysis section of the Hyperion ribbon) or click . The entire
column is removed from the grid.

14 Move Product to the bottom of the grid.

Perform the following steps to move the Product dimension below the product members in the
worksheet:

a. Zoom out on member 100 by selecting 100 in the grid and clicking . Your grid should
look similar to this:
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b. Delete row 4, the row that is the result of the zoom out operation. Select the row and use
the Excel command, Edit > Delete, to delete the row.

c. Zoom in on the Product dimension to expand it and place Product at the bottom of the
grid, as shown:

Now we would like to see a quarterly breakdown.

15 Pivot the Year dimension to a row.

In the POV, click Options > Pivot to Row > Year to place the Year dimension on the worksheet.
The Year dimension should appear to the left of the Sales dimension in the grid.

Now we want to see a quarterly breakdown.

16 Zoom in on the Year dimension.

Zoom in by performing one of the following actions:

● Select Year and then select Hyperion > Ad Hoc Analysis > Zoom In.

● Click .

● Double-click on Year.

The grid expands, as shown in the following graphic:
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The grid getting long. We will shorten the length.

17 Perform the following steps to shorten the grid length:

a. Drag 100 in cell C3 on top of New York in cell D2.

b. Next, drag New York in cell C3 on top of Actual in cell C1.

Now the grid is wide. We will shorten the width.

18 Perform the following steps to remove the Variance and Diet members from the grid.

a. Select the cell that contains “Variance.” This should be cell O2, but may be different in
your worksheet.

b. Select Hyperion > Ad Hoc Analysis > Remove Only or click  to remove the entire
column and associated columns from the grid.

c. Select the cell that contains “Diet.” This should be cell S3, but may be different in your
worksheet.

d. Repeat step 18.b.

The grid should look similar to this:
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After a review of the worksheet, we would like to add first and second half totals to the
grid, as well a variance for those totals. In the next series of steps, we will add several
formulas to the worksheet.

19 Add three new rows at the bottom of the worksheet, above Year.

You should have three blank rows between Q4 and Year.

20 Type labels for the new rows.

a. In cell A8, type First Half Total.

b. In cell A9, type Second Half Total.

c. In cell A10, type First/Second Variance.

21 Use Excel’s formula functionality to add formulas for the first half and second half totals.

a. In the first new row (row 8), enter a formula in the 100 column under Actual to total Q1
and Q2.

For example, in cell C8, enter the formula:

=SUM(C4:C5)

Then, copy the formula across the row from cell D8 to cell L8.

b. In the second new row (row 9), enter a formula in the 100 column under Actual to total
Q3 and Q4.

For example, in cell C9, enter the formula:

=SUM(C6:C7)

Then, copy the formula across the row from cell D9 to cell L9.

22 Use Excel’s formula functionality to add a formula to figure the difference between first half and second half
sales totals.

In the third new row (row 10), add a formula in the 100 column under Actual.

For example, in cell C10, enter the formula:

=SUM(C8-C9)

Then, copy the formula across the row from cell D10 to cell L10.

23 Use Excel’s formula functionality to add formulas to average the variance figures for the first half and second
half.

a. In cell M8 of the first new blank row, enter a formula in the 100 column under Variance %
to average the Q1 and Q2 variance percentages.

For example, in cell M8, enter the formula:

=AVERAGE(M4:M5)
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Then, copy the formula across the row from cell N8 to cell Q8.

b. In cell M9 of the second new blank row, enter a formula in the 100 column under
Variance % to average the Q3 and Q4 variance percentages.

For example, in cell M9, enter the formula:

=AVERAGE(M6:M7)

Then, copy the formula across the row from cell N9 to cell Q9.

24 Use Excel’s formula functionality to add a formula to figure the difference between the first half and second
half average variance figures.

In cell M10 of the third new blank row, add a formula in the 100 column under Variance % to
figure the difference between the first half and second half variance percentages.

For example, in cell M10, enter the formula:

=SUM(M8-M9)

Then, copy the formula across the from cell N10 to cell Q10.

25 Use Excel’s formula functionality to add formulas to average the variance figures for the first half and second
half.

In cell M11, on the same row as Year, add a formula in the100 column under Variance % to
average the first half and second variance percentages.

For example, in cell M11, enter the formula:

=AVERAGE(M8:M9)

Then, copy the formula across the row from cell N11 to cell Q11.

The following is a portion of the grid. Your grid should look similar to this.

Now we can create a template from our worksheet. By doing so, this worksheet can be shared
with other users. First, we will do some further formatting of the sheet.

26 Select Hyperion > Options > Display tab and select the Use Excel Formatting check box.

Alternatively, you may choose to clear the Use Excel Formatting check box and use the Capture
Formatting command to retain the formatting styles that you apply, or use Cell Styles to apply
styles based on intersections in the connected database. However, certain Excel styles you apply
using Capture Formatting or Cell Styles may be lost upon refresh.

27 Decrease the decimal places of the variance percentage figures.
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In Excel, highlight the range of variance percentage figures, select Format > Cells, and for the
Number category on the Number tab, decrease the decimal places to 2.

28 Add dollar signs and decimal places to the Sales figures.

In Excel, highlight the range of sales figures, select Format > Cells, and for the Currency category
on the Number tab, increase the decimal places to 2 and choose the dollar sign ($) as the currency
symbol.

The grid should look similar to this:

29 Use Excel formatting to add background colors to the grid.

Alternatively, you may choose to use the Capture Formatting command to retain the colors after
a refresh.

For example, select cells C4 through F7, select a fill color from the Excel toolbar, then select
Hyperion > Capture Formatting. Be sure the range of cells is still highlighted when you select
the Capture Formatting command.

Capture Formatting only retains formats on data cells that were derived from your ad hoc
operations. It does not retain formats for the cells that were manually added to the grid.

30 Display aliases for member names in the worksheet.

Select Hyperion > Ad Hoc Analysis > Change Alias Table and, for this example, choose “Default”
in the Select Alias Table dialog box.

For more information on using aliases for member names, see “Displaying Aliases for Member
Names” on page 91.

31 Save the workbook.

32 Using VBA functionality, add buttons to the worksheet.

To simplify connecting and refreshing for users with whom you may share this worksheet, use
Excel’s Visual Basic Editor to add buttons to the worksheet and use the Smart View VBA code
samples listed to attach functionality to each button:

● Connect button, to invoke the Connection Manager dialog box to make a data source
connection

x = HypMenuVConnect

● Refresh button, to perform a refresh of the worksheet

x = HypMenuVRefresh

● Disconnect button, to invoke the Connection Manager to disconnect from the data source
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x = HypMenuVDisconnect

Instructions for using VBA functions are in Chapter 17, “VBA Functions.”

See “Using Smart View VBA Functions” on page 224 for instructions on adding a button and
assigning a VBA macro to it.

33 Refresh the worksheet and review the formatting and layout.

For example, check the following items:

● Review the formatting of the sheet. Has Excel formatting you applied been retained? Note
that selections made in the Cell Styles tab of the Options dialog box are overridden if you
are using Excel formatting.

● Test the buttons you added in step 32. Is the correct functionality attached to the button?

● Are the Excel formulas you entered are still valid?

Figure 33 is an example of the spreadsheet developed in this section, with the exception of the
background color formatting and the placement on the worksheet. Also, a title was added to the
page and the cells surrounding the active grid were filled with white using the Fill Color button
on Excel’s Formatting toolbar.

This worksheet provides information to users about the sales of product in New York. It provides
easy data source connection access and refresh functionality. It can be reused by other regional
managers, for example, by replacing the state name, New York, with another state name, like
Florida.

Figure 33 Formatted Free-Form Report
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Constructing an Example Free-form Report Using a Hyperion
Enterprise Data Source

Consider an application in Hyperion Enterprise which has a schedule with the following POV
(Point Of View):

● Category-Actual

● Period-Jan 99

● Organization-Europe

● Entity-Greece

● Account-INVSUB (Investments in Subsidiaries)

The scenario in this section assumes that you are connected to this application and the following
steps lead you through a series of questions based on this application. For example, what if you
wanted to know:What are my investments in subsidiarires of Greece?

The process starts with a single business and culminates with a reusable report template.

➤ To construct an example free-form report:

1 Type the member names INVSUB in cell A2,GREECE in cell B2, and CTD in cell C1. Select Hyperion >
Refresh.

You should see a grid similar to this:

The total investments in subsidiarires for New York is $423240. But how does this figure break
down? This leads to new questions, such as what are the investments by each subsidiary? What
are the investments by quarter?

2 View investments by each subsidiary using Member Selection to select all the subsidiarires from Account
dimension.

a. Click cell A2 and select Hyperion > Member Selection.

b. In Member Selection, select Account and children members of INVSUB and then click

.

c. Click OK.
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The grid and POV should look similar to this:

3 Select Hyperion > Options and in the Options dialog box, set the following options:

● In the Ad Hoc tab, select Suppress Repeated Members options.

● In the Display tab, clear the #No Data/Missing Label text box.

Refresh the grid to view the effect of these options changes.

Note:

The Suppress Repeated Members option only affects member names in the outermost row or
columns.

4 Change the nesting order by moving GREECE; right-click GREECE and drag it on top of the INVSUB cell.

The grid should look similar to this:

Note:

When GREECE was moved to the outer column in the grid, the repeated members in the column
were suppressed.

5 Pivot the dimensions on the grid by selecting either the GREECE or INVSUB member and clicking  or
selecting Hyperion > Ad Hoc Analysis > Pivot; try this several times to see different layouts of the grid.

When there are two row dimensions, pivot one of the row dimensions. When there are two
column dimensions, pivot one of the column dimensions.

6 Click the Undo button, , until the grid appears as it was in step 7.

7 Pivot the member Y 99 to a column.

In the POV, right-click, drag and drop Y 99 on top of cell C1. The Y 99 member should appear
above CTD in the grid.
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8 In the worksheet, zoom in on Y 99.

Select Y 99 and zoom in by performing one of the following actions:

● Select Hyperion > Ad Hoc Analysis > Zoom In.

● Click .

● Double-click on Y 99.

9 Change the replacement text to display for missing or no label cells to a hyphen (-).

a. Select Hyperion > Options, and then click Display.

b. In #NoData/Missing Label , type a hyphen, -, then click OK.

c. Refresh the grid to view the changes in the INVSUB.SPAIN row.

10 Remove the Y 99 column.

After the zoom in operation, we decide that the Y 99 column is not really needed. To remove
the Y 99 column:

a. Select the cell that contains “Y 99.” This should be cell C1, but may be different in your
worksheet.

b. Select Hyperion > Ad Hoc Analysis > Remove Only or click . The entire column is
removed from the grid.

11 Move INVSUB to the bottom of the grid.

Perform the following steps to move the INVSUB member below the children members in the
worksheet:

a. Zoom out on member INVSUB.ITALY by selecting it in the grid and clicking . Your
grid should look similar to this:

b. Select Hyperion > Options and click Ad Hoc. In Ancestor Position, select Bottom and
click OK.

c. Zoom in on the INVSUB member to expand and place it at the bottom of the grid, as
shown:
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Now we would like to see a quarterly breakdown.

12 Pivot Year dimension members to a row.

Select HY1 99 in the grid and select Hyperion > Ad Hoc Analysis > Pivot.

13 Zoom in on HY1 99 member.

Zoom in by performing one of the following actions:

● Select HY1 99 and then select Hyperion > Ad Hoc Analysis > Zoom In.

● Click .

● Double-click on HY1 99.
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14 Repeat step 12 for HY2 99. Remove HY1 99 and HY2 99 rows by selecting it in the grid and selecting
Hyperion > Ad Hoc Analysis > Remove Only. Your grid should look similar to this:

The grid getting long, we will shorten the length.

15 Drag INVSUB.ITALY in cell C2 on top of CTD in cell D1 to shorten the grid length.

Now the grid is wide. We will shorten the length.

16 Perform the following steps to remove the INVSUB.SPAIN member from the grid.

a. Select the cell that contains “INVSUB.SPAIN.”

b. Select Hyperion > Ad Hoc Analysis > Remove Only or click  to remove the entire
column and associated columns from the grid. The grid should look similar to this
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After a review of the worksheet, we would like to add first and second half totals to the
grid, as well a variance for those totals. In the next series of steps, we will add formulae to
the worksheet.

17 Add three new rows at the bottom of the worksheet.

You should have three blank rows after Q4 99.

18 Type labels for the new rows.

a. In cell A7, type First Half Total.

b. In cell A8, type Second Half Total.

c. In cell A9, type First/Second Variance.

19 Use Excel’s formula functionality to add formulas for the first half and second half totals.

a. In the first new row (row 8), enter a formula in the INVSUB.ITALY column to total Q1
99 and Q2 99.

For example, in cell C7, enter the formula:

=SUM(C3:C4)

Then, copy the formula across the row from cell D7 to cell G7.

b. In the second new row (row 9), enter a formula in the INVSUB.ITALY column to total
Q3 99 and Q4 99.

For example, in cell C8, enter the formula:

=SUM(C5:C6)

Then, copy the formula across the row from cell D8 to cell G8.

20 Use Excel’s formula functionality to add a formula to figure the difference between first half and second half
sales totals.

In the third new row (row 9), add a formula in the INVSUB column .

For example, in cell C9, enter the formula:

=SUM(C7-C8)

Then, copy the formula across the row from cell D9 to cell G9.

The grid should look similar to this:

21 Select Hyperion > Options > Display  and select the Use Excel Formatting check box.
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Alternatively, you may choose to clear the Use Excel Formatting check box and use the Capture
Formatting command to retain the formatting styles that you apply, or use Cell Styles to apply
styles based on intersections in the connected database. However, certain Excel styles you apply
using Capture Formatting or Cell Styles may be lost upon refresh.

22 Add dollar signs and decimal places to the figures in data region cells.

In Excel, highlight the range of data region cells, select Format > Cells, and for the Currency
category on the Number tab, increase the decimal places to 2 and choose the dollar sign ($) as
the currency symbol.

23 Use Excel formatting to add background colors to the grid.

Alternatively, you may choose to use the Capture Formatting command to retain the colors after
a refresh.

For example, select cells C7 through G9, select a fill color from the Excel toolbar, then select
Hyperion > Capture Formatting. Be sure the range of cells is still highlighted when you select
the Capture Formatting command.

Capture Formatting only retains formats on data cells that were derived from your ad hoc
operations. It does not retain formats for the cells that were manually added to the grid.

24 Save the workbook.

25 Refresh the worksheet and review the formatting and layout.

For example, check the following items:

● Review the formatting of the sheet. Has Excel formatting you applied been retained? Note
that selections made in the Cell Styles tab of the Options dialog box are overridden if you
are using Excel formatting.

● Are the Excel formulas you entered are still valid?

Figure 24 is an example of the spreadsheet developed in this section, with the exception of the
background color formatting and the placement on the worksheet. Also, a title was added to the
page and the cells surrounding the active grid were filled with white using the Fill Color button
on Excel’s Formatting toolbar.

This worksheet provides information to users about the investments in subsidiarires in
GREECE . It provides easy data source connection access and refresh functionality. It can be
reused by other regional managers, for example, by replacing the state name, GREECE, with
another name, like New York.
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Figure 34 Formatted Free-Form Report

Analyzing Time-Related Data in Free-Form Mode
(Essbase only) Using Smart View, you can analyze flash metrics such as sales of cost of goods
sold against time-based metrics. This enables you to look for trends, find averages for different
time periods, and so forth. To do this, you use linked attributes which enable periodicity of
members. Periodicity is a shared pattern among time dimension members that make them
meaningful for time-based analysis (January and April share periodicity as first months of
quarters, for example). Day by month, day by week, and week by year are examples of linked
attributes. You can also set ranges for linked attributes and apply filters.

➤ To analyze time-related data in free-form mode:

1 Open an Excel worksheet and connect to a data source.

2 Select Date-Time member and select Hyperion > Member Selection to open Member Selection, where
you can select members and apply filters as described in “Filtering Members in Queries” on page 74. For
Office 2007, click Member Selection in the Task section of the Hyperion ribbon.

3 To enter linked attributes, insert a new column to the left of the Date-Time member and select Hyperion >
Member Selection. Linked attributes are selectable from the Dimensions dropdown menu in the Dimension
Name Resolution dialog box.

4 Select Hyperion > Refresh. For Office 2007, click Refresh in the Review section of the Hyperion ribbon.

Highly Formatted Free-Form Report Example
You can use Free-Form to build and customize a report to your own specifications, using the
formatting options you require. Figure 35 is an example of a highly formatted free-form report.
This report example was created using the following Excel formats:

● Standardized column widths

● Cell fill (using multiple colors for each scenario, including dark line breaks)

● Cell-based double-underscoring above totals (for example, row 6)

● Currency and percentage symbols added in various columns

● Excel formulas to derive additional values (rows 23-30)
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● Excel Conditional formatting for dynamic highlighting (for example rows 26 and 27)

● Text box with stylized text for the grid label

Figure 35 Highly Formatted Free-Form Report

Creating and Distributing Report Templates Using Free-Form
Free-form reporting provides a solid foundation for the creation and distribution of report
templates. For the scenario in this section, assume that part of your job was creating a report
such as that shown in “Highly Formatted Free-Form Report Example” on page 138. Also assume
that you want to create a series of product line detail reports across multiple markets, based on
the highly-formatted report. Furthermore, the reporting requirements span data sources in both
Essbase and Financial Management. You can use the free-form capabilities of Smart View to
create your report templates.

The following steps use the sample applications provided with Essbase. Note that these steps
work for Financial Management or Hyperion Enterprise or Essbase data sources.

These sections comprise the taskflow for report template creation and distribution:

● “Creating a Base Grid Using Dimension Name Resolution” on page 139

● “Using Free-Form to Expand the Layout” on page 140

● “Leveraging Excel Formulas” on page 141

● “Formatting the Grid” on page 143

● “Using the POV as a Page Selector” on page 144

● “Creating Additional Reports” on page 144

Creating a Base Grid Using Dimension Name Resolution
With Smart View, you can select members into empty cells in a grid. This process is referred to
as dimension name resolution and allows you to select members without typing or using the
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POV member selector. Additionally, you can use this option to lay out a simple grid as a
foundation for analysis.

Note:

Before beginning the procedure, ensure that Indentation option is set to “Subitems,” as described
in “Indenting Member Names” on page 202.

➤ To create a base grid using dimension name resolution:

1 On a blank Excel worksheet, connect to the Essbase Sample Basic data source.

2 Place the cursor in cell C5 and select Hyperion > Member Selection to display the Dimension Name
Resolution dialog box. For Office 2007, click Member Selection in the Task section of the Hyperion ribbon.

3 Select Measures from the list, and select Vertical Orientation, and then click OK.

Selecting Vertical Orientation places the resulting members vertically onto the grid, whereas
clearing Vertical Orientation places the resulting members horizontally onto the grid.

4 In Member Selection, from the Members list, select these members, and click OK:

Profit Total Expenses

Margin Marketing

COGS Payroll

Sales Misc

5 Place the cursor in D4 and select Hyperion > Member Selection.

6 In Dimension Name Resolution, select Product from the list; do not select Vertical Orientation.

7 In Member Selection, from the Members list, select one product line and its children; for example, select
product line 100 and its children.

8 Refresh the worksheet.

The grid should look similar to this:

Using Free-Form to Expand the Layout
You can useSmart View free-form capabilities to further expand the grid by:
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● Typing directly onto the grid

● Using the Microsoft Office copy and paste functionality

➤ To make further member selections using free-form capabilities:

1 Select cell B5 and type Actual.

2 Refresh the worksheet.

Notice that Scenario is removed from the POV because a member from the Scenario
dimension, Actual, is now represented on the grid.

3 Select cells C5 through C12, copy them, and then paste them starting in cell C13.

4 In cell B13, type Budget.

5 Refresh the worksheet.

The grid should look similar to this:

Leveraging Excel Formulas
Smart View provides the capability of preserving Excel-based formulas entered on a grid. These
can be used to further extend the analysis begun with an ad hoc query. Assume for this example
that you want to determine budget variances in Excel.

➤ To leverage Excel formulas in the worksheet:

1 Select cells C5 through C12, copy them, and then paste them starting in cell C21.
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2 In cells C21 to C28, type an underscore ( _ ) at the end of each member name; for example, Profit_.

Adding the underscore character changes the cell from a member cell to a label cell. This allows
you to use labels for the budget variance rows that are almost the same as the member cells.

Tip:

The underscore is suggested because it is fairly imperceptible to users, but Smart View treats it
as a label.

3 In cell B21, type Actual vs. Plan.

4 Refresh the grid to validate that the labels in the variance area remain undisturbed.

The grid should look similar to this:

5 In cell D21, enter this formula:

=D5-D13

6 Fill the formula down and across all of the cells in the variance region, and refresh the worksheet.

After refresh, the formulas are preserved. The grid should look similar to this:
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Formatting the Grid
Smart View provides a myriad of formatting options. You can take advantage of the Smart View
capture formatting feature, Hyperion product-specific styles, and Excel-based formatting. This
example demonstrates applying Excel-based formatting to the grid.

➤ To apply Excel-based formatting to the grid:

1 Select Hyperion > Options to display the Options dialog box. For Office 2007, click Options in the
Options section of the Hyperion ribbon.

2 Select the Display tab, select Use Excel Formatting, and click OK.

3 Apply these Excel-based formats:

● Fill the worksheet, outside of the data region light grey.

● Fill product cells in row 4 with light yellow

● Fill cells B5 through C12 with light green

● Fill cells B13 through C20 with light blue

● Fill cells B21 through C28 with white

● Place double-underlines beneath all total accounts, and place these in a larger, bold font

● Insert a row, filled with black, in between each scenario region

● Make all column widths 20

● Place currency symbols on all values

● Using a text box, place a title on the report

The resulting grid should look similar to the following:

4 Refresh the worksheet and verify that the formats and formulas are preserved.
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Using the POV as a Page Selector
Once you have a formatted grid in place, you can select members from dimensions in the POV
to quickly view the worksheet from the point of view of the member selected and still preserve
overall grid formatting. For example, you may select the region members from the Market
dimension, then select a specific region from the POV. After refreshing the grid, your formulas
and data points are updated to reflect the point of view of the selected region, preserving any
grid formatting you have applied.

➤ To use the POV as a page selector:

1 View sales by market using the Select Member option in the POV to select all products from all regions in
the Market dimension.

a. In the POV, click Options > Select Members > Market.

b. In Member Selection, select Market and members East, West, South, and

Central, and then click .

c. Click OK.

2 Click the arrow in the Market dimension, select East, and refresh the grid to view only the totals for the
East region.

3 In the POV, click the arrow next to East and select West, then refresh the grid to view the totals for the
West region; repeat to view totals for the South and Central regions.

Creating Additional Reports
Once you have a report that contains, for example, the formatting and formulas you want, you
can use this report as a template for creating additional reports.

For example, assume you want a product detail report for each product line. Using the free-form
capabilities previously described, you can create subsequent reports for product lines 200
through 400.

➤ To create additional reports using the original report as a template:

1 Ensure that the Excel workbook contains five worksheets.

2 Copy the contents of Sheet 1 onto Sheet 2.

3 On Sheet 2, select product 100 in cell D4.

4 Select Hyperion > Member Selection to display the Member Selection dialog box.

5 In the Members area, select product 200 and its children members, and then add them to the Selection
area.

6 If product 100 is in the selection area, remove it.

The Selection area should contain the members:

● 200
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● 200-10

● 200-20

● 200-30

● 200-40

7 Refresh the worksheet.

Notice that after the new members are on the grid, one column extends past the previously
formatted region:

8 To format the new column to match the existing columns, use the Excel format paint option or manually
apply the Excel formats so that the resulting grid looks similar to the following:
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9 Repeat step 3 through step 8 for the remaining worksheets and products, adding or removing data columns
and applying the appropriate formats as necessary.

Using the POV as a Page Drop-down
When you have completed the grids, you can then set up the POV as a type of page drop-down
to help users leverage the report.

➤ To set up the POV as a page drop-down:

1 In the POV on Sheet 1, select Options > Select Members > Market to display Member Selection.

2 Select all members from the Market dimension and click OK.

3 Dock the POV at the top of the Excel window.

You can now select members from the POV as needed and refresh the grid. As you do so, the
data values on the grid are recalculated based on the selection in the POV:

In this example, California is about to be selected:
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Tips
● Name the sheets to match the product line represented on each sheet.

● Use the Refresh All option to refresh all sheets in a workbook at one time, versus manually
selecting and refreshing each sheet.

Note:

The techniques shown in Creating and Distributing Report Templates Using Free-Form, and in
Answering Business Questions Using Free-Form work correctly whether you are connected to
an Essbase or Financial Management or Hyperion Enterprise data source.

Retrieving Data into Asymmetric Reports
When you retrieve data into a worksheet, the resulting report can be either symmetric or
asymmetric. Symmetric reports are characterized by repeating identical groups of members. For
example, a symmetric report may contain Actual and Budget members nested below Year
members (Qtr1, Qtr2, Qtr3, and Qtr4).

An asymmetric report is characterized by groups of nested members that differ by at least one
member. There can be a difference in the number of members or in the names of members.

You can create asymmetric reports in one of the following ways:

● Enter member names into the worksheet in free-form retrieval mode.
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● Use a zoom in action with the “Within Selected Group” option selected from the Ad Hoc
tab of the Options dialog box. See “Member Retention Options” on page 205 for
information on setting this property.

● Suppress rows that contain missing values, zero values, or underscore characters during data
retrievals. See “Suppressing Types of Data” on page 201 for information on suppressing
rows.

Note that if you retrieve data into an asymmetric report, Smart View must perform additional
internal processing to maintain the asymmetric layout. This processing may increase the retrieval
time on large reports.
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Copying and Pasting Live Data into Word and PowerPoint
To present data, Word or PowerPoint is often preferable to Excel. Smart View enables you to
copy data points from Excel and paste them into Word or PowerPoint, creating linked views
(dynamic data) between applications.

Note:

When creating connections to data source providers, do not use semicolons (;) in connection
names planned for using functions. An error occurs when pasting function data points, if
connection names contain semicolons.

You can copy and paste data points from:

● Excel to Word and PowerPoint

● Word to Word and PowerPoint

● PowerPoint to Word and PowerPoint

The data points retain their original Excel-based query information, thus enabling users to
perform data analysis. Word and PowerPoint can contain data points from multiple data sources,
such as Essbase, Financial Management, and Hyperion Enterprise within one document.

Notes:

● Dynamic data points are maintained only in Word and PowerPoint. If you copy and paste
data points within Excel, the data points are not linked to the Excel grid.

● When copying and pasting from Word to PowerPoint, or vice versa, data is displayed in a
straight line. The tabular format is preserved only when copying data from Excel into Word
or PowerPoint.

● Excel formatting is preserved when data is pasted into Word and PowerPoint. Apply the
formatting in Excel before copying and pasting data.

● You can use Word or PowerPoint tools to change number formatting.
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➤ To copy and paste data from Excel to Word or PowerPoint:

1 In Excel, select a data cell or range (may or may not include members).

2 Select Hyperion > Copy Data Points. For Office 2007, click Copy Data in the Task section of the
Hyperion ribbon.

3 Open a Word or PowerPoint document.

4 When asked if you want to create a connection, click Yes.

5 Select Hyperion > Paste Data Points. For Office 2007, click Paste Data in the Task section of the
Hyperion ribbon.

6 Select Hyperion > Refresh or Hyperion > Refresh All For Office 2007, click Refresh or Refresh All in the
Review section of the Hyperion ribbon.

The procedure for copying and pasting data points from Word to Word and PowerPoint or
PowerPoint to Word and PowerPoint are similar.

Note:

When pasting data points into Word and saving the document in another format, such as
a .htm or .mht file, you cannot refresh the data.

You can retrieve the Excel queries from which the data points were copied.

➤ To retrieve the Excel spreadsheets from which data points were copied:

1 In a Word or PowerPoint document into which Excel data points were pasted, select the data cells.

2 Select Hyperion > Link View > Visualize in Excel. For Office 2007, click Visualize in Excel in the
Visualize section of the Hyperion ribbon.

3 If asked to log on the data source, enter the username and password.

Excel displays the spreadsheet associated with the data cells. You can perform ad hoc analysis
on the data.

You can view dynamic data in Visual Explorer.

Note:

Hyperion Enterprise does not support display of dynamic data in Visual Explorer.

➤ To display the data in Hyperion Visual Explorer:

1 In a Word or PowerPoint document into which Excel data points were pasted, select the data cells.

2 Select Hyperion > Link View > Visualize in HVE. For Office 2007, click Visualize in Excel in the
Visualize section of the Hyperion ribbon.

Visual Explorer is displayed. See Visual Explorer Online Help.
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Changing POV in Word and PowerPoint
After pasting Excel data points into Word or PowerPoint, you can use the POV Manager to
change the POV.

➤ To change the POV in Word or PowerPoint:

1 In a Word or PowerPoint document into which Excel data points were pasted, select Hyperion > POV
Manager. For Office 2007, click POV Manager in the Task section of the Hyperion ribbon.

2 In POV Manager, expand the POV list.

The data source connection information and active POV members are listed.

3 To change the POV, double-click a member in the POV list or click Member Selector.

The Member Selection dialog box is displayed.

4 Select a member using the Member Selection dialog box. See “Selecting Members for Ad Hoc Analysis” on
page 81.

5 Optional: To modify the URL connection:

a. Under Connection, double-click the URL.

b. In Add Data Source, connect to a new data source.

See “Adding a Data Source Connection” on page 34.

6 Click Close.

7 Select Hyperion > Refresh or Hyperion > Refresh All. For Office 2007, click Refresh or Refresh All in the
Review section of the Hyperion ribbon.
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Viewing Data in Graphical Format
Visual Explorer (HVE) is a visual analysis and reporting tool that enables Essbase users licensed
to use HVE to explore and analyze databases. HVE can be launched from Excel, Word, or
PowerPoint with or without Smart View. With Smart View, data can be passed from HVE back
to the Excel worksheet from which it was launched or inserted into a new worksheet where you
can do additional analysis.

Note:

See the Visual Explorer online help for information on what Visual Explorer can do and how it
works.

Viewing Data in Excel

➤ To view data in Excel using Visual Explorer:

1 Open a worksheet in Excel.

2 Connect to an Essbase data source.

3 Create a report or use an existing one.

4 Select Hyperion > Link View > Visualize in HVE. For Office 2007, click Visualize in HVE in the Visualize
section of the Hyperion ribbon.

The Visual Explorer interface is displayed.

5 In Show Me! Alternatives, select a format and click OK.
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Viewing Data from Word or PowerPoint
Smart View enables you to copy data points from Excel to Word or PowerPoint and have those
data points retain their original spreadsheet query information. See Chapter 9, “Accessing
Dynamic Data Across Microsoft Office.” You can also view the data in Word or PowerPoint in
graphical format using Visual Explorer.

➤ To view data in Word or PowerPoint in Visual Explorer:

1 Select the data cells in Word or PowerPoint.

2 Select Hyperion > Visualize in HVE.

For Office 2007, click Visualize in Excel in the Visualize section of the Hyperion ribbon.

3 In Show Me! Alternatives, select a graphical format and click OK.

Visual Explorer displays the spreadsheet associated with the data cells in graphical format.

Starting Visual Explorer Independently of Smart View
You can start Oracle's Hyperion® Essbase® Visual Explorer as a stand-alone application,
independent of Excel and Smart View.

➤ To start Visual Explorer as a stand-alone application:

1 Navigate to the location of your Smart View installation.

The default location is C:\Hyperion\SmartView.

2 In the bin folder, double-click hve.exe.

3 To connect to an Essbase data source, select Data > Connect to Data Source and follow the procedure in
“Connecting to a Data Source” on page 37 to complete the connection.
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Importing Reporting and Analysis Documents
Using Smart View, you can import Reporting and Analysis documents into Microsoft Excel,
Word, or PowerPoint.

● For Financial Reporting and Web Analysis, you can import reports.

● For Interactive Reporting, you can import charts, dashboards, and reports. Using the latest
run of BQY jobs, Interactive Reporting supports refresh capabilities.

● For SQR Production Reporting, you can import jobs and job outputs.

Important tasks:

● “Importing Interactive Reporting Documents” on page 158

● “Importing Financial Reporting Documents” on page 162

● “Importing Production Reporting Documents” on page 165

● “Importing Web Analysis Documents” on page 168

● “Using Smart Tags to Import Reporting and Analysis Documents ” on page 172

● “Creating PowerPoint Templates for Financial Reporting” on page 173
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Editing and Refreshing Documents
In Office, the Hyperion menu (Hyperion ribbon in Office 2007) provides the ability to edit and
refresh documents that were previously imported from Workspace. The Hyperion menu or
ribbon provides the following edit and refresh options:

● Edit—change filters, POVs, or parameters of embedded Workspace documents.

● Refresh—refresh the selected job with the latest Workspace data. Only the job selected in
Office is updated; not the entire Office document.

● Refresh All— update all jobs in the Office document.

General edit and refresh behavior

● After the initial import into Office, you can delete any number of pages. Then, when you
perform a Refresh, an update is performed on the remaining pages; the deleted pages are
not reinstated into the document. For example, if you delete page 2 of 4 pages, only pages
1, 3, and 4 are updated.

● If during Edit or refresh the number of imported pages are less than the original import, the
removed pages display as blanks pages in Office.

● If an Edit or Refresh results in additional Workspace pages, those pages are appended to the
end of the document in Office.

● With refresh, formatted pages such as headings and comments are retained in Word and
PowerPoint. In Excel, formatting is not retained on refreshed pages.

Maintaining cell references during document refresh

In Excel, a customized worksheet that references imported document cells or ranges is updated
when you execute a Refresh All on the imported documents. For example, imported worksheet
A and B are referenced in customized worksheet C. When you execute Refresh All on worksheet
A and B, worksheet C is refreshed with updated data from worksheets A and B.

Refreshing Reporting and Analysis Documents
Refreshing updates the report with the latest data from Workspace.

Refresh behavior in SQR Production Reporting and Interactive Reporting:

● In Word, if a report is selected, the entire report is refreshed. If no report is selected, the first
report found in the document is refreshed. The first report is not necessarily the report at
the beginning of the document.

● In PowerPoint, if no report is selected, the first report found in the slide is updated.

When refreshing job outputs in SQR Production Reporting, new outputs in Workspace are
updated.

Refresh behaviors in Financial Reporting and Web Analysis:

● You must select a page in the report to refresh. In Word and PowerPoint, if you do not select
any pages when refreshing, a message is displaying stating that no pages are updated.
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● If you select Refresh, all pages of the report are refreshed. If you select Refresh All, then all
reports in the document are refreshed.

➤ To refresh Workspace documents in Excel, Word, or PowerPoint, perform an action:

1 Select Hyperion > Refresh to update the selected Reporting and Analysis document, including all pages
associated with that document. For Office 2007, click Refresh in the Review section of the Hyperion ribbon.

2 Or, select Hyperion > Refresh All to update all Reporting and Analysis documents. For Office 2007, click
Refresh All in the Review section of the Hyperion ribbon.

Refreshing Reporting and Analysis documents against Essbase or Financial Management
connections

Note:

This applies to Financial Reporting and Web Analysis reports imported into query-ready HTML.

Refreshing against Essbase or Financial Management connections updates the report with the
latest data from Analytic Services and enables you to perform ad hoc analysis on the Reporting
and Analysis document, such as retrieving, zooming, or pivoting data. See Chapter 7, “Working
with Ad Hoc Analysis”.

Refresh for a report imported in query-ready HTML applies to the current page and not all pages.

Important Tasks
● “Editing Interactive Reporting Documents” on page 161

● “Editing Financial Reporting Documents” on page 164

● “Editing Production Reporting Jobs ” on page 168

● “Editing Web Analysis Documents” on page 171

Financial Reporting and Web Analysis Import Formats
You can import Financial Reporting and Web Analysis documents as fully-formatted HTML,
which you can display in Excel, or in query-ready HTML, which enables you to connect to
Financial Management or Essbase data sources and run queries.

When you import Reporting and Analysis documents as query-ready HTML, the selected pages
of the current data object is converted to HTML, and Hyperion-specific formatting is removed.
Thus, Smart View can re-query the data source independent of the Web application.

When you import Reporting and Analysis documents as fully formatted HTML, the selected
pages of the current data object is converted to HTML, and Hyperion formatting definitions
and calculated members are retained. Thus, Smart View cannot directly query the data source,
but Hyperion content can be leveraged by Microsoft Office applications.
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Tip:

After importing an image in Word or PowerPoint, use the Microsoft Office Format Picture
option to format it; for example, to crop and resize. The Format Picture settings are preserved,
even after you refresh the image.

Adding Security Certificates for SSL-enabled Workspace Servers
When accessing Workspace servers running on HTTPS protocols, the server's security certificate
must be issued by a trusted company. To avoid unnecessary prompts when importing
documents, you must add the security certificate into the Internet Explorer certificate path on
the Smart View client's machine.

➤ To add security certificates:

1 In Internet Explorer, connect to Workspace; for example:

https://<workspace_webserver>.hyperion.com/workspace/index.jsp.

2 If prompted with the warning message, “The security certificate was issued by a company you have not chosen
to trust,” select View Certificate.

3 Select Certification Path.

4 Ensure that all certificates in the certification path have been trusted.

Importing Interactive Reporting Documents
● “Importing Interactive Reporting Documents into Excel” on page 159

● “Importing Interactive Reporting Documents into Word and PowerPoint” on page 160

● “Editing Interactive Reporting Documents” on page 161

Imported Interactive Reporting documents are section-specific.

Table 6 Interactive Reporting Import Object Types

Section Excel Word, PowerPoint

Table Formatted data NA

Results Formatted data NA

Chart Formatted data Image

Pivot Formatted data NA

Report Formatted data Image

Dashboard Image Image

Query NA NA
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Section Excel Word, PowerPoint

Data model NA NA

The following restrictions apply when Interactive Reporting documents are imported into Excel:

● Hidden sections are displayed during import.

● Importing dashboard sections into Excel resizes A1 cells.

● Importing report sections into Excel places chart images before tables.

● Importing into Excel may not preserve colors correctly.

● Results sections that contain the euro currency format do not import into Excel.

● Results sections with "+" in their name do not import.

Importing Interactive Reporting Documents into Excel

➤ To import Interactive Reporting documents into Excel:

1 Using Connection Manager, connect to a Workspace data source.

See “Adding a Data Source Through Direct Connection” on page 35 and “Adding a Data Source
Through Shared Services” on page 36.

2 If you have multiple connections, select Hyperion > Active Connections, and select a data source. For Office
2007, click Activate in the Connections section of the Hyperion ribbon.

3 Select Hyperion > Reporting and Analysis Document > Import. For Office 2007, click BI Import in the
Task section of the Hyperion ribbon.

The Import Workspace Document dialog box is displayed.

4 In Select a Document, expand the repository, select an Interactive Reporting document, and click OK.

A wizard screen is displayed.

Note:

Some wizard screens do not apply to some documents.

5 In Select an Action, select an option:

● Process and Preview, to change filters or values prior to previewing the document

● Preview, to preview the document with default settings

6 Click Next.

7 If you selected Process and Preview:

a. If user authentication is required to change filters, such as variable, value, or option in the
document's settings, in Specify Database Credentials, enter the username and password,
and click Next.

The connection name is displayed in parentheses (for example, Sample.oce).
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b. In Specify Filters, select a value.

8 Click Apply, and click Next.

9 If importing a multiple-page document in Preview, use the Page navigation buttons to select a page to
preview:

●  goes to the first page of the report

●  goes to the previous page of the report

●  goes to the next page of the report

●  goes to the last page of the report

10 Optional: to import all pages of the document, select All Pages.

11 If your document contains multiple pages, select Split pages across worksheets to display each page on
a separate Excel worksheet.

12 Click Finish.

The document is displayed in Excel.

Importing Interactive Reporting Documents into Word and
PowerPoint

➤ To import Interactive Reporting documents into Word:

1 Using Connection Manager, connect to a Workspace data source.

See “Adding a Data Source Through Direct Connection” on page 35 and “Adding a Data Source
Through Shared Services” on page 36.

2 Select Hyperion > Reporting and Analysis Document > Import. For Office 2007, click BI Import in the
Task section of the Hyperion ribbon.

The Import Workspace Document dialog box is displayed.

3 In Select a Document, expand the repository, select an Oracle's Hyperion® Interactive Reporting – System
9 document, and click OK.

Note:

Some wizard screens do not apply to some documents.

4 In Select an Action, select an option:

● Process and Preview, to change filters or values prior to previewing the document

● Preview, to preview the document with default settings

5 Click Next.

6 If you selected Process and Preview:
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a. If user authentication is required to change filters, such as variable, value, or option in the
document settings, in Specify Database Credentials, enter the username and password,
and click Next.

The connection name is displayed in parentheses (for example, Sample.oce).

b. In Specify Filters, select a value.

7 Click Apply, and click Next.

8 If importing a multiple-page document, in Preview, use the Page navigation buttons to select a page to
preview:

●  goes to the first page of the report

●  goes to the previous page of the report

●  goes to the next page of the report

●  goes to the last page of the report

9 Optional: To import all pages of the document, select All Pages.

10 Click Finish.

The document is imported.

Editing Interactive Reporting Documents

➤ To edit Interactive Reporting documents in Excel, Word, and PowerPoint:

1 Select a page.

Note:

When editing a report, select a page from the report, then Edit. If you do not select a page, a
message is displayed stating that no pages are updated.

2 Select Hyperion > Reporting and Analysis Document > Edit. For Office 2007, click BI Edit in the Task
section of the Hyperion ribbon.

3 If you selected Process and Preview:

a. If user authentication is required to change filters, such as variable, value, or option in the
document settings, in Specify Database Credentials, enter the username and password,
and click Next.

The connection name is displayed in parentheses (for example, Sample.oce).

b. In Specify Filters, select a value.

4 Click Apply, and click Next.

5 If importing a multiple-page document, in Preview, use the Page navigation buttons to select a page to
preview.
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●  goes to the first page of the report

●  goes to the previous page of the report

●  goes to the next page of the report

●  goes to the last page of the report

6 Click Finish.

Importing Financial Reporting Documents
● “Financial Reporting and Web Analysis Import Formats” on page 157.

● “Importing Financial Reporting Documents into Excel” on page 162

● “Importing Financial Reporting Documents into Word and PowerPoint” on page 164

● “Editing Financial Reporting Documents” on page 164

Table 7  Financial Reporting Import Document Types

Document Type Excel Word, PowerPoint

Report Fully formatted, query-ready Image

Snapshot report Fully formatted Image

Book NA NA

Snapshot Book NA NA

Batch NA NA

Grid Object NA NA

Image Object NA NA

Chart Object NA NA

Text Object NA NA

Row and Column template NA NA

Importing Financial Reporting Documents into Excel

➤ To import Financial Reporting documents into Excel:

1 Using Connection Manager, connect to a Workspace data source.

See “Adding a Data Source Through Direct Connection” on page 35 and “Adding a Data Source
Through Shared Services” on page 36.
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2 If you have multiple connections, select Hyperion > Active Connections and select a data source to activate.
For Office 2007, click Activate in the Connections section of the Hyperion ribbon.

3 Select Hyperion > Reporting and Analysis Document > Import. For Office 2007, click BI Import in the
Task section of the Hyperion ribbon.

The Import Workspace Document dialog box is displayed.

4 In Select a Document, expand the repository, select a Financial Reporting document, and click OK.

The document is previewed in the Import Workspace Document window.

Note:

Some options may not be available for some documents.

5 If the Preview User Point of View is displayed, preview the current POV or change the members of the POV.

Note:

To display this screen, select Preview in Workspace preferences, for User Point of View.

6 Click Next.

7 Optional: If you want to change the default value, in Respond to Prompts, make a selection for prompts,
and click Next.

Note:

This screen is displayed only if the document contains prompts.

8 Optional: In Preview from Grid POV, change the POV by selecting a POV.

9 Change the page dimension by selecting Page.

10 To import all pages of the document, select All Pages to import all pages of the document.

11 To display each page on a separate Excel worksheet, select Split Pages across worksheets.

12 In Import Document As, select an option:

● Fully-Formatted (displays reports in a fully-formatted HTML)

● Query-Ready (enables you to run ad hoc analysis on reports when connected to Financial
Management and Essbase data sources)

13 Click Finish.

The document is imported into Excel. If you used the Fully-Formatted option, you can only
view the Reporting and Analysis document. If you used the Query-Ready option, then connect
to a Financial Management or Essbase data source, you can perform ad hoc analysis, such as
retrieving, zooming, or pivoting data. See Chapter 7, “Working with Ad Hoc Analysis”.
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Importing Financial Reporting Documents into Word and
PowerPoint

➤ To import Financial Reporting documents into Word and PowerPoint:

1 Using Connection Manager, connect to a Workspace data source.

See “Adding a Data Source Through Direct Connection” on page 35 and “Adding a Data Source
Through Shared Services” on page 36.

2 Select Hyperion > Reporting and Analysis Document > Import. For Office 2007, click BI Import in the
Task section of the Hyperion ribbon.

The Import Workspace Document dialog box is displayed.

3 In Select a Document, expand the repository, select a Financial Reporting document, then click OK.

The document is previewed in the Import Workspace Document window.

Note:

Some screens do not apply to some documents.

4 If the Preview User Point of View screen is displayed, preview the current POV or change the members of
the POV by selecting a member.

Note:

To display this screen, select Preview in Workspace preferences, for User Point of View.

5 Optional: If you want to change the default value, in Respond to Prompts, make a selection for prompts,
and click Next.

Note:

This screen is displayed only if the document contains prompts.

6 In Preview  from Grid POV, change the POV by selecting a POV.

7 Change the page dimension by selecting Page.

8 Select All Pages to import all pages of the document.

9 In Import Document As, select Image to import the document as an image.

10 Click Finish.

The document is imported.

Editing Financial Reporting Documents

➤ To edit Financial Reporting documents in Excel, Word, and PowerPoint:

1 Select a page.
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Note:

When editing a report, select a page from the report, then Edit.

2 Select Hyperion > Reporting and Analysis Document > Edit. For Office 2007, click BI Edit in the Task
section of the Hyperion ribbon.

3 If the Preview User Point of View screen is displayed, preview the current POV or change the members of
the POV.

Note:

To display this screen, select Preview in Workspace preferences, for User Point of View.

4 Optional: If you want to change the default value, in Respond to Prompts, make a selection for prompts,
and click Next.

Note:

This screen is displayed only if the document contains prompts.

5 If you want to change the POV, in Preview from Grid POV select a POV.

6 Click Finish.

Importing Production Reporting Documents
SQR Production Reporting documents consist of jobs and job outputs, which you can import
into Excel, Word, and PowerPoint.

● “Importing Production Reporting Jobs into Excel” on page 165

● “Importing Production Reporting Jobs into Word and PowerPoint” on page 166

● “Importing Production Reporting Job Outputs into Excel, Word, and PowerPoint” on page
167

● “Editing Production Reporting Jobs ” on page 168

Table 8  Production Reporting Import Object Types

Object Type Excel Word, PowerPoint

Job Formatted data Image

Job output Formatted data Image

Some limitations exist for importing:

● Images and charts are not imported into Excel.

● Secure jobs are supported, but jobs imported as generic jobs are not supported.

Importing Production Reporting Jobs into Excel
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➤ To import Production Reporting jobs into Excel:

1 Using Connection Manager, connect to a Workspace data source. See “Adding a Data Source Through
Direct Connection” on page 35 and “Adding a Data Source Through Shared Services” on page 36.

2 If you have multiple connections, select Hyperion > Active Connections and select a data source to activate.
For Office 2007, click Activate in the Connections section of the Hyperion ribbon.

3 Select Hyperion > Reporting and Analysis Document > Import. For Office 2007, click BI Import in the
Task section of the Hyperion ribbon.

The Import Workspace Document dialog box is displayed.

4 In Select a Document, expand the repository, select a SQR Production Reporting job, then click OK.

The import wizard screen is displayed.

Note:

Depending on the document, some screens may not be applicable.

5 If the Specify Parameters screen is displayed, define the job parameters, and click Next.

Note:

This screen is displayed only if the job contains parameters.

6 In Preview, if importing a multiple page job, use the Page navigation buttons to select a page to preview:

●  goes to the first page of the report

●  goes to the previous page of the report

●  goes to the next page of the report

●  goes to the last page of the report

7 To import all pages of the job, select All Pages.

8 Select Split Pages across worksheets to display each page on a separate Excel worksheet.

9 Click Finish.

The document is displayed in Excel.

Importing Production Reporting Jobs into Word and
PowerPoint
The procedures for importing SQR Production Reporting jobs into Word and PowerPoint are
similar.

➤ To import SQR Production Reporting jobs into Word and PowerPoint:

1 Using Connection Manager, connect to a Workspace data source.
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See “Adding a Data Source Through Direct Connection” on page 35 and “Adding a Data Source
Through Shared Services” on page 36.

2 Select Hyperion > Reporting and Analysis Document > Import. For Office 2007, click BI Import in the
Task section of the Hyperion ribbon.

The Import Workspace Document dialog box is displayed.

3 In Select a Document, expand the repository, select a Reporting and Analysis document, then click OK.

The import wizard is displayed.

Note:

Some screens may not apply to some documents.

4 If the Specify Parameters screen is displayed, define the job parameters, and click Next.

Note:

This screen is displayed only if the job contains parameters.

5 If importing a multiple-page job, in Preview, use the Page navigation buttons to select a page to preview:

●  goes to the first page of the report

●  goes to the previous page of the report

●  goes to the next page of the report

●  goes to the last page of the report

6 To import all pages of the job, select All Pages.

For Word, Split pages across pages is disabled. For PowerPoint, Split pages across slides is
selected and disabled because by default, the pages from jobs or job outputs always split across
pages and slides.

7 Click Finish.

The job is imported.

Importing Production Reporting Job Outputs into Excel, Word,
and PowerPoint

➤ To import Production Reporting job outputs into Excel, Word, and PowerPoint:

1 Using Connection Manager, connect to a Workspace data source. See “Adding a Data Source Through
Direct Connection” on page 35 and “Adding a Data Source Through Shared Services” on page 36.

2 If you have multiple connections, select Hyperion > Active Connections and select a data source to activate.
For Office 2007, click Activate in the Connections section of the Hyperion ribbon.
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3 Select Hyperion > Reporting and Analysis Document > Import. For Office 2007, click BI Import in the
Task section of the Hyperion ribbon.

The Import Workspace Document dialog box is displayed.

4 In Select a Document, expand the repository, select a SQR Production Reporting job output, then click
OK.

The job output is imported.

Editing Production Reporting Jobs
You can edit imported Oracle's Hyperion® SQR® Production Reporting – System 9 jobs, but
not job outputs. You can edit only job parameters.

➤ To edit SQR Production Reporting jobs:

1 Select a page.

Note:

When editing a report, select a page from the report, then Edit. If you do not select a page, a
message is displayed stating that no pages are updated.

2 Select Hyperion > Reporting and Analysis Document > Edit. For Office 2007, click BI Edit in the Task
section of the Hyperion ribbon.

The Import Workspace Document dialog box is displayed.

3 If the Specify Parameters screen is displayed, define the job parameters, and click Next.

Note:

This screen is displayed only if the job contains parameters.

4 In Preview. view the job.

Note:

If you deleted any imported pages, edit updates only the remaining pages of the job.

5 Click Finish.

The job is updated.

Importing Web Analysis Documents
Web Analysis includes five data object display types, but Smart View can import only three
(spreadsheet, chart, and pinboard). Smart View cannot import freeform grid and SQL
spreadsheets. See “Financial Reporting and Web Analysis Import Formats” on page 157.

● “Importing Web Analysis Documents into Excel” on page 169

168 Importing Reporting and Analysis Documents into Microsoft Office



● “Importing Web Analysis Documents into Word and PowerPoint” on page 170

● “Editing Web Analysis Documents” on page 171

Table 9  Web Analysis Import Document Type

Document Type Excel Word, PowerPoint

Report Fully formatted, query-ready Image

Table 10  Web Analysis Import Data Object Type

Data Object Excel Word, PowerPoint

Spreadsheet Data + formatting Image

Chart Data + formatting Image

Pinboard Data + formatting Image

Importing Web Analysis Documents into Excel

➤ To import Web Analysis documents into Excel:

1 Using Connection Manager, connect to a Workspace data source. See “Adding a Data Source Through
Direct Connection” on page 35 and “Adding a Data Source Through Shared Services” on page 36.

2 If you have multiple connections, select Hyperion > Active Connections and select a data source to activate.
For Office 2007, click Activate in the Connections section of the Hyperion ribbon.

3 Select Hyperion > Reporting and Analysis Document > Import. For Office 2007, click BI Import in the
Task section of the Hyperion ribbon.

The Import Workspace Document dialog box is displayed.

4 In Select a Document, expand the repository, select a Web Analysis document, and click OK.

5 If database credentials are not saved with the Web Analysis document, then the Specify Database
Credentials page is displayed where you are required to enter valid log on credentials to data sources used
in the report. If a report has only one data source and you skip entering credentials, the report is not imported.
If you have data objects with different data sources in one report and only want to import one of the data
objects, you can enter the credentials for the data objects you want to import and skip credential for the
data object you do not wish to import. Enter the user name and password or select Skip to skip entering
credentials to any of the data sources, and click Next.

Tip:

Select Save Credentials to save credentials with a Web Analysis document.

6 Select a data object (spreadsheet, chart, or pinboard) to import.

7 In Preview, using the Pages navigation buttons, select a page to import:

●  goes to the first page of the report
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●  goes to the previous page of the report

●  goes to the next page of the report

●  goes to the last page of the report

8 Optional: To import all pages of the document, select All Pages.

9 If your document contains multiple pages, select Split Pages across worksheets to display each page on
a separate Excel worksheet.

10 To import multiple objects on multiple sheets, select All Report Objects.

Note:

You can select Split pages across worksheets to import objects on separate worksheets instead
of one worksheet.

11 In Import Document As, select an option:

● Fully Formatted (imports reports in fully-formatted HTML)

● Query-Ready (imports reports in query-ready HTML)

12 Click Finish.

The document is imported in Excel. If you used the Fully Formatted option, you can only view
the Reporting and Analysis document. If you used the Query-Ready option, connect to a
Financial Management or Essbase data source, to perform ad hoc analysis on the Reporting and
Analysis document, such as retrieving, zooming, or pivoting data. See Chapter 7, “Working with
Ad Hoc Analysis.”

Importing Web Analysis Documents into Word and
PowerPoint

➤ To import Web Analysis documents into Word and PowerPoint:

1 Using Connection Manager, connect to a Workspace data source.

See “Adding a Data Source Through Direct Connection” on page 35 and “Adding a Data Source
Through Shared Services” on page 36.

2 Select Hyperion > Reporting and Analysis Document > Import. For Office 2007, click BI Import in the
Task section of the Hyperion ribbon.

The Import Workspace Document dialog box is displayed.

3 In Select a Document, expand the repository, select a Web Analysis document, and click OK.

4 If database credentials are not saved with the Web Analysis document, then the Specify Database
Credentials page is displayed where you are required to enter valid log on credentials to data sources used
in the report. If a report has only one data source and you skip entering credentials, the report is not imported.
If you have data objects with different data sources in one report and only want to import one of the data
objects, you can enter the credentials for the data objects you want to import and skip credential for the
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data object you do not wish to import. Enter the User Name and Password, or select Skip to skip entering
credentials to any of the data sources, and click Next.

Tip:

Select Save Credentials to save credentials with a Web Analysis document. It enables you to
refresh an imported document later. Currently, you cannot refresh imported documents without
saving credentials.

5 Select a data object (spreadsheet, chart, or pinboard) to import.

6 In Preview, using the Page navigation buttons, select a page to import:

●  goes to the first page of the report

●  goes to the previous page of the report

●  goes to the next page of the report

●  goes to the last page of the report

7 Optional: To import all pages of the document, select All Pages.

8 In Import Document As, select Image to import the document as image objects.

9 To import multiple objects on multiple sheets, select All Report Objects.

10 Click Finish.

The document is imported.

Editing Web Analysis Documents

➤ To edit Web Analysis documents:

1 Select a page (Excel) or an image (Word or PowerPoint).

Note:

When editing a report, select a page (Excel) or an image (Word or PowerPoint) from the report,
then Edit. If you do not select a page or an image, a message is displayed stating that no pages
are updated.

2 Select Hyperion > Reporting and Analysis Document > Edit. For Office 2007, click BI Edit in the Task
section of the Hyperion ribbon.

3 If database credentials are not saved with the Web Analysis document, then the Specify Database
Credentials page is displayed. In Specify Database Credentials, enter the user name and password, or
select Skip, then click Next.
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Tip:

You can select Save Credentials to save them with the Oracle's Hyperion® Web Analysis – System
9 document.

4 Select a data object (spreadsheet, chart, or pinboard) to import.

5 In Preview, using the Page navigation buttons, select a page to import:

●  goes to the first page of the report

●  goes to the previous page of the report

●  goes to the next page of the report

●  goes to the last page of the report

6 Select All Pages to import all pages of the document. Leave the box cleared to import only the current page.

7 Select Split Pages across worksheets to display each page on a separate worksheet (Excel only).

8 In Import Document As, select:

● Fully Formatted (Excel only)

● Query-Ready (Excel only)

● Image (Word and PowerPoint)

9 Click Finish.

Using Smart Tags to Import Reporting and Analysis Documents
For Microsoft Office 2003, smart tags provide an alternative way of importing Reporting and
Analysis documents, enabling you to import fully-formatted image objects from Workspace into
documents.

Smart tags are supported in Outlook 2003 only if the e-mail editor uses Microsoft Word. By
default, smart tags are turned off. Smart tags are not supported in Office versions prior to
Microsoft Office 2003.

● “Using Smart Tags to Import Reporting and Analysis Documents ” on page 172

● “Removing Smart Tags for a Single Instance” on page 187

● “Stopping Hyperion Smart Tag Recognition” on page 188

● “Recognizing Smart View Smart Tags Again” on page 189

➤ To turn on smart tags:

1 Select Tools > AutoCorrect Options.

2 Select Smart Tags.

3 Select Label text with smart tags.

4 Click OK.

172 Importing Reporting and Analysis Documents into Microsoft Office



➤ To import Reporting and Analysis documents using smart tags:

1 Open a Microsoft Office document.

2 Select Hyperion > Connection Manager and connect to a Workspace data source.For Office 2007, click
Connect in the Connections section of the Hyperion ribbon.

See “Adding a Data Source Through Direct Connection” on page 35 and “Adding a Data Source
Through Shared Services” on page 36.

3 Type smartview anywhere in the document, then move the mouse over the word.

The smart tags action icon  is displayed. The smartview keyword is not case-sensitive.

4 Click  to display the Smart View menu.

5 From Smart View, select Reporting and Analysis Content.

The Import Workspace Document dialog box is displayed.

6 Follow the procedures for importing Reporting and Analysis documents after opening the Import Workspace
Document dialog box:

● “Importing Interactive Reporting Documents” on page 158

● “Importing Financial Reporting Documents” on page 162

● “Importing Production Reporting Documents” on page 165

● “Importing Web Analysis Documents” on page 168

Creating PowerPoint Templates for Financial Reporting
Using Smart View, you can create PowerPoint templates into which you can import multiple
Financial Reporting reports to form PowerPoint presentations that can be saved and later
refreshed.

➤ To create a template:

1 Open PowerPoint.

2 Select Hyperion > Connection Manager and connect to a Reporting and Analysis provider.

3 Select Hyperion > BI+ Document > Create Template to choose a Financial Reporting report. This action
creates a new PowerPoint slide for the report.

4 Repeat step 3 as needed to import additional Financial Reporting reports into the PowerPoint presentation

5 Select File > Save to save the PowerPoint presentation.

➤ To refresh a template:

1 Open the PowerPoint presentation containing the template to be refreshed

2 Select Hyperion > Connection Manager and connect to a Oracle's Hyperion® Reporting and Analysis –
System 9 provider.
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3 Select Hyperion > BI+ Document > Refresh Template.

The template is replaced with a new presentation, and each Financial Reporting report
placeholder in the template is replaced with the current Oracle's Hyperion® Financial Reporting
– System 9 report using the current Oracle's Hyperion® Workspace Point of View. To run the
template again you need to reopen the original emplate PowerPoint presentation.

4 Edit and save the PowerPoint presentation as needed.
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You can use functions to retrieve data from a Microsoft Excel worksheet and save it to your data
source, or send data from a data source to a worksheet. You can also use functions to retrieve
currency values, display member descriptions and labels, and send and retrieve cell text.
Functions are available when accessing Financial Management, Essbase, and Hyperion
Enterprise data source providers. You can also use smart tags to access functions.

Note:

When creating connections to data source providers, do not use semicolons (;) in connection
names planned for using functions. An error occurs when using Function Builder to create
functions.

When a worksheet that contains saved functions is opened on a different machine than the one
on which it was created, the functions include the path of the original machine. Smart View
automatically updates the function paths when you open the worksheet.
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Note:

If you are prompted to manually update the links, click Cancel and the links update
automatically. Functions are not updated automatically if the Excel “Ask to Update Automatic
Links” option is selected. In that case, you must manually update functions using the Excel Edit
> Links option. Functions on a protected worksheet are not automatically updated.

About Functions
You create functions by either of the following:

● The Function Builder (see “The Function Builder” on page 177).

● Creating function syntax manually (see “Creating Functions Manually” on page 189).

When you use the Function Builder to create functions, you can validate the function syntax
before you paste it to a worksheet. When you create functions manually in worksheet cells, the
functions are validated only when you refresh them.

Table 11 lists the available functions.

Table 11 Smart View Functions

Function Description

HsGetValue Retrieves data from a data source for a given Point of View.

Supported for Financial Management, Hyperion Enterprise, and Essbase.

HsSetValue Sends values to the data source for a given Point of View.

Supported for Financial Management, Hyperion Enterprise, and Essbase.

HsCurrency Retrieves the entity currency for the selected members.

Supported for Financial Management and Hyperion Enterprise.

HsDescription Displays the description for the default Point of View member.

Supported for Financial Management and Hyperion Enterprise.

HsLabel Displays the label for the default Point of View member.

Supported for Financial Management and Hyperion Enterprise.

HsGetText Retrieves cell text from the data source.

Supported for Financial Management.

HsSetText Sends cell text to the data source.

Supported for Financial Management.

For each function, you can specify a connection and a full or partial Point of View. If you do not
specify a connection, the system uses the default connection. Some functions also require a value.
For example, the HsSetValue function requires that you set a value in addition to the connection
and Point of View.
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If you do not specify a dimension in a function, the system uses the dimension member specified
in the POV Manager. See Chapter 15, “Using the POV Manager”.

If specified, the connection must precede the Point of View. The Point of View is made up of
dimension#member pairs, where the pound symbol (#) is a separator between dimension and
member, for example, Entity#Connecticut. Parent-child relationships can be represented with
a period, for example, Entity#UnitedStates.Maine.

The connection and Point of View can be grouped as one parameter, for example
“My_connection;Entity#UnitedStates”. Alternatively, they can be split up into several function
parameters, for example, “My_connection”, “Entity#UnitedStates”, “Account#Sales”. If the
connection and Point of View are in the same function parameter, the connection and each
dimension#member pair are separated by a semi-colon (;) character, for example,
“My_connection;Entity#UnitedStates;Account#Sales”.

Examples
HsGetValue(B4,“HFM01”,”Scenario#Actual;Year#2004;Period#July;View#YTD;
Entity#UnitedStates.Connecticut;Value#USD;Account#Sales;ICP#[ICP 
None];Custom1#GolfBalls;Custom2#Customer2;Custom3#[None];Custom4#
Increases”)

HsGetValue(B4,“HE01”,”Scenario#Actual;Period#July;View#YTD;
Entity#UnitedStates.Connecticut;Account#Sales”)

HsCurrency(“HFM03”,”Entity#UnitedStates.Connecticut”,”Value#USD”)

HsSetText
(“text”,”Scenario#Budget;Year#2004;Period#July;View#YTD;Entity#UnitedStates
.Connecticut;Value#USD;Account#Purchases;ICP#[ICP 
None];Custom1#GolfBalls;Custom2#Customer2;Custom3#[None];Custom4#
Increases”)

You can also use cell references in functions. For example, the following HsSetValue function
uses cell references for the data value in the H4 cell and for the period:

HsSetValue (H4,“Comma”;”Period#”&B$2&”;Entity#UnitedStates.Connecticut”)

The Function Builder
The Function Builder provides a graphical interface for creating functions. From the Function
Builder, you can select a function, then select dimension members for the Point of View. You
can view and validate the function before you paste it to the selected worksheet.

If a dimension does not apply for a specific function, the dimension is not available for selection.
If you do not select a member for a dimension, the system uses the default members from the
Point of View.

For information on selecting members, see “Selecting Members for Functions” on page 180.

You can use cell references for all functions except HsLabel. When you enter a cell number, for
example, B3, in the Member text box and select Cell Reference as the Member Type, the function
uses the value from the referenced cell.
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Note:

Before you begin this procedure, connect to all data sources that your functions will access.

➤ To create functions using the Function Builder:

1 Select the spreadsheet cell in which you want to paste the function.

2 Select Hyperion > Functions > Function Builder. For Office 2007, click Function Builder in the Task
section of the Hyperion ribbon.

3 From Select  Connection, select a data source.

Only connected data sources are displayed.

4 From the list of functions, select one of the following functions and then proceed to step 5:

● To retrieve values, select HsGetValue.

● To send values, select HsSetValue.

● To retrieve the entity currency, select HsCurrency.

● To display the description for the default Point of View member, select HsDescription.

● To display the label for the default Point of View member, select HsLabel.

● To retrieve cell text, select HsGetText.

● To submit cell text, select HsSetText.

Note:

When connected to Provider Services, only HsGetValue and HsSetValue are displayed in
Function Builder.

5 Depending on the function you selected in step 4, select parameters as follows:

Function Parameters

HsGetValue a. Select a dimension.

b. In the Member column, do one of the following:

● Double-click to enter a member name.

● Click Select Member to select members as described in “Selecting Members for Functions”
on page 180.

● To use a cell reference, enter a cell identity.

c. Double-click in the Member Type column. From the drop-down list, select Member or Cell
Reference.

HsSetValue a. Select a dimension.

b. In the Member column, do one of the following:

● Double-click to enter a member name.

● Click Select Member to select members as described in “Selecting Members for Functions”
on page 180.

● To use a cell reference, enter a cell identity.
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Function Parameters

c. Double-click in the Member Type column, then from the drop-down list, select either Member
or Cell Reference.

d. Select Data or Cell Reference and enter the value to send.

HsCurrency a. Select the Entity or Value dimension.

b. In the Member column, do one of the following:

● Double-click to enter a member name.

● Click Select Member to select members as described in “Selecting Members for Functions”
on page 180.

● To use a cell reference, enter a cell identity.

c. Double-click in the Member Type column. Fom the drop-down list, select Member or Cell
Reference.

HsDescription a. From the Dimension drop-down list, select a dimension.

b. In the Member column, do one of the following:

● Double-click to enter a member name.

● Click Select Member to select members as described in “Selecting Members for Functions”
on page 180.

● To use a cell reference, enter a cell identity.

c. Double-click in the Member Type column. From the drop-down list, select Member or Cell
Reference.

HsLabel From the Dimension drop-down list, select a dimension.

HsGetText a. Select a dimension.

b. In the Member column, do one of the following:

● Double-click to enter a member name.

● Click Select Member to select members as described in “Selecting Members for Functions”
on page 180.

● To use a cell reference, enter a cell identity.

c. Double-click in the Member Type column. From the drop-down list, select Member or Cell
Reference.

HsSetText a. Select a dimension.

b. In the Member column, do one of the following:

● Double-click to enter a member name.

● Click Select Member to select members as described in “Selecting Members for Functions”
on page 180.

● To use a cell reference, enter a cell identity.

c. Double-click in the Member Type column. From the drop-down list, select Member or Cell
Reference.

d. Select Comment or Cell Reference  and enter the text to send.

6 Click Add to Function.

7 Optional: To add another function, click Add to Function.
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8 Optional: If you have manually edited the function in the Function text box, to validate the function syntax
before inserting it into the worksheet, click Validate Syntax.

Note:

Validate Syntax validates only the syntax you are using for the function. It does not validate the
members you have selected.

9 Click OK to paste the function into the worksheet.

10 To execute the function, select Hyperion > Refresh or  Refresh All. For Office 2007, click Refresh or Refresh
All in the Review section of the Hyperion ribbon.

Note:

Selecting Hyperion > Refresh updates the sheet, but removes the function.

Selecting Members for Functions
You use the Member Selection dialog box to select dimension members. You can filter the list
of members and view labels or descriptions for dimension members. For example, when you
select to view descriptions, the P_Series member is displayed as “P_Series - Phones and PDAs”.

You can use the Select button to select multiple members simultaneously. For example, you can
select the Children option for all immediate dependents of a member, select the Base Members
option for all base members, or select both the Children and Base Members options to select all
dependents.

You can also search for dimension members. See step 10 on page 181.

➤ To select dimension members:

1 From the Function Builder, click Select Member.

2 From Dimension, select a dimension.

3 Optional: To filter the list of members, select a member list from the Filter drop-down list.

4 Optional: For advanced filtering, highlight a member without selecting its check box, then select a member
list.

This uses the highlighted member as the filter parameter. For example, if you highlight United
States and change the filter list to Children, the system displays the children of United States.

5 Optional: To display dimension descriptions instead of labels, select Use Descriptions.

6 Optional: To display Dynamic Time Series members for a time dimension, select Dynamic Time Series
Members.

Note:

The Dynamic Time Series option is available only with Essbase data sources.

7 Optional: To display active entities only, select Active Members.

180 Functions



Note:

Active Members is available only if the application has been set up for Organization by Period.
Active Members is unavailable for Hyperion Enterprise data sources.

8 Select each member that you want to use.

Tip:

To deselect all selected members, click Select None, .

9 Click Add, , to move the selected members to the Selection list.

Tip:

To remove members from the Selection list, select the members, then click Remove, . To

remove all members from the Selection list, click Remove All, .

10 Optional: To search for members in the selected dimension, complete the following steps:

a. Click  and enter the member name or pattern for which you want to search in the text
box.

You can enter the start of a text pattern or a trailing asterisk as a wildcard symbol. For
example, to find EastSales, you can enter “east” or “ea*.”

b. Click  to find the first member within the dimension that matches the search criteria.

Select the member if you want to use it and then click .

c. Click  again to search for the next occurrence and, if you want to use the member,

select the member and click .

Tip:

If you are at the bottom of the member list, click  to find the next member that matches
the search criteria.

Tip:

F3 enables the Find text box. Selecting F3 again searches down and Shift F3 searches up.

11 When you finish selecting members, click OK.
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HsGetValue
The HsGetValue function retrieves data from a data source for the dimension members that you
specify. You can specify all dimension members. Any member not specified is considered a
default POV member and uses the default in the POV Manager.

When users select Refresh or Refresh All, only HsGetValue is called. When users select Submit,
HsSetValue is called first, HsGetValue is then called only if HsSetValue returns sucessfully.

The syntax is as follows:

HsGetValue (“Connection”,”POV”)

Here are two examples:

The function in the following example returns the value from the HFM01 application for the
default Point of View.

Example 1:

HsGetValue(“HFM01”;”Scenario#Actual;Year#2004;Period#July;View#YTD;
Entity#UnitedStates.Connecticut;Value#USD;Account#Sales;ICP#[ICP 
None];Custom1#GolfBalls;Custom2#Customer2;Custom3#[None];Custom4#
Increases”)

The function in the following example returns the value from the HE application for the default
Point of View.

Example 2:

HsGetValue(“HE01”;”Scenario#Actual;Period#July;View#YTD;
Entity#UnitedStates.Connecticut;Account#Sales”)

HsSetValue
HsSetValue sends a data value from a worksheet to a data source for the dimension members
that you specify. You can select any dimension member.

The syntax is as follows:

HsSetValue (dollar amount,“Connection”,”POV”)

Here are two examples:

The function in the following example sends the value from the H4 cell to the HFM01
application.

Example 1:

HsSetValue(H4, "HFM01","Scenario#Actual;Year#2004;Period#"&B
$2&";View#<Scenario View>;Entity#UnitedStates.Connecticut;Value#<Entity 
Currency>;Account#"&$A4&";ICP#[ICP 
None];Custom1#GolfBalls;Custom2#Customer2;Custom3#[None];Custom4#
Increases")

The function in the following example sends the value from the H4 cell to the HE application.

Example 2:
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HsSetValue(H4, "HE01","Scenario#Actual;Period#"&B$2&";View#<Scenario 
View>;Entity#UnitedStates.Connecticut;Account#"&$A4")

Note:

To send data to a data source, you must have the appropriate load rule and write access for the
data source.

HsCurrency
HsCurrency retrieves the currency value of the specified dimension member. Entity and Value
are the only valid members for the HsCurrency function.Hyperion Enterprise does not support
the Value dimension member.

The syntax for Financial Management is as follows:

HsCurrency (“Connection,Entity;Value”)

Note:

The syntax for Hyperion Enterprise is the same as that of Financial Management with the
exception of Value dimension member.

The following lines show an example of retrieving the entity currency where the currency for
the East Sales entity is USD, and the currency for the UKSales entity is GBR.

HsCurrency(“Comma”,”Entity#EastRegion.EastSales;Value#<Entity Currency>.”)
HsCurrency(“Comma”,”Entity#EastRegion.UKSales;Value#<Entity Currency>.”)

In this example, the EastSales entity displays USD, and UKSales displays GBR.

HsDescription
HsDescription displays the description of the specified dimension member. You must specify
the dimension members one at a time.

The syntax is as follows:

HsDescription (“Connection”,”Dimension#Member”)

For example, the following function displays the description for Custom 4.

HsDescription("HFM01","Custom4#Increases")

HsLabel
HsLabel displays the default member label for a specified dimension member.

The syntax is as follows:
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HsLabel (“Connection,Dimension#”)

For example, the following function retrieves the label for the Scenario dimension in the Comma
application:

HsLabel (“Comma”,”Scenario#”)

HsGetText
HsGetText retrieves cell text from a data source. You can use all dimension members, or use cell
references, the default Point of View, or a combination of all three.

The syntax is as follows:

HsGetText (“Connection”,”POV”)

For example, the following function returns the cell text from the HFM01 data source for the
default Point of View.

HsGetText(“HFM01”,"Scenario#Actual;Year#2004;Period#"&B$2&";View#
<Scenario View>;Entity#UnitedStates.Connecticut;Value#<Entity 
Currency>;Account#"&$A3&";ICP#[ICP 
None];Custom1#GolfBalls;Custom2#Customer2;Custom3#[None];Custom4#
Increases")

HsSetText
HsSetText sends cell text to a data source. You can use all dimension members, or use cell
references, the default Point of View, or a combination of all three.

The syntax is as follows:

HsSetText(“Cell Text Comments”,”Connection;POV”)

For example, the following function sends the text from the H3 cell to the HFM01 application.

HsSetText(“H3”,”HFM01;Scenario#Actual;Year#2004;Period#"&B
$2&";View#<Scenario View>;Entity#UnitedStates.Connecticut;Value#<Entity 
Currency>;Account#"&$A3&";ICP#[ICP 
None];Custom1#GolfBalls;Custom2#Customer2;Custom3#[None];Custom4#
Increases")

Accessing Functions Using Smart Tags
Smart tags is a Microsoft Office 2003 feature designed to save time by performing actions in
Office that you would otherwise have other programs do. Smart tags recognizes specific
keywords that invoke associated functionality. Smart View supports smart tags in Excel, Word,
Power Point, and Outlook 2003. Using smart tags, you can type the “smartview” keyword in
Excel, Word, Power Point, or Outlook to invoke a Smart View menu. Smart tags provide an
alternative way of accessing functions for Financial Management, Hyperion Enterprise, and
Essbase. You can also use smart tags to import BI+ content. See “Using Smart Tags to Import
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Reporting and Analysis Documents ” on page 172. The “smartview” keyword is not case-
sensitive.

Note:

Smart tags are supported in Outlook 2003 only if the email editor is using Microsoft Word.
Smart tags are not supported in Office versions before Microsoft Office 2003.

You can perform the following tasks in Smart View using smart tags:

● “Retrieving Values” on page 185

● “Retrieving Cell Text” on page 186

● “Retrieving Entity Currency” on page 186

● “Displaying the POV Description” on page 187

● “Removing Smart Tags for a Single Instance” on page 187

● “Stopping Hyperion Smart Tag Recognition” on page 188

● “Recognizing Smart View Smart Tags Again” on page 189

Note:

By default, smart tags are disabled. To enable smart tags, go to Tools >AutoCorrect Options
>Smart Tags tab and select Label text with smart tags.

Retrieving Values
Using smart tags, you can retrieve a single data value using the HsGetValue function from
Financial Management, Hyperion Enterprise, and Essbase.

➤ To retrieve a single value using smart tags:

1 Select Hyperion > Connection Manager to connect to a Hyperion Financial Management, Hyperion
Enterprise, or Essbase data source. For Office 2007, click Connect in the Connections section of the
Hyperion ribbon.

See “Adding a Data Source Through Direct Connection” on page 35 and “Adding a Data Source
Through Shared Services” on page 36.

2 Type smartview anywhere in the document, then move the mouse over the word.

The Smart Tags Action icon  is displayed.

3 Click  to display the Smart View menu.

4 Select Functions > <connection name> > HsGetValue.

The Member Selection dialog box is displayed.

5 Follow the directions for “Selecting Members for Functions” on page 180.
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The value is displayed in your document.

Retrieving Cell Text
Using smart tags, you can retrieve cell text using the HsGetText function from Financial
Management.

Note:

Essbase and Hyperion Enterprise does not support the HsGetText function.

➤ To retrieve cell text using smart tags:

1 Select Hyperion > Connection Manager to connect to a Hyperion Financial Management data source. For
Office 2007, click Connect in the Connections section of the Hyperion ribbon.

See “Adding a Data Source Through Direct Connection” on page 35 and “Adding a Data Source
Through Shared Services” on page 36.

2 Type smartview anywhere in the document, then move the mouse over the word.

The Smart Tags Action icon  is displayed.

3 Click  to display the Smart View menu.

4 Select Functions > <connection name> > HsGetText.

The Member Selection dialog box is displayed.

5 Follow the directions for “Selecting Members for Functions” on page 180.

The cell text is displayed in your document.

Retrieving Entity Currency
Using smart tags, you can retrieve the entity currency for the selected members using the
HsCurrency function from Financial Management andHyperion Enterprise.

Note:

Essbase does not support the HsCurrency function.

➤ To retrieve the entity currency using smart tags:

1 Select Hyperion > Connection Manager to connect to a Hyperion Financial Management or Hyperion
Enterprise data source. For Office 2007, click Connect in the Connections section of the Hyperion ribbon.

See “Adding a Data Source Through Direct Connection” on page 35 and “Adding a Data Source
Through Shared Services” on page 36.
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2 Type smartview anywhere in the document, then move the mouse over the word. The Smart Tags Action

icon  is displayed.

3 Click  to display the Smart View menu.

4 Select Functions > <connection name> > HsCurrency.

The Member Selection dialog box is displayed.

5 Follow the directions for “Selecting Members for Functions” on page 180.

The entity currency is displayed in your document.

Displaying the POV Description
Using smart tags, you can display the description for the default Point of View member using
the HsDescription function from Financial Management and Hyperion Enterprise.

Note:

Essbase does not support the HsDescription function.

➤ To display the POV description using smart tags:

1 Select Hyperion > Connection Manager to connect to a Hyperion Financial Management or Hyperion
Enterprise data source. For Office 2007, click Connect in the Connections section of the Hyperion ribbon.

See “Adding a Data Source Through Direct Connection” on page 35 and “Adding a Data Source
Through Shared Services” on page 36.

2 Type smartview anywhere in the document, then move the mouse over the word. The Smart Tags Action

icon  is displayed.

3 Click  to display the Smart View menu.

4 Select Functions > <connection name> > HsDescription.

The Member Selection dialog box is displayed.

5 Follow the directions for “Selecting Members for Functions” on page 180.

The POV description is displayed in your document.

Removing Smart Tags for a Single Instance
If you want to use “smartview” as a word in your document, rather than as a smart tag, you can
disable the smart tag icon or that instance. When you later type “smartview” in the document,
the smart tag is still recognized.
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➤ To remove smart tags:

1 Type smartview anywhere in the document, then move the mouse over the word.

The Smart Tags Action icon  is displayed.

2 Click  to display the Smart View menu.

3 Select Remove this Smart Tag.

Stopping Hyperion Smart Tag Recognition
If you no longer want Office to recognize Hyperion smart tags, you can turn them off. You can
turn off smart tags for a data type (for example, all Hyperion smart tags) or individual data items
(specific keyword).

You can stop recognizing the Hyperion smart tag in two ways:

● Accessing the Smart View menu item

● Modifying the smart tag options

➤ To stop recognizing Hyperion smart tags directly through the Smart View menu:

1 Type smartview anywhere in the document, then move the mouse over the word.

The Smart Tags Action icon  is displayed.

2 Click  to display the Smart View menu.

3 Select Stop Recognizing “smartview”, then select one of the following options:

● as Hyperion® to prevent Word or Power Point from recognizing all Hyperion smart tags

● as Smart Tag to stop recognizing the “smartview” keyword

Microsoft Office stops recognizing “smartview” as a smart tag. You must edit the XML
exceptions file to add “smartview” back as a smart tag. See “Recognizing Smart View Smart Tags
Again” on page 189.

➤ To stop recognizing Hyperion smart tags using smart tag options:

1 Type smartview anywhere in the document, then move the mouse over the word.

The Smart Tags Action icon  is displayed.

2 Click  to display the Smart View menu.

3 Select Smart Tag Options.

The AutoCorrect dialog box with the Smart Tags tab is displayed.

4 In Recognizers, clear Hyperion® (Hyperion® Smart View recognizer).
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Note:

The AutoCorrect dialog box has other smart tag options. See the Microsoft Office
documentation for more information.

5 Click OK.

Microsoft Office stops recognizing “smartview” as a smart tag. You must edit the XML
exceptions file to add “smartview” back as a smart tag. See “Recognizing Smart View Smart Tags
Again” on page 189.

Recognizing Smart View Smart Tags Again
When you stop recognizing a smart tag, the keyword is permanently deleted as a smart tag. To
enable Microsoft Office to recognize a smart tag again, you must edit an XML file that contains
all the exceptions. Usually, this XML file is located at a user’s directory:

<Drive letter>:\Documents and Settings\<username>\Application Data
\Microsoft\Smart Tags\Exceptions 

You can find more information about editing the XML exceptions file at:

http://msdn.microsoft.com/library/en-us/stagsdk/html/stconExceptionList.asp

Creating Functions Manually
When you create functions in worksheets manually, you must precede each function with an
equal sign (=). In each function, you can specify a connection and a full or partial Point of View.
If you do not specify a connection, the system uses the default connection. Some functions also
require a value. For example, the HsSetValue function requires that you set a value in addition
to the connection and Point of View.

The connection, if specified, must precede the Point of View. The Point of View is made up of
dimension#member pairs, where the pound symbol (#) is used as a separator between the
dimension and member, for example, Entity#Connecticut. Parent-child relationships can be
represented with a period, for example, Entity#UnitedStates.Maine.

The connection and Point of View can be grouped as one parameter, for example
“My_connection;Entity#UnitedStates”. Alternatively, they can be split up into several function
parameters, for example, “My_connection”, “Entity#UnitedStates”, “Account#Sales”. If the
connection and Point of View are in the same function parameter, the connection and each
dimension#member pair are separated by a semi-colon (;) character, for example,
“My_connection;Entity#UnitedStates;Account#Sales”.

Note:

Functions can contain a maximum of 256 characters.

Example:

Creating Functions Manually 189



=HsGetValue(“HFM01”,”Scenario#Actual;Year#2004;Period#July;View#YTD;
Entity#UnitedStates.Connecticut;Value#USD;Account#Sales;ICP#[ICP 
None];Custom1#GolfBalls;Custom2#Customer2;Custom3#[None];Custom4#
Increases”)

➤ To create functions manually:

1 Select the cell in which you want to create the function.

2 Enter the function, then select the parameters for the function.

3 To refresh the worksheet, select Hyperion > Refresh.

Editing Functions
You can edit a previously-defined function to change the dimension members.

To change the default Point of View, you use the POV Manager. See “Using the POV Manager”
on page 213.

➤ To edit a function:

1 Open a worksheet and select the cell for which you want to edit the function.

2 Select Hyperion > Functions > Function Builder. For Office 2007, click Function Builder in the Task
section of the Hyperion ribbon.

The function is displayed in the Function dialog box.

3 Click Select Member, then from the list of dimension members, select the members that you want to use.

4 To add another function, click Add to Function.

The function is added after the currently displayed function. To replace the current function or
clear all functions, click Clear.

5 To validate the function syntax before pasting it to the worksheet, click Validate.

6 Click OK to paste the function to the worksheet.

7 To refresh the worksheet, select Hyperion > Refresh. For Office 2007, click Refresh in the Review section
of the Hyperion ribbon.

Running Functions
After you have created functions, you can run the functions to retrieve the current values
automatically and update the worksheet.

➤ To run functions:

1 Open the worksheets for which you want to run functions.

2 Select one of the following:

● To run functions and update all worksheets, select Hyperion > Refresh All.
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● To run functions and update only the active worksheet, select Hyperion > Refresh.

Common Function Error Codes
Some common error codes displayed in functions:

#NO CONNECTION - You are not connected or logged on to a data source.

#INVALID - Invalid metadata. These cells are displayed in red in data grids. Invalid cells that
contain a value display the value as zero.

#LOCKED - The cell is locked.

#NO ACCESS - You do not have access to this cell.

#NO DATA - The cell contains NoData. You can select to display zeros instead of NoData. Cells
use the Replacement text that you specify in the Options dialog box.

#INVALID INPUT - The HsSetValue data value is not valid, for example, a text string.

#READ ONLY - This is for the HsSetValue function only when the cell is Read-only.

#NO ROLE ACCESS - You do not have the Financial Management LoadExcelData security role.

#NEEDS REFRESH - Data needs to be refreshed.

#INVALID DIMENSION - An invalid dimension is specified in the function.

#INVALID MEMBER - An invalid dimension member name is specified in the function.

#NAME - Microsoft Excel doesn’t recognize text in a formula. When you forward a spreadsheet
that contains functions to a user who does not have Smart View, users can view the same data
as the functions remain displayed on the spreadsheet. When the user edits the function or selects
Refresh, the function changes to #Name.
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Working with Offline Planning
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About Working Offline
Working disconnected from the Planning server, planners can work much as they do online.
After taking data forms offline, planners can adjust data, view instructions, add supporting detail,
and create data manipulation formulas, then save the changes to the Planning server. Thus,
planners can work with plans and forecasts in any location, such as on planes, hotels, or home,
with or without an Internet connection.

Typical offline working cycle:

● Create an offline connection (see Chapter 4, “Using Connection Manager”).

● Select and download the data forms, dimensions, and members “Taking Data Forms
Offline” on page 194.

● Close Excel.

● At your destination, start Excel, open the offline connection you created, and work with the
data forms, dimensions, and members that you took offline.

● When you are done, save the changed data to the Planning server (see “Synchronizing Data
to the Planning Server” on page 196).

Follow these guidelines when using data forms offline:

● Synchronize data with the server only once during an offline session to save processing time.

Each time you select Sync Back To Server, all data changed within the data forms taken
offline since the beginning of the session is saved to the server.

● Currency conversion is not supported offline.

● If you lose a row or column of data when you refresh a data form, contact the administrator.

● After you reconnect to the server, check that the work you completed offline is correct in
the database.
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Taking Data Forms Offline

Note:

You can include both online and offline data forms in the same Excel workbook.

➤ To take data forms offline:

1 In Excel, establish a connection to the online Planning data source that contains the preferred data form or
forms (see “Adding a Data Source Through Direct Connection” on page 35 for instructions).

2 Select Hyperion > Forms > Take Offline. For Office 2007, click Take Offline in the Forms section of the
Hyperion ribbon.

The Take Offline Wizard is displayed; all data forms that you can take offline are listed.

Note:

If Take Offline is not available, see the Planning administrator.

3 From the Available Forms/Folders list, select or browse for data forms.

● Click the expand (+) and collapse (-) signs next to the folder and data form names to expand
or collapse the list.

● To select a folder or data form, select the check box next to its name.

● If you clear the check box next to a folder name, no data forms in that folder are selected.

4 Click Next.

5 Double-click a dimension.

If you selected multiple data forms, the dimensions displayed are merged from the dimensions
available for the selected data forms. Note that you can select only one dimension.

6 Select members and system variables from the Member Selection page.

The list contains members and system variables of the selected dimension.

● To select all members, select the check box next to the dimension name.

● Click the plus or minus sign to expand or collapse the list.

● To search for a member or system variable in the dimension hierarchy, click . For

Search, type part or all the member or system variable name and click  or .

To Move members or system variables to or from the Selected Members list:

● Click  to add selected members or system variables.

● Click  to remove selected members or system variables.

● Click  to remove all members or system variables.

● Click the arrow to the right of  to list the available member relationships.
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About member relationships:

Table 12 Member Relationships 

Relationship Members Included on the Data Form

Member The selected member

Descendants All members below the selected member

Descendants (inc) The selected member and all its descendants

Ancestors All members above the selected member

Ancestors (inc) The selected member and all its ancestors

Siblings All members from the same level in the hierarchy as the selected member, excluding the
selected member

Siblings (inc) The selected member and all its siblings

Parents The member in the level above the selected member

Parents (inc) The selected member and its parent

Children All members in the level immediately below the selected member

Children (inc) The selected member and all its children

Level 0 Descendants All descendants of the selected member that have no children

Note:

Different data forms may have children and page-member selections. The Page drop-down list
should contain at least one member for each data form from each dimension.

7 Click OK.

8 Repeat steps 5–7 to select members or system variables for each dimension in the list.

9 Click Next.

10 Supply a unique name and a description for the offline connection (for example, you may want to describe
the types of data forms included).

11 Click Finish to download the selected data forms and members.

12 Click OK, then click Done.

You can now view and select the new offline connection in the Connection Manager dialog box.

Working with Data Forms Offline 
For an overview of working offline, see “About Working Offline” on page 193.
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➤ To work with data forms offline:

1 Launch Excel and select Hyperion  > Connection Manager. For Office 2007, click Connect in the
Connections section of the Hyperion ribbon.

2 Select the offline connection.

Online connections specify Planning in the Provider column; offline connections specify Offline
Planning.

3 Click Connect.

4 Select Hyperion > Forms  > Select Form  to select a data form. For Office 2007, click Select Form in the
Forms section of the Hyperion ribbon.

Note:

If you have a data form open while you are directly connected to the Planningserver, then take
the data form offline in the same session, you must reopen the data form from the offline
connection to work with it offline.

5 In the offline data form add or change data.

6 Select Hyperion > Submit Data. For Office 2007, click Submit in the Review section of the Hyperion ribbon.

The changed data is saved locally. You can exit Excel without losing the changed data.

Synchronizing Data to the Planning Server

➤ To save changed data to the Planning server for all data forms and members taken offline:

1 Select Hyperion > Forms  >  Sync Back To Server. For Office 2007, click Sync Back to Server in the
Forms section of the Hyperion ribbon.

The Sync Back To Server option is available only when the current connection is an offline
connection.

2 Logon to the Planning server.

3 Click Sync Back All.

4 Click OK.

➤ To save changed data to the Planning server for selected data forms and members taken offline:

1 Select Hyperion > Forms > Sync Back To Server. For Office 2007, click Sync Back to Server in the
Forms section of the Hyperion ribbon.

The Sync Back To Server option is available only when the current connection is an offline
connection.

2 Logon to the Planning server.

3 Click Next.

4 Double-click a dimension.
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5 Select members and system variables from the Member Selection page.

The list contains members and system variables of the selected dimension.

● To select all members and system variables, select the check box next to the dimension name.

● Click the plus or minus sign to expand or collapse the list.

● To search for a member or system variable in the dimension hierarchy, click . For

Search, type part or all the member or system variable name and click  or .

To Move members and system variables to or from the Selected Members list:

● Click  to add selected members or system variables.

● Click  to remove selected members or system variables.

● Click  to remove all members or system variables.

6 Click OK.

7 Repeat steps 4–6 to select members or system variables for each dimension in the list.

8 Select Finish  to save data.

9 Click OK and Done.

Refreshing the Offline Data Form Definition and Data
When you refresh the offline data form definition, you:

● Update data on the offline data forms with current values from the online data forms.

● Add or delete members or data forms from the ones available during an offline session.

➤ To update offline data and the offline data form definition:

1 If necessary, launch Excel and select Hyperion > Connection Manager. For Office 2007, click Connect in
the Connections section of the Hyperion ribbon.

2 Select the connection associated with the current offline session.

For information, see “About Connection Manager” on page 34.

3 Select Hyperion > Forms > Refresh Offline Definition. For Office 2007, click Refresh Offline in the
Forms section of the Hyperion ribbon.

Note:

If you are using an offline connection and the Refresh Offline Definition option is not available,
contact thePlanning administrator. This option is not available if you are using an online
connection.

4 Enter the user name and password for the online data source.
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Because you want to refresh the offline data from the Planning server, you must log on to the
server.

5 Take an action:

● Click Refresh All to update all members and data forms taken offline with current online
values and definitions. Skip to Step 10.

Note:

Refresh All maintains the current offline data form definition. You change the offline data
form definition if you do not select Refresh All. The members and data forms that you refresh
remain part of the offline data form definition; the members and data forms that you do
not select are no longer part of the definition. For example, if you take five data forms offline,
then select only two of them when you refresh the offline data form definition, the three
data forms you do not select are no longer available offline.

● Click Next to select which data forms, members, and system variables to update.

6 Double-click a dimension.

7 Select members and system variables from the Member Selection page.

The list contains members and system variables of the selected dimension.

● To select all members, select the check box next to the dimension name.

● Click the plus or minus sign to expand or collapse the list.

● To search for a member or system variable in the dimension hierarchy, click . For

Search, type part or all the member or system variable name and click  or .

To Move members and system variables to or from the Selected Members list:

● Click  to add selected members or system variables.

● Click  to remove selected members or system variables.

● Click  to remove all members or system variables.

8 Click OK.

9 Repeat steps 6–8 to select members or system variables for each dimension in the list.

10 Click Finish to start the refresh.

11 Click OK, then click Done when the refresh is complete.

When you connect to the Planning server to synchronize offline data to it, your access privileges
are checked to ensure that your read-write rights have not changed since you went offline. This
check largely involves verifying your access. It also tracks changes to metadata, data form
definition, security, and Planning Unit ownership.
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Entering Data with Menus
The administrator can set up data forms that include menus. Using menus, you right-click a
member and select a menu item to open a URL, data form, workflow, or business rule. For
example, a menu item can open another data form to let you drill down into the data, go to
another scenario and version in the planning unit, or launch a calculation.

➤ To enter data with menus:

1 Open a data form containing a menu.

2 Click a row member, and select a menu option from the list.

The values in the list depend on how your administrator sets up this feature. If the menu includes
submenus, you can select a value from the submenu. The menu can also be set up on a column
member.

Depending on the action that was performed by the menu item, you can continue your work
on the Web page, data form, or workflow.

If a business rule was launched that includes a runtime prompt, enter the required information.
See “Entering Runtime Prompts” on page 40.

Your administrator can customize the runtime prompt that displays for menus. For example, it
can be displayed with a Classic or Streamlined interface, and the Launch button can use another
name, such as OK.
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User Preferences

In This Chapter
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This section explains user preference settings in the Options dialog box.

Ad Hoc Options
The ad hoc options control how data is retrieved into the spreadsheet and which data is retrieved
in ad hoc queries.

The following topics describe the tasks you can perform on the Ad Hoc tab of the Options dialog
box:

● “Suppressing Types of Data” on page 201

● “Indenting Member Names” on page 202

● “Navigating Without Data” on page 202

● “Double-clicking in Ad Hoc Operations” on page 203

● “Undo and Redo” on page 203

● “Zoom Options in Connected Sheets” on page 204

● “Member Retention Options” on page 205

● “Ancestor Positions in Hierarchies” on page 205

Note:

Options dialog box settings are applied globally to all sheets in the workbook.

Suppressing Types of Data
You may want to prevent Smart View from displaying rows in Ad Hoc grids that contain certain
types of data.
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➤ To suppress rows:

1 Select Hyperion > Options > Ad Hoc. For Office 2007, click Options in the Options section of the
Hyperion ribbon.

2 Under Suppress Rows, select any of the following options:

● No Data/#Missing  to suppress rows containing cells for which no data exists in the database
(no data is not the same as zero)

If you later deselect No Data/#Missing , suppressed values are returned only from that point
on. You must drill up then drill down on a member to retrieve values that were suppressed
while this option was selected.

● Zero to suppress rows that contain a zero

● No Access to suppress rows that contain data that you do not have the security access to
view

● Invalid to suppress rows that contain invalid values

● Underscore Characters to suppress underscore characters in member names

● Repeated Members to suppress repeated member names

3 Click OK. The setting takes effect after you refresh or perform a drill operation.

Indenting Member Names
Indenting member names makes it easier to view relationships between members in the
spreadsheet.

➤ To indent member names in the spreadsheet:

1 Select Hyperion > Options > Ad Hoc. For Office 2007, click Options in the Options section of the
Hyperion ribbon.

2 Under Indentation, select one of the following:

● None

● Subitems to indent only descendants. Ancestors are left-justified in the column

● Totals to indent only ancestors. Descendants are left-justified in the column

3 Click OK. The setting takes effect after you refresh or perform a drill operation.

Navigating Without Data
You can speed up navigation operations such as Pivot, Zoom, Keep Only and Remove Only by
preventing the calculation of source data while you are navigating.

➤ To navigate through the sheet without retrieving data:

1 Select Hyperion > Options > Ad Hoc. For Office 2007, click Options in the Options section of the
Hyperion ribbon.
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2 Under Mode, select Navigate without Data.

3 Click OK. The setting takes effect after you refresh or perform a drill operation.

4 When you are ready to retrieve data, clear Navigate without Data.

Double-clicking in Ad Hoc Operations
Normally, double-clicking in an Excel cell puts its contents in edit mode, but you can change it
to Smart View Ad Hoc functionality for Essbase, Financial Management, or Hyperion Enterprise
data sources (double-clicking in Planning retains standard Planning functionality).

Enabled for Ad Hoc operations, double-clicking in a blank spreadsheet connected to an Essbase,
Financial Management, or Hyperion Enterprise data source retrieves the default grid from the
server. Once the grid is loaded, double-clicking on members drills down or up to more or less
detail.

Note:

If Essbase Spreadsheet Add-in and Smart View are installed on the same computer and you have
not completed the steps in “Smart View and Essbase Spreadsheet Add-in” on page 28, double-
clicking invokes the login dialog box for Essbase Spreadsheet Add-in. This behavior is applicable
only for Spreadsheet Add-in in Essbase Release 7.1.2.

➤ To enable double-clicking for ad hoc operations:

1 Select Hyperion > Options > Ad Hoc. For Office 2007, click Options in the Options section of the
Hyperion ribbon.

2 Under Mouse Operation, select Use Double-click for Ad Hoc Operations.

3 Click OK. The setting takes effect after you refresh or perform a drill operation.

Undo and Redo
You must enable Undo and Redo functions before they are available from the Hyperion menu.
Smart View Undo and Redo behave differently depending on the data source to which you are
connected.

● Using Ad Hoc analysis with Essbase, Financial Management, or Hyperion Enterprise data
sources: Undo undoes Zoom In, Zoom Out, Keep Only, Remove Only, or Refresh command
and restores the previous database view to the worksheet. Performing an Undo after
modifying member data returns the sheet to its state before the last refresh, not to its state
before the data modification.

● Using data forms with Financial Management, Hyperion Enterprise, or Planning: Undo
undoes the last user action in a cell. Using Undo and Redo you can go backward and forward
through actions that were performed in the data form until you submit data to the server.
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Note:

You cannot undo operations that are performed on the server rather than in Smart View, such
as calculation status.

Enabling Undo and Redo
When you enable Undo, you are also enabling Redo.

➤ To enable Undo and specify the number of Undo operations allowed:

1 Select Hyperion > Options > Ad Hoc. For Office 2007, click Options in the Options section of the
Hyperion ribbon.

2 Under Undo, select Enable.

3 In Number of Undo Actions, specify the number of permissible Undo operations — 2 through 100.

This is also the number of Redo operations allowed.

4 Click OK. The setting takes effect after you refresh or perform a drill operation.

Using Undo and Redo

➤ To undo one or more operations:

1 From the Excel menu bar, select Hyperion > Undo.

2 Optional: To redo one or more Undo operations, select Hyperion > Redo.

You can undo and redo as many times as specified on the Options dialog box Ad Hoc tab.

Zoom Options in Connected Sheets
The Zoom group controls the behavior of all Zoom In operations except within the selected
group.

➤ To specify zoom options in the connected sheets:

1 Select Hyperion > Options > Ad Hoc. For Office 2007, click Options in the Options section of the
Hyperion ribbon.

2 Under Zoom-In, select one of the following:

● Next Level to retrieve data for the children of the selected members (default)

● All Levels to retrieve data for all descendants of the selected members

● Bottom Level to retrieve data for the lowest level of members in a dimension
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Note:

These options are available only for Essbase, Hyperion Enterprise, and Financial Management .
If an option in this group cannot be selected, then it is not available for your data source.

3 Click OK. The setting takes effect after you refresh or perform a drill operation.

Member Retention Options

➤ To specify member retention in the connected sheets:

1 Select Hyperion > Options > Ad Hoc. For Office 2007, click Options in the Options section of the
Hyperion ribbon.

2 Select one or more of the following:

● Include Selection to retain the selected member along with the other members retrieved as
a result of the zoom

Include Selection is enabled by default.

● Within Selected Group to apply only to the group of members in which the selection is made

This setting is meaningful only when the sheet contains two or more dimensions of data
down a sheet as rows or across a sheet as columns. (This setting also affects the behavior of
Keep Only and Remove Only operations.)

● Remove Unselected Groups to remove all dimension groups that are not in the selected
group

3 Click OK. The setting takes effect after you refresh or perform a drill operation.

Ancestor Positions in Hierarchies
Ancestor position determines the order in which hierarchies display in the spreadsheet.

Note:

Ancestor Position options are not available for Essbase data sources.

➤ To set the ancestor position for hierarchies:

1 Select Hyperion > Options > Ad Hoc. For Office 2007, click Options in the Options section of the
Hyperion ribbon.

2 Under Ancestor Position, select one of the following:

● Top to display hierarchies in order from the highest level of the hierarchy to the lowest

For example, when you expand Sales, you see Gross Margin.

● Bottom to display hierarchies in order from the lowest level of the hierarchy to the highest

For example, when you expand Gross Margin, you see Sales.
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3 Click OK. The setting takes effect after you refresh or perform a drill operation.

Display Options
The options on the Display tab control how data is displayed in the spreadsheet.

The following topics describe the tasks that you can perform on the Display tab of the Options
dialog box:

● “Replacement Labels for Data” on page 206

● “Specifying Data Display Options” on page 207

● “Using Excel Formatting” on page 209

● “Enabling Formula Preservation After POV Changes” on page 209

● “Displaying and Logging Messages” on page 210

Replacement Labels for Data
By default, Smart View uses text in Excel cells to indicate that the data they contain is missing
or invalid, or that you do not have permission to view that data. You can edit this text.

Replacing Invalid Data with Numeric Zeroes or Text
For data cells that contain invalid or missing data, Smart View can display either a text
replacement label such as #INVALID or a numeric zero (0). The numeric zero option is available
in ad hoc, forms, and function-based grids.

Text labels can be descriptive, but text causes Excel functions to fail. The use of zeroes permits
Excel functions; however, when you submit data, Smart View removes all zeroes from
submission even if they are actual zeroes and not labels for invalid data. As a result, you cannot
submit the actual value 0 with this option.

➤ To specify labels for missing or invalid data in Excel cells:

1 Select Hyperion > Options > Display. For Office 2007, click Options in the Options section of the
Hyperion ribbon.

2 Under Replacement, in #NoData/Missing Label:

● To display numeric zeroes, enter #NumericZero. This changes all text replacement labels
to 0 in data cells.

● To display text, enter #MISSING or other text.

3 Click OK. The setting takes effect after you refresh or perform a drill operation.
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Editing Text for Inaccessible Data
By default, Smart View replaces the data in cells that you do not have permission to view with
#No Access.

➤ To edit the # No Access replacement label:

1 Select Hyperion > Options > Display. For Office 2007, click Options in the Options section of the
Hyperion ribbon.

2 Under Replacement, in #No Access Label, edit the text.

3 Click OK. The setting takes effect after you refresh or perform a drill operation.

Specifying Data Display Options
In data grids you can toggle the display of actual data, calculation status, and the process review
level of the data. The calculation status indicates, for example, whether data needs to be
calculated, translated, or consolidated. The review levels indicate the process management level
for combinations of data called process units. The data grid automatically refreshes to reflect
any changes.

You can also select whether to display member names only or member names with descriptions
in grids.

If you are working with a grid that contains duplicate members, you can choose to display the
qualified member names directly in the worksheet.

Finally, you can choose the scaling options and decimal places and automatically view samples
of the selections that you make.

➤ To set the data display options in grids:

1 Select Hyperion > Options > Display. For Office 2007, click Options in the Options section of the
Hyperion ribbon.

2 In the Cell Status group, select one of the following options:

● Data to show data

● Calculation Status to show whether data needs to be calculated, translated, or consolidated
(Hyperion Enterprise and Financial Management data sources only)

● Process Management to show the process management level for combinations of data called
process units (Financial Management data sources only)

3 From Scale, select a scale value, or use the default scale defined for the currency assigned to the entity.

Your selection results are displayed in the “Value 1 will be” text box.

4 From the Decimal Places drop-down list, select the number of decimal places (0 to 8) to be displayed in
the spreadsheet (Hyperion Enterprise, Planning, and Financial Management data sources only).

Your selection results are displayed in the “Value 1 will be” text box.
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5 To use a thousands separator, select the Use Thousands Separator check box (Hyperion Enterprise,
Planning, and Financial Management data sources only).

If you select this option, do not use the pound sign (#) as the thousands separator in Excel's
International Options.

Note:

The Use Excel Formatting option (described in “Using Excel Formatting” on page 209) overrides
the Use Thousands Separator option when both are selected.

6 To compress the Smart View metadata maintained in the worksheet, select Reduce Excel File Size.

7 Click OK. The setting takes effect after you refresh or perform a drill operation.

Member Name Display Options
If your Essbase system permits the use of duplicate member names, you can choose whether to
display member names with or without their descriptions or aliases.

➤ To select how member names are displayed:

1 Select Hyperion > Options > Display. For Office 2007, click Options in the Options section of the
Hyperion ribbon.

2 Under Member Name Display Options, select one of the following options:

● Member Name Only to display fully-qualified names

● Member Name and Description to display fully-qualified names and descriptions (aliases)
in the same cell. (Hyperion Enterprise data source only)

● Description Only to display aliases only. (Not available if connected to Hyperion Enterprise
data source)

Note:

If you select Description Only in free-form mode, fully-qualified names are displayed
initially. After you manually add, remove, or edit any comments and refresh, aliases are
displayed.

3 Click OK. The setting takes effect after you refresh or perform a drill operation.

UI Colors
You can specify one or two background colors for Smart View dialog boxes that contain rows
of information.

➤ To select dialog box colors:

1 Select Hyperion > Options > Display. For Office 2007, click Options in the Options section of the
Hyperion ribbon.
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2 Select UI Colors. Two color buttons are displayed.

3 One at a time, click a color button and select a color.

4 Click OK. The setting takes effect after you refresh or perform a drill operation.

5 Optional: To see your color choices in a dialog box, select Hyperion > Connection Manager.

Using Excel Formatting
You can let Smart View control cell formatting or you can control formatting by using Excel
formatting functionality. Using Excel formatting is generally preferably for highly-formatted
reports, and you must use Excel formatting for data sources whose application-specific colors
are not supported by Excel’s color palate.

When you use Excel formatting, Smart View does not reformat cells based on the grid operations
you perform, and it does not mark cells as dirty when you change data values. Smart View does
preserve the formatting on the worksheet between operations.

Use Excel Formatting is supported for refresh and submit actions but not for zoom or pivot
operations.

The Use Excel Formatting option overrides the following:

● The Use Thousands Separator option on the Display tab of the Options dialog box

● Styles selected in the Cell Styles tab of the Options dialog box

● Styles set using Capture Formatting

Note:

Member and numeric formats may unexpectedly change after pivot operations. For example,
member names may be centered and numeric values may be left justified. You can reset the grid
to the proper format using the formatting options of Excel.

➤ To use Excel formatting:

1 Select Hyperion > Options > Display. For Office 2007, click Options in the Options section of the
Hyperion ribbon.

2 Select Use Excel Formatting.

3 Click OK. The setting takes effect after you refresh the worksheet.

Enabling Formula Preservation After POV Changes
Select Preserve Formula on POV Change to preserve formulas after you change the POV. Upon
refresh, formulas that have been entered into data forms are maintained; only the point of view
of the formula changes.
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Note:

The “Preserve Formula on POV Change” option only applies to data forms in Hyperion
Enterprise, Planning, and Financial Management.

For example, suppose you inserted a formula into a data form grid, with a reference to cell B4
on Sheet 2 of the workbook. The entity dimension is currently set to “Fairfield” within the page
POV:

=Sheet2!B4 

Now suppose you want to apply the same formulas to the “Hartford” entity. Change the entity
dimension within the page POV from Fairfield to Hartford and refresh the data form. This
preserves the existing formula:

=Sheet2!B4 

The data for Hartford is retrieved onto the data form.

Using the “Preserve Formula on POV Change” option has no impact on formulas in the data
form; it simply retains the existing formulas within the data grid.

However, formulas will be lost under these circumstances:

● If they reside on intersections that are invalidated due to suppression options set at the data
source level.

● If a cell changes from input level to Read Only, Invalid, and so on.

For example, a valid cell reference made on one data form may reference a Read Only cell
on another data form.

Note that when a formula is lost, it does not reappear on the data form. You must reenter it.

➤ To enable formula preservation after changes have been made to the POV:

1 Select Hyperion > Options > Display. For Office 2007, click Options in the Options section of the
Hyperion ribbon.

2 Select Preserve Formula on POV Change.

3 Click OK. The setting takes effect after you refresh or perform a drill operation.

Displaying and Logging Messages
All error, warning and informational messages from the connected data source are displayed
when they occur, but you can choose which of these message levels to record in a log file. The
actual messages displayed depend on the provider (Hyperion Enterprise, Planning, Financial
Management, Essbase, etc.) to which you are connected.

➤ To display and log messages:

1 Select Hyperion > Options > Display. For Office 2007, click Options in the Options section of the
Hyperion ribbon.
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Under Log Messages, select one of the following:

● Information to display all messages, including warnings and errors — recommended to
diagnose problems. Adversely impacts performance.

● Warnings to display warning and error level messages. Adversely impacts performance.

● Errors to display error messages only — recommended for general use; has minimal impact
on performance.

● None to suppress all messages.

2 If you want to keep a record of messages in a log file, select Route Messages to Log File.

Note:

Click  to select a new location for the log file. Documents and Settings\”user
name”\Local Settings\TEMP\SmartViewLogs.log is the default location.

3 Optional: To clear the log file each time Smart View is launched, select Clear Log File on Next Launch.

4 Click OK. The setting takes effect after you refresh or perform a drill operation.

Setting Cell Styles
Smart View data source providers each have a set of default cell styles to identify cell types. For
example, Planning designates dirty cells by a yellow background and read-only cells by a gray
background. You can modify default styles in Smart View change cell styles by selecting different
fonts, background colors, or border colors.

➤ To set cell styles for member and data cells:

1 Select Hyperion > Options > Cell Styles. For Office 2007, click Options in the Options section of the
Hyperion ribbon.

2 Expand the list and select a member or data cell.

3 Click Properties and select one of the following:

● Font to choose a font and its color, size, and other properties.

● Background to choose a cell background color.

● Border to choose a cell border color.

4 Click OK. The setting takes effect after you refresh or perform a drill operation.

5 Optional: To revert cell styles to the default styles of the connected Smart View provider, click Default Styles.

Note:

Do not use Smart View worksheets and worksheets created by means other than Smart View in
the same workbook; this causes colors in the non-Smart View sheets to change into unintended
colors when you refresh.
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Note:

The Use Excel Formatting option (described in “Using Excel Formatting” on page 209) overrides
all style options set in the Cell Styles tab of the Options dialog box.

Cell Style Precedence
Because cells can be of more that one type, they can have more than one style. You can determine
the order in which styles are applied in such cells.

Note:

To see a child member style, turn off the parent member style. To see a shared member style,
turn off both parent and child member styles.

➤ To change the order of precedence for member and data cell styles:

1 Select Hyperion > Options >Cell Styles. For Office 2007, click Options in the Options section of the
Hyperion ribbon.

2 Select the member or data cell and then click Move Up or Move Down to give higher or lower precedence,
respectively, to the style for that cell type.

3 Click OK. The setting takes effect after you refresh or perform a drill operation.

Note:

To revert cell precedence of cell styles to their defaults, click Default Styles.
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Using the POV Manager

In This Chapter

Editing the Point of View ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 213

Selecting Dimension Members ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 214

Selecting Dimension Members for the POV ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 214

Copying and Pasting a Point of View... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 216

Deleting a Point of View ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 217

Printing POV Members in Header and Footer.. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 217

When you select a Point of View, the system retrieves and calculates values for the Point of View
dimension settings from the data source unless you specify different settings. You can use the
POV Manager to edit a Point of View, save it to a workbook, copy and paste a saved Point of
View, or delete a Point of View from a workbook.

Editing the Point of View
Each connection has a default Point of View. You can select dimension members for the default
connection Point of View. When you select the connection in the POV Manager, the details of
the connection and the dimension selections or defaults are displayed.

➤ To edit the Point of View:

1 Select Hyperion > POV Manager. For Office 2007, click POV Manager in the Task section of the
Hyperion ribbon.

2 Expand the POVs list.

3 From the Active POV list, select the active connection for which you are changing the Point of View.

4 Click the Member Selector button and select the dimension members that you want to use for the Point of
View.

For more information, see “Selecting Dimension Members for the POV” on page 214.

The worksheet is refreshed with the Point of View changes.

5 Click Close.

6 To refresh the worksheet, select Hyperion > Refresh. For Office 2007, click Refresh in the Review section
of the Hyperion ribbon.
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Selecting Dimension Members
You can select dimension members to use in Point of View Manager, data forms, functions, and
Ad Hoc grids. From the Member Selection dialog box, you can view labels or descriptions for
dimension members and expand and collapse dimension hierarchies.

You can access the Member Selection dialog box in various ways:

● For POV Manager, see “Selecting Dimension Members for the POV” on page 214.

● For data forms, see “Selecting Members for Financial Management and Hyperion Enterprise
Data Forms” on page 46.

● For Functions, see “Selecting Members for Functions” on page 180.

● For Ad Hoc grids, see “Selecting Members for Ad Hoc Analysis” on page 81.

When selecting members for Functions and POV Manager, here are some points to keep in
mind:

● You can select only one member at a time to add to the Selection box.

● You cannot reorder the selections.

When selecting members for Ad Hoc grids and data forms, here are some points to keep in mind:

● You can select multiple members and you can reorder the selections.

● You can remove multiple members from the Selection box.

Selecting Dimension Members for the POV
In the POV Manager, you can select dimension members to use as a default POV for an Ad Hoc
grid, or for the background POV for dimensions when using functions. From the POV Manager,
you can select only one member per dimension.

Note:

Any changes to the background POV are not reflected in the cell until a refresh is completed.

To change the starting POV for an Ad Hoc grid, you must first open the POV Manager, select
members for the POV, and then start the Ad Hoc grid. For example, in a Financial Management
data source, the top member, which is None, is used by default. You might want to change
Account to start with Gross Margin, and change Entity to start with North America.

Note:

After the Ad Hoc grid has been started, you can no longer make changes through the POV
Manager, but instead make changes using the member selector in the Ad Hoc grid.
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You use the Member Selection dialog box to select members. You can filter the list of members
and you can view labels or descriptions for dimension members. For example, when you select
to view descriptions, the P_Series member is displayed as “P_Series - Phones and PDAs”.

You can also search for dimension members. For more information, see step 10 on page 215.

➤ To select dimension members:

1 From the POV Manager, click Member Selector.

2 From the Dimension drop-down list, select a dimension.

3 Optional: To filter the list of members, select a member list from the Filter drop-down list. See “Filtering
Members” on page 83.

4 Optional: For advanced filtering, highlight a member without selecting its check box, then select a member
list.

This uses the highlighted member as the filter parameter. For example, if you highlight United
States and change the filter list to Children, the system displays the children of United States.

5 Optional: To display dimension descriptions instead of labels, select Use Descriptions.

6 Optional: To display Dynamic Time Series members for a time dimension, select Dynamic Time Series
Members.

Note:

The Dynamic Time Series option is available only when working with Essbase data sources.

7 Optional: To display active entities only, select Active Members.

Note:

The Active Members option is available only if the application has been set up for Organization
by Period. For information on Org by Period, see the Hyperion Financial Management
Administrator's Guide.

8 Select the check box next to each member that you want to use.

Tip:

To deselect members, click Select None.

9 Click Add to move the selected members to the Selection list.

Tip:

To remove members from the Selection list, select the members, then click Remove, . To

remove all members from the Selection list, click Remove All, .

10 Optional: To search for members in the selected dimension, complete the following steps:
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a. Click  and enter the member name or pattern for which you want to search in the text
box.

You can enter the start of a text pattern for the search, or you can use a trailing asterisk as
a wildcard symbol. For example, to find EastSales, you can enter “east” or “ea*.”

b. Click  to find the first member within the dimension that matches the search criteria.

Select the check box next to the member if you want to use it and then click .

c. Click  again to search for the next occurrence and, if you want to use the member, select

the check box next to the member and click .

Tip:

If you are at the bottom of the member list, click  to find the next member that matches
the search criteria.

11 When you finish selecting members, click OK.

Copying and Pasting a Point of View
You can copy a Point of View that has been saved in a workbook and paste it to another
workbook. For example, suppose another user has created a worksheet with functions and saved
the connection Point of View to the workbook. They can send you the workbook and to ensure
that you’re looking at the same data, you can use the saved Point of View.

Saved POVs are referenced with the data source name of the computer on which they were saved.
When you use a saved POV, you must have the same data source as the one for the saved POV.

For example, suppose someone saves a Point of View to a workbook using the Comma data
source and referencing the Comma application, then sends it to you with instructions to use the
saved POV. You must have a data source named Comma that references the Comma application/
cube at the same URL and server to use the saved POV. If the data sources do not match, or if
one references a different application or uses a different Web or application server, you cannot
paste the POV into the active worksheet.

When using the POV manager to select POV values for ad hoc analysis, you must copy the POV
defined in the POV Manager to a worksheet that is not associated with a connection, otherwise
the POV has no effect. When you copy the POV to an unconnected sheet and then refresh, the
POV values are used.

➤ To copy and paste a Point of View:

1 Select Hyperion > POV Manager. For Office 2007, click POV Manager in the Task section of the
Hyperion ribbon.

2 From the Active folder, select the Active application connection.
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3 Select the members for the POV and save the workbook.

4 Click Copy.

5 Expand the Saved folder to select the workbook and worksheet into which you want to paste the POV, and
click Paste.

Tip:

You can also drag and drop a Point of View to copy and paste it. For example, from the Saved
POV list, you can select a POV from a workbook, and then drag it to the Active POV list. Or,
conversely, you can select a POV from the Active POV list, and then drag it to the Saved POV
list.

6 Save the workbook.

7 Optional: To copy a saved POV from another workbook, open the workbook and select the saved POV.

The Saved folder displays your source workbook and the new workbook.

8 Copy and paste the source POV to the target worksheet in the Saved folder.

9 To close the POV Manager, click Close.

10 To refresh the worksheet, select Hyperion > Refresh. For Office 2007, click Refresh in the Review section
of the Hyperion ribbon.

Deleting a Point of View
You can delete a Point of View that has been saved in a workbook.

➤ To delete a Point of View:

1 Select Hyperion > POV Manager. For Office 2007, click POV Manager in the Task section of the
Hyperion ribbon.

2 Expand the POV list.

3 From the POV drop-down list, select the worksheet that contains the Point of View that you want to delete.

4 Select the Point of View that you want to delete.

5 Click Delete.

6 Click Close.

7 To refresh the worksheet, select Hyperion > Refresh. For Office 2007, click Refresh in the Review section
of the Hyperion ribbon.

Printing POV Members in Header and Footer
You can print active POV members of the POV toolbar in the header or footer of an Excel
document.
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➤ To print POV members in the header or footer:

1 In Excel, select File > Page Setup.

2 Under Header/Footer, click Custom Header or Custom Footer.

3 In the Left section, Center section, or Right section box, type a statement that includes POV:{}, such
as My current POV members are POV:{}.

4 Click OK.

5 In Page Setup, click OK.

When you print the Excel document, the POV members are printed in the header or footer, or
both.
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The migration utility converts existing Financial Management and Hyperion Enterprise
spreadsheet add-in functions to the new syntax when you upgrade. You can convert a single
workbook or convert multiple workbooks using the batch option.

Considerations Before Converting Workbooks
You can convert workbooks that contain Financial Management Retrieve Data functions or
Hyperion Enterprise HP Retrieve and VBA Retrieve functions from previous releases by using
a migration utility. For example, you can convert Financial Management functions such as
HFMVal, HFMLnk, HFMLab, HFMDes, and HFMCur and Hyperion Enterprise functions such
as HPVal, HPLnk, HPCur, HPHea, HPCde, and HPFul.

The utility might not be able to convert all of your existing functions. Some functions might
require manual adjustment. The following are considerations for converting workbooks.

For functions that use cell references, the following functions can be converted:

● If every parameter in the function is a cell reference, the function will convert. For example:
=HFMVal($B$1&$C$1&$B$2&$C$3&$B$5&$C$5&$B$6&$C$6).

● If the dimension parameters are specified in the function, the members are cell references,
but the period separator is hard coded in the function, the function will convert. For example:
=HFMVal(“S#”&D2&”.Y#”&D3&”.VW#”&D5&”.’)

The following functions that use cell references are not converted:

● If the dimension parameters are specified in the function and the members and period
separator are cell references, the function is not converted. For example: =HFMVal
(“S#”&E2&”Y#”&E3&”VW#”&E5), where E2=Actual, E3=2004, E5=“<Scenario View>.”

● If the dimension parameters are specified in the function, the members are cell references,
but the period separator is in a separate cell, the function is not converted. For example:
=HFMVal(“S#”&F2&C1&”Y#”&F3&C1&”VW#&F5&C1), where C1=. (period separator).
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● If the application specified in the function is a cell reference, the function does not convert
properly.

Before you run the migration utility, ensure that the path is correct (the default path is C:
\Hyperion\SmartView). During the migration process, Microsoft Excel inserts the original
path of the add-in file to functions, which can make the functions too long and can cause
problems in the migration process. Smart View functions cannot contain more than 256
characters per a limit within Excel.

Converting One Workbook
You can convert a workbook with existing Financial Management spreadsheet add-in functions
to the new Hyperion Smart View syntax. For example, if you have a spreadsheet that contains
the HFMVal(POV) function, it is converted to the HsGetValue(POV) function.

➤ To convert one workbook:

1 Select Hyperion > Functions > Migrate Active Workbook.

2 If your functions contain application references, you must map the application to the corresponding
connection.

3 Click Convert.

4 On the conversion completed message, click OK.

The system displays the migration result. For example, it displays a list of any functions that
failed to convert. You can manually adjust those functions.

5 To save the conversion results, click Save Result.

6 Select a location to store the results file, then click Save.

7 Click Close.

Converting Multiple Workbooks
You can convert multiple workbooks in a batch operation.

Note:

Financial Management users skip step 3 and Hyperion Enterprise users skip steps 6 and 7 in the
following procedure.

➤ To convert multiple workbooks:

1 Select Hyperion > Functions > Migrate Batch.

2 Click Add and select the workbooks that you want to convert.

3 To select workbooks for conversion, perform an action:
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● Select Select All/None to select all workbooks.

● Select the check box next to each workbook to select specific workbooks.

4 Click Next. If your functions contain application references, you must map the application to the connection.

5 Click Next.

Migration results are displayed, including a lost of functions that failed to convert. You can
manually adjust those functions.

6 Click Save Result.

7 Select a location to store the results file and click Save.

8 Click Done.

For Hyperion Enterprise users, the converted workbooks are automatically saved in the location
of the original workbooks.
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Using VBA Functions for Smart View
Smart View enables you to customize and automate common tasks by using Visual Basic for
Applications (VBA) functions.

The menu equivalents are Visual Basic functions that execute the Hyperion menu commands.

Note:

To use VBA functions, the sheet must be active.

Note:

The VBA functions for Smart View are separately licensed.

Migrating Legacy VBA Applications
To work in Smart View, VBA applications created using VBA functions from Essbase
Spreadsheet Add-in Toolkit must be migrated to Smart View, although you can continue to use
them in Spreadsheet Add-in. In most cases, you can replace the prefix “EssV” with “Hyp” for
analogous function names in your VBA applications. See “VBA Functions” on page 230 for a
list of supported VBA functions. For example, for EssVRemoveOnly, change the name to
HypRemoveOnly. For VBA menu functions, replace “EssMenuV” with “HypMenuV.” For
example, for EssMenuVZoomIn, change the name to HypMenuVZoomIn. Additionally, you
must replace the declarations from essxlvba.txt with the declarations in smartview.bas.

Creating a Visual Basic Module
To use the VBA functions, you must first create Visual Basic modules to contain the VBA code.
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➤ To create a Visual Basic module:

1 In Excel, select Tools > Macro > Visual Basic Editor to open the Visual Basic application.

2 In the Visual Basic application, select Insert > Module.

A new module is displayed with a labeled Module1 (or labeled with the next highest module
number, if you have already inserted one or more modules).

Using Smart View VBA Functions
This procedure is an example of how to use VBA functions in Smart View.

➤ To use VBA functions (HypConnect in this example):

1 Select View > Toolbars > Forms to display the Forms toolbar.

2 Select Tools > Macro > Visual Basic Editor to display the Visual Basic Editor.

3 In the Visual Basic Editor, select File > Import File.

4 In Import File, select smartview.bas  in \SmartView\bin to declare all functions or just the function
you plan to use.

Tip:

For convenience, copy the entire text of smartview.bas into a separate module from the other
VBA code.

5 Select Insert > Module to create a module.

6 In the module, type the VBA code for the function.

For example, type the following VBA code for the HypConnect function:

Sub Conn()
   X=HypConnect(vtSheetName, User, Password, vtFriendlyName
End Sub

Substitute your own user name, password, and connection name for the data source provider.

7 From the Excel Forms toolbar, select the button to create a button. The Assign Macro dialog box is displayed.

8 In Assign Macro, select the name of the subroutine from the list of functions.

In this example, select Conn.

9 Click OK.

The function is now associated with the button that you just created.

10 Optional: Rename the button.

11 To run this function, select Tools > Macro > Macros, select the function name, then click Run.

Alternatively, you can click the button that you just created.
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Declaring Functions
Before you can use Visual Basic functions in an Excel project, you must declare them in a module.
A declaration outlines the necessary elements of the function so Visual Basic can run it. You
must declare only those functions you plan to use, or you may declare all the VBA functions.

➤ To declare all Smart View VBA functions:

1 In Visual Basic Editor, select File > Import File.

2 From Import File , select smartview.bas in \SmartView\bin.

The file is copied into the module. Now you can use any Smart View Excel VBA function in your
program. If there are functions you do not need in your module, you can delete their declarations.

➤ To declare individual Smart View VBA functions:

1 In Visual Basic Editor, select Insert > File.

2 Move the cursor to the top of the module.

3 Type the appropriate declarations for the functions you will use.

Refer to the description of each function for its declaration, or refer to smartview.bas. For
example:

Declare Function HypConnect Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtUserName As Variant, ByVal vtPassword As Variant, ByVal 
vtFriendlyName As Variant) As Long

Guidelines for Declaring Functions
When typing the declaration, observe the following guidelines:

● Do not substitute specific values for each parameter name.

In the HypConnect example, the first parameter is vtSheetName. In the declaration, you type
it as vtSheetName. When you actually call the HypConnect function in your VBA module,
you substitute the appropriate name of the sheet.

● Type the declaration on one line.

Calling Functions
Once the functions are declared at the top of the module, you can call them in your VBA code.
When you call a function, you tell it to perform its intended action and return a value. You can
then test the returned value to see if the function ran successfully.

The following example shows the syntax for HypConnect.

HypConnect(vtSheetName, vtUser, vtPassword, vtFriendlyName)

When you call a function, observe the following guidelines:

● Substitute the appropriate value for each parameter, shown in italics.
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● Type a value for every parameter. All parameters are required.

Many parameters have default values. If you do not want to specify a value for such
parameters, type Null or Empty. This tells Essbase to use the default value for that parameter.

● Assign the function to a variable. After the function runs, the variable stores the return value,
which indicates the success or failure of the function.

x=HypConnect(Empty, username, password, “My Sample Basic”)

Dynamic Link Views
A link view is used to display the details about a data point in an adjacent window without
disturbing the contents in the main window. Link views can be either static or dynamic.

In a static link view, the link action is predefined and details about a data point being queried
are displayed in the adjacent window. Static link view behavior is already built in to Smart View.

With a dynamic link view, VBA programmers have the option to change the link behavior as
required. Using the set options, you can change the row, column, POV, column information,
and the connection information.

For instructions on working with dynamic link views, see:

● “Setting Up Dynamic Link Views” on page 227

● “Automating Macro Execution” on page 227

The VBA functions related to dynamic link view:

● HypUseLinkMacro

● HypSetLinkMacro

● HypGetLinkMacro

● HypGetSourceGrid

Note:

For all of the following dynamic link view VBA functions, it is assumed that a call has already
been made to HypGetSourceGrid to initialize the dynamic link query, which contains the
information about the active data source and the grid on the sheet.

● HypGetConnectionInfo

● HypSetConnectionInfo

● HypGetRowCount

● HypGetColCount

● HypGetPOVCount

● HypGetRowItems

● HypGetColItems
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● HypGetPOVItems

● HypSetRowItems

● HypSetColItems

● HypSetPOVItems

● HypDisplayToLinkView

When the dynamic link query has been initialized, all the subsequent setinfo, getinfo,
displaytolinkview calls are performed on that saved dynamic link query. If the user changes the
grid on the sheet and wants to perform the dynamic link action as per the new grid, the user
must again initialize the query, using the various setinfo calls available.

Prerequisite to HypGetSourceGrid is that a connected grid must exist on the active sheet and a
valid data point should be selected.

Setting Up Dynamic Link Views
Use dynamic link views to customize the link behavior according to your requirements. With
dynamic link view, you can change the row, column, POV, and column information as well as
the connection information.

➤ To set up a dynamic link view:

1 Set the HypUseLinkMacro flag to true.

2 Set the macro name to run.

The macro name you set should contain all the function calls to initialize the grid and to set the
connection, row, POV, and column items as needed.

3 Connect the sheet and retrieve the appropriate grid onto the sheet.

4 Select a data point on the sheet.

5 Select Hyperion > Link View > Visualize in Excel. For Office 2007, click Visualize in Excel in the
Visualize section of the Hyperion ribbon.

The macro name set in step 2 is executed and the link action is performed.

Note:

When the HypUseLinkMacro flag is set to false, the predefined link query is performed.

Automating Macro Execution
You can automate execution of a macro through the Hyperion menu.

➤ To set up a macro to execute manually through the Hyperion menu:

1 Set the HypUseLinkMacro flag to false.

2 Connect the sheet and retrieve the grid you want onto the sheet.
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3 Select a data point on the sheet.

4 Run the macro which contains all the function calls to initialize the grid and set the connection, row, column,
and POV items.

VBA Parameters
Most Visual Basic functions require you to supply one or more parameters. Table 13 lists the
parameter types and how to supply a valid value for each type:

Table 13 VBA Parameters

Parameters Valid Values

Text A word or phrase or name in quotes. For example,

"Smart View"

"[Book2.xls]Sheet1"

Boolean True

False

Range Object A cell, row or column, one or more selections of cells, or a three-dimensional range address,
surrounded by quotes. For example:

RANGE("A1")

RANGE("A1:B2")

RANGE("A1:B2")

RANGE("G:G,I:I,K:K")

RANGE("A1:B5,C1:C10,D5:L8")

RANGE("Sheet1!C3:R20,Sheet2!C3:R20")

Number A number without quotes and without commas. For example:

1

2.5

50000

List of Strings A list of Text values, separated by commas. For example:

"Qtr1", "Actual", "Oregon"

Constant A predefined constant from smartview.bas.

Default Value Null

Empty

Note: Many parameters have default values or behavior that the function uses if you specify Null or
Empty. If you do not specify a value for such parameters, use Null or Empty. See the description of
each function for default values of such parameters.
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VBA Return Values
The Smart View VBA functions return values indicating the success or failure of the function.
The functions return several types of values:

● 0 (zero) — the function was successful. Functions can run successfully but still have
undesirable results.

● 1 — typically means the user pressed Escape or clicked Cancel from a dialog box.

● -1 — indicates a valid return value, True.

● Negative number — the function failed due to a problem with the client machine, a problem
with the syntax, or a problem with the local environment.

● large positive number, the function failed due to a problem originating on the server, such
as the server not running or an invalid user name.

Table 14 lists the return values for local problems, represented by negative numbers.

Table 14 VBA Return Values  

Return Value Meaning

0 Function ran successfully

-1 Valid return value, True

-2 Termination error

-3 Initialization error

-4 Spreadsheet is not yet connected to the server

-6 Not used

-7 Spreadsheet has become unstable

-8 No Undo information exists

-9 Operation has been canceled

-12 Undo is not enabled

-13 Not enough memory resources are available

-14 Appropriate dialog box could not be displayed

-15 Function contains an invalid parameter

-16 Calculation is in progress

-17 Obsolete setting

-18 Operation is not allowed because the spreadsheet is in formula preservation mode

-19 Operation cannot take place on the specified sheet

-20 Current sheet cannot be determined
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Return Value Meaning

-21 Spreadsheet name was not specified and no active sheet is selected

-22 Calculation cannot be canceled because no calculation is running

-23 Selection parameter is invalid

-25 Cascade list file cannot be created, or you are attempting to cascade while the spreadsheet is
embedded in another document

-26 Spreadsheet macros cannot be run due to a licensing agreement

-27 Spreadsheet macros which update the database cannot be run due to a licensing constraint

-28 Database cannot be updated because you have a read-only license for the database

-29 Obsolete setting

-30 Menu is removed already

-31 Menu is added already

-39 The specified worksheet is protected. Unprotect the worksheet and try the operation again.

-40 Calc script not found

VBA Functions
Table 15 lists the Smart View VBA functions alphabetically and specifies the data source provider
that support the function. A detailed description for each function, including the syntax,
parameter, return value, and sample code, follows the table.

Note:

For this release, VBA functions for Oracle's Hyperion® Planning – System 9 are not supported.
To use ad hoc with data forms, you must be connected to an Essbase orHyperion Enterprise
data source.  

Table 15 VBA Functions and Supported Providers

VBA Functions Essbase Financial Management Hyperion Enterprise

HypCalculate  X X

HypCalculateContribution  X X

HypCell X   

HypConnect X X X

HypConnected X X X

230 VBA Functions



VBA Functions Essbase Financial Management Hyperion Enterprise

HypConnectionExists X X X

HypConsolidate  X X

HypConsolidateAll  X X

HypConsolidateAllWithData  X X

HypCreateConnection X X X

HypDeleteCalc X   

HypDisconnect X X X

HypDisplayToLinkView X X X

HypExecuteCalcScript X   

HypExecuteQuery X   

HypFindMember X   

HypForceCalculate  X X

HypForceCalculateContribution  X X

HypForceTranslate  X X

HypFreeDataPoint X X X

HypFindMember X X X

HypGetAncestor X   

HypGetChildren X   

HypGetColCount X X X

HypGetColItems X X X

HypGetConnectionInfo X X X

HypGetDataPoint X X X

HypGetGlobalOption X X X

HypGetLinkMacro X X X

HypGetParent X   

HypGetPOVCount X X X

HypGetPOVItems X X  

HypGetRowCount X X  
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VBA Functions Essbase Financial Management Hyperion Enterprise

HypGetRowItems X X  

HypGetSheetOption X X  

HypGetSourceGrid X X  

HypGetSubstitutionVariable X   

HypIsAttribute X   

HypIsDescendant X   

HypIsExpense X   

HypIsParent X   

HypIsUDA X   

HypKeepOnly X X X

HypListCalcScripts X   

HypLoginSetPassword X X X

HypOtlGetMemberInfo X   

HypPivot X X X

HypPivotToGrid X X  

HypPivotToPOV X X  

HypQueryMembers X   

HypRedo X X X

HypRemoveConnection X X X

HypRemoveOnly X X X

HypRetrieve X X X

HypRetrieveRange    

HypSetActiveConnection X X X

HypSetBackgroundPOV X X X

HypSetCellsDirty X X X

HypSetColItems X X X

HypSetConnectionInfo X X X

HypSetGlobalOption X X X
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VBA Functions Essbase Financial Management Hyperion Enterprise

HypSetLinkMacro X X X

HypSetMenu X X X

HypSetPOV X X X

HypSetPOVItems X X X

HypSetRowItems X X X

HypSetSheetOption X X X

HypSetSubstitutionVariable X   

HypSubmitData X X X

HypTranslate  X X

HypUndo X X X

HypUseLinkMacro X X X

HypZoomIn X X X

HypZoomOut X X X

HypCalculate

Description

HypCalculate() calls the Calculate method for Financial Management data sources.

Syntax

HypCalculate (vtSheetName, vtRange)

ByVal vtSheetName As Variant

By Val vtRange As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtRange Range object which refers to the data to be used. Passing an empty or null parameter uses the current
selection from the sheet.
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Return Value

Returns 0 if successful; otherwise, returns the corresponding error code.

Example
Declare Function HypCalculate Lib "HsAddin" (ByVal vtSheetName As Variant, 
ByVal vtRange As Variant) As Long

sts = HypCalculate (“Sheet1”, Empty)

HypCalculateContribution

Description

HypCalculateContribution() calls the Calculate Contribution method for Financial
Management data sources.

Syntax

HypCalculateContribution (vtSheetName, vtRange)

ByVal vtSheetName As Variant

By Val vtRange As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtRange Range object which refers to the data to be used. Passing an empty or null parameter uses the current
selection from the sheet.

Return Value

Returns 0 if successful; otherwise, returns the corresponding error code.

Example
Declare Function HypCalculateContribution Lib "HsAddin" (ByVal vtSheetName 
As Variant, ByVal vtRange As Variant) As Long

sts = HypCalculateContribution  (“Sheet1”, Empty)
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HypCell

Description

HypCell() retrieves a cell value for a single member combination.

Syntax

HypCell(vtSheetName, ParamArray MemberList())

ByVal vtSheetName As Variant

ByVal ParamArray MemberList() As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

MemberList A list of strings which describe the member combination for which a data value will be retrieved. If
MemberList is Null or Empty, the top level value is used.

Represent members as “Dimension#Member”; for example, “Year#Jan” or
“Market#East”.

Return Value

Returns the value of the data point if successful. Returns #No Connection if the sheet cannot be
determined or is not connected to a data source. Returns “Invalid Member MemberName or
dimension DimensionName” if a member is incorrect.

Example
Declare Function HypCell Lib "HsAddin" (ByVal vtSheetName As Variant, 
ParamArray MemberList() As Variant) As Variant

Sub InCell()
Dim X As String
X=HypCell("[Book2.xls]Sheet1", "Year#Qtr1", "Scenario#Actual", 
"Market#Oregon")
    If X = "#No Connection" Then
       MsgBox("Not logged in, or sheet not active.")
    Else
       If Left(X, 15) = "#Invalid member" then
          MsgBox("Member name incorrect.")
       Else
          MsgBox(X + " Value retrieved successfully.")
       End If
    End If
End Sub
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Note:

The value of the data point returned is not placed in a cell in the spreadsheet automatically. To
place the value in a cell, use the Visual Basic select method and the ActiveCell property. See your
Visual Basic documentation for more information.

HypConnect

Description

HypConnect() logs into a data source provider and associates the worksheet with that
connection. HypConnect() must be called for each sheet in order to associate this connection
with that sheet.

Syntax

HypConnect(vtSheetName, vtUserName, vtPassword, vtFriendlyName)

ByVal vtSheetName As Variant

ByVal vtUserName As Variant

ByVal vtPassword As Variant

ByVal vtFriendlyName As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtUserName Text name of a valid user for the data source provider.

vtPassword Text name of the password for this user.

vtFriendlyName The friendly connection name for the data source provider. This is the connection name created by
HypCreateConnection.

Return Value

Returns 0 if successful. A negative number indicates a local failure. A return value greater than
zero indicates a failure on the server.

Example
Declare Function HypConnect Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtUserName As Variant, ByVal vtPassword As Variant, ByVal 
vtFriendlyName As Variant) As Long
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Sub Conn()
   X=HypConnect(Empty, username, password, “My Sample Basic”)
End Sub

HypConnected

Description

HypConnected() provides the connection status of the sheet. A true value indicates that the sheet
is connected to a provider; a false value indicates that the sheet is not connected.

Syntax

HypConnected (vtSheetName)

ByVal vtSheetName As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

Return Value

If the sheet is connected, return value of the variant is -1. If the sheet is not connected, return
value of the variant is 0.

Example
Declare Function HypConnected Lib "HsAddin" (ByVal vtSheetName As Variant) 
As Variant

Sub Sample_HypConnected
   Dim X as Variant
   X = HypConnected(“Sheet1”)
End sub

HypConnectionExists

Description

HypConnectionExists() is used to check if a particular connection name exists in the list of all
connections, as viewed in Connection Manager. The particular connection may or may not be
active (i.e., connected).
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Syntax

HypConnectionExists(vtConnectionName)

ByVal vtConnectionName as Variant

Parameters

Parameter Syntax

vtConnectionName Name of the connection to search for in the list of all connections. It is not case-sensitive.

Return Value

Boolean. If successful, return value is TRUE; otherwise, return value is FALSE.

Example
Declare Function HypConnectionExists Lib "HsAddin.dll" (ByVal 
vtConnectionName As Variant) As Variant

Sub Sample_SetActiveConnection
   Dim bIsConnection as Boolean
   bIsConnection = HypConnectionExists (“Demo_Basic”)
End sub

HypConsolidate

Description

HypConsolidate calls the Consolidate method for Financial Management data sources.

Syntax

HypConsolidate (vtSheetName, vtRange)

ByVal vtSheetName As Variant

By Val vtRange As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtRange Range object which refers to the data to be used. Passing an empty or null parameter uses the current
selection from the sheet.
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Return Value

Returns 0 if successful; otherwise, returns the corresponding error code.

Example
Declare Function HypConsolidate Lib "HsAddin" (ByVal vtSheetName As 
Variant, ByVal vtRange As Variant) As Long

sts = HypConsolidate (“Sheet1”, Empty)

HypConsolidateAll

Description

HypConsolidateAll() calls the Consolidate All method for Financial Management data sources.

Syntax

HypConsolidateAll (vtSheetName, vtRange)

ByVal vtSheetName As Variant

By Val vtRange As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtRange Range object which refers to the data to be used. Passing an empty or null parameter uses the current
selection from the sheet.

Return Value

Returns 0 if successful; otherwise, returns the corresponding error code.

Example
Declare Function HypConsolidateAll Lib "HsAddin" (ByVal vtSheetName As 
Variant, ByVal vtRange As Variant) As Long

sts = HypConsolidateAll  (“Sheet1”, Empty)
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HypConsolidateAllWithData

Description

HypConsolidateAllWithData calls the Consolidate All With Data method for Financial
Management data sources.

Syntax

HypConsolidateAllWithData (vtSheetName, vtRange)

ByVal vtSheetName As Variant

By Val vtRange As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtRange Range object which refers to the data to be used. Passing an empty or null parameter uses the current
selection from the sheet.

Return Value

Returns 0 if successful; otherwise, returns the corresponding error code.

Example
Declare Function HypConsolidateAllWithData Lib "HsAddin" (ByVal vtSheetName 
As Variant, ByVal vtRange As Variant) As Long

sts = HypConsolidateAllWithData  (“Sheet1”, Empty)

HypCreateConnection

Description

HypCreateConnection() creates a connection to the data source provider from the specified
information.

Note:

Use HypConnect to establish the connection.
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Syntax

HypCreateConnection(vtSheetName, vtUserName, vtPassword, vtProvider, vtProviderURL,
vtServerName, vtApplicationName, vtDatabaseName, vtFriendlyName, vtDescription)

ByVal vtSheetName As Variant

ByVal vtUserName As Variant

ByVal vtPassword As Variant

ByVal vtProvider As Variant

ByVal vtProviderURL As Variant

ByVal vtServerName As Variant

ByVal vtApplicationName As Variant

ByVal vtDatabaseName As Variant

ByVal vtFriendlyName As Variant

ByVal vtDescription As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtUserName Text name of a valid user on the server.

vtPassword Text name of the password for this user.

vtProvider Description for the data source provider.

Supported vtProvider types are:

● Global Const HYP_ANALYTIC_SERVICES = "Oracle's Hyperion® Provider Services"

● Global Const HYP_FINANCIAL_MANAGEMENT = "Hyperion Financial Management"

vtProviderURL Data source provider URL which to connect.

vtServerName Name of the server on which the application resides.

vtApplication Name of the application.

vtDatabase Name of the database.

vtFriendlyName Connection name for the data source provider.

vtDescription Description for the data source provider.
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Return Value

Returns 0 if successful. A negative number indicates a local failure. A return value greater than
zero indicates a failure on the server.

Example
Declare Function HypCreateConnection Lib "HsAddin" (ByVal vtSheetName As 
Variant, ByVal vtUserName As Variant, ByVal vtPassword As Variant, ByVal 
vtProvider As Variant, ByVal vtProviderURL As Variant, ByVal vtServerName 
As Variant, ByVal vtApplicationName As Variant, ByVal vtDatabase As 
Variant, ByVal vtFriendlyName As Variant, ByVal vtDescription As Variant) 
As Long

Sub Conn()
    X=HypCreateConnection(Empty, username, password, HYP_ANALYTIC_SERVICES,
    "http://localhost:13080/smartview/SmartView", “localhost”, “Sample”, 
    “Basic”, “My Connection”, “Analytic  Provider Services”)
End Sub

HypDeleteCalc

Description

HypDeleteCalc() allows the user to delete a calculation script object from an Analytic Server.

Syntax

HypDeleteCalc (vtSheetName, vtApplicationName, vtDatabaseName, vtCalcScript)

ByVal vtSheetName As Variant

ByVal vtApplicationName As Variant

ByVal vtDatabaseName As Variant

ByVal vtCalcScript As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet on which to operate. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtApplicationName Specify the application name containing the calculation script.

vtDatabaseName Specify the database name containing the calculation script.

vtCalcScript Specify the calculation script name to be deleted.
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Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypDeleteCalc Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtApplicationName As Variant, ByVal vtDatabaseName As 
Variant, ByVal vtCalcScript As Variant) As Long

Sub Sample_HypDeleteCalc
Dim X as Long
   X = HypDeleteCalc (“Sheet1”,”Sample”,”Basic”,”CalcYear”)
End Sub

HypDisconnect

Description

HypDisconnect() logs out from the data source provider.

Syntax

HypDisconnect(vtSheetName, bLogoutUser)

ByVal vtSheetName As Variant

ByVal bLogoutUser As Boolean

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

bLogoutUser Optional. Set to True to disconnect and log out from the provider session. Default value is False.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code..

Example
Declare Function HypDisconnect Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal bLogoutUser As Boolean) As Long

Sub DisConn()
   X=HypDisconnect(Empty, True)
End Sub
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HypDisplayToLinkView

Description

HypDisplayToLinkView() displays Office documents to Word or PowerPoint; or displays a grid
to Excel.

Note:

The link action is performed as per the latest content of the dynamic link query.

Note:

This function is used specifically with dynamic link views, as described in “Dynamic Link Views”
on page 226

Syntax

HypDisplayToLinkView (vtDocumentType, vtDocumentPath)

ByVal vtDocumentType as Variant

ByVal vtDocumentPath as Variant

Parameters

Parameters Description

vtDocumentType Indicates the destination for the link view. Valid values:

● EXCEL_APP

● WORD_APP

● PPOINT_APP

vtDocumentPath The path to the document.

Note: Required only in case of WORD_APP or PPOINT_APP.

Return Value

Returns 0 if successful; otherwise, returns the negative error code.

Example
Declare Function HypDisplayToLinkView Lib "HsAddin.dll" (ByVal 
vtDocumentType As Variant, ByVal vtDocumentPath As Variant) As Long

Sub Macro()
  Dim vtGrid as Variant
  Sts = HypConnect("Sheet1", "system", "password", "MyDemoBasic")
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  Sts = HypRetrieve("Sheet1")
  Range (“B2”).Select
  Sts = HypGetSourceGrid (“Sheet1”, vtGrid)
  Sts = HypSetColItems (1, "Market", "East", "West", "South", "Central",
         "Market")
  Sts = HypDisplayToLinkView ("EXCEL_APP", "")
End sub

HypExecuteCalcScript

Description

HypExecuteCalcScript() uses a calculation script (business rule script) to initiate a calculation
on the server.

Syntax

HypExecuteCalcScript (vtSheetName, vtCalcScript, bSynchronous)

ByVal vtSheetName As Variant

ByVal vtCalcScript As Variant

ByVal bSynchronous As Boolean

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtCalcScript Text name of the calculation script on the Analytic Server in the database directory to run. To run the
default calculation script, use "Default".

bSynchronous Boolean value indicating whether the calculation script should be run synchronously. If synchronous
is Null or Empty, True is used. Currently this flag is unused.

Return Value

Returns 0 if successful. A negative number indicates a local failure. A return value greater than
zero indicates a failure in one of the servers.

Example

Declare Function HypExecuteCalcScript Lib "HsAddin.dll" (ByVal vtSheetName 
As Variant, ByVal vtCalcScript As Variant, ByVal bSynchronous As Variant) 
As Long 

Sub RunCalculate() 
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X = HypExecuteCalcScript (Empty, "Default", False)
   If X = 0 Then
      MsgBox("Calculation complete.") 
   Else
      MsgBox("Calculation failed.") 
   End If 
End Sub

HypExecuteQuery

Description

HypExecuteQuery() executes an MDX query and displays the results on a worksheet. (If you do
not want to display the query results on a worksheet, use HypExecuteMDXEx instead.)

Syntax

HypExecuteQuery (ByVal vtSheetName As Variant, ByVal vtMDXQuery As Variant) As Long

ByVal vtSheetName As Variant

ByVal vtMDXQuery

Parameters

Parameter Description

vtSheetName Text name of worksheet on which to operate. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtMDXQuery The MDX query statement to be executed on the worksheet.

Return Value

Long. If successful, return value is 0; otherwise, returns the appropriate error code.

Example
Declare Function HypExecuteQuery Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtMDXQuery As Variant) As Long

Sub Sample_HypExecuteQuery ()
   Dim vtQuery As Varian
   vtQuery = "SELECT {([Jan])} on COLUMNS, {([East])} on ROWS from 
                 Sample.Basic"
   sts = HypConnect ("Sheet1", "system", "password", "Sample_Basic")
   sts = HypExecuteQuery ("Sheet1", vtQuery)
   sts = HypDisconnect ("Sheet1", True)
End sub
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HypFindMember

Description

HypFindMember() retrieves member information like dimension, alias, generation and level
names.

Syntax

HypFindMember (vtSheetName, vtMemberName, vtAliasTable, vtDimensionName,
vtAliasName, vtGenerationName, vtLevelName)

ByVal vtSheetName As Variant

ByVal vtMemberName As Variant

ByVal vtAliasTable As Variant

ByRef vtDimensionName As Variant

ByRef vtAliasName As Variant

ByRef vtGenerationName As Variant

ByRef vtLevelName As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet on which to operate. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtMemberName The name of the member. This parameter is required because there is no default value.

vtAliasTable The name of the alias table to search for the alias name. If Null, the default alias table is searched.

vtDimensionName The output parameter that contains the dimension, if successful.

vtAliasName The output parameter that contains the alias name of the member, if successful.

vtGenerationName The output parameter that contains the generation name of the member, if successful.

vtLevelName The output parameter that contains the level name of the member, if successful.

Return Value

Returns zero if successful.

Example
Declare Function HypFindMember Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtMemberName As Variant, ByVal vtAliasTable As Variant, 
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ByRef vtDimensionName as Variant, ByRef vtAliasName As Variant, ByRef 
vtGenerationName As Variant, ByRef vtLevelName As Variant) As Long

Sub FindMember() 
   X = HypFindMember(Empty, "100", "Default", dimName, aliasName, 
    genName, levelName) 
   MsgBox (dimName) 
   MsgBox (aliasName) 
   MsgBox (genName) 
   MsgBox (levelName)  
End Sub

HypForceCalculate

Description

HypForceCalculate() calls the Force Calculate method for Financial Management data sources.

Syntax

HypForceCalculate(vtSheetName, vtRange)

ByVal vtSheetName As Variant

By Val vtRange As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtRange Range object which refers to the data to be used. Passing an empty or null parameter uses the current
selection from the sheet.

Return Value

Returns 0 if successful; otherwise, returns the corresponding error code.

Example
Declare Function HypForceCalculate Lib "HsAddin" (ByVal vtSheetName As 
Variant, ByVal vtRange As Variant) As Long

sts = HypForceCalculate (“Sheet1”, Empty)
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HypForceCalculateContribution

Description

HypForceCalculateContribution calls the Force Calculate Contribution method for Financial
Management data sources.

Syntax

HypForceCalculateContribution (vtSheetName, vtRange)

ByVal vtSheetName As Variant

By Val vtRange As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtRange Range object which refers to the data to be used. Passing an empty or null parameter uses the current
selection from the sheet.

Return Value

Returns 0 if successful; otherwise, returns the corresponding error code.

Example
Declare Function HypForceCalculateContribution Lib "HsAddin" (ByVal 
vtSheetName As Variant, ByVal vtRange As Variant) As Long

sts = HypForceCalculateContribution  (Empty, Empty)

HypForceTranslate

Description

HypForceTranslate calls the Force Translate method for Financial Management data sources.

Syntax

HypForceTranslate (vtSheetName, vtRange)

ByVal vtSheetName As Variant

By Val vtRange As Variant
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Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtRange Range object which refers to the data to be used. Passing an empty or null parameter uses the current
selection from the sheet.

Return Value

Returns 0 if successful; otherwise, returns the corresponding error code.

Example
Declare Function HypForceTranslate Lib "HsAddin" (ByVal vtSheetName As 
Variant, ByVal vtRange As Variant) As Long

sts = HypForceTranslate (Empty,  Empty)

HypFreeDataPoint

Description

HypFreeDataPoint() frees any memory allocated by HypGetDataPoint.

Syntax

HypFreeDataPoint()

ByRef vtInfo As Variant

Parameters

Parameter Description

vtInfo Variant array returned by HypGetDataPoint.

Return Value

Returns 0 if successful; returns -15 if not successful.

Example

See “HypGetDataPoint” on page 256 for an example of HypFreeDataPoint.
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HypGetAncestor

Description

HypGetAncestor() returns the ancestor at any specific generation/level for the specified member.

Syntax

HypGetAncestor (vtSheetName, vtMemberName, vtLayerType, intLayerNum, vtAncestor)

ByVal vtSheetName As Variant

ByVal vtMemberName As Variant

ByVal vtLayerType As Variant

ByVal intLayerNum As Integer

ByRef vtAncestor As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet on which to operate. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtMemberName Specify a member name. Required field.

vtLayerType Specify either “Gen” or “Level”. If vtLayerType is Null or Empty, Gen is taken as default.

intLayerNum Specify the Level/Generation number. Required Field.

vtAncestor Output. Contains the ancestor name on successful execution of the macro.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypGetAncestor Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtMemberName As Variant, ByVal vtLayerType As Variant, ByVal 
intLayerNumber As Integer, ByRef vtAncestor As Variant) As Long

Sub Sample_HypGetAncestor
   Dim X as Long
   Dim vtAncestor as Variant
   X = HypGetAncestor ("Sheet1", "100-20", "Level", 1, vtAncestor)
End Sub
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HypGetChildren

Description

HypGetChildren() returns the children for the specified member.

Syntax

HypGetChildren (vtSheetName, vtMemberName, intChildCount, vtChildArray)

ByVal vtSheetName As Variant

ByVal vtMemberName As Variant

ByVal intChildCount As Integer

ByRef vtChildArray As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet on which to operate. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtMemberName Specify a member name. Required Field.

intChildCount To restrict the number of children returned.

● ChildCount <=0. All children are returned.

● ChildCount >0. The result set is limited to the number specified as the argument. If the result
set is less than the specified argument, all result are returned.

vtChildArray Output Result Vector that contains the list of the children. Its contents are unknown if the macro
fails.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypGetChildren Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtMemberName As Variant, ByVal intChildCount As Integer, 
ByRef vtChildNameArray As Variant) As Long

Sub Sample_HypGetChildren
   Dim vtChildren as Variant
   Dim vtChild as Variant
   Dim X as Long
      X = HypGetChildren ("sheet1", "Market", 0, vtChildren)
      If IsArray (vtChildren) Then
         For i = LBound (vtChildren) To UBound (vtChildren)
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         VtChild = vtChildren (i)
      Next
   End If
End Sub

HypGetColCount

Description

HypGetColCount() returns the number of column dimensions.

Note:

This function is used specifically with dynamic link views, as described in “Dynamic Link Views”
on page 226

Syntax

HypGetColCount()

Return Value

Returns the number of column dimensions if successful; otherwise, returns the negative error
code.

Example
Declare Function HypGetColCount Lib "HsAddin.dll" () As Long

Sub Macro()
   Dim vtGrid as Variant
   Sts = HypConnect("Sheet1", "system", "password", "MyDemoBasic")
   Sts = HypRetrieve("Sheet1")
   Range (“B2”).Select
   Sts = HypGetColCount ()
End sub

HypGetColItems

Description

HypGetColItems() returns the members present in the dynamic link query for the nth column
dimensions.

Note:

This function is used specifically with dynamic link views, as described in “Dynamic Link Views”
on page 226
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Syntax

HypGetColItems(vtColumnID, vtDimensionName, vtMembers)

ByVal vtColumnID As Variant

ByRef vtDimensionName As Variant

ByRef vtMembers As Variant

Parameters

Parameters Description

vtColumnID The column number n.

vtDimensionName Returns the nth column dimension name.

vtMembers Returns members for the nth column dimensions.

Return Value

Returns 0 if successful; otherwise, returns the negative error code.

Example
Declare Function HypGetColItems Lib "HsAddin.dll" (ByVal vtColID As 
Variant, ByRef vtDimensionName As Variant, ByRef vtMembernames As Variant) 
As Long

Sub Macro()
   Dim vtGrid as Variant
   Dim vtDimensionName as Variant
   Dim vtMembers as Variant
   Sts = HypConnect("Sheet1", "system", "password", "AnamikaDemoBasic")
   Sts = HypRetrieve("Sheet1")
   Range (“B2”).Select
   Sts = HypGetSourceGrid (“Sheet1”, vtGrid)
   Sts = HypGetColItems(1, vtDimensionName, vtMembers)
End sub

HypGetConnectionInfo

Description

HypGetConnectionInfo() returns the connection information for the dynamic link query.

HypGetConnectionInfo assumes that a call has already been made to HypGetSourceGrid to
initialize the dynamic link query, which contains the information about the active data source
and the grid on the sheet.
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Note:

This function is used specifically with dynamic link views, as described in “Dynamic Link Views”
on page 226

Syntax

HypGetConnectionInfo(vtServerName, vtUserName, vtPassword, vtApplicationName,
vtDatabaseName, vtFriendlyName, vtURL, vtProviderType)

ByRef vtServerName As Variant

ByRef vtUserName As Variant

ByRef vtApplicationName As Variant

ByRef vtDatabaseName As Variant

ByRef vtFriendlyName As Variant

ByRef vtURL As Variant

ByRef vtProviderType As Variant

Parameters

Parameters Description

vtServerName Output. Contains the server name for the dynamic link query.

vtUserName Output. Contains the user name for the dynamic link query.

vtApplicationName Output. Contains the application name for the dynamic link query.

vtDatabaseName Output. Contains the database name for the dynamic link query.

vtFriendlyName Output. Contains the friendly connection name for the dynamic link query.

vtURL Output. Contains the URL for the dynamic link query.

vtProviderType Output. Contains provider type for the dynamic link query.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypGetConnectionInfo Lib "HsAddin.dll" (ByRef vtServerName 
As Variant, ByRef vtUserName As Variant, ByRef vtApplicationName As 
Variant, ByRef vtDatabaseName As Variant, ByRef vtFriendlyName As Variant, 
ByRef vtURL As Variant, ByRef vtProviderType As Variant) As Long

Sub Macro()
   Dim vtGrid as Variant
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   Dim server As Variant
   Dim user As Variant
   Dim app As Variant
   Dim pass As Variant
   Dim db As Variant
   Dim provider As Variant
   Dim conn As Variant
   Dim url As Variant
   Sts = HypConnect("Sheet1", "system", "MyDemoBasic")
   Sts = HypRetrieve("Sheet1")
   Range (“B2”).Select
   Sts = HypGetSourceGrid (“Sheet1”, vtGrid)
   Sts = HypGetConnectionInfo(server, user, app, db, conn, url, provider)
End sub

HypGetDataPoint

Description

HypGetDataPoint() retrieves member information for a single data cell. For example, to find
out the members that consist of the data intersection at cell B6, HypGetDataPoint may return
the members January, California, Actual, Root Beer, Profit.

Syntax

HypGetDataPoint (vtSheetName, vtCell)

By Val vtSheetName As Variant

By Val vtCell As Variant

Parameters

Parameter Description

vtSheetName Text name of the worksheet containing the currency information. vtSheetName is of the form
"[Book.xls]Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtCell Cell name that describes the reference cell for which to retrieve the member combination information.

Return Value

Returns an array of member names.

Example
Declare Function HypGetDataPoint Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal cell As Variant) As Variant

Sub DataPointsSub()
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Dim vt As Variant 
Dim cbItems As Variant 
Dim i As Integer 
Dim pMember As String
vt = HypDataPoint(Empty, “B3”) 
If IsArray(vt) Then
    cbItems = UBound(vt) - LBound(vt) + 1 
    MsgBox ("Number of elements = " + Str(cbItems)) 

    For i = LBound(vt) To UBound(vt)
        MsgBox ("Member = " + vt(i))
    Next    
    X = HypFreeDataPoint(vt) 
    Else 
MsgBox ("Return Value = " + Str(vt))
End If 
End Sub

HypGetGlobalOption

Description

HypGetGlobalOption() returns information about individual Smart View workspace options.

Note:

For option descriptions, see Chapter 14, “User Preferences.”

Syntax

HypGetGlobalOption(vtItem)

ByVal vtItem As Long

Parameters

Parameter Description

vtItem Number indicating which option is to be retrieved. See Table 16 for values.

Table 16 indicates which options are returned for the vtItem parameter.

Table 16

item Option Return Data Type

1 Enable Excel formatting Boolean

2 Enable double-click for Ad Hoc operations Boolean

3 Enable Undo Boolean

Using VBA Functions for Smart View 257



item Option Return Data Type

4 Not used Boolean

5 Specify message level setting:

0 Information messages

1 Warning messages

2 Error messages

3 No messages

Number

6 Use thousands separator Boolean

7 Enable route messages to log file Boolean

8 Clear log file on next launch Boolean

9 Enable Navigate Without Data Boolean

Return Value

Returns a number or Boolean value indicating the state of the requested option. Returns an error
code if parameter item is out of range.

Example

The following example sets the option for specifying a message level and checks whether the
value set is valid.

Declare Function HypGetGlobalOption Lib "HsAddin.dll" (ByVal vtItem As 
Long) As Variant

Sub GetGlobal()
   sts = HypGetGlobalOption(5)
   If sts = -15 then
      Msgbox ("Invalid Parameter")
   Else
      Msgbox ("Message level is set to" & sts)
End Sub

HypGetLinkMacro

Description

HypGetLinkMacro() returns the macro name currently set to be run to perform the dynamic
link query.
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Note:

This function is used specifically with dynamic link views, as described in “Dynamic Link Views”
on page 226

Syntax

HypGetLinkMacro (vtMacroName)

ByRef vtMacroName As Variant

Parameters

Parameter Description

vtMacroName Output. Returns the currently set macro name.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypGetLinkMacro Lib "HsAddin.dll" (ByRef vtMacroName As 
Variant) As Long

Sub Auto_Open()
   Dim Macroname as Variant
   Sts = HypUseLinkMacro(True)
   Sts = HypSetLinkMacro(“Sheet1.Macro8”)
   Sts = HypGetLinkMacro(Macroname)
   If (StrComp(MacroName, "Sheet1.Macro8")) Then
      MsgBox ("Error Occurred")
   End If
End Sub

HypGetParent

Description

HypGetParent() returns the parent name for the specified member.

Syntax

HypGetParent(vtSheetName, vtMemberName, vtParentName)

ByVal vtSheetName As Variant

ByVal vtMemberName As Variant
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ByRef vtParentName As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet on which to operate. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtMemberName Specify a member name. Required Field.

vtParentName Output. Contains the parent name on successful execution of the macro.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypGetParent Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtMemberName As Variant, ByRef vtParentName As Variant) As 
Long

Sub Sample_HypGetParent
   Dim vtParent as Variant
   X = HypGetParent ("Sheet1", "East", vtParent)
End sub

HypGetPOVCount

Description

HypGetPOVCount() returns the number dimensions in the POV from the dynamic link query.

Note:

This function is used specifically with dynamic link views, as described in “Dynamic Link Views”
on page 226

Syntax

HypGetPOVCount()

Return Value

Returns the number of column dimensions if successful; otherwise, returns the negative error
code.
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Example
Declare Function HypGetPOVCount Lib "HsAddin.dll" () As Long

Sub Macro()
   Dim vtGrid as Variant
   Sts = HypConnect("Sheet1", "system", "password", "MyDemoBasic")
   Sts = HypRetrieve("Sheet1")
   Range (“B2”).Select
   Sts = HypGetSourceGrid (“Sheet1”, vtGrid)
   Sts = HypGetPOVCount ()
End sub

HypGetPOVItems

Description

HypGetPOVItems() returns the dimensions in the POV and the currently selected member for
each dimension.

Note:

This function is used specifically with dynamic link views, as described in “Dynamic Link Views”
on page 226

Syntax

HypGetPOVItems(vtDimensionNames, vtPOVNames)

ByRef vtDimensionNames As Variant

ByRef vtPOVNames As Variant

Parameters

Parameter Description

vtDimensionNames The dimension names in the POV.

vtPOVNames The currently selected member for each dimension in the POV.

Return Value

Returns 0 if successful; otherwise, returns the negative error code.

Example
Declare Function HypGetPOVItems Lib "HsAddin.dll" (ByRef vtDimensionNames 
As Variant, ByRef vtPOVNames As Variant) As Long
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Sub Macro()
   Dim vtGrid as Variant
   Dim vtDimNames As Variant
   Dim vtPOVNames As Variant
   Sts = HypConnect("Sheet1", "system", "password", "MyDemoBasic")
   Sts = HypRetrieve("Sheet1")
   Range (“B2”).Select
   Sts = HypGetSourceGrid (“Sheet1”, vtGrid)
   Sts = HypGetPOVItems (vtDimNames, vtPOVNames)
End sub

HypGetRowCount

Description

HypGetRowCount() returns the number of row dimensions.

Note:

This function is used specifically with dynamic link views, as described in “Dynamic Link Views”
on page 226

Syntax

HypGetRowCount()

Return Value

Returns number of row dimensions if successful; otherwise, returns the negative error code.

Example
Declare Function HypGetRowCount Lib "HsAddin.dll" () As Long

Sub Macro()
   Dim vtGrid as Variant
   Sts = HypConnect("Sheet1", "system", "password", "MyDemoBasic")
   Sts = HypRetrieve("Sheet1")
   Range (“B2”).Select
   Sts = HypGetSourceGrid (“Sheet1”, vtGrid)
   Sts = HypGetRowCount ()
End sub

HypGetRowItems

Description

HypGetRowItems() returns the members present for the nth row dimension in the dynamic
link query.
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Note:

This function is used specifically with dynamic link views, as described in “Dynamic Link Views”
on page 226

Syntax

HypGetRowItems(vtRowID, vtDimensionName, vtMemberNames)

ByVal vtRowID As Variant

ByRef vtDimensionName As Variant

ByRef vtMemberNames As Variant

Parameters

Parameter Description

vtRowID The row number n.

vtDimensionName Returns the nth row dimension name.

vtMemberNames Returns the members for the nth row dimensions.

Return Value

Returns 0 if successful; otherwise, returns the negative error code.

Example

Declare Function HypGetRowItems Lib "HsAddin.dll" (ByVal rowID As Variant, 
ByRef vtDimensionName As Variant, ByRef vtMemberNames As Variant) As Long

Sub Macro()
   Dim vtGrid as Variant
   Dim vtDimName as Variant
   Dim vtMembers as Variant
   Sts = HypConnect("Sheet1", "system", "password", "AnamikaDemoBasic")
   Sts = HypRetrieve("Sheet1")
   Range (“B2”).Select
   Sts = HypGetSourceGrid (“Sheet1”, vtGrid)
   Sts = HypGetRowItems(1, vtDimName, vtMembers)
End sub

HypGetSheetOption

Description

HypGetSheetOption() returns information about individual spreadsheet options.

Using VBA Functions for Smart View 263



Syntax

HypGetSheetOption(vtSheetName, vtItem)

ByVal vtSheetName As Variant ByVal vtItem As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtItem Number indicating which option is to be retrieved. See Table 17 for a list of values.

Table 17 indicates which options are returned for the vtItem parameter.

Table 17

vtItem Option Data Type and Values

1 Set zoom in level:

0 Next level

1 All levels

2 Bottom level

Number

2 Enable Include Selection setting Boolean

3 Enable Within Selection Group setting Boolean

4 Enable Remove Unselected Groups setting Boolean

5 Specify Indent setting:

0 No indentation

1 Indent sub items

2 Indent totals

Number

6 Enable suppress missing setting Boolean

7 Enable suppress zeros setting Boolean

8 Enable suppress underscores setting Boolean

9 Enable No Access setting Boolean

10 Enable Repeated Members setting Boolean

11 Enable invalid setting Boolean

12 Ancestor Position:

0 Top

1 Bottom

Number
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vtItem Option Data Type and Values

13 Specify Missing text label Text

14 Specify No Access label Text

15 Cell status:

0 Data

1 Calculation status

2 Process Management

Number

16 Member Name Display options:

0 Name only

1 Name and Description

2 Description only

Number

Return Value

Returns the value of the current setting as a string, number, or Boolean. Returns an error code
if parameter item is out of range.

Example
Declare Function HypGetSheetOption Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtItem As Variant) As Variant

Sub GetSheet()
sts = HypGetSheetOption(“Sheet”, 5)
If sts = -15 then
   Msgbox ("Invalid Parameter")
Else
   Msgbox ("Indentation is set to" & sts)
End Sub

HypGetSourceGrid

Description

HypGetSourceGrid() creates a query from the source grid for the dynamic link query.

This function applies to both static and dynamic link views.

Note:

A cell in the grid must be selected before this making this call.
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Note:

This function is used specifically with dynamic link views, as described in “Dynamic Link Views”
on page 226

Syntax

HypGetSourceGrid(vtSheetName, vtGrid)

ByVal vtSheetName As Variant

ByRef vtGrid As Variant

Parameters

Parameters Description

vtSheetName Text name of worksheet on which to operate. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtGrid The grid XML is returned on successful execution.

Return Value

Returns 0 if successful or the appropriate error code otherwise.

Example
Declare Function HypGetSourceGrid Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByRef vtGrid As Variant) As Long

Sub Macro()
   Dim vtGrid as Variant
   Range ("B2").Select
   Sts = HypGetSourceGrid (“Sheet1”, vtGrid)
End sub

HypGetSubstitutionVariable

Description

HypGetSubstitutionVariable() retrieves substitution variables and their current value from
Analytic Server.

Syntax

HypGetSubstitutionVariable (vtSheetName, vtApplicationName, vtDatabaseName,
vtVariableNameList, vtVariableValueList)

ByVal vtSheetName As Variant
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ByVal vtApplicationName As Variant

ByVal vtDatabaseName As Variant

ByVal vtVariableName As Variant

ByRef vtVariableNameList As Variant

ByRef vtVariableValueList As Variant

Parameters

Parameter Description

vtSheetName Text name of the worksheet on which to operate. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtApplicationName The application name to return variables scoped for the specified application. If
vtApplicationName is Null or Empty all the applications are considered.

vtDatabaseName The database name to return variables scoped for the specified database. If vtDatabaseName
is Null or Empty all the databases are considered.

vtVariableName The variable name to be retrieved. If vtVariableName is Null or Empty the entire list of variables
is returned.

vtVariableNameList Output Result Vector that contains the list of the variable names. Its contents are unknown if
the macro fails.

vtVariableValueList Output Result Vector that contains the list of the variable values corresponding to each variable
returned. Its contents are unknown if the macro fails.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypGetSubstitutionVariable Lib "HsAddin.dll" (ByVal 
vtSheetName As Variant, ByVal vtApplicationName As Variant, ByVal 
vtDatabaseName As Variant, ByVal vtVariableName As Variant, ByRef 
vtVariableNames As Variant, ByRef vtVariableValues As Variant) As Long

Sub Sample_HypGetSubstitutionVariable
   Dim vtVarNameList as Variant
   Dim vtVarValueList as Variant
   Dim vtVarVal as Variant
   Dim vtVar as Variant
   X = HypGetSubstitutionVariable ("Sheet1", "Sample", "Basic",
    Empty, vtVarNameList, vtVarValueList)
      If IsArray (vtVarNameList) Then
         For i = LBound (vtVarNameList) To UBound (vtVarNameList)
         vtVar = vtVarNameList (i)
         Next
      End If

Using VBA Functions for Smart View 267



      If IsArray (vtVarValueList) Then
         For i = LBound (vtVarValueList) To UBound (vtVarValueList)
         vtVarVal = vtVarValueList (i)
         Next
   End If

HypIsAttribute

Description

HypIsAttribute() checks to see if the specified member has a specific attribute.

Syntax

HypIsAttribute(vtSheetName, vtDimensionName, vtMemberName, vtAttributeName)

ByVal vtSheetName As Variant

ByVal vtDimensionName As Variant

ByVal vtMemberName As Variant

ByVal vtAttributeName As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtDimensionName The name of the dimension where the member belongs.

vtMemberName The name of the member for which we must test the condition.

vtAttributeName Input string that is compared against the attributes of the member.

Return Value

Returns a variant in which -1 is true, 0 is false; otherwise, returns the appropriate error code.

Example
Declare Function HypIsAttribute Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtDimensionName As Variant, ByVal vtMemberName As Variant, 
ByVal vtAttribute As Variant) As Variant

Sub CheckAttribute()
vtret = HypIsAttribute("Sheet1", "Market", "Connecticut", “MyAttribute”)
    If vtret = -1 Then
      MsgBox ("Found MyAttribute")
    ElseIf vtret = 0 Then
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      MsgBox ("MyAttribute not available for Connecticut")
    Else
      MsgBox ("Error value returned is" & vtret)
    End If 
End Sub

HypIsDescendant

Description

HypIsDescendant() checks if the specified member is the descendant of another specified
member.

Syntax

HypIsDescendant(vtSheetName, vtMemberName, vtAncestorName)

ByVal vtSheetName As Variant

ByVal vtMemberName As Variant

ByVal vtAncestorName As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet on which to operate. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtMemberName A member name. Required.

vtAncestorName The member name of the ancestor. Required.

Return Value

Returns a variant in which -1 is true, 0 is false; otherwise, returns the appropriate error code.

Example
Declare Function HypIsDescendant Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtMemberName As Variant, ByVal vtDescendantName As Variant) 
As Boolean

Sub Sample_HypIsDescendant
   Dim b as Boolean
   b = HypIsDescendant ("Sheet1", "Year", "Jan")
End sub
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HypIsExpense

Description

HypIsExpense() verifies that the member specified has an Expense tag.

Syntax

HypIsExpense(vtSheetName, vtDimensionName, vtMemberName)

ByVal vtSheetName As Variant

ByVal vtDimensionName As Variant

ByVal vtMemberName As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtDimensionName The name of the dimension where the member belongs. If vtDimensionName is Null or Empty,
the active dimension is used.

vtMemberName The name of the specified member.

Return Value

Returns a variant in which -1 is true, 0 is false; otherwise, returns the appropriate error code.

Example
Declare Function HypIsExpense Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtDimensionName As Variant, ByVal vtMemberName As Variant) 
As Variant

Sub CheckExpense()
vtret = HypIsExpense("Sheet1", "Measures", "Opening Inventory")
    If vtret = -1 Then
     MsgBox ("Opening Inventory has expense flag set")
    ElseIf vtret = 0 Then
     MsgBox ("Expense flag has not been set")
    Else
     MsgBox ("Error value returned is" & vtret)
    End If 
End Sub
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HypIsParent
HypIsParent() checks if the specified member is the parent of another specified member.

Syntax

HypIsParent(vtSheetName, vtMemberName, vtParentName)

ByVal vtSheetName As Variant

ByVal vtMemberName As Variant

ByVal vtParentName As Variant

Parameters

Parameter Description

vtSheetName The text name of worksheet on which to operate. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtMemberName A member name. Required.

vtParentName The member name of the parent. Required.

Return Value

Returns a variant in which -1 is true, 0 is false; otherwise, returns the appropriate error code.

Example
Declare Function HypIsParent Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtMemberName As Variant, ByVal ParentName As Variant) As 
Boolean

Sub Sample_HypIsParent
   Dim b as Boolean
   b = HypIsParent ("sheet1", "East", "Market")
End Sub

HypIsUDA

Description

HypIsUDA() checks to verify if the member specified has a specific UDA.

Syntax

HypIsUDA (vtSheetName, vtDimensionName, vtMemberName, vtUDAString)
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ByVal vtSheetName As Variant

ByVal vtDimensionName As Variant

ByVal vtMemberName As Variant

ByVal vtUDAString As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtDimensionName The name of the dimension where the member belongs.

vtMemberName The name of the member for which we must test the condition.

vtUDAString Input string that is compared against the attributes of the member.

Return Value

Returns a variant in which -1 is true, 0 is false; otherwise, returns the appropriate error code.

Example
Declare Function HypIsUDA Lib "HsAddin.dll" (ByVal vtSheetName As Variant, 
ByVal vtDimensionName As Variant, ByVal vtMemberName As Variant, ByVal 
vtUDAString As Variant) As Variant

Sub CheckUDA() 
vtret = HypIsUDA("Sheet1", "Market", "Connecticut", “MyUDA”)
    If vtret = -1 Then
      MsgBox ("Found MyUDA")
    ElseIf vtret = 0 Then
      MsgBox ("Did not find MyUDA")
    Else
      MsgBox ("Error value returned is" & vtret)
    End If 
End Sub

HypKeepOnly

Description

HypKeepOnly() retains only the selected member(s) in the sheet and removes unselected
members.

The selection must be limited to member cells only, not data cells.
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Syntax

HypKeepOnly(vtSheetName, vtSelection)

ByVal vtSheetName As Variant

ByVal vtSelection As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]Sheet".
If vtSheetName is Null or Empty, the active sheet is used.

vtSelection Range object which refers to the member(s) that will be kept. If selection is Null or Empty, the active
cell is used.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypKeepOnly Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtSelection As Variant) As Long

Sub KOnly()
' Keep Only on one member name
   X=HypKeepOnly("[Book2.xls]Sheet1", RANGE("D2"))
   If X = 0 Then
      MsgBox("Keep Only successful.")
   Else
      MsgBox("Keep Only failed." + X)
   End If
' Keep Only on two member names
   X=HypKeepOnly("[Book2.xls]Sheet1", RANGE("D2:A5"))
   If X = 0 Then
      MsgBox("Keep Only successful.")
   Else
      MsgBox("Keep Only failed." + X)
   End If
End Sub

HypListCalcScripts

Description

HypListCalcScripts() lists all calculation scripts present on Analytic Server.
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Syntax

HypListCalcScripts (vtSheetName, vtScriptArray)

ByVal vtSheetName As Variant

ByRef vtScriptArray As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]Sheet".
If vtSheetName is Null or Empty, the active sheet is used.

vtScriptArray The business rule scripts are returned in this array.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypListCalcScripts Lib "HsAddin.dll" (ByVal sheetName As 
Variant,ByRef scriptArray) As Long

Dim sts As Long
Dim paramList As Variant
sts=HypListCalcScripts ("sheet1",paramList)
If IsArray(paramList) Then
   cbItems = UBound(paramList) - LBound(paramList) + 1
      MsgBox ("Number of elements = " + Str(cbItems))
   For i = LBound(paramList) To UBound(paramList)
      MsgBox ("Member = " + paramList(i))
   Next
   Else
      MsgBox ("Return Value = " + sts))
End If

HypLoginSetPassword

Description

HypLoginSetPassword() sets the password upon login, then logs the user out.

Syntax

HypLoginSetPassword (vtSheetName, vtNewPassword, vtOldPassword, vtServerName,
vtUserName)

ByVal vtSheetName As Variant
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ByVal vtNewPassword As Variant

ByVal vtOldPassword As Variant

ByVal vtServerName As Variant

ByVal vtUserName As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtNewPassword Text name of the new password you want to set for the user name.

vtOldPassword Text name of the old password that you want to replace for the user name.

vtServerName Text name of the server you want to change the password for.

vtUserName Text name of the valid user name on the server.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypLoginSetPassword Lib "HsAddin.dll" (ByVal vtSheetName 
as Variant, ByVal vtNewPassword As Variant, ByVal vtOldPassword As Variant, 
ByVal vtServerName As Variant, ByVal vtUserName As Variant) As Long

Sub SetPassword()
Dim X As Long
'This sets the login password to password2 from password1 for the 
'user User1 on server Local.X
=HypLoginSetPassword ("[Budget.xls]Sheet1", "password2", "password1", 
"Local", "User1") 
If X=0 then
   MsgBox("Set Password Successful.")
Else
   MsgBox("Set Password Unsuccessful.")
End If
End Sub

HypOtlGetMemberInfo

Description

HypOtlGetMemberInfo() returns the following information related to a member selection:
member comment, formula, UDA, attribute, etcetera.
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Syntax

HypOtlGetMemberInfo (vtSheetName, vtDimensionName, vtMemberName, vtPredicate,
vtMemberArray)

ByVal vtSheetName As Variant

ByVal vtDimensionName As Variant

ByVal vtMemberName As Variant

ByVal vtPredicate As Variant

ByRef vtMemberArray As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtDimensionName The name of the dimension. Can be Null; if Null, search for the predicate in the whole outline.
Dimension to limit the scope of the query.

vtMemberName Member name for which information is being queried on.

vtPredicate Member selection criteria:

1 HYP_COMMENT

2 HYP_FORMULA

3 HYP_UDA

4 HYP_ATTRIBUTE

vtMemberArray Output that contains the result of the query. Its contents are unknown if the macro fails.

Return Value

Returns a zero if successful; otherwise returns the appropriate error code.

Example
Declare Function HypOtlGetMemberInfo  Lib "HsAddin.dll" (ByVal vtSheetName 
As Variant, ByVal vtMemberName As Variant, ByVal vtPredicate As Variant, 
ByRef vtMemberArray As Variant) As Long

Sub HypOtlGetMemberInfo()
    vtRet = HypOtlGetMemberInfo  (vtSheetName, “Year”, “Jan”,
    HYP_COMMENT, vt) 
If IsArray(vt) Then cbItems = UBound(vt) + 1 
    MsgBox ("Number of elements = " + Str(cbItems)) 
For i = 0 To UBound(vt) 
    MsgBox ("Member = " + vt(i)) 
    Next 
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Else 
MsgBox ("Return Value = " + vtRet) 
End If
End Sub

HypPivot

Description

HypPivot() transposes spreadsheet rows and columns, based on the selected dimension.

Syntax

HypPivot(vtSheetName, vtStart, vtEnd)

ByVal vtSheetName As Variant

ByVal vtStart As Variant

ByVal vtEnd As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]Sheet".
If vtSheetName is Null or Empty, the active sheet is used.

vtStart Range object which refers to the single cell starting point of the pivot.

vtEnd Range object which refers to the single cell ending point of the pivot.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypPivot Lib "HsAddin.dll" (ByVal vtSheetName As Variant,  
ByVal vtStart As Variant, ByVal vtEnd As Variant) As Long

Sub DoPivot()
X=HypPivot("[Book2.xls]Sheet1", RANGE("B2"), RANGE("D1"))
   If X = 0 Then
      MsgBox("Pivot successful.")
   Else
      MsgBox("Pivot failed.")
   End If
End Sub
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HypPivotToGrid

Description

HypPivotToGrid() moves the selected dimension and members from the POV to the spreadsheet
grid.

Syntax

HypPivotToGrid (vtSheetName, vtDimensionName, vtSelection)

ByVal vtSheetName as Variant

ByVal vtDimensionName as Variant

ByVal vtSelection as Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtDimensionName Currently selected dimension from the toolbar.

vtSelection Range object which refers to the single cell starting point of the pivot. Orientation is calculated
based on the selection.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypPivotToGrid Lib “HsAddin.dll” (By Val vtSheetName As 
Variant, ByVal vtDimensionName as Variant, ByVal vtSelection as Variant) As 
Long

Sub DoPivotGrid()
X=HypPivotToGrid("[Book2.xls]Sheet1", “Product”, RANGE("E6"))
If X = 0 Then
   MsgBox("Pivot to grid successful.")
Else
   MsgBox("Pivot to grid failed.")
End If
End Sub
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HypPivotToPOV

Description

HypPivotToPOV() pivots from the spreadsheet grid to the POV.

Syntax

HypPivotToPOV (vtSheetName, vtSelection)

ByVal vtSheetName as Variant

ByVal vtSelection as Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]Sheet".
If vtSheetName is Null or Empty, the active sheet is used.

vtSelection Range object which refers to the single cell starting point of the pivot. Orientation is calculated based
on the selection.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypPivotToPOV Lib “HsAddin.dll” (By Val vtSheetName As 
Variant, ByVal vtSelection as Variant) As Long

Sub DoPivotPOV()
X=HypPivotToPOV("[Book2.xls]Sheet1", RANGE("E6"))
If X = 0 Then
   MsgBox("Pivot to POV successful.")
Else
   MsgBox("Pivot to POV failed.")
End If
End Sub

HypQueryMembers

Description

HypQueryMembers() executes the member selection query.
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Syntax

HypQueryMembers (vtSheetName, vtMemberName, vtPredicate, vtOption,
vtDimensionName, vtInput1, vtInput2, vtMemberArray)

ByVal vtSheetName As Variant

ByVal vtMemberName As Variant

ByVal vtPredicate As Variant

ByVal vtOption As Variant

ByVal vtDimensionName As Variant

ByVal vtInput1 As Variant

ByVal vtInput2 As Variant

ByRef vtMemberArray As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtMemberName The member name on which to perform the query.

vtPredicate Member selection criteria:

1 HYP_CHILDREN

2 HYP_DESCENDANTS

3 HYP_BOTTOMLEVEL

4 HYP_SIBLINGS

5 HYP_SAMELEVEL

6 HYP_SAMEGENERATION

7 HYP_PARENT

8 HYP_DIMENSION

9 HYP_NAMEDGENERATION

10 HYP_NAMEDLEVEL

11 HYP_SEARCH

12 HYP_WILDSEARCH

13 HYP_USERATTRIBUTE

14 HYP_ANCESTORS

15 HYP_DTSMEMBER

16 HYP_DIMUSERATTRIBUTES

vtOption Options are dependent on the predicate:
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Parameter Description

For the predicate values, HYP_SEARCH and HYP_WILDSEARCH, specify query options:
HYP_MEMBERSONLY

HYP_ALIASESONLY

HYP_MEMBERSANDALIASES

vtDimensionName Dimension to limit the scope of the query. It is used with the following query options and ignored
otherwise: HYP_NAMEDGENERATION, HYP_NAMEDLEVEL, HYP_USERATTRIBUTE HYP_SEARCH
(set to Null to search through all dimensions), HYP_WILDSEARCH (set to Null to search through
all dimensions).

vtInput1 Input string that is determined by the option. It is used with the following query options and
ignored otherwise:

● HYP_NAMEDGENERATION (The name of the generation)

● HYP_NAMEDLEVEL (The name of the level)

● HYP_SEARCH (The string to search for. The string is defined as an exact)

● HYP_WILDSEARCH (The string to search for. The string is defined as an exact search string
with an optional '*' at the end to mean any set of characters)

● HYP_USERATTRIBUTE (The user-defined attribute)

vtInput2 Input string that is determined by the option. It is used with the following query options and
ignored otherwise:

● HYP_USERATTRIBUTE (The user-defined attribute)

● HYP_SEARCH, HYP_WILDSEARCH (If the options are set to search in the alias tables, this
string specifies which alias table to search. If the string is Null, all alias tables will be
searched).

vtMemberArray Output that contains the result of the query. If unsuccessful, its contents are unknown.

Return Value

Returns a zero if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypQueryMembers Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtMemberName As Variant, ByVal vtPredicate As Variant, ByVal 
vtOption As Variant, ByVal vtDimensionName As Variant, ByVal vtInput1 As 
Variant, ByVal vtInput2 As Variant, ByRef vtMemberArray As Variant) As Long

Sub QueryMembersEmptyValues()
  vtRet = HypQueryMembers(Empty, Null, HYP_WILDSEARCH,
    HYP_MEMBERSONLY, "Year", "J*", "", vt) 
If IsArray(vt) Then 
  cbItems = UBound(vt) + 1 
      MsgBox ("Number of elements = " + Str(cbItems)) 
   For i = 0 To UBound(vt) 
      MsgBox ("Member = " + vt(i)) 
   Next 
Else
   MsgBox ("Return Value = " + Str(vt))
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End If 
End Sub

HypRedo

Description

HypRedo() restores the database view as it was before an Undo was performed.

Syntax

HypRedo (vtSheetName)

ByVal vtSheetName As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]Sheet".
If vtSheetName is Null or Empty, the active sheet is used.

Return Value

Returns 0 if successful. A negative number indicates a local failure. A return value greater than
zero indicates a failure on the server.

Example
Declare Function HypRedo Lib "HsAddin" (ByVal vtSheetName As Variant) As 
Long

Sub Redo()
   X=HypRedo("[Book2.xls]Sheet1")
End Sub

HypRemoveConnection

Description

HypRemoveConnection() removes the specified connection from the list of all available Smart
View connections.

Syntax

HypRemoveConnection(vtFriendlyName)
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ByVal vtFriendlyName As Variant

Parameters

Parameter Description

vtFriendlyName The friendly connection name for the data source provider.

Return Value

Returns 0 if successful, otherwise, returns the appropriate error code.

Example
 Declare Function HypRemoveConnection Lib "HsAddin" (ByVal vtFriendlyName 
As Variant) As Long

Sub RConn()
   X=HypRemoveConnection("My Connection")
End Sub

HypRemoveOnly

Description

HypRemoveOnly() removes only the selected member(s) in the sheet and retains unselected
members in the selected dimension.

Selection should include only member cells, not data cells.

Syntax

HypRemoveOnly(vtSheetName, vtSelection)

ByVal vtSheetName As Variant

ByVal vtSelection As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]Sheet".
If vtSheetName is Null or Empty, the active sheet is used.

vtSelection Range object which refers to the member(s) that will be removed. If selection is Null or Empty, the
active cell is used.
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Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypRemoveOnly Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtSelection As Variant) As Long

Sub ROnly()
' Remove Only on one member name
X=HypRemoveOnly("[Book2.xls]Sheet1", RANGE("D2"))
If X = 0 Then
   MsgBox("Remove Only successful.")
Else
   MsgBox("Remove Only failed." + X)
End If
' Remove Only on two member names
X=HypRemoveOnly("[Book2.xls]Sheet1", RANGE("D2, A5"))
If X = 0 Then
   MsgBox("Remove Only successful.")
Else
   MsgBox("Remove Only failed." + X)
End If
End Sub

HypRetrieve

Description

HypRetrieve() retrieves data from the database.

Syntax

HypRetrieve(vtSheetName)

ByVal vtSheetName As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]Sheet".
If vtSheetName is Null or Empty, the active sheet is used.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.
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Example
Declare Function HypRetrieve Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtRange As Variant, ByVal vtLock As Variant) As Long

Sub RetData()
X=HypRetrieve("[Book2.xls]Sheet1")
If X = 0 Then
   MsgBox("Retrieve successful.")
Else
   MsgBox("Retrieve failed.")
End If
End Sub

HypRetrieveRange

Description

HypRetrieveRange() gives users the ability to refresh a selected or named range of cells in a grid
or worksheet. If the range provided to this function contains more rows or columns than the
actual grid has, the additional rows and columns are treated as comments and are thus part of
the grid.

Range retrieval clears the Undo buffer, therefore the Undo operation cannot be used afterward.

Syntax

HypRetrieveRange(vtSheetName,vtRange,vtConnName)

ByVal vtSheetName As Variant

ByVal vtRange As Variant

ByVal vtConnectionName As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtRange Single continuous range to be refreshed. If vtRange is Null, the entire worksheet is refreshed,
and GetUsedRange is used on the worksheet specified to get the range to be refreshed.

vtConnectionName Friendly name of the connection to be used to refresh the range. If vtConn is Null, the active
connection associated with the worksheet is used to refresh the range on that worksheet. If no
connection is associated, an error is returned.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Using VBA Functions for Smart View 285



Example
Declare Function HypRetrieveRange Lib "HsAddin" (ByVal vtSheetName As 
Variant, ByVal vtRange As Variant, ByVal vtConnName As Variant) As Long
Worksheets("Sheet2").Names.Add name:="MyRange", RefersTo:="=$E$11:$F$28"

Sub Sample_RetrieveRange
    Worksheets("Sheet2").Names.Add name:="MyRange", RefersT o:="=$E$11:
$            F$28"
     sts = HypRetrieveRange("Sheet2", range("E11:F28"), "Samp1")  
            'retrieve by regular range
    sts = HypRetrieveRange("Sheet2", range("MyRange"), "Samp1")  
            'retrieve by named range
End sub

HypSetActiveConnection

Description

HypSetActiveConnection() is used to associate the current active worksheet with one of the
active connections.

Syntax

HypSetActiveConnection (vtConnectionName)

ByVal vtConnectionName as Variant

Parameters

Parameter Description

vtConnectionName Name of the active connection which is to be associated with the current active worksheet. It
is not case-sensitive.

Return Value

Long. If successful, return value is 0; otherwise, the appropriate error code is returned.

Example
Declare Function HypSetActiveConnection Lib "HsAddin.dll" (ByVal 
vtConnectionName As Variant) As Long

Sub Sample_SetActiveConnection
   sts = HypSetActiveConnection (“Demo_Basic”)
End sub
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HypSetAliasTable

Description

HypSetAliasTable() enables users to change alias tables in Essbase

Syntax

HypSetAliasTable (ByVal vtSheetName As Variant, ByVal vtAliasTableName As Variant)

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]
Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtAliasTableName Text name of teh alias table. vtAliasTableName is of the form “Default”, “Long Names” and
so forth.

Return Value

0 if successul, else negative value

Example
Public Declare Function HypSetAliasTable Lib "HsAddin.dll" (ByVal 
vtSheetName As Variant, ByVal vtAliasTableName As Variant) As Long

Sub Sample_SetActiveConnection
   sts = HypSetAliasTable("Sheet1","Long Name")
End sub

HypSetBackgroundPOV

Description

HypSetBackgroundPOV() sets the POV for the connection object in the POV Manager.

Syntax

HypSetBackgroundPOV(vtFriendlyName, ParamArray MemberList())

ByVal vtFriendlyName As Variant

ParamArray MemberList() As Variant
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Parameters

Parameter Description

vtFriendlyName Connection name for the data source provider.

MemberList A list of strings which describe the member combination for which a data value will be retrieved. If
MemberList is Null or Empty, the top level value is used.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypSetBackgroundPOV Lib "HsAddin" (ByVal vtFriendlyName, 
ParamArray MemberList() As Variant) As Long

Sub SetBGPOV()
   X=HypSetBackgroundPOV (“My Connection”,”Year#Qtr1”, “Market#East”)
End Sub

HypSetCellsDirty

Description

HypSetCellsDirty() marks selected data range dirty for submit data.

Syntax

HypSetCellsDirty (vtSheetName, vtRange)

ByVal vtSheetName As Variant

ByVal vtRange As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]Sheet".
If vtSheetName is Null or Empty, the active sheet is used.

vtRange Variant data range to be marked as dirty.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.
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Example
Declare Function HypSetCellsDirty Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtRange As Variant) As Long

Sub SetDirtyCells()
   X=HypSetCellsDirty (“Sheet1”, Range (“A3:B3”)
End Sub

HypSetColItems

Description

HypSetColItems() sets the members for the nth column dimension for the dynamic link query.
If the nth column does not exist, a new column is appended.

Note:

This function is used specifically with dynamic link views, as described in “Dynamic Link Views”
on page 226

Syntax

HypSetColItems (vtColumnID, vtDimensionName, ppMemberList())

ByVal vtColumnID As Variant

ByVal vtDimensionName As Variant

ParamArray ppMemberList() As Variant

Parameters

Parameter Description

vtColumnID The column number n.

vtDimensionName The dimension name.

ppMemberList The list of member names.

Return Value

Long. Returns 0 if successful, otherwise, returns the negative error code.

Example
Declare Function HypSetColItems Lib "HsAddin.dll" (ByVal vtColID As 
Variant, ByVal vtDimensionName As Variant, ParamArray MemberList() As 
Variant) As Long
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Sub Macro()
   Dim vtGrid as Variant
   Sts = HypConnect("Sheet1", "system", "password", "SalesDemoBasic")
   Sts = HypRetrieve("Sheet1")
   Range (“B2”).Select
   Sts = HypGetSourceGrid (“Sheet1”, vtGrid)
   Sts = HypSetColItems (1, "Market", "East", "West", "South", 
    "Central", "Market")
End sub

HypSetConnectionInfo

Description

HypSetConnectionInfo() is used to modify the connection information in the query.

The parameters passed for HypSetConnectionInfo() should be match the connection
information stored with that connection name.

Note:

This function is used specifically with dynamic link views, as described in “Dynamic Link Views”
on page 226

Syntax

HypSetConnectionInfo (vtServerName, vtUserName, vtPassword, vtApplicationName,
vtDatabaseName, vtFriendlyName, vtURL, vtProviderType)

ByVal vtServerName As Variant

ByVal vtUserName As Variant

ByVal vtPassword As Variant

ByVal vtApplicationName As Variant

ByVal vtDatabaseName As Variant

ByVal vtFriendlyName As Variant

ByVal vtURL As Variant

ByVal vtProviderType As Variant

Parameters

Parameter Description

vtServerName The server name in the query.

vtUserName The user name in the query.
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Parameter Description

vtPassword The user password in the query.

vtApplicationName The application name in the query.

vtDatabaseName The database name in the query.

vtFriendlyName The friendly connection name in the query.

vtURL The provider URL in the query.

vtProviderType The provider type in the query.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypSetConnectionInfo Lib "HsAddin.dll" (ByVal vtServerName 
As Variant, ByVal vtUserName As Variant, ByVal vtPassword As Variant, ByVal 
vtApplicationName As Variant, ByVal vtDatabaseName As Variant, ByVal 
vtFriendlyName As Variant, ByVal vtURL As Variant, ByVal vtProviderType As 
Variant) As Long

Sub Macro()
   Dim vtGrid as Variant
   Sts = HypConnect("Sheet1", "system", "password", "DemoBasic")
   Sts = HypRetrieve("Sheet1")
   Range (“B2”).Select
   Sts = HypGetSourceGrid (“Sheet1”, vtGrid)
   Sts = HypSetConnectionInfo(“localhost”, “system”, 
    “password”,        “Sample”, “Basic”, “SampleBasic”, 
    “http://localhost:13080/aps/SmartView”, provider)
End sub

HypSetGlobalOption

Description

HypSetGlobalOption() sets individual workspace options. For option descriptions, see
Chapter 14, “User Preferences.”

Note:

You can set only one option at a time.

Syntax

HypSetGlobalOption(vtItem, vtGlobalOption)
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ByVal vtItem As Long

ByVal vtGlobalOption As Variant

Parameters

Parameter Description

vtItem Number indicating which option is to be retrieved. See Table 18 for values.

vtGlobalOption A Boolean or Number value denoting the option being set for vtItem. If vtGlobalOption is Null or
Empty, no action is performed.

Table 18 indicates which options are returned for the vtItem parameter.

Table 18 Values for HypSetGlobalOption item Parameter

vtItem Option Return Data Type

1 Enable Excel formatting Boolean

2 Enable double-click for Ad Hoc operations Boolean

3 Enable Undo Boolean

4 Not used Boolean

5 Specify message level setting:

0 Information messages

1 Warning messages

2 Error messages

3 No messages

Number

6 Use thousands separator Boolean

7 Enable route messages to log file Boolean

8 Clear log file on next launch Boolean

9 Enable Navigate Without Data Boolean

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example

The following example sets the option to display error messages only.

Declare Function HypSetGlobalOption Lib "HsAddin.dll" (ByVal vtItem As 
Long, ByVal vtGlobalOption As Variant) As Long
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Sub SetGlobal()
   X=HypSetGlobalOption(5, 3)
If X=0 Then
   MsgBox("Message level is set to 3 - No messages")
Else
   MsgBox("Error. Message level not set.")
End If
End Sub

HypSetLinkMacro

Description

HypSetLinkMacro() sets the macro name to be run to perform the dynamic link query action.

Note:

Once the link action is triggered from the Hyperion > Link View > Visualize in Excel menu item,
the macro name set by this function name will be run.

Note:

This function is used specifically with dynamic link views, as described in “Dynamic Link Views”
on page 226.

Syntax

HypSetLinkMacro (vtMacroName)

ByVal vtMacroName As Variant

Parameters

Parameter Description

vtMacroName The name of the macro to be run.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypSetLinkMacro Lib "HsAddin.dll" (ByVal vtMacroName As 
Variant) As Long

Sub Auto_Open()
  Sts = HypUseLinkMacro(True)
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  Sts = HypSetLinkMacro(“Sheet1.Macro8”)
End Sub

HypSetMenu

Description

HypSetMenu() removes or restores the Hyperion menu from Excel.

Syntax

HypSetMenu(bSetMenu)

ByVal bSetMenu As Boolean

Parameters

Parameter Description

bSetMenu Boolean value indicating whether to remove or restore the Hyperion menu for Excel.

A True value indicates that the menu should be restored. A False value indicates that the menu should
be removed.

Return Value

Returns 0 if successful. If the menu cannot be set, returns an error code.

Example
Declare Function HypSetMenu Lib "HsAddin.dll" (ByVal bSetMenu As Boolean) 
As Long

Sub SetMyMenu()
   X=HypSetMenu(TRUE)
End Sub

HypSetPOV

Description

HypSetPOV() sets the POV for the selected sheet.

Syntax

HypSetPOV(vtSheetName ParamArray MemberList())

ByVal vtSheetName As Variant
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ParamArray MemberList() As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]Sheet".
If vtSheetName is Null or Empty, the active sheet is used.

MemberList A list of strings which describe the member combination for which a data value will be retrieved. If
MemberList is Null or Empty, the top level value is used.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypSetPOV Lib "HsAddin" (ByVal vtSheetName, ParamArray 
MemberList() As Variant) As Long

Sub SetPOV()
   X=HypSetPOV (“[Book2.xls]Sheet1”,”Year#Qtr1”, “Market#East”)
End Sub

HypSetPOVItems

Description

HypSetPOVItems() sets the POV dimensions for the dynamic link query.

Note:

This function is used specifically with dynamic link views, as described in “Dynamic Link Views”
on page 226

Syntax

HypSetPOVItems (ppMemberList())

ParamArray ppMemberList() As Variant

Parameters

Parameter Description

ppMemberList The list of desired POV items in the form Dimension#Current Member.

Using VBA Functions for Smart View 295



Return Value

Returns 0 if successful; otherwise, returns the negative error code.

Example
Declare Function HypSetLinkMacro Lib "HsAddin.dll" (ByVal vtMacroName As 
Variant) As Long

Sub Macro()
   Dim vtGrid as Variant
   Sts = HypConnect("Sheet1", "system", "password", "MyDemoBasic")
   Sts = HypRetrieve("Sheet1")
   Range (“B2”).Select
   Sts = HypGetSourceGrid (“Sheet1”, vtGrid)
   Sts = HypSetPOVItems ("Scenario#Scenario", "Measures#Measures")
End sub

HypSetRowItems

Description

Sets the members for the nth row dimension for this dynamic link query. If the nth row does
not exist, a new row is appended.

Note:

This function is used specifically with dynamic link views, as described in “Dynamic Link Views”
on page 226

Syntax

HypSetRowItems (vtRowID, vtDimensionName, ppMemberList())

ByVal vtRowID As Variant

ByVal vtDimensionName As Variant

ParamArray ppMemberList() As Variant

Parameters

Parameter Description

vtRowID The row number n.

vtDimensionName The dimension name.

ppMemberList The list of member names.
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Return Value

Long. Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypSetRowItems Lib "HsAddin.dll" (ByVal vtRowID As 
Variant, ByVal vtDimensionName As Variant, ParamArray MemberList() As 
Variant) As Long

Sub Macro()
   Dim vtGrid as Variant
   Sts = HypConnect("Sheet1", "system", "password", "DemoBasic")
   Sts = HypRetrieve("Sheet1")
   Range (“B2”).Select
   Sts = HypGetSourceGrid (“Sheet1”, vtGrid)
   Sts = HypSetRowItems(1, "Product", "100", "200", "300", "400", "Diet", 
"Product")
End sub

HypSetSheetOption

Description

HypSetSheetOption() sets individual spreadsheet options.

Note:

You can set only one option at a time (this function is not plural).

Syntax

HypSetSheetOption(vtSheetName, vtItem, vtOption)

ByVal vtSheetName As Variant

ByVal vtItem As Variant

ByVal vtOption As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtItem Number indicating which option is to be set. See Table 19 for a list of values.

vtOption A Boolean value denoting the new value of item.

Table 19 indicates which options are set for which number and the expected data type.
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Table 19 vtItems

vtItem Option Data Type and Values

1 Set zoom in level:

0 Next level

1 All levels

2 Bottom level

Number

2 Enable Include Selection setting Boolean

3 Enable Within Selection Group setting Boolean

4 Enable Remove Unselected Groups setting Boolean

5 Specify Indent setting:

0 No indentation

1 Indent sub items

2 Indent totals

Number

6 Enable suppress missing setting Boolean

7 Enable suppress zeros setting Boolean

8 Enable suppress underscores setting Boolean

9 Enable No Access setting Boolean

10 Enable Repeated Members setting Boolean

11 Enable invalid setting Boolean

12 Ancestor Position:

0 Top

1 Bottom

Number

13 Specify Missing text label Text

14 Specify No Access label Text

15 Cell status:

0 Data

1 Calculation status

2 Process Management

Number

16 Member Name Display options:

0 Name only

1 Name and Description

2 Description only

Number
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Return Values

Returns 0 if successful. A negative number indicates a local failure. A return value greater than
zero indicates a failure on the server.

Example
Declare Function HypSetSheetOption Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtItem As Variant, ByVal vtOption As Variant) As Long

Sub SetSheet()
X=HypSetSheetOption(Null, 6, FALSE)
If X=0 Then
   MsgBox("#Missing values will appear. ")
Else
   MsgBox("Error. #Missing option not set.")
End If
End Sub

HypSetSubstitutionVariable

Description

HypSetSubstitutionVariable() creates substitution variables on Analytic Server. If the variable
already exists, then its value is set to the new specified value.

Syntax

HypSetSubstitutionVariable (vtSheetName, vtApplicationName, vtDatabaseName,
vtVariableName, vtVariableValue)

ByVal vtSheetName As Variant

ByVal vtApplicationName As Variant

ByVal vtDatabaseName As Variant

ByVal vtVariableName As Variant

ByVal vtVariableValue As Variant

Parameters

Parameter Description

vtSheetName The text name of the worksheet on which to operate. vtSheetName is of the form
"[Book.xls]Sheet". If vtSheetName is Null or Empty, the active sheet is used.

vtApplicationName The application name to define the scope for the new variable. If vtApplicationName is Null or
Empty , the scope of the variable created is global.
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Parameter Description

vtDatabaseName The database name to define the scope for the new variable. If vtDatabaseName is Null or
Empty, the scope of the variable created is global within the application specified.

vtVariableName The variable name to be created. Required.

vtVariableValue The value to be assigned to the variable. Required.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypSetSubstitutionVariable Lib "HsAddin.dll" (ByVal 
vtSheetName As Variant, ByVal vtApplicationName As Variant, ByVal 
vtDatabaseName As Variant, ByVal vtVariableName As Variant, ByVal 
vtVariableValue As Variant) As Long

Sub Sample_HypSetSubstitutionVariable
   Dim X as Long
   X = HypSetSubstitutionVariable ("Sheet1", "Sample", "Basic", 
    "Account", "100")
End Sub

HypSubmitData

Description

HypSubmitData() updates the database with modified data from the specified spreadsheet.

Note:

HypSubmitData() is not supported with aggregate storage databases or in a clustered
environment.

Note:

The ability to update the database depends on the access permissions of the submitter. To update
data, you must have at least Write access to the database.

Syntax

HypSendData(vtSheetName)

ByVal vtSheetName As Variant
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Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]Sheet".
If vtSheetName is Null or Empty, the active sheet is used.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypSubmitData Lib "HsAddin" (ByVal vtSheetName As Variant) 
As Long

Worksheets("Sheet1").range("B2").value = 8023
Worksheets("Sheet1").range("B2").Select
sts = HypSubmitData("Sheet1")

HypTranslate

Description

HypTranslate() calls the Translate method for Financial Management data sources.

Syntax

HypTranslate (vtSheetName, vtRange)

ByVal vtSheetName As Variant

By Val vtRange As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to operate on. vtSheetName is of the form "[Book.xls]Sheet". If
vtSheetName is Null or Empty, the active sheet is used.

vtRange Range object which refers to the data to be used. Passing an empty or null parameter uses the current
selection from the sheet.

Return Value

Returns 0 if successful; otherwise, returns the corresponding error code.
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Example
Declare Function HypTranslate Lib "HsAddin" (ByVal vtSheetName As Variant, 
ByVal vtRange As Variant) As Long

sts = HypTranslate  (“Sheet1”, Empty)

HypUndo

Description

HypUndo() restores the previous database view. A database view is the view of the spreadsheet
after performing Zoom In, Zoom Out, Keep Only, Remove Only, or Refresh commands.

Syntax

HypUndo (vtSheetName)

ByVal vtSheetName As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]Sheet".
If vtSheetName is Null or Empty, the active sheet is used.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example

Declare Function HypUndo Lib "HsAddin.dll" (ByVal vtSheetName As Variant) 
As Long

Sub Undo()
   X=HypUndo("[Book2.xls]Sheet1")
End Sub

HypUseLinkMacro

Description

HypUseLinkMacro() is used to set the flag to specify the type of link view, static or dynamic.
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Note:

Static and dynamic link views share the same menu option; therefore, it is necessary to turn the
flag on before performing the dynamic link query. Once done with dynamic link views, turn the
flag off.

Note:

This function is used specifically with link views, as described in “Dynamic Link Views” on page
226.

Syntax

HypUseLinkMacro (bSetView)

ByVal bSetView as Boolean

Parameters

Parameter Description

bSetView When flag is set to true, dynamic link is performed. When the flag is set to false, static link is performed.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example

Declare Function HypUseLinkMacro Lib "HsAddin.dll" (ByVal bUse As Boolean) 
As Long

Sub Macro()
   Sts = HypUseLinkMacro(True)
End sub

HypZoomIn

Description

HypZoomIn() retrieves and expands data from Smart View based on the selected members.

Syntax

HypZoomIn(vtSheetName, vtSelection, vtLevel, vtAcross)

ByVal vtSheetName As Variant
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ByVal vtSelection As Variant

ByVal vtLevel As Variant

ByVal vtAcross As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]Sheet".
If vtSheetName is Null or Empty, the active sheet is used.

vtSelection Range object which refers to the members that will be zoomed. If selection is Null or Empty, the active
cell is used.

vtLevel Number indicating the granularity of the zoom. The following table describes the valid numbers:

level Action

1 Next level

2 All levels

3 Bottom level

If level is Null or Empty, 1 is used.

You could also use the Level Constants instead of 1-3 to set the zoom-in level.

vtAcross A variant value indicating whether top-level members of a dimension (for example, Products in Sample
Basic) should be zoomed across. A True value indicates that the data should be displayed across
while a False value indicates that the data should be displayed downward. If across is Null or Empty,
False is used. Across is meaningful only for top-level members, also known as dimension or title
members.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example

Declare Function HypZoomIn Lib "HsAddin.dll" (ByVal sheetName As Variant,  
ByVal vtSelection As Variant, ByVal vtLevel As Variant, ByVal vtAcross As 
Variant) As Long

Sub ZoomData()
X=HypZoomIn("[Book2.xls]Sheet1", RANGE("B3"), 1, FALSE)
If X = 0 Then
   MsgBox("Zoom successful.")
Else
   MsgBox("Zoom failed.")
End If
End Sub
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HypZoomOut

Description

HypZoomOut() collapses the view of data based on the selected members.

Syntax

HypZoomOut(vtSheetName, vtSelection)

ByVal vtSheetName As Variant

ByVal vtSelection As Variant

Parameters

Parameter Description

vtSheetName Text name of worksheet to perform the action. vtSheetName is of the form "[Book.xls]Sheet".
If vtSheetName is Null or Empty, the active sheet is used.

vtSelection Range object which refers to the members that will be zoomed out. If selection is Null or Empty, the
active cell is used.

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypZoomOut Lib "HsAddin.dll" (ByVal vtSheetName As 
Variant, ByVal vtSelection As Variant) As Long

Sub UnZoomData()
X=HypZoomOut("[Book2.xls]Sheet1", RANGE("B3"))
If X = 0 Then
   MsgBox("Zoom out successful.")
Else
   MsgBox("Zoom out failed.")
End If
End Sub

About Visual Basic Menu Equivalent Functions
These Visual Basic functions are identical to the equivalent commands on the Hyperion menu.
Use the functions to perform actions as if you selected them from the menu. The requirements
for the functions are the same as those for the menu commands. For example, if you must be
logged in to an instance of Analytic Server to use a menu command, you must also be logged in
to an instance of Analytic Server to use the equivalent Visual Basic function.
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Visual Basic Menu Functions
Table 20 lists the Smart View VBA menu equivalent functions alphabetically and specifies the
data source provider that supports the function. A detailed description for each function,
including the syntax, parameters, return value, and sample code, follows the table.

Table 20 VBA Menu Equivalent Functions and Supported Providers

VBA Functions Oracle's Hyperion®
Essbase® – System 9

Oracle's Hyperion®
Financial Management –
System 9

Oracle's Hyperion®
Enterprise®

HypMenuVCalculation  X X

HypMenuVConnect X X X

HypMenuVDisconnect X X X

HypMenuVKeepOnly X X X

HypMenuVOptions X X X

HypMenuVPivot X X X

HypMenuVRemoveOnly X X X

HypMenuVRefresh X X X

HypMenuVSubmitData X X X

HypMenuVZoomIn X X X

HypMenuVZoomOut X X X

HypMenuVCalculation

Description

HypMenuVCalculation() can be used to open the Calculation Scripts dialog box and calculate
the active database or checks on the status of an active database calculation.

Syntax

HypMenuVCalculation()

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.
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Example
Declare Function HypMenuVCalculation Lib "HsAddin.dll"() As Long 

Sub MCalc()
   X=HypMenuVCalculation() 
End Sub

HypMenuVConnect

Description

HypMenuVConnect() can be used to connect to a data source instance.

Syntax

HypMenuVConnect()

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypMenuVConnect Lib "HsAddin.dll"() As Long

Sub MConn()
   X=HypMenuVConnect()
End Sub

HypMenuVDisconnect

Description

HypMenuVDisconnect() disconnects you from any currently connected databases.

Syntax

HypMenuVDisconnect()

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.
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Example
Declare Function HypMenuVDisconnect Lib "HsAddin.dll"() As Long

Sub MDisConn()
   X=HypMenuVDisconnect()
End Sub

HypMenuVKeepOnly

Description

HypMenuVKeepOnly() retains only the selected member (the active cell) or member range in
the sheet.

Syntax

HypMenuVKeepOnly()

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypMenuVKeepOnly Lib "HsAddin.dll"() As Long

Sub MKeepOnly()
   X=HypMenuVKeepOnly()
End Sub

HypMenuVOptions

Description

HypMenuVOptions() enables you to select options for the active sheet and customize the
behavior of Oracle's Hyperion® Smart View for Office, using the Options dialog box.

Syntax

HypMenuVOptions()

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.
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Example
Declare Function HypMenuVOptions Lib "HsAddin.dll"() As Long

Sub MOptions()
   X=HypMenuVOptions()
End Sub

HypMenuVPivot

Description

HypMenuVPivot() changes the orientation (from row to column or from column to row) of
the group of members associated with the active cell.

Syntax

HypMenuVPivot()

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypMenuVPivot Lib "HsAddin.dll"() As Long

Sub MPivot()
   X=HypMenuVPivot()
End Sub

HypMenuVRemoveOnly

Description

HypMenuVRemoveOnly() removes only the selected member (the active cell) or member range
in the sheet.

Syntax

HypMenuVRemoveOnly()

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.
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Example
Declare Function HypMenuVRemoveOnly Lib "HsAddin.dll"() As Long

Sub MRemoveOnly()
   X=HypMenuVRemoveOnly()
End Sub

HypMenuVRefresh

Description

HypMenuVRefresh() retrieves data into the active sheet, and places the data at the beginning of
the active worksheet.

Syntax

HypMenuVRefresh()

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example
Declare Function HypMenuVRefresh Lib "HsAddin.dll"() As Long

Sub MRetrieve()
   X=HypMenuVRefresh()
End Sub

HypMenuVSubmitData

Description

HypMenuVSubmitData() updates the active database on the server with data that has been
modified in your sheet or marked as “dirty” using the SetCellsDirty call.

Syntax

HypMenuVSubmitData()

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.
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Example
Declare Function HypMenuVSubmitData Lib "HsAddin.dll"() As Long

Sub MSubmit()
   X=HypMenuVSubmitData()
End Sub

HypMenuVZoomIn

Description

HypMenuVZoomIn() retrieves and expands data from the data source according to the options
specified in the Options dialog box.

Syntax

HypMenuVZoomIn()

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.

Example

Declare Function HypMenuVZoomIn Lib "HsAddin.dll"() As Long

Sub MZoomIn()
   X=HypMenuVZoomIn()
End Sub

HypMenuVZoomOut

Description

HypMenuVZoomOut() collapses the view of data according to the options specified in the
Options dialog box.

Syntax

HypMenuVZoomOut()

Return Value

Returns 0 if successful; otherwise, returns the appropriate error code.
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Example
Declare Function HypMenuVZoomOut Lib "HsAddin.dll"() As Long

Sub MZoomOut()
   X=HypMenuVZoomOut()
End Sub
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Index

Financial Reporting
PowerPoint templates, 173

Symbols
#Missing label

handling in free-form, 106
#Missing rows, suppressing, 202
#Missing Values in data forms, 50
#NoData label, replacing, 206, 207

A
accessing a drill-through report, 100
Ad Hoc

accessing Hybrid Analysis data, 92
adding cell text, 94
calculating data, 95
consolidating data, 98
displaying aliases for member names, 91
Dynamic Time Series members, 86
enabling double-clicking for, 203
free-form, 101
keeping data, 94
pivot, 93
removing data, 94
selecting members, 81
submitting data, 98
translating data, 97
viewing cell text, 95
working with formulas, 98
zoom in, 89
zoom out, 89

ad hoc and data forms, 230
Ad Hoc features, 19
ad hoc options, 201

ancestor position in hierarchies, 205
enabling double-click for Ad Hoc operations, 203
indenting member names, 202

navigating the spreadsheet without retrieving data,
202

retaining members, 205
suppressing types of data, 201
Undo and Redo, enabling, 203, 204
Undo and Redo, using, 204
zoom options, 204

Ad Hoc tab
ancestor position in hierarchies, 205
double-click for Ad Hoc operations, enabling, 203
indenting member names in spreadsheets, 202
member retention options, 205
navigating the spreadsheet without retrieving data,

202
suppressing types of data, 201
Undo and Redo, enabling, 203, 204
Undo and Redo, using, 204
zoom options, 204

Add button, 14
Adjust button, 13
adjusting values, 57
aliases, displaying for member names, 91
All Levels zoom option, 204
ancestor position in hierarchies, 205
asymmetric reports, 147

definition of, 147
retrieving data into, 147

attribute dimensions and members, 83
attribute dimensions, in free-form grids, 104
automatic deployment, 29

B
background POV, 214
backward compatibility, 30
base currency, overriding, 52
benefits, 11
Bottom Level zoom option, 204
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business rules
Calculate Currencies, 56
Calculate Form, 56
launching, 54
overview, 53
runtime prompts in, 55

Business Rules button, 13
buttons

Add, 14
Adjust, 13
Business Rules, 13
Cell Text, 13
Collapse, 13
Connection Manager, 12
Copy Data Points, 13
Expand, 13
Function Builder, 13
Instructions, 13
Keep Only, 12
Lock, 13
Member Selection, 13
Options, 14
Paste Data Points, 13
Pivot, 12
POV Manager, 13
Query Designer, 13
Redo, 12
Refresh, 12
Refresh All, 12
Remove, 14
Remove Only, 12
Rules on Form, 13
Run Reports, 13
Select Form, 13
Submit Data, 12
Supporting Details, 13
Sync Back, 13
Take Offline, 13
Undo, 12
Visualize in Excel, 14
Visualize in HVE, 14
Zoom In, 12
Zoom Out, 12

C
Calculate Currencies business rule, 56
Calculate Form business rule, 56

calculating data in Ad Hoc grids, 95
calculating rows, inserting, 97
calculation scripts.. See business rules
Calculation Status grid display option, 207
cell styles options

order of precedence of styles, 212
Cell Styles tab

order of precedence of styles, 212
Cell Text button, 13
cell text in Ad Hoc grids, 94
cell text in data forms

adding, 50
viewing and editing, 51

cells, 49. See also data
copying and pasting in data forms, 49
currency code, location of, 52
currency, changing, 52
navigating in data forms, 45
selecting a range in data forms, 48

changing passwords in Analytic Services, 41
Collapse button, 13
comments in free-form

handling, 105
preserving, 106

concurrent use of Smart View and Essbase Spreadsheet
Add-in, 28

Connection Manager
about, 34
tasks you can perform using, 33
using shortcut menus, 41

Connection Manager button, 12
consolidating data in Ad Hoc grids, 98
Copy Data Points button, 13
copying and pasting data points into Word and

PowerPoint, 149
copying data in data forms, 49
creating

an offline connection, 194
currency

changing for a data cell, 52
currency codes

location of, 52
custom formats, 48

D
data

adjusting, 57
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entering percentage values, 49
missing values, 50
submitting, 52
subtotaling, 51

data display options in the grid
Calculation Status option, 207
Data option, 207
Decimal Places option, 207
Member Name Only option, 208
Process Management option, 207
Scale options, 207
setting, 207

data filtering, 75
data form features, 23
data forms

ad hoc, 230
currency, changing, 52
customizing format, 48
navigating, 45
opening, 45
refreshing offline, 197
selecting multiple, 45
taking offline, 193, 194
viewing instructions, 45
viewing multiple, 46
working with formulas, 68
working with offline, 195

Data grid display option, 207
data source

adding a new connection, 34
adding from Shared Services, 37
adding through direct connection, 35
associating with a worksheet, 38
available types, 34
checking for active connections, 41
connecting to a, 37
definition, 34
deleting, 40
disconnecting from, 40
editing an existing connection, 38
resetting connections, 41

Decimal Places grid display option, 207
decimal separator in data forms, 48
default connection

setting, 39
default connection, setting, 39
dirty cells

defined, 105
submitting in free-form, 105

disabling Smart View, 27
display options, 206

data display options in the grid, setting, 207
Excel formatting, using, 209
messages, specifying types to display, 210
specifying UI colors, 208

Display tab
data display options in the grid, setting, 207
Excel formatting, 209
messages, specifying types to display, 210
specifying UI colors, 208

displaying aliases for member names, 91
Reporting and Analysisdocument import features, 24
double-clicking for Ad Hoc operations, enabling,

203
drill-through reports

accessing, 100
working with, 99

duplicate member names, resolving in free-form
mode, 121

dynamic data access features, 22
dynamic data points, 149
dynamic link views

working with, 226
Dynamic Time Series members

in Ad Hoc grids, 86

E
editing documents, 156
enabling Smart View, 27
Excel formatting, using, 209
Expand button, 13

F
filtering data, 75
filtering members, 74, 83
formats in free-form

preserving, 106
forms, data

refreshing offline, 197
taking offline, 193, 194
working with offline, 195

formulas
in ad hoc grids, 98
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in data forms, 68
preserving when POV changes, 209

formulas in free-form
preserving, 106

free-form, 101
#Missing, handling, 106
asymmetric reports, 147
attribute dimensions, working with, 104
comment handling, 105
comments, preserving, 106
constructing a report, 118
dirty cells, submitting, 105
entering text, 101
example scenario, 122, 131
formats, preserving, 106
formulas, preserving, 106
grid components, 102
guidelines, 103
invalid grids, 107
preserving comments, formulas, formats, 106
resolving member names, 121
retrieving, 118
submitting dirty cells, 105
valid grids, 107

Function Builder, 177
Function Builder button, 13
function features, 24
functions

creating manually, 189
editing, 190
error codes, 191
overview, 176
running, 190
selecting members for, 180

G
Google, 14
graphical views of grids, 153
grid components of free-form, 102
guidelines for free-form reporting, 103

H
HsCurrency function

syntax, 183
using smart tags to retrieve entity currency, 186

HsDescription function

syntax, 183
using smart tags to display POV description, 187

HsGetText function
syntax, 184
using smart tags to import cell text, 186

HsGetValue function
syntax, 182
using smart tags to retrieve single value, 185

HsLabel function, 183
HsSetText function, 184
HsSetValue function, 182
Hybrid Analysis, accessing data from a relational

source, 92
HypCalculate VBA function, 233
HypCalculateContribution VBA function, 234
HypCell VBA function, 235
HypConnect VBA function, 236
HypConnected VBA function, 237
HypConnectionExists VBA function, 237
HypConsolidate VBA function, 238
HypConsolidateAll VBA function, 239
HypConsolidateAllWithData VBA function, 240
HypCreateConnection VBA function, 240
HypDeleteCalc VBA function, 242
HypDisconnect VBA function, 243
HypDisplayToLinkView VBA function, 244
Hyperion Visual Explorer, 153
Hyperion Visual Explorer features, 23
HypExecuteCalcScript VBA function, 245
HypExecuteQuery VBA function, 246
HypFindMember VBA function, 247
HypForceCalculate VBA function, 248
HypForceCalculateContribution VBA function, 249
HypForceTranslate VBA function, 249
HypFreeDataPoint VBA function, 250
HypGetAncestor VBA function, 251
HypGetChildren VBA function, 252
HypGetColCount VBA function, 253
HypGetColItems VBA function, 253
HypGetConnectionInfo VBA function, 254
HypGetDataPoint VBA function, 256
HypGetGlobalOption VBA function, 257
HypGetLinkMacro VBA function, 258
HypGetParent VBA function, 259
HypGetPOVCount VBA function, 260
HypGetPOVItems VBA function, 261
HypGetRowCount VBA function, 262
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HypGetRowItems VBA function, 262
HypGetSheetOption VBA function, 263
HypGetSourceGrid VBA function, 265
HypGetSubstitutionVariable VBA function, 266
HypIsAttribute VBA function, 268
HypIsDescendant VBA function, 269
HypIsExpense VBA function, 270
HypIsParent VBA function, 271
HypIsUDA VBA function, 271
HypKeepOnly VBA function, 272
HypListCalcScripts VBA function, 273
HypMenuVCalculation VBA function, 306
HypMenuVConnect VBA function, 307
HypMenuVDisconnect VBA function, 307
HypMenuVKeepOnly VBA function, 308
HypMenuVOptions VBA function, 308
HypMenuVPivot VBA function, 309
HypMenuVRefresh VBA function, 310
HypMenuVRemoveOnly VBA function, 309
HypMenuVSubmitData VBA function, 310
HypMenuVZoomIn VBA function, 311
HypMenuVZoomOut VBA function, 311
HypOtlGetMemberInfo VBA function, 275
HypPivot VBA function, 277
HypPivotToGrid VBA function, 278
HypPivotToPOV VBA function, 279
HypQueryMembers VBA function, 279
HypRedo VBA function, 282
HypRemoveConnection VBA function, 282
HypRemoveOnly VBA function, 283
HypRetrieve VBA function, 284
HypRetrieveRange VBA function, 285
HypSetActiveConnection VBA function, 286
HypSetBackgroundPOV VBA function, 287
HypSetCellsDirty VBA function, 288
HypSetColItems VBA function, 289
HypSetConnectionInfo VBA function, 290
HypSetGlobalOption VBA function, 291
HypSetLinkMacro VBA function, 293
HypSetMenu VBA function, 294
HypSetPOV VBA function, 294
HypSetPOVItems VBA function, 295
HypSetRowItems VBA function, 296
HypSetSheetOption, 297
HypSetSubstitutionVariable VBA function, 299
HypTranslate VBA function, 301
HypUndo VBA function, 302

HypUseLinkMacro VBA function, 302
HypZoomIn VBA function, 303
HypZoomOut VBA function, 305

I
Indentation options

None, 202
Subitems, 202
Totals, 202

indenting member names in spreadsheets, 202
inserting

calculating rows, 97
non-calculating rows, 97

installing Smart View, 27
Instructions button, 13
introduction, 11
invalid rows, suppressing, 202

K
Keep Only button, 12
Keep Only option, 94

L
labels, entering in spreadsheet, 101
line item detail, 63
link views. See dynamic link views
local currency

changing, 52
Lock button, 13
logging

messages, 210

M
MDX queries, 71, 77
Member Name Only grid display option, 208
member names

displaying aliases for, 91
entering in spreadsheet, 101

member retention options in spreadsheets, 205
Member Selection button, 13
member selection differences, 85
members

taking offline, 194
members, selecting, 214
messages
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specifying type to display, 210
migrating

considerations, 219
converting a workbook, 220
converting multiple workbooks, 220
migration utility, 219

N
navigating the spreadsheet without retrieving data,

202
new versions ofSmart View, 29
Next Level zoom option, 204
No Access rows, suppressing, 202
No Data rows, suppressing, 202
non-calculating rows, inserting, 97
None indentation option, 202
numeric zeroes

as replacement labels, 206

O
offline. See Offline Planning
offline connection

creating, 194
offline data forms, 193

refreshing, 197
taking offline, 194
working with, 195

Offline Planning
creating an offline connection, 194
refreshing data in, 197
selecting members to take offline, 194
taking data forms offline, 194
working in, 193, 195

Options button, 14
Options dialog box

ad hoc options, 201
Ad Hoc tab, 201
cell styles options, 211
Cell Styles tab, 211
display options, 206
Display tab, 206

order precedence of cells styles, setting, 212
overriding the base currency, 52

P
Page dimension

searching for members in, 48
passwords, changing, 41
Paste Data Points button, 13
pasting cells in data forms, 49
percentage values, 49
Pivot button, 12
Pivot option, 93
Point of View

copying, 216
deleting, 217
editing, 213
preserving formulas after POV changes, 209
selecting members for, 214

POV Manager, 213
changing POV in Word or PowerPoint, 151

POV Manager button, 13
POV toolbar

dragging and dropping members, 71
printing POV in header and footer, 217
selecting members, 71

PowerPoint templates, 173
precedence, setting order in Cell Styles tab, 212
Preserve Formula on POV change option, 209
preserving in free-form

comments, 106
formats, 106
formulas, 106

Process Management grid display option, 207

Q
queries

creating, 71
creating from default reports, 72
editing, 74
extracting from existing reports, 73
filtering members, 74

Query Designer, 71
limitations, 71
refreshing queries, 77
time-related data, 76
worksheets, 71

Query Designer button, 13
query designer features, 21

R
Range (“B2”).Select, 245
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Redo
enabling in Smart View, 203, 204
using in Smart View, 204

Redo button, 12
Refresh All button, 12
Refresh button, 12
refreshing data

while working offline, 197
refreshing documents, 156
refreshing Reporting and Analysis documents, 156
Remove button, 14
Remove Only button, 12
Remove Only option, 94
repeated members, suppressing, 202
replacement labels, 206
replacing #NoData label, 206, 207
Reporting and Analysis documents

refreshing, 156
updating, 156

reports
asymmetric, 147
free-form, 101

resolving member names in free-form mode, 121
retaining members in spreadsheets, 205
retrieving

Hybrid Analysis data, 92
in free-form mode, 118
increasing speed, 148
into asymmetric reports, 147
performance impact, 148

Rules on Form button, 13
Rules on Form dialog box, 56
Run Reports button, 13
runtime prompts in business rules, 55

S
Scale grid display option, 207
searching

for members in the Page dimension, 48
Searching with Google, 14
security certificate for Workspace servers, 158
Select Form button, 13
selecting

folders and data forms to take offline, 194
members to take offline, 194

Shared Services, adding data source through, 37
shortcut menus, 14

shortcut menus in Connection Manager, 41
silent installation, 29
Smart Lists, working with, 69
smart tags

displaying POV description using, 187
recognizing deleted, 189
removing a single instance, 187
retrieving cell text using, 186
retrieving entity currency using, 186
retrieving functions, 191
retrieving single function value using, 185
stop recognizing, 188

Smart View
disabling, 27
enabling, 27

Smart View toolbar
displaying, 12
hiding, 12

specifying
latest time period, 87
UI colors, 208

specifying Dynamic Time Series members, 87
spreading data

over time periods, 58
overview, 58
with cell locking, 62

Spreadsheet Add-in for Essbase
using concurrently with Smart View, 28

static link views. See dynamic link views
Subitems indentation option, 202
Submit Data button, 12
Submit Data option, 52
submitting data in ad hoc grids, 98
Subset dialog box, 83
subtotaling values, 51
supporting detail

adding, 64
overview, 63
totaling when cells are blank, 65
working with the hierarchy, 66

Supporting Details button, 13
suppressing

#Missing rows, 202
invalid rows, 202
No Access rows, 202
No Data rows, 202
repeated members, 202
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types of data in spreadsheets, 201
underscore character, 202
zero value rows, 202

symmetric reports, 147
Sync Back button, 13

T
Take Offline button, 13
text

adding in data forms, 50
editing in data forms, 51
entering free-form, 101
viewing in data forms, 51

thousands separator in data forms, 48
time periods, spreading data over, 58
time-related data

free-form mode, 138
Query Designer, 76

toolbar
displaying, 12
hiding, 12

toolbar buttons
Add, 14
Adjust, 13
BI Edit, 13
Business Rules, 13
Cell Text, 13
Collapse, 13
Connection Manager, 12
Copy Data Points, 13
Expand, 13
Function Builder, 13
Instructions, 13
Keep Only, 12
Lock, 13
Member Selection, 13
Options, 14
Paste Data Points, 13
Pivot, 12
POV Manager, 13
Query Designer, 13
Redo, 12
Refresh, 12
Refresh All, 12
Remove, 14
Remove Only, 12
Rules on Forms, 13

Run Reports, 13
Select Form, 13
Submit Data, 12
Supporting Details, 13
Sync Back, 13
Take Offline, 13
Undo, 12
Visualize in Excel, 14
Visualize in HVE, 14
Zoom In, 12
Zoom Out, 12

Totals indentation option, 202
translating data in Ad Hoc grids, 97

U
UI colors

specifying, 208
underscore character, suppressing, 202
Undo

enabling in Smart View, 203, 204
using in Smart View, 204

Undo button, 12
uninstalling Smart View, 30
using Smart View and Essbase Spreadsheet Add-in

concurrently, 28

V
VBA functions, 223

HypCalculate, 233
HypCalculateContribution, 234
HypCell, 235
HypConnect, 236
HypConnected, 237
HypConnectionExists, 237
HypConsolidate, 238
HypConsolidateAll, 239
HypConsolidateAllWithData, 240
HypCreateConnection, 240
HypDeleteCalc, 242
HypDisconnect, 243
HypDisplayToLinkView, 244
HypExecuteCalcScript, 245
HypExecuteQuery, 246
HypFindMember, 247
HypForceCalculate, 248
HypForceCalculateContribution, 249
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HypForceTranslate, 249
HypFreeDataPoint, 250
HypGetAncestor, 251
HypGetChildren, 252
HypGetColCount, 253
HypGetColItems, 253
HypGetConnectionInfo, 254
HypGetDataPoint, 256
HypGetGlobalOption, 257
HypGetLinkMacro, 258
HypGetParent, 259
HypGetPOVCount, 260
HypGetPOVItems, 261
HypGetRowCount, 262
HypGetRowItems, 262
HypGetSheetOption, 263
HypGetSourceGrid, 265
HypGetSubstitutionVariable, 266
HypIsAttribute, 268
HypIsDescendant, 269
HypIsExpense, 270
HypIsParent, 271
HypIsUDA, 271
HypKeepOnly, 272
HypListCalcScripts, 273
HypMenuVCalculation, 306
HypMenuVConnect, 307
HypMenuVDisconnect, 307
HypMenuVKeepOnly, 308
HypMenuVOptions, 308
HypMenuVPivot, 309
HypMenuVRefresh, 310
HypMenuVRemoveOnly, 309
HypMenuVSubmitData, 310
HypMenuVZoomIn, 311
HypMenuVZoomOut, 311
HypOtlGetMemberInfo, 275
HypPivot, 277
HypPivotToGrid, 278
HypPivotToPOV, 279
HypQueryMembers, 279
HypRedo, 282
HypRemoveConnection, 282
HypRemoveOnly, 283
HypRetrieve, 284
HypRetrieveRange, 285
HypSetActiveConnection POV, 286

HypSetBackgroundPOV, 287
HypSetCellsDirty, 288
HypSetColItems, 289
HypSetConnectionInfo, 290
HypSetGlobalOption, 291
HypSetLinkMacro, 293
HypSetMenu, 294
HypSetPOV, 294
HypSetPOVItems, 295
HypSetRowItems, 296
HypSetSheetOption, 297
HypSetSubstitutionVariable, 299
HypTranslate, 301
HypUndo, 302
HypUseLinkMacro, 302
HypZoomIn, 303
HypZoomOut, 305

VBA functions, working with
calling functions, 225
creating a Visual Basic module, 223
declaring functions, 225
dynamic link views, 226
guidelines for declaring functions, 225
menu functions, 305
migrating legacy VBA applications, 223
parameters, 228
return values, 229
using functions in Smart View, 224

Visualize in Excel button, 14
Visualize in HVE button, 14

W
Within Selected Group option, 148
working with dynamic link views, 226

Z
Zero value rows, suppressing, 202
zeroes, numeric, 206
Zoom In button, 12
Zoom in option, 89
Zoom options, 204

All Levels, 204
Bottom Level, 204
Next Level, 204

Zoom Out button, 12
Zoom out option, 89
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