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Module 4: Spreadsheets

4.1 Using the Application
4.1.1 First Steps with Spreadsheets
4.1.1.1 Open (and close) a spreadsheet application.
4.1.1.2 Open one, several spreadsheets. 
4.1.1.3 Create a new spreadsheet (default template). 
4.1.1.4 Save a spreadsheet to a location on a drive.
4.1.1.5 Save a spreadsheet under another name.
4.1.1.6 Save a spreadsheet in another file type such as: text file, HTML, template, 

software specific file extension, version number.
4.1.1.7 Switch between worksheets, open spreadsheets. 
4.1.1.8 Use available Help functions.
4.1.1.9 Close a spreadsheet.  
4.1.2 Adjust Settings
4.1.2.1 Use magnification/zoom tools.
4.1.2.2 Display, hide built-in toolbars. 
4.1.2.3 Freeze, unfreeze row and/or column titles.
4.1.2.4 Modify basic options/preferences in the application: user name, default 

directory/folder to open, save spreadsheets.

4.2 Cells
4.2.1 Insert Data
4.2.1.1 Enter a number, date, text in a cell.
4.2.2 Select Cells
4.2.2.1 Select a cell, range of adjacent cells, range of non-adjacent cells, entire 

worksheet.
4.2.2.2 Select a row, range of adjacent rows, range of non-adjacent rows. 
4.2.2.3 Select a column, range of adjacent columns, range of non-adjacent columns.
4.2.3 Rows and Columns
4.2.3.1 Insert rows, columns in a worksheet. 
4.2.3.2 Delete rows, columns in a worksheet.
4.2.3.3 Modify column widths, row heights.
4.2.4       Edit Data
4.2.4.1 Insert additional cell content, replace existing cell content.
4.2.4.2 Use the undo, redo command.
4.2.5 Duplicate, Move, Delete
4.2.5.1 Duplicate the content of a cell, cell range within a worksheet, between 

worksheets, between open spreadsheets.
4.2.5.2 Use the autofill tool/copy handle tool to copy, increment data entries. 
4.2.5.3 Move the contents of a cell, cell range within a worksheet, between 

worksheets, between open spreadsheets.
4.2.5.4 Delete cell contents. 
4.2.6 Search and Replace
4.2.6.1 Use the search command for specific content in a worksheet.
4.2.6.2 Use the replace command for specific content in a worksheet. 
4.2.7 Sort Data
4.2.7.1 Sort a cell range by one criterion in ascending, descending numeric 

order, ascending, descending alphabetic order. 

4.3 Worksheets
4.3.1 Handling Worksheets
4.3.1.1 Insert a new worksheet.
4.3.1.2 Rename a worksheet.
4.3.1.3 Delete a worksheet.
4.3.1.4 Duplicate a worksheet within a spreadsheet, between open spreadsheets.
4.3.1.5 Move a worksheet within a spreadsheet, between open spreadsheets.
4.4 Formulas and Functions



4.4.1 Arithmetic Formulas
4.4.1.1 Generate formulas using cell references and arithmetic operators 

(addition, subtraction, 
multiplication, division). 

4.4.1.2 Recognize and understand standard error values associated with using 
formulas.

4.4.2 Cell Referencing
4.4.2.1 Understand and use relative, mixed, absolute cell referencing in formulas. 
4.4.3 Working with Functions
4.4.3.1 Generate formulas using sum, average, minimum, maximum, count, functions.
4.4.3.2 Generate formulas using the logical function if (yielding one of two specific 

values).

4.5 Formatting
4.5.1 Numbers/Dates
4.5.1.1 Format cells to display numbers to a specific number of decimal places, to 

display numbers with, without commas to indicate thousands.
4.5.1.2 Format cells to display a date style.
4.5.1.3 Format cells to display a currency symbol.
4.5.1.4 Format cells to display numbers as percentages.
4.5.2 Contents
4.5.2.1 Change cell content appearance: font sizes, font types.
4.5.2.2 Apply formatting to cell contents such as: bold, italic, underline, double 

underline.
4.5.2.3 Apply different colours to cell content, cell background.
4.5.2.4 Copy the formatting from a cell, cell range to another cell, cell range.
4.5.2.5 Apply text wrapping to contents within a cell.
4.5.3 Alignment, Border Effects
4.5.3.1 Align contents in a cell, cell range: left, centre, right, top, bottom.
4.5.3.2 Centre a title over a cell range.
4.5.3.3 Adjust cell content orientation.
4.5.3.4 Add border effects to a cell, cell range.

4.6 Charts/Graphs
4.6.1 Using Charts/Graphs
4.6.1.1 Create different types of charts/graphs from spreadsheet data: column 

chart, bar chart, line chart, pie chart.
4.6.1.2 Add a title, label to the chart/graph. Remove a title, label from the chart/

graph.
4.6.1.3 Change the background colour in a chart/graph.
4.6.1.4 Change the column, bar, line, pie slice colours in the chart/graph.
4.6.1.5 Change the chart/graph type. 
4.6.1.6 Duplicate, move charts/graphs within a worksheet, between open 

spreadsheets.
4.6.1.7 Resize, delete charts/graphs.

4.7 Prepare Outputs
4.7.1 Worksheet Setup
4.7.1.1 Change worksheet margins: top, bottom, left, right.
4.7.1.2 Change worksheet orientation: portrait, landscape. Change paper size 
4.7.1.3 Adjust page setup to fit worksheet contents on one page, on a specific 

number of pages.
4.7.1.4 Add, modify text in Headers, Footers in a worksheet.
4.7.1.5 Insert fields: page numbering information, date, time, file name, worksheet name 

into Headers, Footers.
4.7.2 Preparation
4.7.2.1 Understand the importance of checking spreadsheet calculations and text 

before distribution.
4.7.2.2 Preview a worksheet.
4.7.2.3 Turn on, off display of gridlines, display of row and column headings for 



printing purposes.
4.7.2.4 Apply automatic title row(s) printing on every page of a printed worksheet. 
4.7.3 Printing
4.7.3.1 Print a cell range from a worksheet, an entire worksheet, number of copies 

of a worksheet, the entire spreadsheet, a selected chart.
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4.1 OpenOffice.org Calc: Using the Application
_______________________________________________________________________________________________

4.1.1 First stages with spreadsheets

4.1.1.1 Open and close a spreadsheet application

Open Calc in Linux

• Click on Start Applications
• Click Office
• Click Spreadsheets
• Click OpenOffice.org Calc

Open Calc in Windows

• Click on Start
• Click Programs
• Click OpenOffice.org
• Click Spreadsheet

This will load Calc.

Close Calc

• Click on File then click Exit.
OR

• Click on the Exit icon in the top right hand corner of the screen, 

_____________________________________________________________________________
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4.1 OpenOffice.org Calc: Using the Application
_______________________________________________________________________________________________

Components of the Calc screen

Menu Bar

The  menu  bar  displays  global  commands.  These  commands  that  are  grouped  according  to 
categories.

For example, the File menu item consists of a set of commands related to file operations such as 
open existing files, creating new files, saving files, closing files and so on.

Format toolbar

The object bar contains commands that are used to format cells.

Standard toolbar

The standard toolbar contains shortcuts to commonly used Calc operations.

Formula toolbar

The formula toolbar contains the address of the current cell. It is also used as the entry point for 
text, numbers and formulas that will be entered into the cells.

Work Area

The work area of the spreadsheet consists of  a grid formed by the intersection of rows and 
columns. The columns are named by letters of the alphabet A, B, C, ..... Z, AA, AB, AC, ..... The 
rows are numbered 1,2,3,4, .....

Each cell is identified by its row and column. For example, the cell C11 is the cell lying at the 
intersection of column C and row 11.

C11 is also referred to as the address of the cell..

_____________________________________________________________________________
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4.1 OpenOffice.org Calc: Using the Application
_______________________________________________________________________________________________

Tabs

Each spreadsheet consists of one or more worksheets. These can be accessed by clicking on the 
tabs at the bottom of the work area.

4.1.1.2 Open one, several spreadsheets

A spreadsheet consists of text, values and formulas inserted into the cells  of the work area. 
Spreadsheets are saved on disk as files, just as in the case of Writer documents.

More than one spreadsheet can be opened at a time.

Open a spreadsheet under Linux

• Click on File.
• Click on Open.

This brings up the Open Dialogue window:

The dialogue lists a series of directories and files.

To view the contents of a directory, click on the directory. 

To move up a level, click on the Up one level icon, .
Suppose you have located the directory in which the desired file is located.

• Highlight the file.

_____________________________________________________________________________
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4.1 OpenOffice.org Calc: Using the Application
_______________________________________________________________________________________________

• Click Open.

Open a spreadsheet under Windows

The process of opening files under Windows is essentially the same.

The essential difference between Windows and Linux is that in Linux all computers, disks and 
directories are all part of a large tree. In the case of Windows, each drive forms the root of a 
separate root structure.

The current directory is the Open dialogue above is shown as /home/david. The direction of the 
separators and the absence of a drive indicate that this is a Linux directory.

If you were opening a file in Windows, the Windows Open dialogue would appear:

Note that spreadsheets can have a number of 
different extensions. The main ones are:

ods: This is the default used in OpenOffice.org 
version 2. It is an abbreviation for Open 
Document Spreadsheet.

sxc: This is the default extension of 
spreadsheets in version 1 of OpenOffice.org

xls: This is the extensions that Microsoft Excel 
assigns to spreadsheets.

All can be opened in Calc.

Open several spreadsheets

If you now repeat this process without closing the first spreadsheet all of them will be loaded and 
you may switch between them. The process of doing this will be described shortly.

_____________________________________________________________________________
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4.1 OpenOffice.org Calc: Using the Application
_______________________________________________________________________________________________

An alternative is to open several spreadsheets at once.

• Click on File then Open.
• Locate the directory containing the files you wish to open.
• Click on the first file.
• Hold down the CTRL key and click on each of the additional files you wish to open.
• Click Open.

The last of the files loaded will appear in the window. This will be the active spreadsheet. The 
others are also loaded but are in the background.

You can make one of the other spreadsheets active as follows:

• Click on Window.

This will list the spreadsheets that are loaded.

• Click on the spreadsheet you wish to make active.

4.1.1.3 Create a new spreadsheet (default template)

Suppose you wish to create a spreadsheet from scratch.

• Click on File then click on New then Spreadsheet.
In future a sequence of commands like this will be denoted by:
File » New » Spreadsheet.

You can do this whether other spreadsheets are loaded or not.

_____________________________________________________________________________
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4.1 OpenOffice.org Calc: Using the Application
_______________________________________________________________________________________________

This will display a blank spreadsheet.

You will  learn how to enter data later. At this stage we are concerned with the mechanics of 
opening and saving spreadsheets.

4.1.1.4 Save a spreadsheet to a location on a drive in Linux

For the time being imagine that the spreadsheet you have opened contains data. At this stage 
your work is located in the RAM of the computer. Since RAM is volatile, the contents will be lost is 
the computer is switched off. 

In order to preserve your spreadsheet for later use it must be saved on the hard drive of the 
computer.

To do so:

• File » Save as ...

This will bring up the Save as dialogue.

• Locate the directory in which you wish to save the file.
• Enter the name of the file name window.

• Click Save.

Saving to a floppy disk in Linux

If you wished to save a file to a floppy disk, you would use the directory /mnt/floppy.

Saving a file in Windows

If you are working with Calc running under Windows, the Windows Save as ... dialogue would 
appear when you save the file.

• Select the drive on which you wish to save the file.
• Select the directory on the drive and, if appropriate, the relevant sub-directory.
• Enter the name for the file in the File name window.

_____________________________________________________________________________
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4.1 OpenOffice.org Calc: Using the Application
_______________________________________________________________________________________________

• Click Save.

Saving files to floppy disk in Windows

• Select  Floppy (A:) in the Save as ... dialogue.
• Use the same procedure for saving on the hard disk.

4.1.1.5 Save a spreadsheet under another name

Sometimes we may want  to have the same spreadsheet saved under a number  of  different 
names. Alternatively, we may want to save a spreadsheet before making changes. We would 
then have a copy of the new version as well as the version before changes were made.

Suppose  we  have  a  spreadsheet  loaded  as  shown  on  the  next  screen.  In  this  case  the 
spreadsheet already has the name AfricaDemog.ods.

We can now save what is displayed on the screen in two ways.

_____________________________________________________________________________
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4.1 OpenOffice.org Calc: Using the Application
_______________________________________________________________________________________________

Overwrite existing file

After loading the spreadsheet from disk, we may have made some changes. In this case, the 
changes will not automatically be made to the file that is located on the hard disk.

To replace the version on hard disk with the contents as displayed on the screen:

• File, » Save.

This updates the file on disk.

Save under another name

Suppose we do not wish to overwrite the contents on disk but would still like to save what is on 
the screen:

• File » Save as ...

This will bring up the Save as  dialogue. You use this in exactly the same way as you would if 
you were saving a completely new file.

4.1.1.6 Save a spreadsheet in another file type such as: text file, HTML, 
template, software specific file extension, version number

A spreadsheet is a tool for doing calculations. Consequently, the format of the spreadsheet is 
structured around this aspect.

Sometimes  it  is  useful  to  convert  the  spreadsheet  format  into  another  format  such  as,  for 
example, a text file which can be manipulated using a word processor.

Alternatively, you may wish to save the spreadsheet in a format use by another spreadsheet 
program such as Microsoft Excel. 

To save a spreadsheet in a different format:

• File » Save as ...
• Click on the File Type window. 

This will display a list of file types.

• Use the vertical scroll bar to view all the file 
formats.

_____________________________________________________________________________
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4.1 OpenOffice.org Calc: Using the Application
_______________________________________________________________________________________________

The following table list some of the main file formats and a brief explanation of each.

File type Extension Explanation

OpenOffice.org 
Spreadsheet

ods This is the new format found in OpenOffice.org Version 2

OpenOffice.org 
Spreadsheet

sxc This is the format of Calc in OpenOffice.org Version 1.

OpenOffice.org 
Spreadsheet template

ots A template is an outline for new templates. This may include text, 
values and formulas that are automatically inserted when a new 
template  is  created  using  the  template.  It  could  also  include 
formatting of cells such as font type and colour.

OpenOffice.org 
Spreadsheet template

stc Version 1 templates have this extension.

dBase dbf This  would  save  the  spreadsheet  in  a  format  used  by  some 
database programs. These databases would then be able to access 
the data in the spreadsheet  and work with it  as if it  had been 
created by a database.

Microsoft Excel xls Although Microsoft Excel is also a spreadsheet, it uses a different 
format. By saving the spreadsheet in the xls format, it could be 
opened directly by Microsoft Excel.

Web pages html In order to read files, web browsers need them to be saved in a 
special  format known as HTML or  HyperText  Markup Language. 
Calc is able to save a spreadsheet in this format.

Text CSV csv This format is what is also called a comma delimited file. In this 
format, each row is converted into a paragraph. The columns of 
the spreadsheet are separated by commas. A word processor will 
read this file as an ordinary text file.

Data Interchange Format dif A DIF file is an industry standard for exchanging data between 
different types of application.

Portable  Document 
Format

pdf Pdf files are a common way of sending documents that you do not 
wish the receiver to be able to edit. These files can be read with 
Acrobat  Reader.  Unlike  the  previous  formats  which are  created 
using  the  Save  as  ...  function,  pdf  files  are  created  using  the 
Export as pdf ... option in the File menu.

4.1.1.7 Switch between worksheets, open spreadsheets

Switching between open spreadsheets was covered in section 4.1.1.2 above.

To understand the difference between a spreadsheet and a worksheet, think of a spreadsheet as 
a book. The worksheets correspond to the pages of a book. However, in the case of spreadsheets, 
many of them comprise a single page or worksheet.

The spreadsheet shown in the following screen is made up of three worksheets. Each of these has 
a name indicated on the tabs at the bottom of the work area.

• To switch between the different worksheets, you would click on the tab.

_____________________________________________________________________________
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4.1 OpenOffice.org Calc: Using the Application
_______________________________________________________________________________________________

4.1.1.8 Use available Help functions

Calc provides a range of help features. The most useful of these is Find.

To access help:

• Click Help » OpenOffice.org Help or press F1.

• Click on the Contents tab.
• Double click on the book icon next to Help about OpenOffice.org Calc.

This  lists  the  main  headings  in  help  for  Calc.  Sections  with  a  book  icon  contain  further 
subdivisions.

• Double click on Shortcut Keys in OpenOffice.org.

_____________________________________________________________________________
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4.1 OpenOffice.org Calc: Using the Application
_______________________________________________________________________________________________

• Click on the Index tab.

• If you type some text such as sum into the Search item window, the index will automatically 
scroll down to index items beginning with the word sum.

• If you were to double click on an item in the left hand pane or click the Display button, help 
would be displayed in the right hand pane.

Calc also provides a comprehensive search facility.

• Click on the Find tab.
• Type a key work or part of a key word into the Search item window, for example, sum.
• Click the Display button.

A list of items in the index that make reference to the word sum.

Once again you could highlight the item you wish to read and click the Display button.

Note the two check boxes that appear under the Search item window.

_____________________________________________________________________________
Page 4.17
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The Bookmarks tab takes you to a section which allows you to create references to specific help 
items  that  you  might  wish  to  refer  to  at  a  later  time.  These  named  references  are  called 
bookmarks.

4.1.1.9 Close a spreadsheet

• Click on File.

There are two menu items that need to be distinguished.

Close closes the current spreadsheet, but leaves Calc open. If version 
of the spreadsheet on the screen differs from that saved on disk, Calc 
will ask you if you wish to save before closing the spreadsheet.

Exit closes all open spreadsheets as well as the Calc program itself. 
Once again, if any spreadsheets are open, Calc will ask you if you wish 
to save them before closing.

It is important that you adopt good habits and close Calc before you 
start shutting down the system.

_____________________________________________________________________________
Page 4.18



4.1 OpenOffice.org Calc: Using the Application
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4.1.2 Adjust settings

4.1.2.1 Use magnification / zoom tools

Often when working with spreadsheets it is convenient to enlarge or reduce the spreadsheet in 
the work area.

Suppose the spreadsheet AfricaDemog.ods is loaded.

To change the scale of the spreadsheet:

• Click View » Zoom.

This displays the Zoom dialogue.

• Click the appropriate radio button to scale the spreadsheet.

Values less than 100% will reduce the spreadsheet, while values greater than 100% will enlarge 
it.

• Click 150% then OK.

• Experiment with the other values in the Zoom dialogue.

_____________________________________________________________________________
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4.1 OpenOffice.org Calc: Using the Application
_______________________________________________________________________________________________

A useful zoom is  Page width. This displays the width of the printed page on the screen. The 
degree of enlargement or reduction depends on whether the page setup is portrait or landscape. 
To see the difference follow the instructions below.

Page width in portrait

• Format » Page.
• Click the Page tab, then under Orientation click the Portrait radio button.
• View » Zoom.
• Click the Page width radio button, then click OK.

Page width in landscape

• Format » Page.
• Click the Page tab, then under Orientation click the Landscape radio button.
• View » Zoom.
• Click the Page width radio button, then click OK.

4.1.2.2 Display, hide built-in toolbars

Calc has a number of standard toolbars. Which 
of these are displayed depends on how your 
system was set up. You can decide which 
toolbars you wish to have displayed.

• View » Toolbars.

Toolbars which are displayed have a tick next to 
them. Hidden toolbars are unmarked.

Clicking on a displayed toolbar reverses its 
status and makes it hidden.

Likewise, clicking on a hidden toolbar causes it 
to be displayed.

An operation such as this is called a toggle. A 
toggle is a switch which reverses the status. If it 
is on, the toggle switches it off. If it is off, the 
toggle switches it on.

A related function is Full screen.

• View » Full screen.

This hides all the toolbars and the ruler. 
To restore the toolbars:

• Click the Full Screen icon in the top left hand corner. 

_____________________________________________________________________________
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4.1.2.3 Freeze, unfreeze row and / or column titles

Certain rows and columns are often used as headings. If you scroll down or to the right, these 
headings will scroll off the screen. To keep headings on the screen will data scrolls off the screen, 
we can freeze the rows or columns containing our headings.

Consider the spreadsheet shown on the next screen.

 Notice the column headings in row 3 and the row headings in column A.

If we were to scroll down and across these headings would disappear off the screen.

_____________________________________________________________________________
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We can freeze the headings as follows:

• Position  the cursor  in  the cell  immediately  below the column heading  and in  the column 
immediately to the right of the row headings. In this case it is cell B4.

• Window » Freeze.

If we were to scroll down and across, the headings would remain on the screen as shown below.

In this case both rows and columns are frozen.

If you wish to freeze only rows, position the cursor in column A, then Windows » Freeze.

If you wish to freeze only columns, position the cursor in row 1, then Windows » Freeze.

4.1.2.4 Modify basic options / preferences in the application: user name, 
default directory / folder to open, save spreadsheets

User name and data

The default user data can be set as follows:

• Tools » Options.
• Expand OpenOffice.org by clicking on the +  symbol.
• Click on User Data.

_____________________________________________________________________________
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• Fill in the user data and click OK.

Note that this user information will be used for all the applications in the OpenOffice.org suite.

Default directory

When opening or saving files, Calc will by default look in a certain directory. This can be set as 
follows:

• Tools » Options.
• Expand OpenOffice.org by clicking on the +  symbol.
• Click on Paths.
• Double click on My Documents.

• Locate the desired path using the Select path dialogue.
• Click Select.

Default spreadsheet type

The default, Calc saves spreadsheets in Calc format. This will have an ods extension. You may 
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have to share your work with users who use other spreadsheet programs. In this case you could 
change the default format to that of another product, for example, Microsoft Excel.

• Tools » Options.
• Expand Load/save.
• Click on General.
• Under Document type, select Spreadsheets.
• Under Always save as select the format you wish to use.

• Click OK.

Other settings

• Click on Tools » Options.
• Expand OpenOffice.org Calc.

A number of other important settings can be set in the different sections. For example:

General Use to set measurement units and tab stops.
View Use to change the colour of gridlines; whether formulas or values are shown.

• Scroll through the different options to get a feel of the range of settings.
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4.2 OpenOffice.org Calc: Cells

4.2.1Insert data

Data types

Data entered into cells can be of three types: numeric, text or date.

If a set of pure digits (0,1,2,3,4,5,6,7,8,9) are typed in a cell, Calc will normally treat the data as 
numeric. In this case arithmetic operations can be performed on the numbers.

If the ' symbol is typed in front of a set of digits, then Calc will treat the number as if it were 
ordinary text. In this case you will  not be able to do arithmetic. You will  however be able to 
format the numbers in the way you do text.

If you enter numbers in the format that Calc would recognise as a date, Calc will treat these as a 
date and reformat the contents of the cell in the default date format. For example, 20 Sept 2003, 
20 September 2003 and 20-09-2003 will all be interpreted by Calc as dates. If the default date 
format is Short date, then Calc will reformat these as 20/09/03 in all cases. If you wish these 
not to be interpreted as dates, precede the entry with the ' symbol. 

If the contents of a cell are interpreted as data, then certain types of date arithmetic can be 
performed. For example, two dates can be subtracted to yield the number of days between the 
dates. If a number is added to a date, this is interpreted as a number of days and the result will 
be another date.

Entering data

Data can be entered into the current cell. As you type, numbers and text will be entered into a 
cell. At the same time these appear on the Input line of the Formula bar.

When you have completed your data entry, press  Enter to move to the cell below or  Tab to 
move to the cell to the right.

You may also use the direction arrows to move to an adjacent cell.

Changing the direction of Enter

By default, when you press Enter, the cursor moves to the next cell down. This can be changed 
using:
Tools >> Options >> OpenOffice.org >> General

Note on notation

To simplify the text in future, where there is no possibility of ambiguity, the notation:

• Tools  » Options  » OpenOffice.org  » General

will be used instead of the longer form:

• Click on Tools, then Options.
• Expand the OpenOffice.org  option by clicking on the + symbol

• Click on General
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• Check Press Enter to move selection.
• Select the appropriate option in the drop down window as shown on the screen above.

4.2.2 Select cells

4.2.2.1 Select a cell, range of adjacent cells, range of non-adjacent 
cells, entire worksheet

When  a  cell  or  group  of  cells  is  selected,  actions  can  be  performed on  these  cells.  These 
operations include deleting the cells, copying them to the clipboard, changing their font and so 
on.

Select a single cell

• To select a single cell, simply click of the cell.

Select a range of adjacent cells

• Click on the first cell of the range.
• Hold down the left mouse button and drag the cursor to the last cell of the range
OR
• Hold down the Shift key and use the direction arrows to move to the last cell of the range.
OR
• Hold down the Shift key and click on the last cell of the range.

The selected cells will be highlighted on the worksheet.
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Select a range of non-adjacent cells

• Hold down Shift and click on the first cell.
• Release the Shift key.
• Hold down the Ctrl key and click on each of the cells you wish to select.

The following screen shows the selection of a number of non-adjacent cells.

Select an entire worksheet

• Edit » Select All (Click on Edit, then click on Select All – see Note on notation above)
OR
• Hold down Ctrl and press A.

4.2.2.2 Select a row, range of adjacent rows, range of non-adjacent rows

Select an entire row

• Click on the row number.

Select a range of adjacent rows

• Click on the row number of the first of the rows.
• Hold down the Shift key and click on the row number of the final row.
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Select a range of non-adjacent rows

• Click the row number of the first row you wish to select.
• Hold down the Ctrl key and click on the row numbers of the other rows you wish to select.

4.2.2.3 Select a column, range of adjacent columns, range of non-adjacent 
columns

Select an entire column

• Click on the column letter.

Select a range of adjacent columns

• Click on the column letter of the first of the columns.
• Hold down the Shift key and click on the column letter of the final column.

Select a range of non-adjacent columns

• Click the column letter of the first column you wish to select.
• Hold down the  Ctrl key and click on the column letters of the other columns you wish to 

select.

The following screen illustrates a number of non-adjacent columns selected.
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4.2.3 Rows and columns

4.2.3.1 Insert rows, columns in a worksheet

Insert a single row 

Suppose we have the file AfricaDemog.ods displayed:

We now wish to insert a row after % Urban with the row heading % High school education.

• Position the cursor anywhere in row 8.
• Insert » Rows.

Note when you execute this command, the new row is inserted before the current row. Row 8 is 
now a blank row.
• Click on A8 and type the text % High school education.

Insert several rows

Suppose you wished to insert three rows after % Urban.

• Select rows 8 to 10. 
• Insert » Rows

This will insert three new rows 8 to 10. The previous rows 8 to 10 will be shifted down.
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Insert one or more columns

The process of inserting one or more columns is done in a similar way:

• Select the columns.
• Insert  » Columns

Existing columns will be shifted to the right.

4.2.3.2 Delete rows, columns in a worksheet

• Select the rows or columns to be delete. These may be adjacent or not.
• Edit  » Delete cells

This will bring up the Delete cells dialogue.

• Click on the Delete entire row(s) or Delete entire column(s) radio button as appropriate.
• Click OK.

4.2.3.3 Modify column widths, row heights

Resize column widths using the mouse

• Position the cursor on the right hand border on the column letter box.
• Hold down the left hand mouse button and drag the border to the left or right.

As you do the width of the column will be displayed.

Important: You can only use the right hand border for adjusting the column width.

Resize rows heights using the mouse

• Position the cursor on the lower border of the row number.
• Hold down the left hand mouse button and drag the border down or up.
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Important: You must use the lower border of the cell. If you drag the upper border of a cell, you 
will change the row height of the cell above. For example, instead of making the lower cell wider, 
you will make the upper cell narrower.

Resize one or more columns using Format

• Select  the column(s)  whose width  you wish  to change (or press  Ctrl+A to select  all  the 
columns).

• Format » Column » Width

This brings up the Format column width dialogue.

• Enter a value in the Width window and click OK.
OR
• Check the Default value check box to select the default column width and click OK.

Resize one or more rows using Format

• Select the row(s) whose height you wish to change (or press Ctrl+A for all the rows).
• Format » Row » Height. This brings up the Format row height dialogue.

• Check the Default value check box to select the default row height and click OK.
OR
• Enter a height into the Height window and click OK.
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4.2.4 Edit data

4.2.4.1 Insert additional cell content, replace existing cell content

Edit existing content of a cell

Suppose we click on a cell, for example A8 in the following screen. The contents of cell A8 are 
also display in  the  Input line of the  Formula bar.  If you wish to add text to the existing 
contents of the cell:

• Click at the end of the text in the Input line.

• Press Enter, Tab or an arrow key when you are done.

Alternatively, you could edit the contents of the Input line as you would any text. You can insert 
text or delete text.

Replace content of a cell

• Click on the cell whose content you wish to replace.
• Type your new content. 

When you do this, the existing content of the cell will  automatically be replaced by your new 
entry.

Note: The difference between the method for editing existing content and replacing existing 
content is that to edit the content you click on the input line whereas to replace you do not.

4.2.4.2 Use the undo, redo command

Suppose you delete a line of text, then immediately realise you have made a mistake. The undo 
command allows you to go back a step to the point before the previous command. To use this 
command:

• Edit » Undo
OR
• Press Ctrl+Z.

In fact the undo command has a history. If you repeat the command it will undo the second last 
command. If you repeat it once more it will undo the third last command, and so on.
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The redo command reverses the effect of the last undo. To use this command:

• Edit » Redo.

Suppose you had used the undo command three times. In effect you would have undone your 
previous three command. If you now use the redo, it will re-instate these actions.

The best way of understanding how undo and redo work is to practice using them. 

4.2.5 Duplicate, Move, Delete

4.2.5.1 Duplicate  the  content  of  a  cell,  cell  range  within  a  worksheet, 
between worksheets, between spreadsheets

The process of duplicating data involves a number of simple steps:

• Select the cells to be duplicated.
• Copy them to the clipboard. Usually we refer to this simply as copy.
• Select the target (where the cells are to be copied to).
• Paste the data from the clipboard.

Warning: When you paste data, the contents of the target cells will be overwritten.

Duplicate within a worksheet

Suppose you have the following spreadsheet displayed on your screen.

Suppose you now wish to insert another set of headings above Group 11.

• Insert a blank row at row 14.
• Select cells B3 to K3. (We represent a range of cells such as this with the notation B3:K3)
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• Copy the selected cells using one of the following methods:
Press Ctrl+C.
Edit » Copy

Click the Copy icon, 
• Position the cursor at the start of the target range. (It is not necessary to highlight the entire 

range.)
• Paste the copied cells using one of the following methods:

Press Ctrl+V.
Edit » Paste.

Click the Paste icon, 

Duplicate between worksheets 

When you create a new spreadsheet, Calc creates three worksheets by default. You can think of 
each worksheet as a page of the spreadsheet.  Pages can be added to or removed from the 
spreadsheet very simply.  You can move between the worksheets of  an open spreadsheet by 
clicking on the appropriate tab at the bottom of the work area.

Suppose you wish to copy cells A3:K5 from Sheet 1 to B7 on Sheet 3.

• Select cells A3:K5
• Edit » Copy.
• Click on the Sheet 3 tab.

Select cell B7.
• Edit » Paste.
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Duplicate between open spreadsheets

It  is  possible  to  have several  spreadsheets  open at  the same time.  The difference between 
spreadsheets and worksheets is that the spreadsheets are stored in different files, whereas the 
worksheets of a particular spreadsheet are all stored in the same file.

You can switch between spreadsheet using the Window menu item.

Suppose you have two spreadsheets open. The first is called ObservationsByGroupSector and the 
other is  called  Obs2. You now wish  to copy the cells  A3:K10 from the first  into  the second 
starting at B5.

• Click on Window.
• Click on ObservationsByGroupSector.sxc

This will display this spreadsheet.
• Select cells A3:K10.
• Edit » Copy.
• Window » Obs2.
• Select cell B5.
• Edit » Paste.

4.2.5.2 Use autofill tool/copy to copy, increment data entries

• Open a new spreadsheet.
• Type 1 in A1 and 2 in A2.
• Select A1 and A2.

A fill handle will appear at the bottom right hand corner of A2.

• Drag the highlight across the adjacent cells.
• Deselect the cells by clicking elsewhere in the spreadsheet.

Calc will attempt to complete the series based on the values in the first two cells as shown on the 
next screen.

• Now type 100 in B1 and 101 in B2
• Drag the fill handle across the adjacent cells.

Calc assumes you wish to insert a series of numbers will a common difference between the cells.

• Type 5 in C1 and 8 in C2.
• Drag the fill handle across the adjacent series.
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In this case the difference between the first two cells is 3. Calc assumes each cell must have a 
value 3 greater than the previous cell.

• Type Jan into D1 and Feb into D2.
• Drag the fill handle across adjacent cells.

Calc now assumes you wish the series to be the names of months.

• Type January into E1 and February into E2.
• Drag the fill handle across adjacent cells.

At this point your screen will appear as follows:

You can create your own sort lists as follows:

• Tools » Options » OpenOffice.org Calc » Sort lists
• Click the New button.
• Type the entries into the Entries window as shown on the next screen. You will need to press 

Enter after each entry.

Click Add when complete.
• Type Alpha in A6 and Beta in B6.
• Drag the fill handle across adjacent cells.
•
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You can use this method to create your own sort lists.

4.2.5.3 Move the content of a cell, cell range 
Within a worksheet, between worksheets, between spreadsheets

The procedure for moving the content of cell(s) is exactly the same as that for duplicating the 
content of cell(s) except that you use the Cut function instead of the copy function.

• Select the cell(s) whose content is to be moved
• Cut the selected cells using one of the following methods:

Press Ctrl+X.
Edit » Cut

Click the Cut  icon, 

• Position the cursor at the start of the target range. (It is not necessary to highlight the entire 
range.)

Note that the target may be in the same worksheet, or a different worksheet within the same 
spreadsheet or within a different spreadsheet.

• Paste the copied cells using one of the following methods:
Press Ctrl+V.
Edit » Paste.

Click the Paste icon, 
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4.2.5.4 Delete cell contents

Use the Delete key

• Open a spreadsheet.
• Select a range of cells.
• Press the Delete key.
• The Delete dialogue will be displayed.
• Select an option and press OK.

The effect is as shown on the following screen. 
As this screen shows the contents of the cell are 
emptied. No cells are moved in the process.

Use Edit » Delete Cells

• Highlight a range of cells.
• Edit » Delete cells.

You are now offered a range of options:
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The operation of Edit » Delete cells is quite different to the action of the Delete key. You are 
offered a number of options as shown on the previous screen. All of these will involve movement 
of cells to the right and / or below the highlighted cells.

• Click the Shift cells up radio button and click OK.

Notice that the cells in D15:J19 have been moved up to D10:J14 as shown on the next screen.

4.2.6 Search and Replace

4.2.6.1 Use the search command for specific content in a worksheet

In practical situations spreadsheets are often quite large and we need quick methods of locating 
items.

Suppose you have a spreadsheet loaded as shown on the next screen and you wish to locate an 
item.

• Edit » Find and replace.

• Type the item in the Search for window.
• Click Find all to highlight all occurrences of the item.
OR
• Click Find. 
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• This will select the first occurrence of the item.
• Click Find repeatedly to locate further occurrences.

4.2.6.2 Use the replace command for specific content in a worksheet

The Find command simply locates occurrences of an item. It does not change these in any way. 
You may do so manually, if you wish.

The Replace command on the other hand is useful when we wish to change entries.

The Replace command provides us with two methods of replacement.

Replace all replaces all occurrences of the item with the new entry without further prompting.

Replace gives you the option of changing each occurrence or not.

• Edit » Find and replace
• Type appropriate entries in the Search for window and the Replace with  window.

Global replacement

• Click Replace all.

In  this  case  all  occurrences  of  Andiswa will  be  replaced  by  Andisa without  any  further 
prompting.

Selective replacement

• Click Find to locate the first occurrence.
• Click Replace if you wish to replace this item or click Find to locate the next occurrence.
• Repeat this process until you have cycled through all the occurrences.
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Important Find and replace options

• Click the More Options button.

This  will  display  the  full  set  of  options  which  can  be 
selected by checking the appropriate check box.

Backwards: By default, the Find procedure moves to the 
right and down the spreadsheet, ie forwards. If you wish 
to move backwards, check this option.

Match case: By default, the Find procedure ignores the 
case of text. This is called case insensitive. Where you 
wish to match the case of text, check this box. The 
Search is then said to be case sensitive.

Entire cells: By default, the Find procedure looks 
anywhere in the cell for the search data.  This option 
matches the criterion to the cell as a whole, not any part.

4.2.7 Sort Data

4.2.7.1 Sort a cell range by one criterion in ascending, descending 
numeric order, ascending, descending alphabetic order

Sorting a range of cells is a straight forward process involving the following steps:

• Highlight the range of cells to be sorted.
• Data » Sort.
• Set the criteria in the Sort dialogue.
• Click OK.

Important: Select the entire block to be sorted. If columns are omitted, the resulting data could 
become a meaningless jumble.

Numeric sorts

Suppose we have the following spreadsheet displayed on our screen. We wish to sort the groups 
in the order of the scores in Sector 1. Here we wish to sort according to values, hence this is a 
numeric sort.
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In this case, the data is located in the range A4:N30. We call each row between columns A and 
F a record and each column a field. The rows will be sorted according to the values in Column 
B in Ascending order (the smallest first).

• Highlight the range A4:N30.

If we omitted any rows, the records would not be sorted. If we omitted any columns, the 
values in the omitted fields would be associated with the wrong records.

• Data » Sort.

In the Sort by window select Column B. This is the column that contains the values that we 
wish to sort according to.
• Check the adjacent Ascending radio button.
• Click OK.



If you wished to sort the data by points in descending order, that is with the highest number 
first, you would have checked the Descending radio button.

Alphabetic sorts

Suppose we had wished to sort the data in the previous example in alphabetic order of Group 
you would proceed as follows:

• Highlight A4:N30
• Data » Sort.
• Select Column A in the Sort by window. This is the column containing the name field.
• Check the Ascending radio button. 

This will sort the records into Group order.

If you wished to sort with the names sorted in reverse order from Z to A, you would check the 
Descending radio button.
• Click OK.

Multiple sort criteria

If you look at the results of the previous sort, yo will notice that both Group 3 and Group 22 
had values of 32 in Sector A. A similar duplication of results occurs in Groups 16 and 20 with a 
score of 76 and groups 2 and 21 with scores of 98. Suppose we wish to sort these records 
based on the scores in Sector B. We then need to make use of multiple sort criteria.
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If you are only sorting on a single criterion, then the two Then by windows indicated undefined. 
In the above dialogue, the Then by drop down window indicates Column C.

As the above screen shows, Calc can sort on up to three criteria. These do not have to be in any 
column sequence.
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4.3.1 Handling worksheets

4.3.1.1 Insert a new worksheet

A spreadsheet consists of one or more worksheets. The worksheets can be thought of as pages of 
the spreadsheets. By default,  a spreadsheet consists of three worksheets. These are labelled 
Sheet1  to Sheet3.

New worksheets can be added to a spreadsheet.

• Insert » Sheet ...

This displays the Insert worksheet dialogue.

• Choose the Position, before or after the current sheet.
• Choose the No of sheets you wish to insert.
• If you choose to insert only one sheet, you may (optionally) enter the name of the sheet in the 

Name window.
• Click OK.

4.3.1.2 Rename a sheet

The default names of worksheets are Sheet1, Sheet2, and so on. You may change the name of a 
worksheet as follows:

• Right click on the tab of the worksheet that you wish to rename.
• Select Rename in the contextual menu that appears.
• Enter the new name in the dialogue.
• Click OK.
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4.3.1.3 Delete a worksheet

• Right click on the tab of the worksheet you wish to delete.
• Select Delete in the contextual menu that appears.

A dialogue will appear asking you to confirm that you wish to permanently delete the worksheet 
and its contents.

• Click Yes to confirm that you wish to delete the worksheet or Cancel if you do not wish to.

4.3.1.4 Duplicate a worksheet within a spreadsheet, between spreadsheets

There are two methods of duplicating a copy of a worksheet. One method is to copy the entire 
contents of a worksheet to the clipboard and then pasting this into another existing worksheet. In 
this section you will make a duplicate of the worksheet in a new worksheet.

Duplicate a worksheet within a spreadsheet

• Right  click  on  the  name tab  of  the  worksheet  you wish  to  duplicate.  This  will  display  a 
contextual menu.

• Select Copy/Move worksheet .....

• Tick  the Copy checkbox as shown above.
• Select the position for the duplicate in the Insert before window.
• Click OK.
• Rename the duplicate worksheet if you wish.

Duplicate a worksheet between spreadsheets

You may insert a copy of a worksheet in another open spreadsheet or into a new document.

• Right  click  on  the  name tab  of  the  worksheet  you wish  to  duplicate.  This  will  display  a 
contextual menu.

• Select Copy/Move worksheet .....
• Make sure the Copy checkbox is ticked.
• Click on the To Document drop down window.
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• Select the name of the spreadsheet in which you wish to duplicate the worksheet and select 
the position in this spreadsheet.

• Select New document in the To document window if you wish to create a new spreadsheet 
for the duplicate.

• Click OK.

4.3.1.5 Move  a worksheet within a spreadsheet, between spreadsheets

The process of  moving a worksheet within a spreadsheet or between spreadsheets is virtually 
the same as duplicating a worksheet,  except that you do  NOT tick the Copy checkbox in the 
Move/Copy Sheet dialogue.

Suppose we have two spreadsheets open. They are called Nigeria and Ghana. Nigeria contains 
three worksheets called Lagos, Abuja and Ibadan. We wish to move Lagos to a position before 
Ibadan.

• Right click on Lagos and select Copy/Move Sheets.
• Uncheck the Copy check box.
• Highlight Ibadan in the Insert before window.

• Click OK.
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To move the Lagos worksheet to the end of the worksheets in Ghana:

• Right click on Lagos and select Copy/Move Sheets.
• Uncheck the Copy check box.
• Select Ghana in the To document window.
• Select Move to end position in the Insert before window.

• Click OK.
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4.4.1 Arithmetic formulas

4.4.1.1 Generate formulas using cell references and arithmetic operators
Plus (+), minus (-), division (/) and multiplication (*)

The main purpose of a spreadsheet is to automate numeric work and to store the calculations 
and their results for later use.

At the heart of any numeric work are the calculations themselves. In their simplest form, these 
are made up of numbers separated by the usual arithmetic operators of addition, subtraction, 
division and multiplication. The only difference is that the symbols we use in spreadsheets may 
be different from those you are used to.

Indicating a calculation

Calculations are done within cells. In order to indicate that we wish to do a calculation in a cell, 
we preface the cell entry with the  = symbol. This indicates to Calc that it must treat the cell 
entry as a calculation.

Calc records the entry in a cell as you enter it, but normally displays the result of the calculation.

For example, a cell could contain the entry:

=7+8

Calc however displays the result 15.

You need to make a distinction between the actual contents of a cell and what is displayed.

Arithmetic operators

The four basic operations are as follows:

Addition: =7+8.
Subtraction: =7-8
Multiplication: =7*8
Division: =7/8

Arithmetic using cell references: Automatic recalculation

If we simply performed arithmetic using numbers, we may as well use a calculator. Suppose we 
have a simple situation in which one cell contains an amount of money and another an interest 
rate.  If  a  third  contains  the product  of  the  two (a  product  is  the result  of  multiplying  two 
numbers), this cell will in fact display the interest that would be earned on the capital. This is 
illustrated in the following screen:

The contents of cell C2 are: =A2*B2
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Notice  that  the  formula  bar  contains  the  actual  contents  of  a  cell.  If  the  cell  contains  a 
calculation, the result of the calculation is displayed in the cell.

The = sign indicates that  C2 contains a calculation.  This  calculation involves multiplying the 
contents of A2 with those of B2.

Now suppose we change the contents of cell B2, without making any change to C2, and press 
Enter as shown in the following screen:

The value in C3 automatically changes to reflect the changed value in B2. This tool is called 
automatic recalculation.

When you save a spreadsheet, the formulas are displayed so that they can be reused at a later 
stage.

Arithmetic operations using the values of cells are written down in the same way as arithmetic 
operations between values. 

Addition: =A2+B2
Subtraction: =A2-B2
Multiplication: =A2*B2
Division: =A2/B2

More complex calculations are carried out using the normal rules of arithmetic.

Suppose cell A2 contains the value 12, B2 the value 6 and C2 the value 8. The following table 
illustrates how these can be combined into arithmetic formulas.

Cell entry Equivalent arithmetic expression Cell display

=A2 + B2 - C2 12 + 6 - 8 10

=A2 + B2*C2 12 + 6*8 60

=(A2+B2)*C2 (12 + 6)*8 144

=A2/B2 - C2 12/6 - 8 -2

=A2/B2 + A2*C2 12/2 + 12*8 98

Important note: When you carry out arithmetic involving the different operators, remember 
that different operations have different priorities. The order is as follows:

• Work out the contents of brackets
• Carry out the multiplications and divisions
• Do the additions and subtractions
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4.4.1.2 Recognise  and  understand  error  values  associated  with  using 
formulas

If you enter a formula and Calc is not able to interpret it, it will display an error in the cell. The 
main errors that you will come across are shown below.

Error message Cause of error

#NAME An identifier could not be evaluated. This usually means that the reference to 
a cell or row or column was invalid.  This is also known as error 525

#VALUE Calc was unable to evaluate one of the cell references in the formula as a 
number.  This  error usually  occurs  when  one  of  the  cells  referenced in  a 
formula contains text rather than a number. This is also known as error 519.

#REF This indicates that the formula contains a reference to a cell, row or column 
that was deleted. It is also known as error 524.

Invalid floating 
point operation

A formula  contains  division  by zero.  A  common misunderstanding  is  that 
because  multiplication  by  zero  results  in  zero,  so  does  division  by  zero. 
Division by zero is however impossible. This is also known as error 503.

4.4.2 Cell referencing

4.4.2.1 Understand and use relative, mixed and absolute cell referencing in 
formulas

Relative addressing

Suppose cell  D4 contains the formula =D1-D2. Suppose we now copy the contents of D4 to 
E4:G6.

The result is shown on the following screen:

If you look at this screen, you will see that both the column letters and row numbers can change 
when the cell D4 is copied.

Cell D4 contains the formula =D1-D2. This means find the difference between the cell three rows 
up in the same column and the cell two rows up in the same column. When D4 is copied, the 
formula will be adjusted so that the cell references in the target cells have the same relationship. 

For example, F6 contains the formula =F3-F4. This also means the difference between the cell 
three rows up in the same column and the cell  two rows up in the same column. When cell 
references such as this  can be changed  when the cell  is  copied, we say that  we are using 
relative addresses.
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Absolute addressing

If we put the $ symbol in front of a column letter or row number, then the reference will  not 
change. The following screen indicates this type of addressing known as absolute addressing.

As this screen shows the addresses in the target cells are identical to that in the source cell.

Mixed addressing

You may make either the column or row absolute. When you do this the column or row reference 
will remain fixed when the cell is copied. This is referred to as mixed addressing.

The following two screens illustrate mixed addressing.

4.4.3 Working with functions

4.4.3.1 Generate  formulas  using  SUM,  AVERAGE,  MINIMUM,  MAXIMUM  and 
COUNT functions

SUM

A function is an inbuilt utility that simplifies the creation of arithmetic expressions involving cell 
ranges.

For  example,  we  could  add  up  the  contents  of  all  the  cells  in  the  range  B4:  D7  with  the 
expression:
=B4+B5+B6+B7+C4+C5+C6+C7+D4+D5+D6+D7
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Obviously,  the  bigger  the  cell  range  we  wish  to  add  the  more  terms  there  will  be  in  the 
expression.

The SUM function simplifies the process considerably. All we have to enter is the function:
=SUM(B4:D7)

Important: Notice the = symbol in front of the SUM function.

This means add the contents of all the cells in the range B4:D7.

The SUM function can be used in an arithmetic expression as shown in the following examples:

=SUM(C4:F8) + B6
=B6 – SUM(B7:B12)
=SUM(A3:B6) + SUM(C3:D9)

Syntax

The syntax of a function is the formal structure of the function. We write the syntax of the SUM 
function as:

=SUM(range)

where range is the range of cells that are being summed as, for example, B4:D7.

AVERAGE

Syntax:  =AVERAGE(range)

AVERAGE functions in exactly the same way as SUM, except that it calculates the average value 
of the cells in range.

MAX and MIN

Syntax:  = MAX(range),  =MIN(range)

These functions determine the maximum and minimum values in a range of cells.

COUNT

Syntax:  =COUNT(range)

COUNT returns the number of cells that contain values in range.

=AVERAGE(range) is actually the same as =SUM(range) / COUNT(range).

Using functions in a spreadsheet

Often functions are used to summarise data in a spreadsheet. When you create a spreadsheet, it 
is good practice to put your summary information at the top of the spreadsheet and the data on 
which the summary is based below.
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Suppose we wish to summarise the data in the spreadsheet below.

In this we may wish to find the sum, average, maximum and minimum of each column as well as 
the number of data entries in each column. We start by inserting four rows below row 2.

• Select rows 2 to 6.
• Insert » Rows
• Enter the following in A3:A7

A3: SUM
A4: MAXIMUM
A5: MINIMUM
A6: ENTRIES
A7: AVERAGE

• Enter the following in B3:B6
B3: =SUM(B9:B39)
B4: =MAX(B9:B39)
B5: =MIN(B9:B39)
B6: =COUNT(B9:B39)
B7: = AVERAGE(B9:B39) 

The next screen illustrates the situation at this stage. The functions have been displayed in the 
cells rather than the values. How to do this will be explained shortly.
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• Select B3:B6
• Edit » Copy
• Select C3:K3 OR C3:K6
• Edit » Paste

To display the functions rather than values in the cells:

• Tools » Options
• Expand OpenOffice.org Calc and select View.
• Tick the  Formulas checkbox in the  Display area. If you wish to display values at a later 

stage, untick this box.

Where an entry is  too wide to display in  a cell,  a series of hash symbols  (#####) will  be 
displayed.

• Widen the columns as necessary to view the cell contents.
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In the above screen, the ##### in cells E6 and E7 indicates that the cell is too narrow to display 
the contents.

4.4.3.2 Generate  formulas  using  logical  function  IF  yielding  one  of  two 
specific values

The IF function allows you insert different values, text or formulas in a cell depending on the 
result of a test.

Syntax: =IF(condition; TrueValue; FalseValue)

Condition is a test which can evaluate to True or False. If Condition is True, then TrueValue is 
inserted into the cell. If Condition is False, then FalseValue is inserted into the cell.

Condition generally involves a comparison between two expressions. The comparison is created 
using one of the operators:

= is equal to
<> is not equal to
> is greater than
>= is greater than or equal to
< is less than
<= is less than or equal to

Suppose in the previous example, we wish to indicate whether a score is above average or below 
average by inserting the appropriate word in the adjacent column. We could proceed as follows:

• Selecting column C
• Insert » Column
• Enter the following in C9  =IF(B9>B$7; “Above”; “Below”)

Notice the mixed mode addressing in this example. The reason for this is that the value being 
compared to is always in the same row 7.

• Copy the contents of C9 to C10:C39
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To understand why we need mixed mode addressing rather than absolute  addressing in  C9, 
suppose we were to insert a column after column D and copy column C to the new column. We 
would get the following:

If  we  had  used  absolute  addressing,  you  would  then  have  obtained  the  entry 
=IF(D9>$B$7;”Above”;”Below”) when you copied cell B9 to E9. However the average for column 
D is found in D7 not in B7.
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4.5.1 Number, Date

4.5.1.1 Format cells  to display numbers to a specific number of  decimal 
places,  to  display  numbers  with,  without  commas  to  indicate 
thousands

Suppose we have the spreadsheet Sales.ods on our screen as shown below.

This illustrates a common problem, namely that it is sometimes difficult to read large numbers. 
Calc allows us to format numbers with a decimal separator.

• Highlight the numbers to be formatted.
• Format » Cells
• Click the Numbers tab.
• Select Number in the Category window.
• Select a Format.
• Tick the Thousands separator check box.

• Click OK.

The result is shown on the next screen.

To remove the thousands separator:

• Repeat the above process, but untick the Thousands separator check box.
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In the previous example, we left the number of decimals places as 0. This will display numbers to 
the nearest whole number.

When we do calculations, we usually find that there is a fractional or decimal part to the number. 
For example, 18 / 7 is 2.57142857 .......... It is neither meaningful nor convenient to express 
numbers with all the trailing decimal places. In the Options area of the Numbers tab above, we 
can set the number of decimal places displayed. Numbers are rounded up. The system however 
still  stores the full  number of  decimal  places.  This  means that  calculations  will  not  use the 
displayed number but the actual number. The following table illustrates the effect of using a 
specific number of decimal places.

Decimal places 0 1 2 3 4

Displayed value 3 2.6 2.57 2.571 2.5714

4.5.1.2 Format cells to display a date style

If you type data into a cell, Calc attempts to interpret the data according to one of its known data 
types. These include numeric, text and date.

• Type the entry 3/11/05 into a cell in a blank spreadsheet.

Calc will interpret this as a date according to its default date setting. For example, as soon as you 
press enter, the contents of the above cell may become 2003/11/05. You ay have thought you 
were entering the short form of 03/11/2005.

The following screen  illustrates this  The input window on the  Formula bar shows the actual 
data entry, while the cell illustrates how it has been reformatted.

To change the format of the cell.

• Select the cell(s) to be reformatted.
• Format » Cells.
• Click the Numbers tab.
• Select Date in the Category window.
• Select the date format in the Format window.
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• Click OK.
• If the display shows a series of #####, then widen the column.

As the above example illustrates, be careful when entering dates in short format as the system 
may be set up to interpret them differently to the way you do.

4.5.1.3 Format cells as currency style

If we look at the example in 4.5.1.1 we see that although some of the figures refer to currency, 
the currency symbol is not displayed. This is simply remedied by formatting numeric data to 
currency format.

• Select the range of cells to be formatted as currency.
• Format » Cells.
• Click the Numbers tab.
• Select Currency in the Category window.
• Select a language in the Language window. This will select the appropriate currency symbol.
• Select the desired format in the Format  window.
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• Click OK.

4.5.1.4 Format cells to display numbers as percentages

The next screen shows the previous spreadsheet with the profit calculated as a fraction.

In situations such as this it is more common to express the numbers in E5:E8 as percentages.
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• Select the numbers to be formatted.
• Format » Cells.
• Select the Numbers tab.
• Select Percent in the category window.
• Select the Number of decimal places in the Options area.
• Set any other options.

• Click OK.

4.5.2 Contents

4.5.2.1 Change cell content appearance: font sizes, font types

The font  style,  size and colour  of  any group of cells  whether text,  number or  date may be 
changed.

• Select the cells.
• Format » Cells.
• Click the Font tab.

• Select  the font, typeface and size.
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Additional effects such as colour can be set by clicking on the Font Effects tab.

• Click OK.

4.5.2.2 Apply formatting to cell contents such as: bold, italic, underline, 
double underline

The simplest way to add underlining, bold or italic is to:

• Select the cells to be formatted.
• Click the desired effect on the Formatting toolbar.

Note you could have also changed the font style and size using the Formatting toolbar.

Double underline does not appear by default on the Formatting toolbar. In this case:

• Select the cells to be formatted.
• Format » Cells.
• Click the Font effects tab.
• Click down on the Underlining drop down window to view the different underlining options.
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• Select the desired type of underlining.
Click OK.

4.5.2.3 Apply different colours to cell content, cell background

Suppose you have a single row of cells or a row of cells which you wish to display in a particular 
colour.

• Select the cells to be formatted.
• Format » Cells.
• Click the Font effects tab.
• Click on the drop down arrow next to Font colour to display the possible colours.
•  Select the colour you wish to use then click the OK colour.

You can also change the background of the cells which, by default, is white.

• Select the cells to be formatted.
• Format » Cells.
• Click on the Background tab.
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• Select the colour you wish to apply to the cell backgrounds and click the OK button.
             
4.5.2.4 Copy the formatting from a cell, cell range to another cell, cell range

Copying the formatting of a cell to another cell or range of cells involves a couple of steps.

The following example illustrates the process.

In the following screen, cell A6 has been formatted to Roman, 12 point, bold, red. We wish to 
copy this formatting to cells A5 and A7:A9.

  

• Format » Styles and Formatting

This displays the Cell styles dialogue. This dialogue contains five icons:

The first icon is the Cell styles icon while the second is the Page styles icon.
On the right hand side, the first icon (paint can) is the Fill format mode icon. The next is the 
New style from selection and the last the  Update style icon. An icon can be selected from 
each group independently.

Hint: If you let your cursor hover over the icons, a tip will be displayed telling you what the icon 
is.
 
• Select the Cell styles icon.
• Select the cell whose format you wish to copy and click the New style from selection icon.
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• Enter an appropriate style name for the formatting and click OK.

The new style name will appear in the list of styles.

• Select the style and click on the Fill format mode icon. 

The cursor will now be displayed as a paint can.

• Hold down the left mouse button and drag the cursor over the cells whose format you wish to 
change.

• When you have finished, click on the Fill format mode icon once more. 

This will change the cursor back to its normal pointing function.

4.5.2.5 Apply text wrapping to contents within a cell

Suppose we have a column of cells that we wish to use to write notes. By default, if we write in a 
cell, the text will appear to spill over into the next cell. If we enter text in the next cell, part of 
our old text will cease to be visible.

The answer to this problem is to cause the text to wrap within the cell.

• Select the range of cells in which you wish text to wrap.
• Format » Cells.
• Select the Alignment tab.
• Check the Wrap text automatically check box.
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• Click OK.

The effect is shown below.

4.5.3 Alignment, Border Effects

4.5.3.1 Align contents in a cell, cell range: left, centre, right, top, bottom

If you type numbers in a cell you will  notice that, by default, they are right aligned. In other 
words, the numbers are flush against the right hand borders of the cell. Text, on the other hand 
is left aligned. Changing these defaults is simply a matter of changing the alignment of a cell or 
range of cells.

Notice the alignment of the headings in the worksheet below:

The text in row 3 is left aligned, while the numbers in row 5 are right aligned. Suppose we wish 
to make the contents of B3:G3 right aligned.

• Select the cells whose alignment you wish to change.
• Format » Cells
• Click the Alignment tab.
• Change the Horizontal alignment to the desired option
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• Click OK.

Generally, the height of rows is such that the text in the cells appears to occupy the entire height 
of the row. It is possible to change the height of a row either by clicking and dragging the lower 
border of the row number or by selecting the row and using Format » Row » Height. In the 
next screen, the height of row 3 has been changed in this way.

In this worksheet, the vertical alignment of row 3, is Bottom. 

The vertical alignment of the entire row, a range of cells, or a single cell  can be changed as 
follows:

• Select the cells whose vertical alignment is to be changed.
• Format >> Cells.
• Click the Alignment tab.
• Change the Vertical alignment to the desired option.

• Click OK.
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4.5.3.2 Centre a title over a cell range

Consider the following screen:

Suppose we wish to centre the heading across C2:H2.

• Highlight the range of cells. In this case, it would be C2:H2.
• Format >> Merge cells

• Click the Centre icon on the toolbar, .

4.5.3.3 Adjust cell content orientation 

Normally when we type text in a cell, its orientation is from left to right. Calc allows us to change 
the orientation of text very simply. 

Suppose we wish to add a slightly unusual effect to the following screen so that the headings 
slope from left to right.

• Select the range of cells you wish to modify.
• Format » Cells
• Select the Alignment tab.

Notice that the Text direction is 0º. Next to the degrees box, there is a compass indicating the 
text directly visually.

• Either enter the figure 315º or click on the  315º point on the compass. 
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• Click OK.

• Experiment with other orientations of text in cells.

4.5.3.4 Add border effects to a cell, cell range

The gridlines that you see on your screen indicated the edges of the cells. You can, if you wish, 
add borders to cells or ranges of cells.

Suppose, in the following screen, we wish to put a border round the range of cells C5:H9 as well 
as vertical lines between the columns.

• Select the range of cells for which you wish to define the borders. In this case, it would be 
C5:H9.

• Format » Cells.
• Select the Borders tab.
• Select a Colour for the borders. In the example below, red has been selected.
• Select a Style. In the example below, 2.5 pt has been selected.
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The Line arrangement section allows you to select a predefined option in Default or to create 
your own custom arrangement under User-defined.

• Select a suitable line arrangement. 

You may remove a line you have added by clicking on it.

• Click OK.

Note: In the Borders tab you could have also added a shadow effect to your borders.
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4.6.1 Using Charts and Graphs

4.6.1.1 Create  different  types  of  charts/graphs  from  spreadsheet  data: 
column chart, bar chart, line chart, pie chart

Charts and graphs provide us with a more visual representation of one or more sets of numbers, 
making the interpretation of these numbers simpler and more intuitive.

The following screen shows some data that we wish to represent graphically.

We start with the data in row 4. In creating the chart we will make use of the fact that the names 
of the months are in row 3.

• Select B3:G4
• Insert » Chart

 

• Make sure First row as label has been checked.
• If you wish to insert the chart into a different worksheet, select the worksheet in the Chart 

result in worksheet window.  
• Click Next.

Note: If you click the  Create button, Calc will make a series of choices for you. This is not a 
good idea since these may not be what you had in mind.
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• Select the appropriate chart type. In this case we have selected column.
• Make sure the Rows radio button is checked. (If the data had been organised in a column, we 

would have needed to check the Columns radio button).
• Click Next. 

• Select the variant of the basic chart type. In this case we have selected normal.
• If you wish to select gridlines, check the X axis and Y axis check boxes.
• Click Next.
• Fill in appropriate title for the chart and for the X and Y axis as shown on the following screen.
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• Click Create.

• Drag the chart to the position you desire.

In the above example, we created a column chart. We could have created a number of other 
charts in the same way by making the appropriate choice in the  Choose chart type window. 
Other common chart types are line, pie and bar. These are illustrated below.
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Line chart Pie chart

Bar chart 3D Pie chart
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Creating graphs with more than one data series

In the previous example, only a single data range (the rainfall) was displayed. We can display 
more than one data range. 

The only change we really need make is to select the data labels and data when we start. In the 
example above:

• Select B3:G5
• Insert » Chart
• Follow the process through as before.

4.6.1.2 Add a title, label to the chart/graph. 
Remove a title, label from the chart/graph

The previous  example  illustrated how to add titles  and labels  to  graphs during  the creation 
process.

Suppose a graph had been created without labels and titles as shown in the following screen.

There are no labels or title on this chart. The processing of adding them is quite simple.

• Double click on the chart. A thick grey border will appear round the chart.
• Insert » Title
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• Make sure the Main title, X axis and Y axis check boxes are ticked and add appropriate text 
as shown in the screen above.

• Click OK.

The result is shown on the following screen.

To remove labels and titles:

• Double click on the chart.
• Insert » Titles
• Uncheck the labels and / or titles check boxes.

To change labels and titles:

• Double click on the chart.
• Insert » Titles
• Edit the contents of the labels and titles.
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If you delete the contents of the labels or titles this will also have the effect of removing them.

To add x axis labels:

As you will  notice from the chart, the x-axis labels indicate the column of the data. What we 
would like is for the months to be displayed. These are indicated in row 3. The reason the graph 
in this example did not contain the x axis labels is as a result of only the data row being selected 
when creating the graph. 

To add x axis labels:

• Single click on the chart.
• Right click on the chart to display a context sensitive menu.

• Select Modify data range.
• Tick the First row as label check box.
• Select two rows of data – the x axis labels and the data itself.

The range in the Modify chart data range dialogue will change accordingly.
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Note:  In setting up data for creating graphs, it is important that the data labels are in the row 
above the data.

• Click Create.

There are some further related actions that can be carried out using this method.

To change the gridlines:

In the above example, only horizontal gridlines are displayed. This can be changed as follows:

• Double click on the chart.
• Insert » Grids ...

• Edit the check boxes as desired.

To show the value of data:

• Double click on the chart.
• Insert » Data labels ...
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4.6.1.3 Change the background colour in a chart/graph

By  default,  there  is  no  background  colour  to  the  chart.  To  add  colour  to  or  change  the 
background colour of a chart:

• Double click on the chart.
• Right click on the chart.
• Select Chart area.
• Click the Area tab.

• Select the colour for the background background.
• Click OK.

4.6.1.4 Change the column, bar, line, pie slice colours in the chart/graph    

When we create a line, bar or column chart, Calc assigns default colours to the different data 
series. It also applies default  colours to the different segments of a pie chart.  These default 
colours can be changed as follows:

• Tools » Options
• Expand Charts.
• Select Default colours.
• Select the data series you wish to change.
• Select the desired colour from the palette.
• Click OK.

The new colours will apply to future charts you create.

To change the colours of an existing chart:

• Double click on the chart. This will display a thick grey border around the chart.
• Double click on the data series or pie segment whose colour you wish to change.
• Click on the Area tab.
• Select the new colour.
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• Click OK.

4.6.1.5 Change the chart/graph type

Once a chart has been created it can be changed to another type of chart quite simply as follows:

• Double click on the chart.
• Right click on the chart to display a context sensitive menu.
• Select Chart type.

• Select Chart type and Variant.
• Select 2D or 3D.
• Click OK.
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4.6.1.6 Duplicate, move charts/graphs within a worksheet, between open 
spreadsheets

Charts can be copied and moved just like any other object.

Moving a chart within a worksheet by dragging:

• Position the cursor over the chart.
• Hold down the left mouse button and drag the chart to its new position.
• Release the left mouse button.

Moving / duplicating a chart within a worksheet using cut / copy and paste:

• Click on the chart.
• To move: Edit » Cut OR To duplicate: Edit » Copy.
• Select a target cell.
• Edit » Paste.

Moving / duplicating a chart between worksheets within a spreadsheet:

• Click on the chart.
• To move: Edit » Cut OR To duplicate: Edit » Copy.
• Click on the tab of the target worksheet.
• Select a target cell in the worksheet.
• Edit » Paste.

Moving / duplicating a chart between open spreadsheets:

• Click on the chart.
• To move: Edit » Cut OR To duplicate: Edit » Copy.
• Click on the Window item in the menu bar and select the desired spreadsheet.
• Click on the tab of the target worksheet in the new spreadsheet.
• Select a target cell in the worksheet.
• Edit » Paste.

4.6.1.7 Resize, delete charts/graphs

Deleting a chart:

• Click on the chart.
• Press the Del key.

Resizing a chart:

• Click on the chart.
• Position the cursor over any of the eight handles. 
• Drag the handle by holding down the left mouse button and moving the cursor.
• Release the left mouse button when the desired size has been achieved.

A resizing symbol will appear. The side handles allow you to resize the chart horizontally and the 
top and bottom handles vertically. Using these will cause the chart to appear flatter or longer. 

The corner handles allow you to resize the chart either horizontally or vertically. By dragging 
these diagonally, you are able to resize a chart and keep its scaling.
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4.7.1 Worksheet Setup

4.7.1.1 Change worksheet margins: top, bottom, left, right

Margins refer to the blank areas at the top, bottom and sides of the printed page. The sizes of 
these margins are set as follows:

• Open the document whose margins are to be set.
• Format » Page.
• Click the Page tab.

Here we are only concerned with the Margins area of this dialogue.

• Adjust the margins by typing in the desired measurements into the  Left,  Right,  Top and 
Bottom windows. Alternatively, clicking on the increase and decrease arrows at the side of 
the windows allows you to change the settings in increments or decrements of 0.1 cm.

• Click OK when you have completed the changes.

Note: The settings that you apply in this way will only apply to the current page style. If you 
have used different page styles in a document, you will need to set each of these independently.
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4.7.1.2 Change worksheet orientation: portrait, landscape 
Change paper size

Pages of spreadsheets and other documents can be printed either across the short side of the 
page (as in the case of this document) or across the long side of the paper. The former is called 
portrait and the latter landscape.

Landscape orientation is particularly  important in the case of spreadsheets as our data often 
covers many columns.

Generally, we work with A4 size paper. There are, however, many other standard paper sizes. 
Further, you may form time to time come across non-standard sizes.

To change the worksheet orientation and paper size of the current spreadsheet:

• Format » Page.
• Click the Page tab.

This displays the same dialogue as in the previous section.

• Select portrait  or landscape by clicking the appropriate radio button in  the  Paper format 
area.

• If you are using a standard paper size, click the Format drop down box to select the desired 
paper size. If you are using a non-standard paper size, adjust the Width and Height entries 
in the Paper format area.

4.7.1.3 Adjust page setup to fit worksheet contents on one page, 
on a specific number of pages

It may be that in creating a spreadsheet we have not been careful is setting our columns widths 
so that a spreadsheet can fit on a single page. In such a case, Calc can adjust the column widths 
so that the spreadsheet will fit on a single page.

• Select the pages that need to be adjusted.
• Format » Page.
• Click the Sheet tab.
• Click the drop down button of the Scaling mode window.
• Select Fit print range(s) to width / height.
• Adjust Width in pages to 1.

If you used a different value, Calc would spread the output across this number of pages. For 
example, if you entered the value 2, the output would be spread across two pages.
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• Click OK.

4.7.1.4 Add, modify text in Headers, Footers in a worksheet

Adding headers and footers:

Headers and footers are text and information such as file names and page numbering that are 
inserted at the top and bottom of each printed page.

• Edit » Headers and footers

This brings up the Headers / Footers dialogue.

• Click on the Headers tab.

The header is divided into three sections: Left, centre and right. 

• Enter the appropriate text in each of the sections of the header.
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• If you wish to format the text, click the text attributes icon: 
This will display the text attributes dialogue which will allow you to change the font type and 
size as well as other attributes such as colour.

• Click the Footer tab. 
The footer can be created in exactly the same way as the header.

• Click OK when done.

Editing headers and footers:

If headers and footers have already been defined,  Edit  » Headers and footers will show the 
current entries. These can be edited in the usual way.

                             
4.7.1.5 Insert fields: page numbering information, date, time, file name,
 worksheet name into Headers, Footers

To the right of the text attributes icon in the Headers / Footers dialogue are a number of other 
icons. Pressing any of these will insert information such as page numbering, date and file name.

The meaning of these icons is shown in the following table:

_____________________________________________________________________________
Page 4.92



4.7 OpenOffice.org Calc: Prepare outputs
_______________________________________________________________________________________________

File name Number of pages in worksheet

Sheet name Date 

Current page number Time

4.7.2 Preparation

4.7.2.1 Understand the importance of checking spreadsheet calculations
 and text before distribution

Calculations

A spreadsheet is an example of a decision support system. We create spreadsheets so that data 
can be analysed in various ways and turned into information.

You can think of information as data that has been manipulated in various ways so that we are 
able  to  interpret  the results.  Ways in  which  we manipulate  data include things  like  sorting, 
summing, averaging, and so on.

If our data is  incorrect or if  the logic of our manipulations is flawed, the information will  be 
useless at best and dangerous at worst.

If our spreadsheet provides us with incorrect information, we will make incorrect decisions.

Before we make use of a spreadsheet or before we pass it on to someone else to make use of, 
here are some checks that should be carried out:

• Check the values that have been entered for correctness.
• Check the completeness of the data. Has all data been entered?
• Check  that  the  correct  functions  and  formulas  have  been  used.  It  is  possible  to  get 

spreadsheets  that  provide  us  with  information,  but  there  are  errors  in  the  formulas.  For 
example, incorrect ranges may have been used in functions.

One simple check is to verify that our summaries provide reasonable values. For example, if you 
have a spreadsheet that determines the average sales of a group of representatives, this value 
will be somewhere between the largest and smallest values.

Text

Just as numeric work needs to be accurate, the presentation needs to reflect professionalism. 
This means that the creator of a spreadsheet must check grammar and spelling as well as layout 
before releasing the spreadsheet.  A poorly  constructed spreadsheet will  be treated with  less 
respect by users, even if the numeric work is correct.

                                              
4.7.2.2 Preview a worksheet

Calc allows us to see what the printed spreadsheet will look like without actually printing it. To 
use this facility:

• File » Page preview.
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This will display a full page as it would appear on the printed page.

The  Page view object bar contains a number of icons that are relevant to working with the 
preview. 

These icons are in order:

 Previous page
 Next page
 First page
 Last page
 Zoom in (enlarge)
 Zoom out (shrink)
 Full page
 Page format button will take you directly to the page format dialogue. You can make your 

changes and see the effect immediately.
 Close preview button takes you back to normal mode.

Note: You cannot edit a spreadsheet while in page preview mode.

4.7.2.3 Turn on, off display of gridlines, display of row and column headings 
for printing purposes

Unless you specify otherwise, gridlines and row and column headings are printed when you print 
a spreadsheet.

To specify whether you wish these printed or not:

• Format » Page.
• Click the Sheet tab.
• Uncheck the Column and row headers check box if you do not wish row and column headers 

to be printed. 
• Uncheck the Grid check box if you do not wish gridlines to be printed.
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• Click OK.

4.7.2.4 Apply automatic title row(s) printing on every page of a printed
 worksheet

In the case of very large spreadsheets, you may wish to have certain rows or columns printed on 
each page. This would happen, for example, when certain rows or columns contain titles.

To achieve this:

• Format » Print ranges » Edit.

This will display the Edit print ranges dialogue:

• Enter the rows and or columns you wish to repeat as shown in the screen below.

An alternative method is to click in the window indicating the range or click on the shrink icon at 
the right of the window and select the range of rows or columns by dragging the mouse over 
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them.

• Se the Print range in a similar way to indicate the range for which the rows and or columns 
must be repeated.

4.7.3 Printing

4.7.3.1 Print a cell range from a worksheet, an entire worksheet, number 
of copies of a worksheet, the entire spreadsheet, a selected chart

To print a spreadsheet:

• File » Print.

This brings up the Print dialogue:

• If you wish to print using all the defaults, click OK.

To print a section of a worksheet:

• Highlight the section of the spreadsheet you wish to print.
• File » Print.
• Click the Selection radio button.
• Click OK.

To print a range of pages:

• File » Print.
• Click the Pages radio button.
• Enter the range of pages you wish to print.
• Click OK.
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To print multiple copies:

• File » Print.
• Click the Pages radio button.
• Enter the range of pages you wish to print.
• Set the number of pages you wish to print.
• If you wish the pages to be collated, check the Collate check box.

• Click OK.

Changing the printer:

If you have more than one printer installed, you can click on the Name drop down box. This will 
display a list of installed printers.
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