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Introduction 

The following pages should give you a brief and basic introduction to the architecture 
and structure of a commercial finite element analysis program. The basic ideas can be 
applied in most programs but examples are taken from the software ANSYS. We will 
here only focus on structural mechanics in ANSYS. Note also that many steps can be 
done in several other ways than what is presented here.  

Short history 

The usage of the Finite Element Method as a tool to solve engineering problems 
commercially in industrial applications is quite new. It was used in the late 1950’s and 
early 60’s, but not in the same way as it is today. The calculations were at that time 
carried out by hand and the method was force based, not displacement based as we 
use it today. In the mid 60’s, very specialized computer programs were used to 
perform the analysis. The 1970’s was the time when commercial programs started to 
emerge. At first, FEM was limited to expensive mainframe computers owned by the 
aeronautics, automotive, defense and nuclear industries. However, in the late 70’s 
more companies started to use the FEM, and since then, the usage have grown very 
rapidly.  

Today commercial programs are very powerful and large, complex problems 
can be solved by one person on a PC. Many of them have the possibility to handle 
different kinds of physical phenomena such as e.g. thermo mechanics, electro 
mechanics and structural mechanics. One often talks about multiphysics, were 
different kinds of physical phenomena are coupled in the same analysis. There are 
many available commercial programs, ABAQUS, FLUENT, Comsol Multiphysics, 
and ANSYS are just a few examples. A full license of a finite element analysis 
program costs usually in the order of several ten thousands Euro. ANSYS is a widely 
used commercial general-purpose finite element analysis program. 

Basic program structure 

Treatment of engineering problems basically contains three main parts: create a 
model, solve the problem, analyse the results. ANSYS, like many other FE-programs, 
is also divided into three main parts (processors) which are called preprocessor, 
solution processor, postprocessor. Other software may contain only the preprocessing 
part or only the postprocessing part. During the analysis you will communicate with 
ANSYS via a Graphical User Interface (GUI), which is described below and seen in  
Figure 1. 
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Figure 1: The ANSYS Graphical User Interface (GUI). 
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1. Utility menu: Here you can access and adjust properties about your session, 
such as file controls, listing and graphic controls.  

2. Toolbar: Push buttons to commonly used commands.  
3. Main menu: Here you can find the processors used when analysing your 

problem.  
4. Graphics window: In the graphics window your model is displayed: 

geometry, elements, visualisation of results and so forth.  
5. Input window: You can type commands in the input window.  
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Preprocessor 

Within the preprocessor the model is set up. It includes a number of steps and usually 
in the following order:  
 

• Build geometry. Depending on whether the problem geometry is one, two or 
three dimensional, the geometry consists of creating lines, areas or volumes. 
These geometries can then, if necessary, be used to create other geometries by 
the use of boolean operations. The key idea when building the geometry like 
this is to simplify the generation of the element mesh. Hence, this step is 
optional but most often used. Nodes and elements can however be created 
from coordinates only.  

• Define materials. A material is defined by its material constants. Every 
element has to be assigned a particular material.  

• Generate element mesh. The problem is discretized with nodal points. The 
nodes are connected to form finite elements, which together form the material 
volume. Depending on the problem and the assumptions that are made, the 
element type has to be determined. Common element types are truss, beam, 
plate, shell and solid elements. Each element type may contain several 
subtypes, e.g. 2D 4-noded solid, 3D 20-noded solid elements. Therefore, care 
has to be taken when the element type is chosen.  

The element mesh can in ANSYS be created in several ways. The most 
common way is that it is automatically created, however more or less 
controlled. For example you can specify a certain number of elements in a 
specific area, or you can force the mesh generator to maintain a specific 
element size within an area. Certain element shapes or sizes are not 
recommended and if these limits are violated, a warning will be generated in 
ANSYS. It is up to the user to create a mesh which is able to generate results 
with a sufficient degree of accuracy.  

 

Solution processor 

Here you solve the problem by gathering all specified information about the problem:  
 

• Apply loads: Boundary conditions are usually applied on nodes or elements. 
The prescribed quantity can for example be force, traction, displacement, 
moment, rotation. The loads may in ANSYS also be edited from the 
preprocessor.   

• Obtain solution: The solution to the problem can be obtained if the whole 
problem is defined.  
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Postprocessor 

Within this part of the analysis you can for example:  
 

• Visualise the results: For example plot the deformed shape of the geometry or 
stresses.  

• List the results: If you prefer tabular listings or file printouts, it is possible.  
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Tutorial 1: Truss problem 

You will now use ANSYS to analyse your first problem. It is taken to be the simple 
truss problem shown in Figure 2. The truss is fixed in the left wall and the load of 10 
000 N is equally distributed on the two upper right joints. It is made of wood with 
Young’s modulus 16 GPa (parallel to fibers) and cross sectional area 25 cm2. It is 
recommended that you use SI-units for all quantities in order to obtain a result in SI-
units. Saving your model is optional but recommended.  
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 2: A balcony truss. 
 

1 m 

5000 N 5000 N 

1 m 1 m 

 
To analyse this problem we will go through the following steps:  
 

1. define the geometry  
2. define the material  
3. choose element type  
4. create mesh 
5. apply loads and define boundary conditions  
6. solve the problem  
7. process the results  
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Start ANSYS. Your model can be saved in a database by specifying your working 
directory (the folder where you want your ANSYS files to be saved) and a job name 
(every problem has a job name, for example truss).  
 

ANSYS Utility menu: File → Change directory … 
 

ANSYS Utility menu: File → Change jobname … 
 

Geometry 

We will now draw the structure shown in Figure 2 by first defining keypoints and then 
drawing lines between them. A visible working plane often makes the creation of the 
geometry easier. Therefore:  
 

ANSYS Utility menu: WorkingPlane → WP Settings … 
 
Change to “Grid and Triad” (triad meaning a triplet of base vectors) and set the 
minimum and maximum to 0 and 2 respectively, OK.  
 

ANSYS Utility menu: WorkingPlane → Display Workning Plane 
 
We will now define keypoints at the joints of the truss, see Figure 3 for the location of 
the keypoints.  
 

ANSYS Main menu: Preprocessor → Modeling → Create → Keypoints → In 
Active CS 

  
Press Apply to create the first four keypoints. Press OK to create the last keypoint and 
close the dialog box.  
 
 

                    
 
 
 
 
 
 

 
Figure 3: Keypoint coordinates and input dialog box.  

Keypoint x y 
1 0 0 
2 0 1 
3 1 0 
4 1 1 
5 2 1 

 
 
We will now create lines between the keypoints, see Figure 4.  
 

ANSYS Main menu: Preprocessor → Modeling → Create → Lines → Lines → 
Straight Line 
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Press Apply to create the first five lines. Press OK to create the last line and close the 
dialog box.  
 

 
 
 
 

 
 
 
 
 
 
 
 

 
 
 
 

Figure 4: Lines and keypoints.  

Line KP1 KP2 
1 1 3 
2 2 4 
3 4 5 
4 4 3 
5 2 3 
6 3 5 

 
Tip: You can check your geometry in the graphics display: 
 

ANSYS Utility menu: Plot → Keypoints → Keypoints 
or 

ANSYS Utility menu: Plot → Lines 
 

Numbering of lines and keypoints on the graphics display can be turned on and off in 
the dialog box after selecting 

 
ANSYS Utility menu: PlotCtrls → Numbering… 

 

Material 

We assume that the wood behaves linearly elastic. Define the material model and the 
material constants, see Figure 5:  
 

ANSYS Main menu: Preprocessor → Material Props → Material Models  
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Figure 5: Material model. 
 
 
Enter 16e9 for Ex (Young’s modulus) and 0.3 for PRXY (Poisson’s ratio).  
Save your database:  

ANSYS Toolbar:  SAVE_DB 
 

Element type  

The element type to use is called link1. Add this element from the library:  
 
ANSYS Main menu: Preprocessor → Element type → Add/Edit/Delete → Add… 

 
 

 
 
 
 
 
 
 
 
 
 

Figure 6: Element library. 
 

 
The cross sectional area of the elements in the truss structure also has to be defined. 
This is accomplished with a so called real constant set:  

 
ANSYS Main menu: Preprocessor → Real Constants → Add… 

 
Choose the element type link1, OK. Fill in the value of the cross sectional area in the 
box (Note: use SI-units, i.e. m2 !), OK. In case we would like to define different cross 
sectional areas for the same element type, multiple real constant sets would be 
required.  
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Mesh 

 
In this step we will descretize our geometry by creating an element mesh 
 

ANSYS Main menu: Preprocessor → Meshing → MeshTool 
 

Under Element Attributes Select Lines, click Set. In the dialog box that appears, select 
the lines which should be associated with yout real constant set number. In this case, 
Pick all. Now the dialog box shown in Figure 7 will appear. Check that the material 
number, real constant set number and element type number are the ones that you have 
defined, OK.  
 

 
 
 
 

 
 
 
 
 

 
 
 
 

Figure 7: Line element attributes.  
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We want each line to be divided into one element only. This is accomplished under 
Size Controls, Lines, click Set. Select Pick all in the dialog box that appears. 
Specify NDIV to 1 in the new dialog box, click OK. This step is very important in 
order to avoid creating a mechanism. 
hen click Mesh on the meshtool, Pick all. Elements and nodes will now be created 
n the lines.  

ip: Element and node numbering and display can be activated similarly to keypoints 
nd lines. Do this to check your elements and nodes. 

oads 

he displacement is prescribed to zero at the two joints to the left:  

ANSYS Main menu: Solution → Define Loads → Apply → Structural → 
Displacement → On Nodes 

lick on the appropriate nodes, OK.  
elect ux and uy and set the value to 0, OK.  
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The force is prescribed at the two outer joints:  

 
ANSYS Main menu: Solution → Define Loads → Apply → Structural → 

Force/Moment → On Nodes 
 
Choose the y-direction and the value –5000 (the minus sign indicates that the force is 
directed in the negative y-direction).  
 

Solution 

The problem is now defined and ready to be solved:  
 

ANSYS Main menu: Solution → Solve → Current LS 
 
Save your database:  

ANSYS Toolbar:  SAVE_DB 
 

Results 

Enter the postprocessor and read in the results:  
 

ANSYS Main menu: General Postproc → Read Results → First Set 
 
 
Now there are several results to study. We begin with the displacements:  

 
ANSYS Main menu: General Postproc → Plot Results → Deformed Shape 

 
The undeformed and deformed shape should be similar to what is shown in Figure 8.  
 

 
 

Figure 8: Undeformed and deformed mesh.  
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We can also choose to list the displacements:  
 

ANSYS Utility menu: List → Results → Nodal solution … 
 

In the dialog box select Nodal solution, DOF solution and X-displacement 
components, click Apply. Repeat for Y-displacement components.  
 
 
Next, axial forces may be of interest. For the current element type, the axial force is 
stored in a variable called SMISC, 1. We can choose to list them:  
 

ANSYS Main menu: General Postproc → Element Table → Define Table… → 
Add… 

 
Write your own label (force), select Results data item: By sequence num – SMISC, 
add the item number 1, see Figure 9.  

 

 
 

Figure 9: Define element table item.  
 
 
 

ANSYS Main menu: General Postproc → Element Table → List Element Table…  
 
Select your data item from the list, OK.  
 
 
Reaction forces can directly be obtained from the list menu:  
 

ANSYS Utility menu: List → Results → Reaction solution … 
 
 
 
Save everything and you are ready for the next tutorial.  
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Tutorial 2: Beam problem 

In this second tutorial you will analyze a simple problem where beam type elements 
will be used. The structure to be analyzed is shown in Figure 10. The material is 
aluminum with Young’s modulus 70 GPa and Poisson’s ratio 0.3. The beam has a 
rectangular cross-section with the height 6 cm and the area 24 cm2. It is recommended 
that you use SI-units for all quantities in order to obtain a result in SI-units.  
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 10: A beam structure. 
 

10000 N 

5000 N 

7000 Nm 

1 m 

1 m 

 
Follow the general steps outlined in the previous tutorial in solving this problem.  
If you continue after the previous tutorial you should start a new job: 
 

ANSYS Utility menu: File → Clear & Start New 
 
 

Geometry 

Just as in the previous tutorial define keypoints in the current coordinate system. In 
our current problem the three keypoints can be chosen as (0,0), (1,0) and (1,-1). Once 
you are done with the keypoints create the two lines between these. 
 

Material 

Define the material model and the material constants. 
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Element type  

The element type to use is called beam3. Add this element from the library:  
 
ANSYS Main menu: Preprocessor → Element type → Add/Edit/Delete → Add… 

 
The cross sectional area, height and moment of inertia of the beams also need to be 
specified. Again, do this with the real constant set:  

 
ANSYS Main menu: Preprocessor → Real Constants → Add… 

 
Choose the element type beam3, OK. Fill in the values of the cross sectional area, 
height, and moment of inertia (IZZ) in the box (Note: use SI-units, i.e. m2 !), OK.  
 

Mesh 

 
You are now ready to create the element mesh, follow the steps outlined in the 
previous tutorial. Here you can choose to mesh each line with one or more elements 
(set NDIV). 
 

Loads 

As the left end of the beam is clamped, all displacement components and the rotation 
are prescribed to zero at the corresponding node (0,0):  
 

ANSYS Main menu: Solution → Define Loads → Apply → Structural → 
Displacement → On Nodes 

 
Click on the appropriate node, OK. Select All DOF and set the value to 0, OK.  
 
Apply the force 5000 in the x direction on the node at (1,-1), follow the steps in the 
previous tutorial. 
 
Now we will apply the moment at the coordinate (1,0): 

 
ANSYS Main menu: Solution → Define Loads → Apply → Structural → 

Force/Moment → On Nodes 
 
Click on the appropriate node, OK. Choose Mz and the value 7000, OK. 
 
Finally we will apply the pressure on the top beam. Choose 
 
ANSYS Main menu: Solution → Define Loads → Apply → Structural → Pressure 

→ On Beams 
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Select the appropriate line, OK. In the dialog box that appears enter 10000 for VALI 
and click OK. Note that you can specify a linearly distributed load by entering a value 
for VALJ, which is the value at the other (right) end of the line. As our load is uniform 
that field should be left blank. When finished the uniform load will show up on the 
horizontal element. 

Solution 

The problem is now defined and ready to be solved:  
 

ANSYS Main menu: Solution → Solve → Current LS 

Results 

Enter the postprocessor and read in the results:  
 

ANSYS Main menu: General Postproc → Read Results → First Set 
 
Now there are several results to study. Plot the deformed and undeformed shapes, this 
has been described earlier.  

 
Next, axial forces may be of interest. We can choose to list them:  
 

ANSYS Main menu: General Postproc → Element Table → Define Table… → 
Add… 

 
Write your own label (force), select Results data item: By sequence num – SMISC, 1. 
 
Add results for the moment by repeating the above steps and add the data items 
SMISC, 6 and SMISC, 12. For the current element type these variables define the 
bending moment at the left and right end of the element, respectively. 
 
These items can be studied by listing them 

 
ANSYS Main menu: General Postproc → Element Table → List Element Table…  
 
Select your data item from the list, OK.  
 
It is also possible to plot the moment distribution for the beams: 
 

ANSYS Main menu: General Postproc → Plot Results→ Contour Plot → Line 
Elem Res 

 
Select SMIS6 for “LabI” and SMIS12 for “LabJ”, OK. 
 
Nodal solutions can be listed as outlined previously. In addition to x- and y-
displacements we may also list the z-component of rotation:  
 

ANSYS Utility menu: List → Results → Reaction solution … 
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Tutorial 3: 2D Crack problem 

In this third problem you will analyze a simple 2-dimensional geometry where plane 
solid elements will be used. Here the interest is to calculate the stress intensity factors. 
We will now guide you through a simple analysis of how to do this below. 
 
The geometry to be analyzed is a thin cracked plate shown in Figure 11. The material 
is steel with Young’s modulus 200 GPa and Poisson’s ratio 0.3. It is recommended 
that you use SI-units for all quantities in order to obtain a result in SI-units. Saving 
your model is optional but recommended. 
 

1 m

1 m 

0.25 

30 MPa  
 
 
 
 
 

Crack  
 
 
 
 
 
 
 
 
 
 
 

Figure 11: A plate with an edge crack.  
 
Start ANSYS. Your model can be saved in a database by specifying your working 
directory (the folder where you want your ANSYS files to be saved) and a job name 
(every problem must have a job name). 
 

ANSYS Utility menu: File → Change directory … 
 

ANSYS Utility menu: File → Change jobname … 
 

Geometry 

We will now draw half of (use of symmetry plane) the structure shown in Figure 11 
by first defining keypoints and then draw lines between them. Define keypoints at the 
corners and crack tip, see Figure 12 for the location of the keypoints. 
 

ANSYS Main menu: Preprocessor → Modeling → Create → Keypoints → In 
Active CS 
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Press Apply to create the first five keypoints. Press OK to create the last keypoint and 
close the dialog box.  
 

 
 
 
 
 
 
 
 

Keypoint x y 
1 0 0 
2 0.25 0 
3 1 0 
4 1 1 
5 0 1 

 Figure 12: Keypoints coordinates and input dialog box. 
 
We will now create lines between the keypoints, see Figure 13 for the order of the 
lines. 
 

ANSYS Main menu: Preprocessor → Modeling → Create → Lines → Lines → 
Straight Line 

 
Press Apply to create the first four lines. Press OK to create the last line and close the 
dialog box.  
 
 

Line KP1 KP2 
1 1 2 
2 2 3 
3 3 4 
4 4 5 
5 5 1 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 13: Lines and keypoints.  
 
 
Tip: You can check your geometry in the graphics display: 
 

ANSYS Utility menu: Plot → Keypoints → Keypoints 
or 

ANSYS Utility menu: Plot → Lines 
 

Numbering of lines and keypoints on the graphics display can be turned on and off in 
the dialog box after selecting 
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ANSYS Utility menu: PlotCtrls → Numbering… 
 
You are now ready to create an area from the lines: 
 
ANSYS Main menu: Preprocessor → Modeling → Create → Areas → Arbitrary 

→ By Lines 
 
Pick the lines in any order you like. Click OK to create the area. 
 
Tip: Remember to save your model every now and then through the analysis. 
 

Material 

Define the material model and the material constants. 
 

Element type  

The element type to use is called Plane2. Add this element from the library:  
 
ANSYS Main menu: Preprocessor → Element type → Add/Edit/Delete → Add… 

 
In the options for the element choose plane stress: 
 

ANSYS Main menu: Preprocessor → Element type → Add/Edit/Delete → 
Options → Element behavior → Plane Stress. 

 

Mesh 

In linear elastic problems, it is known that the displacements near the crack tip (or 
crack front) vary as 
 

r , 
 
where r is the distance from the crack tip. The stresses and strains are singular at the 
crack tip, varying as 
 

r
1 . 

 
To resolve the singularity in strain, the crack faces should be coincident, and the 
elements around the crack tip (or crack front) should be quadratic, with the midside 
nodes placed at the quarter points. Such elements are called singular elements. Figure 
14 shows an example of a 2D singular element. 
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¼ le

¾ le

 
 
 
 
 
 
 
 
 
 

Figure 14: Example of a 2D singular element and element- 
division around a crack tip. 

 
 
 
The first row of element around the crack tip should be singular as illustrated above. 
The KSCON command which assigns element division sizes around a keypoint, is 
particularly useful in a fracture model. It automatically generates singular elements 
around the specified keypoint. Other fields on the command allow you to control the 
radius of the first row of elements, number of elements in the circumferential 
direction, etc. KSCON is found in 
 
ANSYS Main menu: Preprocessor → Meshing → Size Cntrls → Concentrat KPs 

→ Create. 
 
Select the crack tip keypoint. Choose the element size closest to the crack tip to be 
0.001 of the crack length, the radius ratio to 1.5 and number of elements in the 
circumferential direction to 6. Also, don’t forget to change the midside node position 
to ¼ pt, see Figure 15. 
 

 
 
 Figure 15: The dialog box appearing in the KSCON command. 
 
Before meshing the area a global size limitation on the element size should be set. 
This is not necessary for the problem to be solved but can improve the condition 
number of the stiffness matrix. 
 

ANSYS Main menu: Preprocessor → Meshing → Size Cntrls → ManualSize → 
Global → Size… 

 
Choose the global size to 0.05 m. Now you are ready to mesh the area with command: 
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ANSYS Main menu: Preprocessor → Meshing → Mesh → Areas → Free. 

 
Pick the area and click OK. 
 

Loads 

As only half of the geometry is modeled, symmetry boundary condition should be 
applied on the symmetry plane:  
 

ANSYS Main menu: Solution → Define Loads → Apply → Structural → 
Displacement → Symmetry B.C. → On lines 

 
Pick line number 2 and click OK. The crack surface is not restricted in its movement 
in any direction that is no boundary condition should be applied to that line. Of 
course, if a negative force is applied and the crack surfaces moves towards each other, 
a contact definition needs to be defined. But here we assume that the crack surfaces 
moves away from each other. 
 
Apply the load on the top line of the model as pressure. The pressure is defined 
positive in the negative normal direction; therefore a minus sign should be included 
when defining the pressure. The command is: 
 
ANSYS Main menu: Solution → Define Loads → Apply → Structural → Pressure 

→ On Lines, 
 
where line number 4 is picked. A new box appears and the pressure can be defied as a 
constant value, -30e6 Pa. By default is the thickness assumed to be of unit size in 
Ansys. 
 

Solution 

The problem is now defined and ready to be solved:  
 
ANSYS Main menu: Solution → Solve → Current LS 
 

Results 

Enter the postprocessor and read in the results:  
 
ANSYS Main menu: General Postproc → Read Results → First Set 
 
Now there are several results to study. Plot the deformed and undeformed shapes, this 
has been described earlier. Also, study the elements solution of the von Mises stress 
around the crack tip. The stress-level should be quite high at the crack tip since the 
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elasticity theory gives infinity large stresses around a crack tip. The higher resolution 
of the mesh the higher stress-levels will be obtained. 
 
The stress-intensity factors may now be of interest. The KCALC command calculates 
the mixed-mode stress intensity factors KI, KII, and KIII. This command is limited to 
linear elastic problems with a homogeneous, isotropic material near the crack region. 
To use KCALC properly, follow these steps in the General Postprocessor: 
 

1. Define a local crack-tip or crack-front coordinate system, with X parallel to 
the crack face (perpendicular to the crack front in 3-D models) and Y 
perpendicular to the crack face, as shown in the following Figure 16. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

This coordinate system must be the active model coordinate system and also 
the results coordinate system when KCALC is issued. 
 
The local coordinate system is defined through: 
 
Utility Menu → WorkPlane → Local Coordinate Systems → Create Local 

CS → At Specified Loc 
 
Choose the keypoint at the crack tip and the following dialog box appears. Fill 
in as below and click OK. 
 

 
 
 

Crack face 

Crack tip 

y 

x 

Figure 16: Local coordinate system at the crack tip. 

Figure 17: Dialog box appearing at the Create Local CS command. 
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You have now set the reference number to 11 for the local coordinate system. 
 
To turn the local coordinate system into active, use the following command: 
 

Utility Menu → WorkPlane → Change Active CS to → Specified Coord 
Sys… 

 
Change to coordinate system number 11 as defined above. 
 
To change the results coordinate system, use the following command: 
 

ANSYS Main menu: General Postproc → Options for Outp. 
 
The command activates a coordinate system for printout or display of element 
and nodal results. Change the RSYS in the dialog box to local system and link 
to the created system above by typing in the reference number. 
 

2. Define a path along the crack face. The first node on the path should be the 
crack-tip node. For a half-crack model, two additional nodes are required, both 
along the crack face, see Figure 18.  
 
Tip: If it is hard to see the actual crack tip node, choose to plot the nodes by 
use of command: 
 

Utility Menu → Plot → Nodes. 
 
 
 

y 

x 
3 2 

 
 
 
 
 
 
 1 
 Figure 18: The nodes to be chosen in the Path definition.  
 
ANSYS Main menu: General Postproc → Path Operations → Define Path. 
 

3. Calculate KI, KII, and KIII. The KPLAN field on the KCALC command specifies 
whether the model is plane-strain or plane stress. Except for the analysis of 
thin plates, the asymptotic or near-crack-tip behavior of stress is usually 
thought to be that of plane strain. The KCSYM field specifies whether the model 
is a half-crack model with symmetry boundary conditions, a half-crack model 
with antisymmetry boundary conditions, or a full-crack model. In this case you 
have a symmetric half-crack model. 
 
ANSYS Main menu: General Postproc → Nodal Calcs → Stress Int Factr 
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 Observe that the stress-intensity factor may need a unit change to be easier to 

interpret, since it is given in the input units.  
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