
Adobe InDesign CS4workshop

page 1 of 8

Introduction to Layout with InDesign
InDesign is a powerful Desktop Publishing (layout) application.  It is flexible enough so that it can be used by 
both new and experienced users because there is no single, correct way to lay out pages.  InDesign can handle 
sophisticated tasks such as glossy magazines  and high-impact ads, but its structured approach to publishing also 
makes it a good choice for newspapers, newsletters, and books.  It can also be used for corporate publishing tasks 
such as proposals and annual reports.

In all cases, you can design for printing on paper or for digital distribution as Adobe Acrobat Portable Document 
Format (PDF) files.  You can also use InDesign to create Web and Flash documents. These documents can include 
interactive features such as page transitions, hyperlinks and buttons to play sounds or a movie.

Tutorial Summary
You will be creating an InDesign file which will consist of several Masters (templates) that will contain the main 
graphics and headings which are common to each style of page layout.  You will then place your images into 
this InDesign file.   Use the instructions below to help you get started.  

Prepare a Concept Design for your Presentation Boards
• You need to make a sketch of your ideas for the layout of your pages by hand before you begin designing in 

InDesign.  This layout concept sketch is your starting point and helps you organise your digital page layout.
• Look at the sample pages below.  You will reconstruct these page layouts for this exercise.  
 

Page 1

Page 3Page 2



Adobe InDesign CS4workshop

page 2 of 8

The Screen Workspace
The Menu Bar is the row across the top and 
organises commands under menus.

The Options Bar appears below the Menu 
Bar at the top of the workspace. The options 
bar is context sensitive—it changes as you 
select different tools. 

The Tools Palette (or Tools Panel) sits on 
the left hand side and can be moved by 
dragging on the top of the panel.  If you 
hover the cursor of your mouse on top of 
each Tool in the Tools Palette, the name of 
that tool will appear. 

The Palettes (or Panels) in InDesign are 
on the right.  They click neatly under one 
another and are moveable. If you hover over 
a Palette Icon, the name of that palette will 

appear.  It is useful to learn the “Icons” for each of the Palettes so that you can quickly recognise and access them. 
If you can’t see a particular palette that you need, open it by selecting Window> “palette name” from the Menu Bar.  
Most palettes open in  group of more than one palette.  You can drag a palette out of a group by dragging the 
palette’s “tab” to a different location on the screen.  The Palette will then sit on its own.  
To close palettes click the “x” (close) button at the top right of the palette.  When you do this, if the palettes are 
grouped the whole group will close.  

Creating and Setting up Your Document
• From the Menu Bar select File>New>Document  
• Set Number of Pages to 4
• Tick “Facing Pages” to view the two pages of a book next 

to each other.
• Untick “Master Text Frame” because we will have varying 

pieces of information (text and images) on each page.
• In the dialogue box Set the settings to:

- width = 15cm
- height = 23.5cm
- orientation = portrait (press the portrait button)
- columns = 1
- gutter - 0.4233cm
- margins = top 1.5cm; bottom 1.27; left 0.8cm; right 1.5cm. 

• Click “Save Preset” and name your layout “book”.  Click OK 
to save.    

• Click OK to create the new document.  A new document will open with a white background layer and with the 
specified number of pages.

View the Rulers
• If you cannot see the Rulers around your document, from the Menu Bar select View>Rulers (or press ⌘ R).

Setting the Units of Measurement
• To set Units of Measurement, right click somewhere inside the 

top ruler, scroll down to the required unit and click to activate it.  
Do this again for the left hand side ruler.

Setting the Margins
• From the Menu Bar select Layout>Margins and Columns.  

This feature will set the margins FOR THIS PAGE ONLY.  If you 
want to set margins for multiple pages, select them first in the 
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Pages Palette.
• You can set all the margins in this menu.   If you need to set margins that are not all the same, press the 

“chain” button to unlink the settings.  
• For this document, make sure the chain is active and set the margins to 1cm.

Navigating your Document
There are several ways to zoom and pan in your document
• Activate the Navigation Palette where you can slide the slider to zoom in and out as well as moving the red 

box to pan (move) to a different position on the page.
• Press Command + to zoom in and Command - to zoom out.  You can use Command Spacebar and click with 

your mouse to zoom into a particular area.  This is called “contextual zoom”.
• Use the scroll bars or press Spacebar and drag with your mouse to pan.

Undo 
To undo any action by choosing Edit>Undo  or Command Z. (Note that you can’t undo some actions such as 
scrolling that don’t affect any items or the underlying document structure).  You can Undo several times.

Setting up the Display Performance
If you are going to include graphics in a layout, it might be a good idea to begin with High Quality Display 
Performance.
• Click on the InDesign button at the right of the Apple button.
• Select Preferences>Display Performance.
• Set the Default View to High Quality.

Setting up a Master
Masters and Pages
Your Master (the basic background design for your pages)
A Master is like a background that you can quickly apply to many pages. 
Objects on a Master appear on all pages with that Master applied.  
Changes you make to a Master are automatically applied to associated pages. 
Masters commonly contain:

• repeating logos and headings
• page numbers
• headers and footers

They can also contain empty text or graphic frames that function as placeholders on document pages.  A master 
item cannot be selected on a document page unless the master item is overridden.

You can create as many Masters as you need.  For example, if you require page numbers 
on some pages but not on others, you would create an A Master for the page with the no 
numbers, and a B Master for the pages with page numbers.

The Pages Palette (Window>Pages) 
The Pages Palette contains all the information about your Master and Pages and can be 
visible at all times to help you navigate through your document.  The top section of the 
palette contains icons for the Masters (A, B, C etc) and the bottom section contains icons for 
the separate “spreads” which are your document pages.  

The A-Master - for Even Pages
• On the Pages Palette you can see that you automatically have an A-Master.
• Double click on the A-Master word to activate the A-Master on the screen for you to design.  
• You can tell which page you are on by looking at the Status Bar (at the bottom left of your document).  This 

should say “A-Master”.
On this A-Master page we will create the necessary elements that may be repeated on more than one page. 
You can see that the A-Master is consists of two facing pages.  
• Make this one page by right clicking in the Pages Palette and selecting “Master Options for A-Master”.  

Change the Number of Pages to 1.
• Look at the first two pages you need to design ((1) on the following page).   The left page has a different 

the Pages Palette
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page number format to the right page.  Page 
numbers will be common elements throughout 
most of the book so they belong on a Master 
Page.

Creating Text - a Text Frame for left page 
numbers 
• Activate the Type Tool from the Tools Palette 

(or press the shortcut T).
• Click and drag the left mouse button to draw 

small marquis (i.e. a rectangle) near the top 
left of the left page.  This will contain a page 
number.   We can adjust the size later if we 
need to.

• When you activated the Type Tool, your 
Options Bar changed to show the Text Options 
on the Options Bar at the top of the screen 
underneath the Menu Bar.

• On the Options Bar, change the font to Calibri 
and the size to 12 pt. 

• From the Menu Bar select Type>Insert 
Special Character>Markers>Current Page 
Number.  An ‘A’ appears showing you where 
the page number will appear.

• Press ESC to activate the Selection Tool and exit the Text Tool.
• Right click and select “Text Frame Options” (or select Object>Text Frame Options).
• Set the Vertical Justification alignment to “Centre” so that your text appears in the middle of the marquis box 

that you drew.
• Open the Paragraph Panel and press the ‘Align Centre’ button near the top left.
• Open the Colour Palette.
• Set the Fill colour to black.
• Click the ‘T’ button on the Colour Palette and change the text colour to white. 

Change size of Text Frame accurately
• With the Text Box selected, look on the Options Bar and readjust the height of the text box to exactly 0.7cm.

The B-Master -for Odd Pages
Setting up a second Master for the right pages
• Open the Pages Palette, click on the small arrow at the top right of the palette and select New Master.  This 

will automatically be named Master B but you can rename it if you wish.
• Double click on the B-Master words on the Pages Palette to start designing a layout for B-Master.  
• From the Menu Bar select Layout>Margins and Columns and change the number of columns to 2.
• There are two lines in the middle where the gutter between the columns is automatically placed.
• From the Menu Bar select View>Grids and Guides and untick ‘Lock Column Guides’ so that we can move 

the columns. 
• Using the Selection Tool click on the right side line of the gutter and drag it to 4cm.
• Place the Page Number under the second column (Type>Insert Special Character>Markers>Current Page 

Number).  You will see that a ‘B’ appears showing you where the page number will appear

You can adjust the masters at any time and you will notice that any changes you make in a Master will 
automatically be applied to all the pages linked to that Master!

Applying Masters to Pages
• Drag the words A-Master to all even pages (i.e. pages on the left)
• Drag the words B-Master to all odd pages (i.e. pages on the right)
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We will first design pages 2 & 3
Page 2
Activating a Page so that you can design your layout
• In the Pages Palette, double click on the Page 2 icon to display page 2 on the screen.  You will notice that this 

page now has the  A-Master has been applied to it.

• Import and arrange the appropriate graphic images from the Lecturer’s folder for page 2 by following the 
instructions below.

Graphics - inserting drawings, images, photos, scans
There are four main ways to insert a graphic - the Place command is used most often, and it’s the recommended 
way to import a graphic.
1. Importing a graphic using Place 
• From the Menu Bar select File>Place.  You will see the document menu from which you can select an image 

from a folder to place into your page.
• Click on the required file and click on OPEN.  You should see your cursor change to a loaded graphics icon.  
• Click with the loaded graphics icon  onto the page at the place where you want the upper left corner of the 

graphic to appear.  Your file will be placed to the scale of the original.
• Be careful that you do not have any frame or image selected when you use File>Place.  You will replace the 

existing image.

2. Importing a graphic using the Rectangle Frame Tool  
• Select the Rectangle Frame Tool from the Tools Palette (the rectangle with an X, in the Tools Palette). 
• Draw a marquis to position the image by clicking and dragging.
• From the Menu Bar select File>Place and locate the image from your folder.  The file will be placed into the 

Placeholder Frame.

3. Copy and Paste 
• In InDesign or another program, select the original graphic , and choose Edit>Copy. 
• Switch to an InDesign document window, and choose Edit>Paste.

4. Drag and Drop a graphic 
• Select the original graphic. 
• Drag the graphic into an open InDesign document window. 

Note: In Windows, if you try to drag an item from an application that does not support drag and drop, the pointer 
displays the  icon.

Placing and Fitting your Image
When you place or paste an object into a frame, it appears at the upper left corner of the frame by 
default. If the frame and its content are different sizes, you need to use the Fitting commands to 
achieve a perfect fit automatically. 
To place your plan onto the first page, 
• From the Menu Bar select File>Place.
• Select the correct file from the list.
• Your cursor has a small thumbnail of the image attached to it.  Click and drag to place the image in the 

approximate position that you require.
• To access the Fitting command, right click on the image (or select Object>Fitting), select Fitting and 

scroll to “Fit Content Proportionally” to select it (1).
• Right click again and select “Fitting>Fit Frame to Content”.  If your frame does not cling to 

the image in the way that you want it to, you can click on the handles with the Selection Tool to 
move the frame edges (2).   

You can also use the Fitting Buttons at the top right of the Options Bar to fit your image 
appropriately.

Most of the time, you will need to use a combination of fitting commands to get the correct result for 

1
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your image.  

Resizing an Image
• Select the image with the Selection Tool.
• Activate the Scale Tool (or press S).
• You will notice that handles appear around your image with a Reference Point in one of the corners. 
• To resize proportionally, pull diagonally on the corner which is opposite the Reference Point corner.  If 

you can’t work out the reference point, there is a diagram at the top left of the Options Bar (1), showing 
where the Reference Point is positioned.  

• You can change the Reference Point by repositioning it on your image, or by using the diagram on the Options 
Bar.

• To resize horizontally or vertically at the same time, place the Reference Point at the centre and pull on the side 
handles.

Views
• At the bottom of the Tools Palette there is the Views Button (2).  Click and hold to get the fly out 

menu and select Preview mode to see your document without guides, margin indicators and blue 
place holders.

Aligning Objects
• Open the Align Palette (Window>Object and Layout>Align or press Shift F7).
• Click on the objects you wish to align and select the Alignment Option from the Align Palette.  For example, 

press the first icon to line up your sections at the left.
• Note that you can use the Distribute Spacings to distribute the vertical and horizontal spacing between 

objects.  InDesign distributes the space between the top and bottom, or left and right objects.

Page 3
Importing Text from a File
• From the Menu Bar select File>Place.
• Choose the document called “text1IndesignTutorial1.docx”
• Your cursor becomes some text.  
• Click and drag a text box into Column 2.  The text from the file will appear.  We need to adjust the layout of the 

text.
• Import the text file called “text2IndesignTutorial1.docx’ and place it into Column 1.

Manipulating Text
Dropped Capitals
• Select the I in the paragraph “I define 

beauty...”.
• Change the font to Times Roman for 

this letter.
• Open the Paragraph Palette.
• Set the Drop Cap Number of Lines to 5 

(3).
• Change the font of the paragraph to
• Change the Skew (false italic) to 5 

degrees (4).
• Your paragraph should look like the one 
       below.

I define beauty to be a harmony of all the 
parts... fitted together with such proportion 
and connection, that nothing could be added, 
diminished or altered, but for the worse.
 - Leon Battista Alberti (1406-1472)

2

Reference Point

1

Calibri 11pt with 13pt leading.

drop cap number 
of lines

3 4Skew (false italic)
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Inserting an Image
• Create a text box for the number 5.
• Drag the text box onto the existing paragraph text. 
• If the number 5 disappears, right click on the text box (or select  Object>Text Frame Options) and select 

Ignore Text Wrap.
• On the Options Bar press the ‘Wrap around bounding box’ button so that the text can be pushed to the right 

of the box.  This is how you get text to ‘flow’ around an object.  You can also select the ‘Wrap around object 
shape’ button if your object is a group of objects, or you want more space between the object and the text.  

Notes to assist with your Layout
Hiding Frame Edges 
Sometimes the number of blue frames can be distracting, particularly when several of them overlap.  
• To see only active frames, from the Menu Bar select View>Hide Frame Edges.

Drawing a Line
• Select the Line Tool and drag the cursor to draw a line.  Press the 

Shift key for a horizontal or a vertical line.
• On the Options Bar set the Line Weight and the Line Style.  The 

Colour of the line is dependent on the Stroke Colour.
       
Placeholder Text
• If you want to trial a batch of text while in the design phase, create a Text 

Frame by dragging a marquis with the Text Tool and from the Menu Bar select 
Type> Fill with Place-Holder Text (see Right).   

Transparency
Unlike Photoshop, each object which can be selected can have its own 
transparency.  To change the transparency of an object
• Select the object.
• Click on the Transparency setting on the Options bar and slide the slider until 

the required transparency is reached.
• Alternatively you can type in a transparency percentage.

Layers Palette
Layers work in a similar way to Photoshop, except that each new 
layer is identified by a different colour.  

When you do something on a layer, the borders of the text or 
image are the colour of the layer.  

It is often an advantage to have certain experimental elements on 
different layers so that you can turn their visibility on and off (by 
clicking the “eye” at the left of the layer on the Layers Palette). 
 

Am us? Batu isul tili, 
ublissime conde clum 
mortilica vivilic aperis alinintu 
vit; noctus locchuctusa 
dentem deribest it.
Lostre fac in de etidem 

Line Weight

Line Style

wrap around bounding box wrap around object shape
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Links
When you place an image into your page it is automatically linked to 
your document.  You can view all your linked images and files in the 
Links Palette.  When you reopen an InDesign file with placed objects 
you will see the message at right.  Always select ‘Don’t Fix’ unless 
you are certain all the objects are in their correct state before you fix.

When you save your InDesign file it keeps a “snapshot” of the images you have placed, in the state that they were 
in at the time you placed them.  When you reopen the InDesign file, if your linked file is not available or if it has 
been modified, a message will be displayed.  If you choose not to fix the link, the image you placed will remain the 
same.  If you choose to fix links automatically, InDesign will search for the image and replace it with a new version 
if you have modified it.  You can use the Links Palette to manually relink if you wish.  In any case, the image will 
remain in your document until you delete it.

Printing 
If you print on an inkjet or laser printer the artwork will not print right to the edge of the sheet of paper, shown as 
the bounding box.  Even if you have designed right to the edges of your page on the screen, there will always be a 
white margin where the machine grips the paper.  This margin is often up to 10mm.  If the design includes images 
or artwork up to the document edge, you will have to print on a larger piece of paper, and specify a larger page size 
for your printer.

Creating a PDF file     
• From the Menu Bar select File> Export> Adobe PDF.  
• Change the compatibility to Acrobat 6 or 7.
• Click Spreads if you have facing pages.
    

Links Palette 
• A. Linked graphic file name
• B. Page containing linked graphic
• C. Embedded-link icon
• D. Modified-link icon
• E. Image from linked .indd file
• F. Missing-link icon
• G. Layer Visibility Override icon
• H. Adobe Stock Photos Comp icon
• I. Relink button
• J. Go To Link button
• K. Update Link button
• L. Edit Original button


