
Layers in Photoshop 
 
An image scanned or imported into Photoshop, or directly created in Photoshop, subsists on a background layer. 
This background layer is analogous to the support in chierographic media: paper in the case of drawing, canvas in 
the case of painting. The background layer is locked by default. 
 
Additional layers can be added on top of the background layer in Photoshop, analogous to the use of  transparent 
sheets of Mylar or acetate to organize successive elements of a work on separate surfaces while seeing the work 
cumulatively in its entirety. Images elements on layers can employ drawing, editing, cutting and pasting, 
repositioning and reorienting, rescaling, all without disturbing elements on other layers. The relative opacity or 
transparency of a layer, as well as its color balance and contrast, can be modified independently of other layers. The 
front to back arrangement of layers can be altered, with elements shifted from behind to in front of, or from in front 
of to behind other elements located on other layers. An image element can be introduced on a layer, experimented 
with, and discarded if not satisfactory. 
 
To create a new layer, either: 

• on the Photoshop Menu Bar, Layer > New 
• in the active window for the image, Command-Shift-N, then use the pop up dialog box 
• click the New Layer button at the bottom of the Layer panel: Layer > New > Layer 
• on the Layers Panel menu at the upper right of the Layers panel, New Layer 
• Option-click the New Layer button  in the Layers panel 
• Command-click the Create New Layer button in the Layers Panel to add a new layer below a currently 

selected layer 
• Drag an image into an image to create a layer from an existing file 
• select a portion of a layer, then click Layer > New > Layer Via Copy to copy the selection to a new layer, 

or Layer > New > Layer Via Cut to cut and paste the selection to a new layer 
• using the Type Tool creates type on a new layer 

 
If an image is to be saved with unmerged layers, it must be saved in the Photoshop format with the .psd filename 
extension. After the image is flattened, it can be saved as another file format. Similarly, images created with a 
transparent background (File > New, with Transparent background selected in the New File dialog box) have no 
background and must be saved as Photoshop .psd files. 
 
Below is an example of an image created in Photoshop using layers, and a screen capture of the Layers panel for the 
image. 
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Note that the image background, and the two layers interposed on the background, are shown in the Layers panel as 
separate; with the background layer selected and active. To select a layer and make it active, click on the layer in the 
layers panel; the layer display a color change, indicating its selection. Only one layer can be active at a time. Only 
the active layer is affected by changes made to the image. 
 
If the Layers panel is not visible, click Windows > Show Layers. 
 
Clicking on the new layer icon at the bottom edge of the layer panel creates a new layer using the default options; 
the layer will use Normal mode and have 100% opacity. The layer will be named Layer n where n is the sequence 
number of the layer's creation. To specify options when adding a new layer, either: 
 

• Choose Layer > New > Layer 
• Select New Layer from the Layers panel menu 
• Alt-click (Option-click in MAC OS) the new layer icon at the bottom edge of the Layers panel. 

 
Specifying options when creating a new layer enables naming the layer, and selection of mode, fill and opacity of 
the new layer. 
 
A background can be converted to a layer: 
 

• in the Layers panel, double click Background 
• specify a name, mode and opacity for the layer 
• click OK 

 
Add a background to an image by: 
 

• click Layer > New > Background. The new background will be filled with the current background color as 
shown in the toolbox. 

 
The stack order of a background cannot be changed unless the background is first converted to a layer. Blending 
mode and opacity cannot be specified for a background. 
 
Select a layer by either: 
 

• clicking on the layer icon in the Layers panel 
• selecting the move tool in the toolbox, then right click or Control-click in the image, and select the desired 

layer in the context menu, which lists all layers containing pixels under the cursor location 
• selecting the desired layer interactively by using the move tool; see that the Auto Select Layer option in the 

Menu Bar is checked to enable this. 
 
Delete a layer by selecting the layer, then clicking on the trash can icon at the lower edge of the layers panel; click 
Yes to confirm the deletion. The layer name can be dragged tot he trash icon to delete the layer. Alt-click on the 
trash icon will delete the active layer. 
 
Show or hide a layer by: 
 

• clicking on the eye icon next to the layer to hide the layer; click in the empty space in the eye icon column 
to show the layer 

• dragging through the eye column to hide or to show multiple layers 
• Option-click to show only that layer; repeat to display all layers. 

 
Note that only visible layers are printed. 
Temporarily making all layers invisible will increase system performance while the layers are invisible. 
Even when an active layer is invisible, all changes to that layer are written to the layer. 
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Layer thumbnails can be altered or made invisible by clicking Options from the Layers panel menu; click a size to 
alter, or None to turn thumbnails off. 
 
Change the layer stacking order by selecting the layer to be shifted, then click Layer > Arrange, and select an option 
on the popup submenu: 
 

• Bring to Front - moves the active layer to the top of the stack - or press Ctrl+Shift+] 
• Bring Forward - move the active layer one level up in the stack - or press Ctrl+] 
• Send Backward - move the active layer one level down in the stack - or press Ctrl+[ 
• Send to Back -moves the active layer to the bottom of the stack, but above the Background - or press 

Ctrl+Shift+[ 
 
Layer stack order can also be easily changed by dragging the layers in the Layers panel: 
 

• make the selected layer active 
• drag the layer up or down in the Layers panel, releasing the mouse button when the highlighted line appears 

in the correct position in the stack. 
 
The background layer cannot be moved from the bottom of the layer list, unless it is first converted to a layer. 
 
Link layers to move their contents together, or to perform transforms, align layer contents or to merge two or more 
layers or to create clipping groups: 
 

• select one of the layers to be linked 
• click in the column immediately to the left of any layers to be linked to the selected layers; the link icon 

will appear in the column. 
 
Duplicate layers within an image by: 
 

• electing the layer in the layers panel, and 
• clicking Layer > Duplicate Layer from the Menu Bar or the layers panel menu; name the layer, click OK. 

 
Copy a layer between images by: 
 

• open both images 
• in the source image layers panel, select the layer to be copied 
• click Select > All to select all pixels on the layer falling within the canvas boundary, then click Edit > Copy 
• make the destination image active 
• click Edit > Paste 
• drag the name of the copied layer from the layers panel into the destination image 
• or by dragging the layer from the source image to the destination image using the move tool, dropping the 

layer in the source image where desired by releasing the mouse button at that location. The copied layer 
will be above the active layer in the destination image. To center the dragged selection, hold down Shift 
while dragging the layer from the source to the destination image. 

 
Align Objects on Different Layers 
 
Use the move tool to align objects on different layers of an image by selecting the layers with the Move tool or in 
the Layers panel. Chose Layer > Align Layer. 
 
To align to a specific point in an image, make a selection in the image, then select the layers in the Layers panel. 
Choose Layer > Align Layer to Selection. 
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Automatically align image layers by using the Auto-Align Layers command. A layer can be used as the reference 
layer, or Photoshop can choose a reference layer; the other layers are aligned to the reference layer. There are 
several methods of aligning layers using the Auto-Align Layers command: 

• combine images using shared overlapping content 
• replace or delete parts of images having the same background; align the images, then use masking or 

blending effects to combine parts of each image intoa single composit. 
To use Auto-Align, copy or place the images to be aligned intoa silgle image file; each image will be on a separate 
layer. This can be done simply by dragging the several images into a single image file, or using the Duplicate Layers 
command, or byusing the script Choose File > Scripts > Load Files Into Stack. 
Either create a referene layer by locking the selected layer, or allow Photoshop to select the layer in the center of the 
stack as the reference layer. 
Select the remaining layers to be aligned. Conveniently, Shift-Click for contiguous layers, Command-Click for 
noncontiguous layers. NOTE: Adjustment layers, vector layers or Smart Objects not needed for alignment should 
not be selected. 
Edit > Auto-Align Layers; select an alignment option. For images sharing overlapping content, use Auto: 
Perspective, or Cylindrical options. For aligning scanned images with offset common contnet, use Reposition Only. 
The Auto options causes Photoshop to analyse the image and apply either the Perspective or the Cylindical  optiom. 
Perspective: creates a consitent composition by using one image (by default, the middle image) as a reference and 
then transforming the other images (by repositioning, skewing, or stretching) to match overlapped content areas. 
Cylindrical:  displays individial images onan unfolded cylinder, matching overlapping content between layers, with 
the reference image at the center. This method reduces ‘bow-tie’ distortion produced by the Perspective option, and 
is best for wide panorama compositng. 
Spherical: Aligns images with wide fields, of view, vertical or horizontal. One of the source images (by defaut the 
middle) is used as the reference image; the other images are spherically transformed to match overlapping content. 
Scene Collage: aligns layers and matches overlapping content without changing the shape of objects in the images, 
thus avoid distortion from stretching or skewing. 
Reposition Only: aligns layers and matches overlapping content without transforms (stretch, skew) of the source 
layers. 
Lens Correction: automatically corects for lens effects: 
 Vignette Removal: corrects for luminance fall off at corners due to inadequate lens coverage. 
 Geometric Distortion: compensates for pin cushion, barrel or fisheye distortion. 
After using Auto_align, use Edit > Free Transform to adjust alignment, or make tonal adjustments needed to correct 
exposure differences between layers. Then combine the layers into the composite image. 
 
Layer Opacity and Blending 
 
Layer overall opacity determines the extent to which a layer conceals or reveals the layer beneath it. A 100% opacity 
layer  is opaque and thus completely conceals what is beneath; a 1% opacity layer is almost transparent and 
thusnearly completely reveals what is beneath.  
 
Layer fill opacity determines the extent to which pixels, shapes or text on a layer is opaque, but does not affect 
opacity of layer effects, e.g., drop shadows. 
 
Opacity of a locked layer, including a background layer (locked by default)  cannot be changed unless the layer is 
first unlocked. 
 
To change opacity, select the layer in the Layers panel; use the slider to change the opacity. 
 
To change Fill, select the layer in the Layers panel; use the slider to change the fill. 
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Blending Mode for Layers or Group 
 
The blending mode of a layer specifies how the pixels of a layer blend with those in lower layers.  A variety of 
effects can be enabled with Blending Mode variations. 
 
The default blending mode of a layer graoup is Pass Through; the group with a Pass Through blending mode has no 
blending properites of its own. 
 
Changing the blending mode of a group changes the order in which the image components are assembled. All layers 
in the grouop are first assembled, with this composite group then treated as an image which is blended with the other 
layers or groups of the image using the specified blending mode. Choosing a blending mode for a group other than 
Pass Through, the adjustment layers and layer blending modes within the group will apply outside the group. 
 
To specify the blending mode for a layer or group, select the layer or group in the Layers panel. Then from the 
Layers panel, select the option from the Blend-Mode popup menu: Layer > Layer Style > Blending Options . then 
choose the option to be specified. 
 
By default all channels are included for blending a layer or group, but blending effects can be restricted to a 
specified channel. Either: 

• Double-click the layer thumbnail 
• Choose Layer > Layer Style > Blending Options 
• Choose a Blending Options from the Add a Layer Style icon fx at the botton of the Layers panel. 

In the Advanced Blending area of the Layer Style dialog box deselect any channels not to be included when 
blending the layer.  
 
The tonal range for layer blending is specified using the sliders in the Blending Options dialog box to control which 
pixels from the active layer and the underlying visible layers appear in the final image, e.g., bright pixels can be 
forced, or dark pixels can be surpressed or dropped out. A range of partially blended pixels can be specified to 
enhance the smoothness of transition between blended and unblended image areas. 
 
To specify a tonal range for blending layers, either: 

• Double-click a layer thumbnail, then choose Layer > Layer Style > Blending Options, or, 
• In the Layers Panel memu, choose Blejding Options from the Add a Layer Style button at the bottom of the 

Layers panel menu. 
In the Advanced Blending area of the Layers Style dialog box, specify an opyion from the Blend If popup menu: 

• Choose Gray to specify a blending range for all channels 
• Select the individual color channel to specify blending in that channel alone. 

Use the This Layer and Underlying Layers sliders to specify the brightness range of the blended pixels; 0 = black, 
255 = white. Dragging the black slider sets the low end of the range, dragging the white slider sets the high ends of 
the range. A range of partially blended pixels can be set by holding Option, then draggingone half of a slider 
triangle; the two values appearing above a divided slider indicate the partial blending range. 
The This Layer slider specifies the range of pixels on the active layer that will blend, and thereby appear in the final 
image. The Underlying Layer slider spefifies the range of pixels in the underlying visible layers that will blend in 
the final image. Blemnded pixels combine with pixels in the active layer to produce composite pixels; unblended 
pixels show througj overlying areas of the active layer. 
 
Some filters cannot be applied to layers with no pixels, e.g., the Lighting Effects filter. Selecting Fill With (Mode)-
Neutral Color in the New Layer dialog box enables the layer to be filled with a preset neutral color. This invisible 
neutral color is assigned according to the blending mode of the layer. Filling with a neutral color has no effect on the 
remaining layers if no effect is applied. Fill With Neutral Color is not supported for layers using these modes: 
Normal, Dissolve, Hard Mix, Hue, Saturation, Color of Luminosity. 
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Combining Images Using Auto-Blend Layers 
Auto-Blend Layers combones images with smooth transitions to produce a final composite image, using layer masks 
as needed to correct over or under exposed areas and to hide content differences. Auto-Blend Layers is only 
supported in RGB and Greyscale modes. Auto-Blend Layers is not supported for video layers, 3D layers, 
background layers or Smart Object. Auto-Blend Layers can combine difference images of a scene with different 
illumination into a coherent composite. It can also be used to stich panoramas, though the Photomerge command 
may be better suited for this use. Auto-Blend Layers can also be used for combine multiple images of a scene with 
different areas in focus to an image having an extended range of depth of field. 
 
Depth of Field Blending Using Auto-Blend Layers 
Copy or place the images, each on a separate layer, into the same document. 
Select the layers to blend. 
Align the layers, manually or using the Auto-Align Layers command. This is an optional but helpful step. 
Choose Edit > Auto-Blend Layers. 
Select the Autoi-Blend Objective: 
 Panoramas: blends overlapping layers into a panorama. 
 Stack Images blends the best details of each corresponding area. Works best if layers are aligned. 
Select Seamless Tones and Colors to adjust the color and tonality fopr blending. 
Clcik OK. 
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