
Lesson overview
In this lesson, you’ll learn how to do the following: 

•	 Use guides to position text in a composition.

•	 Make a clipping mask from type.

•	 Merge type with other layers.

•	 Use layer styles with text.

•	 Preview typefaces interactively to choose them for a composition. 

•	 Control type and positioning using advanced type palette features.

•	 Warp a layer around a 3D object.

This lesson will take about an hour to complete. If needed, download the 
Lesson08.zip file and extract it. As you work on this lesson, you’ll preserve 
the start files. 

About type
Type in Photoshop consists of mathematically defined shapes that 
describe the letters, numbers, and symbols of a typeface. Many typefaces 
are available in more than one format, the most common formats being 
Type 1 or PostScript fonts, TrueType, and OpenType (see page 266).

When you add type to an image in Photoshop, the characters are 
composed of pixels and have the same resolution as the image file—
zooming in on characters shows jagged edges. However, Photoshop 
preserves the vector-based type outlines and uses them when you scale 
or resize type, save a PDF or EPS file, or print the image to a PostScript 
printer. As a result, you can produce type with crisp, resolution-
independent edges, apply effects and styles to type, and transform its 
shape and size.

8 Typographic Design
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Getting started
In this lesson, you’ll work on the layout for the label of a bottle of olive oil. You will start 
from an illustration of a bottle, created in Adobe Illustrator, and then add and stylize 
type in Photoshop, including wrapping the text to conform to the 3D shape. You will 
start with a blank label on a layer above the bottle background.

You’ll start the lesson by viewing an image of the final composition.

1	 Start Photoshop and then immediately hold down Ctrl+Alt+Shift (Windows) or 
Command+Option+Shift (Mac OS) to restore the default preferences.  

2	 When prompted, click Yes to confirm that you want to reset preferences, and Close to 
close the Welcome Screen.

3	 Click the Go To Bridge button ( ) in the tool options bar to open Adobe Bridge.

4	 In the Favorites panel on the left side of Bridge, click the Lessons favorite, and then 
double-click the Lesson08 folder in the Content panel.

5	 Select the 08End.psd file so that it appears in the center Content panel. Enlarge the 
panel if necessary to get a good close-up view by dragging the right splitter bar to the right.
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This layered composite represents a comp of packaging for a new brand of olive oil. For 
this lesson, you are a designer creating the comp for the product. The bottle shape was 
created by another designer in Adobe Illustrator. Your job is to apply the type treatment 
in Photoshop in preparation to present it to a client for review. All of the type controls 
you need are available in Photoshop, and you don’t have to switch to another application 
to complete the project.

7	 Select the 08Start.psd file and double-click it to open it in Photoshop.

8	 Choose File > Save As, rename the file 08Working.psd, and click Save. 

Creating a clipping mask from type
A clipping mask is an object or a group of objects whose shape masks other artwork so 
that only areas that lie within the shape of the masking object are visible. In effect, you 
are clipping the artwork to conform to the shape of the object (or mask). In Photoshop, 
you can create a clipping mask from shapes or letters. In this exercise, you will use 
letters as a clipping mask to allow an image in another layer to show through the letters.

Adding guides to position type
The 08Working.psd file contains a background layer, which is the bottle, and a Blank 
Label layer, which will be the foundation for your typography. The Blank Label is the 
active layer on which you will begin your work. You’ll start by zooming in on your work 
area and using ruler guides to help position your type.

1	 Select the Zoom tool ( ) and drag over the black-and-white portion of the blank 
label to zoom in to the area and center it in the image window. Repeat until you have a 
nice close-up view of the area, and enlarge the image window if necessary.
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2	 Choose View > Rulers to turn on guide rulers along the left and top borders of the 
image window. Then, drag a vertical guide from the left ruler to the center of the label 
(3½ inches) and release.

Adding point type
Now you’re ready to actually add type to the composition. Photoshop lets you create 
horizontal or vertical type anywhere in an image. You can enter point type (a single 
letter, word, or line) or paragraph type. You will do both in this lesson, starting with 
point type.

1	 Make sure that the Blank Layer is selected in the Layers palette. Then, select the 
Horizontal Type tool ( ), and in the tool options bar, do the following:

•	 Choose a sans serif typeface, such as Myriad Pro, from the Font Family pop-up 
menu, and choose Bold from the Font Style pop-up menu.

•	 Type 79 pt into the Size field and press Enter or Return.

•	 Click the Center text alignment button.
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2	 Click on the center guide in the white area of the label to set an insertion point, and 
type OLIO in all caps. Then click the Commit Any Current Edits button ( ) in the tool 
options bar.

      

The word “Olio” is added to your label, and it appears in the Layers palette as a new type 
layer, OLIO. You can edit and manage the type layer as you would any other layer. You 
can add or change the text, change the orientation of the type, apply anti-aliasing, apply 
layer styles and transformations, and create masks. You can move, restack, copy, and 
edit layer options of a type layer as you would for any other layer.

3	 Press Ctrl (Windows) or Command (Mac OS), and drag the OLIO type to visually 
center it vertically in the white box.

4	 Choose File > Save to save your work so far. 
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Making a clipping mask and applying a drop shadow
Photoshop wrote the letters in black, the default text color. You want the letters to 
appear to be filled with an image of olives. So next you will use the letters to make a 
clipping mask that will allow another image layer to show through. 

1	 Click the Go To Bridge button ( ) or use File > Open to open the Olives.psd 
file (located in the Lesson08 folder) in Photoshop. In Photoshop, arrange the image 
windows on-screen so that you can see both of them at once, and make sure that  
Olives.psd is the active image window.

2	 In the Layers palette of the Olives.psd image, hold down Shift and drag the 
Background layer to the center of the 08Start.psd file, and then release the mouse. 
Pressing Shift as you drag centers the Olives.psd image in the composition.
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A new layer appears in the 08Working.psd Layers palette, Layer 1. This new layer 
contains the olives image, which you will use to show through the type. But before you 
make the clipping mask for it, you need make the olives image smaller, as it is too large 
for the composition.

3	 With Layer 1 selected, choose Edit > Transform > Scale. 

4	 Grab a corner handle on the bounding box for the olives, and Shift-drag to make it 
smaller within the same proportions. You may need to move the pointer inside the box 
and drag to reposition the olives so that the image remains centered on the label. Resize 
the olives image so that it is approximately the same width as the white label.

5	 Press Enter or Return to apply the transformation.

6	 Double-click the Layer 1 name and change it to Olives. Then, press Enter or Return, 
or click away from the name in the Layers palette, to apply the change.
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7	 With the Olives layer still selected, choose Create Clipping Mask from the Layers 
palette menu. 

 
You can also make a clipping mask by holding down the Alt (Windows) or Option 

(Mac OS) key and clicking between the Olives and OLIO type layers.

The olives now show through the OLIO letters. A small arrow in the Olives layer and the 
underlined Type layer indicate the clipping mask. Next, you will add a drop shadow to 
give the letters depth.

8	 Select the OLIO type layer to make it active, and then click the Add Layer Style 
button ( ) at the bottom of the Layers palette and choose Drop Shadow from the  
pop-up menu. 
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9	 In the Layer Style dialog box, change the Opacity to 35%, accept all other default 
settings, and then click OK.

10	 Choose File > Save to save your work so far, and close the Olives.psd image file 
without saving any changes.

Creating a design element from type
Next, you will add the vertical lines that appear at the top of the label using a type trick. 
These vertical lines need to be perfectly aligned, so you will use the capital “I” of a sans 
serif font instead of creating, copying, and moving individual lines. You will also easily 
adjust the size and spacing of the “lines” using the Character palette.

1	 In the Layers palette, drag the lower right corner to expand the palette until some 
blank area is visible at the bottom. Click in the blank area to deselect all layers.  
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2	 Select the Horizontal Type tool ( ). In the tool options bar, do the following: 

•	 Choose a sans serif typeface, preferably a narrow one such as Myriad Pro Condensed.

•	 Set the size to 36 pt and press Enter or Return.

•	 Leave the Anti-aliasing pop-up menu set to Sharp.

•	 Choose Left alignment.

•	 Click the color swatch to open the Color Picker. Move the mouse over the olives 
showing through the OLIO letters to select a dark green from the photo, and click OK. 

3	 Click the pointer in the upper left corner of the white box and, holding down the 
Shift key, type I 12 times.

This creates a new type layer in the Layers palette.

4	 Select the Move tool ( ), position it inside the box, and drag the letters so that their 
tops touch the top edge of the white box.
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Note: Entering type in a Photoshop image window puts the Type tool in edit mode. 
Before you can perform other actions or use other tools, you must commit your editing in 
the layer—as you did with the OLIO type using the Commit Any Current Edits button. 
Selecting another tool or layer has the same effect as clicking the Commit Any Current 
Edits button in the tool options bar. You cannot commit to current edits by pressing Enter 
or Return; this action merely creates a new line for typing.

 

Julieanne Kost is an official Adobe Photoshop evangelist. 

T O O L  T I P S  F R O M  T H E  P H O T O S H O P  E V A N G E L I S T

Type tool tricks

• Shift-click in the image window with the Type tool (T) to create a new type layer—in case 
you’re close to another block of type and Photoshop tries to autoselect it.

• Double-click the T thumbnail icon on any type layer in the Layers palette to select all of the 
type on that layer. 

• With any text selected, right-click (Windows) or Control-click (Mac OS) on the text to access the 
context menu. Choose Check Spelling to run a spell check.

Now, you will adjust the tracking to space the “lines” a bit wider apart.

5	 Toggle open the Character palette by choosing Window > Character. 

6	 Type 40 in the Tracking box, or scrub the Tracking label to set the value. 
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Now it is time to adjust the positioning of the OLIO letters so that they’re not too close 
to the vertical lines. To do that, you need to link the OLIO type layer and the olive image 
mask layer and move them as a unit.

7	 Click to select the Olives layer and then Shift-click the OLIO type layer to also select 
it. Then choose Link Layers from the Layers palette pop-up menu. A link icon appears 
next to the names of both layers.

8	 Select the Move tool ( ) and drag the type down as desired.

9	 Choose File > Save to save your work so far.
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Using interactive formatting controls
The Character palette in Photoshop contains many options to help you set beautiful 
type, but not all of the choices and controls are obvious—as in the trick of scrubbing the 
Tracking icon to choose a tracking value. In this exercise, you will make a type selection 
using another advanced trick for previewing type in the Character palette.

1	 Click in a blank area of the Layers palette to deselect all layers. 

2	 Select the Horizontal Type tool ( ). In the tool options bar, do the following: 

•	 Click the Center text alignment button.

•	 Click the color box and choose a bright red color. Click OK to close the Color Picker. 

For the moment, don’t worry about which typeface or size you’re using.

3	 Click the pointer on the center guide in the black stripe in the label. To be sure that 
you don’t accidentally start editing the OLIO text, make sure that the pointer has a thin 
dotted line around it ( ) when you click. This means you’ll create a new type layer when 
you type. 

4	 Type EXTRA VIRGIN in all caps.

Photoshop writes the text in whatever typeface (and size) was previously specified. But 
what if you want to use a different typeface? What if you’re not sure which typeface you 
want to use?

5	 Select the EXTRA VIRGIN text in the image window, and then, in the Character 
palette, click on the name in the Font Family pop-up menu. The name becomes 
highlighted.
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6	 Press the Up or Down Arrow key to cycle through the available fonts, and watch 
as Photoshop interactively previews each font in the highlighted EXTRA VIRGIN 
letters on-screen. 

7	 After experimenting, choose the sans serif typeface that you used for the OLIO 
letters—Myriad Pro, in our example—and then use the Tab key to jump to the Font 
Style box.

8	 Again, use the Up and Down Arrow keys to cycle through available styles (if 
available) to choose one (we chose Bold), and watch as the styles preview interactively 
in the image window.

9	 Tab to the Size box, and use the Up or Down Arrow keys to set the type at 11 points. 

 
Press Shift as you use the Up and Down Arrow keys to change the Size increment 

by 10 points.

10	 Tab to the Tracking field, and set the Tracking to 280: Type the value, use the Up 
Arrow key (press Shift as you press the key to increase the increment by 100), or scrub  
to set it.

      

11	 Select the Move tool ( ) and drag the EXTRA VIRGIN text so that it is centered in 
the black bar of the label.

12	 Choose File > Save to save your work so far.
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Warping point type
Now you will add the words “Olive Oil” to the label, and then warp them to make them 
more playful. Warping lets you distort type to conform to a variety of shapes, such as an 
arc or a wave. The warp style you select is an attribute of the type layer—you can change 
a layer’s warp style at any time to change the overall shape of the warp. Warping options 
give you precise control over the orientation and perspective of the warp effect.

1	 Scroll or use the Hand tool ( ) to move the visible area of the image window so that 
the orange part of the label, below the black bar, is in the center of the screen. Enlarge 
the image window by dragging the lower right corner, if necessary.

2	 Click in a blank area of the Layers palette to deselect all layers. 

3	 Select the Horizontal Type tool ( ), and in the Character palette, do the following: 

•	 Choose a traditional serif typeface, such as Adobe Garamond. 

•	 Set the size to 40 points. 

•	 Set the tracking to 0.

•	 Make the color white.

4	 Click and drag a text box in the upper area of the orange box, and then type Olive 
Oil. Then click the Commit Any Current Edits button ( ) in the tool options bar.

The words appear on the label, and a new layer, Olive Oil, appears in the Layers palette.
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5	 Right-click (Windows) or Control-click (Mac OS) on the Olive Oil layer in the Layers 
palette, and choose Warp Text from the context menu.

6	 In the Warp Text dialog box, choose Style > Wave and click the Horizontal radio 
button. For Bend, specify +77%, Horizontal Distortion –7%, and Vertical Distortion 
–24%. Then click OK.

      

The words “Olive Oil” appear to float like a wave on the label.
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Designing a paragraph of type
All of the text you’ve written on this label so far has been a few discrete words or lines—
point type. Often, however, many designs call for full paragraphs of text. You can design 
complete paragraphs of type in Photoshop; you don’t have to switch to a dedicated page-
layout program for sophisticated paragraph type controls.

Using guides for positioning
Next, you will add a paragraph of descriptive content to the label in Photoshop. You will 
start by adding some guides to the work area to help you position the paragraph.

1	 Drag two guides from the left vertical ruler, placing the first one at 2½ inches and the 
second at 4½ inches. 

2	 Drag two guides down from the top horizontal ruler, placing the first one at 10¾ 
inches and the second at 13 inches. 

Adding paragraph type from a sticky note
Now you’re ready to add the text. In a real design environment, the text might be 
provided to you in the form of a word processing document, or perhaps in the body of 
an e-mail, which you could copy and paste into Photoshop. Or you might have to type 
it in. Another easy way to add a bit of text is for the copywriter to attach it to the image 
file in a sticky note.
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1	 Double-click the yellow sticky note annotation in the lower right corner of the image 
window to open it. 

Note: You may need to change the view or scroll to see the open note on-screen.

2	 Drag with the pointer to select all of the text in the note, and then press Ctrl+C 
(Windows) or Command+C (Mac OS) to copy it to the clipboard. Then click the close 
button to close the sticky note window.

 

Before you paste it in, specify your type options.

3	 Make sure that no layers are selected in the Layers palette. 

4	 Select the Horizontal Type tool ( ), and in the Character palette, do the following:

•	 Choose a sans serif typeface, such as Myriad Pro Regular. 

•	 Set the size to 10 points. 

•	 Set the leading to 24 points.

•	 Set the tracking to 5.

•	 Make the color black.



ADOBE PHOTOSHOP CS3 265
Classroom in a Book

4	 Click the Paragraph tab to bring the Paragraph palette forward, and click the Justify 
All button ( ).

5	 Drag with the Type tool to create a text box that matches the guides you positioned 
in the previous exercise, and then press Ctrl+V (Windows) or Command+V (Mac OS) 
to paste the text from the clipboard into the text box.

The text appears in the image window with the styles you specified, and it wraps to the 
dimensions of the bounding box. In our example, the second-to-last line had some 
unsightly gaps, so as a fine-tuning measure, we will fix that now.

 
If you resize the bounding box, the type will reflow within the adjusted rectangle.

6	 Position the Horizontal Type tool ( ) over the second-to-last line of the paragraph, 
and triple-click to select the line. 

7	 Click the Character tab to bring the Character palette forward, and set tracking to 60.

8	 Click the Commit Any Current Edits button ( ) in the tool options bar. Your 
paragraph text now appears as the layer named, “Like fine wine. . . .”

9	 Choose File > Save to save your work so far.
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OpenType in Photoshop: More fun with bottles
OpenType is a cross-platform font file format developed jointly by Adobe and Microsoft. The format 
uses a single font file for both Macintosh and Windows computers, so you can move files from one 
platform to another without fonts being substituted or text reflowing. Supported in Photoshop CS3, 
OpenType offers widely expanded character sets and layout features, such as swashes and discretionary 
ligatures, that aren’t available in current PostScript and TrueType fonts. This, in turn, provides richer 
linguistic support and advanced typography control.  

The OpenType menu The Character palette menu includes an OpenType submenu  
that displays all available features for a selected OpenType font, including ligatures, 
alternates, and fractions. Grayed out features are unavailable for that typeface;  
checked features have been applied.

Discretionary ligatures To add a discretionary ligature to two OpenType letters,   
such as to a “th” in the Bickham Script Standard typeface, select them in the image,   
and choose OpenType > Discretionary Ligatures from the Character palette menu. 

If you’d like to preview your OpenType choices before committing to them, work with 
the Adobe Illustrator CS3 Glyphs palette: Copy your text in Photoshop and paste it 
into an Illustrator document. Then, open the Glyphs palette by choosing Window > 
Type > Glyphs. Select the text you want to change, and choose Show > Alternates For 
Current Selection. Double-click a glyph to apply it, and when you’ve finished, copy 
and paste the new type into your Photoshop file.

Swashes Adding swashes or alternate characters works the same way: Select the 
letter, such as a capital “T” in Bickham Script, and choose OpenType > Swash to 
change the ordinary capital into a dramatically ornate swash T. 

Creating true fractions Type fractions as usual—for example, 1-slash-2—and 
then select the characters, and from the Character palette menu, choose OpenType 
> Fractions. Photoshop applies the true fraction.



ADOBE PHOTOSHOP CS3 267
Classroom in a Book

Adding the last two lines
You’ve almost finished adding text to the label. You just have to add two more lines.

1	 With the Like fine wine. . . layer selected, click inside the paragraph of text, and then 
drag the handle in the middle of the lower edge of the text box down to the bottom of 
the edge of the label. 

2	 Place the type pointer at the end of the paragraph of text and press Enter or Return.

3	 Type 16 FL Ounces. 

4	 Triple-click to select “16 FL Ounces.” In the Character palette, set the font size to 
13 points and set the Baseline Shift to –10; this option moves characters up or down 
relative to the baseline of the surrounding text. 

5	 In the toolbox, click the Switch Colors button to make the type white.

6	 In the Paragraph palette, click the Center text button ( ). Then, click the Commit 
Any Current Edits button ( ) in the tool options bar.
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Adding vertical type
The last line will be vertical.

1	 Deselect all layers in the Layers palette. Then, click and hold on the Horizontal  
Type tool to display the Vertical Type tool ( ), which is hidden under the Horizontal 
Type tool.

2	 Drag in the orange area of the label to the right of the descriptive text to create a 
long, narrow text box. Start from the lower or upper right corner so that you don’t 
accidentally select the paragraph text.

3	 Type PRODUCT OF ITALY, all caps.

4	 Select the letters either by dragging or triple-clicking them, and then, in the 
Character palette, do the following:

• 	 Choose a serif typeface, such as Adobe Garamond.

• 	 Set the size to 8 points.

• 	 Set the tracking to 300.

• 	 Make the color red.
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5	 Click the Commit Any Current Edits button ( ) in the tool options bar.  
Your vertical text now appears as the layer named PRODUCT OF ITALY. Use the  
Move tool ( ) and drag to center it if necessary.

Now, you’ll do a bit of clean up.

6	 Click to select the annotation, and then right-click (Windows) or Control-click  
(Mac OS) and choose Delete Note from the context menu; click OK at the alert to delete 
the annotation. 

7	 Hide the guides by choosing the Hand tool ( ) and then pressing Ctrl+; (Windows) 
or Command+; (Mac OS). Then, zoom out to get a nice look at your work.

8	 Choose File > Save to save your work so far.

Warping a layer
All of the text is now on the label, but there’s one problem: The bottle looks three-
dimensional, while the label looks unrealistically flat on its surface. So your final effect 
will be to warp the label and its contents to look like they realistically conform to the 
bottle shape. 

Earlier in this lesson, you warped the words “Olive Oil” so that the letters appeared 
wavy. For this exercise, however, you will apply the warp transformation to a layer, 
rather than to individual letters. To do this, you will group the label and type layers, and 
then transform the new, grouped layer using the Smart Objects feature. Using Smart 
Objects allows you to continue to edit both the contents of the layer (the type) and to 
edit the warp after you apply the transformation.
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Grouping layers into a Smart Object
Creating the Smart Object is a two-step process. First you have to merge the OLIO 
type layer and its clipping mask, then you will group all of the label’s layers into the 
Smart Object.

1	 Click to select the OLIO layer in the Layers palette, and then press Shift and click to 
also select the Olives layer. Then choose Merge Layers from the Layers palette pop-up 
menu. Photoshop combines them into one layer, Olives.
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2	 Click to select the Blank Label layer in the Layers palette and then Shift-click the 
topmost layer in the stack, PRODUCT OF ITALY. Photoshop selects the two layers and 
all of the layers in between. Then, choose Convert To Smart Object from the Layers 
palette pop-up menu.

 
Right-click (Windows) or Control-click (Mac OS) to display the context menu with 

the Merge Layers and Convert To Smart Objects commands.

Photoshop groups the selected layers into one Smart Object layer. The name for this 
new layer is the name of the top layer of the old stack, PRODUCT OF ITALY.
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Warping with Smart Objects
Now you will warp the Smart Object layer to match the contour of the bottle. To do this, 
it helps to have your guides visible.

1	 If the guides are not still visible, choose View > Show > Guides to display them. Then, 
zoom in to the label.

2	 With the PRODUCT OF ITALY layer selected, choose Edit > Transform > Warp.

Photoshop lays a 3-x-3 grid over the layer in the image window, with handles and lines 
that you can drag to warp the layer as desired. 
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3	 To help you apply the warp, drag out four horizontal guides, as follows: Place one 
guide at the top of the label, and one guide along the bottom of the label. Then, place 
two more guides one-quarter inch below each of those guides.

4	 One at a time, click the center of each horizontal line of the grid and drag the line 
down one-quarter inch to create the curved label. 

5	 When you’ve finished, press Enter or Return to apply the warp transformation.
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6	 Hide the visible guides by selecting the Hand tool ( ) and pressing Ctrl-; (Windows) 
or Command-; (Mac OS). Then, double-click the Hand tool to see the whole bottle 
composition on your screen.

Congratulations! You’ve added and stylized all of the type on the Olio olive oil bottle. 
If you’d like to experiment further with the capabilities of Smart Objects, go on to the 
“Extra Credit” on page 275. Otherwise, in the real world, you would flatten and save this 
image file for printing.

7	 Choose File > Save As, rename the file as 08Start_flattened. Keeping a layered version 
lets you return to the file in the future to edit it—as you’ll do if you complete the extra-
credit section.

8	 Choose Layer > Flatten Image.

9	 Choose File > Save, and then close the image window.
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EXTRA CREDIT You can take full advantage of your Smart Object now by editing 

the label’s content and letting Photoshop automatically update the bottle composition.

1	 Double-click the PRODUCT OF ITALY Smart Object thumbnail in the Layers 
palette. (If you get a Smart Object alert dialog box, just click OK.) Photoshop opens 
the Smart Object in its own window.

2	 Select the Horizontal type tool ( ), and in the Smart Object image window,  
change the “16 FL Ounces” text and to 32 fl. ounces. Then click the Commit Any 
Current Edits button ( ).

3	 Click the red close button, and when prompted, click Save to save your changes.

Photoshop returns to the 08Start.psd image file and applies the Smart Object updates 
to the label. You can repeat this process to make more edits as often as you’d like 
without compromising the quality of the image or the transformation. To edit the 
warp effect at any time, simply choose Edit > Transform > Warp in the 08Working.psd 
image file, and continue to edit the transformation nondestructively.
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Russell Brown Dancer before Dancer with type

Applying text to a complex path

In this fine sidebar, I’m going to demonstrate how to place text on a path. 
We will start with an image of a dancer. We will create a selection around 
the contours of her body, which we will then convert to a path. Then, we 
will apply the text to the path, finesse it, and voilà—you will apply text to 
a complex path. 

Watch the movie! 
See this tutorial’s 
detailed steps in the 
QuickTime movie included 
on the Adobe Photoshop 
CS3 Classroom in a Book 
CD. Browse to Movies/ 
DancingWithType/
DancingWithType.mov. 
Double-click the movie 
file; then click the Play 
button.© Digital Vision

—Russell Brown
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Step 4: Hide inside descendersStep 3: Place text on the path

Step 2: Convert to a pathStep 1: Select the dancer
The evenly colored, flat background makes the Magic Wand 
a good selection tool to use with this image. With the Dancer 
layer active, click with the Magic Wand in the background 
to select similarly colored pixels, and then press Shift and 
continue clicking until everything but the dancer is selected. 
Then simply invert the selection by pressing Ctrl+Shift+I 
(Windows) or Command+Shift+I (Mac OS).

Convert the selection to a path by choosing Make Work Path 
from the Paths palette pop-up menu. In the Make Work Path 
dialog box, set Tolerance to 1.0 and click OK. The lower the 
tolerance, the greater detail and more control points the 
path will have. Because this is a complex path, we want to be 
sure we have enough detail.

Select the Dancing with Type layer, which contains the text. 
Use the Type tool to select and copy the text to the clipboard. 
Then hide the text layer, select the Dancer layer, click on the 
path, and press Ctrl+V (Windows) or Command+V (Mac OS) 
multiple times to paste the text all around the dancer path.

To finish up, we will hide the descenders that obscure the 
dancer. In the Paths palette, press Ctrl (Windows) or Com-
mand (Mac OS) and click on the Dancer path icon to convert 
the path to a selection. In the Layers palette, select the type-
on-a-path layer, press Alt (Windows) or Option (Mac OS), and 
click the Add Layer Mask button. Ta da—the descenders are 
hidden! 



Review
Review questions
1	 How does Photoshop treat type?

2	 How is a text layer the same or different from other layers in Photoshop? 

3	 What is a clipping mask and how do you make one from type?

4	 Describe two little-known ways to control type formatting in Photoshop.

Review answers
1	 Type in Photoshop consists of mathematically defined shapes that describe the 
letters, numbers, and symbols of a typeface. When you add type to an image in 
Photoshop, the characters are composed of pixels and have the same resolution 
as the image file. However, Photoshop preserves the vector-based type outlines 
and uses them when you scale or resize type, save a PDF or EPS file, or print the 
image to a PostScript printer.

2	 Type that is added to an image appears in the Layers palette as a text layer that 
can be edited and managed in the same way as any other kind of layer. You can 
add and edit the text, change the orientation of the type, and apply anti-aliasing as 
well as move, restack, copy, and edit layer options.

3	 A clipping mask is an object or group whose shape masks other artwork so that 
only areas that lie within the shape are visible. The letters on any text layer can 
be converted to a clipping mask by selecting both the text layer and the layer you 
want to show through the letters, and then choosing Create Clipping Mask from 
the Layers palette pop-up menu.

4	 Select text in the image window, and in the Character palette or on the Type 
tool options bar you can do the following: 
•	 Scrub the Size, Leading, Tracking, Kerning, Scaling, and Baseline Shift values.

•	 Select some type in the image window, click the font displayed in the Font 
Family pop-up menu, and press the up and down arrow keys to cycle through the 
available fonts and watch them preview interactively in the image window.






