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Using QGIS and GRASS for Processing and Analysing Lidar Data

Pre-requisites

To follow this workshop you will need QGIS 1.7 and GRASS 6.4 installed on your 
machine. On Windows these programs are best installed via OSGeo4W installer 
http://trac.osgeo.org/osgeo4w/

To install these packages on linux systems refer to the installation guides for 
the specific system e.g. https://wiki.ubuntu.com/UbuntuGIS

Detailed instructions on how to do this can be found in the pre-course 
information and are not repeated here.

Session 1 - 9:00-11:00

The aim of this lab is familiarise yourself with both QGIS and the GRASS plugin. In this 
session you will undertake the following tasks:

• view ArcGIS ascii raster files in QGIS
• edit the properties of a raster in QGIS
• create a vector file in QGIS
• edit a vector file in QGIS
• set up a location with the GRASS plugin
• import a vector file using the GRASS plugin
• import an ArcGIS file using the GRASS plugin
• set a region of interest using the GRASS plugin
• create a hill shaded model of the lidar raster using the GRASS plugin
• digitise features identified in the lidar model to a shapefile

Each of these tasks stand alone as useful GIS tools but together they provide a 
workflow for visualising lidar raster data and recording the features from it. 
Illustrations in this booklet show the icons on screen for each task. The full menu 
options are notated as follows:  File > Open.
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Task 1 – Opening ArcGIS ascii raster files in QGIS and editing 
their properties

1. Start QGIS. Familiarise yourself with the layout of the screen. Some of the toolbars 
at the top of the screen may be compressed. To expand them use the  double arrow

To move the toolbars so that all the icons are visible use the vertical dotted line to 
the left of each toolbar. Hover your mouse over this line to get cross-hairs then click 
and drag to move the menu to another part of the screen. To find out the purpose 
of any icon hover your mouse over it.
Below are the key toolbars for this session – you should check that all these are 
visible.

Navigation toolbar (pan, zoom)

Add data toolbar

Edit shapefile toolbar

The GRASS plugin toolbar

2. When you are happy that you can see all the icons in the toolbars your first task will 
be to set the project properties and save the project. From the settings menu select 
Project Properties
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3. To set the units in the General tab of the Project Properties box select metres and 
click apply

4. To set the coordinate reference system (CRS) click on the CRS tab. The data for this 
tutorial is from the UK so we will search through the list for OSGB 1936. A quick way 
to do this is to type in the EPSG ID code 27700 and click find. Click apply to set the 
CRS.
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5. Click OK to close Project Properties and return to the main screen.
6. Use File>save to save the project

7. Next we will open an ArcGIS ascii raster (lidar_1.asc) using the tool bar icon (layer > 
add raster layer). Be sure to select the correct file type from the drop down menu at 
the bottom right of the “open raster” window.
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8. To improve the raster display we will now edit the raster properties. In the menu 
bar, right click on the raster's name and select properties.
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9. Edit the symbology so that the image is stretched to min and max values. This 
preference can be saved as the default for the file. 

10. The raster display should now resemble the image below.

11. Return to the properties menu. In this menu can be found a variety of options for 
colouring the map, editing transparency and viewing metadata. Take some time to 
familiarise yourself with these options.

12. Repeat the steps above for the other three ASCII rasters (lidar_2.asc, lidar_3.asc 
and lidar_4.asc) until you have all four displayed on screen. Don't forget to save 
your project!
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Task 2 – Creating a vector file in QGIS

1. For this task you are going to create a shapefile in QGIS that provides a 
boundary for the area covered by the lidar rasters. From the toolbar 
select the create new vector layer icon to open the window below

2. Select the type of file you want to create (point / line / polygon). We want to 
define an area so a polygon will be most appropriate.

3. Specify the CRS of the shapefile (OSGB 36 as in Task 1). Notice that the CRS of 
the project is available for quick selection.

4. Each shapefile has an attribute table where data about the features can be 
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stored. Add the attribute fields you want in the New Attribute section. In this 
case we will make a text field called “field1”. Click add to attributes list to save 
the attribute field then click OK

5. Name the shapefile “Area” and save it to your Archaeology 3D working area. 
Click OK to create the shapefile. It will automatically be added to the navigation 
menu on the left of your screen.

6. To edit the shapefile highlight its name in the menu and click on the Toggle Edit 
icon in the toolbar. 
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7. Select the draw polygon tool 

8. Draw your study area around the four lidar tiles, right click to finish the square. 

9. You will be given the option to record attribute data for Field1. 
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10.Click on the Toggle Edit icon again to finish drawing and save your edits.
11.Make the vector file editable again and experiment with moving the area using 

the move feature icon   and editing the nodes using the node tool 

12.Save your edits, making sure that the area still represents the coverage of 
the lidar rasters.

13.By right clicking on the name of the file in the navigation bar and selecting 
Properties you can edit the symbology. Experiment with different display options 
for your shapefile.
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Task 3 – Creating a GRASS location

1. To create a hill shade from the rasters in QGIS requires use of the GRASS 
plugin. The toolbar is shown below.

2. The first step is to create Location, which is essentially a directory in 
which GRASS will store the files you will make. The structure of this 
directory is very important and can be fiddly to get right in GRASS itself – 
the QGIS plugin makes the process of establishing a location much easier. 
Click on the Create new mapset icon to open the window below:

3. Browse to a directory in which to store your data. When using for the first 
time you should create a directory called “grassdata” to keep all your 
GRASS locations in. Click next.
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4. Select “create a new location”, give your location a name (with no spaces 
or special characters) and click next

5. We will now set the CRS for the GRASS location. You will see that the 
plugin suggests recently used systems at the bottom of the window. 
Select the OSGB36 CRS (using the same ESPG ID as before). Click next.

6. Set the Region of interest. This part is particularly important as GRASS only 
performs its operations within the bounds of this region of interest. For 
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simplicity here select the UK as the region form the drop down menu. (For 
practical reasons we will redefine this later to represent our study area). Click 
set and the North, South, East and West bounds will change. Click next.

7. Within the location create a mapset to work in. Click next

Rebecca Bennett                 Lab 1 – Lidar Processing  14



4th International Summer School “3D Modeling in Archaeology and Cultural Heritage 2011”, 29 August - 4 September 
2011, Grosseto, Italy

14.The final screen confirms the location and mapset you have created. Click finish 
to return to the QGIS main screen. The mapset will now be open and the GRASS 
toolbar icons active.
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Task 4  - Changing the GRASS Region
1. We now need to change the region to reflect our study area to ensure any 

processes we undertake in GRASS function correctly. To do this we will import 
the vector file we created in task 2 into the GRASS mapset and set the region to 
match it. On the GRASS tool bar select the GRASS tools icon 

2. In the Modules Tree tab navigate to File management>Import Vector into Grass 
> Import Loaded Vector. Click to open the tool.
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3. Select your vector file  (created in task 2) from the drop down menu. Give the 
GRASS vector you will create a name (you may wish to prefix this with “GRASS” 
if you intend to use the same name as the original shapefile to denote that it is 
a GRASS vector e.g. GRASSarea). Click “Run” then “View Output” to add the 
GRASS vector to the navigation menu to the left of the QGIS screen.

4. You can check the source of a file by hovering your mouse over its name in the 
navigation bar. The symbology of the GRASS vector can be edited in the same 
way as for QGIS vectors (See task 2).
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5. To set the region to match this vector select the GRASS tools Icon again and 
navigate to File >Config > Region > Region Settings > Set Region to match 
multiple vectors 

6. Type in the name of your vector file. Click Run and close.

7. To make sure that the region is set. Close the GRASS mapset using the Close 
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Mapset Icon 

8. Re-open the mapset using the Open Mapset Icon. Select your mapset.

9. A red line will now appear on your screen showing the extent of the current 
GRASS region. Close the vector files by unchecking the box beside them in the 
navigation menu to see this more clearly.
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10.The QGIS /GRASS toolbar gives only a selection of the most common GRASS 
functions. You can access all the GRASS functions by using the “GRASS shell” to 
enter commands. We will now use the GRASS shell within QGIS to check the 
resolution of the region. From the GRASS Tools window, click to open the GRASS 
shell

11.In the shell window type g.region (the GRASS command for the region settings). 
Hit return. A new window will open.
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12.To check your current settings switch to the “Print” tab and tick “Print the 
Current region”. Click Run.

13.The window will switch to the “Command Output” tab where the current region 
settings will be displayed. You will see that the resolution settings (nsres and 
ewres) are set to 1000m. As the data we will be using is of 1m resolution we 
need to change this setting.
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14.In the “Existing” tab select your imported vector from the drop down menu.

15.In the “Resolution” tab enter the value 1 in the NS and EW grid resolution boxes. 
Click run
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16.The module will switch to the “Command Output” tab where the new resolution 
settings will be displayed

17.Close the window and the shell window to return to QGIS.
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Task 5  - Creating a Hill shade of the lidar Rasters

1. For this task we will import the lidar rasters to our GRASS mapset and 
create a hill shaded image. Open the GRASS tools menu as in Task 4. 
Navigate to File Management >Import raster into GRASS> Import Raster 
into GRASS from QGIS view> r.ingdal – Import loaded raster

2. Select the loaded raster you wish to import to GRASS. Click Run then 
View Output. 
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3. Now we can use GRASS to create a hill shaded model. In the GRASS tools 
menu navigate to Raster> Spatial Analysis > Terrain Analysis> Shaded 
Relief

4. Add the raster map from the drop down menu, give your output map a 
name. For now leave the default values for the Altitude and Azimuth of 
the sun. Click Run and wait for the tool to finish (the bar at the bottom of 
the window will turn green and show 100%). Close GRASS tools.
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5. To add the hill shaded raster to QGIS use the Add GRASS Raster Layer 
icon.

6. Wilson (2000) recommends that archaeological features are best viewed 
in low light levels. We will now re-run the hill shade altering the altitude 
of the sun to <30 degrees (the default level).  Repeat Steps 1-4 opening 
the Shaded Relief tool. Alter the altitude value in the box highlighted. 
Save the raster with the new altitude as part of the name for quick 
reference e.g. hillshade1_10.
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7. By switching these layers on and off in the navigation bar examine the 
differences between them in terms of the visibility of features. Has the 
visibility improved unilaterally? What hampers visibility in this image?
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8. We will now look at the impact of altering the direction of the sun. Repeat 
steps 1-4 to open the Hill shade tool. In the Azimuth box change the 
value to 0 (i.e. North). Save the raster with the new azimuth as part of 
the name for quick reference e.g. hillshade1_N and re-run the processing.

9. Once again by comparing this layer with the previous hill shaded images 
what can be said about the differences / similarities between them? Is the 
visibility of features strongly dependent on the direction of illumination?

10. Once you have decided on an “optimal” altitude and azimuth for 
your hill shade model rerun the process on the other raster images and 
display them all together in QGIS. How does the tiling of this data affect 
your interpretations of the archaeological features?
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Task 6 – Digitising Archaeological features from a hill 
shaded image.

We are now going to look at how you might record archaeological features. This 
task is technically quite simple repeating the vector file creation and editing we 
undertook in task 2 but requires you to plan what exactly you wish to record 
about a feature. 

Before we create a new file we need to decide the attributes that it should have 
and how to standardise our recording so that we can mine the data for our own 
research aims and crucially so that others can understand it. There is a lot of 
information on this topic mostly relating to Historic Environment Records.  A 
good starting point for ensuring compatibility are the FISH INSCRIPTION 
wordlists which can be found here http://www.fish-forum.info/i_lists.htm.

Use the space below to think about the type of information you would like to 
record about a feature from the lidar. Think about both its metric properties and 
its interpretation. Each of these pieces of information will become an attribute.

Once you have decided what you wish to record you need to think about how 
you will map it. There are three digitising options here - point, line and polygon 
(though of course you can map features in more than one file to take 
advantages of different types if you wish). Think carefully about the aims of 
your research before choosing  - if you will need to record the area of a feature 
this will not be possible with a point or line.

Armed with these decisions you are now ready to start digitising!

1. Click on the Create New Vector icon

2. Select the type of shape file you wish to create. Add the Attributes you 
wish to record (ensure you get the correct type of field e.g text, whole 
number, integer). (TIP: use the instructions in Task 2 to remind yourself 
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how to do this)

3. Click OK to create your shapefile and use the toggle editing to begin 
digitising features.
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Session 2 – 11.30 – 13.00

The aim of this session is to introduce GRASS as a tool for processing lidar data. In this 
session you will undertake the following tasks:

• create a new raster for the study area by combining existing tiled rasters
• import lidar point data
• create an interpolation from lidar point data.
• Export your work in a variety of formats (ESRI, geotiff)
• look at some new techniques for modelling lidar data (LRM and SVF)

Task 7 – Opening GRASS

1. We will now leave QGIS for a while and take a look at GRASS GIS directly to 
undertake a number of more complex processing tasks. First open the GRASS 
wxpython GUI using the icon on your desktop

2. You will need to navigate to the Location and Mapset you created in QGIS during 
lab 1. When you have browsed to the directory select the location then the 
mapset. Then click “Start GRASS”
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3. Grass will then open two windows as shown below. On the left is the Map 
Display where graphics are displayed, to the right is the GIS or Layer Manager 
where layers are added and modified and where the menus are found for each 
function. 

4. First we will add a vector and a raster to the display. In the GIS Manager click on 
the Add Vector Icon in the same window and select the vector file representing 
the study area that you created in the first session (GRASS_area).

5. Then click on the Add Raster icon and pick a raster from the drop down menu.

Your screen should now look something like the image below. 

6. By right clicking on the layer name in the Layer manager window you can 
access the display options for each layer. Take a moment to explore these 
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options to improve the display.

Task 8 – Combining the Tiled Rasters
1. To improve the visualisation of the tiled lidar data it is possible to combine the 

lidar tiles supplied and re-run the hill shade analysis on the whole study area. In 
the GIS Manager navigate to Raster> Overlay Rasters > Patch Raster Maps.

2. The r.patch tool will be opened. Add the rasters you wish to patch (use the 
original rasters not the hill shaded models). Give your new raster a name and 
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run the tool. 
3. The new raster will be displayed in the map window

4. Next we will run the hill shade analysis. Navigate to Raster> Terrain Analysis > 
Shaded relief. Enter the base raster and the name of the output raster in the 
r.shaded.relief window. Choose your Altitude and Azimuth variables in the 
“Optional” tab. Notice here that you can also exaggerate the Z values of the 
data to enhance features. When you are happy with the variables selected, run 
the tool.

5. As before the new raster will be added to the display window. Use the 
navigation tools to explore the raster

Rebecca Bennett                 Lab 1 – Lidar Processing  34



4th International Summer School “3D Modeling in Archaeology and Cultural Heritage 2011”, 29 August - 4 September 
2011, Grosseto, Italy

Task 9 – Import Point Data
1. For this task we will look at a subset of the data so we need to set up a new 

region for our mapset. We will do this as in the previous lab by  importing a 
shapefile of our area of interest into GRASS. In the GIS manager window go to 
File> Import Vector Data> Common Import Formats

2. In the Import Vector Data window, navigate to the data folder in your 
Archaeology 3D directory and select the extract. Click Import to run the tool. 
Add the vector as a layer in the GIS manager and display it on screen.
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3. To change the region to match the extract area, navigate to Settings > Region > 
Set Region settings in the Layer Manager
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4. You will see that this opens the same Region tool window as in exercise 4: 12-17 
from the previous session. Change the region settings to match the “Extract” 
vector with a 1m NS and EW resolution. (Return to exercise 4 if you need to 
remind yourself how to do this. Click run.)

5. To check that the computation region matches the imported vector change the 
drop down menu at the bottom of the map display window to “show comp. 
Extent”. Tick the box to the left of the window and the region will be outlined in 
red. Notice that it does not exactly match the shapefile but uses the mix / max 
extent to create a bounding box.
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6. We will now import some lidar data in xzyi flight line data from a .txt file, shown 
below.
Each flightline has over 2 million data points so we will want to work only with 
those that fall within the region of interest. 

7. There are a number of ways to import point data in GRASS. For this tutorial we 
will import the point data to a vector file using v.in.ascii and then interpolate 
this vector to a raster. It is also possible to import the file directly to a raster 
using r.in.xyz but this method although quicker give less control over the 
interpolation technique.

8. Navigate to File > Import  Vector Data> Aggregate ASCII xyz import
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9. In the “Required” tab, add the lidar_point.txt file to be imported from Data 
folder in Archaeology 3D. Type in a name for your raster.

10.In the “Input Format” tab select point from the drop down menu. You will need 
to specify the format of your xyzi text file. Replace the standard Field Separator 
(the 'pipe' symbol “ | ”) with a space. 

11.In the “Points” tab, check the box to only import points in the current region. 
Check that the x and y columns are correct. We will first create an elevation 
raster so check that the data values are set to column 3. (If you wanted to 
create a raster of the intensity values you would change this to column 4)
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12.When you are happy with the variables run the tool. This will take a few minutes 
(no more than 3 on an average PC). The output window reports the number of 
points that fell within the current region points fell within the current area of 
interest. 

13.The point data will be automatically added to the layer manager and map 
window. 
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Task 10 – Interpolating the lidar points

1. Having successfully imported the lidar points our area of interest, we 
need create a continuous model by interpolating the point data into a 
raster. GRASS has a number of options for interpolating point data, we 
will use the simplest here an Inverse Distance Weighted interpolation. 
The choice of model you create is important as it will affect the accuracy 
of your results – more information for each of the interpolation methods 
this can be found on the GRASS wiki

http://grass.itc.it/gdp/html_grass63/v.surf.idw.html

http://grass.itc.it/gdp/html_grass63/v.surf.rst.html

2. Navigate to Raster > Interpolate Surfaces > Bilinear and Bicubic from 
vector points
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3. IIn the v.surf.bspline tool select the input vector file. Choose the vector 
data to interpolate, leave all the settings unchanged in the “settings” 
tab. In the “Optional” tab enter the output raster name. Run the tool.

Remember the resolution of the raster created is determined by the 
region settings, not in this tool!

4. Display the raster and take some time to explore it in the Map Display 
window.

5. To check the metadata of the raster you have created go to Raster > 
Reports and Statistics > Report Basic File Information. Add the raster file 
and run the tool. The results will show the method of interpolation and 
the resolution of the raster.

6. Finally create a hill shade of the raster as in Task 8.4. Compare this with 
the results of the hill shade for the pre-gridded ESRI ASCII data used in 
session 1. What do you notice about the quality of the results? Which 
method is preferable as the base data for hill shaded models?
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Task 11 – Using the GRASS profile tool 

In this task we will look at the profile tool to examine features. When digitising 
features from hill shaded images it is important to understand their topography 
i.e. are the positive or negative features. The best way to do this is by drawing 
a profile across the feature.

1. In the map display window click on the profile tool and select “Profile 
surface map”

2. In the profile window select the lidar_all elevation map. Note you can 
select up to three maps to compare with the same profile.

3. Click on the draw transect icon (in the “profile analysis” window). 

4. In the Map Display window, click and drag to draw a transect over the 
mound feature. Then click on the Draw Profile icon (in the Profile analysis 
window) to draw the profile. The results are shown on the next page

5. Repeat this  procedure for other features in the raster until you are 
familiar with the tool. 

6. Use the add raster map icon to add the shaded relief model created in 
Task 10. Why is this view not very helpful? Close the profile tool.
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7. To visually compare rasters of different scales more efficiently open two 
profile tools. They will automatically draw the same profile. What do you 
notice about the shaded relief model's representation of the topography 
compared with the original DEM?
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Task 12 – Checking the resolution of the point data

1. When receiving lidar in point cloud form it is advisable to check the 
resolution of the data. In GRASS you can do this quickly by creating a 
raster map of the number of points per cell. First we will import a sample 
area on which to work from the shapefile Density. Navigate to  File > 
Import Vector Map > Multiple Formats using OGR. Add the shapefile 
Density.

2. Change the region settings to match the Density vector using Config > 
Region > Change Region settings. In the resolution tab set the North-
south and east-west resolutions (cell size) to 1

3. We will now create a raster that illustrates the number of points per cell. 
Navigate to File > Import Raster > Aggregate ASCII xyz

4. In the r.in.xyz tool navigate to the .txt file with the raw lidar data. Enter a 
name for your output file. In the Statistic tab change the statistic for 
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raster values to n

5. In the Input tab, change the separator to a space and leave the rest of 
the settings as default. Run the tool.

6. Now we will look at how many point were found per cell. Navigate to 
Raster > Reports and Statistics > General statistics

7. Add the raster map in the Options tab. In the Print tab check Print Cell 
Counts and run the tool

In the output window you will see the results of the cell count. What does 
this tell you about the quality of the data at 1m resolution? At what raster 
resolution would you have a point in every cell? 
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Task 14 – Exporting GRASS data

GRASS is able to export vector and raster data in many formats including ESRI 
(grid and shapefile), Matlab (.mat), DXF, KML, text file and Tiff. Most of the 
options for export are found in File > Export Raster Map  > Multiple Formats 
using GDAL or File > Export Raster Map > Multiple Formats Using OGR. Some 
like the ESRI grid require separate tools which are also listed in the menus  File 
> Export Raster / Vector Map.

In this task we will export both vector and raster data. The key thing to 
remember is to ensure that the region of interest is configured to encompass 
the whole of the data you wish to export. 

1. First we will export the DTM raster we have just created into an ESRI 
(ArcGIS) raster. In the GIS manager navigate to File > Export Raster Map 
> ESRI ASCII Grid

2. Select the file to export and chose a location and name for the ESRI 
raster. Append the file with .asc or .txt
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3. The ascii file created can now be read by ArcGIS. Open ArcGIS and in the 
tool box navigate to  Conversion Tools > To Raster > ASCII to raster tool.
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4. We will also export the filtered vector points as a text file. Navigate to File 
> Export Vector Map > ASCII Points or GRASS ASCII Vector

5. Add the vector to be exported and give the export file a name (appended 
with .txt)
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6. In the Points tab, choose the field separator you wish to use (the default 
is “|” )

7. The .txt file created can be opened in Excel or OpenOffice Calc.  In Excel 
navigate to File > Open. Change the file type to csv.

8. Choose Delimited and click next
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9. Select the delimiter (in this case a space) and click finish to view the 
data.
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Task 14 – Advanced Data Processing

Recently two techniques have been published that are designed to help view 
lidar data in a way that is more conducive to mapping microtopographic 
changes without the bias of hill shading.

Sky Factor Modelling

Kokalj, Z., Zaksek, K., and Ostir, K. 2011. Application of sky-view factor for 
the visualisation of historic landscape features in lidar-derived relief models. 
Antiquity 85(327): p.263-273.

SVF is a visualisation technique based on diffuse light. The product is a 
representation of the total amount of light that each pixel is exposed to as the 
sun angle crosses the hemisphere above it. Consequently the model is not 
dependent on sun direction (unlike hill shading)

A stand alone SVF module can be downloaded from http://iaps.zrc-sazu.si/?
q=en/svf. You can use the raster exported from GRASS as the input for this 
module

The SVF can also be modelled in GRASS using the tools Raster > Terrain 
Analysis > Horizon (r.horizon) angle and combining the results of  modelling at 
different angles using the raster calculator Raster > Raster Map Calculator 
(r.calc).

Local Relief Modelling

Hesse, R. 2010. LiDAR-derived Local Relief Models - a new tool for 
archaeological prospection. Archaeological Prospection 18(2).

LRM was developed for mountainous regions and produces a model where the 
affect of the macro-topography is reduced while retaining the integrity of the 
micro-topography. The model process requires several stages. All of these can 
be run in GRASS using a combination of tools. In order to make the process 
easier, a GRASS script will be published at the end of the year allowing users to 
automate the process. Please email r.bennett@bournemouth.ac.uk if you would 
like to receive notification of this release.

LRM Model Stage GRASS command

1 low pass filter r.neighbors

2 subtract low pass filter from DTM r.mapcalc

3 extracting zero contours r.mapcalc (to create a raster where 
the Low pass and DTM both equal 0)
r.to.vect (to convert this to a vector 
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file)

4 interpolating purged DTM v.surf.bspline

5 subtract purged DTM from original to get 
LRM

r.mapcalc

We will explore these two models in GRASS and compare them to the shaded 
relief and original DTM.

1. Import the geotif LRM and SVF models from the data folder using File> 
Import Raster Data > common import formats.

2. Terrain maps are often best analysed in grayscale rather than colour. To 
edit the properties of the LRM and SVF right click on the file in the Layer 
Manager and click on “set colour table”

3. Take some time to experiment with the colour options for each raster
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4. Use the Profile tool (Task 11) to compare the models over archaeological 
features. Notice particularly the z units. What conclusions can you draw 
about the different modelling techniques?

Rebecca Bennett                 Lab 1 – Lidar Processing  56



4th International Summer School “3D Modeling in Archaeology and Cultural Heritage 2011”, 29 August - 4 September 
2011, Grosseto, Italy

Useful Information / Resources

A how to list for QGIS.... http://dl.dropbox.com/u/2858167/Selected%20How
%20To_withEmail.pdf

The QGIS forum - http://forum.qgis.org/ full of lovely helpful people.

The QGIS project homepage http://www.qgis.org/

The GRASS wiki - http://grass.osgeo.org/wiki/GRASS-Wiki     particularly the lidar 
page http://grass.osgeo.org/wiki/LIDAR

GRASS reference manual, http://grass.itc.it/gdp/html_grass63/index.html for 
detailed information, sources and usage tips on each of the tools.

GRASS tutorials http://grass.osgeo.org/gdp/tutorials.php

The GRASS users mailing list - http://grass.ibiblio.org/community/support.php 
check the archives for useful tips

The GRASS bible – hard work to get through at times but 
certainly the most comprehensive guide to using GRASS

Markus Neteler and Helena Mitasova, 2008,
Open Source GIS: A GRASS GIS Approach. Third Edition.
The International Series in Engineering and Computer 
Science: Volume 773. 406 pages, 80 illus., Springer, New 
York
ISBN: 038735767X | ISBN-13: 978-0-387-35767-6 | eBook
e-ISBN-13: 978-0-387-68574-8
Published 1st Nov. 2007 

OSGeo http://www.osgeo.org/ - a portal for all thinks OS and Geographical in 
the UK

OSGeo4W - http://trac.osgeo.org/osgeo4w/ where to download QGIS and GRASS 
for Windows

OS GIS Professionals...

For examples of how OSGeo software is being used commercially in 
archaeology and heritage management - 

http://thehumanjourney.net/index.php?
option=com_content&task=view&id=316&Itemid=201  

And Finally...LAS Tools

The current version of GRASS does not have native support for las files (though 

Rebecca Bennett                 Lab 1 – Lidar Processing  57

http://thehumanjourney.net/index.php?option=com_content&task=view&id=316&Itemid=201
http://thehumanjourney.net/index.php?option=com_content&task=view&id=316&Itemid=201
http://trac.osgeo.org/osgeo4w/
http://www.osgeo.org/
http://dx.doi.org/10.1007/978-0-387-68574-8
http://www.springer.com/east/home/geography/gis+cartography?SGWID=5-40421-22-173664736-0
http://grass.ibiblio.org/community/support.php
http://grass.itc.it/gdp/html_grass63/index.html
http://grass.osgeo.org/wiki/LIDAR
http://grass.osgeo.org/wiki/GRASS-Wiki
http://forum.qgis.org/
http://dl.dropbox.com/u/2858167/Selected%20How%20To_withEmail.pdf
http://dl.dropbox.com/u/2858167/Selected%20How%20To_withEmail.pdf


4th International Summer School “3D Modeling in Archaeology and Cultural Heritage 2011”, 29 August - 4 September 
2011, Grosseto, Italy

GRASS 7 will) LASTOOLS provide a comprehensive set of tools for converting 
las files and clipping them to your study area before importing them to GRASS.

http://www.cs.unc.edu/~isenburg/lastools/ 
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