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Life on the Report Tool Frontier: Rolling Your Own Reports in 
OpenOffice.org
Solveig Haugland  June 2007

My first professional job was as a technical writer for Great Plains Software in Fargo, North Dakota. 
My first major assignment was to document the report writer module of the accounting software 
package, so I walked over to the lead programmer’s desk and said, “Hey, Steve, could you bring me up 
to speed on this whole grouping thing?” 

Steve leaned forward, his eyes wide. “All right,” he said. “But,” and he paused and he looked at me 
very seriously, “have you had calculus?”

Luckily, it turns out I didn’t need to remember my calculus in order to know how to just use the report 
writer.  Programmers always want to explain how the clock works, when all you want to know is the 
time.

If you were going to come up to me and say, “Solveig, could you tell me how to do some really cool 
stuff with reports in OpenOffice.org?” I might just lean toward you, look you straight in the eye and 
say, “All right, but do you know SQL?”

Now, knowing SQ: isn’t crucial. And what you need to know is pretty simple. But it is how you have 
to do the interesting stuff. For instance, printing the total of all values for a field on a report requires 
simple SQL. And multiplying two fields together, while very easy, is technically a SQL function.

Note: I want to assure you that simple stuff, like just printing the contents of a table or query, requires  
no SQL at all. Just the ability to press F4 and click and drag.

You’re going to expand your report-writing options if you think outside the wizard and are willing to 
do a little fiddling with some other windows. One allows you to drag the contents of a query or table 
into a Writer doc; the other lets you insert fields from, about, or which control, a table or query. I’ll get 
into those down the line in this article. 
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Here’s what I’m going to cover; the primary tools I think are important for getting creative with 
reports.

● A Quick Review of the Report Writer Tool—in which I’ll point out the key thing that is useful 
about the wizard.

● What You Can Do in the Query Design Tool and SQL View—not technically specific to reports 
but useful on them.

● What You Can Do With Report-Specific Fields—how to add calculated fields to any report 
document.

● Quick-and-Dirty Reports—printing the contents of a table or query in the blink of an eye.

● Creating Your Own Reports Using the Next Record Field—this gives you a bit more control 
over formatting.

A Quick Review of the Report Writer Tool
To use the report wizard, open the .odb database file containing the data you want. Click the Reports 
icon at left, then click the item labeled Use Wizard to Create Report.

Select the table or query (just one per report) that you want to use, then insert the fields. If you need to 
combine fields from two tables or queries, you need to create a query containing them before you 
create the report. Click Next.
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Follow the wizard through. At the grouping window, you can group the information by one or more of 
the fields.

When you’re done, the report looks like this. The grouping is set up by Item ID, as I specified in the 
wizard. The grouping is a nice feature of the report writer; everything else is just the convenience of the 
wizard interface, and templates. (If you’re able to add page numbers to footers, and you don’t need clip 
art, the templates aren’t that much of an advantage, either.)
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The report wizard doesn’t actually create any new data for you; no totals or averages, no nothin’. It’s 
just about the arrangements. So anything you want to print that’s beyond the data in the table, you need 
to do:

● before creating the report, in the query

● or after creating the report, with a calculated field

What You Can Do in the Query Design Tool and SQL View
When you enter information about a sale, or an employee’s 401k contribution, you don’t usually enter 
amounts that are calculations. You don’t enter the unit price and the quantity, and then also enter the 
total amount. You don’t enter the employee’s salary and their 401k contribution percentage, then also 
what actual amount that works out to. The software generally does the calculation.

UnitPrice QuantityPurchased TotalAmount
[entered] [entered] [calculated]

If you want to be able to have calculated information, on a report or just available in the database, you 
need to create that calculation in a query or view.

Luckily, it’s easy. Open your  .odb database file, and click the Queries icon or the View icon. Then 
either edit an existing query by right-clicking on it and choosing Edit, or click the option to create a 
query or view in design view. I’ll be using queries in this example.

You’ll see this window. For the purpose of this example, let’s say I’m creating a new query.

Select at least one table and click Add. Then double-click each field that you want to have in the query 
just as is, reflecting the data without doing anything about it. (You don’t have to; your query can be 
entirely composed of calculations based on fields that aren’t even in the query.)
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I want this query to show the invoice ID, the date, and the total amount of the invoice. So I’m going to 
add that calculation. All I need to do, in the area where a field name would normally show, is to type 
fieldname*fieldname and press Enter. You could put double quotes around the fieldnames but you 
don’t have to; Base will add them automatically.

If you want to, you can type an alias for the new field, like TotalAmount, in the field below the 
calculation.
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Run the query, and it looks like this.

To add formatting, right-click on the fieldname and choose Column Format. Select the formatting you 
want from the window that appears, then click OK.

If you want to see this query or any query in SQL, just choose View > Switch Design View On/Off.

Of course, multiplication isn’t the only thing you can do. Here are some very basic but useful 
examples. In each, when an alias is mentioned, creating the alias is optional. You can’t easily refer to 
aliases in subsequent calculations, so the purpose of using an alias for the calculated field is to make 
your query or report look more professional.
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Task In Design View (syntax) In SQL (syntax) In SQL (example)
Concatenate 
two fields

“fieldname”+”fieldname” (fields 
will be added if they are both 
numeric values)

“fieldname” + 
“fieldname” AS alias

“InvoiceID” + “Date” 
AS “FullIdentifier”

Add the value 
of one column 
in one record 
to the value of 
another 
column in the 
same record

Same as concatenation; just be 
sure that both fields are numeric.

Multiplication, 
subtraction, 
and division

Same as addition. Be sure both 
fields are numeric.

Sum the value 
of every 
record of one 
field.

Select the field and in the 
Functions line, select the SUM 
function. (If there are other 
fields to the left of this field, 
select GROUP as the function 
for all of them.)

Select SUM(fieldname) 
FROM tablename AS 
alias

SELECT SUM( 
"Quantity") FROM 
"Invoices" AS 
"Invoices"

Get the 
average 
maximum, 
minimum,or 
count of the 
values in a 
column

Same as Sum, but use the 
appropriate function:
MAX
MIN
COUNT
AVG

What You Can Do With Report-Specific Fields
In the last section, I talked about how to sum all the values for a particular column using SUM. 
However, when you do that in a query—well, it doesn’t really work. A query shows multiple records. 
And SUM just gives you one value that applies to the whole set of values. This looks a little weird, to 
see the total for the whole query, next to every invoice ID.

Another issue is that SUM, at least in the designer, will not give you the sum of all the values, if you 
have any other fields in the same query. Here’s an example.

This works fine—but there’s just the one field, the sum of all the items purchased.
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This doesn’t show the total I want; it just shows the total per invoice.

So what do you do if you just want the total (or average, or maximum) for all the information in the 
report, just printed once at the bottom or top of your report?

You create a calculated field on the report document itself, using the fields usually reserved for creating 
forms. You can do this on reports created with the wizard, but not with the approaches covered in the 
next section.

1. Create your report.

2. Close it and save it. Click the Save icon in the report database. The right-click on the name and 
choose Edit to open it again and edit the layout.
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3. You’ll see the report. 

4. Choose View > Toolbars > Form Controls. If most of the icons are dimmed, click the Design View 
icon to switch to design view so you can use the controls.

5. Click the More Controls icon, then in the More Controls toolbar palette that appears, click the 
Numerical Field icon. You’re going to draw a field.
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6. Scroll over to where you want the field. Draw it, making sure to draw it outside the table. 

7. Right-click on the field and choose Form (not Control—not yet.)

8. In the Form Properties window, click the Data tab and type the following command.

Syntax
Select SUM (field you want to sum) as name you want to give this field from query or table that 
the report is based on

Example
Select SUM (TotalPrice) as TotalForReport from InvoiceWithTotalPrice

page 10



Be sure that the Analyze SQL Command field is set to Yes.

9. Close the window.

10. Right-click on the field and this time choose Control.

11. In the Control Properties window, click the Data tab and type the name you gave this calculated 
field. In this example, it’s  TotalForReport.

12. In the General tab, specify a thousands separator, if you want, then set any formatting options.
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Close the window.

13. Close the report, saving changes, then click the Save icon in the database window. This is 
important; if you don’t save before re-running the report, you won’t see the field.

14. Double-click the report name. The report will open and you’ll see the field. Re-edit the report as 
necessary to change column widths, adjust the formatting of the field, etc.

You can create the fields at the top or bottom; use AVG, MAX, MIN or other functions; and so on.

Quick-and-Dirty Reports
Sometimes you just want to print your table or query, and you want to print it now. Here’s how to 
break land speed records.
1. Create a new text document.
2. Press F4.
3. Expand the database you want, the Tables or Queries item, and select the table or query you want.

page 12



4. Click the gray square at the left of the first fieldname. Click and hold down on it, and drag it into the document.

5. The following window will appear. Make the selection based on what you want in the report.

Fields
If you want the data to be fields that stays connected to the database, select the Fields option. Insert the fields you 
want, one by one. Type a space between each field, and press Return to go to the next line. Select a paragraph style if 
you want, then click OK. 

The data will appear, usually with a message saying the data is incorrect. It’s not; click the Data to 
Fields icon shown. 
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The data will appear correctly.

Text in a Table
Select the Table radio button. Insert any fields you want, then select  formatting options by clicking the 
Table or AutoFormat buttons.
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Click OK; the data will appear. The example here shows the formatting for the autoformat I chose.

Choose Table > Table Properties to modify the table.
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Just Text

Click OK; the data will appear.

You can search and replace spaces with tabs, then set tabs to align correctly. Press Ctrl F,  search for 
one or more spaces, click More and select Regular Expressions, and replace with /t.
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Creating Your Own Reports Using the Next Record Field
This approach is more useful if you have a specific layout you need to use, or if you simply prefer this approach. The 
drag-all-at-once approach from the last section is fine but the layout doesn’t look that good.

Let’s say you want to print a list of information like this, with tabs between the columns but not in tables. 

Name Address Birthday

John Bertram 401 East Mulberry June 21, 1964

Miranda Worthington 12 Ludlow April 9, 1971

Here’s what you do to get a nice layout, a connection with the database, and multiple records on the 
same page. You drag out each field separately, separating with tabs or whatever. You paste that row of 
fields to the next line, then you insert the Go to Next Record field in front of that second line. Then 
copy that second line all the way down the page. 
1. Create a new text document and press F4.
2. Click the + icon to expand the database and table or query you want to use.
3. Create some headings and set the tabs as appropriate. And, for a reason that will become clear in a second, press a 

tab before you type the first heading. It should look like this.

4. Click on the first field you want—the title of the field, not the data. Drag it into your document under the first line 
of headings.
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5. Press Tab and drag the next field into the document. Keep going until you’re done.

6. Select the entire line. Copy it, press Return at the end of the line and paste it. You now have two lines of fields, and 
all lines have a tab preceding them.

7. Click at the beginning of the second line of data, before the tab.

8. Choose Insert > Fields > Other. In the Databases tab, in the Type column select Next Record , then select the 
database and table or query you’re using, and click Insert.
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9. The field appears, but only as a faint gray field. This is why you created the tabs, so that you could see the inserted 
Next Record field. If you insert it next to another field, it’s difficult or impossible to see, and difficult to be sure 
you’ve selected it.

10. Now it’s time to copy that line down through the rest of the document. Copy the line with the Next Record field 
preceding it, and copy it until you’ve filled the document.

11. Click the gray square indicated, to preview your data.
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12. Click the Data to Fields icon. You’ll see the data in the document. The gray Next Record field won’t print.

Powerful Reports Can Be Fun....If You Enjoy Getting Your Hands Dirty
Feeling a little tired? You should. This is kind of a typical OpenOffice.org process—you can do lots of 
advanced procedures, but it’s not obvious, and there are several approaches, each with its own benefits 
and drawbacks. That’s life on the frontier of office suites. My advice is to make the best of things until 
the report tool gets a bit more civilized—slap on that an imaginary coonskin cap, and enjoy it. 
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