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What We’ll Cover 
1. Enabling database connections through Microsoft Excel 

2. Accessing the data stored in the SQL Database via the MS Query Tool.  

3. Preparing a Word Document for use in a Mail Merge 

4. Defining fields for use in the merge document 

5. Selecting records for the Mail Merge 

6. Finalizing the Mail Merge and printing the document 

7. Creating labels through Mail Merge function 
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Defining the Data Source 
The first step in creating a mail merge is defining the data source.  In these examples, we will create a 
simple query using Microsoft Excel and the MS Query tool to mine the data for the Mail Merge. 

1. Open Excel and access the “Data” tab.  Select Get Data > From Other Sources > From Microsoft 
Query. 

     

2. Select the database from the available data connections.  (If the Use Query Wizard option is 
checked, uncheck it now) 
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3. Log in with the appropriate user ID and Password for the selected Database. 

      

4. Select the appropriate table from the “Add Tables” list.  In this example, we are going the choose 
the Customers table. 
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5. Once the table has been selected, we will choose the appropriate fields from the table.  Double click 
on the following  fields within the table selection screen. 
• Customer_id 
• Name 
• Address_1 
• Address_2 
• City 
• State 
• Zip_Code 
• Contact 
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6. Once the fields have been selected, click the Return Data to Excel button on the toolbar. 

      

7. Place the data in Cell A1 in the Excel Spreadsheet. 

      

     Your resulting data should look like the example below: 
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8. From the “Data” tab on the ribbon, select Connections. 

 

9. Select the [Properties] button for the selected query. 

      

10. On the “Usage” tab of the Connections Properties box, select “Refresh Data When Opening File.” 
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11. On the “Definition” tab, selecet the option to Save the Password with the query. 
12. You will receive a friendly warning from Microsoft about saving the password. Click Yes to save the 

password along with the query. 

      

 

You may now save the Excel spreadsheet.  This will become our data source for the Mail Merge 
Document in Word. 

Make a note where the file is saved, as we will require this location in a step in the future. 
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Creating Merge Fields 
In the following steps we will create the merge fields within an existing document. Once the Mail Merge 
is complete, the process will replace the merge fields with the appropriate fields from FOUNDATION’s 
database. 

Note: When creating the document, leave space for the customer name and address information, along 
with the customer contact information. 

 

Once the document is created, we will initiate the Mail Merge Genie to step through the process of 
inserting the fields and attaching the data source (the Excel Spreadsheet created in the first step).  

 

 

 

 

 

 

Leave space for the 
Customer information 
(name and address) 
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1. Open Microsoft Word and create a new document.  You may also use an existing form or document.   
2. From the “Mailings” tab on the ribbon, select “Step by Step Mail Merge Wizard.” 

You will notice a sidebar will appear on the right hand side of the document.  We are on “Step 3” 
because we are adding merged fields to an already existing document. 

 

3. Click on “Browse” under the Use an Existing List option on the right-hand sidebar. 
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4. Browse to the Excel document that was created to pull in the customer information. 

 

5. When you select the Excel file, Microsoft Word will prompt you to select which worksheet contains 
the data for the Mail Merge. 

In this example, we will select the data table on Sheet1.  Make sure the option “First Row of Data 
contains column headers” is checked. 
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Microsoft Word will show you a preview of the data selected from the data source. 

There are options here to Sort and Filter the list. 

 

6. Click [OK] to return to the merge document. 
7. In the lower right-hand corner, select “Next: Write Your Letter.” 
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8. Select the spot on the document where you would like to insert the first merge field. When ready, 
click on the the “Insert Merge Field” option from the “Mailings” tab on the ribbon. 

9. Click “name” to insert the Customer Name field into the merge document. 

 

        The result should look like the example below. 

 

10. Continue adding the rest of the fields.  Remember, cursor placement is important for inserting the 
correct fields.  You may add any required punctuation between the merge fields. (I.e., city, state, 
and zip code.) 

 

        Now thet the appropriate fields have been selected, we may now complete the merge. 
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11. In the lower right-hand corner, select “Step 4 : Preview your Letters.” 

 

You can preview the merged document and cycle through the recipients on the list using the buttons  
on the right-hand sidebar. 
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At this point, you can select individual recipients, or a number of recipients from the original data source 
by clicking “Edit Recipient List” on the sidebar to the right. 

 

The mail merge will create a document for any and all records that are selected with a checkbox in 
the Mail Merge Recipients window. 

12. If you are satisfied with the layout of the merge document and the selected recipients, select step 5 
of 6, “Next: Complete the merge.” 
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13. At this point, you can select the “Print” option.  All of these merged documents will print.   

 

14. If you are still unsure about the number of letters that will be printed, you can select the option to 
“Edit individual Letters.” 

15. You will be prompted to choose which records to merge.  Select “All” to review all of the merged 
documents/recipients. 
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     This will create a new document titled Letters1 with separate pages for all of the documents. 

 

Note that this example has created a new document with 63 individual pages based on the selected 
recipients.  At this point you can  edit the individual letters without effecting the main merge 
document. 

You can also print certain pages from the merged document if you did not select the correct 
recipients. 

     You can save this document. This is not the merge file, it is the result of the merged document. 
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Data Source Option #1 
If you save the original document, this file will be available to pull in the data from the linked Excel file at 
a later date. 

When you re-open the document you will be prompted with a message that notifies you that the Word 
document is linked to an external source.  

1. Click “Yes” to repopulate the Word document with the list of recipients shown on the original Excel 
file.  If new records have been added to FOUNDATION, you will need to open the Excel document to 
refresh the query and pull in new records. Once the file has been opened, you may close the file and 
save the changes. 

     

2. Once you have opened and refreshed the query in Excel, select “Edit Recipient List” to open the 
Recipient selection window. 
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3. Highlight the data source in the lower left-hand corner and click the refresh button to update the 
recipient list. 

 

4. You are now ready to complete the mail merge with the updated data.  Click the Finish & Merge 
button to access options to print or save the merged document as a new file. 
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Data Source Option #2 – Saving and Accessing a Query 
1. Open the Excel Document that was created for the customer list.   

 

 

 

5. Once the file is saved, close out of the MS Query tool and close out of the Excel document. 

  

2.  Right-click on a cell within the data 
table. Choose Table > Edit Query to 
access the Query mode. 

 

3.  Once in the MS Query tool, select 
File > Save. 

4.  Name the query with an 
appropriate title that you will be able 
to remember later. Save it in the 
default folder if the file is to be used 
on a local workstation. If this 
document is to be shared, the Query 
file will need to be saved on a shared 
network drive. 
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6. Open the mail merge document, and access the “Mailings” tab from the ribbon. Choose the Select 
Recipients > Use Existing List option. 

 

7. On the Select Data Source window, choose the query that was just saved from the MS Query tool. 

 

8. Click “Open” in the lower right to select the data source. 
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9. You will be prompted to enter the user ID and password to access the query. 

 

10. Microsoft Word will then prompt you to reopen the query every time the Mail merge document is 
opened.  Click “Yes” and continue with your mail merge.   

 

The Data source is now connected to the Query as opposed to the Excel File. This removes the need to 
open and update the Excel file before opening the mail merge File. 

Currently, there is no way to save the password within the query, so every time the Word Document is 
opened, you will need to enter the user ID and password to refresh the data within the query.  You will 
be greated with the following message upon opening the file.  Select yes, and then enter the password 
for the query to refresh the recipient list.   

Which method is best ? It quite simply depends on which you are more comfortable with. 
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Creating Mailing Labels through Mail Merge. 
You may create mailing labels using the same mail merge functionality. Create a new Query, or use an 
existing Data Query as the Data Source. For this example, we will use the Customer_Query created for 
the previous lesson. 

1. Start by accessing the “Mailings” tab on the ribbon and choosing Start Mail Merge > Labels. 

 

2. Select the appropriate label number from the available options. The lower right-hand corner shows 
you the size and dimension of the selected label.  Click [OK] to continue. 
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Your document will now be formatted in the selected label format. 

3. Choose Select Recipients > Use Existing List.   

 

4. Select the appropriate Data Source and click [Open] in the lower right-hand corner. Depending on 
the Data Source, you may receive a prompt to log into the query and/or you may be asked to refresh 
the query every time the file is opened. 

 

       Your document will now look like the example below: 
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5. Now it is time to enter the Merge Fields.  From the ribbon, select Insert Merge fields. 

 

6. Select the required fields for your document.   
Note: spacing and font size may need to be adjusted to fit all of the data on the same label. 

  

7. Once the layout is created, select “Update Labels” from the Mailings ribbon. 
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       Admittedly, the document does not look like much.   

8. Select the Finish & Merge > Edit Individual Documents. 

 

9. You will be prompted for what range you wish to view. Select “All” and click [OK]. 

 

Voila !  A new document is created with the Merged Recipients that you may save and print. 
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Remember to save the original document which is the template for the merge.  This document will 
always be in a pending state, waiting for you to select the recipients for the merge. 

 

Again, depending on the data source, you may be prompted for the user ID and login for the query. The 
alternate method explained in the original lesson would require you to open the Excel document to 
refresh the list before you open the mail merge file. 

So, What can be done with Mail Merges?  Some examples that have been created for current 
FOUNDATION clients: 

• Inventory item labels with Item ID/Description/UPC Code/Bin Location 
• Custom subcontract forms 
• Employee/Job/Vendor file folder Labels 
• Request for Certificates of Insurance from vendors 
• Job folder contact information labels with full address information for the job and customer with 

contact and order information.  
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