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Collaborate effectively on 
3D design data

Reliable data exchange with CAD 
software is important throughout 
the design process.  Autodesk 
Alias helps solve  CAD integration 
issues  by providing fast, high-
quality data exchange with 
Autodesk® Inventor® software. 
By working closely together, 
designers and engineers can 
effectively address both aesthetic 
and functional requirements to 
develop the best design solution.

Style, form and function all influence a customer’s choice of products.  These days, your customers want 
innovative designs for less, requiring you to be as efficient and productive as possible.  It’s not enough to just 
use the latest 3D tools anymore.  In today’s highly competitive market, collaboration between design and 
engineering teams is essential.  By working closely together, designers and engineers can effectively address 
both aesthetic and functional requirements to develop the best design solution.  

The Autodesk solution for Digital Prototyping, which includes the Autodesk® Alias® family of products 
and the Autodesk® Inventor® product line  brings together design data from all phases of the product 
development process to create a single digital model, enabling industrial designers and engineers to design, 
visualize and simulate their products.  

This white paper introduces the interoperability between Autodesk® Alias® and Autodesk® Inventor®.     
The interoperability between Alias and Inventor helps industrial design and engineering professionals 
communicate more effectively by directly reading native Alias WIRE files into Autodesk Inventor. Alias files 
can now be associatively or non-associatively opened in Inventor, which mitigates potential translation errors 
into generic 3D file formats (i.e. STEP or IGES).  In addition, the associative link between Alias and Inventor 
is very powerful; industrial designers are able to maintain their original design intent throughout the entire 
development process and engineering is able to leverage the industrial design surfaces without rebuilding the 
model.

Design and Engineering 
Collaboration with 
Autodesk Alias
and Autodesk Inventor



AUTODESK® MANUFACTURING WHITE PAPER

2Design and Engineering Collaboration with Autodesk Alias and Autodesk Inventor

Building Alias Geometry for Inventor

To achieve the tolerance required by solid modeling, it is important to 
manage the construction units and tolerances when creating your model. 
Most engineering organizations have developed standards for tolerances 
that they apply to their CAD systems.   If you are not clear as to which 
standards your company or clients use, seek out your CAD system 
manager for more information. 

For efficient data transfer from Autodesk Alias to Autodesk Inventor 
software, it is important to set the correct Construction Options before 
the modeling begins. 

The Inventor preset in the Construction Options (Preferences > Construction Options) is a good starting 
point and should suffice for most users. There are times that might require the user to fine tune these 
settings such as changing between imperial and metric units.   By Creating a Copy of the default Inventor 
Preset, the user will be able to modify the settings. 

 
 
Evaluating the Geometry in Alias

Before exchanging data with the engineering team it is essential to validate the quality of the model to find 
any potential problems that might appear downstream in the development process.  Within Alias, users 
have the ability to check the model globally or per-surface.  The following tools are the most common for 
validating data quality prior to data transfer. 

Check Model

Palette > Evaluate > Check Model
The Check Model tool allows you to check for potential problematic conditions - chose either “all of the 
visible” or “selected” geometry.  Additional Check Model options are offered in Alias Surface and Alias 
Automotive software products.  

Autodesk Alias Family of Products 

Autodesk® Alias® Design

Tailored for consumer products designers, it pro-
vides all the tools you need to explore concepts, 
refine concept models, create realistic imagery, 
develop high-quality surfaces, and share data 
with engineering teams.

Autodesk® Alias® Surface 

Evolve concept models and scan data into 
high quality production surfaces for consumer 
product designers. Create Class-A surfaces for 
automotive design and styling with Autodesk® 
Alias® Surface modeling software. Designed for 
virtual modelers, the software offers dynamic 
modeling capabilities for developing, refining, 
and controlling shapes. 

Autodesk® Alias® Automotive 

Autodesk® Alias® Automotive is an industry-
leading application for automotive design and 
styling, and the choice of the majority of auto-
motive styling studios throughout the world. 
The software provides a comprehensive set of 
visualization and analysis tools for the entire 
shape-definition process, from concept sketches 
through Class-A surfacing.

TIP Model Verification
Test geometry created in Alias to predict and di-
agnose problems when transferring to Autodesk 
Inventor
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In the screenshot below, Check Model has red-flagged a potential problem that needs to be addressed. 

Surface Continuity

Palette > Evaluate > Continuity > Surface Continuity
The Surface Continuity evaluation allows users to check the 
relationship between two surfaces based on the position 
(G0), tangent (G1), and curvature (G2) continuity.  Green 
indicates that the continuity is acceptable between surface 
patches and yellow would indicate that the continuity is not 
within tolerance. This feature can also be activated within 
the surfacing tools so adjustments can be made prior to 
exiting the tool.   

Stitching

Palette > Surface Edit > Stitching 
The Stitching tool typically is used to stitch surfaces together to create a solid topology shell.  It can also be 
used as a quick way to verify if the data will easily stitch or shell in Autodesk Inventor.  Gaps or edges will 
show up in yellow when selected.  

In the image below, the red arrows are pointing to the open edges of the surface model.  If the arrows and 
yellow lines are within the model, then the surfaces would need to be investigated and corrected to make a 
valid solid. 

 

 
 

 
 

Take your 3D models to the next level.  Evolve 
concepts through a creative, iterative process.  
The concept development phase demands 
close collaboration between designers and 
engineers to produce concepts that are new, 
yet technically feasible. 

Key Benefits of Design and Engineering  
Collaboration

1.  Create production-quality geometry that can 
move back and forth between Alias Design and 
Autodesk Inventor for collaborative product 
development. 

2.  Design and engineering teams can work 
together so both aesthetic and functional 
requirements are addressed when developing 
design solutions. 

3.  Create sketches at real-world scale, and draw 
over imported Inventor data to ensure design 
feasibility. 

4. Verify the quality of created surfaces, includ-
ing curvature and radii analysis, to help ensure 
that geometry can be used by Autodesk Inven-
tor. 

5. Test geometry created in Alias Design to pre-
dict and diagnose problems when transferring to  
Autodesk Inventor 



AUTODESK® MANUFACTURING WHITE PAPER

4Design and Engineering Collaboration with Autodesk Alias and Autodesk Inventor

Using Alias Data within Inventor

Open > Import of Place Component 
The Alias file format, WIRE can be selected when you use 
Open, Import or Place Component. 

When a WIRE file type is selected, several options are 
available to determine how Inventor will import the data.  
The options can be found at the bottom of the file 

Option Details
Import Type

•	 Associative Import (recommended method) 
Select the check box to import the Alias file and maintain as-
sociativity between the Inventor file and the Alias source file. 
If changes are made to the Alias file after import, the Inventor 
file will allow for automatic updates. If Associative Import is 
selected, all other options in the dialog box are unavailable and 
do not apply.

 
 
 

•	 Non-Associative Import  
Select the check box to import the Alias file without associa-
tion to the Alias source file.  This method is for users that want 
to manually redefine Alias surface features in the development 
cycle. 

Save Options
•	 Save Components during Load  

Select the check box to save the component files in Autodesk Inventor format during the import process. 
Choose where to save the components from the drop-down menu. If you choose to Select Save Locations, 
the Component Destination folder becomes available. This setting is not available when the Import com-
mand is used.

•	 Component Destination Folder   
Sets the location for the component files created from the import operation. If Save in Workspace is 
selected, this folder is defined in the Edit Projects panel.

  
Entity Types to Import
•	 Solids 

Select to import solid bodies and water tight stitched shells as individual solid bodies

•	 Surfaces 
Select to import surface bodies. Water tight stitched shells are imported as solid bodies

•	 WIRE Files  
Select to import WIREs

TIP
Specify file destinations that are included in the 
active project or add the paths to the project to 
assure that referenced files resolve when you 
open a file.

Our Alias surfaces are so 
high-quality we can go straight 
to tooling. We’re cutting our 
turnaround time on projects 
tremendously --which helps us 
get to market faster.
—Kurt Bender  
  Design and Engineering 
  Viking Yacht Company
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 Data Organization
•	 Create Surfaces As 

Select the surface types to create during the import. Choose from:

•	  Individual Surface Bodies  
To import each surface as a single surface body in the part environment.

•	  Single Composite Feature 
To import the surfaces as a single composite in the part environment.

•	  Multiple Composite Features 
To import the surfaces as multiple composites in the part environment.

•	 	Single Construction Group
To import the surfaces as a single group in the construction environment.

•	  Multiple Construction Groups 
To import the surfaces as multiple groups in the construction 
environment.

•	 Group Name to Place Data 
Select a group name for the imported data. The group name will show in the browser. 

 
Units
•	 Import Units  

Converts the imported geometry and parameter values to the selected units.

 
Post Processes
•	 Check Parts during Load  

This quality check of the imported data is automatically performed when you select to create surfaces as 
composite features. It is not performed when you select to create surfaces as construction groups. If bad 
data is found, the composite is marked within the browser and the remaining bodies are not checked.

•	 Auto Stitch and Promote  
When selected, Inventor attempts to stitch surfaces into a quilt or solid. If the surfaces are stitched into 
a single quilt or body, the resulting quilt or body is promoted to the Part Environment. Otherwise, the 
surfaces remain in the Construction Environment.

•	 Enable Advanced Healing  
If selected, slight alterations in the surface geometry are allowed to stitch the surfaces.

Checking Surfaces in Inventor

Once you have successfully opened a WIRE file 
in Inventor you need to make sure that Inventor 
doesn’t have any issues with the surfaces so you 
will need to perform a quality check in Construction 
Mode.

Copy the target surfaces into the Construction.  
Expand the Alias WIRE file icon in the browser and 
right click on the surface icon and select “Copy to 
Construction”

We have chosen the right 
products from the Autodesk 
Digital Prototyping product 
portfolio. With them, we create 
3D CAD models, high-end 
visualizations and animations, 
simulation results, and rapid 
prototyping models.
—Christian Sperka 

CIO 
Franke
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Activate the Construction Mode.    
Double click the Construction folder in the browser and it will activate a new Construction tab in the ribbon.  
You can now perform the quality check.

Click on Quality Check.  Select your Alias surfaces and click examine.  

The quality check will either show no issues (image on the left) or will show the “known issues” (image on 
the right).  If there are errors, the software will indicate the type of error and provide suggested repair steps.  
 
 

 
 

Click on Finish Construction
If there are no errors found in the Alias surface geometry you can return to the modeling environment and 
continue to work on creating the solid body.  Clicking on “Finish Construction” in the ribbon will return you 
to the modeling environment.

TIP
•  Construction Mode inside Inventor also has 

a number of surface editing capabilities such 
as: reverse normals, create boundary patches, 
extend faces, stitch, unstitch, etc.

•  The Quality Check dialog box will tell you how 
many bodies are selected for examination.  

TIP
Once you exit the construction environment, 
turn off the visibility of any surface geometry.  
This will ensure that you do not have any surface 
artifacts on the display of your solid body once 
it has been created.  You can also return to the 
construction environment if you need to copy 
or reference any of the original surfaces for 
solid features creation, such as extend “up to” or 
“terminate at”.
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Converting Surfaces to a Solid

Select File to Open or Import. The Derive Part interface will appear allowing you to select only the 
geometry or layers that are required.  Selecting the top item will open all available geometry. 

Only visible layers in Alias will be accessible by Inventor.

The Stitch feature can be found in the modeling section of the ribbon bar.  This feature will quilt or stitch the 
surfaces together to be a single feature.

 
At this point in the design, the surfaces can now be used with many of the Inventor features.  For example, 
you could  change/add to the part thickness with the “Thicken/Offset” feature found in the Modeling 
section of the ribbon bar.

In the past, we would receive 
storyboards from 
external industrial design firms. 
Now, industrial designers 
send surface models designed in 
Alias software to us and 
we bring them directly into 
Inventor. Our mechanical 
engineers are actudesigning 
around these surface models.  
—Dave Bosworth 

Manager, Enterprise Engineering Systems 
Parker Hannifin Corporation
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Once your model is a Solid Part feature, it can be used with all Inventor tools and simulation functionality. 

Updating the Alias Association
Global Update
Use the following workflow to update your Inventor model when the original Alias model has changed. 

 
Open the part to be updated in Inventor.  Look for the global update notifications in the feature tree and in 
the title bar.  

 

 
Selecting the Update Notification in the title bar will either update the associativity automatically or will 
allow you to manually update the association.

Original Updated

Original Updated

Alias Design helps us
bring our products to the
marketplace in less time.
It is an essential part of
our business and keeps us
ahead of the competition.  
—Marcus Ting 

Founder and Designer 
Sumajin Pte. Ltd.
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Using Update Association
If a caution icon appears after performing an update, then there is a feature that cannot be automatically 
resolved.  Often this is because the number of surfaces has changed.   

•	  Update Association 
Right Mouse Button (RMB) on the WIRE Feature and choose “Update Association”. 
 

•	 Match the Surfaces 
The surfaces must be matched or removed from the feature associations in order to proceed.  For 
example, in the image below, let’s say the number of vents has changed so the extra surfaces of the vent 
in the original will need to be removed from the associations.    
 
Use the “Match” option to link the remaining surfaces. 

 

 
 

TIP
Often there will be features that remain in the 
browser that no longer are required.  These 
can be “deleted”.

By embracing Autodesk Inventor 
and using it to create digital 
prototypes, we were able to take 
the development timeline from 
roughly 18 months to 9 months. 
In addition to the time savings, 
there’s a tremendous amount 
of money saved and benefits to 
be gained just simply getting to 
market sooner.  
—Jason Faircloth 

Product Manager 
Marin Bikws
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Building Sculpt Geometry with Alias Surfaces

A surface developed in Autodesk Alias can be used to cut a volume in Autodesk Inventor. This capability is 
useful to add complex characteristics, such as creating organic shaped parting surfaces for Inventor.

After the surfaces have been imported into Autodesk Inventor, select the surface, and from the “Model” tab 
of the ribbon bar,  choose Surface > Sculpt.

Surfaces are imported to trim the Controller Housing

 

Results from Sculpt surface feature

Alias reduces the gap between 
design and engineering.  The 
early visualization allows us to 
explore more extreme shapes as 
well as to sell our best ideas to 
the marketing groups.  
—Alan Hocknell 

VP Innovation and Advanced Design 
Callaway Golf Company
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Importing Inventor Data into Alias

Inventor .IAM and .IPT files can be imported directly into Autodesk Alias. 

The file can be opened or imported in several ways in Alias:

•	 Choose File>Open to open the file into a new scene or stage.

•	 Choose File>Import>File to add the data to an existing scene.

•	 Drag the file from Windows® Explorer to open the file to a new scene or stage.

Once you bring the solids in as stitched surfaces, the objects can be selected as a standard Alias object and 
assigned to layers as normal. 

 
Referencing Inventor Data into Alias

Inventor .IAM and .IPT files can be translated into a reference file using the Alias Reference Manager.  The 
Reference Manager, File > Reference Manager,  converts the data into a separate file and allows it to be 
rapidly loaded and unloaded without adding to the host file size.

Benefits include
•	 Fast loading and unloading of large data sets 

•	  Pre-Optimized files are only referenced into Alias so they will not add to the file size.

•	  Surfaces can be promoted or imported as needed. 

•	 Variations	can	be	easily	managed

Create a Reference File
Reference Manager > File > Translate
Translate the Inventor file into a reference file prior to importing into Alias.  This will generate a WREF file 
with the desired tessellation values.  These settings affect the quality of the shading and display of the WIRE 
frame. 

TIP
Warning: If the imported construction settings 
are different from the current construction 
settings, Autodesk Alias will prompt you to 
either “Keep Current Settings” or “Accept New 
Settings”. If your current settings are set up to 
your liking, then it is recommended to keep your 
current settings.   
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Import the Reference file.
Reference Manager > File > Import

Select the .WREF file to instantly display it in Alias.  

Selecting and Promoting Geometry
Palette > Pick > Reference 

Reference Manager > Edit > Promote Geometry

Once the entire data set has been referenced into Alias, you will most likely need to work with a few of the 
reference surfaces or parts in order to build additional details from these elements.   Your goal should be to 
only bring in the data you require to minimize the impact on file size and performance.  

Once promoted into Alias, these can be assigned to Layers as normal.   The rest of the reference data can be 
hidden until needed. 

TIP
•  The Reference Data can only be selected with 

the “Pick Reference” data tool.  
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Using Illustrations from Alias in Inventor

Import Autodesk Alias sketches into Autodesk Inventor to use as guides for building models. In this 
example, we will focus on a top view orthographic illustration. 

•	 Make sure that Canvas_Top is selected in the Windows>Construction Plane Editor. 

•	 Export the Canvas Picture 
File > Export > Make Canvas Picture > option box
Make Picture allows you to specify image size and preferred file format - JPEG, TIFF or BMP when export-
ing an image.  The “Blend With Background Color” will use the color of the modeling background to fill any 
transparent areas of the illustration.  

  

•	 In Inventor, open or create a new sketch and choose Insert > Insert Image.  If you get a message at this 
point asking if you want to use Microsoft® Paint as your default editor, click Yes or the software will not 
import your image.  

•	  The cursor is attached to the upper-left corner of the image. Click in the graphics window to place the im-
age.

 

TIP
To create a TIFF with an Alpha Channel, the  
“Blend with background color” feature must be 
turned OFF.

Autodesk Alias Design helps us 
bring our products to the
marketplace in less time.
It is an essential part of
our business and keeps us ahead 
of the competition.  
—Marcus Ting 

Founder and Designer 
Sumajin Pte. Ltd.
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2D Drawing Support in Alias

Autodesk Alias supports DWG™, DXF™ and exporting of DWF file formats.

Most of the drawing data is supported by Alias and will load as curves. This includes the Sheet Frame and 
Dialogs, Dimensions, and many more.  Dimensions are not recognized   as such in Alias so they do not 
display values.

In Inventor, use File>Save Copy As.  In the Save as Type menu, choose either AutoCAD Drawings (*.dwg) or 
DXF Files (*.dxf) options. 

Conclusion

Design and engineering teams no longer have to struggle to collaborate on 3D design data. Working 
collaboratively helps to solve integration problems by providing fast, high quality data exchange between 
Autodesk Alias and Autodesk Inventor software.  

The Autodesk solution for Digital Prototyping enables manufacturing workgroups to create a single 
digital model that can be used in every stage of production, bridging the gaps that usually exist between 
conceptual design, engineering, mechanical design, electrical controls design, and manufacturing teams.

Design, visualize and simulate your design before producing a physical prototype to better enable 
collaboration and innovation. You’ll save time and money, design better products, and beat your 
competition to market.

TIP
DWG and DXF files load with cm default units 
(this means all the model’s dimension will be 
interpreted as being in centimeters). Depend-
ing on the original file units, you might need to 
adjust the size of the model by selecting it and 
scaling it accordingly in Alias.

The digital prototype allows 
teams to easily validate their 
designs against the work of other 
teams.   Designs progress more 
quickly and without collisions. 
With Digital Prototyping, our 
watch movements and cases are 
largely refined during design, 
so we produce just one physical 
prototype instead of three.  
—Pierre Gygax 

Executive Vice President of Production 
Ulysse Nardin
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Appendix
How Solid Modeling Works

The following information provides more detail about the concepts of solid model data types.  This 
information is helpful in understanding how geometric and topological data work together to form a 
complete model.

•	 Geometric Data 
Surfaces contain the geometric data of a solid model. The geometric data describes the basic shape of an 
object and can be represented using NURBS.

•	 Topological Data 
Loops, edges, and vertices contain the topological relationships between the individual surfaces that 
form the solid model. Topological data describes how the geometric components are connected together. 
In solid modeling terminology, surfaces are called faces, and each face is made up of loops, edges, and 
vertices. 

Tolerance Requirements for Solid Modeling
To achieve the tolerances required by CAD applications, it is important to use the appropriate modeling 
units and tolerances when creating your model. Alias offers preset tolerances and settings for various 
engineering-based CAD systems which can be further modified if required. These settings should be 
selected prior to beginning work as they affect the creation and evaluation of surfaces, curves and trimming 
operations.

Get the Topology Right before Transferring Data
The Surface Edit > Stitch tools in Alias creates a valid solid model topology. Creating solid geometry from 
imported Alias models is a common workflow when integrating Alias and CAD systems. Prior to exporting 
the model from Alias, you must ensure that the geometry is built to the correct tolerance and that it can 
be stitched. Stitching in Alias identifies gaps between surfaces so that you can repair the geometry before 
exporting the file.

During the stitching process, surfaces are modified from their original state.  Modifications include deleting 
of construction history, the splitting of boundaries to accommodate adjacent surfaces, and splitting periodic 
geometry into multiple surfaces.  For this reason, you should either “Keep Originals” found in the Stitching 
tool or save the file before stitching so you have the option of keeping the construction history intact.

Importing Data into a Solid Modeler
When you import an Alias model into a solid modeler, the data must satisfy the solid modeler’s rules for 
topological and geometric data in order to produce a valid part. 

The topology of a model defines how each surface relates to all other surfaces in the model. The important 
element of getting the topology right for data exchange to solid modelers is that an edge on one surface 
must have a twin edge on the adjacent surface. Edges are defined by natural surface boundaries or trimmed 
surface boundaries.

You can transfer surfaces and complete the stitch procedure in a CAD system or first stitch them in Alias 
and then export the data.

Rational and Non-Rational Geometry
In the Constructions Options dialog box, you can specify whether the new geometry being created will 
contain rational or non-rational components for primitives, fillets, and curves/surfaces.

Non-rational geometry assumes all CVs weight equals “1.0”. Rational geometry allows each CV to carry its 
own weight. The different weighting of the CVs allows the shape to be an exact radius value. It is acceptable 
to convert non-rational geometry to rational geometry, but not the other way around.  The shape would 
change if the weights are all made to 1.0 when converting from rational to non-rational.

For example, if you build a circle with non-rational geometry with a radius of 100mm, when the radius is 
measured the actual value is allowed to float within a tolerance near 100mm. For rational geometry, the 
result would be exactly 100mm.  However, some CAD systems may only allow non-rational geometry. So if 
Alias users create models in rational geometry, their results in those systems will change the shapes. Since 
Inventor supports rational geometry, there is not a concern for Alias users. They can create models rational 
or non-rational. 
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About Autodesk Alias 
The Autodesk® Alias® product line ― Autodesk Alias Design, Autodesk Alias Surface and Autodesk Alias 
Automotive ― addresses the unique creative requirements of the entire industrial design workflow.  Part of 
the Autodesk Solution for Digital Prototyping, the product line provides a comprehensive and powerful set 
of tools for conceptual design, surface definition and design realization. Optimize your design process with 
industry leading sketching, modeling, and visualization tools that quickly help you bring ideas to reality.  For 
more information about the Autodesk Alias family of products go to www.autodesk.com/aliasfamily.  

About Autodesk Inventor
The Autodesk® Inventor® product line  provides a comprehensive and flexible set of software for 3D 
mechanical design, simulation, tooling creation, and design communication that helps users cost effectively 
take advantage of a digital prototyping workflow to design and build better products in less time. Autodesk® 
Inventor® gives engineers the ability to integrate AutoCAD and 3D data into a single digital model that can 
be used to validate the form, fit, and function of a design before it is built. By enabling engineers to design, 
visualize, and simulate their products digitally, Inventor helps teams communicate more effectively, reduce 
errors and deliver more innovative product designs. To learn how Autodesk Inventor takes you beyond 3D to 
Digital Prototyping, go to www.autodesk.com/inventor.


