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Metasys System Extended 
Architecture Graphics Stencil 
Library

Introduction 
This document describes the GSL and how to use the GSL to make 
background drawings for Metasys® system extended architecture 
graphics. 

This document describes how to: 

• install the GSL 

• use the GSL in Visio® 2002 

• use the hide label and hide value boxes functions 

• import an AutoCAD® file for use as a floor plan graphic 

• modify an imported AutoCAD file for use as a floor plan graphic 

• create a floor plan graphic from an AutoCAD file - alternate 
method 

• import SVGZ files to the User Graphics Tool (UGT) 

• bind data to a Metasys system extended architecture graphic using 
the UGT 

• edit, copy, and paste a Metasys system extended architecture 
graphic value box format 

• implement aliasing 

In addition this document provides information on the limitations of 
the GSL and on improving performance when using the GSL. 



 Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical Bulletin 4 

Key Concepts 
Graphics Stencil Library Overview 

The Metasys system extended architecture Graphics Stencil Library 
(GSL) is a set of Visio Stencils, Templates, and add-ons (including 
Gzip, a compression utility), used with Microsoft® Visio Professional 
2002 to create graphics for use in your Metasys system. Use the GSL 
to create Visio Extensible Markup Language (XML) drawing files 
(VXD) that the GSL then allows you to convert to SVGZ. The SVGZ 
files created with the GSL in Visio 2002 are then imported into the 
User Graphics Tool (UGT) in the Metasys system extended 
architecture. The templates included in this library are listed in  
Table 1. 

System Requirements 
To install the GSL successfully, your computer must be running 
Windows® 2000 Professional with Service Pack 3 (SP3) or 
Windows XP with SP1, Java® Runtime Version 1.3.1, and Microsoft 
Visio Professional 2002 software. 

Scalable Vector Graphics 
The Scaleable Vector Graphic (SVG) file format is an XML-based 
Web standard and is viewable and editable within any text editor, 
much like Hypertext Markup Language (HTML) documents. An 
SVGZ file is a compressed SVG file. The World Wide Web 
Consortium (www.w3.org) maintains the SVG specification. Although 
the SVG specification defines mechanisms for dynamic and animated 
SVG graphics, at Release 1.1 of Metasys system extended architecture, 
all graphic backgrounds are static images. 

Microsoft Visio Professional 2002 
The GSL is designed to work with Visio Professional 2002. At this 
time only a few major drawing packages (such as CorelDRAW® 
software and Adobe® Illustrator® software) support SVG natively. 
However, Visio Professional 2002 software includes a stencil sheet 
mechanism that greatly enhances the ease of use of the GSL. For this 
reason, an add-on to Visio Professional 2002 software was created that 
can translate Visio Professional 2002’s XML save file format into 
SVG XML. 

Visio Professional 2002 software was selected to improve the speed of 
graphics generation. 



 Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical Bulletin 5

Templates and Stencils 
The GSL provides a set of stencils used to create drawings in Visio 
Professional 2002. Each stencil consists of a set of related shapes. 
Several templates (Table 1) are installed with the GSL. These 
templates are drawings created in Visio Professional 2002 using the 
stencils from the GSL. The templates provide a starting point to help 
you create drawings quickly.  

The Template Library 
The GSL has Shapes and Templates for common Air, Water and Floor 
Plan graphics. Table 1 contains a list of the templates installed by 
GSL. 

Table 1: GSL Installed Templates 
Template Name in 
Visio Software 

Full Name of Template Notes 

Base Template Base Template.vtx Contains only the standard framing for 
Johnson Controls® graphics. All other 
templates are based on this template. 

Base Water Template Base Water Template.vtx Use this template for customer Heating, 
Ventilating, and Air Conditioning (HVAC) 
water graphics. 

1ChlrCWS 1ChlrCWS.vtx  
1ChlrCWSFreeCooling 1ChlrCWSFreeCooling.vtx  
1ChlrPriCHWS 1ChlrPriCHWS.vtx  
1ChlrPriCHWSFreeCoolin
g 

1ChlrPriCHWSFreeCooling.vtx  

2ChlrCWS 2ChlrCWS.vtx  
2ChlrPriSecCHWS 2ChlrPriSecCHWS.vtx  
2StmHXHotWater 2StmHXHotWater.vtx  
3Boiler Hot Water 3Boiler Hot Water.vtx  
Computer Room AC Computer Room AC.vtx  
Fancoil Fancoil1.vtx  
Fancoil Alternate Fancoil2.vtx  
MADP MADP.vtx  
MASP MASP.vtx  
Network – 50 VAVs Network – 50 VAVs.vtx  
Network – Ethernet Network – Ethernet.vtx  
Network – N2 Devices Network – N2 Devices.vtx  
OADP OADP.vtx  
OASP OASP.vtx  
VAV Dual Duct VAV Dual Duct.vct  
VAV Dual Duct with EC VAV Dual Duct with EC.vct  
VAVDual Duct with HC VAVDual Duct with HC.vtx  
VAV Parallel Fan VAV Parallel Fan.vtx  
VAV Series Fan VAV Series Fan.vtx  
Continued on next page . . . 
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Template Name in 
Visio Software (Cont.) 

Full Name of Template Notes 

VAV Single Duct with 
3WHC 

VAV Single Duct with 3whc.vtx  

VAV Single Duct VAV Single Duct.vtx  
VAV Single Duct with EC VAV Single Duct with EC.vtx  
VAV Single Duct with HC VAV Single Duct with HC.vtx  

 

Shapes 
Each stencil consists of a set of related shapes. Many shapes have 
built-in labels. These labels have a control handle (the control handle 
appears as a yellow diamond when a shape is selected [Figure 1]) to 
move them around the page. 

 

Figure 1: Label Handle on a Shape 
Some stencil shapes have custom properties and entries on their 
right-click menus. The label text can generally be set using one of the 
custom properties (Figure 2). 

 

Figure 2: Custom Properties on a Sensor 
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User Graphics Tool 
The Metasys system extended architecture includes a User Graphics 
Tool (UGT) that accepts SVGs, SVGZs, or Joint Photographic Experts 
Group (JPG) files for background images. 

Graphics provide a visual representation of the monitored systems. 
They enable you to quickly check the status of systems and recognize 
unusual conditions. You can design graphics to allow you to navigate 
through buildings, floors, and other areas, viewing building systems 
and control processes. 

User graphics are usually made up of three parts: 

Background Image 
Backgrounds are static images displayed behind a graphic. 
Backgrounds can represent buildings, floor plans, mechanical 
equipment, and any other image that represents the location or 
function of the equipment in the graphic. A newly-created graphic has 
a gray background by default. You can insert a background image 
using a file based on SVG, SVGZ, or JPG graphic formats. 

You can create SVG background images with graphic drawing 
packages or from established libraries of images. We recommend 
using Microsoft Visio 2002 software to create background images that 
can be converted to SVGZ format. SVGZ and SVG images must be 
created in positive drawing space (quadrant 1, on the positive X and 
positive Y axis). 

Background images in JPG format are usually created with cameras or 
scanners. You cannot resize a UGT background image in JPG format, 
and if an area of the graphic’s workspace is not fully covered by the 
JPG image, the exposed area defaults to gray. 

Symbols 
Symbols are graphic elements or components that are inserted into 
graphics to represent the value or status of equipment in your system. 
In the UGT’s Edit mode, the symbols appear in a pallet to the left side 
of the graphic workspace. 

Hyperlinks 
Hyperlinks allow you to navigate to other graphics and Web addresses. 

Note: If you are using hyperlinks to Uniform Resource Locators 
(URLs), you must change a setting in Microsoft Internet Explorer. In 
the Tools menu, click Internet Options…. On the Advanced tab, clear 
the check box for Reuse windows for launching shortcuts (Figure 3). If 
you do not clear this check box, the hyperlinked site appears in the 
same window as the Metasys software and the back button only takes 
you back to the Metasys login screen. 



 Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical Bulletin 8 

 

Figure 3: Internet Explorer Options - Advanced Tab 

GNU Zip (gzip) 
GZIP is an open source compression utility included with the GSL to 
compress SVG files. The compressed files have the file extension 
SVGZ. 

Drawing and Template Layers 
All the templates have a drawing layer and a template layer. The 
template layer contains the gray, blue, and black backgrounds as well 
as the Metasys logo. The template layer is locked by default to prevent 
accidental modification. The gray and blue backgrounds are hidden by 
default to display the grid lines. They are unhidden and re-hidden 
during the export process so that they appear in the SVGZ file. 

Note the following: 

• Visio drawings use points to emphasize that these are not scaled 
drawings. 

• The Page size is 723 x 535 points. This design criterion was made 
based on the following assumptions: 
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- The viewing screen resolution is set to 1024 x 768 points. 

- A single line Windows operating system task bar is visible. 

- The user interface window is maximized. 

- The Navigation Tree is attached and at its full size. 

• The water side GSL shapes are scaled to snap to a five point grid. 
All other GSL shapes are scaled to snap to a nine point grid. 

Special Shape Functions 
Many shapes have special functions that control the appearance of the 
shape. For example, the temperature element may be selected to 
display either a bulb type element or an averaging type element. In 
general, right-clicking on a shape reveals a menu of any special 
functions available. The most common special function is the Pick 
Sensor Type that controls the label text of the shape. 

Aliases 
Aliases allow a single graphic to be used for multiple typical 
mechanical systems. The most common use of aliases is in Variable 
Air Volume Controller (VAV) graphics. The alias process changes the 
values displayed in the value boxes to represent the particular system 
desired at the moment the graphic is displayed. 
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Detailed Procedures 
Installing the GSL 

To install the GSL: 

Note: Prior to installing GSL, Visio 2002 must be installed on your 
computer. 

1. On your install media (Branch Purchase Package), navigate to and 
double-click the GSL.msi file. The GSL setup wizard starts. 

2. Click Next. The Select Installation Folder screen appears 
(Figure 4). 

 

Figure 4:Select Installation Folder Screen 
Note: If you do not want to accept the default folder for 
installation, click the Browse button to choose another folder. 

3. Select whether the templates should be available to all users of the 
computer or just to you and click Next. The Installation 
Confirmation screen appears. 

4. Click Next to start the installation. When the installation finishes, 
the Installation Complete Screen appears. 

5. Click Finish to close. 
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6. To confirm the installation, start Visio 2002 Professional. The 
Templates folder should now contain folders labeled Air, Network, 
and Water, which contain the Graphics Stencil Library (Figure 5). 

 

Figure 5: Visio 2002 with GSL Installed 

Using the GSL in Visio 2002 
Note: One of the benefits of using the GSL to create drawings is 
that you can find a preexisting template that is similar to the drawing 
you want to create. You then modify the existing drawing as needed. If 
your needs vary a great deal from the existing drawings, use the blank 
template to create a blank drawing which has all the GSL stencils 
available, along with the standard Johnson Controls’ template 
background image.  

To use the GSL in Visio 2002: 

1. Start Visio 2002. The Choose Drawing Type screen appears 
(Figure 6). 
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Note: If the macro security setting in Visio 2002 is set to Medium 
(default setting), a Disable/Enable Macros message appears every time 
you open a GSL template. Set this option to Low to disable this 
message (Tools > Macros > Security). Do not leave this setting at Low 
if other people use your machine or if this setting violates your 
security policies. However, you must enable macros in order for the 
GSL to function properly. 

 

Figure 6: Visio 2002 Choose Drawing Type Screen 
2. Select a GSL template to start your drawing. A new 

template-based drawing appears (Figure 7). 
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Figure 7: New Template Based Drawing 
3. Modify the drawing as required by deleting unwanted shapes or 

dragging other shapes as needed from the stencils that are typically 
located on the left side of the Visio 2002 workspace. 

4. To make the generic labels more specific, select the Text button on 
the tool bar and click any label you want to change. 

Note: If you do not change, hide, or delete the labels, they appear 
in your final drawing as they appear in Visio 2002 software. However, 
when you bind data to a graphic, you are able to hide labels with data. 
See the Binding Data to a Metasys System Extended Architecture 
Graphic Using the UGT section in this document. Right-click on the 
page background to access master label and value box hide/unhide 
functions. There is also a graphics background hide/unhide function if 
you wish to edit the color of the normally hidden background. To do 
this, you also need to unlock the Template layer to select the 
background for editing. 

5. When you finish modifying the drawing, click the button labeled 
Export SVGZ on the upper right hand side of the GSL-created 
drawing. This button converts your drawing to a compressed SVG 
file in the same directory as the drawing from which it is being 
exported. 
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Note: If the drawing has not been saved already, select Save As on 
the File menu. On the Save As type drop-down list, make sure to select 
XML Drawing (*.vxd) and give the drawing a unique name. 

Using the Hide Label and Hide Value Boxes Functions 
At Release 1.1 of the GSL, all appropriate shapes have a label and 
value box symbol added to them. These indicators simplify creating 
descriptive text and assist with spacing issues. All labels and value 
boxes can be hidden in your graphic either individually or separately.  

To Hide Labels Globally 
To hide labels globally: 

1. With your drawing open in Visio Professional 2002, right-click on 
the Visio Professional 2002 drawing without selecting any shapes. 
The right-click menu appears (Figure 8). 

 

Figure 8: Visio 2002 Right-Click Menu 
2. On the right-click menu, select Hide Labels. All labels and setpoint 

descriptions in your drawing are hidden (Figure 9). 
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Figure 9: Labels and Setpoints Hidden Globally 

Hiding Value Boxes Globally 
To hide value boxes globally: 

1. With your drawing open in Visio Professional 2002, right-click on 
the Visio Professional 2002 drawing without selecting any shapes. 
The right-click menu appears (Figure 8). 

2. On the right-click menu, select Hide Value Boxes. All value boxes 
are hidden (Figure 10). 

Note: If you hide the value boxes before exporting an SVGZ file, 
you do not have to cover Visio value boxes exactly with Metasys 
system extended architecture value boxes. 
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Figure 10: Value Boxes Hidden Globally 

Hiding Labels and Value Boxes Individually 
To hide labels and value boxes individually: 

In your Visio Professional 2002 drawing, right-click on an individual 
shape and select Hide Label or Hide Value Box from the right-click 
menu. Only the selected shape’s value box is hidden from the graphic 
(Figure 11). 
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Figure 11: Visio 2002 Drawing with Individual Value Box Hidden 

Importing an AutoCAD File for Use as a Floor Plan Graphic 
To import an AutoCAD file for use as a floor plan graphic: 

1. On the Start menu, select Program Files > Johnson Controls > GSL 
> GSL Base Template. The GSL Base Template opens in 
Visio 2002. 

2. On the Visio 2002 Insert menu, select CAD Drawing. The Insert 
CAD Drawing screen appears (Figure 12). 
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Figure 12: Insert CAD Drawing Screen 
3. Browse to and select the AutoCAD file (.dwg or .dxf extension) 

with which you want to work. 

4. Click Open. The CAD Drawing Properties screen appears  
(Figure 13). 
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Figure 13: CAD Drawing Properties Screen 
5. Uncheck Lock position and Lock cropping in the CAD Drawing 

protection area of the CAD Drawing Properties screen. All other 
settings can remain at their default value. 

6. Click OK to continue. The CAD Drawing scale screen appears if 
the CAD drawing scale is different from the page scale  
(Figure 14). 

 

Figure 14: CAD Drawing Scale Screen 
7. Select the Continue without matching scale radio button and click 

OK. The AutoCAD drawing appears in Visio 2002. 
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8. Right-click on the imported AutoCAD drawing. On the menu that 
appears select CAD Drawing > Object > Convert. The Convert 
Wizard appears at Step 1 of 3 (Figure 15). 

 

Figure 15: Convert Wizard - Step 1 of 3 
9. Select the layers of the CAD drawing that you want to convert and 

click Next. The Convert Wizard - Step 2 of 3 screen appears 
(Figure 16). 

Note: Step 2 of the Convert Wizard shows you the layers of the 
CAD drawing file that are to be converted. After conversion you have 
the option of deleting or hiding these layers by selecting one of the 
three radio buttons on the right side of the screen. 



 Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical Bulletin 21

 

Figure 16: Convert Wizard - Step 2 of 3 
10. After reviewing the layers to be converted and selecting the 

appropriate radio button, click Next. The Convert Wizard - Step 3 
of 3 screen appears (Figure 17). 

 

Figure 17: Convert Wizard - Step 3 of 3 
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11. Keep the default selections as shown in Figure 17 and click Finish. 
The imported drawing appears in Visio 2002 (Figure 18). 

Note: You are now ready to modify the drawing for use in the 
Metasys system extended architecture. 

 

Figure 18: Imported AutoCAD Drawing in Visio 2002 
12. Continue with the instructions in the Modifying an Imported 

AutoCAD File for Use as a Floor Plan Graphic section of this 
document. 

Modifying an Imported AutoCAD File for Use as a Floor Plan 
Graphic 

Use this procedure on AutoCAD drawings imported using the 
procedure described in the Importing an AutoCAD File for Use as a 
Floor Plan Graphic section of this document. 

Note: For some AutoCAD files, typically larger sized files, 
following these instructions (along with the instructions that follow) 
do not produce the desired results. For these AutoCAD files, follow 
the additional instructions in the Creating a Floor Plan Graphic from 
an AutoCAD File - Alternate Method section of this document. 
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To modify an imported AutoCAD drawing for use as a floor plan 
graphic: 

1. On an imported AutoCAD drawing (Figure 18), click and drag the 
cursor to select all of the shapes converted by the import procedure 
described in the Importing an AutoCAD File for Use as a Floor 
Plan Graphic section in this document. 

2. Click the down arrow to the right of the line color tool and select a 
line color for your floor plan from the drop-down palette that 
appears. 

Note: Gray-25% works well for floor plans. 

3. Click the down arrow to the right of the Text Color tool. Select a 
color for your floor plan’s text from the drop-down palette that 
appears. 

Note: Black works well for text. 

4. On the Visio 2002 Shape menu, select Grouping > Group to group 
the converted objects. 

5. Resize the newly grouped objects as necessary by pressing the Ctrl 
key while dragging a corner of the drawing. Press the Ctrl key 
while resizing to ensure that the drawing is resized proportionately. 

6. On the Visio 2002 Tools menu, select Snap & Glue. The Snap & 
Glue properties screen appears (Figure 19). 

 

Figure 19: Snap & Glue Properties Screen 
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7. Make sure that Shape geometry (circled in Figure 19) is checked 
and click OK. This property helps to outline and provide a fill 
color for the floor plan. 

8. Select the Line Tool on the Visio 2002 tool bar. 

9. With the Line Tool selected, click a spot on the perimeter of the 
floor plan and trace the floor plan until you reconnect with your 
starting point. If you have a default color set for Fill Color, the 
shape takes on that color. Figure 20 shows a floor plan perimeter 
that has been traced and filled (fill color white) in this manner.  

Note: Pressing the Shift key while dragging out your line creates a 
straight line. You can change from the Line Tool to the Arc Tool as 
necessary to complete your shape by clicking the down arrow next to 
the Line Tool icon (circled in Figure 20). 

 

Figure 20: Floor Plan Perimeter Traced and Filled 
10. On the Visio 2002 Shape menu, select Order > Send to Back to 

send your shape to the back of the Visio 2002 drawing. The shape 
now appears behind the floor plan (Figure 21), which makes the 
floor plan stand out from the template background. 



 Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical Bulletin 25

 

Figure 21: Floor Plan Perimeter Traced and Filled behind Floor Plan 
11. Clean up the floor plan as needed and click the Export SVGZ 

button to create your SVGZ file. Consider removing detail from 
the floor plan to improve the display time for graphics. 

12. Add desired shapes from the stencils provided and follow the 
instructions in the Importing SVGZ Files to the User Graphics 
Tool (UGT) section in this document. See Figure 22 for an 
example of a floor plan graphic with shapes added. 

Note: If the floor plan background image does not appear as 
expected, follow the procedures in the Creating a Floor Plan Graphic 
from an AutoCAD File - Alternate Method section in this document. 
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Figure 22: Floor Plan with Shapes Added 

Creating a Floor Plan Graphic from an AutoCAD File - Alternate 
Method 

Note: For some AutoCAD files, typically larger sized files, the 
instructions in the Modifying an Imported AutoCAD File for Use as a 
Floor Plan Graphic section of this document do not produce the 
desired results. For these AutoCAD files, follow the extra instructions 
in this section. 

1. Right-click on the converted, grouped shape (Figure 18) in 
Visio 2002 and select Cut from the Edit menu. 

Note: Cutting the shape moves it from your drawing to the 
Windows operating system Clipboard. Do not copy or cut anything 
else before you paste this drawing or you may lose data. If you 
accidentally cut or copy something else to the Clipboard, try the Undo 
command on the Edit menu. 

2. On the Edit menu, select Paste Special. The Paste Special screen 
appears (Figure 23). 
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Figure 23: Paste Special Screen 
3. Select Picture (Enhanced Metafile) from the As: list box and click 

OK. 

4. With the shape still selected, open the Shape menu and select 
Grouping > Ungroup. 

Note: This action causes Visio 2002 to convert the enhanced 
metafile in to Visio shapes. 

5. On the Edit menu, click Select All. 

6. On the Shape menu, select Grouping > Group to group the 
converted shapes. 

7. Add desired shapes from the stencils provided and follow the 
instructions in the Importing SVGZ Files to the User Graphics 
Tool (UGT) section in this document. See Figure 22 for an 
example of a floor plan graphic with shapes added. 

Importing SVGZ Files to the User Graphics Tool (UGT) 
To import SVGZ files to the User Graphics Tool (UGT): 

Note: For information on using the System Configuration Tool 
(SCT) and the UGT, see the Metasys system online Help. 

1. Log on to the SCT. 

2. Open the archive to which you want to add SVGZ graphics. 

3. Select the location in the Navigation Tree where you want to store 
your graphic. 

4. On the Insert menu, select Graphic. The Insert Graphic Wizard 
opens to the Destination screen (Figure 24). 
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Figure 24: Insert Graphic Wizard Destination Screen 
5. If you have selected the location for your graphic, it appears as the 

default destination. If not, or if you have decided to place the 
graphic in a different location, select the destination for your new 
graphic and click Next. The Insert Graphic Wizard’s Identifier 
screen appears (Figure 25). 
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Figure 25: Insert Graphic Wizard Identifier Screen 
6. Give the graphic a unique name and click Next. The Insert Graphic 

Wizard Configure screen appears (Figure 26). 
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Figure 26: Insert Graphic Wizard Configure Screen 
7. Make sure the information on the Configure screen is correct and 

click Next. The Summary screen appears. 

Note: The Description and Object Category information is optional 
but can be used to help you remember the purposes for different 
graphics. 
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Figure 27: Insert Graphic Wizard Summary Screen 
8. If the information on the Summary screen is correct, click Finish. 

You are returned to the SCT user interface. 

Note: For verification, the Summary screen describes the 
information you entered in the previous steps of the wizard. 

9. On the Action menu, select Refresh all tabs to ensure that you can 
see your new graphic in the left panel of the Navigation Tree. 

10. Navigate to the newly inserted graphic and either double-click it or 
drag it to the right panel. The new, blank graphic appears in the 
right panel (Figure 28). 
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Figure 28: New Blank Graphic in SCT 
11. Click the Edit button in the right panel. The graphic opens to Edit 

mode (Figure 29). 
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Figure 29: New Blank Graphic in SCT in Edit Mode 
12. Click the Set Background Image icon (circled in Figure 29) in the 

right panel. 

13. Select SVGZ under File Type, navigate to the location of your 
SVGZ graphic, and select the SVGZ file you wish to set as a 
Metasys system extended architecture background image. The 
SVGZ graphic appears as a static background in your 
Metasys system extended architecture graphic (Figure 30). 
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Figure 30: SVG Background Added to a UGT Graphic 
14. Click Save in the right panel. Depending on the size of your 

graphic, you may need to scroll to the right or left to make the 
Save button visible on the Graphics toolbar. 

15. Continue to the Binding Data to a Metasys System Extended 
Architecture Graphic Using the UGT section in this document. 

Binding Data to a Metasys System Extended Architecture Graphic 
Using the UGT 

To bind data to a Metasys system extended architecture graphic using 
the UGT: 

1. Navigate to the graphic to which you want to bind data and either 
double-click it or drag it to the right panel. The graphic appears in 
the right panel (Figure 31). 
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Figure 31: Open Graphic in UGT 
2. Click the Edit button at the top of the panel. The UGT goes into 

Edit mode (Figure 32). 
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Figure 32: UGT Graphic in Edit Mode 
3. In the left panel, navigate to and select the objects you want to bind 

to the graphic symbol. In Figure 33 a Mixed Air Temperature 
object is selected (MA-T). 

Note: You can select multiple objects from the Navigation Tree at 
once by using the Shift key to select a range of objects or the Ctrl key 
to select individual objects. If you select multiple objects, dragging the 
graphic symbol into the Metasys system extended architecture graphic 
creates an array of symbols that are already bound to the objects 
selected. 
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Figure 33: Mixed Air Temperature Object Selected 
4. Click the symbol (for example, a button, a value box, a dynamic 

symbol, or a gauge symbol) on the left side of the right panel and 
drag it to the part of the graphic on which you want the object 
placed. If you have already selected an object, it is automatically 
bound to the graphic symbol. If you want a graphic symbol that is 
not automatically bound, make sure to deselect all objects in the 
Navigation Tree. 

Note: If the labels in the background graphic were not given actual 
names when created in Visio 2002, that is, the labels say Label1, 
Label2, etc… you can cover them using the text tool. 
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Figure 34: Mixed Air Temperature Value Box Placed by Mixed Air Damper 
5. To edit a value box in a graphic, select the Bind cursor (circled in 

Figure 34) and select the Metasys system extended architecture 
graphic symbol on the drawing that you want to edit. Alternatively, 
you can double-click the Metasys system extended architecture 
graphic symbol while in the Edit mode of the UGT. 

Note: The symbols in the background graphic are not selectable. 

6. Save the Metasys system extended architecture graphic. If you are 
online, the graphic symbols automatically update. If you are 
offline, you need to download or sync the database to get the 
graphic symbols to update. 

Note: If you have only added one graphic to a database, it is much 
faster to sync the database than to download the database. See the 
Load Wizard topic in the Metasys system online Help for more 
information. 



 Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical Bulletin 39

Editing, Copying, and Pasting a Metasys System Extended 
Architecture Graphic Value Box Format 

You can edit, copy, and paste the format of Metasys system extended 
architecture graphics value boxes. The following attributes can be 
copied and pasted using this feature. 

• size – length and width of value box 

• whether the value box should display Units and/or by Status 

• font, font style, and font size 

To edit, copy, and paste a Metasys system extended architecture 
graphic value box format: 

1. With your graphic open, double-click on a value box. The Binding 
Information dialog box appears (Figure 35). 

 

Figure 35: Binding Information Dialog Box 
2. Select whether you want the value box to display the bound 

object’s Units and/or Status (through color changes of the value 
box) by clicking the appropriate check box. 

3. Click the Properties button in the Binding information dialog box. 
The Choose Font screen appears (Figure 36). 
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Figure 36: Choose Font Screen 
4. Change the Font properties as necessary and click OK. You are 

returned to the Binding Information dialog box. 

5. Click OK to close the Binding Information dialog box. 

6. Right-click on the edited value box and select Format > Copy 
Format from the menu that appears. 

7. Press the Ctrl key and select each of the value boxes to which you 
wish to paste the format. 

8. Right-click on one of the selected value boxes and select Format > 
Paste Format from the menu that appears. All selected value boxes 
are updated. Figure 37 and Figure 38 show an example where 
multiple value boxes were selected and updated. 
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Figure 37: Pasting Formats into Selected Value Boxes 
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Figure 38: Fonts Updated in Selected Value Boxes 

Implementing Aliasing 
There are three steps to implement aliasing. 

1. Create a typical graphic whose value boxes are set up to handle an 
alias. See the Creating a Typical Graphic to Handle Aliases 
section in this document. 

2. Bind information to all aliases. See the Binding Information to 
Aliases section in this document. 

3. Create buttons in another graphic that link to the typical graphic 
and replace the alias with the desired, fully qualified reference 
string. See the Creating Linked Buttons section in this document. 

Aliasing in Metasys system extended architecture supports the 
following: 

• The ‘typical’ graphic can only contain points in a single field 
device. 

• Only one alias can be used. This is the * alias. The * symbol is the 
character in the binding string that is replaced by the button that 
causes the navigation to this graphic. 
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• Editing of a typical graphic is only enabled when that graphic is 
chosen from the Navigation Tree. Editing is not enabled when the 
graphic has been loaded from another graphic. 

Creating a Typical Graphic to Handle Aliases 
To create a typical graphic to handle aliases: 

1. Create an SVGZ file for a background image and import it into the 
UGT as described in the Using the GSL in Visio 2002 and the 
Importing SVGZ Files to the User Graphics Tool (UGT) sections 
of this document. 

2. Find a field device that matches your typical graphic configuration. 
For example, in the points from VMA-1, a VAV box with box 
heating, is selected (Figure 39). 

3. In the Navigation Tree in the left panel, select all the points from 
the system (in this case, VMA-1). 

4. With the points selected, click and drag a value box within the 
UGT in the right panel (Figure 39). An array of value boxes are 
created that are automatically bound to the points selected in the 
Navigation Tree. 

 

Figure 39: Adding Values to a Graphic in the UGT 
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5. Hover the cursor over each value box to identify and therefore 
place the value box appropriately (Figure 38). 

Note: Value boxes can be aligned automatically by selecting a 
value box and then choosing an alignment from the right-click menu. 
The first value box selected becomes the Master and all others selected 
can be aligned to that value box. 

 

Figure 40: Cursor over Value Box 
6. Follow the steps in the Binding Information to Aliases section in 

this document for each value box you have created. 

Binding Information to Aliases 
To bind information to aliases: 

1. Double-click the value box. The Binding Information dialog box 
appears (Figure 41). 

Note: If you are changing the attribute to a value other than 
Default, do so now. Once you change the Object string to an alias, you 
can no longer edit the attribute. 
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Figure 41: Binding Information Dialog Box 
2. Highlight the Object string or fully qualified reference to the left of 

the point just before the point’s name. In the example in  
Figure 42, all characters to the left of .DMPRPOS are highlighted. 

 

Figure 42: Binding Information Dialog Box with Object Reference 
Selected 

3. With the partial string highlighted in the Object field, enter an 
asterisk (*) to replace the reference. Figure 43 shows the object 
reference replaced with a wild card. 
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Figure 43: Binding Information Dialog Box - Object Reference Replaced 
with Wild Card 

4. Perform Steps 1 through 3 for each value box. 

5. Click Save. 

Note: When you hover your cursor over a value box, the alias 
string should now appear as in Figure 44. 

 

Figure 44: Verification of Value String in Value Box 
6. To make a title for the typical graphic that changes along with the 

link, first select a typical controller from the Navigation Tree and 
drag the Value box graphic symbol into the graphic. 

7. Double-click on the Value Box to open the Binding Information 
dialog box (Figure 45). 
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Figure 45: Binding Information Dialog Box 
8. Click the “…” button next to the current attribute to open the 

attribute dialog box. 

9. Change the attribute to Name and click OK. 

10. Highlight the entire Object fully qualified reference, replace it with 
an asterisk (*), and click OK. 

 

Figure 46: Binding Information Dialog Box with Object Fully Qualified 
Reference Selected 

11. Place and size the Value box to fit within the graphic title. Now 
complete the steps in Creating Linked Buttons. 
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Creating Linked Buttons 
The procedure that follows allows you to create buttons in another 
graphic that link to the typical graphic (see the Creating a Typical 
Graphic to Handle Aliases section in this document). This procedure 
also explains how to replace the aliases (see the Binding Information 
to Aliases section) with the desired, fully qualified reference string. 

To create linked buttons: 

1. In the SCT, either double-click the graphic to which you want to 
add buttons or click and drag the graphic to the right panel. 

2. Click the Edit button to enter the Edit mode of the UGT. 

3. In the Navigation Tree in the left panel, press Ctrl + click on all 
similar field devices and the typical graphic that represents them in 
the Navigation Tree. See Figure 47. 

 

Figure 47: Selecting Systems to Create Buttons 
4. With the field devices and the typical graphic selected, click and 

drag the Button symbol in the UGT into the drawing for which you 
are creating buttons in the right panel. An array of buttons is 
created, one for each item selected in the Navigation Tree 
(Figure 48). 
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Note: The typical graphic does not need a button. Delete the button 
created for the typical graphic. The button has the label of the typical 
graphic; in Figure 48 it is the button labeled VAV. 

 

Figure 48: Graphic with Array of Buttons Created 
5. Double-click one of the new buttons. The Hyperlink Information 

dialog box appears (Figure 49). 
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Figure 49: Hyperlink Information Dialog Box 
Note: The defaults for the Hyperlink Information dialog box  
Figure 49) are as follows: 

a. The Item radio button is selected. 

b. The fully qualified reference for the typical graphic selected in 
the Navigation Tree is entered in the Item field. 

c. The Hidden check box is not checked. 

d. The Alias check box is checked and the Alias field contains the 
fully qualified reference fo the field device that was selected in 
the Navigation Tree. 

6. Adjust the properties of the Hyperlink Information dialog box as 
needed and click OK. For example, you could check the Hidden 
check box so that the button could be placed over a VAV box in 
the background image and still display. 

7. Use the Zoom tools and button handles to resize buttons as 
necessary. When you drag a button handle, the button fill 
disappears to enable you to see the graphic beneath it for ease of 
placement. 

8. Add any value boxes as necessary and click the UGT’s Save 
button. 

9. Move the cursor over a hidden button; the cursor turns into a 
pointing hand. 
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Figure 50: Cursor over Hidden Button 
10.  Click on the hidden button to resolve your alias. The typical 

graphic loads. Now, when you hover the cursor over a value box, 
the alias is resolved and the tool tip reads the fully qualified 
reference of the point (Figure 51). 
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Figure 51: Alias Resolved - Tool Tip Shows the Fully Qualified Reference 
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Troubleshooting 
Limitations 

Many drawings need some level of custom drawing beyond what is 
provided in the GSL. Keep in mind the following limitations of the 
SVGZ export mechanism: 

• The generated SVG is completely static. No features such as 
animation, layer hiding/unhiding, or pop-up windows are possible. 

• No Visual Basic for Applications (VBA) from Visio 2002 software 
is preserved in the output file. 

• Text support is limited to single line text blocks, vertically and 
horizontally centered. 

• Defined Visio styles are not supported. You need to apply styling 
such as line weight and fill patterns individually to each shape. 

• Free-form lines are partially supported. Check any free-form lines 
in the SVGZ output to see if they are rendered properly. 

• Bitmap image support is limited to 32, 24, or 8 bits per pixel. Be 
aware that bitmap images scale very poorly. The general rule of 
thumb is to click the Visio Insert menu and select Picture > From 
File... to create a bitmap that translates correctly. If you have a 
bitmap that is stored in an unsupported format (such as a four-color 
bitmap), try to open the file in Windows Paint and use Save as on 
the File menu to save the drawing as a 24-bit bitmap. The 24-bit 
bitmap converts to SVG properly. 

• Bitmaps with transparent backgrounds are not transparent after 
export. 

• Bitmaps must be resized in Visio 2002 proportionately or the do 
not appear correctly. To resize non-proportionately, first resize the 
bitmap to the desired dimensions in Visio 2002 , then cut and paste 
into Windows Paint. Select and cut the bitmap from Windows 
Paint and then use the Paste Special command in Visio 2002 to 
paste the bitmap as a Device Independent Bitmap. 

• OLE objects are not supported. 

• Shapes with multiple geometric sections with interacting fill 
patterns are not supported. Each geometric section fills 
independently. 

• Translucent shapes and shapes with shadows are not supported. 
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Tips on Improving Performance When Using the GSL 
Some complex AutoCAD drawings can reduce the performance of 
your graphics due to issues with the import or the complexity of the 
drawings. The following tips should improve performance: 

• Reduce the geometric complexity in graphic object background 
images. If there is excessive detail in an AutoCAD image you are 
importing, you may have slower performance. For example, 
fixtures and furniture may be in the original drawings that are not 
necessary for your graphic. 

• Replace jagged lines with straight lines or arcs to make the 
drawing more efficient. The exporter may render a single line as 
many individual points and lines. These lines can appear as jagged 
lines in the imported drawing. Each jagged line represents 
equations that must be solved, thus slowing your system. 

• Replace AutoCAD text with Visio text. AutoCAD text may also 
import as line segments rather than font text. 

• Look for changes to the geometry of imported AutoCAD drawings. 
Some simple shapes import in surprisingly complex ways. For 
example, fills may import as many-sided shapes that overlap rather 
than as the shape they are supposed to fill. See Figure 52 for an 
example of how a fill can import as a complex shape. 
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Figure 52: Complex Geometry After Importing Fill 
• Replace hash marked shapes with a Visio hash pattern, an alternate 

pattern, or, if the drawing does not need them, delete them. Hash 
marked shapes in AutoCAD software convert into hundreds of 
individual line segments that make the computer do extra work.  

• Ungroup metafiles before exporting them to SVGZ. Visio 2002 
converts the metafile geometry to native Visio geometry during the 
ungroup process. Geometric shapes that are copied and pasted in 
from other third-party applications often appear as metafiles in 
Visio 2002. 

• If Visio 2002 is having trouble converting a CAD OLE object to 
native Visio geometry, try cutting it to the Clipboard (on the Edit 
menu, click Cut) and then using Paste Special (on the Edit menu, 
click Paste Special) to paste the file in the Metafile format. Then 
ungroup the graphic to prepare to export to SVG. 
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