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Introduction

Although this is an advanced level document, the material is no more difficult to master than
most of the beginning and intermediate level concepts. You will learn timesaving features
such as macros and templates that will make your work easier and you will learn the quickest
way to troubleshoot problems with your spreadsheets.

Learning Objectives
e Automating repetitive tasks with macros

e Saving time with templates

e Using Excel as a database

e Analyzing data with pivot tables

e Auditing worksheets

e Sharing workbooks over a network

e Using Sparklines and Slicer



Using Macros

This section will explain how to use Macros. Figure 1 show terms and definitions
encountered when working with macros:

Term Definition
M A series of Excel commands and instructions that you group

acro . . X

together as a single command to accomplish a task automatically.

Visual Basic Built-in programming language that enables a user to automate
(for Applications) | simple tasks (using macros).
Visual Basic A text editor built into Visual Basic that can be used to write and
Editor edit macros attached to Microsoft Excel workbooks.

Figure 1 - Macros

Recording a Macro

The following example describes how to record a macro and how to add header information
to a worksheet. Steps 1-5 below explain how to add the Developer tab to Excel:

1. Click the File tab in the top-left corner of the screen.
2. Select Options from the menu that appears.

3. The Excel Options dialogue box will open (see Figure 2). Click the option Customize
Ribbon, located on the left side of the window.

4. Click to place a check next to Developer (see Figure 2) in the lower-right area of the
window.
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Figure 2 — Excel Options



5. Click OK. The Developer Tab will now be displayed on the Ribbon (see Figure 3).

Home Insert Page Layout Formulas Data Review

= P Record Macro ::‘}) E] "i ] B Properties T Map Properties  [Z3 Import éﬁ
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Code Add-Ins Controls XML Modify

Figure 3 — Developer Tab

6. On the Developer Tab, in the Code group, Click Record Macro (see Figure 4).

Home asar Page Layout Formulas Data Review View Developer
= P=] Record Macro B =] | § 3 ] " & Properties f * Map Properties  [Ff Import D)
g B> & = 5 ¥ o B .. : L
‘ —&& [l UseRelative References “ Q,'JVmw Code &=| Expansion Packs =5 Export T—_
Visual Macros . Add-Ins COM Insert Design 3 Source . = Document
Basic /I Macro Security Add-Ins v Mode 8 Run Dialog 4 Refresh Data Panel
Code Add-Ins Controls XML Modify

Figure 4 — Developer Tab

7. The Record Macro dialog box will appear.

Record Macro M

Macro name:

Shortout key:
Ctrl+

Store macro in:
This Warkboak EI

Description:

Figure 5 — Record Macro dialogue box

8. Enter a name for the macro in the Macro name field.

9. Enter a shortcut key in the Shortcut key field.

10. Click the down arrow next to the Store macro in field, and select where you want the
macro to be stored (if you plan to use a macro with more than one workbook, select the
Personal Macro Workbook option).

11. Enter a description of the macro in the Description field.



12. Click OK. The Stop Recording option (see Figure 6) will appear in the Developer tab.
You are ready to record the steps of the macro.

Home Insert Page Layout Formulas Data Review View

Developer
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Code Add-Ins Controls XML Modify

Figure 6 — Stop Recording button

13. On the Insert tab (see Figure 7), click Header and Footer.
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Figure 7 — Header & Footer button

14. With your mouse pointer, click in the area marked Click to add header so that a cursor
appears in this location.

15. Enter text in the text box (example: Kennesaw State University).
16. Then, click to select any cell (example: B2) within the spreadsheet.

17. On the Developer tab, click the Stop Recording option (see Figure 6).

Running a Macro
The following explains how to run a Macro:

1. On the Developer tab, select Macros (see Figure 8).

Home Insert Page Layout Formulas Data Review View Developer
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Figure 8 — Macros

2. From the Macro Dialog Box, select the name of the macro that you want to run.

3. Click the Run button.

Note: You can also run the macro by using the shortcut key that you assigned to the macro.



Editing a Macro
The following explains how to edit a macro:

1. On the Developer tab, select Macros (see Figure 8).
2. From the Macro dialog box, select the name of the macro that you want to edit.
3. Click the Edit button.

4. If the macro you selected is saved in the Personal Macro Workbook

("PERSONAL.XLSB"), you may get the message in Figure 9. If so, follow steps a-c

below. Otherwise, proceed to step 5.
a. Click OK, close the Macro Dialog Box.
b. On the View Tab, in the Window group, select Unhide.

c. Repeat steps 1 through 3 above.

Microsoft Office Excel

! E Cannok edit a macro on a hidden workbook, Unhide the workbook using the Unhide command.

Figure 9 — Excel Message

5. The Visual Basic editor starts, showing the Footer macro in a module window (see

Figure 10).
- Int_Excel WorkBook.xls - Module1 [Code)
{General} - |Macro1
Sub Fcn:it,erlljj
!
' Macrol Macro
' Macro recorded 27142007 by John User
|
Range [("EZ3") .Select
Lpplication. WindowState = =1MNormal
Pange ("M15:F15%) .Select
Range ("IN15") . Aot ivate
LApplication.WindowState = =1lNNormal
Range [("LZ20™") .Zelect
Lpplication. CommandEars ("Formuala iuditing®™) .Visikhle = Fal=se
Sheets ("Sheet3 ™) .Select
AetiwveSheet . ChartChjects("Chart 1) .Actiwvate
Arplication. CommandEar=s ("Chart™) .Wisikble = False
ActivelWindow.Vi=sikhle = False
Sheets. add
Lpplication. CommandBars ("Stop Fecording™) .Wisikhle = False
Sheets ("Sheetd™) .Select
Sheset=s ("Shesetd™) . Mowe After:=3heesets(4)
=|= «

Figure 10 — Visual Basic Editor



6. Scroll down in the module window until you see the line: CenterFooter = """

7. Double-click the quote marks to the right of “CenterFooter = " and type the following:
KSU

8. Click File and then click Close and Return to Microsoft Excel.
9. To save, follow the steps below:

Click the File tab in the upper-left area of the screen.

Click Save As.

The Save As dialogue box will appear.

Enter the file name for the document. Then, for Save as type, change this from Excel
Workbook to Excel Macro-Enabled Workbook.

Click Save.

COw>

m

Advanced Formulas

Following are some of the advanced formulas available within Microsoft Excel. Figure 11
contains some of the terms and definitions used with advanced formulas:

Term Definition

A window that opens when you choose a function from the Paste

Formula Palette Function dialog box, and helps you build the function you select.

The values a function uses to perform operations or calculations---

Argument .
numeric values, cell references, etc.

A function within a function. A function's argument is another

Nested Function )
function.

Figure 11 — Advanced Formula Terms

Using the Insert Function and the Formula Palette
The following explains how to use the Insert Function and the Formula Palette:

1. On the Formula Bar, click the Insert Function button (see Figure 12).

Home Insert Page Layout Formulas Data Review
= Cut « .| =
J*” calibri oA === ¥
e 53 Copy - S A
aste - PN - - = = = i
+ < Format Painter U = - = = =15
Clipboard Font A
Al - 5
A B = D E F G
1 I

Figure 12 — Insert Function Button



2. Select the function that you want to use from the Insert Function dialog box.

3. The Formula Palette for the chosen function appears (see Figure 13).

Function Arguments [ 2 &]

PMT

0

11
il

—» Rate 0.08/12 = 0.008666667

—— HNper 43
—» pv 1500

Fv

= 48

| [T (&
(3] (=] [
]

n
1

_E_-_>%

Type

= -39.06067575
onstant interest rate.

Calculates the payment for a loan based on constant payments and a

b is the present value: the tofal amount that a series of future payments is

Argument Fields [ 5o

Collapse/Expand Buttons

Formula result = -39.06067575

Help on this function [ OK. ] [ Cancel ]

Figure 13 — Formula Palette

Note: The example above illustrates the PMT function. There are five function argument
fields; the ones listed in bold type are required, the others are optional. Notice that the result
of the formula is given at the bottom of the Formula Palette.

4. Enter the argument for each field and click OK. You can also select the arguments from
the spreadsheet if you choose. If the Formula Palette obscures cells that you want to
select, click any of the Collapse/Expand buttons.

Creating Nested Functions
The following example is an illustration of a nested function:

=SUM(SUM(A1:A5), AVERAGE(C1:C5))

The formula (which is located at cell E1 in Figure 14) adds the sum of cells A1 through A5
to the average of cells C1 through C5.

Home Insert Page Layout Formulas Data Review View i
2N Calibri Fu s A N === e S
Paste ~a cepy B J U~ | i~ - A | === | i 5= =

- - Format Painter = = L =T=TETEE
Clipboard Font Alignment
E1l - Jfe | =S5UM(SUM(A1:A5), AVERAGE(CL:C5))
A B = D E F G H
1] 10 10 150
2 20 20
3 30 a0
4 40 40
2 30 50
6

Figure 14 — Nested Functions 10



Auditing Worksheets

Excel's Formula Auditing features allows you to show the flow of formulas on the worksheet.
This makes it easier to find the source of problems. Figure 15 contains terms and definitions
frequently encountered when auditing worksheets:

Term Definition
Precedents Cells that are referred to by a formula.
Dependents Cells containing formulas that refer to other cells.
Graphically show the flow of data between cells containing values and
those containing formulas. Point in the direction of the data flow.

Tracer Arrows

Figure 15 — Definitions

On the Formulas tab, in the Formula Auditing group, you are able to access all the formula
auditing options (see Figure 16).

Home Review View

z @ m:[g @ ﬁ @ ’m § ~3) Define Name ~ %= Trace Precedents 5§ Show Formulas ﬁ
Iy - T

f2UseinF =% Trace Dependents ¥ Error Checking ~ &

Insert AutoSum Recently Financial Logical Text Date & Lookup & Math More N Watch

ame i
Function v Used ~ v v Time ~ Reference ~ & Trig ~ Functions ~ | Manager B Create from Selection | 4 Remove Arrows ~ ‘& Evaluate Formula  window
Function Library Defined Names Formula Auditing

Insert Page Layout Developer

Figure 16 — Formula Auditing Options

In the example in Figure 17, we will display what makes up the total in cell G4.

Home Insert Page Layout Formulas Data Review View Developer
- = ~ g % 3 — 53 Define Name ~ %]

ﬁ 2 @ @ ﬁ I_fﬂ @ @ @ m@ £2 Use in Formula ;:
Insert AutoSum Recently Financial Logical Text Date & Lookup & Math Mare Mame
Function - Used = - - = Time~ Reference = &Trig~ Functions = | Manager BB Create from Selection | 3

Function Library Defined Names
G4 - Je | =SUM(B4:E4)
A B C D E F G H

1 ABC Company Sales

2

3 MName January February March April nia

4 |Eastern Region $ 11000 $ 175.00 $ 140.00 $ 168.00 s s33.0001

5 Western Region g 20000 § 210.00 & 240.00 5 283.00

6 Southern Region S 30000 S 180,00 $ 295.00 S 354.00 S 1,129.00

7 Morthern Region 5 220,00 S 195.00 S 185.00 S 222,00 5 822.00

8

9 Total S 830,00 $ 760,00 $ B860.00 S 1,032.00 S 3,482.00
10

Figure 17 — Auditing a Worksheet
2. Select cell G4.
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3. Inthe Formula Auditing group, select the Trace Precedents option (see Figure 18).

4. The Trace Arrow indicates that cells B4 through E4 are the cells referred to in the
formula in cell G4 (see Figure 18).

i Home Insert Page Layout Formulas Data Review View Developer
FIpe@ae e e @ 8o Bl
Insert AutoSum Recently Financial Logical Text Date& Lookup & Math More Mame e e jTraceDependents(bErrorC
Function - Used ~ - - - Time ~ Reference ~ & Trig ~ Fundtions ~ | Manager BT Create from Selection E\raluai
Function Library Defined Names Formula Auditi
G4 - fe | =sum(B4:E4)
A B i D E F G H 1 J

1 ABC Company Sales

2

3 Mame January February March April Total
| 4 |Eastern Region | so—tt&oo—s—ﬁs:oo—s—rmoo—s—tﬁ&oo-l—m!

5 Western Region S 200.00 5 210.00 S 240.00 S 288.00 s 938.00

& Southern Region $ 300.00 S 180.00 S 295.00 S 354.00 S  1,129.00

7 |Northern Region $ 220,00 S 195.00 5 185.00 S5 222.00 S 822.00

8

9 Total $ 830.00 $ 760.00 5 860.00 S 1,032.00 S 3,482.00

A0

Figure 18 — Auditing a Worksheet

5. To remove the arrow from the spreadsheet, click the Remove Arrows button (see
Figure 18).

In the example in Figure 19, we will display the dependents of cell E4.

Home Insert Page Layout Farmulas Data Review View Developer
ft' z @ @ ﬁ EAJ ﬁ ﬁ @ m @ ,_i fo.ine l\l-ame ' féﬂd Trace Precedents @
Insert AutoSum Recently Financial Logical Text Date & Lookup& Math Mare Mame Je e o Bl <>
Function - Used ~ - - +  Time- Reference = & Trig~ Functions~ | Manager B Create from Selection 7 Remove Arrows = (&)
Function Library Defined Names Farmulg
E4 - £ | 168
A B C D E F G H 1 J
1 ABC Company Sales
2
3 Name January February March __—Ap# Total
| 4 Eastern Region $ 11000 $ 175.00 $ 140. $  593.00
5 |Western Region $ 20000 § 210.00 S 240.00 2200 3 938.00
6 Southern Region S 300,00 5 180.00 5 295.00 § 354.00 5 1,129.00
7 Morthern Region S 220,00 S 195.00 S 185.00 S 222.00 ) 822.00
8
9 Total S 830.00 5 760.00 S 860.00 S 1,032.00 S 3,482.00

Figure 19 — Auditing a Worksheet
1. Select cell E4.

2. Inthe Formula Auditing group, select the Trace Dependents option (see Figure 20).

3. The Trace Arrow in Figure 20 indicates that the formulas in both cells E9 and G4 depend
on the value in cell E4.

12



Home Insert Page Layout Formulas Data Review View Developer

F I BB0BE R 8 B S T
£ Use in Formula =(:jTrace Dependents <‘> E|

Insert AutoSum Recently Financial Logical Text Date & Lookup & Math Mare Mame . = ;
Function - Used = - - - Time~ Reference~ & Trig = Functions = | Manager E& Create from Selection @E

Function Library Defined Names Formula |
A27 - £ |
A | 8 c D E F G H ! )
1 ABC Company Sales
2
3 Name January February March April Total
4 |Eastern Region § 11000 $ 175.00 S 140.00 Se—368:60 4 593.00
5 'Western Region $ 200,00 S 210.00 S 240,00 S| 288.00 3 932.00
& |Southern Region $ 300,00 5 180.00 $ 295.00 S| 354.00 §  1,129.00
7 |Northern Region ¢ 22000 5 195.00 $ 185.00 | 222.00 g 822.00
8
9 Total S B830.00 S 760.00 S 860.00 5'1,032.00 S 3,482.00

=
(=]

Figure 20 — Auditing a Worksheet

4. To remove the arrow from the spreadsheet, click the Remove Arrows button (see
Figure 20).

Figure 21shows a mistake in the spreadsheet. In cell B11, the person is attempting to get an
average of sales in January (cells B4 through B7). However, the person accidentally is
attempting to average cells A4 through A7 (instead of B4 through B7). The following steps
show how auditing can be used to locate errors like this one:

Home Insert Page Layout Formulas Data Review View Developer
o " - P - = : 7 5) Define Name ~
F TR e 06D S
e £ Use in Formula
Insert AutoSum Recently Financial Logical Text Date& Lookupd& Math Maore Mame .
Function - Used - - - Time ~ Reference ~ & Trig ~ Fundions ~ | Manager B Create from Selection
Function Library Defined Mames
B11 - f | =AVERAGE(A4:AT)

A 33 ' T D E F G

1 ABC Company Sales

2

3 Name January February March April Total

4 Eastern Region $ 110,00 $ 175.00 $ 140,00 $ 168.00 $ 593,00
5 Western Region $ 20000 5 210.00 S 240,00 § 288.00 3 938.00
6 Southern Region S 300,00 S 180.00 S 295.00 S 354.00 3 1,129.00
7 Morthern Region S 220,00 $ 195.00 S 185.00 S 222.00 3 822.00
8

9 Total S 830.00 $ 760.00 S 860.00 S 1,032.00 3 3,482.00

10
11 |Average (v
12

Figure 21 — Auditing a Worksheet

1. Select cell B11.

13



2. In the Formula Auditing group, click the down arrow to the right of the Error Checking
option (see Figure 22).

3. Select the Trace Error option. The Trace Arrow indicates that cells A4 through A7 are

being used for the formula in cell B11. The correct formula should use cells B4 through

B7 instead.

Home Insert Page Layout Formulas Data Review View Developer

. . " - o
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Function - Used ~ - - Time = Reference = & Trig * Functions ~ | Manager EE Create from Selection /fu Remove Arrows ~ "1;,' Errar-Checking... o

Function Library Defined Names For| s “frace Error
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A B C D E F G H 1 J K L

1 ABC Company Sales
2
3 Name January February March April Total
4 | EastermRegion 3 11000 $ 175.00 5 140.00 $ 168.00 5 593.00
5 Western Region $ 20000 § 210.00 $ 240.00 § 288.00 S 938.00
6 Southern Regign $ 30000 $§ 180.00 & 295.00 $ 354.00 S 1,129.00
7 |Northern Region $ 22000 § 19500 $ 18500 § 222.00 ] 822.00
8
9 Total $ 830,00 $ 760.00 S 860.00 $ 1,032.00 $ 348200
10
11 | Average @ | wowvjor |

12
13

Figure 22 — Auditing a Worksheet

4. To remove the arrow from the spreadsheet, click the Remove Arrows button (see
Figure 20 on the previous page).

Using Database Functions

This section describes the use of database functions within Excel. Figure 23 contains terms
and definitions used in conjunction with databases:

Term Definition
List A series of worksheet rows that contain related data. Excel term for a
database.
Record A row in a worksheet containing all facts about an item in the list.
Field A single fact in a record.
Filtering The process of selecting records meeting certain criteria from a list.

Figure 23 — Database Definitions

Creating a List
This section explains how to enter data that will be used as a database:

1. Enter the field names (column headings) in the first row of the spreadsheet (example:
Last Name, First Name, Address, etc.), beginning with cell Al (see Figure 24).

14
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Figure 24 — Field Names for a Database

2. Select (highlight) the field names and bold the text.

3. AutoFit the column width for each column by positioning the mouse pointer on a column
border between the columns heading area (the arrow turns into a pointed cross) and
double click. It is best to do this after some data has been entered into the cells.

Using a Form to Enter Data
The following explains how to use a form to enter data:

1. Click the File tab in the top left corner of the screen.

2. Next, select Options.

3. Select Quick Access Toolbar.

4. Click the down arrow to the right of the Choose Commands From field (see Figure 25).
5. Select Commands Not in the Ribbon (see Figure 25).

r |
Excel Options - - - - -

General

@ Customize the Ribbon,

Formulas

Choose commands from: Customize the Ribbon:
Proofing Commands ot in the Ribbon [+] Main Tabs [+]
Save

< 3-D Calor L Main Tabs
tanguage ) 3D Effects v E [] Home
. A @ cii
Advanced %7 3-D On/off =‘ B Clipboard
< G_Bnint Star Font

Figure 25 — Excel Options
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6. In the options on the left side of the window, select Form (see Figure 26).

-
Excel Options

-

General

Formulas
Proofing

Save

Language
Advanced
Customize Ribbon
Add-Ins

Trust Center

N
Customize the Quick Access Toolbar,

Choose commands from: (i
Commands Mot in the Ribbon

[=]

TR
.ﬁ] Fit Drawing to Contents
Ak Flip Horizontal

TG
-

G —

@& Free Rotate

(5 Freeform

E Freeze Sheet Panes

m Group Box [Form Control]
g Help

E Image [ActiveX Contral)
j Import External Data

n‘h Insert Chart

= Insert Page Break

4= Inside Borders

m

Inside Horizontal Border
Inside Vertical Border
Isosceles Triangle
Justify

Label [ActiveX Control)
Label (Form Control)

Left Brace

Left Parenthesis

=
Au
{
7

x| Less Brightness &

2\

|:| Show Quick Access Toolbar below the
Ribbon

=

<< Remove

Customize Quick Access Toolbar: (i)

For all documents [default)

H Save
¥} Undo
™ Redo

Modify...

Customizations:

Import/Export ¥ |

Figure 26 — Excel Options

7. Next, click the Add button (see Figure 26).

8. Click the OK button (see Figure 26) to close the Excel Options window.

9. The Form Icon is now added to the Quick Access toolbar at the top of the screen (see

Figure 27).

= ¥ cut

53 Copy ~
Paste

Clipboard

» <J Format Painter ‘*

Tncart

Calibri

B |7 U-

Iy F

Page Layout

Formulas

Data Review

Figure 27 — Quick Access Toolbar

10. Click to select any of the data column headings (Last Name, First Name, etc).
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11. Click the Form Icon that we just added to the Quick Access Toolbar (see Figure 27). If
the message in Figure 28 appears, click OK.

-

Microsoft Excel

Microsoft Excel cannot determine which row in your list or selection contains column labels, which are required for this command.

o If you want the first row of the selection or list used as labels and not as data, didk OK.

« If you selected a subset of cells in error, select a single cell, and try the command again.

+ To create column labels, dick Cancel, and enter a text label at the top of each column of data.
« For information about creating labels that are easy to detect, dick Help.

[ QK ] | Cancel | | Help

Was this information helpful?

Figure 28 — Excel Message

12. The form dialog box will appear; enter the data for the first record.

13. After entering the data, click New.

14. Continue adding data and clicking New until all new records are added, then click Close.

Finding a Record

The following explains how to find a record:

1. Click to select any of the data column headings (Last Name, First Name, etc).

2.

3.

4.

5.

6.

Click the Form Icon just added to the Quick Access Toolbar.

On the Form window, click Criteria.

Enter the search criteria in the appropriate field. Then, click Find Next.

Continue to click Find Next until you locate every record that matches your criteria.

Once you have located a record, you can delete it if desired by clicking Delete.

Sorting by One Field

The following explains how to sort by one field:

1. Click in the column heading (field name) cell of the field by which you want to sort
(example: Last Name).
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2. On the Data Tab, select the A — Z option to sort the data in ascending order (see
Figure 29). You can also sort the data in descending order by selecting the Z — A.

Home Insert Page Layout Formulas Data Review View Developer

L B S 5 5 = [G) connections ? K Clea E ==
@ @ =0 Ea i3 2l Bt ops i - |
From From From From Other Existing Refresh A N Filter { 5 Textto Remove
Access Web Text Sourcesv  Connections All~ %7 Advanced | Columns Duplicates '
Get External Data Connections ort & Filter

Figure 29 — Sorting

Sorting by Multiple Fields
The following explains how to sort by multiple fields:

1. Click to select any of the data column headings (Last Name, First Name, etc).
3. On the Data Tab, select the Sort option (see Figure 29).

4. The Sort window will appear (see Figure 30). Click the down arrow in the Sort By field
and select the field to be sorted.

[ Sort RS

"‘:%l Add Level ] [ X Delete Level ] ’ 53 Copy Level ” - Options... My data has headers

Colurmn Sort On Order

Sortby || ast Name |E| Values |E| Atod IE‘

First Mame
Address
City

State

Zip

Phone

0K ] [ Cancel

Figure 30 — Sorting

5. Click the down arrow in the Sort On field and select from the available options.
6. Click the down arrow in the Order field and select from the available options.
7. If you want to sort the list further, click the Add Level button to add another sorting level.

8. Click OK.
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Filtering Data in a List
The following explains how to filter data in a list:

1. Click to select any of the data column headings (Last Name, First Name, etc).

2. Onthe Data Tab to select the Filter option (see Figure 31).

Home Insert Page Layout Formulas Data Review Vie loper
5 S 3 5 2 (5] connections 4l E K C =R
al @ 50 S 13 1] = z|A =5 o
From From From From Other Existing Refresh ﬁl Sort Filter Textto Remove
Access Web  Text Sources~ Connections Allr = g7 Advanced | Columns Duplicates
Get External Data Connections Sort & Filter

Figure 31 — Filter

2. A down arrow will appear next to each field name.

3. Click the down arrow for the field that contains the criteria that you want to filter. A
drop-down list box appears containing all entries for that field.

4. Select the item that you want to filter. Excel will return a list containing only the items
that match your criteria.

To return the list to its original state, click the down arrow in the same field again and select
All from the drop-down list box.

Analyzing Data with Pivot Tables

A pivot table is an interactive table that summarizes and analyzes data from existing lists and
tables. The following explains how to use Pivot Tables:

1. Click to select any of the data column headings in Figure 32 (January, February, etc.).

2. Onthe Insert tab, select the Pivot Table option (see Figure 32).

Home

Insert Page Layout Formulas Data Review View

e B2 Gl

Hlustrations

Developer

il @Sl ) b

Pie Bar Area  Scatter Other
*J *J *J *  Charts~

Q@ B34 7w

Slicer | Hyperlink | Text Header WordArt Signature Object
Box & Footer Line -

g

Line Column Win/Loss

Charts Sparklines Filter Links Text

f< | ABC Company Sales

[ A [ 8 [ ¢ D E F G [ w 1 3 K L M N )
1 | ABC Company Sales ]
2
3 Name January February March April Total
4 Eastern Region $ 11000 $ 17500 $ 140.00 $ 168.00 $ 593.00
5 |Western Region $ 20000 $ 210.00 S 240.00 S 288.00 S 938.00
6 |Southern Region $ 300.00 $ 180.00 $ 295.00 S 354.00 $  1,129.00
7 |Northern Region $ 220,00 $ 19500 $ 185.00 $ 222.00 $ 822.00
3
9 Total $ 830,00 $ 760.00 S 860.00 $ 1,032.00 S 3,482.00

Figure 32 — Pivot Tables
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3. Confirm the selected data to be added to the Pivot Table (see Figure 33).

4. Click OK.

7

Create PivotTable

Choose the data that you want to analyze

@) Select a table or range

TableRange: SISy

! Use an external data source

Connection name:
Choose where you want the PivotTable report to be placed
@ Mew Worksheet
_| Existing Worksheet

Location:

=

2.5

"

| | cancel

Figure 33 — Pivot Tables

5. The Pivot Table will appear in a new worksheet.

6. The Pivot Table Field List will appear on the right of the screen.

7. Drag-and-drop the column heading to the Column Labels, the Row Labels, or the Values
boxes below the field list.

8. The results will appear on the left side of the screen.
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Creating Templates

The sample below shows a template for calculating first quarter sales for ABC Company.
This template was created by modifying an existing worksheet and saving it as a template
file. The template could also have been created from a new worksheet, with the formulas for
totals saved in the proper cells.

Home Insert Page Layout Formulas Data Review View Developer

i EHBED D o il eyl ) M

PivotTable Table Picture Clip Shapes Smart&rt Screenshot | Column  Line Pie Bar Area  Scatter Other Li
- Al't - - - - - - - - Chal’ts'

Tables INustrations Charts ]
A28 - I

A | B c D E F G
ABC Company Sales

Name January February March April Total
Eastern Region

Western Region
Southern Region
Northern Region

[N=J = RN (= R, B R SURR S R )
Lr U U U

Total 5 - S - 5 - 5 - 5

=
=

=
b

Figure 34 — Templates

1. Click the File tab in the top left corner of the screen
2. Then, click Save As.

3. Inthe Save As dialog box, from the Save as type field, select Excel Macro-Enabled
Template. This automatically saves the template in the Templates folder.

4. Close the spreadsheet.

To use the template, click the File tab.

1. Select New.

2. Select the My Templates option.

3. Select the template from the New dialog box.

4. The worksheet created from the template can be saved as an Excel file and the template
file will remain unchanged.
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Moving and Copying Worksheets
The following explains how to move and copy worksheets:

1. Click to select the worksheet you wish to Move or Copy.

2. Right-click on the selected worksheet tab and select Move or Copy (see Figure 35).
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10

11
12
13
14
15
16
17
18
15
20
21
22
23
24
25
26

i Right-click on the worksheet
i tab and select Move or Copy.
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Figure 35 — Worksheets

3. Inthe dialogue box that appears, select where you want to move the worksheet to and
then click OK.

4. To make a copy of the worksheet, check the Create a copy box first, then click OK.

Linking Data
The following explains how to link data between worksheets:

1. Open the worksheets that contain the source data and the target location.
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6.

7.

Select the cell(s) in the source worksheet that contain the data that you want to link to the
target location.

On the Home tab, select Copy.
Go to the target location and select the cell(s) where you want to put the source data.

From the Home tab, click the arrow under Paste. Then, select Paste Special at the bottom
of the menu.

In the Paste Special dialog box, click the Paste Link button.

Click Ok.

The target location will now be updated whenever the source data is changed.

Adding a Comment to a Cell
The following explains how to add a comment to a cell:

1.
2.

Select the cell where you want to add the comment.

On the Review tab, select New Comment.

Type your comment in the comment box that appears. Click outside the comment box
when done.

The commented cell is now indicated by a red triangle in the top right corner of the cell.

When the mouse pointer is placed over the cell, the comment box appears.
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Sharing Workbooks
The following explains how to share workbooks:

1. On the Review tab, select Share Workbook.

2. In the Share Workbook dialog box, click the option, Allow changes by more than one
user at the same time on the Editing tab (see Figure 36).

Share Warkbook "

Editing Advanced

( = anw changes by mare than one user at the same time. This
lso allows workbook meraing.

Who has this workbook open now:
juser (Exdusive) - 2011 4:15 PM -

[ oK J [ Cancel

Figure 36 — Share Workbook Dialogue Box

All users who open the workbook will be listed in the, Who has this workbook open now
section of the dialogue box.

3. Click the Advanced tab (see Figure 36).

4. Select the options desired on the Advanced tab, then click OK .



Tracking Changes
The following describes how to use the Track Changes feature in Excel:

1. On the Review tab, click on Track Changes (see Figure 37).

2. Select Highlight Changes.

File Horne Insert Page Layout Formulas Data Rewiew Wi Developer
4 E =B A 5 & Protect and Share Warkbaok
F = = -
VAR anmtan; R .
LB Showe Al Comments 3nges
Spelling Research Thesaurus | Translate e [=—___ _ | Protect  Protect Share
Comment i ShawInk Sheet workbook workpfok | L# Track Changes ~
Proofing Language Commernts
G4 - S
A B © o} E E G H 1 K IL %] I
1 3 4 ¥
2

Figure 37 — Track Changes

3. Inthe Highlight Changes dialog box, select the options that you desire (see Figure 38).

7]

Highlight Changes

v Track changes while editing. This also shares yvour workbook,

Highlight which changes

v When: |.0.II j
[ Who: |Ever3ﬂ:ne j
[ where: | 55
¥ Highlight changes on screen
[ List changes on a new sheet

[a]4 | Cancel

Figure 38 — Track Changes
4. Click OK.



A, B
1
2
3 First Last
4 Julie Baker
5 Brad Fulson
& Terri Goldstein
7 loe Hughes
8 Pete Hughes
9 Mary Kinsey
10
11

c o E F G

Personnel Confidential Infarmation

Store City State Sales
2 Dakland A, 3873
3 Cocoa Beach FL 3917
3 Cak Ridze TH 2475
2 Pine Bluff AR
3 Lake Forest IL 2458
1 Evergreen P&, T 3031

Change made to cell F7.

e In the worksheet in Figure 39,

Figure 39 — Track Changes

a change was made in cell F7 and that cell is now

highlighted, since the Highlight changes on screen option was selected.

e Checking the box in Figure 38 on the previous page for List changes on a new sheet in
the Highlight Changes dialog box creates a “History” worksheet that lists all changes

made in the workbook.

File Home Insert Page Layout Formulas Data Review ey Dewveloper
4 =: E% @Protect Shared Warkboo)
‘? J)l IM —a@ —J —J —J —j “Zp Show &1 Comments u“:s:J 3
Spelling Research Thesaurus | Translate Mew  Delete Prewvious Mext me Share .
Comment i3 Show Ink Warkbook Lo# Track Changes ~
Proofing Language Comments Changes
H20 - Je
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1 Personnel Confidential Information
2
3 First Last Store City State Sales
4 Julie Baker 2 Cakland C 3873
5 Brad Fulsan 3 Cacoa Beach FL 3517
& [ Terri Goldstein 3 Oak Ridge TN 2475 Juser, 177/ 2011 6:00 PM:
7 Joe Hughes 2 Fine Bluff AR 2456 [Changed cell F7 from ‘3876 to
5 |Pete Hughes 3 Lake Forest IL 2455|2456
9 Mary Kinsey 1 Evergreen P 3091
10
11

details of the changes.

6. Select Accept/Reject Changes.

Figure 40 — Track Changes

To review the changes each user has made, on the Review tab, click on Track Changes.

In Figure 40, when the mouse pointer is placed over cell F7, a comment box displays the

26



7. In Figure 41, select the options in the dialog box that you prefer and then click OK.

Select Changes to Accept or Reject ﬂﬂ

Wwhich changes
v wWhen: ﬂ
I wha: |Everynne j
I~ Where: | E
Ok | Cancel |

Figure 41 — Track Changes

8. In Figure 42, click the appropriate button to accept or reject the changes listed in the
dialog box.

Mccept or Reject Changes ﬂﬁ
Change 1 of 1 made to this document:
juser, 1/712011 8:06 PM: &
Changed cell F7 Fram 3876 ko "2456',
=l
Reject | Accept Al | Reject Al | Close |

Figure 42 — Track Changes

Creating and Merging Copies
In order to merge copies, the following conditions must be met:

They must be copies of the same workbook.

They must have a different filename.

They must be a shared workbook.

When copies are made, the Change History must be turned on.

The following explains how to create and merge copies:
1. Click the File tab in the top left corner of the screen and select Save As.
2. Give each copy of the workbook a different name (Reviewl, Review?, etc.).

After each user has reviewed their copy and made changes, the copies can be merged into the
original workbook.

3. Click the File tab in the top left corner of the screen.
4. Select Options from the menu choices.

5. Select Quick Access toolbar.
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6. In the Choose commands from list, select All Commands.

~

Select Compare and Merge Workbooks. Then, click the Add button.

8. Click OK.

©

The Compare and Merge Workbooks icon is added to the Quick Access toolbar at the top
of the screen (see Figure 43).

Home Insert Page Layout
—=| I =2

Spelling Research Thesaurus | Translate Me
Carml

Proofing Language

Figure 43 — Compare and Merge Workbooks icon

10. Select the workbook copies to be merged and click OK. Changes made to the review
copies will overwrite any conflicting data in the original workbook.

Protecting Workbooks and Worksheets
The following explains how to protect workbooks and worksheets:

Protecting Cells
To protect the cells within a spreadsheet, do the following:

1. Remove sharing properties.
2. Select the cells that you want to protect.

3. On the Home tab, click on the down arrow under Format (see Figure 44).

&l = E O |~ @ 127.00.1 _ 8 x o & =
File Home Insert Page Layout Formulas Data Rewiews ‘i Developer ] @ o B E3
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Clipboard Font Alignment Mumber Shyles Editing e,

Figure 44 — Protecting Cells

4. Select Format Cells.
5. Click the Protection tab.
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6. Click to place a check by the Locked checkbox to prevent changes to cells.

7. Click to place a check by the Hidden checkbox to prevent formulas from being seen by
other users.

8. Click OK to close the dialog box.

NOTE: Locking or hiding has no effect unless the worksheet is protected.
To hide rows, columns, or sheets, do the following:

1. From the Home tab, click Format.

2. Select Hide & Unhide.

3. Select either Row, Column, or Sheet.

Protecting Worksheets
The following explains how to protect worksheets:

1. On the Home tab, click the down arrow under Format.
2. Select Protect Sheet.

3. Select the options that you want in the dialog box (see Figure 45).

Protect Sheet ﬂﬂ
Iv Protect warksheet and contents of lacked cells

Password to unprotect sheet:
I

Allow all users of this worksheet bo:
Tl select locked cells

¥ Select unlocked cells

[~ Format cells

[ Faormat colurnns

[ Format rows

[ Insett calumns

[ Insert rows

[ Insert hypetlinks

[ Delete columns

[ Delete rows ﬂ
oK | Cancel |

Figure 45 — Protecting Worksheets

4. Enter a password if you wish.
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5. Anyone trying to modify the sheet will receive the message in Figure 46. The user
will be instructed to unprotect the sheet before any changes can be made.

Microsoft Office Excel

The cell or chart that you are trving to change is protected and therefore read-only,

! To modify a protected cell or chart, first remove prokection using the LUnprotect Sheet command (Review tab, Changes group). You may be prampted
for & passward,

Figure 46 — Protecting Worksheets

Protecting Workbooks
Do the following to protect a workbook:

1. On the Review tab, select Protect Workbook.
2. Enter a password if you wish.

3. Anyone trying to modify the workbook will be asked to unprotect the workbook before
any changes can be made.

4. Click OK.

Limiting Access to Shared Workbooks
The following explains how to limit access to shared workbooks:

1. Click the File tab in the top left corner of the screen.
2. Select Save As.

3. Click the Tools icon (see Figure 47) and select General Options.

RETY %]
()0 ) [l = Users = rearden ~ Desktop ~ + 3 [[Seorch Deskeop B
Organize ~  Mew falder = - @

2l ame « | Date modtfied [ Tipe =
¢ Favorites
S BookL.files LE/Z0LL825 M File folde
o
N ‘p | ] abe sales UT/Z0LLIZ06PM  Microsof
ownloads
* Recent Places & Book3 VG/Z011436PM  Microsofi
) Books 1/6/2011 4:39 PM Microso fi
Libraries & charts SO0 421PM Microsaft
=
B Documents ] cul LA BT PM Microsof
o busic ] faculty_staff_workshops_1_4_2011 VAZOLLSILPM  Microsofi
& Pictures ] report_ab 122010 941 AM  Microsofi
2 Videos ) sales 1/7/2011 8:22 PM Microso ft
| !
Tags: Add a tag
I Sawe Thurmbnail
< bide Foldr canc

Figure 47 — Save As Dialog Box
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General Options ﬂﬂ

[ Always create backup
File sharing

Password to open; ||

Password to modify: |

[ Read-only recommended

ok | Cancel |

Figure 48 — General Options Dialog Box

e Entering a password in the Password to open box (see Figure 48) will require a user to
enter the password to open the workbook.

e Entering a password in the Password to modify box will require a user to enter the
password before modifying the workbook.

e Clicking the Read-only recommended box gives the user the option of opening the
workbook as “read-only” if he or she does not know the password.

4. Click OK.
5. Click Save.

6. Click Yes to replace the existing file.

Sparklines

Sparklines, a new feature in Excel 2010, provides for effective data analysis. The following
explains how to use Sparklines:

1. Inthe example in Figure 49, the area of Column F next to the data will be selected.

Fa - £
A B © o} S [ G

1 ABC Company Sales
2
2 Mame January February harch April
4 |Eastern Region ¢ 11000 ¢ 17500 § 140.00 & 162,00
5 'Western Region ¢ 200000 § 21000 § 240.00 §  288.00
& |Southern Region S 30000 § 180,00 S 29500 S 354.00
7 |Morthern Region $ 22000 § 19500 § 18500 § 22200
&
3 |Total 4 830,00 § 760.00 § 860,00 § 1,032.00

-
o

Figure 49 — Sparklines

2. From the Insert tab, click Column (located in the Sparklines group).
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3. The Create Sparklines dialogue box will appear (see Figure 50). Enter the data range in
the first text box. For the example in Figure 49, we would enter the following range:
B4:E7

Create Sparklines ﬂﬂ
Choose the data that you want
Data Range: || @
Choose where you want the sparklines to be placed
Locakion Range: |$F$4:$F$7 E
oK | Cancel |

Fiaure 50 — Sparklines

4. Click OK. The charts will appear in Column F, allowing you to visually analyze your
data (see Figure 51).

£, B I3 D E F
1 ABC Company 5ales
2
3 Name January February March April
4 Eastern Region & 11000 5 17500 & 140,00 5 16E.00
5 Western Region S 200000 & 21000 S 240,00 & 288.00
& Southern Region S 30000 & 180,00 5 29500 & 354.00
7 Northern Region S 22000 % 19500 & 18500 50 222.00
g
9 Total 5 83000 5 FEO.O0 & BROOD S 1,032.00
10
Figure 51 — Sparklines
Slicer

The new Slicer feature in Excel 2010 helps users to break down data in Pivot Tables that
would otherwise be very overwhelming. The following steps describe how to use the Slicer
feature:

1. Select the data on the spreadsheet (see Figure 52).

2 B & 8} [5 5 G H

1 |First Name Last Name Department City State Sales

2 [ohn Watson Furniture Miami FL g 465,00
3 [ason Cook Electronics Jacksonville FL g 755,00
4 |Amanda Roberts Communications Tampa FL 3 856,00
3 |Sarah YWright Comrmunications hMiami FL 3 §22.00
& |wade Johnson Furniture Jacksonville FL g 201,00
7 |Ryan Smith Electronics Tampa FL 3 742,00
&

9

10

Figure 52 — Data Selected for a Pivot Table
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2. Create a Pivot Table by clicking Pivot Table from the Insert tab.
3. Include the data that you want to analyze (see Figure 53).
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Figure 53 — Pivot Table

4. You are now ready to add Slicer. From the Insert tab, click Slicer.
5. Select the data that you want to slice (see Figure 54). For the example in Figure 54,
Department and City will be selected so that they can be effectively analyzed.

Insert Slicers ﬂi

[CJFirst Mame
[CJLast Marme
[JDepartment
Gty

[ 5tate
[3ales

| Cancel |

Figure 54 — Insert Slicers Dialog Box 23



6. The person analyzing the data can now simply click on the options available for

Department and City in Figure 55.
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A B o = = G H i
1
2 Department
3 Row Labels - | Sum of $ales
1 =cook 755 Communications
5 Electronics 755 Electronics
& | =Johnson 801 Furniture
7 Furniture a0l
2 | =Roberts 856
k] Communications 856
10 ='Smith 742 .
11 Electronics 742 cty
12 =watson 465 Jacksonville =
13 Furniture 465 .
Iliami
14 =Wright 822
15 Communications 822 Tampa
1t Grand Total 4441
17
18
Figure 55 — Slicer
7. Figure 56 below shows how the data appears if Jacksonville (under City in the Slicer
window) is selected. To remove the filter so that all of the data again appears on the
spreadsheet, click the Clear Filter button in the upper-right corner of the Slicer window
(see Figure 56).
City - F v
£ = ] £ G H ;
1
2 Department
3 Row labels |~ Sum of Sales
4 | ©cook 755 Electronics
5 Electronics 733 Furniture
& |Blohnson 801 Communications
T Furniture a0l
% Grand Total 1556
k]
; T—
12  Jacksonville =
1s Miami
14
15 Tampa
16
17

Figure 56 — Slicer
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