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WEEK 1: EXCEL OVERVIEW & FORMATTING 
 

 

Introduction to the Excel interface and structure 

 

Excel Interface & Structure 
 

The Excel workbook navigation is made up of the following components: 

 

1. File – When clicked, this button opens the new Backstage View where you can access 

options including New, Save As, Print, and the Excel Options button (which enables 

you to change Excel’s default settings). 

 

2. Quick Access Toolbar – The Quick Access Toolbar is used for common tasks. The 

default actions are the Save, Undo, and Redo buttons. You can customize this tool 

bar, which is discussed later. 

 

 
 

3. Ribbon – The majority of Excel’s commands are located in the Ribbon. The Ribbon is 

arranged into a series of tabs. 

 

 
 

4. Name Box – This displays the address of the current selected cell or if you have a 

named range, the name of that range. 

 

 
 

5. Formula Bar – This displays the formula or contents of the currently selected cell.  
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6. Rows, Columns & Cells – Rows are number on the left-hand side and columns are 

lettered on the top. These rows and columns are shown as grid lines on your 

spreadsheet (these gridlines can be removed by going to the View tab and then 

unchecking the Gridlines box). 

 

 
 

7. Status Bar – The bar at the lower right-hand corner of the workbook allows you to 

select a new worksheet view and to zoom in and out on the worksheet.  

 

 
The Ribbon 

 

 
 

The Ribbon is made up of the following components: 

 

 Home: Used to format your spreadsheet and sort/filter your data. 

 Insert: Used to add charts, PivotTables, shapes, and pictures to a spreadsheet.  

 Page Layout: Used to prepare your spreadsheet for printing. 

 Formulas: Used to insert formulas (although this is a very ineffective method), check 

your worksheet for formula errors, and manage named ranges. 

 Data: Used to import and group your data, create dropdown lists, and to analyze 

different scenarios utilizing Data Tables and Goal Seek. 

 Review: Used to proof, protect, and marking-up your spreadsheet. 

 View: Used to change the display of the worksheet area.  

 Developer: This is not a default tab but can be activated on the File tab. This is used 

when creating or editing macros. 

 Additional Tabs: If you are working with a chart, PivotTable or other object, additional 

tabs will appear to modify that particular object. 
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Groups  

 

Each tab contains a plethora of functions and tools. These items are organized into groups. 

For example, on the Home tab, the Font group contains the tools to modify the text of a cell. 

 

 
 

Dialog Box launcher 

 

This button is located in the lower-right corner of the Font, Alignment, and Number groups on 

the Home tab opens a Format Cells dialog box that contains many more ways to format your 

cells. However, the preferred method to activate the Format Cells dialog box is to use the 

keyboard shortcut Ctrl + 1. 
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Components of the Backstage View 

 

When you click the File button, the Backstage View appears. The screen contains a menu of 

file-related options running down a column on the left side. 

 

 
 

 Info: Shows you the high-level information about the spreadsheet and create 

workbook protections. By default, your spreadsheet will allow anyone to open, copy, 

and change it. 

 New: Create a new, blank workbook or open one of many pre-made templates. 

 Open: Quickly view and open recently used Excel files. 

 Save: Save your workbook. However, you should never save your workbook via this 

method. You should always use the keyboard shortcut Ctrl + S. 

 Save As: By default, your workbook will save as an Excel Workbook (Excel 2007-

2016). You can also save your workbook as an Excel 2003 workbook or as a PDF. Note 

that a file saved as an Excel Workbook (Excel 2007-2016) will not open if a person has 

Excel 2003. However, the opposite is not true. Excel 2007-2016 can open an Excel 

workbook created in 2003. 

 Print: All of the print settings are located in this tab. You can further modify the print 

ranges and page view in the Page Layout tab on the Ribbon. 

 Share: Email the workbook you are currently working on to a co-worker or create a 

PDF of the workbook. 
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 Options: Modify the default settings in Excel, such as the Ribbon or the Quick Access 

Toolbar, on this menu. 

 

To exit out of the Backstage View, simply press the Esc key to get back to your workbook. 

 

 

Entering and editing formulas and text 
 

Working with cell references 

 

If you want to reference another cell as part of a formula or to just pull in that cell’s contents, 

simply hit the equal key “=” and then select the cell you want to reference. You can either 

select a cell on the same worksheet, different worksheet, or an entirely different workbook. 

Where that cell is located will determine how the cell reference looks in your formula. 

 

 Within the same worksheet: 

 

 
 

 On a different worksheet (notice that the sheet name is referenced first, then an 

exclamation point “!”, and finally the cell reference on the other sheet: 

 

 
 

 Within a different workbook (notice that the workbook location is referenced first, then 

the workbook name, then the worksheet name, and finally the cell reference: 

 

 
 

Basic Operators 

 

The four basic operators are: Addition, Subtraction, Division, and Multiplication. The 

operators in excel are as follows: 

 

Addition: + 
 

Subtraction: 
 

- 
 

Multiplication: 
 

* (Shift + 8) 
 

Division: 
 

/ 
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To use an operator, simply type in the equal sign (which is how we start all formulas), select 

the cell you want to include in the formula, add the operator, and then select the cell you 

want to also include in the formula. Here is an example: 

 

 
 

Order of Operations 

 

Just like in math, order of operations is essential when you are building out your formulas. 

The same order of operations that you learned in high school, still apply to Excel. Excel will 

always run through a formula based on this order: 

 

1. Parentheses 

2. Exponents 

3. Multiplication / Division 

4. Addition / Subtraction 

 

An easy way to remember this is “Please Excuse My Dear Aunt Sallie”. The easiest way to 

ensure the proper order of operations is the use parentheses. Parentheses will be your best 

friend as you work through complicated formulas. 

 

 

Formatting Data 
 

Formatting Numbers 

 

There are various ways to format numbers in Excel. The default is the General number 

format. This format drops any formatting, including adding commas to separate your 

numbers. 

 

To change the number format, go to the Home tab and select either:  

 

1. The drop-down list under the Number group to choose your desired format from the list 
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2. The Dialog Box Launcher under the Number group. We recommend option #2 as this 

provides more options to customize your number. We also recommend using the 

keyboard shortcut Ctrl + 1 to access this same option box. 

 

 
 

The most useful formats are:  

 

 General: Default Excel format 

 Number: Creates a number with or without decimals and commas separating 1,000’s 

 Currency: Creates a number with a currency symbol which can be changed. You can 

also select the number of decimal places. 

 Date: Formats the date to a wide range of options showing a combination of day, 

month and year. 

 Percentage: Shows numbers with a “%” symbol and a specified number of decimal 

places. 
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Applying Borders 

 

To add/remove borders, use the Border button in the Font section on the Home tab in the 

Font group. From there you can quickly change the border settings of selected cells.  

 

 
  

For a more customized border, activate the Format Cells dialog box by hitting Ctrl + 1. On 

the Border tab, you can select borders with various weights, patterns and colors.  

 

 
 

Merging Cells, Wrapping Text, and Auto Fit 

 

You can merge cells using Merge & Center. This merges your cell selection into a single cell 

and then centers the combined entry in the first cell between its new left and right borders. To 

do this, select multiple cells and then click the Merge button under the Alignment section on 

the Home tab. 
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If you have more text than can fit in the width of the column, you can wrap the text so that it 

goes onto multiple lines. To do so, select the cell you want to wrap and click Wrap Text under 

the Alignment section on the Home tab). 

 

 
 

When the value in the cell is longer than the width, Excel puts ##### to indicate you need to 

increase the column size. You can automatically auto fit all of your columns by selecting them 

and hovering your mouse pointer to a column intersection. Your pointer should change to a 

line with two arrows. Now double click. Done! 

 

Format Painter 

 

Format Painter allows you to quickly copy the formatting from one cell to another. The icon 

is found on the Home tab on the left-hand side. To use it, first select the cell (or range of 

cells) that contains the formatting you want to copy and click the Format Painter button. Now 

select the cells to which you want the formatting to apply. 

 

The faster way to use Format Painter is utilizing keyboard shortcuts. The keyboard shortcut is 

Alt + H + F + P. After the formatting is copied, you can apply the formatting using the 

method above.  

 

 

  



Microsoft Excel® for the Real World 

 

               17 

Modifying Rows and Columns 
 

Add a Row / Column 

 

To add a row, right click on the row directly below where you want the new row to be inserted 

and choose Insert. To insert a new column, right click on the column directly to the right of 

where you want the new column to be inserted. Again, right click and select Insert.  

 

 
 

To add multiple rows or columns, select the number of rows/columns you want to insert and 

then right click and select Insert. The number of rows / columns you have selected will be 

inserted. 

 

The preferred method to insert a row or column is using keyboard shortcuts. To insert a row, 

hit Shift + Space Bar, this selects an entire row. Now hit Ctrl + Shift + “+=”. 

 

To insert a column, hit Ctrl + Space Bar, this selects an entire column. Now hit Ctrl + Shift 

+ “+=”. 

 

Delete a Row / Column 

 

To delete rows or columns, select the rows / columns you would like deleted, right click, and 

then select Delete.  

 

 
 

If you only want to delete one cell, or range of cells, select the cell(s) you want to delete, 

right click, and select Delete. A prompt will come up asking you how you want to shift that 

data. Just be careful! Deleting or inserting cells this way may affect the rest of the data.  
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When you insert a column or row, Excel automatically adjusts the cell references in the 

formulas. However, if you delete data that is being referenced elsewhere in the workbook, 

that cell will come up with a #REF error and will need to be relinked in order to work again.  

 

The preferred method to delete a row or column is using keyboard shortcuts. To delete a row, 

hit Shift + Space Bar, this selects an entire row. Now hit Ctrl + “-”. 

 

To delete a row, hit Ctrl + Space Bar, this selects an entire column. Now hit Ctrl + “-”. 

 

Hide a Row / Column 

 

If you want to hide rows or columns so that they don’t appear (but aren’t deleted), select the 

rows or columns that you want hidden, right click and select Hide. To unhide them, select the 

rows/columns above and below the hidden rows/columns, right click and select Unhide. 

 

 
 

 

Modifying Worksheets 
 

Add or Delete a Sheet 

 

To completely delete a sheet, right click on the name of the worksheet you want to delete and 

choose Delete. Note that this is permanent and cannot be undone. Therefore, we recommend 

that before you delete a sheet, you save your workbook. If you want to get your workbook 

back, just exit your workbook without saving and open it again. 
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Insert a New Sheet 

 

To insert a new worksheet, right click on any of the tab names and select Insert. 

 

 
 

You can also click on the plus “+” button next to the horizontal scroll bar. 

 

 
 

Hide/Unhide Sheets 

 

You can choose to show only certain sheets in your workbook. To hide a sheet, simply right 

click on the sheet and select Hide.  

 

 
 

You can Unhide this sheet by right clicking on any sheets and selecting Unhide. After you 

select Unhide, a dialog box will appear. Click the sheet you want to unhide and click OK. 
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Rename or Color a Sheet 

 

To rename a sheet, double-click on the sheet tab and then rename it. To change the color, 

right click on the sheet, select Tab Color, and then select the desired color. When coloring 

your sheet, don’t just create the rainbow of colors. Make sure the coloring means something. 
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WEEK 2: BASIC FORMULAS & KEYBOARD SHORTCUTS 
 

 

Basic Excel Functions 
 

SUM 

 

The SUM formula does exactly what it says, it sums the contents of a range of cells. To use 

SUM, use the following syntax: 

 

=SUM(number1, number2, [...]) 

 

The first number is required and then you can add up to 29 other optional number arguments. 

Make sure each one is separated by a comma. Below are a couple examples of how you could 

use the SUM function:  

 

=SUM(A10:A50) 

 

=SUM(A1,B5,C10) 

 

AVERAGE 

 

The AVERAGE function takes the average of the cells or ranges selected. To use AVERAGE, 

use the following syntax: 

 

=AVERAGE(number1, number2, [...]) 

 

Below are a few examples of how you could use the AVERAGE function: 

 

=AVERAGE(A10:A50) 

 

=AVERAGE(E1:E10,G1:G10)  

 

COUNTA 

 

The COUNTA function counts the number of cells in a range that contain any type of 

character. To use COUNTA, use the following syntax: 

 

=COUNTA(value1,value2,[...]) 

 

Below are a couple examples of how to use COUNTA:  

 

=COUNTA(A15:A100) 

 

=COUNTA(D:D) – Note that this would count all the cells in the entire column that 

contain a character. 
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Note that the COUNTA function counts a cell as long it has some entry, even if the entry is 

empty text set off by a single apostrophe (’). 

 

COUNT 

 

The COUNT function works almost exactly the same way the COUNTA formula does. 

However, the difference is the COUNT formula only counts cells that contain a number. So, if 

cell A1 contained the value “Gwyn12”, the COUNT formula would not count it. However, if the 

cell contained the value “12”, the COUNT formula would count it. To use COUNT, use the 

following syntax: 

 

=COUNT(value1,value2,[...]) 

 

 

Copy, Cut and Paste your Data 
 

Copy 

 

To copy the contents of a cell or range of cells, select the cell you want to copy and either a) 

click on Copy on the Home tab or b) hit Ctrl + C on the keyboard. In fact, you should only 

use the b method. After the cell is copied, you will see little marching ant dancing around the 

cell indicating that the cell has been copied. 

 

 
 

Paste 

 

After you copy a range, select the range where you want to paste the copied cells. Once 

selected, either a) click on the clipboard icon on the Home tab (above Paste) or b) hit Ctrl 

+ V on the keyboard. Once again, never, ever use method a. 

 

When you use normal Paste, you are copying the values, formulas, and formatting of the cell. 

Therefore, when you paste the copied cells, everything in the copied cells is copied over. 

 

Paste Special 

 

Paste Special allows you to paste only certain aspects of a copied cell. You access the Paste 

Special by either clicking on the Paste menu on the Home tab or by hitting Ctrl after hitting 

Ctrl + V. 
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The most common Paste Special options are: 

 

1. Formula: Only pastes the formula reference and nothing else (including formatting) 

2. Value: Only pastes the value of the cell and nothing else. For example, let’s say cell A1 

has the formula =3*4. When you copy cell A1 and paste it to B1 but just select Value, 

just the number 12 (3*4) will be pasted over, not the formula itself. 

3. Transpose: Transpose from either horizontal to vertical or vertical to horizontal (this 

neat function is bound to make you a party favorite). 

Cut 

 

Instead of copying a cell, you can completely cut it in order to move it to a different location. 

To cut a cell, either a) click on the Cut icon on the Home tab (above Copy) or b) hit Ctrl + X 

on the keyboard. Once again, never, ever use method a. 

 

After you cut a cell or range of cells, simply paste it wherever you want to put it. 

 

 

Quickly Navigating Excel 
 

Keyboard Shortcuts  

 

Keyboard shortcuts can save you enormous amounts of time. At first, using shortcuts 

instead of your mouse will be much slower. However, after a couple days and after your 

fingers learn the motions, you’ll be amazed with how much faster you are! Below is a list of 

the most common actions and their associated keyboard shortcuts. 

 

We do NOT recommend you memorize every single one of them. Instead, memorize the ones 

that you more useful to you and your use of Excel. 
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Formatting Cells   Formatting Text   
Format cells Ctrl + 1 Bold selection Ctrl + B 

Format as number Ctrl + Shift + 1 Italic selection Ctrl + I 

Format as date Ctrl + Shift + 3 Underline selection Ctrl + U 

Format as currency Ctrl + Shift + 4 Insert multiple lines in cell Alt + Enter 

Format as percentage Ctrl + Shift + 5 Apply formatting as last F4 

Insert a comment SHIFT + F2   

    

Additional Shortcuts     

Autosum a range of cells Alt + Equals Sign   

Insert the date Ctrl + ; (semi-colon)   

Insert the time Ctrl + Shift + ; (semi-colon)   

Go to precedent cells CTRL + [   

Go to dependent cells CTRL + ]   

New sheet Shift + F11   

Fit column width ALT + H + O + I   

 

The Alt Key 

 

Beyond the standard keyboard shortcuts, you can also perform ANY task in Excel using only 
your keyboard. The trick is using the Alt key. If you hit the Alt key, letters will appear on the 
Ribbon. 

 

General   Navigating   
New file Ctrl + N Move to next cell in row Tab 

Open file Ctrl + O Up one screen Page Up 

Save file Ctrl + S Down one screen Page Down 

Close file Ctrl + F4 Move to next worksheet Ctrl + Page Down 

Save as F12 Move to previous worksheet Ctrl + Page Up 

Display the print menu Ctrl + P Go to first cell in data region Ctrl + Home 

Select whole group of data Ctrl + A Go to last cell in data region Ctrl + End 

Select column Ctrl + Space Data region left Ctrl + Left Arrow 

Select row Shift + Space Data region right Ctrl + Right Arrow 

Insert columns/rows Ctrl + Shift + “+” Data region down Ctrl + Down Arrow 

Delete columns/rows Ctrl + “-“ Data region up Ctrl + Up Arrow 

Insert a new worksheet Shift + F11 Select whole data region Ctrl + Shift + 8 

Manual select Shift + Arrow Key Move to next sheet Ctrl + Page Down 

Undo last action Ctrl + Z Move to Prior sheet Ctrl + Page Up 

Redo last action Ctrl + Y Access Drop down menu Alt + Down/Up Arrow 

Spell Check F7 Zoom in / out Ctrl + mouse scroll 

Cut Ctrl + X Edit active cell F2 

Copy Ctrl + C Cancel cell entry Escape Key 

Paste Ctrl + V   

Find text/number Ctrl + F   

Recalculate F9   
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If you type any of these letters, you will be taken to that tab where more letters will appear. 
For instance, if you type H after hitting Alt, these new options will appear. 

 

 
 

If you now type in A+L, your text in the current cell will become left aligned. So, the 

keyboard shortcut to left align your text is: Alt + H + A+L. 

 

Working with Auto Fill  

 
Auto Fill allows you to quickly fill cells with data that follow a pattern (ex. months) or that is 
based on data in other cells (ex. formulas). For instance, you can automatically populate a 

sequence of numbers or copy formulas down columns or across rows.  
 

To do this, select the cells that you are using as your starter cells. Click the little box at the 
bottom right of the cell (your cursor will turn into a cross) and drag it down to fill in the rest 
of the series. 

 

 
 

 
 

You can also use Auto Fill to quickly copy a formula down a column by double-clicking the box 

at the bottom right of the cell after creating your formula. 
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Customize the Quick Access Toolbar 
 
The Quick Access Toolbar is located at the top of your Excel workbook, above the Ribbon. It 

provides quick access to your favorite Excel actions. The default functions are Save, Undo, 
and Redo.  

 

 
 
You can customize this to include your favorite actions to save you vast amounts of time: 
 

1. Go to the File tab and click on Options (located in the left-hand column). A new 

window will appear. 

2. On the left-hand column, click Quick Access Toolbar.   
 

 
 

3. You have the option to add any Excel action from any tab on the Ribbon. Use the 

Add/Remove button to customize your Toolbar. You can change the order of the icons 
using the toggle buttons on the far right. 
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As a bonus, your Quick Access Toolbar just became your own custom keyboard shortcuts. 

Now when you press the Alt key, you will see numbers above your Quick Access Toolbar 
actions. When you type the number, that action will be performed. 

 

 
 
To maximize the utility of your Toolbar, we suggest you place the Toolbar below the Ribbon 

for ease of access. You can do this by checking the box labeled Show Quick Access Toolbar 

below the Ribbon at the bottom of the menu noted above. 
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WEEK 3: WORKING WITH YOUR DATA 
 

 

Sorting and Filtering 
 

Sorting Records on a Single Field 
 
If you only want to sort your data list on one particular column, click the header of the column 

you want to sort and select the appropriate sort option on the Sort & Filter drop-down list: 
 

 
 

There are three different sort options: 
 

 Sort A to Z or Sort Z to A in a text field  

 Sort Smallest to Largest or Sort Largest to Smallest in a number field  

 Sort Oldest to Newest or Sort Newest to Oldest in a date field 

 
Excel then reorders all the records in the data list in accordance with the new ascending or 

descending order in the selected field. If you find that you’ve sorted the list in error, simply 
hit Ctrl+Z to undo the last option. 
 

When you use the ascending sort order on a field in a data list that contains different kinds of 
entries, Excel places numbers (from smallest to largest) before text entries (in alphabetical 

order) and finally, blank cells. When you use the descending sort order, Excel arranges the 
different entries in reverse. 

 
Custom Sort (Sorting Records on Multiple Fields) 

 

When you need to sort a list on more than one field (ex. sort Last Name in Ascending order 
and sort First Name column in Ascending order), you use Custom Sort: 
  

1. Select the entire range of data you are sorting, including the header row.  

2. Click the Sort & Filter Data button on the Home tab and then select Custom Sort.  
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3. Click the name of the field you first want the records sorted by in the Sort By drop-

down list. If you want the records arranged in descending order, remember also to click 
the descending sort option (Z to A, Smallest to Largest, or Oldest to Newest) in the 

Order drop-down list to the right.  

4. If you want to sort on another level(s), click the Add Level button to insert another 
sort level. Click OK. 

 

 
 

AutoFilter 

 
If you want to filter your data to only see certain items, you can apply a column Filter. This 

will allow you to easily filter on one or more fields. It also provides an easier to way to sort 
your data.  

 
To insert a filter, highlight the range of data you want the filter applied to, including the 
header. Click the Sort & Filter Data command button on the Home tab then select Filter.  
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Small arrows will now appear on each column header. When you click on these arrows, it 
allows you to either filter or sort your data. 

 

 
 

 

Removing Duplicates 
 
If you have a list of data that potentially have duplicate information, you can use Remove 

Duplicates to quickly get rid of the extra data. Remove Duplicates is found on the Data tab. 
  

 
 
To remove the duplicate values, first select the entire data set you want to analyze, including 

header rows, and click the Remove Duplicates button on the Data tab. The following menu 
will appear. 

 
 

On the form under Columns, there are checkboxes next to each of the headers (“Acct 

Number” and “Balance” in our example). The more boxes you check, the more precise the 
removal will be.  
 

For examples, by checking off both the “Acct Number” and “Balance” boxes, Excel will only 
remove rows that are both duplicative in terms of the account number and account balance. If 

you only check off the “Acct Number” checkbox, Excel will remove all rows that just have 
duplicative account numbers even if the account balance is different. 
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We highly recommend keeping all boxes checked. After you are done, click OK. A message 
box will appear indicating how many duplicates were found and removed, and how many 

values remain. 
 

 
 

 

Conditional Formatting 
 

Conditional Formatting allows you to automatically change the formatting of cells based on 

criteria you set. For instance, you can have all cells that are over a certain threshold be 

highlighted in yellow.  

 

To apply Conditional Formatting to a group of data, first select the range you want the 

formatting to apply. Next, on the Home tab select Conditional Formatting. From here you 

can select the conditional formatting rule you want to apply to your data. 

 

 
 

Highlight Cells Rules 

 

When you select Highlight Cell Rules, a sub menu will appear. These options allow you to 

highlight cells based on some common qualifiers such as greater than, less than, etc. 

 

Once you select a qualifier, a simple menu will appear. In the first box, insert the criteria. The 

drop-down box to the left allows you to format your cells to how you would like. 
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You can customize how you want your cells to be formatted by selecting Custom Format on 

the drop-down menu. You can change the font type, size, color, borders, etc.  

 

 
 

Top/Bottom Rules 

 

When you select Top/Bottom Rules a sub menu will appear. These options allow you to 

highlight the top and bottom performers in your data set. For example, you can highlight 

above average stock prices. 

 

Note that even though the menu says Top 10 Items or Top 10%, you can easily change this 

to the top 5 or 100 items. 

 

Data Bars 

 

Data Bars imbeds a bar graph in your cell. The graphs assume that the lowest value in the 

range of cells is basically 0% and the highest value is 100%. 

 

 
 

Color Scales 

 

Color Scales options creates a “heat map” of your data. The highest values are shaded green 

(or red if you’d like) and lowest in red (or green) with different shades in between. 
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Delete Rules 

 

If you need to delete the rules of a particular set of cells, first select the cells you want to 

modify. Now, go to Conditional Formatting on Home tab and select Clear Rules. You can 

either delete the rules of particular set of cells (that you’ve highlighted) or from the entire 

worksheet. 

 

 
 

Alternatively, you can go to Manage Rules to delete your formatting. 

 

Manage Rules 

 

If at any time you need to delete a formatting rule, change the data range, or change how 

you want the cells to be formatted, you can do this in the Manage Rules section.  

 

First, highlight the range of cells that you want to modify. From there, go to Conditional 

Formatting on the Home tab and select Manage Rules. 

 

A menu will appear showing the various rules you have applied to your selection. To delete a 
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rule, select the rule and click the Delete Rule button. To change the data set the rules apply 

to, change the cell reference under Applies to. 

 

 
 

Advanced Conditional Formatting 

 

Conditional formatting is a great way to quickly highlights important information in a 

spreadsheet. But sometimes the built-in formatting rules don’t capture everything you want. 

Adding your own formula to a conditional formatting rule allows you to do things the built-in 

rules cannot do. 

 

As an example, let’s say you have a list of birthdays in cells A2:A6 and you want to highlight 

in green those birthdays that have yet to occur. You can use a formula to create this 

conditional formatting. 

 

1. Select all the birthdays in cells A2:A6 

2. Click Home > Conditional formatting > New Rule. A New Rule dialog box will open. 

 

 
 

3. Select Use a formula to determine which cells to format 



Microsoft Excel® for the Real World 

 

               35 

4. In the input section under Format values where this formula is true put the 

following formula: =A2>TODAY(). This is testing whether the birthday is after today’s 

date. 

 

 
 

5. Click the Format button and choose how you want to format your cell. In our case, we’ll 

color the text green. Then click OK. 

 

 

Format List as a Table 
 

The Table feature allows you to both define an entire range of data as a table and format the 
data, all in one operation. Tables provide an easy way to filter and format your data, add 

additional data (while still retaining the formatting), and create a permanent header row. 
 
To create a table: 

 
1. Highlight the entire data range including the header rows. 

2. On the Insert tab on the Ribbon, select the Table command button. 
 

 
 

3. A Create Table message box will appear ensuring you selected the appropriate range 

and to indicate whether or not you have headers (you should ALWAYS have headers). If 
you check the My Table has headers box, you are telling Excel that the top row is a 

header row. 
 

 
 

By default, Excel will reformat the header row, highlight every other row blue, and put filters 
on each column. You will also notice that a new tab on the Ribbon appears, the Design tab. 

From this tab, you can customize your table such as changing the color of rows, removing the 
filter buttons, and adding a total row. 
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The table you created is very dynamic. If you add any information to the bottom of the data 
series, Excel will automatically format the cells the same as the rest of your table. It will also 
add this additional data to your filters. Also, if you insert rows and columns in the table, Excel 

will automatically update the new row/column with the appropriate formatting. 
 

Another neat feature is that when you are in your table and scroll to a point where your 
header row is no longer visible, Excel will change the name of the column letter to the header 
row name. 

 

 
 

The biggest downfall of a Table is that referencing a Table can cause your formula to look very 
confusing. When you reference Table, your formula will look like the below example instead of 
just =H:H or some other normal cell reference. 

 

 
 
If you wish to convert the table back to a normal range (what it was before), you can do so by 

going to the Design tab on the Ribbon and selecting Convert to Range. Although the 
formatting will remain the same, the filters and table functions are now gone. 

 

 
 

 

Create Custom Number/Date Formats 
 
Excel has many options for displaying numbers such as percentages, currency, and dates. 

However, if these built-in formats do not meet your needs, you can custom-build a number 
format. Customizing a number format does not affect the cell value, it just modifies the 

appearance. 
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In the example below, we formatted the value in cell A1 to add “years” at the end of the 
value. However, when you look in the formula bar, you notice that the value is still “30”, it 

just appears as “30 years”. 
 

 
 
To customize your number format: 
 

1. Open the Format Cells dialog box on the Home tab or use keyboard shortcut Ctrl + 1. 
 

 
 

2. When the dialog box appears, under Category select Custom. 
 

 
 

3. Under Type is where you will create your custom format. You can preview what the cell 
value will appear as under “Sample”. It is usually best to start with a built-in format 
and modify it from there. 

 
Here are a few basics when creating your formats: 

 
 ###,0: Adds commas to your value 

 0.00: Adds decimals to your value   

 “your text here”: Adds text to your value 

 Dates are as follows: 

o d = day (ex. 4) 

o dd = day with leading zero (ex. 04) 

o ddd = Short day of week (ex. Wed) 
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o dddd = long day of week (ex. Wednesday) 

o This syntax flows similarly to other parts of the date (m = month, y = year). 

 
In our “30 years” example, here is how it would look: 

 

 
 
 

Working with Large Data Sets 
 
Freezing Panes 

 

To keep an area of a worksheet visible while you scroll to another area of the worksheet, you 
can lock specific rows and/or columns in one area by Freezing Panes. For example, you might 

want to keep certain row and column headers visible as you scroll.  
 

To use the Freeze Panes feature: 
 

1. Click the cell that is located to the immediate left of the column(s) that you want to 

freeze and/or immediately beneath the row(s) that you want to freeze. In the example 
below, we want to freeze everything above row 5 and to the left of column C. 

Therefore, we will select cell C5. 
 

 
 

2. On the View tab, click the Freeze Panes button followed by Freeze Panes on the 
button’s drop-down menu.  
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3. A solid line will now appear indicating which rows/columns are frozen. 
 

 
 
To get rid of the freezed panes, on the View tab click Freeze Panes and then Unfreeze 

Panes. 
 
Grouping Rows and Columns 

 
Worksheets with a lot of data can look overwhelming and become difficult to read. Using the 
Group functionality organizes your data into groups, allowing you to easily show and hide 

different sections of your worksheet. This is different from Hiding/Unhiding rows and 
columns which can be cumbersome and cause people to miss the hidden data (unless that is 

your purpose for hiding the rows/columns). 
 
To group rows or columns, select the rows or columns you want to group. Then, on the 

Ribbon select Data and then click the Group icon. 
 

 
 

The selected rows or columns will now be grouped. You can click the “-“ or “+” sign at the 
top/side of the column/row to show and hide your section. 

 

 
 
To ungroup data, select the grouped rows or columns then click the Ungroup command on 
the Data tab. 
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Naming Ranges 
 
Naming a Range of Data 

 
Naming a cell is one of the easiest ways to reference a cell that you use on a regular basis 
(ex. a cell that you refer to in a formula calculation). This will especially be true when we are 

using VLOOKUP or INDEX/MATCH. Additionally, naming cells makes formulas much more 
comprehensible. 

 
To name a cell range: 
 

1. Select the cell(s) that you intend to name. 

2. Click the Name box on the Formula bar. Excel automatically highlights the address of 

the active cell in the selected range.  
 

 
 

3. Type the range name in the Name box and then press Enter (don’t just select another 
cell).  

 

 
 

When picking a name for your range, the name must be unique to the workbook, not contain 
any special characters (ex. $, &, etc.) and not have any spaces. If you want to add a "space", 

separate the words with an underscore (ex. Prod_Cost). Additionally, you want your name to 
be very descriptive while also being concise. 
 

Referencing a Named Range 

 

After you’ve assigned a name to a range, you can now reference that cell in any formula by 
typing in the cell reference name. For example, consider the following formula that calculates 
the sale price of an item that uses standard cell references: 

 
=D5*(1+D6) 

 
Now consider the following formula that performs the same calculation but, this time, with the 
use of range names: 
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You can change/delete a range name by going to the Formula tab and selecting Name 

Manager. A Name Manager dialog box will appear listing all the range names in your 
workbook. 

 

 
 

Naming an Entire Column 

 
To name an entire column, select the entire column by hitting Ctrl + Spacebar. From here, 
name the column like you would a normal range by changing the name in the Name Box. 

Naming an entire column is especially useful when we use the SUMIFS and COUNTIFS 
formulas. 
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WEEK 4: INTERMEDIATE FOMULAS 
 

 

Absolute Cell References 
 

There may be times when you do not want a cell reference to change when copying cells 
down a column or across a row. By default, all cells are Relative References. This means 

that as you copy a formula, the cell references will change based on where you paste the 
formula. Absolute References on the other hand, do not change when copied. Therefore, 
you use an absolute reference to keep a cell, range, or row/column constant.  

 
When a cell includes an absolute reference, there are $ to the left of the column or row 

referenced. For instance, B5 is a normal cell reference whereas $B$5 is an absolute cell 
reference. 
 

 
 

To get an absolute cell reference, hit the F4 key on your keyboard. If you keep hitting F4, it 

will cycle through the different variations of locking the formula. 
 

$A$2 = The column and the row do not change when copied, the entire range is fixed. 
 
A$2 = The row does not change when copied. 

 
$A2 = The column does not change when copied. 

 
 

Conditional and Lookup Formulas 
 

IF Formula 

 
The IF function will return a value based on whether a given condition is TRUE or FALSE. It is 

a simple IF, THEN, ELSE operation.  
 

For example, IF cell A1 is greater than B1, THEN you want C1 to show “Original”. ELSE if it is 
not true, you want C1 to show “Duplicate”. 
 

The IF function uses the following syntax:  
 

=IF (logical_test, value_if_true, value_if_false) 
 

The logical_test argument is required and is the condition you want to test. To test a 
condition, you need to use a comparison operator: 
 

 Greater than (>) 

 Greater than or equal to (>=) 

 Less than (<) 
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 Less than or equal to (<=) 

 Equal to (=) 

 Not equal to (<>). 
 

For example, if you want to test whether cell A1 is larger than B1, you would put A1>B1. You 
are not limited to testing cell references. You can test fixed numbers (A2>10) or text strings 
(A2= “John Doe”).  

 
The value_if_true argument is required and is the value or text that will appear if the logical 

test is true.  
 
For instance, if A1 is greater than B1 you can have the cell return the text “Original”. You can 

also have the formula return a fixed value (10) or a formula (D2*E2).  
 

The value_if_false argument is required and is value or text that will appear if your test is 
false (i.e. A2 is NOT larger than B2). Once again, the formula can return text, a fixed value, 
or a formula. In our example, we’ll put “Old Property”.  

 
Let’s use an example. Let’s suppose on a test, the teacher had an extra credit question. 

However, she stipulates that you can only get the extra credit if you missed less than 2 days 
of class. If you missed 2+ days of class, you would not get the extra credit.  

 

 
 
The calculate this in column D, we would use the formula: 

  
=IF(C3<2, A2+B2, A2) 

 

 
 
You can have the IF statement return a blank cell by putting two quotation marks (“”) in the 

value_if_true or value_if_false part of the formula. 
 

VLOOKUP Formula 

 
The VLOOKUP function searches vertically (top to bottom) the leftmost column of a lookup 

table until it locates a value that matches or exceeds the one you are looking up. Think of the 
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VLOOKUP as a phone book. You want to look up a person’s phone number so you open the 
phone book, look up their last name, and then go over and find their number. The VLOOKUP 

does the exact same thing. 
 

The VLOOKUP function uses the following syntax: 
 
=VLOOKUP(lookup_value, table_array, col_index_num, [range_lookup])  

 
The lookup_value argument is the value that you want to look up in the first column of the 

lookup table (for example you want to lookup “Gimli”).  
 
The table_array is the lookup table’s cell range. This is the entire table (i.e. phone book). 

 
 

In the example below, cell B7 has the lookup_value (Gimli) and cells A2:C5 is the table_array 
(the phone book where we want to look up Gimli). 
 

 
 

The col_index_num argument is the column number in the table from which the matching 
value must be returned. The first column is 1. In the above example, Name is column 1, Age 
is column 2, and Gender is column 3. 

 
The not-so-optional range_lookup argument is either TRUE or FALSE. This tells Excel 

whether you want Excel to find an exact (FALSE) or approximate (TRUE) match. When you 
specify TRUE or omit the range_lookup argument, Excel finds an approximate match. When 
you specify FALSE as the range_lookup argument, Excel finds only exact matches. Unless it is 

a special situation, you should put FALSE 99% of the time. 
 

The reason is, if your lookup values (Name in our example), is not in alphabetical or 
numerical order and you do not choose the FALSE option, the VLOOKUP will not 
return accurate results. 

 
Putting this together, the formula =VLOOKUP(A1,C2:E5, 2, FALSE) will return Gimli’s age 

which is 140. 
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IFERROR Formula 

 

At times, your formula will return an error, not because the formula is wrong, but because 
there is no value to return. This is especially common with VLOOKUP and INDEX + MATCH 
formulas. The most common formulas are 

 
 #DIV/0 – Indicates you are dividing by zero which is not allowed in math (or in Excel) 

 #NA – Indicates no value is available. For example, you are looking up a value in your 
VLOOKUP and there is not value to lookup in the lookup table. 

 

Using the IFERROR will replace any error with any value, formula, or text that you’d like. We 
recommend either having the formula return a zero or a blank “”. 

 
The IFERROR function uses the following syntax: 

 

=IFERROR(value, value_if_error)  
 

The value argument is your normal a formula. For instance, if you have a VLOOKUP formula, 
you would keep this as the value argument. 

 
The value_if_error argument is the value you want to return if the formula returns an error.  
 

 

Conditional List Formulas 
 

SUMIFS 

 
The SUMIFS function adds all numbers in a range of cells that meet one or more criteria. The 
syntax for the SUMIFS function is as follows: 

 
=SUMIFS(sum_range, criteria_range1, criteria1, [criteria_range2], [criteria2]) 

 
The sum_range argument is required and is the range of cells you want to sum.  
 

The criteria_range1 argument is required and is the range of cells that you want to apply 
criteria1 against.  

 
The criteria1 argument is required and is the criteria used to determine which cells to add. 
You can add additional criteria and criteria ranges in the subsequent arguments.  

 
In the example below, you can add the total number of cars (criteria 1) that Adam (criteria 2) 

sold using the formula: 
  

=SUMIFS(A2:A6, B2:B6, “Car”, C2:C6, “Adam”) which returns the value 6 

 

 



Microsoft Excel® for the Real World 

 

               46 

COUNTIFS 

 

The COUNTIFS function counts the number of cells in a range that meets one or more 
criteria. The syntax for the COUNTIFS function is as follows: 
 

=COUNTIFS(criteria_range1, criteria1, [criteria_range2], [criteria2], ...) 
 

The criteria_range1 argument is required and is the range of cells that you want to test 
criteria1 against.  
 

The criteria1 argument is the criteria used to determine which cells to count. You can add 
additional criteria and criteria ranges in the subsequent arguments. 

 
In the example below, you can count the total number of times Adam (criteria 1) received a 
passing grade (criteria 2) using the formula: 

 
 =COUNTIFS(A2:A6, “Adam”, C2:C6, “Y”) which returns the value 2 

 

 
 

AVERAGEIFS 

 

The AVERAGEIFS function averages all numbers in a range of cells that meet one or more 

criteria. The syntax for the AVERAGEIFS function is as follows: 
 

=AVERAGEIFS(average_range, criteria_range1, criteria1, [criteria_range2], [criteria2]) 
 
The average_range is the range of cells you want to average.  

 
The criteria_range1 is the range of cells that you want to apply criteria1 against.  

 
The criteria1 is the criteria used to determine which cells to add. You can add additional 

criteria and criteria ranges in the subsequent arguments.  
 
In the example below, you can average the car units sold using the formula: 

  
=AVERAGEIFS(C2:C12, B2:C12, “Gizmo”) which returns the value $1,680 
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WEEK 5: CHARTS AND GRAPHS 
 

 

The Different Charts in Excel 
 

There are many different types of charts in Excel, although you will likely use just three basic 

charts: column, line, and pie. If you can understand these charts and how to modify them, 

you can work with any chart. 

 

Column Chart 

 

A column chart is used to compare items between different groups. You can also compare an 

over time, although a line chart is really best for a comparison over time (time series). 

 

 
 

Line Chart 

 

A line chart is almost identical to the column chart except the layout is a line instead of a 

bar. This makes spotting trends much easier to read. 
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Pie Chart 

 

A pie chart is used to compare parts of a whole. For example, what percent of the total does 

x product represent? Pie charts, unlike the other charts, do not show changes over time. 

 

 
 

Combo Chart 

 

Combo charts combine any two charts and places these charts on two separate axes. This is 

fantastic if you are comparing two different items that have vastly different units. Usually you 

will combine a column chart with a line chart. 

 

 
 

 

Inserting a Chart 
 

Excel makes it very easy to create a new chart in your worksheet: 
 

1. Select the range of cells containing the data that you want to plot, including the column 
and row headings. The labels in the top row of selected data become category labels in 
the chart. In other words, they appear along the x-axis in most charts. The labels in the 

first selected column on the left are used to name the data series in the chart. Excel 
assigns values to appear along the y-axis based on the data in those data series. 
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2. On the Insert tab, click the button for the type of chart you want to create (Column, 

Line, Pie, Bar, Area, etc.). Excel then opens the drop-down gallery for the type of chart 
you selected. This gallery contains thumbnails for all the subtypes available under that 

chart type. 
 

 
 

3. Click the thumbnail of the subtype of the chart you want to create on the chart button’s 
drop-down gallery. 
 

 
 

All charts that you create are linked to the worksheet from where the data comes. This means 

that if you modify any of the values in your data, your chart will automatically be redrawn to 
reflect the change 

 
If you want to quickly see how a chart is going to look, click the Change Chart Type 
command button and then click the type of chart you want to try in the Navigation pane on 

the left followed by the thumbnail of the subtype of chart in the gallery on the right before 
you click OK. 
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Customizing a Chart and Adding Chart Elements 
 
Chart Tools Tabs 

 
When you create a new chart, or click on an existing chart, two new tabs will open on the 
Ribbon: Design and Format. 

 
 Design Tab: From the Design tab, you can add the various chart elements (for 

example you can add a Chart Title, Axis Title, Legend, etc.), change the Chart Type, 
modify the layout with some predefined templates (Chart Layouts), or move the chart 
to a new worksheet (Move Chart). 

 Format Tab: You can change the coloring of your chart and the chart elements from 
the Format tab. To change the color or, for instance, one of the bars in your Column 

Chart, click on that bar and from the Format tab you can change the Shape Fill color, 
Shape Outline color and make the bar have a drop shadow or 3-D (Shape Effects). 

 
Formatting the Axis 

The axis is the scale used to plot the data for your chart. The x-axis is known as the 

horizontal axis and the y-axis is known as the vertical axis.  
 

 
 

When you create a chart, Excel sets up the horizontal and vertical axes for you automatically 
which you can then adjust.  

 
To modify the axis, click the axis you wish to modify, right-click and select Format Axis.  
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A Format Axis dialog box will open on the right-side of the screen.  
 

 
 

You can modify: 
 

 Minimum to determine the point where the axis begins. 

 Maximum to determine the highest point displayed on the vertical axis. 

 Major Unit to modify the spacing between the major vertical tick marks. 

 
You can also modify the Tick Marks, Labels, and Number format of your axis. The default 

number is the same number as your data is formatted. 
 
Add Chart Elements 

 
You can add and modify the items on your chart by going to the Design tab and then clicking 
on the Add Chart Element. 
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When you select each of these items, you can change where elements are located on the 
graph or add elements that are currently there. 

 
Creating a Combo Chart 

 

A combo chart combines any two charts on two separate axes. Usually you will combine a 
column chart with a line chart. The combo chart allows for qualities of the bar chart and line 

charts to be visualized.  
 
To create a combo chart, select the data you want to present on your graph. Select both sets 

of data. In our example, we want to plot both the number of Stormtroopers and the amount 
of Galactic Credits. These both have very different units so plotting them on separate axes 

makes sense.  
 

 
 

Insert the main type of chart you want. For instance, in our example we will insert a column 
chart. 

 

 
 
Now click on the Design tab and click on Change Chart Type. Select Combo from the list 
on the left and then in the Choose the chart type box, select which set of data you’d like to be 

on the secondary axis. You can also change the Chart Type. 
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Printing an Excel Worksheet 
 
Setting a Print Range 

 

If you only want to print a specific section on a worksheet, you can define a Print Range that 
includes just that selection. To create a custom Print Range: 

 
1. Select the data on the sheet you want to isolate for printing. 

2. On the Page Layout tab on the Ribbon, click Print Area, then Set Print Area. 

 

 
  

3. After you define the Print Area, Excel will only print this cell section anytime you print 
the worksheet. 
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To clear the Print Area (and therefore go back to the printing defaults Excel establishes), click 
then Clear Print Area on the Page Layout tab. 

 

 
 
Using Page Breaks 

 
Page Breaks allow you to customize which page your information appears on when printing. 
Excel will automatically split your information into different pages based on the default 

settings (which is not always ideal for your information).  
 

The Page Break Preview enables you to spot page break problems in an instant as well as 
fix them. To get to the Page Break Preview, click the Page Break Preview button (the third 
one in the cluster of three to the left of the Zoom slider) on the Status bar or click View Page 

Break Preview on the Ribbon.  
 

 
 

Your worksheet in Page Break Preview will now look like this: 
 

 
 

Page Break Preview mode shows your worksheet data at a reduced magnification with the 
page numbers displayed in large light type and the page breaks shown by heavy lines 

between the columns and rows of the worksheet. 
 

To change the page breaks, position the mouse pointer somewhere on the heavy lines. When 
the pointer changes to a double-headed arrow, drag the page indicator to the desired column 
or row and release the mouse button. 

 
The first time you choose this command, Excel displays a Welcome to Page Break Preview 

dialog box. To prevent this dialog box from reappearing each time you use Page Break 
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Preview, click the Do Not Show This Dialog Again check box before you close the Welcome 
to Page Break Preview alert dialog box. Click OK or press Enter to get rid of the Welcome to 

Page Break Preview alert dialog box. 
 

Repeating Rows or Columns 

 
If your data spills onto more than one page, you may want to have certain rows or columns 

repeat on every page. For instance, you may want to have the header row repeat on every 
page so that when someone is looking at a print out, they can understand the data. 
 

To have rows or columns repeat, click on the Print Titles button on the Page Layout tab. 
 

 
 

When the dialog box appears, select which rows and/or columns you want to repeat. 
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WEEK 6: DATE FORMULAS AND MANIPULATING DATA 
 

 

Date Functions 
 

EDATE 

 
The EDATE (for Elapsed Date) function calculates a future or past date that is x number of 

many months ahead or behind the date that you specify as its start_date. You can use the 
EDATE function to quickly determine the particular date at a particular interval in the future or 

past (for example, three months ahead or one month ago). 
 
The EDATE function has the following syntax: 

 
=EDATE(start_date, months) 

 
The start_date argument is the date that you want to use as the beginning date.  
 

The months argument is a positive (for future dates) or negative (for past dates) integer that 
represents the number of months ahead or months past to calculate. 

 
For example, suppose cell A1 has the date 1/15/2018. When you enter the following EDATE 
function in cell B1: 

 
=EDATE(A1,1) 

 
Then Excel would return the date 2/15/18. 
 

EOMONTH 

 

The EOMONTH (for End of Month) function calculates the last day of the month that is x 
number of months ahead or behind the date that you specify as its start_date. You can use 
the EOMONTH function to quickly determine the end of the month at a set interval in the 

future or past.  
 

The syntax on EOMONTH is the same as EDATE. 
 
For example, suppose cell A1 has the date 1/15/18 and you enter the following EOMONTH 

function in cell B1: 
 

=EOMONTH(A1,1) 
 
Then Excel would return the date 2/28/18. 

 
TODAY 

 

To get the current date, use the TODAY function. The TODAY function takes no arguments 
and is always entered as follows: 

 
=TODAY() 
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Excel will return today’s date formatted as follows: 7/23/2010. This formula will update daily 
so it should only be used to see the current date.  

 
YEAR 

 

The YEAR function returns the year of a specified date.  

 

For example, suppose cell A1 has the date 1/15/18 and you enter the following YEAR function 

in cell B1: 

  

=YEAR(A1) 

 

Excel would return the year 2018 in cell B1. 

 

MONTH 

 

The MONTH function returns the month (as a number) of a specified date.  

 

For example, suppose cell A1 has the date 1/15/18 and you enter the following MONTH 

function in cell B1:  

 

=MONTH(A1) 

 

Excel would return the number 1 (i.e. month 1) in cell B1. 

 

DAY 

 

The DAY function returns the day of a specified date.  

 

For example, suppose cell A1 has the date 1/15/18 and you enter the following DAY function 

in cell B1: 

 

 =DAY(A1) 

 

Excel returns the day 15 in cell B1. 

 

DATE 

 
The DATE function allows you to piece together a date. The DATE function uses the following 

syntax:  
 
=DATE(year, month, day) 

 
The year argument is a four-digit value of a year. 

 
The month argument is a one or two-digit value of the month from 1 to 12. 
 

The day argument is a one or two-digit value of the day from 1 to 31.  
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For example, the below formula would return the date 1/15/18: 
 

=DATE(2018, 1, 15) 
 

Alternatively, you can combine the YEAR, MONTH, and DAY functions to piece together your 
date. 
 

 

Adding Cell Comments 
 

There are two ways to insert a comment into a cell: Cell Comment and an Input Message.  
 
Cell Comment 

 
Once inserted, a cell comment can only be viewed when you hover over the cell with your 

mouse. Simply selecting the cell will not reveal the comment. 
 
To insert a comment, first select the cell where you want the comment inserted. Next, click on 

the New Comment icon on the Review tab. 
 

 
 

A yellow box will appear next to your cell along with a small, red triangle at the top right 
corner of the cell. You can change the text in the comment box. To delete the comment, click 

on Delete on the Review tab. 
 

 
 

Input Message 

 
In contrast to a Comment, an input message can only be accessed by selecting a cell with the 

comment. Also, there is no indication which cells have comments. 
 

To insert a message, first select the cells(s) where you want the input message inserted. 
Next, click on Data Validation on the Data tab. 
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When the dialog box appears, click on the Input Message tab. From here, you can change 
the title and message. When done, click OK. 

 

 
 

Now when you click on the cell with the message, a message like this appears. 

 

 
 

Note that when you copy a cell with an input message, the input message is also copied. 
 
 

Data Validation 
 

The Data Validation feature in Excel can go a long way in preventing incorrect entries in 

your spreadsheets. When you use Data Validation in a cell, you indicate what type of data 
entry is allowed in the cell. When you have a data validation rule, only certain values will be 

permitted to be placed in that range. 
 
One of the more powerful and common ways to restrict entries is to create a drop-down list. 

The drop-down list is a list compiled from cells elsewhere in the workbook.  
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To create a drop-down list: 
 

1. Create a list of entries you want your drop-down list to display in a single column (ex. 
in cells H1:H5) 

2. Select the cell(s) where you want the drop-down list to appear. 

3. On the Data tab click Data Validation. A Data Validation dialog box will appear. 
 

 
 

4. Under the Settings tab, select the Allow box and click List. 

5. Click the Source section. You can either directly select the range where your list is or 
you can manually insert a list by typing out the list separated by commas (ex. Yes, No, 

Maybe). 
 

 
 

 
 
To delete a drop-down list, select the cell with the list. Click the Data tab and then Data 

Validation. In the Data Validation dialog box, click the Settings tab, and under Allow, 
select Any Value. 
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It is best to place the list of inputs on a separate sheet in the workbook and then protect that 
sheet. This will keep users from changing the list of inputs. Alternatively, you can place it on 

the same sheet but hide the column. 
 

 

Text to Columns 
 
Text to Columns (found on the Data tab on the Ribbon) can be used to separate data that 

is contained in single column into multiple columns. 
 

 
 

For example, if your raw data dump puts the employee’s last name, first name, and ID 

number all in one cell, you can use Text to Columns to separate the data. 
 

 
 

Select the cells that contains the text you want to separate and then click the Text to 
Columns command. A wizard dialog box will open to help you through the process.  
 

In step 1 of the wizard, select whether the text is Delimited or Fixed Width. Delimited text is 
text that has some character, such as a comma, tab, or space, separating each group of 

words that you want placed into its own column. Fixed-width text describes text where each 
group is a set number of characters. We’ll only walk through Delimited as that is the most 
common. After selecting the data type, click Next. 

 

 
 

In the next screen, you will provide details on how you want the text separated. Check the 
boxes that describe how your text is separated. In our example, the text is separated by a 

comma. You will note that under Data preview you can see how Excel will separate your data 
before you finish. Once it is separated as desired, click Next. 



Microsoft Excel® for the Real World 

 

               63 

 
 

In the final step, you will tell Excel where you want to place the separated text under 

Destination. Once you have selected the destination, click Finish. 
 

 
 
 

Find & Replace 
 

The Find & Replace function allows you to quickly search and entire range, sheet, or 
workbook for a particular value and replace it with a different value. You can replace either 

text, number, or even portions of a formula. 
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To access the Find & Replace, hit Ctrl + F on your keyboard. A dialog box will appear. Select 
the Replace tab. 

 

 
 

Next to Find what, insert what you want Excel to find. Next to Replace with, insert what 

you want Excel to replace the found item with. Next, click Replace All. 
 
Be careful when using this function. If you want to replace the items in the entire sheet, make 

sure you only have one cell selected. If you only want to replace the contents of certain cells, 
select those cells first before coming to this menu. If you want to replace the items in the 

entire workbook, click on Options and from the Within menu, select Workbook. 
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WEEK 7: PIVOTTABLES AND PIVOTCHARTS 
 

 

PivotTables 
 

Creating a PivotTable 

 
The PivotTable function in Excel is one of the most powerful data analyzing tools in Excel. 

PivotTables help you automatically summarize, analyze, explore, and present your data with a 
few clicks. To create a PivotTable: 

 
1. Make sure your data has column headings, that there are not blank rows, and that your 

data is completely cleaned up (remove all duplicates, all data present, etc.). 

2. Click any cell in the range of cells or table. 

3. On the Insert tab, click the PivotTable command button.  

 

 
 

4. A Create PivotTable dialog box will appear. You have the option to change the 

selected table or range and to either put the PivotTable in a new worksheet or in an 
existing worksheet. 

 

 
 

5. A new PivotTable Field List will appear on the left-side of the screen. It is from here 
that you will create and modify your PivotTable. 
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6. You can very easily zero in on your data and arrange it the way you want. To do so, 

click and drag the field in the Choose fields to add to report section to the 
appropriate section below.  

 
On the example below, we select Quarter as the Column Labels, Region as the Row 
Labels and Sales as the Values. This will create a table breaking out sales by region for 

each quarter. 
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7. You can add multiple layers to your PivotTable by dragging fields below or above the 
Row Labels or Column Labels. However, we recommend you only have one field in 

the Column area. Two to Three is the optimal number of fields in the Row area. 

8. By default, (for most people’s Excel) the Values section will sum your data. You can 

change this by clicking on the field arrow under the Values section (see the above 
picture). 
 

A dialog box will appear. Select the Value Field Settings option. Under the 
Summarize Values By tab, you can change how you want the pivot table calculate 

your data. 
 

 
 

Number Formatting in a PivotTable 

 
By default, your data will be completely unformatted. Do NOT try to update your values on 
the Home tab. The reason is, when you update your PivotTable or move things around, your 

numbers will revert back to be unformatted. Instead, click on the Number Format button as 
shown in the picture above.  

 
New Tabs 

 

As soon as you create or select a PivotTable, two new tabs will be shown on the Ribbon, the 
Analyze and Design tabs.  

 

 
 
These tabs will allow you to insert a Slicer, Refresh you PivotTables, add a PivotChart, and 

change the design of your PivotTables. 
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Analyze Tab 

 

 
 

 Insert Slicer – Slicers are a great way to slice and dice your data. We cover this more 

in-depth below. 

 Refresh – After you create your pivot table, you may need to change your source data. 
Unlike a chart that automatically updates after you change your source data, a 

PivotTable will not. You must manually refresh your PivotChart every time you update 
you source data! To update, go to the Analyze tab and click the Refresh command 

button. 

 Move PivotTable – Move your PivotTable to a new sheet or to an existing sheet. 

 Fields, Items, & Sets – You can add a customized Calculated Field to your PivotTable. 

We go over this below. 

 PivotChart – Create a PivotChart from your PivotTable. We go over then in depth 

below. 

 Field List / +- Buttons / Field Headers – The Field List button will add or remove 
the PivotTables Fields box from the right-side of your screen. The Field Headers should 

(in our opinion) always be removed by clicking the Field Headers button. This gets rid 
of the in-PivotTable ability to filter. You should use Slicers instead. Doing this will clean 

up your PivotTable. 
 

Design Tab 

 

 
 

 Subtotals – Change the position of the subtotals or remove subtotals. We recommend 

you always put subtotals as the bottom of a group to make the table easier to read. 

 Grand Totals – Add or remove grand totals from your rows and columns. 

 Report Layout – We think the default layout is perfect. Feel free to play with these to 

see different default options. 

 Blank Rows – Add a blank row after each line will make your PivotTable easier to 

read. 
 
The various check boxes will allow you to change the view of your PivotTable. We think the 

default settings are perfect so don’t recommend changing this too much. 
You can  

 
You can also change the PivotTable Style to a different color scheme or create your own 
custom style by clicking on the New PivotTable Style option. 
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Adding Slicers 

 

In Microsoft Excel 2010 and above, you can use slicers to quickly and easily filter your 

PivotTable or PivotChart. In addition to quick filtering, slicers also show you which items are 
being filtered which makes it easy to understand what exactly is shown in a filtered report. 
 

You can create a Slicer(s) by: 
 

1. Click anywhere in your PivotTable or PivotChart. 

2. Under the Analyst tab within your PivotChart Tools, select Insert Slicer. 
 

 
 

3. In the Insert Slicers dialog box, select which fields you want to be able to filter on and 
click OK. 

 

 
 

4. Your Slicer(s) will now appear. You can move the Slicer(s) around or resize them. To 
filter your data, click one or more of the buttons on the Slicer. To select multiple 
buttons, hold down the Ctrl button while clicking the buttons. 

 

 
 

5. You can delete a Slicer by clicking on it and pushing the Delete key on your keyboard. 
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Creating a Calculated Field 

 

A Calculated Field allows you to create a new field in your PivotTable Fields that performs a 
calculation on the sum of other pivot fields. For example, in the example below, we have 
three value fields: Marketing Spend, Direct Rev Result, and Net Revenue. Let’s say that we 

want our PivotTable to calculate the ROI (return on investment) of our marketing efforts. ROI 
is calculated by taking the Net Revenue divided by Marketing Spend. 

 
To create the custom field: 
 

1. Go to the Analyze tab, click on Fields, Items & Sets and select Calculated Field 
from the drop down. 

 

 
 

2. The below dialog box will appear. The first thing you should do is give your field a 
proper name that accurately tells the user what the field is calculating. 

3. You will create a formula using the existing Fields. To add a field to a formula, double 

click on the field name. In our example, we are going to divide the Net Revenue by 
Marketing Spend. Beyond simple operators, you can also use more advanced formulas 

like IFERROR. However, the formula cannot reference a certain cell. 
 

 
 

4. Click OK. Your new field will now appear as one of your PivotTable Fields to add to 
your PivotTable.  
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PivotCharts 
 
A PivotChart is a visual representation of a PivotTable and the two of them are connected to 

each other. A PivotChart can help you make sense of your PivotTable. PivotCharts look exactly 
like the standard charts and graphs in Excel but the PivotChart is 100x (in our best estimate) 

more user friendly, dynamic, and powerful. There are two ways to create a PivotChart. 
 
Create PivotChart without creating a PivotTable first 

 

1. Click anywhere in your data set. 
 

 
 

2. On the Insert tab, in the Charts group, click PivotChart. In older versions of Excel, 
this will be housed under PivotCharts on the left-side. 

 
 

 
 
 

 
 

 
3. Once the dialog box appears, ensure that Excel properly selected all your data. You can 

also choose to have the PivotTable put on a new sheet or on an existing worksheet. 

Once are you are done, click OK. 
 

 
 

4. A PivotChart Fields list will appear on the right side of the screen. This list is identical 
to the PivotTable Field List when you created a PivotTable. 
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5. Exactly like a PivotTable, you can start dragging and dropping your fields to create the 
graph you want. 

 

 
 

6. As you drag and drop your fields, your graph will start to come to life. 
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Once you get your field settings complete, you can modify the chart in the exact same way 

you modify a standard chart in Excel. 
 
Create PivotChart with existing PivotTable 

 
If you already have a PivotTable, you can base a PivotChart on that PivotTable. 
  

1. Click anywhere in the PivotTable to show the PivotTable Tools on the ribbon. 
 

 
 

2. In the Insert Chart dialog box, click the chart type you want. 

 

 
 

3. After you create you chart, you can follow the steps above to modify the chart to your 

liking. 
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Form Controls (Spin Buttons) 
 
Spin buttons (one of the Form Controls) allow you to quickly, and in an entertainingly way, 

change a value in a cell by clicking on the button.  
 

Let’s say you have the following set of data and you want an easy way to change the Loan 
Amount assumption in cell B2: 
 

 
 
To create a spin button, follow these steps: 

 
1. Activate the Developer tab 

a. Click the File tab and then click Options. 

 

 
 

b. Under Customize Ribbon, in the right-side box, check the Developer 
checkbox 
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2. On the Developer tab, in the Controls group, select the Insert, and then under Form 
Controls, select the Spin Button. 

 

 
 

3. Draw on your worksheet the area where you would like the spin button to be. 
 

 
 

Now we need to link our spin button to cell B2. To do that: 

 
1. Right click on the spin button and select Format Control. 

 

 
 
a. In the Current value box, you enter the initial value of the spin button. You can leave 

this as 0. 

b. In the Minimum value box, enter the lowest value that a user can get by clicking the 

bottom arrow in the spin button. 

c. In the Maximum value box, enter the highest value that a user can get by clicking the 
top arrow in the spin button. 

d. In the Incremental change box, enter the amount that the value increases or 
decreases when the arrows are clicked. 

e. In the Cell link box, enter a cell reference that contains the current position of the spin 
button.  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Now, when you click the spin button, the value in the linked cell will increase and decrease 

with the button. 
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WEEK 8: TEXT/STATISTICAL FORMULAS & PROTECTING 

YOUR DATA 
 

 

Text Based Formulas 
 

RIGHT / LEFT 

 
The RIGHT function returns the last character(s) in a text string, based on the number of 

characters you specify, while the LEFT function returns the first character(s) in a text string. 
 
The syntax for both function is as follows: 

 
=RIGHT(text, [number_of_characters]) 

 
=LEFT(text, [number_of_characters]) 

 

The text argument is the string that you wish to extract from.  
 

The number_of_characters argument is the number of characters that you wish to extract 
starting from the right-most character (RIGHT function) or left-most character (LEFT 

function).  
 
Let’s assume that cell A1 contains the text “Guacamole”. The RIGHT and LEFT formulas below 

would return the following: 
 

 =RIGHT(A1, 4) would return “mole” 
 

=LEFT(A1, 4) would return “Guac” 

 
MID 

 

The MID function is similar to the RIGHT/LEFT functions except it returns the middle 
character(s) in a text string based on the number of characters you specify. 

 
The MID syntax is as follows: 

 

=MID(text, start_num, num_chars) 
 

The text argument is the text you want to extract from. 
 
The start_num argument is the location of the first character to extract. 

 
The num_chars argument is the number of characters to extract. 

 
For example, if you have the text “The Quick Brown Fox” in cell A1 and wanted to extract 
“Quick”, you would use the following formula: 

  
=MID(A1,5,6) 
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You use 5 as the start_num since “Q” is the 5th character in the string (spaces count as a 
character). You use 6 as the num_chars since there are six characters in the word “Quick”. 

 
LEN  

 

The LEN function counts the number of characters in a text string. 
 

The syntax for the function is as follows: 
 
=LEN(text) 

 
If you have “Bob Adams” in cell A1, then =LEN(A1) would return the value 9 (spaces count as 

a character). LEN is not very useful by itself and is most effective when combined with RIGHT 
or LEFT. 
 

Combining LEN + RIGHT/LEFT 

 

If cell A1 contains a string which includes an employee number, first name, and last name 
(ex. “498585 Bob Adams”) and you want to quickly separate out the first and last name, you 
can use the following formula: 

 
 =RIGHT(A1, LEN(A1)-7)  

 
This would return the text “Bob Adams”. What this formula is doing is saying, starting from 
the RIGHT of the text in cell A1, extract all the characters (LEN(A1)) and then go back 7 

characters (to account for the 6-digit employee number and the space).  
 

CONCATENATE 

 
You can combine texts from different cells into one using the CONCATENATE function. To do 

this, use the following syntax:  
 
=CONCATENATE(cell1, cell2, [...]) 

 
You can add text by putting “” around the desired text. For example, you could add spaces by 

inserting a “ “, a comma by inserting a “, “ and so forth.  
 
Let’s assume that cell A1 contains the text “Bob” and cell B1 contains the text “Smith”. To 

combine the two with the last name, comma space, and then first name, we would use the 
following formula: 

 
 =CONCATENATE(B1, “, “, A1) would generate “Smith, Bob” 
 

 

Statistical Formulas 
 

MIN 

 
The MIN function takes the smallest value out of the range of cells selected within a data set. 

 
 =MIN (number1, [number2],…) 
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Using the MIN formula, you can set a ceiling to a set of values. For instance, let’s say a SUM 
formula is supposed to return negative numbers. However, you want to make sure that the 

smallest number is zero (in other words, not positive numbers). You could set up a MIN 
function that says:  

 
 =MIN(SUM(A1:A10,0) 
 

This formula is saying, keep the smallest number between the sum of A1:A10 and zero. So, if 
the SUM returns -10, the MIN formula will return -10. However, if the SUM formula returns a 

+13, the MIN formula will return a 0. 
 
MAX 

 
The MAX function takes the largest value out of the range of cells selected within a data set. 
 

 =MAX (number1, [ number2],…) 
 

The MAX function works exactly like the MIN function except in reverse. With the MAX 
function, you are able to set a floor to a set of values. 

 
LARGE / SMALL 

 

The LARGE and SMALL formulas perform almost identical functions. The LARGE will find the 
x number of largest numbers in a data set while the SMALL will find the x number of smallest 
numbers. 

 
 =LARGE (array, k) 

 
 =SMALL(array, k) 
 

The array argument is the range from which you want to pull the largest/smallest values. 
 

The k argument is the position you want to return (ex. Put 1 for the largest number, 2 for the 
2nd largest value, etc.) 
 

 

Rounding Formulas 
 

ROUND 

 
You use the ROUND function to round up or down fractional values. The ROUND function 

actually changes the way Excel stores the number in the cell that contains the function, unlike 
when applying a number format to a cell, which affects only the number’s display. To use 
ROUND, use the following syntax: 

 
 =ROUND(number, num_digits) 

 
The number argument is the value that you want to round 

 
The num_digits argument is the number of digits you want to round to. 
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Entering a 0 (zero) will round the number to the nearest integer. Entering a positive number 
will round the number to that many decimals. Entering a negative number will round the 

number to the left of decimal point.  
 

For example, if B2 contains the value 123,456.789 then we can round it as follows: 
 
=ROUND(B2,0) will return 123,457 

 
=ROUND(B2,1) will return 123,456.8 

 
=ROUND(B2,-1) will return 123,460 
 

ROUNDUP 

 
The ROUNDUP formula works almost exactly the same way as the ROUND formula; however, 

this formula always rounds a number up. The arguments for ROUNDUP are the same as 
ROUND. 

 
 =ROUNDUP (number, num_digits) 

 
ROUNDDOWN 

 

The ROUNDDOWN formula also works almost exactly the same way as the ROUND formula; 
however, this formula always rounds a number down. The arguments for ROUNDDOWN are 
the same as ROUND. 

 
 =ROUNDDOWN (number, num_digits) 

 
 

Protecting Worksheets and Workbooks 
 

Protecting Worksheets 

 
After you have your worksheet the way you want it, you can use the Protection feature to 

keep it that way. To keep the formulas and text in a spreadsheet safe from any unwarranted 
changes, you need to protect the worksheet. 

 
Before you start using the Protect Sheet function, you need to understand how protection 
works in Excel. All cells in the workbook can have one of two different protection formats:  

 
 Locked – When you protect your sheet, the cell cannot be modified.  

 Unlocked (done by unchecking Locked) – When you protect your worksheet, this cell 
can be modified. 

 

Be default, all cells in a workbook are Locked. However, this means nothing until you protect 
your sheet. At that time, the user is prevented from making any editing changes to all locked 

cells.  
 

You can change the protection format of a cell by pressing Ctrl + 1 and then going to the 
Protection tab. 
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When setting up your own spreadsheet, unlock all the cells where users need to input new 
data and keep locked all the cells that contain information that should never change. To 

unlock a cell, just uncheck the Locked checkbox. 
 

To protect the worksheet, go to the Review tab and click the Protect Sheet command 
button. If you leave the Password box blank, the worksheet will still be locked but there will 
be no password to unlock it. If you put a password, you will then be required to put it in 

twice. Don’t forget the password as it is not possible to recover it. 
 

 
 

Note that even if you protect your worksheet, someone can still delete the 
worksheet. Use Protect Workbook in conjunction with Protect Sheet to avoid this. 

 
Protecting a Workbook 

 

Protecting your workbook preserves the overall integrity of your workbook. When you protect 
your workbook, people will not be able to add/delete/hide worksheets. However, unless 

individual sheets are protected, users can still freely modify individual worksheets as they 
desire.  

 
To protect your workbook, go to the Review tab and select Protect Workbook. 
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Just as with Protect Sheet, you will be required to put in a password twice. Don’t forget the 
password as it is not possible to recover it. 

 

 
 
Sharing a Workbook 

 
You can set up your workbook so that multiple users can be in the document at the same time 
making changes. This is especially helpful when two different users need to update different 

portions of the spreadsheet.  
 

To allow this, go to the Review tab and click the Share Workbook command button.  
 

 
 
A Share Workbook dialog box will appear. Click the Allow changes by more than one user 
at a time check box. 

 

 
 
You need to save the workbook before this change can take effect. To reverse the sharing 

option, simply uncheck the box and save the workbook. 
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WEEK 9: ADVANCED FORMULAS & SCENARIO ANALYSIS 
 

 

Advanced Conditional & Lookup Formulas 
 

Nested IF Statements  

 
You can nest multiple (up to 7) IF statements into a single formula. But truth be told, if you 

have more than 2 or three nests, there is probably a better formula. Nested IF statements are 
helpful if you need two or more conditions to be met.  

 
Let’s say you need to test whether something is Okay, Bad, or Very Bad. A nested IF 
statement would look like this: 

 
 =IF(A1>0, “Okay”, IF (A1<-1000, “Very Bad”, “Bad”)) 

 
Let’s break down the parts: 
 

=IF(A1>=0, “Okay”: If cell A1 is greater than zero, then put “Okay” in the cell.  
 

, IF (D3<-1000, “Very Bad”: This is where the nest begins. If the first statement is false, then 
you want to test another assumption. In this case, you now want to see if A1 is less than 
($1,000). If so, then put “Very Bad”.  

 
,” Bad”): Finally, if the first and second statements are false, then put “Bad”. In other words, 

if A1 falls between ($1) and ($999). 
 
Nested IF statements are easy once you understand the general concept. Another way to look 

at nested statements is like this: 
=IF This statement is true, then return this value, otherwise IF (This statement is true, then 

return this value, otherwise return this value)). 
 

INDEX  

 
The INDEX function returns a value from within a table or range, similar to a VLOOKUP 

formula. The INDEX formula triangulates, using a row and column number, on a particular cell 
within a range. 
  

The syntax of the INDEX function is as follows:   

 
=INDEX(array, [row_num], [col_num]) 

 

The array argument is a range of cells that you want Excel to use in the lookup.  
 

The row_num argument is the row number where the lookup cell is located. 
 
The col_num argument is the column number where the lookup cell is located. 

 
If this range contains only one row or column, the row_num or col_num arguments are 

optional. If the range has more than one row or more than one column, and you specify both 
the row_num and the col_num arguments, Excel returns the value in the array argument that 
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is located at the intersection of the row_num argument and the col_num argument. 
 

For example, if cells A2:A5 lists names and cells B2:B5 lists ages, you can input the following 
formula to lookup Arwen’s age: 

 
=INDEX(A2:B5, 3, 2) which will return the value at the intersection of the third row and 
second column in the range A2:B5, which is 2,778. 

 

 
 
MATCH 

 

The MATCH function searches for a specified item in a single column or row of cells, and then 
returns the relative position of that item in the range.  

 
For example, if the range A1:A3 contains the values 5, 25, and 38 respectively, then the 
formula =MATCH(25,A1:A3,0) would return the number 2, because 25 is the second item in 

the range. 
 

The syntax of the MATCH function is as follows: 
 
=MATCH(lookup_value, lookup_array, [match_type]) 

 
The lookup_value argument is the value you want to look up.  

 
The lookup_array is the cell range or array containing the values that you want to match.  
 

The sort-of optional match_type argument is the number 1, 0, or –1, which specifies how 
Excel matches the value specified by the lookup_value argument. 99% of the time you will 

want to put 0 for an exact match. 
 
INDEX + MATCH 

 
INDEX and MATCH by themselves are not the most useful of formulas. But when you 
combine them together, it is one of the most powerful formulas in Excel and will outshine any 

VLOOKUP formula. 
 

The VLOOKUP formula can be very limiting. For instance, it can only lookup values contained 
within the first column of a data range. What if you had to look up a value in a middle 
column? Additionally, if you insert a column in your VLOOKUP lookup table, the entire 

VLOOKUP formula will blow up. This is where the combined INDEX/MATCH comes into play. 
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To combine INDEX and MATCH, we will use the MATCH formula to automatically return the 
row and column number for the INDEX formula. This is best explained with an example. The 

table below shows the State, Capital, and State Population. 
 

 
 

We can find the population of Massachusetts’s capital using just an INDEX formula: 
 
=INDEX($A$2:$C$4,3,3) Massachusetts is in the 3rd row of the range and Population is 

in the 3rd column. 
 

However, we can use MATCH to find both Massachusetts and Population: 
 
=MATCH(“Massachusetts”, $A$2:$A$4,0) = 3 

 
=MATCH(“Population”, $A$1:$C$1,0) = 3 

 
We can now combine all the formulas in to one: 

 

=INDEX($A$2:$C$4, MATCH(“Massachusetts”, $A$2:$A$4,0), MATCH(“Population”, 
$A$1:$C$1,0)) 

 
Using INDEX + MATCH definitely takes practice and will initially be slower than VLOOKUP. 
However, after using it three or four times, you will have the formula mastered. 

 
 

Auditing a Worksheet and Formula 
 
Trace Precedents / Dependents 

 

At times, it is useful to be able to track where a cell is used throughout the spreadsheet. This 

can be helpful in tracking down an error or to see if you can delete a cell without causing an 

error.  

 

Excel offers very effective formula-auditing tools that trace the cell’s relationships. You can 

test formulas to see which cells, called precedents, directly feed the formulas and which 

cells, called dependents, depend on the results of the formulas. 

 

The formula-auditing tools are found in the Formulas tab and includes the following tools: 
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 Trace Precedents: When you click this button, Excel draws arrows to the cells (direct 

precedents) that are referred to in the formula inside the selected cell. When you click 

this button again, Excel adds “tracer” arrows that show the cells (the so-called indirect 

precedents) that are referred to in the formulas in the direct precedents.  

 

 
 

 Trace Dependents: When you click this button, Excel draws arrows from the selected 

cell to the cells (direct dependents) that use, or depend on, the results of the formula. 

When you click this button again, Excel adds tracer arrows identifying the cells (indirect 

dependents) that refer to formulas found in the direct dependents. 

 

 
 

 Remove Arrows: Clicking this button removes all the arrows drawn, no matter what 

button or pull-down command you used to put them there. 

 

Evaluate Formulas 

 

Another way to audit a formula is to step through the calculation to see the current value 

returned by each part of the calculation. This is helpful for complicated calculations or to 

isolate an error.  

 

To evaluate a formula step-by-step: 

 

1. Click the cell you want evaluate 
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2. Click the Evaluate Formula command button on the Formulas tab. This opens the 

Evaluate Formula dialog box with an Evaluation list box that displays the contents of 

the entire formula that’s in the current cell. 

 

 
 

3. When you click the Evaluate button, Excel will evaluate the first expression or term in 

the formula (shown underlined in the Evaluation list box) and show it with the 

calculated value. After you evaluate the first expression in the formula, Excel underlines 

the next expression or term in the formula.  

4. When you finish evaluating all the expressions and terms of the current formula, you 

can close the Evaluate Formula window by clicking Close. 

 

 

Single and Multi-Variable Data Tables 
 

Data Tables enable you to see how changing one or two variables affect a certain metric or 
value. For example, you may want to know what happens to net income if revenue increase 

by 5%, 7.5%, 10% and so on.  
 
Data tables provide a shortcut for calculating multiple results in one operation and a way to 

view and compare the results of all the different variations together on your worksheet. 
 

Single-variable data table 
 
We will create a one-variable data table using an example. In this example, we are going to 

figure out what our mortgage payment would be at different interest rates. Cells B1:B4 are 
input cells and cell B5 is the mortgage payment based on a formula using the inputs in cells 

B1:B4. To create the data table: 
  

1. Put a list of different interest rates in Cells D3:D7. Excel will use these rates as 

substitutes for the interest rate in cell B2 once we create the data table. 
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2. In cell E2 we will reference the payment formula in B5. This reference must be one row 
up and to the right of the substitute value list you just created.  

 

 
 

3. Select the entire data table range, including the cell reference to the payment formula. 
 

 
 

4. On the Data tab click the What-If Analysis command button and then click Data 

Table. A Data Table dialog box will appear. Since this is a single variable data table, 
only the column input cell will be populated. The column input cell is the interest rate in 
cell B2. 
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5. After you click Ok, your data table will be populated. 
 

 
 

Multi-variable data table 

 

Like the one-variable data table, we’ll create a two-variable data table using an example. In 
this example, we are going to figure out what our mortgage payment would be at different 

interest rates and different mortgage amounts. To create the data table:  
 

1. Put a list of different interest rates in cells E2:I2 and a list of different mortgage 

amounts in cells D3:D7. Excel will use these rates as substitutes for the interest rate in 
cell B2 and mortgage amount in cell B1 once we create the data table. 

 

 
 

2. In cell D2 we will reference the payment formula in B5. This reference must be in the 

top right corner of the data table. 
 

 
 

3. Select the entire data table range, including the cell reference to the payment formula. 
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4. On the Data tab click the What-If Analysis command button and then click Data 
Table. A Data Table dialog box will appear. The row input cell is the interest rate in cell 

B2. The column input cell is the mortgage amount in cell B1. 
 

 
 

5. After you click Ok your data table will be populated. 
 

 
 

 

Goal Seek 
 

Goal Seek enables you to find out what it takes to reach a predetermined objective, such as 
how many units you need to sell to reach $10 million in revenue this year. Excel can help you 
find the input values necessary to achieve those results. 

 
To use the Goal Seek command: 

 
1. Select the cell whose value you want to change. When you use Goal Seek, you must 

select a cell that already contains a formula. In our example, we'll select cell B3 

because that contains the revenue formula. 
 

 
 

2. From the Data tab, click the What-If Analysis command, then select Goal Seek from 
the drop-down menu. A Goal Seek dialog box will appear with three fields: 
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a. Set Cell: The cell that will contain the desired result. In our example, B3. 

b. To Value: The desired result. In our example that is $10,000,000 

c. By changing cell: The cell that Excel should change to get to your desired 
result. In our example that will be B1 (Units Sold). 

 

 
 

3. Click OK. A Goal Seek Status dialog box will appear and tell you if Goal Seek was able 
to find a solution. 
 

 
 


