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PivotTables
This multi-part course is designed to provide compact explanations and relevant examples of the essential 

elements of mastering Microsoft® Excel® — a program that enables an array of mathematical and analytical 

solutions from simple formulas to complex PivotTable Reports that condense thousands of rows of data into 

meaningful information.

In this course, you’ll go beyond basic “how-to” material and “step-by-step” instructions to best practices for 

designing professional-grade workbooks complete with numbers, text, formulas and functions.

Prerequisites

To fully benefit from this course, it’s important for participants to: 

 • Be comfortable inputting data and writing simple formulas.

 • Understand absolute and relative cell references.

 • Be familiar with basic functions SUM, IF, AVERAGE.

 • Have built basic PivotTable reports.

Learning objectives

At the end of this course, you’ll be able to:

 • Implement essential shortcuts, conditional formatting, functions and tables to build sheets quickly.

 • Design and configure form controls to automate your workbook.

 • Utilize data analysis and data mining tools.

 • Develop effective charts and graphs.

Notes to readers

Throughout this workbook, you’ll see study aids that will help you master Microsoft® Excel®.

 • SkillSteps: The fundamental steps to get to a feature

 • SkillTips: Special guidelines for becoming a power user

 • Strategies: Techniques for mastering Microsoft® Excel®

SKILLTIP

This workbook was written using Microsoft® Excel® for Office 365® MSO Version 1904 Build 11601.20144 

Click-to-Run Monthly Channel
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Master the Basics of PivotTable Reports

SkillStep — To create a PivotTable: Table Tools > Design > Tools > Summarize with PivotTable.

Pivotology: Best practices

If you’re not a “pivotologist” you might be building workbooks and spending too much time on formulas and 

formatting. This module presumes you are familiar with the fundamentals of PivotTable reports:

 • Always start with a Table (not a “laddered” report or a crosstab report).

 • Build helper columns.

 • Build your workbooks in layers keeping your raw data on one sheet, reports on separate sheets (staging 

layer) and your dashboard (presentation layer) on another.

How to start with good data

To summarize data into a PivotTable report, you must start with good tabular data. 
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How to create a table from raw data

From there, you must format it as a Table. 

A PivotTable Report is a summary of the data that is in your table. You can drag and drop the fields from your 

table in either…

 • The Rows drop zone

 • The Columns drop zone

 • The Values drop zone

 • The Filters drop zone

For example, suppose you 

want to total the salary 

by region: 
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How to summarize data in a report

How to add a PivotTable chart

From there, you could easily build a chart:
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How to add a slicer

You can even add a slicer.

You can group your data, filter your data and summarize your data in nearly limitless combinations. 

How to Build a Dashboard

Building a dashboard

You can build a dashboard from your slicer and chart.
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How to add helper columns

Why you must refresh your data

Now you can count hires by day of the week:
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And do a chart…and move it to your dashboard…

Using big data for reports
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How to create report subtotals

You can do percent of column totals. You can do percent of parent rows.
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How to create custom groupings

How to group data and modify sorting
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How to work with bad data

Sometimes you must fix data that’s not tabular.

This is what you need: 

How to create a tabular report
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Techniques That Apply to Financial Reports

Calculated items

There are times when you need to create calculated items for your report — rather than build your formulas 

outside the report. 

SKILLTIP

Always highlight a row item before building a formula based on that row item. If you select a value, 

Custom Item is not available. 

 

Calculated Items and Calculated Fields 

are created from the Fields, Items, 

& Sets button on the Analyze tab of 

the ribbon.

SkillStep — To create a Calculated Item: 

PivotTable Tools > Analyze > Calculations > Fields, Items, & Sets > Calculated Item.
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Calculated fields

In addition to needing calculated items, there are times when you ‘ll need to develop custom value calculations. 

For example, perhaps you want to compare Planned Expenses to Actual Expenses. To calculate the variance in 

a cell, you would write a formula such as: Variance = Planned Expense – Actual Expense. However, to do that in a 

PivotTable report, you’ll need to create a Calculated Field.

SkillStep — To create a Calculated Field: 

PivotTable Tools > Analyze > Calculations > Fields, Items, & Sets > Calculated Field.

Calculated fields are added to the Values drop zone and the Value area of your PivotTable report. They can also 

be enhanced with custom number formats — so that positive variances display a triangle pointing up ▲ and 

negative variances display a triangle pointing down ▼. 

SKILLTIP

Experiment with different custom number formats. To append symbols to positive (▲) and negative 

values (▼), use:  _($* #,##0_)▲;_($* (#,##0)▼;_($* “-”_);_(@_).
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Formatting a Financial Report

Calculating custom items in a financial report

Dividing a multi-year report into separate annual reports
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How to Calculate Year-on-Year Variations in Expenses

And report on it by year:
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How to Consolidate Multiple Datasets  
Into a Single PivotTable Report
There are times you will need to combine separate sheets into a single PivotTable report. To do so, you ‘ll need to 

use the PivotTable and PivotChart Wizard. 

SkillStep — To launch the PivotTable and PivotChart Wizard: ALT, D, P

SKILLTIP

Rather than trying to remember ALT, D, P, you can add the Wizard to the Ribbon or the QAT. You’ll find it 

under “Commands Not in the Ribbon.”
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When do I need this Wizard?

Let’s say you’ve inherited a workbook whose data is divided into many tabs — yearly, monthly or weekly — and 

you need to create a single report. 

With the Wizard, you can select the three different data ranges on the three tabs and label each using the 

Wizard’s page field option.
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When you finish combining the data, the report will have merged all your tab values. 

SKILLTIP

 If you need to modify the data ranges for your consolidated report, click in the report and re-press ALT, 

D, P to launch the Wizard. (Click the “< Back” button to revisit Step 2b of 3 in the Wizard to revise your 

report components.)

SKILLTIP

The PivotTable PivotChart Wizard is also useful to “reverse engineer” a table from cross-tabular data. 

To do so, consolidate the data into a report, then double-click on the grand total to generate the table. 

(Note: See Part 1 of this series for more details on double-clicking summarized values in a PivotTable report.)
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SKILLTIP

 Power Query, a newer tool developed by Microsoft®, provides a wider array of commands that allow 

you to merge multiple datasets into a single report. For this example, the PivotTable PivotChart Wizard 

is enough.

Understanding filter pages and their usage in a consolidation
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The Consolidation Report

The secret to drilling down into a consolidation

Relationships

You can also build reports from multiple tables that you link together with relationships. Relationships can be 

built with the Relationships button on the Data tab… or via Power Pivot.
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The Fundamentals of Power Pivot

Power Pivot is the intersection of two power programs: Excel® and Access®.

What are the benefits of learning and using Power Pivot?

The benefits of using Power Pivot begin with being able to assemble massive amounts of Data – 100s of millions 

of rows of data — all in Excel® (technically Power Pivot).

The data your data can come from:

 • Access® tables

 • Excel® files

 • Text files

 • SQL servers

 • The web

…and, if necessary, transformed by Power Query.

Power Pivot supports multiple tables and relationships. With relationships, VLOOKUP becomes a thing of 

the past.

While basic PivotTables have moderately useful formulas, Power Pivot utilizes Data Analysis Expressions (DAX) 

for writing formulas. 

Conveniently, the Power Pivot interface looks like Excel®…complete with Formula bar, Ribbon and Status bar. 
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In short, with Power Pivot, you can:

 • Work with massive amounts of data from many different sources.

 • Combine the data together using relationships.

 • Analyze the data with powerful DAX measures. 

 • Summarize the results with a familiar PivotTable interface. 

The reasons you need Power Pivot and caveats

Here’s a summary of the benefits and drawbacks to Power Pivot. As you’ll see, the benefits outweigh 

the drawbacks.

ADVANTAGES

1.  You can analyze massive amounts.

2.  You can pull data from multiple sources.

3.  You can link all your data sources together.

4. You can incorporate the powerful DAX (Data 

Analysis Expressions).

5.  You still have the familiar Excel® 

PivotTable interface.

6.  You can build visually rich dashboards from 

the data.

DISADVANTAGES

1. Unlike standard PivotTable grouping, grouping date fields requires a special table of dates with 

permutations of dates.

2.  There’s no editing of data (which could be an advantage!). You can’t’ change data in the Power Pivot 

window. The display may look like cells, but you can’t type anything. If you want to modify data, you 

must go back to the source and re-import the data — unless it’s a linked table. If it’s a linked data source, 

you can just refresh the link. The good news is this maintains the integrity of the data and reduces 

human error.

3.  There’s no backwards compatibility. When you open an old Power Pivot 2010 model in Excel® 2013 or 

2016, the model is converted…and it’s a one-way conversion. 

4. Show Report Filter Pages not available! If you love splitting data using a PivotTable report filter, the 

command is unavailable to Power Pivot PivotTables.

SKILLTIP

Excel® 2013 Power Pivot is compatible with Excel® 2016 Power Pivot… with the exception that new DAX 

functions that come with Power Pivot 2016.
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Power Pivot’s Columnar Data Model

The primary reason for using Power Pivot is that Power Pivot’s Data Model does not store imported tables in an 

Excel® sheet or in a table format. Power Pivot’s Data Model has a behind-the-scenes Columnar Database where 

all data is stored.

When you import a table into the Data Model, each field in the imported table is stored separately with a unique 

list of values for the field. There is a sort of “map” that allows the database to reconstruct the original table and 

all the records.

The Columnar Database is a behind-the-scenes, In-Memory (RAM) Database.

The number of unique values in any one field determines the amount of RAM that is used. The Columnar 

Database allows you to import large data sets (millions of rows) that would not fit in an Excel® sheet. You can 

safely handle 100 million rows. The columnar database stores data efficiently and can dramatically reduce 

file size.

In comparison to a standard dataset, a Columnar Data Model only stores one copy of each unique value. 
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Synonyms for a columnar database:

 • Columnar Database

 • Data Model

 • Power Pivot Database stored in an 

Excel® Workbook 

 • Power Pivot xVelocity engine

 • Power Pivot engine

 • xVelocity analytics engine

 • VertiPaq

Linking tables together with Power Pivot

How to use Diagram View

Building a PivotTable with Power Pivot
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Notes
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