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About this document
These materials are part of the Multimedia Training Kit (MMTK). The MMTK provides an
integrated set of multimedia training materials and resources to support community media,
community multimedia centres, telecentres, and other initiatives using information and
communications technologies (ICTs) to empower communities and support development
work.

Copyright information
This unit is made available under the Creative Commons Attribution-ShareAlike License. To
find out how you may use these materials please read the copyright statement included with
this unit or see
http://creativecommons.org/licenses/by-sa/1.0/legalcode.
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Introduction
In this unit you will learn how to develop slide presentations with OpenOffice.org Impress, the
slide presentation component of the OpenOffice.org suite of office productivity tools. We will
approach the task by breaking it down into the following sections:

• Getting started
• Adding, editing and changing text and objects
• Working with templates and master slides
• Preparing for your presentation

Getting started

Creating a presentation

When you launch OOo Impress, the AutoPilot Presentation dialogue box appears with a
choice of options:

Choose Empty presentation to create a new slide show from scratch.

Choose Create to start work on the new presentation.

There are more options for the creation of a new slide show that you can explore in the 2nd

and 3rd screens of the AutoPilot. We will look at these later in the unit.
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You need to decide which kind of slide to begin your new presentation with. OOo Impress
offers you the following AutoLayout options.

Choose an AutoLayout and click on the OK button.

Your new slide clearly indicates the spaces for adding content. Simply point and click to add
text to your slide.

Saving your work

Choose File > Save to save this presentation with a file name on your computer.

Use the Save As dialogue box to:

• Choose a folder to save your work in
• Give the file a name 
• Select a file type from the drop-down list (the default type is the OpenOffice.org Impress

presentation format)

Closing the file

Choose File > Close to close the file.
 
If you do not have any other files open, this action will also exit OOo Impress.
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Opening an existing file 

Launch OOo Impress.

This time choose Open existing presentation from the choices in the AutoPilot dialogue box.

The name of the presentation file you created earlier will appear in a list. 

Highlight the correct file name and click on the Create button.

The presentation will open.

Views

OOo Impress offers you the following options on the right-hand side of the screen for viewing
your slide show:

Drawing view –  for editing the text and graphical elements of a single slide
Outline view  - for editing text within a structured (levelled) view of all your content 
Slides view  - for getting an overview of all slides in the presentation
Notes view - for adding presenter's notes to each slide
Handouts view - for arranging slide content for printing into handouts
Start slide show  - view your slides as a presentation using the full-screen

Once a presentation includes a number of slides, it becomes easier to work with them by
finding the most appropriate view of the presentation for the work you are doing.

Choosing a different View for your work will make your slides look different, but doesn't
actually have any effect on the slide or its content. You are just taking a different perspective
on the slide – seeing it from a different angle. Some views allow you to see more, and others
less. 

The Drawing View is much the same as the view that your audience will have of the slides
when you do the presentation. 

The Slides View allows you to see all your slides at once – very useful for re-ordering,
duplicating etc.

The Notes View allows you to see both the slide content and any accompanying notes which
are for the presenter's eyes only.

The Outline View displays the content of your whole presentation in a single page, enabling
you to reorder slides and edit slide titles and headings without having to move through the
slides one-by-one.

Adding new slides

In Drawing or Notes view use the fly-out Presentation menu to insert new slides, modify slide
design and layout, and copy existing slides. (If this menu does not appear automatically on
your screen, choose View > Toolbars > Presentation).
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Insert Slide... will add a new slide after the slide currently in view

Modify Slide Layout... gives you the AutoLayout screen to choose
a different layout to apply to the slide

Slide Design... gives you a selection of any pre-defined slide
designs to choose from

Duplicate Slide creates an exact copy of the slide in view

Expand slide creates a new slide from every top-level outline
(bullet) point in the selected slide. The outline text becomes the title
of the new slide.

Moving between slides

To move between slides click on the slide tabs at the bottom of the screen: 

Adding, editing and changing text and objects

Text

Adding content to the text and graphics areas of slides is a point and click operation.
Single click, and start typing to add content to the text area.

Laying out ideas on a slide for presentation to a group of people is a skill which requires you to
understand more than just the technical operations of the software you are using. If the slides
are going to really work at supporting the more detailed (and perhaps complex) information
that the presenter is dealing with, they need to be clear, direct and easy to take in. 
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Bulleted lists

Bulleted lists of ideas have become the style of choice for arranging ideas in text on a slide.
OOo Impress calls these lists outlines as they allow you to structure your ideas into a
hierarchical form. Not only does the list distil complex concepts into more digestible items, it
also allows you to take ideas through levels of detail, so that a main item in the list, can itself
be broken down into a more detailed list of items. Getting to grips with writing an outline, or
bulleted list is a central part of writing successful slide presentations.

Using different levels within a bulleted list can really help you to structure the ideas you are
presenting.

OOo Impress starts all bulleted lists at the highest level by default. 

To change the level of an item in a bulleted list before or during typing it, use the arrow keys
on the  formatting tool bar:

Graphics

If you want to include graphics in a slide, choose a slide AutoLayout which includes a
graphics area.

To add graphics, double click on the graphics area in the slide. 
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Choose your graphics file using the dialogue box which appears.
 
You can manipulate the image in a number of ways:

Right click on the graphic to bring up a
context sensitive menu which allows
you to change the size and layout of the
graphic: 

Use the graphics tool bar for more advanced functions such as changing the brightness and
contrast of the image. 
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Charts and graphs

To add a chart or graph to a slide, you need to select an AutoLayout from the AutoPilot
dialogue box which includes a chart area.

Double click on this area to begin working on your chart. There are 3 areas to edit:

• The main title – simply click and edit the
text 

• The data series – double click to work
through the tabs of the dialogue box

• The legend – double click to work through
the tabs of the dialogue box

To work on the figures in the chart:

• Click once to edit the chart area
• Choose Chart Data from the right-click

menu

The table which appears is much like any
spreadsheet and allows you to add and edit
figures.

When you have completed your data-entry 
and have clicked to close the window, you are
prompted to agree to apply the changes you
have made.

Choose yes to see the data changes incorporated into the chart.
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Templates and master slides

Templates

A template is a "model" slide containing a set of fixed design elements which can be applied to
any presentation. For example, your organization may create a template which includes the
organization's logo and web address, and which uses particular colours and fonts. Each time
a staff member needs to develop a slide presentation they can take the standard template as
their starting point.  

Using templates as a starting point for slide presentations enables us to create a feeling of
continuity within and between slide presentations. By basing all the slides in a presentation on
the same template OOo Impress also saves us having to add in those elements afresh with
each new slide.

If you indicate at the outset that you want the slides to be based on a given template, each
new slide will include the relevant design features of that template.

To use a template for a new presentation

• Choose New > Presentation to launch the AutoPilot.
• Select From Template under Type.
• Select the template you want to use from the list.
• Click on the Create button.

To create a template from an existing presentation:

• Open the presentation in OOo Impress. 
• Choose File > Templates > Save.
• Give the template a name.
• If it is not already highlighted, click on Presentations in the list of categories to highlight it.
• Click on the OK button.
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Master slides

A master slide contains the default text formatting style for the title, bulleted items, and the
background design of all slides in the current slide presentation. 

• If you want to make changes to the design of a single slide, make them in standard
Drawing view.

• If you want to apply changes to every slide in a presentation (for example, changing the
font colour or adding a footer with your organization's web address to each slide), instead
of making the change one slide at a time, make the change on the master slide and it will
be reflected on every slide in the presentation.

To edit the master slide 

• Choose View > Master 
• Choose the type of master view you wish to edit: Drawing, Title, Notes or Handout.

The master slide displays the layout and design elements of your presentation, not its content.

• Make any changes you require to the master slide; these will be reflected on all the slides
in your presentation.

• When you have made the changes, switch back to the contents of your presentation by
choosing View > Slide.

Preparing for your presentation
Having developed the slides for your presentation, you can turn your attention to preparing the
delivery of the slide show.

You need to think about:

• What your presentation will look like on screen
• The broader detail you will talk about, as outlined in the bullet points in each slide
• The handouts that you will distribute amongst the audience

Slide show effects – animation and transition

A slide show is about conveying your ideas to an audience in the most effective way you can.
OOo Impress offers you various options for displaying the content on each slide during your
presentation.
 
You can for instance animate the transition from one slide to the next.

Similarly you can animate the appearance of individual items of content on the slides.

Animation options range from having a slide, or each item in an outline flying onto the screen,
to swirling onto the screen, or emerging from a series of dots.

Deciding which animation effect to use starts with exploring the options available.

Choose Slide Show > Slide Transition
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Choose a category of effect from a drop-
down list. 

Pick an effect.

Open the preview window by clicking on the
preview button : 

Click on the assign button  ; the preview

screen will show you how the animation looks
with your slide.

Animating items within a slide follows the same logic:

Choose Slide Show > Effects
In this instance there are more options for the
way that text is handled, also the order in
which different elements of the slide are
animated.

For the rest this dialogue box works as the
one above. Use the assign button to add the
animation and the preview button to see how
the animation works with your content.

Presenting your slide show 

Delivering the slide show can be as simple as clicking on the Slide Show icon  and then
just manually making your way through the presentation by clicking from one slide to the next.
If you have animated your slides to display one bullet point at a time, then clicking will take you
from one bullet point to the next. 
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This is the default way that OOo Impress will handle your slide show, but there are of course
other options. Choose Slide Show > Slide Show Settings to see these.

Automating your slide show

OOo Impress can automatically move from one slide to the next (no need for the presenter to
click through). This requires that you rehearse and record the timings of the slide show in
advance, so that you can set the time that each slide should be displayed for. 

To rehearse and record the timings of the presentation:

• Choose the Slide View for working with your presentation 
• Start the slide show by clicking on the Rehearse Timings icon 

• Notice how a timer has appeared in the bottom left-hand corner of the screen. 
• As you go through your presentation, click on the timer when you want to move to the next

slide.
• When you have completed the presentation, the timings for each slide are displayed in the

Object Toolbar, where they can also be edited.
• To run the slide show automatically with these timings, return to the Slide show settings

dialogue box above and choose Auto from the Type section. 
• The slide show will start and move through each slide according to the timings that you

recorded.

Printing

You can print out your OOo Impress presentation in a number of different formats: just the
slides, the slides with notes, etc. To select the format 

• Choose File > Print 
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• Click on the Options button.

Drawing prints out each slide on a separate full page.

Notes prints each slide and any accompanying notes on a separate page.

Handouts prints a number of slides together on a page (use Handouts View to control the
appearance of the printed handouts).

Outline prints the Outline view of your presentation. 
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